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Введение

Специалистам известны коммерческие про-

граммы автоматизированного проектирова-

ния в электронике, включающие в себя и воз-

можности моделирования, такие как OrCAD,

Proteus, Micro-Cap, Multisim (Electronics

Workbench). Их возможности, приемы рабо-

ты в них описаны в литературе, в том числе

и русскоязычной. К сожалению, легальные

версии этих программ недоступны для мно-

гих предприятий, не говоря уже об отдель-

ных пользователях. Фирма Linear Technology

свободно распространяет программу моде-

лирования LTSpice/SwitcherCAD III, имею-

щую более скромные, но вполне достаточ-

ные для большинства известных видов ана-

лиза возможности.

Программа включает в себя самую полную

и регулярно обновляемую библиотеку ком-

понентов фирмы Linear Technology, имею-

щих Spice-модели, в том числе импульсных

регуляторов и контроллеров, и незаменима

для разработчиков, предпочитающих про-

дукцию Linear Technology. Кстати сказать, мо-

дели импульсных регуляторов и контролле-

ров практически отсутствуют в других про-

граммах.

К счастью, для пользователей программы

ее возможности не исчерпываются модели-

рованием схем с применением только изде-

лий фирмы-разработчика, и ее с успехом

применяют те, кто специализируется на ана-

логовой схемотехнике.

SwitcherCAD III — это третье поколение

программы моделирования импульсных ре-

гуляторов компании Linear Technology. Про-

грамма состоит из эффективного Spice-симу-

лятора смешанного моделирования, включа-

ющего Spice-устройства с новыми свойствами

для макромоделирования импульсных источ-

ников питания (ИИП) на основе контролле-

ров и регуляторов. Программа рисования ие-

рархических схем позволяет пользователю

редактировать встроенные примеры схем или

создавать новые схемы. В окне графиков ото-

бражаются результаты моделирования с воз-

можностью дальнейшего анализа получен-

ных данных. Имеется встроенная база инте-

гральных схем Linear Technology и многих

пассивных компонентов. В одной програм-

ме объединены база компонентов, редакти-

рование схем, управление моделированием

и анализ графиков.

На рис. 1 показан экран программы.

Установка программы

SwitcherCAD III и руководство пользова-

теля [1] можно загрузить с сайта Linear Tech-

nology. Прямая ссылка на файл установки —

http://ltspice.linear.com/software/swcadiii.exe.

Файл swcadiii.exe — это самораспаковываю-

щийся архив для установки SwitcherCAD III.

Программа часто обновляется. После пер-

воначальной установки SwitcherCAD III мож-

но использовать команду Tools>Sync Release

встроенного меню, которая изменит про-

грамму до текущей версии, если есть доступ

в Интернет. Процесс обновления сначала за-

грузит мастер-файл с сайта LTC, содержащий

размер и контрольную сумму каждого фай-

ла. Если какой-то файл отсутствует или от-

личается по размеру либо контрольной сум-

ме, содержащейся в мастер-файле, он будет

автоматически обновлен. Компоненты базы

данных в процессе модернизации будут до-

бавлены так, как будто вы добавили собст-

венные устройства, то есть дополнения не бу-

дут потеряны, как будто утилита автомати-

ческого обновления и не использовалась.

Файл changelog.txt в каталоге с установлен-

ной программой содержит информацию

о всех модернизациях программы.

Режимы работы

Краткий обзор

Для SwitcherCAD III возможны два основ-

ных режима использования симулятора:

1. Использование программы как универсаль-

ной программы рисования схем с интегри-

рованным симулятором. Команда меню

File>New и File>Open (файлы типа asc.).

2. Загрузка в симулятор списка соединений

(netlist), созданного вручную, или списка

соединений, сгенерированного различны-

ми инструментами создания схем. Коман-

да меню File>Open (файлы типа cir.).

В статье описаны возможности бесплатной программы схемотехническо$

го моделирования SwitcherCAD III и приемы работы в ней.

Программа схемотехнического 

моделирования SwitcherCAD III

Рис. 1. Экран программы
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LTSpice/SwitcherCAD III предназначен для

использования в качестве универсальной про-

граммы рисования схем с интегрированным

Spice-симулятором. Вы рисуете свою ориги-

нальную схему (или открываете имеющую-

ся схему из примеров) и наблюдаете ее рабо-

ту в симуляторе. В процессе разработки вно-

сите изменения, пока при моделировании не

будет достигнуто желаемое поведение схемы.

Более ранние версии LTSpice/SwitcherCAD III

включали в себя синтезатор, пытавшийся со-

здавать совершенный проект ИИП по специ-

фикации пользователя, но теперь такой ре-

жим работы исключен.

В результате схема преобразуется в тексто-

вый список соединений, который запускается

в симулятор. Если обычно список соединений

извлекается из графической схемы, выполнен-

ной в LTSpice/SwitcherCAD III, импортирован-

ный список соединений может быть исполь-

зован непосредственно, без схемы. Несколько

примеров такого использования: 
•• Программа синтеза фильтров от Linear

Technology's FilterCAD может синтезиро-

вать список соединений для LTSpice, что-

бы моделировать фильтр в частотной или

временной области.
•• Осуществляется более простое эталонное

тестирование LTSpice в сравнении с други-

ми Spice-программами.
•• Профессионалы уже знакомы со Spice-си-

муляторами, работающими непосредствен-

но с текстовым списком соединений, по-

скольку в старых системах рисование схемы

не было объединено со Spice-симулятором.

Примеры схем

Есть несколько ресурсов с примерами схем

для LTSpice/SwitcherCAD III, поставляемых

с программой. Как правило, они установле-

ны в каталоге C:\Program Files\LTC\SwCADIII\

examples\Educational, содержащем множест-

во примеров Spice-моделирования для неком-

мерческого использования, они демонстри-

руют различные виды анализа, методы и воз-

можности программы. В каталоге C:\Program

Files\LTC\SwCADIII\examples\jigs есть пример

моделирования для каждого устройства Linear

Technology, имеющего макромодель в LTSpice/

SwitcherCAD III.

По адресу http://www.kit-e.ru/assets/My_

Examples.zip размещена папка со схемами уст-

ройств, на примере которых демонстрируют-

ся некоторые возможности программы, и биб-

лиотеками входящих в них компонентов.

Внешне сгенерированные 

списки соединений

Используя программу, можно открыть

списки соединений, созданные вручную или

другими программами рисования схем. Эти

файлы обычно имеют в названии известные

расширения .cir, .but, .net или .sp. Ранее пе-

речислены примеры использования импор-

тированных (внешне сгенерированных)

списков соединений. ASCII-редактор, ис-

пользуемый для файлов списка соединений,

поддерживает неограниченный размер фай-

ла и неограниченное количество команд

Undo/Redo. Для изменения цветов, исполь-

зуемых в ASCII-редакторе, применяется ко-

манда меню Tool>Color Preferences.

Отчет о потерях

По результатам TRAN-анализа (анализа пе-

реходного процесса) с модификатором steady

можно получить отчет о потерях в преобра-

зователе. По окончании моделирования от-

чет о потерях может быть отображен на схе-

ме в виде блока текста комментария, как по-

казано на рис. 2.

Эффективность преобразователя определя-

ется следующим образом. Чтобы идентифи-

цировать вход и выход, требуется хотя бы по

одному источнику напряжения и источнику

тока. По умолчанию источник напряжения

является входным источником питания, а ис-

точник тока — выходной нагрузкой. Для ис-

пользования в качестве нагрузки программа

имеет два специфических компонента — ис-

точника тока, точнее, потребителя тока: load

и load2. Можно использовать в качестве на-

грузки резистор, обозначив его Rload. Схему

запускают до тех пор, пока при моделирова-

нии не будет обнаружен установившийся ре-

жим работы. Для этого необходимо, чтобы ма-

кромодели ИИП содержали информацию

о том, как обнаруживать установившийся ре-

жим. Макромодели импульсных регуляторов

LTC имеют такую информацию. Обычно ус-

тановившийся режим можно обнаружить, ког-

да отмечено, что ток усилителя ошибки, ус-

редненный по циклу переключения, умень-

шается до малой величины в нескольких

циклах. Тогда энергия в каждой реактивнос-

ти на фронте импульса вычисляется и запо-

минается, а моделирование продолжают еще

до десяти тактов, интегрируя потери в каждом

устройстве. На фронте последнего импульса

энергия, сохраненная в каждой реактивности,

снова запоминается и моделирование останав-

ливается. Информация о потерях представля-

www.kit$e.ru

Рис. 2. Окно схемы с отчетом о потерях

Таблица 1. Ключи командной строки

Ускорение работы WINE (Linux)

Эквивалент команды меню Tools>Sync Release

Выполнение процесса деинсталляции

Позволяет иметь в макромодели МОП-транзистора до 7 узлов

Старт моделирования схемы из командной строки без нажатия кнопки Run

Сохранение пользовательских установок, MRU и т. д. в регистре вместо файла %WINDIR%\scad3.ini 

Преобразование схемы в формат PCBnetlist 

Предотвращение использования работы WINE (Linux) 

Преобразование схемы в список соединений

Синоним для – big

Преобразование бинарного .raw файла в формат  Fast Access

Шифрование библиотеки моделей. При желании можно сделать так, чтобы пользователи третьей стороны 
не видели деталей библиотеки. Не используется в моделях  Linear Technology Corporation

Старт в максимальном окне

Управление пакетным режимом. Например “scad3.exe – b deck.cir” сохранит данные в файле deck.raw

$wine

$web update

$uninstall

$SOI

$Run  

$registry

$PCBnetlist

$nowine

$netlist

$max

$FastAccess

$encrypt

$big

$b

Использование ASCII .raw файлов. Серьезно ухудшается работа программы$ascii

ОписаниеФлаг
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ется как отношение выходной мощности в на-

грузке к мощности входного источника на-

пряжения после коррекции по изменению

в энергии, сохраненной в реактивностях. Так

как потери в каждом устройстве также изве-

стны, можно определить, насколько контроль-

ная сумма энергии близка к нулю.

Можно рассчитать эффективность спроек-

тированной схемы ИИП, используя команду

Stop simulating if steady state is detected («Оста-

новка моделирования по обнаружению уста-

новившегося режима») в диалоговом окне Edit

Simulation Command. После моделирования

используется команда меню View>Efficiency

Report для вывода сообщения о потерях.

Автоматическое обнаружение установив-

шегося режима работает не всегда. Иногда

критерии для обнаружения установившего-

ся режима слишком строги, а порой и слиш-

ком расплывчаты. Тогда следует подобрать

параметр выбора sstol или просто в интерак-

тивном режиме установить пределы для рас-

чета потерь.

Ключи командной строки

В таблице 1 перечислены ключи команд-

ной строки, понятные и исполняемые LTSpice

(scad3.exe).

Рисование схемы

Основы редактирования схемы

Чтобы создать новые схемы или изменить

предоставленные примеры схем, использует-

ся программа рисования. Размер схемы и глу-

бина иерархии ограничены только ресурса-

ми компьютера. Создание новой схемы начи-

нается с команды меню File->New Schematic,

а ранее созданная схема или встроенный при-

мер открываются командой File->Open.

На рис. 3 показан открытый файл проекта

с меню редактирования Edit.

Программа включает в себя около 800 ком-

понентов. Это большинство интегральных

схем для источников питания, операционных

усилителей, компараторов компании LTC

и много устройств общего назначения. Мож-

но создать и собственные символы компо-

нентов для устройств, которые вам нужно

импортировать в программу.

В отличие от многих программ рисования

схем, эта была написана специально для уп-

равления Spice-моделированием. При нажа-

тии на объект по умолчанию отображается

график напряжения в цепи или тока через

компонент без выбора объекта для редакти-

рования или какого-либо редактирования по-

ведения, отменяющего только что выполнен-

ное моделирование. Для перемещения, зер-

кального отражения, вращения, рисования

или удаления объектов сначала следует вы-

брать соответствующую команду. После это-

го можно выбрать объект нажатием на него.

Можно выбрать несколько объектов, обведя

их рамкой. Программа останется в режиме

перемещения, рисования или удаления, по-

ка не нажаты правая кнопка мыши или кноп-

ка Esc. При редактировании вся схема может

быть удалена или перерисована. Команды ме-

ню Edit перечислены в таблице 2.

Команды меню Edit, за исключением ко-

манд Place BUS tap и Draw, дублированы

кнопками на панели инструментов.

Графические объекты (линии, прямоуголь-

ники, окружности и дуги) не имеют электри-

ческих свойств и используются на схеме для

ввода дополнительной информации. По умол-

чанию графические объекты в схеме привяза-

ны к той же сетке, что используется для элек-

трического контакта с проводниками и выво-

Рис. 3. Окно схемы и меню Edit

Таблица 2. Команды меню Edit (редактирование)

Изменение стиля линий графических объектов

Рисование дуги на схеме

Рисование окружности

Рисование прямоугольника

Рисование линии

Нажмите на объект или начертите рамку вокруг объектов, которые следует перетянуть. 
После этого можно переместить объекты и присоединенные проводники без их разрыва в новое местоположение

Размещение объектов в  окне новой схемы, когда они уже были выбраны командой Duplicate

Перемещение объекта нажатием на него или вычерчиванием рамки вокруг объектов, которые необходимо переместить.
После этого можно переместить объекты в новое местоположение

Копирование объектов нажатием на них или вычерчиванием рамки вокруг них. Можно скопировать объект 
из одной схемы в другую, если они обе открыты в LTSpice/SwitcherCAD III. 

Начните команду копирования в окне первой схемы. Далее сделайте вторую схему активным окном и выполните Ctrl$V

Удаление объектов нажатием на них или вычерчиванием рамки вокруг них

Размещение указателя подключения к шине (линии групповой связи)

Размещение символа GROUND. Это узел “0”, обычно глобальный для схемы

Определение имени узла, предотвращающее его произвольное наименование при генерации списка соединений

Нажатием левой кнопкой мыши начинается рисование проводника. Каждое нажатие определяет новый сегмент
проводника. Нажатие на существующем сегменте проводника присоединяет новый проводник или продолжает
существующий. Нажатие правой кнопки отменяет рисование проводника. Следующее нажатие правой кнопки 

отменяет команду рисования. Можно тянуть проводники через компоненты типа резисторов. 
Автоматически будет выполнен разрыв проводника так, чтобы резистор включился в цепь последовательно

Зеркальное отражение редактируемого объекта. Соответствующая кнопка имеет серый цвет, 
когда не выбран никакой объект

Вращение редактируемого объекта на 90° по часовой стрелке. Соответствующая кнопка имеет серый цвет, 
когда не выбран никакой объект

Размещение компонента на схеме. Команда открывает диалоговое окно с базой данных компонентов. 
Это более общая форма по сравнению с командами Resistor, Capacitor, Inductor и Diode

Размещение диода

Размещение индуктивности

Размещение конденсатора

Размещение резистора

Ввод и редактирование команд моделирования

Размещение текста на схеме, который будет включен в список соединений. Это позволяет объединить схему со списком
соединений Spice. Таким путем устанавливаются режимы моделирования, подключаются файлы, содержащие модели,
определяются новые модели или используются любые другие существующие Spice-команды. Можно даже запускать

макромодель, не имеющую символа управлять макромоделью, не имея ее компонента для установки, к примеру,
строкой модели (Spice-команда начинается c “X”) в схеме, включая определение

Размещение текста на схеме. Это просто информация о схеме. Этот текст не имеет электрического воздействия на схему

Отменить удаление объекта (откат вперед)

Draw>Line Style

Draw>Arc

Draw>Circle

Draw>Rectangle

Draw>Line

Drag (F8)

Paste

Move (F7)

Duplicate (F6)

Delete (F5)

Place BUS tap

Place GND (G)

Label Net (F4)

Draw Wire (F3)

Mirror (Ctrl+E)

Rotate (Ctrl+R)

Component (F2)

Diode (D)

Inductor (L)

Capacitor (C)

Resistor (R)

SPICE Analysis

SPICE Directive (S)

Text (T)

Redo (Shift+F9)

Восстановить удаленный объект (откат назад)Undo (F9)

Выполняемая функция
Команда

(горячие клавиши)
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дами. Привязка к сетке отключается, если при

рисовании удерживать нажатой клавишу Ctrl.

Присвоение имени узлу

Каждый узел в схеме должен иметь уни-

кальное имя. Во избежание произвольно-

го именования узла в списке соединений

можно присвоить ему определенное имя.

Узел «0» — «общая земля» схемы и изобра-

жается специальным символом без имени «0».

Есть также графический символ, опреде-

ленный для узла «COM», но этот узел не име-

ет никакого специального значения. Таким

образом, это не Spice глобальное подключе-

ние и даже не глобальный узел. Просто ино-

гда удобно иметь графический символ, свя-

занный с узлом, отличающимся от «земли».

Если присвоить узлу имя, начинающееся

с символов «$G_», как, например, «$G_VDD»,

тогда этот узел является глобальным незави-

симо от иерархии схемы.

Присвоение имени узлу и определение типа

порта выполняется в диалоговом окне (рис. 4),

вызываемом по команде меню Edit>Label Net.

Можно указать, что узел — порт типа

«вход», «выход» или «двунаправленный». Эти

типы портов имеют различные изображения,

но это не имеет никакого значения для фор-

мирования списка соединений. Указание ти-

па порта делает схему более «удобочитаемой».

Глобальные узлы также изображаются с рам-

кой вокруг имени. Возможные типы портов

изображены на рис. 5.

Цвета в схеме

Команда меню Tools>Color Preferences,

вызывающая диалоговое окно регулировки

цвета (рис. 6), позволяет установить предпо-

чтительные цвета для отображения схемы.

Нажав на объект на рисунке схемы в окне или

выбрав требуемый объект из списка в про-

кручивающемся меню, можно отрегулиро-

вать цвета по своему предпочтению, пользу-

ясь «ползунками» red (красный), green (зеле-

ный) и blue (синий).

Неэлектрические графические объекты на

схеме, типа линий и окружностей, будут изо-

бражены в цвете компонентов.

Размещение новых компонентов

Некоторые часто используемые компонен-

ты типа резисторов, конденсаторов и кату-

шек индуктивности могут быть выбраны для

размещения на схеме кнопкой на панели ин-

струментов. Для большинства компонентов

используется команда меню Edit>Component

с открытием диалогового окна поиска требу-

емого устройства, показанного на рис. 7.

Программирование «горячих» клавиш

Команда меню Tools>Control Panel>Drafting

Options>Hot Keys, вызывающая диалоговое

окно (рис. 8), позволяет программировать

«горячие» клавиши для большинства команд.

Просто нажмите мышью на команду, а затем

нажмите клавишу или комбинацию клавиш,

которой требуется сопоставить команду. Что-

бы удалить «горячую» клавишу, сначала на-

жмите команду и затем клавишу Delete.

Извлечение списка соединений 

для программ проектирования 

печатных плат

По команде меню схемы Tools>Export

Netlist генерируется ASCII список соединений

для программы создания печатной платы.

Может потребоваться создание ряда компо-

нентов с соответствующим порядком сле-

дования имен выводов. Например, при им-

порте списка соединений из схемы LTSpice

в ExpressPCB нужно создать компоненты ли-

бо для LTSpice, либо для ExpressPCB, с оди-

наковым порядком следования выводов

в списках соединений. Иначе диоды в списке

соединений могут оказаться перевернутыми

или выводы транзисторов перепутанными.

Доступны следующие форматы: Accel,

Algorex, Allegro, Applicon Bravo, Applicon Leap,

Cadnetix, Calay, Calay90, CBDS, Computervi-

sion, EE Designer, ExpressPCB, Intergraph,

Mentor, Multiwire, PADS, Scicards, Tango,

Telesis, Vectron и Wire List.

Редактирование компонентов

Компоненты могут быть отредактирова-

ны двумя или тремя различными способами,

в зависимости от типа компонента.

Редактирование видимых атрибутов

Видимые непосредственно на поле схемы

атрибуты можно отредактировать указани-

ем на них мышью с последующим нажатием

ее правой кнопки. Курсор мыши превратит-

www.kit$e.ru

Рис. 4. Присвоение имени узлу

Рис. 5. Типы портов

Рис. 6. Редактирование цвета

Рис. 7. Выбор символа компонента

Рис. 8. Программирование «горячих» клавиш

Рис. 9. Редактирование видимых атрибутов
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ся в окно вставки текста, показанное на рис. 9.

Это удобный способ изменения значения па-

раметра компонента.

Специальные редакторы компонентов

Многие типы компонентов, такие как ре-

зисторы, конденсаторы, катушки индуктив-

ности, диоды, биполярные транзисторы,

МОП-транзисторы, полевые транзисторы,

независимые источники напряжения, неза-

висимые источники тока и иерархические

схемные блоки, имеют специальные редак-

торы. Эти редакторы позволяют получить

доступ к соответствующей базе данных уст-

ройств. Для использования этих редакторов

правой кнопкой мыши нажимают на тело

компонента. Диалоговое окно редактора па-

раметров индуктивности показано на рис. 10.

Полное редактирование атрибутов

Иногда желательно получить прямой до-

ступ ко всем имеющимся атрибутам компо-

нента, чтобы редактировать их содержание

и видимость. Редактор, позволяющий делать

это, можно вызвать, если поместить курсор

на компонент, нажать сначала клавишу Ctrl

и затем — правую кнопку мыши. Появится

диалоговое окно (рис. 11), в котором показа-

ны все имеющиеся атрибуты компонента.

В каждой строке есть ячейка с индикатором

видимости признака на схеме. При рисова-

нии схемы полезно сделать видимыми пара-

зитные характеристики компонентов, такие

как, например, эквивалентное последователь-

ное сопротивление конденсатора.

Первый символ имени компонента опре-

деляет его тип. Специфический символ атри-

бута Prefix приписывается в первую позицию,

если он отличается от первого символа име-

ни, определяющего тип компонента. Атрибу-

ты Prefix и InstName в таком случае будут

разделены символом «§». Например, для ат-

рибута Prefix «M» и атрибута InstName «Q1»

имя в списке соединений будет M§Q1. Допу-

скается использовать атрибут InstName, от-

личающийся от используемого Spice для

идентификации типа устройства. Заменив

в схеме атрибут InstName для биполярного

транзистора на привычный «VT1», получим

имя компонента в списке соединений Q§VT1.

Есть три исключения из этого правила:

1. Специальный символ, джампер (jumper),

который не считается элементом схемы,

но указывает генератору списка соедине-

ний, что две цепи с разными именами эле-

ктрически связаны.

2. Символ, имеющий префикс «X», и оба оп-

ределенных атрибута — Value и Value2.

Такой компонент представлен в списке со-

единений двумя строками:

.lib <SpiceModel>

<имя> <узел1> <узел2> [...] <Value2>

Так к соответствующему символу автома-

тически подключается библиотека, содержа-

щая описание макромодели компонента.

Компилятор списка соединений удаляет дуб-

лирующиеся ссылки к библиотекам. Такие

компоненты нельзя отредактировать в листе

схемы.

3. Символ с префиксом «X», имеющий атри-

бут ModelFile. Такой компонент представ-

лен в списке соединений двумя строками:

.lib <ModelFile>

<имя> <узел1> <узел2> [...] <SpiceModel> <Value> <Value2>

<SpiceLine> <SpiceLine2>

Примечание. Здесь и далее по тексту обя-

зательный по правилам переноса строк в Spice-

выражениях знак «+», предваряющий каждую

последующую строку, сознательно опущен.

При работе с программой нарушение этого

правила недопустимо.

Этот метод используется, когда желательно

автоматически подключить файл библиотеки

и иметь возможность редактирования симво-

ла. Если атрибут символа SpiceModel сущест-

вует и имя макромодели определено в файле

<ModelFile>, тогда раскрывающийся список

имен всех макромоделей будет доступен для

редактирования символа в листе схемы.

Создание новых символов

Символы могут представлять примитив-

ное устройство типа резистора или конден-

сатора, либо макромодели с библиотекой

в отдельном файле или на странице схемы.

Для создания нового символа используется

команда меню File>New Symbol.

Графика символа компонента

Графически символ компонента изобра-

жается рядом линий, прямоугольников, ок-

ружностей и дуг. Эти объекты не имеют эле-

ктрического влияния на схему. С помощью

команды Draw>Text можно поместить в сим-

вол компонента текст, также не влияющий

на схему. Точки привязки объектов отмечены

маленькими красными кружками, показыва-

ющими, что их следует захватить для переме-

щения. Красные маркеры можно отключить

командой меню View>Mark Object Anchors.

Рис. 10. Редактор компонентов

Рис. 11. Редактор атрибутов компонентов

Рис. 12. Окно схемы в режиме рисования символа
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Окно схемы в режиме создания нового сим-

вола показано на рис. 12.

Добавление выводов

Электрическое подключение компонента

в схеме обеспечивается через выводы симво-

лов. Чтобы добавить новый вывод, исполь-

зуется команда меню Edit>Add Pin/Port,

по которой вызывается диалоговое окно ре-

дактирования свойств выводов (портов), по-

казанное на рис. 13.

Хотя Pin Label Position должна определять,

как будет показано имя вывода, в действи-

тельности TOP (сверху), BOTTOM (снизу),

LEFT (слева) и RIGHT (справа) определяют по-

ложение вывода относительно текста его име-

ни. Например, если положение вывода опре-

делено как TOP, вывод будет выше имени. Ес-

ли символ представляет собой Spice-примитив

или макромодель с библиотекой, тогда имя вы-

вода не упоминается в списке соединений и,

следовательно, не оказывает прямого электри-

ческого воздействия на схему. Однако если

символ представляет схему низшего уровня

иерархической схемы, имя вывода служит име-

нем цепи схемы более низкого уровня.

Netlist Order определяет порядок следова-

ния выводов в списке соединений для Spice.

Добавление атрибутов

Можно изменить атрибуты символа, уста-

новленные по умолчанию, используя коман-

ду меню Edit>Attributes>Edit Attributes, по ко-

торой вызывается диалоговое окно, показан-

ное на рис. 14. Наиболее важный атрибут —

Prefix. Он в основном определяет тип симво-

ла. Если символ представляет Spice-прими-

тив, он должен иметь соответствующий пре-

фикс: R для резистора, C для конденсатора, М

для МОП-транзистора и т. д. Для символа,

представленного макромоделью с определе-

нием в библиотеке, префикс должен быть X.

Атрибуты символа могут отвергаться, если

символ представляет компонент с собствен-

ной схемой. Например, для символа МОП-

транзистора атрибут Prefix «M», однако, если

конкретный транзистор представлен в виде

макромодели, то он будет иметь префикс X.

Специальная комбинация атрибутов за-

ставляет подключить необходимую библио-

теку автоматически в каждую схему, в кото-

рой используется компонент с префиксом X:
•• SpiceModel: <имя файла подключаемой

Spice-модели>;
•• Value: <значение, отображаемое на листе

схемы>;
•• Value2: <значение, отображаемое в списке

соединений>.

Value2 должно совпадать с именем макро-

модели, определенном в файле подключае-

мой модели, и может содержать дополнитель-

ные параметры макромодели. Когда символ

определен в такой манере, невозможно ре-

дактировать различные атрибуты компонен-

та в листе схемы.

Если необходимо, чтобы символ представ-

лял следующую страницу в иерархической

схеме, все атрибуты нужно оставить пусты-

ми, а тип компонента Symbol Type должен

быть изменен с Cell на Block. Не должны быть

установлены значения никаких атрибутов.

Есть атрибут символа, ModelFile, который

может быть указан. При этом используется

имя файла, включаемого в список соедине-

ний как библиотека. Пример использования

этого атрибута в файле .LTC\SwCADIII\lib\

Misc\ neobulb. Если атрибут Prefix — «X» и оп-

ределен атрибут символа SpiceModel, указы-

вающий на макромодель с файлом модели,

будет доступен ниспадающий список всех

имен макромоделей на случай редактирова-

ния символа в схеме.

Видимость атрибута

Можно редактировать видимость атри-

бутов в диалоговом окне (рис. 15), исполь-

зуя команду меню Edit>Attributes>Attribute

Window. После того, как выбран соответст-

вующий атрибут в диалоговом окне, можно

переместить его относительно символа так,

как в данный момент необходимо.

Можно изменить ориентацию текста и со-

держание атрибутов, которые уже сделаны

видимыми, в диалоговом окне (рис. 16), оно

появляется при нажатии правой кнопки мы-

ши на текст атрибута.

Иерархия

Иерархическое построение схем имеет

большие преимущества. Достаточно боль-

шие схемы могут быть нарисованы на одном

листе с ясностью изображения, характерной

для небольших схем. Просто изобразить по-

вторяющиеся узлы. Блоки схемы могут быть

включены в библиотеку для последующего

использования в другом проекте.

Правила иерархии

Для использования какой-либо схемы в ка-

честве блока в схеме высшего уровня необ-

ходимо создать символ с тем же самым име-

нем, что и у схемы блока, а затем поместить

этот символ в схему высшего уровня. Напри-

мер, есть схема высшего уровня, названная

TL431_test_pulse.asc, и есть файл другой схе-

мы с именем TL431_test.asc, которую жела-

тельно поместить в схему TL431_test_pulse.asc.

Создадим символ, названный TL431_test.asy,

и поместим его в схему TL431_test_pulse.asc.

Этот иерархический проект показан на рис. 17.

Электрические соединения между схемами

можно установить путем подсоединения про-

водников схемы более высокого уровня к вы-

водам символа блока более низкого уровня,

которые соответствуют именам узлов в схеме

низшего уровня. Как имена символов, исполь-

зованных в качестве блоков схемы, так и име-

на схем соответствующих блоков должны со-

стоять из разрешенных символов. Недопус-

тимо использование пробелов.
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Рис. 13. Редактирование выводов

Рис. 14. Редактирование атрибутов символа

Рис. 15. Редактирование видимости атрибутов символа

Рис. 16. Коррекция положения атрибута символа
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LTSpice ищет в каталоге схемы высшего

уровня схемы символов и блоков, чтобы

скомплектовать схему высшего уровня.

Для символа, создаваемого как блок схемы

низшего уровня, не должны быть определе-

ны никакие атрибуты.

Навигация в иерархии

Любой файл, открытый командой File>Open,

рассматривается как схема высшего уровня.

Можно добавить Spice-директивы к блоку

и начать моделирование, используя схему лю-

бого уровня.

Чтобы открыть схему блока, входящего

в схему более высокого уровня, сначала от-

кройте схему более высокого уровня, а затем

переместите курсор на символ вызываемого

блока. При нажатии правой кнопкой мыши

на выбранном символе отобразится диало-

говое окно (рис. 18), позволяющее открыть

схему и символ. Диалоговое окно позволяет

вводить параметры блока при их наличии.

Когда схема будет открыта, можно иссле-

довать узловые напряжения и токи в блоке.

Отметим, что необходимо включить режи-

мы Save Subcircuit Node Voltages и Save

Subcircuit Device Currents в окне Save Defaults

в Control Panel. Если подсветить цепь на схе-

ме более высокого уровня, она так же подсве-

тится в блоке нижнего уровня.

В следующей части статьи будет рассказа-

но, как отображаются результаты моделиро-

вания и какие операции можно выполнить

над ними. ■
Продолжение следует

Рис. 17. Окно программы в режиме иерархического проекта

Рис. 18. Редактирование в иерархическом проекте


