Толковый словарь по искусственному интеллекту

Словарь содержит около 550 терминов

Авторы-составители: А.Н.Аверкин, М.Г.Гаазе-Рапопорт, Д.А.Поспелов

Компьютерная версия: И.Н.Листопад, А.Б.Прокудин, Е.Н.Щербаков

Предисловие А Б В Г Д Е Ж З И Й К Л М Н О П Р C Т У Ф Х Ц Ч Ш Щ Э Ю Я

Предисловие

Специальная терминология по искусственному интеллекту и интеллектуальным системам начала формироваться в 60-е годы ХХ в. Первый этап формирования терминологии всегда отличается наличием многих синонимических терминов, которые используют различные школы и группы специалистов. На этом этапе термины быстро возникают и часть из них также быстро исчезает. К середине 70-х годов терминология в области искусственного интеллекта стала устанавливаться. Появились термины, которые признало подавляющее большинство специалистов. Все эти термины (за редким исключением) по происхождению англоязычные, так как именно в США проводились интенсивные исследования в этой области. Окончательно основная терминология закрепилась в первой половине 80-х годов. С этого периода стали издаваться словари и энциклопедические справочники по искусственному интеллекту. Трудность создания толкового словаря по искусственному интеллекту связана с междисциплинарным характером исследований в этой области. Так как в искусственном интеллекте используются методы, традиционно развиваемые в логике, психологии, лингвистике, кибернетике, дискретной математике и программировании, встречается немало терминов и других наук. Обсуждение толкового словаря показало, что имеются два крайних случая: включить в него термины, которые используются только в искусственном интеллекте и не заимствованы им из других наук, или включить в него все термины смежных с искусственным интеллектом наук, если они встречаются в работах специалистов данного направления. Составителями словаря было принято промежуточное решение, которое, конечно, тут же поставило перед ними проблему границ. Используя коллективный опыт специалистов ряда стран и СССР, составители попытались определить эту естественную границу, связав ее с частотой встречаемости заимствованных в искусственный интеллект терминов.

А

абдукция abduction
абстракция abstraction
абстракция данных data abstraction
автомат automaton
автомат бесконечный
автомат вероятностный
автомат детерминированный
автомат инициальный
автомат клеточный cellular automaton
автомат конечный finite automaton
автомат линейно-ограниченный linear-bounded automaton
автомат магазинный push-down automaton
автомат недетерминированный
автомат с переменной структурой
автомат секвенциальный sequential automaton
автомат стековый
автомат стохастический stochastic automaton
автоматизация делопроизводства office automation
автоматизированная система управления(АСУ)
АСУ предприятием (АСУП)
АСУ технологическим процессом (АСУТП)
аксиома axiom
акт речевой speech act
актант
актор actor
алгоритм algorithm
алгоритм волновой wave algorithm
алгоритм генетический genetic algorithm
анализ
анализ кластерный cluster analisys
анализ морфологический morphologic analisys
анализ протокольный protocol analysis
анализ синтаксический syntactic analysis
анализ сцен scenary analysis
анализатор синтаксический syntactic parser
аналогия analogy
анафора anaphora
аргументация argumentation
архитектура вычислительной системы
архитектура компьютера computer architecture
архитектура конвейерная pipeline architecture
архитектура параллельная parallel architecture
архитектура потоковая data flow architecture
ассоциация association
атом atom
атрибут attribute

Б

база данных data base
база данных иерархическая hierarchical data base
база данных реляционная relational data base
база данных сетевая
база данных экстенсиональная extensional data base
база знаний knowledge base
база знаний замкнутая closed knowledge base
база знаний интенсиональная intensional knowledge base
база знаний открытая open knowledge base
бектрекинг backtracking
беседа сократическая Socratic dialogue
бихейвиоризм behaviourism

В

валидация validation
верификация verification
видеопроцессор video-processor
восприятие perception
восприятие зрительной информации visual perception
восприятие тактильной информации tactile perception
выборка обучающая teaching selection
вывод inference
вывод абдуктивный abductive inference
вывод вероятностный probabilitic inference
вывод естественный common-sense inference
вывод индуктивный inductive inference
вывод интуиционисткий intuitionistic inference
вывод линейный linear inference
вывод логический logical inference
вывод на знаниях knoledge-based inference
вывод немонотонный non-monotonic inference
вывод нечеткий fuzzy inference
вывод обратный
вывод по аналогии inference by analogy
вывод правдоподобный plausible inference
вывод прямой direct inference
вызов по образцу call by pattern
высказывание proposition
высказывание атомарное atomic proposition

Г

генерация текста text generation
герменевтика hermeneutics
гиперсобытие hyper-event
гипотеза hypothesis
гипотеза компактности compactness hypothesis
глубинная структура (предложения)
грамматика
грамматика автоматная
грамматика контекстно-зависимая
грамматика контекстно-свободная
грамматика контекстно-связанная
грамматика матричная matrix grammar
грамматика неукорачивающая
грамматика падежная case grammar
грамматика сетевая network grammar
грамматика формальная formal grammar
граф graph
графика динамическая animation
графика когнитинвная cognitive graphics
графика машинная

Д

действие action
декомпозиция задач problem decomposition
денотат denotatum
дерево вывода inference tree
дерево двоичное binary tree
дерево зависимостей dependency tree
дерево решений decision tree
дерево составляющих consistency tree
дерево целей goal tree
десигнат designator
дескриптор descriptor
дефолт default
дизъюнкт
дизъюнкт боковой
дизъюнкт пустой empty clause
дизъюнкт Хорна Horn clause
дизъюнкция disjunction
дискурс discourse
диссонанс когнитивный cognitive dissonance
доказательство конструктивное constructive proof
доказательство теоремы theorem proving
домен domain
доска объявлений blackboard

Е

Ж

З

закон исключенного третьего
закон снятия двойного отрицания
знания knowledge
знания декларативные declarative knowledge
знания о предметной области problem area knowledge
знания прагматические pragmatic knowledge
знания процедурные procedural knowledge
знания эвристические heuristic knowledge
знания экспертные expert knowledge
значение атрибута attribute value
значение по умолчанию default value
зрение машинное computer vision

И

И/ИЛИ граф AND/OR graph
идентификация identification
идентификация знаний knowledge identification
извлечение знаний knowledge acquisition
ИИ-программирование AI-programming
иллокутивный потенциал
иллокуция illocution
имитация интеллектуального поведения
имитация процессов мышления
импликация implication
индукция induction
индукция неполная (эмпирическая) empirical induction
индукция полная (математическая) complete induction (mathematical)
инженер по знаниям knowledge engineer
инженерия знаний knowledge engineering
интеллект искусственный artificial intelligence
интервью interview
интерпретация interpretation
интерфейс
интерфейс естественно-языковый natural language interface
интерфейс интеллектуальный intelligent interface
искусственный мозг
источник знаний knowledge source
исчисления calculus
исчисление высказываний propositional calculus
исчисление генцена
исчисление логическое logical calculus
исчисление предикатов predicate calculus
исчисление предикатов первого порядка first order predicate calculus
исчисление пропозициональное propositional calculus
исчисление ситуационное situational calculus

Й

К

карта когнитивная cognitive map
каузация causation
квантификатор quantifier
квантификация quantification
квантор общности universal quantifier
квантор существования existential quantifier
классификация classification
кластеризация clusterization
клауза
когитология cogitology
когнитивная наука cognitive science
компонента декларативная declarative component
конкатенация concatenation
конструкт Келли Kelly construct
концепт concept
конъюнкция conjunction

Л

лингвистика вычислительная computational linguistics
лингвистика компьютерная computer linguistics
липс lips
литера literal
логика logic
логика вероятностная probabilitic logic
логика веры belief logic
логика временная temporal logic
логика второго порядка second order logic
логика двоичная
логика действий operational logic
логика деонтическая deontic logic
логика динамическая dynamic logic
логика здравого смысла common-sense logic
логика индуктивная inductive logic
логика интуиционисткая intuitionistic logic
логика каузальная causal logic
логика команд command logic
логика конструктивная constructive logic
логика математическая mathematical logic
логика многозначная multi-valued logic
логика монотонная monotonic logic
логика немонотонная non-monotonic logic
логика нечетная fuzzy logic
логика норм
логика оценок deontic logic
логика первого порядка first order logic
логика пропозициональная propositional logic
логика пространственная spatial logic
логика псевдофизическая pseudophysical logic
логика размытая fuzzy logic
логика рассуждений по умолчанию default logic
логика эпистемиологическая epistemiological logic
лок
локуция locution
"лямбда"-исчисление lambda-calculus

М

машина абстрактная abstract machine
машина баз данных data base machine
машина баз знаний knowledge base machine
машина виртуальная virtual machine
машина параллельного вывода parallel inference machine
машина Поста Post machine
машина связей connection machine
машина Тьюринга Turing machine
машина, управляемая потоком данных data flow machine
машинный интеллект
меню menu
мера правдоподобия plausibility measure
метазнание meta-knowledge
метапродукция meta-production
метафора metaphor
метаязык meta-language
метод ветвей и границ branch-and-bound method
метод интервью interview method
метод обратной волны
метод прямой волны
механизм вывода inference mechanism
механизм наследования inheritance mechanism
МИМД архитектура MIMD architecture
множество нечеткое fuzzy set
модель model
модель ассоциативная associative model
модель вычислительная computational model
модель замкнутая closed model
модель знаний knowledge model
модель когнитивная cognitive model
модель концептуальная conceptual model
модель Крипке Kripke model
модель лабиринтная labyrinth model
модель лингвистическая linguistic model
модель логико-лингвистическая logical-linquistic model
модель логическая logical model
модель мира world model
модель обучения learning model
модель общения communication model
модель открытая open model
модель поведения
модель пользователя user model
модель реляционная relational model
модель сетевая network model
модель ситуаций situational model
модель сознания
модель стимул-реакция SR-model (stimulus-reaction model)
модель течения диалога
модель формальная formal model
модель языка language model
модус поненс modus ponens
модус толленс modus tollens
монотонность при выводе

Н

наследование hireditance
нейробионика neurobionics
нейрокомпьютер
нейрон формальный
немонотонность при выводе
неопределенность uncertainty
неопределенность лингвистическая linguistic uncertainty
неполнота incompleteness
неразрешимость алгоритмическая algorithmic nonresolvability
новая информационная технология

О

область предметная subject area
область предметная плохо структурированная ill-structered subject area
область предметная хорошо структурированная well-structured subject area
область проблемная problem area
обобщение знаний
обобщение индуктивное inductive generalization
оболочка shell
обоснование argument
обработка естественного языка natural language processing
обработка изображений image processing
обработка параллельная parallel processing
обработка сигналов signal processing
образ image
образец pattern
обучение learning
обучение на примерах learning from examples
общение communication
объединение свидетельств combination of evidences
объяснение explanation
ограничение целостности
оживление
оправдание justification
отладка базы знаний knowledge base debugging
отладка семантическая
отладка синтаксическая
отношение relation
отношение антирефлексивное antireflexive relation
отношение антисимметричное antisymmetric relation
отношение антитранзитивное antitransitive relation
отношение виртуальное virtual relation
отношение временное temporal relation
отношение действия action relation
отношение интенсиональное intensional relation
отношение каузальное causal relation
отношение моделирования нечетко fuzzy modelling relation
отношение нерефлексивное non-reflexive relation
отношение несимметричное non-symmetric relation
отношение нетранзитивное non-transitive relation
отношение пространственное spatial relation
отношение релевантности relevance relation
отношение рефлексивное reflexive relation
отношение семантическое semantic relation
отношение симметричное symmetric relation
отношение толерантности tolerance relation
отношение транзитивное transitive relation
отношение функциональное functional relation
отношение эквивалентности equivalence relation
отношение экстенсиональное extensional relation
отрицание negation
отрицание логическое logical negation

П

падеж глубинный deep case
падеж Филлмора Fillmor case
память ассоциативная associative memory
память виртуальная virtual memory
память иконическая iconic memory
паплайн-архитектура pipeline architecture
перевод машинный machine translation
переменная лингвистическая linguistic variable
переменная пропозициональная propositional variable
переменная связанная bound variable
перлокуция perlocution
перцептрон perceptron
перцепция perception
пиксел pixel
пиктограмма
планирование planning
планирование деятельности activity planning
планирование иерархическое hierarchical planning
планирование распределенное distributed planning
планирование стратегическое strategic planning
планирование тактическое tactic planning
планировщик planner
подход байесовский Bayesian approach
поиск search
поиск ассоциативный associative search
поиск в глубину depth-first search
поиск в пространстве задач search in problem space
поиск в пространстве состояний search in state space
поиск в ширину breadth-first search
поиск восходящий
поиск информационный information search
поиск нисходящий
поиск по образцу pattern-matching
поиск по принципу "сперва лучше"best-first search
поиск случайный
поиск типа "сперва вглубь"
поиск типа "сперва вширь"
понимание естественного языка natural language understanding
понятие concept
порождение гипотез автоматическое automated hypothesis generation
порождение текста text generation
поток данных data flow
правила де Моргана de Morgan rules
правило rule
правило вывода inference rule
правило вывода композиционное compositional inference rule
правило синтаксическое syntactic rule
предикат predicate
представление данных data representation
представление знаний knowledge representation
представление экстенсиональное extensional representation
пресуппозиция presupposition
принцип резолюции resolution principle
приобретение знаний knowledge acquisition
программа игровая game program
программа эвристическая heuristic program
программирование programming
программирование логическое logical programming
программирование объектно-ориентированное object-oriented programming
программирование функциональное
программирование эвристическое heuristic programming
продукция production
пропозиция proposition
пространство задач
пространство Осгуда Osgood space
пространство семантическое semantic space
пространство состояний state space
пространство целевое goal space
противоречивость абсолютная absolute inconsistency
противоречивость модельная model inconsistency
протофрейм frame-prototype
процедура опровержения refutation procedure
процедура присоединенная attached procedure
процесс асинхронный asynchronous process
процессор ассоциативный associative processor
процессор базы данных data base processor
процессор лингвистический linguistic processor
процессор логический logical processor
процессор логического вывода inference processor
процессор матричный matrix processor
процессор символьный simbolic processor
психология когнитивная cognitive psychology

Р

разрешимость алгоритмическая algorithmic resolvability
распознавание образов pattern-recognition
распознавание речи speech recognition
расстояние семантическое semantic distance
рассуждение reasoning
рассуждение автоэпистемическое autoepistemic reasoning
рассуждение герменевтическое hermeneutics reasoning
рассуждение здравого смысла common-sense reasoning
рассуждение немонотонное non-monotonic reasoning
рассуждение по аналогии reasoning by analogy
рассуждение по ассоциации reasoning by association
рассуждение по умолчанию default reasoning
рассуждение правдоподобное plausible reasoning
резольвента resolvent
резолюция resolution
решатель задач problem solver
решетка Келли репертуарная repertoire lattice of Kelly
РИСК-архитектура RISC-architecture
робот автономный autonomous robot
робот интегральный integral robot
робот интеллектуальный intelligent robot

С

сборка мусора garbage collection
свидетельство evidence
секвенция sequent
семантика semantics
семантика ситуативная situational semantics
семиотика semiotics
сеть network
сеть ассоциативная associative network
сеть вывода inference network
сеть каузальная causal network
сеть переходов расширенная argumented transition network
сеть Петри Petri network
сеть причинно-следственная causal network
сеть семантическая semantic network
сеть семантическая интенсиональная intensional semantic network
сеть семантическая экстенсиональная extensional semantic network
сеть соединительная connectional network
силлогизм syllogism
СИМД-архитектура SIMD-architecture
синтаксис syntax
синтез программ автоматический automated program synthesis
синтез программ дедуктивный inductive program synthesis
синтез программ индуктивный inductive program synthesis
синтез программ трансформационный
синтез текста
система автоматизированного проектирования computer-aided design
система аксиоматическая axiomatic system
система вопросно-ответная question-answering system
система дедуктивная deductive system
система доверия belief system
система естественно-языковая natural language system
система индуктивная inductive system
система интеллектуальная intelligent system
система интеллектуальная обучающая intelligent teaching system
система интеллектуальная обучающаяся intelligent learning system
система интерактивная interactive system
система квазиаксиоматическая
система мультипроцессорная multi-processor system
система обучающаяся learning system
система объяснения explanatory system
система, основанная на знаниях knowledge-based system
система, основанная на правилах rule-based system
система представления знаний knowledge representation system
система продукций production system
система продукционная production system
система пятого поколения вычислительная fifth generation computer system
система управления автоматизированная computer-aided control system
система управления базой данных data base management system
система управления базой знаний knowledge base management system
система управления производством
система управления технологическим процессом
система формальная formal system
система фреймов frame system
система экспертная expert system
система экспертная пустая tool expert system
следствие логическое logical consequence
слот slot
событие event
сопоставление с образцом pattern-matching
составляющая знаний интенсиональная
составляющая знаний экстенсиональная
список ассоциативный associative list
средства инженерии знаний инструментальные knowledge engineering tools
ссылка анафорическая anaphoric reference
стратегия управления выводом inference control strategy
структура глубинная deep structure
структура когнитивная cognitive structure
структура однородная homogeneous structure
структура падежная case structure
структура познавательная cognitive structure
суждение judgement
сущность entity
схема концептуальная conceptual scheme
сценарий script

Т

творчество машинное computer art
тезис Черча Church thesis
теория аксиоматическая axiomatic theory
теория логическая logical theory
теория речевых актов speech act theory
терм term
тип данных data type
тип данных абстрактный abstract data type

У

универсум universum
универсум Эрбрана Herbrand universum
унификатор unifier
унификатор наибольший общий most general unifier
унификация unification
управление ситуационное situational control

Ф

фасет facet
фокус focus
форма префиксная нормальная prefix normal form
формула атомарная atomic formula
формула замкнутая closed formula
формула общезначимая valid formula
формула открытия
фрактал fractail
фрейм frame
фрейм-образец frame-prototype
фрейм падежный case frame
фрейм-прототип prototype frame
фрейм-экземпляр frame-example
функция выходов
функция доверия belief function
функция переходов membership function
функция принадлежности membership function
функция Сколема Skolem function

Х

Ц

цепочка вывода inference chain

Ч

Ш

шкала абсолютная absolute scale
шкала метрическая metric scale
шкала Осгуда Osgood scale
шкала относительная relative scale
шкала размытая fuzzy scale
шкала топологическая topological scale
шкала универсальная universal scale

Щ

Э

ЭВМ нейробионические neurobionical computer
эвристика heuristics

Ю

Я

язык автоматный
язык запросов query language
язык контекстно-свободный
язык контекстно-связанный
язык представления знаний knowledge representation language
язык представления знаний логический logical knowledge representation language
язык продукционный production language
язык секвенций
язык фреймовый frame language
ящик серый
ящик черный black box

АБДУКЦИЯ

Правдоподобный вывод от частного к частному.

АБСТРАКЦИЯ

Процесс отcечения единичного, случайного или несущественного для последующих шагов работы. A. всегда имеет место при представлении данных и знаний о внешнем мире в интеллектуальных системах. A. используется при обобщении знаний, проведении рассуждений и планировании целесообразной деятельности. A. является средством образования понятий.

АБСТРАКЦИЯ ДАННЫХ

1. Использование при преобразовании переменных только связывающих их операций без учета внутреннего представления переменных.
2. Методология программирования, при которой программа описывается как совокупность абстрактных типов данных. (См.также Абстракция)

АВТОМАТ

Абстрактная машина, преобразующая последовательности входных символов в последовательности выходных символов. В зависимости от числа внутренних состояний памяти A. различаются конечные A. и бесконечные A.; в зависимости от однозначности или неоднозначности формирования выходных последовательностей - детерминированные A. и недетерминированные A.; в зависимости от особенностей структуры магазинные A., стековые A., клеточные A.

АВТОМАТ БЕСКОНЕЧНЫЙ

Автомат, у которого множество внутренних состояний является счетным, в частности, машина Поста и машина Тьюринга.

АВТОМАТ ВЕРОЯТНОСТНЫЙ

Частный случай стохастического автомата, когда структура автомата остается неизменной при любых результатах его функционирования.

АВТОМАТ ДЕТЕРМИНИРОВАННЫЙ

Автомат, у которого в любой такт работы набор входных символов и внутреннее состояние однозначно определяет набор выходных символов и внутреннее состояние A.Д. в последующем такте работы.

АВТОМАТ ИНИЦИАЛЬНЫЙ

Автомат с заранее фиксированным внутренним состоянием в начале работы.

АВТОМАТ КЛЕТОЧНЫЙ

Однородная структура, состоящая из клеток, в каждой из которых находится конечный автомат, в общем случае А.К. имеет четыре входа от соседних клеток и четыре выхода, идущих к ним. Все автоматы в клетках являются одинаковыми. A.K. позволяет моделировать параллельные асинхронные процессы. В частности, с помощью A.K. можно моделировать самоорганизацию различных пространственно-временных конфигураций.

АВТОМАТ КОНЕЧНЫЙ

Автомат, работа которого определяется двумя функциями:
y(t+1) = F1(x(t), y(t)),
z(t) = F2(x(t),y(t)).
Первая функция задает смену состояний автомата в дискретные такты времени t и называется функцией переходов; вторая - выходные сигналы автомата и называется функцией выхода; x, y, и z - множества двоичных векторов фиксированной длины, т.е. конечные множества. Математической моделью A.K. может служить автоматная грамматика с помощью которой порождается автоматный язык.

АВТОМАТ ЛИНЕЙНО-ОГРАНИЧЕННЫЙ

Частный вид машины Тьюринга, у которого в каждый момент времени лента имеет конечную длину. При необходимости сдвига управляющей головки за край ленты лента наращивается на конечный отрезок, нужный головке. Линейно-ограниченным автоматам соответствуют контекстно-зависимые грамматики, порождающие контекстно-зависимые языки.

АВТОМАТ МАГАЗИННЫЙ

Частный случай стекового автомата, у которого можно считывать только ту информацию, которая была записана в стек последней.

АВТОМАТ НЕДЕТЕРМИНИРОВАННЫЙ

Автомат, у которого в некоторые такты работы набор входных символов и внутреннее состояние задают альтернативный выбор набора выходных символов и/или внутреннего состояния А.Н. в последующем такте работы. Частный случай А.Н. являются вероятностный автомат и стохастический автомат.

АВТОМАТ С ПЕРЕМЕННОЙ СТРУКТУРОЙ

См. Автомат стохастический.

АВТОМАТ СЕКВЕНЦИАЛЬНЫЙ

Конечный автомат, описанный на языке секвенций, задающий автоматные функции. Каждой такой системе можно поставить в соответствие типовую структуру А.С. состоящую из регистра (связанных между собой триггеров), схем совпадения и двух диодных матриц, одна из которых служит для реализации функций переходов автомата, а другая функций выходов.

АВТОМАТ СТЕКОВЫЙ

Автомат, память которого организована в виде стека, в котором запоминается последовательность входных символов с сохранением порядка их поступления. Считывание информации из стека производится по номеру позиции в стек. Частный случай А.С. является магазинный автомат. А.С. применяется при порождении контекстно-зависимых языков с заданной глубиной контекстов, что приводит к его использованию в лингвистических процессорах.

АВТОМАТ СТОХАСТИЧЕСКИЙ

Автомат, у которого вместо функций переходов и выходов в общем случае задаются распределения вероятностей дискретного типа. Для переходов задаются вероятности Hij, характеризующие вероятность смены состояния с номером i на состояние с номером j, а для выхода вероятности Qij, характеризующие появление выхода с номером j, если текущее состояние автомата имеет номер i. A.C. часто используется для описания процесса адаптации к среде, в которой он функционирует. В зависимости от успеха или неуспеха действий A.C. пересчитываются Hij и Qij, что приводит к адаптации A.C., если среда носит стационарный характер.

АВТОМАТИЗАЦИЯ ДЕЛОПРОИЗВОДСТВА

Совокупность средств, с помощью которых автоматизируется процесс делопроизводства на уровне одного работника. А.Д. дает возможность хранить совокупность документов в памяти ЭВМ, "пролистывать" папки с документами на экране дисплея, корректировать документы, "печатать и класть в папки" новые документы, уничтожать ненужные и т.п. Использование машинной графики позволяет высвечивать на экране дисплея привычный вид документов.

АВТОМАТИЗИРОВАННАЯ СИСТЕМА УПРАВЛЕНИЯ (АСУ)

Комплекс средств для автоматизированного управления организационными и организационно-техническими системами, включающий набор подсистем, реализующих все функции необходимые для планирования, оперативного управления и отчетности. При интеллектуализации АСУ в ее состав могут входить экспертные системы, интеллектуальные информационные системы, базы данных и знаний и естественно-языковый интерфейс.

АВТОМАТИЗИРОВАННАЯ СИСТЕМА УПРАВЛЕНИЯ ПРЕДПРИЯТИЕМ (АСУП)

Комплекс программных и аппаратных средств для автоматизированного управления предприятием. Основными задачами АСУП являются: календарное и перспективное планирование, организационное и оперативное управление, сбыт и снабжение, финансово-бухгалтерский учет, статистическая отчетность. АСУП включает систему сбора и обработки информации, а также такие средства интеллектуализации системы как базы данных, базы знаний, экспертные системы и естественно-языковый интерфейс. Нижними уровнями АСУП (ее частями) являются автоматизированные системы управления технологическим процессом.

АВТОМАТИЗИРОВАННАЯ СИСТЕМА УПРАВЛЕНИЯ ТЕХНОЛОГИЧЕСКИМ ПРОЦЕССОМ (АСУТП)

Комплекс программных и аппаратных средств, непосредственно управляющих ходом технологического (производственного) процесса. Основными задачами АСУТП являются отслеживание и корректировка хода технологического процесса, решение оперативно-диспетчерских задач и формирование для высшего уровня управления (АСУП). В состав АСУТП могут входить такие средства интеллектуалиации системы, как системы визуализации информации, экспертные системы и естественно-языковый интерфейс.

АКСИОМА

Утверждение, которое априорно считается истинным.

АКТ РЕЧЕВОЙ

Произнесение говорящим некоторого сообщения при наличии слушающего и конкретного ситуативного окружения. Изучение Р.А. позволило сформулировать требования к успешности коммуникации при общении людей друг с другом и людей с искусственными системами. Изучается в теории речевых актов.

АКТАНТ

Термин А. связан с определенной синтаксической концепцией, согласно которой элементарные высказывания расчленяются на функции (субъект, объект, предикат) и предикат рассматривается как ядро высказывания.

АКТОР

Специальным образом организованная процедура, характерная для объектно-ориентированного стиля программирования. Особенность А. состоит в том, что он самостоятельно включает в работу (активизируется), когда выполняются условия активизации. После окончания работы А. передает полученные им результаты другим А. Использование А. обеспечивает децентрализованное и максимальное параллельное решение задач.

АЛГОРИТМ

Система предписаний, задающая последовательность действий, с помощью которых за конечное число шагов находится решение всех задач определенного класса или выдается сообщение об отсутствии решения.

АЛГОРИТМ ВОЛНОВОЙ

Организация вычислительного процесса на сетевой структуре, например семантической сети. Предполагается, что в вершинах сети находятся операторы, которые необходимо обработать, а дуги (ребра) сети описывают возможные связи между операторами. От каждого оператора по всем дугам, исходящим из него, распространяется волна обработки с учетом требований, которые предъявляет к организации распространения волны А.В. А.В. используются в тех случаях, когда имеется набор устройств, способных параллельно и асинхронно обрабатывать сетевую структуру. А.В. показали высокую эффективность при решении задач теории графов и сетей, а также в поисковых и сортирующих процедурах (например, при поиске по образцу в базах знаний).

АЛГОРИТМ ГЕНЕТИЧЕСКИЙ

Организация процесса, напоминающего эволюцию в живой природе. Альтернативные решения плистируют популяцию. Для выбора решения используются механизмы, похожие на мутацию и кроссинговер. Альтернативные решения сравниваются между собой и "выживает" то решение, которое приобретает в "популяции" максимальный вес, А.Г. используются в моделях обучения.

АНАЛИЗ

Способ, вид исследования при котором реальный или мыслимый объект расчленяется на составляющие части (элементы) и изучаются эти элементы и связи между ними.

АНАЛИЗ КЛАСТЕРНЫЙ

Разбиение множества объектов на кластеры (компактные группы объектов) в специально сконструированном пространстве, метрика которого такова, что в один кластер попадают объекты, близкие друг другу с точки зрения этой метрики. Выделение кластеров может производиться многими способами теории А.К.

АНАЛИЗ МОРФОЛОГИЧЕСКИЙ

Обработка текста, дающая информацию о морфологических характеристиках каждого слова текста.

АНАЛИЗ ПРОТОКОЛЬНЫЙ

Ведение протокола с экспертом при приобретении знаний, в котором каким-либо образом фиксируется весь диалог (запись на магнитный носитель, стенографирование и т.п.).

АНАЛИЗ СИНТАКСИЧЕСКИЙ

1. Проверка выражения на вхождение его в совокупность построенных выражений.
2. При обработке естественного языка под А.С. понимается построение синтаксической структуры предложения на некотором естественном языке.
В интеллектуальных системах реализующих функции понимания текстов на ограниченном естественном языке, А.С. осуществляется в два этапа. На первом строится поверхностная синтаксическая структура, в которой участвуют части речи и отношения между ними. На втором этапе происходит переход к глубинной синтаксической структуре, которая по сути познавательная структура, связанная с отражением действительности в тексте на естественном языке. Для А.С. созданы программные системы - синтаксические анализаторы.

АНАЛИЗ СЦЕН

Комплекс моделей и методов, позволяющий в интеллектуальных системах (например, в интеллектуальных роботах) отображать в памяти системы трехмерные зрительные сцены. При проецировании сцен в память происходит переход к их формальному описанию. При этом необходимо правильно распознать объекты, принимающие участие в сцене, определить их расположение по глубине, дополнить загороженные участки объектов и т.п.

АНАЛИЗАТОР СИНТАКСИЧЕСКИЙ

Средства для проверки соответствия входных цепочек заданного языка его грамматике. Классификация А.С., как правило базируется на классификации соответствующих формальных грамматик.

АНАЛОГИЯ

Связь между двумя объектами, процессами, событиями или ситуациями на уровне отношений сходства-различия в базе знаний.

АНАФОРА

Повторение одного и того же слова или словосочетания в рамках одного предложения или соседних предложений в тексте. Часто при повторении используется не само слово или словосочетание а так называемое анафорическое слово (чаще всего местоимение). Например, в тексте "Петя шел в школу. Она находилась на краю поселка" "она" есть анафорическое слово для слова "школа". Такие анафорические ссылки затрудняют автоматический анализ текстов для их понимания в интеллектуальных системах.

АРГУМЕНТАЦИЯ

Процесс доказательства истинности утверждения с привлечением фактов из которых следует истинность данного утверждения или которое увеличивает уверенность в его истинности А. близка к обоснованию.

АРХИТЕКТУРА ВЫЧИСЛИТЕЛЬНОЙ СИСТЕМЫ

См. Архитектура компьютера.

АРХИТЕКТУРА КОМПЬЮТЕРА

Совокупность обобщенных сведений о структуре основных блоков компьютера, их функционировании и информационно-управляющих связях между ними.

АРХИТЕКТУРА КОНВЕЙЕРНАЯ

Архитектура вычислительной системы, состоящая из цепочки параллельно работающих процессоров, взаимодействующих таким образом, что выход одного из процессоров цепочки подключен к входу следующего процессора. При этом процессор состоит из последовательных элементов, каждый из которых реализует частичную обработку команды (выбор команды, дешифрацию кода операции, адресную арифметику, выборку операндов, выполнение операции) и следующая команда начинает выполнять раньше, чем завершается предыдущая. А.К. обладает высокой производительностью при реализации алгоритмов, характеризующихся применением одинаковых последовательностей операторов к разным исходным данным (в так называемых системах массовой обработки данных).

АРХИТЕКТУРА ПАРАЛЛЕЛЬНАЯ

Архитектура вычислительной системы в которой одновременно выполняются одинаковые или различные операции над несколькими группами данных. См. также СИМД-архитектура и МИМД-архитектура.

АРХИТЕКТУРА ПОТОКОВАЯ

Архитектура вычислительной системы ориентированном на управление вычислительным процессом с помощью потока данных или потока запросов. В первом случае выполнение каждой операции инициируется содержимым ее операндов: заранее последовательность выполнения команд не задается. В качестве операндов команды выступают не адреса ячеек памяти, а команды, результаты выполнения которых являются операндами данной команды. Такая организация ЭВМ ориентирована на применение функционального программирования (ЛИСП и подобные ему).

АССОЦИАЦИЯ

Связь между двумя информационными единицами в базе знаний, устанавливаемая на основе некоторой меры близости, определяемой на множестве информационных единиц, хранимых в этой базе.

АТОМ

См. Формула атомарная.

АТРИБУТ

Уникальное имя, приписываемое домену значений некоторой информационной единицы.

БАЗА ДАННЫХ

Совокупность программных средств, обеспечивающих поиск, хранение и запись информационных единиц заданной структуры (данных) в памяти ЭВМ.

БАЗА ДАННЫХ ИЕРАРХИЧЕСКАЯ

База данных, в которой между информационными единицами введены отношения вида "Элемент-класс", "тип-подтип" и т.п., с помощью которых образуются иерархические классификации хранящихся в базе информационных единиц.

БАЗА ДАННЫХ РЕЛЯЦИОННАЯ

База данных, в которой информационные единицы связаны между собой отношениями типа "один к одному", снабжены атрибутами и для представления отношений используется запись в виде таблиц.

БАЗА ДАННЫХ СЕТЕВАЯ

База данных, в которой информационные единицы связаны между собой отношениями типа "один к одному", "один к многим" и "многие к многим".

БАЗА ДАННЫХ ЭКСТЕНСИОНАЛЬНАЯ

База данных, в которой хранятся лишь константные факты о внешнем мире.

БАЗА ЗНАНИЙ

Совокупность программных средств, обеспечивающих поиск, хранение, преобразование и запись в памяти ЭВМ сложно структурированных информационных единиц (знаний).

БАЗА ЗНАНИЙ ЗАМКНУТАЯ

База знаний, содержимое которой в процессе функционирования не изменяется. Логический вывод в такой базе эквивалентен выводу в формальной системе и обладает свойством монотонности, т.е. ранее выведенные утверждения остаются верными на весь период функционирования Б.З.З.

БАЗА ЗНАНИЙ ИНТЕНСИОНАЛЬНАЯ

База знаний, в которой описаны общие закономерности, характерные для некоторой проблемной области, а также способы постановки и решения задач в этой области.

БАЗА ЗНАНИЙ ОТКРЫТАЯ

База знаний, позволяющая в процессе ее функционирования пополнять содержимое базы и убирать знания из базы. Свойство открытости приводит к тому, что вывод в такой базе является немонотонным, т.е. истинность выведенных в ней утверждений может меняться в процессе работы системы с такой базой.

БЕКТРЕКИНГ

Процедура возврата при поиске на некоторой структуре (например, поиск по дереву решений или в лабиринте). При движении по структуре часто возникает необходимость, когда выбранный путь оказался неудачным или тупиковым в возврате к месту разветвления процесса поиска. Для ускорения возможности возврата в последнюю точку ветвления ее координаты следует хранить в памяти. Для хранения совокупности вложенных друг в друга по старшинству точек ветвления используются специальные стековые регистры.

БЕСЕДА СОКРАТИЧЕСКАЯ

Специально организованный диалог, в ходе которого один из участников предлагает некоторый тезис, а второй последовательно выдвигает возражения против тезиса, на которые участник, предложивший тезис, отвечает только: "согласен" или " не согласен". Целью Б.С. является обучение приемам логических рассуждений.

БИХЕВИОРИЗМ

Сведение создания к целенаправленному поведению, связанному с парой "стимул-реакция". Для Б. характерно рассмотрение субъекта как черного ящика. Ряд моделей искусственного интеллекта был построен на основе подхода, декларируемого в Б.

ВАЛИДАЦИЯ

Оценка программного продукта с точки зрения соответствия всем предъявленным к нему требованиям.

ВЕРИФИКАЦИЯ

Оценка правильности исходных данных для производства всех требований к будущему продукту, так и к его производству.

ВИДЕОПРОЦЕССОР

Специализированный процессор, предназначенный для эффективной реализации алгоритмов обработки изображений. Особенностью взаимодействия растрового дисплея со спецпроцессором является соответствие каждой точки изображения одного или нескольких разрядов памяти в адресном пространстве спецпроцессора. Изменяя содержимое ячеек памяти, программа изменяет изображение на экране.

ВОСПРИЯТИЕ

Отражение окружающей ситуации и ее элементов при взаимодействии органов чувств человека или рецепторов искусственной системы с внешней средой. В. обеспечивает непосредственно-чувственную ориентировку в среде и порождает поток входной информации для последующей обработки ее человеком или искусственной системой. Для интеллектуальных систем наиболее важными видами Восприятия являются восприятие зрительной информации, восприятие тактильной информации и акустической информации (распознавание речи).

ВОСПРИЯТИЕ ЗРИТЕЛЬНОЙ ИНФОРМАЦИИ

Обработка сигналов, поступающих в интеллектуальную систему (интеллектуальный робот) с датчиков зрительных сцен. В качестве датчиков для плоских изображений часто используются матрицы из фотодиодов, но применяется и фотографическая аппаратура. Для трехмерных сцен чаще всего в качестве датчика используют телевизионную камеру. При В.З.И. происходит очистка изображения от шумов и искажений, анализ плоского изображения или анализ сцен для объемного изображения, перекодировка изображения и передача его в базу знаний или решатель.

ВОСПРИЯТИЕ ТАКТИЛЬНОЙ ИНФОРМАЦИИ

В интеллектуальных роботах обработка сигналов, поступающих от датчиков, меряющих кинематические характеристики для эффекторов робота, и от специальных датчиков, измеряющих усилия, связанные с взятием предметов или опорой на грунт. После предварительной обработки полученная информация поступает в систему планирования деятельности и используется для выработки управляющих воздействий на среду или на робота.

ВЫБОРКА ОБУЧАЮЩАЯ

Набор примеров и контрпримеров для формирования решающих правил. Входит в состав таблицы обучения.

ВЫВОД

Получение новых информационных единиц из ранее известных. Частным случаем является логический вывод.

ВЫВОД АБДУКТИВНЫЙ

Вывод на основании абдукции.

ВЫВОД ВЕРОЯТНОСТНЫЙ

Вывод, при котором каждое выражение, используемое в нем, имеет оценку правдоподобия в виде вероятности того, что оно является истинным. При В.В. применяются специальные процедуры для вычисления вероятности истинного значения результирующего выражения по вероятностям посылок, используемых при выводе.

ВЫВОД ЕСТЕСТВЕННЫЙ

Вывод, полученный на основании "здравого смысла". В.Е. может либо соответствовать логическому выводу в некоторой формальной системе (но быть для человека очевидным), либо опираться на соображения, которые не укладываются в строгие рамки формальной системы.

ВЫВОД ИНДУКТИВНЫЙ

Вывод "от частного к общему". Позволяет на основании обобщения частных примеров некоторого явления выдвинуть гипотезу о существовании общей закономерности. В интеллектуальных системах, использующих В.И., работают механизм, позволяющий при формировании гипотезы приписывать ей оценку правдоподобия (например, вероятность того, что данная гипотеза является истинной). В.И. является средством получения новых знаний в интеллектуальных системах.

ВЫВОД ИНТУИЦИОНИСТСКИЙ

Вывод, характерный для интуиционистской логики, не использующий, в частности, закон снятия двойного отрицания и закон исключенного третьего.

ВЫВОД ЛИНЕЙНЫЙ

Последовательность дизъюнктов, в которой начальный дизъюнкт принадлежит исходному множеству, в каждый промежуточный дизъюнкт является резольвентой предшествующего в уже построенной части последовательности дизъюнктов и некоторого бокового дизъюнкта.

ВЫВОД ЛОГИЧЕСКИЙ

1. Последовательность рассуждений, приводящая от посылок к следствию с использованием аксиом и правил вывода.
2. Результат вывода.

ВЫВОД НА ЗНАНИЯХ

Вывод, использующий в качестве посылок выражения, хранящиеся в базе знаний В.Н.З. может быть достоверным, если эти выражения являются достоверным, или правдоподобным или снабжены оценками правдоподобия. Как правило, процедуры В.Н.З. включают поиск необходимых знаний для вывода, т.е. процедуру поиск по образцу.

ВЫВОД НЕМОНОТОННЫЙ

Вывод, при котором нарушается свойство монотонности при выводе.

ВЫВОД НЕЧЕТКИЙ

Вывод, при котором используются нечеткие кванторы или значения функций принадлежности. При нечетких кванторах правила вывода определяют тот квантор, который следует приписать результату при заданных значениях кванторов посылок. При использовании значений функций принадлежности правило вывода определяет значение этой функции для результата по значениям функций принадлежности посылок.

ВЫВОД ОБРАТНЫЙ

Вывод, при котором поиск доказательства начинается с целевого утверждения. Выясняются условия, при которых целевое утверждение является выводимым. Эти условия принимаются за новые целевые утверждения и процесс поиска продолжается. В.О. заканчивается, когда все очередные условия оказываются аксиомами или процесс условий обрывается, не приведя к аксиомам. В.О. широко используется в интеллектуальных системах при поиске решений.

ВЫВОД ПО АНАЛОГИИ

Вывод, основанный на перенесении рассуждения из исследованной области на другую область, похожую на исследованную. Если имеется вывод A ® B, и область, в которой определено A, гомоморфна области, где определена C, а область, где определено B, гомоморфна области, где определено D, то вывод A ® B порождает вывод C ® D. В.П.А. есть частный случай правдоподобного вывода.

ВЫВОД ПРАВДОПОДОБНЫЙ

Вывод, при котором каждый шаг сопровождается вычислением оценки достоверности полученного утверждения. Частными случаями В.П. является, например, вывод вероятностный и вывод индуктивный.

ВЫВОД ПРЯМОЙ

Вывод, ведущий от исходных аксиом к целевому выражению. При В.П. из-за неоднозначности выбора применимы аксиом и правил вывода образуется дерево решений и процесс нахождения цепочки, ведущей от исходных аксиом к целевому выражению, является переборным. Стандартной процедурой, используемой при обходе дерева решений, является процедура возврата - бектрекинг.

ВЫЗОВ ПО ОБРАЗЦУ

Способ поиска информации в базах данных, базах знаний или в оперативной памяти компьютера. В отличие от поиска по адресу хранения, В.П.О. предполагает ассоциативный поиск по содержимому запросу на поиск. (См. Поиск по образцу).

ВЫСКАЗЫВАНИЕ

Логическое выражение, относительно которого всегда можно утверждать, что оно либо истинно, либо ложно.

ВЫСКАЗЫВАНИЕ АТОМАРНОЕ

Высказывание, структура которого далее не расчленяема. В формальных системах В.А. соответствуют базовые элементы. Интерпретация истинности В.А. задается для формальной системы извне и на этой основе определяется интерпретация всех правильно построенных формул формальной системы.

ГЕНЕРАЦИЯ ТЕКСТА

Процесс порождения текста, включающий выделение фрагмента внутреннего представления, который войдет в текст; формирование схемы дискурса, т.е. последовательности, в которой должна быть изложена информация; заполнение схемы дискурса языковыми выражениями. При Г.Т. также учитывается фокус внимания и предотвращения коммуникативных ошибок. (См. Порождение текста. Синтез текста).

ГЕРМЕНЕВТИКА

Раздел семантики, изучающий способы выявления содержания текста, в явной форме в нем не выраженного. Поиск скрытого в тексте содержания происходит в результате обращения к знаниям, являющимся релевантными для данного текста.

ГИПЕРСОБЫТИЕ

Специально организованное описание типовой ситуации (кражи, драки, покупки в магазине и т.п.). Г. может представляться в базах знаний различными способами, например, в виде сценариев.

ГИПОТЕЗА

Частично обоснованная закономерность знаний, или для связи между различными эмпирическими фактами, или для объяснения факта или группы фактов. В интеллектуальных системах Г. порождаются в процессе обучения систем (в частности, при обучении на примерах).

ГИПОТЕЗА КОМПАКТНОСТИ

Предположение о том, что образы в пространстве признаков группируются из изображений (точек пространства), которые могут быть отделены друг от друга гиперповерхностями простого вида. Гипотеза Компактности используется при распознавании образов, когда применяется принцип разделения.

ГЛУБИННАЯ СТРУКТУРА (предложения)

См. Структура глубинная.

ГРАММАТИКА

Совокупность правил формирования правильных предложений в рамках рассматриваемого языка.

ГРАММАТИКА АВТОМАТНАЯ

Формальная грамматика, у которой правила вывода имеют вид
b1A1 ® b2A2, b1A1 ® b2
где A1, A2 - нетерминальные символы; b1, b2 - терминальные символы. Каждая Г.А. порождается некоторым конечным автоматом. И каждый конечный автомат задает некоторую Г.А.

ГРАММАТИКА КОНТЕКСТНО-ЗАВИСИМАЯ

См. Грамматика контекстно-связанная.

ГРАММАТИКА КОНТЕКСТНО-СВОБОДНАЯ

ГРАММАТИКА КОНТЕКСТНО-СВЯЗАННАЯ

Формальная грамматика, для которой существуют такие цепочки что и имеют место правила и К.С. обладают свойством сохранения длины цепочки. Цепочки, получаемые после применения любого правила, либо сохраняют длину исходной цепочки, либо увеличивают ее. Г.К.С. порождаются линейно-ограниченными автоматами. И для каждой Г.К.С. может быть построен воспроизводящий ее линейно-ограниченный автомат.

ГРАММАТИКА МАТРИЧНАЯ

Формальная грамматика, у которой в качестве правил вывода выступают фиксированные по порядку применения совокупности правил вывода обычных грамматик. Эти совокупности, называемые матричными правилами вывода, могут пересекаться между собой по общим правилам вывода, входящим в матричные правила вывода. Г.М. используются при описании параллельных процессов и языков программирования для устройств, обеспечивающих параллельное выполнение программ.

ГРАММАТИКА НЕУКОРАЧИВАЮЩАЯ

См. Грамматика контекстно-связанная.

ГРАММАТИКА ПАДЕЖНАЯ

Грамматика предикатно-аргументной структуры предложения. Аргументами такой структуры являются имена, для которых можно указать глубинные падежи (обобщенные отношения между содержанием глагола и содержанием той или иной из именных групп).

ГРАММАТИКА СЕТЕВАЯ

Грамматика расширенных сетей переходов - подкласс трансформационных грамматик. В настоящее время под Г.С. понимается упорядоченная тройка Fs = < V,Z N >, где V - описание лексиконов обрабатываемого языка; Z - описание нестандартных функций, повышающих эффективность обработки; N - описание расширенной сети переходов (специального графа, с помощью которого представляется анализатор языка).

ГРАММАТИКА ФОРМАЛЬНАЯ

Четверка <S, A, B, P>, в которой S - аксиома Г.Ф.; A - множество нетерминальных символов; B - множество терминальных символов; P - правила вывода. Объектами, с которыми работает Г.Ф., являются цепочки, состоящие из терминальных и нетерминальных символов. Правила вывода имеют вид, где и цепочки символов. При этом содержит хотя бы один нетерминальный символ. Функционирование Г.Ф. всегда начинается с цепочки, состоящей из единственного символа S. Применение правила к цепочке заключается в замене всех вхождений (или только самого левого вхождения) в на . Процесс заканчивается, когда ни одно из правил вывода к данной цепочке неприменимо. Такие заключительные цепочки входят в язык, порождаемый данной Г.Ф. В синтаксически правильных Г.Ф. в язык входят только те цепочки, которые состоят полностью из терминальных символов. Г.Ф. широко используются в синтаксических моделях для естественных языков и в лингвистических процессорах. Они являются частным случаем формальных систем. В зависимости от ограничений, накладываемых на структуру правил вывода, выделяются различные типы Г.Ф.

ГРАФ

Пара (X, R), где X - множество, элементы которого переименованы и называются вершинами; R - бинарное отношение, заданное на X. Если между вершинами x1 О X и x2 О X существует отношение R, то тройка x1 R x2 называется ребром Г. Если отношение R несимметрично, то x1 R x2 называется дугой Г. Г. с ребрами называется неориентированным, а с дугами - ориентированным. Г. находят широкое применение в моделях интеллекта искусственного.

ГРАФИКА ДИНАМИЧЕСКАЯ

Направление в машинной графике, которое разрабатывает приемы и процедуры для воспроизведения на экране дисплея движущихся сцен. В Г.Д. используются многие средства, разработанные в мультипликационном (анимационном) кино, а также ряд приемов математического характера.

ГРАФИКА КОГНИТИВНАЯ

Направление в машинной графике, которое связывает представления, возникающие на экране дисплея, с когнитивными процессами, протекающими при решении задач. Г.К. позволяет как бы визуализировать процесс решения. При достаточно продуманной системе визуализации образы, возникающие в динамике на экране, могут помочь пользователю, решающему задачу в интерактивном режиме, увидеть те закономерности или пути решения задачи, которые ранее для него не были доступны. С развитием Г.К. связывают большие надежды на повышение эффективности решения задач, так как мышление пользователя может существенно ускорить процесс поиска решения и рождать новые пути его поиска. Г.К. требует специальных представлений в базе знаний соответствующих образам на экране дисплея, и процедур соотнесения этих представлений с традиционными когнитивными структурами.

ГРАФИКА МАШИННАЯ

1. Совокупность программных средств для выдачи на дисплей изображений представления в графической форме промежуточных и окончательных результатов решения задач и для работы с графическими изображениями.
2. Направление, занимающиеся разработкой этих средств.

ДЕЙСТВИЕ

Единица процесса деятельности, активность, направленная на достижение определенной цели. Д. может быть внутренним, направленным на преобразование информации внутри интеллектуальной системы, или внешним, направленным во внешнюю среду (сообщение пользователю, движение манипулятора автономного робота и т.п.).

ДЕКОМПОЗИЦИЯ ЗАДАЧ

Разбиение задачи на подзадачи с последующим разбиением этих подзадач до получения базовых (элементарных) задач, для которых заранее известно решение. Д.З. применяется в интеллектуальных системах при создании систем автоматического программирования и при планировании поведения в пространстве задач. В более общем смысле Д.З. может служить для понимания размеренности решаемой задачи.

ДЕНОТАТ

Реальный объект, процесс, явление, ситуация и т.п. в физическом мире, для которого есть специальное именующее выражение в некотором языке. Это именующее выражение является десигнатом для данного денотата.

ДЕРЕВО ВЫВОДА

Представление процедуры логического вывода в виде дерева, вершинами которого являются или исходные формулы, или формулы, полученные в процессе вывода.

ДЕРЕВО ДВОИЧНОЕ

Представление процесса поиска в виде дерева, каждая вершина которого связана со значением ключа поиска таким образом, что все меньшие ключи сосредоточены в ее левом поддереве, а все большие - в правом.

ДЕРЕВО ЗАВИСИМОСТЕЙ

Представление результата работы этапа синтаксического анализа в лингвистических процессорах в виде дерева разбора предложения, в вершинах которого стоят лексемы, соответствующие подлежащему, сказуемому, дополнению и т.п., а дуги указывают на связь между вершинами по управлению. Используется на этапах глубинного синтаксического и семантического анализа предложения.

ДЕРЕВО РЕШЕНИЙ

Структура, состоящая из узлов принятия решений и альтернатив, соответствующих этим узлам. Движение по Д.Р. может осуществляться случайным образом или на основании локальной информации об успехе, которая имеется в узлах. В результате успешного поиска на Д.Р. образуется путь, ведущий из корня дерева исходная ситуация к тому узлу дерева, которое соответствует целевой ситуации. В процессе движения по Д.Р. часто возникает необходимость возврата в ранее пройденные узлы, что осуществляется с помощью процедуры бектрекинга.

ДЕРЕВО СОСТАВЛЯЮЩИХ

Представление системы составляющих, корнем которой является полная составляющая, а висячими узлами являются точечные составляющие.

ДЕРЕВО ЦЕЛЕЙ

Специальный вид дерева в котором одна или несколько вершин соответствуют целям, а остальные вершины подцелями этих целей. Дуги показывают, как декомпозируются цели в подцелях.

ДЕСИГНАТ

Специальное именующее выражение для денотатов, существующих во внешнем по отношению к данной системе мира. Все значения системы о денотатах фиксируются в виде знаний о Д. В ряде случаев Д. называют уникальным именем, меткой, ключом.

ДЕСКРИПТОР

Выделенное слово (или сочетание), которое для понимающей тексты на естественном языке системы служит маркером. Этот маркер входит в левые части правил вывода, секвенций или продукций. При появлении маркера соответствующее правило срабатывает. Д. выбирается из специального словаря и ему искусственно придается смысловая однозначность, позволяющая с его помощью обозначать класс (синонимичных) понятий.

ДЕФОЛТ

Наиболее типичное значение атрибута, приписываемое объекту, если его значение для этого объекта указано.

ДИЗЪЮНКТ

Выражение вида B1 Ú B2 Ú ... Ú Bn ¬ A1 & A2 &...& Am, где (&,Ú,¬ ) соответственно символы конъюнкции, дизъюнкции и импликации. Д. читается так: "Если A1, и A2, и, Am, то B1, или B2, или ,..., Bn". Правая или левая часть импликации может быть пустой. В этом случае Д. интерпретируется иначе. Для Д. вида B1 Ú B2 Ú ... Ú Bn интерпретация заключается в утверждении существования факта B1 Ú B2 Ú ... Ú Bn ; а для Д. вида ¬ A1 & A2 &...& Am интерпретация состоит в утверждении, что (A1 & A2 &...& Am). Если в Д. пусты левая и правая часть импликации, то он называется пустым. Д. используется в методе логического вывода, основанном на использовании резолюций, а также в языке программирования Пролог.

ДИЗЪЮНКТ БОКОВОЙ

Дизъюнкт, который является либо элементом исходного множества, либо некоторым дизъюнктом, предшествующим в выводе рассматриваемому.

ДИЗЪЮНКТ ПУСТОЙ

Пустое множество, возникающее при исчерпании исходного множества, дизъюнктов в случае успешного завершения процесса вывода, опирающегося на принцип резолюции.

ДИЗЪЮНКТ ХОРНА

Дизъюнкт, содержащий не более одной положительной литеры.

ДИЗЪЮНКЦИЯ

Логическая операция (связка) для n> 2 выражений. Результирующее выражение ложно только тогда, когда ложны исходные выражения. Для обозначения Д. стандартно используется знак Ú (реже +).

ДИСКУРС

Анализ текста с точки зрения его коммуникативной функции и структуры. Теория дискурса изучает закономерность построения текстов, сочетаемость текстовых единиц и фрагментов текста.

ДИССОНАНС КОГНИТИВНЫЙ

Диссонанс, возникающий у субъекта, когда он располагает одновременно двумя противоречивыми знаниями об одном и том же объекте, субъекте, ситуации или явлении. Д.К. есть побудительный мотив для того, чтобы начать некоторую деятельность по устранению противоречия в знаниях. В интеллектуальных системах Д.К. используется в базах знаний, чтобы сделать знания активными.

ДОКАЗАТЕЛЬСТВО КОНСТРУКТИВНОЕ

Вывод утверждения в логическом исчислении, который обеспечивает явное построение всех элементов, участвующих в выводе. Таковым не является, например, широко распространенный способ доказательства "от противного", используемый в классической математике.

ДОКАЗАТЕЛЬСТВО ТЕОРЕМЫ

Логическое следование данной формулы из данной совокупности выведенных ранее формул.

ДОМЕН

Помещенная в базу данных совокупность значений некоторой информационной единицы. Д. определяется своим атрибутом.

ДОСКА ОБЪЯВЛЕНИЙ

Способ управления параллельно протекающими асинхронными процессами решения задач, при которых информация о закончившихся процессах и полученных результатах "вывешивается" на Д.О., к которой имеют независимый доступ все процессы (и/или программисты), ожидающие нужных результатов. Д.О. часто используется в экспертных системах, интеллектуальных роботах и других интеллектуальных системах.

ЗАКОН ИСКЛЮЧЕННОГО ТРЕТЬЕГО

Один из базовых законов рассуждений, характерных для традиционных формальных систем. Он утверждает, что выражение (A V ¬A) является тождественно истинным. З.И.Т. подвергался критике и отвергался логиками, стоящими на позиции интуиционистской математики и конструктивной математики.

ЗАКОН СНЯТИЯ ДВОЙНОГО ОТРИЦАНИЯ

Один из базовых законов рассуждений, характерных для традиционных формальных систем. Он утверждает, что всегда имеет место равенство A=A.

ЗНАНИЯ

Совокупность сведений, образующих целостное описание, соответствующее некоторому уровню осведомленности об описываемом вопросе, предмете, проблеме и т.д.

ЗНАНИЯ ДЕКЛАРАТИВНЫЕ

Знания, которые записаны в памяти интеллектуальной системы так, что они непосредственно доступны для использования после обращения к соответствующему полю памяти. В виде З.Д. обычно записывается информация о свойствах предметной области, фактах, имеющих в ней место и т.п. информация. По форме представления З.Д. противопоставляются процедурным знаниям.

ЗНАНИЯ О ПРЕДМЕТНОЙ ОБЛАСТИ

Совокупность сведений о предметной области, хранящихся в базе знаний интеллектуальной системы. В З.П.О. входят факты, относящиеся к предметной области, закономерности, характерные для нее, гипотезы о возможных связях между явлениями, процессами и фактами в ней, процедуры для решения типовых задач в данной проблемной области. З.П.О. вводит в базу знаний инженер по знаниям. В процессе функционирования интеллектуальной системы З.П.О. могут пополняться. З.П.О. используют при поиске решений задач, возникающих в экспертных и других интеллектуальных системах.

ЗНАНИЯ ПРАГМАТИЧЕСКИЕ

1.Знания о способах решения задач в заданной предметной области.
2. В естественном языке знания о прагматической компоненте текстов. (См. также Модель пользователя, Фокус внимания).

ЗНАНИЯ ПРОЦЕДУРНЫЕ

Знания, хранящиеся в памяти интеллектуальной системы в виде описаний процедур, с помощью которых их можно получить. В виде З.П. обычно описываются информация о предметной области, характеризующая способы решения задач в этой области, а также различные инструкции, методики и т.п. информация. По форме представления З.П. противопоставляются декларативные знания.

ЗНАНИЯ ЭВРИСТИЧЕСКИЕ

Знания, накапливаемые интеллектуальной системой в процессе ее функционирования, а также знания, заложенные в ней априорно, но не имеющие статуса абсолютной истинности в данной проблемной области. Часто З.Э. связаны с отражением в базе знаний человеческого (неформального) опыта решения задач.

ЗНАНИЯ ЭКСПЕРТНЫЕ

Знания, которыми располагает специалист в некоторой предметной области.

ЗНАЧЕНИЕ АТРИБУТА

Константа, приписанная атрибуту в базе данных.

ЗНАЧЕНИЕ ПО УМОЛЧАНИЮ

Значение переменной, которое ей автоматически приписывается, если ее значение не задается.

ЗРЕНИЕ МАШИННОЕ

Совокупность моделей и методов для выполнения техническими системами процедур, характерных для зрительного восприятия у живых организмов. В рамках З.М. решаются задачи выделения объектов из фона, их идентификация, ввод в промежуточную память, перекодировка во внутренние представления и т.п. Системы З.М. характерны для интеллектуальных роботов и других интеллектуальных систем.

И/ИЛИ ГРАФ

Ориентированный граф, обладающий свойствами: 1). При возбуждении (передаче информации) входных дуг, ведущих в некоторую вершину, реализуется либо конъюкция (И), либо дизъюнкция (ИЛИ). В первом случае вершина возбуждается (становится активной и принимает информацию) только тогда, когда возбуждены все дуги, входящие в нее. Во втором случае для возбуждения вершины достаточно возбуждения любой входящей в нее дуги. 2). При возбуждении вершины возбуждаются либо все выходящие из вершины дуги (И), либо только одна, выбираемая вершиной (исключающее ИЛИ для числа аргументов, равного числу выходящих дуг). Часто под И/ИЛИ г. понимают граф, для которого выполнено первое свойство, а для выходных дуг всегда имеет место И. И/ИЛИ г. широко используются в системах планирования целесообразного поведения автономных роботов и в других системах искусственного интеллекта.

ИДЕНТИФИКАЦИЯ

Процедура установления интересующих исследователя свойств в изучаемом явлении или объекте. Для интеллектуальных систем И. часто означает проверку того, что данная система действительно решает те задачи, для решения которых она была создана.

ИДЕНТИФИКАЦИЯ ЗНАНИЙ

Определение характеристик знаний, необходимых для решения задачи.

ИЗВЛЕЧЕНИЕ ЗНАНИЙ

Получение информации о предметной области от специалистов и выражение ее на языке представления знаний. И.З. используется при построении экспертной системы или базы знаний.

ИИ-ПРОГРАММИРОВАНИЕ

Разработка инструментального программного обеспечения для решения задач искусственного интеллекта. В ИИ-П. создаются языки программирования, ориентированные на особенности задач искусственного интеллекта, интеллектуальные вспомогательные средства, языки представления знаний и манипулирования ими, пустые экспертные системы и оболочки и другие инструментальные средства.

ИЛЛОКУТИВНЫЙ ПОТЕНЦИАЛ

Коммуникативные возможности конкретного вида речевого акта. Например, возможность выражать вопрос, сомнение, просьбу вопросительным предложением типа "А разве вы не придете?".

ИЛЛОКУЦИЯ

Одна из составляющих речевого акта наряду с локуцией и перлокуцией. Выполнение действия посредством речи: побуждение (просьба, приказ), вопрос, сомнение, утверждение, обещание.

ИМИТАЦИЯ ИНТЕЛЛЕКТУАЛЬНОГО ПОВЕДЕНИЯ

Воспроизведение процедур формирования целенаправленного поведения человека и животных в внешнем мире в зависимости от возникающих в нем ситуаций. Для И.И.П. разрабатываются специальные модели и методы планирования деятельности. Имитация интеллектуального поведения широко используется в интеллектуальных роботах.

ИМИТАЦИЯ ПРОЦЕССОВ МЫШЛЕНИЯ

Воспроизведение программы путем или с помощью специальной аппаратуры отдельных процессов, характерных для мышления человека и животного (распознавание ситуаций, принятие решений о своем поведении, понимание текстов на естественном языке и т.п.). В искусственном интеллекте И.И.М., как правило, предполагает не идентичность процессов, протекающих в мозгу и в технической системе, а совпадение результатов решения одинаковых задач.

ИМПЛИКАЦИЯ

Логическая операция (связка) для двух выражений. Результирующее выражение ложно тогда, когда первое выражение истинно, а второе ложно (операция И. некоммутативна). Стандартное обозначение импликации: ®.

ИНДУКЦИЯ

Метод перехода от частных наблюдений к общей закономерности, которой удовлетворяют все частные наблюдения.

ИНДУКЦИЯ НЕПОЛНАЯ (ЭМПИРИЧЕСКАЯ)

Нахождение закономерностей, которым подчиняются все известные до этого момента наблюдения. Найденные закономерности могут опровергаться новым наблюдениями.

ИНДУКЦИЯ ПОЛНАЯ (МАТЕМАТИЧЕСКАЯ)

Математическое доказательство справедливости некоторой закономерности, основанное на выдвижении гипотезы по конечному числу фактов и обоснований к изменению этой закономерности.

ИНЖЕНЕР ПО ЗНАНИЯМ

Специалист, основной задачей которого является проектирование баз знаний и наполнение их знаниями о проблемной области. В процессе этой деятельности И.П.З. выбирает форму представления знаний, удобную для данной проблемной области, организует приобретение знаний из различных источников (официальные документы, учебники, монографии и т.п.), а также в результате общения с экспертами-специалистами в данной проблемной области.

ИНЖЕНЕРИЯ ЗНАНИЙ

Раздел искусственного интеллекта, в рамках которого решаются проблемы, связанные с извлечением знаний, приобретением знаний, представлением знаний и манипулированием знаниями. И.З. служит основой для создания экспертных систем и других интеллектуальных систем.

ИНТЕЛЛЕКТ ИСКУССТВЕННЫЙ

1. Научное направление, в рамках которого ставятся и решаются задачи аппаратного или программного моделирования тех видов человеческой деятельности, которые традиционно считаются интеллектуальными. (См. также Представление знаний, Обучение, Общение, Объяснение).
2. Свойство интеллектуальных систем выполнять функции (творческие), которые традиционно считаются прерогативой человека.

ИНТЕРВЬЮ

Способ работы с экспертом при приобретении знаний, когда инженер по знаниям выступает в роли интервьюера.

ИНТЕРПРЕТАЦИЯ

В широком смысле - объяснение, толкование чего-либо. В программировании - процесс перевода программы, написанной на языке высокого уровня, в объектный код таким способом, что программа храниться в памяти ЭВМ в первоначальной форме, а трансляция в объектный код осуществляется частями, по мере необходимости. В искусственном интеллекте - установление связи между двумя системами описаний, что позволяет понимать одну систему на уровне другой.

ИНТЕРФЕЙС

Совокупность технических и/или программных средств, обеспечивающая сопряжение двух или более элементов системы для их совместного функционирования в этой системе. Типичным примером технического И. является набор конструктивных параметров телефонных аппаратов и телефонных каналов, позволяющих подключить любой телефонный аппарат к любому телефонному каналу.

ИНТЕРФЕЙС ЕСТЕСТВЕННО-ЯЗЫКОВЫЙ

Совокупность программных и аппаратных средств, обеспечивающих общие интеллектуальной системы с пользователем на ограниченном рамками проблемной области естественном языке. В состав И.Е.Я. входят словари, отражающие словарный состав и лексику языка, а также лингвистический процессор, осуществляющий анализ текстов (морфологический, синтаксический, семантический и прагматический) и синтез ответов пользователю.

ИНТЕРФЕЙС ИНТЕЛЛЕКТУАЛЬНЫЙ

Интерфейс, в который включены средства, позволяющие человеку вести общие с ЭВМ, не используя для ввода в ЭВМ специальные программы.

ИСКУССТВЕННЫЙ МОЗГ

Гипотетическое устройство, способное заменить мозг человека и (или) реализовать все функциональные свойства, известные о мозге. В искусственном интеллекте под И.М. понимают повторение искусственными средствами свойств, присущих мозгу.

ИСТОЧНИК ЗНАНИЙ

Текст, (инструкция, монография, фотография, кинолента и т.п.), наблюдение или сообщающий нужную информацию специалист-профессионал. Из И.З. черпается информация, преобразуемая в знания, фиксируемые в памяти интеллектуальной системы.

ИСЧИСЛЕНИЕ

Формальная система, задаваемая четверкой <Т,В,А,Р>, где Т - множество базовых символов исчисления; В - синтаксические правила, с помощью которых из элементов Т порождаются произвольные элементы; А - множество априорно истинных элементов исчисления (аксиомы исчисления); Р - множество семантических правил (правил вывода), с помощью которых из одних элементов системы порождаются другие.

ИСЧИСЛЕНИЯ ВЫСКАЗЫВАНИЙ

См. Исчисление пропозициональное.

ИСЧИСЛЕНИЕ ГЕНЦЕНА

Исчисление, в котором аксиомы задаются в виде секвенций.

ИСЧИСЛЕНИЕ ЛОГИЧЕСКОЕ

Объект изучения в математической логике, в основе которого лежит понятие формальной системы. В искусственном интеллекте используются различные И.Л.: исчисления предикатов, пропозициональное исчисление, исчисление классов, исчисление отношений, многосортные и многозначные логики и т.п.

ИСЧИСЛЕНИЕ ПРЕДИКАТОВ

Исчисление, в котором наряду с формулами исчисления высказываний используются формулы в которые могут входить отношения (предикаты), связывающие между собой группы элементов исчисления и кванторы общности и существования.

ИСЧИСЛЕНИЕ ПРЕДИКАТОВ ПЕРВОГО ПОРЯДКА

Исчисление предикатов, в котором под знаком квантора не могут находиться символы предикатов. (См. также Квантор общности, Квантор существования.)

ИСЧИСЛЕНИЕ ПРОПОЗИЦИОНАЛЬНОЕ

Формальная система, базовыми элементами которой являются высказывания - нерасчлененные предложения, относительно которых в каждый данный момент можно утверждать, что они являются либо абсолютно истинными, либо абсолютно ложными. И.П. изучает связи между этими высказываниями, которые задаются логическими связками: отрицанием, дизъюнкцией, конъюнкцией, импликацией и др. И.П. является аксиоматической системой, и для классического И.П. все аксиомы являются тождественно истинными высказываниями, а правила вывода не меняют этого свойства. С помощью И.П. порождаются все тождественно истинные высказывания и только они.

ИСЧИСЛЕНИЕ СИТУАЦИОННОЕ

Исчисление предикатов, в котором все или некоторые предикаты снабжены метками, привязывающими их к тем или иным ситуациям. Каждая ситуация задается описанием, в котором участвуют внеситуационные выражения, и те, которые связаны с данной ситуацией. В качестве аксиом И.С. используются обычные аксиомы ситуаций и характеристик этих ситуаций в той проблемной области, для которой И.С. используется . (См. также Управление ситуационное.)

КАРТА КОГНИТИВНАЯ

Способ описания известного субъекту фрагмента пространства с находящимися в нем заполнителями. Существует ряд вариантов К.К., отличающихся друг от друга сложностью и подробностью, например, карта-обозрение и карта-путь. С помощью К.К. изучается то, как человек воспринимает пространственные ситуации и отображает их в своей памяти. В интеллектуальных системах К.К. используются для отображения пространственных ситуаций в базах знаний и при работе с экспертами-профессионалами, когда инженер по знаниям получает от них информацию, связанную с пространственными ситуациями.

КАУЗАЦИЯ

Установление связи явлений или фактов. В строгой форме К. устанавливает причинно-следственные связи между явлениями или фактами. В более широком смысле К. устанавливает влияние одних явлений или фактов на другие. В этом более широком смысле К. отражает в моделях знаний в виде каузальных сетей и сценариев. При узком понимании К. в тех же моделях приводит к причинно-следственным сетям.

КВАНТИФИКАТОР

В узком смысле - это указатель на область истинности некоторого утверждения. Примерами К. в этом смысле могут служить лексемы: "всегда", "почти никогда", "для многих", "примерно в половине случаев" и т.д. В формальных системах, как правило, используются два квантификатора, называемых квантором общности и квантором существования. Первому соответствует лексема "всегда" и "для всех", а второму - "существует". В широком смысле К. может означать любое значение лингвистической переменной (например, "много", "часто", "далеко" и т.д.). Именно в таком смысле К. используются в псевдофизической логике и в ситуационном управлении.

КВАНТИФИКАЦИЯ

Приписывание оценок (в том числе, числовых) на выражения формальной системы. Эти оценки иногда называют квантофикаторами. Оценки могут характеризовать степень правдоподобия выражений, приоритетность при решении задачи и т.п.

КВАНТОР ОБЩНОСТИ

Специальный указатель на то, что некоторое содержащее переменные, распространяется на все формулы, получаемые при подстановке вместо переменных, перечисленных в этом указателе, любых значений из областей определения этих переменных. К.О. обозначает как где xi имена тех переменных, на которые распространяется его действие (связанные переменные).

КВАНТОР СУЩЕСТВОВАНИЯ

Специальный указатель на то, что некоторое P имеет место (или истинно) при некоторых переменных, перечисленных в этом указателе, причем конкретные значения, обеспечивающие это, не указываются, а фиксируется лишь то, что они существуют. Переменные, перечисленные в указателе, называются связанными. Стандартно К.С. обозначается как где xi - имена переменных, которые являются связанными.

КЛАССИФИКАЦИЯ

Введение отношений на множестве объектов или явлений, позволяющих разбить их на классы с установлением между классами отношений включения типа "род-вид", "элемент класс", "целое часть" и т.п. См. также Таксономия, Кластеризация.

КЛАСТЕРИЗАЦИЯ

Способ разбиения объектов или явлений на классы на основании некоторого отношения близости в пространстве признаков. См. также Таксономия, Классификация.

КЛАУЗА

См. Дизъюнкт.

КОГИТОЛОГИЯ

Раздел философии, изучающий проблемы, связанные с получением и использованием человеческих в процессе деятельности.

КОГНИТИВНАЯ НАУКА

Комплекс научных дисциплин (когнитивная психология, теория аргументации и др.), объединенных единым предметом исследования - отражением в познавательных структурах человека окружающей его действительности и исследованием механизмов рассуждения об этой действительности.

КОМПОНЕНТА ДЕКЛАРАТИВНАЯ

См. Знания декларативные.

КОНКАТЕНАЦИЯ

Операция приписывания одних элементов к другим так, что получается новый произвольный элемент. С помощью К., например, образуются из букв слова языка, из слов, знаков пунктуации и знака пробела - предложения.

КОНСТРУКТ КЕЛЛИ

Униполярный или биполярный признак, пара альтернатив, параметр, шкала или пара противоположных отношений личности к объекту или какой-либо его стороне. К.Л. используется в моде репертуарных решеток, разработанных Келли и его последователями для выявления тех субъективных представлений, которыми люди руководствуются в своей профессиональной и обыденной деятельности. Эти подходы к выявлению субъективных знаний используются в инженерии знаний при приобретении знаний у профессионалов для заполнения баз знаний экспертных систем.

КОНЦЕПТ

См. Понятие.

КОНЪЮКЦИЯ

Логическая операция (связка) для n>2 выражений. Результирующее выражение (конъюнкция исходных выражений) истинно только тогда, когда истинны все исходные выражения. Для обозначения К. стандартно используется знак & (реже), а также знак умножения в виде точки. Во многих случаях знак К. может быть опущен.

ЛИНГВИСТИКА ВЫЧИСЛИТЕЛЬНАЯ

См. Лингвистика компьютерная.

ЛИНГВИСТИКА КОМПЬЮТЕРНАЯ

Раздел лингвистики, задачей которого является исследование проблем, связанных с машинной обработкой текста: организацией естественно-языкового интерфейса, машинным переводом и реферированием, статистическим анализом словарей и текстов на ЭВМ, автоматическим распознаванием речи.

ЛИПС

Единица измерения производительности машины вывода (от англ. Logical Interence PerSecond), равная числу логических выводов, выполняемых в одну секунду. Как правило, для реализации одного логического вывода требуется от 10 до 100 команд ЭВМ.

ЛИТЕРА

Любая константа, переменная или ее отрицание.

ЛОГИКА

Наука о правильных способах рассуждений. В классическом варианте состоит из учения о понятиях, учения о суждениях и учения об умозаключениях. В течении долгого времени с Л. связывалось учение Аристотеля о силлогистических умозаключениях. Силлогистика была первой дедуктивной системой, возникшей в науке. В основе Л. лежит понятие аксиоматической системы. Сила чистой логики, отвлекающейся от семантики предметной области, состоит в общности ее методов и положений. Важно отметить, что Л. есть наука о мышлении в понятиях, а не о познании мира посредством мышления о понятиях. Это показывает, что в интеллектуальных системах чисто логические решатели задач не могут исчерпать весь запас средств, необходимых для воссоздания интеллектуальной деятельности. На основе Л. в конце XIX в. начала создаваться математическая логика, в основе которой лежит теоретико-множественные категории и понятие формальной системы.

ЛОГИКА ВЕРОЯТНОСТНАЯ

Логика, в которой формулы оцениваются значениями , интерпретируемыми как вероятности того, что данная формула принимает значение "Истина". С правилами вывода в Л.В. связываются процедуры, позволяющие вычислять вероятностную оценку истинности выводимой формулы по известным оценкам истинности для формул-посылок.

ЛОГИКА ВЕРЫ

Вид эпистимической логики, в которой все утверждения снабжаются квантификаторами, оценивающими степень правдоподобности этих утверждений.

ЛОГИКА ВРЕМЕННАЯ

Логика отношений, в которой отношения (предикаты) или специальные операторы характеризуют временные зависимости ("раньше", "будет", "одновременно" и т.д.). Другим типом Л.В. являются так называемые логики, в которых один из аргументов предиката есть время (состояние, ситуация).

ЛОГИКА ВТОРОГО ПОРЯДКА

Формальная система, в которой допускается, что кванторы общности и существования могут связывать не только индивидные переменные, но и предикатные или иные функциональные символы.

ЛОГИКА ДВОИЧНАЯ

Логика, в которой в качестве истинностных значений выражений рассматриваются лишь два значения: 0 и 1, интерпретируемые как абсолютная ложь и абсолютная истина.

ЛОГИКА ДЕЙСТВИЙ

Система рассуждений о закономерностях действий в некоторой проблемной среде. Л.Д. опирается на временную логику и пространственную логику, а также на свойства конкретной среды. Л.Д. используется в интеллектуальных работах и экспертных системах. Для Л.Д. характерны немонотонные выводы.

ЛОГИКА ДЕОНТИЧЕСКАЯ

Общее название для логики норм, описывающей нормативное прогнозируемое поведение, и логики оценок, в которой описываются оценочные характеристики для различных утверждений. Используется при организации поведения интеллектуальных систем.

ЛОГИКА ДИНАМИЧЕСКАЯ

Система рассуждений, в явной форме учитывающая динамику объектов, к которым прилагаются эти рассуждения. Если время входит в рассуждение в явной форме, то Л.Д. совпадает с одним из вариантов временной логики. Если динамика задается законами смены ситуаций, то Л.Д. превращается в ситуационное исчисление. Л.Д. используется для моделирования функционирования открытых систем, в частности, открытых баз данных и баз знаний, а также во всех интеллектуальных системах, имеющих дело с динамической моделью мира.

ЛОГИКА ЗДРАВОГО СМЫСЛА

Совокупность рассуждений имеющая хождение в быту и отражающая систему ценностей, мотивы поступков и цели людей. В интеллектуальных системах Л.З.С. используется в тех случаях, когда при воспроизведении деятельности эксперта-профессионала нет возможности построить формальную систему, в которую можно было бы погрузить процедуры рассуждений этого эксперта.

ЛОГИКА ИНДУКТИВНАЯ

Формальная система, описывающая правила формирования общих утверждений на основе конечного множества частных утверждений. В Л.И. все утверждения взвешиваются оценками правдоподобности, характеризующими истинность этих утверждений.

ЛОГИКА ИНТУИЦИОНИСТСКАЯ

Логика, используемая в формальных системах, которые опираются не на классические конструкции, восходящие к теории множеств. а на умозрительные конструкции. В рассуждениях об этих конструкциях оказываются неприменимыми закон снятия двойного отрицания и закон исключенного третьего. Л.И. широко используется при доказательстве теорем на ЭВМ и в решателях интеллектуальных систем.

ЛОГИКА КАУЗАЛЬНАЯ

Логика, в которой отношения характеризуют типы связей, совпадающие с причинно-следственными или близкие к ним по содержанию.

ЛОГИКА КОМАНД

Логика, в которой в качестве операторов используются различные императивы. Близка к логике действий. Используется в интеллектуальных роботах и других интеллектуальных системах.

ЛОГИКА КОНСТРУКТИВНАЯ

Логика, в которой разрешены лишь конструктивные доказательства. ( ) Л.К. лежат в основе конструктивной математики, тесно связанной с проблемами вычислимости на ЭВМ и других устройствах, имеющих ограниченную память.

ЛОГИКА МАТЕМАТИЧЕСКАЯ

Логика, основанная не на содержательной стороне высказываний, а на синтаксических категориях и их структурных (операционных) связях. В основе Л.М. лежит понятие формальной системы. Различные интерпретации формальной системы приводят к различным логическим исчислениям. Наиболее известным из которых являются пропозициональное исчисление (исчисление высказываний), исчисление предикатов, ситуационное исчисление, многозначные логики и т.п.

ЛОГИКА МНОГОЗНАЧНАЯ

Логика, в которой в качестве значений истинности переменных выступают натуральные числа 0,1,...,k.

ЛОГИКА МОНОТОННАЯ

Логика замкнутого мира, эквивалентная некоторой формальной системы. В Л.М. действует принцип монотонности: если на некотором шаге вывода получено утверждение, то его истинность на последующих шагах вывода не может изменяться.

ЛОГИКА НЕМОНОТОННАЯ

Логика открытого мира. В Л.Н. нарушается основной принцип монотонной логики. Если на некотором шаге вывода получено утверждение, то при поступлении в систему новой информации (новых фактов) истинность этого вывода может исчезнуть. Л.Н. характерны для большинства интеллектуальных систем, имеющих дело со сложными предметными областями, для которых получить априорно исчерпывающее замкнутое описание не представляется возможным.

ЛОГИКА НЕЧЕТКАЯ

Логика, в которой используются нечетные квантификаторы, чаще всего нечеткие квантификаторы лингвистической переменной "частота": "почти никогда", почти всегда". Рассуждения с подобными квантификаторами требуют специальных приемов для нахождения квантификатора, который должен быть приписан заключению, когда посылки помечены определенными квантификаторами.

ЛОГИКА НОРМ

См. Логика деонтическая.

ЛОГИКА ОЦЕНОК

См. Логика деонтическая.

ЛОГИКА ПЕРВОГО ПОРЯДКА

Формальная система, в которой кванторы общности и существования могут связывать только индивидуальные переменные, но не могут связывать символы предикатов или иных функциональных символов.

ЛОГИКА ПРОПОЗИЦИОНАЛЬНАЯ

Логика, характерная для пропозиционального исчисления.

ЛОГИКА ПРОСТРАНСТВЕННАЯ

Формальная система, в которой использованы аксиомы, характерные для описания возможных расположений объектов в трехмерном (или двумерном) пространстве, расстояний между ними и локов. Л.П. позволяют проводить рассуждения о пространственном расположении и взаимосвязи объектов для случая абсолютной и относительной системы координат и для случая, когда такие переменные, как расстояние, размер лока или характеристики взаимного расположения предметов, заданы в виде лингвистических переменных. В Л.П. выделяют логику расстояний и логику взаимного положения предметов в метрическом и топологическом (размытом) вариантах.

ЛОГИКА ПСЕВДОФИЗИЧЕСКАЯ

Логика, отражающая восприятие субъектом или искусственной системой закономерностей внешней физической среды. Особенностью Л.П. является наличие размытых шкал, на которые проецируются объекты, с которыми имеет дело логика. Примерами Л.П. являются временная логика, пространственная логика, логика действий и др.

ЛОГИКА РАЗМЫТАЯ

См. Логика нечеткая.

ЛОГИКА РАССУЖДЕНИЙ ПО УМОЛЧАНИЮ

Рассуждения, в которых при отсутствии явной информации, необходимой для продолжения рассуждений, интеллектуальная система или человек обращаются к своей памяти и используют содержащуюся в ней информацию, предназначенную для тех случаев, когда нужная информация отсутствует. Введение механизма умолчаний приводит к тому, что Л.Р.У. становится немонотонной логикой. Л.Р.У. широко используется в открытых базах данных и базах знаний.

ЛОГИКА ЭПИСТЕМИОЛОГИЧЕСКАЯ

Формальная система, в которой используются операторы типа "знает", "хочет", "верит" и т.п.

ЛОК

Ограниченная часть пространства, в котором полностью помещается некоторый объект, чьи внешние границы совпадают с границами Л. Понятие Л. используется в пространственной логике.

ЛОКУЦИЯ

Одна из составляющих речевого акта - собственное говорение, характеризуемое дикцией, скоростью речи, ее правильностью и т.п., без учета намерений говорящего и достигаемого при этом эффекта. Две другие составляющие - иллокуция и перлокуция.

"ЛЯМБДА" - ИСЧИСЛЕНИЕ

Исчисление, в котором используется операция функциональной абстракции (конверсии) xM, задающая функцию, значения которой для любого аргумента получаются подставной этого аргумента вместо x во все его вхождения в М. Такие исчисления широко применяются в формальных моделях баз данных.

МАШИНА АБСТРАКТНАЯ

Теоретическая конструкция, в которой отражаются все формальные аспекты функционирования некоторого реального или гипотетического устройства. Примерами М.А. могут служить конечный автомат, машина Поста, машина Тьюринга и многие другие модели, изучаемые в математике, кибернетике, искусственном интеллекте и других науках.

МАШИНА БАЗ ДАННЫХ

Блок управления базой данных в информационных системах. Специализированный процессор с собственной памятью, выполняющий обработку запросов.

МАШИНА БАЗ ЗНАНИЙ

Блок управления базой знаний в машине пятого поколения. Специализированный процессор (система процессоров), выполняющий обработку запросов и формирование ответов в некоторой предметной области на основе использования совокупностей фактов и знаний о предметной области, представляемых в виде правил, а также механизмов вывода.

МАШИНА ВИРТУАЛЬНАЯ

Абстрактная машина (комплекс программных средств), с помощью которой для пользователя имитируется гипотетическая ЭВМ, обладающая практически неограниченной оперативной памятью и расширяемым набором команд. М.В. использует для имитации конечную оперативную память и базовый набор команд.

МАШИНА ПАРАЛЛЕЛЬНОГО ВЫВОДА

Специализированный процессор (система процессоров), реализующий параллельно основные операции, характерные для вывода на знаниях.

МАШИНА ПОСТА

Абстрактная машина, состоящая из бесконечной в обе стороны ленты, разделенной на клетки, и управляющей головки. Клетки ленты могут быть пустыми или отмеченными специальным символом. Вдоль клетки перемещается управляющая головка. За один такт работы М.П. выполняет одну из шести базовых команд: сдвиг управляющей головки на одну клетку влево, аналогичный сдвиг на одну клетку вправо, вписывание отмечающего символа в пустую клетку, условный переход и остановку. Из последовательности перенумерованных натуральными числами таких команд образуются программы функционирования М.П. Перед началом работы М.П. необходимо заполнить нужные клетки ленты отмечающими символами и расположить управляющую головку против некоторой клетки. После этого М.П. будет выполнять команду программы с номером один. Если это не команды сдвига или прекращения работы, то следующая выполняемая команда программы после данной определяется специальными указателями (отсылками), входящими в каждую команду записи и стирания отмечающих символов. В команде условного перехода выбор новой команды зависит от того, содержит обозреваемая в этом такте работы клетка пустоту или она отмечена символом. В зависимости от ситуации происходит переход к программе указанной в команде условного перехода. М.П. по результатам работы эквивалентна машине Тьюринга, но функционирование ее более медленное. Как и машина Тьюринга, М.П. служит для уточнения интуитивного понятия алгоритма.

МАШИНА СВЯЗЕЙ

Компьютер, состоящий из десятков и сотен тысяч параллельно работающих процессоров. Конструкция М.С. позволяет любому процессору связываться с любым другим процессором подобно абонентам телефонной станции. Быстродействие М.С. достигает десятков миллиардов операций в секунду.

МАШИНА ТЬЮРИНГА

Абстрактная машина, состоящая из бесконечной в одну сторону ленты, разделенной на клетки, и управляющей головки, которая может передвигаться вдоль ленты. Символы входного алфавита, включающие пустой символ, могут размещаться на ленте по одному в клетке. Управляющая головка может находится в одном из конечного числа внутренних состояний, один из которых является особым. Оно соответствует выключению М.Т. Каждый шаг работы состоит в том, что управляющая головка по паре (наблюдаемый символ в клетке ленты, против которой находится управляющая головка; - внутреннее состояние головки) вырабатывает тройку (новое содержимое клетки - новое внутреннее состояние головки - сдвиг головки на одну клетку влево или вправо или сохранение положения головки). Работа М.Т. заканчивается, когда управляющая головка переходит в состояние конца работы. Начальное заполнение ленты и начальное положение управляющей головки вместе с ее начальным состоянием задаются извне. Действия М.Т. на каждом шага определяются конечной таблицей, размер которой соответствует числу символов внешнего алфавита и числу внутренних состояний головки. М.Т. является моделью универсального вычислительного процесса, так как можно построить универсальную М.Т., которая будет имитировать работу любой конкретной М.Т. В этом смысле универсальная М.Т. может рассматриваться как математическая модель ЭВМ, построенной по традиционной архитектуре. М.Т. является одним из возможных уточнений понятия известным в дискретной математике. Языки, порождаемые в результате работы М.Т., называются рекурсивно-перечисленними.

МАШИНА, УПРАВЛЯЕМАЯ ПОТОКОМ ДАННЫХ

См. Архитектура потоковая.

МАШИННЫЙ ИНТЕЛЛЕКТ

См. Интеллект искуственный.

МЕНЮ

Способ организации интерфейсов, базирующихся на перечислении альтернатив и поддержке возможности выбора нужной из них с помощью курсора и/или явным указанием ее названия.

МЕРА ПРАВДОПОДОБИЯ

Оценка истинности события или факта, значение которой получается дополнением до единицы значения функции доверия.

МЕТАЗНАНИЕ

Знание интеллектуальной системы о знаниях, которой хранятся в ее базе знаний, или о процедурах, которые можно совершать с хранящимися в базе знаний. Введение М. - процесс рекурсивный. М. в текстах на естественном языке может быть соответственно с фразами типа "Я знаю, что Иванов не умеет плавать" или "Сидоров предполагал, что Петров не знает алгебру".

МЕТАПРОДУКЦИЯ

Продукция, включаемая в систему продукций для указания порядка выполнения продукций, входящих в список готовых продукций.

МЕТАФОРА

Перенесение свойств одного предмета (явления) на другой на основании признака, общего для обоих сопоставляемых предметов ("говор волн", "брожение умов")

МЕТАЯЗЫК

Язык для описания других языков. Чаще всего метаязык использует нотацию, в которой собственные символы описываемого языка являются терминальными символами метаязыка.

МЕТОД ВЕТВЕЙ И ГРАНИЦ

Способ решения задач целочисленного линейного программирования и поисковых задач на древообразных структурах, использующий эвристические правила отсечения вариантов поиска на основании локальных оценок целесообразности дальнейшего поиска в данном направлении, формируемых в процессе реализации метода.

МЕТОД ИНТЕРВЬЮ

В инженерии знаний прием, с помощью которого добываются знания у экспертов-профессионалов. Инженер по знаниям выступает в роли репортера, берущего интервью. Он задает вопросы, цель которых уточнить сведения, сообщаемые экспертом относительно предметной области, в которой эксперт работает. Существуют специальные приемы, которые входят в стандартный М.И., делающий беседу целенаправленной и эффективной.

МЕТОД ОБРАТНОЙ ВОЛНЫ

См. Поиск нисходящий.

МЕТОД ПРЯМОЙ ВОЛНЫ

См. Поиск восходящий.

МЕХАНИЗМ ВЫВОДА

Совокупность правил вывода и стратегии управления выводом (применения этих правил). Крайним случаем М.Б. может быть произвольное применение правил вывода, как это делается в логических исчислениях.

МЕХАНИЗМ НАСЛЕДОВАНИЯ

Прием, используемый в базах знаний. Заключается в том, что на множестве информационных единиц вводятся классифицирующие отношения типа "класс-элемент", "род-вид" и т.п. При этом информация, относящаяся ко всем элементам класса или ко всем видам рода, содержится соответственно в описании класса или рода, а подчиненные им информационные единицы наследуют эту информацию, когда это необходимо.

МИМД-АРХИТЕКТУРА

Архитектура вычислительной системы с несколькими одинаковыми или разными параллельно работающими процессорами, каждый из которых выполняет свои команды над своими данными.

МНОЖЕСТВО НЕЧЕТКОЕ

Множество, характеристическая функция которого может принимать значения из отрезка [0,1]. Значение характеристической функции для некоторого элемента характеризует степень принадлежности этого элемента к множеству.

МОДЕЛЬ

Объект (реальный, знакомый или воображаемый), отличный от исходного, но способный заменить его и в рамках решаемых задач.

МОДЕЛЬ АССОЦИАТИВНАЯ

Модель процесса решения задачи человеком, опирающаяся на процедуру установления сходства данной задачи (или составляющих ее подзадач) с задачами, решение которых уже известно.

МОДЕЛЬ ВЫЧИСЛИТЕЛЬНАЯ

Описание процедур решения задач в некоторой предметной области. В М.В. задается полная структура функциональных связей для элементов предметной области, связанных между собой соотношениями, позволяющими находить значения одних элементов через другие. Задание исходных целевых элементов приводит к поиску в М.В. путей, ведущих от исходных элементов к целевым. Если хотя бы один такой путь существует, то по нему строится программа решения поставленной задачи. М.В. обеспечивают автоматический синтез программ.

МОДЕЛЬ ЗАМКНУТАЯ

Модель, остающаяся неизменной при работе с ней. В процессе функционирования интеллектуальной системы М.З. в отличие от открытой модели нельзя добавлять новые факты и закономерности. Все утверждения, полученные в М.З. окончательны и абсолютны.

МОДЕЛЬ ЗНАНИЙ

Описание знаний в базе знаний. Известны четыре типа М.З.: логические, в основе которых лежит формальная модель; сетевые, в основе которых лежит семантическая сеть; фреймовые, основанные на фреймах ; продукционные, основанные на продукциях. Каждая такая М.З. определяет форму представления знаний.

МОДЕЛЬ КОГНИТИВНАЯ

Гипотетическая модель, описывающая устройство когнитивной структуры (структуры знаний у человека). Для интеллектуальных систем М.К. совпадает с моделью знаний.

МОДЕЛЬ КОНЦЕПТУАЛЬНАЯ

Модель предметной области из перечня всех понятий, используемых для описания этой области, вместе с их свойствами и характеристиками, классификаций этих понятий по типам, ситуациям, признакам в данной области и законами функционирования процессов, протекающих в ней. М.К. строится при погружении описания предметной области в базу знаний интеллектуальной системы.

МОДЕЛЬ КРИПКЕ

Одна из моделей логической семантики, используемая в искусственном интеллекте. В основе М.К. лежит представление о множестве возможных миров, каждый из которых задается формальной системой. Переход из одного возможного мира в другой в рамках М.К. осуществляется с помощью специального отношения, свойства которого могут варьироваться.

МОДЕЛЬ ЛАБИРИНТНАЯ

Модель, в рамках которой процесс решения задач человеком объясняется аналогией с движением по лабиринту. Площадки лабиринта соответствуют промежуточным результатам (часть площадок отмечена как целевые), а передвижение от площадки к площадке происходит за счет использования преобразований из заданного набора. В М.Л. решение задачи - это поиск пути от начальной площадки лабиринта к одной из целевых. При этом лабиринт считается полностью заданным. (См. также Модель реляционная.)

МОДЕЛЬ ЛИНГВИСТИЧЕСКАЯ

1. Модель, относящаяся к фиксации тех или иных знаний о естественном языке.
2. Описание объекта в терминах лингвистических переменных и рассуждений о них.

МОДЕЛЬ ЛОГИКО-ЛИНГВИСТИЧЕСКАЯ

Модель, основанная на расширении формальной системы, в рамках которой вводятся процедуры изменения всех или части элементов формальной системы в зависимости от решаемых задач. М.Л.Л. часто используется как способ задания модели Крипке.

МОДЕЛЬ ЛОГИЧЕСКАЯ

Модель представления знаний, в основе которой лежит формальная система.

МОДЕЛЬ МИРА

Способ отображения в памяти интеллектуальной системы знаний о внешней среде. (См. также Модель знаний, Схема концептуальная.)

МОДЕЛЬ ОБУЧЕНИЯ

Модель, лежащая в основе процесса обучения человека или технического устройства. Различают два типа М.О. - дескриптивный и нормативный. Дескриптивный М.О. извлекается из описания процесса деятельности, которой человек или система должны обучаться. Это извлечение может происходить разными способами. Наиболее известный из них основан на процедуре обучения на примерах. Нормативная М.О. задается заранее. Часто обучение нормативного типа называют обучением с учителем.

МОДЕЛЬ ОБЩЕНИЯ

Описание совокупности знаний о том, как организуется общение между пользователем и интеллектуальной системой. Обычно в М.О. входит модель пользователя и модель течения диалога. Если общение происходит на профессиональном естественном языке, то для построения модели пользователя используются результаты, полученные в теории речевых актов. В других случаях могут быть применены процедуры обмена графической информации через экран дисплея.

МОДЕЛЬ ОТКРЫТАЯ

Модель, в которую в процессе функционирования интеллектуальной системы можно добавить новые факты и закономерности.

МОДЕЛЬ ПОВЕДЕНИЯ

Модель (техническая или программная), воспроизводящая некоторые виды поведения объектов при определенных условиях внешней среды (преодоление препятствий, реакция на внешние воздействия, выбор решений и пр.). М.П. используется как при изучении реального поведения биологических систем и человека, так и при разработке интеллектуальных роботов (планирования их автоматного поведения).

МОДЕЛЬ ПОЛЬЗОВАТЕЛЯ

Совокупность знаний об особенностях работы пользователя с системой, его намерениях, целях и требованиях, которая хранится в памяти интеллектуальной системы. М.П. помогает системе организовать эффективный диалог с пользователем, создает ему психологический комфорт.

МОДЕЛЬ РЕЛЯЦИОННАЯ

Модель описания данных, в которой все отношения задаются строками таблиц, столбцы которых помечены именами атрибутов. Табличное представление данных оказывается часто удобным. Это обеспечило широкое распространение реляционных баз данных. В основе М.Р. лежит специальное исчисление предикатов.

МОДЕЛЬ СЕТЕВАЯ

Модель представления знаний, в основе которой лежит семантическая сеть.

МОДЕЛЬ СИТУАЦИЙ

Классификационная модель, которая позволяет опознавать текущие ситуации как известные системы. М.С. используется, например, в ситуационном управлении.

МОДЕЛЬ СОЗНАНИЯ

В искусственном интеллекте - совокупность процедур и декларативных описаний, с помощью которых в интеллектуальных системах имитируется та часть сознательной деятельности человека, которая поддается вербализации. В психологии термин "сознание" трактуется более широко. В него включаются, например, способность субъекта, обладающего сознанием , к самонаблюдению (самосознанию), рефлексии и активности.

МОДЕЛЬ СТИМУЛ-РЕАКЦИЯ

Модель поведения, опирающаяся на принцип черного ящика. В М.С.Р. рассматриваются конечное множество стимулов, которые могут восприниматься субъектом или подаваться на выход искусственной системы, и правила соотнесения этим стимулам реакций, выдаваемых субъектом или системой. Внутренние процессы, связывающие стимулы и реакции, не анализируются и не учитываются. М.С.Р. находит применение в интеллектуальных системах на уровне воспроизведения простейших поведенческих реакций на раздражения, поступающие из внешней среды.

МОДЕЛЬ ТЕЧЕНИЯ ДИАЛОГА

Часть модели общения, представляющая собой описание видов и структур диалога, которые имеются в распоряжении интеллектуальной системы и которые может использовать пользователь в ходе общения с данной интеллектуальной системой. М.Т.Д. задается в виде либо жестких правил, либо автоматной грамматики, либо сценария. (См. также Модель пользователя.)

МОДЕЛЬ ФОРМАЛЬНАЯ

Формальное описание на некотором логическом языке структуры объекта. (См. также Система формальная.)

МОДЕЛЬ ЯЗЫКА

В лингвистике - формализованное представление знаний о языке. Как правило, включает морфологический, синтаксический, семантический и прагматический компоненты, которые также могут разделяться на более дробные компоненты.

МОДУС ПОНЕНС

Правила вывода, в логике которое утверждает: "Если выведены A и A®B, то B выводимо".

МОДУС ТОЛЛЕНС

Правило вывода в логике, которое утверждает: "Если верно A и BA, то верно B". Это правило используется в методе резолюций.

МОНОТОННОСТЬ ПРИ ВЫВОДЕ

Свойство, характерное для вывода в замкнутой формальной системе и в закрытой базе знаний и состоящее в том, что ранее выведенные утверждения не теряют истинности при расширении множества посылок для вывода.

НАСЛЕДОВАНИЕ

Свойство, используемое в базах данных и знаний и заключающееся в том, что если две информационные единицы соединены между собой отношениями типа "род-вид" или "класс-элемент", то информация, общая для всех видов, входящих в род, или для всех элементов, входящих в класс, содержится в информационной единице более высокого уровня и при необходимости наследуется единицей более низкого уровня. Н. позволяет ликвидировать дублирование в хранении информации в базах данных и знаний.

НЕЙРОБИОНИКА

Направление в исследованиях по искусственному интеллекту для которого характерно использование для воспроизведения в интеллектуальных системах процессоров, присущих биологическим объектам, структур и функций, аналогичных структурам и функциям этих объектов. В рамках этого направления были созданы формальные модели нейронов, на основе которых строятся сети, позволяющие решать задачи распознавания образов, классификации, стимул-реактивного поведения и т.п. Усложнение структур формальных нейронов приводит к структурам, обладающим широкими функциональными возможностями. Их часто называют нейрокомпьютерами. Примерами нейробионического устройства может служить перцептрон.

НЕЙРОКОМПЬЮТЕР

См. ЭВМ нейробионические.

НЕЙРОН ФОРМАЛЬНЫЙ

Элемент, работа которого описывается функцией
      /
     | 0 при S AiXi - S BiZi < h
y = <
     | 1 при S AiXi - S BiZi >= h
      \
Здесь y -двоичный выход; Xi -разрешающие двоичные входы; Zi-запрещающие двоичные входы; ai и bi - весовые коэффициенты; h порог. Варьируя значения весовых коэффициентов и порога, можно с помощью Н.Ф. реализовать любую булеву функцию. В Н.Ф. входы ассоциируются с синапсами нейрона, а выход - с его аксоном. Н.Ф. функционирует не так , как биологический нейрон (не учитывается время релаксации, латентный период, который всегда наступает после срабатывания нейрона и в течении которого он не может воспринимать входных сигналов). Но именно такая модель используется при конструирования многих устройств, разрабатываемых в нейробионике (например, перцептронов).

НЕМОНОТОННОСТЬ ПРИ ВЫВОДЕ

Свойство, характерное для вывода в открытой формальной системе и в открытой базе знаний и состоящее в том, что ранее выведенные утверждения могут перестать быть выводимыми при появлении новых фактов.

НЕОПРЕДЕЛЕННОСТЬ

Свойство интерпретации выражений, когда им приписываются оценки правдоподобия, отличные от абсолютной истины и лжи. Работа с такими выражениями требует специальных средств пересчета оценок правдоподобия. При логическом выводе, когда имеется неопределенность, используются либо многозначные логики, либо правдоподобные рассуждения.

НЕОПРЕДЕЛЕННОСТЬ ЛИНГВИСТИЧЕСКАЯ

Неопределенность, возникающая из-за расплывчатости и неоднозначности словесных выражений. При описании качественных знаний приходится применять специальные приемы для устранения Н.Л. (См. также Множество нечеткое, Функция принадлежности, Переменная лингвистическая.)

НЕПОЛНОТА

Свойство описания предметной области, заключающееся в том, что это описание не может быть преобразовано в формальную систему. При работе с неполной информацией используются правдоподобные рассуждения или рассуждения по умолчанию.

НЕРАЗРЕШИМОСТЬ АЛГОРИТМИЧЕСКАЯ

Ситуация, при которой для множества однотипных задач нельзя найти общего алгоритма, решающего их, хотя для подмножеств этого множества можно построить специфические алгоритмы поиска решения. Существование таких алгоритмически неразрешимых проблем строго доказано.

НОВАЯ ИНФОРМАЦИОННАЯ ТЕХНОЛОГИЯ

Технология обработки информации и решения задач с помощью ЭВМ, опирающейся на достижения искусственного интеллекта. Основной идеей, используемой в НИТ, является автоматизация процедуры построения программы, интересующей пользователя, на основании введенного им в систему описания постановки задачи на привычном для него профессиональном языке. Таким образом, Н.И.Т. обеспечивает возможность общения с ЭВМ пользователя, который не является профессиональным программистом. Для того чтобы была реализована основная идея Н.И.Т., необходимо, чтобы ЭВМ обладала интеллектуальным интерфейсом, базой знаний и решателем, т.е. была бы интеллектуальной системой. Другой чертой Н.И.Т. является распределенный способ решения задачи, когда пользователи, занятые решением общей задачи, общаются между собой через сеть ЭВМ, электронную почту и общую базу знаний. В сеть входят также базы данных, из которых пользователи черпают информацию для решения своей задачи.

ОБЛАСТЬ ПРЕДМЕТНАЯ

Совокупность реальных или абстрактных объектов (сущностей), связей и отношении между этими объектами, а также процедур преобразования этих объектов для решения задач возникающих в О.П.

ОБЛАСТЬ ПРЕДМЕТНАЯ, ПЛОХО СТРУКТУРИРОВАННАЯ

Предметная область, концептуальная модель которой не может быть погружена в формальную систему или совокупность формальных систем. Большинство предметных областей, с которыми приходится иметь дело в интеллектуальных системах, являются плохо структурированными.

ОБЛАСТЬ ПРЕДМЕТНАЯ, ХОРОШО СТРУКТУРИРОВАННАЯ

Предметная область, концептуальная модель которой может быть погружена в формальную систему.

ОБЛАСТЬ ПРОБЛЕМНАЯ

См. Область предметная.

ОБОБЩЕНИЕ ЗНАНИЙ

Совокупность приемов и методов, позволяющих в базах знаний вводить новые знания, получаемые из имеющихся за счет кластеризации, введения гиперсобытий и гипотез.

ОБОБЩЕНИЕ ИНДУКТИВНОЕ

Процесс выработки гипотезы, с помощью которой описывается общая закономерность, связывающая воедино разрозненные знания, выступающие как частные случаи этой закономерности.

ОБОЛОЧКА

Инструментальное средство для проектирования и создания экспертных систем. В состав О. входят средства проектирования баз знаний с различными формами представления знаний и выбора режима работы решателя задач. Для конкретной предметной области инженер по знаниям определяет нужное представление знаний и стратегии решения задач, а затем, вводя их в О., создает конкретную экспертную систему.

ОБОСНОВАНИЕ

Одна из функций интеллектуальной системы, заключающаяся в доказательстве или проверке того, что полученное системой решение не противоречит знаниям, которые хранятся в памяти системы. Таким образом, О. является относительным. При изменении содержимого базы знаний или базы данных. О. может либо сохранить свою силу, либо стать неверным. Обычно О. тесно связано с объяснением. К О. близко понятие аргументации.

ОБРАБОТКА ЕСТЕСТВЕННОГО ЯЗЫКА

Совокупность процессов анализа текстов на естественном языке, их понимания и синтеза текстов. В процессе анализа в наиболее развитых системах обработки естественно-языковых сообщений происходит морфологический, синтаксический и семантический анализ текста, в результате чего выявляется глубинная структура текста, которая переводится во внутреннее представление, используемое в базе знаний интеллектуальной системы. Соотнесение этой структуры с теми знаниями, которые хранятся в системе, позволяет понять смысл исходного текста. При синтезе текстов сначала формируется семантическая структура текста, которая затем наполняется лингвистическими единицами с учетом синтаксиса и морфологии выбранного естественного языка. С О.Е.Я. связано решение задач машинного перевода, автоматического реферирования, общения с пользователем на ограниченном профессиональном естественном языке и т. п.

ОБРАБОТКА ИЗОБРАЖЕНИЙ

Процесс, связанный с обработкой визуальной информации (изменение масштабов, выделение контуров, распознавание видимых и невидимых частей изображения и т. п.).

ОБРАБОТКА ПАРАЛЛЕЛЬНАЯ

Способ решения задачи, при котором выделенные из нее подзадачи выполняются одновременно. За счет специально организованного взаимодействия процессов решения подзадач в конце О.П. получается решение исходной задачи.

ОБРАБОТКА СИГНАЛОВ

Совокупность процедур, используемых при обработке изображений, особенностью которых является то, что они оперируют данными, представляющими собой содержимое одного двоичного разряда.

ОБРАЗ

Изображение типичного или обобщенного представителя некоторого класса объектов.

ОБРАЗЕЦ

Фрагмент знаний, по которому осуществляется поиск по образцу, или эталон, по которому происходит классификация изображений, ситуаций, правил и т. п.

ОБУЧЕНИЕ

Усвоение знаний, умений и навыков путем или получения и восприятия информации от учителя или обработки наблюдаемой информации с последующим построением на основе этих наблюдений новых общих правил и закономерностей. Обе формы О. используются в интеллектуальных системах для приобретения новых знаний.

ОБУЧЕНИЕ НА ПРИМЕРАХ

Вид обучения, при котором индивиду или интеллектуальной системе предъявляется набор положительных и отрицательных примеров, связанных с какой-либо заранее неизвестной закономерностью. В интеллектуальных системах вырабатываются решающие правила, с помощью которых происходит разделение множества примеров на положительные и отрицательные. Качество разделения, как правило, проверяется экзаменационной выборкой примеров. Если качество разделения на экзаменационной выборке оказывается удовлетворительным, то выработанные решающие правила принимаются системой как окончательные. Если экзамен оказался неудовлетворительным, то экзаменационная выборка добавляется к обучающей и строятся новые решающие правила. После этого процесс экзамена повторяется.

ОБЩЕНИЕ

Процесс установления и развития контакта между людьми, порождаемый потребностью в совместной деятельности и включающий обмен информацией, выработку единой стратегии взаимодействия и восприятие и понимание друг друга. В расширительном смысле понятие О. распространяется на контакт человека с ЭВМ, в ходе которого решается некоторая задача.

ОБЪЕДИНЕНИЕ СВИДЕТЕЛЬСТВ

Процедура объединения в обобщенную гипотезу ряда гипотез, снабженных своими коэффициентами правдоподобия.

ОБЪЯСНЕНИЕ

Одна из функций интеллектуальной системы. О. предоставляет пользователю информацию о том, как интеллектуальная система получила выданное пользователю решение. В отличие от обоснования О. опирается лишь на тот маршрут, который сохранился в памяти системы от процесса поиска решения. Используя этот маршрут, интеллектуальная система формирует пользователю О. на профессиональном естественном языке, позволяющее ему представить все принципиальные шаги решения.

ОГРАНИЧЕНИЕ ЦЕЛОСТНОСТИ

Ограничения, налагаемые на совокупность информационных единиц, хранящихся в базах данных и базах знаний. Эти ограничения должны выполнятся в любых состояниях, которые определяются текущим содержимым базы знаний и базы данных.

ОЖИВЛЕНИЕ

См. Графика динамическая.

ОПРАВДАНИЕ

Одна из функций интеллектуальной системы. С помощью О. некоторое решение системы обосновывается не путем логических рассуждений или обращения к имеющимся в системе знаниям а путем обращения к имеющийся в системе ценностной структуре. О. убеждает в том, что данное решение не противоречит этой ценностной структуре. (См. также Объяснение, Обоснование.)

ОТЛАДКА БАЗЫ ЗНАНИЙ

Поиск ошибок в базе знаний интеллектуальной системы. Различают синтаксическую отладку и семантическую отладку базы знаний.

ОТЛАДКА СЕМАНТИЧЕСКАЯ

Нахождение в программе смысловых ошибок. О.С. осуществляется путем выполнения на ЭВМ тестируемой программы с такими исходными данными, для которых правильное решение заранее известно.

ОТЛАДКА СИНТАКСИЧЕСКАЯ

Идентификация ошибок в программе на языке представления знаний, осуществляемая автоматически синтаксическим анализатором.

ОТНОШЕНИЕ

Задание на множестве М декартова произведения М' * M' M. Пары, входящие в M' * M'', являются элементами О., а совокупность этих пар образует график О. или его экстенсионал. О. может обладать рядом внутренних (рефлексивностью, симметричностью и т. п.) и некоторой внешней семантикой, связанной с его именем. Вся эта информация образует семантику О. или его интенсионал.

ОТНОШЕНИЕ АНТИРЕФЛЕКСИВНОЕ

Термин объясняется в статье Отношение рефлексивное.

ОТНОШЕНИЕ АНТИСИММЕТРИЧНОЕ

Термин объясняется в статье Отношение симметричное.

ОТНОШЕНИЕ АНТИТРАНЗИТИВНОЕ

Термин объясняется в статье Отношение транзитивное.

ОТНОШЕНИЕ ВИРТУАЛЬНОЕ

Отношение в явной форме не присутствующее в базе знаний, но определяемое из тех отношений, которые имеются в базе.

ОТНОШЕНИЕ ВРЕМЕННОЕ

Отношение, с помощью которого описываются связи факторов, событий и явлений во времени. Примерами О.В. могут служить "быть раньше", "одновременно", "заканчиваться одновременно" и т. п. О.В. используются во временных логиках, логиках действий и других псевдофизических логиках.

ОТНОШЕНИЯ ДЕЙСТВИЯ

Отношения, с помощью которого описываются действия, происходящие в реальном мире. Примерами О.Д. могут служить: "двигаться к", "приближаться", "воздействовать" и т. п. О.Д. используются в логиках действий, являющихся видом псевдофизических логик.

ОТНОШЕНИЕ ИНТЕНСИОНАЛЬНОЕ

Отношение на множестве утверждений, относящихся к интенсиональной составляющей знаний о проблемах области.

ОТНОШЕНИЕ КАУЗАЛЬНОЕ

Отношение, с помощью которого описываются различные виды причинно-следственных связей между объектами.

ОТНОШЕНЕ МОДЕЛИРОВАНИЯ НЕЧЕТКОЕ

Отношение, задаваемое специальной коммутативной диаграммой, связывающей элементы и операции одного множества с элементами и операциями другого множества с помощью операторов, характерных для размытой логики.

ОТНОШЕНИЕ НЕРЕФЛЕКСИВНОЕ

Термин объясняется в статье Отношение рефлексивное.

ОТНОШЕНИЕ НЕСИММЕТРИЧНОЕ

Термин объясняется в статье Отношение симметричное.

ОТНОШЕНИЕ НЕТРАНЗИТИВНОЕ

Термин объясняется в статье Отношение транзитивное.

ОТНОШЕНИЕ ПРОСТРАНСТВЕННОЕ

Отношение, с помощью которого описываются пространственные взаимосвязи объектов. Примерами О.П. могут служить: "находиться близко", "соприкасаться", "быть внутри" и т. п. О.П. используются в пространственных логиках, логиках действии и других псевдофизических логиках.

ОТНОШЕНИЕ РЕЛЕВАНТНОСТИ

Связь двух или более информационных единиц, устанавливаемая на основе их семантической близости.

ОТНОШЕНИЕ РЕФЛЕКСИВНОЕ

Отношение, обладающее тем свойством, что любой его элемент сам с собой всегда находится в этом отношении. Примерами О.Р. могут служить: "совпадать", "быть похожим" и т. п. Если свойство рефлексивности не выполняется хотя бы для одного элемента отношения, то оно называется нерефлексивным отношением, а если оно не имеет места ни для одного элемента - антирефлексивным отношением.

ОТНОШЕНИЕ СЕМАНТИЧЕСКОЕ

Используемое в базах знаний отношение семантика которого задается его именем.

ОТНОШЕНИЕ СИММЕТРИЧНОЕ

Отношение, обладающее тем свойством, что для любой пары (А, В) элементов, находящихся в этом отношении, справедливо утверждение, что пара (В, А) также находится в этом отношении. Примером может служить отношение "быть супругом" для мужей и жен. Отношение, для которого это свойство не выполняется хотя бы для одного пары, называется несимметричным, а если оно не выполняется ни для одной пары - антисимметричным.

ОТНОШЕНИЕ ТОЛЕРАНТНОСТИ

Рефлексивное, симметричное и нетранзитивное отношение. Такое отношение может толковаться как отношение сходства. В отличие от отношения эквивалентности, дающего разбиение множества элементов, на котором оно определено, на непересекающиеся подмножества, О.Т. дает покрытие этого множества. О.Т. используется при классификациях информации в базах знаний.

ОТНОШЕНИЕ ТРАНЗИТИВНОЕ

Отношение, для которого из того, что пары (А, В) и (В, С) находятся в этом отношении, всегда следует, что в этом же отношении находится пара (А, С). Если это свойство не выполняется хотя бы для одной тройки элементов, то отношение называется нетранзитивным, а если не выполняется ни для какой тройки элементов, то - антитранзитивным. Примером транзитивного отношения может служить отношение "быть старше".

ОТНОШНИЕ ФУНКЦИОНАЛЬНОЕ

Отношение, с помощью которого в базе знаний задаются связи между информационными единицами. Эти связи определяют процедуры нахождения (вычисления) одних единиц через другие.

ОТНОШЕНИЕ ЭКВИВАЛЕНТНОСТИ

Симметричное, рефлексивное и транзитивное отношение. Используется для классификации множеств элементов путем разделения его на непересекающиеся классы, в совокупности покрывающие все исходное множество.

ОТНОШЕНИЕ ЭКСТЕНСИОНАЛЬНОЕ

Отношение на множестве конкретных фактов, хранящихся в базе данных. (См. также Представление экстенсиональное.)

ОТРИЦАНИЕ

Одноместная логическая операция, обозначаемая а. Для двузначной логики она определяется следующим образом: если а является истинным, то а является ложным, а если а является ложным, то а является истинным. В многозначной логике имеется несколько видов отрицания. Прямое обобщение двузначного отрицания для k-значной логики выглядит как а = (k - a) mod k.

ОТРИЦАНИЕ ЛОГИЧЕСКОЕ

См. Отрицание.

ПАДЕЖ ГЛУБИННЫЙ

См. Актант.

ПАДЕЖ ФИЛЛМОРА

См. Актант.

ПАМЯТЬ АССОЦИАТИВНАЯ

Память, ориентированная на поиск хранящейся информации по содержанию. Организована с использованием признаков (тегов), связывающих данные (информацию) по их содержанию, в отличие от обычной памяти, информация в которой отыскивается по номеру ячейки, в которой она хранится. В П.А. используется поиск по образцу.

ПАМЯТЬ ВИРТУАЛЬНАЯ

"Неограниченная" оперативная память, которой располагает пользователь. С помощью специальных системных средств в ЭВМ происходит проецирование части П.В. на поле оперативной памяти. При этом остальная часть П.В. хранится на внешних носителях.

ПАМЯТЬ ИКОНИЧЕСКАЯ

Специально выделенная область памяти, предназначенная для хранения пиктограмм - условных графических изображений информационных объектов или операций.

ПАПЛАЙН-АРХИТЕКТУРА

См. Архитектура конвейерная.

ПЕРЕВОД МАШИННЫЙ

Совокупность процедур с помощью которых на ЭВМ происходит перевод текста с одного языка на другой. Эти процедуры реализуют анализ исходного текста, его грамматический (морфологический и синтаксический) разбор, перевод текста в глубинную структуру, отражающую смысл текста. По этой глубинной структуре строится соответствующий текста на другом языке. Процедуры синтеза текста в какой-то мере повторяют в обратной последовательности процедуры анализа. В настоящее время существуют системы П.М. осуществляющие перевод текстов из фиксированной предметной области.

ПЕРЕМЕННАЯ ЛИНГВИСТИЧЕСКАЯ

Переменная, которая в качестве своих значений использует слова и словосочетания, являющиеся характеристиками какого-либо явления. Например П.Л. с именем "длина" может принимать, следующие значения: "крошечная", "очень маленькая", "средняя", "большая", "очень большая". П.Л. используются при формализации качественной информации при ее вводе в базу знаний. В нечеткой логике значения П.Л. могут выступать как специальные квантификаторы.

ПЕРЕМЕННАЯ ПРОПОЗИЦИОНАЛЬНАЯ

Переменная, используемая в пропозициональной логике.

ПЕРЕМЕННАЯ СВЯЗАННАЯ

Переменная в логике, стоящая в зоне действий квантора общности или квантора существования.

ПЕРЛОКУЦИЯ

Одна из составляющих речевого акта наряду с локуцией и иллокуцией. Эффект, достигаемый в результате иллокуции.

ПЕРЦЕПТРОН

Устройство, построенное по нейробионическому принципу. Простейший трехслойный П. состоит из поля фоторецепторов, каждый из которых может находиться в двух состояниях, поля ассоциативных формальных нейронов и решателей. На поле фоторецепторов проецируется черно-белые изображения. Фоторецепторы случайным образом соединяются с разрешающими и запрещающими входами ассоциативных формальных нейронов, выходы которых также случайным образом соединяются с входами решателей. В процессе обучения классификации входных изображений происходит подбор весовых коэффициентов и порогов ассоциативных нейронов таким образом, чтобы вход решателей (на них суммируются сигналы, приходящие от ассоциативных нейронов) могли использоваться как источник разделения множества входных изображений. Кроме трехслойного П. исследовались и многослойные П., у которых вводилось несколько слоев ассоциативных нейронов. Как показали исследования, возможности П. в области классификации - ограниченные. В настоящее время интерес к П. практически угас.

ПЕРЦЕПЦИЯ

См. Восприятие.

ПИКСЕЛ

Элементарная часть изображения на экране дисплея. П. характеризуется яркостью и цветом. Размер П. стандартен. Из П. строится изображение на экране.

ПИКТОГРАММА

Условное графическое изображение информационных объектов или операций.

ПЛАНИРОВАНИЕ

Процесс составления последовательности действий, подзадач, операций, подцелей, поочередное выполнение которых должно привести в достижению целей, поставленных перед системой. В интеллектуальных системах П. может осуществляться либо в пространстве задач, либо в пространстве состояний.

ПЛАНИРОВАНИЕ ДЕЯТЕЛЬНОСТИ

См. Планирование.

ПЛАНИРОВАНИЕ ИЕРАРХИЧЕСКОЕ

Планирование, при котором сначала ищется приблизительный план, с помощью которого находится принципиальный ответ о достижимости поставленных целей. Затем этот план постепенно уточняется и доводится до уровня, когда он может однозначно реализоваться.

ПЛАНИРОВАНИЕ РАСПРЕДЕЛЕННОЕ

Планирование, при котором отдельные части плана формируются в разных местах и различными средствами, а затем объединяются центральным органом. П.Р. встречается в интеллектуальных роботах и других интеллектуальных системах, когда они включены в систему сбора, передачи и обработки данных.

ПЛАНИРОВАНИЕ СТРАТЕГИЧЕСКОЕ

Построение начального плана действий в иерархических системах планирования. Стратегический план учитывает только основные сведения о среде планирования, но не учитывает особенности конкретной ситуации, в которой происходит планирование. Используется затем на нижележащих уровнях.

ПЛАНИРОВАНИЕ ТАКТИЧЕСКОЕ

Построение плана действий в иерархических системах планирования. При П.Т. в план, получаемый на уровне стратегического планирования, вносятся коррективы, связанные с учетом конкретных особенностей текущей ситуации и состояния планирующей системы. Уровней П.Т. может быть несколько.

ПЛАНИРОВЩИК

Комплекс программных средств, предназначенных для поиска планов действий.

ПОДХОД БАЙЕСОВСКИЙ

Метод принятия оптимальных статистических решений, основанный на положении, что параметр распределения вероятностей наблюдаемого случайного события, влияющий на характер принимаемых решений, является случайной величиной, определенной априорным распределением. П.Б. минимизирует средний риск, т. е. математическое ожидание теперь, связанных с неправильными или неточными решениями. П.Б. используется в теории статистических решений, теории игр, теории распознавания образов и для правдоподобного вывода в интеллектуальных системах.

ПОИСК

Движение в структурированном пространстве от одних узлов этого пространства к другим. Если П. является целенаправленным, то задано множество начальных узлов, с которых П. может начинаться, и множество конечных (целевых) узлов, при достижении которых П. прекращается. Движение по структуре поискового пространства определяется стратегическими П. Среди них наиболее распространены восходящий поиск и поиск нисходящий, а также поиск в глубину и поиск в ширину. Если пространство П. не структурировано, то единственной возможностью для П. является случайный поиск.

ПОИСК АССОЦИАТИВНЫЙ

Поиск по образцу в базах знаний. (См. также Память ассоциативная).

ПОИСК В ГЛУБИНУ

Поиск при котором движение по структуре поиска происходит вдоль одного пути до конца. При неудаче происходит просмотр другого пути. Для возвращения в ближайшую точку ветвления используется процедура бектрекинга.

ПОИСК В ПРОСТРАНСТВЕ ЗАДАЧ

Нисходящий поиск, когда структура поиска задается декомпозицией крупных задач на более мелкие вплоть до задач, решение которых системе известно. Задача, подлежащая решению, рассматривается как целевой узел, м от него идет нисходящий поиск к множеству задач, решение которых системе известно. П.П.З. используется в интеллектуальных системах при планировании деятельности.

ПОИСК В ПРОСТРАНСТВЕ СОСТОЯНИЙ

Нисходящий или восходящий поиск, при котором структура пространства поиска задана множеством состояний некоторой системы, между которыми указаны возможные переходы. П.П.С. используется в интеллектуальных системах при планировании деятельности.

ПОИСК В ШИРИНУ

Поиск при котором движение по структуре поиска происходит на определенную глубину по всем направлениям, возможным из данной точки поиска. Если все продвижения оказались неуспешными, то либо увеличивается глубина поиска, либо сужается фронт поиска и происходит дальнейшее продвижение по всему этому фронту еще на заданное число шагов. Сужение фронта приводит к тому, что П.Ш. комбинируется с поиском в глубину.

ПОИСК ВОСХОДЯЩИЙ

Поиск при котором движение по структуре поиска идет от начальных заданных узлов к целевым узлам. При этом могут использоваться поиск в глубину, поиск в ширину, или их комбинация. В логических системах аналогом П.В. является прямой вывод. Другое название П.В. - метод прямой волны.

ПОИСК ИНФОРМАЦИОННЫЙ

Поиск нужной информации в большом массиве по заранее известной совокупности признаков.

ПОИСК НИСХОДЯЩИЙ

Поиск, при котором движение по структуре поиска происходит от целевых узлов к заданным узлам. П.Н. может использовать поиск в глубину, поиск в ширину или их комбинацию. В логических системах аналогом П.Н. является обратный вывод. Другое название П.Н. - метод обратной волны.

ПОИСК ПО ОБРАЗЦУ

Поиск фрагмента знаний в базе знаний на основании заданного образца. Образец может представлять собой полностью определенный фрагмент, или содержать свободные переменные. Например, при представлении в виде семантической сети, образец первого типа может выглядеть как "Иванов - Родиться - 1965", что означает прямой запрос к базе знаний: "Верно ли, что Иванов родился в 1965 году?". Образец второго типа: "Х - Родится - 1965". Он интерпретируется так: "Назовите тех, кто родился в 1965 году". Запросы второго типа могут с помощью специального указателя интерпретироваться как выдача любого ответа, касающегося одного субъекта Х, родившегося в 1965 г., или как выдача всех Х, характеризуемых этим свойством. П.О. является основной процедурой для поиска информации в базах знаний.

ПОИСК ПО ПРИНЦИПУ "СПЕРВА ЛУЧШЕ"

Поиск, при котором в каждом узле пространства поиска выбирается то продолжение, которое имеет лучшую для данного узла локальную оценку успеха. Таким образом, П.П.С.Л. является разновидностью поиска в глубину.

ПОИСК СЛУЧАЙНЫЙ

Поиск в неструктурированном пространстве поиска. При П.С. с помощью некоторого вероятностного распределения выбираются узлы пространства и проверяются, не являются ли они целевыми. При достижении первого целевого узла П.С. прекращается.

ПОИСК ТИПА "СПЕРВА ВГЛУБЬ"

См. Поиск в глубину.

ПОИСК ТИПА "СПЕРВА ВШИРЬ"

См. Поиск в ширину.

ПОНИМАНИЕ ЕСТЕСТВЕННОГО ЯЗЫКА

В искусственном интеллекте - совокупность моделей и процедур, с помощью которых в интеллектуальных системах происходит соотнесение поступающего текста на естественном языке с фрагментами знаний из базы знаний, а также процедур, позволяющих выводить из имеющихся знаний другие, необходимые для правильной интерпретации содержимого введенного текста.

ПОНЯТИЕ

Имя, присваиваемое классу сущностей, объединяемых благодаря общности из призначных структур. В логике П. являются строго определенными и неизменными образованиями, характеризующими лишь призначной структурой, имманенто присущей всем понятиям. В искусственном интеллекте, как и в бытовой практике людей, П. понимается шире. В формировании П. могут принимать участие не только призначные структуры, но и результаты использования П. в деятельности людей или при функционировании интеллектуальной системы. Именно в этом смысле используются П. при рассуждениях о деятельности людей и о функционировании интеллектуальных систем. Для образования П. в интеллектуальных системах используются различные приемы обобщения.

ПОРОЖДЕНИЕ ГИПОТЕЗ АВТОМАТИЧЕСКОЕ

Процесс получения из фактов, хранящихся в базе данных, новых информационных единиц в базе знаний.

ПОРОЖДЕНИЕ ТЕКСТА

См. Генерация текста.

ПОТОК ДАННЫХ

Последовательность данных, непрерывно подаваемых при конвейерной архитектуре в операционное устройство, выполняющее над ними однотипные операции.

ПРАВИЛА ДЕ МОРГАНА

Правила, устанавливающие связь конъюнкции и дизъюнкции.
Типичные примеры:
а & b = ¬ (¬a V ¬b),
a V b = ¬ (¬a & ¬b).

ПРАВИЛО

См. Продукция.

ПРАВИЛО ВЫВОДА

Правило, с помощью которого в формальных системах из множества аксиом порождается правильно построенные формулы, которые интерпретируются как истинные.

ПРАВИЛО ВЫВОДА КОМПОЗИЦИОННОЕ

Правило вывода в нечеткой логике, основанное на операции композиции. Эта операция преобразует коэффициент правдоподобия исходной посылки (умножением на специально подобранную матрицу) в коэффициент правдоподобия заключения. Существуют такие матрицы, которые превращают П.В.К. в модус поненс и модус толленс.

ПРАВИЛО СИНТАКСИЧЕСКОЕ

В формальной системе правило, которое определяет способ формирования синтаксически правильных выражений. В лингвистике П.С. позволяют отделять синтаксически правильные предложения данного языка от тех, которые таковыми не являются.

ПРЕДИКАТ

В исчислении предикатов специальный знак, отражающий определенное отношение между конечным множеством сущностей - аргументов. В обычном варианте исчисления предикатов в качестве значения П. на множестве означенных аргументов выступают два: истина и ложь.

ПРЕДСТАВЛЕНИЕ ДАННЫХ

Расположение данных в физической среде фиксируемое специальной схемой базы данных. Используя эту схему, система управления базой данных соотносит запрос на поиск нужной информации с физическим расположением данных. Различные принципы построения схемы базы данных приводят к различным типам П.Д. (реляционное, иерархическое и сетевое).

ПРЕДСТАВЛЕНИЕ ЗНАНИЙ

Формализация знаний для их ввода в базу знаний. На концептуальном уровне П.З. наиболее распространены модели знаний в виде семантических сетей, фреймов и продукционных систем. В П.З. как направление искусственного интеллекта традиционно включает также задачи проверки содержимого базы знаний на корректность и полноту, пополнения знаний за счет логического вывода на основе имеющихся в базе знаний, обобщения знаний и классификация знаний.

ПРЕДСТАВЛЕНИЕ ЭКСТЕНСИОНАЛЬНОЕ

Представление константных фактов, не содержащих свободных переменных в базах данных или в базах знаний.

ПРЕСУПОЗИЦИЯ

Высказывание, истинность которого является предпосылкой истинности или ложности другого высказывания. Например, два высказывания "Кеплер умер в нищете" и "Кеплер умер не в нищете" имеют одну и ту же пресуппозицию, что Кеплер существовал.

ПРИНЦИП РЕЗОЛЮЦИИ

Метод логического вывода, в основе которого лежит приведение доказываемого утверждения к множеству дизъюктов и поиску в этом множестве пар, один дизъюнкт которых содержит некоторую литеру, а другой - отрицание этой литеры, для их последовательного устранения из исходного множества. Если этот процесс через конечное число шагов приводит к пустому дизъюнкту, то вывод успешен. В противном случае формула недоказуема.

ПРИОБРЕТЕНИЕ ЗНАНИЙ

Совокупность методов и процедур, которые применяет инженер по знаниям при заполнении им базы знаний. П.З. предполагает использование источников знаний двух типов: пассивных и активных. К первым относятся официальные документы, инструкции, печатные издания, кино-фото-документы и многие другие источники, в которых содержатся сведения, важные для описания знаний о предметной области. Ко второму типу источников знаний относятся люди - специалисты в данной предметной области. Инженер по знаниям с помощью специальных психологических методик и инструментальных средств в процессе диалога получает от экспертов необходимые сведения. Все приобретенные знания для ввода в базу знаний формализуются в соответствии с требованиями той модели знаний, которая соответствует выбранному проектировщиком системы представлению знаний.

ПРОГРАММА ИГРОВАЯ

Программа позволяющая использовать ЭВМ в качестве одного из участников игры. П.И. составляются как для игр типа шахмат, шашек и т. п., так и для реализации на ЭВМ развлекательных игр (погоня, рулетка и др.).

ПРОГРАММА ЭВРИСТИЧЕСКАЯ

Программа, в основу которой положены соображения о том, как данную проблему решает человек.

ПРОГРАММИРОВАНИЕ

Процесс представления алгоритма решения задачи в виде, "воспринимаемом" ЭВМ. Программирование включает детализацию алгоритма уровня элементарных операторов; запись алгоритма на выбранном языке программирования и описание процессов управления ходом выполнения программ на ЭВМ.

ПРОГРАММИРОВАНИЕ ЛОГИЧЕСКОЕ

Программирование, при котором программа представляется в виде процедуры логического вывода в исчислении предикатов первого порядка. Механизм вывода обычно встроен в язык П.Л. Примером может служить распространенный в интеллектуальных системах язык ПРОЛОГ, в который встроен обратный вывод.

ПРОГРАММИРОВАНИЕ ОБЪЕКТНО-ОРИЕНТИРОВАННОЕ

Программирование, при котором программа трактуется как множество объектов и сообщений, циркулирующих между этими объектами. Такой подход вносит в программу модульность.

ПРОГРАММИРОВАНИЕ ФУНКЦИОНАЛЬНОЕ

Программирование, при котором решение задачи сводится к вычислению значений рекурсивно вложенных функций.

ПРОГРАММИРОВАНИЕ ЭВРИСТИЧЕСКОЕ

Процесс составления эвристических программ.

ПРОДУКЦИЯ

Способ представления процедурных знаний в следующим наиболее общем виде: (i); Q; P; C; A B; N. Здесь (i) - собственное имя (метка) П.; Q - сфера применения П., вычленяющая из предметной области некоторую ее часть, в которой знание, заключенное в П., имеет смысл; Р - предусловие, содержащее информацию об истинности данной П., ее приоритетности и т. п., используемую в стратегиях управления выводом для выбора данной продукции для исполнения; С - условие, представляющее собой предикат, истинное значение которого разрешает применять на некотором шаге данную П.; А В - ядро продукции (интерпретация ядра может быть различной, например: "Если А истинно, то В истинно", "Если А имеется в базе знаний, то В надо внести в базу знаний", "Если А текущая ситуация, то надо делать В" и т.п.); N - постусловие П., содержащее информацию о том, какие изменения надо внести в данную П. или другие П., входящие в систему продукций, после выполнения данной П.

ПРОПОЗИЦИЯ

Предложение, суждение, утверждение. (См. также Исчисление пропозициональное.)

ПРОСТРАНСТВО ЗАДАЧ

Структура, отражающая декомпозицию крупных задач на более мелкие, вплоть до стандартных задач, решение которых предполагается известным. П.З. используется в интеллектуальных системах для планирования деятельности и в задачах автоматического синтеза программ. Решение нужной задачи ищется как композиция решений стандартных задач.

ПРОСТРАНСТВО ОСГУДА

Применяемый в психологии формализованный способ выявления семантической близости используемых людьми понятий. Для построения П.О. используются бинарные шкалы, концы которых отмечены словами-антонимами типа "безопасный - опасный", "широкий - узкий", "добрый - злой" и т. д. На этих шкалах нанесено некоторое число позиций. Испытуемые должны располагать на них точки, соответствующие словам, произносимым экспериментатором. Результаты подвергаются статистической обработке с помощью факторного анализа или кластерного анализа. На основании многочисленных экспериментов такого типа было построено трехмерное П.О., оси которого интерпретируются как обобщение шкалы оценок, силы и активности. В этом пространстве используется обычная метрика векторных пространств. В П.О. понятия, связанные между собой общей ситуацией, группируются в некоторые сгущения, что подтверждает мысль о том, что основой классификации знаний у людей является принцип ситуативности.

ПРОСТРАНСТВО СЕМАНТИЧЕСКОЕ

Структура на знаниях, в которой введено понятие "семантическое расстояние". Примером П.С. может служить пространство Осгуда.

ПРОСТРАНСТВО СОСТОЯНИЙ

Совокупность состояний, в которых может находиться техническая система или процесс. В П.С. может быть задана метрика, а также указаны возможные траектории смены состояний под влиянием различных причин. П.С. используется в интеллектуальных системах при автоматическом синтезе программ и при планировании деятельности.

ПРОСТРАНСТВО ЦЕЛЕВОЕ

Совокупность целей с указанием возможных траекторий их достижения. П.Ц. используется в интеллектуальных системах при планировании деятельности и при автоматическом синтезе программ.

ПРОТИВОРЕЧИВОСТЬ АБСОЛЮТНАЯ

Возможность одновременного вывода в формальной системе утверждения и его отрицания. В такой формальной системе можно вывести любые утверждения по правилу модус поненс.

ПРОТИВОРЕЧИВОСТЬ МОДЕЛЬНАЯ

Противоречие, обнаруживаемое в модели. В замкнутых моделях П.М. является аналогом абсолютной противоречивости, в открытых моделях П.М. относительна. (См. также Модель Крипке).

ПРОТОФРЕЙМ

Фрейм, в котором заполнение некоторых (или всех) слотов таково, что оно допускает различные конкретизации этих значений.

ПРОЦЕДУРА ОПРОВЕРЖЕНИЯ

Установление противоречивости (невыполнимости) формулы, состоящей из конъюнкции посылок и отрицания заключения.

ПРОЦЕДУРА ПРИСОЕДИНЕНИЯ

Процедура на которую возможна ссылка по имени, использованному в некоторой информационной единице. По этому имени П.П. может быть просто вызвана и присоединена к описанию информационной единицы или актуализирована и выполнена.

ПРОЦЕСС АСИНХРОННЫЙ

Сложный процесс, состоящий из совокупности отдельных подпроцессов, взаимодействие которых не синхронировано во времени.

ПРОЦЕССОР АССОЦИАТИВНЫЙ

Процессор, приспособленный для работы с ассоциативной памятью.

ПРОЦЕССОР БАЗЫ ДАННЫХ

См. Машина баз данных.

ПРОЦЕССОР ЛИНГВИСТИЧЕСКИЙ

Устройство или совокупность программ, ориентированные на реализацию общения пользователей с системой на ограниченном естественном языке.

ПРОЦЕССОР ЛОГИЧЕСКИЙ

См. Процессор логического вывода.

ПРОЦЕССОР ЛОГИЧЕСКОГО ВЫВОДА

Специализированный процессор (система процессоров), реализующий набор процедур, необходимых для организации логического вывода или извлечения следствий из знаний о некоторой предметной области.

ПРОЦЕССОР МАТРИЧНЫЙ

Специализированный процессор, обеспечивающий параллельное выполнение операций над массивами чисел: векторами или матрицами. Обычно состоит из набора арифметических процессоров, выполняющих одинаковые операции над различными элементами массива, с общим устройством управления.

ПРОЦЕССОР СИМВОЛЬНЫЙ

Специализированный процессор, ориентированный на обработку символьной информации.

ПСИХОЛОГИЯ КОГНИТИВНАЯ

Направление в совместной психологии, в которой центральное место занимают вопросы отображения знаний в когнитивных структурах памяти, исследование этих структур и их влияние на принятие решений и поведение субъектов. В П.К. большое внимание уделяется соотношению вербальных и образных компонентов в процессах запоминания и мышления. П.К. использует аналоги между представлением и переработкой знаний человеком и интеллектуальной системой. В частности, с помощью методов П.К. были проанализированы такие когнитивные структуры, как семантические сети, фреймы, продукционные системы, и было показано, что организация знаний у человека основана на иных структурах.

РАЗРЕШИМОСТЬ АЛГОРИТМИЧЕСКАЯ

Наличие алгоритма решения поставленной задачи.

РАСПОЗНАВАНИЕ ОБРАЗОВ

Научное направление, основной задачей которого является создание моделей, методов и средств, связанных с решением задач классификации, таксономии, формирования понятий и т.п.

РАСПОЗНАВАНИЕ РЕЧИ

Один из видов восприятия в интеллектуальных системах. В процессоре Р.Р. происходит анализ входного акустического сигнала, выделение в нем фонем, слов, лексем, стандартных кусков текста, которые соотносятся с информацией, хранящейся в базе знаний системы, что позволяет системе понимать вводимый текст. Различают Р.Р. на уровне отдельных слов, произносимых стандартным диктором, а также с подстройкой системы к особенностям произношения конкретного диктора, и Р.Р., относящиеся к слитному тексту. В настоящее время реализованы системы Р.Р.Д, позволяющие уверенно определять значение 1 - 2 тыс. слов, а также анализировать слитный текст, в котором используются не слишком большие словари.

РАССТОЯНИЕ СЕМАНТИЧЕСКОЕ

Оценка "семантической" близости информационных единиц, хранящихся в памяти интеллектуальной системы или человека. Понятие "семантической" близости неоднозначно. Эксперименты с людьми показывают, что в зависимости от поставленной цели Р.С. может интерпретироваться как ситуативная близость (встреча в некоторых типовых ситуациях), ассоциативная близость (типа "молоток-гвоздь"), таксономическая близость ( типа "стол-кровать") и т. д. Р.С. используется в базах знаний для ускорения выбора релевантной информации к данному понятию или ситуации. До настоящего времени нет удовлетворительных моделей, в рамках которых можно было бы измерять Р.С. (См. также Пространство Осгуда.)

РАССУЖДЕНИЕ

Способ получения заключения на основе посылок и вспомогательных соображений. Крайним случаем Р. является логический вывод, в котором воля субъекта не играет роли. В других случаях Р. отражает личностные мотивы и интересы того, кто проводит Р.

РАССУЖДЕНИЕ АВТОЭПИСТИМИЧЕСКОЕ

Вид немонотонного вывода когда выводимость утверждения зависит от контекста, в рамках которого оно существует. Примерами Р.А. могут служить многочисленные в человеческой практике исключения из общих правил в выделенных специальных контекстах (ситуациях).

РАССУЖДЕНИЕ ГЕРМЕНЕВТИЧЕСКОЕ

Рассуждение, опирающееся на принятые в герменевтике схемы получения заключений, учитывающее строение текста, на основе которого делается вывод. Например, в фразе "Все моря целовали его корабли" (К. Бальмонт) имеется явная неоднозначность. Но при Р.Г. эта неоднозначность снимается, ибо одна из схем герменевтики для текстов, написанных на русском языке, гласит, что субъект должен упоминаться раньше объекта, на который направлено его действие. И следовательно, субъектом утверждения является "моря", а не "корабли". Р.Г. не носит строго логического характера, а базируются на традиции.

РАССУЖДЕНИЕ ЗДРАВОГО СМЫСЛА

Один из видов правдоподобного рассуждения опирающийся не на основания, верные в некоторой формальной системе а не соображения, аппелирующие к человеческому опыту, интуиции, вере.

РАССУЖДЕНИЕ НЕМОНОТОННОЕ

Рассуждение в открытой модели. Из-за открытости возможно добавление новой информации извне в процессе проведения рассуждения. Это приводит к тому, что некоторые шаги рассуждения, верные до появления этой информации, могут стать неверными. Когда рассуждение является строгим выводом, то имеет место немонотонный вывод.

РАССУЖДЕНИЕ ПО АНАЛОГИИ

Перенос заключений, полученных на основе ряда посылок, на другую совокупность посылок, которая считывается по некоторому критерию аналогичной первой. В частном случае Р.А. есть способ получения заключения на основании диаграммы Лейбница А, А1; В, В1; Т, Т1; Г, Г1), где А1 = Т (А); где Т - некоторый преобразующий оператор; Г - гомоформизм между А и В; Г1 - гомоформизм между А1 и В1; Т1 - преобразующий оператор В1 = Т1 (В). Р.А. есть нахождение В1 по известным остальным элементам диаграммы.

РАССУЖДЕНИЕ ПО АССОЦИАЦИИ

Рассуждение, основанное на том, что заключение относительно одного объекта переносится на другой объект, имеющий с первым ассоциативную связь. Эта связь может иметь различный характер (например, ассоциацию по схожести, по одновременности, по встречаемости в одинаковых ситуациях и т. п.). Р.А. является правдоподобным рассуждением, степень его правдоподобия определяется существенностью используемой ассоциативной связи.

РАССУЖДЕНИЕ ПО УМОЛЧАНИЮ

Один из видов правдоподобного рассуждения где результат получается не из явно присутствующих для этого посылок, а на основе "традиции", прошлого опыта, внутренних моральных или ценностных убеждений и т.п. Р.У. возникают тогда, когда во входной информации часть сведений отсутствует и интеллектуальная система пополняет их на основе хранящейся в ее памяти специальной информации, предназначенной для случаев неполноты входной информации. Например, во фреймах могут существовать специальные слоты, к которым система обращается за информацией, когда для проведения рассуждения чего-то не хватает.

РАССУЖДЕНИЕ ПРАВДОПОДОБНОЕ

Рассуждение, которое опирается либо на знания, не имеющие абсолютно истинного характера, либо на приемы рассуждений, которые не являются абсолютно верными. Обычно результат Р.П. снабжается оценкой его правдоподобия. Примерами Р.П. могут служить рассуждения по аналогии или ассоциации или герменевтические рассуждения.

РЕЗОЛЬВЕНТА

Образование дизъюнкта (ct - lt) V (dt - lt), где с и d - дизъюнкты, не имеющие общих переменных; l и l - контрарная пара литер, каждая из которых принадлежит своему дизъюнкту; t - наиболее общий унификатор контратной пары литер.

РЕЗОЛЮЦИЯ

Прием, используемый при дедуктивном выводе, заключающийся в нахождении двух дизъюнктов, один из которых содержит литеру, а другой - ее отрицание. На основании этого сравнения формируется новый дизъюнкт, называемый резольвентой. Порождение новых дизъюнктов является основой метода резолюций, широко применяемого в интеллектуальных системах.

РЕШАТЕЛЬ

Система, способная благодаря встроенной в нее общей стратегии нахождения решения (например, путем поиска в пространстве альтернатив или путем логического вывода) находить решения задач. Р. входит в качестве основного блока в интеллектуальные системы. Иногда этот блок называется полно: Решатель задач.

РЕШЕТКА КЕЛЛИ РЕПЕРТУАРНАЯ

Метод изучения структуры индивидуального сознания путем заполнения специальным образом составленной матрицы. Строки матрицы соответствуют конструктам Келли. Столбцам матрицы соответствуют объекты, скомпонованные аналогично ролям в пьесе. Метод позволяет оценить силу и направленность связей между конструктами для заполнившего матрицу человека.

РИСК-АРХИТЕКТУРА

Совокупность обобщенных сведений о структуре и функционировании основных блоков и об информационно-управляющих связях между ними для процессора с сокращенным набором команд, реализованного на СБИС. Состав команд процессора определяется конкретной областью его применения, причем в этот состав включается наиболее часто используемые короткие команды, выполняемые за один машинный такт. В структуре процессора используется большое число регистров общего назначения (данные считываются из регистра и переписываются снова в регистр), что существенно уменьшает время обращения к оперативной памяти.

РОБОТ АВТОНОМНЫЙ

Техническое устройство, способное к планированию целесообразного поведения в условиях динамической, заранее не полностью известной среды. Р.А. должен обладать базой знаний о среде и ее особенностях, решателем задач с средствами для анализа ситуаций и последствий своих действий в среде, чтобы накапливать информацию о том, как нужно действовать в тех или иных ситуациях. Р.А. является представителем интеллектуальных систем.

РОБОТ ИНТЕГРАЛЬНЫЙ

Техническое устройство в котором имеется развитая система "глаз-рука", позволяющая наблюдаемому координировать ситуацию с движением манипуляторов и средств перемещения. Это отличает Р.И. от роботов-манипуляторов, в которых нет обратной связи со средой, если ситуации отличаются от штатных, заранее зафиксированных в конструкции робота-манипулятора. Р.И. должен обладать способностью к анализу зрительных сцен и уметь принимать решения на основе этого анализа. Р.И. является представителем интеллектуальных систем.

РОБОТ ИНТЕЛЛЕКТУАЛЬНЫЙ

Автономный робот, в котором имеются все основные блоки, характерные для интеллектуальной системы. С их помощью реализуются функции общения Р.И. с внешними партнерами, строятся программы поведения, накапливаются знания о внешней среде и действиях в ней, строятся планы поведения по достижению нужных целей.

СБОРКА МУСОРА

Процесс чистки памяти, связанный с обнаружением неиспользуемых программой блоков памяти и присоединением их к пространству свободной памяти для повторного использования. Сборка мусора - необходимый процесс в любой системе, работающей с динамическим распределением памяти.

СВИДЕТЕЛЬСТВО

Факт, используемый для увеличения или уменьшения оценки правдоподобия некоторой гипотезы. С. применяются в продукционных системах, в которых продукции являются гипотезами.

СЕКВЕНЦИЯ

В узком смысле - правило логического перехода А В, которое интерпретируется следующим образом: если А истинно, то В также истинно, если А ложно, то о В сказать ничего нельзя. В широком смысле С. совпадает с понятием ядра продукции.

СЕМАНТИКА

1. Один из аспектов семиотики. Рассматривает отношение знаков к обозначаемому (содержание знаков) независимо от того, кто служит адресатом знака.
2. Значение отдельных единиц знака.
3. Изучение отдельных единиц языка - языковедческая семантика, элементарным объектом изучения которой является единство трех объектов: означающего, означаемого и денотата. Означающее - внешний элемент (последовательность звуков или знаков), денотат - обозначаемый объект действительности и означаемое - отражение этого объекта в сознании человека.

СЕМАНТИКА СИТУАТИВНАЯ

Приписывание некоторым объектам, хранящимся в базе знаний, некоторых характеристик в зависимости от ситуации, в которой эти объекты наблюдаются или используются. В системах понимания текстов на естественном языке С.С. связана с приписыванием различных значений лексемам в зависимости от того контекста, в котором они используются.

СЕМИОТИКА

Наука, изучающая свойство знаков и знаковых систем (в основном естественных и искусственных языков.) Выделяются три основных аспекта исследования: синтактика, изучающая внутренние свойства систем знаков безотносительно к интерпретации; семантика, рассматривающая отношение знаков к их означаемому, безотносительно к особенностям интерпретатора знаков; прагматика, изучающая проблемы интерпретации знаков.

СЕТЬ

Пятерка Н = <A, B, P, P1, C>, где А - множество вершин, В - множество имен (весов) вершин; Р - множество дуг, соединяющих пары вершин; Р1 - множество отмеченных входных и выходных дуг; С - множество имен (весов) дуг.

СЕТЬ АССОЦИАТИВНАЯ

Семантическая сеть, в которой отношения указывают на ассоциативные связи между вершинами, характеризующими объекты, факты и ситуации для описываемой предметной области.

СЕТЬ ВЫВОДА

Структура, которая отображает последовательности применения правил вывода к исходным посылкам. Из-за неоднозначности выбора правил на каждом шаге возникает множество путей, образующих С.В.

СЕТЬ КАУЗАЛЬНАЯ

Семантическая сеть, в которой дуги характеризуют отношения, используемые в каузальной логике.

СЕТЬ ПЕРЕХОДОВ РАСШИРЕННАЯ

Расширение контекстно-свободной грамматики за счет вынесения контекста в специальные именованные регистры со стековой структурой и введения специальных процедур, управляющих анализом с помощью проверки контекста ходом выполнения анализа управляет программист). См. также. Грамматика формальная.

СЕТЬ ПЕТРИ

Модель для описания асинхронных параллельных и недетерминированных процессов, а также систем продукционного типа. Статически модель задается двудольным орфографом с двумя типами вершин - позициями и переходами (изображаемыми обычно кружками и полочками соответственно), причем переходы (позиции) могут соединяться дугами только с позициями (переходами). Исходное состояние С.П. задается начальной маркировкой некоторых ее позиций. Маркеры изображаются точками внутри позиций. Динамика вносится соглашением о правиле срабатывания возбужденного перехода (содержащего по крайней мере один маркер в каждой из его входных позиций), который может сработать через заранее неизвестное время, после чего из всех (во все) его входных позиций (выходные позиции) изымается (добавляется) по одному маркеру. Процесс функционирования С.П. состоит в переходе от одной маркировки к другой посредством срабатываний возбужденных переходов.

СЕТЬ ПРИЧИННО-СЛЕДСТВЕННАЯ

Семантическая сеть, в которой все отношения между вершинами трактуются как отношение "причина-следствие", т. е. как нерефлексивное, антисимметричное и транзитивное отношение.

СЕТЬ СЕМАНТИЧЕСКАЯ

Сеть, в вершинах которой находятся информационные единицы, а дуги характеризуют отношения и связи между ними С.С. является наиболее общей моделью представления знаний.

СЕТЬ СЕМАНТИЧЕСКАЯ ИНТЕНСИОНАЛЬНАЯ

Семантическая сеть, в которой отражены интенсиональные знания о предметной области. Эти знания относятся к общим законам области и оперируют не константными фактами, а высказываниями об области, содержащими переменные, которые могут означиваться в конкретных ситуациях. При фреймовом представлении С.С.И. соответствует фрейм-прототип.

СЕТЬ СЕМАНТИЧЕСКАЯ ЭКСТЕНСИОНАЛЬНАЯ

Семантическая сеть, в которой отражены экстенсиональные знания о конкретной ситуации в предметной области. В С.С.Э. все вершины сети соответствуют конкретным объектам, а связи между ними конкретным связям, которые наблюдаются в описании ситуации. При фреймовом представлении С.С.Э. соответствует фрейм-экземпляр.

СЕТЬ СОЕДИНИТЕЛЬНАЯ

Сеть, позволяющая соединить процессор произвольно заданным образом, в том числе каждый с каждым.

СИЛЛОГИЗМ

Специальная форма умозаключения от общего к частному. С. представляет собой заключение, следующее из двух посылок, содержащих утверждения о соотношении объемов двух классов или о принадлежности некоторого элемента определенному классу. Примером С. может служить следующее умозаключение: Все хищники питаются мясом Волк - хищник Волк питается мясом

СИМД-АРХИТЕКТУРА

Архитектура вычислительной системы с несколькими одинаковыми параллельно работающими процессорами, каждый из которых выполняет один и тот же поток команд над своими данными. СИМД-архитектура часто используется в матричных процессорах.

СИНТАКСИС

1. Способы соединения слов в словосочетания и простые предложения и простых предложений - в сложные.
2. Раздел языкознания, изучающий способы соединения слов и предложений, вместе с морфологией составляющий грамматику.
3. Синтаксис текста - то же, что схема дискурса или неративная (повествовательная) схема; строение текста.

СИНТЕЗ ПРОГРАММ АВТОМАТИЧЕСКИЙ

Автоматическое построение программ по исходным условиям задачи. Формально задача С.П.А. может быть поставлена следующим образом: по заданному значению х, удовлетворяющему предикату Р (х), вычислить значение у, удовлетворяющее предикату R (х, у). Здесь х, у - конечные множества входных и выходных переменных программы. Отображение Q = < P (x), R(x, y) > должно при этом содержать достаточно информации для синтеза нужной программы. Различают три подхода: индуктивный синтез программ, дедуктивный синтез программ или трансформационный синтез программ.

СИНТЕЗ ПРОГРАММ ДЕДУКТИВНЫЙ

Автоматический синтез программ в котором используется формальный метод построения программ; вывод программы из заданной спецификации рассматривается как задача конструктивного доказательства существования нужного решения. В ходе реализации С.П.Д. часто используются методы автоматического доказательства теорем в исчислении предикатов первого порядка.

СИНТЕЗ ПРОГРАММ ИНДУКТИВНЫЙ

Автоматический синтез программ опирающийся на нахождение общих для заданного множества примеров процедур, ведущих к решению задачи. С.П.И. может осуществляться на синтаксическом уровне, когда используются внешние признаки программ, или на семантическом уровне, когда в основе лежит семантика модели программы.

СИНТЕЗ ПРОГРАММ ТРАНСФОРМАЦИОННЫЙ

Автоматический синтез программ, в котором конструирование программы осуществляется последовательным преобразованием исходной спецификации в эквивалентную ей результирующую программу. С.П.Т. обычно разбивается на следующие этапы: переход от формальной спецификации к рекурсивной версии программы общего вида; трансформация общерекурсивной версии в рекурсивную версию специального вида; переход от рекурсивной версии к итеративной версии.

СИНТЕЗ ТЕКСТА

См. Генерация текста.

СИСТЕМА АВТОМАТИЗИРОВАННОГО ПРОЕКТИРОВАНИЯ (САПР)

Комплекс средств, предназначенных для помощи инженеру-проектировщику в создании новых технических объектов. САПР включает большое количество расчетных модулей, базу знаний средств ведения документации и технического черчения.

СИСТЕМА АКСИОМАТИЧЕСКАЯ

Система рассуждений, в основе которой лежат аксиомы. Если аксиомы являются логическими (т. е. тождественно истинными вне зависимости от предметной области), то С.А. совпадает с формальной системой. Если среди аксиом имеются аксиомы, справедливые только в данной предметной области, то С.А. применима только в этой области. Часто С.А., у которой имеются предметные аксиомы, называют квазиаксиоматической системой.

СИСТЕМА ВОПРОСНО-ОТВЕТНАЯ

Совокупность программ, позволяющая реализовать вопросно-ответное отношение для пары "пользователь - ЭВМ". С.В.О. обеспечивает поиск релевантных данных и знаний по поступившему в систему вопросу, из которых формируется ответ пользователю. С.В.О. могут использовать вопросы и ответы, формулируемые на естественном языке, ограниченном естественном языке или на специальном формальном языке общения.

СИСТЕМА ДЕДУКТИВНАЯ

Аксиоматическая система, в которой имеет место теорема дедукции, обеспечивающая вывод всего множества выражений, которое допускается аксиомами и правилами вывода (и только ими). При этом предполагается, что выводимые выражения обладают априорным свойством (например, тождественной истинностью или истинностью с оценкой правдоподобия не менее заданной).

СИСТЕМА ДОВЕРИЯ

Совокупность процедур, используемая в системах объяснения экспертных систем. С.Д. применяется для того, чтобы повысить уровень доверия пользователя к результатам, полученным экспертной системой. Для этого С.Д. выдает пользователю ряд дополнительных аргументов в пользу того решения, которое было получено системой, при условии, что эти аргументы не были непосредственно использованы в процессе получения решения.

СИСТЕМА ЕСТЕСТВЕННО-ЯЗЫКОВАЯ

Интеллектуальная система, способная воспринимать тексты или речь на ограниченном естественном языке, понимать их и функционировать в соответствии с информацией, содержащейся в тексте. При необходимости С.Е.Я. может формировать ответные сообщения, связанные с введенным в них текстом. (См. также Интерфейс естественно-языковый.)

СИСТЕМА ИНДУКТИВНАЯ

Модель в которой используется индуктивная логика или индуктивное обобщение (или и то и другое).

СИСТЕМА ИНТЕЛЛЕКТУАЛЬНАЯ

Техническая или программная система, способная решать задачи, традиционно считающиеся творческими, принадлежащие конкретной предметной области, знания о которой хранятся в памяти С.И. Структура С.И. включает три основных блока - базу знаний, решатель и интеллектуальный интерфейс.

СИСТЕМА ИНТЕЛЛЕКТУАЛЬНАЯ ОБУЧАЮЩАЯ

Интеллектуальная система для обучения человека какому-либо роду деятельности или используемая в процессе обучения школьников или студентов. С.И.О. включает естественно-языковый интерфейс, средства графического общения, базу знаний и специальный блок, управляющий процессом подачи материала, анализирующий обучаемого и принимающий решение об оценке степени усвоения.

СИСТЕМА ИНТЕЛЛЕКТУАЛЬНАЯ ОБУЧАЮЩАЯСЯ

Интеллектуальная система в которой имеется совокупность средств для пополнения ее базы знаний. Возможны два способа обучения: с учителем и без учителя. В первом случае С.И.О. должна иметь возможность пополнять свою базу знаний информацией, сообщаемой ей учителем, корректировать новую информацию с ранее имевшейся и задавать учителю вопросы, когда возникают конфликтные ситуации. При обучении без учителя С.И.О. обобщает информацию, которая содержится в ее базе данных или наблюдается во внешней среде. С помощью индуктивного вывода и, возможно, рассуждений по аналогии и рассуждений по ассоциации С.И.О. формирует гипотезы о новых закономерностях в той предметной области, в которой она работает. Этим новым знаниям система может приписывать оценки правдоподобия.

СИСТЕМА ИНТЕРАКТИВНАЯ

Комплекс программных или аппаратно-программных средств, обеспечивающих взаимодействие пользователя с системой, решающей его задачу в процессе поиска решения.

СИСТЕМА КВАЗИАКСИОМАТИЧЕСКАЯ

Термин объясняется в статье Система аксиоматическая.

СИСТЕМА МУЛЬТИПРОЦЕССОРНАЯ

Вычислительная система, состоящая из большого числа процессорных модулей (элементов), в совокупности решающих сложную задачу. На организацию работы С.М. существенное влияние оказывает используемая соединительная сеть.

СИСТЕМА ОБУЧАЮЩАЯ

Система, способная к накоплению новых знаний в результате обращения к учителю или обобщения наблюдаемых фактов. (См. также Система интеллектуальная обучающаяся.)

СИСТЕМА ОБЪЯСНЕНИЯ

Часть экспертной системы, предназначенная для разъяснения пользователю по его просьбе способа, которым получено решение. С.О. дает ответы на вопросы трех типов. "Как-вопросы" заставляют систему объяснять путь решения. "Почему-вопросы" вызывают у С.О. необходимость в пояснении, почему получено именно это решение, а не какое либо другое. "Что-вопросы" требуют от С.О. выдачи всей имеющейся в экспертной системе информации относительно объекта или явления, к которому относится "Что-вопрос". Для ответов на подобные вопросы в С.О. имеется набор специальных процедур и рабочая память, в которой в процессе поиска решения формируется информация, необходимая для ответа на вопросы пользователя. С С.О. связана система доверия, увеличивающая объяснительную силу экспертной системы.

СИСТЕМА, ОСНОВАННАЯ НА ЗНАНИЯХ

Интеллектуальная система, функционирование которой определяется совокупность знаний о проблемной области, в которой она используется.

СИСТЕМА, ОСНОВАННАЯ НА ПРАВИЛАХ

Интеллектуальная система, в базе знаний которой принято представление знаний в виде систем продукций.

СИСТЕМА ПРЕДСТАВЛЕНИЯ ЗНАНИЙ

Совокупность средств для автоматизированного заполнения баз знаний и поддержания их в рабочем состоянии. В зависимости от выбранной в интеллектуальной системе модели знаний различают С.П.З., основанные на семантических сетях, фреймах и продукционных правилах. С.П.З. входят в состав всех интеллектуальных систем.

СИСТЕМА ПРОДУКЦИЙ

Совокупность множества продукций, выполнение которых задается с помощью стратегии управления выводом. Стратегия определяется абстрактной машиной М = <M1, M2, M3 >, где М1 формирует фронт продукций, для которых выполнены условия их применимости; М2 производит выбор из фронта готовых продукций той, которая будет выполняться на данном шаге процесса, М3 вносит необходимые изменения в продукции, входящие в С.П., на основании той информации, которая содержалась в постусловии продукции, выполненной на данном шаге процесса.

СИСТЕМА ПРОДУКЦИОННАЯ

См. Система продукций.

СИСТЕМА ПЯТОГО ПОКОЛЕНИЯ ВЫЧИСЛИТЕЛЬНАЯ

Новое поколение ЭВМ, отличающееся от ранее созданных наличием естественно-языкового интерфейса и средств для автоматического синтеза программы на основе хранящихся в памяти систем типовых модулей. Синтез программы производится по сообщению пользователя, сформулированному на профессиональном естественном языке. Таким образом, в С.П.П.В. имеется встроенная интеллектуальная система, дающая возможность общения с ЭВМ пользователей, не обладающих специальными знаниями по программированию.

СИСТЕМА УПРАВЛЕНИЯ АВТОМАТИЗИРОВАННАЯ

См. Автоматизированная система управления.

СИСТЕМА УПРАВЛЕНИЯ БАЗОЙ ДАННЫХ (СУБД)

Комплекс средств, входящих в состав базы данных, с помощью которых формируются поисковые запросы к информации, хранящейся в базе данных, выполняются процедуры поиска, служебные процедуры связанные с сохранением целостности базы, и т. п.

СИСТЕМА УПРАВЛЕНИЯ БАЗОЙ ЗНАНИЙ

Совокупность программных и аппаратных средств для организации в базах знаний процедур, связанных с поиском знаний, пополнением базы знаний, ее корректировкой и т. п.

СИСТЕМА УПРАВЛЕНИЯ ПРОИЗВОДСТВОМ

См. Автоматизированная система управления предприятием.

СИСТЕМА УПРАВЛЕНИЯ ТЕХНОЛОГИЧЕСКИМ ПРОЦЕССОМ

См. Автоматизированная система управления технологическим процессом.

СИСТЕМА ФОРМАЛЬНАЯ

Модель, лежащая в основе многих математических теорий. С.Ф. представляет собой четверку: множество базовых элементов синтаксические правила аксиомы правила вывода.

СИСТЕМА ФРЕЙМОВ

Множество фреймов, связанных между собой различными отношениями.

СИСТЕМА ЭКСПЕРТНАЯ

Интеллектуальная система, предназначенная для оказания консультационной помощи специалистам, работающим в некоторой предметной области. Различают два типа С.Э. Системы первого типа предназначены для специалистов, чей профессиональный уровень не слишком высок. В базах знаний таких систем хранятся знания, полученные от специалистов экстракласса. Системы второго типа призваны помогать специалистам высокой квалификации, выполняя для них значительную часть рутинных операций и просмотр больших массивов информации. Особенностью С.Э. является наличие в них системы объяснений, повышающей консультационную силу С.Э.

СИСТЕМА ЭКСПЕРТНАЯ ПУСТАЯ

Экспертная система, у которой база знаний пуста. При использовании С.ЭП. в некоторой предметной области пользователю необходимо произвести заполнение базы знаний либо самому с помощью специальных инструкций по заполнению базы, либо привлекая инженера по знаниям. Как показал опыт, С.Э.П. могут эффективно использоваться лишь на однотипных предметных областях, на которое ориентированы принятые в С.Э.П. способы представления знаний и рассуждений. (См. также Оболочка.)

СЛЕДСТВИЕ ЛОГИЧЕСКОЕ

Факт, полученный в процессе логического вывода в формальной системе.

СЛОТ

Основная структурная единица фрейма. С. представляет собой пару: (атрибут (имя слота) - значение). В качестве значения могут выступать константные факты, выражения, содержащие переменные, ссылки на другие С. и т. п. С. может иметь структуру, элементы которой сами являются слотами. Часто эти более мелкие С. называют фассетами, ячейками, аспектами и т.п.

СОБЫТИЕ

Информационная единица, которой в базе знаний присваивается интервал времени, в течение которого эта единица существует.

СОПОСТАВЛЕНИЕ С ОБРАЗОМ

Процедура сравнения фрагмента знаний или описания с эталоном-образцом. Входит в состав процедуры поиска по образцу в базах знаний и используется при распознавании образов.

СОСТАВЛЯЮЩАЯ ЗНАНИЙ ИНТЕНСИОНАЛЬНАЯ

Знания о предметной области, которые отражают факты, закономерности, свойства и характеристики, справедливые для любых конкретных ситуаций, которые могут возникнуть в этой предметной области.

СОСТАВЛЯЮЩАЯ ЗНАНИЙ ЭКСТЕНСИОНАЛЬНАЯ

Знания о предметной области, отражающие факты, закономерности, свойства и характеристики, типичные для конкретных ситуаций или классов однотипных ситуаций, которые могут возникнуть в этой области.

СПИСОК АССОЦИАТИВНЫЙ

Совокупность пар "атрибут - значение".

СРЕДСТВА ИНЖЕНИРИИ ЗНАНИЙ ИНСТРУМЕНТАЛЬНЫЕ

Системы программирования, которые упрощают работу по созданию интеллектуальных систем.

ССЫЛКА АНАФОРИЧЕСКАЯ

Способ связывания между собой двух предложений в тексте, когда в первом предложении называется лицо, объект, явление и т. п., а во втором используется анафомическое слово (как правило, местоимение), заменяющее слово из первого предложения. Например, в тексте "Система управления дала сбой. Она не была во время продиагностирована" анафорическое слово "она" во втором предложении указывает, что в нем идет речь о той же системе управления, о которой шла речь в первом предложении. С.А. требует специальных процедур при анализе текстов в интеллектуальных системах. С.А. являются частным случаем анафоры.

СТРАТЕГИЯ УПРАВЛЕНИЯ ВЫВОДОМ

Совокупность правил, с помощью которых организуется выбор правил вывода в формальных системах или выбор продукций в системе продукций при поиске решения. Наиболее известные С.У.В. в формальных логических системах - это прямой вывод и обратный вывод. В системах продукций известно много С.У.В. (принцип "классной доски", учет наиболее длинного условия продукции, принцип "повестки дня" и т. п.).

СТРУКТУРА ГЛУБИННАЯ

Структура, отражающая семантику текста на естественном языке. В С.Г. отсутствуют особенности морфологического или синтаксического строения естественного языка. С.Г. используется при машинном переводе с одного языка на другой, а также обеспечивает понимание текстов на естественном языке, так как от С.Г. легко осуществляется переход к тем представлениям знаний, которые используются в базе знаний.

СТРУКТУРА КОГНИТИВНАЯ

Гипотетическая структура, с помощью которой отображаются и хранятся в памяти человека знания об окружающем мире, возможных действиях в нем и о самом человеке. С.К. изучается в когнитивной психологии.

СТРУКТУРА ОДНОРОДНАЯ

Архитектура новых поколений ЭВМ, образованная одинаковыми активными элементами или процессорами, соединенными между собой однотипным образом (например, расположенных на поверхности тора при регулярном соединении каждого активного элемента или процессора с четырьмя ближайшими соседями). Теоретические модели, связанные с функционированием С.О. изучаются в теории клеточных автоматов.

СТРУКТУРА ПАДЕЖНАЯ

Структура текста, в которой используются глубинные падежи (падежи Филмора). Эти падежи не зависят от грамматических падежей какого-либо естественного языка, а отражают глубинные (ролевые) взаимосвязи элементов, о которых идет речь в тексте. Например, для фраз "Иван рубит дерево" и "Дерево рубится Иваном" грамматические падежи для слов "Иван" и "дерево" различаются. Но в обоих случаях глубинным падежом для "Ивана" является субъектный падеж, а для "дерева" - объектный падеж. Число глубинных падежей у разных авторов колеблется от полутора десятков до тридцати. С.П. является одной из разновидностей глубинной структуры.

СТРУКТУРА ПОЗНОВАТЕЛЬНАЯ

В искусственном интеллекте - модель, в которой происходит соотнесение объектов действительности с их внутренним представлением в памяти интеллектуальной системы. С.П. не зависит от особенностей языка, на котором написан текст, а определяется теми механизмами, которыми располагает человеческое сознание для восприятия окружающего мира и его осмысления.

СУЖДЕНИЕ

Выражение, связывающее между собой субъект и предикат с помощью связки "есть". С. изучается в логике.

СУЩНОСТЬ

Любой объект в предметной области.

СХЕМА КОНЦЕПТУАЛЬНАЯ

См. Ограничение целостности.

СЦЕНАРИЙ

Семантическая сеть, в которой в качестве отношений используются каузальные отношения или отношения типа "действие-результат", "действие-цель", "орудие-действие" и т. п.

ТВОРЧЕСТВО МАШИННОЕ

Направление в искусственном интеллекте, в рамках которого создаются модели и способы генерирования на ЭВМ аналогов результатов творческой деятельности человека. Сюда относятся программы для сочинения музыкальных произведений, стихотворений, прозы, машинная графика и живопись, игровые программы и т. п.

ТЕЗИС ЧЕРЧА

Утверждение о том, что "лямбда"-исчисление эквивалентно интуитивному пониманию алгоритма Т.Ч. аналогичен другим тезисам (например, тезису Тьюринга о том, что машина Тьюринга эквивалентна интуитивному пониманию алгоритмического процесса), позволяющим формализовать понятие алгоритма.

ТЕОРИЯ АКСИОМАТИЧЕСКАЯ

Логическая теория, в которой все исходные аксиомы являются тождественно истинными, а правила вывода - достоверными.

ТЕОРИЯ ЛОГИЧЕСКАЯ

Теория, в основе которой лежит формальная система.

ТЕОРИЯ РЕЧЕВЫХ АКТОВ

Раздел лингвистики, описывающий, как в текстах на естественном языке отражаются мотивы и цели говорящего. В Т.Р.А. большую роль играют внелингвистические компоненты (длительность пауз, тон, громкость произнесения, мимика и жесты), что сближает Т.Р.А. используется при создании модели общения в интеллектуальных системах.

ТЕРМ

Константа, переменная или выражение вида f(t1, t2, ... tn) где f - функциональный символ; ti - термы.

ТИП ДАННЫХ

Объединенные под одним именем по какому-либо признаку данные. Т.Д. используются в базах данных.

ТИП ДАННЫХ АБСТРАКТНЫЙ

Описание данных на языках программирования, позволяющее создавать в памяти ЭВМ те структуры данных, которые удобны для решения задачи.

УНИВЕРСУМ

Область, на которой определены значения предиката. Из этой области берутся значения для означивания переменных, входящих в предикат. Для многоместных предикатов У. есть декартово произведение областей определения для каждого из аргументов предиката.

УНИВЕРСУМ ЭРБРАНА

Специальная область, на которой проверяется невыполнимость множества дизъюнктов (клауз) при реализации процедур вывода типа метода резолюций.

УНИФИКАТОР

Термин объясняется в статье Унификация.

УНИФИКАТОР НАИБОЛЬШИЙ ОБЩИЙ

Унификатор r, обладающий тем свойством, что для всякого другого унификатора q для того же множества выражений существует такая подстановка t, что q = zt, где zt - композиция подстановок r и t.

УНИФИКАЦИЯ

Процедура подстановки термов в два логических выражения вместо переменных. Термы подбираются таким образом, что при замене ими одноименных в двух выражениях переменных оба выражения становятся идентичными. Сама подстановка называется унификатором. У. используется при логическом выводе в методе резолюций.

УПРАВЛЕНИЕ СИТУАЦИОННОЕ

Способ управления сложными техническими и организационными системами, при котором с помощью экспертной информации строится классификатор, позволяющий разбивать все наблюдаемые ситуации на классы и приписывать каждому классу одношаговое решение или первый шаг в многошаговом решении. Для описания ситуаций и классификации их в У.С. используется модель знаний, близкая в семантической сети.

ФАСЕТ

См. Слот.

ФОКУС

В искусственном интеллекте совокупность знаний, активизируемая при формировании или интерпретации сообщения на естественном языке.

ФОРМА ПРЕФИКСНАЯ НОРМАЛЬНАЯ

ФОРМУЛА АТОМАРНАЯ

Выражение вида Н(t1, t2,..., tm), где Н - m-местный предикат, ti - термы.

ФОРМУЛА ЗАМКНУТАЯ

Выражение в формальной системе в котором либо нет переменных, либо переменные являются связанными квантификаторами.

ФОРМУЛА ОБЩЕЗНАЧИМАЯ

Замкнутая формула, сохраняющая тождественную истинность при всех интерпретациях.

ФОРМУЛА ОТКРЫТАЯ

Выражение в формальной системе, в которое входит хотя бы одна переменная, не связанная квантификатором.

ФРАКТАЛ

Множество с нецелой размерностью для описания негладких кривых и поверхностей. Ф. используется в системах машинной графики для задания сложных графических образов и при изменении масштабов изображений. С помощью Ф. удается при изменении масштаба убирать и вводить элементы изображения, зависящие от выбранного масштаба.

ФРЕЙМ

Специальная форма представления знаний, которая определяется рекурсивно. Ф. состоит из конечного числа слотов, каждый из которых имеет имя и значение.

ФРЕЙМ-ОБРАЗЕЦ

1. Фрейм, выступающий в качестве образца при поиске по образцу в базах знаний.
2. Синоним для фрейма-экземпляра.

ФРЕЙМ ПАДЕЖНЫЙ

Фрейм, у которого все слоты имеют имена, являющиеся глубинными падежами.

ФРЕЙМ-ПРОТОТИП

Фрейм, у которого в части слотов (или во всех слотах) отсутствуют константные значения. Ф.П. описывает знание о предметной области. При означивании всех слотов. Ф.П. константными значениями он превращается в фрейм-экземпляр.

ФРЕЙМ-ЭКЗЕМПЛЯР

Фрейм-прототип, у которого значения всех слотов заполнены констативной информацией. Совокупность Ф.Э. образует экстенсиональную базу данных.

ФУНКЦИЯ ВЫХОДОВ

Термин объясняется в статье Автомат конечный.

ФУНКЦИЯ ДОВЕРИЯ

Функция, значение которой характеризует веру субъекта в истинность события или факта.

ФУНКЦИЯ ПЕРЕХОДОВ

Термин объясняется в статье Автомат конечный.

ФУНКЦИЯ ПРИНАДЛЕЖНОСТИ

Характеристическая функция для нечеткого множества, изменяющаяся в интервале (0,1).

ФУНКЦИЯ СКОЛЕМА

Функциональный символ операции по устранению кванторов существования в логических выражениях, приведенных к префиксной нормальной форме.

ЦЕПОЧКА ВЫВОДА

Последовательность формул, начинающаяся с аксиом в которой каждая последующая формула выводится на основе совокупности предшествующих элементов цепочки.

ШКАЛА АБСОЛЮТНАЯ

Шкала, на которой задана метрика, позволяющая отсчитывать расстояния от абсолютного начала.

ШКАЛА МЕТРИЧЕСКАЯ

Шкала, на которой задана метрика, позволяющая оценивать расстояния между элементами, отображенными на шкалу.

ШКАЛА ОСГУДА

Шкала, использующая пары слов-антонимов (острый - тупой, хороший - плохой и т. п.), стоящие на концах шкалы. Средняя позиция шкалы является нейтральной. Кроме того, имеется еще несколько промежуточных делений, как правило, не обозначаемых никакими словами. Ш.О. используется в психологических экспериментах, связанных с выявлением особенностей индивидуального психосемантического пространства испытуемых. (См. также Пространство Осгуда.)

ШКАЛА ОТНОСИТЕЛЬНАЯ

Метрическая шкала, в которой расстояния отсчитываются от какого-либо относительного маркера, например от наблюдаемого в данный момент объекта.

ШКАЛА РАЗМЫТАЯ

Порядковая шкала, на которой располагаются значения лингвистической переменной или интервалы, получаемые из функций принадлежности отсечками соответствующего уровня.

ШКАЛА ТОПОЛОГИЧЕСКАЯ

Шкала, на которой отображается лишь отношение порядка между элементами, расположенными на шкале. Ш.Т. обладает свойствами, присущими метрическим шкалам.

ШКАЛА УНИВЕРСАЛЬНАЯ

Специальная шкала для проецирования размытых шкал, у которых на расположение квантификаторов оказывает влияние конкретная семантика ситуаций, для описания которых они используются. На Ш.У. эти квантификаторы переводятся в другие отражающие общую меру размытости. Ш.У. позволяет сравнивать между собой высказывания, относящиеся к разным размытым шкалам.

ЭВМ НЕЙРОБИОНИЧЕСКАЯ

Новое поколение ЭВМ, архитектура которого опирается на модель формального нейрона. В зависимости от решаемой задачи происходит соединение формальных нейронов между собой с помощью транзитных клеток. Достоинством таких ЭВМ является возможность распараллеливания протекающих процессов. Из формальных нейронов образуется однородная структура или неоднородная, на которой асинхронно протекает несколько процессов.

ЭВРИСТИКА

Прием решения задачи, основанный не на строгих математических моделях и алгоритмах, а на соображениях, восходящих к "здравому смыслу". Как правило, Э. отражает особенности того, как такие задачи решает человек, когда от не пользуется строго формальными приемами. Если эти человеческие способы решения удается запрограммировать, то такие программы называются эвристическими. Э. часто используются при программировании игр, имитации творческих процессов и т. п. В экспертных системах при формализации профессиональных знаний человека, касающихся способов решения задач в той или иной проблемной области, широко используются те Э., которыми руководствуются профессионалы-эксперты.

ЯЗЫК АВТОМАТНЫЙ

Множество цепочек символов, порождаемых с помощью автоматной грамматики.

ЯЗЫК ЗАПРОСОВ

Язык для обращения в базы данных и базы знаний за необходимой информацией. Формально Я.З. это счетное множество цепочек из символов некоторого конечного алфавита. На этом множестве цепочек выделено подмножество правильных цепочек или правильных запросов. Каждый правильный запрос имеет процедурную интерпретацию а операциях, разрешенных для информационных единиц, находящихся в базе данных или базе знаний.

ЯЗЫК КОНТЕКСТНО-СВОБОДНЫЙ

Множество цепочек символов, порождаемых контекстно-свободной грамматикой.

ЯЗЫК КОНТЕКСТНО-СВЯЗАННЫЙ

Множество цепочек символов, порождаемых контекстно-связанной грамматикой.

ЯЗЫК ПРЕДСТВЛЕНИЯ ЗНАНИЙ

Способ описания моделей знаний в системах представления знаний. На сегодняшний день известны Я.П.З. для модели знаний в виде фреймов (языки LISP, FRL, KRL и др.), а также ряд продукционных языков.

ЯЗЫК ПРЕДСТВЛЕНИЯ ЗНАНИЙ ЛОГИЧЕСКИЙ

Язык представления знаний в основе которого лежит исчисление предикатов первого порядка. Выражениями Я.П.З.Л. являются синтаксически правильные формулы этого исчисления. В виде таких формул записывается все хранимые в системе декларативные и процедурные знания. Достоинством Я.П.З.Л. является их полная формализуемость и наличие для них формальных процедур, позволяющих выполнять вывод и анализ таких характеристик записей, как непротиворечивость, эквивалентность и т. п. Недостатком Я.П.З.Л. является плохая наглядность для пользователя информационных единиц, записанных в виде формул логического исчисления.

ЯЗЫК ПРОДУКЦИОННЫЙ

Язык предствления знаний, основной единицей которого является продукция.

ЯЗЫК СЕКВЕНЦИЙ

Язык, ориентированный на описание дискретных автоматических устройств, в частности конечных автоматов с памятью и без памяти. Позволяет строить компактные описания, особенно для сильно недоопределенных автоматов. Описание на Я.С. состоит из секвенций, каждая из которых является частным случаем продукции, в левой и правой части которой находятся булевы функции. Смысл секвенции состоит в том, что правая функция принимает значение 1, если левая функция равна 1, и не определена, если левая функция равна 0.

ЯЗЫК ФРЕЙМОВЫЙ

Язык представления знаний и манипулирования знаниями, использующий в качестве модели знаний фреймовые представления. Наиболее известными Я.Ф. являются языки FRL и KRL.

ЯЩИК СЕРЫЙ

Объект исследований, о внутреннем устройстве которого либо известно частично, либо существуют некоторые гипотезы. В отличие от черного ящика, модели Я.С. учитывают помимо связей между реакциями и внешними воздействиями и те частичные сведения, которые известны о его внутреннем строении.

ЯЩИК ЧЕРНЫЙ

Введенное У. Р. Эшби наименование объекта исследования, внутреннее устройство которого неизвестно или не принимается во внимание. Модель Я.Ч. строится на основе его поведения т.е. реакции на воздействия, поступающие на вход извне, и характеризует связи между реакциями и вызвавшими их воздействиями. Модели Я.Ч. теоретически обосновываются в направлении экспериментальной психологии, называемом бихевиоризмом, и обычно называются моделями "стимул - реакция".