Винер Н

Винер Н. Кибернетика, или управление и связь в животном и машине. – 2-е издание. – М.: Наука; Главная редакция изданий для зарубежных стран, 1983. – 344 с.

АРТУРО РОЗЕНБЛЮТУ,
МОЕМУ ТОВАРИЩУ ПО НАУКЕ
В ТЕЧЕНИЕ МНОГИХ ЛЕТ.

ОГЛАВЛЕНИЕ

Норберт Винер и его “Кибернетика” (от редактора перевода)
Предисловие ко второму изданию

Часть I. Первоначальное издание (1948 г.)

Введение
Глава I. Ньютоново и бергсоново время
Глава II. Группы и статистическая механика
Глава III. Временные ряды, информация и связь
Глава IV. Обратная связь и колебания
Глава V. Вычислительные машины и нервная система
Глава VI. Гештальт и универсалии
Глава VII. Кибернетика и психопатология
Глава VIII. Информация, язык и общество
Замечание

Часть II. Дополнительные главы (1961 г.)

Глава IX. Об обучающихся и самовоспроизводящихся машинах
Глава X. Мозговые волны и самоорганизующиеся системы

Приложения

Приложение I. Розенблют А., Винер Н., Бигелоу Дж. Поведение, целенаправленность и телеология
Приложение II. Винер Н. Машина умнее своего создателя
Приложение III. Винер Н. Кибернетика и человек: Интервью для советского журнала “Природа”
Приложение IV. Винер Н. Машины изобретательнее людей? Интервью для журнала “Юнайтед Стэйтс Ньюс энд Уорлд Рипорт”)

Предметно-именной указатель


Поваров Г

Поваров Г.Н. Норберт Винер и его “Кибернетика” (от редактора перевода). // Винер Н. Кибернетика, или управление и связь в животном и машине. – 2-е издание. – М.: Наука; Главная редакция изданий для зарубежных стран, 1983. – С. 5–28.

Красным шрифтом в квадратных скобках обозначается конец текста на соответствующей странице печатного оригинала данного издания

НОРБЕРТ ВИНЕР И ЕГО “КИБЕРНЕТИКА”
(от редактора перевода)

История века делается у нас на глазах. Мы с изумлением взираем на странные громады, выросшие на недавних пустырях, а затем быстро к ним привыкаем, обживаем их и спешим дальше, к новым стоэтажным небоскребам.

История кибернетики насчитывает 19 лет, официальная история, начало которой положил Норберт Винер, профессор математики Массачусетсского технологического института, когда опубликовал в 1948 г. свою знаменитую книгу “Кибернетика, или управление и связь в животном и машине”. Конечно, эта история имела свою предысторию, возводимую позднейшими авторами к самому Платону, но о кибернетике заговорили повсюду лишь после винеровской сенсации. Казавшаяся вначале только сенсацией, кибернетика превратилась в настоящее время в обширную я влиятельную отрасль мировой науки.

Норберт Винер уже окончил свои земные труды. Это был один из самых блестящих и парадоксальных умов капиталистического Запада, глубоко обеспокоенный противоречиями атомного века, напряженно размышлявший о судьбе человека в эпоху небывалого могущества науки и техники. “Человеческое использование человеческих существ” – так названа его вторая кибернетическая книга. Он чувствовал крушение старого либерального гуманизма, но, подобно Эйнштейну я ряду других представителей западной мысли, не обрел пути к новым ценностям. Отсюда его пессимизм, облаченный в одежды стоицизма; он страшился роли Кассандры.

Он оставил после себя большое научное наследство, сложное и противоречивое, во многом спорное, во многом интересное и стимулирующее. Это наследство требует вдумчивого, критического, философского подхода, далекого от крайностей отрицания и преувеличения, какие столь часто приходилось слышать. И в этом наследстве первое место занимает “Кибернетика” – книга, провозгласившая рождение новой науки.

Это главная книга Винера, итог всей его научной деятельности. Винер называл ее “описью своего научного багажа”. Она представляет собой важнейший материал к характеристике ученого и вместе с тем памятник ранней, романтической поры кибернетики, “периода бури и натиска”. Но она не потеряла научного [c.5] значения и может оказаться небесполезной для пытливого исследователя и в новых условиях, когда кибернетика, завоевав место под солнцем, озабочена рациональной организацией завоеванного.

Первое английское издание “Кибернетики” увидело свет в США и Франции в 1948 г.1 Скромная книга в красном переплете, изобиловавшая описками и опечатками, скоро стала научным бестселлером, одной из “книг века”. В 1958 г. она переводится на русский в издательстве “Советское радио”. В 1961 г. в США вышло второе издание “Кибернетики”2 с новым авторским предисловием и новыми главами, составившими вторую часть книги; прежний ее текст, перепечатанный без изменений, лишь с правкой ошибок, сделан первой частью. В 1963 г. издательство “Советское радио” выпустило книгу “Новые главы кибернетики”, содержащую перевод предисловия и второй части из второго издания. Ныне вниманию читателей предлагается полный пересмотренный перевод издания с приложением некоторых дополнительных статей и бесед Винера.

* * *

Проф. Винер значительно облегчил задачу своих биографов, написав на склоне лет две книги воспоминаний: одна из них посвящена детству и годам учения (“Бывший вундеркинд”3); другая – профессиональной карьере и творчеству (“Я–математик”4).

Норберт Винер родился 26 ноября 1894 г. в г. Колумбия, штат Миссури, в семье еврейского иммигранта. Его отец, Лео Винер (1862–1939), уроженец Белостока, тогда принадлежавшего России, в молодости учился в Германии, а затем переселился за океан, в Соединенные Штаты. Там, после разных приключений, он стал со временем видным филологом. В Колумбии он уже был профессором современных языков в Миссурийском университете, позже состоял профессором славянских языков старейшего в США Гарвардского университета, в г. Кембридже, штат Массачусетс, близ Бостона. В этом же американском Кембридже в 1915 г. обосновался Массачусетсский технологический институт (МТИ), Одно из главных высших технических училищ страны, в котором [c.6] впоследствии работал и сын5. Лео Винер был последователем Толстого и его переводчиком на английский. Как ученый, он проявлял весьма широкие интересы и не отступал перед рискованными гипотезами6. Эти его качества были унаследованы Норбертом Винером, отличавшимся, однако, по-видимому, большей методичностью и глубиной.

По семейному преданию, Винеры происходят от известного еврейского ученого и богослова Моисея Маймонида из Кордовы (1135–1204), лейб-медика при дворе султана Саладина Египетского. Норберт Винер с гордостью отзывался об этой легенде, не ручаясь, однако, вполне за ее достоверность. Особенно восхищала его разносторонность Маймонида.

Будущий основатель кибернетики был в детстве “вундеркиндом”, ребенком с рано пробудившимися способностями. Этому во многом содействовал отец, занимавшийся с ним по собственной программе. Юный Норберт семи лет читал Дарвина и Данте, одиннадцати – окончил среднюю школу, четырнадцати – высшее учебное заведение, Тафтс-колледж. Здесь получил он свою первую ученую степень – бакалавра искусств.

Затем он учился в Гарвардском университете уже как аспирант (graduate student) и семнадцати лет стал магистром искусств, а восемнадцати, в 1913 г., доктором философии по специальности “математическая логика”. Титул доктора философии в данном случае не является только данью традиции, так как Винер сначала готовил себя к философской карьере и лишь впоследствии отдал предпочтение математике. В Гарварде он изучал философию под руководством Дж. Сантаяны и Дж. Ройса (имя которого читатель найдет в “Кибернетике”). Философское образование Винера сказалось впоследствии при выработке проекта новой науки и в книгах, которые он написал о ней.

Гарвардский университет предоставил молодому доктору стипендию для поездки в Европу. В 1913–1915 гг. Винер посещает Кембриджский университет в Англии и Гёттингенский в Германии, но в связи с войной возвращается в Америку и заканчивает свое образовательное путешествие в Колумбийском университете в Нью-Йорке. В английском Кембридже Винер занимался у знаменитого Б. Рассела, который в начале века был ведущим авторитетом в области математической логики, и у Дж. X. Харди, известного математика, специалиста по теории чисел. Впоследствии [c.7] Винер писал: “Рассел внушил мне весьма разумную мысль, что человек, собирающийся специализироваться по математической логике и философии математики, мог бы знать кое-что и из самой математики”7. В Гёттингене Винер занимался у крупнейшего немецкого математика Д. Гильберта, слушал лекции философа Э. Гуссерля.

В 1915 г. началась служба. Винер получил место ассистента на кафедре философии в Гарварде, но только на год. В поисках счастья он сменил ряд мест, был журналистом, хотел идти в солдаты. Впрочем, он, по-видимому, был достаточно обеспечен и не испытывал нужды. Наконец, при содействии математика Ф.В. Осгуда, друга отца, Винер получил работу в Массачусетсском технологическом институте. В 1919 г. Винер был назначен преподавателем (instructor) кафедры математики МТИ и с тех пор всю жизнь оставался сотрудником института. В 1926 г. Винер вступил в брак с Маргаритой Энгеман, американкой немецкого происхождения.

Годы 1920–1925 Винер считал годами своего становления в математике. Он обнаруживает стремление решать сложные физические и технические задачи методами современной абстрактной математики. Он занимается теорией броунова движения, пробует свои силы в теории потенциала, разрабатывает обобщенный гармонический анализ для нужд теории связи. Академическая карьера его протекает медленно, но успешно.

В 1932 г. Винер–полный профессор. Он завоевывает имя в ученых кругах Америки и Европы. Под его руководством пишутся диссертации. Он издает ряд книг и больших мемуаров по математике: “Обобщенный гармонический анализ”, “Тауберовы теоремы”, “Интеграл Фурье и некоторые его применения” и др.8 Совместное исследование с немецким математиком Э. Гопфом (или Хопфом) о радиационном равновесии звезд вводит в науку “уравнение Винера–Гопфа”9. Другая совместная работа, монография “Преобразование Фурье в комплексной области” написана в сотрудничестве с английским математиком Р. Пэли10. Эта книга вышла в свет при трагических обстоятельствах: еще до ее окончания англичанин погиб в Канадских Скалистых горах во время лыжной прогулки. Отдает Винер дань и техническому творчеству, в компании с китайским ученым Ю.В. Ли и В. Бушем, известным конструктором аналоговых вычислительных машин. В 1935–1936 гг. Винер был вице-президентом Американского математического общества.

В 20-е и 30-е годы Винер неоднократно бывает в Европе, завязывает обширные научные знакомства, подолгу живет в Кембридже и Гёттингене, участвует в международных математических [c.8] конгрессах. В числе его знакомых М. Фреше, Ж. Адамар, Н. Бор, М. Борн, Дж. Холдэйн, Дж. Бернал и др. В 1935–1936 гг. Винер посещает Китай в качестве “разъездного профессора” (visiting professor) и читает лекции в пекинском университете Цинхуа. Путешествиям и личному научному общению Винер придавал большое значение в своем научном развитии.

Год поездки в Китай – 1935 – Винер считал важным рубежом своей жизни, началом научной зрелости. Ему исполнилось сорок лет, он добился признания и прочного положения в науке. “Мои труды начали приносить плоды – мне удалось не только опубликовать ряд значительных самостоятельных работ, но и выработать определенную концепцию, которую в науке уже нельзя было игнорировать”11. Развитие этой концепции привело затем Винера к знаменательному проекту кибернетики.

Еще в 30-е годы Винер сближается с мексиканским ученым Артуром Розенблютом, сотрудником известного американского физиолога У.Б. Кеннона12, и принимает участие в вольном методологическом семинаре, организованном Розенблютом и объединявшем представителей разных наук. Этот семинар сыграл важную роль в предуготовлении винеровской кибернетики. С рассказа о нем и начинается настоящая книга. Знакомство с мексиканским физиологом ввело Винера в мир биологии и медицины; в его уме стала укрепляться мысль о широком синтетическом подходе к проблемам современной науки.

История рождения кибернетики и изобретения термина излагается подробно в книге самого Винера, и я не буду ее здесь повторять. Окончательный толчок дала II мировая война. Механизированная борьба с применением новейших технических средств поставила перед воюющими сторонами сложнейшие технические проблемы и превратила лаборатории в поля сражений. Проблемы автоматического управления и автоматической связи получили необыкновенную остроту, быстро развивалась вычислительная техника. Винер во время войны работал в этой ответственной области и, сравнивая функции автоматических устройств с функциями живых существ, суммируя свои многолетние научные искания, пришел к проекту новой науки.

Отметим лишь два события: составление Винером в 1942 г. для военных секретного отчета, в котором он приблизился к общей статистической теории информации, и появление в 1943 г. статьи трех авторов с первым наброском кибернетического метода, хотя этого слова там еще не было. После войны отчет был рассекречен и издан в 1949 г. в виде монографии “Интерполяция, экстраполяция и сглаживание стационарных временных рядов”13 (впоследствии она издавалась под более лаконичным названием “Временные ряды”). Статья А. Розенблюта, Н. Винера и Дж. Бигелоу “Поведение, целенаправленность и телеология”14 представляет большой интерес [c.9] для понимания генезиса кибернетики. Это тщательно составленный манифест, призывающий к широкому изучению телеологических систем – систем с обратной связью. Мы приводим полный перевод этой малоизвестной у нас статьи в качестве приложения к книге.

Знаменитая книга писалась Винером в 1947 г. в Мексике, у Розенблюта, который еще во время войны вернулся на родину. Винер признавал своего мексиканского друга соизобретателем новой науки и посвятил ему первое ее изложение. И вот наступил 1948 год – год славы Винера, год выхода “Кибернетики”. “Появление книги в мгновение ока превратило меня из ученого-труженика, пользующегося определенным авторитетом в своей специальной области, в нечто вроде фигуры общественного значения. Это было приятна, но имело и свои отрицательные стороны, так как отныне я был вынужден поддерживать деловые отношения с самыми разнообразными научными группами и принимать участие в движении, которое быстро приняло такой размах, что я уже не мог с ним справиться”15.

В 1948 г. Винеру уже 53 года, но энергия его не иссякает. Он ведет пропаганду и популяризацию кибернетики, продолжает свои исследования, пишет статьи и книги. Особенно его интересует применение кибернетических методов к проблемам физиологии и общей биологии. В 1950 г. он пишет вторую кибернетическую книгу “Человеческое использование человеческих существ”16, в 1958 г. появляются “Нелинейные задачи в теории случайных процессов”17, в 1961 г. – второе издание “Кибернетики”, в 1963 г. – третья, весьма своеобразная кибернетическая книга Винера “Акционерное общество Бог и Голем”18. Выходят книги воспоминаний, о которых мы уже говорили выше. Винер выступает перед публикой в роли романиста (“Искуситель”19).

По-прежнему Винер много путешествует, часто наезжает в Европу. В 1953 г. по приглашению индийских властей он совершает поездку в Индию с лекционным турне. В 1960 г. во время I конгресса Международной федерации автоматического управления (IFAC) Винер посещает Советский Союз; он встречается и беседует с советскими учеными, дает интервью журналистам, выступает с [c.10] лекцией о мозговых волнах в Политехническом музее. В приложении к книге мы приводим его интервью для московского журнала “Природа”. Интересна его беседа в редакции “Вопросов философии”20; позже он опубликовал в этом журнале статью “Наука и общество”21.

В 1963 г. за выдающиеся заслуги в области математики, техники и биологических наук Винер награжден Национальной медалью науки–высшим американским отличием для ученых. В феврале 1964 г. журнал “Юнайтед Стэйтс Ньюс энд Уорлд Рипорт” публикует последнее его интервью “Машины изобретательнее людей?”22 Смерть постигла основателя кибернетики 18 марта 1964 г., в возрасте 69 лет.

* * *

Винер был ученым широкого профиля, ученым-полигистором23, как когда-то называли таких людей. Он как бы воскресил в наши дни традиции универсализма, процветавшие во времена лейбницев и бюффонов. Широта интересов сочеталась в нем с глубоким убеждением в единстве науки и в необходимости тесного союза различных ее отраслей. Он был врагом узкой специализации, дробления науки на бесчисленные изолированные ветви. Отсюда его внимание к вопросам метода, к философии науки, отсюда его стремление к широким синтезам, его мысли о потаенных богатствах “ничьих земель”, пограничных полос между отдельными дисциплинами.

Рассказывая о своей работе с Розенблютом, он писал: “Прежде всего нас объединял глубокий интерес к вопросам научной методологии, а кроме того, мы оба были убеждены, что деление науки на различные дисциплины есть не более, чем административная условность, нужная лишь для удобства распределения средств и сил. Мы не сомневались, что каждый творчески работающий ученый волен ломать любые перегородки, если это нужно для успеха его работы, и нам обоим было совершенно ясно, что наука должна создаваться объединенными усилиями многих людей”24.

С сарказмом рисует он в “Кибернетике” портрет узкого специалиста: “Он набит жаргоном своей специальной дисциплины и знает всю литературу по ней и все ее подразделы. Но всякий вопрос, сколько-нибудь выходящий за эти узкие пределы, такой ученый чаще всего будет рассматривать как нечто, относящееся к коллеге, который работает через три комнаты дальше по коридору. Более того, всякий интерес со своей стороны к подобному вопросу он будет считать непозволительным нарушением чужой тайны”25. [c.11]

В главной своей специальности – математике – Винер решительно выступал против разделения ее на чистую и прикладную. Математика для него едина и связана органически с естествознанием. “Ведь высшее назначение математики как раз и состоит в том, чтобы находить скрытый порядок в хаосе, который нас окружает”26. Он широко применял к практическим задачам мощные абстрактные методы современной математики, но в то же время призывал учиться математике у самой природы. “Природа, в широком смысле этого слова, может и должна служить не только источником задач, решаемых в моих исследованиях, но и подсказывать аппарат, пригодный для их решения”27.

Другой характерной чертой Винера как ученого была научная смелость, готовность к гипотезе, к риску, соединенная с любовью к необычайному, сложному, парадоксальному. “Нужно иметь храбрость поверить в свои убеждения, иначе самое интересное, что могло прийти вам в голову, у вас из-под носа заберут другие, более отважные, духом, но главное – это ведь единственное, ради чего по-настоящему стоит работать”28. Вся “Кибернетика” полна догадок, гипотез, аналогий. Понятно, что при таких устремлениях он нередко забегал вперед, в области, где почва еще не отвердела и надежное движение затруднительно. Это был ученый-разведчик, или, как говорил В. Оствальд, ученый-романтик. Недаром всю жизнь он работал с вероятностями!

Выросший в атмосфере XIX в., которая еще сохранялась в канун I мировой войны, Винер любил индивидуальное, независимое творчество в стиле прежних мастеров науки и резко осуждал административную рутину больших лабораторий. “Я счастлив, что родился до I мировой войны, когда силы и порыв ученого мира еще не захлестнуло волнами сорока лет катастроф. Я особенно счастлив, что мне не пришлось долгие годы быть одним из винтиков современной научной фабрики, делать, что приказано, работать над задачами, указанными начальством, и использовать свой мозг только in commendam29, как использовали свои лены средневековые рыцари. Думаю, что, родись я в теперешнюю эпоху умственного феодализма, мне удалось бы достигнуть немного. Я от всего сердца жалею современных молодых ученых, многие из которых, хотят они этого или нет, обречены из-за духа времени служить интеллектуальными лакеями или табельщиками, отмечающими время прихода и ухода с работы”30.

В вопросах религии Винер признавал себя “скептиком”, стоящим вне исповеданий, но отмежевывался от воинствующего атеизма, приравнивая последний к религии31. Философские и социальные [c.12] воззрения его, в общих рамках буржуазного радикализма, характеризуются такой же промежуточностью и парадоксальностью. Кризис старого мира набрасывает на них тревожную предзакатную тень. Автор “Кибернетики” смел в суждениях, но зыбок в надеждах.

Анализ мировоззрения крупных ученых всегда представляет известные трудности именно потому, что мы имеем дело с людьми незаурядными и своеобразными. С другой стороны, необходимо принимать расчет среду, место, время. Наклеивание ярлыков, как и искусственное сближение с нашими собственными взглядами, здесь одинаково недопустимо. Избегая чрезмерной полемики, отметим некоторые общие черты мировоззрения Винера, сказавшиеся на его научном творчестве.

Винер не причисляет себя к известным философским школам. Он сводит материализм к механицизму32, но не приемлет и идеализма, “растворяющего все вещи в уме”33. Не приходится сомневаться, что американский ученый испытал значительное влияние позитивизма, в широком смысле. Но ближе всего он, по-видимому, к физикам копенгагенской школы, таким, как его знаменитые друзья Н. Бор и М. Борн, притязавшие, как известно, на особое “реалистическое” мировоззрение, вне материализма и идеализма, и провозгласившие независимость “от профессиональных метафизиков”34. Взгляды копенгагенцев вызывали в нашей философской литературе много споров, но в последние годы возобладало мнение, что за позитивистской формой в них можно найти некоторые диалектико-материалистические тенденции35. То же, по-видимому, можно сказать и о Винере, если вдуматься в смысл его критики механицизма. Современное естествознание парадоксально не только по содержанию, но часто и по форме. Впрочем, тенденции эти не стоит преувеличивать.

Винер излагает свои философские взгляды более всего в “Человеческом использовании человеческих существ” (другое название – “Кибернетика и общество”), отчасти в “Кибернетике” и других работах. Подобно копенгагенцам, он апеллирует в первую очередь к опыту новой физики; кибернетика для него теснейше связана со статистической механикой. Он ищет преодоления слабостей старого примитивного механицизма в стохастической, вероятностной концепции Вселенной. В то же время пессимистическая трактовка случайности сближает его с таким течением западной философии, как экзистенциализм, – связь, отмеченная самим Винером. В целом винеровский взгляд на мир можно, по-видимому, определить как своего рода казуализм36, не лишенный диалектики, но с сильным уклоном к агностицизму я релятивизму.

Случайность существует в природе объективно, и новая физика в отличие от детерминистической физики Ньютона – Лапласа является по преимуществу стохастической. Дело, однако, в том, [c.13] какую роль отвести случайности в общем механизме Вселенной. Проблема соотношения необходимости и случайности, детерминизма и вероятности – одна из сложнейших в современном естествознании) уже самая случайность подчиняется определенным законам необходимости, без чего не было бы и теории вероятностей.

Винер называет родоначальником стохастического естествознания американского физика У. Дж. Гиббса и видит в себе продолжателя его замыслов. В своем решении проблемы необходимости и случайности Винер учитывает обе стороны медали, но, чувствуется, дает первенство одной из них. В результате история природы и человека приобретает у него довольно капризный, как бы игорный характер. Признавая известную закономерность окружающего нас мира, он резко подчеркивает случайные, иррациональные моменты бытия и ограниченные возможности человека.

В вероятностной Вселенной Винера порядок борется с хаосом, но, как состояние менее вероятное, неизбежно проигрывает битву. Прогресс – явление преходящее, локальное. Человек – звено этой борьбы. “Мы плывем вверх по течению, борясь с огромным потоком дезорганизованности, который в соответствии со вторым законом термодинамики стремится все свести к тепловой смерти – всеобщему равновесию и одинаковости. То, что Максвелл, Больцман и Гиббс в своих физических работах называли тепловой смертью, нашло своего двойника в этике Киркегора, утверждавшего, что мы живем в мире хаотической морали. В этом мире наша первая обязанность состоит в том, чтобы устраивать произвольные островки порядка и системы”37.

Не избежать общей участи и нашему подлунному миру: “Мы в самом прямом смысле являемся терпящими кораблекрушение пассажирами на обреченной планете”38.

Правда, тепловая смерть мыслится Винером как асимптотическое, предельное состояние, достижимое лишь в вечности, так что упорядочивающие флюктуации возможны и в будущем. “В мире, где энтропия в целом стремится к возрастанию, существуют местные и временные островки уменьшающейся энтропии, и наличие этих островков дает возможность некоторым из нас доказывать наличие прогресса”39. Механизм их возникновения состоит в естественном отборе устойчивых форм40; здесь физика непосредственно переходит в кибернетику.

Стремясь в конечном счете к вероятнейшему, стохастическая Вселенная не знает единственного предопределенного пути, и это позволяет порядку бороться до времени с хаосом. Человек воздействует в свою пользу на ход событий, гася энтропию извлеченной из окружающей среды отрицательной энтропией – информацией. Познание – часть жизни, более того – самая ее суть. “Действенно жить–это значит жить, располагая правильной информацией”41. Однако победы познания временны, как временна жизнь. “Я никогда не представлял себе логику, знания и всю умственную [c.14] деятельность как завершенную замкнутую картину; я мог понять эти явления только как процесс, с помощью которого человек организует свою жизнь таким образом, чтобы она протекала в соответствии с внешней средой. Важна битва за знание, а не победа. За каждой победой, т.е. за всем, что достигает апогея своего, сразу же наступают сумерки богов, в которых само понятие победы растворяется в тот самый момент, когда она будет достигнута”42.

Человеческие способности познания стохастической Вселенной и управления ею ограничены. Это, по Винеру, обусловлено уже стохастическим характером связи между человеком и окружением. “В вероятностном мире мы уже не имеем больше дела с величинами и суждениями, относящимися к определенной реальной Вселенной в целом, а вместо этого ставим вопросы, ответы на которые можно найти в допущении огромного числа подобных миров”43. Иными словами, здесь также возникает кибернетическая проблема “шума”.

Самое существование вероятностей есть для Винера в конечном счете гипотеза “Никакое количество чисто объективных и отдельных наблюдений не может показать, что вероятность является обоснованной идеей. Иными словами, законы индукции в логике нельзя установить с помощью индукции. Индуктивная логика, логика Бэкона, представляет собой скорее нечто такое, в соответствии с чем мы может действовать, чем то, что мы можем доказать”44.

Статистическим методам в физике Винер ставит в параллель иррационалистические течения в философии и психологии – экзистенциализм, фрейдизм, бергсоновский интуиционизм. Выше уже приводилась цитата с параллелью между Гиббсом и отцом экзистенциализма Киркегором, а в “Кибернетике” мы найдем ссылки на Бергсона. Винер – рационалист, но, как казуалист, он согласен допустить глубоко иррациональный компонент в поведении и мышлении человека.

Этот “интеллектуальный пессимизм”45, вызванный торжествующим буйством случая, Винер хотел дополнить своеобразным новым стоицизмом и тем самым внести “нечто положительное” в трагические учения Киркегора и Сартра “Лучшее, на что мы может надеяться, говоря о роли прогресса во Вселенной, в целом идущей к своей гибели, так это то, что зрелище наших устремлений к прогрессу перед лицом гнетущей нас необходимости может иметь смысл очищающего ужаса греческой трагедии”46. “Никакое поражение не может лишить нас успеха, заключающегося в том, что в течение определенного времени мы пребывали в этом мире, которому, кажется, нет до нас никакого дела”47.

Я не могу здесь входить в подробный разбор всех этих посылок и выводов. Такой разбор, наверное, вылился бы в новую книгу. Картине мироздания, рисуемой Винером, нельзя отказать в известном мрачном величии, но по существу она более вопрос интерпретации, чем фактов. Напрашивается мысль, что основатель кибернетики [c.15] смотрел на вещи слишком мрачно и что другое понимание необходимости и случайности открыло бы перед нами более оптимистические виды.

Вокруг второго закона термодинамики десятилетиями кипела физическая и философская полемика. Заметим лишь, что даже при справедливости его для всей Вселенной в целом невозможно указать верхнюю границу во времени и пространстве для существования счастливых “островков порядка”. Если тепловая смерть достижима лишь в вечности, как предел неограниченно долгого процесса, то и прогресс может продолжаться сколь угодно и распространяться по Вселенной вширь – при условии, что он достаточно организован и целеустремлен. Бесконечность допускает подобные парадоксы. В частности, человечество не приковано к Земле и может “сменить пароход”, выйдя в космос. Мыслимы и другие оптимистические гипотезы; я хотел показать лишь сложность того, что некоторые называют “кибернетической эсхатологией”. Винер прав, однако, в том, что человек сам должен позаботиться о своем будущем. “Простая вера в прогресс является убеждением не силы, а покорности и, следовательно, слабости”48.

Социальные идеалы Винера суть идеалы абстрактного гуманизма, но пути к ним для него не ясны или, скорее, случайны. Мечтая об обществе, основанном “на человеческих ценностях, отличных от купли-продажи”49, о здоровой демократии и братстве народов, клеймя фашизм и войну, Винер возлагал надежды на “уровень общественного сознания”, на “прорастание зерен добра”, а в целом смотрел на будущее довольно мрачно. Он колебался между резкой критикой капиталистического бизнеса, столь ярко выраженной в “Кибернетике”, и упованием на “социальную ответственность” деловых кругов50. Не приходится говорить, что он далек от пролетарского коллективизма.

Ближайшее будущее казалось ему критической эпохой, кульминацией противоречий прогресса. “Многие из нас не понимают, что последние четыреста лет представляют собой весьма специфический период в мировой истории. Скорость, с какой происходили изменения на протяжении этих лет, не имеет себе подобия в прежней истории. Так же обстоит дело и с самой природой этих изменений... Мы столь радикально изменили нашу среду, что теперь, для того чтобы существовать в этой среде, мы должны изменить себя”51. Даже мозг человеческий чудится Винеру близким к исчерпанию своего могущества. “Быть может, человеческий мозг продвинулся так же далеко по пути к этой губительной специализации, как большие носовые рога последних титанотериев”52.

Сама кибернетика становится фактором кризиса, способствуя II промышленной революции. “Новая промышленная революция является обоюдоострым оружием. Она может быть использована на благо человечества, однако только в том случае, если человечество просуществует достаточно длительное время, чтобы вступить в период, когда станут возможны такие блага. Она может быть также [c.16] использована для уничтожения человечества, и если ее не использовать со знанием дела, она может очень быстро развиваться в этом направлении”53. “Час пробил, и выбор между добром и злом у нашего порога”54.

Считая Запад клонящимся к интеллектуальному и моральному упадку, Винер питал большой интерес к странам Востока с их древней культурой. Выше уже говорилось о его путешествиях в Китай и Индию. Он предложил индийскому правительству план индустриализации Индии через строительство кибернетических заводов-автоматов, чтобы избежать “опустошительной пролетаризации”55. “Превосходство европейской культуры над великой культурой Востока, – писал он, – лишь временный эпизод в истории человечества”56. Он полагал себя связанным с Востоком и в личном плане своим происхождением, хотя в целом считал себя американцем.

* * *

Главный труд Винера, прославивший его имя, – “Кибернетика” является ярким отражением личности своего автора. Разнообразие знаний, широта интересов, любовь к риску, парадоксальность, тревога за будущее, даже пристрастие к европейской старине – все это запечатлелось на страницах книги, отлилось в романтический проект новой науки “об управлении и связи в животном и машине”.

Основной тезис книги – подобие процессов управления и связи в машинах, живых организмах и обществах, будь то общества животных (муравейник) или человеческие. Процессы эти суть прежде всего процессы передачи, хранения и переработки информации, т.е. различных сигналов, сообщений, сведений. Любой сигнал, любую информацию, независимо от ее конкретного содержания и назначения, можно рассматривать как некоторый выбор между двумя или более значениями, наделенными известными вероятностями (селективная концепция информации), и это позволяет подойти ко всем процессам с единой меркой, с единым статистическим аппаратом. Отсюда мысль об общей теории управления и связи – кибернетике.

Количество информации – количество выбора – отождествляется Винером с отрицательной энтропией и становится, подобно количеству вещества или энергии, одной из фундаментальных характеристик явлений природы. Таков второй краеугольный камень кибернетического здания. Отсюда толкование кибернетики как теории организации, как теории борьбы с мировым хаосом, с роковым возрастанием энтропии.

Действующий объект поглощает информацию из внешней среды и использует ее для выбора правильного поведения. Информация никогда не создается, она только передается и принимается, но при этом может утрачиваться, исчезать. Она искажается помехами, “шумом”, на пути к объекту и внутри его и теряется для него. [c.17] Борьба с энтропией – борьба с шумом, искажающим информацию.

Таковы, в немногих словах, главные мысли книги. Она не содержит, однако, последовательного курса кибернетики. В 1948 г. это был только проект. Сам Винер не раз отмечает в книге ее предварительный, вводный характер. Хотя Винер и располагал определенными результатами и методами, включая элементы заложенной им и К.Э. Шенноном теории информации, до подробного, систематического построения новой науки было еще далеко. Теория управления гораздо шире фундаментальной теории информации и очерчена Винером весьма бегло. В целом перед нами ряд эскизов, общая программа, набросанная большими мазками, отважно апеллирующая к аналогии и гипотезе, скорее индуктивная, нежели дедуктивная. Небывалый синтез только намечен, здание еще все в лесах.

Винер видит обширное поле для приложения новых понятий. С кибернетических позиций атакует он проблемы техники, физики, биологии, физиологии, медицины, психологии, социологии. Он убежден, что кибернетика даст возможность объединить и упорядочить огромный материал из разных областей, наладить сотрудничество ученых разных специальностей, вооружить их общим языком и общей методикой.

Основатель кибернетики не ограничивается специальными научными вопросами. Он задумывается над общественной миссией кибернетики, переходит к проблемам философским и моральным; теория соединяется с публицистикой, специальные исследования – с вольными размышлениями о путях науки и путях человека.

Книга Винера весьма своеобразна по своей форме и стилю. Не монография обычного типа, не сухой ученый трактат, а живое, свободное изложение мыслей автора, с неожиданными отступлениями и внезапными догадками, с гражданскими раздумьями, со сложными математическими формулами на одних страницах и художественными литературными образами на других. Определение чередуется с метафорой, доказательство – с притчею. Автор рассказывает нам историю своих исканий, дает прочувствовать свои мотивы и основания, проследить постепенную кристаллизацию идей. В книге много эмоционального, она взывает не только к уму читателя, но и к его воображению и чувству. Это особый жанр, своего рода научные этюды или эссе, напоминающие произведения ученых-универсалистов прежних времен. Я сравнил бы “Кибернетику” Винера с “Эпохами природы” Бюффона, хотя последний обладал более изящным пером.

Обращаясь к специалистам разных профилей и просто к широкой публике, Винер, естественно, должен был позаботиться о доступности общего содержания книги, главных своих положений и выводов, и в той или иной степени разъяснить используемые им понятия и данные далеких друг от друга дисциплин. Физиологи нуждались в некоторых пояснениях по части математики, математики – по части физиологии и т.д. Благодаря выборочной, как бы “контурной” популяризации, книгу может прочесть с интересом каждый образованный читатель. Тем не менее это отнюдь не популярная книга, и подлинный разбор ее и оценка требуют больших усилий.

Математические разделы книги написаны столь бегло и лаконично, что доступны вполне лишь хорошо подготовленному математику. Степень популяризации и детализации колеблется от места [c.18] к месту; многие промежуточные звенья пропущены, намеки заменяют изложение. Читатель, пожелавший глубоко проштудировать материал и досконально разобраться в умозаключениях автора, должен накопить основательные звенья в области теории вероятностей, математической статистики, математической логики, функционального анализа, статистической физики, теории автоматического регулирования, теории вычислительный машин, неврологии и невропатологии. Необходимо изучение предыдущих математических работ Винера, на которые тот ссылается в тексте. Впрочем, книга адресована не индивидуальному, а коллективному читателю.

Эскизность, фрагментарность книги задают также немалый труд абстрагирования и систематизации понятий из приводимых описаний и сравнений. Понятийный аппарат новой науки во многом еще зачаточен, смутен, это кибернетика in statu nascendi – “в состоянии зарождения”. Наконец, надо признаться, Винер во многих местах просто небрежен и тороплив.

Настоящий бич книги составляют многочисленные описки и опечатки. Первое издание 1948 г. изобилует искажениями формул, имен, ссылок; неточности прокрались и в словесный текст. Винер сообщает в автобиографии, что в это время он страдал тяжелой болезнью глаз – катарактой, перенес операцию хрусталиков и не мог должным образом проверять печатание. “Книга появилась в неряшливом виде, так как корректуры проходили в то время, когда неприятности с глазами лишили меня возможности читать, а молодые ассистенты, которые мне помогали, отнеслись к своим обязанностям недостаточно хорошо”57. Кроме того, денежные затруднения заставляли Винера спешить.

Но не будем зоилами! Победителей, как известно, не судят. Книга сыграла свою роль в истории науки, и если не как сообщение, то как сигнал.

* * *

С выходом книги в свет кончился первый, инкубационный период истории кибернетики и начался второй, крайне бурный – период распространения и утверждения. Дискуссии потрясли ученый мир. Кибернетика нашла горячих защитников и столь же горячих противников. Не буду пересказывать всех перипетий борьбы – об этом еще будут написаны книги. Одни усматривали в кибернетике сплошной философский выверт и “холодную войну” против учения Павлова. Другие, энтузиасты, относили на ее счет все успехи автоматики и вычислительной техники и соглашались видеть уже в тогдашних “электронных мозгах” подлинных разумных существ. Третьи, не возражая против сути проекта, сомневались, однако, в успехе предпринятого синтеза и сводили кибернетику к простым призывам.

Сближение человеческого мозга с “электронными мозгами” вызвало не менее бурную реакцию, чем некогда дарвиновское сближение человека с обезьяной. Пожалуй, после Коперника и Дарвина это было третьим крупным уязвлением нашего привычного антропоцентризма. Снова расцвела чапековская фантастика роботов. [c.19] Правда, в самой “Кибернетике” роботы как таковые не фигурируют. Винер предостерегает в ней против угрозы, таящейся в обычных автоматах при бездумном их применении. Однако предшествующая статья трех авторов показывает, что кибернетика родилась sub specie roboti – “под знаком робота”. “В будущие годы, когда знание белков и коллоидов возрастет, будущие инженеры смогут взяться за конструирование роботов, подобных тому или иному млекопитающему не только по поведению, но и по структуре”58. Кстати, роботы Чапека, так же как и знаменитый Франкенштейн из повести Мэри Шелли, органические, а не металлические!

Тем не менее в первой главе “Кибернетики” Винер обсуждает проблему “создания машин, подражающих живому организму”, упоминает историю глиняного Голема – “магического автомата” из легенд пражского гетто – и приходит к более или менее положительному ответу относительно принципиальных возможностей машин; уже нынешние автоматы, подчеркивает он, обнаруживают грубое функциональное подобие с живыми организмами. Впоследствии Винер открыто говорил о машинах “умнее своего создателя”59, такие машины, по его мнению, обладали бы в некоторой степени и жизнью. Противники кибернетики изобрели специальный термин “технозоизм” для обозначения веры в оживающие машины.

В связи с проблемой создания искусственного человека выдвигалась еще более дерзкая идея – “о возможности путешествовать по телеграфу наряду с путешествиями поездом и самолетом”. Основатель кибернетики защищал этот проект следующим образом: “Тот факт, что мы не можем передавать телеграфно форму строения человека из одного места в другое, по-видимому, обусловлен техническими трудностями, и в частности трудностями сохранения жизни организма во время такой радикальной перестройки. Сама же идея весьма близка к истине. Что касается проблемы радикальной перестройки живого организма, то трудно найти гораздо более радикальную перестройку, чем перестройка бабочки в течение стадии куколки”60.

Вокруг всего этого бушевали страсти. Однако кибернетика выиграла в конце концов сражение и получила право гражданства в древней семье наук. Период утверждения занял приблизительно десятилетие. Постепенно решительное отрицание кибернетики сменилось поисками в ней “рационального зерна” и признанием ее полезности и неизбежности. К 1958 г. уже почти никто не выступал совсем против. Винеровский призыв к синтезу раздался в чрезвычайно благоприятный момент, обстоятельства работали на кибернетику, несмотря на ее несовершенства и преувеличения.

Пройдя сквозь трагические испытания II мировой войны, человечество вступило в новую научно-техническую революцию, представляющую собой коренное преобразование всего арсенала производительных сил с неисчислимыми социально-экономическими последствиями. Это революция автоматизации, II промышленная революция, как ее иногда называют по аналогии с I промышленной [c.20] революцией конца XVIII – начала XIX века. Техника нашего времени характеризуется использованием сложных, больших по масштабу систем, в которых переплетаются многочисленные и разнообразные материальные, энергетические и информационные потоки, требующие координации, управления и регулирования с быстротой и точностью, недостижимыми для внимания и памяти человека, если тот не вооружен автоматическими приборами. Поэтому автоматизация процессов управления и связи открывает широкие перспективы роста производительных сил и переустройства человеческой жизни. Разумеется, подобная научно-техническая революция заполняет собой целую эпоху, и даже сегодня она еще не достигла своего апогея.

Сложность и разнообразие автоматизируемых систем, необходимость сочетания в них различных средств управления и связи, новые возможности, создаваемые электронными вычислительными машинами, – все это порождало нужду в единой, общей теории управления и связи, общей теории передачи и преобразования информации. Кибернетика была наиболее общей и яркой попыткой восполнить пробел, и это обстоятельство оказалось решающим в ее судьбе. Новая техника не могла и не хотела ждать окончания теоретических споров и брала кибернетику такой, какой ее находила, чтобы достраивать на ходу. Кибернетика пускала тысячи корней, вербовала тысячи адептов. Появилась кибернетика техническая, биологическая, медицинская, экономическая, лингвистическая и т.д. Старые, частные теории управления и связи – теория автоматического регулирования, теория вычислительных машин и иные – волей или неволей были вовлечены в кибернетический водоворот. Новые авторы предлагали новые концепции кибернетики, учреждали новые направления и школы. Кибернетика перестала быть делом одного Винера и зажила собственной жизнью.

В 1959 г. акад. А.Н. Колмогоров в предисловии к книге английского кибернетика д-ра У.Р. Эшби писал: “Сейчас уже поздно спорить о степени удачи Винера, когда он в своей известной книге в 1948 году выбрал для новой науки название “кибернетика”. Это название достаточно установилось и воспринимается как новый термин, мало связанный со своей греческой этимологией. Кибернетика занимается изучением систем любой природы, способных воспринимать, хранить и перерабатывать информацию и использовать ее для управления и регулирования. При этом кибернетика широко пользуется математическим методом и стремится к получению конкретных специальных результатов, позволяющих как анализировать такого рода системы (восстанавливать их устройство на основании опыта обращения с ними), так и синтезировать их (рассчитывать схемы систем, способных осуществлять заданные действия). Благодаря этому своему конкретному характеру кибернетика ни в какой мере не сводится к философскому обсуждению природы “целесообразности” в машинах и философскому анализу изучаемого ею круга явлений”61.

Председатель Научного совета по кибернетике при АН СССР акад. А.И. Берг следующим образом характеризует кибернетику: “Кибернетика – это наука об управлении сложными динамическими [c.21] системами. Термин “сложность” здесь применяется как философская категория. Динамические системы на производстве, в природе и в человеческом обществе – это системы, способные к развитию, к изменению своего состояния. Сложные динамические системы образуются множеством более простых или элементарных систем или элементов, взаимосвязанных и взаимодействующих”62. И далее, имея в виду советскую школу кибернетики: “Предметом кибернетики являются процессы управления, происходящие в сложных динамических системах. Подобные системы постоянно встречаются в производственной деятельности, в естествознании и обществе. Целью советской кибернетики является разработка и реализация научных методов управления сложными процессами для повышения эффективности человеческого труда, – для изыскания наиболее рациональных путей перехода от социализма к коммунизму”63.

Так к концу 50-х годов кибернетика стала признанным популярным направлением науки, с широкими задачами, со сложным, многообразным инструментарием. Однако ее одиссея еще не кончилась. Добившись признания, она вступила в третий, важнейший период своего формирования – период ее систематического построения, создания и изложения ее логической системы. Эта задача стоит перед ней и сегодня.

В период распространения рост кибернетики шел более вширь, чем вглубь. И по сие время кибернетика кажется скорее областью исследований, чем упорядоченной, сложившейся наукой. По поводу ее предмета, методов и границ существуют различные точки зрения. Общепризнанного последовательного изложения кибернетики как отдельной дисциплины все еще нет, а ведь только наличие такого изложения дает твердую почву для суждения о значении, возможностях и ограничениях данной науки. Правда, в общих определениях кибернетики как будто нет недостатка, но далеко не все они сопровождаются конкретным дедуктивным воплощением, действительной попыткой построить на их основе систематический курс кибернетики. Переплетение вопросов специальных с вопросами философскими умножает трудности.

Подобную стадию поисков своего подлинного лица проходит, по существу, всякая новая наука. Вспомним первое смутное столетие анализа бесконечно малых, упреки в “мистике” и знаменитый призыв Даламбера: “allez en avant” – смело вперед! Лишь великий систематизатор Коши навел здесь порядок. Польский ученый проф. Г. Грсневский справедливо писал в своей “Кибернетике без математики”: “Только строительство дома начинается с фундамента, а при строительстве науки ее основания появляются обычно довольно поздно”64.

Тем не менее до появления прочного логического фундамента наука живет в кредит. Кибернетика не может быть суммой примеров и аналогий и нуждается в последовательном логическом построении, отправляющемся от немногих основных понятий и законов. [c.22] Такие попытки уже делались, и можно не сомневаться, что со временем они увенчаются успехом. Сошлемся хотя бы на упомянутые книги У.Р. Эшби и Г. Греневского65 или на изящный курс Л. Бриллюэна66.

Как мы уже отмечали, Винер связывал кибернетику со статистической физикой и с борьбой против роста энтропии. Позднейшие авторы большей частью предпочитают излагать кибернетику абстрактно, вне этой связи, отвлекаясь от энергетической стороны процессов. Информация, определяемая как “выбор”, не подвергается при этом термодинамическому истолкованию и трактуется per se, как особая величина. Как говорит Бриллюэн, это свободная информация, в отличие от связанной, отнесенной к микросостояниям какой-либо физической системы. Таким образом, мы может отделить общую кибернетику от более частной термодинамической кибернетики, которую имел в виду Винер. Впрочем, у Винера наличествуют обе концепции информации, но они не разделены между собой достаточно ясно.

В книгах Эшби и Греневского речь идет только об общей кибернетике, без термодинамических выводов. При этом оба автора видят логическое основание кибернетики в общей теории динамических систем. Эшби прямо отождествляет кибернетику с этой “логикой механизмов”67, тогда как Греневский оставляет в ведении кибернетики лишь некоторые – преимущественно информационные – системы68. Аналогичный системный подход находим мы в первоначальной статье Розенблюта, Винера и Бигелоу69.

Конечно, выбор того или иного названия – дело соглашения, но, по-видимому, разумнее последовать за польским автором и отделить кибернетику от более общей н более абстрактной теории динамических систем. Такое ограничение, думается, лучше отвечает винеровскому определению кибернетики как науки “об управлении и связи” и лучше подходит к обычному содержанию кибернетических работ. В целом кибернетика, несомненно, вращается вокруг понятия информации, хотя общая теория управления, надо полагать, окажется шире нынешней теории информации – общей теории связи. Последняя логически вполне развита и прочно стоит на ногах, но то сведение общей теории управления к теории связи, о котором говорит Винер70, отнюдь не означает полного тождества обеих. Одно дело передача информации, другое – переработка ее.

Создание общей теории динамических систем (а может быть, просто общей теории систем) – актуальная и важная проблема [c.23] современной науки. Существующая частная теория динамических систем, известный раздел математической физики, слишком узка и затрагивает весьма специальные системы. Общая теория динамических систем нужна и кибернетике, и физике, и биологии, и социологии, и логике. Многие проблемы логики и научной методологии являются по существу системными. Греневский находит элементы системного подхода не только у кибернетиков, но и у классиков индуктивной логики (Гиппократ, Милль) – еще один довод в пользу разделения кибернетики и “системологии”. В настоящее время теория систем разрабатывается и вне рамок кибернетики71, но, насколько можно судить, процесс этот только начинается. Заметим, что и общая теория систем уступает в общности самому общему взгляду на мир – философии. Поэтому было бы неправомерно противопоставлять системный подход философской диалектике. Великое здание наук имеет много этажей абстракции.

Прошлое кибернетики также выдвигает немало проблем, коль скоро мы понимаем над ней общую науку, а не специально учение Винера. Американский математик имел предшественников не только в Платоне и Ампере, в Максвелле и Гиббсе. Другие тоже сделали немало, и их имена не должны быть забыты. Это проблема докибернетических кибернетиков.

Обращение к истории может принести пользу не только истории. Не исключено, что на пожелтевших страницах мы найдем новые для нас мысли и факты, которые заставят нас взглянуть по-новому на вещи и помогут нам в окончательном логическом формировании кибернетики, которого мы ожидаем.

Нам, русским, прилично вспомнить о русской науке. Теория автоматического регулирования ведет свое начало не только от Дж. Максвелла, но и от видного русского ученого и государственного деятеля XIX в. И.А. Вышнеградского; должно быть упомянуто и имя знаменитого П.Л. Чебышева. В 900-е годы в Екатеринославе Я.И. Грдина опубликовал работы по динамике живых организмов, в которых рассматривались динамические системы “с волевыми связями”. Сам Винер ссылается на работы акад. А.Н. Крылова и акад. Н.Н. Боголюбова. Акад. И.А. Павлов в 30-е годы вплотную подошел к сравнению мозга и электрических переключательных схем (впоследствии, однако, многие хотели противопоставить его Винеру). В.И. Шестаков, независимо от К.Э. Шеннона, открыл применимость математической логики к теории таких схем. В теории связи Винер ссылается на статистические методы акад. А.Н. Колмогорова и П.А. Козуляева. Известна пионерская работа акад. В.А. Котельникова о пропускной способности “эфира и проволоки” (1933 г.) и т.д. К сожалению, суровая обстановка 40-х годов препятствовала обобщению.

Историкам науки надлежит понять и проследить эти исторические нити. Естественно подумать также об отношении кибернетики Винера к тектологии А.А. Богданова. Их сопоставляли уже не раз, но всегда бегло и не в пользу русского автора. Здесь не место [c.24] для подробного обсуждения этой сложной темы, но кажется, что по существу Богданов во многом был предшественником Винера, по крайней мере в системной части кибернетики. Философские и политические заблуждения Богданова известны, но только ли они определяют его научное лицо? Никто не отрицает научных заслуг В. Оствальда или А. Пуанкаре только потому, что они оставались идеалистами, да и Винер отнюдь не во всем материалист.

Сам Богданов отделял тектологию от своих философских теорий. Он определял ее как “всеобщую организационную науку”, но нередко толковал ее как некую теорию систем; термин “комплекс” у него в тектологии значит просто “система”72. Многочисленные параллели с Винером и особенно с Эшби бросаются в глаза, хотя, в отличие от позднейших кибернетиков, Богданов пользуется исключительно качественными методами. Достаточно упомянуть о трактовке живых организмов как “биорегуляторов” – систем с обратной связью. Было бы справедливо, если бы нынешние кибернетики рассмотрели тектологию вновь и решили, что в ней достойно внимания, а что только заблуждение и абсурд.

Что касается столь возбудившей умы проблемы роботов, то она и сегодня принадлежит более научной фантастике, нежели положительной науке. Роботы – это будущее кибернетики. Кибернетике, конечно, свойственно внутреннее стремление к созданию искусственного разума и искусственной жизни, однако предстоит еще громадная теоретическая и экспериментальная работа, чтобы узнать, как далеко можно пойти по этому пути. Пока же кибернетика занимается гораздо более простыми, хотя по-своему и достаточно сложными автоматами. По поводу роботов в настоящее время можно высказать лишь самые общие замечания и гипотезы.

Не вызывает сомнения, что существующие “электронные мозги” – вычислительные и даже специальные логические машины – не способны к подлинному самостоятельному мышлению и лишь моделируют с известной глубиной те или иные мыслительные процессы. Это моделирование всегда частично и основано на формализации мыслительных операций, сведении их к жестким схемам формальной переработки информации, так называемым алгорифмам. Конечно, обладая, как отмечает в “Кибернетике” Винер, определенным набором рецепторов и эффекторов и некоторым подобием центральной нервной системы, вычислительные машины и другие современные автоматы допускают описание в физиологических терминах и в какой-то мере действительно воспроизводят поведение живых организмов. Однако – пока лишь на уровне тропизмов или простейших условных рефлексов. Отсюда далеко до целостного, осмысленного восприятия внешнего мира и самостоятельного, творческого мышления. Точно так же мы далеки от создания искусственных живых существ, способных к самоорганизации, росту, развитию.

Сказанное относится и к тем человекоподобным “роботам”, которые строятся время от времени в экспериментальных или рекламных целях. Это весьма примитивные модели человека, как и знаменитые андроиды Вокансона, хотя порой внешне весьма импозантные. Это роботы доразумные, или, если угодно, псевдороботы. Подлинный [c.25] Robotus sapiens сегодня обитает на страницах А. Азимова и других фантастов. Не будем, однако, слишком трезвы; полеты в космос начинались тоже с романов Ж. Верна и Уэллса!

Наши модели разумного и живого еще очень грубы, очень просты. Однако можно констатировать непрерывный, хотя и не всегда быстрый, прогресс в направлении усложнения моделей мозга, приближения их к чудесному оригиналу. Уже самое строительство электронных вычислительных машин означало большой шаг вперед. Теперь на повестку дня встает вопрос о создании “познающих” машин, способных к обучению, к анализу внешнего мира, к неформальным, содержательным операциям. Уже в “Кибернетике” рассматривалась проблема машинного восприятия образов. Начиная с гомеостатов Эшби, техника настойчиво стремится овладеть процессами обучения и самоорганизации; новые главы, написанные Винером для второго издания книги, посвящены именно этим проблемам. По Винеру, здесь необходимо достичь определенного уровня сложности системы, чтобы последняя обнаружила явления сознания и жизни73.

Будущее покажет пределы возможного. Подобные естественнонаучные вопросы нельзя решить логомахией или простой ссылкой на “здравый смысл”. Установить здесь какую-либо границу, значит установить причину – конкретную, экспериментально проверяемую, которая препятствовала бы росту искусственного разума. И вряд ли можно сомневаться, что такая невозможность носила бы не менее фундаментальный характер, чем, скажем, законы термодинамики. Все это относится как к органическим – истинно чапековским – роботам, так и к механическим. Никто не доказал еще, что “электронный мозг” такой же сложности и компактности, как человеческий, принципиально невозможен; успехи миниатюризации свидетельствуют скорее о другом.

Винер, как мы уже упоминали, считает возможным создание не только разумной машины, но и машины “умнее своего создателя”. Не исключает он и “бунта машин”. Не только робот, но и обычная современная вычислительная машина, использованная для “точных” стратегических расчетов, способна вызвать катастрофу74. Винер не устает бичевать слепое машинопоклонство. Отдаться во власть “Железного Майка” было бы самоубийством; люди не должны допускать, чтобы машины стали находчивее, изобретательнее, чем они сами75. По существу, это еще одна часть винеровской теории о начинающейся критической эпохе в истории человечества.

Действительно, научно-технический прогресс ставит перед человечеством серьезные проблемы. Стремительное развитие науки и техники возлагает на нас колоссальную ответственность за разумное использование полученного нами могущества. “Кто живет в стеклянном доме, тот не должен бросать камней”, – гласит старинная [c.26] пословица. Человек стал настолько могущественным, что любое его нерассчнтанное движение: с роботами, с атомной энергией, с химией – может иметь тяжелые непредвиденные последствия. Это парадокс могущества.

Нельзя забывать, однако, что наука и техника не только возлагают новую ответственность на человека, но и доставляют ему новые средства справиться с ней. Это относится и к роботам. Альтернатива “человек или робот”, “опасное развитие искусственного разума или своевременный отказ от него”, чем ограничивается большинство авторов, имеет третье, более необычайное и, пожалуй, более вероятное решение, если только искусственный разум и искусственная жизнь вообще возможны. Человек, научившийся создавать искусственный разум и искусственную жизнь, не остановится перед коренной переделкой самого себя. Не роботы вместо людей, а новый человек вместо старого!

Человек будущего вряд ли останется, таким же “натуральным” существом, таким же теплокровным позвоночным, каким он вышел из горнила естественного отбора. Почти наверное, он будет искусственно развивать свой мозг и свое тело, будет по воле лепить и изменять свою физическую оболочку. Ему по силам быть впереди любого возможного робота. Это будет биологическая революция, и если смелые гипотезы оправдаются, она будет означать преобразование всего человеческого существования. Быть может, далекий смысл “безумной” винеровской идеи о передаче человека по телеграфу и есть достижение человеком перевоплощаемости? Позволим себе минуту фантазии: не станет ли тогда человек новым могущественным космическим существом, свободным от земных ограничений?

Есть ли абсолютная граница могущества и сложности для человека и его творений, абсолютная граница могущества и сложности для саморазвивающихся систем вообще? Основатель кибернетики, сравнивая человеческий мозг с “рогами последних титанотериев”, указывает нам на внутреннюю тенденцию очень сложных систем к самораспаду, к “сумасшествию”. “Человеческий мозг, вероятно, уже слишком велик, чтобы он мог эффективно использовать все средства, которые кажутся наличными анатомически ...”76

Проблема кризиса сложности – это та же проблема борьбы порядка с хаосом, проблема сохранения счастливых антиэнтропийных островков в бушующем море случайностей. Мы уже говорили, что даже стремление Вселенной к асимптотической тепловой смерти, по-видимому, не устанавливает абсолютной верхней границы для жизни таких островков. Можно ли заключить отсюда, что не существует и абсолютной верхней границы сложности систем? Система в борьбе с самораспадом может переживать кризисы сложности, но выбираться из них и достигать высших уровней сложности. В частности, дефекты мозга не являются неустранимыми, коль скоро допускается возможность преобразования человеком своей физической природы. Впрочем, это вопросы науки будущего, на которые она сумеет ответить лучше нас.

* * *

Мы возвращаемся к книге. В предыдущем обзоре были высказаны некоторые мысли по поводу ее содержания и значения. Сложность [c.27] предмета очевидна, и наши оценки нельзя считать ни полными, ни окончательными. Программа, изложенная в винеровской книге, завоевала признание и оказала уже немалое воздействие на мировую науку, но в ней далеко не все раскрыто и истолковано; кибернетике еще предстоит найти свои строгие, классические формы. Знаменитое сочинение Винера нуждается во внимательном, критическом прочтении. Критика и оценка этой книги – дело специалистов многих профилей, представителей многих наук; нужна здесь и острая мысль философа. Итогом будут новые книги, которые откроют нам новые горизонты.

Несколько слов о переводе. Сложность и своеобразие книги делают последнюю задачу отнюдь не тривиальной. При первом русском переводе пришлось столкнуться с большими трудностями. Для настоящего издания текст перевода заново отредактирован и по возможности исправлен с учетом поправок автора во втором английском издании77. К сожалению, и второе английское издание в этом отношении оставляет желать лучшего. По существу, книга нуждается в специальных комментариях, которыми она когда-нибудь непременно обрастет. Нами увеличено также число приложений: помещенные в них материалы позволяют полнее судить о взглядах автора.

Заключая свое предисловие, я хотел бы напомнить мудрые слова шекспировского Гамлета: “И в небе, и в земле сокрыто больше, чем снится вашей мудрости, Горацио”. Не таков ли окончательный урок кибернетики?

Г.Н. Поваров

Москва,
март 1967 г. [c.28]

Далее:
ПРЕДИСЛОВИЕ КО ВТОРОМУ ИЗДАНИЮ

К оглавлению

ПРИМЕЧАНИЯ

1 Wiener N. Cybernetics or Control and Communication in the Animal and the Machine. – New York: The Technology Press and John Wiley & Sons, Inc. – Paris: Hermann et Cie, 1948.
Вернуться к тексту

2 Wiener N. Cybernetics or Control and Communication in the Animal and the Machine. – 2nd ed. – New York – London: The M.I.T. Press and John Wiley & Sons, Inc., 1961.
Вернуться к тексту

3 Wiener N. Ex-Prodigy: My Childhood and Youth. – Cambridge, Mass.: The M.I.T. Press, 1964 (первое издание: New York: Simon & Schuster, Inc., 1953).
Вернуться к тексту

4 Wiener N. I am a Mathematician. – N.Y.: Doubleday & Co., Inc., Garden City, 1956 (русский перевод: Винер Н. Я – математик. – М.: Наука, 1964).
Вернуться к тексту

5 Гарвардский университет (Harvard University) основан в 1636 г. первыми английскими поселенцами в Массачусетсе и назван по имени пуританского проповедника Джона Гарварда, завещавшего ему деньги и книги. Городок, выбранный для размещения университета, назван Кембриджем в честь английского Кембриджа. Массачусетсский технологический институт (Massachusetts Institute of Technology – M.I.T.) основан в 1861 г. в Бостоне и в 1915 г. переведен в Кембридж. Оба – частные учебные заведения.
Вернуться к тексту

6 См., например, резкий отзыв Р. Уокопа о предложенной Л. Винером теории африканского происхождения цивилизаций Перу и Мексики (Уокоп Р. Затонувшие материки и тайны исчезнувших племен. – М.: Мир, 1966. С. 85–87).
Вернуться к тексту

7 Wiener N. Ex-Prodigy. Р. 190.
Вернуться к тексту

8 Из них переведена на русский: Винер Н. Интеграл Фурье и некоторые его применения. – М.: Физматгиз, 1963.
Вернуться к тексту

9 См.: Нойл Б. Метод Винера – Хопфа. – М.: ИЛ, 1962.
Вернуться к тексту

10 Раlеу R.Е.А.С., Wiener N. Fourier Transforms in the Complex Domain. – New York: Amer. Math. Soc., 1934 (русский перевод: Винер Н., Пэли Р. Преобразование Фурье в комплексной области. – М.: Наука, 1964).
Вернуться к тексту

11 Винер Н. Я - математик. С. 318.
Вернуться к тексту

12 А. Розенблют состоял в штате Гарвардской медицинской школы в Бостоне - факультета Гарвардского университета
Вернуться к тексту

13 Wiеnеr N. Extrapolation, Interpolation, and Smoothing of Stationary Time Series. New York: Technology Press and Wiley, 1949.
Вернуться к тексту

14 См. наст. изд., приложение I.
Вернуться к тексту

15 Винер Н. Я - математик. C. 318.
Вернуться к тексту

16 Wiener N. The Human Use of Human Beings: Cybernetics and Society. - Boston: Houghton Mifflin Co., 1950 (русский перевод: Винер Н. Кибернетика и общество. - М.: ИЛ, 1958).
Вернуться к тексту

17 Wiener N. Nonlinear Problems in Random Theory. - New York: The Technology Press of M.I.T. and John Wiley & Sons, Inc., 1958 (русский перевод: Винер Н. Нелинейные задачи в теории случайных процессов. М.: ИЛ, 1961).
Вернуться к тексту

18 Wiener N. God and Golem, Inc. - Cambridge, Mass.: The М.I.T. Press, 1963 (русский перевод: Винер Н. Творец и робот. - М.: Прогресс, 1966).
Вернуться к тексту

19 Wiener N. The Tempter. - New York: Random House, 1956. Роман представляет собой своего рода современный вариант истории Фауста и Мефистофеля. Герой романа, талантливый ученый, становится жертвой корысти дельцов.
Вернуться к тексту

20 Норберт Винер в редакции нашего журнала. // Вопросы философии. - 1960. - № 9. - С. 164-168.
Вернуться к тексту

21 Винер Н. Наука и общество. // Вопросы философии. - 1961. - № 7. - С. 117-122 (с послесловием редакции: Там жe. С. 123-131).
Вернуться к тексту

22 См. наст. изд., приложение IV.
Вернуться к тексту

23 Гр. πολνιστωρ (в латинском написании polyhistor) - много знающий, знаток во многих науках.
Вернуться к тексту

24 Винер Н. Я - математик. С. 166.
Вернуться к тексту

25 Наст. изд. С. 44.
Вернуться к тексту

26 Винер Н. Я - математик. С. 27.
Вернуться к тексту

27 Там же.
Вернуться к тексту

28 Винер Н. Я - математик. С. 343.
Вернуться к тексту

29 In commendam - по поручению.
Вернуться к тексту

30 Винер Н. Я - математик. С. 343. См. также: Винер Н. Наука и общество. // Вопросы философии. - 1961. - № 7.
Вернуться к тексту

31 Wienеr N. Ex-Prodigy. P. 42. Еще родители Винера отказались от традиционного иудаизма. В “Творце и роботе” Винер проводит аналогию между богом и кибернетиком, трактуя бога как предельное понятие, наподобие бесконечности в математике.
Вернуться к тексту

32 Наст. изд. С. 99.
Вернуться к тексту

33 Wiener N. Ex-Prodigy. Р. 165.
Вернуться к тексту

34 Борн Н. Атомная физика и человеческое познание. - М.: ИЛ, 1961; Борн М. Физика в жизни моего поколения. - М.: ИЛ, 1963.
Вернуться к тексту

35 См., например, послесловие С.Г. Суворова к книге М. Борна.
Вернуться к тексту

36 Казуализм (от лат. casualis - “случайный”) - учение, признающее случайность основой мироздания.
Вернуться к тексту

37 Винер Н. Я - математик. С. 311.
Вернуться к тексту

38 Винер Н. Кибернетика и общество. С. 52.
Вернуться к тексту

39 Там же. С. 49.
Вернуться к тексту

40 Там же. С. 49-50; см. также наст. изд., приложение II.
Вернуться к тексту

41 Винер Н. Кибернетика и общество. С. 31.
Вернуться к тексту

42 Винер Н. Я - математик. С. 310-311.
Вернуться к тексту

43 Винер Н. Кибернетика и общество. С. 26.
Вернуться к тексту

44 Там же. С. 198.
Вернуться к тексту

45 Там же. С. 52.
Вернуться к тексту

46 Там же. С. 53.
Вернуться к тексту

47 Винер Н. Я - математик. С. 311.
Вернуться к тексту

48 Винер Н. Кибернетика и общество. С. 58.
Вернуться к тексту

49 Наст. изд. С. 80.
Вернуться к тексту

50 Винер Н. Кибернетика и общество. С. 167.
Вернуться к тексту

51 Там же. С. 57-58.
 Вернуться к тексту

52 Наст. изд. С. 235.
Вернуться к тексту

53 Винер Н. Кибернетика и общество. С. 167.
Вернуться к тексту

54 Там же. С. 189.
Вернуться к тексту

55 Винер Н. Я - математик. С. 338-340.
Вернуться к тексту

56 Там же. С. 177.
Вернуться к тексту

57 Винер Н. Я - математик. С. 318.
Вернуться к тексту

58 Наст. изд. С. 306.
Вернуться к тексту

59 Наст. изд., приложение II. См. также: Винер Н. Творец и робот. М.: Прогресс, 1966.
Вернуться к тексту

60 Винер Н. Кибернетика и общество. С. 111.
Вернуться к тексту

61 Эшби У.Р. Введение в кибернетику. - М.: ИЛ, 1959. С. 7-8.
Вернуться к тексту

62 Философские проблемы кибернетики. - М.: Соцэкгиз, 1961. С. 155-156.
Вернуться к тексту

63 Там же. С. 179.
Вернуться к тексту

64 Греневский Г. Кибернетика без математики. - М.: Советское радио, 1961. С. 59.
Вернуться к тексту

65 Оригинальные издания: Ashby W.R. An Introduction to Cybernetics. - L.: Chapman & Hall, 1956; Greniewski Н. Elementy cybernetqki, sposobem niematematycznyb wytozone. - Warszawa: PWN, 1959.
Вернуться к тексту

66 Вrillоuin L. Science and Information Theory. - New York: Academic Press, Inc., 1956 (русский перевод: Бриллюэн Л. Наука и теория информации. - М.: Физматгиз, 1960).
Вернуться к тексту

67 Эшби У.Р. Применение кибернетики в биологии и социологии. // Вопросы философии. - 1958. - № 12. - С. 110-117.
Вернуться к тексту

68 Греневский Г. Указ. соч. § 3.2.
Вернуться к тексту

69 Наст. изд., приложение I.
Вернуться к тексту

70 Наст. изд. С. 308.
Вернуться к тексту

71 См., напр.: Views on General Systems Theory. / Ed.: M.D. Mesarovic. - New York - London - Sydney: John Wiley and Sons, Inc., 1964 (русский перевод: Общая теория систем. / Пер. с англ. - М.: Мир, 1966).
Вернуться к тексту

72 См. трехтомник: Богданов А. Всеобщая организационная наука (тектология). Ч. I-III. Л.-M.: Изд-во “Книга”, 1925-1928.
Вернуться к тексту

73 Наст. изд., приложение II.
Вернуться к тексту

74 Наст. изд. С. 263.
Вернуться к тексту

75 Наст. изд. С. 319. В “Творце и роботе” Винер пишет: “Отдайте же человеку - человеческое, а вычислительной машине - машинное. В этом и должна, по-видимому, заключаться разумная линия поведения при организации совместных действий людей и машин” (Винер Н. Творец и робот. С. 82-83).
Вернуться к тексту

76 Наст. изд. С. 235.
Вернуться к тексту

77 Перевод введения из части I “Кибернетики” и приложений I и IV принадлежит Г.Н. Поварову, перевод остального текста “Кибернетики” и приложения II - И.В. Соловьеву.
Вернуться к тексту


ПРЕДИСЛОВИЕ КО ВТОРОМУ ИЗДАНИЮ

Винер Н. Кибернетика, или управление и связь в животном и машине. – 2-е издание. – М.: Наука; Главная редакция изданий для зарубежных стран, 1983. – 344 с.

Красным шрифтом в квадратных скобках обозначается конец текста на соответствующей странице печатного оригинала данного издания

ПРЕДИСЛОВИЕ КО ВТОРОМУ ИЗДАНИЮ

Когда тринадцать лет тому назад я готовил первое издание “Кибернетики”, работу мою затрудняли некоторые серьезные помехи, следствием чего были многочисленные опечатки наряду с отдельными ошибками в содержании. Ныне, думается, настало время пересмотреть кибернетику не только как программу для будущего, но и как существующую науку. Поэтому я воспользовался настоящей возможностью, чтобы внести необходимые исправления для моих читателей и одновременно дополнить книгу изложением современного состояния предмета и новых близких идей, появившихся со времени первого издания.

Если какая-либо новая отрасль науки является действительно жизненной, то центр интереса в ней с годами неизбежно должен перемещаться. Когда я писал “Кибернетику” в первый раз, главное препятствие для меня заключалось в том, что понятия статистической теории информации и управления были тогда новы и даже в какой-то мере противоречили установившимся взглядам. Теперь они стали обычным орудием инженеров связи и разработчиков автоматического оборудования, и главная опасность, мне угрожающая, состоит в том, что книга может показаться банальной. Значение обратной связи в техническом проектировании и в биологии твердо установлено. Значение информации и методика ее измерения и передачи составляют целый предмет изучения для инженера, физиолога, психолога и социолога. Автоматы, о которых в первом издании книги делались лишь предсказания, заняли подобающее [c.29] им место, и связанные с этим социальные опасности, против которых я предостерегал не только в данной книге, но и в небольшой популярной работе “Человеческое использование человеческих существ”1, видны теперь отовсюду.

А потому кибернетику надлежит спешить к новым областям и обратить побольше внимания на идеи, возникшие уже в последнее десятилетие. Простые линейные обратные связи, изучение которых сыграло такую большую роль в пробуждении интереса ученых к кибернетическим исследованиям, оказываются совсем не такими простыми и линейными, как представлялось сначала. В самом деле, в ранние дни теории электрических цепей ее математические ресурсы не шли дальше линейного комбинирования сопротивлений, емкостей и индуктивностей. Это означало, что весь предмет можно было достаточно верно описать в терминах гармонического анализа передаваемых сообщений и величин импедансов, адмиттансов и отношений напряжений в цепях, через которые проходят эти сообщения.

Задолго до выхода в свет “Кибернетики” стало ясно, что изучение нелинейных цепей (таких, какие мы находим в различных усилителях, ограничителях напряжения, выпрямителях и т. д.) не умещается в эти рамки. Тем не менее за отсутствием лучшей методики предпринимались многочисленные попытки распространить линейные понятия прежней электротехники далеко за те границы, в которых они допускали естественное представление новых элементов.

Когда около 1920 г. я пришел в МТИ, обычный способ подхода к нелинейным устройствам состоял в том, что искалось расширенное понятие импеданса, которое охватывало бы как линейные, так и нелинейные системы. В результате нелинейная электротехника пришла в состояние, подобное состоянию птолемеевой системы астрономии в последний период ее существования, когда нагромождали эпицикл на эпицикл, поправку на поправку, пока все это латаное сооружение не рухнуло под собственной тяжестью. [c.30]

Как из крушения перенапряжений птолемеевой системы возникла коперникова система с ее простым и естественным гелиоцентрическим описанием движений небесных тел, заменившим сложную и запутанную картину геоцентрической птолемеевой системы, так и для изучения нелинейных устройств и систем, электрических или механических, естественных или искусственных была необходима совершенно новая отправная точка. Я попытался нащупать новый подход в своей книге “Нелинейные задачи в теории случайных процессов”2.

Оказывается, что с переходом к нелинейным явлениям тригонометрический анализ теряет ту ведущую роль, которая ему принадлежит в изучении линейных явлений. Это имеет четкое математическое объяснение. Процессы в электрических цепях, как и многие другие физические явления, характеризуются инвариантностью при сдвиге начала отсчета во времени. Физический опыт, начатый в полдень и достигший определенного состояния к 2 часам дня, должен достигнуть такого же состояния к 2.15, если мы начнем его в 12.15. Таким образом, физические законы говорят об инвариантах группы сдвигов во времени.

Тригонометрические функции sin nt и cos nt обнаруживают важные инвариантные свойства относительно той же группы сдвигов. Функция общего вида eit перейдет в функцию

eiω(t+τ) = eiωτ eiωt

того же вида при сдвиге, который получается прибавлением τ к t. Как следствие,

a cos n (t + τ) + b sin n (t + τ) = (a cos nτ + b sin nτ) cos nt + (b cos nτ – a sin nτ) sin nt =
= a1 cos nt + b1 sin nt.

Иными словами, семейства функций

Аеiωt и A cos ωt + B sin ωt

инвариантны при сдвиге. [c.31]

Но существуют и другие семейства функции, инвариантные при сдвигах. Если рассматривать так называемое случайное блуждание, когда перемещение частицы за любой промежуток времени имеет распределение, зависящее от длительности этого промежутка и не зависящее от событий, происшедших до его начала, то ансамбль случайных блужданий также перейдет в себя при временном сдвиге.

Иными словами, инвариантность при сдвигах – это свойство тригонометрических кривых, которым обладают также другие множества функций.

В дополнение к этой инвариантности, тригонометрические функции характеризуются свойством

Аеiωt + Веiωt = (А + В)еiωt

благодаря которому они образуют чрезвычайное простое линейное множество. Легко заметить, что это свойство связано с линейностью, т. е. мы можем свести все колебания данной частоты к линейной комбинации двух колебаний. Именно это специфическое свойство обусловливает роль гармонического анализа при изучении линейных свойств электрических цепей. Функции

еiωt

суть характеры группы переносов и дают нам линейное представление этой группы3.

Но когда мы обращаемся к другим комбинациям функций, нежели сложение с постоянными коэффициентами, например к перемножению функций, то простые тригонометрические функции уже не обнаруживают этого элементарного группового свойства. С другой стороны, случайные функции, такие, как при случайном блуждании, обладают определенными свойствами, весьма полезными при рассмотрении их нелинейных комбинаций.

Я не хотел бы входить в подробности, математически довольно сложные и уже разобранные в моей книге “Нелинейные задачи в теории случайных процессов”. Материал этой книги уже применялся не раз при рассмотрении специфических нелинейных задач, но для выполнения изложенной там программы остается еще многое сделать. Практически дело сводится к тому, что [c.32] в качестве удобного стандартного сигнала на входе выступает уже не набор тригонометрических функций, а сигнал типа броунова движения. В случае электрических цепей такая “броунова” функция физически может быть получена дробовым эффектом. Дробовой эффект есть явление нерегулярности электрических токов, возникающее вследствие того, что токи представляют собой не непрерывный поток электричества, а последовательность неделимых и одинаковых электронов. Поэтому электрические токи подвержены статистическим колебаниям, которые сами носят довольно ровный характер и могут быть усилены настолько, что составят заметный случайный шум.

Как я покажу в гл. IX, теория случайного шума может служить на практике не только для анализа электрических цепей и других нелинейных процессов, но и для их синтеза4. С этой целью выходной сигнал нелинейного устройства со случайным входом приводится к ряду некоторых ортонормальных функций, тесно связанных с многочленами Эрмита. Задача анализа нелинейной цепи состоит в определении коэффициентов этих многочленов усреднением по параметрам входного сигнала.

Указанный процесс описывается довольно просто. Кроме черного ящика, изображающего еще не проанализированную нелинейную систему, у меня есть некоторые тела известной структуры, которые я буду называть белыми ящиками и которые изображают разные члены искомого разложения5. Я ввожу один и тот же случайный [c.33] шум в черный ящик и в данный белый ящик. Коэффициент белого ящика в разложении черного ящика равен среднему произведению их выходных сигналов. Это среднее надо брать по всему ансамблю входных сигналов, создаваемых дробовым эффектом, но существует теорема, которая во всех случаях, кроме множества меры 0, позволяет заменять это среднее средним по времени. Таким образом, мы нуждаемся в перемножающем устройстве, которое бы находило произведение выходов черного и белого ящиков, и в усредняющем устройстве, которое может быть основано на том, что разность потенциалов конденсатора пропорциональна его заряду и, следовательно, интегралу по времени от тока, текущего через конденсатор.

Можно не только определить один за другим коэффициенты каждого белого ящика, входящего слагаемым в эквивалентное представление черного ящика, но и определить их все одновременно. Можно даже при помощи соответствующих схем обратной связи заставить каждый белый ящик автоматически настраиваться на уровень, соответствующий коэффициенту этого белого ящика в разложении черного ящика. Это позволяет нам построить сложный белый ящик, который, будучи соединен надлежащим образом с черным ящиком и получая тот же самый случайный входной сигнал, автоматически превратится в операционный эквивалент черного ящика, хотя его внутреннее строение может быть весьма отличным.

Описанные операции анализа, синтеза и автоматической самонастройки белых ящиков по подобию черных могут выполняться и другими методами, принадлежащими проф. Амару Бозе6 и проф. Габору7. Во всех этих методах используются процессы подгонки, или обучения, включающие выбор удобных входных сигналов для [c.34] черного и белого ящиков и сравнение этих ящиков. И во многих из них, в том числе в методе проф. Габора, важную роль играют перемножающие устройства.

Хотя имеется много способов электрического перемножения двух функций, задача эта технически нелегкая. С одной стороны, хороший перемножитель должен работать в широком диапазоне амплитуд. С другой стороны, он должен быть настолько быстродействующим, почти мгновенным, чтобы работать точно на высоких частотах. Габор утверждает, что его перемножитель работает в диапазоне частот примерно до 1000 гц. В своей речи при вступлении в должность профессора электроники в Имперском колледже естественных и технических наук Лондонского университета он не указал ни диапазона амплитуд, в котором применим его метод, ни достижимой степени точности. Я с нетерпением жду, чтобы эти данные были указаны и можно было оценить перспективы использования такого перемножителя в других зависящих от него устройствах.

Все эти системы, в которых некоторое устройство приобретает определенную структуру или функцию на основании прошлого опыта, приводят к весьма интересному новому подходу как в технике, так и в биологии. В технике устройства такого рода можно применять для того, чтобы не только проводить игры и другие целевые действия, но и постоянно совершенствовать при этом свое поведение на основании прошлого опыта. Я рассмотрю некоторые из этих возможностей в гл. IX настоящей книги. В биологическом плане перед нами по меньшей мере аналог того, что, быть может, составляет центральное явление жизни. Для существования наследственности и для размножения клеток необходимо, чтобы ответственные за наследственность компоненты клеток – так называемые гены – были способны строить по своему образу другие подобные, ответственные за наследственность структуры. Поэтому было бы весьма заманчиво найти способ, посредством которого технические устройства могли бы производить другие устройства с функциями, подобными их собственным. Я отведу этому вопросу гл. X, где, в частности, будет рассмотрено, каким путем колебательные системы данной частоты могут привести другие колебательные системы к той же частоте. [c.35]

Часто утверждают, что создание молекул данного вида по образу существующих молекул аналогично применению шаблонов в технике, которое позволяет использовать функциональный элемент машины как эталон для изготовления другого подобного элемента. Образ шаблона статичен, а молекула гена должна производить другую молекулу посредством некоторого процесса. Я делаю пробное предположение, что образцовыми элементами, определяющими индивидуальность биологических веществ, могут быть частоты, скажем, частоты молекулярных спектров, а самоорганизация генов может быть проявлением самоорганизации частот, которую я рассмотрю дальше.

Я говорил уже в общих чертах об обучающихся машинах. Я отведу особую главу для более подробного рассмотрения этих машин, их возможностей и некоторых проблем их использования. Пока же хочется сделать несколько замечаний общего характера.

Как мы увидим в гл. I, понятие обучающихся машин столь же старо, как и сама кибернетика. В случае описанных мною приборов управления артиллерийским зенитным огнем линейные характеристики предсказывающего устройства, используемого в данное время, зависят от долговременного знакомства со статистиками ансамбля тех временных рядов, которые мы хотим предсказать. Эти характеристики можно найти математически. по изложенным там принципам, но вполне возможно придумать вычислительную машину, которая будет собирать эти статистики и вырабатывать кратковременные характеристики предсказывающего устройства на основании опыта, уже пережитого самим предсказывающим устройством и записываемого автоматически. Это может пойти гораздо дальше чисто линейного предсказывающего устройства. В ряде статей Каллианпура, Мазани, Акутовича и моих8 развита [c.36] теория нелинейного предсказания, которую можно, по крайней мере в принципе, механизировать аналогичным образом, с использованием долговременных наблюдений как статистической основы для кратковременного предсказания.

Обе теории предсказания – линейного и нелинейного – предполагают определенные критерии качества предсказания. Простейший, хотя отнюдь и не единственный пригодный, – это критерий наименьшей среднеквадратической ошибки. Он применяется здесь в частном виде с функционалами броунова движения, использованными мною для синтеза нелинейных устройств, поскольку различные члены моего разложения имеют некоторые свойства ортогональности. Эти свойства гарантируют, что частичная сумма конечного числа членов дает наилучшую имитацию рассматриваемого устройства, какая только может быть получена с этими членами при указанном критерии. Метод Габора также основан на среднеквадратическом критерии ошибки, но в более общем виде, пригодном для временных рядов, полученных из опыта.

Понятие обучающихся машин можно распространить на гораздо более широкую область, нежели предсказывающие устройства, фильтры и тому подобные приборы. Особенно важно оно для изучения и конструирования машин, играющих в игры со встречными интересами, как, например, в шашки. Здесь интересную работу выполнили Сэмьюэл9 и Ватанабе10 в лабораториях фирмы “Интернешнел Бизнес Машине”. Как и в случае фильтров и предсказывающих устройств, здесь подбираются какие-то функции временных рядов, на которые можно разложить функции гораздо более широкого класса. Выбранные функции могут включать численные оценки существенных величин, от которых зависит успех игры. Например, они включают число фигур с обеих сторон, господство над пространством, подвижность и т.д. В начале работы машины этим факторам даются пробные [c.37] веса, и машина выбирает допустимый ход, имеющий наибольший общий вес. Эти действия машина проводит по жесткой программе, без какого-либо оборудования.

Но время от времени машина переходит к другой задаче. Она пробует разложить функцию, равную 1 при выигрыше, 0 при проигрыше и, положим, 1/2 при ничьей, по различным функциям, выражающим факторы, которые машина способна учитывать. Тем самым она заново определяет вес этих факторов, чтобы вести затем более сложную игру. Некоторые свойства таких машин будут рассмотрены в гл. IX, здесь же я должен сказать, что применение подобных оценок позволяет машине обыграть своего программиста после 10–20 часов обучения и тренировки. Я также упомяну в этой главе о некоторых аналогичных машинах, предназначенных для доказательства геометрических теорем и для имитации – в ограниченной степени – логики индукции.

Вся эта работа составляет часть теории и практики двойного программирования11, которые усиленно изучались в лаборатории электронных систем Массачусетсского технологического института. Там было установлено, что, если не применять какое-либо обучающееся устройство такого типа, программирование машины с жесткой схемой представляет собой очень трудную задачу и что существует настоятельная необходимость в устройствах для программирования этого программирования.

Но понятие обучающихся машин применимо не только к тем машинам, которые мы создаем сами, но и к тем живым машинам, которые мы называем “животными”, и это бросает новый свет на биологическую кибернетику. Здесь я хочу выделить среди многих современных исследований книгу супругов Стэнли-Джонсов о кибернетике (отметим орфографию) живых систем 12. [c.38] В этой книге авторы много места отводят обратным связям, поддерживающим рабочий уровень нервной системы, а также другим обратным связям, отвечающим на частные раздражения. Поскольку соединение уровня системы с частными реакциями является в значительной степени мультипликативным, оно также нелинейно и подчиняется соображениям, подобным изложенным выше.

Эта область исследований сейчас усиленно развивается и, я надеюсь, в ближайшем будущем должна развиваться гораздо больше.

Машины с памятью и самовоспроизводящиеся машины, которые я до сих пор описывал, основаны в большой мере, хотя и не полностью, на устройствах с весьма высокой специализацией, которые можно назвать копировальными устройствами. Физиологические варианты того же процесса должны больше соответствовать особым методам, свойственным живым организмам, где копирование заменяется менее специализированным процессом самоорганизации системы. Гл. Х настоящей книги посвящена одному примеру процесса самоорганизации, а именно процессу, посредством которого образуются узкие, весьма специфические частоты в мозговых волнах. Она оказывается, таким образом, в значительной мере физиологическим двойником предыдущей главы, в которой аналогичные процессы рассматриваются на более близкой к копированию основе.

Обнаружение таких резких частот в мозговых волнах и теории, предложенные мною для объяснения того, как они возникают, что они могут сделать и как их можно использовать в медицине, представляют, по моему мнению, новое существенное направление в физиологии. Подобные же идеи можно применить для объяснения многих других физиологических явлений, и они могут внести значительный вклад в изучение основ явлений жизни. В этом направлении я даю скорее программу, чем законченное исследование, но программу, на которую я возглагаю большие надежды.

В мои намерения ни в первом издании книги, ни в настоящем не входило дать конспект всего, что было сделано в кибернетике. Это не соответствует ни моим интересам, ни моим возможностям. Цель моя – изложить и дополнить свои мысли по этому предмету и [c.39] представить некоторые идеи и философские соображения, которые побудили меня начать работу в данной области и продолжали интересовать меня при ее дальнейшем развитии. Таким образом, это книга весьма личного характера, уделяющая много места исследованиям, которыми я сам интересовался, и относительно мало – исследованиям, в которых я сам не участвовал.

При пересмотре книги я получил ценную помощь от многих. В частности, я должен выразить признательность за сотрудничество мисс Констанции Д. Бойд из издательства Массачусетсского технологического института, д-ру Сикао Икехара из Токийского технологического института, д-ру Ю.В. Ли с электротехнического факультета Массачусетсского технологического института и д-ру Гордону Рейсбеку из Белловских телефонных лабораторий. Кроме того, при написании новых глав, и в частности в расчетах для гл. X, в которой рассматриваются самоорганизующиеся системы, обнаруживаемые при изучении энцефалограмм, я должен отметить помощь со стороны моих учеников Джона Котелли и Чарльза Э. Робинсона и особенно со стороны д-ра Джона С. Барлоу из Главной Массачусетсской больницы. Указатель составил Джеймс Я. Дэйвис.

Без постоянной заботы и преданности всех этих лиц у меня не хватило бы мужества и прилежания, чтобы выпустить новое исправленное издание.

Норберт Винер

Кембридж, Массачусетс,
март 1961 г. [c.40]

Далее:
ЧАСТЬ I. ПЕРВОНАЧАЛЬНОЕ ИЗДАНИЕ 1948 г.
ВВЕДЕНИЕ

К оглавлению

ПРИМЕЧАНИЯ

1 Wiener N. The Human Use of Human Beings: Cybernetics and Society. - Boston Houghton Miftlin Co., 1950 (русский перевод: Винер Н. Кибернетика и общество. - М.: ИЛ, 1958. - Ред.).
Вернуться к тексту

2 Wiener N. Nonlinear Problems in Random Theory. - New York: The Technology Press of М.I.T. and John Wiley & Sons, 1958 (русский перевод: Винер Н. Нелинейные задачи в теории случайных процессов. - М.: ИЛ, 1961. - Ред.).
Вернуться к тексту

3 О группах и характерах групп см. ниже гл. II - Прим ред.
Вернуться к тексту

4 Термин “нелинейная система” употребляется мною не для исключения линейных систем, а для того, чтобы показать, что речь идет о более широкой категории. Анализ нелинейных систем при помощи случайного шума применим также к линейным системам, и его применяют на самом деле.
Вернуться к тексту

5 Термины “черный ящик” и “белый ящик” - удобные и образные выражения с не очень точно установленым значением. Под черным ящиком я подразумеваю какое-либо устройство (например, четырехполюсник с двумя входными и двумя выходными полюсами), которое выполняет определенную операцию над настоящим и прошлым входного потенциала, но для которого мы не обязательно. располагаем информацией о структуре, обеспечивающей выполнение этой операции. С другой стороны, белый ящик есть аналогичная цепь, в которой для обеспечения заданной зависимости между входом и выходом мы связали входной и выходной потенциалы согласно определенному структурному плану.
Вернуться к тексту

6 Воse A.G. Nonlinear System Characterization and Optimization // IRE TRANSACTIONS IT-5. - 1959. - Р. 30-40, специальное приложение к IRE TRANSACTIONS.
Вернуться к тексту

7 Габор Д. Электронные изобретения и их влияние на цивилизацию. Вступительная лекция, 3 марта 1959 г., Имперский колледж естественных и технических наук при Лондонском университете, Англия.
Вернуться к тексту

8 Wiener N., Masani P. The Prediction Theory of Multivariate Stochastic Processes, Part I // Acta Mathematica. - 1957. - Vol. 98. - P. 11-150; Part II // Ibid. - 1958. - Vol. 99. - P. 93-137. Также Wiener N., Akutоwiсz E.J. The Definition and Ergodic Properties of the Stochastic Adjoint of a Unitary Transformation. // Rendiconti del Circolo Matematico di Palermo. - Ser. II. - 1957. - Vol. VI. - P. 205-217.
Вернуться к тексту

9 Samuel A.L. Some Studies in Machine Learning, Using the Game of Checkers. // IBM Journal of Research and Development. - 1959. - Vol. 3. - P. 210-229.
Вернуться к тексту

10 Watanabe S. Information Theoretical Analysis of Multivariate Correlation. // IBM Journal of Research and Development. - 1960. - Vol. 4. - P. 66-82.
Вернуться к тексту

11 То есть речь идет об автоматизации программирования. - Прим. ред.
Вернуться к тексту

12 Stanley-Jones D., Stanley-Jones К. Kybernetics of Natural Systems: A Study of Patterns of Control. - London: Pergamon Press, 1960. (Стэнли-Джонсы употребляют слово “кибернетика” в исходной греческой форме - “kybernetics”, тогда как Винер, а за ним и большинство англо-американских авторов пишут его в латинизированной форме - “cybernetics”, т. е. “цибернетика”; ср. “киклоп” и “циклоп”. В русской литературе с самого начала утвердилось греческое чтение. - Ред.).


Винер Н

Винер Н. Кибернетика, или управление и связь в животном и машине. - 2-е издание. - М.: Наука; Главная редакция изданий для зарубежных стран, 1983. - 344 с.

Красным шрифтом в квадратных скобках обозначается конец текста на соответствующей странице печатного оригинала данного издания

ЧАСТЬ I.
ПЕРВОНАЧАЛЬНОЕ ИЗДАНИЕ
1948 г.

ВВЕДЕНИЕ

Эта книга представляет итог более чем десятилетних исследований, предпринятых совместно с д-ром Артуро Розенблютом, работавшим тогда в Гарвардской медицинской школе, а ныне перешедшим в Национальный институт кардиологии в Мексике. В то время д-р Розенблют, коллега и сотрудник покойного д-ра Уолтера Б. Кеннона, ежемесячно устраивал дискуссии о научном методе. В этих дискуссиях участвовали главным образом молодые ученые Гарвардской медицинской школы. Мы собирались на обед за круглым столом в Вандербилт-Холле. Беседа была живой и непринужденной. Здесь было неподходящее место для игры в амбицию, да это и не поощрялось. После обеда кто-нибудь из нашей группы или из гостей делал доклады на какую-либо научную тему, причем обычно в этих докладах вопросы методологии ставились на первое или хотя бы на почетное место. На докладчика обрушивалась резкая критика, благожелательная, но беспощадная. Она была великолепным лекарством от незрелых мыслей, недостаточной самокритичности, излишней самоуверенности и напыщенности. Кто не мог выдержать испытание, не возвращался в нашу среду, но многие из нас, бывших завсегдатаев этих встреч, чувствуют, что эти встречи были постоянным существенным вкладом в наше научное развитие.

На этих собраниях присутствовали не только врачи и ученые-медики. К постоянным и активным участникам наших споров принадлежал д-р Мануэль Сандоваль Вальярта, профессор физики Массачусетсского технологического института, один из самых первых моих [c.43]студентов в те годы, когда я пришел в МТИ после I мировой воины. Как и д-р Розенблют, д-р Вальярта был мексиканец. Он имел обыкновение приводить на эти встречи своих коллег по институту. На одну из встреч он привел и меня; так я встретился впервые с д-ром Розенблютом. Я давно интересовался методологией науки и в 1911-1913 гг. принимал участие в семинаре по этим вопросам, который вел Джосайя Ройс в Гарвардском университете. Чувствовалось, что на подобных собраниях необходимо присутствие человека, способного критически рассматривать математические вопросы. Поэтому я был активным членом группы до того момента, пока д-р Розенблют не был вызван в Мексику в 1944 г. и пока общий беспорядок, связанный с войной, не положил конец этим собраниям.

В течение многих лет д-р Розенблют разделял со мной убеждение, что самыми плодотворными для развития наук являются области, оставленные в пренебрежении по той причине, что они были “ничьей территорией” между различными сложившимися науками. После Лейбница, быть может, уже не было человека, который бы полностью обнимал всю интеллектуальную жизнь своего времени. С той поры наука становится все более делом специалистов, области компетенции которых обнаруживают тенденцию ко все большему сужению. Сто лет тому назад хотя и не было таких ученых, как Лейбниц, но были такие, как Гаусс, Фарадей, Дарвин.

В настоящее же время лишь немногие ученые могут назвать себя или математиками, или физиками, или биологами, не прибавляя к этому дальнейшего ограничения. Ученый становится теперь топологом, или акустиком, или специалистом по жесткокрылым. Он набит жаргоном своей специальной дисциплины и знает всю литературу по ней и все ее подразделы. Но всякий вопрос, сколько-нибудь выходящий за эти узкие пределы, такой ученый чаще всего будет рассматривать как нечто, относящееся к коллеге, который работает через три комнаты дальше по коридору. Более того, всякий интерес со своей стороны к подобному вопросу он будет считать совершенно непозволительным нарушением чужой тайны.

Специализация дисциплин все время возрастает и [c.44] захватывает все новые области. В результате создается ситуация, похожая на ту, которая возникла, когда в Орегоне одновременно находились и поселенцы из Соединенных Штатов, и англичане, и мексиканцы, и русские, - сложный и запутанный клубок открытий, названий и законов. Ниже мы увидим, что существуют области научной работы, исследуемые с разных сторон чистой математикой, статистикой, электротехникой и нейрофизиологией. В этих областях каждое понятие получает особое название у каждой группы специалистов, и многие важные исследования проделываются трижды или четырежды. В то же время другие важные исследования задерживаются из-за того, что в одной области не известны результаты, уже давно ставшие классическими в смежной области.

Именно такие пограничные области науки открывают перед надлежаще подготовленным исследователем богатейшие возможности. Но изучение таких областей представляет и наибольшие трудности для обычного метода массового наступления с разделением труда.

Если трудность физиологической проблемы по существу математическая, то десять несведущих в математике физиологов сделают не больше, чем один несведущий в математике физиолог. Очевидно также, что если физиолог, не знающий математики, работает вместе с математиком, не знающим физиологии, то физиолог не в состоянии изложить проблему в выражениях, понятных математику; математик, в свою очередь, не сможет дать совет в понятной для физиолога форме.

Д-р Розенблют всегда настойчиво утверждал, что действенное изучение этих белых пятен на карте науки может быть предпринято только коллективом ученых, каждый из которых, будучи специалистом в своей области, должен быть, однако, основательно знаком с областями науки своих коллег. При этом необходимо, чтобы все привыкли работать совместно, зная склад ума другого, оценивая значение новых идей коллеги, прежде чем эти идеи будут точно сформулированы. От математика не требуется умения провести физиологический эксперимент, но он должен уметь понимать такой эксперимент, уметь подвергнуть его критике и уметь предложить новый эксперимент. От физиолога не требуется умения доказать определенную математическую [c.45] теорему, но физиолог должен быть в состоянии понять ее значение для физиологии и указать математику направление поисков. В течение многих лет мы мечтали об обществе независимых ученых, работающих вместе в одной из этих неисследованных областей науки, и не под началом какого-нибудь высокопоставленного администратора, а объединенных желанием, даже духовной необходимостью, понимать науку как нечто целое и передавать друг другу силу такого понимания.

Мы пришли к согласию по этим вопросам задолго до того, как выбрали область наших совместных исследований и наметили, какое каждый примет в них участие. На наш выбор существенно повлияла война. Я давно знал, что в случае войны мое участие в ней определялось бы в значительной степени двумя обстоятельствами: моим тесным контактом с программой создания вычислительных машин, проводимой д-ром Ванневаром Бушем, и моей совместной работой с д-ром Юк Винг Ли по синтезу электрических схем. Действительно, оба обстоятельства сыграли значительную роль. Летом 1940 г. я стал уделять много внимания разработке вычислительных машин для решения дифференциальных уравнений в частных производных. Я давно интересовался этим, и у меня сложилось убеждение, что здесь, в отличие от обыкновенных дифференциальных уравнений, так хорошо решавшихся на дифференциальном анализаторе д-ра Буша, главной является проблема представления функций многих переменных. Я был убежден также, что процесс развертки, применяемый в телевидении, дает ответ на этот вопрос и что в действительности телевидение принесет технике больше пользы именно созданием таких новых процессов, чем само по себе, как особая отрасль.

Было ясно, что всякий процесс развертки должен значительно увеличить количество используемых данных по сравнению с тем, которое встречается в задачах, сводимых к обыкновенным дифференциальным уравнениям. Поэтому для получения приемлемых результатов в приемлемое время необходимо довести до максимума скорость элементарных процессов и добиться, чтобы течение этих процессов не прерывалось существенно более медленными шагами. Необходимо также повысить точность выполнения элементарных процессов [c.46] настолько, чтобы их частое повторение не приводило к накоплению слишком большой ошибки. В результате были сформулированы следующие требования:

1) Центральные суммирующие и множительные устройства должны быть цифровыми, как в обычном арифмометре, а не основываться на измерении, как в дифференциальном анализаторе Буша.

2) Эти устройства, являющиеся по существу переключателями, должны состоять из электронных ламп, а не из зубчатых передач или электромеханических реле. Это необходимо, чтобы обеспечить достаточное быстродействие.

3) В соответствии с принципами, принятыми для ряда существующих машин Белловских телефонных лабораторий, должна использоваться более экономичная двоичная, а не десятичная система счисления.

4) Последовательность действия должна планироваться самой машиной так, чтобы человек не вмешивался в процесс решения задачи с момента введения исходных данных до снятия окончательных результатов. Все логические операции, необходимые для этого, должна выполнять сама машина.

5) Машина должна содержать устройство для запасания данных. Это устройство должно быстро их записывать, надежно хранить до стирания, быстро считывать, быстро стирать их и немедленно подготавливаться к запасанию нового материала.

Эти рекомендации вместе с предложениями по их реализации были направлены д-ру Ванневару Бушу для возможного применения их в случае войны. На той стадии подготовки к войне казалось, что они не столь важны, чтобы приступить к немедленной работе над ними. Тем не менее все эти рекомендации представляют собой идеи, положенные в основу современной сверхбыстрой вычислительной машины. Эти мысли почти носились тогда в воздухе, и я не хочу в данный момент заявлять какие-либо претензии на исключительный приоритет в их формулировке. Все же указанные рекомендации оказались полезными, и я надеюсь, что они имели некоторое влияние на популяризацию этого круга идей среди инженеров. Во всяком случае, как мы увидим в основной части книги, такие идеи интересны в связи с изучением нервной системы. [c.47]

Итак, эта работа была отложена. Хотя она и принесла некоторую пользу, но непосредственно она не привела д-ра Розенблюта и меня к каким-либо проектам. Наше действительное сотрудничество возникло в связи с другой задачей, также имевшей непосредственное отношение к последней войне. В начале войны господство Германии в воздухе и оборонительная позиция Англии сосредоточили внимание многих ученых на задаче усовершенствования зенитной артиллерии. Уже до войны стало ясно, что возрастающая скорость самолетов опрокинула классические методы управления огнем и что необходимо встроить в прибор управления огнем все вычислительные устройства, обеспечивающие расчеты для выстрела. Эти вычислительные устройства оказались очень сложными вследствие того обстоятельства, что, в отличие от других целей, самолет имеет скорость, сравнимую со скоростью зенитного снаряда. Поэтому необходимо стрелять не прямо в цель, а в некоторую точку, в которой, согласно расчетам, должны по прошествии некоторого времени встретиться самолет и снаряд. Следовательно, мы должны найти какой-нибудь метод предсказания будущего положения самолета.

Простейший метод - продолжить наблюдаемый курс самолета по прямой. Этот метод заслуживает серьезного внимания. Чем больше самолет кружит при полете, чем больше он делает виражей, тем меньше его эффективная скорость, тем меньше времени он имеет для выполнения боевого задания, тем дольше он остается в поражаемом пространстве. При прочих равных условиях самолет будет по возможности лететь по прямой. Однако после разрыва первого снаряда эти прочие условия уже не равны, и пилот, вероятно, начнет выполнять зигзагообразный полет, фигуры высшего пилотажа или другой противозенитный маневр.

Если бы этот маневр зависел только от пилота и задача пилота сводилась бы к разумному использованию своих шансов, такому, какое мы, например, ожидаем от хорошего игрока в покер, то к моменту разрыва снаряда пилот мог бы настолько изменить положение самолета, что шансы на удачное попадание стали бы пренебрежимо малы, если только не применять весьма неэкономного заградительного огня. Но пилот не имеет возможности неограниченного маневра. Во-первых, пилот [c.48] находится в самолете, летящем с чрезвычайно большой скоростью, и всякое внезапное отклонение от курса создаст огромную нагрузку, при которой пилот может потерять сознание, а самолет - развалиться. Далее, управлять самолетом можно только посредством движения рулевых поверхностей, и для перехода в новый режим полета потребуется некоторое время.

Однако перевод рулевых поверхностей в новое положение изменит лишь ускорение самолета, и это изменение ускорения еще должно перейти в изменение скорости и затем в изменение положения, прежде чем оно даст эффект. Наконец, находясь в напряженных условиях боя, летчик едва ли будет способен к очень сложному и ничем не ограниченному сознательному поведению. Вероятнее всего, он будет просто выполнять ту программу действий, которой его ранее обучили.

Все это делало целесообразным разработку проблемы предсказания полета по кривой, независимо от того, насколько благоприятными окажутся результаты для действительного применения прибора управления огнем, использующего такие методы предсказания. Для предсказания будущей криволинейной траектории необходимо выполнить определенные операции над прошлыми наблюдениями траектории. Точный оператор предсказания вообще нельзя осуществить с помощью какой бы то ни было реальной аппаратуры. Но некоторые операторы дают известное приближение и притом допускают реализацию с помощью аппаратуры, которую мы можем построить. Я сказал профессору Массачусетсского технологического института Сэмьюэлу Колдуэллу, что следовало бы испытать эти операторы. Он немедленно предложил мне начать испытания, используя дифференциальный анализатор д-ра Буша как готовую модель требуемых приборов для управления огнем. Мы провели испытания и получили результаты, описанные в основной части книги. Во всяком случае, я оказался работающим над военным проектом, в котором г-н Джулиан X. Бигелоу и я совместно проводили разработку теории предсказания и конструирование устройств, воплощающих ее результаты.

Таким образом, я во второй раз занялся изучением электромеханической системы, предназначенной узурпировать [c.49] специфические функции человека: в первом случае речь шла о выполнении сложных вычислений, во втором - о предсказании будущего. При этом во втором случае мы не могли обойтись без исследования того, как выполняет некоторые функции человек. Правда, в ряде приборов управления огнем исходные данные для наводки поступают непосредственно с радиолокатора, но обычно огнем управляет живой, а не механический наводчик. Люди: вертикальный наводчик, горизонтальный наводчик или оба вместе - действуют в качестве неотъемлемой части системы управления огнем. Чтобы математически описать их участие в работе управляемой ими машины, необходимо знать их характеристики. Кроме того, их цель - самолет - также управляется человеком, и желательно знать рабочие характеристики такой цели.

Мы с Бигелоу пришли к заключению, что исключительно важным фактором в сознательной деятельности служит явление, которое в технике получило название обратной связи. Этот вопрос освещен мною весьма подробно в соответствующих главах книги. Здесь я отмечу только одно обстоятельство. Когда мы хотим, чтобы некоторое устройство выполняло заданное движение, разница между заданным и фактическим движением используется как новый входной сигнал, заставляющий регулируемую часть устройства двигаться так, чтобы фактическое движение устройства все более приближалось к заданному.

Например, в одном из типов корабельной рулевой машины поворот штурвала воздействует на L-образное колено, присоединенное к румпелю. Это колено так регулирует клапаны рулевой машины, чтобы румпель двигался в положение, при котором эти клапаны закрыты. Поэтому румпель поворачивается так, чтобы привести другой конец названного колена на серединную, нейтральную линию, и тем самым угловое положение штурвала воспроизводится как угловое положение румпеля. Конечно, любое трение или другая задерживающая сила, тормозящая движение румпеля, будет увеличивать впуск пара в клапаны на одной стороне и уменьшать его на другой, чтобы увеличить вращающий момент, стремящийся привести румпель в требуемое положение. Таким образом, система с обратной связью стремится [c.50] сделать работу рулевой машины относительно независимой от нагрузки.

Но при некоторых условиях, например при наличии задержки во времени и т.п., обратная связь, осуществляемая слишком резко, заставит руль пройти за требуемое положение, а затем обратная связь, действующая в другом направлении, вызовет еще большее отклонение руля от требуемого положения. В результате рулевой механизм будет испытывать сильные колебания, или рысканье, пока совсем не сломается. В таких книгах, как монография Маккола1, можно найти весьма точное описание обратной связи, условий, при которых обратная связь оказывается применимой, а также условий, при которых она отказывает. Обратная связь – это явление, которое мы хорошо понимаем с количественной точки зрения.

Допустим теперь, что я поднимаю карандаш. Чтобы это сделать, я должен привести в движение определенные мышцы. Однако никто, за исключением специалистов-анатомов, не знает, какие это мышцы. Даже среди анатомов лишь немногие, да и то вряд ли, сумеют поднять карандаш посредством сознательного акта последовательного сокращения отдельных мышц. Нами осознается лишь конечная цель – поднять карандаш. Когда мы решили это сделать, наше движение совершается так, что, грубо говоря, степень, в которой карандаш еще не взят, на каждом этапе уменьшается. Все движение мы выполняем почти бессознательно.

Чтобы действие выполнялось таким способом, на каждом этапе движения в нервную систему должны сознательно или бессознательно подаваться сведения о том, насколько положение нашей руки отличается от положения, при котором мы возьмем карандаш. Если мы смотрим на карандаш, то эти сведения могут быть зрительными, хотя бы частично; но обычно они бывают кинестетическими, или, употребляя термин, который сейчас в ходу, проприоцептивными. Если проприоцептивные ощущения отсутствуют и мы не заменим их зрительными или какими-либо другими, то мы не сможем поднять карандаш – состояние, называемое атаксией. [c.51] Атаксия этого типа обычна при той форме сифилиса центральной нервной системы, которая носит название спинной сухотки (tabes dorsalis). При ней кинестетические ощущения, передаваемые спинномозговыми нервами, более или менее утрачиваются.

Но чрезмерная обратная связь, очевидно, должна быть столь же серьезным препятствием для организованной деятельности, как и недостаточная обратная связь. Принимая во внимание эту возможность, мы с Бигелоу обратились к д-ру Розенблюту с одним специальным вопросом. Существует ли патологическое состояние, при котором больной, пытаясь выполнить сознательное действие, например поднять карандаш, проскакивает мимо цели и совершает не поддающиеся контролю колебания? Д-р Розенблют ответил, что такое состояние существует и хорошо известно. Называется оно интенционным тремором и часто связано с повреждением мозжечка.

Итак, мы нашли весьма существенное подтверждение нашей гипотезы относительно природы сознательной деятельности или, по крайней мере, некоторых видов этой деятельности. Следует отметить, что эта точка зрения идет значительно дальше обычной точки зрения, распространенной среди нейрофизиологов. Центральная нервная система уже не представляется автономным, независимым органом, получающим раздражения от органов чувств и передающим их в мышцы. Наоборот, некоторые характерные виды деятельности центральной нервной системы объяснимы только как круговые процессы, идущие от нервной системы в мышцы и снова возвращающиеся в нервную систему через органы чувств. При этом не важно, являются ли эти органы чувств проприоцепторами или внешними органами чувств. Нам казалось, что такой подход означает новый шаг в изучении того раздела нейрофизиологии, который затрагивает не только элементарные процессы в нервах и синапсах, но и деятельность нервной системы как единого целого.

Мы трое сочли необходимым написать и опубликовать статью, излагающую эту новую точку зрения2. Как [c.52] д-р Розенблют, так и я предвидел, что эта статья может быть только изложением программы большой экспериментальной работы. Мы решили, что если когда-нибудь нам удастся создать институт, занимающийся проблемами связей между разными науками, то эта тема была бы почти идеальным объектом для нашей деятельности.

Что касается техники связи, то для г-на Бигелоу и для меня уже стало очевидным, что техника управления и техника связи неотделимы друг от друга и что они концентрируются не вокруг понятий электротехники, а вокруг более фундаментального понятия сообщения. При этом не существенно, передается ли сообщение посредством электрических, или механических, или нервных систем. Сообщение представляет собой дискретную или непрерывную последовательность измеримых событий, распределенных во времени, т.е. в точности то, что статистики называют временным рядом.

Предсказание будущего отрезка сообщения производится применением некоторого оператора к прошлому отрезку сообщения, независимо от того, реализуется ли этот оператор алгорифмом математических вычислений или электрическими и механическими устройствами. В связи с этим мы нашли, что идеальные предсказывающие устройства, которые мы сначала рассматривали, подвержены воздействию ошибок двух противоположных видов. Первоначально спроектированный нами предсказывающий прибор можно было сделать таким, чтобы он предугадывал весьма гладкую кривую с любой степенью точности. Однако повышение точности достигалось ценой повышения чувствительности прибора. Чем лучше был прибор для гладких сигналов, тем сильнее он приводился в колебания небольшими нарушениями гладкости и тем продолжительнее были такие колебания. Таким образом, хорошая экстраполяция гладкой кривой, по-видимому, требовала применения более точного и чувствительного прибора, чем наилучшее возможное предсказание негладкой кривой; в каждом отдельном случае выбор прибора зависел бы от статистической природы предсказываемого явления. Можно было думать, что эти два вида взаимозависимых ошибок имеют нечто общее с противоречивыми задачами измерения положения и количества [c.53] движения, рассматриваемыми в квантовой механике Гейзенберга в соответствии с его принципом неопределенности.

После того как мы уяснили, что решение задачи оптимального предсказания можно получить лишь обратившись к статистике предсказываемого временного ряда, было уже легко превратить то, что сперва представлялось трудностью для теории предсказания, в эффективное средство решения задачи предсказания. Приняв определенную статистику для временного ряда, можно найти явное выражение для, среднего квадрата ошибки предсказания при данном методе и на данное время вперед. А располагая таким выражением, мы можем свести задачу оптимального предсказания к нахождению определенного оператора, при котором становилась бы минимальной некоторая положительная величина, зависящая от этого оператора. Задачи на минимум такого типа решаются в хорошо развитой отрасли математики – вариационном исчислении, и эта отрасль имеет хорошо развитую методику. Благодаря этой методике мы оказались в состоянии получить в явном виде наилучшее решение задачи предсказания будущего отрезка временного ряда на основе его статистических свойств и, более того, найти физическую реализацию этого решения посредством реальных приборов.

Проделав это, мы увидели, что по крайней мере одна задача технического проектирования приняла совершенно новый вид. Ведь обычно техническое проектирование считается скорее искусством, чем наукой. Сведя задачу такого рода к разысканию определенного минимума, мы поставили дело проектирования на более научную основу. Нам пришла мысль, что перед нами не изолированный случай и что существует целая область инженерной работы, в которой аналогичные задачи проектирования можно решать методами вариационного исчисления.

Мы обратились к другим аналогичным задачам и решили их этими методами. В числе решенных задач была задача проектирования волновых фильтров. Часто бывает так, что передаваемое сообщение искажают посторонние помехи, так называемый шумовой фон. Тогда встает задача восстановления посланного сообщения из искаженного сообщения при помощи [c.54] некоторого оператора. При этом может потребоваться восстановление посланного сообщения либо в первоначальном виде, либо с данным упреждением, либо с данным запаздыванием. Выбор оптимального оператора и прибора, его реализующего, определяется статистическими свойствами сообщения и шума, рассматриваемых по отдельности и совместно. Так в проектировании волновых фильтров мы заменили старые методы, носившие эмпирический и довольно-таки случайный характер, методами, допускающими четкое научное обоснование.

Но тем самым мы сделали из проектирования систем связи статистическую науку, раздел статистической механики. И действительно, понятия статистической механики вторгаются во все отрасли науки уже более ста лет. Мы увидим далее, что эта преобладающая роль статистической механики в современной физике имеет самое существенное значение для понимания природы времени. В случае же техники связи значение статистического элемента непосредственно очевидно. Передача информации возможна лишь как передача альтернатив. Если нужно передавать одну-единственную возможность, то лучше всего и легче всего это сделать тем, что не посылать вообще никакого сообщения. Телефон и телеграф могут выполнять свои функции только в том случае, когда передаваемые ими сообщения беспрерывно изменяются, причем эти изменения не определяются полностью прошлой частью сообщений. С другой стороны, эффективное проектирование телефона и телеграфа возможно только при том условии, что изменения передаваемых сообщений подчиняются каким-нибудь статистическим закономерностям.

Чтобы подойти к технике связи с этой стороны, нам пришлось разрабатывать статистическую теорию количества информации. В этой теории за единицу количества информации принимается количество информации, передаваемое при одном выборе между равновероятными альтернативами. Такая мысль возникла почти одновременно v нескольких авторов, в том числе у статистика Р.А. Фишера, у д-ра Шеннона из Белловских телефонных лабораторий и у автора настоящей книги3. При этом Фишер исходил из классической [c.55] статистической теории, Шеннон – из проблемы кодирования информации, автор настоящей книги – из проблемы сообщения и шумов в электрических фильтрах. Следует, однако, отметить, что некоторые мои изыскания в этом направлении связаны с более ранней работой Колмогорова4 в России, хотя значительная часть моей работы была сделана до того, как я обратился к трудам русской школы.

Понятие количества информации совершенно естественно связывается с классическим понятием статистической механики – понятием энтропии. Как количество информации в системе есть мера организованности системы, точно так же энтропия системы есть мера дезорганизованности системы; одно равно другому, взятому с обратным знаком. Эта точка зрения приводит нас к ряду рассуждений относительно второго закона термодинамики и к изучению возможности так называемых “демонов” Максвелла. Вопросы такого рода возникают совершенно независимо при изучении энзимов и других катализаторов, и их рассмотрение существенно для правильного понимания таких основных свойств живой материи, как обмен веществ и размножение. Третье фундаментальное свойство жизни – свойство раздражимости – относится к области теории связи и попадает в группу идей, которые мы только что разбирали5.

Таким образом, четыре года назад группа ученых, объединенных вокруг д-ра Розенблюта и меня, уже понимала принципиальное единство ряда задач, в центре которых находились вопросы связи, управления и статистической механики, и притом как в машине, так и в живой ткани. Но наша работа затруднялась отсутствием единства в литературе, где эти задачи трактовались, и отсутствием общей терминологии или хотя бы единого названия для этой области. После продолжительного обсуждения мы пришли к выводу, что вся [c.56] существующая терминология так или иначе слишком однобока и не может способствовать в надлежащей степени развитию этой области. По примеру других ученых, нам пришлось придумать хотя бы одно искусственное неогреческое выражение для устранения пробела. Было решено назвать всю теорию управления и связи в машинах и живых организмах кибернетикой, от греческого χυβερνητησ – “кормчий”6. Выбирая этот термин, мы тем самым признавали, что первой значительной работой по механизмам с обратной связью была статья о регуляторах, опубликованная Кларком Максвеллом в 1868 г.7, и что слово “governor”, которым Максвелл обозначал регулятор, происходит от латинского искажения слова “χ υβερνητησ”. Мы хотели также отметить, что судовые рулевые машины были действительно одними из самых первых хорошо разработанных устройств с обратной связью8.

Несмотря на то, что термин “кибернетика” появился только летом 1947 г., мы сочли удобным использовать его в ссылках, относящихся к более ранним периодам развития этой области науки. Приблизительно с 1942 г. развитие кибернетики проходило по нескольким направлениям. Сначала идеи совместной статьи Бигелоу, Розенблюта и Винера были изложены д-ром Розенблютом [c.57] на совещании, проведенном фондом Джосайи Мейси в Нью-Йорке в 1942 г. Совещание было посвящено проблемам центрального торможения в нервной системе. На совещании присутствовал д-р Уоррен Мак-Каллох из Медицинской школы Иллинойсского университета, уже давно поддерживавший связь с д-ром Розенблютом и со мною и интересовавшийся изучением организации коры головного мозга.

Примерно в это же время на сцену выступает фактор, который неоднократно появляется в истории кибернетики, – влияние математической логики. Если бы мне пришлось выбирать в анналах истории наук святого – покровителя кибернетики, то я выбрал бы Лейбница. Философия Лейбница концентрируется вокруг двух основных идей, тесно связанных между собой: идеи универсальной символики и идеи логического исчисления.

Из этих двух идей возникли современный математический анализ и современная символическая логика. И как в арифметическом исчислении была заложена возможность развития его механизации от абака и арифмометра до современных сверхбыстрых вычислительных машин, так в calculus ratiocinator9 Лейбница содержится в зародыше machina rationatrix – думающая машина. Сам Лейбниц, подобно своему предшественнику Паскалю, интересовался созданием вычислительных машин в металле. Поэтому совсем неудивительно, что тот же самый умственный толчок, который привел к развитию математической логики, одновременно привел к гипотетической, или действительной механизации процессов мышления.

Всякое математическое доказательство, за которым мы можем следить, выразимо конечным числом символов. Эти символы, правда, могут быть связаны с понятием бесконечности, но связь эта такова, что ее можно установить за конечное число шагов. Так, когда в случае математической индукции мы доказываем теорему, зависящую от параметра п, мы доказываем ее сначала для n=0 и затем устанавливаем, что случай, когда параметр имеет значение n+1, вытекает из случая, когда параметр имеет значение п. Тем самым мы убеждаемся [c.58] в правильности теоремы для всех положительных значений параметра n. Более того, число правил действия в нашем дедуктивном механизме должно быть конечным, даже если оно кажется неограниченным из-за ссылки на понятие бесконечности. Ведь и само понятие бесконечности выразимо в конечных терминах. Короче говоря, как номиналистам (Гильберт), так и интуиционистам (Вейль) стало совершенно очевидно, что развитие той или иной математико-логической теории подчиняется ограничениям того же рода, что и работа вычислительной машины. Как мы увидим позже, можно даже интерпретировать с этой точки зрения парадоксы Кантора и Рассела.

Я сам в прошлом ученик Рассела и многим обязан его влиянию. Д-р Шеннон взял как тему своей докторской диссертации в Массачусетсском технологическом институте применение методов классической булевой алгебры классов к изучению переключательных систем в электротехнике10. Тьюринг был, пожалуй, первым среди ученых, исследовавших логические возможности машин с помощью мысленных экспериментов. Во время войны он работал для английского правительства в области электроники. В настоящее время он возглавляет программу по созданию вычислительных машин современного образца, принятую Национальной физической лабораторией в Теддингтоне.

Другим молодым ученым, перешедшим из математической логики в кибернетику, был Уолтер Питтс. Он был учеником Карнапа в Чикаго и был связан с проф. Рашевским и его школой биофизиков. Заметим попутно, что эта последняя группа сделала очень много для того, чтобы направить внимание ученых-математиков на возможности биологических наук. Правда, некоторым из нас кажется, что она находится под слишком большим влиянием задач об энергии и потенциалах и методов классической физики, чтобы наилучшим образом решать задачи по изучению систем, подобных нервной системе, которые весьма далеки от энергетической замкнутости. [c.59]

Г-н Питтс весьма удачно попал под влияние Мак-Каллоха; они вместе начали работать над проблемами, связанными с соединением нервных волокон синапсами в системы, обладающие заданными общими свойствами. Независимо от Шеннона они использовали аппарат математической логики для решения проблем, являющихся прежде всего переключательными проблемами. Мак-Каллох и Питтс ввели принципы, остававшиеся в тени в ранней работе Шеннона, хотя и вытекающие, несомненно, из идей Тьюринга: использование времени как параметра, рассмотрение сетей, содержащих циклы, и рассмотрение синаптических и других задержек11.

Летом 1943 г. я встретил д-ра Дж. Леттвина из Бостонской городской больницы, весьма интересовавшегося вопросами, связанными с нервными механизмами. Он был близким другом г-на Питтса и познакомил меня с его работой12. Он убедил Питтса приехать в Бостон и встретиться с д-ром Розенблютом и со мной. Мы с радостью пригласили его в нашу группу. Г-н Питтс перешел в Массачусетсский технологический институт осенью 1943 г., чтобы работать вместе со мной и чтобы углубить свою математическую подготовку для исследований в этой науке – кибернетике, к тому времени уже родившейся, но еще не окрещенной.

Г-н Питтс был тогда основательно знаком с математической логикой и нейрофизиологией, но не имел случая сколько-нибудь близко соприкасаться с техникой. В частности, он не был знаком с работой д-ра Шеннона и недостаточно ясно представлял себе возможности электроники. Он очень заинтересовался, когда я показал ему образцы современных вакуумных ламп и объяснил, что они являются идеальным средством для реализации в металле эквивалентов рассматриваемых им нейронных сетей и систем. С этого времени нам стало [c.60] ясно, что сверхбыстрая вычислительная машина, поскольку вся она строится на последовательном соединении переключательных устройств, является идеальной моделью для решения задач, возникающих при изучении нервной системы. Возбуждение нейронов по принципу “все или ничего” в точности подобно однократному выбору, производимому при определении разряда двоичного числа; а двоичная система счисления уже признавалась не одним из нас за наиболее удовлетворительную основу для проектирования вычислительных машин. Синапс есть не что иное, как механизм, определяющий, будет ли некоторая комбинация выходных сигналов от данных предыдущих элементов служить подходящим стимулом для возбуждения следующего элемента или нет; тем самым синапс в точности подобен устройствам вычислительной машины. Наконец, проблема объяснения природы и разновидностей памяти у животных находит параллель в задаче создания искусственных органов памяти для машин.

Тем временем оказалось, что создание вычислительных машин имеет гораздо более важное значение для военных целей, чем предполагал ранее д-р Буш. Строительство новых машин развернулось в нескольких центрах, и притом в направлении, которое не очень отличалось от указанного в моем первом докладе. Гарвардский университет, испытательный полигон в Абердине и Пенсильванский университет уже построили вычислительные машины, а Институт высших исследований в Принстоне13 и Массачусетсский технологический институт должны были к этому вскоре приступить. В программе строительства вычислительных машин наблюдался постепенный переход от механических систем к электрическим, от десятичной системы счисления к двоичной, от механического реле к электрическому, от ручного управления операциями к автоматическому управлению. Короче говоря, каждая новая машина все более и более походила на образец, описанный в том докладе, [c.61] который я в свое время направил д-ру Бушу. Множество народа жадно интересовалось этими вопросами; у нас была возможность передавать свои идеи коллегам, в частности д-ру Эйкену из Гарвардского университета, д-ру фон Нейману из Института высших исследований и д-ру Голдстайну, работавшему над машинами ЭНИАК14 и ЭДВАК15 в Пенсильванском университете. Везде нас внимательно выслушивали, и скоро словарь инженеров стал пестреть выражениями, употребляемыми нейрофизиологами и психологами.

На этой стадии работ д-р Нейман и я сочли необходимым провести объединенное совещание всех интересующихся тем, что мы сейчас называем кибернетикой. Такое совещание было организовано в Принстоне в конце зимы 1943-1944 гг. Присутствовали и инженеры, и физиологи, и математики. Д-р Розенблют не мог быть среди нас, так как он только что принял приглашение на должность заведующего лабораторией физиологии в Национальном институте кардиологии в Мексике; но от физиологов присутствовали д-р Мак-Каллох и д-р Лоренте де Но из Рокфеллеровского института. Д-р Эйкен не смог присутствовать, но в совещании участвовало несколько конструкторов вычислительных машин и среди них д-р Голдстайн. Д-р фон Нейман, г-н Питтс и я представляли математиков. Физиологи сделали совместное изложение задач кибернетики с их точки зрения, аналогичным образом конструкторы вычислительных машин изложили свои цели и методы. В конце совещания всем стало ясно, что существует значительная идейная общность между работниками разных [c.62] специальностей, что представители каждой группы уже могут пользоваться понятиями, выработанными представителями других групп, и что поэтому необходимо попытаться создать общую для всех терминологию.

Значительно раньше военная исследовательская группа, руководимая д-ром Уорреном Уивером, выпустила отчет, сначала секретный, а затем для ограниченного пользования, где излагалась работа г-на Бигелоу и моя по предсказывающим приборам и волновым фильтрам16. Было установлено, что конструирование специальных приборов для криволинейного предсказания не оправдывается условиями ведения зенитного огня. Но принципы оказались верными и были использованы государственными органами при решении задач на сглаживание и в некоторых смежных областях. В частности, оказалось, что интегральное уравнение того типа, к которому сводится рассматриваемая нами задача вариационного исчисления, появляется в проблемах волноводов и во многих других проблемах прикладной математики. Таким образом, к концу войны идеи теории предсказания, идеи статистического подхода к технике связи так или иначе стали уже знакомы значительной части статистиков и инженеров-связистов в Соединенных Штатах и Великобритании; кроме моего военного отчета, ныне совершенно разошедшегося, к этому времени вышло большое число объяснительных статей, написанных Левинсоном, Уоллменом, Дэниеллом, Филлипсом и другими17 для заполнения пробела. Сам я в течение нескольких лет готовил большую математическую статью с целью окончательно зафиксировать проделанную работу, но затем не зависящие от меня обстоятельства воспрепятствовали быстрой публикации этой статьи. Наконец, после совместного совещания Американского математического общества и Института математической статистики, организованного в Нью-Йорке весной 1947 г. (оно было посвящено изучению стохастических процессов, с точки зрения весьма близкой к кибернетике), я переслал проф. Дубу из Иллинойсского университета готовую часть рукописи с тем, [c.63] чтобы он переработал ее в своих обозначениях и в соответствии со своими идеями для книги, которая должна выйти в серии математических обзоров Американского математического общества18. Часть работы уже излагалась в курсе лекций, читанном мною на математическом отделении МТИ летом 1945 г. После этого вернулся из Китая мои старый ученик и сотрудник19 д-р Ю.В. Ли. Сейчас, осенью 1947 г., он читает лекции о новых методах проектирования волновых фильтров и других аналогичных приборов в МТИ на электротехническом отделении. На основе этого курса лекций он собирается издавать книгу. В то же время намечается переиздание моего военного отчета, разошедшегося полностью20.

Как я уже сказал, д-р Розенблют вернулся в начале 1944 г. в Мексику. Весной 1945 г. я получил приглашение от Мексиканского математического общества принять участие в совещании, которое должно было состояться в июне в Гвадалахаре. К этому приглашению присоединилась Комиссия по поощрению и координации научных исследований, руководимая д-ром Мануэлем Сандовалем Вальяртой, о котором я уже говорил. Д-р Розенблют предложил мне провести совместно какое-либо исследование, и Национальный институт кардиологии, где директором был д-р Игнасио Чавес, оказал мне свое гостеприимство.

Я тогда пробыл в Мексике около десяти недель. Мы с д-ром Розенблютом решил продолжать работу, которую уже обсуждали ранее с д-ром Уолтером Б. Кенноном, также гостившим у д-ра Розенблюта; к несчастью, эта поездка оказалась для д-ра Кеннона последней. Наша работа посвящалась зависимости между тоническими, клоническимн и фазовыми судорогами при эпилепсии, с одной стороны, и тонической спазмой, [c.64] биением и мерцанием сердца, с другой. Мы полагали, что сердечная мышца благодаря своей раздражимости столь же полезна для изучения механизмов проводимости, как и нервная ткань, а анастомозы и перекресты волокон сердечной мышцы ставят нас перед меньшими трудностями, чем нервные синапсы. Мы были глубоко благодарны д-ру Чавесу за его щедрое гостеприимство; и хотя институт никогда не стремился ограничить д-ра Розенблюта одними лишь исследованиями сердца, мы были весьма рады возможности способствовать выполнению основной задачи института.

Исследования наши приняли два направления: изучение явлений проводимости и покоя в однородных проводящих средах двух и более измерений и статистическое изучение свойств проводимости случайных сетей проводящих волокон. Первое направление привело нас к наброскам теории трепетания сердца, второе – к некоторому возможному пониманию явления мерцания. Оба направления изложены в опубликованной нами статье21. Конечно, наши первые результаты потребовали затем значительного пересмотра. Но работу о трепетании продолжает г-н Оливер Г. Селфридж из Массачусетсского технологического института, а статистические методы, примененные при изучении сетей волокон сердечной мышцы, были распространены на нейронные сети г-ном Уолтером Питтсом, ныне стипендиатом фонда Джона Саймона Гуггенгейма. Д-р Розенблют проводит экспериментальную работу, в чем ему помогает д-р. Ф. Гарсия Рамос, сотрудник Национального института кардиологии и Мексиканской военно-медицинской школы.

В Гвадалахаре на заседании Мексиканского математического общества мы с д-ром Розенблютом доложили [c.65] часть полученных результатов. Мы сделали вывод, что наши прежние предположения о возможном сотрудничестве оказались вполне реальными. Нам повезло, и мы получили возможность изложить наши результаты большой аудитории слушателей. Весной 1946 г, д-р Мак-Каллох договорился с фондом Джосайи Мейси об организации первого из совещаний по вопросам обратной связи, которые должны были состояться в Нью-Йорке. Эти совещания проводились в соответствии с традициями фонда Мейси. Организацией совещаний занимался по поручению фонда д-р Фрэнк Фремонт-Смит, разработавший весьма эффективный порядок. Предполагалось собирать небольшую – не свыше, скажем, двадцати человек – группу специалистов по различным связанным между собой отраслям науки, чтобы эти специалисты проводили вместе пару дней в постоянном общении на неофициальных докладах, дискуссиях и совместных обедах; группа будет собираться до тех пор, пока ее члены не преодолеют своих разногласий и преуспеют в выработке общего мнения. Основным ядром наших собраний была группа, сложившаяся в Принстоне в 1944 г.; однако доктора Мак-Каллох и Фремонт-Смит, правильно оценив возможность психологических и социологических применений наших идей, включили в группу ряд ведущих психологов, социологов и антропологов. Необходимость привлечения к работе психологов была очевидна с самого начала. Кто изучает нервную систему, не может забывать о мышлении, а кто изучает мышление, обязан постоянно помнить о нервной системе. Значительная часть психологии прошлого, по существу, была не чем иным, как физиологией внешних органов чувств; а комплекс идей, вносимых в психологию кибернетикой, затрагивает в первую очередь анатомию и физиологию высокоспециализированных областей коры головного мозга, связанных с этими внешними органами чувств. С самого начала мы догадывались, что проблема восприятия гештальта 22, или иначе говоря, проблема образования обобщений при [c.66] восприятии, имеет тот же характер. Каков механизм, при помощи которого мы опознаем квадрат как квадрат, независимо от его положения, размеров и ориентации? Чтобы помочь нам в таких вопросах и, в свою очередь, получить информацию о возможных применениях наших концепций в своей области, среди нас присутствовали психологи: проф. Клювер из Чикагского университета, покойный д-р Курт Левин из Массачусетсского технологического института и д-р М. Эриксон из Нью-Йорка.

Что касается социологии и антропологии, то очевидно, что информация и связь как механизмы организации действуют не только в индивидууме, но и в обществе. Совершенно невозможно понять устройство таких социальных систем, как муравейник, без подробного анализа их средств связи; здесь нам очень пригодилась помощь, которую оказал д-р Шнейрла. При рассмотрении аналогичных проблем, касающихся организации человеческого общества, мы обращались к антропологам д-ру Бейтсону и д-ру Маргарите Мид. Д-р Моргенштерн из Института высших исследований был нашим консультантом в той важной области социальной организации, которая связана с экономическими вопросами. Между прочим, его очень ценная книга по теории игр, написанная им совместно с д-ром фон Нейманом, принадлежит к наиболее интересным исследованиям социальной организации23. Методы, которыми это исследование выполнено, тесно связаны с методами кибернетики, хотя и отличны от них. Д-р Левин и другие представляли новое направление в теории изучения общественного мнения и практике его формирования, а д-р Нортроп интересовался анализом философского значения нашей работы.

Это, однако, не составляет полного списка нашей группы. Расширяя группу, мы пополнили ее также новыми инженерами и математиками (Бигелоу и Сэведж), новыми нейроанатомами и нейрофизиологами (фон Бонин и Ллойд) и т.д. Наше первое совещание, состоявшееся весной 1946 г., было посвящено в основном ознакомительным докладам бывших участников [c.67] Принстонского совещания и общей оценке новой области всеми присутствующими. Мнение совещания было следующим. Идеи кибернетики достаточно важны и интересны, и имеет смысл устраивать такие совещания каждые полгода. Перед ближайшим совещанием надо устроить небольшой семинар для лиц, обладающих меньшей математической подготовкой, и объяснить им как можно проще существо используемых математических понятий.

Летом 1946 г., воспользовавшись поддержкой Рокфеллеровского фонда и гостеприимством Национального института кардиологии, я возвратился в Мексику, чтобы продолжить нашу совместную с д-ром Розенблютом работу. На сей раз мы решили взять неврологическую задачу, непосредственно затрагивающую вопросы обратной связи, и посмотреть, чего здесь можно добиться экспериментальным путем. В качестве подопытного животного мы выбрали кошку и решили изучать у нее четырехглавую мышцу – разгибатель бедра. Мы перерезали место прикрепления мышцы, присоединяли ее под известным напряжением24 к рычагу и записывали ее сокращения в изометрических и в изотонических условиях. Для записи электрических изменений в самой мышце мы пользовались осциллографом. Обычно мы работали с кошкой, которая была сначала децеребрирована под эфирным наркозом, а затем превращена в спинномозговой препарат перерезкою спинного мозга на уровне груди. Во многих случаях для усиления рефлекторных реакций использовался стрихнин. Мышца нагружалась до тех пор, пока легкое надавливание не вызывало у нее периодических сокращений, которые на языке физиологов называются клонусом. Мы исследовали эти периодические сокращения с учетом физиологического состояния кошки, нагрузки мышцы, частоты колебаний, основного уровня, вокруг которого происходят колебания, и их амплитуды. Эти колебания мы пытались анализировать теми же методами, которыми анализировали бы механическую или электрическую систему, обнаруживающую рысканье такой же формы. Например, мы применяли методы, изложенные в книге Маккола о сервомеханизмах. [c.68]

Здесь не место обсуждать подробно значение наших результатов. Сейчас мы их проверяем и готовимся изложить для публикации. Однако установлены или весьма вероятны следующие положения: во-первых, частота клонических колебаний гораздо менее чувствительна к изменениям условий нагрузки, чем мы ожидали; во-вторых, эта частота определяется почти исключительно константами замкнутой дуги “эфферентный нерв – мышца – конечное кинестетическое тело – афферентный нерв – центральный синапс – эфферентный нерв”. Эта цепь не является даже в первом приближении цепью линейных операторов относительно числа импульсов, передаваемых в секунду эфферентным нервом, но становится почти что линейной, если вместо числа импульсов взять его логарифм. Это соответствует тому обстоятельству, что огибающая раздражения эфферентного нерва весьма далека от синусоиды, но логарифм этой кривой гораздо ближе к синусоиде. Между тем в линейной колебательной системе с постоянным уровнем энергии кривая раздражения должна быть синусоидой во всех случаях, кроме множества случаев нулевой вероятности. С другой стороны, понятия проторения и торможения по своей природе являются скорее мультипликативными, чем аддитивными. Так, полное торможение означает умножение на нуль, а частичное торможение – умножение на малый множитель. С помощью понятий торможения и проторения и обсуждалась эта рефлекторная дуга25. Далее, синапс есть регистратор совпадений, и выходное волокно раздражается лишь тогда, когда число импульсов, поступивших на входы в течение некоторого малого времени суммации, превышает определенный порог. Если этот порог достаточно низок по сравнению с общим числом входных сигналов, то синаптический механизм служит просто для умножения вероятностей и может рассматриваться как приблизительное линейное звено лишь в логарифмической системе. Этот приблизительно логарифмический характер синаптического механизма, несомненно, связан с приблизительно логарифмическим характером закона интенсивности ощущения [c.69] Вебера – Фехнера, хотя названный закон и является лишь первым приближением.

Самое интересное – это то, что, приняв логарифмическую шкалу и использовав данные, полученные при изучении прохождения одиночных импульсов через различные звенья нервно-мышечной дуги, мы смогли получить весьма хорошее приближение к экспериментальным значениям периода клонических судорог при помощи методов, применяемых в теории сервомеханизмов для определения частоты колебаний рысканья в перерегулированных системах с обратной связью. Теоретически мы получили колебания приблизительно в 13,9 гц для условий, в которых частота экспериментально наблюдаемых колебаний изменялась от 7 до 30 гц, оставаясь, однако, большей частью в пределах от 12 до 17 гц. Учитывая условия исследования, совпадение следует считать очень хорошим.

Частота клонических судорог не является единственным важным явлением, которое мы наблюдали. Мы также встретили относительно медленное изменение основного упругого напряжения и еще более медленное изменение амплитуды. Эти явления, конечно, носят совсем нелинейный характер. Однако достаточно медленные изменения параметров линейной колебательной системы можно рассматривать в первом приближении как бесконечно медленные, а тогда на протяжении каждого этапа колебаний система ведет себя как система с постоянными параметрами. Этот метод известен в других разделах физики под названием метода вековых возмущений. Он может применяться и для изучения изменений основного уровня, и амплитуды клонуса. Эта работа еще не закончена, но ясно, что она является перспективной и обещающей.

Есть серьезные основания для следующего предположения: хотя при клонусе синхронизация главной дуги свидетельствует о ее принадлежности к двухнейронным дугам, усиление импульсов в этой дуге изменяется в одной, а может быть, и в нескольких точках, так что некоторая часть общего усиления определяется медленными, многонейронными процессами, протекающими в отделах центральной нервной системы, расположенных гораздо выше спинномозговой цепочки, ответственной за синхронизацию клонических судорог. На это [c.70] переменное усиление влияет уровень центральной активности, применение стрихнина или анестезирующих средств, децеребрация и многие другие причины.

Таковы главные результаты, доложенные д-ром Розенблютом и мною на Мейсиевском совещании осенью 1946 г. и на заседании Нью-Йоркской академии наук. Это заседание академии состоялось той же осенью и преследовало цель пропаганды кибернетики в широких массах слушателей. Хотя мы были удовлетворены нашими результатами и целиком убеждены в осуществимости работ в этом направлении, мы чувствовали, что наша совместная работа продолжалась слишком мало и проводилась в слишком стесненных обстоятельствах и что поэтому не стоило публиковать результаты без дальнейших экспериментальных подтверждений. Сейчас, летом и осенью 1947 г., мы ищем эти подтверждения, которые, впрочем, могут оказаться и опровержением.

Рокфеллеровский фонд ранее уже предоставил д-ру Розенблюту субсидию на оборудование нового лабораторного здания в Национальном институте кардиологии. Мы решили, что наступило подходящее время для нашего совместного обращения в этот фонд к д-ру Уоррену Уиверу, заведующему отделом физических наук, и д-ру Роберту Морисону, заведующему отделом медицинских наук. Помощь фонда дала бы нам основу для длительного научного сотрудничества и тем самым позволила бы выполнять нашу программу более медленно, но более основательно. В этом нас горячо поддержали наши учреждения. Д-р Джордж Гаррисон, декан отделения точных наук, был главным представителем Массачусетсского технологического института во время этих переговоров, а д-р Игнасио Чавес выступал от имени Национального института кардиологии. Во время переговоров выяснилось, что лабораторный центр нашей совместной работы следует организовать в Национальном институте кардиологии, так как, во-первых, это позволяло избежать дублирования лабораторного оборудования и, во-вторых. Рокфеллеровский фонд был весьма заинтересован в развитии научных центров в Латинской Америке. Наконец, был принят план на пять лет, в течение которых я должен был проводить по шести месяцев каждый второй год в Национальном [c.71] институте кардиологии, а д-р Розенблют – по шести месяцев в Массачусетсском технологическом институте все остальные годы. Время пребывания в Национальном институте кардиологии предполагалось посвятить получению и разъяснению экспериментальных данных, относящихся к кибернетике, а остальное время – изысканиям более теоретического характера и, самое главное, исключительно трудной задаче составления программы подготовки для людей, желающих работать в этой новой области. Необходимо было, чтобы эта программа обеспечивала им приобретение необходимых математических, физических и технических знаний и наряду с этим надлежащее знакомство с методами биологии, психологии и медицины.

Весной 1947 г. д-р Мак-Каллох и г-н Питтс сделали работу, имеющую большое значение для кибернетики. Перед д-ром Мак-Каллохом стояла задача сконструировать аппарат, дающий возможность слепому воспринимать печатный текст на слух. Получение звуков разных тонов от разных букв через посредство фотоэлементов – давно известная вещь. Осуществить ее можно многими способами. Основная трудность заключается в том, чтобы получить один и тот же звук для букв данной формы, независимо от их величины. Это точный аналог задачи восприятия формы, или гештальта, восприятия, позволяющего нам опознавать квадрат как квадрат, независимо от бесчисленных изменений размера и ориентации. Прибор Мак-Каллоха обеспечивал избирательное чтение печатной буквы при различных ее увеличениях. Такое избирательное чтение может выполняться автоматически посредством процесса развертки. Идея развертки, позволяющей производить сравнение между исследуемой фигурой и данной стандартной фигурой фиксированного, но совсем другого размера, уже предлагалась мною на одном из Мейсиевских совещаний. Схема прибора, осуществляющего избирательное чтение, привлекла внимание д-ра фон Бонина, который тут же спросил: “Это схема четвёртого слоя зрительной коры головного мозга?” Основываясь на этой идее, д-р Мак-Каллох с помощью г-на Питтса разработал теорию, связывающую анатомию и физиологию зрительной коры головного мозга. В этой теории операция развертки по некоторому множеству [c.72] преобразований играет большую роль. Указанная теория была доложена весной 1947 г. на Мейсиевском совещании и на заседании Нью-йоркской академии наук.

Упомянутый процесс последовательного перебора занимает определенный период времени, соответствующий так называемому “времени развертки” в обычном телевидении. Различные анатомические соображения позволяют определить этот период по длине цепочки последовательных синапсов, необходимых для осуществления одного цикла работы. Эти соображения дают время порядка одной десятой секунды для полного завершения цикла операций, что приблизительно равно периоду так называемого “альфа-ритма” головного мозга. Между прочим, совершенно другие соображения уже давно говорили за то, что альфа-ритм связан со зрительным восприятием и играет важную роль в процессе восприятия формы.

Весной 1947 г. я получил приглашение принять участие в математической конференции в Нанси (Франция) по проблемам гармонического анализа. Я принял его и по пути в Нанси и обратно провел в целом около трех недель в Англии в гостях у моего старого друга проф. Дж. Б.С. Холдэйна. Это был прекрасный случай встретиться с большинством специалистов, работавших по сверхбыстрым вычислительным машинам, особенно в Манчестере и в Национальной физической лаборатории в Теддингтоне. Но больше всего я был ряд возможности побеседовать в Теддингтоне об основных идеях кибернетики с г-ном Тьюрингом. Я посетил также Психологическую лабораторию в Кембридже и имел возможность обсудить подробно работу, которую вели проф. Ф.К. Бартлетт и его сотрудники. Они занимались оценкой человеческого фактора в управляющих системах, содержащих такой фактор. Я нашел, что в общем в Англии так же сильно интересуются кибернетикой и так же хорошо разбираются в ней, как и в Соединенных Штатах, и что инженерно-технические работы поставлены превосходно, хотя и ограничены в масштабах из-за меньших размеров выделенных средств. Я обнаружил большой интерес к кибернетике и большое понимание ее возможностей у многих, а профессора Холдэйн, X. Леви и Бернал смотрели на нее совершенно определенно, как на один из самых актуальных вопросов, [c.73] стоящих перед наукой и научной философией. Однако в деле объединения всей этой области и сближения друг с другом различных линий научно-исследовательской работы я не обнаружил такого продвижения, как у нас, в Штатах.

Во Франции, на конференции по гармоническому анализу в Нанси, был сделан ряд докладов, в которых статистические понятия соединялись с понятиями из техники связи совершенно в духе идей кибернетики. В особенности должны быть упомянуты г-н Блан-Лапьерр и г-н Лоэв. Я обнаружил также, что этой темой весьма интересуются математики, физиологи и физико-химики, особенно в связи с ее термодинамическими аспектами, затрагивающими более общую проблему природы самой жизни. Между прочим, когда венгерский биохимик проф. Сент-Дьёрдьи обсуждал со мной эти вопросы в Бостоне еще до моего отъезда, оказалось, что его взгляды вполне гармонируют с моими.

Еще одно событие во время моего пребывания во Франции заслуживает здесь особого упоминания. Мой коллега проф. Дж. де Саптильяна из Массачусетсского технологического института познакомил меня с г-ном Фрейманом из издательской фирмы “Герман и Ко”, и г-н Фрейман предложил мне издать настоящую книгу. Я был очень рад его предложению, так как г-н Фрейман – мексиканец, а эта книга писалась в Мексике и значительная часть подготовительной научной работы проводилась также в Мексике.

Как уже упоминалось выше, одно из направлений работы, наметившихся на Мейсиевских совещаниях, касалось значения, которое могут иметь понятия и методы теории связи при изучении общественной системы. Нет сомнения, что общественная система является организованным целым, подобно индивидууму; что она скрепляется в целое системой связи; что она обладает динамикой, в которой круговые процессы обратной связи играют важную роль. Это относится как к общим вопросам антропологии и социологии, так и к более специальным вопросам экономики. В частности, весьма важная работа фон Неймана и Моргенштерна, о которой мы уже говорили, относится к этому кругу идей. На этом основании д-р Грегори Бейтсон и д-р Маргарита Мид убеждали меня, ввиду крайне неотложного [c.74] характера социально-экономических проблем в наш век беспорядка, посвятить значительную часть моих сил обсуждению этой стороны кибернетики.

Однако при всей солидарности с их уверенностью, что ситуация не терпит промедления, и при всей надежде, что они и другие компетентные работники займутся проблемами такого рода (эти проблемы обсуждаются в последней главе настоящей книги), я не могу разделить ни их мнения, что мне следует заниматься этими вопросами в первую очередь, ни их надежд, что в этом направлении можно добиться результатов, которые оказали бы ощутимое терапевтическое действие на теперешние болезни общества. Начать с того, что основные величины, действующие на общество, не только являются статистическими, но более того, определяются чрезвычайно короткими статистическими рядами. Что толку объединять данные об экономике сталелитейной промышленности до и после введения бессемеровского процесса или сравнивать статистику производства резины до и после расцвета автомобильной промышленности и культивации гевеи в Малайе? Точно так же нет глубокого смысла собирать статистику венерических заболеваний, в одной таблице, охватывающей период до и после введения сальварсана, если только специально не имеется в виду выяснить эффективность лекарства. Для хорошей статистики общества нужно собирать данные в течение длительного отрезка времени при существенно постоянных условиях, как для хорошего разрешения света нужен объектив с большим отверстием диафрагмы. Эффективное отверстие диафрагмы не возрастает заметно с увеличением ее номинального отверстия, если только объектив не сделан из столь однородного материала, что задержка света при прохождении различных частей объектива соответствует нужным теоретическим значениям с точностью до малой доли длины волны. Подобно этому, долговременные статистические ряды, составленные при весьма изменчивых условиях, дают лишь кажущуюся, ложную точность.

Итак, гуманитарные науки – убогое поприще для новых математических методов. Настолько же убогой была бы статистическая механика газа для существа с размерами того же порядка, что и молекула. Флюктуацни, [c.75] которые мы игнорируем с более широкой точки зрения, представляли бы для него как раз наибольший интерес. Более того, при отсутствии надежной стандартной методики расчетов роль суждения эксперта в оценке социологических, антропологических и экономических факторов настолько велика, что новичку, еще не приобретшему огромного опыта, свойственного обычно эксперту, здесь нечего делать. Замечу в скобках, что современный аппарат теории малых выборок, как только он выходит за рамки простого подсчета своих собственных, специально определенных параметров и превращается в метод положительных статистических выводов для новых случаев, уже не внушает мне никакого доверия. Исключение составляет случай, когда этот аппарат применяется статистиком, который явно знает или хотя бы неявно чувствует основные элементы динамики исследуемой ситуации.

Я говорил только что об области, в которой мои надежды на кибернетику являются довольно умеренными ввиду существования ограничений на данные, которые мы хотим получить. Однако имеются две области, где, по моему мнению, можно добиться практических результатов с помощью кибернетических идей, но где для этого еще потребуются дальнейшие исследования. Одна из них – протезирование утерянных или парализованных конечностей. Как мы видели при обсуждении гештальта, идеи техники связи уже применялись Мак-Каллохом к проблеме замены утраченных органов чувств, когда он строил прибор, который бы позволил слепому читать печатный текст на слух. Здесь важно, что прибор Мак-Каллоха берет на себя в совершенно явной форме не только функции глаза, но и некоторые функции зрительной области коры головного мозга. Очевидно, нечто подобное возможно и в случае искусственных конечностей. Потеря части конечности означает не только потерю чисто пассивной опоры, доставляемой потерянной частью как механическим продолжением уцелевшей части, и не только потерю способности сокращения соответствующих мышц. Она означает также потерю всех кожных и кинестетических ощущений, возникавших в потерянной части. Первые две потери протезист в настоящее время пытается заменить. Замена третьей пока что была вне его возможностей. В случае [c.76] простой деревянной ноги это не имеет значения: брусок, заменяющий утраченную конечность, не обладает собственными степенями свободы, и кинестетический механизм культи вполне достаточен для регистрации положения и скорости протеза. Иное дело – шарнирный протез с подвижным коленом и лодыжкой, который при ходьбе выбрасывается протезируемым вперед с помощью оставшейся мускулатуры. В этом случае у протезируемого нет достаточных сведений о положении и скорости частей протеза, и протезируемый ступает по неровному грунту неуверенно. Снабдить искусственные суставы и подошву искусственной ступни датчиками натяжения или давления, действующими электрически или как-либо иначе (например, через вибраторы) на нетронутые участки кожи, – это вряд ли непреодолимая трудность. Существующие протезы устраняют некоторые ограничения подвижности, вызванные ампутацией, но оставляют атаксию. Применение подходящих рецепторов позволило бы устранить в значительной степени и атаксию, так что протезируемый мог бы выработать, например, такие рефлексы, которыми все мы пользуемся при управлении автомобилем. Это позволило бы ему ходить гораздо увереннее. Все сказанное о ноге можно применить с еще большим основанием к руке. Рисунок человека в разрезе, знакомый всем читателям книг по неврологии, показывает, что сенсорная потеря при удалении одного только большого пальца руки намного больше, чем при удалении ноги даже до тазобедренного сустава.

Эти доводы я пытался изложить соответствующим авторитетам, но до сего времени мало чего добился. Не знаю, высказывались ли подобные идеи кем-либо раньше, как и не знаю, проводилась ли их проверка и не были ли они отвергнуты за технической неосуществимостью. Если они еще не получили надлежащего практического рассмотрения, то, по всей видимости, получат таковое в ближайшем будущем.

Перейдем теперь к другому вопросу, заслуживающему, по моему мнению, внимания. Для меня давно сделалось ясно, что современная сверхбыстрая вычислительная машина в принципе является идеальной центральной нервной системой для устройств автоматического управления. Ее входные и выходные сигналы не обязательно [c.77] должны иметь вид чисел или графиков, а могут быть также показаниями искусственных органов чувств, например фотоэлементов или термометров, и соответственно сигналами для двигателей и соленоидов. Тензометры и другие подобные средства позволяют наблюдать работу таких двигательных органов и, замыкая обратную связь, передавать эти наблюдения в центральную управляющую систему как искусственные кинестетические ощущения. С помощью этих средств мы уже в состоянии построить искусственные машины почти со сколь угодно сложным поведением. Еще задолго до Нагасаки и до того, как общественности стало известно о существовании атомной бомбы, мне пришла мысль, что мы стоим перед лицом другой социальной силы, несущей неслыханные возможности для добра и для зла. Заводы-автоматы, сборочные конвейеры без рабочих появятся так скоро, как только мы решим затратить на них столько же усилий, сколько мы, например, затратили на развитие техники радиолокации во время II мировой войны26.

Я сказал, что это новое развитие техники несет неограниченные возможности для добра и для зла. С одной стороны, оно делает метафорическое господство машин, о котором фантазировал Сэмьюэл Батлер27, самой непосредственной и неметафорической проблемой. Оно дает человеческой расе новый, весьма эффективный набор механических рабов для несения ее трудов. Такой механический труд обладает многими экономическими качествами рабского труда, хотя, в отличие от последнего, он свободен от деморализующего влияния [c.78] человеческой жестокости. С другой стороны, всякий труд, принимающий условия конкуренции с рабским трудом, принимает и условия рабского труда, а тем самым становится по существу рабским. В этой формуле главное понятие – конкуренция. Быть может, для человечества было бы хорошо, если бы машины избавили его от необходимости выполнять грязные и неприятные работы. А быть может, это было бы плохо – я не знаю. К этим новым возможностям нельзя подходить с точки зрения рынка, с точки зрения сэкономленных денег. Но как раз лозунг свободного рынка – “пятой свободы” – стал лозунгом того сектора американского общественного мнения, который представлен Национальной ассоциацией промышленников и журналом “Сатердей ивнинг пост”. Я говорю об американском общественном мнении потому, что как американец, знаком с ним лучше всего; но торгаши не знают национальных границ.

Быть может, исторические корни настоящего положения вещей станут яснее, если вспомнить, что I промышленная революция – революция “темных сатанинских фабрик”28 – была обесценением человеческих рук вследствие конкуренции машин. Любая заработная плата, на которую мог бы прожить землекоп в Соединенных Штатах, будет слишком высока, чтобы позволить ему конкурировать с экскаватором. Современная промышленная революция должна обесценить человеческий мозг, по крайней мере в его наиболее простых и рутинных функциях. Разумеется, подобно тому, как квалифицированный плотник, квалифицированный механик или квалифицированный портной пережили так или иначе I промышленную революцию, квалифицированный ученый и квалифицированный администратор могут пережить и вторую. Но представим себе, что вторая революция завершена. Тогда средний человек со средними или еще меньшими способностями не сможет предложить для продажи ничего, за что стоило бы платить деньги. [c.79]

Выход один – построить общество, основанное на человеческих ценностях, отличных от купли-продажи. Для строительства такого общества потребуется большая подготовка и большая борьба, которая при благоприятных обстоятельствах может вестись в идейной плоскости, а в противном случае – кто знает как? Поэтому я счел своим долгом передать мои сведения и мое понимание положения тем, кто активно заинтересован условиями и будущим труда, т.е. профсоюзам. Я принял меры к установлению контактов с одним-двумя лицами из руководства Конгресса производственных профсоюзов. Они выслушали меня с большим пониманием и сочувствием. Более этого ни я, ни они сделать не смогли. По их мнению, как и по моим предыдущим наблюдениям и сведениям, профсоюзы и рабочее движение в Соединенных Штатах и в Англии находятся в руках группы весьма ограниченных лиц, хорошо разбирающихся в специальных вопросах деятельности цеховых старост и борьбы за заработную плату и условия работы, но совершенно не подготовленных для занятия большими политическими, техническими, социологическими и экономическими проблемами, касающимися самого существования труда. Причины ясны. Профсоюзный работник, переходя от напряженной жизни рабочего к напряженной жизни администратора, обычно лишен возможности получить широкое образование. Тех же, кто имеет такое образование, обычно не привлекает карьера профсоюзного деятеля. В свою очередь, профсоюзы, вполне естественно, не заинтересованы в приеме таких людей.

Те из нас, кто способствовал развитию новой науки – кибернетики, находятся, мягко говоря, не в очень-то утешительном моральном положении. Эта новая наука, которой мы помогли возникнуть, ведет к техническим достижениям, создающим, как я сказал, огромные возможности для добра и для зла. Мы можем передать наши знания только в окружающий нас мир, а это – мир Бельзена и Хиросимы. Мы даже не имеем возможности задержать новые технические достижения. Они носятся в воздухе, и самое большее, чего добился бы кто-либо из нас своим отказом от исследований по кибернетике, был бы переход всего дела в руки самых безответственных и самых корыстных из наших [c.80] инженеров. Самое лучшее, что мы может сделать, – это позаботиться о том, чтобы широкая публика понимала общее направление и значение этой работы, и ограничиться в своей собственной деятельности такими далекими от войны и эксплуатации областями, как физиология и психология. Как упоминалось выше, есть и такие, кто надеется, что польза от лучшего понимания человека и общества, которое дает эта новая наука, сможет предупредить и перевесить наше невольное содействие концентрации власти (которая всегда – по самим условиям своего существования – сосредоточивается в руках людей, наиболее неразборчивых в средствах). Но я пишу это в 1947 г. и должен заявить, что надежда на такой исход очень слаба.

Автор желает выразить благодарность г-ну Уолтеру Питтсу, г-ну Оливеру Селфриджу, г-ну Жоржу Дюбе и г-ну Фредерику Уэбстеру за помощь при корректировании рукописи и подготовке материала к изданию.

Национальный институт кардиологии,
г. Мехико

Ноябрь 1947 г. [c.81]

Далее:
I. НЬЮТОНОВО И БЕРГСОНОВО ВРЕМЯ

К оглавлению

ПРИМЕЧАНИЯ

1 МсСоll L. A Fundamental Theory of Servomechanisms. – New York: Van Nostrand, 1946 (русский перевод: Маккол Л.Б. Основы теории сервомеханизмов. – М.: ИЛ, 1947 – Ред.).
Вернуться к тексту

2 Rosenblueth A., Wiener N., Bigelow J. Behavior, Purpose & Teleology. // Philosophy of Science. – 1943. – Vol. 10. – P. 18–24 (русский перевод см. в приложении I – Ред.).
Вернуться к тексту

3 См.: Фишер Р.А. Статистические методы для исследователей. – М.: Госстатиздат, 1961; Шеннон К.Э. Работы по теории информации и кибернетики. – М.: ИЛ, 1963. – Прим. ред.
Вернуться к тексту

4 Колмогоров А.Н. Интерполирование и экстраполирование стационарных случайных последовательностей. // Известия АН СССР. – Сер. мат. – 1941. – № 5. – С. 3–14.
Вернуться к тексту

5 Schrődinger E. What is Life? – Cambridge, England: Cambridge University Press, 1945 (русский перевод: Шредингер Э. Что такое жизнь с точки зрения физики? – М.: ИЛ, 1947. – Ред.).
Вернуться к тексту

6 Собственно, Винер употребляет это слово в латинизированной форме “cybernetics”, т.е. “цибернетика”. См. стр. 37. – Прим ред.
Вернуться к тексту

7 Maxwell J.С. On Governors. // Proc. Roy. Soc. (London). – 1868. – Vol. 16. – P. 270–283 (русский перевод: Максвелл Д.К. О регуляторах. // Максвелл Д.К., Вышнеградский И.А., Стодол А. Теория автоматического регулирования. – М.: Изд-во АН СССР, 1949. С. 9–29 – Ред.).
Вернуться к тексту

8 Как оказалось, слово “кибернетика” (χυβερνητίχη) не является неологизмом. Оно встречается довольно часто у Платона, где обозначает искусство управлять кораблем, искусство кормчего, а в переносном смысле – также искусство управления людьми. В 1834 г. знаменитый французский физик А.-М. Ампер, занимавшийся также вопросами классификации наук, назвал, по примеру древних, кибернетикой (cybernetique) науку об управлении государством. В таком значении это слово вошло в ряд известных словарей XIX в. Ампер относил кибернетику вместе с “этнодицеей” (наукой о правах народов), дипломатией и “теорией власти” к политическим наукам, причем кибернетика и теория власти составляли у него “политику в собственном смысле слова” (см. Ampere A.–М. Essai sur la philosophie des sciences. – 2nd partie. – Paris: Bachelier, 1843. Chapitre IV. § IV. P. 140–142). – Прим. ред.
Вернуться к тексту

9 Исчисление умозаключений. – Прим. ред.
Вернуться к тексту

10 См.: Шеннон К.Э. Указ. соч. Булева алгебра классов – логическое исчисление, названное по имени известного английского математика Джорджа Буля (1815–1864), который считается основателем математической логики. – Прим. ред.
 Вернуться к тексту

11 Turing A.M. On Computable Numbers, with an Application to the Entscheidungsproblem. // Proc. London Math. Soc. – Ser. 2. – 1936. – Vol. 42. – P. 230–265.
Вернуться к тексту

12 McCulloch W.S., Pitts W. A logical calculus of the ideas immanent in nervous activity. // Bull. Math. Biophys. – 1943. – Vol. 5. – P. 115–133 (русский перевод: Мак–Каллох У.С., Питтс В. Логическое исчисление идей, относящихся к нервной активности. // Автоматы. / Пер. под ред. Ляпунова А.А. – М.: ИЛ, 1956. С. 362–384. – Ред.).
Вернуться к тексту

13 Институт высших исследований (Institute for Advanced Study) – известный научно–исследовательский центр в гор. Принстоне, штат Нью-Джерси, в котором работали многие выдающиеся ученые, включая А. Эйнштейна. Основан в 1933 г. реформатором американской системы просвещения А. Флекснером. Частное заведение, частично связанное с Принстонским университетом. – Прим. ред.
Вернуться к тексту

14 ЭНИАК (ENIAC – Electronic Numerical Integrator and Automatic Calculator, т.е. “Электронный численный интегратор и автоматический вычислитель”) – первая американская электронная вычислительная машина; строилась во время воины Пенсильванским университетом в Филадельфии для Управления вооружения армии США. Впервые публично продемонстрирована в феврале 1946 г. и затем использовалась в баллистической лаборатории испытательного полигона в Абердине, Мэриленд США. – Прим. ред.
Вернуться к тексту

15 ЭДВАК (EDVAC – Electronic Discrete Variable Automatic Computer, т.е. “Электронная автоматическая вычислительная машина с дискретными переменными”) – вторая электронная вычислительная машина, построенная в Пенсильванском университете; предназначалась для баллистической лаборатории испытательного полигона в Абердине. – Прим. ред.
Вернуться к тексту

16 Как сообщается в другой книге Винера, этот военный отчет вышел в феврале 1942 г. – Прим. ред.
Вернуться к тексту

17 Levinson N. // J. Math. and Physics. – 1947. – Vol. 25. – P. 261–278; Vol. 26. – P. 110–119.
Вернуться к тексту

18 Впоследствии вышла книга: Dооb J.L. Stochastic Processes. – New York – London: Wiley – Chapman & Hall, 1953 (русский перевод: Дуб Дж. Л. Вероятностные процессы. – М.: ИЛ, 1956). В предисловии к ней Дуб указал, что глава XII, посвященная теории линейного предсказания (прогнозирования), написана с помощью Н. Винера. – Прим. ред.
Вернуться к тексту

19 Lee Y.W. // J. Math. and Physics. – 1932. – Vol. 11. – P. 261–278.
Вернуться к тексту

20 Wiener N. Extrapolation, Interpolation, and Smoothing of Stationary Time Series. – New York: Technology Press and Wiley, 1949.
Вернуться к тексту

21 Wiener N.,. Rosenblueth A. The Mathematical Formulation of the Problem of Conduction of Impulses in a Network of Connected Excitable Elements, Specifically in Cardiac Muscele. // Arch. Inst. Cardlol Мех. – 1946. – Vol. 16. – P. 205–265 (русский перевод: Винер Н., Розенблют А. Проведение импульсов в сердечной мышце: Математическая формулировка проблемы проведения импульсов в сети связанных возбудимых элементов, в частности в сердечной мышце. // Кибернетический сборник. – Вып. 3. – М., 1961. С. 7–86. – Ред.).
Вернуться к тексту

22 Гештальт (нем. Gestalt) – целостная форма, целостный образ; термин так называемой гештальтпсихологии – направления в зарубежной психологической науке, придающего особое значение целостному подходу к явлениям. – Прим. ред.
Вернуться к тексту

23 Имеется в виду книга: Neuman J. von, Morgenstern O. Theory of Games and Economic Behavior. – Princeton: Princeton University Press, 1943 (1st ed.; 2nd ed. – 1947). – Прим. ред.
Вернуться к тексту

24 Речь идет об упругом напряжении, т.е. о натяжении, измеряемом в единицах силы. – Прим. ред.
Вернуться к тексту

25 Неопубликованные статьи по клонусу, подготовленные в Национальном институте кардиологии в Мексике.
Вернуться к тексту

26 Fortune. – 1945. – № 32, October. – Р. 139–147; November. – Р. 163–169.
Вернуться к тексту

27 Сэмьюэл Батлер (1835–1902) – видный английский писатель-сатирик. В его фантастической сатире “Едгин, или За горами” (“Erewhon or Over the Range”, 1872) рассказывается о путешествии в труднодоступную страну Едгин (анаграмма от “нигде”, англ. Erewhon от “nowhere”), где “все наоборот”. Едгиняне некогда обладали высокоразвитой техникой, но затем, после “антимашинистской революции”, разрушили все машины и навсегда отказались от них. Переворот вызвала “Книга машин” некоего пророка, анализировавшего эволюцию машин и доказавшего неизбежность конечного порабощения ими человека. Повесть Батлера, написанная в яркой свифтовской форме, имела большой успех (на русский язык не переводилась). Продолжением ее является “Новое путешествие в Едгин” (“Erewhon Revisited”, 1901), где Едгин “европеизируется”. – Прим. ред.
Вернуться к тексту

28 Слова известного английского художника и поэта Уильяма Блейка (1757–1827), современника I промышленной революции (поэма “Иерусалим”) – Прим. ред.


Винер Н

Винер Н. Кибернетика, или управление и связь в животном и машине. – 2-е издание. – М.: Наука; Главная редакция изданий для зарубежных стран, 1983. – 344 с.

Красным шрифтом в квадратных скобках обозначается конец текста на соответствующей странице печатного оригинала данного издания

I. НЬЮТОНОВО И БЕРГСОНОВО ВРЕМЯ

Есть маленький гимн или песня, знакомая каждому немецкому ребенку:

Weiβlt du, wieviel Sternlein stehen
An dem blauen Himmelszelt?
Weiβlt du, wieviel Wolken gehen
Weithin ũber alle Welt?
Cott, der Herr, hat sie gezahlet,
Daβ ihm auch nicht eines fehlet
An der ganzen, groβen Zahl

В. Гей 1

В переводе это значит: “Знаешь ли ты, сколько звездочек стоит на синем шатре небес? Знаешь ли ты, сколько облаков проходит надо всем миром? Господь бог их сосчитал, чтобы не пропало у него ничего из всего огромного числа”.

Эта песенка интересна для философа и для историка науки, ибо в ней сопоставляются две отрасли знания, имеющие то сходство, что в них рассматривается небесный свод, но совершенно различные во всех других отношениях: астрономия, древнейшая наука, и метеорология, одна из самых молодых наук, лишь сейчас начинающая заслуживать название науки. Обычные астрономические явления могут быть предсказаны за много веков, а точное предсказание погоды на завтра, вообще говоря, затруднительно и во многих случаях является очень грубым.

Что касается стихотворения, то на первый вопрос следует ответить, что в определенных границах мы действительно знаем, сколько звезд на небе. Оставляя в стороне мелкие спорные детали, касающиеся некоторых двойных и переменных звезд, можно сказать, что звезда – вполне определенный объект, весьма удобный для [c.82] счета и каталогизации; и если человеческий перебор 2 звезд, как мы можем назвать эти каталоги, останавливается на звездах не слишком слабой величины, то мысль о том, что некий божественный перебор может пойти в этом направлении значительно дальше, не кажется нам слишком нелепой.

Напротив, если вы попросите метеоролога дать аналогичный перебор облаков, то он рассмеется вам в лицо или, быть может, терпеливо объяснит, что в метеорологии нет понятия облака как определенного объекта, остающегося всегда более или менее тождественным самому себе, и что если бы таковое и существовало, то у него, у метеоролога, нет средств сосчитать облака, да, по существу, счет облаков его и не интересует. Метеоролог со склонностью к топологии, пожалуй, мог бы определить облако как связную область пространства, в которой плотность воды, имеющейся в твердом или жидком состоянии, превосходит некоторое значение. Но это определение не имело бы ни для кого ни малейшей ценности и описывало бы в лучшем случае весьма преходящее состояние. Метеоролога интересуют в действительности лишь статистические утверждения, например: “Бостон, 17 января 1950 г., облачность 38%, перисто-кучевые облака”.

Правда, есть раздел астрономии, имеющий дело, так сказать, с космической метеорологией – исследованием галактик, туманностей, звездных скоплений и их статистики, чем занимается, например, Чандрасекар. Но это очень молодой раздел астрономии, моложе метеорологии, и он лежит несколько в стороне от основного направления классической астрономии, которая, вне рамок чистой классификации и перебора, первоначально занималась больше Солнечной системой, чем миром неподвижных звезд. Именно астрономия Солнечной системы тесно связана с именами Коперника, Кеплера, Галилея и Ньютона и явилась кормилицей современной физики.

Это действительно идеально простая наука. Даже до появления какой-либо динамической теории еще в Вавилоне понимали, что затмения происходят через правильные, предсказуемые периоды и что можно [c.83] узнать их наступление в прошлом и в будущем. Люди поняли, что и само время лучше всего измерять перемещением звезд по их путям. Моделью всех событий в Солнечной системе считалось вращение колеса или ряда колес, как в птолемеевской теории эпициклов или в коперниковской теории орбит; и в любой такой теории будущее в некоторой степени повторяло прошедшее. Музыка сфер – палиндром 3 – и книга астрономии читаются одинаково в прямом и обратном направлениях. Прямое и обратное движения планетария различаются лишь начальными положениями и направлениями перемещения светил. Наконец, когда Ньютон свел все это к формальной системе постулатов и к замкнутой механике, было установлено, что основные законы не изменяются при замене переменной времени t на –t.

Таким образом, если снять кинофильм движения планет, ускоренного так, чтобы изменения их положения были заметны, и затем пустить этот фильм в обратном направлении, то картина движения планет была бы все же возможной и согласной с механикой Ньютона. Напротив, если бы мы сняли кинофильм турбулентного движения облаков в области фронта грозы и пустили бы этот фильм в обратном направлении, то получилась бы совершенно неверная картина. Мы увидели бы нисходящие токи там, где должны быть восходящие; размеры турбулентных образований увеличивались бы; молния предшествовала бы тем изменениям строения тучи, за которыми она обычно следует, и т.д. до бесконечности.

В чем же различие природы астрономических и метеорологических явлений, вызывающее все эти особенности, и в частности то, что в астрономии время столь очевидно обратимо, а в метеорологии оно столь очевидно необратимо? Дело прежде всего в том, что метеорологическая система всегда содержит большое число приблизительно одинаковых частиц, причем некоторые из них очень тесно связаны между собой. Напротив, астрономическая, а именно Солнечная система содержит лишь сравнительно небольшое число частиц, притом [c.84] весьма различного размера и связанных между собой настолько слабо, что связи второго порядка не меняют общего характера наблюдаемой нами картины, а связи высших порядков можно совершенно не учитывать. Планеты движутся при условиях, более благоприятных обособлению некоторой ограниченной системы сил, чем условия любого физического опыта, который мы можем поставить в лаборатории. Планеты и даже Солнце по сравнению с расстояниями между ними являются настоящими точками. Упругие и пластические деформации планет настолько малы, что планеты можно считать абсолютно твердыми телами; а если даже это и не так, то во всяком случае внутренние силы планет имеют сравнительно малое значение при рассмотрении относительного движения их центров. Пространство, в котором движутся планеты, почти совершенно свободно от вещества, препятствующего их движению, а при рассмотрении взаимного притяжения планет вполне можно считать, что их массы сосредоточены в центрах и постоянны. Отклонения силы тяготения от закона обратной пропорциональности квадрату расстояния совершенно ничтожны. Положения, скорости и массы тел Солнечной системы в любой момент известны с исключительной точностью, а их будущие и прошлые положения вычисляются легко и точно – хотя бы в принципе, если и не всегда на практике. Напротив, в метеорологии число рассматриваемых частиц так велико, что точная запись их начальных положений и скоростей совершенно невозможна, а если даже и составить такую запись и вычислить будущие положения и скорости всех частиц, то мы получим лишь необозримое множество цифр, которые нужно было бы коренным образом переосмыслить, прежде чем мы смогли бы их использовать. Термины “облако”, “температура”, “турбулентность” и т.д. относятся не к отдельному физическому состоянию, а к распределению возможных состояний, из которых реализуется лишь одно. Если собрать все одновременные наблюдения всех метеостанций мира, то эти наблюдения не составят и одной миллиардной доли данных, необходимых для описания мгновенного состояния атмосферы в ньютонианском смысле. Они дадут лишь некоторые константы, совместимые с бесконечным числом различных атмосфер и в лучшем случае способные – при некоторых [c.85] априорных допущениях – определить в виде распределения вероятностей лишь некоторую меру на множестве возможных атмосфер. При помощи законов Ньютона или любой другой системы причинных законов мы можем предсказать на будущий момент лишь распределение вероятностей для констант метеорологической системы, причем надежность даже и этого предсказания уменьшается с увеличением времени.

Но и в ньютоновой системе, в которой время вполне обратимо, в задачах на вероятность и предсказание получаются асимметрические ответы для прошлого и будущего, потому что сами эти задачи асимметричны. Если я ставлю физический опыт, я перевожу рассматриваемую мной систему из прошлого в настоящее, фиксируя некоторые величины и считая себя вправе предполагать, что некоторые другие величины имеют известные статистические распределения. Затем я наблюдаю статистическое распределение результатов после данного промежутка времени. Этот процесс я не могу обратить. Для этого нужно было бы подобрать благоприятное распределение систем, которые без нашего вмешательства заканчивали бы свои процессы в определенных статистических пределах, и найти, каковы были условия в данный момент прежде. Но событие, при котором система, начавшая свой процесс с неизвестного состояния, заканчивает его в строго определенном статистическом диапазоне, бывает настолько редко, что мы можем считать это чудом. Очевидно, мы не можем основывать наши экспериментальные методы на ожидании и счете чудес. Говоря коротко, наше время направлено и наше отношение к будущему отлично от отношения к прошлому. Все вопросы, которые мы ставим, содержат эту асимметрию, и ответы на них также асимметричны.

Очень интересный астрономический вопрос относительно направления времени возникает в связи с астрофизическим временем. Ведь в астрофизике, при однократном наблюдении отдаленных небесных тел, опыт по своей сущности как будто не является однонаправленным. Почему же однонаправленная термодинамика, основанная на экспериментальных земных наблюдениях, оказывается столь полезной в астрофизике? Ответ на этот вопрос довольно интересный и не такой простой. Мы наблюдаем звезды через посредство лучей или [c.86] частиц света, исходящих от наблюдаемого объекта и воспринимаемых нами. Мы можем воспринимать приходящий свет, но не можем воспринимать уходящий свет. По крайней мере, восприятия уходящего света нельзя добиться таким же простым и непосредственным экспериментом, как восприятия приходящего света. Мы воспринимаем приходящий свет при помощи глаза или фотографической пластинки. Мы подготавливаем их для восприятия образов, изолируя их от прошлого в течение некоторого времени: мы смотрим предварительно в темноту, чтобы устранить следы предшествующих образов, и завертываем пластинки в черную бумагу во избежание засвечивания. Очевидно, только такие глаза и такие пластинки могут быть пригодны; сохранять предыдущие образы – все равно, что быть слепым, и если бы нам нужно было завертывать пластинки в черную бумагу после их применения и проявлять их до применения, то фотография была бы очень трудным делом. Поэтому мы можем видеть звезды, испускающие свет для нас и для всей Вселенной, а если существуют звезды, развивающиеся в обратном направлении, они будут притягивать излучения от всех небесных светил. Но притяжение света, даже исходящего от нас, никак нельзя будет заметить, потому что мы знаем свое прошлое, но не будущее. Итак, видимая нами часть Вселенной должна иметь соотношения между прошлым и будущим, согласные с существующими на Земле, поскольку дело касается светового излучения. Сам факт, что мы видим звезду, означает, что ее термодинамика подобна нашей термодинамике.

Очень интересный мысленный опыт – вообразить разумное существо, время которого течет в обратном направлении по отношению к нашему времени. Для такого существа никакая связь с нами не была бы возможна. Сигнал, который оно послало бы нам, дошел бы к нам в логическом потоке следствий – с его точки зрения – и причин – с нашей точки зрения. Эти причины уже содержались в нашем опыте и служили бы нам естественным объяснением его сигнала без предположения о том, что разумное существо послало сигнал. Если бы оно нарисовало нам квадрат, остатки квадрата представились бы нам предвестниками последнего, и квадрат казался бы нам любопытной кристаллизацией этих [c.87] остатков, всегда вполне объяснимой. Его значение казалось бы нам столь же случайным, как те лица, которые представляются нам при созерцании гор и утесов. Рисование квадрата показалось бы нам катастрофической гибелью квадрата – внезапной, но объяснимой естественными законами. У этого существа были бы такие же представления о нас. Мы можем сообщаться только с мирами, имеющими такое же направление времени.

Вернемся к различию между ньютоновой астрономией и метеорологией. Большинство наук занимает промежуточное положение между ними, но ближе к метеорологии, чем к астрономии. Да и астрономия, как мы видели, включает в себя космическую метеорологию. Она включает также чрезвычайно интересную область, которую изучал сэр Джордж Дарвин, известную под наименованием теории приливной эволюции. Мы сказали, что можно рассматривать относительные движения Солнца и планет как движения твердых тел, но это не совсем так. Земля, например, большей частью покрыта океанами. Вода, расположенная ближе к Луне, чем центр Земли, притягивается Луной сильнее, чем твердая часть Земли, а вода, расположенная на другой стороне, – слабее. Вследствие этого, сравнительно небольшого воздействия вода образует два возвышения: одно – под Луной, другое – в противоположном пункте. На совершенно жидкой сфере эти возвышения следовали бы за движением Луны вокруг сферы, не рассеивая значительной энергии, и поэтому оставались бы все время почти точно под Луной и в противоположном пункте. Вследствие этого они задерживали бы Луну лишь весьма незначительно и не оказывали бы большого влияния на ее угловое положение на небосводе. Но приливная вол-па, образуемая ими на Земле, задерживается на берегах и в мелких морях, таких, например, как Берингово море и Ирландское море. Поэтому приливная волна отстает от Луны, причем силы, вызывающие отставание, в основном суть турбулентные, диссипативные силы, весьма сходные с силами, наблюдаемыми в метеорологии, и они требуют статистического подхода. По существу океанографию можно назвать метеорологией – но не атмосферы, а гидросферы.

Эти силы трения задерживают Луну в ее движении вокруг Земли и ускоряют вращение Земли. Они стремятся [c.88] приблизить друг к другу продолжительности месяца и дня. Действительно, день Луны – месяц, и Луна всегда повернута к Земле почти одной и той же стороной. Высказывалось предположение, что это произошло вследствие давней приливной эволюции, когда на Луне имелась или жидкость, или газ, или пластическое вещество, которые подвергались притяжению Земли и при этом рассеивали большое количество энергии. Явление приливной эволюции не ограничивается Луной и Землей, его можно наблюдать в некоторой степени во всех гравитационных системах. В прошедшие эпохи приливы значительно изменили облик Солнечной системы, хотя за время, сравнимое с историческим периодом, это изменение было незначительным по сравнению с движением планет Солнечной системы как твердых тел.

Итак, даже гравитационная астрономия связана с задерживающими процессами трения. Нет ни одной науки, которая полностью подчинялась бы концепции Ньютона. В биологических науках, бесспорно, однонаправленные явления господствуют. Рождение не есть процесс, в точности противоположный смерти. Анаболизм – образование тканей – не является точной противоположностью катаболизму – их разрушению. Деление клеток, так же как соединение зародышевых клеток при оплодотворении яйца, происходит по схеме, которая не симметрична во времени. Индивидуум – стрела, устремленная во времени в одном направлении, и раса точно так же направлена из прошлого в будущее. Палеонтологическая летопись указывает для большого промежутка времени на определенную тенденцию развития, часто прерываемую и запутанную, но идущую от простого к сложному. К середине прошлого столетия эта тенденция стала очевидной для всех честных, непредубежденных ученых, и не случайно задача открытия ее механизма была решена благодаря одной и той же великой догадке почти одновременно двух ученых: Чарлза Дарвина и Альфреда Уоллеса. Эта догадка состояла в том, что простое случайное изменение особей вида может вылиться в развитие, идущее более или менее по одной или немногим направлениям для каждой линии, благодаря различным степеням жизнеспособности разных изменений с точки зрения особи или вида. Собака, вследствие мутации оказавшаяся без ног, конечно, [c.89] погибнет, а длинная, тонкая ящерица, развившая у себя механизм ползания на ребрах, может выжить, если ее тело гладко и не имеет выступающих членов. Водное животное – рыба, ящерица или млекопитающее – будет плавать лучше при веретенообразной форме тела и наличии сильных мышц и захватывающего воду заднего придатка. Если оно добывает пищу погоней за быстрыми животными, то шансы его выживания, возможно, будут определяться тем, что его тело получит такое строение.

Дарвиновская эволюция, таким образом, представляет собой некоторый механизм, при помощи которого более или менее случайные изменения комбинируются в весьма определенную структуру. Принцип Дарвина остается справедливым и в настоящее время, хотя мы знаем гораздо лучше механизм, лежащий в его основе. Работа Менделя дала нам значительно более точное и последовательное представление о наследственности, чем то, которое было у Дарвина, а идея мутации со времени Де Фриза совершенно изменила наше понимание статистической основы мутации. Мы изучили тонкую анатомию хромосомы и локализовали в ней ген. Список современных генетиков большой и включает выдающихся ученых. Некоторые из них, например Холдэйн, сделали статистические законы менделизма эффективным орудием исследования эволюции.

Мы уже говорили о теории приливной эволюции сэра Джорджа Дарвина, сына Чарлза Дарвина. Связь идей сына с идеями отца, как и выбор названия “эволюция”, не случайны. В приливной эволюции, как и в происхождении видов, мы встречаемся с механизмом, который преобразует динамическим путем случайные изменения, а именно случайные движения волн и молекул воды при приливе, в однонаправленное развитие. Теория приливной эволюции есть не что иное, как теория Дарвина-старшего в применении к астрономии.

Третий представитель династии Дарвинов, сэр Чарлз, является одним из авторитетов в современной квантовой механике. Этот факт может показаться случайным, но тем не менее он означает дальнейшее вторжение статистических принципов и в ньютонову механику. Последовательность имен Максвелл – Больцман – Гиббс характеризует все большее сведение [c.90] термодинамики к статистической механике, т.е. сведение явлений, связанных с теплотой и температурой, к явлениям, при рассмотрении которых ньютонова механика применяется не к одиночной динамической системе, а к статистическому распределению динамических систем, и выводы относятся не ко всем таким системам, но к их подавляющему большинству. К 1900 г. стало очевидно, что в термодинамике имеются серьезные упущения, в частности, когда речь шла об излучении. Закон Планка показал, что эфир поглощает излучения высокой частоты в значительно меньшей степени, чем это допускалось всеми существовавшими тогда механическими теориями излучения. Планк предложил квазиатомистическую теорию излучения – квантовую теорию, которая достаточно удовлетворительно объясняла эти явления, но расходилась со всей остальной физикой. После этого Нильс Бор предложил теорию атома, также построенную ad hoc 4 . Таким образом, Ньютон и Планк – Бор составили соответственно тезис и антитезис гегелевой антиномии. Синтезом является статистическая теория, открытая Гейзенбергом в 1925 г., в которой статистическая ньютонова динамика Гиббса заменена статистической теорией, весьма близкой к теории Ньютона и Гиббса для макроскопических явлений, но в которой полное собрание данных для прошлого и настоящего позволяет предсказать будущее лишь статистически. Поэтому не будет слишком смелым сказать, что не только ньютонова астрономия, но и ньютонова физика стала ареной усредненных результатов статистической ситуации и, следовательно, рассказом об эволюционном процессе.

Этот переход от ньютонова обратимого времени к гиббсову необратимому получил философские отклики. Бергсон подчеркнул различие между обратимым временем физики, в котором не случается ничего нового, и необратимым временем эволюции и биологии, в котором всегда имеется что-нибудь новое. Догадка, что ньютонова физика не составляла подходящей основы для биологии, была, пожалуй, главным вопросом в старом споре между витализмом и механицизмом, хотя этот спор осложнялся еще желанием сохранить в той или иной форме хотя бы тени души и бога от атак материализма. [c.91] В конце концов, как мы видели, витализм доказал слишком много. Вместо сооружения стены между требованиями жизни и требованиями физики была воздвигнута стена, заключающая столь обширную территорию, что и материя, и жизнь оказались внутри нее. Истина в том, что материя новейшей физики не есть материя Ньютона. Но она также очень далека от антропоморфических представлений виталистов. Случайность в квантовой теории – не то, что нравственная свобода у блаженного Августина, и Тиха – столь же неумолимая владычица, как Ананка 5.

Идеи каждой эпохи отражаются в ее технике. Инженерами древности были землемеры, астрономы и мореплаватели; инженерами XVII и начала XVIII столетия – часовщики и шлифовальщики линз. Как и в древности, ремесленники создавали свои инструменты по образу небесных светил. Ведь часы не что иное, как карманный планетарий, движущийся в силу необходимости, подобно небесным сферам, а если в часах играет некоторую роль трение и рассеяние энергии, то это явления нужно устранить, чтобы движение стрелок было по возможности периодическим и правильным. Основным практическим результатом этой техники, основанной на идеях Гюйгенса и Ньютона, была эпоха мореплавания, когда впервые стало возможно вычислять долготы с приемлемой точностью, и торговля с заокеанскими странами, бывшая чем-то случайным и рискованным, превратилась в правильно поставленное предприятие. Это была техника коммерсантов.

Купца сменил фабрикант, а место хронометра заняла паровая машина. От машины Ньюкомена почти до настоящего времени основной областью техники было исследование первичных двигателей. Тепло было превращено в полезную энергию вращения и поступательного движения, а физика Ньютона была дополнена физикой Румфорда, Карно и Джоуля. Появилась термодинамика – наука, в которой время, по существу, необратимо; и хотя на первых шагах эта наука, по-видимому, представляла собой область мышления, почти не имевшую точек соприкосновения с ньютоновой [c.92] динамикой, однако теория сохранения энергии и последующее статистическое истолкование принципа Карно, или второго закона термодинамики, или принципа вырождения энергии, – этого принципа, на основании которого максимальный коэффициент полезного действия, достижимый для паровой машины, зависит от рабочих температур котла и конденсатора, – все эти открытия привели к слиянию термодинамики и ньютоновой динамики в одну науку, взятую соответственно в ее статистическом и нестатнстическом аспектах.

Если XVII столетие и начало XVIII столетия – века часов, а конец XVIII и все XIX столетие – века паровых машин, то настоящее время есть век связи и управления. В электротехнике существует разделение на области, называемые в Германии техникой сильных токов и техникой слабых токов, а в США и Англии – энергетикой и техникой связи. Это и есть та граница, которая отделяет прошедший век от того, в котором мы сейчас живем. В действительности техника связи может иметь дело с токами любой силы и с двигателями большой мощности, способными вращать орудийные башни; от энергетики ее отличает то, что ее в основном интересует не экономия энергии, а точное воспроизведение сигнала. Этим сигналом может быть удар ключа, воспроизводимый ударом приемного механизма в телеграфном аппарате на другом конце линии, или звук, передаваемый и принимаемый через телефонный аппарат, или поворот штурвала, принимаемый в виде углового положения руля. Техника связи началась с Гаусса, Уитстона и первых телеграфистов. Она получила первую достаточно научную трактовку у лорда Кельвина, после повреждения первого трансатлантического кабеля в середине прошлого столетия. С 80-х годов, по-видимому, больше всего сделал для приведения ее в современный вид Хевисайд. Изобретение и использование радиолокации во II мировой войне, наряду с требованиями управления зенитным артиллерийским огнем, привлекло в эту область большое число квалифицированных математиков и физиков. Чудеса автоматической вычислительной машины принадлежат к тому же кругу идей – идей, которые, бесспорно, никогда еще не разрабатывались так интересно, как сейчас.

На всех ступенях развития техники со времени [c.93] Дедала и Герона Александрийского людей интересовала возможность создания машин, подражающих живому организму. Это стремление к созданию и изучению автоматов всегда выражалось на языке существовавшей в данное время техники. В дни магии мы встречаем причудливое и зловещее представление о Големе – глиняной фигуре, в которую раввин из Праги вдохнул жизнь кощунством против Неизрекаемого Имени Божия 6 . Во времена Ньютона автомат принимает вид часового музыкального ящика с фигурками на крышке, совершающими чопорные пируэты. В XIX столетии автомат – это прославленный тепловой двигатель, сжигающий горючее подобно тому, как человеческие мышцы сжигают гликоген. Наконец, современный автомат открывает двери при помощи фотоэлементов или направляет пушки на то место, где луч радиолокатора обнаруживает самолет, или решает дифференциальное уравнение.

И автомат древних греков, и магический автомат лежат в стороне от основных линий развития современных машин, и по-видимому, не оказали большого влияния на серьезную философскую мысль. Совсем иначе обстоит дело с часовым автоматом. Эта идея действительно сыграла важную роль в ранней истории новой философии, хотя мы склонны ее игнорировать.

Начать с того, что Декарт считает низших животных автоматами, дабы не подвергать сомнению ортодоксальное христианское положение о том, что животные не имеют души, которая может быть спасена или осуждена. Вопрос о том, как действуют эти живые [c.94] автоматы. Декарт, насколько мне известно, нигде не обсуждает. Но важный родственный вопрос о способе соединения человеческой души в сфере ощущений и воли с ее материальным окружением Декарт рассматривает, хотя и весьма неудовлетворительным образом. Он считает местом этого соединения одну известную ему среднюю часть мозга – шишковидную железу. Характер соединения – является ли оно непосредственным действием духа на материю и материи на дух – ему не особенно ясен. Вероятно, он рассматривает это соединение как непосредственное действие в том и другом направлении, но он считает, что истинность человеческого опыта по отношению ко внешнему миру обусловлена благостью и справедливостью бога.

Роль, приписываемая в этом смысле богу, неясна. Либо бог полностью пассивен, и тогда объяснение Декарта ничего в действительности не объясняет, либо он активный участник, тогда гарантия, основанная на его справедливости, может состоять лишь в активном участии бога в акте ощущения. Таким образом, параллельно причинной цепи материальных явлений проходит причинная цепь, начинающаяся с акта, совершаемого богом, которым он производит в нас восприятия, соответствующие данному материальному состоянию. После такого допущения вполне естественно приписать подобному же божественному вмешательству соответствие между нашей волей и действиями, которые она, кажется нам, производит во внешнем мире. По этому пути пошли окказионалисты – Гейлинкс и Мальбранш. У Спинозы, который во многих отношениях является продолжателем этой школы, доктрина окказионализма принимает более разумную форму, в виде утверждения, что соответствие между духом и материей есть соответствие двух атрибутов, содержащихся в самом боге. Но Спиноза лишен динамического склада мышления и обращает мало внимания на механизм этого соответствия.

Из этого положения исходит Лейбниц, но мышление Лейбница динамично, в отличие от геометрического мышления Спинозы. Он заменяет пару соответствующих друг другу элементов – дух и материю – континуумом соответствующих друг другу элементов – монадами. Хотя они созданы по образу души, во многих случаях они не поднимаются до степени самосознания [c.95] совершенных душ и образуют часть того мира, который Декарт считал материей. Каждая из них живет в своем замкнутом мире, в котором имеет место совершенная причинная цепь от сотворения или от минус бесконечности во времени до неограниченно отдаленного будущего, но хотя они и замкнуты, они соответствуют друг другу благодаря предустановленной гармонии бога. Лейбниц сравнивает их с часами, которые были заведены так, что с сотворения они будут идти в такт в течение всей вечности. В отличие от часов, сделанных .людьми, они не впадают в асинхронизм. Но это обусловлено чудесным и совершенным мастерством творца.

Итак, Лейбниц рассматривает мир автоматов, который, как и полагается ученику Гюйгенса, он строит по образцу часового механизма. Хотя монады и отображают одна другую, это отображение не есть перенос причинной связи от одной монады к другой. По существу, они столь же самодовлеющие или даже более самодовлеющие, чем пассивно танцующие фигурки на крышке музыкального ящика. Они не оказывают реального влияния на внешний мир и, по существу, не испытывают его влияния. Как говорит Лейбниц, монады “не имеют окон”. Наблюдаемая нами организация мира представляет собой нечто среднее между вымыслом и чудом. Монада – это ньютонова Солнечная система в миниатюре.

В XIX в. автоматы, построенные человеком, и другие, естественные автоматы – животные и растения в представлении материалистов – изучаются в совершенно другом разрезе. Руководящие принципы этого века – сохранение и вырождение энергии. Живой организм – это прежде всего тепловой двигатель, сжигающий глюкозу, гликоген или крахмал, жиры и белки, которые превращаются в двуокись углерода, воду и мочевину. Внимание сосредоточено на метаболическом балансе, и если обращали внимание на низкие рабочие температуры мышц животного в противоположность высоким рабочим температурам теплового двигателя с таким же коэффициентом полезного действия, то от этого факта отмахивались и объясняли его тем, что в живом организме действует химическая энергия, а в машине – тепловая энергия. Все основные понятия приводились в связь с энергией, и основным из них было [c.96] понятие потенциала. Изучение механизма тела представляло собой ветвь энергетики. Такова до настоящего времени господствующая точка зрения классически мыслящих, консервативных физиологов. Общее направление мыслей таких биофизиков, как Рашевский и представители его школы, свидетельствует о живучести этих взглядов.

В настоящее время мы начинаем понимать, что тело – далеко не консервативная система и что его составные части действуют в окружении, имеющем не такую ограниченную мощность, как это считалось. Электронная лампа показала нам, что система с внешним источником энергии, которая почти вся тратится впустую, может быть очень эффективным средством выполнения нужных операций, особенно если она работает на низком энергетическом уровне. Мы начинаем понимать, что такие важные элементы, как нейроны – атомы нервной системы нашего тела – совершают свою работу примерно при таких же условиях, как электронные лампы, получая свою сравнительно небольшую энергию извне от кровообращения, и что энергия не является основным фактором при учете их работы. Короче говоря, в наше время исследование автоматов – из металла или из плоти – представляет собой отрасль техники связи, и фундаментальными понятиями являются понятия сообщения, количества помех, или “шума” (термин, перенятый у инженера-телефониста), количества информации, методов кодирования и т.д.

При таком исследовании мы рассматриваем автоматы, эффективно связанные с внешним миром не только потоком энергии или метаболизмом, но также потоком впечатлений – приходящих сообщений – и действий – исходящих сообщений. Органы, воспринимающие впечатления, эквивалентны органам чувств человека и животных. Таковы фотоэлектрические элементы и другие световые приемники; радиолокационные системы, принимающие свои собственные короткие электромагнитные волны; приборы для регистрации потенциала водородных ионов, подобные органам осязания; термометры, манометры, различного рода микрофоны и т.д. Исполнительными органами могут быть электрические двигатели, соленоиды, нагревательные катушки и другие самые разнообразные приборы. Между [c.97] воспринимающими, или чувствительными, органами и исполнительными органами находится промежуточная группа элементов. Их функция – объединять приходящие впечатления таким образом, чтобы вызвать желательную реакцию в исполнительных органах. Это – центральная система управления. Информация, поступающая в эту центральную управляющую систему, очень часто содержит информацию о работе самих исполнительных органов. Дающие эту информацию элементы соответствуют, между прочим, кинестетическим органам и другим проприоцепторам нервной системы человека, ибо человек также имеет органы, регистрирующие положение сустава или степень сокращения мышцы и т.д. Кроме того, информация, принимаемая автоматом, не обязательно должна использоваться немедленно, но может быть задержана или запасена, чтобы ее можно было использовать когда-нибудь в будущем. Это свойство аналогично памяти. Наконец, пока автомат работает, правила его действия могут изменяться на основании данных, прошедших раньше через его воспринимающие органы. Это напоминает процесс обучения.

Машины, о которых мы сейчас говорим, – отнюдь не мечта сенсуалиста и не предположение об отдаленном будущем. Они уже существуют в виде термостатов, автоматических гирокомпасных систем управления кораблем, самолетов-снарядов, особенно самонаводящихся, систем управления артиллерийским зенитным огнем, автоматических крекинговых установок, сверхбыстрых вычислительных машин и т. п. Такие машины стали применяться задолго до войны – по существу регулятор старинной паровой машины также относится к ним, – но широкая механизация во время II мировой войны привела к их полному развитию, а необходимость управления необыкновенно разрушительной энергией атома вызовет, вероятно, еще большее их усовершенствование. Почти каждый месяц появляется новая книга об этих так называемых следящих системах, или сервомеханизмах. Наше столетие является в такой же мере веком следящих систем, как XIX столетие было веком паровой машины, а XVIII столетие – веком часов.

Итак, многие нынешние автоматы имеют связь с внешним миром, выражающуюся как в восприятии [c.98] впечатлений, так и в выполнении действий. Они содержат органы чувств, исполнительные органы и какой-то эквивалент нервной системы, объединяющий передачу информации от первых ко вторым. Их вполне можно описывать при помощи физиологических терминов. Неудивительно, что автоматы и физиологические системы можно охватить одной теорией.

Отношение этих механизмов ко времени требует тщательного изучения. Понятно, что зависимость между входом и выходом является последовательной во времени и предполагает определенный порядок перехода от прошлого к будущему. Но, пожалуй, не столь очевидно, что теория чувствующих автоматов является статистической. Нас вряд ли может интересовать работа устройства связи с одним-единственным входным сигналом. Чтобы соответствовать своему назначению, такое устройство должно работать удовлетворительно для целого класса входных сигналов, прием которых статистически возможен. Поэтому его нужно изучать на основе статистической механики Гиббса, а не классической механики Ньютона. Мы рассмотрим этот вопрос подробнее в главе, посвященной теории связи.

Итак, современный автомат существует в таком же бергсоновом времени, как и живой организм. Поэтому соображения Бергсона о том, что деятельность живого организма по существу отлична от деятельности автомата этого типа, необоснованы. Витализм выиграл спор до такой степени, что даже механизмы оказались соответствующими виталистической структуре времени, но, как было сказано выше, эта победа равносильна полному поражению, ибо со всех точек зрения, имеющих какое-либо отношение к нравственности и религии, новая механика столь же механистична, как и старая. Назвать ли новую точку зрения материалистической – это в общем спор о словах. Господство материи характеризует определенную стадию физики XIX века в гораздо большей степени, чем современность. Сейчас “материализм” – это лишь что-то вроде вольного синонима “механицизма”. По существу, весь спор между механицистами и виталистами можно отложить в архив плохо сформулированных вопросов. [c.99]

Далее:
II. ГРУППЫ И СТАТИСТИЧЕСКАЯ МЕХАНИКА

К оглавлению

ПРИМЕЧАНИЯ

1 Вильгельм Гей (1790–1854) – немецкий баснописец. – Прим. ред.
Вернуться к тексту

2 Винер пользуется здесь немецким словом Durchmusterung. – Прим. ред.
 Вернуться к тексту

3 Палиндром (греч.) – слово или фраза, сохраняющие свой смысл при чтении в обратном направлении (“комок”, “рог гор”) – Прим. ред.
Вернуться к тексту

4 Специально на этот случай – Прим. пер.
Вернуться к тексту

5 Тиха (или Тюхе) по-гречески – Случай, Ананка – Рок, образы античной мифологии. – Прим. ред.
Вернуться к тексту

6 По преданию, главный раввин Праги, известный талмудист Лива (или Леве) бен-Бецалел (1525–1609) сделал глиняного слугу – Голема – и оживил его кощунственным употреблением священнейшего имени бога, произношение которого у евреев было строжайше запрещено. По библейскому повествованию, под этим именем бог открылся Моисею, когда давал ему законы для Израиля. В Ветхом Завете оно обозначено четырьмя буквами JHWH и читалось позже как “Иегова” (Jehowah), подлинное же древнее произношение, как предполагают, было “Ягве” (Jahweh); в силу запрета его обычно заменяли словом “господь”, как оно и переведено в русской библии. Древнееврейское слово “голем” (golem) означает “нечто бесформенное, зачаточное” и в переносном смысле – “манекен, подобие человека”. Легенда о Големе сложилась, по-видимому, в пражском гетто и была использована в ряде романов и фильмов. – Прим. ред.


Винер Н

Винер Н. Кибернетика, или управление и связь в животном и машине. – 2-е издание. – М.: Наука; Главная редакция изданий для зарубежных стран, 1983. – 344 с.

Красным шрифтом в квадратных скобках обозначается конец текста на соответствующей странице печатного оригинала данного издания

II. ГРУППЫ И СТАТИСТИЧЕСКАЯ МЕХАНИКА

К началу этого столетия двое ученых, один в Соединенных Штатах, другой во Франции, работали в областях, которые показались бы им совершенно не связанными, если бы один из них узнал о существовании другого. Уиллард Гиббс в Нью-Хейвене разрабатывал свой новый подход к статистической механике. Анри Лебег в Париже соперничал славой со своим учителем Эмилем Борелем, создав новую, более мощную теорию интегрирования, которая должна была использоваться при изучении тригонометрических рядов. Эти два исследователя походили друг на друга тем, что оба были кабинетными, а не лабораторными работниками, но они подходили к науке с диаметрально противоположных позиций.

Гиббс, хотя и был математиком, всегда считал математику наукой, подчиненной физике. Лебег был чистейший аналитик, выдающийся представитель современных, крайне суровых требований к математической строгости, и его работы, насколько мне известно, не содержат ни одного примера задач или методов, вытекающих непосредственно из физики. Тем не менее работы этих ученых составляют единое целое, и на вопросы, которые ставит Гиббс, мы находим ответ не в его собственных работах, а в работах Лебега.

Главная мысль Гиббса такова. В ньютоновой динамике в ее первоначальном виде рассматривается индивидуальная система с заданными начальными скоростями и импульсами 1 , подвергающаяся изменениям под [c.100] действием некоторой системы сил согласно законам Ньютона, которые устанавливают связь между силой и ускорением. Однако в громадном большинстве практических случаев нам известны далеко не все начальные скорости и импульсы. Если принять некоторое начальное распределение не вполне известных положений и импульсов системы, то тем самым будет определено в строго ньютоновском смысле распределение положений и импульсов в любой момент будущего. Тогда можно высказать ряд предложений об этих распределениях, и часть из них – в форме утверждений, что система будет иметь некоторые характеристики с вероятностью 1 и некоторые другие – с вероятностью 0.

Вероятности, равные единице и нулю, суть понятия, включающие полную достоверность и полную невозможность, но их значение гораздо шире. Если я стреляю по цели нулей точечного размера, то вероятность моего попадания в определенную точку цели равна нулю, хотя не исключена возможность, что я попаду в нее; и, действительно, в каждом отдельном случае я обязательно попаду в некоторую точку, что является событием нулевой вероятности. Таким образом, событие вероятности 1, а именно попадание в какую-либо точку, может состоять из совокупности событий, каждое из которых имеет вероятность 0.

Тем не менее в гиббсовой статистической механике применяется, хотя и неявно (Гиббс нигде не отдает себе в этом ясного отчета), разложение сложного события в бесконечную последовательность частных событий – первого, второго, третьего и т.д., – каждое из которых имеет известную вероятность; вероятность этого более широкого события находится затем как сумма вероятностей частных событий, образующих бесконечную последовательность. Таким образом, вероятности нельзя складывать во всех мыслимых случаях для получения полной вероятности, ибо сумма любого числа нулей равна нулю; но их можно складывать, коль скоро существует первый, второй, третий член и т. д., образующие последовательность событий, в которой каждый член имеет определенное место, задаваемое положительным целым числом.

Чтобы провести различие между этими двумя случаями, необходимы довольно тонкие изыскания о природе [c.101] множеств событий, а Гиббс был хотя и очень сильный, но не очень тонкий математик. Может ли класс быть бесконечным и в то же время существенно отличным по мощности от другого класса, например от класса натуральных чисел? Эту задачу решил в конце прошлого столетия Георг Кантор, и ответ был “да”. Если мы рассмотрим все десятичные дроби, конечные и бесконечные, лежащие между нулем и единицей, то, как известно, их нельзя расположить в порядке “один, два, три…”, хотя – удивительно – мы можем расположить так все конечные десятичные дроби. Поэтому проведение различия, требуемого в статистической механике Гиббса, не является само по себе невозможным. Услуга, оказанная Лебегом теории Гиббса, заключалась в доказательстве того, что неявные требования статистической механики относительно событий нулевой вероятности и сложения вероятностей событий действительно могут быть удовлетворены и что теория Гиббса не содержит противоречий.

Однако работа Лебега была непосредственно связана не с требованиями статистической механики, а с другой, как будто весьма далекой от нее, теорией – теорией тригонометрических рядов. Последняя восходит к физике XVIII в., изучавшей волны и колебания, и к спорному тогда вопросу об общности возможных движений линейной системы, полученных сложением ее простых колебаний, – колебаний, при которых течение времени лишь умножает отклонения системы от равновесия на положительный или отрицательный множитель, зависящий только от времени, но не от положения. Таким образом, одна функция выражается в виде суммы ряда. Коэффициенты этих рядов выражаются как средние произведения представляемой функции на данную весовую функцию. Вся теория основана на соотношениях между средним значением ряда и средними значениями отдельных членов. Заметим, что среднее значение величины, равной единице на интервале от нуля до А и нулю на интервале от А до 1, равно А и что его можно рассматривать как вероятность для случайной точки находиться в интервале от 0 до А, если известно, что она находится между 0 и 1. Иными словами, теория, необходимая для определения среднего значения ряда, очень близка к той, которая необходима для [c.102] адекватной трактовки вероятностей, выводимых из бесконечной последовательности случаев. Вот почему Лебег, решая свою задачу, решил также задачу Гиббса.

Распределения, исследуемые Гиббсом, сами допускают динамическую интерпретацию. Если мы рассматриваем консервативную динамическую систему весьма общего вида с N степенями свободы, то координаты положений и скоростей такой системы можно привести к особой системе 2 N координат, из которых N называются обобщенными координатами положения и N – обобщенными импульсами. Эти координаты определяют 2 N-мерное пространство 2 и в нем 2 N-мерный объем. Возьмем произвольную область этого пространства и заставим точки перемещаться с течением времени. Каждый набор 2 N координат перейдет тогда в новый набор, зависящий от истекшего времени, но непрерывное изменение границ области не изменит ее 2 N-мерного объема. В общем случае для множеств, не столь простых, понятие объема порождает систему меры лебегова типа. В этой системе меры и в консервативных динамических системах, преобразуемых так, что мера сохраняется постоянной, сохраняет постоянство и другая скалярная величина – энергия. Если все тела системы действуют только друг на друга и в системе нет сил, связанных с фиксированным положениями и фиксированными направлениями в пространстве, то остаются постоянными еще два выражения, оба векторные: количество движения и момент количества движения системы в целом. Их нетрудно исключить и тем самым заменить данную систему системой с меньшим числом степеней свободы.

В сугубо частных системах могут быть и другие величины, не определяемые энергией, количеством движения и моментом количества движения, также не меняющиеся с эволюцией системы. Известно, однако, что системы с другими инвариантными величинами, зависящими от начальных координат и импульсов динамической системы и достаточно регулярными, чтобы [c.103] допускать интегрирование на основе меры Лебега, в действительности очень редки, в некотором вполне точном смысле 3 . В системах, не имеющих других инвариантных величин, можно фиксировать координаты, соответствующие энергии, количеству движения и общему моменту количества движения, и тогда в пространстве остальных координат мера, определяемая координатами положении н импульсов, определит сама некоторую подмеру, подобно тому, как мера в трехмерном пространстве определит площадь на двумерной поверхности для заданного семейства двумерных поверхностей. Например, пусть мы имеем семейство концентрических сфер; объем между двумя сближаемыми концентрическими сферами (если его нормировать, приняв за единицу полный объем области между двумя сферами) в пределе даст меру площади на поверхности сферы.

Применим теперь эту новую меру к одной из областей фазового пространства, для которой определена энергия, общее количество движения и общий момент количества движения, и предположим, что в системе нет других измеримых инвариантных величин. Пусть полная мера этой ограниченной области постоянна; изменяя масштаб, се можно приравнять единице. Поскольку наша мера была получена из меры, инвариантной во времени, способом, инвариантным во времени, она и сама инвариантна. Мы назовем эту меру фазовой мерой, а средние по этой мере – фазовыми средними.

Но всякая величина, изменяющаяся во времени, может иметь также среднее значение по времени – временное среднее. Например, если f(t) зависит от t, то временное среднее для прошлого равно

,

(2.01)

а временное среднее для будущего

(2.02)

[c.104]

В гиббсовой статистической механике встречаются как временные, так и пространственные средние. Блестящей идеей Гиббса была попытка доказать, что эти средние в некотором смысле тождественны. Догадка Гиббса о связи двух типов средних совершенно правильна, но метод, которым он пытался доказать эту связь, был совершенно и безнадежно неверным. В этом его вряд ли можно винить. Интеграл Лебега стал известен в Америке лишь к моменту смерти Гиббса. В течение еще пятнадцати лет он был музейной редкостью и применялся только, чтобы продемонстрировать молодым математикам, до какой степени могут быть доведены требования математической строгости. Такой выдающийся математик, как У.Ф. Осгуд, не хотел его признать до конца своей жизни 4 . Лишь около 1930 г. группа математиков – Купмен, фон Нейман, Биркгофф 5 – установила наконец прочные основы статистической механики Гиббса. Каковы были эти основы, мы увидим дальше, когда познакомимся с эргоднческой теорией.

Сам Гиббс думал, что в системе, из которой удалены все инварианты – лишние координаты, почти все пути точек в фазовом пространстве проходят через все координаты такого пространства. Эту гипотезу он назвал эргодической, от греческих слов εργον – “работа” и οδόσ – “путь”. Но как показал Планшерель и другие, ни в одном реальном случае эта гипотеза не оправдывается. Никакая дифференцируемая траектория, даже бесконечной длины, не может покрыть целиком область на плоскости. Последователи Гиббса и, по-видимому, в конце концов сам Гиббс смутно поняли это и заменили свою гипотезу другой, квазиэргодической гипотезой, которая утверждает лишь, что с течением времени система в общем случае проходит неограниченно близко к каждой точке в области фазового пространства определенной известными интервалами. Логически такая гипотеза вполне приемлема, но она совершенно недостаточна для тех выводов, которые Гиббс основывает на ней. Она ничего не говорит об относительном времени пребывания системы в окрестности каждой точки. [c.105]

Помимо понятии среднего и меры (иначе говоря, среднего по всему пространству от функции, равной 1 на измеряемом множестве и 0 вне его), необходимых в первую очередь для разбора идей Гиббса, мы нуждаемся при оценке действительного значения эргодической теории в более точном анализе понятия инварианта, как и понятия группы преобразований. Эти понятия, несомненно, были известны Гиббсу, как показывают его работы по векторному анализу. Тем не менее можно утверждать, что он не оценил в полной мере их философского значения. Подобно своему современнику Хевисайду, Гиббс принадлежал к типу ученых, у которых физико-математическая проницательность часто опережает их логику и которые обыкновенно бывают правы, но часто не в состоянии объяснить, почему и как.

Для существования любой науки необходимо, чтобы существовали явления, которые не оставались бы изолированными. Если бы мир управлялся серией чудес, совершаемых иррациональным богом с его внезапными прихотями, то мы были бы вынуждены ждать каждой новой катастрофы в состоянии пассивного недоумения. Подобную картину мира встречаем мы в крокетной игре, описанной в “Алисе в стране чудес” 6 . В этой игре молотки – фламинго, шары – ежи, которые спокойно разворачиваются и идут по своим делам, ворота – карточные солдаты, точно так же способные совершать движения по собственной инициативе, а правила игры определяются декретами вспыльчивой королевы червей 7 , поведение которой невозможно предугадать.

Существо эффективного правила игры или полезного закона физики состоит в том, что правило можно установить заранее и применять во многих случаях. В идеале закон должен описывать свойство рассматриваемой системы, остающееся всегда тем же самым в потоке частных событий. В простейшем случае берется свойство, инвариантное относительно множества преобразований, которым подвергается система. Так мы приходим к [c.106] понятиям преобразования, группы преобразований и инварианта.

Преобразование системы есть изменение, при котором каждый элемент переходит в другой элемент. Изменение Солнечной системы в промежуток между моментами времени t1 и t2 есть преобразование координат планет. Аналогичное изменение их координат при перемещении нами начала координат при повороте наших геометрических осей также есть преобразование. Изменение масштаба, происходящее, когда мы наблюдаем препарат в микроскоп, – еще один пример преобразования”

Если за преобразованием А следует преобразование В, то в результате получается преобразование, называемое произведением, или результирующим преобразованием ВА. Заметим, что произведение, вообще говоря, зависит от порядка преобразований A и В. Например, если А – преобразование, переводящее координату х в координату у, а у – в х, оставляя z без изменений, и если В переводит х в z, а z – в х, оставляя у без изменений, то ВА будет переводить х в у, у – в z и z – в х, а АВ будет переводить х в z, у – в х и z – в у. Если АВ и ВА совпадают, то говорят, что А и В перестановочны.

Иногда, но не всегда, преобразование А не только переводит каждый элемент системы в элемент, но обладает еще тем свойством, что каждый элемент оказывается результатом преобразования одного из элементов. В этом случае существует такое единственное преобразование А–1, что каждое из произведений АА–1 и А–1A представляет собой особое, вырожденное преобразование, которое называется тождественным преобразованием I и преобразует каждый элемент в самого себя. В этом случае мы называем преобразование А–1 обратным к преобразованию А. Очевидно, что А обратно к А–1, что I обратно к самому себе и что обратное преобразование к АВ есть B–1A–1.

Существуют множества преобразований, в которых: 1) каждое преобразование, принадлежащее к данному множеству, имеет обратное преобразование, также принадлежащее к этому множеству, и 2) произведение любых двух преобразований, принадлежащих к данному множеству, само принадлежит к этому множеству. Такие множества носят название групп преобразований. [c.107] Множество всех сдвигов или по прямой, или в плоскости, или в трехмерном пространстве есть группа преобразований; более того, оно принадлежит к группам преобразований особого рода, называемым абелевыми группами 8 , где любые два преобразования перестановочны. Напротив, множество поворотов около точки и множество всех перемещений твердого тела в пространстве суть неабелевы группы.

Предположим теперь, что имеется какая-то величина, связанная со всеми элементами, преобразуемыми данной группой преобразований. Если эта величина не изменяется, когда каждый элемент изменяется одним и тем же преобразованием группы, каково бы ни было это преобразование, то она называется инвариантом группы. Существует много разновидностей таких инвариантов. Из них для наших целей особенно важны две.

Первая разновидность – так называемые линейные инварианты. Обозначим через х элементы, преобразуемые абслевой группой, и пусть f(x) – комплексная функция этих элементов, обладающая надлежащими свойствами непрерывности или интегрируемости. Тогда, если Тх – элемент, получаемый из х при преобразовании Т, a f(x) – функция с абсолютным значением 1, такая, что

f (Tx) = α(T) f(x),

(2.03)

где α(T) – число с абсолютным значением 1, зависящее только от Т, то f(x) мы будем называть характером группы.

Это инвариант группы в несколько обобщенном смысле. Ясно, что если f(x) и g(x) – характеры группы, то f(x)g(x) также есть характер группы, как и [f(x)] –1. Если какая-либо функция h(x), определенная на группе, представима линейной комбинацией характеров группы, скажем в виде

,

(2.04)

где fk(x) – характер группы, и если αk(T) находится в таком же отношении к fk(x), как α(T) – к f(x) в (2.03), то [c.108]

(2.05)

Таким образом, коль скоро h(x) допускает разложение по некоторому множеству характеров группы, то и h(Tx) при всех Т допускает такое разложение.

Мы видели, что характеры группы порождают другие характеры при умножении и обращении; нетрудно видеть также, что константа 1 есть характер. Следовательно, умножение на характер порождает группу преобразований самих характеров; последняя называется группой характеров исходной группы.

Если исходная группа есть группа сдвигов по бесконечной прямой, то оператор Т изменяет х в х+Т и соотношение (2.03) переходит в соотношение

,

(2.06)

которое выполняется при f(x)=eiλx, α(T)= eiλT. Характерами будут функции eiλx, а группой характеров будет группа сдвигов, изменяющая λ в λ+τ и, следовательно, имеющая такое же строение, как и исходная группа. Но дело будет обстоять иначе, если исходная группа состоит из поворотов по окружности. В этом случае оператор Т изменяет х в число, лежащее между 0 и 2π и отличающееся от х+Т на целочисленное кратное 2π. Соотношение (2.06) еще справедливо, но у нас появляется добавочное условие

.

(2.07)

Положив вновь f(x) = eiλx, получим

.

(2.08)

Это значит, что λ должно быть целым действительным числом – положительным, отрицательным или нулем. Следовательно, группа характеров здесь соответствует сдвигам целых действительных чисел. С другой стороны, если исходная группа есть группа сдвигов целых чисел, то х и Т в (2.06) могут принимать только целочисленные значения и функция eiλx задается полностью числом, лежащим между 0 и 2π и отличающимся от λ на целочисленное кратное 2π. Следовательно, группа характеров в этом случае по существу представляет собой группу поворотов по окружности.

В любой группе характеров числа α(T), соответствующие данному характеру f, распределены таким образом, [c.109] что эти распределение не нарушается при умножении их всех на α(S), каков бы ни был элемент S исходной группы. Иначе говоря, если есть какое-то разумное основание взять среднее от этих чисел, не затрагиваемое, когда группа преобразуется умножением каждого ее преобразования на одно фиксированное, то либо α(Т) тождественно равно 1, либо наше среднее инвариантно относительно умножения на числа, отличные от 1, и потому должно равняться 0. Отсюда можно заключить, что среднее произведение характера на величину, с ним сопряженную (которая также является характером), будет равно 1, а среднее произведение характера на величину, сопряженную с другим характером, будет равно 0. Другими словами, если h(x) представлено как в (2.04), то

(2.09)

Для группы поворотов по окружности это дает нам сразу, что если

(2.10)

то

(2.11)

Для сдвигов же по бесконечной прямой результат тесно связан с тем обстоятельством, что если в некотором подходящем смысле

(2.12)

то в определенном смысле

(2.13)

Эти результаты изложены здесь очень грубо, без точной формулировки условий их справедливости. Более строгое изложение теории читатель может найти в работе, указанной в примечании 9. [c.110]

Наряду с теорией линейных инвариантов группы, существует также общая ее метрических инвариантов. Последние представляют собой системы меры Лебега, не претерпевающие изменений, когда объекты, преобразуемые группой, переставляются операторами группы. В этой связи следует упомянуть интересную теорию групповой меры, которую дал Гаар 10 . Как мы видели, всякая группа сама есть собрание объектов, которые переставляются между собой при умножении на операторы данной группы. Поэтому она может иметь инвариантную меру. Гаар доказал, что некоторый довольно широкий класс групп имеет однозначно определенную инвариантную меру, задаваемую строением самой группы.

Наиболее важное применение теории метрических инвариантов группы преобразований состоит в обосновании взаимной заменимости фазовых и временных средних, которую, как мы видели выше, Гиббс тщетно пытался доказать. Это доказательство было выполнено на основе так называемой эргодической теории.

В обычных эргодических теоремах рассматривается ансамбль Е, меру которого можно принять за единицу, и этот ансамбль преобразуется в себя сохраняющим меру преобразованием Т или группой сохраняющих меру преобразований Т λ, где –∞<λ<∞ и

(2.14)

Эргодическая теория имеет дело с комплексным функциями f(х) элементов х из Е. Во всех случаях f(х) считается измеримой по х, а если мы рассматриваем непрерывную группу преобразований, то f(Тλх) считается измеримой по х и λ вместе.

В эргодической теореме Купмена – фон Неймана о сходимости в среднем функция f(х) считается принадлежащей к классу L2; это значит, что

(2.15)

Теорема утверждает, что [c.111]

(2.16)

или соответственно

(2.17)

сходится в среднем к пределу f*(х) при N→∞ или соответственно при А→∞ в том смысле, что

(2.18)

(2.19)

В эргодической теореме Биркгоффа о сходимости “почти всюду” функция f(х) считается принадлежащей к классу L; это значит, что

(2.20)

Функции fN(х) и fA(х) определяются, как в (2.16) и (2.17). Теорема утверждает 11 , что для всех значений х, за исключением множества нулевой меры, существуют пределы

(2.21)

и

(2.22)

Особенно интересен так называемый эргодический, или метрически транзитивный, случай, когда преобразование Т или множество преобразований Т λ не оставляет инвариантным ни одно множество точек х с мерой, отличной от 1 и 0. В таком случае множество значений (для обеих эргодических теорем), на которых f*(х) пробегает заданный интервал, почти всегда есть 1 или 0. Это возможно только при том условии, что [c.112] f*(х) почти всегда постоянна. Тогда f*(х) почти всегда равна

(2.23)

Таким образом, в теореме Купмена мы получаем предел в среднем 12

(2.24)

а в теореме Биркгоффа

(2.25)

за исключением множества значений х меры (или вероятности) 0. Аналогичные результаты имеют место в непрерывном случае. Это служит достаточным обоснованием производимой Гиббсом замены фазовых и временных средних.

Для случая, когда преобразование Т или группа преобразований Т λ не являются эргодическими, фон Нейман показал, что при очень общих условиях они могут быть сведены к эргодическим составляющим. Это значит, что, отбросив множество значений х нулевой меры, Е можно разбить на конечное или счетное множество классов Е n и континуум классоd Е(у), таких, что на каждом Е n и Е(у) устанавливается мера, инвариантная при Т и Т λ. Все эти преобразования эргодические, и если S(y) – пересечение множества S с Е(у), Sn – пересечение множества S с Е n, то

(2.26)

Другими словами, вся теория сохраняющих меру преобразований может быть сведена к теории эргодических преобразований.

Заметим мимоходом, что вся эргодическая теория применима и к более общим группам преобразований, [c.113] чем те, которые изоморфны с группой сдвигов по прямой. В частности, ее можно применить к группе сдвигов в п измерениях. Для физики важен случай трех измерений. Пространственным аналогом равновесия во времени служит пространственная однородность и такие теории, как теория однородного газа, жидкости или твердого тела основанные на применении трехмерной эргодической теории. Между прочим, примером неэргодической группы преобразований сдвига в трех изменениях может служить множество сдвигов смеси раздельных состояний, таких, что в данный момент существует то или другое состояние, но не их смесь.

Одним из кардинальных понятий статистической механики, получившим также применение в классической термодинамике, является понятие энтропии. Энтропия – это прежде всего свойство областей фазового пространства; она выражается логарифмом от их меры вероятности. Например, рассмотрим динамику п частиц, находящихся в сосуде, который разделен на две части: А и В. Если m частиц находится в А и п–m в В, то это характеризует некоторую область в фазовом пространстве, имеющую определенную меру вероятности. Логарифм этой меры есть энтропия распределения “m частиц в А, п–m в В”. Большую часть времени система будет пребывать в состоянии, близком к состоянию наибольшей энтропии, в том смысле, что если комбинация “m1 в А, п–m1 в В” имеет наибольшую вероятность, то большую часть времени примерно m1 частиц будет в А и примерно п– m1 в В. Для систем с большим числом частиц и состояниями, еще остающимися в пределах практической различимости, это значит, что если взять состояние с энтропией ниже максимальной и наблюдать, что произойдет, то энтропия почти всегда возрастает.

В обычных термодинамических задачах о тепловом двигателе мы имеем дело с условиями, когда в больших областях, скажем в цилиндре двигателя, существует грубое тепловое равновесие. Состояния, для которых мы исследуем энтропию, уже являются состояниями максимальной энтропии для данной температуры и объема, где речь идет о немногих областях фиксированных объемов и температуры. Даже при более тонких рассмотрениях тепловых двигателей, в частности двигателей [c.114] типа турбины, где газ расширяется гораздо более сложным образом, чем в цилиндре, эти условия не изменяются очень сильно. Мы все еще может говорить с весьма хорошим приближением о местных температурах, хотя температура определима точно лишь в состоянии равновесия и методами, предполагающими такое равновесие. Но в живом веществе мы уже не. можем предполагать даже этой грубой однородности. В строении белковой ткани, которое показывает электронный микроскоп, наблюдается чрезвычайная определенность и тонкость организации, и физиология такой ткани должна обладать соответственно тонкой организацией. Эта тонкость гораздо больше, чем у пространственно-временной шкалы обычного термометра, и потому температуры, измеряемые обычными термометрами в живых тканях, представляют грубые средние величины, а не истинные термодинамические температуры. Гиббсова статистическая механика может оказаться довольно адекватной моделью того, что происходит в живом теле; картина, подсказанная обычным тепловым двигателем, – заведомо нет. Тепловой коэффициент полезного действия мышц почти ничего не значит и, уж конечно, он не значит того, что он, казалось бы, должен значить.

Очень важное значение в статистической механике имеет идея максвеллова демона. Представим себе газ, в котором частицы движутся с распределением скоростей, остающимся в статистическом равновесии при данной температуре. Для идеального газа это будет распределение Максвелла. Пусть наш газ заключен в твердый сосуд с поперечной стенкой, снабженной небольшим отверстием; отверстие закрывается дверцей, приводимой в действие привратником – человекоподобным демоном или миниатюрным механизмом. Когда частица со скоростью выше средней подходит к дверце из отделения А или частица со скоростью ниже средней подходит к дверце из отделения В, привратник открывает дверцу и частица проходит через отверстие; когда же частица со скоростью ниже средней подходит из отделения А или частица со скоростью выше средней подходит из отделения В, дверца закрывается. Таким образом, частицы большей скорости сосредоточиваются в отделении В, а в отделении А их концентрация уменьшается. Это вызывает очевидное уменьшение энтропии, [c.115] и если соединить оба отделения тепловым двигателем, мы, как будто, получим вечный двигатель второго рода 13.

Легче отвергнуть вопрос, поставленный Максвеллом, чем ответить на него. Самое простое – отрицать возможность подобных существ или устройств. При строгом исследовании мы действительно найдем, что демоны Максвелла не могут существовать в равновесной системе, но если мы примем с самого начала эту невозможность и не будем пытаться доказать ее, то упустим прекрасный случай узнать кое-что об энтропии и о возможных физических, химических и биологических системах.

Чтобы демон Максвелла мог действовать, он должен получать от приближающихся частиц информацию об их скорости и точке удара о стенку. Независимо от того, связаны ли эти импульсы с переносом энергии или нет, они предполагают связь между демоном и газом. Но закон возрастания энтропии справедлив для полностью изолированной системы и неприменим к неизолириванной части такой системы. Поэтому мы должны рассматривать энтропию системы газ – демон, а не энтропию одного газа. Энтропия газа есть лишь компонент общей энтропии более широкой системы. Можно ли найти другие, связанные с демоном компоненты, входящие в общую энтропию?

Без малейшего сомнения, можно. Демон способен действовать лишь на основании принимаемой информации, а эта информация, как мы увидим в следующей главе, представляет собой отрицательную энтропию. Информация должна переноситься каким-то физическим процессом, например какой-то формой излучения. Можно вполне допустить, что эта информация переносится на очень низком энергетическом уровне и что перенос энергии от частицы к демону в течение продолжительного времени имеет гораздо меньшее значение, чем перенос информации. Но по законам квантовой механики [c.116] нельзя получить информацию о положении или импульсе частицы, а тем более о том и другом без воздействия на энергию исследуемой частицы, причем это воздействие должно превышать некоторый минимум, зависящий от частоты света, применяемого для исследования. Поэтому во всякой связи необходимо участвует энергия, и система, находящаяся в статистическом равновесии, должна находиться в равновесии как по отношению к энтропии, так и по отношению к энергии. В конечном счете максвеллов демон будет подвержен случайному движению, соответствующему температуре окружающей среды, и, как говорит Лейбниц о некоторых монадах, будет получать большое число малых впечатлений, пока не впадет в “головокружение” и не потеряет способность к ясным восприятиям. По существу, он перестанет действовать как максвеллов демон.

Тем не менее до того как демон собьется с толку, может пройти немалое время, и оно может оказаться столь продолжительным, что мы вправе называть активную фазу демона метастабильной. Нет оснований полагать, что метастабильные демоны в действительности не существуют; напротив, вполне возможно, что энзимы являются метастабильными максвелловыми демонами, которые уменьшают энтропию, пусть не разделением быстрых и медленных частиц, а каким-нибудь другим эквивалентным процессом. Мы вполне можем рассматривать живые организмы, как и самого Человека, в этом свете. Без сомнения, энзим и живой организм одинаково метастабильны: стабильное состояние энзима наступает, когда он перестает действовать, а стабильное состояние живого организма наступает с его смертью. Все катализаторы в конце концов отравляются, ибо они изменяют лишь скорости реакций, но не меняют истинного равновесия. Тем не менее и катализаторы, и человек имеют настолько определенные состояния метастабильности, что эти состояния можно считать относительно постоянными.

Я не хотел бы кончить эту главу, не сказав, что эргодическая теория – гораздо более обширный предмет, нежели здесь изложено. В некоторых новейших направлениях эргодической теории мера, остающаяся инвариантной при группе преобразований, определяется непосредственно самой группой, а не задается заранее. [c.117] В особенности я должен упомянуть работы Крылова и Боголюбова и некоторые работы Гуревича и японской школы.

Следующая глава посвящена статистической механике временных рядов. В этой области условия также очень далеки от условий, принимаемых статистической механикой для тепловых двигателей, и поэтому они весьма хорошо могут служить моделью того, что происходит в живых организмах. [c.118]

Далее:
III. ВРЕМЕННЫЕ РЯДЫ, ИНФОРМАЦИЯ И СВЯЗЬ

К оглавлению

ПРИМЕЧАНИЯ

1 В современной механике термин “импульс” (в отличие от “импульса силы”) означает то же, что и “количество движения”. Наш выбор следует наметившейся традиции русской литературы по динамическим системам. В оригинале Винер употребляет традиционный английский термин “momentum”. – Прим. ред.
Вернуться к тексту

2 Это пространство называется фазовым пространством системы: его точки изображают различные фазы, или состояния, системы. Термин “фазовое пространство” появляется у Винера несколько ниже без пояснения – Прим. ред.
Вернуться к тексту

3 Oxtoby J.С., Ulam S.M. Measure – Preserving Homeomorphisms and Metrical Transitivity. // Ann. of Math. – Ser. 2. – 1941. – Vol. 42. – P. 874–920.
Вернуться к тексту

4 Тем не менее некоторые из ранних работ Осгуда представляют важный шаг в направлении к интегралу Лебега.
 Вернуться к тексту

5 Норf E. Ergodcntheorie. // Ergeb. Math. – 1937. – B. 5. – № 2, Springer, Berlin.
 Вернуться к тексту

6 Известная сказка английского писателя Льюиса Кэрролла (Ч.Л. Доджсона, 1832–1898), неоднократно издававшаяся в русском переводе. – Прим. ред.
Вернуться к тексту

7 Читатель, не ошибись в истолковании титула! Это, конечно, фигура с игральной карты – червонная дама, если быть очень точным. Мы, однако, следуем за русским переводом сказки. – Прим-ред.
Вернуться к тексту

8 По имени норвежского математика Нильса Абеля (1802–1829). – Прим. ред.
 Вернуться к тексту

9 Wiener N. The Fourier Integral and Certain of Its Applications. – Cambridge, England: the University Press; N.Y.: Dover Publications, Inc., 1933 (русский перевод: Винер Н. Интеграл Фурье и некоторые его применения. – М.: Физматгиз, 1963). – Прим. ред.
Вернуться к тексту

10 Haar H. Der Maβbegriff in der Theorie der Kontinuierlichen Gruppen. // Ann. of Math. – Ser. 2. – 1933. – Vol. 34. – P. 147–169.
Вернуться к тексту

11 См. также: Винер Н. Теория предсказания. // Современная математика для инженеров. / Под ред. Э.Ф. Беккенбаха. – М.: ИЛ, 1959. С. 185–215. – Прим. ред.
Вернуться к тексту

12 l.i.m. (the limit in the mean) – применяемое Винером обозначение предела в среднем (употребляется и в русском переводе его “Интеграла Фурье”) – Прим. ред.
 Вернуться к тексту

13 Идея такого существа, нарушающего второй закон термодинамики, изложена Максвеллом в 1871 г. в его “Теории теплоты” (Maxwell S.С. Theory of Heat. – London: Longmans, Green, and Co., 1871. Chap. XXII. Р. 308–309; русское издание: Максуэлль К. Теория теплоты в элементарной обработке. / Пер. с 7-го англ. издания. – Киев: Типография И.Н. Кушнерева и Ко, 1888. Гл. XXII. С. 288–289). – Прим. ред.


III

Винер Н. Кибернетика, или управление и связь в животном и машине. – 2-е издание. – М.: Наука; Главная редакция изданий для зарубежных стран, 1983. – 344 с.

Красным шрифтом в квадратных скобках обозначается конец текста на соответствующей странице печатного оригинала данного издания

III. ВРЕМЕННЫЕ РЯДЫ, ИНФОРМАЦИЯ И СВЯЗЬ

Существует широкий класс явлений, в которых объектом наблюдения служит какая-либо числовая величина или последовательность числовых величин, распределенные во времени. Температура, непрерывно записываемая самопишущим термометром; курс акций на бирже в конце каждого дня; сводка метеорологических данных, ежедневно публикуемая бюро погоды, – все это временные ряды, непрерывные или дискретные, одномерные или многомерные. Эти временные ряды меняются сравнительно медленно, и их вполне можно обрабатывать посредством вычислений вручную или при помощи обыкновенных вычислительных приборов, таких, как счетные линейки и арифмометры. Их изучение относится к обычным разделам статистической науки.

Но не все отдают себе отчет в том, что быстро меняющиеся последовательности напряжений в телефонной линии, телевизионной схеме или радиолокаторе точно так же относятся к области статистики и временных рядов, хотя приборы, которые их комбинируют и преобразуют, должны, вообще говоря, обладать большим быстродействием и, более того, должны выдавать результаты одновременно с очень быстрыми изменениями входного сигнала. Эти приборы: телефонные аппараты, волновые фильтры, автоматические звукокодирующие устройства типа вокодера1 Белловских телефонных лабораторий, схемы частотной модуляции и соответствующие им приемники – по существу [c.119] представляют собой быстродействующие арифметические устройства, соответствующие всему собранию вычислительных машин и программ статистического бюро, вместе со штатом вычислителей. Необходимый для их применения разум был вложен в них заранее, так же как и в автоматические дальномеры и системы управления артиллерийским зенитным огнем и по той же причине: цепочка операций должна выполняться настолько быстро, что ни в одном звене нельзя допустить участия человека.

Все эти временные ряды и все устройства, работающие с ними, будь то в вычислительном бюро или в телефонной схеме, связаны с записью, хранением, передачей и использованием информации. Что же представляет собой эта информация и как она измеряется? Одной из простейших, наиболее элементарных форм информации является запись выбора между двумя равновероятными простыми альтернативами, например между гербом и решеткой при бросании монеты. Мы будем называть решением однократный выбор такого рода. Чтобы оценить теперь количество информации, получаемое при совершенно точном измерении величины, которая заключена между известными пределами А и В и может находиться с равномерной априорной вероятностью где угодно в этом интервале, положим А=0, В=1 и представим нашу величину в двоичной системе бесконечной двоичной дробью 0, а1, а2, а3, …, an, …, где каждое а1, а2, … имеет значение 0 или 1. Здесь

(3.01)

Мы видим, что число сделанных выборов и вытекающее отсюда количество информации бесконечны.

Однако в действительности никакое измерение не производится совершенно точно. Если измерение имеет равномерно распределенную ошибку, лежащую в интервале длины 0, b1, b2, …, bn, …, где bk – первый разряд, отличный от 0, то, очевидно, все решения от а1 до аk–1 и, возможно, до ak будут значащими, а все последующие – нет. Число принятых решений, очевидно, близко к

(3.02)

[c.120]

и это выражение мы примем за точную формулу количества информации и за его определение.

Это выражение можно понимать следующим образом: мы знаем априори, что некоторая переменная лежит между нулем и единицей, и знаем апостериори, что она лежит в интервале (а, b) внутри интервала (0, 1). Тогда количество информации, извлекаемой нами из апостериорного знания, равно

(3.03)

Рассмотрим теперь случай, когда мы знаем априори, что вероятность нахождения некоторой величины между х и x+dx равна f1(x)dx, а апостериорная вероятность этого равна f2(x)dx. Сколько новой информации дает нам наша апостериорная вероятность?

Эта задача, но существу, состоит в определении ширины областей, расположенных под кривыми y=f1(x) и у=f2(x). Заметим, что, по нашему допущению, переменная х имеет основное равномерное распределение, т.е. наши результаты, вообще говоря, будут другими, если мы заменим х на х3 или на какую-либо другую функцию от х. Так как f1(x) есть плотность вероятности, то

(3.04)

Поэтому средний логарифм ширины области, расположенной под кривой f1(x), можно принять за некоторое среднее значение высоты логарифма обратной величины функции f1(x). Таким образом, разумной мерой2 количества информации, связанного с кривой f1(x), может служить 3 [c.121]

(3.05)

Величина, которую мы здесь определяем как количество информации, противоположна по знаку величине, которую в аналогичных ситуациях обычно определяют как энтропию. Данное здесь определение не совпадает с определением Р.А. Фишера для статистических задач, хотя оно также является статистическим определением и может применяться в методах статистики вместо определения Фишера.

В частности, если f1(x) постоянна на интервале (а, b) и равна нулю вне этого интервала, то

(3.06)

Используя это выражение для сравнения информации о том, что некоторая точка находится в интервале (0, 1), с информацией о том, что она находится в интервале (а, b), получим как меру разности

(3.07)

Определение, данное нами для количества информации, пригодно также в том случае, когда вместо переменной х берется переменная, изменяющаяся в двух или более измерениях. В двумерном случае f1 (x, y) есть такая функция, что

(3.08)

и количество информации равно

(3.081)

Заметим, что если f1(x, y) имеет вид φ(х)ψ(у) и

,

(3.082)

[c.122]

то

(3.083)

и

(3.084)

т.е. количество информации от независимых источников есть величина аддитивная.

Интересной задачей является определение информации, получаемой при фиксации одной или нескольких переменных в какой-либо задаче. Например, положим, что переменная и заключена между х и x+dx с вероятностью

,

а переменная v заключена между теми же двумя пределами с вероятностью

Сколько мы приобретаем информации об и, если знаем, что u+v=w? В этом случае очевидно, что u=w—v, где w фиксировано. Мы полагаем, что априорные распределения переменных и и v независимы, тогда апостериорное распределение переменной и пропорционально величине

,

(3.09)

где c1 и c2 — константы. Обе они исчезают в окончательной формуле.

Приращение информации об и, когда мы знаем, что w таково, каким мы его задали заранее, равно

[c.123]

(3.091)

Заметим, что выражение (3.091) положительно и не зависит от w. Оно равно половине логарифма от отношения суммы средних квадратов переменных и и v к среднему квадрату переменной v. Если v имеет лишь малую область изменения, то количество информации об и, которое дается знанием суммы u+v, велико и становится бесконечным, когда b приближается к нулю.

Мы можем истолковать этот результат следующим образом. Будем рассматривать и как сообщение, а v – как помеху. Тогда информация, переносимая точным сообщением в отсутствие помехи, бесконечна. Напротив, при наличии помехи это количество информации конечно и быстро приближается к нулю по мере увеличения силы помехи.

Мы сказали, что количество информации, будучи отрицательным логарифмом величины, которую можно рассматривать как вероятность, по существу есть некоторая отрицательная энтропия. Интересно отметить, что эта величина в среднем имеет свойства, которые мы приписываем энтропии.

Пусть φ(х) и ψ(x) – две плотности вероятностей, тогда

также есть плотность вероятности и

(3.10)

Это вытекает из того, что

(3.11)

Другими словами, перекрытие областей под φ(х) и ψ(x) уменьшает максимальную информацию, заключенную в сумме φ(х)+ψ(x). Если же φ(х) есть плотность [c.124] вероятности, обращающаяся в нуль вне (а, b), то интеграл

(3.12)

имеет наименьшее значение, когда [image] на интервале (а, b) и φ(х)=0 вне этого интервала. Это вытекает из того, что логарифмическая кривая выпукла вверх.

Как и следовало ожидать, процессы, ведущие к потере информации, весьма сходны с процессами, ведущими к росту энтропии. Они состоят в слиянии областей вероятностей, первоначально различных. Например, если мы заменяем распределение некоторой переменной распределением функции от нее, принимающей одинаковые значения при разных значениях аргумента, или в случае функции нескольких переменных позволяем некоторым из них свободно пробегать их естественную область изменения, мы теряем информацию. Никакая операция над сообщением не может в среднем увеличить информацию. Здесь мы имеем точное применение второго закона термодинамики к технике связи. Обратно, уточнение в среднем неопределенной ситуации приводит, как мы видели, большей частью к увеличению информации и никогда – к ее потере.

Интересен случай, когда мы имеем распределение вероятностей с n-мерной плотностью f(х1, …, xn) по переменным (х1, …, xn) и m зависимых переменных y1, …, ym. Сколько информации мы приобретаем при фиксации таких т переменных? Пусть они сперва фиксируются между пределами y1*, y1*+dy1*, …, ym*, ym*+dym*. Примем х1, x2, …, xn–m, у1, y2, ..., ут за новую систему переменных. Тогда для новой системы переменных наша функция распределения будет пропорциональна f1(х1, …, xn) над областью R, определенной условиями

и равна нулю вне ее. Следовательно, количество информации, полученной при наложении условий на значения у, будет равно 4 [c.125]

(3.13)

С этой задачей тесно связано обобщение задачи, о которой говорилось по поводу уравнения (3.091). Сколько информации в рассматриваемом случае приобретается нами об одних только переменных х1, ..., xn–m? Здесь априорная плотность вероятности этих переменных равна

,

(3.14)

а ненормированная плотность вероятности после фиксации величин у* будет

(3.141)

где Σ берется по всем множествам значений (xn–m+1, …, xn), соответствующим данному множеству значений у*. Основываясь на этом, нетрудно записать решение нашей задачи, хотя оно и будет несколько громоздким. Если мы примем множество (x1, …, xn–m) за обобщенное сообщение, множество (xn–m+1, …, xn) – за [c.126] обобщенный шум. а величины у* – за обобщенное искаженное сообщение, то получим, очевидно, решение обобщенной задачи выражения (3.091).

Таким образом, мы имеем по крайней мере формальное решение обобщения упомянутой уже задачи о сигнале и шуме. Некоторое множество наблюдений зависит произвольным образом от некоторого множества сообщений и шумов с известным совместным распределением. Мы хотим установить, сколько информации об одних только сообщениях дают эти наблюдения. Это центральная проблема техники связи. Решение ее позволит нам оценивать различные системы связи, например системы с амплитудной, частотной или фазовой модуляцией, в отношении их эффективности в передаче информации. Это техническая задача, не подлежащая здесь подробному обсуждению; уместно, однако, сделать некоторые замечания.

Во-первых, можно показать, что если пользоваться данным здесь определением информации, то при случайных помехах в эфире с равномерно распределенной по частоте мощностью и для сообщения, ограниченного определенным диапазоном частот и определенной отдачей мощности на этом диапазоне, не существует более эффективного способа передачи информации, чем амплитудная модуляция, хотя другие способы могут быть столь же эффективны. Во-вторых, переданная этим способом информация не обязательно имеет такую форму, которая наиболее приемлема для слуха или для другого данного рецептора. В этом случае специфические свойства уха и других рецепторов должны быть учтены при помощи теории, весьма сходной с только что изложенной. Вообще эффективное использование амплитудной модуляции или какого-либо другого вида модуляции должно быть дополнено применением соответствующих декодирующих устройств для преобразования принятой информации в такую форму, которая может быть хорошо воспринята рецепторами человека или же механическими рецепторами. Первоначальное сообщение тоже должно кодироваться, чтобы оно занимало возможно меньше места при передаче. Эта задача была разрешена, по крайней мере частично, когда Белловские телефонные лаборатории разработали систему “вокодер”, а д-р К. Шеннон из этих лабораторий [c.127] представил в весьма удовлетворительном виде соответствующую общую теорию. Так обстоит дело с определением и методикой измерения информации. Теперь рассмотрим, каким способом информация может быть представлена в однородной во времени форме. Заметим, что большинство телефонных устройств и других приборов связи в действительности не предполагает определенного начала отсчета во времени. В самом деле, только одна операция как будто противоречит этому, но и здесь противоречие лишь кажущееся. Мы имеем в виду модуляцию. В ее наиболее простом виде она состоит в преобразовании сообщения f(t) в сообщение вида f(t)sin(at+b). Однако, если мы будет рассматривать множитель sin(at+b) как добавочное сообщение, вводимое в аппаратуру, то, очевидно, случай модуляции подойдет под наше общее утверждение. Добавочное сообщение, которое мы называем переносчиком, ничего не прибавляет к скорости передачи информации системой. Вся содержащаяся в нем информация посылается в произвольно короткий промежуток времени, и затем больше ничего нового не передается.

Итак, сообщение, однородное во времени, или, как выражаются профессионалы-статистики, временной ряд, находящийся в статистическом равновесии, есть функция или множество функций времени, входящее в ансамбль таких множеств с правильным распределением вероятностей, не изменяющимся, если всюду заменить t на t+τ. Иначе говоря, вероятность ансамбля инвариантна относительно группы преобразований, состоящей из операторов Tλ которые изменяют f(t) в f(t+λ). Группа удовлетворяет условию

(3.15)

Следовательно, если Ф[f(t)] – “функционал” от f(t), т.е. число, зависящее от всей истории функции f(t), и среднее значение f(t) по всему ансамблю конечно, то мы вправе применить эргодическую теорему Биркгоффа из предыдущей главы и заключить, что всюду, исключая множество значений f(t) нулевой вероятности, существует временное среднее от Ф[f(t)], или в символах

(3.16)

[c.128]

Но это еще не все. В предыдущей главе проводилась другая теорема эргодического характера, доказанная фон Нейманом: коль скоро некоторая система переходит в себя при данной группе сохраняющих меру преобразований, как в случае нашего уравнения (3.15), то, за исключением множества элементов нулевой вероятности, каждый элемент системы входит в подмножество (быть может, равное всему множеству), которое: 1) переходит в себя при тех же преобразованиях; 2) имеет меру, определенную на нем самом и также инвариантную при этих преобразованиях; 3) замечательно тем, что любая часть этого подмножества с мерой, сохраняемой данной группой преобразований, имеет либо максимальную меру всего подмножества, либо меру 0. Отбросив все элементы, не принадлежащие к такому подмножеству, и используя для него надлежащую меру, мы найдем, что временное среднее (3.16) почти во всех случаях равно среднему значению функционала Ф[f(t)] по всему пространству функций f(t), т.е. так называемому фазовому среднему. Стало быть, в случае такого ансамбля функции f(t), за исключением множества случаев нулевой вероятности, мы можем найти среднее значение любого статистического параметра ансамбля по записи любого временного ряда ансамбля, применяя временное среднее вместо фазового. Более того, этим путем можно найти одновременно любое счетное множество таких параметров ансамбля, и нам нужно знать лишь прошлое одного, почти какого угодно временного ряда ансамбля. Другими словами, если дана вся прошлая история – вплоть до настоящего момента – временного ряда, принадлежащего к ансамблю в статистическом равновесии, то мы можем вычислить с вероятной ошибкой, равной нулю, все множество статистических параметров ансамбля, к которому принадлежит ряд. До сих пор мы установили это для отдельного временного ряда, но сказанное справедливо также для многомерных временных рядов, где вместо одной изменяющейся величины мы имеем несколько одновременно изменяющихся величин.

Теперь мы можем рассмотреть различные задачи, относящиеся к временным рядам. Ограничимся случаями, в которых все прошлое временного ряда может быть задано счетным множеством величин. Например, для [c.129] довольно широкого класса функций f(t) (–∞ < t < ∞) функция f(t) полностью определена, если известно множество величин

,
(n=0, 1, 2, …)

(3.17)

Пусть теперь А – некоторая функция от будущих значений t, т.е. от значений аргумента, больших нуля. Тогда мы можем определить совместное распределение величин (a0, a1, ..., аn, A) из прошлого одного, почти любого временного ряда, если множество функций f берется в самом узком возможном смысле. В частности, если даны все a0, ..., аn, то мы можем найти распределение функции А. Здесь мы прибегаем к известной теореме Никодима об условных вероятностях. Та же теорема гарантирует нам, что это распределение при весьма общих условиях стремится к пределу, когда п→∞, и этот предел даст нам полные сведения относительно распределения любой будущей величины. Мы можем таким же образом определить по известному прошлому совместное распределение значений любого множества будущих величин или любого множества величин, зависящих от прошлого и от будущего. Если теперь нам дана некоторая подходящая интерпретация “наилучшего значения” статистического параметра или множества статистических параметров – например, в смысле математического ожидания, или медианы, или моды, – то мы можем вычислить это значение из известного распределения и получить предсказание, удовлетворяющее любому желательному критерию надежности предсказания. Мы можем численно оценить качество предсказания, применяя какой угодно статистический показатель качества: среднеквадратическую ошибку, максимальную ошибку, среднюю абсолютную ошибку и т.д. Мы можем вычислить количество информации о любом статистическом параметре или множестве статистических параметров, которое дает нам фиксация прошлого. Можно даже вычислить количество информации о всем будущем после определенного момента, даваемое нам знанием прошлого. Правда, если этот момент – настоящее, то, вообще говоря, мы будем знать о нем из прошлого, и наше знание настоящего будет содержать бесконечно много информации. [c.130]

Другой интересной проблемой является проблема многомерных временных рядов, в которых мы точно знаем лишь прошлое нескольких составляющих. Распределение величины, зависящей от более богатого прошлого, может изучаться методами, весьма близкими к уже рассмотренным. В частности, нам может понадобиться узнать распределение значений другой составляющей или множества значений других составляющих в некоторый момент прошлого, настоящего или будущего. К этому классу относится и общая задача о волновом фильтре. Даны сообщение и шум, скомбинированные некоторым образом в искаженное сообщение, прошлое которого нам известно. Нам известно также статистическое совместное распределение сообщения и шума как временных рядов. Мы ищем распределение значений сообщения в данный момент прошлого, настоящего или будущего. Затем мы разыскиваем оператор, который, будучи применен к прошлому искаженного сообщения, восстановит истинное сообщение наилучшим образом, в данном статистическом смысле. Мы можем также искать статистическую оценку какой-либо меры ошибок в нашем знании сообщения. Наконец, мы можем искать количество информации, которым располагаем в сообщении.

Особенно простым и важным является ансамбль временных рядов, связанный с броуновым движением. Броуновым движением называется движение частицы газа, толкаемой случайными ударами других частиц под действием теплового возбуждения. Теория его была разработана многими исследователями, в частности Эйнштейном, Смолуховским, Перреном и автором5. Если только мы не спускаемся по шкале времени до столь малых промежутков, что становятся различимыми отдельные удары частиц по данной частице, броуново движение обнаруживает любопытное явление недифференцируемости. Средний квадрат перемещения частицы в данном направлении за данный промежуток времени пропорционален длине этого промежутка, а перемещения за [c.131] последовательные промежутки времени совершенно не коррелируются между собой. Это вполне согласуется с физическими наблюдениями. Если мы нормируем шкалу броунова движения соответственно шкале времени и будем рассматривать только одну координату х, положив x(t)=0 для t=0, то вероятность того, что при 0≤t1≤t2…≤tn частицы находятся между х1 и x1+dx1 в момент t1 между х2 и x2+dx2 в момент t2, ..., между xп и xп+dхп в момент tn равна

.

(3.18)

Исходя из создаваемой этим системы вероятностей, вполне однозначной, мы можем ввести на множестве путей, соответствующих различным возможным броуновым перемещениям, такой параметр α, лежащий между 0 и 1, что: 1) каждый путь будет функцией x(t,α), где х зависит от времени t и параметра распределения α и 2) вероятность данному пути находиться в данном множестве S будет равна мере множества значений α, соответствующих путях, находящимся в S. Поэтому почти все пути будут непрерывными и недифференцируемыми.

Весьма интересен вопрос об определении среднего значения произведения x(t, α), …, x(tn, α) относительно α. Это среднее равно

(3.19)

при условии 0 ≤t1 ≤…≤ tn. Положим

(3.20)

[c.132]

где λk,1+λk,2+…+λk,n=n.Тогда выражение (3.19) примет значение

.

(3.21)

Здесь первая сумма берется по j; вторая – по всем способам разбиения п элементов на пары в группах, включающих соответственно λk,1, …, λk,n элементов; произведение – по парам значений k и q, где λk,1 элементов среди выбранных tk и tq равны t1, λk,2 элементов равны t2 и т.д. Отсюда сразу же следует

(3.22)

[c.133]

где сумма берется по всем разбиениям величин t1, ..., tn на различные пары, произведение – по всем парам в каждом разбиении. Другими словами, если нам известны средние значения попарных произведений величин x(tj, α), то нам известны и средние значения всех многочленов от этих величин и, следовательно, их полное статистическое распределение.

До сих пор мы рассматривали броуновы перемещения x (tj,α), в которых t положительно. Положив

,

(3.23)

где α и β имеют независимые равномерные распределения в интервале (0, 1), получим распределение для ξ(t, α, β), где t пробегает всю бесконечную действительную ось. Существует хорошо известный математический прием отобразить квадрат на прямолинейный отрезок таким образом, что площадь преобразуется в длину. Надо лишь записать координаты квадрата в десятичной форме

(3.24)

и положить

,

и мы получим искомое отображение, являющееся взаимно однозначным почти для всех точек как прямолинейного отрезка, так и квадрата. Используя эту подстановку, введем

.

(3.25)

Теперь мы хотим определить в некотором подходящем смысле

(3.26)

Сразу приходит мысль определить указанное выражение как интеграл Стильтьеса6, но это встречает [c.134] препятствие в том, что ξ представляет собой весьма нерегулярную функцию от t. Однако если К приближается достаточно быстро к нулю при t→± ∞ и является достаточно гладкой функцией, то разумно положить

(3.27)

При этих условиях мы формально получим

(3.28)

Если теперь t и s имеют противоположные знаки, то

(3.29)

а если они одного знака и |s|<|t|, то

(3.30)

[c.135]

Отсюда

(3.31)

В частности,

(3.32)

Более того,

(3.33)

[c.136]

где сумма берется по всем разбиениям величин τ1, …, τn на пары, а произведение – по парам в каждом разбиении. Выражение

(3.34)

изображает очень важный ансамбль временных рядов по переменной t, зависящих от некоторого параметра распределения γ. Доказанное нами равносильно утверждению, что все моменты и, следовательно, все статистические параметры этого распределения зависят от функции

(3.35)

представляющей собой известную в статистике автокорреляционную функцию со сдвигом τ. Таким образом, распределение функции f(t, γ) имеет те же статистики, что и функция f(t+t1, γ); и действительно, можно доказать, что если

,

(3.36)

то преобразование параметра γ в Г сохраняет меру. Другими словами, наш временной ряд f(t, γ) находится в статистическом равновесии.

Далее, если мы рассмотрим среднее значение для

(3.37)

то оно состоит в точности из членов выражения

(3.38)

[c.137]

и из конечного числа членов, имеющих множителями степени выражения

,

(3.39)

если последнее стремится к нулю при σ→∞, то (3.38) будет пределом выражения (3.37). Другими словами, распределения функций f(t, γ) и f(t+σ, γ) становятся асимптотически независимыми, когда σ→∞. Более общим, но совершенно аналогичным рассуждением можно показать, что одновременное распределение функций f(t1, γ), ..., f(tn, γ) и функций f(σ+s1, γ), …, f(σ+sm, γ) стремится к совместному распределению первого и второго множества, когда σ→∞. Другими словами, если F[f (t, γ)] – любой ограниченный измеримый функционал, т.е. величина, зависящая от всего распределения значений функции f(t, γ) от t, то для него должно выполняться условие

.

(3.40)

Если F[f (t, γ)] инвариантен при сдвиге по t и принимает только значения 0 или 1, то

,

(3.41)

т.е. группа преобразований f(t, γ) в f(t+σ, γ) метрически транзитивна. Отсюда следует, что если F[f (t, γ)] – любой интегрируемый функционал от f как функции от t, то по эргодической теореме

(3.42)

[c.138]

для всех значений γ, исключая множество нулевой меры. Таким образом, мы почти всегда можем определить любой статистический параметр такого временного ряда (и даже любого счетного множества статистических параметров) из прошлой истории одного только параметра. В самом деле, если для такого временного ряда мы знаем

(3.43)

то мы знаем Ф(t) почти во всех случаях и располагаем полным статистическим знанием о временном ряде.

Некоторые величины, зависящие от временного ряда такого рода, обладают интересными свойствами. В частности, интересно знать среднее значение величины

(3.44)

Формально мы можем записать его в виде

.

(3.45)

Весьма интересная задача – попытаться построить возможно более общий временной ряд из простых рядов броунова движения. При таких построениях, как подсказывает пример рядов Фурье, разложения типа (3.44) составляют удобные строительные блоки. В частности, исследуем временные ряды специального вида:

(3.46)

[c.139]

Предположим, что нам известна функция ξ(τ, γ), а также выражение (3.46). Тогда при t1>t2 находим, как в (3.45),

(3.47)

Умножив на

и положив s(t2–t1)=iσ, получим при t2→t1

(3.48)

Примем K(t1, λ) за новую независимую переменную μ и, решая относительно λ, получим

(3.49)

Тогда выражение (3.48) будет иметь вид

(3.50)

Отсюда преобразованием Фурье можно найти

(3.51)

как функцию от μ, коль скоро μ лежит между K(t1, a) и K(t1, b). Интегрируя эту функцию по μ, найдем

(3.52)

[c.140]

как функцию от K(t1, λ) и t1. Иначе говоря, существует известная функция F (u, v), такая, что

(3.53)

Поскольку левая часть этого равенства не зависит от t1, мы можем обозначить ее через G(λ) и положить

(3.54)

Здесь F – известная функция, и ее можно обратить относительно первого аргумента, положив

,

(3.55)

где H – также известная функция. Отсюда

(3.56)

Тогда выражение

(3.57)

будет известной функцией и

(3.58)

откуда

,

(3.59)

или

.

(3.60)

Входящую в это выражение константу можно определить из соотношения

,

(3.61)

или

.

(3.62)

Очевидно, что если а конечно, то безразлично, какое значение мы ему дадим; в самом деле, наш оператор не [c.141] изменится от прибавления одной и той же величины ко всем значениям λ. Поэтому можно взять а=0. Таким образом, мы определили λ как функцию от G и, следовательно, G – как функцию от λ. Из (3.55) следует, что мы тем самым определили K(t, λ). Для завершения расчетов нам нужно только найти b. Это число можно определить сравнением выражений

(3.63)

и

.

(3.64)

Таким образом, если при некоторых условиях, которые еще остается точно сформулировать, временной ряд допускает запись в виде (3.46) и известна функция ξ(t, γ) то мы можем определить функцию K(t, λ) в (3.46) и числа а и b с точностью до неопределенной константы, прибавляемой к а, λ и b. Не возникает особых трудностей при b→+∞, также не слишком сложно распространить эти рассуждения на случай а→ –∞. Конечно, предстоит проделать еще немалую работу, рассматривая задачу обращения функций в случае, когда результаты не однозначны, и общие условия справедливости соответствующих разложений. Тем не менее мы по крайней мере сделали первый шаг к решению задачи приведения обширного класса временных рядов к каноническому виду, что чрезвычайно важно для конкретного формального применения теорий предсказания и измерения информации, намеченных выше в этой главе.

Имеется, однако, одно очевидное ограничение, которое мы должны устранить из этого наброска теории временных рядов, а именно необходимость знать ξ(t, γ), и временной ряд, который мы разлагаем в виде (3.46). Вопрос ставится так: при каких условиях временной ряд с известными статистическими параметрами можно представить как ряд, определяемый броуновым движением, или по крайней мере как предел (в том или ином смысле) временных рядов, определяемых броуновым движением? Мы ограничимся временными рядами, [c.142] обладающими свойством метрической транзитивности и даже следующим более сильным свойством: если брать интервалы времени фиксированной длины, но отдаленные друг от друга, то распределения любых функционалов от отрезков временного ряда в этих интервалах приближаются к независимости по мере того, как интервалы отдаляются друг от друга7. Соответствующая теория уже излагалась автором.

Если K(t) – достаточно непрерывная функция, то можно показать, что нули величины

(3.65)

по теореме М. Каца, почти всегда имеют определенную плотность и что эта плотность при подходящем выборе К может быть сделана сколь угодно большой. Пусть выбрано такое КD, что плотность равна D. Последовательность нулей величины

,

от –∞ до ∞ обозначим через Zn(D, γ), –∞<n<–∞. Конечно, при нумерации этих нулей индекс п определяется лишь с точностью до аддитивной целочисленной константы.

Пусть теперь T(t, μ) – произвольный временной ряд от непрерывной переменной t, а μ – параметр распределения временных рядов, изменяющийся равномерно в интервале (0, 1). Пусть далее

,

(3.66)

где Zn – нуль, непосредственно предшествующий моменту t. Можно показать, что, каково бы почти ни было μ, для любого конечного множества значений t1, t2, …, tv переменной х одновременное распределение величин TD(tk, μ, γ) (k=1, 2, ..., v) при D→∞ будет приближаться к одновременному распределению величин T(tk, μ) для тех же tk при D→∞. Но TD(tk, μ, γ) полностью определяется величинами tk, μ, D. Поэтому вполне уместно попытаться выразить TD(tk, μ, γ) [c.143] для данного D и данного μ, либо прямо в виде (3.46), либо некоторым образом в виде временного ряда, распределение которого является пределом (в указанном свободном смысле) распределении этого типа.

Следует признать, что все это изображает скорее программу на будущее, чем уже выполненную работу. Тем не менее эта программа, по мнению автора, дает наилучшую основу для рационального, последовательного рассмотрения многих задач в области нелинейного предсказания, нелинейной фильтрации, оценки передачи информации в нелинейных системах и теории плотного газа и турбулентности. К ним принадлежат, быть может, самые острые задачи, стоящие перед техникой связи.

Перейдем теперь к задаче предсказания для временных рядов вида (3.34). Мы замечаем, что единственным независимым статистическим параметром такого временного ряда является функция Ф(t), определенная формулой (3.35). Это значит, что единственной значащей величиной, связанной с K(t), является

(3.67)

Конечно, здесь К – величина действительная.

Применяя преобразование Фурье, положим

.

(3.68)

Если известно K(s), то известно k(ω), и обратно. Тогда

(3.69)

Таким образом, знание Ф(t) равносильно знанию k(ω)k(–ω). Но поскольку K(s) действительно, то

,

(3.70)

откуда [image]. Следовательно, |k(ω)|2 есть известная функция, а потому действительная часть log|k(ω)| также есть известная функция. [c.144]

Если записать 8

(3.71)

то нахождение функции K(s) эквивалентно нахождению мнимой части log k(ω). Это задача неопределенная, если не наложить дальнейшего ограничения на k(ω). Налагаемое ограничение будет состоять в том, что log k(ω) должен быть аналитической функцией и иметь достаточно малую скорость роста относительно ω в верхней полуплоскости. Для выполнения этого условия предположим, что k(ω) и [k(ω)]–1 возрастают вдоль действительной оси алгебраически. Тогда [F(ω)]2 будет четной и не более, чем логарифмически бесконечной функцией, и будет существовать главное значение Коши9 для

(3.72)

Преобразование, определяемое выражением (3.72), называется преобразованием Гильберта; оно изменяет cos λω в sin λω и sin λω в –cos λω. Следовательно,

F(ω)+iG(ω)

есть функция вида

(3.73)

и удовлетворяет требуемым условиям для log |k(ω)| в нижней полуплоскости.

Если теперь положить

,

(3.74)

то можно показать, что при весьма общих условиях функция K(s), определяемая формулой (3.68), будет обращаться в нуль для всех отрицательных аргументов. Таким образом,

(3.75)

[c.145]

С другой стороны, можно показать, что 1/k(ω) записывается в виде

,

(3.76)

где значения Nn определены подходящим образом, и что при этом можно получить

(3.77)

Здесь значения Qn должны удовлетворять формальному условию

(3.78)

В общем случае будем иметь

,

(3.79)

а если ввести по образцу соотношения (3.68)

,

(3.80)

то

.

(3.81)

Следовательно,

.

(3.82)

Этот вывод мы используем для того, чтобы получить оператор предсказания в форме, связанной не со временем, а с частотой. [c.146]

Таким образом, прошлое и настоящее функции ξ(t, γ), или точнее “дифференциала” dξ(t, γ), определяют прошлое и настоящее функции f(t, γ), и обратно.

Если теперь А >0, то

(3.83)

Здесь первый член последнего выражения зависит от области изменения dξ(t, γ), в которой, зная лишь f(σ, γ) для σ≤, сказать ничего нельзя, и совершенно не зависит от второго члена. Его среднеквадратическое значение равно

,

(3.84)

и эта формула дает все статистическое знание о нем. Можно показать, что первый член имеет гауссово распределение с этим среднеквадратическим значением. Последнее равно ошибке наилучшего возможного предсказания функции f(t+A, γ).

Само же наилучшее возможное предсказание выражается вторым членом в (3.83):

.

(3.85)

Если теперь положим

(3.86)

[c.147]

и применим оператор (3.85) к eiωt, получив

,

(3.87)

то найдем, подобно (3.81), что

(3.88)

Это и есть частотная форма наилучшего оператора предсказания.

Задача фильтрации в случае временных рядов типа (3.34) тесно связана с задачей предсказания. Пусть сумма сообщения и шума имеет вид

,

(3.89)

а сообщение имеет вид

,

(3.90)

где γ и δ распределены независимо в интервале (0, 1). Тогда предсказуемая часть функции m(t+a), очевидно, равна

,

(3.901)

а среднеквадратическая ошибка предсказания равна

.

(3.902)

Допустим, кроме того, что нам известны следующие величины:

[c.148]

(3.903)

(3.904)

(3.905)

[c.149]

Преобразование Фурье для этих величин соответственно равно

(3.906)

где

(3.907)

то есть

(3.908)

и

,

(3.909)

где для симметрии пишем

.

Теперь мы можем определить k(ω) из (3.908), как прежде определили k(ω) из (3.74). Здесь мы принимаем

В результате

(3.910)

и

.

(3.911)

Таким образом, наилучшее определение функции m(t) с наименьшей среднеквадратической ошибкой есть

.

(3.912)

[c.150]

Сравнивая это с уравнением (3.89) и пользуясь рассуждениями, подобными тем, посредством которых было получено (3.88), заключаем, что оператор для m(t)+n(t), дающий “наилучшее” представление функции m(t+a), имеет при записи в частотной шкале следующий вид:

.

(3.913)

Этот оператор служит характеристическим оператором устройства, которое в электротехнике называют волновым фильтром. Величина а есть фазовое отставание фильтра. Она может быть положительной или отрицательной; если она отрицательна, то а называется фазовым опережением. Прибор, соответствующий формуле (3.913), может быть построен с какой угодно точностью. Подробности его конструкции нужны более для инженера-электрика, чем для читателя этой книги. Их можно найти в соответствующей литературе 10.

Среднеквадратическая ошибка фильтрации (3.902) может быть представлена как сумма среднеквадратической ошибки фильтрации для бесконечного фазового отставания

(3.914)

[c.151]

и другого члена

,

(3.915)

зависящего от фазового отставания. Мы видим, что среднеквадратическая ошибка фильтрации есть монотонно убывающая функция фазового отставания.

Другим интересным вопросом в случае сообщений и шумов, порождаемых броуновым движением, является скорость передачи информации. Рассмотрим для простоты случай, когда сообщение и шум независимы, т.е. когда

.

(3.916)

Рассмотрим в этом случае функции

,

(3.917)

где γ и σ распределены независимо. Пусть нам известна сумма m(t)+n(t) в интервале (–А, А). Сколько у нас тогда информации об m(t)? Заметим, что, по эвристическому суждению, это количество информации не должно слишком отличаться от количества информации о функции

(3.918)

которым мы располагаем, когда нам известны все значения выражения

,

(3.919)

где γ и σ имеют независимые распределения. Можно, однако, показать, что п-й коэффициент Фурье для выражения (3.918) имеет гауссово распределение, независимое от всех других коэффициентов Фурье, и что его [c.152] среднеквадратическое значение пропорционально величине

(3.920)

Следовательно, в силу (3.09) полное количество информации об М равно

,

(3.921)

а временная плотность передачи энергии равна этой величине, деленной на 2А. Если А→∞, то выражение (3.921) стремится к

.

(3.922)

Именно этот результат и был получен автором и Шенноном для скорости передачи информации в рассматриваемом случае. Как видим, эта величина зависит не только от ширины полосы частот, которой мы располагаем для передачи сообщения, но и от уровня шума. В действительности она обнаруживает прямую связь с аудиограммами, применяемыми для измерения величины слуха и потери его у данного индивидуума. В аудио-грамме абсциссой служит частота, ординатой нижней границы – логарифм порога слышимой силы звука (мы можем назвать его логарифмом внутреннего шума принимающей системы), а ординатой верхней границы – логарифм наибольшей силы звука, которую система может пропустить. Площадь между ними, представляющая величину такой же размерности, как выражение (3.922), принимается за меру скорости передачи информации, с которой ухо способно справиться. [c.153]

Теория сообщений, линейно зависящих от броунова движения, имеет много важных вариантов. Основными являются формулы (3.88), (3.914) и (3.922), разумеется, вместе с определениями, необходимыми для их понимания. Существует ряд вариантов этой теории. Прежде всего она дает нам наилучший возможный синтез предсказывающих устройств и волновых фильтров в случае, когда сообщения и шумы представляют собой реакции линейных резонаторов на броуновы движения, однако и в значительно более общих случаях она обеспечивает некоторый возможный синтез предсказывающих устройств и фильтров. Последние, правда, не будут иметь абсолютно наилучшей конструкции, но, во всяком случае, позволят свести к минимуму среднеквадратическую ошибку предсказания при использовании линейных устройств. Однако, вообще говоря, найдутся такие нелинейные устройства, которые будут работать лучше, чем любые линейные устройства.

Кроме того, выше мы рассматривали простые временные ряды, в которых от времени зависит лишь одна числовая переменная. Существуют также многомерные временные ряды, где несколько таких переменных зависят все вместе от времени; именно многомерные ряды имеют наибольшее значение в экономических науках, метеорологии и т.п. Полная карта погоды Соединенных Штатов, составляемая ежедневно, есть такой временной ряд. В этом случае нам нужно одновременно выразить несколько функций через частоту, причем квадратические величины, такие, как выражение (3.35) или |k(ω)|2 в рассуждениях после формулы (3.70), заменяются множествами пар величин, т.е. матрицами. Задача определения функции k(ω) через |k(ω)|2 с выполнением некоторых добавочных условий в комплексной плоскости становится теперь гораздо труднее, особенно ввиду того, что умножение матриц не является перестановочной операцией. Тем не менее задачи, относящиеся к этой многомерной теории, были решены, по крайней мере частично, Крейном и автором.

Многомерная теория представляет собой усложнение предыдущей теории. Существует, кроме того, другая близкая теория, которая является ее упрощением. Эта теория предсказания, фильтрации и количества информации в дискретных временных рядах. Такой ряд [c.154] представляет собой последовательность функций fn(α) параметра α, где n пробегает все целочисленные значения от –∞ до ∞. Величина α, как и раньше, служит параметром распределения, и можно по-прежнему считать, что этот параметр изменяется равномерно в интервале (0, 1). Говорят, что временной ряд находится в статистическом равновесии, если замена п на n+v (v – целое число) равносильна сохраняющему меру преобразованию в себя интервала (0, 1), пробегаемого параметром α.

Теория дискретных временных рядов во многих отношениях проще теории непрерывных рядов. Гораздо легче, например, свести их к последовательности независимых выборов. Каждый член (в случае перемешивания) можно представить как комбинацию предшествующих членов с некоторой величиной, не зависящей от всех предшествующих членов и равномерно распределенной в интервале (0, 1), и последовательность этих независимых коэффициентов взять вместо броунова движения, столь важного для непрерывных рядов.

Если fn(α) – временной ряд, находящийся в статистическом равновесии и метрически транзитивный, то его коэффициент автокорреляции будет равен

.

(3.923)

и мы будем иметь

(3.924)

почти для всех α. Положим

,

(3.925)

или

(3.926)

[c.155]

Пусть

, | (3.927)
 | (3.928)

и

.

(3.929)

Тогда при очень общих условиях k(ω) будет граничным значением на единичном круге для функции без нулей и особых точек внутри единичного круга; (а является здесь углом. Отсюда

(3.930)

Если теперь за наилучшее линейное предсказание функции fn(α) с опережением v принимается

,

(3.931)

то

.

(3.932)

Это выражение аналогично выражению (3.88). Заметим, что если положить

,

(3.933)

то

(3.934)

[c.156]

Из нашего способа образования k(ω) видно, что для весьма широкого класса случаев мы вправе положить

.

(3.935)

Тогда уравнение (3.934) принимает вид

.

(3.936)

В частности, при v=l

,

(3.937)

или

(3.938)

Таким образом, при предсказании на один шаг вперед наилучшим значением для fn+1(α) будет

;

(3.939)

последовательным же предсказанием по шагам мы можем решить всю задачу линейного предсказания для дискретных временных рядов. Как и в непрерывном случае, это будет наилучшим возможным предсказанием относительно любых методов, если

.

(3.940)

Переход от непрерывного случая к дискретному в задаче фильтрации совершается примерно таким же путем. Формула (3.913) для частотной характеристики наилучшего фильтра принимает вид

,

(3.941)

где все члены имеют тот же смысл, что и в непрерывном случае, за исключением того, что все интегралы по ω и u [c.157] имеют пределы от –π до π, а не от –∞ до ∞ и вместо интегралов по t берутся дискретные суммы по v. Фильтры для дискретных временных рядов представляют собой обычно не столько физически осуществимые устройства для применения в электрической схеме, сколько математические процедуры, позволяющие статистикам получать наилучшие результаты со статистически несовершенными данными.

Наконец, скорость передачи информации дискретным временным рядом вида

,

(3.942)

при наличии шума

,

(3.943)

где γ и δ независимы, будет точным аналогом выражения (3.922), а именно:

,

(3.944)

где на интервале (–π, π) выражение

(3.945)

изображает распределение мощности сообщения по частоте, а выражение

(3.946)

изображает распределение мощности шума.

Изложенные здесь статистические теории предполагают полное знание прошлого наблюдаемых нами временных рядов. Во всех реальных случаях мы должны довольствоваться меньшим, поскольку наши наблюдения не распространяются в прошлое до бесконечности. Разработка нашей теории за пределы этого [c.158] ограничения требует расширения существующих методов выборки. Автор и другие исследователи сделали первые шаги в этом направлении. Это связано со всеми сложностями применения закона Бейеса либо тех терминологических ухищрений теории правдоподобия11, которые на первый взгляд устраняют необходимость в применении закона Бейеса, но в действительности лишь перелагают ответственность за его применение на статистика-практика или на лицо, использующее в конце концов результаты, полученные статистиком-практиком. Тем временем статистик-теоретик может вполне честно утверждать, что все сказанное им является совершенно строгим и безупречным.

В заключение этой главы мы коснемся современной квантовой механики, на которой сильнее всего сказалось вторжение теории временных рядов в современную физику. В ньютоновой физике последовательность физических явлений полностью определяется своим прошлым, и в частности, указанием всех положений и импульсов в какой-либо один момент. В полной гиббсовской теории, при точном определении многомерного временного ряда всей Вселенной, знание всех положений и импульсов в какой-либо один момент также определило бы все будущее. И только вследствие того, что существуют неизвестные, ненаблюдаемые координаты и импульсы, только по этой причине временные ряды, с которыми мы фактически работаем, приобретают своего рода смесительное свойство, с которым мы познакомились в этой главе для случая временных рядов броунова движения. Большим вкладом Гейзенберга в физику была замена этого все еще квазиньютонова мира Гиббса миром, в котором временные ряды совершенно не могут быть сведены к набору детерминированных нитей развития во времени. В квантовой механике все прошлое индивидуальной системы не создает никакого абсолютного определения будущего этой системы, но дает лишь распределение возможных будущих состояний. Величины, которые требуются классической физике для знания всего поведения системы, можно наблюдать одновременно лишь приближенным и нестрогим образом, хотя эти наблюдения и достаточно точны для нужд классической физики в том диапазоне [c.159] точности, в котором экспериментально доказана ее применимость. Условия наблюдения импульса и соответствующего ему положения несовместимы. Для наблюдения положения системы с наибольшей возможной точностью мы должны наблюдать его с помощью световых или электронных волн или аналогичных средств с высокой разрешающей способностью или короткой длиной волны. Однако свет обладает корпускулярным действием, зависящим только от его частоты, и при освещении тела светом высокой частоты количество движения тела изменяется тем больше, чем выше частота. С другой стороны, свет низкой частоты дает минимальное изменение импульса освещаемых частиц, но не имеет достаточной разрешающей способности, чтобы дать резкий отсчет положений. Промежуточные частоты света дают размытый отсчет как положений, так и импульсов. Вообще нельзя придумать системы наблюдений, которая могла бы дать нам достаточно информации о прошлом системы, чтобы получить полную информацию о ее будущем.

Тем не менее, как и в случае всех ансамблей временных рядов, изложенная здесь теория количества информации, а следовательно, и теория энтропии сохраняют силу. Но так как мы теперь имеем дело с временными рядами, обладающими свойством перемешивания даже в случае, когда наши данные настолько полны, насколько это возможно, то наша система, очевидно, лишена абсолютных потенциальных барьеров, и с течением времени любое состояние системы может и будет переходить в любое другое состояние. Однако вероятность такого перехода зависит в конечном счете от относительной вероятности или меры данных двух состояний. Последняя оказывается особенно большой для состояний, которые могут быть преобразованы сами в себя большим числом преобразований, т.е. для состояний, которые, на языке квантовой теории, имеют большой внутренний резонанс, или большое квантовое вырождение. Примером может служить бензоловое кольцо, так как здесь оба состояния эквивалентны:

[c.160]

Это наводит на следующую мысль. Пусть дана система, в которой составные части могут различными способами близко соединяться друг с другом, как в случае смеси аминокислот, организующейся в белковые цепи, тогда ситуация, при которой многие из этих цепей одинаковы и проходят через стадию тесной связи между собой, может оказаться более устойчивой, чем ситуация, при которой они различны. Холдэйи предположил, что именно таким путем воспроизводят себя гены и вирусы, и хотя он не подтвердил своего предположения окончательными доказательствами, я не вижу причин, почему не принять его как пробную гипотезу. Как указал сам Холдэйн, поскольку в квантовой теории ни одна частица не имеет совершенно четкой индивидуальности, можно сказать лишь приблизительно, какой из двух экземпляров гена, воспроизведшего себя таким образом, является оригиналом и какой – копией.

Это явление резонанса, как известно, очень часто встречается в живом веществе. Сент-Дьёрдьи указал на его значение в конструкции мышц. Вещества с большим резонансом обычно обладают ненормально большой способностью запасать энергию и информацию, а такое ненормально большое запасание, бесспорно, имеет место при мышечном сокращении.

Эти же явления, участвующие в воспроизведении, имеют, вероятно, отношение и к чрезвычайной специфичности химических веществ, обнаруживаемых в живых организмах, не только по отношению к разным видам, но даже по отношению к особям одного вида. Соображения такого рода могут иметь большое значение в иммунологии. [c.161]

Далее:
IV. ОБРАТНАЯ СВЯЗЬ И КОЛЕБАНИЯ

К оглавлению

ПРИМЕЧАНИЯ

1 Вокодер – система “синтетической” телефонии, в которой по каналам связи передаются вместо натуральных речевых сигналов упрощенные командные сигналы, получаемые в результате анализа речи на передающем конце. Тем самым передача занимает меньшую полосу частот. На приемном конце речь искусственно синтезируется под управлением командных сигналов, определяющих высоту и силу тонов, ритм и т.д. – Прим. ред.
Вернуться к тексту

2 Здесь автор использует личное сообщение Дж. фон Неймана.
Вернуться к тексту

3 Равенство (3.04) означает, что площадь под кривой y=f1(x) равна 1. Поэтому средняя ширина этой области равна обратной величине ее средней высоты, т.е. среднего значения функции f1(x). Отсюда, по-видимому, автор заключает об указанной вольной связи между средними логарифмами и, приняв, согласно (3.03), минус средний двоичный логарифм от ширины области за меру количества информации, находит в итоге [image],
как в (3.05). – Прим. ред.
Вернуться к тексту

4 Деление на

служит нормировке апостериорной плотности вероятности. – Прим. ред.
Вернуться к тексту

5 Раlеу R.Е.А.С., Wiener N. Fourier Transforms in the Complex Domain / Amer. Math. Soc. – Colloquium Publications. – Vol. 19. – New York, 1934. Chapter 10 (русский перевод: Винер Н., Пэли Р. Преобразование Фурье в комплексной области. – М.: Наука, 1964. Гл. 10. – Ред.).
Вернуться к тексту

6 Stielltes Т.J. Annales de la Fac. des Sc. de Toulouse. – 1894. – P. 165; Lebesgue Н. Lemons sur l'Integration. – Paris: Gauthier-Villars et Cie, 1928 (русский перевод: Лебег А. Интегрирование и отыскание примитивных функций. – М.–Л.: ГТТИ, 1934. – Ред.)
Вернуться к тексту

7 Это – открытое Купменом свойство перемешивания, составляющее необходимую и достаточную эргодическую предпосылку для оправдания статистической механики.
Вернуться к тексту

8 Обозначая через [image] действительную часть от стоящего справа выражения. – Прим. ред.
Вернуться к тексту

9 Под значением Коши несобственного интеграла

обычно понимают выражение
– Прим. ред.
Вернуться к тексту

10 В частности, можно указать последние статьи д-ра Ю.В. Ли.
Вернуться к тексту

11 См. работы Р.А. Фишера и Дж. фон Неймана.


Винер Н

Винер Н. Кибернетика, или управление и связь в животном и машине. – 2-е издание. – М.: Наука; Главная редакция изданий для зарубежных стран, 1983. – 344 с.

Красным шрифтом в квадратных скобках обозначается конец текста на соответствующей странице печатного оригинала данного издания

IV. ОБРАТНАЯ СВЯЗЬ И КОЛЕБАНИЯ

В неврологическую клинику приходит больной. Он не парализован и, получив приказание, может двигать ногами. Тем не менее он страдает тяжелым недугом. Он идет странной, неуверенной походкой и все время смотрит вниз, на землю и на свои ноги. Каждый шаг он начинает с рывка, выбрасывая вперед сначала одну, потом другую ногу. Если ему завязать глаза, он не сможет стоять, он шатается и падает. Что с ним?

Приходит другой больной. Пока он неподвижно сидит на стуле, кажется, что у него все в порядке. Но если предложить ему папиросу, то при попытке взять ее рукой он промахнется. Затем он столь же тщетно качнет руку в обратном направлении, потом опять вперед, и, наконец, его рука станет совершать лишь быстрые и бесцельные колебания. Дайте ему стакан воды, и он выплеснет всю воду, прежде чем сумеет поднести стакан ко рту. Что с ним?

Оба больные страдают разными формами так называемой атаксии. Их мышцы достаточно сильны и здоровы, но они не могут управлять своими движениями. Первый больной страдает спинной сухоткой. Часть спинного мозга, обычно воспринимающего ощущения, повреждена или разрушена поздними осложнениями от сифилиса. Поступающие сигналы притуплены или даже полностью пропадают. Рецепторы в суставах, сухожилиях, мышцах и подошвах его ног, обычно сообщавшие ему о положении и движении ног, не посылают сигналов, которые центральная нервная система могла бы принять и передать, и чтобы получить информацию о положении своего тела, больной должен полагаться на глаза и органы равновесия внутреннего уха. Физиолог на своем языке скажет, что больной потерял значительную часть проприоцептивных и кинестетических [c.162] ощущений. Второй больной не потерял проприоцептивных ощущений – у него повреждение мозжечка, и он болен так называемым мозжечковым, или интенционным, тремором. По-видимому, функция мозжечка – соразмерять мышечную реакцию с проприоцептивными сигналами, и если эта соразмерность нарушена, одним из следствий может явиться тремор.

Мы видим, таким образом, что для эффективного воздействия на внешний мир не только необходимо иметь хорошие эффекторы, но действие этих эффекторов должно находиться под надлежащим контролем центральной нервной системы; показания же контрольных органов должны сочетаться надлежащим образом с другими сведениями, поступающими из органов чувств, образуя правильно соразмеренные выходные сигналы к эффекторам. Нечто подобное наблюдается и в механических системах. Рассмотрим центральный пост сигнализации на железной дороге. Оператор управляет рядом рычагов, которые открывают или закрывают семафоры и переводят стрелки. Однако он не может слепо верить, что семафор и стрелки подчинились его приказаниям. Стрелки могли замерзнуть или снег мог согнуть крылья семафоров, и действительное положение стрелок и сигналов семафоров – эффекторов оператора – может не соответствовать его приказаниям. Во избежание опасностей, неизбежно связанных с такой возможностью, каждый эффектор – стрелка или сигнал семафора – соединяется с контрольными приборами на сигнальном посту, которые сообщают оператору о действительном состоянии и работе эффектора. Это представляет собой механическую аналогию повторению приказов в военно-морском флоте, где по уставу каждый подчиненный по получении приказа повторяет его своему начальнику, чтобы показать, что он расслышал и понял. На основании таких повторенных приказов и действует оператор.

Заметим, что в этой системе человек участвует в цепи прямой и обратной передачи информации, в цепи, которую мы далее будем называть цепью обратной связи. Правда, оператор не может действовать полностью по своему произволу; стрелки и сигналы связаны блокировкой, механической или электрической, и не в его воле выбрать гибельные комбинации. Но имеются цепи [c.163] обратной связи, в которых человек совершенно не участвует. Одна из таких цепей – обычный термостат, регулирующий отопление жилища. Термостат устанавливают на желательную температуру помещения, и если действительная температура ниже” то срабатывает устройство, которое открывает заслонку печи для усиления тяги или увеличивает поступление горючего и тем самым доводит температуру помещения до желательного уровня. Если же температура помещения превышает желательный уровень, то выключается тяга, либо уменьшается или прекращается поступление горючего. Таким образом, температура помещения удерживается приблизительно на постоянном уровне. Заметим, что постоянство этого уровня зависит от качества конструкции термостата и что плохо спроектированный термостат может вызвать сильные колебания температуры, подобные движениям человека, страдающего мозжечковым тремором.

Другой пример чисто механической системы обратной связи – это изученный впервые Кларком Максвеллом регулятор паровой машины, служащий для регулировки ее скорости при переменных режимах нагрузки. Регулятор в своем первоначальном виде, как его сконструировал Уатт, состоит из двух шаров, укрепленных на маятниковых стрежнях на противоположных сторонах вращающегося вала. Собственный вес или пружина тянет шары вниз, а центробежная сила, зависящая от угловой скорости вала, стремится подбросить их вверх. Поэтому они принимают некоторое промежуточное положение, которое также зависит от угловой скорости. Шары через другие стержни управляют положением муфты, сидящей на валу, которая приводит в движение золотник, открывающий впускные клапаны цилиндра, когда скорость машины уменьшается и шары опускаются, и закрывающий их, когда скорость машины увеличивается и шары поднимаются. Заметим, что обратная связь стремится противодействовать тому, что делает система; следовательно, эта обратная связь является отрицательной.

Итак, мы рассмотрели примеры отрицательной обратной связи для стабилизации температуры и отрицательной обратной связи для стабилизации скорости. Возможна также отрицательная обратная связь для [c.164] стабилизации положения, как в рулевых машинах корабля, которые приходят в действие при наличии угловой разности между положением штурвала и положением руля и действуют всегда таким образом, чтобы привести положение руля в соответствие с положением штурвала. Обратная связь при произвольных действиях человека имеет такой же характер. Мы не хотим специально приводить в движение определенные мышцы и даже вообще не знаем, какие мышцы нужно привести в движение, чтобы выполнить данную задачу, мы просто хотим взять папиросу. Наше движение регулируется степенью того, насколько задача еще не выполнена.

Информация, поступающая обратно в управляющий центр, стремится противодействовать отклонению управляемой величины от управляющей, но она может зависеть от этого отклонения весьма различным образом. Простейшие управляющие системы – линейные системы: выходной сигнал исполнительного органа зависит линейно от входного сигнала, и при сложении входных сигналов складываются и выходные сигналы. Выходной сигнал отсчитывается каким-нибудь прибором, также линейным. Этот отсчет просто вычитается из входного сигнала. Мы хотим дать точную теорию работы такой системы и, в частности, исследовать ее неисправное поведение и возникновение в ней колебаний при неправильном обращении или перегрузке.

В этой книге мы по возможности избегали математической символики и математических методов, хотя в ряде мест, включая предыдущую главу, вынуждены были примириться с ними. Сейчас речь опять пойдет о вопросах, где математическая символика – самый надежный язык; избежать ее можно только ценой длинных перифраз, которые вряд ли будут понятны профану и которые поймет лишь читатель, знакомый с математической символикой, поскольку в его власти перевести их в символы. Наилучший компромисс, который мы можем выбрать, – это дополнять символику пространными словесными пояснениями.

Пусть f(t) – функция времени t, где t изменяется от –∞ до ∞; иначе говоря, f(t) – величина, принимающая определенное числовое значение для каждого момента t. В любой момент t нам доступны величины f(s), где s меньше или равно t, но отнюдь не больше t. [c.165] Мы располагаем устройствами, электрическими или механическими, которые задерживают входной сигнал на фиксированное время и выдают нам при входном сигнале f(t) выходной сигнал f(t–τ), γде τ – фиксированная задержка.

Мы можем включить одновременно несколько таких устройств, получив на выходах сигналы f(t–τ1), f(t–τ2),..., f(t–τ n). Каждый из этих выходных сигналов мы можем умножить на фиксированные величины, положительные или отрицательные. Так, при помощи потенциометра можно умножить напряжение на фиксированное положительное число, меньшее единицы, и не очень трудно изобрести автоматические компенсационные устройства и усилители, чтобы умножать напряжение на отрицательные величины или на величины, большие единицы. Нетрудно также составить простую электрическую схему для непрерывного сложения напряжений, при помощи которой мы получим выход

.

(4.01)

Увеличивая число задержек τ k и выбирая подходящим образом коэффициенты ak, мы можем сколь угодно приблизиться к выходному сигналу вида

.

(4.02)

Обратим внимание на то существенное обстоятельство, что в этом выражении интегрирование производится от 0 до ∞, а не от –∞ до ∞. В противном случае мы могли бы с помощью различных практических устройств преобразовать наш сигнал в f(t+σ), где σ положительно. Но это предполагает знание будущего функции f(t), a f(t) может быть величиной, которая не определяется однозначно своим прошлым; пример – координаты трамвая, который может повернуть на стрелке в ту или другую сторону. Если физический процесс по видимости дает нам оператор, преобразующий f(t) в

(4.03)

[c.166]

где а(τ) не исчезает при отрицательных τ, это значит, что мы не имеем больше истинного оператора для f(t),определяемого однозначно прошлым этой функции. Такое может встретиться в реальных физических ситуациях. Например, динамическая система без входа может прийти в постоянные колебания или даже в колебания, нарастающие до бесконечности, с неопределенной амплитудой. В этом случае будущее системы не определяется ее прошлым, и мы, наверное, можем найти формализм, в котором бы использовался оператор, зависящий от будущего.

Операция, посредством которой получено выражение (4.02) из f(t), имеет еще два существенных свойства: 1) она не зависит от сдвига начального момента и 2) она линейна. Первое свойство выражается утверждением, что если

,

(4.04)

то

.

(4.05)

Второе выражается утверждением, что если

,

(4.06)

то

.

(4.07)

Можно показать, что в некотором подходящем смысле всякий оператор для прошлого функции f(t), линейный и инвариантный относительно сдвига начального момента, имеет вид (4.02) или является пределом последовательности операторов этого вида. Например, f’(t) есть результат применения оператора с такими свойствами к f(t), и потому [c.167]

,

(4.08)

где

(4.09)

Как мы уже видели, функции е zt составляют особенно интересное семейство с точки зрения оператора (4.02), поскольку

,

(4.10)

и оператор задержки становится просто множителем, зависящим от z. Оператор (4.02) переходит тогда в

.

(4.11)

и также оказывается оператором умножения, зависящим только от z. Выражение

(4.12)

называется представлением, оператора (4.02) в виде функции частоты. Если z – комплексная величина х+iy, где х и y – действительные числа, то (4.12) переходит в

(4.13)

Отсюда следует ввиду известного неравенства Шварца для интегралов, что если y>0 и

,

(4.14)

то [c.168]

.

(4.15)

Это значит, что А(х+iу) – ограниченная голоморфная функция комплексной переменной в каждой полуплоскости x≥ε>0, а функция A(iy) представляет в некотором весьма определенном смысле граничные значения этой функции.

Положим

,

(4.16)

где и и v – действительные числа. Тогда x+iy определится как функция (не обязательно однозначная) от u+iv. Это функция аналитическая, хотя и мероморфная, за исключением точек u+iv, соответствующих точкам z=x+-iy, где дА(z)/дz=0. Граница х=0 перейдет в кривую с параметрическим уравнением

(y действительное).

(4.17)

Эта новая кривая может пересекать саму себя любое число раз, но в общем случае она будет делить плоскость на две области. Рассмотрим кривую (4.17), вычерченную в направлении возрастания у от –∞ до +∞. Если идти от нее вправо по непрерывной линии, не пересекающей снова кривую (4.17), можно попасть в те или иные точки плоскости. Точки, не входящие в это множество и не лежащие на кривой (4.17), мы будем называть внешними точками. Часть кривой (4.17), содержащую предельные точки внешних точек, назовем эффективной границей. Все остальные точки будут именоваться внутренними точками. На нашем чертеже с границами, проведенными в направлении стрелок (рис. 1), внутренние точки заштрихованы, а эффективная граница выделена жирной линией.

Рис. 1

[c.169]

Условие ограниченности функции А в любой правой полуплоскости указывает на то, что бесконечно удаленная точка не может быть внутренней точкой. Она может быть граничной точкой, хотя существуют весьма определенные ограничения на тип граничной точки, которой может быть бесконечно удаленная точка. Эти ограничения касаются “толщины” множества внутренних точек, простирающихся к бесконечности.

Мы переходим теперь к математической формулировке задачи о линейной обратной связи. Пусть структурная (не электрическая!) схема нашей системы имеет вид, как на рис. 2.

Рис. 2

Здесь входной сигнал двигателя, обозначенный через Y, равен разности между первоначальным входным сигналом Х и выходным сигналом умножителя, умножающего выходную мощность AY двигателя на коэффициент λ. Тогда

(4.18)

и

,

(4.19)

откуда выходной сигнал двигателя

.

(4.20)

Следовательно, оператор, создаваемый всем механизмом обратной связи, равен A/(1+ λA). Он будет бесконечно большим тогда и только тогда, когда А= –1/λ. Κπивая (4.17) для этого нового оператора будет иметь вид [c.170]

,

(4.21)

и ∞ будет внутренней точкой этой кривой тогда и только тогда, когда –1/λ является внутренней точкой первоначальной кривой (4.17)1.

В этом случае обратная связь с коэффициентом λ, несомненно, произведет нечто катастрофическое, и эта катастрофа практически выразится в том, что система придет в неограниченные, нарастающие колебания. Если же точка –1/λ внешняя, то можно показать, что никаких неприятностей не будет, и обратная связь будет устойчивой. Случай, когда точка –1/λ лежит на эффективной границе, требует особого исследования. В большинстве случаев система может прийти при этом в колебание с амплитудой, которая не будет увеличиваться.

Пожалуй, полезно рассмотреть несколько операторов А и допустимые для них диапазоны обратной связи. Мы будем рассматривать не только операции (4.02), но и их пределы, предполагая, что к последним применимы те же рассуждения.

Если оператор А соответствует дифференциальному оператору, то A(z)=z; тогда при изменении у от –∞ до ∞ точно так же изменяется и А (у), и внутренние точки являются внутренними точками правой полуплоскости. Точка –1/λ всегда является внешней, и любая степень обратной связи возможна.

Если

,

(4.22)

то кривая (4.17) принимает следующий вид:

,

(4.23)

или

, [image],

(4.24)

что можно также записать в виде

(4.25)

[c.171]

Таким образом, наша кривая есть окружность с радиусом 1/2 и центром в точке (1/2, 0). Обход ее совершается по часовой стрелке, и внутренними будут те точки, которые обычно считаются внутренними. В этом случае обратная связь также неограниченна, ибо точка – \tK всегда находится вне круга. Оператор a(t), соответствующий этому оператору А, будет равен

.

(4.26)

Положим теперь

,

(4.27)

тогда (4.17) принимает вид

(4.28)

Или

,

(4.29)

что дает

(4.30)

или

(4.31)

Тогда

(4.32)

В полярных координатах при u = ρ соs φ, v = ρ sin φ получим

(4.33)

или

(4.34)

Иными словами, [c.172]

(4.35)

Можно показать, что оба эти уравнения изображают одну кривую – кардиоиду с вершиной в начале координат и острием, направленным вправо. Внутренняя область этой кривой не содержит точек отрицательной действительной оси; как и в предыдущем случае, допустимое усиление неограниченно. Оператор а(t) для этого случая имеет следующий вид:

(4.36)

Положим еще

(4.37)

Определим ρ и φ, как в предыдущем случае. Тогда

(4.38)

Как в первом случае, отсюда получим

(4.39)

т.е.

(4.40)

Эта кривая имеет форму, показанную на рис. 3 2 . Заштрихованная область изображает внутренние точки. Коэффициент обратной связи не может быть больше 1/8. Соответствующий оператор a(t) равен

(4.41)

Рис. 3

Наконец, пусть наш оператор, соответствующий A, представляет собой простую задержку на Т единиц [c.173] времени. Тогда

(4.42)

и

(4.43)

Кривая (4.17) в этом случае представляет собой единичную окружность с центром в начале координат, проходимую в направлении часовой стрелки со скоростью, равной единице. Внутренней областью кривой будет внутренняя область в обычном смысле, и предельная обратная связь равна 1.

Отсюда можно вывести одно весьма интересное заключение. Оператор 1/(1+kz) можно компенсировать произвольно сильной обратной связью, что заставляет A/(1+λ A) приближаться сколь угодно близко к единице в сколь угодно широком диапазоне частот. Таким образом, три последовательных оператора этого типа можно компенсировать тремя – или даже двумя – обратными связями. Но оператор 1/(1+kz)3, получаемый при последовательном соединении трех операторов 1/(1+kz), нельзя сколь угодно точно компенсировать одной обратной связью. Оператор 1/(1+kz)3 можно также записать в виде

(4.44)

и рассматривать как предел аддитивного соединения трех операторов со знаменателями первой степени. Итак, оказывается, что сумму различных операторов, каждый из которых допускает сколь угодно точную компенсацию одной обратной связью, нельзя компенсировать таким же образом.

В ценной книге Макколла приведен пример сложной системы, которая может быть стабилизирована двумя обратными связями, но не одной. Речь идет о системе управления кораблем при помощи гирокомпаса. Наличие угла между курсом, который задал рулевой, и тем, который показывает компас, приводит к перекладке руля, создающей вследствие поступательного движения корабля вращающий момент, который изменяет курс корабля таким образом, чтобы уменьшить расхождение между заданным и действительным курсом. Если это [c.174] осуществляется путем непосредственного открывания клапанов одной рулевой машины и закрывания клапанов другой с таким расчетом, что скорость перекладывания руля пропорциональна отклонению корабля от курса, то угловое положение руля будет примерно пропорционально моменту вращения корабля и, следовательно, его угловому ускорению. Поэтому поворот корабля пропорционален с отрицательным коэффициентом третьей производной отклонения от курса, а операция, которую нужно стабилизировать обратной связью от гирокомпаса, имеет вид kz3, где k положительно. Таким образом, мы получаем для кривой (4.17) уравнение

(4.45)

и поскольку внутренней областью служит левая полуплоскость, никакой следящий механизм не сможет стабилизировать эту систему.

В этом описании мы несколько упростили задачу управления. В действительности здесь присутствует какое-то трение, и сила, поворачивающая корабль, не определяет ускорения. Если θ – угловое положение корабля, а φ – угловое положение руля по отношению к кораблю, то

(4.46)

и

(4.47)

Эту кривую можно записать как

(4.48)

и систему по-прежнему нельзя стабилизировать никакой обратной связью. Когда у изменяется от –∞ до ∞, v изменяется от ∞ до –∞, так что внутренняя область кривой расположена слева.

Если, с другой стороны, положение руля пропорционально отклонению от курса, то оператор, который мы хотим стабилизировать обратной связью, имеет вид k1z2+k2z, и кривая (4.17) будет задаваться уравнением

(4.49)

Эту кривую можно записать как

(4.50)

[c.175]

но на этот раз при изменении у от –∞ до ∞ и также изменяется от –∞ до ∞, а кривая наша обходится в направлении от у=–∞ до у=∞. Внешняя область кривой находится слева от нее, и возможно неограниченное усиление.

Для достижения этого результата можно применить вторую ступень обратной связи. Если положение клапанов рулевой машины регулируется не расхождением между действительным и желательным курсом, а разностью между этой величиной и угловым положением руля, то при достаточно большой обратной связи (т.е. когда клапаны открыты достаточно широко) будет поддерживаться с любой точностью пропорциональность между угловым положением руля и отклонением корабля от истинного курса. Система управления с двойной обратной связью обычно и применяется для автоматического управления кораблем при помощи гирокомпаса.

В человеческом теле движение руки или пальца связано с большим числом суставов. Выходное усилие равно векторной комбинации выходных усилий всех этих суставов. Мы видели, что, вообще говоря, сложную аддитивную систему такого рода нельзя стабилизировать одной обратной связью. Поэтому обратная связь произвольного движения, при помощи которой мы регулируем выполнение задачи, наблюдая, насколько та еще не выполнена, должна быть поддержана другими обратными связями. Последние называются обратными связями позы и служат общему поддержанию тонуса мышечной системы. Именно обратная связь произвольного движения и подвержена нарушениям и расстройствам при повреждении мозжечка, ибо следующий за этим тремор появляется только тогда, когда больной пытается выполнить произвольное действие. Этот интенционный тремор, при котором больной не может взять стакан воды, не опрокинув его, весьма отличен по природе от тремора при паркинсоновской болезни, или дрожательном параличе. Тремор при паркинсоновской болезни проявляется наиболее типично, когда больной неподвижен, и часто, по-видимому, значительно ослабляется, когда больной пытается выполнить сознательно контролируемые действия. Встречаются хирурги с паркинсоновской болезнью, которые неплохо [c.176] справляются с операциями. Паркинсоновская болезнь, как известно, имеет причину не в болезненном состоянии мозжечка, а связана с патологическим очагом где-то в стволе мозга. Это лишь одна из болезней обратных связей позы, и многие из таких болезней происходят от повреждений частей нервной системы, расположенных весьма разнообразно. Одна из важных задач физиологической кибернетики – распутать и локализировать различные части этого комплекса обратных связей произвольных действий и поз. Примерами составных рефлексов такого рода служат чесальный рефлекс и рефлекс ходьбы.

Когда обратная связь возможна и устойчива, то, как мы уже говорили, она даст ту выгоду, что делает поведение системы менее зависимым от нагрузки. Допустим, что нагрузка изменяет характеристику А на dА. Относительное изменение равно dA/A. Если оператор после обратной связи имеет вид

(4.51)

то мы получим 3

(4.52)

Таким образом, обратная связь позволяет уменьшить зависимость системы от характеристики двигателя и стабилизировать ее для всех частот, для которых

(4.53)

То есть вся граница между внутренними и внешними точками должна лежать внутри круга с радиусом С и центром в точке – С. Это не будет выполняться даже в первом из рассмотренных нами случаев. Эффект сильной отрицательной обратной связи, если она устойчива, состоит в увеличении устойчивости системы при низких частотах, однако большей частью за счет ее устойчивости при тех или иных высоких частотах. Тем не менее [c.177] во многих случаях оказывается выгодной даже такая степень стабилизации.

Рассмотрение колебаний, вызванных чрезмерной обратной связью, поднимает весьма важный вопрос о частоте начинающегося колебания. Последняя определяется значением у в iy, соответствующим той точке границы между внутренней и внешней областями кривой (4.17), которая будет самой левой на отрицательной оси и. .Величина у, очевидно, имеет размерность частоты.

Мы пришли к концу нашего элементарного исследования линейных колебаний с точки зрения обратной связи. Линейная колебательная система обладает весьма специальными свойствами, характеризующими ее колебания. Одно из них заключается в том, что такая система всегда может и большей частью – при отсутствии независимых одновременных колебаний – будет совершать колебания вида

(4.54)

Существование периодического несинусоидального колебания всегда указывает по меньшей мере на то, что система нелинейна относительно наблюдаемой переменной. В некоторых, хотя и весьма немногих, случаях систему можно сделать линейной, выбрав другую независимую переменную.

Другое весьма значительное различие между линейными и нелинейными колебаниями заключается в том, что в первом случае амплитуда совершенно не зависит от частоты, а во втором обычно существует лишь одна амплитуда или самое большее дискретное множество амплитуд, с которыми система будет колебаться на данной частоте, как и дискретное множество частот, на которых возможны колебания. Это хорошо иллюстрируется изучением процессов, которые имеют место в органной трубе. Существует две теории органной трубы: приближенная линейная и более точная нелинейная. В первой органная труба трактуется как консервативная система. Вопрос о том, как труба приходит в колебание, не ставится, и уровень колебания остается совершенно неопределенным. Во второй теории считают, что колебания органной трубы рассеивают энергию, которая создается воздушным потоком, проходящим через [c.178] отверстие трубы. Теоретически возможен стационарный воздушный поток через отверстие трубы, не обменивающийся энергией ни с одной из форм колебания трубы, но при определенных скоростях воздушного потока стационарное состояние является неустойчивым. Малейшее случайное отклонение приводит к переходу энергии от воздушного потока к одному или нескольким собственным линейным колебаниям трубы, причем до известного момента это отклонение усиливает связь собственных колебаний трубы с источником энергии. Приток энергии и ее утечка вследствие теплового рассеяния и других причин происходят по разным законам, но при устойчивом режиме колебаний обе величины должны совпадать. Этим определяется как амплитуда, так и частота нелинейного колебания.

Рассмотренный случай служит примером так называемых релаксационных колебаний, когда система уравнений, инвариантных относительно сдвига во времени, дает решение, периодическое во времени или соответствующее некоторому обобщенному понятию периодичности и обладающее определенной амплитудой и частотой, но неопределенной фазой. В данном случае частота колебания системы близка к частоте некоторой слабо связанной, приблизительно линейной части системы. Б. ван дер Поль, один из главных авторитетов по релаксационным колебаниям, нашел, что это не всегда так и что возможны релаксационные колебания, у которых преобладающая частота далека от частоты линейных колебаний любой части системы. Можно привести следующий пример. Струя газа течет в камеру, сообщающуюся с наружным воздухом. В камере горит сигнальный огонь. Когда концентрация газа в воздухе достигает некоторой критической величины, в системе может произойти взрыв вследствие возгорания смеси от сигнального огня. Время, которое пройдет до того, как это случится, зависит лишь от скорости течения светильного газа, от скорости всасывания воздуха и удаления продуктов сгорания и от процентного состава взрывчатой смеси светильного газа и воздуха.

Вообще говоря, нелинейные системы уравнений трудно решать. Существует, однако, случай, легко поддающийся исследованию, когда система лишь немного отличается от линейной, и члены, составляющие [c.179] различие, изменяются так медленно, что их можно считать, по существу, постоянными за период колебания. В этом случае нелинейная система может исследоваться так, как если бы это была линейная система с медленно изменяющимися параметрами. Системы, допускающие подобный подход, носят название систем с вековыми возмущениями; теория систем с вековыми возмущениями играет важнейшую роль в гравитационной астрономии.

Кажется вероятным, что некоторые виды физиологических треморов можно рассматривать приближенно как линейные системы с вековыми возмущениями. На такой системе легко понять, почему амплитуда стационарного колебания может оказаться столь же определенной, как и частота. Пусть одним из элементов такой системы будет усилитель, коэффициент усиления которого уменьшается по мере того, как увеличивается некоторое долговременное среднее входного сигнала. Тогда с ростом колебаний системы коэффициент усиления может упасть, пока не будет достигнуто состояние равновесия.

Нелинейные системы релаксационных колебаний исследовались в ряде случаев методами, которые разработали Хилл и Пуанкаре 4 . Классическими примерами являются случаи, когда системы описываются уравнениями дифференциального характера, особенно если эти дифференциальные уравнения низшего порядка. Насколько мне известно, не существует какого-либо сравнимого исследования соответствующих интегральных уравнений, когда будущее системы зависит от всего ее прошлого. Однако нетрудно представить себе, какой вид должна иметь такая теория, особенно если мы ищем лишь периодические решения. В этом случае небольшое изменение коэффициентов уравнения должно вызывать небольшое и, следовательно, приблизительно линейное изменение уравнений движения.

Например, пусть Op[f(t)] – функция от f, полученная нелинейной операцией из f(t) и подвергаемая сдвигу. Тогда вариация δOp[f(t)] функции Op[f(t)], соответствующая вариационному изменению δf(t) функции f(t) и известному изменению динамики системы, [c.180] является линейной, но неоднородной относительно δf(t), хотя она нелинейна относительно f(t). Если теперь мы знаем некоторое решение f(t) уравнения

Op [f (t)] = 0

(4.55)

и изменим динамику системы, то получим линейное неоднородное уравнение для δf(t). Если

(4.56)

и сумма f(t)+δf(t) также периодическая, имея вид

,

(4.57)

то

.

(4.58)

Все коэффициенты в линейных уравнениях для δf(n) разлагаются в ряд по е iλnt, поскольку f(t) сама разложима в такой ряд. В результате получим бесконечную систему линейных неоднородных уравнений относительно δan+an, δλ и λ, и она может оказаться разрешимой методами Хилла. В этом случае можно, по крайней мере, представить, что, отправляясь от линейного (неоднородного) уравнения и понемногу снимая ограничения, мы можем прийти к решению весьма общей нелинейной задачи о релаксационных колебаниях. Однако это дело будущего.

Системы управления с обратной связью, рассмотренные в этой главе, и компенсационные системы, рассмотренные в предыдущей, до некоторой степени конкурируют между собой. Те и другие служат для приведения сложных отношений между входом и выходом эффектов к виду, близкому к простой пропорциональности. Как мы видели, система обратной связи дает большее: ее поведение сравнительно независимо от характеристики применяемого эффектора и изменений этой характеристики. Какой из двух методов управления лучше, зависит, следовательно, от того, насколько постоянна характеристика эффектора. Естественно предположить, [c.181] что могут быть случаи, когда выгодно сочетать оба метода. Для этого существуют разные способы.

Один из простейших показан на рис. 4. В этом случае всю систему обратной связи можно рассматривать как расширенный эффектор, и здесь не возникает ничего нового, исключая то, что компенсатор должен компенсировать величину, которая в некотором смысле является средней характеристикой системы обратной связи.

Рис. 4

Другая схема изображена на рис. 5. Здесь компенсатор и эффектор соединены в один расширенный эффектор. Это, вообще говоря, приводит к изменению максимально допустимой обратной связи, и нелегко сказать, насколько значительно можно повысить этот уровень таким путем. С другой стороны, при том же уровне обратной связи работа системы совершенно явно улучшится. Если, например, эффектор имеет существенно запаздывающую характеристику, то компенсатор должен быть упреждающим, или предсказывающим, устройством, рассчитанным на статистический ансамбль входного сигнала. Обратная связь, которую [c.182] можно назвать упреждающей, будет стремиться ускорить действие эффектора.

Рис. 5

Обратные связи подобного рода, несомненно, присутствуют в рефлексах человека и животных. При охоте на уток мы стремимся свести к минимуму не ошибку направления ствола относительно действительного положения цели, а ошибку направления ствола относительно предугадываемого положения цели. Всякая система управления зенитным огнем должна решать такую же задачу. Условия устойчивости и эффективности упреждающих обратных связей нуждаются в гораздо более тщательном исследовании, чем до сего времени.

Другой интересный вариант систем обратной связи – управление автомобилем на обледенелой дороге. Поведение водителя полностью определяется его знанием, что дорога скользкая, т.е. знанием рабочих характеристик системы автомобиль – дорога. Если он будет ждать, пока найдет эти характеристики, ведя автомобиль обычным способом, то машину занесет, прежде чем водитель опомнится. Поэтому он дает рулю последовательные быстрые толчки – не такие сильные, чтобы вызвать большое скольжение, но достаточные, чтобы его кинестетические ощущения дали ему знать, не грозит ли автомобилю забрасывание, соответственно этому он и регулирует свое вождение.

Этот метод управления, который можно назвать управлением с помощью информирующей обратной связи, нетрудно воплотить в форму механизма, и он может оказаться полезным на практике. Мы располагаем компенсатором для нашего эффектора, и этот компенсатор имеет характеристику, которая изменима извне. На приходящее сообщение накладывается слабый высокочастотный сигнал, и от выходного сигнала эффектора при помощи соответствующего фильтра отбирается некоторая часть той же высокой частоты. Исследуется амплитудно-фазовая зависимость между высокочастотным выходом и входом, чтобы найти рабочие характеристики эффектора. На основании этого изменяют соответствующим образом характеристики компенсатора. Структурная схема системы будет выглядеть примерно так, как на рис. 6.

Рис.6.

Этот вид обратной связи выгоден тем, что компенсатор можно отрегулировать так, чтобы обеспечить [c.183] устойчивость при постоянной нагрузке любого рода, и если характеристика нагрузки изменяется достаточно медленно, вековым, как мы сказали, образом, по сравнению с изменениями первоначального входного сигнала, а нагрузка замеряется точно, то система не будет склонна к колебаниям. Имеется много случаев, когда изменение нагрузки является вековым в этом смысле. Например, трение орудийной башни зависит от вязкости смазки, которая, в свою очередь, зависит от температуры, но вязкость не изменится заметным образом в течение нескольких поворотов башни.

Конечно, такая информирующая обратная связь будет работать хорошо только в том случае, когда характеристики нагрузки на высоких частотах такие же, как на низких, или дают верное отражение последних. Это часто имеет место, когда нагрузка, а значит, и эффектор зависят от сравнительно небольшого числа переменных параметров.

Информирующая обратная связь и приведенные выше примеры обратной связи с компенсаторами представляют лишь частные случаи весьма сложной теории, пока еще недостаточно разработанной. Вся эта область развивается чрезвычайно быстро и заслуживает того, [c.184] чтобы в ближайшем будущем на нее обратили гораздо больше внимания.

Прежде чем закончить главу, мы должны напомнить другое очень важное физиологическое применение принципа обратной связи. В многочисленных примерах так называемого гомеостаза мы встречаемся с тем фактом, что обратная связь не только участвует в физиологических явлениях, но и оказывается совершенно необходимой для продолжения жизни. Условия, при которых у высших животных возможна жизнь, особенно нормальная жизнь, довольно ограниченны. Изменение температуры тела на полградуса по Цельсию обычно есть признак болезни, а при длительном изменении температуры на пять градусов жизнь вряд ли возможна. Осмотическое давление крови и концентрация в ней водородных ионов должны поддерживаться в узких границах. Отбросы организма должны извергаться, прежде чем они достигнут токсической концентрации. Кроме того, у нас должно быть надлежащее количество лейкоцитов и химических агентов защиты от инфекции; скорость сердечных сокращений и кровяное давление должны быть не слишком высокими и не слишком низкими; цикл половой деятельности должен соответствовать потребностям воспроизведения рода; обмен кальция должен быть таким, чтобы кости не размягчались и ткани не кальцинировались и т.д. Одним словом, наше внутреннее хозяйство должно включать в себя целую батарею термостатов, автоматических регуляторов давления и тому подобных приборов – батарею, которой хватило бы на большой химический завод. Все это вместе и составляет наш гомеостатический механизм.

Гомеостатические обратные связи имеют одно общее отличие от обратных связей произвольных движений и обратных связей поз: они действуют медленнее. Изменения физиологического гомеостаза, вызывающие серьезное или постоянное нарушение в долю секунды, очень немногочисленны, и даже анемия головного мозга действует не столь стремительно. Поэтому нервные волокна предназначенные для гомеостатических связей, т.е. волокна симпатической и парасимпатической систем, часто лишены миэлиновой оболочки и, как известно, имеют значительно меньшую скорость передачи, чем волокна с миэлиновой оболочкой. Типичные [c.185] гомеостатические эффекторы – гладкие мышцы и железы – также действуют медленно по сравнению с поперечнополосатыми мышцами – типичными эффекторами произвольной деятельности и деятельности, связанной с положением тела. Многие сообщения гомеостатической системы передаются не по нервам, а по иным каналам, таким, как непосредственный анастомоз мышечных волокон сердца или химические вестники: гормоны, содержание углекислоты в крови и т.д. За исключением сердечной мышцы, эти каналы передают сообщения значительно медленнее, чем миэлинизированные нервные волокна.

Любой полный курс кибернетики должен включать в себя тщательный и подробный обзор гомеостатических процессов, которые во многих частных случаях обсуждались в литературе довольно подробно 5 . Но данная книга представляет собой более введение в предмет, нежели систематический трактат; теория же гомеостатических процессов требует слишком детального знакомства с общей физиологией, чтобы быть здесь к месту. [c.186]

Далее:
V. ВЫЧИСЛИТЕЛЬНЫЕ МАШИНЫ И НЕРВНАЯ СИСТЕМА

К оглавлению

ПРИМЕЧАНИЯ

1 Речь идет о точке (–1/λ, 0) на плоскости (u, v). – Прим. ред.
Вернуться к тексту

2 Кривая ρ1/3=cos φ/3 называется кэлиевой кривой 6-го порядка (по имени английского математика А. Кэли). И кардиоида, и кэлиева кривая 6-го порядка суть частные случаи так называемых синус-спиралей. – Прим. ред.
Вернуться к тексту

3 С учетом
– Прим. ред.
Вернуться к тексту

4 Poincare H. Les Methodes Nouvelles de la Mecanique Celeste. – Paris: Gauthier-Villars et fils., 1892–1899.
Вернуться к тексту

5 Cannon W. The Wisdom of the Body. – New York: W.W. Norton & Company, Inc., 1932; Henderson L.J. The Fitness of the Environment. – New York: The Macmillan Co., 1913.


V

Винер Н. Кибернетика, или управление и связь в животном и машине. – 2-е издание. – М.: Наука; Главная редакция изданий для зарубежных стран, 1983. – 344 с.

Красным шрифтом в квадратных скобках обозначается конец текста на соответствующей странице печатного оригинала данного издания

V. ВЫЧИСЛИТЕЛЬНЫЕ МАШИНЫ И НЕРВНАЯ СИСТЕМА

Вычислительные машины – это, коротко говоря, машины для записи чисел, производства действий над ними и выдачи результата в числовой форме. На простую задачу ясной и точной записи чисел приходится значительная доля стоимости вычислительной машины как в денежном выражении, так и с точки зрения затрат конструкторского труда. Простейшим решением будет, по-видимому, равномерная шкала с каким-либо указателем, движущимся вдоль нее. Если мы хотим записать число с точностью до 1/n, мы должны обеспечить возможность установки указателя с этой точностью в любой части шкалы. Другими словами, при количестве информации, равном log2n, каждое отдельное перемещение указателя должно заканчиваться с этой степенью точности, и стоимость записи будет выражаться как An, где A близко к константе. Вернее, поскольку после точного выделения п–1 частей точно определится и оставшаяся часть, стоимость записи количества информации I будет приблизительно равна

(5.01)

Разделим теперь эту информацию между двумя шкалами, градуированными каждая менее точно. Стоимость записи такой информации будет приблизительно равна

(5.02)

Если информация разделена между N шкалами, то стоимость будет близка к

(5.03)

Минимум достигается при

,

(5.04)

[c.187]

а если положить

,

(5.05)

то при

(5.06)

Последнее равенство выполняется тогда и только тогда, когда x=0, т.е. N=∞. Следовательно, чтобы стоимость хранения информации была наименьшей, N должно быть как можно больше.

Вспомним, однако, что 2 I/N обязано быть целым числом и что оно не может равняться единице; ведь в случае 2 I/N=1 мы имели бы бесконечно много шкал, каждая из которых не содержала бы информации. Наименьшее допустимое значение для 2 I/N равно 2; в этом случае число записывается на нескольких независимых шкалах, разделенных каждая на две равные части. Другими словами, мы представляем числа в двоичной системе на ряде шкал, где требуется лишь знать, что некоторая величина находится на одной из двух равных частей шкалы, и где вероятность неточного наблюдения шкалы сделана ничтожно малой. Другими словами, мы представляем v в виде

(5.07)

где каждое vn равно единице или нулю.

В настоящее время существует два основных типа вычислительных машин: 1) машины, подобные дифференциальному анализатору Буша 1 , которые принято называть аналоговыми машинами; 2) машины, подобные обычному арифмометру, которые мы называем цифровыми машинами. В первых – данные изображаются посредством измерений на какой-либо непрерывной шкале, вследствие чего точность машины определяется точностью градуировки шкалы; во вторых – данные изображаются серией выборов из нескольких возможностей, а точность определяется четкостью различения [c.188] отдельных возможностей, числом альтернатив при каждом выборе и числом сделанных выборов. Понятно, что, во всяком случае для точных вычислений, цифровые машины лучше, а из них лучше всего машины с двоичной шкалой, в которых при каждом выборе возникает лишь две альтернативы. Наше предпочтение машинам с десятичной шкалой обусловлено просто той исторической случайностью, что десятичная шкала, основанная на числе пальцев, уже была в употреблении, когда индусы сделали свое великое открытие роли нуля и преимуществ позиционной нотации. Сохранение десятичной системы оправдано лишь тогда, когда значительная часть выполняемой с помощью машины работы состоит в передаче ей чисел, записанных в традиционной десятичной форме, и в получении от нее чисел, которые должны записываться в той же традиционной форме.

Так в действительности и используется обычный арифмометр в банках, деловых конторах и различных статистических бюро. Но это не наилучший способ эксплуатации более крупных и более автоматических машин; ведь всякая вычислительная машина применяется именно потому, что машинные методы быстрее ручных. При любом комбинированном использовании вычислительных средств, как и при любой комбинации химических реакций, порядок постоянной времени всей системы определяется самым медленным звеном. Поэтому желательно по возможности исключить непосредственное участие людей из всякой сложной цепочки вычислений, оставив его только там, где оно совершенно неизбежно – в самом начале и в самом конце. При таком подходе выгодно иметь устройство для изменения системы счисления и применять его в начале и в конце цепочки, а все промежуточные операции производить по двоичной шкале.

В идеальную вычислительную машину все данные надо вводить сразу же в начале работы, и затем до самого конца она должна по возможности быть свободна от человеческого вмешательства. Это значит, что машина должна получить в начале работы не только все числовые данные, но и все правила их соединения, в виде инструкций на любую ситуацию, которая может возникнуть в ходе вычислений. Следовательно, вычислительной машине надо быть не только арифметической, [c.189] но и логической машиной и комбинировать возможности согласно систематическому алгорифму. Существует много алгорифмов, которые могли бы использоваться для комбинирования возможностей, но простейший из них известен как алгебра логики par excellence 2 , или булева алгебра. Этот алгорифм, подобно двоичной арифметике, основан на дихотомии, т.е. на выборе между “да” и “нет”, между пребыванием в классе и вне класса. Причины его превосходства над другими системами те же, что и причины превосходства двоичной арифметики над другими арифметиками.

Таким образом, все данные, числовые или логические, введенные в машину, имеют вид некоторого множества выборов между двумя альтернативами, а все операции над данными имеют вид приведения того или иного множества новых выборов в зависимость от того или иного множества прежних выборов. Когда я складываю два однозначных числа А и В, я получаю двузначное число, начинающееся с единицы, если А и В оба равны единице, а в остальных случаях начинающееся с нуля. Второй разряд есть единица, если А?В, и нуль, если А=В. Сложение чисел, имеющих более одного разряда, происходит по аналогичным, но более сложным правилам. Умножение в двоичной системе, как и в десятичной, можно свести к таблице умножения и к сложению чисел; правила умножения двоичных чисел изображаются очень простой таблицей:

(5.08)

Следовательно, умножение есть просто способ определения множества новых цифр по данным исходным цифрам.

С логической стороны, если О – отрицательное, а I – положительное решение, то всякий оператор может быть получен из трех операторов: отрицания, переводящего I в О и О в I; логического сложения, описываемого таблицей: [c.190]

(5.09)

и логического умножения, описываемого такой же таблицей, что и умножение чисел в системе (1, 0), а именно:

(5.10)

Таким образом, любая ситуация, возникающая при работе машины, требует лишь новых выборов между альтернативами I и О согласно фиксированной системе правил, связывающих их с ранее принятыми решениями. Иными словами, машина строится как комплект реле, имеющих каждое два состояния, скажем: “включено” и “выключено”, причем на каждом этапе работы каждое реле принимает положение, определяемое положениями некоторых или всех реле данного комплекта на предыдущем этапе. Эти этапы работы можно “синхронизировать” с помощью центрального импульсного устройства или нескольких импульсных устройств; или же действие каждого реле может быть задержано, пока все реле, которым нужно было действовать раньше, не совершат все необходимые операции.

В вычислительной машине могут применяться весьма разнообразные реле. Они могут быть чисто механическими или могут быть электромеханическими, как в случае соленоидного реле, где якорь остается в одном из двух возможных положений равновесия, пока соответствующий импульс не перебросит его в другое положение. Они могут быть чисто электрическими системами с двумя противоположными положениями равновесия; таковы газонаполненные и вакуумные лампы (последние являются гораздо более быстродействующими). Оба возможных состояния релейной системы могут быть устойчивы при отсутствии внешнего возмущения, или же одно может быть устойчивое, а другое – переходное. Во втором случае всегда, а в первом случае большей частью желательно иметь специальное устройство для хранения импульсов, которые должны [c.191] действовать через некоторое время в будущем, и избегать застопоривания системы, наступающего, когда одно из реле повторяет свои импульсы бесконечно. Но о проблеме памяти мы еще будем говорить дальше.

Достойно внимания, что нервные системы человека и животных, способные, как известно, совершать такие же действия, как и вычислительная система, содержат элементы, идеально приспособленные для работы в качестве реле. Речь идет о так называемых нейронах, или нервных клетках. Хотя под влиянием электрических токов они обнаруживают довольно сложные свойства, обычное их физиологическое действие очень близко к принципу “все или ничего”, т. е. они либо находятся в покое, либо, будучи возбуждены, проходят через ряд изменений, природа и интенсивность которых почти не зависят от раздражителя. Сначала наступает активная фаза, передаваемая от данного конца нейрона до другого с определенной скоростью; затем следует рефракторный период, когда нейрон не способен приходить в возбуждение, по крайней мере под действием нормального физиологического процесса. По окончании этого эффективного рефракторного периода нерв остается бездеятельным, но может быть снова приведен в возбуждение.

Таким образом, нерв можно уподобить реле с двумя существенными состояниями активности: возбуждением и покоем. За исключением тех нейронов, к которым сообщения поступают от свободных нервных окончаний или чувствительных концевых органов, каждый нейрон получает сообщения от других нейронов через точки контакта, называемые синапсами. Число синапсов у отдельных нейронов может изменяться от нескольких единиц до нескольких сотен. Состояние входных импульсов в различных синапсах в сочетании с предшествующим состоянием самого нейрона определяет, будет ли он возбуждаться или нет. Если он не находится в состоянии возбуждения или рефрактерности и число входных синапсов, пришедших в возбуждение в течение определенного, весьма короткого промежутка времени, превосходит определенный порог, то нейрон придет в возбуждение после некоторой, почти постоянной синаптической задержки.

Это, пожалуй, слишком упрощенная картина: “порог” [c.192] может зависеть не только от числа синапсов, но также от их “веса” и от их геометрической конфигурации относительно нейрона, для которого они служат входами;

с другой стороны, мы располагаем весьма убедительными доказательствами существования синапсов другой природы – так называемых “тормозящих синапсов”, которые совершенно не допускают возбуждения нейрона или, во всяком случае, повышают порог его возбуждения по сравнению с обычными синапсами. Ясно одно: некоторые комбинации импульсов от нейронов, синаптически соединенных с данным нейроном, будут вызывать его возбуждение, а другие – нет. Отсюда, конечно, не следует, что не может быть других, не нейронных, влияний, например гуморальной природы, порождающих медленные, вековые изменения в комбинациях входных импульсов, способных вызывать возбуждение.

Чрезвычайно важной функцией нервной системы и, как мы уже отмечали, столь же необходимой функцией вычислительных машин является память, т.е. способность сохранять результаты прежних действий для использования в будущем. Понятно, что память используется весьма разнообразно, и потому кажется маловероятным, чтобы какой-либо один механизм мог удовлетворить всем требованиям. Существует, с одной стороны, память, необходимая для выполнения текущего процесса, скажем умножения; в этом случае промежуточные результаты не имеют ценности после того, как процесс завершен, и рабочий аппарат должен освобождаться для дальнейшего использования. Такая память должна допускать быструю запись, быстрое считывание и быстрое стирание. С другой стороны, существует память, предназначенная служить архивом, или постоянными записями, машины или мозга и составлять основу всего будущего поведения, но крайней мере при выполнении данной программы.

Заметим, между прочим, что между способами применения мозга и машины имеется существенное различие: машина предназначена для многих последовательных программ, не связанных одна с другой или имеющих минимальную, ограниченную связь, и может быть очищена при переходе от одной программы к другой, тогда как мозг при естественном ходе вещей никогда не [c.193] очищается от своих прошлых записей. Поэтому мозг при нормальных условиях не является полным подобием вычислительной машины. Его деятельность можно скорее сравнить с выполнением вычислительной машиной одной заданной программы. Мы увидим дальше, что это обстоятельство имеет глубокое значение для психопатологии и психиатрии.

Возвращаясь к проблеме памяти, заметим, что хороший способ построить кратковременную память – это заставить последовательность импульсов циркулировать по замкнутой цепи до тех пор. пока последняя не будет очищена вмешательством извне. Весьма правдоподобно, что это и происходит в нашем мозгу при удержании импульсов, относящихся к так называемому “кажущемуся настоящему” 3 . Подобный метод осуществлен в некоторых вычислительных машинах или, по крайней мере, предложен для них. Желательно, чтобы такое запоминающее устройство удовлетворяло двум условиям: 1) импульс должен передаваться в среде, в которой не слишком трудно достичь значительного запаздывания; 2) импульс должен восстанавливаться возможно точнее, прежде чем присущие устройству погрешности размоют его слишком сильно. Первое условие исключает применение световой передачи или даже во многих случаях электрических цепей и благоприятствует той или иной форме упругих колебаний; такие колебания действительно использовались для создания задержек в вычислительных машинах. Если же применять электрические цепи. то на каждой ступени возможна лишь сравнительно короткая задержка; иначе, как всегда в линейной аппаратуре, искажения накапливаются и очень скоро становятся недопустимыми. Бороться с искажениями помогает другой прием: включаем где-нибудь в цикл реле, служащее не для повторения формы приходящего сообщения, а для передачи нового сообщения заданной формы. Это очень легко достигается в нервной системе, где, по существу, всякая передача связана в большей или меньшей степени с триггерным механизмом. В электротехнике давно известны приборы для этой цели, [c.194] применяемые в телеграфных схемах. Они получили название телеграфных повторителей. Применение их в качестве долговременной памяти весьма затрудняется тем, что они должны действовать безошибочно в течение огромного числа последовательных рабочих циклов. Тем замечательнее их успешное применение в приборе, сконструированном г-ном Вильямсом в Манчестерском университете. В этом приборе устройство такого рода с единичной задержкой порядка одной сотой доли секунды продолжало успешно работать в течение нескольких часов. Еще более замечательно то, что этот прибор предназначен для хранения не одного-единственного решения “да – нет”, а сразу тысяч таких решений.

Подобно другим устройствам, предназначенным для хранения большого числа решений, прибор работает по принципу развертки. Одним из простейших способов запасания информации в течение относительно короткого времени является использование заряда конденсатора. В сочетании с телеграфным повторителем это дает вполне удовлетворительный способ запоминания. Для полного раскрытия схемных возможностей, связанных с такой системой запасания, нужно переключать повторитель от одного конденсатора к другому последовательно и очень быстро. Обычные приспособления для таких переключении обладают механической инерцией и потому несовместимы с высокими скоростями. Гораздо лучше применять большое число конденсаторов, в которых одной пластиной служит небольшое количество металла, на-пыленное на диэлектрик, или же не идеально изолирующая поверхность самого диэлектрика, а подводкой к этим конденсаторам – пучок электронных лучей, который системой развертки перемещается по траектории, напоминающей траекторию плуга на вспахиваемом поле. Существуют различные реализации этого метода. В несколько ином виде он применялся фирмой “Радио Корпорейшен оф Америка” еще до его использования г-ном Вильямсом.

Названные методы запасания информации позволяют хранить сообщение довольно значительное время, хотя и не сравнимое со сроком человеческой жизни. Для более долговечной записи имеется широкий выбор возможностей. Помимо таких громоздких и медленных методов нестираемой записи, как перфорированные карты [c.195] и перфорированная лента, мы располагаем магнитной лентой с ее последними усовершенствованиями, в значительной мере устраняющими свойственное ей расплывание сообщений; мы располагаем фосфоресцирующими веществами; наконец, мы располагаем фотографией. Фотография действительно идеальна в отношении постоянства, а также кратковременности экспозиции, необходимой для записи наблюдения. Но она страдает двумя серьезными недостатками: 1) время проявления, хотя и уменьшенное до нескольких секунд, все же не настолько мало, чтобы фотографию можно было применять в качестве кратковременной памяти; 2) фотографическая запись не позволяет быстро стирать и быстро наносить новую запись. Фирма “Истмен” работает над этими проблемами, которые, по-видимому, не являются неразрешимыми и, возможно, уже решены в настоящее время.

Очень многие из упомянутых методов запасания информации обнаруживают одну и ту же важную физическую черту. Они, по-видимому, зависят от систем с высокой степенью квантового вырождения, или, иными словами, со многими видами собственных колебаний одной и той же частоты. Это заведомо справедливо в случае ферромагнетизма и справедливо также в случае материалов с чрезвычайно большой диэлектрической постоянной, особенно пригодных для конденсаторов. Фосфоресценция также представляет собой явление, связанное с большим квантовым вырождением, и подобный эффект наблюдается в фотографическом процессе, где многие вещества, используемые в качестве проявителей, обладают большим внутренним резонансом. Квантовое вырождение, по всей вероятности, связано с возможностью заставить малые причины вызывать значительные и постоянные следствия. Как мы уже видели в гл. II , многие проблемы метаболизма и воспроизведения имеют прямое отношение к веществам, обладающим большим квантовым вырождением. Вероятно, совсем не случайно, что здесь, в неживой среде, эти вещества оказываются связанными с третьим основным свойством живого вещества – способностью принимать и организовывать импульсы и заставлять их действовать на внешний мир.

Как мы видели, в фотографии и аналогичных процессах [c.196] сообщение может запасаться в форме постоянного изменения некоторых запасающих элементов. Чтобы запасенная информация вводилась обратно в систему, эти изменения должны воздействовать каким-то образом на сообщения, проходящие через систему. Один из простейших способов добиться этого – применить для постоянного запасания элементы, которые нормально участвуют в передаче сообщений и в которых запасание информации изменяет способ передачи ими сообщений на все будущее время. В нервной системе нейроны и синапсы являются как раз такими элементами, и вполне правдоподобно, что информация сохраняется в мозгу долгое время благодаря изменениям порогов нейронов, или, другими словами, благодаря изменениям проницаемости каждого синапса для сообщений. Многие из нас полагают, за неимением лучшего объяснения, что запасание информации в мозгу действительно может происходить таким образом. Легко представить себе такое запасание в форме открытия новых путей или разрыва старых. Кажется вполне установленным, что после рождения в мозгу не образуется новых нейронов. Возможно, хотя и не доказано, что не образуется также новых синапсов, и правдоподобна догадка, что основные изменения порогов в процессе запоминания суть их повышения. Если это так, то вся наша жизнь построена по принципу “Шагреневой кожи” Бальзака, и самый процесс обучения и запоминания истощает наши способности обучения и запоминания, пока жизнь не расточит наш основной капитал жизнеспособности. Очень может быть, что так оно и есть. Этим, возможно, объясняются некоторые явления старения. Впрочем, в целом старение – явление слишком сложное, чтобы его можно было объяснить только этим.

Мы уже говорили о вычислительной машине – и тем самым о мозге – как о логической машине. Полезно посмотреть, какой свет проливают на логику такие машины, естественные и искусственные. Здесь основной является работа Тьюринга 4 . Мы уже сказали раньше, [c.197] что machina rationatrix 5 есть не что иное, как calculus ratiocinator 6 Лейбница, снабженное двигателем; и как исчисление это явилось началом современной математической логики, так и технические разработки наших дней неизбежно должны пролить новый свет на логику. Современная наука является операциональной, т.е. она считает всякое утверждение по существу связанным с возможными экспериментами или наблюдаемыми процессами 7 . С этих позиций изучение логики должно свестись к изучению логической машины, нервной или механической, со всеми ее неустранимыми ограничениями и несовершенствами.

Некоторые читатели могут возразить, что тем самым логика сводится к психологии, а это науки явно разные. Последнее верно в том смысле, что многие психологические состояния и движения мысли не согласуются с канонами логики. В психологии многое чуждо логике, но – и это очень важно – всякая логика, имеющая для нас смысл, не может содержать ничего такого, чего человеческий разум, а следовательно, и человеческая нервная система не были бы способны объять. Всякая логика ограничена в силу ограничений человеческого ума, которым он подвержен в деятельности, именуемой логическим мышлением.

Например, в математике мы посвящаем много времени рассуждениям о бесконечности, но эти рассуждения и сопровождающие их доказательства в действительности не бесконечны. Всякое допустимое доказательство содержит лишь конечное число шагов. Правда. доказательство посредством математической индукции кажется содержащим бесконечное число шагов; это лишь видимость. На самом деле оно содержит лишь следующие шаги:

1) Рn есть предложение, связанное с числом n;
2) Рn доказано для n=1;
3) если Р n справедливо, то справедливо и Р n+1;
4) поэтому Р n справедливо для всякого положительного целого n. [c.198]

Конечно, где-то в наших логических посылках должна быть такая, которая бы оправдывала подобный вывод. Тем не менее математическая индукция, о которой мы говорим, весьма отлична от полной индукции по бесконечному множеству. Это относится и к более утонченным видам математической индукции, таким, как трансфинитная индукция, встречающаяся в некоторых математических дисциплинах.

В результате возникают весьма любопытные ситуации, когда мы можем, при достаточном времени и достаточных вычислительных средствах, доказать каждый отдельный случай теоремы Р n, но, не располагая систематическим способом объяснения этих доказательств в одном выводе, не зависящем от n, как это было в математической индукции, не можем доказать Р n для всех n. Возможность такого исхода признана в математике – дисциплине, столь блестяще развитой Гёделем и его школой.

Доказательство есть логический процесс, который должен привести к определенному заключению через конечное число шагов. Напротив, логическая машина, действующая по определенным правилам, не обязательно должна прийти когда-либо к заключению. Она может продолжать свою работу шаг за шагом, никогда не останавливаясь; при этом она будет либо совершать последовательность действий все увеличивающейся сложности, либо повторять один и тот же процесс, подобно вечному шаху в шахматах. Это действительно происходит в случае некоторых парадоксов Кантора и Рассела. Рассмотрим, например, класс всех классов, не являющихся членами самих себя. Будет ли этот класс членом самого себя? Если да, то он определенно не является членом самого себя; а если нет, он столь же определенно обязан быть членом самого себя. Машина для решения этого вопроса будет попеременно давать ответы “да”, “нет”, “да”, “нет” и т.д. и никогда не придет к равновесию.

Решение, некогда предложенное Бертраном Расселом для его парадоксов, состоит в том, что каждому утверждению приписывается особая величина, так называемый “тип”, позволяющая нам различать утверждения, на первый взгляд формально одинаковые сообразно природе предметов, к которым они относятся: являются [c.199] ли эти предметы “вещами” в простейшем смысле, классами “вещей”, классами классов “вещей” и т. д. Наш метод решения парадоксов также состоит в присвоении некоторого параметра каждому утверждению: этим параметром служит момент времени, в который оно высказано. В обоих случаях мы вводим папа-метр, который можно назвать параметром униформизации, и с его помощью устраняем двусмысленность, которая была обусловлена лишь пренебрежением этим параметром.

Мы видим, таким образом, что логика машины похожа на человеческую логику и, следуя Тьюрингу, можем использовать логику машины для освещения человеческой логики. Имеет ли машина другое, еще более яркое человеческое свойство – способность к обучению? Чтобы убедиться, что она может иметь даже и это свойство, рассмотрим два тесно связанных понятия: ассоциацию идей и условный рефлекс.

В английской эмпирической философской школе, от Локка до Юма, считалось, что содержание ума состоит из определенных элементов, которые Локк называл идеями, а позднейшие авторы – представлениями и впечатлениями. Предполагалось, что простые представления или впечатления находятся в чисто пассивном уме, не влияющем на содержащиеся в нем идеи, так же как чистая грифельная доска не влияет на символы, которые могут быть на ней начертаны. Предполагалось, что благодаря некоторой внутренней деятельности, не заслуживающей, впрочем, названия силы, эти идеи соединяются в группы по принципам сходства, смежности и причинной связи. Из этих принципов наиболее важным признавался принцип смежности. Предполагалось, что представления и впечатления, часто появлявшиеся вместе во времени или в пространстве, приобретают способность вызывать друг друга, так что появление одного вызывает появление всей группы.

Во всем этом налицо признание некоторой динамики, но идея динамики еще не проникла тогда из физики в биологические и психологические науки. Типичным биологом XVIII столетия был Линней, собиратель и классификатор, точка зрения которого прямо противоположна точке зрения современных эволюционистов, физиологов, генетиков и представителей экспериментальной [c.200] эмбриологии. По существу, при таком обилии материала, подлежащего исследованию, образ мыслей биологов того времени вряд ли мог быть иным. Точно так же в психологии понятие психического содержания преобладало над понятием психического процесса. Это вполне могло быть пережитком схоластического упора на различные субстанции в мире, где существительное было гипостазировано, а на глагол обращалось мало внимания. Тем не менее переход от этого статического образа мыслей к более динамической точке зрения современности, примером которой явилась работа Павлова, совершенно ясен.

Павлов работал гораздо больше с животными, чем с людьми, и занимался больше видимыми действиями, чем интроспективными состояниями ума. Он открыл, что наличие пищи вызывает у собак увеличенное выделение слюны и желудочного сока. Если собаке показывать какой-нибудь предмет вместе с пищей и только вместе с пищей, то вид этого предмета приобретает способность вызывать выделение слюны или желудочного сока даже в отсутствие пищи. Соединение по смежности, которое Локк интроспективно наблюдал для идей, здесь соответствует аналогичному соединению типов поведения.

Однако есть существенное различие между точками зрения Павлова и Локка, обусловленное тем, что Локк рассматривает представления, а Павлов – типы поведения. Реакции, которые наблюдал Павлов, направлены к тому, чтобы довести процесс до успешного завершения или предотвратить катастрофу. Выделение слюны важно для глотания и переваривания пищи, а избегание болезненного раздражения предохраняет животное от телесного повреждения. Таким образом, в условном рефлексе участвует элемент, который можно назвать аффективным тонусом. Этот тонус не обязательно связан с ощущениями удовольствия и боли, и, вообще, он не обязательно должен быть связан с выгодой для животного. Существенно следующее: аффективный тонус пробегает некоторую шкалу от отрицательного значения – “боли” – до положительного значения – “удовольствия”, и повышение аффективного тонуса, постоянное или в течение значительного времени, благоприятствует всем процессам, которые в это время совершаются в [c.201] нервной системе, и дает им вторичную способность повышать еще больше аффективный тонус, а понижение афективного тонуса стремится препятствовать всем процессам, происходящим в это время, и дает им вторичную способность понижать еще ниже аффективный тонус.

С биологической точки зрения, высокий аффективный тонус, естественно, должен иметь место в ситуациях, благоприятных для продолжения рода, хотя, быть может, и не для сохранения индивидуума, а низкий аффективный тонус – в ситуациях, неблагоприятных для продолжения рода, хотя, быть может, и не губительных для индивидуума. Всякая раса, не сообразующаяся с этим требованием, разделит участь Сдобной Бабки 8 Льюиса Кэрролла и неизбежно вымрет. Тем не менее даже у обреченной расы может функционировать действенный механизм, пока раса еще продолжается. Другими словами, даже самое самоубийственное распределение аффективного тонуса будет вызывать определенный тип поведения.

Заметим, что механизм аффективного тонуса сам является механизмом обратной связи. Его можно даже изобразить схемой, как показано на рис. 7.

Рис. 7

Здесь сумматор аффективного тонуса комбинирует аффективные тонусы от отдельных механизмов аффективного тонуса за короткий промежуток прошлого, действуя по определенным правилам, которые мы не будем указывать. Обратные провода от сумматора к отдельным механизмам аффективного тонуса служат для изменения внутреннего аффективного тонуса каждого процесса сообразно выходному сигналу сумматора, и эти изменения сохраняются до тех пор, пока они не будут изменены последующими сообщениями от сумматора. Обратные провода от сумматора к механизмам процессов служат для понижения порогов при повышении общего аффективного тонуса и для повышения их [c.202] при понижении общего аффективного тонуса. Они опять-таки производят долговременное воздействие, которое продолжается до тех пор, пока не будет изменено другим импульсом от сумматора. Однако это продолжающееся воздействие ограничено теми процессами, которые имеют место в момент прихода обратного сообщения, и точно так же ограничены воздействия на отдельные механизмы аффективного тонуса.

Этим, подчеркиваю, я не хочу сказать, что условно-рефлекторный процесс осуществляется согласно указанному здесь механизму; я лишь говорю, что он мог бы так осуществляться. Если, однако, принять этот или аналогичный механизм, то о нем можно сказать многое. Во-первых, этот механизм способен к обучению. Уже признано, что условный рефлекс является механизмом, способным к обучению, и этот вывод используется при исследовании поведения крыс в лабиринте. Для обучения нужно лишь, чтобы примененные поощрения и наказания имели соответственно положительный и отрицательный аффективный тонус. Так, наверное, и обстоит дело, и экспериментатор узнает характер этого аффективного тонуса на опыте, а не посредством лишь априорных соображений.

Значительный интерес представляет также то, что такой механизм посылает определенную группу сообщений [c.203] в нервную систему ко всем элементам, которые могут принять их. Мы имеем в виду обратные сообщения от сумматора аффективного тонуса и до некоторой степени также сообщения от механизмов аффективного тонуса к сумматорам. В действительности сумматор не обязательно должен быть отдельным элементом; он может представлять собой просто некоторый естественный комбинаторный эффект сообщений, приходящих от отдельных механизмов аффективного тонуса. Но такие сообщения “тем, кого это может касаться”, могут посылаться наиболее эффективно и с наименьшей стоимостью аппаратуры другими каналами, чем нервы. Подобно этому, обычная система связи на руднике может состоять из телефонной станции с соответствующей проводкой и аппаратами; но когда необходимо спешно вывести людей из рудника, мы не полагаемся на эту систему, а разбиваем трубку с меркаптаном 9 в вентиляционном ходе. Химические вестники, подобные меркаптану или, скажем, гормонам, проще всего и наиболее эффективно передают сообщение, не адресованное определенному получателю. А теперь я на минуту загляну в область, которая, я знаю, выглядит как чистая фантазия. Высоко эмоциональный и, следовательно, аффективный характер деятельности гормонов способен производить весьма сильные внушения. Отсюда не следует, что чисто нервный механизм сам по себе не способен к аффективному тонусу и обучению; но сказанное означает, что при исследовании этой стороны нашей психической деятельности мы не можем не замечать возможностей гормонной передачи сообщений. Было бы, пожалуй, слишком смело связывать эту мысль с тем, что в теориях Фрейда участвует как память – функция запасания нервной системы, – так и половая деятельность. Пол, с одной стороны, и все аффективные тонусы, с другой, весьма тесно связаны с гормонами. Это указание на значение пола и гормонов сделали мне д-р Дж. Леттвин и г-н Оливер Селфридж. Хотя в настоящее время нет достаточных доказательств в пользу такого предположения, в принципе его нельзя считать явно нелепым. [c.204]

В природе вычислительной машины нет ничего несовместимого с наличием и ней условных рефлексов. Вспомним, что действующая вычислительная машина не есть только набор реле и запоминающих устройств, поставленных конструктором. Действующая вычислительная машина несет в себе также содержание своих запоминающих устройств, а это содержание никогда полностью не очищается в ходе выполнения одной программы. Мы уже видели, что жизни индивидуума соответствует выполнение одной программы, а не все существование механической структуры вычислительной машины. Мы видели вероятность того, что в нервной вычислительной машине информация хранится в значительной мере через изменения проницаемости синапсов. Но вполне возможно построить искусственные машины, в которых информация будет запасаться таким же образом. Например, вполне возможно сделать так, чтобы сообщение, приходящее в запасающую систему, изменяло навсегда или на время сеточное смещение одной или нескольких электронных ламп и тем самым изменяло численное значение суммы импульсов, отпирающей лампу или несколько ламп.

Более подробное исследование обучающих устройств в вычислительных и управляющих машинах и их возможных применений – дело скорее инженера, чем такой предварительной книги, как эта. Остальную часть главы лучше, по-видимому, посвятить более разработанным и привычным применениям современных вычислительных машин. Одно из главных среди них – решение дифференциального уравнения в частных производных. Даже линейные дифференциальные уравнения в частных производных требуют для своей записи огромной массы данных, поскольку приходится давать точное описание функций двух и более переменных. Для уравнений гиперболического типа, таких, как волновое уравнение, обычно ставится задача решения уравнения при заданных начальных условиях. В этом случае можно идти постепенно, шаг за шагом, от начальных значений к результатам в любой позднейший момент. Сказанное применимо в основном и к уравнениям параболического типа. Для уравнений эллиптического типа” где обычно задаются граничные, а не начальные условия, естественные методы решения включают итеративный [c.205] процесс последовательного приближения. Этот процесс повторяется очень много раз подряд, и здесь почти не обойтись без очень быстрых методов, какие возможны в современной вычислительной технике.

Для нелинейных дифференциальных уравнений в частных производных мы лишены того, что имеем для линейных уравнений, – достаточно строгой, чисто математической теории. Здесь вычислительные методы важны не только для исследования частных случаев, но, как отмечал фон Нейман, должны помочь нашему ознакомлению с большим числом частных случаев, без чего мы вряд ли сможем сформулировать общую теорию. До некоторой степени такое ознакомление производилось с помощью весьма дорогого экспериментального оборудования, например с помощью аэродинамических труб. Именно этим способом мы познакомились со сложными свойствами таких явлений, как ударные волны, поверхности скольжения, турбулентность и т. п., для которых мы вряд ли можем дать надлежащую математическую теорию. Мы не знаем, сколько еще может быть неоткрытых явлений подобного характера. Аналоговые машины имеют несколько меньшую точность по сравнению с цифровыми и во многих случаях действуют настолько медленнее, что цифровые машины следует считать значительно более перспективными.

При применении этих новых машин становится все более очевидным, что они требуют специальных математических методов, совершенно отличных от тех, к которым прибегали в ручных расчетах или на малых машинах. Так, даже применение машин для вычисления определителей не очень высокого порядка или для решения системы 20- или 30-линейных уравнений связано с трудностями, не возникающими при изучении аналогичных задач более низкого порядка. Если не проявить особой тщательности при постановке задачи, эти трудности могут привести к тому, что в решении совершенно не будет значащих цифр. Излишне даже говорить, что тонкие, эффективные средства, подобные сверхбыстрой вычислительной машине, теряют силу, попадая в руки лиц, не имеющих достаточной технической квалификации для полного их использования. Сверхбыстрые вычислительные машины, конечно, не уменьшат [c.206] потребности в математиках, обладающих глубокими знаниями и надлежащими техническими навыками.

И при механическом, и при электрическом конструировании вычислительной машины следует иметь в виду несколько правил. Во-первых, сравнительно часто используемые механизмы, как, например, множительные или суммирующие устройства, должны представлять собой относительно стандартизированные узлы, приспособленные для одного частного применения, а механизмы, используемые реже, должны формироваться на время из элементов, пригодных также и для других целей. С этим тесно связано следующее соображение: в этих более общих механизмах компоненты должны использоваться в соответствии с их общими свойствами и их не должны назначать в какую-либо постоянную комбинацию с другими частями машины. Должно иметься какое-то устройство, подобное автоматической телефонной станции, которое будет искать свободные компоненты и соединители разного рода и включать их по мере необходимости. Это значительно снизит весьма высокие издержки, обусловленные наличием большого количества неиспользуемых элементов, которые не могут применяться, если не применяется весь узел. Мы увидим большую важность этого принципа при рассмотрении проблем нагрузки и перегрузки в нервной системе.

Наконец, я хотел бы указать, что большая вычислительная машина, будь то механическая или электрическая система или мозг, потребляет большое количество энергии, которая расходуется и рассеивается в виде тепла. Кровь, оттекающая от мозга, на долю градуса теплее, чем кровь, притекающая к нему. Никакая другая вычислительная машина не приближается по экономии энергии к мозгу. В большой установке, подобной машинам ЭНИАК или ЭДВАК, нити накала ламп потребляют количество энергии, измеряемое киловаттами, и, если не предусмотреть надлежащих вентилирующих и охлаждающих приспособлений, система может пострадать от перегрева, который в конце концов совершенно изменит параметры машины и нарушит ее работу. Однако энергия, расходуемая на отдельную операцию, ничтожно мала и не может никоим образом служить надлежащей мерой работы аппаратуры. Механический [c.207] мозг не выделяет мысль, “как печень выделяет желчь”, что утверждали прежние материалисты, и не выделяет ее в виде энергии, подобно мышцам. Информация есть информация, а не материя и не энергия. Тот материализм, который не признает этого, не может быть жизнеспособным в настоящее время. [c.208]

Далее:
VI. ГЕШТАЛЬТ И УНИВЕРСАЛИИ

К оглавлению

ПРИМЕЧАНИЯ

1 Journal of the Franklin Institute, разные статьи, начиная с 1930 г.
 Вернуться к тексту

2 По преимуществу, в собственном смысле. – Прим. ред.
Вернуться к тексту

3 Кажущееся, или психологическое, настоящее – наименьший промежуток времени, воспринимаемый субъектом как одна ситуация, одно переживание. – Прим. ред.
Вернуться к тексту

4 Turing A.M. On Computable Numbres, with an Application to the Entscheidungsproblem. // Proceedings of the London Mathematical Society. – Ser. 2. – 1936. – Vol. 42. – P. 230–265.
Вернуться к тексту

5 Думающая машина, рассуждающая машина (лат.) – Прим. ред.
Вернуться к тексту

6 Исчисление умозаключений. – Прим. ред.
Вернуться к тексту

7 Концепция операционализма, связываемая обычно с именем американского физика П. Бриджмена. – Прим. ред.
Вернуться к тексту

8 Сдобная Бабка – фантастическое насекомое из повести Л. Кэрролла “Алиса в Зазеркалье”. По-английски оно называется Bread-and-Butter-Fly, наш перевод этого названия взят из существующего русского перевода названной повести: Кэрролл Л. Алиса в Зазеркалье. – М.–П.: Изд-во Л.Д. Френкель, 1924. – Прим. ред.
 Вернуться к тексту

9 Меркаптан – спирт, в котором кислород замещен серой: жидкость с отвратительных запахом. – Прим. ред.


VI

Винер Н. Кибернетика, или управление и связь в животном и машине. – 2-е издание. – М.: Наука; Главная редакция изданий для зарубежных стран, 1983. – 344 с.

Красным шрифтом в квадратных скобках обозначается конец текста на соответствующей странице печатного оригинала данного издания

VI. ГЕШТАЛЬТ И УНИВЕРСАЛИИ 1

В предыдущей главе, в числе прочего, мы обсуждали, можно ли связать какой-либо нервный механизм с локковской теорией ассоциации идей. Согласно Локку, ассоциация идей основана на трех принципах: принципе смежности, принципе сходства и принципе причины и следствия. Третий принцип Локк и еще решительнее Юм сводят просто к постоянному сосуществованию, и, таким образом, он подпадает под первый принцип – смежности. Второй принцип – принцип сходства – заслуживает более детального рассмотрения.

Как мы узнаем индивидуальные черты человеческого лица в разных его положениях: в профиль, в три четверти или в анфас? Как мы узнаем в круге круг, большой ли он или маленький, далекий или близкий, расположен ли он перпендикулярно лучу зрения к своему центру и кажется нам действительно кругом или ориентирован иначе, выглядя эллипсом? Как мы видим лица животных и географические карты в облаках или в кляксах тестов Роршаха 2 ? Все эти примеры относятся к зрению, но аналогичные вопросы можно поставить и для других чувств; некоторые из них касаются связей между различными чувствами. Как мы перекладываем в слова крик птицы или стрекотание насекомого? Как узнаем осязанием, что монета круглая?

Ограничимся пока чувством зрения. Существенным фактором при сравнении форм различных предметов является, конечно, взаимодействие глаза и мышц: мышц, находящихся внутри глазного яблока; мышц, [c.209] двигающих глазное яблоко; мышц, двигающих голову; мышц, двигающих все тело в целом. И эта система зрительно-мышечной обратной связи существует в какой-то форме уже на такой низкой ступени животного царства, как плоские черви. У плоских червей отрицательный фототропизм – стремление избегать свет – регулируется, как полагают, балансом импульсов от двух глазных пятен. Соотношение этих импульсов действует на мышцы туловища, поворачивающие тело прочь от света, и в сочетании с общим импульсом поступательного движения приводит животное в наиболее темную область, ему доступную. Любопытно отметить, что пара фотоэлементов с соответствующими усилителями, мостик Уитстона для сравнения их выходных напряжений и еще одна пара усилителей, управляющих питанием двух электродвигателей двухвинтового механизма, обеспечивают нам весьма приличное отрицательное фототропическое управление для небольшой лодки. Было бы трудно или даже невозможно вместить этот механизм в такие габариты, чтобы его мог нести плоский червь; но здесь мы встречаем еще один пример истины, уже известной читателю: живые механизмы, как правило, имеют значительно меньшие размеры, чем механизмы, наиболее удобные для изготовления человеком, хотя, с другой стороны, применение электричества дает искусственному механизму громадное преимущество перед живым организмом в отношении скорости.

Пропуская все промежуточные стадии, переходим сразу к обратным связям между зрением и мышцами у человека. Некоторые из этих обратных связей имеют чисто гомеостатическую природу; так, зрачок расширяется в темноте и сокращается на свету, стремясь держать проникающий в глаз световой поток в более узких границах, чем было бы возможно без этого. Другие обусловлены тем, что человеческий глаз экономично ограничил свою способность наилучшего различения формы и цвета сравнительно небольшим желтым пятном сетчатки. Когда периферическим зрением уловлен какой-нибудь предмет, заметный своей яркостью, или световым контрастом, или цветом, или – и прежде всего – движением, рефлекторная обратная связь переводит его на желтое пятно. Эта обратная связь сопровождается сложной системой взаимозависимых [c.210] подчиненных обратных связей, которые стремятся свести направления обоих глаз в одну точку, чтобы предмет, привлекший внимание, находился в одной и той же части поля зрения того и другого глаза, и фокусировать хрусталики, чтобы очертания предмета были возможно более четкими. Эти действия дополняются движениями тела и головы, при помощи которых мы переводим предмет в центр поля зрения, если этого трудно достичь движениями одних глаз, или переводим в поле зрения предмет, лежащий вне его и воспринятый другим чувством. Если перед нами предметы, которые мы привыкли наблюдать в определенной угловой ориентации, – письмо, человеческие лица, пейзажи и т.п., – то посредством особого механизма мы стремимся также привести их в надлежащую ориентацию.

Все эти процессы можно резюмировать одной фразой: мы стремимся привести привлекший наше внимание предмет в нормальное положение и в нормальную ориентацию, чтобы создаваемый нами зрительный образ предмета менялся в возможно меньшем диапазоне. Это не исчерпывает процессов, связанных с восприятием формы и значения предмета, но, бесспорно, облегчает все дальнейшие процессы, служащие названной цели. Эти последние развертываются в глазу и в зрительной области коры головного мозга. Имеется немало данных, свидетельствующих о том, что на многих стадиях число нейронных каналов, участвующих в передаче зрительной информации, падает с каждым шагом процесса, а информация становится на один шаг ближе к той форме, в которой она используется и хранится в памяти.

Первый шаг в концентрации зрительной информации совершается при переходе от сетчатки к зрительному нерву. Заметим, что в желтом пятне сетчатки существует почти взаимно однозначное соответствие между палочками и колбочками, с одной стороны, и волокнами зрительного нерва, с другой, тогда как на периферии одно волокно зрительного нерва соответствует десяти и более концевым органам. Это вполне понятно, поскольку основное назначение периферических волокон состоит не столько в самом зрительном восприятии, сколько в уловлении предмета для центрирующего, фокусирующего и направляющего механизма глаза. [c.211]

Одним из самых замечательных явлений в зрении следует считать нашу способность узнавать контурный рисунок. Несомненно, контур человеческого лица имеет очень малое сходство с самим лицом в отношении цвета и распределения светотени, и тем не менее в нем очень легко узнать портрет данного человека. Наиболее правдоподобно объясняется это тем, что где-то в зрительном процессе подчеркиваются контуры, а значение других сторон образа уменьшается. Указанные процессы начинаются в самом глазу. Подобно всем органам чувств, сетчатка подвержена аккомодации; иначе говоря, действие постоянного раздражения уменьшает ее способность воспринимать и передавать раздражение. Аккомодация заметнее всего для рецепторов, воспринимающих внутреннюю часть большого скопления образов постоянного цвета и постоянной освещенности, так как даже неизбежные небольшие флюктуации фокуса и точки фиксации не меняют характера воспринимаемого изображения. Совершенно иначе обстоит дело на границе двух контрастирующих областей. В этом случае флюктуации вызывают смену одного раздражения другим, и эта смена, как мы видим в явлении остаточных образов, не только не приводит к истощению зрительного механизма из-за аккомодации, но вызывает повышение его чувствительности. Сказанное относится к контрасту между двумя соседними областями как по освещенности, так и по цвету. В объяснение этих фактов заметим, что три четверти волокон зрительного нерва реагируют только на “вспышку” освещения. Мы видим, таким образом, что глаз воспринимает наиболее сильные впечатления на границах и что всякий зрительный образ в некоторой мере является контурным.

Вероятно, этот эффект обусловлен не только периферическим восприятием. Известно, что в фотографии некоторые способы обработки пластинки увеличивают ее контрастность, и, конечно, такие явления, по существу нелинейные, могут иметь место и в нервной системе. Они сходны с процессами в телеграфном повторителе, о которых мы уже говорили. Как и там, впечатление – если оно не слишком размыто, вызывает новое впечатление стандартной четкости. Во всяком случае, эти явления уменьшают общее количество неиспользуемой информации, переносимой образом, и, вероятно, объясняют [c.212] собой частично то уменьшение количества передающих волокон, которое наблюдается на различных участках зрительной области коры.

Мы наметили, таким образом, ряд действительных или возможных этапов схематизации наших зрительных впечатлений. Мы центрируем изображения относительно фокуса внимания и сводим их более или менее к контурам. Затем их надо сравнить между собой или, во всяком случае, со стандартным изображением, хранимым в памяти, например с “кругом” или с “квадратом”. Это может быть сделано различными способами. Выше мы дали грубый набросок возможного механизма для локковского принципа ассоциации по смежности. Заметим, что принцип смежности в значительной степени покрывает также локковский принцип сходства. Мы часто наблюдаем различные стороны одного и того же предмета, когда приводим его к фокусу внимания, а также при других движениях, позволяющих нам видеть его то на одном, то на другом расстоянии, то под одним, то под другим углом. Это общий принцип, применимый не только к какому-то одному чувству и, несомненно, играющий важную роль при сравнении наших более сложных переживаний. Но, вероятно, ассоциация по смежности – не единственный процесс, формирующий наши специфически зрительные общие представления, или, как их называет Локк, “сложные идеи”. Зрительная область коры имеет настолько высоко организованное и специфическое строение, что трудно предположить, чтобы она действовала как подобный, крайне обобщенный механизм. Создается впечатление, что мы имеем здесь дело со специальным механизмом, представляющим собой не кратковременное соединение универсальных элементов, где части допускают взаимную замену, а постоянный субблок, подобный суммирующим и множительным устройствам вычислительной машины. Целесообразно поэтому рассмотреть, как может работать такой субблок и как нужно подойти к его проектированию.

Возможные перспективные преобразования предмета составляют группу в том смысле, как она определена в гл. II . Эта группа включает несколько подгрупп преобразований: аффинную группу, состоящую только из таких преобразований, которые не затрагивают [c.213] бесконечно удаленной области; однородные растяжения относительно данной точки, в которых сохраняется одна точка, направления осей и равенство масштабов во всех направлениях; преобразования, сохраняющие длину; вращения в двух или трех измерениях вокруг заданной точки; множество всех сдвигов и т.д. Упомянутые группы являются непрерывными группами, т.е. относящиеся к ним операции определяются значениями нескольких непрерывно изменяющихся параметров в соответствующем пространстве. Они образуют, таким образом, многомерные конфигурации в n-мерном пространстве и содержат подмножества преобразований, составляющие области в этом пространстве.

И как область на обычной двумерной плоскости покрывается в телевидении процессом развертки, позволяющим представить целое множество выборочных точек, распределенных более или менее равномерно по области, точно так же и любую область в групповом пространстве, включая само пространство, можно представить с помощью процесса групповой развертки. При таком процессе (он, конечно, применим к пространству не только трех измерений) сетка точек в пространстве обегается в одномерной последовательности, а точки этой сетки распределены так, что в некотором, соответственно определенном, смысле они подходят к каждой точке области. Таким образом, сетка будет содержать точки, сколь угодно близкие к любой выбранной точке. Если эти “точки” (или системы параметров) действительно используются для выбора соответствующих преобразований, то нетрудно видеть, что в результате применения этих преобразований к данной Фигуре мы сколь угодно приблизимся к любому преобразованию этой фигуры, осуществимому в данной групповой области. Если наша развертка достаточно мелка и преобразуемая область имеет максимальное протяжение средн всех областей, преобразуемых группой, то обегаемые при развертке преобразования дадут в результате область, покрывающую сколь угодно большую часть площади любого преобразования исходной области 3. [c.214]

Пусть теперь мы сравниваем некоторую область с другой фиксированной областью, взятой за эталон. Если на каком-либо этапе развертки группы образ сравниваемой области, полученный с помощью одного из развертываемых преобразований, совпадает с фиксированным эталоном в пределах допустимого расхождения, то это совпадение регистрируется, и обе области считаются подобными. Если такого совпадения не происходит ни на каком этапе развертки, области считаются неподобными. Этот процесс легко поддастся механизации и может быть использован для распознания формы фигуры, независимо от ее размеров и ориентации и от тех преобразований, которые могут быть в развертываемой групповой области.

Если эта область не составляет всей группы, то может оказаться, что область А будет подобна области В, область В будет подобна области С, но область А не будет подобна области С. Так бывает и в действительности. Фигура может не иметь сходства с такой же фигурой, но перевернутой, по крайней мере, не иметь его при первом впечатлении, в котором не участвуют процессы более высокого порядка. Однако на каждом этапе переворачивания может найтись достаточно соседних положений, представляющихся подобными. Образованные таким путем общие “представления” не являются совершенно различными, но незаметно переходят друг в друга.

Существуют и более тонкие способы использования групповой развертки при абстрагировании универсалий из группы преобразований. Рассматриваемые нами группы имеют “групповую меру” – плотность вероятности, которая зависит от самой группы и не меняется с умножением всех преобразований группы справа или слева на любое данное преобразование группы. Можно развертывать группу так, что для достаточно обширного класса групповых областей плотность развертки области (т.е. время, в течение которого переменный развертывающий элемент находится внутри области при полном развертывании группы) будет почти пропорциональна ее групповой мере. Пусть теперь, при такой равномерной развертке, мы встречаемся с величиной, зависящей от некоторого множества элементов S, преобразуемого группой, и пусть это множество S [c.215] преобразуется всеми преобразованиями группы. Обозначим через Q(S) величину, зависящую от S, и обозначим через TS образ множества S при преобразовании Т из нашей группы. Тогда при замене S на TS величина Q(S) примет значение Q(TS). Усредняя или интегрируя эту величину относительно групповой меры для группы преобразований Т, получим величину примерно такого вида:

(6.01)

где интегрирование производится по групповой мере. Величина (6.01) будет тождественна для всех множеств S, переходящих друг в друга при преобразованиях группы, т.е. для всех множеств S, имеющих в некотором смысле одну и ту же форму, один гештальт. Можно сравнивать формы приближенно, если интеграл в формуле (6.01) брать не по всей группе и если подынтегральная функция Q(TS) мала в отбрасываемой области. На этом мы простимся с групповой мерой.

В последние годы обратили внимание на проблему протезирования одного потерянного чувства с помощью другого. Наибольшей решительностью отличалась попытка создать читающие аппараты для слепых, снабженные фотоэлементами. Мы будем предполагать, что эти усилия ограничиваются печатным текстом, и даже одним шрифтом или немногими шрифтами. Будем также считать, что выравнивание страниц, центрирование строк, переход от одной строки к другой уже обеспечиваются вручную или, что вполне возможно, как-либо автоматически. Эти процессы, очевидно, соответствуют стадиям распознания зрительного образа, основанным на мышечных обратных связях и использовании нашего нормального центрирующего, ориентирующего, фокусирующего и конвергирующего аппарата. Далее встает проблема определения форм отдельных букв, над которыми последовательно проходит развертывающее устройство. Здесь предлагалось использовать фотоэлементы, расположенные в ряд по вертикали и соединенные каждый со звучащим прибором особого тона. Черный цвет букв может отмечаться либо отсутствием звука, либо звуком. Предположим, что выбрано второе, и вообразим себе три фотоэлектрических рецептора, один над другим. Пусть они изображают буквы в виде трех [c.216] нот гаммы, причем самая высокая нота соответствует верхнему фотоэлементу, а самая низкая – нижнему.

Тогда, например, заглавная буква F будет передана

звуком:

Заглавная буква Z будет передана звуком:

Заглавная буква О – звуком:

и т.д. С обычной нашей способностью к интерпретации читать такой слуховой код нетрудно – не труднее, чем, скажем, читать шрифт Брайля.

Но все зависит от одного условия – от надлежащего соотношения фотоэлементов с высотой букв. Даже при стандартном шрифте неизбежны значительные колебания в размерах букв. Поэтому желательно найти возможность растягивать или сжимать вертикальный масштаб развертки, чтобы привести образ данной буквы к стандарту. Мы должны иметь в своем распоряжении, в ручной или в автоматической форме, хотя бы некоторые преобразования из группы вертикальных растяжений.

Это можно сделать несколькими способами. Можно предусмотреть механическую вертикальную регулировку фотоэлементов. С другой стороны, можно взять достаточно большой вертикальный ряд фотоэлементов и менять распределение нот соответственно размеру шрифта, оставляя фотоэлементы, расположенные выше и ниже шрифта, немыми. Для этого можно, например, воспользоваться схемой с двумя комплектами соединительных линий. В этой схеме входные линии отходят от фотоэлементов и ведут к цепочке переключателей, все более и более расходясь в стороны, а выходами [c.217] служат вертикальные линия, как на рис. 8. Здесь одиночные линии – провода от фотоэлементов, двойные линии – провода к генераторам звука, кружки на пунктирных линиях – точки соединения входных и выходных, проводов, а сами пунктирные линии – провода, управляющие включением того или иного генератора. Это и есть упомянутое во введении устройство, которое спроектировал Мак-Каллох для регулировки своего аппарата по высоте шрифта. В первом варианте выбор пунктирных линий производился вручную.

Рис. 8

Именно эта схема, показанная д-ру фон Бонину, заставила его подумать о четвертом слое зрительной коры. Соединительные кружки напоминают собой тела нейронов этого слоя, расположенные подслоями с равномерно меняющейся горизонтальной плотностью и с протяженностью, меняющейся в противоположном направлении к плотности. Горизонтальные проводники возбуждаются, вероятно, в каком-то циклическом порядке. Весь механизм кажется вполне приспособленным для групповой развертки. Конечно, должен существовать какой-то процесс перераспределения во времени верхних выходов.

Итак, Мак-Каллох навел нас на мысль, что подобное устройство действительно используется в мозгу для обнаружения зрительных образов. В сущности, оно годится для групповой развертки любого рода. Нечто подобное происходит и в других органах чувств. Для уха переложение музыки с одного основного тона на другой есть не что иное, как сдвиг логарифма частоты, и, следовательно, может быть осуществлено посредством устройства групповой развертки. [c.218]

Устройство групповой развертки имеет, таким образом, вполне определенную, адекватную анатомическую структуру. Необходимое переключение может осуществляться через независимые горизонтальные проводники, по которым подаются импульсы, смещающие пороги каждого уровня как раз настолько, чтобы соответствующие клетки возбуждались при раздражении их входов. Хотя мы не знаем всех подробностей действия этого хозяйства, нетрудно вообразить возможный механизм, соответствующий такому анатомическому строению. Короче говоря, устройство групповой развертки вполне способно образовать своего рода постоянный субблок мозга, соответствующий суммирующим или множительным устройствам цифровой вычислительной машины.

Наконец, развертывающее устройство должно иметь собственный рабочий период, выделимый в общей работе мозга. Длительность этого периода должна соответствовать минимальному времени, необходимому для прямого сравнения форм у предметов разных размеров. Такое прямое сравнение возможно только между двумя предметами, не слишком отличающимися друг от друга по величине; в других случаях сравнение – продолжительный процесс, что свидетельствует о действии неспециализированного соединения универсальных элементов. Там, где прямое сравнение кажется возможным, оно как будто занимает время порядка одной десятой секунды. Таков же, видимо, порядок времени, необходимого для возбуждения всех слоев поперечных проводников в циклической последовательности.

Хотя этот циклический процесс может иметь местное происхождение, некоторые данные свидетельствуют о том, что существует значительный синхронизм между разными участками коры головного мозга, а это показывает, что процесс обусловлен каким-то синхронизирующим центром. Порядок частоты процесса соответствует ритму альфа-колебаний мозга, как видно из электроэнцефалограмм. Можно подозревать, что этот альфа-ритм связан с восприятием формы и носит характер ритма развертки, подобно ритму телевизионной аппаратуры. Он исчезает при глубоком сне; с другой стороны, он, как и следовало бы ожидать, маскируется и перекрывается другими ритмами, когда мы смотрим на [c.219] какой-либо предмет и наш ритм развертки действует подобно несущему колебанию для других ритмов и процессов. Альфа-ритм делается наиболее заметен, если бодрствовать с закрытыми глазами или же, не обращая взгляда ни на что в отдельности, пристально смотреть перед собой в пространство, как йог в состоянии отрешенности от внешнего мира 4 , когда альфа-ритм обнаруживает почти совершенную периодичность.

Мы видели, что задача протезирования органов чувств – задача замены информации, нормально поступающей от потерянного органа чувств, информацией от уцелевших органов чувств – имеет важное значение и не является заведомо неразрешимой. Особенно обнадеживающим является то обстоятельство, что память и ассоциативные зоны, нормально возбуждаемые одним внешним чувством, не являются замками с единственным ключом, но могут хранить впечатления, поступающие и от других чувств. Ослепший человек, в отличие от слепорожденного, не только сохраняет зрительные воспоминания, предшествующие потере зрения, но способен даже запасать осязательные и слуховые впечатления в виде зрительных образов. Ощупывая свой путь при движении по комнате, он может представлять себе, как она должна выглядеть.

Следовательно, часть его нормального зрительного механизма продолжает ему служить. С другой стороны, он потерял не только свои глаза, он потерял также возможность пользоваться той частью зрительной области коры, которую можно рассматривать как фиксированный блок, организующий зрительные впечатления. Его нужно снабдить не только искусственными зрительными рецепторами, но л искусственной зрительной корой, которая будет переводить световые впечатления, поступающие в его новые рецепторы, в форму, настолько близкую к нормальным выходным сигналам его зрительной коры, что предметы, обычно выглядящие одинаково, будут иметь теперь одинаковое звучание.

Отсюда ясно, что критерием возможности такой замены зрения слухом служит, по крайней мере частично, отношение между числом различимых зрительных образов и числом различимых слуховых образов на уровне [c.220] коры. Это – отношение количеств информации. Ввиду довольно сходной организации различных участков сенсорной коры оно не будет, вероятно, сильно отличаться от отношения площадей зрительной и слуховой областей коры, которое составляет 100:1. Если всю слуховую область коры использовать для зрения, то можно надеяться, что количество получаемой информации будет равно примерно одному проценту информации, поступающей через зрительные органы. С другой стороны, зрение обычно оценивается по относительному расстоянию, при котором получают определенную степень разрешения образов, и по такой оценке 10/100 зрения означает поток информации, равный примерно одному проценту нормального потока. Это очень плохое зрение, но, конечно, не слепота; люди с таким зрением могут не считать себя слепыми.

В другом направлении картина гораздо благоприятнее. Глаз может распознавать все звуковые оттенки, используя лишь один процент своих способностей, и сохранность зрения при этом будет составлять около 95/100, т.е. по существу оно будет совершенным. Итак, протезирование внешних чувств представляет собой весьма перспективную область работы. [c.221]

Далее:
VII. КИБЕРНЕТИКА И ПСИХОПАТОЛОГИЯ

К оглавлению

ПРИМЕЧАНИЯ

1 Универсалии – общие понятия, общие представления. – Прим. ред.
Вернуться к тексту

2 Тест Роршаха – предложенный швейцарским психиатром Германом Роршахом психологический тест-испытание, состоящий из 10 стандартных черных или цветных чернильных пятен. По тому, какие фигуры видит в них испытуемый, судят о его умственных наклонностях и личности. – Прим. ред.
Вернуться к тексту

3 В этой главе автор все время переходит от областей в групповом абстрактном пространстве к областям в физическом, зрительном пространстве и обратно. – Прим. ред.
Вернуться к тексту

4 Личное сообщение д-pa Уолтера из Бристоля (Англия).


VII

Винер Н. Кибернетика, или управление и связь в животном и машине. - 2-е издание. - М.: Наука; Главная редакция изданий для зарубежных стран, 1983. - 344 с.

Красным шрифтом в квадратных скобках обозначается конец текста на соответствующей странице печатного оригинала данного издания

VII. КИБЕРНЕТИКА И ПСИХОПАТОЛОГИЯ

Начиная эту главу, я должен сделать оговорку. С одной стороны, я не психопатолог и не психиатр и имею мало опыта в этой области, где опыт – единственный верный руководитель. С другой стороны, наши знания о нормальной работе мозга и нервной системы и тем более наши знания об отклонениях от нормы далеко еще не достигли такого совершенства, чтобы можно было полагаться на ту или иную априорную теорию. Поэтому я заранее отказываюсь от утверждений, что какие-либо конкретные психопатологические явления, например болезненные состояния, описанные Крепелином и его последователями, вызываются дефектами определенного рода в организации мозга как вычислительной машины. Те, кто пожелает сделать подобные выводы из изложенного здесь, будут действовать паевой страх и риск.

Однако понимание того, что мозг и вычислительная машина имеют много общего, может привести к новым ценным методам в психопатологии и даже в психиатрии. Эти сопоставления начинаются уже с самого, быть может, простого вопроса: каким образом мозг избегает грубых ошибок и неверно направленных действий при неисправности отдельных своих компонентов? Подобные вопросы в случае вычислительной машины имеют большое практическое значение, потому что здесь цепочка операций, занимающих каждая лишь долю миллисекунды, может длиться часы и дни. Цепочка вычислительных операций вполне может содержать 109 отдельных шагов. В этих условиях нельзя пренебрегать вероятностью того, что по меньшей мере одна операция будет идти неправильно, хотя надежность современной электронной аппаратуры далеко превзошла самые смелые ожидания. [c.222]

В обычных вычислениях, проводимых вручную или при помощи арифмометров, принято проверять каждый шаг, и когда обнаруживается ошибка, она локализируется обратным процессом, начинаемым с точки, где она замечена. Для того чтобы быстродействующей машине работать аналогичным образом, необходимо, чтобы проверка шла с такой же скоростью, как и само вычисление; в противном случае эффективная скорость машины снижается более медленным процессом проверки. К тому же, если заставить машину сохранять все промежуточные результаты вычислений, то ее сложность и размер возрастут недопустимо – вероятно, значительно больше, чем в два или три раза.

Гораздо лучший способ проверки, который обычно и применяется на практике, состоит в том, чтобы поручать проверку каждой операции одновременно двум или трем отдельным механизмам. В случае применения двух таких механизмов выдаваемые ими результаты автоматически сопоставляются между собой, и если есть расхождение, то все данные передаются долговременной памяти, машина останавливается, и оператор получает сигнал, что что-то не в порядке. Тогда оператор сравнивает результаты и, руководствуясь ими, находит неисправный элемент, например перегоревшую лампу, требующую замены. Если для каждого шага применяются три отдельных механизма, то, поскольку вероятность неисправности каждого отдельного механизма очень мала, практически всегда будет согласие между двумя из трех механизмов, которые и дадут искомый результат. В этом случае сопоставляющее устройство выдает в качестве правильного результат большинства, так что машину можно не останавливать; но вместе с тем дается сигнал, указывающий, где и каким образом результат меньшинства отличается от результата большинства. Если это произойдет в самом начале расхождения, то местоположение ошибки может быть указано очень точно. В хорошо спроектированной машине элементы не закрепляются за определенными шагами последовательности операций, а на каждом шаге производится поиск, подобно тому, как на автоматических телефонных станциях, и находится первый свободный элемент данного вида, который и включается в последовательность операций, Тогда устранение и [c.223] замена неисправных элементов не вызывают большой задержки.

Позволительно предположить, что, по меньшей мере, два элемента этого процесса представлены также в нервной системе. Вряд ли можно думать, что передача важного сообщения поручается одному нейронному механизму. Подобно вычислительной машине, мозг, по всей вероятности, действует согласно одному из вариантов знаменитого принципа, изложенного Льюисом Кэрроллом в “Охоте на снарка”1: “Что три раза скажу, тому верь”. Невероятно также, чтобы различные каналы, передающие информацию, проходили от одного своего конца до другого без всяких перекрестов. Гораздо вероятнее, что, когда сообщение достигает определенного уровня нервной системы, оно может оставить эту точку и направиться к следующей по одному или нескольким альтернативным членам так называемого “промежуточного комплекса”2. В некоторых частях нервной системы эта взаимозаменяемость может быть сильно ограничена или даже совершенно отсутствовать, и к ним, по-видимому, принадлежат такие высокоспециализированные участки коры головного мозга, как те, что служат внутренним продолжением органов чувств. Тем не менее принцип сохраняет силу и, вероятно, более всего в сравнительно неспециализированных областях коры, служащих для ассоциации и так называемых высших видов умственной деятельности.

До сих пор мы разбирали ошибки в работе мозга, которые являются нормальными и которые можно считать патологическими лишь в самом широком смысле слова. Обратимся теперь к ошибкам, носящим более очевидный патологический характер. Психопатология принесла разочарование инстинктивному материализму врачей, принимавших ту точку зрения, что всякое расстройство должно сопровождаться материальными повреждениями соответствующей ткани. Правда, такие специфические повреждения мозга, как травмы, [c.224] опухоли, тромбозы, и т.п., могут сопровождаться психическими симптомами, и некоторые психические болезни, как парез, представляют собой последствия общего соматического заболевания и связаны с патологическим состоянием мозговой ткани; но не существует способа опознания мозга шизофреника, принадлежащего строго к одному из типов, описанных Крепелином, или мозга больного маниакально-депрессивным психозом, или мозга параноика. Такие расстройства называются функциональными. Различие между функциональными и органическими расстройствами, по-видимому, противоречит догмату современного материализма, что всякое нарушение функции имеет какую-то физиологическую или анатомическую основу в соответствующих тканях.

Это различие между функциональными и органическими расстройствами находит себе в значительной мере объяснение в теории вычислительных машин. Как мы уже видели, мозгу, по крайней мере мозгу взрослого, соответствует не голая физическая структура вычислительной машины, но сочетание этой структуры с инструкциями, заданными в начале цепи операций, и со всей дополнительной информацией, запасаемой и приобретаемой извне во время выполнения этой цепи. Указанная информация хранится в какой-то физической форме – в форме памяти, но часть – в форме циркулирующих записей памяти, физическая основа которых исчезает, когда машина выключается или мозг умирает, а часть – в форме долговременных следов, сохраняемых способом, о котором можно только строить догадки, но, вероятно, также с физической основой, исчезающей после смерти. Мы еще не умеем распознавать по трупу, каким был порог данного синапса при жизни; и если бы даже умели, то у нас нет никакой возможности проследить цепь нейронов и синапсов, связанных с данным синапсом, и определить, какое мысленное содержание было записано в этой цепи.

Стало быть, нет ничего странного в том, чтобы рассматривать функциональные психические расстройства по существу как болезни памяти: циркулирующей информации, сохраняемой мозгом в активном состоянии, и долговременной проницаемости синапсов. Даже при более серьезных расстройствах, как парез, большинство [c.225] симптомов может быть вызвано не столько разрушением ткани и изменением синаптических порогов, сколько вторичными нарушениями связи, сопровождающими первичные повреждения: перегрузкой остающейся части нервной системы и посылкой сигналов по другим путям.

В системе, состоящей из большого числа нейронов, круговые процессы вряд ли могут быть устойчивыми в течение длительных промежутков времени. Либо они, как в случае памяти “кажущегося настоящего”, заканчивают свое течение, рассеиваются и угасают, либо они вовлекают в свою систему все больше и больше нейронов, пока не захватят чрезмерную долю всего нейронного материала. Это, по-видимому, и происходит в случае навязчивой тревоги, сопровождающей неврозы страха. В этом случае, возможно, у больного просто нет места, нет достаточного запаса нейронов для выполнения нормальных процессов мышления. При таких условиях деятельность мозга ослабевает, вследствие чего уменьшается загрузка еще не затронутых нейронов, и они тем скорее вовлекаются в этот распространяющийся процесс. Затем эти явления все глубже и глубже захватывают постоянную память, и патологический процесс, начавшийся па уровне циркулирующих записей, может повториться в более тяжелой форме на уровне постоянных записей. Так относительно тривиальное и случайное отклонение от устойчивого состояния способно вырасти в процесс, совершенно нарушающий нормальную психическую деятельность.

Патологические процессы относительно сходной природы известны и для вычислительных машин, механических и электрических. Зуб шестерни может соскользнуть таким образом, что сцепляющиеся с ним зубья не смогут переместить его вновь в нормальное положение, или быстродействующая электрическая вычислительная машина начнет повторять без конца один и тот же цикл операций. Эти случайности могут зависеть от какой-нибудь маловероятной мгновенной конфигурации системы и, будучи устранены, наверное, никогда не повторятся или повторятся очень нескоро. Тем не менее они на время выводят машину из строя.

Как мы поступаем в таких случаях с машиной? Прежде всего, пробуем очистить ее от всей информации в расчете на то, что, когда она начнет работать с [c.226] другими данными, нарушение не повторится. Если это не помогает и неисправность скрыта в таком месте, которое вообще или временно недоступно для очищающего механизма, мы встряхиваем машину или, если она электрическая, подаем на нее ненормально большой электрический импульс, надеясь в результате добраться до недоступной части и перебросить ее в такое состояние, при котором неправильная работа прекратится. Если и это не помогло, то мы можем отсоединить неправильно работающую часть, так как не исключено, что оставшаяся часть будет достаточна для наших целей.

Но, кроме смерти, нет ни одного нормального процесса, который бы полностью очищал мозг от всех прошлых впечатлений, а после смерти мозг нельзя заставить действовать снова. Из всех нормальных процессов всего ближе к непатологическому очищению сон. Как часто бывает, что наилучший способ избавиться от тяжелого беспокойства или умственной путаницы – это переспать их! Однако сон не очищает памяти от более глубоких воспоминаний, да сильная тревога и не даст заснуть по-настоящему. Поэтому мы часто бываем вынуждены прибегать к более сильным вмешательствам в работу памяти. Сильнейшее из них – хирургическое воздействие на мозг, после которого остается постоянное повреждение, увечье и ограничение способностей пострадавшего, поскольку центральная нервная система млекопитающих, по всей вероятности, совсем не обладает способностью регенерации. Основное хирургическое вмешательство, практиковавшееся до сих пор, – это префроптальная лоботомия, т.е. удаление или изоляция части лобной доли коры3. Недавно лоботомия была довольно модной, вероятно, по той причине, что она облегчает содержание психических больных под надзором сторожей. Да позволено мне будет заметить мимоходом, что умерщвление больных еще больше облегчило бы надзор за ними! Однако префронтальная лоботомия, по-видимому, действует на навязчивое состояние не тем, что помогает больному разрешить мучащие его вопросы, а тем, что повреждает [c.227] или уничтожает способность к продолжительной тревоге, называемую, по терминологии другой профессии, совестью. В общем случае лоботомия, насколько можно судить, ограничивает все виды циркулирующей памяти и связанную с ними способность сохранять в уме ситуацию, уже не присутствующую в настоящем.

Различные виды лечения шоком – электрический ток, инсулин, метрозол – представляют собой не столь сильные средства, но оказывают весьма сходное действие. Они не разрушают мозговой ткани или, по крайней мере, по идее не должны разрушать ее, но они оказывают определенно вредное влияние на память. Поскольку дело касается циркулирующих записей и поскольку последние бывают особенно повреждены в случаях недавнего расстройства и вряд ли заслуживают сохранения, лечение шоком следует определенно предпочесть лоботомии; но оно не всегда свободно от вредных влияний на постоянную память и на личность. При настоящем положении вещей лечение шоком представляет собой второй насильственный, не вполне изученный, не вполне контролируемый способ прервать душевный порочный круг. Тем не менее следует признать, что во многих случаях лечение шоком – лучшее, что мы можем в настоящее время сделать.

Лоботомия и лечение шоком – это такие методы, которые по своей природе более пригодны для действия на порочные циркулирующие записи и навязчивые состояния, чем на глубже расположенные постоянные записи, хотя не исключено, что они могут оказывать некоторое действие и на последние. Как было сказано выше, при душевных расстройствах давнего происхождения постоянная память нарушается столь же сильно, как и циркулирующая. Мы, по-видимому, не располагаем никаким чисто фармацевтическим или хирургическим средством для дифференцированного воздействия на постоянную память. Вот тут-то и выступает на сцену психоанализ и подобные ему психотерапевтические меры. Идет ли речь о психоанализе в ортодоксальном понимании Фрейда, или в измененном понимании Юнга и Адлера, или о психотерапии, совсем не основанной на психоанализе, лечение всегда основывается на том представлении, что: 1) хранимая в уме информация расположена на нескольких уровнях доступности и [c.228] гораздо богаче и разнообразнее, нежели информация, доступная непосредственному самонаблюдению – интроспекции – без помощи специальных методов; 2) она существенно зависит от аффективных переживании, которые мы не всегда можем обнаружить таким самонаблюдением, – либо потому, что они никогда не были явно выражены на языке взрослых, либо потому, что они были подавлены определенным психическим механизмом, аффективным, но, вообще говоря, непроизвольным; 3) содержание этих сохраненных переживаний, а также их аффективный тонус обусловливают во многом нашу последующую психическую деятельность, иногда патологическим образом.

Метод психоанализа состоит в последовательном применении ряда средств для обнаружения и истолкования этих скрытых воспоминаний; больного заставляют осознать их истинное значение и благодаря этому осознанию изменяют если не содержание воспоминаний, то, по крайней мере, сопровождающий их аффективный тонус, уменьшая тем самым их вредное действие. Все это вполне согласуется с точкой зрения, принятой в настоящей книге. Это, возможно, объясняет также, почему в некоторых случаях рекомендуется совместное применение лечения шоком в психотерапии, куда входит физическая или фармакологическая терапия для устранения реверберации в нервной системе и психологическая терапия для долговременной памяти, которая без такого вмешательства могла бы восстановить изнутри порочный круг, разорванный шоком.

Мы уже упоминали о проблеме нагрузки нервной системы. Многие авторы, и в частности Д'Арси Томпсон4, отмечали, что для всякой формы организации существует верхняя граница ее размера, выше которой ока не будет действовать. Так, размер организма насекомого ограничен длиной трахеи, при которой воздух может попадать через дыхальца путем непосредственной диффузии к дышащим тканям; сухопутное животное не может иметь больший вес, чем позволяют его ноги и другие органы, соприкасающиеся с землей; размер дерева ограничен механизмом переноса воды и [c.229] солей от корней к листьям и продуктов фотосинтеза от листьев к корням и т.д. То же самое наблюдается в технических сооружениях. Высота небоскребов ограничена тем, что если она превысит некоторый предел, то для верхних этажей потребуется шахта лифта, которая займет слишком большую часть поперечного сечения нижних этажей. Наилучший подвесной мост, который можно построить из материалов данной упругости, рухнет от собственного веса, если его пролет превысит некоторый предел, а при еще большем пролете рухнет от собственного веса любая конструкция, построенная из данного материала или материалов. Размер телефонной станции, построенной по жесткому, не допускающему расширения плану, также ограничен, и инженеры-телефонисты исследовали это ограничение весьма подробно.

В телефонной системе существенным ограничивающим фактором служит относительное время, в течение которого абонент не может получить нужного ему соединения. 99-процептная вероятность успешного вызова, конечно, удовлетворит самых требовательных; 90 процентов успешных вызовов, вероятно, достаточно для того, чтобы вести свои дела довольно удовлетворительно, 75-процентная вероятность уже вызывает досаду, но все же позволяет кое-как вести дела; если же половина вызовов неудачна, то абоненты начнут требовать снятия своих телефонов. Но это лишь общие цифры. Если вызовы проходят через “ отдельных ступеней коммутации и вероятности отказа независимы и одинаковы на всех ступенях, то для того, чтобы получить общую вероятность успешного вызова, равную р, вероятность успешного соединения на каждой ступени должна составлять р1/n. Следовательно, чтобы получить 75-процентную вероятность соединения после пяти ступеней, мы должны иметь приблизительно 95-процентную вероятность успеха на ступень. Чтобы получить 90 процентов успешных вызовов, мы должны иметь 98 процентов успешных соединений па каждой ступени. Чтобы получить 50-процентную вероятность, нужно иметь вероятность успеха на каждой ступени в 87 процентов. Мы видим, что чем больше ступеней, тем быстрее обслуживание становится очень плохим после того, как превышен некоторый критический уровень вероятности неуспеха отдельного [c.230] вызова, и тем быстрее оно становится очень хорошим после того, как вероятность неуспеха опустилась ниже этого критического уровня. Таким образом, система автоматической коммутации, состоящая из многих ступеней и рассчитанная на определенную вероятность отказа, не обнаруживает явных признаков неблагополучия, пока нагрузка не дойдет до критической точки, после чего эта система совершенно распадается и образуется катастрофический затор.

Человек имеет наиболее развитую нервную систему из всех живых существ, и его поведение, вероятно, определяется наиболее длинными из эффективно действующих нейтронных цепей. Если он надламывается глубоко и катастрофически, то это должно означать, что он выполнял сложные действия очень уж близко к грани перегрузки. Перегрузка может возникать различным образом: вследствие избытка передаваемых сообщений, физической потери каналов связи или чрезмерного занятия каналов такой нежелательной нагрузкой, как циркулирующие записи памяти, усиливающиеся до превращения в навязчивые идеи. Во всех подобных случаях внезапно наступает момент, когда для нормальных видов нагрузки не будет хватать каналов, и тогда перед нами психическое расстройство, доходящее нередко до помешательства.

Указанное расстройство действует сперва на способности или операции, в которых участвуют наиболее длинные цепи нейронов. Есть серьезное основание для отождествления этих процессов с теми, которые мы обычно называем высшими. Известно, что повышение температуры почти до физиологических границ облегчает выполнение большей части, если не всех, нейронных процессов; эффект тем заметнее, чем выше процесс, приблизительно соответствуя нашей обычной оценке “ранга” процессов. Но любое облегчение процессов в единичной системе нейрон – синапс становится кумулятивным, когда нейрон соединен последовательно с другими нейронами. Поэтому степень усиления процесса при повышении температуры может служить грубой мерой длины участвующей в нем нейронной цепи.

Мы видим, таким образом, что большая длина нейронных цепей человеческого мозга по сравнению с мозгом животных объясняет, почему психические расстройства [c.231] у человека наиболее заметны и, вероятно, наиболее распространены. Вопрос допускает и другой, более специфический подход. Рассмотрим сначала два геометрически подобных мозга с одним и тем же отношением весов серого и белого вещества и с линейными размерами, относящимися как А:В. Пусть объем клеток серого вещества и поперечное сечение волокон белого вещества у первого и второго мозга одни и те же5. Тогда отношение числа клеток в обоих случаях равно А3:В3, а отношение числа длинных соединительных лилий равно А2:В2. Это значит, что при одинаковой плотности процессов в клетках плотность процессов, протекающих в волокнах, будет для большого мозга в А:В раз больше, чем для малого мозга.

Сравнивая человеческий мозг с мозгом других млекопитающих, мы видим, что первый отличается гораздо большей рельефностью поверхности. Относительная толщина серого вещества примерно одинакова в обоих случаях, но человеческий мозг имеет гораздо более развитую систему извилин и борозд. Это равносильно увеличению количества серого вещества за счет белого вещества. Внутри извилин белое вещество уменьшается главным образом из-за уменьшения длины волокон, а не их числа, поскольку противоположные склоны извилины ближе между собой, чем на мозге того же размера, но – с гладкой поверхностью. С другой стороны, для соединительных линий между разными извилинами расстояние, которое они должны пройти, только увеличивается вследствие рельефности мозга. Можно думать, что человеческий мозг оказывается достаточно эффективным, когда дело касается коротких соединительных линий, но не слишком надежным, когда затронуты длинные магистральные пути. Это значит, что в случае перегрузок первыми будут нарушены процессы, в которых участвуют удаленные друг от друга части мозга. Таким образом, при помешательстве наименее устойчивыми оказываются процессы, захватывающие несколько центров, т.е. ряд различных двигательных процессов и значительное число ассоциативных процессов. Именно [c.232] эти процессы обычно относятся к высшим. Таким образом, мы получаем еще одно подтверждение нашей как будто оправдываемой опытом уверенности, что при помешательство прежде всего страдают высшие процессы.

Существуют некоторые указания на то, что длинные пути в мозгу обнаруживают тенденцию пролегать совершенно вне полушарий головного мозга и идти через низшие центры. На это указывает тот факт, что при перерезке некоторых длинных петель белого вещества в полушариях головного мозга наблюдаются совершенно незначительные повреждения, как будто эти поверхностные соединения настолько недостаточны, что обеспечивают лишь небольшую часть необходимых связей.

В свете этого интересно рассмотреть явления право-и леворукости и преобладания (доминирования) полушарий. Подобная асимметрия функций, по-видимому, встречается и у других млекопитающих, хотя у них она менее заметна, отчасти, вероятно, потому, что для выполнения задач им не требуется такая организация и умение. Однако разница в ловкости мышц правой и левой стороны даже у других приматов, по-видимому, меньше, чем у человека. Праворукость нормального человека, как хорошо известно, обычно сочетается с преобладанием левой стороны мозга, а леворукость меньшинства людей – с преобладанием правой стороны мозга. Иначе говоря, функции головного мозга распределены неравномерно между двумя полушариями, и одно из них – преобладающее – сосредоточивает львиную долю высших функций. Правда, многие существенно двусторонние функции, например связанные с полями зрения, представлены каждая в своем полушарии, хотя это справедливо отнюдь не для всех двусторонних функций. Однако большинство “высших” областей находится исключительно в преобладающем полушарии. Например, у взрослого серьезное повреждение второстепенного полушария оказывает значительно меньшее действие, чем аналогичное повреждение преобладающего полушария. У Пастера на сравнительно раннем этапе его карьеры случилось кровоизлияние в правой стороне мозга, после чего у него остался небольшой левосторонний паралич – гемиплегия. После смерти мозг его был исследован, и обнаружилось, что у Пастера было [c.233] настолько серьезное повреждение правой стороны мозга, что, как говорили, после этого повреждения “у него оставалась лишь половина мозга”. У него были серьезные поражения теменной и височной области. Тем не менее после этого повреждения Пастер сделал некоторые из своих самых значительных открытий. У взрослого правши подобное повреждение левой стороны, почти наверно, было бы роковым и привело бы пострадавшего к животному состоянию, к состоянию умственной и нервной инвалидности.

Было замечено, что в раннем детстве такое повреждение мозга производит гораздо меньшее действие; тяжелое поражение преобладающего полушария впервые шесть месяцев жизни может привести к тому, что его место займет другое полушарие, и пострадавший будет отклоняться от нормы гораздо меньше, чем если бы повреждение произошло в более позднем возрасте. Это вполне согласуется с тем, что нервная система в первые недели жизни вообще очень гибка, но позже быстро становится жесткой. Возможно, что при отсутствии таких серьезных повреждений преобладание правой или левой стороны в очень раннем детстве может довольно легко меняться. Но задолго до школьного возраста природная асимметрия рук и преобладание одного полушария устанавливаются на всю жизнь. Раньше считали, что леворукость является серьезной помехой для жизни в обществе. Поскольку большинство инструментов, школьных парт и спортивных принадлежностей рассчитано, главным образом, на праворуких, леворукость действительно представляет некоторое неудобство. Кроме того, в прежние времена на нее смотрели с той суеверной неприязнью, которую вызывали всякие мелкие отклонения от общечеловеческой нормы, как, скажем, родимые пятна или рыжие волосы. Многие по различным побуждениям пытались – и даже успешно – изменять леворукость своих детей воспитанием, хотя, конечно, не могли изменить физиологическую основу – преобладание правого полушария. Во многих случаях люди с искусственно развитым левым полушарием страдали заиканием и другими дефектами речи, чтения и письма в такой степени, что это преграждало им путь к нормальной деятельности.

Мы видим, по крайней мере, одно возможное [c.234] объяснение явления. Развивая вторую руку, частично развивали ту часть второго полушария, которая заведует выученными движениями, например письмом. Но поскольку выполнение этих движений находится в очень тесной связи с чтением, речью и другими видами деятельности, локализированными в преобладающем полушарии, нейтронные цепи, участвующие в подобных процессах, должны переходить из одного полушария в другое и обратно, а в более сложных процессах они должны совершать этот переход по нескольку раз. Но число прямых соединений между полушариями – комиссур – в таком большом мозгу, как человеческий, настолько мало, что прямые соединения приносят немного пользы, и связь между полушариями должна осуществляться по путям, проходящим через мозговой ствол. Эти окольные пути мало изучены, но, бесспорно, они очень длинные, редкие и могут прерываться. Поэтому процессы, связанные с речью и письмом, легко могут быть нарушены при заторе в нервной системе и тогда заикание – совершенно естественная вещь.

Таким образом, человеческий мозг, вероятно, уже слишком велик, чтобы он мог эффективно использовать все средства, которые кажутся наличными анатомически. У кошки разрушение преобладающего полушария, по-видимому, производит меньший ущерб, чем у человека, а разрушение второстепенного полушария – больший. Во всяком случае, у кошки распределение функций между полушариями гораздо равномернее. Выигрыш, достигнутый человеком благодаря большему размеру и большей сложности мозга, частично сводится на нет тем обстоятельством, что за один раз можно эффективно использовать лишь часть мозга. Возникает любопытная мысль, что, быть может, мы стоим перед одним из тех природных ограничений, когда высококвалифицированные органы достигают уровня нисходящей эффективности и в конце концов приводят к угасанию вида. Быть может, человеческий мозг продвинулся так же далеко по пути к этой губительной специализации, как большие носовые рога последних титанотериев. [c.235]

Далее:
VIII. ИНФОРМАЦИЯ, ЯЗЫК И ОБЩЕСТВО

К оглавлению

ПРИМЕЧАНИЯ

1 “Охота на снарка” (“The Hunting of the Snark”) – поэма Льюиса Кэрролла, где фигурирует придуманное им фантастическое морское чудовище снарк. – Прим. ред.
Вернуться к тексту

2 Промежуточный комплекс (internuncial pool) – группа взаимодействующих промежуточных (вставочных) нейронов. – Прим. ред.
Вернуться к тексту

3 Эта операция известна также под названием префронтальной лейкотомии. – Прим. ред.
Вернуться к тексту

4 Thompson D'Arcy. On Growth and Form, Amer. ed.– New York: The Macmillan Co., 1942.
Вернуться к тексту

5 Серое вещество мозга образуется телами и отростками нейронов (нервных клеток), а белое – нервными волокнами, т.е. частями аксонов (длинных отростков нейронов), покрытыми белой миэлиновой оболочкой. – Прим. ред.


VIII

Винер Н. Кибернетика, или управление и связь в животном и машине. - 2-е издание. - М.: Наука; Главная редакция изданий для зарубежных стран, 1983. - 344 с.

Красным шрифтом в квадратных скобках обозначается конец текста на соответствующей странице печатного оригинала данного издания

VIII. ИНФОРМАЦИЯ, ЯЗЫК И ОБЩЕСТВО

Идея организации, элементы которой сами суть малые организации, не является чем-то новым и необычным. Свободные федерации древней Греции, Священная Римская империя и современные ей аналогичные феодальные государства, Швейцарская Конфедерация, Королевство Нидерландов, Соединенные Штаты Америки и другие Соединенные Штаты, расположенные южнее, Союз Советских Социалистических Республик – все это примеры иерархий организаций в политической сфере. Левиафан Гоббса, Человек-Государство, составленный из меньших людей, есть иллюстрация той же идеи ступенью масштаба ниже, а воззрение Лейбница на живой организм как на некое сложное целое, где другие живые организмы (например, кровяные тельца) ведут собственную жизнь, представляет дальнейший шаг в этом направлении.

По существу, это лишь философское предвосхищение клеточной теории, согласно которой большинство животных и растений небольшого размера и все животные и растения больших размеров состоят из единиц – клеток, которые обладают многими, если не всеми свойствами независимых живых организмов. Многоклеточные организмы могут быть сами составными элементами организмов более высокой ступени. Так, физалия (“португальский кораблик”) представляет собой сложную структуру дифференцированных кишечнополостных полипов, в которой отдельные особи претерпели различные видоизменения, чтобы служить целям питания, опоры, передвижения, выделения и воспроизведения колонии как целого. [c.236]

Строго говоря, такая физически объединенная колония не ставит перед нами более глубоких философских проблем организации, чем те, какие возникают на низших уровнях индивидуальности. Совсем иначе обстоит дело с человеком и другими общественными животными – стадами павианов или скота, колониями бобров, пчелиными ульями, осиными гнездами, муравейниками. По степени целостности жизнь сообщества может вполне приближаться к уровню, характерному для поведения отдельной особи; но особь обычно наделена фиксированной нервной системой, с постоянными топографическими отношениями между элементами и постоянными соединениями, а сообщество состоит из особей, находящихся между собой в изменяющихся пространственно-временных отношениях и не имеющих постоянных, неразрывных физических соединений. Нервная ткань пчелиного улья – это лишь нервная ткань отдельных пчел. Как же пчелиный улей может действовать согласованно и организованно, приспособляясь к весьма изменчивым условиям? Очевидно, секрет состоит во взаимном общении членов улья.

Сложность и содержание этого взаимного общения могут быть весьма различными. У человека оно охватывает все дебри языка и литературы и еще очень многое. У муравьев оно, вероятно, сводится почти полностью к нескольких запахам. Весьма маловероятно, что муравей может отличить одного муравья от другого. Он, конечно, может отличить муравья из своего муравейника от муравья из чужого муравейника и будет сотрудничать с первым и стремиться уничтожить второго. В рамках нескольких внешних реакций подобного рода ум муравья, по-видимому, почти такой же шаблонный, жесткий, как его скованное хитином тело. Этого и следовало ожидать заранее от животного, у которого стадия роста ив значительной степени стадия обучения строго отделены от стадии зрелости. Единственное средство связи между муравьями, которое можно проследить, является столь же общим и ненаправленным, как гормонная система связи внутри организма. Действительно, обоняние, представляющее собой одно из химических внешних чувств, общее и ненаправленное, можно уподобить воздействиям гормонов внутри организма.

Заметим мимоходом, что мускус, цибет, бобровая [c.237] струя и другие сексуально возбуждающие вещества можно рассматривать как общественные, внешние гормоны, необходимые (особенно у животных, ведущих одинокую жизнь) для соединения полов в соответствующие периоды и служащие для продолжения рода. Этим я не хочу сказать, что действие названных веществ в организме, после того как они попали в орган обоняния, является только гормонным, а не действием на нервную систему. Трудно представить, как оно может быть чисто гормонным при тех малых количествах, какие уже могут быть восприняты животными; с другой стороны, мы слишком мало знаем о действии гормонов, чтобы отрицать возможность гормонного действия ничтожно малых количеств таких веществ. Кроме того, длинные скрученные кольца атомов углерода, обнаруженные в мусконе и цибетоне, не требуют большой перестройки, чтобы превратиться в группы сросшихся колец, характерные для половых гормонов, некоторых витаминов и некоторых канцерогенных веществ. Я не стремлюсь высказать определенное мнение по этому вопросу и оставляю приведенные выше замечания как интересную спекуляцию.

Запахи, которые воспринимает муравей, по-видимому, вызывают у него весьма стандартное поведение, но ценность, которую может иметь для переноса информации такой простои раздражитель, как запах, зависит не только от информации, непосредственно переносимой раздражителем, но и от всей нервной конструкции передатчика и приемника раздражителя. Допустим, я нахожусь в лесах вдвоем со смышленым дикарем, который не может говорить на моем языке и на языке которого я тоже не могу говорить. Даже без какого-либо условного языка знаков, известного нам обоим, я могу многое узнать от него. Мне нужно лишь быть особенно внимательным в те моменты, когда он обнаруживает признаки волнения или интереса. Тогда я должен посмотреть вокруг, особенно в направлении его взгляда, и запомнить все, что увижу или услышу. Не пройдет много времени, как я открою, какие предметы представляются важными для него, – не потому, что он сообщил мне о них словами, но потому, что я сам их заметил. Иначе говоря, сигнал, лишенный внутреннего содержания, может приобрести для моего спутника смысл по тому, что [c.238] наблюдает он в данный момент, и может приобрести для меня смысл по тому, что наблюдаю я в данный момент. Способность дикаря замечать моменты моего особенно активного внимания сама по себе образует язык, возможности которого столь же разнообразны, так и диапазон впечатлений, доступных нам обоим. Таким образом, общественные животные могут иметь активные, разумные, гибкие средства связи задолго до появления языка.

Какие бы средства ни имела раса или биологический вид, всегда можно определить и измерить количество информации, которое может получить эта раса, и отличить его от количества информации, доступной для особи. Конечно, никакая информация, доступная для особи, не может быть также доступной для расы, если она не видоизменяет поведения особи по отношению к другой особи, а это поведение не имеет значения для расы, если другие особи не могут отличить его из других форм поведения. Итак, является ли некоторая информация расовой или исключительно индивидуальной, зависит от того, приводит ли она к такой форме деятельности особи, которую другие члены расы могут распознать как отличающуюся от других форм деятельности, в том смысле, что она в свою очередь изменяет их деятельность, и т.д.

Я говорил о расе. Это в действительности слишком широкий термин для сферы действия большинства типов общественной информации. Собственно говоря, сообщество простирается лишь до того предела, до которого простирается действительная передача информации. Можно дать некоторую меру сообщества, сравнивая число решений, поступающих в группу извне, с числом решений, принимаемых в группе. Мы измеряем тем самым автономию группы. Мера эффективной величины группы – это тот размер, который она должна иметь, чтобы достичь определенной установленной степени автономии.

Группа может иметь больше или меньше групповой информации, чем ее члены. Группа необщественных животных, временно соединенных, имеет очень мало информации, если даже ее члены как индивидуумы имеют много информации. Это происходит потому, что лишь [c.239] очень немногое из того, что делает отдельный член группы, бывает замечено другими членами группы и оказывает на них влияние, которое распространялось бы и дальше по группе. С другой стороны, человеческий организм содержит, по всей вероятности, намного больше информации, чем какие-либо из его клеток. Таким образом, между количеством информации, имеющейся у расы, племени или сообщества, и количеством информации, имеющейся у особи, не обязательно должно быть прямое или обратное соотношение.

Как и в случае особи, доступ к информации, которая имеется у расы в данный момент, может потребовать специальных усилий. Известно, что при слишком большом объеме библиотек их работа затрудняется, что науки доходят до такой специализации, при которой специалист часто ничего не знает вне своей узкой специальности. Д-р Ванневар Буш предложил применять механические устройства для поисков нужного материала в больших массивах материалов. Такие устройства, вероятно, приносят пользу, но их применение ограничено невозможностью подвести ту или иную книгу под какую-либо необычную рубрику без того, чтобы кто-нибудь предварительно не установил применимость этой рубрики к данной книге. В том случае, когда темы, рассматриваемые в двух книгах, близки по методике и основным идеям, но относятся к совершенно различным областям, рубрикация потребует человека с почти лейбницианской универсальностью.

В связи с вопросом об эффективном количестве общественной информации следует отметить как один из самых поразительных фактов в жизни государства, что в ней крайне мало действенных гомеостатических процессов. Во многих странах распространено мнение, признанное в Соединенных Штатах официальным догматом, что свободная конкуренция сама является гомеостатическим процессом, т.е. что на вольном рынке эгоизм торговцев, каждый из которых стремится продать как можно дороже и купить как можно дешевле, в конце концов приведет к устойчивой динамике цен и будет способствовать наибольшему общему благу.

Это мнение связано с очень “утешительным” [c.240] воззрением, что частный предприниматель, стремясь обеспечить свою собственную выгоду, является в некотором роде общественным благодетелем и поэтому заслуживает больших наград, которыми общество его осыпает, К сожалению, факты говорят против этой простодушной теории. Рынок – игра, находящая свое подобие в семейной игре, известной под названием “монополия”1. Она строго подчинена общей теории игр, которую разработали фон Нейман и Моргенштерн. Эта теория основана на допущении, что на любой стадии игры каждый игрок, исходя из доступной ему информации, играет согласно вполне разумной стратегии, которая в конце концов должна обеспечить ему наибольшее математическое ожидание выигрыша. Это – рыночная игра, в которую играют вполне разумные и совершенно беззастенчивые дельцы. Даже при двух игроках теория сложна, хотя она приводит часто к выбору определенного направления игры. Но при трех игроках во многих случаях, а при многих игроках в подавляющем большинстве случаев результат игры характеризуется крайней неопределенностью и неустойчивостью. Побуждаемые своей собственной алчностью, отдельные игроки образуют коалиции; но эти коалиции обычно не устанавливаются каким-нибудь одним определенным образом и обычно кончаются столпотворением измен, ренегатства и обманов. Это точная картина высшей деловой жизни и тесно связанной с ней политической, дипломатической и военной жизни. В конце концов даже самого блестящего и беспринципного маклера ждет разорение. Но допустим, что маклерам это надоело и они согласились жить в мире между собой. Тогда награда достанется тому, кто, выбрав удачный момент, нарушит соглашение и предаст своих партнеров. Здесь нет никакого гомеостаза. Мы должны проходить циклы бумов и спадов в деловой жизни, последовательную смену диктатуры и революции, войны, в которых все теряют и которые столь характерны для современности.

Конечно, рисуемый фон Нейманом образ игрока как [c.241] вполне разумной и совершенно беззастенчивой личности представляет абстракцию и искажение действительности. Редко можно встретить, чтобы большое число вполне разумных и беспринципных людей играло вместе. Там, где собираются мошенники, всегда есть дураки; а если имеется достаточное количество дураков, они представляют собой более выгодный объект эксплуатации для мошенников. Психология дурака стала вопросом, вполне достойным серьезного внимания мошенников. Вместо того, чтобы добиваться своей конечной выгоды, подобно игрокам фон Неймана, дурак действует так, что его образ действий в общем можно предсказать в такой же степени, как попытки крысы найти путь в лабиринте. Одна политика обмана – или, точнее, заявлений, безразличных к истине, – заставит его покупать определенную марку папирос, другая побудит его, как надеется партия, голосовать за определенного кандидата – любого кандидата – или принять участие в политической охоте за ведьмами. Иллюстрированная газета будет продаваться благодаря некоторой точно установленной смеси религии, порнографии и псевдонауки. Комбинация заискивания, подкупа и устрашения заставит молодого ученого работать над управляемыми снарядами или атомной бомбой. Для определения рецептов этих смесей имеется механизм радиоопросов, предварительных голосований, выборочных обследований общественного мнения и других психологических исследований, объектом которых является простой человек; и всегда находятся статистики, социологи и экономисты, готовые продать свои услуги для этих предприятий.

К счастью для нас, эти торговцы ложью, наживающиеся на людском легковерии, еще не дошли до такого совершенства, чтобы все происходило по их желанию, потому что люди не бывают только дураками или мошенниками. Средний человек достаточно разумен по отношению к вещам, представляющимся его непосредственному вниманию, и достаточно альтруистичен там, где дело касается общественного блага или индивидуальных страданий, которые он видит собственными глазами. В небольшой сельской общине, существующей достаточно долго, чтобы в ней сложились более или менее одинаковые уровни понимания и поведения, существуют вполне достойные уважения нормы [c.242] попечения об обездоленных, управления дорогами и другими общественными средствами, терпимости к тем, кто лишь один-два раза нарушил общественные законы. Как бы то ни было, нарушители находятся здесь, и остальная община должна жить с ними и впредь. С другой стороны, в такой общине человеку не годится быть выше своих соседей. Всегда есть средства заставить его почувствовать силу общественного мнения. С течением времени он обнаружит, что оно является столь вездесущим, столь непререкаемым, столь ограничивающим и подавляющим, что он вынужден будет оставить общину, чтобы защитить себя.

Таким образом, небольшие, тесно спаянные сообщества обладают высокой степенью гомеостаза, будут ли это культурные сообщества в цивилизованной стране или селения первобытных дикарей. Какими бы странными и даже отталкивающими не казались нам обычаи многих варварских племен, эти обычаи, как правило, имеют вполне определенную гомеостатическую ценность, объяснение которой является одной из задач антропологов. Лишь в большом сообществе, где Господа Действительного Положения Вещей предохраняют себя от голода споим богатством, от общественного мнения – тайной и анонимностью, от частной критики – законами против клеветы и тем, что средства связи находятся в их распоряжении, – лишь в таком сообществе беззастенчивость может достигнуть высшего уровня. Из всех этих антигомеостатических общественных факторов управление средствами связи является наиболее действенным и важным.

Один из выводов настоящей книги состоит в том, что всякий организм скрепляется наличием средств приобретения, использования, хранения и передачи информации. В обществе, слишком большом для прямого контакта между его членами, эти средства суть пресса (книги и газеты), радио, телефонная связь, телеграф, почта, театр, кино, школы и церковь. Помимо своего непосредственного значения как средств связи все они служат другим, вторичным целям. Газета – средство рекламы и средство наживы для ее владельца, так же, как кино и радио. Школа и церковь не только убежище ученого и святого, но также жилище воспитателя и [c.243] епископа. Книга, не приносящая прибыли ее издатели, вероятно, не будет издана и, конечно, не будет переиздана.

В таком обществе, как наше, открыто основанном на купле и продаже, в котором все природные и человеческие ресурсы рассматриваются как полная собственность первого встречного дельца, достаточно предприимчивого, чтобы их использовать, эти вторичные стороны средств связи все более вытесняют их основное назначение. Этому способствует само развитие и распространение средств связи. Сельская газета может по-прежнему использовать собственных корреспондентов для сбора сплетен по деревням, но она покупает свои общенациональные известия, своя синдицированные сенсации, свои политические мнения в виде готового “котельного железа”2. Доход радио зависит от рекламодателей, и, как и везде, кто платит, тот и распоряжается. Большие информационные агентства стоят слишком дорого для издателя с небольшими средствами. Книгоиздатели издают в основном книги в расчете на какой-нибудь книжный клуб3, который может закупить целиком огромный тираж. Президент колледжа и епископ, даже если они лишены личного честолюбия, управляют дорогостоящими учреждениями и должны искать деньги там, где они имеются.

Итак, повсюду на средства связи налагается тройное ограничение: исключение менее выгодных средств в пользу более выгодных; то обстоятельство, что средства связи находятся в руках очень ограниченного класса богатых людей и потому, естественно, выражают мнения этого класса; и, наконец, то обстоятельство, что средства связи, как один из основных путей к политической и личной власти, привлекают прежде всего всех тех, кто стремится к такой власти. Та система, которая больше всех других должна способствовать [c.244] общественному гомеостазу, попадает прямо в руки тех, кто больше всего заинтересован в игре за власть и деньги, в игре которая, как мы видели, является одним из основных антигомеостэтических факторов в обществе. Неудивительно поэтому, что большие сообщества, подверженные этому подрывному влиянию, имеют гораздо меньше общественно доступной информации, чем малые сообщества, не говоря уже об отдельных людях, из которых состоят все сообщества. Подобно волчьей стае – будем надеяться, все же в меньшей степени – государство глупее, чем большинство его членов.

Это противоречит мнению, весьма распространенному среди руководителей предприятий, руководителей больших лабораторий и тому подобных лиц, которое гласит, что поскольку сообщество больше индивидуума, то оно и умнее. Отчасти это мнение вызвано лишь детским восхищением перед тем, что велико и обильно. В некоторой мере оно вызвано пониманием возможностей большой организации для свершения благих дел. Однако в значительной мере оно поддерживается лишь корыстными побуждениями и жаждой богатства.

Имеется другая группа – тех, кто не видит ничего хорошего в анархии современного общества и под влиянием оптимистического ощущения, что ведь должен же быть какой-нибудь выход, слишком высоко оценивает возможные гомеостатические факторы в обществе. Как бы мы ни симпатизировали этим людям и как бы глубоко ни чувствовали эмоциональную дилемму, перед которой они находятся, мы не можем придавать слишком большого значения этому направлению мыслей, подсказанному желанием. Их мысли – это мысли мышей из басни, захотевших повесить колокол на шею кошке, чтобы знать о ее приближении. Без сомнения, было бы очень приятно для нас, мышей, если бы хищные кошки мира сего носили такие колокола; но кто возьмется это сделать? Кто гарантирует нам, что вся власть не попадает снова в руки тех, кто больше всего жаждет ее?

Я упоминаю этот вопрос ввиду значительных и, как я думаю, напрасных надежд, которые возлагали некоторые из моих друзей на общественную действенность новых направлений мысли, связанных с содержанием этой книги. Они убеждены, что наша способность управлять [c.245] окружающей нас материальной средой намного обогнала нашу способность управлять окружающей нас общественной средой и понимать ее. Поэтому они считают, что основная задача ближайшего будущего – распространить на области антропологии, социологии и экономики методы естественных наук с целью достижения таких же успехов в социальных областях. От убеждения в том, что это необходимо, они переходят к убеждению в том, что это возможно. Я утверждаю, что в этом отношении они обнаруживают чрезмерный оптимизм и непонимание существа всякого научного достижения.

Все большие успехи точных наук связаны с такими областями, где явление отделено достаточно резко от наблюдателя. Мы видели на примере астрономии, что такое отделение может быть следствием огромного масштаба наблюдаемых явлений по сравнению с человеком, когда самые большие человеческие усилия, не говоря о простом созерцании, не могут произвести сколько-нибудь заметного впечатления на мир небесных светил. Правда, в современной атомной физике, науке о невыразимо малом, все, что мы делаем, будет оказывать влияние на многие отдельные частицы и это влияние будет достаточно велико с точки зрения такой частицы. Но мы не живем в масштабе изучаемых частиц ни во времени, ни в пространстве, и события, которые могут иметь величайшее значение с точки зрения наблюдателя, соответствующего масштабу существования частиц, представляются нам – хотя и с некоторыми исключениями, как, например, при опытах в камере Вильсона, – лишь как средние массовые эффекты, в которых участвуют огромные совокупности частиц. При исследовании этих эффектов те промежутки времени, с которыми мы имеем дело, весьма велики с точки зрения отдельной частицы и ее достижений, и наши статистические теории имеют более чем достаточную основу. Итак, мы слишком малы, чтобы влиять на движение звезд, и настолько велики, что можем интересоваться лишь массовыми действиями молекул, атомов и электронов. В обоих случаях наша связь с изучаемыми явлениями настолько слаба, что мы можем учитывать се лишь в общих чертах, хотя эта связь может быть и не столь слабой, чтобы ею совсем пренебрегать. [c.246]

В общественных науках связь между наблюдаемым явлением и наблюдателем очень трудно свести к минимуму. С одной стороны, наблюдатель может оказывать значительное влияние на явление, привлекшее его внимание. При всем уважении к разуму, умению и честности намерений моих друзей-антропологов, я не могу поверить, что любое исследованное ими сообщество останется тем же самым после этого исследования. Не один миссионер, приводя первобытные языки к письменной форме, закреплял в качестве вечных законов таких языков плоды своего собственного непонимания. В общественных обычаях народа много такого, что рассеивается и искажается при первом же обследовании. В несколько другом смысле, чем обычно принято, можно сказать: traduttore traditore 4.

С другой стороны, ученый-социолог не может взирать на свои объекты с холодных высот вечности и вездесущности. Возможно, существует массовая социология человеческих инфузорий, наблюдаемых подобно популяциям дрозофил в сосуде; но в этой социологии мы, эти самые человеческие инфузории, не особенно заинтересованы. Мы не очень интересуемся подъемами и падениями, радостями и страданиями человечества sub specie aeternitatis 5 . Антрополог описывает обычаи, относящиеся к жизни, воспитанию, деятельности и смерти людей, имеющих в общем такой же масштаб жизни, как и его собственный. Экономиста, главным образом, интересует предсказание таких экономических циклов, которые протекают менее чем за одно поколение или, по крайней мере, отражаются на человеке различным образом в различные периоды его жизни. Теперь мало таких политических философов, которые старались бы ограничить свои исследования миром платоновских идей. Другими словами, в общественных науках мы имеем дело с короткими статистическими рядами и не можем быть уверены, что значительная часть наблюдаемого нами не создана нами самими. Исследование фондовой биржи, вероятно, перевернет всю фондовую биржу. Мы слишком хорошо настроены на объекты нашего [c.247] исследования, чтобы представлять из себя хорошие зонды. Короче говоря, будут ли наши исследования в общественных науках статистическими или динамическими – а они должны быть и теми и другими, – они могут иметь точность лишь до очень небольшого числа десятичных знаков и в итоге никогда не доставят нам такого количества проверяемой, значащей информации, которое было бы сравнимо с тем, что мы привыкли ожидать в естественных науках. Мы не можем позволить себе пренебрегать социальными науками, но не должны строить преувеличенных надежд на их возможности. Нравится ли это нам или нет, но многое мы должны предоставить “ненаучному”, повествовательному методу профессионального историка. [c.248]

ЗАМЕЧАНИЕ

Существует один вопрос, относящийся собственно к этой главе, хотя он никоим образом не является ее кульминационным пунктом. Это вопрос о том, можно ли построить машину, играющую в шахматы, и являются ли способности такого рода существенным отличием человеческого разума от машины. Заметим, что мы не поднимаем вопроса о том, можно ли построить шахматную машину, которая будет вести оптимальную игру в смысле фон Неймана. Даже наилучший человеческий мозг не может приблизиться к решению этой задачи. С другой стороны, не вызывает сомнения возможность построения машины, которая будет играть в шахматы в том смысле, что она будет следовать правилам игры безотносительно к ценности ходов. Построить такую машину по существу не труднее, чем построить систему блокировки сигналов для железнодорожного сигнального поста. Реальная задача является промежуточной – построить машину, которая будет служить интересным противником для игрока какого-нибудь одного из многих уровней, по которым располагаются шахматисты. [c.248]

Я думаю, что можно построить сравнительно грубое, но не совсем тривиальное устройство такого назначения. Машина должна перебирать – по возможности с большой скоростью – все свои допустимые ходы и все допустимые ответы противника на два или три хода вперед. Каждой последовательности ходов она должна приписывать определенную условную оценку. Мат противнику получает на каждой стадии наивысшую оценку, получение мата – самую низшую; потеря фигур, взятие фигур противника, шахование и другие характерные ситуации должны получить оценки, не слишком отличающиеся от тех, какие дали бы им хорошие шахматисты. Первый из всей последовательности ходов должен получать оценку, сходную с той, которая была бы ему дана по теории фон Неймана. Когда у машины есть один ход и у противника один ход, машина оценивает каждый вариант своего хода по минимальной оценке ситуации, получаемой после перебора всех возможных ответов противника. Когда машина и противник имеют по два хода, машина оценивает каждый вариант своего первого хода по минимальной оценке относительно вариантов первого хода противника, оцениваемых, в свою очередь, по максимальной оценке следующих за ними вариантов второго хода машины, а эта максимальная оценка подсчитывается для вариантов второго хода машины в предположении, что у противника есть лишь один ход и у машины лишь один. Этот процесс можно распространить на тот случай, когда каждый игрок делает три хода, и т.д. Затем машина выбирает любой из вариантов своего хода, дающих максимальную оценку для п ходов вперед, где п имеет значение, установленное конструктором машины. Этот ход она выбирает как окончательный.

Такая машина будет играть в шахматы не только правильно, но даже и не столь плохо, чтобы это было смешно. Если на какой-либо стадии игры будет возможен мат в два или три хода, то машина сделает этот мат; а если можно избежать мата в два или три хода, то машина избежит его. Она, вероятно, будет выигрывать у бестолкового и невнимательного шахматиста и почти наверное будет проигрывать внимательному и достаточно умелому игроку. Другими словами, машина, [c.249] вполне возможно, будет играть не хуже, чем огромное большинство человечества. Это не значит, что она дойдет до такой же степени совершенства, как мошенническая машина Мельцеля6, но тем не менее она может достичь вполне удовлетворительного уровня. [c.250]

Далее:
ЧАСТЬ II
ДОПОЛНИТЕЛЬНЫЕ ГЛАВЫ 1961 г.
IX. ОБ ОБУЧАЮЩИХСЯ И САМОВОСПРОИЗВОДЯЩИХСЯ МАШИНАХ

К оглавлению

ПРИМЕЧАНИЯ

1 Монополия – американская настольная игра, в которой игроки играют в покупку, аренду и продажу недвижимости, причем выигрывает тот, кто станет “владельцем” большей части имущества. - Прим. ред.
Вернуться к тексту

2 Синдикат в американской прессе – объединение, поставляющее статьи, фотографии и т.д. для одновременной публикации во многих газетах. Этот материал на готовых матрицах позван газетчиками “котельным железом” (boiler plate). – Прим. ред.
Вернуться к тексту

3 Книжными клубами в США называют книготорговые организации, периодически снабжающие своих членов или подписчиков новыми книгами, – Прим. ред.
Вернуться к тексту

4 Переводчик-предатель (итал.). – Прим. ред.
Вернуться к тексту

5 Под знаком вечности. – Прим. ред.
Вернуться к тексту

6 В 1770 г, венгерский механик барон Вольфганг фон Кемпелен (1734–1804) построил автомат для игры в шахматы в виде “механического турка”, который побеждал даже наиболее сильных игроков. Машина демонстрировалась изобретателем в различных странах Европы и произвела сенсацию. После смерти Кемпелена в 1804 г. ее приобрел австрийский механик Л. Мельцель, изобретатель метронома. Секрет автомата был раскрыт лишь в 1834 г.: внутри стола с шахматной доской, возле которой сидел турок, скрывался человек, управляющий его движениями. Разоблачению мнимого автомата посвящена также статья Эдгара По “Шахматный игрок Мельцеля” (1836). В 1836 г. машина была помещена в Китайский музей в Филадельфии, США, где погибла при пожаре в 1854 г. (см.: Murray H. J. R. History of Chess. Clarendon Press, Oxford, 1913, pp. 876–877). – Прим. ред.


ЧАСТЬ II

Винер Н. Кибернетика, или управление и связь в животном и машине. - 2-е издание. - М.: Наука; Главная редакция изданий для зарубежных стран, 1983. - 344 с.

Красным шрифтом в квадратных скобках обозначается конец текста на соответствующей странице печатного оригинала данного издания

ЧАСТЬ II
ДОПОЛНИТЕЛЬНЫЕ ГЛАВЫ
1961 г.

IX. ОБ ОБУЧАЮЩИХСЯ И САМОВОСПРОИЗВОДЯЩИХСЯ МАШИНАХ

К числу явлений, которые мы считаем характерными для живых систем, относится способность обучаться и способность воспроизводить самих себя. Эти свойства, хотя и кажутся различными, тесно связаны между собой. Обучающееся животное – это животное, которое может преобразиться под действием своего прошлого окружения в другое существо и тем самым приспособиться к окружению в течение своей индивидуальной жизни. Размножающееся животное – это животное, которое может создавать других животных по своему подобию, по крайней мере приближенно, хотя подобие и не настолько полно, чтобы они не могли изменяться со временем. Если эти изменения сами окажутся наследуемыми, появляется сырой материал, над которым может работать естественный отбор. Если наследование касается поведения животного, то среди различных распространяющихся типов поведения некоторые окажутся благоприятными для продолжения существования расы и сохранятся, а другие окажутся вредными и будут устранены. Таким образом, происходит своеобразное расовое, или филогенетическое, обучение, в отличие от онтогенетического обучения индивидуума. И онтогенетическое, и филогенетическое обучение суть методы приспособления животного к окружающей среде.

Обе формы обучения, и в особенности филогенетическое, свойственны не только всем животным, но и растениям – и по существу всем организмам, которые в каком-либо смысле можно считать живыми. Однако значение этих двух форм обучения у различных видов живых существ может весьма различаться. У человека – и в меньшей степени у других млекопитающих – онтогенетическое обучение и индивидуальная приспособляемость достигли высшей точки. По существу, [c.253] можно сказать, что весьма большая часть филогенетического обучения человека была посвящена созданию возможности хорошего онтогенетического обучения.

Джулиан Хаксли в своем фундаментальном исследовании об уме птиц1 показал, что у птиц способность к онтогенетическому обучению невелика. То же справедливо для насекомых, и в обоих случаях это может объясняться огромными требованиями, предъявляемыми к индивидууму полетом, и вытекающим отсюда поглощением способностей нервной системы, которые в противном случае могли бы быть применены к онтогенетическому обучению. Как ни сложны формы поведения птиц: полет, ухаживание, забота о птенцах, постройка гнезд, они выполняются правильно с первого раза, не требуя особого научения от матери.

Вполне уместно посвятить одну из глав этой книги двум взаимосвязанным проблемам: могут ли созданные человеком машины обучаться и могут ли они воспроизводить самих себя? Мы попытаемся показать, что они действительно могут и то и другое, и обрисуем технику обеих активностей.

Более простым из этих двух процессов является обучение, и здесь техническое развитие пошло дальше. Я буду говорить, в частности, об обучении играющих машин, которое дает им возможность совершенствовать свою стратегию и тактику на основании опыта.

Существует признанная теория игр – теория фон Неймана2. Она посвящена способу игры, который лучше рассматривать не с начала партии, а с конца. На последнем ходе партии игрок стремится сделать по возможности выигрышный ход, а если нельзя, то, по крайней мере, ход, приводящий к ничьей. На предыдущем этапе его противник стремится сделать ход, препятствующий другому игроку сделать выигрышный или ничейный ход. Если же он сам может сделать выигрышный ход, он сделает таковой, и это будет не предпоследний, а последний этап игры. Другой игрок на ходе, предшествующем этому ходу, будет пытаться действовать [c.254] так, чтобы все усилия его противника не помещали ему закончить партию выигрышным ходом, и т.д.

Существуют игры, как, например, в крестики и нулики, где вся стратегия известна и такую политику можно проводить с самого начала. Если это возможно, то это явно наилучший способ игры. Но во многих играх, как шахматы и шашки, наше знание недостаточно для полного осуществления подобной стратегии, и тогда мы можем лишь приблизиться к ней. Приближенная теория в стиле фон Неймана, как правило, учит игрока действовать с крайней осторожностью, исходя из допущения, что его противник – совершенный мастер.

Однако такая установка не всегда оправданна. На войне, являющейся родом игры, она, как правило, будет вести к нерешительным действиям, которые во многих случаях будут немногим лучше поражения. Приведу два исторических примера. Когда Наполеон сражался с австрийцами в Италии, его успех был обусловлен отчасти тем, что ему было известно ограниченное и традиционное военное мышление австрийцев. С полным основанием он мог полагать, что они не способны использовать новые, требующие решительных действий методы войны, введенные солдатами французской революции. Когда затем Нельсон сражался с объединенными флотами континентальной Европы, у него было то преимущество, что он командовал флотом, господствовавшим на морях в течение многих лет и выработавшим методы мышления, недоступные, как ему было хорошо известно, для противников. Если бы адмирал вместо того, чтобы полностью использовать это преимущество, действовал осторожно, исходя из допущения, что противник имеет такой же военно-морской опыт, он возможно, выиграл бы в конце концов войну, но не смог бы одержать столь быструю и решительную победу и установить непроницаемую морскую блокаду, которая в конечном счете привела к падению Наполеона.

Итак, в обоих случаях руководящим принципом была известная репутация командира и его противников, проявившаяся статистически в их прошлых действиях, а не стремление проводить совершенную игру против совершенного противника. Непосредственное применение метода фон Неймана в этих случаях не принесло бы пользы. [c.255]

Подобно этому, учебники шахматной теории написаны не с точки зрения фон Неймана. Они представляют собой собрания принципов, извлеченных из практического опыта шахматистов, игравших против других шахматистов высокой квалификации и больших знаний, и устанавливают определенные стоимости или веса, присваиваемые потере каждой фигуры, подвижности, господству над пространством, развитию сил и другим факторам, изменяющимся в ходе партии.

Не очень трудно сделать машины, которые будут играть в шахматы каким-то образом. Простое соблюдение законов игры, при котором делаются лишь разрешенные ходы, легко осуществимо на весьма простых вычислительных машинах. Для этой цели нетрудно приспособить обычную цифровую машину.

Теперь встает вопрос о политике в рамках правил игры. Всякие оценки фигур, господства, подвижности и т.д. внутренне допускают сведение к количественным выражениям, и, когда это сделано, становится возможным применить принципы шахматного учебника, чтобы на каждой стадии найти лучшие ходы. Такие машины созданы, и они будут играть очень хорошие любительские партии, но пока что не партии на уровне мастера.

Представьте себе, что вы играете в шахматы против такой машины. Чтобы сделать ситуацию справедливой, предположим, что вы играете заочно, не зная, что играете против машин, и, следовательно, без предубеждений. Естественно, как всегда бывает в шахматной игре, вы составите некоторое суждение о шахматной индивидуальности вашего противника. Вы обнаружите, что, когда на доске возникает дважды одно и то же положение, ваш противник будет реагировать каждый раз одинаковым образом, и вы решите, что его поведение весьма негибкое. Если какой-нибудь из ваших приемов достигнет цели, то этот прием всегда будет достигать цели при тех же самых условиях. Поэтому искусному игроку не очень трудно выработать надлежащую линию игры против противника-машины и все время обыгрывать ее.

Однако существуют машины, которые нельзя обыграть так тривиально. Предположим, что машина через каждые несколько игр делает перерыв и использует свои способности для другой цели. На этот раз она не [c.256] играет с противником, но исследует все предшествующие партии, записанные у нее в памяти, чтобы определить, какие веса различных оценок фигур, господства, подвижности и т.п. приводят чаще всего к выигрышу. Таким образом, она учится не только на своих неудачах, но и на успехах противника. После этого она заменяет свои прежние оценки новыми и начинает играть как другая, лучшая машина. Такая машина уже не будет иметь жесткой индивидуальности, и приемы, бывшие прежде успешными против нее, потерпят в конце концов неудачу. Более того, она может стечением времени усвоить нечто из стратегии своих противников.

Все это очень трудно осуществить в шахматах, и на практике метод не был разработан настолько, чтобы создать машину, способную играть в шахматы как мастер. Шашки представляют более легкую задачу. Равноценность фигур значительно уменьшает число рассматриваемых комбинаций. Кроме того, отчасти вследствие этой однородности, шашечная игра гораздо легче делится на отдельные стадии, нежели шахматная. Даже в шашках главная задача эндшпиля уже не в том, чтобы брать фигуры, а в том, чтобы входить в контакт с противником, добиваясь позиций, позволяющих брать фигуры. Оценка ходов в шахматной партии должна делаться независимо на различных стадиях. Не только эндшпиль отличается от миттельшпиля в важнейших отношениях, но и в дебютах выдвижение фигур в положение, обеспечивающее свободу движений для нападения и защиты, имеет гораздо большее значение, чем в миттельшпиле. Поэтому мы даже приближенно не можем удовольствоваться равномерной оценкой различных весовых факторов для игры в целом, но должны разбить процесс обучения на ряд отдельных стадий. Только тогда можно надеяться на создание обучающейся машины, которая сумеет играть в шахматы как мастер.

В этой книге уже упоминалась, в связи с задачей предсказания, идея сочетать программирование первого порядка, которое может быть о ряде случаев линейным, с программированием второго порядка, в котором для выбора стратегии, применяемой при программировании первого порядка, используется гораздо больший отрезок прошлого. Предсказывающее устройство использует [c.257] ближайшее прошлое полета самолета для предсказания будущего при помощи линейной операции; но отыскание правильной линейной операции есть статистическая задача, в которой долгое прошлое этого полета и прошлое многих подобных полетов используются для получения статистической основы.

Статистические исследования, необходимые для того, чтобы почерпать из долгого прошлого стратегию, предназначенную для короткого прошлого, являются в высшей мере нелинейными. Так, при использовании для предсказания уравнения Винера – Гопфа3 коэффициенты уравнения разыскиваются нелинейным методом. В общем случае обучающаяся машина действует при помощи нелинейной обратной связи. Шашечная машина, описанная Сэмьюэлом4 и Ватанабе5, может выучиться обыгрывать своего программиста вполне закономерным образом после 10–20 рабочих часов программирования.

Философские идеи Ватанабе о применении программирующих машин чрезвычайно интересны. С одной стороны, метод доказательства элементарной геометрической теоремы, оптимальным образом отвечающий определенным критериям изящества и простоты, рассматривается Ватанабе как обучение игре, но не против индивидуального противника, а против, так сказать, “полковника Боуги”6. Другая игра, исследуемая Ватанабе, ведется при логической индукции, когда, желая построить теорию, оптимальную в таком же квазиэстетическом смысле, исходя из оценки экономичности, прямоты и т.п., мы определяем значения конечного числа параметров, оставленных свободными. Несмотря на ограниченность такой логической индуктивной игры, она вполне заслуживает изучения. [c.258]

Теория играющих машин проливает свет на многий виды борьбы, которые мы обычно не считаем играми. Любопытный пример – борьба мангусты со змеей. Как отмечает Киплинг в “Рикки-Тикки-Тави”, мангуста не является невосприимчивой к яду кобры, хотя она до некоторой степени защищена своей жесткой шкурой, которую змее трудно прокусить. По описанию Киплинга, эта борьба – настоящая игра со смертью, состязание в мускульной ловкости и проворстве. Нет основания считать, что у мангусты движения быстрее или точнее, чем у кобры. Тем не менее мангуста почти всегда убивает кобру и выходит из борьбы без единой царапины. Как же ей это удается?

Я даю здесь объяснение, которое мне кажется верным и которое я составил, когда посмотрел такое сражение, а также кинофильм о других подобных сражениях. Я не гарантирую правильности ни своих наблюдений, ни своих интерпретаций. Мангуста начинает с ложного выпада, который вызывает бросок змеи. Мангуста увертывается и делает еще выпад, так что противники действуют в некотором ритме. Но эта пляска не статическая, а постепенно прогрессирующая. Свои выпады мангуста делает все раньше и раньше по отношению к броскам кобры и, наконец, нападает в тот момент, когда кобра вытянулась во всю длину и не может двигаться быстро. На сей раз мангуста не делает ложного выпада, а точным броском прокусывает мозг змеи и убивает ее.

Другими словами, образ действия змеи сводится к одиночным, не связанным между собой броскам, тогда как мангуста действует с учетом некоторого, хотя и не очень большого отрезка всего прошлого хода сражения. В этом отношении мангуста действует подобно обучающейся машине, и действительная смертоносность ее нападения основана на гораздо более высокой организации нервной системы.

Как видно из шедшего несколько лет тому назад фильма Уолта Диснея, нечто очень похожее происходит, когда одна из наших западных птиц, кукушка-подорожник (road runner), нападает на гремучую змею. Хотя птица сражается клювом и когтями, а мангуста – зубами, их образ действия очень схож. Другой замечательный пример – бой быков. Не нужно забывать, что [c.259] бой быков не спорт, а игра со смертью, в которой обнаруживается красота переплетающихся, взаимосвязанных движений быка и человека. Честность по отношению к быку здесь неуместна, и мы можем оставить без учета предварительное подстрекание и ослабление быка, имеющие целью довести борьбу до той ступени, где полностью проявляется взаимодействие схем движений противников. Искусный тореадор имеет большой запас возможных действий, подобных размахиванию плащом, различным уверткам и пируэтам и т.п., которые должны привести быка в позицию, где он, остановившись после броска вперед, вытянулся во всю длину в то самое мгновение, когда тореадор готов вонзить ему шпагу в сердце.

Сказанное выше о борьбе мангусты с коброй или тореадора с быком можно отнести также к физическим состязаниям человека с человеком. Рассмотрим поединок па рапирах. Он состоит из последовательности обманных движений, парирований и выпадов, причем каждый из противников стремится отвести рапиру другого настолько, чтобы иметь возможность попасть в него, не раскрываясь самому и не подвергая себя ответному удару. Точно так же в теннисном чемпионате не достаточно хорошо подать или отбить мяч в каждом отдельном ударе; стратегия игры состоит в том, чтобы рядом отражений последовательных подач постепенно ухудшить положение противника настолько, что в конце концов ему трудно будет отразить мяч как следует.

И эти физические состязания, и игры такого рода, какие мы предполагали для играющих машин, содержат тот же самый элемент обучения через накопление опыта о навыках противника и о своих собственных. То, что верно относительно игр физического столкновения, верно и относительно состязаний, в которых умственный элемент представлен сильнее, таких, как война и игры, имитирующие войну, посредством которых наши штабные офицеры приобретают военный опыт. Это верно как для классической войны па суше и на море, так и для новой, еще не испытанной войны с атомным оружием. Во всех этих столкновениях можно применить некоторую механизацию, аналогичную механизации шашек при помощи обучающихся машин. [c.260]

Самая большая опасность сейчас – III мировая война. Заслуживает внимания вопрос: в какой мере эта опасность может корениться в неосмотрительном применении обучающихся машин? Много раз я слышал утверждение, что обучающиеся машины не могут подвергнуть нас каким-либо новым опасностям, потому что мы можем выключить их, когда захотим. Но действительно ли можем? Чтобы действительно выключить машину, мы должны получить информацию, что наступило опасное положение. То обстоятельство, что мы создали машину, еще не гарантирует, что мы будем иметь надлежащую информацию для такого вмешательства. Этот вывод уже содержится неявно в утверждении, что шашечная машина может обыграть своего программиста, и притом после очень небольшого времени подлаживания к нему. Кроме того, самое быстродействие современных цифровых машин может воспрепятствовать нам заметить и продумать признаки опасности.

Мысль о нечеловеческих устройствах, наделенных большим могуществом и большой способностью вести свою политику, и об их опасности не имеет в себе ничего нового. Ново лишь то, что теперь мы располагаем эффективными устройствами такого рода. В прошлом подобные возможности постулировались для методов магии и волшебства, составляющих тему множества легенд и народных сказок, В этих сказках тщательно разбирается моральное положение волшебника. Я уже рассматривал некоторые аспекты легендарной этики волшебства в своей предыдущей книге, озаглавленной “Человеческое использование человеческих существ”7. Повторю здесь кое-что из сказанного там, чтобы связать это с обучающимися машинами.

Хорошо известна волшебная сказка из стихотворения Гёте “Ученик чародея”. В ней чародей оставляет своего ученика и помощника одного, приказав ему принести воды. Ленивый и хитрый юноша поручает эту работу метле, произнеся волшебные слова, слышанные им от учителя. Метла покорно делает за него работу и не [c.261] хочет остановиться. Юноша едва не тонет. Он обнаруживает, что не выучил или забыл второе заклинание, которое должно остановить метлу. В отчаянии хватает он метлу, переламывает ее о колено и к ужасу своему видит, что обе половины продолжают носить воду. К счастью, прежде чем он погиб, возвращается учитель, произносит Властное Слово, останавливающее метлу, и задает порядочный нагоняй ученику.

В “Тысяче и одной ночи” есть сказка о рыбаке и джине. Рыбак вытащил сетью кувшин, запечатанный печатью Соломона. В этот сосуд Соломон заключил мятежного джина. Джин выходит в виде гигантского облака дыма и говорит рыбаку, что в первые годы своего заточения он хотел вознаградить своего спасителя могуществом и богатством, а теперь решил убить его тут же на месте. К счастью для рыбака, ему удается уговорить джина войти опять в бутылку; которую он бросает на дно океана.

Еще страшнее притча об обезьяньей лапе, принадлежащая перу английского писателя начала текущего столетия У.У. Джекобса. Старый, удалившийся на покой английский рабочий сидит за столом с женой и другом, вернувшимся из Индии британским сержантом. Сержант показывает хозяевам талисман в виде высушенной, сморщенной обезьяньей лапы. Один индийский святой человек, хотевший доказать, как безумно искушать судьбу, наделил эту лапу способностью исполнить три желания каждого из трех человек. Солдат говорит, что не знает первых двух желаний первого владельца, но последнее было – смерть. Сам он, объявляет сержант друзьям, второй владелец, по не будет рассказывать о своих страшных переживаниях. Он бросает лапу в огонь, однако его друг спасает лапу и хочет испытать ее силу. Его первое желание – получить 200 фунтов стерлингов. Вскоре раздается стук в дверь, и в комнату входит служащий фирмы, где работает его сын. Отец узнает, что сын убит машиной, но фирма, хотя и отклоняет от себя всякую ответственность, желает предложить отцу вознаграждение в 200 фунтов. Убитый горем, отец называет свое второе желание – чтобы сын вернулся, и когда опять раздается стук в дверь и она открывается, появляется нечто, представляющее собой – об этом много не говорится – призрак [c.262] сына. Последнее желание – чтобы призрак удалился прочь8.

Суть всех этих историй в том, что волшебные силы выполняют все дословно, и если мы просим у них для себя какой-либо дар, мы должны просить то, что нам действительно желательно, а не то, что нам кажется таковым. Новые и реальные силы обучающейся машины также выполняют указания буквально. Если мы программируем машину на победу в войне, то должны ясно представлять себе, как мы понимаем победу. Обучающаяся машина должна программироваться опытом. Единственный опыт ядерной войны, который не приводит сразу же к катастрофе, – это опыт военной игры. Если мы хотим использовать этот опыт как руководство для нашего поведения в действительном кризисе, то ценности победы, которые мы принимали в играх программирования, должны быть теми самыми ценностями, к которым мы стремились бы в глубине души в действительной войне. Ошибка в этом отношении может означать лишь немедленную, полную и окончательную гибель. Мы не можем рассчитывать на то, что машина будет подражать нам в тех предрассудках и эмоциональных компромиссах, благодаря которым мы позволяем себе называть разрушение победой. Если мы требуем победы и не знаем, что подразумеваем под этим, мы встретимся с призраком, стучащимся к нам в дверь.

На этом расстанемся с обучающимися машинами. Теперь следует сказать кое-что о самораспространяющихся машинах. Здесь важны оба слова: “машина” и “самораспространяющаяся”. Машина – не только материальная форма, но и средство для достижения определенных целей. И самораспространение – не просто создание осязаемой копии, но и создание копии, способной к тем же самым функциям.

Здесь мыслимы два разных подхода. Один из них, чисто комбинаторный, связан с вопросом: может ли машина иметь достаточно много частей и достаточно [c.263] сложную структуру, чтобы самовоспроизведение могло быть в числе ее функций? На этот вопрос дал положительный ответ покойный Джон фон Нейман. Другой вопрос касается действительной рабочей процедуры для построения самовоспроизводящихся машин. Здесь я ограничусь одним классом машин, который, хотя и не охватывает всех машин, отличается большой общностью. Я имею в виду нелинейные преобразователи.

Названные машины представляют собой устройства, где входным сигналом служит одна функция времени, выходным – другая. Выходной сигнал полностью определяется прошлым входного сигнала; но, вообще говоря, при сложении входных сигналов соответствующие выходные сигналы не складываются. Такие устройства называются преобразователями. Общим свойством всех преобразователей, линейных или нелинейных, является инвариантность относительно сдвига во времени. Если машина выполняет некоторую функцию, то при сдвиге входного сигнала назад во времени выходной сигнал! сдвигается назад па такой же интервал.

Наша теория самовоспроизводящихся машин основана на некотором каноническом представлении нелинейных преобразователей. Понятия импеданса и адмиттанса, столь необходимые в теории линейных систем, здесь не вполне пригодны. Нам придется сослаться на новые методы получения такого представления, разработанные отчасти мною9 и отчасти профессором Деннисом Габором10 из Лондонского университета.

Хотя методы профессора Габора и мои собственные приводят к построению нелинейных преобразователей, они линейны в том смысле, что выходной сигнал нелинейного преобразователя представляется в них как сумма выходных сигналов комплекта нелинейных преобразователей, на которые подается один и тот же входной сигнал. Указанные выходные сигналы складываются с переменными линейными коэффициентами. Это [c.264] позволяет нам при расчете и задании нелинейного преобразователя применить теорию линейных разложений. В частности, можно разыскивать коэффициенты составляющих элементов методом наименьших квадратов. Если сюда еще добавить метод статистического усреднения по множеству всех входных сигналов, которые могут поступать в наше устройство, то получится, по существу, один из разделов теории ортогональных разложений. Такую статистическую основу для теории нелинейных преобразователей можно получить фактическим изучением прошлых статистик входных сигналов, используемых в каждом частном случае.

Таковы, в общих чертах, методы Габора. Мои методы по существу аналогичны, но статистическая основа моей работы несколько иная.

Хорошо известно, что электрический ток не является непрерывным, а представляет собой поток электронов, подверженный статистическим отклонениям. Эти статистические флюктуации можно описать достаточно хорошо с помощью теории броупова движения или аналогичной теории дробового эффекта (лампового шума), о которых я собираюсь говорить в следующей главе. Во всяком случае, можно создать прибор, производящий стандартный дробовой шум с весьма специфическим статистическим распределением, и такой прибор выпускается промышленностью. Заметим, что ламповый шум является в некотором роде универсальным входным сигналом, поскольку его флюктуации, если брать их за достаточно долгое время, будут рано или поздно приближаться к любой данной кривой. Для лампового шума существует весьма простая теория интегрирования и усреднения.

С помощью статистик лампового шума легко построить замкнутое множество нормальных и ортогональных нелинейных операций. Если входные сигналы, подвергаемые этим операциям, имеют статистическое распределение, присущее ламповому шуму, то среднее произведение выходных сигналов двух составляющих элементов нашего нелинейного преобразователя, взятое по статистическому распределению лампового шума, будет равно нулю. Кроме того, средний квадрат выходного сигнала каждого устройства можно нормировать к единице. [c.265]

Тогда для разложения нелинейного преобразователя общего вида по этим составляющим элементам можно применить известную теорию ортонормальных функций.

Конкретно, наши устройства дают выходные сигналы, представляющие собой произведения многочленов Эрмита от коэффициентов Лагерра для прошлого отрезка входного сигнала. Это подробно изложено в моих “Нелинейных задачах в теории случайных процессов”.

Конечно, трудно найти среднее непосредственно по множеству возможных входных сигналов. Эта трудная задача становится разрешимой только потому, что дробовые входные сигналы обладают свойством, которое называется метрической транзитивностью или эргодичностью. Любая интегрируемая функция от параметра распределения дробовых входных сигналов имеет почти во всех случаях среднее по времени, равное среднему по множеству. Вследствие этого мы можем взять два прибора, на которые поступает один и тот же дробовой шум, и найти среднее их произведение по всему множеству возможных входных сигналов путем перемножения их выходных сигналов и усреднения полученного произведения по времени. Для всех этих процессов необходимы лишь операции сложения напряжений, перемножения напряжений и усреднения по времени, для которых имеются соответствующие устройства. Фактически для методики Габора требуются те же устройства, что и для моей методики. Один из его учеников изобрел весьма эффективный и недорогой перемножитель, основанный на пьезоэлектрическом эффекте в кристалле, находящемся в поле двух магнитных катушек.

Итак, любой неизвестный нелинейный преобразователь мы можем имитировать суммой линейных членов, обладающих каждый заданными характеристиками и регулируемым коэффициентом. Коэффициент можно найти как среднее произведение выходных сигналов неизвестного преобразователя и соответствующего известного преобразователя, когда их входы подключены к одному и тому же генератору дробового шума. Более того, вместо того, чтобы считывать результат на шкале прибора и переносить его вручную в соответствующий преобразователь, моделируя устройство по частям, [c.266] можно без большого труда осуществить автоматический перенос коэффициентов в цепи обратной связи. В итоге нам удалось создать белый ящик, потенциально способный приобрести характеристики любого нелинейного преобразователя, и затем сделать его подобным данному преобразователю – черному ящику, подав на входы приборов одну и ту же случайную функцию и соединив их выходы таким образом, чтобы получить надлежащую комбинацию без всякого вмешательства с нашей стороны.

Я спрашиваю, будет ли это философски очень разниться от того, что происходит в организме, когда ген действует как шаблон, формирующий другие молекулы того же гена из неопределенной смеси аминокислот и нуклеиновых кислот, или когда вирус формирует другие подобные себе молекулы того же вируса из тканей и соков организма-хозяина. Я совсем не утверждаю, что процессы одинаковы в деталях, но утверждаю, что философски они представляют собой весьма сходные явления. [c.267]

Далее:
Х. МОЗГОВЫЕ ВОЛНЫ И САМООРГАНИЗУЮЩИЕСЯ СИСТЕМЫ

К оглавлению

ПРИМЕЧАНИЯ

1 Huxley J. Evolution: The Modern Synthesis. – New York: Harper Bros., 1943.
Вернуться к тексту

2 Von Neumann J., Morgenstern O. Theory of Games and Economic Behavior. – Princeton, New Jersey: Princeton University Press, 1944.
Вернуться к тексту

3 Wiener N. Extrapolation, Interpolation, and Smoothing of Stationary Time Series with Engineering Applications. – New York: The Technology Press of M.I.Т., and J. Wiley & Sons, 1949.
Вернуться к тексту

4 Samuel A.L. Some Studies in Machine Learning: Using the Game of Checkers. // IBM Journal of Research and Development. – 1959. – Vol. 3. – P. 210–229.
Вернуться к тексту

5 Watanabe S. Information Theoretical Analysis of Multivariate Correlation. // IBM Journal of Research and Development. – 1960. – Vol. 4. – P. 66–82.
Вернуться к тексту

6 Полковник Боуги (Coloner Bogey) – воображаемый игрок, который всегда играет безупречно (н гольфе). – Прим. ред.
Вернуться к тексту

7 Wiener N. The Human Use of Human Beings: Cybernetics and Society. – Boston: Houghton Mifflin Co., 1950 (русский перевод: Винер Н. Кибернетика и общество. – М.: ИЛ, 1958. – Ред.).
Вернуться к тексту

8 Уильям Уимарк Джекобс (1863–1943) ныне у нас забыт, но в 10–20-х годах в России издавалось много его переводов. Переведен и этот рассказ, самое известное его произведение. (Джекобс В.В. Обезьянья лапа: Шесть рассказов. – СПб.: Акц. о-во типографск. дела, 1912). Любопытно, что Джекобс в целом писатель-юморист. – Прим. ред.
Вернуться к тексту

9 Wiener N. Nonlinear Problems in Random Theory. – New York: The Technology Press of M.I.T. and John Wiley & Sons, Inc., 1958.
Вернуться к тексту

10 Электронные изобретения и их влияние на цивилизацию. Вступительная лекция, 3 марта 1959 г., Имперский колледж естественных и технических наук при Лондонском университете. Англия.


двигающих глазное яблоко; мышц, двигающих голову; мышц, двигающих все тело в целом

Винер Н. Кибернетика, или управление и связь в животном и машине. – 2-е издание. – М.: Наука; Главная редакция изданий для зарубежных стран, 1983. – 344 с.

Красным шрифтом в квадратных скобках обозначается конец текста на соответствующей странице печатного оригинала данного издания

Х. МОЗГОВЫЕ ВОЛНЫ И САМООРГАНИЗУЮЩИЕСЯ СИСТЕМЫ

В предыдущей главе я рассматривал вопросы обучения и самораспространения в применении к машинам и, по крайней мере по аналогии, к живым системам. Здесь я повторю некоторые соображения, которые высказал в предисловии и которые намереваюсь использовать сейчас. Как уже отмечалось выше, эти два явления тесно связаны между собой: первое служит основой для приспособления индивидуума к окружению через опыт, что можно назвать онтогенетическим обучением, а второе, поскольку оно дает материал, с которым может работать изменчивость и естественный отбор, служит основой для обучения филогенетического. Как я уже указывал, млекопитающие, и в частности человек, приспособляются к своему окружению в значительной мере путем онтогенетического обучения, а у птиц, с их весьма разнообразными типами поведения, которые не приобретаются при жизни особи, гораздо большее значение имеет филогенетическое обучение.

Мы видели важность нелинейных обратных связей в возникновении обоих процессов. Настоящая глава посвящена изучению одной конкретной самоорганизующейся системы, в которой нелинейные явления играют большую роль. Здесь описывается то, что происходит, по моему мнению, при самоорганизации электроэнцефалограмм, или электрических волн головного мозга.

Прежде чем обсуждать эту тему по существу, я должен сказать несколько слов о том, что такое волны головного мозга и как их строение можно подвергнуть точному математическому исследованию. Уже много лет было известно, что деятельность нервной системы сопровождается определенными электрическими потенциалами. Первые наблюдения в этой области восходят к началу прошлого столетия и были сделаны Вольтой и Гальвани на нервно-мышечных препаратах лягушачьей [c.268] ноги. Так родилась наука электрофизиология. Однако до конца первой четверти нашего столетия указанная наука развивалась довольно медленно.

Стоит подумать, почему развитие этой ветви физиологии было таким медленным. Для исследования физиологических электрических потенциалов сперва применялись гальванометры. Они имели два недостатка. Во-первых, вся энергия, необходимая для перемещения катушки или стрелки прибора, поступала из самого нерва и была очень мала. Второе затруднение заключалось в том, что в тогдашних гальванометрах подвижные части имели довольно значительную инерцию и для приведения стрелки в строго определенное положение необходима была значительная устанавливающая сила, т.е. гальванометр неизбежно был не только регистрирующим, но и искажающим прибором. Самым лучшим из прежних физиологических гальванометров был струнный гальванометр Эйнтговена, в котором подвижные части сведены к одной нити. Как ни превосходен был этот прибор по тому времени, он не был достаточно хорош, чтобы регистрировать малые электрические потенциалы без больших искажений.

Таким образом, электрофизиологии пришлось дожидаться появления новой техники. То была электронная техника в двух формах. Одна из них восходит к открытию Эдисоном некоторых эффектов проводимости газов, откуда пошло применение электронной лампы для усиления. В результате стало возможным преобразовывать достаточно верно слабые напряжения в сильные и тем самым перемещать оконечные элементы регистрирующего прибора при помощи энергии, не исходящей от нерва, но управляемой им.

Второе изобретение также связано с электрическим током в вакууме и называется катоднолучевым осциллографом. Благодаря осциллографу стало возможно применять в качестве подвижной части прибора гораздо более легкий якорь, нежели в любом предыдущем гальванометре, а именно поток электронов. С помощью двух этих устройств, взятых порознь или вместе, физиологи нашего столетия сумели точно проследить изменение во времени малых напряжений, что было совершенно вне возможностей точных приборов XIX века.

Подобными методами смогли получить точные [c.269] записи изменения во времени весьма малых потенциалов между двумя электродами, помещенными на кожу головы или введенными в мозг. Хотя эти потенциалы наблюдались и в XIX веке, возможность получения новых точных записей возбудила 20–30 лет тому назад большие надежды у физиологов. Ведущими в использовании таких приборов для непосредственного изучения деятельности мозга были Бергер в Германии, Эдриан и Мэттьюс в Англии и Джаспер, Дэйвис и супруги Гиббсы в Соединенных Штатах.

Надо признать, что последующее развитие электроэнцефалографии не оправдало розовых надежд, которые питали первые исследователи в этой области. Полученные ими данные записывались чернильным самописцем. Это чрезвычайно сложные и неправильные кривые; и хотя можно было различить некоторые преобладающие частоты, как, например, альфа-ритм с частотой около 10 колебаний в секунду, записи чернилами были мало пригодны для дальнейшей математической обработки. В результате электроэнцефалография стала больше искусством, чем наукой, и зависела от способности тренированного наблюдателя распознавать определенные свойства чернильной кривой на основании большого опыта. Это вызывало весьма серьезный упрек, что истолкование электроэнцефалограмм делается в значительной мере субъективным.

В конце 20-х – начале 30-х годов я заинтересовался гармоническим анализом непрерывных процессов. Хотя физики ранее уже рассматривали такие процессы, математическая теория гармонического анализа почти вся ограничивалась изучением либо периодических процессов, либо процессов, стремящихся в некотором смысле к нулю с возрастанием времени в положительном или отрицательном направлении. Моя работа была первой попыткой поставить гармонический анализ непрерывных процессов на твердую математическую основу. При этом я нашел, что главным здесь является понятие автокорреляции, которое уже применял Дж. И. Тэйлор (ныне сэр Джеффри Тэйлор) при изучении турбулентностей 1. [c.270]

Автокорреляция для функции времени f(t) представляет собой временное среднее от произведения f(t+t) на f(t). Удобно вести комплексные функции времени, если даже в реальных случаях мы рассматриваем действительные функции. Тогда автокорреляция становится равной среднему произведению f(t+t) на величину, сопряженную с f(t). Работаем ли мы с действительными или с комплексными функциями, спектр мощности функции f(t) равен преобразованию Фурье от ее автокорреляции.

Я уже говорил о непригодности чернильных записей для дальнейшей математической обработки. Прежде чем ожидать многого от идеи автокорреляции, необходимо было заменить чернильные записи какими-либо другими, более пригодными.

Одним из лучших способов фиксации малых флюктуирующих напряжений для дальнейшей обработки – применение магнитной ленты. Она позволяет сохранять флюктуирующее электрическое напряжение в виде постоянной записи, которую можно затем использовать когда угодно. Один из таких приборов был придуман около десяти лет тому назад в научно-исследовательской лаборатории электроники Массачусетсского технологического института под руководством проф. Уолтера А. Розенблита и д-ра Мэри А. Б. Бразье 2.

В этом приборе применяется запись на магнитную ленту с частотной модуляцией. Дело в том, что считывание всегда связано с некоторым стиранием магнитной ленты. При записи с амплитудной модуляцией стирание приводит к изменению хранимого сообщения, и при последовательных считываниях ленты мы по существу имеем дело с меняющимся сообщением.

При частотной модуляции также происходит некоторое стирание, но приборы, посредством которых мы читаем ленту, сравнительно нечувствительны к амплитуде и считывают только частоту. Пока лента не сотрется настолько, что станет совершенно неразборчива, частичное стирание ленты не искажает значительно сообщения, которое она хранит. Поэтому ленту можно [c.271] читать много раз почти с такой же точностью, как и при первом считывании.

Как следует из самого понятия автокорреляции, нам понадобится механизм, задерживающий считывание ленты на регулируемый интервал времени. Если отрывок записи длительности А пропустить через прибор с двумя последовательными считывающими головками, то образуются два одинаковых, но сдвинутых во времени сигнала. Временной сдвиг зависит от расстояния между считывающими головками и от скорости подачи ленты, и его можно менять по нашему желанию. Мы можем обозначить один сигнал через f(t), а другой – через f(t+t), где t – временной сдвиг, Произведение этих сигналов можно, например, получить при помощи квадратических детекторов и линейных смесителей, используя тождество

4ab = (a+b)2–(a–b)2

(10.01)

Это произведение можно приближенно усреднить на интегрирующей реостатно-емкостной цепи, имеющей большую постоянную времени сравнительно с длительностью А нашей выборки. Полученное среднее [c.272] пропорционально значение автокорреляционной функции при задержке t . Повторение процесса при различных t даст некоторый ряд значений автокорреляции (или, вернее, выборочной автокорреляции за большое время включения А). На рис. 9 показан график одной реальной автокорреляции такого рода 3 . Заметим, что здесь показана лишь половина кривой, так как автокорреляция для отрицательных времен совпадает с автокорреляцией для положительных времен, по крайней мере, в случае, когда мы отыскиваем автокорреляцию действительной кривой.

Рис. 9. Автокорреляция

Заметим, что подобные автокорреляционные кривые применялись уже много лет в оптике и что прибором, с помощью которого их получали, был интерферометр Майкельсона (рис. 10). Интерферометр Майкельсона посредством системы зеркал и линз разделяет световой луч на две части, которые посылаются по путям разной длины и затем вновь соединяются в один луч. Различные длины путей вызывают различные задержки во [c.273] времени, и результирующий луч будет равен сумме двух отражений входящего луча, которые можно опять обозначить через f(t) и f(t+t). Если измерить чувствительным фотометром силу луча, то его показание будет пропорционально квадрату суммы f(t)+ f(t+t) и, следовательно, должно содержать член, пропорциональный автокорреляции. Другими словами, яркость интерференционных полос даст нам автокорреляцию (с точностью до линейного преобразования).

Рис. 10. Интерферометр Майкельсона

Все это неявно содержалось в работе Майкельсона. Нетрудно видеть, что при выполнении преобразования Фурье над интерференционными полосами интерферометр дает нам энергетический спектр света и тем самым по существу является спектрометром. Более того, это самый точный из известных нам типов спектрометров.

Спектрометр такого типа получил должное признание лишь в последние годы. Мне говорили, что теперь он принят в качестве важного средства прецизионных измерений. Отсюда видно, что методы обработки автокорреляционных записей, которые я сейчас изложу, применимы также в спектроскопии и позволяют довести до предела ту информацию, которую может дать спектрометр.

Рассмотрим, как получить спектр мозговой электрической волны по автокорреляции. Пусть C(t) – автокорреляция функции f(t). Тогда C(t) можно записать в виде

(10.02)

Здесь F всегда является возрастающей или по меньшей мере неубывающей функцией от w ; мы будем называть ее интегральным спектром функции f. Вообще говоря, этот интегральный спектр состоит из трех аддитивных частей. Линейчатая часть спектра возрастает лишь на счетном множестве точек. После ее исключения останется непрерывный спектр, равный, в свою очередь, сумме двух частей: одна из них возрастает только на множестве меры нуль, а другая абсолютно непрерывна и является интегралом положительной интегрируемой функции.

Будем впредь полагать, что первые две части спектра: дискретная часть и непрерывная часть, возрастающая [c.274] на множестве меры нуль, – отсутствуют. В этом случае можно написать

(10.03)

где j (w) – спектральная плотность. Если j (w) принадлежит к классу Лебега L2, то можно написать

(10.04)

Как видно по автокорреляционной кривой мозговых волн, преобладающая часть мощности спектра сосредоточена в окрестности частоты 10 гц. В таком случае j (w) будет иметь форму, подобную следующей диаграмме:

Два пика около 10 и –10 суть зеркальные изображения друг друга.

Известны различные способы численного выполнения разложения Фурье, включая применение интегрирующих приборов и цифровые вычислительные процессы. В обоих случаях неудобством является то, что главные пики расположены около 10 и –10, а не около 0. Но существуют способы переноса гармонического анализа в окрестность нулевой частоты, которые весьма сокращают объем работы. Заметим, что

(10.05)

Другими словами, если умножить С(t) на е20p it, то новый гармонический анализ даст нам полосу вблизи нулевой частоты и другую полосу вблизи частоты +20. Таким образом, если произвести такое умножение и исключить полосу вблизи +20 методами усреднения, равносильными применению волнового фильтра, то мы сведем наш гармонический анализ к гармоническому анализу в окрестности нулевой частоты. [c.275]

Но

(10.06)

Следовательно, действительная и мнимая части функции С(t)е20πit равны соответственно

С(t) cos 20πt и iС(t) sin 20π t.

Частоты в окрестности +20 можно исключить, пропустив эти две функции через фильтр нижних частот, что равносильно усреднению по интервалу в одну двадцатую секунды или более.

а другая – примерно так:

Пусть мы анализируем кривую, у которой большая часть мощности сосредоточена вблизи частоты 10 гц. Умножив эту кривую на косинус или синус от 20πt, получим кривую, являющуюся суммой двух составляющих: одна из них ведет себя локально примерно так:

Усреднив вторую кривую по интервалу в 0,1 сек, получим нуль. Усреднив первую кривую, получим половину максимальной высоты. Таким образом, сглаживая С(t)cos20πt и iС(t)sin20πt, мы получим хорошие приближения соответственно к действительной и мнимой части некоторой функции, имеющей все свои частоты в окрестности пуля, и эта функция будет обладать таким же распределением частоты вокруг нуля, какое одна часть спектра кривой C(t) имела вокруг 10.

Обозначим теперь через K1(t) результат сглаживания произведения С(tcos20πt, а через K2(t) – результат сглаживания произведения С(tsin20πt. Мы хотим найти [c.276]

(10.07)

Выражение (10.07) должно быть действительным, так как это спектр. Следовательно, оно будет равно

(10.08)

Другими словами, если найти косинус-преобразование от K1 и синус-преобразование от K2 и сложить их друг с другом, то мы получим смещенный спектр функции f. Можно показать, что K1 будет четной, a K2 – нечетной функцией. Стало быть, если определить косинус-преобразование от K1 и прибавить или вычесть синус-преобразование от K2, мы получим спектр соответственно справа и слева от центральной частоты на расстоянии ω. Этот метод получения спектра мы будет называть методом гетеродинирования.

Коль скоро автокорреляционные кривые локально представляют собой почти синусоиду с периодом, скажем, 0,1 сек (как в случае автокорреляции мозговых волн на рис. 9), то вычисления, связанные с методом гетеродинирования, можно упростить. Мы берем нашу автокорреляцию через интервалы в 1/40 сек. Затем берем последовательность значений при 0, 1/20, 2/20, 3/20 сек и т.д. и меняем знак на дробях с нечетным числителем. Усредняя по очереди эти значения по достаточно длинному отрезку, получим величину, приблизительно равную K1(t). Взяв аналогично значения автокорреляции при 1/40, 3/40, 5/50 сек и т. д. с чередующимися знаками и проведя такое же усреднение, получим приближенную величину K2(t). Дальнейшая процедура очевидна.

Оправдание этой процедуры следующее. Распределение массы, равное

1 в точках 2πn,
–1 в точках (2n+1)π и
0 во всех остальных точках,

если его подвергнуть гармоническому анализу, будет [c.277] содержать косинусоидальную составляющую с частотой 1 и не будет иметь синусоидальной составляющей. Точно так же распределение массы, равное

1 при (2n+1/2)π,
–1 при (2n–1/2)π и
0 во всех остальных точках,

будет содержать синусоидальную составляющую с частотой 1 и не будет иметь косинусоидальной составляющей. Оба распределения будут содержать также составляющие с частотами N; но поскольку исходная наша кривая не содержит или почти не содержит таких частот, эти члены будут незаметны. Это значительно упрощает наше гетеродинирование, так как нам нужно умножать лишь на множители +1 или –1.

Мы нашли метод гетеродинирования очень полезным при гармоническом анализе мозговых волн, когда в распоряжении имеются лишь ручные средства и когда объем работы становится подавляющим, если выполнять все шаги гармонического анализа без помощи гетеродинирования. Все паши первые исследования по гармоническому анализу спектров мозга выполнены методом гетеродинирования. Но поскольку со временем появилась возможность применять цифровую вычислительную машину, для которой объем работы не столь существен, многие из последующих анализов были проведены прямыми методами, без гетеродинирования. Однако еще немало работы придется делать в местах, где нет цифровых вычислительных машин, и я не считаю метод гетеродинирования устаревшим в практическом отношении.

Я привожу здесь куски одной автокорреляционной кривой, полученной при наших исследованиях. Ввиду того, что она охватывает большую серию данных, воспроизвести ее полностью затруднительно, и мы даем только се начало, в окрестности t =0 и один из дальнейших кусков.

Рис. 11 изображает результат гармонического анализа автокорреляционной кривой, часть которой показана на рис. 9. В данном случае результат был получен на быстродействующей цифровой вычислительной машине 4, [c.278] но мы обнаружили хорошее согласие между этим спектром и вычисленным ранее вручную методами гетеродинирования, по крайней мере вблизи сильной части спектра.

Рис. 11. Спектр

Рассматривая кривую, мы обнаруживаем замечательное падение мощности в окрестности частоты 9,05 гц. Точка, в которой спектр по существу исчезает, выражена весьма отчетливо и дает объективную величину, которая может быть проверена с гораздо большей точностью, чем любая величина, встречавшаяся до сих пор в электроэнцефалографии. Существуют указания, что на других кривых, которые мы получили, но которые несколько сомнительны в своих подробностях, за этим внезапным падением мощности довольно скоро следует крутой подъем. Таким образом, кривая имеет здесь как бы впадину. Но даже если догадка не верна, многое говорит за то, что концентрация мощности в пике соответствует отсасыванию мощности из области, где кривая идет низко. Стоит отметить, что в полученном спектре основная часть пика лежит в диапазоне шириной 1/3 гц. Любопытно, что на другой электроэнцефалограмме того же субъекта, записанной через четыре дня, ширина пика почти не изменилась и, насколько можно судить, форма его также сохранилась в [c.279] какой-то мере. Есть основание полагать, что у других субъектов ширина пика будет другой и даже меньшей. Для вполне удовлетворительной проверки этого необходимы дальнейшие изыскания.

Весьма желательно, чтобы исследования, здесь упомянутые, были продолжены более точными инструментальными работами, с лучшими приборами, и чтобы благодаря этому гипотезы, высказанные здесь, могли быть окончательно подтверждены или окончательно опровергнуты.

Теперь я хочу перейти к вопросу выборки. Для этого мне понадобятся некоторые идеи из моих предыдущих работ об интегрировании в пространстве функций 5 . С помощью этого аппарата мы сможет построить статистическую модель непрерывного процесса с заданным спектром. Хотя такая модель не воспроизводит в точности процесса формирования мозговых волн, она достаточно близка к нему, чтобы доставить статистически значимую информацию о том, какой среднеквадратической ошибки можно ожидать в спектрах волн, подобных представленному выше.

Здесь я сформулирую без доказательств ряд свойств некоторой действительной функции х(t, α), уже излагавшихся в моей статье по обобщенному гармоническому анализу и в других работах 6 . Действительная функция х(t, α) зависит от переменной t, изменяющейся от –∞ до ∞, и от переменной α, изменяющейся от 0 до 1. Она изображает одну пространственную координату броунова движения, зависящую от времени t и параметра а статистического распределения. Выражение

(10.09)

определяется для всех функций φ(t) класса Лебега L, [c.280] в интервале от –∞ до +∞. Если φ(t) имеет производную, принадлежащую L2, то выражение (10.09) понимается как

(10.10)

и затем определяется для всех функций φ(t) из L2 некоторым вполне определенным предельным процессом. Другие интегралы

(10.11)

вводятся аналогичным образом.

Основная теорема, используемая нами, утверждает, что

(10.12)

можно найти, положив

,

(10.13)

где переменные τk образуются всеми возможными способами путем отождествления всех пар переменных σk, друг с другом (если n четно) 7 , и образовав

(10.14)

Если n нечетно, то

(10.15)

Другая важная теорема, касающаяся этих стохастических интегралов, гласит: пусть F(g) – функционал [c.281] от g(t), такой, что F[x(t, α)] ερςό функция, принадлежащая к L по α и зависящая только от разностей x(t2, α)–х(t1, α); тогда для любого t: и почти всех α

(10.16)

Это эргодическая теорема Биркгоффа, доказанная некогда автором8 и другими.

В упомянутой статье из “Acta Mathematica” установлено, что если U – действительное унитарное преобразование функции K(t), то

,

(10.17)

где β отличается от α только сохраняющим меру преобразованием интервала (0 1) в себя.

Пусть теперь К(t) принадлежит к L2, и пусть

(10.18)

в смысле Планшереля9. Рассмотрим действительную функцию

,

(10.19)

изображающую отклик линейного преобразователя на броунов вход. Она будет иметь автокорреляцию

,

(10.20)

[c.282]

которая, в силу эргодической теоремы, почти для всех значений а будет равна

(10.21)

Тогда спектр почти всегда будет равен

(10.22)

Но это истинный спектр. Выборочная автокорреляция за время усреднения А (в нашем случае 2700 сек) будет равна

(10.23)

В результате выборочный спектр почти всегда будет иметь временное среднее

(10.24)

Следовательно, выборочный спектр и истинный спектр будут иметь одно и то же среднее значение по времени. Для многих целей нам интересен приближенный спектр, в котором интегрирование по т производится только по интервалу (0, В), где В в описанном выше частном случае равно 20 сек. Напомним, что f(t) – действительная функция, а автокорреляция – симметрическая [c.283] функция. Поэтому интеграл от 0 до В можно заменить интегралом от –В до В:

(10.25)

Эта величина будет иметь среднее значение

(10.26)

Квадрат приближенного спектра в интервале (–В, В) будет равен

а эта величина будет иметь среднее значение

 | [c.284]
. | (10.27)

Как известно, если m обозначает среднее, то

(10.28)

Таким образом, среднеквадратическая ошибка приближенного выборочного спектра будет равна

(10.29)

Но

(10.30)

Следовательно, интеграл

(10.31)

равен величине 1/А, умноженной на текущее взвешенное среднее от g(ω). Если усредняемая величина приблизительно постоянна в малом интервале 1/А, как [c.285] можно здесь разумно предположить, мы получим как приближенную главную часть среднеквадратической ошибки в любой точке спектра выражение

(10.32)

Заметим, что если приближенный выборочный спектр имеет максимум при u=10, то величина этого максимума

(10.33)

Эта величина при гладкой функции q(ω) мало будет отличаться от │q(10)│2. Среднеквадратическая ошибка спектра, отнесенная к этой величине как единице измерения, будет равна

(10.34)

и, следовательно, не превосходит

(10.35)

В рассматриваемом случае она равна

(10.36)

Если допускать реальность явления провала, или, по крайней мере, реальность крутого падения нашей кривой на частоте около 9,05 гц, то будет уместно поставить по этому поводу несколько физиологических вопросов. Три главных касаются физиологической функции наблюденных нами явлений, физиологического механизма, производящего их, и применения, которое они могли бы найти в медицине.

Заметим, что резкая линия частоты эквивалентна точным часам. Так как мозг есть в некотором смысле управляющее и вычислительное устройство, естественно спросить, находят ли часы применение в других формах управляющих и вычислительных устройств. И действительно, многие из них содержат часы. Часы применяются [c.286] в таких устройствах в целях стробирования10. Все такие устройства должны комбинировать большое число импульсов в один импульс. Если импульсы передаются простым включением или выключением цепи, их синхронность не имеет большого значения и стробирование не нужно. Однако при подобном способе передачи импульсов вся цепь оказывается занятой вплоть до смены сообщения и значительная часть аппаратуры выводится из действия па неопределенное время. Поэтому желательно, чтобы в вычислительном или управляющем устройстве сообщения передавались комбинированным сигналом включения-выключения. Тогда аппаратура будет сразу же свободна для дальнейшего использования. Достичь этого можно, если сообщения будут запоминаться, чтобы их всех можно было послать одновременно, и затем быстро комбинироваться, пока они еще в машине. Здесь необходимо стробирование, а стробирование удобно осуществлять при помощи часов.

Хорошо известно, что, по крайней мере в длинных нервных волокнах, нервные импульсы переносятся пиками, форма которых не зависит от способа их возникновения. Комбинирование этих пиков – функция синаптического механизма. В этих синапсах несколько входящих волокон соединяются с выходящим волокном. Если надлежащая комбинация входящих волокон возбуждается в течение некоторого весьма короткого промежутка времени, то возбуждается и выходящее волокно. В такой комбинации действие входящих волокон в некоторых случаях аддитивно: если возбуждается больше известного числа волокон, достигается порог, вызывающий возбуждение выходящего волокна. В других случаях некоторые из входящих волокон производят тормозящее действие, совершенно не допускающее возбуждения или, во всяком случае, увеличивающее порог для других волокон. В обоих случаях существен короткий период комбинирования, и если приходящие сообщения не попадают в этот короткий период, они не комбинируются. Поэтому необходим какой-то стробирующий механизм, позволяющий сообщениям прибывать [c.287] почти одновременно. В противном случае синапс не может действовать как комбинирующий механизм 11.

Желательно, однако, найти дальнейшее подтверждение тому, что стробирование действительно имеет место. Здесь уместно упомянуть работу проф. Дональда Б. Линдсли с психологического факультета Калифорнийского университета в Лос-Анджелесе. Он исследовал время реакции при зрительных сигналах. Как хорошо известно, когда приходит зрительный сигнал, возбуждаемые им мышцы действуют не сразу, а с запаздыванием. Линдсли показал, что эта задержка непостоянна и, судя по всему, состоит из трех частей. Одна из них имеет постоянную длительность, тогда как две другие, по-видимому, равномерно распределены в интервале около 1/10 сек. Представляется, что центральная нервная система может воспринимать приходящие импульсы только каждую 1/10 сек и что импульсы от центральной нервной системы могут приходить к мышцам только каждую 1/10 сек. Это является экспериментальным доказательством стробирования, и весьма вероятно, что связь стробирования с одной десятой секунды, составляющей приблизительный период альфа-ритма мозга, не случайна.

На этом закончим обсуждение функции центрального альфа-ритма. Возникает вопрос о механизме, создающем названный ритм. Здесь нужно указать, что альфа-ритм может дрейфовать при мелькании света. Если свет мелькает перед глазом с интервалами, близкими к 1/10 сек, то альфа-ритм мозга изменяется и приобретает сильную составляющую того же периода. Несомненно, мелькание света вызывает электрическое мелькание в сетчатке и, почти наверное, – в центральной нервной системе.

Мы располагаем, однако, прямыми данными, что чисто электрическое мелькание способно вызвать действие, подобное действию светового мелькания. Такой [c.288] опыт был проведен в Германии. В комнате был сделан проводящий пол и к потолку подвешена изолированная проводящая металлическая пластина. Испытуемые помещались а комнату, и потолок и пол соединялись с генератором переменного электрического потенциала. Частота этого потенциала, по-видимому, была близка к 10 гц. Действие потенциала на испытуемых было весьма неприятным, что очень похоже на неприятное действие аналогичного мелькания света.

Конечно, эти опыты нуждаются в повторении при более контролируемых условиях, с непременным снятием одновременных электроэнцефалограмм испытуемых субъектов. Тем не менее мы имеем повод думать, что электрическое мелькание, создаваемое электростатической индукцией, может произвести такое же действие, как мелькание света.

Важно отметить, что, если частоту генератора можно изменять импульсами другой частоты, действующий механизм должен быть нелинейным. Действие линейного механизма на колебание данной частоты может произвести лишь колебание той же частоты, в общем случае с некоторым изменением фазы и амплитуды. Это перестает быть верным для нелинейных механизмов, которые могут производить колебания с частотами, равными суммам и разностям различных порядков от частоты генератора и частоты возмущения. Такой механизм может вызвать сдвиг частоты, и в рассматриваемом случае этот сдвиг будет иметь характер притяжения. Отнюдь не исключено, что притяжение окажется долговременным, вековым явлением и что в течение коротких промежутков времени система будет оставаться приближенно линейной.

Представим себе, что головной мозг содержит ряд генераторов частот, близких к 10 гц, и что в некоторых пределах эти частоты могут притягиваться друг к другу. При таких обстоятельствах частоты, вероятно, будут собираться в одну или несколько небольших групп, по крайней мере, на некоторых участках спектра. Частоты, собранные в эти группы, должны быть перемещены откуда-то, а потому в спектре образуются провалы, где мощность будет меньшей, чем следовало бы ожидать в противном случае. О том, что такое явление действительно могло иметь место в случае индивидуума, [c.289] автокорреляция которого показана на рис. 9, свидетельствует резкое падение мощности на частотах выше 9,0 гц. Падение это было бы нелегко обнаружить с теми низкими разрешающими способностями гармонического анализа, какие были доступны прежним авторам12.

Чтобы сделать правдоподобным такое объяснение происхождения мозговых электрических волн, мы должны рассмотреть, существуют ли в головном мозгу предполагаемые генераторы и какова их природа. Профессор Розеиблит из Массачусетсского технологического института сообщил мне о так называемом явлении остаточного разряда13. Если действовать на глаза световой вспышкой, то потенциалы коры головного мозга, которые можно коррелировать со вспышкой, не возвращаются сразу к нулю, а проходят через последовательность положительных и отрицательных фаз, прежде чем затухнуть. Форму этого потенциала можно подвергнуть гармоническому анализу, причем обнаруживается, что значительная часть мощности сосредоточена в окрестности 10 гц. Подобный результат по меньшей мере не противоречит изложенной здесь теории самоорганизации мозговых волн. Собирание таких кратковременных колебаний в одно непрерывное наблюдалось в других ритмах тела, каков, например, суточный ритм приблизительно в 231/2 часа, наблюдаемый во многих живых организмах14. Этот ритм изменениями во внешней среде может быть превращен в 24-часовой ритм дня и ночи. Биологически не существенно, равняется ли естественный ритм живых организмов в точности 24 часам, если только он может притягиваться к 24-часовому ритму под действием внешней среды. [c.290]

Интересным опытом, способным пролить свет на справедливость моей гипотезы о волнах головного мозга, могло бы, наверное, оказаться исследование светляков или других животных, подобных кузнечикам или лягушкам, которые могут излучать заметные световые или звуковые импульсы и также принимать их. Часто высказывалось предположение, что светляки на дереве вспыхивают в унисон, и это видимое явление приписывалось оптической иллюзии человека. Я слышал, что у некоторых светляков Юго-Восточной Азии это явление выражено столь резко, что его вряд ли можно приписать иллюзии. Но светляк действует двояким образом: с одной стороны, он излучает более или менее периодические импульсы, а с другой, – обладает рецепторами для этих импульсов. Не происходит ли здесь то же, предполагаемое, явление собирания частот?

Для такого исследования необходимы точные записи вспышек, чтобы их можно было подвергнуть точному гармоническому анализу. Кроме того, светляков нужно подвергнуть действию периодического света, например, от неоновой импульсной лампы, и определить, будет ли такой свет иметь тенденцию настраивать светляков на свою частоту. Если да, то нам следует попытаться получить точную запись этих спонтанных вспышек и подвергнуть ее автокорреляционному анализу, как в случае волн головного мозга. Хотя я не осмеливаюсь предсказать исход опытов, которые не ставились, подобное направление исследований кажется мне обещающим и не слишком трудным.

Явление притяжения частот возникает также в некоторых ситуациях, не связанных с живыми организмами. Представим себе ряд генераторов переменного тока, частоты которых регулируются регуляторами, приданными первичным двигателям. Эти регуляторы удерживают частоты в сравнительно узких полосах. Предположим, что выходы генераторов присоединены параллельно к сборным шинам, а с них ток идет на внешнюю нагрузку, которая в общем случае будет подвержена более или менее случайным флюктуациям, вследствие включения и выключения освещения и т.п. Чтобы избежать проблем, какие возникали на электростанциях прежнего типа в связи с участием человека в коммутации, предположим, что включение и выключение [c.291] генераторов происходят автоматически. Когда генератор доведен до скорости и фазы, достаточно близких к скорости и фазе других генераторов системы, автоматическое устройство подключает его к сборным шинам, а если случайно его частота и фаза отклоняются слишком далеко от надлежащих величин, аналогичное устройство автоматически отключает его.

В такой системе генератор, стремящийся вращаться слишком быстро и, следовательно, иметь слишком высокую частоту, берет большую долю нагрузки, чем ему полагается, а генератор, вращающийся слишком медленно, берет меньше своей нормальной доли. В результате частоты генераторов сближаются. Генерирующая система в целом действует как бы под управлением скрытого регулятора, более точного, чем регуляторы отдельных генераторов, и представляющего собой совокупность этих регуляторов вместе с электрическим взаимодействием между ними. Этим, по крайней мере частично, обусловлена точная регулировка частоты электрических генерирующих систем. Потому-то и возможно применение электрических часов высокой точности.

Я предлагаю, чтобы выходы таких систем были исследованы теоретически и экспериментально теми же самыми приемами, какими мы исследовали волны головного мозга.

С исторической точки зрения интересно, что на заре техники переменного тока делались попытки включать генераторы с постоянной величиной напряжения (такие же, как в современных генерирующих системах) не параллельно, а последовательно. Оказалось, что взаимодействие отдельных генераторов по частоте выражалось в отталкивании, а не в сближении. В результате такие системы были недопустимо неустойчивы, если только вращающиеся части отдельных генераторов не были жестко соединены общим валом или зубчатым механизмом. Напротив, параллельное подключение генераторов к общим сборным шинам оказалось внутренне устойчивым, что позволило соединять генераторы разных станций в единую автономную систему. Если воспользоваться биологической аналогией, то параллельная система обладала лучшим гомеостазом, чем последовательная система, и потому выжила, в то время как последовательная была устранена естественным отбором. [c.292]

Итак, мы видим, что нелинейное взаимодействие, создающее притяжение частот, может породить самоорганизующуюся систему, как в случае исследованных нами мозговых электрических волн или в случае сети переменного тока. Возможность такой самоорганизации отнюдь не ограничивается низкими частотами, свойственными этим двум явлениям. Представим себе, например, самоорганизующиеся системы на частотном уровне инфракрасного света или радиолокационных спектров.

Как нам уже приходилось говорить, одной из центральных проблем биологии является способ, посредством которого основные вещества, входящие в гены или вирусы, или, может быть, специфические вещества, вызывающие рак, воспроизводят себя из материалов, лишенных этой специфики, скажем из смеси аминокислот и нуклеиновых кислот. Обычно дается такое объяснение, что одна молекула этих веществ действует в качестве шаблона, с помощью которого меньшие молекулы компонентов смеси располагаются в определенном порядке и объединяются в аналогичную макромолекулу. По существу, это лишь оборот речи, лишь иной способ описания фундаментального феномена жизни, состоящего в том, что новые макромолекулы формируются по образу и подобию существующих макромолекул.

Как бы ни протекал такой процесс, это – динамический процесс, включающий какие-то силы или их эквиваленты. Один из возможных способов представления этих сил состоит s том, чтобы поместить активный носитель специфики молекулы в частотном строении ее молекулярного излучения, значительная часть которого лежит, по-видимому, в области инфракрасных электромагнитных частот или даже ниже. Может оказаться, что специфические вещества вируса при некоторых обстоятельствах излучают инфракрасные колебания, которые обладают способностью содействовать формированию других молекул вируса из неопределенной магмы аминокислот и нуклеиновых кислот. Вполне возможно, что такое явление позволительно рассматривать как некоторое притягательное взаимодействие частот. Так как весь предмет остается еще sub jutlice15 к подробности даже не сформулированы, я воздержусь от более [c.293] конкретных высказываний. Очевидный путь к решению состоит в том, чтобы изучить спектры поглощения и излучения большого количества вирусного вещества, например кристалла мозаичного вируса табака, и затем проследить действие света этих частот на образование дальнейших вирусов от существующего вируса в надлежащей питательной среде. Говоря о спектрах поглощения, я имею в виду явление, которое почти несомненно существует; что касается спектров излучения, то нечто подобное мы имеем в явлении флюоресценции.

Любое такое исследование потребует методой высокой точности для подробного расчета спектров в условиях чрезмерно сильного – в обычном смысле – света с непрерывным спектром. Мы уже видели, что подобная задача встает перед нами при микроанализе мозговых волн и что математика интерференционной спектрографии по существу совпадает с той, какой мы пользовались здесь. Поэтому я делаю специальное предложение, чтобы возможности метода были полностью использованы при изучении молекулярных спектров, и в частности при изучении спектров вирусов, генов и рака. Сейчас преждевременно предсказывать значение этих методов в исследованиях по чистой биологии и в медицине, но я питаю большие надежды, что они могут оказаться чрезвычайно ценными в обеих областях. [c.294]

Далее:
 Приложение I. Розенблют А., Винер Н., Бигелоу Дж. Поведение, целенаправленность и телеология
Приложение II. Винер Н. Машина умнее своего создателя
Приложение III. Винер Н. Кибернетика и человек: Интервью для советского журнала “Природа”
Приложение IV. Винер Н. Машины изобретательнее людей? Интервью для журнала “Юнайтед Стэйтс Ньюс хнд Уорлд Рипорт”)

К оглавлению

ПРИМЕЧАНИЯ

1 Taylor G.I. Diffussion by Continuous Movements. // Proceedindgs of the London Mathematical Society. – Ser. 2. – 1921-1922. – Vol. 20. – P. 196–212.
Вернуться к тексту

2 Barlow J.S., Brown R.M. An Analog Correlator System for Brain Potentials: Technical Report 300, Research Laboratory of Electronics, M.I.T. – Cambridge, Mass., 1955.
Вернуться к тексту

3 Эта работа выполнена в сотрудничестве с лабораторией нейрофизиологии Главной Массачусетсской больницы и лабораторией биофизики связи Массачусетсского технологического института.
 Вернуться к тексту

4 Машины IBM–709 в вычислительном центре Массачусетсского технологического института.
 Вернуться к тексту

5 Wiener N. Generalized Harmonic Analysis. // Acta Mathematica. – 1930. – Vol. 55. – P. 117–258; Wiener N. Nonlinear Problems in Random Theory. – New York: The Technology Press of M.I.T., and John Wiley & Sons, Inc., 1958 (русский перевод: Винер Н. Нелинейные задачи в теории случайных процессов. – М.: ИЛ, 1962. – Ред.)
Вернуться к тексту

6 Wiener N. Generalized Harmonic Analysis. // Acta Mathematica. – 1930. – Vol. 55. – P. 117–258; Wiener N. Nonlinear Problems in Random Theory. – New York: The Technology Press of M.I.T., and John Wiley & Sons, Inc., 1958.
Вернуться к тексту

7 Иными словами, переменные σ1, σ2, …, σn разбиваюися всеми возможными (n-1)(n-3)…(1) способами на пары, и в каждом разбиении k-й пары (σik, σjk) отождествляются в одну переменную τk. Например, K1(τ1)=K1(τ1, τ1)=ΣK(σ1, σ2), K(τ1, τ2)=K(τ11, τ2, τ2)+ K(τ1, τ2, τ1, τ2)+K(τ1, τ2, τ>2, τ1)= ΣK(σ1, σ2, σ3, σ4) и т.д. – Прим. ред.
Вернуться к тексту

8 Wiener N. The Ergodic Theorem. // Duke Mathematical Journal. – 1939. – Vol. 5. – P. 1-39; также в Modern Mathematics for the Engineer. / Ed.: E.F. Beckenbach. – New York: McGrow Hill, 1956. P. 166–186 (русский перевод: Современная математика для инженеров. / Под ред. Э.Ф. Беккенбаха. – М.: ИЛ, 1959. С. 185–215. – Ред.).
Вернуться к тексту

9 Wiener N. Plancherel’s Theorem. // Wiener N. The Fourier Integral and Certain of Its Applications. – Cambridge, England: The University Press; New York: Dover Publications, Inc., 1933. P. 46–71 (гл. “Теорема Планшереля” в кн.: Винер Н. Интеграл Фурье и некоторые его приложения. – М.: Физматгиз, 1963. – Ред.)
Вернуться к тексту

10 Стробированием (gating), или временной селекцией, называется такой способ работы устройства, при котором его цепи реагируют только на сигналы в определенных временных пределах. – Прим. ред.
Вернуться к тексту

11 Это – упрощенная картина происходящего, особенно по отношению к коре головного мозга, так как способность нейронов к действию типа “все или ничего” зависит от их достаточной длины, благодаря которой воспроизведение формы приходящих импульсов в самом нейроне приближается к некоторой асимптотической форме. Однако вследствие малой длины нейронов необходимость синхронизации все же существует, например в коре головного мозга, хотя подробности этого процесса намного сложнее.
Вернуться к тексту

12 Необходимо сказать, что д-р У. Грей Уолтер из Неврологического института им. Бэрдена в Бристоле (Англия) получил некоторые указания на существование узкополосных центральных ритмов Мне не известны подробности его методики, но насколько я понимаю, явление состоит в том, что на полученных им топоскопических картинах мозговых волн, если идти из центра, лучи, указывающие частоту, заключены и сравнительно узких секторах.
Вернуться к тексту

13 Barlow J.S. Rhythmic Activity Induced by Photic Stimulation in Relation to Intrinsic Alpha Activity of the Brain in Man, EEG. // Clin. Neurophysiol. – 1960. – Vol. 12. – P.317–326.
Вернуться к тексту

14 Cold Spring Harbor Symposium on Quantitative Biology. – Vol. XXV (Biological Clocks), The Biological Laboratory, Cold Spring Harbor, Long Island, New York, 1960.
Вернуться к тексту

15 Sub judlce (лат.) –под вопросом. – Прим. ред.


Приложение 1

Розенблют А., Винер Н., Бигелоу Дж. Поведение, целенаправленность и телеология. // Винер Н. Кибернетика, или управление и связь в животном и машине. – 2-е издание. – М.: Наука; Главная редакция изданий для зарубежных стран, 1983. – С. 297–307.

Красным шрифтом в квадратных скобках обозначается конец текста на соответствующей странице печатного оригинала данного издания

Приложение I

ПОВЕДЕНИЕ, ЦЕЛЕНАПРАВЛЕННОСТЬ И ТЕЛЕОЛОГИЯ 1

Артуро Розенблют, Норберт Винер и Джулиан Бигелоу

Настоящий этюд преследует двоякую цель. Во-первых, определить бихевиористический (поведенческий)2 метод исследования естественных событий и классифицировать поведение. Во-вторых, подчеркнуть важность понятия целенаправленности.

Пусть дан некоторый объект, относительно отделенный от окружающей среды для своего изучения. Бихевиористический метод состоит в рассмотрении выхода объекта и отношений между выходом и входом. Под выходом понимается любое изменение, производимое объектом в окружении. Обратно, под входом понимается любое внешнее к объекту событие, изменяющее любым образом этот объект.

Предыдущая формулировка не содержит никакого упоминания о специфической структуре и внутренней организации объекта. Это принципиальное умолчание, ибо на нем основано различие между бихевиористическим и альтернативным функциональным методом. При функциональном анализе, в противоположность бихевиористическому подходу, главную цель составляет внутренняя организация изучаемого образования, его структура и свойства; отношения между объектом и окружением значат сравнительно мало. [c.297]

Из такого определения бихевиористического метода вытекает весьма широкое определение поведения. Под поведением понимается любое изменение объекта но отношению к окружающей среде. Это изменение может представлять собой преимущественно выход объекта при минимальном, дальнем или побочном входе; или же оно может быть непосредственно приписано определенному входу. В итоге любое преобразование объекта, заметное извне, может быть отмечено как поведение. Термин был бы поэтому слишком общим, чтобы приносить пользу, если бы не возможность ограничения его соответствующими прилагательными, другими словами, возможность классификации поведения.

Изменения энергии, сопутствующие поведению, дают основание для классификации. Активным поведением является такое, при котором объект служит источником выходной энергии, используемой в данной специфической реакции. Объект может аккумулировать энергию, приносимую дальним или относительно близким входом, но вход непосредственно не возбуждает выхода. При пассивном поведении, напротив, объект не составляет источника энергии; вся энергия в выходе должна быть приписана непосредственно входу (пример – бросание предмета), или же объект способен управлять энергией, остающейся внешней к нему в течение всей реакции (парящий полет птицы).

Активное поведение можно подразделить на два класса: нецеленаправленное (или случайное) и целенаправленное. Термин “целенаправленное” здесь означает, что действие или поведение допускает истолкование как направленное на достижение некоторой цели, т.е. некоторого конечного состояния, при котором объект вступает в определенную связь в пространстве или во времени с некоторым другим объектом или событием. Нецеленаправленным поведением является такое, которое нельзя истолковать подобным образом.

Слова “допускает истолкование”, употребленные выше, могут показаться настолько туманными, что все различие теряет смысл. Однако признание, что поведение иногда бывает целенаправленным, – дело неизбежное и полезное, как можно видеть из следующего. В основе понятия целенаправленности лежит представление о нашей “произвольной деятельности”. Но целенаправленность [c.298] произвольных действий – это не вопрос субъективной интерпретации, а физиологический факт. Совершая произвольное действие, мы произвольно выбираем специфическую цель, а не специфическое движение. Так, решив взять стакан с водой и поднести его ко рту, мы не приказываем определенным мышцам сократиться в определенной степени и в определенной последовательности – мы просто задаемся целью, и реакция следует автоматически. Экспериментальная физиология была до сих пор по существу неспособна объяснить механизм произвольной деятельности. Мы осмеливаемся связать эту неудачу с тем обстоятельством, что экспериментатор, раздражающий двигательные области коры головного мозга, отнюдь не воспроизводит произвольной реакции; он задаст эффективные, “выходные” пути, по не задает цели, как при произвольном движении.

Часто выражался взгляд, что все машины целенаправленны. Это несостоятельный взгляд. Во-первых, можно сослаться на механические устройства типа рулетки для азартной игры, специально созданные для нецеленаправлепности. Далее, существуют устройства типа часов, созданные, правда, с определенной целью, но обладающие нецеленаправленным, хотя и регулярным, поведением; в самом деле, нет никакого специфического конечного состояния, к которому стремилось бы движение часов. Подобно этому, хотя ружье можно использовать для вполне определенной цели, целенаправленность не присуща внутренне его действию; возможна случайная пальба, нарочито бесцельная.

Некоторые машины, с другой стороны, внутренне целенаправленны. Возьмем, например, торпеду, снабженную механизмом поиска цели. Для обозначения машин с внутренне целенаправленным поведением был специально выкован термин “сервомеханизм”.

Эти соображения показывают, что хотя определение целенаправленного поведения остается относительно смутным и лишенным точного операционального значения3, самое понятие целенаправленности полезно и заслуживает сохранения. [c.299]

Целенаправленное активное поведение можно подразделить на два класса: “с обратной связью” (или “телеологическое”) и “без обратной связи” (или “нетелеологическое”). Выражение “обратная связь” употребляется инженерами в двух различных смыслах. В широком смысле оно означает, что часть выходной энергии аппарата или машины возвращается как вход; примером может служить электрический усилитель с обратной связью. Обратная связь в этих случаях положительна: часть выхода, снова поступающая в объект, имеет тот же знак, что и первоначальный входной сигнал. Положительная обратная связь прибавляется к входным сигналам, она не корректирует их. Термин “обратная связь” применяется также в более узком смысле для обозначения того, что поведение объекта управляется величиной ошибки в положении объекта по отношению к некоторой специфической дели. В этом случае обратная связь отрицательна, т.е. сигналы от цели используются для ограничения выходов, которые в противном случае шли бы дальше цели. Это второе значение термина “обратная связь” и имеется здесь в виду.

Можно считать, что всякое целенаправленное действие требует отрицательной обратной связи. Если цель должна быть достигнута, то в какой-то момент необходимы сигналы от нее, чтобы направить поведение. Под поведением без обратной связи понимается такое, при котором сигналы от цели не изменяют деятельности объекта в процессе поведения. Так, можно послать машину сразить светящийся объект, хотя машина может быть нечувствительна к свету. Подобно этому змея может броситься на лягушку или лягушка – на муху, не получая зрительных или иных впечатлений от жертвы после начала движения. Действительно, движение в этих случаях происходит настолько быстро, что нервные импульсы едва ли имеют время сформироваться в сетчатке глаза, дойти до центральной нервной системы и возбудить новые импульсы, которые бы своевременно достигли мышц для эффективной перемены поведения.

В противоположность рассмотренным примерам поведение некоторых машин и некоторые реакции живых организмов включают в себя непрерывную обратную связь от цели, изменяющую и направляющую [c.300] действующий объект. Этот тип поведения эффективнее, чем предыдущий, особенно когда цель нестационарна. Но управление с непрерывной обратной связью способно привести к весьма неуклюжему поведению, если обратная связь плохо демпфирована и для некоторых частот колебаний вместо отрицательной становится положительной. Предположим, например, что построена машина для поражения движущейся светящейся цели; траектория, описываемая машиной, регулируется направлением и силой света от цели. Предположим, что следуя движению цели в определенном направлении, машина далеко проскочит за цель и что будет приложено чрезмерно большое усилие, чтобы развернуть машину в противоположном направлении. Если это движение вновь промахнется, начнется серия все более сильных колебаний, и машина упустит цель.

Эта картина последствий недемпфированной обратной связи удивительно напоминает то, что наблюдается при выполнении произвольного действия больным, у которого поврежден мозжечок. В состоянии покоя субъект не обнаруживает заметного двигательного расстройства. Если, однако, попросить его поднести ко рту стакан с водой, то рука, несущая стакан, будет совершать, по мере приближения к цели, серию колебательных движений возрастающей амплитуды; в результате вода расплещется, и намерение не будет осуществлено. Этот симптом типичен для расстроенной моторики больных с мозжечковым заболеванием. Аналогия с поведением машины, наделенной недемпфированной обратной связью, столь очевидна, что мы решаемся видеть главную функцию мозжечка в регулировании нервных механизмов обратной связи, участвующих в целенаправленной двигательной активности.

Целенаправленное поведение с обратной связью можно опять подразделить. Оно может быть экстраполирующим (предсказывающим) или неэкстраполирующим (непредсказывающим). Реакции одноклеточных организмов, так называемые тропизмы, дают примеры непредсказывающего поведения. Амеба просто следует за источником, на который она реагирует; нет никаких данных о том, что она экстраполирует его траекторию. С другой стороны, предсказывающее поведение животных – самая обыкновенная вещь. Кошка, начинающая [c.301] преследование бегущей мыши, не бежит прямо к месту, где мышь в данный момент находится, а движется к экстраполированному будущему положению. Не составит также труда найти примеры предсказывающих и непредсказывающих сервомеханизмов.

Предсказывающее поведение можно подразделить на различные порядки. Кошка, охотящаяся за мышью, – пример предсказания первого порядка; она предсказывает только мышиный путь. Бросание камня в движущуюся мишень требует предсказания второго порядка; здесь необходимо предвидеть пути мишени и камня. Примером предсказания более высокого порядка является стрельба из рогатки или лука.

Предсказывающее поведение требует различения по меньшей мере двух координат: оси времени хотя бы одной пространственной оси. Предсказание, однако, будет эффективнее и гибче, если действующий объект способен реагировать па изменения более чем в одной пространственной координате. Чувствительные рецепторы организма или соответствующие им элементы машины могут поэтому ограничивать предсказывающее поведение. Так, собака-ищейка следует следу; предсказывающее поведение ей не доступно, потому что химический, обонятельный вход приносит только пространственную информацию – расстояние, указываемое силой запаха. Внешние изменения, способные возбуждать слуховые или, еще лучше, зрительные рецепторы, допускают более точную пространственную локализацию; отсюда возможность более эффективных предсказывающих реакций при действии входа на эти рецепторы.

Способность к предсказывающим действиям встречает, помимо того, ограничения во внутренней организации действующего объекта. Так, машина, предназначенная для предсказывающего слежения за подвижной светящейся целью, должна не только быть чувствительна к свету (например, через приданный ей фотоэлемент), но и обладать структурой, пригодной для расшифровки светового входа. Представляется вероятным, что ограничения внутренней организации, особенно организации центральной нервной системы, определяют сложность предсказывающего поведения, которой может достичь млекопитающее. Так, можно подумать, что нервная система крысы или собаки не позволяет им [c.302] осуществлять интеграцию входа и выхода, необходимую дли предсказывающей реакции третьего или четвертого порядка. Действительно, одна из особенностей скачка, наблюдаемого при сравнении человека с другими высшими млекопитающими, заключается, по-видимому, в том, что последние способны лишь к предсказывающему поведению низшего порядка, тогда как человек потенциально способен к весьма высоким порядкам предсказания.

Ниже приводится таблица предлагаемой классификации поведения:

Нетрудно видеть, что каждая из дихотомий произвольно выделяет одну черту, признаваемую интересной, оставляя аморфный остаток – не-класс. Очевидно также, что критерии отдельных дихотомий разнородны. Понятно поэтому, что существует много других линий классификации, независимых от рассмотренных. Так, можно разделить поведение в целом или внутри каждой из табличных групп па линейное (выход пропорционален входу) и нелинейное. Для многих целей было бы полезно деление на непрерывное и дискретное поведение. Различные степени свободы, свойственные поведению, также могут служить основанием систематизации.

Классификация, представленная в предыдущей таблице, была выбрана по нескольким причинам. Она приводит к выделению класса предсказывающего [c.303] поведения – особо интересного класса, ввиду открывающейся возможности систематизировать все более сложные критерии поведения организмов. Она делает упор на понятиях целенаправленности и телеологии, понятиях, как мы видели, большого значения, хотя и дискредитированных сегодня. Наконец, она показывает, что единообразный бихевиористический анализ применим как к машинам, так и к живым организмам, независимо от сложности поведения.

Иногда утверждалось, что конструкторы машин просто пытаются воспроизводить действия живых организмов. Это некритическое мнение. В том, что поведение некоторых машин являет грубое сходство с реакциями организмов, нет ничего необычайного. Поведение животных включает много разновидностей всех возможных способов поведения, а изобретенные до сих пор машины еще очень далеки от исчерпания всех этих возможностей. Отсюда значительное перекрытие двух названных областей поведения. Нетрудно, однако, найти примеры созданных человеком машин, поведение которых превосходит человеческое поведение. Взять хотя бы машины с электрическим выходом; ведь люди, в отличие от электрических рыб, неспособны к испусканию электричества. Еще лучше, пожалуй, пример радио: не известно ни одного животного, которое обладало бы способностью к генерации коротких волн, даже если принимать всерьез так называемые опыты по телепатии.

Дальнейшее сравнение животных организмов и машин приводит к следующим выводам. В настоящее время методы изучения обеих групп подобны. Будут ли они столь же близки всегда, зависит, по всей видимости, от существования или несуществования качественно особых, уникальных характеристик, свойственных одной группе и отсутствующих у другой. Покамест таких качественных различий не обнаружено.

Общие классы поведения одинаковы для машин и для живых организмов. Специфические, узкие классы могут принадлежать исключительно одной или другой группе. Так, никакая из существующих машин не могла бы написать санскрито-мандаринский словарь4. С другой [c.304] стороны, мы не знаем ни одного живого организма, который бы катился на колесах; представим себе, каковы бы были последствия, если бы инженеры настаивали на копировании живых организмов и вместо колес снабжали бы свои локомотивы руками и ногами!

В то время как бихевиористический анализ машин и живых организмов в основном единообразен, функциональное исследование их обнаруживает глубокие различия. Структурно организмы по преимуществу коллоидальны и содержат главным образом белковые молекулы – большие, сложные и анизотропные; машины чаще всего металлические и содержат главным образом малые молекулы. С энергетической точки зрения машины обыкновенно отличаются высокими разностями потенциалов, обеспечивающими быструю мобилизацию энергии; в организмах энергия распределена равномернее и не очень мобильна. Так, в электрических машинах проводимость большей частью электронная, тогда как в организмах электрические изменения обыкновенно ионные.

В машинах широта и гибкость достигаются в основном умножением эффектов во времени; легко получаются и используются частоты в миллион герц и выше. В организмах правилом является не временное, а пространственное умножение; временные достижения бедны – самые быстрые нервные волокна могут проводить только около тысячи импульсов в секунду; пространственное же умножение обильно и изумительно в своей компактности. Это различие хорошо иллюстрируется сравнением телевизора и глаза. Телевизор можно рассматривать как одноколбочковую сетчатку; образы формируются разверткой, т.е. регулярным последовательным детектированием сигнала со скоростью около 20 миллионов в секунду. Развертка – это процесс, который редко, если когда-либо вообще, встречается в организмах, требуя высоких частот для эффективного осуществления5. Глаз же использует пространственный умножитель. Вместо единственной колбочки телевизора мы находим в человеческом глазу около шести с половиной [c.305] миллионов колбочек и около ста пятнадцати миллионов палочек.

Если бы инженеру пришлось конструировать робота, грубо подобного по своему поведению некоторому живому организму, то сегодня он не стал бы обращаться для этого к белкам и иным коллоидам. Он, вероятно, построил бы его из металлических частей, диэлектриков и многочисленных электронных ламп. Движения робота могли бы быть гораздо быстрее и сильнее соответствующих движений первоначального организма. Зато обучение и память оставались бы весьма рудиментарными. В будущие годы, когда знание коллоидов и белков возрастет, будущие инженеры смогут взяться за конструирование роботов, подобных тому или иному млекопитающему не только по поведению, но и по структуре. Окончательной моделью кошки может быть только другая кошка, рождена ли она еще от одной кошки или же синтезирована в лаборатории.

В нашей классификации поведения термин “телеология” употреблялся как синоним “целенаправленности, управляемой обратной связью”. В прошлом телеологию толковали как нечто предполагающее цель и часто добавляли сюда смутное понятие “конечной причины”. Это понятие конечных причин вызвало противопоставление телеологии и детерминизма. Обсуждение причинности, детерминизма и конечных причин не входит в нашу задачу. Можно отметить, однако, что целенаправленность, как она здесь была определена, совершенно не зависит от причинности, начальной или конечной. Телеология была дискредитирована главным образом потому, что при прежнем ее определении причина должна следовать во времени за действием. Однако с крушением этого аспекта телеологии было, к сожалению, отказано в признании и всякой целенаправленности. Мы видим в целенаправленности понятие, необходимое для познания некоторых определенных способов поведения, и считаем, что телеологический подход полезен, если только не касаться проблем причинности и довольствоваться исследованием целенаправленности как таковой. Мы ограничили содержание телеологического поведения, прилагая последнее наименование лишь к таким целенаправленным реакциям, которые управляются ошибкой реакции, т.е. разностью между состоянием [c.306] действующего объекта в данный момент и конечный состоянием, принимаемым за цель. Тем самым телеологическое поведение становится равнозначным поведению, управляемому отрицательной обратной связью, и, теряя соответственно в широте, выигрывает как понятие в точности.

Согласно этому узкому определению, телеология противоположна не детерминизму, а не-телеологии. Как телеологические, так и нетелеологические системы будут детерминистическими, коль скоро рассматриваемое поведение относится к области, где детерминизм вступает в силу. Понятие телеологии имеет с понятием причинности лишь один общий элемент – ось времени. Но причинность означает одностороннюю, относительно необратимую функциональную зависимость, тогда как телеология связана с поведением – не с функциональными зависимостями.

Гарвардская медицинская школа
и Массачусетсский технологический институт [c.307]

Далее:
Приложение II. Винер Н. Машина умнее своего создателя

К оглавлению

ПРИМЕЧАНИЯ

1 Rosenbluelh А., Wiener N., Bigelow J. Behavior, Purpose and Teleology. // Philosophy of Science. - Baltimore, 1943. - Vol. 10. - № 1. - Р. 18—24.
Вернуться к тексту

2 От англ. behavior — “поведение”. Напрашивается сопоставление с бихевиоризмом в психологии (Дж. Б. Уотсон н др.), однако по существу речь идет о самостоятельном, отдельном направлении. Насколько можно судить, авторы не применяют специфических положений школы Уотсона и не отрицают, подобно ему, психики и сознания. Впрочем, в современной зарубежной литературе термин “бихевиоризм” употребляется и просто как название науки о поведении. — Прим. ред.
Вернуться к тексту

3 Операциональное определение понятия – определение, допускающее точную проверку через эксперименты или измерение. – Прим. ред.
Вернуться к тексту

4 “Мандаринский язык” – старое название северного (пекинского) диалекта китайского языка. – Прим. ред.
Вернуться к тексту

5 Позже, в связи с исследованием альфа–ритма, Винер пришел к мысли о наличии в зрительном механизме мозга групповой развертки (“Кибернетика”, гл. VII). – Прим. ред.


Винер Н

Винер Н. Кибернетика, или управление и связь в животном и машине. – 2-е издание. – М.: Наука; Главная редакция изданий для зарубежных стран, 1983. – С. 308–314.

Красным шрифтом в квадратных скобках обозначается конец текста на соответствующей странице печатного оригинала данного издания

Приложение II

МАШИНА УМНЕЕ СВОЕГО СОЗДАТЕЛЯ1

Норберт Винер

Последние десять лет были свидетелями появления нового взгляда на технику связи и на автоматы как устройства связи. Проделанную здесь работу можно уже разделить на два этапа. Первым из них был тот, на котором фигурировала моя собственная работа и на котором Клод Шеннон – один из наиболее оригинальных исследователей в этой области – направил усилия на прояснение самого понятия связи, на теорию и практику измерения связи, на анализ управления как явления по существу одной природы со связью и вообще на грамматику новой науки, которую я назвал кибернетикой.

Работа д-ра Эшби представляет раздел кибернетики, зародившийся еще на заре науки и посвященный не столько элементарным вопросам дефиниции и словаря, сколько тем вопросам философии предмета, которые затрагивают специфические свойства кибернетических систем и которые, хотя и связаны с определениями, являются вопросами фактов и логики и далеко выходят за рамки определений. [c.308]

К вопросам, исследуемым д-ром Эшби, принадлежат, в частности, следующие: что такое обучение? должна ли способность к обучению вкладываться в машину посредством некоторой весьма специфической организации или явления обучения может обнаруживать машина с организацией, в значительной мере случайной? может ли машина быть умнее своего создателя?

Все эти вопросы можно ставить в двух различных планах. В плане чисто биологическом подобные рассуждения занимала биологов с тех пор, как биология вышла из стадии чисто теологических обоснований; они касаются самой сущности проблем эволюции, особенно дарвиновской эволюции через естественный отбор. В плане механическом эти проблемы возникают по поводу гораздо более ограниченных машин, которые создает человек, и условий, которым он должен подчиняться, сознательно присваивая себе функции демиурга. [c.309]

Машины, создаваемые человеком, и машины, создаваемые природой

Вполне признавая большую эффективность и приспособляемость структуры и действия природных машин по сравнению с машинами рукотворными, необходимо в то же время отметить, что эти вторые внесли в арсенал науки новое оружие как для естественного эксперимента, так и для мысленного. Роль их сходна с ролью плодовой мушки – дрозофилы. Последняя как будто , была нарочно создана для того, чтобы превратить генетику из науки вековых наблюдений, какой она была бы неизбежно в случае ограничения наблюдениями над человеком и крупными домашними животными, в науку, совместимую с пространственными и временными ограничениями небольшой биологической лаборатории. Точно так же машины, созданные человеком, обещают свести наше изучение биологических процессов обучения и приспособления, индивидуального развития и эволюции к такому масштабу, при котором мы сможем разбирать эти зыбкие понятия с уверенностью и точностью, сравнимой с тем, что мы имеем в физической и технической лаборатории. Среди ученых, которые не [c.309] только говорят об этих вещах, но и действительно что-то делают, д-р Эшби занимает одно из ведущих мест.

Главная идея естественного отбора, примененная Даренном к теории эволюции, заключается в том, что земная флора и фауна состоят из форм, которые дошли до нас просто как остаточные формы, а не в силу какого-либо прямого процесса стремления к совершенству. Это не кусок мрамора, превращающийся в совершенное изваяние под руками художника-творца, а скорее один из тех изваянных ветром столбов песчаника, которые украшают каньоны штата Юта. Случайные процессы эрозии, соединяясь, образовали эти каменные столбы, имеющие вид замков и памятников и даже фигур людей и животных. Но их красота и образность не такие, как красота и образность картины, а такие, как у роршаховских пятен,– иными словами, не для глаза художника, а для глаза зрителя. Подобно этому, кажущаяся теодицея, на которую намекает великолепие и разумность бесконечно сложного царства природы, представляет собой, согласно дарвинизму, лишь то, что осталось после случайного процесса роста и изменения, когда более мягкие и менее прочные проявления разрушились под действием песка времени и под бременем собственной слабости. [c.310]

Устойчивость – характеристика мира

Природа располагает еще одним способом демонстрации остаточных форм, родственным естественному отбору, но с иным акцентом. Со времени открытий супругов Кюри мы знаем, что атомы некоторых элементов испытывают прогрессивный метаморфоз. Если взять атом радия, то рано или поздно с ним обязательно произойдет метаморфоз, при котором он начинает испускать радиевые эманации. Мы не может сказать, когда произойдет это превращение, ибо, по всей видимости, оно происходит случайно. Но мы можем сказать, что через некоторое время, называемое временем полураспада радия, вероятность того, что превращение произошло, будет равна одной второй.

Но радиоактивные элементы испытывают не [c.310] одно-единственное превращение, а целую серию последовательных превращений в другие элементы, и каждое из них имеет свое время полураспада. Про элементы с большим временем полураспада можно сказать, что они устойчивы, про элементы с малым временем полураспада – что они неустойчивы. Если проследить теперь какой-нибудь элемент в его превращениях, то, как правило, он будет существовать длительное время в виде элементов с большим периодом полураспада и короткое время – в виде элементов с малым периодом полураспада.

В результате, наблюдая процесс очень долго, мы найдем, что элементы с большим периодом полураспада встречаются чаще, чем элементы с малым периодом полураспада. Это значит, что исследование, исходящее из частоты наблюдаемых элементов и не прослеживающее судеб единичного атома, легко упускает высокорадиоактивные материалы с малым периодом полураспада. Отсюда мы видим, что устойчивость свойственна большей части мира. Таким образом, отсутствие неустойчивых форм, которое мы обнаруживаем в биологических рядах вследствие их неспособности выживать в борьбе за существование, наблюдается в эволюции радиоактивных элементов потому, что неустойчивые формы проходят столь быстро, что мы не замечаем их в той же степени, как замечаем формы более устойчивые.

Одним из следствий подобного статистического преобладания устойчивости во вселенной является то обстоятельство, что мы знаем очень мало о происходящем в критические периоды неустойчивости. Возьмем, например, хорошо известный эффект, открытый Артуром Комптоном: при столкновении фотона с электроном оба отскакивают в направлениях, которые определяются лишь статистически. Существует по меньшей мере подозрение, что на самом деле электрон и фотон, первоначально не соединенные, вступают здесь в соединение на слишком короткий промежуток времени, чтобы мы могли определить действительный ход событий, и что затем они выходят из этого соединения через все более слабые соединения, каждое из которых протекает по-своему. Некоторые физики, например Вом, высказывали предположение, что действительный ход [c.311] событий не является столь неопределенным, но что в течение того ничтожного промежутка времени, когда частицы находятся вместе, имеет место очень сложная последовательность событий, определяющая их дальнейшее поведение. Если это верно, то значительная часть важнейших физических явлений нам не известна, ибо мы проходим сквозь них слишком быстро и не умеем их регистрировать.

Из этих двух видов естественного отбора: через разрушение непригодного и через слишком поспешное прохождение по неустойчивому – последний есть единственно возможный при явлениях сохранения, препятствующих простому устранению неустойчивого. Эшби рассматривает весьма сложные, машины, в которых элементы соединены между собой более или менее случайным образом, так что мы знаем кое-что о статистике соединений и очень мяло о деталях таковых. Машины эти, вообще говоря, разрушаются очень быстро, если не вводить в них предохранительных элементов, наподобие амплитудных ограничителей в электрических схемах. Действие таких ограничителей придает системе некоторую консервативность. Поэтому машины Эшби стремятся проводить большую часть своего существования в относительно устойчивых состояниях, а их неустойчивые состояния, хотя и существуют, но так ограничены во времени, что очень мало проявляются при статистическом изучении системы.

Следует помнить, что в явлениях жизни и поведения нас интересуют относительно устойчивые, а не абсолютно устойчивые состояния. Абсолютная устойчивость достижима лишь при очень больших значениях энтропии и по существу равносильна тепловой смерти. Если же система ограждена от тепловой смерти условиями, которым она подчинена, то она будет проводить большую часть своего существования в состояниях, которые не являются состояниями полного равновесия, но подобны равновесным. Иными словами, энтропия здесь не абсолютный, а относительный максимум или, по крайней мере, изменяется очень медленно в окрестностях данных состояний. Именно такие квазиравновесные – не истинно равновесные – состояния связаны с жизнью и мышлением и со всеми другими органическими процессами. [c.312]

Машины с глазами и ушами?

Мне кажется, будет вполне в духе д-ра Эшби сказать, что эти квазиравновесные состояния, как правило, суть состояния, при которых имеет место относительно слабый обмен энергией между системой и окружающей средой, но зато относительно большая информационная связь между ними. Системы, рассматриваемые д-ром Эшби, имеют глаза и уши и таким путем получают сведения для приспособления ко внешней среде. Они приближаются к автоматам по своему внутреннему энергетическому балансу, но очень далеки от них по своему внешнему энтропийному, или информационному балансу. Поэтому равновесие, к которому они стремятся, – это равновесие, при котором они хорошо приспособлены к изменениям во внешней среде и в известной степени нечувствительны к таким изменениям. Они находятся в состоянии частичного гомеостаза.

Д-р Эшби конструирует свой гомеостат как прибор, имеющий именно такую связь со внешней средой и обнаруживающий некоторую случайность во внутреннем строении. Такая машина в известной степени может обучаться, т.е. приспособляться формами своего поведения к устойчивому равновесию с окружением. Однако реальные гомеостаты, разработанные пока д-ром Эшби, хотя и способны поглощать информацию из окружения, содержат в своем внутреннем строении количество информации и решений, заведомо превосходящее то, которое проходит через их, так сказать, органы чувств. Короче говоря, эти машины могут обучаться, но они отнюдь не умнее своих создателей или примерно столь же умны. Тем не менее д-р Эшби полагает, что можно действительно создать машины, которые были бы умнее своих создателей; и в этом я с ним совершенно согласен. Количество информации, которое может воспринимать через свои органы чувств прибор, нельзя априори ограничивать теми значениями, при которых требуется не больше решений, чем уже было заложено в структуру прибора. Обыкновенно способность системы поглощать информацию растет на первых порах довольно медленно по сравнению с количеством информации, заложенной в нее. И лишь после того, как заложенная информация перейдет за некоторую точку, [c.313] способность машины поглощать дальнейшую информацию начнет догонять внутреннюю информацию ее структуры. Но при некоторой степени сложности приобретенная информация может не только сравняться с той, которая была первоначально заложена в машину, но и далеко ее превзойти, н с этой стадии сложности машина приобретает некоторые из существенных характеристик живого существа. [c.314]

Необходима сложность

Рассматриваемая ситуация допускает любопытное сравнение с атомной бомбой, с атомным реактором или с огнем в очаге. Если вы попытаетесь построить атомный реактор или атомную бомбу слишком малых размеров или зажечь большое лубовое полено одной спичкой, вы убедитесь, что всякая запущенная вами атомная или химическая реакция угаснет, как только будет удален ее возбудитель, и никогда не будет расти или оставаться на одном уровне. Лишь когда воспламенитель достигнет определенной величины, или в атомном реакторе соберется определенное количество молекул, или масса изотопа урана достигнет определенного взрывного размера, положение изменится, и мы увидим не только мимолетные и неполные процессы. Точно так же действительно существенные и активные явления жизни и обучения начинаются лишь после того, как организм достигнет некоторой критической ступени сложности; и хотя эта сложность, вероятно, достижима при помощи чисто механических, не слишком трудных средств, тем не менее потребуется предельное их напряжение.

Из этого разбора, посвященного лишь некоторым идеям книги д-ра Эшби, можно заключить, что она открывает нам широкий взгляд на новые рубежи мысли. Д-р Эшбн, хотя в сущности и обладает сильным математическим воображением, не является в полном смысле профессиональным математиком, и профессиональным математикам надлежит осуществить многие из набросанных им идей. Он не причисляет себя к профессиональным математикам, но он, несомненно, обладает принципиальностью и талантом, и книгу его надо читать как одни из первых плодов на ниве, заслуживающей усердного возделывания. [c.314]

Далее:
Приложение III.
Винер Н. Кибернетика и человек: Интервью для советского журнала “Природа”
К оглавлению

ПРИМЕЧАНИЕ

1 Wiener N. A Machine Wiser Than Its Maker. // Electronics. – 1953. – Vol. 26. – № 6. – Р. 368–374. Этот этюд Винера является откликом на книгу английского ученого У.Р. Эшби “Конструкция мозга”, вышедшую в 1952 г. н составившую важный этап в формировании кибернетики (Ashbу W.R. Design for a Braian. – New York: John Wiley & Sons, 1952; русский перевод со 2-го англ. изд.: Эшби У.Р. Конструкция мозга. – М.: ИЛ, 1962). Впоследствии Эшби написал “Введение в кибернетику” (Ashbу W.R. An Introduction to Cybernetics. – London: Chapman & Hall, 1956; русский перевод: Эшби У.Р. Введение в кибернетику. – М.: ИЛ, 1958).– Прим. ред.


Винер Н

Винер Н. Кибернетика и человек: Интервью для советского журнала “Природа”. // Винер Н. Кибернетика, или управление и связь в животном и машине. – 2-е издание. – М.: Наука; Главная редакция изданий для зарубежных стран, 1983. – С. 315–318.

Красным шрифтом в квадратных скобках обозначается конец текста на соответствующей странице печатного оригинала данного издания

Приложение III

КИБЕРНЕТИКА И ЧЕЛОВЕК 1
(Интервью для советского журнала “Природа”)

Вопрос. Каково Ваше мнение относительно возможности развития математики при помощи машин? Можем ли мы ожидать, что таким путем будут открыты новые теоремы или созданы новые доказательства уже существующих?

Ответ. В настоящее время уже созданы такие машины, которые не только производят сложные вычислительные операции, но также способны проверять и исправлять программу, составленную для этих машин. Можно поэтому сказать, что такие машины, в прямом смысле этого слова, сами себя обучают. Ныне идет работа по созданию таких машин, которые имеют возможность сами открывать новые теоремы из области геометрии или логики. В таком направлении работает, например, д-р Соломон из фирмы ИБМ. Принцип действия таких машин заключается в том, что различные доказательства связываются между собой па основе некоторых заранее установленных критериев. Машина сохраняет только те доказательства, которые этим критериям лучше других соответствуют, и отбрасывает все остальные. Здесь возникает важная проблема, которая интересна с философской стороны. А именно: какое [c.315] соотношение существует между индуктивной и дедуктивной логикой?

Обычно новые теоремы или новые доказательства известных теорем сначала формулируются индуктивным путем, а затем доказываются строго логически, т.е. дедуктивно. В этом направлении работает известный японский математик Ватанабе. Он исходит из общих гипотез, справедливость которых может быть оценена при помощи чисел. Применяя этот метод, Ватанабе в состоянии, сравнивая гипотезы, выбрать те, которые соответствуют данному предположению и которые справедливы также в других аналогичных случаях. Данная ситуация очень похожа на ту, которая возникает при определении оптимальной стратегии в теории игр.

Тут появляется то парадоксальное обстоятельство, что, применяя в этих целях вычислительные машины, мы решает проблемы индуктивной логики при помощи дедуктивной. Этот метод очень важен потому, что он дает нам представление о том, как у человека происходит процесс индукции. Обычно принимается, что индукция по существу состоит в выборе правильного результата из бесконечного числа возможностей. Однако на практике оказывается, что выбор ограничивается только конечным числом возможностей и, что самое удивительное, это число очень мало. Осознание данного факта имеет большое практическое значение.

Вопрос. Известно, что у живых организмов существуют функции, которые с успехом используются в технических устройствах, например принцип обратной связи в автоматике. Каково Ваше мнение, есть ли еще какие-нибудь принципы такого рода?

Ответ. Паши нынешние автоматические машины отличаются тем, что они могут правильно работать лишь в том случае, если они получают от человека необходимую им информацию и в самой точной форме. Это означает, что характер информации, вводимой в машину, в общем смысле должен быть точно и заранее известен человеку. Живые организмы, наоборот, развивают необходимую им информацию благодаря постоянному взаимодействию с природой. Это означает, что возникновение информации в живых организмах есть исторически развивающийся процесс. Мне бы хотелось еще раз подчеркнуть, что речь здесь идет именно о [c.316] взаимодействии и обмене с окружающей средой. Можно сказать, что живые организмы сами себя организуют. Как уже было показано в моих работах, о которых я рассказывал на докладе в Политехническом музее в Москве, такие явления самоорганизации имеют место и в технических устройствах. Примером могут служить электрические генераторы, имеющие несколько различных частот; будучи укрепленными на одной оси, они автоматически принуждаются генерировать на вполне определенной резонансной частоте.

Как показал недавно состоявшийся в Москве I конгресс ИФАК, человек в настоящее время уже в состоянии конструировать такие самоорганизующиеся машины. Это представляет собой новую главу в истории техники.

Вопрос. Успехи кибернетики настолько значительны, что в последнее время появились суждения о том, что машина якобы может полностью заменить человека. Каково Ваше мнение по этой проблеме?

Ответ. Различие между человеком и машиной, прежде всего, заключается в том, что в организме человека число элементов по порядку величин во много раз больше, чем обладает машина. Из этого непосредственно вытекает, что организация элементов в организме настолько сложна, что при помощи наших современных логических средств мы не можем еще овладеть этой сложностью. Я бы даже не решился сейчас дать определение понятия “сложность”.

Помимо этого количественного различия, существует еще качественное отличие. Преимущество человека состоит в его гибкости, в его умении работать с неточными идеями. Это означает, что человек обладает фантазией, другими словами, он создает понятие. Преимущества машин – в скорости и точности.

В некоторых странах, в том числе в США, заметна тенденция к “обожествлению” машин, к попытке приписать им такие возможности, которыми они в действительности не обладают. В этом заключается большая опасность.

Далее, наши машины нуждаются в программах. Эти программы могут, правда, быть составлены другими машинами, однако для этих машин программу должен опять-таки составить человек. Данную мысль можно [c.317] продолжить – это означает, что подвижна сама граница между машиной и организмом, и ответ на вопрос, какой сложности могут быть построены машины, даст только опыт.

Однако при конструировании новых машин мы всегда должны сознавать, какие возможны последствия от их применения. Программы для этих машин должны быть всегда заранее точно определены, в противном случае могут быть не только положительные, но и вредные последствия. Пели последствия не будут точно известны, то может произойти то, о чем говорится в известной английской сказке, которую я обычно при рассмотрении этого вопроса привожу. Один человек стал обладателем талисмана, с помощью которого могло быть выполнено любое его желание. Однако какой ценой он должен был заплатить за такое благо, было ему неизвестно. Когда он однажды получил с помощью своего талисмана большую сумму денег, то оказалось, что он должен был за это пожертвовать жизнью любимого сына…

Исполнение желания имеет свои хорошие и дурные последствия. То же относится и к новым автоматам. Применение их может иметь либо хорошие, либо плохие результаты. Какие именно получатся – это зависит от людей.

Вопрос. Какими физиологическими проблемами Вы интересуетесь в настоящее время?

Ответ. Сейчас я занимаюсь проблемой: как можно теоретически осмыслить способности гена или вируса к воспроизведению. Я надеюсь, что по этим вопросам смогу поговорить с моими коллегами в Москве.

Вопрос. В заключение мы хотели бы спросить, каковы Ваши впечатления от Москвы и конгресса?

Ответ. Я получил много хороших впечатлений от города, от успехов советских людей. Конгресс показал, что советские ученые играют значительную роль в области автоматического регулирования. Я уверен, что сотрудничество ученых различных стран приведет к еще большим успехам в деле мира и взаимопонимания на благо человечества. [c.318]

Далее:
Приложение IV
Винер Н. Машины изобретательнее людей?
(Интервью для журнала “Юнайтед Стэйтс энд Уорлд Рипот”)

К оглавлению

ПРИМЕЧАНИЯ

1 См.: Природа. – 1960. – № 8. – С. 68–69, в разделе “Наши интервью”. Летом 1960 г. в Москве состоялся I конгресс Международной федерации по автоматическому управлению (International Federation of Automatic Control, отсюда сокращение ИФАК), в котором принимали участке ученые из многих стран. В числе американских делегатов был и Норберт Випер. Во время своего пребывания в Москве Винер дал ряд интервью, в частности настоящее интервью сотруднику журнала “Природа”. – Прим. ред.


Винер Н

Винер Н. Машины изобретательнее людей?: Интервью для журнала “Юнайтед Стэйтс Ньюс энд Уорлд Рипот”. // Винер Н. Кибернетика, или управление и связь в животном и машине. – 2-е издание. – М.: Наука; Главная редакция изданий для зарубежных стран, 1983. – С. 319–326.

Красным шрифтом в квадратных скобках обозначается конец текста на соответствующей странице печатного оригинала данного издания

Приложение IV

МАШИНЫ ИЗОБРЕТАТЕЛЬНЕЕ ЛЮДЕЙ? 1
(Интервью для журнала “Юнайтед Стэйтс Ньюс энд Уорлд Рапорт”)

Вопрос. Д-р Винер, существует ли опасность, что машины – вычислительные машины – когда-нибудь возьмут верх над людьми?

Ответ. Такая опасность, несомненно, существует, если мы не усвоим реалистического взгляда на вещи. Собственно говоря, это опасность умственной лени. Некоторые так сбиты с толку словом “машина”, что не представляют себе, что можно и чего нельзя делать с машинами и что можно и чего нельзя оставить человеку.

Вопрос. Существует ли тенденция придавать чрезмерное значение применению вычислительных машин?

Ответ. Существует культ техники. Люди заворожены техникой. Машины предназначены для службы человеку, и если человек предпочитает передать весь вопрос о способе их употребления машине, из-за слепого машинопоклонства или из-за нежелания принимать решения (назовете ли вы это леностью или трусостью), тогда мы сами напрашиваемся на неприятности.

Вопрос. Согласны ли Вы с прогнозом, который мы иногда слышим, что дело идет к созданию машин, которые будут изобретательнее человека?

Ответ. Осмелюсь сказать, что если человек не изобретательнее машины, то уже слишком плохо. Но здесь нет убийства нас машиной. Здесь просто самоубийство, Вопрос. Действительно ли машины обнаруживают тенденцию становиться сложнее, изобретательнее? [c.319]

Ответ. Мы делаем сейчас гораздо более сложны, машины и собираемся в ближайшие годы делать еще более сложные. Есть вещи, которые совсем пока не дошли до общественного внимания, вещи, которые заставляют многих из нас думать, что это случится не позже, чем через какие-нибудь десять лет.

Вопрос. Можете ли Вы дать нам взглянуть в будущее?

Ответ. Могу. Одним из важных событий была миниатюризация – уменьшение размеров деталей. Там, где в самом начале развития вычислительной техники понадобилась бы машина величиной с Эмпайр-Стэйтс-Билдинг 2 , теперь вы можете обойтись конструкцией, которая поместится в довольно небольшой комнате. Одним из главных факторов в этой миниатюризации было введение новых типов памяти – памяти, основанной на физике твердого тела, на транзисторах и т.п.

Сейчас возник интерес к вопросу, как работает человеческий мозг. И за последний примерно год мы впервые получаем настоящее представление об этом.

Видите ли, генетическая память – память наших генов – в значительной степени зависит от веществ, являющихся комплексами нуклеиновых кислот. В последнем году стали подозревать более или менее широко, что память нервной системы – того же рода. На это указывает открытие комплексов нуклеиновых кислот в мозгу и тот факт, что они обладают свойствами, обеспечивающими хорошее запоминание. Это весьма тонкий раздел физики твердого тела, как и физика, ныне используемая в машинной памяти.

Я предполагаю – и я не одинок, – что ближайшее десятилетие увидит это в техническом воплощении.

Вопрос. Иными словами, вместо магнитной ленты как элемента памяти вычислительной машины Вы будете располагать генами?

Ответ. Мы будем располагать веществами, родственными генам. Называть их генами или нет, вопрос терминологический, но вещества – того же рода. Это вызовет массу новых фундаментальных исследований. Как вводить в эту генетическую память и выводить из нее данные, как ее использовать, – все это требует [c.320] большой исследовательской работы, пока едва начатой. Некоторые из нас имеют предчувствия (еще не проверенные), что ввод и вывод осуществимы посредством световых колебаний определенных молекулярных спектров. Так ли это или не так, я бы не поклялся. Но кое-кто из нас смотрит на это серьезно.

Вопрос. Не будет ли пугать народ такая перспектива?

Ответ. Любая перспективная возможность будет пугать народ. Она будет пугать народ, если ее использовать без понимания. Использованная же с пониманием, она может оказаться весьма ценным орудием.

Вопрос. Можете ли Вы описать вычислительную машину, использующую гены как запоминающее устройство? Что было бы для нее возможно?

Ответ. Слишком похоже на фантастику, чтобы говорить сейчас.

Вопрос. Каковы бы были возможности подобной машины по сравнению с вычислительными машинами, которыми мы располагаем сегодня?

Ответ. Они могут оказаться несравненно большими. Машина могла бы быть гораздо меньше; она могла бы пропускать гораздо больше данных. Но все, что я сказал бы о ней, было бы не только преждевременным, но и безнадежно преждевременным. Однако работа в этих областях должна проводиться, я уверен.

Вопрос. Говорят, что вычислительные машины думают. Так ли это?

Ответ. Если иметь в виду нынешнее положение вещей, то вычислительные машины могут обучаться. Вычислительные машины могут учиться улучшать свою работу путем ее анализа. Это, безусловно, верно. Называть ли это мышлением, вопрос терминологический. Что вещи такого рода получат гораздо большее развитие в будущем, когда наша способность строить более сложные вычислительные машины возрастет, в этом, я думаю, не приходится сомневаться.

Вопрос. Существует ли вероятность, что машины могут учиться больше, чем человек? Способны ли они к этому сейчас?

Ответ. Сейчас наверняка нет, и наверняка нет еще долгое время, если вообще когда-либо будут способны. Но если смогут, то лишь потому, что мы перестанем [c.321] учиться. Я хочу сказать, что намучиться легче, чем машине. Если же мы поклоняемся машине и все ей оставляем, то мы должны благодарить самих себя за все неприятности, в которые попадаем.

В этом суть дела. Вычислительная машина очень хороша при быстрой работе, проводимой однозначным образом над полностью представленными данными. Вычислительная машина не может сравниться с человеческим существом при обработке еще не выкристаллизовавшихся данных. Если назвать это интуицией, то я не сказал бы, что интуиция недоступна вычислительной машине, но у нее она меньше, а экономически невыгодно заставлять машину делать то, что человек делает намного лучше.

Вопрос. Что именно представляет собой обучающаяся машина?

Ответ. Обучающаяся машина – это такая машина, которая не просто, скажем, играет в какую-нибудь игру по твердым правилам, с неизменной стратегией, но периодически или непрерывно рассматривает результаты этой стратегии, дабы определить, нельзя ли изменить с пользой те или иные параметры, те или иные величины в стратегии.

Вопрос. Пример, который всегда приходит на ум, – машины, играющие в шашки…

Ответ. Прекрасно, возьмем шашки. Машина была достаточно хороша, чтобы через некоторое время стать способной систематически обыгрывать своего изобретателя, пока тот не выучил про шашки немного больше.

Вопрос. Почему же с шахматами не так?

Ответ. Потому что шахматы сложнее. С шахматами тоже будет так, но это потребует гораздо более длительной работы.

Вопрос. Обучаются ли машины письму?

Ответ. Да. Имеются машины, способные воспринять код и перевести его в рукописный шрифт или воспринять рукописный, а также печатный шрифт и перевести его в код. О да! Это разрабатывается: можно даже воспринять речь и перевести ее в код.

Вопрос. Говорить о думающих роботах, захватывающих власть над Землей, – фантастика?

Ответ. Фантастика, если только народ не придет к идее: “Оставим все Железному Майку!” Я хочу [c.322] сказать: если мы смотрим на машину не как на дополнение к нашим силам, а как на нечто их расширяющее, мы должны держать се под контролем. Иначе нельзя. Машинопоклоппики, ожидающие, что машина будет работать, а народ пусть сидит и получает все без труда, думают, конечно, по-другому.

Вопрос. Разумно ли используются сегодня вычислительные машины?

Ответ. В 10% случаев – да.

Вопрос. Поразительно низкая цифра. Почему Вы так говорите?

Ответ. Потому что нужен разум, чтобы знать, что давать машине. И во многих случаях машина используется в расчете на разум, которого-то и нет.

Вычислительная машина ценна ровно настолько, насколько ценен использующий ее человек. Она может позволить ему продвинуться дальше за то же самое время. Но он обязан иметь идеи. И на ранней стадии проверки идей вам не следует быть зависимым от вычислительных машин.

Вопрос. Относится ли это также к применению вычислительных машин как средства автоматизации? Иными словами, не используется ли автоматизация в некоторых случаях неразумно?

Ответ. Вне всякого сомнения. Однако, что касается примера, сие не моя область.

Вопрос. Какие можно назвать работы, для которых машины могут применяться разумно и которые они делают лучше, чем люди?

Ответ. Бухгалтерию, продажу билетов и тому подобное ведение записей. Когда мы составили свой план вычислений, машина может выполнить его гораздо лучите, чем человек. И вычислительные машины будущего смогут делать эти вещи еще лучше. Они будут обладать достаточной разносторонностью, чтобы позволить себе то, что делает мозг, – затрачивать массу усилий и все-таки достигать чего-то.

Вопрос. Эти машины будущего отнимут еще много занятий у людей?

Ответ. Отнимут.

Вопрос. Это обострит проблему, которая уже существует. Где же решение?

Ответ. Ответ гласит: мы больше не можем [c.323] оценивать человека по той работе, которую он выполняет. Мы должны оценивать его как человека.

В этом суть. Вся уйма работы, для которой мы сейчас используем людей, – это работа, в действительности делаемая лучше машинами. Ведь уже давно человеческая энергия стоит немного, поскольку речь идет о физической энергии. Сегодня человек, пожалуй, не смог бы произвести столько энергии, чтобы купить пищу для своего собственного тела.

Реальная коммерческая стоимость его услуг в условиях современной культуры недостаточна. Если мы оцениваем людей, мы не можем оценивать их на этой основе. Если мы настаиваем на применении машин повсюду, безотносительно к людям, но не переходим к самим фундаментальным рассмотрениям и не даем человеческим существам надлежащего места в мире, мы погибли.

Вопрос. Уже поздно остановить это движение ко все большей и большей автоматизации?

Ответ. То, что сделано, непоправимо. Я предвидел это в самом начале. Здесь налицо не просто факт, что используются вычислительные машины. Настоящую трудность представляет факт, что они стоят наготове для применения.

Иными словами, причина, по которой нам нельзя идти назад, заключена в том, что нам никогда не удастся уничтожить возможность использования вычислительных машин.

Вопрос. Вы считаете это необратимой тенденцией?

Ответ. Я не говорю даже о тенденции. Это необратимое приращение знания. Такое случилось с Адамом и Евой, когда они повстречались со змеем. Коль скоро вы вкусили от древа познания, вы вряд ли сможете сделать другое, чем идти дальше с этим знанием.

Вопрос. Итак, можно ожидать, что машины будут играть все большую роль в автоматизации, в бизнесе, в образовании…

Ответ. Можно. И во всяком случае, используем ли мы машины или нет (решение, которое мы так или иначе должны принять), тот факт, что они имеются налицо для использования, нельзя отбросить.

Вопрос. Вы хотите сказать, что более мудрым [c.324] решением был бы, возможно, отказ от использования некоторых машин?

Ответ. В определенных ситуациях это может оказаться более мудрым. Приведу вам пример. Сейчас с автоматизацией совсем нетрудно построить фабрику, способную произвести больше, чем может потребить весь рынок. Если вы беретесь за дело и лишь толкаете производство вверх, вы можете упереться в потолок. Конкуренция, как она понималась в прошлом, существенно изменяется при наличии автоматизации. Автоматизация больше несовместима с laissez faire 3.

Вопрос. Если в ближайшее десятилетие разовьется новая техника такого типа, на который Вы намекали, как можно задержать дальнейшую автоматизацию?

Ответ. Прогресс задерживали в прошлом не раз. Совсем не обязательно, если мы делаем новое оружие, немедленно пускать его в ход.

Вопрос. Вы нашли во время Вашей последней поездки в Россию, что Советы придают большое значение вычислительной машине?

Ответ. Я скажу вам, насколько большое. У них есть институт в Москве. У них есть институт в Киеве. У них есть институт в Ленинграде. У них есть институт в Ереване в Армении, в Тифлисе, в Самарканде, в Ташкенте и Новосибирске. У них могут быть и другие.

Вопрос. Используют ли они эту область науки полностью, если сравнить с нами?

Ответ. Общее мнение – и оно идет от самых разных лиц – таково, что они отстают от нас в аппаратуре: не безнадежно, а немного. Они впереди нас в разработке теория автоматизации.

Вопрос. Д-р Винер, необходимо ли сегодня использование вычислительных машин для военных решений?

Ответ. Да, и они могут быть использованы весьма неразумно. Я не сомневаюсь, что проблема того, когда нажать “большую кнопку”, трактуется сейчас с точки зрения обучающихся машин. Я был бы очень удивлен, если бы дело обстояло иначе, ведь это ходовые идеи. Вы знаете: “Пусть делает Железный Майк!”

Но давайте рассмотрим это чуть поподробнее. Как [c.325] учатся солдаты своему ремеслу? Посредством военных игр. Веками они упражнялись в играх на карте. Прекрасно! Если вы располагаете некоторым формальным критерием, определяющим, что значит выиграть войну, вы можете заниматься такими играми. Но вам не мешало бы удостовериться, что ваш критерий есть то, что вы действительно хотите, а не некая формализация желаемого. В противном случае вы можете создать вычислительную машину для ядерной войны, которая все разрушит.

Вопрос. Как можно программировать вычислительную машину для ядерной войны, если Вы никогда не имели настоящего опыта подобной войны?

Ответ. Совершенно нельзя. Но тем не менее это сейчас пытаются делать. Экспертов по атомной войне нет. Эксперт – это человек, обладающий опытом. Такого человека сегодня мы не имеем. Поэтому программирование военных игр на основании искусственных критериев успеха в высшей степени опасно и может кончиться плохо.

Вопрос. Существует ли тенденция к программированию такого рода?

Ответ. Тенденция в этом направлении существует, и эта глупость верхов меня поражает. Автомат обладает свойством, которым некогда наделяли магию. Он может дать вам то, что вы просите, но не скажет вам, чего просить.

Мы слышали речи, что нам нужно создать машинные системы, которые скажут нам, когда нажать кнопку. Но нам нужны системы, которые скажут нам, что случится, если мы будем нажимать кнопку в самых разных обстоятельствах, и – главное – скажут нам, когда не нажимать кнопки!

Вопрос. Как Вы думаете, возможно ли для машин объявить войну и обречь все человечество?

Ответ. Если мы позволим им. Разумеется, они не объявят войны, если мы заранее не настроим их на это.

Вопрос. Д-р Винер, не изменяет ли человек окружающую среду свыше своей способности приспособления к ней?

Ответ. Это вопрос № 1. Человек, несомненно, изменяет ее чрезвычайно сильно, а делает ли он это свыше своей способности, мы узнаем довольно скоро. Или не узнаем – нас больше не будет. [c.326]

К оглавлению

ПРИМЕЧАНИЯ

1 Machines Smarter than Men? Interview with Dr. Norbert Wiener, Noted Scientist, // U.S. News & World Report. – 1964. – Feb. 24. – P. 84-86.
Вернуться к тексту

2 102-этажный нью-йоркский небоскреб – одно из высочайших зданий Америки (381 м.) – Прим. ред.
Вернуться к тексту

3 Laissez fairc (франц.)-невмешательство, свобода рынка (лозунг старой буржуазной политэкономии). – Прим. ред.


Винер Н

Винер Н. Кибернетика, или управление и связь в животном и машине. - 2-е издание. - М.: Наука; Главная редакция изданий для зарубежных стран, 1983. - 344 с.

ПРЕДМЕТНО-ИМЕННОЙ УКАЗАТЕЛЬ*

* При переводе указатель был несколько переработан и дополнен. В частности, имена и термины, отмеченные звездочкой, встречаются только в редакторском предисловии и редакторских примечаниях. - Ред.

Абелевы группы 108
Абердинский испытательный полигон (Aberdeen Proving Ground) 61
Августин Блаженный (Augustine Saint) 92
Автокорреляционная функция 137, 155, 271
– –.метод получения 271, 274
– –, разрешающая способность 280
Автоматизация 20, 324
Автоматы и техника связи 97
– –, история 92-96
– – и их органы чувств 97-99
– – и статистическая теория 99
(см. также Самоорганизующиеся системы)
Адлер А. (Adler A.) 228
Аккомодация 212
Акутович Э. Дж. (Akutowicz E.J.) 36
Альфа-ритм 73, 220
– – и время реакции 24, 288
– – и остаточный разряд 289
– – как подчиненная частота 286
– – как часы в мозгу 286
Американское математическое общество (American Mathematical Society) 8, 63
Ампер А.М. (Ampere A.M.)* 24, 57
Аналитическая функция 169
Аналоговые вычислительные машины 188, 206
Ананка (Рок) 92
Анемия головного мозга 185
Ансамбль временных рядов 137
– – и случайное блуждание 32
– – и теория информации 128
– – и эргодическая теория 112, 128
Антропология 67, 74
Аппарат для слепых 72, 216
Ассоциативные зоны (коры головного мозга) 219
Ассоциация идей 209
Астрономия 82-84, 86-89, 246
Астрофизика 86
Атаксия 52, 77, 162
Аффективный тонус 201, 202

Бальзак О. (Balzac H.) 197
Барлоу Дж. С. (Barlow J.S.) 271, 290
Бартлетт Ф.К. (Bartlett F.С.) 73
Батлер, Сэиьюэл (Batler, Samuel) 78
Бейтсон Дж. (Bateson G.) 67, 74
Белловекие телефонные лаборатории (Bell Telephone Laboratories) 47, 55, 119, 127
Белый ящик 33, 267
Берг А.И.* 21
Бергсон A. (Bergson Н.) 15, 91, 99
Бернал Дж. Д. (Bernal J.D.) 9, 73
Бесконечность и ее классы 102
Бигелоу Дж. (Bigеlow J.) 9, 49, 50, 52, 57, 63, 67, 297
Биология 91, 161, 200
– – и время 89, 91
– – и колебательные системы 35
– – и обучающиеся системы 253
Биркгофф Г. Д. (Birkhoff G.D.) 105, 112, 113, 128, 282
Бихевиоризм 297
Бланк-Лапьерр A. (Blanc-Lapiеrre A.) 74
Блейк, Уильям (Blake, William)* 79
Богданов А.А.* 25
Боголюбов Н.Н. 24, 118
Бозе А.Г. (Bose A.G.) 34
Больцман Л. (Bolzmann L.) 14
Бом Д. (Bohm D.) 311
Бонапарт, Наполеон (Bonaparte, Napoleon) 255
Бор, Нильс (Bohr, Niels) 9, 13, 89
Борн М. (Born М.)* 9, 13
Бостонская городская больница (Boston City Hospital) 60
Боуги, полковник (Bogey, Colonel) 258
Бразье, Мэри А.Б. (Brazier, Магу А.В.) 271
Брайль (Braille) 217
Бриджмен Л. (Bridgeman L.)* 198
Бриллюэн Л. (Вrillouin L.)* 23
Броуново движение 33, 131, 139, 142, 159, 280
Булева алгебра 59, 190
Буш В. (Bush V.) 8, 46, 47, 49, 71, 188, 240
Вальярта, Мануэль С. (Vallarta, Manuel S.) 43, 64
Ван дер Поль Б. (Van der Pol В.) 179
Ватанабе С. (Watanabe S.) 37, 316
Вейль A. (Weyl H.) 59
Вековые возмущения 70, 179
– – в нервной системе человека 193
– –, примеры 70, 183
Вероятность в броуновом движении 139
– – и информация 121, 124, 231
– –, полученная из бесконечной последовательности случаев 103
– –, равная 1 и 0 101
– – и энтропия 14, 114
Вечный двигатель второго рода 116
Винер Н. (Wiener N.) 7, 30, 31, 36, 52, 57, 110, 258, 261, 264, 280, 282, 297, 305, 308, 315
– –, биография* 6
– –, интервью 315, 319
Витализм 91, 93
Вокодер (Vocoder), система синтетической телефонии 119
Волновые фильтры 54, 63, 131, 151, 154
– – и энергетический спектр 275
Вольта A. (Volta A.) 268
Восприятие формы 66, 72, 212, 219
– – универсалий 66
Временная задержка 161, 195
Временные ряды, ансамбли 160
– – в дискретном случае 157, 158
– – и квантовая механика 159
– – многомерные, примеры 131
– – и предсказание 53, 144, 147
– – и примеры 119, 129
– – и сообщения 52, 128
– –, их статистические параметры 129, 139, 143, 144
(см. также Броуново движение)
Время и биология 91
Время, измерение 83
– –, необратимость 85, 92
– – ньютоново и бергсоново 82
Вход 297
Выход 297
Вычислительные машины 47-50, 57-60, 94, 119, 187, 205, 213, 219, 253, 256
– –, два типа 188
– – и игра в шахматы 248, 257, 320
– – и логическая индукция 258
– – и подневольный труд 78
– – как центральная нервная система 77
– –, применение 320
– –, способ работы 189
Вышнеградский И.А.* 24, 57
Гаар Г. (Haar H.) 110
Габор Д. (Gabor D.) 34, 37, 265-266
Гейзенберг В. (Heisenberg W.) 54, 91, 159
Галилей, Галилео (Galileo G.) 83
Гарвардская медицинская школа (Harvard Medical School) 9, 43, 307
Гарвардский университет (Harvard University) 6, 44, 61, 62
Гармонический анализ 32, 73, 278, 280, 290
– – и гетеродинный метод 278
Гаррисон Г.С. (Harrison G. S.) 71
Гаусс К. (Gauss К.) 93, 147, 152
Гёдель К. (Gődel К.) 199
Гей, Вильгельм (Hey, Welhelm) 82
Гейлинкс A. (Geulincx A.) 95
Гете И.В. (Goethe J.W.) 261
Гендерсон Л. Дж. (Handerson L.J.) 186
Генетика 90, 200
Гены 35, 161, 320
Герон Александрийский (Него of Alexandria) 94
Гештальт 66, 76, 209, 216
Гиббс Э.Л. (Gibbs E. L.) 270
Гиббс Уиллард (Gibbs, Willard) 14, 15, 91, 98–104, 106, 111, 113, 115, 159
Гильберт Д. (Hilbert D.) 8, 59
Гоббс Т. (Hobbes Т.) 236
Гольдстайн X.X. (Goldstine H.H.) 62
Голем (Golem), глиняный человек 10, 20, 94
Гомеостаз 185
– – и конкуренция 241
– – в неодушевленных системах 293
– – в общинах и в обществе 243
– – частичный 313
Гомеостат 240, 313
Гопф Э. (Hopf E.) 8
Гормоны 204, 238
Грдина Я.И.* 24
Греневский Г. (Grcniewski H.)* 22
Группа абелева 108
– – преобразований 107, 108
– –, сохраняющих меру 111
– – сдвигов 31
– – целых чисел 109
– – характеров 109
Групповая мера 215, 216
– – развертка 145, 214
Гуревич В. (Hurewicz W.) 117
Гюйгенс X. (Huyghens Ch.) 92

Дарвин, Чарлз Роберт (Darwin, Charles) 7, 19, 44
Дарвин, Джорж Говард (Darwin, George H.) 89, 90
Дарвин, сэр Чарлз Галтон (Darwin, Sir Charles) 90
Двоичная арифметика 190
– – система счисления 61, 188-191
Дедал (Daedalus) 93-94
Декарт P. (Descartes R.) 94
Де Фриз Г. (de Vries H.) 90
Де Сантнльяна Дж. Д. (de Sanlillana G.D.) 74
Джаспер X.X. (Jasper H.H.) 270
Джоуль Дж. П. (Joule J.P.) 92
Диаграмма Найквиста (Nyquist diagram) 171
Дисней Уолт (Disney, Walt) 259
Дифференциальный анализатор 46, 47, 49, 188
Дробовой эффект 33, 265
Дуб Дж. Л. (Dоob J.L.) 63, 64
Думающая машина 58, 198
Дэвис X. (Davis H.) 270
Дэниелл П. Дж. (Daniell P. J.) 16, 63
Дюбе Ж. (Dube G.) 81

Естественные колебания 178

Закон Бейса (Bayes) 159
– – Вебера–Фехнера (Закон интенсивности ощущений) 69-70

Избыточность в нервной системе 224
Иллинойсский университет (University of Illinois) 58, 63
Инвариант групповой 31, 108
– – линейный 108, 111
– – метрический 111
Индукция логическая 316
– – математическая 60, 200
– – трансфинитная 199
Институт высших исследований (Institute for Advanced Study) 61, 67
Институт математической статистики (Institute of Mathematical Statistics) 63
Институт Рокфеллера (Rockefeller Institute) 62, 68
Интеграл Стильтьеса 134
– – Лебега 105
“Интернешнел Бизнес Машинес” (International Business Machines Company), фирма 37
Интуиция 322
Информация и автоматы 18, 97
– –, аддитивные свойства 123
– – и временные ряды 120
– – и живые организмы 55, 313-314
– –, замена через протез 220
– –, метод эффективной передачи 127
– –, нелинейная фильтрация 144
– – общественная 240-241, 244
– –, общественный контроль 66, 244
– – и отрицательная энтропия 17, 22, 116, 124
– –, передаваемая органами чувств 210, 259, 313
– –, передаваемая сообщением 124
– –, передача 54, 192, 220
– –, проблема нагрузки 230
– –, скорость передачи 151, 158
– –, сравнение количеств 55, 121, 130, 219
– –, стоимость 187
– –, хранение 195, 225
– –, шум 17, 124
(см. также Сообщение)
Искусственные органы чувств 77, 98 (см. также Протезирование)
“Истмен” (Estman), фирма 196
Исчисление умозаключений 58, 196 (см. также Булева алгебра)

Йоги 220

“Кажущееся настоящее” 194, 226
Каллфорнийскнй университет (University of California) 288
Каллианпур Дж. (Каllingapur G.) 36
Камера Вильсона 246
Кантор, Георг (Cantor, Georg) 59, 102, 199
Карнап Р. (Carnap R.) 59
Карно М. Л. C. .(Carnot M.L.S.) 92
Кац M. (Kac M.) 143
Кельвин, лорд (В. Томсон) (Kelvin, Lord W. Thomson) 93
Кемпелен, барон В. фон (Kempelen, Baron W. von)* 250
Кеннон У.Б. (Cannen W.В.) 43, 64, 186
Кеплер И. (Kepler J.) 83
Кибернетика 17, 29, 30, 36, 38, 62, 71, 73, 75
– – и общество 76, 236
– –, происхождение названия 38, 57
– – н психология 65, 222
– – и человек 26, 316, 319
Кинестетические ощущения 52, 69, 77, 98
Киплинг P. (Kipling R.) 259
Киркегор С. (Kierkegaard S.)* 14, 15
Клонус 68
– – и клонические колебания 68, 69
– – и спинномозговое управление 70
Клювер Г. (Kluver H.) 67
Кодирование информации 55
– – слуховое 217
Козуляев П.А.* 24
Колдуэлл С.X. (Caldwell S.H.) 49
Колебания 169, 171
– – клоннческие 70
– – линейные в сравнении с нелинейными 178, 179
– – в логических машинах 199
– – в мышцах кошки 68
– –, релаксация 180
– – в системе обратной связи 50, 162, 171, 301
– –, их частота 70, 177
– – и чувствительность прибора 53
Колебательные системы в биологии 35, 69, 289-294
– – в мозгу 289
– – нелинейные 178, 289, 292
– – и энергетический спектр альфа-волн 289-290
Колмогоров А.Н. 21, 24, 56
Комиссия но поощрению и координации научных исследований (Comision Instigadora у Coordinadora de la Investigacion Cientifica) 64
Комптон A. (Compton A.) 311
Конгресс ИФАК 10, 305, 317
– – производственных профсоюзов (С.I.О.) 80
Коперник Н. (Copernicus N.) 83
Кора головного мозга, ассоциация 224
– –, зрительная область 72, 218
– –, сравнение областей 221
Котельников В.А.* 24
Коши О.Л. (Cauchy A.L.) 145
Коэффициенты Фурье 148
Крейн М.Г. 154
Крепелнн Э. (Graepelin E.) 222, 225
Критерий среднеквадратической ошибки 37
Крылов Н.М. 117
Купмен Б.О. (Koopman В.О.) 111, 113, 143
Кэрролл, Льюис (Ч.Л. Доджсон) (Carroll, Lewis (С.L. Dogson)) 100, 202
Кюри М. (Curie М.) 310
Кюри П. (Curie P.) 310-311

Лаггерр Э. (Laguerre E.) 266
Лебег, Анри (Lebesque, Henri) 101, 103, 105, 111
Леви X. (Levy H.) 73
Левин, Курт (Lewin, Kurt) 67-68
Левинсон Н. (Levinson N.) 63
Лейбниц, барон Г.В. фон (Leibniz, Baron G.W. von) 44, 58, 96, 117, 198, 236
Леттвин Дж. (Lettvin J.) 60, 198
Лечение шоком 228
Ли, Юк Винг (Lee, Yuk Wing) 46, 63, 151
Лива (Лене), раввин 94
Линдсли Д. Б. (Lindsley D.В.) 288
Линейная комбинация характеров 108
Линейная управляющая система, определение 165, 167
Линейное предсказание, дискретные временные ряды 157
Линейное программирование 257
Линейные дифференциальные уравнения в частных производных 206
– – инварианты 108
– – и нелинейные уравнения 179, 180
– – тригонометрические функции 32
– – формы в нервной системе 68
Линней Карл (Linnaeus С. (Carl von Linne) 200
Ллойд Д. П. К. (Lloyd D.P.С.) 67
Лоботомия 228
Логика 198
– – индуктивная и дедуктивная 316
Логическая индукция 258
– – машина 190, 198 (см. также Вычислительные машины)
Локк Дж. (Locke J.) 200, 201, 213
Локков принцип ассоциации 209
Лондонский университет (University of London) 264
Лоренте де Но P. (Lorente de No R.) 62
Лоэв М. (Loeve М.) 74

Мак-Каллох У.С. (McCulloch W.S.) 57, 60, 62, 66, 72, 76, 218
Макколл Л. A. (MacColl L. А.) 51, 68
Максвелл Дж. К. (Maxwell J С.) 14, 57, 90, 115, 116, 164
Максвеллов демон 56, 116
Мальбранш Н.Д. (Malebranche N.D.) 95
Мазани П. (Masani P.) 36
Массачусетсская главная больница (Massachuset General Hospital) 273
Массачусетсский технологический институт (Massachusetts Institute of Technology) 6, 30, 38, 43, 49, 58, 59, 60, 64, 65, 70, 72, 268, 271, 273, 290
Математика и индукция 58, 198
– – и логика 58, 198
– –, символика 165, 194, 200
– – и физика 100
Материализм 13, 91, 99, 224
Матрицы 154
Машинопоклонство, культ машин 26, 313
Машины и живые организмы 304, 318
– – с глазами и ушами 313
– –, обожествление их 26, 302, 317, 319, 322
– – обучающиеся 243, 253, 322
– – и развитие математики 315
– ––, создаваемые человеком и природой 309
– – умнее своего создателя 19, 308, 319 (см. Вычислительные машины)
Мексиканская военно–медицинская школа (Mexican Army Medical School) 65
Мельцель Л. (Maelzel L.) 249
Мендель Г.И. (Mendel G.J.) 90
Математика 193
Метеорология 82, 85
Метрическая транзитивность 281 (см. также Эргодическая теория)
Мид, Маргарита (Mead, Margaret) 67, 74
Майкельсон А.А. (Michelson A.A.) 273
Миэлиновые волокна 186
Миниатюризация 305
Мозг 194, 227, 232
– –, его ограничения 16, 26, 27, 226, 235
– – и его повреждение 224
– – и функциональная асимметрия 233 (см. также Кора головного мозга и Мозжечок)
Мозговые волны 39, 268 (см. также Электроэнцефалография и альфа-ритм)
Мозжечок 163, 301
– –, его повреждение 52 (см. также Мозг)
Монады Лейбница 95
Монополия, игра 241
Моргенштерн О. (Morgenstern О.) 67, 74, 254
Морисон Р.С. (Morison R.S.) 71
Мостик Уитсона 210
Мэтьюс Б. X. К. (Matthews В.Н.С.) 270

Навигация 92
Нагрузка, мозг, 231, 287
– –, телефон 230
Надежность, методы определения 223
Наследственность 35, 90, 253, 293
Наука, история и философия 82
– – и научный метод 11, 43
Национальная ассоциация промышленников (National Association of Manufacturers) 79
Национальная физическая лаборатория в Тедингтоне (National Physics Lahoratory at Teddington) 59, 73
Национальный институт кардиологи (Institute Nacional di Cardiologia) 43, 62, 64, 68, 71, 72, 81
Небесная механика 85, 86
Нейрон 97, 192, 218, 224, 276 (см. также Нервная система)
Нейронные цепи 231
Нейронный комплекс 225
Нейрофизиология 45, 52, 60, 77, 162
Нелинейные проблемы в теории случайных процессов 31, 32, 266
Нелинейные системы, анализ 33
– – изучение 31
Нелинейные системы и колебания 178, 179
– –, обратная связь и обучение 260-261
– –, преобразователи 264, 266
– –, синтез 34
– – и случайный шум 265
Нельсон, Горацио (Nelson, Horatio) 255
Необратимость времени 84, 91
– – эволюции 91
Неравенство Шварца 168
Нервная система 52, 182, 193, 194, 198, 207
– – и нервные волокна 69, 287
– – парасимпатическая 115
– –, пересчет каналов 217
– –, проблема нагрузки 221
– –, реверберация в ней 217
– –, хирургическое вмешательство в нее 227
– –, центральное торможение 57
Нервные окончания 192
Никодим О.М. (Nikodym О.М.) 130
Нортроп Ф.К. (Northrup F.С.S.) 67
Пулевая вероятность 69, 97
– – мера 34, 112
Нью-Йоркская академия наук (New York Academy of Sciences) 71, 73
Ньютон, сэр Исаак (Newton, Sir Isaac) 13, 83, 84, 91, 92, 94, 99, 101

Обратная связь в биологических системах 38
– – и гомеостаз 185
– – информирующая 184
– – комбинированная 172, 203
– – линейная 29, 30, 170
– –, ее математическое выражение 170
– –, ее преимущества 176
– –, ее цепь 163
– – и обучение 258, 268
– – отрицательная 164, 177, 300
– – позы 176
– – положительная 300
– – при синтезе нелинейных систем 266-267
– – произвольного движения 176, 185
– – упреждающая 183
– – устойчивая 166, 171
– – физиологическая 183, 185
Обучающиеся машины 36, 309-310
– – и поединок кобры и мангусты 260
– – и III мировая война 260, 263, 326
– – и шахматы 248
– – и шашки 37, 257
Обучение 309
– – в биологических системах 25, 36
– – и нелинейная обратная связь 258
– – в нелинейных системах 34, 37
– – онтогенетическое 253, 268
– – и условный рефлекс 202, 203
– – филогенетическое 253, 268
– – как характеристика жизни 253-254
Общественная информация 240-241, 244-245
Океанография 88
Окказионализм 95
Окстоби Дж. К. (Oxtoby J.С.) 104
Оператор 168, 171
– – дифференциальный 171
– – нелинейный 181
– –, принадлежащий к группе 214-215
Операционное определение понятия 198, 299, 300
Оптимальное проектирование волновых фильтров 55
Осгуд В.Ф. (Osgood W.F.) 8, 105
Остаточный разряд (afterdischarge) 290

Павлов И.П. 24, 201
Память в автоматах 47
– –, ее болезни 225
– –, возможный механизм у человека 198, 199, 226, 227
– – генетическая 318
– –, метод построения 194, 195
– – постоянная и циркулирующая 226
– – и теории Фрейда 204
– –, типы 194, 195, 196
– –, хранение впечатлений 219-220
– –, хранение информации 225
– –, эффект лечения шоком 228
Парасимпатическая нервная система 185, 186
Паркинсоновская болезнь 177
Паскаль Б. (Pascal В.) 58
Пастер Л. (Pasteur L.) 233
Пенсильванский унинерситет (University of Pennsylvania) 61, 62
Переключающие схемы 47, 48, 59
Перекресты каналов 66, 67, 224
Перемножитель 34
Перрен Ж.Б. (Perrin J.В.) 131
Пирексия 206-207
Питтс У.X. (Pitts W.H.) 59, 60, 62, 72, 81
Планк, Макс (Planck, Max) 91
Планшерель М. .(Plancherel M.) 105, 282
Платон (Plato) 23, 56, 246, 247
Поведение 297, 298, 299
– – активное 298
– –, классификация 302
– – без обратной связи 300-301
– – пассивное 298
– – предсказывающее 301
– – телеологическое 306
– – целенаправленное с обратной связью 301, 302
Политехнический музей в Москве 11, 317
Порог нейронов 69, 70
Предел в среднем 110, 111
Предсказание 37
– – в ньютоновой системе 86, 87
– – полета самолета 48, 49, 50
– –, проектирование предсказывающих устройств 154-155
– – и сообщения 53
– – и фильтрование временных рядов 148
– – по частоте в сравнении с предсказанием по времени 146
– – в шахматах 257
Преобразования букв 217
– – Гильберта 145
– – и группы преобразований 107, 215
– – и инвариантность 106
– – метрически транзитивные 138, 143
– – музыки 218
– – обратные 108
– –, определение 107
– – перестановочные 107
– – постоянной меры 102
– – результирующие 107
– – сообщения 128
– –, сохраняющие меру 111, 114, 129, 137
– – тождественные 107
– – унитарные 282
– – Фурье 140
– – эргодические 111-112
Преобразователи 264
– – в биологии 265
– – обобщенные линейные и нелинейные 263-266
Приливная эволюция 88
Прнстонский университет (Princeton University) 61
Принцип неопределенности 54, 159
– – “все или ничего” 61, 287
Произвольная деятельность 52, 165, 298
– – пилота 48-49
Промышленная революция, первая и вторая 16, 20, 79
Проприоцептивные ощущения 51, 163 (см. также Кинестетические ощущения)
Протезирование 76, 77, 216
Психоанализ 278
Психология 81, 198
Психопатология 224
Птолемей (Ptolemy) 84
Пуанкаре A. (Poincare H.) 180
Пэли Р. Э. А. К. (Paley R.Е.А.С.) 8, 130

“Радио Корпорейшен оф Америка”, фирма (Radio Corporation of America) 195
Радиолокация 50, 77
Развертка 214, 305
– – печатной страницы 72
– – в связи с альфа-ритмом 220
– – в телевидении 305
Разложение Фурье 140 (см. также Гармонический анализ)
Рамос Ф.Г. (Ramos F.G.) 65
Распределение вероятностей 86, 101, 119
Рассел, Бертран А.В. (граф Рассел) (Russell В, A.W., Count Russell) 7, 59, 199
Регуляторы 56 (см. также Система обратной связи)
Резервирование в нервной системе 223
Релаксатор 180
Рефлекс 183
– – у кошки 68
– – обратной связи 211
– –, рефлекторная дуга 69
– – условный 203
– – ходьбы 177
– – чесательный 177
Роботы 26, 94, 306, 320
Розеиблит У.A. (Rosenblith W.А.) 271, 290
Розенблют, Артуро (Rosenblueth, Arturo) 9, 43-47, 52-72, 297
Ройс, Джосайя (Royce, Josiah) 7, 44
Роршах Г. (Rorschach H.) 209
“Рысканье” в сервосистемах 51, 70, 301

Самоорганизующиеся системы 266, 289, 293
Самовоспроизводящиеся машины 264
Самораспространяющиеся машины 263
“Сатерди ивиинг пост” (“Saturday Evening Post”), журнал 79
Связь и автоматы 96, 98
– – как механизм организации 67
– – в общественной системе 74
– – и управление 92
– –, формулировка центральной проблемы 127
– – между функциями головного мозга 235
Селфридж О. (Selfridge О.) 65, 81, 204
Сент-Дьёрдьи A. (Szent-Győrgyi A.) 74, 161
Сервомеханизм 68-70, 299, 302 (см. также Система обратной связи)
Сердце 65
Символическая логика 58 (см. также Булева алгебра)
Симпатическая нервная система 185
Синапс, использование 192, 197, 205, 225
– – тормозящий 192
– –, управляемый часами 286
– – центральный 70
– –, цепочка синапсов 72
Система колебательная 35
– – консервативная динамическая 103
– – линейная 165
– – нелинейная 30
– –, обратная связь (см. Обратная связь)
– – парасимпатическая 185
– – симпатическая 185
– – счисления 48, 61, 188
– –, энтропия 116
Система обратной связи, определение 50
– –, примеры 51-52, 164, 174, 182, 203, 210
– – как процесс в обществе 75
– – и эксперименты на кошке 68
Системы компенсации 174, 181
– – в сравнении с системами обратной связи 181
– –, их характеристики 183
Слух и замена утраченных органов чувств 72, 76
Слух и прием информации 127, 153
Случайность 13, 90-92
Случайные сети 65
– – функции 32
Смолуховскнй P. (Smoluchowski R.) 131
Совесть 228
Солнечная система 83, 84
Соломон (Solomon) 316
Соломон, царь 262
Сообщение и волновые фильтры 131
– – и логическое управление 286
– – обобщенное 126
– –, определение 53
– –, передаваемое нервной системой 288
– –, скорость передачи 151-153
– – и теория автоматов 98-99
– – и шум 54, 124, 131, 153 (см. также Информация)
Социология 67, 247
Спинная сухотка (Tabes dorsalis) 52, 162
Спиноза Б. (Spinoza В.) 95
Средние величины по всему пространству 106
– –, инварианты группы 108
– – временные 104, 111, 129
– –, их подобия 106
– – и температура 115
– – фазовые 105, 111, 129
Стабилизация (см. Системы компенсации)
Статистика и временные ряды 53, 119, 129, 132
– – и информация 121-126
– – общества 75
– – и статистические распределения 85-86
–. – и термодинамика 91
– – электрического тока 264
Статистическая механика 54
– – и автоматы 98-99, 106
– – и максвеллов демон 116
– – в солнечной системе 85
– – и средние величины 104
– – и статистическая закономерность 54-56
Статистическая механика и термодинамика 91
Стэнли-Джонс Д. (Stanley-Jones D.) 38
Стенли-Джонс К. (Stanley-Jones К.) 38
Сэведж Л. Дж. 67
Сэмьюэл А.Л. (Samuel A.L.) 37, 258

Тэйлор сэр Дж. И. (Taylor, Sir G.I.) 270
Тектология* 24
Телевидение 46, 87, 304, 306
Телеология 297, 306
Телеологические системы 9, 306-307
Телеграфные повторители 210, 213
Теория игр 48, 75, 241, 264
– – интегрирования 99
– – информации* 17
– – малых выборок 76
– – орбит 85
– – приливной эволюции 89
– – предсказания 36, 63
– – систем* 23
– – сообщений и броунова движения 155
– – сохранения энергии 93
– – тригонометрических рядов 102
– – энтропии (см. Энтропия)
– – эпициклов 85
Теория меры 105-118, 137
– – и информация 121
– –, нулевая мера 114, 139
– – и энтропия 122
Термодинамика 55, 86–91, 93
– –, второй закон 15, 55, 93, 125
– – и необратимость времени 93
– – и энтропия 113, 125
Термостат 97, 164
Техника 92
Тиха (Случай) 92
Томпсон, Д'Арси (Thompson, D'Arcy) 229
Торможение в нервной дуге 70
Тремор интенционный 163
– – мозжечковый 163, 164, 176
– – физиологический 179
Тригонометрические функции, инвариантные свойства 31
– –, теория 101
Трубка Вильямса 195
Тьюринг А.М. (Turing A.M.) 60, 73, 198

Уатт, Джеймс (Watt, James) 164
Уивер, Уоррен (Weaver, Warren) 63, 71
Улам С.М. (Ulam S.М.) 104
Универсалии 209
Уоллес A. (Wallace A.) 89
Уоллмен X. (Wallman H.) 89
Уолтер, В. Грей (Walter, W. Grey) 220, 289
Управление с помощью информирующей обратной связи 183
Условный рефлекс 200, 202–203
Устойчивость 310
– – относительная 310 (см. также Максвеллов демон)
Уточнение в классической физике 160
– – и мера информации 120
Уэбстер Ф. (Webster F.) 81

Фазовая мера 104
Фазовое пространство 103–106, 115
Фарадей М. (Faraday М.) 44
Физиология 44, 66, 77, 162, 183, 185, 200, 270, 280
– –, английская эмпирическая школа 200
– –, механицизм против витализма 89
Филлипс Р.С. (Phillips R. S.) 63
Философия и автоматы 94
– – и кибернетика 5, 12, 22, 306, 313
Фишер P.A. (Fisher R.A.) 55, 122, 159
Фон Бонин Г. (von Bonin G.) 67, 72, 218
Фон Нейман Джон (von Neumann J.) 62, 67, 113, 121, 159, 241, 248, 254-255, 264
Фонд Джонса Саймона Гуггенгейма (John Simon Guggenheim Foundation) 65
– – Джосайи Мейси (Josiah Macay Foundation) 57, 66
– – Рокфеллера (Rockefeller Foundation) 68, 71
Фототропизм 203
– – у кошки 68
Фрейд З. (Freud S.) 15, 204, 228
Фримонт-Смит Ф. (Frcemont-Smiih F.) 66
Функция времени 165, 167
– – от двух или более переменных 205
– – мероморфная 169
– – нелинейная 264
– – частоты 168

Хаксли Дж. С. (Huxley J.S.) 254
Характер группы 109
Хэвисайд О. (Heaviside О.) 93, 106
Хилл Дж. У. (Hill G.W.) 180
Холдэйн Дж. Б. С. (Haidanе J.В.S.) 9, 73, 90, 161
Хранение информации (см. Память)

Целенаправленность 297

Чавес И. (Cnaves I.) 65-66, 71

Чандрасекар С. (Chandrasekhar S.) 83
Чапек К. (Capek К.)* 20
Чебышев П.Л.* 24
Человек и машина 317
Черный ящик 33

Шахматная машина 37, 248, 320
Шашечная машина 37, 258, 320
Шеннон К.Э. (Shannon С.Е.) 17, 24, 55, 59, 127, 153, 186, 308
Шестаков В.И.* 24
Шнейрла Т.К. (Schneirlа Т.С.) 67
Шредингер Э. (Schrodinger E.) 56
Шум 14, 54, 95

Эволюция, необратимость 92
– – приливная 88
– –, теория 90
ЭДВАК (EDVAC), вычислительная машина 62, 207
Эдриан Э.Д. (Adrian E.D.) 270
Эйкен Г.X. (Aiken H.Н.) 61–62
Эйнтговен В. (Einthoven W.) 131, 269
Эйнштейн A. (Einstein A.) 5, 131
Электроэнцефалография 219
– – и аппаратура 269-271
– – н энергетические спектры 274-277
Энергетический спектр в мозговых волнах 275
– –, и нелинейные генераторы 290
– –, определение 275-276
– – приближенный 285
– –, форма 276
– –, степень достоверности 276
ЭНИАК (ENIAC), вычислительная машина 62, 207
Энтропия и информация 14, 55–56, 122–126, 161
– – и максвеллов демон 116
– –, определение 114, 122
Эпилепсия 65
Эргодическая теория 106, 112-113, 128-129
Эриксон М. (Ericsson M.) 67
Эрмитовы многочлены 266
Эсхатология* 15-16
Эффектор 162–164, 181–183
– –, гомеостэтические эффекторы 184, 185, 186
– –, эффекторы произвольной деятельности 185
Эшбн У.P. (Ashby W.R.) 21, 24-25, 308, 313–314

Юм Д. (Hume D.) 200, 209
Юнг К.Г. (Jung С.G.) 228