Варшавский В. И., Поспелов Д. А., Оркестр играет без дирижера: размышления об эволюции некоторых технических систем и управлении ими.—М.: Наука. Главная редакция физико-математической литературы, 1984.— 208 с., 50 илл.— 65коп.

ПРОБЛЕМЫ НАУКИ И ТЕХНИЧЕСКОГО ПРОГРЕССА

В. И. ВАРШАВСКИЙ

Д. А. ПОСПЕЛОВ

ОРКЕСТР ИГРАЕТ БЕЗ ДИРИЖЕРА

РАЗМЫШЛЕНИЯ ОБ ЭВОЛЮЦИИ НЕКОТОРЫХ ТЕХНИЧЕСКИХ СИСТЕМ И УПРАВЛЕНИИ ИМИ

МОСКВА «НАУКА» ГЛАВНАЯ РЕДАКЦИЯ ФИЗИКО-МАТЕМАТИЧЕСКОЙ ЛИТЕРАТУРЫ

1984

32.81

В 18

УДК 62-50

Варшавский В. И., Поспелов Д. А.

В 18 Оркестр играет без дирижера: размышления об эволюции некоторых технических систем и управлении ими.—М.: Наука. Главная редакция физико-математической литературы, 1984.— 208 с., 50 илл.— 65коп.

Мир, создаваемый человеком в технических системах во многом похож на тот, который окружает человека в природе. И в искусственном мире техники могут происходить процессы, подобные эволюции живых организмов. Возникают колонии и сообщества технических систем, формируются «сверхорганизмы» типа муравейника, возникают «коллективы», живущие по своим законам. Авторы книги анализируют эти аналогии и рассматривают принципы построения управления в таких технических системах, которые во многом отличаются от привычных схем управления. Для чтения книги не требуется никакой специальной подготовки, хотя она обращена не только к так называемому широкому читателю, но и к специалистам, работающим в области управления и кибернетики.

В 1502000000-058 185-84 ББК 32.81 053(02)-84 6Ф 0.1

© Издательство -«Наука» Главная редакция

физико-математической литературы. 1984

ВМЕСТО ПРЕДИСЛОВИЯ

13 февраля 1922 года в Москве состоялось первое публичное выступление Персимфанса — Первого симфонического ансамбля Моссовета. Это выступление стало настоящей сенсацией для всех профессионалов и любителей музыки,

Дело в том, что Персимфанс исполнял музыку без дирижера. И не какие-нибудь легкие для коллективного исполнения сочинения. В его первой программе прозвучали такие серьезные музыкальные вещи, как Третья (Героическая:) симфония Бетховена или концерт для скрипки с оркестром того же авторе. И звучали они настолько слаженно и артистично, что профессионалы уходили после концерта в полном недоумении. Им казалось, что в игре Персимфанса есть какой-то трюк, фокус, кто-то скрытно дирижирует оркестром, создает то неповторимое исполнение, которое может обеспечить лишь воля дирижера. Ибо лишь дирижер способен дать свою, глубоко индивидуальную интерпретацию музыкального произведения, навязать динамику исполнения, синхронизировать партии различных инструментов, заставить огромный оркестр звучать слаженно. Именно поэтому обычно музыканты сидят на сцене так, чтобы видеть дирижера и следовать его указаниям.

А музыканты Персимфанса сидели совсем иначе. Струнные сидели, образуя полный круг (частично спиной к зрителям!), а духовые располагалась в середине этого круга. Каждый музыкант видел каждого, ибо в Персимфансе каждый слушал каждого и всех, а все слушали каждого. Не было никакого трюка. Взаимодействуя непосредственно друг с другом, прекрасные музыканты, входившие в Персимфанс, легко обходились без дирижера.

Десять лет продолжались с неослабевающим успехом выступления Персимфанса, и все это время загадка этого оркестра интересовала и широкую публику, и специалистов. В рамках общей цели — достижения артистичного исполнения, того или иногопроизведения, каждый музыкант реализовал наилучшим образом свою локальную цель, демонстрируя в полной мере свои профессиональные возможности. (Другим примером, возможно более близким некоторым читателям, может служить джазовый ансамбль, играющий в стиле диксиленд.) Таким образом, вместо централизованного управления, реализуемого дирижером, в Персимфансе восторжествовал децентрализованный способ управления. Этот способ реализовался за счет коллективного взаимодействия музыкантов, которое «порождало» процесс управления. Но как это происходило, оставалось непонятным» не укладывалось в четкие и формальные правила.

Подобная ситуация, когда сложные процессы развиваются не за счет централизованных воздействий, а за счет локальных взаимодействий их элементов, широко распространена в природе и в человеческом обществе. Она встречается гораздо чаще, чем это может показаться на первый взгляд. А, значит, вопрос о том, как рождается децентрализованное управление в результате коллективного взаимодействия элементов — куда глубже того, который возник у тех, кто стремился понять загадку Персимфанса. Ответ на него — одна из целей этой книги.

Авторы ее поставили перед собой задачу рассказать на популярном уровне о проблемах управления в сложных системах, которые в теории управления принято называть большими. В подобных системах часто приходится переходить от централизованного управления к децентрализованному. Это представляет собой как бы плату за сложность, присущую большим системам. Централизованное управление в них, как правило, неэффективно, а в ряде случаев просто невозможно. Но откуда берутся столь сложные системы? Не есть ли категория больших систем надуманной? Как мы постарались показать в книге, мир больших систем, окружающих человека, все время обогащается. Рост сложности искусственных систем, создаваемых человеком, происходит постоянно. Идет эволюционное развитие созданных ранее искусственных систем, в какой-то степени напоминающее эволюцию в мире живых организмов. Децентрализованное управление — закономерное порождение этой эволюции. И наша задача — убедить читателей в справедливости этих утверждений.

Глава 1 КАК ВОЗНИКАЕТ ДЕЦЕНТРАЛИЗОВАННОЕ УПРАВЛЕНИЕ?

Голос: «До того, как что-нибудь было, ничего не было.»

И. Шток

§ 1.1. Искусственный мир

С того момента, как наш далекий пращур взял в руки камень и стал обрабатывать им бесформенный кусок породы, стараясь придать ему нужную форму, стал возникать мир вещей, которых не было в природе. Эти создания человеческих рук и человеческого ума со временем образовали то, что теперь принято называть словом техноценоз. Техноценозы,— подобно биологическим сообществам, биоценозам — представляют собой множество различных технических устройств, приборов, систем и приспособлений, связанных между собою тесными и на первый взгляд непривычными связями. Живя среди этих искусственных вещей, человек не часто фиксирует эти связи. Редко, кто сознательно отмечает, что ручки на двери располагаются на определенной высоте, а сама дверь требует для своего открывания и закрывания определенных усилий, никого не удивляет, что шурупы устроены так, что их можно ввинчивать и вывинчивать с помощью отвертки, не приводит нас в изумление и то, что железнодорожный вагон, прицепленный к поезду в Москве, может пересечь в составе поезда всю Европу (проезжая по мостам через реки и через туннели в горах), переплыть пролив на пароме и оказаться в Лондоне. Техноценозы подобно биоценозам заставляют «организмы», входящие в них, жить по законам, диктуемым всем сообществам. Если, например, конструктор пополняет техноценоз новым типом самолета, который требует для своего взлета и посадки полосы длиной, большей, чем на существующих в данный момент аэродромах, то такой самолет не сможет существовать нигде, кроме как в воображении конструктора или в цехе завода-изготовителя. Для него просто нет соответствующей «экологической ниши» в техноценозе, связанном с полетами.

В этой книге мы часто будем пользоваться анало-гиями из биологии, использовать термины, принятые при описании структуры и функционирования биологических сообществ. Это не просто прихоть авторов. Мы глубоко убеждены, что между органическим миром, созданным природой, и техническим миром, созданным и создаваемым человеком, имеется большое сходство. И это сходство не внешнее, а глубинное. Фундаментальные законы природы влияют на биологические организмы и на технические систему, которые должны функционировать в той же среде,' что и живые организмы. Одинаковость целей даже при условии кардинальных различий живого и неживого приводит к появлению сходства в структуре и функционировании. И в нашей книге мы попытаемся вскрыть некоторые черты этого глубинного сходства.

Рассмотрим теперь грубую схему того, как человек создает новый элемент техноценоза. В рамках рациональной деятельности человек ничего не делает «просто так», без определенной цели. И создаваемые им технические устройства изобретаются, проектируются и изготовляются для решения некоторой задачи, достижения определенной цели. У этих изделий есть цель существования, которую мы будем обозначать через Ge. Например, создавая мотыгу, ее первые изобретатели ставили перед собой вполне определенную цель: создать приспособление, с помощью которого можно было бы взрыхлять нa определенную глубину землю для посадки растений. Это предопределило и множество допустимых форм рабочей поверхности мотыги, и длину ее ручки, и выбор материала для изготовления ее частей. Создавая автомобиль типа «БелАЗ», конструкторы ставили перед собой вполне определенную задачу, породившую «существование» этого семейства сверхтяжелых грузовиков,— перевозку больших объемов породы на открытых карьерных разработках.

Естественно, что создатель нового объекта учитывает, что Ge должна быть достижима. Но, как правило, он хочет, чтобы эта цель достигалась эффективным образом. Что вкладывается в это понятие? Ответить на такой вопрос очень трудно. Но для нас важно, что в понятие эффективности в частности может входить требование о возможно меньшем расходе каких-либо ресурсов (например, энергетических, сырьевых или временных) на достижение Ge, надежности достижения Ge, полноты (точности) ее достижения, минимизации затрат на изменения в техно-ценозе для обеспечения функционирования создаваемого объекта. Все эти требования можно объединять в некоторое понятие «ограничения». Не все читатели, вероятно, согласятся с такой трактовкой понятия ограничения. В теории управления этот термин понимается более узко. Но для нас такое его расширение в рамках данной книги представляется оправданным.

Для того чтобы созданный объект техноценоза мог бы достигать Ge, требуется еще организовать процесс ее достижения. Мало создать мотыгу, нужны еще человеческие руки, способные заставить ее действовать. Мало создать «БелАЗ», нужен еще шофер, способный использовать тяжеловоз по назначению. Другими словами, для достижения Ge необходим процесс управления. Управление требует для своей реализации определенных средств, ресурсов, которые мы будем обозначать R, и наличия информации о текущем состояния дел в той среде, где функционирует наш объект, состояниях самого объекта и состоянии управляющих средств. Обозначим всю эту информацию через I. Необходимость в управлении как бы выделяет в объекте две части: исполнительную и управляющую. Деление это весьма условно и в реальном объекте может иногда происходить лишь на уровне рассуждения об объекте, но оно весьма удобно. Именно к управляющей части обычно относят рассуждения об эффективности процесса достижения Ge. И для оценки ее работы вводят понятие критерия управления (например, достижение цели минимальными средствами) Q, который может носить как количественный, так и качественный характер.

С течением времени техноценозы растут количественно, структура их усложняется, число различных связей и зависимостей увеличивается. При этом возникает качественно новая задача управления — управление в рамках некоторого техноценоза или части его. Эта задача возникает потому, что цель существования самого техноиеноза обычно не формулируется каким-либо отдельным человеком или группой людей, a Ge объектов, входящих в техноценоз, далеко не всегда согласованы между собой.

Рассмотрим некоторый пример. Пусть нам необходимо перевезти контейнер с грузом из пункта А в пункт Б. Между этими пунктами нет прямой связи (даже воздушной), и мы вынуждены везти контейнер сначала по морю на корабле, потом по железной дороге и, наконец, на автомобиле. Каждый вид транспорта, которым мы воспользуемся, «живет» в своем техноценозе. Для морского транспорта в него в частности входят порты, предназначенные для грузовых операций. Они в свою очередь состоят из причалов, погрузочно-разгрузочных механизмов и складов. Железнодорожный транспорт не может существовать вне сортировочных станций, складов и тех же погрузочно-разгрузочных механизмов, а для автомобиля в его техноценоз входят и дороги, и авторемонтные хозяйства, и заправочные станции. Простая операция перевозки контейнера требует согласованной формы взаимодействия техноценозов и многих объектов внутри них. Если между портовым складом и железной дорогой нет связи, способной осуществить передачу контейнера, то он не достигнет пункта Б. Если заправочные станции не обеспечат горючим автомобиль, выделенный для перевозки контейнера, и его нельзя доставить ни на каком другом автомобиле, то результат будет тот же, контейнер никогда не попадет в пункт Б.

Именно это требует специальных усилий по управлению в рамках одного техноценоза или группы взаимодействующих техноценозов*). Но на самом деле ситуация еще сложнее. Весь этот искусственный мир существует не сам по себе. Он существует в тесном переплетении с миром естественным. Человек, породивший техноценозы, сам становится их элементом, взаимодействует с объектами техноценоза» ставит и реализует в них свои собственные цели, наконец, организует управление внутри техноценоза и между техноценозами. Это резко усложняет структуру связей, ограничений и критериев. Учет экономических и социальных факторов делает управление особенно сложным. Тот всплеск работ по созданию автоматизированных систем управления, который так ярко проявился в последнее десятилетие, свидетельствует о том, что проблемы управления в техноценозах и между ними превратились в «горячие точки» техногенной цивилизации.

*) Отметим, что выделение тех или иных техноценозов как самостоятельных единиц сама по себе задача нетривиальная Но в этой книге мы ее не решаем.

В чем сложность возникшей перед человечеством задачи в области такого управления? Почему до сих пор не видно кардинальных успехов в этой области? Частичный ответ на свои вопросы мы получим в следующем параграфе.

§ 1.2. Системы, которые в полном объеме никто не создавал

Вероятно, все читатели нашей книги пользовались междугородним телефоном. Предположим, что некто X, живущий в небольшом районном городке на юге Днепропетровской области, очень хочет поговорить со своим братом, работающим в Магадане. Оформив заказ на разговор и прождав необходимое для службы связи время, абонент Х начинает говорить со своим братом Y. Как возникает возможность такого разговора, ни X, ни Y, как правило, не интересует. Им важно только, чтобы слышимость была хорошей, а время ожидания начала разговора небольшим. Однако десятки, если не сотни различных технических устройств обеспечивают этот разговор. Между Х и Y протягивается канал, скоммутированный с помощью этих устройств. А при полуавтоматическом или ручном каналах связи в обеспечении разговора Х и Y участвуют и люди — диспетчеры. И ни X, ни Y не знают маршрута движения своих сообщений.

Но мы не будем анализировать сейчас те принципы управления, которые позволяют сети телефонной связи обеспечивать коммуникацию Х с Y и многих других абонентов, которые одновременно с нашими Х и Y используют ту же сеть телефонной связи. Обратим внимание на другую особенность столь привычной для большинства обитателей земного шара системы, входящей в современную техногенную сферу. В отличие от радиоприемника или телевизора, самолета или автомобиля мировая сеть телефонной связи не имеет единого проектировщика, который бы воплотил свой замысел в имеющуюся сеть. Та система, которая существует, возникла из более простых систем эволюционным путем, путем постепенного объединения более простых систем и усложнения функционирования в процессе их объединения. Поясним эту очень важную для авторов книги мысль.

Когда в 1878 г. в Нью-Хойзене в США появилась первая телефонная станция, то возник как бы зародыш будущей системы. Конечно, у этой станции был свой создатель и проектировщик. И, создавая свое детище, он создал и способ управления им. Так появилось наборное коммутационное поле и первые работники связи—миловидные девушки, ловко орудовавшие штекерами, обеспечивая необходимые соединения между абонентами. Телефонный аппарат, каналы связи и коммутатор стали первыми важными Элементами этой телефонной сети. Такие локальные сети быстро распространились по многим странам. Потом появилась каналы связи между городами и странами, которые связывали между собой отдельные телефонные сети. Постепенное усложнение структуры сети приводило к возникновению новых технических проблем, без решения которых эти новообразования не могли бы функционировать. Возникли промежуточные усилители, полуавтоматические и автоматические коммутаторы и многое другое. И на каждом этапе развития телефонной сети работали изобретатели, ученые и проектировщики, которые улучшали элементы сети, изобретали новые устройства для коммутации абонентов, повышения качества передачи сигналов и т. п. В развивающейся сети появилась иерархия — верный признак усложнения ее структуры. Усложнялись и методы управления сетью.

Но что же происходило с системой управления сетью связи? Создатели телефонного аппарата сначала исходили из того, что абонент, соединившись с коммутационным узлом, назовет диспетчеру необходимый ему номер. Появление автоматических узлов коммутации принципиально ничего не изменило. Только вместо произнесения номера вызываемого абонента в трубку мы набираем его на вращающемся диске или с помощью кнопочного устройства. Но при вызове абонента из другого города, с которым пока еще не установлена автоматическая коммутация по коду города, мы продолжаем пользоваться «старым дедовским способом», называя диспетчеру номер необходимого телефона и город, в котором этот абонент проживает.

Таким образом, управление со стороны абонента, пытающегося установить связь с нужным ему лицом, практически никак не изменилось со времен тех телефонов, когда он крутил ручку магнето, посылая сигнал начального вызова в коммутатор. И рост телефонной сети сказывается для пользователя лишь в расширении его возможностей по связи с другими абонентами, да в росте отказов и времени ожидания при попытках установления связи.

А какие изменения произошли в системе управления на коммутационном узле? Внешне тоже никаких, ибо принцип коммутации каналов остался старым. Но изменения коснулись более глубинного пласта управления. В телефонной сети каждый коммутационный узел, каждая национальная компания или одна из таких компаний имеют свои собственные цели и предпочтения. Но для работы всей сети нужно, чтобы вое эти индивидуальные цели были бы как-то скомпенсированы, согласованы с другими индивидуальными целями. Сеть, связывающая отдельные подсети, заставляет всех пользователей образовывать некоторую коалицию, коллектив. И без соотнесения личных интересов пользователя с интересами партнеров по коалиции ничего нельзя добиться. Это приводит к тому, что вместо максимизации своего личного выигрыша (будем называть так всю совокупность требований, которые индивид предъявляет к сети) каждый специалист, принимающий участие в управлении, должен максимизировать свой личный выигрыш лишь в условиях согласованных действий остальных специалистов. Поэтому и возникает новая функция управления — достижение согласованных действий при управлении объектом при наличии многих управляющих систем (пользователей) со своими личными локальными интересами.

Как можно добиться такого согласования? Один из способов — распространение специальной служебной информации по всей сети, организация переговоров и совещаний, плакирование ее работы. Этот путь имеет скорее теоретический, чем практический интерес. Время, затрачиваемое на переговоры и согласования, будет слишком большим, планирование в условиях случайных требований абонентов на обслуживание невозможно, ситуации, возникающие в сети, динамичны и трудно предсказуемы. Где же выход из создавшегося положения? По-видимому, он единственный. Согласование действий управляющих органов в сети должно возникать как бы «само собой» в процессе автономного и децентрализованного функционирования всех частей этой системы. А для того чтобы оно стало возможным, необходим некоторый регулирующий механизм, реализуемый не каким-либо «верховным органом» сети, а в процессе обмена незначительной информацией локального типа между отдельными подсистемами управления. В телефонной сети земного шара это может быть реализовано в виде взаимных платежей между государствами и компаниями, отражающими качество согласования работы отдельных участков сети и величину потоков требований на связь в тех или иных участках сети.

Для нас чрезвычайно важен и принципиален следующий вывод из сказанного. Система, возникшая эволюционным путем, не может управляться централизованно, единым органом управления. И достижение глобальной цели функционирования такой системы (ее Ge) происходит за счет согласования действий отдельных подсистем объекта, за счет своеобразного конформизма систем управления этими отдельными подсистемами. Централизованное управление в подобных системах может привести только к ее развалу. Известному советскому ученому А. А. Ляпунову принадлежит следующий замечательный по своей наглядности пример бессмысленности централизованного управления в определенных технических системах. Предположим, что кому-нибудь в голову пришла идея централизованно управлять использованием всех товарных вагонов, находящихся в распоряжении железных дорог СССР. Крайним случаем выражения этой идеи было бы создание грандиозного парка свободных вагонов, размещаемого где-нибудь в районе Урала. Требования на перевозки поступали бы в центральную диспетчерскую, которая и выделяла бы необходимое заказчику множество вагонов и гнала бы их к месту погрузки. После выполнения задания вагоны возвращались бы в парк. Ясно, что подобная организация управления парком грузовых вагонов неэффективна и попросту вредна. Хотя это отнюдь не означает, что не может существовать некоторой глобальной цели управления и критерия управления, относящегося ко всему парку грузовых вагонов. Но они должны достигаться не путем прямого управления ресурсами, как это было в едином парке вагонов на Урале, а путем согласованных действий отдельных подсистем в условиях организации между ними такой системы поощрения и наказания, которая обеспечивала бы достижение этой цели с учетом глобального критерия управления.

Такое управление и подобное взаимодействие управляющих подсистем встречается не столь уж редко. Для иллюстрации этого утверждения приведем несколько поучительных примеров.

§ 1.3. Несколько поучительных примеров

1. По-видимому, каждый из читателей посещал колхозный рынок. На рынке, если исключить лиц, зашедших туда из любопытства или в поисках случайного заработка, все остальные посетители делятся на два класса: покупателей и продавцов. Основной операцией, совершаемой на колхозном рынке, является единичный акт купли — продажи. В результате этого акта некоторое количество определенного товара переходит из рук продавца в руки покупателя. Мы не хотели бы пока вдаваться в тонкости, связанные с совершением этого акта, ибо многие из них должны исследоваться не в данной книге, а в литературе иного направления (от юридической и психологической до художественной). Поэтому, обедняя процесс, мы будем каждый единичный акт купли — продажи характеризовать тремя параметрами: С1, С2 и С. Смысл этих параметров следующий: C1 характеризует опорную цену продавца, т. е. ту цену, ниже которой ему невыгодно продавать свой товар; С2 — предельную цену, за который покупатель может приобрести товар, отказываясь его покупать по более высокой цене;

С — цену, которая была реализована в акте купли — продажи. Конечно, если этот акт совершился, то C1 £С £ С2. Будем считать, что продавцы и покупатели не договариваются заранее о величине C1 по всему множеству продавцов (что иногда явно наблюдается на рынке) и о величине С2 но всему множеству покупателей. Конкретное значение С в этом случае будет появляться в результате некоторого процесса, протекающего в конкретной паре покупатель — продавец. Но никто не заставляет покупателя не получать информацию о ценах, которые требуют за свой товар различные продавцы, а продавца — не анализировать готовность назначить ту или иную цену множеством отдельных покупателей. Никто не заставляет покупателя выбирать именно этого продавца, а продавца — именно этого покупателя. С помощью изменения цен на товары и тот и другой как бы управляют процессом купли—продажи.

Будем для определенности считать, что класс покупателей есть объект управления, а класс продавцов — управляющая система, цель которой — продать весь имеющийся у продавцов товар (предполагается, что запросы покупателей и количество товара, имеющегося на рынке у продавце», сбалансированы). Эта общая цель как бы разлагается на индивидуальные цели отдельных продавцов—продать тот товар, который они привезли на рынок. Общая цель мало интересует конкретного продавца. Она интересует скорее местный горисполком» получающий от продажи товаров на рынке определенный процент от количества проданного товара. В реальной жизни этот процент получается не непосредственно, а косвенным образом, с учетом таких показателей, как обеспечение населения города необходимыми продуктами питания, но нас устраивает подобная очень грубая модель.

Если теперь зафиксировать закон изменения цен в процессе торговли между покупателями и продавцами и учесть, что цель продавца — максимизировать С при ограничении С ³ C1 и продать как можно больше товара, то эта цель может быть достигнута при замене каждого продавца устройством, изменяющим по заданному закону величину назначаемой за товар цены, начиная с некоторой цены С*, определяемой начальным состоянием продавца' при приезде на рынок (например, значением продажной цены, которое было установлено перед выездом на рынок на семейном совете), до величины его опорной цены C1. При этом отказ очередного покупателя от покупки товара по запрашиваемой цене в простейшем случае снижает эту цену на основании заложенного в устройство закона изменения цен. Каждое устройство-продавец действует как бы автономно. Множество покупателей и другие устройства-продавцы выступают для него как некоторая среда, подающая ему сигналы о необходимости снижения или повышения цен. Как показывает анализ процессов, протекающих в такой рыночной модели, децентрализованное управление, совершаемое множеством устройств-продавцов, приводит к выравниванию цен С на рынке. При этом достигается и общая цель всего коллектива продавцов — количество продаваемого товара стремится к максимуму. Если же увеличить количество информации, поступающей к продавцам, сообщая им, например, среднее значение величины С в данный момент по всем уже совершенным актам купли — продажи или полную информацию о значениях С по всем уже реализованным актам купли — продажи, то сходимость процесса выравнивания цен на рынке будет иметь значительно большую скорость.

Что мы должны особенно выделить в этом примере? Прежде всего децентрализованный характер управления. Управление происходит с помощью коллектива почти автономных устройств (продавцов), получающих информацию о действиях друг друга только через среду. И тем не менее, как эта ни парадоксально, такое управление приводит к удовлетворению всех локальных целей продавцов и обеспечивает некоторый глобальный выигрыш, отражающий интересы системы управления более высокого уровня, которая, однако, не оказывает непосредственного влияния на локальные процессы во взаимодействии продавцов и покупателей.

2. Второй наш пример относится к пчелиному улью и описывает ситуацию, хорошо известную наблюдательным пчеловодам. Наступило похолодание. Оно грозит неприятностями расплоду. Он может погибнуть. И рабочие пчелы собираются на сотах с расплодом плотной массой, тесно прижавшись друг к другу. Температура в районе расплода поднимается и опасность исчезает. А когда жара такова, что температура в улье начинает катастрофически под- ниматься, рабочие пчелы приносят в улей воду и покрывают ячейки с расплодом тонкой водяной пленкой. После этого каждая из рабочих пчел, находящихся в улье, начинает выполнять роль своеобразного вентилятора. Она быстро работает крыльями, помогая испарению воды и охлаждению ячеек с расплодом.

В описанных процессах все пчелы действуют индивидуально, независимо друг от друга, децентрализованно, ибо каждая из них своими органами чувств ощущает критические перепады температуры в улье и включает программы ликвидации нежелательных последствий.

3. Рассмотрим грубую модель конвейерного производства автомобилей. Некоторые цеха или группа цехов выпускает отдельные узлы будущего автомобиля; они поступают на главный конвейер и собираются в готовое изделие. В отдельных производствах также могут существовать свои «главные конвейеры», узлы для которых готовятся во вспомогательных подразделениях второго порядка и т. д.:

«я гайки делаю, а ты для гаек делаешь болты». Это приводит к взаимной увязке работы всех частей сложного производственного процесса. И если соответствующий участок, производящий гайки, ежемесячно выполняет план на 200 %, а участок, производящий болты — на 150 %, то радости от этого немного. И если нельзя увеличить выпуск болтов до 200 %, то необходимо снизить выпуск гаек до 150 %.,

Таким образом, основной заботой для автозавода в целом должен быть комплекс мероприятий, обеспечивающих ритмичность и бесперебойность работы главного сборочного конвейера, а не максимизацию выпуска каких-либо вспомогательных узлов (если только не удается использовать их для снабжения автохозяйств дефицитными запасными частями). Руководители вспомогательных подразделений могут действовать автономно и децентрализованно лишь в пределах решения основной задачи, подчиняя свои локальные цели общей цели завода.

4. Всякий житель большого города имел дело с радиофицированными такси. Водители этих машин могут принимать информацию о поступающих в диспетчерскую заказах. Давайте вспомним, как происходит их распределение. Диспетчер может придерживаться различных .стратегий распределения. Во-первых, он может просто сообщить всем автомашинам, находящимся на линии, условия поступившего заказа. Если у кого-то из водителей этот заказ встретит интерес (например, данный водитель простаивает и находится недалеко от места, где надо брать пассажира, или он заинтересован в перемещении к конечному пункту, указанному в заказе), то он может взять заказ на себя, сообщив об этом диспетчеру. Во-вторых, диспетчер может назначить того или иного водителя для выполнения заказа, исходя из своего понимания обстановки или из каких-либо личных соображений. Однако второй путь оказывается гораздо менее эффективным как для парка, так и для заказчика, у которого в среднем растет время ожидания исполнения заказа. Особенно это проявляется в том случае, когда заказы поступают не для незамедлительного выполнения, а с указанием срока их выполнения. В этом случае децентрализованное управление, осуществляемое водителями такси (здесь диспетчер выполняет роль информационного, а не управляющего звена), оказывается более эффективным, чем централизованное.

§ 1.4. Обсуждение примеров

Нам кажется, что приведенных примеров уже достаточно для того, чтобы можно было сделать некоторые выводы. В последующих главах читатель встретит еще немало примеров объектов из того множества естественных и искусственных систем, которые обладают теми же специфическими свойствами, что и телефонная сеть, пчелиный улей, колхозный рынок или большое автохозяйство.

Выше мы ввели такие характеристики систем управления, как I, Q и R. Попробуем теперь, опираясь на приведенные примеры, дать самую общую классификацию систем управления, причем мы заранее предупреждаем читателя, что цель этой классификации весьма узка. Она нужна нам для пояснения идей, развиваемых в данной книге, а не для исчерпывающей классификации централизованных и децентрализованных систем управления. Вторая задача неизмеримо труднее и серьезнее, чем та классификация, которая будет дана в этом параграфе.

Рассмотрим сначала управление температурой в улье. Каждая рабочая пчела имеет полную информацию о состоянии улья. И эта информация одина- кова для всех рабочих пчел, находящихся в улье.

Она сводится к знаниям о текущей температуре в улье. Каждая рабочая пчела обладает не только одинаковой I, но и одинаковым Q. Цель управления — приведение температуры около сот с расплодом в допустимый интервал, а в качестве дополнительного требования выступает время, в течение которого это необходимо сделать. Кроме того, и R у всех рабочих пчел одинаковы. Все они умеют махать крыльями с одинаковой скоростью, повышать. температуру своего тела на 10 градусов но сравнению с температурой воздуха, приносить и распылять воду. Таким образом, в случае регулирования температуры в улье мы имеем управляющую систему, состоящую из однотипных подсистем управления, каждая из которых характеризуется одними и теми же значениями I, Q и R. Кроме того, локальные интересы таких подсистем согласованы с глобальной целью управления (попросту cовпадают с ней), что не требует от них каких-либо действий по согласованию интересов.

Подобные системы можно отнести к простейшим децентрализованным системам управление. В них отсутствует какая-либо специализация подсистем управления, и если управление не может быть осуществлено отдельной подсистемой, то, увеличивая их число, мы получаем систему управления, способную решить поставленную перед вей задачу («не умом, так количеством»—вот девиз подобных систем),

Когда пожарная команда прибывает к месту тушения пожара, то картина несколько отличается от ситуации в улье. Хотя все пожарные подразделения имеют одинаковую глобальную цель — потушить пожар с минимальными затратами и в минимально возможное время — и одинаковую исходную информацию, средства их различны, а значит, различны и индивидуальные локальные цели, которых они могут достичь. Одни из них баграми и топорами взламывают крышу, под которой находится очаг пожара, а другие с помощью специального раствора пытаются сбить пламя. Здесь наблюдается не только чисто структурная децентрализация системы управления (пожарной части), но и специализация подсистем по средствам. Системы такого класса иаиболее часто встречаются в технических системах, образующих техноценозы. Если же при этом на пожаре нет начальника, ставящего подразделениям задачи и разумно координирующего их действия, то мы имеем дело с типичной децентрализованной по средствам системой управления.

Конвейерная система автомобильного завода дает нам пример того, что подсистемы системы управления могут и не обладать полной и однотипной информацией. Средства, имеющиеся в руках отдельных подразделений завода, и их локальные цели могут также различаться между собой (во всяком случае, в условиях принятой системы стимулирования производства). И лишь административное подчинение всех заводских подсистем управления главному диспетчеру завода и ряду других лиц вносит в эту систему ту централизацию, которая необходима для согласования этих локальных целей. Если же централизация будет отсутствовать, то автомобили все равно будут собираться, если зарплату платить только за собранные автомобили. Как это сделать, по-видимому, представляют все читатели.

Таксопарк дает нам пример системы, где водители автомобилей, обладая однотипной информацией и одинаковыми средствами достижения целей, принимают различные решения из-за различных критериев достижения своих целей. Роль диспетчерской сводится к тому, чтобы эти личные цели не вступили в противоречие с целью таксопарка (например, выполнением спущенного ему плана). При необходимости диспетчер может навязать тому или иному водителю свою волю, отражающую стремление к достижению глобальной цели всего коллектива.

Наконец, ситуация на рынке, где отсутствует опо- вещение о сделках между продавцами и покупателя- ми, дает нам пример децентрализованного управления, в котором из-за взаимного влияния подсистем управления друг на друга происходит принудитель-ное согласование личных целей продавцов, приводящее к равновесным ценам в актах купли — продажи.

Сказанное означает, что понятие децентрализации в системе управления может быть весьма различным. Обязательно лишь наличие отдельных подсистем в системе управления, которые должны выбирать средства воздействия на объект управления, не получая информации о том, какое решение в тот же момент времени принимают другие подсистемы. Корректировка действий подсистем происходит только через информацию, получаемую подсистемами от объекта управления. Весьма часто подсистемы могут быть таковы, что они «не знают» о существовании других подсистем или имеют весьма ограниченную информацию об их функционировании.

Рис. 1.1.

На рис. 1.1 приведена классификационная структура, использующая значение трех классификационных параметров: I, R, Q. Звездочка означает, что. в данной системе управления для разных подсистем нет совпадения по множеству значений этого параметра. Около каждой позиции классификационной структуры указан пример системы управления, для которой выполнены соответствующие условия. Пояснения нужны только для двух случаев, так как остальные примеры мы уже проанализировали. Для случая (I*, R*, Q) можно рассматривать систему управления движением городского транспорта. В такой системе происходит естественная декомпозиция системы управления на подсистемы по видам транспорта (троллейбусно-трамвайное управление, управление метрополитеном и т. п.). В распоряжении каждой такой подсистемы имеются свои средства достижения однотипной цели — максимизации количества перевозимых пассажиров при обязательной экономии энергии и ресурсов. Для случая же (I*, R*, Q*) примером может служить система управления ходом спектакля в театре. Ведущие спектакль согласуют между собой различные подсистемы (систему освещения сцены, систему музыкального сопровождения, систему смены декораций и т. п.). Все подсистемы имеют свои средства и свои цели, согласованные с помощью режиcсерского плана с глобальной целью максимизации эстетического наслаждения, которое испытывают зрители.

Приведенные нами иллюстративные примеры в ряде случаев упрощены, но нам хотелось, чтобы они были несложны и ненадуманы. И если читатели почувствовали смысл классификации, приведенной на рис. 1.1, то авторы достигли своей цели полностью.

§ 1.5. Зачем нужна децентрализация?

Возникает вполне законный вопрос: не является ли децентрализация в системе управления следствием нашего плохого знания поведения объекта управления или того, как надо строить системы управления? Мы хотим привести ряд соображений в пользу того, что во многих случаях децентрализованное управление есть не ухудшенный вариант централизованного или иерархического, но вполне законный, а часто и единственно возможный вид управления. Кое-какие мысли по этому поводу мы уже высказывали выше. Здесь же мы суммируем их окончательно.

1. Не все технические, а особенно экономические и организационные системы, возникли на основании единого проектировочного замысла. Многие системы в их современном виде «никто не изобретал, не проектировал и не создавал». Они возникли из более простых систем в результате своеобразной технической эволюции, о которой мы будем говорить в заключительной части книги. Выражение, которое мы взяли в кавычки, является метафорическим. Конечно, в создании этих систем принимали участие и изобретатели, и проектировщики, и ученые. Но мы хотим подчеркнуть, что ни один из них не создал всю систему «целиком». Были люди, которые проектировали автоматические телефонные станции или локальные сети связи, но нет единого создателя Мировой телефонной сети или Мировой транспортной сети или Всемирного сообщества филателистов. В системах такого типа централизованное управление возможно лишь на уровне соглашений о путях развития системы, договоров о стандартах и основных ограничениях на пользование системой и т. п. Оперативное же управление самим процессом в них возможно, по-видимому, лишь децентрализованным образом.

2. Сложность тех систем, которыми в настоящее время пытается управлять человечество, достигла такого порядка, что централизованное управление ими становится невозможным из-за огромного потока информации, подлежащей переработке центральным управляющим органом и передаче по каналам связи. Время, затрачиваемое на это, делает, как правило, дальнейшую работу по управлению в динамическом режиме бесполезной. Иллюстрацией может служить положение, сложившееся в метеорологии при решении задачи краткосрочного прогноза погоды. Наземные метеостанции и метеоспутники поставляют сейчас такое количество оперативной информации, которое просто невозможно обработать в нужные сроки. Это породило остроумное и печальное замечание одного из крупных специалистов по прогнозу погоды, сказавшего, что «сегодня мы можем с абсолютной точностью предсказать погоду на завтра, но для этого нам нужен месяц работы».

3. С ростом сложности больших систем падает их надежность. При числе контактов порядка 1010, что примерно соответствует числу контактов в современной мировой телефонной сети, наличие отказов практически постоянно. Другими словами, система должна выходить из строя с вероятностью, весьма близкой к единице. Тем не менее, практика использования телефонной сети показывает, что этот феномен нами не наблюдается. Причиной такого парадокса является все та же децентрализация, которая обеспечивает в системе избыточность по управлению, необходимую для нормального функционирования системы. Нормальное функционирование таких систем, как мировая сеть связи или большая энергосистема, обеспечивается за счет локальных решений по изменению коммутации каналов или по переброске энергии из одной точки энергосети в другую. Если бы эти решения принимались централизованно, то время, затрачиваемое на передачу необходимей информации, сделало бы функционирование таких систем абсолютно ненадежным и неэффективным.

4. В ряде случаев очень трудно сформулировать на том уровне точности, который необходим для централизованного управления, цель существования объекта управления и критерий управления. Но даже если это и можно сделать для сложной системы, то, к сожалению, почти, никогда не удается указать, как, исходя из них, осуществлять само управление объектом. Однако весьма часто такую информацию можно указать для подсистем управления и увязать их функционирование через, ограничения, формируемые из цели существования и критерия управления всем объектом в целом. Примером подобной ситуации могут служить различные автоматизированные системы управления региональными объектами (типа города, области и т. п.).

5. При создании межнациональных и межгосударственных систем децентрализация в условиях современного состояния мира просто неизбежна, хотя отдельные межгосударственные органы управления и могут быть созданы в результате специальных соглашений.

Все сказанное заставляет весьма серьезно отнестись к самой идее децентрализованного управления в сложных системах. Исторически первые интересные модели такого управления были созданы М. Л. Цет-линым, чей вклад в это направление трудно переоценить. Он был создателем целого направления исследований, получившего название «коллективное поведение автоматов». Им были сформулированы основные принципы, лежащие в основе подобных мо- делей, и способы их реализации. Последующие исследования в этой области позволили создать ряд оригинальных и интересных моделей децентрализованного управления типа (I, R, Q*), а впоследствии и других типов.

Итак, объектами наших дальнейших исследований будут децентрализованные системы управления разных типов (см. рис. 1.1). При этом, как правило, мы будем рассматривать системы управления, в которых подсистемы однотипны. Децентрализация в таких системах достигается за счет согласования действий подсистем через объект управления (среду, в которой функционируют подсистемы), что позволяет всей системе достигать поставленной перед ней цели в результате действий подсистем, направленных на достижение своих локальных целей.

Такое ограничение рассматриваемых систем управления связано с тем, что в противном случае нам пришлось бы говорить о столь широком классе систем, что никакие результаты, кроме тривиальных, мы бы получить не смогли. Кроме того, однотипность подсистем управления резко облегчает задачу компановки самой системы управления и значительно снижает сложность ее проектирования.

Чаще всего мы будем рассматривать такие подсистемы управления, работу которых можно описы-вать моделью конечного или вероятностного автомата. Хотя читатель встретит в дальнейшем и другие модели. Такое наше пристрастие определяется двумя фактами: хорошей разработанностью теории именно для таких подсистем и широким спектром приложений, в которых автоматные модели управления находят свое применение.

План нашего дальнейшего изложения таков. В следующей главе мы рассмотрим модель отдельной подсистемы, представляющей собой или детерминированный, или вероятностный автомат, функционирующий в случайной среде. Мы покажем, что, несмотря на весьма простую конструкцию, устройство этого типа могут с успехом приспосабливать свое поведение к априорно неизвестным условиям функционирования. Затем в гл. 3 и 4 мы опишем различные способы организации взаимодействия таких подсистем и приведем много разнообразных примеров решения задач управления, успешно решаемых таким образом. В гл. 5 мы обсудим проблемы, относящиеся к однородным структурам, в которых протекают параллельные и асинхронные процессы. Такие распределенные системы децентрализованного управления обладают многими важными для техники сегодняшнего дня свойствами, позволяющими использовать их в тех случаях, когда централизованным управлением воспользоваться невозможно. В заключительной главе книги мы проанализируем эволюционный путь развития технических объектов и систем управления ими, который, как нам представляется, начинает играть все большую роль в техническом прогрессе человечества. Для систем такого типа децентрализованное управление оказывается единственно возможным.

В тексте книги, учитывая ее популярный (насколько это нам удалось) характер, почти нет аналитических выкладок и доказательств. В ней господствует качественный характер изложения. Какие-либо ссылки на источники отсутствуют. Однако краткий комментарий (библиография), завершающий книгу, позволит заинтересованным читателям найти работы, в которых строго доказаны все результаты, упомянутые в этой книге, а также те работы, которые были использованы авторами в качестве источников примеров и моделей. И последнее. Кое-что читатель должен знать (например, азы теории вероятностей или математического анализа). Если бы мы этого не могли потребовать от читателя, то ничего, кроме вводной главы, нам бы написать не удалось,

[Главы 2-3, убраны по требованию правообладателя. Книга переиздана издательством URSS.]

Г л а в а 6 ДИАЛЕКТИКА ПРОСТОГО И СЛОЖНОГО

«Дороги, которые мы выбираем, следует отличать от дорог, которые выбирают нас».

Феликс Кривин

§ 6.1. Синтезогенез и интеграция усилий

«Все эти создания обладали тройственной симметрией и напоминали формой греческую букву гамма с тремя остроконечными плечиками, соединяющимися в центральном утолщении. В падающем свете они казались черными, как уголь, в отраженном — переливались синим и оливковым цветом, как брюшки некоторых земных насекомых. Наружные их стенки состояли из очень мелких пластин, напоминающих грани бриллианта, а внутри «мушки» содержали одну и ту же микроскопическую конструкцию. Ее элементы, в сотни раз меньшие, чем зернышки песка, образовывали что-то вроде автономной нервной системы, в которой удалось различить две частично независимые друг от друга цепи.

Меньшая часть, занимающая внутренность плеч, представляла собой микроскопическую схему, заведующую движением «насекомого», нечто вроде универсального аккумулятора и одновременно трансформатора энергии. В зависимости от способа, каким сжимали кристаллы, они создавали то электрическое, то магнитное поле, то переменные силовые поля, которые могли нагревать до относительно высокой температуры центральную часть; тогда накопленное тепло излучалось наружу однонаправленно. Вызванное этим движение воздуха, .как реактивная струя, делало возможным движение в любом направлении. Отдельный кристаллик не столько летал, сколько подпрыгивал, и не был, во всяком случае во время лабораторных экспериментов, способен точно управлять своим полетом. Несколько же кристалликов, соединяясь кончиками плеч друг с другом, образовывали систему с тем лучшими аэродинамическими показателями, чем больше их было.

Каждый кристаллик соединялся с тремя; кроме того, он мог соединяться концом плеча с центральной частью любого другого, что давало возможность образования многослойных комплексов. Соединения не обязательно требовали соприкосновения, кристалликам достаточно было сблизиться, чтобы возникшее магнитное поле удерживало все образование в равновесии. При определенном количестве насекомых система начинала проявлять многочисленные закономерности, могла в зависимости от того, как ее «дразнили» внешними импульсами, менять направление движения, форму, вид, частоту внутренних пульсаций; при определенных внешних условиях менялись знаки поля, и, вместо того, чтобы притягиваться, металлические кристаллики отталкивались, переходили в состояние «индивидуальной россыпи».

Эта длинная цитата из повести Станислава Лема «Непобедимый» приведена нами не случайно. На планете «Регис-III» люди столкнулись с необычным явлением. Из примитивных кристалликов, обладающих примитивным поведением, при определенных условиях возникал сверхорганизм — туча. И эта туча обладала почти неисчерпаемыми возможностями по адаптации своего поведения, ибо хранила в огромной памяти, складывающейся из памятей-песчинок отдельных кристаллов, необъятный запас знаний.

Однако столь ли уж необычен этот способ возникновения сложного из простого? После того, что читатель прочитал в предшествующих главах, подобный путь организации сложного поведения должен казаться ему весьма привычным; Наблюдения за биологическими организмами также не противоречат идее польского фантаста. Такое объединение более простых организмов в более сложный —один из путей эволюции в органическом мире. К. М. Завадский, много лет занимавшийся проблемами эволюции, назвал такой путь синтезогенезом. Переход от одноклеточных водорослей к многоклеточным был решающим шагом на пути прогресса органического мира; сообщество рабочих пчел в улье или рабочих муравьев в муравейнике—примеры того же типа.

Но простое скопление однородных подсистем или организмов—это еще не новая система или организм. Множество рабочих пчел, встретившихся на цветущем лугу и относящихся к разным пчелиным семьям,—это совсем не то, что множество рабочих пчел из одного улья. И совокупность пассажиров, оказавшихся одновременно в трамвае, резко отличается от множества покупателей и продавцов на колхозном рынке.

В чем же состоит это отличие? В самом общем виде можно сказать, что некоторая совокупность элементов является единой системой, если эти элементы обладают потенциальным свойством образовывать статические или динамические структуры, необходимые для «выживания» элементов и всей их совокупности, т. е. обладают свойством устанавливать взаимодействие друг с другом для достижения локальных и глобальной целей. Это, конечно, не определение, а скорее рассуждение о чрезвычайно сложном вопросе. Исчерпывающий ответ на него — предмет специального исследования, выходящего далеко за границы возможностей авторов. Но, как нам кажется, суть всех моделей коллективного поведения и взаимодействия в этом и состоит. Отметим еще, что когда речь идет о биологических совокупностях, то в реальных ситуациях эти потенциальные свойства проявляются лишь частично, а остальные — ждут своего часа. Хорошо- известны, например, опыты с некоторыми бактериями, которые всегда обитали в средах, где отсутствуют определенные виды углеводов. При искусственной пересадке их в среды, где эти непривычные углеводы были единственной доступной для бактерий пищей, они начинали вырабатывать фермент для их расщепления. Возможность этого была заложена в их генную структуру «на всякий случай» и реализовалась именно тогда, когда в этом возникла необходимость. Другой пример — огромные потенциальные возможности любого человека, подавляющее большинство которых никогда не проявляется у индивида, а возможно, и у человеческого сообщества.

Таким образом, синтезогенез—это путь увеличения числа потенциально возможных свойств, которые могут пригодиться системе при встрече с непривычными для нее ситуациями и средами.

Рассмотрим простую модель, иллюстрирующую возможности синтезогенеза. На рис. 6.1 [image] показан тороидальный мир — совокупность клеток, размещенных на внешней поверхности тора (обычная сушка или баранка дают превосходное представление о тороидальной форме). Предположим, что в клетках этого мира может находиться пища, которой могут питаться «организмы», обитающие в них. В качестве таких «организмов» будем рассматривать автоматы с линейной тактикой. Простейшая форма подобного автомата — автомат с одним действием, показанный на рис. 6.2, а. В состоянии 1 при получении сигнала штраф автомат «умирает» (на рисунке это отмечено крестиком). Действие, которое может совершать автомат,— перемещение в некотором фиксированном направлении на одну клетку тора. Обозначим четыре возможных направления перемещения, показанные на рис. 6.1, через А, Б, В, Г. Тогда простейшие автоматы будут делиться на четыре типа — будем обозначать их теми же буквами. Допустим, что автоматы, находящиеся в одной клетке, могут объединяться. Если объединяются два автомата одного типа, то это приводит к увеличению длины лепестка (т. е. глубины памяти для этого действия). При объединении же автоматов различного типа новый автомат имеет уже не один лепесток, а два. На рис. 6.2,6 показан автомат, который возник в результате объединения четырех автоматов, два из которых относятся к типу А, а оставшиеся два — к типу В и Г. Для удобства будем обозначать такой автомат как А2ГВ.

В отличие от классического автомата с линейной тактикой наш автомат не может накапливать наказания безгранично и «умирает», когда число подряд действующих штрафов (пунктирные стрелки) превышает число состояний, имеющееся у автомата (для автомата, показанного на рис. 6.2, б, оно равно четырем). Кроме того, смена лепестков происходит равновероятно.

Сигналы наказания и поощрения формируются средой следующим образом. Если автомат в данной клетке съедает пищу, то он получает сигнал поощрения, в противном случае—сигнал наказания. После того как автомат съест пищу (на что в модели требуется один такт) и уйдет из клетки, то пища может в ней одномоментно восстановиться или клетка останется пустой до того момента, когда по закону, характеризующему среду, пища снова восстановится.

Если в одну и ту же клетку попадает несколько автоматов, то они принудительно объединяются и образуют новый более сложный «организм».

Рассмотрим несколько ситуаций в эволюционном процессе на торе.

На рис. 6.3 [image] показано несколько простейших ситуация на некотором участке тороидальной поверхности. Клетки, в которых имеется пища, отмечены точками. Предполагается, что пища, съеденная в клетках, полностью восстанавливается, как только автомат уйдет из нее. На рис. 6.3, а показаны два простейших автомата. Автомат Л съедает пищу в клетке, где он находится, и идет наверх. Но на этом кольце пищи нигде больше нет. В результате он погибает в клетке, помеченной крестиком. Иная судьба у автомата Г. Если пища имеется на всем кольце, то этот автомат, двигаясь по замкнутому кольцу вправо, будет все время поддерживать свое существование. Он живет вечно, не беспокоясь ни о чем.

На рис. 6.2, б показана еще одна очень простая ситуация. Автоматы А и Г встречаются в клетке с пищей, объединяются и начинают движение. Каким оно будет? Это зависит от того, какое именно состояние окажется начальным. Ели это состояние, соответствующее состоянию 1 автомата А, то объединенный автомат сначала сделает шаг наверх. В этой клетке пищи нет и автомат получит наказание. Это заставит перейти его в состояние 1 бывшего автомата Г и сделать шаг на одну клетку вправо. Там пища есть. Съев ее, автомат сделает еще один шаг вправо. Получив наказание, он, как автомат А, сделает шаг вверх и получит пищу. Далее процесс будет повторяться циклически, если пища размещается на поверхности тора регулярным образом. Автомат будет двигаться по «диагональной линии» и жить вечное Если бы начальным состоянием объединенного автомата было состояние 1 автомата Г, то движение было бы аналогичным. Пунктирные стрелки показывают оба возможных пути автомата АГ.

Усложнение структуры далеко не всегда приводит к улучшению функционирования. Это положение иллюстрируется рис. 6.3, в. В клетке с пищей образуется автомат АБГ. Пусть начальным его состоянием является состояние 1 автомата Г. Сдвинувшись на одну клетку вправо и получив сигнал штраф, автомат переходит (путем равновероятного выбора) в состояние автомата Б. Он сдвигается вниз, но пищи там нет. Опять следует равновероятный переход, и автомат снова попадает в состояние автомата Г. Происходит сдвиг вправо. Но так как пищи в этой клетке нет, объединенный автомат погибает, исчерпав все свои ресурсы. Если бы объединения не произошло, то при том распределении пищи, которое показано на рис. 6.3, в, все три простейших автомата могли бы жить вечно.

Наши забавные автоматы на тороидальной поверхности можно исследовать с разных точек зрения. Но, к сожалению, это увело бы нас весьма далеко от основной канвы книги. Те, кому понравился этот мир, могут придумать много занимательных и интересных историй, полных драматизма и неожиданных метаморфоз, которые могут развернуться на поверхности тора.

Для нас же важно отметить, что синтезогенез может приносить как пользу, так и вред, ибо иногда лучшее — враг хорошего.

Тем не менее путь синтеза, своеобразной полимеризации, часто встречается в эволюционирующих технических системах. Этот путь сыграл большую роль в создании мировой сети связи и транспортных сетей. При образовании комплексов резервированных устройств мы также сталкиваемся с явлением, подобным синтезогенезу.

Выскажем еще раз одну весьма важную мысль, связанную с синтезогенезом. В процессе такого объединения возникает особое явление, сходное (чисто внешне) с полимеризацией в химии. Элементы, вступая в объединение и не меняясь по своей структуре, как бы приобретают новые качественные возможности. И эти новые возможности зависят от механизма объединения. В гл. 4 мы уже столкнулись с этим явлением. Когда два автомата объединялись чисто механически (так, как объединяются автоматы в нашей модели эволюции на горе), число их состояний растет, как п2, если каждый из автоматов имел п состояний. Когда же они объединяются за счет случайного парного взаимодействия, то это дает им возможность функционировать как автоматам, обладающим памятью глубины 2n. В гл. 5 мы также столкнулись с явлением «полимеризации». Автомат всего с восемью состояниями, объединившись в шеренгу стрелков, как бы приобретал возможность работы с памятью всей совокупности автоматов, становился богаче по своим возможностям, не меняя своей структуры. Это явление кажется нам весьма любопытным.

Но, наряду с этим процессом в биологической и технической эволюции, идет и другой важный процесс, связанный с ростом неоднородности в организме с появлением специализированных подсистем.

§ 6.2. Сегрегациогенез и его последствия

Термин сегрегациогенез, как и термин синтезогенез, принадлежит К. М. Завадскому. Его смысл сводится к тому, что в процессе развития биологических

особей идет не только их усложнение путем объеди-нения более простых организмов в более сложные, но и процесс дифференциации функций, выполняемых отдельными подсистемами, и ведущий затем к изменению структуры этих подсистем для лучшего осуществления своих специфических функций. Прогресс требует отказа от универсальности, однотипности. Универсальный элемент делает все одинаково плохо. Если пища на торе в примере, рассмотренном в предыдущем параграфе, всегда расположена так, что для обхода клеток с пищей нужен ход шахматным конем, то имеет смысл, чтобы специфическая функция автомата позволяла бы ему прямо выполнять это движение в течение одного такта. Но если пища расположена иным образом, то подобное действие и не нужно.

Коллизия между универсальностью и специфичностью, между однородностью и разнородностью есть явление всеобщее, встречающееся всюду. Биоценозы и техноценозы также демонстрируют эту коллизию.

Количество рабочих пчел в улье может колебаться в довольно широких пределах, и они образуют подсистему, способную прожить самостоятельно, но самка пчелиного улья должна быть всегда одной единственной, и она быстро погибнет, если лишить ее рабочих пчел. Дифференциация здесь зашла уже весьма далеко, и отдельные подсистемы перестали уже быть способными к автономному функционированию вне той системы, в состав которой они входят.

Однако польза от появления подобных подсистем очевидна. Мы уже говорили в гл. 3 о пользе разнородности в коллективе автоматов. Ранги рефлексии, уровни пессимизма—оптимизма были первыми показателями различий, намечавшихся в подсистемах, которые позволяли неоднородному коллективу более успешно решать стоящую перед ним задачу, чем однородному коллективу. Правда, любой из автоматов такого коллектива мог бы функционировать и в одиночку. Но это просто означает, что специализация еще не дошла до того рубежа, за которым самостоятельное существование отдельной подсистемы становится невозможным. Однако специализация — непременный спутник прогресса, ибо только с ее помощью можно уменьшать затраты времени на достижение тех или иных целей, стоящих перед организмом.

В качестве иллюстрации сказанного рассмотрим, например, эволюцию в области ЭВМ. На первом этапе каждая вычислительная машина представляла собой некоторое единое и неделимое целое. Ее процессор, память, устройства обмена с внешним миром и управляющая система находились в столь жестких связях, что не могли не только функционировать, но и анализироваться отдельно друг от друга. Все процессы в ЭВМ протекали строго последовательно под контролем центрального устройства управления. Такую ЭВМ мы можем уподобить некоторой «клетке» в мире вычислительной техники.

Как же происходила эволюция ЭВМ в последующие годы? Один путь был связан с усложнением структуры ЭВМ, введением в ее состав новых подсистем, обеспечивающих для нее возможность выполнения новых функций*) (например, графопостроителей, которые сделали возможным выводить из ЭВМ не только текстовую, но и графическую информацию, или появление в составе ЭВМ датчиков случайных чисел, позволяющих использовать при решении задач методы, опирающиеся на случайные распределения). Эти подсистемы, увеличивая сложность «клетки», не меняли принципиально условий ее существования. Но это усложнение вело к усложнению управляющей системы, на плечи которой падало все больше задач. И наступил момент, когда операционные системы ЭВМ (а именно они, как правило, выполняют роль центрального блока управления всеми процессами, протекающими в ЭВМ) стали самым узким местом. Появились грозные признаки того, что усложнение структуры ЭВМ приведет в тупик. Все чаще и чаще возникали ситуации, которые специалисты по операционным системам называют дедлоками (ловушками). Это такие состояния, когда требования различных процессов, протекающих в машине, предъявляют к операционной системе разноречивые требования, и она не знает, что ей делать.

*) Эти подсистемы могут быть реализованы и в виде программ.

Стало ясно, что при централизованном управлении дальнейшее усложнение структуры ЭВМ и улучшение ее функционирования уже невозможно.

Переход к комплексированию ЭВМ был тем следующим шагом в эволюции, который надо было неизбежно сделать. Синтезогенез сработал. Вместо «одноклеточного» вычислительного устройства появились «многоклеточные». Эти образования могли иметь различную структуру. На рис. 6.4 показаны некоторые типы структур комплексов ЭВМ. На рис. 6.4, а приведена структура с центральной ЭВМ 1, которая выполняет роль центрального управляющего устройства для ЭВМ 2, 3, 4, на рис. 6.4,6 мы видим смешанную структуру, а на рис. 6.4, в — децентрализованную, в которой все ЭВМ равноправны. Важно отметить, что даже в централизованной структуре возникает некоторая децентрализация. Центральная ЭВМ не все время ведет процессы в подчиненных ей машинах. Она лишь инициирует в них начало некоторых процессов, синхронизует протекающие процессы между собой и производит обмен информацией между процессами. А в остальном машины, входящие в систему, действуют самостоятельно. И это направление эволюции подтверждает правильность отказа от пути йогов, о котором говорилось в гл. 5.

Интересно отметить, что децентрализованная структура, показанная на рис. 6.4,в, демонстрирует возможность введения в структуру «организма» неспецифического централизованного управления. Показанный на этом рисунке пунктиром блок синхронизации К. может по специальной кольцевой шине передавать сигнал одновременно всем ЭВМ, образующим систему. Это может быть, например, сигнал прерывания всех вычислений для приема новой внешней информации, или для повторения вычислений, или для тестовой проверки. Но такой центральный управляющий блок может и отсутствовать. Тогда синхронизация работы децентрализованной системы будет осуществляться по типу кольца стрелков, о чем было рассказано в гл. 5.

Кроме этого основного пути эволюции ЭВМ приблизительно в те же годы развивался и еще один путь — создание ЭВМ на основе однородных клеточных структур, о которых мы также говорили в гл. 5. Этот путь был связан с идеей синтезогенеза в чистом виде. Предполагалось, что однородность и универсальность отдельных подсистем (автоматов, находящихся в клетках однородной структуры с потенциально однотипными связями между ними) позволят улучшить характеристики ЭВМ. Однако этого не произошло. Ибо сегрегациогенез оказался куда более эффективным в отношении этих характеристик.

И следующий шаг в эволюции ЭВМ — комплексирование не однотипных, а узкоспециализированных подсистем, причем для каждой из них четко определены те функции, которые она реализует. Сначала это привело к структурам того же типа, что и показанные на рис. 6.4. Отличие состояло лишь в том, что ЭВМ, входящие в систему, стали специализированными. Например, они могли быть специально созданы для обработки символьной информации, работы с матрицами, предварительной обработки и преобразования сигналов, поступающих от объекта управления, и т. п. Но при этом, как в автоматных моделях с рефлексией или уровнями пессимизма — оптимизма, все такие ЭВМ могли действовать и вне системы, автономно.

При дальнейшем сегрегациогенезе это свойство исчезло. Дифференциация коснулась даже той исходной ячейки — ЭВМ, которую мы уподобили клетке. Ее составляющие как бы обрели самостоятельность, и возникла структура, показанная на рис. 6.5 [image]. Процессоры, блоки памяти, блоки обмена и управляющие блоки как бы плавают в некоторой вычислительной среде. Их объединение в структуру происходит динамически, управляющие блоки, получив задание, ищут исполнителей, свободных от работы, и организуют процесс. На рис. 6.5 показан такой момент, когда управляющий блок У1 объединил для решения задачи два процессора П1 и П4, один блок памяти 32 и три блока обмена O1, О3 и О5. Одновременно управляющий блок У2 организовал другой процесс, объединив для этого в структуру процессор Пз, запоминающее устройство 31 и обменное устройство O1. Задачи управляющие блоки получают из внешней среды. Из той же среды обменные устройства получают исходную информацию. Результаты решения также возвращаются во внешнюю среду. После окончания решения задачи структуры «рассыпаются».

В этой структуре сегрегациогенез зашел настолько далеко, что отдельные подсистемы автономно не могут существовать. Лишь объединившись в структуру, где обязательно наличие одного управляющего блока и хотя бы одного обменного устройства, связанного с процессорами или запоминающими устройствами, наш «организм» сможет функционировать. Способность образовывать структуры под задачи демонстрирует его адаптационные возможности, а специализация отдельных подсистем позволяет реализовать связанные с ними функции параллельно и максимально быстро.

Анализируя прогресс в эволюции, К. М. Завадский предложил следующую наглядную схему, показанную на рис. 6.6 [image]. Есть как бы три возможности в эволюционном развитии биологических организмов. При первом из них арогенезе идет расширение адаптационных возможностей организма. Он как бы расширяет набор сред, в которых он будет выживать и давать потомство. Этот процесс может идти либо за счет синтезогенеза (как в нашей модели эволюции на тороидальной поверхности), либо за счет сегрега-циогенеза (как, например, в вычислительной среде, дающей возможность решать любые задачи, для которых у системы хватает ресурсов). Заметим, что при наличии тех же ресурсов в рамках единой системы типа, показанной на рис. 6.4, а, не удалось бы, например, организовать одновременное протекание двух процессов, показанных на рис. 6.5.

Если арогенез есть расширение адаптационных возможностей системы, то аллогенез есть смена некоторых функций, реализуемых организмом, на новые, экологически равноценные. Другими словами, при аллогенезе происходит как бы смена одной экологической ниши на другую, более выгодную для выживаемости организма. Такое явление можно наблюдать не только в биологии, но и в технике. В эпоху клавишных вычислителей, предшествующую появлению ЭВМ, они использовались в основном в научных расчетных бюро. ЭВМ вытеснили их оттуда, но они нашли свою экологическую нишу в бюро технико-экономических расчетов, которым невыгодно пользоваться услугами ЭВМ. Самолеты в свое время вытеснили дирижабли, но похоже, что горячие поклонники дирижаблей нашли для них новую подходящую нишу в современном техноценозе, и в ближайшее время мы, возможно, вновь увидим в небе их неповторимые силуэты.

Наконец, телогенез — это как бы обратная сторона арогенеза. При телогенезе происходит очень глубокая адаптация к заданному состоянию экологической среды, которая достигается глубокой специализацией организма. Примеры телогенеза в технических системах очевидны. Практически все узкоспециализированные системы могут рассматриваться с этой точки зрения. Первобытное рубило, пригодное для всех случаев жизни, постепенно породило огромное количество рубящих инструментов, многие из которых пригодны для выполнения очень конкретных работ, но не могут использоваться для чего-либо иного (например, колун, если только не использовать его обуха для забивания чего-либо).

Арогенез, аллогенез и телогенез — это не альтернативные пути эволюции. Они действуют согласованно и одновременно. Доминирование любого из них может оказаться в развитии некоторого организма временным и преходящим. Но все эти пути направлены на единственную цель — улучшение адаптации .организма к данной среде и, как следствие этого, .увеличение его выживаемости в ней. И сказанное .вполне можно перенести на технические системы.

§ 6.3. Эволюция в городе Едгин

Странное название города есть обратное прочтение слова «нигде». Город этот придумал английский писатель С. Батлер во второй половине XIX века. В английском написании название этого города, совпадающее с названием романа, выглядит как «Erehwon».

Роман С. Батлера утопический. Герой романа, молодой человек по имени Хиггс, путешествуя в горах, попадает в необычный город. Его жители живут по законам, противоречащим нормам морали и юриспруденции, которые господствовали в Европе того времени. Например, болезни и несчастья, которые случаются с жителями Едгина, приравниваются к преступлениям. И за это судят и наказывают. Рождение ребенка также не является радостным событием, и дети, когда они вырастают, вовсе не благодарны своим родителям за то, что те даровали им жизнь. Но зато все жители города Едгин красивы, веселы и жизнерадостны. Хиггса они принимают с распростертыми объятиями, но вскоре сажают в тюрьму,

Причина столь странного поступка — наличие у Хиггса часов. Почему часы испугали местных жителей, Хиггс узнает существенно позже, из рассказа дочери начальника тюрьмы Ирем. И эта причина имеет непосредственное отношение к теме нашей книги.

Но прежде чем говорить об этом, необходимо несколько слов сказать о самом Самуэле Батлере. В его богатой событиями жизни, наполненной разнообразными интересами и пристрастиями, было одно многолетнее увлечение. И это увлечение — попытка понять суть эволюционного процесса. Чарльз Дарвин и его фундаментальная теория происхождения видов сыграли в этом огромную роль. Сначала С. Батлер принял его теорию целиком, но позже наступил период, когда его стали одолевать сомнения. Наиболее сомнительным положением дарвиновской теории для Батлера было то, что течение такого процесса, как биологическая эволюция, возможно только за счет случайного взаимодействия и случайных мутаций. Он был глубоко убежден, что процесс этот должен быть целенаправленным*). Но кем он направляется? С. Батлер был рационалистом, он критически относился к религии, неоднократно высмеивал в своих произведениях церковные порядки и религиозные догмы. Но в своих книгах, посвященных модели эволюции («Жизнь и привычка», 1877, «Старая и новая эволюция», 1879, «Бессознательная память», 1880 и «Случайность или хитрость как главный источник органических изменений», 1886), С. Батлер выступал против идеи Дарвина о вероятностном характере эволюции. И одним из его аргументов была принятая им концепция технической эволюции. Пожалуй, впервые эта концепция появилась в статье С. Батлера «Дарвин среди машин», опубликованной в 1863 г. Уже в ней он указывает на то, что человек выступает в технической эволюции как звено, привносящее в эволюционный процесс цель и рациональность. В романе «Едгин» эта идея раскрывается во всей своей глубине.

*) Идею о направленности эволюции, ее рациональности рбосновывал и академик Л. С, Берг, создавший теорию номогенеза.

Герой романа постепенно узнает, что раньше в Едгине существовал богатейший техноценоз, созданный учеными и техниками для обслуживания жителей города, облегчения их труда и дальнейшего развития науки и техники. Но, возникнув, техноценоз стал подобен раковой опухоли. Из «Трактата машин», попавшего к нему в руки, Хиггс узнает, что развитие техноценоза шло так быстро, что люди постепенно из хозяев положения стали превращаться в рабов созданной ими машинной цивилизации. С точки зрения машин люди превращаются в насекомых, опыляющих и оплодотворяющих технические устройства, живущие своей независимой жизнью. И, верный своей задаче критики современного ему общества, С. Батлер восклицает: «Сколько людей и теперь живут, как рабы у машин? Сколько людей проводят всю жизнь от колыбели до могилы, служа машинам и днем и ночью?»

Так происходит и в Едгине. Все развивающееся множество машин прекрасно приспосабливается к функционированию в создаваемой специально для них среде. Они поглощают массу энергии, которую для них необходимо производить, требуют постоянного ухода за собой. Все большие массы жителей города должны отдавать свое время машинам, обслуживанию их, конструированию новых машин, подготовке для них рабочих мест. Чем бы это кончилось для города, возникшего в воображении С. Батлера, неизвестно. Писатель своей волей обрывает лавинообразную техническую эволюцию в Едгине. Находится ученый, который строго доказывает, опираясь на теорию Дарвина об естественном отборе и идею целенаправленности эволюции Батлера, что жители города весьма скоро будут полностью покорены машинами и в результате сегрегациогенеза потеряют возможность существовать самостоятельно. Результатом этого выступления было уничтожение всей техники в Едгине и запрещение создавать в будущем какие-либо механизмы. И лишь в музее хранятся остатки некогда уничтоженных порождений эры техногенеза, напоминая жителям города о минувшей опасности.

Для нас интересно отметить те особенности технических систем, возникших в процессе эволюции по воле человека, которые отмечает С. Батлер. Во-первых, это достижение цели любыми средствами. Логика действий технического устройства отлична от логики действия человека. Во-вторых, развитые технические системы требуют от человека, участвующего в управлении ими, узкой специализации, при которой коллектив управленцев связан между собой только информацией, выдаваемой ему технической системой. Первое положение мы уже обсуждали в гл. 5, когда говорили о трудностях, связанных с созданием общих законов управления, которые могли бы компенсировать логику «машинных рассуждении». Что же касается второго положения, то тут писатель был бы совершенно прав, если бы не возникала возможность заменить человека-управленца соответствующим техническим устройством. А именно эта идея и была обсуждена в гл. 3 и 4 (а отчасти и в гл. 5) книги. Образ рабочего на конвейере, столь ярко сыгранный в бессмертном фильме Чарли Чаплина, показывает, что опасения С. Батлера были небезосновательны.

В чем-то писатель оказался прав. И когда в книге Р. К. Баландина, изданной в 1978 г., мы читаем: «Но даже техника — наше создание, над которым мы безраздельно господствуем,— одновременно имеет над нами значительную власть. Мы сейчас столько же зависим от нее, сколько от остальной природы. Мы употребляем в пищу техногенные (искусственно выведенные и взращенные) виды животных и сорта растений, причем после обязательной кулинарной, техногенной обработки. Мы существуем среди техники и за счет техники. Мы, безусловно, вынуждены обслуживать технику, заботиться о ней, в какой-то степени к ней приспосабливаться, вынуждены учитывать ее возможности и запросы (нередко в ущерб собственным, личным интересам), максимально содействовать ее прогрессу и постоянной работе в оптимальном режиме...»*, и тень города Едгин витает перед нами.

*) Баландин Р. К. Геологическая деятельность человечества. Техногенез. —Минск: Вышэйшая шкода, 1978, с. 256.

И тем не менее мы, конечно, не можем пойти по пути жителей города, придуманного английским писателем. Технический прогресс нельзя повернуть вспять. Никто из нас не откажется от тех завоеваний, которые он дал человечеству. Но необходимо очень четко и точно понимать, что в условиях лавинного нарастания элементов в различных техноценозах, появления глобальных техноценозов, охватывающих практически всю деятельность человека, проблемы управления ими становятся самыми главными. И идея децентрализации управления, создания кооперированных и коалиционных систем управления — основное направление в управлении техническими сверхсистемами.

§ 6.4. Вместо заключения. Эволюция продолжается

Наша книга подошла к концу. Мы постарались, насколько это возможно в популярной книге, предназначенной для широкого круга читателей, рассказать о путях построения децентрализованных систем управления различного типа. Нам кажется, что аналогии в этой области, которые нетрудно заметить. между биологическими, организационными и техническими системами, не случайны. Похожее управление возникает из-за сходных условий, складывающихся на объекте управления. И эволюционный путь развития больших технических систем —.одно из ярких свидетельств этого. Поэтому в заключение книги мы приведем еще один пример эволюционного развития технической системы, который идет сейчас на наших глазах.

ЭВМ возникли менее 40 лет назад. В одном из предшествующих параграфов данной главы мы уже говорили об их эволюции. Сейчас в этом процессе реализован еще один шаг, имеющий огромное значение как для самих ЭВМ, так и для человечества. Этот шаг — появление всемирной сети обработки данных.

Сначала ЭВМ объединялись друг с другом непосредственно, кабелем. Но потом возникла идея вое-пользоваться для этого каналами связи, которые существуют во всемирной сети связи. Такое решение дало качественный скачок. Если раньше человек, который собирался использовать вычислительную машину для решения интересующей его задачи, знал, какая именно ЭВМ ее решает, непосредственно взаимодействовал с ней, то теперь он потерял эту информацию. Задача, введенная в сеть, может решаться на любой ЭВМ, входящей в нее. И зачастую эта ЭВМ находится территориально весьма далеко от пользователя. Пользователь становится как бы обладателем всего ресурса сети, что делает его возможности почти безграничными. Его задача может решаться одной машиной в сети или одновременно несколькими машинами. Возможен и такой режим, при котором задача пользователя решается последовательно по частям на различных ЭВМ сети. А учитывая неоднородность ЭВМ, входящих в сеть, и неоднородность отдельных частей решаемых задач, такая организация решения может привести к существенному повышению эффективности решения.

Первая территориальная сеть обработки данных стала функционировать в 1969 г. в США. Это сеть ARPA, ставшая прообразом многих последующих сетей. В ней имеется подсеть, состоящая из коммутационных процессоров, которая обеспечивает обмен между всеми ЭВМ, входящими в сеть. В отличие от телефонной сети, в которой два абонента связываются друг с другом через коммутацию каналов, в сети обработки данных заявки на связь поступают от ЭВМ в коммутационные процессоры. В заявках указан адресат и абонент. Иногда адресат не указывается, а указываются лишь требования к нему (макисимально допустимое время решения и необходимый объем оперативной памяти для решения задачи). Коммутационный процессор при наличии адресата пересылает заявку либо непосредственно ему (если имеется прямой канал связи между этим коммутационным процессором и адресатом и последний способен принять заказ), либо в другой коммутационный процессор, чье положение на сети обеспечит передачу заявки на решение нужному адресату. Ели же адресат не указан, то коммутационный процессор сам определяет ту ЭВМ, которой можно передать поступившее задание. Таким образом, в сети обработки данных вместо коммутации каналов возникает коммутация сообщений, циркулирующих в сети. Сами сообщения в каждом коммутационном процессоре, в который они попадают, получают как бы транзитную визу. Эти визы помогают потом коммутационным процессорам и сообщениям «вспоминать» свой путь по сети и не терять абонента, который ввел сообщение в сеть.

Для облегчения функционирования коммутационных процессоров в сети имеются еще терминальные коммутационные процессоры, задача которых сводится к тому, чтобы служить своеобразным буфером между ЭВМ и подсетью коммутационных процессоров. Каждый терминальный коммутационный процессор обеспечивает выход к другим ЭВМ — не одной, а целой группе ЭВМ, каждая из которых через свои оконечные устройства — терминалы обслуживает десятки и сотни пользователей. На рис. 6.7 [image] показан фрагмент такой сети. На нем зачерненные кружки — оконечные терминалы, большие круги—отдельные ЭВМ. Терминальные коммутационные процессоры ТК. показаны прямоугольниками, а коммутационные процессоры К—параллелограммами.

Сеть ARPA развивалась очень быстро. В короткий срок она охватила всю территорию США, а вскоре через английский и норвежский узлы связи дотянулась до Европы. В последующее десятилетие стали появляться и другие сети. В США стала функционировать сеть TYMNET, которая предоставляет своим пользователям услуги не только для обработки данных, но и позволяет им черпать информацию из банков данных, где хранится огромный объем информации по самым различным отраслям знаний. Создатели этой сети предполагают, что со временем она сможет оказывать такие же услуги, как и библиотеки. Требование читателя будет поступать в сеть, и читателю на экран дисплея будет высвечиваться текст книги. При желании пользователь может заказать этот текст для хранения дома. Тогда он будет выдан ему через печатающее устройство.

Вообще, появление сети обработки данных породило и продолжает порождать новые функциональные возможности использования ЭВМ. Так, одно время в сети ARPA «печаталась газета» по проблемам искусственного интеллекта и робототехники. Корреспонденты вводили тексты статей в память своих ЭВМ. Далее эти статьи собирались на одной из ЭВМ, которая формировала «газету». Каждый читатель мог вызвать себе «газету» на экран дисплея, прочитать ее и при желании отпечатать всю целиком или некоторые особенно интересные для него статьи.

Другое неожиданное применение сеть получила, когда в США происходила одна из конференций по проблемам искусственного интеллекта. В ней участвовали ученые не только США, но и ряда европейских стран. Необычным было то, что европейские участники при этом находились у себя дома и никуда не выезжали. Да и американские специалисты не покидали своего места жительства. Все доклады, присланные на конференцию, были введены в сеть, каждый участник мог ознакомиться с наиболее интересными для себя сообщениями и выступить в дискуссии или задать докладчику вопросы. Выступления и вопросы просто вводились с терминальных устройств в сеть. Докладчики получали их и вводили в сеть свои ответы на вопросы. Самое приятное заключалось в том, что любой участник конференции мог отдыхать в любое время, не рискуя что-либо упустить. Более того, из-за различий во времени между США и Европой часть участников конференции активно работала, а другая спокойно спала, чтобы утром включиться в работу с новыми силами.

Но мы несколько отвлеклись от основной канвы. Вернемся к анализу процесса эволюции сети обработки данных. Кроме нескольких сетей в США появились общегосударственные территориальные сети в ряде европейских стран. В 1974 г. вступила в строй первая очередь сети CYCLADES во Франции. В 1971 г. был подписан протокол между восемью странами Европы о создании европейской сети обработки данных. В 1976 г. эта сеть начала функционировать в составе пяти узлов коммутации (Лондон, Цюрих, Париж, Милан, Испра). Через Лондон эта сеть соединилась с американскими сетями, возникли узлы в Вене и многих других городах. Некоторые страны Восточной Европы также установили каналы связи с европейской сетью. А сейчас имеется канал, соединивший Москву с несколькими сетями обработки данных в Европе. Ведутся активные работы по созданию территориальной сети СССР. Так происходит эволюция этой новой технической системы, которая сулит человечеству невиданные ранее возможности использования ЭВМ.

И как во всякой системе, возникающей эволюционным путем, в системе обработки данных всемирного масштаба нет и не может быть какого-либо центрального пункта оперативного управления. Все территориальные национальные и межнациональные сети функционируют автономно, независимо от остальных. Согласованное управление достигается децентрализованным способом, подобным тому, который уже много лет используется в телефонных сетях. Плата за услуги по использованию вычислительных мощностей и каналов связи, а также банков информации скореллирована с платами за время ожидания обслуживания таким образом, что пропускная способность сети становится весьма высокой и в ряде случаев приближается к максимальной. Вся служебная информация, которая циркулирует между центрами коммутации, оформляется специальным образом в виде протоколов обмена стандартного типа, что облегчает подсоединение к сети новых участков и сетей.

Пока еще синтезогенез в мировой сети обработки данных явно доминирует. Но начинают появляться признаки того, что и сегрегациогенез заявляет о своих правах. Некоторые участники сети начинают специализироваться на обработке задач определенного типа и создавать технические средства, которые позволяли им решать такие задачи наиболее эффективно (а значит, и увеличивать свою прибыль). Эта тенденция, по-видимому, будет развиваться и может со временем привести к тому, что отдельные участки сети (прежде всего на территории одной страны) будут терять свою автономность и способность к самостоятельному функционированию.

А впереди намечается слияние сети обработки данных с всемирной телевизионной сетью, что даст новые еще даже не предугадываемые возможности. Люди сами творят техническую эволюцию, но в отличие от природы они делают это целенаправленно. И только от них зависит будущее техногенной сферы.

И все слаженнее звучит оркестр систем, порожденных человеком. Звучит, хотя и не управляется одним дирижером. Ибо нет такого дирижера, который мог бы управлять столь сложным оркестром. И нам кажется, что прав был поэт Константин Фофанов, который еще в конце прошлого века писал:

«Сильней и глубже век от века
Земли и мысли торжество.

Все меньше веры в Божество.

И больше веры в Человека».

ЛИТЕРАТУРА И КОММЕНТАРИЙ

Для тех читателей, которые хотели бы более подробно ознакомиться с моделями коллективного поведения и децентрализованного управления, можно рекомендовать следующие четыре книги.

1. Цетлин М. Л. Исследования по теории автоматов и моделированию биологических систем.—М.: Наука, 1959, 316 с.

2. Варшавский В. И. Коллективное поведение автоматов.—М.: Наука, 1973. 407 с.

3. Срагович В. Г. Теория адаптивных систем.— M.I Наука, 1976, 319 с.

4. Цыпкин Я. 3. Адаптация и обучение в автоматических системах.—М.: Наука, 1968, 399 с.

Все они специально посвящены проблемам, обсуждавшимся нами, хотя авторы двух последних книг и пользуются зачастую другой терминологией для описания моделей и методов, составляющих суть теории коллективного поведения. В этих книгах приведена обширная библиография работ в данной области, которая может послужить отправным пунктом для дальнейших поисков.

Кроме этих основных источников мы бы хотели указать еще на несколько книг, посвященных смежным областям с той, которая исследовалась на предшествующих страницах.

5. Поспелов Д. А. Игры и автоматы.—М.: Л.: Энергия, 1966, 134 с.

6. Поспелов Д. А. Вероятностные автоматы. — М.: Энергия, 1970, 87 с.

7. Буш Р., Мостеллер Ф. Стохастические модели обучаемости. — М.: Физматгиз, 1962, 483 с.

8. фон Нейман Дж. Теория самовоспроизводящихся автоматов.—М.: Мир, 1971, 382 с.

В этих книгах читатели найдут многие модели, тесно связанные с коллективным поведением и решением задач на однородных структурах.

При написании гл. 6 мы использовали ряд работ биологов, специалистов в области теории эволюции. Укажем эти источники.

9.Брайнес С. Н., Свечинский В. Б. О соотношении принципов централизации и децентрализации в биологических системах управления.— В сб.: «Бионика», Научный Совет по комплексной проблеме «Кибернетика».—М.: 1973, т. 3, с. 17—19.

10. Завадский К. М. К проблеме прогресса живых и технических систем.—В сб.: «Теоретические вопросы прогрессивного развития живой природы и техники».—Л.: Наука, 1970, с. 3—28.

11.Рашевский Н. Организмические множества: очерк общей теории биологических и социальных организмов. — В сб. «Исследования по общей теории систем».—М.: Прогресс, 1969, с. 442—461.

Трактат о машинной эволюции С. Батлера, о котором мы говорили также в гл. 6, включен в состав его утопического романа «Едгин». Этот роман на русский язык никогда не переводился. Поэтому мы приводим его оригинальные выходные данные, а также указываем современное исследование, специально посвященное сравнительному анализу концепций Батлера и Дарвина по вопросам эволюции.

12. Butler S. Erewhon. — London: Penguin Books, 1970.— 170 p.

13. Wile у В. Darwin Сh., Butler S. Two versions of evolution.—London: Chatto a. Windus, I960.—130 p.

И, наконец, укажем на ряд работ, из которых мы заимствовали те или иные модели и результаты и которые не использовались еще в основных книгах [1—4].

14. Алексеев М. А., Залкинд М. С., Кушнарев В. М. Решение человеком задачи выбора при вероятностном подкреплении двигательных реакций.— В сб.: «Биологические аспекты кибернетики».—М.: Изд-во АН СССР, 1962, с. 198—209. (Результаты использованы в § 2.4 при описании опытов с людьми, производящими альтернативный выбор.)

15. Вайсборд Э. М., Розенштейн Г. Ш. О времени «жизни» стохастических автоматов.—Изв. АН СССР:

Сер. Техн. киберн. 1965, № 4, с. 52—59. (В этой работе приведена точная модель максимизации «жизни» автомата, которая на уровне внешней интерпретации описана нами в § 2.6.)

16. Филоник С. А., Солнцев С. В. Реализация арифметических функций на однородных структурах. — Изв. АН СССР:

Сер. Техн. киберн. 1974, № 4, с. 114—126. (Наш пример умножения в столбик, обсуждавшийся в § 5.4, заимствован из этой работы. Кроме того, в данной работе приведен метод умножения, дающий результат существенно быстрее, а также методы деления на однородных структурах.)

17. Варшавский В. И., Мараховский В. Б. и др. Однородные структуры. Анализ. Синтез. Поведение.—М.: Энергия, 1973, 140 с. (В этой книге читатель найдет многочисленные примеры использования однородных структур для решения самых разнообразных задач.)

Модели голосования, рассмотренные в § 4.6, были исследованы С. Б. Котляр, чьими результатами мы и воспользовались.

ОГЛАВЛЕНИЕ

Вместо предисловия ................ 3

Глава 1. Как возникает децентрализованное управление? 5

1.1. Искусственный мир .......... 5

1.2. Системы, которые в полном объеме никто не создавал 9

1.3. Несколько поучительных примеров . ...... 13

1.4. Обсуждение примеров ............ 17

1.5. Зачем нужна децентрализация? ......... 21

Глава 2. Просто ли существовать в сложном мире? ... 26

2.1. Парадоксы целесообразности . ........ 26

2.2. «Маленькая зверушка» . . . ........ 29

2.3. Линейная тактика—залог успеха ....... 33

2.4. «Личные» качества автоматов ......... 36

2.5. Как жить в динамическом мире? ........ 40

2.6. «Доживем до понедельника» . ........ 51

2.7. От индивида к коллективу . ......... 55

Глава 3. Согласованность без договоренности . .... 58

3.1. История начиналась в Арбатове ........ 58

3.2. Когда все одинаковые ............ 69

3.3. Распределение ограниченного ресурса . ..... 80

3.4. Что дает случайное взаимодействие ....... 85

3.5. «Он думает, что я думаю...» .......... 94

3.6. Оптимисты и пессимисты в мире автоматов . . . 100

3.7. Еще три простые модели . . ........ 103

Глава 4. Когда «все по справедливости» . ...... 115

4.1. Прав ли был Остап Бендер? . ........ 115

4.2. Дилемма парикмахера и приоритеты . ..... 121

4.3. Как мастер распределяет наряды . ...... 128

4.4. Проблема нескольких арен . ......... 132

4.5. Задача о жилищной комиссии и родственные ей задачи ................... 137

4.6. «Упрямые» автоматы и голосование . ..... 144

Глава 5. Коллектив во времени ........ 152

5.1. Что такое синхронизация? . . . ....... 152

5.2. Управление стрелками . . . . ....... 155

5.3. Синхронизация и асинхронность . ....... 160

5.4. Гимн однородным структурам . . ...... 164

5.5. Почему йога — не наш путь? . ........ 173

Глава 6. Диалектика простого и сложного . ..... 178

6.1. Синтезогенез и интеграция усилий ....... 178

6.2. Сегрегациогепез и его последствия . . .... 184

6.3. Эволюция в городе Едгин ........ 191

6.4. Вместо заключения. Эволюция продолжается . . . 195

Литература и комментарий ....... ..... 201

Предметный указатель .............. 203

<<:o: