Руководство по установке Debian GNU/Linux
След.

Руководство по установке Debian GNU/Linux

Copyright © 2004 – 2010 Команда разработчиков программы установки Debian

Это руководство является свободным программным обеспечением; вы можете его распространять и/или модифицировать на условиях Стандартной Общественной Лицензии GNU. С текстом соглашения можно ознакомиться здесь: Приложение F, GNU General Public License.

Аннотация

Данный документ содержит инструкции по установке системы Debian GNU/Linux 6.0 («squeeze») для архитектуры 32-bit PC («i386»). Кроме того, в нём указаны источники более подробной информации и описаны методы наиболее эффективного применения системы Debian.

Замечание

Несмотря на то, что данное руководство по установке на i386 полностью соответствует текущей программе установки, планируется внести некоторые изменения и провести реорганизацию документа после официального выпуска squeeze. Свежую версию этого руководства можно найти в Интернете на домашней странице debian-installer. Там же находятся дополнительные переводы руководства.

Содержание

Установка Debian GNU/Linux 6.0 на i386
1. Добро пожаловать в Debian
1.1. Что такое Debian?
1.2. Что такое GNU/Linux?
1.3. Что такое Debian GNU/Linux?
1.4. Что такое Debian GNU/kFreeBSD?
1.5. Получение Debian
1.6. Получение последней версии этого документа
1.7. Структура этого документа
1.8. Об авторских правах и лицензиях на программы
2. Системные требования
2.1. Поддерживаемое оборудование
2.1.1. Поддерживаемые архитектуры
2.1.2. Поддерживаемые процессоры, материнские платы и видеокарты
2.1.3. Ноутбуки
2.1.4. Несколько процессоров
2.1.5. Поддержка видеокарт
2.1.6. Аппаратура для подключения к сети
2.1.7. Дисплеи Брайля
2.1.8. Устройства речевого синтеза
2.1.9. Периферия и другое оборудование
2.2. Устройства, которым требуются микропрограммы
2.3. Покупка аппаратного обеспечения специально для GNU/Linux
2.3.1. Избегайте собственнического или закрытого аппаратного обеспечения
2.3.2. Аппаратное обеспечение, работающее только в Windows
2.4. Установочные носители
2.4.1. CD-ROM/DVD-ROM
2.4.2. Жёсткий диск
2.4.3. Карта памяти USB
2.4.4. Сеть
2.4.5. Система Un*x или GNU
2.4.6. Поддерживаемые системы хранения
2.5. Требования к памяти и дисковому пространству
3. Перед установкой Debian GNU/Linux
3.1. Обзор процесса установки
3.2. Сохраните ваши данные в надёжном месте!
3.3. Информация, которая понадобится
3.3.1. Документация
3.3.2. Поиск источников технической информации
3.3.3. Совместимость аппаратного обеспечения
3.3.4. Настройки сети
3.4. Минимальные требования к аппаратному обеспечению
3.5. Переразметка для мульти-загрузочных систем
3.5.1. Разметка дисков из DOS или Windows
3.6. Настройка аппаратного обеспечения и операционной системы перед установкой
3.6.1. Вызов меню настройки BIOS
3.6.2. Выбор загрузочного устройства
3.6.3. Другие настройки BIOS
3.6.4. Аппаратные проблемы, которых нужно остерегаться
4. Получение носителя с дистрибутивом
4.1. Официальный набор компакт-дисков Debian GNU/Linux
4.2. Скачивание файлов с серверов-зеркал Debian
4.2.1. Где искать установочные образы
4.3. Подготовка файлов для загрузки с карты памяти USB
4.3.1. Preparing a USB stick using a hybrid CD or DVD image
4.3.2. Manually copying files to the USB stick
4.3.3. Manually copying files to the USB stick — the flexible way
4.4. Подготовка файлов для загрузки с жёсткого диска
4.4.1. Загрузка программы установки с жёсткого диска с помощью LILO или GRUB
4.4.2. Загрузка программы установки с жёсткого диска с помощью loadlin
4.5. Подготовка файлов для загрузки по TFTP
4.5.1. Настройка DHCP сервера
4.5.2. Настройка BOOTP сервера
4.5.3. Включение TFTP сервера
4.5.4. Копирование TFTP образов в каталог TFTP сервера
4.6. Автоматическая установка
4.6.1. Автоматическая установка с помощью программы установки Debian
5. Загрузка системы установки
5.1. Запуск программы установки на 32-bit PC
5.1.1. Загрузка с CD-ROM
5.1.2. Загрузка из Windows
5.1.3. Загрузка из DOS
5.1.4. Загрузка из Linux с помощью LILO или GRUB
5.1.5. Загрузка с карты памяти USB
5.1.6. Загрузка по TFTP
5.1.7. Экран запуска
5.2. Лёгкость управления
5.2.1. USB-дисплеи Брайля
5.2.2. Дисплеи Брайля, подключаемые к последовательному порту
5.2.3. Устройства речевого синтеза
5.2.4. Встраиваемые устройства
5.2.5. Тема с высокой контрастностью
5.3. Параметры загрузки
5.3.1. Параметры программы установки Debian
5.3.2. Использование параметров загрузки для ответов на вопросы
5.3.3. Передача параметров модулям ядра
5.3.4. Внесение модулей ядра в чёрный список
5.4. Диагностика проблем процесса установки
5.4.1. Надёжность CD-ROM
5.4.2. Настройка загрузки
5.4.3. Распространённые проблемы установки на 32-bit PC
5.4.4. Интерпретация загрузочных сообщений ядра
5.4.5. Сообщение о проблемах при установке
5.4.6. Отправка отчётов об ошибках установки
6. Использование программы установки Debian
6.1. Как работает программа установки
6.2. Описание компонент
6.3. Применение отдельных компонент
6.3.1. Настройка программы установки Debian и оборудования
6.3.2. Добавление пользователей и паролей
6.3.3. Разметка разделов и выбор точек монтирования
6.3.4. Установка базовой системы
6.3.5. Установка дополнительного программного обеспечения
6.3.6. Установка и настройка системного загрузчика
6.3.7. Завершение установки
6.3.8. Troubleshooting
6.3.9. Установка по сети
6.4. Загрузка отсутствующих микропрограмм
6.4.1. Подготовка носителя
6.4.2. Микропрограмма в установленной системе
7. Загрузка только что установленной системы Debian
7.1. Момент истины
7.2. Монтирование шифрованных томов
7.2.1. dm-crypt
7.2.2. loop-AES
7.2.3. Устранение неполадок
7.3. Вход в систему
8. Следующие шаги и что делать дальше
8.1. Выключение системы
8.2. Если вы новичок в Unix
8.3. Самостоятельное ориентирование в Debian
8.3.1. Система управления пакетами Debian
8.3.2. Управление версиями приложений
8.3.3. Управление заданиями cron
8.4. Что почитать
8.5. Настройка почты
8.5.1. Почтовая конфигурация по умолчанию
8.5.2. Отправка почты из системы
8.5.3. Настройка агента пересылки почты Exim4
8.6. Сборка нового ядра
8.6.1. Управление образами ядра
8.7. Восстановление неработающей системы
A. Краткая инструкция по установке
A.1. Предварительные сведения
A.2. Загрузка программы установки
A.2.1. Загрузка с CDROM
A.2.2. Загрузка с карты памяти USB
A.2.3. Загрузка по сети
A.2.4. Загрузка с жёсткого диска
A.3. Установка
A.4. Отправьте нам отчёт об установке
A.5. И напоследок…
B. Автоматическая установка с помощью списка ответов
B.1. Введение
B.1.1. Методы использования файла ответов
B.1.2. Ограничения
B.2. Использование автоматической установки
B.2.1. Загрузка файла ответов
B.2.2. Использование параметров загрузки для автоматизации
B.2.3. Автоматический режим
B.2.4. Полезные в автоматизации псевдонимы
B.2.5. Использование сервера DHCP для указания файлов автоматической конфигурации
B.3. Создание файла ответов
B.4. Содержимое файла ответов (для squeeze)
B.4.1. Локализация
B.4.2. Настройка сети
B.4.3. Сетевая консоль
B.4.4. Настройка сервера-зеркала
B.4.5. Настройка учётной записи
B.4.6. Настройка времени и часового пояса
B.4.7. Разметка дисков
B.4.8. Установка базовой системы
B.4.9. Настройка Apt
B.4.10. Выбор пакетов
B.4.11. Установка загрузчика
B.4.12. Завершение установки
B.4.13. Автоматизация других пакетов
B.5. Дополнительные параметры
B.5.1. Запуск пользовательских команд во время установки
B.5.2. Использование автоматической установки для изменения значений по умолчанию
B.5.3. Последовательная загрузка нескольких файлов ответов
C. Разметка дисков в Debian
C.1. Дисковые разделы Debian и их размеры
C.2. Структура каталогов
C.3. Рекомендуемые схемы разметки
C.4. Имена устройств в Linux
C.5. Программы разметки в Debian
C.5.1. Разметка для 32-bit PC
D. Разное
D.1. Устройства Linux
D.1.1. Установка мыши
D.2. Дисковое пространство, необходимое для задач
D.3. Установка Debian GNU/Linux из системы Unix/Linux
D.3.1. Начинаем
D.3.2. Установка debootstrap
D.3.3. Запуск debootstrap
D.3.4. Настройка базовой системы
D.3.5. Установка ядра
D.3.6. Установка системного загрузчика
D.3.7. Заключительные шаги
D.4. Установка Debian GNU/Linux через Parallel Line IP (PLIP)
D.4.1. Требования
D.4.2. Настройка источника
D.4.3. Установка приёмника
D.5. Установка Debian GNU/Linux с использованием PPP через Ethernet (PPPoE)
D.6. Программа установки с графическим интерфейсом
D.6.1. Использование программы установки с графическим интерфейсом
E. Общие сведения
E.1. Об этом документе
E.2. Как помочь в разработке этого документа
E.3. Люди, внёсшие значительный вклад в написание этого руководства
E.4. Торговые марки
F. GNU General Public License

Список таблиц

3.1. Информация об аппаратном обеспечении, требуемая для установки
3.2. Рекомендуемые минимальные требования к системе
След.
Установка Debian GNU/Linux 6.0 на i386


Установка Debian GNU/Linux 6.0 на i386
Пред. След.

Установка Debian GNU/Linux 6.0 на i386

Мы рады, что вы решили попробовать Debian. Мы уверены, что дистрибутив Debian GNU/Linux покажется вам замечательным. Debian GNU/Linux собирает высококачественное свободное ПО со всего света, объединяя его в единое целое. Мы верим, вы признаете, что получившийся результат — это действительно больше, чем сумма частей.

Мы понимаем, что многие из вас хотят установить Debian, не читая этого руководства, и поэтому программа установки Debian была спроектирована с учётом этого. Если прямо сейчас у вас нет времени на чтение всего руководства, прочтите "Краткое руководство по установке", которое покажет вам основы процесса установки, а также укажет на конкретные главы руководства для углублённого изучения конкретных тем или на случай непредвиденных проблем. Приложение A, Краткая инструкция по установке содержит это краткое руководство.

Тем не менее, мы надеемся, что у вас найдётся время на чтение большей части этого руководства, так как прочитав его, вы сможете более умело и успешно установить систему.

Пред. |  | След.
Руководство по установке Debian GNU/Linux | Начало | Глава 1. Добро пожаловать в Debian


Глава 1. Добро пожаловать в Debian
Пред. След.

Глава 1. Добро пожаловать в Debian

Содержание

1.1. Что такое Debian?
1.2. Что такое GNU/Linux?
1.3. Что такое Debian GNU/Linux?
1.4. Что такое Debian GNU/kFreeBSD?
1.5. Получение Debian
1.6. Получение последней версии этого документа
1.7. Структура этого документа
1.8. Об авторских правах и лицензиях на программы

Эта глава посвящена обзору проекта Debian и Debian GNU/Linux. Если вы уже знаете историю проекта Debian и дистрибутива Debian GNU/Linux, спокойно переходите к следующей главе.

Пред. |  | След.
Установка Debian GNU/Linux 6.0 на i386 | Начало | 1.1. Что такое Debian?


1.1. Что такое Debian?
Пред. Глава 1. Добро пожаловать в Debian След.

1.1. Что такое Debian?

Debian — это организация, полностью состоящая из добровольцев, посвятившая себя разработке свободного программного обеспечения и распространению идеалов сообщества Свободного Программного Обеспечения (Free Software). Проект Debian начался в 1993 году, когда Иэн Мэрдок (Ian Murdock) выпустил открытое приглашение к разработчикам программ внести свой вклад в полноценный программный дистрибутив, основанный на относительно новом ядре Linux. Небольшая группа энтузиастов, на которых повлияла философия GNU, изначально поддерживаемая Фондом Свободного Программного Обеспечения, с годами выросла в организацию, насчитывающую приблизительно 886 разработчиков Debian.

Разработчики Debian выполняют различные задачи, включая администрирование Web и FTP сайтов, графический дизайн, юридический анализ программных лицензий, написание документации и, конечно же, сопровождение пакетов.

В интересах распространения нашей философии и привлечения разработчиков, которые верят в принципы Debian, проект Debian выпустил множество документов, которые подчёркивают наши ценности и рассказывают, что значит быть разработчиком Debian:

  • Общественный Договор Debian — это утверждение обязательств Debian перед Сообществом Свободного Программного Обеспечения. Любой, кто соглашается следовать Общественному Договору Debian может стать сопровождающим. Любой сопровождающий может добавить новые программы в Debian — при условии, что программы соответствуют нашим критериям свободы, а пакеты следуют нашим стандартам качества.

  • Критерии Debian по определению Свободного Программного Обеспечения (DFSG) — это краткие и ясные определения критериев Debian к свободным программам. DFSG является очень влиятельным документом в Движении Свободного Программного Обеспечения и взят за основу Определения Открытых Исходных Текстов.

  • Руководство по политике Debian — это обширная спецификация стандартов качества проекта Debian.

Разработчики Debian также вовлечены и в другие проекты, некоторые из которых созданы специально для Debian, другие выполняются для части или для всего сообщества Linux. Вот несколько примеров:

  • Проект Linux Standard Base (LSB, Основа Стандарта Linux) нацелен на стандартизацию базовой системы GNU/Linux, что позволит сторонним разработчикам программного обеспечения и оборудования легко разрабатывать программы и драйверы устройств для Linux в целом, а не для конкретного дистрибутива GNU/Linux.

  • Стандарт Иерархии Файловой Системы (FHS) — это попытка стандартизировать организацию файловой системы Linux. Стандарт FHS позволит разработчикам программ сконцентрировать свои усилия на создании программы и не беспокоиться о том, как пакет будет устанавливаться в различные дистрибутивы GNU/Linux.

  • Внутренний проект Debian для детей, его цель — уверенность в том, что Debian'у есть что предложить нашим младшим пользователям.

Для более общей информации о Debian, смотрите Debian FAQ.

Пред. | Уровень выше | След.
Глава 1. Добро пожаловать в Debian | Начало | 1.2. Что такое GNU/Linux?


1.2. Что такое GNU/Linux?
Пред. Глава 1. Добро пожаловать в Debian След.

1.2. Что такое GNU/Linux?

Linux — это операционная система: набор программ, которые позволяют вам работать с вашим компьютером и запускать другие программы.

Операционная система (ОС) состоит из нескольких основных программ, которые нужны вашему компьютеру, чтобы он мог общаться и получать инструкции от пользователей; читать и записывать данные на жёсткие диски, ленты и принтеры; контролировать использование памяти; запускать другие программы. Самая важная часть ОС — ядро. В системе GNU/Linux ядром является Linux. Оставшаяся часть системы состоит из других программ, многие из которых написаны проектом GNU или для проекта GNU. Поскольку одно ядро Linux — это ещё не вся работающая ОС, мы предпочитаем использовать термин «GNU/Linux» для обозначения систем, которые многие люди ошибочно называют «Linux».

Linux сделана по образцу операционной системы Unix. С самого начала Linux разрабатывалась как многозадачная, многопользовательская система. Этих факторов достаточно, чтобы сделать Linux отличной от других широко известных операционных систем. Однако, Linux отличается намного сильнее, чем вы можете себе представить. В отличие от других операционных систем, Linux никому не принадлежит. Значительная часть системы разработана добровольцами бесплатно.

Разработка того, что позже станет GNU/Linux, началась в 1984 году, когда Фонд Свободного Программного обеспечения начал разработку свободной Unix-подобной операционной системы, названной GNU.

Проект GNU разработал всеобъемлющий набор свободного программного обеспечения для использования в Unix™ и Unix-подобных операционных системах, таких как Linux. Эти программы позволяют пользователям выполнять задачи широкого спектра, от простых (копирование или удаление файлов из системы) до сложных (написание и компилирование программ или выполнение сложного редактирования в различных форматах документов).

Хотя многие рабочие группы и отдельные люди вложили свой труд в создание Linux, наибольшим пока ещё остается вклад Фонда Свободного Программного Обеспечения. Помимо разработки большинства используемых инструментов, фонд также создал философию и организовал сообщество (независимых программистов и энтузиастов-пользователей). От этого, в свою очередь, стало возможным появление отлаженных Linux систем.

Ядро Linux впервые появилось в 1991 году, когда финский студент-компьютерщик по имени Линус Торвальдс (Linus Torvalds) анонсировал первую версию замены ядра Minix в группе новостей comp.os.minix. Подробнее смотрите на сайте Linux Internationals страничку истории Linux.

Линус Торвальдс продолжает координировать работу нескольких сотен разработчиков с помощью нескольких сопровождающих подсистем. Есть официальный сайт для ядра Linux. Подробную информацию о списке рассылки linux-kernel можно найти в FAQ списка рассылки linux-kernel.

Пользователи Linux имеют огромную свободу в выборе программного обеспечения. Например, пользователи Linux могут выбирать из дюжины различных оболочек командной строки и нескольких графических рабочих столов. Этот выбор часто удивляет пользователей других операционных систем, которые и не думали, что командные оболочки или рабочий стол можно заменить.

Linux также менее подвержен сбоям, лучше приспособлен для одновременного выполнения более чем одной программы и более защищён, чем многие другие системы. Благодаря этим преимуществам, Linux быстро завоёвывает рынок серверных операционных систем. С недавних пор, Linux начал становиться популярным среди домашних пользователей и в корпоративной среде.

Пред. | Уровень выше | След.
1.1. Что такое Debian? | Начало | 1.3. Что такое Debian GNU/Linux?


1.3. Что такое Debian GNU/Linux?
Пред. Глава 1. Добро пожаловать в Debian След.

1.3. Что такое Debian GNU/Linux?

Комбинация философии и методологии Debian, средств GNU, ядра Linux и других важных программ, составляют уникальный дистрибутив под названием Debian GNU/Linux. Этот дистрибутив собран из большого количества пакетов программ. Каждый пакет в дистрибутиве содержит исполняемые файлы, сценарии, документацию, конфигурационную информацию и имеет сопровождающего, который отвечает за поддержание пакета в актуальном состоянии, отслеживает сообщения об ошибках (bug reports) и общается с основными авторами программы. Огромная база наших пользователей в сочетании с нашей системой отслеживания сообщений об ошибках гарантируют, что проблемы будут быстро обнаружены и устранены.

Внимание Debian к деталям позволило создать высококачественный, стабильный и расширяемый дистрибутив. Установленные системы могут быть легко настроены на выполнение самых различных задач: от упрощённого межсетевого экрана (firewall), рабочей станции учёного, до высокопроизводительного сетевого сервера.

Debian особенно популярен среди опытных пользователей из-за его технического совершенства и глубокого понимания нужд и ожиданий сообщества Linux. Debian также добавил много новых свойств в Linux, которые теперь повсеместно используются.

Например, Debian был первым дистрибутивом Linux, который имел систему управления пакетами для более лёгкой установки и удаления программ. Также он был первым дистрибутивом Linux, который можно обновить до последней версии без переустановки.

Debian продолжает быть лидером в разработке Linux. Его процесс разработки является примером того, как хорошо может работать модель Открытых Исходников (Open Source) даже для очень сложных задач, таких как построение и сопровождение целой операционной системы.

Наиболее отличительной особенностью Debian от других дистрибутивов Linux является его система управления пакетами. Она даёт администратору системы Debian полный контроль над пакетами, установленными в системе, будь это установка одного пакета или автоматическое обновление всей операционной системы. Также, отдельные пакеты могут быть защищены от обновления. Вы даже можете указать системе управления пакетами программы, которые вы собрали сами и о том, от каких программ она зависит.

Для защиты вашей системы от «троянских коней» и других вредоносных программ, на серверах Debian выполняется проверка, что поступающие пакеты получены только от зарегистрированных сопровождающих Debian. Также, разработчики Debian заботятся о настройке безопасности программ в своих пакетах. Когда случаются проблемы с безопасностью в выпущенном пакете, обычно очень быстро выходят исправления. С помощью простой системы обновлений Debian исправления безопасности можно загружать и устанавливать автоматически через Интернет.

Основным и самым лучшим способом получения поддержки системы Debian GNU/Linux и общения с разработчиками Debian является множество списков рассылки проекта Debian (на момент написания этих строк их было более 245). Самый простой способ подписаться на один из этих списков — посетить страницу подписки на списки рассылки Debian и заполнить форму.

Пред. | Уровень выше | След.
1.2. Что такое GNU/Linux? | Начало | 1.4. Что такое Debian GNU/kFreeBSD?


1.4. Что такое Debian GNU/kFreeBSD?
Пред. Глава 1. Добро пожаловать в Debian След.

1.4. Что такое Debian GNU/kFreeBSD?

Debian GNU/kFreeBSD — это система Debian GNU с ядром kFreeBSD.

Этот перенос Debian в настоящее время разработан только для архитектур i386 и amd64, хотя возможен перенос и на другие архитектуры.

Заметим, что Debian GNU/kFreeBSD не является системой Linux, и поэтому некоторая информация о Linux к ней неприменима.

Подробности смотрите на странице переноса Debian GNU/kFreeBSD и в списке рассылки проекта <debian-bsd@lists.debian.org>.

Пред. | Уровень выше | След.
1.3. Что такое Debian GNU/Linux? | Начало | 1.5. Получение Debian


1.5. Получение Debian
Пред. Глава 1. Добро пожаловать в Debian След.

1.5. Получение Debian

Информацию о том, как загрузить Debian GNU/Linux из Интернет или у кого можно купить официальные компакт-диски с Debian, смотрите на странице распространения. Список серверов-зеркал Debian содержит полный перечень официальных зеркал Debian, так что вы можете легко найти ближайший к вам.

После установки Debian может быть легко обновлён. Процедура установки поможет настроить систему так, чтобы вы смогли сделать это обновление после завершения установки, если нужно.

Пред. | Уровень выше | След.
1.4. Что такое Debian GNU/kFreeBSD? | Начало | 1.6. Получение последней версии этого документа


1.6. Получение последней версии этого документа
Пред. Глава 1. Добро пожаловать в Debian След.

1.6. Получение последней версии этого документа

Этот документ постоянно обновляется. На странице Debian 6.0 вы найдёте самую свежую информацию о последних изменениях в выпуске 6.0 системы Debian GNU/Linux. Обновлённые версии этого руководства по установке также доступны на официальных страницах руководства по установке.

Пред. | Уровень выше | След.
1.5. Получение Debian | Начало | 1.7. Структура этого документа


1.7. Структура этого документа
Пред. Глава 1. Добро пожаловать в Debian След.

1.7. Структура этого документа

Этот документ может служить руководством для начинающих пользователей Debian. В нём делается несколько предположений о вашем уровне знаний. Однако, мы надеемся, что вы в целом понимаете, как работает аппаратная часть (hardware) вашего компьютера.

Опытные пользователи в этом документе смогут найти ссылки на интересную справочную информацию, например, минимальные размеры установки, детали о поддержке аппаратных средств системой установки Debian и так далее. Мы призываем опытных пользователей хотя бы пробежаться глазами по документу.

Это руководство построено последовательно, оно проведёт вас через процесс установки от начала и до конца. Вот шаги установки Debian GNU/Linux и соответствующие им разделы документа:

  1. Определите, соответствует ли ваше аппаратное обеспечение требованиям системы установки (Глава 2, Системные требования).

  2. Сделайте резервную копию вашей системы, выполните необходимое планирование и настройку аппаратного обеспечения перед установкой Debian (Глава 3, Перед установкой Debian GNU/Linux). Если вы подготавливаете мульти-загрузочную систему, то вам, возможно, понадобится выделить место на жёстком диске под раздел Debian.

  3. Выбрав способ установки, получите необходимые файлы (Глава 4, Получение носителя с дистрибутивом).

  4. Глава 5, Загрузка системы установки описывает загрузку системы установки. В этом разделе также обсуждается процедура поиска неисправностей при возникновении проблем.

  5. Выполните саму установку согласно Глава 6, Использование программы установки Debian. Сюда входит выбор языка установки, настройка драйверов периферийных устройств, настройка сетевых соединений для загрузки оставшихся файлов установки прямо с сервера Debian (если установка производится не с компакт-диска), создание разделов на жёстком диске, установка базовой системы, а затем выбор и установка задач. (Некоторые советы по настройке разделов для системы Debian можно найти в Приложение C, Разметка дисков в Debian.)

  6. Загрузите вашу только что установленную базовую систему согласно Глава 7, Загрузка только что установленной системы Debian.

После установки системы вы можете почитать Глава 8, Следующие шаги и что делать дальше. В ней рассказывается о том, где найти дополнительную информации о Unix и Debian, и как заменить ядро.

И наконец, информацию об этом документе и как помочь его развитию, можно найти в Приложение E, Общие сведения.

Пред. | Уровень выше | След.
1.6. Получение последней версии этого документа | Начало | 1.8. Об авторских правах и лицензиях на программы


1.8. Об авторских правах и лицензиях на программы
Пред. Глава 1. Добро пожаловать в Debian След.

1.8. Об авторских правах и лицензиях на программы

Мы уверены, что вы читали некоторые лицензии, на условиях которых распространяется большинство коммерческих программ — обычно в них говорится, что вы можете использовать только одну копию программы на одном компьютере. Лицензия этой системы совсем не такая. Мы предлагаем вам установить копию Debian GNU/Linux на каждый компьютер в вашей школе или на работе. Дайте ваши установочные носители друзьям и помогите им поставить систему на их компьютеры! Вы даже можете сделать тысячи копий и продавать их — хотя и с некоторыми ограничениями. Ваша свобода ставить и использовать систему происходит непосредственно из-за того, что Debian основан на свободном программном обеспечении.

Хотя программы и называются свободными, это не означает, что программы не защищены авторскими правами, и это не означает, что компакт-диски, содержащие эти программы, должны распространяться бесплатно. Свободное программное обеспечение, в частности, означает, что лицензии отдельных программ не требуют оплаты за привилегию распространять или использовать эти программы. Свободное программное обеспечение также означает, что кто угодно может не только расширять, адаптировать и изменять программы, но также и распространять результаты своей работы.

Замечание

Заметьте, что проект Debian, уступая требованиям пользователей, сделал некоторые пакеты доступными, хотя они и не отвечают нашим критериям свободы. Однако, эти пакеты не являются частью официального дистрибутива, и доступны только из областей contrib или non-free серверов-зеркал Debian или на неофициальных компакт-дисках; более подробную информацию о расположении и содержании архивов смотрите в разделе «FTP-архивы Debian» в Debian FAQ.

Большинство программ в системе выпущено под Стандартной Общественной Лицензией GNU , часто называемой просто «GPL». Лицензия GPL требует от вас сделать исходный код программ доступным, если вы распространяете двоичную копию программы; это условие лицензии даёт гарантию, того что любой пользователь сможет изменять программу. Согласно этому положению, в системе Debian доступен исходный код[1] всех таких программ доступен.

Программы в Debian доступны по нескольким соглашениям об авторских правах и программных лицензий. Сразу после установки в систему, лицензия на пакет сохраняется в файле /usr/share/doc/имя-пакета/copyright .

Более полную информацию о лицензиях и о том, как Debian определяет, является ли программа достаточно свободной, чтобы быть включённой в основную (main) часть дистрибутива, смотрите в критериях Debian для свободного программного обеспечения.

Самое важное юридическое замечание — программное обеспечение поставляется без гарантий. Программисты, создавшие программу, сделали это на пользу обществу. Не даётся никаких гарантий о пригодности поставляемого программного обеспечения для каких-то определённых целей. Однако, поскольку программное обеспечение свободно, вы вольны модифицировать программу для достижения необходимых вам целей — и наслаждаться выгодами изменений, сделанных другими людьми, которые расширили возможности программы тем же путём.

[1] Информацию о том как найти, распаковать и собрать двоичные программы из исходных кодов Debian, смотрите в Debian FAQ, в разделе «Основы системы управления пакетами Debian».

Пред. | Уровень выше | След.
1.7. Структура этого документа | Начало | Глава 2. Системные требования


Глава 2. Системные требования
Пред. След.

Глава 2. Системные требования

Содержание

2.1. Поддерживаемое оборудование
2.1.1. Поддерживаемые архитектуры
2.1.2. Поддерживаемые процессоры, материнские платы и видеокарты
2.1.3. Ноутбуки
2.1.4. Несколько процессоров
2.1.5. Поддержка видеокарт
2.1.6. Аппаратура для подключения к сети
2.1.7. Дисплеи Брайля
2.1.8. Устройства речевого синтеза
2.1.9. Периферия и другое оборудование
2.2. Устройства, которым требуются микропрограммы
2.3. Покупка аппаратного обеспечения специально для GNU/Linux
2.3.1. Избегайте собственнического или закрытого аппаратного обеспечения
2.3.2. Аппаратное обеспечение, работающее только в Windows
2.4. Установочные носители
2.4.1. CD-ROM/DVD-ROM
2.4.2. Жёсткий диск
2.4.3. Карта памяти USB
2.4.4. Сеть
2.4.5. Система Un*x или GNU
2.4.6. Поддерживаемые системы хранения
2.5. Требования к памяти и дисковому пространству

Этот раздел содержит информацию о том, какое оборудование требуется для запуска Debian. Также, вы найдете ссылки на информацию об оборудовании, поддерживаемом GNU и Linux.

Пред. |  | След.
1.8. Об авторских правах и лицензиях на программы | Начало | 2.1. Поддерживаемое оборудование


2.1. Поддерживаемое оборудование
Пред. Глава 2. Системные требования След.

2.1. Поддерживаемое оборудование

Для Debian не требуется от оборудования сверх того, что требуют ядро Linux или kFreeBSD и утилиты GNU. Таким образом, любая архитектура или платформа, на которую были перенесены ядро Linux или kFreeBSD, libc, gcc и т.д. и на которую перенесён Debian, может работать под Debian. Сверьтесь со страницами переносов http://www.debian.org/ports/i386/, какие системы на архитектуре 32-bit PC были протестированы с Debian GNU/Linux.

Вместо того, чтобы пытаться описать всё разнообразие аппаратных конфигураций, которое существует на 32-bit PC, эта глава содержит общую информацию и указания, где можно найти дополнительную информацию.

2.1.1. Поддерживаемые архитектуры

Debian GNU/Linux 6.0 поддерживает одиннадцать основных архитектур и несколько вариаций каждой архитектуры, известных как «варианты (flavors)».

Архитектура | Обозначение в Debian | Субархитектура | Вариант
основанные на Intel x86 | i386 |  |
AMD64 & Intel EM64T | amd64 |  |
ARM | armel | Intel IOP32x | iop32x
 |  | Intel IXP4xx | ixp4xx
 |  | Marvell Kirkwood | kirkwood
 |  | Marvell Orion | orion5x
 |  | Versatile | versatile
HP PA-RISC | hppa | PA-RISC 1.1 | 32
 |  | PA-RISC 2.0 | 64
Intel IA-64 | ia64 |  |
MIPS (с прямым порядком байтов) | mips | SGI IP22 (Indy/Indigo 2) | r4k-ip22
 |  | SGI IP32 (O2) | r5k-ip32
 |  | MIPS Malta (32-битная) | 4kc-malta
 |  | MIPS Malta (64-битная) | 5kc-malta
MIPS (с обратным порядком байтов) | mipsel | Cobalt | cobalt
 |  | MIPS Malta (32-битная) | 4kc-malta
 |  | MIPS Malta (64-битная) | 5kc-malta
IBM/Motorola PowerPC | powerpc | PowerMac | pmac
 |  | PReP | prep
Sun SPARC | sparc | sun4u | sparc64
 |  | sun4v
IBM S/390 | s390 | IPL с VM-reader и DASD | generic
 |  | IPL с ленты | tape

Debian GNU/kFreeBSD 6.0 поддерживает две архитектуры.

Архитектура | Обозначение в Debian
основанные на Intel x86 | kfreebsd-i386
AMD64 & Intel EM64T | kfreebsd-amd64

Этот документ содержит описание установки на архитектуру 32-bit PC. Если вы ищете информацию по любой другой архитектуре, поддерживаемой Debian, посмотрите на странице переносов Debian.

2.1.2. Поддерживаемые процессоры, материнские платы и видеокарты

Полную информацию о поддерживаемом периферийном оборудовании можно найти в Linux Hardware Compatibility HOWTO. Этот раздел содержит только базовые сведения.

2.1.2.1. Центральный процессор

Поддерживаются почти все x86-совместимые (IA-32) процессоры, используемые в персональных компьютерах, включая все серии Intel "Pentium". Сюда входят 32-битные процессоры AMD и VIA (ранее Cyrix), а также процессоры типа Athlon XP и Intel P4 Xeon.

Однако, Debian GNU/Linux squeeze не работает на процессорах 386 и более ранних. Несмотря на то, что название архитектуры "i386", в Debian Sarge (r3.1) была выключена поддержка для процессоров 80386 (и их клонов)[2]. (Ни одна версия Linux не поддерживала процессор 286 и более ранние в этой серии.) Все процессоры i486 и более поздние поддерживаются[3].

Замечание

Если в вашей системе установлен 64-битный процессор из семейств AMD64 или Intel EM64T, то, вероятно, вам лучше использовать программу установки для архитектуры amd64 вместо программы установки для (32-битной) архитектуры i386.

2.1.2.2. Шина ввода-вывода (I/O)

Системная шина — это часть материнской платы, которая позволяет процессору взаимодействовать с периферией, например, с устройствами хранения. Ваш компьютер должен использовать ISA, EISA, PCI, PCIe, PCI-X или VESA Local Bus (VLB, иногда называемая VL шиной). В сущности, все персональные компьютеры, продаваемые в последние годы, имеют одну из них.

2.1.3. Ноутбуки

Ноутбуки также поддерживаются и сегодня большинство из них Если в них содержится специализированное или проприетарное оборудование, то некоторые возможности могут не поддерживаться. На странице Linux на ноутбуках можно посмотреть, будет ли работать GNU/Linux на вашем ноутбуке.

2.1.4. Несколько процессоров

На этой архитектуре поддерживается нескольких процессоров — так называемая «симметричная многопроцессорная обработка (symmetric multi-processing)» или SMP. Стандартное ядро Debian 6.0 собрано с поддержкой SMP-alternatives. Это означает, что ядро определит число процессоров (или процессорных ядер) и автоматически выключит SMP в однопроцессорных системах.

Вариант 486 пакетов образа ядра Debian для 32-bit PC собран без поддержки SMP.

2.1.5. Поддержка видеокарт

Вам понадобится VGA-совместимый видео-интерфейс для консольного терминала. Практически любая современная видеокарта совместима с VGA. Устаревшие стандарты, такие как CGA, MDA или HGA тоже подойдут, если вам не нужна поддержка X11. Заметим, что X11 не используется во время установки, описанной в этом документе, если не была выбрана установка с помощью установщика с графическим интерфейсом.

Поддержка графического интерфейса в Debian полностью зависит от поддержки этого интерфейса системой X.Org X11. Большинство видеокарт AGP, PCI, PCIе и PCI-X работает в X.Org. Список поддерживаемых графических шин, карт, мониторов и устройств ввода можно найти на http://xorg.freedesktop.org/. Debian6.0 поставляется с X.Org версии 7.5.

2.1.6. Аппаратура для подключения к сети

Почти любая сетевая плата (NIC), поддерживаемая ядром Linux, должна поддерживаться системой установки; драйверы модулей должны загрузиться автоматически. Это относится к почти всем картам PCI и PCMCIA. Также поддерживается много старых карт ISA.

ISDN поддерживается, но не во время установки.

2.1.6.1. Карты для беспроводных сетей

Беспроводные сети, в основном, поддерживаются, как и растёт число поддерживаемых беспроводных адаптеров в официальном ядре Linux, хотя для работы многих из них требуется загрузка микропрограммы. Если нужна микропрограмма, то программа установки предложит её загрузить. В Раздел 6.4, «Загрузка отсутствующих микропрограмм» есть подробное описание о том, как загрузить микропрограмму во время установки.

Беспроводные адаптеры, не поддерживаемые официальным ядром Linux, обычно, можно заставить работать в Debian GNU/Linux, но это не поддерживается во время установки.

Поддержка шифрованной беспроводной сети во время установки поддерживается только для WEP. Если в вашей точке доступа используется более стойкий алгоритм шифрования, то она не может быть использована при установке.

Если есть проблемы с беспроводной сетью и других сетевых устройств нет, которые можно использовать во время установки, то всё ещё возможно установить Debian GNU/Linux с полного образа CD-ROM или DVD. Добавьте параметр для выключения настройки сети и установите только пакеты с CD/DVD. После завершения установки (после перезагрузки) вы сможете установить драйвер и микропрограмму, которые требуются, и настроить сеть вручную.

Иногда, нужный драйвер недоступен в виде пакета Debian. В этом случае вам придётся поискать исходный код в интернете и собрать драйвер самостоятельно. Это не описано в данном руководстве. Если драйвер под Linux недоступен, в последнюю очередь можно использовать пакет ndiswrapper, который позволяет использовать драйвер от Windows.

2.1.7. Дисплеи Брайля

Поддержка дисплеев Брайля обеспечивается программой brltty. С её помощью работает заработает большинство дисплеев, подключаемых к последовательному порту, USB или bluetooth. Список поддерживаемых устройств можно найти на сайте brltty. В Debian GNU/Linux 6.0 включена brltty версии 4.2.

2.1.8. Устройства речевого синтеза

Поддержка устройств речевого синтеза обеспечивается программой speakup. speakup поддерживает только встраиваемые платы и внешние устройства, подключаемые к последовательному порту (USB или serial-to-USB адаптеры не поддерживаются). Список поддерживаемых устройств можно найти на сайте speakup. В Debian GNU/Linux 6.0 включена speakup версии 3.1.5.

2.1.9. Периферия и другое оборудование

Linux поддерживает много разных устройств, таких как мыши, принтеры, сканеры, PCMCIA и USB устройства. Однако, большинство этих устройств не требуется для установки системы.

USB устройства в основном работают нормально, за исключением некоторых USB-клавиатур, которые могут потребовать дополнительной настройки (смотрите Раздел 3.6.4, «Аппаратные проблемы, которых нужно остерегаться»).

Напомним, что список поддерживаемого в Linux оборудования можно найти в Linux Hardware Compatibility HOWTO.

[2] Мы долго пытались избежать этого, но теперь это стало необходимо из-за серий проблем с компилятором и ядром, начиная с ошибки в C++ ABI, происходящей в GCC. Вы всё ещё можете запустить Debian GNU/Linux на настоящих процессорах 80386, если соберёте ядро самостоятельно и скомпилируете все пакеты из исходных текстов, но как это делать не описано в данном руководстве.

[3] В качестве положительного момента отказа от поддержки старых процессоров стоит отметить, что многие пакеты Debian будут работать немного быстрее на современных компьютерах. Процессор i486, выпущенный в 1989 году, имеет три команды (bswap, cmpxchg и xadd), которых нет в процессоре i386, выпущенном в 1986 году. Прежде, их нелегко было использовать в большинстве пакетов Debian; теперь это возможно.

Пред. | Уровень выше | След.
Глава 2. Системные требования | Начало | 2.2. Устройства, которым требуются микропрограммы


2.2. Устройства, которым требуются микропрограммы
Пред. Глава 2. Системные требования След.

2.2. Устройства, которым требуются микропрограммы

Для того, чтобы устройства начали работать мимо драйверов, в некоторое аппаратное обеспечение также требуется загрузить так называемую микропрограмму или микрокод. Это требуется почти для всех сетевых карт (особенно для беспроводных сетей), а также для некоторых устройств USB и даже контроллеров жёстких дисков.

В большинстве случаев микропрограмма является несвободной, если исходить из критериев, используемых проектом Debian GNU/Linux, и поэтому не может быть включена в основной дистрибутив или в систему установки. Если сам драйвер устройства включён в дистрибутив и если для Debian GNU/Linux разрешено легально распространять микропрограмму, то а, чаще всего, доступна в виде отдельного пакета в архиве в разделе non-free.

Однако, это не означает, что такое аппаратное обеспечение не может использоваться во время установки. Начиная с Debian GNU/Linux 5.0, debian-installer поддерживает загрузку файлов микропрограмм или пакетов с микропрограммами со сменных носителей, таких как дискеты или USB-накопители. Подробней о том, как загружать файлы микропрограмм и пакеты во время установки см. Раздел 6.4, «Загрузка отсутствующих микропрограмм».

Пред. | Уровень выше | След.
2.1. Поддерживаемое оборудование | Начало | 2.3. Покупка аппаратного обеспечения специально для GNU/Linux


2.3. Покупка аппаратного обеспечения специально для GNU/Linux
Пред. Глава 2. Системные требования След.

2.3. Покупка аппаратного обеспечения специально для GNU/Linux

Некоторые продавцы предлагают системы с уже установленным Debian или с другими дистрибутивами GNU/Linux. Может быть, за это вам придётся заплатить чуть больше, но это плата за душевный покой, так как в этом случае можно быть уверенным в том, что данное аппаратное обеспечение хорошо поддерживается GNU/Linux.

Если вы купили машину с установленным Windows, внимательно прочитайте лицензию, которая поставляется с Windows; может быть, вы сможете не согласиться с лицензией и получить скидку от продавца. Поиск в Интернет по ключевым словам «windows refund» может дать полезную информацию об этом.

Покупаете ли вы машину с установленным Linux или нет, или даже подержанную систему, всё равно, важно проверить, что аппаратное обеспечение поддерживается ядром Linux. Убедитесь, что ваше аппаратное обеспечение находится в списках по ссылке, приведённой выше. Скажите продавцу (если он есть), что вы покупаете систему для Linux. Поддержите дружественных к Linux продавцов аппаратного обеспечения.

2.3.1. Избегайте собственнического или закрытого аппаратного обеспечения

Некоторые производители аппаратного обеспечения просто не говорят нам как писать драйверы для своего аппаратного обеспечения. Другие не дают нам доступ к документации без соглашения о неразглашении, которое запрещает нам выпускать исходный код под Linux.

Так как мы не имели доступа к документации на эти устройства — они просто не работают в Linux. Вы можете помочь, попросив производителей таких устройств выпустить документацию. Если попросит много людей, они поймут, что сообщество свободного программного обеспечения тоже важный рынок.

2.3.2. Аппаратное обеспечение, работающее только в Windows

Появилась нездоровая тенденция выпускать Windows-зависимые модемы и принтеры. В некоторых случаях они специально разрабатываются для работы под операционной системой Microsoft Windows и на них написано «WinModem» или «Сделано особенно для компьютеров с Windows». Из такого оборудования обычно удалены встроенные процессоры, а их функции перенесены в драйвер Windows, то есть на ваш основной процессор. Такая стратегия делает устройство менее дорогим, но экономию, зачастую, получает не пользователь и его аппаратное обеспечение даже может оказаться дороже эквивалентному устройству, в котором остался встроенный интеллект.

Вы должны избегать устройств зависимых от Windows по двум причинам. Первая: обычно, производители не предоставляют ресурсов для написания Linux драйвера. Обычно, аппаратный и программный интерфейс к устройству закрыт, а документация недоступна без соглашения о неразглашении, если она вообще доступна. Это мешает использовать его в свободном программном обеспечении, так как писатели свободного программного обеспечения открывают коды своих программ. Второе: когда из устройства удаляется встроенный процессор, операционная система должна выполнять работу встроенного процессора, часто с приоритетом реального времени, а это значит, что центральный процессор недоступен для работы других программ на время обслуживания таких устройств. Так как обычный пользователь Windows не так интенсивно использует многозадачность как пользователь Linux, производители надеются, что пользователь Windows просто не заметит, как тяжесть работы их устройств перенесена на центральный процессор компьютера. Однако у любой многозадачной операционной системы, даже Windows 2000 или XP, снижается производительность, когда производители периферийного оборудования урезают задачи, выполняемые самими устройствами.

Вы можете повлиять на ситуацию, призвав производителей выпустить документацию и другие ресурсы необходимые нам для программирования их устройств, но лучшая стратегия — просто избегать покупать устройства, которые не описаны как работающие в Linux Hardware Compatibility HOWTO.

Пред. | Уровень выше | След.
2.2. Устройства, которым требуются микропрограммы | Начало | 2.4. Установочные носители


2.4. Установочные носители
Пред. Глава 2. Системные требования След.

2.4. Установочные носители

Этот раздел поможет определить, какие типы носителей вы можете использовать для установки Debian. Например, если на вашей машине есть дисковод гибких дисков, его можно использовать для установки Debian. Существует целая глава, целиком посвящённая выбору носителей (Глава 4, Получение носителя с дистрибутивом), в которой перечислены преимущества и недостатки каждого типа. Вы можете вернуться к этой странице, когда прочитаете эту главу.

2.4.1. CD-ROM/DVD-ROM

Замечание

Когда вы видите слово «CD-ROM» в этом руководстве, то оно применимо и к приводам CD-ROM, и к приводам DVD-ROM, потому что обе технологии с точки зрения операционной системы одинаковы, исключая некоторые очень старые нестандартные (не SCSI и не IDE/ATAPI) приводы CD-ROM.

Установка с CD-ROM поддерживается не на всех архитектурах. На машинах, которые поддерживают загрузку с CD-ROM, вы сможете выполнить полностью бездискетную установку. Даже если ваша система не поддерживает загрузку с CD-ROM, вы можете использовать привод CD-ROM для установки системы после загрузки машины другим способом; смотрите Глава 5, Загрузка системы установки.

Поддерживается SCSI, SATA и IDE/ATAPI CD-ROM-ы. В Linux CD-ROM HOWTO подробно описывается использование CD-ROM в Linux.

Также работают приводы CD-ROM, подключаемые по USB, и устройства FireWire, которые поддерживаются драйверами ohci1394 и sbp2.

2.4.2. Жёсткий диск

Загрузка системы установки непосредственно с жёсткого диска — это ещё один вариант, работающий на многих архитектурах. Он требует наличия какой-нибудь другой операционной системы для загрузки программы установки на жёсткий диск.

2.4.3. Карта памяти USB

Многим машинам Debian дисководы гибких и/или компакт-дисков нужны только для установки системы и для восстановления. Если вы управляете несколькими серверами, то вероятно уже не заказываете такие дисководы в комплекте и используете карты памяти USB для установки и (если необходимо) для восстановления системы. Также это полезно для маленьких машин, у которых нет места для ненужных дисководов.

2.4.4. Сеть

Для получения требуемых для установки файлов может быть использована сеть. Будет или нет задействована сеть зависит от выбранного метода и ваших ответов на некоторые вопросы, которые будут заданы во время установки. Система установки поддерживает большинство типов подключения к сети (включая PPPoE, но не ISDN или PPP), и работает по HTTP или FTP. Настройку ISDN и PPP вы сможете выполнить после завершения установки.

Также вы можете загрузить систему по сети.

Ещё один вариант — бездисковая установка с использованием загрузки по локальной сети и монтированием всех локальных файловых систем через NFS.

2.4.5. Система Un*x или GNU

Если вы работаете в другой Unix системе, то можете использовать её для установки Debian GNU/Linux без использования debian-installer, описанного в остальной части руководства. Этот тип установки может пригодиться пользователям с каким-то неподдерживаемым оборудованием или на машинах, работу которых нельзя прерывать. Если вы заинтересовались данным способом, перейдите в Раздел D.3, «Установка Debian GNU/Linux из системы Unix/Linux».

2.4.6. Поддерживаемые системы хранения

Загрузочные диски Debian содержат ядро, которое собрано исходя из задачи максимизации числа систем, на которых оно сможет работать. К сожалению, этот подход приводит к увеличению размера ядра из-за включения большого количества драйверов, которые, возможно, не будут использоваться на вашей машине (смотрите Раздел 8.6, «Сборка нового ядра», чтобы научиться создавать своё собственное ядро). Поддержка как можно большего количества типов устройств в целом желательна, так как это даёт уверенность в том, что Debian сможет быть установлен на широком спектре оборудования.

Система установки Debian включает поддержку дискет, дисков IDE (также известных как PATA), дискет IDE, устройств IDE, подключаемых к параллельному порту, контроллеров/дисков SATA и SCSI, USB и FireWire. Поддерживаются файловые системы FAT, Win-32 расширения FAT (VFAT) и NTFS.

Также поддерживаются дисковые интерфейсы, имитирующие интерфейс жёсткого диска «AT», часто называемый MFM, RLL, IDE или PATA. Поддерживается множество дисковых контроллеров SATA и SCSI различных производителей. Подробней см. Linux Hardware Compatibility HOWTO.

Пред. | Уровень выше | След.
2.3. Покупка аппаратного обеспечения специально для GNU/Linux | Начало | 2.5. Требования к памяти и дисковому пространству


2.5. Требования к памяти и дисковому пространству
Пред. Глава 2. Системные требования След.

2.5. Требования к памяти и дисковому пространству

Для выполнения обычной установки у вас должно быть 56MB оперативной памяти и 650MB на жёстком диске. Заметим, что это действительно самый минимум, который должен быть. Более реалистичные данные смотрите в Раздел 3.4, «Минимальные требования к аппаратному обеспечению».

Установка на системах с малым количеством оперативной памяти[4] или дискового пространства может быть возможна, но только для опытных пользователей.

[4] Установка с образов, имеющих графическую программу установки, требует больше памяти, чем при использовании консольной программы установки и не должна выполняться на системах, в которых установлено менее56MB оперативной памяти. Если можно выбирать между загрузкой обычной и графической программой установки, то должна быть выбрана обычная.

Пред. | Уровень выше | След.
2.4. Установочные носители | Начало | Глава 3. Перед установкой Debian GNU/Linux


Глава 3. Перед установкой Debian GNU/Linux
Пред. След.

Глава 3. Перед установкой Debian GNU/Linux

Содержание

3.1. Обзор процесса установки
3.2. Сохраните ваши данные в надёжном месте!
3.3. Информация, которая понадобится
3.3.1. Документация
3.3.2. Поиск источников технической информации
3.3.3. Совместимость аппаратного обеспечения
3.3.4. Настройки сети
3.4. Минимальные требования к аппаратному обеспечению
3.5. Переразметка для мульти-загрузочных систем
3.5.1. Разметка дисков из DOS или Windows
3.6. Настройка аппаратного обеспечения и операционной системы перед установкой
3.6.1. Вызов меню настройки BIOS
3.6.2. Выбор загрузочного устройства
3.6.3. Другие настройки BIOS
3.6.4. Аппаратные проблемы, которых нужно остерегаться

В этой главе рассказывается о том, что нужно сделать перед запуском программы установки Debian: резервное копирование данных, сбор информации об оборудовании и поиск необходимой информации.

Пред. |  | След.
2.5. Требования к памяти и дисковому пространству | Начало | 3.1. Обзор процесса установки


3.1. Обзор процесса установки
Пред. Глава 3. Перед установкой Debian GNU/Linux След.

3.1. Обзор процесса установки

Во-первых, немного о переустановках. Случаи, когда приходится полностью переустанавливать Debian очень редки; наиболее часто это делается при механической поломке жёсткого диска.

Для большинства операционных систем при критических сбоях или для обновления до новой версии может требоваться выполнение полной установки. Даже если новая установка не требуется, часто приходится переустанавливать некоторые программы, чтобы они заработали в новой версии ОС.

В случае Debian GNU/Linux у вас намного больше шансов, что ОС будет восстановлена без переустановки. При обновлении до новой версии установка "всего" не требуется никогда; достаточно обновления только нужных частей. Все программы почти всегда совместимы с новыми версиями операционной системы. Если новая версия программы требует более нового программного обеспечения, система управления пакетами Debian обеспечивает автоматическое обнаружение и установку всего необходимого программного обеспечения. Много труда было вложено именно в то, чтобы избежать переустановки, поэтому думайте об этом как о последней причине вашего выбора. Программа установки не разрабатывалась для переустановки поверх существующей системы.

Вот путь, который вам предстоит совершить.

  1. Сделать резервную копию существующих данных и документов жёсткого диска, на который вы планируете выполнить установку.

  2. Перед началом установки собрать информацию о компьютере и всю необходимую документацию.

  3. Выделить место под Debian на жёстком диске.

  4. Найти и/или скачать программу установки и все нужные для вашей машины специальные драйверы (пользователям компакт-дисков Debian этого делать не надо).

  5. Создать ленты/дискеты/USB-карты памяти или разместить загрузочные файлы (большинство пользователей компакт-дисков Debian могут загрузиться с одного из компакт-дисков).

  6. Загрузить систему установки.

  7. Выбрать язык установки.

  8. Активировать, если есть, подключение к сети ethernet.

  9. Создать и смонтировать разделы, на которые будет установлен Debian.

  10. Присматривать за автоматической загрузкой/установкой/настройкой базовой системы.

  11. Установить системный загрузчик, который сможет запускать Debian GNU/Linux и/или другую существующую систему.

  12. Загрузить только что установленную систему в первый раз.

Для 32-bit PC доступна версия системы установки с графическим интерфейсом. Подробней, смотрите Раздел D.6, «Программа установки с графическим интерфейсом».

Если у вас возникли проблемы во время установки, хорошо иметь представление о том, какими пакетами это могло быть вызвано и на каком шаге. Представляем основных актёров от программного обеспечения в драме "установка":

Программа установки, debian-installer — это главное, о чём писалось данное руководство. Она обнаруживает аппаратное обеспечение и загружает соответствующие драйверы, использует dhcp-client для настройки подключения к сети, запускает debootstrap для установки пакетов базовой системы и запускает tasksel для того, чтобы позволить вам выбрать установку дополнительного ПО. Намного больше актёров играют меньшие роли в этом процессе, а debian-installer завершает свою работу после первой загрузки операционной системы.

Для настройки системы под ваши нужды служит программа tasksel, которая позволяет выбрать для установки различные готовые группы взаимосвязанных программ под задачу, например, для веб сервера или настольного компьютера.

Одним из важных пунктов установки — это будет или нет установлена графическое окружение рабочего стола, состоящее из оконной системы X и одного из доступных графических окружений рабочего стола. Если вы не выберете задачу «Окружение рабочего стола», то у вас получится относительно простая система, управляемая из командной строки. Установка Окружения рабочего стола является необязательной задачей, так как для неё требуется огромное количество дискового пространства, и из-за того, что многие системы Debian GNU/Linux являются серверами, которым не нужен графический интерфейс пользователя для выполнения требуемых задач.

Оконная система X — это полностью отдельная программа никак не связанная с debian-installer, и фактически, намного более сложная. Описание установки и устранение проблем с оконной системой X не предмет рассмотрения данного руководства.

Пред. | Уровень выше | След.
Глава 3. Перед установкой Debian GNU/Linux | Начало | 3.2. Сохраните ваши данные в надёжном месте!


3.2. Сохраните ваши данные в надёжном месте!
Пред. Глава 3. Перед установкой Debian GNU/Linux След.

3.2. Сохраните ваши данные в надёжном месте!

Перед тем как начать, убедитесь, что вы сохранили каждый файл из вашей системы. Если вы впервые устанавливаете на компьютер не родную операционную систему, скорее всего вам придётся переразметить диск, чтобы выделить место для Debian GNU/Linux. Всегда при разметке диска вы должны считать, что теряете всё на диске, вне зависимости от используемого для этого инструмента. Программы, используемые в установке, достаточно надёжны; с большинством из них люди работают не первый год; но они достаточно мощны для того, чтобы одно неосторожное движение дорого вам обошлось. Даже после сохранения данных будьте осторожны и думайте над даваемыми ответами и действиями. Две минуты раздумий могут спасти вас от нескольких часов ненужной работы.

Если вы создаёте мульти-загрузочную систему, убедитесь, что у вас под рукой есть носители с дистрибутивами всех операционных систем, присутствующих на диске. Особенно если вы переразмечаете загрузочный диск, то можете обнаружить, что затёрли системный загрузчик операционной системы или, в большинстве случаев, всю операционную систему и все файлы на разделах.

Пред. | Уровень выше | След.
3.1. Обзор процесса установки | Начало | 3.3. Информация, которая понадобится


3.3. Информация, которая понадобится
Пред. Глава 3. Перед установкой Debian GNU/Linux След.

3.3. Информация, которая понадобится

3.3.1. Документация

3.3.1.1. Руководство по установке

Документ, который вы сейчас читаете, является официальной версией руководства по установке Debian squeeze и доступен в различных форматах и на разных языках.

3.3.1.2. Техническая документация

Часто содержит полезную информацию по настройке и использованию вашего аппаратного обеспечения.

  • Совместимость Linux и аппаратного обеспечения HOWTO

3.3.2. Поиск источников технической информации

В большинстве случаев программа установки способна определить используемое оборудование автоматически. Но всё же мы рекомендуем вам перед установкой самостоятельно ознакомиться с имеющимся оборудованием.

Информацию по аппаратному обеспечению можно найти:

  • В руководствах, которые были вместе с приобретённым аппаратным обеспечением.

  • В настройках BIOS. Вы можете увидеть эти настройки, если нажмёте комбинацию клавиш во время загрузки компьютера. Посмотрите в руководстве нужную комбинацию. Часто это клавиша Delete.

  • На коробках и ящиках от аппаратного обеспечения.

  • Щёлкнув на значке "Система" в панели управления Windows.

  • С помощью системных команд и инструментов других операционных систем, включая файловый менеджер. Это особенно полезный источник информации об оперативной памяти и жёстких дисках.

  • Узнать у вашего системного администратора или провайдера услуг Интернет. Они могут рассказать вам о настройках почты и подключении к сети.

Таблица 3.1. Информация об аппаратном обеспечении, требуемая для установки

Аппаратное обеспечение | Информация, которая может потребоваться
Жёсткие диски | Количество дисков.
 | Их порядок в системе.
 | IDE (тн. PATA), SATA или SCSI.
 | Доступное дисковое пространство.
 | Разделы.
 | Разделы, на которых установлены операционные системы.
Монитор | Модель и производитель.
 | Поддерживаемые разрешения.
 | Частота горизонтальной развёртки.
 | Частота вертикальной развёртки.
 | Поддерживаемая глубина цвета (число цветов).
 | Размер экрана.
Мышь | Тип интерфейса: последовательный, PS/2 или USB.
 | Порт.
 | Производитель.
 | Число кнопок.
Сеть | Модель и производитель.
 | Тип адаптера.
Принтер | Модель и производитель.
 | Поддерживаемое разрешение печати.
Видеокарта | Модель и производитель.
 | Размер видеопамяти.
 | Поддерживаемые разрешения и глубина цвета (это должно быть проверено вместе с возможностями монитора).

3.3.3. Совместимость аппаратного обеспечения

Многие продукты под известными торговыми марками без проблем работают в Linux. Кроме того, поддержка аппаратного обеспечения в Linux ежедневно улучшается. Однако, Linux всё равно пока не может сравниться по количеству поддерживаемой аппаратуры с другими операционными системами.

В частности, на Linux не работает аппаратное обеспечение, для которого требуется работающая версия Windows.

Хотя некоторое аппаратное обеспечение "только-для-Windows" можно заставить работать под Linux, но чтобы добиться этого обычно нужно приложить дополнительные усилия. Кроме того, драйвера под Linux для Windows-специфичного оборудования обычно работают только с определённой версией ядра. Поэтому, они могут быстро устареть.

Так называемые вин-модемы — наиболее распространённый тип такого аппаратного обеспечения. Однако, принтеры и другое оборудование также может оказаться Windows-специфичным.

Вы можете проверить совместимость аппаратного обеспечения:

  • Поискав новые драйверы на веб сайте производителя.

  • Поискав на веб сайте или в руководствах информацию об эмуляции. Менее известные производители иногда могут использовать драйверы или настройки более известных.

  • Проверив совместимость аппаратного обеспечения Linux на веб сайтах, посвящённых архитектуре вашей машины.

  • Поискав в Интернете отзывы других пользователей о работе данного оборудования.

3.3.4. Настройки сети

Если компьютер подключён к сети 24 часа в сутки (например, по Ethernet или через аналогичное подключение, но не PPP соединение), вы должны попросить у вашего сетевого системного администратора следующую информацию:

  • Имя вашей машины (возможно вы можете выбрать его самостоятельно).

  • Имя домена.

  • IP-адрес компьютера.

  • Маска сети.

  • IP-адрес шлюза по умолчанию, если в вашей сети есть такой шлюз.

  • Система в сети, которая используется как DNS (Domain Name Service) сервер.

С другой стороны, если администратор говорит, что существует DHCP сервер и рекомендуется использовать его для настройки, то вам не нужна вся эта информация, так как DHCP сервер передаст её вашему компьютеру автоматически во время процесса установки.

Если вы используете беспроводную сеть, то также нужно выяснить:

  • ESSID беспроводной сети.

  • WEP ключ безопасности (если он применяется).

Пред. | Уровень выше | След.
3.2. Сохраните ваши данные в надёжном месте! | Начало | 3.4. Минимальные требования к аппаратному обеспечению


3.4. Минимальные требования к аппаратному обеспечению
Пред. Глава 3. Перед установкой Debian GNU/Linux След.

3.4. Минимальные требования к аппаратному обеспечению

После сбора всей информации о компонентах компьютера, проверьте, что ваше аппаратное обеспечение соответствует требованиям желаемого типа установки.

В зависимости от потребностей, у вас может оказаться машина меньшей мощности, чем рекомендовано в таблице ниже. Однако, большинство пользователей рискуют оказаться расстроенными, если проигнорируют эти советы.

Минимальной рекомендуемой конфигурацией для настольной системыявляется машина с процессором Pentium 4, 1 ГГц.

Таблица 3.2. Рекомендуемые минимальные требования к системе

Тип установки | Память (минимум) | Память (рекомендуется) | Жёсткий диск
Без настольных приложений | 64 мегабайта | 256 мегабайт | 1 гигабайт
С настольными приложениями | 128 мегабайт | 512 мегабайт | 5 гигабайт

Реальное минимальное требование к размеру памяти намного меньше, чем указано в таблице. В зависимости от архитектуры, возможно установить Debian на имеющихся от 20МБ (для s390) до 60МБ (для amd64). То же самое можно сказать о требовании к дисковому пространству, особенно, если вы выбираете сами, какие приложения устанавливать; дополнительную информацию о требованиях к дисковому пространству смотрите в Раздел D.2, «Дисковое пространство, необходимое для задач».

Возможно запускать графическое окружение рабочего стола на старых или дешёвых машинах, в этом случае рекомендуется установить менеджер окон, который потребляет меньше ресурсов, чем окружения рабочего стола GNOME или KDE; здесь стоит упомянуть xfce4, icewm и wmaker, но есть и другие.

Практически невозможно указать требования к диску и памяти для установки серверной конфигурации, так как это в многом зависит от типа задач, выполняемых сервером.

Не забудьте, что в данные размеры не включены размеры файлы, которые обычно лежат на машине: файлы пользователя, почта и данные. Всегда нужно быть более щедрым, когда подсчитываешь место для своих файлов и данных.

Дисковое пространство, необходимое для гладкой работы в Debian GNU/Linux уже включено в рекомендуемые требования к системе. В частности, раздел /var содержит много специфичной для Debian информации, а также обычные данные типа журнальных файлов. Файлы dpkg (с информацией о всех установленных пакетах) могут легко занять 40МБ. apt-get также помещает сюда скачанные файлы перед их установкой. Обычно, требуется выделить по крайней мере 200МБ для /var и гораздо больше, если вы планируете установку графического окружения рабочего стола.

Пред. | Уровень выше | След.
3.3. Информация, которая понадобится | Начало | 3.5. Переразметка для мульти-загрузочных систем


3.5. Переразметка для мульти-загрузочных систем
Пред. Глава 3. Перед установкой Debian GNU/Linux След.

3.5. Переразметка для мульти-загрузочных систем

Разметка диска — это просто операция деления диска на секции. Каждая выделенная секция не зависит от других. Это, грубо говоря, как построить стены внутри дома; если вы добавите в одну комнату мебель, то это никак не повлияет на другие комнаты.

Если у вас на машине уже установлена операционная система (Windows 9x, Windows NT/2000/XP/2003/Vista/7, OS/2, MacOS, Solaris, FreeBSD, …) и вы хотите добавить Debian на тот же диск, то вам нужно его переразметить. Для Debian нужно создать отдельные разделы на жёстком диске. Он не может быть установлен на разделы Windows или MacOS. Он может совместно использовать некоторые разделы с другими системами Unix, но в этом руководстве это не описывается. Как минимум, вам нужно выделить место под корневой раздел Debian.

Вы можете найти информацию об имеющихся разделах с помощью инструментов разметки из имеющейся операционной системы, например, fdisk или PartitionMagic. Любая утилита разметки умеет показывать существующие разделы без их изменения.

Изменение раздела с уже имеющейся файловой системой уничтожит всю информацию на нём. То есть вы всегда должны сделать резервную копию всей информации перед переразметкой. Используя аналогию с домом, вы вероятно захотите вынести всю мебель перед переносом стен или же вы рискуете попортить её.

Если на вашем компьютере имеется более одного жёсткого диска, вы можете выделить один диск полностью под Debian. Если это так, то вам не нужно размечать диск перед загрузкой системы установки; программа установки содержит утилиту разметки, которая хорошо справляется со своей работой.

Если ваша машина содержит только один жёсткий диск и вы хотите заменить установленную операционную систему на Debian GNU/Linux, то также можете произвести разметку в процессе установки (Раздел 6.3.3, «Разметка разделов и выбор точек монтирования») после загрузки системы установки. Однако, это сработает только если вы планируете загружать программу установки с лент, CD-ROM или с удалённой машины. Учтите: если вы загружаетесь с раздела жёсткого диска и затем разметите этот жёсткий диск во время установки системы, то это удалит загрузочные файлы, и будем надеяться, что установка пройдёт с первого раза. Для этого случая вы должны иметь альтернативное средство оживить машину, например, с оригинальных системных установочных лент или CD.

Если на машине уже есть несколько разделов, а достаточное место может быть получено удалением или замещением одного или двух из них, то вы также можете отложить разметку до процедуры установки Debian. Тем не менее, вы всё равно должны дочитать этот материал до конца, так как могут встретиться необычные комбинации, типа соблюдения порядка существующих разделов в таблице разделов, что всё равно заставит вас переразмечать диск до запуска установки.

Если ваша машина содержит файловую систему FAT или NTFS, используемую DOS и Windows, то вы можете подождать и использовать утилиту разметки из программы установки Debian для изменения размера файловой системы.

Если ни один из описанных вариантов не подошёл, то вам нужно разметить диск перед запуском установки, чтобы выделить место под разделы Debian. Если некоторые разделы должны принадлежать другим операционным системам, то вы должны создать эти разделы с помощью программ разметки из этих операционных систем. Мы не рекомендуем пытаться создавать разделы Debian GNU/Linux с помощью утилит других операционных систем. Пользуйтесь ими только для создания разделов операционных систем, которые вы захотели оставить.

Если вы хотите установить более одной операционной системы на одну машину, то вы должны установить все операционные системы перед установкой Debian. Windows и другие ОС могут уничтожить возможность запуска Debian или посоветовать вам переформатировать все неизвестные для них разделы.

Вы можете устранить последствия таких действий или избежать их, но установка родной системы в первую очередь оградит вас от подобных проблем.

Если сейчас у вас один диск с одним разделом (обычное дело для настольных компьютеров) и вы хотите запускать родную систему и Debian, то вам нужно:

  1. Сделать резервную копию всех файлов компьютера.

  2. Загрузить программу установки родной операционной системы с CD-ROM или лент.

  3. С помощью родных утилит разметки создать родной системный раздел(ы). Оставить или раздел-пустышку, или свободное место для Debian GNU/Linux.

  4. Установить родную операционную систему в её новый раздел.

  5. Загрузиться в родную операционную систему и проверить, что всё хорошо, и загрузить файлы программы установки Debian.

  6. Загрузить программу установки Debian, чтобы продолжить установку Debian.

3.5.1. Разметка дисков из DOS или Windows

Если вы преобразуете существующие разделы FAT или NTFS, то рекомендуется или следование схеме, приведённой ниже или использование родных утилит Windows, или DOS. Иначе, нет никакой необходимости в разметке из DOS или Windows; утилиты разметки Debian обычно лучше подходят для этой работы.

Но если вы имеете большой IDE диск и не используете ни LBA адресацию, ни вспомогательный драйвер (иногда поставляемый производителями жёстких дисков ) или у вас не новый (после 1998 года) BIOS, который поддерживает расширенный доступ к большим дискам, то вы должны правильно разместить загрузочный раздел Debian. В этом случае нужно разместить загрузочный раздел на первых 1024 цилиндрах жёсткого диска (обычно это первые 524 мегабайта без трансляции BIOS). Для этого может потребоваться перемещение существующего раздела FAT или NTFS.

3.5.1.1. Переразметка без потерь при запуске из DOS, Win-32 или OS/2

Одна из наиболее распространённых установок: на машину, которая уже содержит DOS (включая Windows 3.1), Win32 (все Windows 95, 98, Me, NT, 2000, XP, 2003, Vista, 7) или OS/2, и желательно разместить Debian на том же диске без уничтожения предыдущей системы. Заметим, что программа установки поддерживает изменение размера файловых систем FAT и NTFS, используемых DOS и Windows. Просто запустите программу установки, выберите Вручную, изменяемый раздел и задайте новый размер. Поэтому в большинстве случаев вы не должны использовать метод, описываемый ниже.

Перед тем как что-то сделать дальше, вы должны решить как вы разделите диск. Метод в этом разделе описывает разделение только на две части. Одна будет содержать имеющуюся ОС, а другая будет использоваться для Debian. Во время установки Debian вам предоставят возможность выбора как использовать часть диска Debian, то есть, под раздел подкачки или в качестве файловой системы.

Идея в том, что перед изменением информации о разделах для того чтобы ничего не потерять переместить все данные в начало раздела. Важно сделать как можно меньшим промежуток между перемещаемыми данными и переразмечаемой областью, чтобы минимизировать вероятность того, что файл будет в конце раздела, а это уменьшает количество места, которое можно вычленить из раздела.

Во-первых, нужно скопировать fips. Распакуйте архив и скопируйте файлы RESTORRB.EXE, FIPS.EXE и ERRORS.TXT на загрузочную дискету. Загрузочную дискету можно создать с помощью команды sys a: из DOS. По fips есть хорошая документация, с которой не плохо было бы ознакомиться. Вам однозначно нужно прочитать её, если вы используете драйвер сжатия или дисковый менеджер. Создайте диск и прочитайте документацию перед дефрагментацией диска.

Далее, нужно переместить все данные в начало раздела. Стандартная команда defrag из DOS версии 6.0 и более поздней легко выполняет эту работу. Смотрите в документации к fips список других программ, которые делают тоже самое. Заметим, что если у вас Windows 9x, то вы должны запускать defrag из неё, так как DOS не понимает VFAT, который используется в Windows 95 и выше для поддержки длинных имён.

После завершения дефрагментации (которая занимает много времени на большом диске), перезагрузитесь с дискеты fips. Просто введите a:\fips и следуйте инструкциям.

Заметим, что существует много других менеджеров разделов, если fips чем-то не подошёл вам.

3.5.1.2. Разметка для DOS

Если вы делаете раздел для диска DOS или изменяете размер разделов DOS с помощью утилит Debian, надо сказать, что много людей испытывали проблемы при работе с получившимися разделами FAT. Например, некоторые рассказывали о плохой производительности, проблемах целостности с scandisk и других странных ошибках в DOS или Windows.

Очевидно, что при создании или изменении размера раздела для использования в DOS хорошей идеей будет заполнить несколько первых секторов нулями. Для этого, перед запуском DOS команды format, выполните следующую команду Debian:

# dd if=/dev/zero of=/dev/hdXX bs=512 count=4

Пред. | Уровень выше | След.
3.4. Минимальные требования к аппаратному обеспечению | Начало | 3.6. Настройка аппаратного обеспечения и операционной системы перед установкой


3.6. Настройка аппаратного обеспечения и операционной системы перед установкой
Пред. Глава 3. Перед установкой Debian GNU/Linux След.

3.6. Настройка аппаратного обеспечения и операционной системы перед установкой

В этом разделе описывается аппаратное обеспечение, для которого требуется настройка перед установкой Debian. Обычно, для этого производится проверка и возможно, изменение настроек микропрограммы вашей системы. «Микропрограмма (firmware)» — это программное обеспечение используемое аппаратным обеспечением; она почти всегда вызывается во время загрузки машины (после подачи питания). Здесь также описаны известные проблемы аппаратного обеспечения, которые влияют на надёжность Debian GNU/Linux.

3.6.1. Вызов меню настройки BIOS

В BIOS содержатся базовые функции загрузки машины, предоставляющие операционной системе доступ к оборудованию. Обычно, для настройки BIOS в машину встраивается меню. Перед установкой вы должны убедиться, что ваш BIOS корректно настроен; невыполнение этого может вызвать случайные сбои или невозможность установки Debian.

Остаток главы взят из http://www.faqs.org/faqs/pc-hardware-faq/part1/ и отвечает на вопрос, «Как мне войти в меню настройки CMOS?». Как получить доступ в меню настройки BIOS (или «CMOS»), зависит от производителя программы BIOS:

AMI BIOS

Клавиша Delete во время POST (power on self test, самотестирование при включении питания)

Award BIOS

Клавиши Ctrl+Alt+Esc или Delete во время POST

DTK BIOS

Клавиша Esc во время POST

IBM PS/2 BIOS

Ctrl+Alt+Insert после Ctrl+Alt+Delete

Phoenix BIOS

Ctrl+Alt+Esc или Ctrl+Alt+S или F1

Информацию о процедуре входа в другие BIOS можно найти в http://www.tldp.org/HOWTO/Hard-Disk-Upgrade/install.html.

Некоторые машины 32-bit PC не содержат меню настройки CMOS в BIOS. Им необходимо программное обеспечение для настройки CMOS. Если у вас нет установочной и/или диагностической дискеты для машины, можете попробовать использовать shareware/freeware программу. Попытайтесь поискать на ftp://ftp.simtel.net/pub/simtelnet/msdos/.

3.6.2. Выбор загрузочного устройства

Многие меню настройки BIOS позволяют выбрать устройство, с которого будет загружаться система. Настройте этот параметр так, чтобы сначала операционная система пыталась загрузиться с A: (первый дисковод гибких дисков), затем, необязательно, с привода CD-ROM (вероятно, называется D: или E:) и затем с C: (первый жёсткий диск). Такая настройка позволит вам загрузиться, или с дискеты, или с CD-ROM, которые являются двумя наиболее распространёнными загрузочными устройствами, используемыми для установки Debian.

Если у вас новый SCSI-контроллер и к нему подключён привод CD-ROM, то обычно, возможна загрузка с этого CD-ROM. Всё, что нужно сделать, это разрешить загрузку с CD-ROM в BIOS SCSI-контроллера.

Другой популярный параметр — загрузка с накопителя USB (также называемого как карта памяти USB или ключ USB). Некоторые BIOS могут загружать систему непосредственно с накопителя USB, а некоторые нет. Чтобы загрузиться с USB устройства вам может потребоваться настроить BIOS на загрузку с «Removable drive» или даже с «USB-ZIP».

Вот некоторые подробности о настройке порядка загрузки. Не забудьте изменить порядок после установки Linux на загрузку с жёсткого диска.

3.6.2.1. Изменение порядка загрузки на компьютерах с IDE

  1. Как только компьютер начнёт загружаться, нажмите клавишу для входа в BIOS. Часто это клавиша Delete. Однако, посмотрите в документации на компьютер, какие клавиши предназначены для этого.

  2. Найдите в меню порядок загрузки. Его местоположение зависит от BIOS, но обычно вам нужно искать поле со списком дисководов.

    Распространённые поля на машинах с IDE: C, A, cdrom или A, C, cdrom.

    C — это жёсткий диск, а A — дисковод гибких дисков.

  3. Измените порядок загрузки так, чтобы первой стояла загрузка с CD-ROM или дискет. Обычно, для этого используются клавиши Page Up или Page Down, которые по циклу перебирают возможные значения.

  4. Сохраните изменения. Как это сделать написано в подсказке на экране.

3.6.2.2. Изменение порядка загрузки на компьютерах со SCSI

  1. Как только компьютер начнёт загружаться, нажмите клавиши для входа в меню настройки SCSI.

    Вы можете войти в меню настройки SCSI после проверки памяти, а о том как это сделать, появляется подсказка на экране.

    Нужная комбинация клавиш зависит от контроллера. Часто, это Ctrl+F2. Однако, нужную комбинацию посмотрите в документации на аппаратуру.

  2. Найдите пункт изменения порядка загрузки.

  3. Настройте так, что SCSI ID привода компакт дисков был первым в списке.

  4. Сохраните изменения. Как это сделать написано в подсказке на экране. Обычно, вы должны нажать F10.

3.6.3. Другие настройки BIOS

3.6.3.1. Настройки CD-ROM

На некоторых системах BIOS (например, Award BIOS) позволяет автоматически выбирать скорость CD. Вы не должны делать этого и вместо этого выберите установку самой маленькой скорости. Если вы получаете сообщения об ошибке seek failed, вероятно, проблема в этом.

3.6.3.2. Расширенная и дополнительная память

Если ваша система предоставляет и расширенную (extended) и дополнительную (expanded) память, задайте, если возможно, чтобы было много расширенной и мало дополнительной памяти. Linux нужна расширенная память и он не использует дополнительную память.

3.6.3.3. Защита от вирусов

Выключите в BIOS любые антивирусные предупреждения. Если у вас плата с антивирусной защитой или другое специальное оборудование, убедитесь, что оно выключено или физически удалено при работе GNU/Linux. Оно не совместимо с GNU/Linux; более того, из-за файловой системы с разграничением доступа и с защищённой памятью ядра Linux, про вирусы практически ничего не слышно[5].

3.6.3.4. Shadow RAM

Материнская плата может предоставлять shadow RAM или кэширование BIOS. Эта настройка может выглядеть как «Video BIOS Shadow», «C800-CBFF Shadow» и т.д.. Выключите её. Shadow RAM использовалась для ускорения доступа к ПЗУ материнской платы и к некоторым контроллерам. Linux не использует эти ПЗУ после того как загрузится, так как он предоставляет свой быстрый 32-битный программный доступ вместо 16-битных программ из ПЗУ. Выключение shadow RAM может привести к появлению большей свободной памяти для программ. Оставление включённой shadow RAM может мешать Linux при доступе к аппаратуре.

3.6.3.5. Memory Hole

Если BIOS предлагает что-то типа «15–16 MB Memory Hole», выключите это. Linux найдёт эту память, если она есть.

Нам сообщили о материнских платах Intel Endeavor, на которых есть опция называемая «LFB» или «Linear Frame Buffer». Она может принимать значения «Disabled» и «1 Megabyte». Установите в «1 Megabyte». Если она выключена, установочные дискеты читаются неправильно, и следовательно система не работает. На момент написания руководства, мы не поняли, что именно происходит с этим устройством — оно просто работает с этим значением, а может и без него.

3.6.3.6. Усовершенствованное управление питанием (Advanced Power Management)

Если материнская плата предоставляет усовершенствованное управление питанием (APM), настройте его так, чтобы питание управлялось APM. Выключите режимы doze, standby, suspend, nap и sleep, и запретите отключение питания жёсткого диска по таймеру. Linux может сам управлять этими режимами, и делает это лучше чем BIOS.

3.6.4. Аппаратные проблемы, которых нужно остерегаться

Поддержка USB в BIOS и клавиатуры. Если в имеете клавиатуру не AT, а только USB модель, то вам может потребоваться включить эмуляцию старых(legacy) AT клавиатур в настройках BIOS. Сделайте это только после того как система установки не сможет использовать клавиатуру в USB режиме. И наоборот, для некоторых систем (особенно ноутбуки) вам может потребоваться запретить эмуляцию, если клавиатура не работает. Посмотрите руководство к материнской плате и найдите параметры в BIOS «Legacy keyboard emulation» или «USB keyboard support».

[5] После установки вы можете включить защиту загрузочного сектора, если хотите. Это не добавит безопасности в Linux, но если вы также запускаете Windows, то может предотвратить катастрофу. Не нужно изменять главную загрузочную запись (MBR) после настройки системного загрузчика.

Пред. | Уровень выше | След.
3.5. Переразметка для мульти-загрузочных систем | Начало | Глава 4. Получение носителя с дистрибутивом


Глава 4. Получение носителя с дистрибутивом
Пред. След.

Глава 4. Получение носителя с дистрибутивом

Содержание

4.1. Официальный набор компакт-дисков Debian GNU/Linux
4.2. Скачивание файлов с серверов-зеркал Debian
4.2.1. Где искать установочные образы
4.3. Подготовка файлов для загрузки с карты памяти USB
4.3.1. Preparing a USB stick using a hybrid CD or DVD image
4.3.2. Manually copying files to the USB stick
4.3.3. Manually copying files to the USB stick — the flexible way
4.4. Подготовка файлов для загрузки с жёсткого диска
4.4.1. Загрузка программы установки с жёсткого диска с помощью LILO или GRUB
4.4.2. Загрузка программы установки с жёсткого диска с помощью loadlin
4.5. Подготовка файлов для загрузки по TFTP
4.5.1. Настройка DHCP сервера
4.5.2. Настройка BOOTP сервера
4.5.3. Включение TFTP сервера
4.5.4. Копирование TFTP образов в каталог TFTP сервера
4.6. Автоматическая установка
4.6.1. Автоматическая установка с помощью программы установки Debian
Пред. |  | След.
3.6. Настройка аппаратного обеспечения и операционной системы перед установкой | Начало | 4.1. Официальный набор компакт-дисков Debian GNU/Linux


4.1. Официальный набор компакт-дисков Debian GNU/Linux
Пред. Глава 4. Получение носителя с дистрибутивом След.

4.1. Официальный набор компакт-дисков Debian GNU/Linux

Самым лёгким путём установки Debian GNU/Linux является установка с официального набора компакт-дисков Debian (смотрите страницу продавцов компакт-дисков Debian). Также, вы можете загрузить образы компакт-дисков с сервера-зеркала Debian и сделать из них набор самостоятельно, если у вас есть высокоскоростное подключение к сети и устройство записи компакт-дисков (подробные инструкции смотрите на странице Debian GNU/Linux на компакт-дисках). Если у вас есть официальный набор компакт-дисков Debian и машина способна загружаться с привода CDROM, то вы можете сразу перейти к Глава 5, Загрузка системы установки; много усилий было потрачено, чтобы добиться того, чтобы файлы на этих дисках стали полезными большому числу людей. Хотя полный набор готовых пакетов умещается на нескольких дисках, вряд ли вам понадобятся пакеты, расположенные на третьем и последующих дисках. Также вы можете подумать над использованием DVD версии, так как это сохранит место на вашей полке и вы избежите частой смены компакт-дисков в приводе.

Если машина не поддерживает загрузку с компакт-диска, а вы имеете набор CD, то для загрузки программы установки можно воспользоваться другим методом, например, загрузить ядро с жёсткого диска, с карт памяти usb, по сети, или вручную с CD. Для этого на компакт-диске есть все файлы; структура архива Debian в сети и каталогов CD идентичны. Поэтому, когда ниже встречаются пути к файлам в архиве, которые требуются для определённого вида загрузки, поищите эти файлы в тех же каталогах и подкаталогах на ваших CD.

После загрузки программы установки, можно будет загрузить все остальные файлы с компакт-дисков.

Если у вас нет набора CD, то вам потребуется загрузить системные файлы программы установки и сохранить их на жёсткий диск, или карте памяти usb, или подключённый к сети компьютер и использовать их для загрузки программы установки.

Пред. | Уровень выше | След.
Глава 4. Получение носителя с дистрибутивом | Начало | 4.2. Скачивание файлов с серверов-зеркал Debian


4.2. Скачивание файлов с серверов-зеркал Debian
Пред. Глава 4. Получение носителя с дистрибутивом След.

4.2. Скачивание файлов с серверов-зеркал Debian

Ближайший (и поэтому, вероятно, самый быстрый) к вам сервер-зеркало можно найти в списке серверов-зеркал Debian.

При скачивании файлов с сервера-зеркала Debian по протоколу FTP проверьте, что загружаете файлы в двоичном, а не текстовом или автоматическом режиме.

4.2.1. Где искать установочные образы

Установочные образы на сервере-зеркале Debian находятся в каталоге debian/dists/squeeze/main/installer-i386/current/images/ — в файле MANIFEST описано для чего предназначен каждый образ.

Пред. | Уровень выше | След.
4.1. Официальный набор компакт-дисков Debian GNU/Linux | Начало | 4.3. Подготовка файлов для загрузки с карты памяти USB


4.3. Подготовка файлов для загрузки с карты памяти USB
Пред. Глава 4. Получение носителя с дистрибутивом След.

4.3. Подготовка файлов для загрузки с карты памяти USB

Для подготовки карты памяти USB вам нужна работающая система GNU/Linux с поддержкой USB. В этой системе карта памяти USB должна автоматически распознаваться при вставке. Если нет, то убедитесь, что загружен модуль ядра usb-storage. Когда USB-карта вставлена, то она доступна в системе как устройство с именем /dev/sdX, где «X» — это буква из диапазона a-z. Вы можете определить, какое устройство появилось после вставке карты USB запустив команду dmesg. Также выключите защиту от записи на карту.

Внимание

Процедура, описанная в этом разделе, уничтожит все данные на устройстве! Не ошибитесь в названии устройства карты памяти USB. Если вы укажите не то устройство, это может привести к полной потере информации где-то ещё, например, на жёстком диске.

4.3.1. Preparing a USB stick using a hybrid CD or DVD image

Debian CD and DVD images can now be written directly a USB stick, which is a very easy way to make a bootable USB stick. Simply choose a CD or DVD image that will fit on your USB stick. See Раздел 4.1, «Официальный набор компакт-дисков Debian GNU/Linux» to get a CD or DVD image.

Alternatively, for very small USB sticks, only a few megabytes in size, you can download the mini.iso image from the netboot directory (at the location mentioned in Раздел 4.2.1, «Где искать установочные образы»). [6]

The CD or DVD image you choose should be written directly to the USB stick, overwriting its current contents. For example, when using an existing GNU/Linux system, the CD or DVD image file can be written to a USB stick as follows:

# cat debian.iso > /dev/sdX
# sync

4.3.2. Manually copying files to the USB stick

An alternative way to set up your USB stick is to manually copy the installer files, and also a CD image to it. Note that the USB stick should be at least 256 MB in size (smaller setups are possible if you follow Раздел 4.3.3, «Manually copying files to the USB stick — the flexible way»).

Существует файл "всё-в-одном" — hd-media/boot.img.gz, который содержит все файлы программы установки (включая ядро) , а также syslinux и его файл настройки .

Заметим, что хотя этот метод удобен, он имеет большой недостаток: логический размер устройства ограничен 256 МБ, даже если ёмкость карты памяти USB гораздо больше. Вам нужно переразметить карту USB и создать новые файловые системы, чтобы снова получить всё пространство, если вы хотите использовать его для другой цели. Вторым недостатком является то, что вы не можете скопировать полный CD-образ на карту памяти USB,а только CD-образы меньшего размера, например businesscard или netinst.

Чтобы использовать образ, просто распакуйте его прямо на карту памяти USB:

# zcat boot.img.gz > /dev/sdX

После этого, смонтируйте карту памяти USB (mount /dev/sdX /mnt), которая теперь имеет файловую систему FAT и скопируйте на неё ISO-образ Debian netinst или businesscard. Размонтируйте устройство (umount /mnt) и всё готово.

4.3.3. Manually copying files to the USB stick — the flexible way

Если вам хочется большей гибкости или вы просто хотите знать, что на самом деле происходит, то можете воспользоваться следующим методом записи файлов на карту памяти. Преимущество использования этого метода в том, что если ёмкость карты USB достаточно велика, то вы можете скопировать на неё полный образ CD ISO.

4.3.3.1. Разметка карты памяти USB

Мы покажем как использовать на карте памяти только первый раздел, а не всё устройство.

Замечание

Так как большинство карт памяти USB продаются с единственным разделом FAT16, то вам, вероятно, не хочется переразмечать или переформатировать устройство. Если вам всё равно это нужно сделать, воспользуйтесь cfdisk или любой другой утилитой разметки для создания раздела FAT16[7], а затем создайте файловую систему:

# mkdosfs /dev/sdX1

Обязательно вводите правильное имя устройства карты памяти USB. Команда mkdosfs содержится в пакете Debian dosfstools.

Для запуска ядра после загрузки с карты памяти USB, мы поместим на неё системный загрузчик. Хотя должен работать любой системный загрузчик (например, lilo), удобнее использовать syslinux, так как он использует раздел FAT16 и настраивается простым редактированием текстового файла. Для настройки системного загрузчика можно использовать любую операционную систему, которая поддерживает файловую систему FAT.

Чтобы поместить syslinux на раздел FAT16 карты памяти USB, установите в систему пакеты syslinux и mtools и введите

# syslinux /dev/sdX1

Ещё раз отметим: не ошибитесь в имени устройства. Раздел не должен быть смонтирован при запуске syslinux. Эта процедура записывает загрузочный сектор раздела и создаёт файл ldlinux.sys, который содержит код системного загрузчика.

4.3.3.2. Добавление образа программы установки

Смонтировав раздел (mount /dev/sdX1 /mnt), скопируйте следующие файлы образа программы установки на карту памяти:

  • vmlinuz или linux (файл ядра)

  • initrd.gz (образ ramdisk)

Вы можете выбрать обычную версию программ установки или версию с графическим интерфейсом. Последнюю можно найти в подкаталоге gtk. Если вы хотите переименовать файлы, учтите, что syslinux работает только с файловыми именами DOS (8.3).

Затем, вам нужно создать файл настройки syslinux.cfg, который, как минимум содержит две строки (измените имя файла с ядром на «linux», если используется образ netboot):

default vmlinuz
append initrd=initrd.gz

Для графической версии программы установки нужно добавить vga=788 во вторую строку.

Если вы используете образ hd-media, то теперь должны скопировать ISO-образ Debian[8] на карту памяти. После завершения, размонтируйте карту памяти USB (umount /mnt).

[6] A special method can be used to add firmware to the mini.iso. First, write the mini.iso to the USB stick. Next obtain the necessary firmware files. See Раздел 6.4, «Загрузка отсутствующих микропрограмм» for more information about firmware. Now unplug and replug the USB stick, and two partitions should now be visible on it. You should mount the second of the two partitions, and unpack the firmware onto it.

# mount /dev/sdX2 /mnt
# cd /mnt
# tar zxvf /путь/к/firmware.tar.gz
# cd /
# umount

[7] Не забудьте установить флаг загрузки «bootable».

[8] Вы можете использовать businesscard, netinst или полный образ CD (см. Раздел 4.1, «Официальный набор компакт-дисков Debian GNU/Linux»). Убедитесь, что он подходит по размеру. Заметим, что образ «netboot mini.iso» не подходит для этой цели.

Пред. | Уровень выше | След.
4.2. Скачивание файлов с серверов-зеркал Debian | Начало | 4.4. Подготовка файлов для загрузки с жёсткого диска


4.4. Подготовка файлов для загрузки с жёсткого диска
Пред. Глава 4. Получение носителя с дистрибутивом След.

4.4. Подготовка файлов для загрузки с жёсткого диска

Программа установки может быть загружена из файлов, размещённых на существующем разделе жёсткого диска, или запущена из другой операционной системы или вызовом системного загрузчика прямо из BIOS.

«Полностью сетевой» установки можно достичь с помощью этой техники. Она позволяет избежать всех неприятностей со сменными носителями, например, поиск и прожиг CD образов или борьбы с кучей нечитаемых дискет.

4.4.1. Загрузка программы установки с жёсткого диска с помощью LILO или GRUB

Этот раздел описывает как добавить или даже заменить существующую установку linux с помощью LILO или GRUB.

Во время загрузки оба системных загрузчика способны загружать в память не только ядро, но и образ диска. Этот RAMdisk может использоваться ядром в качестве корневой файловой системы.

Скопируйте следующие файлы из архива Debian в любое место на жёстком диске (заметим, что загрузчик LILO не способен загружать файлы из файловой системы NTFS), например, в /boot/newinstall/.

  • vmlinuz (файл ядра)

  • initrd.gz (образ ramdisk)

Настройте системный загрузчик следуя указаниям Раздел 5.1.4, «Загрузка из Linux с помощью LILO или GRUB».

4.4.2. Загрузка программы установки с жёсткого диска с помощью loadlin

Этот раздел описывает как подготовить жёсткий диск для загрузки программы установки из DOS с помощью loadlin.

Скопируйте следующие каталоги из образа Debian CD на c:\.

  • /install.386 (файл ядра и образ ramdisk)

  • /tools (утилита loadlin)

Пред. | Уровень выше | След.
4.3. Подготовка файлов для загрузки с карты памяти USB | Начало | 4.5. Подготовка файлов для загрузки по TFTP


4.5. Подготовка файлов для загрузки по TFTP
Пред. Глава 4. Получение носителя с дистрибутивом След.

4.5. Подготовка файлов для загрузки по TFTP

Если ваша машина подключена к локальной сети, то вы можете загрузить её по сети с другой машины через TFTP. Для этого на удалённую машину в определённое место вам нужно поместить загрузочные файлы и настроить поддержку загрузки вашей машины.

Вам нужно настроить TFTP сервер, а если машин много, то DHCP сервер .

BOOTP — это IP протокол, который информирует компьютер о его IP-адресе и где в сети получить загрузочный образ. DHCP (Dynamic Host Configuration Protocol) более гибок и обратно совместим с BOOTP. Некоторые системы могут быть настроены только через DHCP.

Trivial File Transfer Protocol (TFTP) используется для загрузки загрузочного образа на клиентскую машину. Теоретически, можно использовать любой сервер на любой платформе, которая реализует эти протоколы. В примерах этого раздела мы используем команды из SunOS 4.x, SunOS 5.x (так называемый Solaris) и GNU/Linux.

Замечание

Для сервера Debian GNU/Linux мы рекомендуем tftpd-hpa. Он написан автором системного загрузчика syslinux и поэтому, скорее всего, не вызовет проблем. Также неплох atftpd.

4.5.1. Настройка DHCP сервера

Одним из свободных DHCP серверов является ISC dhcpd. В Debian GNU/Linux он доступен из пакета dhcp3-server. Вот пример его конфигурационного файла (обычно /etc/dhcp3/dhcpd.conf):

option domain-name "example.com";
option domain-name-servers ns1.example.com;
option subnet-mask 255.255.255.0;
default-lease-time 600;
max-lease-time 7200;
server-name "servername";

subnet 192.168.1.0 netmask 255.255.255.0 {
  range 192.168.1.200 192.168.1.253;
  option routers 192.168.1.1;
}

host clientname {
  filename "/tftpboot.img";
  server-name "servername";
  next-server servername;
  hardware ethernet 01:23:45:67:89:AB;
  fixed-address 192.168.1.90;
}

В этом примере определён единственный сервер servername, который работает в качестве DHCP, TFTP серверов и шлюза сети. Вам почти наверняка нужно изменить опцию domain-name, а также имя сервера и аппаратный адрес клиента. Опция filename должна содержать имя файла, который нужно получить по TFTP.

После редактирования конфигурационного файла для dhcpd, перезагрузите сервер командой /etc/init.d/dhcp3-server restart.

4.5.1.1. Включение загрузки PXE в конфигурацию DHCP

Вот другой пример dhcp.conf, который можно использовать, если включён метод предстартового выполнения среды (PXE) по TFTP.

option domain-name "example.com";

default-lease-time 600;
max-lease-time 7200;

allow booting;
allow bootp;

# нужно изменить согласно вашим настройкам
subnet 192.168.1.0 netmask 255.255.255.0 {
  range 192.168.1.200 192.168.1.253;
  option broadcast-address 192.168.1.255;
# адрес шлюза, который может быть другим
# (для доступа в интернет, например)
  option routers 192.168.1.1;
# используемый dns
  option domain-name-servers 192.168.1.3;
}

group {
 next-server 192.168.1.3;
 host tftpclient {
# аппаратный адрес клиента tftp
  hardware ethernet  00:10:DC:27:6C:15;
  filename "/pxelinux.0";
 }
}

Заметим, что для PXE загрузки в filename клиента pxelinux.0 записан системный загрузчик, а не образ ядра (смотрите ниже Раздел 4.5.4, «Копирование TFTP образов в каталог TFTP сервера»).

4.5.2. Настройка BOOTP сервера

Для GNU/Linux есть два BOOTP сервера. Первый — CMU bootpd. Второй, на самом деле являющийся сервером DHCP — ISC dhcpd. В Debian GNU/Linux они находятся в пакетах bootp и dhcp3-server соответственно.

Чтобы использовать CMU bootpd, во-первых, вы должны раскомментировать (или добавить) соответствующую строку в /etc/inetd.conf. Для этого в Debian GNU/Linux вы можете запустить update-inetd --enable bootps, затем /etc/init.d/inetd reload. Если BOOTP сервер работает не под Debian, то строка выглядит так:

bootps  dgram  udp  wait  root  /usr/sbin/bootpd  bootpd -i -t 120

Теперь вы должны создать файл /etc/bootptab. Внутри он напоминает хорошо знакомый и загадочный формат старых добрых BSD файлов printcap, termcap и disktab. Подробности смотрите в справочной странице bootptab. Для CMU bootpd вам нужно знать аппаратный адрес (MAC) клиента. Вот пример /etc/bootptab:

client:\
  hd=/tftpboot:\
  bf=tftpboot.img:\
  ip=192.168.1.90:\
  sm=255.255.255.0:\
  sa=192.168.1.1:\
  ha=0123456789AB:

Вам нужно изменить, по крайней мере, параметр «ha», который содержит аппаратный адрес клиента. Параметр «bf» содержит файл, который клиент должен получить по TFTP; подробности смотрите в Раздел 4.5.4, «Копирование TFTP образов в каталог TFTP сервера».

Напротив, настройка BOOTP в ISC dhcpd очень проста, так как здесь клиенты BOOTP считаются одним из вариантов клиентов DHCP. Некоторые архитектуры требуют сложной настройки для загрузки клиентов по BOOTP. Если у вас один из таких случаев, прочитайте раздел Раздел 4.5.1, «Настройка DHCP сервера». Если нет, то достаточно просто добавить директиву allow bootp в блок настройки подсети, содержащей клиента, в /etc/dhcp3/dhcpd.confи перезапустить dhcpd командой /etc/init.d/dhcp3-server restart.

4.5.3. Включение TFTP сервера

Чтобы сервер TFTP заработал, во-первых нужно проверить что включена tftpd.

Программа tftpd-hpa может быть запущена двумя способами. Она может запускаться по требованию службой inetd, или может быть настроена для работы как независимая служба. Выбор метода происходит при при установке пакета, и его можно изменить через перенастройку пакета.

Замечание

Исторически, TFTP-серверы используют каталог /tftpboot для хранения образов. Однако, пакеты Debian GNU/Linux могут использовать другие каталоги, чтобы соответствовать Filesystem Hierarchy Standard. Например, tftpd-hpa по умолчанию использует /srv/tftp. Вам может потребоваться изменить примеры конфигурации для соответствия.

По умолчанию, все альтернативные программы in.tftpd, доступные в Debian, протоколируют запросы TFTP в системный журнал. Некоторые из них имеют параметр -v, позволяющий включить более подробный протокол. Рекомендуется проверить эти сообщения в журнале в случае возникновения проблем с загрузкой; это хорошая отправная точка при поиске причин ошибок.

4.5.4. Копирование TFTP образов в каталог TFTP сервера

Далее, поместите нужный загрузочный образ TFTP из Раздел 4.2.1, «Где искать установочные образы» в каталог загрузочных образов tftpd. Вы можете сделать ссылку на этот файл для файла, который tftpd будет передавать для загрузки определённому клиенту. К сожалению, имя файла зависит от клиента TFTP и никак не стандартизовано.

Для загрузки через PXE, всё что нужно лежит в файле netboot/netboot.tar.gz. Просто распакуйте этот файл в каталог загрузочных образов tftpd. Убедитесь, что dhcp сервер передаёт pxelinux.0 команде tftpd в качестве имени загружаемого файла.

Пред. | Уровень выше | След.
4.4. Подготовка файлов для загрузки с жёсткого диска | Начало | 4.6. Автоматическая установка


4.6. Автоматическая установка
Пред. Глава 4. Получение носителя с дистрибутивом След.

4.6. Автоматическая установка

Для установки на несколько компьютеров можно воспользоваться полностью автоматической установкой. Необходимые пакеты Debian: fai-quickstart (используется сервером установки) и сама программа установки Debian. Подробная информация представлена на домашней странице FAI.

4.6.1. Автоматическая установка с помощью программы установки Debian

Программа установки Debian поддерживает автоматическую установку через файлы автоматической установки. Файл автоматической установки может быть загружен по сети или со сменного носителя, и используется для ответов на вопросы, задаваемые во время процесса установки.

Полную документацию по автоматической установке и рабочий пример, который вы можете отредактировать, находится в Приложение B, Автоматическая установка с помощью списка ответов.

Пред. | Уровень выше | След.
4.5. Подготовка файлов для загрузки по TFTP | Начало | Глава 5. Загрузка системы установки


Глава 5. Загрузка системы установки
Пред. След.

Глава 5. Загрузка системы установки

Содержание

5.1. Запуск программы установки на 32-bit PC
5.1.1. Загрузка с CD-ROM
5.1.2. Загрузка из Windows
5.1.3. Загрузка из DOS
5.1.4. Загрузка из Linux с помощью LILO или GRUB
5.1.5. Загрузка с карты памяти USB
5.1.6. Загрузка по TFTP
5.1.7. Экран запуска
5.2. Лёгкость управления
5.2.1. USB-дисплеи Брайля
5.2.2. Дисплеи Брайля, подключаемые к последовательному порту
5.2.3. Устройства речевого синтеза
5.2.4. Встраиваемые устройства
5.2.5. Тема с высокой контрастностью
5.3. Параметры загрузки
5.3.1. Параметры программы установки Debian
5.3.2. Использование параметров загрузки для ответов на вопросы
5.3.3. Передача параметров модулям ядра
5.3.4. Внесение модулей ядра в чёрный список
5.4. Диагностика проблем процесса установки
5.4.1. Надёжность CD-ROM
5.4.2. Настройка загрузки
5.4.3. Распространённые проблемы установки на 32-bit PC
5.4.4. Интерпретация загрузочных сообщений ядра
5.4.5. Сообщение о проблемах при установке
5.4.6. Отправка отчётов об ошибках установки
Пред. |  | След.
4.6. Автоматическая установка | Начало | 5.1. Запуск программы установки на 32-bit PC


5.1. Запуск программы установки на 32-bit PC
Пред. Глава 5. Загрузка системы установки След.

5.1. Запуск программы установки на 32-bit PC

Внимание

Если у вас уже установлены другие операционные системы и их нужно сохранить (настроить двойную загрузку), перед тем как загружать программу установки убедитесь, что они были полностью выключены. Установка операционной системы в то время как другая операционная система находится в режиме "спячки" (была выполнена приостановка с сохранением состояния на диск) может привести к потере или повреждению состояния приостановленной системы, вследствие чего могут возникнуть проблемы при её перезагрузке.

Замечание

О том, как запустить программу установки с графическим интерфейсом смотрите Раздел D.6, «Программа установки с графическим интерфейсом».

5.1.1. Загрузка с CD-ROM

Для большинства пользователей проще всего будет использовать набор компакт-дисков Debian. Если у вас есть набор компакт-дисков и ваш компьютер поддерживает загрузку с компакт-диска, прекрасно! Просто настройте ваш компьютер для загрузки с компакт-диска как описано в Раздел 3.6.2, «Выбор загрузочного устройства», вставьте компакт-диск, перезагрузите компьютер и переходите к следующей главе.

Заметим, что некоторым приводам компакт-дисков нужны специальные драйверы и поэтому, они недоступны на ранних стадиях установки. Если производимая стандартная последовательность загрузки с CD не работает, обратитесь к этой главе снова и прочитайте об альтернативных ядрах и методах установки, которые доступны для вашей машины.

Даже если не удалось загрузиться с CD-ROM, вероятно, вы ещё сможете установить с CD-ROM компоненты Debian и пакеты. Просто загрузитесь с другого носителя, например, с дискет. Когда придёт время установки операционной системы, базовой системы или дополнительных пакетов, укажите программе установки на привод CD-ROM.

При возникновении проблем с загрузкой смотрите Раздел 5.4, «Диагностика проблем процесса установки».

5.1.2. Загрузка из Windows

Для запуска программы установки из Windows, сначала вы должны получить установочный носитель CD-ROM/DVD-ROM или карту памяти USB как описано вРаздел 4.1, «Официальный набор компакт-дисков Debian GNU/Linux» и Раздел 4.3, «Подготовка файлов для загрузки с карты памяти USB».

Если это CD-ROM или DVD-ROM, то после вставки диска, программа должна запуститься автоматически. Если Windows не запустила её, или у вас карта памяти USB, то вы можете сделать это вручную, открыв устройство и запустив setup.exe.

Когда программа запустится, будет задано несколько предварительных вопросов, и система будет подготовлена для запуска программы установки Debian GNU/Linux.

5.1.3. Загрузка из DOS

Загрузите DOS (не из Windows). Для этого вы можете использовать диск восстановления или диагностики.

Если вы можете работать с установочным CD, измените текущий диск на устройство CD-ROM, например

d:

, а также убедитесь, что доступен ранее подготовленный жёсткий диск (Раздел 4.4.2, «Загрузка программы установки с жёсткого диска с помощью loadlin»), и измените текущий диск на его, если потребуется.

Войдите в подкаталог выбранного вами типа, например,

cd \install.386

Если вы хотите использовать графический интерфейс к программе установки, то войдите в подкаталог gtk.

cd gtk

Затем запустите install.bat. Будет загружено ядро и запущена система установки.

5.1.4. Загрузка из Linux с помощью LILO или GRUB

Для загрузки программы установки с жёсткого диска у вас уже должны быть полностью полученные и размещённые на диске необходимые файлы (смотрите Раздел 4.4, «Подготовка файлов для загрузки с жёсткого диска»).

Если вы намереваетесь использовать жёсткий диск только для загрузки, а затем выполнять установку по сети, то вы должны скачать файл netboot/debian-installer/i386/initrd.gz и соответствующее ему ядро netboot/debian-installer/i386/linux. Это позволит вам переразметить жёсткий диск с которого вы загрузились, хотя вы должны делать это осторожно.

Или же, если вы намереваетесь сохранить существующий раздел жёсткого диска неизменным во время установки, то можете скачать файл hd-media/initrd.gz и ядро, а также скопировать файл образа CD (или DVD) на жёсткий диск (проверьте, что имя заканчивается на .iso). Затем программу установки можно загрузить с диска и установить из образа CD/DVD без использования сети.

В LILO нужно настроить две важные вещи в файле /etc/lilo.conf:

  • загружать программу установки из initrd.gz;

  • ядро vmlinuz использует RAM диск в качестве корневого раздела.

Вот пример /etc/lilo.conf:

image=/boot/newinstall/vmlinuz
       label=newinstall
       initrd=/boot/newinstall/initrd.gz

Подробней смотрите на страницах руководства initrd(4) и lilo.conf(5). Теперь запустите lilo и перезагрузите машину.

Процедура для GRUB очень похожа. Найдите файл menu.lst в каталоге /boot/grub/ (или иногда в /boot/boot/grub/) и добавьте запись для программы установки, например (предполагается, что /boot находится на первом разделе первого жёсткого диска системы):

title  New Install
root   (hd0,0)
kernel /boot/newinstall/vmlinuz
initrd /boot/newinstall/initrd.gz

В дальнейшем нет никакой разницы между GRUB или LILO.

5.1.5. Загрузка с карты памяти USB

Предположим, что вы уже приготовили всё как написано в Раздел 3.6.2, «Выбор загрузочного устройства» и Раздел 4.3, «Подготовка файлов для загрузки с карты памяти USB». Теперь вставьте карту памяти USB в свободное USB гнездо и перезагрузите компьютер. Система должна загрузиться и вы должны увидеть приглашение boot:. Здесь вы можете ввести необязательные параметры загрузки, или просто нажать Enter.

5.1.6. Загрузка по TFTP

Загрузка по сети требует наличия сетевого подключения и сетевого загрузочного сервера TFTP (DHCP, RARP или BOOTP).

Метод установки с загрузкой из сети описан в Раздел 4.5, «Подготовка файлов для загрузки по TFTP».

Есть несколько возможностей выполнить загрузку по TFTP на i386.

5.1.6.1. Сетевая карта или материнская плата с поддержкой PXE

Возможно, ваша сетевая карта (NIC) или материнская плата предоставляют возможность загрузки через PXE. Так названа реализация TFTP загрузки от компании Intel™. В этом случае вы можете настроить BIOS на загрузку по сети.

5.1.6.2. Сетевая карта с сетевым BootROM

Возможно, что сетевая карта (NIC) предоставляет возможность загрузки по TFTP.

5.1.6.3. Etherboot

Проект etherboot предоставляет загрузочные дискеты и даже прошивки (bootrom) для TFTPboot.

5.1.7. Экран запуска

В самом начале загрузки программы установки на экране появится логотип Debian и меню:

Installer boot menu

Install
Graphical install
Advanced options       >
Help

Press ENTER to boot or TAB to edit a menu entry

В зависимости от используемого метода установки, пункт «Graphical install» может быть недоступен.

Для обычной установки выберите «Install» или «Graphical install» с помощью клавиш со стрелками на клавиатуре или нажав первую (выделенную) букву, и нажмите Enter для запуска программы установки.

Пункт «Advanced options» выводит второе меню, которое позволяет запускать программу установки в экспертном режиме, в режиме восстановления и для автоматизации установки.

Если вы хотите добавить какие-то параметры загрузки для программы установки или ядра, то нажмите Tab. После этого будет показана команда загрузки по умолчанию для выбранного пункта меню, и можно будет ввести дополнительные параметры. В экранной справке (смотрите далее) можно найти описание общих параметров. Нажмите Enter для загрузки программы установки с вашими параметрами; чтобы вернуться в загрузочное меню и отменить любые сделанные вами изменения, нажмите Esc.

Выбрав пункт «Help», можно увидеть первый справочный экран, на котором дано краткое описание всех доступных справочных экранов. Заметим, что после перехода к справочным экранам, невозможно вернуться в загрузочное меню. Однако, справочные экраны по F3 и F4 описывают команды, которые эквивалентны методам загрузки, имеющимся в меню. Все справочные экраны имеют приглашение к загрузке, в котором можно набрать команду загрузки:

Press F1 for the help index, or ENTER to boot:

В приглашении к загрузке, вы можете просто нажать Enter для запуска программы установки с параметрами по умолчанию, или ввести специальную команду загрузки и параметры к ней. Различные загрузочные параметры можно найти на справочных экранах. Если вы добавляете какой-то параметр в командную строку загрузки, убедитесь, что сперва указан метод загрузки (по умолчанию install), и есть пробел перед первым параметром (например, install fb=false).

Замечание

По умолчанию предполагается, что используется клавиатура с раскладкой американского английского. Это означает, что если клавиатура имеет другую (языковую) раскладку, то при вводе параметров на экране могут появляться не те символы, которых вы ожидаете. В Wikipedia есть картинка американской раскладки клавиатуры, которую можно использовать для поиска нужных клавиш.

Замечание

Если вы используете компьютер, в котором из BIOS настроена работа через последовательную консоль, то вы можете не увидеть начальную графическую заставку на экране при запуске программы установки; вы даже можете не увидеть загрузочное меню. Это же может случиться, если вы устанавливаете систему через удалённое устройство управления, которое предоставляет текстовый интерфейс на VGA консоли. К таким устройствам относятся текстовые консоли Compaq «integrated Lights Out» (iLO) и HP «Integrated Remote Assistant» (IRA).

Чтобы пропустить графическую заставку загрузки вы можете вслепую нажать Esc и получить текстовое приглашение к загрузке, или (также вслепую) нажать «H» и Enter для выбора пункта «Help», описанного ранее. После этого, вы должны видеть то, что набираете. Чтобы программа установки не использовала фрейм-буфер для дальнейшей установки, также вам нужно добавить в приглашение к загрузке параметр vga=normal fb=false, который описан в справке.

Пред. | Уровень выше | След.
Глава 5. Загрузка системы установки | Начало | 5.2. Лёгкость управления


5.2. Лёгкость управления
Пред. Глава 5. Загрузка системы установки След.

5.2. Лёгкость управления

Некоторым пользователям может потребоваться специальная поддержка из-за, например, проблем со зрением. USB-дисплеи Брайля обнаруживаются автоматически, но большинство других возможностей удобства управления нужно включать вручную. На машинах (если это ими поддерживается) загрузочное меню выдаёт звуковой сигнал, когда оно готово принимать команды с клавиатуры. Для включения возможностей удобства управления после этого можно добавить некоторые параметры загрузки (смотрите также Раздел 5.1.7, «Экран запуска»). Заметим, что на большинстве архитектур системный загрузчик считает, что используется клавиатура с раскладкой QWERTY.

5.2.1. USB-дисплеи Брайля

USB-дисплеи Брайля должны определяться автоматически. Будет выбрана программа установки с текстовым интерфейсом, а в устанавливаемую систему будет автоматически добавлена поддержка дисплея Брайля. Вы можете просто нажать Enter в загрузочном меню. После того, как запустится brltty, вы сможете выбрать таблицу Брайля в меню параметров. Список клавиатурных комбинаций для устройств Брайля доступен на веб-сайте brltty.

5.2.2. Дисплеи Брайля, подключаемые к последовательному порту

Дисплеи Брайля, подключаемые к последовательному порту, невозможно определить автоматически (так как это может привести к их поломке). Поэтому вам нужно добавить параметр загрузки brltty=драйвер,порт,таблица, чтобы указать brltty, какой драйвер нужно использовать. Часть драйвер нужно заменить на двух-буквенный код вашего терминала (см. в нужный код драйвера). Часть порт нужно заменить на имя устройства последовательного порта, к которому подключён дисплей, по умолчанию используется ttyS0. Часть таблица — это имя используемой таблицы Брайля (см. в нужный код таблицы); по умолчанию используется английская таблица. Заметим, что таблицу можно изменить позже в меню параметров. Список клавиатурных комбинаций для устройств Брайля доступен на веб-сайте brltty.

5.2.3. Устройства речевого синтеза

Поддержка аппаратных устройств речевого синтеза доступна только в графическом интерфейсе программы установки. То есть в загрузочном меню вам нужно выбрать «Graphical install».

Устройства речевого синтеза не определяются автоматически. Вам нужно добавить параметр загрузки speakup.synth=драйвер, чтобы указать speakup, какой драйвер нужно использовать. Часть драйвер нужно заменить на код драйвера вашего устройства (см. в список драйверов). После его указания будет автоматически выбран текстовый интерфейс программы установки, а в устанавливаемую систему будет автоматически добавлена поддержка устройств речевого синтеза.

5.2.4. Встраиваемые устройства

Некоторые устройства облегчения управления представляют собой платы, которые устанавливаются внутрь компьютера и читают текст напрямую из видеопамяти. Чтобы они смогли работать, нужно выключить использование фрейм-буфера с помощью загрузочного параметраvga=normal fb=false. Однако, это сократит количество доступных языков установки.

Если желательно активировать текстовую версию системного загрузчика до добавления загрузочного параметра, то введите h Enter.

5.2.5. Тема с высокой контрастностью

Для пользователей с ослабленным зрением в программе установки предусмотрена высоко-контрастная тема, которая делает его более читаемым. Чтобы её использовать, добавьте загрузочный параметр theme=dark.

Пред. | Уровень выше | След.
5.1. Запуск программы установки на 32-bit PC | Начало | 5.3. Параметры загрузки


5.3. Параметры загрузки
Пред. Глава 5. Загрузка системы установки След.

5.3. Параметры загрузки

Параметры загрузки — это параметры ядра Linux, которые обычно используются для того, чтобы указать присутствующие периферийные устройства. В большинстве случаев ядро может определить периферийные устройства автоматически. Однако, иногда вы должны немного помочь ядру.

Если вы в первый раз загружаете систему, попробуйте параметры загрузки по умолчанию (то есть не пытайтесь их изменять) и посмотрите, корректно ли всё работает. Скорее всего, так оно и будет. Если нет, вы сможете позже перезагрузиться и поискать специальные параметры, которые помогут системе определить аппаратуру вашего компьютера.

Информацию о многих параметрах загрузки можно найти в Linux BootPrompt HOWTO, где можно найти советы советы и по нераспознанному оборудованию. В этом разделе содержатся только краткие сведения о наиболее важных параметрах. Некоторые распространённые ошибки включены ниже в Раздел 5.4, «Диагностика проблем процесса установки».

В самом начале при загрузке ядра должно появиться сообщение:

Memory:availk/totalk available

Значение total должно совпадать с общим количеством ОЗУ в килобайтах. Если оно не соответствует действительно установленному объёму ОЗУ, вам надо использовать параметр mem=ram, где ram равно объёму памяти, дополненному буквой «k», если объём задан в килобайтах или «m», если в мегабайтах. Например, mem=65536k или mem=64m означают 64МБ ОЗУ.

Если вы загружаетесь через консоль на последовательном порту, обычно ядро обнаруживает это автоматически. Если к компьютеру подключёны видеокарта (фрейм-буфер) и клавиатура, а вы хотите загрузиться через консоль на последовательном порту, вам надо передать ядру параметр console=устройство, где устройство — имя устройства последовательного порта, обычно ttyS0[9].

5.3.1. Параметры программы установки Debian

Система установки анализирует некоторые дополнительные параметры загрузки[10], что может быть полезно.

Некоторые параметры имеют «сокращённую форму записи», что помогает избежать ограничений параметров командной строки ядра и облегчает ввод параметров. Если у параметра есть сокращённая форма, то она даётся в скобках после (обычной) длинной формы. В примерах руководства также используется сокращённая форма.

debconf/priority (priority)

Этот параметр задаёт низший приоритет отображаемых сообщений.

Значение по умолчанию равно priority=high. Это означает, что будут показаны сообщения с высоким и с критическим приоритетами, а сообщения со средним и низким приоритетами будут пропущены. В случае возникновения проблем, программа установки подстраивает значение приоритета.

Если вы добавите priority=medium в качестве параметра загрузки, то увидите меню программы установки и получите больший контроль над установкой. При использовании priority=low показываются все сообщения (эквивалентно методу загрузки expert). Если указать priority=critical, то система установки будет показывать только критические сообщения и попробует всё сделать правильно самостоятельно.

DEBIAN_FRONTEND

Этот параметр загрузки контролирует тип пользовательского интерфейса, используемого программой установки. Возможные на текущий момент значения параметра:

  • DEBIAN_FRONTEND=noninteractive

  • DEBIAN_FRONTEND=text

  • DEBIAN_FRONTEND=newt

  • DEBIAN_FRONTEND=gtk

По умолчанию выбран тип DEBIAN_FRONTEND=newt. Для установки через консоль на последовательном порту наиболее предпочтителен DEBIAN_FRONTEND=text . Вообще, с носителей установки по умолчанию в данный момент доступен только интерфейс newt. На некоторых архитектурах используется графический интерфейс программы установки gtk.

BOOT_DEBUG

Присвоение этому загрузочному параметру значения 2 приводит к более подробному протоколированию процесса загрузки программы установки. Значение 3 приводит к запуску интерпретатора командной строки в наиболее важных точках процесса загрузки. (Завершение работы с интерпретатором приводит к продолжению процесса загрузки.)

BOOT_DEBUG=0

Значение по умолчанию.

BOOT_DEBUG=1

Подробней чем обычно.

BOOT_DEBUG=2

Много отладочной информации.

BOOT_DEBUG=3

В различных точках процесса загрузки будет вызван интерпретатор командной строки, чтобы разрешить детальную отладку. При выходе из интерпретатора загрузка продолжится.

INSTALL_MEDIA_DEV

Значением этого параметра является путь к устройству, с которого загружается программа установки Debian. Например, INSTALL_MEDIA_DEV=/dev/floppy/0

Загрузочная дискета в поисках корневой дискеты сканирует все дискеты и USB устройства хранения. Этим параметром можно заставить её искать корневую дискету только на избранном устройстве.

lowmem

Используется для указания программе установки выставить для lowmem больший уровень, чем это рассчитывается по умолчанию исходя из количества доступной памяти. Возможные значения 1 и 2. Смотрите также Раздел 6.3.1.1, «Определение доступной памяти / режим с малым потреблением памяти».

noshell

Указывает программе установки не запускать интерактивную оболочку на tty2 и tty3. Полезно при автоматизированной установке, где ограничена физическая безопасность.

debian-installer/framebuffer (fb)

Чтобы предложить установку на нескольких языках на некоторых архитектурах используется фрейм-буфер ядра. Если работа через фрейм-буфер вызывает проблемы на вашей системе, можно выключить его параметром vga=normal fb=false. Симптомы проблемы — сообщения об ошибках bterm или bogl, пустой экран или замирание на несколько минут в начале установки.

debian-installer/theme (theme)

Темой определяется вид пользовательского интерфейса программы установки (раскраска, иконки и т.д.). У каждого интерфейса есть свои темы. В настоящий момент для интерфейсов newt и gtk есть только одна тема «dark», которая была специально разработана для людей с ослабленным зрением. Для установки темы загрузитесь с параметром theme=dark.

netcfg/disable_dhcp

По умолчанию, debian-installer автоматически пытается настроить сеть через DHCP. Если получение адреса прошло успешно, у вас не будет шанса пересмотреть и изменить полученные настройки. Вы сможете настроить сеть вручную только в случае ошибок при работе с DHCP.

Если в вашей локальной сети есть DHCP сервер, но вы не хотите его использовать, потому что он, например, дает неправильные ответы, можете указать параметр netcfg/disable_dhcp=true, чтобы отключить настройку сети по DHCP и ввести информацию вручную.

hw-detect/start_pcmcia

Установите в false, чтобы избежать запуска PCMCIA сервисов, если это вызывает проблемы. Особенно полезно для некоторых ноутбуков.

disk-detect/dmraid/enable (dmraid)

Установите в true, чтобы включить поддержку Serial ATA RAID (также называемого ATA RAID, BIOS RAID или недо-RAID) дисков в программе установки. Заметим, что эта поддержка является экспериментальной. Дополнительную информацию можно найти на страницах вики Debian Installer.

preseed/url (url)

Задайте url для загрузки файла с настройками и использования автоматической установки. Смотрите Раздел 4.6, «Автоматическая установка».

preseed/file (file)

Укажите путь к файлу для загрузки настроек автоматической установки. Смотрите Раздел 4.6, «Автоматическая установка».

preseed/interactive

Установка в true включает отображение всех вопросов, даже для которых есть автоматизированный ответ. Может оказаться полезным при отладке или тестировании файла ответов. Заметим, что это не действует на параметры, указанные в приглашении к загрузке, для работы с ними используется специальный синтаксис. Смотрите Раздел B.5.2, «Использование автоматической установки для изменения значений по умолчанию».

auto-install/enable (auto)

Отложить вопросы, которые обычно задаются перед автоматической установкой, которые можно задать после настройки сети. Подробней об автоматизации установки смотрите в Раздел B.2.3, «Автоматический режим».

finish-install/keep-consoles

При установке с консоли на последовательном порту обычные виртуальные консоли (VT1-VT6) выключаются в /etc/inittab. Если установить в значение true, то этого не случится.

cdrom-detect/eject

По умолчанию перед перезагрузкой, debian-installer автоматически извлекает компакт-диск, который использовался при установке. Это делать необязательно, если система система не загружается с компакт-диска автоматически. В некоторых случаях это даже нежелательно, например, если устройство чтения не может самостоятельно загрузить компакт-диск и пользователь не может сделать это вручную. Многие устройства со слотовой загрузкой, slim-line и caddy не способны загружать носитель автоматически.

Чтобы запретить автоматическое извлечение задайте значение false, но проверьте, что система не загружается автоматически с компакт-диска после начальной установки.

base-installer/install-recommends (recommends)

Если назначить данному параметру значение false, то это отключит в системе управления пакетами установку «Рекомендуемых» пакетов, как во время установки так и в установленной системе.

Заметим, что этот параметр позволяет получить более отточенную систему, но это также может привести к отсутствию некоторых возможностей, которые вы рассчитывали получить. Для получения дополнительных возможностей вы можете установить некоторые рекомендуемые пакеты вручную. Поэтому этот параметр должен использоваться только очень опытными пользователями.

debian-installer/allow_unauthenticated

По умолчанию программа установки требует, чтобы репозитории аутентифицировались с помощью известного ключа gpg. Установка в true выключает данную аутентификацию. Предупреждение: это небезопасно, рекомендуется не делать этого.

rescue/enable

Установка в true активирует режим восстановления, вместо обычного режима установки. Смотрите Раздел 8.7, «Восстановление неработающей системы».

5.3.2. Использование параметров загрузки для ответов на вопросы

За некоторым исключением, в приглашении к загрузке можно задать любые значения ответов на вопросы установки, хотя это полезно только в специфических случаях. Описание как это делать можно найти в Раздел B.2.2, «Использование параметров загрузки для автоматизации». Некоторые специальные примеры даны ниже.

debian-installer/language (language), debian-installer/country (country), debian-installer/locale (locale)

Есть два способа указать язык, страну и локаль, используемую при установки и в установленной системе.

Первый и самый простой — передать только параметр locale. Для языка и страны будет использовано вычисленное значение. Например, вы можете использовать locale=de_CH для выбора немецкого языка и Швейцарии в качестве страны (в установленной системе по умолчанию будет использована локаль de_CH.UTF-8 ). Этот способ имеет ограничения по комбинациям языка, страны и локали.

Второй, более гибкий способ — отдельно указать язык и страну. В этом случае locale можно задать дополнительно для выбора специфичной локали по умолчанию для установленной системы. Пример: language=en country=DE locale=en_GB.UTF-8.

anna/choose_modules (modules)

Может использоваться для автоматической загрузки компонент программы установки, которые не загружаются по умолчанию. В качестве примеров дополнительных полезных компонент, можно привести openssh-client-udeb (для того, чтобы во время установки можно было использовать команду scp) и ppp-udeb (на настройки PPPoE).

netcfg/disable_dhcp

Установите в true, если хотите выключить DHCP и задать настройки сети статически.

mirror/protocol (protocol)

По умолчанию, программа установки использует протокол http для загрузки файлов с серверов-зеркал Debian, и изменить его на ftp невозможно при установке с обычным приоритетом. Установив этот параметр равным ftp, вы можете заставить программу установки использовать этот протокол. Заметим, что вы не сможете выбрать сервер-зеркало ftp из списка, вам придётся вводить имя вручную.

tasksel:tasksel/first (tasks)

Может быть использована для выбора задач, которых нет в списке выбора в программе установки, например задача kde-desktop. Подробней смотрите в Раздел 6.3.5.2, «Выбор и установка программного обеспечения».

5.3.3. Передача параметров модулям ядра

Если драйверы встроены в ядро, вы можете передать им параметры как это описано в документации к ядру. Если же драйверы собраны как модули и так как модули ядра загружаются немного по-другому чем при загрузке установленной системы, невозможно передать параметры модулям обычным способом. Вместо этого вам нужно использовать специальный синтаксис, распознаваемый программой установки, которая сохраняет эти параметры в нужные конфигурационные файлы, для того чтобы использовать их при загрузке модуля. Параметры также будут автоматически включены в конфигурацию установленной системы.

Заметим, что теперь редко требуется указывать параметры модулям. В большинстве случаев ядро способно само определить имеющееся оборудование в системе и настроить его правильно. Однако иногда всё ещё может потребоваться установка параметров вручную.

Синтаксис установки параметров модулей:

имя_модуля.имя_параметра=значение

Если требуется передать несколько параметров одному или разным модулям, то выражение повторяют. Например, чтобы указать старым сетевым картам 3Com использовать BNC (коаксиальный) разъём и IRQ 10, вы должны написать:

3c509.xcvr=3 3c509.irq=10

5.3.4. Внесение модулей ядра в чёрный список

Иногда бывает необходимо внести модуль в чёрный список, чтобы предотвратить его автоматическую загрузку ядром и udev. Одной из причин для этого может быть то, что этот модуль неправильно работает с вашим оборудованием. Также, иногда ядро имеет два разных драйвера для одного устройства. Это может приводить к неправильной работе устройства при конфликте драйверов, или если сперва загружается неправильный драйвер.

Чтобы внести модуль в чёрный список используйте следующий синтаксис: module_name.blacklist=yes. Это поместит модуль в чёрный список в файле /etc/modprobe.d/blacklist.local на время установки и в установленной системе.

Заметим, что модуль всё ещё может загружаться самой системой установки. Чтобы этого избежать, запустите установку в экспертном режиме и снимите выделение с модуля в списке модулей, отображаемого во время шага обнаружения оборудования.

[9] Чтобы тип терминала точно совпал с типом эмулятора терминала, запускаемого программой установки, можно добавить параметр TERM=тип. Заметим, что программа установки поддерживает только следующие типы терминалов: linux, bterm, ansi, vt102 и dumb. По умолчанию для последовательного порта в debian-installer используется vt102.

[10] Новые версии ядер (2.6.9 и новее) позволяют использовать 32 параметра в командной строке и 32 переменные среды.

Пред. | Уровень выше | След.
5.2. Лёгкость управления | Начало | 5.4. Диагностика проблем процесса установки


5.4. Диагностика проблем процесса установки
Пред. Глава 5. Загрузка системы установки След.

5.4. Диагностика проблем процесса установки

5.4.1. Надёжность CD-ROM

Иногда, особенно в старых приводах CD-ROM, программа установки может не загрузиться с CD-ROM. Программа установки также может (даже после успешной загрузки с CD-ROM) не распознать CD-ROM или выдавать ошибки при чтении во время установки.

Такие проблемы могут возникать по разным причинам. Мы можем описать только общие из них и предложить общие решения. Остальное зависит от вас.

Есть несколько простых вещей, которые вы можете попробовать сделать в первую очередь.

  • Если с CD-ROM не получается загрузиться, проверьте, что он вставлен правильно и что диск не грязный.

  • Если программа установки не смогла определить CD-ROM, попробуйте выполнить пункт меню Поиск и монтирование CD-ROM второй раз. Некоторые проблемы с DMA на старых приводах CD-ROM решаются таким способом.

Если это не сработало, попробуйте советы данные ниже. Хотя большинство, но не все, описываемые предложения работают и для CD-ROM и для DVD, для простоты мы будем использовать термин CD-ROM.

Если вы не можете заставить программу установки работать с CD-ROM, попробуйте, если возможно, другой метод установки.

5.4.1.1. Общие причины

  • Некоторые старые приводы CD-ROM не поддерживают чтение с дисков, которые были записаны на высоких скоростях в современных устройствах записи CD.

  • Если система корректно загружается с CD-ROM, это совсем не значит, что Linux также поддерживает CD-ROM (или, если более точно, контроллер, к которому подключён привод CD-ROM).

  • Некоторые старые приводы CD-ROM работают неправильно, если включён «прямой доступ к памяти» (DMA).

5.4.1.2. Как изучать и может быть решить проблему

Если с CD-ROM не удаётся загрузиться, попробуйте способы указанные ниже.

  • Проверьте, что в BIOS включена загрузка с CD-ROM (возможно, старые машины этого не умеют), и что привод CD-ROM поддерживает используемый тип носителя.

  • Если вы скачивали образ iso, проверьте, что md5sum этого образа совпадает с суммой указанной в файле MD5SUMS, который должен лежать там же, где вы брали образ.

    $ md5sum debian-testing-i386-netinst.iso
a20391b12f7ff22ef705cee4059c6b92  debian-testing-i386-netinst.iso

    Далее проверьте, что md5sum записанного CD-ROM также совпадает. Следующая команда должна сработать. Здесь считается сумма прочитанных с CD-ROM байт, составляющих образ.

    $ dd if=/dev/cdrom | \

> head -c `stat --format=%s debian-testing-i386-netinst.iso` | \

> md5sum
a20391b12f7ff22ef705cee4059c6b92  -
262668+0 records in
262668+0 records out
134486016 bytes (134 MB) copied, 97.474 seconds, 1.4 MB/s

Если после успешной загрузки программы установки не определяется CD-ROM, то иногда помогает просто попробовать ещё раз. Если у вас более одного привода CD-ROM, попробуйте загрузиться с другого CD-ROM. Если это не помогает или если CD-ROM определяется, но при чтении возникают ошибки, попробуйте выполнить предложения, данные ниже. Для этого потребуются азы работы в Linux. Перед тем как выполнить любую команду, сначала вы должны переключиться во вторую виртуальную консоль (VT2) и активировать оболочку командной строки.

  • Переключитесь в VT4 или посмотрите файл /var/log/syslog (в качестве редактора используется nano), чтобы найти сообщения о специфических ошибках. После этого также проверьте вывод команды dmesg.

  • В выводе dmesg проверьте, что привод CD-ROM был найден. Вы должны увидеть что-то типа этого (строки могут быть в другой последовательности):

    Probing IDE interface ide1...
hdc: TOSHIBA DVD-ROM SD-R6112, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
hdc: ATAPI 24X DVD-ROM DVD-R CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20

    Если вы не нашли подобных строк, это случай, когда контроллер, к которому подключён CD-ROM, не распознан или не поддерживается ядром вообще. Если вы знаете, какой драйвер требуется для привода, то можете попытаться загрузить его вручную с помощью команды modprobe.

  • Проверьте, что есть соответствующий файл устройства для привода CD-ROM в каталоге /dev/. Для примера выше, должен существовать файл /dev/hdc. Также может быть /dev/cdroms/cdrom0.

  • С помощью команды mount проверьте, что CD-ROM уже смонтировать; если нет, попытайтесь смонтировать вручную:

    $ mount /dev/hdc /cdrom

    Проверьте, не появилось ли ошибок после этой команды.

  • Проверьте, включён ли DMA:

    $ cd /proc/ide/hdc
$ grep using_dma settings
using_dma      1       0       1       rw

    «1» означает включён. Если включён, попробуйте выключить его:

    $ echo -n "using_dma:0"
>settings

    Удостоверьтесь, что находитесь в каталоге для устройства, соответствующего приводу CD-ROM.

  • Если возникли проблемы во время установки, попробуйте проверить целостность CD-ROM с помощью пункта внизу главного меню программы установки. Этим также можно провести общую проверку надёжности чтения CD-ROM.

5.4.2. Настройка загрузки

Если у вас возникли проблемы и ядро падает во время загрузки, не распознает имеющуюся периферию или неправильно распознаются диски, сперва проверьте параметры загрузки, как это обсуждается в Раздел 5.3, «Параметры загрузки».

Часто, проблемы можно решить, убрав дополнения и периферию, а затем попытаться загрузиться ещё раз. Особенно часто проблемы бывают с внутренними модемами, звуковыми картами и устройствами Plug-n-Play.

Если на вашей машине установлен большой объём памяти, более чем 512МБ и программа установки виснет при загрузке ядра, то вам может понадобиться указать параметр загрузки для ограничения объёма памяти видимого ядру — mem=512m.

5.4.3. Распространённые проблемы установки на 32-bit PC

Есть некоторое количество распространённых проблем установки, которые можно решить или избежать с помощью передачи параметров загрузки программе установки.

Некоторые системы имеют дисковод гибких дисков с «обратными DCL». Если вы получаете ошибки чтения с дискеты, даже когда знаете, что она хорошая, попробуйте задать параметр floppy=thinkpad.

На некоторых системах, таких как IBM PS/1 или ValuePoint (имеющих дисковый драйвер ST-506), привод IDE может быть распознан неправильно. Сначала попробуйте загрузиться без параметров и посмотрите, правильно ли определяется привод IDE. Если нет, выясните геометрию диска (количество цилиндров, головок и секторов) и воспользуйтесь параметром hd=количество цилиндров, количество головок, количество секторов.

Если у вас очень старая машина и ядро зависает после надписи Checking 'hlt' instruction..., то вы должны попробовать параметр загрузки no-hlt, который выключает этот тест.

На некоторых системах (особенно ноутбуках),имеющих заводское разрешение экрана в масштабе не 4:3 (то есть, например, не 800x600 или 1024x768), после загрузки программы установки может пропасть изображение. В этом случае может помочь добавление загрузочного параметра vga=788[11]. Если это не сработает, попробуйте добавить загрузочный параметр fb=false.

Если во время загрузки ядра экран выглядит странно, например, он полностью белый, чёрный или замусорен разными цветами, то ваша система, вероятно, имеет проблемную видеокарту, которая неправильно переключается в режим фрейм-буфера. В этом случае, вы можете попробовать указать параметр загрузки fb=false, чтобы выключить фрейм-буфер на консоли. Из-за ограничений консоли установка будет доступна только на нескольких языках. Подробней см. Раздел 5.3, «Параметры загрузки».

5.4.3.1. Система подвисает во время настройки PCMCIA

Про некоторые модели ноутбуков Dell известно, что они виснут когда при определении PCMCIA устройства производится попытка доступа по некоторым аппаратным адресам. Похожие проблемы могут иметь и другие ноутбуки . Если у вас возникла такая проблема и вам не нужна поддержка PCMCIA во время установки, то вы можете выключить PCMCIA с помощью параметра загрузки hw-detect/start_pcmcia=false. После установки вы сможете настроить PCMCIA, исключив диапазон ресурсов, с которым возникают проблемы.

Другой вариант: вы можете загрузить программу установки в экспертном режиме. Вас попросят указать диапазон ресурсов, который используется аппаратным обеспечением. Например, если у вас один из ноутбуков Dell, упомянутых выше, то вы должны ввести exclude port 0x800-0x8ff. Также, есть список распространённых диапазонов ресурсов в System resource settings section of the PCMCIA HOWTO. Заметим, что при вводе значений в программу установки вы не должны указывать запятых, если они есть.

5.4.3.2. Система подвисает во время загрузки USB модулей

Обычно, ядро пытается установить модули USB и драйвер USB клавиатуры, чтобы обеспечить поддержку некоторых нестандартных клавиатур USB. Однако, есть несколько нестандартных USB систем, где драйвер подвисает при загрузке. Возможно, обходным решением может быть выключение контроллера USB в настройке BIOS материнской платы. Другим решением может служить передача параметра nousb в приглашении загрузки.

5.4.4. Интерпретация загрузочных сообщений ядра

Во время загрузки вы можете увидеть много сообщений вида can't find что-то или что-то not present, can't initialize что-то или даже this driver release depends on чего-то . Большинство этих сообщений безвредны. Вы видите их потому что устанавливаемое ядро собрано так, чтобы запускаться на компьютерах с самыми различными периферийными устройствами. Очевидно, ни один компьютер не может содержать все доступные устройства, так что операционная система может немного пожаловаться во время поиска периферии, которой у вас нет. Также, вы можете заметить, что система иногда замирает. Это случается из-за ожидания ответа от устройства, которого нет в вашей системе. Если вы посчитаете, что загрузка системы занимает недопустимо долгое время, вы можете позже создать собственное ядро (смотрите Раздел 8.6, «Сборка нового ядра»).

5.4.5. Сообщение о проблемах при установке

Если вы прошли фазу начальной загрузки, но не смогли завершить установку, полезно войти в меню Сохранение файлов журнала с отладочной информацией. Из этого меню можно скопировать системные журналы ошибок и информацию о конфигурации из программы установки на дискету или загрузить через веб браузер. Эта информация поможет понять, что было не так и как это исправить. Если вы отправляете отчёт об ошибках, то можете приложить эту информацию к отчёту.

Другие сообщения, имеющие отношение к установке, можно найти в /var/log/ во время установки, и в /var/log/installer/ после того, как компьютер загрузит установленную систему.

5.4.6. Отправка отчётов об ошибках установки

Если у вас возникли проблемы, отправьте отчёт об установке. Также, мы приветствуем отправку отчётов даже в случае успешной установки, чтобы получить побольше информации о разных аппаратных конфигурациях.

Заметим, что отчёт об установке будет опубликован в системе отслеживания ошибок Debian (BTS) и переслан в открытый список рассылки. Проверьте, что вы используете адрес электронной почты, который не жалко опубликовывать.

Если система Debian заработала, самый простой путь отправки отчёта об установке — установить пакеты installation-report и reportbug (aptitude install installation-report reportbug), настроить reportbug, как это описывается в Раздел 8.5.2, «Отправка почты из системы» и запустить команду reportbug installation-reports.

Или же используйте этот шаблон для заполнения отчёта об установке и отправьте отчёт как сообщение об ошибке псевдо-пакету installation-reports на адрес <submit@bugs.debian.org>.

Package: installation-reports

Boot method: <Как запускалась программа установки? с CD? с дискет? из сети?>
Image version: <Указать полный url, где брался образ>
Date: <Дата и время установки>

Machine: <Описание машины (например, IBM Thinkpad R32)>
Processor:
Memory:
Partitions: < вывод результата команды df -Tl; лучше таблицу разделов в необработанном (raw) виде>

Вывод результата команд lspci -knn и lspci -nn:

Base System Installation Checklist:
[O] = OK, [E] = Ошибка (описать подробности ниже), [ ] = не пробовал

Initial boot:           [ ]
Detect network card:    [ ]
Configure network:      [ ]
Detect CD:              [ ]
Load installer modules: [ ]
Detect hard drives:     [ ]
Partition hard drives:  [ ]
Install base system:    [ ]
Clock/timezone setup:   [ ]
User/password setup:    [ ]
Install tasks:          [ ]
Install boot loader:    [ ]
Overall install:        [ ]

Comments/Problems:

<Описание установки, комментарии, предложения возникшие в процессе.>

В отчёте об ошибках опишите, в чём состоит проблема, включая последние увиденные сообщения ядра в случае подвисания ядра. Опишите шаги, которые вы делали, чтобы привести систему в проблемное состояние.

[11] Параметр vga=788 включает фрейм-буфер VESA с разрешением 800x600. Это, скорее всего, поможет, но это может быть неоптимальным разрешением вашей системы. Список поддерживаемых разрешений можно получить с помощью vga=ask, но заметим, что список может быть неполным.

Пред. | Уровень выше | След.
5.3. Параметры загрузки | Начало | Глава 6. Использование программы установки Debian


Глава 6. Использование программы установки Debian
Пред. След.

Глава 6. Использование программы установки Debian

Содержание

6.1. Как работает программа установки
6.2. Описание компонент
6.3. Применение отдельных компонент
6.3.1. Настройка программы установки Debian и оборудования
6.3.2. Добавление пользователей и паролей
6.3.3. Разметка разделов и выбор точек монтирования
6.3.4. Установка базовой системы
6.3.5. Установка дополнительного программного обеспечения
6.3.6. Установка и настройка системного загрузчика
6.3.7. Завершение установки
6.3.8. Troubleshooting
6.3.9. Установка по сети
6.4. Загрузка отсутствующих микропрограмм
6.4.1. Подготовка носителя
6.4.2. Микропрограмма в установленной системе
Пред. |  | След.
5.4. Диагностика проблем процесса установки | Начало | 6.1. Как работает программа установки


6.1. Как работает программа установки
Пред. Глава 6. Использование программы установки Debian След.

6.1. Как работает программа установки

Программа установки Debian состоит из нескольких специализированных компонент, предназначенных для выполнения определённых задач установки. Каждая компонента выполняет свою задачу, задавая пользователю вопросы, если это необходимо для выполнения работы. Каждому вопросу назначен приоритет, и можно задать приоритет задаваемых вопросов при старте программы установки.

Когда выполняется установка по умолчанию, задаются только самые важные (высокоприоритетные) вопросы. Результатом будет полностью автоматизированный процесс установки с небольшим вмешательством пользователя. Компоненты автоматически запускаются в определённой последовательности; какая компонента будет запущена, зависит, в основном, от выбранного метода установки и от имеющегося оборудования. Программа установки будет использовать значения по умолчанию для вопросов, которые не задавались.

При возникновении проблемы, пользователь увидит экран с ошибкой и, возможно, меню программы установки предложит выбрать какое-нибудь альтернативное действие. Если же проблем нет, пользователь никогда не увидит меню программы установки, а просто будет отвечать на вопросы каждой компоненты. Извещениям о серьёзных ошибках установлен приоритет «критический», так что пользователь всегда будет оповещён.

Некоторые параметры по умолчанию, используемые программой установки, можно изменить передав как значения параметров загрузки при старте debian-installer. Если, например, вы хотите настраивать сеть вручную (по умолчанию используется DHCP, если получится), то можете добавить параметр загрузки netcfg/disable_dhcp=true. Возможные параметры можно посмотреть в Раздел 5.3.1, «Параметры программы установки Debian».

Опытным пользователям, возможно, будет более удобен интерфейс управления через меню, где каждый шаг контролируется пользователем, а не выполняется автоматически программой установки. Для использования программы установки в ручном режиме управляемом через меню, добавьте параметр загрузки priority=medium.

Если ваше оборудование требует передачи параметров модулям ядра при их установке, нужно запустить программу установки в режиме «эксперта». Это можно сделать либо введя команду expert для запуска программы установки, либо передав параметр загрузки priority=low. Режим эксперта дает вам полный контроль над debian-installer.

Для данной архитектуры debian-installer поддерживает два типа пользовательских интерфейса: текстовый и графический. Текстовый интерфейс используется по умолчанию, если не выбрать пункт «Graphical install» в первоначальном меню загрузки. Дополнительную информацию о графическом интерфейсе программы установки см. в Раздел D.6, «Программа установки с графическим интерфейсом».

В текстовом окружении невозможно управление с помощью мыши. Вот кнопки, с помощью которых вы можете перемещаться внутри различных диалогов. Клавиша Tab или правая стрелка перемещают указатель «вперёд», а Shift+Tab или левая стрелка — «назад» по отображаемым кнопкам или полям ввода. Клавишами стрелок вверх и вниз выбираются различные пункты в прокручиваемом списке, а также прокручивается сам список. Кроме этого, в длинных списках вы можете нажать на клавишу с буквой, чтобы список прокрутился прямо к пункту, начинающемуся на эту букву, а также использовать клавиши Pg-Up и Pg-Down для прокручивания списка в секциях. Клавиша пробел служит для выбора пунктов типа флажок. Для подтверждения выбора используйте клавишу Enter.

По некоторым окнам есть дополнительная справочная информация.Если она доступна, то об этом будет сообщено в нижней строке экрана надписью, что справочная информация доступна по нажатию клавиши F1.

Сообщения об ошибках и протокол выполнения выводятся на четвёртой консоли. Вы можете получить доступ к этой консоли, нажав Левый Alt+F4 (удерживайте клавишу Alt нажатой во время нажатия функциональной клавиши F4); чтобы вернуться к основному процессу установки нажмите Левый Alt+F1.

Также эти сообщения можно найти в файле /var/log/syslog. После установки этот файл копируется в файл /var/log/installer/syslog на новой системе. Остальные сообщения об установке можно найти в каталоге /var/log/ во время установки и в /var/log/installer/ после того, как компьютер перезагрузится в установленную систему.

Пред. | Уровень выше | След.
Глава 6. Использование программы установки Debian | Начало | 6.2. Описание компонент


6.2. Описание компонент
Пред. Глава 6. Использование программы установки Debian След.

6.2. Описание компонент

Ниже представлен список компонент программы установки с кратким описанием назначения каждой компоненты. Детали об использовании каждой компоненты можно найти в Раздел 6.3, «Применение отдельных компонент».

main-menu

Показывает список компонент пользователю во время работы программы установки и запускает компоненту, когда она выбрана. Вопросам main-menu установлен средний (medium) приоритет, так что если вы изменили приоритет на высокий или критический(по умолчанию высокий), вы не увидите меню. С другой стороны, если возникает ошибка, которая требует вмешательства пользователя, приоритет вопросов может быть временно понижен, чтобы позволить решить проблему, и в этом случае меню может появиться.

Вы можете добраться до главного меню, многократно нажав кнопку Go Back, чтобы пройти весь путь обратно от выполняемой в данный момент компоненты.

localechooser

Позволяет пользователю указать параметры локализации процесса установки и устанавливаемой системы: язык, страну и локали. Программа установки будет отображать сообщения на выбранном языке, если есть перевод на этот язык. Если перевода сообщения нет, то будет показано сообщение на английском языке.

kbd-chooser

Показывает список клавиатур, из которого пользователь может выбрать подходящую модель.

hw-detect

Автоматически определяет большую часть аппаратуры системы, включая сетевые карты, приводы дисков и PCMCIA.

cdrom-detect

Ищет и монтирует компакт-диск с программой установки Debian.

netcfg

Настраивает сетевые подключения компьютера, чтобы он мог получить доступ к Интернет.

iso-scan

Ищет ISO-образы (файлы .iso files) на жёстких дисках.

choose-mirror

Предоставляет список серверов-зеркал Debian. Пользователь может выбрать источник, из которого будут устанавливаться пакеты.

cdrom-checker

Проверяет целостность данных на компакт-диске. Таким образом пользователь может убедиться, что установочный компакт-диск не повреждён.

lowmem

Пытается распознать системы с малым объёмом памяти и затем выполняет различные действия, чтобы удалить ненужные части debian-installer из памяти (ценой потери некоторых возможностей).

anna

Anna Не Настоящий APT. Устанавливает пакеты, которые были получены с выбранного сервера-зеркала или компакт-диска.

user-setup

Настраивает пароль суперпользователя и добавляет обычного пользователя.

clock-setup

Обновляет системные часы и определяет установлены часы по Гринвичу (UTC) или нет.

tzsetup

Выбирает часовой пояс, основываясь на местоположении указанном ранее.

partman

Позволяет пользователю разметить подключённые к системе диски, создать файловые системы на выбранных разделах и назначить им точки монтирования. Также обладает интересными возможностями, например, может работать в полностью автоматическом режиме и поддерживает LVM. Это предпочтительная утилита для работы с разделами в Debian.

partitioner

Позволяет пользователю разметить диски, подключённые к системе. Программа разметки будет соответствовать архитектуре вашего компьютера.

partconf

Отображает список разделов и создаёт файловые системы на выбранных разделах, согласно пользовательским указаниям.

lvmcfg

Помогает пользователю с настройкой LVM (менеджера логических томов).

mdcfg

Позволяет пользователю установить программный RAID (Redundant Array of Inexpensive Disks). Программный RAID обычно лучше, чем дешёвые IDE (псевдо-аппаратные) RAID-контроллеры в новых материнских платах.

base-installer

Устанавливает самый минимальный набор пакетов, который позволит компьютеру работать под Debian GNU/Linux после перезагрузки.

apt-setup

Настраивает apt, по большей части автоматически, основываясь на том, с какого носителя была запущена программа установки.

pkgsel

Использует tasksel для выбора и установки дополнительного ПО.

os-prober

Определяет уже установленные на компьютере операционные системы и передаёт эту информацию в bootloader-installer, который может предложить вам добавить найденные операционные системы в стартовое меню системного загрузчика. Таким образом пользователь может легко выбрать операционную систему для запуска в момент загрузки.

bootloader-installer

Устанавливает на жёсткий диск программу системный загрузчик, которая необходима для того, чтобы компьютер запустился под Linux без использования дискеты или компакт-диска. Многие системные загрузчики позволяют пользователю выбрать загрузку альтернативной операционной системы при старте компьютера.

shell

Позволяет пользователю вызвать интерпретатор командной строки из меню или на второй консоли.

save-logs

Предоставляет пользователю возможность записать информацию на дискету, через сеть, на жёсткий диск или другой носитель в случае возникновения проблем, чтобы позже отправить разработчикам Debian точный отчёт о проблеме в программе установки.

Пред. | Уровень выше | След.
6.1. Как работает программа установки | Начало | 6.3. Применение отдельных компонент


6.3. Применение отдельных компонент
Пред. Глава 6. Использование программы установки Debian След.

6.3. Применение отдельных компонент

В этом разделе мы подробно опишем каждую компоненту программы установки. Компоненты собраны в понятные пользователю группы и расположены в порядке использования во время установки. Обратите внимание, что в зависимости от метода установки и вашей аппаратуры некоторые модули могут не использоваться.

6.3.1. Настройка программы установки Debian и оборудования

Давайте представим, что программа установки Debian загрузилась и вы видите её первый экран. В этот момент возможности debian-installer всё ещё немного ограничены. Она многого не знает о вашем оборудовании, предпочитаемом языке или даже о задачах, которые она должна выполнить. Не беспокойтесь. Поскольку debian-installer немножко умная, она может автоматически определить ваше оборудование, найти свои остальные компоненты и обновить себя до очень умелой системы установки. Однако, вы должны помочь debian-installer некоторой информацией, которую она не сможет определить автоматически (например, выбрать предпочитаемый вами язык, раскладку клавиатуры или необходимый сетевой сервер-зеркало).

Заметим, что debian-installer выполняет определение оборудования несколько раз во время установки. На первом этапе определяется оборудование, необходимое для загрузки компонент программы установки (т.е. ваш CD-ROM или сетевая карта). Поскольку не все драйверы могут быть доступны во время этого первого запуска, определение оборудования надо будет повторить позже по ходу установки.

Во время определения оборудования debian-installer проверяет необходимость загрузки микропрограмм в драйверы устройств. Если микропрограмма требуется, но недоступна, выводится диалоговое окно, которое позволяет загрузить отсутствующую микропрограмму со сменного носителя. Подробней см. Раздел 6.4, «Загрузка отсутствующих микропрограмм».

6.3.1.1. Определение доступной памяти / режим с малым потреблением памяти

Одну из первых вещей, которую делает debian-installer, это проверка размера доступной памяти. Если размер ограничен, то эта компонента делает некоторые изменения процесса установки, которые, будем надеяться, позволят установить Debian GNU/Linux на вашу машину.

Первое, что делается для уменьшения потребления памяти программой установки — это выключение переводов в интерфейсе, то есть установка будет производится на английском языке. Конечно, вы сможете выполнить локализацию системы после завершения установки.

Если этого окажется недостаточно, программа установки дальше станет уменьшать потребление памяти загружая только компоненты, которые необходимы для выполнения базовой установки. Это уменьшает функциональность системы установки. Вам будет предоставлена возможность загрузить дополнительные компоненты вручную, но вы должны понимать, что каждая выбранная вами компонента использует память, и это может привести к неудачному завершению установки.

При работе программы установки в режиме с малым потреблением памяти рекомендуется создать относительно большой раздел подкачки (64–128МБ). Раздел подкачки будет использован в качестве виртуальной памяти, и это увеличит количество доступной памяти системы. Программа установки активирует раздел подкачки сразу как только это станет возможно в процессе установки. Заметим, что интенсивное использование раздела подкачки уменьшит производительность системы и может привести к большой нагрузке на диск.

Несмотря на все старания, система всё равно может повиснуть, могут произойти неожиданные ошибки или процессы могут быть завершены ядром из-за нехватки памяти в системе (вы увидите сообщения «Out of memory» на VT4 и в syslog).

Например, были отчёты об установке, что не удавалось создать большую файловую систему в режиме с малым потреблением памяти, если было недостаточно пространства подкачки. Если увеличение размера подкачки не помогает, попробуйте вместо неё создать файловую систему ext2 (которая является обязательной компонентой программы установки). После установки возможно изменить раздел ext2 на ext3.

Возможно заставить программу установки использовать более высокий уровень для lowmem чем значение, рассчитываемое из количества доступной оперативной памяти, с помощью загрузочного параметра «lowmem» как это описано в Раздел 5.3.1, «Параметры программы установки Debian».

6.3.1.2. Выбор параметров локализации

В большинстве случаев сначала вас попросят указать параметры локализации, которые будут использованы в программе установки и в устанавливаемой системе. В параметры локализации входят язык, расположение и локали.

Выбранный язык будет использован в процессе установки, предлагая переводы различных диалогов если возможно. Если перевод для выбранного языка недоступен, по умолчанию используется английский язык.

Указанное значение географического расположения (в большинстве случаев — страны) будет использовано позднее в процессе установки для выбора правильного часового пояса и подходящего для страны сервера-зеркала Debian. Значения страны и языка будут использованы вместе для настройки локали вашей системы и выборе правильной раскладки клавиатуры.

Сначала вас попросят выбрать предпочитаемый язык. Названия языков написаны на английском(слева) и на самом языке (справа); названия справа также показаны в правильном написании для этого языка. Список отсортирован по английским названиям. Вверху списка есть дополнительный пункт, который вместо языка позволяет выбрать «C» локаль. При выборе «C» локали установка будет производиться на английском; установленная система не будет иметь поддержку локализации, так как пакет locales в данном случае установлен не будет.

Далее вас попросят указать географическое расположение. Если вы выбрали язык, на котором говорят более чем в одной стране[12], вам будет показан список только этих стран. Чтобы указать страну не из списка, выберите другая (последний пункт). Далее вам будет предложен список континентов; при выборе определённого континента будет показан список стран, которые на нём расположены.

Если с языком связана только одна страна, то будет показан список стран континента или региона, на котором находится страна, и по умолчанию будет выбрана эта страна. Нажмите Вернуться, для выбора стран другого континента.

Замечание

Очень важно выбрать страну вашего проживания или нахождения, так как по ней определяется часовой пояс, который будет настроен в установленной системе.

Если вы выберете комбинацию языка и страны, для которой нет локали и есть несколько локалей для этого языка, то программа установки предложит вам выбрать желаемую локаль по умолчанию для устанавливаемой системы[13].Во всех других случаях локаль по умолчанию будет выбрана на основе языка и страны.

В любой выбранной локали по умолчанию, как описано в предыдущем параграфе, будет использована кодировка символов UTF-8.

Если вы производите установку с низким приоритетом, то вас попросят выбрать дополнительные локали, включая так называемые «старые» локали[14] для их генерации в установленной системе; если вы что-то выберете, то вас попросят выбрать локаль по умолчанию для устанавливаемой системы.

6.3.1.3. Выбор клавиатуры

Клавиатуры часто приспосабливают к алфавиту определённого языка. Выберите раскладку, которая подходит к вашей клавиатуре, или выберите наиболее подходящую, если таковой не имеется. После завершения установки вы сможете выбрать раскладку из большего количества вариантов (запустите kbd-config с правами суперпользователя после завершения установки).

Выберите нужную клавиатуру и нажмите Enter. Для перемещения используйте клавиши стрелок — они находятся в одном и том же месте во всех национальных клавиатурных раскладках, поэтому не зависят от конфигурации клавиатуры. 'Расширенная' клавиатура — это клавиатура с клавишами от F1 до F10 в самом верхнем ряду клавиш.

6.3.1.4. Поиск образа ISO программы установки Debian

Если установка производится с помощью метода hd-media, настанет момент, когда вам нужно будет найти и смонтировать ISO-образ программы установки Debian, чтобы получить оставшиеся файлы установки. Для этого существует компонента iso-scan.

Сначала iso-scan автоматически смонтирует все блочные устройства (например, разделы), на которых есть распознанная файловая система, и последовательно будет искать на них файлы с именами, оканчивающимися на .iso (или .ISO, это важно). Обратите внимание, ищутся файлы только в корневом каталоге и подкаталогах первого уровня (то есть найдутся файлы /имя.iso, /data/имя.iso, но не /data/tmp/имя.iso). После нахождения iso-образа, iso-scan проверит его содержимое чтобы выяснить, является ли образ правильным iso-образом Debian или нет. В первом случае поиск завершается, в последнем iso-scan будет искать другой образ.

Если найти ISO-образ с программой установки не удалось, iso-scan спросит, хотите ли вы чтобы был выполнен более тщательный поиск. В этом случае будет произведён поиск по всей файловой системе.

Если iso-scan не нашла ISO образ программы установки, перезагрузитесь в первоначальную операционную систему и проверьте правильность имени (должно оканчиваться на .iso), если файл находится на распознаваемой debian-installer файловой системе, и что образ не повреждён (проверьте контрольную сумму). Опытные пользователи Unix могут это сделать со второй консоли без перезагрузки.

6.3.1.5. Настройка сети

Если в начале этого шага система обнаруживает, что имеется более одного сетевого устройства, то вас попросят указать, какое устройство будет первичным сетевым интерфейсом, то есть какое устройство будет использовано для установки системы. Другие интерфейсы останутся ненастроенными. Вы сможете настроить дополнительные интерфейсы после завершения установки; смотрите страницу руководства interfaces(5).

По умолчанию, debian-installer пытается настроить сетевой интерфейс вашего компьютера автоматически через DHCP. Если на DHCP запросы получен ответ, настройка завершена. Если ответов не получено, это могло произойти по многим причинам, начиная от не подключённого сетевого кабеля и кончая неправильной настройкой DHCP. Или вы просто не имеете DHCP сервера в локальной сети. Для выяснения причины посмотрите сообщения об ошибках на третьей консоли. В любом случае вас спросят, не хотите ли вы попробовать ещё раз, или хотите выполнить настройку вручную. Иногда DHCP сервера очень медленно отвечают, поэтому если вы уверены, что всё в порядке, попробуйте ещё раз.

При ручной настройке сети вам зададут несколько вопросов о вашей сети, а именно про IP-адрес, маску сети, шлюз, адреса DNS-серверов и имени машины. Кроме того, если у вас интерфейс беспроводной сети, то вас попросят ввести личный Wireless ESSID и WEP ключ. Введите ответы из Раздел 3.3, «Информация, которая понадобится».

Замечание

Некоторые настройки иногда легко, но не всегда, определить вручную: программа предполагает, что IP-адрес сети вычисляется с помощью операции побитового И над IP-адресом системы и маской сети. Широковещательный адрес по умолчанию вычисляется с помощью операции побитового ИЛИ над IP-адресом системы и инверсной маской сети. Также угадывается шлюз. Если вы не можете найти какой-нибудь ответ, используйте предлагаемые системой — если нужно, вы можете изменить их сразу после установки системы, отредактировав /etc/network/interfaces.

6.3.1.6. Настройка времени и часового пояса

Сначала программа установки попытается подключиться к серверу времени в Интернете (по протоколу NTP), чтобы выставить правильное системное время. Если это не удаётся, то программа установки будет считать правильными время и дату, полученные с системных часов при загрузке программы установки. В процессе установки невозможно выставить системное время вручную.

В зависимости от места, выбранного ранее в процессе установки, вам может быть показан список часовых поясов, возможных в вашей географической точке. Если в вашей местности только один часовой пояс и вы выполняете установку по умолчанию, то вопрос задан не будет и система выберет этот часовой пояс.

В экспертном режиме или при установке со средним приоритетом вам будет предложено выбрать «Универсальное координированное время » (UTC) в качестве часового пояса.

Если по какой-то причине вы хотите установить часовой пояс для устанавливаемой системы, который не является правильным в выбранном местонахождении, то есть два способа сделать это.

  1. Простой способ: выберите другой часовой пояс после завершения установки и загрузки в новую систему. Это можно сделать с помощью следующей команды:

    # dpkg-reconfigure tzdata

  2. Второй способ: часовой пояс может быть задан при загрузке программы установки с помощью параметра time/zone=значение. Значение должно быть правильным часовым поясом, например Europe/London или UTC.

Для автоматизации установки часовой пояс может быть задан в файле ответов.

6.3.2. Добавление пользователей и паролей

Перед настройкой часов, программа установки предложит вам настроить учётную запись «root» и/или учётную запись для первого пользователя. Дополнительные учётные записи можно будет создать после завершения установки.

6.3.2.1. Установка пароля суперпользователя (root)

Учётная запись root также называемая суперпользовательской — это учётная запись, для которой нет никаких преград в вашей системе. Учётная запись root должна использоваться только для администрирования системы и как можно меньшее время.

Любой создаваемый вами пароль должен состоять как минимум из 6 символов и содержать заглавные и строчные буквы, а также знаки препинания. Уделите побольше внимания при установке пароля root, поскольку эта самая мощная учётная запись. Избегайте слов из словаря или использования любой персональной информации, которую можно угадать.

Если кто-то говорит вам, что ему нужен ваш пароль root, будьте очень осторожны. Обычно нет необходимости давать свой пароль root кому-либо, если только вы не администрируете машину вместе с другими системными администраторами.

6.3.2.2. Создание учётной записи обычного пользователя

Система спросит вас, желаете ли вы сейчас создать учётную запись для обычного пользователя. Эта учётная запись должна использоваться в качестве вашей основной рабочей учётной записи. Вы не должны использовать учётную запись root в повседневной работе или в качестве персональной учётной записи.

Почему не должны? Одна из причин, по которой следует избегать использования привилегий root это то, что в качестве root можно очень легко сделать необратимые повреждения. Другая причина: вас могут обманом заставить запустить программу троянского коня — это программа, которая воспользуется преимуществами ваших возможностей суперпользователя, чтобы скомпрометировать систему. В любой хорошей книге по системному администрированию Unix эта тема рассматривается подробно — прочтите одну из них, если это для вас в новинку.

Сначала вас попросят ввести полное имя пользователя. Затем спросят имя пользовательской учётной записи; в общем случае, ваше имя или что-то похожее вполне подойдёт. И, наконец, вас попросят ввести пароль учётной записи.

Если в любой момент после установки вы захотите создать ещё одну учётную запись, воспользуйтесь командой adduser.

6.3.3. Разметка разделов и выбор точек монтирования

После того как определение оборудования было выполнено в последний раз, debian-installer должен быть во всей своей красе, подстроенный под нужды пользователя и готовый к выполнению кое-какой настоящей работы. Как написано в заголовке раздела, основной задачей нескольких следующих компонент будет разметка дисков, создание файловых систем, назначение точек монтирования и, возможно, настройка RAID, LVM или шифрованных устройств.

Если вы плохо знакомы с процедурой разметки, или просто хотите знать детали процесса, смотрите Приложение C, Разметка дисков в Debian.

Сначала вам предложат автоматическую разметку или всего диска или только имеющего на нём свободного места. Это так называемая «направляющая» разметка. Если вы не хотите использовать авторазметку, выберите в меню Вручную.

6.3.3.1. Поддерживамые параметры разметки

Программа разметки debian-installer довольно универсальна. Она позволяет создать много различных схем разметки используя различные таблицы разделов, файловые системы и расширенные блочные устройства.

Список доступных параметров зависит, в основном, от архитектуры, но есть и другие факторы. Например, на системах с ограниченной внутренней памятью доступны не все параметры. Параметры по умолчанию также могут различаться. Тип таблицы разделов, используемый по умолчанию, может, например, отличаться на дисках большого объёма по сравнению с дисками малого объёма. Некоторые параметры можно изменять только при установке со средним или низким приоритетом debconf; чем выше приоритет, тем более целесообразные настройки по умолчанию будут использоваться.

Программа установки поддерживает различные виды расширенных настроек и использование устройств хранения, которые во многих случаях можно использовать совместно.

  • Управление логическими томами (LVM)

  • Программный RAID

    Поддерживается RAID 0, 1, 4, 5, 6 и 10 уровня.

  • Шифрование

  • Serial ATA RAID (с помощью dmraid)

    Так называемый «фиктивный RAID» или «BIOS RAID». Поддержка для Serial ATA RAID доступна только если её включить при запуске программы установки. Дополнительная информация в вики.

  • Многолучевое устройство (экспериментальная поддержка)

    Смотрите описание в вики. Поддержка многолучевых устройств доступна только если её включить при запуске программы установки.

Поддерживаются следующие файловые системы.

  • ext2, ext3, ext4

    В большинстве случаев файловой системой по умолчанию выбирается ext3; при использовании направляющей разметки для разделов /boot будет выбрана ext2.

  • jfs (недоступна на всех архитектурах)

  • xfs (недоступна на всех архитектурах)

  • reiserfs (по выбору; недоступна на всех архитектурах)

    Поддержка файловой системы Reiser по умолчанию более недоступна. При запуске программы установки со средним или низким приоритетом debconf, её можно включить выбрав компонент partman-reiserfs. Поддерживается файловая система только третьей версии.

  • qnx4

    Существующие разделы будут распознаны и их можно смонтировать. Создание новых разделов с qnx4 не поддерживается.

  • FAT16, FAT32

  • NTFS (только на чтение)

    Существующие разделы NTFS будут распознаны и их можно смонтировать. Создание новых разделов с NTFS не поддерживается.

6.3.3.2. Направляющая разметка

Если вы выбрали направляющую разметку, то есть два пути: создавать разделы непосредственно на жёстком диске (классический метод), создавать их с помощью управления логическими томами (LVM) или создавать, используя LVM с шифрованием[15].

Замечание

LVM или LVM с шифрованием может быть недоступно на некоторых архитектурах.

При использовании LVM или LVM c шифрованием, программа установки создаст большинство разделов внутри одного большого раздела; преимущество этого метода в том, что у разделов внутри этого большого раздела можно легко изменить размеры позже. При использовании LVM с шифрованием большой раздел будет недоступен без специальной ключевой фразы, предоставляя тем самым дополнительную безопасность вашим (личным) данным.

При использовании шифрованных LVM, программа установки также автоматически стирает диск, записывая на него произвольные данные. Это способствует усилению безопасности (так как это делает невозможным определить какие части диска используются и этим также стираются предыдущие следы установок), но это занимает некоторое время в зависимости от размера диска.

Замечание

При использовании направляющей разметки с LVM или LVM c шифрованием, перед тем как приступить к настройке LVM, нужно произвести запись на выбранный диск. Эти изменения сотрут все имеющиеся данные на выбранном жёстком диске и их больше нельзя будет восстановить. Однако программа установки перед записью на диск попросит вас подтвердить выполнение этих изменений.

If you choose guided partitioning (either classic or using (encrypted) LVM) for a whole disk, you will first be asked to select the disk you want to use. Check that all your disks are listed and, if you have several disks, make sure you select the correct one. The order they are listed in may differ from what you are used to. The size of the disks may help to identify them.

Any data on the disk you select will eventually be lost, but you will always be asked to confirm any changes before they are written to the disk. If you have selected the classic method of partitioning, you will be able to undo any changes right until the end; when using (encrypted) LVM this is not possible.

Далее вам предложат выбрать одну из схем, описанных в таблице ниже. Любая схема имеет свои "за" и "против", некоторые обсуждаются в Приложение C, Разметка дисков в Debian. Если вы не знаете что выбрать, выберите первую. Помните, что для работы направляющей разметки требуется определённое минимальное количество свободного места с которым можно работать. Если вы не выделите по крайней мере около 1ГБ (зависит от выбранной схемы), направляющая разметка завершится неудачно.

Схема разметки | Минимальное пространство | Создаваемые разделы
Все файлы на одном разделе | 600МБ | /, swap
Отдельный раздел /home | 500МБ | /, /home, swap
Отдельные разделы /home, /usr, /var и /tmp | 1ГБ | /, /home, /usr, /var, /tmp, swap

Если вы выбрали направляющую разметку с использованием LVM (с шифрованием), то программа установки также создаст отдельный раздел /boot. Остальные разделы, включая раздел подкачки, будут созданы внутри раздела LVM.

После выбора схемы, следующий экран покажет только что созданную таблицу разделов, включая информацию будут ли и как форматироваться разделы и куда они будут смонтированы.

Список разделов может выглядеть так:

  IDE1 master (hda) - 6.4 GB WDC AC36400L
        #1 primary   16.4 MB  B f ext2       /boot
        #2 primary  551.0 MB      swap       swap
        #3 primary    5.8 GB      ntfs
           pri/log    8.2 MB      FREE SPACE

  IDE1 slave (hdb) - 80.0 GB ST380021A
        #1 primary   15.9 MB      ext3
        #2 primary  996.0 MB      fat16
        #3 primary    3.9 GB      xfs        /home
        #5 logical    6.0 GB    f ext3       /
        #6 logical    1.0 GB    f ext3       /var
        #7 logical  498.8 MB      ext3
        #8 logical  551.5 MB      swap       swap
        #9 logical   65.8 GB      ext2

Здесь показаны два жёстких диска IDE, разделённые на несколько разделов; на первом диске осталось немного свободного места. Каждая строка раздела содержит номер раздела, тип, размер, необязательные флаги, файловую систему и точку монтирования (если есть). Замечание: такая настройка не может быть создана с помощью направляющей разметки, это просто пример, созданный с помощью разметки вручную.

На этом направляющая разметка завершена. Если вам нравится сгенерированная таблица разделов, то вы можете выбрать Закончить разметку и записать изменения на диск из меню для создания новой таблицы разделов (как описано в конце этого раздела). Если результат вам не нравится, то можно выбрать Отменить изменение разделов и запустить направляющую разметку снова или изменить предложенные изменения вручную, как описано ниже.

6.3.3.3. Разметка вручную

При ручной разметке появляется похожий экран, за исключением того, что отображается существующая таблица разделов и нет точек монтирования. Далее описано как вручную редактировать таблицу разделов и как использовать эти разделы в Debian.

Если вы выбрали чистый диск, на котором нет ни разделов ни свободного места, то вам предложат создать новую таблицу разделов (это необходимо для создания новых разделов). После этого, на выбранном диске должна появиться новая строка «СВОБОДНОЕ МЕСТО».

If you select some free space, you will have the opportunity to create a new partition. You will have to answer a quick series of questions about its size, type (primary or logical), and location (beginning or end of the free space). After this, you will be presented with a detailed overview of your new partition. The main setting is Use as:, which determines if the partition will have a file system on it, or be used for swap, software RAID, LVM, an encrypted file system, or not be used at all. Other settings include mountpoint, mount options, and bootable flag; which settings are shown depends on how the partition is to be used. If you don't like the preselected defaults, feel free to change them to your liking. E.g. by selecting the option Use as:, you can choose a different filesystem for this partition, including options to use the partition for swap, software RAID, LVM, or not use it at all. Another nice feature is the ability to copy data from an existing partition onto this one. When you are satisfied with your new partition, select Done setting up the partition and you will return to partman's main screen.

Если вы решили, что хотите что-то изменить в разделе, просто выберите раздел и попадёте обратно в меню настройки раздела. Так как это тоже самое меню что и для создания раздела, вы можете изменить тот же набор параметров. Одна вещь, которая может показаться, на первый взгляд, не очевидной: вы можете изменить размер раздела, выбрав элемент, отображающий размер раздела. Это работает, как минимум, на файловых системах fat16, fat32, ext2, ext3 и с разделом подкачки. Также, из этого меню можно удалить раздел.

Убедитесь, что создали, по крайнем мере, два раздела: один для корневой файловой системы (который должен быть смонтирован как /) и один раздел подкачки. Если вы забыли указать точку монтирования корневой файловой системы, partman не разрешит вам продолжить, пока вы не исправите ошибку.

Возможности partman могут быть расширены модулями программы установки, но это зависит от архитектуры компьютера. Поэтому, если вы не найдёте всех обещанных свойств, проверьте, загрузили ли вы все требуемые модули (например, partman-ext3, partman-xfs или partman-lvm).

Для завершения работы по разметке, выберите Закончить разметку и записать изменения на диск из меню разметки. Вам покажут отчёт об изменениях, которые будут произведены на диске и попросят подтвердить, что все представленные файловые системы должны быть созданы.

6.3.3.4. Настройка устройств Multidisk (программный RAID)

Если у вас более одного жёсткого диска[16] в компьютере, то можно воспользоваться программой mdcfg для увеличения производительности дисков и/или повышения надёжности хранения данных. В результате получается так называемое устройство Multidisk (или другое, более известное название, программный RAID).

Основу MD составляют группы разделов, расположенные на различных дисках и объединённые вместе в логическое устройство. Затем это устройство можно использовать как обычный раздел (то есть в partman вы можете отформатировать его, назначить ему точку монтирования и т.д.).

Получаемые преимущества зависят от типа создаваемого MD устройства. В данный момент поддерживаются:

RAID0

Применяется где нужна производительность. RAID0 разбивает все входящие данные на полосы и равномерно распределяет их по дискам в массиве. Это может увеличить скорость операций чтения/записи, но если один из дисков сломается, вы потеряете всё (часть информации всё ещё на исправных дисках(е), другая часть хранилась на сломавшемся диске).

Обычно, разделы RAID0 используют при редактировании видео.

RAID1

Используется там, где надёжность превыше всего. Он состоит из нескольких (обычно двух) одинаковых по размеру разделов, и на каждом разделе хранятся одинаковые данные. В сущности, это означает три вещи. Первое: если один из дисков сломается, вы не теряете данные, так как они продублированы на оставшихся дисках. Второе: вам доступна только часть имеющегося объёма (более точно, размер самого маленького раздела в RAID). Третье: нагрузка при чтении файла сбалансированно распределяется по всем дискам, что может повысить производительность, например, файлового сервера, на котором операций чтения больше чем операций записи.

Также, вы можете иметь в массиве запасной диск, который включится в работу в случае неисправности одного из дисков.

RAID5

Хороший компромисс между скоростью, надёжностью и избыточностью. RAID5 разделяет все входящие данные на полосы и распределяет их пропорционально на все диски кроме одного (как и RAID0). В отличие от RAID0, RAID5 вычисляет контрольную сумму, которую записывает на оставшийся диск. Диск с контрольной суммой не статичен (тогда это был бы RAID4), а периодически изменяется, так что контрольная сумма распределяется по всем дискам. Когда один из дисков ломается, потерянную часть информации можно вычислить из оставшихся данных и её контрольной суммы. RAID5 должен состоять, как минимум из трёх активных разделов. Также, вы можете иметь в массиве запасной диск, который включится в работу в случае неисправности одного из дисков.

Как видите, RAID5 имеет немного надёжности от RAID1, но это достигается с меньшей избыточностью. С другой стороны, он немного медленнее на операциях записи, чем RAID0 из-за вычислений контрольной суммы.

RAID6

Подобен RAID5, но контрольная сумма хранится на двух дисках, а не на одном.

Массив RAID6 останется рабочим даже после выхода из строя сразу двух дисков.

RAID10

В RAID10 используется чередование (как в RAID0) и зеркалирование (как в RAID1). В нём создаётся n копий входящих данных, которые распределяются между разделами так, что все копии одинаковых данных хранятся на разных устройствах. По умолчанию n равно 2, но в режиме эксперта это можно изменить. Число задействованных разделов должно быть как минимум n. В RAID10 есть различные схемы распределения копий. По умолчанию используется схема близкого (near) распределения. При этом все одинаковые копии располагаются на дисках по одинаковому смещению. Далёкие (far) копии имеют разные смещения на дисках. Смещение копий относится ко всей полосе, а не к отдельной копии.

RAID10 может использоваться для достижения надёжности и избыточности без трат на подсчёты контрольных сумм.

Итог:

Тип | Минимум устройств | Запасное устройство | Сохранятся ли данные при отказе диска? | Доступное пространство
RAID0 | 2 | нет | нет | Размер самого маленького раздела умноженный на число устройств в RAID
RAID1 | 2 | необязательно | да | Размер самого маленького раздела в RAID
RAID5 | 3 | необязательно | да | Размер самого маленького раздела умноженный на (число устройств в RAID минус один)
RAID6 | 4 | необязательно | да | Размер самого маленького раздела умноженный на (число устройств в RAID минус два)
RAID10 | 2 | необязательно | да | Общее количество всех разделов, поделённое на число полос копий (по умолчанию два)

Если вы хотите узнать больше о программном RAID, смотрите Software RAID HOWTO.

Для создания MD устройства нужно пометить желаемые разделы как используемые в RAID. (Это делается в partman из меню Настройки раздела, где вы должны выбрать Использовать как: → Использовать раздел как устройство RAID.)

Замечание

Убедитесь, что система может загружаться с планируемой вами схемы разметки. Обычно, требуется создать отдельную файловую систему для /boot, если в качестве корневой файловой системы (/) используется RAID. Большинство загрузчиков (включая lilo и grub) поддерживают зеркало (без чередования!) RAID1, так что решением может стать, например,RAID5 для / и RAID1 для /boot.

Внимание

Поддержка MD в программе установки появилась относительно недавно. У вас могут возникнуть проблемы с некоторыми уровнями RAID и в сочетании с некоторыми системными загрузчиками, если вы пытаетесь использовать MD в качестве корневой файловой системы (/). Опытные пользователи, возможно, могут обойти некоторые из этих проблем, выполнив некоторую настройку или шаги установки вручную из командной строки.

Далее, вы должны выбрать Настройка программного RAID из главного меню partman. (Меню появится только после того как вы отметите хотя бы один раздел используемый как физический том для RAID.)На первом экране mdcfg просто выберите Создать MD устройство. Вам будет предложен список поддерживаемых типов MD устройств, из которого вы должны выбрать один (например, RAID1). Дальнейшие действия зависят от типа выбранного MD.

  • RAID0 очень прост — вам предложат список доступных разделов RAID, а вашей задачей будет выбор разделов, из которых вы хотите сформировать MD.

  • С RAID1 немного сложнее. Во-первых, вас попросят ввести количество активных устройств и количество запасных устройств, из которых будет формироваться MD. Далее, вам потребуется выбрать из списка доступных разделов RAID те, которые будут активными и затем, те которые будут запасными. Число выбранных разделов должно быть равно числу, введённому несколькими секундами ранее. Не волнуйтесь. Если вы ошибётесь и выберете неверное число разделов, debian-installer не позволит вам продолжить, пока вы не исправите ошибку.

  • Создание RAID5 напоминает процедуру RAID1 за исключением того, что вам нужно использовать как минимум три активных раздела.

  • Создание RAID6 напоминает процедуру RAID1 за исключением того, что вам нужно использовать как минимум четыре активных раздела.

  • Создание RAID10 также похоже на процедуру создания RAID1, если это происходит не в режиме эксперта. В экспертном режиме debian-installer попросит указать схему распределения. В схеме задаётся два параметра. Первый — это тип схемы. Его значение может быть n (для близких копий), f (для далёких копий), или o (смещение копий). Вторым параметром задаётся число копий с данными. Оно должно быть равно, как минимум, числу активных дисков, чтобы было возможно распределить все копии по разным дискам.

Можно иметь несколько типов MD одновременно. Например, если вы имеете три жёстких диска по 200 ГБ выделенных под MD, каждый из которых разбит на два 100 ГБ раздела, можно объединить первые разделы трёх дисков в RAID0 (быстрый 300 ГБ раздел для редактирования видео) и использовать оставшиеся три раздела (2 активных и 1 запасной) для RAID1 (вполне надёжный 100 ГБ раздел для /home).

После настройки MD устройств в соответствии с вашими желаниями, вы можете выбрать Закончить mdcfg и вернуться в partman, чтобы создать файловые системы на новых MD устройствах и назначить им обычные атрибуты типа точек монтирования.

6.3.3.5. Настройка менеджера логических томов (LVM)

Если вы работаете с компьютером на уровне системного администратора или «продвинутого» пользователя, то, определённо, попадали в ситуацию, когда на дисковом разделе (обычно на самом важном) заканчивалось место, а соседний раздел был почти пуст и вы выбирались из этой ситуации переносом данных с одного раздела на другой, созданием символических ссылок и т.д.

Чтобы избежать описанной ситуации вы можете воспользоваться менеджером логических томов (LVM). Проще говоря, с помощью LVM вы можете объединить разделы (физические тома в терминах LVM) в виртуальный диск (так называемую группу томов), который затем можно поделить на виртуальные разделы (логические тома). Выгода в том, что логические тома (и, конечно, содержащие их группы томов) можно распределить по нескольким физическим дискам.

Теперь, когда вы поняли, что вам нужно ещё место на имеющемся 160ГБ /home разделе, вы можете просто добавить новый 300ГБ диск в компьютер, объединить его с существующей группой томов и затем изменить размер логического тома, который содержит файловую систему с /home и вуаля, ваши пользователи имеют дополнительное место на новом 460ГБ разделе. Этот пример, конечно, сильно упрощён. Дополнительную информацию вы найдёте в LVM HOWTO.

Настройка LVM в debian-installer очень проста и полностью поддерживается partman Во-первых, отметьте раздел(ы), которые будут использоваться в качестве физических томов LVM. Это делается с в меню Настройки раздела, где вы должны выбрать Использовать как: → физический том для LVM.

После того как вы вернётесь в главное меню partman, вы увидите новый пункт Настройка менеджера логических томов (LVM). Выбрав его, сначала вас попросят подтвердить сделанные изменения (если есть) в таблице разделов, а затем будет показано меню настройки LVM. Сверху меню кратно показана настройка LVM. Сам состав меню зависит от выбранных настроек и содержит только допустимые действия. Возможные действия:

  • Показать настройку подробней: показывает структуру LVM устройства, имена и размеры логических томов и т.д.

  • Создать группу томов

  • Создание логических томов

  • Удалить группу томов

  • Удаление логических томов

  • Расширить группу томов

  • Уменьшить группу томов

  • Закончить: вернуться в главное меню partman

С помощью этого меню сначала создайте логическую группу, а затем внутри неё логические тома.

После возвращения в главное меню partman, вы должны увидеть все созданные логические тома, как обычные разделы (и настраиваются они одинаково).

6.3.3.6. Настройка шифрованных томов

debian-installer позволяет настраивать шифрованные разделы. Каждый файл, записываемый на такой раздел, немедленно сохраняется на устройстве в шифрованном виде. Доступ к шифрованным данным разрешается только после ввода ключевой фразы, которая задаётся при создании шифрованного раздела. Эта возможность полезна для защиты конфиденциальных данных на ноутбуке или жёстком диске при краже. Вор может получить физический доступ к жёсткому диску, но не зная правильной ключевой фразы, данные на диске выглядят как случайный набор символов.

Два наиболее важных раздела для шифрования: раздел /home, где хранятся ваши личные данные, и раздел подкачки, куда важные данные могут временно попасть во время работы с ними. Естественно, нет никаких препятствий, чтобы зашифровать любые другие разделы, которые могут представлять интерес. Например, /var, где сервера баз данных, почтовые сервера или сервера печати хранят свои данные, или /tmp, который используется разными программами для хранения потенциально важных временных файлов. Некоторые люди могут захотеть зашифровать всю систему. Исключение составляет лишь раздел /boot, который должен остаться не шифрованным, так как пока нельзя загрузить ядро с шифрованного раздела.

Замечание

Заметим, что производительность шифрованных разделов будет меньше чем не шифрованных, так как при каждом чтении и записи данных происходит шифрование и дешифрование. Производительность зависит от быстродействия процессора, выбранного алгоритма шифрования и длины ключа.

Для использования шифрования создайте новый раздел выделив свободное пространство в главном меню разметки. Также можно выбрать уже существующий раздел (например, обычный раздел, логический том LVM или том RAID). В меню Настройки раздела для Использовать как: нужно выбрать физический том для шифрования. После этого в меню для раздела появятся несколько параметров шифрования.

debian-installer поддерживает несколько методов шифрования. Методом по умолчанию является dm-crypt (включён в новые ядра Linux, может работать поверх физических томов LVM), также есть loop-AES (старый, сопровождается отдельно от ядра Linux). Если у вас нет непреодолимых причин, рекомендуется использовать метод по умолчанию.

Сначала давайте рассмотрим возможные параметры, если в качестве метода шифрования выбран Device-mapper (dm-crypt). Как и всегда: если не знаете, используйте значения по умолчанию, так как они вдумчиво выбирались исходя из соображений безопасности.

Шифрование: aes

Этот параметр позволяет выбрать алгоритм шифрования (шифр), который будет использоваться для шифрования данных раздела. debian-installer поддерживает следующие блочные шифры: aes, blowfish, serpent и twofish. Здесь не будет обсуждаться стойкость этих алгоритмов, однако, при выборе вам наверно будет небезынтересно узнать, что в 2000 году AES был выбран Национальным Институтом Стандартизации США в качестве стандартного алгоритма шифрования для защиты конфиденциальной информации в 21-ом веке.

Размер ключа: 256

Здесь вы можете указать длину ключа шифрования. С увеличением размера ключа стойкость шифрования обычно усиливается. С другой стороны, увеличение длины ключа обычно негативно сказывается на производительности. Допустимые размеры ключа зависят от шифра.

IV алгоритм: cbc-essiv:sha256

Вектор инициализации или IV алгоритм используется в криптографии для того, чтобы при шифровании одного и того же обычного текста одинаковым ключом всегда получался уникальный шифрованный текст. Это было введено для того, чтобы при взломе шифра предотвратить нахождение повторяющихся участков в шифрованных данных.

Из предлагаемых возможностей, значение по умолчанию cbc-essiv:sha256 является на сегодняшний момент наименее уязвимым к известным атакам. Используйте альтернативы только когда это нужно для совместимости с раннее установленной системой, в которой невозможно задействовать новые алгоритмы.

Ключ шифрования: ключевая фраза

Здесь можно ввести тип ключа шифрования для этого раздела.

Ключевая фраза

Ключ шифрования будет создан[17] на основе ключевой фразы, которую вы сможете ввести позже.

Произвольный ключ

Новый ключ шифрования будет генерироваться из произвольных данных всякий раз при монтировании раздела. Другими словами: при каждом выключении машины содержимое раздела теряется, так как ключ удаляется из памяти. (Естественно, вы можете попробовать найти ключ перебором всех вариантов, но если в алгоритме шифрования нет неизвестных уязвимостей, это недостижимо за нашу продолжительность жизни.)

Произвольные ключи полезны для разделов подкачки, так как вам не нужно запоминать ключевую фразу из вычищать конфиденциальную информацию из раздела подкачки перед выключением компьютера. Однако, это также означает, что вы не сможете использовать функцию «suspend-to-disk» из новых ядер Linux, так как невозможно (во время последующей загрузки) восстановить приостановленные данные записанные в раздел подкачки.

Стереть данные: да

Задаёт, нужно ли перезаписать содержимое раздела произвольными данными перед настройкой шифрования. Это рекомендуется делать, так как иначе это может позволить злоумышленнику разгадать какие части раздела используются, а какие нет. Также, это усложнит процесс восстановления любых оставшихся от предыдущей установки данных[18].

Если вы выберете в Алгоритм шифрования: → Loopback (loop-AES), то меню будут следующие параметры:

Шифрование: AES256

В loop-AES, в отличие от dm-crypt, параметры для шифра и размера ключа объединены, поэтому вы можете выбрать их вместе. Подробней о шифрах и размерах ключей смотрите в разделах ранее.

Ключ шифрования: Keyfile (GnuPG)

Здесь вы можете выбрать тип ключа шифрования для этого раздела.

файл ключа (GnuPG)

Ключ шифрования будет сгенерирован из произвольных данных во время установки. Кроме того, этот ключ будет зашифрован с помощью GnuPG, поэтому чтобы им воспользоваться, требуется ввести правильную ключевую фразу (которую вас попросят ввести позже в процессе установки).

Произвольный ключ

Подробней о произвольных ключах смотрите в разделе ранее.

Стереть данные: да

Подробней о стирании данных смотрите в разделе ранее.

После выбора желаемых параметров для шифруемых разделов, вернитесь обратно в главное меню разметки. Там должен появиться новый пункт Настроить шифрование для томов. После того как вы его выберете, вас попросят подтвердить удаление данных на разделах, помеченных на стирании и возможно, другие действия, типа записи новой таблицы разделов. Для огромных разделов это может занять некоторое время.

Затем вас попросят ввести ключевую фразу для разделов, настроенные на её использование. Хорошие ключевые фразы должны быть больше 8 знаков, должны содержать вперемешку буквы, числа и другие символы и не должны содержать общеупотребительных словарных слов или информации, которая как-то относится к вам лично (например, дни рождения, хобби, имена домашних животных, имена родственников и тому подобное).

Внимание

Перед вводом ключевых фраз вы должны убедиться, что клавиатура настроена правильно и генерирует ожидаемые символы. Если вы не уверены, можно переключиться на вторую виртуальную консоль и попробовать ввести текст. Это застрахует вас от неожиданностей в последствии, например, если вы вводите ключевую фразу на клавиатуре с раскладкой qwerty, а во время установки вы использовали раскладку azerty. Такая ситуация может случиться по нескольким причинам. Вы могли переключиться на другую раскладку клавиатуры во время установки, или выбранная раскладка ещё не активирована ко времени ввода ключевой фразы для корневой файловой системы.

Если для создания ключей шифрования вы выбрали использование методов без ключевой фразы, то они будут сгенерированы. Так как ядро могло не собрать достаточное количество энтропии на данной ранней стадии установки, процесс может занять продолжительное время. Вы можете ускорить процесс генерации энтропии: например, нажимая произвольные клавиши, или переключиться в оболочку командной строки на второй виртуальной консоли и создать некоторый обмен данными по сети или с диском (загрузив какие-то файлы, скопировать большие файлы в /dev/null и т.д.). Это нужно сделать для каждого шифруемого раздела.

После возвращения в главное меню разметки, вы увидите все шифрованные тома как дополнительные разделы, которые можно настраивать как обычные разделы. В следующем примере показаны два разных тома. Первый зашифрован с помощью dm-crypt, второй с помощью loop-AES.

Шифрованный том (sda2_crypt) - 115.1 ГБ Linux device-mapper
     #1 115.1 GB  F ext3

Файловое loopback устройство (loop0) - 515.2 МБ AES256 keyfile
     #1 515.2 MB  F ext3

Теперь можно назначить томам точки монтирования и изменить тип файловых систем, если значения по умолчанию чем-то не устраивают.

Запишите где-нибудь информацию о соответствии идентификаторов в скобках (sda2_crypt и loop0 в данном случае) и точках монтирования, которые вы назначили шифрованным томам. Эти данные вам потребуются позже при загрузки новой системы. Различия между обычным процессом загрузки и загрузки с шифрованием описаны далее в Раздел 7.2, «Монтирование шифрованных томов».

После того как вас полностью устроит схема разметки, продолжайте установку.

6.3.4. Установка базовой системы

Хотя эта стадия наименее проблематична, она занимает наибольшую часть времени установки, потому что загружается, проверяется и распаковывается вся базовая система. Если у вас медленный компьютер или сетевое соединение, это может занять определённое время.

Во время установки базовой системы сообщения о распаковке и настройке пакетов переправляются на tty4. Вы можете перейти на этот терминал, нажав левый Alt+F4; чтобы вернуться обратно в основной процесс установки нажмите левый Alt+F1.

Сообщения распаковки/настройки во время этого этапа сохраняются в файле /var/log/syslog. Вы можете посмотреть их, если установка выполняется через консоль на последовательном порту.

В одной из частей установки выполняется установка ядра Linux. С приоритетом по умолчанию программа установки выберет ядро наиболее подходящее для вашего оборудования. В режимах с низким приоритетом, это предложат сделать вам из списка доступных ядер.

При установке пакетов с помощью системы управления пакетами по умолчанию также производится установка пакетов, рекомендуемых устанавливаемыми пакетами. Рекомендуемые пакеты не требуются для работоспособности основных возможностей выбранного ПО, но они добавляют новые возможности этому ПО и должны, по мнению сопровождающих, обычно устанавливаться вместе с этим ПО.

Замечание

По техническим причинам, пакеты, устанавливаемые во время установки базовой системы, устанавливаются без их «Рекомендуемых» пакетов. Правило, описанное выше, действует только после данного этапа процесса установки.

6.3.5. Установка дополнительного программного обеспечения

На этом этапе уже есть рабочая, но ограниченная по возможностям система. Большинство пользователей хотело бы добавить дополнительное программное обеспечение в систему, чтобы решать свои задачи, и программа установки позволяет это сделать. Этот этап может продлиться дольше чем установка базовой системы, если у вас медленный компьютер или соединение с сетью.

6.3.5.1. Настройка apt

Одной из программ для установки пакетов в систему является программа под названием apt-get из пакета apt[19]. Также используются другие инструменты для управления пакетами, например, aptitude и synaptic. Эти программы рекомендуются для новичков, так как они объединяют в себе несколько дополнительных свойств (поиск пакетов и отображение состояния) в отличном интерфейсе пользователя. Фактически, aptitude теперь даже рекомендуется использовать для управления пакетами.

Пакету apt нужно указать откуда получать пакеты. Результат настройки сохраняется в файле /etc/apt/sources.list. Вы можете проверить и изменить его по желаю после завершения установки.

Если вы выполняете установку с приоритетом по умолчанию, то программа установки выполнит большую часть настройки автоматически, основываясь на используемом методе установки и, возможно, на ответах, указанных вами ранее. В большинстве случаев программа установки автоматически добавит зеркало безопасности и, если вы используете стабильный дистрибутив, зеркало сервиса обновлений «volatile».

Если вы производите установку с низким приоритетом (например, в экспертном режиме), то вы сможете принять больше решений самостоятельно. Вы сможете выбрать использовать ли сервисы обновлений безопасности и/или часто меняющихся данных (volatile), а также добавлять ли секции пакетов «contrib» и «non-free».

6.3.5.1.1. Установка с нескольких CD или DVD дисков

Если вы производите установку с одного CD или DVD из набора дисков, то программа установки спросит, хотите ли вы просканировать дополнительные CD или DVD диски. Если у вас есть дополнительные диски CD или DVD, то вы, вероятно, захотите это сделать для того, чтобы программа установки могла использовать пакеты с этих дисков.

Если у вас нет дополнительных дисков, это не проблема: их наличие не требуется. Если у вас также нет доступа к сетевому серверу-зеркалу пакетов (описано в следующей разделе) то, возможно, не все пакеты из выбранных на следующем этапе задач смогут быть установлены.

Замечание

Пакеты распределяются по дискам CD (и DVD) согласно популярности. Это значит, что для большинства людей хватит первого CD из набора, и только некоторые люди на самом деле используют пакеты с последнего CD-диска.

Это также означает, что покупка или загрузка и прожиг полного набора CD пустая трата денег, так как большинство дисков просто не будут использоваться. В большинстве случаев достаточно получить только первые от 3 до 8 CD, а устанавливать нужные дополнительные пакеты можно из Интернет с сервера-зеркала. Тоже касается и DVD наборов: первого DVD или, может быть, первых двух DVD хватит для большинства задач.

Практика показывает, что для обычной установки рабочего стола с приложениями (рабочий стол GNOME) требуются только первые три CD. Для альтернативных окружений рабочего стола (KDE или Xfce) нужны дополнительные CD-диски. На первом DVD легко вмещаются все три окружения рабочего стола.

Если вы просканируете несколько CD или DVD-дисков, программа установки будет выдавать сообщение при необходимости смены CD/DVD в приводе. Заметим, что должны сканироваться CD или DVD из одного набора. Порядок сканирования значения не имеет, но сканирование по порядку уменьшает вероятность сделать ошибку.

6.3.5.1.2. Использование сетевого сервера-зеркала пакетов

Один из часто задаваемых вопросов: использовать или нет сетевой сервер-зеркало в качестве источника пакетов. В большинстве случаев значение ответа по умолчанию вполне приемлемо, но не всегда.

Если вы не устанавливаете систему с полного CD или DVD диска или с полного образа CD/DVD, то вы определённо должны использовать зеркала из сети, иначе в конце установки получится очень ограниченная по возможностям система. Однако, если у вас дорогое или медленное подключение к Интернет, то лучше не выбирать задачу рабочий стол на следующем шаге установки.

Если вы устанавливаете систему с одного полного CD-диска или с полного образа CD, то использование зеркала не обязательно, но настоятельно рекомендуется, так как на одном CD содержится совсем немного пакетов. Если у вас дорогое или медленное подключение к Интернет, то пока лучше не выбирать сетевое зеркало, а закончить установку с доступного CD и установить дополнительные пакеты после установки (то есть после перезагрузки в новую систему).

Если вы производите установку с DVD диска или образа, то все нужные для установки пакеты будут на первом DVD. Все пакеты также доступны, если вы просканируете несколько CD-дисков, как это описывалось в предыдущем разделе. Использовать сетевой сервер-зеркало в данном случае необязательно.

Преимуществом добавления сетевого зеркала является то, что обновления пакетов, произошедшие с момента прожига CD/DVD дисков, становятся доступными сразу во время установки, что расширяет срок службы вашего набора CD/DVD без ущерба безопасности или стабильности устанавливаемой системы.

Итог: выбор сетевого сервера-зеркала обычно хорошая идея, если у вас хорошее соединение с Интернет. Если нужная версия пакета есть на CD/DVD, то программа установки будет всегда использовать этот носитель. Размер данных, которые требуется скачать, если вы выбрали зеркало, зависит от

  1. задач, которые вы выберете на следующем этапе установки,

  2. пакетов, которые необходимы для этих задач,

  3. какие из этих пакетов есть на просканированных CD/DVD, и

  4. есть ли обновлённые версии пакетов, имеющихся на CD или DVD, на сервере-зеркале (или на обычном зеркале пакетов, или на зеркалах обновлений безопасности или часто изменяемых данных).

Заметим, что даже если вы выберете не использовать сетевое зеркало, некоторые пакеты могут всё равно быть скачаны из Интернет, если для них есть, согласно сервису безопасности или часто изменяющихся данных, новые версии, и если эти были сервисы настроены.

6.3.5.2. Выбор и установка программного обеспечения

Во время процесса установки вам будет предложено выбрать дополнительное программное обеспечение для установки. Вместо выбора каждой программы из 28250 доступных пакетов, этот этап позволяет сосредоточиться на выборе и установке заранее подготовленных наборов ПО, чтобы быстро настроить компьютер на выполнение определённых задач.

Поэтому, сначала вы можете выбрать задачи, а позже установить дополнительные пакеты. В общем, под задачей подразумеваются какие-то работы или задания, которые вы хотите выполнять на компьютере, например, использовать его как «среду рабочего стола», чтобы он служил в качестве «веб-сервера» или «сервера печати» [20]. В таблице Раздел D.2, «Дисковое пространство, необходимое для задач» показано необходимое пространство для доступных задач.

Некоторые задачи могут быть уже выбраны в зависимости от характеристик компьютера на который производится установка. Если вы не согласны с таким выбором, то можете отменить лишние задачи. Вы даже можете вообще ничего не устанавливать с помощью задач.

Подсказка

В стандартном пользовательском интерфейсе программы установки для выбора/отмены задач используется клавиша пробел.

Замечание

Если вы не используете специальные CD-диски с KDE или Xfce/LXDE, то по задаче «Окружение рабочего стола» будет установлено окружение рабочего стола GNOME.

Во время установки интерактивный выбор рабочего стола не предусмотрен. Однако, возможно заставить debian-installer установить рабочий стол KDE вместо GNOME с помощью автоматизации ответов (см. Раздел B.4.10, «Выбор пакетов») или добавив параметр desktop=kde в строку приглашения к загрузке при запуске программы установки. Или же можно выбрать менее требовательное к ресурсам окружение рабочего стола Xfce или LXDE, указав desktop=xfce или desktop=lxde.

Некоторые CD образы (businesscard, netinst и DVD) также позволяют выбирать желаемое окружение рабочего стола из графического загрузочного меню. Выберите пункт «Advanced options» в главном меню и найдите пункт «Alternative desktop environments».

Заметим, что это сработает, если доступны все пакеты, необходимые для желаемого рабочего стола. Если вы производите установку только с одного полного CD образа, то пакеты нужно скачивать с сервера-зеркала, так как большинство необходимых пакетов включены только на следующих CD-дисках; установка KDE, Xfce или LXDE таким способом замечательно работает при использовании образа DVD или другого метода установки.

Согласно различным серверным задачам будет установлено ПО, указанное ниже. DNS-сервер: bind9; файловый сервер: samba, nfs; почтовый сервер: exim4, spamassassin, uw-imap; сервер печати: cups; база данных SQL: postgresql; веб-сервер: apache2.

По задаче «Стандартная система» установятся все пакеты с приоритетом «стандарт». Сюда входит множество общих утилит, которые есть в любой Linux или Unix системе. Вы должны оставить эту задачу выбранной, если вы новичок и не хотите получить действительно минимально работоспособную систему.

Если в следствии выбора языка локаль по умолчанию стала отличаться от локали «C», то tasksel проверит, определены ли какие-либо задачи локализации для этой локали, и автоматически попытается установить подходящие пакеты локализации. Например, к таким пакетам относятся пакеты со словарями или специальными шрифтами для вашего языка. Если выбрана установка окружения рабочего стола, то также будут установлены соответствующие пакеты локализации (если есть).

После выбора задач нажмите Continue. Теперь aptitude начнёт установку пакетов, которые являются частью указанных задач. Если какой-то программе нужна дополнительная информация от пользователя, то она задаст её во время данного процесса.

Хотим сообщить, что есть очень большие задачи, особенно Рабочий стол. Если установка происходит с обычного CD-ROM и с зеркала пакетов, которых нет на CD-ROM, то программе установки может потребоваться получить много пакетов из сети. Если у вас медленное соединение с интернет, то это займёт много времени. После начала установки пакетов её никак нельзя прервать.

Даже если пакеты есть на CD-ROM, программа установки всё равно может скачивать пакеты с зеркала, если на зеркале есть более новая версия пакета, чем на CD-ROM. Если вы устанавливаете стабильную версию дистрибутива, такое может происходить после обновления выпуска (обновление первого стабильного выпуска); если вы устанавливаете тестируемую версию, то это может происходить, если у вас устаревший образ.

6.3.6. Установка и настройка системного загрузчика

Если вы выполняете установку на бездисковую рабочую станцию, очевидно, что загрузка с локального диска не нужна, и этот шаг можно пропустить.

6.3.6.1. Обнаружение операционных систем

Перед установкой системного загрузчика программа установки попытается обнаружить другие операционные системы, установленные на машине. Если она обнаружит поддерживаемую операционную систему, то это будет отражено на этапе установки системного загрузчика, и компьютер сможет загружать эту операционную систему в дополнении к Debian.

Надо заметить, что загрузка множества операционных систем на одной машине всё ещё напоминает чёрную магию. Автоматическая поддержка обнаружения и настройки системных загрузчиков на загрузку различных операционных систем различается на разных архитектурах и даже субархитектурах. Более подробную информацию можно найти в документации по менеджеру загрузки.

6.3.6.2. Установка системного загрузчика Grub на жёсткий диск

Основной системный загрузчик для i386 называется «grub». Grub — гибкий и понятный системный загрузчик и является хорошим выбором по умолчанию для новичков и опытных пользователей.

По умолчанию, grub будет установлен в главную загрузочную запись (MBR), где будет полностью контролировать процесс загрузки. Если хотите, можете установить его в другое место. Полную информацию смотрите в руководстве по grub.

Если вы не хотите устанавливать grub, нажмите кнопку Go Back, чтобы перейти в главное меню, и там выберите системный загрузчик, который вы хотите использовать.

6.3.6.3. Установка системного загрузчика LILO на жёсткий диск

Второй системный загрузчик для i386 называется «LILO». Это старая сложная программа с множеством функций, включая управление загрузкой DOS, Windows и OS/2. Внимательно прочитайте инструкции из каталога /usr/share/doc/lilo/, если вам нужны эти функции; также посмотрите LILO mini-HOWTO.

Замечание

В данный момент установка LILO только создаст пункты меню для других операционных систем, если они могут быть загружены по цепочке. Это значит, что вы сможете вручную добавить пункты меню для операционных систем, например, GNU/Linux и GNU/Hurd после установки.

debian-installer предлагает три места, куда можно установить системный загрузчик LILO:

Главная загрузочная запись (MBR)

Отсюда LILO будет полностью контролировать процесс загрузки.

новый раздел Debian

Выберите это место, если хотите использовать другой менеджер загрузки. Загрузчик LILO будет установлен в начало раздела, созданного для Debian и будет играть роль вторичного системного загрузчика.

Другой

Полезен для опытных пользователей, которые хотят установить LILO куда-то ещё. Вас попросят указать желаемое размещение. Вы можете использовать традиционные имена устройств типа /dev/hda или /dev/sda.

Если вы не смогли загрузить Windows 9x (или DOS) после этого шага, то вам нужно воспользоваться загрузочной дискетой с Windows 9x (MS-DOS) и запустить команду fdisk /mbr для переустановки главной загрузочной записи MS-DOS — однако, это означает, что вам придётся искать какой-то другой способ, чтобы попасть обратно в Debian!

6.3.6.4. Продолжение без системного загрузчика

Эта опция может быть использована для завершения установки без установки системного загрузчика, если для этой архитектуры/субархитектуры его не существует или потому что, он вам не нужен (например, чтобы использовать существующий системный загрузчик).

Если вы планируете настройку системного загрузчика вручную, то должны узнать имя файла устанавливаемого ядра, которое лежит в каталоге /target/boot. Также, проверьте существование каталога initrd; если он есть, то вероятно нужно указать это в системном загрузчике, чтобы он использовал его. Ещё вам потребуется знать диск и раздел, который выбран в качестве / файловой системы и, если вы выбрали установку с отдельным разделом /boot, то также и раздел файловой системы с /boot.

6.3.7. Завершение установки

Это последний этап установки Debian в процессе которого программа установки выполнит ещё пару действий. В основном, это уборка за debian-installer.

6.3.7.1. Настройка системного времени

Программа установки может спросить вас показывают ли часы компьютера время по Гринвичу (UTC). Обычно этот вопрос, если возможно, не задаётся и программа установки решает, что часы показывают время по Гринвичу, если на машине не установлено других операционных систем.

В экспертном режиме вы всегда можете выбрать установлены ли часы по Гринвичу или нет. В системах, которые (также) работают под Dos или Windows, часы обычно настроены на местное время. Если хотите использовать мультизагрузку, выберите местное время вместо UTC.

На этом этапе debian-installer попытается сохранить текущее время в аппаратных часах системы. Оно будет выставлено в UTC или местном времени, в зависимости от выбора, который вы недавно делали.

6.3.7.2. Перезагрузка системы

Вам предложат вынуть загрузочный носитель (CD, дискету, другой), который использовался для загрузки программы установки. После этого компьютер будет перезагружен в новую систему Debian.

6.3.8. Troubleshooting

Перечисленные в этом разделе компоненты обычно не используются в процессе установки, но они готовы прийти на помощь пользователю в случае, если что-то пойдёт не так.

6.3.8.1. Сохранение протокола установки

Если установка прошла успешно, файлы протокола установки, созданные во время процесса установки, будут автоматически записаны в /var/log/installer/ в новой системе Debian.

Выбор Сохранить файлы журнала с отладочной информацией из главного меню позволяет записать файлы протокола на дискету, через сеть, на жёсткий диск или другой носитель. Это может быть полезно, если вы обнаружили неустранимую проблему при установке и хотите изучить протокол на другой системе или послать его вместе с отчётом об ошибке.

6.3.8.2. Использование командной строки и просмотр журнальных файлов

Есть несколько способов перейти в оболочку командной строки во время выполнения установки. На большинстве систем, и если вы не производите установку с консоли на последовательном порту, самый простой метод — это переключиться на вторую виртуальную консоль нажав левый Alt+F2[21] (на клавиатуре Mac: Option+F2). Чтобы вернуться обратно в программу установки используйте левый Alt+F1.

Описание программы установки с графическим интерфейсом смотрите в Раздел D.6.1, «Использование программы установки с графическим интерфейсом».

Если вы не можете переключаться между консолями, также есть пункт в меню Запуск оболочки, который запускает оболочку. Чтобы из большинства диалогов попасть обратно в главное меню нажмите кнопку Go Back один или несколько раз. Чтобы вернуться обратно в программу установки, введите exit для завершения оболочки.

В данный момент вы загрузились с RAM диска и имеете ограниченный набор Unix утилит. Вы можете выяснить какие утилиты доступны с помощью команды ls /bin /sbin /usr/bin /usr/sbin или набрав help. Клон Bourne оболочки командной строки называется ash и имеет некоторые полезные свойства,такие как автодополнение и история команд.

Для редактирования и просмотра файлов имеется текстовый редактор nano. Журнальные файлы системы установки можно найти в каталоге /var/log.

Замечание

Хотя вы и можете делать в оболочке в помощью команд всё что угодно, не забывайте, что оболочка, прежде всего, предназначалась для отладки и если что-то заработает неправильно.

Выполнение команд в оболочке может повлиять на процесс установки и привести к ошибкам или неполной установке. В частности, вы всегда должны позволить программе установки активировать раздел подкачки и не выполнять это самостоятельно из оболочки командной строки.

6.3.9. Установка по сети

Одной из наиболее интересных компонент является network-console. Она позволяет выполнить огромную часть процесса установки через сеть по протоколу SSH. Чтобы использовать сеть, вам нужно выполнить первые шаги установки из консоли, по крайней мере настройку сети. (Хотя вы можете автоматизировать и эту часть с помощью Раздел 4.6, «Автоматическая установка».)

По умолчанию данная компонента не загружается в главное меню установки, поэтому вам потребуется явно указать это. Если для установки используется CD, вам нужно загрузиться со средним приоритетом или как-то иначе получить главное меню установки и выбрать Загрузка компонент программы установки с компакт-диска и в списке дополнительных компонент выбрать network-console: Continue installation remotely using SSH. При успешной загрузке в меню появится новый пункт Продолжение установки через SSH.

Далее после выбора данного пункта попросят ввести новый пароль и его подтверждение для подключения к устанавливаемой системе. Это всё. Теперь вы должны увидеть инструкции по удалённому подключению в качестве пользователя installer с только что введённым паролем. Также здесь будет показан отпечаток (fingerprint) системы. Вам нужно передать этот отпечаток безопасным образом человеку, который будет продолжать установку удалённо.

Если вы решите продолжить установку локально, то всегда можете нажать клавишу Enter и вернуться обратно в меню чтобы выбрать другую компоненту.

Теперь давайте перейдём на другую сторону соединения. Здесь вам потребуется настроить терминал для работы с кодировкой UTF-8, потому что её использует устанавливаемая система. Если вы не можете этого сделать, удалённая установка всё ещё возможна, но в этом случае вы будете наблюдать на экране странные закорючки вместо границ окон и не-ascii символов. Чтобы установить соединение с удалённой системой просто наберите:

$ ssh -l installer install_host

где install_host это имя или IP-адрес компьютера с запущенной программой установки. Перед приглашением в систему будет показан идентификатор машины (fingerprint), чтобы вы смогли убедиться, что это именно тот компьютер.

Замечание

Сервер ssh из программы установки использует настройки по умолчанию, то есть не отправляет пакеты keep-alive. В принципе, соединение с системой, будучи установленным, должно сохраняться открытым бесконечно. Однако, в некоторых ситуациях — в зависимости настроек вашей локальной сети — соединение может быть потеряно после некоторого периода неактивности. Одним из случаев когда это случается — использование одной из форм трансляции сетевых адресов (NAT) где-то между клиентом и устанавливаемой системой. В зависимости от этапа установки, при котором было разорвано соединение, вы не всегда сможете продолжить установку после переподключения.

Чтобы избежать потери подключения, добавьте параметр -o ServerAliveInterval=значение при запуске соединения ssh, или добавьте этот параметр в свой файл настройки ssh. Заметим однако, что в некоторых случаях добавление этого параметра вообще может приводить к потере соединения (например, если пакеты keep-alive посылались во время краткосрочных проблем в сети, хотя без параметра ssh сам бы восстановился), поэтому используйте это только когда очень нужно.

Замечание

Если вы производите установку на несколько компьютеров последовательно и так получилось, что они имеют одинаковый IP-адрес или имя, то ssh не будет подключаться к таким машинам. Причина в том, что они имеют разные отпечатки, что обычно указывает на атаку подмены. Если вы уверены, что это не так, то вам нужно удалить соответствующую строку из ~/.ssh/known_hosts[22] и попробовать подключиться ещё раз.

После регистрации на удалённой системе вам предложат два варианта:Start menu и Start shell. Выбрав первый, вы попадёте в главное меню программы установки, откуда можно продолжить установку как обычно. Во втором варианте запускается оболочка командной строки, из которой можно проверить и возможно, что-то исправить на удалённой системе. Разрешается запускать только одну сессию SSH для установочного меню и несколько для оболочки командной строки.

Внимание

После запуска установки через SSH, вы не должны возвращаться к установке с консоли, так как это может привести к порче базы данных, которая содержит настройки новой системы. Это, в свою очередь, может привести к неудачному завершению установки или проблемам в установленной системой.

[12] Технически говоря: когда для языка существует несколько локалей с различными кодами стран.

[13] Установив средний или низкий приоритет, вы всегда можете выбрать предпочитаемую локаль из тех, что доступны для выбранного языка (если есть больше одной).

[14] Старые локали — это локали, не использующие UTF-8, с устаревшей стандартной символьной кодировкой, например ISO 8859-1 (используется для западно-европейских языков) или EUC-JP (используется для японского языка).

[15] Программа установки шифрует групповые тома LVM 256-битным ключом AES и использует поддержку «dm-crypt» в ядре.

[16] Если честно, вы можете собрать MD устройство даже из обычных разделов, расположенных на одном физическом жёстком диске, но это не даст никакой выгоды.

[17] Использование ключевой фразы в качестве ключа означает, что раздел будет настроен с помощью LUKS.

[18] Однако, есть мнение, что ребята из служб на три буквы могут восстанавливать данные даже после их неоднократной перезаписи на магнитооптических носителях.

[19] Заметим, что программа, которая в действительности устанавливает пакеты, называется dpkg. Однако, это более низкоуровневая утилита. apt-get — утилита более высокого уровня, так как вызывает dpkg при необходимости. Она знает как получить пакет с CD, по сети или как-то ещё. Также, она может автоматически установить другие пакеты, которые нужны для работы пакету, который вы пытаетесь установить.

[20] Вы должны знать, что для предоставления этого списка программа установки просто вызывает программу tasksel. Её можно запустить в любое время после установки, чтобы установить (или удалить) некоторые пакеты, или же вы можете воспользоваться другим более точным инструментом aptitude. Если вам нужен какой-то определённый пакет, то после завершения установки просто запустите aptitude install пакет, где пакет — это имя требуемого пакета.

[21] То есть: нажмите клавишу Alt с левой стороны от клавиши пробел и функциональную клавишу F2 одновременно.

[22] Для удаления существующей записи об узле можно воспользоваться командой: ssh-keygen -R <имя_узла|IP-адрес>.

Пред. | Уровень выше | След.
6.2. Описание компонент | Начало | 6.4. Загрузка отсутствующих микропрограмм


6.4. Загрузка отсутствующих микропрограмм
Пред. Глава 6. Использование программы установки Debian След.

6.4. Загрузка отсутствующих микропрограмм

Как описывалось в Раздел 2.2, «Устройства, которым требуются микропрограммы», в некоторые устройства требуется загрузить микропрограмму. В большинстве случаев, устройство вообще не будет работать при отсутствии микропрограммы; иногда в устройстве всё-же работают базовые функции, а микропрограмма нужна только для предоставления дополнительных возможностей.

Если драйвер устройства запрашивает микропрограмму, а она недоступна, то debian-installer выведет окно диалога, предлагающее загрузить отсутствующую микропрограмму. Если ответить утвердительно, то debian-installer просканирует доступные устройства в поисках файлов или пакетов с нужной микропрограммой. Если файлы найдены, то микропрограмма будет скопирована в нужное место (/lib/firmware) и будет предпринята попытка перезагрузки модуля с драйвером.

Замечание

Список сканируемых устройств и файловых систем зависит от архитектуры, метода установки и этапа установки. На самых первоначальных этапах установки успешная загрузка микропрограммы наиболее вероятна с дискет или USB-носителей с файловой системой FAT. На i386 и amd64 микропрограмма также загружается с карт MMC или SD.

Заметим, что можно пропустить загрузку микропрограммы, если вы уверены, что устройство будет работать и без неё, или если устройство не требуется во время установки.

Внимание

Функция загрузки микропрограммы появилась сравнительно недавно и, по всей вероятности, будет улучшена в будущих выпусках программы установки. В настоящий момент, debian-installer, например, не выводит предупреждение, если вы выбрали загрузку отсутствующей микропрограммы, а файлы для неё не нашлись. Сообщайте о любых обнаруженных проблемах в отчёте об установке (см. Раздел 5.4.6, «Отправка отчётов об ошибках установки»).

6.4.1. Подготовка носителя

Хотя в большинстве случаев микропрограмма может быть загружена с раздела жёсткого диска, чаще всего она загружается с какого-нибудь сменного носителя, например, дискеты или карты памяти USB. Файлы или пакеты с микропрограммой должны быть размещены в корневом каталоге или каталоге с именем /firmware в файловой системе носителя. Рекомендуется использовать файловую систему FAT, так как она, скорее всего, поддерживается на самых ранних этапах установки.

Tar-архивы и файлы zip с пакетами наиболее распространённых микропрограмм доступны здесь:

  • http://cdimage.debian.org/cdimage/unofficial/non-free/firmware/

Просто скачайте tar-архив или zip-файл под нужный выпуск и распакуйте его на файловую систему носителя.

Если требуемой микропрограммы нет в tar-архиве, то также вы можете скачать нужные пакеты с микропрограммами из архива (из раздела non-free). Вот список наиболее скачиваемых пакетов микропрограмм, но он может быть не полон и также может содержать пакеты без микропрограмм:

  • http://packages.debian.org/search?keywords=firmware

Также, можно копировать на носитель отдельные файлы микропрограммы. Такие микропрограммы можно получить, например, из уже установленной системы или от поставщика оборудования.

6.4.2. Микропрограмма в установленной системе

Все микропрограммы, загруженные во время установки, будут автоматически скопированы в установленную систему. В большинстве случаев это гарантирует, что устройство, которому требуется микропрограмма , будет также работать правильно после перезагрузки компьютера в установленную систему. Однако, если установленная система работает на версии ядра, отличной от использованного в программе установки, есть небольшая вероятность, что микропрограмма не загрузится из-за изменений ядра.

Если микропрограмма загружена из пакета, то debian-installer также установит этот пакет в устанавливаемую систему и автоматически добавит раздел non-free архива пакетов в APT-файл sources.list. Это позволит автоматически обновлять микропрограмму при появлении новой версии.

Если загрузка микропрограммы была пропущена во время установки, то соответствующее устройство, вероятно, не заработает в установленной системе пока микропрограмма (пакет) не будет установлена вручную.

Замечание

Если микропрограмма была загружена из отдельных файлов, то скопированная в установленную систему микропрограмма не будет автоматически обновляться, пока не не будет установлен соответствующий пакет с микропрограммой (если есть) после завершения установки.

Пред. | Уровень выше | След.
6.3. Применение отдельных компонент | Начало | Глава 7. Загрузка только что установленной системы Debian


Глава 7. Загрузка только что установленной системы Debian
Пред. След.

Глава 7. Загрузка только что установленной системы Debian

Содержание

7.1. Момент истины
7.2. Монтирование шифрованных томов
7.2.1. dm-crypt
7.2.2. loop-AES
7.2.3. Устранение неполадок
7.3. Вход в систему
Пред. |  | След.
6.4. Загрузка отсутствующих микропрограмм | Начало | 7.1. Момент истины


7.1. Момент истины
Пред. Глава 7. Загрузка только что установленной системы Debian След.

7.1. Момент истины

Первую самостоятельную загрузку системы инженеры-электрики называют «smoke test».

Если выполнялась установка по умолчанию, первое, что вы увидите при запуске системы — это меню системного загрузчика grub или, возможно, lilo. Под первым пунктом меню будет загрузка новой системы Debian. Каждой имеющейся на компьютере другой операционной системе, обнаруженной во время установки, присвоен отдельный пункт в меню (расположены ниже).

Если система не загружается, не волнуйтесь. Если установка завершилась успешно, то это всего лишь результат какой-то несущественной проблемы, которая не позволяет системе загрузить Debian. В большинстве случаев такие проблемы решаются без повторной установки. Одним из методов решения проблем с загрузкой является встроенный в программу установки режим восстановления (Раздел 8.7, «Восстановление неработающей системы»).

Если вы новичок в Debian и Linux, вам может потребоваться помощь более опытных пользователей. Чтобы получить помощь быстро, вы можете попробовать воспользоваться IRC каналами #debian или #debian-boot сети OFTC. Или же вы можете написать вв список рассылки debian-user. Также вы можете отправить отчёт об установке как это описано в Раздел 5.4.6, «Отправка отчётов об ошибках установки». Описывайте проблему как можно понятнее, добавьте все сообщения которые отображались, они могут помочь определить причину проблемы.

Если у вас на компьютере есть другие операционные системы, и они не определились или определились неправильно, отправьте отчёт об установке.

Пред. | Уровень выше | След.
Глава 7. Загрузка только что установленной системы Debian | Начало | 7.2. Монтирование шифрованных томов


7.2. Монтирование шифрованных томов
Пред. Глава 7. Загрузка только что установленной системы Debian След.

7.2. Монтирование шифрованных томов

Если вы создали шифрованные тома во время установки и назначили им точки монтирования, то во время загрузки машины вас попросят ввести ключевую фразу на каждый том. В процедуре ввода для dm-crypt и loop-AES есть некоторые различия.

7.2.1. dm-crypt

Для разделов, зашифрованных dm-crypt, во время загрузки вы увидите следующее сообщение:

Starting early crypto disks... part_crypt(starting)
Enter LUKS passphrase:

В первой строке приглашения, вместо part будет указано название используемого раздела, например sda2 или md0. Вы, вероятно, задумаетесь: для какого тома нужно вводить ключевую фразу? Для /home? Или для /var? Естественно, если у вас только один шифрованный том, это легко и вы можете просто ввести ключевую фразу, которую задали при настройке тома. Если же у вас несколько шифрованных томов, то пригодятся заметки, которые вы сделали на последнем этапе Раздел 6.3.3.6, «Настройка шифрованных томов». Если вы ранее не записали соответствие между part_crypt и точкой монтирования, то можете выяснить это в файлах /etc/crypttab и /etc/fstab на новой системе.

При монтировании зашифрованного корневого раздела приглашение может выглядеть несколько иначе. Это зависит от генератора initramfs, который использовался при создании initrd для загрузки системы. Пример для initrd, созданного с помощью initramfs-tools:

Begin: Mounting root file system... ...
Begin: Running /scripts/local-top ...
Enter LUKS passphrase:

Во время ввода ключевой фразы символы не отображаются (даже звёздочками). Если вы введёте неверную ключевую фразу, то у вас ещё есть две попытки. После третьей попытки процесс загрузки пропустит этот том и начнётся монтирование следующей файловой системы. Подробней смотрите в Раздел 7.2.3, «Устранение неполадок».

После ввода всех ключевых фраз загрузка продолжится как обычно.

7.2.2. loop-AES

Для разделов, зашифрованных loop-AES, во время загрузки вы увидите следующее приглашение:

Checking loop-encrypted file systems.
Setting up /dev/loopX (/mountpoint)
Password:

Во время ввода ключевой фразы символы не отображаются (даже звёздочками). Если вы введёте неверную ключевую фразу, то у вас ещё есть две попытки. После третьей попытки процесс загрузки пропустит этот том и начнётся монтирование следующей файловой системы. Подробней смотрите в Раздел 7.2.3, «Устранение неполадок».

После ввода всех ключевых фраз загрузка продолжится как обычно.

7.2.3. Устранение неполадок

Если некоторые шифрованные тома не были смонтированы из-за ввода неправильной ключевой фразы, их можно смонтировать вручную после загрузки. Но есть несколько случаев.

  • Первый случай касается корневого раздела. Если он не смонтирован, то процесс загрузки остановится, а вам придётся перезагрузить компьютер чтобы попробовать ещё раз.

  • Простейший случай — шифрованные тома с данными типа /home или /srv. Вы можете просто смонтировать их после загрузки. Для loop-AES это делается в одно действие:

    # mount /точка_монтирования
Password:

    , где /точку_монтирования нужно заменить именем каталога (например, /home). Отличие от обычной операции монтирования только в запросе ключевой фразы для этого тома.

    Для dm-crypt немного сложнее. Во-первых вам нужно зарегистрировать тома с помощью device mapperвыполнив:

    # /etc/init.d/cryptdisks start

    Эта операция просканирует все тома указанные в /etc/crypttab и создаст соответствующие устройства в каталоге /dev после ввода правильных ключевых фраз. (Тома зарегистрированные ранее будут пропущены, поэтому вы можете спокойно запускать эту команду несколько раз.) После успешной регистрации вы можете смонтировать тома как обычно:

    # mount /точка_монтирования

  • Если на любых несмонтированных томах содержатся некритичные системные файлы (/usr или /var), система должна загрузиться и вы сможете смонтировать тома вручную как в предыдущем случае. Однако, может потребоваться (пере)запуск каждого сервиса, который обычно запускается на уровне выполнения по умолчанию, так как скорее всего они не смогли запуститься. Самый простой способ сделать это — перейти на первый уровень выполнения и вернуться назад с помощью запуска

    # init 1

    в оболочке и нажать Control+D когда попросят ввести пароль суперпользователя.

Пред. | Уровень выше | След.
7.1. Момент истины | Начало | 7.3. Вход в систему


7.3. Вход в систему
Пред. Глава 7. Загрузка только что установленной системы Debian След.

7.3. Вход в систему

После загрузки системы будет показано приглашение к входу в систему. Для входа используйте персональный логин и пароль, которые вы указали во время процесса установки. Система готова к работе.

Если вы новичок, то начните с просмотра документации, которая уже установлена в системе. Есть несколько систем документации, продолжается работа над их объединением. Вот несколько мест, откуда можно начать.

Документация на установленные программы находится в /usr/share/doc/ в подкаталоге с именем этой программы (точнее, с именем пакета Debian, в котором содержится эта программа). Однако более полная документация часто упакована отдельно в специальные пакеты с документацией, которые по умолчанию не устанавливаются. Например, документацию на программу управления пакетами apt можно найти в пакетах apt-doc или apt-howto.

Также, /usr/share/doc/ содержит несколько специальных каталогов. Linux HOWTO установлены в формате .gz в каталог /usr/share/doc/HOWTO/en-txt/. После установки dhelp появляется файл /usr/share/doc/HTML/index.html со ссылками на документацию.

Простой способ просмотреть эту документацию — запустить текстовый браузер с помощью команд:

$ cd /usr/share/doc/
$ w3m .

Точка после команды w3m служит для показа содержимого текущего каталога.

Если у вас установлено графическое окружение рабочего стола, то также вы можете использовать веб-браузер. Запустите веб-браузер из меню приложений и введите /usr/share/doc/ в строке адреса.

Также вы можете набрать info команда или man команда, чтобы получить документацию по большинству команд доступных в командной строке. Набрав help, вы увидите помощь по командам интерпретатора командной строки. А при вводе имени команды с параметром --help обычно выдаётся короткая справка по использованию программы. Если начало результата выполнения команды уехало за пределы экрана, добавьте | more после команды, и это включит паузу при заполнении всего экрана. Чтобы увидеть список всех доступных команд, начинающихся с определённого символа, введите символ и нажмите клавишу табуляции два раза.

Пред. | Уровень выше | След.
7.2. Монтирование шифрованных томов | Начало | Глава 8. Следующие шаги и что делать дальше


Глава 8. Следующие шаги и что делать дальше
Пред. След.

Глава 8. Следующие шаги и что делать дальше

Содержание

8.1. Выключение системы
8.2. Если вы новичок в Unix
8.3. Самостоятельное ориентирование в Debian
8.3.1. Система управления пакетами Debian
8.3.2. Управление версиями приложений
8.3.3. Управление заданиями cron
8.4. Что почитать
8.5. Настройка почты
8.5.1. Почтовая конфигурация по умолчанию
8.5.2. Отправка почты из системы
8.5.3. Настройка агента пересылки почты Exim4
8.6. Сборка нового ядра
8.6.1. Управление образами ядра
8.7. Восстановление неработающей системы
Пред. |  | След.
7.3. Вход в систему | Начало | 8.1. Выключение системы


8.1. Выключение системы
Пред. Глава 8. Следующие шаги и что делать дальше След.

8.1. Выключение системы

Чтобы выключить работающую Debian GNU/Linux систему, вы не должны использовать кнопку сброса на передней панели корпуса компьютера или просто выключать электропитание. Debian GNU/Linux нужно выключать правильно, иначе можно потерять файлы и/или повредить жёсткий диск. Если вы работаете в окружении рабочего стола, то обычно есть возможность «завершить сеанс» из меню приложений, которая позволяет выключить (или перезагрузить) систему.

Также можно нажать комбинацию клавиш Ctrl+Alt+Del . Если комбинация клавиш не работает или вы предпочитаете вводить команды, то как последний вариант можно войти в систему под именем root и выполнить одну из следующих команд: poweroff, halt или shutdown -h now; для перезагрузки системы используйте команду reboot.

Пред. | Уровень выше | След.
Глава 8. Следующие шаги и что делать дальше | Начало | 8.2. Если вы новичок в Unix


8.2. Если вы новичок в Unix
Пред. Глава 8. Следующие шаги и что делать дальше След.

8.2. Если вы новичок в Unix

Если вы новичок в Unix, то, вероятно, вам стоит купить несколько книг и что-нибудь почитать. Много полезной информации можно найти в справочнике по Debian. В списке Unix FAQs содержатся ссылки на некоторые интересные документы UseNet.

Linux — это одна из реализаций Unix. Linux Documentation Project (LDP) собирает различные HOWTO и электронные книги, посвящённые Linux. Большинство из этих документов можно получить просто установив пакет doc-linux-html (HTML версия) или пакет doc-linux-text (ASCII версия), а затем перейти в каталог /usr/share/doc/HOWTO. Переводы LDP HOWTO также доступны в виде пакетов Debian.

Пред. | Уровень выше | След.
8.1. Выключение системы | Начало | 8.3. Самостоятельное ориентирование в Debian


8.3. Самостоятельное ориентирование в Debian
Пред. Глава 8. Следующие шаги и что делать дальше След.

8.3. Самостоятельное ориентирование в Debian

Debian слегка отличается от других дистрибутивов. Даже если вы знакомы с другими дистрибутивами Linux, есть вещи, которые вы должны знать о Debian, чтобы поддерживать систему в рабочем состоянии. Эта глава содержит материалы, которые помогут вам ориентироваться; она не является руководством по использованию Debian, она всего лишь кратко описывает систему для занятых людей.

8.3.1. Система управления пакетами Debian

Наиболее важно разобраться в системе управления пакетами Debian. В сущности, большая часть системы находится под контролем системы управления пакетами. Сюда входят:

  • /usr (кроме /usr/local)

  • /var (вы можете сделать /var/local, там меняться ничего не будет)

  • /bin

  • /sbin

  • /lib

Например, если вы замените /usr/bin/perl, он будет работать, но позже, если вы обновите пакет perl, файл, который вы положили будет заменён. Эксперты могут обойти это, установив на пакеты флаг «hold» в aptitude.

Один из лучших методов установки пакетов — apt. Вы можете использовать версию для командной строки apt-get или полноэкранную текстовую версию aptitude. Заметим, что apt также позволяет объединить main, contrib и non-free, так что вы можете устанавливать имеющие экспортные ограничения пакеты вместе с обычными.

8.3.2. Управление версиями приложений

Альтернативность версий приложений управляется с помощью программы update-alternatives. Если вы работаете с несколькими версиями одного приложения, прочитайте страницу руководства к update-alternatives.

8.3.3. Управление заданиями cron

Любые работы относящиеся к администрированию системы должны проводится в каталоге /etc, так как там расположены конфигурационные файлы. Если у вас есть ежедневные, еженедельные или ночные задания cron для суперпользователя, поместите их в каталог /etc/cron.{daily,weekly,monthly}. Они вызываются из /etc/crontab и запускаются в алфавитном порядке.

С другой стороны, если задания: (а) нужно запускать от определённого пользователя или (b) нужно запустить в определённое время или с определённой частотой, вы можете использовать или /etc/crontab, или, что лучше, /etc/cron.d/имя_задания. Это особые файлы, они содержат дополнительное поле, позволяющее вам указать учётную запись пользователя, от которого будет выполняться задание cron.

В любом случае, просто отредактируйте файлы, и cron обнаружит эти изменения автоматически. Не нужно запускать специальную команду. Подробная информация доступна в cron(8), crontab(5) и /usr/share/doc/cron/README.Debian.

Пред. | Уровень выше | След.
8.2. Если вы новичок в Unix | Начало | 8.4. Что почитать


8.4. Что почитать
Пред. Глава 8. Следующие шаги и что делать дальше След.

8.4. Что почитать

Если вам требуется информация по определённой программе, сначала, попробуйте выполнить man название программы или info название программы.

Также, есть много полезной документации в каталоге /usr/share/doc. В частности, в каталогах /usr/share/doc/HOWTO и /usr/share/doc/FAQ содержится море интересных сведений. Информацию об ошибках смотрите в /usr/share/doc/debian/bug*. Отличия в работе определённой программы, касающиеся Debian, смотрите в файле /usr/share/doc/(имя пакета )/README.Debian.

Веб-сайт Debian содержит огромное количество документации по Debian. В частности, посмотрите Debian GNU/Linux FAQ и Справочник по Debian. Каталог документации Debian находится по адресуПроект Документации Debian. Можно обратиться с вопросом к сообществу Debian подписавшись на один или более списков рассылки Debian Подписка на списки рассылки. Также, не последнее место занимают Архивы списков рассылки Debian, содержащие ценную информацию о Debian.

Общая информация о GNU/Linux есть в проекте документации Linux. Здесь вы найдёте разные HOWTO и ссылки на другие превосходные источники информации на компоненты системы GNU/Linux.

Пред. | Уровень выше | След.
8.3. Самостоятельное ориентирование в Debian | Начало | 8.5. Настройка почты


8.5. Настройка почты
Пред. Глава 8. Следующие шаги и что делать дальше След.

8.5. Настройка почты

Сегодня электронная почта (email) — это очень важная часть жизни многих людей. Так как при настройке почты используется много параметров, а правильность настройки влияет на многие программы в Debian, в этом разделе мы попытаемся описать основные моменты настройки.

Почтовая система состоит из трёх частей. Первая: пользовательский почтовый агент [Mail User Agent] (MUA) — это программа, с которой работает пользователь для написания и чтения писем. Вторая: агент пересылки почты [Mail Transfer Agent] (MTA) — отвечает за пересылку сообщений между компьютерами. Третья: агент доставки почты [Mail Delivery Agent] (MDA) — отвечает за доставку входящей почты в почтовый ящик пользователя.

Данные части могут выполняться разными программами, но могут быть и объединены в одной или двух программах. Также можно настроить, чтобы разные виды почты обрабатывались разными программами.

Исторически, в системах Linux и Unix очень популярным MUA является mutt. Как и большинство классических программ Linux он имеет текстовый интерфейс. Часто он используется в связке с exim или sendmail, работающих в качестве MTA и procmail в качестве MDA.

В связи с ростом популярности систем с графическим рабочим столом, становятся более востребованными почтовые программы с графическим интерфейсом типа GNOME evolution, KDE kmail или Mozilla thunderbird (в Debian имеет название icedove[23]). В этих программах объединены функции MUA, MTA и MDA, но они могут (так часто и происходит) использоваться совместно с классическими утилитами Linux.

8.5.1. Почтовая конфигурация по умолчанию

Даже если вы планируете использовать почтовую программу с графическим интерфейсом, очень важно, чтобы в системе Debian GNU/Linux также были установлены и правильно настроены классические MTA/MDA. Они нужны для различных утилит, которые работают в системе [24], чтобы они могли послать важные уведомления по почте системному администратору о (потенциальных) проблемах или изменениях.

По этой причине по умолчанию устанавливаются пакеты exim4 и mutt (если вы не отменили задачу «стандарт» во время установки). exim4 — это комбинация MTA/MDA, имеет относительно небольшой размер, но очень гибок в конфигурировании. По умолчанию, он настраивается на обработку только локальной почты самой системы, а почта, предназначенная системному администратору (учётная запись root), будет доставлена на учётную запись обычного пользователя, созданного во время установки[25].

При доставке почты она добавляется в файл /var/mail/учётная_запись. Почту можно читать с помощью mutt.

8.5.2. Отправка почты из системы

Как было упомянуто ранее, установленная система Debian настроена для обработки только локальной почты, она не может отправлять или принимать почту от других систем.

Если вы хотите, чтобы exim4 обрабатывал внешнюю почту, перейдите в следующий подраздел, в котором описаны основные параметры настройки. Обязательно протестируйте приём и отправку почтовых сообщений.

Если вы будете использовать почтовую программу с графическим интерфейсом с почтовым сервером вашего провайдера интернет (ISP) или вашей компании, то необязательно настраивать exim4 для обработки внешней почты. Просто укажите в любимой почтовой программе с графическим интерфейсом нужные серверы для отправки и приёма сообщений (не описано в данном руководстве).

Однако, в этом случае вам потребуется правильно настроить отдельные утилиты, чтобы они могли отправлять почту. Одной из таких утилит является reportbug, программа для отправки сообщений об ошибках в пакетах Debian. По умолчанию, она настроена на использование exim4.

Чтобы правильно настроить reportbug на использование внешнего почтового сервера, запустите команду reportbug --configure и ответьте «нет» на вопрос о доступности MTA. Затем вас попросят указать сервер SMTP, который нужно использовать для отправки сообщений об ошибках.

8.5.3. Настройка агента пересылки почты Exim4

Если вы хотите, чтобы система также работала с внешней почтой, то вам нужно перенастроить пакет exim4[26]:

# dpkg-reconfigure exim4-config

После ввода этой команды (имея права суперпользователя), вас спросят, хотите ли вы разделить конфигурацию на маленькие файлы. Если не знаете что делать, выберите установку по умолчанию.

Затем вам будет предложено несколько общих почтовых сценариев. Выберите тот, который подходит вам больше всего.

интернет-сайт

Ваша система подключена к сети, почта отправляется и получается напрямую по протоколу SMTP. На следующих экранах вам зададут несколько основных вопросов, таких как почтовое имя вашей машины или список доменов, для которых вы принимаете или передаёте почту.

отправка почты через компьютер-шлюз (smarthost)

По этому сценарию ваша исходящая почта переправляется на другую машину, называемую «smarthost», которая и отправит письмо по назначению. Smarthost обычно ещё и хранит входящую почту, адресованную вашему компьютеру, так что вам не надо постоянно находиться в сети. Это также означает, что вам нужно загружать почту со smarthost с помощью программ типа fetchmail.

В большинстве случаев, в качестве smarthost используется почтовый сервер вашего ISP, что очень подходит пользователям, которые используют модемное подключение по телефонной линии. Также это может быть почтовый сервер компании или другая система в вашей сети.

отправка почты через smarthost; локальная почта отсутствует

То же самое, что и предыдущее значение, кроме того, что система не будет настроена на обработку почты локального домена. Почта от самой системы (например, для системного администратора) всё равно будет обработана.

доставка только локальной почты

Настроено в системе по умолчанию.

в данный момент конфигурация отсутствует

Выберите этот вариант, если вы абсолютно уверены в том, что делаете. Это оставит вас с ненастроенной почтовой системой; до тех пор пока вы не настроите её, вы не сможете отправлять или получать почту и вы можете пропустить некоторые важные сообщения от ваших системных утилит.

Если ни один из этих сценариев не подходит, или нужна более тонкая настройка, то после завершения установки вам нужно отредактировать файлы конфигурации в каталоге /etc/exim4. Дополнительную информацию про exim4 можно найти в каталоге /usr/share/doc/exim4; в файле README.Debian.gz содержатся дополнительные подробности о настройке exim4 и указано где найти дополнительную документацию.

Заметим, что если у вас нет официального доменного имени и вы отправляете почту в интернет напрямую, это может привести к тому, что ваша почта не будет приниматься серверами, так как на них установлены средства борьбы со спамом. Предпочтительней использовать почтовый сервер ISP. Если вы всё равно хотите отправлять почту напрямую, то вам нужно использовать другой почтовый адрес, а не сгенерированный по умолчанию. Если в качестве MTA используется exim4, это это делается добавлением записи в файл /etc/email-addresses.

[23] Причиной переименования thunderbird в icedove стала проблема с лицензией. Подробности выходят за рамки этого руководства.

[24] Примеры: cron, quota, logcheck, aide, …

[25] Пересылка почты root на учётную запись обычного пользователя настраивается в файле /etc/aliases. Если учётная запись обычного пользователя не была создана, почта, естественно, будет направляться самой учётной записи root.

[26] Конечно, также вы можете удалить exim4 и заменить его другим MTA/MDA.

Пред. | Уровень выше | След.
8.4. Что почитать | Начало | 8.6. Сборка нового ядра


8.6. Сборка нового ядра
Пред. Глава 8. Следующие шаги и что делать дальше След.

8.6. Сборка нового ядра

Зачем пересобирать ядро? Обычно этого делать не нужно, так как ядро, устанавливаемое по умолчанию в Debian, подходит для многих конфигураций. Кроме этого, в Debian есть ещё несколько сборок ядра. Поэтому, сначала проверьте, может другой пакет с ядром лучше подходит для вашего компьютера. Однако, полезно пересобрать ядро в следующих случаях:

  • если установлено специфичное оборудование или возникает конфликт аппаратного обеспечения со стандартным ядром

  • чтобы задействовать свойства, которых нет в поставляемых сборках ядра (например, поддержка high memory)

  • для оптимизации ядра, удаляя ненужные драйверы для уменьшения времени загрузки

  • создания монолитного ядра, без модулей

  • для установки обновлённого или разрабатываемого ядра

  • чтобы больше узнать о ядрах linux

8.6.1. Управление образами ядра

Не бойтесь пересобирать ядро. Это забавно и полезно.

Чтобы собрать ядро по технологии Debian, вам потребуются некоторые пакеты: fakeroot, kernel-package, linux-source-2.6 и некоторые другие, которые, вероятно, уже установлены (в /usr/share/doc/kernel-package/README.gz есть полный список).

С помощью этого метода создаётся .deb файл из исходных текстов ядра, а также, если у вас имеются нестандартные модули, делается .deb файл с синхронизированными зависимостями. Это наилучший способ управления образами ядра; в /boot лежит ядро, System.map и журнальный конфигурационный файл от сборки.

Заметим, что вам не обязательно собирать ядро «по технологии Debian»; но мы пришли к выводу, что управлять ядрами с помощью системы управления пакетами на самом деле безопаснее и легче. Фактически, вы можете получить исходные тексты ядра прямо у Линуса, а не в виде linux-source-2.6, и собрать ядро с помощью kernel-package.

Заметим, что полную документацию по использованию kernel-package можно найти в /usr/share/doc/kernel-package. Этот раздел содержит лишь краткое руководство.

Далее мы предполагаем, что вы можете делать на своей машине что угодно и распаковываете исходные тексты ядра в домашний каталог[27]. Также мы предполагаем, что у вас ядро версии 2.6.32. Проверьте, что вы находитесь в каталоге куда хотите распаковать исходные тексты ядра, распакуйте их с помощью команды tar xjf /usr/src/linux-source-2.6.32.tar.bz2 и перейдите в только что появившийся каталогlinux-source-2.6.32.

Теперь вы можете выполнить настройку ядра. Если установлены, настроены и запущены X11, то запустите make xconfig, иначе make menuconfig (вам потребуется установить пакет libncurses5-dev). Внимательно прочитайте интерактивную документацию и внимательно выберите нужные параметры. Если что-то непонятно, обычно лучше включить драйвер устройства (программное обеспечение, которое управляет установленным оборудованием, например, картами Ethernet, SCSI-контроллерами и так далее). Будьте осторожны: для других параметров, не относящихся к определённому аппаратному обеспечению, нужно оставить значения по умолчанию, если вы не понимаете, что они делают. Не забудьте выбрать «Kernel module loader» в «Loadable module support» (не включён по умолчанию). Если его не включить, возникнут проблемы с установкой Debian.

Очистите дерево исходных текстов и сбросьте параметры kernel-package. Для этого выполните make-kpkg clean.

Теперь соберите ядро: fakeroot make-kpkg --initrd --revision=custom.1.0 kernel_image. Номер версии «1.0» можно изменить; этот номер версии нужен только для отслеживания ваших сборок. Более того, вы можете добавить любое слово вместо «custom» (например, имя машины). Сборка ядра может занять некоторое время в зависимости от мощности машины.

После завершения сборки вы можете установить собранное ядро как обычный пакет. От суперпользователя выполните dpkg -i ../linux-image-2.6.32-субархитектура_custom.1.0_i386.deb. Часть субархитектура — это необязательная субархитектура, например, «686», зависящая от установленных параметров ядра. dpkg -i установит ядро вместе с некоторыми полезными файлами поддержки. Например, будет правильно установлен System.map (полезен при отладке проблем с ядром), а также /boot/config-2.6.32, содержащий параметры сборки ядра. Также, пакет способен автоматически использовать системный загрузчик платформы для обновления загрузки. Если вы создали пакет с модулями, то вам нужно установить и его.

Настало время перезагрузить систему: внимательно прочитайте все предупреждения, которые могут появиться, затем наберите shutdown -r now.

Подробней о ядрах Debian и сборке ядра смотрите в Debian Linux Kernel Handbook. Полная информация о kernel-package лежит в каталоге /usr/share/doc/kernel-package.

[27] Есть несколько мест куда можно распаковывать исходные тексты и собрать своё ядро, но это самый лёгкий способ без необходимости раздачи специальных прав.

Пред. | Уровень выше | След.
8.5. Настройка почты | Начало | 8.7. Восстановление неработающей системы


8.7. Восстановление неработающей системы
Пред. Глава 8. Следующие шаги и что делать дальше След.

8.7. Восстановление неработающей системы

Иногда что-то идёт неправильно, и система, которую вы аккуратно установили больше не загружается. Возможно, испортились настройки системного загрузчика во время изменения, или не хочет загружаться новое ядро, или космические лучи попали в жёсткий диск и исправили единичку на нолик в файле /sbin/init. В любом случае, вам нужна система с которой можно всё исправить, и режим восстановления может помочь в этом.

Чтобы войти в режим восстановления, введите rescue после приглашения boot:, или загрузитесь с параметром загрузки rescue/enable=true . В начале вы пройдёте по нескольким диалогам программы установки, на которых есть пометка в углу экрана, что это режим восстановления, а не полная установка. Не волнуйтесь, ваши данные не исчезнут! Режим восстановления использует программу установки только для определения имеющихся устройств, таких как диски и сетевые устройства, и они будут доступны во время восстановления системы.

Вместо программы разметки, вам покажут список разделов, имеющихся в системе, попросят выбрать один из них. Обычно, нужно выбрать раздел, содержащий корневую систему, которую нужно восстановить. Кроме созданных непосредственно на дисках, вы можете выбирать разделы на устройствах RAID и LVM.

Если возможно, программа установки запустит оболочку командной строки в выбранной файловой системе, где вы сможете провести любые дополнительные процедуры восстановления. Например, для переустановки системного загрузчика GRUB в главную загрузочную запись первого жёсткого диска, введите команду grub-install '(hd0)'.

Иногда программе установки не удаётся запустить оболочку командной строки в выбранной корневой файловой системе. Возможной причиной может быть повреждение файловой системы, и в этом случае выдаётся предупреждение и предлагается запустить оболочку командной строки в среде программы установки. Здесь не так много полезных программ, но и их часто достаточно для восстановления системы. Выбранная корневая файловая система будет смонтирована в каталог /target.

В обоих случаях, после выхода из оболочки командной строки система будет перезагружена.

И напоследок заметим, что восстановление нерабочей системы может оказаться очень трудным делом, и это руководство не пытается описать все возможные случаи, которые могут произойти и способы их решения. Если у вас есть проблемы — обратитесь к профессионалам.

Пред. | Уровень выше | След.
8.6. Сборка нового ядра | Начало | Приложение A. Краткая инструкция по установке


Приложение A. Краткая инструкция по установке
Пред. След.

Приложение A. Краткая инструкция по установке

Содержание

A.1. Предварительные сведения
A.2. Загрузка программы установки
A.2.1. Загрузка с CDROM
A.2.2. Загрузка с карты памяти USB
A.2.3. Загрузка по сети
A.2.4. Загрузка с жёсткого диска
A.3. Установка
A.4. Отправьте нам отчёт об установке
A.5. И напоследок…

Данный документ описывает установку Debian GNU/Linux squeeze на 32-bit PC («i386») с помощью нового debian-installer. Это краткое описание процесса установки, в нём содержится вся информация, необходимая для большинства установок. В тех местах, где полезно прочитать более обширное описание, будет приведена ссылка на соответствующую главу этого документа.

Пред. |  | След.
8.7. Восстановление неработающей системы | Начало | A.1. Предварительные сведения


A.1. Предварительные сведения
Пред. Приложение A. Краткая инструкция по установке След.

A.1. Предварительные сведения

Если вы обнаружите ошибки во время установки, обратитесь к Раздел 5.4.6, «Отправка отчётов об ошибках установки», чтобы прочитать как сообщить о них. Если у вас есть вопросы, на которые нет ответа в этом документе, смело задавайте их в списке рассылки debian-boot (debian-boot@lists.debian.org) или в IRC-канале (#debian-boot в сети OFTC).

Пред. | Уровень выше | След.
Приложение A. Краткая инструкция по установке | Начало | A.2. Загрузка программы установки


A.2. Загрузка программы установки
Пред. Приложение A. Краткая инструкция по установке След.

A.2. Загрузка программы установки

CD-образы с debian-installer, подготовленные командой debian-cd можно найти на странице Debian CD. Более подробно об этом написано в Раздел 4.1, «Официальный набор компакт-дисков Debian GNU/Linux».

Для некоторых методов установки требуются дополнительные образы помимо CD-образа. В Раздел 4.2.1, «Где искать установочные образы» описано, как их найти на серверах-зеркалах Debian.

В следующих подразделах указано, какие образы требуются для каждого конкретного вида установки.

A.2.1. Загрузка с CDROM

Существуют два различных CD-netinst-образа для установки squeeze с помощью debian-installer. Эти образы предназначены для загрузки с CD и установки дополнительных пакетов по сети, отсюда и название 'netinst'. Разница между ними в том, что полный netinst-образ включает базовые пакеты, а с business card их придётся загружать через сеть. При желании можно воспользоваться полным CD-образом, который не требует наличия сети для установки. Для этого достаточно первого диска из набора.

Загрузите любой понравившийся вам тип образа и запишите его на CD. Чтобы загрузиться с CD, вам может понадобиться изменить конфигурацию BIOS. Раздел 3.6.1, «Вызов меню настройки BIOS» описывает, как это сделать.

A.2.2. Загрузка с карты памяти USB

Также возможна установка со съёмных USB устройств хранения. Например, из USB-брелка можно сделать удобный носитель установки Debian, который можно взять с собой куда угодно.

The easiest way to prepare your USB memory stick is to download any Debian CD or DVD image that will fit on it, and write the CD image directly to the memory stick. Of course this will destroy anything already on the memory stick. This works because Debian CD images are "isohybrid" images that can boot both from CD and from USB drives.

Существуют другие, более гибкие пути подготовки карт памяти для использования с debian-installer, также возможно использовать карту памяти меньшего объёма. Подробней смотрите Раздел 4.3, «Подготовка файлов для загрузки с карты памяти USB».

Некоторые BIOS поддерживают загрузку непосредственно с USB, а некоторые нет. Вам может потребоваться настроить BIOS на загрузку с removable drive или даже с USB-ZIP, чтобы машина загрузилась с USB устройства. Полезные подсказки и подробное описание смотрите в Раздел 5.1.5, «Загрузка с карты памяти USB».

A.2.3. Загрузка по сети

debian-installer можно загрузить полностью из сети. Методы загрузки по сети (netboot) зависят от архитектуры и настройки сетевой загрузки. Файлы для загрузки debian-installer по сети лежат в каталоге netboot/.

The easiest thing to set up is probably PXE netbooting. Untar the file netboot/pxeboot.tar.gz into /srv/tftp or wherever is appropriate for your tftp server. Set up your DHCP server to pass filename /pxelinux.0 to clients, and with luck everything will just work. For detailed instructions, see Раздел 4.5, «Подготовка файлов для загрузки по TFTP».

A.2.4. Загрузка с жёсткого диска

Возможна загрузка программы установки не со сменного носителя, а просто с имеющегося жёсткого диска, который может содержать различные операционные системы. Скачайте файлы hd-media/initrd.gz, hd-media/vmlinuz и образ Debian CD в корневой каталог жёсткого диска. Проверьте, что образ CD имеет имя файла, оканчивающееся на .iso. Теперь просто выполняется загрузка linux с initrd. Раздел 5.1.4, «Загрузка из Linux с помощью LILO или GRUB» показывает один вариант, как это сделать.

Пред. | Уровень выше | След.
A.1. Предварительные сведения | Начало | A.3. Установка


A.3. Установка
Пред. Приложение A. Краткая инструкция по установке След.

A.3. Установка

После запуска программа установки выводит приветствие. Нажмите Enter для загрузки, или прочитайте инструкции про другие методы загрузки и параметры (смотрите Раздел 5.3, «Параметры загрузки»).

Через некоторое время вас попросят выбрать язык. Используйте клавиши управления курсором для выбора языка и нажмите Enter, чтобы продолжить. Затем вас попросят выбрать страну из списка стран, где говорят на этом языке. Если её нет в коротком списке, то доступен список стран всего мира.

Вас могут попросить выбрать раскладку клавиатуры. Выберите предлагаемую по умолчанию, если не знаете какая лучше.

Теперь можно отдохнуть, пока debian-installer определяет необходимое аппаратное обеспечение вашей машины, и загружает оставшуюся часть самого себя с CD, дискеты, USB и т.д.

Затем программа установки попытается определить сетевое аппаратное обеспечение и настроить сеть с помощью DHCP. Если у вас нет сети или вы не имеете DHCP, то вам будет предложено настроить сеть вручную.

Затем настраиваются часовой пояс и время. Программа установки попытается подключиться к серверу времени в Интернет, чтобы проверить точность времени компьютера. Часовой пояс выбирается на основе ранее указанной вами страны, и программа установки попросит вас указать его явно только, если страна расположена в нескольких часовых поясах.

Теперь пришло время разметки дисков. Сначала вам предложат автоматическую разметку всего диска или только свободного пространства (см. Раздел 6.3.3.2, «Направляющая разметка»). Этот режим рекомендуется для новичков или спешащих людей. Если вы не хотите авторазметку, выберите в меню пункт Вручную.

Если у вас есть разделы DOS или Windows, которые вы хотите сохранить, то будьте осторожны с автоматической разметкой. Если вы выберете разметку вручную, то сможете использовать программу установки для изменения размеров существующих разделов FAT или NTFS, чтобы создать место для установки Debian; просто выберите нужный раздел и укажите его новый размер.

На следующем экране вы увидите текущую таблицу разделов, формат разделов и куда они будут монтироваться. Выберите раздел для изменения или удаления. Если вы выбрали автоматическую разметку, то вам доступен только пункт меню Закончить разметку и записать изменения на диск, нажав на который вы подтвердите изменения. Не забудьте назначить по крайней мере один раздел для подкачки и смонтировать один раздел в качестве корневого раздела /. В Раздел 6.3.3, «Разметка разделов и выбор точек монтирования» подробно описано как использовать программу разметки; в Приложение C, Разметка дисков в Debian рассказано более подробно о процедуре разметки.

Далее debian-installer отформатирует разделы и начнёт установку базовой системы, что может занять некоторое время. Затем устанавливается ядро.

Основная часть системы, установленная ранее, уже работает, но умеет очень немного. Чтобы сделать систему более полезной, следующий этап позволяет установить дополнительные пакеты для определённых задач. Чтобы указать откуда получать пакеты, перед установкой пакетов нужно настроить apt. Задача «Стандартная система» выбрана по умолчанию и обычно нужна для установки. Выберите задачу «Окружение рабочего стола», если после установки хотите работать с графическим рабочим столом. Подробней об этом этапе смотрите в Раздел 6.3.5.2, «Выбор и установка программного обеспечения».

После установки базовой системы настраиваются учётные записи пользователей. По умолчанию, вам нужно задать пароль для учётной записи «root» (администратор) и данные, необходимые для создания одной обычной пользовательской учётной записи.

На последнем шаге устанавливается системный загрузчик. Если программа установки обнаружит другую операционную систему на компьютере, то добавит её в меню загрузки и скажет вам об этом. По умолчанию в главную загрузочную запись первого жёсткого диска устанавливается GRUB, что обычно и нужно. Вам будет предоставлена возможность изменения и установки его в другое место.

Далее debian-installer скажет, что установка завершена. Вытащите компакт-диск или другой носитель с программой установки и нажмите Enter для перезагрузки машины. После этого должна произойти загрузка в установленную систему и появиться приглашение к входу в систему. Это описано в Глава 7, Загрузка только что установленной системы Debian.

Если вам требуется дополнительная информация по процессу установки, посмотрите Глава 6, Использование программы установки Debian.

Пред. | Уровень выше | След.
A.2. Загрузка программы установки | Начало | A.4. Отправьте нам отчёт об установке


A.4. Отправьте нам отчёт об установке
Пред. Приложение A. Краткая инструкция по установке След.

A.4. Отправьте нам отчёт об установке

Если вы успешно справились с установкой с помощью debian-installer, пожалуйста, найдите время и отправьте нам отчёт. Самый простой путь отправки отчёта — установить пакет reportbug (aptitude install reportbug), настроить reportbug по описанию из Раздел 8.5.2, «Отправка почты из системы» и запустить команду reportbug installation-reports.

Если завершить установку не получилось, то вероятно вы обнаружили ошибку в debian-installer. Для улучшения программы установки необходимо, чтобы мы узнали об этом, поэтому, пожалуйста, сообщите об ошибке. Вы можете использовать отчёт об установке, чтобы сообщить о проблеме; если установить вообще ничего не удалось, смотрите Раздел 5.4.5, «Сообщение о проблемах при установке».

Пред. | Уровень выше | След.
A.3. Установка | Начало | A.5. И напоследок…


A.5. И напоследок…
Пред. Приложение A. Краткая инструкция по установке След.

A.5. И напоследок…

Мы надеемся, что установка Debian была несложной и что вы найдёте Debian полезным. Вероятно, вам пригодится информация из Глава 8, Следующие шаги и что делать дальше.

Пред. | Уровень выше | След.
A.4. Отправьте нам отчёт об установке | Начало | Приложение B. Автоматическая установка с помощью списка ответов


Приложение B. Автоматическая установка с помощью списка ответов
Пред. След.

Приложение B. Автоматическая установка с помощью списка ответов

Содержание

B.1. Введение
B.1.1. Методы использования файла ответов
B.1.2. Ограничения
B.2. Использование автоматической установки
B.2.1. Загрузка файла ответов
B.2.2. Использование параметров загрузки для автоматизации
B.2.3. Автоматический режим
B.2.4. Полезные в автоматизации псевдонимы
B.2.5. Использование сервера DHCP для указания файлов автоматической конфигурации
B.3. Создание файла ответов
B.4. Содержимое файла ответов (для squeeze)
B.4.1. Локализация
B.4.2. Настройка сети
B.4.3. Сетевая консоль
B.4.4. Настройка сервера-зеркала
B.4.5. Настройка учётной записи
B.4.6. Настройка времени и часового пояса
B.4.7. Разметка дисков
B.4.8. Установка базовой системы
B.4.9. Настройка Apt
B.4.10. Выбор пакетов
B.4.11. Установка загрузчика
B.4.12. Завершение установки
B.4.13. Автоматизация других пакетов
B.5. Дополнительные параметры
B.5.1. Запуск пользовательских команд во время установки
B.5.2. Использование автоматической установки для изменения значений по умолчанию
B.5.3. Последовательная загрузка нескольких файлов ответов

В этом приложении описывается файл ответов на вопросы, который используется debian-installer для автоматизации установки операционной системы.

Фрагменты конфигурации, используемые в этом приложении, также доступны в примере файла ответов http://www.debian.org/releases/squeeze/example-preseed.txt.

Пред. |  | След.
A.5. И напоследок… | Начало | B.1. Введение


B.1. Введение
Пред. Приложение B. Автоматическая установка с помощью списка ответов След.

B.1. Введение

Автоматическая установка позволяет автоматизировать ручной ввод ответов на вопросы программы установки. Это даёт возможность автоматизации наиболее типичных установок, а также предоставляет дополнительные возможности, недоступные во время обычной установки.

Автоматическая установка не является обязательной. Если вы укажите пустой файл ответов, то программа установки станет работать также, как при установке вручную. Каждый автоматический ответ на вопрос меняет (если поняли его правильно!) ход установки.

B.1.1. Методы использования файла ответов

Есть три метода использования для автоматизации: initrd, файловый и сетевой. Метод initrd работает при любом способе установки системы и поддерживает ответы на большинство вопросов, но он наиболее трудоёмок. Файловый и сетевой методы могут использоваться при различных способах установки.

В следующей таблице показано соответствие методов автоматической установки со способами установки операционной системы.

способ установки системы | initrd | файловый | сетевой
CD/DVD | да | да | да[a]
netboot | да | нет | да
hd-media (включая usb-носители) | да | да | да[a]
[a] только если есть подключение к сети и указан соответствующий preseed/url

Основным различием в методах автоматической установки является момент загрузки и обработки файла ответов. Для метода initrd он наступает сразу в начале установки, перед тем как будет задан первый вопрос. Для файлового метода он наступает после загрузки с CD или CD образа. Для сетевого метода он наступает только после настройки сети.

Очевидно, что на любые вопросы, задаваемые перед загрузкой файла ответов, нельзя указать готовые ответы (сюда включаются вопросы, которые задаются только на среднем и низком уровне важности, например запуск определения аппаратуры. Раздел B.2.2, «Использование параметров загрузки для автоматизации» описывает как избежать отображения таких вопросов.

Чтобы избежать вопросов, которые обычно задаются перед тем как начнёт действовать автоматизация ответов, вы можете запустить программу установки в режиме «auto». Это позволит отложить вопросы, которые обычно задаются перед автоматической установкой (например, про язык, страну и выбор клавиатурной раскладки), до появления работоспособной сети. Также этот режим используется когда установка выполняется с критическим уровнем важности, что позволяет избежать многих неважных вопросов. Подробней смотрите в Раздел B.2.3, «Автоматический режим».

B.1.2. Ограничения

Хотя для большинства вопросов debian-installer могут быть заданы предварительные ответы, есть несколько заметных исключений. Вы можете (пере)разметить только весь диск или использовать только доступное место на диске; невозможно задействовать существующие разделы.

Пред. | Уровень выше | След.
Приложение B. Автоматическая установка с помощью списка ответов | Начало | B.2. Использование автоматической установки


B.2. Использование автоматической установки
Пред. Приложение B. Автоматическая установка с помощью списка ответов След.

B.2. Использование автоматической установки

Во-первых, нужно создать файл ответов и сделать его доступным для использования. Создание файла ответов описывается позже в этом приложении. Разместить его в нужном месте довольно просто для сетевой автоматической установки и при чтении файла с дискеты или usb-носителя. Если нужно включить этот файл на CD или DVD, то придётся обновлять ISO образ. Здесь не будет описано как поместить файл ответов в initrd; обратитесь к документации разработчика debian-installer.

Пример файла ответов, который можно взять за основу доступен здесь http://www.debian.org/releases/squeeze/example-preseed.txt. Данный файл основан на фрагментах конфигурации, включённых в это приложение.

B.2.1. Загрузка файла ответов

Если используется метод initrd, то нужно убедиться, что файл с именем preseed.cfg лежит в корневом каталоге initrd. Программа установки автоматически проверяет наличие этого файла и загружает его.

Для других методов автоматической установки нужно указать при загрузке программе установки какой файл использовать при загрузке. Это можно сделать через параметр загрузки ядра, вручную во время загрузки или изменив файл настройки системного загрузчика (например, syslinux.cfg) и добавить параметр в конец строки append для ядра.

Если вы указываете файл ответов в настройке системного загрузчика, то можно изменить конфигурацию таким образом, чтобы не нажимать клавишу ввод для загрузки программы установки. Для syslinux это достигается установкой timeout равным 1 в файле syslinux.cfg.

Чтобы убедиться, что программа установки получила правильный файл ответов, можно дополнительно указать контрольную сумму файла. Это значение вычисляется с помощью md5sum, и если его указать, то оно должно соответствовать указываемому файлу, иначе программа установки не будет использовать данный файл.

Задаваемые параметры при загрузке:
- при загрузке из сети:
  preseed/url=http://host/path/to/preseed.cfg
  preseed/url/checksum=5da499872becccfeda2c4872f9171c3d

- при загрузке с изменённого CD:
  preseed/file=/cdrom/preseed.cfg
  preseed/file/checksum=5da499872becccfeda2c4872f9171c3d

- при установке с USB носителя (поместите файл ответов в
  корневой каталог USB носителя):
  preseed/file=/hd-media/preseed.cfg
  preseed/file/checksum=5da499872becccfeda2c4872f9171c3d

Заметим, что preseed/url можно укоротить до url, а preseed/file до file, если они передаются в параметрах загрузки.

B.2.2. Использование параметров загрузки для автоматизации

Если файл ответов не может быть использован для автоматизации некоторых шагов, установку всё ещё можно сделать полностью автоматической, передав нужные значения ответов в командной строке запуска программы установки.

Параметры загрузки также можно использовать не только для автоматизации установки, а просто для того, чтобы указать ответ на определённый вопрос. Несколько примеров такого использования есть в разных местах этого руководства.

Чтобы установить значение, используемое внутри debian-installer, просто укажите путь/до/переменная=значение для любой автоматизируемой переменной, описанной в примерах в этом приложении. Если значение будет использоваться для настройки пакетов в устанавливаемой системе, то нужно перед переменной указывать владелец[28], например, владелец:путь/до/переменной=значение. Если вы не указываете владельца, то значение переменной не копируется в базу данных debconf устанавливаемой системы и поэтому не будет использоваться во время настройки соответствующего пакета.

Обычно, автоматизация ответов приводит к тому, что вопрос задан не будет. Чтобы установить для вопроса ответ по умолчанию и оставить вопрос задаваемым, используйте в качестве оператора «?=» вместо «=». Смотрите также Раздел B.5.2, «Использование автоматической установки для изменения значений по умолчанию».

Заметим, что для некоторых переменных, которые часто задаются в приглашении загрузчика, имеются короткие названия. Если имеется короткое название, то оно используется в примерах в этом приложении вместо полного имени переменной. Например, переменная preseed/url сокращается до url. Ещё пример: псевдоним tasks раскрывается в tasksel:tasksel/first.

Обозначение «--» в параметрах загрузки имеет специальное значение. Параметры ядра, указанные после «--», могут быть скопированы в конфигурацию установленного системного загрузчика (если это умеет программа установки для загрузчика). Программа установки автоматически фильтрует все параметры (например, параметры предварительной настройки), которые распознаёт.

Замечание

В настоящее время ядра linux версии (2.6.9 и новее) максимально могут принять 32 параметра в командной строке и 32 параметра через переменные окружения, считая все параметры, добавляемые программой установки по умолчанию. Если это число превышено, то ядро прекращает работу с ошибкой. (Для ранних версий ядер эти значения меньше.)

В большинстве установок некоторые параметры по умолчанию в файле конфигурации загрузчика, типа vga=normal, можно безопасно удалить, что может позволить вам добавить больше параметров автоматизации.

Замечание

Не всегда возможно задать значения с пробелами в параметрах загрузки, даже если заключить их в кавычки.

B.2.3. Автоматический режим

Есть несколько возможностей программы установки Debian, объединив которые с помощью простых команд в приглашении к загрузке, можно получить автоматическую установку любого уровня настраиваемости. Вот один из примеров использования настроек в приглашении к загрузке:

auto url=autoserver

В этом случае для установки согласно полученным настройкам с DHCP сервера будет найдена машина autoserver из записей DNS, возможно к имени будет добавлено имя локального домена, если он передаётся в DHCP. Если в сети используется доменное имя example.com, и этот домен передаётся по DHCP, то в результате файл с ответами будет получен с http://autoserver.example.com/d-i/squeeze/./preseed.cfg.

Последняя часть этого url (d-i/squeeze/./preseed.cfg) берётся из auto-install/defaultroot. По умолчанию в него включён каталог squeeze, чтобы для будущих версий можно было задать своё название, что позволит людям контролировать процесс перехода на новую версию. Часть /./ используется для указания корня, относительно которого будут заданы остальные пути (для использования в preseed/include и preseed/run). Это позволяет указывать файлы с полным URL (пути, начинающиеся с /) или даже пути относительно места, где был найден последний файл ответов. Это может быть использовано для написание более переносимых сценариев, для того чтобы полное дерево сценариев можно было переместить в новое место ничего при этом не сломав, например скопировать файлы на USB-носитель, если ранее они брались с веб-сервера. Продолжая пример, если в файле ответов значение preseed/run заменить на /scripts/late_command.sh, то файл будет получен с http://autoserver.example.com/d-i/squeeze/./scripts/late_command.sh.

Если в сети нет локальных серверов DHCP или DNS, или, если вы не хотите использовать пути по умолчанию к preseed.cfg, то вы всё ещё можете явно задать url, и, если вы не используете элемент /./, то это будет началом пути (третий / в URL). Вот пример, для которого нужна минимальная поддержка служб в локальной сети:

auto url=http://192.168.1.2/path/to/mypreseed.file

Это работает так:

  • если в URL не указан протокол, то используется http,

  • если в имени машины нет точек, то будет добавлен домен, полученный по DHCP, и

  • если нет / после имени машины, то добавляется путь по умолчанию.

Также, помимо указания url, вы можете задать настройки, которые не влияют напрямую на поведение самого debian-installer, но будут переданы во все сценарии, заданные заданы с помощью preseed/run в загруженном файле ответов. В настоящий момент, как пример использования, есть только auto-install/classes с псевдонимом classes. Это можно использовать так:

auto url=example.com classes=class_A;class_B

classes, например, может означать тип устанавливаемой системы или используемую локализацию.

Естественно, можно расширить эту концепцию, и если вы это делаете,имеет смысл задействовать пространство имён auto-install. Это может выглядеть как auto-install/style, что затем будет использовано в ваших сценариях. Если вы думаете, что вам это нужно, напишите в список рассылки <debian-boot@lists.debian.org>, для того чтобы мы смогли избежать конфликта имён, и возможно, добавили псевдонимы для ваших параметров.

Загрузочная метка auto пока определена не везде. Такой же эффект можно получить просто добавив два параметра auto=true priority=critical в командной строке параметров ядра. Параметр auto — это псевдоним для auto-install/enable и установка его в trueзадерживает выдачу вопросов о локали и клавиатуре, чтобы была возможность настроить их автоматически, а priority является псевдонимом для debconf/priority, и установка в значение critical заставляет программу установки не задавать вопросы с меньшим уровнем важности.

Для автоматизации с использованием DHCP могут пригодиться следующие дополнительные параметры: interface=auto netcfg/dhcp_timeout=60, будет выбрана первая рабочая сетевая карта, ответ на DHCP запрос будет ожидаться больше чем обычно.

Подсказка

Большой пример использования данной интегрированной среды, включающий примеры сценариев и классов, можно найти на сайте разработчика. На примерах с сайта также показано много других замечательных эффектов, которых можно достичь, если творчески подойти к процессу автоматизации.

B.2.4. Полезные в автоматизации псевдонимы

При использование автоматизации установки (режим auto) могут пригодиться следующие псевдонимы. Заметим, что сокращаются только имена вопросов, и вам всегда нужно указывать ещё и значение. Например, auto=true или interface=eth0.

auto | auto-install/enable
classes | auto-install/classes
fb | debian-installer/framebuffer
language | debian-installer/language
country | debian-installer/country
locale | debian-installer/locale
priority | debconf/priority
файловый | preseed/file
url | preseed/url
interface | netcfg/choose_interface
hostname | netcfg/get_hostname
domain | netcfg/get_domain
protocol | mirror/protocol
suite | mirror/suite

B.2.5. Использование сервера DHCP для указания файлов автоматической конфигурации

Также возможно использовать DHCP для указания файла автоматической конфигурации, загружаемого по сети. DHCP позволяет указать имя файла. Обычно, он указывается для способа установки по сети, но если он задан в виде URL, то установочный носитель, который поддерживает автоматическую установку по сети, загрузит файл с указанного в URL адреса и использует его как файл автоматической установки. Вот пример, как можно настроить dhcpd.conf для третьей версии сервера ISC DHCP (Debian пакет dhcp3-server).

if substring (option vendor-class-identifier, 0, 3) = "d-i" {
    filename "http://host/preseed.cfg";
}

Заметим, что пример выше ограничивает использование имени файла только DHCP клиентами с идентификатором "d-i", поэтому он не влияет на простых DHCP клиентов, а только на программу установки. Вы также можете поместить текст в строфу указав определённую машину, чтобы избежать автоматизации всех установок в сети.

При автоматизации с помощью DHCP лучше указывать только значения специфичные для вашей сети, например, желаемые сервера-зеркала Debian. В этом случае при установке по сети машины получат правильные сервера-зеркала, а оставшаяся установка будет выполнена в интерактивном режиме. Использование DHCP для полной автоматической установки Debian тоже возможна, но с большой осторожностью.

[28] Владелец переменной debconf (или шаблона) — это, обычно, имя пакета, в котором содержится соответствующий шаблон debconf. Переменными самой программы установки владеет «d-i». Шаблоны и переменные могут иметь более одного владельца, что влияет на их удаление из базы данных debconf при вычистке пакета.

Пред. | Уровень выше | След.
B.1. Введение | Начало | B.3. Создание файла ответов


B.3. Создание файла ответов
Пред. Приложение B. Автоматическая установка с помощью списка ответов След.

B.3. Создание файла ответов

Файл ответов аналогичен формату файла используемому программой debconf-set-selections. Общая форма строки файла ответов:

<владелец> <имя вопроса> <тип вопроса> <значение>

При написании файла ответов есть несколько правил, которые нужно помнить.

  • Между типом и значением вставляйте только один пробел или отступ(tab): любой дополнительный пробельный символ будет включён в значение.

  • Строка может быть разбита на несколько строк, с помощью добавления обратного слеша («\») в конец строки. Хорошо разделять строку после имени вопроса; плохо — между типом и значением. При обратном объединении нескольких строк все начальные/конечные пробельные символы будут сжаты в один.

  • Владельцем переменных debconf (шаблонов), используемых в самой программе установки, нужно назначать «d-i»; для переменных автоматизации установки, используемых в установленной системе, должно использоваться имя пакета, содержащее соответствующий шаблон debconf. В базу данных debconf в установленной системе попадут только переменные, у которых владельцем установлено нечто, отличное от «d-i».

  • Для большинства вопросов нужно указывать ответы на английском языке, а не их перевод. Однако, есть несколько вопросов (например, в partman), где нужно использовать ответы на родном языке.

  • В ответах некоторых вопросов вместо английского текста указывается код, который показывается во время установки.

Самый простой путь создания файла ответов это использовать файл примера Раздел B.4, «Содержимое файла ответов (для squeeze)» в качестве основы и изменить его.

Альтернативный метод — выполнить установку вручную и затем, после перезагрузки, использовать команду debconf-get-selections из пакета debconf-utils, чтобы сохранить базу данных debconf и базу данных программы установки cdebconf в один файл:

$ debconf-get-selections --installer > файл
$ debconf-get-selections >> файл

Однако, таким образом созданный файл будет содержать некоторые элементы,которые не должны быть автоматизированы, и всё-таки для большинства пользователей лучше использовать файл примера.

Замечание

Этот метод основан на том, что в конце установки, база данных программы установки cdebconf сохраняется в установленной системе в /var/log/installer/cdebconf. Однако, так как база данных может содержать частную информацию, по умолчанию файл разрешено читать только суперпользователю.

Каталог /var/log/installer и все файлы в нём будут удалены из системы при вычистке пакета installation-report.

Для выяснения возможных ответов на вопросы можно использовать редактор nano для просмотра файла /var/lib/cdebconf прямо во время процесса установки. В файле templates.dat хранятся необработанные шаблоны, а в questions.dat — текущие значения и значения, назначенные переменным.

Для проверки правильности формата файла ответов до установки, можно использовать команду debconf-set-selections -c preseed.cfg.

Пред. | Уровень выше | След.
B.2. Использование автоматической установки | Начало | B.4. Содержимое файла ответов (для squeeze)


B.4. Содержимое файла ответов (для squeeze)
Пред. Приложение B. Автоматическая установка с помощью списка ответов След.

B.4. Содержимое файла ответов (для squeeze)

Фрагменты конфигурации, используемые в этом приложении, также доступны в примере файла ответов http://www.debian.org/releases/squeeze/example-preseed.txt.

Заметим, что показанный пример основан на установке для архитектуры Intel x86. Если вы выполняете установку на другую архитектуру, то некоторые примеры (например, выбор клавиатуры и установка загрузчика) могут различаться и должны быть заменены на соответствующие настройки debconf для этой архитектуры.

Details on how the different Debian Installer components actually work can be found in Раздел 6.3, «Применение отдельных компонент».

B.4.1. Локализация

Настройка значений локализации работает только для метода initrd. Во всех остальных методах файл ответов загружается после того, как эти вопросы уже заданы.

Для указания языка и страны можно использовать локаль; возможна любая комбинация для языка, если она поддерживается debian-installer, и страны. Если в локали указана недопустимая комбинация, то программа установки автоматически выберет локаль, подходящую для выбранного языка. Чтобы указать локаль в параметре загрузки, используйте locale=ru_RU.

Хотя этот метод очень прост в использовании, с его помощью нельзя задать любые комбинации языка, страны и локали[29]. Поэтому есть возможность задать автоматический ответ для каждого параметра отдельно. Язык и страну также можно указывать в параметрах запуска.

# Автоответ для языка и страны на основе локали.
d-i debian-installer/locale string en_US

# Значения можно указывать отдельно для каждого параметра.
#d-i debian-installer/language string en
#d-i debian-installer/country string NL
#d-i debian-installer/locale string en_GB.UTF-8
# В добавок, можно указать дополнительные локали для генерации.
#d-i localechooser/supported-locales en_US.UTF-8, nl_NL.UTF-8

При настройке клавиатуры выбирается архитектура клавиатуры и раскладка. В большинстве случаев правильная архитектура клавиатуры уже выбрана по умолчанию, поэтому обычно не нужно задавать автоматический ответ. Раскладка клавиатуры должна быть известна debian-installer для выбранной архитектуры клавиатуры.

# Выбор клавиатуры.
#d-i console-tools/archs select at
d-i console-keymaps-at/keymap select ru
d-i keyboard-configuration/xkb-keymap select ru
# Пример другой архитектуры клавиатуры
#d-i console-keymaps-usb/keymap select mac-usb-us

Чтобы не выполнять настройку клавиатуры укажите в console-tools/archs значение skip-config. В результате останется активной клавиатурная раскладка ядра.

Замечание

Изменения в уровне ввода в ядрах версии 2.6 сделали архитектуру клавиатуры виртуально ненужной. Для ядер версии 2.6 обычно нужно выбирать клавиатурную раскладку «PC» (at).

B.4.2. Настройка сети

Естественно, автоматическая настройка сети не работает, если вы загружаете файл ответов из сети. Но она отлично работает, если загрузка происходит с CD или USB накопителя. Если вы загружаете файл ответов из сети, то можете указать конфигурацию сети через загрузочные параметры ядра.

Если нужно использовать определённый интерфейс для загрузки по сети перед загрузкой файла ответов из сети, используйте параметр загрузки interface=eth1.

Хотя автоматическая настройка сети обычно невозможна при загрузки файла ответов по сети (с помощью «preseed/url»), вы можете обойти этот недостаток, например, если задав статический адрес на сетевом интерфейса. Данное обходное решение заставит запуститься настройку сети ещё раз после загрузки файла ответов, если создать сценарий «preseed/run» со следующими строчками:

killall.sh; netcfg

Следующие переменные debconf относятся к настройке сети.

# Выключить настройку сети полностью. Это полезно при установке с cdrom
# на устройства, не имеющих сети, где вопросы о сети,
# предупреждения и ожидания только раздражают.
#d-i netcfg/enable boolean false

# netcfg выберет активный сетевой интерфейс, если такой имеется. Если
# есть более одного интерфейса, то при данной настройке список
# интерфейсов выводится не будет.
d-i netcfg/choose_interface select auto

# Чтобы использовать нужный интерфейс:
#d-i netcfg/choose_interface select eth1

# Если у вас медленный dhcp сервер и программа установки не дожидается
# ответа, то данная настройка может оказаться полезной.
#d-i netcfg/dhcp_timeout string 60

# Если вы предпочитаете настраивать сеть вручную, раскомментируйте эту
# строку и статическую настройку сети ниже.
#d-i netcfg/disable_dhcp boolean true

# Если вы хотите чтобы файл ответов работал при наличии и без сервера
# dhcp, раскомментируйте эти строки и статическую настройку сети ниже.
#d-i netcfg/dhcp_failed note
#d-i netcfg/dhcp_options select Configure network manually

# Статическая настройка сети.
#d-i netcfg/get_nameservers string 192.168.1.1
#d-i netcfg/get_ipaddress string 192.168.1.42
#d-i netcfg/get_netmask string 255.255.255.0
#d-i netcfg/get_gateway string 192.168.1.1
#d-i netcfg/confirm_static boolean true

# Имя узла и домен, назначенные с помощью dhcp, имеют приоритет над
# значениями, установленными здесь. Однако, установка значений всё ещё
# предотвращает показ вопросов, даже если значения получены от dhcp.
d-i netcfg/get_hostname string unassigned-hostname
d-i netcfg/get_domain string unassigned-domain

# Выключить показ надоедливого диалога с WEP ключом.
d-i netcfg/wireless_wep string
# Странное имя dhcp сервера, которое используют некоторые провайдеры в
# качестве некоего пароля.
#d-i netcfg/dhcp_hostname string radish

# Если для работы сети или другого оборудования требуется несвободная
# микропрограмма, то вы можете указать программе установки всегда пытаться
# её загружать не задавая вопросов. Или замените значение на false, чтобы
# этот вопрос вообще не задавался.
#d-i hw-detect/load_firmware boolean true

Заметим, что netcfg автоматически выберет маску сети,если она не указана в netcfg/get_netmask. В этом случае, переменная будет помечена как seen при автоматической установке. Аналогично netcfg выберет подходящий адрес шлюза, если не указано значение в netcfg/get_gateway. Но есть специальная настройка: netcfg/get_gateway можно установить в «none», чтобы указать, что шлюз вообще не должен использоваться.

B.4.3. Сетевая консоль

# Используйте следующие настройки, если хотите использовать компоненту
# network-consoleдля удалённой установки через SSH. Это имеет смысл, если вы
# намереваетесь выполнять оставшуюся часть установки вручную.
#d-i anna/choose_modules string network-console
#d-i network-console/password password r00tme
#d-i network-console/password-again password r00tme

B.4.4. Настройка сервера-зеркала

В зависимости от используемого метода установки для загрузки дополнительных компонент программы установки, установки базовой системы и настройки файла /etc/apt/sources.list в установленной системе можно использовать сервер-зеркало.

Параметр mirror/suite определяет версию дистрибутива для устанавливаемой системы.

Параметр mirror/udeb/suite определяет версию дистрибутива для дополнительных компонент программы установки. Он нужен только если компоненты загружаются по сети и должны соответствовать версии, которая была использована для сборки initrd, который используется для установки с помощью одноимённого метода. Обычно программа установки автоматически определяет правильное значение, и этот параметр задавать ненужно.

# Если вы выберете ftp, то mirror/country string устанавливать не нужно.
#d-i mirror/protocol string ftp
d-i mirror/country string manual
d-i mirror/http/hostname string http.us.debian.org
d-i mirror/http/directory string /debian
d-i mirror/http/proxy string

# Устанавливаемая версия.
#d-i mirror/suite string testing
# Версия загружаемых компонент (необязательно).
#d-i mirror/udeb/suite string testing

B.4.5. Настройка учётной записи

Могут быть автоматически настроены пароль суперпользователя и имя и пароль первого обычного пользователя. Пароли могут быть заданы или в нешифрованном виде или в виде хешей MD5.

Внимание

Обратите внимание, что автоматическую настройку паролей использовать небезопасно, так как любой может получить доступ к файлу ответов и узнать пароли. Считается, что использование хешей MD5 улучшает ситуацию с точки зрения безопасности, но MD5 хеш всё ещё остаётся доступным для атак на пароль прямым перебором.

# Пропустить создание учётной записи суперпользователя (в обычной учётной
# записи пользователя можно использовать sudo).
#d-i passwd/root-login boolean false
# Или же пропустить создание обычной учётной записи пользователя.
#d-i passwd/make-user boolean false

# Пароль суперпользователя, любой открытым текстом
#d-i passwd/root-password password r00tme
#d-i passwd/root-password-again password r00tme
# или в виде MD5 хеша.
#d-i passwd/root-password-crypted password [MD5 хеш]

# Создать учётную запись обычного пользователя.
#d-i passwd/user-fullname string Debian User
#d-i passwd/username string debian
# Пароль обычного пользователя, или открытым текстом
#d-i passwd/user-password password insecure
#d-i passwd/user-password-again password insecure
# или в виде MD5 хеша.
#d-i passwd/user-password-crypted password [MD5 хеш]
# Создать первую учётную запись с заданным UID вместо значения по
# умолчанию.
#d-i passwd/user-uid string 1010

# Учётная запись будет добавлена в несколько стандартных начальных групп.
# Чтобы это изменить -- отредактируйте и раскомментируйте строчку ниже.
#d-i passwd/user-default-groups string audio cdrom video

Также, в начале значений переменных passwd/root-password-crypted и passwd/user-password-crypted можно указать знак «!». В этом случае, соответствующая учётная запись будет заблокирована. Это может быть удобно для учётной записи суперпользователя, если используется другой метод настройки, предоставляющий возможность выполнить административные действия или вход в систему от имени суперпользователя (например, используя аутентификацию по SSH ключу или sudo).

С помощью следующей команды можно сгенерировать MD5 хеш для пароля:

$ printf "r00tme" | mkpasswd -s -m md5

B.4.6. Настройка времени и часового пояса

# Задаёт, установлены или нет аппаратные часы по Гринвичу.
d-i clock-setup/utc boolean true

# Здесь вы можете указать любое допустимое значение для $TZ; смотрите
# допустимые значения в файле /usr/share/zoneinfo/.
d-i time/zone string US/Eastern

# Определяет, нужно ли использовать NTP для установки часов во время установки
d-i clock-setup/ntp boolean true
# Используемый сервер NTP. Значение по умолчанию указывается здесь.
#d-i clock-setup/ntp-server string ntp.example.com

B.4.7. Разметка дисков

Использование настроек разметки жёсткого диска в автоматической установке очень ограничено; поддерживаются параметры только для partman-auto. Вы можете выбрать разметку только свободного места на диске или всего диска. Разметку диска можно выбрать из одного из имеющихся в программе установки наборов, пользовательского набора из файла или набора из файла ответов.

Расширенные возможности разметки с использованием RAID, LVM и шифрования поддерживаются в автоматической установке, но не так гибки как при разметке без автоматической установки.

Представленные далее примеры показывают только основы по использованию наборов. Подробности смотрите в файлах partman-auto-recipe.txt и partman-auto-raid-recipe.txt и пакета debian-installer. Также эти файлы доступны в репозитории debian-installer. Заметим, что список поддерживаемых возможностей может поменяться между выпусками.

Внимание

Идентификация дисков зависит от порядка загрузки драйверов. Если в системе есть несколько дисков, проверьте, что выбирается правильный диск перед тем как использовать автоматическую установку.

B.4.7.1. Пример разметки

# Если система имеет свободное место, вы можете выбрать для разметки
# только его.
# Это соблюдается, только есть не задан partman-auto/method (ниже).
#d-i partman-auto/init_automatically_partition select biggest_free

# Или же, вы можете задать размечаемый диск. Если в системе
# имеется только один диск, то программа установки будет
# использовать его по умолчанию, иначе имя устройства
# должно задаваться в обычном не-devfs формате (то есть,
# /dev/hda или /dev/sda, а не /dev/discs/disc0/disc).
# Например, для использования первого жёсткого диска SCSI/SATA:
#d-i partman-auto/disk string /dev/sda
# Также, вы можете указать какой метод использовать.
# Доступные методы:
# - regular: использовать обычные для архитектуры типы разделов
# - lvm: при разметке диска использовать LVM
# - crypto: использовать LVM с шифрованием
d-i partman-auto/method string lvm

# Если один из дисков, который нужно разметить с помощью автоматической
# разметки, содержит старую конфигурацию LVM, то пользователю выдаётся
# предупреждение. Ответ можно автоматизировать...
d-i partman-lvm/device_remove_lvm boolean true
# То же самое для существующих программных RAID массивов:
d-i partman-md/device_remove_md boolean true
# И подтвердить запись lvm разделов.
d-i partman-lvm/confirm boolean true

# Вы можете выбрать один из трёх имеющихся наборов разметки:
# - atomic: все файлы в одном разделе
# - home:   отдельный раздел для /home
# - multi:  отдельные разделы для /home, /usr, /var и /tmp
d-i partman-auto/choose_recipe select atomic

# Или создать набор вручную...
# Если вы каким-то образом поместили файл набора в окружение d-i, то можно
# просто указать его.
#d-i partman-auto/expert_recipe_file string /hd-media/recipe

# Если нет, то можно записать набор полностью в файле ответов в одну
# (логическую) строку. В примере ниже создаётся маленький /boot
# раздел, подходящего размера раздел подкачки,
# а оставшееся место используется под корневой раздел:
#d-i partman-auto/expert_recipe string                         \
#      boot-root ::                                            \
#              40 50 100 ext3                                  \
#                      $primary{ } $bootable{ }                \
#                      method{ format } format{ }              \
#                      use_filesystem{ } filesystem{ ext3 }    \
#                      mountpoint{ /boot }                     \
#              .                                               \
#              500 10000 1000000000 ext3                       \
#                      method{ format } format{ }              \
#                      use_filesystem{ } filesystem{ ext3 }    \
#                      mountpoint{ / }                         \
#              .                                               \
#              64 512 300% linux-swap                          \
#                      method{ swap } format{ }                \
#              .

# Полностью формат набора описан в файле partman-auto-recipe.txt,
# включённом в пакет debian-installer и репозиторий D-I.
# Там же описано как задать другие настройки, такие как метки
# файловой системы, имена групп томов и какие физические
# устройства включить в группу томов.

# Это заставляет partman автоматически выполнить разметку
# без подтверждения, ровно такую, которую вы указали в методах выше.
d-i partman-partitioning/confirm_write_new_label boolean true
d-i partman/choose_partition select finish
d-i partman/confirm boolean true
d-i partman/confirm_nooverwrite boolean true

B.4.7.2. Разметка с использованием RAID

Также вы можете автоматизировать настройку массивов программного RAID. Поддерживаются RAID уровни 0, 1, 5, 6 и 10, создание неполных массивов (degraded arrays) и можно указать запасные устройства.

Если вы используете RAID 1, то можете автоматизировать установку grub на все устройства массива, см. Раздел B.4.11, «Установка загрузчика».

Внимание

В данном типе автоматизации разметки легко ошибиться. Также эта возможность тестировалась относительно мало разработчиками debian-installer. Ответственность при создании правильного набора (то есть, чтобы он был логически верным и не имел конфликтов) лежит на пользователе. Если возникают проблемы -- см. /var/log/syslog.

# Метод должен быть установлен в значение "raid".
#d-i partman-auto/method string raid
# Задать размечаемые диски. Они будут иметь одинаковую разметку,
# поэтому это работает только, если диски одинакового размера.
#d-i partman-auto/disk string /dev/sda /dev/sdb

# Далее нужно указать какие физические разделы будут использоваться.
#d-i partman-auto/expert_recipe string \
#      multiraid ::                                         \
#              1000 5000 4000 raid                          \
#                      $primary{ } method{ raid }           \
#              .                                            \
#              64 512 300% raid                             \
#                      method{ raid }                       \
#              .                                            \
#              500 10000 1000000000 raid                    \
#                      method{ raid }                       \
#              .

# Наконец, нужно указать как использовать определённые ранее разделы
# в настройке RAID. Указывайте правильные номера разделов
# для логических разделов. Поддерживается RAID 0, 1, 5, 6 и 10;
# устройства разделяются с помощью "#".
# Параметры:
# <raidtype> <devcount> <sparecount> <fstype> <mountpoint> \
#          <devices> <sparedevices>

#d-i partman-auto-raid/recipe string \
#    1 2 0 ext3 /                    \
#          /dev/sda1#/dev/sdb1       \
#    .                               \
#    1 2 0 swap -                    \
#          /dev/sda5#/dev/sdb5       \
#    .                               \
#    0 2 0 ext3 /home                \
#          /dev/sda6#/dev/sdb6       \
#    .

# Полностью формат набора описан в файле partman-auto-raid-recipe.txt,
# включённом в пакет debian-installer и репозиторий D-I.

# Это заставит partman сделать разметку автоматически, без подтверждения.
d-i partman-md/confirm boolean true
d-i partman-partitioning/confirm_write_new_label boolean true
d-i partman/choose_partition select finish
d-i partman/confirm boolean true
d-i partman/confirm_nooverwrite boolean true

B.4.7.3. Управление монтированием разделов

Обычно, файловые системы монтируются с использованием в качестве ключа универсального уникального идентификатора (UUID); это позволяет монтировать их правильно, даже если изменились их имена устройств. UUID-ы длинные и их сложно запоминать, поэтому, по вашему желанию, программа установки может смонтировать файловые системы основываясь на традиционных именах устройств, или на основе назначенных вами меток. Если вы укажите программе установки монтировать по меткам, то все файловые системы без метки будут смонтированы на основе UUID.

Для устройств со стабильными именами, такими как логические тома LVM, при монтировании будет продолжено использование их традиционных имён, а не UUID-ы.

Внимание

Традиционные имена устройств могут изменяться из-за порядка, в котором ядро обнаруживает устройства при загрузке, что может приводить к монтированию не тех файловых систем. Подобным образом, могут встретиться одинаковые метки, если вы подключаете новый диск или USB-устройство, и если это случается, то ваша система начинает работать непредсказуемым образом.

# По умолчанию, используется монтирование по UUID, но вы можете
# выбрать "traditional", чтобы использовать обычные имена устройств
# или "label", чтобы попробовать монтирование по меткам, перед
# тем как откатиться к UUID-ам.
#d-i partman/mount_style select uuid

B.4.8. Установка базовой системы

Для этого этапа, фактически, не так много автоматизируемых настроек. В основном они касаются установки ядра.

# Настроить APT для отмены автоматической установки рекомендуемых пакетов.
# Использование данного параметра может привести к установке неполноценной
# системы, и он должен использоваться только
# очень опытными пользователями.
#d-i base-installer/install-recommends boolean false

# Выбрать генератор initramfs, используемый для создания initrd
# для ядер 2.6.
#d-i base-installer/kernel/linux/initramfs-generators string initramfs-tools

# Устанавливаемый пакет (мета) с образом ядра; можно указать "none",
# если ядро устанавливать не нужно.
#d-i base-installer/kernel/image string linux-image-2.6-486

B.4.9. Настройка Apt

Настройка файла /etc/apt/sources.list и основных параметров конфигурации выполняется автоматически на основании метода установки и ответов на ранее заданные вопросы. Необязательно вы можете добавить другие (локальные) репозитории.

# Вы можете указать нужно ли устанавливать non-free и contrib ПО.
#d-i apt-setup/non-free boolean true
#d-i apt-setup/contrib boolean true
# Раскомментируйте, если не хотите использовать зеркало из сети.
#d-i apt-setup/use_mirror boolean false
# Выберите обновляемые сервисы; задайте используемые зеркала.
# Значения ниже используются по умолчанию.
#d-i apt-setup/services-select multiselect security, volatile
#d-i apt-setup/security_host string security.debian.org
#d-i apt-setup/volatile_host string volatile.debian.org

# Дополнительные репозитории доступны как local[0-9]
#d-i apt-setup/local0/repository string \
#       http://local.server/debian stable main
#d-i apt-setup/local0/comment string local server
# Активировать строки для deb-src
#d-i apt-setup/local0/source boolean true
# URL публичного ключа локального репозитория; вы должны
# предоставлять ключ, или apt будет жаловаться о невозможности
# аутентифицировать репозиторий и закомментирует строку,
# описывающую этот репозиторий в sources.list
#d-i apt-setup/local0/key string http://local.server/key

# По умолчанию программа установки требует, чтобы репозитории
# аутентифицировались с помощью известного ключа gpg.
# Этот параметр выключает данную аутентификацию.
# Предупреждение: это небезопасно, рекомендуется не делать этого.
#d-i debian-installer/allow_unauthenticated boolean true

B.4.10. Выбор пакетов

Вы можете выбрать любую доступную комбинацию устанавливаемых задач. Доступные задачи:

  • standard (стандартная система)

  • desktop (рабочий стол)

  • gnome-desktop (рабочий стол gnome)

  • kde-desktop (рабочий стол kde)

  • web-server (веб сервер)

  • print-server (сервер печати)

  • dns-server (DNS-сервер)

  • file-server (файловый сервер)

  • mail-server (почтовый сервер)

  • sql-database (база данных SQL)

  • laptop (для ноутбука)

Также вы можете не выбирать задачи и выполнить установку списка пакетов каким-то другим способом. Мы рекомендуем всегда включать задачу standard.

Если вы хотите установить несколько отдельных пакетов в дополнении к пакетам, устанавливаемым задачами, то вы можете использовать параметр pkgsel/include. В значении этого параметра в качестве разделителя можно использовать запятые или пробелы, поэтому также его можно указать в командной строке ядра.

#tasksel tasksel/first multiselect standard, web-server
# Если выбрана задача Рабочий стол, то установить рабочие столы
# kde и xfce вместо рабочего стола gnome по умолчанию.
#tasksel tasksel/desktop multiselect kde, xfce

# Отдельные дополнительные пакеты для установки
#d-i pkgsel/include string openssh-server build-essential
# Обновлять ли пакеты после debootstrap.
# Возможные значения: none, safe-upgrade, full-upgrade
#d-i pkgsel/upgrade select none

# Некоторые версии программы установки могут отсылать отчёт
# об установленных и используемых пакетах. По умолчанию данная
# возможность выключена, но отправка отчёта помогает проекту
# определить популярность программ и какие из них включать на CD.
#popularity-contest popularity-contest/participate boolean false

B.4.11. Установка загрузчика

# Grub is the default boot loader (for x86). If you want lilo installed
# instead, uncomment this:
#d-i grub-installer/skip boolean true
# To also skip installing lilo, and install no bootloader, uncomment this
# too:
#d-i lilo-installer/skip boolean true

# This is fairly safe to set, it makes grub install automatically to the MBR
# if no other operating system is detected on the machine.
d-i grub-installer/only_debian boolean true

# This one makes grub-installer install to the MBR if it also finds some other
# OS, which is less safe as it might not be able to boot that other OS.
d-i grub-installer/with_other_os boolean true

# Alternatively, if you want to install to a location other than the mbr,
# uncomment and edit these lines:
#d-i grub-installer/only_debian boolean false
#d-i grub-installer/with_other_os boolean false
#d-i grub-installer/bootdev  string (hd0,0)
# To install grub to multiple disks:
#d-i grub-installer/bootdev  string (hd0,0) (hd1,0) (hd2,0)
# To install to a particular device:
#d-i grub-installer/bootdev  string /dev/sda

# Optional password for grub, either in clear text
#d-i grub-installer/password password r00tme
#d-i grub-installer/password-again password r00tme
# or encrypted using an MD5 hash, see grub-md5-crypt(8).
#d-i grub-installer/password-crypted password [MD5 hash]

# Use the following option to add additional boot parameters for the
# installed system (if supported by the bootloader installer).
# Note: options passed to the installer will be added automatically.
#d-i debian-installer/add-kernel-opts string nousb

Хеш MD5 для пароля на grub можно сгенерировать с помощью grub-md5-crypt или командой из примера в Раздел B.4.5, «Настройка учётной записи».

B.4.12. Завершение установки

# При установке с консоли на последовательном порту обычные виртуальные
# консоли (VT1-VT6) выключаются в /etc/inittab. Раскомментируйте
# следующую строку, чтобы этого не происходило.
#d-i finish-install/keep-consoles boolean true

# Не показывать последнее сообщение о том, что установка завершена.
d-i finish-install/reboot_in_progress note

# Не выдвигать лоток CD при перезагрузке, что иногда может пригодиться.
#d-i cdrom-detect/eject boolean false

# Остановить систему после завершения установки, а
# не перегружаться в установленную систему.
#d-i debian-installer/exit/halt boolean true
# Эта настройка позволяет выключить питание машины, а не просто остановить её.
#d-i debian-installer/exit/poweroff boolean true

B.4.13. Автоматизация других пакетов

# В зависимости от выбранного для установки ПО, или если что-то идёт
# неправильно во время процесса установки, существует вероятность появления других
# вопросов. Естественно, их тоже можно автоматизировать. Чтобы получить список
# всех возможных вопросов, которые могут быть заданы во время установки, выполните
# установку, а затем запустите следующие команды:
#   debconf-get-selections --installer
> файл
#   debconf-get-selections
>
> файл

[29] При задании значения для locale равным en_NL, например, приведёт к установке системы с локалью по умолчанию en_US.UTF-8. Если, например, требуется en_GB.UTF-8, то значения для автоматического ответа нужно задавать отдельно для каждого параметра.

Пред. | Уровень выше | След.
B.3. Создание файла ответов | Начало | B.5. Дополнительные параметры


B.5. Дополнительные параметры
Пред. Приложение B. Автоматическая установка с помощью списка ответов След.

B.5. Дополнительные параметры

B.5.1. Запуск пользовательских команд во время установки

Инструментарий автоматической установки предлагает очень мощную и гибкую возможность — способность запуска команд или сценариев в определённые моменты установки.

# Автоматизация d-i по сути небезопасна. Программа установки не выполняет
# проверок на переполнения буфера или другого использования значений
# такого направления из файла ответов. Используйте файлы ответов только из
# надёжных источников! Для использования дома, и потому что это обычно
# полезно, здесь показано как запускать свои команды оболочки внутри
# программы установки автоматически.

# Эта первая команда, которая выполняется как можно раньше сразу после
# чтения файла ответов.
#d-i preseed/early_command string anna-install какой-то-udeb
# Эта команда выполняется непосредственно перед запуском утилиты разметки.
# Это может пригодиться для динамической автоматической настройки утилиты
# разметки, зависящей от состояния дисков (которое может быть
# непонятно при работе preseed/early_command).
#d-i partman/early_command \
#       string debconf-set partman-auto/disk "$(list-devices disk | head -n1)"
# Эта команда выполняется перед окончанием установки, пока ещё
# есть рабочий каталог /target. Вы можете выполнить chroot в /target
# и непосредственно использовать его, или же воспользоваться командами
# apt-install и in-target для облегчения задачи установки пакетов и
# запуска команд в целевой системе.
#d-i preseed/late_command string apt-install zsh; in-target chsh -s /bin/zsh

B.5.2. Использование автоматической установки для изменения значений по умолчанию

С помощью автоматической установки можно изменить ответы по умолчанию, но вопросы всё равно будут задаваться. Для этого после задания ответа на вопрос нужно установить флаг seen в «false» после указания ответа на вопрос.

d-i foo/bar string value
d-i foo/bar seen false

Того же эффекта можно достигнуть для всех вопросов, указав параметр preseed/interactive=true в приглашении к загрузке. Также это может помочь при отладке или тестировании вашего файла ответов.

Заметим, что владелец «d-i» должен использоваться только для переменных, используемых в самой программе установки. Для переменных, принадлежащих устанавливаемым в систему пакетам,вы должны использовать имя этого пакета. См. сноску к Раздел B.2.2, «Использование параметров загрузки для автоматизации».

Если вы выполняете автоматизацию через параметры загрузки, то можете заставить программу установки задавать соответствующий вопрос с помощью оператора «?=», а именно foo/bar?=value (или owner:foo/bar?=value). Естественно, это действует только на параметры, которые относятся к отображаемым во время установки вопросам, но никак не на «внутренние» параметры.

B.5.3. Последовательная загрузка нескольких файлов ответов

В файлах ответов поддерживаются ссылки на дополнительные файлы ответов. Любые настройки файлов, загруженных позже, будут перекрывать настройки из файлов, загруженных ранее. Это позволяет поместить, например, общие настройки сети в один файл, а более специфичные для определённых конфигураций в другие файлы.

# Можно указать более одного файла, разделив их пробелами; все будут
# загружены. Включаемые файлы, в свою очередь, тоже могут содержать
# директивы preseed/include. Заметим, что если имена файлов
# относительные, то они берутся
# из того же каталога что и файл ответов, в который они включены.
#d-i preseed/include string x.cfg

# Программу установки можно заставить проверять контрольные суммы файлов
# ответов перед их использованием. В данный момент поддерживается только
# md5sums; в списке md5sums файлы должны указываться в том же порядке,
# что и при включении файлов.
#d-i preseed/include/checksum string 5da499872becccfeda2c4872f9171c3d

# Для большей гибкости можно запустить команду оболочки и если она выдаст
# имена файлов ответов, включить эти файлы.
#d-i preseed/include_command \
#      string if [ "`hostname`" = bob ]; then echo bob.cfg; fi

# Наиболее гибкий из всех способ -- загрузить и выполнить программу.
# Программа может использовать команды, например, debconf-set для
# управления базой данных debconf.
# Можно указать более одного файла, разделив их пробелами
# Заметим, что если имена файлов относительные, то они ищутся в том же
# каталоге откуда взят файл ответов, который запускает их.
#d-i preseed/run string foo.sh

Также возможно цепочечное выполнение автоматизации из initrd или файла, а затем автоматизацию по сети, если задать preseed/url в файлах исполняемых первыми. Это приведёт выполнению автоматизации по сети, когда сеть станет доступна. Нужно быть осторожным при настройке, так как будут выполняться два разных по сути метода автоматизации, что, например, приведёт к выполнению команды из preseed/early дважды: один раз из первого метода, второй раз после включения сети.

Пред. | Уровень выше | След.
B.4. Содержимое файла ответов (для squeeze) | Начало | Приложение C. Разметка дисков в Debian


Приложение C. Разметка дисков в Debian
Пред. След.

Приложение C. Разметка дисков в Debian

Содержание

C.1. Дисковые разделы Debian и их размеры
C.2. Структура каталогов
C.3. Рекомендуемые схемы разметки
C.4. Имена устройств в Linux
C.5. Программы разметки в Debian
C.5.1. Разметка для 32-bit PC
Пред. |  | След.
B.5. Дополнительные параметры | Начало | C.1. Дисковые разделы Debian и их размеры


C.1. Дисковые разделы Debian и их размеры
Пред. Приложение C. Разметка дисков в Debian След.

C.1. Дисковые разделы Debian и их размеры

Как минимум, для GNU/Linux требуется один раздел. Вы можете иметь единственный раздел, содержащий всю операционную систему, приложения и ваши личные файлы. Большинство людей считают, что также необходим раздел подкачки, хотя это не совсем верно. «Раздел подкачки (swap)» — это рабочее пространство для операционной системы, которое позволяет использовать дисковое пространство в качестве «виртуальной памяти». Linux работает с виртуальной памятью более эффективно, если она расположена в отдельном разделе. Linux может использовать для подкачки обычный файл, но это не рекомендуется.

Однако большинство людей выделяют под GNU/Linux больше одного раздела. Есть две причины, по которым возможно вы захотите разделить файловую систему на несколько маленьких разделов. Первая — это безопасность. Если что-то повредится в файловой системе, пострадает только один раздел. То есть, вам нужно будет восстановить (из резервной копии, которую вы заботливо храните) только часть системы. Как минимум, вам нужно создать так называемый «корневой раздел». Он содержит наиболее важные компоненты системы. Если любой другой раздел будет повреждён, вы всё равно сможете загрузиться в GNU/Linux чтобы починить систему. Это может спасти вас от неприятной полной переустановки системы.

Вторая причина обычно более важна для бизнеса, но на самом деле это зависит от того, в каком качестве используется машина. Например, почтовый сервер, получая спам, может легко переполнить раздел письмами. Если вы сделаете для /var/mail отдельный раздел на почтовом сервере, большинство систем будут продолжать работать даже если вас заспамят.

Единственным настоящим препятствием по использованию нескольких разделов является то, что часто трудно предсказать размер, который для них нужно выбрать. Если вы сделаете раздел слишком маленьким, то вам придётся или переустанавливать всю систему или постоянно перемещать файлы из-за нехватки места на разделе. С другой стороны, если сделать раздел слишком большим, то это трата места впустую, а оно могло пригодиться где-нибудь ещё. В наши дни дисковое пространство дёшево, но зачем выбрасывать деньги на ветер?

Пред. | Уровень выше | След.
Приложение C. Разметка дисков в Debian | Начало | C.2. Структура каталогов


C.2. Структура каталогов
Пред. Приложение C. Разметка дисков в Debian След.

C.2. Структура каталогов

Debian GNU/Linux придерживается стандарта Filesystem Hierarchy Standard для каталогов и имён файлов. Этот стандарт позволяет пользователям и программному обеспечению быть уверенным в расположении файлов и каталогов. Уровень корневого каталога представляется просто косой чертой /. На корневом уровне, все системы Debian содержат следующие каталоги:

Каталог | Содержит
bin | необходимые исполняемые файлы
boot | статичные файлы системного загрузчика
dev | файлы устройств
etc | настройки системы данной машины
home | домашние каталоги пользователей
lib | необходимые библиотеки общего пользования и модули ядра
media | содержит точки монтирования для съёмных носителей
mnt | точка монтирования для временно монтируемой файловой системы
proc | виртуальный каталог для системной информации (для ядер 2.4 и 2.6)
root | домашний каталог суперпользователя
sbin | необходимые системные исполняемые файлы
sys | виртуальный каталог для системной информации (для ядер 2.6)
tmp | временные файлы
usr | вторичная иерархия
var | изменяемые данные
srv | Данные сервисов, предоставляемых системой
opt | дополнительное программное обеспечение

Далее следует список важных предположений относительно каталогов и разделов. Заметьте, что дисковое пространство может использоваться совершенно по-разному, в зависимости от настроек системы и специфики решаемых задач. Приводимые здесь рекомендации являются лишь отправной точкой в решении задачи разметки.

  • На корневом разделе / всегда физически должны находиться каталоги /etc, /bin, /sbin, /lib и /dev, иначе будет невозможна загрузка системы. Обычно, для корневого раздела требуется 150–250 МБ.

  • В /usr хранятся: все пользовательские программы (/usr/bin) , библиотеки (/usr/lib), документация (/usr/share/doc) и так далее. Этой части файловой системы требуется много места. Вы должны выделить как минимум 500 МБ дискового пространства. Объём этого раздела зависит от числа и типа пакетов, планируемых к установке. Для рабочих станций общего назначения или серверов цифра может вырасти до 4–6 ГБ.

  • Каталог /var содержит: все изменяющиеся данные типа новостных статей, сообщений электронной почты, веб-сайтов, баз данных, кэша системы управления пакетами и т.д. Размер каталога целиком зависит от степени использования компьютера, но для большинства людей он определяется работой с системой управления пакетами. Если вы собираетесь установить всё, что предлагает Debian, при чём сразу, то 2 или 3 гигабайта для /var должно хватить. Если вы собираетесь производить установку по частям (то есть, установить службы и утилиты, потом программы для работы с текстом, потом X, ...), то можно уложиться в 300–500 МБ. Если пространство жёсткого диска дорого и вы не планируете делать глобальных обновлений системы, то вам будет достаточно 30 или 40 МБ.

  • Каталог /tmp содержит: временные данные создаваемые запущенными программами. Обычно достаточно 40–100 МБ. Некоторые приложения — управление резервным копированием, утилиты работы с CD/DVD и мультимедийными данными — могут использовать /tmp для временного хранения файлов. Если вы планируете использовать данные приложения, то должны выделить пространство под /tmp согласно вашим потребностям.

  • Каталог /home содержит: отдельный подкаталог для каждого пользователя, где хранятся личные данные. Его размер зависит от количества пользователей в системе и какие файлы они будут хранить в своих каталогах. В зависимости от планируемого использования вы должны зарезервировать около 100 МБ для каждого пользователя, но можете изменить это значение согласно своим требованиям. Выделите больше места, если планируете хранить много мультимедийных файлов (картинок, MP3, фильмов) в своём домашнем каталоге.

Пред. | Уровень выше | След.
C.1. Дисковые разделы Debian и их размеры | Начало | C.3. Рекомендуемые схемы разметки


C.3. Рекомендуемые схемы разметки
Пред. Приложение C. Разметка дисков в Debian След.

C.3. Рекомендуемые схемы разметки

Для новичков, устанавливающих Debian только для себя на домашние машины, создание единственного раздела для / (плюс раздел подкачки) вероятно, самый лёгкий и простой путь. Однако, если ваш раздел более 6 ГБ, в качестве типа раздела выберите ext3. Разделы ext2 требуют периодической проверки целостности файловой системы, а это на больших разделах может вызвать паузу при загрузке.

Для многопользовательских систем или систем с большим дисковым пространством будет лучше создать для /usr, /var, /tmp и /home собственные разделы, отдельные от /.

Вам может потребоваться отдельный раздел /usr/local, если вы планируете установку многих программ, которые не являются частью дистрибутива Debian. Если ваша машина будет почтовым сервером, вам может потребоваться сделать отдельный раздел под /var/mail. Часто, полезно выделить /tmp в отдельный раздел размером 20–50 МБ. Если вы настраиваете сервер, обслуживающий большое количество пользователей, обычно, хорошо иметь отдельный большой /home раздел. В общем, ситуация с разметкой зависит от цели, которой служит компьютер.

Для очень сложных систем вы должны прочитать Multi Disk HOWTO. В нём содержится подробная информация, которая будет наиболее интересна провайдерам Интернет и людям, настраивающим серверы.

По поводу размера раздела подкачки существует много точек зрения. Согласно проверенному опытом методу, размер подкачки должен совпадать с размером оперативной памяти. Также, в большинстве случаев он должен быть не менее 16 МБ. Естественно, есть исключения из правил. Если вы пытаетесь одновременно решить 10000 уравнений на машине с 256 МБ памяти, то вам может потребоваться гигабайтный (или более) раздел подкачки.

On some 32-bit architectures (m68k and PowerPC), the maximum size of a swap partition is 2GB. That should be enough for nearly any installation. However, if your swap requirements are this high, you should probably try to spread the swap across different disks (also called «spindles») and, if possible, different SCSI or IDE channels. The kernel will balance swap usage between multiple swap partitions, giving better performance.

Пример: старая домашняя машина имеет 32 МБ оперативной памяти и 1.7 ГБ жёсткий диск IDE /dev/hda. Здесь можно сделать 500 МБ раздел для другой операционной системы /dev/hda1, 32 МБ раздел подкачки/dev/hda3 и около 1.2 ГБ раздел Linux /dev/hda2.

Про то, как будет использовано дисковое пространство можно определить по задачам, которые вы захотите установить после установки системы; смотрите Раздел D.2, «Дисковое пространство, необходимое для задач».

Пред. | Уровень выше | След.
C.2. Структура каталогов | Начало | C.4. Имена устройств в Linux


C.4. Имена устройств в Linux
Пред. Приложение C. Разметка дисков в Debian След.

C.4. Имена устройств в Linux

Имена дисков и разделов в Linux могут отличаться от имён в других операционных системах. Для того чтобы создавать и монтировать разделы вам нужно знать какие имена используются в Linux. Вот основы схемы именования:

  • Первый дисковод гибких дисков называется /dev/fd0.

  • Второй дисковод гибких дисков называется /dev/fd1.

  • Первый SCSI диск (отсчитывая по SCSI ID) называется /dev/sda.

  • Второй SCSI диск (отсчитывая по SCSI ID) называется /dev/sdb и так далее.

  • Первый SCSI CD-ROM называется /dev/scd0, также можно использовать /dev/sr0.

  • Мастер диск первичного IDE контроллера называется /dev/hda.

  • Подчинённый диск первичного IDE контроллера называется /dev/hdb.

  • Мастер и подчинённый диски вторичного контроллера называются /dev/hdc и /dev/hdd соответственно. Новые IDE контроллеры могут на самом деле иметь два канала, эффективно действуя как два независимых контроллера.

Имена разделов диска получаются добавлением к имени диска десятичного числа: sda1 и sda2 представляют первый и второй разделы на первом диске SCSI в системе.

Вот реальный пример. Предположим, что вы имеете систему с 2-мя SCSI дисками, один имеет SCSI адрес 2, а другой SCSI адрес 4. Первый диск (с адресом 2) называется sda, а второй sdb. Если диск sda содержит 3 раздела, то их имена будут sda1, sda2 и sda3. То же относится к диску sdb и его разделам.

Заметим, что если вы имеете два адаптера SCSI (то есть, контроллера), то порядок дисков может показаться непонятным. Лучшее решение в этом случае посмотреть загрузочные сообщения; предполагается, что вы знаете модели дисков и/или их объём.

В Linux первичные разделы представляются как имя диска плюс число от 1 до 4. Например, первый первичный раздел первого IDE диска называется /dev/hda1. Логические разделы нумеруются начиная с 5, поэтому первый логический раздел на том же диске называется/dev/hda5. Помните, что это расширенный раздел, то есть первичный раздел содержащий логические разделы, сам по себе не использующийся. Это применимо и к дискам SCSI и к дискам IDE.

Пред. | Уровень выше | След.
C.3. Рекомендуемые схемы разметки | Начало | C.5. Программы разметки в Debian


C.5. Программы разметки в Debian
Пред. Приложение C. Разметка дисков в Debian След.

C.5. Программы разметки в Debian

Для работы с различными типами жёстких дисков и компьютерных архитектур разработчиками Debian были адаптированы несколько разновидностей программ разметки. На вашей машине могут работать программы, представленные в списке далее.

partman

Рекомендуемая утилита разметки в Debian. Этот швейцарский армейский нож может также изменять размеры разделов, создавать файловые системы (как «format» в Windows) и назначать им точки монтирования.

fdisk

Самая первая программа разметки дисков в Linux, хороша для гуру.

Будьте осторожны, если у вас на машине есть разделы FreeBSD. В устанавливаемые ядра включена поддержка этих разделов, но способ их отображения в fdisk может отличаться. Смотрите Linux+FreeBSD HOWTO

cfdisk

Простая в использовании, полноэкранная программа разметки дисков для повседневного использования.

Заметим, что cfdisk не понимает разделов FreeBSD, и ещё раз, поэтому имена устройств могут различаться.

Одна из этих программ будет запущена по умолчанию, когда вы выберете Разметка дисков (или типа того). Возможно использовать другую утилиту разметки из командной строки на VT2, но это не рекомендуется.

Не забудьте пометить раздел загрузки как «Загрузочный».

C.5.1. Разметка для 32-bit PC

Если у вас есть другие операционные системы, например, DOS или Windows, и вы хотите сохранить их, то может потребоваться изменить размеры их разделов, чтобы освободить больше пространства для Debian. Программа установки может изменять размеры файловых систем FAT и NTFS; на шаге разметки выберите Вручную и затем просто выберите имеющийся раздел и измените его размер.

PC BIOS обычно накладывает дополнительные ограничения на дисковую разметку. Есть ограничение на количество «первичных» и «логических» разделов, которые может содержать диск. Также, в BIOS 1994–98 годов, есть ограничения, откуда BIOS может производить загрузку. Подробную информацию можно найти в Разметка в Linux HOWTO и Phoenix BIOS FAQ, но в этом разделе будет дано краткое описание, которое поможет во многих ситуациях.

«Первичные» разделы присутствовали в первоначальной схеме разметки дисков на PC. Однако, их может быть только четыре. Чтобы обойти это ограничение, были придуманы «расширенные» и «логические» разделы. Пометив один из первичных разделов как расширенный, вы можете поделить всё его пространство на логические разделы. Вы можете создать до 60 логических разделов на расширенном разделе; однако, вы можете иметь только один расширенный раздел на диске.

Linux ограничивает количество разделов до 15 на SCSI дисках (3 первичных раздела, 12 логических разделов), и 63 раздела на IDE дисках (3 первичных раздела, 60 логических разделов). Однако, обычная система Debian GNU/Linux предоставляет только 20 устройств под разделы, поэтому вы не сможете произвести установку на раздел выше чем 20, если только сначала вручную не создадите устройства для этих разделов.

Если вы имеете большой IDE диск и не используете ни LBA адресацию, ни драйвера поддержки (иногда предоставляемого производителем жёсткого диска), то загрузочный раздел (раздел, содержащий образ ядра) должен располагаться в пределах первых 1024 цилиндров жёсткого диска (обычно, это 524 мегабайта без BIOS трансляции).

Этого ограничения нет в BIOS новее 1995–98 годов (зависит от производителя), которые поддерживают «Enhanced Disk Drive Support Specification». И Lilo, Linux загрузчик, и альтернатива Debian — mbr, должны использовать BIOS для чтения ядра с диска в оперативную память. Если будет найдено расширение прерывания BIOS int 0x13 доступа к диску, то оно будет использовано. Иначе, будет использован обычный старый интерфейс доступа к диску, и не будут использованы адреса, расположенные на диске за 1023-им цилиндром. После загрузки Linux, неважно какой BIOS имеется в компьютере, эти ограничения больше не действуют, так как Linux не использует BIOS для доступа к диску.

Если вы имеете большой диск, то можете использовать технологию трансляции цилиндров, которую можно включить в BIOS; она называется LBA (логическая адресация блоков) или режим трансляции CHS («Large»). Подробную информацию о проблемах с большими жёсткими дисками можно найти в HOWTO по большим дискам. Если вы используете схему трансляции цилиндров, а BIOS не поддерживает расширения доступа к большим жёстким дискам, то ваш загрузочный раздел должен попадать в транслированное представление первых 1024-х цилиндров.

Рекомендуемый путь выполнения этого условия — создать маленький (25–50 МБ должно хватить) раздел в начале диска, для использования в качестве загрузочного раздела, а затем создавать любые нужные разделы в оставшейся области. Загрузочный раздел должен быть смонтирован в /boot, так как в этом каталоге хранятся ядра Linux. Такая конфигурация будет работать на любой системе, независимо используется ли трансляции LBA больших дисков или CHS, и независимо от того поддерживает ли BIOS расширение для доступа к большим дискам.

Пред. | Уровень выше | След.
C.4. Имена устройств в Linux | Начало | Приложение D. Разное


Приложение D. Разное
Пред. След.

Приложение D. Разное

Содержание

D.1. Устройства Linux
D.1.1. Установка мыши
D.2. Дисковое пространство, необходимое для задач
D.3. Установка Debian GNU/Linux из системы Unix/Linux
D.3.1. Начинаем
D.3.2. Установка debootstrap
D.3.3. Запуск debootstrap
D.3.4. Настройка базовой системы
D.3.5. Установка ядра
D.3.6. Установка системного загрузчика
D.3.7. Заключительные шаги
D.4. Установка Debian GNU/Linux через Parallel Line IP (PLIP)
D.4.1. Требования
D.4.2. Настройка источника
D.4.3. Установка приёмника
D.5. Установка Debian GNU/Linux с использованием PPP через Ethernet (PPPoE)
D.6. Программа установки с графическим интерфейсом
D.6.1. Использование программы установки с графическим интерфейсом
Пред. |  | След.
C.5. Программы разметки в Debian | Начало | D.1. Устройства Linux


D.1. Устройства Linux
Пред. Приложение D. Разное След.

D.1. Устройства Linux

В Linux в каталоге /dev содержатся различные специальные файлы. Эти файлы называются файлами устройств. Доступ к устройствам в мире Unix отличается от того, как это сделано в других операционных системах. Здесь это делается через специальный файл, который в действительности обслуживается драйвером (часть ядра Linux), осуществляющим доступ к устройству. Другим, менее используемым типов файла устройства является канал. Ниже перечислены наиболее важные файлы устройств.

fd0 | Первый дисковод
fd1 | Второй дисковод

hda | Жёсткий диск IDE / CD-ROM на первом порту IDE (мастер)
hdb | Жёсткий диск IDE / CD-ROM на первом порту IDE (подчинённый)
hdc | Жёсткий диск IDE / CD-ROM на втором порту IDE (мастер)
hdd | Жёсткий диск IDE / CD-ROM на втором порту IDE (подчинённый)
hda1 | Первый раздел на первом жёстком диске IDE
hdd15 | Пятнадцатый раздел на четвёртом жёстком диске IDE

sda | Жёсткий диск SCSI с наименьшим SCSI ID (т.е. 0)
sdb | Жёсткий диск SCSI со следующим наибольшим SCSI ID (т.е. 1)
sdc | Жёсткий диск SCSI со следующим наибольшим SCSI ID (т.е. 2)
sda1 | Первый раздел на первом жёстком диске SCSI
sdd10 | Десятый раздел на четвёртом жёстком диске SCSI

sr0 | SCSI CD-ROM с наименьшим SCSI ID
sr1 | SCSI CD-ROM со следующим наибольшим SCSI ID

ttyS0 | Последовательный порт 0, COM1 под MS-DOS
ttyS1 | Последовательный порт 1, COM2 под MS-DOS
psaux | Устройство мышь PS/2
gpmdata | Псевдо-устройство, повторитель данных от демона GPM (мыши)

cdrom | Символическая ссылка на привод CD-ROM
mouse | Символическая ссылка на файл устройства мыши

null | Всё, что записывается в это устройство, исчезнет
zero | Можно бесконечно читать нули из этого устройства

D.1.1. Установка мыши

Мышь можно использовать одновременно в консоли Linux (с помощью gpm) и в среде X window. Обычно, для этого достаточно установить gpm и X-сервер. Они должны быть настроены на использование /dev/input/mice в качестве устройства мыши. В gpm нужно установить протокол работы с мышью exps2, а в X — ExplorerPS/2. Это производится в соответствующих файлах настройки /etc/gpm.conf и /etc/X11/xorg.conf.

Чтобы мышь заработала, должны быть загружены определённые драйверы ядра. В большинстве случаев нужные модули определяются автоматически, но это происходит не всегда, если используются старые мыши, подключаемые к последовательному порту и по шине[30], что есть большая редкость и встречается только на очень старых компьютерах. Краткая справка по модулям ядра Linux, которые нужны для различных типо мышей:

Модуль | Описание
psmouse | мышь PS/2 (должна определяться автоматически)
usbhid | мышь USB (должна определяться автоматически)
sermouse | Большинство мышей, подключаемых к последовательному порту
logibm | Мышь, подключаемая по шине к карте Logitech
inport | Мышь, подключаемая по шине к карте ATI или Microsoft InPort

Для загрузки драйвера мыши, вы можете воспользоваться командой modconf (из пакета с тем же названием) и посмотреть в категории kernel/drivers/input/mouse.

[30] Мышь, подключаемая к последовательному порту, имеет трапециевидный разъём с 9 отверстиями; мышь с подключением по шине имеет 8-штырьковый круглый разъём, не перепутайте с 6-штырьковым круглым разъёмом мыши PS/2 или 4-штырьковым круглым разъёмом мыши ADB.

Пред. | Уровень выше | След.
Приложение D. Разное | Начало | D.2. Дисковое пространство, необходимое для задач


D.2. Дисковое пространство, необходимое для задач
Пред. Приложение D. Разное След.

D.2. Дисковое пространство, необходимое для задач

Для стандартной установки на amd64 с ядром по умолчанию версии 2.6, со всеми стандартными пакетами требуется 532 МБ дискового пространства. Минимальная базовая установка без выбранной задачи «Стандартная система» занимает 368 МБ.

Важно

В обоих случаях — это реальное дисковое пространство, которое используется после завершения установки и удаления всех временных файлов. Сюда не входит место, занятое в файловой системе, например, журнальными файлами. Это означает, что во время процесса установки и просто работы системы потребуется значительно больше места на диске.

В таблице ниже приведено количество используемого места при установке задач, описанных в tasksel. Данные величины получены с помощью aptitude. Заметим, что некоторые пакеты входят в несколько задач одновременно, поэтому полный размер установки для двух задач вместе может быть меньше, чем полный размер, полученный сложением размеров.

По умолчанию программа установки устанавливает окружение рабочего стола GNOME, но можно выбрать другие окружения рабочего стола, или использовав один из специальных CD образов, или указав желаемое окружение рабочего стола при запуске программы установки (см. Раздел 6.3.5.2, «Выбор и установка программного обеспечения»).

Заметьте, что при подсчёте размера разделов к размеру стандартной установки нужно добавить размеры из таблицы. Большинство размеров из колонки «Размер после установки» нужно приплюсовывать к /usr и /lib, а размеры из колонки «Размер загрузки» занимает место (временно) в /var.

Задача | Размер после установки (МБ) | Размер загрузки (МБ) | Требуемое место для установки (МБ)
Окружение рабочего стола |  |  |
• GNOME (по умолчанию) | 2567 | 954 | 3521
• KDE | 2159 | 860 | 3019
• Xfce | 1672 | 637 | 2309
• LXDE | 1452 | 566 | 2018
Для ноутбука[a] | 182 | 59 | 241
веб сервер | 55 | 17 | 72
сервер печати | 196 | 63 | 259
DNS-сервер | 4 | 1 | 5
файловый сервер | 126 | 42 | 168
почтовый сервер | 64 | 23 | 87
база данных SQL | 49 | 10 | 59
SSH-сервер | 1 | 1 | 2
[a] Эта задача по нескольким пакетам пересекается с задачей Окружения рабочего стола. Если вы устанавливаете обе, то для задачи Для ноутбука потребуется дополнительно всего лишь несколько мегабайт.

Если вы выбрали установку не на английском языке, tasksel может автоматически установить задачу по локализации, если она существует для вашего языка. Необходимое пространство на диске зависит от языка; добавьте около 350 МБ на загрузку и установку.

Пред. | Уровень выше | След.
D.1. Устройства Linux | Начало | D.3. Установка Debian GNU/Linux из системы Unix/Linux


D.3. Установка Debian GNU/Linux из системы Unix/Linux
Пред. Приложение D. Разное След.

D.3. Установка Debian GNU/Linux из системы Unix/Linux

В этом разделе объясняется, как установить Debian GNU/Linux из существующей системы Unix или Linux без использования управляемой из меню программы установки, основанной на библиотеке ncurses, как это описывается в остальном руководстве. Это «междистрибутивное» HOWTO попросили пользователи, переходящие на Debian GNU/Linux из Redhat, Mandriva и SUSE. В этом разделе подразумевается наличие некоторого опыта работы с командами *nix и навигации по файловой системе. Здесь символ $ означает команду, вводимую в текущей пользовательской системе, а # относится к команде, вводимой в Debian chroot.

Как только вы получите новую систему Debian, настроенную по вашим предпочтениям, вы можете перенести свои данные (если они есть) в неё и продолжать работу. Поэтому такая установка Debian GNU/Linux считается «с нулевым временем простоя» (zero downtime). Также это мудрый способ работы с аппаратурой, которая не может нормально работать с разными загрузочными или установочными носителями.

Замечание

Так как это, по большей части, ручная процедура, вы должны помнить, что вам придётся сделать множество начальных настроек системы самостоятельно, которые также требуют больше знаний о Debian и Linux в общем, чем при выполнение обычной установки. Вы не должны ожидать, что эта процедура настроит вам систему так, как это делается при обычной установке. Также вы должны помнить,что эта процедура выполняет только основные этапы настройки системы. Может потребоваться дополнительная установка и/или настройка.

D.3.1. Начинаем

С помощью имеющейся утилиты *nix для работы с разделами диска, переразметьте диск как нужно, создав как минимум одну файловую систему плюс раздел подкачки (swap). Вам потребуется около 350 МБ для консольной версии установки или около 1 ГБ, если вы планируете установить X (или ещё больше, если вы будете устанавливать окружение рабочего стола типа GNOME или KDE).

Затем создайте файловые системы на разделах. Например, чтобы создать файловую систему ext3 на разделе /dev/hda6 (это корневой раздел в нашем примере):

# mke2fs -j /dev/hda6

Чтобы создать файловую систему ext2, не указывайте параметр -j.

Проинициализируйте и активируйте раздел подкачки (замените номер раздела на свой):

# mkswap /dev/hda5
# sync; sync; sync
# swapon /dev/hda5

Смонтируйте один раздел как /mnt/debinst (точка установки, она будет корневой (/) файловой системой в вашей новой системе). Имя точки монтирования абсолютно произвольное.

# mkdir /mnt/debinst
# mount /dev/hda6 /mnt/debinst

Замечание

Если вы хотите монтировать некоторые файловые системы (например, /usr) с отдельных разделов, то нужно создать и смонтировать эти каталоги вручную, перед тем как перейти к следующему этапу.

D.3.2. Установка debootstrap

Утилита, которой пользуется программа установки Debian и которая признана официальным способом установки базовой системы Debian является debootstrap. Она использует wget и ar, но зависит только от /bin/sh и часто используемых инструментов Unix/Linux[31]. Установите wget и ar, если их ещё нет в системе, а затем загрузите и установите debootstrap.

Или вы можете использовать следующую процедуру установки вручную. Создайте рабочий каталог для распаковки в него .deb:

# mkdir work
# cd work

Двоичный файл debootstrap расположен в архиве Debian (убедитесь, что вы выбрали правильный файл, соответствующий вашей архитектуре). Скачайте debootstrap .deb из пула, скопируйте пакет в рабочий каталог и извлеките из него файлы. Для установки файлов вам потребуются привилегии суперпользователя (root).

# ar -x debootstrap_0.X.X_all.deb
# cd /
# zcat /full-path-to-work/work/data.tar.gz | tar xv

D.3.3. Запуск debootstrap

Команда debootstrap может скачивать необходимые файлы прямо из архива. В примере ниже вы можете заменить http.us.debian.org/debian на любой сервер-зеркало архива Debian, лучше всего использовать из наиболее близкой к вам сети. Список серверов http://www.debian.org/mirror/list.

Если у вас есть компакт-диск с squeeze Debian GNU/Linux, смонтированный в /cdrom, вы можете подставить URL типа file вместо http URL: file:/cdrom/debian/

Замените ARCH на один из следующих вариантов в команде запуска debootstrap: alpha, amd64, arm, armel, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390 или sparc.

# /usr/sbin/debootstrap --arch ARCH squeeze \
     /mnt/debinst http://ftp.us.debian.org/debian

D.3.4. Настройка базовой системы

Теперь у вас есть настоящая система Debian на диске, хотя и небогатая возможностями. Выполните chroot в неё:

# LANG=C chroot /mnt/debinst /bin/bash

После chrooting, вам может потребоваться выполнить настройку терминала для совместимости с базовой системой Debian, например:

# export TERM=xterm-color

D.3.4.1. Создание файлов устройств

В данный момент /dev/ содержит только основные файлы устройств. Для следующих этапов установки могут потребоваться дополнительные файлы устройств. Есть несколько способов их создания; выбор более подходящего зависит от: a) системы, с которой производится установка; б) будет ли использоваться модульность ядро; в) используются в новой системе динамические (например, посредством udev) или статические файлы устройств.

Некоторые доступные способы:

  • создание используемого по умолчанию набора статических файлов устройств

    # cd /dev
# MAKEDEV generic

  • создание вручную только выбранных файлов устройств с помощью MAKEDEV

  • привязка смонтированного /dev имеющейся системы поверх /dev в устанавливаемой системе; заметим, что сценарии postinst некоторых пакетов могут пытаться создавать файлы устройств, поэтому данный параметр нужно использовать осторожно

D.3.4.2. Монтирование разделов

Вам нужно создать файл /etc/fstab.

# editor /etc/fstab

Вот пример, который можно изменить в соответствии с вашими условиями:

# /etc/fstab: информация о статических монтируемых файловых системах.
#
# файл. система  точка монтир. тип     параметры                дамп проход
/dev/XXX         /             ext3    defaults                 0    1
/dev/XXX         /boot         ext3    ro,nosuid,nodev          0    2

/dev/XXX         none          swap    sw                       0    0
proc             /proc         proc    defaults                 0    0

/dev/fd0         /media/floppy auto    noauto,rw,sync,user,exec 0    0
/dev/cdrom       /media/cdrom  iso9660 noauto,ro,user,exec      0    0

/dev/XXX         /tmp          ext3    rw,nosuid,nodev          0    2
/dev/XXX         /var          ext3    rw,nosuid,nodev          0    2
/dev/XXX         /usr          ext3    rw,nodev                 0    2
/dev/XXX         /home         ext3    rw,nosuid,nodev          0    2

Выполните mount -a для монтирования всех файловых систем, указанных в файле /etc/fstab, а для монтирования определённой файловой системы выполните:

# mount /path   # пример: mount /usr

В системах Debian точки монтирования для съёмных носителей расположены в /media, но для обратной совместимости в / созданы символические ссылки. Создайте их, если нужно. Пример:

# cd /media
# mkdir cdrom0
# ln -s cdrom0 cdrom
# cd /
# ln -s media/cdrom

Вы можете монтировать файловую систему proc несколько раз и в произвольные места, хотя принято в /proc. Если вы не использовали mount -a, то перед тем как продолжить, убедитесь, что proc смонтирована:

# mount -t proc proc /proc

Команда ls /proc теперь должна показывать, что каталог не пустой. Если это не так, можно смонтировать proc за пределами chroot:

# mount -t proc proc /mnt/debinst/proc

D.3.4.3. Настройка часового пояса

В файле /etc/default/rcS есть параметр, который задаёт, как система должна интерпретировать аппаратные часы — установлены ли они по UTC или показывают местное время. Следующая команда позволяет указать это и выбрать часовой пояс.

# editor /etc/default/rcS
# dpkg-reconfigure tzdata

D.3.4.4. Настройка сети

Для настройки сети, отредактируйте /etc/network/interfaces, /etc/resolv.conf, /etc/hostname и /etc/hosts.

# editor /etc/network/interfaces

Здесь приведены некоторые простые примеры из /usr/share/doc/ifupdown/examples:

######################################################################
# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
# See the interfaces(5) manpage for information on what options are
# available.
######################################################################

# We always want the loopback interface.
#
auto lo
iface lo inet loopback

# To use dhcp:
#
# auto eth0
# iface eth0 inet dhcp

# An example static IP setup: (broadcast and gateway are optional)
#
# auto eth0
# iface eth0 inet static
#     address 192.168.0.42
#     network 192.168.0.0
#     netmask 255.255.255.0
#     broadcast 192.168.0.255
#     gateway 192.168.0.1

Enter your nameserver(s) and search directives in /etc/resolv.conf:

# editor /etc/resolv.conf

A simple example /etc/resolv.conf:

search hqdom.local
nameserver 10.1.1.36
nameserver 192.168.9.100

Укажите DNS-сервер(ы) и директивы search в /etc/resolv.conf:

# editor /etc/resolv.conf

Простой пример /etc/resolv.conf:

search hqdom.local
nameserver 10.1.1.36
nameserver 192.168.9.100

Укажите имя узла (от 2 до 63 символов):

# echo DebianHostName > /etc/hostname

И базовый /etc/hosts с поддержкой IPv6:

127.0.0.1 localhost
127.0.1.1 DebianHostName

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

Если у вас несколько сетевых карт, то вам нужно разместить имена драйверов в файле /etc/modules в желаемом порядке. Позже при загрузке каждая карта будет связана с именем интерфейса (eth0, eth1 и т.д.) как вы и ожидали.

D.3.4.5. Настройка Apt

Debootstrap создаст очень общий /etc/apt/sources.list, который позволит установить дополнительные пакеты. Однако, вы можете захотеть добавить дополнительные источники, например для пакетов с исходным кодом и обновлений безопасности:

deb-src http://ftp.us.debian.org/debian squeeze main

deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main

Обязательно запустите aptitude update после изменения списка источников.

D.3.4.6. Настройка раскладки клавиатуры и локалей

Чтобы использовать язык, отличный от английского, нужно настроить локаль. Для этого установите пакет поддержки locales и настройте его. Рекомендуется использовать UTF-8 локали.

# aptitude install locales
# dpkg-reconfigure locales

Для настройки раскладки клавиатуры (если нужно):

# aptitude install console-data
# dpkg-reconfigure console-data

Заметим, что клавиатура не может быть настроена, пока работа производится в chroot, но настройка будет произведена после следующей перезагрузки.

D.3.5. Установка ядра

Если вы намерены загружать эту систему, то вам скорее всего понадобится ядро Linux и системный загрузчик. Определите доступные пакеты с ядрами с помощью:

# apt-cache search linux-image

Затем установите пакет с ядром, указав подходящий вам вариант.

# aptitude install linux-image-2.6.32-arch-etc

D.3.6. Установка системного загрузчика

Чтобы сделать систему Debian GNU/Linux загружаемой, настройте системный загрузчик на загрузку установленного ядра с новым корневым разделом. Заметим, что debootstrap не устанавливает системный загрузчик, хотя вы можете использовать aptitude внутри вашего Debian chroot, чтобы сделать это.

Просмотрите info grub или man lilo.conf про установку системного загрузчика. Если вы оставляете систему, которую использовали для установки Debian, просто добавьте запись для установленной системы Debian в существующий файл grub menu.lst или lilo.conf. Для lilo.conf вы можете также скопировать его в новую систему и отредактировать его там. После того как закончите редактирование, вызовите lilo (помните, что он будет использовать lilo.conf, относящийся к системе, из которой его вызвали).

Установить и настроить grub легко:

# aptitude install grub
# grub-install /dev/hda
# update-grub

Вторая команда устанавливает grub (в данном случае в MBR диска hda). Последняя команда создаёт приемлемый и рабочий файл /boot/grub/menu.lst.

Заметим, что это предполагает, что файловое устройство /dev/hda было создано ранее. Есть другие методы установки grub, но они здесь не описаны.

Вот простой /etc/lilo.conf в качестве примера:

boot=/dev/hda6
root=/dev/hda6
install=menu
delay=20
lba32
image=/vmlinuz
initrd=/initrd.img
label=Debian

D.3.7. Заключительные шаги

Как упоминалось ранее, установленная система мало что умеет. Если вы хотите сделать систему более пригодной для работы, можно установить все пакеты с приоритетом «стандарт»:

# tasksel install standard

Конечно, также вы можете использовать aptitude для установки отдельных пакетов.

После установки все скаченные пакеты будут сохранены в каталог /var/cache/apt/archives/. Вы можете освободить немного места запустив:

# aptitude clean

[31] Сюда входят базовые утилиты GNU и команды типа sed, grep, tar и gzip.

Пред. | Уровень выше | След.
D.2. Дисковое пространство, необходимое для задач | Начало | D.4. Установка Debian GNU/Linux через Parallel Line IP (PLIP)


D.4. Установка Debian GNU/Linux через Parallel Line IP (PLIP)
Пред. Приложение D. Разное След.

D.4. Установка Debian GNU/Linux через Parallel Line IP (PLIP)

Этот раздел описывает установку Debian GNU/Linux на компьютер без сетевой карты Ethernet, но подключённый к другому компьютеру-шлюзу с помощью нуль-модемного кабеля (также называемого нуль-принтерным кабелем). Компьютер-шлюз должен быть подключён к сети, где есть сервер-зеркало Debian (например, к Интернет).

В примере, показанном в приложении, мы будем настраивать PLIP соединение со шлюзом подключённым к Интернет через соединение по телефонной линии (ppp0). Мы будет использовать IP-адреса 192.168.0.1 и 192.168.0.2 для PLIP интерфейсов системы приёмника и системы источника соответственно(эти адреса не должны использоваться в вашем сетевом адресном пространстве).

PLIP соединение, настроенное в время установки будет также работать и после перезагрузки в установленную систему (смотрите Глава 7, Загрузка только что установленной системы Debian).

Перед тем как начать, проверьте настройки BIOS (IO base address и IRQ) параллельных портов на обеих системах. Наиболее распространённые значения: io=0x378, irq=7.

D.4.1. Требования

  • На компьютер приёмник, называемый приёмник, будет установлен Debian.

  • Системные установочные носители; смотрите Раздел 2.4, «Установочные носители».

  • Другой компьютер, подключённый к Интернет, называемый источник, будет использоваться в качестве шлюза.

  • Нуль-модемный кабель DB-25. Подробней о кабеле и как его сделать смотрите PLIP-Install-HOWTO.

D.4.2. Настройка источника

Сценарий, показанный ниже — это простой пример настройки компьютера источника в качестве шлюза в Интернет через ppp0.

#!/bin/sh

# We remove running modules from kernel to avoid conflicts and to
# reconfigure them manually.
modprobe -r lp parport_pc
modprobe parport_pc io=0x378 irq=7
modprobe plip

# Configure the plip interface (plip0 for me, see dmesg | grep plip)
ifconfig plip0 192.168.0.2 pointopoint 192.168.0.1 netmask 255.255.255.255 up

# Configure gateway
modprobe iptable_nat
iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE
echo 1
> /proc/sys/net/ipv4/ip_forward

D.4.3. Установка приёмника

Загрузитесь с установочного носителя. Установка должна быть запущена в экспертном режиме; в приглашении к загрузке введите expert. Если требуется задать параметры для модулей ядра, вы также должны указать их в приглашении к загрузке. Например, для загрузки программы установки и настройки значений параметров «io» и «irq» для модуля parport_pc, введите следующее:

expert parport_pc.io=0x378 parport_pc.irq=7

Ниже показаны ответы, которые нужно ввести на различных этапах установки.

  1. Загрузка компонент программы установки с CD

    В списке выберите параметр plip-modules; это сделает доступным PLIP драйвера для программы установки.

  2. Определение сетевой карты

    • Если приёмник имеет сетевую карту, будет показан список модулей драйверов для обнаруженных карт. Если вы хотите, чтобы debian-installer использовал всё равно plip, то снимите выделение со всех показанных модулей драйверов. Естественно, если приёмник не имеет сетевой карты, программа установки не покажет этого списка.

    • Так как ранее сетевой карты обнаружено/выбрано не было, программа установки попросит выбрать модуль сетевого устройства из списка. Выберите модуль plip.

  3. Настройка сети

    • Настроить сеть автоматически с помощью DHCP: нет

    • IP-адрес: 192.168.0.1

    • Адрес PPP: 192.168.0.2

    • Адреса DNS-серверов: можно указать те же адреса что и для источника (смотрите /etc/resolv.conf)

Пред. | Уровень выше | След.
D.3. Установка Debian GNU/Linux из системы Unix/Linux | Начало | D.5. Установка Debian GNU/Linux с использованием PPP через Ethernet (PPPoE)


D.5. Установка Debian GNU/Linux с использованием PPP через Ethernet (PPPoE)
Пред. Приложение D. Разное След.

D.5. Установка Debian GNU/Linux с использованием PPP через Ethernet (PPPoE)

В некоторых странах PPP через Ethernet (PPPoE) является широко распространённым протоколом для широкополосных подключений (ADSL или кабельных) к провайдеру сервиса Интернет. По умолчанию программа установки не поддерживает настройку сети с использованием PPPoE, но этого можно легко добиться. В этом разделе будет описано как это сделать.

PPPoE соединение, настроенное в время установки, будет также работать и после перезагрузки в установленную систему (смотрите Глава 7, Загрузка только что установленной системы Debian).

Для настройки и использования PPPoE во время установки вам нужно выполнять установку с одного из доступных образов CD-ROM/DVD. Другие методы установки не подойдут (например, netboot).

Процесс установки через PPPoE практически не отличается от любого другого способа установки. Далее будут описаны различия.

  • Загрузите программу установки с параметром загрузки modules=ppp-udeb[32]. Это гарантирует, что компонента PPPoE (ppp-udeb) будет загружена и и запущена автоматически.

  • Далее выполните обычные начальные шаги установки (выбор языка, страны и клавиатуры; загрузка дополнительных компонент программы установки[33]).

  • На следующем этапе происходит определение сетевого аппаратного обеспечения с целью распознавания имеющихся в системе карт Ethernet.

  • После этого запускается настройка PPPoE. Программа установки попытается найти концентратор PPPoE (специальный сервер обработки подключений PPPoE) через все найденные интерфейсы Ethernet.

    Может случиться так, что концентратор не будет найден с первой попытки. Это может происходить из-за медленной или перегруженной сети или серверов. В большинстве случаев вторая попытка обнаружения концентратора будет успешной; чтобы попытаться ещё раз, выберите Настройка и установление PPPoE-соединения из главного меню программы установки.

  • После того как концентратор найден, будет предложено ввести регистрационную информацию (имя пользователя и пароль для PPPoE).

  • С этого момента программа установки будет использовать полученную информацию для установления соединения PPPoE. Если всё правильно, соединение PPPoE должно настроиться и программа установки сможет использовать его для подключения к Интернет и получения пакетов (если потребуется). Если регистрационная информация неверна или возникли какие-то ошибки, то программа установки остановится, но настройку можно попытаться повторить ещё раз выбрав в меню Настройка и установление PPPoE-соединения.

[32] О том, как добавлять загрузочные параметры, см. Раздел 5.1.7, «Экран запуска»

[33] Компонента ppp-udeb загружается на этом этапе как одна из дополнительных компонент. При выполнении установки со средним или низким приоритетом (экспертный режим), можно вручную выбрать ppp-udeb, а не вводить параметр «modules» в строке приглашения к загрузке.

Пред. | Уровень выше | След.
D.4. Установка Debian GNU/Linux через Parallel Line IP (PLIP) | Начало | D.6. Программа установки с графическим интерфейсом


D.6. Программа установки с графическим интерфейсом
Пред. Приложение D. Разное След.

D.6. Программа установки с графическим интерфейсом

Графическая версия программы установки доступна только для ограниченного числа архитектур, включая 32-bit PC. Функциональность графической версии программы установки практически та жа, что и у обычной программы установки, так как внутри используются одинаковые программы, отличия только в интерфейсе.

Хотя функциональность и одинакова, графическая версия программы установки обладает рядом значительных новшеств. Основное преимущество — поддержка большего числа языков, а именно тех, в которых нельзя отобразить все символы через обычный интерфейс «newt». Также, ей более удобно пользоваться, управляя с помощью мыши, и иногда некоторые вопросы целиком влезают на один экран.

Графическая версия программы установки доступна со всех образов CD и при установке с жёсткого диска. Для запуска графической версии просто выберите соответствующий пункт в загрузочном меню. Режимы эксперта и восстановления для графической версии выбираются в меню «Advanced options». Ранее использовавшиеся способы загрузки installgui, expertgui и rescuegui остались доступны из загрузочной командной строки, которая появляется после выбора пункта «Help» в загрузочном меню.

Доступен образ графической программы установки, загружаемый по сети. Также есть специальный «mini» ISO-образ[34], который, в основном, полезен для тестов.

Как и для обычной программы установки можно добавлять параметры загрузки при запуске её графической версии.

Замечание

Для графической версии программы установки требуется гораздо больше памяти для запуска, чем для обычной программы установки: 100MB. Если памяти недостаточно, то автоматически будет осуществлён переход на интерфейс «newt».

Если количество установленной памяти в системе меньше 56MB, то графическая программа установки может совсем не запуститься, в то время как загрузка обычной программы установки будет работать. При малом количестве памяти в системе рекомендуется использовать обычную программу установки с консольным интерфейсом.

D.6.1. Использование программы установки с графическим интерфейсом

Как уже говорилось, графическая версия программы установки работает практически также как и обычная, и поэтому это руководство можно использовать для выполнения процесса установки.

Если вы предпочитаете использовать клавиатуру вместо мыши, есть две вещи, которые необходимо знать. Чтобы раскрыть свёрнутый список (например, выбор стран и континентов), вы можете использовать клавиши + и -. Если в вопросе можно выбрать более одного значения (например, выбор задач), во-первых, вам нужно перейти на кнопку Continue после окончания выбора; нажимая enter для переключения выбора, не активировать Continue.

Если есть дополнительная справочная информация, то появляется кнопка Справка. Справочная информация доступна по нажатию кнопки или клавиши F1.

Чтобы перейти на другую консоль, вам также нужно использовать клавишy Ctrl, как и в X Window System. Например, чтобы перейти на VT2 (первая оболочка командной строки для отладки), воспользуйтесь: Ctrl+левый Alt+F2. Сама программа установки с графическим интерфейсом работает на VT5, так что вы можете использовать левый Alt+F5 для обратного переключения.

[34] Образ mini ISO можно скачать с сервера-зеркала Debian, действуя по описанию из Раздел 4.2, «Скачивание файлов с серверов-зеркал Debian». Ищите netboot/gtk/mini.iso.

Пред. | Уровень выше | След.
D.5. Установка Debian GNU/Linux с использованием PPP через Ethernet (PPPoE) | Начало | Приложение E. Общие сведения


Приложение E. Общие сведения
Пред. След.

Приложение E. Общие сведения

Содержание

E.1. Об этом документе
E.2. Как помочь в разработке этого документа
E.3. Люди, внёсшие значительный вклад в написание этого руководства
E.4. Торговые марки
Пред. |  | След.
D.6. Программа установки с графическим интерфейсом | Начало | E.1. Об этом документе


E.1. Об этом документе
Пред. Приложение E. Общие сведения След.

E.1. Об этом документе

Настоящее руководство было создано для программы debian-installer из Sarge, оно основано на руководстве по установке c использованием boot-floppies дистрибутива Woody, которое в свою очередь было основано на более ранних руководствах по установке Debian, а также на руководстве дистрибутива Progeny, выпущенном под лицензией GPL в 2003 году.

При написании этого документа использовался формат DocBook XML. Выходные форматы созданы различными программами при помощи данных из пакетов docbook-xml и docbook-xsl.

В целях повышения удобства сопровождения этого документа, мы применяем некоторые возможности XML, такие как сущности (entities) и профилирующие атрибуты (profiling attributes). Они играют роль, схожую с переменными и условиями в языках программирования. Исходный XML-текст этого документа содержит информацию обо всех архитектурах, а для изоляции архитектурно-зависимых кусочков текста использованы профилирующие атрибуты.

Пред. | Уровень выше | След.
Приложение E. Общие сведения | Начало | E.2. Как помочь в разработке этого документа


E.2. Как помочь в разработке этого документа
Пред. Приложение E. Общие сведения След.

E.2. Как помочь в разработке этого документа

При наличии проблем или предложений по этому документу, лучше всего отправить их в виде сообщения об ошибке в пакете installation-guide. Как это сделать можно прочитать в документации к пакету reportbug или на сайте системы отслеживания ошибок Debian. Также загляните в список открытых ошибок руководства по установке, не сообщил ли уже кто-то о вашей проблеме. Если такая ошибка есть, то вы можете послать дополнительную или полезную информацию на адрес <XXXX@bugs.debian.org>, где XXXX — это номер сообщённой ошибки.

Ещё лучше взять копию исходных текстов этого документа в формате DocBook XML и сделать заплатку к ним. Исходные тексты можно найти в SVN-репозитории программы установки. Если вы не сильны в DocBook, не беспокойтесь: в каталоге с руководствами есть простая шпаргалка, которая поможет вам приступить к работе. DocBook похож на HTML, но ориентирован на содержание текста, а не на его внешний вид. Заплаткам в списке рассылки debian-boot (смотрите ниже) всегда рады. О том, как получить исходные тексты через SVN, можно прочитать в файле README, который находится в корне каталога с исходными текстами.

Не связывайтесь с авторами этого документа напрямую — для обсуждения в том числе и этого руководства существует список рассылки debian-installer, который доступен по адресу <debian-boot@lists.debian.org>. На странице подписки на списки рассылки Debian описано, как на него можно подписаться. Также доступны архивы этого и других списков.

Пред. | Уровень выше | След.
E.1. Об этом документе | Начало | E.3. Люди, внёсшие значительный вклад в написание этого руководства


E.3. Люди, внёсшие значительный вклад в написание этого руководства
Пред. Приложение E. Общие сведения След.

E.3. Люди, внёсшие значительный вклад в написание этого руководства

Первоначально, этот документ был написан Брюсом Перенсом (Bruce Perens), Свеном Рудольфом (Sven Rudolph), Игорем Гробманом (Igor Grobman), Джеймсом Триси (James Treacy) и Адамом Ди Карло (Adam Di Carlo). Себастьян Лей (Sebastian) написал "Краткое руководство по установке".

Мирослав Куре (Miroslav Kuře) описал много новых возможностей в в debian-installer из Sarge. Франц Поп (Frans Pop) был главным редактором и ответственным за выпуск в дистрибутивах Etch, Lenny и Squeeze.

Очень многие пользователи и разработчики Debian внесли свой вклад в этот документ. Особо нужно отметить Михаэля Шмитца (Michael Schmitz) (поддержка m68k), Франка Нойманна (Frank Neumann) (первый автор руководства по установке на Amiga), Арто Астала (Arto Astala), Эрика Делонея (Eric Delaunay), Бена Коллинза (Ben Collins) (все трое — информация по SPARC), Тапио Лейтонена (Tapio Lehtonen) и Стефана Бортцмайера (Stéphane Bortzmeyer) за тексты и многочисленные правки. Мы благодарим Паскаля ЛеБеля (Pascal Le Bail) за полезную информацию о загрузке с USB-карт памяти.

Множество полезной информации можно найти в HOWTO по сетевой загрузке под авторством Джима Минта (Jim Mintha) (URL на данный момент недоступен), Debian FAQ, Linux/m68k FAQ, FAQ по Linux для процессоров SPARC, Linux/Alpha FAQ и в других документах. Мы хотим поблагодарить сопровождающих этих свободно доступных и полезных источников информации.

При создании раздела о chroot установке (Раздел D.3, «Установка Debian GNU/Linux из системы Unix/Linux») были использованы материалы, написанные Карстеном М. Селфом (Karsten M. Self).

При создании раздела об установке через plip соединение (Раздел D.4, «Установка Debian GNU/Linux через Parallel Line IP (PLIP)») было использовано PLIP-Install-HOWTO, написанное Гилесом Ламиралем (Gilles Lamiral).

Пред. | Уровень выше | След.
E.2. Как помочь в разработке этого документа | Начало | E.4. Торговые марки


E.4. Торговые марки
Пред. Приложение E. Общие сведения След.

E.4. Торговые марки

Все торговые марки являются собственностью их владельцев.

Пред. | Уровень выше | След.
E.3. Люди, внёсшие значительный вклад в написание этого руководства | Начало | Приложение F. GNU General Public License


Приложение F. GNU General Public License
Пред.

Приложение F. GNU General Public License

Version 2, June 1991

Copyright (C) 1989, 1991 Free Software Foundation, Inc.
51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.

Everyone is permitted to copy and distribute verbatim copies
of this license document, but changing it is not allowed.

F.1. Preamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the gnu General Public License is intended to guarantee your freedom to share and change free software — to make sure the software is free for all its users. This General Public License applies to most of the Free Software Foundation's software and to any other program whose authors commit to using it. (Some other Free Software Foundation software is covered by the gnu Library General Public License instead.) You can apply it to your programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed to make sure that you have the freedom to distribute copies of free software (and charge for this service if you wish), that you receive source code or can get it if you want it, that you can change the software or use pieces of it in new free programs; and that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you to surrender the rights. These restrictions translate to certain responsibilities for you if you distribute copies of the software, or if you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must give the recipients all the rights that you have. You must make sure that they, too, receive or can get the source code. And you must show them these terms so they know their rights.

We protect your rights with two steps: (1) copyright the software, and (2) offer you this license which gives you legal permission to copy, distribute and/or modify the software.

Also, for each author's protection and ours, we want to make certain that everyone understands that there is no warranty for this free software. If the software is modified by someone else and passed on, we want its recipients to know that what they have is not the original, so that any problems introduced by others will not reflect on the original authors' reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the danger that redistributors of a free program will individually obtain patent licenses, in effect making the program proprietary. To prevent this, we have made it clear that any patent must be licensed for everyone's free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.

F.2. GNU GENERAL PUBLIC LICENSE

TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0. This License applies to any program or other work which contains a notice placed by the copyright holder saying it may be distributed under the terms of this General Public License. The "Program", below, refers to any such program or work, and a "work based on the Program" means either the Program or any derivative work under copyright law: that is to say, a work containing the Program or a portion of it, either verbatim or with modifications and/or translated into another language. (Hereinafter, translation is included without limitation in the term "modification".) Each licensee is addressed as "you".

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of running the Program is not restricted, and the output from the Program is covered only if its contents constitute a work based on the Program (independent of having been made by running the Program). Whether that is true depends on what the Program does.

1. You may copy and distribute verbatim copies of the Program's source code as you receive it, in any medium, provided that you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this License and to the absence of any warranty; and give any other recipients of the Program a copy of this License along with the Program.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Program or any portion of it, thus forming a work based on the Program, and copy and distribute such modifications or work under the terms of Section 1 above, provided that you also meet all of these conditions:

  1. You must cause the modified files to carry prominent notices stating that you changed the files and the date of any change.

  2. You must cause any work that you distribute or publish, that in whole or in part contains or is derived from the Program or any part thereof, to be licensed as a whole at no charge to all third parties under the terms of this License.

  3. If the modified program normally reads commands interactively when run, you must cause it, when started running for such interactive use in the most ordinary way, to print or display an announcement including an appropriate copyright notice and a notice that there is no warranty (or else, saying that you provide a warranty) and that users may redistribute the program under these conditions, and telling the user how to view a copy of this License. (Exception: if the Program itself is interactive but does not normally print such an announcement, your work based on the Program is not required to print an announcement.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from the Program, and can be reasonably considered independent and separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute them as separate works. But when you distribute the same sections as part of a whole which is a work based on the Program, the distribution of the whole must be on the terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to exercise the right to control the distribution of derivative or collective works based on the Program.

In addition, mere aggregation of another work not based on the Program with the Program (or with a work based on the Program) on a volume of a storage or distribution medium does not bring the other work under the scope of this License.

3. You may copy and distribute the Program (or a work based on it, under Section 2) in object code or executable form under the terms of Sections 1 and 2 above provided that you also do one of the following:

  1. Accompany it with the complete corresponding machine-readable source code, which must be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,

  2. Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more than your cost of physically performing source distribution, a complete machine-readable copy of the corresponding source code, to be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,

  3. Accompany it with the information you received as to the offer to distribute corresponding source code. (This alternative is allowed only for noncommercial distribution and only if you received the program in object code or executable form with such an offer, in accord with Subsection b above.)

The source code for a work means the preferred form of the work for making modifications to it. For an executable work, complete source code means all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control compilation and installation of the executable. However, as a special exception, the source code distributed need not include anything that is normally distributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs, unless that component itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy from a designated place, then offering equivalent access to copy the source code from the same place counts as distribution of the source code, even though third parties are not compelled to copy the source along with the object code.

4. You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this License. Any attempt otherwise to copy, modify, sublicense or distribute the Program is void, and will automatically terminate your rights under this License. However, parties who have received copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

5. You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or distribute the Program or its derivative works. These actions are prohibited by law if you do not accept this License. Therefore, by modifying or distributing the Program (or any work based on the Program), you indicate your acceptance of this License to do so, and all its terms and conditions for copying, distributing or modifying the Program or works based on it.

6. Each time you redistribute the Program (or any work based on the Program), the recipient automatically receives a license from the original licensor to copy, distribute or modify the Program subject to these terms and conditions. You may not impose any further restrictions on the recipients' exercise of the rights granted herein. You are not responsible for enforcing compliance by third parties to this License.

7. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this License, they do not excuse you from the conditions of this License. If you cannot distribute so as to satisfy simultaneously your obligations under this License and any other pertinent obligations, then as a consequence you may not distribute the Program at all. For example, if a patent license would not permit royalty-free redistribution of the Program by all those who receive copies directly or indirectly through you, then the only way you could satisfy both it and this License would be to refrain entirely from distribution of the Program.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is intended to apply and the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity of any such claims; this section has the sole purpose of protecting the integrity of the free software distribution system, which is implemented by public license practices. Many people have made generous contributions to the wide range of software distributed through that system in reliance on consistent application of that system; it is up to the author/donor to decide if he or she is willing to distribute software through any other system and a licensee cannot impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

8. If the distribution and/or use of the Program is restricted in certain countries either by patents or by copyrighted interfaces, the original copyright holder who places the Program under this License may add an explicit geographical distribution limitation excluding those countries, so that distribution is permitted only in or among countries not thus excluded. In such case, this License incorporates the limitation as if written in the body of this License.

9. The Free Software Foundation may publish revised and/or new versions of the General Public License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns. Each version is given a distinguishing version number. If the Program specifies a version number of this License which applies to it and "any later version", you have the option of following the terms and conditions either of that version or of any later version published by the Free Software Foundation. If the Program does not specify a version number of this License, you may choose any version ever published by the Free Software Foundation.

10. If you wish to incorporate parts of the Program into other free programs whose distribution conditions are different, write to the author to ask for permission. For software which is copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals of preserving the free status of all derivatives of our free software and of promoting the sharing and reuse of software generally.

NO WARRANTY

11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL AND COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS

F.3. How to Apply These Terms to Your New Programs

If you develop a new program, and you want it to be of the greatest possible use to the public, the best way to achieve this is to make it free software which everyone can redistribute and change under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the start of each source file to most effectively convey the exclusion of warranty; and each file should have at least the "copyright" line and a pointer to where the full notice is found.

one line to give the program's name and a brief idea of what it does.
Copyright (C) year  name of author

This program is free software; you can redistribute it and/or
modify it under the terms of the GNU General Public License
as published by the Free Software Foundation; either version 2
of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program; if not, write to the Free Software
Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA  02110-1301, USA.

Also add information on how to contact you by electronic and paper mail.

If the program is interactive, make it output a short notice like this when it starts in an interactive mode:

Gnomovision version 69, Copyright (C) year name of author
Gnomovision comes with absolutely no warranty; for details
type `show w'. This is free software, and you are welcome
to redistribute it under certain conditions; type `show c'
for details.

The hypothetical commands `show w' and `show c' should show the appropriate parts of the General Public License. Of course, the commands you use may be called something other than `show w' and `show c'; they could even be mouse-clicks or menu items — whatever suits your program.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a "copyright disclaimer" for the program, if necessary. Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright interest in the
program `Gnomovision' (which makes passes at compilers) written
by James Hacker.

signature of Ty Coon, 1 April 1989
Ty Coon, President of Vice

This General Public License does not permit incorporating your program into proprietary programs. If your program is a subroutine library, you may consider it more useful to permit linking proprietary applications with the library. If this is what you want to do, use the GNU Lesser General Public License instead of this License.

Пред. |
E.4. Торговые марки | Начало