WinXPFAQ -> Вступление

Вступление

Автор: Алексей Шашков
Последнее дополнение: от 06/06/2002
Версия: 3.0

Это третья версия WinXP FAQ CHM Edition.
XP вобрала в себя многое из W2k, поэтому нет ничего удивительного в том, что читатели нашего W2k FAQ найдут для себя много знакомого и в этом документе. Тем не менее, это два абсолютно самостоятельных труда, которые будут развиваться параллельно. Как обычно, мы рассчитываем на Вашу помощь и на Ваш опыт, в наших усилиях сделать этот FAQ лучше.
В заключение хотелось бы выразить глубокую признательность Владимиру Суворову, Роману Клину, Александру Шейко, Тарасу Сороке, и всем авторам fido7.ru.windows.f2000 FAQ, с последней версией которого можно ознакомиться на http://www.chem.univ.kiev.ua/~adsh/win2k/, материалы из которого входят в наш XP FAQ.

Вы столкнулись с интересной проблемой и успешно её разрешили? Поделитесь с нами! Возможно, это поможет ещё кому нибудь.

Файл справки *.chm создан Hawk-EYE'ем на основании статьи WinXP FAQ с сайта http://www.3dnews.ru/.


WinXPFAQ -> Вопросы

Общая информация

  1. Что такое WIndowsXP?
  2. Какой build финальный? Как точно узнать версию XP? Как отличить пиратский релиз от настоящего?
  3. Что такое Windows Product Activation, и зачем он нужен? updated
  4. Какие виды поставки XP бывают? updated
  5. Какой компьютер необходимо иметь для нормальной работы XP?
  6. Как насчёт совместимости со старым программным обеспечением?
  7. А что знаменитый DLL-hell? updated
  8. Что такое Dynamic Disk?
  9. Что такое Task Manager?
  10. Что нового появилось в интерфейсе XP по сравнению с предыдущими ОС от Microsoft?
  11. Как настроить Taskbar и Start Menu?
  12. Как управлять пользователями, которым можно заходить на компьютер? updated
  13. Как залогиниться администратором? updated
  14. Существуют ли аналоги autoexec.bat и config.sys под XP?
  15. Чем различаются Windows XP Professional и Windows XP Home? updated

  16. Как посмотреть Up Time (время работы с последней перезагрузки)? new

  17. Что случилось с regedit32.exe? new

  18. Как создавать и редактировать темы для XP? new

Инсталляция

  1. Как поставить XP?
  2. Как выбрать нужную версию ядра и HAL ещё при инсталляции?
  3. При инсталляции система не даёт выбрать компоненты, да и после инсталляции в Add/Remove programs - Windows Components почти ничего нет.
  4. Стоит ли переходить с FAT32 на NTFS?
  5. Что вообще такое NTFS, и как она работает?
  6. Что нового в файловой системе NTFS5, и в чем её отличия от NTFS4?
  7. Что такое кластер, и какого размера он должен быть?
  8. Как уменьшить занимаемый объем пpоинсталиpованной XP? updated
  9. Можно ли отконвеpтировать диск FAT32 в NTFS без потеpи данных?
  10. Как полностью выключить SFC (System Files Protection)?
  11. Какие параметры можно менять в boot.ini?
  12. Как мне поставить Win9x при уже установленном XP? updated
  13. Как изменить букву системного/загрузочного диска в XP?
  14. Как переименовать папку аккаунта Администратор?
  15. Как сделать загрузочные флоппу диски для XP?
  16. Как удалить XP с диска без потери данных? Hадо вернуться на Win9x.
  17. После изменения прав доступа к файлам (security permissions) на NTFS хочется вернуть все к тому виду, как было после установки. Возможно ли это?

Твики

  1. При запуске Windows Explorer открывается папка My Documents. Как сделать так, что бы открывался корневой каталог системного диска?
  2. Когда открывается директория с большим количеством файлов, находящаяся на NTFS-разделе, например, WINNT, то это делается слишком долго. Можно ускорить этот процесс?
  3. Как ускорить работу интерфейса XP?

  4. Как отключить Dr. Watson, встроенный дебагер? new

  5. Какие службы можно отключить, для ускорения работы системы? new

  6. Как отключить автозапуск у привода компакт-дисков? updated
  7. По какому принципу XP присваивает буквы дискам?
  8. Как сделать, чтобы пpи остановке/запyске стиpался/создавался новый файл подкачки pagefile.sys?
  9. Как задать пpиоpитет процесса еще пpи его запyске? Чтоб не лазить постоянно для этого в task manager?
  10. XP при загрузке проверяет на ошибки все дисковые разделы, даже если на них установлены другие ОС. Как это отключить?
  11. Как ускорить работу с памятью? updated
  12. У меня пусто в "Автозапуске", но некоторые программы продолжают стартовать при входе в Windows
  13. Можно ли ввести машину в состояние hibernate, или выключить из командной строки? updated
  14. Правда ли что XP всегда загружает определённый набор DLL, даже если они не используются?
  15. Как сделать что бы задачи которые повисли и перестали отвечать убивались автоматически?
  16. Как добавить содержимое рабочего стола в меню Start?
  17. Как мне залочить мой компьютер? Crtl+Alt+Del не помогают.
  18. При открытии папки с рисунками, рисунки рисуются как картинки. В первый раз тормозит, потом работает быстро. Где это всё кешируется? И как это отключить?
  19. Куда пропала закладка Security на томах NTFS, и что случилось с закладкой Sharing? updated
  20. Как включить кодирование Mp3 с высоким битрейтом? updated
  21. Как убрать папку Shared Documents из My Computer?
  22. Как мне изменить time-server, используемый XP?
  23. Что такое boot defrag, и что с ним делать?
  24. Как добавить и отредактировать сообщение, которое будет выводить при старте компьютера?
  25. Как отключить сообщение о том что недостаточно свободного места на диске?
  26. Как создать загрузочный CD-ROM с Windows XP?

  27. Компьютер выключается очень долго. Как это ускорить? new

Восстановление

  1. Система не загружается, что делать?
  2. Как восстановить повреждённый загрузчик XP?
  3. Пропали куда-то системные шрифты под XP, или вообще, система начала вести себя как то странно, перестали работать некоторые программы, появились глюки, которых раньше точно не было. Как это можно исправить?
  4. Как поменять ядро системы?
  5. Как в Recovery Console получить доступ в папки, отличные от \WINNT?
  6. Можно ли восстановить информацию из зашифрованного средствами XP файла? updated

Шрифты

  1. Вместо русских букв в некоторых программах показываются закорючки.
  2. В DOS-приложениях не переключается раскладка клавиатуры на русскую, хотя русские буквы отображаются нормально.
  3. Региональные настройки настроил, но всё равно, в некоторых местах (например в Photoshop) показываются закорючки. updated
  4. Как включить antialiasing шрифтов в XP?

Железо

  1. Где мне найти драйвер для моей железки?
  2. Машина с ATX блоком питания не выключает питание самостоятельно. updated
  3. Как получить поддержку функций управления питанием на SMP машинах? updated
  4. При работе полноэкранных Direct3D и OpenGL приложений, очень низкий refresh rate, как можно это исправить?
  5. Ничего не получается с hackmon.inf, чего делать?
  6. Как поменять IRQ используемые различными устройствами? В их Properties в Device manager чекбокс Use automatic Settings затемнён, и снять его не удаётся.
  7. На моём CD-ROM нет CD-CPDIF выхода, или, по какой то причине я не могу его использовать. Можно ли мне как-нибудь получить числовой звук для CD-Audio?
  8. Мой 12х CD Recorder записывает диск за 15 минут, а должен за 6. А везде пишется, что запись прошла на скорости 12x, почему так происходит и что делать? updated
  9. В Stand by режиме не выключаются вентиляторы на блоке питания и процессоре.
  10. После перезагрузки XP не находит внешний модем. Что делать? updated
  11. Как заменить материнскую плату без переустановки системы?

  12. CD-ROM постоянно сбрасывается в PIO режим, и не хочет выставляться обратно в UDMA. new

  13. Как установить старую, не PnP но NЕ2000 совместимую сетевую карту? new

Проблемы

  1. Что то не работает, как найти причину?
  2. Help в XP какой то сильно упрощенный и урезанный. Неужели ничего толковее не могли написать?
  3. Почему некоторые программы не инсталлируются в XP? Запускается инсталлятор, появляется окно, в нём закрашивается индикатор до 100%, но потом всё пропадает. Процесс висит в памяти, но инсталляция не продолжается. updated
  4. Под XP не хотят работать некоторые программы, требующие интенсивного обращения к CD приводу, такие как Audiograbber, CDEx, программы для записи CD-RW, некоторые DVD декодеры, и т.д...
  5. Моя любимая программа работает только под аккаунтом администратора :( Как сделать, чтобы она работала и под аккаунтом обычного пользователя? updated
  6. Как запустить Fine Reader 5.0 под XP?

  7. Как назначить конкретные права доступа к файлам и папкам в XP Home? Simple File Sharing не выключается. new

  8. Как справится с тормозами при работе антивируса Касперского? new

  9. Компьютер перезагружается непонятно почему new

  10. Как изменить загрузочную картинку WindowsXP? new

  11. При загрузке имя и пароль по умолчанию вводятся русскими буквами. Как это изменить? new

  12. Как сделать что бы при загрузке всегда включался NumLock? new

  13. Как убить процесс из командной строки? new

  14. Как отучить XP работать с ZIP файлами как с папками? new

  15. Как убрать надоедливые сообщения, которые иногда вылазят в notification area? new

  16. Надоело стирать Temporary Internet Files каждый раз вручную. Можно автоматизировать этот процесс? new

  17. Как узнать что означает та или иная ошибка в Event Viewer? new

  18. Как поменять расположение папок My Documents, My Music? new

  19. Как мне удалить файл hiberfil.sys? new

  20. Как отключить Automatic Update? new

  21. Как обезопасить себя от утери пароля для входа в систему? new

Сеть

  1. Как обеспечить доступ к моим ресурсам другим пользователям сети?
  2. Что такое Remote Desktop и как с ним работать?
  3. Правда ли что у XP возникают проблемы с сетью при установленном AVP? updated

  4. Как ускорить открытие сетевых машин с W9x из XP? new

  5. Как убрать окно с сообщение об ошибке, выскакивающее при неудачном дозвоне? new

  6. Как полностью отключить службу QoS (Quality of Service). Как её настроить? Правда ли что она ограничивает скорость сети? new

  7. Как настроить сервер удалённого доступа под ХР? new

  8. Как настроить aDSL соединение? new

  9. Как настроить Internet Connection Sharing? new

  10. Как использовать несколько настроек TCP/IP для одной сетевой карты? new

  11. Как спрятать имя пользователя из Welcome Screen? new

  12. Как запретить пользователю логинится локально? new

  13. Как запретить пользователю логинится по сети? new

  14. Как настроить IPv6 под ХР? new

Copyright (c) 1997-2002 3DNews
При цитировании документа ссылка на сайт с указанием автора обязательна. Полное заимствование документа является нарушением российского и международного законодательства и возможно только с согласия редакции 3DNews.


WinXPFAQ -> Общая информация

Общая информация
(1) Что такое WindowsXP?
Это новая OC от Microsoft, начиная с которой сделана попытка объединить две, ранее существовавшие независимо, линейки W9x и NT. Первоначально этот проект назывался Whisler, но сейчас он разделился на две линии, WindowsXP, позиционирующуюся на замену W9x и W2kPro, и Windows.NET, позиционирующуюся на замену NT Server всех сортов. Вне зависимости от названия, все они является прямыми наследниками Windows2000, и продолжателями линейки WindowsNT. Этот факт и определяет основные особенности WindowsXP. Это полностью 32 разрядная ОС с приоритетной многозадачностью. В её основе лежат те же принципы, на которых базировались все NT. Это

1. Совместимость (Compatibility). Система может иметь привычный интерфейс ОС семейства Windows, с некоторыми добавлениями и расширениями, поддержку файловых систем NTFS5, NTFS4, FAT16 и FAT32. Большинство приложений, написанных под MSDOS, W9x, NT4, а также некоторые программы под OS/2 и POSIX запускаются и функционируют без проблем. При проектировании NT учитывалась возможность работы системы в различных сетевых средах, поэтому в поставку входят средства для работы в Unix- и Novell-сетях.

2. Переносимость (Portability). Система работает на различных процессорах семейства x86 производства Intel и AMD. Уже существует 64 битная версия WindowsXP и Windows.NET, предназначенная для работы на Intel Itanium. Реализация поддержки процессоров других архитектур возможна, но потребует некоторых усилий.

3. Масштабируемость (Scalability). В WindowsXP реализована поддержка технологии SMP. В Windows.NET Advanced Server и Datacenter Server кроме этого есть поддержка COW (Cluster Of Workstations).

4. Система безопасности (Security). Реализована привычная для NT система безопасности на уровне пользователей.

5. Распределённая обработка (Distributed processing). WindowsXP имеет встроенные в систему сетевые возможности, что обеспечивает возможность связи с различными типами компьютеров-хостов благодаря наличию разнообразных транспортных протоколов и технологии "клиент-сервер".

6. Надёжность и отказоустойчивость (Reliability and robustness). Архитектура ОС защищает приложения от повреждения друг другом и самой операционной системой. При этом используется отказоустойчивая структурированная обработка особых ситуаций на всех архитектурных уровнях, которая включает восстанавливаемую файловую систему NTFS и обеспечивает защиту с помощью встроенной системы безопасности и усовершенствованных методов управления памятью.

7. Локализация (Localization). Система предоставляет возможности для работы во многих странах мира на национальных языках, что достигается применением стандарта ISO Unicode.

8. Расширяемость (Extensibility). Благодаря модульному построению системы становится возможно добавление новых модулей на различные архитектурные уровни ОС.

(2) Какой build финальный? Как точно узнать версию XP? Как отличить пиратский релиз от настоящего?
Финальный билд - 2600. Узнать его можно либо командой winver, либо по версии ядра ХР, например файла ntoskrnl.exe. Отличить пиратский релиз от настоящего, стало ещё проще, чем в каком-либо другом Windows. Это стало возможно благодаря механизму активации (Windows Product activation) востренным в систему. В пиратском релизе должны быть включены средства борьбы с ней, поэтому если Вы увидите папку с названием crack, или чем то вроде этого, то можете быть уверенны, что релиз пиратский. Если на Вашем диске нет ничего подобного, а сам диск имеет все признаки нелегального (нет голограммы, лицензионного соглашения на бумаге, нет наклейки, которая меняет цвет если нагреть её пальцем), то Вы рискуете тем, что Ваша версия перестанет работать в течении месяца. Впрочем, есть и «ломаные» пиратские релизы, которые не требуют регистрации вообще. Кроме этого, существуют так называемые корпоративные релизы, сделанные Microsoft для своих крупнейших OEM партнёров. Такие релизы не требуют регистрации изначально.
(3) Что такое Windows Product Activation, и зачем он нужен?
Это новая технология, разработанная Microsoft для борьбы с нелегальными копиями их программного обеспечения. Впервые подобный механизм был опробован на Terminal Service, из W2k Server, теперь же, похоже, подобным образом будут защищаться многие последующие продукты Microsoft. Суть технологии состоит в следующем: после инсталляции системы на основе серийного номера, который даётся с каждой копией XP, и некоторых особенностей вашего компьютера, генерится так называемый Product ID. Он состоит из 20 цифр, и на его основе (вместе с правильным серийным номером, конечно же) вы получаете Activation Code, после введения которого Windows считается активированным. Как утверждает Microsoft, на основе этих двух номеров они не могут узнать ничего про ваш компьютер. То есть, полная анонимность. Если не проделать такой процедуры, то через 30 дней в XP просто перестанет функционировать всё, кроме апплета отвечающего за активацию. Проводить активацию на одном и том же компьютере можно сколько угодно. Product ID на одной и той железке всегда будет одинаковый, поэтому вы безбоязненно можете переставлять систему столько раз сколько захотите, Activation Code который вы получили один раз, будет подходить всегда. Вне зависимости от того, какой из способов активирования вы использовали. Узнать, активирована ли ваша версия XP, можно в окне System Summary, находящегося в меню Programs -> Accessories -> System tools -> System Information. Если увидите строку Activation Status и напротив неё надпись вроде Activation Pending (XX days remaining), значит через XX дней ваша XP перестанет работать. Апплет, который отвечает за активацию XP, находится в меню Programs -> Accessories -> System Tools -> Activate Windows. При запуске этого апплета откроется простой визард, который предложит зарегистрировать свою копию XP через интернет, либо по телефону. После того как система будет активирована (любым способом), строка Activation Pending из System Information пропадёт без следа.
(4) Какие виды поставки XP бывают?
Первоначально будет выпущено две версии - Windows XP Home Edition и Windows XP Professional. Кроме этого, существует 64-битная версия Windows XP Professional, сделанная для 64- битного Intel Itanium. Позже будут выпущены Widows.NET Server, Windows.NET Advanced Server и Windows.NET Datacenter Server (x86 и 64 bit edition для каждого). XP Home позиционируется как ОС на смену линейки W9x (хотя не имеет с ней ничего общего), XP Professional как смена для Windows2000 Professional. Из существенных отличий между ними можно отметить только отсутствие поддержки SMP в XP Home. Но, несмотря на это, даже XP Home построена на ядре и по идеологии NT, поэтому с 25 октября 2001 года (дата официального выхода XP) можно говорить о давно обещанной официальной смерти линейки W9x, и идеологии MS-DOS вместе с ней. Windows.NET отличается от XP наличием системных служб и приложений, свойственных серверу, и поддержкой более мощного железа. Так, если XP Pro поддерживает SMP только на два процессора, то NET Server уже на 4, NET Advanced Server на 8, а NET Datacenter Server на 32.
(5) Какой компьютер необходимо иметь для нормальной работы XP?
Microsoft утверждает, что для успешной инсталляции XP Вам необходим процессор не менее 233 мегагерц, 64 мегабайта оперативной памяти, и 1.5 гигабайта свободного места на диске. Однако, для более-менее комфортной работы Вам понадобится процессор не менее 500 мегагерц, и не менее 128 мегабайт оперативной памяти. Хотя, максимально облегчив интерфейс можно добиться того, что XP будет требовать меньше памяти чем W2k, поэтому если пожертвовать всякими "примочками", и визуальными эффектами, то вполне комфортно можно будет работать и на менее мощных системах. Вообще, если на Вашей машине работает W2k, то будет работать и XP, ничуть не хуже, если не лучше. Как и любая ОС на ядре NT, XP очень любит лишнюю оперативную память, поэтому 512 мегабайт для такой системы совсем не будут лишними, хотя и не являются обязательными. На 256 Mb система работает очень быстро и очень приятно, если не грузить её очень тяжёлыми приложениями. Если включить все визуальные эффекты, то XP будет заметно притормаживать на относительно слабых процессорах, вне зависимости от объёма оперативной памяти. Такой же эффект наблюдается при использовании слабой видеокарты. Однако, если система достаточно мощная, то нормально настроенный XP будет работать гораздо быстрее, чем любая ОС от Microsoft выпущенная ранее.
(6) Как насчёт совместимости со старым программным обеспечением?
Как и в W2k, ядро NT накладывает свои ограничения, поэтому нельзя ожидать от XP абсолютно полной совместимости со старым программных обеспечением. Однако, по сравнению с w2k ситуация с совместимостью несколько улучшилась. Из наиболее заметных изменений можно отметить появившийся звук в старых ДОСовских играх, что было весьма сложно добиться в W2k. Поддерживается эмуляция Sound Blaster 2 и General MIDI, так что теперь можно без беганий с бубном и сторонних утилит заставить работать со звуком такие старые хиты как Worms, Duke Nukem 3D, Warcraft 1 и 2, Dune 2. Кроме этого, в XP встроен режим совместимости со старыми ОС. Для того что бы его задействовать, необходимо выбрать закладку Compatibility из Properties файла или ярлыка (shortcut) на файл. В этой закладке можно указать под видом какой ОС требуется запускать программу, надо ли менять разрешение или глубину цвета при этом (необходимо для многих старых программ).

В отличии от acompat.exe из дистрибутива W2k, XP в режиме совместимости не просто рапортует программе, что она это не она (по типу старой утилитки из MS-DOS, под названием setver), но и эмулирует структуру реестра Windows, свойственную той или иной версии ОС. Если нет желания лазать по свойствам файлов и ярлыком самостоятельно, можно воспользоваться Program Compatibility Wizard, из кнопки Start - Programs - Accessories. Впрочем, не стоит ожидать от этого механизма чуда, 100% совместимости добиться так и не удалось, поэтому не будет лишним сходить на сайт производителя Вашей программы и посмотреть, не появился ли там апдейт на неё делающей её совместимой с XP. Как насчёт совместимости со старым программным обеспечением? Как и в W2k, ядро NT накладывает свои ограничения, поэтому нельзя ожидать от XP абсолютно полной совместимости со старым программных обеспечением.
(7) А что знаменитый DLL-hell?
Этой проблеме было уделено самое пристальное внимание. Причём, к этому вопросу подошли более комплексно, чем когда-либо до этого. Во первых, никому не дадут просто так перезаписать какой либо DLL в системной директории. Кроме этого, остался знакомый нам по W2k механизм SFC, System File Protection. Эта система мониторит основные системные файлы, и в случае замены какого-либо из них, меняет всё обратно. Кроме этого, в Microsoft почему то позаботились об криворуких программистах, которые не могут писать нормально, и им обязательно надо что бы их творение работало с собственными DLL, подменяющими системные. При инсталляции такой программы, эти переделанные DLL всё-таки будут записываться на диск, но не вместо системных. Потом, при запуске такой программы, в случае вызова DLL должен вызываться не системный файл, а заранее сохранённый файл именно от этой программы. Хранятся эти DLL в подкаталоге WinSxS, что означает Windows Side by Side (бок о бок), что весьма символично.
(8) Что такое Dynamic Disk?
Это физический диск, на котором могут быть созданы динамические разделы. Такой диск может быть доступен только из W2k или XP.Динамические разделы могут быть следующих видов:

1. Простые (simple). Простые разделы практически ни чем не отличаются от тех, к которым мы привыкли.
2. Составные (spanned). Состоят из нескольких динамических дисков, которые представлены как один диск. Данные пишутся и читаются последовательно.
3. Чередующиеся (stripped). Несколько динамических дисков, которые представлены как один диск. Данные пишутся и читаются одновременно на несколько дисков. Это, теоретически, должно обеспечивать вдвое большую скорость на дисковых операциях. На практике, прирост хотя и значительный, но меньше, чем в два раза. Мы бы рекомендовали использовать этот режим только в том случае, если уже имеются два диска. В противном случае, гораздо выгоднее купить один винчестер, вдвое большего объёма, с отличными скоростными характеристиками, чем два маленьких и более медленных, в расчёте на то, что они будут много быстрее. Конечно, если взять два быстрых диска и объединить их в Stripped Volume, то они будут быстрее, чем один. Однако системный раздел не может быть Stripped Volume. В этом случае разумнее приобрести аппаратный IDE-RAID контролёр который обеспечивает возможность работы с RAID даже из под ДОС; таким образом можно сделать системный раздел чередующимся.
4. Зеркальные (mirrored). Эти разделы состоят из двух физических дисков. Данные записываемые на один из дисков автоматически дублируются на другом. Это не даёт никаких преимуществ в плане скорости, но зато обеспечивает вдвое большую степень надёжности сохранности данных.
5. RAID5. Состоит из трёх, или более дисков. Представляет из себя stripped volume с контролём ошибок. То есть, данные пишутся на два диска, в два блока, а на третий диск, и в третий блок записывается ECC, код коррекции ошибок, с помощью которого, по информации любого из блоков можно восстановить содержимое второго блока. Причём код ECC записывается попеременно, на каждый из входящих в массив дисков. Эта технология позволяет более экономно использовать дисковое пространство, чем mirrored volumes, но, работает медленнее. Любой из этих разделов может быть отформатирован как под FAT32, так и под NTFS. Управление Dynamic disk осуществляется через раздел Disk Management окна Computer Management.

Примечание: Все эти разделы, кроме simple можно создавать только на динамических дисках.

Обычный диск может быть конвертирован в динамический, из окна Disk Management, однако обратный процесс (конвертировать динамический диск в простой) не всегда возможен. Например, если диск с самого начала создавался как динамический, то на нём отсутствует привычная таблица разделов, и что бы создать её, его придётся заново разбивать с помощью fdisk и форматировать.
Кроме этого, если удалить на динамическом диске несколько партиций, то свободное место не объединяется и новая партиция, равная по размеру удаленным, будет состоят из нескольких мелких партиций объединненных в volume set под одной буквой.

(9) Что такое Task Manager?
Task Manager - это один из самых мощных и удобных инструментов в NT, предназначенных для управления процессами. Вызывается он либо Ctrl+Shift+Esc, либо выбором в меню, появляющимся после нажатия правой кнопкой на Taskbar-е. Task manager в XP состоит из пяти закладок - Applications, Processes, Performance, Networking и Users. Начнём с Performance.

На этой закладке показывается информация о загрузке процессора(ов) в реальном времени (зелёным цветом процессы пользователя, красным системные процессы), показывается загрузка физической памяти, причём показано сколько занято/свободно оперативной памяти, и сколько занято системного Swap-а. Кроме этого даётся другая дополнительная информация, например Threads и Processes, - количество нитей и процессов, исполняемых сейчас на машине, Peak - пиковый размер Swap-а в течении сессии, Nonpaged - количество памяти, отведённое под ядро. Эта информация может использоваться, когда надо будет ответить на вопрос, какой фактор в системе является "бутылочным горлышком", замедляющим работу (хотя для этих целей лучше использовать Performance Monitor).

Вторая закладка, Processes, содержит список процессов, активных в данный момент.

Для каждого процесса можно узнать некоторую дополнительную информацию, как то: PID (Process ID), количество используемой оперативной памяти, количество нитей, сгенерированных процессом и многое другое. Из полезных дополнений, которые появились в XP, следует отметить появившейся столбик User Name. В нём можно узнать, какой пользователь, или системная служба запустила тот или иной процесс. Добавить/удалить показываемые параметры можно через View -> Select Columns.

Кроме этого, с любым из этих процессов можно произвести определённые действия. Для этого надо просто нажать на нём правой кнопкой мыши, появится контекстное меню, через которое можно закончить, "убить" процесс (End Process), можно убить сам процесс, и все остальные, которые он "породил" (End Process Tree). Можно выставить приоритет процессу, от высшего Real-Time до самого низкого, Low. Если на машине установлено два процессора и многопроцессорное ядро, то в этом меню появляется ещё один пункт, Set Affinity, который позволяет перевести процесс на другой процессор, Cpu 0, Cpu1, и так далее до Cpu31.

Закладка - Applications, позволяет просмотреть список работающих приложений, и "убить" любое из них. Task Manager позволяет не только "убивать" приложения, он может также запускать новые приложения. File -> New task (Run..). Иногда это бывает очень полезно. Например, если по какой либо причине зависнет интерфейс пользователя, то его можно с лёгкостью "убить" (процесс explorer.exe), а после стартовать заново. Причём, это не обязательно должен быть explorer.exe. Можно, к примеру, запустить progman.exe, и получить интерфейс подобный интерфейсу W3.1, или же любой из внешних интерфейсов, которые в изобилии можно найти на просторах Интернета.

Закладка Networking. Эта одна из закладок которая появилась в Task Manager только в XP. На ней показывается загрузка локальной сети.

Закладка Users. На ней можно посмотреть пользователей, которые в данный момент работают на машине. Если у Вас имеется достаточно прав, то Вы можете отключить этого пользователя, или просто послать ему сообщение. Подобные вещи давно и широко используются в самом различном программном обеспечении, предназначенном для управления многопользовательскими системами, но именно в Task Manager эта возможность появилась впервые.
(10) Что нового появилось в интерфейсе XP по сравнению с предыдущими ОС от Microsoft?

После достаточно долгого перерыва Microsoft существенно меняет внешний вид своих ОС. Основные принципы работы интерфейса остались прежними, но всяких мелких, и не очень, изменений и улучшений просто огромное количество. Первое, что бросается в глаза, это изменившееся оформление системы. На смену строгим, ровным линиям без лишних "украшательств" пришли округлые линии, мягкие полутона и тени. Вообще то, Microsoft не изобретал "велосипед", многие тенденции, которые нашли своё воплощение в новом оформлении XP мы могли видеть и раньше, в том числе и на PC. Как и W2k, использовавший цветовую гамму впервые появившуюся в KDE 1.2, XP использует элементы цветовой гаммы и оформление некоторых элементов интерфейса (например скролл-бары) сходные с используемыми в KDE 2.0 Если кому не нравятся новые веянья в "компьютерной моде", он легко может привести внешний вид системы в более привычный вид, такой как у W2k или W98.

(11) Как настроить Taskbar и Start Menu?
Всё богатство настроек Taskbar вызывается через правый клик на таскбаре, пункт Properties.

На первой закладке, Taskbar, имеется два раздела. В первом разделе, Taskbar Appearance доступны следующие чекбоксы
Lock the taskbar отметив этот пункт Вы потеряете возможность добавлять/удалять иконки в quick launch меню, не сможете менять его размер и местоположение. Зато, уберётся разграничительная линия между quick launch меню и основной частью таскбара.
Auto-hide taskbar подобный пункт существовал уже в W98, и отметив его вы заставите Ваш таскбар уезжать вниз, за пределы экрана, когда курсор мышки стоит не на нём.
Keep taskbar on top of other windows снятие этого чекбокса приведёт к тому, что раскрытые на полный экран окна будут закрывать собой таскбар
Group similar taskbar buttons если этот пункт отмечен, то несколько копий одной и той же программы группируются в одной кнопке. Например, если у Вас открыто несколько десятков окон IE, то они не расползаются на несколько рядов, а группируются в одной кнопке, и выкидываются списком при нажатии на неё.

Show Quick Launch показывает/прячет Quick launch.

Второй раздел, Notification area.
Show the clock включает/выключает отображение часов на таскбаре.
Hide inactive icons позволяет прятать неиспользуемые иконки в notification area. Нажав на кнопку customize, расположенную рядом, Вы сможете просмотреть список иконок, показываемых в этой области, и выбрать для каждой из них, должна она показываться всегда, должна прятаться сразу, или должна прятаться когда не используется.

Вторая закладка - Start Menu. Всего два пункта, Start menu и Classic start menu. Что они делают, прекрасно понятно из картинки над ними, которая меняется при выборе одного или другого пункта. Несколько более интересны кнопочки Customize напротив каждого из пунктов, но и там всё достаточно понятно и очевидно.
Для Start Menu можно настроить размер иконок, сколько программ будет показываться в списке наиболее часто используемых программ, выбрать программы запускаемые при нажатии на Internet и E-Mail, выбрать режим в котором будут показываться различные элементы меню, и будут ли показываться вообще (Display as link - при нажатии откроется окно, Display as menu - при наведении мышки выкинет меню, Don't display item - вообще не покажет).

Для Classic Start Menu доступны те же опции, что были в W2k, и несколько новых, из которых стоит отметить пункт, раньше доступный только через реестр или с помощью различных твикеров, удаление из Start Menu пункта Run.
(12) Как управлять пользователями, которым можно заходить на компьютер?
Как любая NT, XP имеет механизм идентификации пользователей, и каждого пользователя можно ограничить в правах. На этих пользователях и их правах строится вся модель безопасности XP, как на локальной машине, так и в сети. Нельзя защитить что-либо паролем, можно определить какие пользователи имеют право использовать тот или иной ресурс. Пользователей на одной машине может быть множество, и чтобы было проще ими управлять, пользователи разбиты на группы. Управление пользователями и группами осуществляется с помощью апплета Users Accounts в Control Panel. После установки системы образуется только два пользователя, один с правами администратора, который вы создали в процессе установки XP, и Guest, которые показаны в окне (на самом деле есть ещё несколько пользователей, например пользователь Administrator, но его не показывает в списке, и чтобы залогиниться им придётся идти на некоторые ухищрения). Если вы обладаете правами администратора, то можете добавить или удалить пользователя в этом окне, можете поменять пароль пользователя или пиктограмму соответствующую пользователю, поменять метод, который используется для входа в систему. Для этого надо выбрать пункт Change the way users log on and off. По умолчанию стоит Use the Welcome screen что означает, что для логона следует всего-навсего кликнуть по иконке из списка и ввести пароль. Если убрать галочку с этого пункта, то будет использоваться старый добрый метод входа знакомый по всем NT, с окном в котором предлагается ввести имя пользователя и пароль. Вы не можете использовать Welcome Screen если компьютер входит в домейн. Классический вход может быть двух видов, с требованием нажать Crtl+Alt+Del, и без оного. Для того что бы это изменить, наберите в любой командной строке control userapasswords2. Откроется знакомое пользователям W2k окно

На второй закладке этого окна, Advanced, ставим или снимаем галочку в чекбоксе Require Users To Press Ctrl+Alt+Delete check box, расположенном в разделе Secure Logon.

На той же закладке можно нажать кнопку Advanced в разделе Advanced User Management, и запустить хорошо знакомый пользователям предыдущих ОС линейки NT апплет Local Users and Groups (ещё его можно запустить через Control Panel - Administrative Tools - Computer Management - Local Users and Groups ). Вы окажетесь в хорошо знакомом пользователям предыдущих ОС линейки NT апплете, в котором сможете добавить или удалить пользователей отредактировать уже существующих, поменять им группу, и т.д...

Кроме этого, некоторые настройки для пользователей, такие как время жизни пароля, конкретные права для различных групп, и некоторые другие настраиваются из апплета Local Security Setings из Administrative Tools. Последнее, что хотелось бы отметить, это возможность и вовсе отключить необходимость в вводе пароля. Для этого вновь запускаем control userpasswords2, и снимаем галочку c users must enter a user name and password to use this computer. После этого пользователь выбранный в разделе Users for this computer: будет логинится на компьютер сразу, минуя всякие формальности, вроде ввода паролей или кликанья на собственном имени.
(13) Как залогиниться администратором?
Без лишних усилий администратором дают залогиниться только в Safe mode. Но, залогиниться им можно и в нормальном режиме. Самый простой способ, это не использовать Welcome screen. При обычном входе вводите имя пользователя (Administrator), пароль, и логинитесь. При использовании Welcome screen, когда выкинется окно с списком пользователей, дважды нажмите Ctrl+Alt+Del, и окажитесь в старом добром окне, где сможете ввести имя пароль. После того, как залогинитесь Administrator'ом, можете удалить всех пользователей с правами администратора, и тогда вы будете грузится administrator'ом всегда по умолчанию. Ещё одним способом, является конфигурирование окна User Accounts (control userapasswords2) на автоматическую загрузку администратора.
(14) Существуют ли аналоги autoexec.bat и config.sys под XP?
Да. Расположены они в папке C:\WINDOWS\system32\, и называются autoexec.nt и config.nt. Эти файлы влияют только на процессы, работающие через NTVDM (эмуляция DOS) и на Win32 никакого эффекта не оказывают.
Можно отметить настройку эмуляции Sound Blaster 2.0, которую теперь поддерживает NTVDM. Через autoexec.nt можно настроить ресурсы (IRQ, I/O порт, DMA). Значения которые установлены по умолчанию строкой SET BLASTER=A220 I5 D1 P330 соответствуют «традиционным значениям», которые считались стандартными для SB, и менять их как правило не приходиться. Причём абсолютно не имеет значения, какие ресурсы реально использует Ваша звуковая плата, при работе через NTVDM все порты виртуальные.
Кроме того следует отметить, что при указании путей в autoexec.nt могут некорректно вести себя Win16-приложения. Поэтому крайне рекомендуется прописывать пути в свойствах "Мой компьютер" ("My Computer") на закладке "Дополнительно" ("Advanced") -> "Переменные среды" ("Environment Variables").

Примечание: Если в момент загрузки W2k в корне системного раздела присутствовал файл autoexec.bat, то значения переменной path, определенные в нём, добавятся к путям определенным в "Переменных среды". Если вы не хотите этого, в разделе реестра HKCU\Software\Microsoft\WindowsNT\CurrentVersion\Winlogon значение параметра ParseAutoexec: REG_SZ: установите в 0.

(15) Чем различаются Windows XP Professional и Windows XP Home?
Обе эти системы имеют очень много общего, и XP Pro и XP Home построены на одном и том же ядре, NT 5.1. Разница между ними заключается только в том, что XP Home не поддерживает несколько функций работающих в XP Pro. В XP Home не поддерживаются следующие функции:
  • Remote Desktop – позволяет удалённую работу на компьютере.
  • Offline Files and Folders – позволяет иметь доступ к сетевым ресурсам когда отключены от сервера.
  • Scalable processor support – поддержка многопроцессорных систем.
  • Encrypting File System – шифрование файлов средствами файловой системы.
  • Access Control – ограничение доступа к файлам, программам и другим ресурсам.
  • Centralized administration – централизованое администрирование системы в рамках домена.
  • Group Policy – облегчает администрирование групп пользователей на компьютере.
  • Software Installation and Maintenance – автоматически инсталлирует, конфигурирует, ремонтирует и удаляет программное обеспечение.
  • Roaming User Profiles – доступ к Вашим документам и настройкам из любого места, где Вы подсоединились в домен.
  • Remote Installation Service (RIS) – поддержка удалённой инсталляции операционной системы по сети.
  • Multi-lingual User Interface (MUI) add-on – поддержка изменения языков интерфейса различных пользователей.

Кроме этого, есть незначительная разница в интерфейсах, например в XP Home нельзя выключить Simple File Sharing и включить нормальный.
(16) Как посмотреть Up Time (время работы с последней перезагрузки)?
Запустите окно терминала (cmd), и наберите в нём systeminfo. Эта команда выдаст различную информацию по системе, в том числе и uptime.
(17) Что случилось с regedit32.exe? Никак не могу его найти.
Этой полезной и привычной многим пользователям NT утилитки больше не существует. Все функции, которые когда то можно было выполнить только с её помощью, теперь доступны и в простом Regedit.
(18) Как создавать и редактировать темы для XP?
В состав ХР не входит никаких программ для работы с темами. Поэтому придётся использовать внешние программки. Например StyleXP, скачать можно здесь – www.tgtsoft.com


WinXPFAQ -> Инсталляция

Инсталляция
(1) Как поставить XP?
Есть несколько способов:

Во-первых, если Ваш компакт с дистрибутивом похож на тот, что выпускается Microsoft, то он должен являться бутовым (загрузочным). Чтобы загрузиться с него надо в BIOS-e параметр "Boot sequence" установить равным CD-ROM, вставить CD и перезагрузиться. После старта компьютера запустится программа установки. Дальше - просто следовать инструкциям.
Это единственный метод загрузится прямо в программу-установщик имея только CD. Microsoft считает, что CD-ROM это неотемлемая и абсолютно необходимая деталь для компьютера на который устанавливается XP, поэтому средств для реализации старого доброго способа загрузки с дискеток в состав дистрибутива больше не входит.

Во-вторых, можно загрузиться с DOS-овской системной дискеты с драйвером CD-ROM и запустить программу "winnt.exe" в директории i386 на диске с дистрибутивом.

Примечание: если Ваш винчестер подключен к внешнему контроллеру (SCSI или IDE), то не забудьте скачать новый XP (или W2k) драйвер для него и скинуть его на дискету. Он понадобится, если программа инсталляции не сможет правильно определить и установить устройство. В этом случае необходимо нажать на F6, когда будет производиться поиск таких устройств.

И, наконец, можно из под W9x, NT4 или W2k запустить программу "setup.exe" из корневого каталога СD диска, или winnt32.exe из директории i386, и апгрейднуть систему на XP. Сделается это очень корректно и перед перезагрузкой система выдаёт список программ и драйверов несовместимых с XP.
Однако, последний способ не является самым оптимальным. Несмотря на то что XP пытается самостоятельно определить список программ и драйверов, которые не будут работать с ней корректно, она не в состоянии сделать это правильно во всех случаях. Поэтому, во избежание проблем с совместимостью, мы бы рекомендовали Вам ставить систему заново.

Есть ещё более радикальный метод решения проблем с совместимостью. При инсталляции поверх существующей ОС, у вас будет возможность выбора ОС (Dual boot). Примечание: после установки XP как отдельной ОС будет невозможна нормальная работа Outlook Express и Internet Explorer в Windows 9x, т.к. XP заменит последние. Это верно только в случае установки обеих ОС на один и тот же раздел диска. Но, эту проблему можно решить, путём копирования некоторых DLL из WinXP\System32 в Windows\System. Для определения нужных библиотек можно воспользоваться программой ShowDep или аналогичные сведения показывает Outlook Express в окне "О программе".

Кроме этого, многие программы придётся устанавливать по два раза, раз для XP, и раз для W9x. Иногда, можно и в один и тот же каталог, например Office 2000 уже при установке способен понять, что он уже раз стоит, и в итоге устанавливает всего около 18 мегабайт.

(2) Как выбрать нужную версию ядра и HAL ещё при инсталляции?
В самом начале текстового этапа установки XP при появлении сообщения "Setup is inspecting your computer's hardware configuration" нажмите и удерживайте клавишу "F5". В появившемся на экране списке версий библиотек HAL выберите версию, соответствующую вашему компьютеру, или выберите позицию "Other" для того, чтобы указать файл библиотеки от производителя оборудования. Затем продолжите установку Windows. В поставку XP включены следующие версии библиотеки HAL:
  • ACPI Multiprocessor PC - для ACPI-систем с несколькими процессорами.
  • ACPI Uniprocessor PC - используется для ACPI-систем с многопроцессорной системной платой и одним установленным процессором.
  • Advanced Configuration and Power Interface (ACPI) PC - используется для однопроцессорных ACPI-систем.
  • MPS Uniprocessor PC - для систем без поддержки ACPI, с многопроцессорной системной платой и одним установленным процессором.
  • MPS Multiprocessor PC - для многопроцессорных систем без поддержки.
  • ACPI Compaq SystemPro Multiprocessor or 100% compatible - для компьютеров Compaq SystemPro или полностью совместимых с ними.
  • Standard PC - используется для любого стандартного компьютера, не многопроцессорного и без поддержки ACPI.
  • Standart PC with C-Step i486 - используется для компьютеров с поддержкой этой технологии.
(3) При инсталляции система не даёт выбрать компоненты, да и после инсталляции в Add/Remove programs – Windows Components почти ничего нет.
Во время установки выбрать вам ничего, к сожалению, не удастся. Но, после инсталляции, в Windows/inf найдите файлик sysoc.inf и удалите в нём слово hide или HIDE везде, где найдёте. В Add/Remove Windows components появятся новые пункты. К сожалению, всё из появившихся пунктов удалять нельзя, но кое-что всё-таки можно.
(4) Стоит ли переходить с FAT32 на NTFS?
Всё зависит от того, с какой целью вы используете компьютер, и сколько у вас оперативной памяти. Следует учесть, что NTFS работает несколько медленнее чем FAT, из-за дополнительно загружаемых сервисов и её системы безопасности. Если у вас мало оперативной памяти, и вы решили поставить себе XP, то вам однозначно нельзя ставить себе NTFS. Если у вас 128MB или больше, то можно уже подумать об NTFS. Следует взвесить преимущества и недостатки NTFS для простого пользователя и решить, что вам нужно. К преимуществам FAT32 можно отнести то, что она быстрее и требует меньше памяти для работы. Если система работает только с FAT32, то в память не грузятся драйвера и сервисы, необходимые NTFS. Кроме этого, при использовании FAT32 имеется возможность доступа к диску при загрузке с загрузочного флоппи W9x. Преимущества NTFS для простого пользователя можно описать одним ёмким словом: indestructible. На полном серьёзе, вышибить NTFS чрезвычайно сложно, хоть и возможно. Для опыта запускалась куча различных приложений, оптимизаторы диска, и в самые неподходящие моменты жалась кнопка reset. Повторение этого садизма добрый десяток раз никакого впечатления на систему не произвело, она продолжала работать без ошибок. Кроме этого, NTFS обладает встроенными средствами шифрования файлов, что обеспечивает определённую уверенность в сохранности данных. Конечно, при условии что система не будет переустанавливаться.
(5) Что вообще такое NTFS, и как она работает?
NTFS выросла из файловой системы HPFS, разрабатываемой совместно IBM и Microsoft для проекта OS/2. Она начала использоваться вместе с Windows NT 3.1 в 1993 году. Windows NT 3.1 должна была составить конкуренцию серверам на базе NetWare и Unix, поэтому NTFS вобрала в себя все тогдашние технологические достижения. Вот основные из них:
  1. Работа с большими дисками. NTFS имеет размер кластера 512 байт, что в принципе оптимально, но его можно менять до 64К. Более важно то, что NTFS способна теоретически работать с томами размером в 16,777,216 терабайт. Теоретически, потому что таких жестких дисков пока просто не существует, и появятся они весьма не скоро.
  2. Устойчивость. NTFS содержит две копии аналога FAT, которые называются MFT (Master File Table). В отличие от FAT MSDOS, MFT больше напоминает таблицу базы данных. Если оригинал MFT повреждён в случае аппаратной ошибки (например, появления bad-сектора), то система при следующей загрузке использует копию MFT, и автоматически создаёт новый оригинал, уже с учётом повреждений. Но это не самое главное. Главное, что NTFS использует систему транзакций при записи файлов на диск. Эта система пришла из СУБД, где защита целостности данных - жизненно важное дело. Уже это говорит о её эффективности. В упрощённом виде она работает так:
  • Драйвер ввода/вывода NTFS инициирует процесс записи, одновременно сообщая сервису Log File Service вести лог всего происходящего.
  • Данные пишутся в кэш, под управлением сервиса Cache Manager.
  • Cache Manager посылает данные Virtual Memory Manager-у (менеджеру виртуальной памяти), для записи на диск в фоновом режиме.
  • Virtual Memory Manager посылает данные драйверу диска, пропустив их через Fault Tolerant Driver (если у вас массив дисков RAID).
  • Драйвер диска шлёт их контроллеру, который уже пишет их либо в кэш, либо прямо на диск.
  • Если эта операция проходит без ошибок, запись лога удаляется.
  • Если происходит сбой, запись лога остается в таблице транзакций, и при следующем доступе к диску Log File Service обнаруживает эту запись, и просто восстанавливает всё как было до этой операции.
Такая система гарантирует абсолютную сохранность данных в случае копирования, перемещения и удаления файлов или директорий. При внесении изменений в файл, вы теряете те изменения, которые находились в момент сбоя в памяти или в кэше контроллера, и не успели записаться на диск.
  3. Защищенность. NTFS рассматривает файлы, как объекты. Каждый файловый объект обладает свойствами, такими как его имя, дата создания, дата последнего обновления, архивный статус, и дескриптор безопасности. Файловый объект также содержит набор методов, которые позволяют с ним работать, такие как open, close, read и write. Пользователи, включая сетевых, для обращения к файлу вызывают эти методы, а Security Reference Monitor определяет, имеет ли пользователь необходимые права для вызова какого-либо из этих методов. Кроме этого, файлы можно шифровать. Правда, с шифрованием стоит быть осторожнее. Если у вас рухнет система, или вы её переустановите то вы не сможете прочитать зашифрованные файлы, если не имеете ERD.
  4. Компрессия данных. NTFS позволяет компрессировать отдельные каталоги и файлы, в отличие от DriveSpace, который позволял сжимать только диски целиком. Это очень удобно, для экономии пространства на диске, например можно сжимать "на лету" большие графические файлы формата BMP, или текстовые файлы, причём для пользователя всё это будет прозрачно.
  5. Поддержка формата ISO Unicode. Формат Unicode использует 16bit для кодировки каждого символа, в отличие от ASCII, который использовал 8bit, или ещё хуже - 7bit. Для простого пользователя это означает то, что теперь он может называть файлы на любом языке, хоть на китайском - система это будет поддерживать, не требуя изменить кодовую страницу, как это делал DOS и W9x.
(6) Что нового в файловой системе NTFS5, и в чем её отличия от NTFS4?
Самое главное, за что ругали NT4, и в чём она уступала NetWare, это за отсутствие квотирования. Квотирование - это ограничение максимального объёма дискового пространства для пользователя, которое он сможет использовать. Зачем это нужно? Ну, на компьютерах, работающих в больших сетях, в фирмах и организациях и без вопросов понятно зачем, ведь жесткие диски не резиновые. А на домашнем компьютере, можно например, выделить пользователю "жена" или "младший брат" не более 50МБ на винчестере, чтобы они не захламляли диск чем попало. Причём, вовсе не обязательно, чтобы все файлы пользователя хранились в одном месте, они могут быть разбросаны по всем дискам. Устанавливаются квоты через Properties NTFS раздела, закладка Quota. Через Quota Entries... можно выставлять квоты для каждого отдельного пользователя. Второе, достаточно важное отличие NTFS5 от старой версии - возможность поиска файла, по имени его владельца. Зачем это нужно? А вот зачем: например, вам нужно найти все файлы созданные в Word-е, каким-то одним пользователем, на диске, где этих файлов тысячи. В NT4 это было проблемой. С помощью Access Control List (Список управления доступом), можно легко проверить, какие файлы доступны пользователю, и установить права доступа к отдельным файлам или каталогам. Кроме непосредственного изменения самой структуры NTFS, в XP добавлен Microsoft Index Server, который значительно ускоряет поиск файлов, особенно по их содержимому, за счёт индексации содержимого дисков. Управляется эта служба через раздел Indexing Service окна Computer Management. В этом разделе можно просмотреть, какие директории индексируются, и, при желании, добавить новые или удалить старые. Работает это c любыми разделами, а не только NTFS. В NTFS5 добавлена такая функция как точки монтирования или, по-другому, точки соединения (junction point). Функция эта давно знакома пользователям различных вариантов Unix/Linux, но в продуктах Microsoft она появилась впервые недавно (только с W2k). С помощью этой технологии можно присоединить любой дисковый ресурс в любое место файловой системы. Например, можно присоединить жёсткий диск D:\ в любой из каталогов на диске C:\, например, в C:\games Теперь, зайдя в директорию C:\games, можно будет видеть содержимое корневого каталога диска D:\. Все изменения, которые будут произведены в этой директории, будут произведены на диске D:\. После этого, можно в окне Computer management -> Disk Management убрать букву, присвоенную этому диску (Change disk letter and path), и пользователь даже не будет знать, что на компьютере установлено два диска! Он будет работать с одним диском C:\ и директория C:\games для него ничем не будет отличаться от других. Смонтировать диск или раздел в директорию на NTFS разделе или диске, можно из уже знакомого нам меню Change disk letter and path, выбором пункта Add.. -> Mount in this Ntfs folder -> Browse… Управлять этой функцией можно и через командную строку, командой mountvol. Сразу после примонтирования диска, директория в которую он смонтировался, будет показываться другим значком:

Но стоит переименовать её, как она примет такой же вид, как и все остальные

Что бы размонтировать диск, используйте Disk Management, меню Change disk letter and path, выбором пункта Remove. Если Вы просто удалите папку с примонтированым диском в Explorer'е, то вместе с папкой Вы удалите ВСЁ содержимое примонтированого диска. Так что будьте внимательны. Кроме монтирования целых дисков, можно монтировать отдельные директории, но для этого придётся воспользоваться сторонней утилиткой. Взять её можно здесь: http://www.3dnews.ru/reviews/software/win-xp-faq/junction.zip. Зайдите в консоль, запустите её, и ознакомитесь с её операндами.

(7) Что такое кластер?

Кластер - минимальный размер места на диске, которое может быть выделено файловой системой для хранения одного файла. Определяется он, как правило, автоматически, при форматировании винчестера, по зависимости указанной в таблице:

Размер раздела | Секторов в кластере | Размер кластера
< 512mб | 1 | 512 байт
< 1024mб | 2 | 1K
< 2048mб | 4 | 2K
< 4096mб | 8 | 4K
< 8192mб | 16 | 8K
< 16384mб | 32 | 16K
< 32768mб | 64 | 32K
> 32768 MБ | 128 | 64K

Небольшое исключение для системного раздела: если он меньше 2048МБ, то размер кластера, при использовании NTFS, всегда 512 байт.
Кроме этого, при конвертации Fat32 раздела в NTFS встроенной в XP утилиткой convert, размер кластера всегда будет 512 байт. Что бы избежать, придётся воспользоваться внешними программами, например Partition Magic.

Узнать размер кластера в XP можно несколькими способами. Во первых, можно зайти в Administrative Tools -> Computer Management -> Storage -> Disk Defragmenter. Выбрать нужный диск и нажать на Analyze. Через несколько секунд появится табличка, где есть три кнопки. Нажатие на View Report запускает окошко, в котором море информации про выбранный диск, в том числе и Cluster size.
Есть ещё один метод, который подходит не только для XP. Создаётся, или берётся готовый, маленький файлик размером от 1 байта до 500 байт. Нажимается на нём правая кнопка мыши, выбирается Properties. Смотрим на два пункта, Size и Size on disk. Size должен быть чем-то вроде 10 байт (или какой там размер он реально имеет), а Size on disk будет, к примеру, 4096 байт, что соответствует размеру кластера, т.е. 4K.
Размер кластера можно выбрать и самому, вручную, правда, только при форматировании. Делается это так: "format d: /A:size", где size это размер кластера в байтах. Однако существуют некоторые правила, которых следует придерживаться: во-первых, размер кластера должен быть кратен размеру физического сектора, то есть 512 байтам в подавляющем большинстве случаев; во-вторых, есть ограничения по количеству кластеров на разделе.
Кроме всего вышеперечисленного следует учитывать, что при размере кластера выше 4 килобайт на NTFS разделе не будут работать функции сжатия, встроенные в файловую систему.

(8) Как уменьшить занимаемый объем пpоинсталиpованной XP?
Можно удалить директории:
  • %SystemRoot%\Driver Cache\i386\ Это можно сделать в том случае, если всё оборудование уже стоит и работает. При добавлении нового оборудования система будет запрашивать дистрибутив.
  • %SystemRoot%\system32\dllcache\ Это кэш защищенных системных файлов, используемый для их автоматического восстановления в случае повреждения. Размер по умолчанию этой папки 400 Мб, и определяется он параметром SFCQuota (0xFFFFFFFF) в ключе реестра HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows NT \ CurrentVersion \ Winlogon Изменить размер кэша системных файлов можно помощью команды sfc: sfc /cachesize=0 (можно ввести другое значение, например, 3 Мб), а потом вручную удалить все файлы в указанной директории. Если не задать /cachesize=0, то при следующей проверке защищенных системных файлов система снова наполнит свой кэш до заданного объема.
  • Выключить System Restore. Сдать это можно здесь: System Properties -> System Restore -> Turn off System Restore for all drives. Этим вы сотрёте всю информацию, которая записана System Restore, и хранится в папке System Volume Informatiоn.
  • Отключить Hibernate. Так называется технология, которая позволяет быстро выключать и включать компьютер. Основана она на сохранении содержимого оперативной памяти в виде файла на жёстком диске. Поэтому при её использовании в корне системного диска всегда присутствует файл под названием hiberfil.sys объёмом равным оперативной памяти. Стирать его вручную бесполезно, во первых сделать это можно только под другой ОС, во вторых при загрузке он будет создан заново, даже если компьютер не уходил в хибернейт. Сделано это для того, что бы не было ситуации, когда машина не может уйти в хибернейт только из за того, что на диске не хватает места для этого. Для того что бы убрать этот файл навсегда, требуется отключить хибернейт, что можно сделать в Control Panel – Power Options, закладка Hibernate, снять галочку с чекбокса Enable Hibernate.
  • Уменьшить размер Swap файла. По умолчанию XP создаёт файл подкачки размером в полтора раза больше чем объём оперативной памяти. С современными объёмами RAM, которые даже в домашних машинах могут доходить до гигабайта, и файл подкачки того размера, что XP выставит для такой машину по умолчанию, большинству пользователей не нужен. Поменять размер файла подкачки можно через System Properties – закладка Advanced, кнопка Settings раздела Performance. В открывшемся окне переходим на закладку Advanced и нажимаем на кнопку Change раздела Virtual Memory.

В открывшемся окне выбираем диск или раздел, на котором требуется изменить размер файла подкачки, вводит нужные значения, и нажимаем на кнопку Set. Остаётся только перезагрузиться.

(9) Можно ли отконвеpтировать диск FAT32 в NTFS без потеpи данных?
  1. Можно воспользоваться командой CONVERT том: /FS:NTFS [/V] Преобразование произойдет при следующей перезагрузке. Потери информации не при этом не будет, но нужно иметь в виду, что размер кластера после конвертации составит 512 байт, что не очень хорошо на больших разделах, кроме того, диск после конвертации будет сильно фрагментирован. Обратное преобразование (NTFS -> FAT) без потери данных средствами XP невозможно, потребуется отформатировать раздел заново.
  2. Выполнить конвертацию также сможет программа Partition Magic. C NTFS 5 нормально работает, начиная с версии 6.0, но если использовать только загрузочную дискету, то подойдет и версия 5.01. Данная программа также позволяет выполнять обратное преобразование без потери данных и даже может менять размер кластера (к сожалению, только на FAT16 и FAT32). Partition Magic не работает с динамическими дисками, только с основными.
(10) Как полностью выключить SFC (System Files Protection)?
Для этого необходимо поменять значение [HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows NT \ CurrentVersion \ Winlogon] "SfcDisable" на "dword:ffffff9d". Для того что бы включить его обратно, этот же ключ надо изменить на 0. Кроме этого, можно воспользоваться вот этой утилиткой http://www.3dnews.ru/documents/1143/setsfc.zip, с помощью которой можно не только выключить sfc, но и изменить некоторые другие его параметры, причём делать это гораздо удобнее, чем копаться в дебрях реестра.
Однако, следует помнить что сделав это, вы рискуете испытать на себе все последствия Dll-hell, начиная от снижения общей производительности системы и заканчивая самыми разнообразными проблемами и глюками, вызванных заменой системных библиотек на несовместимые версии от сторонних производителей.
(11) Какие параметры можно менять в boot.ini?
boot.ini отвечает за порядок загрузки ОС установленных в системе, и позволяет задать некоторые параметры загрузки этих систем. Начинается этот файл разделом [boot loader] В этом разделе всего два параметра:
  • Timeout, определяет время в секундах, которое ждёт система прежде чем начать загружать ОС по умолчанию, в случае если в системе установлено несколько ОС.
  • Default, определяет систему которая грузится по умолчанию.

Второй раздел [operating system], в котором находится список возможных к загрузке ОС. Для каждой ОС указывается её местоположение с использованием имен ARC (Advanced RISC Computer):

  • scsi(*) или multi(*) - элемент scsi(*) используется в случае контроллера SCSI с отключенным BIOS. Элемент multi(*) используется для дисков всех остальных типов, включая IDE, EIDE, ESDI и SCSI с включенным BIOS. (*) - номер адаптера, с которого осуществляется загрузка. Адаптеры нумеруются с нуля, начиная с контроллера, расположенного ближе к слоту 0 на мат. плате.
  • disk(*) - если (1) = scsi(*), то равен логическому номеру устройства (LUN), установленному для диска. Если (1) = multi(*), то всегда равен нулю.
  • rdisk(*) - если (1) = multi(*), то равен номеру диска в цепочке, счет дисков начинается с 0. Если (1) = multi(*), то всегда равен нулю
  • partition(*) - определяет дисковый раздел, содержащий файлы ОС. В отличие от всех остальных элементов имен ARC нумерация разделов начинается с 1, т.е. первый раздел обозначается partition(1), второй - partition(2) и т.д.
  • \path - определяет каталог (или подкаталог) раздела, в котором находятся файлы ОС. По умолчанию в XP используется путь \windows. Кроме этого, в кавычках прописывается текст, который будет виден в пункте выбора этой ОС в стартовом меню. После этого текста могут быть ключи которые влияют на загрузки ОС. Для XP возможны следующие ключи:
  • /basevideo - с этим ключом система будет использовать только стандартный VGA драйвер. Этот параметр может пригодится если Вы на коротко время ставите другую видеокарту, и Вам не хочется мучаться с перестановкой драйверов.
  • /fastdetect - обычно ставится автоматически при инсталляции системы. При установке этого ключа система не определяет все Plug and Play устройства в процессе загрузки.
  • /maxmem - определяет максимальный размер RAM, который может использоваться системой. Теоретически, может помочь если у Вас глючная оперативка.
  • /noguiboot - При использовании этого ключа не будет рисоваться цветная заставка при загрузке. Может использоваться теми кто не желает смотреть на эту картинку в 60 герцах. Но надо учесть, что кроме этого не будут рисоваться BSOD при загрузке. Но виснуть система, если что-нибудь не в порядке, естественно не перестанет.
  • /noserialmice=[com 1,2,3] - при использовании этого параметра не будет определяться мышь подключенная к COM порту для портов перечисленных в скобках. Если номера портов не указывать, то мышь не будет определяться на всех портах.
  • /bootlog - при задании этого параметра система будет писать лог загрузки в %SystemRoot%\Nbtlog.txt Этот параметр можно использовать что найти причину почему система может загрузится только в safe mode.
  • /safeboot - при его установке система загрузится в Safe mode. То же самое можно сделать нажав F8 в начале загрузки системы. Через двоеточие можно задать несколько параметров для /safeboot. Minimal - минимальная конфигурация. Network - с поддержкой сети. Dsrepair - доступна только в NET Server и позволяет восстановить Active Directory с заблаговременно сделанной резервной копии. Alternateshell - позволяет использовать альтернативные графические оболочки. По умолчанию с системой ставится только Explorer (стандартная оболочка) и Progman (осталась в наследство от Windows3.11 и NT 3.5).
  • /sos - отображает на экране список загружаемых драйверов. Может помочь выяснить, на чём система спотыкается при загрузке.
  • /baudrate - этот параметр указывает скорость с которой будет работать COM порт для отладки системы. Если не указать конкретную скорость, то будет 9600 для модема и 19200 для нуль-модемного кабеля. При включении этого параметра автоматически ставится параметр /debug
  • /crashdebug - с этим флагом загружается отладчик, но остаётся в неактивном состоянии до тех пор пока не произойдёт ошибка ядра. Может использоваться разработчиками программного обеспечения.
  • /debugport=com* - указывает номер COM порта (* должна быть номером порта) используемого при отладчиком. Автоматически включает ключ /debug
  • /debug - загружается отладчик, который может быть активизирован другим компьютером через подключенным COM порт. Может использоваться разработчиками ПО.
  • /nodebug - на экран не выводится отладочная информация.
  • /hal - указывает имя файла, который должен использоваться как hal.dll после загрузки.
  • /kernel - указывает имя файла, который должен использоваться как ntoskrnl.dll после загрузки.
(12) Как мне поставить Win9x при уже установленном XP?
Win9x при инсталляции затирает загрузочный сектор XP. Что бы этого не произошло, перед установкой Win9x нужно правильно сконфигурировать его инсталлятор. Для этого в файле MSBATCH.INF (если такого файла в вашем дистрибутиве нет, создайте его) нужно прописать следующие строки:

[Setup]
CleanBoot=0

После установки Win9x устанавливает загpyзкy по умолчанию на себя, но это легко меняется. Если дистрибутив Win9x находится на CD (как это обычно и бывает), то исправленный или новосозданный MSBATCH.INF можно использовать, запустив программу установки Win9x с параметром: setup.exe диск:\путь\MSBATCH.INF В данном случае файл можно назвать как угодно, а не только MSBATCH.INF. После установки, требуется прописать W9x в стартовом меню XP. Для того что бы загрузиться в W9x, необходим файлик bootsect.bin в корне системного диска, который содержит загрузочный сектор W9x, и строка в boot.ini C:\="Microsoft Windows 98" Где текст в кавычках это то, что будет выводится в загрузочном меню выбора ОС.

(13)Как изменить букву системного/загрузочного диска в XP?
Изменение буквы может потребоваться в случае поломки зеркального тома или при изменении конфигурации дисковой подсистемы. Ниже рассмотрено, как поменять местами буквы для дисков С и D. Если вам не нужно менять буквы местами, просто измените значение \DosDevice\[буква]: на любую неиспользуемую букву.
Имейте в виду, что при изменении буквы диска в нормально работающей системе перестанут работать программы, которые используют абсолютный метод адресации - придется переинсталлировать их или вручную изменять все неправильные пути в реестре.
  • Зайдите в систему как администратор и запустите Regedt.exe.
  • Откройте ключ HKLM\SYSTEM\MountedDevices и разрешите администратору полный доступ к нему (меню Безопасность (Security) -> Разрешения (Permissions)).
  • В HKLM\SYSTEM\MountedDevices найдите букву диска, которую вы хотите изменить, в нашем случае это "\DosDevices\C:".
  • Измените букву на любую неиспользуемую, например, "\DosDevices\Z:".
  • Выберите вторую изменяемую букву диска, т.е. "\DosDevices\D:", измените её на требуемую, в нашем случае будет "\DosDevices\C:"
  • Выберите значение \DosDevices\Z: и переименуйте его в "\DosDevices\D:".
  • Перезагрузите компьютер

Примечание: перед сменой буквы подумайте, где окажется свап файл. Дело в том, что с потерей диска, на котором должен быть свап файл, система при загрузке сразу же после окна логона отрапортует Вам о том что свап файл слишком мал, и вновь вернётся в окно логона. Этот цикл может быть бесконечным, и что бы загрузиться Вам переустанавливать систему заново. Впрочем, можно будет ставить систему наверх, тогда не придётся переустанавливать установленные программы.

(14) Как переименовать папку аккаунта Администратор?
Заходим в систему под аккаунтом администратора, создаем папку с нужным именем в директории Documents and Settings. Затем - правый клик на иконке "My computer" -> Properties -> Advanced -> User Profiles, нажимаем кнопку Copy To ... и копируем профиль администратора в созданную папку. Запускаем regedit и находим ключ:
HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList
В этом ключе находим ветку, соответствующую профилю администратора по значению ключа ProfileImagePath и в ней исправляем этот параметр на нужный. Перелогиниваемся, если все прошло удачно, можно удалить старую папку - она больше не понадобится.
(15) Как сделать загрузочные флоппу диски для XP?
В отличии от W2k, где всё необходимое шло вместе с дистрибутивом, для XP Вам придётся скачать пакет из http://support.microsoft.com/support/kb/articles/q310/9/94.asp?ID=310994
Для создания комплекта загрузочных дискет Вам понадобится 6 флоппу дисков. При загрузке с них вы окажитесь в той же программе установки, что и при загрузке с компакт диска с XP, так что если у Вас есть возможность грузиться с такого диска, эти дискеты Вам не нужны.
(16) Как удалить XP с диска без потери данных? Hадо вернуться на Win9x.
Если XP стоял на NTFS, сначала нужно cконвертировать диск в FAT32. Для этого можно воспользоваться программой Partition Magic фирмы Power Quest. Затем создаем загрузочную дискету нужной версии Win9x, копируем на неё файлы fdisk.com, sys.com и загружаемся с неё. Выполняем команды fdisk /mbr и sys a: c: После этого удаляем директорию /Windows и файлы из корневого каталога, имеющие отношение к XP - ntldr, boot.ini и т.д.
(17) После изменения прав доступа к файлам (security permissions) на NTFS хочется вернуть все к тому виду, как было после установки. Возможно ли это?
Да, это возможно. Более того, это просто необходимо, если вы поставили XP на FAT или FAT32, а затем cконвертировали файловую систему в NTFS. Для того, чтобы восстановить разрешения по умолчанию для NTFS, зайдите в систему под аккаунтом администратора, и введите в командной строке:

Secedit /configure /db C:\windows\temp\temp.mdb /Cfg c:\winnt\inf\defltwk.inf /areas filestore

Данная процедура затронет все папки из %Windir% и "Program Files", а для папки "Documents and Settings" все же придется выставлять права доступа вручную.

Примечание: после выполнения команды вы можете получить сообщение о том, что задача выполнена, но часть файлов отсутствует и для них операция не применима.

(!) Если вы запретили доступ к файлам аккаунту SYSTEM на загрузочном диске, то результатом будет невозможность загрузки системы. Для решения этой проблемы придется воспользоваться другой копией XP или W2k (можно поставить вновь на другой диск или раздел) и с помощью Windows Explorer дать аккаунту SYSTEM полные права доступа на корневую папку и все системные файлы и папки.
После этого, загрузившись в оригинальной версии XP, восстановите разрешения по умолчанию.


WinXPFAQ -> Твики

Твики
(1) При запуске Windows Explorer открывается папка My Documents. Как сделать так, что бы открывался корневой каталог системного диска?
В Propreties shortcut'а на Explorer, меняем target %SystemRoot%explorer.exe на %SystemRoot%explorer.scf. После этого, открываться будет не My Documents, а корневой каталог системного диска. Кроме этого, можно запускать Explorer комбинацией клавиш Win+E, в этом случае он откроется в разделе My Computer. Кроме этого, можно в свойствах ярлыка для Explorer прописать в Target:

%SystemRoot%\explorer.exe /e,c:\ (вместо c:\ можно указать любой другой путь).

После этого открываться будет не My Documents, а корневой каталог диска С или указанная директория. Более подробно почитать про использование этого и других ключей в командной строке при запуске Windows NT Explorer можно здесь: http://support.microsoft.com/support/kb/articles/Q152/4/57.asp

(2) Когда открывается директория с большим количеством файлов, находящаяся на NTFS-разделе, например, WINNT, то это делается слишком долго. Можно ускорить этот процесс?
Когда открывается директория, то NTFS обновляет метку последнего доступа к файлам. Если файлов много и на всех надо метку обновить, то это занимает довольно много времени. Однако эту функцию можно отключить. Для этого запускаем Regеdit и по адресу HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> Control -> FileSystem cоздаём ключ типа DWORD под названием NtfsDisableLastAccessUpdate, после чего ставим его в 1.
(3) Как ускорить работу интерфейса XP?
Во-первых, нужно отключить все эффекты. Для этого требуется зайти в System Properties, закладка Advanced, раздел Performance, кнопка Settings.

Вы окажитесь в таком окне:

в котором можно либо выключать эффекты по отдельности, снимая соответствующие значки, либо выключить всё сразу, отметив пункт Adjust for best performance. Если это кажется недостаточным, то можно через Regedit отредактировать несколько ключей. По адресу HKEY_CURRENT_USER -> ControlPanel -> Desktop находится ключ MenuShowDelay. По умолчанию его значение равно 400, это значение задержки в миллисекундах, после которой появляются раскрывающиеся меню. Установите его в 0.

Также по адресу HKEY_CURRENT_USER -> ControlPanel -> Desktop -> WindowsMetrics находится ключ MinAnimate (если его нет, то создайте его; тип String), по умолчанию он стоит 0. Если его поставить равным 1, то он уберёт эффект анимации при сворачивании/разворачивании. Для того что бы эти изменения вступили в действие, необходимо перезагрузить компьютер.

(4) Как отключить Dr. Watson, встроенный дебагер?
Это не только позволит быстрее закрывать подвиснувшие приложения, но и позволит ускорить запуск программ и освободить пару мегабайт оперативной памяти. Сделать это можно выставив ключ Auto равным 0 по адресу HKEY_LOCAL_MACHINE -> SOFTWARE -> Microsoft -> Windows NT -> CurrentVersion -> AeDebug. В этом случае, если возникнут какие-либо сбои в работе приложения, то система предложит либо закрыть приложение, либо передать его отладчику для отладки. Если выбрать второе, то запустится Dr.Watson,и создаст лог- файл. Если вы уверены, что такая возможность вам ни к чему, то можете удалить папку AeDebug из реестра.
(5) Какие службы можно отключить, для ускорения работы системы?
Ускорить работу системы, попутно освободив немного памяти, можно запретив загрузку ненужных системных служб. Отключить (Disable) ненужные службы можно через раздел Services окна Computer Management.

Здесь надо быть предельно осторожным, потому как последствия необдуманных действий могут быть непредсказуемы. Многие службы для своей работы требуют работы других служб, поэтому если Вы отключите слишком много лишнего, то можете столкнуться с такой ситуацией, что не сможете включить всё обратно. Какая служба от какой зависит можно посмотреть через закладку Dependencies из свойства службы.

Но чтобы полностью избежать проблем при экспериментах со службами, мы бы советовали вам перед тем как производить эксперименты с службами сохранить ветку реестра отвечающую за запуск системных служб. Для этого в regedit идите по адресу HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Serviсes, и выбрать в меню File, или контекстном по правому клику, пункт Export Registry Key. Тогда, в случае каких либо проблем Вы просто сможете применить полученный *.reg файлик и всё поправить. А вообще, мы бы настоятельно советовали бы Вам воспользоваться советами из раздела восстановление, и сразу после инсталляции системы сохранить все системные настройки. Это, в последствии, может помочь избежать Вам многих проблем. Ниже мы приведём несколько служб, которые могут быть отключены. Используйте эти советы на свой страх и риск, авторы не несут никакой ответственности за возможные последствия (список служб дан для XP Pro).

  • Print Spooler: Спулер печати, ускоряет печать; если принтера нет, то его можно отключить.
  • Automatic Updates: Автоматичесткое обновление. Если у вас нет постоянного соединения с Интернетом, или если вы просто хотите контролировать всё что делает компьютер, то обновлять программное обеспечение входящее в состав XP можно и вручную. Выключая эту службу не забудьте выключить Automatic Updates в одноименной закладке System Properties.
  • Cryptographic Service: Отвечает за безопасный обмен ключами и шифрование. Используется для установки защищённых соединений, как в локальной сети, так и в интернет, играет важную роль в поддержке шифрования файловой системой. Если вам не надо шифровать файлы находящиеся на NTFS разделах, и вы не планируете использовать защищённые соединения в интернет (что использует, например, Windows Update), можете эту службу отключить. Используется она и во время проверки системных файлов (команда sfc), поэтому перед такой проверкой не забудьте включть её обратно.
  • Portable media serial number: Обеспечивает получение серийного номера переносного музыкального устройства подключаемого к компьютеру. Очередное нововведение Microsoft в рамках борьбы с музыкальным пиратством. На сегодняшний день для большинства из нас эта служба не актуальна.
  • SSDP Discovery service: обеспечивает автоматических устройств подключаемых к сети устройств, поддерживающих UPnP. Пока что это редкость.
  • Task Scheduler: обеспечивает возможность запуска приложений в заданное время. Казалось бы, если не используете эту возможность, то эта служба первый кандидат на отключение. Кроме этого, эта служба используется для создания так называемых prefetch файлов. Эти файлы создаются для каждого из запускаемых приложений (в том числе и для самой ХР), и содержан информацию где физически на вашем диске расположены файлы программы, и в каком порядке их следует загружать. Что заметно ускоряет запуск программ и системы.
  • Terminal Service: Раньше эта служба была доступна только в серверных вариантах ОС. Она позволяет подключаться к Вашей машине про сети, и удалёно работать на ней. В XP Pro эта служба предназначена для удаленного администрирования Вашей машины, что бы IT специалисту не приходилось бегать самому чинить всё что Вы там натворили, а можно было сделать это удалённо. Кроме этого, через эту службу работает переключение пользователей на одной машине (Switch User). Если Вам эти возможности не нужны, можете отключить эту службу.
  • Windows time: синхронизирует время на локальной машине и сервере. Нет time-сервера - служба не нужна. * Wireless zero configuration: автоматически настраивает беспроводные сети форматов 803.11 и 803.11b. Участвует в таких вещах как подсоедение/отсоеденение рабочих станций, перевод их с одного репитера на другой, и т.д.. Если беспроводной сети нет, то абсолютно бесполезна.
  • Task Scheduler: Отвечает за запуск определённых программ в определённое время. Например, можно настроить, чтобы каждый день в определённое время запускался "scandisk" или "defrag". Если подобные функции не нужны, то эту службу можно отключить.
  • Messenger: Принимает и отправляет сообщения, посланные администратором. Если нет сети и администратора, то можно отключить.
  • Protected Storage: Служит для защиты важных данных, ключей пользователей. Запрещает неавторизированный доступ. Если нет сети (в том числе Интернет), или безопасность не волнует, то данный сервис можно отключить.
  • Computer Browser: Обновляет список компьютеров в сети. Если у вас нет локальной сети, то можно отключить.
  • Event Log: Занимается тем, что ведет лог системных и программных событий, а также событий в системы безопасности. Если уверены, что у вас всё уже настроено и нет желания шпионить за каким-либо пользователем, то можно отключить.
  • Server: Обеспечивает общий доступ к принтерам, папкам и файлам, а также обеспечивает поддержку Remote Procedure Call. В случае, если у вас нет ни сетевой карты, ни модема, он вам не нужен.
  • IPSEC Policy Agent: Сервис безопасности протокола TCP/IP. Если вы не пользуетесь этим протоколом, то можно его выключить. Если вы сами зашли на http://www.3dnews.ru/ с машины, на которой стоит XP, то значит, что TCP/IP у вас установлен, и вы им пользуетесь :-)
  • Network Connections: Занимается управлением объектами в директории Network and Dial-Up Connections, то есть всеми сетевыми соединениями. Если нет сети, то он становится не нужным.
  • Remote Registry Service: Позволяет удалённые манипуляции с реестром. Скорее всего нужен только администраторам.
  • System Event Notification: Отслеживает системные события. Если уверены, что всё у вас уже работает, то можно отключить.
  • DHCP client: Отвечает за автоматическое распределение IP-адресов. Если нет сети (ни локальной, ни модема), то он не нужен.
  • Telephony: Работает с модемом. Если модема нет, то он не нужен.
  • Telnet: Обеспечивает возможность соединения и удалённой работы с хостами по протоколу telnet. Если уверены, что это не пригодится, то данный сервис можно отключить.
  • Uninterruptible power supply: Управляет работой бесперебойных источников питания (UPS). Если таковых нет, то можно отключить.

Этот список можно ещё продолжить, необходимость того или иного сервиса определяется задачами, которые выполняются на конкретной машине, и установленным аппаратным обеспечением. Поэтому, каждый должен сам решать, что можно отключить.

(6) Как отключить автозапуск у привода компакт-дисков?
Самый простой способ, сделать это через CD Properties, вызываемой по правому клику мышки на CD диск.

из этого окна можно выбрать, как система должна реагировать на диски определённого содержания. Но в этом списке нет Data CD, и что бы отключить автозапуск на таких дисках, надо нажать левый Shift во время загрузки компакт-диска. А можно поправить значение в реестре: ключ: [HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ CDRom] паpаметp: Autorun тип: REG_DWORD значение: (0=отключено, 1=включено) Но помните, что если проделать это для пишущего привода, то вы можете потерять возможность писать и стирать диски средствами XP. На работу внешних программ для записи это, конечно же, не окажет никакого влияния, всё будет прекрасно писаться.

(7) По какому принципу XP присваивает буквы дискам?
В порядке подключения. Системному диску обычно присваивается название С:\ и изменить его сложно. После него идут все жёсткие диски, которые найдены в процессе инсталляции, потом CD-ROM’ы, и так далее. Но, если диск подключается после того как система установлена, то ему присваивается следующая свободная буква, буквы уже установленных дисков не меняются. Причём для системы нет никакой разницы, что это за диск: винчестер, CD-ROM, Zip или Jaz drive, или что-либо ещё. Таким образом, нередки ситуации, когда CD drive имеет букву меньшую, чем винчестер, или, если в системе установлено много дисков, они идут вперемешку, без всякой системы, что несколько смущает пользователей привыкших к тому, что W9x упорядочивает диски, меняя буквы, и установленный в W9x винчестер всегда получает букву меньшую, чем у CD-ROM, сдвигая последний. Впрочем, и в XP можно привести нумерацию дисков в "привычный" вид, но делать это придётся вручную, через Disk Management.
(8) Как сделать, чтобы пpи остановке/запyске стиpался/создавался новый файл подкачки pagefile.sys?
[HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Control \ Session Manager \ Memory Management]
Параметр "ClearPageFileAtShutdown"=dword:00000001
Этот ключ не стирает пейджфайл с диска, а заполняет его весь нулями, т.е. очищает. Hо сам файл на диске остается. Тоже самое делается в апплете Local Security Policy в Administrative Tools, раздел Local Policies, Security Options, ключ Shutdown: Clear virtual memory pagefile when system shuts down.
(9) Как задать пpиоpитет процесса еще пpи его запyске? Чтоб не лазить постоянно для этого в task manager?
Запуская с помощью консольной команды start можно запускать приложение с нужным приоритетом, указывать время, через которое приложение должно быть закрыто, и некоторые другие параметры. Для более подробной справки почитайте start /? Все эти команды можно прописать в *.bat файле и пользоваться им для запуска приложени. Что бы не писать *.bat файлы для каждой программы отдельно, и не набирать команду целиком, можно сделать файлик high.bat, с таким содержимым

echo off
start /high %1

и поместить его в директорию SendTo профиля вашего пользователя. Тогда, что бы запустить программу с более высоким приоритетом, достаточно просто переслать её на этот файлик через правую кнопку мыши. Но пересылать надо именно исполняемый файл, а не shortcut к нему. Конечно же, этот файлик можно и переделать и запускать программы с другим приоритетом.

Дополнение: Ускорение запуска программ
XP может работать в двух режимах. Первый отводит больший приоритет запущенным пользователем приложениям (Optimize Performance for Applications), второй отводит больший приоритет на фоновые приложения и службы (Optimize Performance for Background). Настройку можно посмотреть, если выбрать значок System в Control panel, далее закладку Advanced и кнопку "Performance options". (В русской версии Панель управления/Система/Дополнительно/Параметры быстродействия).

Первое значение (for Applications) выделяет программам приоритет в зависимости от их уровня приоритета (priority level). Если вы не знакомы с этим понятием, то вкратце поясним: по уровню компьютер решает, какие программы более важны и тратит на них больше процессорного времени. Уровень определяется двумя параметрами: классом приоритета (Priority Class) и приоритетом нити (thread priority). Классы бывают: реального времени (real-time), высокого (high), среднего (normal), близкого к нулю (idle) приоритетов. У нити выделяют следующие приоритеты: критичный ко времени (time critical), высокий (highest), выше среднего (above normal), средний (normal), ниже среднего (below normal), низкий (low) и близкий к нулю (idle).

В приведенной ниже таблице можно посмотреть, как эти два параметра влияют на выполнение задачи.

 | Priority Class
Thread Priority |  | Real-Time | High | Normal | Idle
 | Time Critical | 31 | 15 | 15 | 15
 | Highest | 26 | 15 | 10 | 6
 | Above Normal | 25 | 14 | 9 | 5
 | Normal | 24 | 13 | 8 | 4
 | Below Normal | 23 | 12 | 7 | 3
 | Lowest | 22 | 11 | 6 | 2
 | Idle | 16 | 1 | 1 | 1

Значение от 1 до 31 показывает, сколько компьютерного времени выделяется на каждый процесс. Пользователь может изменить класс приоритета программы, причем двумя способами. Первый - через Диспетчер задач (Task Manager). Он подходит, если программа уже запущена. Выбираем закладку "Процессы" (Processes), нажимаем правую клавишу мыши на нужном процессе, выбираем строчку "Приоритет" (Set Priority) и устанавливаем класс приоритета. Второй способ заключается в указании параметра при запуске программы, или создании командного (.CMD) файла в текстовом редакторе. Параметры:

start /<класс приоритета> [<путь>]<имя файла>

Например,

start /high c:\windows\notepad.exe

Будьте осторожны в присваивании класса реального времени. Такая программа будет иметь очень высокий приоритет, что может сказаться на замедлении выполнения других программ. Более того, если у Вас не SMP система, то охочее до ресурсов приложение может просо ничего не оставить системе, и вы столкнётесь с ситуацией, когда компьютер не будет реагировать на Ваши действия, или будет реагировать с большим опозданием. В худшем случае он может просто повиснуть.

(10) XP при загрузке проверяет на ошибки все дисковые разделы, даже если на них установлены другие ОС. Как это отключить?
Для этого необходимо в реестре по адресу [HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Control \ Session Manager] изменить ключ "BootExecute". По умолчанию там стоит "autocheck *", "*" можно попробовать поменять на букву раздела, который следует проверять. Впрочем, возможно это приведёт к тому, что никакие разделы не будут проверятся вообще, полной уверенности о работе этого ключа нет.
(11) Как ускорить работу с памятью?
Можно регулировать несколько значений реестра для ускорения работы подсистемы памяти XP. Но будьте осторожны, так как неправильные значения могу привести к неработоспособности системы. Вы можете изменить некоторые значения реестра в ветке [HKLM/System/CurrentControlSet/Control/Session Manager/Memory Management]:
  • DisablePagingExecutive - при включении этого параметра, ядро системы и драйвера не будут скидываться в файл подкачки (swap). Система и программы будут быстрее реагировать на действия пользователя. Параметр следует использовать только при большом объеме доступной памяти (>256 Мбайт). По умолчанию значение "0", включение - "1".
  • LargeSystemCache - при включении (по умолчанию включено на сервере Windows.NET) операционная система будет использовать всю оперативную память для кеша системных файлов, за исключением 4 мегабайт зарезервированых для дискового кеша. Для включения опции следует указать в качестве параметра "1". Установка опции в значение "0" рекомендуется для серверов использующих приложения со своими собственными функциями кэширования памяти, например Microsoft SQL Server или IIS.
  • IOPageLockLimit - сомнительная функция, если вы, конечно, не желаете организовать сервер из своей машины. Опция ускорит выполнение операций ввода/вывода при большом количестве передаваемых файлов или при подобных нагрузках. Не имеет ощутимого эффекта, если на вашем компьютере установлено менее 128 Мбайт памяти. Если памяти больше, то вы получите увеличение производительности при установке параметра в значение от 8 до 16 Мбайт. По умолчанию выставляется 512 кбайт. Вам следует указать параметр в байтах, поэтому умножьте требуемое число мегабайт два раза на 1024. Протестируйте несколько настроек и выберите наилучшую.
(12) У меня пусто в "Автозапуске", но некоторые программы продолжают стартовать при входе в Windows
Проверьте следующую ветку реестра, используя regedit [HLKM \SOFTWARE \MICROSOFT \WINDOWS \CURRENTVERSION \RUN]. Там находятся значения, каждое из которых соответствует одной запускаемой при старте программе. Если вы не уверены, перед стиранием сохраните выбранные строчки. Ещё проще сделать это из программки msconfig, закладка StartUp,

запустить которую можно из пункта Run... кнопки Start.

(13) Можно ли ввести машину в состояние hibernate, или выключить из командной строки?
Можно. Вот так:

%windir%\System32\rundll32.exe powrprof.dll,SetSuspendState.

Если создать *.cmd файл подобного содержания, то с его помощью можно будет вводить машину в hibernate из шедулера, в заданное время. Для того что бы выключить компьютер, можно воспользоваться следующим методом. Создаем в любом текстовом редакторе файл poweroff.vbs следующего содержания:

dim OpSysSet, obj
Set OpSysSet = GetObject("winmgmts:{impersonationLevel=impersonate," &
_
"(Shutdown)}//./root/cimv2").ExecQuery _
("SELECT * FROM Win32_OperatingSystem" &_
" WHERE Primary=true")

For Each objIn OpSysSet
obj.Win32Shutdown(8)
Next

В дальнейшем можно стартовать этот скрипт из командной строки или включить вызов в командный файл. Уже готовый скрипт при желании можно скачать здесь: http://www.chem.univ.kiev.ua/~adsh/win2k/soft/poweroff.zip Кроме этого, для выключения компьютера можно воспользоваться командой shutdown. Набрав "shutdown /?" можно ознакомиться со справкой со этой утилитке.

(14) Правда ли что XP всегда загружает определённый набор DLL, даже если они не используются?
Правда. Список этих DLL находится здесь:
HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\KnownDLLs
Теоретически, если вы уберёте из этого списка лишнее, это может освободить некоторое количество памяти и ускорить работу. Практически, я бы не советовал. Зато можно добавить в этот список библиотеки, которые часто используются используемым именно Вами.
(15) Как сделать что бы задачи которые повисли и перестали отвечать убивались автоматически?
За это отвечает ключ HungAppTimeout, находящийся по адресу HKCU\Control Panel\Desktop. Значение этого ключа определяет время в миллисекундах, через которое не отвечающее приложение считается зависшим. Кроме этого ключа, в той же ветке есть ключи WaitToKillServiceTimeout, который задаёт время ожидания перед «убийством» зависшей службы, и AutoEndTasks, присвоив которому значение 1, вы разрешите системе убивать зависшие процессы самостоятельно. Не следует, только, ставить очень малые значения Timeout, иначе могут возникнуть проблемы с не вовремя убитыми программами и службами.
(16) Как добавить содержимое рабочего стола в меню Start?
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders value Desktop, default val is "%USERPROFILE%\Desktop" change to "%USERPROFILE%\Start Menu\Desktop" скопировать папку %USERPROFILE%\Desktop в %USERPROFILE%\Start Menu\Desktop
Перегрузится, после этого, при нажатии на Start там будет распахивающееся меню Desktop.
(17) Как мне залочить мой компьютер? Crtl+Alt+Del не помогают.
Теперь для этого придётся нажать Win+L. Кроме этого, можно создать *.cmd файл следующего содержания

rundll32.exe user32.dll,LockWorkStation

и лочить машину запуская его. Если Вы снимите галочку с Use Welcome Screen в Control Panel - Users Accounts - Change the way users log on and off, то когда другой пользователь, зарегистрированный на Вашей машине попытается разлочить его, то он отсоединит (log off) Вашего пользователя, и Вы потеряете всё несохраненные документы. Такого же эффекта можно добиться отключив (Disabled) службу Terminal Service. Для того что бы иметь возможность работать на компьютере нескольким пользователям одновременно, придётся включить Welcome Screen и Fast User Switching.

(18) При открытии папки с рисунками, рисунки рисуются как картинки. В первый раз тормозит, потом работает быстро. Где это всё кешируется? И как это отключить?
Для отключения этой функции достаточно изменить вид отображения папки в меню View, или через соответствующую ему пиктограмму. Сам кэш храниться в той же директории что и картинки, это системный файл с именем Thumbs.db.
(19) Куда пропала закладка Security на томах NTFS, и что случилось с закладкой Sharing?
В полном соответствии с новыми принципами построения интерфейса OC, Microsoft спрятал закладку Security и сильно упростил закладку Sharing, что бы не смущать неопытных пользователей кучей непонятных для них значений и понятий. Для того что бы вернуть всё как было в W2k, необходимо в Windows Explorer выбрать меню Tools - Folder Options. В открывшемся окне выбрать закладку View, и в разделе Advanced Settings очистить чекбокс Use simple file sharing (Recommended). Это не только приведёт закладку Sharing в нормальный вид (с возможностью выставить нормальные права доступа), но и вернёт закладку Security. Этот рецепт работает только для WinXP Pro, в XP Home вернуть закладку Sharing в нормальный вид не возможно. Если вам надо назначить нормальные права доступа под XP, придётся воспользоваться утилиткой для командной строки calcs.
(20) Как включить кодирование Mp3 с высоким битрейтом?
Одна из новых возможностей XP, это встроенный механизм кодирования музыки с CD. Делается это средствами Media Player, меню Tools, пункт Options, закладка Copy Music. Основным форматом в который можно кодировать, по умолчанию считается wma, для которого и можно выбрать битрейт, вплоть до 192 килобит. В списке file format можно выбрать MP3, но по умолчанию он недоступен, несмотря на то, что кодек в системе установлен. Выходов из этого положения два. Во первых, можно поставить внешний mp3 кодек и внешний софт для кодирования (например AudioGrabber), и кодить с их помощью.К преимуществам этого метода можно отнести то, что битрейт в этом случае будет любой максимально доступный для кодека, то есть вплоть до 360 килобит. Если Вы не хотите возиться с внешними программами, то импортируйте в реестр *.reg файлик следующего содержания:

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ MediaPlayer\ Settings]
[HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ MediaPlayer\ Settings\ MP3Encoding]
"LowRate"=dword:0000dac0
"MediumRate"=dword:0000fa00
"MediumHighRate"=dword:0001f400
"HighRate"=dword:0002ee00

Вам всё равно придётся инсталлировать внешний mp3 кодек (если он ещё не установлен. Устанавливается он, например, вместе с Divx кодеком). Встроенный кодек хоть и есть, но кодировать он не позволяет. В принципе можно даже не инсталлировать весь новый кодек, а просто поменять файл под названием l3codeca.acm находящийся в корневой папке Windows и имеющий версию 1.9.0.305 на что-нибудь более свежее.

(21) Как убрать папку Shared Documents из My Computer?
Заходим в RegEdit HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ Explorer \ My Computer \ NameSpace \ DelegateFolders Удаляем ключ {59031a47-3f72-44a7-89c5-5595fe6b30ee}.
(22) Как мне изменить time-server, используемый XP?
Список серверов, которые используются для синхронизации времени на локальной машине и сервере, находится в HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\DateTime\Servers
Добавьте здесь свой, или удалите существующие, если Вам эта возможность не нужна. В последнем случае, отключите службу Windows time.
Кроме этого, time-server можно поменять через контекстное меню вызываемого правую кнопку мыши на времени в системном трее, пункт Adjust Date/Time, закладка Internet Time.
(23) Что такое boot defrag, и что с ним делать?
Это новая функция, которую Microsoft ввёл в Windows XP. Суть её состоит в том, что при каждой загрузки дефрагментируются файлы необходимые для старта XP, что позволяет ей грузиться быстрее. Если выключить эту функцию, то на первых порах загрузка будет идти чуть-чуть быстрее, но по прошествии определённого времени заметно замедлиться. Управлять данной функцией можно через реестр. В разделе HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Dfrg\BootOptimizeFunction ищем ключ Enable. Поменяв его значение на N, мы выключим boot defrag, присвоив Y включим.
(24) Как добавить и отредактировать сообщение, которое будет выводить при старте компьютера?
Для этого идём в Control Panel - Administrative Tools - Local Security Policy. Выбираем Security Options, ищем там пункт Interactive logon: Message text for users attempting to log on. Это будет сообщение, что выведется в окне. На строчку ниже смотрим Interactive logon: Message title for users attempting to log on. Это будет название окна (титл), в котором будет выводиться сообщение.
(25) Как отключить сообщение о том что недостаточно свободного места на диске?
Создайте в реестре, по пути HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer Ключ типа DWORD под названием NoLowDiskSpaceChecks, и присвойте ему значение 1.
(26) Как создать загрузочный CD-ROM с Windows XP?
В этом вопросе будет описана процедура для Nero Burning ROM.
Сначала необходимо внести изменения в реестре:
  1. Запустите "regedit" и найдите раздел "HKEY_CURRENT_USER\Software\ahead\Nero - Burning ROM\General"
  2. В правой панели сверху найдите переменную "AddISOFileVersion"
  3. Щелкните правой клавишей на "AddISOFileVersion" и выберите "Modify"
  4. Значение будет "1", подсветите значение и измените на "0" - это нуль.
  5. Закройте regedit, перезагрузитесь и следуйте инструкциям ниже. Скачайте себе загрузчик xpboot.img либо xpboot.bin, который был извлечен из ИСО 2600. (Размер этих файлов - 2Kb, находятся они внутри CHM'а)

ЗАПИСЫВАЕМ ЗАГРУЗОЧНЫЙ ДИСК:

  1. Закройте "Мастера" и выберите "File" "New"
  2. Прокрутите вниз по типам CD и выберите"CD-ROM (Boot)"
  3. В правой области появится новая вкладка BOOT. Выберите "image file" как "Source of Boot Image Data" и обзором укажите на "xpboot.img" файл, если загрузили вышеупомянутый, или "xpboot.bin" если имеете такой файл.
  4. Выберите "Enable Expert Settings" и затем "NO EMULATION", Boot Message должно быть MICROSOFT CORPORATION, "Load Segment" оставьте по умолчанию 07C0, и измените "Number of Loaded Sectors" на 4.
  5. Выберите вкладку LABEL, наберите "Volume Label" как WXPVOL_EN. Введите MICROSOFT_CORPORATION в качестве параметра для "Publisher" и "Data Preparer".
  6. Щелкните вкладку BURN и поставьте галочки "Write", "Finalize CD", а также "Write Method" - "Disc-At-Once".
  7. Щелкните вкладку ISO для проверки. По умолчанию все установки правильные - ISO level 1, Mode 1, ISO 9660, Joliet
  8. Щелкните "New" в правом углу и, как обычно, добавьте файлы. Когда закончите с файлами, выберите значек "Write CD" или последовательность "File, Write CD"
  9. Появится диалоговое окно, в котором вы можете еще раз проверить свои настройки.
  10. Выберите "Write" для записи загрузочного CD.
(27) Компьютер выключается очень долго. Как это ускорить?
Рецепт не универсальный, и не работающий во всех 100 процентах случаев, но помогающий достаточно часто. Причиной того что ХР долго выключается является, зачастую, то что не все процессы выгружаются правильно, и система ждёт, когда их можно будет убить. Регулируется это ключом WaitToKillServiceTimeout, расположенным по адресу HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control Значение этого ключа определяет время в милисекундах, которое система и выжидает. По умолчанию это 20000, что означает 20 секунд, которые прибавляются к времени затрачиваемому системой на выключение компьютера, если какая то служба или программа не выгружается по человечески. Измените его на 5000, и всё пойдёт гораздо быстрее. Но не ставьте слишком мало, потому что в этом случае вы можете столкнуться с ситуацией когда ХР будет убивать программы раньше, чем они будут успевать сохранить свои данные. Что тоже плохо.


WinXPFAQ -> Восстановление

Восстановление
(1) Система не загружается, что делать?
Восстановить систему в XP будет гораздо проще, если заранее об этом позаботиться. Наиболее радикальным методом будет сохранение всех основных системных файлов. Для этого, в Properties жёсткого диска выберите закладку Tools и нажмите на кнопку Backup now..., а лучше через Start -> Programs -> Accessories -> System Tools -> Backup. В открывшемся окне выбираем закладку Backup, и отмечаем галочкой System state. Далее остаётся только нажать на Start Backup.

К недостаткам этого метода можно отнести то, что созданный файл с расширением *.bkf займёт около 200МБ места на диске, и для того чтобы воспользоваться им, необходимо иметь работающую систему. То есть, он не спасёт Вас от полной переустановки системы, он просто поможет восстановить Вам все свои настройки и позволит не переустанавливать заново некоторые программы.
Поэтому мы предлагаем воспользоваться менее радикальным методом и сохранить только содержимое папки С:\WINDOWS\system32\config: это займёт всего 10-30МБ. Точный список файлов реестра XP можно посмотреть здесь: HKEY_LOCAL_MACHINE\System\CotnrolSet\Control\HiveList\ Причём для этой цели можно и не пользоваться каким-либо дополнительным софтом, а просто скопируйте их в другое место. Файлы, содержащиеся в этой папке включают в себя весь реестр XP, поэтому все проблемы связанные с реестром решаются просто перезаписыванием сбойного реестра старым, гарантированно работающим. Сделать это можно, например, загрузившись с любой досовской загрузочной дискеты.
Однако, если системный раздел отформатирован под NTFS, то Вы не сможете увидеть его, загрузившись с простой досовской дискеты. Вам придётся использовать NTFS драйвер для DOS или Win98. Найти их можно на http://www.sysinternals.com.
Штатными средствами, можно только загрузиться с загрузочного CD XP. После загрузки Вам будет предложено установить систему заново или восстановить её с помощью Recovery Сonsole. Выбрав пункт Recovery Сonsole нам предложат выбрать, какую из инсталляций XP необходимо отремонтировать (если в системе их несколько), потом спросят пароль администратора. После этого Вы окажетесь в интерфейсе командной строки. Список поддерживаемых команд невелик: с ним можно ознакомиться командой "help". Для того, чтобы перезаписать реестр можно воспользоваться командой "copy". Кроме этого, стоит отметить ещё несколько команд. Во-первых, это команды "listsvc", "disable" и "enable". Первая выдаёт список системных служб и драйверов с информацией о способе старта. Вторая позволяет отключить службы, которые являются источником проблем. Ну а третья, позволит Вам наоборот, включить службы или драйвера. Во-вторых, можно отметить команды "fixboot" и "fixmbr", которые восстанавливают загрузочные файлы и master boot record.
Для того, чтобы попасть в Recovery Соnsole вовсе не обязательно использовать загрузочный CD. Можно установить её на жёсткий диск, тогда каждый раз при загрузке Вы сможете выбирать нужное: загружать систему полностью или загружаться в Recovery Console.
Чтобы установить Recovery Console нужно из командной строки в директории i386 дистрибутива XP набрать winnt32.exe /cmdcons. Но, вообще-то, набор команд доступных с консоли весьма ограничен, и мы бы посоветовали Вам в случае каких-либо неприятностей ставить винт на другую машину, с установленной XP или W2k, она увидит NTFS5 раздел и позволит с ним нормально работать. Если же такой возможности нет, и Вы склоны к экспериментам со своей машиной, то стоит системный раздел отформатировать под FAT32. В противном случае возможна ситуация, когда при крахе системы Вы не сможете добраться до своих данных.
Восстанавливать систему можно при помощи Windows Automated System Recovery Disk. Для этого этот диск необходимо предварительно создать. Сделать это можно в окне Backup wizard-а нажатием на кнопку Automated System Recovery Wizard. Правда, при создании этого будет бакапиться всё содержимое системного диска, так что решайте сами, надо ли оно Вам.

Для использования Windows Automated System Recovery Disk нужно загрузиться с загрузочного диска XP (или запустить winnt.exe из директории i386 дистрибутива) и нажать на F2 в начале загрузки, когда соответствующая надпись будет на экране.
Если система загружается хотя бы в safe mode, можно попробовать загрузиться в safe mode с поддержкой командной строки и дать команду "chkdsk /r".
С помощью этих методик можно решить множество возникающих проблем, но далеко не все. Например, ни одна из них не поможет, если в системе установлено неверное ядро.
Более радикальным методом является использование System Restore, пришедшем в XP из WinME. Справедливости ради стоит сказать, что System Restore в XP сделана гораздо толковее, чем в его предшественнике. Запустить этот апплет можно из меню Start -> Programs -> Accessories -> System Tools -> System Restore.При запуске этого апплета Вам будет предложено два выбора, сохранить текущее состояние системы, или восстановиться с сохраненного ранее. Выбирайте то, что нужно, и просто следуйте инструкциям на экране.

(2) Как восстановить повреждённый загрузчик XP?
Загрузиться в Recovery Console и дать команду FIXBOOT. Ещё можно использовать программу Bootpart, загрузившись с досовской дискеты и дав команду "bootpart winnt boot:c:". Кроме того, при помощи этой программы легко конфигурируется загрузка любых ОС NT загрузчиком. Взять программу можно на http://www.winimage.com/ - это официальный сайт её автора.

Кроме этого, всегда можно воспользоваться более радикальным методом, и запустить заново инсталляционную программу XP, и выбрать там отремонтировать текущую инсталляцию.

(3) Пропали куда-то системные шрифты под XP, или вообще, система начала вести себя как то странно, перестали работать некоторые программы, появились глюки, которых раньше точно не было. Как это можно исправить?
В командной строке вводишь sfc.exe /scannow - проверить системные файлы (к ним относятся и шрифты) и поставит обратно (возможно, при этом попросит компакт-диск). Естественно, эта методика решит проблему с другими повреждениями системных файлов. Если это не помогает, то можно запустить инсталляцию XP из под XP, и выбрать пункт Upgrade to Windows XP.
(4) Как поменять ядро системы?
В XP этот процесс упрощён до предела. Больше не надо переставлять всю систему, или использовать внешние утилитки из Resource Kit-а. Ядро меняется в Device Manager -> Computer, как и любой другой драйвер.

Но, это ИСКЛЮЧИТЕЛЬНО важно, НЕ СТАВЬТЕ ядро, которое не держится железом. Если не уверены, то лучше ничего не трогать, потому что последствия установки неправильного ядра непредсказуемы. Скорее всего машина просто перестанет загружаться, во всех режимах. Предотвратить подобное можно подредактировав boot.ini. Нужно всего лишь продублировать рабочий пункт меню выбора ОС, например,
multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Professional" /fastdetect
и приписать после /fastdetect следующие опции: /kernel=ntoskchk.exe /hal=halchk.dll,
а также в директории WINDOWS\System32 сделать копии вашего ядра и HAL-а. Назвать их, конечно же, надо ntoskrnl.exe -> ntoskchk.exe и hal.dll -> halchk.dll.
Кроме этого, необходимо учитывать одну тонкость. Видимо из за того, что при установке неправильного ядра XP просо виснет, теперь весь список доступных ядер не выводиться в окне смены драйвера. Таким образом, возможна ситуация, когда Вы точно знаете, что ядро поддерживается системой, но система не даёт его установить. В этом случае, придётся делать это вручную. Для начала найдите в windows\inf файл под названием hal.inf. После этого, изучите его, что бы выяснить, какие файлы и куда переписываются при смене ядра. Обычно перезаписывается только hal.dll, названия какого hal какому ядру соответствуют, можно узнать из списка:

  • Standard PC - hal.dll
  • Advanced Configuration and Power Interface (ACPI) PC -halacpi.dll
  • ACPI Uniprocessor PC - halaacpi.dll ACPI Multiprocessor PC -halmacpi.dll
  • Compaq SystemPro Multiprocessor or 100% Compatible - halsp.dll
  • MPS Uniprocessor PC -halapic.dll
  • MPS Multiprocessor PC -halmps.dll

После этого остаётся "выдрать" соответствующий файл из Windows\Driver Cache\i386\driver.cab, скопировать его с Windows\system32, и сослаться на него в boot.ini. После загрузки (если повезёт :-)), можно переставить его по нормальному, в списке это ядро появится.

(5) Как в Recovery Console получить доступ в папки, отличные от \WINNT?
Под аккаунтом администратора заходим в Control Panel -> Administrative Tools. Далее - запускаем апплет Local Security Policy -> Local Policies -> Security Options, опцию "Recovery Console: Allow floppy copy and access to all drives and folders" устанавливаем в Enable. После этого перегружаемся в режим Recovery Console и даем команду SET AllowAllPaths = TRUE.
(6) Можно ли восстановить информацию из зашифрованного средствами XP файла?
Если не позаботится об этом заранее, то нет (и это логично, ведь шифрование для этого и задумывалось). Ключ, с помощью которого шифруются данные в XP уникален для каждого пользователя в каждой инсталляции, он имеет длину до 128 байт, Шифрование работает на уровне драйверов непосредственно через ядро системы, а ключ хранится в профиле пользователя, поэтому после переустановки системы или удалении пользователя он теряется. Создание другого пользователя с таким же именем и паролем для входа в систему проблему абсолютно бесполезно, и проблему не решает. Единственное приемлемое решение – это сохранение необходимых сертификатов и ключей, или заблаговременное создание Encrypted Data Recovery Agent. Подробнее про это можно почитать здесь http://www.3dnews.ru/reviews/software/win-xp-encrypting/


WinXPFAQ -> Шрифты

Шрифты
(1) Вместо русских букв в некоторых программах показываются закорючки.
Запустите апплет Control Panel -> Regional and Languadge Options. На закладке Regional Options есть два раздела, Standarts and formats и Location.

Первый раздел настраивает локаль для конкретного пользователя и отвечает за то, в каком виде и на каком языке пишется дата, время, какие меры длины используются и так далее. В нашем случае его лучше всего ставить Russian. Второй пункт отвечает, в том числе, и за системные шрифты, это как раз то, что нам и нужно. Необходимо убедиться, что там выставлена Russia. Кроме этого, на закладке Advanced надо выставить Language for non-Unicode programs в Russian.

После этого, при отображении всех менюшек и сообщений, XP будет использовать русскую кодировку. Конечно же, это никак не повлияет на латинские буквы.

(2) В DOS-приложениях не переключается раскладка клавиатуры на русскую, хотя русские буквы отображаются нормально.
Для решения необходимо в реестре по адресу:

HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> Control -> KeyboardLayout

изменить значение ключа 00000409 в папке DosKeybCodes на "ru".

Кроме этого, в файле "autoexec.nt", расположенном в Windows\system32, надо добавить строку "lh %SystemRoot%\system32\kb16.com ru". После перезагрузки переключение раскладки клавиатуры в DOS-приложениях будет производиться комбинациями Ctrl+Left Shift (английская) и Ctrl+Right Shift (русская). Данный метод нормально работает в том случае, если Language settings for the system (апплет Regional Options) в качестве Default стоит Cyrilic.
Если Вас не устраивают возможности предоставляемые системой, можете поставить внешний русификатор, например, проверенный временем RKM v.3.0. Удобнее всего прописать его в файле autoexec.nt (аналогично kb16). Можно взять здесь: http://www.chem.univ.kiev.ua/~adsh/win2k/soft/rkm.php

(3) Региональные настройки настроил, но всё равно, в некоторых местах (например в Photoshop) показываются закорючки.
Этот метод не совсем корректен. В ключе реестра [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage] изменяем значение параметра "1252" на "c_1251.nls" Обычно этот метод применяют для Photoshop, но он применим и для некоторых других программ. Правда, могут начаться проблемы с русскоязычными программами. Поэтому, мы бы советовали экспортировать этот ключ из реестра, и создать два *.reg файлика, один из которых будет учить такие программы русскому языку, а другой возвращать всё в прежнее состояние. В случае с Photoshop для кардинального решения проблемы следует воспользоваться вот этим ps601patch110.rar патчем. Для его использования необходимо пропатчить Photoshop до версии 6.01, что можно сделать скачав патч отсюда ftp://ftp.adobe.com/pub/adobe/photoshop/win/6.x/ps601up.exe
Еще одним решением, является использование Photoshop 7 версии, в нём (наконец то) нет проблем с национальными раскладками.
(4) Как включить antialiasing шрифтов в XP?
Делается это в Display Properties, закладка Appearance, кнопка Effects...Надо поставить галочку напротив Use following metod to smooth edges if screen font.

Выбрав Standard, вы включите стандартную поддержку АА, которая была в ОС от Microsoft ещё со времён W95, включается при большом размере фонтов, поэтому в повседневной работе мало чем отличается от полного отсутствия АА. Выбрав ClearFont, Вы задействуете технологию, изначально придуманную Microsoft для LCD экранов, и ранее использоваемую в Windows CE. Этот метод прекрасно показывается на современных CRT мониторах, и даёт реальный AA, причём везде, ко всех приложениях, всех окошках, и т.д..

Нормальные шрифты:

Clеar Type шрифты:

Того же эффекта можно добиться и через реестр, HKEY_USERS\.DEFAULT\Control Panel\Desktop, присвойте ключу FontSmoothingType значение 1 - если хотите Standard AA, 2 - если хотите ClearType, и оставьте 0, если ничего не хотите. Но, в последнем случае придётся перезагрузить компьютер.


WinXPFAQ -> Железо

Железо
(1) Где мне найти драйвер для моей железки?
Первое, где надо начать поиски, это, конечно же, сайт производителя Вашего устройства. Правда, драйвера написанного специально для XP может просто не существовать. В этом случае попробуйте использовать драйвер для Windows 2000, из за схожести W2k и XP есть хорошие шансы что этот драйвер подойдёт. Драйвер лучше ставить вручную, через Update Driver в Properties устройства (из закладки Hardware в System Properties), указав Install from the list of specific location. Если пустить это дело на самотёк, и доверить XP самостоятельно искать и устанавливать драйвер, то можно столкнуться с ситуацией, когда система не примет вполне работоспособный драйвер на том основании, что он не писался для XP, и не прошёл соответствующей сертификации. Сложнее, когда нет возможности ручной установки, и драйвер должен ставиться через программу установки, так называемый Wizard. В этом случае может ругаться как сам инсталлятор (мол, неправильная ОС), так и XP (мол, неправильный драйвер). В этом случае следует либо попытаться обмануть инсталлятор (в Properties - Compatibility файла или ярлыка). Если не охота каждый раз возиться с Compatibility, можете попробовать, в ветви реестра [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion] поменять два ключа "ProductName"="Microsoft Windows XP" и "CurrentBuildNumber"="2600" на "ProductName"="Microsoft Windows 2000" и "CurrentBuildNumber"="2195", хотя в этом случае могут возникнуть проблемы с драйверами предназначенными для XP.
Если ничего не поможет, можно попытаться поставить драйвер вручную. Для этого, сначала очистите временную папку, потом запустите инсталлятор, и когда он выкинет первое окно с вопросом, посмотрите содержимое временной папки. Очень возможно, что Вы увидите в ней *.inf файлик и всё остальное необходимое для ручной инсталляции. Просто скопируйте это в надёжное место, и используйте впоследствии.
Если ни один из вышеприведённых советов не приведёт к желаемому результату, останется только бомбить письмами Technical Support производителя. Впрочем, с этого можно и начать.
(2) Машина с ATX блоком питания не выключает питание самостоятельно.
Основным режимом работы для XP считается ACPI режим, и именно вокруг ACPI построено управление питанием. Проблема в том, что до выхода W2k и XP все возможности ACPI нигде толком не использовались. Поэтому производители железок не сильно заморачивались с обеспечением нормальной поддержки оного. Что привело к проблемам с работой таких устройств под w2k. То есть, само устройство может работать нормально, но когда система пытается управлять питанием, например выключить компьютер, то проблемное устройство не даёт ей этого сделать. Для решения этих проблем в XP предусмотрен APM режим, но даже он не всегда решает проблему. Но всё по порядку. Прежде всего необходимо выяснить, Ваша машина работает в ACPI режиме, или нет. Для этого можно обратиться в System Properties, но выяснить и через Control Panel - Power Options. При использовании стандартного ядра, это окно будет выглядеть так:

Кроме этого, в этом окне может присутствовать закладка APM. Если она есть, то надо убедиться что на параметре Enable Advanced Pоwer management support стоит галочка. Если ничего похожего нет, то Вам может помочь установка NT Apm/Legacy Support. Для того чтобы про проверить установлена ли она, необходимо в Device Manager выбрать меню View - Show hidden Devices. В списке добавившихся устройств Вы должны увидеть NT Apm/Legacy Interface Node. Если его нет, то установите его через Add New Hardware Wizard. После этого, взгляните в Device Manager ещё раз. Если NT Apm/Legacy Interface Node функционирует нормально, а компьютер всё равно не выключается, то попробуйте по адресу HKEY_LOCAL_MACHINE -> SOFTWARE -> Microsoft -> Windows NT -> CurrentVersion -> Winlogon выставить ключ PowerdownAfterShutdown равным 1. Если железо (ВСЁ железо) позволяет (строго соответствует требованиям стандарта) всё должно заработать.

Примечание. Нормальная работа компьютера под W9x ничего не гарантирует, у некоторых железок поддержка APM функций в её среде сделана не правильно, не через стандартные методы, а всевозможные «хаки», как аппаратные так и программные. Естественно, что такое оборудование не будет нормально работать с функциями управления питанием в среде XP, и будет препятствовать выключению компьютера.

Если NT Apm/Legacy Interface Node появился в Device Manager, но не работает (обозначен жёлтым кружком с восклицательным знаком, или чем то вроде этого), это значит что Ваш компьютер не соответствует представлениям Microsoft о современном компьютере, и пока причина этого не устранена, увы, компьютер самостоятельно выключаться не будет. Причиной столь печального явления, обычно является материнская плата, и есть шанс, что обновлением Bios это можно решить. Более того, обновление Bios может сделать Вашу материнскую плату ACPI совместимой. В этом случае (при использовании соответствующего ядра) окно Power Options будет выглядеть так:

ACPI режим считается основным для XP, поэтому проблемы с выключением при его использовании бывают гораздо реже. Если они всё-таки возникают, то причиной этого может быть как плохой Bios, так и не соответствующее требованиям ACPI устройство или драйвер (хотя в этом случае система чаще виснет при выключении, а не выкидывает окно с просьбой выключить компьютер вручную). Поэтому поиски решения стоит начинать, прежде всего, на сайте производителя Вашей материнской платы, в разделе биосов. Если это не поможет, то можете попробовать повытаскивать из компьютера все необязательные устройства, возможно что именно так удастся отловить проблему. Вообще, причины неправильной работы ACPI могут быть самыми разными, и найти что именно мешает бывает совсем не просто.

Наиболее часто встречаются следующие причины:

  • Не соответствие материнской платы требованиям ACPI. Хорошо если проблема кроется только в BIOS, что решается его обновлением, но иногда встречается и аппаратная несовместимость.
  • Не соответствие требованиям ACPI какого-либо устройства или его драйвера.

Опять же, хорошо если проблема только в неправильно написанном драйвере, тогда есть надежда что когда-нибудь будет написан нормальный драйвер, и всё заработает как следует. К сожалению, возможна ситуация когда несовместимость аппаратная. Причиной сбоев в работе ACPI может быть и программное обеспечение установленное на компьютере. Причём проблемы могут вызывать самые различные программы, от программ для шифрования (вроде PGP), до программ для очистки реестра. Посоветовать можно использовать только протестированные и полностью совместимые с XP версии программ что, к сожалению, не всегда возможно. Кстати, несовместимость программного обеспечения может приводить не только к тому что компьютер не будет выключаться вообще, но и к тому что компьютер будет выключаться, но очень медленно (окно с надписью saving you settings может висеть 5, 10 или даже 30 минут).

(3) Как получить поддержку функций управления питанием на SMP машинах?
Как уже упоминалось выше, спецификации APM не предусматривают существования многопроцессорных систем поэтому бесполезно даже искать закладку APM в Control Panel -> Power Options если в системе установлено многопроцессорное ядро. Единственный выход - это использовать ACPI Multiprocessor ядро. Однако, для этого вы должны иметь ACPI совместимую систему. Если ваша система не соответствует, можно попробовать обратиться к производителю вашей материнской платы за обновлённым BIOS, зачастую это решает проблему. Если же ваша система успешно проходит эти тесты, можно попробовать поменять ядро на ACPI multiprocessor.

НО, НЕ СТАВЬТЕ ACPI ядро на машины BIOS или железо которых не поддерживает его, в этом случае компьютер гарантировано перестанет загружаться, и вам придётся переставлять всю систему. Если же, всё-таки, решились на такой эксперимент, то, по крайней мере, обеспечьте себе возможность альтернативной загрузки с другим ядром. Про то, как это сделать, написано в этом FAQ. Впрочем, даже соответствие материнской платы спецификациям ACPI не гарантирует нормальную загрузку системы после замены ядра. Однозначного рецепта здесь нет, но если система после замены ядра доходит до этапа графической загрузки (это когда рисуется цветная картинка), то это означает что, скорее всего, ваша машина сможет работать в ACPI режиме. Но, скорее всего, придётся переустановить всю систему. Кроме этого, даже если установка системы прошла удачно, это не гарантирует, что система будет полностью поддерживать ACPI (Hibernate, Stand-By, программирование Power button, и т.д.), более-менее уверенными вы можете быть только в том, что машина будет самостоятельно выключать питание. Для поддержки всего спектра возможностей ACPI необходима поддержка не только со стороны материнской платы, но и со стороны установленной на ней устройств и их драйверов. Например, поддержка Hibernate может пропасть после установки XP драйвера для Voodoo3, или Sound Blaster128. Список этот гораздо длиннее, так что ничему не удивляйтесь после установки ACPI ядра.

(4) При работе полноэкранных Direct3D и OpenGL приложений, очень низкий refresh rate, как можно это исправить?
Сделать это можно, и связано это с тем КАК NT работает со своей графической подсистемой. Есть несколько способов. Если драйвера видеокарты позволяют, то делается это легко и красиво. На примере с референсными драйверами от nVidia, это делается так:

В архиве с драйверами есть файл nv4_displ.inf, а в нём раздел nv_SoftwareDeviceSettings. Ищите там раздел относящийся к вашей видеокарте, первая TNT, например, обозначается аббревиатурой NV4. В списке NV4_MODES просто удаляете ненужные значения. Например, оригинальная запись выглядит так:
HKR,, NV4_Modes, %REG_SZ_APPEND%, "16 640 480 60 70 72 75 85 100 120 0"

Приводим её в такой вид:
HKR,, NV4_Modes, %REG_SZ_APPEND%, "16 640 480 100 120 0"

И всё, теперь ваша видеокарта физически не сможет работать в разрешении 640*480 с глубиной цвета 16 бит с Refresh rate меньше, чем 100 герц в любых программах (Во всяком случае XP именно так и считает, поэтому будет использовать для Refresh Rate цифры, которые здесь указаны). После этого нужно всего лишь переустановить драйверы с измененным nv4_displ.inf.

Естественно, цифры можно ставить любые, даже нестандартные. Однако, здесь надо соблюдать осторожность, потому что существует возможность испортить монитор слишкой высокой Refresh Rate либо после перезагрузки вы не увидите своего десктопа, вообще ничего. Эта методика подходит и для других драйверов не только от nVidia, например, SiS.

Однако, этот совет из не подходит для пользователей многих весьма популярных видеокарт, например таких как Voodoo, Matrox, или ATI. Однако, они тоже не хотят портить себе зрение смотря на 60 герцовую картинку в OpenGL, Direct3D, Glide или каких либо других приложениях. В этом случае, можно попытаться сказать XP, что ваш монитор не способен работать с refresh rate ниже той, что нам требуется. Для этого можно воспользоваться нашим "хакнутым" драйвером монитора http://www.3dnews.ru/documents/971/hackmon.zip.

Редактируя строки вроде:
HKR,"MODES800,600",Mode1,,"35-90,85-100,+,+"
можно добиться желаемого. Например, в нашем примере эта строка запрещает монитору работу в 800*600 с любыми рефрешами кроме 85 или 100 Hz, в ЛЮБЫХ режимах. Удостоверьтесь, только, что отмечен чекбокс "Hide modes that this monitor cannot display". Но, будьте осторожны, и используйте только те значения, которые реально поддерживаются вашим монитором, в противном случае последствия могут быть неприятными, вплоть до ПОЛНОГО ВЫХОДА МОНИТОРА ИЗ СТРОЯ.
Если у вас карта nVidia, то вы можете воспользоваться специальной утилитой nVidia refresh rate fix. Скачать можно здесь - http://www.3dnews.ru/download/tools/nv_refresh_fix/

(5) Ничего не получается с hackmon.inf, чего делать?
Если hackmon.inf у вас по какой то причине не работает, то можно попробовать отредактировать соответствующие значения реестра вручную. Для этого заходите в HKEY_LOCAL_MACHINE \SYSTEM \ControlSet \Enum \DISPLAY, и дальше на две папки вглубь (их название зависит от установленного у вас монитора, поэтому я не привожу никакого). В этой папке должны быть несколько ключей, в том числе CalssGUID и Driver. Берём название драйвера (это будет 4D36E96E-E325-11CE-BFC1-08002BE10318, стандартное значение для мониторов), идём в начало реестра и делаем поиск на это значение. Оно встретится несколько раз, в HKEY_LOCAL_MACHINE \SYSTEM \ControlSet \Control \Class \4D36E96E-E325-11CE-BFC1-08002BE10318 \0000 (или 000х, если в системе стояло несколько мониторов, тот что вам нужен прописывался в ключе Driver, в предыдущем абзаце), и его копиях, ControlSet00x. В этих разделах находим Modes, и видим папки для каждого из стандартных разрешений. Если не видим, то можно и самому добавить. В каждой из них имеется ключ Mode1, который и определяет значения Refresh Rate для этого разрешения. Ключ этот имеет значения "30-96, 60-120,+,+", или что-то похожее, где первые две цифры означают возможные значения вертикальной развёртки в килогерцах, а вторые две значение горизонтальной развёртки в герцах. Меняете на то, что по вашему мнению (а лучше по паспорту монитора) правильно, и наслаждаетесь результатом. Если результатом является пропадание разрешения из Display properties, значит много поставили. Так что придётся либо снизить частоту горизонтальной, либо повысить верхний предел вертикальной развёртки. Только не перестарайтесь.
(6) Как поменять IRQ используемые различными устройствами? В их Properties в Device manager чекбокс Use automatic Settings затемнён, и снять его не удаётся.
Наиболее "правильным" и простым методом является отключение поддержки ACPI во всех видах. Для этого необходимо поменять ядро на Standart PC (или MPS multiprocessor в случае с SMP системой). Не будет лишним отключить ACPI контролёр в Bios, раздел Power management. Кроме этого, может помочь выключение всех PnP функций в Bios. Даже если чекбокс Use Automatic Settings и останется затемнённым, система будет распределять прерывания так, как они распределились Bios'ом, поэтому переставив карту в другой слот, или переназначив ей IRQ в Bios (конечно, если Bios поддерживает такую функцию), можно добиться желаемого. Очевидным минусом этого метода является то, что с высокой долей вероятности машина перестанет самостоятельно выключаться.
(7) На моём CD-ROM нет CD-CPDIF выхода, или, по какой то причине я не могу его использовать. Можно ли мне как-нибудь получить числовой звук для CD-Audio?
Можно. XP позволяет передавать audio информацию с AudioCD через IDE шлейф в числовом виде. Для того что бы задействовать эту функцию, достаточно в Device Manager на Properties CD привода на второй закладке выставить галочку в чекбоксе "Enable Digital CD-Audio for this CD-ROM device." Естественно, что после этого вам не потребуется проводок который обычно подключают от CD-ROM к звуковой карте, всё будет идти через IDE шлейф.
(8) Мой 12х CD Recorder записывает диск за 15 минут, а должен за 6. А везде пишется, что запись прошла на скорости 12x, почему так происходит и что делать?
Причина такого печального явления заключается в том, что в процессе записи опустошается буфер (что можно наблюдать в окне мониторинга записывающей программы), и привод, что бы не испортить записываемый диск сбрасывает скорость записи. Эта технология называется burnproof. Для борьбы с опустошением буфера прежде всего необходимо убедится, что установлен достаточно свежий aspi layer. Взять его можно здесь http://www.3dnews.ru/documents/971/forceaspi17.zip. Если проблема не исчезнет, значит привод не очень хорошо уживается с вашим IDE контролёром. Для устранения этого досадного недоразумения достаточно отключить в BIOS режим UDMA для IDE канала на котором висит рекордер. Это заставит его работать в режиме PIO4, что приведёт к несколько более высокой загрузке процессора при работе с приводом (что не совсем не критично при современных мощностях процессоров), зато избавит вас от проблем с опустошением буфера. DMA режим отключать надо только в BIOS, под Windows он может (и должен) быть включён. Если нет желания отключать UDMA, то можно попробовать выставить привод на отдельный шлейф в качестве Master устройства, в полном одиночестве (без Slave).
(9) В Stand by режиме не выключаются вентиляторы на блоке питания и процессоре.
Переключите в BIOS, в разделе Power Management Suspend Mode из ST1 на ST3.
Но учтите, что выключение вентиляторов правильно работает только в ACPI режиме, поэтому первое, в чём необходимо убедиться, это что Ваш компьютер работает под управлением ACPI ядра. Кроме этого, правильная работа stand by во многом зависит от правильности поддержки ACPI со стороны BIOS, поэтому есть целый ряд машин на которых добиться этого просто невозможно.
(10) После перезагрузки XP не находит внешний модем. Что делать?
Если не включить внешний модем перед загрузкой XP, то система может и не найти его. Для того что бы «разбудить» его, достаточно зайти в Device Manager, и произвести поиск новых устройств (Scan for hardware changes), модем будет найден и включен. Того же эффекто можно добиться вот этой rescan.rar программкой. Что бы не приходилось этого делать каждый раз, когда Вы забудете включить модем перед загрузкой системы, придётся поставить не PnP версию драйвера для этого модема. Поискать её можно в *.inf файле для этого модема (для чего достаточно указать при установке что драйвера будут ставится вручную, и что надо показывать все устройства, а не только совместимые). Если там такой версии нет, то придётся ограничиться установкой какого-либо стандартного драйвера, например Standart Modem. Если Ваш модем соответствует понятиям системы о стандартном модеме (а это так и есть с большинством модемов для COM порта), то всё будет славно работать, вне зависимости от того, сколько раз и когда модем включался и выключался.
Недостатком этого метода является то, что для Standart Modem нельзя включить некоторые полезные настройки, например аппаратную компрессию данных. С другой стороны, для него всё равно можно задать строку инициализации, и если изучить инструкцию к модему, то в этой строке можно включить и настроить всё что угодно.
Ещё одним вариантом решения проблем с внешними устройствами является использование режима Hibernate вместо полноценной перезагрузки системы. Ну и, наконец, можно один и тот же модем установить два раза (можно даже оба раза PnP). Тогда, как ни странно, хоть система и не найдёт первый модем после загрузки, она сможет работать со вторым. Конечно же, второй можем должен быть указан в свойствах соединения.
(11) Как заменить материнскую плату без переустановки системы?
Меняя материнскую плат учтите, что благодаря механизму активации XP система жёстко привязывается к железу, и замена слишком большого количества оборудования (сейчас это больше трёх. В ближайшем будущем Microsoft обещает увеличить это количество до 5) приведёт к тому, что система перестанет работать, и потребует активировать её ещё раз.
Что касается самой замены, то перед сменой платы в Device Manager в разделе IDE ATA/ATAPI Controllers поменяйте Bus Master IDE контролёр установленный там на Standart Dual Channel PCI IDE Controller. Если этого не сделать, то при загрузке на новой материнской плате система может не найти жёсткого диска, и Вы получите сообщение про "inaccessible boot device".
(12) CD-ROM постоянно сбрасывается в PIO режим, и не хочет выставляться обратно в UDMA.
Это происходит если XP обнаруживает что устройство не стабильно работает в выбранном для него режиме. Определяется это по количеству ошибок чтения, получаемых с привода. Обычно это означает что привод находится в плохом состоянии, и про правде ему надо бы на покой. Но выбрасывать вроде бы работающий привод жалко, поэтому такие устройства можно встретить в машинах наших читателей. Хотя, благодаря механизмам контроля ошибок, многие такие приводы могут работать долго, счастливо и беспроблемно, не смотря на мнение XP о них. Единственное, что портит кровь их владельцам, это постоянные тормоза системы, из за PIO режима. У меня нет полной уверенности, как работает и чем управляется система контроля ошибок в XP, поэтому я не могу гарантировать что этот совет сработает во всех случаях. Но попробовать можно.

Для отключения режима отслеживания ошибок можно попробовать выставить в 0 ключ ErrorControl расположенный по адресу HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdfs\

Для того что бы вернуть режим UDMA, лучше всего удалить и поставить заново IDE контролёр из Device Manager. Но можно вновь обратится к реестру. Параметры контролёра определяются в реестре, по адресу

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}

Внутри этой ветки находится 4 папки. В том числе и

0000 – отвечает за сам контролёр.
0001 – отвечает за Secondary IDE Chanell.
0002 – отвечает за Primary IDE Chanell.

Выбираем папку которая отвечает за нужный нам канал, и заходим в неё. Каждому из установленных устройств, соответствуют по два ключа, MasteDeviceTimingModeAllowed и SlaveDeviceTimingModeAllowed (или UserMasteDeviceTimingModeAllowed и UserSlaveDeviceTimingModeAllowed, если режимы выбирались вручную), определяющие в каком максимальном режиме разрешается работать Master и Slave устройства, установленные на контролёре, и MasterDeviceTimingMode и SlaveDeviceTimingMode, которые определяют в каком режиме реально работают Slave и Master устройства. Для того что бы разрешить использовать устройство в UDMA режиме, MasterDeviceTimingModeAllowed (или Slave…, зависит от того к чему диск подключен) должно иметь значение 0хffffffff. Если оно будет 0х0000001f, то устройство сможет работать только в PIO режиме. Убедившись что этот ключ стоит правильно, выставляем MasterDeviceTimingMode, определяя в каком режиме должен работать привод. Возможны следующие варианты (цифры в HEX):

0x10010 режим UDMA Mode 5 (ATA100).
0x8010 режим UDMA Mode 4 (ATA66).
0x2010 режимы UDMA Mode 2 (ATA33).
0x0410 режим Multi-Word DMA Mode 2 и PIO 4.

Кроме этого, UDMA Mode 4 можно включить 0xffff, а UDMA Mode 5 – 0xfffff. Выставляйте нужное, и перезагружайтесь, диск должен перейти в требуемый режим.
(13) Как установить старую, не PnP но NЕ2000 совместимую сетевую карту?
Как ни странно, это простое действие иногда вызывает затруднения, и можно услышать советы даже выкинуть такую сетевую карточку. Между тем, это совсем не обязательно, она может вам ещё послужить. Для этого вам понадобится вот этот novel2000.rar файлик. Запускаем мастер добавления новых устройств (Control Panel -> Add Hardware), нажимаем на Next до тех пор пока не появится список устройств. Выбираем Add a new hardware device, в следующем окне выбираем пункт Install the hardware that I manually select from a list (Advanced), ведь карточка не PnP, и самостоятельно ХР её, скорее всего, не найдёт. Нажимаем на Next, выбираем в списке Network Adapters, нажимаем на Next, жмём на Have Disk..., указываем на netnovel.inf, из архива упоминавшегося выше, и получаем возможность выбрать из кучи старых сетевых карточек. Файл ne2000.sys, входящий в архив, вам скорее всего не понадобится, потому что точно такой же входит в базовый набор драйверов ХР, но если возникнут какие-либо проблемы, то можно использовать и тот что в архиве. Настраивая сетевую карточку позаботьтесь о том, что бы те ресурсы которые будут выделены её ХР соответствовали реально ей используемым.


WinXPFAQ -> Проблемы

Проблемы
(1) Что то не работает, как найти причину?
Вообще-то, этот вопрос не относится к какой либо из конкретных операционных систем, и опытные пользователи прекрасно знают ответ на него, но анализируя ваши письма мы пришли к выводу, что лишним он не будет. Прежде всего, необходимо локализовать источник проблем. Поиски следует начать с ответа на вопрос: с чего всё началось? Было ли время, когда подобной проблемы не было? Что изменилось с тех пор? Для того, что бы было проще отвечать, можно посоветовать воспользоваться методикой используемой при администрировании больших серверов, и вести журнал изменений, в который записывать все изменения которые были сделаны в настройках системы, и когда что было инсталлировано, но в домашних условиях данная методика вряд ли является оправданной. В любом случае, если когда-то проблемы не было, значит, она является решаемой, и не столь важно, даже если не удаётся сразу вспомнить, с чего всё это началось, это просто несколько удлинит дальнейшие поиски. Для начала, попробуйте поставить последние драйвера на все установленные в системе устройства, особо обратив внимание на материнскую плату и видеокарту. Если и так стоят самые последние, можно попробовать сделать наоборот, и поставить те, что находятся на дисках, которые давались вместе с оборудованием при покупке.
  • В Device Manager посмотрите, нет ли IRQ или каких либо других конфликтов.
  • Выключите все Power Saving опции, в том числе и screen saver.
  • Попробуйте в BIOS установить более высокие значения таймингов памяти (то есть, замедлить её).
  • Ставим Video BIOS Casheable - Disabled, Video BIOS Shadow - Disabled.
  • Увеличиваем 8 и16 bit I/O Recovery Time
  • Удостоверяемся, что Assign IRQ for VGA - Yes
  • Уберите все разгоны (если у Вас что нибудь разогнано), можно попробовать поднять (НЕМНОГО, на 0.05 максимум на 0.1V) напряжение процессора.
  • Не будет лишним проверить работу всех вентиляторов, возможно, что какой нибудь из них неисправен, и система просто перегревается.
  • В BIOS отключаем AGP (AGP Aperture size - на минимум), выключаем AGP2x и AGP4x

Если вышеперечисленное не помогает, или по каким то причинам не подходит, то, предположив, что проблема имеет корни в каком либо неисправном устройстве, можно перейти к более решительным мерам.

  • Удаляем (физически) из системы все устройства, без которых система может работать (оставить только материнскую плату, память, винчестер, и видеокарту), в BIOS отключаем всё, что можно (COM и LPT порты, все Power Options, Assign IRQ for USB (не трогаем Assign IRQ for VGA!)).
  • Если есть вероятность что проблема с винчестером, в BIOS принудительно ставим ему PIO 4, или даже PIO 2 mode.
  • Если проблема не пропала, проверяем всё оставшиеся устройства (видеокарту - память - процессор - материнскую плату и винчестер). Наиболее простой способ - установить устройство на другую машину и посмотреть, как оно себя там поведёт.

Если же после удаления всех лишних устройств проблема пропала, то надо по очереди ставить удалённые устройства на место, и после КАЖДОГО включать систему и проверять "самочувствие". Если проблема в неисправном оборудовании, то, как правило, таким методом её удаётся локализовать.
Впрочем, далеко не всегда приходится прибегать к столь радикальным методам, зачастую причина лежит на поверхности, и предположительно проблемное устройство удаётся вычислить сразу. Наилучшим, в этом случае, является проверить её на другой машине, а лучше и не на одной, крайне желательно, что бы их конфигурация отличалась от Вашей. Если выясниться, что железка всё-таки рабочая, то следует лучше изучить свою машину. Первое на что стоит обратить внимание, какие слоты с какими делят одно IRQ. Обычно, про это можно узнать из инструкции к материнской плате. Если инструкции нет, или лень копаться, то можно сразу попробовать плату в другом слоте (не сработает в случае с AGP видеокартой, в этом случае лучше всё-таки выяснить, какой из PCI слотов дели IRQ с AGP, и посмотреть что в нём стоит). Кстати, это поможет и в том случае, если у Вас неисправен один из слотов. Кроме этого, как это ни прискорбно, встречаются ситуации когда устройство А физически несовместимо с устройством В, например из за недостаточного питания. В большинстве случаев с этим ничего нельзя поделать, хотя бывают счастливые исключения, иногда всё приходит в норму после установки более мощного и качественного блока питания, или, как с некоторыми ASUS’скими матерями, на матери стоит джампер с помощью которого можно принудительно увеличить питание AGP слота.
Если проблема уходит корнями в программное обеспечение, то основные принципы решения такие же, удаление всего, что можно, и постепенная установка обратно с проверкой работоспособности системы после каждой инсталляции. Иногда таким методом выясняются очень интересные закономерности. Например, кто бы мог подумать, что установка PGP может привести к сообщению POWER_STAT_FAILURE при выключении машины? Ну и, конечно же, всегда остаётся радикальный метод - полное удаление старой ОС и чистая установка новой. В этом случае не забудьте очистить папку Documents and Settings, XP не перезаписывает файлы в ней (хотя и грозится), а просто создаёт новые директории. Поэтому, если не чистить эту папку, то после неоднократной переустановки системы там можно будет найти такие папки как User1.USER.000, Default User.001 и множество других. И разобраться, какие из них нужны, не всегда бывает просто.
В случае возникновения каких либо проблем с конкретным оборудованием или программным обеспечением, лучшее место, откуда следует начинать поиски решения, это служба технической поддержки производителя. Можете быть уверены, они свой продукт знают гораздо лучше чем мы.
И последнее. Если Вы всё-таки решитесь разбирать свой компьютер, то будьте осторожны и внимательны. Обязательно отключите притание от компьютера от компьютера, прежде чем разбирать его. ПОЛНОСТЬЮ, то есть вытяните его из розетки, потому что в противном случае дежурное питание в 5 вольт всё равно будет подаваться, на АТХ корпусах. Не забывайте убедиться, что в слоте, в который вы собираетесь что-нибудь вставлять, ничего нет, включая пыли. И перед установкой убедитесь, в правильной ориентации вставляемой детали. Потому что пыль обладает определённой токопроводностью, и может вызвать короткое замыкание, да и засунуть DIMM не той стороной не так невозможно, как может показаться.
(2) Help в XP какой то сильно упрощенный и урезанный. Неужели ничего толковее не могли написать?
Могли. И написали. В XP (как и в W2k) есть несколько файлов справки. Главный, тот который вызывается через пункт Help and Support, кнопки Start, и рассчитан на неквалифицированных пользователей. Писался он, как мне кажется, с расчетом "как бы они чего с большого ума не натворили", и не содержит сведений об очень многих аспектах управления системой, или содержит их в очень усечённом виде. То же самое относиться и к элементам управления. Гораздо более подробную и толковую информацию можно получить изучая файлы справки по отдельным апплетам. Наиболее полные и полезные из них можно увидеть в апплетах собранных в разделе Computer Management, из Control Panel.

И в этом нет ничего удивительного, ведь многие вещи, которые в NT можно было делать непосредственно там, где это использовалось (например выставить нормальные права доступа на расшаренный ресурс через Properties этого ресурса) оттуда убрали, и по умолчанию они стали доступны только здесь. Так что если окажется, что Вы не можете найти привычной опции там, где она всегда была и, по логике, должна быть, загляните в раздел Computer management, скорее всего её спрятали именно здесь.
(3) Почему некоторые программы не инсталлируются в XP? Запускается инсталлятор, появляется окно, в нём закрашивается индикатор до 100%, но потом всё пропадает. Процесс висит в памяти, но инсталляция не продолжается.
Это происходит когда временные папки в XP помещены в профайлы пользователей. Временные папки используются инсталляторами для распаковки временных данных, необходимых для инсталляции. Но, когда временную папку помещают в директорию профайла пользователя, у ней получается очень длинное имя, и некоторые инсталляторы благополучно распаковав в её свои данные не могут их найти. Для решения этой проблемы достаточно просто поместить папку куда-нибудь повыше, чтобы путь был коротким, и, желательно, без русских символов. Делается это через System Properties, Advanced, Environment. Меняете пути к TEMP и TMP на C:\WINDOWS\TEMP, и всё. Осталось только стереть старые папки.

Кроме этого, встречаются инсталляторы в которых прописаны абсолютные пути. Обычно этот путь выглядит как %windir%\Temp (или что-то вроде этого), и тогда никаких проблем не возникает, но иногда путь прописан более конкретно, обычно C:\Windows\Temp, и тогда инсталлятор может зависнуть не найдя этих директорий. К счастью, такие кривые инсталляторы попадаются очень редко, но если нужная программа не хочет инсталлироваться несмотря на все усилия, то можно попробовать создать указанный выше путь, может и поможет. Кроме всего вышеперечисленного, иногда помогает замена файла Setup.exe другим, из работающего инсталятора.

(4) Под XP не хотят работать некоторые программы, требующие интенсивного обращения к CD приводу, такие как Audiograbber, CDEx, программы для записи CD-RW, некоторые DVD декодеры, и т. д..
Многие программы, требующие непрерывного потока данных идущих на или с CD/DVD привод, нуждаются в правильно установленном ASPI (Advanced SCSI Programming Interface) manager. Несмотря на своё название, ASPI manager с успехом используется IDE дисками. Для инсталляции ASPI можно воспользоваться универсальным пакетом forceaspi17.zip http://www.3dnews.ru/documents/971/forceaspi17.zip. Просто разархивируйте этот пакет, и запустите instaspi.bat. Если он не сможет разобраться с тем что у Вас за ОС, изучите содержимое этого батника, и сделать всё самостоятельно, руками. Всё должно копироваться и прописываться так же как и в W2k.
(5) Моя любимая программа работает только под аккаунтом администратора :( Как сделать, чтобы она работала и под аккаунтом обычного пользователя?
Наиболее простой способ, это запустить программу через пункт Run As… в меню вызываемым правой кнопкой мыши. При этом откроется вот такое окно:

Выбираем нужного пользователя (администратора или кого-нибудь с администраторскими полномочиями), вводим пароль, и всё. Если не охота делать это каждый раз, можно создать CMD файлик, и запускать его. Для запуска программы под другим пользователем из командной строки служит команда runas, с доступными опциями которой можно ознакомиться набрав runas /?

Но даже при использовании CMD файла, всё равно придётся вручную вводить пароль для соответствующего пользователя. Что бы полностью автоматизировать загрузки, придётся воспользоваться следующей методикой. Входим в систему под аккаунтом администратора, запускаем regedit.exe, в разделе HKLM/SOFTWARE находим подраздел нужной программы. Затем в пункте Permissions, появляющемся по правому клику мышки, выставляем полный доступ на эту ветвь реестра для пользователя или группы пользователей, которые будут с ней работать. Если программа использует кроме раздела HKLM реестра ещё и раздел HKCU, нужно запустить под аккаунтом администратора Редактор реестра (regedit.exe). Hаходим ветку HKEY_CURRENT_USER\SOFTWARE\Имя_компании\Имя_программы (иногда встречатся только раздел Имя_компании, в котором хранятся параметры для нескольких программ этого производителя) и выбираем её. Затем с помощью меню "Реестр" ("Registry") экспортируем выбранную ветвь в файл. При выборе пути сохранения файла учтите его доступность для других пользователей. Перегрузившись под обычным пользователем, импортируйте полученный файл. Для этого достаточно дважды щелкнуть по *.reg файлу в Проводнике и ответить "Да" ("Yes") на запрос об импорте файла в реестр, и подтвердить выполнение операции (Ok). После перезагрузки компьютера программа должна работать и под этим аккаунтом.

Кроме того, некоторые программы (например, Windows Commander) создают свои *.ini-файлы. Обычные пользователи имеют разрешение "Read" на эти файлы. Для корректной работы программ нужно добавить разрешение "Modify" ("Изменение"). Редко, но все же иногда требуется разрешение "Write" ("Запись") на *.exe файл программы. Этим отличилась, например, популярная программа ReGet. В свойствах ярлыка программы можно выставить галочку "Запускать от имени другого пользователя". Тогда при запуске программы можно будет ввести логин и пароль администратора (правда, для этого их нужно знать ;)) Аналогичного эффекта можно добиться с помощью cmd-файла, в котором пишем: runas /profile / user:machinename\administrator [полный путь к *.exe файлу] где machinename - имя вашей машины; если в пути к файлу программы есть пробелы, то его необходимо заключить в кавычки. Теперь, при запуске этого cmd-файла, будет также спрашиваться пароль администратора.

(6) Как запустить Fine Reader 5.0 под XP?
Необходимо внести следующие изменения в реесре:

[HKEY_CURRENT_USER\Software\ABBYY\Fine Objects]

"ErrorStopMode"="NEVER"
"AssertStopMode"="NEVER"

А проще воспользоваться вот этим StopMode.rar файликом.
Просто запустите его, и все необходимые изменения будут произведены автоматически.

(7) Как назначить конкретные права доступа к файлам и папкам в XP Home? Simple File Sharing не выключается.
Действительно, в XP Home Simple File Sharing отключить нельзя, и никаких средств для этого в GIU XP Home нет. Но утилика для командной строки, которая это делает, есть. Для того что бы узнать как она работает, достаточно набрать в командной строке cacls.
(8) Как справится с тормозами при работе антивируса Касперского?
Вообще то тормозит всё с благой целью, алгоритм проверки в KAV сейчас настолько крут, что пробраться мимо его всё сложнее. Побочным эффектом этого является что этот алгоритм способен поставить на колени, как кажется, компьютер любой мощности. К сожалению, Касперский не даёт пользователю выбрать что для него важнее, безопасность, пусть даже и за счёт скорости, или его вполне удовлетворит пусть и не такая навёрнутая защита, но нормальная скорость. Поэтому приходится бороться с Касперским не совсем честными методами. Для того что бы дать компьютеру вздохнуть по свободнее, просто уменьшите приоритет для всех его процессов.
(9) Компьютер перезагружается непонятно почему.
Скорее всего компьютер выбивает в BSOD, и он перезагружается. Для решения проблемы необходимо отключить автоматическую перезагрузку при сбое системы. Для этого открываем System Properties, переходим на закладку Advanced, нажимаем на кнопку Settings в разделе Startup and Recovery, и оказываемcя вот в таком окне.

Здесь требуется снять галочку с Automatically restart в разделе System failure. Конечно же это не решит проблему с BSOD, но теперь компьютер не будет сразу же перезагружаться, и вы успеете прочитать содержимое экрана смерти, что может навести вас на путь решения этой проблемы.
(10) Как изменить загрузочную картинку WindowsXP?
Делается это так же как и в W2k, что описано здесь http://www.3dnews.ru/reviews/software/win2000-boot-logo/, но есть небольшие отличия. Если не сильно вдаваться в подробности, то делается это так:

Качаем ResHacker или аналогичную утилиту: http://www.users.on.net/johnson/resourcehacker/ Этим самым резхакером открываем \winxp\system32\ntoskrnl.exe. Слева в столбике списка ресурсов Bitmap-ресурсы под номерами 1, 8 и 10 являются картинками загрузочного лого. Для WinXP Pro это общая картинка, бегущие синие "таблетки" и надпись "Professional". Их можно сохранить на диске, отредактировать в любом редакторе растровой графики (Adobe Photoshop, Jasc Paint Shop Pro и т.п.) и, сохранив, резхакером всунуть обратно в файл ядра ntoskrnl.exe. При этом нужно обойти один подводный камень, который подложила микрософт: при открытии в редакторе эти bmp-шки выглядят абсолютно черными. Для исправления этого недоразумения нужно воспользоваться специальной палитрой, загрузив файл палитры и применив его к открытой bmp-шке. Для фотошопа файлик с палитрой можно взять здесь: http://www.thetechguide.com/howto/xpbootlogo/16.act
Или ручками вбить в редакторе палитры:

R | G | B
0 | 0 | 0
0 | 0 | 0
32 | 26 | 21
45 | 62 | 210
83 | 101 | 1
178 | 53 | 5
70 | 70 | 70
137 | 146 | 0
74 | 127 | 252
247 | 107 | 32
141 | 166 | 255
142 | 220 | 4
243 | 188 | 27
188 | 188 | 188
255 | 255 | 255
255 | 255 | 255

Когда эта палитра будет загружена для открытой bmp-шки, она примет вид как при загрузке. Картинку можно отредактировать, не меняя параметров разрешения и т.п., а потом сохранить и всунуть резхакером в ядро. Возможно, перед сохранением нужно применить палитру, состоящую только из черных цветов (все цвета черные, RGB=0,0,0), чтобы вернуться к исходному кодированию картинки как у микрософт.

НЕ НАДО ПЫТАТЬСЯ заменить ИМЕЮЩИЙСЯ ntoskrnl.exe! Во первых этому возмутится sfc, во вторых это просто не самая лучшая идея. Гораздо разумнее, после засовывания измененных картинок сохранить попорченное ядро как, например, kernel01.exe (обязательно в формате DOS filename 8.3, т.е., имя файла не более 8 букв без пробелов и пр. + .exe). А затем воспользоваться замечательным ключом /kernel= filename.ext в файле настройки загрузчика C:\boot.ini (может быть скрытый/системный):

[boot loader]
timeout=7
default=multi(0)disk(0)rdisk(0)partition(1)\WINXP
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINXP="Original Windows XP" /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINXP="New Logo Windows XP" /fastdetect /kernel=kernel01.exe

Таким образом, мы сохраним исходный файл ядра ntoskrnl.exe, сохраним исходную строчку в boot.ini и всё это без каких-либо модификаций реестра или обхода системы system file checking. Единственное, следует выставить несколько секунд timeout для того, чтобы иметь возможность выбора при загрузке. После успешного тестирования модифицированную строчку можно перенести наверх, тогда она будет по умолчанию загружаться по истечении timeout, или нажатии на Enter.
(11) При загрузке имя и пароль по умолчанию вводятся русскими буквами. Как это изменить?
Вообще то, это изменяется во время установки системы, и после этого изменить стандартными методами это нельзя. Но немного отредактировав реестр, можно. Идём по адресу [HKEY_USERS\.DEFAULT\Keyboard Layout\Preload], и видим там в каком порядке переключается раскладка в окне логона, и меняем на то что нам надо. В случае с двумя установленными языками, русским и английским, всё должно выглядеть так:

"1"="00000409" - Английская (США), основная
"2"="00000419" - Русская, дополнительная

Если охота поменять сочетание клавиш, которые переключают раскладку, то и это можно сделать. Для этого идём по адресу [HKEY_USERS\.DEFAULT\Keyboard Layout\Toggle], и редактируем ключ Hotkey. Когда он имеет значение 1, язык переключается через левые Alt+Shift, когда 2, то через левые Crtl+Shift.
(12) Как сделать что бы при загрузке всегда включался NumLock?
Самый простой способ, это несколько раз выйти из системы с включенный NumLock, система должна запомнить это, и в будущем включать его при загрузке автоматически. Но можно добиться того же эффекта и быстрее. Идём в реестр, и по адресу HKEY_USERS\DEFAULT\Control Panel\Keyboard находим ключ InitialKeyboardIndicators. Меняем его значение на 2, и при загрузке NumLock будет всегда включен. Меняем на 0, и NumLock будет всегда выключен (полезно для ноутбуков, где нет вынесенного блока клавиш с цифрами).
(13) Как убить процесс из командной строки?
Для начала требуется узнать PID процесса, через команду tasklist. Убить процесс можно командой taskkill /PID или tskill PID.
(14) Как отучить XP работать с ZIP файлами как с папками?
Для этого необходимо в командной строке набрать regsvr32 /u zipfldr.dll. Для того что бы вернуть всё обратно, наберите regsvr32 zipfldr.dll.
(15) Как убрать надоедливые сообщения, которые иногда вылазят в notification area?
Что бы выключить эти сообщения, в реестре по адресу HKEY_CURRENT_USER/Software/Microsoft/Windows/Current Version/Explorer/Advanced создайте ключ типа DWORD под названием EnableBalloonTips, и присвойте ему значение 0. Присвоив ему значение 1, вы вновь разрешите показывать эти сообшения.
(16) Надоело стирать Temporary Internet Files каждый раз вручную. Можно автоматизировать этот процесс?
Для этого запустите Internet Explorer, меню Tools, пункт Internet Options… В открывшемся окне переходим на закладку Advanced. Скролируем список до самого низа, раздела Security. Ставим чекбокс в пункте Empty Temporary Internet Files Folder When Browser is Closed.
(17) Как узнать что означает та или иная ошибка в Event Viewer?
Несмотря на то, что в окне с текстом ошибки ХР радостно сообщает, что по адресу http://qo.microsoft.com/fwlink/events.asp можно найти дополнительную информацию, на самом деле через этот адрес просто отправляются сообщения об ошибках в Microsoft. Тем не менее, сделана попытка создать сайт с исчерпывающей информацией про ошибки. Находится он здесь http://www.eventid.net/ Информация размещённая на нём не полна, и не всегда точна, но ведь он постоянно развивается. Зайдите на него, возможно именно в вашем случае он поможет.
(18) Как поменять расположение папок My Documents, My Music?
Эта методика работает далеко не для всех папок, а только для тех, что XP позволяет двигать. Нажимаем на папке на правую кнопку мыши, выбираем Properties. В открывшемся окне нажимаем на кнопку Move, и переносим папку куда требуется.
(19) Как мне удалить файл hiberfil.sys?
Не смотря на то, что этот вопрос уже описан в факе, причём не однократно, он возникает снова и снова, с завидным постоянством. Поэтому, как мне кажется, стоит осветить его ещё раз. Этот файл является частью системы Hibernate, которая позволяет при выключении компьютера сбросить содержимое оперативной памяти на жёсткий диск, а при включении, просто загрузить этот файл в память. Это позволяет избежать достаточно долгого процесса загрузки, и сразу же после включения компьютера получить рабочий стол и открытые программы или документы точно в том виде, в котором они оставались когда компьютер выключался. Для того что бы обезопасить себя от ситуации, когда не удаться сбросить содержимое памяти просто из за того что на диске нет места, служба hibernate постоянно держит на диске файл hiberfil.sys размером равным объёму оперативной памяти. Этот файл нельзя стереть из под XP, его бесполезно стирать из под соседней ОС, всё равно служба hibernate создаст его заново при первой же возможности. Единственны способ, это отключить саму службу hibernate. Сделать это можно через Control Panel – Power Options, закладка Hibernate. Снимаем галочку с чекбокса Enable hibernation, и служба будет отключена, а файл hiberfil.sys удалён.
(20) Как отключить Automatic Update?
Если этого не сделать, то при наличии соединения с интернет ХР будет постоянно ломиться на сайт Microsoft в поисках новых заплаток. Ничего плохого в этом нет, но если в ваши планы это не входит, эту функцию можно отключить. Для этого открываем System Properties, переходим на закладку Automatic Updates, и выставляем нужное, в нашем случае Turn off automatic updates.

(21) Как обезопасить себя от утери пароля для входа в систему?
Для этого требуется создать Password reset disk, который позводит вам сбросить пароль для аккаунта. Диск создаётся один раз, и работает вне зависимости от того, менял ли пользователь пароль для входа в систему после создания диска. Пароль всё равно будет сброшен. Для создания этого диска зайдите в Control Panel – User Accounts. В открывшемся окне выбираем пользователя, для которого необходимо сделать диск, кликаем на нём. В вновь открывшемся окне в левом столбце выбираем пункт Prevent a forgotten password, и запускаем мастер создания дискеты для сброса пароля. Дальше просто следуем инструкциям. С помощью получившегося диска любой сможет зайти в систему под этим аккаунтом, поэтому не стоит бросать её где попало.


WinXPFAQ -> Сеть

Сеть
(1) Как обеспечить доступ к моим ресурсам другим пользователям сети?
C самого начала в системе существует папка под названием Shared Documents, расположенная в Document and Settings\All Users\Shared Documents, которая расшарена по умолчанию, и очень удобна для обмена файлами и документами, причём не только по сети, но и между пользователями на одной и той же машине.
Однако, этих возможностей хватает не всегда. Принцип, по которому осуществляется доступ к ресурсам в XP интентичен тому, который использовался в W2k. Если требуется просто обеспечить доступ, без разграничения прав, то достаточно просто убедиться в том, что пользователь Guest не отключен (апплет User Accounts в Control panel). После этого добавьте пользователя Guest в права доступа на расшаренную папку.
Для того что бы сделать это, отключите Simple Files Sharing (как это сделать описано в вопросе 18 раздела Твики), выберите закладку Sharing из Properties. На этой закладке нажимаете Permissions, и откроется окно, в этом окне жмёте на кнопку Add, и откроется вот такое окно:

В котором можно ввести имя пользователя, которому разрешается доступ к выбранному ресурсу. Имя вводится в следующем формате Имя компьютера\Имя пользователя. Впрочем, можно не вводить имя вручную, а нажать кнопку Advanced, а в открывшемся окне Find Now, и Вы увидите список пользователей существующих на компьютере. Выбираете нужного (в нашем случае Guest), жмёте на Add. Остаётся только выставить права доступа добавленным пользователям.
Если диск на котором находиться расшаренный ресурс отформатирован под NTFS, то не забудьте добавить пользователя и выставить права доступа в закладке Security (если этой закладки нет, а раздел действительно отформатирован под NTFS, то воспользуйтесь советом из вопроса 18 раздела «Твики»).
Однако, иногда требуется обеспечить доступ не всем подряд, а только определённым пользователям. Здесь необходимо сделать небольшое отступление. В отличии от Win9x в XP, как и в любой NT права распределяются не на уровне ресурсов, а на уровне пользователей.
Поэтому в XP нет такого понятия как доступ по паролю, к которому привыкли пользователи Win9x. Пользователь логинится на машину с XP, вводит пароль один раз, и получает доступ ко всем ресурсам, на которые у него есть соответствующие права.
Для того что бы пользователь мог залогиниться на машину с XP, он должен быть на ней прописан. Делается это через апплет User Accounts в Control Panel, надо добавить пользователя с тем же именем, как и на компьютере, для которого надо обеспечить доступ. Этого пользователя следует добавить в права доступа для расшаренного ресурса и назначить ему права.
Если при попытке подсоединения к компьютеру с XP Вы получите сообщение что ресурс недоступен, Вам придётся поставить пароль как пользователю в Win9x, так и пользователю в XP. Желательно одинаковые.

(2) Что такое Remote Desktop и как с ним работать?
Так называется технология которую ввёл Microsoft в XP, которая служит для того, что бы IT специалисту не приходилось бегать через всё здание, просто для того, что бы показать пользователю как создать shortcut :-)
Это простой терминал, который позволяет удалённо работать на другом компьютере. Но, не стоит ожидать от него слишком много, несмотря на то, что эта система хорошо подходит для удалённого решения проблем, нормально именно работать на удалённой машине у Вас не получиться. Управлять всеми этими функциями можно через апплет Remote Assistance, найти который можно через кнопку Start – Programs – Remote Assistance. Запустив его, вы окажитесь вот в таком окне:

Начать стоит с пункта Invite someone to help you. После того как Вы выберете его, система проверит наличие сетевого соединения (если Вы планируете получить помощь с помощью интернета, Вам придётся подсоединиться к нему), и если всё в порядке, то откроется следующее окно. Для того что бы человек получил возможность помочь Вам, надо переслать ему файлик в 1 килобайт размером. В этом окне система и предлагает несколько вариантов, для этого можно воспользоваться Windows Messenger, послать файлик электронной почтой с помощью Outlook Express, или же просто сохранить этот файлик, и доверить задачу по его доставке Вам. Выбираем нужное (например сохранить как файл), и оказываемся в очередном окне, где Вы можете ввести имя, от кого будет приглашение и время, в течении которого будет возможно воспользоваться этим приглашением. Нажав на Continue, Вы окажитесь в следующем окне, где Вам предложат определиться, нужен ли пароль для доступа к Вашей машине и каким он должен быть. После чего Вас попросят сохранить полученный файл (если в первом окне Вы решите воспользоваться Windows Messenger или Outlook Express для отсылки приглашения, то процедура будет немного отличаться от описанной).
Так или иначе, но файлик доставлен, теперь, всё что требуется, это запустить его. Покажется окошко с информацией о том кто прислал приглашение, спросят пароль (если он задан), и соединение произойдёт автоматически. На экране у второго компьютера, в этот момент, появится окно с сообщением от службы Remote Assistance что кто то подсоединился, и ждёт разрешения начать работу. Нажимаете OK, и у Вас на экране появиться вот такое окно:

Всё что можно сделать в этом окне достаточно очевидно, единственный совет, который можно дать, это через Settings выбрать скорость Вашего соединения. Если этого не сделать, то даже при использовании высокоскоростной локальной сети соединение будет оптимизировано под малоскоростной канал, что чревато заметным лагом. Если канал достаточно быстр (например локальная сеть), и выставлено быстрое соединение, то работать можно вполне комфортно. Впрочем, слишком много ожидать не стоит, например посмотреть фильм запущенный на чужой машине нормально не удастся даже при наличии очень быстрого соединения.
Из других приятных особенностей Remote Assistance можно отметить возможность обмениваться голосовыми сообщениями (конечно, если скорость соединения позволяет). Кроме этого, если пользователь «исследуемой» машины разрешит, то присоединившийся пользователь сможет взять контроль в свои руки (take control), и получит возможность управлять мышкой и клавиатурой на чужом компьютере. Впрочем, нажав на ESC (причём не важно на какой машине, той что подсоединилась или на локальной), это право у него можно отобрать.
Последняя рекомендация, которую мне хотелось бы дать, это поменяйте разрешение экрана на машине-сервере на меньшее, чем используется на машине –клиенте, причём до того, как начнёте сеанс работы. Надо это для того, что бы подсоединившийся клиент видел рабочий стол сервера целиком, без необходимости тягать скролл-бары. А делать это надо перед началом работы, потому что если поменять разрешение когда подключен клиент, то его сразу же отключит.
Плюсы Remote Assistance очевидны, поэтому стоит уделить пару строк недостаткам. По большому счёту они не являются недостатками, просто встречаются излишние ожидания, мол это же готовый Terminal Server, пригодный для удалённой работы. Это далеко не так. Remote Assistance хорошо делает то для чего задумывалась, и плохо подходит для всего остального. Главный минус Remote Assistance, если попытаться использовать его как обычный терминальный сервер, это требование к постоянному присутствию пользователя на другой стороне, без разрешения которого вообще ничего сделать нельзя.
Кроме этого, в качестве клиента может выступать только машина с XP Pro, что так же накладывает некоторые ограничения на аппаратную часть клиента, и сводит практически на нет все те преимущества, которые обычно пытаются получить при использовании терминальных серверов.
Ещё одним очень важным ограничением, которое сводит практически на ноль всю пользу от применения Remote Assistance не по прямому назначению, является ограничение одновременно подключенных клиентов одним единственным. Более того, если на «сервере» сделать switch user, то подсоединение через Remote Assistance к текущему пользователю будет разорвано, то есть одновременная работа нескольких пользователей невозможна ни в каком виде.

(3) Правда ли что у XP возникают проблемы с сетью при установленном AVP?
Для решения этой проблемы попробуйте отключить службу Web Client.
(4) Как ускорить открытие сетевых машин с W9x из XP?
Происходит это из за того, что ХР каждый раз сканирует сеть на наличие сетевых принтеров и отложенных заданий (Scheduled Tasks). Для того что бы он этого не делал, достаточно удалить две папки из реестра. Находятся они по адресу HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/CurrentVersion/Explorer/Remote Computer/Name Space

И называются {2227A280-3AEA-1069-A2DE-08002B30309D} для принтеров и {D6277990-4C6A-11CF-8D87-00AA0060F5BF} для отложенных заданий.
(5) Как убрать окно с сообщение об ошибке, выскакивающее при неудачном дозвоне?
Для этого в реестр надо добавить такой ключ: REGEDIT4 [HKEY_CURRENT_USER\Software\Microsoft\RAS Phonebook] "PopupOnTopWhenRedialing"=dword:00000000
(6) Как полностью отключить службу QoS (Quality of Service). Как её настроить? Правда ли что она ограничивает скорость сети?
Действительно, по умолчанию Quality of Service резервирует для своих нужд 20 % от пропускной способности канала (любого, хоть модем на 14400, хоть гигабитный Ethernet). Причём, даже если удалить службу QoS Packet Scheduler из Properties соединения, этот канал не освобождается. Освободить канал, или просто настроить QoS, можно здесь. Запускаем апплет Group Policy (gpedit.msc). В Group Policy находим Localcomputer policy и нажимаем на Administrative templates. Выбираем пункт Network -- QoS Packet Sheduler. Включаем Limit reservable bandwidth. Теперь cнижаем Bandwidth limit 20% до 0, или просто отключаем его. При желании здесь же можно настроить и другие параметры QoS. Для активации произведённых изменений остаётся только перезагрузиться.
(7) Как настроить сервер удалённого доступа под ХР?
Этот сервер для соединения двух компьютеров либо по модему, либо через LTP или COM кабель. В XP создание и настройка любых соединений производятся через мастер Create a new connection, вызвать который можно из окна Network Connections. Для создания прямого соединения, запускаем мастер, и на втором окне выбираем Set up an advanced connection, нажимаем на Next.

На следующей закладке выбираем пункт Accept incoming connections, что бы разрешить принимать входящие звонки (человек на другом конце, соответственно, должен выбрать другой пункт), нажимаем на Next.

В следующем окне выбираем устройства, которые должны принимать входящие соединения, вновь нажимаем на Next.

В следующем окне можно настроить возможность создания виртуальных соединений в рамках этого соединения. В нашем случае, когда требуется просто соединить два компьютера, это не нужно, поэтому выбираем пункт Do not allow virtual private connections, нажимаем на Next.

В следующем окне выбираем кто из пользователей, зарегистрированных на компьютере сможет пользоваться соединением (этим пользователям должно быть разрешено подсоединятся удалённо), нажимаем на Next.

Остаётся только выставить какие протоколы и службы должны использоваться. Каждый из протоколов можно настроить выбрав его и нажав на кнопку Properties. Ещё раз нажимаем на Next, потом Finish, и соединение создано. Теперь остаётся только запустить вновь созданное соединение, и к вам можно будет дозваниваться.
(8) Как настроить aDSL соединение?
В XP есть всё необходимое для настройки DSL соединения, поэтому если ваш провайдер не использует какого то очень уж экзотичного оборудования, вам не понадобится никаких дополнительных драйверов или какого-либо другого программного обеспечения. Как и любое другое соединение, DSL соединение создаётся через мастер Create new connection находящегося в окне Network Conection. Запускаем мастер, на второй закладке отмечаем пункт Connect to Internet, нажимаем на Next. На следующей закладке отмечаем пункт Set up my connection manually, вновь нажимаем на Next. На следующем окне выбираем Connect using a broadband connection that requires a user name and password, и нажимаем на Next. В двух следующих окнах вводите имя провайдера, имя и пароль, которые должны использоваться при подсоединении (об этом можно узнать у провайдера), и всё готово. Просто звоните по появившемуся соединению, когда потребуется подсоединится к интернету.
(9) Как настроить Internet Connection Sharing?
В свойстве любого непостоянного соединения, которое может использоваться для соединения в Internet, есть закладка Advanced.

Для того что бы разрешить пользователям локальной сети использовать это соединение для совместного доступа в интернет, достаточно просто отметить чекбокс Allow other network user to connect trough this computer’s Internet connection. Но для того что бы другие пользователи сети моги использовать это соединение, требуется выполнить еще несколько условий. Во первых, компьютер предоставляющий доступ должен иметь IP адрес 192.168.0.1, и никакой другой. Все остальные компьютеры, которые ходят через него в интернет должны конфигурироваться автоматически (Obtain IP address automatically). Это требование не ново, и должно быть знакомо всем пользователям ICS от Microsoft, ещё со времён Windows98, где эта служба была представлена впервые.
(10) Как использовать несколько настроек TCP/IP для одной сетевой карты?
Использование ICS для доступа в интернет подразумевает, что компьютер должен получать IP адрес автоматически, с компьютера предоставляющего доступ в интернет. Однако, это неудобно, и мешает нормальной работе в локальной сети. Для решения этой проблемы ХР предоставляет возможность иметь несколько конфигураций TCP/IP на одной сетевой карте. Для этого служит закладка Alternative в Properties TCP/IP протокола карты.

На этой закладке можно задать альтернативные настройки протокола, которые будут использоваться, к примеру, когда получить IP адрес автоматически не представляется возможным. Конечно, при этом не будет работать первая конфигурация, например интернет предоставляемый через ICS будет не доступен. Что бы поменять используемую конфигурацию, если условия изменились, достаточно нажать правой кнопкой мыши на значке соединения в трее (конечно, для этого отображение этого значка должно быть включено, чекбокс Show icon in notification area when connected в Properties всего соединения), в открывшемся меню выбрать пункт Repair. Машина просканирует сеть, и если будет найден сервер раздающий адреса, адрес будет получен и заменит текущий. Таким образом, к примеру, начнёт работать ICS (Internet Connection Sharing). Последнее пожелание, конфигурация с автоматическим получением адреса должна быть основной, а с постоянным - альтернативной. Если сделать наоборот, то автоматически адрес не будет получаться никогда.
(11) Как спрятать имя пользователя из Welcome Screen?
Это может пригодится, например, когда на компьютере прописан пользователь, который никогда не логинится локально, только по сети. Для того что бы убрать пользователя из списка доступных пользователей нужно в реестре по адресу HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\SpecialAccounts\UserList\ добавить ключ типа REG_DWORD соответствующий имени пользователя. Присвоив этому ключу значение 1 мы разрешим показывать этого пользователя в Welcome Screen, а 0 запретим. Несмотря на то что пользователя не видно, им всё равно можно залогиниться. Для этого дважды нажимаем Crtl+Alt+Del, открывается классическое окно логона, вводим имя, пароль, и логинимся.
(12) Как запретить пользователю логинится локально?
Это может понадобиться, например, для пользователей которые пользуются ресурсами вашего компьютера только по сети. Что бы запретить такому пользователю логиниться локально, запускаем апплет Local Security Policy (Control panel – Administrative Tools), и переходим в рездел Local Polices – User Right Assignment. Находим здесь ключ Deny logon locally, дважды кликаем на нём, и добавляем (Add User or Group…) пользователей которым требуется запретить логинится локально. Как обычно, пользователя можно ввести либо вручную (Имя компьютера\Имя пользователя), либо выбрать из списка, для чего требуется нажать на кнопку Advanced, и в изменившемся окне на кнопку Find.
(13) Как запретить пользователю логинится по сети?
Запускаем апплет Local Security Policy (Control panel – Administrative Tools), и переходим в рездел Local Polices – User Right Assignment. Находим здесь ключ Access this computer from the network, дважды кликаем на нём, и получаем возможность удалить группу, члены которой не должны иметь доступ к компьютеру из сети. Если вам понадобиться разрешить доступ члену удалённой группы, его придётся добавлять индивидуально, через кнопку Add User or Group. Как обычно, пользователя можно ввести либо вручную (Имя компьютера\Имя пользователя), либо выбрать из списка, для чего требуется нажать на кнопку Advanced, и в изменившемся окне на кнопку Find.
(14) Как настроить IPv6 под ХР?
В XP уже встроена поддержка этого протокола, но она нигде не отражена в интерфейсе. Для его установки IPv6 достаточно набрать в командной строке install ipv6. Не переживайте, на текущие настройки TCP/IP это не окажет никакого влияния. Настройка IPv6 производится из командной строки, что бы узнать про это подробнее, просто введите ipv6 /?


WinXPFAQ -> Благодарности

Благодарности

В продолжение славной традиции W2kFAQ на 3Dnews, и этот FAQ никогда не стал бы тем, чем он является сегодня если бы сотни читателей не делились со мной своими проблемами, опытом, и находками. Людей, которые помогли сделать этот FAQ лучше множество, и их количество растёт каждый день. Вашу помощь трудно переоценить. Людей, которые помогли сделать этот FAQ лучше так много, что я чисто физически не могут привести здесь все их имена, не говоря уже про то, что установить первенство и авторство в том или ином вопросе не всегда возможно. Всё что я могу сделать - это постараться что бы знания и опыт, которыми со мной так щедро делятся читатели, не пропали, а нашли своё отражение на страницах этого труда. И пусть наградой вам будут те слова благодарности, которые присылают в мой адрес за поддержку этого документа.

От себя лично, и от лица всех читателей нашего FAQ, говорю вам:

Огромное Cпасибо!

Ведущий WinXP FAQ на http://www.3Dnews.ru/
Алексей Шашков ака Lehmen