Параллельные ЦАП

ЦАП с cуммированием весовых токов

Большинство схем параллельных ЦАП основано на суммировании токов, сила каждого из которых пропорциональна весу цифрового двоичного разряда, причем должны суммироваться только токи разрядов, значения которых равны 1. Пусть, например, требуется преобразовать двоичный четырехразрядный код в аналоговый сигнал тока. У четвертого, старшего значащего разряда (СЗР) вес будет равен 23=8, у третьего разряда – 22=4, у второго – 21=2 и у младшего (МЗР) – 20=1. Если вес МЗР IМЗР=1 мА, то IСЗР=8 мА, а максимальный выходной ток преобразователя Iвых.макс=15 мА и соответствует коду 11112. Понятно, что коду 10012, например, будет соответствовать Iвых=9 мА и т.д. Следовательно, требуется построить схему, обеспечивающую генерацию и коммутацию по заданным законам точных весовых токов. Простейшая схема, реализующая указанный принцип, приведена на рис. 3.

Сопротивления резисторов выбирают так, чтобы при замкнутых ключах через них протекал ток, соответствующий весу разряда. Ключ должен быть замкнут тогда, когда соответствующий ему бит входного слова равен единице. Выходной ток определяется соотношением

При высокой разрядности ЦАП токозадающие резисторы должны быть согласованы с высокой точностью. Наиболее жесткие требования по точности предъявляются к резисторам старших разрядов, поскольку разброс токов в них не должен превышать тока младшего разряда. Поэтому разброс сопротивления в k-м разряде должен быть меньше, чем

D R / R=2–k

Из этого условия следует, что разброс сопротивления резистора, например, в четвертом разряде не должен превышать 3%, а в 10-м разряде – 0,05% и т.д.

Рассмотренная схема при всей ее простоте обладает целым букетом недостатков. Во-первых, при различных входных кодах ток, потребляемый от источника опорного напряжения (ИОН), будет различным, а это повлияет на величину выходного напряжения ИОН. Во-вторых, значения сопротивлений весовых резисторов могут различаться в тысячи раз, а это делает весьма затруднительной реализацию этих резисторов в полупроводниковых ИМС. Кроме того, сопротивление резисторов старших разрядов в многоразрядных ЦАП может быть соизмеримым с сопротивлением замкнутого ключа, а это приведет к погрешности преобразования. В-третьих, в этой схеме к разомкнутым ключам прикладывается значительное напряжение, что усложняет их построение.

Эти недостатки устранены в схеме ЦАП AD7520 (отечественный аналог 572ПА1), разработанном фирмой Analog Devices в 1973 году, которая в настоящее время является по существу промышленным стандартом (по ней выполнены многие серийные модели ЦАП). Указанная схема представлена на рис. 4. В качестве ключей здесь используются МОП-транзисторы.

Рис. 4. Схема ЦАП с переключателями и матрицей постоянного импеданса

В этой схеме задание весовых коэффициентов ступеней преобразователя осуществляют посредством последовательного деления опорного напряжения с помощью резистивной матрицы постоянного импеданса. Основной элемент такой матрицы представляет собой делитель напряжения (рис. 5), который должен удовлетворять следующему условию: если он нагружен на сопротивление Rн, то его входное сопротивление Rвх также должно принимать значение Rн. Коэффициент ослабления цепи a=U2/U1 при этой нагрузке должен иметь заданное значение. При выполнении этих условий получаем следующие выражения для сопротивлений:

(6)

При двоичном кодировании a =0,5. Если положить Rн=2R, то
Rs=R и Rp=2R (7)

в соответствии с рис.4.

Поскольку в любом положении переключателей Sk они соединяют нижние выводы резисторов с общей шиной схемы, источник опорного напряжения нагружен на постоянное входное сопротивление Rвх=R. Это гарантирует неизменность опорного напряжения при любом входном коде ЦАП.

Согласно рис. 4, выходные токи схемы определяются соотношениями

(8)
(9)

а входной ток

(10)

Поскольку нижние выводы резисторов 2R матрицы при любом состоянии переключателей Sk соединены с общей шиной схемы через низкое сопротивление замкнутых ключей, напряжения на ключах всегда небольшие, в пределах нескольких милливольт. Это упрощает построение ключей и схем управления ими и позволяет использовать опорное напряжение из широкого диапазона, в том числе и различной полярности. Поскольку выходной ток ЦАП зависит от Uоп линейно (см. (8)), преобразователи такого типа можно использовать для умножения аналогового сигнала (подавая его на вход опорного напряжения) на цифровой код. Такие ЦАП называют перемножающими (MDAC).

Точность этой схемы снижает то обстоятельство, что для ЦАП, имеющих высокую разрядность, необходимо согласовывать сопротивления R0 ключей с разрядными токами. Особенно это важно для ключей старших разрядов. Например, в 10-разрядном ЦАП AD7520 ключевые МОП-транзисторы шести старших разрядов сделаны разными по площади и их сопротивление R0 нарастает согласно двоичному коду (20, 40, 80, … , 640 Ом). Таким способом уравниваются (до 10 мВ) падения напряжения на ключах первых шести разрядов, что обеспечивает монотонность и линейность переходной характеристики ЦАП. 12-разрядный ЦАП 572ПА2 имеет дифференциальную нелинейность до 0,025% (1 МЗР).

ЦАП на МОП ключах имеют относительно низкое быстродействие из-за большой входной емкости МОП-ключей. Тот же 572ПА2 имеет время установления выходного тока при смене входного кода от 000...0 до 111...1, равное 15 мкс. 12-разрядный DAC7611 фирмы Burr-Braun имеет время установления выходного напряжения 10 мкс. В то же время ЦАП на МОП-ключах имеют минимальную мощность потребления. Тот же DAC7611 потребляет всего 2,5 мВт. В последнее время появились модели ЦАП рассмотренного выше типа с более высоким быстродействием. Так 12-разрядный AD7943 имеет время установления тока 0,6 мкс и потребляемую мощность всего 25 мкВт. Малое собственное потребление позволяет запитывать такие микромощные ЦАП прямо от источника опорного напряжения. При этом они могут даже не иметь вывода для подключения ИОН, например, AD5321.

ЦАП на источниках тока

ЦАП на источниках тока обладают более высокой точностью. В отличие от предыдущего варианта, в котором весовые токи формируются резисторами сравнительно небольшого сопротивления и, как следствие, зависят от сопротивления ключей и нагрузки, в данном случае весовые токи обеспечиваются транзисторными источниками тока, имеющими высокое динамическое сопротивление. Упрощенная схема ЦАП на источниках тока приведена на рис. 6.

Рис. 6. Схема ЦАП на источниках тока

Весовые токи формируются с помощью резистивной матрицы. Потенциалы баз транзисторов одинаковы, а чтобы были равны и потенциалы эмиттеров всех транзисторов, площади их эмиттеров делают различными в соответствии с весовыми коэффициентами. Правый резистор матрицы подключен не к общей шине, как на схеме рис. 4, а к двум параллельно включенным одинаковым транзисторам VT0 и VTн, в результате чего ток через VT0 равен половине тока через VT1. Входное напряжение для резистивной матрицы создается с помощью опорного транзистора VTоп и операционного усилителя ОУ1, выходное напряжение которого устанавливается таким, что коллекторный ток транзистора VTоп принимает значение Iоп. Выходной ток для N-разрядного ЦАП.

(11)

Характернымипримереми ЦАП на переключателях тока с биполярными транзисторами в качестве ключей являются 12-разрядный 594ПА1 с временем установления 3,5 мкс и погрешностью линейности не более 0,012% и 12-разрядный AD565, имеющий время установления 0,2 мкс при такой же погрешности линейности. Еще более высоким быстродействием обладает AD668, имеющий время установления 90 нс и ту же погрешность линейности. Из новых разработок можно отметить 14-разрядный AD9764 со временем установления 35 нс и погрешностью линейности не более 0,01%.

В качестве переключателей тока Sk часто используются биполярные дифференциальные каскады, в которых транзисторы работают в активном режиме. Это позволяет сократить время установления до единиц наносекунд. Схема переключателя тока на дифференциальных усилителях приведена на рис. 7.

Дифференциальные каскады VT1–VT3 и VT' 1–VT' 3 образованы из стандартных ЭСЛ вентилей. Ток Ik, протекающий через вывод коллектора выходного эмиттерного повторителя является выходным током ячейки. Если на цифровой вход Dk подается напряжение высокого уровня, то транзистор VT3 открывается, а транзистор VT' 3 закрывается. Выходной ток определяется выражением

Точность значительно повышается, если резистор Rэ заменить источником постоянного тока, как в схеме на рис. 6. Благодаря симметрии схемы существует возможность формирования двух выходных токов – прямого и инверсного. Наиболее быстродействующие модели подобных ЦАП имеют входные ЭСЛ-уровни. Примером может служить 12-ти разрядный МАХ555, имеющий время установления 4 нс до уровня 0,1%. Поскольку выходные сигналы таких ЦАП захватывают радиочастотный диапазон, они имеют выходное сопротивление 50 или 75 ом, которое должно быть согласовано с волновым сопротивлением кабеля, подключаемого к выходу преобразователя.

Формирование выходного сигнала в виде напряжения

Существует несколько способов формирования выходного напряжения для ЦАП с суммированием весовых токов. Два из них показаны на рис. 8.

Рис. 8. Формирование напряжения по токовому выходу ЦАП

На рис. 8а приведена схема с преобразователем тока в напряжение на операционном усилителе (ОУ). Эта схема пригодна для всех ЦАП с токовым выходом. Поскольку пленочные резисторы, определяющие весовые токи ЦАП имеют значительный температурный коэффициент сопротивления, резистор обратной связи Rос следует изготавливать на кристалле ЦАП и в том же технологическом процессе, что обычно и делается. Это позволяет снизить температурную нестабильность преобразователя в 300…400 раз.

Для ЦАП на МОП-ключах с учетом (8) выходное напряжение схемы на рис. 8а.

Обычно сопротивление резистора обратной связи Rос=R. В таком случае

(12)

Большинство моделей ЦАП имеет значительную выходную емкость. Например, у AD7520 с МОП-ключами в зависимости от входного кода Свых составляет величину 30…120 пФ, у AD565А с источниками тока Свых=25 пФ. Эта емкость совместно с выходным сопротивлением ЦАП и резистором Rос создает дополнительный полюс частотной характеристики петли обратной связи ОУ, который может вызвать неустойчивость в виде самовозбуждения. Особенно это опасно для ЦАП с МОП-ключами при нулевом входном коде. При Rос=10 кОм частота второго полюса составит около 100 кГц при 100%-ной глубине обратной связи. В таком случае усилитель, частота единичного усиления которого fт превышает 500 кГц, будет иметь явно недостаточные запасы устойчивости. Для сохранения устойчивости можно включить параллельно резистору Rос конденсатор Ск, емкость которого в первом приближении можно взять равной Свых. Для более точного выбора Ск необходимо провести полный анализ устойчивости схемы с учетом свойств конкретного ОУ. Эти мероприятия настолько серьезно ухудшают быстродействие схемы, что возникает парадоксальная ситуация: для поддержания высокого быстродействия даже недорогого ЦАП может потребоваться относительно дорогой быстродействующий (с малым временем установления) ОУ.

Ранние модели ЦАП с МОП ключами (AD7520, 572ПА1 и др.) допускают отрицательное напряжение на ключах не свыше 0,7 В, поэтому для защиты ключей между выходами ЦАП следует включать диод Шоттки, как это показано на рис. 8а.

Для цифро-аналогового преобразователя на источниках тока преобразование выходного тока в напряжение может быть произведено с помощью резистора (рис.8б). В этой схеме невозможно самовозбуждение и сохранено быстродействие, однако амплитуда выходного напряжения должна быть небольшой (например, для AD565А в биполярном режиме в пределах ± 1 В). В противном случае транзисторы источников тока могут выйти из линейного режима. Такой режим обеспечивается при низких значениях сопротивления нагрузки: Rн »1 кОм. Для увеличения амплитуды выходного сигнала ЦАП в этой схеме к ее выходу можно подключить неинвертирующий усилитель на ОУ.

Для ЦАП с МОП-ключами, чтобы получить выходной сигнал в виде напряжения, можно использовать инверсное включение резистивной матрицы (рис. 9).

Рис. 9. Инверсное включение ЦАП с МОП-ключами

Для расчета выходного напряжения найдем связь между напряжением Ui на ключе Si и узловым напряжением U'i . Воспользуемся принципом суперпозиции. Будем считать равными нулю все напряжения на ключах, кроме рассматриваемого напряжения Ui. При Rн=2R к каждому узлу подключены справа и слева нагрузки сопротивлением 2R. Воспользовавшись методом двух узлов, получим

Выходное напряжение ЦАП найдем как общее напряжение на крайнем правом узле, вызванное суммарным действием всех Ui. При этом напряжения узлов суммируются с весами, соответствующими коэффициентам деления резистивной матрицы R-2R. Получим

Для определения выходного напряжения при произвольной нагрузке воспользуемся теоремой об эквивалентном генераторе. Из эквивалентной схемы ЦАП на рис. 10 видно, что

Рис. 10

(13)

Откуда э.д.с. эквивалентного генератора

(14)

Эквивалентное сопротивление генератора Rэ совпадает со входным сопротивлением матрицы R-2R, т.е. Rэ=R. При Rн=2R из (14) получим

(15)

Подставив (15) в (13), для произвольной нагрузки получим

В частности, при Rн=Ґ

(16)

Недостатками этой схемы являются: большое падение напряжения на ключах, изменяющаяся нагрузка источника опорного напряжения и значительное выходное сопротивление. Вследствие первого недостатка по этой схеме нельзя включать ЦАП типа 572ПА1 или 572ПА2, но можно 572ПА6 и 572ПА7. Из-за второго недостатка источник опорного напряжения должен обладать низким выходным сопротивлением, в противном случае возможна немонотонность характеристики преобразования. Тем не менее, инверсное включение резистивной матрицы довольно широко применяется в ИМС ЦАП с выходом в виде напряжения, например, в 12-ти разрядном МАХ531, включающем также встроенный ОУ в неинвертирующем включении в качестве буфера, или в 16-ти разрядном МАХ542 без встроенного буфера. 12-ти разрядный ЦАП AD7390 построен на инверсной матрице с буферным усилителем на кристалле и потребляет всего 0,3 мВт мощности. Правда его время установления достигает 70 мкс.

Параллельный ЦАП на переключаемых конденсаторах

Основой ЦАП этого типа является матрица конденсаторов, емкости которых соотносятся как целые степени двух. Схема простого варианта такого преобразователя приведена на рис. 11. Емкость k-го конденсатора матрицы определяется соотношением

Сk=2kC0. (17)

Цикл преобразования состоит из двух фаз. В первой фазе ключи S0…SN–1 находятся в левой позиции. Ключ сброса Sсб замкнут. При этом все конденсаторы разряжены. Во второй фазе ключ сброса Sсб размыкается. Если k-й бит входного N-разрядного слова dk=1, то соответствующий ключ Sk переключается в правую позицию, подключая нижнюю обкладку конденсатора к источнику опорного напряжения, или остается в левой позиции, если dk=0. Суммарный заряд конденсаторов матрицы с учетом (17) составит

(18)

Равный заряд получает и конденсатор С в обратной связи ОУ. При этом выходное напряжение ОУ составит

Uвых=–q/C. (19)

Рис. 8.11. Параллельный ЦАП на коммутируемых конденсаторах

Подставив (18) в (19), найдем окончательно

(20)

Для хранения результата преобразования (постоянного напряжения) в течении сколь-нибудь продолжительного времени к выходу ЦАП этого типа следует подключить устройство выборки-хранения. Хранить выходное напряжение неограниченное время, как это могут делать ЦАП с суммированием весовых токов, снабженные регистром-защелкой, преобразователи на коммутируемых конденсаторах не могут из-за утечки заряда. Поэтому они применяются, в основном, в составе аналого-цифровых преобразователей. Другим недостатком является большая площадь кристалла ИМС, занимаемая подобной схемой.

ЦАП с суммированием напряжений

Схема восьмиразрядного преобразователя с суммированием напряжений, изготавливаемого в виде ИМС, приведена на рис. 8.12. Основу преобразователя составляет цепь из 256 резисторов равного сопротивления, соединенных последовательно. Вывод W через ключи S0…S255 может подключаться к любой точке этой цепи в зависимости от входного числа. Входной двоичный код D преобразуется дешифратором 8х256 в унитарный позиционный код, непосредственно управляющий ключами. Если приложить напряжение UAB между выводами А и В, то напряжение между выводами W и B составит

UWB=UABD.

Достоинством данной схемы является малая дифференциальная нелинейность и гарантированная монотонность характеристики преобразования. Ее можно использовать в качестве резистора, подстраиваемого цифровым кодом. Выпускается несколько моделей таких ЦАП. Например, микросхема AD8403 содержит четыре восьмиразрядных ЦАП, выполненных по схеме на рис. 8.12, с сопротивлением между выводами А и В 10, 50 либо 100 кОм в зависимости от модификации. При подаче активного уровня на вход “Экономичный режим” происходит размыкание ключа Sоткл и замыкание ключа S0. ИМС имеет вход сброса, которым ЦАП можно установить на середину шкалы. Фирма Dallas Semiconductor выпускает несколько моделей ЦАП (например, сдвоенный DS1867) с суммированием напряжений, у которых входной регистр представляет собой энергонезависимое оперативное запоминающее устройство, что особенно удобно для построения схем с автоматической подстройкой (калибровкой). Недостаток схемы – необходимость изготавливать на кристалле большое количество (2N) согласованных резисторов. Тем не менее, в настоящее время выпускаются 8-ми, 10-ти и 12-ти разрядные ЦАП данного типа с буферными усилителями на выходе, например, AD5301, AD5311 и AD5321.

<-- Предыдущая страница Оглавление Следующая страница -->

ПОИСК ПО СЕРВЕРУ

СПИСКИ РАССЫЛКИ
HTML PDF
Расширенный поиск
Имя
E-mail

НАВИГАЦИЯ

вверх на главную пишите webmasteru © Centre.RU