Последовательные ЦАП

ЦАП с широтно-импульсной модуляцией

Очень часто ЦАП входит в состав микропроцессорных систем. В этом случае, если не требуется высокое быстродействие, цифро-аналоговое преобразование может быть очень просто осуществлено с помощью широтно-импульсной модуляции (ШИМ). Схема ЦАП с ШИМ приведена на рис. 1а.

ЦАП с широтно-импульсной модуляцией

Рис. 1. ЦАП с широтно-импульсной модуляцией

Наиболее просто организуется цифро-аналоговое преобразование в том случае, если микроконтроллер имеет встроенную функцию широтно-импульсного преобразования (например, AT90S8515 фирмы Atmel или 87С51GB фирмы Intel). Выход ШИМ управляет ключом S. В зависимости от заданной разрядности преобразования (для контроллера AT90S8515 возможны режимы 8, 9 и 10 бит) контроллер с помощью своего таймера/счетчика формирует последовательность импульсов, относительная длительность которых g =tи/ Т определяется соотношением

где N – разрядность преобразования, а D – преобразуемый код. Фильтр нижних частот сглаживает импульсы, выделяя среднее значение напряжения. В результате выходное напряжение преобразователя

Рассмотренная схема обеспечивает почти идеальную линейность преобразования, не содержит прецизионных элементов (за исключением источника опорного напряжения). Основной ее недостаток – низкое быстродействие.

Последовательный ЦАП на переключаемых конденсаторах

Рассмотренная выше схема ЦАП с ШИМ вначале преобразует цифровой код во временной интервал, который формируется с помощью двоичного счетчика квант за квантом, поэтому для получения N-разрядного преобразования необходимы 2N временных квантов (тактов). Схема последовательного ЦАП, приведенная на рис. 2, позволяет выполнить цифро-аналоговое преобразование за значительно меньшее число тактов.

В этой схеме емкости конденсаторов С1 и С2 равны. Перед началом цикла преобразования конденсатор С2 разряжается ключом S4. Входное двоичное слово задается в виде последовательного кода. Его преобразование осуществляется последовательно, начиная с младшего разряда d0. Каждый такт преобразования состоит из двух полутактов. В первом полутакте конденсатор С1 заряжается до опорного напряжения Uоп при d0=1 посредством замыкания ключа S1 или разряжается до нуля при d0=0 путем замыкания ключа S2. Во втором полутакте при разомкнутых ключах S1, S2 и S4 замыкается ключ S3, что вызывает деление заряда пополам между С1 и С2. В результате получаем

U1(0)=Uвых(0)=(d0/2)Uоп

 (3)

Пока на конденсаторе С2 сохраняется заряд, процедура заряда конденсатора С1 должна быть повторена для следующего разряда d1 входного слова. После нового цикла перезарядки напряжение на конденсаторах будет

 (4)

Точно также выполняется преобразование для остальных разрядов слова. В результате для N-разрядного ЦАП выходное напряжение будет равно

(5)

Если требуется сохранять результат преобразования сколь-нибудь продолжительное время, к выходу схемы следует подключить УВХ. После окончания цикла преобразования следует провести цикл выборки, перевести УВХ в режим хранения и вновь начать преобразование.

Таким образом, представленная схема выполняет преобразование входного кода за 2N квантов, что значительно меньше, чем у ЦАП с ШИМ. Здесь требуется только два согласованных конденсатора небольшой емкости. Конфигурация аналоговой части схемы не зависит от разрядности преобразуемого кода. Однако по быстродействию последовательный ЦАП значительно уступает параллельным цифро-аналоговым преобразователям, что ограничивает область его применения.

<-- Предыдущая страница Оглавление Следующая страница -->

ПОИСК ПО СЕРВЕРУ

СПИСКИ РАССЫЛКИ
HTML PDF
Расширенный поиск
Имя
E-mail

НАВИГАЦИЯ

вверх на главную пишите webmasteru © Centre.RU