Fairchild Semiconductor - Parametric Search - MOSFET - Product Comparison

Fairchild Semiconductor space space space
space | space
 | space | SEARCH | Parametric | Cross Reference | Inventory
 |  | Product Folders and Datasheets
space
space | space | space
find products Find Products |  | Home >> Product selection and parametric search >> Discrete >> MOSFET
space | space | space
space | Products groups
 | space | Analog and Mixed Signal
 |  | Discrete
 |  | Interface
 |  | Logic
 |  | Microcontrollers
 |  | Non-Volatile Memory
 |  | Optoelectronics
 | Power
 | Markets and applications
 | New products
 | Product selection and parametric search
 | Cross-reference search
Technical Information
buy products Buy Products
support Support
my Fairchild My Fairchild
global Fairchild Global Fairchild
company Company
 space
MOSFET Product Comparison

  • Refine this list by modifying existing parameters
  • New MOSFET parametric search
  • New product selection and parametric search
Products
Package
Lead Count
Configuration
Polarity
VDS
RDS(ON) Max @ VGS =
QG (Note)
ID
PD
Device Grade
FETBench
Lead Free
Data Sheet
10V
4.5V
2.5V
1.8V
UOM: V Ohms Ohms Ohms Ohms nC A W
FDS4410
SO-8 8 Single N 30 .0135 .02 - - 13 10 2.5 Commercial Run Analysis No Datasheet
FDS4488
SO-8 8 Single N 30 .022 .03 - - 9.5 7.9 2.5 Commercial - No Datasheet
FDS4501H
SO-8 8 Complementary
N
P
30
-20 		.018 .046
.023 		.063 - 17
13 		9.3
5.6 		2.5 Commercial Run Analysis No Datasheet
FDS4559
SO-8 8 Complementary
N
P
60
-60 		.055
.105 		.075
.135 		- - 12.5
15 		4.5
3.5 		2 Commercial Run Analysis No Datasheet
FDS6294
SO-8 8 Single N 30 .0113 .0144 - - 10 13 3 Commercial Run Analysis No Datasheet
FDS6570A
SO-8 8 Single N 20 - .0075 .01 - 47 15 2.5 Commercial Run Analysis No Datasheet
FDS6572A
SO-8 8 Single N 20 - .006 .008 - 57 16 2.5 Commercial - No Datasheet
FDS6574A
SO-8 8 Single N 20 - .006 .007 .009 75 16 2.5 Commercial Run Analysis No Datasheet
FDS6612A
SO-8 8 Single N 30 .022 .03 - - 9 8.4 2.5 Commercial Run Analysis
No
Yes
Datasheet
FDS6614A
SO-8 8 Single N 30 .018 .025 - - 12 9.3 2.5 Commercial Run Analysis
No
Yes
Datasheet
Products
Package
Lead Count
Configuration
Polarity
VDS
RDS(ON) Max @ VGS =
QG (Note)
ID
PD
Device Grade
FETBench
Lead Free
Data Sheet
10V
4.5V
2.5V
1.8V
UOM: V Ohms Ohms Ohms Ohms nC A W
FDS6630A
SO-8 8 Single N 30 .038 .053 - - 5 6.5 2.5 Commercial - No Datasheet
FDS6644
SO-8 8 Single N 30 .0085 .0105 - - 25 13 2.5 Commercial Run Analysis No Datasheet
FDS6670A
SO-8 8 Single N 30 .008 .01 - - 35 13 2.5 Commercial Run Analysis No Datasheet
FDS6670S
SO-8 8 SyncFET N 30 .009 .0125 - - 24 13.5 2.5 Commercial Run Analysis No Datasheet
FDS6672A
SO-8 8 Single N 30 .008 .0095 - - 33 12.5 2.5 Commercial Run Analysis No Datasheet
FDS6676
SO-8 8 Single N 30 .007 .008 - - 45 14.5 2.5 Commercial Run Analysis No Datasheet
FDS6676S
SO-8 8 SyncFET N 30 .0052 .006 - - 43 14.5 2.5 Commercial Run Analysis No Datasheet
FDS6678A
SO-8 8 Single N 30 .02 .024 - - 13 7.5 2.5 Commercial Run Analysis No Datasheet
FDS6680
SO-8 8 Single N 30 .01 .015 - - 19 11.5 2.5 Commercial Run Analysis
No
Yes
Datasheet
FDS6680A
SO-8 8 Single N 30 .0095 .013 - - 23 12.5 2.5 Commercial Run Analysis
No
Yes
Datasheet
Products
Package
Lead Count
Configuration
Polarity
VDS
RDS(ON) Max @ VGS =
QG (Note)
ID
PD
Device Grade
FETBench
Lead Free
Data Sheet
10V
4.5V
2.5V
1.8V
UOM: V Ohms Ohms Ohms Ohms nC A W
FDS6680S
SO-8 8 SyncFET N 30 .011 .017 - - 17 11.5 2.5 Commercial Run Analysis No Datasheet
FDS6682
SO-8 8 Single N 30 .0075 .009 - - 22 14 2.5 Commercial - No Datasheet
FDS6688
SO-8 8 Single N 30 .006 .007 - - 40 16 2.5 Commercial Run Analysis
No
Yes
Datasheet
FDS6690
SO-8 8 Single N 30 .0135 .02 - - 13 10 2.5 Commercial Run Analysis No Datasheet
FDS6690A
SO-8 8 Single N 30 .0125 .017 - - 17 11 2.5 Commercial Run Analysis
No
Yes
Datasheet
FDS6690S
SO-8 8 SyncFET N 30 .016 .025 - - 17 10 2.5 Commercial Run Analysis No Datasheet
FDS6692
SO-8 8 Single N 30 .012 .0145 - - 18 12 2.5 Commercial Run Analysis No Datasheet
FDS6694
SO-8 8 Single N 30 .011 .0135 - - 13 12 2.5 Commercial - No Datasheet
FDS6812A
SO-8 8 Dual N 20 - .022 .035 - 12 6.7 2 Commercial Run Analysis No Datasheet
FDS6890A
SO-8 8 Dual N 20 - .018 .022 - 23 7.5 2 Commercial Run Analysis No Datasheet
Products
Package
Lead Count
Configuration
Polarity
VDS
RDS(ON) Max @ VGS =
QG (Note)
ID
PD
Device Grade
FETBench
Lead Free
Data Sheet
10V
4.5V
2.5V
1.8V
UOM: V Ohms Ohms Ohms Ohms nC A W
FDS6892A
SO-8 8 Dual N 20 - .018 .024 - 12 7.5 2 Commercial - No Datasheet
FDS6892AZ
SO-8 8 Dual N 20 - .018 .024 - 12 7.5 2 Commercial - No Datasheet
FDS6894A
SO-8 8 Dual N 20 - .017 .02 .03 17 8 2 Commercial - No Datasheet
FDS6894AZ
SO-8 8 Dual N 20 - .017 .02 .03 14 8 2 Commercial - No Datasheet
FDS6898A
SO-8 8 Dual N 20 - .014 .018 - 16 9.4 2 Commercial Run Analysis No Datasheet
FDS6898AZ
SO-8 8 Dual N 20 - .014 .018 - 16 9.4 2 Commercial - No Datasheet
FDS6900S
SO-8 8 Dual (MOSFET & SyncFET) N 30
30 		.03
.022 		.037
.029 		- - 8
12 		6.9
8.2 		2 Commercial - No Datasheet
FDS6912
SO-8 8 Dual N 30 .028 .042 - - 7 6 2 Commercial Run Analysis No Datasheet
FDS6912A
SO-8 8 Dual N 30 .028 .035 - - 9 6 2 Commercial Run Analysis
No
Yes
Datasheet
FDS6930A
SO-8 8 Dual N 30 .04 .055 - - 5 5.5 2 Commercial Run Analysis
No
Yes
Datasheet
Products
Package
Lead Count
Configuration
Polarity
VDS
RDS(ON) Max @ VGS =
QG (Note)
ID
PD
Device Grade
FETBench
Lead Free
Data Sheet
10V
4.5V
2.5V
1.8V
UOM: V Ohms Ohms Ohms Ohms nC A W
FDS6961A
SO-8 8 Dual N 30 .09 .14 - - 2.1 3.5 2 Commercial Run Analysis No Datasheet
FDS6982
SO-8 8 Dual N 30
30 		.015
.028 		.02
.035 		- - 18.5
8.5 		8.6
6.3 		2 Commercial - No Datasheet
FDS6982S
SO-8 8 Dual (MOSFET & SyncFET) N 30
30 		.016
.028 		.022
.035 		- - 17.5
8.5 		8.6
6.3 		2 Commercial Run Analysis No Datasheet
FDS6984S
SO-8 8 Dual (MOSFET & SyncFET) N 30
30 		.019
.04 		.028
.055 		- - 11
5 		8.5
5.5 		2 Commercial Run Analysis No Datasheet
FDS6986S
SO-8 8 Dual (MOSFET & SyncFET) N 30
30 		.029
.02 		.038
.028 		- - 6.5
11 		6.5
7.9 		2 Commercial Run Analysis No Datasheet
FDS6990A
SO-8 8 Dual N 30 .018 .023 - - 17 7.5 2 Commercial Run Analysis No Datasheet
FDS6990S
SO-8 8 Dual SyncFET N 30 .022 .03 - - 11 7.5 2 Commercial - No Datasheet
FDS6994S
SO-8 8 Dual (MOSFET & SyncFET) N 30
30 		.021
.015 		.026
.0175 		- - 8
25 		6.9
8.2 		2 Commercial - No Datasheet
FDS7760A
SO-8 8 Single N 30 .0055 .008 - - 37 15 2.5 Commercial Run Analysis No Datasheet
FDS7764A
SO-8 8 Single N 30 - .0075 - - 29 15 2.5 Commercial Run Analysis No Datasheet
Products
Package
Lead Count
Configuration
Polarity
VDS
RDS(ON) Max @ VGS =
QG (Note)
ID
PD
Device Grade
FETBench
Lead Free
Data Sheet
10V
4.5V
2.5V
1.8V
UOM: V Ohms Ohms Ohms Ohms nC A W
FDS7764S
SO-8 8 SyncFET N 30 .0075 .009 - - 25 13.5 2.5 Commercial - No Datasheet
FDS7766
SO-8 8 Single N 30 .005 .006 - - 43 17 2.5 Commercial - No Datasheet
FDS7766S
SO-8 8 SyncFET N 30 .0055 .0065 - - 41 17 2.5 Commercial - No Datasheet
FDS7788
SO-8 8 Single N 30 .004 .005 - - 37 18 2.5 Commercial Run Analysis No Datasheet
FDS7796
SO-8 8 Single N 30 .009 .012 - - 16 13 2.5 Commercial - No Datasheet
FDS8333C
SO-8 8 Complementary
N
P
30
-30 		.08
.13 		.13
.2 		- - 4.7
4.1 		4.1
3.4 		2 Commercial - No Datasheet
FDS8926A
SO-8 8 Dual N 30 - .03 .038 - 19.8 5.5 2 Commercial Run Analysis No Datasheet
FDS8928A
SO-8 8 Complementary
N
P
30
-20 		- .03
.055 		.038
.072 		- 19.8
20 		5.5
4 		2 Commercial Run Analysis No Datasheet
FDS8936A
SO-8 8 Dual N 30 .028 .04 - - 19 6 2 Commercial Run Analysis
No
Yes
Datasheet
FDS8958A
SO-8 8 Complementary
N
P
30
-30 		.028
.052 		.04
.08 		- - 18
19 		7
5 		2 Commercial Run Analysis
No
Yes
Datasheet
Products
Package
Lead Count
Configuration
Polarity
VDS
RDS(ON) Max @ VGS =
QG (Note)
ID
PD
Device Grade
FETBench
Lead Free
Data Sheet
10V
4.5V
2.5V
1.8V
UOM: V Ohms Ohms Ohms Ohms nC A W
FDS9412
SO-8 8 Single N 30 .022 .036 - - 9 7.9 2.5 Commercial Run Analysis No Datasheet
FDS9926A
SO-8 8 Dual N 20 - .03 .043 - 7 6.5 2 Commercial - No Datasheet
FQS4900
SO-8 8 Complementary
N
P
60
-300 		.55
15.5 		.65@5V
16@5V 		- - 1.6
3.6 		1.3
.3 		2 Commercial - No Datasheet
NDS8425
SO-8 8 Single N 20 - .022 .028@2.7V - 11 7.4 2.5 Commercial Run Analysis No Datasheet
NDS8426A
SO-8 8 Single N 20 - .0135 .016@2.7V - 43 10.5 2.5 Commercial Run Analysis No Datasheet
NDS9952A
SO-8 8 Complementary
N
P
30
-30 		.08
.13 		- - - 9.5
10 		3.7
2.9 		2 Commercial -
No
Yes
Datasheet
NDS9956A
SO-8 8 Dual N 30 .08 .11 - - 9.5 3.7 2 Commercial Run Analysis No Datasheet
SI4466DY
SO-8 8 Single N 20 - .0075 .01 - 47 15 2.5 Commercial - Yes Datasheet
SI4532DY
SO-8 8 Complementary
N
P
30
-30 		.065
.085 		.095
.19 		- - 3.7
5 		3.9
3.5 		2 Commercial - No Datasheet

Note: Unless otherwise specified,
QG is given @ 5VGS for MOSFET s with ratings of 30VDS and below.
QG is given @ 10VGS for MOSFETs with ratings higher than 30VDS.

When using the information presented in Fairchild Semiconductor's parametric search tool, we recommend that you completely review our datasheets to confirm the device functionality and performance for your application. Fairchild Semiconductor is not responsible for any incorrect or incomplete information. No information provided herein shall be used in a manner which is adverse to Fairchild.

space | space | Home | Find products | Technical information | Buy products | Support | Company | Contact us | Site index | Privacy policy | Site Terms & Conditions © Copyright 2003 Fairchild Semiconductor