Secure Digital Card Pinout, SD Flash Card Memory Module Pin Out

Secure Digital Card Pinout

Secure Digital Card, Pin Out

Secure Digital [SD] is a flash based removable memory card. The card format may also be used other device functions in addition to data storage.
Secure Digital uses a 9-Pin connector [1 rows of 9 pins], labeled 0 to 8 as shown below.
A compatible card format is called Secure Digital I/O [SDIO]. Refer to the SDIO page for information on that card standard.
Also refer to the microSD Card, or the miniSD Card pages, which are different physical versions of the SDcard.

SDXC memory card format; XC - for 'eXtended Capacity'
Refer here for the SD Association ... http://www.sdcard.org/developers/tech/sdhc/
The format used Microsoft's exFAT [FAT 64] file system [however this site does not cover any software OS].
exFAT was introduced with Windows CE 6.0, and appeared in Vista in Service Pack 1.
Read and Write speeds to 104MB/s with 2TB capacity.
SDIO and SDHC, may be updated to support the higher data throughput.

Secure Digital Card showing pin locations and numbering
SD Card

The Secure Digital card dimensions are: 24mm wide x 32mm long.
The standard width is 2.1mm, while the Thin SD Memory Card has a width 1.4mm.

Secure Digital Pinout
Pin # | Pin Name | SD Signal Function SD Mode | SPI Signal Function SPI Mode
1 | DAT3/CS | Data Line 3 | Chip Select/Slave Select [SS]
2 | CMD/DI | Command Line | Master Out/Slave In [MOSI]
3 | VSS1 | Ground | Ground
4 | Vdd | Voltage Supply [2.7v or 3.6v] | Voltage Supply [2.7v or 3.6v]
5 | Clock | Clock | Clock [SCK]
6 | Vss2 | Ground | Ground
7 | DAT0/D0 | Data Line 0 | Master In Slave Out [MISO]
8 | DAT1/IRQ | Data Line 1 | Unused or IRQ
9 | DAT2/NC | Data Line 2 | Unused

The graphic below provides a comparison of the different Removable memory Card standards.
Many of the different Memory Card standards have descriptions listed on this web site.
The different standards based on card size are provided below [Flash Memory Stick Formats].
Refer to the Personal Computer Buses page for more information for different memory types, as listed here.

Memory Board Dimension
Comparison of Flash Memory Card sizes

The graphic to the right shows:
The SD card, 32mm x 24mm
The miniSD card, 21.5 x 20mm
The microSD card, 15mm x 11mm

Note that pin contacts 3 and pin 4
are bit bit longer than the other pins.
This allows pin 3 [Vss], and pin 4 [Vdd]
to make contact in the socket before the other pins.
Allowing Ground and power to be connected first
to the SD socket.
Pins CLK, CMC, DAT0, DAT1, DAT2, and Vss
make connection after pins 3 and 4 make contact.
Pin 1, DAT3 makes contact last.
Of course pins 3 and 4 are also the last
pins to lose contact with the socket.

The MicroSD form factors picture [left]
is used under GNU License

Article on Designing with SD Card, learn more.

 SD Card Sizes
Comparison of SD Memory Card sizes
SD Card, miniSD Card, microSD Card

{Secure Digital Card Index}

Acronyms; Smartmedia Host Controller (SMHC), Secured Digital Host Controller (SDHC)

PC motherboard
Home
Distributor rolodex | Electronic Components | Electronic Equipment | EDA CDROM Software | Engineering Standards, BOB card | Cabled Computer Bus | Electronic Engineering Design Table | Conversion DB9-to-DB25.
Distributors | Components | Equipment | Software | Standards | Buses | Design | Reference

Modified 12/31/11
Copyright © 1998 - 2011 All rights reserved Leroy Davis