Имитация сигналов GPS

ГЛАВНАЯ GPS КАТАЛОГ НОВОСТИ GPS КЛУБ УЗНАЙ О GPS GPS ТЕСТЫ GPS WIKI GPS ФОРУМ NAVI TV NaviTrаvel
Навигация
GPS Клуб
Участники GPS Клуба
GPS ГЛОНАСС каталог
GPS ГЛОНАСС новости
GPS ГЛОНАСС тесты
GPS карты и программы
ГЛОНАСС GPS видео
Узнай о GPS и ГЛОНАСС
Рейтинг GPS ГЛОНАСС
GPS ГЛОНАСС форум
GPS Инструкции
GPS ГЛОНАСС Блоги
Фотогалерея GPS Клуба
Все опросы
English version
О нас
ЭРА ГЛОНАСС

Услуги сервис центра
НавиЦентр
Обновление GPS карт и программ
Обновить прошить GPS навигатор
Установка программ навигации
Обновить СитиГИД
Обновить Навител
Обновить Автоспутник
Новинки GPS/ГЛОНАСС

ВКонтакте

Navi TV
21.12.2010 Второй независимый тест GPS программ с сервисом "Пробки". Серия 3.
08.12.2010 Второе тестирование навигационных сервисов "пробки". Эпизод-4.
08.12.2010 Второе тестирование навигационных сервисов "пробки". Эпизод-3.
05.12.2010 Второй независимый тест GPS программ с сервисом "Пробки". Видео.
05.12.2010 Второе тестирование навигационных GPS комплексов прошло в Москве под контролем ГЛОНАСС.

Все выпуски

Нас поддерживают

GPS навигаторы купить, обновить gps карты и программы

Имитация сигналов GPS

GPS Тесты / GPS Club новоcти
Подписка на новости | RSS | Поделись с друзьями | Прислать новость | Вступайте в наш клуб | Свяжитесь с нами
 |  |  | info@gps-club.ru | Вступить в GPS-клуб | Наши контакты
Имитация сигналов GPS

Имитация – это полезный метод при создании и работе оборудования, используемого системами глобальной спутниковой навигации. С помощью радиочастотного имитатора мы можем имитировать радиосигналы, генерируемые спутниками. Эти устройства позволяют определять сценарии, в том числе траектории приемников, и проигрывать их, изменяя рабочие параметры приемника. Некоторые имитаторы позволяют записывать реальные сигналы и проигрывать их при различных заданных условиях.

Как бы то ни было, такие имитаторы GNSS/ГЛОНАСС/GPS-сигналов могут иметь высокую стоимость и выходить за рамки бюджета многих исследователей. В этой статье мы рассмотрим подход одной компании к имитации GNSS-сигналов по низкой цене. Такой подход может быть доступен практически любому исследователю.

Как однажды в довольно пессимистичной форме сказал один известный французский социолог и философ Жан Бодрийяр, «мы находимся во вселенной, в которой становится все больше информации и все меньше смысла». Имитация помогает бороться с этим и дает нам лучшее понимание реальности, по крайней мере, в области GNSS-инженерии.

Встраиваемые GPS-приемники вошли в повседневную жизнь с развитием систем GPS-навигации и стали внедряться практически во все категории автомобилей и телефонов, за исключением самых недорогих. По мере роста числа недорогих встраиваемых GPS-приемников, растет и потребность в недорогих имитаторах GPS-сигналов. Контролируемое виртуальное тестирование жизненно важно для изучения производительности будущих систем.

Многие доступные в настоящее время генераторы GPS-сигналов специально разработаны для крупномасштабных производственных испытаний устройств, в которых используются коммерческие приемники сигналов GPS/SBAS, GLONASS и Galileo. Зачастую стоимость таких высококлассных имитаторов оказывается слишком высокой для мелких компаний и университетов. В ответ на потребность в такой системе мы разработали тестовый набор для архитектуры сигналов GPS (GPS Signal Architect) на основе программно-определяемой радиосистемы (SDR), предназначенный для широкого круга исследователей, академиков, а также для промышленного и оборонного использования. Система является гибкой, масштабируемой и, что самое важное, недорогой.

Наш тестовый набор использует радиоплатформу Universal Software Radio Peripheral (USRP) и инструментарий имитации GPS-сигналов (GPS Signal Simulation Toolbox) для генерации GPS-сигналов по намного более низкой цене, чем та, что сейчас доступна на рынке. Комбинация программного обеспечения для имитации GPS-сигналов с поддержкой платформы USRP записи и воспроизведения обеспечивает невероятно недорогое и при этом довольно гибкое решение для имитации GPS-сигналов.

На Рисунке 1 представлено оборудование для имитации сигналов GPS. Имитатор предназначен для работы с коммерческими программно-определяемыми радиосистемами и основан на инструментарии имитации GPS-сигналов.

Рисунок 1. Аппаратная часть имитатора сигналов GPS.

Набор инструментов Toolbox. Toolbox представляет собой полный набор инструментов для имитации сигналов GPS, тестирования и анализа. Набор на базе Matlab имитирует эффект ослабления сигнала на обычном коммерческом GPS-приемнике, в том числе симулирует ионосферную активность и её влияние на прием сигнала. Географические инструменты Toolbox’а помогают переводить данные между разными системами координат, используемыми в GPS-исследованиях, включая такие как широта-долгота-широта, WGS-84 ECEF и NED (north-east-down). Они также обеспечивают средства для чтения альманахов и эфемерид, расчета ECEF и векторов к GPS-спутникам в зоне прямой видимости. Приемник и инструменты анализа моделируют различные виды архитектуры приемника и имитируют различные сценарии ошибок с помощью трекинга и навигационных алгоритмов, включая петли фазовой синхронизации и синхронизации по задержке.

Настраиваемые пользователем опции позволяют оператору задавать практически все аспекты окружения сигналов GPS, в том числе распространяющиеся GPS-коды, навигационные сообщения и сценарии помех. Такая гибкость оказывается полезной в условиях имитации GPS-помех, когда недостаточными являются время, ресурсы и повторяемость.

В связи с тем, что эти ресурсы привязаны напрямую к Matlab, определить и реализовать новые компоненты сигналов становится довольно просто, так как они становятся доступными. Основной интерес для нас представляют коды модернизации GPS, а также коды модернизации других глобальных систем спутниковой навигации (GNSS). Также нас интересуют новые и экзотичные виды генераторов помех, включая частотно-модулированные, амплитудно-модулированные, фазомодулированные и генераторы помех качающейся частоты.

Конфигурация. В конфигурации, показанной на Рисунке 1 блок управления сигналами (SCU) используется в управлении радиоприемником для записи и воспроизведения. Платформа USRP оснащена стандартным входом с частотой 10 МГц, а также входом для подключения внешнего генератора тактовых импульсов. Программное обеспечение GPS Signal Architect может создавать файлы данных с пользовательскими сценариями GPS, которые используют платформу USRP для генерации GPS-сигналов на радиочастоте.

В этой статье представлен краткий обзор того, как имитатор сигналов использует серию радиоприемников USRP в качестве недорогих устройств для записи и воспроизведения частот, используя файлы Signal Architect. Помимо этого, описываются конструкция оборудования и поддерживаемые сигналы, а также представлены результаты тестов, в которых видно, как платформа USRP передает сигналы GPS на обычное пользовательское оборудование.

Радиооборудование

Серия радиоприемников USRP представляет собой недорогую базовую инструментальную платформу для программно-определяемых радиосистем. USRP можно использовать для записи и воспроизведения GPS-сигналов в статическом или мобильном окружении. Оператор может на стенде воспроизвести сигнал из имитируемого профиля, либо из ранее записанного тестового окружения. Преимуществом USRP является поддержка широкополосных внешних интерфейсов приемопередатчика, которые могут вмещать весь 20 МГц-диапазон GPS-сигналов и могут быть настроены для работы на любой из GPS-частот (L1 на частоте 1575,42 МГц, L2 на частоте 1227,60 МГц или L5 на частоте 1176,45 МГц). Это позволяет записывать и воспроизводить как гражданские, так и военные коды GPS.

И хотя инструменты GPS Signal Architect могут быть приспособлены для работы с любой коммерчески доступной программно-определяемой радиосистемой, семейство устройств USRP было выбрано именно благодаря своей разумной цене, качественной сборке и расширенной поддержке проекта GNU Radio.

USRP-радиоприемники – это программно-определяемые радиосистемы, которые могут передавать или принимать сигналы на любой частоте под управлением программного обеспечения. Обычно USRP-приемники подключаются к локальному компьютеру через высокоскоростной USB-порт или гигабитный порт Ethernet, который используется хостовым программным обеспечением для управления аппаратной частью USRP, а также для приема и передачи данных. Некоторые модели USRP обладают функциями хост-компьютера и оснащены встроенным процессором, что позволяет использовать их в качестве самостоятельных устройств. Оборудование USRP управляется аппаратным драйвером, который поддерживает платформы Linux, MacOS и Windows. Фреймворк, запущенный на хост-компьютере получает доступ к USRP с помощью драйвера. Несколько Фреймворков, включая GNU Radio (бесплатно распространяемый программный пакет для изучения, построения и размещения SDR-систем, разработанных в рамках проекта GNU (GNU – рекурсивный акроним от GNU is Not Unix), LabView, Matlab и Simulink, используют драйвер. Доступ к функциям драйвера также можно получить напрямую через прикладной программный интерфейс (API) с собственной поддержкой языка программирования C++. Использовать драйвер может и любой другой язык, способный импортировать функции C++.

Это выполняется, к примеру, в языке Python при помощи Simplified Wrapper и Interface Generator. API позволяет пользователям разрабатывать свои собственные Фреймворки, как мы сделали это в случае с блоком управления сигналами (SCU).

Из доступных USRP-радиоприемников был выбран N210, благодаря самой высокой частоте опроса, высокой гибкости и наибольшим возможностям модификации (см. Рисунок 2).

Рисунок 2. Платформа USRP (Universal Software Radio Peripheral).

USRP обеспечивает подключение высокоскоростных аналого-цифровых конвертеров, высокоскоростных цифро-аналоговых конвертеров к Ethernet-порту. Плата расширения, доступная для USRP, обеспечивает передачу немодулированных сигналов, представленных в конвертерах данных, на GPS-частоты и обратно.

Плата расширения (дочерняя плата или субплата) – это печатная плата, которая является расширением материнской платы. USRP использует взаимозаменяемые платы расширения, подключаемые к основной плате, и выступает в качестве радиочастотного внешнего интерфейса. Существует несколько классов плат расширения: приемники, передатчики и приемопередатчики. Передатчики способны модулировать выходной сигнал на более высокую частоту; приемники могут принимать радиосигнал и конвертировать его в немодулированный; приемопередатчики сочетают возможности передатчиков и приемников.

Для данного проекта в USRP был установлен широкополосный WBX-приемопередатчик. Настраиваемый диапазон частот (от 50 МГц до 2,2 ГГц) покрывает все существующие GNSS-частоты. Радиочастотный предфильтр используется для ограничения полосы частот GNSS-сигналов до уровня частоты опроса, выбранного для использования в блоке SCU, который позволяет избежать спектрального наложения 40 МГц-канала приемника N210. Например, 2 МГц-фильтр, отцентрированный в диапазоне L1, является оптимальным, основываясь на частоте дискретизации Найквиста 2 МГц синфазной и квадратурной составляющих сигнала. Если испытывать на частоте 20 МГц, то потребуется фильтр 20 МГц.

Блок управления сигналами (SCU)

Блок управления сигналами включает в себя одноплатный компьютер на базе Linux c программным обеспечением, разработанным специально для работы под GNU Radio Companion (графический инструмент с открытым исходным кодом для создания сигнальных ориентированных графов и генерирования исходного кода ориентированных графов с использованием библиотек GNU Radio) и систему менеджмента программно-определяемой радиосистемой GNU для записи и воспроизведения радиочастот под управлением ПО GPS Signal Architect через Ethernet-соединение. Это позволяет пользователю получить поддержку USRP-сообщества для своего проекта и иметь преимущество за счет близкой связи проекта GNU Radio и производителем платформы USRP. Ethernet-соединение используется еще и для загрузки и выгрузки файлов с записанными и имитируемыми сигналами из программного обеспечения Signal Architect.

Программное обеспечение для имитации сигналов

Аппаратная и программная часть GPS Signal Architect дает пользователям возможность генерировать сигналы GPS на базе Matlab. Если набор инструментов Matlab GPS Toolbox есть в наличии, то имитация GPS-сигналов может проходить в среде Matlab. Для пользователей, не использующих среду Matlab, программное обеспечение Signal Architect может поставляться в версии, которая сама может выполнять функции такой среды. Поток имитации сигналов показан на Рисунке 3.

Рисунок 3: Имитационный поток Signal Architect.

Графический интерфейс (GUI). Используя простой и понятный графический пользовательский интерфейс, пользователь задает траекторию и весь набор имитационных параметров, в результате чего создается файл данных I/Q (см. Рисунок 4). Пользователь обозначает траекторию с помощью файла NMEA (большинство GPS-приемников используют интерфейсный стандарт National Marine Electronics Association 0183 для протоколирования положений и прочих данных) или файла KML из Google Earth (Keyhole Markup Language от Google теперь является стандартом описания геореференсных объектов), а также файл альманаха, используемый для указания имитируемых GPS-спутников. Пользователь задает угол маски при выборе спутников и коэффициент шума, который будет имитироваться. После этого ПО Signal Architect генерирует файл имитируемого цифрового хранилища, включающий в себя выбранные псевдослучайные коды шума (C/A и/или нешифрованные военные коды P или M).

Рисунок 4: Графический пользовательский интерфейс Signal Architect.

Таблица 1: Характеристики систем симуляции сигналов

Сценарии. Программный пакет Signal Architect идет в комплекте с загруженными файлами сценариев, которые пользователь может сразу же запустить на блок управления сигналами при помощи платформы USRP. Signal Architect поддерживает компьютеры с многоядерными процессорами и автоматически настраивается на работу на всех доступных процессорах. Кроме того, Signal Architect генерирует либо статические, либо динамические профили имитации. Графический интерфейс Signal Architect позволяет оператору легко менять переменные сценариев с заданных по умолчанию значений. Готовые сценарии могут легко перемещаться между системами имитации сигналов, поддерживая совместное тестирование в одинаковых проектах, тем самым сокращая время, затрачиваемое на разработку инструментов тестирования.

После этого файл с данными сигнала используется для последующего анализа в Matlab с использованием набора инструментов Matlab GPS Toolbox, либо его можно передать на блок управления сигналами и платформу USRP для создания GPS-сигнала, пригодного для воспроизведения на GPS-приемнике. Если Matlab GPS Toolbox доступен, у пользователя имеется весь набор инструментов для управления сигналами на разных стадиях генерирования или постгенерирования для имитации GPS-аномалий. Без Matlab GPS Toolbox пользователь ограничен в возможностях – он может использовать только стандартные инструменты моделирования ошибок, которые идут в составе компилированного кода Signal Architect.

Результаты тестов имитации

Для демонстрации высокой точности записи и воспроизведения сигналов в Signal Architect, была проведена серия стационарных GPS-имитаций. В этих тестах для записи и воспроизведения GPS-сигналов с кодами C/A в диапазоне L1 (на частоте 1575, 42 МГц) использовалась платформа USRP. Блок управления сигналами и USRP были подключены к GPS L1-антенне, размещенной на крыше. GPS-сигнал был разделен между коммерческим GPS-приемником и платформой USRP, что позволило оператору следить за GPS-приемником одновременно с записью GPS-сигнала платформой USRP.

В режиме записи данные I/Q переписываются из USRP в файл на блоке управления сигналами. В режиме воспроизведения данные считываются из файла платформой USRP для генерирования радиосигнала. Радиосигналы попадают на GPS-приемник через внешний регулируемый аттенюатор. Аттенюатор позволяет оператору регулировать мощность сигнала, подаваемого на GPS-приемник в зависимости от длины антенного кабеля или разделения сигнала на другие GPS-приемники.

Для демонстрации работы тестового набора GPS Signal Architect в ходе двух лабораторных тестов были получены репрезентативные данные. Первый тест демонстрирует работу системы в качестве имитатора GPS-сигналов при записи и воспроизведении. Результаты второго теста показывают работу системы во время использования Signal Architect в процессе генерирования файлов пользовательских GPS-сценариев для воспроизведения на GPS-приемник.

В первом тесте аппаратная часть GPS-имитатора была настроена в соответствии с Рисунком 5. GPS-приемник и USRP были подключены к коммерческой антенне. Антенна была расположена в известном месте с открытым обзором спутниковой группы. Сигнал с GPS-антенны был разбит между GPS-приемником и USRP, таким образом, данные записывались приемником одновременно с блоком управления сигналами.

Рисунок 5: Запись и воспроизведение GPS-имитации при помощи имитатора сигналов GPS

Имитируемая спутниковая группа показана на Рисунке 6. В обзоре находится семь спутников.

Рисунок 6: Имитируемая группа спутников

Позиционная 2D-погрешность имитируемого сигнала показана на Рисунке 7. Погрешности являются репрезентативными данными точности, достигаемой при помощи псевдодальностей GPS с кодами C/A.

Рисунок 7: Позиционная погрешность в системе координат Север-Восток (2D)

Мы можем проверить работу нашего тестового набора, взглянув на значения измерений соотношения плотности сигнал/шум (C/N0) GPS-приемника в режиме реальной передачи данных со спутника и в режиме передачи записанного сигнала имитатором сигналов на три канала GPS- приемника (см. Рисунок 8). Данные C/N0, полученные с GPS-антенны показаны синим цветом, а данные C/N0 с USRP – зеленым.

Рисунок 8: Значения соотношения сигнал/шум в режиме воспроизведения записанного сигнала и в режиме реальной передачи сигнала.

Как мы видим, C/N0 в режиме воспроизведения на 1-2 дБ ниже в сравнении с данными, полученными с GPS-антенны. Ослабление сигнала связано с 1-битной дискретизацией входящего GPS-сигнала в программе Signal Architect. 1-битное и 2-битное квантование используются во многих коммерческих GPS-приемниках. Эмпирическое правило говорит, что 1-битное квантование снижает соотношение сигнал/шум на 1,96 дБ, а 2-битное – на 0,55 дБ. Эти результаты показывают, что 1-битная I/Q-дискретизация является достаточной для воспроизведения GPS-сигналов L1 C/A с помощью платформы USRP.

Во втором тесте приложение Signal Architect использовалось для генерирования файла с 10-минутным статическим GPS L1 C/A сценарием. Блок управления сигналами использовал платформу USRP для генерирования GPS-сигнала.

На Рисунке 9 показано число спутников, отслеживаемых GPS-приемником. При использовании тестового набора GPS Signal Architect для воспроизведения файла статического сценария GPS-приемник смог отследить все имитируемые спутники в файле. Время, которое потребовалось GPS-приемнику для получения и отслеживания сигнала со спутников сопоставимо со временем при подключении GPS-приемника к внешней антенне.

Рисунок 9: Число отслеживаемых спутников (режим воспроизведения файла цифрового сигнала).

На Рисунке 10 представлены замеры C/N0 GPS-приемника на трех каналах. В файле статического сценария присутствовало девять спутников. Значение C/N0 для всех спутников оставалось постоянным в течение всего времени воспроизведения сценария.

Рисунок 10: Соотношение сигнал/шум (режим воспроизведения файла цифрового сигнала).

Прочие аппаратные/программные опции

Мы также сотрудничали с производителем оборудования для имитации сигналов под маркой LabSat с целью добавления в них некоторых программных возможностей системы USRP.

GNSS-имитатор LabSat (см. Рисунок 11) может применяться для записи навигационных спутниковых радиочастотных данных в реальном времени на жесткий диск. В дальнейшем эти данные могут воспроизводиться в качестве радиосигналов. При интеграции с программным обеспечением SatGen могут быть сгенерированы и воспроизведены на имитаторе LabSat имитируемые цифровые радиоданные вместо записанных цифровых GNSS-радиосигналов.

Рисунок 11: GNSS-имитатор LabSat.

Ядром SatGen является программный компонент Signal Architect, адаптированный для работы на платформе LabSat и позволяющий имитировать спутниковые сигналы различных GNSS-систем.

Аппаратная часть. Последняя версия оборудования LabSat (LabSat 2) позволяет записывать и воспроизводить синхронизированные потоки радиоданных GPS и GLONASS (см. Рисунок 12). Во время записи сигналов GPS и GLONASS каналы L1 (1575,42 МГц для GPS и 1602,0 МГц для GLONASS) преобразованы с понижением до промежуточной частоты 0 Гц. Сигналы дискретизируются (2 бит I и Q) на частоте 16,368 МГц для захвата всего набора частотных каналов GLONASS. После этого данные GPS и GLONASS чередуются, образуя 4-битный поток данных, и записываются во внутренний буфер в виде двоичного файла. Высокоскоростной USB-интерфейс передает данные на компьютер. Для воспроизведения компьютер передает хранящиеся двоичные данные на LabSat через USB-интерфейс. Записанные цифровые сигналы GPS и GLONASS преобразуются с повышением частоты на радиоканалы GPS и GLONASS и воспроизводятся на тестируемый приемник. Цифровой аттенюатор выходного сигнала регулирует уровень выходного радиосигнала.

Рисунок 12: Конструкция GNSS-имитатора LabSat.

В режиме записи и воспроизведения LabSat записываются все эффекты реального мира на GNSS-сигналах, включая многолучевое распространение, выпадение сигнала и атмосферные эффекты, что позволяет проводить многочисленные тесты GNSS-приемников в различных реальных условиях, например, в условиях густонаселенного города. Такая возможность позволяет проводить устранение неисправностей аппаратной и программной части систем GNSS. Для более серьезных имитаций в различных условиях можно использовать программное обеспечение LabSat SatGen, которое дает возможность генерировать сценарии имитации в любое время, в любом месте и в динамическом окружении.

Сценарии имитации SatGen. SatGen – это программный пакет, позволяющий пользователю задавать траектории при генерировании файлов имитируемых данных для воспроизведения на оборудовании LabSat. Файл пользовательской траектории можно использовать для создания сценариев маршрутов в любой точке мира, имитируемых при помощи LabSat. Маршруты можно генерировать напрямую из файлов NMEA, импортированных в SatGen из GPS-даталоггера или пользовательских маршрутов, созданных при помощи Google Earth.

Пользователи SatGen могут использовать Google Earth для определения маршрута. Для этого им потребуется создать путь с помощью инструмента “Add Path”. Пользователь может указать любое количество путевых точек по его усмотрению, а затем редактировать маршрут, перемещая, добавляя или удаляя эти точки. Путь сохраняется в виде стандартного файла Google Earth KML, импортируемого в SatGen, который затем наполняется и сглаживает траекторию между путевыми точками. Пользователь также может задать скоростной профиль, либо SatGen может выбрать его автоматически. SatGen создает файл NMEA, который используется для генерирования двоичного I/Q-имитируемого сигнального файла для воспроизведения на оборудовании LabSat.

Имитация с помощью Signal Architect. В основе программного обеспечения SatGen лежит GNSS Signal Architect, усовершенствованная версия GPS Signal Architect, позволяющая имитировать множественные GPS-сигналы, а также сигналы прочих GNSS-систем.

Signal Architect импортирует траекторию NMEA либо из из ранее записанного файла, либо из файла, сгенерированного при помощи SatGen и использует этот файл при генерировании GNSS-имитируемого сценария. Пользователь задет группу GPS-спутников через файл альманаха в формате Yuma, а группу GLONASS-спутников – через файл альманаха GLONASS в формате .agl или RINEX. После этого эти файлы используются для имитации псевдодальностей, Допплера и фазы несущей частоты для спутников GPS и GLONASS, находящихся в зоне видимости имитируемых GNSS-приемников с заданным углом маски. Полученные имитируемые данные о расстоянии используются для генерирования цифровых I/Q-сигналов для спутников GPS и GLONASS. Пользователи, имеющие доступ к инструментам GNSS Signal Simulation Toolbox (усовершенствованная версия GPS Toolbox) получат дополнительную возможность изменять интенсивность GNSS-сигналов и добавлять модели погрешностей высокого разрешения в имитируемые сигналы, в том числе многолучевое распространение и параметры погрешностей GNSS-сигналов. Полученные имитируемые I/Q-данные для спутников GPS и GLONASS записываются в файл данных, который можно загрузить на оборудование LabSat для воспроизведения на тестовом приемнике.

Результаты тестов с использованием LabSat и SatGen показали, что высокоточные навигационные решения можно получить в различных режимах воспроизведения.

Заключение

Комбинация программного пакета GPS Signal Architect с блоком управления сигналами и платформой USRP, либо с оборудованием LabSat, оказалась идеальным недорогим инструментом имитации GPS-сигналов с возможностью имитации и записи всего спектра GPS-сигналов, включая

гражданские и военные. Первый релиз тестового набора GPS Signal Architect поддерживает работу в диапазоне L1, имитацию C/A-, P- и M-кодированных сигналов, а также запись и воспроизведение C/A-, P(Y)- и M-кодированных сигналов. Оборудование LabSat позволяет генерировать и воспроизводить сигналы GPS и GLONASS.

Команда радиоэкспертов и экспертов в области технологии GPS ведет непрерывную работу над совершенствованием системы с целью появления в ней новых функциональных возможностей. В будущих релизах тестового набора появится поддержка многочастотных программно-определяемых радиосистем и возможность имитации других гражданских и военных GPS-сигналов и сигналов прочих систем глобальной спутниковой навигации. Именно поэтому последняя версия системы имитации получила название GNSS Signal Architect Test Set.

Источник http://www.gpsworld.com/simulating-gps-signals/

Права на перевод ©GPSClub.ru
Перепечатка допускается при активной ссылке на источник перевода

27.11.2012