SB Sources

Общее оглавление

Справочный раздел

Источники дополнительной информации

Книга о коммутаторах

Источники дополнительной информации

Что читать дальше

Технологии

Консорциум 100 VG AnyLAN

Консорциум 100 VG AnyLAN тестирует продукцию на предмет интероперабельности и соответствия стандарту 100 VG AnyLAN, а также публикует новости, связанные с технологией. InterOperability Lab
University of New Hampshire
332 Morse Hall
Durham, NH 03824
Электронная почта: sav@unh.edu
Сервер консорциума

ATM KnowledgeBase

Общая информация о технологии ATM. Сведения о стандартах ATM и реализации проектов в различных отраслях. ATM KnowledgeBase

Страница по ISDN от Dan Kegel

Чудесная страница с базовой информацией по ISDN. Ссылки на различные RBOC и информацию, связанную с реализацией ISDN, производителями и т.п.

Базовая информация по ISDN

Страница по Fast Ethernet от Dan Kegel

Информация о технологии Fast Ethernet (100BaseT), стандартах и производителях.

Информация о Fast Ethernet

Страница Ethernet

Обширная коллекция данных о технологии Ethernet (IEEE 802.3), включая информацию о Fast Ethernet. Страница Ethernet

Консорциум Fast Ethernet

Консорциум Fast Ethernet тестирует оборудование Fast Ethernet (IEEE802.3u) и программы на предмет интероперабельности и соответствия стандартам.
InterOperability Lab
University of New Hampshire
332 Morse Hall
Durham, NH 03824
Электронная почта: bbr@unh.edu
Консорциум Fast Ethernet

Консорциум FDDI Consortium (университет Нью-Гемпшира)

Консорциум FDDI разрабатывает стандарты и распространяет информацию, связанную с технологией FDDI. Сервер консорциума

Комитеты по стандартам

ATM Forum

Организация, занимающаяся разработкой стандартов ATM. На сервере форума ATM Вы можете найти информацию о стандартах и другие сведения о технологии ATM.

2570 W. El Camino Real, Suite 304
Mountain View, CA 94040-1313
Телефон: 1-415-949-6700
Факс: 1-415-949-6705
Электронная почта: info@atmforum.com
Официальный сайт ATM Forum

IEEE

Информация о стандартах и рабочих группах института.
Электронная почта: customer.service@ieee.org

Официальный сервер

Международный телекоммуникационный союз (ITU)

Международный комитет по стандартизации. На сервере ITU много информации, касающейся коммуникационных технологий, включая ATM.

Information Services Department
Place des Nations
1211 Geneva 20
Switzerland
Voice: +41 22 730-6666 or 730-5554
Fax: +41 22 730 5337
Электронная почта: helpdesk@itu.ch
http://www.itu.ch/

Производители программ и оборудования

Корпорация Microsoft

На сервере компании достаточно много информации, связанной с компьютерными сетями.

One Microsoft Way
Redmond, WA 98052
Телефон: (206) 882-8080
Факс: (206) 936-7329
Корпорация Microsoft

Novell Inc.

Обширная информация о сетевой ОС Novell NetWare, используемых протоколах и о сетях вообще.

Novell Incorporated
Corporate Headquarters:
1555 North Technology Way
Orem, UT 84057 USA
Телефон: 1-(801)-222-6000 Or 1-(800)-453-1267
Факс: 1-(800)-453-1267
Сервер компании

Другие источники

Strategic Networks Switched Technology Evaluations

Обзор различных коммутаторов. Продукция от Ethernet до ATM

Сервер компании

Исследовательская группа UC Berkeley Networking

Материалы Калифорнийского университета (Беркли). Информация об исследованиях по ATM, управлению информацией и распределению ресурсов в сетях ATM и многое другое.

Страница исследовательской группы

Книги

Internetworking with TCP/IP, Volumes I and II; by Douglas E. Comer and David L. Stevens

ISBN 0-13-468505-9 (v.1)
ISBN 0-13-472242-6 (v.2)

Том I описывает принципы, протоколы и архитектуру сетей, том II посвящен проектированию и архитектуре. В томе II содержится обширная информация по протоколам TCP/IP. Рассматриваются детали протоколов, варианты реализации, программы.

TCP/IP Network Administration; A Nutshell(R) Handbook by Craig Hunt

ISBN 0-937175-82-X

Практическая информация для сетевых администраторов.

LAN Protocol Handbook; by Mark A. Miller

ISBN 1-55851-099-0

Руководство по программам Netware, PC LAN/OS/2, LAN Server, VINES, AppleTalk, информация по анализаторам протоколов.

Internet Systems Handbook; Edited by Daniel C. Lynch and Marshall T. Rose

ISBN 0-201-56741-5

Описание систем Internet с рекомендациями по работе в сети. Каждая глава книги представляет законченное пособие.

Приведенная в документе информация может быть изменена без предупреждения.
© 1997 Xylan Corporation.
Титульная страница | О компании | О корпорации Xylan | Продукция Xylan | Прейскуранты | Новости | Библиотека | Справочный раздел | Поиск на сервере | Web-мастер
1 июля 1998 года
Перевод на русский язык © 1998, BiLiM Systems Ltd.


SB: Chapter 3 contents

Справочный раздел

Что такое скоростная ЛВС?
Высокоскоростные решения для магистралей
Высокоскоростные решения для серверов
Высокоскоростные решения для рабочих станций
Что следует принимать во внимание?
Выбор технологии

Книга о коммутаторах

Высокоскоростные ЛВС

Glenn Gabriel Ben-Yosef

Что такое скоростная ЛВС?

Для решения проблемы больших задержек и нехватки полосы достаточно установить коммутатор, к каждому порту которого подключено по одному устройству. Коммутация ЛВС не требует требует вносить какие-либо изменения на рабочих станциях, а изменения в сетевой инфраструктуре минимальны. Вместо концентраторов и маршрутизаторов ставятся коммутаторы, которые автоматически настраиваются для работы на MAC-уровне. Однако полоса даже выделенного соединения Ethernet (10 Мбит/с) или token ring (16 Мбит/с) недостаточна для многий приложений и во много раз уступает скорости 100 Мбит/с, обеспечиваемой в сетях FDDI, 100BaseT (Fast Ethernet), 100VG-AnyLAN (IEEE 802.12), а также скоростям ATM.

Переход на более скоростные технологии потребует внесения в сеть большего числа изменений, нежели установка коммутатора. Потребуется не только заменить концентратор и/или маршрутизатор, но и установить новые адаптеры и драйверы для них в каждый компьютер. Переход на более скоростные технологии при корректном выборе решения обеспечит существенное повышение производительности сети. При организации высокоскоростных сетей обычно для передачи основного трафика используются скоростные магистрали, к которым также можно подключить сетевые серверы и даже рабочие станции, если им требуется высокая скорость, малые задержки или передача больших объемов информации.

Высокоскоростные решения для магистралей

Потребности в расширении магистральной полосы связаны в основном с двумя аспектами. Во-первых, централизация серверов и других ресурсов увеличивает объем передачи данных между рабочими группами. При централизации серверы обычно переносятся из рабочих групп и подразделений в единый серверный центр корпоративной сети. Такое решение существенно снижает расходы на управление и поддержку. Кроме того, связь между рабочими группами обычно увеличивает магистральный трафик даже при наличии в группах локальных серверов. На рисунке 3.1 показан пример сети с централизованными ресурсами.

Рисунок 3.1 Насыщение магистрали

Магистральные решения сегодня основываются на передаче кадров или ячеек. Основная разница между этими технологиями заключается в размере передаваемых за один прием блоков информации. Технологии передачи пакетов типа FDDI, Fast Ethernet или 100VG-AnyLAN похожи на традиционные низкоскоростные протоколы ЛВС. Системы ATM используют короткие ячейки фиксированной длины (53 байта), обеспечивающие возможность достаточно точного предсказания времени задержки. Поскольку все ячейки имеют одинаковые размеры, приоритизация трафика может быть реализована за счет организации нескольких очередей или регулировки очередности. Организация магистралей является одним из важнейших применений ATM, поскольку почти все широкополосные приложения критичны к задержкам. Кроме того, технология ATM обеспечивает хорошое масштабирование и может быть использована в распределенных сетях, позволяя увеличить протяженность корпоративных сетей.

FDDI

FDDI является одной из наиболее распространенных магистральных технологий и используется в таком качестве уже достаточно давно. Эффективность магистралей FDDI обусловлена беспристрастностью распределения доступа к среде на основе передачи маркеров и высокой устойчивостью к сбоям и повреждениям. FDDI использует пакеты переменной длины в отличие от ATM. Поскольку технология ATM обеспечивает более высокий уровень масштабирования и гарантированное качество обслуживания, ее применение быстро ширится. Особенно четко это проявляется в сетях с высокой нагрузкой и разнотипным трафиком (голос, данные, видео).

Перспективы ATM

ATM в части организации магистралей превосходит все остальные скоростные технологии. Используемый метод передачи коротких ячеек фиксированной длины обеспечивает высокую эффективность как для широкополосных приложений, так и для критичных к задержкам задач. Эти преимущества поневоле обращают внимание администраторов на ATM-технологии, несмотря на сравнительно высокие цены. Высокий уровень масштабирования ATM обеспечивает простоту перехода от низкоскоростных решений (25 Мбит/с) к скоростям до 2.4 Гбит/с, позволяя использовать полосу пропускания в соответствии с реальными потребностями. Наконец, ATM обеспечивает возможность непосредственного подключения к телекоммуникационному сервису, позволяя предприятиям соединять удаленные сайты через ATM-сети общего пользования.

Высокоскоростные технологии для серверов

Для серверов требуется обычно более высокая скорость в сравнении с рабочими станциями, поскольку с сервером может одновременно работать множество пользователей сети. Если производительность сервера превосходит возможности сети, сервер будет часть времени простаивать. На рисунке 3.2 показана картина трафика при доступе к серверу.

Трафик клиент-сервер может порождать в сети пробки
Рисунок 3.2 Трафик клиент-сервер может порождать в сети пробки

Другой тенденцией является распределение специфических сетевых задач между специализированными аппаратными платформами. Файловый сервис может обеспечиваться одним набором аппаратных платформ, тогда как печать, работа с базами данных, электронная почта или служба каталогов могут быть реализованы на другом оборудовании. Следовательно, рост числа сетевых серверов опрережает темпы роста числа традиционных файловых серверов и сетевых ОС. По мере реализации технологии клиент-сервер на менее дорогих аппаратных платформах растет нагрузка на такие серверы и потребности в полосе доступа к ним. При этом рост потребностей зачастую опережает расширение коммуникационных возможностей.

В средах клиент-сервер зачастую возникают пробки при доступе к серверу многочисленных клиентов. Эта ситуация становится все более частой по мере расширения сферы обслуживания сервера в рамках сети. Поскольку основной трафик сконцентрирован в канале соединения сервера с сетью, обычно для подключения серверов используют скоростные технологии, в результате чего в сети возникают различные по скорости соединения. Для подключения клиентов к коммутатору вполне достаточно полосы 10 Мбит/с, администратор лишь должен решить подключать к портам отдельных пользователей или группы (на основе концентраторов). Однако для соединения сервера с коммутатором следует использовать полосу 100 или 155 Мбит/с с обеспечением буферизации (во избежание блокировки коммутатора).

Серверные соединения достаточно сильно нагружены

Серверные соединения представляют собой достаточно сильно загруженные сегменты, для которых требуется обеспечить устойчивость к сбоям. Если сервер имеет выделенное соединение с ЛВС (через отдельный порт коммутатора), алгоритм контроля насыщения может не играть важной роли, поскольку никакие другие устройства не используют общий с данным сервером канал доступа. Следовательно, выбор технологии может основываться на простоте протокола, пропускной способности, уровне расходов на организацию и поддержку. Некоторые организации с небольшой нагрузкой на серверы объединяют в одном высокоскоростном сегменте несколько серверов. В таких случаях алгоритм контроля насыщения начинает играть важную роль, поскольку при загруженном канале связи сегмента серверов с сетью может возникать значительная задержка. Для таких ситуаций разумно использовать системы с маркерным доступом к среде (например, FDDI).

Системы клиент-сервер дополнительно увеличивают нагрузку

По мере роста числа приложений клиент-сервер нагрузка на каналы доступа к серверам постоянно растет и требуется обеспечивать для каждого сервера канал с высокой пропускной способностью. В конечном итоге все сетевые ресурсы могут оказаться распределенными в сети ATM для обеспечения высокой скорости, масштабируемости и малых задержек. Однако, высокоскоростные соединения ЛВС будут по-прежнему играть важную роль для небольших организаций.

Высокоскоростные технологии для рабочих станций

Потребности расширения полосы для рабочих станций связаны с двумя причинами - рост производительности компьютеров и появление большого числа multimedia-приложений. По мере повышения производительности компьютеров практически каждому пользователю требуется предоставление отдельного коммутируемого порта Ethernet или token ring.

Многие администраторы надеются на быстрое и значительное снижение цен на оборудование ATM и предполагают установить адаптеры ATM на настольные компьютеры. Технологии FDDI и CDDI остаются достаточно дорогими для того, чтобы их можно было использовать на рабочих станциях. Однако, многие пробки в сетях, связанные с ростом потребностей пользователей, можно устранить другими способами. Например, проблемы, связанные с непредсказуемой задержкой передачи пакетов, можно решить за счет снижения числа станций в сегменте. Использование ATM в настольных компьютерах будет определяться темпами снижения цен на оборудование.

Приложения multimedia требуют расширения полосы

Первыми станциями, которым потребуется расширение полосы, будут компьютеры, использующие приложения multimedia. В современных сетях наблюдается постоянный рост числа станций, использующих звуковые и видео-приложения, а также мощные графические пакеты программ. Высокоскоростные ЛВС на базе технологии Fast Ethernet могут решить проблему расширения полосы, оставаясь при этом значительно дешевле систем на основе технологии ATM. Однако, здесь важно учитывать картину трафика и требования его приоритизации.

ATM для настольных компьютеров

Стоимость использования ATM в настольных системах уже не превышает $500 на станцию, но переход на ATM влечет за собой целый ряд сложностей при использовании традиционных протоколов ЛВС. Многочисленные высокоскоростные решения на базе технологий ЛВС обеспечивают более простой способ модернизации локальных сетей. Сетевые адаптеры 10/100 Мбит/с с автоматическим определением скорости являются важной составной частью такого процесса модернизации. В новые компьютеры имеет смысл устанавливать такие адаптеры, даже если в сети пока используется скорость 10 Мбит/с. В этом случае переход от 10BaseT к использованию технологии Fast Ethernet будет значительно проще.

Что следует принимать во внимание?

Программы с интенсивным обменом данными по сети и рост числа рабочих станций послужили причиной быстрого роста потоков данных в сетях. Реорганизация сетей и централизация ресурсов обеспечивают возможность повышения производительности ЛВС. Поскольку никто не хочет рубить под собой сук, одним из наиболее эффективных вариантов модернизации сетей является интеграция высокоскоростных технологий с имеющимися сетевыми инфраструктурами. Понимание ограничений используемых протоколов и их применимости к решаемым задачам обеспечивает возможность выбора правильной технологии и получения максимальных преимуществ. Сетевые среды изменяются от систем на базе хостов и терминалов к распределенной архитектуре клиент-сервер. Это означает, что разработка новых приложений будет вести к росту запросов в части полосы доступа к серверам. Однако простого увеличения полосы может быть недостаточно из-за непредсказуемой задержки пакетов.

Преимущества централизованных систем перед распределенными

Возможно одной из наиболее распространенных целей реконфигурации сетей является централизация серверов. Объединение серверов в одном помещении обеспечивает ряд преимуществ по сравнению с распределением серверов по всей сети и делает решение более гибким. Кроме того, такое решение получается более экономичным за счет снижения расходов на поддержку, обеспечение безопасности и кондиционирование воздуха.

Довольно часто серверы распределены по рабочим группам на разных этажах или в разных зданиях. Каждое подразделение может раелизовать ЛВС для своей рабочей группы, купить и сконфигурировать свой собственный сервер, а потом пожелать интегрировать рабочую группу с остальной сетью. Такая схема может работать в тех случаях, когда основной трафик локализован в рабочих группах. Однако, использование приложений клиент-сервер, электронной почты и взаимодействие рабочих групп могут потребовать единого управления и консолидации сетевых ресурсов. Перенос серверов из локальных сегментов на корпоративную магистраль или в высокоскоростной сегмент ЛВС за пределами магистрали обеспечивает удобство физического доступа к оборудованию и более эффективную систему резервного копирования данных. Многие администраторы пользуются этим случаем для модернизации серверного оборудования и программ, а также организации сетевого сервиса, охватывающего несколько рабочих групп - это обеспечивает достаточно высокую производительность при незначительных расходах.

Консолидация серверов обеспечивает также большую гибкость при выборе решений. Поскольку недорогие системы ЛВС на базе медных кабелей обеспечивают только локальные решения, ограничение длины зачастую определяет выбор технологии для связи сетей и рабочих групп. Размещение серверов в одном помещении или на одном этаже позволяет использовать для их соединения скоростные технологии Fast Ethernet. Организация отдельного коммутируемого сегмента для каждого сервера позволяет эффективно решить проблему задержек, возникающую по причине состязательного характера доступа к среде ЛВС. Кроме того, коммутатор позволяет организовать эффективное и недорогое соединение группы серверов с остальной сетью.

Поддержка сетей и общий уровень расходов

Поскольку во многих организациях расходы на серверы и ЛВС подразделений относят к общему бюджету информационной системы предприятия, обслуживание и поддержка упрощаются при установке оборудования и серверов в одном месте. Кроме того, такая концентрация оборудования позволяет повысить уровень безопасности и облегчить задачу поддержки параметров окружающей среды и питания. В одном помещении с серверами логично разместить и устройства объединения сетей (коммутаторы и маршрутизаторы), что существенно упростит задачи настройки и поддержки сети.

Коммутаторы с промежуточной буферизацией и изменение скорости

Одним из основных вопросов при переходе к высокоскоростным технологиям является простота и надежность объединения с традиционными низкоскоростными ЛВС. Для сетей Ethernet переход от скорости 10 Мбит/с на 100 Мбит/с требует буферизации пакетов в коммутаторе. Память коммутатора играет критически важную роль в обеспечении неблокируемой работы, поэтому требуется использование в коммутаторе промежуточной буферизации (store and forward). Простые коммутаторы cut-through (коммутация на лету), обеспечивающие минимальную задержку при коммутации портов 10 Мбит/с, не обеспечивают требуемой при связи разноскоростных портов буферизации.

Из двух основных типов коммутаторов ЛВС (cut-through и store-and-forward) в общем случае коммутаторы cut-through (в том числе адаптивные) обеспечивают меньшие задержки, поскольку каждый пакет содержит в заголовке алрес получателя, доступный коммутатору и позволяющий обеспечить переключение в нужный порт еще до приема всего пакета. Коммутаторы с промежуточной буферизацией принимают каждый пакет целиком в буфер и только после этого передают его в порт назначения. Преимуществом коммутации store-and-forward является возможность проверки целостности пакета и отбрасывания пакетов, принятых с ошибками. Однако, интеграция высокоскоростных ЛВС с традиционными сетями просто требует буферизации пакетов для согласования скоростей. Для эффективной и надежной неблокируемой коммутации размер буферов должен быть достаточно большим.

Двухскоростные адаптеры и коммутаторы с автоматическим определением скорости

При покупке новых компьютеров в них целесообразно устанавливать адаптеры, способные поддерживать высокую и низкую скорость (10/100 или 4/16 Мбит/с). Двухскоростные адаптеры очень удобны, поскольку режим автоматического определения скорости позволяет использовать такие адаптеры как в старых, так и в новых сетях. Использование универсальных адаптеров позволяет обеспечить эффективность вложения средств, а также упростить настройку и поддержку сети. Разница в цене между высокоскоростными и универсальными адаптерами пренебрежимо мала (иногда ее просто нет), а с учетом затрат на настройку и поддержку сети использование таких адаптеров обеспечивает существенную экономию. Фактически все новые станции имеет смысл оборудовать универсальными адаптерами, что позволит впоследствии без каких-либо проблем перейти на более скоростную технологию. Из всех высокоскоростных технологий Fast Ethernet является в настоящее время наиболее дешевой и популярной за счет полной обратной совместимости с 10BaseT.

Механизм доступа к среде, соответствие задачам и масштабируемость

Вопросы совместимости с установленным оборудованием и программами, а также величина расходов на модернизацию и поддержку сети являются очень важными, но не следует упускать из вида и механизмы доступа к сетевой среде. В большинстве случаев доступ определяется на основе той или иной реализации алгоритма CSMA/CD или передачи маркера. Важно также представлять картину трафика в сети и ее влияние на общую производительность системы. Наконец, вопросы масштабирования сети и понимание текущих требований к пропускной способности и величине задержки также имеют важное значение при выборе скоростной технологии и коммутаторов. Рассмотрев эти вопросы, Вы сможете решить требуется ли Вам коммутатор кадров или коммутатор ячеек.

Развитие алгоритмов контроля за насыщением

Исключая ATM, высокоскоростные технологии ЛВС используют разделяемую среду без организации соединений - в рамках целого сегмента применяется общий коммуникационный канал.

  • Fast Ethernet использует метод доступа CSMA/CD. Непредсказуемая задержка и высокая пропускная способность определяют эффективность использования канала передачи. При небольшом числе станций частота коллизий невелика и повторная передача требуется достаточно редко. Широкая поддержка и обратная совместимость с традиционными протоколами ЛВС обеспечивают экономическую эффективность для такого решения. Двухскоростные адаптеры позволяют обеспечить переход к более скоростной технолгии без какой-либо дополнительной настройки станций. Организация и поддержка сетей также не представляют значительных трудностей, поскольку протоколы Fast Ethernet и Ethernet очень похожи (они относятся к группе IEEE 802.3). Однако, сети Fast Ethernet, подобно своему предшественнику, недостаточно эффективны при высоком уровне загрузки среды. В этом случае рост числа коллизий и связанных с этим повторных передач существенно снижает производительность сети (до половины теоретического значения). Организация выделенных соединений Fast Ethernet обеспечивает решение этой проблемы, но требует существенного увеличения числа портов коммутатора.
  • Технология 100VG-AnyLAN поддерживается небольшим числом производителей оборудования и использует для доступа к среде более сложный алгоритм передачи маркера. Эта технология требует замены во всех станциях сетевых адаптеров на 100VG-AnyLAN и установки соответствующих драйверов. Не каждый адаптер имеет драйверы для нужных операционных систем. Однако, несмотря на достаточно малое распространение и слабую поддержку, технология 100VG-AnyLAN имеет ряд преимуществ перед Fast Ethernet при передаче чувствительного к задержкам трафика. Данная технология обеспечивает практически стопроцентное использование полосы канала передачи даже для разделяемой среды. Кроме того, 100VG-AnyLAN позволяет использовать более дешевый кабель категории 3.
  • FDDI использует сдвоенное оптическое кольцо. Эта технология по-прежнему остается дорогой и требует от администраторов наличия специальных знаний. За счет использования оптических кабелей FDDI поддерживает большую, чем Fast Ethernet или 100VG-AnyLAN, протяженность сети. За счет этого основным вариантом использования FDDI является организация магистралей. Однако, даже для магистралей более эффективным может оказаться использование ATM или менее дорогих технологий скоростных ЛВС.

Сетевой рынок определяет поддержку той или иной технологии и вклад конкретных производителей в разработку устройств. Выбор технологии, поддерживаемой многочисленными производителями (включая мировых лидеров), обеспечивает соответствие стандартам, интероперабельность и разумные цены.

Выбор технологии

Понимание основных преимуществ той или иной высокоскоростной технологии обеспечивает возможность правильного выбора решения.
Сравнение высокоскоростных технологий
Технология | Преимущества | Недостатки
FDDI/CDDI | Хорошо известна и широко распространена Доступность оборудования Эффективная организация магистралей Эффективное подключение серверных групп | Высокая цена Технология практически не развивается Худшие по сравнению с ATM перспективы
100BaseT | Эффективна для подключения серверов Эффективна для подключения рабочих станций Известные протоколы Широкая поддержка | Снижение производительности при большом числе устройств Требует более дорогой кабель категории 5
100VG-AnyLAN | Хорошо приспособлена для критичных к задержкам приложений Использует кабель категории 3 (4 пары) | Небогатый выбор устройств Ограниченная диагностика Малое число производителей
ATM | Масштабируемость Поддержка разных типов трафика (голос, данные и т.д.) Простой переход от Token Ring | Высокие цены Необходимость обучения специалистов Сложность настройки

100VG-AnyLAN

Разработанная и поддерживаемая компанией Hewlett-Packard, технология 100VG-AnyLAN не стала массовой на рынке скоростного оборудования ЛВС. Эта технология описана стандартом IEEE 802.12 и использует новый MAC-протокол, называемый DPAM (Demand Priority Access Method - доступ по приоритету запроса). Технология достаточно хороша для критичных к задержкам приложений (multimedia или серверные группы) и обеспечивает возможность использования видео-приложений даже в сегментах с большим числом станций. Однако, новый протокол, ограниченные средства диагностики и отсутствие широкой поддержки ограничивают использование данного протокола. VG в названии протокола означает voice-grade или категорию 3 для кабельной системы на базе 4 пар стандартного кабеля. Ограниченная поддержка производителями оборудования обусловила также более высокие по сравнению с Fast Ethernet цены.

ATM

Технология ATM в большинстве случаев кажется более дорогой (как оборудование, так и его настройка и поддержка). Поскольку ATM радикально отличается от традиционных технологий ЛВС на основе коммутации пакетов без организации соединений, для реализации и поддержки сетей ATM требуется специальная подготовка персонала. Технология ATM играет очень важную роль в системах реального времени и для широкополосных приложений (голос, видео). Масштабируемость и простота перехода от token ring делают технологию ATM эффективным решением для крупных сетей.

Fast Ethernet

Технология Fast Ethernet быстро занимает лидирующие позиции в сфере подключения рабочих станций. Полная совместимость с кабельными системами 10BaseT обеспечивает простой и недорогой переход от старых технологий. Адаптеры Fast Ethernet зачастую являются двухскоростными (10/100), что позволяет использовать их в традиционных сетях 10BaseT с автоматическим переключением скорости при переходе на Fast Ethernet. Будучи идеальным решением для рабочих станций, Fast Ethernet имеет ряд недостатоков при использовании в магистралях.

Совместимость с кабельными системами, средствами анализа и управления

В то время, как традиционные ЛВС типа Ethernet и token ring работают с различными кабельными системами, включая коаксиальные кабели и IBM Type 1, высокоскоростные ЛВС требуют использования кабеля из скрученных пар категории 5 или многомодового оптического кабеля. Не всегда такие кабельные системы уже имеются на предприятии, а их прокладка может потребовать значительных инвестиций. Некоторые скоростные протоколы (100VG-AnyLAN и 100BaseT4) позволяют применять кабели категории 3 за счет увеличения числа используемых пар.

Приведенная в документе техническая информация может быть изменена без предупреждения.
© 1997 Xylan Corporation.
Титульная страница | О компании | О корпорации Xylan | Продукция Xylan | Прейскуранты | Новости | Библиотека | Справочный раздел | Поиск на сервере | Web-мастер
19 июня 1998 года
Перевод на русский язык © 1998, BiLiM Systems Ltd.

Адрес для критики


SB: Chapter 4

Справочный раздел

ATM
... история и базовые принципы
... как технология ЛВС
... как современная инфраструктура
... парадигма для сетей
... развертывание

Книга о коммутаторах

Часть 4. ATM

ATM

Сегодня для всех организаций вопросы стандартизации играют немалую роль. Не остаются в строне от этого процесса и вопросы стандартизации сетевых решений.

Корпоративные сетевые стандарты позволяют обеспечить эффективное взаимодействие всех станций сети за счет использования одинаковых версий программ и однотипной конфигурации. Однако, значительные сложности возникают при унификации технологии доступа рабочих станций к WAN-сервису, поскольку в этом случае происходит преобразование данных из формата token ring или Ethernet в форматы типа X.25 или T1/E1. ATM обеспечивает связь между станциями одной сети или передачу данных через WAN-сети без изменения формата ячеек - технология ATM является универсальным решением для ЛВС и телекоммуникаций.

Нет сомнений в том, что скоростные технологии ЛВС являются основой современных сетей. ATM, FDDI и Fast Ethernet являются основными вариантами для организация сетей с учетом перспективы. Очевидно, что приложениям multimedia, системам обработки изображений, CAD/CAM, Internet и др. требуется широкополосный доступ в сеть с рабочих станций. Все современные технологии обеспечивают высокую скорость доступа для рабочих станций, но только ATM обеспечивает эффективную связь между локальными и WAN-сетями.

ATM - история и базовые принципы

Технология ATM сначала рассматривалась исключительно как способ снижения телекоммуникационных расходов, возможность использования в ЛВС просто не принималась во внимание. Большинство широкополосных приложений отличается взрывным характером трафика. Высокопроизводительные приложения типа ЛВС клиент-сервер требуют высокой скорости передачи в активном состоянии и практически не используют сеть в остальное время. При этом система находится в активном состоянии (обмен данными) достаточно малое время. Даже в тех случаях, когда пользователям реально не нужна обеспечиваемая сетью полоса, традиционные технологии ЛВС все равно ее выделяют. Следовательно, пользователям приходится платить за излишнюю полосу. Перевод распределенных сетей на технологию ATM позволяет избавиться от таких ненужных расходов.

Комитеты по стандартизации рассматривали решения для обеспечения недорогих широкополосных систем связи в начале 80-х годов. Важно то, что целью этого рассмотрения было применение принципов коммутации пакетов или статистического мультиплексирования, которые так эффективно обеспечивают передачу данных, к системам передачи других типов трафика. Вместо выделения специальных сетевых ресурсов для каждого соединения сети с коммутацией пакетов выделяют ресурсы по запросам (сеансовые соединения). Поскольку для каждого соединения ресурсы выделяются только на время их реального использования, не возникает больших проблем из-за спада трафика.

Проблема, однако, состоит в том, что статистическое мультиплексирование не обеспечивает гарантированного выделения полосы для приложений. Если множество пользователей одновременно захотят использовать сетевые ресурсы, кому-то может просто не хватить полосы. Таким образом, статистическое мультиплексирование, весьма эффективное для передачи данных (где не требуется обеспечивать гарантированную незначительную задержку), оказывается малопригодным для систем реального времени (передача голоса или видео). Технология ATM позволяет решить эту проблему.

Проблема задержек при статистическом мультиплексировании связана в частности с большим и непостоянным размером передаваемых по сети пакетов информации. Возможна задержка небольших пакетов важной информации из-за передачи больших пакетов малозначимых данных. Если небольшой задержанный пакет оказывается частью слова из телефонного разговора или multimedia-презентации, эффект задержки может оказаться весьма существенным и заметным для пользователя. По этой причине многие специалисты считают, что статистическое мультиплексирование кадров данных дает слишком сильную дрожь из-за вариации задержки (delay jitter) и не позволяет предсказать время доставки. С этой точки зрения технология коммутации пакетов является совершенно неприемлемой для передачи трафика типа голоса или видео.

ATM решает эту проблему за счет деления информации любого типа на небольшие ячейки фиксированной длины. Ячейка ATM имеет размер 53 байта, пять из которых составляют заголовок, оставшиеся 48 - собственно информацию. В сетях ATM данные должны вводиться в форме ячеек или преобразовываться в ячейки с помощью функций адаптации. Сети ATM состоят из коммутаторов, соединенных транковыми каналами ATM. Краевые коммутаторы, к которым подключаются пользовательские устройства, обеспечивают функции адаптации, если ATM не используется вплоть до пользовательских станций. Другие коммутаторы, расположенные в центре сети, обеспечивают перенос ячеек, разделение транков и распределение потоков данных. В точке приема функции адаптации восстанавливают из ячеек исходный поток данных и передают его устройству-получателю, как показано на рисунке 4.1.

Рисунок 4.1 Адаптация ATM

Передача данных в коротких ячейках позволяет ATM эффективно управлять потоками различной информации и обеспечивает возможность приоритизации трафика.

Пусть два устройства передают в сеть ATM данные, срочность доставки которых различается (например, голос и трафик ЛВС). Сначала каждый из отправителей делит передаваемые данные на ячейки. Даже после того, как данные от одного из отправителей будут приниматься в сеть, они могут чередоваться с более срочной информацией. Чередование может осуществляться на уровне целых ячеек и малые размеры последних обеспечивают в любом случае непродолжительную задержку. такое решение позволяет передавать срочный трафик практически без задержек, приостанавливая на это время передачу некритичной к задержкам информации. В результате ATM может обеспечивать эффективную передачу всех типов трафика.

Даже при чередовании и приоритизации ячеек в сетях ATM могут наступать ситуации насыщения пропускной способности. Для сохранения минимальной задержки даже в таких случаях ATM может отбрасывать отдельные ячейки при насыщении. Реализация стратегии отбрасывания ячеек зависит от производителя оборудования ATM, но в общем случае обычно отбрасываются ячейки с низким приоритетом (например, данные) для которых достаточно просто повторить передачу без потери информации. Коммутаторы ATM с расширенными функциями могут при отбрасывании ячеек, являющихся частью большого пакета, обеспечить отбрасывание и оставшихся ячеек из этого пакета - такой подход позволяет дополнительно снизить уровень насыщения и избавиться от излишнего объема повторной передачи. Правила отбрасывания ячеек, задержки данных и т.п. определяются набором параметров, называемым качеством обслуживания (Quality of Service) или QoS. Разным приложениям требуется различный уровень QoS и ATM может обеспечить этот уровень.

Поскольку приходящие из разных источников ячейки могут содержать голос, данные и видео, требуется обеспечить независимый контроль для передачи всех типов трафика. Для решения этой задачи используется концепция виртуальных устройств. Виртуальным устройством называется связанный набор сетевых ресурсов, который выглядит как реальное соединение между пользователями, но на самом деле является частью разделяемого множеством пользователей оборудования. Для того, чтобы сделать связь пользователей с сетями ATM как можно более эффективной, виртуальные устройства включают пользовательское оборудование, средства достуа в сеть и собственно сеть ATM.

В заголовке ATM виртуальный канал обозначается комбинацией двух полей - VPI (идентификатор виртуального пути) и VCI (идентификатор виртуального канала. Виртуальный путь применяется в тех случаях, когда 2 пользователя ATM имеют свои собственные коммутаторы на каждом конце пути и могут, следовательно, организовывать и поддерживать свои виртуальные соединения. Виртуальный путь напоминает канал, содержащий множество кабелей, по каждому из которых может быть организовано виртуальное соединение.

Поскольку виртуальные устройства подобны реальным, они также могут быть "выделенными" или "коммутируемыми". В сетях ATM "выделенные" соединения называются постоянными виртуальными устройствами (PVC), создаваемыми по соглашению между пользователем и оператором (подобно выделенной телефонной линии). Коммутируемые соединения ATM используют коммутируемые виртуальные устройства (SVC), которые устанавливаются путем передачи специальных сигналов между пользователем и сетью. Протокол, используемый ATM для управления виртуальными устройствами подобен протоколу ISDN. Вариант для ISDN описан в стандарте Q.931, ATM - в Q.2931.

Виртуальные устройства ATM поддерживаются за счет мультиплексирования трафика, что существенно снижает расходы на организацию и поддержку магистральных сетей. если в одном из виртуальных устройств уровень трафика невысок, другое устройство может использовать часть свободных возможностей. За счет этого обеспечивается высокий уровень эффективности использования пропускной способности ATM и снижаются цены. Небольшие ячейки фиксированной длины позволяют сетям ATM обеспечить быструю передачу критичного к задержкам трафика (например, голосового). Кроме того, фиксированный размер ячеек обеспечивает практически постоянную задержку, позволяя эмулировать устройства с фиксированной скоростью передачи типа T1E1. Фактически, ATM может эмулировать все существующие сегодня типы сервиса и обеспечивать новые услуги. ATM обеспечивает несколько классов обслуживания, каждый из которых имеет свою спецификацию QoS.

Класс QoS | Класс обслуживания | Описание
1 | A | производительность частных цифровых линий (эмуляция устройств или CBR)
2 | B | пакетные аудио/видео-конференции и multimedia (rt-VBR)
3 | C | ориентированные на соединения протоколы типа frame relay (nrt-VBR)
4 | D | протоколы без организации соединений типа IP, эмуляция ЛВС (ABR)
5 | Unspecified | наилучшие возможности в соответствии с определением оператора (UBR)

Большая часть трафика, передаваемого через сети ATM использует класс обслуживания C, X или Y. Класс C определяет параметры QoS (качество обслуживания) для задержки и вероятности отбрасывания, но требует от пользователя аккуратного управления трафиком во избежание перенасыщения сети. трафик класса X дает пользователю большую свободу, но может не обеспечить стабильной производительности. Класс Y, называемый также "Available Bit Rate" (ABR или доступная скорость) позволяет пользователю и сети установить совместно скорость на основе оценки потребностей пользователя и возможностей сети.

ATM как технология ЛВС

Технология ATM изначально создавалась как часть сервиса "Broadband ISDN" под эгидой CCITT (сейчас ITU). Однако возможности ATM можно эффективно использовать и в локальных сетях.

Современные крупные сети используются для передачи самых разных типов данных, включая изображения, звук, CAD/CAM и т.п. Несмотря на то, что большинство компьютерных приложений используется уже достаточно давно, возможности современных настольных компьютеров позволяют по новому подойти к организации работы. Однако, рост возможностей настольных компьютеров существенно опережает расширение сетевых возможностей (в частности, пропускной способности сетей).

Возьмем для примера издательские системы, где с одним набором данных может одновременно работать множество людей. Представьте себе процесс подготовки газетной полосы для публикации. редакторы работают с одной частью полосы, корректоры просматривают текст, дизайнеры размещают материал на полосе - и все это происходит в одно время. Не будем забывать и о том, что высокое качество печати требует использования графических фалов размером в сотни мегабайт. Традиционные сети обеспечивают разделение доступа к таким файлам, однако из-за ограниченной пропускной способности доступ к расположенному на другом компьютере файлу размером в несколько сот мегабайт будет отнюдь не быстрым. ATM 25 позволяет пользователям организовать каналы доступа с полосой 25 Мбит/с для работы с серверами. Такое решение избавляет от задержек и позволяет готовить публикации существенно быстрее.

Преимущества ATM не ограничиваются вертикальным рынком. Сегодня организации могут связать через магистрали ATM свои корпоративные серверы. Можно ожидать и достаточно широкого использования ATM в настольных компьютерах при работе пользователей с большими объемами данных или использовании критичных к задержкам приложений.

Экономический фактор играет далеко не последнюю роль в расширении использования технологий ATM. Сегодня большинство людей использует в своей работе и телефон и компьютер. В течение нескольких лет существенно расширится обмен данными multimedia (клипами), использование видеоконференций и т.п. технология ISDN позволяет решить такие задачи. Однако, это потребует установки оборудования ISDN в каждый компьютер. Телефонные и сетевые кабельные системы не могут полностью совпадать, что дополнительно увеличивает сложность такого решения. Использование решения на базе ISDN с необходимостью приведет к возникновению параллельных кабельных систем для ЛВС и телефонии и подключению каждого компьютера к обеим системам. Нужно учесть еще и телевизионные кабели, которые также требуется проложить по причине расширения использования настольных видео-приложений. Такая кабельная система будет весьма сложна, а ее установка и поддержка потребуют высоких расходов. Переход на использование технологии ATM в локальных сетях позволяет обойтись одной кабельной системой и одним адаптером в компьютере, что не может не привести к значительному снижению расходов.

ATM позволяет не только организовать ЛВС, но может обеспечить передачу голосового и видео-трафика. Такое решение позволяет использовать настольные системы видеоконференций и приложения multimedia.

Фактически, использование ATM обеспечивает сразу множество премуществ. Во-первых, высокая скорость доступа за приемлемую цену, во-вторых, возможность организации компактных магистралей на базе ATM (collapsed backbone). Наконец, эта архитектура обеспечивает сквозное повышение эффективности использования сетевых ресурсов.

Пользователи, которые думают об использовании ATM в будущем, должны использовать совместимые с ATM устройства уже сегодня - в противном случае переход может оказаться слишком дорогим и трудоемким. Мы рассмотрим этот вопрос более подробно в следующем разделе.

ATM как современная инфраструктура

Если виртуальные устройства напоминают реальные, ATM можно легко приспособить для текущих приложений, просто заменив выделенные или коммутируемые линии виртуальными устройствами ATM. Фактически, этот способ вместе с переходом на ATM в сетевых магистралях, является наиболее очевидным первым шагом.

На рисунках 4.2, 4.3 и 4.4 показан типичный пользовательский сайт с устройствами, порождающими разнотипный трафик (голос, видео, данные). Эти три типа трафика могут передаваться с использованием сервиса ATM тремя показанными на рисунках способами.

1. Голос, данные и видео преобразуются в ячейки ATM в сети оператора с использованием функций адаптации ATM. Оператор будет реализовать все функции доступа и передачи, а для каждого устройства потребуется отдельная линия доступа в сеть ATM.

Раздельный доступ для каждого устройства
Рисунок 4.2 Преобразование в ATM осуществляется оператором

2. ЛВС, голосовые и видео-устройства подключаются к локальному коммутатору ATM для преобразования трафика в ячейки. Для доступа в сеть оператора используется одна линия, передающая все потоки трафика одновременно (как виртуальные устройства). Сеть оператора обеспечивает маршрутизацию трафика. Такое решение более экономично и может использоваться для организации "частных сетей ATM" для пользователей, которые имеют доступ к ATM-сервису или хотят создать свою распределенную сеть на базе ATM. Отметим, что находящийся в сети пользователя коммутатор ATM может принадлежать оператору и находиться у него на обслуживании.

Доступ различных устройств в сеть ATM через один коммутатор
Рисунок 4.3 Преобразование в ATM осуществляется у пользователя

3. Устройства оборудуются собственными интерфейсами ATM. Одно устройство доступа позволяет объединить весь пользовательский трафик в одном транке, связанном с сетью оператора. В этом случае на стороне пользователя устанавливается принадлежащее ему оборудование ATM, которое можно использовать для организации магистралей ЛВС или подключения настольных станций.

Сеть на базе ATM
Рисунок 4.4 Сеть на базе ATM

Скорое появление интерфейсов ATM в телефонном и видео-оборудовании не представляется вероятным, поэтому реализация третьего варианта соединения с сетью не сможет в ближайшие годы стать доминирующей. Фактически, скорость распространения каждого из приведенных вариантов будет определяться темпами снижения цен на оборудование и услуги опереторов сетей ATM. Отсутствие эффективного управления этими процессами порождает определенный хаос и не позволяет надежно предсказать перспективы того или иного сервиса ATM.

Стандарт, определяющий интерфейс между операторами и пользователями ATM называется Public User Network Interface или Public UNI. Этот интерфейс определяется для различных значений скорости. Первые услуги ATM предлагались в основном со скоростью T3 (45 Мбит/с). Сейчас многие операторы предлагают скорость 155 Мбит/с и выше, но такая полоса обычно не требуется пользователям, да и стоимость подобных услуг весьма высока. Для большинства пользователей, планирующих организовать доступ к ATM или создать частную сеть ATM основной проблемой является стоимость оборудования.

Форум ATM - организация производителей оборудования ATM и пользователей работает в направлении развития стандартов и обеспечения интероперабельности оборудования. В конечном итоге это не может не привести к снижению цен. Кроме обеспечения интероперабельности ATM ведется большая работа по реализации ATM на скоростях меньше T3. Здесь возможно несколько вариантов:

  1. Полнофункциональные решения ATM при скорости T1. Один стандарт для ATM T1 уже утвержден, но некоторые производители и пользователи считают, что связанные с реализацией этого стандарта накладные расходы слишком велики - канал T1 с полосой 1.544 Мбит/с может обеспечить полезную полосу только около 1.1 Мбит/с.
  2. Так называемый dixie-стандарт (от акронима DXI - Data eXchange Interface). DXI был разработан как способ использования ATM в кадровом режиме с маршрутизаторами и другими устройствами передачи данных и специальными устройствами DSU, обеспечивающими преобразование кадров в реальные ячейки ATM. DXI работает через стандартные интерфейсы типа V.35 и HSSI.
  3. Интерфейс пользователь - сеть Frame Relay или F-UNI (произностися как FOONY), являющийся стандартом использования frame relay для доставки "кадров данных ATM" в сеть, которая будет конвертировать их в ячейки непосредственно на границе сети.
  4. Инверсное мультиплексирование ATM или AIM - стандарт для инверсного мультиплексирования множества линий T1 в один транк с полосой между T1 и T3. Такая полоса обеспечивает поддержку ATM для приложений, где скоростные запросы незначительно превышают возможности T1.
Проверка этих вариантов показывает, что они в основном подходят для систем обмена данными. Причиной этого является эффективная поддержка технологией ATM взрывного трафика современных систем передачи данных (ЛВС). Как было отмечено выше ATM может просто использоваться взамен выделенных линий в таких сетях, обеспечивая коммутацию ЛВС, поддерживаемую ATM UNI.

Замена выделенных линий системами ATM позволяет более эффективно организовать сети. Отметим, что виртуальные устройства ATM используются для организации многосвязных систем, позволяющих обеспечить доставку трафика непосредственно адресату. Сегодня желание пользователей применять многосвязные системы на базе ATM для связи своих сетей в значительной мере определяется предлагаемыми операторами ценами на услуги. Если оператор берет деньги за каждое виртуальное устройство ATM UNI, а не за общий трафик, стоимость организации многосвязной сети может оказаться слишком велика. Конечно, в кампусной магистрали ATM стоимость полосы в многосвязной системе будет несравненно ниже. Поддержка многосвязности требует лишь прокладки дополнительных физических соединений (кабелей) и установки более скоростных транковых портов в коммутаторы. Эти дополнительные расходы достаточно малы по сравнению с общей стоимостью сети.

Рисунок 4.5 Многосвязная сеть
В многосвязной (каждый с каждым) сети ATM существует меньше транзитных точек, снижающих производительность и вносящих дополнительные задержки и насыщение. Такое решение обеспечивает существенное повышение стабильности работы приложений. Более того, каждый коммутатор является соседом для всех остальных коммутаторов и связан с ними напрямую. Это упрощает задачу динамическогго определения маршрута для протоколов маршрутизации типа RIP, используемого TCP/IP или NetWare, OSPF или IS-IS. Эти протоколы часто генерируют значительный трафик и могут существенно замедлить сеть при обмене конфигурационными данными (интервал сближения или конвергенции).

Если существует способ передачи "телефонного номера" ATM точке публичной сети ATM, которая достаточно близка к пользователям традиционной ЛВС, насколько можно приблизиться к пользователям? Ближайшей, готовой к использованию ATM станцией, сегодня является коммутаторю Это может быть магистральный коммутатор пользователя, коммутатор рабочей группы или даже настольный компьютер с адаптером ATM. В этом случае ATM используется как универсальная архитектура для коммуникаций, обеспечивающая связь между настольными системами вместе с традиционными технологиями ЛВС, а в некоторых случаях - взамен их. Это наиболее интересная, но и наиболее спорная часть применений ATM.

Сквозная ATM-парадигма для сетей

ATM на настольных станциях имеет несколько преимуществ. Во-первых, способность ATM гарантировать для приложений качество обслуживания (QoS) обеспечивает сквозную передачу критичного к задержкам трафика типа видео или голоса. Будучи технологией передачи данных, ATM не только может поддерживать "приложения завтрашнего дня", но и эффективно справляется с сегодняшними задачами. Пользователи задаются двумя основными вопросами - как будут формироваться распределенные сети на базе ATM и какие шаги нужно предпринять, чтобы быть готовым к переходу? Есть три разных варианта включения ATM в архитектуру межсетевого взаимодействия для современных и будущих приложений:

  1. Эмуляция традиционных протоколов ЛВС с использованием оборудования ATM. В этом случае существующие приложения будут продолжать работать как раньше, а ATM-добавит к существующим протоколам новые, специально разработанные для приложений multimedia. Отметим, что слово "новые" в данном контексте отнюдь не означает, что эти протоколы еще не существуют (они скорее еще не стали общепринятыми).
  2. Подключение сервиса ATM напрямую к интерфейсам прикладных программ, используемых сегодня, в обход традиционных протоколов нижних уровней. Для поддержки этого варианта потребуется разработка новых API.
  3. Использование новых API для "новых" приложений и эмуляция традиционных протоколов для существующих приложений.

Поскольку использование ATM обычно начинается с нескольких станций, которым требуются multimedia-приложения, требуется обеспечить эмуляцию традиционных протоколов ЛВС в сетях ATM. Это позволяет обеспечить надежное взаимодействие между новыми станциями на базе ATM и традициооными ЛВС. Для эмуляции ЛВС в системах на базе ATM (ATM LAN emulation) предложены два варианта - ATM Forum LAN Emulation (LANE) и RFC 1577. Говоря здесь об эмуляции, мы имеем в виду оба варианта.

Как LANE, так и RFC 1577 основаны на допущении что пользователи ATM применяют адаптеры, поддерживающие интерфейс ATM UNI. Поскольку этот интерфейс располагается со стороны пользователя, его иногда называют "Private UNI"; существует набор стандартов, определяющих данный интерфейс. Стандарты Private UNI существуют для скоростей 25 Мбит/с (по медному кабелю), 100 Мбит/с (оптический кабель)и 155 Мбит/с (медь и оптика). Оба стандарта эмуляции ЛВС предполагают также, что пользователи подключены к коммутатору ATM. Некоторые ATM-коммутаторы поддерживают также станции других типов (не ATM). Такие коммутаторы обеспечивают взаимодествие между ЛВС Ethernet и token ring и сетями ATM. Коммутаторы также поддерживают порты (для подключения станций и серверов) и транки (для соединения коммутаторов ATM или подключения к магистральным коммутаторам) ATM. Интерфейс между коммутаторами основан на UNI, но включает дополнительно специальные сообщения для маршрутизации и управления состоянием маршрутов. ATM Forum называет этот интерфейс Private Network-to-Network Interface или P-NNI.

Эмуляция ЛВС во всех вариантах состоит из двух программных частей - функции клиента используются на конечных системах, подключенных к эмулируемым ЛВС, а функции сервера - реализуются в каждой группе клиентских станций. Группа клиентов и связанный с ней сервер называются эмулируемой ЛВС (Emulated LAN или ELAN).

Протоколы ЛВС являются многоуровневыми и, следовательно, любой стандарт, обеспечивающий взаимодействие традиционных ЛВС и ATM должен обеспечивать поддержку соответствующих уровней. В этом вопросе существующие стандарты эмуляции ЛВС существенно различаются. ATM LANE (стандарт ATM Forum) предназначен для эмуляции протоколов канального (MAC/LLC) уровня. Поскольку этот протокол занимает самый нижний для ЛВС уровень, LANE можно использовать со всеми протоколами ЛВС вышележащих уровней, включая TCP/IP, NetWare SPX/IPX, IBM SNA/LLC2. RFC 1577, с другой стороны, работает на сетевом уровне (уровень 3) и предназначен для протокола TCP/IP.

Оба варианта эмуляции ЛВС похожи по принципам работы, несмотря на различие уровней. При организации ATM ЛВС клиентские системы пытаются вступить в контакт с сервером и зарегистировать адресную информацию, которая содержит адрес ATM, а таже адреса канального и сетевого уровней. Сервер строит каталог адресной информации для последующего использования. По завершении регистрации клинеты и серверы переходят в режим ожидания пользовательского трафика.

Пользовательские программы, работаюие на клиентских и серверных системах, функционируют в среде эмуляции ЛВС как в обычных средах традиционных локальных сетей и только коммуникационные драйверы нижних уровней связаны с ATM. Когда программа генерирует сообщение, это сообщение передается вниз по стеку протоколов программам ATM, прибывая к ним в форме дейтаграммы или сообщения без организации соединения на уровне два (канальном) или уровне 3 (сетевом) в зависимости от способа эмуляции ЛВС. ограммы ATM должны обеспечить эмуляцию ЛВС.

Если между отправителем и получателем будет существовать виртуальное устройство, дейтаграммы можно просто помещать в это виртуальное устройствои передавать получателю в исходной форме (дейтаграмма) для обработки на станции получателя программами ATM и приложением. Фактически, каждый клиент ATM поддерживает таблицу адресов канального и сетевого уровня, а же едентификаторов виртуальных устройств ATM (VPI/VCI). Если адрес получателя найден в таблице, дейтаграмма передается соответствующему виртуальному устройству. Проблема возникает когда адрес получателя не найден - в этом случае в игру вступает сервер эмуляции ЛВС.

Клиентская система, не имеющая виртуального устройства ATM, должна организовать его, но дейтаграмма является сообщением ЛВС и не содержит ATM-адреса получателя. Для получения этого адреса клиент посылает сообщение своему серверу, указывая получателя дейтаграммы с помощью адреса сетевого и/или канального уровня и запрашивая соответствующий адрес ATM. Сервер сообщает адрес, после чего клиент организует коммутируемое соединение ATM SVC с адресатом, в которое направляется поток дейтаграмм.

Сервер также обеспечивает поддержку широковещательного и неадресованного (broadcast and unknown) трафика для клиентов, рассылающих широковещательные и групповые (multicast() дейтаграммы. Сервер в таких случаях пересылает принятые дейтаграммы всем зарегистрированным клиентам. Перед организацией SVC клиент может также использовать режим "broadcast and unknown" для рассылки дейтаграмм адресатам, для которых адреса ATM еще не получены.

Устройства традиционных ЛВС должны обмениваться данными со станциями ATM, работающими в эмулируемых ЛВС; коммутаторы обеспечивают функции proxy-клиента от имени станций традиционных ЛВС (не ATM). В этом случае станция ATM, вызывающая станцию ЛВС будет получать от сервера адрес proxy-клиента и организовывать SVC по этому адресу. Proxy-клиент будет в этом случае играть роль моста или маршрутизатора для передачи дейтаграмм нужной станции. На практике такое использование эмуляции является преобладающим, поскольку большинство настольных станций по-прежнему используют Ethernet или token ring.

Это может выглядеть как попытка создания всемирной "плоской" сети, но это не так. RFC 1577 задает ограничение на размер доменов эмуляции ЛВС - не более одной IP-подсети на домен. ATM Forum LANE не содержит такого ограничения, но практический размер домена устанавливается числом генерируемых многоадресных сообщений (с ростом этого числа растет нагрузка на сервер и клиентов). В действительности LANE представляет собой мост, а широковещательный и групповой трафик всегда является ограничивающим фактором для сетей на базе мостов.

Как связать между собой эмулируемые домены ЛВС? Лучшим способом является использование коммутаторов ЛВС. Поскольку коммутатор может одновременно работать с ATM LANE и дейтаграммами традиционных ЛВС, он может обеспечивать связь эмулируемых доменов (как подсетей IP или сегментов ЛВС).

Проблема возникает при использовании маршрутизаторов для соединения устройств ATM, использующих multimedia-приложения. Маршрутизаторы, как устройства, работающие без организации соединений, не могут обеспечивать гарантии качества обслуживания (QoS), предлагаемой коммутаторами ATM. Таким образом, маршрутизатор между двумя станциями ATM существенно ограничивает возможности связи между этими станциями (до уровня станций традиционных ЛВС). Решения на базе коммутаторов позволя сохранить гибкость и скорость ATM.

Естественные соединения ATM требуют коммутируемого пути между адресатом и отправителем. Если оба устройства подключены к одному коммутатору, проблем не возникает. Также просто организовать связь между устройствами, использующими услуги одного оператора или коммутаторы одного производителя. При соединении устройств в среде с разнотипным оборудованием может потребоваться использование PNNI для организации мостов между двумя или несколькими коммутаторами ATM и в тех случаях, когда ATM-соединение организуется через распределенную сеть (WAN).

Существует три варианта организации "реальных" соединений ATM через распределенную сеть:

  1. Выделенная цифровая линия от оператора (T3, например) служить транком между двумя коммутаторами ATM - эти коммутаторы будут генерировать ячейки, обеспечивать сигнализацию ATM и поддерживать потоки трафика. Фактически, это вариант частной сети ATM.
  2. Оператор ATM может обеспечивать виртуальный путь между парой коммутаторов. В этом случае оператор передает ячейки и принимает участие в управлении трафиком ATM, но соединенные между собой устройства управляются виртуальными устройствами как при использовании соединения по выделенной линии.
  3. Может использоваться предоставляемое оператором коммутируемое соединение ATM SVC.

В первых двух вариантах ATM-коммутаторы принадлежат пользователю и должны выполнять все операции по преобразованию адресов (логические адреса, известные приложениям, конвертируются в реальные адреса ATM). В последнем варианте может потребоваться преобразование адресов оператором или, по крайней мере, использование архитектуры, поддерживающей соединений частных сетей через публичные. Одна из таких архитектур обеспечивается протоколом NHRP (маршрутизация в следующий интервал), предложенным IETF. Поскольку элементы протокола NHRP включены в базовую архитектуру стандарта ATM Forum MPOA, очевидно, что MPOA будет поддерживать управление адресами в больших сетях ATM, подключенных к системам общего пользования.

В долгосрочной перспективе ATM может полностью заменить технологии ЛВС и системы межсетевого взаимодействия в их современном виде. Сети на базе коммутаторов, в результате, будут значительно более гибкими, нежели связанные между собой ЛВС. Стоимость таких решений также может оказаться меньше. Многие пользователи верят в перспективность ATM и даже неизбежность успеха этой технологии. Однако переход к использованию ATM тормозится высокими ценами на оборудованиеи сложностью его использования.

Эволюция

Большинство организаций входят в одну из трех категорий с точки зрения перспектив использования ATM:

  1. Организации, которые используют приложения сильно выигрывающие в результате перехода на ATM. Примером компаний этого класса являются организации здравоохранения, брокерские фирмы с большими потоками коммерческой информации, компании, занимающиеся производством видеопродукции.
  2. Организации, которые могут перейти на ATM в результате агрессивной ценовой политики поставщиков услуг.
  3. "Оборонительная стратегия" Организации этого типа знают, что технология ATM обеспечит им целый ряд преимуществ, но пока не планируют использовать данную технологию.
Для любой компании первым правилом эволюции ATM является предотвращение потери средств, вложенных на этапе оценки технологии ATM. Это означает, что при покупке сетевого оборудования сегодня нужно принимать во внимание возможность использования этого оборудования в будущей сети на базе ATM. Если от закупаемого сегодня оборудования придется потом отказываться, лучше сразу поискать другое решение.

Это правило наиболее ярко проявляется при выборе сетевых коммутаторов. Приобретаемые сегодня устройства должны обеспечивать возможность использования в системах на базе ATM. Минимальным требованием является возможность использования ATM-транков для связи между коммутаторами. Желательно также иметь в коммутаторе порт (или гнездо для его установки), позволяющий в будущем подключить настольные станции с интерфейсом ATM. Маршрутизаторы, пока не будет найдено более эффективного решения для ATM, должны использоваться как краевые устройства, обеспечивающие возможность подключения устройств традиционных ЛВС к сетям ATM. По крайней мере, такие устройства должны иметь интерфейс proxy-клиента эмуляции ЛВС.

Организации с "оборонной" стратегией, отмеченные в категории три, могут счесть наличие транкового порта ATM в коммутаторе достаточной для ближайших перспектив использования ATM (использовать не будем, но на всякий случай возьмем).

Компании, планирующие для ATM ключевую роль в своей сети, должны выбирать коммутаторы с портами ATM для подключения настольных станций. ATM обеспечивает широкий диапазон скоростей для подключения настольных станций - от 25 до 155 Мбит/с. ATM25 работает с кабельными системами категории 3 - 5 и может использоваться вместо token ring или 10BaseT для станций с высоким уровнем сетевых запросов.

Снижение цен на оборудование ATM для настольных станций играет важную роль, поскольку сегодня приложений, не способных обойтись без возможностей ATM, еще не так много. Скорей всего, пользователи первых станций ATM будут работать с одним из расмотренных выше вариантов эмуляции ЛВС и большинство приложений будут скорее использовать эмуляцию, нежели естественные ATM API. Адаптеры ATM и коммутационные технологии дожны удовлетворять потребности пользователей в течение 5 -8 лет, а скорость отказа от традиционных технологий ЛВС будет в значительной мере определяться темпами расширения числа видеоприложений.

Понимание того, что большинство пользователей не работает с приложениями, требующими возможностей ATM зачастую служит тормозом внедрения ATM, поскольку никому не хочется тратить деньги га приобретение неиспользуемых возможностей. Использование ATM только на части станций избавит от ненужных расходов на модернизацию сети.

Если вы предполагаете начать использование ATM в настольных станциях в течение ближайшей пары лет, вам нужно выбирать коммутаторы с учетом этой перспективы. Коммутаторы должны иметь порты для подключения станций и магистральны порты 155 и 622 Мбит/с для соединения коммутаторов. Порты ATM должны поддерживать эмуляцию ЛВС. Важно также обратить внимание на перспективы реализации в коммутаторах поддержки таких протоколов, как RFC 1577 и MPOA. наконец, транковый интерфейс для связи с другими коммутаторами должен поддерживать стандарт PNNI.

Если оператор ATM предлагает свои услуги по разумным ценам или ваша организация планирует организовать собственную магистраль ATM, следует оценить потребности до покупки оборудования ATM. Остается ответить на вопрос "Какой тип ATM-сервиса использовать?"

Публичные или частные системы ATM будут нормально поддерживать подключение устройств frame relay через специальные преобразователи (ATM DSU/CSU). Если ваше соглашение с оператором ATM требует покупки такого оборудования для подключения других источников трафика к ATM, может оказаться более эффективной реализация сервиса frame relay на базе существующих коммутаторов и их связь с ATM через краевые устройства.

Если для подключения связывающих сети устройств (типа маршрутизаторов) к ATM вам потребуется покупать дополнительные устройства, лучше будет купить интерфейс ATM для коммутатора. Этот интерфейс можно будет использовать и после перехода на ATM, тогда как устройства DSU/CSU после такого перехода станут просто ненужными. Существует три варианта подключения ATM к коммутаторам:

  1. Естественная форма ATM (ячейки) с прямым подключением цифрового транка ATM (обычно T1 или T3) к маршрутизатору. Этот тип интерфейса может поддерживать все типы сервиса ATM (включая multimedia). Такой вариант целесообразно выбирать при планировании перехода от маршрутизаторов к коммутаторам ATM.
  2. DXI-форма ATM - интерфейс на основе кадров, поддерживающий только транспортный сервис ATM, ориентированный на передачу данных. Такой тип подключения хорош для систем, где не планируется замена маршрутизаторов на коммутаторы ATM. Выбирая этот вариант, следует помнить, что некоторые операторы ATM не поддерживают DXI-сервис и может потребоваться покупка ATM DSU/CSU для преобразования DXI в ячейки ATM.
  3. Интерфейс F-UNI, который представляет собой вариант интерфейса frame relay с поддержкой сигнализации ATM. Этот вариант пока распространен недостаточно широко, но может обеспечить просто и недорогой переход для маршрутизаторов, которые уже поддерживают frame relay.
При любом варианте перехода на ATM в первую очередь возникает задача организации магистралей. Организация компактных магистралей (collapsed backbone) без использования технологии ATM в таком случае будет весьма рискованным решением. Магистральные технологии при переходе на ATM приходится менять в первую очередь. Наиболее критичным при переходе на ATM будет первый шаг в сторону от традиционной коммутатции ЛВС. В системах коммутации ЛВС без ATM-транков магистрали не используют технологии ATM и, следовательно, модернизация магистралей будет достаточно рискованным шагом. В идеальном случае коммутаторы ЛВС должны поддерживать магистрали ATM и других типов (например, FDDI).

Переход приложений на ATM будет постепенным. На настольных станциях ATM будет поначалу использоваться для эмуляции ЛВС и работы с набором традиционных приложений ЛВС. По мере расширения инфраструктуры ATM станет возможным связать большие группы пользователей в "чистые" сети ATM. Это позволит использовать специальные приложения, рассчитанные на качество обслуживания ATM (видео, multimedia и т.п.) или упростить работу с традиционными потоками данных за счет более высокой производительности ATM.

ATM, по мере реализации, будет делать сеть компании более гармоничной - сначала на уровне магистралей, а потом и для настольных систем. Полный переход на ATM наверняка будет определяться темпами снижения цен на порты для подключения настольных станций и адаптеры, а также реализацией поддержки возможностей в прикладных программах. Использование единой технологии для организации магистралей, подключения настольных станций и распределенных сетей может обеспечить, в конечном итоге, существенную экономию.

В долгосрочной перспективе ATM должна стать единой архитектурой внутрикорпоративных и межкорпоративных коммуникаций. Коммутируемые виртуальные устройства, используемые настольными системами могут быть расширены за счет поддержки соединений SVC операторами публичных сетей, делая ATM универсальной технологией multimedia-сетей. Протоколы типа NHRP являются средством обеспечения универсальной связи, но в конечном итоге набор протоколов ATM для multimedia будет, по-видимому, основан на службах каталогов.

Степень воздействия универсальных multimedia-коммуникаций на бизнес достаточно трудно прогнозировать с учетом отсутствия альтернативных вариантов. Несомненно, ATM будет играть значительную роль в коммерции, здравоохранении, обучении за счет систем распространения информации. Системы ATM основаны на экономичной технологии мультиплексирования, позволяющей преодолеть барьеры, связанные с взрывным характером трафика во многих приложениях.

С учетом всех этих влияний технология ATM остается привлекательной реализацией и очевидно, что множество пользователей будут готовы перейти на ATM в ближайшем будущем. Это означает, что и ваша организация может быстро начать работу с ATM и расширять использование этой технологии для повышения эффективности раьоты.

Приведенная в документе техническая информация может быть изменена без предупреждения.
© 1997 Xylan Corporation.
Титульная страница | О компании | О корпорации Xylan | Продукция Xylan | Прейскуранты | Новости | Библиотека | Справочный раздел | Поиск на сервере | Web-мастер
19 августа 1998 года


SB: Chapter 5 contents

Справочный раздел

Зачем использовать VLAN и коммутацию ЛВС?

В чем заключаются ограничения коммутации?

Какие проблемы решаются за счет VLAN?

Типы VLAN

Книга о коммутаторах

Глава 5: Виртуальные ЛВС

Зачем нужны виртуальные ЛВС?

Немногие из современных сетевых концепций столь сильно смущают пользователей как виртуальные ЛВС (VLAN). Виртуальные ЛВС являются новинкой и их широкое использование только начинается. Производители оборудования в своих попытках привлечь внимание заказчиков не всегда дают ясные трактовки понятия виртуальных ЛВС. Наконец, существует масса способов реализации виртуальных ЛВС на базе коммутаторов - каждая из этих реализаций имеет свои преимущества и недостатки.

Зачем используются коммутаторы ЛВС?

Первое, что слежует принимать во внимание при разговоре о виртуальных ЛВС - это то, что виртуальные сети появились в результате использования коммутации ЛВС. Возникает естественный вопрос - зачем же используются коммутаторы ЛВС?

Объемы трафика в локальных сетях непрерывно и быстро возрастают. Часть роста трафика обусловлена увеличением числа сетвых приложений - сейчас почти каждый использует в своей работе компьютер, а компьютеры организации обычно связаны в локальную сеть. Всего лишь несколько лет назад ситуация была совершенно иной (даже в больших сетях). Рост использования сетей обусловлен двумя аспектами - аппаратным и программным.

  • Первые компьютеры PC и Macintosh привели к настоящей революции к компьютерной и сетевой сферах. Сейчас взамен "тупых" терминалов, связанных с интеллектуальными мини-компьютерами или мэйнфреймами используются в основном персональные компьютеры и интеллект сетевых систем в значительной мере перенесен в настольные устройства. Рагьше по сети передавались экранные образы от большого компьютера на терминалы и сигналы о нажатии клавиш - от терминалов к компьютерам. интеллектуальные настольные станции привели к радикальному изменению ситуации. Сейчас требуется перенос по сети больших файлов и привычные в эпоху терминалов соединения 9.6 кбит/с уже не могут обеспечить требуемой скорости передачи данных. Технологии Ethernet и token ring обеспечивают значительно более высокие скорости обмена данными в сетях.
    Однако возможности первых настольных компьютеров были все-таки достаточно ограничены. Современные компьютеры обладают значительно большими возможностями (большие диски, много памяти, высокая производительность процессора и т.п.). В результате каждый компьютер в сети способен сегодня генерировать значительно более высокий уровень трафика.

  • При замене терминалов на персональные компьютеры не произошло радикального изменения природы сетевого трафика. Большинство приложений (исключая некоторые научные и конструкторские системы) передавали через сеть исключительно текстовую информацию. текстовый формат ограничивал объемы передаваемой по сети информации. Графическая информация, в отличие от текстовой, имеет значительно большие объемы. Объем данных, содержащийся в 300 страницах текста, составляет около 600 кбайт. Одна картинка с высоким разрешением и большим количеством цветов может быть во много раз больше такого текста.

Сейчас многочисленные приложения передают через сеть большие объемы графической информации. Зачастую в компаниях используются интерактивные графические системы. Достаточно часто приходится работать с графическими образами документов. Медицинские системы постоянно используют изображения для диагностики и других задач.

В конце концов эта тенденция приводит к передаче видео в локальных сетях, а для этого требуется достаточно высокая скорость.

Коммутаторы ЛВС дают возможность переноса больших объемов информации с высокой скоростью, значительно превосходя в этом отношении системы на базе концентраторов и маршрутизаторов. Сегменты Token ring и Ethernet можно выделять с помощью коммутаторов для отдельных устройств или не больших групп.

В чем заключаются ограничения коммутации?

LAN switches achieve high performance levels by using simplified processes; they're basically bridges, rather than routers. They switch via layer-two ("MAC") destination/source addresses; this is much simpler than routing. Routers must manage a variety of protocols -- route selection, address resolution, internet packet transfer, internet control message, etc. -- just to move information in a single protocol "stack," such as TCP/IP. Many networks combine a variety of stacks, and a complete set of protocols is required for each stack.

There's nothing new about using bridging to build local networks. The first LANs were created with relatively simple bridges. What's different now is that hardware has significantly advanced, and enormous volumes of frames can be moved in a single switch.

All bridged networks have a basic limitation -- bridges, since they don't participate in the layer-three protocols which use MAC broadcasts, send broadcasts to all ports. Although point-to-point ("unicast") traffic is isolated to the specific ports sending and receiving those frames, broadcasts must be sent everywhere. The same is true of frames that have a destination MAC address that hasn't been learned by the bridge; they have to be sent everywhere.

In most networks of moderate size this "flooding" has almost no impact on other traffic. There just aren't that many broadcasts in most networks, and new unicast addresses are quickly learned. However, in a very large network or one with an unusually high level of broadcasts, it is possible for flooding to impact point-to-point traffic. When this happens, it's important to keep broadcasts isolated in what are called "broadcast domains."

Many local area networks built over the last ten years use hubs and routers. The workstations, servers, and other devices are connected to the hubs, and the hubs are interconnected with routers. In this type of LAN broadcast domains are built automatically, since every hub (or hub segment, or ring) is a broadcast domain. Routers are essentially devices for interconnecting broadcast domains. But with networks based on LAN switches we need to provide this function in other ways.

How do virtual LANs address those limitations?

That's what virtual LANs do. A virtual LAN is a broadcast domain. Just as with a hub, all devices in a virtual LAN see all broadcasts as well as all frames with unknown destination addresses, so long as the broadcast and "unknown" frames originated inside that virtual LAN.

This is nothing new; it's exactly the same technique that's used in a LAN based on hubs and routers. With hubs and routers, frames are repeated within a hub and routed between hubs. With virtual LANs, frames are switched (bridged) within a virtual LAN, and routed between virtual LANs. So a virtual LAN is nothing more than a more flexible version of familiar networking practices.

What is new is that a broadcast domain is no longer restricted to the devices in one physical part of the network. This is important. Remember that switching is simpler than routing, and therefore faster. To the extent that data can be switched between devices, rather than routed, it can be moved much faster. Unfortunately for hub/router-based networks, devices that need to connect to each other all day long are often in different parts of a building, or even in different buildings on a campus or in a metropolitan area. Virtual LANs address this issue -- if they're powerful enough. A broadcast domain in a good virtual LAN implementation can span a building, campus, or city. So the need for routing is minimized, and data moves much faster.

What are the additional benefits of virtual LANs?

Routers use layer-three addresses to move data around a LAN. Each layer-three address contains a field which identifies the broadcast domain in which the destination can be found (its "network address"). These addresses are assigned by a network administrator, and are generally entered into a workstation's networking software configuration files. In a hub/router-based network the network address identifies an Ethernet segment or a token ring.

Unfortunately, if a device is moved from one hub to another, its network address is no longer correct, and someone from the networking group must go to the machine and correct it. This isn't much work if it seldom happens, but in a large network with a high percentage of workstations moving every year the process can eat up large amounts of time. And, until the update is completed, that machine can't communicate.

A good virtual LAN capability eliminates this problem. A workstation or server remains in the same virtual LAN, automatically, no matter where in the network it's connected.

Theoretically, network addresses can be assigned in any way the administrator chooses. Unfortunately, that's not true in practice in most networks today. The reason is the Internet. In order to mesh a private network with the Internet, it's necessary to restrict network numbers to those assigned by the Internet Number Authority. The explosive growth in this worldwide network has used up a large percentage of the possible network numbers, so that individual organizations are very restricted in the numbers available to them.

Until the widespread implementation of the next generation of IP, virtual LANs can be helpful in reducing wastage of Class B and Class C addresses. Virtual LANs make it possible to use a limited number of network addresses very efficiently. In a hub/router-based network, each segment or ring needs its own subnet number, so that the routers can move data between them. In a virtual LAN-based network, any number of segments or rings can be combined into a single virtual LAN, so addresses need not be wasted.

What are the issues virtual LANs should address?

Like any new technology, virtual LANs are changing rapidly. Some vendors offer relatively simple feature sets, while other implementations are very powerful. It's important to understand the applications that virtual LANs need to address in order to appreciate the differences between them.

Multiple MAC types

Remember that the basic purpose of moving to a switched LAN is to increase throughput. One fundamental way to do that is to divide the network into smaller segments or rings; ultimately, switching each device on its own segment or ring. As discussed earlier, this means that workstations no longer contend for bandwidth. If all network communications were peer-to-peer, this "micro-segmentation" by itself would provide a significant performance gain. However, real applications tend to have one or more central resources, which are accessed by a large number of workstations. These resources may be file servers, application servers, mainframes or routers. If the access speed for the central resources is no greater than that of the workstations a bottleneck is created.

To solve this, modern switched networks are moving to structures which allow central resources to run at speeds greater than those of the workstations. Examples include: 10 Mbps Ethernet workstations and 100 Mbps Ethernet servers; 16 Mbps token ring workstations and 100 Mbps FDDI servers; and Ethernet and/or token ring workstations connecting to ATM-based servers operating at 155 Mbps.

Obviously, as noted earlier, the point is to switch the traffic between the workstations and the servers, rather than routing it. This means that a virtual LAN must be able to accommodate a variety of MAC types.

Switches combined with hubs

For ten years network planners have been designing LANs using hubs and routers. A huge infrastructure is now in place that can't be simply replaced overnight. Even if that were practical, many workstations still have relatively low throughput requirements. Workstations with low bandwidth demands can be connected to hubs, and then to the switched network, while workstations with more demanding requirements are switched directly.

A hub is essentially a wiring device. All of the workstations in a given part of a building connect to the same hub -- regardless of the job function of the people using them. Frequently people who are in different departments, or working on different projects, will be sitting near each other and their workstations will be connected to the same hub.

Ideally, a virtual LAN capability in a switching network should allow members of several virtual LANs to be connected to a hub, and the traffic separated out intelligently by the switches.

Switches combined with routers

Recall that a virtual LAN is simply a broadcast domain, and that broadcast domains are interconnected with routing. Some LAN switches are capable of performing layer three routing, such as IP and IPX. This provides a mechanism for moving data between virtual LANs.

However, billions of dollars of multiprotocol routers are already installed, and users have made large investments in installing and learning to use them, and now rely upon them. These devices are optimized for their function, and it seems sensible to use them when they're already installed and functioning well.

One way to use existing routers to move data between virtual LANs is, for each virtual LAN, to connect one physical port from the LAN switch network to one physical port on the router. This works well for a small number of virtual LANs. But when a large number of virtual LANs need to be supported, and when large amounts of traffic must be routed, then a more optimal form of connection is needed. Several standards proposals have been presented to create a "trunking protocol" that meets this requirement. It's important that a LAN switch vendor be committed to supporting these standards as they develop. It now appears likely that the most important of these standards will be 802.1Q.

Servers supporting multiple virtual LANs

Servers have become very powerful, especially those optimized to run enterprise applications. Some of these servers may need to connect to a large number of workstations which are not necessarily in the same department. A virtual LAN function should allow these servers to participate in more than one virtual LAN.

This capability can often be provided by installing multiple network interface cards in the server. But this can be expensive and can create an excessive processing load on the server. It's especially a problem when using high-speed technologies, such as FDDI, CDDI, or ATM, to connect servers to the switched network. Here again, a public VLAN trunking standard will be valuable.

Workstations connecting to multiple virtual LANs

Some workstations also need to belong to more than one virtual LAN. One important instance of this is the use of NDIS or ODI drivers at the MAC layer to allow more than one protocol stack to operate on the same workstation.

For example, a workstation with ODI drivers might be using Novell NetWare to obtain access to a departmental file server, and TCP/IP to connect with a corporate enterprise application running on a Unix machine. These two resources would logically be placed on separate virtual LANs. One solution to this is placing the workstation in one virtual LAN, and routing from that to the other as needed. But this forces one of the two connections to run more slowly than is optimal.

Ideally, the workstation should be able to connect to each of the two virtual LANs directly, without routing to either one, and without joining the two into a single virtual LAN.

Multiple-switch networks

Virtual LANs are of relatively little benefit if they can exist only in a single switch. After all, the need for virtual LANs is greatest in mid-sized and larger networks, which, by definition, will need multiple switches. Some way is needed to link workstations and servers which are connected to a number of switches into a single virtual LAN.

FDDI backbones

FDDI has provided a reliable high-speed backbone and server technology for some years. It's reliable and widely supported, the standards are mature, and high-performance products are available. Many organizations have FDDI backbones already in place, in many cases servers are already connected with FDDI or CDDI.

Not all virtual LANs support this common network configuration. If you have an FDDI backbone already in place, or if you're planning to install one, it's important to ensure that the switches you select support this technology.

ATM backbones

ATM is the developing standard that will eventually encompass a wide variety of data types (data, image, video, voice), geographical scope (LAN, MAN, WAN), device types (servers, workstations, trunks), and rates (56 Kbps - 2.4 Gbps and beyond). At the moment it's pretty expensive, and most users are postponing installing it directly to the desktop. But it's reaching the point where it's a strong alternative to FDDI as a backbone, and fairly soon for server connections.

A variety of options are available for connecting devices across an ATM backbone. These include:

  • Routing IP packets over ATM

  • Establishing switched virtual LANs between LAN-attached devices by using a trunking protocol

  • Using ATM LAN Emulation (LANE) to switch among LAN-attached and ATM-attached devices

  • Using Multi-Protocol Over ATM (MPOA) to route among LAN-attached and ATM-attached devices

If you decide to move ahead with an ATM backbone, bear in mind that the switching option(s) that are most suitable now may not be optimal in the future. Generally, the more powerful and flexible the standard, the further it is from final standardization and widespread implementation. It's important that a virtual LAN mechanism be able to operate efficiently across ATM backbones while the LANE and MPOA standards are finalized, implemented and tested.

Network moves, adds, and changes

In many networks it's common for devices to move frequently within a building or a campus. You should be able to assign a workstation to one or more virtual LANs once, and after that it should remain connected to them, no matter where on the campus it's moved.

Speed of operation

Increased throughput is the reason why LAN networks are moving to switching solutions. Virtual LANs assist this movement by keeping broadcast traffic at reasonable levels. It's obvious that the implementation of the virtual LAN capability should not slow down the network. This implies that the actual forwarding of the individual frames should be done in hardware, including checking source and destination virtual LAN matches.

Types of virtual LANs

There are a variety of possible ways to create virtual LANs. Vendors have implemented methods that are feasible on their switch architecture. As a result, some mechanisms provide only basic capabilities while others are more powerful.

Port-based virtual LANs

This is the simplest form of virtual LAN. In this model a virtual LAN is a collection of switch ports, sometimes only on a single switch, sometimes on a number of switches.

Port-based virtual LANs are relatively easy to set up initially. However, they're unable to meet some of the needs discussed in the previous section. For example, they typically can't support more than one virtual LAN on a given port, so hubs that need to join more than one virtual LAN must be segmented (if that's possible), and servers and workstations that need to join more than one virtual LAN must do so with multiple network interface cards (if that's possible).

Device moves, adds, and changes are a problem for port-based virtual LANs. If a device moves to a new port, manual reconfiguration is required. And if it moves to a new hub which is assigned to a different virtual LAN, it may not be able to join its original virtual LAN. In Figure 5.1 below, each color corresponds to a port based virtual LAN.

Figure 5.1 A port-based virtual LAN

MAC-based virtual LANs

It's possible to assign devices to virtual LANs by using their MAC source addresses. Essentially, each virtual LAN is a list of MACs. This solves some of the limitations of port-based virtual LANs, including allowing a hub to contain member of multiple virtual LANs and tracking devices as they move automatically around a building or campus. But it doesn't necessarily address the problem of a workstation or server belonging to more than one virtual LAN.

Another limitation to this approach is that it requires manipulation of large numbers of cryptic MAC addresses. Although this can be of value in certain applications, most users would rather assign virtual LANs in ways that are more intelligible and that can be easily audited.

In Figure 5.2 the numbers and letters correspond to MAC based virtual LANs.

Figure 5.2 Mac-based virtual LANs

Layer three-based virtual LANs

It's possible to construct virtual LANs using the same criteria that have been used to manage routers: IP subnets, IPX network numbers and so on. LAN switches that use this method generally allow a subnet to spread across a number of ports, and sometimes allow more than one subnet per port. This provides a good deal of flexibility, and is easier to manage than MAC-based virtual LANs.

Some layer-three virtual LANs extend to multiple switches; others are more limited in this regard. Some use hardware effectively to provide high throughput, while others are architecturally almost identical to routers, and therefore are unable to sustain the loads that switches are meant to handle.

Figure 5.3 below shows a possible implementation of a layer-3 VLAN.

Figure 5.3 Layer-3 based VLANs

Policy-based virtual LANs

These are the most flexible of virtual LAN alternatives. They assign devices to virtual LANs using policies, established in network management, which apply to all switches. Therefore, when a device moves, it automatically remains in the same virtual LAN.

These policy-based virtual LANs can implement a variety of assignment methods, including MAC source addresses, layer-three addresses, Ethernet protocol type field, and other parts of the frame. It's possible to select a method that suits the needs of a particular network.

Figure 5.4 below shows a rule-based virtual LANs where workstations are connected by a variety of criteria. Note that similarly colored devices on the network are on the same VLAN.

Figure 5.4 Policy-based VLANs
Приведенная в документе техническая информация может быть изменена без предупреждения.
6 июня 1998 года


SB: Chapter 6 contents

Справочный раздел

Network 1

Network 2

Network 3

Книга о коммутаторах

Chapter 4: ATM

Network 1

The problem

Varying wiring topologies is a common phenomenon among organizations which originally had small networks servicing individual departments. Eventually companies incorporated those individual networks into the single campus/enterprise networks that are common in today's businesses. Figure 6.1 shows an example enterprise network which employed Ethernet and token ring on individual segments (sometimes on the same floor) and used 100 Mbps FDDI as its backbone technology.

Depending on what segment and floor a workstation was on, it could have been running token ring at 4 or 16 Mbps or running 10 Mbps Ethernet over twisted pair or coaxial wiring. To solve the problem of integrating these topologies network implementers used traditional bridge/router configurations to weave them into an enterprise network. While this solution worked for a while, the size and bandwidth demands of network applications grew, and consequently so did network problems.

As users began using the connectivity conveniences a network provides, network traffic skyrocketed. They shared large data files on servers, as well as activated peer to peer networking. Often this meant data had to pass through multiple routers to get to its final destination. Each router read the data from its respective segments and forwarded it to another segment on its domain, or released the data to the corporate backbone. Because each router processes information in this manner there is a delay while the router processes the packet. This is known as latency. High latency, caused by multiple routers in the data path, can slow a network down dramatically.

In the case of this network, the shared data files were extremely large and low router throughput ground the entire network to a halt while large files passed.

Figure 6.1 Network 1 -- The problem

The solution

Switching is an inherently versatile technology. When the company who used the network shown in Figure 6.1 decided to upgrade their network, a couple of solutions were presented. They could opt to give every workstation on their network its own dedicated port on a switch or they could replace their current routers with switches and reallocate those routers to other areas of the network such as Internet gateways and WAN gateways. For budget reasons, the organization chose the latter option which left the option open to upgrade to a fully switched solution in the future.

The company realized the benefit of adding switches to its LAN shortly after installing them. The most obvious improvement was in intranetwork traffic. No longer did data have to pass through successive routers which could not handle the demands of a high traffic network. Instead data zipped through the network without slowing down. The switch automatically performs translation so 16 Mbps token rings can transmit data to Ethernet segments or FDDI rings rapidly and effectively.

While most switch ports were used to connect to hubs and MAUs, some ports were still left for users who needed extra bandwidth.

In addition, the switch solution seamlessly integrated the company's existing 100 Mbps FDDI ring which allowed the company to keep its original backbone in place.

Figure 6.2 The solution for Network 1

Network 2

The problem

The network shown in Figure 6.3 originally had multiple independent networks serving individual departments. Some departments still existed within the organization without any form of network connection. As the company grew, management decided to add a main server which would service the existing networks and also connect the unnetworked portion of the organization to a corporate network.

Figure 6.3 shows their network after they added a main server and connected the unnetworked departments. Note that some segments still had their own servers. Ethernet and token ring were still used on the integrated enterprise network; however, the third floor caused special problems since it used Ethernet, 4Mbps token ring and 16 Mbps token ring. Data traveling from 16 Mbps token ring to a 4 Mbps token ring on the same floor had to travel to the company's router on the first floor and then all the way back up to the 4 Mbps ring -- not a very efficient way to pass data.

The company originally added the router to regulate the moderate interfloor network traffic, control server access and also manage the small amount of traffic coming from the WAN. Since the company's original independent networks did not pass data from floor to floor, the company believed that floor to floor traffic would be non-existent to moderate. However, after implementing the enterprise network, interfloor traffic ramped up quickly as users took advantage of the corporate network. The lone router on the bottom floor had to direct all data to its proper segment and also perform translation from Ethernet to token ring. When there was little to no traffic on the network this single router solution worked well. But, all of the extra interfloor traffic reduced the ability of workstations to access the main server as well as the company's WAN link.

Figure 6.3 Network 2 -- The problem: One router with multiple technologies and floors

The solution

The company elected to put a switch on each floor of the building and create a backbone by meshing its switches together with 155 Mbps ATM. The individual switches are specially equipped for the topologies of the floors they are installed on. For instance, the floor which uses Ethernet along with 4Mbps token ring and 16 Mbps token ring has a switch with an Ethernet module, a 4 Mbps token ring module and 16 Mbps token ring module.

Since ATM traffic is point to point, the network no longer experiences backbone congestion because data only travels from source to destination and bypasses switches which do not manage the data's destination segment.

In addition, intraswitch traffic does not run into congestion problems since it can handle hundreds of megabits per second while translating media on the fly. Data which previously traveled all the way to the main router on the first floor can now simply travel to the switch on its own floor and have the routing and translation take place there. The original department networks, which still have independent servers, also run faster since their servers are plugged directly into a switch giving it a full 10 Mbps pipe to the rest of the network.

Figure 6.4 The Solution for Network 2 -- Switches tie multiple technologies together and speed up traffic

Network 3

The problem

Six thousand workers use this campus network which spans four multi-floor buildings with mixed wiring topologies. Figure 6.5 shows a network where every floor's wiring ran to repeaters and bridges located in a LAN room on the first floor of the building. In each LAN room, a router tied together the four buildings through a 100 Mbps FDDI backbone.

Router/bridge technology is wonderful while there is light traffic. However, the bandwidth limitations of the network immediately became evident since the existing routers could not keep up with the constant data bombardment from the users in each building. The routers had to read the destination network address of each packet on its segments and subsequently forward it to the router which controlled the destination segment. The result was high latency, congestion on the network's individual segments, and even more congestion on the network's backbone. Simply put, the current configuration could not keep up with demand, especially with the increasing requirements created by bandwidth intensive applications.

The company wanted to add more CAD/CAM applications as well as video conferencing, however their network configuration scarcely held up even with the current level of traffic.

Figure 6.5 Network 3 -- The problem: Routers can't handle high traffic

To make matters worse, data not only passed from segment to segment or from floor to floor -- ten megabyte files routinely passed from the operations building to the finance building or from the building housing customer service to the marketing center. These large data files severely hampered the network's ability to perform. Loss in network performance caused many users to lose faith in the network.

The solution

Because this company's data demands are still growing and the company wanted to add applications which demand intense bandwidth, they decided to go with a completely switched solution which provides immediate improvement in network performance and stability. The organization knew that this would provide immediate relief for the congested network while also allowing integration of new technologies such as video conferencing.

Figure 6.6 The solution for Network 3 -- Switches on each floor and along the backbone

They installed a switch with enough ports to service each user on their existing wiring and also left enough ports for future growth. A 100 Mbps FDDI ring links each of the building's switches to a network server. Therefore workstations on every floor can access the server via their own switched port. Furthermore, the server has a 100 Mbps FDDI connection through which it can send and receive data. Once the switches were installed, the users experienced a remarkable improvement in performance.

The company also added an extra switch to the server room in each building to insure that building to building communication was as fast as intrabuilding communication. These switches have a direct connection to the building's server ring and a second connection to another 100 Mbps FDDI backbone ring which interconnects the four buildings. The large data files which had previously brought the network to its knees now whisked through the network with surprising ease.

To augment this improvement the company decided to employ virtual LAN (VLAN) technology so that users in different buildings can connect to the same virtual LAN. Virtual LAN technology allows these users located in different areas of the campus to pass data efficiently and quickly while not causing intensive congestion on the network's backbone or segments.

Приведенная в документе техническая информация может быть изменена без предупреждения.
6 июня 1998 года


SB: Chapter 7 contents

Справочный раздел

Choices

Workstation technologies

Server technologies

Backbone network technologies

Switching methods

Routing methods

Virtual LANs

Redundancy and reliability

Enclosures

Network management

Книга о коммутаторах

Chapter 7: About Xylan

Choices

In the early 1900s people making telephone calls relied on live operators to to create a connection to the number they dialed. While personable, this method often took minutes for operators to complete a single call. Automated telephone switches have long since taken the place of the original telephone operators. The automated telephone switch revolution points out one of the earliest examples of our need to have fast, reliable communications equipment.

Networking is rapidly changing from shared LANs, based on hubs and routers, to switched LANs, based on LAN switches and ATM switches. A switched network provides more bandwidth, effectively supporting very high-speed transmission. That's essential for many new applications, including imaging, client/server, interactive desktop video, and others.

The Xylan OmniSwitch comes with the most complete set of switching solutions available. In every possible way, you can shape a solution to fit your specific needs. Why is this important?

  • It lets you evolve your network gracefully. For example, you can use an existing FDDI backbone to carry virtual LAN traffic, and gradually move to a new ATM backbone.

  • Different applications have different switching needs. Xylan doesn't try to convert users to one particular technology. Instead, we help you get from where you are now to where you want to be in the future.

  • Many networks need a combination of solutions. Some have a mixture of Ethernet and token ring workstations. Sometimes there's fiber cable in the risers and copper from the wiring closets to the desks. And there's almost always a need for both switching and routing.

When evaluating a switching system, you should be sure that it offers powerful options for workstation connections, for server connections, and for high-speed backbones. You should consider its ability to both switch and route. You should look at the specific capabilities of its virtual LAN features. You should ensure that all the reliability and redundancy you need in your application are available. And you should make sure that it's manageable.

If a switching system doesn't give you the choices you need, is it really a strategic solution? And can you afford a system that isn't strategic?

Workstation technologies

Low-cost, high-performance switching makes your workstations more effective without the cost of new interface cards and wiring, and without the hidden costs of disrupting your users. Xylan's products can give each device its own dedicated segment, or switch MAUs and hubs.

  • Ethernet over unshielded twisted pair cable (10BaseT)

  • Ethernet over fiber optic cable (10BaseFL)

  • Ethernet over thin coaxial cable (10Base2)

  • Ethernet over thick coaxial cable (10Base5 -- connects to a transceiver)

  • Token ring over unshielded twisted pair cable (connects to a lobe port)

  • Token ring over shielded twisted pair cable (connects to a lobe port)

  • Token ring over fiber optic cable (connects to a lobe port or to Ring In / Ring Out ports)

Server technologies

You can dramatically increase the effective bandwidth of your network by using switches to reduce the number of workstations on each ring or segment. But why do this if they still have to contend for a server operating at the same rate? Switched networks provide maximum performance gains when servers and other common resources (such as mainframes and routers) use high-speed connections. To help you, Xylan incorporated the following technologies into switching modules for their products.

  • 100BaseT over unshielded twisted pair cable (100BaseTX)

  • 100BaseT over multimode fiber optic cable (100BaseFX)

  • FDDI DAS over multimode fiber optic cable

  • FDDI SAS over multimode fiber optic cable

  • FDDI SAS over unshielded twisted pair cable (CDDI)

  • ATM over multimode fiber optic cable (OC-3c)

Backbone network technologies

Some networks can be built with a single switch. But larger applications call for a number of switches linked together over a backbone. In fact, one of the advantages of switching is that it fits so well with the vertical / horizontal wiring systems that are already in place.

Some users will want to make optimal use of an FDDI network they already have. Some will want to move as quickly as possible to an ATM backbone, seeing ATM as the trend of the future. And others prefer 100BaseT because of its simplicity and its similarity to Ethernet. Xylan switches allow you to run the following:

  • FDDI over multimode fiber optic cable

  • FDDI over single mode fiber optic cable

  • ATM over multimode fiber optic cable (OC-3c)

  • ATM over single mode fiber optic (OC-3c)

  • ATM over public leased line (DS-3)

  • 100BaseT over multimode fiber optic cable (100BaseFX)

Switching methods

Switching supports high-bandwidth transmission because it's a relatively simple, layer-two technology that can be performed largely in hardware. But unlike some products that offer only limited, simplistic switching capabilities, Xylan switches provide a complete range of software tools for every application.

  • Automatic layer-two translation

  • Spanning Tree Bridging (802.1D)

  • Xylan's Optimized Device Switching

  • Source Route Bridging

  • Source Route / Transparent Bridging

  • ATM encapsulation (RFC 1483)

  • ATM LAN Emulation

Routing methods

Routing provides a standards-based method for moving traffic between virtual LANs while containing layer-two broadcasts. The OmniSwitch and PizzaSwitch integrate both routing and switching, making them ideal platforms for constructing entire campus networks.

  • IP

  • IPX

  • Classical IP over ATM (RFC 1577)

Virtual LANs

Switching makes it possible to organize devices in logical, rather than physical, groups. Xylan's AutoTracker feature implements rule-based virtual LANs; this is the most powerful form of virtual LANs, and lets you create amazingly powerful automatic groupings.

  • Rules that define virtual LANs can be applied to any part of a packet.

  • Devices are automatically tracked as they move around the network.

  • Virtual LANs can span multiple switches, across FDDI and/or ATM backbones.

  • Workstations and servers can belong to one or more virtual LANs.

Redundancy and reliability

A lot of things these days depend on the network's being available. Network failure is inconvenient at best, and at worst it results in enormous direct and indirect costs. Your switching infrastructure should be as resistant to failure as your applications require. That's why Xylan designs their switches with the following redundancy and reliability features:

  • Optional redundant Management Processor Modules

  • Optional redundant, load-sharing power supplies, each with its own power cord, switch and fuse

  • Hot-swappable Switching Modules, Management Processor Modules, and power supplies

  • Passive backplane

  • Dual cooling fans

  • Flash memory for configuration and software storage

  • FDDI optical bypass support

  • Redundant connections to an ATM switch fabric

  • Redundant connections to an FDDI backbone ring

  • Redundant server connections

  • Redundant connections to hubs

Enclosures

Not every application is ideally served by one size of switch. Xylan has packaged its switching hardware and software technologies into three platforms, each designed for a specific need. Workstation, server, and backbone technologies can be mixed in any combination.

  • Omni-5: modular; five slots

  • Omni-9: modular; nine slots

  • PizzaSwitch: Semi-modular, with twelve Ethernet ports and two high-speed sub-modules

Network management

Xylan has put a great deal of effort into ensuring that a network of OmniSwitches and PizzaSwitches can be planned, monitored and controlled.

  • Graphical control of switches, modules, and ports

  • OmniVision integrated with OpenView for Windows

  • OmniVision integrated with OpenView for UNIX

  • OmniVision integrated with SunNet Manager

  • OmniVision integrated with NetView for AIX


SB: Reference contents

Стандарты

Телекоммуникации

Ethernet

Token Ring

FDDI

ATM

Сетевые протоколы
уровней 3 и 4

Книга о коммутаторах
Справочный раздел

Справочный раздел Книги о коммутаторах содержит обзор основных компонент коммутируемой сети. В Справочном разделе 1, описаны сетевые стандарты, содержащие правила организации сетей. Справочный раздел 2 содержит информацию о сетевом оборудовании.

Справочник содержит информацию о стандартах Ethernet, token ring, FDDI и ATM, касающуюся трех нижних уровней модели OSI, после чего рассмотрены протоколы 4-го уровня, связанные с этими технологиями.

При описании всех технологий кратко рассматриваются аппаратные спецификации, схемы кодирования и другая информация, связанная с данной технологией. С числу рассматриваемых вопросов относятся кабельные системы и схемы кодирования, форматы кадров, подуровни MAC и LLC.

Справочный раздел содержит обширную информацию. Однако, если Вы увидите, что какой-либо важный вопрос пропущен, напишите нам об этом.

Приведенная в документе техническая информация может быть изменена без предупреждения.
8 июня 1998 года


SB: Reference contents

Справочный раздел

IP

IPX

TCP

SPX

Книга о коммутаторах
Справочный раздел

Протоколы уровней 3 и 4

Протокол Internet (Internet Protocol - IP)

Формат заголовка IP
Рисунок 8.51 Формат заголовка IP
Ver | Версия 0100 = 4, текущий стандарт
HL | Длина заголовка (число 32-битовых слов в заголовке IP)
TOS | Тип обслуживания
FL | Длина фрагмента, общее число байтов в пакете
PaID | Идентификационный номер пакета
Flag | Флаги фрагментации пакета
 | 000 | Последний фрагмент
 | 001 | Пакет фрагментирован
 | 010 | Пакет не фрагментирован
FO | Смещение фрагмента
TTL | Время жизни
PrID | Идентификатор протокола
 | 0000 0001 | ICMP - протокол управляющих сообщений Internet (Internet Control Message Protocol)
 | f0000 0110 | TCP - протокол управления передачей (Transmission Control Protocol)
 | 0000 1000 | EGP - протокол внешнего шлюза (Exterior Gateway Protocol)
 | f0001 0001 | UDP - протокол пользовательских дейтаграмм (User Datagram Protocol)
 | 0101 1001 | OSPF - Open Shortest Path First
HC | Контрольная сумма заголовка
SIP | IP-адрес отправителя
DIP | IP-адрес получателя
OpT | Опции
Pad | Заполнение (используется для выравнивания заголовка по 32-битовой границе
Data | Данные протоколов вышележащих уровне (например, TCP)

Формат IP-адреса

Адрес класса A
Рисунок 8.52 Адрес класса A
Адрес класса B
Рисунок 8.53 Адрес класса B
Адрес класса C
Рисунок 8.54 Адрес класса C
32 бита адреса группируются в 4 поля по 8 бит, разделенных точками и записываются в десятичном формате (например, 128.1.254.56).

Протокол межсетевого обмена пакетами IPX

Рисунок 8.55 IPX (межсетевой обмен пакетами)

Протокол управления передачей (TCP)

Формат пакета TCP
Рисунок 8.56 Формат пакета TCP
Ck | Контрольная сумма
LN | Длина пакета
TC | Управление транспортировкой. Значение этого поля увеличивается на 1 каждым маршрутизатором на пути следования. Когда значение поля достигает 16, пакет отбрасывается
PT | Тип пакета
 | 0000 0000 | неизвестный тип
 | 00000100 | PEP, протокол обмена пакетами
 | 0000 0101 | SPX, упорядоченный обмен пакетами
 | 0001 0001 | NCP, Netware Core Protocol
DN | Сетевой адрес получателя (0, если получатель в той же сети)
DH | Адрес хоста-получателя (48-битовый MAC-адрес)
DS | Socket-адрес получателя
 | 0000 0001 | RIP, протокол маршрутной информации
 | 0000 0010 | Эхо-пакет
 | 0000 0011 | Управление ошибками
 | Ox451 | пакет файлового сервиса NCP
 | Ox452 | SAP, протокол информации об услугах
 | Ox453 | IPX RIP
 | Ox455 | NetBIOS
 | Ox456 | Диагностика
SN, SH, SS | Отправитель (сеть, хост, сокет)
SP | Порт отправителя
DP | Порт получателя
SeqN | Порядковый номер
AckN | Номер подтверждения
DO | Смещение данных
CNT | Управлени
UP | Указатель важности
OPT | Опции (переменная длина
PAD | Заполнение до 32-битовой границы
Формат пакета UDP
Рисунок 8.57 Формат пакета UDP
Номер порта TCP
5 | RJE
7 | Эхо
11 | Пользователи
20 | Данные FTP
21 | Управление FTP
23 | TELNET
25 | SMTP
37 | Время
42 | Сервис имен
53 | DNS
67 | сервер BOOTP
68 | клиент BOOTP
69 | TFTP
79 | Finger
101 | Сервер имен хостов
102 | ISO-TSAP
103 | X.400
104 | X.400 SND
105 | CSNET-NS
109 | POP-2
111 | RPC
137 | NetBIOS-NS
138 | NetBIOS-DG
139 | NetBIOS-SS
NetBIOS/NetBEUI
Рисунок 8.58 NetBIOS/NetBEUI

Упорядоченный обмен пакетами (SPX)

Формат заголовка SPX
Рисунок 8.59 Формат заголовка SPX
IPX | Заголовок IPX
CC | Управление соединением
Ox10 | Последний пакет
Ox20 | Внимание
Ox40 | Требуется подтверждение
Ox80 | Системный пакет
DST | Тип потока данных, идентификатор протокола, если поле данных содержит пакет
SID | Идентификатор соединения (Source connection ID) - номер виртуального устройства, присвоенный отправителем
DID | Идентификатор соединения (Destination connection ID), используемый для демультиплексирования множества виртуальных устройств из одного соединения
Seq | Порядковый номер пакета
Ack | Порядковый номер пакета, который получатель ждет следующим
All | Число доступных буферов

Код страны (DCC) |  | Обозначение международного кода |  | Формат адресов E.164 ATM
Тип | Размер в байтах | Тип | Размер в байтах | Тип | Размер в байтах
Идентификатор полномочий и формата | 1 | Идентификатор полномочий и формата | 1 | Идентификатор полномочий и формата | 1
Код страны | 2 | Код страны | 2 | E.164 | 6
Формат DSP | 1 | Формат DSP | 1
Административные полномочия | 3 | Административные полномочия | 3
Зарезервировано | 2 | Зарезервировано | 2 | Зарезервировано | 2
Area | 2 | Area | 2 | Area | 2
Идентификатор оконечной системы | 6 | Идентификатор оконечной системы | 6 | Идентификатор оконечной системы | 6
SELector | 1 | SELector | 1 | SELector | 1
Приведенная в документе техническая информация может быть изменена без предупреждения.

4 июня 1998 года


SB: Reference contents

Справочный раздел
ATM/B-ISDN
Генерация ячеек ATM
Классы обслуживания AAL
Функции уровней
Интерфейс обмена данными DXI

Книга о коммутаторах
Справочный раздел

ATM

ATM (асинхронный режим передачи)

ATM/B-ISDN

ATM использует оптические кабели или кабели из скрученных пар.

Функции оборудования аналогичны оборудованию ISDN, дополнительная буква "B" означает широкополосных (broadband) характер сетей.

UNI - (интерфейс пользователь-сеть - User to Network Interface).

Функциональные группы и точки входа
Рисунок 8.44 Функциональные группы и точки входа
Стеки протоколов а B-ISDN
Рисунок 8.45 Стеки протоколов а B-ISDN
SSCS | Связанный с сервисом подуровень схождения
CPCS | Общая часть подуровня схождения
AALCP | Общая часть уровня адаптации ATM
SAAL | Уровень адаптации сигналов ATM

Генерация ячеек ATM

Генерация ячеек ATM
Рисунок 8.46 Генерация ячеек ATM
SSCS | Связанное с сервисом схождение
CPCS | Общая часть подуровня схождения (Common Part Convergence Service)
SAR | Сегментация и сборка
Ячейки ATM в UNI
Рисунок 8.47 Ячейки ATM в UNI
GFC | Общее управление потоком
VPI | Идентификатор виртуального пути
VCI | Идентификатор виртуального канала
PTI | Идентификатор типа обслуживания
 | 000 - 011 | пользовательские данные
 | 100 - 111 | управляющие данные
CLP | Приоритет потери ячеек
HEC | Контроль ошибок в заголовке
Смещения в ячейках ATM в октетах (8 бит)
Общее управление потоком | 4 бита
Идентификатор виртуального пути | 1 октет
Идентификатор виртуального канала | 2 octets
Тип обслуживания | 3 бита
CLP | 1 бит
Header Error Control | 1 octet
Модуль данных протокола (Payload - полезная загрузка) | 48 октетов

Класс обслуживания AAL

Класс обслуживания AAL
Рисунок 8.48 Класс обслуживания AAL

Классы трафика ATM - целью деления трафика на классы AAL является преобразование и агрегирование различных типов трафика в стандартные форматы для поддержки различных пользовательских приложений.

Класс A
Постоянная скорость (Constant bit rate - CBR) - ориентирован на соединения (например, CBR для видео)
Синхронизация отправителя и получателя: требуется.
Класс B
Переменная скорость (Variable Bit Rate - VBR) - ориентирован на соединения (например, VBR для видео или голоса
Синхронизация отправителя и получателя: требуется.
Класс C
Переменная скорость (Variable Bit Rate - VBR) - ориентирован на соединения
Синхронизация отправителя и получателя: не требуется.
Class D
Переменная скорость (Variable Bit Rate - VBR) - без организации соединений
Синхронизация отправителя и получателя: не требуется.

Функции уровней

Функции уровней
Рисунок 8.49 Функции уровней
CS | Подуровень схождения (конвергенции)
SAR | Сегментация и сборка
AAL | Уровень адаптации ATM
 | Управление потоком
 | Обработка заголовков ячеек
 | Обработка VPI/VCI
 | Мультиплексирование/демультиплексирование
TC | Подуровень схождения передачи
 | Разделение скорости ячеек
 | Обработка заголовков HEC
 | Описание (delineation) ячеек
 | Адаптация передачи кадров
 | Генерация/восстановление кадров
PL | Физический уровень
PM | Подуровень физической среды

Интерфейс обмена данными ATM DXI

Интерфейс обмена данными ATM DXI
Рисунок 8.50 Формат кадра ATM DXI (RFC 1483 и 1577
Приведенная в документе техническая информация может быть изменена без предупреждения.
3 июня 1998 года


SB: Reference contents

Справочный раздел
Кабели
Топология
Кодирование
Формат кадров

Книга о коммутаторах
Справочный раздел

FDDI

Кабельные системы FDDI

Рисунок 8.38 Разъемы FDDI
Для организации сетей FDDI используются одномодовые оптические кабели или многомодовые 62.5/125 мкм.

В оптических кабеля для передачи используется световой поток взамен электрических сигналов. Сети FDDI имеют реальную полосу передачи сигналов 125 Мбит/с, однако кодирование 4b/5b занимает 25 Мбит/с, оставляя для полезных сигналов 100 Мбит/с.

Одномодовые кабели обеспечивают более низкие потери (обычно меньше 2 dB на километр), уровень потерь в многомодовых кабелях выше за счет большей дисперсии и поглощения света.

Рисунок 8.39 Кабели FDDI

Топология FDDI

Рисунок 8.40 Первичное и вторичное кольца FDDI
На приведенном ниже рисунке показана архитектура FDDI с двойным кольцом. Первый рисунок иллюстрирует схему FDDI, в которой оба кольца работают нормально. Отметим, что некоторые устройства подключаются к обоим кольцам FDDI, а другие - только к первичному. Сдвоенный концентратор доступа (DAC) на первом рисунке позволяет станциям с одинарным подключением (SAS) использовать первичное кольцо сети FDDI.

На втором рисунке показана возможность самовосстановления FDDI. При возникновении проблемы в сети, кольцо переходит в состояние самовосстановления (wrap state). В приведенном на рисунке пример часть кольца между станциями с двойным подключенияем в верхнем левом и верхнем правом углах отрезаются от сети (повреждение кабеля), после чего FDDI незамедлительно меняет путь переноса данных с использованием вторичного кольца, восстанавливая работоспособность сети.

Схема сети FDDI с двойным и одинарным подключением станций
Рисунок 8.41 Схема сети FDDI с двойным и одинарным подключением станций
Устойчивость FDDI к повреждениям в сети
Figure 8.42 Устойчивость FDDI к повреждениям в сети

Кодирование в FDDI

FDDI использует дифференциальное манчестерское кодирование 4B/5B - каждые 4 бита данных передаются 5 битами сигнала.
Символ | 5-битовый код | Символ управления | 5-битовый код
0 | 11110 | Quiet | 00000
1 | 01001 | Простой (Idle) | 11111
2 | 10100 | Остановка (Halt) | 00100
3 | 10101 | Стартовый разделитель J | 11000
4 | 01010 | Стартовый разделитель K | 10001
5 | 01011 | Стартовый разделитель T | 01101
6 | 01110 | Сброс управления (логический нуль) | 00111
7 | 01111 | Сброс управления (логическая единица) | 11001
8 | 10010
9 | 10011
10 | 10110
11 | 10111
12 | 11010
13 | 11011
14 | 11100
15 | 11101

Формат кадров FDDI

Формат кадров FDDI
Рисунок 8.43 Формат кадров FDDI
PR | Преамбула
SD | Стартовый разделитель
FC | Управление кадром
DA | Адрес получателя
SA | Адрес отправителя
I | Информация
FCS | Контрольная сумма, CRC 32
ED | Финишный разделитель
FS | Статус кадра
Маркер FDDI
Преамбула | 8 байт
Стартовый разделитель | 1 байт
Управление кадром | 1 байт
Финишный разделитель | 1 байт
Формат кадра данных FDDI
Треамбула | 8 байт
Стартовый разделитель | 1 байт
Адрес получателя | 1 байт
Адрес отправителя | 1 байт
Информация | 0+ любая информация
Контрольная сумма | 4 байта
Финишный разделитель | 1 нибл (4 бита)
Статус кадра | 3

Отметим, что командные и MAC-кадры не содержат данных в информационном поле кадра, тогда как кадры LLC - содержат их. Различить кадры LLC и MAC можно по значению поля "Управление кадром".

Адресация FDDI подобна адресации token ring и использует 12 шестнадцатиричных цифр.

Приведенная в документе техническая информация может быть изменена без предупреждения.
6 июня 1998 года


SB: Reference contents

Справочный раздел

Модель OSI

  1. физический уровень
  2. канальный уровень
  3. сетевой уровень
  4. транспортынй уровень
  5. сеансовый уровень
  6. уровень представления
  7. прикладной уровень
Протоколы IEEE 802

Протоколы ITU

Другие стандарты

  • ANSI
  • ATM Forum
  • EIA

Книга о коммутаторах
Справочный раздел

Модель OSI

Модель OSI

Эталонная модель OSI, иногда называемая стеком OSI представляет собой 7-уровневую сетевую иерархию (рис. 8.1) разработанную Международной организацией по стандартам (International Standardization Organization - ISO). Эта модель содержит в себе по сути 2 различных модели:

  • горизонтальную модель на базе протоколов, обеспечивающую механизм взаимодействия программ и процессов на различных машинах
  • вертикальную модель на основе услуг, обеспечиваемых соседними уровнями друг другу на одной машине

В горизонтальной модели двум программам требуется общий протокол для обмена данными. В вертикальной - соседние уровни обмениваются данными с использованием интерфейсов API.

Рисунок 8.1 Модель OSI

Уровень 1, физический

Физический уровень получает пакеты данных от вышележащего канального уровня и преобразует их в оптические или электрические сигналы, соответствующие 0 и 1 бинарного потока. Эти сигналы посылаются через среду передачи на приемный узел. Механические и электрические/оптические свойства среды передачи определяются на физическом уровне и включаютя:

  • Тип кабелей и разъемов
  • Разводку контактов в разъемах
  • Схему кодирования сигналов для значений 0 и 1

К числу наиболее распространенных спецификаций физического уровня относятся:

  • EIA-RS-232-C, CCITT V.24/V.28 - механические/электрические характеристики несбалансированного последовательного интерфейса.
  • EIA-RS-422/449, CCITT V.10 - механические, электрические и оптические характеристики сбалансированного последовательного интерфейса.
  • IEEE 802.3 -- Ethernet
  • IEEE 802.5 -- Token ring

Уровень 2, канальный

Канальный уровень обеспечивает создание, передачу и прием кадров данных. Этот уровень обслуживает запросы сетевого уровня и использует сервис физического уровня для приема и передачи пакетов. Спецификации IEEE 802.x делят канальный уровень на два подуровня: управление логическим каналом (LLC) и управление доступом к среде (MAC). LLC обеспечивает обслуживание сетевого уровня, а подуровень MAC регулирует доступ к разделяемой физической среде.

Наиболее часто используемые на уровне 2 протоколы включают:

  • HDLC для последовательных соединений
  • IEEE 802.2 LLC (тип I и тип II) обеспечивают MAC для сред 802.x
  • Ethernet
  • Token ring
  • FDDI
  • X.25
  • Frame relay

Уровень 3, сетевой

Сетевой уровень отвечает за деление пользователей на группы. На этом уровне происходит маршрутизация пакетов на основе преобразования MAC-адресов в сетевые адреса. Сетевой уровень обеспечивает также прозрачную передачу пакетов на транспортный уровень.

Наиболее часто на сетевом уровне используются протоколы:

  • IP - протокол Internet
  • IPX - протокол межсетевого обмена
  • X.25 (частично этот протокол реализован на уровне 2)
  • CLNP - сетевой протокол без организации соединений

Уровень 4, транспортный

Транспортный уровень делит потоки информации на достаточно малые фрагменты (пакеты) для передачи их на сетевой уровень.

Наиболее распространенные протоколы транспортного уровня включают:

  • TCP - протокол управления передачей
  • NCP - Netware Core Protocol
  • SPX - упорядоченный обмен пакетами
  • TP4 - протокол передачи класса 4

Уровень 5, сеансовый

Сеансовый уровень отвечает за организацию сеансов обмена данными между оконечными машинами. Протоколы сеансового уровня обычно являются составной частью функций трех верхних уровней модели.

Уровень 6, уровень представления

Уровень представления отвечает за возможность диалога между приложениями на разных машинах. Этот уровень обеспечивает преобразование данных (кодирование, компрессия и т.п.) прикладного уровня в поток информации для транспортного уровня. Протоколы уровня представления обычно являются составной частью функций трех верхних уровней модели.

Уровень 7, прикладной

Прикладной уровень отвечает за доступ приложений в сеть. Задачами этого уровня является перенос файлов, обмен почтовыми сообщениями и управление сетью.

К числу наиболее распространенных протоколов верхних уровней относятся:

  • FTP - протокол переноса файлов
  • TFTP - упрощенный протокол переноса файлов
  • X.400 - электронная почта
  • Telnet
  • SMTP - простой протокол почтового обмена
  • CMIP - общий протокол управления информацией
  • SNMP - простой протокол управления сетью
  • NFS - сетевая файловая система
  • FTAM - метод доступа для переноса файлов

Протоколы IEEE 802

IEEE (Institute of Electrical and Electronics Engineers) является профессиональной организацией (США), определяющей стандарты, связанные с сетями и другими аспектами электронных коммуникаций. Группа IEEE 802.X содержит описание сетевых спецификаций и содержит стандарты, рекомендации и информационные документы для сетей и телекоммуникаций.

Публикации IEEE являются результатом работы различных технических, исследовательских и рабочих групп.

Рекомендации IEEE связаны главным образом с 2 нижними уровнями модели OSI - физическим и канальным. Эти рекомендации делят канальный уровень на 2 подуровня нижний - MAC (управление доступом к среде) и верхний - LLC (управление логическим каналом).

Часть стандартов IEEE (802.1 - 802.11) была адаптирована ISO (8801-1 - 8802-11, соответственно), получив статус международных стандартов. В литературе, однако, гораздо чаще упоминаются исходные стандарты, а не международные (IEEE 802.3, а не ISO/IEC 8802-3).

Ниже приведено краткое описание стандартов IEEE 802.X:

  • 802.1 - задает стандарты управления сетью на MAC-уровне, включая алгоритм Spanning Tree. Этот алгоритм используется для обеспечения единственности пути (отсутствия петель) в многосвязных сетях на основе мостов и коммутаторов с возможностью его замены альтернативным путем в случае выхода из строя. Документы также содержат спецификации сетевого управления и межсетевого взаимодействия.
  • 802.2 - определяет функционирование подуровня LLC на канальном уровне модели OSI. LLC обеспечивает интерфейс между методами доступа к среде и сетевым уровнем. Прозрачные для вышележащих уровней функции LLC включают кадрирование, адресацию, контроль ошибок. Этот подуровень используется в спецификации 802.3 Ethernet, но не включен в спецификацию Ethernet II.
  • 802.3 - описывает физический уровень и подуровень MAC для сетей с немодулированной передачей (baseband networks), использующих шинную топологию и метод доступа CSMA/CD. Этот стандарт был разработан совместно с компаниями Digital, Intel, Xerox и весьма близок к стандарту Ethernet. Однако стандарты Ethernet II и IEEE 802.3 не полностью идентичны и для обеспечения совместимости разнотипных узлов требуется применять специальные меры. 802.3 также включает технологии Fast Ethernet (100BaseTx, 100BaseFx, 100BaseFl).
  • 802.5 - описывает физический уровень и подуровень MAC для сетей с кольцевой топологией и передачей маркеров. Этому стандарту соответствуют сети IBM Token Ring 4/16 Мбит/с.
  • 802.8 - отчет TAG по оптическим сетям. Документ содержит обсуждение использования оптических кабелей в сетях 802.3 - 802.6, а также рекомендации по установке оптических кабельных систем.
  • 802.9 - отчет рабочей группы по интеграции голоса и данных (IVD). Документ задает архитектуру и интерфейсы устройств для одновременной передачи данных и голоса по одной линии. Стандарт 802.9, принятый в 1993 году, совместим с ISDN и использует подуровень LLC, определенный в 802.2, а также поддерживает кабельные системы UTP (неэкранированные кабели из скрученных пар).
  • 802.10 - в этом отчете рабочей группы по безопасности ЛВС рассмотрены вопросы обмена данными, шифрования, управления сетями и безопасности в сетевых архитектурах, совместимых с моделью OSI.
  • 802.11 - имя рабочей группы, занимающейся спецификацийе 100BaseVG Ethernet 100BaseVG. Комитет 802.3, в свою очередь, также предложил спецификации для Ethernet 100 Мбит/с

Отметим, что работа комитета 802.2 послужила базой для нескольких стандартов (802.3 - 802.6, 802.12). Отдельные комитеты (802.7 - 802.11) выполняют в основном информационные функции для комитетов, связанных с сетевыми архитектурами.

Отметим также, что разные комитеты 802.X задают разный порядок битов при передаче. Например, 802.3 (CSMA/CD) задает порядок LSB, при котором передается сначала наименее значимый бит (младший разряд), 802.5 (token ring) использует обратный порядок - MSB, как и ANSI X3T9.5 - комитет, отвечающий за архитектурные спецификации FDDI. Эти два варианта порядка передачи известны как "little-endian" (канонический) и "big-endian" (некононический), соответственно. Эта разница в порядке передачи имеет существенное значение для мостов и маршрутизаторов, связывающих различные сети.

Международный телекоммуникационный союз (ITU)

ITU представляет собой международную организацию в области стандартизации при ООН, ответственную за разработку стандартов для телекоммуникационного оборудования и услуг.

ITU включает три подразделения:

  • ITU-T (телекоммуникационный сектор, ранее Международный консультативный комитет по телефонной и телеграфной связи - CCITT) отвечает за коммуникационные стандарты. Эта группа является наиболее активным разработчиком стандартов в сфере передачи данных по сетям.
  • CCIR - международный консультативный комитет по радиосвязи.
  • IFRB - международный комитет по регистрации частот, отвечающий за выделение радиочастот для телекоммуникаций.

Ниже приведен список наиболее распространенных стандартов ITU:

  • V.11 - электрические характеристики сбалансированных устройств при скоростях до 10 Мбит/с. Совместим с RS-422.
  • V.22 - работа синхронных и асинхронных модемов по выделенным и коммутируемым линиям при скоростях до 1200 бит/с.
  • V.22bis - работа синхронных и асинхронных модемов по выделенным и коммутируемым линиям при скоростях до 2400 бит/с с возможностью снижения до 1200 бит/с.
  • V.24 - устройства физического обмена данными для подключения компьютерного оборудования. RS-232D является частью V.24. V.28 определяет электрические параметры устройства.
  • V.25bis - процедура автоматических звонков (соединений) и ответа, реализующая командный протокол, подобный набору команд Hayes AT, но ориентированных на поддержку систем международной связи.
  • V.28 - электрические характеристики несбалансированного устройтсва обмена, используемого совместно с физическим устройством V.24. Напряжение от 5 до 15 В определяет двоичный 0; от -5 до -15 - двоичную 1. Стандарт совместим с RS-232D.
  • V.32 - работа синхронных и асинхронных модемов по выделенным и коммутируемым линиям при скоростях до 9600 и 4800 бит/с.
  • V.32ter - версия стандарта V.32, предложенная AT&T для скорости 19200 бит/с с возможностью снижения до максимальной поддерживаемой линией и устройствами скорости.
  • V.32 bis - работа синхронных и асинхронных модемов по выделенным и коммутируемым линиям при скоростях до 14400 бит/сс возможностью снижения до максимальной поддерживаемой линией и устройствами скорости.
  • V.35 - физическое устройство обмена данными для подключения компьютерного оборудования при скоростях до 48 Кбит/с взамен устаревших V.36 и V.37. Сейчас V.35 является базовым термином для описания физического соединения и электрических параметров при скоростях до 2 Мбит/с.
  • V.42 - Стандарт CCITT для контроля ошибок при связи асинхронных модемов. Определяет протокол LAP-M.
  • V.42bis - Стандарт CCITT для встроенного в модемы протокола коррекции ошибок и компрессии данных.
  • V.34 - работа синхронных и асинхронных модемов по выделенным и коммутируемым линиям при скоростях до 28800 бит/с.

Другие стандарты

Американский национальный институт стандартов (ANSI)

Представляет США в ISO. К числу наиболее важных стандартов ANSI относится FDDI.

ATM Forum

Некоммерческая организация (консорциум), задачей которой является обеспечение интероперабельности оборудования на базе международных стандартов и обеспечение кооперации производителей оборудования. К числу наиболее важных стандартов ATM Forum относятся:

  • Эмуляция ЛВС (ATM LAN Emulation v. 1.0)
  • Спецификация основанного на кадрах взаимодействия пользователь-сеть (FUNI)
  • UNI 3.0, 3.1 и 4.0

Ассоциация электронной промышленности (EIA)

Наиболее важные стандарты EIA:

  • Интерфейс RS-232D

  • Кабельные системы EIA/TIA-568

Приведенная в документе техническая информация может быть изменена без предупреждения.
4 июня 1998 года


The Switching Book

Справочный раздел

Что такое коммутация ЛВС?
Технологические аспекты
Экономические аспекты

Книга о коммутаторах

Коммутация ЛВС

Glenn Gabriel Ben-Yosef

Что такое коммутация ЛВС?

Коммутация в локальных сетях (ЛВС) является одной из основ происходящего сегодня перехода к использованию технологий следующего поколения. Традиционные ЛВС рассчитаны на совместное использование ресурсов пользователями небольшого числа станций (обычно до 50). К числу разделяемых ресурсов относятся файлы и периферийные устройства (принтеры, модемы и т.п.). Поскольку картина трафика в таких сетях имеет ярко выраженный взрывной характер, использование разделяемой между всеми пользователями полосы может приводить к существенному замедлению работы. Стандарты Ethernet и token ring регулируют доступ сетевых устройств к разделяемой среде передачи. Когда одно из устройств передает данные в сеть, все остальные должны ждать окончания передачи, не делая попыток передать в сеть свои данные.

Такая схема разделения доступа к среде очень эффективна в небольших сетях, используемых для совместного использования файлов или принтеров. Сегодня размер и сложность локальных сетей значительно возрасли, а число устройств измеряется тысячами. В сочетании с ростом потребностей пользователей недетерминистический характер традиционных сеетвых архитектур (таких как Ethernet и token ring) начал ограничивать возможности сетевых приложений. Коммутация ЛВС является популярной технологией, способной продлить жизнь существующих ЛВС на базе Ethernet и token ring. Преимущества коммутации заключаются в сегментировании сетей - делении их на более мелкие фрагменты со значительным снижением числа станций в каждом сегменте. Изоляция трафика в небольшом сегменте приводит к многократному расширению доступной каждому пользователю полосы, а поддержка виртуальных ЛВС (VLAN) значительно повышает гибкость системы.

Коммутация обеспечивает сегментирование ЛВС с разделяемой средой

Администраторы сетей должны представлять себе технологические аспекты коммутации ЛВС и стоимость перехода к использованию коммутаторов в существующих сетях. Технологические вопросы включают понимание архитектуры коммутаторов ЛВС различий между коммутацией на MAC-уровне и маршрутизацией на сетевом, а также разницы между выполнением операций на программном и аппаратном уровне. Экономические аспекты включают сравнение соотношения производительность/цена для маршрутизаторов и коммутаторов, оценку эффективности вложения средств, а также расходов на организацию и поддержку сетей (включая управление сетью).

Технологические аспекты

Еще недавно для сегментации ЛВС использовались мосты, но развитие технологий позволило использовать для этого более эффективные решения. Еще несколько лет назад для объединения сегментов ЛВС использовались маршрутизаторы - устройства сетевого уровня. Маршрутизаторы обеспечивают эффективную сегментацию, но они достаточны дороги и сложны в управлении. Появление коммутаторов, основанных на базе специализированных контроллеров ASIC, сделало эти устройства значительно более эффективным инструментом сегментации сетей.

Коммутаторы ЛВС отличаются большим разнообразием возможностей и, следовательно, цен - стоимость 1 порта колеблется в диапазоне от 50 до 1000 долларов. Одной из причин столь больших различий является то, что они предназначены для решения различных классов задач. Коммутаторы высокого класса должны обеспечивать высокую производительность и плотность портов, а также поддерживать широкий спектр функций управления. Такие устройства зачастую кроме традиционной коммутации на MAC-уровне выполняют функции маршрутизации. Простые и дешевые коммутаторы имеют обычно небольшое число портов и не способны поддерживать функции управления.

Одним из основных различий является используемая в коммутаторе архитектура. Поскольку большинство современных коммутаторов работают на основе патентованных контроллеров ASIC, устройство этих микросхем и их интеграция с остальными модулями коммутатора (включая буферы ввода-вывода) играет важнейшую роль. Коммутаторы, реализующие также функции сетевого уровня (маршрутизацию), оснащены, как правило, RISC-процессорами для выполнения ресурсоемких программ маршрутизации.

Блок-схема коммутатора с архитектурой cross-bar
Рисунок 2.1 Блок-схема коммутатора с архитектурой cross-bar
Контроллеры ASIC для коммутаторов ЛВС делятся на 2 класса - большие ASIC, способные обслуживать множество коммутируемых портов (один контроллер на устройство) и небольшие ASIC, обслуживающие по несколько портов и объединяемые в матрицы коммутации. Вопросы масштабирования и стратегия разработчиков коммутаторов в области организации магистралей и/или рабочих групп определяет выбор ASIC и, следовательно, - скорость продвижения коммутаторов на рынок.

Существует 3 варианта архитектуры коммутаторов - переключение (cross-bar) с буферизацией на входе, самомаршрутизация (self-route) с разделяемой памятью и высокоскоростная шина. На рисунке 2.1 показана блоксхема коммутатора с архитектурой, используемой для поочередного соединения пар портов. В любой момент такой коммутатор может обеспечить организацию только одного соединения (пара портов). При невысоком уровне трафика не требуется хранение данных в памяти перед отправкой в порт назначения - такой вариант называется коммутацией на лету cut-through). Однако, коммутаторы cross-bar требуют буферизации на входе от каждого порта, поскольку в случае использования единственного возможного соединения коммутатор блокируется (рисунок 2.2). Несмотря на малую стоимость и высокую скорость продвижения на рынок, коммутаторы класса cross-bar слишком примитивны для эффективной трансляции между низкоскоростными интерфейсами Ethernet или token ring и высокоскоростными портами ATM и FDDI.

Блокировка коммутатора с архитектурой cross-bar
Рисунок 2.2 Блокировка коммутатора с архитектурой cross-bar
Коммутаторы с разделяемой памятью имеют общий входной буфер для всех портов, используемый как внутренняя магистраль устройства (backplane). Буферизагия данных перед их рассылкой (store-and-forward - сохранить и переслать) приводит к возникновению задержки. Однако, коммутаторы с разделяемой памятью, как показано на рисунке 2.3 не требуют организации специальной внутренней магистрали для передачи данных между портами, что обеспечивает им более низкую цену по сравнению с коммутаторами на базе высокоскоростной внутренней шины.
Архитектура коммутатора с разделяемой памятью
Рисунок 2.3 Архитектура коммутатора с разделяемой памятью
На рисунке 2.4 показана блок-схема коммутатора с высокоскоростной шиной, связывающей контроллеры ASIC. После того, как данные преобразубтся в приемлемый для передачи по шине формат, они помещаются на шину и далее передаются в порт назначения. Поскольку шина может обеспечивать одновременную передачу потока данных от всех портов, такие коммутаторы часто называют "неблокируемыми" (non-blocking) - они не создают пробок на пути передачи данных.
Коммутатор с высокоскоростной шиной
Рисунок 2.4 Коммутатор с высокоскоростной шиной
Понимание модели OSI весьма полезно при рассмотрении различий между коммутацией на уровне MAC и маршрутизацией а сетевом уровне. Коммутация (сервис канального уровня) лежит ниже в иерархии уровней модели OSI, нежели маршрутизация (сервис сетевого уровня). Следовательно, коммутаторам не требуется так много интеллектуальных возможностей, как маршрутизаторам. В результате коммутаторы работают существенно быстрее, чем маршрутизаторы.

Коммутаторы работают с протоколами MAC-уровня (Ethernet, token ring и т.п.), а маршрутизаторы - с протоколами сетевого уровня (IP, IPX). На рисунке 2.5 показаны соотношения между сервисом MAC-уровня (коммутация) и сетевого уровня (маршрутизация). Коммутация использует "плоское" представдение сети, а маршрутизация понимает "сетевую иерархию". Поскольку маршрутизаторы фактически являются устройствами для объединения больших сетей на базе протоколов IP и IPX, обеспечение услуг маршрутизации играет важную роль для многих сетей. Когда коммутаторы начнут выполнять большую часть функций маршрутизации, роль традиционных маршрутизаторов в построении сетей существенно изменится.

Коммутация и маршрутизация в модели OSI
Рисунок 2.5 Коммутация и маршрутизация в модели OSI
Большинство современных сетевых устройств - концентраторы, коммутаторы, маршрутизаторы - поддерживают отдельные функции коммутации и маршрутизации. Администратор сети должен решить, какие услуги каждого типа требуются в сети и чье оборудование наиболее соответствует задачам.

Аппаратные реализации коммутаторов ЛВС используют специализированные микросхемы ASIC (собственной разработки или других фирм), в которых реализованы функции коммутации. Аппаратная реализация обеспечивает более высокую скорость по сравнению с программной. Однако, этого еще недостаточно для создания хорошего коммутатора. При разработке ASIC должны создавать и проверяться программы коммутации, реализуемые в микросхемах. После создания контроллера программный код уже нельзя изменить, поэтому эффективность машины коммутации играет важнейшую роль. Стремление быстрее предложить устройства на рынок зачастую определяет уровень функциональности ASIC. Программные решения используют процессоры общего назначения, для работы которых требуется загрузить программный код. Преимущества такого подхода включают более высокий уровень сервиса (например, маршрутизация), но эти преимущества зачастую полностью подавляются ростом задержек.

Экономические аспекты

Очевидно, что основной причиной столь быстрого внедрения коммутаторов является более низкая, по сравнению с традиционными маршрутизаторами, стоимость самих устройств и существенное снижение расходов на организацию и поддержку сетей. Будучи устройством MAC-уровня, коммутатор не требует какой-либо настройки и обеспечивает решение plug-and-play (это относится прежде всего к простым коммутаторам). Коммутаторы легко позволяют решить проблему расширения полосы и могут работать в сетях с традиционными маршрутизаторами, обеспечивая деление сети на сегменты, связываемые потом маршрутизаторами. Поскольку на канальном уровне сеть выглядит плоской, все дополнительные услуги маршрутизации должны выполняться традиционными маршрутизаторами. Таким образом, коммутаторы в рабочих группах позволяют эффективно сегментировать сеть, оставляя маршрутизаторам функции связи между сегментами.

Другой причиной быстрого роста популярности коммутаторов является то, что они оптимизированы для решения различных сетевых задач (в частности для организации рабочих групп). Поскольку потребности рабочих групп связаны прежде всего с высокой скоростью обмена и обеспечением неблокируемых путей передачи трафика между членами группы, коммутаторы ЛВС содержат в качестве ядра аппаратную машину коммутации (switching engine). Массовое производство контроллеров ASIC привело к значительному снижению цен. Дополнительные высокоскоростные порты (uplink) для подключения к серверам, маршрутизаторам или магистралям обеспечивают пользователям рабочих групп удовлетворение всех возникающих потребностей. Гибкое и масштабируемое выделение полосы делает коммутаторы ЛВС важной частью процесса модернизации существующих сетей на базе разделяемых сред. Возможность простого переноса из одной точки сети в другую обеспечивает высокую эффективность капиталовложений, поскольку при изменении задач или структуры сети не приходится покупать новые устройства взамен имеющихся.

Возможно наибольшая экономия в результате использования коммутаторов связана с эффектиной сегментацией сети (рост пропускной способности) и простотой управления (plug-and-play). В отличие от маршрутизаторов, коммутаторы ЛВС практически не требуют настройки и не отнимают много времени у сетевых администраторов. MAC-адреса подключенных к коммутатору устройств определяются автоматически, а сложные схемы IP-адресации, используемые в сегодняшних сетях остаются полностью прозрачными для рабочих групп. Установка коммутатора в рабочей группе обычно не требует ничего, кроме подключения устройств к портам коммутатора взамен портов концентратора или размещения коммутатора между концентраторами и маршрутизатором как показано на рисунках 2.6, 2.7 и 2.8.

Традиционная ЛВС на основе концентратора
Рисунок 2.6 Традиционная ЛВС на основе концентратора
Коммутатор ЛВС взамен хаба
Рисунок 2.7 Коммутатор ЛВС взамен хаба
Совместное использование коммутаторов и концентраторов
Рисунок 2.8 Совместное использование коммутаторов и концентраторов

Коммутаторы ЛВС обеспечивают расширение агрегатной полосы

Сегментирование ЛВС с разделяемой средой можно проиллюстрировать на примере разделения участников большой конференции на специализированные группы, разделенные в разных помещениях. Сегментация сети обеспечивает многократный рост агрегатной полосы, позволяя вместо одного устройства вести передачу многим устройствам сразу. Сети Ethernet и token ring аналогичны пленарным заседаниям конференций, где все слушают одного оратора. Заседания рабочих групп позволяют выступать одному человеку в каждой группе. Таким образом и сегментация сетей позволяет вести передачу данных нескольким устройствам одновременно (по одному на сегмент).

При рассмотрении вопросов коммутации ЛВС важно понимать картину трафика и изменения в структуре ЛВС. Картины трафика в традиционных ЛВС с состязательным доступом к среде и сетях с выделенной полосой для каждого порта существенно отличаются. При изучении картины администратор наверняка увидит, что отдельным пользователям или группам требуется более широкая полоса, а часть задач весьма чувствительна к задержкам.

Изменения в структуре ЛВС и картине трафика

Сейчас уже очевидно, что используемый в сетях с разделяемой полосой состязательный механизм доступа является основной причиной недостаточной пропускной способности традиционных ЛВС. Напомним, что в каждый момент времени передавать данные в разделяемую среду может лишь одна станция - остальные должны "слушать". Реализации механизмов доступа в сетях Ethernet и token ring отличаются, следовательно, будут различаться и результаты использования коммутаторов.

Доступ к среде в сетях Ethernet основан на алгоритме CSMA/CD (множественный доступ с детектированием несущей и обнаружением конфликтов). Когда станции требуется передать данные, она сначала проверяет канал на предмет его использования другой станцией (обнаружение несущей - CS). Если среда в данный момент не используется, станция может начать передачу. Если среда занята, станция повторяет попытку доступа по истечении случайного интервала времени. Несмотря на предварительное прослушивание среды две (или более) станции могут начать передачу одновременно - возникает конфликт или коллизия (CD). В этом случае обе станции должны немедленно прекратить передачу и пытаться повторить ее по истечение случайного интервала времени.

В небольших сетях взрывной характер трафика (пакеты данных передаются лишь время от времени) обеспечивает достаточно малую вероятность возникновения конфликтов. В большой сети интервалы между пакетами сокращаются и вероятность коллизий растет. Это приводит к тому (рисунок 2.9), что в больших сетях возможна (хотя и маловероятна) ситуация, когда какая-либо станция (например, с медленным процессором) вообще не сможет получить доступа к среде передачи, поскольку какой-либо очередности доступа не соблюдается (известный принцип - кто первый встал, тому и тапочки). Сегментация такой сети позволит обеспечить существенное повышение пропускной способности.

Пример сети рабочей группы
Figure 2.9 Пример сети рабочей группы

Число станций и эффективная полоса

В сетях Token ring доступ к среде основан на передаче маркера (token) - специального пакета, распространяемого по кольцу. Получившая маркер станция может начать начать передачу своих данных в сеть. Здесь не возникает конфликтов, но станция, не владеющая маркером, не может передавать данные, даже при свободной среде. В маленьких сетях цикл передачи маркера по кольцу занимает немного времени и станции не ждут подолну возможности начать передачу. Однако, в большой сети время ожидания может стать слишком большим. Разделение кольца на несколько меньших колец с помощью коммутатора (сегментация) уменьшает число станций в кольце и снижает время ожидания маркера. Кроме того, коммутация token ring повышает устойчивость сети к повреждениям.

Причиной нехватки пропускной способности является то, что каждая станция сегмента слышит "разговоры" всех других станций. Переход к ориентированным на организацию соедиений "точка-точка" технологиям типа ATM, является важнейшим шагом вперед. Преимущества полностью коммутируемых сетей, ориентированных на организацию соединений, очевидны, но что делать с имеющимися сетевыми приложениями и услугами на основе широковещательных пакетов в традиционных ЛВС. До тех пор, пока все эти приложения не будут переписаны для сетей на основе организации прямых соединений, проблема широковещательного трафика будет основным вопросом в связи с коммутацией ЛВС.

Число пользователей Ethernet и эффективная полоса
Рисунок 2.10 Число пользователей Ethernet и эффективная полоса

Различниые требования пользователей к полосе

Широкополосные приложения, такие как multimedia и базы данных клиент-сервер являются достаточно тяжелым грузом для ЛВС с разделяемой средой, рассчитанных просто на совместное использование файлов и принтеров. Использование состязательных механизмов доступ к среде не позволяет обеспечить пользователям графических приложений высокоскоростной перенос по сети больших объемов данных с малой задержкой. Администраторы сетей часто решают эту проблему организацией для таких пользователей отдельных сегментов без перехода на высокоскоростные технологии типа FDDI. Подбор числа пользователей для каждого порта коммутатора обеспечивает экономичное решение проблемы недостаточной пропускной способности без перехода на новые технологии.

Файловые серверы, серверы приложений и пользователи с высокими запросами можно подключить к коммутатору через скоростные порты Fast Ethernet, FDDI или ATM. Этот путь требует замены сетевых адаптеров в серверах и, возможно, кабельной системы, но обеспечивает гибкое и масштабируемое решение.

Широкополосные приложения отнюдь не являются единственной проблемой сетевых администраторов. Чувствительные к задержкам задачи реального времени (например, видео) в разделяемых средах с недетерминистическим способом доступа (типа Ethernet).

Коммутация ЛВС повышает уровень гибкости

Коммутация ЛВС позволяет создавать виртуальные сети (VLAN) из групп пользователей, основываясь на их задачах, а не по физическому расположению в сети. Технология виртуальных ЛВС позволяет пользователям свободно перемещаться по сети, оставаясь в своей рабочей группе.

Простота приспособления виртуальных ЛВС к перемещению и добавлению узлов, а также другим изменениям в сети вместе с эффективной интеграцией традиционных ЛВС в сети ATM способна поразить воображение каждого. Перестройка сети с учетом роста числа мобильных пользователей и необходимости обеспечения доступа на базе правил, позволяет многочисленным пользователям свободно работать даже находясь за пределами офиса. Планирование интеграции традиционных ЛВС в сети на базе ATM требует от администраторов с осторожностью относится к выбору технологии. Правильный выбор позволит создать эффективную сеть и обеспечит возможность поэтапного перехода на новые технологии.

Виртуальные ЛВС упрощают перенос, добавление или удаление узлов

Сотрудники многих организаций работают над различными проектами, группируясь в рабочие команды для решения конкретных задач. По мере решения задачи состав группы может меняться, а по завершении потребуется создание новой группы. Организация рабочих групп по физическому расположнию компьютеров (как это делается в сетях с разделяемой средой) зачастую создает трудноразрешимые проблемы. Приходится переносить рабочие места пользователей или передавать большие объемы информации через перегруженные маршрутизаторы. Кроме того, трудоемкость настройки маршрутизаторов делает практически нереальной задачу создания временных рабочих групп из числа сотрудников, удаленных друг от друга. Виртуальные ЛВС позволяют группировать пользователей, не обращая внимание на их физическое расположение в сети - вы можете создать рабочую группу из сотрудников, расположенных в разных зданиях или даже в разных городах.

Возможность организации VLAN с использованием WAN-каналов требует интеграции коммутаторов ЛВС и ATM. На рисунке 2.11 показан пример использования ATM для организации логического соединения между портами удаленных коммутаторов ЛВС. Таким образом можно создавать широковещательные домены (виртуальные ЛВС) из станций, расположенных на значительном удалении

Логические соединения коммутаторов ATM через WAN-каналы
Рисунок 2.11 Логические соединения коммутаторов ATM через WAN-каналы
Виртуальные ЛВС обеспечивают многочисленные преимущества. Рассмотрим для примера организацию с большим числом работающих на выезде сотрудников. При переезде такого сотрудника в другое место меняется его сетевой адрес и требуется полностью обновлять таблицу маршрутизации. Пользователю после такого переезда также придется вносить конфигурационные изменения для получения привычного сервиса. Виртуальные ЛВС на базе коммутаторов с поддержкой функций маршрутизации значительно упрощают операции, связанные с перемещениями пользователей. Возможно обеспечить полное сохранение рабочей среды независимо от местоположения пользователя (рисунок 2.12).
Построение виртуальной ЛВС
Рисунок 2.12 Построение виртуальной ЛВС
В дополнение к возможности организации распределенных рабочих групп технология VLAN позволяет создавать такие группы на основе широкого набора критериев (правил), задаваемых администратором сети. Таким образом, вопросы доступа, обеспечения безопасности, ведения счетов на оплату услуг можно решать автоматически за счет задания соответствующих правил организации VLAN. Виртуальные сети на базе правил позволяют обеспечить высочайшую гибкость при надежном обеспечении безопасности сети. Управление VLAN на основе технолгии drag-and-drop позволяет легко настраивать права доступа, создавать и менять логические рабочие группы.
Построение виртуальной ЛВС
Рисунок 2.13 Построение виртуальной ЛВС

Коммутация ЛВС обеспечивает интеграцию традиционных рабочих групп в сети ATM

Возможно одним из основных преимуществ коммутации ЛВС является возможность удовлетворения разнообразных потребностей пользователей в части предоставления полосы и типа сервиса. Как мы показали ранее установка коммутатора ЛВС, работающего на MAC-уровне не требует внесения изменений на уровне рабочих станций или уже имеющихся в сети маршрутизаторов. За счет возможности управления числом станций на каждом порту коммутатора администратор может обеспечить каждому пользователю или приложению требуемую полосу и величину задержки. Высокоскоростные магистральные модули (uplink) обеспечивают хорошее масштабирование за счет возможности подключения к высокоскоростным серверам и магистралям. Поскольку установка коммутаторов практически не требует настройки, добавление коммутаторов вследствие роста сети не вызывает затруднений и не требует высоких расходов.

Наконец, возможность поэтапной модернизации позволяет оценить необходимость использования новых технологий (типа ATM) для расширения возможностей существующих сетей. Реализация сетей полностью на базе ATM требует значительных средств и возможность использования преимуществ этой технологии при сохранении существующих сетей Ethernet и token ring имеет очень важное значение.

Приведенная в документе техническая информация может быть изменена без предупреждения.
12 июня 1998 года


The Switching Book

Справочный раздел

Четыре этапа развития сетей
1: Большие компьютеры
2: Мини-компьютеры
3: Сети с разделяемой полосой
4: Коммутация
Основные элементы коммутируемых систем

Книга о коммутаторах

Коммутаторы - революция в сетях

Дуглас Хилл (Douglas Hill)

Вице-президент корпорации Xylan

Четыре этапа развития сетей

В развитии сетевых коммуникаций хорошо видны 3 основных этапа, а сегодня происходит становление четвертого. Каждый из периодов развития создавал новое поколение оборудования и приложений, постоянно расширяя использование компьютеров во всех сферах человеческой деятельности. Мы присутствуем при зарождении и развитии новой эру сетевых технологий - коммутируемых сетей, в которых каждый узел может получить в свое распоряжение всю полосу среды передачи.

Этап 1: Сети больших компьютеров (1965 - 1975)

В времена доминирования больших компьютеров было разработано множество частных вариантов сетевой архитектуры. Сети того времени обеспечивали надежное, масштабируемое решение для связи между терминалами и хостами. Все приложения работали на большом компьютере, а передаваемые через сеть данные имели в основном характер текста.

Наиболее существенным элементом сетей на базе мэйнфреймов были интерфейсные процессоры (front-end processor) и контроллеры кластеров (cluster controller), показанные на рисунке 1.1. Группы терминалов подключаются к контроллеру, а контроллеры к интерфейсному процессору с помощью системы соединений "точка-точка" по кабелям или выделенным телефонным линиям. По тем временам сети с такой архитектурой обеспечивали достаточно полное решение задач при сравнительно невысокой стоимости и достаточной надежности. Основным производителем больших компьютеров в то время была корпорация IBM. Их сети, построенные много лет назад, продолжают до сих пор надежно работатьв некоторых организациях. Однако, большинство пользователей со временем начало переходить к использованию сетей с маркерным кольцом (token ring), связанных между собой мостами и/или маршрутизаторами. Технология Token ring достаточно сложна, но обеспечивает большие преимущества в производительности, а также большую гибкость и широкую полосу доступа для локальных сетей.

Типичная схема мэйнфрейма
Рисунок 1.1 Типичная схема мэйнфрейма

Этап 2: Сети мини-компьютеров (1975 - 1985)

По мере расширения снижения цен и роста функциональности мини-компьютеров многие организации начали использовать их для бизнес-приложений. Терминальный доступ обеспечивался непосредственным подключением терминалов к асинхронным портам компьютеров. Статистические мультиплексоры обеспечивали совместное использование телефонных линий для удаленного доступа и защиту от ошибок. Телефонные станции (PBX) были общими для множества сетей, позволяя терминальным пользователям выбирать компьютеры для доступа (рисунок 1.2).

В сфере сетей произошли ключевые изменения - типичным стало использование оборудования от многих производителей для обеспечения требуемой функциональности. Эта потребность значительно ускорила разработку спецификаций межсетевого взаимодействия.

Крупнейший производитель мини-компьютеров - корпорация Digital Equipment Corporation стала одним из лидеров на рынке асинхронного оборудования для сетей на базе миникомпьютеров. Существующие терминалы подключались к терминальным серверам, а те, в свою очередь, - к мини-компьютерам, которые объединялись в локальные сети с помощью технологии Ethernet (10 Мбит/с). В такой архитектуре терминальные серверы заняли место PBX, а удаленные мосты заменили статистические мультиплексоры.

Примерно таким же путем шла эволюция сетей IBM. Кабели, соединяющие кластерные контроллеры с мэйнфреймами, были заменены локальными сетями token ring.

Рисунок 1.2 Эпоха мини-компьютеров

Этап 3: ЛВС с разделяемой средой (1985 - 1995)

Терминальные сети на базе оборудования IBM, DEC и более мелких производителей послужили основой для создания локальных сетей (ЛВС) как основы сетевой инфраструктуры. Однако более важным шагом явилось создание персональных компьютеров. Настольные компьютерные системы стали все шире сипользоваться в большинстве организаций, а пользователям потребовался совместный доступ к ресурсам (принтеры, файлы и т.п.) Для объединения компьютерных ресурсов и периферийного оборудования были разработаны сетевые операционные системы. Такое решение позволяло пользователю работать с локальными приложениями и обеспечило быстрый рост числа сетевых приложений и их повсеместное использование (рисунок 1.3).

Основой таких сетей является разделяемая среда. Множество компьютеров и других устройств подключены к общей физической среде (сегмент Ethernet или кольцо token ring). Поскольку собственные возможности первых ПК были весьма ограничены, такие компьютеры не могли порождать трафик, для которого возможностей разделяемой среды было бы недостаточно.

Для сетей с разделяемой средой характерны 2 основных проблемы:

  • Толстые кабели громоздки и дороги, кроме того для сетей Ethernet они не позволяют использовать топологию звезда, весьма распространенную при организации терефонных и терминальных сетей. В такой топологии кабели из скрученных пар соединяют каждое устройство с кабельным центром, организуемым для обслуживания 1 этажа или его части.
  • Для связи сегментов Ethernet и token rings использовались мосты. По своей природе эти устройства передают часть трафика (широковещательные пакеты - broadcasts) всем станциям. Для небольших сетей это не составляет проблемы, поскольку процент широковещательных пакетов невелик. Однако в очень больших сетях широковещательные пакеты откровенно перегружают сеть, занимая значительную часть разделяемой полосы.

Интеллектуальные концентраторы позволили решить кабельные проблемы, обеспечивая поддержку топологии "звезда" для Ethernet и token ring. Каждая станция может теперь использовать существующие кабельные системы на основе скрученных пар. Однако, при наличии в одном сегменте или кольце большого числа станций, организация кабельной системы становится сложной задачей.

Маршрутизация (в файловых серверах и специализированных устройствах) решила проблему широковещания, позволяя администраторам сегментировать сети. Маршрутизаторы ограничивают область широковещания (особенно важно это при использовании низкоскоростных WAN-каналов) и межсегментный трафик становится управляемым. Для решения этой задачи маршрутизаторы используют весьма сложные протоколы, позволяющие обеспечить интеллектуальную фильтрацию широковещательного трафика.

ЛВС с разделяемой средой
Рисунок 1.3 ЛВС с разделяемой средой

Этап 4: Коммутируемые сети (1995 - )

Быстрый рост возможностей настольных компьютеров послужил причиной начала новой эры сетевых технологий. Рост возможностей и производительности настольных компьютеров обусловил рост требований к производительности и функциональности сетей. Производительность современных компьютеров существенно выше возможностей Ethernet или token ring. Особенно существенно это ограничение сказывается при работе с корпоративными серверами, на которых хранится большая часть данных и работают совместно используемые приложения. (рисунок 1.4).

Рост возможностей настольных компьютеров привел к повсеместному использованию графических интерфейсов и представлению данных чаще в графических, нежели текстовых форматах. Всемирная паутина WWW, обработка изображений, медицинские приложения, САПР, учеьные курсы, допечатная подготовка изданий, да и обычные бизнес-приложения требуют от сети широкой полосы пропускания. Для передачи слова "самолет" требуется всего лишь 8 байт, а для передачи изображения этого самолета могут потребоваться десятки и сотни килобайт. Если же говорить о динамических изображениях, размеры начинают исчисляться десятками мегабайт.

Преимущества использования графических систем очевидны. Информация в графической форме быстрее воспринимается и более понятна. Пользователи затрачивают меньше времени на обучение работе с приложениями, существенно снижается расход бумаги. Возможна организация совместной работы специалистов, разделенных значительными расстояниями. Всех преимуществ просто не перечесть.

Обратной стороной этого прогремма является явная перегрузка сетей. Число пользователей постоянно растет, приложения клиент-сервер требуют все большей полосы, серверы приложений и файловые серверы корпоративных сетей делают трафик все менее локальным, расширяя его за пределы рабочих групп.

Становится понятным, что традиционные сетевые технологии на базе концентраторов и маршрутизаторов, разработанные 10 лет назад, просто не способны вынести такие нагрузки. Хорошей идеей является разделение сетей на более мелкие сегменты или кольца, но это решение не обеспечивает достаточного масштабирования сетей и усложняет управление.

Более эффективным решением является коммутация. В коммутируемых сетях каждая рабочая станция или сервер имеет выделенную полосу доступа (собственное подключение к сети). Это означает, что 20 пользователей взамен разделения среды Ethernet с полосой 10 Мбит/с получат агрегатную полосу до 200 Мбит/с. За счет поддержки коммутаторами высокоскоростных соединений 100BaseT, ATM или FDDI можно значительно ускорить доступ пользователей к серверам.

Рисунок 1.4 Эра коммутации

Базовые элементы коммутируемой сети

Четыре этапа развития сетей
Рисунок 1.5 Четыре этапа развития сетей

ATM-коммутация

Технология ATM является одним из ключевых аспектов перехода от ЛВС с разделяемой средой к коммутируемым системам. Пользователи ожидают, что оборудование различных производителей будет обеспечивать должную интероперабельность. Технология ATM обеспечивает надлежащую совместимость оборудования и услуг.

Асинхронный режим передачи (ATM) становится все более широко распространенным стандартным механизмом коммутации в современных сетях. Быстрая реализация протоколов локальных и распределенных сетей на базе ATM делает эту технологию все более привлекательной. ATM использует короткие ячейки фиксированной длины (53 байта), обеспечивающие меньшие задержки, нежели при передаче больших пакетов. Данная технология обеспечивает поддержку взрывного трафика ЛВС наряду с изохронным трафиком (например, видео). Поскольку коммутация ATM реализована полностью на аппаратном уровне и поддерживаются многосвязные топологии, сети ATM очень хорошо масштабируются для любых приложений.

Вопрос не в том, состоится ли всеобщий переход на ATM, а в том, как быстро это будет происходить. Очевидно, что наилучшим вариантом является непосредственное высокоскоростное подключение к сервису ATM настольных станций, однако в ближайшем будущем этого явно не произойдет. Интерфейсные платы ATM по-рпежнему существенно дороже Ethernet-адаптеров. Архитектура коммутаторов ATM еще находится в стадии развития и подключение слишком большого числа станций корпоративной сети непосредственно к ATM приведет к непосильному росту нагрузки на коммутаторы. Многим пользователям, которые хотят получить преимущества ATM, придется заменить свои кабельные системы на оптику или UTP категории 5. По-видимому, в ближайшие годы большинство организаций ограничатся использованием ATM для магистралей и рабочих групп, которым нужна очень высокая производительность.

Коммутация ЛВС

Коммутация ЛВС в настоящее время является наиболее динамичным сектором сетевой интдустрии. Причины этого очевидны - быстрое снижение цен (от 1.5 - 2 тясяч долларов за коммутируемый порт Ethernet в 1993 году до $100 сегодня). В отличие от маршрутизаторов коммутаторы ЛВС обеспечивают рассылку данных на аппаратном уровне за счет чего коммутаторы работают быстрее и производительнее, чем маршрутизаторы при более низких ценах. Большинство коммутаторов ЛВС поддерживает одновременно низкоскоростные (Ethernet и token ring) и высокоскоростные (100BaseT, FDDI и ATM) технологии. Способность коммутаторов поддерживать различные технологии обеспечивает возможность модернизации сетей без дорогостоящей прокладки новых кабельных инфраструктур. Пользователи, которые хотят получить преимущества коммутируемой технологии, вполне могут обойтись сегодня без ATM в настольных компьютерах. Для большинства приложений рост полосы за счет коммутации обеспечит решение всех задач. Дополнительный рост производительности обеспечит подключение серверов через высокоскоростные интерфейсы 100BaseT, FDDI или ATM. очевидно, что для решения этих задач требуются коммутаторы разных типов. Первый тип устройств обеспечивает подключение станций и серверов через порты Ethernet, token ring и FDDI. Каждое устройство использует выделенный порт для подключения к сети. связь между подключенными к одному коммутатору устройствами (например, рабочая станция и сервер рабочей группы) полностью обеспечивается данным коммутатором при высокой скорости обмена. Второй тип коммутаторов обеспечивает связь коммутаторов первого типа с коммутаторами ATM. Эти коммутаторы должны обеспечивать поддержку гигантских потоков магистрального трафика. За счет использования эмуляции ЛВС (ATM LAN Emulation) серверы, подключенные непосредственно к коммутаторам ATM, становятся доступными для рабочих станций, подключенных к коммутаторам ЛВС.

Такое решение обеспечивает несколько путей оптимизации коммутируемых магистралей ATM. Локальные коммутируемые соединения (в пределах коммутатора ЛВС) не преобразуются в потоки ячеек ATM. Данные сохраняются в форме традиционных пакетов, а отсутствие дополнительного преобразования позволяет избавиться от лишних задержек. Локальная коммутация снижает нагрузку на магистрали ATM. Коммутаторы ЛВС обеспечивают эффект статистического мультиплексирования, сглаживая поток входного трафика для коммутаторов ATM и оптимизируя пропускную способность магистральных сетей. Комбинация коммутаторов ЛВС (базовый способ доступа в сеть) и ATM (ядро коммутации) обеспечивает мощь новой сетевой парадигмы. Результирующая архитектура проще в управлении и обеспечивает значительно более высокую производительность, нежели сети на базе маршрутизаторов и интеллектуальных концентраторов.

Виртуальные ЛВС

Сети на базе коммутаторов ЛВС и ATM позволяют объединять пользователей в виртуальные сети (virtual LANs или VLAN). VLAN представляет собой логическую (в отличие от физических для традиционных сетей) группу пользователей. В сетях на базе маршрутизаторов пользователи идентифицируются по своему реальному местоположению в сети, выражаемому в адресах сетевого уровня, говорящих маршрутизатору в какой физический сегмент или кольцо нужно направлять данные для пользователя. Следовательно, пользователи одного сегмента должны находиться в одном здании или части здания. Виртуальная ЛВС не имеет подобных ограничений - пользователи могут находиться в любой точке сети. Другим подходом к VLAN является рассмотрение их как широковещательных доменов - весь широковещательный трафик ограничивается пределами данной VLAN. Протоколы предполагают, что широковещательные пакеты канального уровня (MAC-уровень) будут видны всем членам группы. В сетях на основе маршрутизаторов/концентраторов широковещательным доменом является сегмент или кольцо, в коммутируемой сети таким доменом является виртуальная ЛВС. Технологии VLAN позволяют строить очень большие коммутируемые сети без перегрузки полосы. Виртуальные сети можно строить на основе самых различных критериев - от физических портов до задаваемых администратором правил, включая в VLAN существующие концентраторы, маршрутизаторы, магистрали FDDI и ATM, распределенные сети и т.д.

Маршрутизация

В коммутируемых сетях необходимость маршрутизации не исчезает, просто изменяется ее роль. Маршрутизатору не нужно больше обеспечивать пересылку данных между зданиями или этажами. Коммутаторы обеспечивают значительно более высокую скорость для подобных операций. Маршрутизаторы теперь служат для объединения виртуальных ЛВС. VLAN представляют собой широковещательные домены, а эти домены соединяются с помощью маршрутизаторов. Функции маршрутизации можно также встроить в коммутаторы ЛВС, существенно уменьшая число оборудования и упрощая управление сетью. Модульная структура серверов маршрутизации позволяет выбрать для каждого приложения только нужные компоненты, существенно снижая сложность и стоимость оборудования. Серверы маршрутизации, встроенные в коммутаторы ЛВС могут быть централизованными или распределенными. Серверы маршрутизации в коммутаторах ATM упрощают управление сетью и существенно повышают уровень интероперабельности. Однако реализация функций маршрутизации в коммутаторах ATM сопряжена с целым рядом трудностей - коммутаторы для этого должны собирать пакеты из ячеек и только после этого принимать решение о пересылке пакета. Большинство производителей коммутаторов ATM не хочет брать на себя реализацию этих задач, ограничиваясь исключительно коммутацией ячеек.

Маршрутизаторы, ранее использовавшиеся в традиционных сетях, можно перестроить для работы с виртуальными ЛВС. Порты Ethernet, token ring или FDDI этих маршрутизаторов можно подключить к соответствующим портам коммутаторов ЛВС, обеспечивая маршрутизацию трафика между VLAN, организованными на базе коммутаторов. Или один порт ATM в маршрутизаторе может обеспечивать множество логических каналов, каждый из которых соединен с эмулируемой ЛВС ATM ELAN. Третьим вариантом является использование транковых протоколов для FDDI или 100BaseT.

Приведенная в документе техническая информация может быть изменена без предупреждения.
8 июня 1998 года


Xylan. The Switching Book

The Switching Book
Книга о коммутаторах

Введение
Коммутаторы - революция в сетях
Коммутация в ЛВС
Скоростные технологии ЛВС
ATM
Виртуальные ЛВС
Применения
Корпорация Xylan

Справочный раздел

Стандарты
Телекоммуникации
Ethernet
Token Ring
FDDI
ATM
Сетевые протоколы уровней 3 и 4
Источники дополнительной информации

Связь с переводчиком
The Switching Book

Корпорация Xylan

Перевод на русский язык Н. Малых

Приведенная в документе техническая информация может быть изменена без предупреждения. OmniSwitch, OmniStack и PizzaSwitch - торговые марки Xylan Corporation. Другие имена и торговые марки принадлежат соответствующим компаниям.
1 июля 1998 года


Xylan. The Switching Book.

Справочный раздел
Пример
RJ-11
25-парный кабель Telco
ISDN
T-Carrier
HDLC
X.25
SMDS
Frame relay
E1
Иерархия систем операторов

Книга о коммутаторах
Справочный раздел

Телекоммуникации

Пример коммуникационного оборудования

Телекоммуникации играют все более важную роль в компьютерных сетях, обеспечивая возможность доступа из ЛВС в распределенные сети и Internet.

Для понимания сходства и различий между оборудованием ЛВС и телекоммуникационным оборудованием и предназначен этот короткий раздел, включающий описание некоторых интерфейсов и форматов, чаще всего используемых на стыке локальных сетей и телекоммуникаций.

Приведенный на рисунке пример показывает вполне реальную конфигурацию для передачи данных через PABX. Используемое оборудование может быть самым разным, однако схема оставется практически неизменной.

Пример телефонного оборудования
Рисунок 8.3 Пример телефонного оборудования

RJ-11

4-проводная телефонная кабельная система. Рекомендуемое распределение по цветам проводников приведено в таблице, одгако реальная цветовая раскладка может отличаться у разных фирм.
1 | Черный
2 | Красный
3 | Зеленый
4 | Желтый
Наиболее распространенный в телефонных системах разъем RJ-11
Рисунок 8.2 Наиболее распространенный в телефонных системах разъем RJ-11

25-парный кабель Telco (ISO 13575)

Обычно используется для подключения кабелей от PBX.
Номера пар и окраска проводников
1 | Голубой/Белый - Белый/Голубой
2 | Оранжевый/Белый - Белый/Оранжевый
3 | Зеленый/Белый - Белый/Зеленый
4 | Коричневый/Белый - Белый/Коричневый
5 | Серо-голубой/Белый - Белый/Серо-голубой
6 | Голубой/Красный - Красный/Голубой
7 | Оранжевый/Красный - Красный/Оранжевый
8 | Зеленый/Красный - Красный/Зеленый
9 | Коричневый/Красный - Красный/Коричневый
10 | Серо-голубой/Красный - Красный/Серо-голубой
11 | Голубой/Черный - Черный/Голубой
12 | Оранжевый/Черный - Черный/Оранжевый
13 | Зеленый/Черный - Черный/Зеленый
14 | Коричневый/Черный - Черный/Коричневый
15 | Серо-голубой/Черный - Черный/Серо-голубой
16 | Голубой/Желтый - Желтый/Голубой
17 | Оранжевый/Желтый - Желтый/Оранжевый
18 | Зеленый/Желтый - Желтый/Зеленый
19 | Коричневый/Желтый - Желтый/Коричневый
20 | Серо-голубой/Желтый - Желтый/Серо-голубой
21 | Голубой/Фиолетовый - Фиолетовый/Голубой
22 | Оранжевый/Фиолетовый - Фиолетовый/Оранжевый
23 | Зеленый/Фиолетовый - Фиолетовый/Зеленый
24 | Коричневый/Фиолетовый - Фиолетовый/Фиолетовый
25 | Серо-голубой/Фиолетовый - Фиолетовый/Серо-голубой

Цифровая сеть с интеграцией услуг (ISDN)

ISDN обычно используется в двух вариантах - PRI и BRI. Линии PRI ISDN в США объединяют 23 канала пользователей (bearer channel или B-канал) - 56/64К и один сигнальный канал (D), а BRI использует 2 канала 56/64К, в Европе PRI содержит 30 каналов B и 1 канал D. Схема организации ISDN показана на рисунке 8.4.
Общая схема оборудования ISDN
Рисунок 8.4 Общая схема оборудования ISDN
BRI является основным вариантом использования ISDN в небольших организациях, а PRI может эффективно использоваться для мощных приложений, требующих широкой полосы.
TA | Терминальный адаптер
TE1 | Совместимое с ISDN терминальное оборудование
TE2 | Не совместимое с ISDN терминальное оборудование (например, терминал RS232)
NT2 | Модуль NT2 - обычно используется с линиями PRI ISDN
NT1 | Модуль NT1 - обычно используется с BRI ISDN
CPE | Пользовательское оборудование
PSTN | Телефонная сеть
R | Интерфейс с отличным от ISDN оборудованием
S/T | 4-проводный интерфейс
U | 2-проводный интерфейс (используется в основном в США)

T-Carrier

T-Carrier (Рисунок 8.5) - используется для кодирования данных в устройствах T1. Отметим, что на рисунке "1" представлены положительными и отрицательными импульсами, а "0" - нейтральным уровнем. В США PRI использует T1, делая T-Carrier важной частью технологии ISDN.

Последовательность кодирования T1
Рисунок 8.5 Последовательность кодирования T1

Формат кадров HDLC

HDLC является наиболее распространенным протоколом канального уровня для передачи данных в WAN-сетях.
HDLC - формат LAPD
Рисунок 8.6 HDLC - формат LAPD
C/R | Командный отклик
SAPI | Идентификатор точки доступа к сервису (SAPI)
TEI | Идентификатор оконечного терминала
Значения SAPI | 0 | Управление вызовом
 | 1 | Управление вызовом в пакетном режиме I.451
 | 16 | Пакет X.25 уровня 3
 | 63 | Управление канального уровня
Значения TE1 | 0-63 | Неавтоматическое назначение TE1 пользовательского оборудования
 | 64-126 | Автоматическое назначение TE1 пользовательского оборудования
 | 127 | Используется при автоматическом назначении TE1
Значения S-бита | 00 | RR - приемник готов
 | 10 | RNR - приемник не готов
 | 01 | REJ - отказ
HDLC - LAPD, продолжение
Рисунок 8.7 HDLC - LAPD, продолжение
HDLC - LAPD, продолжение
Рисунок 8.8 HDLC - LAPD, продолжение

Рисунок 8.9 Информационный кадр
Информация HDLC и поля управления кадра supervisory
Информация HDLC и поля управления кадра supervisory
Рисунок 8.10 Информация HDLC и поля управления кадра supervisory
Поле управления ненумерованного кадра
Рисунок 8.11 Поле управления ненумерованного кадра

X.25

X.25 является стандартом для сетей передачи данных с коммутацией пакетов.
Формат пакетов X.25 уровня 3
Рисунок 8.12 Формат пакетов X.25 уровня 3
GFI | Общий идентификатор формата = 0001 для данных
LCG | Группа логического канала = 0000 - 1111
LCN | Номер логического канала = 00000000 - 1111 1111
PTI | Идентификатор типа пакета - обозначает формат следующих полей пакета (например, нумерованный или ненумерованный и т.п.)
P(R) | Получено пакетов
M | Флаг переноса данных
P(S) | Пакет передан
INFO | Полезная нагрузка (Payload)
FCS | Контрольная сумма, CRC-16

Коммутируемые мультимегабитные сети SMDS

Этот стандарт адаптирован IEEE для реализации в городских сетях (metropolitan area networkss), где узлы могут быть рассеяны на расстояния свыше 5 километров. На рисунке приведен пример пакета SMDS (SIP).

Рисунок 8.13 SIP level
LAN | Локальная сеть
SDSU | Модуль данных SMDS
DQDB | Сдвоенная шина распределенной очереди, приемно-передающая оптическая пара, Шина A и шина B
SNI | Сетевой интерфейс пользователя
MSS | Коммутатор городского сервиса
IXC | Внутренний коммутатор

Формат кадров Frame Relay

Frame relay представляет собой систему передачи пакетов с высокой скоростью без контроля ошибок. Frame relay широко используется для доступа в Internet и подключения к WAN-сетям. На рисунке 8.14 показан формат кадров frame relay.
Формат кадров Frame relay
Рисунок 8.14 Формат кадров Frame relay
Flag
DLCI | Идентификатор соединения
C/R | Флаг команды/отклика
EA | Расширенный адрес
FECN | Прямое уведомление о насыщении
BECN | Обратное уведомление о насыщении
DE | Возможность отбрасывания
Формат ненумерованного кадра
Рисунок 8.15 Формат ненумерованного кадра
Ненумерованные кадры в общем случае используются для управления сетью. Unnumbered frames generally serve an administrative purpose. В таблице перечислены некоторые типы сообщений, передаваемых с помощью ненумерованных кадров.
1111P110 | SAB | Установить асинхронный сбалансированный режим
1111F000 | DM | Режим отключения
1100P000 | UI | Ненумерованная информация
1100P010 | DISC | Отсоединение
1100F110 | UA | Ненумерованное подтверждение
1110F001 | FRMR | Отбрасывание кадра
1111*101 | XID | Идентификатор обмена (Exchange ID)
Формат сообщений Q.931/I451
Рисунок 8.16 Формат сообщений Q.931/I451
Q.931 представляет собой стандарт сигнализации ISDN.
Формат кадра T1
Рисунок 8.17 Формат кадра T1
T1 может передавать большие объемы данных на значительные расстояния со скоростью 1.544 Мбит/с.

Формат кадра E1

Формат кадра E1
Рисунок 8.18 Формат кадра E1
E1 во многом совпадает с T1, но обеспечивает более высокую скорость (2.048 Мбит/с).

Иерархия ситем операторов

 | Северная Америка | Япония | Европа
DSO | 64 Кбит/с | 64 Кбит/с | 64 Кбит/с
DS1 | 24 голосовых канала, 1.544 Мбит/с | 24 голосовых канала, 1.544 Мбит/с | 30 голосовых канала, 2.048 Мбит/с
DS3 | 672 голосовых канала, 44.736 Мбит/с | 480 голосовых канала, 32.064 Мбит/с | 480 голосовых канала, 34.368 Мбит/с
Приведенная в документе техническая информация может быть изменена без предупреждения.
5 июня 1998 года


Xylan. The Switching Book. Reference 3: Ethernet

Справочный раздел

RJ-45
DB-15
Типы кабелей Ethernet
Типы сетей
Формат кадров версии 2
Значения поля Тип (Type Field) для кадров версии 2
Идентификаторы производителей (OUI)
Формат кадров 802.3 и 802.2
Типы SAP
Формат управляющих полей 802.2
802.2 SNAP
Кадр Ethernet
LLC

Книга о коммутаторах
Справочный раздел

Ethernet

RJ-45

В таблице приведено описание разводки контактов стандартных разъемов RJ-45 для подключения оборудования Ethernet (10BaseT) с неэкранированного помощью кабеля на основе скрученных пар.
Номера контактов RJ-45 и цвет проводов* Назначение Разъем RJ-45 Ethernet 10BaseT
Рисунок 8.19 Разъем RJ-45 Ethernet 10BaseT для подключения сетевых адаптеров (NIC), к сети Ethernet
1 | Голубой | Передача (TX+)
2 | Оранжевый | Передача (TX-)
3 | Черный | Прием (RX+)
4 | Красный | Не используется
5 | Зеленый | Не используется
6 | Желтый | Прием (RX-)
7 | Коричневый | Не используется
8 | Серо-голубой | Не используется
*) Замечание. В кабелях категории 3 - 5 используется другая цветовая маркировка проводников.
Распределение пар по цветам описано в спецификациях TIA/EIA

DB-15

Разъемы DB-15 обычно используются в кабельных системах Thick Ethernet (толсьый коаксиал) и для подключения трансиверов.
Контакт Описание Интерфейс Ethernet AUI
Рисунок 8.20 Интерфейс Ethernet AUI
1 | Управление - вход (экран)
2 | Управление - вход
3 | Передача
4 | Прием (экран)
5 | Прием
6 | Питание (возврат)
7 | Управление - выход
8 | Управление - выход (экран)
9 | Управление - вход (возврат)
10 | Передача (возврат)
11 | Передача (экран)
12 | Прием (возврат)
13 | Питание (+12 -15)
14 | Питание (экран)
15 | Управление (возврат)

Типы кабелей Ethernet

Толстый кабель Ethernet
Рисунок 8.21 Толстый кабель Ethernet
Тонкий кабель Ethernet
Рисунок 8.22 Тонкий кабель Ethernet
Типы кабелей | 10Base5 | 10Base2 | 10BaseT | 10BaseF
Описание | Толстый коаксиал (Thicknet) | Тонкий коаксиал (ThinNet) | Неэкранированные скрученные пары (UTP) | Оптический кабель (Fibernet)
Тип | RG8 | RG58 A/U | EIA/TIA CAT3/4/5 | 62.5/125мкм
Импеданс | 50 Ом | 50 Ом | 100 Ом | --
Максимальная длина сегмента | 500 M | 185 M | 185 M | 2 KM
Минимальная длина кабеля | 2.5 M | .5 M | -- | --

Типы сетей Ethernet

Тип | Описание
10Base2 | Сети на базе тонкого кабеля (Thin Ethernet) используют коаксиальный кабель диаметром 4.7 мм (3/16") с волновым сопротивлением 50 Ом. До появления спецификации 10BaseT этот вариант сетей Ethernet был самым распространенным.
10Base5 | Сети на базе толстого кабеля (Thick Ethernet) используют коаксиальный кабель диаметром 9.5 мм (3/8") с волновым сопротивлением 50 Ом. Хотя сепцификация таких кабельных систем включена в Blue Book Ethernet, они достаточно редко используются по причине дороговизны и сложности прокладки кабельных систем.
10BaseT | Сети на базе скрученных пар (Twisted-pair Ethernet) используют неэкранированные медные кабели UTP. Эта конфигурация была включена в спецификацию 802.3i в 1990 и с тех пор стала самой популярной для сетей Ethernet, поскольку кабель UTP очень дешев и прост в использовании.
10BaseF | Единственный вариант оптической кабельной системы, включенный в спецификацию 802.3. В действительности оптические кабельные системы делятся на три категории - 10BaseFB, 10BaseFP, 10BaseFL.
10BaseFB | Этот тип сетей использует оптические кабели для организации магистралей или транков. Длина транкового сегмента может достигать 2 километров.
10BaseFP | Сеть на основе оптических кабелей с топологией "звезда". Соединитель кабелей используется как пассивное устройство (регенерация сигналов не производится). В результате такие сети не требуют для организации каких-либо электронных устройств (за исключением компьютеров). Максимальная длина кабеля составляет 500 метров.
10BaseFL | Сети, использующие оптические кабели для соединения узлов с сетевым концентратором. Длина кабельного сегмента может достигать 2 километров.
100BaseVG (100VG-AnyLAN) | Спецификация сетей Ethernet 100 Мбит/с, предложенная компаниями Hewlett-Packard и AT&T Microelectronics*.
100BaseT | Стандарт сетей Ethernet 100Мбит/с. Предложен группой IEEE 802.3 и включает несколько вариантов - 100BaseT4, 100BaseTX, 100BaseFX.
*) Замечание. В настоящее время это решение уже почти не поддерживается производителями оборудования.

Рисунок 8.23 Манчестерское кодирование

Манчестерское кодирование (Manchester encoding) представляет собой схему преобразования битового потока в сигналы для передачи через среду Ethernet.

Формат кадров Ethernet V2

На рисунке показан формат кадров Ethernet версии 2. Этот формат кадров используется в общем случае в системах TCP/IP.

Формат кадров Ethernet V2
Рисунок 8.24 Формат кадров Ethernet V2

Значения поля Тип (Type Field) для кадров версии 2

В таблице приведены значения поля "тип", задающего используемый отправителем протокол сетевого уровня.
Тип | Протокол | Тип | Протокол
0600 | Xerox Networks Services (XNS) | 8046-8047 | AT&T
0800 | ARPANET Internet Protocol (IP) | 807D-8080 | Vitalink
0801 | X.75 Internet Protocol (IP) | 8088-808A | Xyplex
0802 | NBS Internet Protocol (IP) | 809B | Ethertalk
0803 | ECMA Internet Protocol (IP) | 80C0-80C3 | Digital Communications Associates (DCA)
0804 | CHAOSnet | 80D5 | IBM SNA
0805 | X.25 Level 3 | 80F2 | Retix
0806 | Address Resolution Protocol (ARP) | 80F3-80F5 | Kinetics
0BAD | Banyan VINES | 80F7 | Apollo Computer (HP)
6000-6009 | Digital Equipment Corporation | 80FF-8103 | Wellfleet Communications
7000-7002 | Ungermann-Bass | 8137-8138 | Novell
7030 | Proteon | 8008 | AT&T
7034 | Cabletron | 809F | Spider Systems
8005 | Hewlett-Packard probe protocol | 80E0 | Allen Bradley
8010 | Excelan | 80F3 | AARP (AppleTalk ARP)
8013-8016 | Silicon Graphics | 9000 | Loopback
8035 | Reverse ARP | 9001 | Bridge Communications XNS Systems Management
8038-8042 | Digital Equipment Corporation | 9002 | Bridge Communications TCP/IP Systems Management

Идентификаторы производителей (OUI)

Идентификаторы OUI используются для обозначения производителей оборудования Ethernet (платы, коммутаторы и т.п.). Идентификатор производителя занимает первые 3 байта MAC-адреса устройства Ethernet.
OUI | Компания | OUI | Компания
00-00-0E | Fujitsu Limited | 00-80-AE | Hughes Network Systems
00-00-1B | Novell, Inc. | 00-80-C2 | Комитет IEEE 802
00-00-3F | Syntrex, Inc. | 00-C0-00 | Lanoptics, Ltd.
00-00-46 | Olivetti North America | 00-C0-0D | Advanced Logic Research, Inc.
00-00-4C | NEC Corporation | 00-C0-13 | Netrix
00-00-52 | Optical Data Systems | 00-C0-1C | Interlink Communications, Ltd.
00-00-58 | Racore Computer Products, Inc. | 00-C0-1D | Grand Junction Networks, Inc.
00-00-61 | Gateway Communications | 00-C0-33 | Telebit Communications Aps
00-00-65 | Network General Corporation | 00-C0-34 | Dale Computer Corporation
00-00-6D | Cray Communications, Ltd. | 00-C0-43 | Stratacom
00-00-6E | Artisoft, Inc. | 00-C0-63 | Morning Star Technologies
00-00-6F | Madge Networks, Ltd. | 00-C0-64 | General Datacomm Ind., Inc.
00-00-74 | Ricoh Company, Ltd. | 00-C0-6D | Boca Research, Inc.
00-00-79 | Networth, Inc. | 00-C0-6F | Komatsu, Ltd.
00-00-7D | Cray Research Superservers, Inc. | 00-C0-77 | Daewoo Telecom, Ltd.
00-00-7F | Linotype-Hell AG | 00-C0-A8 | GVC Corporation
00-00-94 | Asante Technologies | 00-C0-AA | Silicon Valley Computer
00-00-98 | Crosscom Corporation | 00-C0-B0 | GCC Technologies, Inc.
00-00-99 | Memorex Telex Corporation | 00-C0-B3 | Norand Corporation
00-00-AA | Xerox Corporation | 00-C0-B6 | Meridian Data, Inc.
00-00-A7 | Network Computing Devices, Inc. | 00-C0-E2 | Calcomp, Inc.
00-00-A8 | Stratus Computer Inc. | 00-C0-E8 | Plexcom, Inc.
00-00-A9 | Network Systems Corp. | 00-C0-EC | Dauphin Technology
00-00-BC | Allen-Bradley Co., Inc. | 00-C0-ED | US Army Electronic
00-00-C0 | SMC (Western Digital) | 00-C0-EE | Kyocera Corporation
00-00-D0 | Develcon Electronics, Ltd. | 00-C0-F3 | Network Communications Corp.
00-00-E7 | Star Gate Technologies | 00-C0-F4 | Interlink System Co., Ltd.
00-00-E8 | Accton Technology Corp. | 00-C0-FB | Advanced Technology Labs
00-00-F2 | Spider Communications | 02-07-01 | Racal-Datacom
00-00-F8 | Digital Equipment Corporation | 08-00-07 | Apple Computer, Inc.
00-07-01 | Racal-Datacom | 08-00-09 | Hewlett Packard
00-20-09 | Packard Bell Electronics, Inc. | 08-00-0B | Unisys Corporation
00-20-1D | Katana Products | 08-00-1F | Sharp Corporation
00-20-24 | Pacific Communications Sciences | 08-00-28 | Texas Instruments
00-20-33 | Synapse Technologies, Inc. | 08-00-2B | Digital Equipment Corporation
00-20-35 | CPN Architectures/IBM Corp. | 08-00-39 | Spider Systems Limited
00-20-48 | Fore Systems, Inc. | 08-00-5A | IBM Corporation
00-20-DA | Xylan Corporation | 08-00-69 | Silicon Graphics, Inc.
00-80-7 | Bartel Communications Corp. | 08-00-74 | Casio Computer Co. Ltd.
00-80-8A | Summit Microsystems Corp. | 08-00-8F | Chipcom Corporation
00-80-90 | Microtek International, Inc. | AA-00-00 | Digital Equipment Corporation
00-80-A3 | Lantronix | AA-00-03 | Digital Equipment Corporation
00-80-AD | CNET Technology, Inc. | AA-00-04 | Digital Equipment Corporation

Формат кадров Ethernet 802.3 и 802.2

Это стандартный формат кадров 802.3 Ethernet, предложенный IEEE. Спецификация Ethernet 802.2 очень похожа на Ethernet 802.3, однако кадры 802.2 имеют поле LLC. На рисунке 8.25 показаны различия между кадрами 802.2 и 802.3.
Формат кадров Ethernet 802.3 и 802.2
Рисунок 8.25 Формат кадров Ethernet 802.3 и 802.2

Типы SAP

EO | Novell Netware
FO | NetBIOS
06 | TCP/IP
42 | Spanning Tree BPDU
FF | Global Sap
F4-F5 | IBM Network Management
7F | ISO 802.2
00 | Null SAP
FB, FC | Remote Program Load
04, 05, 08, 0C | SNA
AA | SNAP
80 | XNS
FE | OSI
18 | Texas Instruments
7E | X.25 Level 3
98 | Протокол преобразования адресов (ARP)
BC | Banyan VINES
FA | Ungerman-Bass

Формат управляющего поля 802.2

Этот формат предложен IEEE и содержит внутри себя LLC.

I-Frame - информационный кадр
Рисунок 8.26 I-Frame - информационный кадр
N/S | Передано (Number Sent)
P/F | Опрос/завершающий бит
N/R | Принято (Number Received)
S-Frame - кадр контроля
Рисунок 8.27 S-Frame - кадр контроля
S Bits
00 | RR, приемник готов (Receiver Ready)
01 | REJ, непригодный кадр (Reject)
10 | RNR, приемник не готов (Receiver Not Ready)
U-Frame - ненумерованный кадр
Рисунок 8.28 U-Frame - ненумерованный кадр
1111P110 | SABME
1100P010 | DISC
1100F110 | Отклик UA (UA Response)
1111F000 | Отклик DM (DM Response)
1110F001 | Непригодный кадр (Frame Reject)

802.2 SNAP. Протокол доступа к подсети (SubNetwork Access Protocol)

Кадры этого типа похожи на кадры 802.2, однако содержат 5 дополнительных байтов информации.
Формат управляющего кадра SNAP
Figure 8.29 Формат управляющего кадра SNAP
DA | Адрес распространения (Distribution Address)
SA | Адрес отправителя
LF | Поле длины
DSAP | SAP получателя
SSAP | SAP отправителя
OUI | OUI
если OUI = 00 00 00, далее следует поле типа (Ethertype)
TYPE | Начало пакета Ethernet V2

Кадр Ethernet

Раздел кадра | Подраздел | Длина подраздела | Общая длина
Преамбула | Преамбула | 7 |
 | Стартовый ограничитель кадра | 1 |
 | Общая длина преамбулы |  | 8
Заголовок | Адрес получателя | 6 |
 | Адрес отправителя | 6 |
 | Длина (802.3) | 2 |
 | или |  |
 | протокол сетевого уровня | 2 |
 | Общая длина заголовка |  | 14
Данные |  |  | 46-1500
Цепочка (Trailer) - порядок следования кадров |  |  | 4
Минимальный размер кадра Ethernet (не включая преамбулу) |  |  | 64
Максимальный размер кадра Ethernet (не включая преамбулу) |  |  | 1518
Адресация Ethernet основана на уникальности номеров устройств, представляющих собой 12-значные 16-ричные значения, в общем случае содержащие код производителя, за которым следует серийный номер данного устройства.

Управление логическим каналом (Logical Link Control - LLC) в Ethernet

Кадр данных 802.2
DSAP (Destination Service Access Point - SAP получателя) | 1
SSAP (Source Service Access Point - SAP отправителя) | 1
Управление (указывает тип запрашиваемого сервиса LLC) | 2 (макс.)
Данные | 43-1497 или 42-1496
Смещения в кадре данных SNAP
DSAP (Destination Service Access Point - SAP получателя) | 1
SSAP (Source Service Access Point - SAP отправителя) | 1
Управление (указывает тип запрашиваемого сервиса LLC) | 2 (макс.)
Код организации | 3
Тип | 2
Данные (в зависимости от поля Управление) | 38-1492 или 37-1491

Кадры Ethernet 802.2 и Ethernet SNAP содержат информацию LLC в начале пакета. Однако кадры Ethernet II и Ethernet 802.3 не содержат такой информации, размещая взамен данные. Отметим также, что сети Ethernet могут работать без организации соединений, о организацией соединений, а также с организацией и подтверждением соединений.

Приведенная в документе техническая информация может быть изменена без предупреждения.
2 июня 1998 года


Xylan. The Switching Book. Reference 4: Token ring

Справочный раздел
Типы кабелей
Топология
Формат кадров
MAC и LLC в сетях token ring

Книга о коммутаторах
Справочный раздел

Token Ring

Кабельные спецификации Token Ring

Тип | Кабель | Длина | Импеданс | Описание
Тип 1 | STP | 100 метров | 150 Ом | 2 пары 22 AWG
Тип 2 | STP | 100 метров | 150 Ом | 4 пары 22 AWG (2 паря для данных)
Тип 3 | UTP | 45 метров | 100 Ом | 2, 3 или 4 пары 22 или 24 AWG. Две скрутки на фут (30.5 см).
Тип 5 | оптика | 1 KM | - | Обычно используется для магистралей.
Тип 6 | STP | 66 метров | 150 Ом | 2 пары 26 AWG
Тип 8 | STP | -- | 150 Ом | 2 пары 26 AWG (плоский кабедь для прокладки под покрытиями)
Тип 9 | STP | 66 метров | 150 Ом | 2 пары 26 AWG

Рисунок 8.30 Разъем DB-9
Экранированные разъемы для скрученных пар
Рисунок 8.31 Экранированные разъемы для скрученных пар

Топология и передача Token Ring

Рисунок 8.32 Физическая топология

Рисунок 8.33 Логическая топология
Передача Token ring
Рисунок 8.34 Передача Token ring
Дифференциальное манчестерское кодирование для ограничителей кадров
Рисунок 8.35 Дифференциальное манчестерское кодирование для ограничителей кадров

В начале и конце разделителей кадров используется нарушение кодирования (Code violations).

Формат кадров Token Ring 802.5

Рисунок 8.36 Маркер (Token)

Рисунок 8.37 Информационный кадр
SD | Стартовый разделитель
AC | Управление доступом
FC | Управление кадром
DA | Адрес получателя
SA | Адрес отправителя, если бит 0 поля SA имеет значение 1, информация source routing - в противном случае
RIF | Поле маршрутной информации
I | Данные
FCS | Контрольная сумма - CRC-32
ED | Финишный разделитель
FS | Состояние кадра

MAC и LLC в Token Ring

В таблицах ниже приведены названия полей кадра token ring и их размеры. Для сравнения показаны различия между кадрами MAC и LLC.

Описание | Размер
Стартовый разделитель | 1 байт
Управление доступом | 1 байт
Управление кадром | 1 байт

Отметим, что если 2 первых бита поля управления кадром имеют значение 00, это означает MAC-кадр, 01 служит для обозначения кадров LLC.

Адрес получателя | 6 байт
Адрес отправителя | 6 байт
Маршрутная информация | 0 + 2 байта для управления маршрутизацией 2 байта для каждого дополнительного номера сегмента

В таблице показано информационное поле кадра token ring. Отметим, что эти поля отличаются в кадрах LLC и MAC.

LLC | Размер | MAC | Размер
DSAP | 1 байт | Длина | 2 байта
SSAP | 1 байт | Идентификатор основного вектора | 2
Control | 1 или 2 байта | MAC subvector | 0 + данные
Info | 0 + информация | MAC subvector | 0 + данные

Наконец - завершающие поля кадров.

Контрольная сумма | 4 байта
Финишный разделитель | 1 байт
Состояние кадра | 1 байт

Адресация Token ring использует 12 символов и задается, в общем случае, на аппаратном уровне. Однако многие сетевые адаптеры позволяют пользователю менять адресные установки.

Приведенная в документе техническая информация может быть изменена без предупреждения.
8 июня 1998 года


Книга о коммутаторах. Введение

Справочный раздел

Книга о коммутаторах

Введение

Computer networking has revolutionized the way information is processed. Prior to networks, information was processed on a mainframe computer and sent to dumb terminals through a variety of methods that were often proprietary. Data networks have moved the processing of information from the large mainframe to each user's desktop. Organizations originally implemented computer networks to help improve their workforce's productivity. However, as productivity improved, users began demanding more from their network applications while also expecting improved response time.

To keep up with network demand, corporations upgraded their networks infrastructure with routers that increased network performance while also improving network reliability. The network was now a key component in successful businesses, and network downtime could no longer be tolerated.

Today corporations routinely buy the fastest computers on the market and want those machines to run on the fastest safest network possible. The network switch was invented to help networks achieve these precise characteristics. This book takes a look at the evolution of the network switch, it looks at various components of network switches, and then applies network switching to some common local area network environments. Simply put, this book is a reference tool for those seeking information about network switching. In the first section of the book, we'll take a close look at the switching revolution currently taking place in the networking world. We'll begin by finding out about the evolution of networks, and then find out what pushed organizations to move from mainframe computers to standalone PCs and eventually to corporate networks. We'll also look at the place of the switch within the corporate network.

Next we examine today's network environment and how collisions and congestion can bring networks to their knees, why organizations used routers and bridges to solve these problems and also the problems associated with bridges and routers. We then discuss the role a switch plays in solving these problems.

The following section looks at high-speed network access and what that means to a network. The chapter covers high-speed technologies such as 100VG-Anylan, 100BaseT, FDDI and ATM and shows how these technologies can be integrated between switches (forming a backbone) and immediately improve network performance. Also find out how a network switch integrates these fast technologies and translates them to slower, existing technologies.

ATM is the topic of our next chapter. This section discusses why ATM technology may be needed in your business sooner than you think. It also compares ATM standards and delves into the costs of ATM. It also discusses the evolution of ATM networking from telecommunications to the data network.

Virtual LAN (VLAN) technology is one of the hottest areas of networking, but not many people understand what a VLAN really is. This chapter gives a simple tutorial of VLAN technology and explains not only how it works, but also explains the different types of VLANs and where they should be integrated into a network.

Next we'll take a look at some real world networks and some of the common problems associated with those traditional network layouts. Then we'll integrate switches into those problem networks and examine the effect.

Xylan is a leader in the network switching field. The following section tells a little bit about Xylan and the company's products.

The reference section is a nuts-and-bolts look at various networking technologies and standards commonly associated with switches. It examines the various topologies associated with networks through the eyes of the OSI Networking Reference Model. In addition, brief discussions are given of the OSI Reference Model as well as the IEEE, ITU and their respective standards.

Finally we'll give a pointer as to where to go for further information on many of the topics discussed in the book. We've added a glossary so that if the terminology or acronyms confuse you, you'll have somewhere to look them up.

While reading The Switching Book, think of your network and consider how a switch would affect it. If you have any comments or suggestions for future revisions of the book, let us know. We're happy to listen to your feedback. We'll even try to integrate it into future versions of The Switching Book.

8 июня 1998 года