Справочник по JavaScript

A B C D E F G H I J K L M N O P Q R S T U V X Y

Справочник по "Javascript"

  • ВВЕДЕНИЕ
      • Как пользоваться этой книгой
      • Обработчики событий
      • Функции
      • Иерархия объектов
      • Java
      • JavaScript
      • Литералы
      • Целые числа
      • Числа с плавающей точкой
      • Логические литералы
      • Строки
      • Методы
      • Объекты
      • Операторы
      • Свойства
      • Сценарии
      • Замена типов данных
      • Замена тип
    • ОПИСАНИЕ ОБЪЕКТОВ, МЕТОДОВ,
      СВОЙСТВ И ОБРАБОТЧИКОВ СОБЫТИЙ
    Объекты => | Методы => |  | Свойства => |  | Обработчики событий
anchors array button checkbox Date document elements array form frame hidden history links_array location Math navigator password radio reset select string submit text textarea window | abs acos alert anchor asin atan back big blink blur bold ceil charAt clear clearTimeout click close confirm escape eval exp fixed floor focus fontcolor fontsize forward getDate getDay getHours getMinutes getMonth getSeconds getTime getTimezoneOffset go | indexOf isNaN italics lastlndexOf link log max min open parse parseFloat parseInt pow prompt random round select setDate setHours setMinutes setMonth setSeconds setTime setTimeout setYear sqrt small sub submit substring sup tan toGMTString toLocaleString toLowerCase write writeln | action alinkColor anchors appCodeName appName appVersion bgColor checked cookie cos defaultChecked defaultSelected defaultStatus defaultValue E elements encoding fgColor forms frames hash host hostname href Index lastModified length linkColor links LN2 LN10 location LOG2E LOG10E | method name options parent pathname PI port protocol referrer search selected selectedIndex self SQRT1_2 SQRT2 status target text title top value vlinkColor window | onBlur onChange onClick onFocus onLoad onMouseOver onSelect onSubmit onUnload

    ВВЕДЕНИЕ

        JavaScript - это язык программирования, используемый в составе
    страниц   HTML  для  увеличения  функциональности  и  возможностей
    взаимодействия с пользователями. Он был разработан фирмой Netscape
    на базе языка Sun's Java корпорации Sun. На первый взгляд кажется,
    что  найти  информацию  по  JavaScript несложно. Сначала создается
    впечатление,  что  ее  можно увидеть везде: на сервере Netscape, в
    виде  электронных  руководств и примеров, во многих других местах.
    Тем  не менее разыскать информацию об объектах, операторах, цветах
    и  всем прочем в одном источнике, чтобы она была всегда под рукой,
    трудно. Настоящая книга и должна восполнить этот пробел.

          JavaScript и Java Прежде всего надо понять, что JavaScript и
    Java  -  это  совер-шенно  разные  вещи.  Java  представляет собой
    объектно-ориентированный   язык   программирования,  разработанный
    фирмой  Sun  Microsystems  и требующий для своего функционирования
    компилятора   и   вспомогательных  файлов.  Этот  язык  хорош  для
    программистов  с опытом работы на языках типа С++. Разрабатываемые
    с  помощью  Java  Development  Kit  программы  могут  работать как
    законченные   приложения  либо  как  встроенные  в  страницу  HTML
    апплеты.  И хотя апплеты встроены в страницы HTML, они хранятся на
    клиентской машине как отдельные файлы. JavaScript был разработан в
    Netscape. Он близок к языку Java в том, что оба содержат некоторый
    простой  набор  команд, сходных в своей реализации. По структуре и
    синтаксису  JavaScript близок к Java, но JavaScript реализует свою
    функциональность  только  в  составе  страницы  HTML. Вы не можете
    разрабатывать   апплеты  или  обособленные  приложения  с  помощью
    JavaScript - они могут располагаться только внутри страницы HTML и
    функционируют,  будучи  загруженными  в  подходящий  броузер  типа
    Netscape Navigator версии 2.0 или более поздней.

    Как пользоваться этой книгой

          Для   упрощения  поиска  информации  в  этой  книге  принято
    несколько соглашений.
          Описания  элементов  языка имеют одинаковую структуру. После
    названия элемента и указания его типа (объект, Свойство или метод)
    следует  краткое  описание  способа  применения.  Далее приводится
    синтаксис  команды.  Некоторые  элементы,  особенно  относящиеся к
    формам,  могут  быть  реализованы  несколькими способами. Основные
    варианты  перечисляются  как  часть  синтаксиса. Если предлагается
    такой синтаксис:

    document.formName

          то  к форме, названной user Info, можно обращаться следующим
    образом:

    document.userInfo

          Методы,  помеченные  звездочкой,  являются  встроенными и не
    требуют  вызова  объекта для своей работы. Далее следует подробное
    описание   способа  использования  и  примеры  программ.  В  конце
    приводятся  ссылки  на имеющиеся в книге описания других элементов
    языка.
          Когда  встречается аббревиатура URL, она указывает на полный
    универсальный  адрес  ресурса,  включающий  в себя протокол, адрес
    сервера  и, если необходимо, путь к файлу и имя точки назначения в
    файле.

    Обработчики событий

           Обработчики   событий   являются   особенной  частью  языка
    JavaScript и придают ему основную мощь. Они позволяют программисту
    отслеживать  действия  пользователя  по отношению к странице HTML,
    такие  как  щелчок  мышью  на кнопке формы или помещение указателя
    мыши над гиперссылкой.
          Обработчики  событий  встраиваются вбеги теги HTML, обычно в
    составе форм, но иногда включаются в описание ссылок.
          Практически все, что пользователь может делать со страницей,
    можно отслеживать с помощью обработчиков событий, от движения мыши
    до  выхода  из страницы. Например, следующий фрагмент кода выводит
    строку  «Справочник по JavaScript» в строке состояния, когда указатель
    мыши оказывается над гиперссылкой.
    Netscape's Home Page

    Функции

           Функция  представляет  собой  созданный  программистом  или
    встроенный  в  язык  метод, выполняющий какую-то задачу. Она может
    также  вернуть  значение,  если  поместить  в нее оператор return.
    Функции  универсальны  и не требуют привязки к какому-либо объекту
    для своей работы. Методы же всегда связаны с объектом.
          Как правило, лучше всего помещать определения функций внутри
    тега  <HEAD>.  Такой  подход  гарантирует, что любая функция
    будет  загружена  в  память  и «готова к употреблению» прежде, чем
    пользователь сможет произвести какие-либо действия, вызывающие эту
    функцию.

    Иерархия объектов

           Среди  объектов  существуют  определенные  взаимоотношения.
    Например,  объекты Navigator имеют структуру, отражающую структуру
    страницы   HTML.   Такие   взаимоотношения   называются  иерархией
    экземпляров,  так  как  эта иерархия работает только с конкретными
    экземплярами объектов, а не с абстрактными классами.
          Объект  window  является  родительским  по отношению ко всем
    остальным  объектам  Navigator.  Прямыми  потомками объекта window
    являются  объекты  location,  history  и  document. Объекты forms,
    links  и  anchors  являются дочерними для объекта document. Каждый
    объект  является  потомком  объекта более высокого уровня. Форма с
    названием  orderForm  является  объектом и в то же время свойством
    объекта   document.   Таким   образом,   для  вызова  такой  формы
    используется выражение document. orderForm.
          Иерархию  объектов  языка  JavaScript  можно  сопоставить  с
    иерархией объектов в реальном мире. Колеса, руль и педали -это все
    объекты,  принадлежащие  велосипеду.  Велосипед представляет собой
    объект, принадлежащий к средствам наземного транспорта, которые, в
    свою   очередь,   принадлежат  к  более  общей  категории  средств
    передвижения.
          В  терминах объектов JavaScript эти взаимоотношения могли бы
    быть выражены следующим образом:

          travelMode.groundTransport.bicycle.handleBars

          Наиболее  общий  объект  высшего  уровня  находится  слева в
    выражении,  и  слева  направо  происходит  переход к более частным
    объектам,  являющимся  при  этом  наследниками  высших  в иерархии
    объектов.

    Java

          По  выражению  Sun  Microsystems,  «Java  представляет собой
    простую, удобную, объектно-ориентированную, платформо-неэависимую,
    многопоточную,  динамичную,  многоцелевую среду программирования».
    Все  эти  громкие  слова подразумевают, что Java идеально подходит
    для  создания  апплетов  и  приложений  для  Internet,  для  сетей
    intranet и для других сложных распределенных сетей.
          Будучи  однажды скомпилированным, исходный код на языке Java
    может  исполняться  на  компьютере с любой операционной системой -
    Windows 95, Solaris, Macintosh или любой другой, лишь бы на машине
    имелся   интерпретатор  Java.  Программирование  на  Java  требует
    наличия  Java  Development  Kit  с  компилятором и набором базовых
    классов,   созданных  фирмой  Sun  или  третьей  фирмой,  например
    Symantec.

    JavaScript

          JavaScript  является  интерпретируемым языком для документов
    HTML,   разработанным  фирмой  Netscape  в  сотрудничестве  с  Sun
    Microsystems.   Сценарии   (scripts)   выполняются   в  результате
    наступления    каких-либо   событий,   инициированных   действиями
    пользователя.  Создание  Web-документов,  включающих  программы на
    JavaScript,  требует  наличия  текстового  редактора и подходящего
    броузера.   Броузер  Netscape  Gold  включает  в  себя  встроенный
    редактор, так что нужда во внешнем редакторе отпадает.
         Несмотря на отсутствие прямой связи с языком Java, JavaScript
    может  обращаться  к  внешним  свойствам  и методам Java-апплетов,
    встроенных  в  страницу HTML. Разница сводится к тому, что апплеты
    существуют вне броузера, в то время как программы JavaScript могут
    работать только внутри броузера.

    Литералы

           Литералом  называется  значение,  которое  можно  присвоить
    переменной.  Литералы  не  могут  измениться.  Примерами литералов
    являются 1,3.1415927, «Bob» и true.
          Некоторым  типам  литералов  в JavaScript соответствуют типы
    переменных.

    Целые числа

          Целыми  называются  числа  типа 1,16 и 25896. Они могут быть
    выражены  в  десятичном  (по  основанию 10), шестнадцатиричном (по
    основанию 16) или восьмеричном (по основанию 8) представлении.
          Шестнадцатиричные  числа  включают  цифры 0-9 и буквы a-f, в
    JavaScript  они  записываются  с  комбинацией символов Ох (ноль-х)
    перед  числом.  Восьмеричные  числа  включают только цифры 0-7 и в
    JavaScript  записываются  с  ведущего  нуля.  Например, десятичное
    число  23  представляется  в  шестнадцатиричном  виде как 0x17 и в
    восьмеричном как 027.

    Числа с плавающей точкой

          Числа  с  плавающей  точкой представляют собой дробные части
    целых  чисел и должны включать в себя по крайней мере одну цифру и
    десятичную точку либо символ экспоненты («е» или «Е»). В следующих
    примерах  приведены различные варианты представления одного и того
    же числа:

    3.1415927
    3145927е-7
    .3141527Е1

    Логические литералы

          Логические литералы имеют только два значения, true (истина)
    или  false  (ложь).  В  некоторых  реализациях  языка JavaScript О
    (false)   и  1  (true)  не  могут  быть  использованы  в  качестве
    логических  значений. Текущие версии Netscape Navigator и Netscape
    Navigator Gold обе поддерживают 0 и 1 как логические false и true.

    Строки

         Строки определяются как любое количество символов, окруженных
    одинарными  или  двойными  кавычками. Использование обратной косой
    черты «\» позволяет вставлять в строку специальные символы.

         document.write("\Вам следует принять ванну\", - сказал доктор
         и наморщил нос.")

    выводит

         "Вам следует принять ванну", — сказал доктор и наморщил нос.

    Методы

         Метод представляет собой функцию, ассоциированную с объектом.
    Например,userName.toUpperCase()  возвращает строку, содержащуюся в
    переменной userName, преобразованную к верхнему регистру.

    Объекты

         Объектом называется структура, имеющая свойства (properties),
    представляющие  собой  переменные  JavaScript  или другие объекты.
    Функции,  ассоциированные с объектом, называются методами объекта.
    Обращение   к   свойствам   и   методам   осуществляется   просто:
    objectName.propertyName objectName.methodName

         Все имена чувствительны к регистру.

          Если  объект  с  названием  house  имеет  свойства bedrooms,
    bathrooms,   floors  и  squareFeet,  вы  можете  обращаться  к  их
    значениям:

         house.bedrooms
         house.bathrooms
         house.floors
         house.squareFeet

         Другим способом представления объектов является запись их как
    массивов:

            house["bedrooms"]
            house["bathrooms"]
            house["floors"]
            house["squareFeet"]

          Этот  же  объект  может  быть представлен в JavaScript и как
    обычный массив:

         house[0]
         house[1]
         house[2]
         house[3]

           Такой   тип  взаимоотношений  между  индексами  и  строками
    называется ассоциативным массивом.
          Создание  нового объекта требует вызова функции-конструктора
    объекта.   Например,  следующая  функция  должна  создавать  новый
    экземпляр объекта house:

         function House(bedrooms, bathrooms, floors, squareFeet)
         {
         this.bedrooms - bedrooms;
         this.bathrooms   -   bathrooms;
         }
         this.floors  -  floors;
         this.squareFeet = squareFeet
         }

          Теперь,  когда  объект  определен, его экземпляр создается с
    помощью оператора new.

         5OOSouth5th = new House (2, 1, 1, 1700)

          В  определение  объекта  могут быть включены другие объекты.
    Например,  объект  с  названием  owner  имеет  свойства name, age,
    mortgageLength.

         function Owner(name, age, mortgageLength)
         {
         this.name = name;
         this.age = age;
         this.mortgageLength = mortgageLength
         }

          Добавление дополнительного аргумента и строки кода в функцию
    Hous'e добавляет объект owner к объекту house:

           function  House(bedrooms,  bathrooms,  floors,  squareFeet,
    owner) {

           this.bedrooms   =  bedrooms;
           this.bathrooms  =  bathrooms;
           this.floors  =  floors;
           this.squareFeet = squareFeet;
           this.owner = owner
           }

          Новый  экземпляр  объекта  owner  (Glenn Woodson, 38 лет, со
    сроком  закладной  в 20 лет), представленный переменной G_Woodson,
    включен в объект house:

          G_Woodson = new Owner("Glenn Woodson",38,20);
          5OOSouth5th = new House(2, 1, 1, 1700, G__Woodson)

         Свойства объекта G_Woodson включены в объект 5OOSouth5th:

         5OOSouth5th.bedrooms
         5OOSouth5th.bathrooms
         5OOSouth5th.floors
         5OOSouth5th.squareFeet
         5OOSouthSth.G_Woodson.name
         5OOSouth5th.G_Woodson.age
         5OOSouth5th.G_Woodson.mortgageLength

    Операторы

          Оператор  производит  действия  над  одним  или  несколькими
    операндами  или  переменными.  Операторы  делятся  на две основные
    группы:  унарные  и  бинарные.  Бинарные  операторы  требуют  двух
    операндов, а унарные имеют дело только с одним операндом.

          Например, оператор сложения является бинарным оператором:

          sum = 1 + 5

          Унарные операторы часто используются для обновления значений
    счетчиков.  Следующий  пример  увеличивает  переменную счетчика на
    единицу:

          counter++

    Свойства

          Свойства  используются для описания объекта или его текущего
    состояния.  Свойство определяется путем присваивания ему значения.
    Значение может быть присвоено броузером, программой или действиями
    пользователя.
          Несколько  свойств в JavaScript содержат константы-значения,
    которые  никогда не меняются. Такими являются значения числа я или
    основания  натуральных  логарифмов  (е). Другие элементы, например
    элементы  формы,  различаются  от страницы к странице, но не могут
    быть изменены в пределах одной страницы.

    Сценарии

          Одна  или  несколько команд JavaScript могут быть помещены в
    тег  <SCRIPT>.  Сосуществование  нескольких  вспомогательных
    языков  программирования  для  расширения  возможностей языка HTML
    сделало  необходимым сообщать броузеру, какой же язык используется
    в  данном  конкретном  случае.  Для  JavaScript  синтаксис  таков:
    <SCRIPT  LANGUAGE="JavaScript"> <!--
 ...Строки кода...
//  --></SCRIPT>

         Использование атрибута LANGUAGE в броузерах Netscape пока что
    не  обязательно,  но  это  положение  может измениться, если будет
    реализована  поддержка  других  языков,  например  VBScript  фирмы
    Microsoft.
        Обратите  внимание  на  использование  тегов  комментария HTML
    <!--  и  -->.  Если  страница,  содержащая  сценарий,  будет
    загружена  в  броузер,  не  поддерживающий языки сценариев, строки
    программы  будут  выведены  на  экран  как  обычный текст, засоряя
    экран.
         Если же использовать тег комментария, такой броузер пропустит
    текст  программы,  воспринимая  его как комментарий. Двойная косая
    черта   перед   закрывающим   текст   JavaScript-npoграммы   тегом
    комментария  гарантирует, что тег не будет воспринят броузером как
    оператор JavaScript.

    Замена типов данных

          Тип  переменной  зависит от того, какой тип информации в ней
    хранится  (см.  раздел  «Литералы»). JavaScript не является жестко
    типизированным  языком,  то  есть  нет необходимости объявлять тип
    переменной  в  момент  ее  создания.  Тип переменной присваивается
    переменной  автоматически  в зависимости от литерала, присвоенного
    переменной. Взгляните на следующие выражения:

           //пример1
           var oneString  =  "1"
           var oneInt  =  1
           var oneConcatenate = oneString + oneInt //     В результате
           //получается "11"

    Замена типов

           var  oneAddition  =  oneInt  +  oneString  //  В результате
           //получается 2

          В  первой операции сложения первый операнд является строкой.
    JavaScript   предполагает,   что  производится  операция  с  двумя
    строками.   Когда   JavaScript  обнаруживает  в  качестве  второго
    операнда  целое число, он в соответствии со своими представлениями
    преобразует переменную в строку.
          Так как JavaScript не поддерживает никаких методов и свойств
    для  определения  типа  текущего  значения переменной, очень важно
    внимательно  отслеживать  типы переменных во избежание неожиданных
    результатов.

    ОПИСАНИЕ ОБЪЕКТОВ, МЕТОДОВ,
СВОЙСТВ И ОБРАБОТЧИКОВ СОБЫТИЙ

           Синтаксис и команды JavaScript можно разделить на несколько
    категорий в зависимости от их назначения и использования.
           Объекты  представляют  собой  блоки,  из  которых  строится
    JavaScript.  Они  применяются для возвращения значений и изменения
    состояния  форм,  страниц,  броузера  и определенных программистом
    переменных.  Объекты  можно сопоставить с существительными. Кошка,
    автомобиль,  дом,  компьютер, форма - все это существительные, они
    могут быть представлены как объекты (см. раздел «Объекты»).
          Мы  используем  свойства  для  того, чтобы различать объекты
    одного  класса  -  например,  всех  объектов  типа кошка. Свойства
    сравнимы  с  прилагательными и ссылаются на уникальные для каждого
    экземпляра объекта особенности. В случае кошки это может быть вес,
    цвет,  местоположение,  текущее  занятие,  количество блох и т. п.
    (см. раздел «Свойства»).
          Методы  служат  для  передачи сообщений объекту и иногда для
    изменения  состояния  его свойств. Например, один метод может быть
    использован  для изменения текущего занятия кошки от еды ко сну, а
    другой - для уменьшения количества блох (см. раздел «Методы»).

    Дальше   следует   список   строительных  блоков  языка JavaScript:

    abs
    (Метод)
         Возвращает абсолютное значение своего аргумента.

    Math.abs(argument)

         Применение
         Следующие примеры возвращают соответственно 10 и 12.5.

    document.writeln(Math.abs(-10));

         John.age.value = 12.5

    document.writeln(Math.abs(John.age.value))

         Связанные элементы
         Метод объекта Math.

    acos
    (Метод)

        Возвращает  арккосинус  своего  аргумента(от  0 до ПИ радиан).
    Math.acos(argument)

         Применение

          Аргумент  должен  быть числом в диапазоне между -1 и 1. Если
    значение выходит за пределы этого диапазона, возвращается 0.

         Связанные элементы
         Метод объекта Math.
         См. методы asin, atan, cos, sin и tan.

    action
    (Свойство)

         Отображение атрибута ACTION тега HTML <FORM>.

         document.formName.action
         document.forms[index].action

        Применение

           Свойство   action   возвращает  строку,  состоящую  из  URL
    назначения  для данных, введенных в форму. Это значение может быть
    установлено   или   изменено  как  до,  так  и  после  загрузки  и
    форматирования документа.
          В  следующем  примере  свойство  action для формы, названной
    outlineForm, устанавливает значение URL равным значению переменной
    outlineURL.

        outlineURL  = "http://www.wossamottau.edu/cgi-bin/outline.cgi"
        outlineForm.action-outlineURL

         Связанные элементы
         Свойство объекта form.
         См, свойства encoding, method и target.

    alert
    (Метод)

         Выводит  на  экран диалоговое окно JavaScript Alert с кнопкой
         ОК и определенным программистом сообщением.

    [window.]alert(AlertMessage)

         Применение

        Прежде чем пользователь сможет продолжить работу со страницей,
    он должен нажать кнопку ОК диалогового окна JavaScript Alert.

         Связанные элементы
         Метод объекта window.
         См. методы confirm и prompt.

    alinkColor
    (Свойство)

          Цвет гиперссылки после нажатия на ней левой кнопкой мыши, но
    до отпускания кнопки.

         document.alinkColor

         Применение

          Подобно  остальным  цветам в JavaScript, свойство alinkColor
    записывается  как  шестнадцатеричный  триплет  RGB  или  строковый
    литерал.  Это  свойство  не  может  быть  изменено  после загрузки
    документа   HTML.  Оба  следующих  примера  устанавливают  цвет  в
    бледно-голубой.

         document.alinkColor="aliceblue" document.alinkColor="FOF8FF"

         Связанные элементы
         Свойство объекта document.
         См.  свойства  bgColor,  fgColor,  linkColor  и  vlinkColor.

    anchors array
    (Объект)

         Массив с информацией о якорях в документе.

         [windowName.]document.anchors[index]

         Применение

          Объект  anchors  array (только для чтения) устанавливается в
    тегах HTML <A NAME>.

         <А [HREF=URL] NAME="anchor name" [TARGET="windowName"]>
    текст якоря

         Включение в тег значения для атрибута HREF делает якорь также
    и  гиперссылкой  и добавляет ее к массиву links. Новые якоря можно
    определить в JavaScript с помощью метода anchor.
          Для  определения  количества  элементов  массива  anchors  в
    документе используйте свойство length.

    document.anchors.length

          Выражение  document.anchor[index] возвращает null. Например,
    document.anchor[0]  возвращает null, несмотря на то что существует
    якорь,   созданный  с  помощью  тега  <A  NAME="Elef">Все  о
    слонах</А>.

         Связанные элементы
         Свойство объекта document. См. объект link и метод anchor.

    anchor
    (Метод)

         Выводит строку на экран и делает ее якорем.

         textString.anchor(anchorName)

         Применение

        Будучи  примененным вместе с методами write или writeln, метод
    anchor  создает  в  текущем  документе якорь, где textString - это
    строка,  которую  пользователь видит на экране, a anchorName имеет
    значение атрибута NAME тега HTML<ANCHOR>.

        anchorString = "Louie's Place";
        document.writeln(anchorString.anchor("louies_place"));

         Связанные элементы
         Метод объекта string. См. метод link.

    anchors
    (Свойство)

          Массив всех якорей в текущем документе. Подробнее в описании
    объекта anchor.

         document.anchors[index]

         Применение

          Если  массив  anchor в документе содержит 5 элементов, то он
    начинается      с      document.anchors[0]     и     заканчивается
    document.anchors[4].

         Связанные элементы
         Свойство объекта document.
         См. объект anchor.
         См. свойства length и links.

    appCodeName
    (Свойство)

          Возвращает  строку  (только  для  чтения)  с  кодовым именем
    броузера.

          navigator.appCodeName

          Для  вывода на экран кодового имени текущего броузера служит
    следующая строка:

         document.write("Кодовое название вашего броузера:
                                      " + navigator.appCodeName + ".")
         Это выражение вернет:

         Связанные элементы
         Свойство объекта navigator.
         См. свойства appName, appVersion и userAgent.

    appName
    (Свойство)

         Возвращает строку (только для чтения) с именем броузера.

         navigator.appName

         Применение

         Для вывода на экран имени приложения текущего броузера служит
    следующая строка:

         document.write("Название вашего броузера:
                                          " + navigator.appName + ".")

         Это выражение вернет:

         Связанные элементы
         Свойство объекта navigator.
         См. свойства appCodeName, appVersion и userAgent.

    appVersion
    (Свойство)

         Возвращает строку с информацией о версии броузера.

         navigator.appVersion

         Применение

           Свойство   appVersion   используется  для  проверки  версии
    используемого  на  клиентском  компьютере броузера. Оно возвращает
    значение  в  формате  номер_версии (платформа; страна). Для версии
    Netscape 2.0 под Windows 95:

           document.write("Версия вашего броузера:"
                                         + navigator.appVersion + ".")

    возвращает:

        Возвращенное  значение  говорит  о  том,  что используется "*"
    версия"*", работающая под "*". Код страны "U" указывает версию для
    США, в то время как код "I" возвращается международной версией.

         Связанные элементы
         Свойство объекта navigator.
         См.    свойства    appName,   appCodeName   и   userAgent.

    asin
    (Метод)

         Возвращает арксинус своего аргумента.

         Math.asin(argument)

         Применение

          При  передаче  методу  asin  числа в диапазоне от -1 до 1 он
    возвращает  арксинус  аргумента  (от  -пи/2  до пи/2 радиан). Если
    передаваемый  аргумент  выходит  за  пределы указанного диапазона,
    возвращается 0.

         Связанные элементы
         Метод объекта Math.
         См. методы acos, atan, cos, sin и tan.

    atan
    (Метод)

         Возвращает арктангенс своего аргумента.

         Math.atan(argument)

         Применение

          Метод  atan  возвращает  число  между  -пи/2  и пи/2 радиан.
    Аргументом  является число в диапазоне от -1 до 1, равное тангенсу
    возвращаемого значения.

         Связанные элементы
         Метод объекта Math.
         См. методы acos, asin, cos, sin и tan.

    back
    (Метод)

          Вызывает переход к предыдущему URL из списка просмотренных в
    текущей сессии работы с броузером документов.

         history.back()

         Применение

          Использование  метода  back  идентично  применению выражения
    history,go(-1).

         Связанные элементы
         Метод объекта history. См. методы forward и go.

    bgColor
    (Свойство)

         Фоновый цвет документа.

         document.bgColor

         Применение

           Использование   свойства   bgColor   имеет   приоритет  над
    соответствующей настройкой броузера. Его значение записывается как
    шестнадцатиричный  триплет  RGB  или  строковый  литерал. Значение
    свойства  может  быть  изменено  в  любой момент. Следующий пример
    позволяет пользователям устанавливать свой собственный цвет фона с
    помощью переключателей.

           function   newColor(colorString)
           {
    document.bgColor = colorString
           }
    <FORM  NAME="colors">
    <INPUT TYPE="radio" NАМЕ="соlоr" VALUE="F0F8FF" onClick="newColor(this.value)">
    AliceBlue
    <INPUT TYPE="radio" NAME="color" VALUE="FF4500" onClick="newColor(this.value)">
    0chre
    <INPUT  TYPE="radio" NAME="color" VALUE="FFEFD5" onClick="newColor(this.value)">
    Papaya Whip</FORM>

    AliceBlue0chrePapaya WhipWhite

         Связанные элементы
         Свойство объекта document.
         См. свойства alinkColor, fgColor, linkColor и vlinkColor.

    big
     (Метод)

         Форматирует строковый объект более крупным шрифтом.

         stringName.big()

         Применение

          По своей функциональности использование метода big идентично
    изменению   шрифта   выводимого   текста   с   помощью  тега  HTML
    <BIG>.  Оба  следующих  примера  приводят к одному и тому же
    результату:  выводу  сообщения  «Добро  пожаловать на мою домашнюю
    страницу» крупным шрифтом:

    var  welcomeMessage = "Добро пожаловать на мою домашнюю страницу."
    document.write(welcomeMessage.big())

         Связанные элементы
         Метод объекта string.
         См. методы fontsize и small.

    blink
    (Метод)

         Форматирует строковый объект в виде мигающей строки.

         stringname.blink()

         Применение

           Использование   метода   blink   идентично  изменению  вида
    выводимого текста с помощью тега HTML <BLINK>. Оба следующих
    примера  приводят  к  одному и тому же результату: выводу мигающей
    строки «Обратите внимание»:

         var attentionMessage = "Обратите внимание"
         document.writeln(attentionMessage.blink())

         <BLINK>Обратите внимание</BLINK>

         Связанные элементы
         Метод объекта string.
         См. методы bold, italics и strike.

    blur
    (Метод)

         Удаляет фокус из указанного элемента формы.

         document.formName.elementName.blur()
         document.forms[index].elements[index].blur()

         Применение

           Например,   следующая  строка  удаляет  фокус  из  элемента
    feedback:

         feedback.blur()

         в предположении, что элемент feedback определен так:
         <input type="text name="feedback">

         Связанные элементы
         Метод объектов password, select, text, и textarea.
         См. методы focus и select.

    bold
    (Метод)

        Форматирует строковый объект жирным шрифтом.

        stringName.bold()

        Применение

        Использование  метода  bold идентично изменению стиля шрифта с
    помощью тега HTML <B>.

        Связанные элементы
        Метод объекта string.
        См. методы blink, italics и strike.

    button
    (Объект)

        Кнопка в форме.

        formName.buttonName
        forms[index].elements[index]

       Применение

        Кнопки  должны быть определены внутри тега <FORM> и могут быть
    использованы для выполнения каких-либо действий.

        <INPUT TYPE="button" NAME="buttonName"
        VALUE="textOnButton"[onClick="eventHandler"]>

        Для   лучшей   читаемости   кода   программы  и  во  избежание
    неоднозначности  при  обращении  к  элементу  формы  рекомендуется
    использовать  имя  элемента  вместе с именем формы. При назначении
    кнопке   обработчика   события   onClick   эта  кнопка  становится
    дополнительным  средством  для  инициализации событий, отличных от
    submit  и  reset.  Щелчок  на  следующей  кнопке  вызывает функцию
    validateForm.

        <INPUT TYPE="button" NAME="validate"
        VALUE="Check for Accuracy" onClick="validateForm(this.form)">

        Связанные элементы
        Свойство объекта form.
        См. объекты reset и submit.
        См свойства name и value.
        См. метод click.
        См. обработчик события onClick

    ceil
    (Метод)

        Возвращает   ближайшее   целое   число,   большее  или  равное
    аргументу.

        Math.ceil(argument)

        Применение

        Метод  ceil  возвращает  наименьшее  целое  число, большее или
    равное целому или дробному аргументу. Например:
    Math.ceil(l.0l) возвращает 2.

        Связанные элементы
        Метод объекта Math. См. метод floor.

    charAt
    (Метод)

        Возвращает символ из строки.

        stringName.charAt(index)

        Применение

        Этот  метод  принимает  целое  число  в  качестве  аргумента и
    возвращает  символ,  находящийся на этой позиции в строке. Позиция
    первого символа равна 0, а последнего - длине строки минус 1.

        var userName = "Bobba Louie"
    document.write(userName.charAt(4))

        возвращает «».

        Связанные элементы
        Метод объекта string.
        См. методы indexOf и lastlndexOf.

    checkbox
    (Объект)

        Элемент  формы, который пользователь устанавливает в состояние
    on или off посредством щелчка левой кнопкой мыши.

    formName.checkboxName

    forms[index].elements[index]

        Флажок  может  иметь  только  одно  из двух значений: true или
    false.  Если  флажок  не  установлен, как показано на рисунке, его
    значение равно true, иначе - false

        Применение

        Объект checkbox определяется в теге <FORM>.

    <INPUT TYPE="checkbox" NAME="checkboxName" VALUE="checkboxValue"
    [CHECKED] [onClick="eventHandler"]>textToDisplay

        Свойства   и   методы   флажков  имеют  множество  применений.
    Используйте   свойство   checked  объекта  checkbox  для  проверки
    текущего состояния флажка: установлен (true) или нет (false). Если
    атрибут  CHECKED  был  использован  в определении флажка, свойство
    defaultChecked также возвращает true.

        Связанные элементы
        Свойство объекта form.
        См. объект radio.
        См. свойства checked, defaultChecked, name и value.
        См. методы click.
        См. обработчик события onClick.

    checked
    (Свойство)

        Возвращает   логическое   значение,   представляющее   текущее
    состояние отдельного флажка или переключателя.

        formName.checkboxName.checked
        formName.radioButtonName[index].checked
        forms[index].elements[index].checked

        Применение

        Свойство  checked  возвращает  логическое  значение  (true или
    false),   показывая,   установлен  ли  флажок  или  переключатель.
    Значение    свойства   изменяется   немедленно   после   изменения
    пользователем  состояния  элемента.  Будучи  использовано  в цикле
    for...in, свойство может помочь определить состояние кнопок:

        function whichOneChecked() {
        var checkedValue = ""
        for (var i in document.formName.radioName) {
                 if (document.formName.radioName[i].checked==true)
                 checkedValue=document.formName.radioName[i].value
            }
        }

        Связанные элементы
        Свойство объектов checkbox и radio.
        См.   свойство defaultChecked.

    clear
    (Метод)

        Очищает окно броузера.

        document.clear()

        Применение

        Метод  clear  уничтожает  содержимое  окна, вне зависимости от
    того, как оно было заполнено.

        Связанные элементы
        Метод объекта document.
        См. методы close, open, write и writeln.

    clearTimeout
    (Метод)

        Сбрасывает таймер.

        [windowName.]clearTimeout(argument)
        parent.[frameName.]clearTimeout(argument)

        Применение

        Метод  clearTimeout  отключает задержку таймера, установленную
    до  этого  с  помощью  метода setTimeout, Уникальный идентификатор
    таймера,  полученный  при  его  установке,  должен быть указан для
    сброса задержки:

        clearTimeout(waitTime)

        Связанные элементы
        Метод объектов frame и window.
        См. метод setTimeout.

    click
    (Метод)

        Эмулирует щелчок на объекте левой кнопкой мыши.

        formName.elementName.click()
        forms[index].elements[index].click()
        --------------------------------------------------------------
        Метод click и его воздействие на элементы формы
        --------------------------------------------------------------
        Элемент формы               Результат
        --------------------------------------------------------------
        button, reset и submit      Аналогичен щелчку по кнопке
        --------------------------------------------------------------
        radio                       Выбор переключателя
        --------------------------------------------------------------
        checkbox                    Устанавливает флажок и присваивает
                                    ему значение on
        --------------------------------------------------------------
        Применение

        Эффект щелчка зависит от типа элемента формы.

        Связанные элементы
        Метод объектов button, checkbox, radio, reset и submit.

    close
    (Метод)

        Для   объекта   document  закрывает  текущий  поток  вывода  и
    показывает содержимое документа на экране.
        Для объекта window закрывает текущее окно.

        document.close()
        window.close()
        [windowName.]close()

        Применение

        Для    документов    метод   close   прекращает   динамическое
    формирование  документа,  выводит  содержимое документа на экран и
    сообщение «Document:Done» в строке состояния,
        Для  объектов  window  подразумевается  текущее  окно  window.
    Например, каждая из строк:

        window.close()
        close()
        self.close()

        закрывает текущее окно.

        Связанные элементы
        Метод объектов document и window.
        См. методы clear, open, write и writeln.

    confirm
    (Метод)

        Выводит диалоговое окно JavaScript Confirm (см. рис. 3).

        window.confirm() [windowName.]confirm()

        Диалоговое  окно  JavaScript  Confirm  предлагает пользователю
    продолжить или прекратить выполнение операции

        Применение

        Сходное  с  диалоговым  окном JavaScript Alert, но дополненное
    кнопкой   Cancel,   диалоговое  окно  JavaScript  Confirm  выводит
    сообщение и две кнопки выбора. Метод confirm возвращает true, если
    пользователь  нажимает  кнопку  ОК,  и  false  при  нажатии кнопки
    Cancel.  Следующий  пример  загружает  документ в новое окно, если
    пользователь выбирает ОК:

    if (confirm("Are you sure you want to enter."))
    tourWindow = window.open('index.html', 'Содержание');

        пример:(перейти на ОГЛАВЛЕНИЕ)

        Связанные элементы
        Метод объекта window.
        См. методы alert и prompt.

    cookie
    (Свойство)

        Строка   с   небольшим   количеством  информации,  сохраняемая
    броузером в файле cookies.txt на клиентском компьютере.

        document.cookie

        Применение

        Значение,  хранимое  в свойстве cookie, может быть извлечено с
    помощью методов charAt, IndexOf и lastIndexOf.
        Специальное  свойство  cookie сохраняет информацию о состоянии
    клиентского  компьютера.  Эта  информация  может  быть затребована
    сервером.  В  свойство  cookie включен диапазон URL, к которым эта
    информация относится.
        Будущие   запросы   HTTP  со  стороны  клиента,  попадающие  в
    указанный диапазон URL, будут включать в себя допустимую для этого
    диапазона  информацию  о  клиенте  и  передаваться  серверу.  Этот
    простой способ хранения данных позволяет серверу возвращать ответы
    клиентскому  компьютеру  с  учетом информации о клиенте. Примерами
    такого    использования    свойства    cookie   являются   посылка
    регистрационной  информации  и  автоматизация ввода идентификатора
    пользователя.  Пользовательские  настройки могут быть сохранены на
    клиентском  компьютере и затребованы сервером во время соединения.
    Можно ограничить время существования свойства cookie.
        Для  отправки  и  просмотра  установок  cookie в HTML-сценарии
    свойству следует присвоить значение:

        document.cookie = "string"

        Сценарии CGI также применяются для чтения и изменения значения
    свойства cookie. Генерация cookie требует посылки заголовка HTTP в
    формате:

        Set-Cookie: NAME=Value;
        [EXPIRES=date;] [PATH=pathname;] [DOMAIN=domainname;] [SECURE]

        Когда  запрос от сервера на получение значения свойства cookie
    попадает  к броузеру, список URL просматривается в поисках адреса,
    соответствующего    URL   сервера.   Все   совпадающие   подстроки
    возвращаются в таком формате:

        cookie: NAME1=string1; NAME2=string2; ...

        Cookie  -  это  произвольно  выбранное  имя.  Более  подробная
    информация  о  свойстве  cookie  и  его  назначении  можно найти в
    Netscape's        Cookie       Specification       по       адресу
    http://home.netscape.com/newsref/std/cookie_spec.html.

        Связанные элементы
        Свойство объекта document.
        См. объект hidden.

    cos
    (Метод)

        Возвращает косинус своего аргумента.

        Math.cos(argument)

        Применение

        Величина  угла  должна  быть  указана в радианах, возвращаемы^
    результат будет находиться в диапазоне от -1 до 1.

        Связанные элементы
        Метод объекта Math.
        См. метода acos, asin, atan, sin и tan.

    Date
    (Объект)

        Предоставляет набор методов для работы с датами и временем.

        Date.method(parameters)

        Применение

        Встроенный  объект  Date  заменяет  в языке JavaScript обычные
    типы  данных  для  дат. Несмотря на отсутствие каких-либо свойств,
    объект  Date  имеет  несколько  методов  для установки и изменения
    своего значения.
        Хотя   значения   даты   возвращаются   в  стандартной  форме,
    фактическое   значение   хранится   как   количество  миллисекунд,
    прошедших  после  полуночи  1  января  1970 года. Применение этого
    соглашения запрещает использование дат до 1970 года.
        Для  создания нового объекта Date можно использовать несколько
    вариантов синтаксиса:

        objectName = newDate() //Создает объект, хранящий текущие дату
        //и время
        objectName = newDate("month, day, year [hours:minutes:seconds]")
        //  Создает  объект  со  значением,  заданным  в  виде  строки
    определенного  формата
        objectName  = newDate(year, month, day [,hours,minutes,seconds])
        //  Создает  объект  со значением, заданным с помощью числовых
        //параметров

        Если при создании объекта Date опустить компонент, указывающий
    время,  оно  по умолчанию будет установлено в 00:00:00. Методы для
    установки  и  получения  значения даты и времени делятся на четыре
    основных категории: set, get, to и parse/UTC.
        За исключением номера дня в месяце, все числовые представления
    даты  нумеруются с нуля. Это не должно представлять проблемы, если
    не считать месяцев. Они представляются числами от 0 (январь) до 11
    (декабрь).
        Стандартный  синтаксис  даты таков: «Thu, 11 Jan 1996 06:20:00
    GMT».  Принятые в США аббревиатуры временных поясов воспринимаются
    корректно,  но  для универсальности лучше указывать сдвиг поясного
    времени  относительно  Гринвичского  меридиана. Например, «Thu, 11
    Jan  1996  06:20:00  GMT+0530» указывает пояс, находящийся на 5:30
    западнее Гринвича.

        Связанные элементы
        См.  методы  getDate,  getDay, getHours, getMinutes, getMonth,
    getSeconds,  getTime,  getTimezoneOffset, getYear, parse, setDate,
    setHours,  setMinutes,  setMonth,  setSeconds,  setTime,  setYear,
    toGMTString, toLocaleString и toUTC.

    defaultChecked
    (Свойство)

        Логическое  значение  (true  или false), указывающее состояние
    флажка или переключателя по умолчанию.

    formName.elementName.defaultChecked
    forms[index].elements[index].defaultChecked

        Применение

        Установка  значения  свойства defaultChecked может перекрывать
    атрибут CHECKED тега, создавшего элемент формы. Следующий фрагмент
    программы   возвращает   группу   переключателей  к  их  исходному
    состоянию  путем  поиска  и установки переключателя в положение по
    умолчанию:

        for (var i in menuForm.choices) {
        if (menuForm.choices[i].defaultChecked) {
        menuForm.choices[i].defaultChecked = true } }

        Изменение  свойства defaultChecked не влияет на вывод на экран
    переключателя,    даже    если    затронуто    состояние    других
    переключателей.

        Связанные элементы
        Свойство объектов checkbox и radio.
        См. объект form.
        См. свойство checked.

    defaultSelected
    (Свойство)

        Состояние элемента формы select по умолчанию.

        formName.elementName.defaultSelected
        forms[index].elements[index].defaultSelected

        Применение

        Свойство   defaultSelected   возвращает   true  или  false,  в
    зависимости   от   того,   был  ли  при  создании  элемента  формы
    использован   в   теге  атрибут  SELECTED:  Программная  установка
    значения   этого   свойства  перекрывает  наличие  или  отсутствие
    атрибута  SELECTED тега <OPTION>. Синтаксис и поведение аналогичны
    свойству defaultChecked.

        Связанные элементы
        Свойство объекта options.
        См. свойства index, selected и selectedIndex.

    defaultStatus
    (Свойство)

        Выводимое  по умолчанию сообщение в строке состояния в  нижней
    части окна броузера.

        [windowName.]defaultStatus

        Применение

        Устанавливает  сообщение,  выводимое в строке состояния, когда
    броузер не выдает своих сообщений. Это сообщение вытесняется более
    приоритетными  или  временными  сообщениями,  подобными сообщению,
    инициируемому обработчиком события mouseOver. Например:

    window.defaultStatus = "Добро пожаловать на мою домашнюю страницу"

        выводит приветственное сообщение в тот момент, когда указатель
    мыши  не  находится  над  гиперссылкой  или  броузер  не  извещает
    пользователя о производимых им действиях.

        Связанные элементы
        Свойство объекта window. См. свойство status.

    defaultValue
    (Свойство)

        Первоначальное содержимое текстовых элементов формы.

        formName.elementName.defaultValue
        forms[index].elements[index].defaultValue

        Применение

        Для  любого  из  стандартных полей ввода текстовых данных форм
    HTML  -  hidden, password, text, textarea (для которых значение по
    умолчанию   записывается  между  тегами  <TEXTAREA>)  и  string  -
    свойство   defaultValue   возвращает   первоначальное  содержимое,
    установленное  в  тегах,  независимо  от  текущего  значения.  Для
    элементов типа password это свойство автоматически устанавливается
    в  null no соображениям безопасности, независимо от установленного
    значения,

        Связанные элементы
        Свойство  объектов  hidden,  password,  text  и  textarea. См.
    свойство value.

    document
    (Объект)

        Объект, создаваемый броузером во время загрузки страницы.

        document.propertyOrMethod
        document.objectName.propertyOrMethod

        Применение

        Объект  document  является  одним  из  основных в JavaScript и
    содержит информацию о текущем документе, такую как заголовок, цвет
    фона  и  имеющиеся  в документе формы. Эти свойства определяются в
    теге  <BODY>.  С  помощью  методов write и writeln объект document
    позволяет также выводить для пользователя на экран текст HTML.
        Вы  можете ссылаться на якоря, формы и гиперссылки документа с
    помощью  соответствующих  массивов объекта document. Элементы этих
    массивов   соответствуют  каждому  якорю,  форме  или  гиперссылке
    документа.

        Связанные элементы
        Свойство объекта window. См. объект frame.
        См.  свойства  alinkColor,  anchors, bgColor, cookie, fgColor,
    forms, lastModified, linkColor, links, location, referrer, title и
    vlinkColor.
        См.   методы   clear,   close,  open,  write  и  writeln.  См.
    обработчики событий onLoad и onUnload,

    E
    (Свойство)

        Основание натуральных логарифмов.

        Math.E

        Применение

        Также  называется  константой  Эйлера, значение приблизительно
    равно 2.71828.

        Связанные элементы
        Свойство объекта Math.
        См. свойства LN2, LN10, LOG2E, LOG10E, PI, SQRT1_2 и
    SQRT2.

    elements array
    (Объект)

        Массив  элементов  формы  в  порядке их определения в исходном
    документе.
        formName.elements[index]
        forms[index].elements[index]

        Применение

        В  этот  массив включены все элементы формы. Обращение к этому
    массиву  происходит  с  помощью  имени  формы  или  массива forms.
    Элементами  формы  являются кнопки, флажки, переключатели, объекты
    text и textarea. Ссылаться на элементы можно по их индексу.
        Например,   если   форма  содержит  два  текстовых  поля,  три
    переключателя  и  две кнопки, все они - соответствующие элементы в
    массиве  elements от formName.elements[0] до formName.elements[6].
    Заметьте, что нумерация нумерация начинается с 0, а не с 1.
        Для  определения  количества элементов в форме служит свойство
    length.  Значением  свойства  value  для  каждого элемента массива
    elements является полный текст тега HTML, создавшего элемент.
        На   элементы  формы  можно  также  ссылаться  no  их  именам.
    Например,  элемент  типа password, названный newPassword, является
    вторым  элементом  формы на странице HTML. Его значение может быть
    получено тремя способами:

        formName.elements[1].value
        formName.elements["newPassword"].value
        formName.newPassword.value

        Значения   элементов  массива  elements  доступны  только  для
    чтения.

        Связанные элементы
        Свойство объекта form. См. свойство length.

    elements
    (Свойство)

        Массив  объектов,  содержащий  элементы формы в том порядке, в
    котором они перечислены в тексте страницы HTML.

        formName.elements[index]
        forms[index].elements[index]

        Применение

        Нумерация  элементов массива начинается с нуля и заканчивается
    количеством  элементов  формы  минус 1. Более подробная информация
    содержится в описании объекта elements array.

        Связанные элементы
        Свойство объекта form. См. oбъeкт elements.

    encoding
    (Свойство)

        Возвращает строку с типом кодирования MIME.

        formName.encoding
        forms[index].encoding

        Применение

        Тип  кодирования  MIME устанавливается в атрибуте ENCTYPE тега
    HTML  <FORM>.  Стандарты  кодирования MIME в HTML не устоялись, но
    черновые  документы  и  информацию  о состоянии дел можно найти на
    Web-сайте University of California-lrvine Information and Computer
    Sciences Department http://www.ics.uci.edu/pub/ietf/html/.

        Связанные элементы
        Свойство объекта form.
        См. свойства action, method и target.

    escape*
    (Метод)

        Возвращает ASCII-код своего аргумента.

        escape(argument)

        Коды  ASCII  HTML  основаны  на  наборе символов ISO Latin-1 и
    записываются   в   форме   %xxx,   где  xxx  -  десятичное  число,
    представляющее  код  ASCII.  Этот метод не относится к какому-либо
    объекту, а является встроенным в язык JavaScript. Буквы латинского
    алфавита  и  числа  возвращаются  как есть, для остальных символов
    возвращаются коды ASCII.

    document.write(escape("Hi!"));

    возвращает:

        Связанные элементы
        См. метод unescape.

    eval*
    (Метод)

        Вычисляет строку как числовое выражение.

        eval(string)

        Применение

        Встроенная  функция  языка  JavaScript  получает  числовое или
    строковое  значение  как аргумент. В случае получения строки метод
    eval   пытается  преобразовать  ее  в  числовое  выражение,  затем
    вычисляет это выражение и возвращает получившийся результат.

        var x = 10
        var у = 20 document.write(eval("x + у"))

        Этот  метод может быть также использован для выполнения команд
    JavaScript, включенных в строку.

        var  doThis  =  "if(х==10)"  {  аlеrt('Достигнуто максимальное значение') }
        function checkMax() {
    x++;
        eval(doThis) }

        Этот   метод   может  оказаться  полезным  для  преобразования
    введенной  в  поле  формы  строки,  представляющей  собой какую-то
    дату, в числовое выражение.

    exp
    (Метод)

        Возвращает значение экспоненты.

        Math.exp(argument)

        Применение

        Метод exp возвращает число E (константу Эйлера), возведенное в
    степень, равную аргументу.

        Связанные элементы
        Метод объекта Math. См. методы log и pow. См.свойство Е.

    fgColor
    (Свойство)

        Цвет текста, выводимого на странице.

        document.fgColor

        Применение

        Цвета  в  JavaScript  представлены  в  виде  шестнадцатиричных
    триплетов  RGB  или  строковых  литералов. Это значение не моможет
    быть  изменено  после загрузки документа, для отдельных фрагментов
    текста можно изменить цвет с помощью метода fontcolor.
         Свойство fgColor записывается в двух формах:

        document.fgColor="aliceblue" document.fgColor="FOF8FF"

    BlueRedPapaya WhipBlack

        что  дает тот же эффект, что и атрибут TEXT тега <BODY>: <BODY
    TEXT="aliceblue">

        Связанные элементы
        Свойство объекта document.
        См. свойства alinkColor, bgColor, linkColor и vlinkColor.
        См. метод fontcolor.

    fixed
    (Метод)
        Выводит  строку  на  экран шрифтом фиксированной ширины.

        stringName.fixed()

        Применение

        Использование  метода  fixed  аналогично  применению тега HTML
    <TT>.

        Связанные элементы
        Метод объекта string.

    floor
    (Метод)

        Возвращает   ближайшее   целое   число,   меньшее  или  равное
    аргументу.

        Math.floor(argument)

        Применение

        Если  этому  методу  передано  в  качестве аргумента целое или
    дробное  число,  он  возвращает  целое  число, меньшее или рав-ное
    аргументу аргументу. Например:

        Math.floor(2.99) возвращает 2.

        Связанные элементы
        Метод объекта Math. См. метод ceil.

    focus
    (Метод)

        Передает фокус указанному элементу формы.

        formName.elementName.focus()
        forms[index].elements[index].focus()

        Применение

        Используя  имена  формы и элемента, метод focus передает фокус
    элементу.  С  этого  момента  можно  программно  ввести значение в
    элемент формы, либо пользователь может сделать это вручную.

        Связанные элементы
        Метод  объектов  password, select, text и textarea. См. методы
    blur и select.

    fontcolor
    (Метод)

        Переопределяет цвет выводимого текста для строкового объекта.

        stringName.fontcolor()

        Применение

        Метод fontcolor форматирует строковый объект цветом, указанным
    в  аргументе  как  шестнадцатиричный  триплет  RGB  или  строковый
    литерал. Использование метода fontcolor подобно использованию тега
    <FONT COLOR=color>.

        myDog = "Brown";
        document.write(myDog.fontcolor("sienna"))

        Связанные элементы
        Метод объекта string.

    fontsize
    (Метод)

        Выводит на экран строку шрифтом указанного размера.

        stringName.fontsize(argument)

        Применение

        Этот  метод использует один из семи возможных размеров шрифта,
    устанавливаемых  в  теге  <FONTSIZE=size>.  Если  методу  передана
    строка,  размер  шрифта  задается  относительно базового значения,
    установленного в теге <BASEFONT>.

        Аргумент  задает  размер  шрифта. Если это целое число, то оно
    представляет собой размер шрифта и должно быть в диапазоне от 1 до
    7.  Если  же  в  качестве аргумента передана строка, размер шрифта
    изменяется относительно базового.

        Связанные элементы
        Метод объекта string. См. методы big и small.

    form
    (forms array)(Объект)

        Объект, представляющий форму на странице.

        document,formName
        document.forms[index]

        Применение

        Объект  form является свойством объекта document. Каждая форма
    в документе является отдельным объектом. НА нее можно ссылаться по
    имени.   Объект  form  является  также  элементом  массива  forms,
    определенного   в  тегах  HTML.  Если  первая  форма  в  документе
    называется   orderForm,   то   ссылаться   на  нее  можно  как  на
    document.orderForm  или document.forms[0]. Если форме не присвоено
    имени,  сослаться на нее можно только как на элемент массива forms
    по  индексу.  Для  получения  количества  форм  на странице служит
    свойство length.

        document.forms.length

        Отдельные  элементы  формы могут быть указаны по их именам или
    как элементы массива elements.

        document.formName.elements[index]

        Массив  forms  -  объект только для чтения. Попытка установить
    значение с помощью выражения:

        document.forms[l]="OldGuestBook" не даст никакого эффекта.

        Значение  элемента  массива  forms  имеет  синтаксис, подобный
    синтаксису  тега HTML. Например, значение объекта form для формы с
    именем userInfo будет <OBJECT userInfo>.

        Связанные элементы
        Свойство объекта document.
        См.  объект  hidden,  свойства action, elements, encoding, forms, method, name и target.
        Cм. метод submit.
        См. обработчик события onSubmit.

    forms
    (Свойство)

        Массив  объектов,  соответствующих  формам,  созданных в тегах
    HTML в том же порядке.

        document.forms

        Применение

        Свойство  forms  относится  к  объекту  document и содержит по
    элементу  на  каждую  форму  в  документе.  Более  подробно  см. в
    описании объекта form.

        Связанные элементы
        Свойство  объекта  document.  См.  объект  form.  См. свойство
    length.

    forward
    (Метод)

        Загружает  следующий  документ из списка URL, просмотренных за
    текущий сеанс работы с броузером.

        history.forward()

        Применение

        Результат   действия   этого   метода   аналогичен   выражению
    history.go(1).

        Связанные элементы
        Метод объекта history. См. методы back и go.

    frame
    (Объект)

        Окно (кадр),  содержащее независимо прокручиваемый субдокумент
    HTML

        [windowName.][parent.]frameName
        [windowName.][parent.]frames[index]

        Применение

        Кадры  могут быть связаны с различными URL Загрузка документов
    в  каждый  кадр  может быть инициирована из другого кадра в том же
    окне  броузера. Каждый кадр представляет собой объект типа window,
    определенный  в  теге <FRAMESET> для создания требуемой компоновки
    страницы. Страница определяется в родительском документе HTML. Все
    субдокументы являются дочерними no отношению к родительскому.
        Если  кадр  содержит определения атрибутов SRC и NAME, то кадр
    может  быть  идентифицирован  с помощью выражений parent.frameName
    или parent.frames[index].

        Связанные элементы
        Свойство объекта window
        См объекты document и window.
        См.  свойства defaultStatus, frames, parent, self, status, top
    и window.
        См методы setTimeout и clearTimeout.

    frames
    (Свойство)

        Массив,  соответствующий  дочерним кадрам, созданным с помощью
    тега <FRAMESET>.

        [windowName.][parent.]frameName
        [windowName.][parent.)frames[index]

        Применение

        Определить  количество  кадров в окне можно с помощью свойства
    length.  Дополнительная  информация  содержится в описании объекта
    frame.

        Связанные элементы
        Свойство объекта window. См.объект frame. См. свойство length.

    getDate
    (Метод)

        Возвращает число месяца

        Date.getDate()

        Применение

        Один  из  немногих  элементов  языка  JavaScript,  нумерация в
    котором начинается не с 0. Этот метод возвращает число в диапазоне
    от 1 до 31, представляющее число месяца.

        endOfTheWorld = newDate("January 11,1996 06:18:00")

        document.write(endOfTheWorld.getDate())//Возвращает 11

        Связанные элементы
        Метод объекта Date. См. метод setDate.

    getDay
    (Метод)

        Возвращает  день  недели как целое число от 0 (воскресенье) до
    6(суббота).

        Date.getDay() dateName.getDay()

        Применение

        Соответствующего  метода  setDay  не  существует, так как день
    недели автоматически вычисляется на основе значения объекта Date.

        Связанные элементы
        Метод объекта Date.

    getHours
    (Метод)

        Возвращает час суток.

        Date.getHours() dateName.getHours()

        Применение

    Значение возвращается в  24-часовом  формате, от 0 (полночь) до23.

        Связанные элементы
        Метод объекта Date. См. метод setHours.

    getMinutes
    (Метод)

        Возвращает минуты как целое от 0 до 59.

        Date.getMinutes() dateName.getMinutes()

        Применение

        Подобно  остальным  методам  объекта  Date,  getMinutes просто
    возвращает один из элементов времени.

        endOfTheWorld = new Date("January 11, 1996 06:18:00")
        document.write(endOfTheWorld.getMinutes())  //Возвращает 18

        Связанные элементы

        Метод объекта Date. См. метод setMinutes.

    getMonth
    (Метод)

        Возвращает номер месяца в году.

        Math.getMonth() dateName.getMonth()

        Применение

        Номер  месяца возвращается как целое число в интервале между 0
    (январь)  и  11  (декабрь),  а  не  как строка. Это значение может
    внести  путаницу,  так  как  не соответствует стандартному способу
    нумерации  месяцев. Прежде чем вывести значение на экран или после
    получения данных, введенных пользователем в форму, надо произвести
    соответствующие преобразования.

        function  toReality()  { //преобразует номер месяца в систему "1-12"
        this += 1 }
        function  toConvention()  {  //  преобразует  номер  месяца  в систему "0-11"

    getSeconds
    (Метод)
        Возвращает число секунд.

        Date.getSeconds() dateName.getSeconds()

        Секунды возвращаются как целое число от 0 до59.

        Связанные элементы
        Метод объекта Date. См. метод setSeconds.

    getTime
    (Метод)

        Возвращает  целое число, представляющее собой текущее значение
    объекта date.

        Date.getTime() dateName.getTime()

        Значение  представляет собой количество миллисекунд, прошедших
    после   полуночи   1   января   1970   года.  Это  значение  может
    использоваться  для  сравнения двух дат. Для функций, включающих в
    себя   вычисления   дат,   полезно   создать   набор   переменных,
    определяющих минуты, часы и дни в миллисекундах.

        var dayMillisec = 1000 * 60 * 60 * 24
        //1,000 миллисекунд x 60 сек. x 60 мин. x 24 часа
        var hourMillisec = 1000 * 60 * 60
        //1,000 миллисекунд  x  60  сек.  60  мин.
        var minuteMillisec = 1000 * 60
        //1,000 миллисекунд x 60 сек.

        Связанные элементы
        Метод объекта Date. См. метод setTime.

    getTimezoneOffset
    (Метод)

        Возвращает  разницу в минутах между местным временем клиента и
    гринвичским (GMT).

        Date.getTimezoneOffset() dateName.getTimezoneOffset()

        Применение

        Это  значение  является  константой,  за  исключением  случаев
    перехода на летнее/зимнее время.

        Метод объекта Date.

    getYear
    (Метод)

        Возвращает год объекта date минус 1900.

        Date.getYear()
        dateName.getYear()

        Применение

        Несмотря  на  то что значение года может быть передано объекту
    date  как  4-значное  число  в  виде  строки, возвращаемое методом
    getYear   значение   является  2-значным  числом.  Например,  1996
    возвращается как 96.

        Связанные элементы
        Метод объекта Date См. метод setYear.

    go
    (Метод)

        Загружает  документ  из  списка страниц, посещенных за текущий
    сеанс работы броузера.

        history.go(argumentOrURL)

            Применение

        Этот  метод  может ссылаться на документы из списка history no
    URL  или  по  относительной  позиции  в  этом  списке. Если указан
    неполный   адрес   URL,   используется  ближайшее  соответствующее
    значение. Результат поиска не зависит от регистра.

        Связанные элементы
        Метод объекта history. См. методы back и forward.

    hash
    (Свойство)

        Возвращает часть URL, начинающуюся с символа #.

        document.linkName.hash
        document.links[index].hash
        document.location.hash

        Применение

        Свойство  hash ссылается на имя, созданное в теге <А NAME...>.
    Изменяя  это  свойство,  можно  изменять часть URL, начинающуюся с
    символа  #,  хотя  безопаснее  менять  весь URL с помощью свойства
    href.  Если имя, указанное в свойстве hash данного URL, не удается
    найти, возвращается ошибка.

        Связанные элементы
        Свойство объектов link и location. См. объект anchor.
        См.  свойства host, hostname, href, pathname, port, protocol и
    search.

    hidden
    (Объект)

        Текстовый объект в форме HTML, не отображаемый на экране.

    document.formName.hiddenName
    document.forms[index].elements[index].
    propertyOrMethod

        Применение

        Объект  hidden  может применяться наряду с cookie для передачи
    пар  имя/значение  для клиент-серверного взаимодействия. Разница в
    том,  что  cookie  постоянно существуют на клиентском компьютере в
    течение   сессии,  в  то  время  как  объект  hidden  относится  к
    конкретной форме.
        Первоначальное  содержание  объекта hidden может быть изменено
    внутри  функции  путем  присвоения  нового значения свойству value
    этого объекта.

        <INPUT TYPE-"hidden" NAME-"failedTries" VALUE="0">
        ...строки кода...
        function setRetry() {
            document.userPasswordForm.failedTries.value++ }
        }
        Каждый   раз,  когда  вызывается  функция  setRetry,  значение
    объекта  типа  hidden,  названного  failedTries,  увеличивается на
    единицу.   Это  один  из  примеров  гибкости  типов  переменных  в
    JavaScript.  Первоначальное  значение  объекта  представляет собой
    строку.  Несмотря на это, когда программа встречает математический
    оператор,  она  пытается  преобразовать  значение  объекта в целое
    число.

        Связанные элементы
        Свойство объекта form.
        См. свойства cookie, defaultValue, name и value.

    history
    (Объект)

        Список   ранее   просмотренных  страниц,  аналогично  меню  Go
    броузера.

    document.history

        Применение

        Этот  объект унаследован из меню Go броузера и содержит список
    ранее просмотренных страниц. Методы объекта служат для навигации к
    любому элементу списка.
        Для  определения  количества элементов объекта служит свойство
    length:

        document.history.length

        Навигация  представляет  собой  относительное  перемещение  по
    списку  вперед  или  назад, подобно использованию кнопок на панели
    инструментов.

        document.history.forward()
        document.history.back()

        Метод  go  допускает и более сложные, чем просто перемещение к
    следующей  или  предыдущей  странице,  переходы по списку, подобно
    выбору адреса прямо из меню Go.

        document.history.go(-2) //загружает предпоследнюю страницу

        Указав  конкретное  окно,  можно управлять навигацией в других
    окнах  или  кадрах.  Следующий  пример загружает новую страницу из
    списка  объекта history в кадр с именем content. Заметьте, что имя
    кадра заменяет указание документа.

        parent.content.history.back() // загружает предыдущую страницу
    в кадр

        Связанные элементы
        Свойство объекта document.
        См. объект location.
        См. свойство length.
        См. методы back, forward и go.

    host
    (Свойство)

        возвращает строку, сформированную из свойств URL

        hostname и port.
        location.host linkName.host
        links[index].host

        Применение

        Предоставляет  метод  для просмотра и изменения той части URL,
    которая  идентифицирует  Web-узел.  Если  порт не указан, свойства
    host и hostname одинаковы.

        location.host * "www.montana.com:80"

        Связанные элементы
        Свойство объектов link и location.
        См.  свойства hash, hostname, href, pathname, port, protocol и
    search.

    hostname
    (Свойство)

        Возвращает  или изменяет строку с именем домена или IP-адресом
    URL.

        location.hostname
        1inkName.hostname
        links[index].hostname

        Применение

        Это  свойство  сходно  со свойством host, за исключением того,
    что  не  включает  в себя информации о номере порта. Если свойство
    port имеет значение null, то свойства host и hostname одинаковы.
        Несмотря  на  то  что  свойство hostname может быть изменено в
    любой   момент,   рекомендуется  изменять  весь  URL  сразу.  Если
    указанное  значение  hostname  не может быть найдено, возвращается
    ошибка.

        Связанные элементы
        Свойство объектов link и location.
        См.  свойства  hash,  host,  href,  pathname, port, protocol и
    search.

    href
    (Свойство)

        Возвращает строку, содержащую полный URL текущего документа.

        location.href
        linkName.href
        links[index].href

    применение

        Все  остальные  свойства  объектов  location  и  link являются
    подстроками  свойства  href,  которое  может быть изменено в любой
    момент.
        URL  текущего  документа  можно  вывести  на  экран  с помощью
    выражения document.write.

        document.write("You are here: " + window.location.href)

        Связанные элементы
        Свойство объектов link и location.
        См.  свойства hash, host, hostname, pathname, port, protocol и
    search.

    Index
    (Свойство)

        Возвращает индекс элемента объекта select

        formName.selectName.options[index].index
        forms[index].elements[index]-options[index].index

        Применение

        Позиция элемента в объекте select нумеруется начиная с 0.

        Связанные элементы
        Свойство   объекта   select   (options  array).  См.  свойства
    defaultSelected, selected и selectedIndex.

    indexOf
    (Метод)

        Возвращает позицию определенного символа или подстроки.

        stringName.indexOf(character|string, startingPoint)

        Применение

        Поиск  начинается  с  позиции  startingPoint.  Первый символ в
    строке  имеет  номер  0,  а  последний  равен  длине  строки минус
    единица.  Если подстрока не найдена, метод возвращает -1. Значение
    параметра startingPoint по умолчанию равно 0.

        if (navigator. appVersion, indexOf ('Unix') !=-1)
            return true

        Связанные элементы
        Метод объекта string.
        См. методы charAt и lastIndexOf .

    isNaN*
    (Метод)

        Проверяет, является ли аргумент числом.

        isNaN (argument)

        Применение

        Метод  применим  только для UNIX. Эта функция возвращает true,
    если  аргумент  не  является  числом.  На  всех  платформах, кроме
    Windows,  методы  parseFloat  и  parseInt  возвращают NaN, если их
    аргумент не является числом.

        Связанные элементы
        См. методы parseFloat и parseInt.

    italics
    (Метод)

        Форматирует строку курсивом.

        stringName.italics()

        Применение

        Метод  italics  дает  тот  же  эффект,  что  и применение тега
    HTML<I>.

        Связанные элементы
        Метод объекта string.
        См. методы blink, bold и strike.

    lastlndexOf
    (Метод)

        Возвращает  позицию  символа  или  подстроки в строке, начиная
    поиск с конца.

        stringName.lastlndexOf()

        Применение

        Возвращает  позицию  определенного  символа  или  подстроки  в
    строковом  объекте, производя поиск с конца строки или с указанной
    позиции. Если подстрока не найдена, метод возвращает -1.

        if (navigator.appVersion.lastlndexOf('Win') !=-1)
            return true

        Связанные элементы
        Метод объекта string.
        См. методы charAt и indexOf.

    lastModified
    (Свойство)

        Строка  только  для чтения, хранящая дату последнего изменения
    текущего документа.

        document.lastModified

        Это  свойство  опирается  на  атрибуты файла-источника. Строка
    форматируется  стандартным  для  JavaScript  способом  (см. объект
    Date). Обычно применяется так:

    dateModified = "Дата последнего изменения:" + document.lastModified
    document.write(dateModified.small())

        Связанные элементы
        Свойство объекта document.

    length
    (Свойство)

        Целое  число,  показывающее  длину или размер соответствующего
    свойства объекта.

        formName.length
        forms.length
        formName.elements.length
        forms[index].length
        fwindowName.]frameName.length
        frameRef.frames.length
        history.length
        radioName.length
        selectName.length
        selectName.options.length
        stringName.length
        windowName.length
        anchors.length
        links.length

        Применение

        Смысл  возвращаемого  свойством  length  значения определяется
    массивом или объектом, к которому это свойство применено.

        Таблица 2.
        Объект/Массив              Свойство определяет

        history                     Длина списка просмотренных страниц

        string                      Целое число,  представляющее длину
                                    строки, или 0 для пустой строки

        radio                       Количество переключателей

        anchors, forms,             Количество элементов массива
        frames, links,
        options

        Связанные элементы
        См. свойства объектов anchors, elements, forms, frame, frames,
    history, links, options, radio, string и window.

    link
    (links array)(Объект)

        Текст  или изображение, определенные как гиперссылка на другой
    URL.

        document.linkName document.links[index]

        Применение

        Объект   link  представляет  собой  объект  типа  location  и,
    следовательно,  имеет  те  же  свойства  и  методы,  что  и объект
    location.
        Если для объекта определено имя, то он одновременно становится
    элементом массива anchors.

    <А HREF='http://www.cnet.com/'>c|net's front door</A>
    <A HREF='http://www.cnet.com/' NAME='cnet'>c|net's front door</A>

        В  вышеприведенном  примере первая строка создает только новый
    элемент  массива  links.  Если  же тег дополнен атрибутом NAME, то
    дополнительно создается и элемент массива anchors.
        Объект  link только для чтения. Для создания новой гиперссылки
    применяется метод link объекта string.

        Связанные элементы
        Свойство объекта document. См. объект anchor.
        См.  свойства  hash,  host,  hostname, href, length, pathname,
    port,  protocol,  search и target. См. метод link. См. обработчики
    событий onClick и onMouseOver.

    link
    (Метод)

        Создает новую гиперссылку на другой URL.

    stringName.link(argument)

        Применение

        Создает  новую  гиперссылку, определяя атрибут <HREF> и текст,
    который увидит пользователь.

        linkText = "Wossamatta University";
        linkURL = "http://www.wossammotta.edu/";
        document.write("Alma mater Рокки: " + linkText.link(linkURL))

        Связанные элементы
        Метод объекта string. См. метод anchor.

    linkColor
    (Свойство)

        Цвет гиперссылки в документе.

    document.linkColor

        Применение

        Цвет   определяется  как  шестнадцатиричный  триплет  RGB  или
    строковый  литерал.  Это  свойство не может быть установлено после
    того,  как  документ  отформатирован.  Цвет соответствует атрибуту
    LINK  в теге <BODY> и не может быть изменен после вывода документа
    на экран.

         document.write("Текущий цвет гиперссылок: " + document.linkColor)

        Связанные элементы
        Свойство объекта document.
        См. свойства alinkColor, bgColor, fgColor и vlinkColor.

    links
    (Свойство)

        Массив объектов link.

    document.links[index]

        Применение

        Ссылки  определяются  в  HTML с помощью тега <А HREF=URL>. Они
    отражаются  в  свойстве  links,  первая  ссылка  представлена  как
    document.links[0].   Более   подробная   информация  приводится  в
    описании объекта link.

        Связанные элементы
        См. объект link.
        См. свойства anchors и length.

    LN2
    (Свойство)

        Константа,   представляющая   натуральный  логарифм  числа  2.
    Math.LN2

        Применение

        Значение этой константы приблизительно равно 0.69315.

        Связанные элементы
        Свойство объекта Math.
        См. свойства Е, LN10, LOG2E, LOG10E, PI, SQRT1_2 и SQRT2.

    LN10
    (Свойство)

        Константа, представляющая натуральный логарифм числа 10.

        Math.LN10

        Применение

        Значение этой константы приблизительно равно 2.30259.

        Связанные элементы
        Свойство объекта Math.
        См. свойства Е, LN2, LOG2E, LOG10E, PI, SQRT1_2 и SQRT2.

    location
    (Объект)

        Полная информация об URL текущего документа.

        [WindowName][frameName.]location.propertyName
        parent.[frameName.]location.propertyName

            Применение

        Объект   location  используется  для  определения  URL  любого
    активного документа, включая документы в других окнах или в кадрах
    навигатора.  Если объект window не указан, подразумевается текущее
    окно.
        Каждое свойство объекта location содержит отдельную часть URL.
    Шесть частей URL отражены в объекте location:

        protocol://hostname:port/pathname.search#hash

        Протоколы  включают  в  себя  начальную  часть  адреса  (http,
    mailto,  ftp  и  т.  д.)  до  двоеточия включительно. B JavaScript
    включено несколько дополнительных протоколов.
        Протокол  javascript  исполняет  выражение  после  двоеточия и
    пытается   загрузить   получившееся   строковое   выражение.  Если
    результата  нет  или он не определен, остается загруженной текущая
    страница.

        javascript:parent.content.history.go(-1)

        Протокол about предоставляет три метода получения информации о
    броузере. Сам по себе он дает тот же результат, что и выбор пункта
    About  меню  Help.  Два  других  метода, cache и plugins, отражают
    текущее  состояние  кэша и информацию об установленных приложениях
    plug-in.

        about:cache
        about:plugins

        He  путайте  этот объект, являющийся свойством объекта window,
    со свойством location объекта document. Обычно они отражают одно и
    то же значение, но свойство документа не может быть изменено, в то
    время как свойства данного объекта могут быть изменены.

        Связанные элементы
        Свойство объекта window. См. объект history.
        См.  свойства  hash, host, hostname, href, location, pathname,
    port, protocol, search и target.

    location
    (Свойство)

        Возвращает строку с URL текущего документа.

        document.location

        Применение

        Это свойство только для чтения (document. location) отличается
    от   свойства   location   объекта   window   (window,   location.
    propertyName), которое может быть изменено.

        Связанные элементы
        Свойство объекта document. См, объект location.

    log
    (Метод)

        Возвращает  натуральный  логарифм для положительного аргумента
    expression.

    Math.log(expression)

        Применение

        Для     отрицательного     аргумента     всегда     возвращает
    -1.797693134862316е+308.

        Связанные элементы
        Свойство объекта Math. См. методы ехр и pow.

    LOG2E
    (Свойство)

      Константа, представляющая собой логарифм числа Е по основанию 2.

      Math.LOG2E

        Применение

        Значение этой константы приблизительно равно 1.44270.

        Связанные элементы
        Свойство объекта Math
        См. свойства Е, LN2, LN10, LOG10E, PI, SQRT1_2 и SQRT2.

    LOG10E
    (Свойство)

     Константа, представляющая собой логарифм числа Е по основанию 10.

     Math.LOG10E

        Применение

        Значение этой константы приблизительно равно 0.43429.

        Связанные элементы
        Свойство объекта Math.
        См. свойства Е. LN2, LN10, LOG2E, SQRT1_2 и SQRT2.

    Math
    (Объект)

        Встроенный  в  JavaScript объект, дающий доступ к константам и
    математическим функциям.

        Math.property
        Math.method(arguments)

        Применение

        Объект   Math   делится   на  две  части-свойства,  содержащие
    константы и методы для реализация функций. Например, для получения
    значения числа я в уравнении используйте:

        Math.PI

        Стандартные      тригонометрические,     логарифмические     и
    экспоненциальные   функции  также  включены  в  этот  объект.  Все
    аргументы  тригонометрических функций выражаются в радианах. Также
    представлено  несколько  операции  сравнения,  например  max - для
    определения большего из двух чисел.
        Так  как  назначением  объекта  Math  является  предоставление
    средств  для  математических операций, нет необходимости создавать
    второй объект Math.
        Для  функций,  активно  использующих  математические функции и
    константы  JavaScript, утомительно включать Math как часть каждого
    выражения.  Оператор with упрощает синтаксис в подобных ситуациях.
    Обратите  внимание  на  различия  в  следующих примерах, каждый из
    которых выполняет одни и те же операции.

    function Hard() {
        circleArea = Math.PI*(radius^2);
        radians = (degrees/360)*Math.PI;
        result - Math.cos(radians);
        }

    function Easy() {
        with Math {
            circleArea = PI*(radius^2);
            radians = (degrees/360)*PI;
            result = cos(radians); }
        }

        Связанные элементы
        См. свойства Е, LN10, LN2, PI, SQRT1_2 и SQRT2.
        См.  методы abs, acos, asin, atan, ceil, cos, exp, floor, log,
    max, min, pow, random, round, sin, sqrt и tan.

    max
    (Метод)

        Возвращает наибольший из двух аргументов.

        Math.max(argument1, argument2)

        Применение

        Принимает  любую комбинацию числовых констант или переменных и
    возвращает значение большей. Например:

        firstNum = 1
        secondNum = 100

        Math.max(firstNum,secondNum)
        возвращает 100.

        Связанные элементы
        Метод объекта Math. См. метод min.

    method
    (Свойство)

        Отражает значение атрибута METHOD тега HTML <FORM>.

        formName.method forms[index].method

        Применение

        Возвращаемое  значение или get, или post. Новое значение может
    быть установлено в любой момент.
        Первая  функция возвращает текущее значение объекта form, в то
    время  как  вторая  функция устанавливает значение свойства method
    равным параметру newMethod.

        function getMethod(formObj) {
        return  formObj.method
        }
        function setMethod(formObj,newMethod){
        formObj.method = newMethod
        }

        Связанные элементы
        Свойство формы.
        См. свойства action, encoding и target.

    min
    (Метод)

        Возвращает меньший из двух аргументов.

        Math.min(argument1, argument2)

        Применение

        Принимает  любую комбинацию числовых констант или переменных и
    возвращает значение наименьшего. Например:

        firstNum = 1
        secondNum = 100

        Math.min(firstNum,secondNum)
        возвращает 1.

        Связанные элементы
        Метод объекта Math. См. метод max.

    name
    (Свойство)

        Возвращает строку со значением атрибута name объекта.

        objectName.name
        frameRef.name
        frameRef.frames.name
        radioName[index].name
        selectName.options.name
        windowRef.name
        windowRef.frames.name

        Применение

        Атрибут  этого  свойства  зависит  от  объекта.  Он может быть
    изменен в любой момент.
        Это  свойство  ссылается  на внутренние имена объектов button,
    reset  и  submit, а не на подписи кнопок. Например, после открытия
    нового окна с помощью:

    indexOutline = window.open("http://www.wossamotta.com/outline.html","MenuPage")
        и выполнения команды
            document.write(indexOutline.name)

        JavaScript  вернет строку «MenuPage», то есть присвоенное окну
    имя. У всех переключателей в группе имена одинаковы, каждый из них
    идентифицируется своей позицией.

        Связанные элементы
        Свойство  объектов  button,  checkbox, frame, password, radio,
    reset, select, submit, text, textarea и window.
        См. свойство value.

    navigator
    (Объект)

        Содержит  информацию  о  броузере  на  клиентском  компьютере.

    navigator

        Применение

        Объект  navigator  возвращает информацию о броузере, такую как
    имя  и  версия броузера. Одно из основных применений этого объекта
    состоит   в  определении  платформы,  используемой  на  клиентском
    компьютере,  для учета особенностей конкретного броузера, подобных
    обработке символа новой строки или генерации случайных чисел.

        function UnixMachine() {
        if (navigator.appVersion.lastIndexOf('Unix') !=-l)
            return true
        else
            return false

        Связанные элементы
        См. объекты link и anchors.
        См. свойства appName, appCodeName, appVersion и userAgent.

    onBlur
    (Обработчик события)

        Событие  происходит  в тот момент, когда элемент формы select,
    text или textarea теряет фокус.

        <INPUT TYPE="elementType" onBlur="function">

        Применение

        Событие потери фокуса (blur) может использоваться для проверки
    корректности  ввода  данных пользователем. Этот обработчик события
    отличается  от  обработчика  onChange, который вызывается только в
    случае изменения значения поля.

    <INPUT TYPE="textarea" VALUE="" NAME="feedback" onBlur="checkSignature(this.value)">

        Связанные элементы
        Обработчик событий для объектов select, text, textarea.
        См. методы focus и blur.
        См. обработчики событий onChange и onFocus.

    onChange
    (Обработчик события)

        Событие происходит в тот момент, когда значение элемента формы
    select, text или textarea изменилось и элемент потерял фокус.

        <INPUT TYPE="elementType" onChange="function">

        Применение

        Этот  обработчик  особенно  полезен  для проверки корректности
    ввода данных пользователем.

        <INPUT TYPE="text" VALUE="MT" NAME="state" onChange="checkAvailability(this.value)">

        Связанные элементы
        Обработчик событий для объектов select, text, textarea.
        См. обработчики событий onBlur и onFocus.

    onClick
    (Обработчик события)

        Вызывается после щелчка левой кнопкой мыши на объекте.

        <INPUT TYPE="elementType" onclick="function">

        Применение

        Обработчик  onClick  придает  широкую функциональность кнопкам
    формы  и  другим объектам на странице. Кнопки могут использоваться
    для   проверки   корректности  ввода  данных  пользователем  перед
    посылкой  на  сервер  или для вычисления результатов в форме или в
    выражении.   Щелчок   на   переключателе   или   флажке  позволяет
    переключиться на обработку другой информации.
        Следующий пример посылает содержимое формы с именем «overtime»
    функции howRich.

        <FORM NAME="overtime">Full  days  worked:
        <INPUT  TYPE="text" VALUE="0" NAME="days" SIZE=3>Hours worked:
        <INPUT  TYPE="text"  VALUE="0"  NAME  «"hours" SIZE=30>
        <INPUT TYPE="button" VALUE="Compute" NAME="computeWage"
               onClick="howRich(this.form)">
        </FORM>

        Связанные элементы
        Обработчик событий для объектов button, checkbox, radio, link,
    reset и submit.

    onFocus
    (Обработчик события)

        Событие  происходит в тот момент, когда пользователь переходит
    к элементу формы select, text или textarea для ввода данных.

        <INPUT TYPE="inputType" onFocus="function">

        Применение

        Элемент  формы получает фокус в тот момент, когда пользователь
    переходит  к этому элементу формы с помощью клавиши Tab или щелчка
    мыши. Выделение символов внутри поля приводит к вызову обработчика
    события onSelect.
        Одним  из  применений  обработчика  onFocus  является вывод на
    экран  всплывающей  подсказки,  когда  элемент выбирается в первый
    раз.

        Связанные элементы
        Обработчик  событий  для  объектов select, text, textarea. См.
    обработчики событий onBlur и onChange,

    onLoad
    (Обработчик события)

        Вызывается,  когда  загрузка  Документа  в  окно  или  в  кадр
    закончена.

        <BODY onLoad="function"> <FRAMESET onLoad="function">

        Применение

        Событие load возникает в тот момент, когда броузер заканчивает
    загрузку окна или всех кадров внутри тега <FRAME SET>.

        Связанные элементы
        Обработчик  событий для объекта window. См. обработчик события
    onUnload.

    onMouseOver
    (Обработчик события)

        Событие   происходит,  когда  указатель  мыши  помещается  над
    гиперссылкой.

        <А HREF="URL" onMouseOver="function">linkText</A>

        Применение

        Обработчик   onMouseOver   вызывается   в  тот  момент,  когда
    пользователь  помещает  указатель  мыши  над  объектом  link,  Для
    взаимодействия  со  свойствами status или defaultStatus обработчик
    события должен возвращать true.

    <А HREF="http://home.netscape.com/"
      onMouseOver="window.status='Netscape'; return true">Netscape</A>

        Связанные элементы
        Обработчик событий для объекта link.

    onSelect
    (Обработчик события)

        Обработчик  события  onSelect  вызывается  в тот момент, когда
    выделен текст внутри элемента формы.

        <INPUT TYPE="textType" onSelect="function">

        Применение

        Событие  select  вызывается  выбором  части или всего текста в
    объектах text или textarea.

        Связанные элементы
        Обработчик событий для объектов text и textarea.

    onSubmit
    (Обработчик события)

        Событие  происходит в момент щелчка мышью на кнопке Submit для
    посылки данных формы на сервер.

        <TAG onSubmit="function">

        Применение

        Обработчик  события  onSubmit  запускается  в  момент отправки
    пользователем  данных  формы  на  сервер.  Любое отличное от false
    возвращаемое  значение,  в  том  числе  пропуск  оператора return,
    приводит  к  отправке данных на сервер. Для получения более ясного
    кода рекомендуется вставлять оператор return в обоих случаях.

        <FORM onSubmit="feedbackSubmit()">
        ...элементы формы...
        </FORM>

        function feedbackSubmit() {
        ...сроки кода...
        if (!validData) {
        return true }
        else {
            return false; }
        }

        Связанные элементы
        Обработчик событий для объекта form. См. объект submit.
        См. метод submit.

    onUnload
    (Обработчик события)

        Вызывается, когда пользователь выходит из документа.

        <BODY onUnload="function"> <FRAMESET onUnload="function">

        Применение

        Когда  несколько  событий  unload  включено в иерархию кадров,
    порядок операций - от дочернего к родительскому.

        Например,   событие   unload   включено   в  два  документа  и
    родительский  тег  <FRAMESET>, который загрузил их. Когда дочерний
    документ изменяется, его событие unload обрабатывается, но событие
    unload  тега <FRAMESET> не происходит. Когда пользователь выбирает
    опцию, заменяющую родительский документ на новый источник, событие
    unload самого верхнего уровня будет обработано.

        Связанные элементы
        Обработчик  события  объекта  window.  См.  обработчик события
    onLoad.

    open
    (Метод)

        Создает новый документ или экземпляр окна.

        document.open([MIMEtype])
        window.open("URL", "windowName"
        [,"windowFeatures"])

        Применение

        Для  документа  метод  open открывает поток вывода для методов
    write  или  writeln. Если тип MIME является версией text или image
    (например,  text/html  или  image/gif),  документ будет открыт для
    показа.  Иначе  поток будет направлен в plug-in. Если документ уже
    существует  в  целевом  окне,  метод  open очищает это окно. Поток
    закрывается с помощью метода document.close().
        Для  окна  метод  open  открывает новое окно броузера, подобно
    выбору   пункта  меню  File  =>  New  Web  Browser  броузера.  При
    использовании аргумента URL метод загружает в новое окно документ;
    в  противном  случае новое окно остается пустым. При использовании
    метода  в программе обработки события форма должна включать объект
    window; В противном случае подразумевается объект document.
        Параметр   windowFeatures   описывается  в  виде  разделенного
    запятыми  списка  параметров,  где -1 или «yes - включено и =0 или
    =no   -  отключено.  windowFeatures  включают  управление  выводом
    инструментальной   панели,  окна  URL,  кнопок  каталогов,  строки
    состояния,  строки  меню,  полос прокрутки, возможностью изменения
    размеров, сохранением истории навигации, шириной и высотой.

        Связанные элементы
        Метод объектов document и window.
        См. методы clear, close, write, и writeln.

    options
    (Свойство)

        Этот  массив  параметров  является  свойством  элемента  формы
    select.  Массив  создается  с помощью тегов <OPTION> внутри набора
    тегов <SELECT>.

        formName.selectName.options[index]
        forms[index].elements[index].options[index]

        Индекс  первого  параметра  -  ноль,  второго - 1 и так далее.
    Более подробная информация содержится в описании объекта select.

        Связанные элементы
        См. объект select.

    parent
    (Свойство)

        Ссылается  на  вызывающий  документ в текущем кадре, созданном
    тегом <FRAMESET>.

        parent
        parent.frameName
        parent.frames[index]
        parent.property

        Применение

        Использование  свойства  parent  дает  доступ к другим кадрам,
    созданным  тем  же  самым  тегом  <FRAMESET>.  Например, пусть два
    вызываемых  кадра  называются  index  и contents. Тогда кадр index
    может   выводить  текст  в  кадр  contents,  используя  синтаксис:
    parent.contents.document.write("Здесь был Вася")

        Связанные элементы
        Свойство объектов document и window.

    parse
    (Метод)

        Преобразует  строку  даты  типа  «Jan  11,1996»  в  количество
    миллисекунд, прошедших с полуночи 1 января 1970.

        Применение

        Эта функция может использоваться для возвращения значения даты
    на  основе  значения  строки.  При передаче строки со временем она
    возвращает значение времени.
        Так  как  parse - статическая функция объекта Date, она всегда
    используется  как  Date.parse(), a не как метод созданного объекта
    Date.

        Date.parse ("Jan 11, 1996");

        Today - new Date();

    Date.parse(Today.toLocaleString())

        Связанные элементы
        Метод объекта Date. См. метод UTC.

    parseFloat*
    (Метод)

        parseFloat(string)

        Применение

        Метод  parseFloat  анализирует строковый аргумент и возвращает
    число  с  плавающей точкой, если первый символ переданной строки —
    знак  «плюс», знак «минус», десятичная точка, число «е» (основание
    натурального  логарифма) или цифра. Если parseFloat сталкивается с
    недопустимым символом, то метод возвращает значение, основанное на
    подстроке,  следующей до этого символа, игнорируя все последующие.
    Если первый  же символ  недопустим,  parseFloat возвращает одно из
    двух значений, в зависимости от платформы:

        Windows - 0, не Windows - NaN.

        Связанные элементы
        См. методы isNaN и parseInt.

    parseInt*
    (Метод)

        Анализирует  строковый  аргумент  и  возвращает  целое  число,
    основанное на указанной системе счисления.

    parseInt(string[,radix])

        Применение

        При  параметре  radix,  равном  10, string преобразовывается в
    десятичное  число, при 8 преобразовывается в восьмеричное и при 16
    -  в  шестнадцатиричное.  Значения,  большие  10,  для  оснований,
    превышающих  10,  представляются символами от А до F вместо чисел.
    Использование  radix,  равного  2,  служит  для  преобразований  в
    двоичные  числа.  Числа  с плавающей запятой будут преобразованы в
    целые  числа.  Правила  обработки  строки  идентичны  правилам для
    parseFloat.  Если radix опущен или система счисления конфликтует с
    первыми   символами,   JavaScript  использует  систему  счисления,
    анализируя первые символы строки.

        Символы                        Система счисления

        О                              8  (восьмеричная)

        Ох                             16 (шестнадцатиричная)

        Другие                         10 (десятичная)

        Связанные элементы
        См. методы isNaN и parseFloat.

    password
    (Объект)

        Окно ввода пароля в форме HTML.

        document.formName.passwordName
        document.forms[index].element[index]

        Применение

        password   -  текстовое  поле,  в  котором  символы,  вводимые
    пользователем,  в  целях  защиты  маскируются  звездочками.  Любые
    значения  по  умолчанию,  включенные как часть области определения
    HTML,   очищаются   при  загрузке  страницы.  Эти  предотвращаются
    намеренные  или  случайные  нарушения  защиты.  Несмотря на то что
    свойство  defaultValue  допустимо для объекта password, оно всегда
    возвращает нулевое значение.
        Возвращаемое  значение  объекта password может быть программно
    обработано  внутри  сценария, однако рекомендуется не использовать
    литералы   (буквенное   значение  пароля)  в  тексте  сценария  из
    очевидных соображений безопасности.

        Связанные элементы
        Свойство объекта form.
        См. объект text.
        См. свойства defaultValue, name и value.
        См. методы focus, blur и select.

    pathname
    (Свойство)

        Извлекает из URL ту его часть, которая содержит путь.

        location.pathname
        link.pathname
        links[index].pathname

        Применение

        Хотя  pathname  может  быть  изменено  в  любое  время, всегда
    безопаснее изменить весь URL сразу, используя свойство href.

        Связанные элементы
        Свойство объекта form
        См.  свойства  hash,  host,  hostname,  href, port, protocol и
    search.

    PI
    (Свойство)

        Возвращает значение числа "pi".

    Math.PI

        Применение

        Значение числа я приблизительно равно 3.14159. Это - отношение
    длины окружности к диаметру.

        circumference = 2*Math.PI*radius
        area = Math.PI*Math.pow(radius,2)

        Связанные элементы
        Свойство объекта Math.
        См. свойства E, LN2, LN10, LOG2E, LOG10E, SQRT1_2 и
    SQRT2.

    port
    (Свойство)

        Извлекает из URL номер порта.

    location.port
    link.port
    links[index].port

        Применение

        Значение порта - подстрока свойства host в свойстве href.

        Связанные элементы
        Свойство объекта form.
        См.  свойства hash, host, hostname, href, pathname, protocol и
    search.

    pow
    (Метод)

        Возвращает основание, возведенное в степень.

    Math.pow(argument)

            Применение

        Многие   языки  программирования  используют  оператор  ^  для
    операции   возведения   в  степень.  JavaScript  имеет  для  этого
    собственный   метод.   Символ  ^  используется  в  JavaScript  для
    выполнения поразрядной операции XOR.

        Связанные элементы
        Метод объекта Math. См. методы exp и log.

    prompt
    (Метод)

        Отображает диалоговое окно ввода пользователя.

        [windowName.]prompt(message [inputDefault])

        Применение

        Если  первоначальное  значение для inputDefault не определено,
    диалоговое  окно  предлагает  значение <UNDEFINED>.

        var userid = prompt("Please enter your ID","")

        Связанные элементы
        Метод объекта window.
        См, методы alert и confirm.

    protocol
    (Свойство)

        Возвращает метод доступа к файлу.

    location.protocol
    link.protocol
    links[index].protocol

        Применение

        Строка,  возвращаемая этим свойством, - начальная часть URL до
    двоеточия  включительно. Это та часть URL, которая указывает метод
    доступа (http, ftp, mailto и т. п.).

        http                протокол передачи гипертекста
        mailto              адрес электронной почты
        news                узел новостей
        file                ссылка на файл на локальной машине
        javascript          предшествует набору команд JavaScript

        Связанные элементы
        Свойство объекта form.
        См,  свойства  hash,  host,  hostname,  href, pathname, port и
    search.

    radio
    (Объект)

        Набор переключателей.

        formName.radioName[index] forms[index].elements[index]

        Применение

        Объекты radio создаются внутри HTML-тега <FORM> и представляют
    собой  переключатели.  Набор переключателей позволяет пользователю
    выбирать   один   элемент  из  группы.  При  ссылке  на  объект  с
    использованием  имени  переключателя  индекс  состоит  из кнопок с
    одинаковым   свойством   name.   При  ссылке  на  переключатель  с
    использованием  массива elements каждый переключатель представляет
    собой отдельный элемент в индексе.

        Связанные элементы
        Свойство объекта form.
        См. объекты checkbox и select.
        См.  свойства  checked,  defaultChecked, index, length, name и
    value.
        См. метод click,
        См. обработчик события onClick.

    random
    (Метод)

        Возвращает случайное число в интервале между 0 и 1 (только для
    UNIX).

    Math.random()

        Применение

        Метод    random    реализован    только  на  UNIX-платформах -
    пользователи    Windows    и    Macintosh   должны    использовать
    альтернативную  форму  генерации  случайного  числа.  Пример такой
    формы включен в раздел «Примеры задач» в конце этой книги.

        Связанные элементы
        Метод объекта Math.

    referrer
    (Свойство)

        URL документа, который привел к текущему документу.

    document.referrer

        Применение

        Возвращает  строку  только  для  чтения, содержащую полный URL
    того  документа,  который  вызвал  текущий  документ. Это свойство
    может  использоваться  со  сценарием  CGI.  чтобы отслеживать, как
    пользователь перешел к текущей странице.

    document.write("Щелкните <А HREF=\'"+document.referrer+"\'>здeсь,</A>
    чтобы   вернуться   к   предыдущей странице.")

        Связанные элементы
        Свойство объекта form.

    reset
    (Объект)

        Кнопка   для   возвращения  всем  объектам  form  значений  по
    умолчанию.

        formName.resetButtonName forms[index).elements[index]

        Применение

        Этот  объект  соответствует кнопке Reset, созданной тегом HTML
    <INPUT TYPE="Reset">, возвращающей все объекты form к их значениям
    по умолчанию.
        Объект  reset должен быть создан внутри тега <FORM> и не может
    управляться  из  программы  обработки события onClick. При нажатии
    кнопки все объекты формы возвращаются к их значениям по умолчанию.
    Однако  программа об* работки события onClick может в дополнение к
    восстановлению значений по умолчанию вызывать другие действия.

        Связанные элементы
        Свойство объекта form.
        См. объекты button и submit.
        См. свойства name и value.
        См. метод click.
        См. обработчик события onClick.

    round
    (Метод)

        Округляет число до ближайшего целого.

    Math.round(argument)

        Применение

        Округляет  аргумент  с плавающей точкой до ближайшего большего
    целого  числа,  если десятичная часть больше или равна 0.5, или до
    ближайшего  меньшего  целого  числа, если десятичная часть меньше,
    чем 0.5.

        Math.round(2.1)  // Возвращает 2
        Math.round(2.9) // Возвращает 3

        Связанные элементы
        Метод объекта Math.

    search
    (Свойство)

        Возвращает любую информацию запроса, присоединенную к URL.

        location.search linkName.search links[index].search

        Применение

        Возвращает   строку,   содержащую  любую  информацию  запроса,
    добавленную  в  конец  URL.  Данные  запроса  предваряются  знаком
    вопроса и являются последним элементом в URL документа. Информация
    в строке форматируется так:

    ?elementName=element+value

        Подобно  всем  подстрокам свойства href, свойство search может
    быть изменено в любое время.

        Связанные элементы
        Свойство объекта form.
        См.  свойства  hash,  host,  hostname,  href, pathname, port и
    protocol.

    select
    (Метод)

        Выделяет область ввода указанного элемента формы.

    formName.elementName.select()
    forms[index].elements[index].select()

        Применение

        При  использовании  вместе  с  методом  focus  метод  select в
    JavaScript может выделить поле и установить курсор для ввода.

        Связанные элементы
        Метод  объектов  password,  text и textarea. См. методы blur и
    focus.

    select
    (options array)(Объект)

        Раскрывающийся  список  или  список  с множественным выбором в
    форме HTML.

    formName.selectName
    forms[index].elements[index]
    formName.selectName[index].options[index]
    forms[index].elements[index].options[index]

        Применение

        Список  выбора позволяет пользователю выбирать один элемент из
    списка.   Список   прокрутки  допускает  выбор  любого  количества
    элементов из списка при наличии атрибута MULTIPLE во входном теге.
        Будучи  использованным  без  массива параметров, объект select
    ссылается  на  весь список, используя свойства типа length и name.
    Свойства value и selectedIndex указывают на текущий выбор в списке
    выбора или на первый выделенный элемент в списке прокрутки.

        Связанные элементы
        Свойство объекта form.
        См. объект radio.
        См. свойства length, name, options и selectedIndex
        См. методы blur и focus.
        См, обработчики события onBlur, onChange и onFocus
        Для  получения  дополнительной  информации  о свойстве options
    объекта select см. свойства defaultSelected, index, selected, text
    и value.

    selected
    (Свойство)

        Возвращает  логическое  значение  (true  или false), показывая
    текущее состояние параметра в объекте select.

    formName.elementName.[options[index].]selected
    forms[index].elements[index].[options[index].]selected

        Применение

        Свойство  selected  может  быть  изменено  в  любой  момент  и
    результат  изменения  будет немедленно отражен на экране. Свойство
    selected  удобно  использовать  с  элементами select, созданными с
    использованием атрибута MULTIPLE.
        При  использовании свойства select вы можете просматривать или
    изменять  значение любого элемента в массиве options без изменения
    значений любых других элементов в массиве.

        Связанные элементы
        Свойство объекта options.
        См. свойства defaultSelected, index и selectedIndex.

    selectedIndex
    (Свойство)

        Возвращает   целое   число,   указывающее   индекс  выбранного
    элемента.

    formName.elementName.[options[index].]selectedlndex
    forms[index].elements[index].[options[index].]selectedlndex

        Применение

        Свойство   selectedIndex   удобно  использовать  с  элементами
    select,  созданными  без  использования  атрибута  MULTIPLE в теге
    <SELECT>.   Если   selectedIndex  определяется  при  установленном
    атрибуте  MULTIPLE,  свойство  возвращает  индекс  только  первого
    выделенного   элемента.   Установка   этого   свойства  сбрасывает
    выделение любых других элементов.

        Связанные элементы
        Свойство объектов select, options.
        См. свойства defaultSelected, index и selected.

    self
    (Свойство)

        Ссылается на текущее окно или форму.

        self

        Применение

        Свойство  self  полезно для устранения неоднозначности свойств
    form и window с одним и тем же именем.

        Связанные элементы
        Свойство объектов frame и window. См. свойство window.

    setDate
    (Метод)

        Устанавливает день месяца.

        Date.setDate(argument) dateName.setDate(argument)

        Применение

        SetDate  использует  целое  число  в  диапазоне от 1 до 31 для
    установки дня месяца в объекте Date.

        endOfTheWorld = new Date("January 11, 1996 06:18:00")
        endOfTheWorld.setDate(26)
        document.write(endOfTheWorld.getDate())
        //Возвращает 26

        Связанные элементы
        Метод объекта Date. См. метод getDate.

    setHours
    (Метод)

        Устанавливает час для текущего времени.

        Date.setHours(argument) dateName.setHours(argument)

        Применение

        SetHours  использует  целое  число  от  0  (полночь) до 23 для
    установки часа, используя 24-часовую шкалу.

        Связанные элементы
        Метод объекта Date. См. метод getHours.

    setMinutes
    (Метод)

        Устанавливает минуты для текущего времени.

        Date.setMinutes(argument) dateName.setMinutes(argument)

        Применение

        Использует  целые  числа  от  0  до 59 для установки минут для
    объекта Date.

        Связанные элементы
        Метод объекта Date. См. метод getMinutes.

    setMonth
    (Метод)

        Устанавливает значение месяца для объекта Date.

        Date.setMonth(argument) dateName.setMonth(argument)

        Применение

        Использует  целые  числа  от  0  (январь) до 11 (декабрь). Это
    единственный   элемент   объекта   Date,   который   отступает  от
    стандартных   соглашений   по  нумерации  дат  и  времени.  Будьте
    внимательны при переводе значений месяца из сценария на JavaScript
    в форму для пользователей.

        Связанные элементы
        Метод объекта Date. См. метод getMonth.

    setSeconds
    (Метод)

        Устанавливает секунды.

        Date.setSeconds(argument) dateName.setSeconds(argument)

        Применение

        Использует  целые  числа  от  0 до 59 для установки секунд для
    объекта   Date.   Несмотря   на  то  что  объект  Date  использует
    миллисекунды    для   отслеживания   времени,   секунды   являются
    минимальным  уровнем  детализации,  допустимым  при вводе значения
    времени.

        Связанные элементы
        Метод объекта Date. См. метод getSeconds.

    setTime
    (Метод)

        Устанавливает значение объекта Date.

    dateName.setTime(argument)

        Применение

        Это  основная  форма объекта Date. Метод возвращает количество
    миллисекунд,  прошедших  с  полуночи  1 января 1970 года. Хотя нет
    необходимости  знать  конкретное  значение  этого числа, оно может
    быть использовано как простейший метод копирования значения одного
    объекта типа Date в другой.

        endOfTheWorld = new Date(userGuess)
        checkDate = new Date()
        checkDate.setTime(endOfTheWorld.getTime())

        Связанные элементы
        Метод объекта Date. См. метод getTime.

    setTimeout
    (Метод)

        Исполняет  выражение  по  истечении указанного в миллисекундах
    промежутка времени.

        [window.]setTimeout(timerID)
        [windowName.]setTimeout(timerID)

        Применение

        Исполнение  выражения  происходит  только  один раз. Например,
    установка   промежутка   в   3  секунды  приведет  к  однократному
    исполнению выражения по истечении этих 3 секунд, а не к повторению
    каждые 3 секунды.
        Для  рекурсивного вызова метода setTimeout достаточно вставить
    в  вызываемую функцию новый вызов метода setTimeout. Вызов функции
    startclock в нижеприведенном примере запускает бесконечный цикл, в
    котором  таймер  сбрасывается,  затем  на  экран выводится текущее
    время  и,  наконец,  заново устанавливается промежуток времени в 1
    секунду для вывода очередного значения времени.
    см. пример "setTimeout"

    <SCRIPT>
        var timerID = null;
        var timerRunning = false;
        function stopclock () {
          if(timerRunning) clearTimeout (timerID);
          timerRunning=false;
        }
        function startclock() {
        stopclock();
        showtime();
        }
        function showtime() {
          var now = new Date();
          document.clock.display.value = now.toLocaleString();
          timerID = setTimeout("startclock()",1000);
          timerRunning = true;
        }
    </SCRIPT>
    <BODY onLoad="startclock()">
    <FORM NAME="clock">
    <INPUT ITEM=text NAME="display" VALUE="Standby for the time">
    </FORM>
    </BODY>

        Связанные элементы
        Метод объекта window. См. метод clearTimeout.

    setYear
    (Метод)

        Устанавливает значение года для объекта Date.

        Date.setYear(argument) dateName.setYear(argument)

        Применение

        Параметром  метода  setYear  является  двузначное целое число,
    представляющее номер года минус 1900.

        Связанные элементы
        Метод объекта Date. См. метод getYear.

    sin
    (Метод)

        Возвращает синус аргумента.

        Math.sin(argument)

        Применение

        Аргументом  является  величина  угла  в радианах, возвращаемое
    значение может быть от -1 до 1.

        Связанные элементы
        Метод объекта Math.
        См. методы acos, asin, atan, cos и tan.

    small
    (Метод)

        stringName.small()

        Применение

        Метод  small  уменьшает  шрифт,  которым  отображается  объект
    string, используя тег HTML <SMALL>.

        Связанные элементы
        Метод объекта string.
        См. методы big и fontsize.

    sqrt
    (Метод)

        Возвращает квадратный корень из положительного числа.

        Math.sqrt(argument)

        Применение

        Если аргумент отрицателен, возвращается число 0.

    SQRT1_2
    (Свойство)

        Квадратный корень из 1/2.

        Math.SQRT1_2

        Применение

        Квадратный  корень  из  1/2  (приблизительно 0.707) может быть
    также представлен как величина, обратная квадратному корню из 2.

        Связанные элементы
        Свойство объекта Math.
        См. свойства E, LN2, LN10, LOG2E, LOG10E, PI и SQRT2.

    SQRT2
    (Свойство)

        Квадратный корень из 2.

        Math.SQRT2

        Применение

        Значение этой константы приблизительно равно 1.414.

        Связанные элементы
        Свойство объекта Math.
        См. свойства E, LN2, LN10, LOG2E, LOG10E, PI и SQRT1_2
    status
    (Свойство)

        Устанавливает  текст  основного  или  временного  сообщения  в
    строке состояния.

        window.status [windowName].status

        Применение

        Строка состояния находится в нижней части окна броузера. Вызов
    временного  сообщения  должен  быть  вставлен  в текст обработчика
    события  mouseOver  из  тега  <А. . . >. Чтобы вывести сообщение в
    строке  состояния в тот момент, когда указатель мыши находится над
    гиперссылкой, надо сделать так:

    <А anchorDefinition onMouseOver="window.status='Your message.';
    return true">link</A>

        Обратите   внимание   на   вложенные  кавычки  и  обязательное
    возвращаемое значение true.
        Однажды  вызванное,  сообщение  остается в строке состояния до
    тех пор, пока указатель мыши не окажется над другой гиперссылкой.

        Связанные элементы
        Свойство объекта window.
        См. свойство defaultStatus.

    string
    (Объект)

        Последовательность   символов,   ограниченная  одинарными  или
    двойными кавычками.

        stringName

        Применение

    Например:

        myDog = "Brittany Spaniel"

    возвращает   строковый   объект,  названный  myDog,  со  значением
    Brittany Spaniel. Кавычки не являются частью значения строки - они
    только ограничивают строку с обеих сторон.
        Значение строкового объекта можно изменять при помощи методов,
    возвращающих      преобразованную      строку,     -     например,
    myDog.toUpperCase()  вернет  BRITTANY  SPANIEL.  Строковые объекты
    включают  также  методы  вывода  строки  в окне броузера, например
    жирным или наклонным шрифтом и другие.

        Связанные элементы
        См. объекты text и textarea. См. свойство length.
        См. методы anchor, big, blink, bold, charAt, fixed, fontcolor,
    fontsize, indexOf, italics, lastlndexOf, link, small, strike, sub,
    substring, sup, toLowerCase и toUpperCase.

    strike
    (Метод)

        Форматирует строковый объект как зачеркнутый текст.

        stringName.strike()

        Применение

        Использование   метода   strike   аналогично  применению  тега
    HTML<STRIKE>.

        Связанные элементы
        Метод объекта string.
        См. методы blink, bold и italics.

    sub
    (Метод)

        Форматирует строковый объект как нижний индекс.

        stringName.sub()

        Применение

        Использование метода sub аналогично применению тега HTML<SUB>.

        Связанные элементы
        Метод объекта string. См. метод sup.

    submit
    (Объект)

        Кнопка отправки данных на странице HTML.

        formName.buttonName
        forms[index].elements[index]

        Применение

        Щелчок  на кнопке заставляет форму отправить данные программе,
    указанной  в  свойстве  action.  Кнопка создается внутри тега HTML
    <FORM>  и всегда загружает новую страницу, которая может оказаться
    той же, что и текущая, если свойство action не указано.

        Связанные элементы
        Свойства объекта form.
        См..объекты button и reset.
        См. свойства name и value.
        См. метод click.
        См. обработчик событий onClick.

    submit
    (Метод)

        Производит действие, аналогичное щелчку по кнопке Submit

        formName.submit() forms[index].submit()

        Применение

        Метод отсылки информации из формы зависит от значения атрибута
    METHOD - get или post.

        Связанные элементы
        Метод объекта form.
        См. объект submit.
        См. обработчик события onSubmit.

    substring
    (Метод)

        Возвращает часть строкового объекта в зависимости от индексов.

        stringName.substring(index1, index2)

        Применение

        Если   индексы   равны,   возвращается   пустая   строка.  Вне
    зависимости  от порядка индексов подстрока формируется от меньшего
    индекса к большему.

        Связанные элементы
        Метод объекта string.

    sup
    (Метод)

        Форматирует строковый объект как верхний индекс.

        stringName.sup()

        Применение

        Использование метода sub аналогично применению тега HTML<SUB>.

        Связанные элементы
        Метод объекта string. См. метод sub.

    tan
    (Метод)

        Возвращает тангенс аргумента.

        Math.tan(argument)

        Применение

        Аргументом является величина угла в радианах.

        Связанные элементы
        Метод объекта Math.
        См. методы acos, asin, atan, cos, sin.

    target
    (Свойство)

        Строка,  указывающая  имя  окна, в которое будет помещен ответ
    после посылки данных формы серверу.

        formName.target
        forms[index].target
        location.target
        link.target
        links[index].target

        Применение

        Обычно  используется  для  просмотра ответа сервера на посылку
    данных.  Кроме  того,  может  быть  использовано для просмотра или
    изменения   URL   гиперссылки.  Для  гиперссылки  свойство  target
    возвращает  строку,  указывающую  имя  окна, в котором должно быть
    выведено содержимое выбранной гиперссылки,

        homePage.target = "http://www.wossamotta.edu/"

        Для  установки  свойства  target  нужно использовать константу
    типа литерал. Выражения JavaScript или переменные недопустимы.

        Связанные элементы
        Свойство  объектов form, link и location. См. свойства action,
    encoding и method.

    text
    (Объект)

        Однострочное поле ввода формы HTML.

    formName.textName
    forms[index].elements[index]

        Применение

        Объекты  text  допускают  ввод  букв и цифр. Объект text может
    быть изменен путем присваивания нового значения.

        Связанные элементы
        Свойство объекта form.
        См.   объекты   password,  string  и  textarea.  См.  свойства
    defaultValue, name и value. См. методы focus, blur и select.
        См. обработчики событий onBlur, onChange, onFocus и onSelect.

    text
    (Свойство)

        Возвращает  текст,  записанный  после  тега <OPTION> в объекте
    select.

        formName.selectName.options[index].text
        forms[index].elements[index].options[index].text

        Применение

        Свойство  text  может  быть  также  использовано для изменения
    значения   элемента   списка,  за  важным  исключением:  изменение
    значения не приводит к немедленному отображению на экране.

        Связанные элементы
        Свойство объекта options.

    textarea
    (Объект)

        Объект    textarea    подобен   объекту   text,   дополненному
    возможностью многострочного ввода.

        formName.textAreaName
        forms[index].elements[index]

        Применение

        Объект  textarea  также  может быть изменен путем присваивания
    нового значения. Это изменение немедленно отражается на экране.

    <FORM>
        <ITEM  INPUT=textarea  NAME="sponsorMessage"  VALUE="Внимание,
            примите сообщение от нашего спонсора.">
    </FORM>
    <SCRIPT>
    sponsorMessage.value = "А теперь — самое время \r\n
    брать ноги в руки \r\n и смываться отсюда.
    </SCRIPT>

        Обратите  внимание  на использование символа перехода на новую
    строку   \n.  Реализация  перехода  на  новую  строку  зависит  от
    платформы.  Для  Windows это комбинация \r\n; для Macintosh и UNIX
    это \n.
        При   определении  объекта  textarea  в  форме  можно  указать
    значение  по  умолчанию,  введя  текст  между  тегами  <TEXTAREA>.
    Следующий  пример загружает три строки текста и одну пустую строку
    в элемент textarea:

    <BR><TEXTAREA  NAME="user_comments" ROWS=4  COLS=40>  Введите свой
      комментарий. Затем щелкните на  кнопке  Submit,  чтобы отправить
        его нам.
    </TEXTAREA>

        Связанные элементы
        Свойство  объекта  form.  См. объекты password, string и text.
    См.  свойства defaultValue, name и value. См. методы focus, blur и
    select.
        См. обработчики событий onBlur, onChange, onFocus и onSelect.

    title
    (Свойство)

        Возвращает  значение  только для чтения, указанное внутри тега
    HTML<TITLE>.

    document.title

        Применение

        Если  в  документе  заголовок отсутствует, значение свойства -
    null.

        Связанные элементы
        Свойство объекта document.

    toGMTString
    (Метод)

        Преобразует  объект  типа  Date  в строку на основе соглашений
    InternetGMT.

        Date.toGMTString() dateName.toGMTString()

        Применение

        Этот  метод возвращает время в формате GMT, который зависит от
    платформы.
        Например,  если  today  представляет  собой  объект  Date,  то
    выражение

    today.toGMTString()

        возвратит  строку  «Thu,  11  Jan  1996 06:05:15». Фактический
    формат  может  различаться  от  платформы к платформе Время и дата
    определяются на клиентском компьютере.

        Связанные элементы
        Метод объекта Date.
        См. метод toLocaleString.

    toLocaleString
    (Метод)

        Преобразует  объект  типа  Date  в строку, используя локальные
    установки.

        Date.toLocaleString() dateName.toLocaleString()

        Применение

        Возвращаемая  строка  со  значением  даты зависит от установок
    клиентского компьютера, например mm/dd/yy hh:mm:ss.

        Связанные элементы
        Метод объекта Date.
        См. метод toGMTString.

    toLowerCase
    (Метод)

        Преобразует все символы строки к нижнему регистру.

    stringName.toLowerCase()

        Применение

        Результатом использования метода toLowerCase является вывод на
    экран  строки  символами  нижнего  регистра. Следует отметить, что
    реальное содержимое строки не изменяется.

        Связанные элементы
        Метод объекта string. См. метод toUpperCase.

    top
    (Свойство)

        Объект window высшего уровня.

        top
        top.frameName
        top.frames[index]

        Применение

        Называемое  также  предком  или  окном  броузера, свойство top
    ссылается  на  окно  высшего  уровня,  содержащее кадры или наборы
    вложенных кадров.

        Связанные элементы
        Свойство объекта window.

    toUpperCase
    (Метод)

        Преобразует все символы строки к верхнему регистру.

        stringName.toUpperCase()

        Применение

        Несмотря  на то, что метод toUpperCase выводит на экран строку
    символами   верхнего   регистра,  реальное  содержимое  строки  не
    изменяется.

        Связанные элементы
        Метод объекта string.
        См. метод toLowerCase

    unescape*
    (Метод)

        Возврвщает символ на основании кода ASCII.

        unescape(string)

        Применение

        Строка-аргумент  может  включать  последовательности вида %ХХ,
    где  ХХ  -  шестнадцатиричное представление кода символа (от 00 до
    FF). Например,

        document.write(unescape("%24 223.23"))

        выведет на экран строку $223.23.

        Связанные элементы
        См. метод escape.

    userAgent
    (Свойство)

        Заголовок,  посылаемый  как  часть протокола HTTP от клиента к
    серверу для идентификации типа клиента.

        navigator.userAgent

        Применение

        Синтаксис  возвращаемого  значения  такой  же,  как у свойства
    appVersion, дополненный кодовым именем приложения броузера.

        codename/releaseNumber(platform; country)

        Связанные элементы
        Свойство объекта navigator.
        См. свойства appName, appVersion и appCodeName.

    UTC
    (Метод)

        Возвращает   количество   миллисекунд   для   даты   на   базе
    универсального   координированного   времени  (UTC),  прошедших  с
    полуночи 1 января 1970 года.

        Date.UTC(year, month, day, [, hrs][, min] [, sec])

        Применение

        Метод  UTC всегда вычисляется от одной и той же даты и поэтому
    всегда  используется  как  Date.UTC(),  а  не  с  заданным заранее
    объектом.  При  указании  значения  для  месяца  не забывайте, что
    JavaScript нумерует месяцы от 0 до 11.

        Связанные элементы
        Метод объекта Date. См. метод parse.

    value
    (Свойство)

        Возвращает значение объекта

        formName.buttonName.value
        formName.resetName.value
        formName.submit.value
        formName.checkboxName.value
        formName.radioName.value
        formName.hiddenName.value
        formName.textName.value
        formName.textareaName.value
        formName.selectName.value
        formName.passwordName.value
        forms[index].elements[index].value

        Применение

        Значение объекта зависит от его типа.
        --------------------------------------------------------------
        Объект                    | Значение свойства Value
        --------------------------------------------------------------
        button, reset, submit     | Надпись   на   кнопке,  но  не имя
                                  | кнопки
        --------------------------------------------------------------
        checkbox                  | On для отмеченного элемента, off -
                                  | для неотмеченного
        --------------------------------------------------------------
        radio                     | Строковое представление значения
        --------------------------------------------------------------
        hidden, text, textarea    | Содержимое поля
        --------------------------------------------------------------
        select                    | Представление  значения выбранного
                                  | элемента
        --------------------------------------------------------------
        password                  | Возвращает допустимое значение  по
                                  | умолчанию, но зашифрованное значе-
                                  | ние модифицируется пользователем
        --------------------------------------------------------------
        Изменение  значения  для объектов text или textarea немедленно
    отображается на экране. Изменение значений всех остальных объектов
    формы на экране не отображается.

        Связанные элементы
        Свойство объектов button, checkbox, hidden, options, password,
    radio, reset, submit, text и textarea.
        Для   объектов   password,   text   и  textarea  см.  свойство
    defaultValue.
        Для объектов button, reset и submit см. свойство name.
        Для  свойства  options см. свойства defaultSelected, selected,
    selectedIndex и text.
        Для   объектов   checkbox  и  radio  см.  свойства  checked  и
    defaultChecked.

    vlinkColor
    (Свойство)

        Возвращает или устанавливает цвет просмотренной гиперссылки.

        document.vlinkColor

        Применение

        Как  и  все  свойства  цвета,  свойство  vlinkColor использует
    шестнадцатиричные триплеты RGB или строковые литералы.
        Это  свойство  не  может  быть  установлено  после  того,  как
    документ  отформатирован.  Для  переопределения установок броузера
    настройка  цветов  выполняется в обработчике событий onLoad в теге
    <BODY>:

        <BODY onLoad="document.vlinkColor='aliceblue'">

        Связанные элементы
        Свойство объекта document.
        См. свойства alinkColor, bgColor, fgColor и linkColor.

    window
    (Объект)

        Наивысший  объект  в иерархии JavaScript, представляющий собой
    открытое окно броузера.

        window
        self
        top
        parent
        windowName
        propertyName
        methodName(parameters)

        Применение

        Объект window создается броузером во время загрузки страницы и
    содержит  свойства,  применяемые ко всему окну. Это объект высшего
    уровня  для  каждого из объектов document, location и history. Так
    как  существование  этого  объекта  подразумевается,  вам  не надо
    указывать   имя  окна,  ссылаясь  на  его  объекты,  свойства  или
    методы.
        Например,  следующие  две  строки  приводят к одному и тому же
    результату (выводу сообщения в строке состояния):

        status="Go away from here." window.status="Go away from here."

        Существует  несколько  способов  ссылки  на  объект  window, в
    зависимости  от его отношения к текущему положению, как показано в
    таблице.

        Псевдоним         Описание
        --------------------------------------------------------------
        window,  self       Окно,  содержащее  текущий  документ. Если
                            эти псевдонимы опущены, все равно подразу-
                            мевается  текущий  документ.  Исключениями
                            являются   обработчики  ошибок, в  которых
                            методы  типа  open  и  close  должны  быть
                            указаны с определенным окном и кадром
        --------------------------------------------------------------
        top                 Ссылается на окно самого высокого  уровня.
                            Полезно в случае  сложной иерархии кадров,
                            созданной  с  использованием  многих тегов
                            <FRAMESET>
        --------------------------------------------------------------
        parent              Окно, содержащее тег <FRAMESET>, создавший
                            текущий кадр
        --------------------------------------------------------------
        windowName          Используется для указания на объект window
                            в тегах HTML.  При  использовании  свойств
                            и  методов  объектов  window   используйте
                            имя переменной типа window
        --------------------------------------------------------------
        Создание нового окна с помощью метода open:

    aNewWindow = window.open("URL","Window_Name" [,"windowFeatures"])

        Имя  переменной  используется  для ссылки на свойства и методы
    окна.  Параметр  Window_Name используется в аргументе target тегов
    <FORM. . . > или <А. . . >. Параметры windowFeatures (см. таблицу)
    управляют  представлением  и  функциональностью броузера.
        Если  ни  один  параметр  из  списка windowFeatures не указан,
    используются значения параметров по умолчанию. Если же указан хотя
    бы   один  параметр  из  списка  windowFeatures,  все  неуказанные
    параметры исключаются.

        Параметр         Применение
        --------------------------------------------------------------
        toolbar          Выводит   стандартную   панель  инструментов,
                         включая  кнопки  Forward,  Back,  перехода  к
                         домашней странице и печати
        --------------------------------------------------------------
        location         Выводит строку URL
        --------------------------------------------------------------
        directories      В  Netscape  Navigator,  выводит набор кнопок
                         для стандартных ссылок, таких как What's New,
                         What's Cool и Handbook
        --------------------------------------------------------------
        status           Выводит строку состояния внизу экрана
        --------------------------------------------------------------
        menubar          Выводит   меню   в   верхней   части  экрана,
                         включающее пункты File, Edit и View
        --------------------------------------------------------------
        scrollbars       Добавляет линейки прокрутки, если документ не
                         помещается на экран
        --------------------------------------------------------------
        resizable        Позволяет пользователю изменять размер окна
        --------------------------------------------------------------
        width            Первоначальная ширина окна в пикселях
        --------------------------------------------------------------
        height           Первоначальная высота окна в пикселях 1
        --------------------------------------------------------------

        Связанные элементы
        См. объекты document и frame.
        См.  свойства defaultStatus, frames, parent, self, status, top
    и window.
        См.  методы  alert, close, confirm, open, prompt, setTimeout и
    clearTimeout.
        См. обработчики событий onLoad и onUnload.

    window
    (Свойство)

        Синоним текущего окна.

        frameName.window [windowName.]window

        Применение

        Свойство  window  используется  для устранения неоднозначности
    при  ссылках  на  объекты  window и form с одинаковым именем. Хоть
    свойство   window   также   относится   к   текущему   кадру,  для
    определенности лучше использовать свойство self.

        Связанные элементы
        Свойство объектов frame и window. См. свойство self.

    write
    (Метод)

        Записывает строку или несколько строк в окно документа.

        document.write(string)

        Применение

        Строки, записываемые в окно, могут включать в себя теги HTML и
    выражения  JavaScript,  включая  числовые,  строковые и логические
    выражения.  Метод write не добавляет символ новой строки (<BR> или
    /n)  в  конце  строки. Когда метод write вызывается из обработчика
    события,  текущей документ очищается, если для вывода не создается
    новое окно.

        Связанные элементы
        Метод объекта document.
        См. методы close, clear, open и writeln.

    writeln
    (Метод)

        Записывает  строку  или  несколько  арок  в  окно  документа и
    добавляет символ новой строки в конце вывода.

        document.writeln(string)

        Применение

        Подобно  методу  write,  записываемые  строки могут включать в
    себя  теги  HTML  и  выражения  JavaScript,  в том числе числовые,
    строковые  и  логические выражения. Когда метод writeln вызывается
    из  обработчика  события,  текущей  документ  очищается,  если для
    вывода  не  создается  новое  окно.  HTML  игнорирует символ новой
    строки, за исключением использования его внутри тега <PRE>.

        Связанные элементы
        Метод объекта document.
        См. методы close, clear, open и write.

    All materials © by Nic & Makkintosh Corp
    For additional info or suggestions, please, contact: zn@nm.ru