Справочник по CSS — Справочник Web-языков

Справочник по CSS

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная ::. CSS

[править] Разделы справки

  • Что такое CSS и как применить
  • Свойства шрифта
  • Цветовая гамма
  • Свойства текста
  • Свойства текста, содержащего иероглифы
  • Расположение элементов
  • Границы элементов
  • Классификации
  • Принтер
  • Псевдостили гиперссылок
  • Псевдостили текста
  • Правила

[править] Фильтры в Internet Explorer

  • Пару вводных слов
  • Статические фильтры
  • Динамические фильтры
    • Barn
    • Blinds
    • CheckerBoard
    • Fade
    • GradientWipe
    • Inset
    • Iris
    • Pixelate
    • RadialWipe
    • RandomBars
    • RandomDissolve
    • Slide
    • Spiral
    • Stretch
    • Strips
    • Wheel
    • ZigZag

[править] Приложения

  • Единицы измерения CSS

[править] Полезные ссылки

  • Форум по CSS
Получено с http://spravkaweb.local/index.php/css
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 09:00, 26 марта 2007.
  • К этой странице обращались 562 раза.
  • Политика конфиденциальности
  • Описание Справочник Web-языков
  • Отказ от ответственности
9.58185195923


Разработка сайтов — Справочник Web-языков

Разработка сайтов

Главная ::. Разработка сайтов
Этот раздел находится на стадии разработки!

Разработка сайтов любой сложности. Доработка текущих проектов. Внедрение CRM-систем. Делаю качественно и в самые короткие сроки.

  • Резюме
  • Портфолио
Получено с http://spravkaweb.local/index.php/development
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 19:59, 30 марта 2007.
  • К этой странице обращались 25 раз.
  • Политика конфиденциальности
1.45229291916


Скачать offline-версию справочника SpravkaWeb.ru — Справочник Web-языков

Скачать offline-версию справочника SpravkaWeb.ru

[править] Offline-версия сайта SpravkaWeb.ru от 31 марта 2007 года

Много html-файлов (zip-архив)
5 220 Кб
Много html-файлов (tar.gz-архив)
4 603 Кб
Один chm-файл (zip-архив)
3 186 Кб
Один chm-файл (tar.gz-архив)
3 186 Кб

По всем вопросам и замечаниям пишите по адресу admin@spravkaweb.ru

Получено с http://spravkaweb.local/index.php/download
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 20:52, 31 марта 2007.
  • К этой странице обращались 56 раз.
1.33675098419


Справочник по Flash — Справочник Web-языков

Справочник по Flash

Главная ::. Flash

[править] Разделы справки

  • ActionScript
    • Basic Actions
      • gotoAndPlay - Переход на кадр и воспроизведение
      • gotoAndStop - Переход на кадр и остановка
      • nextFrame - Переход на следующий кадр
      • prevFrame - Переход на предыдущий кадр
      • nextScene - Переход на следующую сцену
      • prevScene - Переход на предыдущую сцену
      • Play - Воспроизведение
      • Stop - Остановка
      • toggleHighQuality - Изменение качества
      • stopAllSounds - Остановка всех звуков
      • getURL - Переход на веб-страницу
      • fscommand - Передача данных браузеру
      • loadMovie - Загрузить файл .swf
      • loadMovieNum - Загрузить файл .swf
      • unloadMovie - Удалить фильм или клип из проигрывателя
      • unloadMovieNum - Удалить фильм из проигрывателя
      • tellTarget - Обратиться к удаленному клипу
      • ifFrameLoaded - Выполняет код если загруженн определенный кадр
    • Action
      • break - Прекращает выполнение цикла
      • call - Выполнить сценарий удаленного клипа
      • comment - Вставить комментарии
      • continue - Заново начинает текущий цикл
      • delete - Удаление объекта, элемента массива или переменной
      • duplicateMovieClip - Создать копию клипа
      • evaluate - Создает новую пустую строку, и вставляет ;
      • for - Многократно выполняет некоторый код
      • for...in - Цикл, используемый для перечисления свойств объекта
      • fscommand - Передача данных браузеру
      • function - Создает новую функцию
      • getURL - Переход на веб-страницу
      • if - Выполнение или не выполнение предложений в зависимости от условий
      • ifFrameLoaded - Выполняет код если загруженн определенный кадр
      • include - Импорт текста из внешнего файла ActionScript
      • loadMovie - Загрузить файл .swf
      • loadMovieNum - Загрузить файл .swf
      • loadVariables - Загружает в клип или фильм внешние переменные
      • loadVariablesNum - Прикрепляет группу внешних переменных к уровню документа
      • print - Вывод на печать кадров фильма или клипа с использованием векторной графики
      • printNum - Печать кадров уровня документа как векторных изображений
      • printAsBitmap - Вывод на печать кадров фильма или клипа с использованием растровой графики
      • printAsBitmapNum - Печать кадров уровня документа как растровых изображений
      • removeMovieClip - Удалить клип фильма из Flash Player
      • return - Выходит из функции или возвращает ее значение
      • setProperty - Присвоить значение свойству клипа фильма
      • startDrag - Заставляет фильм или клип следовать за курсором мыши
      • Stop - Остановить воспроизведение фильма на текущем кадре
      • stopAllSounds - Выключить все звуки
      • stopDrag - Останавливает текущую операцию перетаскивания
      • tellTarget - Обратиться к удаленному клипу
      • toggleHighQuality - Изменение качества
      • unloadMovie - Удалить фильм или клип из проигрывателя
      • unloadMovieNum - Удалить фильм из проигрывателя
      • var - Объявление локальной переменной
      • while - Многократно выполняет некоторый код
      • with - Выполняет некоторый код в конце указанного объекта

[править] Полезные ссылки

  • Форум по Flash
Получено с http://spravkaweb.local/index.php/flash
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 12:47, 20 марта 2007.
  • К этой странице обращались 397 раз.
2.22694706917


Справочник по HTML — Справочник Web-языков

Справочник по HTML

Главная ::. HTML

[править] Разделы справки

  • Структура документа
  • Заголовки и названия
  • Параграфы и строки
  • Стили текста
  • Списки.Ссылки
  • Таблицы
  • Графика, объекты, мультимедиа, сценарий
  • Формы
  • Фреймы

[править] Алфавитный указатель атрибутов

Все :: A :: B :: C :: D :: E :: F :: G :: H :: I :: L :: M :: N :: P :: R :: S :: T :: U :: V :: W :: Z

[править] Советы

  • Внедрение элементов в html-страницу
    • Как вставить в html-страницу документы MS Office (Word, Excel и т.д.)

[править] Приложения

  • Коды и обозначения символов
  • Коды и названия цветов
  • Коды языков HTML

[править] Полезные ссылки

  • Форум по HTML
Получено с http://spravkaweb.local/index.php/html
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 11:07, 21 марта 2007.
  • К этой странице обращались 717 раз.
2.33159899712


php/sover/nocash — Справочник Web-языков

php/sover/nocash

Страница-перенаправление
Перейти к: навигация, поиск
php/sovet/nocash
Получено с http://spravkaweb.local/index.php/php/sover/nocash
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 13:30, 18 марта 2007.
  • К этой странице обращались 19 раз.
1.59290981293


Справочкик по JavaScript — Справочник Web-языков

Справочкик по JavaScript

Главная ::. JavaScript

[править] Разделы справки

  • Совместное использование HTML и JavaScript
    • Правила написания скриптов
    • Объектная модель документа
  • Объект document
    • Свойства
    • Методы
    • Коллекция объектов
    • Подчиненные объекты и коллекции объекта document
    • Обращение к элементам страницы
  • Объект location
  • Объект style
    • Свойства и методы
    • Работа с объектом style
    • Объект style в Internet Explorer
    • Объект style в Navigator. JavaScript-стили
  • Объект window
    • Свойства
    • Методы
    • Свойства окна, передаваемые методу open
    • Работа с окнами
  • Объект layer
    • Доступ к слоям
    • Свойства
    • Методы
  • Объект navigator
  • Объект screen
  • Объект history

[править] Алфавитный указатель свойств

Все :: A :: B :: C :: D :: E :: F :: H :: I :: K :: L

[править] Алфавитный указатель методов

Все :: A :: B :: C :: D :: E :: F :: G :: H :: I :: J :: L :: M :: N :: O :: P :: Q :: R :: S :: T :: U :: W

[править] Алфавитный указатель событий браузера

Все :: A :: B :: C :: D :: E :: F :: H :: K :: L :: M :: P :: R :: S :: U

[править] Советы по JavaScript

  • Передача и обработка данных в html-файле
  • Чем заменить SSI, или необычное использование JavaScript
  • Как сделать страницу стартовой
  • Как добавить страницу в избранное
  • Как вывести дату последнего изменения страницы
  • Как убрать в теге SELECT рамку и стрелку
  • Интересный JavaScript - побуквенное появление текста

[править] Полезные ссылки

  • Форум по JavaScript
  • http://msdn.microsoft.com/library - Обширный справочник по JavaScript (англ.)
  • Yahoo! User Interface Library - Очень полезный framework. Богатые возможности и кроссбраузерность (англ.).
  • Prototype is a JavaScript Framework
  • Firebug - Отладчик JavaScript (Описание к нему на русском)
Получено с http://spravkaweb.local/index.php/javascript
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 12:33, 21 марта 2007.
  • К этой странице обращались 939 раз.
7.14826989174


jscript — Справочник Web-языков

jscript

Этот раздел находится на стадии разработки!
Главная ::. JScript

[править] Разделы справки

  • Обработка ошибок в JScript
  • Список функций JScript
  • Список методов JScript
  • Список объектов JScript
  • Список операторов JScript
  • Список свойств JScript
  • Список конструкций языка JScript
Получено с http://spravkaweb.local/index.php/jscript
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 10:44, 20 марта 2007.
  • К этой странице обращались 31 раз.
1.31011509895


Notice: Undefined index: request in z:\home\spravkaweb\www\json_quick_search.php on line 37

Notice: Undefined offset: 1 in z:\home\spravkaweb\www\json_quick_search.php on line 41
:active CSS css/reference/guper :first-letter CSS css/reference/classtext :first-line CSS css/reference/classtext :hover CSS css/reference/guper :link CSS css/reference/guper :visited CSS css/reference/guper @charset CSS css/reference/rule @font-face CSS css/reference/rule @import CSS css/reference/rule @important CSS css/reference/rule


Логотип для сайта SpravkaWeb.Ru — Справочник Web-языков

Логотип для сайта SpravkaWeb.Ru

Как то исторически сложилось, что как такового логотипа у сайта SpravkaWeb.Ru никогда и не было!

Сам я программист, рисовать не умею. Все попытки привлечь знакомых дизайнеров нарисовать человекоподобный лого за бесплатно или за бартер к успеху не привели. Платить $500 за логотип не имею возможности.

В связи с чем хочу обратиться к общественности:

НАРИСУЙТЕ ЛОГОТИП ДЛЯ САЙТА SPRAVKAWEB.RU НЕДОРОГО!

Понравившуюся работу готов оплатить электронными деньгами (Yandex.Money, Webmoney) или бартером (разработка чеголибо, реклама на этом сайте).

Размер логотипа - 135 x 135 пикселей

Свои варианты размещайте либо здесь, либо присылайте на адрес admin@spravkaweb.ru

ICQ для связи: 195938768

Содержание

  • 1 Присланные варианты
    • 1.1 №1
    • 1.2 №2
    • 1.3 №3
    • 1.4 №4 Прислал Michael Tikhomirov
    • 1.5 №5 Прислал Zenith

[править] Присланные варианты

[править] №1

[править] №2

[править] №3

[править] №4 Прислал Michael Tikhomirov

[править] №5 Прислал Zenith

Получено с http://spravkaweb.local/index.php/logo
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 21:02, 31 марта 2007.
  • К этой странице обращались 251 раз.
1.29191303253


Заглавная страница — Справочник Web-языков

Заглавная страница

Добро пожаловать на SpravkaWeb.ru

SpravkaWeb.ru — информационный ресурс, посвященный программированию в Internet. Здесь вы найдете только оригинальные статьи по программированию а также теоретические основы наиболее популярных языков программирования в Internet. Большая база справочной информации позволит Вам не только быстро освоится с языками программирования, но и узнать много нового. Если после изучения материала возникают вопросы - добро пожаловать на наш форум, где постоянные посетители и продвинутые пользователи всегда помогут своим советом.

Новости
  • 2007-03-31: Offline-версия справочника SpravkaWeb.ru
    Пользоваться справочником SpravkaWeb.ru можно и без интернета!!! Для этого достаточно скачать offline-версию сайта www.spravkaweb.ru в разделе Download! Доступны форматы для скачивания как в виде множества *.htm-файлов, так и в CHM-формате (файл справки).
  • 2007-03-24: Указатель элементов справочника
    Теперь справочником SpravkaWeb.ru стало пользоваться еще удобнее! В систему добавлен указатель элементов справочника (левая панель "указатель"). Подробнее...
  • 2007-03-19: Ищется логотип для этого сайта
    Ищу веб-дизайнера, который нарисует лого для этого сайта. Подробности здесь.
  • 2007-03-18: Запущен информационный портал SpravkaWeb.ru в новом исполнении
    Надеемся, что наш информационный ресурс будет полезен пользователям
Справочники

HTML

  • Структура документа
  • Заголовки и названия
  • Параграфы и строки
  • Стили текста
  • Списки.Ссылки
  • Таблицы
  • Графика, объекты, мультимедиа, сценарий
  • Формы
  • Фреймы
  • Алфавитный указатель атрибутов

JavaScript

  • Совместное использование HTML и JavaScript
  • Объект document
  • Объект location
  • Объект style
  • Объект window
  • Объект layer
  • Объект navigator
  • Объект screen
  • Объект history
  • Алфавитный указатель свойств
  • Алфавитный указатель методов
  • Алфавитный указатель событий браузера

VBScript

  • Общие сведения
  • Текстовые функции
  • Ветвления и циклы
  • Объявление функций и процедур
  • Прочее

CSS

  • Что такое CSS и как применить
  • Свойства шрифта
  • Цветовая гамма
  • Свойства текста
  • Свойства текста, содержащего иероглифы
  • Расположение элементов
  • Границы элементов
  • Классификации
  • Принтер
  • Псевдостили гиперссылок
  • Псевдостили текста
  • Правила
  • Фильтры в Internet Explorer

Flash

  • Basic Actions
  • Action

Perl

  • Функции обработки строк и скаляров
  • Функции, связанные с регулярными выражениями
  • Числовые функции
  • Функции обработки массивов скаляров
  • Функции обработки списков
  • Функции обработки хеш-массивов
  • Функции ввода/вывода
  • Функции для работы с файлами и каталогами
  • Функции, относящиеся к управлению выполнением программы
  • Функции, относящиеся к области видимости переменных
  • Функции, относящиеся к модулям Perl
  • Функции, относящиеся к классам и объектно-ориентированным технологиям
  • Разные функции
  • Функции для работы с процессами и группами процессов
  • Низкоуровневые функции работы с сокетами
  • Функции для работы со временем и датой
  • Информация о пользователях и группах
  • Сетевая информация
  • Функции взаимодействия между процессами
  • Стандартные модули Perl
  • Специальные переменные

PHP

  • Синтаксис языка и операторы
  • Функции работы с данными
    • Математические функции
    • Работа с массивами
    • Строковые функции
    • XML
  • Файлы и сети
    • Работа с файлами
    • Функции для работы с каталогами
    • FTP
    • Функции сжатия Bzip2
    • Функции IMAP
    • Функции SNMP
    • Функции Vmailmgr
    • Сетевые функции
  • Управляющие функции
    • Отслеживание и обработка ошибок
    • Управление сессиями
    • Работа с WWW
    • Управление выводом
    • Управление исполнением сценария PHP
    • Почтовые функции
    • Функции запуска программ
    • Функции динамической загрузки
    • Информационные функции
  • Взаимодействие с базами данных
    • База данных MySQL
  • Графика
    • Работа с изображениями и библиотека GD
    • PDF-документы

MySQL

  • Типы данных, используемые в базе данных MySQL
  • Создание базы данных MySQL (CREATE DATABASE)
  • Удаление базы данных MySQL (DROP DATABASE)
  • Создание таблицы в базе данных MySQL (CREATE TABLE)
  • Удаление таблицы из базы данных MySQL (DROP TABLE)
  • Изменение свойств таблицы
  • Вставка строки в таблицу INSERT
  • Удаление строк из таблицы (DELETE FROM)
  • Обновление записей в таблице(UPDATE)
  • Поиск записей в таблице(SELECT)

SSI

  • Базовые директивы
  • Переменные включения
  • Подстановка переменных

VRML

  • Заголовок VRML-файла
  • Примитивы VRML
  • Цвет и текстура
  • Положение фигуры в пространстве
  • Определение собственных объектов
  • Однозначные поля
  • Многозначные поля
Советы

HTML

  • Внедрение элементов в html-страницу

JavaScript

  • Передача и обработка данных в html-файле
  • Чем заменить SSI, или необычное использование JavaScript
  • Как сделать страницу стартовой
  • Как добавить страницу в избранное
  • Как вывести дату последнего изменения страницы
  • Как убрать в теге SELECT рамку и стрелку
  • Интересный JavaScript - побуквенное появление текста

PHP

  • Запрет кэширования посредством PHP
  • Создание голосования на PHP
  • Отправка писем при помощи PHP
  • Из PHP в Excel: работа с COM-объектами
Приложения

HTML

  • Коды и обозначения символов
  • Коды и названия цветов
  • Коды языков HTML

CSS

  • Единицы измерения CSS

PHP

  • Переменные окружения
  • MIME-типы файлов
Получено с http://spravkaweb.local/index.php/main
Просмотры
  • Статья
  • Обсуждение
  • Просмотр
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 20:51, 31 марта 2007.
  • К этой странице обращались 2055 раз.
1.3604259491


Справочник по MySQL — Справочник Web-языков

Справочник по MySQL

Главная ::. MySQL

[править] Разделы справки

  • Типы данных, используемые в базе данных MySQL
  • Создание базы данных MySQL (CREATE DATABASE)
  • Удаление базы данных MySQL (DROP DATABASE)
  • Создание таблицы в базе данных MySQL (CREATE TABLE)
  • Удаление таблицы из базы данных MySQL (DROP TABLE)
  • Изменение свойств таблицы
    • Переименование таблицы (ALTER TABLE RENAME)
    • Вставка столбцов (ALTER TABLE ADD)
    • Изменение свойств столбца (ALTER TABLE CHANGE)
    • Удаление столбцов (ALTER TABLE DROP)
  • Вставка строки в таблицу INSERT
  • Удаление строк из таблицы (DELETE FROM)
  • Обновление записей в таблице(UPDATE)
  • Поиск записей в таблице(SELECT)

[править] Полезные ссылки

  • Форум по MySQL
  • http://www.mysql.ru/ - Рускоязычный сайт поддержки базы данных MySQL
  • http://www.mysql.com/ - Официальный сайт базы данных MySQL
Получено с http://spravkaweb.local/index.php/mysql
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 12:50, 20 марта 2007.
  • К этой странице обращались 436 раз.
1.41187000275


Справочник по Perl — Справочник Web-языков

Справочник по Perl

Главная ::. Perl

[править] Разделы справки

  • Функции обработки строк и скаляров
  • Функции, связанные с регулярными выражениями
  • Числовые функции
  • Функции обработки массивов скаляров
  • Функции обработки списков
  • Функции обработки хеш-массивов
  • Функции ввода/вывода
  • Функции для работы с файлами и каталогами
  • Функции, относящиеся к управлению выполнением программы
  • Функции, относящиеся к области видимости переменных
  • Функции, относящиеся к модулям Perl
  • Функции, относящиеся к классам и объектно-ориентированным технологиям
  • Разные функции
  • Функции для работы с процессами и группами процессов
  • Низкоуровневые функции работы с сокетами
  • Функции для работы со временем и датой
  • Информация о пользователях и группах
  • Сетевая информация
  • Функции взаимодействия между процессами
  • Стандартные модули Perl
  • Специальные переменные

[править] Полезные ссылки

  • Форум по Perl
Получено с http://spravkaweb.local/index.php/perl
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 12:47, 20 марта 2007.
  • К этой странице обращались 342 раза.
3.45294809341


Справочник по PHP — Справочник Web-языков

Справочник по PHP

Главная ::. PHP

[править] Синтаксис языка и операторы

  • Выражения

[править] Функции работы с данными

  • Математические функции
    • Функции округления
    • Случайные числа
    • Перевод в различные системы счисления
    • Минимум и максимум
    • Степенные функции
    • Тригонометрия
    • Функции повышенной точности BCMath
    • Функции GMP
      • Введение
      • Значения функции GMP
      • Арифметика
      • Математика
      • Бинарные операции
  • Работа с массивами
    • Введение
    • Создание массива
    • Сортировка массивов
    • Курсор массива
    • Ключи и значения
    • Работа с несколькими массивами
    • Получение и удаление части массива
    • Вставка / удаление элементов
    • Переменные и массивы
  • Строковые функции
    • Функции для работы с одиночными символами
    • Функции отрезания пробелов
    • Поиск в тексте
    • Функции сравнения
    • Форматирование и вывод строк
    • Составление/разбиение строк
    • Работа с блоками текста
    • Функции для преобразования символов
    • Функции изменения регистра
    • Установка локали (локальных настроек)
    • Преобразование кодировок
    • Функции URL
    • Работа с бинарными данными
    • Строковые суммы и хеш-функции
  • XML
    • SimpleXML
      • asXML
      • attributes
      • children
      • xpath
      • simplexml_import_dom
      • simplexml_load_file
      • simplexml_load_string
  • Символические ссылки. Жесткие ссылки.
  • Функции даты и времени
  • Логические функции определения типа переменной
  • Функции переменных
  • Функции для работы с функциями
  • Календарные функции

[править] Файлы и сети

  • Работа с файлами
    • Открытие файла
    • Закрытие файла
    • Чтение и запись
    • Положение указателя текущей позиции
    • Функции для определения типов файлов
    • Определение параметров файла
    • Функции для работы с именами файлов
    • Функции манипулирования целыми файлами
    • Другие функции
  • Функции для работы с каталогами
    • Манипулирование каталогами
    • Работа с записями
  • FTP
    • Работа с FTP-сервером
    • Работа с файлами
  • Функции сжатия Bzip2
    • Введение
    • Работа с файлами Bzip2
  • Функции IMAP
  • Функции SNMP
  • Функции Vmailmgr
  • Сетевые функции

[править] Управляющие функции

  • Отслеживание и обработка ошибок
    • Введение
    • Функции обработки ошибок
    • Установка пользовательского обработчика ошибок
  • Управление сессиями
    • Зачем нужны сессии.Механизм работы сессий.
    • Инициализация сессии и регистрация переменных
    • Имя группы сессии
    • Идентификатор сессии
    • Другие функции
    • Обзор обработчиков
    • Про сессии и Cookies
  • Работа с WWW
    • Установка заголовков ответа
    • Получение заголовков запроса
    • Работа с Cookies
    • SSI и функция virtual()
  • Управление выводом
    • Введение
    • Функции управления выводом
  • Управление исполнением сценария PHP
    • Функции управления сценарием
    • Статус подключений
    • Дополнительные функции
  • Почтовые функции
  • Функции запуска программ
  • Функции динамической загрузки
  • Информационные функции

[править] Взаимодействие с базами данных

  • База данных MySQL
    • Работа с базами данных
    • Обработка результатов запроса

[править] Графика

  • Работа с изображениями и библиотека GD
    • Параметры изображения
    • Манипулирование изображениями
    • Работа с цветом в формате RGB
    • Графические примитивы
    • Работа с фиксированными шрифтами
    • Работа со шрифтами TrueType и PostScript Type 1
  • PDF-документы
    • Введение
    • Открытие документа
    • Работа с текстом
    • Установка масштаба и системы координат
    • Черчение и заполнение фигур
    • Размещение рисунков
    • Стиль документа

[править] Приложения

  • Переменные окружения
  • MIME-типы файлов

[править] Советы

  • Запрет кэширования посредством PHP
  • Создание голосования на PHP
  • Отправка писем при помощи PHP
  • Из PHP в Excel: работа с COM-объектами

[править] Полезные ссылки

  • Форум по PHP
  • www.php.net - Официальный сайт PHP
  • pear.php.net - Библиотека скриптов PEAR
  • http://www.zend.com/products/zend_studio - Среда разработки проектов на PHP от Zend.com (Форум поддержки)
  • http://framework.zend.com/ - Фреймворк от Zend.com (Форум поддержки)
Получено с http://spravkaweb.local/index.php/php
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 06:40, 25 марта 2007.
  • К этой странице обращались 1161 раз.
1.64806818962


Программное обеспечение — Справочник Web-языков

Программное обеспечение

Главная ::. Программное обеспечение
Этот раздел находится на стадии разработки!

Содержание

  • 1 Для разработчкика
  • 2 Для дизайнера
  • 3 Для администратора
  • 4 Сравнение

[править] Для разработчкика

  • Продукция от Zend.com
    • ZendStudio
    • ZendServer

[править] Для дизайнера

  • Продукция от Adobe.com
    • Flash
    • Photoshop

[править] Для администратора

  • Apache - Web-cервер
  • MySQL - DB-cервер
  • Postgres - DB-cервер

[править] Сравнение

  • Бесплатные аналоги платных программ - SOHO-сегмент
Получено с http://spravkaweb.local/index.php/po
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 10:59, 31 марта 2007.
  • К этой странице обращались 24 раза.
1.17438387871


Справочник по SSI — Справочник Web-языков

Справочник по SSI

Главная ::. SSI

[править] Разделы справки

  • Базовые директивы
  • Переменные включения
  • Подстановка переменных
Получено с http://spravkaweb.local/index.php/ssi
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 10:40, 28 февраля 2007.
  • К этой странице обращались 183 раза.
1.59381198883


Справочник по VBScript — Справочник Web-языков

Справочник по VBScript

Главная ::. VBScript

[править] Разделы справки

  • Общие сведения
  • Текстовые функции
  • Ветвления и циклы
  • Объявление функций и процедур
  • Прочее
Получено с http://spravkaweb.local/index.php/vbscript
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 09:53, 7 января 2007.
  • К этой странице обращались 246 раз.
11.5518829823


Справочник по VRML — Справочник Web-языков

Справочник по VRML

Главная ::. VRML

[править] Разделы справки

  • Заголовок VRML-файла
  • Примитивы VRML
  • Цвет и текстура
  • Положение фигуры в пространстве
  • Определение собственных объектов
  • Однозначные поля
  • Многозначные поля

[править] Полезные ссылки

  • Форум по VRML
Получено с http://spravkaweb.local/index.php/vrml
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 12:51, 20 марта 2007.
  • К этой странице обращались 210 раз.
1.24131178856


Справочник по CSS — Справочник Web-языков

Справочник по CSS

Главная ::. CSS

[править] Разделы справки

  • Что такое CSS и как применить
  • Свойства шрифта
  • Цветовая гамма
  • Свойства текста
  • Свойства текста, содержащего иероглифы
  • Расположение элементов
  • Границы элементов
  • Классификации
  • Принтер
  • Псевдостили гиперссылок
  • Псевдостили текста
  • Правила

[править] Фильтры в Internet Explorer

  • Пару вводных слов
  • Статические фильтры
  • Динамические фильтры
    • Barn
    • Blinds
    • CheckerBoard
    • Fade
    • GradientWipe
    • Inset
    • Iris
    • Pixelate
    • RadialWipe
    • RandomBars
    • RandomDissolve
    • Slide
    • Spiral
    • Stretch
    • Strips
    • Wheel
    • ZigZag

[править] Приложения

  • Единицы измерения CSS

[править] Полезные ссылки

  • Форум по CSS
Получено с http://spravkaweb.local/index.php/css
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 09:00, 26 марта 2007.
  • К этой странице обращались 563 раза.
1.46023321152


Приложения CSS — Справочник Web-языков

Приложения CSS

Главная | ::. | CSS | ::. | Приложения CSS

[править] Приложения CSS

  • Единицы измерения CSS
Получено с http://spravkaweb.local/index.php/css/pril
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 10:49, 18 марта 2007.
  • К этой странице обращались 85 раз.
1.22838687897


Справочник по CSS : Фильтры в Internet Explorer : Пару вводных слов — Справочник Web-языков

Справочник по CSS : Фильтры в Internet Explorer : Пару вводных слов

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | CSS | ::. | Фильтры в Internet Explorer | ::. | Пару вводных слов
 |  |  |  |  |  | Статические фильтры

Надо отметить, что фильтры отображаются только в браузерах Internet Explorer не ниже 4-ой версии.

[править] Синтаксис:

"filter:имя_фильтра(параметр1=значение, параметр2=значение,...)"

Некоторые фильтры могут быть без параметров.

Фильтры деляться на статические и динамические. Статические фильтры меняют вид объекта, а сам он остается неподвижным. Динамические фильтры позволяют менять объект с задаваемой скоростью переключения кадров.

Далее будут мною описаны 18 статических и 19 динамических фильтра.

Фильтры применяют через параметр STYLE:

Возьмём картинку (img.gif) и применим к ней фильтр прозрачности:

<IMG SRC=img.gif STYLE="filter:alpha(opacity=50)">

- имеем ту же картинку, но полупрозрачную.

Фильтры поддерживаются языками сценариев. Доступ к фильтрам организуется через объектное свойство filters и атрибут ID графического элемента.

[править] JavaScript:

<script language="JavaScript">
function Blur(inc){
Pic.filters.blur.strength+=inc;}
</script>
...
<IMG ID=Pic SRC=img.gif
STYLE="filter:blur(strength=10)"
OnMouseOver="javascript:Blur(20)"
OnMouseOut="javascript:Blur(-20)">

Здесь функция Blur() обращается к фильтру blur объекта Pic и изменяет его параметр strength при наведении курсора мышки.

[править] VBScript:

<script language="VBScript"> Pic.style.filter = "flipv" </script> ... <IMG ID=Pic SRC=img.gif>

Здесь используется фильтр flip, который переворачивает изображение вокруг вертикальной оси.

Получено с http://spravkaweb.local/index.php/css/filter/about
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:19, 8 января 2007.
  • К этой странице обращались 123 раза.
2.09549593925


Справочник по CSS : Фильтры в Internet Explorer : Статические фильтры — Справочник Web-языков

Справочник по CSS : Фильтры в Internet Explorer : Статические фильтры

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Пару вводных слов
Главная | ::. | CSS | ::. | Фильтры в Internet Explorer | ::. | Статические фильтры
 |  |  |  |  |  | Динамические фильтры

Содержание

  • 1 Alpha
  • 2 AlphaImageLoaded
  • 3 BasicImage
  • 4 Blur
  • 5 Chroma
  • 6 Compositor
  • 7 DropShadow
  • 8 Emboss
  • 9 Engrave
  • 10 Glow
  • 11 Gradient
  • 12 Light
  • 13 MaskFilter
  • 14 Matrix
  • 15 MotiobBlur
  • 16 Pixelate
  • 17 Shadow
  • 18 Wave

[править] Alpha

Задает уровень прозрачности элемента страницы.

При настройке этого фильтра можно использовать следующие параметры:

Opacity
Задает уровень прозрачности для элемента. Значение прозрачности может быть в пределах от 0 (полная прозрачность) до 100 (полностью непрозрачен).
Style
Задает вид градиентной прозрачности: 0 (по умолчанию)-нет градиента, 1-линейный градиент, 2-круговой градиент, 3-прямоугольный градиент
StartX
Горизонтальная координата, с которой начинается область градиентной прозрачности. Задается в пикселях.
StartY
Вертикальная координата, с которой начинается область градиентной прозрачности. Задается в пикселях.
FinishX
Горизонтальная координата, в которой заканчивается область градиентной прозрачности. Задается в пикселях.
FinishY
Вертикальная координата, в которой заканчивается область градиентной прозрачности. Задается в пикселях.
Enabled
Разрешение применения фильтра. Имеет два значения:
  • true (по умолчанию) - разрешает применить фильтр
  • false - не разрешает

[править] AlphaImageLoaded

Отображает графическое изображение внутри элемента страницы между его фоном и содержимым.

При настройке этого фильтра можно использовать следующие параметры:

src
URL-адрес файла с изображением.
SizingMethod
Способ размещения изображения в пределах элемента страницы.
  • SezingMethod="crop" - обрезание изображения
  • SezingMethod="image"(по умолч.) - уменьшение или увеличение самого элемента страницы
  • SezingMethod="scale" - уменьшение или увеличение изображения
Enabled
Разрешение применения фильтра. Имеет два значения:
  • true (по умолчанию) - разрешает применить фильтр
  • false - не разрешает

[править] BasicImage

Делает элемент страницы черно-белым, как бы просвеченным рентгеновскими лучами, вращает его.

Отдельно можно задавать угол поворота, стерень "просвеченности".

При настройке этого фильтра можно использовать следующие параметры:

GrayScale=1
Элемент страницы отображается черно-белым
GrayScale=0 (по умолчанию)
Цветным
Invert=1
Элемент страницы отображается с инвертированными цветами
Invert=0 (по умолчанию)
Элемент страницы отображается как обычно
MaskColor
Цвет, на который будет заменен прозрачный цвет элемент страницы
Masc=1
Прозрачный цвет элемента страницы будет заменен значением свойства MaskColor
Masc=0 (по умолчанию)
Не будет
Mirror=1
Элемент страницы будет отображен зеркально
Mirror=0 (по умолчанию)
Элемент страницы будет отображен как обычно
Opacity
Уровень прозрачности элемента страницы. Варьируется в пределах от 0.0 до 1.0
Rotation
Задает поворот элемента страницы. Доступны всего 4-е занчения: 0 (по умолчанию) - нет поворота, 1 - на 90 градусов, 2 - на 180 градусов и 3 - на 270 градусов
XRay=1
Элемент страницы будет "просвечен рентгеновскими лучами"
XRay=0 (по умолчанию)
Как обычно
Enabled
Разрешение применения фильтра. Имеет два значения:
  • true (по умолчанию) - разрешает применить фильтр
  • false - не разрешает

[править] Blur

Делает элемент страницы размытым.

При настройке этого фильтра можно использовать следующие параметры:

MakeShadow=true
Элемент страницы будет отображаться как тень
MakeShadow=false (по умолчанию)
Элемент страницы будет отображаться как обычно
PixelRadius
Задает размер области размытия. Может принимать значения от 0.0 до 100.0
ShadowOpacity
Указывает прозрачность тени. Может принимать заначения от 0.0 (что соответствует полной прозрачности) до 1.0 (полная непрозрачность)
Enabled
Разрешение применения фильтра. Имеет два значения:
  • true (по умолчанию) - разрешает применить фильтр
  • false - не разрешает

[править] Chroma

Делает прозрачным отдельный цвет элемента.

При настройке этого фильтра можно использовать следующие параметры:

Color
Задает цвет, который будет прозрачным
Enabled
Разрешение применения фильтра. Имеет два значения:
  • true (по умолчанию) - разрешает применить фильтр
  • false - не разрешает

[править] Compositor

Объеденяет два цвета элемента страницы и выводит что получилось.

При настройке этого фильтра можно использовать следующие параметры:

Function
Функция преобразования
Enabled
Разрешение применения фильтра. Имеет два значения:
  • true (по умолчанию) - разрешает применить фильтр
  • false - не разрешает

[править] DropShadow

Отбрасывает тень у элемента страницы, которая отображается отдельно от самого элемента.

При настройке этого фильтра можно использовать следующие параметры:

Color
Цвет
OffX
Горизонтальное смещение тени
OffY
Вертикальное смещение тени
Positive=true (по умолчанию)
Тень создается из прозрачных пикселов элемента страницы
Positive=false
Тень создается из непрозрачных пикселов элемента страницы ("негативная" тень)
Enabled
Разрешение применения фильтра. Имеет два значения:
  • true (по умолчанию) - разрешает применить фильтр
  • false - не разрешает

[править] Emboss

Делает элемент страницы выпуклым.

При настройке этого фильтра можно использовать следующие параметры:

Bias
Процентное значение, добавляемое к цвету элемента
Enabled
Разрешение применения фильтра. Имеет два значения:
  • true (по умолчанию) - разрешает применить фильтр
  • false - не разрешает

[править] Engrave

Делает элемент страницы вдавленным.

При настройке этого фильтра можно использовать следующие параметры:

Bias
Процентное значение, добавляемое к цвету элемента
Enabled
Разрешение применения фильтра. Имеет два значения:
  • true (по умолчанию) - разрешает применить фильтр
  • false - не разрешает

[править] Glow

Создает эффект "тления" элемента страницы.

При настройке этого фильтра можно использовать следующие параметры:

Color
Цвет
Strength
Расстояние в пикселях, на которое выполняется "тление"
Enabled
Разрешение применения фильтра. Имеет два значения:
  • true (по умолчанию) - разрешает применить фильтр
  • false - не разрешает

[править] Gradient

Эффект градиентной закраски элемента страницы.

При настройке этого фильтра можно использовать следующие параметры:

StartColor,StartColorStr
Начальный цвет градиентной закраски
EndColor,EndColorStr
Конечный цвет градиентной закраски
GradientType=1 (по умолчанию)
Градиентная закраска распологается по горизонтали
GradientType=0
Градиентная закраска распологается по вертикали
Enabled
Разрешение применения фильтра. Имеет два значения:
  • true (по умолчанию) - разрешает применить фильтр
  • false - не разрешает

[править] Light

Создет эффект освещенности элемента страницы.

Методы, применяемые к этому фильтру:

AddAmbient({Красный},{Зеленый},{Синий},{Интенсивность})
Добавляет источник рассеянного света с заданными цветовыми параметрами
AddCone({x1},{y1},{z1},{x2},{y2},{Красный},{Зеленый},{Синий},{Интенсивность},{Угол})
Добавляет источник направленного света с заданными цветовыми параметрами. Параметры x1,y1,z1 задают координаты источника света, x2,y2 - точки, куда падает свет.
AddPoint({x},{y},{z},{Красный},{Зеленый},{Синий},{Интенсивность})
Добавляет источник направленного света с заданными цветовыми параметрами. Координаты x,y,z - координаты источника света.
ChangeColor({№},{Красный},{Зеленый},{Синий},1|0)
Изменяет цвет источника света с заданным номером на указанный цвет. Последний параметр указывает, будет абсолютное (1) или относительное (0) изменение цвета.
ChangeStrength({№},{Интенсивность},1|0)
Изменяет интенсивность света источника с заданным номером. Последний параметр указывает, будет абсолютное (1) или относительное (0) изменение интенсивности.
Clear()
Удаляет все источники света
MoveLight({№},{x},{y},{z},1|0)
Перемещает источник света с заданным номером в место с заданными координатами. Последний параметр указывает, будет абсолютное (1) или относительное (0) перемещение.
Enabled
Разрешение применения фильтра. Имеет два значения:
  • true (по умолчанию) - разрешает применить фильтр
  • false - не разрешает

[править] MaskFilter

Отображает прозрачный цвет элемента страницы заданным цветом.

При настройке этого фильтра можно использовать следующие параметры:

Color
Задает цвет, которым замениться прозрачный цвет элемента страницы.
Enabled
Разрешение применения фильтра. Имеет два значения:
  • true (по умолчанию) - разрешает применить фильтр
  • false - не разрешает

[править] Matrix

Изменяет элемент страницы путем изменения размеров, поворотов или инвертируя его при помощи матричных преобразований.

При настройке этого фильтра можно использовать следующие параметры:

Dx
Значения fDx матричных преобразований
Dy
Значения fDy матричных преобразований
FilterType
Задает тип пикселов нового содержимого.

"bilinear" (по умолчанию)

M11,M12,M21,M22
Значения fM11,fM12,fM21,fM22 матричных преобразований
SizingMethod
Определяет способ размещения нового изображения в пределах элемента страницы, к которому применяется фильтр. Это свойство может иметь два значения:
  • "clip to original" (по умолчанию) - обрезание изображения
  • "auto expand" - уменьшение или увеличение изображения
Enabled
Разрешение применения фильтра. Имеет два значения:
  • true (по умолчанию) - разрешает применить фильтр
  • false - не разрешает

[править] MotiobBlur

Создает эффект быстрого движения (размытости).

При настройке этого фильтра можно использовать следующие параметры:

Add
Имеет 2 значения:
  • true - исходный элемент страницы перекрывает результат работы фильтра
  • false (по умолчанию) - результат работы фильтра перекрывает исходный элемент страницы
Direction
Задает направление работы фильтра в градусах, которые должны быть кратны 45.
Strength
Дистанция, задаваемая в пикселях, на которую выполняется работа фильтра
Enabled
Разрешение применения фильтра. Имеет два значения:
  • true (по умолчанию) - разрешает применить фильтр
  • false - не разрешает

[править] Pixelate

Отображает элемент страницы отдельными пикселами.

При настройке этого фильтра можно использовать следующие параметры:

MaxSquare
Этот параметр задает максимальный размер пикселов
Enabled
Разрешение применения фильтра. Имеет два значения:
  • true (по умолчанию) - разрешает применить фильтр
  • false - не разрешает

[править] Shadow

Создает эффект отбрасывания тени у элемента страницы.

При настройке этого фильтра можно использовать следующие параметры:

Color
Цвет тени
Direction
Задает направление тени в градусах, которые должны быть кратны 45
Enabled
Разрешение применения фильтра. Имеет два значения:
  • true (по умолчанию) - разрешает применить фильтр
  • false - не разрешает

[править] Wave

Создает волнистое искажение элемента страницы.

При настройке этого фильтра можно использовать следующие параметры:

Add
Доступны два параметра:
  • true - элемент страницы, к которому был применени фильтр закроет результат фильтрации
  • false (по умолчанию) - результат фильтрации перекроет исходный элемент страницы
Freq
Задает количество волн
LightStrength
Окраска волн. Может принимать значение от 0 до 100
Phase
Фаза волн. Может принимать значение от 0 до 100
Strength
Дистанция, указанная в пикселах, на которую органицуется фильтрация
Enabled
Разрешение применения фильтра. Имеет два значения:
  • true (по умолчанию) - разрешает применить фильтр
  • false - не разрешает
Получено с http://spravkaweb.local/index.php/css/filter/static
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:18, 9 января 2007.
  • К этой странице обращались 84 раза.
1.8606197834


Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Barn — Справочник Web-языков

Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Barn

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Статические фильтры
Главная | ::. | CSS | ::. | Фильтры в Internet Explorer | ::. | Динамические фильтры | ::. | Barn
 |  |  |  |  |  |  |  | Blinds

[править] Barn()

Создает эффект "открывающейся и закрывающейся двери".

[править] Синтаксис фильтра Barn():

Где: | Общий пример использования: | Совместимость:
HTML | <ELEMENT STYLE="filter:progid:DXImageTransform.Microsoft.Barn(sProperties)" ... > | Internet Explorer 5.5 или выше
Script | object.style.filter = "progid:DXImageTransform.Microsoft.Barn(sProperties)" | Internet Explorer 5.5 или выше

Здесь sProperties - строка, содержащая один или несколько свойств, задающих поведение фильтра.

[править] Свойства, используемые в фильтре Barn:

Атрибуты
Исползуются в HTML 		Свойства
Исползуются в скриптах 		Описание
duration Duration Задает или возвращает продолжительность преобразования в секундах.
enabled Enabled Задает или возвращает признак разрешения применения фильтра.
Свойство может принимать следующие значения
  • true - разрешает применить фильтр (значение по умолчанию)
  • false - не разрешает
motion Motion Задает или возвращает направление движения: от центра к границам или наоборот.
Свойство может принимать два значения
  • out - движение происходит из центра к границам (значение по умолчанию)
  • in - движение происходит от границ к центру
orientation Orientation Задает или возвращает направление преобразования: по вертикали или по горизонтали.
Свойство может принимать два значения
  • horizontal - преобразование происходит по горизонтали
  • vertical - по вертикали
Percent Задает процент выполнения преобразования.
Может принимать значения от 0 (преобразование еще не началось) до 100 (преобразование закончено).
status Возвращает состояние выполнения преобразования.
Свойство может принимать следующие значения
  • 0 - если преобразование было остановлено
  • 1 - если оно было применено
  • 2 - если преобразование выполняется

[править] Методы, которые могут быть применены к фильтру Barn():

Метод | Описание
apply | Замораживает элемент страниы, после чего вы можете делать с ним все, что хотите. Для того, чтобы запустить преобразование, используйте метод Play().
play | Запускает преобразование.
stop | Немедленно останавливает преобразование.

[править] Примеры использования динамического фильтра Barn():

Пример 1:

<SCRIPT>
var bToggle = 0;
function fnToggle() {
    oDiv.filters[0].Apply();
// После того, как применяется метод Apply к выбранному объекту
// фильтр не запустится пока не будет вызван метод Play

    if (bToggle) {
        bToggle = 0;
        oDiv.style.backgroundColor="gold";
    } else {
        bToggle = 1;
        oDiv.style.backgroundColor="blue";}
    oDiv.filters[0].Play();
}
</SCRIPT>

<BUTTON onclick="fnToggle()">Toggle Transition</BUTTON><BR><BR>
<DIV ID="oDiv" STYLE="height:250px; width:250px; background-color: gold;
                filter:progid:DXImageTransform.Microsoft.Barn(
                duration=2, motion=out, orientation=vertical);">
</DIV>

Пример 2:

<!-- К этому элементу применяется фильтр. -->

<DIV ID="oTransContainer" STYLE="position:absolute; top: 0px; left: 0px; width: 300px;
height:300px;  filter:progid:DXImageTransform.Microsoft.Barn(orientation=horizontal, motion=out) ">

<!-- Это первое содержимое, которое будет показано. -->

    <DIV ID="oDIV1" STYLE="position:absolute; top:50px; left:10px; width:240px; height:160px;
    background:gold"> This is DIV #1  </DIV>

<!-- Это содержимое, которое будет показано после применения фильтра. -->

    <DIV ID="oDIV2" STYLE="visibility:hidden; position:absolute; top:50px; left:10px;
    width:240px; height:160px; background: yellowgreen; "> <BR> This is DIV #2
    </DIV>
</DIV>

<BUTTON onclick="fnToggle()">Toggle Transition</BUTTON>

<SCRIPT>
var bTranState = 0;
function fnToggle() {
    oTransContainer.filters[0].Apply();
    if (bTranState=="0") {
        bTranState = 1;
        oDIV2.style.visibility="visible";
        oDIV1.style.visibility="hidden";
    } else {
        bTranState = 0;
        oDIV2.style.visibility="hidden";
        oDIV1.style.visibility="visible";}
        oTransContainer.filters[0].Play();}
</SCRIPT>
Получено с http://spravkaweb.local/index.php/css/filter/dynamic/barn
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 17:46, 11 января 2007.
  • К этой странице обращались 107 раз.
1.81622815132


Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Blinds — Справочник Web-языков

Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Blinds

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Barn
Главная | ::. | CSS | ::. | Фильтры в Internet Explorer | ::. | Динамические фильтры | ::. | Blinds
 |  |  |  |  |  |  |  | CheckerBoard

[править] Blinds()

Создает эффект "открывающихся и закрывающихся жалюзи"

[править] Синтаксис фильтра Blinds():

Где: | Общий пример использования: | Совместимость:
HTML | <ELEMENT STYLE="filter:progid:DXImageTransform.Microsoft.Blinds(sProperties)" ... > | Internet Explorer 5.5 или выше
Script | object.style.filter="progid:DXImageTransform.Microsoft.Blinds(sProperties)" | Internet Explorer 5.5 или выше

Здесь sProperties - строка, содержащая один или несколько свойств, задающих поведение фильтра.

[править] Свойства, используемые в фильтре Blinds():

Атрибуты
Исползуются в HTML 		Свойства
Исползуются в скриптах 		Описание
bands | bands | Задает или возвращает количество полос, на которые разделяется область.
Direction Direction Задает или возвращает направление, в которое происходит открытие полосок.
Свойство может принимать следующие значения
  • up - открытие вверх
  • down - вниз
  • right - вправо
  • left - влево
duration | Duration | Задает или возвращает продолжительность преобразования в секундах.
enabled Enabled Задает или возвращает признак разрешения применения фильтра.
Свойство может принимать следующие значения
  • true - разрешает применить фильтр (значение по умолчанию)
  • false - не разрешает
Percent Задает процент выполнения преобразования.
Может принимать значения от 0 (преобразование еще не началось) до 100 (преобразование закончено).
status Возвращает состояние выполнения преобразования.
Свойство может принимать следующие значения
  • 0 - если преобразование было остановлено
  • 1 - если оно было применено
  • 2 - если преобразование выполняется

[править] Методы, которые могут быть применены к фильтру Blinds():

Метод | Описание
apply | Замораживает элемент страниы, после чего вы можете делать с ним все, что хотите. Для того, чтобы запустить преобразование, используйте метод Play().
play | Запускает преобразование.
stop | Немедленно останавливает преобразование.

[править] Примеры использования динамического фильтра Blinds():

Пример 1:

<SCRIPT>
var bToggle = 0;
function fnToggle() {
    oDiv.filters[0].Apply();

// Устанавливаем случайное число "шторок".
    oDiv.filters[0].bands =  Math.random()*12 + 3;

// После того, как применяется метод Apply к выбранному объекту
// фильтр не запустится пока не будет вызван метод Play

    if (bToggle) {
        bToggle = 0;
        oDiv.style.backgroundColor="gold";}
    else {
        bToggle = 1;
        oDiv.style.backgroundColor="blue";}
    oDiv.filters[0].Play(duration=3);
}
</SCRIPT>

<BUTTON onclick="fnToggle()">Toggle Transition</BUTTON><BR/><BR/>
<DIV ID="oDiv" STYLE="height:250px; width:250px; background-color: gold;
                filter:progid:DXImageTransform.Microsoft.Blinds(
                direction=down);">
</DIV>

Пример 2:

<!-- К этому элементу применяется фильтр. -->

<DIV ID="oTransContainer" STYLE="position:absolute; top: 0px; left: 0px; width: 300px;
height:300px;  filter:progid:DXImageTransform.Microsoft.Blinds(bands=2,  direction=RIGHT) ">

<!-- Это первое содержимое, которое будет показано. -->

    <DIV ID="oDIV1" STYLE="position:absolute; top:50px; left:10px; width:240px; height:160px;
    background:gold"> This is DIV #1  </DIV>

<!-- Это содержимое, которое будет показано после применения фильтра. -->

    <DIV ID="oDIV2" STYLE="visibility:hidden; position:absolute; top:50px; left:10px;
    width:240px; height:160px; background: yellowgreen; "> <BR> This is DIV #2
    </DIV>
</DIV>

<BUTTON onclick="fnToggle()">Toggle Transition</BUTTON>

<SCRIPT>
var bTranState = 0;
function fnToggle() {
    oTransContainer.filters[0].Apply();
    if (bTranState=="0") {
        bTranState = 1;
        oDIV2.style.visibility="visible";
        oDIV1.style.visibility="hidden";}
    else {
        bTranState = 0;
        oDIV2.style.visibility="hidden";
        oDIV1.style.visibility="visible";}
        oTransContainer.filters[0].Play();}
</SCRIPT>
Получено с http://spravkaweb.local/index.php/css/filter/dynamic/blinds
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 18:00, 11 января 2007.
  • К этой странице обращались 67 раз.
1.58444905281


Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Fade — Справочник Web-языков

Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Fade

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | CheckerBoard
Главная | ::. | CSS | ::. | Фильтры в Internet Explorer | ::. | Динамические фильтры | ::. | Fade
 |  |  |  |  |  |  |  | GradientWipe

[править] Fade()

Создает эффект наплыва, т.е. старое содержимое элемента странцы плавно пропадает, а новое одновременно плавно появляется

[править] Синтаксис фильтра Fade():

Где: | Общий пример использования: | Совместимость:
HTML | <ELEMENT STYLE="filter:progid:DXImageTransform.Microsoft.Fade(sProperties)" ... > | Internet Explorer 5.5 или выше
Script | object.style.filter = "progid:DXImageTransform.Microsoft.Fade(sProperties)" | Internet Explorer 5.5 или выше

Здесь sProperties - строка, содержащая один или несколько свойств, задающих поведение фильтра.

[править] Свойства, используемые в фильтре Fade():

Атрибуты
Исползуются в HTML 		Свойства
Исползуются в скриптах 		Описание
overlap Overlap Задает или возвращает время одновременного показа старого содержимого объекта и нового относительно общей продолжительности работы фильтра.
Может принимать значения от 0,0 до 1,0
duration Duration Задает или возвращает продолжительность преобразования в секундах.
enabled Enabled Задает или возвращает признак разрешения применения фильтра.
Свойство может принимать следующие значения
  • true - разрешает применить фильтр (значение по умолчанию)
  • false - не разрешает
Percent Задает процент выполнения преобразования.
Может принимать значения от 0 (преобразование еще не началось) до 100 (преобразование закончено).
Status Возвращает состояние выполнения преобразования.
Свойство может принимать следующие значения
  • 0 - если преобразование было остановлено
  • 1 - если оно было применено
  • 2 - если преобразование выполняется

[править] Методы, которые могут быть применены к фильтру Fade():

Метод | Описание
apply | Замораживает элемент страниы, после чего вы можете делать с ним все, что хотите. Для того, чтобы запустить преобразование, используйте метод Play().
play | Запускает преобразование.
stop | Немедленно останавливает преобразование.

[править] Примеры использования динамического фильтра Fade():

Пример 1:

<SCRIPT>
var bToggle = 0;
function fnToggle() {
    oDiv.filters[0].Apply();
// После того, как применяется метод Apply к выбранному объекту
// фильтр не запустится пока не будет вызван метод Play

    if (bToggle) {
        bToggle = 0;
        oDiv.style.backgroundColor="gold";}
    else {
        bToggle = 1;
        oDiv.style.backgroundColor="blue";}
    oDiv.filters[0].Play();
}
</SCRIPT>

<BUTTON onclick="fnToggle()">Toggle Transition</BUTTON><BR/><BR/>
<DIV ID="oDiv" STYLE="height:250px; width:250px; background-color: gold;
                filter:progid:DXImageTransform.Microsoft.Fade(
                duration=2);">
</DIV>

Пример 2:

<!-- К этому элементу применяется фильтр. -->

<DIV ID="oTransContainer" STYLE="position:absolute; top: 0px; left: 0px; width: 300px;
height:300px;  filter:progid:DXImageTransform.Microsoft.Fade(duration=1.0,overlap=1.0) ">

<!-- Это первое содержимое, которое будет показано. -->

    <DIV ID="oDIV1" STYLE="position:absolute; top:50px; left:10px; width:240px; height:160px;
    background:gold"> This is DIV #1  </DIV>

<!-- Это содержимое, которое будет показано после применения фильтра. -->

    <DIV ID="oDIV2" STYLE="visibility:hidden; position:absolute; top:50px; left:10px;
    width:240px; height:160px; background: yellowgreen; "> <BR> This is DIV #2
    </DIV>
</DIV>

<BUTTON onclick="fnToggle()">Toggle Transition</BUTTON>

<SCRIPT>
var bTranState = 0;
function fnToggle() {
    oTransContainer.filters[0].Apply();
    if (bTranState=="0") {
        bTranState = 1;
        oDIV2.style.visibility="visible";
        oDIV1.style.visibility="hidden";}
    else {
        bTranState = 0;
        oDIV2.style.visibility="hidden";
        oDIV1.style.visibility="visible";}
        oTransContainer.filters[0].Play();}
</SCRIPT>
Получено с http://spravkaweb.local/index.php/css/filter/dynamic/checkerboard
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 18:16, 11 января 2007.
  • К этой странице обращались 89 раз.
1.61250090599


Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Fade — Справочник Web-языков

Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Fade

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | CheckerBoard
Главная | ::. | CSS | ::. | Фильтры в Internet Explorer | ::. | Динамические фильтры | ::. | Fade
 |  |  |  |  |  |  |  | GradientWipe

[править] Fade()

Создает эффект наплыва, т.е. старое содержимое элемента странцы плавно пропадает, а новое одновременно плавно появляется

[править] Синтаксис фильтра Fade():

Где: | Общий пример использования: | Совместимость:
HTML | <ELEMENT STYLE="filter:progid:DXImageTransform.Microsoft.Fade(sProperties)" ... > | Internet Explorer 5.5 или выше
Script | object.style.filter = "progid:DXImageTransform.Microsoft.Fade(sProperties)" | Internet Explorer 5.5 или выше

Здесь sProperties - строка, содержащая один или несколько свойств, задающих поведение фильтра.

[править] Свойства, используемые в фильтре Fade():

Атрибуты
Исползуются в HTML 		Свойства
Исползуются в скриптах 		Описание
overlap Overlap Задает или возвращает время одновременного показа старого содержимого объекта и нового относительно общей продолжительности работы фильтра.
Может принимать значения от 0,0 до 1,0
duration Duration Задает или возвращает продолжительность преобразования в секундах.
enabled Enabled Задает или возвращает признак разрешения применения фильтра.
Свойство может принимать следующие значения
  • true - разрешает применить фильтр (значение по умолчанию)
  • false - не разрешает
Percent Задает процент выполнения преобразования.
Может принимать значения от 0 (преобразование еще не началось) до 100 (преобразование закончено).
Status Возвращает состояние выполнения преобразования.
Свойство может принимать следующие значения
  • 0 - если преобразование было остановлено
  • 1 - если оно было применено
  • 2 - если преобразование выполняется

[править] Методы, которые могут быть применены к фильтру Fade():

Метод | Описание
apply | Замораживает элемент страниы, после чего вы можете делать с ним все, что хотите. Для того, чтобы запустить преобразование, используйте метод Play().
play | Запускает преобразование.
stop | Немедленно останавливает преобразование.

[править] Примеры использования динамического фильтра Fade():

Пример 1:

<SCRIPT>
var bToggle = 0;
function fnToggle() {
    oDiv.filters[0].Apply();
// После того, как применяется метод Apply к выбранному объекту
// фильтр не запустится пока не будет вызван метод Play

    if (bToggle) {
        bToggle = 0;
        oDiv.style.backgroundColor="gold";}
    else {
        bToggle = 1;
        oDiv.style.backgroundColor="blue";}
    oDiv.filters[0].Play();
}
</SCRIPT>

<BUTTON onclick="fnToggle()">Toggle Transition</BUTTON><BR/><BR/>
<DIV ID="oDiv" STYLE="height:250px; width:250px; background-color: gold;
                filter:progid:DXImageTransform.Microsoft.Fade(
                duration=2);">
</DIV>

Пример 2:

<!-- К этому элементу применяется фильтр. -->

<DIV ID="oTransContainer" STYLE="position:absolute; top: 0px; left: 0px; width: 300px;
height:300px;  filter:progid:DXImageTransform.Microsoft.Fade(duration=1.0,overlap=1.0) ">

<!-- Это первое содержимое, которое будет показано. -->

    <DIV ID="oDIV1" STYLE="position:absolute; top:50px; left:10px; width:240px; height:160px;
    background:gold"> This is DIV #1  </DIV>

<!-- Это содержимое, которое будет показано после применения фильтра. -->

    <DIV ID="oDIV2" STYLE="visibility:hidden; position:absolute; top:50px; left:10px;
    width:240px; height:160px; background: yellowgreen; "> <BR> This is DIV #2
    </DIV>
</DIV>

<BUTTON onclick="fnToggle()">Toggle Transition</BUTTON>

<SCRIPT>
var bTranState = 0;
function fnToggle() {
    oTransContainer.filters[0].Apply();
    if (bTranState=="0") {
        bTranState = 1;
        oDIV2.style.visibility="visible";
        oDIV1.style.visibility="hidden";}
    else {
        bTranState = 0;
        oDIV2.style.visibility="hidden";
        oDIV1.style.visibility="visible";}
        oTransContainer.filters[0].Play();}
</SCRIPT>
Получено с http://spravkaweb.local/index.php/css/filter/dynamic/fade
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 18:16, 11 января 2007.
  • К этой странице обращались 61 раз.
1.33785581589


Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : GradientWipe — Справочник Web-языков

Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : GradientWipe

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Fade
Главная | ::. | CSS | ::. | Фильтры в Internet Explorer | ::. | Динамические фильтры | ::. | GradientWipe
 |  |  |  |  |  |  |  | Inset

[править] GradientWipe()

Создает наползание нового содержимого элемента страницы на старое, причем граница выглядит как градиентная полоса

[править] Синтаксис фильтра GradientWipe():

Где: | Общий пример использования: | Совместимость:
HTML | <ELEMENT STYLE="filter:progid:DXImageTransform.Microsoft.GradientWipe(sProperties)" ... > | Internet Explorer 5.5 или выше
Script | object.style.filter="progid:DXImageTransform.Microsoft.GradientWipe(sProperties)" | Internet Explorer 5.5 или выше

Здесь sProperties - строка, содержащая один или несколько свойств, задающих поведение фильтра.

[править] Свойства, используемые в фильтре GradientWipe():

Атрибуты
Исползуются в HTML 		Свойства
Исползуются в скриптах 		Описание
duration Duration Задает или возвращает продолжительность преобразования в секундах.
enabled Enabled Задает или возвращает признак разрешения применения фильтра.
Свойство может принимать следующие значения
  • true - разрешает применить фильтр (значение по умолчанию)
  • false - не разрешает
gradientSize GradientSize Задает или возвращает часть площади элемента страницы, которая будет покрыта градиентной полосой.
Может принимать значения от 0.0 до 1.0
motion Motion Задает или возвращает направление преобразования: прямое или обратное.
Свойство может принимать следующие значения
  • forward - движение происходит согласно значению свойства WipeStyle (значение по умолчанию)
  • reverse - в обратном направлении
Percent Задает процент выполнения преобразования.
Может принимать значения от 0 (преобразование еще не началось) до 100 (преобразование закончено).
Status Возвращает состояние выполнения преобразования.
Свойство может принимать следующие значения
  • 0 - если преобразование было остановлено
  • 1 - если оно было применено
  • 2 - если преобразование выполняется
WipeStyle Задает или возвращает направление преобразования: по горизонтали или по вертикали.
Свойство может принимать следующие значения
  • 0 - едвижение происходит по горизонтали (значение по умолчанию)
  • 1 - движение происходит по вертикали

[править] Методы, которые могут быть применены к фильтру GradientWipe():

Метод | Описание
apply | Замораживает элемент страниы, после чего вы можете делать с ним все, что хотите. Для того, чтобы запустить преобразование, используйте метод Play().
play | Запускает преобразование.
stop | Немедленно останавливает преобразование.

[править] Примеры использования динамического фильтра GradientWipe():

Пример 1:

<SCRIPT>
var bToggle = 0;
function fnToggle() {
    oDiv.filters[0].Apply();
// После того, как применяется метод Apply к выбранному объекту
// фильтр не запустится пока не будет вызван метод Play

    if (bToggle) {
        bToggle = 0;
        oDiv.style.backgroundColor="orange";}
    else {
        bToggle = 1;
        oDiv.style.backgroundColor="blue";}
    oDiv.filters[0].Play();
}
</SCRIPT>

<BUTTON onclick="fnToggle()">Toggle Transition</BUTTON><BR/><BR/>
<DIV ID="oDiv" STYLE="height:250px; width:250px; background-color: orange;
                filter:progid:DXImageTransform.Microsoft.gradientWipe(
                duration=3, gradientsize=0.5);">
</DIV>

Пример 2:

<!-- К этому элементу применяется фильтр. -->

<DIV ID="oTransContainer" STYLE="position:absolute; top: 0px; left: 0px; width: 300px;
height:300px;  filter:progid:DXImageTransform.Microsoft.Wipe(
        GradientSize=1.0, wipeStyle=0, motion=forward) ">

<!-- Это первое содержимое, которое будет показано. -->

<DIV ID="oDIV1" STYLE="position:absolute; top:50px; left:10px; width:240px; height:160px;
background:gold"> This is DIV #1  </DIV>

<!-- Это содержимое, которое будет показано после применения фильтра. -->

<DIV ID="oDIV2" STYLE="visibility:hidden; position:absolute; top:50px; left:10px;
width:240px; height:160px; background: yellowgreen; "> <BR> This is DIV #2</DIV>
</DIV>

<BUTTON onclick="fnToggle()">Toggle Transition</BUTTON>

<SCRIPT>
var bTranState = 0;
function fnToggle() {
    oTransContainer.filters[0].Apply();
    if (bTranState=="0") {
        bTranState = 1;
        oDIV2.style.visibility="visible";
        oDIV1.style.visibility="hidden";}
    else {
        bTranState = 0;
        oDIV2.style.visibility="hidden";
        oDIV1.style.visibility="visible";}
        oTransContainer.filters[0].Play(duration=2);}
</SCRIPT>
Получено с http://spravkaweb.local/index.php/css/filter/dynamic/gradientwipe
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 18:55, 11 января 2007.
  • К этой странице обращались 61 раз.
1.27830481529


Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Inset — Справочник Web-языков

Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Inset

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | GradientWipe
Главная | ::. | CSS | ::. | Фильтры в Internet Explorer | ::. | Динамические фильтры | ::. | Inset
 |  |  |  |  |  |  |  | Iris

[править] Inset()

Новое содержимое элемента страницы диагонально заменяет старое

[править] Синтаксис фильтра Inset():

Где: | Общий пример использования: | Совместимость:
HTML | <ELEMENT STYLE="filter:progid:DXImageTransform.Microsoft.Inset(sProperties)" ... > | Internet Explorer 5.5 или выше
Script | object.style.filter="progid:DXImageTransform.Microsoft.Inset(sProperties)" | Internet Explorer 5.5 или выше

Здесь sProperties - строка, содержащая один или несколько свойств, задающих поведение фильтра.

[править] Свойства, используемые в фильтре Inset():

Атрибуты
Исползуются в HTML 		Свойства
Исползуются в скриптах 		Описание
duration Duration Задает или возвращает продолжительность преобразования в секундах.
enabled Enabled Задает или возвращает признак разрешения применения фильтра.
Свойство может принимать следующие значения
  • true - разрешает применить фильтр (значение по умолчанию)
  • false - не разрешает
Percent Задает процент выполнения преобразования.
Может принимать значения от 0 (преобразование еще не началось) до 100 (преобразование закончено).
Status Возвращает состояние выполнения преобразования.
Свойство может принимать следующие значения
  • 0 - если преобразование было остановлено
  • 1 - если оно было применено
  • 2 - если преобразование выполняется

[править] Методы, которые могут быть применены к фильтру Inset():

Метод | Описание
apply | Замораживает элемент страниы, после чего вы можете делать с ним все, что хотите. Для того, чтобы запустить преобразование, используйте метод Play().
play | Запускает преобразование.
stop | Немедленно останавливает преобразование.

[править] Примеры использования динамического фильтра Inset():

Пример 1:

<SCRIPT>
var bToggle = 0;
function fnToggle() {
    oDiv.filters[0].Apply();
// После того, как применяется метод Apply к выбранному объекту
// фильтр не запустится пока не будет вызван метод Play

    if (bToggle) {
        bToggle = 0;
        oDiv.style.backgroundColor="gold";}
    else {
        bToggle = 1;
        oDiv.style.backgroundColor="blue";}
    oDiv.filters[0].Play(duration=2);  // Set duration as a parameter of Play.
}
</SCRIPT>

<BUTTON onclick="fnToggle()">Toggle Transition</BUTTON><BR/><BR/>
<DIV ID="oDiv" STYLE="height:250px; width:250px; background-color: gold;
                filter:progid:DXImageTransform.Microsoft.Inset( );">
</DIV>

Пример 2:

<SCRIPT>
var bTranState = 0;
function fnToggle() {
        oDIV2.filters[0].Apply();
    if (bTranState) {
        bTranState = 0;
        oDIV2.style.visibility="hidden";    }
    else {
        bTranState = 1;
        oDIV2.style.visibility="visible";   }
        oDIV2.filters[0].Play();
}
</SCRIPT>

<BUTTON onclick="fnToggle()">Toggle Transition</BUTTON>

<DIV ID="oDIV1" STYLE="position:absolute; top:50px; left:10px; width:240px; height:160px;
background:gold"> This is DIV #1  </DIV>

<DIV ID="oDIV2" STYLE="visibility:hidden; position:absolute; top:50px; left:10px;
width:240px; height:160px; background: yellowgreen;
filter:progid:DXImageTransform.Microsoft.Inset()">
<BR>This is DIV #2</DIV>
Получено с http://spravkaweb.local/index.php/css/filter/dynamic/inset
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:06, 11 января 2007.
  • К этой странице обращались 61 раз.
1.59134888649


Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Iris — Справочник Web-языков

Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Iris

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Inset
Главная | ::. | CSS | ::. | Фильтры в Internet Explorer | ::. | Динамические фильтры | ::. | Iris
 |  |  |  |  |  |  |  | Pixelate

[править] Iris()

Создает эффект радужной оболочки глаза, подобной открытию объектива камеры

[править] Синтаксис фильтра Iris():

Где: | Общий пример использования: | Совместимость:
HTML | <ELEMENT STYLE="filter:progid:DXImageTransform.Microsoft.Iris(sProperties)" ... &gt | Internet Explorer 5.5 или выше
Script | object.style.filter="progid:DXImageTransform.Microsoft.Iris(sProperties)" | Internet Explorer 5.5 или выше

Здесь sProperties - строка, содержащая один или несколько свойств, задающих поведение фильтра.

[править] Свойства, используемые в фильтре Iris():

Атрибуты
Исползуются в HTML 		Свойства
Исползуются в скриптах 		Описание
duration Duration Задает или возвращает продолжительность преобразования в секундах.
enabled Enabled Задает или возвращает признак разрешения применения фильтра.
Свойство может принимать следующие значения
  • true - разрешает применить фильтр (значение по умолчанию)
  • false - не разрешает
irisStyle IrisStyle Задает или возвращает форму лепестков.
Свойство может принимать следующие значения
  • Circle - в виде круга
  • Cross - в виде креста
  • Plus - плюс
  • Square - квадрат
  • Star - звезда
motion Motion Задает или возвращает направление движения: от центра к границам или наоборот.
Свойство может принимать два значения
  • out - движение происходит из центра к границам (значение по умолчанию)
  • in - движение происходит от границ к центру
Percent Задает процент выполнения преобразования.
Может принимать значения от 0 (преобразование еще не началось) до 100 (преобразование закончено).
Status Возвращает состояние выполнения преобразования.
Свойство может принимать следующие значения
  • 0 - если преобразование было остановлено
  • 1 - если оно было применено
  • 2 - если преобразование выполняется

[править] Методы, которые могут быть применены к фильтру Iris():

Метод | Описание
apply | Замораживает элемент страниы, после чего вы можете делать с ним все, что хотите. Для того, чтобы запустить преобразование, используйте метод Play().
play | Запускает преобразование.
stop | Немедленно останавливает преобразование.

[править] Примеры использования динамического фильтра Iris():

Пример 1:

<SCRIPT>
<!-- Задаем массив с возможными значениями параметра IrisStyles. -->
var arrIrisStyles = new Array();
arrIrisStyles = [DIAMOND,CIRCLE,CROSS,PLUS,SQUARE,STAR];
var iIndexCount = 0;

var bToggle = 0;

function fnToggle() {

<!-- Используем массив для отображения параметра IrisStyles. -->
var  iStyleIndex = iIndexCount%6 ;  // MOD функция предотвращает
                                    // повторную установку счетчика.
    oDiv.filters[0].irisstyle = arrIrisStyles[iStyleIndex];
    oSpan.innerText = IrisStyle = " + arrIrisStyles[iStyleIndex] + ";

    oDiv.filters[0].Apply();
// После того, как применяется метод Apply к выбранному объекту
// фильтр не запустится пока не будет вызван метод Play

    if (bToggle) {
        bToggle = 0;
        oDiv.style.backgroundColor="gold";
    }
    else {
        bToggle = 1;
        oDiv.style.backgroundColor="green";
    }

    oDiv.filters[0].Play();
    iIndexCount += 1;
}
</SCRIPT>
<BUTTON onclick="fnToggle()">Запустить преобразование</BUTTON><BR/><BR/>

<FONT SIZE="+4" >
<!-- This DIV is the target of the transition. -->
    <DIV ID="oDiv" STYLE="height:250px; width:250px; background-color: gold;
                filter:progid:DXImageTransform.Microsoft.Iris(
                duration=3);">
        TEXT<BR/>TEXT<BR/>TEXT<BR/>TEXT<BR/>
    </DIV>

<SPAN ID="oSpan"></SPAN>

Пример 2:

<!-- К этому элементу применяется фильтр. -->

<DIV ID="oTransContainer" STYLE="position:absolute; top: 0px; left: 0px; width: 300px;
height:300px;  filter:progid:DXImageTransform.Microsoft.Iris(irisStyle=SQUARE, motion=in) ">

<!-- Это первое содержимое, которое будет показано. -->

    <DIV ID="oDIV1" STYLE="position:absolute; top:50px; left:10px; width:240px; height:160px;
    background:gold"> This is DIV #1  </DIV>

<!-- Это содержимое, которое будет показано после применения фильтра. -->

    <DIV ID="oDIV2" STYLE="visibility:hidden; position:absolute; top:50px; left:10px;
    width:240px; height:160px; background: yellowgreen; "> <BR> This is DIV #2
    </DIV>
</DIV>

<BUTTON onclick="fnToggle()">Запустить преобразование</BUTTON>

<SCRIPT>
var bTranState = 0;
function fnToggle() {
    oTransContainer.filters[0].Apply();
    if (bTranState=="0") {
        bTranState = 1;
        oDIV2.style.visibility="visible";
        oDIV1.style.visibility="hidden";}
    else {
        bTranState = 0;
        oDIV2.style.visibility="hidden";
        oDIV1.style.visibility="visible";}
        oTransContainer.filters[0].Play();}
</SCRIPT>
Получено с http://spravkaweb.local/index.php/css/filter/dynamic/iris
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:22, 11 января 2007.
  • К этой странице обращались 61 раз.
1.30646395683


Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Pixelate — Справочник Web-языков

Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Pixelate

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Iris
Главная | ::. | CSS | ::. | Фильтры в Internet Explorer | ::. | Динамические фильтры | ::. | Pixelate
 |  |  |  |  |  |  |  | RadialWipe

[править] Pixelate()

Старое содержимое элемента страницы рассыпается на отдельные пикселы, а новое содержимое собирается из отдельных пикселов

[править] Синтаксис фильтра Pixelate():

Где: | Общий пример использования: | Совместимость:
HTML | <ELEMENT STYLE="filter:progid:DXImageTransform.Microsoft.Pixelate(sProperties)" ... > | Internet Explorer 5.5 или выше
Script | object.style.filter="progid:DXImageTransform.Microsoft.Pixelate(sProperties)" | Internet Explorer 5.5 или выше

Здесь sProperties - строка, содержащая один или несколько свойств, задающих поведение фильтра.

[править] Свойства, используемые в фильтре Pixelate():

Атрибуты
Исползуются в HTML 		Свойства
Исползуются в скриптах 		Описание
duration | Duration | Задает или возвращает продолжительность преобразования в секундах.
enabled Enabled Задает или возвращает признак разрешения применения фильтра.
Свойство может принимать следующие значения
  • true - разрешает применить фильтр (значение по умолчанию)
  • false - не разрешает
maxSquare | MaxSquare | Задает или возвращает максимальную ширину в пиксельных квадратах.
Percent Задает процент выполнения преобразования.
Может принимать значения от 0 (преобразование еще не началось) до 100 (преобразование закончено).
Status Возвращает состояние выполнения преобразования.
Свойство может принимать следующие значения
  • 0 - если преобразование было остановлено
  • 1 - если оно было применено
  • 2 - если преобразование выполняется

[править] Методы, которые могут быть применены к фильтру Pixelate():

Метод | Описание
apply | Замораживает элемент страниы, после чего вы можете делать с ним все, что хотите. Для того, чтобы запустить преобразование, используйте метод Play().
play | Запускает преобразование.
stop | Немедленно останавливает преобразование.

[править] Примеры использования динамического фильтра Pixelate():

Пример 1:

<SCRIPT>
var bToggle = 0;
function fnToggle() {
    oDiv.filters[0].Apply();
// После того, как применяется метод Apply к выбранному объекту
// фильтр не запустится пока не будет вызван метод Play

    if (bToggle) {
        bToggle = 0;
        oDiv.style.visibility="visible";  }
    else {
        bToggle = 1;
        oDiv.style.visibility="hidden"; }
    oDiv.filters[0].Play();
}
</SCRIPT>

<BUTTON onclick="fnToggle()">Запустить преобразование</BUTTON><BR/><BR/>
<FONT SIZE="+4">
    <DIV ID="oDiv" STYLE="width:100px; background-color: lightblue;
                filter:progid:DXImageTransform.Microsoft.Pixelate(
                duration=3, enabled=false);">
         Text<BR/>Text<BR/>Text<BR/>
    </DIV>
</FONT>

Пример 2:

<!-- К этому элементу применяется фильтр. -->

<DIV ID="oTransContainer" STYLE="position:absolute; top: 0px; left: 0px; width: 300px;
height:300px;  filter:progid:DXImageTransform.Microsoft.Pixelate(MaxSquare=50,
  Duration=1, Enabled=false) ">

<!-- Это первое содержимое, которое будет показано. -->

    <DIV ID="oDIV1" STYLE="position:absolute; top:50px; left:10px; width:240px; height:160px;
    background:gold"> This is DIV #1  </DIV>

<!-- Это содержимое, которое будет показано после применения фильтра. -->

    <DIV ID="oDIV2" STYLE="visibility:hidden; position:absolute; top:50px; left:10px;
    width:240px; height:160px; background: yellowgreen; "> <BR> This is DIV #2
    </DIV>
</DIV>

<BUTTON onclick="fnToggle()">Запустить преобразование</BUTTON>

<SCRIPT>
var bTranState = 0;
function fnToggle() {
    oTransContainer.filters[0].enabled = true;
    oTransContainer.filters[0].Apply();
    if (bTranState=="0") {
        bTranState = 1;
        oDIV2.style.visibility="visible";
        oDIV1.style.visibility="hidden";}
    else {
        bTranState = 0;
        oDIV2.style.visibility="hidden";
        oDIV1.style.visibility="visible";}
        oTransContainer.filters[0].Play();}
</SCRIPT>
Получено с http://spravkaweb.local/index.php/css/filter/dynamic/pixelate
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:27, 11 января 2007.
  • К этой странице обращались 60 раз.
1.37970709801


Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : RadialWipe — Справочник Web-языков

Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : RadialWipe

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Pixelate
Главная | ::. | CSS | ::. | Фильтры в Internet Explorer | ::. | Динамические фильтры | ::. | RadialWipe
 |  |  |  |  |  |  |  | RandomBars

[править] RadialWipe()

Старое содержание элемента радиально стирается, наподобие стиранию дворниками на стекле, а новое появляется

[править] Синтаксис фильтра RadialWipe():

Где: | Общий пример использования: | Совместимость:
HTML | <ELEMENT STYLE="filter:progid:DXImageTransform.Microsoft.RadialWipe(sProperties)" ... > | Internet Explorer 5.5 или выше
Script | object.style.filter="progid:DXImageTransform.Microsoft.RadialWipe(sProperties)" | Internet Explorer 5.5 или выше

Здесь sProperties - строка, содержащая один или несколько свойств, задающих поведение фильтра.

[править] Свойства, используемые в фильтре RadialWipe():

Атрибуты
Исползуются в HTML 		Свойства
Исползуются в скриптах 		Описание
duration Duration Задает или возвращает продолжительность преобразования в секундах.
enabled Enabled Задает или возвращает признак разрешения применения фильтра.
Свойство может принимать следующие значения
  • true - разрешает применить фильтр (значение по умолчанию)
  • false - не разрешает
wipeStyle WipeStyle Задает или возвращает метод, которым будет показываться новое содержимое.
Свойство может принимать следующие значения
  • clock - вращение вокруг центра элемента страницы по часовой стрелке (значение по умолчанию)
  • wedge - вращение сразу в обе стороны вокруг центра элемента
  • radial - радиальное вращение относительно верхнего левого угла
Percent Задает процент выполнения преобразования.
Может принимать значения от 0 (преобразование еще не началось) до 100 (преобразование закончено).
Status Возвращает состояние выполнения преобразования.
Свойство может принимать следующие значения
  • 0 - если преобразование было остановлено
  • 1 - если оно было применено
  • 2 - если преобразование выполняется

[править] Методы, которые могут быть применены к фильтру RadialWipe():

Метод | Описание
apply | Замораживает элемент страниы, после чего вы можете делать с ним все, что хотите. Для того, чтобы запустить преобразование, используйте метод Play().
play | Запускает преобразование.
stop | Немедленно останавливает преобразование.

[править] Примеры использования динамического фильтра RadialWipe():

Пример 1:

<SCRIPT>
<!-- Declare an array and index counter to access wipeStyles. -->
var arrWipeStyles = new Array();
arrWipeStyles = [CLOCK,WEDGE,RADIAL];
var iIndexCount = 0;

var bToggle = 0;

function fnToggle() {

<!-- Используем массив для изменения и отображения WipeStyle -->
var  iStyleIndex = iIndexCount%3 ;  // MOD function avoids resetting the counter.
    oDiv.filters[0].wipeStyle = arrWipeStyles[iStyleIndex];
    oSpan.innerText = WipeStyle = " + arrWipeStyles[iStyleIndex] + ";

    oDiv.filters[0].Apply();
// После того, как применяется метод Apply к выбранному объекту
// фильтр не запустится пока не будет вызван метод Play

    if (bToggle) {
        bToggle = 0;
        oDiv.style.backgroundColor="gold";  }
    else {
        bToggle = 1;
        oDiv.style.backgroundColor="green"; }

    oDiv.filters[0].Play();
    iIndexCount += 1;
}
</SCRIPT>
<BUTTON onclick="fnToggle()">Запустить преобразование</BUTTON><BR/><BR/>

<FONT SIZE="+4" >
<!-- Этот DIV является целью перехода -->
    <DIV ID="oDiv" STYLE="height:250px; width:250px; background-color: gold;
                filter:progid:DXImageTransform.Microsoft.RadialWipe(
                duration=2);">
        TEXT<BR/>TEXT<BR/>TEXT<BR/>TEXT<BR/>
    </DIV>

<SPAN ID="oSpan"></SPAN>
</FONT>

Пример 2:

<!-- К этому элементу применяется фильтр. -->

<DIV ID="oTransContainer" STYLE="position:absolute; top: 0px; left: 0px; width: 300px;
height:300px;  filter:progid:DXImageTransform.Microsoft.RadialWipe(wipeStyle=clock) ">

<!-- Это первое содержимое, которое будет показано. -->

    <DIV ID="oDIV1" STYLE="position:absolute; top:50px; left:10px; width:240px; height:160px;
    background:gold"> This is DIV #1  </DIV>

<!-- Это содержимое, которое будет показано после применения фильтра. -->

    <DIV ID="oDIV2" STYLE="visibility:hidden; position:absolute; top:50px; left:10px;
    width:240px; height:160px; background: yellowgreen; "> <BR> This is DIV #2
    </DIV>
</DIV>

<BUTTON onclick="fnToggle()">Запустить преобразование</BUTTON>

<SCRIPT>
var bTranState = 0;
function fnToggle() {
    oTransContainer.filters[0].Apply();
    if (bTranState=="0") {
        bTranState = 1;
        oDIV2.style.visibility="visible";
        oDIV1.style.visibility="hidden";}
    else {
        bTranState = 0;
        oDIV2.style.visibility="hidden";
        oDIV1.style.visibility="visible";}
        oTransContainer.filters[0].Play();}
</SCRIPT>
Получено с http://spravkaweb.local/index.php/css/filter/dynamic/radialwipe
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 20:01, 11 января 2007.
  • К этой странице обращались 62 раза.
1.30928397179


Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : RandomBars — Справочник Web-языков

Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : RandomBars

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | RadialWipe
Главная | ::. | CSS | ::. | Фильтры в Internet Explorer | ::. | Динамические фильтры | ::. | RandomBars
 |  |  |  |  |  |  |  | RandomDissolve

[править] RandomBars()

Старое содержимое элемента страницы рассыпается на отдельные линии, а новое содержимое собирается из отдельных линий

[править] Синтаксис фильтра RandomBars():

Где: | Общий пример использования: | Совместимость:
HTML | <ELEMENT STYLE="filter:progid:DXImageTransform.Microsoft.RandomBars(sProperties)" ... > | Internet Explorer 5.5 или выше
Script | object.style.filter="progid:DXImageTransform.Microsoft.RandomBars(sProperties)" | Internet Explorer 5.5 или выше

Здесь sProperties - строка, содержащая один или несколько свойств, задающих поведение фильтра.

[править] Свойства, используемые в фильтре RandomBars():

Атрибуты
Исползуются в HTML 		Свойства
Исползуются в скриптах 		Описание
duration Duration Задает или возвращает продолжительность преобразования в секундах.
enabled Enabled Задает или возвращает признак разрешения применения фильтра.
Свойство может принимать следующие значения
  • true - разрешает применить фильтр (значение по умолчанию)
  • false - не разрешает
orientation Orientation Задает или возвращает направление преобразования.
Свойство может принимать следующие значения
  • horizontal - преобразование происходит в вертикальной плоскости (значение по умолчанию)
  • vertical - преобразование происходит в вертикальной плоскости
Percent Задает процент выполнения преобразования.
Может принимать значения от 0 (преобразование еще не началось) до 100 (преобразование закончено).
Status Возвращает состояние выполнения преобразования.
Свойство может принимать следующие значения
  • 0 - если преобразование было остановлено
  • 1 - если оно было применено
  • 2 - если преобразование выполняется

[править] Методы, которые могут быть применены к фильтру RandomBars():

Метод | Описание
apply | Замораживает элемент страниы, после чего вы можете делать с ним все, что хотите. Для того, чтобы запустить преобразование, используйте метод Play().
play | Запускает преобразование.
stop | Немедленно останавливает преобразование.

[править] Примеры использования динамического фильтра RandomBars():

Пример 1:

<SCRIPT>
var bToggle = 0;
function fnToggle() {
    oDiv.filters[0].orientation="vertical";
    oDiv.filters[0].Apply();
// После того, как применяется метод Apply к выбранному объекту
// фильтр не запустится пока не будет вызван метод Play

    if (bToggle) {
        bToggle = 0;
        oDiv.style.backgroundColor="gold";}
    else {
        bToggle = 1;
        oDiv.style.backgroundColor="blue";}
    oDiv.filters[0].Play();
}
</SCRIPT>

<BUTTON onclick="fnToggle()">Запустить преобразование</BUTTON><BR/><BR/>
<DIV ID="oDiv" STYLE="height:250px; width:250px; background-color: gold;
                filter:progid:DXImageTransform.Microsoft.RandomBars(
                duration=5);">
</DIV>

Пример 2:

<!-- К этому элементу применяется фильтр. -->

<DIV ID="oTransContainer" STYLE="position:absolute; top: 0px; left: 0px; width: 300px;
height:300px;  filter:progid:DXImageTransform.Microsoft.RandomBars(orientation=horizontal) ">

<!-- Это первое содержимое, которое будет показано. -->

    <DIV ID="oDIV1" STYLE="position:absolute; top:50px; left:10px; width:240px; height:160px;
    background:gold"> This is DIV #1  </DIV>

<!-- Это содержимое, которое будет показано после применения фильтра. -->

    <DIV ID="oDIV2" STYLE="visibility:hidden; position:absolute; top:50px; left:10px;
    width:240px; height:160px; background: yellowgreen; "> <BR> This is DIV #2
    </DIV>
</DIV>

<BUTTON onclick="fnToggle()">Запустить преобразование</BUTTON>

<SCRIPT>
var bTranState = 0;
function fnToggle() {
    oTransContainer.filters[0].Apply();
    if (bTranState=="0") {
        bTranState = 1;
        oDIV2.style.visibility="visible";
        oDIV1.style.visibility="hidden";}
    else {
        bTranState = 0;
        oDIV2.style.visibility="hidden";
        oDIV1.style.visibility="visible";}
        oTransContainer.filters[0].Play();}
</SCRIPT>
Получено с http://spravkaweb.local/index.php/css/filter/dynamic/randombars
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 20:07, 11 января 2007.
  • К этой странице обращались 64 раза.
1.56781411171


Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : RandomDissolve — Справочник Web-языков

Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : RandomDissolve

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | RandomBars
Главная | ::. | CSS | ::. | Фильтры в Internet Explorer | ::. | Динамические фильтры | ::. | RandomDissolve
 |  |  |  |  |  |  |  | Slide

[править] RandomDissolve()

Создает эффект поточечного появления нового содержимого на месте старого

[править] Синтаксис фильтра RandomDissolve():

Где: | Общий пример использования: | Совместимость:
HTML | <ELEMENT STYLE="filter:progid:DXImageTransform.Microsoft.RandomDissolve(sProperties)" ... > | Internet Explorer 5.5 или выше
Script | object.style.filter="progid:DXImageTransform.Microsoft.RandomDissolve(sProperties)" | Internet Explorer 5.5 или выше

Здесь sProperties - строка, содержащая один или несколько свойств, задающих поведение фильтра.

[править] Свойства, используемые в фильтре RandomDissolve():

Атрибуты
Исползуются в HTML 		Свойства
Исползуются в скриптах 		Описание
duration Duration Задает или возвращает продолжительность преобразования в секундах.
enabled Enabled Задает или возвращает признак разрешения применения фильтра.
Свойство может принимать следующие значения
  • true - разрешает применить фильтр (значение по умолчанию)
  • false - не разрешает
Percent Задает процент выполнения преобразования.
Может принимать значения от 0 (преобразование еще не началось) до 100 (преобразование закончено).
Status Возвращает состояние выполнения преобразования.
Свойство может принимать следующие значения
  • 0 - если преобразование было остановлено
  • 1 - если оно было применено
  • 2 - если преобразование выполняется

[править] Методы, которые могут быть применены к фильтру RandomDissolve():

Метод | Описание
apply | Замораживает элемент страниы, после чего вы можете делать с ним все, что хотите. Для того, чтобы запустить преобразование, используйте метод Play().
play | Запускает преобразование.
stop | Немедленно останавливает преобразование.

[править] Примеры использования динамического фильтра RandomDissolve():

Пример 1:

<SCRIPT>
var bToggle = 0;
function fnToggle() {
    oDiv.filters[0].Apply();
// После того, как применяется метод Apply к выбранному объекту
// фильтр не запустится пока не будет вызван метод Play

    if (bToggle) {
        bToggle = 0;
        oDiv.style.visibility="visible";  }
    else {
        bToggle = 1;
        oDiv.style.visibility="hidden"; }
    oDiv.filters[0].Play();
}
</SCRIPT>

<BUTTON onclick="fnToggle()">Запустить преобразование</BUTTON><BR/><BR/>
<DIV ID="oDiv" STYLE="height:250px; width:250px; background-color: gold;
                filter:progid:DXImageTransform.Microsoft.RandomDissolve(
                duration=3);">
    <FONT SIZE="+4" COLOR="#A08000">
        TEXT<BR/>TEXT<BR/>TEXT<BR/>TEXT<BR/>
    </FONT>
</DIV>

Пример 2:

<!-- К этому элементу применяется фильтр. -->

<DIV ID="oTransContainer" STYLE="position:absolute; top: 0px; left: 0px; width: 300px;
height:300px;  filter:progid:DXImageTransform.Microsoft.RandomDissolve() ">

<!-- Это первое содержимое, которое будет показано. -->

    <DIV ID="oDIV1" STYLE="position:absolute; top:50px; left:10px; width:240px; height:160px;
    background:gold"> This is DIV #1  </DIV>

<!-- Это содержимое, которое будет показано после применения фильтра. -->

    <DIV ID="oDIV2" STYLE="visibility:hidden; position:absolute; top:50px; left:10px;
    width:240px; height:160px; background: yellowgreen; "> <BR> This is DIV #2
    </DIV>
</DIV>

<BUTTON onclick="fnToggle()">Запустить преобразование</BUTTON>

<SCRIPT>
var bTranState = 0;
function fnToggle() {
    oTransContainer.filters[0].Apply();
    if (bTranState=="0") {
        bTranState = 1;
        oDIV2.style.visibility="visible";
        oDIV1.style.visibility="hidden";}
    else {
        bTranState = 0;
        oDIV2.style.visibility="hidden";
        oDIV1.style.visibility="visible";}
        oTransContainer.filters[0].Play();}
</SCRIPT>
Получено с http://spravkaweb.local/index.php/css/filter/dynamic/randomdissolve
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 20:12, 11 января 2007.
  • К этой странице обращались 61 раз.
1.49041509628


Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Slide — Справочник Web-языков

Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Slide

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | RandomDissolve
Главная | ::. | CSS | ::. | Фильтры в Internet Explorer | ::. | Динамические фильтры | ::. | Slide
 |  |  |  |  |  |  |  | Spiral

[править] Slide()

Старое содержимое элемента страницы сдвигается в сторону, открывая под собой новое содержимое (эффект слайдов)

[править] Синтаксис фильтра Slide():

Где: | Общий пример использования: | Совместимость:
HTML | <ELEMENT STYLE="filter:progid:DXImageTransform.Microsoft.Slide(sProperties)" ... > | Internet Explorer 5.5 или выше
Script | object.style.filter="progid:DXImageTransform.Microsoft.Slide(sProperties)" | Internet Explorer 5.5 или выше

Здесь sProperties - строка, содержащая один или несколько свойств, задающих поведение фильтра.

[править] Свойства, используемые в фильтре Slide():

Атрибуты
Исползуются в HTML 		Свойства
Исползуются в скриптах 		Описание
slideStyle SlideStyle Задает или возвращает способ замещения старого содержимого элемента страницы новым.
Свойство может принимать следующие значения
  • Hide - Старое содержимое уходит влево открывая под собой новое содержимое элемента страницы (значение по умолчанию)
  • Push - новое содержимое идет вслед за старым
  • Swap - старое и новое содерижимое страницы как бы меняются местами
bands | Bands | Задает или возвращает количество полос, на которые разбиваются элементы страницы при преобразовании
duration | Duration | Задает или возвращает продолжительность преобразования в секундах.
enabled Enabled Задает или возвращает признак разрешения применения фильтра.
Свойство может принимать следующие значения
  • true - разрешает применить фильтр (значение по умолчанию)
  • false - не разрешает
Percent Задает процент выполнения преобразования.
Может принимать значения от 0 (преобразование еще не началось) до 100 (преобразование закончено).
Status Возвращает состояние выполнения преобразования.
Свойство может принимать следующие значения
  • 0 - если преобразование было остановлено
  • 1 - если оно было применено
  • 2 - если преобразование выполняется

[править] Методы, которые могут быть применены к фильтру Slide():

Метод | Описание
apply | Замораживает элемент страниы, после чего вы можете делать с ним все, что хотите. Для того, чтобы запустить преобразование, используйте метод Play().
play | Запускает преобразование.
stop | Немедленно останавливает преобразование.

[править] Примеры использования динамического фильтра Slide():

Пример 1:

<SCRIPT>
<!-- Declare an array and index counter to access  slideStyles. -->
var arrSlideStyles = new Array();
arrSlideStyles = [HIDE,PUSH,SWAP];
var iIndexCount = 0;

var bToggle = 0;

function fnToggle() {

<!-- В массиве задаем значения для параметра slideStyle. -->
var  iStyleIndex = iIndexCount%3 ;  // MOD function avoids resetting the counter.
    oDiv.filters[0].slideStyle = arrSlideStyles[iStyleIndex];
    oSpan.innerText = SlideStyle = " + arrSlideStyles[iStyleIndex] + ";

    oDiv.filters[0].Apply();
// После того, как применяется метод Apply к выбранному объекту
// фильтр не запустится пока не будет вызван метод Play

    if (bToggle) {
        bToggle = 0;
        oDiv.style.backgroundColor="gold";
    }
    else {
        bToggle = 1;
        oDiv.style.backgroundColor="green";
     }

    oDiv.filters[0].Play();
    iIndexCount += 1;
}
</SCRIPT>
<BUTTON onclick="fnToggle()">Запустить преобразование</BUTTON><BR/><BR/>

<FONT SIZE="+4" >
<!-- This DIV is the target of the transition. -->
    <DIV ID="oDiv" STYLE="height:250px; width:250px; background-color: gold;
                filter:progid:DXImageTransform.Microsoft.Slide(
                duration=3, bands=8);">
        TEXT<BR/>TEXT<BR/>TEXT<BR/>TEXT<BR/>
    </DIV>

<SPAN ID="oSpan"></SPAN>
</FONT>

Пример 2:

<!-- К этому элементу применяется фильтр. -->

<DIV ID="oTransContainer" STYLE="position:absolute; top: 0px; left: 0px; width: 300px;
height:300px;  filter:progid:DXImageTransform.Microsoft.Slide(slideStyle=SWAP, bands=5) ">

<!-- Это первое содержимое, которое будет показано. -->

    <DIV ID="oDIV1" STYLE="position:absolute; top:50px; left:10px; width:240px; height:160px;
    background:gold"> This is DIV #1  </DIV>

<!-- Это содержимое, которое будет показано после применения фильтра. -->

    <DIV ID="oDIV2" STYLE="visibility:hidden; position:absolute; top:50px; left:10px;
    width:240px; height:160px; background: yellowgreen; "> <BR> This is DIV #2
    </DIV>
</DIV>

<BUTTON onclick="fnToggle()">Запустить преобразование</BUTTON>

<SCRIPT>
var bTranState = 0;
function fnToggle() {
    oTransContainer.filters[0].Apply();
    if (bTranState=="0") {
        bTranState = 1;
        oDIV2.style.visibility="visible";
        oDIV1.style.visibility="hidden";}
    else {
        bTranState = 0;
        oDIV2.style.visibility="hidden";
        oDIV1.style.visibility="visible";}
        oTransContainer.filters[0].Play();}
</SCRIPT>
Получено с http://spravkaweb.local/index.php/css/filter/dynamic/slide
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 20:18, 11 января 2007.
  • К этой странице обращались 66 раз.
1.46522808075


Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Spiral — Справочник Web-языков

Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Spiral

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Slide
Главная | ::. | CSS | ::. | Фильтры в Internet Explorer | ::. | Динамические фильтры | ::. | Spiral
 |  |  |  |  |  |  |  | Stretch

[править] Spiral()

Старое содержимое элемента страницы спирально закрашивается новым содержимым

[править] Синтаксис фильтра Spiral():

Где: | Общий пример использования: | Совместимость:
HTML | <ELEMENT STYLE="filter:progid:DXImageTransform.Microsoft.Spiral(sProperties)" ... > | Internet Explorer 5.5 или выше
Script | object.style.filter="progid:DXImageTransform.Microsoft.Spiral(sProperties)" | Internet Explorer 5.5 или выше

Здесь sProperties - строка, содержащая один или несколько свойств, задающих поведение фильтра.

[править] Свойства, используемые в фильтре Spiral():

Атрибуты
Исползуются в HTML 		Свойства
Исползуются в скриптах 		Описание
gridSizeX GridSizeX Задает или возвращает ширину закрашивающей полоски по горизонтали.
Свойство может принимать значение от 1 до 100.
gridSizeY GridSizeY Задает или возвращает ширину закрашивающей полоски по вертикали.
Свойство может принимать значение от 1 до 100.
duration Duration Задает или возвращает продолжительность преобразования в секундах.
enabled Enabled Задает или возвращает признак разрешения применения фильтра.
Свойство может принимать следующие значения
  • true - разрешает применить фильтр (значение по умолчанию)
  • false - не разрешает
Percent Задает процент выполнения преобразования.
Может принимать значения от 0 (преобразование еще не началось) до 100 (преобразование закончено).
Status Возвращает состояние выполнения преобразования.
Свойство может принимать следующие значения
  • 0 - если преобразование было остановлено
  • 1 - если оно было применено
  • 2 - если преобразование выполняется

[править] Методы, которые могут быть применены к фильтру Spiral():

Метод | Описание
apply | Замораживает элемент страниы, после чего вы можете делать с ним все, что хотите. Для того, чтобы запустить преобразование, используйте метод Play().
play | Запускает преобразование.
stop | Немедленно останавливает преобразование.

[править] Примеры использования динамического фильтра Spiral():

Пример 1:

<SCRIPT>
var bToggle = 0;
function fnToggle() {
    oDiv.filters[0].Apply();
// После того, как применяется метод Apply к выбранному объекту
// фильтр не запустится пока не будет вызван метод Play

    if (bToggle) {
        bToggle = 0;
        oDiv.style.visibility="visible";  }
    else {
        bToggle = 1;
        oDiv.style.visibility="hidden"; }

    oDiv.filters[0].Play();
}
</SCRIPT>

<BUTTON onclick="fnToggle()">Запустить преобразование</BUTTON><BR/><BR/>
<DIV ID="oDiv" STYLE="height:250px; width:250px; background-color: gold;
                filter:progid:DXImageTransform.Microsoft.Spiral(
                duration=3, GridSizeX=25, GridSizeY=25);">
    <FONT SIZE="+4" COLOR="#A08000">
        TEXT<BR/>TEXT<BR/>TEXT<BR/>TEXT<BR/>
    </FONT>
</DIV>

Пример 2:

<!-- К этому элементу применяется фильтр. -->

<DIV ID="oTransContainer" STYLE="position:absolute; top: 0px; left: 0px; width: 300px;
height:300px;  filter:progid:DXImageTransform.Microsoft.Spiral(GridSizeX=8, GridSizeY=64) ">

<!-- Это первое содержимое, которое будет показано. -->

    <DIV ID="oDIV1" STYLE="position:absolute; top:50px; left:10px; width:240px; height:160px;
    background:gold"> This is DIV #1  </DIV>

<!-- Это содержимое, которое будет показано после применения фильтра. -->

    <DIV ID="oDIV2" STYLE="visibility:hidden; position:absolute; top:50px; left:10px;
    width:240px; height:160px; background: yellowgreen; "> <BR> This is DIV #2
    </DIV>
</DIV>

<BUTTON onclick="fnToggle()">Запустить преобразование</BUTTON>

<SCRIPT>
var bTranState = 0;
function fnToggle() {
    oTransContainer.filters[0].Apply();
    if (bTranState=="0") {
        bTranState = 1;
        oDIV2.style.visibility="visible";
        oDIV1.style.visibility="hidden";}
    else {
        bTranState = 0;
        oDIV2.style.visibility="hidden";
        oDIV1.style.visibility="visible";}
        oTransContainer.filters[0].Play();}
</SCRIPT>
Получено с http://spravkaweb.local/index.php/css/filter/dynamic/spiral
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 20:24, 11 января 2007.
  • К этой странице обращались 65 раз.
1.2790749073


Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Stretch — Справочник Web-языков

Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Stretch

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Spiral
Главная | ::. | CSS | ::. | Фильтры в Internet Explorer | ::. | Динамические фильтры | ::. | Stretch
 |  |  |  |  |  |  |  | Strips

[править] Stretch()

Этот фильтр растягивает новое содержимое элемента страницы, тем самым закрывая старое содержимое

[править] Синтаксис фильтра Stretch():

Где: | Общий пример использования: | Совместимость:
HTML | <ELEMENT STYLE="filter:progid:DXImageTransform.Microsoft.Stretch(sProperties)" ... < | Internet Explorer 5.5 или выше
Script | object.style.filter="progid:DXImageTransform.Microsoft.Stretch(sProperties)" | Internet Explorer 5.5 или выше

Здесь sProperties - строка, содержащая один или несколько свойств, задающих поведение фильтра.

[править] Свойства, используемые в фильтре Stretch():

Атрибуты
Исползуются в HTML 		Свойства
Исползуются в скриптах 		Описание
stretchStyle StretchStyle Задает или возвращает способ замещения старого содержания элемента страницы новым.
Для свойства доступны следующие значения
  • Hide - новое содержание элемента наползает на старое слева на право (значение по умолчанию)
  • Spin - новое содержание элемента страницы наползает на старое из середины элемента к бокам
  • Push - новое содержание элемента страницы раздвигаясь с левого бока, сжимает старое содержание
duration Duration Задает или возвращает продолжительность преобразования в секундах.
enabled Enabled Задает или возвращает признак разрешения применения фильтра.
Свойство может принимать следующие значения
  • true - разрешает применить фильтр (значение по умолчанию)
  • false - не разрешает
Percent Задает процент выполнения преобразования.
Может принимать значения от 0 (преобразование еще не началось) до 100 (преобразование закончено).
Status Возвращает состояние выполнения преобразования.
Свойство может принимать следующие значения
  • 0 - если преобразование было остановлено
  • 1 - если оно было применено
  • 2 - если преобразование выполняется

[править] Методы, которые могут быть применены к фильтру Stretch():

Метод | Описание
apply | Замораживает элемент страниы, после чего вы можете делать с ним все, что хотите. Для того, чтобы запустить преобразование, используйте метод Play().
play | Запускает преобразование.
stop | Немедленно останавливает преобразование.

[править] Примеры использования динамического фильтра Stretch():

Пример 1:

<SCRIPT<
<!-- Задаем в массиве значения свойства stretchStyles. --<
var arrStretchStyles = new Array();
arrStretchStyles = [HIDE,PUSH,SPIN];
var iIndexCount = 0;

var bToggle = 0;

function fnToggle() {

<!-- Use the array index to update and display  the stretchStyle used. --<
var  iStyleIndex = iIndexCount%3 ;  // MOD function avoids resetting the counter.
    oDiv.filters[0].stretchstyle = arrStretchStyles[iStyleIndex];
    oSpan.innerText = StretchStyle = " + arrStretchStyles[iStyleIndex] + ";

    oDiv.filters[0].Apply();
// После того, как применяется метод Apply к выбранному объекту
// фильтр не запустится пока не будет вызван метод Play

    if (bToggle) {
        bToggle = 0;
        oDiv.style.backgroundColor="gold";
    }
    else {
        bToggle = 1;
        oDiv.style.backgroundColor="green";
    }

    oDiv.filters[0].Play();
    iIndexCount += 1;
}
</SCRIPT<
<BUTTON onclick="fnToggle()"<Запустить преобразование</BUTTON<<BR/<<BR/<

<FONT SIZE="+4" <
<!-- This DIV is the target of the transition. --<
    <DIV ID="oDiv" STYLE="height:250px; width:250px; background-color: gold;
                filter:progid:DXImageTransform.Microsoft.Stretch(
                duration=3);"<
        TEXT<BR/<TEXT<BR/<TEXT<BR/<TEXT<BR/<
    </DIV<

<SPAN ID="oSpan"<</SPAN<
</FONT<

Пример 2:

<!-- К этому элементу применяется фильтр. --<

<DIV ID="oTransContainer" STYLE="position:absolute; top: 0px; left: 0px; width: 300px;
height:300px;  filter:progid:DXImageTransform.Microsoft.Stretch(stretchStyle=push) "<

<!-- Это первое содержимое, которое будет показано. --<

    <DIV ID="oDIV1" STYLE="position:absolute; top:50px; left:10px; width:240px; height:160px;
    background:gold"< This is DIV #1  </DIV<

<!-- Это содержимое, которое будет показано после применения фильтра. --<

    <DIV ID="oDIV2" STYLE="visibility:hidden; position:absolute; top:50px; left:10px;
    width:240px; height:160px; background: yellowgreen; "< <BR< This is DIV #2
    </DIV<
</DIV<

<BUTTON onclick="fnToggle()"<Запустить преобразование</BUTTON<

<SCRIPT<
var bTranState = 0;
function fnToggle() {
    oTransContainer.filters[0].Apply();
    if (bTranState=="0") {
        bTranState = 1;
        oDIV2.style.visibility="visible";
        oDIV1.style.visibility="hidden";}
    else {
        bTranState = 0;
        oDIV2.style.visibility="hidden";
        oDIV1.style.visibility="visible";}
        oTransContainer.filters[0].Play();}
</SCRIPT<
Получено с http://spravkaweb.local/index.php/css/filter/dynamic/stretch
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 20:29, 11 января 2007.
  • К этой странице обращались 62 раза.
1.16459393501


Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Strips — Справочник Web-языков

Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Strips

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Stretch
Главная | ::. | CSS | ::. | Фильтры в Internet Explorer | ::. | Динамические фильтры | ::. | Strips
 |  |  |  |  |  |  |  | Wheel

[править] Strips()

Новое содержимое элемента страницы диагонально отдельными полосками наползает на старое содержимое

[править] Синтаксис фильтра Strips():

Где: | Общий пример использования: | Совместимость:
HTML | <ELEMENT STYLE="filter:progid:DXImageTransform.Microsoft.Strips(sProperties)" ... > | Internet Explorer 5.5 или выше
Script | object.style.filter="progid:DXImageTransform.Microsoft.Strips(sProperties)" | Internet Explorer 5.5 или выше

Здесь sProperties - строка, содержащая один или несколько свойств, задающих поведение фильтра.

[править] Свойства, используемые в фильтре Strips():

Атрибуты
Исползуются в HTML 		Свойства
Исползуются в скриптах 		Описание
motion Motion Задает или возвращает угол, из которого появится новое содержимое элемента.
Для свойства доступны следующие значения
  • left-down - левый нижний (значение по умолчанию)
  • left-up - левый верхний
  • right-down - правый нижний
  • right-up - правый верхний
duration Duration Задает или возвращает продолжительность преобразования в секундах.
enabled Enabled Задает или возвращает признак разрешения применения фильтра.
Свойство может принимать следующие значения
  • true - разрешает применить фильтр (значение по умолчанию)
  • false - не разрешает
Percent Задает процент выполнения преобразования.
Может принимать значения от 0 (преобразование еще не началось) до 100 (преобразование закончено).
Status Возвращает состояние выполнения преобразования.
Свойство может принимать следующие значения
  • 0 - если преобразование было остановлено
  • 1 - если оно было применено
  • 2 - если преобразование выполняется

[править] Методы, которые могут быть применены к фильтру Strips():

Метод | Описание
apply | Замораживает элемент страниы, после чего вы можете делать с ним все, что хотите. Для того, чтобы запустить преобразование, используйте метод Play().
play | Запускает преобразование.
stop | Немедленно останавливает преобразование.

[править] Примеры использования динамического фильтра Strips():

Пример 1:

<SCRIPT>
var bToggle = 0;
function fnToggle() {
    oDiv.filters[0].Apply();
// После того, как применяется метод Apply к выбранному объекту
// фильтр не запустится пока не будет вызван метод Play

    if (bToggle) {
        bToggle = 0;
        oDiv.style.backgroundColor="gold";}
    else {
        bToggle = 1;
        oDiv.style.backgroundColor="blue";}
    oDiv.filters[0].Play();
}
</SCRIPT>

<BUTTON onclick="fnToggle()">Запустить преобразование</BUTTON><BR/><BR/>
<DIV ID="oDiv" STYLE="height:250px; width:250px; background-color: gold;
                filter:progid:DXImageTransform.Microsoft.Strips(
                duration=5, motion=rightdown);">
</DIV>

Пример 2:

<!-- К этому элементу применяется фильтр. -->

<DIV ID="oTransContainer" STYLE="position:absolute; top: 0px; left: 0px; width: 300px;
height:300px;  filter:progid:DXImageTransform.Microsoft.Strips(Duration=2, Motion=leftdown) ">

<!-- Это первое содержимое, которое будет показано. -->

    <DIV ID="oDIV1" STYLE="position:absolute; top:50px; left:10px; width:240px; height:160px;
    background:gold"> This is DIV #1  </DIV>

<!-- Это содержимое, которое будет показано после применения фильтра. -->

    <DIV ID="oDIV2" STYLE="visibility:hidden; position:absolute; top:50px; left:10px;
    width:240px; height:160px; background: yellowgreen; "> <BR> This is DIV #2
    </DIV>
</DIV>

<BUTTON onclick="fnToggle()">Запустить преобразование</BUTTON>

<SCRIPT>
var bTranState = 0;
function fnToggle() {
    oTransContainer.filters[0].Apply();
    if (bTranState=="0") {
        bTranState = 1;
        oDIV2.style.visibility="visible";
        oDIV1.style.visibility="hidden";}
    else {
        bTranState = 0;
        oDIV2.style.visibility="hidden";
        oDIV1.style.visibility="visible";}
        oTransContainer.filters[0].Play();}
</SCRIPT>
Получено с http://spravkaweb.local/index.php/css/filter/dynamic/strips
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:47, 12 января 2007.
  • К этой странице обращались 60 раз.
1.23009896278


Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Wheel — Справочник Web-языков

Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : Wheel

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Strips
Главная | ::. | CSS | ::. | Фильтры в Internet Explorer | ::. | Динамические фильтры | ::. | Wheel
 |  |  |  |  |  |  |  | ZigZag

[править] Wheel()

Создает эффект посекторного наползания нового элемента страницы на старый

[править] Синтаксис фильтра Wheel():

Где: | Общий пример использования: | Совместимость:
HTML | <ELEMENT STYLE="filter:progid:DXImageTransform.Microsoft.Wheel(sProperties)" ... > | Internet Explorer 5.5 или выше
Script | object.style.filter="progid:DXImageTransform.Microsoft.Wheel(sProperties)" | Internet Explorer 5.5 или выше

Здесь sProperties - строка, содержащая один или несколько свойств, задающих поведение фильтра.

[править] Свойства, используемые в фильтре Wheel():

Атрибуты
Исползуются в HTML 		Свойства
Исползуются в скриптах 		Описание
spokes | Spokes | Задает или возвращает количество секторов
duration | Duration | Задает или возвращает продолжительность преобразования в секундах.
enabled Enabled Задает или возвращает признак разрешения применения фильтра.
Свойство может принимать следующие значения
  • true - разрешает применить фильтр (значение по умолчанию)
  • false - не разрешает
Percent Задает процент выполнения преобразования.
Может принимать значения от 0 (преобразование еще не началось) до 100 (преобразование закончено).
Status Возвращает состояние выполнения преобразования.
Свойство может принимать следующие значения
  • 0 - если преобразование было остановлено
  • 1 - если оно было применено
  • 2 - если преобразование выполняется

[править] Методы, которые могут быть применены к фильтру Wheel():

Метод | Описание
apply | Замораживает элемент страниы, после чего вы можете делать с ним все, что хотите. Для того, чтобы запустить преобразование, используйте метод Play().
play | Запускает преобразование.
stop | Немедленно останавливает преобразование.

[править] Примеры использования динамического фильтра Wheel():

Пример 1:

<SCRIPT>
var bToggle = 0;
function fnToggle() {
    oDiv.filters[0].Apply();
// После того, как применяется метод Apply к выбранному объекту
// фильтр не запустится пока не будет вызван метод Play

    if (bToggle) {
        bToggle = 0;
        oDiv.style.backgroundColor="gold";}
    else {
        bToggle = 1;
        oDiv.style.backgroundColor="blue";}
    oDiv.filters[0].Play();
}
</SCRIPT>

<BUTTON onclick="fnToggle()">Запустить преобразование</BUTTON><BR/><BR/>
<DIV ID="oDiv" STYLE="height:250px; width:250px; background-color: gold;
                filter:progid:DXImageTransform.Microsoft.Wheel(
                duration=2, spokes=8);">
</DIV>

Пример 2:

<SCRIPT>
var bTranState = 0;
function fnToggle() {
        oDIV2.filters[0].Apply();
    if (bTranState) {
        bTranState = 0;
        oDIV2.style.visibility="hidden";    }
    else {
        bTranState = 1;
        oDIV2.style.visibility="visible";   }
        oDIV2.filters[0].Play();
}
</SCRIPT>

<BUTTON onclick="fnToggle()">Запустить преобразование</BUTTON>

<DIV ID="oDIV1" STYLE="position:absolute; top:50px; left:10px; width:240px; height:160px;
background:gold"> This is DIV #1  </DIV>

<DIV ID="oDIV2" STYLE="visibility:hidden; position:absolute; top:50px; left:10px;
width:240px; height:160px; background: yellowgreen;
filter:progid:DXImageTransform.Microsoft.Wheel(spokes=10)">
<BR>This is DIV #2</DIV>
Получено с http://spravkaweb.local/index.php/css/filter/dynamic/wheel
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:58, 12 января 2007.
  • К этой странице обращались 81 раз.
1.31835389137


Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : ZigZag — Справочник Web-языков

Справочник по CSS : Фильтры в Internet Explorer : Динамические фильтры : ZigZag

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Wheel
Главная | ::. | CSS | ::. | Фильтры в Internet Explorer | ::. | Динамические фильтры | ::. | ZigZag

[править] ZigZag()

Новое содержимое элемента страницы зигзагообразно отдельными полосками заполняет старое

[править] Синтаксис фильтра ZigZag():

Где: | Общий пример использования: | Совместимость:
HTML | <ELEMENT STYLE="filter:progid:DXImageTransform.Microsoft.ZigZag(sProperties)" ... > | Internet Explorer 5.5 или выше
Script | object.style.filter="progid:DXImageTransform.Microsoft.ZigZag(sProperties)" | Internet Explorer 5.5 или выше

Здесь sProperties - строка, содержащая один или несколько свойств, задающих поведение фильтра.

[править] Свойства, используемые в фильтре ZigZag():

Атрибуты
Исползуются в HTML 		Свойства
Исползуются в скриптах 		Описание
gridSizeX GridSizeX Задает или возвращает количество полосок по горизонтали.
Свойство может принимать значения от 1 до 100.
gridSizeY GridSizeY Задает или возвращает количество полосок по вертикали.
Свойство может принимать значения от 1 до 100.
duration Duration Задает или возвращает продолжительность преобразования в секундах.
enabled Enabled Задает или возвращает признак разрешения применения фильтра.
Свойство может принимать следующие значения
  • true - разрешает применить фильтр (значение по умолчанию)
  • false - не разрешает
Percent Задает процент выполнения преобразования.
Может принимать значения от 0 (преобразование еще не началось) до 100 (преобразование закончено).
Status Возвращает состояние выполнения преобразования.
Свойство может принимать следующие значения
  • 0 - если преобразование было остановлено
  • 1 - если оно было применено
  • 2 - если преобразование выполняется

[править] Методы, которые могут быть применены к фильтру ZigZag():

Метод | Описание
apply | Замораживает элемент страниы, после чего вы можете делать с ним все, что хотите. Для того, чтобы запустить преобразование, используйте метод Play().
play | Запускает преобразование.
stop | Немедленно останавливает преобразование.

[править] Примеры использования динамического фильтра ZigZag():

Пример 1:

<SCRIPT>
var bToggle = 0;
function fnToggle() {
    oDiv.filters[0].Apply();
// После того, как применяется метод Apply к выбранному объекту
// фильтр не запустится пока не будет вызван метод Play

    if (bToggle) {
        bToggle = 0;
        oDiv.style.visibility="visible";  }
    else {
        bToggle = 1;
        oDiv.style.visibility="hidden"; }
    oDiv.filters[0].Play();
}
</SCRIPT>

<BUTTON onclick="fnToggle()">Запустить преобразование</BUTTON><BR/><BR/>
<DIV ID="oDiv" STYLE="height:250px; width:250px; background-color: gold;
                filter:progid:DXImageTransform.Microsoft.Zigzag(
                duration=3, GridSizeX=25, GridSizeY=25);">
    <FONT SIZE="+4" COLOR="#A08000">
        TEXT<BR/>TEXT<BR/>TEXT<BR/>TEXT<BR/>
    </FONT>
</DIV>

Пример 2:

<!-- К этому элементу применяется фильтр. -->

<DIV ID="oTransContainer" STYLE="position:absolute; top: 0px; left: 0px; width: 300px;
height:300px;  filter:progid:DXImageTransform.Microsoft.zigzag(GridSizeX=64, GridSizeY=64) ">

<!-- Это первое содержимое, которое будет показано. -->

<DIV ID="oDIV1" STYLE="position:absolute; top:50px; left:10px; width:240px; height:160px;
background:gold"> This is DIV #1  </DIV>

<!-- Это содержимое, которое будет показано после применения фильтра. -->

<DIV ID="oDIV2" STYLE="visibility:hidden; position:absolute; top:50px; left:10px;
width:240px; height:160px; background: yellowgreen; "> <BR> This is DIV #2</DIV>
</DIV>

<BUTTON onclick="fnToggle()">Запустить преобразование</BUTTON>

<SCRIPT>
var bTranState = 0;
function fnToggle() {
    oTransContainer.filters[0].Apply();
    if (bTranState=="0") {
        bTranState = 1;
        oDIV2.style.visibility="visible";
        oDIV1.style.visibility="hidden";}
    else {
        bTranState = 0;
        oDIV2.style.visibility="hidden";
        oDIV1.style.visibility="visible";}
        oTransContainer.filters[0].Play(duration=3);}
</SCRIPT>
Получено с http://spravkaweb.local/index.php/css/filter/dynamic/zigzag
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:58, 12 января 2007.
  • К этой странице обращались 60 раз.
1.44211792946


Приложения CSS : Единицы измерения CSS — Справочник Web-языков

Приложения CSS : Единицы измерения CSS

Главная | ::. | CSS | ::. | Приложения CSS | ::. | Единицы измерения CSS

[править] Единицы измерения CSS

В этой таблице перечислены все единицы измерения, поддерживаемые CSS.

Единица измерения | Обозначение
Высота буквы M текущего шрифта | em
Высота буквы x текущего шрифта | ex
Пикселы | px
Пункты | pt
Пики | pc
Дюймы | in
Миллиметры | mm
Сантиметры | cm
Получено с http://spravkaweb.local/index.php/css/pril/units
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 10:53, 18 марта 2007.
  • К этой странице обращались 94 раза.
1.72294592857


Справочник по CSS : Что такое CSS и как применить — Справочник Web-языков

Справочник по CSS : Что такое CSS и как применить

Главная | ::. | CSS | ::. | Что такое CSS и как применить
 |  |  |  | Свойства шрифта

Каскадные таблицы стилей или CSS (Cascading Style Sheets) были революцией, потрясшей WWW. Елси до этого Web-дизайнер не знал, как будет выглядеть его творение в разных программах Web-обозревателей, то теперь он может контролировать все: от начертания шрифта до положения картинки на странице.

Предположим, вам нужно изменить цвет текста в HTML-документе с черного на синий. Вы помещаете его в пару тегов <FONT> и </FONT> следующего вида:

<P><FONT color="blue">Это синий текст</FONT></P>

А теперь представим, что вы внесли определение внешнего вида текста в другое место документа:

P.bluetext { color: blue }

Эта строка обозначает, что мы определили для текста, находящегося внутри тега <P> и помеченного стилевым классом bluetext, синий цвет шрифта. Такая конструкция HTML называется определением стиля или просто стилем.

В результате в HTML-тексте у нас остануться только теги логического форматирования текста:

<P class="bluetext">Это синий текст</P>

Здесь мы пометили нужный текст с помощью атрибута class, присвоив ему значение bluetext. Атрибут class задает имя стилевого класса для тега, и его поддерживают все теги.

Вы можете переназначить цвета текста для всех тегов <P>. В этом случае мы не задаем имя стилевого класса:

P { color: blue }

Или вы можете задать форматирование для стилевого класса, не привязанного ни к какому тегу:

.bluetext{ color: blue }

И теперь вы можете присваивать стилевой класс тексту, заключенному в любые теги:

<H1 class="bluetext">Это синий цвет</H1>

<CENTER class="bluetext">Это синий цвет</CENTER>

Это <B class="bluetext">жирный синий</B> текст

Вы можете дать специальное форматирование тегу только в том случае, если он заключен внутрь другого тега:

H7 B { color: blue }

И теперь:

<H7><B>Этот</B> текст будет синим</H7>

<P>А <B>этот</B> - не будет!</P>

Более того, вы можете встроить определение стиля прямо в тег:

<P style="color: blue">Это синий текст</P>

Это достигается при помощи атрибута style, который также поддерживают все теги HTML.

И еще один способ привязать стиль к какому-либо тегу - использовать атрибут id, задающий уникальное имя элемента HTML.

#headerofdocument { font-size: 20pt }

Здесь мы задали размер шрифта 20 пунктов.

<H1 id="headerofdocument">Это заголовок документа</H1>

Вы можете задавать несколько атрибутов в определении стиля. В этом случае они разделяются точкой с запятой:

P { color: blue; fotn-size: 9ptl; text-align: center }

Определение стилей, вынесенные в заголовок HTML-документа, составляют таблицу стилей. Таблица стилей заключается в теги <STYLE> и </STYLE>:

<Style [type="text/css"]>

. . .

</STYLE>

Тег <STYLE> может содержать необязательный атрибут type, содержащий обязательное значение text/css.

Таблицу стилей можно вынести в отдельный файл и использовать сразу в нескольких документах. В этом случае в заголовке HTML-документа необходимо разместить тег <LINK>, указывающий на эту таблицу стилей:

<LINK rel="stylesheet" href="{Адрес файла таблицы стилей}">
Получено с http://spravkaweb.local/index.php/css/reference/about
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:27, 7 января 2007.
  • К этой странице обращались 159 раз.
4.9733850956


Справочник по CSS : Границы элементов — Справочник Web-языков

Справочник по CSS : Границы элементов

 |  |  |  | Расположение элементов
Главная | ::. | CSS | ::. | Границы элементов
 |  |  |  | Классификации

Содержание

  • 1 border
  • 2 border-color
  • 3 border-top-color
  • 4 border-bottom-color
  • 5 border-left-color
  • 6 border-right-color
  • 7 border-style
  • 8 border-top-style
  • 9 border-bottom-style
  • 10 border-left-style
  • 11 border-right-style
  • 12 border-width
  • 13 border-top-width
  • 14 border-bottom-width
  • 15 border-left-width
  • 16 border-right-width
  • 17 border-top
  • 18 border-bottom
  • 19 border-left
  • 20 border-right
  • 21 border-collapse

[править] border

Задает все свойства границ элемента страницы в один прием.

Заменяет атрибуты border-color, border-style и border-width. Значения этих атрибутов могут располагаться в любом порядке.

border: [{border-color}] [{border-style}] [{border-width}];

Значение по умолчанию medium none.

Поддерживается IE начиная с 4.0

[править] border-color

(IE)

Задает цвет всех границ элемента страницы.

Заменяет атрибуты border-top-color, border-right-color, border-bottom-color и border-left-color.

border-color: {border-top-color} [{border-right-color}] [{border-bottom-color}] [{border-left-color}];

Может быть задано от одного до четырех значений. Если задано одно значение, оно применяется ко всем четырем границам. Если задано два значения, первое относится к верхней и нижней границам, а второе - к левой и правой. Если задано три значения, то первое применяется к верхней границе, второе - к левой и правой, третье - к нижней.

Поддерживается IE начиная с 4.0

(NN)

Задает цвет границ элемента страницы.

border-color: none|{Цвет};

Может быть задано либо цветное значение, либо none, обозначающее отсутствие границ.

Поддерживается NN начиная с 4.0

[править] border-top-color

Задает цвет верхней границы элемента страницы.

border-top-color: {Цвет};

Поддерживается IE начиная с 4.0

[править] border-bottom-color

Задает цвет нижней границы элемента страницы.

border-bottom-color: {Цвет};

Поддерживается IE начиная с 4.0

[править] border-left-color

Задает цвет левой границы элемента страницы.

border-left-color: {Цвет};

Поддерживается IE начиная с 4.0

[править] border-right-color

Задает цвет правой границы элемента страницы.

border-right-color: {Цвет};

Поддерживается IE начиная с 4.0

[править] border-style

Задает тип сразу всех границ элемента страницы в один прием.

Заменяет атрибуты border-top-style, border-right-style, border-bottom-style и border-left-style.

border-style: none|dotted|dashed|solid|double|groove|ridge|inset|outset;
  • border-style: none; - запрещает рисование границы (значение по умолчанию);
  • border-style: dotted; - рисует точечную линию (не поддерживается в NN);
  • border-style: dashed; - рисует штриховую линию (не поддерживается в NN);
  • border-style: solid; - рисует сплошную линию;
  • border-style: double; - рисует двойную сплошную линию;
  • border-style: groove; - рисует трехмерную вдавленную границу;
  • border-style: ridge; - рисует трехмерную выпуклую границу;
  • border-style: inset; - рисует трехмерную "ступеньку вверх";
  • border-style: outset; - рисует трехмерную "ступеньку вниз".

Поддерживается IE и NN начиная с 4.0

[править] border-top-style

Задает тип верхней границы элемента страницы.

  • border-top-style: none|dotted|dashed|solid|double|groove|ridge|inset|outset;
  • border-top-style: none; - запрещает рисование границы (значение по умолчанию);
  • border-top-style: dotted; - рисует точечную линию (не поддерживается в NN);
  • border-top-style: dashed; - рисует штриховую линию (не поддерживается в NN);
  • border-top-style: solid; - рисует сплошную линию;
  • border-top-style: double; - рисует двойную сплошную линию;
  • border-top-style: groove; - рисует трехмерную вдавленную границу;
  • border-top-style: ridge; - рисует трехмерную выпуклую границу;
  • border-top-style: inset; - рисует трехмерную "ступеньку вверх";
  • border-top-style: outset; - рисует трехмерную "ступеньку вниз".

Поддерживается IE начиная с 4.0

[править] border-bottom-style

Задает тип нижней границы элемента страницы.

border-bottom-style: none|dotted|dashed|solid|double|groove|ridge|inset|outset;
  • border-bottom-style: none; - запрещает рисование границы (значение по умолчанию);
  • border-bottom-style: dotted; - рисует точечную линию (не поддерживается в NN);
  • border-bottom-style: dashed; - рисует штриховую линию (не поддерживается в NN);
  • border-bottom-style: solid; - рисует сплошную линию;
  • border-bottom-style: double; - рисует двойную сплошную линию;
  • border-bottom-style: groove; - рисует трехмерную вдавленную границу;
  • border-bottom-style: ridge; - рисует трехмерную выпуклую границу;
  • border-bottom-style: inset; - рисует трехмерную "ступеньку вверх";
  • border-bottom-style: outset; - рисует трехмерную "ступеньку вниз".

Поддерживается IE начиная с 4.0

[править] border-left-style

Задает тип левой границы элемента страницы.

border-left-style: none|dotted|dashed|solid|double|groove|ridge|inset|outset;
  • border-left-style: none; - запрещает рисование границы (значение по умолчанию);
  • border-left-style: dotted; - рисует точечную линию (не поддерживается в NN);
  • border-left-style: dashed; - рисует штриховую линию (не поддерживается в NN);
  • border-left-style: solid; - рисует сплошную линию;
  • border-left-style: double; - рисует двойную сплошную линию;
  • border-left-style: groove; - рисует трехмерную вдавленную границу;
  • border-left-style: ridge; - рисует трехмерную выпуклую границу;
  • border-left-style: inset; - рисует трехмерную "ступеньку вверх";
  • border-left-style: outset; - рисует трехмерную "ступеньку вниз".

Поддерживается IE начиная с 4.0

[править] border-right-style

Задает тип правой границы элемента страницы.

border-right-style: none|dotted|dashed|solid|double|groove|ridge|inset|outset;
  • border-right-style: none; - запрещает рисование границы (значение по умолчанию);
  • border-right-style: dotted; - рисует точечную линию (не поддерживается в NN);
  • border-right-style: dashed; - рисует штриховую линию (не поддерживается в NN);
  • border-right-style: solid; - рисует сплошную линию;
  • border-right-style: double; - рисует двойную сплошную линию;
  • border-right-style: groove; - рисует трехмерную вдавленную границу;
  • border-right-style: ridge; - рисует трехмерную выпуклую границу;
  • border-right-style: inset; - рисует трехмерную "ступеньку вверх";
  • border-right-style: outset; - рисует трехмерную "ступеньку вниз".

Поддерживается IE начиная с 4.0

[править] border-width

Задает толщину всех границ элемента страницы.

Заменяет атрибуты border-top-width, border-right-width, border-bottom-width и border-left-width.

border-width: {border-top-width} [{border-right-width}] [{border-bottom-width}] [{border-left-width}];

Может быть задано от одного до четырех значений. Если задано одно значение, оно применяется ко всем четырем границам. Если задано два значения, первое относится в верхней и нижней границам, а второе - к левой и правой. Если задано три значения, то первое применяется к верхней границе, второе - к левой и правой, третье - к нижней.

Толщина может быть задана числовым значением. Также доступны три предопределенных значения: thin, medium, thick, рисующие тонкую, среднюю и толстую линию соответственно.

Значение по умолчанию medium.

Поддерживается IE и NN начиная с 4.0

[править] border-top-width

Задает толщину верхней границы элемента страницы.

border-top-width: medium|thin|thick|{Толщина};

Толщина может быть задана числовым значением. Также доступны три предопределенных значения: thin, medium, thick, рисующие тонкую, среднюю и толстую линию соответственно.

Значение по умолчанию medium.

Поддерживается IE и NN начиная с 4.0

[править] border-bottom-width

Задает толщину нижней границы элемента страницы.

border-bottom-width: medium|thin|thick|{Толщина};

Толщина может быть задана числовым значением. Также доступны три предопределенных значения: thin, medium, thick, рисующие тонкую, среднюю и толстую линию соответственно.

Значение по умолчанию medium.

Поддерживается IE и NN начиная с 4.0

[править] border-left-width

Задает толщину левой границы элемента страницы.

border-left-width: medium|thin|thick|{Толщина};

Толщина может быть задана числовым значением. Также доступны три предопределенных значения: thin, medium, thick, рисующие тонкую, среднюю и толстую линию соответственно.

Значение по умолчанию medium.

Поддерживается IE и NN начиная с 4.0

[править] border-right-width

Задает толщину правой границы элемента страницы.

border-right-width: medium|thin|thick|{Толщина};

Толщина может быть задана числовым значением. Также доступны три предопределенных значения: thin, medium, thick, рисующие тонкую, среднюю и толстую линию соответственно.

Значение по умолчанию medium.

Поддерживается IE и NN начиная с 4.0

[править] border-top

Задает все свойства верхней границы элемента страницы за один прием.

Заменяет атрибуты border-top-color, border-top-style и border-top-width. Значения этих атрибутов могут располагаться в любом порядке.

border-top: [{border-top-color}] [{border-top-style}] [{border-top-width}];

Значение по умолчанию medium none.

Поддерживается IE начиная с 4.0

[править] border-bottom

Задает все свойства нижней границы элемента страницы за один прием.

Заменяет атрибуты border-bottom-color, border-bottom-style и border-bottom-width. Значения этих атрибутов могут распологаться в любом порядке.

border-bottom: [{border-bottom-color}] [{border-bottom-style}] [{border-bottom-width}];

Значение по умолчанию medium none.

Поддерживается IE начиная с 4.0

[править] border-left

Задает все свойства левой границы элемента страницы за один прием.

Заменяет атрибуты border-left-color, border-left-style и border-left-width. Значения этих атрибутов могут распологаться в любом порядке.

border-left: [{border-left-color}] [{border-left-style}] [{border-left-width}];

Значение по умолчанию medium none.

Поддерживается IE начиная с 4.0

[править] border-right

Задает все свойства правой границы элемента страницы за один прием.

Заменяет атрибуты border-right-color, border-right-style и border-right-width. Значения этих атрибутов могут распологаться в любом порядке.

border-right: [{border-right-color}] [{border-right-style}] [{border-right-width}];

Значение по умолчанию medium none.

Поддерживается IE начиная с 4.0

[править] border-collapse

Задает, будут ли границы ячеек и общая граница таблицы сливаться в одну или нет.

Применяется только для тега <TABLE>.

border-collapse: separate|collapse;
  • border-collapse: separate; - разделяет границу табилицы и границы ее ячеек (значение по умолчанию);
  • border-collapse: collapse; - объединяет их.

Поддерживается IE начиная с 5.0

Получено с http://spravkaweb.local/index.php/css/reference/border
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 19:20, 7 января 2007.
  • К этой странице обращались 154 раза.
2.78354692459


Справочник по CSS : Классификации — Справочник Web-языков

Справочник по CSS : Классификации

 |  |  |  | Границы элементов
Главная | ::. | CSS | ::. | Классификации
 |  |  |  | Принтер

Содержание

  • 1 display
  • 2 position
  • 3 z-index
  • 4 visibility
  • 5 clip
  • 6 white-space
  • 7 cursor
  • 8 list-style
  • 9 list-style-image
  • 10 list-style-position
  • 11 list-style-type

[править] display

Определяет, как будет отображаться элемент.

display: inline|block|none|inline-block|list-item|table-header-group|table-footer-group;
  • display: inline; - (значение по умолчанию) заставляет элемент страницы вести себя как встроенный. При этом он располагается внутри текста, его позиция и размеры рассчитываются согласно позиции и размерам текста. Пример встроенного элемента - <I>;
  • display: block; - делает элемент страницы блочным. При этом его можно свободно позиционировать. Пример блочного элемента - <DIV>;
  • display: none; - делает элемент страницы невидимым. При этом страница отображается так, будто этого элемента вообще не существует;
  • display: inline-block; - аналогично inline, но содержимое страницы ведет себя как блочный элемент (не поддерживается NN);
  • display: list-item; - аналогично block, но при этом элемент страницы считается позицией списка (ставится маркер);
  • display: table-header-group; - заставляет элемент страницы отображаться после верхнего заголовка таблицы и перед всеми строками данных (аналогично тегу <THEAD>) (не поддерживается NN);
  • display: table-footer-group; - заставляет элемент страницы отображаться перед основанием таблицы и после всех строк данных (аналогично тегу <TFOOT>) (не поддерживается NN);

Поддерживается IE и NN начиная с 4.0

[править] position

Устанавливает, каким образом вычисляется положение элемента в плоскости экрана.

position: static|absolute|relative;
  • position: static; - (значение по умолчанию) задает статическое позиционирование, при котором элемент страницы отображается внутри общего "потока" текста, т.е. не свободно. Значения атрибутов bottom, left, right и top при этом не принимаются Web-обозревателем во внимание;
  • position: absolute; - задает абсолютное свободное позиционирование. Значения атрибутов bottom, left, right и top при этом задают абсолютные координаты элемента страницы относительно родителя;
  • position: relative; - задает относительное свободное позиционирование. Значения атрибутов bottom, left, right и top при этом задают смещение координат элемента страницы от точки, в которой он был отображен, будь атрибут position установлен в static.

Поддерживается IE и NN начиная с 4.0

[править] z-index

Задает порядок перекрытия свободно позиционированными объектами друг друга.

z-index: auto|{Порядок перекрытия}|;

Порядок перекрытия задается положительными или отрицательным целым числом. При этом элементы с большим значением этого атрибута будут перекрывать элементы с меньшим значением. Предопределенное значение auto задает порядок перекрытия по умолчанию, когда элементы, определенные в HTML-коде раньше, перекрываются заданными позже.

Значение по умолчанию auto.

Поддерживается IE и NN начиная с 4.0

[править] visibility

Позволяет элементу быть видимым или невидимым на странице.

visibility: inherit|visible|hidden;
  • visibility: inherit - (значение по умолчанию) элемент виден, если его родительский элемент является видимым (наследует видимость);
  • visibility: visible - делает элемент страницы видимым;
  • visibility: hidden - невидимым.

Поддерживается IE и NN начиная с 4.0

[править] clip

Задает прямоугольный фрагмент элемента страницы, который будет видим.

clip: auto|rect({Верхняя граница} {Правая граница} {Нижняя граница} {Левая граница});

Предопределенное значение auto задает видимость всего элемента страницы. Оно же является значением по умолчанию. Для того чтобы ограничить видимую часть элемента страницы прямоугольным фрагментом, задаются четыре координаты границ этого прямоугольника, разделенные пробелами.

Поддерживается IE и NN начиная с 4.0

[править] white-space

Задает, будут ли строки текста, содержащегося в элементе страницы, автоматически переноситься, если они не помещаются в нем по ширине.

white-space: normal|nowrap|pre;
  • white-space: normal; - (значение по умолчанию) включает автоматический перенос длинных строк;
  • white-space: nowrap; - отключает автоматический перенос строк. Чтобы "разорвать" строку вручную, вставьте в нужном месте тег <BR> (NN не поддерживается);
  • white-spice: pre; - не поддерживается;

Поддерживается IE начиная с 5.5 и NN начиная с 4.0

[править] cursor

Определяет форму курсора мыши, которую он принимает при наведении на элемент страницы.

cursor: auto|crosshair|default|hand|move|*-resize|text|wait|help;
  • cursor: auto - (значение по умолчанию) заставляет Web-обозреватель самому определять нужную форму курсора мыши;
  • cursor: crosshair - крестообразный курсор;
  • cursor: default - курсор по умолчанию, обычно стрелка;
  • cursor: hand - "указывающий перст";
  • cursor: move - стрелка, указывающая "на все четыре стороны";
  • cursor: e-resize
  • cursor: ne-resize
  • cursor: nw-resize
  • cursor: n-resize
  • cursor: se-resize
  • cursor: sw-resize
  • cursor: s-resize
  • cursor: w-resize
  • cursor: text - текстовой курсор;
  • cursor: wait - "песочные часы", курсор ожидания;
  • cursor: help - стрелка с вопросительным знаком.

Поддерживается IE начиная с 4.0

[править] list-style

Задает параметры маркера или номера позиции списка.

Заменяет атрибуты list-style-image, list-style-position и list-style-type.

Значения этих атрибутов могут располагаться в любом порядке.

list-style: [{list-style-image}] [{list-style-position}] [{list-style-type}];

Значение по умолчанию disk outside none.

Поддерживается IE начиная с 4.0

[править] list-style-image

Задает графическое изображение, отображаемое в качестве маркера позиции списка. Имеет приоритет над атрибутом list-style-type.

list-style-image: none|url({Интернет-адрес файла изображения});

Если задано предопределенное значение none, то стиль маркера берется из установок атрибута list-style-type, если он задан, или отображается маркер по умолчанию. Если задан интернет-адрес файла изображения, то оно отображается в качестве маркера, перекрывая установки атрибута list-style-type.

Значение по умолчанию none.

Поддерживается IE начиная с 4.0

[править] list-style-position

Задает местонахождение маркера позиции списка: в тексте позиции или вне его.

list-style-position: outside|inside;

Доступны два значения. Значение outside (по умолчанию) задает отображение маркера позиции списка вне текста позиции. Значение же inside заставляет Web-обозреватель отобразить маркер позиции в ее тексте в качестве первого символа.

Поддерживается IE начиная с 4.0

[править] list-style-type

Задает тип маркера или номер позиции списка.

list-style-type: disc|circle|square|decimal|lower|roman|upper-roman|lower-alpha|upper-alpha|none;
  • list-style-type: disc; - (значение по умолчанию) отображает сплошной кружок;
  • list-style-type: circle; - окружность;
  • list-style-type: square; - сплошной квадрат;
  • list-style-type: decimal; - нумерует позиции арабскими цифрами;
  • list-style-type: lower-roman; - малыми римскими;
  • list-style-type: upper-roman; - большими римскими;
  • list-style-type: lower-alpha; - помечает позиции малыми латинскими буквами;
  • list-style-type: upper-alpha; - большими латинскими;
  • list-style-type: none; - вообще убирает маркер или нумерацию.

Поддерживается IE и NN начиная с 4.0

Получено с http://spravkaweb.local/index.php/css/reference/class
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 19:29, 7 января 2007.
  • К этой странице обращались 156 раз.
2.60866308212


Справочник по CSS : Псевдостили текста — Справочник Web-языков

Справочник по CSS : Псевдостили текста

 |  |  |  | Псевдостили гиперссылок
Главная | ::. | CSS | ::. | Псевдостили текста
 |  |  |  | Правила

Псевдостили применяются некоторым элементам текстовых абзацев, например, к первой строке абзаца или первой букве первой строки.

[править] first-letter

Применяется к первой букве первой строки абзаца. Может использоваться для создания буквиц.

{Задание стиля абзаца}:first-letter {Определение стиля};

Пример:

st:first-letter {font-size: 16pt;}

По умолчанию в IE первые буквы первых строк абзацев никак не выделяются.

Поддерживается IE начиная с 5.0

[править] first-line

Применяется к первой строке абзаца.

{Задание стиля абзаца}:first-line{Определение стиля};

Пример:

st:first-line {text-decoration: underline;}

По умолчанию в IE первые строки абзацев никак не выделяются.

Поддерживается IE начиная с 5.0

Получено с http://spravkaweb.local/index.php/css/reference/classtext
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 19:49, 7 января 2007.
  • К этой странице обращались 114 раз.
3.03626489639


Справочник по CSS : Цветовая гамма — Справочник Web-языков

Справочник по CSS : Цветовая гамма

 |  |  |  | Свойства шрифта
Главная | ::. | CSS | ::. | Цветовая гамма
 |  |  |  | Свойства текста

Содержание

  • 1 color
  • 2 background
  • 3 background-color
  • 4 background-image
  • 5 background-attachment
  • 6 background-repeat
  • 7 background-position
  • 8 background-position-x
  • 9 background-position-y
  • 10 scrollbar-3dlight-color
  • 11 scrollbar-arrow-color
  • 12 scrollbar-base-color
  • 13 scrollbar-darkshadow-color
  • 14 scrollbar-face-color
  • 15 scrollbar-highlight-color
  • 16 scrollbar-shadow-color
  • 17 scrollbar-track-color

[править] color

Определяет цвет элемента.

color: {Цвет};

Поддерживается IE начиная с 3.02 для текстовых элементов страницы и начиная с 4.0 для нетекстовых.

Поддерживается NN начиная с 4.0

[править] background

Задает все свойства фона элемента страницы в один прием. Заменяет собой атрибуты background-attachment, background-color, background-image, background-position и background-repeat.

background: [{background-color}] [{background-image}] [{background-repeat}] [{background-attachment}] [{background-position}];

Значения этих свойств могут располагаться в любом порядке.

Значение по умолчанию transparent none repeat scroll 0% 0%.

Поддерживается IE начиная с 3.02; задание значений background-position и background-repeat поддерживается начиная с 4.0

[править] background-color

Задает фоновый цвет Web-страницы или ее элемента.

background-color: {Цвет}|transparent;

Предопределенное значение transparent задает "прозрачный" фон. Оно же является значением по умолчанию.

Поддерживается IE начиная с 4.0, в составе атрибута background - с 3.02

Поддерживается NN начиная с 4.0

[править] background-image

Задает фоновый рисунок Web-страницы или ее элемента.

background-image: url({Интернет-адрес файла рисунка})|none;

Предопределенное значение none отключает фоновый рисунок. Оно же является значением по умолчанию.

Поддерживается IE начиная с 4.0, в составе атрибута background - с 3.02

Поддерживается NN начиная с 4.0

[править] background-attachment

Данный атрибут позволяет "зафиксировать" фоновый рисунок, чтобы он не прокручивался вместе с содержимым Web-страницы.

background-attachment: scroll|fixed;
  • background-attachment: scroll; - фоновое изображение прокручивается вместе с содержимым страницы (значение по умолчанию);
  • background-attachment: fixed; - фоновое изображение фиксируется на одном месте и не прокручивается с содержимым страницы.

Применяется только для тега <BODY>.

Поддерживается IE начиная с 4.0, в составе атрибута background - с 3.02

[править] background-repeat

Устанавливает порядок повторения фонового рисунка на Web-странице или ее элементе.

Иногда этот атрибут необходим, чтобы занять все свободное пространство, если фоновый рисунок слишком мал, чтобы покрыть пространство без повторения.

background-repeat: repeat|no-repeat|repeat-x|repeat-y;
  • background-repeat: repeat; - размножает фоновое изображение во всех направлениях (значение по умолчанию);
  • background-repeat: no-repeat; - запрещает фоновому изображению повторяться;
  • background-repeat: repeat-x; - размножает фоновое изображение только по горизонтали;
  • background-repeat: repeat-y; - размножает фоновое изображение только по вертикали.

Поддерживается IE начиная с 4.0

[править] background-position

Задает местонахождение фонового рисунка. Это комбинированный атрибут, заменяющий атрибуты background-position-x и background-position-y.

background-position: [{background-position-x}] [{background-position-y}];

Если задана только одна координата, то она считается горизонтальной, а для вертикальной принимается значение 50%.

Значение по умолчанию 0% 0%.

Поддерживается IE начиная с 4.0

[править] background-position-x

Задает горизонтальную координату фонового рисунка.

background-position-x: {X}|{X}%|left|center|right;

Координата может быть задана целым числом (абсолютная координата), процентом от соответствующего размера фонового рисунка (относительная координата) или предопределенным значением. Доступны три предопределенных значения: left, center, right, которые задают выравнивание фонового рисунка на странице по левому краю, по центру и по правому краю соответственно.

Значение по умолчанию 0%.

Поддерживается IE начиная с 4.0

[править] background-position-y

Задает вертикальную координату фонового рисунка.

background-position-y: {Y}|{Y}%|top|center|bottom;

Координата может быть задана целым числом (абсолютная координата), процентом от соответствующего размера фонового рисунка (относительная координата) или предопределенным значением. Доступны три предопределенных значения: top, center, bottom, которые задают выравнивание фонового рисунка на странице по верху, по центру и по низу страницы соответственно.

Значение по умолчанию 0%.

Поддерживается IE начиная с 4.0

[править] scrollbar-3dlight-color

Задает цвет верхней и левой границ полосы прокрутки, ее бегунка и стрелок.

scrollbar-3dlight-color: {Цвет};

Поддерживается IE начиная с 5.5

[править] scrollbar-arrow-color

Задает цвет стрелок на кнопках полосы прокрутки.

scrollbar-arrow-color: {Цвет};

Поддерживается IE начиная с 5.5

[править] scrollbar-base-color

Задает цвет бегунка и кнопок-стрелок полосы прокрутки.

scrollbar-base-color: {Цвет};

Поддерживается IE начиная с 5.5

[править] scrollbar-darkshadow-color

Задает цвет "тени", отбрасываемой бегунком и кнопками прокрутки полосы прокрутки (цвет правых и нижних гранией).

scrollbar-darkshadow-color: {Цвет};

Поддерживается IE начиная с 5.5

[править] scrollbar-face-color

Задает цвет бегунка и кнопок прокрутки полосы прокрутки.

scrollbar-face-color: {Цвет};

Поддерживается IE начиная с 5.5

[править] scrollbar-highlight-color

Задает цвет "освещенной" части бегунка и кнопок прокрутки полосы прокрутки (цвет левых и верхних их граней).

scrollbar-highlight-color: {Цвет};

Поддерживается IE начиная с 5.5

[править] scrollbar-shadow-color

Задает цвет "неосвещенной" части бегунка и кнопок прокрутки полосы прокрутки (цвет правых и нижних их граней). Не путать с цветом "тени", задаваемым атрибутом scroll-darkshadow-color.

scrollbar-shadow-color: {Цвет};

Поддерживается IE начиная с 5.5

[править] scrollbar-track-color

Задает цвет рабочей части полосы прокрутки, т.е. той ее части, по которой перемещается бегунок.

scrollbar-track-color: {Цвет};

Поддерживается IE начиная с 5.5

Получено с http://spravkaweb.local/index.php/css/reference/color
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 18:35, 7 января 2007.
  • К этой странице обращались 139 раз.
4.36411881447


Справочник по CSS : Свойства шрифта — Справочник Web-языков

Справочник по CSS : Свойства шрифта

 |  |  |  | Что такое CSS и как применить
Главная | ::. | CSS | ::. | Свойства шрифта
 |  |  |  | Цветовая гамма

Содержание

  • 1 font
  • 2 font-family
  • 3 font-weight
  • 4 font-size
  • 5 font-style
  • 6 font-variant

[править] font

Задает параметры шрифта элемента страницы.

Заменяет атрибуты font-family, font-height, font-size, font-style, font-variant и font-weight. Значения этих атрибутов могут располагаться в любом порядке.

font: {font-family} [{font-height}] [{font-size}] [{font-style}] [{font-variant}] [{font-weight}];

Значение по умолчанию - normal normal normal medium normal "Times New Roman".

Альтернативный формат:

font: caption|icon|menu|message-box|small-caption|status-bar;

В этом случае доступны шесть предопределенных значений, задающие один из стандартных шрифтов, используемых в элементах интерфейса Windows:

  • font: caption; - шрифт заголовка кнопок, текстовых меток и т.п.;
  • font: icon; - шрифт подписей под пиктограммами;
  • font: menu; - шрифт пунктов меню;
  • font: message-box; - шрифт содержимого стандартных окон-предупреждений;
  • font: small-caption; - мелкий шрифт заголовков;
  • font: status-bar; - шрифт содержимого строки состояния.

Поддерживается IE начиная с 4.0

[править] font-family

Указывает имя шрифта или шрифтового семейства, используемого в элементе страницы.

font-family: {Имя шрифта}|serif|san-serif|cursive|fantasy|monospace;

В качестве значения этого атрибута задается либо непосредственно имя нужного шрифта, либо одно из пяти предопределенных значений, задающих имя шрифтового семейства. Можно задавать одновременно несколько шрифтов, разделив их имена запятыми; в этом случае Web-обозреватель сможет выбрать из них тот, который установлен на компьютере клиента. Если имя шрифта содержит пробелы, его следует взять в кавычки.

font-family: "Times New Roman",sans-serif;

Поддерживается IE начиная с 3.02 для текстовых элементов и начиная с 4.0 для нетекстовых.

Поддерживается NN начиная с 4.0

[править] font-weight

Задает "жирность" шрифта, используемого в элементе страницы.

font-weight: normal|bold|bolder|lighter|100..900;

"Жирность" может быть задана тремя способами. Во-первых, предопределенными значениями normal и bold, задающими обычное и жирное начертание соответственно. Во-вторых, относительными значениями bolder и lighter, делающими шрифт элемента страницы жирнее и светлее шрифта родителя. И, в-третьих, одним из девяти значений от 100 до 900; здесь нормальному начертанию соответствует значение 400, а жирному - 700.

  • font-weight: normal; - обычный;
  • font-weight: lighter; - светлее;
  • font-weight: bold; - жирный;
  • font-weight: bolder; - жирнее;
  • font-weight: от 100 до 900 - любое значение, кратное 100 (200,700).

Значение по умолчанию normal.

Поддерживается IE начиная с 3.02 для текстовых элементов и начиная с 4.0 для нетекстовых. При этом IE 4.0 и более старые версии распознавали только значения normal и bold этого атрибута.

Поддерживается NN начиная с 4.0

[править] font-size

Задает размер шрифта, используемого в элементе страницы.

font-size: xx-small|x-small|small|medium|large|x-large|xx-large|larger|smaller|{Абсолютный размер}|{Относительный размер}%;

Возможно задание либо абсолютного размера шрифта в одной из поддерживаемых CSS единиц измерения, либо как процент от размера шрифта родителя. Также доступны девять определенных значений.

  • font-size: 200% - относительная величина (проценты)
  • font-size: 150px - размер в пикселях
  • font-size: 300pt - размер в пунктах
  • font-size: {xx-small,small,medium,large,x-large,xx-large} - задают один из семи размеров шрифтов, поддерживаемых HTML
  • font-size: {smaller,larger} - задают размер шрифта, который на размер либо больше, либо меньше родительского шрифта соответственно

Поддерживается IE начиная с 3.02 для текстовых элементов и начиная с 4.0 для нетекстовых.

Поддерживается NN начиная с 4.0

[править] font-style

Задает начертание шрифта.

font-style: normal|italic|oblique;
  • font-style: normal; - задает обычный вид шрифта (используется по умолчанию);
  • font-style: italic - курсивное начертание;
  • font-style: obligue - наклонное начертание (легкий наклон нормального шрифта) (IE отображает как курсив, а NN не поддерживает).

Поддерживается IE начиная с 3.02 для текстовых элементов и начиная с 4.0 для нетекстовых.

Поддерживается NN начиная с 4.0

[править] font-variant

Задает вид малых букв шрифта, используемого в элементе страницы.

font-variant: normal|small-caps;
  • font-variant: normal; - задает обычный вид малых букв шрифта (используется по умолчанию);
  • font-variant: small-caps; - делает их такими же, как большие буквы, только меньшего размера (капитель).

Поддерживается IE начиная с 4.0

Получено с http://spravkaweb.local/index.php/css/reference/font
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:09, 26 марта 2007.
  • К этой странице обращались 161 раз.
8.2200448513


Справочник по CSS : Псевдостили гиперссылок — Справочник Web-языков

Справочник по CSS : Псевдостили гиперссылок

 |  |  |  | Принтер
Главная | ::. | CSS | ::. | Псевдостили гиперссылок
 |  |  |  | Псевдостили текста

Псевдостили применяются к гиперссылкам <A>.

Содержание

  • 1 active
  • 2 hover
  • 3 link
  • 4 visited

[править] active

Применяется к активным гиперссылкам, т.е. гиперссылкам, на которых находится фокус ввода пользователя.

{Задание стиля гиперссылки}:active {Определение стиля};

Аналогичен атрибуту alink тега <BODY>.

Пример:

A:active {color: lime;}

активная гиперссылка будет ярко-зеленой.

По умолчанию в IE активные гиперссылки выделяются красным цветом.

Поддерживается IE начиная с 4.0

[править] hover

Применяется к гиперссылкам, когда пользователь помещает над ними курсор мыши.

{Задание стиля гиперссылки}:hover {Определение стиля};

Пример:

A:hover {color: lime; text-decoration: none;}

Гиперссылка, при наведении на нее мыши, будет ярко-зеленой и неподчеркнутой.

По умолчанию в IE гиперссылки подчеркиваются, когда пользователь помещает над ними курсор мыши.

Поддерживается IE начиная с 4.0

[править] link

Применяется к не посещенным еще пользователем гиперссылкам.

{Задание стиля гиперссылки}:link {Определение стиля};

Аналогичен атрибуту link тега <BODY>.

Пример:

A:link {color: black;}

По умолчанию в IE непосещенные гиперссылки отображаются синим цветом.

Поддерживается IE начиная с 3.02

[править] visited

Применяется к уже посещенным пользователем гиперссылкам.

{Задание стиля гиперссылки}:visited {Определение стиля};

Аналогичен атрибуту vlink тега <BODY>.

Пример:

A:link {color: indigo;}

По умолчанию в IE посещенные гиперссылки отображаются бордовым цветом.

Поддерживается IE начиная с 3.02

Получено с http://spravkaweb.local/index.php/css/reference/guper
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 19:37, 7 января 2007.
  • К этой странице обращались 127 раз.
2.97599697113


Справочник по CSS : Свойства текста, содержащего иероглифы — Справочник Web-языков

Справочник по CSS : Свойства текста, содержащего иероглифы

 |  |  |  | Свойства текста
Главная | ::. | CSS | ::. | Свойства текста, содержащего иероглифы
 |  |  |  | Расположение элементов

Содержание

  • 1 text-justify
  • 2 text-autospace
  • 3 text-kashida-space
  • 4 line-break
  • 5 word-break
  • 6 ime-mode
  • 7 layout-flow
  • 8 layout-grid
  • 9 layout-grid-char
  • 10 layout-grid-line
  • 11 layout-grid-mode
  • 12 layout-grid-type

[править] text-justify

Задает тип текста по ширине. Значение атрибута text-align при этом должно быть равно justify.

text-justify: auto|newspaper|distribute|distribute-all-lines|distribute-center-last|inter-word|inter-ideograph|inter-cluster|kashida;
  • text-justify: auto; - отдает управление выравниванием по ширине на усмотрение Web-обозревателя (используется по умолчанию);
  • text-justify: newspaper; - выравнивает строки, изменяя расстояние между словами и между символами;
  • text-justify: distribute; - аналогично newspaper и предназначено для азиатских языков (тайский и пр.);
  • text-justify: distribute-all-lines; - аналогично distribute за тем исключением, что последняя строка абзаца подвергается полному выравниванию. Предназначено для иероглифических языков;
  • text-justify: distribute-center-last; - не реализовано;
  • text-justify: inter-word; - выравнивает строки, изменяя только расстояние между словами;
  • text-justify: inter-ideograph; - выравнивает строки иероглифического текста, изменяя расстояния между словами и между иероглифами;
  • text-justify: inter-cluster; - выравнивает строки текста на азиатских языках, не содержащих пробелов между словами;
  • text-justify: kashida; - выравнивает строки текста на арабском языке, изменяя ширину самих символов.

Поддерживается IE начиная с 5.0

[править] text-autospace

Позволяет установить, будет ли добавлять дополнительное пространство между фрагментами текста, написанными на разных языках.

text-autospace: none|ideograph-alpha|ideograph-numeric|ideograph-parenthesis|ideograph-space;
  • text-autospace: none; - запрещает добавлять дополнительное пространство между фрагментами текста (используется по умочанию);
  • text-autospace: ideograph-alpha; - добавляет дополнительное пространство между иероглифическими и неиероглифическими (литинскими, кириллистическими, греческими и т.д.) фрагментами текста;
  • text-autospace: ideograph-numeric; - добавляет дополнительное пространство между иероглифическим текстом и цифрами;
  • text-autospace: ideograph-parenthesis; - добавляет дополнительное пространство между иероглифическим текстом и круглыми скобками;
  • text-autospace: ideograph-space; - увеличивает ширину пробелов, граничащих с иероглифическим текстом.

Поддерживается IE начиная с 5.0

[править] text-kashida-space

Задает процент, на который будут расширяться символы арабского языка при выравнивании текста по ширине.

Можно использовать только, если атрибут text-justify равен auto, distribute, kashida или newspaper.

text-kashida-space: {Расширение}%|inherit;

Величина отступа может быть задана как процент свободного пространства между символами, на которое они могут расширяться. Значение 0% (используется по умолчанию) означает, что расширение символов недопустимо, а вместо них будет расширяться свободное пространство; значение 100% - что допустимо расширение только символов, но не свободного пространства.

Поддерживается IE начиная с 5.5

[править] line-break

Задает правила разрыва строк для текста на японском языке.

line-break: normal|strict;
  • line-break: normal; - задает обычные правила разрыва японского текста (значение по умолчанию);
  • line-break: strict; - задает строгие правила.

Поддерживается IE начиная с 5.0

[править] word-break

Включает или отключает поддержку переноса строк по словам (а не только по пробелам) для текстов, содержащих фрагменты на разных языках.

word-break: normal|break-all|keep-all;
  • word-break: normal; - разрешает строкам "разрываться" по слову (используется по умолчанию);
  • word-break: break-all; - предназначено для текстов на азиатских языках с небольшими иноязычными фрагментами;
  • word-break: keep-all; - предназначено для текстов, включающих фрагменты на иероглифических языках.

Поддерживается IE начиная с 5.0

[править] ime-mode

Задает состояние IME (Input Method Editor - редактор способа ввода), с помощью которого вводятся иероглифические тексты на китайском, корейском и японском языках. Этот атрибут применяется только для полей ввода.

ime-mode: auto|active|inactive|disabled;
  • ime-mode: auto; - передает управление IME Web-обозревателю (значение по умолчанию);
  • ime-mode: active; - активизирует IME. Пользователь может его деактивизировать;
  • ime-mode: inactive; - деактивизирует IME. Пользователь может его активизировать;
  • ime-mode: disabled; - отключает IME.

Поддерживается IE начиная с 5.0

[править] layout-flow

Задает направление написания текста: по горизонтали или по вертикали.

layout-flow: horizontal|vertical-ideographic;
  • layout-flow: horozontal; - задает горизонтальное направление написания текста (значение по умолчанию);
  • layout-flow: vertical-ideographic; - вертикальное направление написания текста.

Поддерживается IE начиная с 5.5. В настоящее время признан устаревшим; вместо него рекомендуется использовать атрибут writing-mode.

[править] layout-grid

Задает параметры разметки элемента страницы, используемой для вывода иероглифических текстов на китайском, корейском и японском языках. Заменяет атрибуты layout-grid-char, layout-grid-line, layout-grid-mode и layout-grid-type.

layout-grid: [{layout-grid-char}] [{layout-grid-line}] [{layout-grid-mode}] [{layout-grid-type}]

Значения этих атрибутов могут располагаться в любом порядке.

Значение по умолчанию - both loose none none.

Поддерживается IE начиная с 5.0

[править] layout-grid-char

Задает шаг горизонтальной разметки элемента страницы, используемой для вывода иероглифических текстов на китайском, корейском и японском языках.

layout-grid-char: none|auto|{Y}{Y}%;

Шаг разметки может быть задан как абсолютной величиной, так и процентом от шага разметки родителя. Предопределенное значение auto заставляет Web-обозреватель устанавливать шаг разметки по максимальному символу текста. Другое предопределенное значение none вообще отключает разметку.

Значение по умолчанию - none.

Поддерживается IE начиная с 5.0

[править] layout-grid-line

Задает шаг вертикальной разметки элемента страницы, используемой для вывода иероглифических текстов на китайском, корейском и японском языках.

layout-grid-line: none|auto|{Y}{Y}%;

Шаг разметки может быть задан как абсолютной величиной, так и процентом от шага разметки родителя. Предопределенное значение auto заставляет Web-обозреватель устанавливать шаг разметки по максимальному символу текста. Другое предопределенное значение none вообще отключает разметку.

Значение по умолчанию - none.

Поддерживается IE начиная с 5.0

[править] layout-grid-mode

Задает тип разметки элемента страницы, используемой для вывода иероглифических текстов на китайском, корейском и японском языках.

layout-grid-mode: both|none|char|line;
  • layout-grid-mode: both; - задает использование и горизонтальной, и вертикальной разметок (используется по умолчанию);
  • layout-grid-mode: none; - отключает разметку;
  • layout-grid-mode: char; - задает использование горизонтальной разметки;
  • layout-grid-mode: line; - задает использование вертикальной разметки.

Поддерживается IE начиная с 5.0

[править] layout-grid-type

Задает режим форматирования иероглифических текстов на китайском, корейском и японском языках с использованием разметки элемента страницы.

layout-grid-type: loose|strict|fixed;
  • layout-grid-type: loose; - задает "гибкое" форматирование, используемое для корейских и японских текстов (используется по умолчанию);
  • layout-grid-type: strict; - задает более строгое форматирование, используемое для китайских, корейских и японских текстов;
  • layout-grid-type: fixed; - задает самое строгое форматирование, когда символы жестко привязываются к разметке.

Поддерживается IE начиная с 5.0

Получено с http://spravkaweb.local/index.php/css/reference/hieroglyph
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 18:55, 7 января 2007.
  • К этой странице обращались 113 раз.
4.00641083717


Справочник по CSS : Расположение элементов — Справочник Web-языков

Справочник по CSS : Расположение элементов

 |  |  |  | Свойства текста, содержащего иероглифы
Главная | ::. | CSS | ::. | Расположение элементов
 |  |  |  | Границы элементов

Содержание

  • 1 margin
  • 2 margin-top
  • 3 margin-right
  • 4 margin-bottom
  • 5 margin-left
  • 6 padding-top
  • 7 padding-right
  • 8 padding-bottom
  • 9 padding-left
  • 10 width
  • 11 height
  • 12 top
  • 13 bottom
  • 14 left
  • 15 right
  • 16 float
  • 17 vertical-align
  • 18 overflow
  • 19 overflow-x
  • 20 overflow-y
  • 21 zoom
  • 22 table-layout
  • 23 Смотреть также

[править] margin

Задает ширины полей между элементами страницы и его соседями.

Заменяет атрибуты margin-top, margin-right, margin-bottom и margin-left.

margin: {margin-top} [{margin-right}] [{margin-bottom}] [{margin-left}];

Может быть задано от одного до четырех значений. Если задано одно значение, оно применяется ко всем четырем полям. Если задано два значения, первое относится к верхнему и нижнему полю, а второе - к левому и правому. Если задано три значения, то первое применяется к верхнему полю, второе - к левому и правому, третье - к нижнему.

Поддерживается IE начиная с 3.02 для текстовых элементов и начиная с 4.0 для нетекстовых.

Поддерживается NN начиная с 4.0

[править] margin-top

Задает верхнее поле между элементом страницы и его соседями сверху.

margin-top: auto|{Y}|{Y}%;

Координата может быть задана как абсолютной величиной, так и процентом от высоты родителя. Предопределенное значение auto заставляет Web-обозреватель устанавливать поле самостоятельно. При этом если задан атрибут margin-bottom, значение верхнего поля устанавливается равным значению нижнего поля. Значение по умолчанию auto.

Поддерживается IE начиная с 3.02 для текстовых элементов и начиная с 4.0 для нетекстовых.

Поддерживается NN начиная с 4.0

[править] margin-right

Задает правое поле между элементом страницы и его соседями справа.

margin-right: auto|{X}|{X}%;

Координата может быть задана как абсолютной величиной, так и процентом от ширины родителя. Предопределенное значение auto заставляет Web-обозреватель устанавливать поле самостоятельно. При этом если задан атрибут margin-left, значение правого поля устанавливается равным значению левого поля. Значение по умолчанию auto.

Поддерживается IE начиная с 3.02 для текстовых элементов и начиная с 4.0 для нетекстовых.

Поддерживается NN начиная с 4.0

[править] margin-bottom

Задает нижнее поле между элементом страницы и его соседями снизу.

margin-bottom: auto|{Y}|{Y}%;

Координата может быть задана как абсолютной величиной, так и процентом от высоты родителя. Предопределенное значение auto заставляет Web-обозреватель устанавливать поле самостоятельно. При этом если задан атрибут margin-top, значение нижнего поля устанавливается равным значению верхнего поля. Значение по умолчанию auto.

Поддерживается IE начиная с 3.02 для текстовых элементов и начиная с 4.0 для нетекстовых.

Поддерживается NN начиная с 4.0

[править] margin-left

Задает левое поле между элементом страницы и его соседями слева.

margin-left: auto|{X}|{X}%;

Координата может быть задана как абсолютной величиной, так и процентом от ширины родителя. Предопределенное значение auto заставляет Web-обозреватель устанавливать поле самостоятельно. При этом если задан атрибут margin-right, значение левого поля устанавливается равным значению правого поля. Значение по умолчанию auto.

Поддерживается IE начиная с 3.02 для текстовых элементов и начиная с 4.0 для нетекстовых.

Поддерживается NN начиная с 4.0

[править] padding-top

Задает расстояние между элементом страницы и верхней границей.

pading-top: {Y}|{Y}%;

Координата может быть задана как абсолютной величиной, так и процентом от высоты родителя.

Значение по умолчанию 0, для тега <TD> 1.

Поддерживается IE и NN начиная с 4.0

[править] padding-right

Задает расстояние между элементом страницы и правой границей.

pading-right: {X}|{X}%;

Координата может быть задана как абсолютной величиной, так и процентом от ширины родителя.

Значение по умолчанию 0, для тега <TD> 1.

Поддерживается IE и NN начиная с 4.0

[править] padding-bottom

Задает отступ между элементом страницы и нижней границей.

pading-bottom: {Y}|{Y}%;

Координата может быть задана как абсолютной величиной, так и процентом от высоты родителя.

Значение по умолчанию 0, для тега <TD> 1.

Поддерживается IE и NN начиная с 4.0

[править] padding-left

Задает расстояние между элементом страницы и левой границей.

pading-left: {X}|{X}%;

Координата может быть задана как абсолютной величиной, так и процентом от ширины родителя.

Значение по умолчанию 0, для тега <TD> 1.

Поддерживается IE и NN начиная с 4.0

[править] width

Задает ширину свободно позиционирования элемента.

width: auto|{X}|{X}%;

Ширина может быть задана как абсолютной величиной, так и процентом от ширины родителя. Предопределенное значение auto заставляет Web-обозреватель устанавливать ширину элемента самостоятельно.

Значение по умолчанию auto.

Поддерживается IE и NN начиная с 4.0

[править] height

Задает высоту свободно позиционированного элемента.

height: auto|{X}|{X}%;

Высота может быть задана как абсолютной величиной, так и процентом от ширины родителя. Предопределенное значение auto заставляет Web-обозреватель устанавливать высоту элемента самостоятельно.

Значение по умолчанию auto.

Поддерживается IE и NN начиная с 4.0

[править] top

Задает вертикальную позицию верхней границы свободно позиционированного элемента относительно родителя.

top: auto|{Y}|{Y}%;

Координата может быть задана как абсолютной величиной, так и процентом от высоты родителя. Предопределенное значение auto заставляет Web-обозреватель позиционировать элемент самостоятельно.

Значение по умолчанию auto.

Поддерживается IE и NN начиная с 4.0

[править] bottom

Задает вертикальную позицию нижней границы свободно позиционированного элемента относительно родителя.

bottom: auto|{Y}|{Y}%;

Координата может быть задана как абсолютной величиной, так и процентом от высоты родителя. Предопределенное значение auto заставляет Web-обозреватель позиционировать элемент самостоятельно.

Значение по умолчанию auto.

Поддерживается IE начиная с 4.0

[править] left

Задает горизонтальную позицию левой границы свободно позиционированного элемента относительно родителя.

left: auto|{X}|{X}%;

Координата может быть задана как абсолютной величиной, так и процентом от ширины родителя. Предопределенное значение auto заставляет Web-обозреватель позиционировать элемент самостоятельно.

Значение по умолчанию auto.

Поддерживается IE и NN начиная с 4.0

[править] right

Задает горизонтальную позицию правой границы свободно позиционированного элемента относительно родителя.

right: auto|{X}|{X}%;

Координата может быть задана как абсолютной величиной, так и процентом от ширины родителя. Предопределенное значение auto заставляет Web-обозреватель позиционировать элемент самостоятельно.

Значение по умолчанию auto.

Поддерживается IE начиная с 4.0

[править] float

Определяет обтекание элемента другими слева или справа вместо помещения под ним.

float: none|left|right;
  • float: none; - заставляет элемент страницы появляться там, где он задан (используется по умолчанию);
  • float: left; - принудительно выравнивает элемент страницы по левому краю;
  • float: right; - по правому краю.

Поддерживается IE начиная с 4.0 для кнопок и внедренных объектов и начиная с 5.0 - для остальных элементов страницы.

Поддерживается NN начиная с 4.0

[править] vertical-align

Задает вертикальное выравнивание элемента страницы внутри родителя.

vertical-align: auto|baseline|sub|super|top|text-top|middle|bottom|text-bottom;
  • vertical-align: auto; - выравнивает элемент страницы согласно значению атрибута layout-flow;
  • vertical-align: baseline; - задает выравнивание базовой линии элемента страницы по базовой линии родителя (используется по умолчанию);
  • vertical-align: sub; - превращает текст в нижний индекс;
  • vertical-align: super; - превращает текст в верхний индекс;
  • vertical-align: top; - выравнивает верх элемента страницы по самому верху родителя;
  • vertical-align: text-top; - выравнивает верх текста элемента страницы по верху текста родителя;
  • vertical-align: middle; - выравнивает центр элемента страницы по центру родителя;
  • vertical-align: bottom; - выравнивает низ элемента страницы по низу родителя;
  • vertical-align: text-bottom; - выравнивает низ текста элемента страницы по низу текста родителя.

Поддерживается IE начиная с 4.0

[править] overflow

Задает поведение элемента страницы, если содержимое в нем не помещается.

overflow: visible|scroll|hidden|auto;
  • overflow: visible; - заставляет элемент страницы расшириться так, чтобы все его содержимое было видно (значение по умолчанию);
  • overflow: scroll; - заставляет Web-обозреватель отобразить в элементе страницы полосы прокрутки, пользуясь которыми можно прокручивать его содержимое;
  • overflow: hidden; - скрывает все то, что выходит за пределы элемента страницы;
  • overflow: auto; - аналогично scroll за тем исключением, что полосы прокрутки отобаржаются только тогда, когда они реально необходимы (значение по умолчанию для <TEXTAREA>).

Поддерживается IE начиная с 4.0

[править] overflow-x

Задает поведение элемента страницы, если его ширина меньше ширины содержимого.

overflow-x: visible|scroll|hidden|auto;

Поддерживается IE начиная с 4.0

[править] overflow-y

Задает поведение элемента страницы, если его высота меньше высоты его содержимого.

overflow-y: visible|scroll|hidden|auto;

Поддерживается IE начиная с 4.0

[править] zoom

Задает масштаб отображения элемента страницы.

zoom: normal|{Масштаб}|{Масштаб}%;

Масштаб может быть задан как числом с плавающей точкой, обозначающим степень увеличения или уменьшения, так и процентной величиной. Предопределенное значение normal задает масштаб 1.0 или 100%.

Значение по умолчанию normal.

Поддерживается IE начиная с 5.5

[править] table-layout

Позволяет "зафиксировать" значения ширины ячеек таблицы.

table-layout: auto|fixed;
  • table-layout: auto; - устанавливает ширину ячейки по ширине ее содержимого (значение по умолчанию);
  • table-layout: fixed; - использует для установки ширин ячеек значения атрибутов WIDTH или, если они не заданы, просто дает ячейкам равную ширину.

Другими словами, задание значения auto позволит точно "подогнать" значения ширин ячеек, но таблица при этом будет выводиться очень долго. Значение fixed этого атрибута позволит Web-обозревателю вывести таблицу значительно быстрее, но Web-дизайнер должен будет сам задать значения ширин ячеек. Это может сильно ускорить вывод больших таблиц на экран.

Применяется только для тега <TABLE>.

Поддерживается IE начиная с 5.0

[править] Смотреть также

  • clear
Получено с http://spravkaweb.local/index.php/css/reference/margin
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 09:59, 26 марта 2007.
  • К этой странице обращались 197 раз.
3.64197087288


Справочник по CSS : Принтер — Справочник Web-языков

Справочник по CSS : Принтер

 |  |  |  | Классификации
Главная | ::. | CSS | ::. | Принтер
 |  |  |  | Псевдостили гиперссылок

[править] page-break-after

Устанавливает, будет ли после текущего элемента при печати Web-страницы производиться прогон листа.

page-break-after: auto|always|empty string;
  • page-break-after: auto; - передает управление размещением информации на листе операционной системе (значение по умолчанию);
  • page-break-after: always; - заставляет принтер прогнать лист после печати текущего элемента страницы;
  • page-break-after: empty string; - запрещает принтеру делать это в любом случае.

Поддерживается IE начиная с 4.0

[править] page-break-before

Устанавливает, будет ли перед текущего элемента при печати Web-страницы производиться прогон листа.

page-break-before: auto|always|empty string;
  • page-break-before: auto; - передает управление размещением информации на листе операционной системе (значение по умолчанию);
  • page-break-before: always; - заставляет принтер прогнать лист перед печатью текущего элемента страницы;
  • page-break-before: empty string; - запрещает принтеру делать это в любом случае.

Поддерживается IE начиная с 4.0

Получено с http://spravkaweb.local/index.php/css/reference/print
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 19:32, 7 января 2007.
  • К этой странице обращались 97 раз.
2.98926210403


Справочник по CSS : Правила — Справочник Web-языков

Справочник по CSS : Правила

 |  |  |  | Псевдостили текста
Главная | ::. | CSS | ::. | Правила

Правила используются в таблицах стилей для особых нужд.

Содержание

  • 1 charset
  • 2 font-face
  • 3 import
  • 4 page
  • 5 important

[править] charset

Задает текстовую кодировку для внешней таблицы стилей.

@charset {Кодировка};

Пример:

@charset "windows-1251";

Может использоваться только во внешних таблицах стилей; должна быть первой строкой в файле.

Поддерживается IE начиная с 4.0

[править] font-face

Задает файл загружаемого шрифта для использования на Web-странице.

@font-face {Определение загружаемого шрифта};

Определение загружаемого шрифта имеет следующий формат:

font-family: {Имя шрифта}
src: url({Интернет-адрес файла шрифта}) }

Пример:

@font-face {
font-family: comic;
src: url(http://www.youodmain.ru/comic_font_file.eot); }

Поддерживается IE начиная с 4.0

[править] import

Импортирует внешную таблицу стилей.

@import url("{Интернет-адрес файла таблицы стилей}");

Пример:

@import url("http://www.spravkaweb.ru/style_file.css");

Поддерживается IE начиная с 4.0

[править] page

Используется при задании размеров, ориентаций и полей печатной страницы в таблице стилей.

@page {Селектор страницы} {Правила}

Селектор страницы может принимать одно из трех значений:

  • first: - первая печатная страница;
  • left: - четная страница;
  • right: - нечетная страница.

Пример:

@page :first {margin-top: 2cm; margin-bottom: 2cm;}

Здесь мы задали для первой печатной страницы поля по два сантиметра сверху и снизу.

Поддерживается IE начиная с 5.5

[править] important

Используется для задания неперекрываемых установок стиля.

{Установки слиля}!important

Пример:

<STYLE>
P { color: red !important}
</STYLE>
<P style="color: green">Этот текст останется красным.</P>

Здесь установки, сделанные для текстового абзаца <P>, не будут перекрыты в дальнейшем.

Поддерживается IE начиная с 4.0

Получено с http://spravkaweb.local/index.php/css/reference/rule
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:07, 19 марта 2007.
  • К этой странице обращались 127 раз.
2.38607907295


Справочник по CSS : Свойства текста — Справочник Web-языков

Справочник по CSS : Свойства текста

 |  |  |  | Цветовая гамма
Главная | ::. | CSS | ::. | Свойства текста
 |  |  |  | Свойства текста, содержащего иероглифы

Содержание

  • 1 text-decoration
  • 2 text-underline-position
  • 3 text-align
  • 4 text-align-last
  • 5 text-indent
  • 6 text-height
  • 7 text-transform
  • 8 clear
  • 9 word-spacing
  • 10 word-wrap
  • 11 word-mode
  • 12 leter-spacing
  • 13 line-height
  • 14 direction
  • 15 unicode-bidi
  • 16 accelerator

[править] text-decoration

Задает специальное оформление текста: подчеркнутый, зачеркнутый и т.п.

text-decoration: none|underline|overline|line-through|blink;
  • text-decoration: none; - отменяет любое специальное оформление (значение по умолчанию для большинства тегов);
  • text-decoration: underline; - подчеркивает текст (значение по умолчанию для тегов <A>, <INS> и <U>);
  • text-decoration: overline; - черта сверху текста;
  • text-decoration: line-through; - зачеркивает текст (значение по умолчанию для тегов <DEL>, <S> и <STRIKE>);
  • text-decoration: blink; - мигание текста (отсутствует в IE)
  • text-decoration: uppercase - все буквы становятся заглавными;
  • text-decoration: lowercase - все буквы становятся маленькими (прописными);
  • text-decoration: capitalize - каждое слово в строке начинается с большой буквы.

Поддерживается IE начиная с 3.02 для текстовых элементов страницы и начиная с 4.0 для нетекстовых.

Поддерживается NN начиная с 4.0

[править] text-underline-position

Задает местонахождение линии подчеркивания: выше или ниже текста.

Имеет смысл, если атрибут text-decoration равен underline или overline.

text-underline-position: below|above;
  • text-underline-position: below; - помещает линию подчеркивания под текстом (значение по умолчанию);
  • text-underline-position: above; - над текстом ("надчеркивание").

Поддерживается IE начиная с 5.5

[править] text-align

Определяет горизонтальное выравнивание текста.

text-align: left|right|center|justify;
  • text-align: left; - выравнивание текста по левому краю (значение по умолчанию);
  • text-align: right; - выравнивание по правому краю;
  • text-align: center; - выравнивание по центру;
  • text-align: justify; - выравнивание по обоим краям (по ширине).

Поддерживается IE начиная с 3.02; значение justify поддерживается начиная с 4.0

Поддерживается NN начиная с 4.0

[править] text-align-last

Задает горизонтальное выравнивание последней строки абзаца.

text-align-last: auto|inherit|left|right|center|justify;
  • text-align: auto; - выравнивает последнюю строку абзаца так же, как и остальные строки (основываясь на значении атрибута text-align) (значение по умолчанию);
  • text-align: inherit; - так же, как выровнен текст родителя;
  • text-align: left; - выравнивание текста по левому краю;
  • text-align: right; - выравнивание по правому краю;
  • text-align: center; - выравнивание по центру;
  • text-align: justify; - выравнивание по обоим краям (по ширине).

Поддерживается IE начиная с 5.5

[править] text-indent

Устанавливает отступ красной строки.

text-ident: {Отступ}|{Отступ}%;

Отступ может быть задан как абсолютной величиной, так и процентом от ширины родителя. Значение по умолчанию 0.

Поддерживается IE и NN начиная с 4.0

[править] text-height

Интервал между строками текста.

text-height: {Интервал}|{Интервал}%;

Интервал может быть задан как абсолютной величиной, так и процентом от ширины родителя.

Поддерживается IE и NN начиная с 4.0

[править] text-transform

Задает преобразование регистра символов текста.

text-transform: none|capitalize|uppercase|lowercase;
  • text-transform: none; - отключает любые преобразования регистра символов (значение по умолчанию);
  • text-transform: capitalize; - преобразует первую букву каждого слова текста в верхний регистр;
  • text-transform: uppercase; - преобразует все символы текста в верхний регистр;
  • text-transform: lowercase; - в нижний регистр.

Поддерживается IE и NN начиная с 4.0

[править] clear

Определяет, с какой стороны элемента запрещено его обтекание другими элементами. Если установлено значение параметра float для этого элемента, свойство clear отменяет его действие для указанных сторон.

clear: none|left|right|all;

Атрибут задается для текста, а не для элемента страницы, который он будет "обтекать".

  • clear: none; - разрешает тексту "обтекать" элемент страницы (значение по умолчанию);
  • clear: left; - запрещает тексту "обтекать" элемент страницы с левой стороны;
  • clear: right; - с правой стороны;
  • clear: all; - с обеих сторон.

Поддерживается IE и NN начиная с 4.0

[править] word-spacing

Определяет дополнительное расстояние между словами в тексте.

word-spacing: normal|{Величина};

Значение этого атрибута может быть задано либо абсолютной величиной в одной из поддерживаемых CSS единиц измерения, либо предопределенным значением normal, задающим стандартную величину расстояния между символами.

Значение по умолчанию normal.

Поддерживается IE начиная с 4.0

[править] word-wrap

Устанавливает, будет ли строка, выходящая за границы элемента страницы и не содержащая пробелов, переноситься по словам.

word-wrap: normal|break-word;
  • word-wrap: normal; - запрещает переносить строки по словам (значение по умолчанию);
  • word-wrap: break-word; - разрешает.

Поддерживается IE начиная с 5.5

[править] word-mode

Задает направление строк текста: горизонтальное или вертикальное.

word-mode: lr-tb|tb-rl;
  • word-mode: lr-tb; - задает обычное горизонтальное расположение строк текста; текст пишется слева направо и сверху вниз (значение по умолчанию);
  • word-mode: tb-rl; - поворачивает текст на 90° по часовой стрелке; при этом он будет писаться сверху вниз и справа налево.

Поддерживается IE начиная с 5.5

[править] leter-spacing

Определяет расстояние между символами в тексте.

letter-spacing: normal|{Величина};

Значение этого атрибута может быть задано либо абсолютной величиной в одной из поддерживаемых CSS единиц измерения, либо предопределенным значением normal, задающим стандартную величину расстояния между символами.

Значение по умолчанию normal.

Поддерживается IE начиная с 4.0

[править] line-height

Задает вертикальное расстояние между строками текста.

line-height: normal|{Y}|{Y}%;

Высота может быть задана как абсолютной величиной, так и процентом от высоты родителя. Предопределенное значение normal задает стандартное расстояние.

Значение по умолчанию normal.

Поддерживается IE и NN начиная с 4.0

[править] direction

Задает порядок чтения текста: слева направо или справа налево.

direction: ltr|rtl|inherit;
  • direction: ltr; - задает порядок чтения слева направо (значение по умолчанию);
  • direction: rtl; - справа налево;
  • direction: inherit; - заставляет наследовать порядок чтения у родителя.

Для документов, составленных на европейских языках, порядок чтения всегда слева направо (ltr).

Поддерживается IE начиная с 5.0

[править] unicode-bidi

Задает поведение встроенных элементов при изменении направления письма с помощью атрибута direction.

unicode-bidi: normal|embed|bidi-override;
  • unicode-bidi: normal; - меняет направление письма и у родителя (используется по умолчанию);
  • unicode-bidi: embed; - меняет направление письма только у встроенного элемента;
  • unicode-bidi: bidi-override; - аналогично embed за тем исключением, что направление письма меняется согласно значению атрибута direction, независимо от локальных установок Web-обозревателя.

Поддерживается IE начиная с 5.0

[править] accelerator

Позволяет указать, содержит ли текст элемента страницы клавишу-ускоритель.

accelerator: true|false;

Клавиша-ускоритель - это особая клавиша на клавиатуре, при нажатии которой вместе с клавишей <Alt> происходит переход к данному элементу страницы.

  • accelerator: true; - указывает, что текст содержит клавишу-ускоритель;
  • accelerator: false; - не содержит.

Значения по умолчанию не имеет.

Пример использования:

<LABEL for="txtName"><U style="accelerator: true">И</U>мя</LABEL>
<INPUT type="text" id="txtName" accesskey="B" value="Имя пользователя">

В этом случае символ "И" в слове "Имя" будет подчеркнут. Если в региональных настройках операционной системы Windows 2000 была выбрана опция Скрыть индикаторы клавиш-ускорителей до нажатия Alt, этот символ не будет подчеркнут, пока пользователь не нажмет клавишу <Alt> на клавиатуре.

Поддерживается IE начиная с 5.0

Получено с http://spravkaweb.local/index.php/css/reference/text
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 08:58, 26 марта 2007.
  • К этой странице обращались 168 раз.
4.79574799538


Разработка сайтов : Портфолио — Справочник Web-языков

Разработка сайтов : Портфолио

 |  |  |  | Резюме
Главная | ::. | Разработка сайтов | ::. | Портфолио

[править] Разработка и внедрение проектов

spravkaweb.ru - Информационный портал по языкам программирования в Internet
ndv.ru - Портал агенства недвижимости "НДВ-группа"
lucas-m.ru - Интернет-магазин ювелирного завода ЗАО Торговая фирма «Лукас М»
diamondring.ru - Интернет-магазин ювелирных украшений
rumex.ru - Интернет-магазин международной офтальмологической компании "Rumex Group"
expo.rumex.ru - Сокращенная версия интернет магазина rumex.net для установки на стендах при проведении выставок международной офтальмологической компании "Rumex Group"
office.rumex.ru - CRM-система для международной офтальмологической компании "Rumex Group"
realtypro.ru - Многопользовательская система работы с новостройками «RealtyPro – Новостройки»

[править] Доработка и настройка проектов

  • Новостные сайты: 1001runews.com, 1001-runews.com, 1001runews.net, 1001-runews.net, all-hotnews.com, allhot-news.com, all-hotnews.net, allhot-news.net, city-rus.com, eventreadmore.com, eventreadmore.net, event-readmore.net, event-readmore.com, hotrunews.com, hot-runews.com, hotrunews.net, hot-runews.net, news-air.com, news-art.info, news-politics.com, newsreadmore.com, news-readmore.com, newsreadmore.net, news-readmore.net, news-russian.net, news-russian.info, politics-rus.com, readmoreevent.com, readmore-event.com, readmoreevent.net, readmore-event.net, readmorenews.com, readmore-news.com, readmorenews.net, readmore-news.net, runews1001.com, runews-1001.com, runews1001.net, runews-1001.net, runewshot.com, runews-hot.com, runewshot.net, runews-hot.net, rus-city.com, ruscity-news.com, rusnewssport.com, ruspolitics.com, rus-politics.com, russian-news.info, russportnews.com, russport-news.com
  • Сайт поддержки группы "Аквариум" aquarium.moipoisk.ru
  • Страховая компания ООО "Страховой Сервис" inmar.ru
Получено с http://spravkaweb.local/index.php/development/portfolio
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:13, 30 марта 2007.
  • К этой странице обращались 31 раз.
1.48150491714


Разработка сайтов : Резюме — Справочник Web-языков

Разработка сайтов : Резюме

Главная | ::. | Разработка сайтов | ::. | Резюме
 |  |  |  | Портфолио

Содержание

  • 1 Успенский Евгений Владимирович
    • 1.1 Личные данные
    • 1.2 Профессиональные навыки
    • 1.3 Иностранные языки
    • 1.4 Личностные качества

[править] Успенский Евгений Владимирович

[править] Личные данные

Успенский Евгений Владимирович
  • Дата рождения: 9 апреля 1979 года
  • Место рождения: г.Рязань, Россия
  • Образование: Рязанская Государственная Радиотехническая Академия ( Радиотехнический факультет)
  • Семейное положение: женат
  • Дети: дочь
  • Контактная информация: тел.: 8-910-908-21-23, [image] 195938768, E-mail: admin@spravkaweb.ru

[править] Профессиональные навыки

Технологии
  • Web, XML и HTML: HTML, CSS, XML/XSL, DOM
  • Контроль версий: SVN, CVS
  • AJAX на базе JSON и Sajax
  • Flash
Веб-серверы
  • Apache
Субд
  • MySQL
Языки программирования
  • PHP, JavaScript, ActionScript
  • Приложения: Smarty, XTPL, PEAR, Zend Framework, YUI
  • Программные продукты: OSCommerce, XTCommerce, SapidCMF, SugarCRM, phpBB

[править] Иностранные языки

Технический ангийский: чтение технической литературы

[править] Личностные качества

Лидерские качества, коммуникабельность, желание постоянно самосовершенствоваться, быстрая обучаемость, высокая работоспособность, целеустремленность.

Получено с http://spravkaweb.local/index.php/development/resume
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 19:41, 30 марта 2007.
  • К этой странице обращались 42 раза.
1.30252218246


Справочник по Flash — Справочник Web-языков

Справочник по Flash

Главная ::. Flash

[править] Разделы справки

  • ActionScript
    • Basic Actions
      • gotoAndPlay - Переход на кадр и воспроизведение
      • gotoAndStop - Переход на кадр и остановка
      • nextFrame - Переход на следующий кадр
      • prevFrame - Переход на предыдущий кадр
      • nextScene - Переход на следующую сцену
      • prevScene - Переход на предыдущую сцену
      • Play - Воспроизведение
      • Stop - Остановка
      • toggleHighQuality - Изменение качества
      • stopAllSounds - Остановка всех звуков
      • getURL - Переход на веб-страницу
      • fscommand - Передача данных браузеру
      • loadMovie - Загрузить файл .swf
      • loadMovieNum - Загрузить файл .swf
      • unloadMovie - Удалить фильм или клип из проигрывателя
      • unloadMovieNum - Удалить фильм из проигрывателя
      • tellTarget - Обратиться к удаленному клипу
      • ifFrameLoaded - Выполняет код если загруженн определенный кадр
    • Action
      • break - Прекращает выполнение цикла
      • call - Выполнить сценарий удаленного клипа
      • comment - Вставить комментарии
      • continue - Заново начинает текущий цикл
      • delete - Удаление объекта, элемента массива или переменной
      • duplicateMovieClip - Создать копию клипа
      • evaluate - Создает новую пустую строку, и вставляет ;
      • for - Многократно выполняет некоторый код
      • for...in - Цикл, используемый для перечисления свойств объекта
      • fscommand - Передача данных браузеру
      • function - Создает новую функцию
      • getURL - Переход на веб-страницу
      • if - Выполнение или не выполнение предложений в зависимости от условий
      • ifFrameLoaded - Выполняет код если загруженн определенный кадр
      • include - Импорт текста из внешнего файла ActionScript
      • loadMovie - Загрузить файл .swf
      • loadMovieNum - Загрузить файл .swf
      • loadVariables - Загружает в клип или фильм внешние переменные
      • loadVariablesNum - Прикрепляет группу внешних переменных к уровню документа
      • print - Вывод на печать кадров фильма или клипа с использованием векторной графики
      • printNum - Печать кадров уровня документа как векторных изображений
      • printAsBitmap - Вывод на печать кадров фильма или клипа с использованием растровой графики
      • printAsBitmapNum - Печать кадров уровня документа как растровых изображений
      • removeMovieClip - Удалить клип фильма из Flash Player
      • return - Выходит из функции или возвращает ее значение
      • setProperty - Присвоить значение свойству клипа фильма
      • startDrag - Заставляет фильм или клип следовать за курсором мыши
      • Stop - Остановить воспроизведение фильма на текущем кадре
      • stopAllSounds - Выключить все звуки
      • stopDrag - Останавливает текущую операцию перетаскивания
      • tellTarget - Обратиться к удаленному клипу
      • toggleHighQuality - Изменение качества
      • unloadMovie - Удалить фильм или клип из проигрывателя
      • unloadMovieNum - Удалить фильм из проигрывателя
      • var - Объявление локальной переменной
      • while - Многократно выполняет некоторый код
      • with - Выполняет некоторый код в конце указанного объекта

[править] Полезные ссылки

  • Форум по Flash
Получено с http://spravkaweb.local/index.php/flash
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 12:47, 20 марта 2007.
  • К этой странице обращались 398 раз.
1.4582028389


Справочник по Flash : ActionScript : Action : break - Прекращает выполнение цикла — Справочник Web-языков

Справочник по Flash : ActionScript : Action : break - Прекращает выполнение цикла

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Basic Actions : ifFrameLoaded - Выполняет код если загруженн определенный кадр
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | break - Прекращает выполнение цикла
 |  |  |  |  |  |  |  | call - Выполнить сценарий удаленного клипа

[править] break

(Предложение)

Прекращает выполнение цикла

[править] Синтаксис:

break()

[править] Описание:

В простом цикле проверочное выражение является единственным фактором, определяющим прекращение выполнения цикла. Когда проверочное предложение простого цикла дает значение false, цикл завершается. Однако если цикл становится более сложным, может потребоваться остановка его выполнения независимо от значения проверочного предложения. Для этого используются предложения break и continue.

Предложение break предоставляет способ остановить процесс, продолжать который нет больше необходимости.

Например, можно использовать цикл for-in в программе проверки формы, которая обходит переменные текстовых полей ввода на временной диаграмме. При обнаружении пустого поля ввода мы предупреждаем пользователя о том, что он неправильно заполнил форму.

Прекратить процесс можно, выполнив предложение break, как показано в приведенном далее примере.

Обратите внимание, что в примере предполагается существование клипа с именем form, который содержит ряд объявленных входных переменных с именами input01, input02 и т.д.:

for(var prop in form) {
  // Если это свойство служит одним из наших
  // "входных" текстовых полей
  if (prop.indexOf("input") != -1) {
    // Если в поле формы пусто,
    // прервать операцию
    if (form[prop] == "") {
      displayMessage = "Пожалуйста, заполните форму полностью.";
      break;
    }
    // Все подпредложения после команды break пропускаются,
    // когда выполнена break
  }
}
// Отсюда возобновляется выполнение после окончания цикла,
// вызванного командой break или присваиванием проверочному
// выражению значения false

Предложение break можно использовать для прерывания цикла, который иначе был бы бесконечным. Это позволяет, скажем, выполнить предложения первой части блока и не выполнять предложения, следующие за if (условие) break:

while (true) {
  // Здесь идут начальные предложения
  if (condition) break;
  // Здесь идут последующие предложения
}

[править] Совместимость:

Используется с 4-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/break
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 11:45, 14 января 2007.
  • К этой странице обращались 109 раз.
1.9692568779


Справочник по Flash : ActionScript : Action : call - Выполнить сценарий удаленного клипа — Справочник Web-языков

Справочник по Flash : ActionScript : Action : call - Выполнить сценарий удаленного клипа

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | break - Прекращает выполнение цикла
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | call - Выполнить сценарий удаленного клипа
 |  |  |  |  |  |  |  | comment - Вставить коментарии

[править] call

(Глобальная функция)

Вызывает из текущего скрипта скрипт, который прикреплен к указываемому кадру

[править] Синтаксис:

call(frameLabel)
call(frameNumber)

[править] Аргументы:

frameLabel
Строка, содержащая метку кадра, сценарий которого должен быть выполнен.
frameNumber
Номер кадра, сценарий которого должен быть выполнен.

[править] Описание:

Функция call() выполняет сценарий, прикрепленный к кадру с меткой frmaeLabel или номером frameNumber.

Например, следующий код выполняет сценарий кадра 20 текущей временной диаграммы:

call(20);

Во Flash 4 call() использовалась для создания грубого подобия многократно используемой подпрограммы (не способной принимать параметры и возвращать значение). Во Flash 5 предпочтительнее использовать предложение function.

Отметим, что во Flash 5 при удаленном вызове сценария через call() переменные, объявленные посредством ключевого слова var, считаются локальными для этого сеанса выполнения и прекращают свое существование по завершении сценария. Чтобы создать нелокальные переменные в удаленно выполняемом сценарии, опустите ключевое слово var:

// Локальная переменная; умрет после выполнения сценария
var x = 10;
// Переменная временной диаграммы; сохраняется по завершении
x = 10;

Для вызова call() с кадрами вне текущей временной диаграммы воспользуйтесь функцией tellTarget()

В следующем примере выполняется сценарий в кадре 10 клипа box:

tellTarget ("box") {
    call(10);
}

[править] Совместимость:

Используется с 4-ой версии Flash. В Flash 5 рекомендуется использовать команду function().

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/call
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 11:54, 14 января 2007.
  • К этой странице обращались 69 раз.
1.48766088486


Справочник по Flash : ActionScript : Action : comment - Вставить коментарии — Справочник Web-языков

Справочник по Flash : ActionScript : Action : comment - Вставить коментарии

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | call - Выполнить сценарий удаленного клипа
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | comment - Вставить коментарии
 |  |  |  |  |  |  |  | continue - Заново начинает текущий цикл

[править] comment

Указывает начало комментария. Любой текст между ограничителем и знаком конца строки является комментарием и игнорируется интерпретатором ActionScript.

[править] Синтаксис:

// comment

[править] Аргументы:

comment
Текст, который не является частью кода и должен игнорироваться интерпретатором.

[править] Пример:

Этот скрипт использует двойной слеш для идентификации первой, третьей, пятой и седьмой строк, как комментариев:

// set the X position of the ball movie clip
ball = getProperty(ball._x);
// set the Y position of the ball movie clip
ball = getProperty(ball._y);
// set the X position of the kitty movie clip
kitty = getProperty(kitty._x);
// set the Y position of the kitty movie clip
kitty_y = getProperty(kitty._y);

[править] Совместимость:

Используется с 1-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/comment
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:13, 14 января 2007.
  • К этой странице обращались 60 раз.
1.29039812088


Справочник по Flash : ActionScript : Action : continue - Заново начинает текущий цикл — Справочник Web-языков

Справочник по Flash : ActionScript : Action : continue - Заново начинает текущий цикл

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | comment - Вставить коментарии
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | continue - Заново начинает текущий цикл
 |  |  |  |  |  |  |  | delete - Удаление объекта, элемента массива или переменной

[править] continue

(Предложение)

Фигурирует внутри некоторых типах операторов цикла

[править] Синтаксис:

continue

[править] Описание:

Предложение continue аналогично предложению break, поскольку прерывает текущую итерацию цикла, но в отличии от break возобновляет выполнение цикла с очередной естественной итерации.

Во всех типах циклов предложение continue прерывает текущую итерацию тела цикла, но при возобновлении цикла могут быть некоторые различия в зависимости от типа предложения цикла.

  • В цикле while, continue заставляет Flash пропустить оставшуюся часть тела цикла, и перейти к его вершине, где проверяется условие выхода из цикла.
  • В цикле do...while, continue заставляет Flash пропустить оставшуюся часть тела цикла, и перейти к его окончанию, где проверяется условие выхода из цикла.
  • В цикле for, continue заставляет Flash пропустить оставшуюся часть тела цикла, и перейти туда, где вычисляется условие выхода из цикла.
  • В цикле for...in, continue заставляет Flash пропустить оставшуюся часть тела цикла, и перейти к его вершине, где обрабатывается следующее значение.

С помощью предложения continue можно сделать предложение тела цикла необязательным в зависимости от обстоятельств.

Например, в следующем коде мы перемещаем все экземпляры клипов, не являющиеся прозрачными, к левому краю рабочего стола и пропускаем тело цикла для прозрачных экземпляров:

for (var prop in _root) {
  if (typeof _root[prop] == "movieclip") {
    if (_root[prop]._alpha < 100) {
      continue;
    }
    _root[prop]._x = 0;
  }
}

[править] Совместимость:

Используется с 4-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/continue
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:20, 14 января 2007.
  • К этой странице обращались 54 раза.
1.42705893517


Справочник по Flash : ActionScript : Action : delete - Удаление объекта, элемента массива или переменной — Справочник Web-языков

Справочник по Flash : ActionScript : Action : delete - Удаление объекта, элемента массива или переменной

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | continue - Заново начинает текущий цикл
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | delete - Удаление объекта, элемента массива или переменной
 |  |  |  |  |  |  |  | duplicateMovieClip - Создать копию клипа

[править] delete

(Оператор)

Этот оператор используется для удаления из сценария объекта, свойства объекта, элемента массива или переменных.

[править] Синтаксис:

delete identifier;

[править] Аргументы:

identifier
Имя переменной, объекта, свойства объекта, массива или переменной массива, подлежащего удалению.

[править] Описание:

Оператор delete уничтожает объект или переменную, имя которой указывает identifier, и возвращает true если объект был успешно удален. В противном случае возвращает false.

Этот оператор полезен для высвобождения памяти, используемой скриптами, хотя, delete - оператор, который обычно применяется в формулировке:

delete x;

Оператор delete может не сработать и возвратить false если identifier не существует, или не может быть удален.

Предопределенные функции и объекты, также как и переменные, объявленные с помощью var, не могут быть удалены.

Чтобы избавить массив от ненужного именованного элемента, применяем оператор delete:

delete arrayName.elementName

Удаление именованного элемента разрушает как значение элемента, так и его контейнер, освобождая при этом память, занимаемую элементом и его содержимым. (При удалении нумерованных элементов оператор delete удаляет только значение, а контейнер сохраняет).

В следующих примерах создается объект, используется, а затем удаляется за ненадобностью:

account = new Object();
    account.name = "Jon";
    account.balance = 10000;
    ...
    delete account;

В следующем примере удаляется свойство (property) объекта:

// создаем новый объект "account"
account = new Object();
// назначаем свойство name объекту account
    account.name = "Jon";
// удаляем свойство
delete account.name;

Еще один пример удаления свойства объекта:

// создаем массив длиной 0
array = new Array();
// теперь его длина - 1
    array[0] = "abc";
// добавляем еще один элемент - длина - 2
    array[1] = "def";
// теперь - 3
    array[2] = "ghi";
// удаляем array[2] но длина массива не меняется,
    delete array[2];

Следующие примеры демонстрируют действие delete на объектные ссылки:

// создаем объект, присваиваем переменной ref1 значение ссылки на него
ref1 = new Object();
ref1.name = "Jody";
// копируем ссылочную переменную, а затем удаляем ref1
ref2 = ref1;
delete ref1;

Если бы ref1 не была бы скопирована в ref2, то и объект был бы удален, так как на него не осталось бы ни одной ссылки. Когда же мы удалим ref2, больше не останется ссылок на объект, и он будет удален, так как на него не будет ссылаться ни одна переменная.

[править] Совместимость:

Используется с 5-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/delete
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:34, 14 января 2007.
  • К этой странице обращались 54 раза.
1.45380711555


Справочник по Flash : ActionScript : Action : duplicateMovieClip - Создать копию клипа — Справочник Web-языков

Справочник по Flash : ActionScript : Action : duplicateMovieClip - Создать копию клипа

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | delete - Удаление объекта, элемента массива или переменной
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | duplicateMovieClip - Создать копию клипа
 |  |  |  |  |  |  |  | evaluate - Создает новую пустую строку, и вставляет ;

[править] duplicateMovieClip

(Глобальная функция)

Эта функция позволяет создать копию существующего клипа

[править] Синтаксис:

duplicateMovieClip(target, newname, depth);

[править] Аргументы:

target
Строка, указывающая путь к клипу, который нужно дублировать (называемому также порождающим клипом). Ссылаться на вложенные клипы можно с помощью синтаксиса точки, например, duplicateMovieClip("_root.myClip","myClip2",0). Так как ссылка на клип преобразуется в путь при использовании в строковом контексте, target может также быть ссылкой на объект клипа, как в duplicateMovieClip(myClip, "myClip2", 0).
newname
Строка, которая станет именем экземпляра дублируемого клипа. Она должна удовлетворять правилам создания идентификаторов.
depth
Целое число, показывающее уровень стека программно создаваемых клипов, на который должен быть помещен продублированный клип. Клипы на более низких уровнях визуально помещаются позади клипов на более высоких уровнях. Клип с самым высоким значением depth в стеке закрывает все клипы, лежащие ниже. Например, клип на depth-1 оказывается за клипом на depth 0, который в свою очередь оказывается за клипом на depth 1. Если назначаемое значение depth уже используется, прежний клип удаляется, а его место занимает новый клип. Отрицательные значения уровней действуют, но официально не поддерживаются ActionScript - для гарантии совместимости с будущими версиями используйте уровни 0 и выше.

[править] Описание:

Создает экземпляр муви-клипа во время проигрывания фильма. Дублирование всегда начинается с кадра номер 1, вне зависимости от того, на каком кадре был клип.

Дублированный клип наследует все преобразования (поворот, масштаб и пр.), применявшиеся к target, но не наследует его переменные временной диаграммы target.

Если удаляется родительский мувик, то дублированный - тоже удаляется. Используйте команду или метод removeMovieClip чтобы удалить экземпляр муви-клипа, созданного командой duplicateMovieClip.

Доступ к глобальной функции duplicateMovieClip() можно осуществить и как к методу клипа, но в таком формате не используется аргумент target.

[править] Примеры:

// Копирует клип ball и дает копии имя ball2
duplicateMovieClip(ball, "ball2", 0);
// Перемещает созданный клип ball2,
// чтобы его можно было видеть
ball2._x += 100;

Следующие строчки множат flower десять раз. Переменная i используется для того, чтобы создать уникальное имя и положить новый мувик на уникальную глубину.

on(release) {
    amount = 10;
    while(amount>0) {
        duplicateMovieClip (_root.flower, "mc" + i, i);
        setProperty("mc" + i, _x, random(275));
        setProperty("mc" + i, _y, random(275));
        setProperty("mc" + i, _alpha, random(275));
        setProperty("mc" + i, _xscale, random(50));
        setProperty("mc" + i, _yscale, random(50));
        i = i + 1;
        amount = amount-1;
    }
}

[править] Совместимость:

Используется с 4-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/duplicatemovieclip
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:44, 14 января 2007.
  • К этой странице обращались 62 раза.
1.61992383003


Справочник по Flash : ActionScript : Action : evaluate - Создает новую пустую строку, и вставляет ; — Справочник Web-языков

Справочник по Flash : ActionScript : Action : evaluate - Создает новую пустую строку, и вставляет ;

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | duplicateMovieClip - Создать копию клипа
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | evaluate - Создает новую пустую строку, и вставляет ;
 |  |  |  |  |  |  |  | for - Многократно выполняет некоторый код

[править] evaluate

Создает новую пустую строку, и вставляет ; для того, чтобы можно было ввести свой код в строку Expression панели Actions.

[править] Синтаксис:

statement;

Действие evaluate позволяет вызывать свои функции пользователю, который редактирует скрипт в режиме Normal Mode.

[править] Совместимость:

Используется с 5-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/evaluate
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:32, 14 января 2007.
  • К этой странице обращались 53 раза.
1.42552781105


Справочник по Flash : ActionScript : Action : for - Многократно выполняет некоторый код — Справочник Web-языков

Справочник по Flash : ActionScript : Action : for - Многократно выполняет некоторый код

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | evaluate - Создает новую пустую строку, и вставляет ;
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | for - Многократно выполняет некоторый код
 |  |  |  |  |  |  |  | for...in - Цикл, используемый для перечисления свойств объекта

[править] for

Многократно выполняет некоторый код

[править] Синтаксис:

for (initialization; condition; next) {
    statements
}

Цикл for помещает в заголовок цикла ключевые компоненты цикла, разделенные точкой с запятой. Перед первой итерацией цикла for выполняется предложение initialization (только один раз). Обычно оно используется для задания начального значения переменной итератора.

Как и в других циклах, если condition имеет значение true, выполняются statemets. В противном случае, цикл завершается.

В конце каждой итерации выполняется предложение next, перед очередной проверкой condition, позволяющей узнать, должен ли продолжаться цикл.

[править] Примеры:

Типичный цикл for, который просто считает от 1 до 10.

for (var i = 1; i <= 10; i++) {
  trace("Число: "+i);
}

Вот эквивалент этого примера, только составленный с помощью цикла while:

var i = 1;
while (i <= 10) {
  trace("Число: "+i);
  i++;
}

Допустим, нам нужно управлять в цикле более чем одним фактором.

В цикле for можно использовать более одной переменной-итератора, разделив их запятой.

for (var i = 1, j = 10; i <=10; i++, j--) {
  trace("i увеличивается: " + i);
  trace("j уменьшается: " + j);
};

[править] Совместимость:

Используется с 5-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/for
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:36, 14 января 2007.
  • К этой странице обращались 54 раза.
1.33663678169


Справочник по Flash : ActionScript : Action : for...in - Цикл, используемый для перечисления свойств объекта — Справочник Web-языков

Справочник по Flash : ActionScript : Action : for...in - Цикл, используемый для перечисления свойств объекта

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | for - Многократно выполняет некоторый код
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | for...in - Цикл, используемый для перечисления свойств объекта
 |  |  |  |  |  |  |  | fscommand - Передача данных браузеру

[править] for...in

Цикл, используемый для перечисления свойств объекта.

[править] Синтаксис:

for (var thisProp in object) {
    statements // Предложения обычно используют thisProp
}

Вместо повторения серии предложений, пока заданное проверочное выражение не даст значения false, цикл for-in осуществляется по одной итерации для каждого свойства для заданного объекта.

Предложения for-in не требуют явного обновляющего предложения, поскольку число итераций цикла определяется числом свойств рассматриваемого объекта.

Предложения statements выполняются по одному разу для каждого свойства object;

  • object является именем произвольного действительного объекта;
  • thisProp является произвольным именем переменной или идентификатора.

На каждой итерации цикла переменная thisProp временно хранит строку, которая содержит имя свойства объекта, перечисляемого в данный момент. Это значение строки можно использовать во время каждой итерации, чтобы получить доступ к каждому свойству и обработать его.

Простейшим примером цикла for-in является сценарий, который перечисляет свойства объекта.

[править] Примеры:

Создание объекта, а затем перечисление по пунктам его свойств с помощью цикла for-in

var ball = new Object();
ball.radius = 12;
ball.color = "red";
ball.style = "beach";

for (var prop in ball) {
  trace("balls has the property " + prop);
}

Пример выведет следующее

balls has the property style
balls has the property color
balls has the property radius

Т.к. prop хранит имена свойств ball как строки, для извлечения значений этих свойств можно использовать prop с оператором []:

for (var prop in ball) {
  trace("balls." + prop + " is " + ball[prop]);
}

Пример выведет:

ball.style is beach
ball.color is red
ball.radius is 12

Стоит обратить внимание, что свойства объекта, просматриваемые в цикле for-in, нумеруются в непредсказуемом порядке. Кроме того, предложения for-in не всегда перечисляют все свойства объекта. Если объект определен пользователем, перечисляются все свойства, включая унаследованные.

Но некоторые свойства встроенных объектов предложением for-in пропускаются. Например, этим циклом не перечисляются методы встроенных объектов. Если вы хотите использовать предложение for-in для работы со свойствами встроенного объекта, сначала создайте проверочный цикл для определения доступных свойств объекта.

Извлечение значений свойств с помощью цикла for-in предоставляет также отличную возможность обнаружения клипов, присутствующих на временной диаграмме.

Пример: Заполнение массива динамически идентифицируемыми клипами

var childClip = new Array();
var childClipCount = 0;

for(i in _root) {
  thisItem = _root[i];
  if(typeof thisItem == "movieclip") {
    // Обратите внимание на постфиксный оператор инкрементирования
    childClip[childClipCount++] = thisItem;
  }
}

// После заполнения массива можно использовать его
// для обработки клипов, которые в нем находятся

// Поместить первый клип у левого края рабочего стола
childClip[0]._x = 0
// Поместить второй клип у верхнего края рабочего стола
childClip[1]._y = 0

В приведенном примере при использовании в предложении for-in функция typeof дает удобный способ нахождения всех экземпляров клипа на временной диаграмме.

Когда клипы определены, их можно присвоить массиву для проведения программной обработки.

Цикл for-in также можно использовать для извлечения элементов массива. В этом случае цикл примет вид:

for (var thisElement in array) {
    statements;
}

Пример: Перечисление элементов массива

var myArr = [123, 234, 345, 456];
for( var elem in myArr) {
  trace(myArr[elem]);
}

[править] Совместимость:

Используется с 5-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/forin
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 18:06, 14 января 2007.
  • К этой странице обращались 62 раза.
1.34442782402


Справочник по Flash : ActionScript : Action : fscommand - Передача данных браузеру — Справочник Web-языков

Справочник по Flash : ActionScript : Action : fscommand - Передача данных браузеру

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | for...in - Цикл, используемый для перечисления свойств объекта
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | fscommand - Передача данных браузеру
 |  |  |  |  |  |  |  | function - Создает новую функцию

[править] fscommand

(Глобальная функция)

Позволяет отправить данные программе, которая запустила данный клип

[править] Синтаксис:

fscommand(command, arguments)

[править] Аргументы:

command
Строка, передаваемая приложению-хозяину, часто имя функции JavaScript;
arguments
Строка, передаваемая приложению-хозяину, часто аргумент для функции, указанной в command.

[править] Описание:

С помощью функции fscommand(), фильм Flash может связываться с автономным проигрывателем или приложением-хозяином проигрывателя: средой, в которой выполняется Flash Player (веб-браузером или Macromedia Director).

Функция fscommand() обычно используется одним из трех способов:

  • Для отправки одной из немногочисленных встроенных команд автономному проигрывателю Flash
  • Для отправки команд языку сценариев веб-браузера, например, JavaScript или VBScript
  • Для связи с Lingo в фильме Macromedia Director

При использовании с автономным плеером fscommand() принимает одну из встроенных пар команда/аргумент, как показано в следующей таблице:

Пары команда/аргумент в автономном проигрывателе

Команда | Аргумент | Описание
"allowscale" | "true" или "false" | В случае "false" предотвращает увеличение или сжатие содержимого фильма в зависимости от размера окна проигрывателя. "allowscale" часто используют в сочетании с "fullscreen", чтобы создать Projector, занимающий весь экран при сохранении исходного размера фильма.
"exec" | "application_name" | Запускает внешнее приложение. Путь к приложению задается в строке application_name. Путь разрешается относительно фильма Flash, если только application_name не задано как абсолютный тип, например: "C:/WINDOWS/NOTEPAD.EXE". Обратите внимание, что в пути используется прямая косая черта (/), а не обратная ().
"fullscreen" | "true" или "false" | В случае "true" включает максимизацию окна проигрывателя, которое занимает весь экран пользователя.
"quit" | "н/а" | Закрывает фильм и выходит из проектора Flash (автономный проигрыватель).
"showmenu" | "true" или "false" | В случае "false" подавляет вывод управляющих элементов в контекстном меню проигрывателя, оставляя только опцию About Macromedia Flash Player.
"trapallkeys" | "true" или "false" | В случае "true" все нажатия клавиш - даже клавиш сокращенного набора - посылаются фильму Flash. trapallkeys используется для отключения управляющих клавиш в автономном проигрывателе (например, Ctrl-F для полноэкранного режима, Ctrl-Q для завершения работы, Esc для режима Stop/exit Full Screen mode и т.д.)

При использовании в браузере функция fscommand() в фильме влечет вызов специальной функции JavaScript (Netscape) или VBScript (Internet Explorer) на странице, содержащей фильм. Имя этой специальной функции имеет общий вид movieID_DoFSCommand, где movieID является именем, указанным в атрибуте фильма OBJECT ID (Internet Explorer) или атрибутом EMBED NAME (Netscape) в содержащем фильм документе HTML. При вызове movieID_DoFSCommand() значения параметров fscommand() command и arguments передаются в качестве аргументов функции movieID_DoFSCommand(). Если на содержащей фильм странице не существует функции movieID_DoFSCommand(), происходит отказ функции fscommand() без каких-либо сообщений.

Обратите внимание, что для работы fscommand() с Netscape атрибут swLiveConnect тега фильма EMBED должен быть задан как "true":

<EMBED
    NAME="testmoviequot;
    SRC="myMovie.swf"
    WIDTH="100%"
    HEIGHT="100%"
    swLiveConnect="true"
    PLUGINSPAGE="http://www.macromedia.com/go/flashplayer/">
</EMBED>

Связь с браузером через fscommand() невозможна в следующих конфигурациях системы:

  • Internet Explorer под Macintosh OS
  • Любой браузер на Macintosh серии 68К
  • Любой браузер под Windows 3.1
  • Netscape 6

Стоит отметить, что fscommand() не всегда дает лучший способ связи с фильмом Director из Flash. Предпочтительным средством коммуникации с Director является функция getURL() с протоколом event: или lingo:.

[править] Примеры:

Чтобы выйти из автономного проектора, используйте такой код:

fscommand("quit");

Чтобы создать автономный проектор, выполняемый в полноэкранном режиме:

fscommand("fullscreen", "true");

Чтобы создать автономный проектор, выполняемый в полноэкранном режиме, но сохраняющий размер исходного фильма:

fscommand("fullscreen", "true");
fscommand("allowscale", "false");

Для запуска Notepad на большинстве систем Windows можно использовать:

fscommand("exec", "C:/WINDOWS/NOTEPAD.EXE");

В следующем коде показана страница HTML с командами JavaScript и VBScript, необходимыми для ответа на простой вызов fscommand() в фильме. Обратите внимание, что функция VBScript просто вызывает функцию JavaScript - это позволяет работать как в Internet Explorer, так и в Netscape с помощью одной функции JavaScript:

<HTML>
<HEAD>
<TITLE>fscommand demo</TITLE>
<SCRIPT LANGUAGE="JavaScript">
<!--
function testmovie_DoFSCommand(command, args) {
  alert("Здесь данные из Flash: "+command+", "+args);
}
//-->
</SCRIPT>
<SCRIPT LANGUAGE="VBScript">
<!--
Sub testmovieFSCommand(ByVal command, ByVal args)
  call testmovie_DoFSCommand(command, args)
end sub
//-->
</SCRIPT>
</HEAD>
<BODY>
<OBJECT
  ID="testmovie"
  CLASSID="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
  WIDTH="100%"
  HEIGHT="100%"
  CODEBASE="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab">
<PARAM NAME="MOVIE" VALUE="flash-to-javascript.swf">
<EMBED
  NAME="testmovie"
  SRC="flash-to-javascript.swf"
  WIDTH="100%"
  HEIGHT="100%"
  swLiveConnect="true"
  PLUGINSPACE="http://www.macromedia.com/go/flashplayer/"
</EMBED>
</OBJECT>
</BODY>
</HTML>

Чтобы вызвать предшествующую функцию JavaScript testmovie_DoFSCommand() из фильма flash-to-javascript.swf, можно использовать:

fscommand("hello", "world");

[править] Совместимость:

Используется с 4-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/fscommand
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 18:09, 14 января 2007.
  • К этой странице обращались 109 раз.
1.23227214813


Справочник по Flash : ActionScript : Action : function - Создает новую функцию — Справочник Web-языков

Справочник по Flash : ActionScript : Action : function - Создает новую функцию

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | fscommand - Передача данных браузеру
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | function - Создает новую функцию
 |  |  |  |  |  |  |  | getURL - Переход на веб-страницу

[править] function

Определяет набор операторов, которые вы определили для выполнения определенной задачи. Вы можете декларировать (declare), или определить (define), функцию в том же месте, где вы ее вызываете, или в любом другом месте муви-клипа. При определении функции, вы можете также определить ее аргументы. Туда можно поместить при вызове некоторые значения, которыми оперирует функция при ее вызове. Каждый раз, когда заново вызывается функция, можно вызывать ее с другими аргументами.

[править] Синтаксис:

function functionname ([argument0, argument1,...argumentN]){
    statement(s)
}
function ([argument0, argument1,...argumentN]){
    statement(s)
}

[править] Аргументы:

functionname
Название новой функции.
argument
Строки, числа или объекты в количестве, большем, либо равным нулю, которые передаются функции.
statements
Ноль или более нуля операторов ActionScript, которые являются телом функции (function).

Используйте оператор return в теле функции statement(s), чтобы заставить функцию возвратить какое-либо значение.

Вариант использования номер раз: Определяем function с определенными functionname, arguments, и statement(s). Во время вызова имени функции, на самом деле вызывается описание этой функции с нужными параметрами. Разрешен вызов функции до того, как она определена в Action list, то есть функция может быть объявлена после того, как к ней обратились.

Вариант использования номер два: Создаем безыменную функцию и возвращаем ее. Такой вариант используется в выражениях, кроме того, он частично полезен при создании методов в объектах. Вариант 1) В следующем примере создается функция sqr, которая принимает один аргумент (число), возвращая его квадрат. Обратите внимание, что в этом скрипте объявление функции стоит после ее вызова.

y=sqr(3);
function sqr(x) {
    return x*x;
}

(Вариант 2) Следующий пример создает объект Окружность (Circle):

function Circle(radius) {
 this.radius = radius;
}

А здесь создается безымянная функция, которая считает площадь круга и присоединяет ее значение, как метод, объекту Окружность (Circle):

Circle.prototype.area = function () {
  return Math.PI * this.radius * this.radius
}

[править] Совместимость:

Используется с 5-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/function
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 18:53, 14 января 2007.
  • К этой странице обращались 76 раз.
1.25540184975


Справочник по Flash : ActionScript : Action : getURL - Переход на веб-страницу — Справочник Web-языков

Справочник по Flash : ActionScript : Action : getURL - Переход на веб-страницу

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | function - Создает новую функцию
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | getURL - Переход на веб-страницу
 |  |  |  |  |  |  |  | if - Выполнение или не выполнение предложений в зависимости от условий

[править] getURL

(Глобальная функция)

Загружает документ с указанного адреса (URL) в окно, или передает переменные другому приложению по URL (выполняет сценарии на стороне сервера), либо генерирует событие Macromedia Director.

[править] Синтаксис:

getURL(URL)
getURL(URL, window)
getURL(URL, window, method)

[править] Аргументы:

URL
Адрес (URL), задающий абсолютное или относительное местоположение документа, который нужно загрузить, или внешнего сценария, который нужно выполнить.
window
Необязательный аргумент, определяющий окно или фрейм (frame) в HTML, куда должен быть помещен документ. Укажите здесь имя окна/фрейма, либо укажите одно из зарезервированных слов:
  • _self - указывает на то же окно/тот же фрейм, откуда вызывается функция.
  • _blank - указывает на новое окно.
  • _parent - указывает на родительское по отношению к текущему окно.
  • _top - указывает на самый верхний фрейм в окне.
method
Необязательный аргумент, указывающий на метод, которым надо пересылать переменные. Если переменные передавать не надо, пропустите этот аргумент, иначе укажите, использовать метод GET или POST. GET добавляет имена переменных вместе со значениями в конец URL, и обычно используется для небольшого количества (и небольшого суммарного объема имен+значений) переменных. POST посылает переменные в отдельном заголовке HTTP и используется для передачи длинных строк или больших по объему данных.

[править] Описание:

Функция getURL() используется для того, чтобы:

  • Загрузить документ (обычно веб-страницы) в фрейм или окно браузера;
  • Выполнить сценарий на стороне сервера и получить результат во фрейм или окно браузера;
  • Выполнить код JavaScript в веб-браузере;
  • Генерировать событие из составляющих Flash, импортированных в Director как спрайты;

Чтобы загрузить документ в текущее окно или фрейм, просто укажите URL документа, не передавая аргументы window или method. Естественно, Flash поддерживает абсолютные URL (такие, в которых указаны протокол, например, "http:", а также имя сервера или аппаратного устройства) и относительные URL (те, которые заданы относительно текущего адреса):

// Абсолютный URL веб-страницы
getURL("http://spravkaweb.ru/");
// Абсолютный URL локального файла
getURL("file:///f:/www/example.html");
// Относительный URL, предполагается протокол http
getURL("/resource/resource.html");

Чтобы загрузить документ в окно или фрейм, имеющие имя, укажите это имя в качестве аргумента window:

// Загрузить в именованный фрейм
getURL("http://spravkaweb.ru/", "myFrame");
// Загрузить в именованное окно
getURL("http://spravkaweb.ru/", "myWindow");

Чтобы заменить набор фреймов, в котором содержится текущий фильм, дайте аргументу window заначение "_parent":

getURL("http://spravkaweb.ru/", "_parent");

Чтобы заменить загружаемым документом все наборы фреймов на странице, дайте аргументу window значение "_top":

getURL("http://spravkaweb.ru/", "_top");

Чтобы открыть загружаемый документ в новом анонимном окне браузера, дайте аргументу window значение "_blank":

getURL("http://spravkaweb.ru/", "_blank");

Нужно отметить, что открытие нового окна с помощью "_blank" лишает нас всякого контроля над внешним видом нового окна (размером, конфигурацией панелей управления, местонахождением и т.д.). Чтобы открывать настраиваемые окна с помощью getURL(), нужно вызвать на содержащей фильм странице функцию JavaScript.

С помощью функции getURL() можно также посылать переменные удаленным приложениям или сценариям на сервере. Чтобы передать переменные текущей временной диаграммы во внешний сценарий, нужно указать имя сценария в качестве аргумента URL и задать "GET" или "POST" в качестве значения аргумента method:

getURL("http://spravkaweb.ru/php.php", "_blank", "GET");

При вызове в качестве метода клипа getURL() посылает переменные временной диаграммы этого клипа:

// Передает переменные myClip в example.php
myClip.getURL("http://spravkaweb.ru/example.php", "_blank", "GET");

Результаты выполнения сценария появятся в окне или фрейме, указанных в аргументе window (который необходимо задавать при передаче переменных).

Чтобы загрузить результаты выполнения сценария в текущие фрейм или окно, нужно задать в качестве аргумента window значение "_self":

getURL("http://spravkaweb.ru/", "_self", "GET");

Если значением аргумента method является "GET", переменные временной диаграммы текущего клипа посылаются в виде строки запроса, присоединенной к URL сценария в запросе HTTP GET. Строки запросов состоят из пар имя/значение, разделяемых амперандами (&):

getURL("http://www.mysite.ru/example.php?ss=2&pl=34", "_self");

Если аргумент method содержит "POST", переменные временной диаграммы текущего клипа посылаются сценарию в виде отдельного блока данных после заголовка запроса HTTP POST (так же, как в обычной форме HTML, использующей метод POST). Обратите внимание, что "POST" недоступен в автономном Flash Player.

Поскольку для большинства веб-серверов максимальная допустимая длина URL лежит между 255 и 1024 символами, при передаче больших объемов данных используйте "POST", а не "GET".

Надо отметить, что любые данные, возвращаемые сценарием, который вызван getURL(), выводятся как обычное веб-содержание в браузере, а не во Flash. Чтобы получить результаты выполнения сценария во Flash, используйте loadVariables().

Функция getURL() может применяться и с другими протоколами помимо "http:".

Протоколы, поддерживаемые getURL

Протокол | Формат | Назначение
event | "event:eventName params" | Послать событие в Director, если принадлежность Flash является спрайтом Director.
file | "file:///driveSpec/forder/filename" | Обратиться к локальному файлу.
ftp | "ftp://server.domain.ru/forder/filename" | Обратиться к удаленному файлу по FTP (протокол передачи файлов).
http | "http://server.domain.ru/forder/filename" | Обратиться к удаленному файлу по HTTP (протокол передачи гипертекста).
javascript | "javascript: command" | Выполнить в браузере команду JavaScript.
lingo | "lingo: comand" | Выполнить команду Lingo, если принадлежность Flash является спрайтом Director.
print | "print:", "targetClip" | Вывод во Flash 4, до появления функции print() во Flash 5.
vbscript | "vbscript: command" | Выполнить в браузере команду VBScript.

Как показывает вышеприведенная таблица, если принадлежность Flash импортируется в файл Macromedia Director, с помощью getURL() можно генерировать события Lingo или выполнять команды Lingo. (Lingo - это язык сценариев в Director, аналогичный ActionScript).

Например, можно добавить событие кадра такого вида:

getURL("event: eventName params");

что приведет к вызову в Director обработчика события Lingo с именем on eventName. Вот команда getURL(), генерирующая событие с именем "myEvent" и передающая ему строку "A". Обратите внимание на преобразование символа с помощью:

// Отправить событие в Director
getURL("event: myEvent "A"");

Вот обработчик события Lingo sprite, который должен быть прикреплен к спрайту Flash в Director, чтобы получить событие. Заметим, что спрайт в Director примерно соответствует экземпляру клипа во Flash; ключевое слово Lingo put родственно команде ActionScript trace(), а && в Lingo является оператором конкатенации строк:

on myEvent msg
    put "The message received from Flash was " && msg
end

Можно также спровоцировать запуск Lingo из спрайта Flash в Director с помощью ключевого слова "lingo:":

// Пусть Director даст звуковой сигнал
getURL("lingo: beep");

Наконец, с помощью getURL() можно выполнять код JavaScript. Вызовем простую функцию alter JavaScript с помощью getURL():

getURL("javascript: alter("Hello world");");

[править] Примеры:

Далее приведен стандартный код кнопки со ссылкой на веб-страницу:

on(release) {
    getURL("http://www.spravkaweb.ru/");
}

[править] Совместимость:

Используется со 2-ей версии Flash. В 4-ой версии усилена добавлением параметра method.

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/geturl
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:53, 15 января 2007.
  • К этой странице обращались 94 раза.
1.26395797729


Справочник по Flash : ActionScript : Action : if - Выполнение или не выполнение предложений в зависимости от условий — Справочник Web-языков

Справочник по Flash : ActionScript : Action : if - Выполнение или не выполнение предложений в зависимости от условий

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | getURL - Переход на веб-страницу
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | if - Выполнение или не выполнение предложений в зависимости от условий
 |  |  |  |  |  |  |  | ifFrameLoaded - Выполняет код если загруженн определенный кадр

[править] if

Позволяет выполнить или не выполняет определенные предложения в зависимости от заданного условия

[править] Синтаксис:

if (condition) {
    statements
}

[править] Аргументы:

condition
Условие, которое должно быть выполнено для того, чтобы выполнились предложения statements.
statement
одно или больше предложений ActionScript, которые должны заканчиваться точкой с запятой.

В целом, предложение if завершается закрывающей фигурной скобкой (}) без замыкающей точки с запятой.

Условие condition предложения if может быть любым допустимым выражением. При выполнении предложения if, интерпретатор проверяет значение этого выражения (которое еще называется проверочным выражением).

Если оно равно true, то выполняется statements. В противном случае statements не выполняются.

[править] Примеры:

Пример: Операция сравнения возвращает булево значение.

// Положение мыши по горизонтали
var varX = _xmouse;

// Если varX > 300 дает true
if (varX > 300) {
  // выполняется предложение
  trace("Мышь находится за отметкой 300 пикселов");
}

Надо заметить, что проверочное выражение условного предложения не обязательно должно давать в результате булево значение - годится любое выражение.

Пример: Проверочное выражение - число или строка.

if ("hi") {
  trace("Условие выполнено!");
}
if (4) {
  trace("Условие выполнено!");
}

Когда проверочное выражение условного предложения не является булевым, интерпретатор преобразует его в булево. Например, интерпретатор преобразует "hi" в false, потому что все нечисловые строки при использовании в булевом контексте принимают значение false. Поэтому условие не выполнено, и первое предложение trace() тоже не выполняется.

Аналогично, интерпретатор преобразует число 4 в true (любое ненулевое число преобразуется в true), поэтому второе предложение trace() выполняется.

Пример: Применение оператора ИЛИ.

lastName = "";
firstName = "";
if (firstName != "" || lastName != "") {
  trace("Welcome " + firstName + " " + lastName);
}

Пример: Проверка существования клипа.

if (myClip) {
  myClip._x = 0; // Если myClip существует, поместить его
}                // на левый край рабочего стола

[править] Совместимость:

Используется с 4-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/if
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:00, 15 января 2007.
  • К этой странице обращались 58 раз.
1.48478198051


Справочник по Flash : ActionScript : Action : ifFrameLoaded - Выполняет код если загруженн определенный кадр — Справочник Web-языков

Справочник по Flash : ActionScript : Action : ifFrameLoaded - Выполняет код если загруженн определенный кадр

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | if - Выполнение или не выполнение предложений в зависимости от условий
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | ifFrameLoaded - Выполняет код если загруженн определенный кадр
 |  |  |  |  |  |  |  | include - Импорт текста из внешнего файла ActionScript

[править] ifFrameLoaded

(Предложение)

Выполняет некоторый код, если загружен определенный кадр

[править] Синтаксис:

ifFrameLoaded(scene, frame) {
    statement;
}
ifFrameLoaded(frame) {
    statement;
}

[править] Аргументы:

scene
Опрашиваемая сцена.
frame
Номер кадра или строка, указывающая метку кадра. Если кадр, заданный frame, загружен в Player, выполняются предложения statement. Если нет, блок предложений пропускается.

[править] Описание:

Проверяет, доступно ли содержимое указанного кадра локально (скачано ли уже?). Используйте для создания прелоадера, то есть небольшой анимации, пока загружается остальная часть фильма. Разница между использованием _framesloaded и ifFrameLoaded() в том, что _framesloaded позволяет добавить if, или else, в то время, как ifFrameLoaded() позволяет указать количество кадров в одном простом выражении.

Начиная с Flash 4 следует использовать свойства _totalframes и _framesloaded с предложениями if-else для создания более гибкого предварительного загрузчика.

[править] Пример:

if (_totalframes > 0 && _framesloaded == _totalframes) {
    gotoAndPlay("beginFrame");
} else {
    gotoAndPlay(_currentframe - 1);
}

[править] Совместимость:

Используется с 3-ей версии Flash. Действие ifFrameLoaded устарело в Flash 5; используйте вместо него _framesloaded

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/ifframeloaded
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:02, 15 января 2007.
  • К этой странице обращались 52 раза.
1.4099187851


Справочник по Flash : ActionScript : Action : include - Импорт текста из внешнего файла ActionScript — Справочник Web-языков

Справочник по Flash : ActionScript : Action : include - Импорт текста из внешнего файла ActionScript

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | ifFrameLoaded - Выполняет код если загруженн определенный кадр
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | include - Импорт текста из внешнего файла ActionScript
 |  |  |  |  |  |  |  | loadMovie - Загрузить файл .swf

[править] include

Включает содержимое файла, во время того, как клип тестируется, публикуется или экспортируется.

[править] Синтаксис:

#include path

[править] Аргументы:

path
Строка, задающая имя и местонахождение импортируемого файла сценария, которое можно задать относительно файла .fla или как абсолютный путь. Стоит обратить внимание, что в пути должна использоваться прямая, а не обратная косая черта. Файлы сценариев должны иметь расширение .as

Директива #include загружает в текущий сценарий текст сценария из внешнего текстового файла (предпочтительно с расширением .as), помещая его прямо в то место, где находится команда #include.

Операция #include осуществляется на этапе компиляции, и это означает, что включаемый в фильм текст существовал во время тестирования, экспорта или публикации из среды разработки. Изменения, произведенные во внешнем файле после экспорта фильма, не будут отражены в фильме. Чтобы добавить эти изменения в фильм, его нужно повторно экспортировать.

Директива #include используется для включения одного и того же блока кода в несколько сценариев или в разные проекты Flash (подобно тому, как используется внешняя библиотека принадлежностей Flash). Это следует делать для централизации кода, сопровождения кода в системе контроля версий (например, CVS или Microsoft Visual Source Safe), либо при использовании внешнего текстового редактора, который предпочтительней редактора ActionScript.

Это удобно и тогда, когда программист работает отдельно от, скажем, разработчика графических анимаций Flash. Внешние файлы удобны при использовании хранилищ кода, например, библиотек функций, независимых от текущей временной диаграммы или клипа. Менее полезными она оказываются в коде, который требует тесной интеграции с файлом Flash.

Следует заметить, что директива #include начинается с символа # и не должна заканчиваться точкой с запятой. Любое предложение #include, завершающееся точкой с запятой, вызовет ошибку и не выполнит импорта внешнего сценария. Если файла по указанному пути нет, директива вызовет ошибку, и внешний файл не будет включен.

При выполнении синтаксической проверки по команде Check Syntax (Ctrl-T или Command-T) меню панели Actions (которое находится под кнопкой со стрелкой в правом верхнем углу панели) текст во внешнем файле тоже проверяется.

[править] Примеры:

Следующий код импортирует внешний файл .as с именем myScript.as в текущий файл .fla. При использовании относительного пути myScript.as должен быть в той же папке, что и файл .fla, содержащий директиву включения:

#include "myScript.as"

Можно построить относительный путь, содержащий подкаталог. В следующем коде предполагается, что mySqcript.as находится на один уровень ниже текущего файла .fla в подкаталоге с именем includes:

#include "includes/myScript.as"

Для обозначения папки над текущей используются две точки. В следующем примере предполагается, что myScript.as находится на один уровень выше текущего файла .fla:

#include "../myScript.as"

В следующем коде предполагается, что myScript.as находится в каталоге includes, на том же уровне, что и подкаталог, содержащий текущий файл .fla:

#include "../includes/myScript.as"

Можно задавать и абсолютный путь к любой папке, например:

#include "C:/WINDOWS/Desktop/myScript.as"

[править] Совместимость:

Используется с 5-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/include
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:22, 15 января 2007.
  • К этой странице обращались 60 раз.
2.00336289406


Справочник по Flash : ActionScript : Action : loadMovie - Загрузить файл .swf — Справочник Web-языков

Справочник по Flash : ActionScript : Action : loadMovie - Загрузить файл .swf

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | include - Импорт текста из внешнего файла ActionScript
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | loadMovie - Загрузить файл .swf
 |  |  |  |  |  |  |  | loadMovieNum - Загрузить файл .swf

[править] loadMovie

(Глобальная функция)

Позволяет загрузить в проигрыватель файл .swf.

[править] Синтаксис:

loadMovie(URL, target)
loadMovie(URL, target, method)

[править] Аргументы:

URL
Строка, задающая абсолютный или относительный путь к загружаемому файлу .swf. Во всех URL должна использоваться прямая косая черта, а абсолютные URL должны содержать ссылку на протокол в виде http:// или file:///.
target
Строка, задающая клип или уровень документа, в которых расположится внешний файл .swf. Может также являться ссылкой на существующий клип или уровень документа (ссылки преобразуются на пути при использовании в строковом контексте).
method
Необязательная строка, задающая метод отправки переменных внешнему сценарию. Значениями method могут быть "GET" или "POST". Этот параметр должен быть литералом, а не переменной или другим выражением. Автономная версия Flash Player всегда использует метод "GET" вне зависимости от заданного в method

[править] Описание:

Функция loadMovie() импортирует во Flash Player файл .swf, размещенный по адресу URL.

Если target является ссылкой на существующий клип или строкой, задающей путь к клипу, загруженный файл .swf будет помещен в указанный клип (вызывая удаление предшествующего содержимого). Чтобы загрузить фильм в текущий клип, используйте в качестве параметра target пустую строку:

loadMovie("myMovie.swf", "")

Если target является ссылкой на существующий уровень документа (например, _level2) или строкой, указывающей путь к уровню документа (например, "_level2"), то файл .swf помещается на указанный уровень документа. Загрузка фильма на уровень _level0 очищает проигрыватель от всего содержимого и помещает новый файл .swf на уровень _level0.

Можно посылать переменные вместе с вызовом loadMovie(), и тогда URL обычно является адресом сценария, возвращающего файл .swf, соответствующий переданным переменным. Чтобы отправить переменные при вызове loadMovie(), включается аргумент method (заданный в "GET" или "POST"). "GET" посылает переменные временной диаграммы текущего клипа в виде строки запроса, присоединенный к URL сценария. "POST" посылает переменные временной диаграммы текущего клипа после заголовка HTTP для запроса POST. Метод "POST" недоступен в автономном Flash Player. Поскольку у большинства веб-серверов длина URL ограничена величиной от 255 до 1024 символов, для передачи больших объемов данных используйте "POST", а не "GET".

Вызовы loadMovie() над веб-сервером, использующие метод "GET", могут передавать переменные в загруженный фильм без вмешательства сценария.

Например, загрузим внешний фильм myMovie.swf на уровень 1 стека документов проигрывателя, передав ему переменные текущей временной диаграммы:

loadMovie("myMovie.swf", "_level1", "GET");

Переменные, передаваемые в загружаемый фильм, определяются на главной временной диаграмме этого фильма. Этот прием действует только при обработке запроса loadMovie() веб-сервером. Попытки использовать метод "GET" в loadMovie() для локальных файлов вызывают ошибку.

[править] Некоторые особенности:

Будьте осторожны при использовании ссылок на клипы и уровни в качестве аргумента target функции loadMovie(). Если аргумент target дает значение undefined, то функция loadMovie() использует в качестве target текущую временную диаграмму.

Аналогично, ссылки target, дающие пустую строку, заставляют loadMovie() действовать над текущей временной диаграммой. В частности, этим вызываются проблемы при загрузке фильмов на новые незанятые уровни.

Рассмотрим следующий код:

loadMovie("myMovie.swf", _level1);

Если до выполнения этого предложения объект _level1 не существовал, то этот код загрузит файл myMovie.swf во временную диаграмму, содержавшую предложение loadMovie(), а не на _level1! Чтобы избежать этой проблемы, вместо loadMovie() можно использовать loadMovieNum(). Кроме того, можно указать строку в качестве параметра target для loadMovie():

loadMovie("myMovie.swf", "_level1");

В этом случае уровень будет создан, если его еще не существует ( только _level0 существует по умолчанию во всех фильмах).

[править] Пример:

// Поместить myMovie.swf на level 1
loadMovie("myMovie.swf", "_level1");
// Поместить myMovie.swf на level 0
loadMovie("myMovie.swf", "_level0");
// Поместить myMovie.swf в myClip
loadMovie("myMovie.swf", "myClip");
// Заменить содержимое проигрывателя на
// coolmovie.swf, использую абсолютный путь
loadMovie("http://www.yousite.ru/coolmovie.swf", "_level0");
// Загрузить фильм на уровень 1 с рабочего стола Windows.
loadMovie("file:///C:/WINDOWS/Desktop/myMovie.swf", "_level1");

[править] Совместимость:

Используется с 4-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/loadmovie
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 15:05, 16 января 2007.
  • К этой странице обращались 77 раз.
1.27202582359


Справочник по Flash : ActionScript : Action : loadMovieNum - Загрузить файл .swf — Справочник Web-языков

Справочник по Flash : ActionScript : Action : loadMovieNum - Загрузить файл .swf

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | loadMovie - Загрузить файл .swf
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | loadMovieNum - Загрузить файл .swf
 |  |  |  |  |  |  |  | loadVariables - Загружает в клип или фильм внешние переменные

[править] loadMovieNum

(Глобальная функция)

Позволяет загрузить в проигрыватель файл .swf

[править] Синтаксис:

loadMovieNum(URL, level)
loadMovieNum(URL, level, method)

[править] Аргументы:

URL
Строка, задающая абсолютный или относительный путь к загружаемому файлу .swf. Во всех URL должна использоваться прямая косая черта, а абсолютные URL должны содержать ссылку на протокол в виде http:// или file:///.
level
Неотрицательное целое или выражение, возвращающее неотрицательное целое число, задающее уровень документа, на котором будет размещен внешний файл .swf.
method
Необязательная строка, задающая метод отправки переменных внешнему сценарию. Значениями method могут быть "GET" или "POST". Этот параметр должен быть литералом, а не переменной или другим выражением. Автономная версия Flash Player всегда использует метод "GET" вне зависимости от заданного в method

[править] Описание:

Функция loadMovieNum() почти идентична loadMovie(), но требует задания целевого уровня загрузки в виде числа, а не строки. Это означает, что loadMovieNum() может загружать фильмы только на уровни документов, а не в клипы. Если указанного уровня не существует, он будет создан. Если указанный уровень существует, его содержимое будет заменено новым файлом .swf. Допускается загрузка фильма на _level2, даже если _level1 не создан.

Функцию loadMovieNum() можно использовать, когда нужно динамически задавать уровень для загрузки фильма, например:

var x = 3;
loadMovieNum("muMovie.swf", x);

Того же самого можно достичь путем конкатенации строк и использования обычной функции loadMovie():

loadMovie("muMovie.swf", "_level" + x);

[править] Совместимость:

Используется с 3-ей версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/loadmovienum
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 15:07, 16 января 2007.
  • К этой странице обращались 57 раз.
1.29589700699


Справочник по Flash : ActionScript : Action : loadVariables - Загружает в клип или фильм внешние переменные — Справочник Web-языков

Справочник по Flash : ActionScript : Action : loadVariables - Загружает в клип или фильм внешние переменные

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | loadMovieNum - Загрузить файл .swf
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | loadVariables - Загружает в клип или фильм внешние переменные
 |  |  |  |  |  |  |  | loadVariablesNum - Прикрепляет группу внешних переменных к уровню документа

[править] loadVariables

(Глобальная функция)

Загружает в клип или фильм внешние переменные

[править] Синтаксис:

loadVariables (url, target);
loadVariables (url, target, method);

[править] Аргументы:

url
Абсолютный или относительный адрес источника переменных - сценария на стороне сервера, который возвращает переменные, или текстового файла, содержащего переменные. При подгрузке в сети, файл должен находиться в том же поддомене, что и исходный клип.
target
Строка, указывающая уровень, или имя муви-клипа, куда необходимо заслать полученные переменные. Первый (базовый) клип находится на нулевом уровне (level 0), подгруженные клипы могут находится на уровнях с другими номерами.
method
Необязательный аргумент, указывающий метод передачи переменных внешнему сценарию. Если он задан, то переменные текущей временной диаграммы передаются сценарию, а target получает загруженные переменные. Если этот аргумент опущен, то переменные загружаются, но не отправляются. Допустимыми значениями для method являются "GET" и "POST". Этот параметр должен быть литералом, а не переменным или другим выражением.

Обычно переменные внутри фильмов определяются при помощи ActionScript. Однако посредством loadVariables() можно также импортировать в клип переменные из текстового файла или выполняемого на сервере приложения - например, сценария PHP. Областью видимости для переменных, загружаемых через loadVariables(), является клип или уровень, указанные в target, а типом данных всегда является string. Для прикрепления загруженных переменных к текущей временной диаграмме нужно использовать в качестве значения аргумента target пустую строку.

[править] Примеры:

Пример: Прикрепление переменных к текущей временной диаграмме.

loadariables("myVars.txt", "");
// Загружаем переменные из myVars.txt
// в текущую временную диаграмму

Вне зависимости от того, будут ли загружаемые переменные находиться в текстовом файле, или из создает сценарий, они должны иметь формат, соответствующий кодировке URL:

  • Имя каждой переменной должно отделяться от ее значения знаком равенства, без пробелов: firstName=Jon.
  • Пары имен/значений должны разделяться амперсандами (&): firstName=Jon&lastName=Smit.
  • Пробелы должны быть заменены знаками плюс (+).
  • Любой символ, не являющийся пробелом, цифрой (1-9) или латинской буквой (a-z, A-Z), должен быть заменен шестнадцатеричной escape-последовательностью вида %xx, где xx является кодовой позицией символа в Latin 1 в шестнадцатеричном виде.

Следующий пример покажет содержимое текстового файла, импортируемого во Flash посредством loadVariables().

Пример: Импортирование из файла переменных name и address.

name=Jon&address=65+malkom+st%21
// name присваивается значение "Jon"
// address присваивается значение "65 malkom st!"

Текстовой файл, который используется в loadVariables(), является обычным текстовым файлом, содержащим переменные в кодировке URL, как показано выше. Для загрузки переменных из внешнего текстового файла путь к файлу указывается как аргумент URL в вызове функции loadVariables().

Пример: Загрузка переменных в главную временную диаграмму.

// Загрузить переменные из myVar.txt
// в главную временную диаграмму фильма
loadVariables("myVar.txt", "_root");

loadVariables() также можно использовать со сценарием или приложением сервера, выводящим переменные в кодировке URL. Когда сценарий посылает переменные в фильм Flash в ответ на вызов функции loadVariables(), он должен задать MIME-тип данных как "application/x-www-urlform-encoded".

На равне с приемом переменных, функция loadVariables() также может передавать переменные в сценарий на стороне сервера. Чтобы отправить в сценарий все переменные, определенные в текущей временной диаграмме, аргумент method при вызове функции loadVariables() задается равным "GET" или "POST". Переменные пересылаются в формате кодировки URL.

Если method задан как "GET", переменные передаются как строка запроса в URL сценария.

Если method установлен как "POST", переменные посылаются после заголовка HTTP POST.

Т.к. для большинства веб-серверов максимальная длина URL лежит между 255 и 1024 символами, при передаче больших объемов данных используйте "POST", а не "GET".

Из соображений безопасности loadVariables() действует только с хостами домена, из которого был загружен фильм. Правила, которым подчиняется loadVariables(), перечислены в следующей таблице.

Исходный домен фильма | Как подключиться | Разрешено?
www.domainname.ru | www.domainname.ru | Да
www.domainname.ru | othe.domainname.ru | Да
www.domainname.ru | www.domainname-else.ru | Нет
www.domainname.ru | domainname.ru | Да
domainname.ru | www.domainname.ru | Да

Эти меры безопасности оказывают воздействие только на подключаемые модули и на элементы ActiveX браузера Flash Player; автономный проигрыватель может загружать переменные из любого домена.

Ограничения на домены являются умышленной защитной функцией во Flash, но их можно обойти с помощью прокси-сценария, выполняемого на сайте X, действующего как посредник между Flash и сайтом Y, или псевдонима DNS на сайте X, который указывает на сайт Y. Дополнительную информацию по данному вопросу можно получить по адресу: http://www.macromedia.com/support/flash/ts/documents/loadvars_security.htm.

Результаты многократных обращений loadVariables() по одному и тому же URL сценария могут некоторыми браузерами кэшироваться, в результате чего новые данные с сервера не загружаются. Чтобы избежать этой проблемы, добавляйте в каждый вызов loadVariables() фиктивную переменную, чтобы URL оказался уникальным.

Пример: Генерация уникального URL.

loadVariables("http://www.mysite.ru/myScript.php?var="
   + getTimer(), serverResponse);

Использование обработчика события data с функцией loadVariables().

Если у сервера запрашивается ряд переменных с помощью функции loadVariables(), необходимо дождаться их полной загрузки, прежде чем использовать содержащиеся в них данные.

Когда клип получает всю группу загружаемых переменных, генерируется событие data, которое указывает, что можно выполнять код, зависящий от этих переменных.

Допустим, например, что имеется фильм гостевой книги, в которую пользователи вводят свои комментарии, а эти комментарии сохраняются на сервере. Если пользователь хочет просмотреть комментарий, тот запрашивается с сервера с помощью loadVariables(). Но прежде чем начать вывод комментария, необходимо сделать остановку на экране загрузки, пока не станет известно, что запрошенные данные доступны. Обработчик события data извещает о том, что данные загружены, после чего можно вывести комментарий пользователю.

В нижеприведенном примере приведен отрывок кода гостевой книги, показывающий использование обработчика события data с функцией loadVariables(). В этом примере есть кнопка, с помощью которой две переменные в кодировке URL загружаются из текстового файла в клип. В клипе имеется обработчик события data, который выполняется, когда эти две переменные загружены. Обработчик отображает значения этих двух переменных. Безопасность вывода этих двух переменных гарантируется тем, что код обработчика выполняется только при генерации события data (т.е. после получения данных).

Пример: Ожидание события data.

// Содержимое файла guest.txt
name=Jon&message=hello

// Кнопка внутри клипа
on (release) {
  this.loadVariables("guest.txt");
}

// Обработчик в клипе
onClipEvent (data) {
  trace(name);
  trace(message);
}

[править] Ошибки в реализации:

Метод POST не поддерживается в Internet Explorer 4.5 для Macintosh. Эта проблема была исправлена в версии 5 браузера.

[править] Совместимость:

Используется с 4-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/loadvariables
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 06:41, 20 марта 2007.
  • К этой странице обращались 97 раз.
1.58198285103


Справочник по Flash : ActionScript : Action : loadVariablesNum - Прикрепляет группу внешних переменных к уровню документа — Справочник Web-языков

Справочник по Flash : ActionScript : Action : loadVariablesNum - Прикрепляет группу внешних переменных к уровню документа

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | loadVariables - Загружает в клип или фильм внешние переменные
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | loadVariablesNum - Прикрепляет группу внешних переменных к уровню документа
 |  |  |  |  |  |  |  | print - Вывод на печать кадров фильма или клипа с использованием векторной графики

[править] loadVariablesNum

(Глобальная функция)

Прикрепляет группу внешних переменных к уровню документа

[править] Синтаксис:

loadVariablesNum (url, level);
loadVariablesNum (url, level, method);

[править] Аргументы:

url
Абсолютный или относительный адрес источника переменных - сценария на стороне сервера, который возвращает переменные, или текстового файла, содержащего переменные. При подгрузке в сети, файл должен находиться в том же поддомене, что и исходный клип.
level
Неотрицательное целое число или выражение, возвращающее неотрицательное целое число. Задает уровень документа, на котором будут определены загруженные переменные.
method
Необязательный аргумент, указывающий метод передачи переменных внешнему сценарию. Если он задан, то переменные текущей временной диаграммы передаются сценарию, а target получает загруженные переменные. Если этот аргумент опущен, то переменные загружаются, но не отправляются. Допустимыми значениями для method являются "GET" и "POST". Этот параметр должен быть литералом, а не переменным или другим выражением.

Функция loadVariablesNum() почти идентична loadVariables(), но требует задания целевого level как числа, а не как строки. Это значит, что loadVariablesNum() может прикреплять переменные только к уровням документов, а не к клипам. Целевой уровень можно задавать динамически.

[править] Примеры

Пример: Задание целевого уровня динамически.

var myLevel = 3;
loadVariablesNum("Vars.txt", myLevel);

Того же самого эффекта можно добиться путем конкатенации строк и использования обычной функции loadVariables().

loadVariables("Vars.txt", "_level" + myLevel);

[править] Совместимость:

Используется с 5-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/loadvariablesnum
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:04, 16 января 2007.
  • К этой странице обращались 67 раз.
1.33782887459


Справочник по Flash : ActionScript : Action : print - Вывод на печать кадров фильма или клипа с использованием векторной графики — Справочник Web-языков

Справочник по Flash : ActionScript : Action : print - Вывод на печать кадров фильма или клипа с использованием векторной графики

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | loadVariablesNum - Прикрепляет группу внешних переменных к уровню документа
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | print - Вывод на печать кадров фильма или клипа с использованием векторной графики
 |  |  |  |  |  |  |  | printNum - Печать кадров уровня документа как векторных изображений

[править] print

(Глобальная функция)

Вывод на печать кадров фильма или клипа с использованием векторной графики

[править] Синтаксис:

print(target, boundingBox)

[править] Аргументы:

target
Строка или ссылка, указывающая путь к клипу фильма или уровню документа, которые должны быть напечатаны (ссылки преобразуются в пути при использовании в строковом контексте).
boundingBox
Строка, указывающая способ обрезания кадров target при выводе на печать. Обрезание определяется ограничивающей рамкой, которая представляет всю печатную страницу. Область target, включаемую в печатаемую страницу, можно задать с помощью одного из трех допустимых для boundingBox значений (которое должно быть задано как строковой литерал):
  • "bframe" - Рамка границ для каждого печатаемого кадра устанавливается индивидуально, чтобы соответствовать размеру содержимого каждого кадра. Поэтому содержимое каждого печатаемого кадра масштабируется, чтобы заполнить всю печатную страницу.
  • "bmax" - Области, занимаемые содержимым всех печатаемых кадров, объединяются, чтобы образовать общую рамку границ. Содержимое каждого печатаемого кадра масштабируется и располагается на печатной странице относительно общей рамки границ.
  • "bmovie" - Рамка границ для всех печатаемых кадров устанавливается по размеру одного выделенного кадра в клипе target. Содержимое печатаемых кадров обрезается по рамке границ этого выделенного кадра. Чтобы выделить кадр как рамку границ, ему присваивается метка #b.

Печать фильма Flash с помощью встроенной функции печати браузера происходит не единообразно и часто дает опечатки низкого качества. С помощью функции print() можно печатать содержимое фильма точно и с высоким качеством прямо из Flash. По умолчанию print() отправляет на печать все кадры с временной диаграммы target, по одному кадру на страницу, обрезая их в соответствии с аргументом boundingBox. Для печати избранных кадров им присваивается метка #P.

Функция print() посылает на PostScript-принтеры непосредственно векторную графику, а на принтеры без поддержки PostScript - графику, преобразованную в растровые изображения. Так как print() использует векторы, с ее помощью нельзя печатать фильм с преобразованиями прозрачности или цвета. Для печати фильмов с цветовыми эффектами используется функция printAsBitmap().

Во Flash r20 и выше возможности различных функций print() Flash 5 доступны в виде модифицированного действия getURL() Action. За подробностями обращайтесь к Macromedia Flash Printing SDK по адресу: http://www.macromedia.com/software/flash/open/webprinting/authoring.html

[править] Примеры:

Пример: Распечатка фильма.

// Напечатать все кадры главной временной диаграммы,
// задав размер каждого из них так, чтобы он занимал всю страницу
print("_root", "bframe");

// Напечатать все кадры главной временной диаграммы,
// изменив размер каждого соответственно общему размеру всех кадров
print("_root", "bmax");

При щелчке по кнопке со следующим кодом Flash выводит на печать все кадры на временной диаграмме кнопки, обрезанные по рамке границ кадра с меткой #b и с размером на всю страницу:

on (release) {
  print(this, "bmovie");
}

[править] Совместимость:

Используется с 5-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/print
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:56, 16 января 2007.
  • К этой странице обращались 70 раз.
1.11621499062


Справочник по Flash : ActionScript : Action : printAsBitmap - Вывод на печать кадров фильма или клипа с использованием растровой графики — Справочник Web-языков

Справочник по Flash : ActionScript : Action : printAsBitmap - Вывод на печать кадров фильма или клипа с использованием растровой графики

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | printNum - Печать кадров уровня документа как векторных изображений
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | printAsBitmap - Вывод на печать кадров фильма или клипа с использованием растровой графики
 |  |  |  |  |  |  |  | printAsBitmapNum - Печать кадров уровня документа как растровых изображений

[править] printAsBitmap

(Глобальная функция)

Вывод на печать кадров фильма или клипа с использованием растровой графики

[править] Синтаксис:

printAsBitmap(target, boundingBox)

[править] Аргументы:

target
Строка или ссылка, указывающая путь к клипу фильма или уровню документа, которые должны быть напечатаны (ссылки преобразуются в пути при использовании в строковом контексте).
boundingBox
Строка, указывающая способ обрезания кадров target при выводе на печать. Обрезание определяется ограничивающей рамкой, которая представляет всю печатную страницу. Область target, включаемую в печатаемую страницу, можно задать с помощью одного из трех допустимых для boundingBox значений (которое должно быть задано как строковой литерал):
  • "bframe" - Рамка границ для каждого печатаемого кадра устанавливается индивидуально, чтобы соответствовать размеру содержимого каждого кадра. Поэтому содержимое каждого печатаемого кадра масштабируется, чтобы заполнить всю печатную страницу.
  • "bmax" - Области, занимаемые содержимым всех печатаемых кадров, объединяются, чтобы образовать общую рамку границ. Содержимое каждого печатаемого кадра масштабируется и располагается на печатной странице относительно общей рамки границ.
  • "bmovie" - Рамка границ для всех печатаемых кадров устанавливается по размеру одного выделенного кадра в клипе target. Содержимое печатаемых кадров обрезается по рамке границ этого выделенного кадра. Чтобы выделить кадр как рамку границ, ему присваивается метка #b.

Функция printAsBitmap() по своему действию идентична print(), за исключением того, что выводит не векторы, а растрированное содержимое. В результате она может успешно печатать фильмы с преобразованием цвета, но дает результаты более низкого качества для векторной графики.

Во Flash r20 и выше возможности различных функций printAsBitmap() Flash 5 доступны в виде модифицированного действия getURL() Action. За подробностями обращайтесь к Macromedia Flash Printing SDK по адресу: http://www.macromedia.com/software/flash/open/webprinting/authoring.html

[править] Примеры:

Пример: Распечатка фильма.

// Напечатать все кадры главной временной диаграммы,
// задав размер каждого из них так, чтобы он занимал всю страницу
printAsBitmap("_root", "bframe");

// Напечатать все кадры главной временной диаграммы,
// изменив размер каждого соответственно общему размеру всех кадров
printAsBitmap("_root", "bmax");

При щелчке по кнопке со следующим кодом Flash выводит на печать все кадры на временной диаграмме кнопки, обрезанные по рамке границ кадра с меткой #b и с размером на всю страницу:

on (release) {
  printAsBitmap(this, "bmovie");
}

[править] Совместимость:

Используется с 5-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/printasbitmap
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 18:38, 16 января 2007.
  • К этой странице обращались 50 раз.
1.46426081657


Справочник по Flash : ActionScript : Action : printAsBitmapNum - Печать кадров уровня документа как растровых изображений — Справочник Web-языков

Справочник по Flash : ActionScript : Action : printAsBitmapNum - Печать кадров уровня документа как растровых изображений

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | printAsBitmap - Вывод на печать кадров фильма или клипа с использованием растровой графики
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | printAsBitmapNum - Печать кадров уровня документа как растровых изображений
 |  |  |  |  |  |  |  | removeMovieClip - Удалить клип фильма из Flash Player

[править] printAsBitmapNum

(Глобальная функция)

Печать кадров уровня документа как растровых изображений

[править] Синтаксис:

printAsBitmapNum(level, boundingBox)

[править] Аргументы:

level
Неотрицательное целое число или выражение, дающее неотрицательное целое число. Задает уровень документа, который должен быть напечатан.
boundingBox
Строка, указывающая способ обрезания кадров target при выводе на печать. Обрезание определяется ограничивающей рамкой, которая представляет всю печатную страницу. Область target, включаемую в печатаемую страницу, можно задать с помощью одного из трех допустимых для boundingBox значений (которое должно быть задано как строковой литерал):
  • "bframe" - Рамка границ для каждого печатаемого кадра устанавливается индивидуально, чтобы соответствовать размеру содержимого каждого кадра. Поэтому содержимое каждого печатаемого кадра масштабируется, чтобы заполнить всю печатную страницу.
  • "bmax" - Области, занимаемые содержимым всех печатаемых кадров, объединяются, чтобы образовать общую рамку границ. Содержимое каждого печатаемого кадра масштабируется и располагается на печатной странице относительно общей рамки границ.
  • "bmovie" - Рамка границ для всех печатаемых кадров устанавливается по размеру одного выделенного кадра в клипе target. Содержимое печатаемых кадров обрезается по рамке границ этого выделенного кадра. Чтобы выделить кадр как рамку границ, ему присваивается метка #b.

Функция printAsBitmapNum() почти идентична printAsBitmap(), но требует задания целевого уровня level для операции печати в виде числа, а не строки. Это означает, что printAsBitmapNum() может печатать только уровни документов, а не клипы фильмов. Обычно она используется, когда нужно динамически назначить выводимый на печать уровень фильма.

[править] Примеры:

Пример: Распечатка уровня фильма.

var x = 3;
printAsBitmapNum(x, "bmax");

Того же самого можно достичь с помощью конкатенации строк и использования обычной функции printAsBitmap():

printAsBitmap("_level" + x, "bmax");

[править] Совместимость:

Используется с 5-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/printasbitmapnum
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 18:47, 16 января 2007.
  • К этой странице обращались 53 раза.
1.22573280334


Справочник по Flash : ActionScript : Action : printNum - Печать кадров уровня документа как векторных изображений — Справочник Web-языков

Справочник по Flash : ActionScript : Action : printNum - Печать кадров уровня документа как векторных изображений

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | print - Вывод на печать кадров фильма или клипа с использованием векторной графики
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | printNum - Печать кадров уровня документа как векторных изображений
 |  |  |  |  |  |  |  | printAsBitmap - Вывод на печать кадров фильма или клипа с использованием растровой графики

[править] printNum

(Глобальная функция)

Печать кадров уровня документа как векторных изображений

[править] Синтаксис:

printNum(level, boundingBox)

[править] Аргументы:

level
Неотрицательное целое число или выражение, дающее неотрицательное целое число. Задает уровень документа, который должен быть напечатан.
boundingBox
Строка, указывающая способ обрезания кадров target при выводе на печать. Обрезание определяется ограничивающей рамкой, которая представляет всю печатную страницу. Область target, включаемую в печатаемую страницу, можно задать с помощью одного из трех допустимых для boundingBox значений (которое должно быть задано как строковой литерал):
  • "bframe" - Рамка границ для каждого печатаемого кадра устанавливается индивидуально, чтобы соответствовать размеру содержимого каждого кадра. Поэтому содержимое каждого печатаемого кадра масштабируется, чтобы заполнить всю печатную страницу.
  • "bmax" - Области, занимаемые содержимым всех печатаемых кадров, объединяются, чтобы образовать общую рамку границ. Содержимое каждого печатаемого кадра масштабируется и располагается на печатной странице относительно общей рамки границ.
  • "bmovie" - Рамка границ для всех печатаемых кадров устанавливается по размеру одного выделенного кадра в клипе target. Содержимое печатаемых кадров обрезается по рамке границ этого выделенного кадра. Чтобы выделить кадр как рамку границ, ему присваивается метка #b.

Функция printNum() почти идентична print(), но требует задания целевого уровня level для операции печати в виде числа, а не строки. Это означает, что printNum() может печатать только уровни документов, а не клипы фильмов. Обычно она используется, когда нужно динамически назначить выводимый на печать уровень фильма.

[править] Примеры:

Пример: Распечатка уровня фильма.

var x = 3;
printNum(x, "bmax");

Того же самого можно достичь с помощью конкатенации строк и использования обычной функции print():

print("_level" + x, "bmax");

[править] Совместимость:

Используется с 5-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/printnum
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:01, 16 января 2007.
  • К этой странице обращались 58 раз.
1.3043680191


Справочник по Flash : ActionScript : Action : removeMovieClip - Удалить клип фильма из Flash Player — Справочник Web-языков

Справочник по Flash : ActionScript : Action : removeMovieClip - Удалить клип фильма из Flash Player

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | printAsBitmapNum - Печать кадров уровня документа как растровых изображений
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | removeMovieClip - Удалить клип фильма из Flash Player
 |  |  |  |  |  |  |  | return - Выходит из функции или возвращает ее значение

[править] removeMovieClip

(Глобальная функция)

Удалить клип фильма из Flash Player.

[править] Синтаксис:

removeMovieClip(target);

[править] Аргументы:

target
Строка или ссылка, задающие путь к экземпляру клипа, который должен быть удален из проигрывателя (ссылки преобразуются в пути, если используются в строковом контексте).

Функция removeMovieClip() удаляет указанный клип фильма из проигрывателя, не оставляя следов содержимого или оболочки клипа. Последующие ссылки на клип или его переменные и свойства возвращают undefined.

Функцию removeMovieClip() можно использовать только с экземплярами клипов, созданными первоначально посредством duplicateMovieClip() или attachMovie(). На клипы фильмов, созданные в среде разработки, влияния не оказывает.

[править] Совместимость:

Используется с 4-ой версии Flash.

Усилена во Flash 5 возможностью применения к экземплярам, создаваемых с помощью attachMovie().

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/removemovieclip
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 19:00, 16 января 2007.
  • К этой странице обращались 58 раз.
1.69760799408


Справочник по Flash : ActionScript : Action : return - Выходит из функции или возвращает ее значение — Справочник Web-языков

Справочник по Flash : ActionScript : Action : return - Выходит из функции или возвращает ее значение

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | removeMovieClip - Удалить клип фильма из Flash Player
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | return - Выходит из функции или возвращает ее значение
 |  |  |  |  |  |  |  | setProperty - Присвоить значение свойству клипа фильма

[править] return

Выходит из функции или возвращает ее значение

[править] Синтаксис:

return;
return expression;

[править] Аргументы:

expression
Тип, строка, число, массив или объект, обрабатываемые функцией и возвращаемые, как ее значение. Это необязательный аргумент (опциональный).

[править] Описание:

При вызове функции можно передавать ей одно или более значений (параметров или аргументов), участвующих в выполнении. Аналогично, функция может передавать обратно возвращаемое значение (значение, получаемое в результате выполнения функции и пересылаемое обратно вызвавшему). Для завершения выполнения функции и, если нужно, возврата значения, в ее теле используется предложение return.

Когда интерпретатор во время выполнения функции сталкивается с предложением return, он пропускает все оставшиеся в функции предложения.

[править] Примеры:

Пример: Пропуск предложения после return.

function myFun(msg) {
  return;
  // Эта строка никогда не выполнится
  trace(msg);
}

Этот пример не реалистичен, потому что предложение return всегда вызывает завершение функции до того, как будет достигнуто предложение trace(). Поэтому предложение return обычно является последним предложением функции, если только оно не используется внутри условного предложения.

Пример: Выход при неверном пароле.

var correctPass = "spravkaweb&quor;;
function enterSite(pass) {
  if (pass != correctPass) {
    // Выйти, если пароль не верен
    return;
  }
  // Этот код достигается только при верном пароле
  gotoAndPlay("intro");
}

// Выход из функции будет досрочным
enterSite("cactus");
// Выход из функции будет естественным
enterSite("spravkaweb");

Как предполагается самим именем, return приказывает интерпретатору возвратиться в место вызова функции. Если предложение return отсутствует, ActionScript действует так, как если бы последняя строка функции содержала предложение return:

fuction myFun(msg) {
  trace(msg);
  // В таком контексте эта строка совершенно лишняя
  return;
}

Независимо от того, является предложение return подразумеваемым или явным, по окончании работы функции выполнение возобновляется со строчки кода, следующей за предложением вызова функции.

// Выполняем код функции myFun()
myFun("Hi!");
// По завершении функции myFun() выполнение возобновляется здесь
trace("World");

Как мы видели ранее, return всегда завершает функцию. Но его можно также использовать для возврата значений в сценарий, который вызвал функцию.

Пример: Определим функцию, складывающую три числа.

function sum(a, b, c) {
  return a + b + c;
}

// Вызовем функцию
var total = sum(5,6,2); // Возвратит 13

Выражение или результат, возвращаемое предложением return, называется возвращаемым значением функции.

Следует обратить внимание, что функция sum() просто вычисляет и возвращает сумму трех чисел. Она не совершает явного действия. Использовать возвращаемое функцией значение можно, присвоив его переменной.

var total = sum (1,2,3); // total = 11
var greet = sum ("Hello ", "world", "!"); // greet = "Hello world!"

Результатом вызова функции является обычное выражение. Поэтому его можно использовать в других выражениях.

[править] Совместимость:

Используется с 5-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/return
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 19:24, 16 января 2007.
  • К этой странице обращались 54 раза.
1.37249183655


Справочник по Flash : ActionScript : Action : setProperty - Присвоить значение свойству клипа фильма — Справочник Web-языков

Справочник по Flash : ActionScript : Action : setProperty - Присвоить значение свойству клипа фильма

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | return - Выходит из функции или возвращает ее значение
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | setProperty - Присвоить значение свойству клипа фильма
 |  |  |  |  |  |  |  | startDrag - Заставляет фильм или клип следовать за курсором мыши

[править] setProperty

Присвоить значение свойству клипа фильма

[править] Синтаксис:

setProperty(movieClip, property, value);

[править] Аргументы:

movieClip
Выражение, возвращающее строку, указывающую путь к клипу фильма. Во Flash 5 это может быть и ссылкой на клип фильма, поскольку ссылки на клипы преобразуются в пути при использовании в строковом контексте.
property
Имя встроенного свойства, которому должно быть присвоено value. Должно быть идентификатором, а не строкой (т.е. _alpha, а не "_alpha").
value
Новое значение данных, которое должно быть присвоено указанному свойству property клипа movieClip.

[править] Описание:

Функция setProperty() присваивает value одному из встроенных свойств movieClip. Ее нельзя использовать для установки свойств, определенных пользователем. Во Flash 4 setProperty() была единственным способом присвоения значений свойствам клипа; начиная с Flash 5 наиболее предпочтительными способами задания как встроенных, так и пользовательских свойств являются операторы и [].

[править] Примеры:

// Повернуть главный фильм на 45 градусов
setProperty("_root", _rotation, 45);

// То же самое, только без setProperty()
_root._rotation = 45;

При нажатии кнопки, следующий пример присваивает свойству _alpha мувиклипа star значение равное 30 процентам:

on(release) {
    setProperty("star", _alpha, 30);
}

[править] Совместимость:

Используется с 4-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/setproperty
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:10, 17 января 2007.
  • К этой странице обращались 55 раз.
1.32376384735


Справочник по Flash : ActionScript : Action : startDrag - Заставляет фильм или клип следовать за курсором мыши — Справочник Web-языков

Справочник по Flash : ActionScript : Action : startDrag - Заставляет фильм или клип следовать за курсором мыши

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | setProperty - Присвоить значение свойству клипа фильма
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | startDrag - Заставляет фильм или клип следовать за курсором мыши
 |  |  |  |  |  |  |  | Stop - Остановить воспроизведение фильма на текущем кадре

[править] startDrag

Заставляет фильм или клип следовать за курсором мыши

[править] Синтаксис:

startDrag(target);
startDrag(target, lockCenter);
startDrag(target, lockCenter, left, top, right, bottom);

[править] Аргументы:

target
Строка или ссылка, указывающие путь к фильму или экземпляру клипа, который должен следовать за курсором мыши (ссылки на клипы преобразуются в пути при использовании в строковом контексте).
lockCenter
Двоичное значение, определяющее, как перемещаемый мувиклип будет прикреплен к указателю мыши. true - по центру, false - точкой, в которой пользователь первый раз нажал по клипу. Этот аргумент необязателен.
left, top, right, bottom
Значения, указывающие на координаты родительского клипа и описывающие прямоугольник, в котором будет перемещаться мувиклип. Эти аргументы необязательны.

[править] Описание:

Функция startDrag() вызывает зрительное перемещение target за курсором мыши по проигрывателю (называемое также буксировкой (dragging) клипа). Перемещение буксируемого клипа можно ограничить рамкой, координаты которой передаются в качестве аргументов функции startDrag(). Координаты ограничивающей рамки задаются относительно холста, на котором расположен target. Если холстом является рабочий стол главного фильма, то точка (0,0) является левым верхним углом рабочего стола. Если холстом является клип фильма, то (0,0) обозначает точку регистрации холста клипа. Следует обратить внимание, что координатная система Flash переворачивает декартову ось Y: значения Y возрастают в направлении к нижней части экрана и убывают в направлении верхней части экрана. Отрицательные значения Y находятся выше начала координат (т.е. над осью X).

Буксировку можно прекратить в любой момент с помощью функции stopDrag(). В каждый конкретный момент можно буксировать только один клип или фильм, поэтому вызов функции startDrag() с новым target автоматически прекращает текущую операцию буксировки. При этом во время буксировки фильма или клипа вместе с ним перемещаются все содержащиеся в нем клипы.

[править] Примеры:

Перетаскивание клипа в замкнутом пространстве

on(press) {
    startDrag("ball", true, 0, 0, 200, 250);
}
on(release) {
    stopDrag();
}

[править] Совместимость:

Используется с 4-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/startdrag
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:17, 17 января 2007.
  • К этой странице обращались 58 раз.
1.38186192513


Справочник по Flash : ActionScript : Action : Stop - Остановить воспроизведение фильма на текущем кадре — Справочник Web-языков

Справочник по Flash : ActionScript : Action : Stop - Остановить воспроизведение фильма на текущем кадре

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | startDrag - Заставляет фильм или клип следовать за курсором мыши
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | Stop - Остановить воспроизведение фильма на текущем кадре
 |  |  |  |  |  |  |  | stopAllSounds - Выключить все звуки

[править] Stop

(Глобальная функция)

Производит остановку фильма на текущем кадре

[править] Синтаксис:

Stop()

[править] Описание:

Функция Stop() останавливает воспроизведение фильма или клипа. Это глобальный аналог метода MovieClip.stop(). Она часто используется для ожидания, когда пользователь, например, сделает выбор в графическом меню.

[править] Примеры:

on (release) {
    stop();
}

[править] Совместимость:

Используется с 3-ей версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/stop
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:15, 17 января 2007.
  • К этой странице обращались 59 раз.
1.24416589737


Справочник по Flash : ActionScript : Action : stopAllSounds - Выключить все звуки — Справочник Web-языков

Справочник по Flash : ActionScript : Action : stopAllSounds - Выключить все звуки

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Stop - Остановить воспроизведение фильма на текущем кадре
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | stopAllSounds - Выключить все звуки
 |  |  |  |  |  |  |  | stopDrag - Останавливает текущую операцию перетаскивания

[править] stopAllSounds

(Глобальная функция)

Производит выключение всех звуков в фильме

[править] Синтаксис:

stopAllSounds()

[править] Описание:

Функция stopAllSounds() заглушает все звуки, воспроизводящиеся в данный момент в фильме, независимо от глубины вложенности в клипы. Она применяется ко всем звукам фильма, в том числе к программно генерируемым объектам Sound. Более точно управлять остановкой, запуском и громкостью звука можно с помощью класса Sound. Стоит отметить, что функция stopAllSounds() оказывает только временное воздействие. Любой звук, который начинается после вызова stopAllSounds(), будет воспроизводиться нормально.

[править] Пример:

Следующий код может быть введен в кнопку, которая при нажатии выключит все звуки в клипе:

on(release) {
    stopAllSounds();
}

[править] Совместимость:

Используется с 3-ей версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/stopallsounds
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:17, 17 января 2007.
  • К этой странице обращались 53 раза.
1.70831179619


Справочник по Flash : ActionScript : Action : stopDrag - Останавливает текущую операцию перетаскивания — Справочник Web-языков

Справочник по Flash : ActionScript : Action : stopDrag - Останавливает текущую операцию перетаскивания

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | stopAllSounds - Выключить все звуки
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | stopDrag - Останавливает текущую операцию перетаскивания
 |  |  |  |  |  |  |  | tellTarget - Обратиться к удаленному клипу

[править] stopDrag

(Глобальная функция)

Останавливает текущую операцию перетаскивания

[править] Синтаксис:

stopDrag();

[править] Описание:

Функция startDrag() вызывает перемещение клипа за курсором мыши по рабочему столу. Операция stopDrag() прекращает перемещение клипа вслед за курсором мыши. Поскольку в каждый конкретный момент можно буксировать только один клип или фильм, для stopDrag() не требуется аргумента target - эта функция просто прекращает любую текущую операцию буксировки.

Вместе с startDrag() функция stopDrag() используется для создания во Flash простых интерфейсов "drag-and-drop".

[править] Примеры:

Следующие команды останавливают перетаскивание мувиклипа mc, когда пользователь отпустит кнопку мыши:

on(press) {
    startDrag("mc");
}
on(release) {
    stopdrag();
}

[править] Совместимость:

Используется с 4-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/stopdrag
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:20, 17 января 2007.
  • К этой странице обращались 47 раз.
1.38439488411


Справочник по Flash : ActionScript : Action : tellTarget - Обратиться к удаленному клипу — Справочник Web-языков

Справочник по Flash : ActionScript : Action : tellTarget - Обратиться к удаленному клипу

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | stopDrag - Останавливает текущую операцию перетаскивания
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | tellTarget - Обратиться к удаленному клипу
 |  |  |  |  |  |  |  | toggleHighQuality - Изменение качества

[править] tellTarget

(Глобальная функция)

Позволяет выполнить предложения, находящиеся в области видимости удаленного клипа фильма

[править] Синтаксис:

tellTarget(target){
    statements
}

[править] Аргументы:

target
Строка или ссылка, указывающие путь к фильму или экземпляру клипа (ссылки преобразуются в пути при использовании в строковом контексте).
statements
Предложения, которые должны быть выполнены в области видимости target.

[править] Описание:

Во Flash 3 и Flash 4 tellTarget() была главным средством связи между двумя клипами фильмов (т.е. управления одним клипом из другого). Она использовалась для вызова таких функций, как play(), stop(), и gotoAndStop() с удаленными клипами фильмов. Во Flash 4, где в ActionScript были добавлены переменные, с помощью tellTarget() можно было также получать и задавать значения переменных удаленных клипов. Во Flash 5 такие действия лучше осуществлять с помощью оператора точки, ., и оператора обращения к массиву, []. Другой альтернативой функции tellTarget() является предложение with.

[править] Некоторые особенности:

Функцию tellTarget() лучше было бы описать как предложение, поскольку для нее требуется блок предложений. Вопрос этот, однако, чисто академический, поскольку tellTarget() устарела.

Обычно она применяется, если нужно динамически назначить уровень удаляемого фильма.

[править] Пример:

tellTarget("ball") {
    gotoAndStop("redStripes");
    _x +=300;
}

[править] Совместимость:

Используется с 3-ей версии Flash. Устарела в 5-ой версии

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/telltarget
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:22, 17 января 2007.
  • К этой странице обращались 60 раз.
1.30378389359


Справочник по Flash : ActionScript : Action : toggleHighQuality - Изменение качества — Справочник Web-языков

Справочник по Flash : ActionScript : Action : toggleHighQuality - Изменение качества

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | tellTarget - Обратиться к удаленному клипу
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | toggleHighQuality - Изменение качества
 |  |  |  |  |  |  |  | unloadMovie - Удалить фильм или клип из проигрывателя

[править] toggleHighQuality

(Глобальная функция)

Изменяет качество вывода.

[править] Синтаксис:

toggleHighQuality()

[править] Описание:

Функция toggleHighQuality() осуществляет переключение между низким и высоким качеством вывода. Если установить высокое качество вывода, то Flash Player выводит линии со сглаженными краями. При установке низкого качества линии выводятся с не сглаженными (зубчатыми) краями.

Функция toggleHighQuality() не принимает аргументов, она просто переключает две возможные установки - "High" и "Low". Это может вызвать проблемы, т.к. качество не устанавливается явно в известное состояние, и при этом не допускается иных установок качества, кроме двух заданных.

[править] Примечание:

Во Flash 5 эта функция устарела благодаря появлению глобального свойства _quality, которое поддерживает качество вывода Low, Medium, High и Best.

[править] Пример:

Изменение качества изображения при нажатии на кнопку.

on(release) {
    toggleHighQuality();
}

[править] Совместимость:

Используется со 2-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/togglehighquality
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:35, 17 января 2007.
  • К этой странице обращались 49 раз.
1.33504700661


Справочник по Flash : ActionScript : Action : unloadMovie - Удалить фильм или клип из проигрывателя — Справочник Web-языков

Справочник по Flash : ActionScript : Action : unloadMovie - Удалить фильм или клип из проигрывателя

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | toggleHighQuality - Изменение качества
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | unloadMovie - Удалить фильм или клип из проигрывателя
 |  |  |  |  |  |  |  | unloadMovieNum - Удалить фильм из проигрывателя

[править] unloadMovie

(Глобальная функция)

Позволяет удалить фильм или клип фильма из проигрывателя

[править] Синтаксис:

unloadMovie(target)

[править] Аргументы:

target
Строка или ссылка, указывающие путь к клипу фильма или уровню документа, которые нужно удалить из проигрывателя (ссылки преобразуются в пути при использовании в строковом контексте).

[править] Описание:

Функция unloadMovie() чаще всего используется для удаления фильмов с уровней документов в проигрывателе.

Например, если фильм загружен на уровень 1 проигрывателя, удалить его из проигрывателя можно так:

unloadMovie("_level1");

Функция unloadMovie() может использоваться с экземплярами клипов, и тогда она удаляет содержимое экземпляра, а не сам экземпляр. Экземпляр остается на рабочем столе в виде пустой оболочки, в которую можно загружать последующие фильмы. Поэтому один клип может выступать как контейнер динамического содержания, управляемого последовательными вызовами loadMovie() и unloadMovie().

[править] Совместимость:

Используется с 4-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/unloadmovie
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:38, 17 января 2007.
  • К этой странице обращались 51 раз.
1.6092569828


Справочник по Flash : ActionScript : Action : unloadMovieNum - Удалить фильм из проигрывателя — Справочник Web-языков

Справочник по Flash : ActionScript : Action : unloadMovieNum - Удалить фильм из проигрывателя

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | unloadMovie - Удалить фильм или клип из проигрывателя
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | unloadMovieNum - Удалить фильм из проигрывателя
 |  |  |  |  |  |  |  | var - Объявление локальной переменной

[править] unloadMovieNum

(Глобальная функция)

Позволяет удалить фильм из проигрывателя

[править] Синтаксис:

unloadMovieNum(level)

[править] Аргументы:

level
Неотрицательное целое число или выражение, дающее неотрицательное целое число, которое указывает уровень документа, подлежащий выгрузке.

[править] Описание:

Функция unloadMovieNum() почти идентична функции unloadMovie(), за исключением того, что требует задания конечного уровня level как числа, а не как строки.

Это означает, что unloadMovieNum() может удалять только фильмы на уровнях документа, а не клипы.

Обычно она применяется, если нужно динамически назначить уровень удаляемого фильма:

var x = 3;
unloadMovieNum(x);

Тот же результат может быть получен с помощью конкатенации строк и использования обычной функции unloadMovie():

unloadMovie("_level1"+x);

[править] Совместимость:

Используется с 3-ей версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/unloadmovienum
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:40, 17 января 2007.
  • К этой странице обращались 53 раза.
1.55743479729


Справочник по Flash : ActionScript : Action : var - Объявление локальной переменной — Справочник Web-языков

Справочник по Flash : ActionScript : Action : var - Объявление локальной переменной

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | unloadMovieNum - Удалить фильм из проигрывателя
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | var - Объявление локальной переменной
 |  |  |  |  |  |  |  | while - Многократно выполняет некоторый код

[править] var

Используется для объявления локальных переменных

[править] Синтаксис:

var variableName1 [= value1] [...,variableNameN [=valueN]];

[править] Аргументы:

variableName
Имя объявляемой переменной.
value
Значение присваиваемое переменной.

[править] Описание:

Создание переменной называется ее объявлением. Объявление - это этап формального создания переменной. Когда впервые объявлена переменная, она пуста. В таком состоянии переменная содержит особое значение, называемое indefined (указывающее на отсутствие данных).

[править] Примеры:

Пример: Объявление переменной.

var speed;
var myVars;
var y;

Слово var сообщает интерпретатору, что мы объявляем переменную, а последующий текст, например, speed, myVars или y, становиться именем новой переменной. Создавать переменные можно везде, где допускается прикрепление кода: в ключевом кадре, кнопке или клипе.

С помощью одного предложения var можно объявить несколько переменных.

Пример: Объявление нескольких переменных.

var speed, myVars, y;

Однако в этом случае мы не сможем поместить комментарии рядом с этой переменной.

Допустимые имена переменных:

  • Должны состоять исключительно из букв, цифр и символов подчеркивания (Пробелы, дефисы и символы пунктуации не допустимы).
  • Должны начинаться с буквы или с символа подчеркивания.
  • Не должны превышать в длину 255 символов.
  • Являются не чувствительными к регистру (верхний и нижний регистр воспринимаются одинаково).

Пример: Допустимые имена переменных.

var first_name;
var counter;
var MyFirstNameVars;

Пример: Недопустимые имена переменных.

var 1first_name                 // Начинается с цифры
var variable name with spaces;  // Содержит пробелы
var my-vars-name;               // Содержит дефис

В предложении var также можно задать начальное значение новой переменной.

var x = 10;

Если локальные переменные объявляются внутри функции, то они действуют только в ее пределах. Если переменные не объявлены внутри блока, но список команд был выполнен через вызов call, переменные являются локальными и действуют до конца текущего списка. Если переменные не объявлены внутри блока и текущий список команд не выполнялся командой call, переменные не являются локальными.

[править] Совместимость:

Используется с 5-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/var
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:46, 17 января 2007.
  • К этой странице обращались 56 раз.
1.29891490936


Справочник по Flash : ActionScript : Action : while - Многократно выполняет некоторый код — Справочник Web-языков

Справочник по Flash : ActionScript : Action : while - Многократно выполняет некоторый код

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | var - Объявление локальной переменной
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | while - Многократно выполняет некоторый код
 |  |  |  |  |  |  |  | with - Выполняет некоторый код в конце указанного объекта

[править] while

Выполняет оператор или серию операторов в цикле, пока условный аргумент соответствует истине (true).

[править] Синтаксис:

while(condition) {
    statements;
}

[править] Аргументы:

condition
Условие, проверяемое каждый раз при выполнении команды while. Если результат проверки соответствует истине (true), исполняются операторы, указанные в statements.
statements
Операторы, исполняемые в том случае, если условие соответствует истине (true).

[править] Описание:

По структуре предложение while во многом похоже на предложение if: если условие имеет значение true, выполняются предложения statements. Но, в отличии от if, по завершении последнего из подпредложений выполнение повторяется снова с начала предложения while (т.е. интерпретатор "зацикливается" на начале предложения while).

Второй проход через предложение while действует точно так же, как первый: вычисляется условие, и если оно по прежнему оказывается true, снова выполняются statements. Этот процесс продолжается, пока condition не станет false, и тогда выполнение продолжится с тех предложений, которые следуют в сценарии за while.

Цикл обычно используется для выполнения действий, пока переменная счетчика имеет значение меньше чем определенное условием. В конце каждого цикла счетчик увеличивает свое значение и цикл повторяется, и так происходит до тех пор, пока не счетчик не превысит порогового значения, определенного в условии condition, после чего цикл завершается.

Это пример дублирования пяти мувиков, каждый из которых получает случайные координаты x и y, свойства xscale, yscale и _alpha. Переменная foo инициализируется со значения 0. Аргумент condition устанавливается таким, что while цикл будет выполнен пять раз или пока значение переменной foo будет меньше 5. Внутри while цикла мувик клонируется и через setProperty получает новые свойства. Последний оператор цикла увеличивает значение foo, и так происходит до тех пор, пока foo не достигнет значения 5, после чего при очередной проверке аргумента condition будет получено false и цикл завершит работу.

on(release) {
    foo = 0;
    while(foo < 5) {
        duplicateMovieClip("/flower", "mc" + foo, foo);
        setProperty("mc" + foo, _x, random(275));
        setProperty("mc" + foo, _y, random(275));
        setProperty("mc" + foo, _alpha, random(275));
        setProperty("mc" + foo, _xscale, random(200));
        setProperty("mc" + foo, _yscale, random(200));
        foo = foo + 1;
    }
}

[править] Совместимость:

Используется с 4-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/while
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:52, 17 января 2007.
  • К этой странице обращались 56 раз.
1.36027479172


Справочник по Flash : ActionScript : Action : with - Выполняет некоторый код в конце указанного объекта — Справочник Web-языков

Справочник по Flash : ActionScript : Action : with - Выполняет некоторый код в конце указанного объекта

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | while - Многократно выполняет некоторый код
Главная | ::. | Flash | ::. | ActionScript | ::. | Action | ::. | with - Выполняет некоторый код в конце указанного объекта

[править] with

Предоставляет сокращенный способ обращения к свойствам объекта.

[править] Синтаксис:

with (object) {
    statements;
}

[править] Аргументы:

object
Экземпляр ActionScript объекта или мувиклипа.
statements
Команда или группа команд, заключенных в фигурные скобки.

[править] Описание:

Если обращение к свойству происходит в блоке предложений with, проверяется наличие этого свойства у объекта object. Если у object существует указанное свойство, то оно и используется для разрешения ссылки на свойство. Если у object нет такого свойства, оно ищется в текущей временной диаграмме или функции.

[править] Примеры:

Следующий пример демонстрирует разницу между выполнением предложения внутри with и вне with:

PI = 10;                 // Задать переменную временной диаграммы, PI
with (Math) {            // Выполнить предложения в контексте Math
  trace("pi is: " + PI); // Выводит: 3.1459 (PI - свойство Math)
}
trace("pi is: " + PI);   // Выводит: 10 (Обращение к Math больше нет)

Помимо предоставления удобного доступа к свойствам объекта, with может использоваться для вызова методов объекта:

x = 10;
y = 11;
with (Math) {
  larget = max(x, y);
}
trace(larget); // Выводит: 11

Нельзя определять новое свойство объекта, являющегося целью предложения with. Обратите внимание в предыдущем примере на то, что переменная larget не определена в объекте Math, поэтому ссылка на свойство воздействует на временную диаграмму или функцию, содержащую предложение with.

Следующий код показывает неверную попытку присвоить переменной значение myClip:

with (myClip) {
  var x = 10; // значение x задается в текущей временной диаграмме,
              // а не в myClip
}

Можно, однако, с полным правом использовать with для воздействия на экземпляры клипов другими способами. Это предложение предоставляет удобный способ работы с глубоко вложенными структурами экземпляров.

Например, следующий код:

_root.form.userProfile.userID = "34R56";
_root.form.userProfile.gotoAndPlay("guestionnaire");

можно заменить таким:

with (_root.form.userProfile) {
  userID = "34R56";
  gotoAndPlay("guestionnaire");
}

Но with не является единственным способом обеспечения такого удобства. Можно просто присвоить наш экземпляр переменной и использовать эту переменную в ссылках:

var userForm = _root.form.userProfile;
userForm.userID = "34R56";
userForm.gotoAndPlay("guestionnaire");

Следующий пример устанавливает свойства x и y экземпляра someOtherMovieClip и затем командует ему перейти на третий кадр и остановиться:

with (someOtherMovieClip) {
    _x = 50;
    _y = 100;
    gotoAndStop(3);
}

Следующий отрывок кода показывает, как можно написать предшествующий пример без использования команды with:

someOtherMovieClip._x = 50;
someOtherMovieClip._y = 100;
someOtherMovieClip.gotoAndStop(3);

Этот код также можно написать с использованием команды tellTarget:

tellTarget ("someOtherMovieClip") {
    _x = 50;
    _y = 100;
    gotoAndStop(3);
}

Использование команды with полезно для одновременного вызова многих элементов в контекстном листе. В следующем примере встроенный объект Math помещен в начало объектной области (контекста). Установка Math, как объекта по умолчанию, приводит идентификаторы cos, sin и PI к Math.cos, Math.sin и Math.PI соответственно. Идентификаторы a, x, y и r - не методы или свойства объекта Math, но так как они существуют в объектной области (контексте) функции polar, они приводятся к к соответствующим локальным переменным.

function polar(r){
    var a, x, y
    with (Math) {
        a = PI * r * r
        x = r * cos(PI)
        y = r * sin(PI/2)
}
trace("area = " +a)
trace("x = " + x)
trace("y = " + y)
}

Возможно использование вложенных команд with для доступа к информации во многих контекстных областях. В следующем примере экземпляры fresno и salinas являются дочерними по отношению к california. Оператор устанавливает значения _alpha для fresno и salinas без изменения значения _alpha у california.

with (california){
    with (fresno){
        _alpha = 20;
    }
    with (salinas){
        _alpha = 40;
    }
}

[править] Совместимость:

Используется с 4-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/action/with
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:58, 17 января 2007.
  • К этой странице обращались 58 раз.
1.19554495811


Справочник по Flash : ActionScript : Basic Actions : fscommand - Передача данных браузеру — Справочник Web-языков

Справочник по Flash : ActionScript : Basic Actions : fscommand - Передача данных браузеру

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | getURL - Переход на веб-страницу
Главная | ::. | Flash | ::. | ActionScript | ::. | Basic Actions | ::. | fscommand - Передача данных браузеру
 |  |  |  |  |  |  |  | loadMovie - Загрузить файл .swf

[править] fscommand

(Глобальная функция)

Позволяет отправить данные программе, которая запустила данный клип

[править] Синтаксис:

fscommand(command, arguments)

[править] Аргументы:

command
Строка, передаваемая приложению-хозяину, часто имя функции JavaScript;
arguments
Строка, передаваемая приложению-хозяину, часто аргумент для функции, указанной в command.

[править] Описание:

С помощью функции fscommand(), фильм Flash может связываться с автономным проигрывателем или приложением-хозяином проигрывателя: средой, в которой выполняется Flash Player (веб-браузером или Macromedia Director).

Функция fscommand() обычно используется одним из трех способов:

  • Для отправки одной из немногочисленных встроенных команд автономному проигрывателю Flash
  • Для отправки команд языку сценариев веб-браузера, например, JavaScript или VBScript
  • Для связи с Lingo в фильме Macromedia Director

При использовании с автономным плеером fscommand() принимает одну из встроенных пар команда/аргумент, как показано в следующей таблице:

Пары команда/аргумент в автономном проигрывателе

Команда | Аргумент | Описание
"allowscale" | "true" или "false" | В случае "false" предотвращает увеличение или сжатие содержимого фильма в зависимости от размера окна проигрывателя. "allowscale" часто используют в сочетании с "fullscreen", чтобы создать Projector, занимающий весь экран при сохранении исходного размера фильма.
"exec" | "application_name" | Запускает внешнее приложение. Путь к приложению задается в строке application_name. Путь разрешается относительно фильма Flash, если только application_name не задано как абсолютный тип, например: "C:/WINDOWS/NOTEPAD.EXE". Обратите внимание, что в пути используется прямая косая черта (/), а не обратная ().
"fullscreen" | "true" или "false" | В случае "true" включает максимизацию окна проигрывателя, которое занимает весь экран пользователя.
"quit" | "н/а" | Закрывает фильм и выходит из проектора Flash (автономный проигрыватель).
"showmenu" | "true" или "false" | В случае "false" подавляет вывод управляющих элементов в контекстном меню проигрывателя, оставляя только опцию About Macromedia Flash Player.
"trapallkeys" | "true" или "false" | В случае "true" все нажатия клавиш - даже клавиш сокращенного набора - посылаются фильму Flash. trapallkeys используется для отключения управляющих клавиш в автономном проигрывателе (например, Ctrl-F для полноэкранного режима, Ctrl-Q для завершения работы, Esc для режима Stop/exit Full Screen mode и т.д.)

При использовании в браузере функция fscommand() в фильме влечет вызов специальной функции JavaScript (Netscape) или VBScript (Internet Explorer) на странице, содержащей фильм. Имя этой специальной функции имеет общий вид movieID_DoFSCommand, где movieID является именем, указанным в атрибуте фильма OBJECT ID (Internet Explorer) или атрибутом EMBED NAME (Netscape) в содержащем фильм документе HTML. При вызове movieID_DoFSCommand() значения параметров fscommand() command и arguments передаются в качестве аргументов функции movieID_DoFSCommand(). Если на содержащей фильм странице не существует функции movieID_DoFSCommand(), происходит отказ функции fscommand() без каких-либо сообщений.

Обратите внимание, что для работы fscommand() с Netscape атрибут swLiveConnect тега фильма EMBED должен быть задан как "true":

<EMBED
    NAME="testmoviequot;
    SRC="myMovie.swf"
    WIDTH="100%"
    HEIGHT="100%"
    swLiveConnect="true"
    PLUGINSPAGE="http://www.macromedia.com/go/flashplayer/">
</EMBED>

Связь с браузером через fscommand() невозможна в следующих конфигурациях системы:

  • Internet Explorer под Macintosh OS
  • Любой браузер на Macintosh серии 68К
  • Любой браузер под Windows 3.1
  • Netscape 6

Стоит отметить, что fscommand() не всегда дает лучший способ связи с фильмом Director из Flash. Предпочтительным средством коммуникации с Director является функция getURL() с протоколом event: или lingo:.

[править] Примеры:

Чтобы выйти из автономного проектора, используйте такой код:

fscommand("quit");

Чтобы создать автономный проектор, выполняемый в полноэкранном режиме:

fscommand("fullscreen", "true");

Чтобы создать автономный проектор, выполняемый в полноэкранном режиме, но сохраняющий размер исходного фильма:

fscommand("fullscreen", "true");
fscommand("allowscale", "false");

Для запуска Notepad на большинстве систем Windows можно использовать:

fscommand("exec", "C:/WINDOWS/NOTEPAD.EXE");

В следующем коде показана страница HTML с командами JavaScript и VBScript, необходимыми для ответа на простой вызов fscommand() в фильме. Обратите внимание, что функция VBScript просто вызывает функцию JavaScript - это позволяет работать как в Internet Explorer, так и в Netscape с помощью одной функции JavaScript:

<HTML>
<HEAD>
<TITLE>fscommand demo</TITLE>
<SCRIPT LANGUAGE="JavaScript">
<!--
function testmovie_DoFSCommand(command, args) {
  alert("Здесь данные из Flash: "+command+", "+args);
}
//-->
</SCRIPT>
<SCRIPT LANGUAGE="VBScript">
<!--
Sub testmovieFSCommand(ByVal command, ByVal args)
  call testmovie_DoFSCommand(command, args)
end sub
//-->
</SCRIPT>
</HEAD>
<BODY>
<OBJECT
  ID="testmovie"
  CLASSID="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
  WIDTH="100%"
  HEIGHT="100%"
  CODEBASE="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab">
<PARAM NAME="MOVIE" VALUE="flash-to-javascript.swf">
<EMBED
  NAME="testmovie"
  SRC="flash-to-javascript.swf"
  WIDTH="100%"
  HEIGHT="100%"
  swLiveConnect="true"
  PLUGINSPACE="http://www.macromedia.com/go/flashplayer/"
</EMBED>
</OBJECT>
</BODY>
</HTML>

Чтобы вызвать предшествующую функцию JavaScript testmovie_DoFSCommand() из фильма flash-to-javascript.swf, можно использовать:

fscommand("hello", "world");

[править] Совместимость:

Используется с 4-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/basicactions/fscommand
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:28, 14 января 2007.
  • К этой странице обращались 90 раз.
1.2792840004


Справочник по Flash : ActionScript : Basic Actions : getURL - Переход на веб-страницу — Справочник Web-языков

Справочник по Flash : ActionScript : Basic Actions : getURL - Переход на веб-страницу

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | stopAllSounds - Остановка всех звуков
Главная | ::. | Flash | ::. | ActionScript | ::. | Basic Actions | ::. | getURL - Переход на веб-страницу
 |  |  |  |  |  |  |  | fscommand - Передача данных браузеру

[править] getURL

(Глобальная функция)

Загружает документ с указанного адреса (URL) в окно, или передает переменные другому приложению по URL (выполняет сценарии на стороне сервера), либо генерирует событие Macromedia Director.

[править] Синтаксис:

getURL(URL)
getURL(URL, window)
getURL(URL, window, method)

[править] Аргументы:

URL
Адрес (URL), задающий абсолютное или относительное местоположение документа, который нужно загрузить, или внешнего сценария, который нужно выполнить.
window
Необязательный аргумент, определяющий окно или фрейм (frame) в HTML, куда должен быть помещен документ. Укажите здесь имя окна/фрейма, либо укажите одно из зарезервированных слов:
  • _self - указывает на то же окно/тот же фрейм, откуда вызывается функция.
  • _blank - указывает на новое окно.
  • _parent - указывает на родительское по отношению к текущему окно.
  • _top - указывает на самый верхний фрейм в окне.
method
Необязательный аргумент, указывающий на метод, которым надо пересылать переменные. Если переменные передавать не надо, пропустите этот аргумент, иначе укажите, использовать метод GET или POST. GET добавляет имена переменных вместе со значениями в конец URL, и обычно используется для небольшого количества (и небольшого суммарного объема имен+значений) переменных. POST посылает переменные в отдельном заголовке HTTP и используется для передачи длинных строк или больших по объему данных.

[править] Описание:

Функция getURL() используется для того, чтобы:

  • Загрузить документ (обычно веб-страницы) в фрейм или окно браузера;
  • Выполнить сценарий на стороне сервера и получить результат во фрейм или окно браузера;
  • Выполнить код JavaScript в веб-браузере;
  • Генерировать событие из составляющих Flash, импортированных в Director как спрайты;

Чтобы загрузить документ в текущее окно или фрейм, просто укажите URL документа, не передавая аргументы window или method. Естественно, Flash поддерживает абсолютные URL (такие, в которых указаны протокол, например, "http:", а также имя сервера или аппаратного устройства) и относительные URL (те, которые заданы относительно текущего адреса):

// Абсолютный URL веб-страницы
getURL("http://spravkaweb.ru/");
// Абсолютный URL локального файла
getURL("file:///f:/www/example.html");
// Относительный URL, предполагается протокол http
getURL("/resource/resource.html");

Чтобы загрузить документ в окно или фрейм, имеющие имя, укажите это имя в качестве аргумента window:

// Загрузить в именованный фрейм
getURL("http://spravkaweb.ru/", "myFrame");
// Загрузить в именованное окно
getURL("http://spravkaweb.ru/", "myWindow");

Чтобы заменить набор фреймов, в котором содержится текущий фильм, дайте аргументу window заначение "_parent":

getURL("http://spravkaweb.ru/", "_parent");

Чтобы заменить загружаемым документом все наборы фреймов на странице, дайте аргументу window значение "_top":

getURL("http://spravkaweb.ru/", "_top");

Чтобы открыть загружаемый документ в новом анонимном окне браузера, дайте аргументу window значение "_blank":

getURL("http://spravkaweb.ru/", "_blank");

Нужно отметить, что открытие нового окна с помощью "_blank" лишает нас всякого контроля над внешним видом нового окна (размером, конфигурацией панелей управления, местонахождением и т.д.). Чтобы открывать настраиваемые окна с помощью getURL(), нужно вызвать на содержащей фильм странице функцию JavaScript.

С помощью функции getURL() можно также посылать переменные удаленным приложениям или сценариям на сервере. Чтобы передать переменные текущей временной диаграммы во внешний сценарий, нужно указать имя сценария в качестве аргумента URL и задать "GET" или "POST" в качестве значения аргумента method:

getURL("http://spravkaweb.ru/php.php", "_blank", "GET");

При вызове в качестве метода клипа getURL() посылает переменные временной диаграммы этого клипа:

// Передает переменные myClip в example.php
myClip.getURL("http://spravkaweb.ru/example.php", "_blank", "GET");

Результаты выполнения сценария появятся в окне или фрейме, указанных в аргументе window (который необходимо задавать при передаче переменных).

Чтобы загрузить результаты выполнения сценария в текущие фрейм или окно, нужно задать в качестве аргумента window значение "_self":

getURL("http://spravkaweb.ru/", "_self", "GET");

Если значением аргумента method является "GET", переменные временной диаграммы текущего клипа посылаются в виде строки запроса, присоединенной к URL сценария в запросе HTTP GET. Строки запросов состоят из пар имя/значение, разделяемых амперандами (&):

getURL("http://www.mysite.ru/example.php?ss=2&pl=34", "_self");

Если аргумент method содержит "POST", переменные временной диаграммы текущего клипа посылаются сценарию в виде отдельного блока данных после заголовка запроса HTTP POST (так же, как в обычной форме HTML, использующей метод POST). Обратите внимание, что "POST" недоступен в автономном Flash Player.

Поскольку для большинства веб-серверов максимальная допустимая длина URL лежит между 255 и 1024 символами, при передаче больших объемов данных используйте "POST", а не "GET".

Надо отметить, что любые данные, возвращаемые сценарием, который вызван getURL(), выводятся как обычное веб-содержание в браузере, а не во Flash. Чтобы получить результаты выполнения сценария во Flash, используйте loadVariables().

Функция getURL() может применяться и с другими протоколами помимо "http:".

Протоколы, поддерживаемые getURL

Протокол | Формат | Назначение
event | "event:eventName params" | Послать событие в Director, если принадлежность Flash является спрайтом Director.
file | "file:///driveSpec/forder/filename" | Обратиться к локальному файлу.
ftp | "ftp://server.domain.ru/forder/filename" | Обратиться к удаленному файлу по FTP (протокол передачи файлов).
http | "http://server.domain.ru/forder/filename" | Обратиться к удаленному файлу по HTTP (протокол передачи гипертекста).
javascript | "javascript: command" | Выполнить в браузере команду JavaScript.
lingo | "lingo: comand" | Выполнить команду Lingo, если принадлежность Flash является спрайтом Director.
print | "print:", "targetClip" | Вывод во Flash 4, до появления функции print() во Flash 5.
vbscript | "vbscript: command" | Выполнить в браузере команду VBScript.

Как показывает вышеприведенная таблица, если принадлежность Flash импортируется в файл Macromedia Director, с помощью getURL() можно генерировать события Lingo или выполнять команды Lingo. (Lingo - это язык сценариев в Director, аналогичный ActionScript).

Например, можно добавить событие кадра такого вида:

getURL("event: eventName params");

что приведет к вызову в Director обработчика события Lingo с именем on eventName. Вот команда getURL(), генерирующая событие с именем "myEvent" и передающая ему строку "A". Обратите внимание на преобразование символа с помощью:

// Отправить событие в Director
getURL("event: myEvent "A"");

Вот обработчик события Lingo sprite, который должен быть прикреплен к спрайту Flash в Director, чтобы получить событие. Заметим, что спрайт в Director примерно соответствует экземпляру клипа во Flash; ключевое слово Lingo put родственно команде ActionScript trace(), а && в Lingo является оператором конкатенации строк:

on myEvent msg
    put "The message received from Flash was " && msg
end

Можно также спровоцировать запуск Lingo из спрайта Flash в Director с помощью ключевого слова "lingo:":

// Пусть Director даст звуковой сигнал
getURL("lingo: beep");

Наконец, с помощью getURL() можно выполнять код JavaScript. Вызовем простую функцию alter JavaScript с помощью getURL():

getURL("javascript: alter("Hello world");");

[править] Примеры:

Далее приведен стандартный код кнопки со ссылкой на веб-страницу:

on(release) {
    getURL("http://www.spravkaweb.ru/");
}

[править] Совместимость:

Используется со 2-ей версии Flash. В 4-ой версии усилена добавлением параметра method.

Получено с http://spravkaweb.local/index.php/flash/actionscript/basicactions/geturl
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:27, 14 января 2007.
  • К этой странице обращались 96 раз.
1.35045313835


Справочник по Flash : ActionScript : Basic Actions : gotoAndPlay - Переход на кадр и воспроизведение — Справочник Web-языков

Справочник по Flash : ActionScript : Basic Actions : gotoAndPlay - Переход на кадр и воспроизведение

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | Flash | ::. | ActionScript | ::. | Basic Actions | ::. | gotoAndPlay - Переход на кадр и воспроизведение
 |  |  |  |  |  |  |  | gotoAndStop - Переход на кадр и остановка

[править] gotoAndPlay

(Глобальная функция)

Осуществляет немедленный безусловный переход на указанный кадр, а затем воспроизводит текущий клип или фильм.

[править] Синтаксис:

gotoAndPlay(frameNumber)
gotoAndPlay(frameLabel)
gotoAndPlay(scene, frameNumber)
gotoAndPlay(scene, frameLabel)

[править] Аргументы:

frameNumber
Задает номер кадра, в который воспроизводящая головка текущей временной диаграммы должна переместиться перед воспроизведением. В случае, если в этом параметре было задано число меньше 1 или больше числа кадров, то воспроизведение начинается с первого кадра или последнего соответственно.
frameLabel
Этот аргумент задает метку кадра, в который должна переместиться воспроизводящая головка перед проигрыванием клипа. В случае, если была задана несуществующая метка, то воспроизведение начинается с первого кадра.
scene
Этот необязательный аргумент задает имя сцены, в которую перейдет воспроизводящая головка. Если этот параметр не задан, то по умолчанию предполагается текущая сцена.

[править] Описание:

Если функция gotoAndPlay() вызвана без необязательного параметра scene, то воспроизведение начинается с номера кадра или метки, заданной в параметре frameNumber или frameLabel, на текущей временной диаграмме.

Если при вызове функции используется два параметра, то подразумевается, что первый задает имя сцены. При этом функция gotoAndPlay() перемещает воспроизводящую головку в указанный номером или меткой кадр заданной сцены и воспроизводит эту сцену.

Отметим, что при использовании аргумента scene функция должна вызываться из временной диаграммы _root; в противном случае, операция не выполняется, и воспроизводящая головка не перемещается в указанный кадр.

Содержимое текущего кадра не прорисовывается. Если после этого оператора в текущем сценарии расположены еще какие-либо операторы, то они выполняются.

Небольшая особенность: при воспроизведении сцены выравниваются в одну временную диаграмму. Например, у нас есть сцена 1, которая содержит 30 кадров, и сцена 2, которая содержит 15 кадров. Если мы хотим начать воспроизведение с 10-ого кадра 2-ой сцены, то достаточно выполнить:
gotoAndPlay(40);

Глобальная функция gotoAndPlay() действует только на текущую временную диаграмму. На кадры или состояние других клипов текущей временной диаграммы она не оказывает влияние. Для воспроизведения других клипов нужно вызывать отдельные команды play() или gotoAndPlay() для каждого клипа. Чтобы применить функцию gotoAndPlay() к клипу, находящемуся вне текущей временной диаграммы, нужно использовать формат метода клипа myClip.gotoAndPlay().

[править] Примеры:

В следующем примере при нажатии на кнопку проигрывание переходит на 10-й кадр и продолжает играть:

gotoAndPlay(10);

А здесь перейдем в кадр "begin" сцены beginScene и воспроизведем его:

gotoAndPlay("beginScene", "begin");

[править] Дополнительно:

У этого оператора на вспомогательной панели расположено 4-е поля:

Scene - выбор сцены для проигрывания
<current scene> - текущая сцена
<next scene> - (оператор nextScene()) - безусловный переход к следующей сцене
<previous scene> - (оператор prevScene()) - безусловный переход к предыдущей сцене
названия сцен - сцены, которые есть на данный момент (например, Scene 1)
Type - выбор типа метки для перехода на тот или иной фрейм
Frame Number - в качестве перехода задается номер кадра
Frame Label - в качестве перехода задается метка кадра
Expression - в качестве перехода задается выражение
Next Frame - (оператор nextFrame()) - безусловный переход к следующему кадру
Previous Frame - (оператор prevFrame()) - безусловный переход к предыдущему кадру
Frame - поле ввода номера кадра или метки для указания перехода
gotoAndPlay(5) - переход к 5-му фрейму
gotoAndPlay("begin") - переход к фрейму с меткой "begin"
Go To and Play - (оператор gotoAndStop) после перехода к указанному фрейму останавливает воспроизведение ролика
Все сказанное про gotoAndPlay справедливо и для gotoAndStop.

[править] Совместимость:

Используется со 2-ой версии Flash.

Получено с http://spravkaweb.local/index.php/flash/actionscript/basicactions/gotoandplay
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:20, 14 января 2007.
  • К этой странице обращались 167 раз.
3.18526697159


Справочник по Flash : ActionScript : Basic Actions : gotoAndStop - Переход на кадр и остановка — Справочник Web-языков

Справочник по Flash : ActionScript : Basic Actions : gotoAndStop - Переход на кадр и остановка

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | gotoAndPlay - Переход на кадр и воспроизведение
Главная | ::. | Flash | ::. | ActionScript | ::. | Basic Actions | ::. | gotoAndStop - Переход на кадр и остановка
 |  |  |  |  |  |  |  | nextFrame - Переход на следующий кадр

[править] gotoAndStop

(Глобальная функция)

Осуществляет немедленный безусловный переход на указанный кадр, а затем останавливает текущий клип или фильм.

[править] Синтаксис:

gotoAndStop(frameNumber)

gotoAndStop(frameLabel)

gotoAndStop(scene, frameNumber)

gotoAndStop(scene, frameLabel)

[править] Аргументы:

frameNumber
Задает номер кадра, в который воспроизводящая головка текущей временной диаграммы должна переместиться перед остановкой. В случае, если в этом параметре было задано число меньше 1 или больше числа кадров, то переход осуществляется на первый или последний кадр соответственно.
frameLabel
Этот аргумент задает метку кадра, в который должна переместиться воспроизводящая головка перед остановкой клипа. В случае, если была задана несуществующая метка, то переход осуществляется на первый кадр.
scene
Этот необязательный аргумент задает имя сцены, в которую перейдет воспроизводящая головка. Если этот параметр не задан, то по умолчанию предполагается текущая сцена.

[править] Описание:

Если функция gotoAndStop() вызвана без необязательного параметра scene, то переход происходит на номер кадра или метки, заданный в параметре frameNumber или frameLabel, на текущей временной диаграмме.

Если при вызове функции используется два параметра, то подразумевается, что первый задает имя сцены. При этом функция gotoAndStop() перемещает воспроизводящую головку в указанный номером или меткой кадр заданной сцены и останавливает воспроизведение.

Отметим, что при использовании аргумента scene функция должна вызываться из временной диаграммы _root; в противном случае, операция не выполняется, и воспроизводящая головка не перемещается в указанный кадр.

Содержимое текущего кадра не прорисовывается. Если после этого оператора в текущем сценарии расположены еще какие-либо операторы, то они выполняются.

Глобальная функция gotoAndStop() действует только на текущую временную диаграмму. На кадры или состояние других клипов текущей временной диаграммы она не оказывает влияние. Для воспроизведения других клипов нужно вызывать отдельные команды gotoAndStop() для каждого клипа. Чтобы применить функцию gotoAndStop() к клипу, находящемуся вне текущей временной диаграммы, нужно использовать формат метода клипа myClip.gotoAndStop().

[править] Примеры:

В следующем примере при нажатии на кнопку проигрывание переходит на 10-й кадр и останавливает воспроизведение:

on (release) {	gotoAndStop(10);}

А здесь перейдем в кадр "begin" сцены beginScene:

gotoAndStop("beginScene", "begin");

[править] Совместимость:

Используется со 2-ой версии Flash.

Получено с http://spravkaweb.local/index.php/flash/actionscript/basicactions/gotoandstop
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:21, 14 января 2007.
  • К этой странице обращались 71 раз.
1.25907897949


Справочник по Flash : ActionScript : Basic Actions : ifFrameLoaded - Выполняет код если загруженн определенный кадр — Справочник Web-языков

Справочник по Flash : ActionScript : Basic Actions : ifFrameLoaded - Выполняет код если загруженн определенный кадр

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | tellTarget - Обратиться к удаленному клипу
Главная | ::. | Flash | ::. | ActionScript | ::. | Basic Actions | ::. | ifFrameLoaded - Выполняет код если загруженн определенный кадр
 |  |  |  |  |  |  |  | Action: break - Прекращает выполнение цикла

[править] ifFrameLoaded

(Предложение)

Выполняет некоторый код, если загружен определенный кадр

[править] Синтаксис:

ifFrameLoaded(scene, frame) {
    statement;
}
ifFrameLoaded(frame) {
    statement;
}

[править] Аргументы:

scene
Опрашиваемая сцена.
frame
Номер кадра или строка, указывающая метку кадра. Если кадр, заданный frame, загружен в Player, выполняются предложения statement. Если нет, блок предложений пропускается.

[править] Описание:

Проверяет, доступно ли содержимое указанного кадра локально (скачано ли уже?). Используйте для создания прелоадера, то есть небольшой анимации, пока загружается остальная часть фильма. Разница между использованием _framesloaded и ifFrameLoaded() в том, что _framesloaded позволяет добавить if, или else, в то время, как ifFrameLoaded() позволяет указать количество кадров в одном простом выражении.

Начиная с Flash 4 следует использовать свойства _totalframes и _framesloaded с предложениями if-else для создания более гибкого предварительного загрузчика.

[править] Пример:

if (_totalframes > 0 && _framesloaded == _totalframes) {
    gotoAndPlay("beginFrame");
} else {
    gotoAndPlay(_currentframe - 1);
}

[править] Совместимость:

Используется с 3-ей версии Flash. Действие ifFrameLoaded устарело в Flash 5; используйте вместо него _framesloaded

Получено с http://spravkaweb.local/index.php/flash/actionscript/basicactions/ifframeloaded
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:38, 14 января 2007.
  • К этой странице обращались 54 раза.
1.39156079292


Справочник по Flash : ActionScript : Basic Actions : loadMovie - Загрузить файл .swf — Справочник Web-языков

Справочник по Flash : ActionScript : Basic Actions : loadMovie - Загрузить файл .swf

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | fscommand - Передача данных браузеру
Главная | ::. | Flash | ::. | ActionScript | ::. | Basic Actions | ::. | loadMovie - Загрузить файл .swf
 |  |  |  |  |  |  |  | loadMovieNum - Загрузить файл .swf

[править] loadMovie

(Глобальная функция)

Позволяет загрузить в проигрыватель файл .swf.

[править] Синтаксис:

loadMovie(URL, target)
loadMovie(URL, target, method)

[править] Аргументы:

URL
Строка, задающая абсолютный или относительный путь к загружаемому файлу .swf. Во всех URL должна использоваться прямая косая черта, а абсолютные URL должны содержать ссылку на протокол в виде http:// или file:///.
target
Строка, задающая клип или уровень документа, в которых расположится внешний файл .swf. Может также являться ссылкой на существующий клип или уровень документа (ссылки преобразуются на пути при использовании в строковом контексте).
method
Необязательная строка, задающая метод отправки переменных внешнему сценарию. Значениями method могут быть "GET" или "POST". Этот параметр должен быть литералом, а не переменной или другим выражением. Автономная версия Flash Player всегда использует метод "GET" вне зависимости от заданного в method

[править] Описание:

Функция loadMovie() импортирует во Flash Player файл .swf, размещенный по адресу URL.

Если target является ссылкой на существующий клип или строкой, задающей путь к клипу, загруженный файл .swf будет помещен в указанный клип (вызывая удаление предшествующего содержимого). Чтобы загрузить фильм в текущий клип, используйте в качестве параметра target пустую строку:

loadMovie("myMovie.swf", "")

Если target является ссылкой на существующий уровень документа (например, _level2) или строкой, указывающей путь к уровню документа (например, "_level2"), то файл .swf помещается на указанный уровень документа. Загрузка фильма на уровень _level0 очищает проигрыватель от всего содержимого и помещает новый файл .swf на уровень _level0.

Можно посылать переменные вместе с вызовом loadMovie(), и тогда URL обычно является адресом сценария, возвращающего файл .swf, соответствующий переданным переменным. Чтобы отправить переменные при вызове loadMovie(), включается аргумент method (заданный в "GET" или "POST"). "GET" посылает переменные временной диаграммы текущего клипа в виде строки запроса, присоединенный к URL сценария. "POST" посылает переменные временной диаграммы текущего клипа после заголовка HTTP для запроса POST. Метод "POST" недоступен в автономном Flash Player. Поскольку у большинства веб-серверов длина URL ограничена величиной от 255 до 1024 символов, для передачи больших объемов данных используйте "POST", а не "GET".

Вызовы loadMovie() над веб-сервером, использующие метод "GET", могут передавать переменные в загруженный фильм без вмешательства сценария.

Например, загрузим внешний фильм myMovie.swf на уровень 1 стека документов проигрывателя, передав ему переменные текущей временной диаграммы:

loadMovie("myMovie.swf", "_level1", "GET");

Переменные, передаваемые в загружаемый фильм, определяются на главной временной диаграмме этого фильма. Этот прием действует только при обработке запроса loadMovie() веб-сервером. Попытки использовать метод "GET" в loadMovie() для локальных файлов вызывают ошибку.

[править] Некоторые особенности:

Будьте осторожны при использовании ссылок на клипы и уровни в качестве аргумента target функции loadMovie(). Если аргумент target дает значение undefined, то функция loadMovie() использует в качестве target текущую временную диаграмму.

Аналогично, ссылки target, дающие пустую строку, заставляют loadMovie() действовать над текущей временной диаграммой. В частности, этим вызываются проблемы при загрузке фильмов на новые незанятые уровни.

Рассмотрим следующий код:

loadMovie("myMovie.swf", _level1);

Если до выполнения этого предложения объект _level1 не существовал, то этот код загрузит файл myMovie.swf во временную диаграмму, содержавшую предложение loadMovie(), а не на _level1! Чтобы избежать этой проблемы, вместо loadMovie() можно использовать loadMovieNum(). Кроме того, можно указать строку в качестве параметра target для loadMovie():

loadMovie("myMovie.swf", "_level1");

В этом случае уровень будет создан, если его еще не существует ( только _level0 существует по умолчанию во всех фильмах).

[править] Пример:

// Поместить myMovie.swf на level 1
loadMovie("myMovie.swf", "_level1");
// Поместить myMovie.swf на level 0
loadMovie("myMovie.swf", "_level0");
// Поместить myMovie.swf в myClip
loadMovie("myMovie.swf", "myClip");
// Заменить содержимое проигрывателя на
// coolmovie.swf, использую абсолютный путь
loadMovie("http://www.yousite.ru/coolmovie.swf", "_level0");
// Загрузить фильм на уровень 1 с рабочего стола Windows.
loadMovie("file:///C:/WINDOWS/Desktop/myMovie.swf", "_level1");

[править] Совместимость:

Используется с 4-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/basicactions/loadmovie
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:29, 14 января 2007.
  • К этой странице обращались 87 раз.
1.42997193336


Справочник по Flash : ActionScript : Basic Actions : loadMovieNum - Загрузить файл .swf — Справочник Web-языков

Справочник по Flash : ActionScript : Basic Actions : loadMovieNum - Загрузить файл .swf

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | loadMovie - Загрузить файл .swf
Главная | ::. | Flash | ::. | ActionScript | ::. | Basic Actions | ::. | loadMovieNum - Загрузить файл .swf
 |  |  |  |  |  |  |  | unloadMovie - Удалить фильм или клип из проигрывателя

[править] loadMovieNum

(Глобальная функция)

Позволяет загрузить в проигрыватель файл .swf

[править] Синтаксис:

loadMovieNum(URL, level)
loadMovieNum(URL, level, method)

[править] Аргументы:

URL
Строка, задающая абсолютный или относительный путь к загружаемому файлу .swf. Во всех URL должна использоваться прямая косая черта, а абсолютные URL должны содержать ссылку на протокол в виде http:// или file:///.
level
Неотрицательное целое или выражение, возвращающее неотрицательное целое число, задающее уровень документа, на котором будет размещен внешний файл .swf.
method
Необязательная строка, задающая метод отправки переменных внешнему сценарию. Значениями method могут быть "GET" или "POST". Этот параметр должен быть литералом, а не переменной или другим выражением. Автономная версия Flash Player всегда использует метод "GET" вне зависимости от заданного в method

[править] Описание:

Функция loadMovieNum() почти идентична loadMovie(), но требует задания целевого уровня загрузки в виде числа, а не строки. Это означает, что loadMovieNum() может загружать фильмы только на уровни документов, а не в клипы. Если указанного уровня не существует, он будет создан. Если указанный уровень существует, его содержимое будет заменено новым файлом .swf. Допускается загрузка фильма на _level2, даже если _level1 не создан.

Функцию loadMovieNum() можно использовать, когда нужно динамически задавать уровень для загрузки фильма, например:

var x = 3;
loadMovieNum("muMovie.swf", x);

Того же самого можно достичь путем конкатенации строк и использования обычной функции loadMovie():

loadMovie("muMovie.swf", "_level" + x);

[править] Совместимость:

Используется с 3-ей версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/basicactions/loadmovienum
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:29, 14 января 2007.
  • К этой странице обращались 70 раз.
1.2411301136


Справочник по Flash : ActionScript : Basic Actions : nextFrame - Переход на следующий кадр — Справочник Web-языков

Справочник по Flash : ActionScript : Basic Actions : nextFrame - Переход на следующий кадр

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | gotoAndStop - Переход на кадр и остановка
Главная | ::. | Flash | ::. | ActionScript | ::. | Basic Actions | ::. | nextFrame - Переход на следующий кадр
 |  |  |  |  |  |  |  | prevFrame - Переход на предыдущий кадр

[править] nextFrame

(Глобальная функция)

Перемещает воспроизводящую головку текущего клипа или фильма на один кадр вперед и останавливает ее.

[править] Синтаксис:

nextFrame()

[править] Описание:

Функция nextFrame() перемещает воспроизводящую головку текущей временной диаграммы на один кадр вперед и останавливает ее там.

Текущей временной диаграммой называется временная диаграмма, из которой была вызвана функция nextFrame().

Эта функция идентична функции gotoAndStop(_currentFrame+1);

Если вызов функции произошел из последнего кадра текущей временной диаграммы, и за этой сценой нет другой, то воспроизводящая головка просто останется на месте. Если за текущей сценой есть другая, то происходит переход на 1 кадр следующей сцены.

[править] Примеры:

В следующем примере при нажатии на кнопку происходит переход на следующий кадр:

on (release) {
    nextFrame();
}

[править] Совместимость:

Используется со 2-ой версии Flash.

Получено с http://spravkaweb.local/index.php/flash/actionscript/basicactions/nextframe
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:22, 14 января 2007.
  • К этой странице обращались 76 раз.
1.55101799965


Справочник по Flash : ActionScript : Basic Actions : nextScene - Переход на следующую сцену — Справочник Web-языков

Справочник по Flash : ActionScript : Basic Actions : nextScene - Переход на следующую сцену

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | prevFrame - Переход на предыдущий кадр
Главная | ::. | Flash | ::. | ActionScript | ::. | Basic Actions | ::. | nextScene - Переход на следующую сцену
 |  |  |  |  |  |  |  | prevScene - Переход на предыдущую сцену

[править] nextScene

(Глобальная функция)

Перемещает воспроизводящую головку в первый кадр следующей сцены

[править] Синтаксис:

nextScene()

[править] Описание:

Функция nextScene() перемещает главную воспроизводящую головку фильма в первый кадр следующей сцены и останавливает временную диаграмму главного фильма.

Если вызов функции произошел из последней сцены фильма, то переход осуществляется на первый кадр этой сцены и воспроизведение останавливается.

Функция nextScene() должна вызываться из главной временной диаграммы фильма, т.е. она не работает внутри клипа или обработчика onClipEvent().

[править] Примеры:

В следующем примере при нажатии на кнопку происходит переход на следующую сцену:

on (release) {
    nextScene();
}

[править] Совместимость:

Используется со 2-ой версии Flash.

Получено с http://spravkaweb.local/index.php/flash/actionscript/basicactions/nextscene
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:23, 14 января 2007.
  • К этой странице обращались 69 раз.
1.31558203697


Справочник по Flash : ActionScript : Basic Actions : Play - Воспроизведение — Справочник Web-языков

Справочник по Flash : ActionScript : Basic Actions : Play - Воспроизведение

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | prevScene - Переход на предыдущую сцену
Главная | ::. | Flash | ::. | ActionScript | ::. | Basic Actions | ::. | Play - Воспроизведение
 |  |  |  |  |  |  |  | Stop - Остановка

[править] Play

(Глобальная функция)

Воспроизведение ролика после остановки

[править] Синтаксис:

Play()

[править] Описание:

При вызове функции Play() начинается последовательное воспроизведение кадров текущего главного фильма или клипа. Текущим называется фильм или клип, в котором находится предложение с вызовом функции Play(). Кадры воспроизводятся с частотой, измеряемой в кадрах в секунду (FPS) и задаваемой для фильма в целом в свойствах фильма Movie Properties (меню Modify -> Movie -> Frame Rate).

Начавшееся воспроизведение клипа или фильма продолжается, пока его специально не остановит вызов другой функции. Все клипы фильмов зацикливаются (снова начинают воспроизведение с кадра 1), когда воспроизводящая головка достигает конца временной диаграммы. Однако в браузере главные фильмы зацикливаются только тогда, когда в коде, встраивающем фильм в страницу HTML, указана необходимость зацикливания с помощью атрибута LOOP. (Если для встраивания фильма в страницу HTML используется команда Publish, атрибут LOOP устанавливается при выборе меню File -> Publish Setting -> HTML -> Playback -> Loop.)

[править] Примеры:

Следующий код использует оператор if для проверки введенного значения имени пользователя. Если введено Steve, команда play включает дальнейшее воспроизведение клипа на линейке. В противном случае, в текстовом поле с переменной alert выдается соответствующее значение.

stop();
if (name = "Steve") {
    play();
} else {
    alert = "You are not Steve!";
}

[править] Совместимость:

Используется со 2-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/basicactions/play
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:25, 14 января 2007.
  • К этой странице обращались 68 раз.
1.23361515999


Справочник по Flash : ActionScript : Basic Actions : prevFrame - Переход на предыдущий кадр — Справочник Web-языков

Справочник по Flash : ActionScript : Basic Actions : prevFrame - Переход на предыдущий кадр

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | nextFrame - Переход на следующий кадр
Главная | ::. | Flash | ::. | ActionScript | ::. | Basic Actions | ::. | prevFrame - Переход на предыдущий кадр
 |  |  |  |  |  |  |  | nextScene - Переход на следующую сцену

[править] prevFrame

Перемещает воспроизводящую головку текущего клипа или фильма на один кадр назад и останавливает ее

[править] Синтаксис:

prevFrame()

[править] Описание:

Функция prevFrame() перемещает воспроизводящую головку текущей временной диаграммы на один кадр назад и останавливает ее там.

Текущей временной диаграммой называется временная диаграмма, из которой была вызвана функция prevFrame().

Эта функция идентична функции gotoAndStop(_currentFrame-1);.

Если вызов функции произошел из первого кадра текущей временной диаграммы, и перед этой сценой нет другой, то воспроизводящая головка просто останется на месте. Если перед текущей сценой есть другая, то происходит переход на последний кадр предшествующей сцены.

[править] Примеры:

В следующем примере при нажатии на кнопку происходит переход на предыдущий кадр:

on (release) {
    prevFrame();
}

[править] Совместимость:

Используется со 2-ой версии Flash.

Получено с http://spravkaweb.local/index.php/flash/actionscript/basicactions/prevframe
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:23, 14 января 2007.
  • К этой странице обращались 63 раза.
1.37884497643


Справочник по Flash : ActionScript : Basic Actions : prevScene - Переход на предыдущую сцену — Справочник Web-языков

Справочник по Flash : ActionScript : Basic Actions : prevScene - Переход на предыдущую сцену

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | nextScene - Переход на следующую сцену
Главная | ::. | Flash | ::. | ActionScript | ::. | Basic Actions | ::. | prevScene - Переход на предыдущую сцену
 |  |  |  |  |  |  |  | Play - Воспроизведение

[править] prevScene

(Глобальная функция)

Перемещает воспроизводящую головку в первый кадр предыдущей сцены

[править] Синтаксис:

prevScene()

[править] Описание:

Функция prevScene() перемещает главную воспроизводящую головку фильма в первый кадр предыдущей сцены и останавливает временную диаграмму главного фильма.

Если вызов функции произошел из первой сцены фильма, то переход осуществляется на первый кадр этой сцены и воспроизведение останавливается.

Функция prevScene() должна вызываться из главной временной диаграммы фильма, т.е. она не работает внутри клипа или обработчика onClipEvent().

[править] Примеры:

В следующем примере при нажатии на кнопку происходит переход на предыдущую сцену:

on (release) {
    prevScene();
}

[править] Совместимость:

Используется со 2-ой версии Flash.

Получено с http://spravkaweb.local/index.php/flash/actionscript/basicactions/prevscene
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:24, 14 января 2007.
  • К этой странице обращались 65 раз.
1.36000299454


Справочник по Flash : ActionScript : Basic Actions : Stop - Остановка — Справочник Web-языков

Справочник по Flash : ActionScript : Basic Actions : Stop - Остановка

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Play - Воспроизведение
Главная | ::. | Flash | ::. | ActionScript | ::. | Basic Actions | ::. | Stop - Остановка
 |  |  |  |  |  |  |  | toggleHighQuality - Изменение качества

[править] Stop

(Глобальная функция)

Производит остановку фильма на текущем кадре

[править] Синтаксис:

Stop()

[править] Описание:

Функция Stop() останавливает воспроизведение фильма или клипа. Это глобальный аналог метода MovieClip.stop(). Она часто используется для ожидания, когда пользователь, например, сделает выбор в графическом меню.

[править] Пример:

on (release) {
    stop();
}

[править] Совместимость:

Используется с 3-ей версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/basicactions/stop
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:25, 14 января 2007.
  • К этой странице обращались 73 раза.
1.40265083313


Справочник по Flash : ActionScript : Basic Actions : stopAllSounds - Остановка всех звуков — Справочник Web-языков

Справочник по Flash : ActionScript : Basic Actions : stopAllSounds - Остановка всех звуков

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | toggleHighQuality - Изменение качества
Главная | ::. | Flash | ::. | ActionScript | ::. | Basic Actions | ::. | stopAllSounds - Остановка всех звуков
 |  |  |  |  |  |  |  | getURL - Переход на веб-страницу

[править] stopAllSounds

(Глобальная функция)

Производит выключение всех звуков в фильме

[править] Синтаксис:

stopAllSounds()

[править] Описание:

Функция stopAllSounds() заглушает все звуки, воспроизводящиеся в данный момент в фильме, независимо от глубины вложенности в клипы. Она применяется ко всем звукам фильма, в том числе к программно генерируемым объектам Sound. Более точно управлять остановкой, запуском и громкостью звука можно с помощью класса Sound. Стоит отметить, что функция stopAllSounds() оказывает только временное воздействие. Любой звук, который начинается после вызова stopAllSounds(), будет воспроизводиться нормально.

[править] Пример:

Следующий код может быть введен в кнопку, которая при нажатии выключит все звуки в клипе:

on(release) {
    stopAllSounds();
}

[править] Совместимость:

Используется с 3-ей версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/basicactions/stopallsounds
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:26, 14 января 2007.
  • К этой странице обращались 73 раза.
1.37477707863


Справочник по Flash : ActionScript : Basic Actions : tellTarget - Обратиться к удаленному клипу — Справочник Web-языков

Справочник по Flash : ActionScript : Basic Actions : tellTarget - Обратиться к удаленному клипу

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | unloadMovieNum - Удалить фильм из проигрывателя
Главная | ::. | Flash | ::. | ActionScript | ::. | Basic Actions | ::. | tellTarget - Обратиться к удаленному клипу
 |  |  |  |  |  |  |  | ifFrameLoaded - Выполняет код если загруженн определенный кадр

[править] tellTarget

(Глобальная функция)

Позволяет выполнить предложения, находящиеся в области видимости удаленного клипа фильма

[править] Синтаксис:

tellTarget(target){
    statements
}

[править] Аргументы:

target
Строка или ссылка, указывающие путь к фильму или экземпляру клипа (ссылки преобразуются в пути при использовании в строковом контексте).
statements
Предложения, которые должны быть выполнены в области видимости target.

[править] Описание:

Во Flash 3 и Flash 4 tellTarget() была главным средством связи между двумя клипами фильмов (т.е. управления одним клипом из другого). Она использовалась для вызова таких функций, как play(), stop(), и gotoAndStop() с удаленными клипами фильмов. Во Flash 4, где в ActionScript были добавлены переменные, с помощью tellTarget() можно было также получать и задавать значения переменных удаленных клипов. Во Flash 5 такие действия лучше осуществлять с помощью оператора точки, ., и оператора обращения к массиву, []. Другой альтернативой функции tellTarget() является предложение with.

[править] Некоторые особенности:

Функцию tellTarget() лучше было бы описать как предложение, поскольку для нее требуется блок предложений. Вопрос этот, однако, чисто академический, поскольку tellTarget() устарела.

Обычно она применяется, если нужно динамически назначить уровень удаляемого фильма.

[править] Пример:

tellTarget("ball") {
    gotoAndStop("redStripes");
    _x +=300;
}

[править] Совместимость:

Используется с 3-ей версии Flash. Устарела в 5-ой версии

Получено с http://spravkaweb.local/index.php/flash/actionscript/basicactions/telltarget
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:31, 14 января 2007.
  • К этой странице обращались 75 раз.
1.23899197578


Справочник по Flash : ActionScript : Basic Actions : toggleHighQuality - Изменение качества — Справочник Web-языков

Справочник по Flash : ActionScript : Basic Actions : toggleHighQuality - Изменение качества

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Stop - Остановка
Главная | ::. | Flash | ::. | ActionScript | ::. | Basic Actions | ::. | toggleHighQuality - Изменение качества
 |  |  |  |  |  |  |  | stopAllSounds - Остановка всех звуков

[править] stopAllSounds

(Глобальная функция)

Производит выключение всех звуков в фильме.

[править] Синтаксис:

stopAllSounds()

[править] Описание:

Функция stopAllSounds() заглушает все звуки, воспроизводящиеся в данный момент в фильме, независимо от глубины вложенности в клипы. Она применяется ко всем звукам фильма, в том числе к программно генерируемым объектам Sound. Более точно управлять остановкой, запуском и громкостью звука можно с помощью класса Sound.

Стоит отметить, что функция stopAllSounds() оказывает только временное воздействие. Любой звук, который начинается после вызова stopAllSounds(), будет воспроизводиться нормально.

[править] Пример:

Следующий код может быть введен в кнопку, которая при нажатии выключит все звуки в клипе:

on(release) {
    stopAllSounds();
}

[править] Совместимость:

Используется с 3-ей версии Flash.

Получено с http://spravkaweb.local/index.php/flash/actionscript/basicactions/togglehighquality
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:26, 14 января 2007.
  • К этой странице обращались 66 раз.
1.36544299126


Справочник по Flash : ActionScript : Basic Actions : unloadMovie - Удалить фильм или клип из проигрывателя — Справочник Web-языков

Справочник по Flash : ActionScript : Basic Actions : unloadMovie - Удалить фильм или клип из проигрывателя

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | loadMovieNum - Загрузить файл .swf
Главная | ::. | Flash | ::. | ActionScript | ::. | Basic Actions | ::. | unloadMovie - Удалить фильм или клип из проигрывателя
 |  |  |  |  |  |  |  | unloadMovieNum - Удалить фильм из проигрывателя

[править] unloadMovie

(Глобальная функция)

Позволяет удалить фильм или клип фильма из проигрывателя

[править] Синтаксис:

unloadMovie(target)

[править] Аргументы:

target
Строка или ссылка, указывающие путь к клипу фильма или уровню документа, которые нужно удалить из проигрывателя (ссылки преобразуются в пути при использовании в строковом контексте).

[править] Описание:

Функция unloadMovie() чаще всего используется для удаления фильмов с уровней документов в проигрывателе.

Например, если фильм загружен на уровень 1 проигрывателя, удалить его из проигрывателя можно так:

unloadMovie("_level1");

Функция unloadMovie() может использоваться с экземплярами клипов, и тогда она удаляет содержимое экземпляра, а не сам экземпляр. Экземпляр остается на рабочем столе в виде пустой оболочки, в которую можно загружать последующие фильмы. Поэтому один клип может выступать как контейнер динамического содержания, управляемого последовательными вызовами loadMovie() и unloadMovie().

[править] Совместимость:

Используется с 4-ой версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/basicactions/unloadmovie
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:30, 14 января 2007.
  • К этой странице обращались 77 раз.
1.3020670414


Справочник по Flash : ActionScript : Basic Actions : unloadMovieNum - Удалить фильм из проигрывателя — Справочник Web-языков

Справочник по Flash : ActionScript : Basic Actions : unloadMovieNum - Удалить фильм из проигрывателя

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | unloadMovie - Удалить фильм или клип из проигрывателя
Главная | ::. | Flash | ::. | ActionScript | ::. | Basic Actions | ::. | unloadMovieNum - Удалить фильм из проигрывателя
 |  |  |  |  |  |  |  | tellTarget - Обратиться к удаленному клипу

[править] unloadMovieNum

(Глобальная функция)

Позволяет удалить фильм из проигрывателя

[править] Синтаксис:

unloadMovieNum(level)

[править] Аргументы:

level
Неотрицательное целое число или выражение, дающее неотрицательное целое число, которое указывает уровень документа, подлежащий выгрузке.

[править] Описание:

Функция unloadMovieNum() почти идентична функции unloadMovie(), за исключением того, что требует задания конечного уровня level как числа, а не как строки.

Это означает, что unloadMovieNum() может удалять только фильмы на уровнях документа, а не клипы.

Обычно она применяется, если нужно динамически назначить уровень удаляемого фильма:

var x = 3;
unloadMovieNum(x);

Тот же результат может быть получен с помощью конкатенации строк и использования обычной функции unloadMovie():

unloadMovie("_level1"+x);

[править] Совместимость:

Используется с 3-ей версии Flash

Получено с http://spravkaweb.local/index.php/flash/actionscript/basicactions/unloadmovienum
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:30, 14 января 2007.
  • К этой странице обращались 62 раза.
1.39602398872


Справочник по HTML : Алфавитный указатель атрибутов — Справочник Web-языков

Справочник по HTML : Алфавитный указатель атрибутов

Главная | ::. | HTML | ::. | Алфавитный указатель атрибутов
above
- Задает слой, который будет перекрываться текущим слоем.
accesskey
- Задает клавишу-ускоритель для быстрого доступа к элементу страницы.
action
- Задает интернет-адрес серверной программы, которой форма передаст введенные пользователем данные.
align (Для <CAPTION>, <LEGEND>)
- Задает выравнивание элемента заголовка таблицы (<CAPTION>) по отношению к таблице или пояснительной надписи (<LEGEND>) относительно группы полей.]]
align (Для <DIV>, <Hn>, <HR>, <P>, элементы таблицы)
- Задает выравнивание содержимого элемента страницы.
align (Для <IFRAME> и <TABLE>)
- Задает выравнивание "плавающего" фрейма (<IFRAME>) или таблицы (<TABLE>).
align (Для <IMG>, <SPACER>, элементы управления, внедренные элементы)
- Задает местоположение рисунка, элемента управления или внедренного элемента относительно "обтекающего" его текста.
alink
- Задает цвет активных гиперссылок в документе.
allowtransparency
- Задает прозрачность фрейма, обычного или "плавающего".
alt
- Задает "альтернативный" текст, отображаемый на месте изображения, если оно еще не загружено.
archive
- Задает адрес архивного файла в формате ZIP, в котором находится файл Java-класса.
autocomplete
- Задает или отменяет возможность "автозаполнения" форм и полей ввода текста.
background
- Задает фоновый рисунок для документа или таблицы.
balance
- Задает стереобаланс при воспроизведении фонового звука с использованием тега <BGSOUND>.
behavior
- Задает поведение прокручивающегося текста в элементе <MARQUEE>.
below
- Задает слой, которым будет перекрываться текущий слой.
bgcolor
- Задает цвет фона.
bgproperties
- Задает поведение фонового рисунка документа: будет ли он прокручиваться при прокрутке содержимого или нет.
border (Для <EMBED>)
- Задает толщину в пикселах границы, отображаемой вокруг внедренного элемента.
border (Для <FRAMESET>, <IFRAME>)
- Задает толщину границы между фреймами в пикселах.
border (Для <IMG>, <TABLE>)
- Задает толщину в пикселах границы, отображаемой вокруг рисунка или таблицы.
bordercolor
- Задает цвет границы.
bottommargin
- Задает расстояние от нижней границы окна Web-обозревателя до нижней границы содержимого Web-страницы в пикселах.
cellpadding
- Задает расстояние между границей и содержимым ячейки таблицы в пикселах либо в процентах от доступного пространства.
cellspacing
- Задает расстояние между ячейками таблицы в пикселах либо в процентах от доступного пространства.
challenge
- Задает строку вызова для тега <KEYGEN>.
checked
- Задает включенное состояние флажка или радиокнопки.
class
- Задает стилевой класс элемента страницы.
classid
- Задает уникальный идентификатор класса элемента ActiveX.
clear
- Задает поведение текста, разорванного тегом <BR>, при "обтекании" им некоторых элементов страницы, таких как изображения.
clip
- Задает прямоугольник, за пределами которого содержимое слоя не будет видно (видимая область слоя).
code
- Задает интернет-адрес файла, содержащего откомпилированный класс Java.
codebase (Для <APPLET>)
- Задает интернет-адрес папки, в которой содержится файл Java-класса.
codebase (Для <OBJECT>)
- Задает интернет-адрес папки, в которой содержится дистрибутивный файл элемента ActiveX, Java-класса или расширения (plug-in) Web-обозревателя.
codetype
- Задает тип данных MIME элемента ActiveX.
color
- Задает цвет шрифта или горизонтальной линии.
cols (Для <FRAMESET>)
- Задает количество и значение ширины всех фреймов-колонок в наборе фреймов.
cols (Для <MULTICOL>)
- Задает количество колонок, в которых будет располагаться текст.
cols (Для <PRE>)
- Задает ширину в символах текста с заданным форматом.
cols (Для <TABLE>)
- Задает количество колонок в таблице.
cols (Для <TEXTAREA>)
- Задает ширину в символах текста области редактирования.
colspan
- Задает количество ячеек, которые должны быть объединены в одну.
compact
- Задает компактное отображение позиций списков.
content
- Задает метаданные в теге <META>.
contenteditable
- Задает или отменяет возможность редактирования содержимого Web-страницы или ее элемента пользователем.
coords
- Задает координаты "горячей" области в карте-изображении.
data
- Задает интернет-адрес файла данных, требуемых элементом ActiveX.
datafld
- Задает поле таблицы базы данных, значение которого будет отображаться в элементе страницы.
dataformatas
- Задает представление, используемое для отображения данных из полей таблицы.
datapagesize
- Задает размер страницы данных, выводимых за один раз, в пикселах.
datasrc
- Задает объект-источник данных.
defer
- Позволяет отложить выполнение скриптов, пока Web-страница не будет загружена полностью.
dir
- Задает порядок чтения текста.
direction
- Задает направление прокрутки текста в элементе <MARQUEE>.
disabled
- Запрещает доступ к элементу страницы.
dynsrc
- Задает интернет-адрес динамического содержимого, отображаемого вместо статического рисунка.
enctype
- Задает метод кодирования данных, отправляемых формой в виде MIME.
event
- Задает событие, к которому привязан скрипт-обработчик.
face
- Задает имя шрифта.
for (Для <LABEL>)
- Задает элемент управления, к которому привязана метка <LABEL>.
for (Для <SCRIPT>)
- Задает элемент страницы, к которому привязан скрипт.
frame
- Задает отображение внешних рамок таблицы.
frameboarder (Для <EMBED>
- Задает или отменяет отображение границы вокруг внедренного элемента.
frameboarder (Для фреймов)
- Задает или отменяет отображение границ между фреймами.
framespacing
- Задает дополнительное пространство между фреймами в пикселах.
gutter
- Задает расстояние между колонками текста в пикселах.
height
- Задает высоту элемента страницы в пикселах или как процент от доступного пространства.
hidden
- Задает или отменяет показ внедренного элемента на Web-странице.
hidefocus
- Отменяет показ фокуса ввода (текстового курсора).
href (Для <BASE>)
- Задает базовый интернет-адрес в теге <BASE>, относительно которого отсчитываются все ссылки.
href (Для <гиперссылок>)
- Задает интернет-адрес назначения, куда пользователь попадает после активизации гиперссылки.
hspace
- Задает горизонтальное расстояние от элемента страницы до окружающего его текста.
http-equiv
- Задает тип метаданных, задаваемых в теге <META>.
id
- Задает уникальное имя элемента страницы для доступа к нему из скрипта.
ismap
- Задает поведение рисунка <IMG> как карты изображения.
lang
- Задает язык, на котором набран текст.
language
- Задает язык программирования, на котором написан скрипт, привязанный к элементу страницы.
left
- Задает горизонтальную координату левого верхнего угла слоя относительно родителя.
leftmargin
- Задает расстояние от левой границы окна Web-обозревателя до левой границы содержимого Web-страницы в пикселах.
link
- Задает цвет гиперссылок в документе.
loop (Для <BGSOUND>, <IMG>, <INPUT type="image">)
- Задает количество повторений фонового звука или видеофильма.
loop (Для <MARQUEE>)
- Задает, сколько раз в теге <MARQUEE> будет прокручиваться текст.
lowsrc
- Задает интернет-адрес файла с изображением низкого качества.
marginheight
- Задает в пикселях отступ по вертикали между границей фрейма и его содержимым.
marginwidth
- Задает в пикселях отступ по горизонтали между границей фрейма и его содержимым.
maxlength
- Задает максимальное количество пикселей, которое пользователь может ввести в поле ввода.
mayscript
- Разрешает или запрещает доступ из скрипта к Java-апплету.
media
- Задает способ применения таблицы стилей: только для просмотра Web-страницы на экране компьютера, только для печати на принтере или и для того, и для другого.
method
- Задает метод передачи данных формой: get или post.
methods
- Задает список методов протокола HTTP, поддерживаемых гиперссылкой.
multiple
- Задает возможность выбора пользователем нескольких значений в списке <SELECT>.
name (Для <A>)
- Задает имя "якоря".
name (Для <FRAME>)
- Задает имя фрейма.
name (Для <IMG>, элементы управления, внедренные объекты)
- Задает имя элемента страницы, используемое в скриптах.
name (Для <META>)
- Задает в теге <META> тип метаданных.
name (Для <PARAM>)
- Задает имя параметра внедренного объекта.
nohref
- Используется при создании "пустой", не привязанной ни к чему области на карте-изображении.
noresize
- Используется при создании фрейма, размер которого не может быть изменен пользователем.
noshade
- Отключает тень у горизонтальной линейки.
nowrap
- Отключает автоматический перенос слова в тексте.
pagex
- Задает горизонтальную координату левого верхнего угла слоя относительно окна Web-обозревателя.
pagey
- Задает вертикальную координату левого верхнего угла слоя относительно окна Web-обозревателя.
palette
- Задает цветовую палитру Windows, которую будет использовать внедренный элемент.
pluginspage
- Задает интернет-адрес Web-страницы, содержащей инструкции по инсталяции расширения Web-обозревателя.
pluginurl
- Задает интернет-адрес дистрибутивного файла расширения Web-обозревателя.
point-size
- Задает размер шрифта в пикселах.
prompt
- Задает подсказку для тега <ISINDEX>.
readonly
- Делает невозможным редактирование текста в поле ввода.
rel
- Задает связь между текущей Web-страницей и той, на которую указывает гиперссылка.
rev
- Аналогичен REL, но направлен в обратную сторону, т.е. сообщает, чем текущая страница является для той, на которую указывает гиперссылка.
rightmargin
- Задает расстояние от правой границы окна Web-обозревателя до правой границы содержимого Web-страницы в пикселах.
rows (Для <FRAMESET>)
- Задает количество и высоту фреймов-строк в наборе фреймов.
rows (Для <TEXTAREA>)
- Задает высоту области редактирования в строках текста.
rowspan
- Задает количество строк в столбце, которые должны быть объединены в одну.
rules
- Задает отображение внутренних рамок таблицы.
scroll
- Задает, будет ли окно Web-обозревателя иметь полосы прокрутки.
scrollamount
- Задает шаг в пикселах, на который будет смещаться текст в <MARQUEE> за один раз.
scrolldelay
- Задает задержку в миллисекундах перед каждым шагом прокрутки текста в <MARQUEE>.
scrolling
- Задает, будет ли прокручиваться при необходимости содержимое фрейма.
selected
- Задает, будет ли текущий пункт списка выбран изначально.
shape
- Задает форму "горячей" области на карте-изображении.
size (Для <BASEFONT> и <FONT>)
- Задает размер шрифта от 1 (минимальный) до 7 (максимальный).
size (Для <HR>)
- Задает высоту горизонтальной линейки в пикселах.
size (Для <SPACER>)
- Задает величину дополнительного расстояния, добавляемого между символами в строке или между строками в абзаце, в зависимости от значения атрибута type.
size (Для элементов управления)
- Задает размер элемента управления.
span
- Задает количество колонок, на которое распространяется действие параметров, заданных в тегах <COL> или <COLGROUP>.
src (Для <APPLET>, <BGSOUND>, <EMBED>, <XML>, фреймов, рисунков, слоев)
- Задает интернет-адрес файла, содержащего загружаемый элемент страницы.
src (Для <LINK>)
- Задает интернет-адрес файла, на который ссылается текущая страница.
src (Для <SCRIPT>)
- Задает интернет-адрес файла с текстом скрипта.
start (Для <IMG>)
- Задает момент, с которого начнет воспроизводиться видеоклип, имя файла которого было задано в атрибуте dynsrc.
start (Для <OL>)
- Задает начальную позицию нумерации элементов пронумерованного списка <OL>.
style
- Задает встроенный стиль для элемента страницы.
suppress
- Включает или отключает отображение "альтернативного" текста и значка в левом правом углу рамки, когда изображение еще не загружено.
tabindex
- Задает номер в последовательности обхода элементов управления при нажатии клавиши <TAB>.
target
- Задает имя фрейма или окна Web-обозревателя, куда будет загружена Web-страница, указанная в гиперссылке.
text
- Задает цвет текста документа.
title
- Задает текст "всплывающей" подсказки для элемента страницы. Эта подсказка появляется при наведении на элемент курсора мыши.
title (Для <STYLESHEET>)
- Задает заголовок для таблицы стилей.
top
- Задает вертикальную координату левого верхнего угла слоя относительно родителя.
topmargin
- Задает расстояние от верхней границы окна Web-обозревателя до верхней границы содержимого Web-страницы в пикселах.
truespeed
- Задает способ вычисления нового положения прокручиваемого текста в <MARQUEE>.
type (Для <BUTTON>)
- Задает тип кнопки <BUTTON>.
type (Для <EMBED>, <LINK>, <OBJECT>)
- Задает тип данных MIME элемента ActiveX.
type (Для <INPUT>)
- Задает тип элемента управления: кнопка, флажок, поле ввода или что-то другое.
type (Для <LI>, <OL>, <UL>)
- Задает тип маркера и тип нумерации нумерованного списка.
type (Для <SCRIPT>)
- Задает тип интерпретатора (виртуальной машины) скриптового языка в стандарте MIME.
type (Для <SPACER>)
- Задает тип дополнительного свободного пространства, размещаемого на странице.
type (Для <STYLE>)
- Задает тип таблицы стилей в стандарте MIME.
units
- Задает единицу измерения ширины и высоты внедренного объекта <EMBED>.
urn
- Задает имя сетевого ресурса (Uniform Resource Name).
usemap
- Задает имя (и, возможно, интернет-адрес) списка "горячих" областей для карты-изображения.
valign (Для <CAPTION>)
- Задает местонахождение заголовка таблицы: вверху или внизу.
valign
- Задает вертикальное выравнивание текста в таблице и ее элементах.
value (Для <LI>)
- Задает номер позиции нумерованного списка.
value (Для <OPTION>)
- Задает значение, которое будет послано формой серверу.
value (Для <PARAM>)
- Задает значение параметра внедренного объекта.
value (кнопки)
- Задает надпись, помещаемую на кнопке.
value (скрытое поле)
- Задает значение, посылаемое серверной программе скрытым полем.
value (текстовые поля)
- Задает начальное значение, помещаемое в текстовом поле.
value (флажки и радиокнопки)
- Задает значение, которое форма отправит серверной программе, если пользователь включит флажок или радиокнопку.
vcard_name
- Задает значение одного из свойств объекта vCard (сведений о пользователе) для использования во всплывающем списке автозаполнения полей ввода.
visibility
- Задает видимость или невидимость слоя.
vlink
- Задает цвет посещенных гиперссылок в документе.
volume
- Задает громкость проигрывания звука <BGSOUND>.
vspace
- Задает вертикальное расстояние в пикселах от элемента страницы до окружающего его текста.
weight
- Задает "жирность" шрифта от 100 (самый светлый) до 900 (самый жирный).
width
- Задает ширину элемента страницы либо в пикселах, либо в процентах от доступного пространства.
wrap (Для <PRE>)
- Включает перенос строк текста с заданным форматом в теге <PRE>.
wrap (Для <TEXTAREA>)
- Задает перенос строк в области редактирования.
z-index
- Задает порядок перекрытия слоев.
Получено с http://spravkaweb.local/index.php/html/attribute
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 05:31, 20 марта 2007.
  • К этой странице обращались 180 раз.
6.99827003479


Справочник по HTML : Формы — Справочник Web-языков

Справочник по HTML : Формы

 |  |  |  | Графика, объекты, мультимедиа, сценарий
Главная | ::. | HTML | ::. | Формы
 |  |  |  | Фреймы

Содержание

  • 1 <FIELDSET>...</FIELDSET>
  • 2 <FORM>...</FORM>
  • 3 <INPUT>...</INPUT>
  • 4 <SELECT>...</SELECT>
  • 5 <OPTION>...</OPTION>
  • 6 <TEXTAREA>...</TEXTAREA>
  • 7 Смотрите также

[править] <FIELDSET>...</FIELDSET>

Используется для группирования элементов форм.

Пример:

<FIELDSET>
<LEGEND>Возраст</LEGEND>
<INPUT type=Radio Name="size18">До 18
<INPUT type=Radio Name="size18">Больше 18
</FIELDSET>

[править] <FORM>...</FORM>

Окрытие формы.

Атрибуты FORM:

  • ACTION - обязательный атрибут - определяет местонахождение определяемых форм
  • METHOD - определяет место передачи формы
METHOD=POST
METHOD=GET - (по умолчанию)
  • ENCTYPE - определяет кодировку для передачи обработчику по умолчанию
ENCTYPE=application/x-www-form-urlencoded

[править] <INPUT>...</INPUT>

Рисует кнопку или окно ввода.

Синтаксис:

<INPUT TYPE="тип кнопки" VALUE="надпись" NAME=" имя переменной">
  • тип кнопки=SUBMIT - рисует кнопку с надписью "надпись" - обработчик checkbox
  • тип кнопки=RADIO - рисует круглую кнопку - обработчик onclick
параметр CHECKED - обозначает, что кнопка помечена
параметр VALUE - определяет имя, присвояемое переменной
  • тип кнопки=CHECKBOX - рисует квадрат, в котором можно зделать пометку - обработчик onclick
параметр CHECKED - обозначает, что кнопка помечена
параметр VALUE - определяет имя, присвояемое переменной
  • тип кнопки=BUTTON - рисует кнопку с надписью надпись - обработчик onclick
  • тип=HIDDEN - определяет скрытый элемент данных
параметр NAME - определяет переменную
параметр VALUE - определяет имя, присвояемое переменной
  • тип кнопки=TEXT - ввод текста в окно
параметр VALUE - текст по умолчанию
параметр SIZE - ширина окна в символах
  • тип кнопки=PASSWORD - окно для ввода пароля
параметр VALUE - пароль по умолчанию
параметр SIZE - ширина окна в символах
параметр MAXLENGTH - допустимая длина пароля
  • тип кнопки=NUM - ввод числа в окно
параметр VALUE - число по умолчанию
  • тип кнопки=RESET - сброс данных формы

[править] <SELECT>...</SELECT>

Выбор значения из всех предложенных.

  • NAME - обязательный атрибут, определяющий имя переменной, которую генерирует меню.
  • MULTIPLE - атрибут, указывающий на возможность выбора нескольких элементов
  • SIZE - высота окна в строках

[править] <OPTION>...</OPTION>

Определяет элемент меню. Используется внутри тега <SELECT>.

  • VALUE - начение, которое будет передано обработчику (обязательный атрибут)
  • SELECTED - атрибут, указывающий на значение по умолчанию

[править] <TEXTAREA>...</TEXTAREA>

Выводит область ввода текста.

[править] Смотрите также

  • Алфавитный указатель атрибутов
Получено с http://spravkaweb.local/index.php/html/forms
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 19:20, 18 декабря 2006.
  • К этой странице обращались 150 раз.
7.39186501503


Справочник по HTML : Фреймы — Справочник Web-языков

Справочник по HTML : Фреймы

 |  |  |  | Формы
Главная | ::. | HTML | ::. | Фреймы

Содержание

  • 1 <FRAMESET>...</FRAMESET>
  • 2 <FRAME>...</FRAME>
  • 3 <NOFRAME>...</NOFRAME>
  • 4 <IFRAME>...</IFRAME>
  • 5 Смотрите также

[править] <FRAMESET>...</FRAMESET>

Определяет состав и размеры кадров на экране.

Атрибуты FRAMESET:

  • COLS
- определяет размеры и количество вертикальных окон
  • ROWS
- определяет размеры и количество горизонтальных окон

[править] <FRAME>...</FRAME>

Определяет HTML файл для каждого кадра.

Теги <FRAME>...</FRAME> располагаются внутри <FRAMESET>

Атрибуты FRAME:

  • SRC - адрес HTML-документа
<FRAME SRC="MyDocument.html">
  • NAME - задает имя кадра
  • FRAMEBORDER - отражение рамки фрейма (0 - выключена)

Для загрузки в нужном окне HTML-документа по гиперссылке из другого окна используют атрибут TARGET в теге <A HREF>

<A HREF="Text.html" TARGET="nameWindow">

Для упрощения можно использовать тег <BASE>

<BASE TARGET="nameWindow">
  • Параметр TARGET - задает кадр, выделяемый по умолчанию для отображения гипертекста
  • NORESIZE - включает режим, при котором пользователь не может изменить размеры данного кадра
  • SCROLLING - линейка прокрутки
SCROLLING=YES - создается линейка прокрутки
SCROLLING=NO - линейка прокрутки не создается
  • MARGINHEIGHT
  • MARGINWIDTH толщина граничной линии между кадрами в пикселях

[править] <NOFRAME>...</NOFRAME>

Предназначен для передачи сообщений браузеру, не обрабатывающему кадры.

Пример использования <NOFRAMES>

<HTML>
<HEAD>
<TITLE>Пример</TITLE>
</HEAD>
<FRAMESET COL="25,*">
<FRAME SRC="LeftFile.html">
<FRAME SRC="RightFile.html">
</FRAMESET>
<NOFRAME>
<BODY>
Ваш браузер не может обрабатывать кадры!!!
</BODY>
</NOFRAME>
</HTML>

[править] <IFRAME>...</IFRAME>

Создание вложенного окна.

Атрибуты IFRAME:

  • frameBorder -
  • height - высота окна
  • width - ширина окна
  • marginHeight - верхний и нижний отступ документа в окне
  • marginWidth - левый и правый отступ документа в окне
  • SCROLLING - прокрутка
  • scrolling=yes - прокрутка разрешена
  • scrolling=no - прокрутка запрещена
  • SRC - описание вставляемого документа

[править] Смотрите также

  • Алфавитный указатель атрибутов
Получено с http://spravkaweb.local/index.php/html/frames
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 19:20, 18 декабря 2006.
  • К этой странице обращались 135 раз.
7.64737296104


Справочник по HTML — Справочник Web-языков

Справочник по HTML

Главная ::. HTML

[править] Разделы справки

  • Структура документа
  • Заголовки и названия
  • Параграфы и строки
  • Стили текста
  • Списки.Ссылки
  • Таблицы
  • Графика, объекты, мультимедиа, сценарий
  • Формы
  • Фреймы

[править] Алфавитный указатель атрибутов

Все :: A :: B :: C :: D :: E :: F :: G :: H :: I :: L :: M :: N :: P :: R :: S :: T :: U :: V :: W :: Z

[править] Советы

  • Внедрение элементов в html-страницу
    • Как вставить в html-страницу документы MS Office (Word, Excel и т.д.)

[править] Приложения

  • Коды и обозначения символов
  • Коды и названия цветов
  • Коды языков HTML

[править] Полезные ссылки

  • Форум по HTML
Получено с http://spravkaweb.local/index.php/html
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 11:07, 21 марта 2007.
  • К этой странице обращались 718 раз.
1.4751060009


Справочник по HTML : Списки.Ссылки — Справочник Web-языков

Справочник по HTML : Списки.Ссылки

 |  |  |  | Стили текста
Главная | ::. | HTML | ::. | Списки.Ссылки
 |  |  |  | Таблицы

Содержание

  • 1 <DL>...</DL>
  • 2 <DT>...</DT>
  • 3 <DD>...</DD>
  • 4 <OL>...</OL>
  • 5 <LI>...</LI>
  • 6 <UL>...</UL>
  • 7 <A>...</A>
  • 8 Смотрите также

[править] <DL>...</DL>

Этот тег используется для создания списка определений. Включает в себя теги <DT> (термин) и <DD> (определение термина).

<DL>
<DT>Определяемый термин
<DD>определение термина
</DL>

Если определяемые термины короткие

<DL COMPACT>...</DL>

Атрибуты <DL>:

  • class="Стилевой класс"
  • COMPACT
  • id="Имя"
  • lang="Код языка"
  • style="Определение встроенного стиля"

Атрибуты <DL> в IE:

  • accesskey="Клавиша-ускоритель"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Блочный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.0

[править] <DT>...</DT>

Этот тег помечает текст термина в списке определений <DL>.

Атрибуты <DT>:

  • class="Стилевой класс"
  • id="Имя"
  • lang="Код языка"

Атрибуты <DT> в IE:

  • accesskey="Клавиша-ускоритель"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • NOWRAP
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Блочный одинарный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.0

[править] <DD>...</DD>

Этот тег помечает текст определения в списке определений <DL>.

Атрибуты <DD>:

  • class="Стилевой класс"
  • id="Имя"
  • lang="Код языка"
  • style="Определение встроенного стиля"

Атрибуты <DD> в IE:

  • accesskey="Клавиша-ускоритель"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • NOWRAP
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Блочный одинарный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.0

[править] <OL>...</OL>

Используется для создания нумерованного списка.

Атрибуты <OL>:

  • class="Стилевой класс"
  • id="Имя"
  • lang="Код языка"
  • start="Начальный номер"
  • type="A|a|I|i|1"

Атрибуты <OL> в IE:

  • accesskey="Клавиша-ускоритель"
  • COMPACT
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Каждый элемент списка начинать с <LI TYPE=вид>

  • вид=A - прописные буквы
  • вид=a - строчные
  • вид=I - римские прописные
  • вид=i - римские строчные
  • вид=1 - арабские

Блочный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.0

[править] <LI>...</LI>

Метка.Помечает позицию списка.

Атрибуты <OL>:

  • class="Стилевой класс"
  • id="Имя"
  • lang="Код языка"
  • style="Определение встроенного стиля"
  • type="A|a|I|i|1|disc|circle|square"
  • value="Номер"

Атрибуты <OL> в IE:

  • accesskey="Клавиша-ускоритель"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"
  • вид=A - прописные буквы
  • вид=a - строчные
  • вид=I - римские прописные
  • вид=i - римские строчные
  • вид=1 - арабские
  • вид=DISK - круглая жирная точка
  • вид=CIRCLE - окружность
  • вид=SQUARE - маленький черный квадрат

Встроенный одинарный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.0

[править] <UL>...</UL>

Используется для создания маркированного списка.

Атрибуты <UL>:

  • class="Стилевой класс"
  • id="Имя"
  • lang="Код языка"
  • style="Определение встроенного стиля"
  • type="disc|circle|square"

Атрибуты <UL> в IE:

  • accesskey="Клавиша-ускоритель"
  • COMPACT
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"
  • вид=A - прописные буквы
  • вид=DISK - круглая жирная точка
  • вид=CIRCLE - окружность
  • вид=SQUARE - маленький черный квадрат

Блочный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.0

[править] <A>...</A>

Создание анкера (якоря), или гиперссылки.

Атрибуты <A>:

  • href="Интернет-адрес назначения"
  • name="Имя якоря"
  • target="Имя окна или фрейма|_blank|_parent|_search|_top">

Атрибуты <A> в IE:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • datafld="Имя поля таблицы базы данных"
  • datasrc="Имя объекта-источника данных"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • methods="Список методов HTTP, разделенных запятыми"
  • rel="Alternate|Appendix|Bookmark|Chapter |Contents|Copyright|Glossary|Help |Index|Next|Offline|Prev |Section|Shortcut Icon|Start|Stylesheet |Subsection|fontdef|stylesheet"
  • rev="Alternate|Appendix|Bookmark|Chapter |Contents|Copyright|Glossary|Help |Index|Next|Prev|Section |Start|Stylesheet |Subsection|"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"
  • urn="Имя сетевого ресурса"

Обязательные атрибуты NAME или HREF

Атрибут NAME
Создание анкера(метки)
  • NAME="AAA", где AAA имя гипертекстовой ссылки внутри документа
Атрибут HREF
Определяет переход по гипертекстовой ссылке к странице или анкеру
<A HREF="#AAA">Переход к анкеру AAA</A>
<A HREF=&quot2.html#AAA">Переход к анкеру ААА в файде 2.html</A>
<A HREF="ftr://server/directory/file.ext"> Загрузить файл </A>
<A HREF=&quotmailto:user@mail.box">Послать письмо</A>
Атрибут TARGET
Определяет окно, в которое будет загружаться гиперссылка.
  • TARGET="windowName"

Поддерживается IE и NN начиная с 1.0

[править] Смотрите также

  • Алфавитный указатель атрибутов
Получено с http://spravkaweb.local/index.php/html/list
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 12:55, 18 марта 2007.
  • К этой странице обращались 181 раз.
4.37768292427


Справочник по HTML : Графика, объекты, мультимедиа, сценарий — Справочник Web-языков

Справочник по HTML : Графика, объекты, мультимедиа, сценарий

 |  |  |  | Таблицы
Главная | ::. | HTML | ::. | Графика, объекты, мультимедиа, сценарий
 |  |  |  | Формы

Содержание

  • 1 <MAP>...</MAP>
  • 2 <BGSOUND>...</BGSOUND>
  • 3 <IMG>...</IMG>
  • 4 <MARQUEE>...</MARQUEE>
  • 5 <SCRIPT>...</SCRIPT>
  • 6 <EMBED>...</EMBED>
  • 7 <OBJECT>...</OBJECT>
  • 8 <PARAM>...</PARAM>
  • 9 Смотрите также

[править] <MAP>...</MAP>

Создание нескольких активных областей на одном рисунке <AREA> - задает чувствительную область

Атрибуты <MAP>:

  • NAME - имя карты координат

Атрибуты <AREA>:

  • SHAPE - форма области
SHAPE=rect - прямоугольник (задаются две пары координат: x1,y1,x2,y2 (для верхнего левого и нижнего правого углов))
SHAPE=circle - окружность (задается x,y,r , где x,y - координаты центра, r - радиус)
SHAPE=poly - многоугольник (задается x1,y1,x2,y2,...xn,yn , где x,y - координаты углов)
  • HREF - URL ссылки при щелчке на область мыщью
  • NOHREF - задание неактивной но чувствительной области
  • COORDS - координаты области

Пример:

<MAP NAME="menu">
<AREA SHAPE=rect COORDS="0,0,20,20" HREF="file1.html">
<AREA SHAPE=rect COORDS="40,0,60,20" HREF="file2.html">
</MAP>

Определение рисунка как меню производится в теге <IMG> при помощи атрибута USEMAP:

<IMG SRC="pic.gif" border=0 USEMAP=#menu>

[править] <BGSOUND>...</BGSOUND>

Вставить звуковой файл в документ (вставляется после <HEAD>). Только для IE.

Параметры BGSOUND:

  • SRC - имя звукового файла (wav)
SRC="Sound.wav"
  • LOOP - число повторов
LOOP=3
  • VOLUME
  • DELAY
  • BALANCE

[править] <IMG>...</IMG>

Вставка изображения, видео или звука.

Синтаксис:

<IMG SRC="имя файла">
  • имя файла=file.jpg
  • имя файла=file.gif - вставка графического изображения
  • имя файла=file.wav - вставка звука
  • имя файла=file.avi - вставка видео фрагмента

Параметры:

  • WIDTH - ширина картинки в пикселях
  • HEIGHT - высота картинки в пикселях
  • ALIGN - выравнивание
ALIGN=LEFT - изображение прижимается к левому полю окна, текст обтекает изображение с правой стороны
ALIGN=CENTER - выравнивание по центру
ALIGN=RIGHT - изображение прижимается к правому полю окна, текст обтекает изображение с левой стороны
ALIGN=TOP - верхняя граница изображения выравнивается по самому высокому элементу текущей строки
ALIGN=TEXTTOP - верхняя граница изображения выравнивается по самому высокому текстовому элементу текущей строки
ALIGN=MIDDLE - выравнивание середины изображения по базовой линии текущей строки
ALIGN=ABSMIDDLE - выравнивание середины изображения посередине текущей строки
ALIGN=BOTTOM,BASELINE - выравнивание нижней границы изображения по базовой линии текущей строки
ALIGN=ABSBOTTOM - выравнивание нижней границы изображения по нижней границе текущей строки
  • HSPACE - оризонтальный отступ от графического изображения
  • ALT - альтернативный текст

[править] <MARQUEE>...</MARQUEE>

Создание бегущей строки.

  • BEHAVIOR-устанавливает движения текста
  • BEHAVIOR="scroll"(по умолчанию)-стандартное движение от правого края к левому
  • BEHAVIOR="alternate"-движение от правого края к левому и обратно
  • BEHAVIOR="slide"-один раз пробегает и остается
  • DIRECTION-направление движения текста
  • DIRECTION="left"(по умолчанию)
  • DIRECTION="right"
  • DIRECTION="up"
  • DIRECTION="down"
  • LOOP - число повторений цикла, по умолчанию "infinite"-вечно
  • WIDTH - ширина строки
  • WIDTH=n - ширина строки n пикселей
  • WIDTH=n% - ширина строки n% от ширины экрана
  • HEIGHT - высота строки
  • HEIGHT=n - высота строки n пикселей
  • HEIGHT=n% - высота строки n% от max возможного значения
  • scrollAmount - регулировка движения строки по экрану
  • scrollAmount=n - строка скачет через n пикселей
  • scrollDelay - скорость перерисовки строки
  • scrollDelay= t - скорость перерисовки t милисекунд
  • TrueSpeed - по умолчанию"false"
  • BGCOLOR - цвет поверхности бегущей строки

События:

  • onStart срабатывает, когда должна начаться прокрутка
  • onFinish срабатывает, когда прокрутка закончилась
  • onBounce срабатывает, когда бегущяя строка достигла границы и меняет направление
допускается, когда значение behavior установлено на "alternate"
  • onMouseOver срабатывает при наведении курсора на прокрутку
  • onMouseOut срабатывает, когда курсор убирается с прокрутки
  • onClick срабатывает при нажатии на прокрутку

[править] <SCRIPT>...</SCRIPT>

Описывает язык скрипта.

Обычно это или JavaScript либо VBScript.

Атрибуты:

  • LANGUAGE="JavaScript" - указывает, что используется JavaScript
  • LANGUAGE="VBScript" - указывает, что используется VBScript

[править] <EMBED>...</EMBED>

Размещает модуль на Web-странице.

Атрибуты EMBED:

  • ALIGN=value - Выравнивание.
  • BORDER=num - Ширина рамки в пикселях.
  • FRAMEBORDER=value (NO - не отображать рамку).
  • HEIGHT=num - Высота кадра, выраженная в единицах, которые установлены в атрибуте UNITS.
  • HIDDEN - Скрывает модули на странице.
  • HSPACE=num - Ширина левого и правого полей в пикселях.
  • NAME=name - имя модуля.
  • PALETTE=value
PALETTE=FOREGROUND - цвет переднего плана.
PALETTE=BACKGROUND - цвет фона.
  • PLUGINSPAGE=URL - URL Web-страницы, содержащей инструкции по инсталяции модуля.
  • SRC=URL - URL, указывающий местонахождение встроенного файла мультимедиа. Если этот атрибут не используется, то следует использовать атрибут TYPE.
  • TYPE=type - MIME-тип встроенного объекта, определяющий модуль, который необходимо загрузить. Используется для модулей, которым не требуются данные.
  • UNITS=value
Значение PIXELS - Единицами измерения служат пиксели.
Значение EN - Единицами измерения служит половина размера шрифта.
  • VSPACE=num - Ширина верхнего и нижнего полей в пикселях.
  • WIDTH=num - Ширина фрейма, выраженная в единицах, которые установлены в атрибуте UNITS.
  • AVTOSTART - Указывает, надо ли сразу проигрывать загружаемый файл.

[править] <OBJECT>...</OBJECT>

Размещает модуль на Web-странице. Применяется внутренний тег <PARAM>.

Атрибуты OBJECT:

  • BORDER=num - Ширина рамки в пикселях.
  • CLASSID=URL - URL модуля для загрузки из Internet, если у пользователя этот модуль не инсталирован.
  • DATA=URL - URL файла, содержащего данные объекта.
  • HEIGHT=num - Высота кадра, выраженная в единицах, которые установлены в атрибуте UNITS.
  • HSPACE=num - Ширина левого и правого полей в пикселях.
  • ID=name - Имя встроенного объекта.
  • TYPE=type - MIME-тип встроенного объекта, определяющий модуль, который необходимо загрузить. VSPACE=num - Ширина верхнего и нижнего полей в пикселях.
  • WIDTH=num - Ширина фрейма, выраженная в единицах, которые установлены в атрибуте UNITS.
  • UNITS=value
Значение PIXELS - Единицами измерения служат пиксели.
Значение EN - Единицами измерения служит половина размера шрифта.

[править] <PARAM>...</PARAM>

Указывает дополнительные свойства вставляемого модуля. Размещается между <OBJECT>...</OBJECT>

Пример:

<OBJECT определение_объекта>
    <PARAM NAME="LOOP" VALUE="TRUE">
</OBJECT>

[править] Смотрите также

  • Алфавитный указатель атрибутов
Получено с http://spravkaweb.local/index.php/html/multimedia
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 19:20, 18 декабря 2006.
  • К этой странице обращались 182 раза.
2.78283309937


Приложения HTML — Справочник Web-языков

Приложения HTML

Главная | ::. | HTML | ::. | Приложения HTML

[править] Приложения HTML

  • Коды и обозначения символов
  • Коды и названия цветов
  • Коды языков HTML
Получено с http://spravkaweb.local/index.php/html/pril
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 09:00, 18 марта 2007.
  • К этой странице обращались 77 раз.
1.28812980652


Советы по HTML — Справочник Web-языков

Советы по HTML

Главная | ::. | HTML | ::. | Советы HTML

[править] Советы HTML

  • Внедрение элементов в html-страницу
    • Как вставить в html-страницу документы MS Office (Word, Excel и т.д.)
Получено с http://spravkaweb.local/index.php/html/sovet
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 06:57, 3 марта 2007.
  • К этой странице обращались 74 раза.
1.34491491318


Справочник по HTML : Параграфы и строки — Справочник Web-языков

Справочник по HTML : Параграфы и строки

 |  |  |  | Заголовки и названия
Главная | ::. | HTML | ::. | Параграфы и строки
 |  |  |  | Стили текста

Содержание

  • 1 <BR>...</BR>
  • 2 <CENTER>...</CENTER>
  • 3 <LEFT>...</LEFT>
  • 4 <RIGHT>...</RIGHT>
  • 5 <HR>...</HR>
  • 6 <P>...</P>
  • 7 Смотрите также

[править] <BR>...</BR>

Переход на новую строку не прерывая абзатца.

Атрибуты <BR>:

  • clear="all|left|right|none"

Атрибуты <BR> в IE:

  • class="Стилевой класс"
  • id="Имя"
  • style="Определение встроенного стиля"

Одинарный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.0

[править] <CENTER>...</CENTER>

Используется для центрирования блока текста.

Атрибуты <CENTER> в IE:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Блочный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.1

[править] <LEFT>...</LEFT>

Используется для расположения блока текста по левому краю.

Атрибуты <LEFT> в IE:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Блочный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.1

[править] <RIGHT>...</RIGHT>

Используется для расположения блока текста по правому краю.

Атрибуты <RIGHT> в IE:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Блочный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.1

[править] <HR>...</HR>

Описывает горизантальную линию.

Атрибуты <HR>:

  • align="left|center|right|justify";
  • NOSHADE
  • size="Высота в пикселах"
  • width="Ширина"

Атрибуты <HR> в IE:

  • color="Цвет"
  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • HIDEFOCUS
  • id="Имя"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Блочный одинарный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.0

[править] <P>...</P>

Описывает текстовой обзац.

Атрибуты <P>:

  • align="left|center|right|justify";
  • class="Стилевой класс"
  • id="Имя"
  • lang="Код языка"
  • style="Определение встроенного стиля"

Атрибуты <P> в IE:

  • accesskey="Клавиша-ускоритель"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Блочный парный тег, однако, в некоторый случаях может использоваться как одинарный. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.0

[править] Смотрите также

  • Алфавитный указатель атрибутов
Получено с http://spravkaweb.local/index.php/html/string
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 19:19, 18 декабря 2006.
  • К этой странице обращались 157 раз.
2.74357581139


Справочник по HTML : Структура документа — Справочник Web-языков

Справочник по HTML : Структура документа

Главная | ::. | HTML | ::. | Структура документа
 |  |  |  | Заголовки и названия

Содержание

  • 1 <BASE>...</BASE>
  • 2 <BODY>...</BODY>
  • 3 <DIV>...</DIV>
  • 4 <HEAD>...</HEAD>
  • 5 <META>...</META>
  • 6 <HTML>...</HTML>
  • 7 <LABEL>...</LABEL>
  • 8 <STYLE>...</STYLE>
  • 9 <<!-- -->>...</<!-- -->>
  • 10 Смотрите также

[править] <BASE>...</BASE>

Задает базовый адрес, который может быть использован для формирования полной формы URL из неполной.

Задается в HTML-заголовке страницы (внутни тега <HEAD>) перед всеми гиперссылками.

Синтаксис:

<BASE href="Базовый адрес" id="Имя" target="Имя окна или фрейма|_blank|_parent|_search|_top">

Обязательный параметр: href, который задает интернет-адрес

Одинарный тег. Поддерживается IE начиная с 3.0 и NN начиная с 1.0. В NN отсутствует атрибут ID.

<HEAD>
 . . .
<BASE HREF="http://spravkaweb.ru/">
 . . .
</HEAD>

и тогда гиперссылка вида

<A HREF="/img/10.gif">
будет расширена до
<A HREF="http://spravkaweb.ru/img/10.gif">

Также тег <BASE> применяется в описании фреймов.

[править] <BODY>...</BODY>

Задает начало и конец тела HTML-документа.

Блочный парный тег. Обязательных атрибутов не имеет.

Атрибуты тега <BODY> в IE и NN:

  • bgcolor="Цвет" - определяет цвет фона документа
  • text="Цвет" - определяет цвет текста документа
  • link="Цвет" - определяет цвет выделенного элемента текста
  • vlink="Цвет" - определяет цвет ссылки на документ, который уже просмотрен
  • alink="Цвет" - определяет цвет ссылки в момент, когда на нее указывает курсор мыши
  • background="Интернет-адрес файла изображения" - дает изображение, служащее фоновым
  • bgproperties="fixed" - фоновое изображение не движется. Только для IE.
  • class="Стилевой класс"
  • id="Имя"
  • lang="Код языка"
  • NOWRAP
  • style="Определение встроенного стиля"

Атрибуты тега <BODY> в Internet Explorer :

  • accesskey="Клавиша-ускоритель"
  • leftmargin="Расстояние" - задание отступа на странице слева.
  • rightmargin="Расстояние" - задание отступа на странице справа.
  • topmargin="Расстояние" - задание отступа на странице сверху
  • bottommargin="Расстояние" - расстояние отступа на странице снизу
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • scroll="yes|no|auto"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Атрибуты тега <BODY> в Netscape Navigator:

  • marginwidth="Отступ" - задание отступа на странице слева и справа
  • marginheight="Отступ" - задание отступа на странице сверху и снизу

Поддерживается IE и NN начиная с 1.0

[править] <DIV>...</DIV>

Определяет отдельный элемент страницы: простой текстовой абзац или более сложный фрагмент с HTML-форматированием. Его содержимое может быть сколь угодно сложно. Зачастую используется для создания слоев и применения стилей.

Атрибуты <DIV> :

  • id="Имя" - название слоя
  • style="Определение встроенного стиля"
  • class="Стилевой класс"
  • align="left|center|right|justify";

Атрибуты <DIV> в IE:

  • title="Текст подсказки"
  • accesskey="Клавиша-ускоритель"
  • contenteditable="inherit|true|false"
  • datafld="Имя поля таблицы базы данных"
  • dataformatas="text|html|localized-text"
  • datasrc="Имя объекта-источника данных"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • NOWRAP
  • tabindex="Порядковый номер в последовательности"

Блочный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 2.0

[править] <HEAD>...</HEAD>

Указывает на начало и конец заголовка документа.

Атрибуты <HEAD> :

  • lang="Код языка"

Параметры <HEAD> в IE:

  • class="Стилевой класс"
  • id="Имя"
  • dir="ltr|rtl"

Блочный парный тег. Обязательных атрибутов не имеет. Поддерживается IE и NN начинаяс 1.0

[править] <META>...</META>

Служит для размещения дополнительной информации о Web-странице: предоставление информации о документе, его авторе, дате создания, списки ключевых слов для поисковых машин и т.п.

Общий синтаксис META-тегов :

<META name="имя_META-тэга" content="содержание_META-тэга">

или

<META HTTP-EQUIV="имя_META-тэга" content="содержание_META-тэга">
  • name - Не обрабатывается броузером.
  • HTTP-EQUIV - Обрабатывается броузером.

Теги с параметром NAME :

<META name="description" content="Описание Вашего ресурса">

Описание содержимого документа.

Описание стоит составлять в виде небольшого текста, рекомендуется не более 250-300 символов.

Пример :

<META NAME="description" CONTENT="Эта страница предназначена для предоставления справочной информации по HTML">

<META name="keywords" content=" Ваши ключевые слова">

Список ключевых слов документа, представленных через пробел или запятую. Эти слова нужны поисковым машинам для индексации вашей страницы в своем каталоге. Пример :

<META NAME="keywords" CONTENT="HTML html JavaScript javascript css html CSS VBScript vbscript
VRML vrml php PHP Perl perl справочник язык программирования таги программирование">
<META name="author" content="Информация_об_авторе">

Имя автора документа и его email, домашний адрес и другие координаты.

<META name="generator" content="Название_программы">

Название программы, создавшей документ.

<META name="Copyrigh" content="Авторские_права">

Описание авторских прав на документ.

Теги с параметром HTTP-EQUIV :

<META HTTP-EQUIV="Refresh" CONTENT="0; URL=http://spravkaweb.ru">

Позволяет осуществлять редирект через заданный промежуток времени на определенный адрес. (В данном случае браузер сразу после загрузки страницы осуществит переход на http://spravkaweb.ru)

<META HTTP-EQUIV="Content-Type" content="text/html; charset=windows-1251">

Этот тэг задает тип содержимого (MIME) и его кодироку. В данном случае тип указывается как "text/html" - то есть гипертекст, кодировка (charset) - windows-1251. Вообще, указывать явно кодировку не рекомендуется. Броузеры и сами неплохо справляются с ее выбором.

<META HTTP-EQUIV="expires" CONTENT="Tue, 29 Apr 2001 10:00:00 GMT">

Время "устаревания" документа. Указывается в формате RFC-850 (стандарт электронной почты).

  • Tue - день недели;
  • 29 Apr - день месяца и месяц;
  • 2001 - год;
  • 10:00:00 - время. Часы:минуты:секунды;
  • GMT - время московское. Тип временного пояса.

При истечении указанной даты документ будет удален из кэша и повторном обращении заново запрошен из сети. Это выполняется и броузером и прокси сервером. Обратите внимание - если дата указана как 0, то документ будет удален сразу же после загрузки, то есть он вообще не храниться в кэше. Если вы решили использовать этот параметр, то знайте, что могут возникнуть проблемы с индексированием в поисковых машинах, например, документ не будет проиндексирован вообще.

[править] <HTML>...</HTML>

Заключает в себя весь текст HTML-документа.

Параметры <HTML> в IE:

  • class="Стилевой класс"
  • id="Имя"
  • dir="ltr|rtl"

Блочный парный тег. Обязательных атрибутов не имеет. Поддерживается IE и NN начинаяс 1.0

[править] <LABEL>...</LABEL>

Связывает текстовое содержание с определенным элементом управления.

Атрибуты <LABEL>:

  • for="Имя элемента управления"
  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • datafld="Имя поля таблицы базы данных"
  • dataformatas="text|html|localized-text"
  • datasrc="Имя объекта-источника данных"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Встроенный парный тег. Обязательных атрибутов - for, задающий имя элемента управления, к которому привязывается метка. Это имя должно быть задано атрибутом id! Поддерживается IE начиная с 4.0

Пример 1:

<LABLE FOR="Info">Send Information:</LABLE>
<Input type=Checkbox ID="Info">
Send information

Пример 2:

<STYLE type="text/css">
.accesskey{text-decoration:underline}
</STYLE>

[править] <STYLE>...</STYLE>

Задает таблицу стиля для Web-страницы. Может присутствовать только в HTML-заголовке (нутри тега <HEAD>).

Атрибуты <STYLE>:

  • type="Тип данных MIME" - обязательный атрибут, указывающий браузеру на использования CSS. "Тип данных MIME" - обычно "text/css"

Атрибуты <STYLE> в IE:

  • media="screen|print|all"

Блочный парный тег. Поддерживается IE начиная с 3.0 и NN начиная с 4.0

Импортирование :

Возможность ссылаться на таблицу стилей, расположенную у вас на сервере, и добавлять свои значения

@import: url(MyStyle.css)

Пример :

<HEAD>
    <STYLE type="text/css">
    <!--
    @import:url(MyStyle.css)
    BODY:{font-family:Verbana,Sans-serif}
    A:hover{text-decoration:none}
    . . .
    -->
    </STYLE>
    </HEAD>

[править] <<!-- -->>...</<!-- -->>

Коментарии в документе, которые не выводятся на экран.

[править] Смотрите также

  • Алфавитный указатель атрибутов
Получено с http://spravkaweb.local/index.php/html/structure
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 05:17, 20 марта 2007.
  • К этой странице обращались 262 раза.
5.07896780968


Справочник по HTML : Таблицы — Справочник Web-языков

Справочник по HTML : Таблицы

 |  |  |  | Списки.Ссылки
Главная | ::. | HTML | ::. | Таблицы
 |  |  |  | Графика, объекты, мультимедиа, сценарий

Содержание

  • 1 <TABLE>...</TABLE>
  • 2 <CAPTION>...</CAPTION>
  • 3 <TH>...</TH>
  • 4 <TR>...</TR>
  • 5 <TD>...</TD>
  • 6 <MULTICOL>...</MULTICOL>
  • 7 Смотрите также

[править] <TABLE>...</TABLE>

Данный тег помещает на Web-страницу таблицу.

Атрибуты <TABLE>:

  • align="left|center|right";
  • bgcolor="Цвет"
  • border="Толщина границы в пикселах"
  • cellpadding="Расстояние"
  • cellspacing="Расстояние"
  • cols="Количество колонок"
  • height="Высота"
  • width="Ширина"

Атрибуты <TABLE> в IE:

  • accesskey="Клавиша-ускоритель"
  • background="Интернет-адрес файла изображения"
  • bordercolor="Цвет"
  • class="Стилевой класс"
  • datafld="Имя поля таблицы базы данных"
  • datapagesize="Размер страницы данных"
  • datasrc="Имя объекта-источника данных"
  • dir="ltr|rtl"
  • frame="none|above|below|hsides|lhs|rhs|vsides|box"
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • rules="none|rows|cols|groups|all"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Атрибуты <TABLE> в NN:

  • hspace="Горизонтальный отступ"
  • vspace="Вертикальный отступ"

Блочный парный тег. Обязательных атрибутов не имеет, за исключением атрибута datapagesize, который обязателен при привязке таблицы к данным. Поддерживается IE начиная с 3.0 и NN начиная с 1.1

[править] <CAPTION>...</CAPTION>

Заголовок таблицы.

Атрибуты <CAPTION>:

  • align="bottom|center|left|right|top";

Атрибуты <CAPTION> в IE:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"
  • valign="top|bottom"

Встроенный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.1

[править] <TH>...</TH>

Обозначает заголовок таблицы.

Атрибуты как у TD, только содержимое выравнивается по центру.

[править] <TR>...</TR>

Метки строк в таблице.

Aтрибуты: ALIGN - устанавливает выравнивание текста в ячейках строки

  • ALIGN=LEFT - выравнивание влево
  • ALIGN=CENTER - выравнивание по центру
  • ALIGN=RIGHT - выравнивание вправо

VALIGN - вертикальное выравнивание текста в ячейках строки

  • VALIGN=TOP - выравнивание по верхнему краю
  • VALIGN=MIDDLE - по центру
  • VALIGN=BOTTON - по нижнему краю
  • VALIGN=CENTER
  • VALIGN=BASELINE
  • bgcolor - цвет фона
  • bordercolor - цвет рамки строки
  • bordercolordark - темный цвет рамки строки (IE)
  • bordercolorlight - светлый цвет рамки строки (IE)

[править] <TD>...</TD>

Метки ячеек таблицы.

Aтрибуты: NOWRAP - содержимое ячейки показывать в одну строку COLSPAN - размах ячейки по горизонтали

  • COLSPAN=3 - ячейка на 3 колонки

ROWSPAN - размах ячейки по вертикали

  • ROWSPAN=2 - ячейка, за ней 2 строки

ALIGN - выравнивание текста в ячейках

  • ALIGN=LEFT - выравнивание влево
  • ALIGN=CENTER - выравнивание по центру
  • ALIGN=RIGHT - выравнивание вправо

VALIGN - вертикальное выравнивание

  • VALIGN=TOP - по верхнему краю
  • VALIGN=MIDDLE - по центру
  • VALIGN=BOTTOM - по нижнему краю

WIDTH - ширина ячейки в пикселях

  • WIDTH=200

HEIGHT - высота ячейки в пикселях

  • HEIGHT=40
  • bgcolor - цвет фона
  • background - фоновая графика (JPEG или GIF)
  • bordercolor - цвет рамки строки
  • bordercolordark - темный цвет рамки строки (IE)
  • bordercolorlight - светлый цвет рамки строки (IE)

[править] <MULTICOL>...</MULTICOL>

Вывод текста в несколько столбцов.

Атрибуты:

COLS="n"
n - количество столбцов
GUTTER="m"
m - расстояние между столбцами

[править] Смотрите также

  • Алфавитный указатель атрибутов
Получено с http://spravkaweb.local/index.php/html/table
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 19:20, 18 декабря 2006.
  • К этой странице обращались 191 раз.
4.04671597481


Справочник по HTML : Стили текста — Справочник Web-языков

Справочник по HTML : Стили текста

 |  |  |  | Параграфы и строки
Главная | ::. | HTML | ::. | Стили текста
 |  |  |  | Списки.Ссылки

Содержание

  • 1 <ABBR>...</ABBR>
  • 2 <ACRONYM>...</ACRONYM>
  • 3 <B>...</B>
  • 4 <BIG>...</BIG>
  • 5 <BLOCKQUOTE>...</BLOCKQUOTE>
  • 6 <CITE>...</CITE>
  • 7 <CODE>...</CODE>
  • 8 <DFN>...</DFN>
  • 9 <EM>...</EM>
  • 10 <FONT>...</FONT>
  • 11 <BASEFONT>...</BASEFONT>
  • 12 <I>...</I>
  • 13 <KBD>...</KBD>
  • 14 <LINK>...</LINK>
  • 15 <LISTING>...</LISTING>
  • 16 <PRE>...</PRE>
  • 17 <S>...</S>
  • 18 <SAMP>...</SAMP>
  • 19 <SMALL>...</SMALL>
  • 20 <STRONG>...</STRONG>
  • 21 <SUB>...</SUB>
  • 22 <SUP>...</SUP>
  • 23 <U>...</U>
  • 24 <VAR>...</VAR>
  • 25 Смотрите также

[править] <ABBR>...</ABBR>

Сокращенная форма

Позволяет авторам явно показывать использование аббревиатур и акронимов.

[править] <ACRONYM>...</ACRONYM>

Акроним. Используется для создания условных обозначений.

Атрибуты <ACRONYM>:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Позволяет авторам явно показывать использование аббревиатур и акронимов. Встроенный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 4.0

[править] <B>...</B>

Используется для выделения текста жирным шрифтом.

Атрибуты <B> в IE:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Встроенный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.0

[править] <BIG>...</BIG>

Задает отображение текста крупным шрифтом. Атрибуты <BIG> в IE:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Встроенный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 2.0

[править] <BLOCKQUOTE>...</BLOCKQUOTE>

Форматирует текст как цитату. Текст выводится на экран с увеличенным левым полем.

Атрибуты <BLOCKQUOTE>:

  • class="Стилевой класс"
  • id="Имя"
  • lang="Код языка"
  • style="Определение встроенного стиля"

Атрибуты <BLOCKQUOTE> в IE:

  • accesskey="Клавиша-ускоритель"
  • contenteditable="inherit|true|false"
  • DISABLED
  • HIDEFOCUS
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Блочный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.0

[править] <CITE>...</CITE>

Используется для создания цитат. IE отображает цитаты курсивом.

Атрибуты <CITE> в IE:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Встроенный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.0

[править] <CODE>...</CODE>

Рекомендуется использовать для фрагментов исходного текста, помещения на страницы примеров. IE и NN отображают моноширным шрифтом.

Атрибуты <CODE> в IE:

  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • title="Текст подсказки"

Встроенный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.0

[править] <DFN>...</DFN>

Указывает, что это является определением вложенного термина.

Атрибуты <DFN>:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Встроенный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0

[править] <EM>...</EM>

Выделяет текст терминов. IE и NN отображают его курсивом.

Атрибуты <EM> в IE:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Встроенный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.0

[править] <FONT>...</FONT>

Управление параметрами текста.

Атрибуты <FONT>:

  • color="Цвет"
  • face="Имя шрифта"
  • size="Высота в пикселах"

Атрибуты <FONT> в IE:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"

Атрибуты <FONT> в NN:

  • point-size="Размер шрифта в пикселах"

Блочный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.1

[править] <BASEFONT>...</BASEFONT>

Служит для установления стандартноло размера шрифта, гарнитуры и цвета текста в документе.

Атрибуты <BASEFONT>:

  • size="Размер шрифта"

Атрибуты <BASEFONT> в IE:

  • color="Цвет"
  • face="Имя шрифта"
  • id="Имя"

Параметры, указанные в теге, действуют во всем документе, пока эти установки не будут перекрыты тегом <FONT>. После закрытия тега <FONT> характеристики <BASEFONT> вновь вступают в силу.

Одинарный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.0

[править] <I>...</I>

Используеся для выделения текста курсивом.

Атрибуты <I> в IE:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Встроенный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.0

[править] <KBD>...</KBD>

Выводит текст моноширным шрифтом.

Атрибуты <KBD> в IE:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Рекомендуется использовать для указания того, что нужно ввести с клавиатуры.

Встроенный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.0

[править] <LINK>...</LINK>

Устанавливает связь текущей страницы с другими файлами. Основное применение: обращение к ранее описаным стилям в отдельном файле. Вставляется между тегами <HEAD>

Атрибуты <LINK>:

  • href="Интернет-адрес назначения"
  • rel="Alternate|Appendix|Bookmark|Chapter |Contents|Copyright|Glossary|Help |Index|Next|Offline|Prev |Section|Shortcut Icon|Start|Stylesheet |Subsection|fontdef|stylesheet"
  • type="Тип данных MIME"

Атрибуты <LINK> в IE:

  • rev="Alternate|Appendix|Bookmark|Chapter |Contents|Copyright|Glossary|Help |Index|Next|Prev|Section |Start|Stylesheet |Subsection|"
  • id="Имя"
  • target="Имя окна или фрейма|_blank|_parent|_search|_top">

Пример:

<HEAD>
. . .
<link rel="stylesheet" type="text/css" href="MyStyle.css">
. . .
</HEAD>

Блочный одинарный тег. Обязательные атрибуты: href, задающий интернет-адрес назначения, и либо rel, указывющий, как отноститься документ с интернет-адресом href к текущей странице, либо rev, указывающий обратное отношение. Поддерживается IE начиная с 3.0 и NN начиная с 4.0

[править] <LISTING>...</LISTING>

Выводит блок текста моноширным шрифтом. Текст выводится как он есть, со всеми пробелами и т.д.

Атрибуты <LISTING> в IE:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Весь ваш текст, как он выглядит в окне редактора

Блочный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0

[править] <PRE>...</PRE>

Выводит блок текста моноширным шрифтом с сохранением всего заданного форматирования, т.е. текст выводится как он есть, со всеми пробелами и т.д.

Атрибуты <PRE>:

  • class="Стилевой класс"
  • id="Имя"
  • lang="Код языка"
  • style="Определение встроенного стиля"

Атрибуты <PRE> в IE:

  • accesskey="Клавиша-ускоритель"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"
  • wrap="soft|hard|off"

Атрибуты <PRE> в NN:

  • cols="Ширина в символах"
  • WRAP

Блочный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.0

[править] <S>...</S>

Выводит текст зачеркнутым. Все тегами будет написано перечеркнутым шрифтом.

Атрибуты <S> в IE:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Встроенный парный тег. Обязательных атрибутов не имеет. Поддерживается IE и NN начиная с 3.0

[править] <SAMP>...</SAMP>

Форматирует текст как пример исходного кода программы. Рекомендуется использовать для демонстрации образцов сообщений, выводимых на экран программами.

Атрибуты <SMAP> в IE:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Встроенный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0

[править] <SMALL>...</SMALL>

Задает отображение текста мелким шрифтом.

Атрибуты <SMALL> в IE:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Встроенный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 2.0

[править] <STRONG>...</STRONG>

Применяется для выделения текста. IE и NN отображают такой текст жирным шрифтом.

Атрибуты <STRONG> в IE:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Встроенный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.0

[править] <SUB>...</SUB>

Отображает текст нижним индексом (подстрочный индекс).

Атрибуты <SUB> в IE:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Встроенный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.0

[править] <SUP>...</SUP>

Отображает текст верхним индексом (надстрочный индекс).

Атрибуты <SUP> в IE:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Встроенный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 2.0

[править] <U>...</U>

Выводит текст подчеркнутым.

Атрибуты <U> в IE:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Встроенный парный тег. Обязательных атрибутов не имеет. Поддерживается IE и NN начиная с 2.0

[править] <VAR>...</VAR>

Используется для форматирования имен переменных и функций языков программирования. IE и NN выводят курсивом.

Атрибуты <U> в IE:

  • accesskey="Клавиша-ускоритель"
  • class="Стилевой класс"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • id="Имя"
  • lang="Код языка"
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • style="Определение встроенного стиля"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Встроенный парный тег. Обязательных атрибутов не имеет. Поддерживается IE начиная с 3.0 и NN начиная с 1.0

[править] Смотрите также

  • Алфавитный указатель атрибутов
Получено с http://spravkaweb.local/index.php/html/textstyle
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 19:19, 18 декабря 2006.
  • К этой странице обращались 168 раз.
6.72363090515


Справочник по HTML : Заголовки и названия — Справочник Web-языков

Справочник по HTML : Заголовки и названия

 |  |  |  | Структура документа
Главная | ::. | HTML | ::. | Заголовки и названия
 |  |  |  | Параграфы и строки

[править] <Hn>...</Hn>

Форматирует текст как заголовок n-ого уровня.

Атрибуты <Hn>:

  • align="left|center|right|justify";
  • class="Стилевой класс"
  • id="Имя"
  • lang="Код языка"
  • style="Определение встроенного стиля"

Атрибуты <Hn> в IE:

  • accesskey="Клавиша-ускоритель"
  • contenteditable="inherit|true|false"
  • dir="ltr|rtl"
  • DISABLED
  • HIDEFOCUS
  • language="JScript|javascript|vbs|vbscript|XML|Код языка скрипта"
  • tabindex="Порядковый номер в последовательности"
  • title="Текст подсказки"

Блочный парный тег. Обязательных атрибутов не имеет. Всего доступны шесть шровней: от &ltH1> до <H6>.

Поддерживается IE начиная с 3.0 и NN начиная с 1.0

[править] <TITLE>...</TITLE>

Определяет заголовок Web-страницы. Может применяться только в HTML-заголовке (внутри тега <HEAD>).

Атрибуты <TITLE> в IE:

  • id="Имя"
  • lang="Код языка"

Блочный парный тег. Обязательных атрибутов не имеет.

Поддерживается IE и NN начиная с 1.0

[править] Смотрите также

  • Алфавитный указатель атрибутов
Получено с http://spravkaweb.local/index.php/html/title
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 19:19, 18 декабря 2006.
  • К этой странице обращались 156 раз.
3.65381979942


Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву A — Справочник Web-языков

Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву A

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | HTML | ::. | Алфавитный указатель атрибутов | ::. | A : B : C : D : E : F : G : H : I : L : M : N : P : R : S : T : U : V : W : Z

Содержание

  • 1 above
  • 2 accesskey
  • 3 action
  • 4 align (Для <CAPTION>, <LEGEND>)
  • 5 align (Для <DIV>, <Hn>, <HR>, <P>, элементы таблицы)
  • 6 align (Для <IFRAME> и <TABLE>)
  • 7 align (Для <IMG>, <SPACER>, элементы управления, внедренные элементы)
  • 8 alink
  • 9 allowtransparency
  • 10 alt
  • 11 archive
  • 12 autocomplete

[править] above

- Задает слой, который будет перекрываться текущим слоем.

<LAYER above="{Имя слоя}">

Поддерживается NN начиная c 4.0

[править] accesskey

- Задает клавишу-ускоритель для быстрого доступа к элементу страницы.

<INPUT accesskey="{Клавиша-ускоритель}">

Например, можно присвоить клавишу-ускоритель полю ввода и при ее нажатии вместе с клавишей <ALT> поле ввода будет активизировано.

Поддерживается IE начиная с 4.0 для элементов управления и внедренных объектов и начиная с 5.0 для всех остальных элементов.

[править] action

- Задает интернет-адрес серверной программы, которой форма передаст введенные пользователем данные.

<FORM action="{Интернет-адрес серверной программы}">

Поддерживается IE начиная с 3.02 Поддерживается NN начиная с 1.0

[править] align (Для <CAPTION>, <LEGEND>)

- Задает выравнивание элемента заголовка таблицы (<CAPTION>) по отношению к таблице или пояснительной надписи (<LEGEND>) относительно группы полей.

<CAPTION align="bottom|center|left|right|top">

Для IE доступны пять значений:

  • bottom - выравнивание по нижнему краю и по центру;
  • left - выравнивание по левому краю;
  • center - выравнивание по центру;
  • right - выравнивание по правому краю;
  • top - выравнивание по верхнему краю и по центру.

В NN реализованы только значения top и bottom, значение по умолчанию top.

Поддерживается IE начиная с 3.02 для <CAPTION> и начиная с 4.0 для <LEGEND>. Поддерживается NN начиная с 1.1

[править] align (Для <DIV>, <Hn>, <HR>, <P>, элементы таблицы)

- Задает выравнивание содержимого элемента страницы.

<DIV align="left|center|right|justify">

Доступны четыре значения:

  • left - выравнивание по левой границе (по умолчанию);
  • center - выравнивание по центру (по умолчанию для <HT>);
  • right - выравнивание по правой границе;
  • justify - полное выравнивание по ширине (доступно только для <DIV>,<Hn> и <P>; NN не поддерживает это значение).

Поддерживается IE начиная с 3.02 для <COL>, <COLGROUP>,<DIV>,<HR>,<P>,<TD>,<TH>,<TR> и начиная с 4.0 для <Hn>,<TBODY>,<TFOOT>,<THEAD>.

Поддерживается NN начиная с 1.1 для <P>,<HR> и элементов таблиц, а начиная с 2.0 для <DIV>

[править] align (Для <IFRAME> и <TABLE>)

- Задает выравнивание "плавающего" фрейма (<IFRAME>) или таблицы (<TABLE>).

<TABLE align="left|center|right">

Доступны три значения:

  • left - выравнивание по левому краю доступного пространства (по умолчанию);
  • center - выравнивание по центру доступного пространства;
  • right - выравнивание по правому краю доступного пространства.

Поддерживается IE начиная с 3.02 для <TABLE> и начиная с 4.0 для <IFRAME>.

Поддерживается NN начиная с 4.0 для <TABLE>

[править] align (Для <IMG>, <SPACER>, элементы управления, внедренные элементы)

- Задает местоположение рисунка, элемента управления или внедренного элемента относительно "обтекающего" его текста.

<IMG align="left|right|top|texttop|middle|absmiddle|baseline|bottom|absbottom"> Доступны следующие значения:

  • left - элемент смещается влево, а текст обтекает его справа (значение по умолчанию);
  • right - элемент смещается вправо, а текст обтекает его слева;
  • top - вершина элемента выравнивается по верхней границе строки;
  • texttop - вершина элемента выравнивается по вершине самого высокого символа строки;
  • middle - элемент центрируется в строке;
  • absmiddle - центр элемента выравнивается точно по центру строки;
  • baseline - низ элемента выравнивается по базовой линии строки;
  • bottom - низ элемента выравнивается по низу строки;
  • absbottom - низ изображения выравнивается по низу самого низко сидящего символа строки.

Поддерживается IE начиная с 3.02 для <APPLET>, <IMG>, <INPUT>, <OBJECT> и начиная с 4.0 для <EMBED>, <FIELDSET>, <SELECT>.

Поддерживается NN начиная с 1.1; значения атрибута absmiddle, absbottom, texttop, middle и baseline реализованы начиная с 3.0 для всех элементов, кроме <EMBED> и <OBJECT>.

[править] alink

- Задает цвет активных гиперссылок в документе.

<BODY alink="{Цвет}">

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 1.0

[править] allowtransparency

- Задает прозрачность фрейма, обычного или "плавающего".

<IFRAME [allowtransparency]>

По умолчанию фон фрейма определяется отображаемой в нем Web-страницей. Если же в тег включен атрибут allowtransparency, то фон фрейма можно задать каким угодно; если же он не задан, используется цвет фона Web-страницы, где определен фрейм.

Пример использования атрибута allowtransparency:

<BODY style="background-color: red">
<IFRAME id="Frame1" src="file.html" allowtransparency="true">
</IFRAME>
<IFRAME id="Frame2" src="file.html" allowtransparency="true" style="background-color: green">
</IFRAME>
<IFRAME id="Frame3" src="file.html">
</IFRAME>
<IFRAME id="Frame4" src="file.html" style="background-color: green">
</IFRAME>
</BODY>

Фрейм Frame1 будет иметь красный фон, т.к. атрибут allowtransparency имеет значение true; красный фон страницы будет "просвечивать" сквозь него. Фрейм Frame2 будет иметь зеленый фон, т.к. атрибут allowtransparency имеет значение true, и в определении стиля задан фоновым цветом зеленый. А вот фреймы Frame3 и Frame4 будут иметь цвет фона, определяемый загруженным в них документом, т.к. атрибут allowtransparency у них имеет значение false.

И хотя в определении стиля фрейма Frame4 задан зеленый фон, это не будет иметь значения.

Поддерживается IE начиная с 5.5

[править] alt

- Задает "альтернативный" текст, отображаемый на месте изображения, если оно еще не загружено.

<IMG alt="{Альтернативный текст}">

Поддерживается IE начиная с 3.02 для <IMG> и <INPUT type="image">, а начиная с 4.0 для <AREA>.

Поддерживается NN начиная с 1.0 для <IMG> и <INPUT type="image">, а начиная с 3.0 для <APPLET>.

[править] archive

- Задает адрес архивного файла в формате ZIP, в котором находится файл Java-класса.

<APPLET archive="{Интернет-адрес архивного файла}">

Поддерживается IE начиная с 3.0

[править] autocomplete

- Задает или отменяет возможность "автозаполнения" форм и полей ввода текста.

<FORM autocomplete="on|off">

IE имеет возможность так называемого "автозаполнения" форм и полей ввода. Когда пользователь начинает вводить текст в поле, ниже появляется всплывающее меню, содержащее ранее введенные в него значения. Пользователь может выбрать значение из этого меню или ввести новое; в последнем случае оно также будет сохранено.

Формы и поля ввода текста идентифицируются их именами, заданными в атрибуте name. IE определяет по имени формы или поля ввода значения, которые были введены в них ранее.

Доступны два значения: on включает автозаполнение, а off отключает. Значения по умолчанию нет, точнее, оно зависит от настроек пользователя.

Поддерживается IE начиная с 5.0

Получено с http://spravkaweb.local/index.php/html/attribute/a
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 10:58, 16 декабря 2006.
  • К этой странице обращались 119 раз.
1.93518090248


Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву B — Справочник Web-языков

Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву B

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | HTML | ::. | Алфавитный указатель атрибутов | ::. | A : B : C : D : E : F : G : H : I : L : M : N : P : R : S : T : U : V : W : Z

Содержание

  • 1 background
  • 2 balance
  • 3 behavior
  • 4 below
  • 5 bgcolor
  • 6 bgproperties
  • 7 border (Для <EMBED>)
  • 8 border (Для <FRAMESET>, <IFRAME>)
  • 9 border (Для <IMG>, <TABLE>)
  • 10 bordercolor
  • 11 bottommargin

[править] background

- Задает фоновый рисунок для документа или таблицы.

<BODY background="{Интернет-адрес файла изображения}">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.1

[править] balance

- Задает стереобаланс при воспроизведении фонового звука с использованием тега <BGSOUND>.

<BGSOUND balance="{Значение баланса}">

Атрибут может принимать значения от -10000 (крайняя левая позиция) до 10000 (крайняя правая позиция).

Значение по умолчанию 0 (центр).

Поддерживается IE начиная с 4.0

[править] behavior

- Задает поведение прокручивающегося текста в элементе <MARQUEE>.

<MARQUEE behavior="scroll|alternate|slide">

Для этого атрибута доступно три значения:

  • scroll - задает обычную прокрутку, т.е. текст уходит в одну сторону и появляется с противоположной (значение по умолчанию);
  • alternate - заставляет текст двигаться взад-вперед;
  • slide - заставляет текст прокрутиться до конца и остановиться.

Поддерживается IE начиная с 3.02

[править] below

- Задает слой, которым будет перекрываться текущий слой.

<LAYER below="{Имя слоя}">

Поддерживается NN начиная с 4.0

[править] bgcolor

- Задает цвет фона.

<BODY bgcolor="{Цвет}">

Поддерживается IE начиная с 3.02.

Поддерживается NN начиная с 1.1 для <BODY> и <TD>, а начиная с 3.0 для <TABLE> и <TH>.

[править] bgproperties

- Задает поведение фонового рисунка документа: будет ли он прокручиваться при прокрутке содержимого или нет.

<BODY bgproperties="fixed">

Если в качестве значения этого атрибута указана пустая строка (по умолчанию), фоновый рисунок будет прокручиваться при прокрутке содержимого документа.

Если указано значение fixed, то фон прокручиваться не будет.

Поддерживается IE начиная с 3.02

[править] border (Для <EMBED>)

- Задает толщину в пикселах границы, отображаемой вокруг внедренного элемента.

<EMBED border="{Толщина границы в пикселах}">

Значение 0 убирает границу совсем.

Поддерживается NN начиная с 2.0

[править] border (Для <FRAMESET>, <IFRAME>)

- Задает толщину границы между фреймами в пикселах.

<FRAMESET border="{Толщина границы в пикселах}">

Значение 0 убирает границу совсем.

Значение по умолчанию 5.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 3.0

[править] border (Для <IMG>, <TABLE>)

- Задает толщину в пикселах границы, отображаемой вокруг рисунка или таблицы.

<IMG border="{Толщина границы в пикселах}">

Значение 0 убирает границу совсем.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.1

[править] bordercolor

- Задает цвет границы.

<TABLE bordercolor="{Цвет}">

Поддерживается IE начиная с 3.02 для таблиц и их элементов и начиная с 4.0 для фреймов.

Поддерживается NN начиная с 3.0

[править] bottommargin

- Задает расстояние от нижней границы окна Web-обозревателя до нижней границы содержимого Web-страницы в пикселах.

<BODY bottommargin="{Расстояние}">

Значение по умолчанию равно 15.

Поддерживается IE начиная с 4.0

Получено с http://spravkaweb.local/index.php/html/attribute/b
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 13:41, 16 декабря 2006.
  • К этой странице обращались 85 раз.
2.33700299263


Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву C — Справочник Web-языков

Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву C

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | HTML | ::. | Алфавитный указатель атрибутов | ::. | A : B : C : D : E : F : G : H : I : L : M : N : P : R : S : T : U : V : W : Z

Содержание

  • 1 cellpadding
  • 2 cellspacing
  • 3 challenge
  • 4 checked
  • 5 class
  • 6 classid
  • 7 clear
  • 8 clip
  • 9 code
  • 10 codebase (Для <APPLET>)
  • 11 codebase (Для <OBJECT>)
  • 12 codetype
  • 13 color
  • 14 cols (Для <FRAMESET>)
  • 15 cols (Для <MULTICOL>)
  • 16 cols (Для <PRE>)
  • 17 cols (Для <TABLE>)
  • 18 cols (Для <TEXTAREA>)
  • 19 colspan
  • 20 compact
  • 21 content
  • 22 contenteditable
  • 23 coords

[править] cellpadding

- Задает расстояние между границей и содержимым ячейки таблицы в пикселах либо в процентах от доступного пространства.

<TABLE cellpadding="{Расстояние}">

Значение по умолчанию 1.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.1

[править] cellspacing

- Задает расстояние между ячейками таблицы в пикселах либо в процентах от доступного пространства.

<TABLE cellspacing="{Расстояние}">

Значение по умолчанию 2.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.1

[править] challenge

- Задает строку вызова для тега <KEYGEN>.

<KEYGEN challenge="{Строка вызова}">

Поддерживается NN начиная с 1.0

[править] checked

- Задает включенное состояние флажка или радиокнопки.

<INPUT type="checkbox" checked>

По умолчанию все флажки и радиокнопки выключены. Чтобы включить флажок или радиокнопку, включите в тег атрибут checked.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] class

- Задает стилевой класс элемента страницы.

<DIV class="{Стилевой класс, определенный в таблице стилей}">

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 4.0

[править] classid

- Задает уникальный идентификатор класса элемента ActiveX.

<OBJECT classid="{Уникальный идентификатор класса}">

Уникальный идентификатор класса является шестнадцатеричным представлением 128-разрядного двоичного числа и используется для однозначного определения файла, в котором находится код нужного элемента ActiveX.

Уникальный идентификатор класса записывается в Реестр Windows при установке и регистрации элемента ActiveX на компьютере клиента.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 4.0

[править] clear

- Задает поведение текста, разорванного тегом <BR>, при "обтекании" им некоторых элементов страницы, таких как изображения.

<BR clear="all|left|right|none">

Доступны четыре значения:

  • all - запрещает тексту "обтекать" элемент страницы с обоих сторон;
  • left - с левой стороны;
  • right - с правой стороны;
  • none - разрешает тексту "обтекать" элемент страницы.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.1

[править] clip

- Задает прямоугольник, за пределами которого содержимое слоя не будет видно (видимая область слоя).

<LAYER clip="{X1, Y1, X2, Y2}">

Принимаемое значение представляет собой список из четырех координат в пикселах, разделенных запятыми.

Поддерживается NN начиная с 4.0

[править] code

- Задает интернет-адрес файла, содержащего откомпилированный класс Java.

<APPLET code="{Интернет-адрес файла с классом Java}">

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 2.0

[править] codebase (Для <APPLET>)

- Задает интернет-адрес папки, в которой содержится файл Java-класса.

<APPLET codebase="{Интернет-адрес дистрибутивного файла}">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0

[править] codebase (Для <OBJECT>)

- Задает интернет-адрес папки, в которой содержится дистрибутивный файл элемента ActiveX, Java-класса или расширения (plug-in) Web-обозревателя.

<OBJECT codebase="{Интернет-адрес дистрибутивного файла элемента ActiveX [#version={Номер версии элемента ActiveX}]}">

В IE значение этого атрибута может содержать номер требуемой версии элемента ActiveX.

Он имеет вид "1,2,3,4".

Пример:

<OBJECT codebase="http://www.youdomain.ru/distr/file.cab#version=1,1,0,0">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 4.0

[править] codetype

- Задает тип данных MIME элемента ActiveX.

<OBJECT codetype="{Тип данных миме}">

Поддерживается IE начиная с 3.02

[править] color

- Задает цвет шрифта или горизонтальной линии.

<FONT color="{Цвет}">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0

[править] cols (Для <FRAMESET>)

- Задает количество и значение ширины всех фреймов-колонок в наборе фреймов.

<FRAMESET cols="{Список значений ширины фреймов-колонок, разделенных запятыми}">

Значения ширины фреймов-колонок могут быть заданы как в пикселах, так и в процентах от ширины всего набора фреймов. Также может быть использовано значение *, предписывающее Web-обозревателю отвести соответствующему фрейму все оставшееся место.

<FRAMESET cols="100, 20%, *">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] cols (Для <MULTICOL>)

- Задает количество колонок, в которых будет располагаться текст.

<MULTICOL cols="{Количество колонок}">

Поддерживается NN начиная с 3.0

[править] cols (Для <PRE>)

- Задает ширину в символах текста с заданным форматом.

<PRE cols="{Ширина в символах}">

Если длина строки превысит заданную ширину, и если в тег <PRE> включен атрибут WRAP, Web-обозреватель перенесет эту строку.

Поддерживается NN начиная с 1.0

[править] cols (Для <TABLE>)

- Задает количество колонок в таблице.

<TABLE cols="{Количество колонок}">

Указание количества колонок позволяет ускорить обработку таблицы.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 3.0

[править] cols (Для <TEXTAREA>)

- Задает ширину в символах текста области редактирования.

<TEXTAREA cols="{Ширина в символах}">

Значение по умолчанию 20.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] colspan

- Задает количество ячеек, которые должны быть объединены в одну.

<TD colspan="{Количество ячеек, объединяемых в одну}">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.1

[править] compact

- Задает компактное отображение позиций списков.

<DL compact>

По умолчанию все списки отображаются в обычном режиме. Чтобы включить компактное отображение (т.е. без дополнительных пробелов), включите в тег списка атрибут compact.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 1.0

[править] content

- Задает метаданные в теге <META>.

<META content="{Метаданные}">

Тип метаданных зависит от значений атрибутов HTTP-EQUIV или NAME.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.1

[править] contenteditable

- Задает или отменяет возможность редактирования содержимого Web-страницы или ее элемента пользователем.

<DIV contenteditable="inherit|true|false">

Доступны следующие значения:

  • inherit - заставляет элемент страницы "наследовать" эту возможность от родителя (значение по умолчанию);
  • true - разрешает пользователю редактировать содержимое элемента страницы;
  • false - запрещает пользователю редактировать содержимое элемента страницы.

Если значение этого свойства равно true (или inherit, и при этом родитель допускает редактирование), пользователь сможет редактировать содержимое элемента или всей страницы, как в обычном текстовом редакторе.

Поддерживается IE начиная с 5.5

[править] coords

- Задает координаты "горячей" области в карте-изображении.

<AREA coords="{Координаты "горячей" области}">

Доступны три типа "горячих" областей:

  • rect - прямоугольник. Атрибут coords имеет формат coords="{X1}, {Y1}, {X2}, {Y2}", где X1 и Y1 - координаты верхнего левого, а X2 и Y2 - правого нижнего угла прямоугольника;
  • circle - круг. Атрибут coords имеет формат coords="{X центра}, {Y центра}, {Радиус}";
  • poly - многоугольник. Атрибут coords имеет формат coords="{X1}, {Y1}, {X2}, {Y2}, {X3}, {Y3}, ...", где Xn и Yn 0 координаты соответствующей вершины.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

Получено с http://spravkaweb.local/index.php/html/attribute/c
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 13:54, 16 декабря 2006.
  • К этой странице обращались 81 раз.
2.18011498451


Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву D — Справочник Web-языков

Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву D

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | HTML | ::. | Алфавитный указатель атрибутов | ::. | A : B : C : D : E : F : G : H : I : L : M : N : P : R : S : T : U : V : W : Z

Содержание

  • 1 data
  • 2 datafld
  • 3 dataformatas
  • 4 datapagesize
  • 5 datasrc
  • 6 defer
  • 7 dir
  • 8 direction
  • 9 disabled
  • 10 dynsrc

[править] data

- Задает интернет-адрес файла данных, требуемых элементом ActiveX.

<OBJECT data="{Интернет-адрес файла данных}">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 4.0

[править] datafld

- Задает поле таблицы базы данных, значение которого будет отображаться в элементе страницы.

<DIV datafld="{Имя поля таблицы базы данных}">

Требует задания источника данных в атрибуте datasrc.

Поддерживается IE начиная с 4.0

[править] dataformatas

- Задает представление, используемое для отображения данных из полей таблицы.

<DIV dataformatas="text|html|localized-text">

Доступны три значения:

  • text - задает текстовое представление (значение по умолчанию);
  • html - заставляет Web-обозреватель учитывать все теги HTML, встречающиеся в значениях полей;
  • localized-text - работает аналогично text, за тем исключением, что при этом используются региональные настройки Windows.

Поддерживается IE начиная с 4.0

[править] datapagesize

- Задает размер страницы данных, выводимых за один раз, в пикселах.

<TABLE datapagesize="{Размер страницы данных}">

Требуется, если нужно привязать таблицу к данным.

Поддерживается IE начиная с 4.0

[править] datasrc

- Задает объект-источник данных.

<DIV datasrc="{Имя объекта-источника данных}">

Поддерживается IE начиная с 4.0

[править] defer

- Позволяет отложить выполнение скриптов, пока Web-страница не будет загружена полностью.

<SCRIPT defer>

По умолчанию скрипты выполняются при загрузке Web-страницы. Если вы хотите отложить их выполнение до полной загрузки страницы, включите в тег нужного скрипта атрибут defer. Это может быть полезно при разработке дизайна страницы или для увеличения скорости ее загрузки.

Поддерживается IE начиная с 4.0

[править] dir

- Задает порядок чтения текста.

<DIV dir="ltr|rtl">

По умолчанию текст читается слева на право (ltr). Значение rtl позволяет задать порядок чтения справа на лево.

Для документов, составленных на европейских языках, порядок чтения всегда слева на право (ltr).

Поддерживается IE начиная с 5.0

[править] direction

- Задает направление прокрутки текста в элементе <MARQUEE>.

<MARQUEE direction="left|right|up|down">

Для этого атрибута возможны следующие значения:

  • left - текст прокручивается налево (значение по умолчанию);
  • right - направо;
  • up - вверх;
  • down - вниз.

Поддерживается IE начиная с 3.02

[править] disabled

- Запрещает доступ к элементу страницы.

<TEXTAREA disabled>

По умолчанию доступ к элементу страницы разрешен. При этом пользователь может редактировать текст в поле ввода, включать или отключать флажки и радиокнопки, выбирать пункты из списков, нажимать командные кнопки и редактировать содержимое остальных элементов страницы, если для них было задано соответствующее значение атрибута contenteditable.

Чтобы запретить доступ к элементу страницы, включите в его тег атрибут disabled.

Поддерживается IE начиная с 4.0 для элементов управления и начиная с 5.5 для остальных элементов страницы.

[править] dynsrc

- Задает интернет-адрес динамического содержимого, отображаемого вместо статического рисунка.

<IMG dynsrc="{Интернет-адрес динамического содержимого}">

Динамическим содержимым для рисунка может быть видеофильм.

Если задан этот атрибут, вместо обычного статического рисунка будет отображен видеофильм, содержащийся в файле, интернет-адрес которого был задан в этом атрибуте. Пример:

<IMG src="video.jpg" dynsrc="videofilm.avi">

Поддерживается IE начиная с 3.02

Получено с http://spravkaweb.local/index.php/html/attribute/d
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:10, 16 декабря 2006.
  • К этой странице обращались 76 раз.
2.60567498207


Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву E — Справочник Web-языков

Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву E

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | HTML | ::. | Алфавитный указатель атрибутов | ::. | A : B : C : D : E : F : G : H : I : L : M : N : P : R : S : T : U : V : W : Z

[править] enctype

- Задает метод кодирования данных, отправляемых формой в виде MIME.

<FORM enctype="{Метод кодирования данных}">

Значение по умолчанию application/x-www-form-urlencoded.

Может также использоваться значение multipart/form-data, если в форме применен элемент <INPUT type="file">.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] event

- Задает событие, к которому привязан скрипт-обработчик.

<SCRIPT event="{Тип события}">

Этот способ создания обработчиков событий специфичен для IE.

Пример:

<SCRIPT event="onclick()" for="mFunc">

Поддерживается IE начиная с 3.02

Получено с http://spravkaweb.local/index.php/html/attribute/e
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:12, 16 декабря 2006.
  • К этой странице обращались 66 раз.
1.71816301346


Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву F — Справочник Web-языков

Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву F

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | HTML | ::. | Алфавитный указатель атрибутов | ::. | A : B : C : D : E : F : G : H : I : L : M : N : P : R : S : T : U : V : W : Z

Содержание

  • 1 face
  • 2 for (Для <LABEL>)
  • 3 for (Для <SCRIPT>)
  • 4 frame
  • 5 frameboarder (Для <EMBED>)
  • 6 frameboarder (Для фреймов)
  • 7 framespacing

[править] face

- Задает имя шрифта.

<FONT face="{Имя шрифта}">

Пример:

<FONT face=&quotArial Cyr,Arial,Times New Roman"> - выбор шрифта начиная с левого.

Поддерживается IE начиная с 3.02 для <FONT> и начиная с 4.0 для <BASEFONT>.

Поддерживается NN начиная с 3.0

[править] for (Для <LABEL>)

- Задает элемент управления, к которому привязана метка <LABEL>.

<LABEL for="{Имя элемента управления}">

Поддерживается IE начиная с 4.0

[править] for (Для <SCRIPT>)

- Задает элемент страницы, к которому привязан скрипт.

<SCRIPT for="{Имя элемента страницы}">

Этот способ создания обработчиков событий специфичен для IE.

Пример:

<SCRIPT event="onclick()" for="mFunc">

Поддерживается IE начиная с 3.02

[править] frame

- Задает отображение внешних рамок таблицы.

<TABLE frame="none|above|below|hsides|lhs|rhs|vsides|box">

Доступны девять значений:

  • void - внешней рамки нет вообще (значение по умолчанию);
  • above - рисуется только верхняя линия внешней рамки;
  • below - рисуется только нижняя линия внешней рамки;
  • hsides - рисуются только горизонтальные линии внешней рамки, т.е. верхняя и нижняя;
  • lhs - рисуется только левая линия внешней рамки;
  • rhs - рисуется только правая линия внешней рамки;
  • vsides - рисуются только вертикальные линии внешней рамки, т.е. левая и правая;
  • box - рисуются все линии внешней рамки.

Поддерживается IE начиная с 3.02

[править] frameboarder (Для <EMBED>)

- Задает или отменяет отображение границы вокруг внедренного элемента.

<EMBED frameboarder="no">

По умолчанию граница вокруг внедренного элемента отображается. Чтобы убрать ее, включите в тег <EMBED> этот атрибут.

Поддерживается NN начиная с 2.0

[править] frameboarder (Для фреймов)

- Задает или отменяет отображение границ между фреймами.

<FRAMESET frameboarder="1|0|yes|no">

По умолчанию граница между фреймами отображаются (значения 1 или yes). Значения 0 или no отключают отображение границ.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 3.0 В NN не реализованы значения 1 и 0.

[править] framespacing

- Задает дополнительное пространство между фреймами в пикселах.

<FRAMESET framespacing="{Дополнительное пространство между фреймами}">

Значение по умолчанию 2.

Поддерживается IE начиная с 3.02

Получено с http://spravkaweb.local/index.php/html/attribute/f
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:17, 16 декабря 2006.
  • К этой странице обращались 69 раз.
1.8090941906


Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву G — Справочник Web-языков

Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву G

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | HTML | ::. | Алфавитный указатель атрибутов | ::. | A : B : C : D : E : F : G : H : I : L : M : N : P : R : S : T : U : V : W : Z

[править] gutter

- Задает расстояние между колонками текста в пикселах.

<MULTICOL gutter="{Расстояние между колонками}">

Значение по умолчанию 2.

Поддерживается NN начиная с 3.0

Получено с http://spravkaweb.local/index.php/html/attribute/g
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 18:10, 18 декабря 2006.
  • К этой странице обращались 68 раз.
1.25976490974


Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву H — Справочник Web-языков

Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву H

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | HTML | ::. | Алфавитный указатель атрибутов | ::. | A : B : C : D : E : F : G : H : I : L : M : N : P : R : S : T : U : V : W : Z

Содержание

  • 1 height
  • 2 hidden
  • 3 hidefocus
  • 4 href (Для <BASE>)
  • 5 href (Для <гиперссылок>)
  • 6 hspace
  • 7 http-equiv

[править] height

- Задает высоту элемента страницы в пикселах или как процент от доступного пространства.

<TABLE height="{Высота}">

Поддерживается IE начиная с 3.02 для <EMBED>, <IMG>, <MARQUEE>, <OBJECT>, <TD> и <TH>, начиная с 4.0 для <TABLE>, начиная с 5.0 для <TR> и начиная с 5.5 для <FRAME>.

Поддерживается NN начиная с 1.1

[править] hidden

- Задает или отменяет показ внедренного элемента на Web-странице.

<EMBED hidden="true|false">

По умолчанию внедренный элемент показывается на странице (значение false). Чтобы скрыть его, присвойте этому атрибуту значение true.

Поддерживается NN начиная с 2.0

[править] hidefocus

- Отменяет показ фокуса ввода (текстового курсора).

<TEXTAREA hidefocus>

По умолчанию фокус ввода всегда показывается. Чтобы скрыть его, включите в тег элемента страницы атрибут HIDEFOCUS.

Поддерживается IE начиная с 5.5

[править] href (Для <BASE>)

- Задает базовый интернет-адрес в теге <BASE>, относительно которого отсчитываются все ссылки.

<BASE href="{Базовый интернет-адрес}">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.1

[править] href (Для <гиперссылок>)

- Задает интернет-адрес назначения, куда пользователь попадает после активизации гиперссылки.

<A href="{Интернет-адрес назначения}">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.1

[править] hspace

- Задает горизонтальное расстояние от элемента страницы до окружающего его текста.

<IMG hspace="{Горизонтальный отступ}">

Значение по умолчанию 0.

Поддерживается IE начиная с 3.02 для <APPLET>, <IMG>, <INPUT type="image">, <MARQUEE> и <OBJECT> и начиная с 4.0 для <IFRAME>

Поддерживается NN начиная с 1.1

[править] http-equiv

- Задает тип метаданных, задаваемых в теге <META>.

<META http-equiv="description|refresh|url|mimetype|charset|Expires|Refresh|Set-Cookie">

Для IE доступны следующие значения:

  • description - задает описание Web-страницы;
  • refresh - задает в секундах интервал обновления Web-страницы, отображенной Web-обозревателем;
  • url - задает адрес, откуда будет загружаться Web-страница при обновлении. Требует наличие тега <META>, задающего интервал обновления (refresh);
  • mimetype - задает тип данных MIME Web-страницы (всегда text/html);
  • charset - задает кодовую страницу, использовавшуюся при написании текста.

Для NN доступны следующие значения:

  • Expires - задает дату, после которой Web-страница, сохраненная в памяти Web-обозревателя, считается устаревшей и должна быть обновлена. Если дата задана некорректно (например, "0"), страница считается устаревшей сразу после первого посещения;
  • Refresh - задает в секундах интервал обновления Web-страницы, отображенной Web-обозревателем;
  • Set-Cookie - передает Web-обозревателю cookie.

Также могут поддерживаться другие, нестандартные типы метаданных.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

Получено с http://spravkaweb.local/index.php/html/attribute/h
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 18:13, 18 декабря 2006.
  • К этой странице обращались 73 раза.
1.1454539299


Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву I — Справочник Web-языков

Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву I

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | HTML | ::. | Алфавитный указатель атрибутов | ::. | A : B : C : D : E : F : G : H : I : L : M : N : P : R : S : T : U : V : W : Z

[править] id

- Задает уникальное имя элемента страницы для доступа к нему из скрипта.

<P id="{Имя элемента страницы}">

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 4.0

[править] ismap

- Задает поведение рисунка <IMG> как карты изображения.

<IMG ismap>

По умолчанию рисунок не является картой-изображением. Чтобы сделать его картой-изображением, включите в тег атрибут ismap.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

Получено с http://spravkaweb.local/index.php/html/attribute/i
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 18:21, 18 декабря 2006.
  • К этой странице обращались 79 раз.
1.47856378555


Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву L — Справочник Web-языков

Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву L

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | HTML | ::. | Алфавитный указатель атрибутов | ::. | A : B : C : D : E : F : G : H : I : L : M : N : P : R : S : T : U : V : W : Z

Содержание

  • 1 lang
  • 2 language
  • 3 left
  • 4 leftmargin
  • 5 link
  • 6 loop (Для <BGSOUND>, <IMG>, <INPUT type="image">)
  • 7 loop (Для <MARQUEE>)
  • 8 lowsrc

[править] lang

- Задает язык, на котором набран текст.

<P lang="{Код языка}">

Список доступных кодов языка можно найти здесь.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 3.0

[править] language

- Задает язык программирования, на котором написан скрипт, привязанный к элементу страницы.

<DIV language="JScript|javascript|vbs|vbscript|XML|{Код языка скрипта}">

Доступны пять предопределенных значений:

  • JScript;
  • javascript;
  • vbs;
  • vbscript;
  • XML;

Также могут поддерживаться другие, нестандартные языки.

NN поддерживает указание после имени языка - через пробел - его версии.

Например, "javascript 1.1".

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 3.0

[править] left

- Задает горизонтальную координату левого верхнего угла слоя относительно родителя.

<LAYER left="{Координата X}">

Поддерживается NN начиная с 4.0

[править] leftmargin

- Задает расстояние от левой границы окна Web-обозревателя до левой границы содержимого Web-страницы в пикселах.

<BODY leftmargin="{Расстояние}">

Значение по умолчанию равно 10.

Поддерживается IE начиная с 4.0

[править] link

- Задает цвет гиперссылок в документе.

<BODY link="{Цвет}">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] loop (Для <BGSOUND>, <IMG>, <INPUT type="image">)

- Задает количество повторений фонового звука или видеофильма.

<BGSOUND loop="-1/0/{Количество повторений}">

Значение -1 или 0 задает бесконечное повторение.

Значение по умолчанию 1.

Поддерживается IE начиная с 3.02

[править] loop (Для <MARQUEE>)

- Задает, сколько раз в теге <MARQUEE> будет прокручиваться текст.

<MARQUEE loop="-1/0/{Количество повторений}">

Значение -1 или 0 задает бесконечное повторение.

Значение по умолчанию -1.

Поддерживается IE начиная с 3.02

[править] lowsrc

- Задает интернет-адрес файла с изображением низкого качества.

<IMG lowsrc="{Интернет-адрес файла изображения}">

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 1.0

Получено с http://spravkaweb.local/index.php/html/attribute/l
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 07:27, 20 марта 2007.
  • К этой странице обращались 90 раз.
1.34271717072


Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву M — Справочник Web-языков

Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву M

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | HTML | ::. | Алфавитный указатель атрибутов | ::. | A : B : C : D : E : F : G : H : I : L : M : N : P : R : S : T : U : V : W : Z

Содержание

  • 1 marginheight
  • 2 marginwidth
  • 3 maxlength
  • 4 mayscript
  • 5 media
  • 6 method
  • 7 methods
  • 8 multiple

[править] marginheight

- Задает в пикселях отступ по вертикали между границей фрейма и его содержимым.

<FRAME marginheight="{Отступ}">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] marginwidth

- Задает в пикселях отступ по горизонтали между границей фрейма и его содержимым.

<FRAME marginwidth="{Отступ}">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] maxlength

- Задает максимальное количество пикселей, которое пользователь может ввести в поле ввода.

<INPUT type="text" maxlength="{Максимальное количество символов}">

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 1.0

[править] mayscript

- Разрешает или запрещает доступ из скрипта к Java-апплету.

<APPLET mayscript>

По умолчанию скрипты не могут управлять Java-апплетом. Чтобы разрешить скриптам доступ к апплету, нужно включить в тег <APPLET> атрибут mayscript.

Поддерживается NN начиная с 3.0

[править] media

- Задает способ применения таблицы стилей: только для просмотра Web-страницы на экране компьютера, только для печати на принтере или и для того, и для другого.

<STYLE media="screen|print|all">

Доступны три значения:

  • screen - заставляет Web-обозреватель использовать таблицу стилей только для просмотра Web-страницы на экране;
  • print - только для печати на принтере;
  • all - и для просмотра, и для печати (значение по умолчанию).

Поддерживается IE начиная с 4.0 для <LINK> и начиная с 5.0 для <STYLE>.

[править] method

- Задает метод передачи данных формой: get или post.

<FORM method="get|post">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] methods

- Задает список методов протокола HTTP, поддерживаемых гиперссылкой.

<A methods="{Список методов HTTP, разделенных запятыми}">

Поддерживается IE начиная с 4.0

[править] multiple

- Задает возможность выбора пользователем нескольких значений в списке <SELECT>.

<SELECT multiple>

По умолчанию в списке может быть выбрано только одно значение. Чтобы дать возможность пользователю выбирать из списка одновременно несколько значений, включите в тек списка атрибут multiple.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

Получено с http://spravkaweb.local/index.php/html/attribute/m
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 18:29, 18 декабря 2006.
  • К этой странице обращались 70 раз.
1.47281503677


Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву N — Справочник Web-языков

Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву N

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | HTML | ::. | Алфавитный указатель атрибутов | ::. | A : B : C : D : E : F : G : H : I : L : M : N : P : R : S : T : U : V : W : Z

Содержание

  • 1 name (Для <A>)
  • 2 name (Для <FRAME>)
  • 3 name (Для <IMG>, элементы управления, внедренные объекты)
  • 4 name (Для <META>)
  • 5 name (Для <PARAM>)
  • 6 nohref
  • 7 noresize
  • 8 noshade
  • 9 nowrap

[править] name (Для <A>)

- Задает имя "якоря".

<A name="{Имя якоря}">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] name (Для <FRAME>)

- Задает имя фрейма.

<FRAME name="{Имя фрейма}">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0

[править] name (Для <IMG>, элементы управления, внедренные объекты)

- Задает имя элемента страницы, используемое в скриптах.

<SELECT name="{Имя}">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] name (Для <META>)

- Задает в теге <META> тип метаданных.

<META name="Author|Description|Generator|Keywords|ProgID|Robots|Template|{Тип>}">

Для IE доступно шесть предопределенных значений:

  • Description - обозначает описание Web-страницы;
  • Generation - задает имя приложения, создавшего Web-страницу;
  • Keywords - задает список ключевых слов, разделенных запятыми. Эти ключевые слова будут использоваться поисковыми машинами;
  • ProgID - идентифицирует программу для редактирования Web-страниц;
  • Robots - разрешает или запрещает индексацию Web-страницы поисковыми машинами. Доступны два значения атрибута content: all и noindex, соответственно разрешающее и запрещающее индексацию;
  • Template - задает имя файла шаблона, примененного для создания Web-страницы. Используется вместе с ProgID.

Для NN доступно три значения:

  • Description - обозначает описание Web-страницы;
  • Keywords - задает список ключевых слов, разделенных запятыми. Эти ключевые слова будут использоваться поисковыми машинами;
  • Author -указывает имя автора Web-страницы.

Также допускаются любые другие, не предопределенные типы метаданных.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] name (Для <PARAM>)

- Задает имя параметра внедренного объекта.

<PARAM name="{Имя>}">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0

[править] nohref

- Используется при создании "пустой", не привязанной ни к чему области на карте-изображении.

<AREA nohref>

По умолчанию область карты-изображения привязана к какой-то гиперссылке. Чтобы сделать "пустую" область, включите в ее тег атрибут nohref.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] noresize

- Используется при создании фрейма, размер которого не может быть изменен пользователем.

<FRAME noresize>

По умолчанию пользователь может изменять размер фрейма, перетаскивая мышью его границу. Чтобы запретить это, включите в тег фрейма атрибут noresize.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 1.0

[править] noshade

- Отключает тень у горизонтальной линейки.

<HR noshade>

По умолчанию линейка имеет трехмерный вид. Чтобы сделать ее обычной, "плоской", включите в тег <BR> атрибут NOSHADE

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.1

[править] nowrap

- Отключает автоматический перенос слова в тексте.

<TD nowrap> По умолчанию слова в тексте переносятся на новую строку автоматически, если ширина элемента страницы недостаточна для отображения строки целиком.

Чтобы отменить автоматический перенос, включите в тег атрибут nowrap.

Поддерживается IE начиная с 3.02 для <TD> и <TH> и начиная с 4.0 для <BODY>, <DD>, <DIV> и <DT>.

Поддерживается NN начиная с 1.1

Получено с http://spravkaweb.local/index.php/html/attribute/n
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 18:31, 18 декабря 2006.
  • К этой странице обращались 68 раз.
2.11735010147


Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву P — Справочник Web-языков

Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву P

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | HTML | ::. | Алфавитный указатель атрибутов | ::. | A : B : C : D : E : F : G : H : I : L : M : N : P : R : S : T : U : V : W : Z

Содержание

  • 1 pagex
  • 2 pagey
  • 3 palette
  • 4 pluginspage
  • 5 pluginurl
  • 6 point-size
  • 7 prompt

[править] pagex

- Задает горизонтальную координату левого верхнего угла слоя относительно окна Web-обозревателя.

<LAYER pagex="{Координата X}">

Поддерживается NN начиная с 4.0

[править] pagey

- Задает вертикальную координату левого верхнего угла слоя относительно окна Web-обозревателя.

<LAYER pagey="{Координата Y}">

Поддерживается NN начиная с 4.0

[править] palette

- Задает цветовую палитру Windows, которую будет использовать внедренный элемент.

<EMBED palette="foregroud|background">

По умолчанию внедренный элемент выбирает фоновую палитру (значение background).

Чтобы заставить его прибегнуть к основной палитре, используемой для отображения содержимого страницы, задайте этому атрибуту значение foreground.

Поддерживается NN начиная с 2.0

[править] pluginspage

- Задает интернет-адрес Web-страницы, содержащей инструкции по инсталяции расширения Web-обозревателя.

<EMBED pluginspage="{Интернет-адрес инструкций по инсталяции}">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0

[править] pluginurl

- Задает интернет-адрес дистрибутивного файла расширения Web-обозревателя.

<EMBED pluginurl="{Интернет-адрес дистрибутивного файла расширения}">

Рекомендуется использовать вместо pluginspage.

Поддерживается NN начиная с 4.0

[править] point-size

- Задает размер шрифта в пикселах.

<FONT point-size="{Размер шрифта в пикселах}">

Поддерживается NN начиная с 4.0

[править] prompt

- Задает подсказку для тега <ISINDEX>.

<ISINDEX prompt="{Подсказка}">

Поддерживается NN начиная с 1.1

Получено с http://spravkaweb.local/index.php/html/attribute/p
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 18:33, 18 декабря 2006.
  • К этой странице обращались 64 раза.
1.76867794991


Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву R — Справочник Web-языков

Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву R

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | HTML | ::. | Алфавитный указатель атрибутов | ::. | A : B : C : D : E : F : G : H : I : L : M : N : P : R : S : T : U : V : W : Z

Содержание

  • 1 readonly
  • 2 rel
  • 3 rev
  • 4 rightmargin
  • 5 rows (Для <FRAMESET>)
  • 6 rows (Для <TEXTAREA>)
  • 7 rowspan
  • 8 rules

[править] readonly

- Делает невозможным редактирование текста в поле ввода.

<TEXTAREA readonly>

По умолчанию пользователь имеет возможность редактировать текст в поле ввода.

Если вы хотите сделать этот текст нередактируемым, включите в тег поля ввода атрибут readonly.

Обратите внимание: при этом поле ввода останется разрешенным для доступа; пользователь сможет выделять и копировать из него текст (readonly не то же самое, что disabled).

Поддерживается IE начиная с 4.0

[править] rel

- Задает связь между текущей Web-страницей и той, на которую указывает гиперссылка.

<LINK rel="Alternate|Appendix|Bookmark|Chapter|Contents|Copyright|Glossary|Help |Index|Next|Offline|Prev|Section|Shortcut Icon|Start|Stylesheet|Subsection|fontdef|stylesheet">

Для IE доступно семнадцать возможных значений:

  • Alternate - гиперссылка указывает на страницу, заменяющую текущую;
  • Appendix - на приложение к большому многостраничному документу;
  • Bookmark - на закладку;
  • Chapter - на отдельную часть большого многостраничного документа;
  • Contents - на содержание большого многостраничного документа (данная связь указывает на некий файл, где приводится оглавление к данному документу);
  • Copyright - на соглашение об авторских правах (данная связь ссылается на текст, где указаны авторские права на данный документ);
  • Glossary - на словарь терминов, используемых в большом многостраничном документе (данная связь указывает на некий документ, где содержится глоссарий терминов, относящихся к текущему документу);
  • Help - на справочную страницу (данная связь указывает на документ, предлагающий некую помощь, например это может быть текст, дающий более развернутое описание и предлагающий ссылки на другие документы по этой теме. Назначение этой связи - оказание помощи тем читателям, кто потерял свой путь в Web);
  • Index - на список всех страниц большого многостраничного документа (данная связь указывает на другой документ, который можно использовать в целях индексного поиска по текущему документу);
  • Next - на следующую страницу в последовательности (данная связь указывает на следующий документ в неком заранее предопределенном маршруте просмотра. Например, она может использоваться для упреждающей автоматической загрузки браузером следующей страницы);
  • Offline - на CDF-файл "канала";
  • Prev - на предыдущий документ в последовательности (данная связь ссылается на предыдущий документ в неком предопределенном маршруте просмотра);
  • Section - на отдельную часть большого многостраничного документа;
  • Shortcut Icon - на файл закачки, используемого для обозначения ссылки на текушую страницу;
  • Start - на первый документ в последовательности;
  • Stylesheet - на таблицу стилей;
  • Subsection - на отдельный подраздел большого многостраничного документа.

NN поддерживает только два возможных значения:

  • fontdef - гиперссылка указывает на файл загруженного шрифта;
  • stylesheet - на таблицу стилей.

Поддерживается IE начиная с 3.02 для <A> и начиная с 4.0 для <A>

Поддерживается NN начиная с 4.0

[править] rev

- Аналогичен REL, но направлен в обратную сторону, т.е. сообщает, чем текущая страница является для той, на которую указывает гиперссылка.

<LINK rev="Alternate|Appendix|Bookmark|Chapter|Contents|Copyright|Glossary| Help|Index|Next|Prev|Section|Start|Stylesheet|Subsection|">

Для IE доступно пятнадцать возможных значений:

  • Alternate - страница, заменяющая другую;
  • Appendix - приложение к большому многостраничному документу;
  • Bookmark - закладка;
  • Chapter - отдельная часть большого многостраничного документа;
  • Contents - содержание большого многостраничного документа;
  • Copyright - соглашение об авторских правах;
  • Glossary - словарь терминов, используемых в большом многостраничном документе;
  • Help - справочная страница;
  • Index - список всех страниц большого многостраничного документа;
  • Next - следующая страница в последовательности;
  • Prev - предыдущая страница в последовательности;
  • Section - отдельная часть большого многостраничного документа;
  • Start - первый документ в последовательности;
  • Stylesheet - таблицу стилей;
  • Subsection - отдельный подраздел большого многостраничного документа.

Поддерживается IE начиная с 3.02 для <A> и начиная с 4.0 для <A>

[править] rightmargin

- Задает расстояние от правой границы окна Web-обозревателя до правой границы содержимого Web-страницы в пикселах.

<BODY rightmargin="{Расстояние}">

Значение по умолчанию равно 10.

Поддерживается IE начиная с 4.0

[править] rows (Для <FRAMESET>)

- Задает количество и высоту фреймов-строк в наборе фреймов.

<FRAMESET rows="{Список значений высоты фреймов-строк, разделенных запятыми}">

Значения высоты фреймов-строк могут быть заданы как в пикселах, так и в процентах от высоты всего набора фреймов.

Также может быть использовано значение *, предписывающее Web-обозревателю отвести соответствующему фрейму все оставшееся место.

Пример:

<FRAMESET rows="20, 40%, *">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] rows (Для <TEXTAREA>)

- Задает высоту области редактирования в строках текста.

<TEXTAREA rows="{Высота в строках}">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] rowspan

- Задает количество строк в столбце, которые должны быть объединены в одну.

<TD rowspan="{Количество строк, объединяемых в одну}">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.1

[править] rules

- Задает отображение внутренних рамок таблицы.

<TABLE rules="none|rows|cols|groups|all">

Доступны пять значений:

  • none - внутренних рамок нет совсем;
  • rows - рисуются только горизонтальные линии;
  • lols - рисуются только вертикальные линии;
  • groups - рисуются вертикальные линии между группами колонок <COLGROUP> и горизонтальные линии между секциями <THEAD>, <TBODY> и <TFOOT>;
  • all - рисуются все внутренние рамки.

Поддерживается IE начиная с 4.0

Получено с http://spravkaweb.local/index.php/html/attribute/r
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 18:37, 18 декабря 2006.
  • К этой странице обращались 71 раз.
1.57916808128


Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву S — Справочник Web-языков

Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву S

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | HTML | ::. | Алфавитный указатель атрибутов | ::. | A : B : C : D : E : F : G : H : I : L : M : N : P : R : S : T : U : V : W : Z

Содержание

  • 1 scroll
  • 2 scrollamount
  • 3 scrolldelay
  • 4 scrolling
  • 5 selected
  • 6 shape
  • 7 size (Для <BASEFONT>, <FONT>)
  • 8 size (Для <HR>)
  • 9 size (Для <SPACER>)
  • 10 size (Для элементов управления)
  • 11 span
  • 12 src (Для <APPLET>, <BGSOUND>, <EMBED>, <XML>, фреймы, рисунки, слои)
  • 13 src (Для <LINK>)
  • 14 src (Для <SCRIPT>)
  • 15 start (Для <IMG>)
  • 16 start (Для <OL>)
  • 17 style
  • 18 suppress

[править] scroll

- Задает, будет ли окно Web-обозревателя иметь полосы прокрутки.

<BODY scroll="yes|no|auto">

Доступны три значения:

  • yes - полосы прокрутки есть всегда, даже если они не нужны (по умолчанию);
  • no - полос прокрутки нет, даже если содержимое Web-страницы не помещается в окно;
  • auto - полосы прокрутки появляются только тогда, когда в них ести необходимость.

Поддерживается IE начиная с 4.0

[править] scrollamount

- Задает шаг в пикселах, на который будет смещаться текст в <MARQUEE> за один раз.

<MARQUEE scrollamount="{Шаг в пикселах}">

Значение по умолчанию 6.

Поддерживается IE начиная с 3.02

[править] scrolldelay

- Задает задержку в миллисекундах перед каждым шагом прокрутки текста в <MARQUEE>.

<MARQUEE scrolldelay="{Задержка в миллисекундах}">

Значение по умолчанию 85.

Поддерживается IE начиная с 3.02

[править] scrolling

- Задает, будет ли прокручиваться при необходимости содержимое фрейма.

<FRAME scrolling="yes|no|auto">

Для атрибута доступно три значения:

  • yes - будет прокручиваться (появятся полосы прокрутки);
  • no - не будет прокручиваться (полосы прокрутки не появятся, даже если в них возникнет необходимость);
  • auto - полосы прокрутки появятся только тогда, когда в них есть необходимость (значение по умолчанию).

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] selected

- Задает, будет ли текущий пункт списка выбран изначально.

<OPTION selected>

По умолчанию в списке будет выбран первый пункт.

Если вы хотите, чтобы был выбран другой пункт, включите в его тек атрибут selected.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] shape

- Задает форму "горячей" области на карте-изображении.

<AREA shape="circ|circle|poly|polygon|rect|rectangle">

Для атрибута доступны следующие значения:

  • circ (или circle) - круг;
  • poly (или polygon) - многоугольник;
  • rect (или rectangle) - прямоугольник.

Координаты "горячей" области задаются в атрибуте coords.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] size (Для <BASEFONT>, <FONT>)

- Задает размер шрифта от 1 (минимальный) до 7 (максимальный).

<FONT size="{Размер шрифта}">

Значение по умолчанию 3.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] size (Для <HR>)

- Задает высоту горизонтальной линейки в пикселах.

<HR size="{Высота в пикселах}">

Значение по умолчанию 2.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.1

[править] size (Для <SPACER>)

- Задает величину дополнительного расстояния, добавляемого между символами в строке или между строками в абзаце, в зависимости от значения атрибута type.

<SPACER size="{Дополнительное расстояние}">

Значение задается в пикселах.

Поддерживается NN начиная с 3.0

[править] size (Для элементов управления)

- Задает размер элемента управления.

<INPUT type="text" size="{Размер в символах}">

<SELECT size="{Количество одновременно видимых пунктов}">

Если атрибут применяется к полю ввода, его размер указывается в символах текста.

Если атрибут применяется к списку или всплывающему меню - размер указывается в пунктах.

Во всех остальных случаях никак не влияет на внешний вид элемента управления.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] span

- Задает количество колонок, на которое распространяется действие параметров, заданных в тегах <COL> или <COLGROUP>.

<COLGROUP span="{Количество колонок}">

Значение по умолчанию 1.

Поддерживается IE начиная с 3.02

[править] src (Для <APPLET>, <BGSOUND>, <EMBED>, <XML>, фреймы, рисунки, слои)

- Задает интернет-адрес файла, содержащего загружаемый элемент страницы.

<APPLET src="{Интернет-адрес файла с Java-апплетом}">

<IMG src="{Интернет-адрес файла рисунка}">

Загружаемым элементом страницы может быть: Java-апплет, данные, обрабатываемые с помощью расширения Web-обозревателя, содержимое фрейма или слоя, фоновый звук или рисунок.

Поддерживается IE начиная с 3.02 для <BGSOUND>, <EMBED>, <FRAME>, <IFRAME> и <IMG>, начиная с 4.0 для <APPLET> и <INPUT type="image">, а начиная с 5.0 для <XML>.

Поддерживается NN начиная с 1.0 для <FRAME>, <IMG> и <INPUT type="image">, начиная с 2.0 для <EMBED>, а начиная с 4.0 для <ILAYER> и <LAYER>.

[править] src (Для <LINK>)

- Задает интернет-адрес файла, на который ссылается текущая страница.

<LINK src="{Интернет-адрес файла}">

Поддерживается NN начиная с 4.0

[править] src (Для <SCRIPT>)

- Задает интернет-адрес файла с текстом скрипта.

<SCRIPT src="{Интернет-адрес файла с текстом скрипта}">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 3.0

[править] start (Для <IMG>)

- Задает момент, с которого начнет воспроизводиться видеоклип, имя файла которого было задано в атрибуте dynsrc.

<IMG start="fileopen|mouseover">

Для этого атрибута доступно два значения:

  • fileopen - запускает клип сразу после его загрузки (значение по умолчанию);
  • mouseover - запускает клип только после того, как пользователь разместит над ним курсор мыши.

Поддерживается IE начиная с 3.02

[править] start (Для <OL>)

- Задает начальную позицию нумерации элементов пронумерованного списка <OL>.

<OL start="(Начальный номер}">

Значение по умолчанию 1.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.1

[править] style

- Задает встроенный стиль для элемента страницы.

<DIV style="{Определение встроенного стиля}">

Поддерживается IE начиная с 3.02 для текстовых элементов страницы и начиная с 4.0 для нетекстовых (рисунки, фреймы, расширения и т.п.).

Поддерживается NN начиная с 4.0

[править] suppress

- Включает или отключает отображение "альтернативного" текста и значка в левом правом углу рамки, когда изображение еще не загружено.

<IMG suppress="true|false">

По умолчанию и "альтернативный" текст, и значек отображаются (значение false).

Если вы хотите убрать их, присвойте этому атрибуту значение true.

Поддерживается NN начиная с 4.0

Получено с http://spravkaweb.local/index.php/html/attribute/s
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 18:45, 18 декабря 2006.
  • К этой странице обращались 67 раз.
1.39601802826


Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву T — Справочник Web-языков

Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву T

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | HTML | ::. | Алфавитный указатель атрибутов | ::. | A : B : C : D : E : F : G : H : I : L : M : N : P : R : S : T : U : V : W : Z

Содержание

  • 1 tabindex
  • 2 target
  • 3 text
  • 4 title
  • 5 title (Для <STYLESHEET>)
  • 6 top
  • 7 topmargin
  • 8 truespeed
  • 9 type (Для <BUTTON>)
  • 10 type (Для <EMBED>, <LINK>, <OBJECT>)
  • 11 type (Для <INPUT>)
  • 12 type (Для <LI>, <OL>, <UL>)
  • 13 type (Для <SCRIPT>)
  • 14 type (Для <SPACER>)
  • 15 type (Для <STYLE>)

[править] tabindex

- Задает номер в последовательности обхода элементов управления при нажатии клавиши <TAB>.

<TEXTAREA tabindex="{Порядковый номер в последовательности}">

Значение по умолчанию 0.

Если значения tabindex одинаковы или вообще не заданы, обход выполняется в порядке появления элементов управления в исходном тексте Web-страницы. Если задано отрицательное значение, элемент управления исключается из последовательности.

Поддерживается IE начиная с 4.0 для элементов управления и начиная с 5.0 для остальных элементов страницы. Отрицательные значения атрибута поддерживаются начиная с 5.01

[править] target

- Задает имя фрейма или окна Web-обозревателя, куда будет загружена Web-страница, указанная в гиперссылке.

<A target="{Имя окна или фрейма}|_blank|_parent|_search|_self|_top">

Кроме собственного имени окна или фрейма доступны также пять предопределенных значений:

  • _blank - загружает Web-страницу в новое окно;
  • _parent - загружает Web-страницу в родительское окно;
  • _search - загружает Web-страницу в панель поиска Web-обозревателя (доступно в IE начиная с версии 5.0);
  • _self - загружает Web-страницу в то же самое окно (по умолчанию);
  • _top - загружает Web-страницу в самое верхнее окно в иерархии.

Поддерживается IE начиная с 3.02 для <A>, <AREA>, <BASE> и <FORM>, а начиная с 4.0 для <LINK>.

Поддерживается NN начиная с 2.0

[править] text

- Задает цвет текста документа.

<BODY text="{Цвет}">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] title

- Задает текст "всплывающей" подсказки для элемента страницы. Эта подсказка появляется при наведении на элемент курсора мыши.

<P title="{Текст подсказки}">

Поддерживается IE начиная с 4.0

[править] title (Для <STYLESHEET>)

- Задает заголовок для таблицы стилей.

<STYLESHEET title="{Текст заголовка}">

Используется только для идентификации таблицы стилей.

Поддерживается IE начиная с 4.0

[править] top

- Задает вертикальную координату левого верхнего угла слоя относительно родителя.

<LAYER top="{Координата Y}">

Поддерживается NN начиная с 4.0

[править] topmargin

- Задает расстояние от верхней границы окна Web-обозревателя до верхней границы содержимого Web-страницы в пикселах.

<BODY topmargin="{Расстояние}">

Значение по умолчанию равно 15.

Поддерживается IE начиная с 3.02

[править] truespeed

- Задает способ вычисления нового положения прокручиваемого текста в <MARQUEE>.

<MARQUEE truespeed>

По умолчанию новое положение вычисляется каждые 60 миллисекунд, независимо от значений атрибутов scrollamount и scrolldelay.

Если вы хотите, чтобы новое положение текста вычислялось каждые {scrolldelay} миллисекунд (более точно), включите в тег атрибут truespeed. При этом текст будет двигаться более плавно, но прокрутка будет отнимать больше ресурсов у компьютера.

Поддерживается IE начиная с 4.0

[править] type (Для <BUTTON>)

- Задает тип кнопки <BUTTON>.

<BUTTOM type="button|reset|submit">

Для этого атрибута доступно три значения:

  • button - обыкновенная кнопка (значение по умолчанию);
  • reset - кнопка сброса формы;
  • submit - кнопка отправки на сервер данных формы.

Поддерживается IE начиная с 4.0

[править] type (Для <EMBED>, <LINK>, <OBJECT>)

- Задает тип данных MIME элемента ActiveX.

<OBJECT type="{Тип данных MIME}">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0 для <EMBED> и начиная с 4.0 для <LINK> и <OBJECT>.

[править] type (Для <INPUT>)

- Задает тип элемента управления: кнопка, флажок, поле ввода или что-то другое.

<INPUT type="button|checkbox|file|hidden|image|password|radio|reset|submit|text">

Для этого атрибута доступны следующие значения:

  • button - обычная командная кнопка;
  • checkbox - флажок;
  • file - поле ввода имени файла и кнопка открыть. Позволяет отправить файл на Web-сервер;
  • hidden - "скрытое" поле. Оно не как не отображается в форме, но его значение посылается вместе с остальными данными. Может использоваться, например, для уникальной идентификации Web-страницы;
  • image - изображение. Аналогично по действию кнопке submit;
  • password - текстовое поле для ввода паролей. Вводимый текст отображается в виде звездочек;
  • radio - радиокнопка (кнопка-переключатель);
  • reset - командная кнопка, аналогичная button, при нажатии на которую вся форма очищается. Называется также кнопкой reset;
  • submit - командная кнопка, аналогичная button, при нажатии на которую происходит отправка серверу данных, введенных в форму. Называется также кнопкой submit;
  • text - поле ввода.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0

[править] type (Для <LI>, <OL>, <UL>)

- Задает тип маркера и тип нумерации нумерованного списка.

<OL type="A|a|I|i|1">

<UL type="disc|circle|square">

Для нумерованного списка <OL> доступны пять значений:

  • A - нумерует позиции списка большими латинскими буквами;
  • a - малыми латинскими буквами;
  • I - большими римскими буквами;
  • i - малыми римскими буквами;
  • 1 - арабскими цифрами (значение по умолчанию).

Для маркировки списка <UL> доступны три значения:

  • disk - маркирует позиции списка сплошным кружком (значение по умолчанию);
  • circle - окружностью без заливки;
  • square - квадратиком.

Поддерживается IE начиная с 3.02 для <LI> и <OL> и начиная с 4.0 для <UL>.

Поддерживается NN начиная с 1.0 для <LI> и начиная с 1.1 для <ol> и <UL>.

[править] type (Для <SCRIPT>)

- Задает тип интерпретатора (виртуальной машины) скриптового языка в стандарте MIME.

<SCRIPT type="{Тип интерпретатора в стандарте MIME}">

Тип интерпретатора должен соответствовать языку, указанному атрибутом language.

Для этого атрибута доступно шесть значений:

  • text/ecmascript - ECMAScript;
  • text/Jscript - Microsoft JScript;
  • text/javascript - Microsoft JScript;
  • text/vbs - Microsoft VBScript;
  • text/vbscript - Microsoft VBScript;
  • text/xml - XML.

Поддерживается IE начиная с 4.0

[править] type (Для <SPACER>)

- Задает тип дополнительного свободного пространства, размещаемого на странице.

<SPACER type="horizontal|vertical|block"> Дополнительное свободное пространство - может быть дополнительным пространством между символами в строке, между строками или просто прямоугольное пространство, подобное невидимому изображению.

Для этого атрибута доступно три значения:

  • horizontal - добавляет дополнительное пространство между символами в строке. Используйте атрибут size для его задания;
  • vertical - добавляет дополнительное пространство между строками в абзаце. Используйте атрибут size для его задания;
  • block - размещает на странице невидимый прямоугольник. Используйте атрибуты align, height и width для задание его параметров.

Поддерживается NN начиная с 3.0

[править] type (Для <STYLE>)

- Задает тип таблицы стилей в стандарте MIME.

<STYLE type="{Тип данных MIME}">

Для таблицы стилей он должен быть равен text/css.

NN также поддерживает таблицы стилей JavaScript; для них значение этого атрибута будет равно text/javascript.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 4.0

Получено с http://spravkaweb.local/index.php/html/attribute/t
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 18:51, 18 декабря 2006.
  • К этой странице обращались 78 раз.
1.79159784317


Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву U — Справочник Web-языков

Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву U

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | HTML | ::. | Алфавитный указатель атрибутов | ::. | A : B : C : D : E : F : G : H : I : L : M : N : P : R : S : T : U : V : W : Z

[править] units

- Задает единицу измерения ширины и высоты внедренного объекта <EMBED>.

<EMBED units="px|em">

Доступно два значения:

  • px - задает пикселы в качестве единицы измерения;
  • em - задает в качестве единицы измерения ширину и высоту символа текущего шрифта.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0

[править] urn

- Задает имя сетевого ресурса (Uniform Resource Name).

<A urn="{Имя сетевого ресурса}">

Поддерживается IE начиная с 4.0

[править] usemap

- Задает имя (и, возможно, интернет-адрес) списка "горячих" областей для карты-изображения.

<IMG usemap="{Интернет-адрес и имя списка "горячих" областей}">

Пример:

<MAP name="somemap">
. . . Список "горячих" областей
</MAP>
<IMG usemap="#somemap" id=idImg src="someimage.gif">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

Получено с http://spravkaweb.local/index.php/html/attribute/u
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 18:53, 18 декабря 2006.
  • К этой странице обращались 58 раз.
1.28189301491


Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву V — Справочник Web-языков

Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву V

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | HTML | ::. | Алфавитный указатель атрибутов | ::. | A : B : C : D : E : F : G : H : I : L : M : N : P : R : S : T : U : V : W : Z

Содержание

  • 1 valign (Для <CAPTION>)
  • 2 valign (Для элементов таблицы)
  • 3 value (Для <LI>)
  • 4 value (Для <OPTION>)
  • 5 value (Для <PARAM>)
  • 6 value (кнопки)
  • 7 value (скрытое поле)
  • 8 value (текстовые поля)
  • 9 value (флажки и радиокнопки)
  • 10 vcard_name
  • 11 visibility
  • 12 vlink
  • 13 volume
  • 14 vspace

[править] valign (Для <CAPTION>)

- Задает местонахождение заголовка таблицы: вверху или внизу.

<CAPTION valign="top|bottom">

Доступны два значения:

  • top - помещает заголовок вверху таблицы (значение по умолчанию);
  • bottom - внизу таблицы.

Поддерживается IE начиная с 4.0

[править] valign (Для элементов таблицы)

- Задает вертикальное выравнивание текста в таблице и ее элементах.

<TD valign="middle|baseline|bottom|top">

Доступны следующие значения:

  • middle - выравнивает текст посередине элемента таблицы (значение по умолчанию);
  • baseline - выравнивает базовую линию первой строки по базовой линии элемента таблицы;
  • bottom - выравнивает текст по низу элемента таблицы;
  • top - по верху элемента таблицы.

Поддерживается IE начиная с 3.02 для <TD> и <TR> и начиная с 4.0 для <COL>, <COLGROUP>, <TBODY>, <TFOOT>, <TH> и <THEAD>.

Поддерживается NN начиная с 1.1

[править] value (Для <LI>)

- Задает номер позиции нумерованного списка.

<LI value="{Номер}">

По умолчанию Web-обозреватель сам нумерует позиции списка.

Поддерживается IE начиная с 3.02

[править] value (Для <OPTION>)

- Задает значение, которое будет послано формой серверу.

<OPTION value="{Значение для передачи серверной программе}">

По умолчанию, если атрибут value не указан, форма передает серверной программе значение, помещенное в теге <OPTION>.

Если атрибут value указан, форма передаст его значение.

Пример:

<SELECT>
<OPTION>Красный</OPTION>
<OPTION value="yellow">Желтый</OPTION>
<OPTION>Зеленый</OPTION>
</SELECT>

Если пользователь выберет первый или третий пункты списка, будут переданы соответственно значения Красный и Зеленый. Если пользователь выберет второй пункт, будет передано значение yellow

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] value (Для <PARAM>)

- Задает значение параметра внедренного объекта.

<PARAM value="{Значение}">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0

[править] value (кнопки)

- Задает надпись, помещаемую на кнопке.

<INPUT type="reset" value="{Надпись}">

Надпись, помещаемая на кнопке по умолчанию, зависит от программы Web-обозревателя.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] value (скрытое поле)

- Задает значение, посылаемое серверной программе скрытым полем.

<INPUT type="hidden" value="{Значение}">

Значения по умолчанию нет.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] value (текстовые поля)

- Задает начальное значение, помещаемое в текстовом поле.

<INPUT type="text" value="{Начальное значение}">

По умолчанию текстовое поле пусто.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] value (флажки и радиокнопки)

- Задает значение, которое форма отправит серверной программе, если пользователь включит флажок или радиокнопку.

<INPUT type="checkbox" value="{Значение}">

По умолчанию для флажка посылается значение on, если он выбран. Для радиокнопки значение по умолчанию отсутствует.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] vcard_name

- Задает значение одного из свойств объекта vCard (сведений о пользователе) для использования во всплывающем списке автозаполнения полей ввода.

<INPUT type="text" vcard_name="{Свойство объекта vCard}">

Далее перечислены все доступные свойства этого атрибута:

  • vCard.Business.City - город, где расположено место работы;
  • vCard.Business.Country - страна, где расположено место работы;
  • vCard.Business.Fax - номер факса места работы;
  • vCard.Business.Phone - номер телефона места работы;
  • vCard.Business.State - Шатат, область или территория, где расположено место работы;
  • vCard.Business.StreetAddress - адрес по улице места работы;
  • vCard.Business.URL - адрес Web-страницы места работы;
  • vCard.Business.Zipcode - почтовый индекс места работы;
  • vCard.Cellular - номер сотового телефона;
  • vCard.Company - название фирмы, предприятия или учреждения;
  • vCard.Departmen - название отдела фирмы, предприятия или учреждения;
  • vCard.DisplayName - имя, которое будет отображаться в списке адресов адресной книги;
  • vCard.Email - адрес электронной почты;
  • vCard.FirstName - имя;
  • vCard.Gender - пол;
  • vCard.Home.City - город проживания;
  • vCard.Home.Country - страна проживания;
  • vCard.Home.Fax - номер домашнего факса;
  • vCard.Home.Phone - номер домашнего телефона;
  • vCard.Home.State - штат, область или территория, где расположено место проживания;
  • vCard.Home.StreetAddress - адрес места проживания;
  • vCard.Home.Zipcode - почтовый индекс места проживания;
  • vCard.Homepage - адрес домашней Web-страницы;
  • vCard.JobTitle - название должности;
  • vCard.LastName - фамилия;
  • vCard.MiddleName - отчество;
  • vCard.Notes - примечания;
  • vCard.Office - местонахождение места работы;
  • vCard.Pager - номер пейджера.

Поддерживается IE начиная с 5.0

[править] visibility

- Задает видимость или невидимость слоя.

<LAYER visibility="show|hidden|inherit">

Для этого атрибута доступно три значения:

  • show - делает слой видимым;
  • hidden - делает слой невидимым;
  • inherit - "наследует" видимость или невидимость от слоя-родителя или самого документа (значение по умолчанию).

Поддерживается NN начиная с 4.0

[править] vlink

- Задает цвет посещенных гиперссылок в документе.

<BODY vlink="{Цвет}">

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 1.0

[править] volume

- Задает громкость проигрывания звука <BGSOUND>.

<BGSOUND volume="{Громкость}">

Значение громкости может быть от -10000 до 0 (полная громкость).

Поддерживается IE начиная с 4.0

[править] vspace

- Задает вертикальное расстояние в пикселах от элемента страницы до окружающего его текста.

<IMG vspace="{Вертикальный отступ}">

Поддерживается IE начиная с 3.02 для <APPLET>, <IMG>, <INPUT type="image">, <MARQUEE> и <OBJECT>, а начиная с 4.0 для <IFRAME>.

Поддерживается NN начиная с 1.1

Получено с http://spravkaweb.local/index.php/html/attribute/v
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:01, 18 декабря 2006.
  • К этой странице обращались 74 раза.
1.60099101067


Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву W — Справочник Web-языков

Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву W

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | HTML | ::. | Алфавитный указатель атрибутов | ::. | A : B : C : D : E : F : G : H : I : L : M : N : P : R : S : T : U : V : W : Z

Содержание

  • 1 weight
  • 2 width
  • 3 wrap (Для <PRE>)
  • 4 wrap (Для <TEXTAREA>)

[править] weight

- Задает "жирность" шрифта от 100 (самый светлый) до 900 (самый жирный).

<FONT weight="{Жирность шрифта}">

Значение по умолчанию 300.

Поддерживается NN начиная с 4.0

[править] width

- Задает ширину элемента страницы либо в пикселах, либо в процентах от доступного пространства.

<TABLE width="{Ширина}">

Если встречается в теге <MULTICOL>, то задает ширину отдельной колонки.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 1.1

[править] wrap (Для <PRE>)

- Включает перенос строк текста с заданным форматом в теге <PRE>.

<PRE wrap>

По умолчанию строки текста с заданным форматом не переносятся.

Если вы хотите, чтобы они переносились, включите в тег атрибут wrap.

Поддерживается IE начиная с 5.5

Поддерживается NN начиная с 1.0

[править] wrap (Для <TEXTAREA>)

- Задает перенос строк в области редактирования.

<TEXTAREA wrap="soft|hard|off">

Доступны три значения:

  • soft - включает перенос строк, и при этом не вставляются символы возврата каретки (значение по умолчанию);
  • hard - включает перенос строк и заставляет область редактирования вставлять в нужные места результирующего текста символы возврата каретки;
  • off - отключается перенос строк.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 2.0

Получено с http://spravkaweb.local/index.php/html/attribute/w
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:02, 18 декабря 2006.
  • К этой странице обращались 65 раз.
1.55085897446


Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву Z — Справочник Web-языков

Справочник по HTML : Алфавитный указатель атрибутов : Атрибуты HTML на букву Z

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | HTML | ::. | Алфавитный указатель атрибутов | ::. | A : B : C : D : E : F : G : H : I : L : M : N : P : R : S : T : U : V : W : Z

[править] z-index

- Задает порядок перекрытия слоев.

<LAYER z-index="{Номер в порядке перекрытия}">

Слои с большим значением этого атрибута перекрывают слои с меньшим значением.

Поддерживается NN начиная с 4.0

Получено с http://spravkaweb.local/index.php/html/attribute/z
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:03, 18 декабря 2006.
  • К этой странице обращались 73 раза.
1.49527192116


Приложения HTML : Коды и обозначения символов в HTML — Справочник Web-языков

Приложения HTML : Коды и обозначения символов в HTML

Главная | ::. | HTML | ::. | Приложения HTML | ::. | Коды и обозначения символов
 |  |  |  |  |  | Коды и названия цветов

[править] Коды и обозначения символов в HTML

Название | Символ | HTML-код
Меньше | < | &lt;
Больше | > | &gt;
Амперсанд | & | &amp;
Кавычка | " | &quot;
Пробел | " " | &nbsp;
Торговый знак | ® | &reg;
Фунт | £ | &pound;
Параграф | § | &sect;
Копирайт | © | &copy;
Вторая степень | ² | &sup2;
Третья степень | ³ | &sup3;
Плюс-минус | ± | &plusmn;
Градус | ° | &deg;
Надчеркивание | ¯ | &macr;
Дробь 1/4 | ¼ | &frac14;
Дробь 1/2 | ½ | &frac12;
Дробь 3/4 | ¾ | &frac34;
Перевернутый вопросительный знак | ¿ | &iquest;
Французкая кавычка справо | » | &raquo;
Французкая кавычка слево | « | &laquo;
Порядковое числительное мужского рода | º | &ordm;
Порядковое числительное женского рода | ª | &ordf;
Мю | µ | &micro;
Не/Нет | ¬ | &not;
Точки умлаута | ¨ | &uml;
Иена | ¥ | &yen;
Цент | ¢ | &cent;
Получено с http://spravkaweb.local/index.php/html/pril/chars
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 07:27, 20 марта 2007.
  • К этой странице обращались 103 раза.
1.41237401962


Приложения HTML : Коды и названия цветов в HTML — Справочник Web-языков

Приложения HTML : Коды и названия цветов в HTML

 |  |  |  |  |  | Коды и обозначения символов
Главная | ::. | HTML | ::. | Приложения HTML | ::. | Коды и названия цветов
 |  |  |  |  |  | Коды языков HTML

[править] Коды и названия цветов в HTML

Пример | RGB-код | Эквивалентное название | Название цвета
 | #000000 | black | Черный
 | #000080 | navy | Темно-синий
 | #00008B | darkblue | Темно-голубой
 | #0000CD | mediumblue | Умеренно-голубой
 | #0000FF | blue | Голубой
 | #006400 | darkgreen | Темно-зеленый
 | #008000 | green | Зеленый
 | #008080 | teal | Чайный
 | #008B8B | darkcyan | Темный циан
 | #00BFFF | deepskyblue | Темный небесно-синий
 | #00CED1 | darkturquoise | Темно-бирюзовый
 | #00FA9A | mediumspringgreen | Умеренный синевато-серый
 | #00FF00 | lime | Известковый
 | #00FF7F | springgreen | Весенний зеленый
 | #00FFFF | aqua | Синий
 | #191970 | midnightblue | Ночной синий
 | #1E90FF | dodgerblue | Тускло-васильковый
 | #20B2AA | lightseagreen | Светлый морской волны
 | #228B22 | forestgreen | Лесной зеленый
 | #2E8B57 | seagreen | Морской волны
 | #2F4F4F | darkslategray | Темный синевато-серый
 | #32CD32 | limegreen | Зеленовато-известковый
 | #3CB371 | mediumseagreen | Умеренный морской волны
 | #40E0D0 | turquoise | Бирюзовый
 | #4169E1 | royalblue | Королевский голубой
 | #4682B4 | steelblue | Голубовато-стальной
 | #483D8B | darkslateblue | Темный серовато-синий
 | #48D1CC | mediumturquoise | Умеренно-бирюзовый
 | #4B0082 | indigo | Индиго
 | #556B2F | darkolivegreen | Темно-оливковый
 | #5F9EA0 | cadetblue | Блеклый серо-голубой
 | #6495ED | cornflowerblue | Васильковый
 | #66CDAA | mediumaaquamarine | Умеренно-аквамариновый
 | #696969 | dimgray | Тускло-серый
 | #6A5ACD | slateblue | Серовато-синий
 | #6B8E23 | olivedrab | Тускло-коричневый
 | #708090 | slategray | Синевато-серый
 | #778899 | lightslategray | Светлый синевато-серый
 | #7B68EE | mediumslateblue | Умеренный серовато-синий
 | #7CFC00 | lawngreen | Зеленой травы
 | #7FFF00 | chartreuse | Фисташковый
 | #7FFFD4 | aquamarine | Аквамарин
 | #800000 | maroon | Оранжево-розовый
 | #800080 | purple | Пурпурный
 | #808000 | olive | Оливковый
 | #808080 | gray | Серый
 | #87CEEB | skyblue | Небесно-голубой
 | #87CEFA | lightskyblue | Светлый небесно-синий
 | #8A2BE2 | blueviolet | Светло-фиолетовый
 | #8B0000 | darkred | Темно-красный
 | #8B008B | darkmagenta | Темный фуксин
 | #8B4513 | saddlebrown | Старой кожи
 | #8FBC8F | darkseagreen | Темный морской волны
 | #9370DB | mediumpurple | Умеренно-пурпурный
 | #9400D3 | darkviolet | Темно-фиолетовый
 | #98FB98 | palegreen | Бледно-зеленый
 | #9932CC | darkorchid | Темно-орхидейный
 | #9ACD32 | yellowgreen | Желто-зеленый
 | #9CEE90 | lightgreen | Светло-зеленый
 | #A0522D | sienna | Охра
 | #A52A2A | brown | Коричневый
 | #A9A9A9 | darkgray | Темно-серый
 | #ADD8E6 | lightblue | Светло-голубой
 | #ADFF2F | greenyellow | Желто-зеленый
 | #AFEEEE | paleturquise | Бледно-бирюзовый
 | #B0C4DE | lightsteelblue | Светло-стальной
 | #B0E0E6 | powderblue | Туманно-голубой
 | #B22222 | firebrick | Огнеупорного кирпича
 | #B8860B | darkgoldenrod | Темный красно-золотой
 | #BA55D3 | mediumorchid | Умеренно-орхидейный
 | #BC8F8F | rosybrown | Розово-коричневый
 | #BDB76B | darkkhaki | Темный хаки
 | #C0C0C0 | silver | Серебристый
 | #C71585 | mediumvioletred | Умеренный красно-фиолетовый
 | #CD5C5C | indianred | Ярко-красный
 | #CD853F | peru | Коричневый
 | #D2691E | chocolate | Шоколадный
 | #D2B48C | tan | Желтовато-коричневый
 | #D3D3D3 | lightgray | Светло-серый
 | #D8BFD8 | thistle | Чертополоха
 | #DA70D6 | orchid | Орхидейный
 | #DAA520 | goldenrod | Красного золота
 | #DB7093 | plaevioletred | Бледный красно-фиолетовый
 | #DC143C | cornsilk | Малиновый
 | #DCDCDC | fainsboro | Светлый серо-фиолетовый
 | #DDA0DD | plum | Сливовый
 | #DEB887 | burlywood | Старого дерева
 | #E0FFFF | lightcyan | Светлый циан
 | #E6E6FA | lavender | Бледно-лиловый
 | #E9967A | darksalmon | Темный оранжево-розовый
 | #EE82EE | violet | Фиолетовый
 | #EEE8AA | palegoldenrod | Бледно-золотой
 | #F08080 | lightcoral | Светло-коралловый
 | #F0E68C | khaki | Хаки
 | #F0F8FF | aliceBlue | Блекло-голубой
 | #F0FFF0 | honeydew | Свежего меда
 | #F0FFFF | azure | Лазурь
 | #F4A460 | sandybrown | Рыже-коричневый
 | #F5DEB3 | wheat | Пшеничный
 | #F5F5DC | beige | Бежевый
 | #F5F5F5 | whitesmoke | Белый дымчатый
 | #F5FFFA | mintcream | Мятно-кремовый
 | #F8F8FF | ghostwhite | Туманно-белый
 | #FA8072 | salmon | Оранжево-розовый
 | #FAEBD7 | antuqueWhite | Античный белый
 | #FAF0E6 | linen | Льняной
 | #FDF5E6 | oldlace | Старого коньяка
 | #FF00FF | fuchsia | Фуксия
 | #FF1493 | deeppink | Темно-розовый
 | #FF4500 | orangered | Красно-оранжевый
 | #FF6347 | tomato | Томатный
 | #FF69B4 | hotpink | Ярко-розовый
 | #FF7F50 | coral | Коралловый
 | #FF8C00 | darkorange | Темно-оранжевый
 | #FFA07A | lightsalmon | Светлый оранжево-розовый
 | #FFA500 | orange | Оранжевый
 | #FFB6C1 | lightpink | Светло-розовый
 | #FFC0CB | pink | Розовый
 | #FFD700 | gold | Золотой
 | #FFDAB9 | peachpuff | Персиковый
 | #FFDEAD | navajowhite | Грязно-серый
 | #FFE4B5 | moccasin | Болотный
 | #FFE4C4 | bisque | Бисквитный
 | #FFE4E1 | mistyrose | Туманно-розовый
 | #FFEBCD | blanchedalmond | Светло-кремовый
 | #FFEFD5 | papayaawhip | Дыни
 | #FFF0F5 | lavenderblush | Бледный розово-лиловый
 | #FFF5EE | seashell | Морской пены
 | #FFF8DC | cornsilk | Темно-зеленый
 | #FFFACD | lemonchiffon | Лимонный
 | #FFFAF0 | floralwhite | Цветочно-белый
 | #FFFAFA | snow | Снежный
 | #FFFF00 | yellow | Желтый
 | #FFFFE0 | lightyellow | Светло-желтый
 | #FFFFF0 | ivory | Слоновой кости
 | #FFFFFF | white | Белый
Получено с http://spravkaweb.local/index.php/html/pril/color
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 10:06, 18 марта 2007.
  • К этой странице обращались 109 раз.
1.30112981796


Приложения HTML : Коды языков HTML — Справочник Web-языков

Приложения HTML : Коды языков HTML

 |  |  |  |  |  | Коды и названия цветов
Главная | ::. | HTML | ::. | Приложения HTML | ::. | Коды языков HTML

[править] Коды языков HTML

В этой таблице перечислены все коды языков, которые доступны для использования в атрибуте lang.

Албанский | sq
Английский | en
Английский (Австралия) | en-au
Английский (Белиз) | en-bz
Английский (Великобритания) | en-gb
Английский (Ирландия) | en-ie
Английский (Канада) | en-ca
Английский (Новая Зеландия) | en-nz
Английский (США) | en-us
Английский (Тринидад) | en-tt
Английский (Южная африка) | en-za
Английский (Ямайка) | en-jm
Арабский (Алжир) | ar-dz
Арабский (Бахрейн) | ar-bh
Арабский (Египет) | ar-eg
Арабский (Иордания) | ar-jo
Арабский (Ирак) | ar-iq
Арабский (Йемен) | ar-ye
Арабский (Катар) | ar-qa
Арабский (Кувейт) | ar-kw
Арабский (Ливан) | ar-lb
Арабский (Ливия) | ar-ly
Арабский (Марокко) | ar-ma
Арабский (ОАЕ) | ar-ae
Арабский (Оман) | ar-om
Арабский (Саудовская Аравия) | ar-sa
Арабский (Сирия) | ar-sy
Арабский (Тунис) | ar-tn
Африкаанс | af
Баскский | eu
Белорусский | be
Болгарский | bg
Венгерский | hu
Венда | ve
Вендский | sb
Вьетнамский | vi
Голландский | nl
Голландский (Бельгия) | nl-be
Греческий | el
Гэльский (Ирландия) | gd-ie
Гэльский (Шотландия) | gd
Датский | da
Зулусский | zu
Иврит | he
Идиш | ji
Индонезийский | in
Исландский | is
Испанский | es
Испанский (Аргентина) | es-ar
Испанский (Боливия) | es-bo
Испанский (Венесуэла) | es-ve
Испанский (Гватемала) | es-gt
Испанский (Гондурас) | es-hn
Испанский (Доминиканская республика) | es-do
Испанский (Колумбия) | es-co
Испанский (Коста-Рика) | es-cr
Испанский (Мексика) | es-mx
Испанский (Никарагуа) | es-ni
Испанский (Панама) | es-pa
Испанский (Парагвай) | es-py
Испанский (Перу) | es-pe
Испанский (Пуэрто-Рико) | es-pr
Испанский (Сальвадор) | es-sv
Испанский (Уругвай) | es-uy
Испанский (Чили) | es-cl
Испанский (Эквадор) | es-ec
Итальянский | it
Итальянский (Швейцария) | it-ch
Каталонский | ca
Китайский (Аомынь) | zh-cn
Китайский (Гонконг, КНР) | zh-hk
Китайский (Сингапур) | zh-sg
Китайский (Тайвань) | zh-tw
Корейский | ko
Коса | xh
Латышский | lv
Литовский | lt
Македонский | mk
Малайский | ms
Мальтийский | mt
Немецкий | de
Немецкий (Австрия) | de-at
Немецкий (Лихтенштейн) | de-li
Немецкий (Люксембург) | de-lu
Немецкий (Швейцария) | de-ch
Норвежский | no
Польский | pl
Португальский | pt
Португальский (Бразилия) | pt-br
Ретороманский | rm
Румынский | ro
Румынский (Молдавия) | ro-mo
Русский | ru
Русский (Молдавия) | ru-mo
Саамский (лапландский) | sz
Сербский | sr
Словацкий | sk
Словенский | sl
Суто | sx
Тайский | th
Тсвана | tn
Тсонга | ts
Турецкий | tr
Украинский | uk
Урду | ur
Фарерский | fo
Фарси | fa
Финский | fi
Французский | fr
Французский (Бельгия) | fr-be
Французский (Канада) | fr-ca
Французский (Люксембург) | fr-lu
Французский (Швейцария) | fr-ch
Хинди | hi
Хорватский | hr
Чешский | cs
Шведский | sv
Шведский (Финляндия) | sv-fi
Эстонский | et
Японский | ja
Получено с http://spravkaweb.local/index.php/html/pril/lang
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 10:24, 18 марта 2007.
  • К этой странице обращались 115 раз.
1.28651785851


Советы по HTML : Внедрение элементов в html-страницу — Справочник Web-языков

Советы по HTML : Внедрение элементов в html-страницу

Главная | ::. | HTML | ::. | Советы HTML | ::. | Внедрение элементов в html-страницу

[править] Внедрение элементов в html-страницу

  • Как вставить в html-страницу документы MS Office (Word, Excel и т.д.)
Получено с http://spravkaweb.local/index.php/html/sovet/obj
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 06:44, 3 марта 2007.
  • К этой странице обращались 89 раз.
1.34558081627


Советы по HTML : Внедрение элементов в html-страницу : Как вставить в html-страницу документы MS Office (Word, Excel и т.д.) — Справочник Web-языков

Советы по HTML : Внедрение элементов в html-страницу : Как вставить в html-страницу документы MS Office (Word, Excel и т.д.)

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | HTML | ::. | Советы HTML | ::. | Внедрение элементов в html-страницу | ::. | Как вставить в html-страницу документы MS Office (Word, Excel и т.д.)

Вставить документы Оффиса можно при помощи плавающего фрейма <IFRAME>. Для этого достаточно указать только адрес вставляемого документа и размеры фрейма. Если размеры фрейма не указывать, то документ вставиться во всю свою ширину (что наверняка займет весь экран).

Вставить в html-страницу документ Microsoft Word можно следующей строкой:

<iframe src="document.doc" width=200 height=500>

По аналогии можно вставить в html-страницу документ Microsoft Excel:

<iframe src="table.xls" width=200 height=500>

Это может быть полезно, например, если на страницах нужно выложить часто обновляемые прайсы, а переводить их в html-вид затруднительно.

Однако, на мой взгляд, перебарщивать с этим не стоит, т.к. обычно файлы офиса достаточно много "весят", а это для многих пользователей может быть решающим фактором.

Получено с http://spravkaweb.local/index.php/html/sovet/obj/msoffice
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 06:41, 3 марта 2007.
  • К этой странице обращались 63 раза.
1.55226898193


images/5/5e/Download spravkaweb ru chm.zip — Справочник Web-языков

images/5/5e/Download spravkaweb ru chm.zip

В настоящий момент текст на данной странице отсутствует. Вы можете найти упоминание данного названия в других статьях или создать страницу с таким названием.
Получено с http://spravkaweb.local/index.php/images/5/5e/Download_spravkaweb_ru_chm.zip
Просмотры
  • Статья
  • Обсуждение
  • Править
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Загрузить файл
  • Спецстраницы
Rambler's Top100 Powered by MediaWiki
  • Политика конфиденциальности
  • Описание Справочник Web-языков
  • Отказ от ответственности
1.15808701515


images/5/5e/images/5/5e/Download spravkaweb ru chm.zip — Справочник Web-языков

images/5/5e/images/5/5e/Download spravkaweb ru chm.zip

В настоящий момент текст на данной странице отсутствует. Вы можете найти упоминание данного названия в других статьях или создать страницу с таким названием.
Получено с http://spravkaweb.local/index.php/images/5/5e/images/5/5e/Download_spravkaweb_ru_chm.zip
Просмотры
  • Статья
  • Обсуждение
  • Править
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Загрузить файл
  • Спецстраницы
Rambler's Top100 ������ ����������� Powered by MediaWiki
  • Политика конфиденциальности
1.43128490448


images/5/5e/images/5/5e/images/5/5e/images/5/5e/Download spravkaweb ru chm.zip — Справочник Web-языков

images/5/5e/images/5/5e/images/5/5e/images/5/5e/Download spravkaweb ru chm.zip

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
В настоящий момент текст на данной странице отсутствует. Вы можете найти упоминание данного названия в других статьях или создать страницу с таким названием.
Получено с http://spravkaweb.local/index.php/images/5/5e/images/5/5e/images/5/5e/images/5/5e/Download_spravkaweb_ru_chm.zip
Просмотры
  • Статья
  • Обсуждение
  • Править
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Загрузить файл
  • Спецстраницы
Rambler's Top100 ������ ����������� Powered by MediaWiki
  • Политика конфиденциальности
1.49850487709


images/5/5e/images/5/5e/images/5/5e/images/5/5e/images/5/5e/images/5/5e/images/5/5e/images/5/5e/Download spravkaweb ru chm.zip — Справочник Web-языков

images/5/5e/images/5/5e/images/5/5e/images/5/5e/images/5/5e/images/5/5e/images/5/5e/images/5/5e/Download spravkaweb ru chm.zip

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
В настоящий момент текст на данной странице отсутствует. Вы можете найти упоминание данного названия в других статьях или создать страницу с таким названием.
Получено с http://spravkaweb.local/index.php/images/5/5e/images/5/5e/images/5/5e/images/5/5e/images/5/5e/images/5/5e/images/5/5e/images/5/5e/Download_spravkaweb_ru_chm.zip
Просмотры
  • Статья
  • Обсуждение
  • Править
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Загрузить файл
  • Спецстраницы
Rambler's Top100 ������ ����������� Powered by MediaWiki
  • Политика конфиденциальности
1.39184999466


images/9/96/download spravkaweb ru chm.tar.gz — Справочник Web-языков

images/9/96/download spravkaweb ru chm.tar.gz

В настоящий момент текст на данной странице отсутствует. Вы можете найти упоминание данного названия в других статьях или создать страницу с таким названием.
Получено с http://spravkaweb.local/index.php/images/9/96/download_spravkaweb_ru_chm.tar.gz
Просмотры
  • Статья
  • Обсуждение
  • Править
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Загрузить файл
  • Спецстраницы
Rambler's Top100 Powered by MediaWiki
  • Политика конфиденциальности
  • Описание Справочник Web-языков
  • Отказ от ответственности
2.06826281548


images/9/96/images/9/96/download spravkaweb ru chm.tar.gz — Справочник Web-языков

images/9/96/images/9/96/download spravkaweb ru chm.tar.gz

В настоящий момент текст на данной странице отсутствует. Вы можете найти упоминание данного названия в других статьях или создать страницу с таким названием.
Получено с http://spravkaweb.local/index.php/images/9/96/images/9/96/download_spravkaweb_ru_chm.tar.gz
Просмотры
  • Статья
  • Обсуждение
  • Править
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Загрузить файл
  • Спецстраницы
Rambler's Top100 ������ ����������� Powered by MediaWiki
  • Политика конфиденциальности
0.972461938858


images/9/96/images/9/96/images/9/96/images/9/96/download spravkaweb ru chm.tar.gz — Справочник Web-языков

images/9/96/images/9/96/images/9/96/images/9/96/download spravkaweb ru chm.tar.gz

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
В настоящий момент текст на данной странице отсутствует. Вы можете найти упоминание данного названия в других статьях или создать страницу с таким названием.
Получено с http://spravkaweb.local/index.php/images/9/96/images/9/96/images/9/96/images/9/96/download_spravkaweb_ru_chm.tar.gz
Просмотры
  • Статья
  • Обсуждение
  • Править
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Загрузить файл
  • Спецстраницы
Rambler's Top100 ������ ����������� Powered by MediaWiki
  • Политика конфиденциальности
1.07657504082


images/9/96/images/9/96/images/9/96/images/9/96/images/9/96/images/9/96/images/9/96/images/9/96/download spravkaweb ru chm.tar.gz — Справочник Web-языков

images/9/96/images/9/96/images/9/96/images/9/96/images/9/96/images/9/96/images/9/96/images/9/96/download spravkaweb ru chm.tar.gz

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
В настоящий момент текст на данной странице отсутствует. Вы можете найти упоминание данного названия в других статьях или создать страницу с таким названием.
Получено с http://spravkaweb.local/index.php/images/9/96/images/9/96/images/9/96/images/9/96/images/9/96/images/9/96/images/9/96/images/9/96/download_spravkaweb_ru_chm.tar.gz
Просмотры
  • Статья
  • Обсуждение
  • Править
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Загрузить файл
  • Спецстраницы
Rambler's Top100 ������ ����������� Powered by MediaWiki
  • Политика конфиденциальности
0.754860877991


images/b/b0/Download spravkaweb ru many files.tar.gz — Справочник Web-языков

images/b/b0/Download spravkaweb ru many files.tar.gz

В настоящий момент текст на данной странице отсутствует. Вы можете найти упоминание данного названия в других статьях или создать страницу с таким названием.
Получено с http://spravkaweb.local/index.php/images/b/b0/Download_spravkaweb_ru_many_files.tar.gz
Просмотры
  • Статья
  • Обсуждение
  • Править
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Загрузить файл
  • Спецстраницы
Rambler's Top100 Powered by MediaWiki
  • Политика конфиденциальности
  • Описание Справочник Web-языков
  • Отказ от ответственности
1.69064378738


images/b/b0/images/b/b0/Download spravkaweb ru many files.tar.gz — Справочник Web-языков

images/b/b0/images/b/b0/Download spravkaweb ru many files.tar.gz

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
В настоящий момент текст на данной странице отсутствует. Вы можете найти упоминание данного названия в других статьях или создать страницу с таким названием.
Получено с http://spravkaweb.local/index.php/images/b/b0/images/b/b0/Download_spravkaweb_ru_many_files.tar.gz
Просмотры
  • Статья
  • Обсуждение
  • Править
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Загрузить файл
  • Спецстраницы
Rambler's Top100 ������ ����������� Powered by MediaWiki
  • Политика конфиденциальности
0.967429876328


images/b/b0/images/b/b0/images/b/b0/images/b/b0/Download spravkaweb ru many files.tar.gz — Справочник Web-языков

images/b/b0/images/b/b0/images/b/b0/images/b/b0/Download spravkaweb ru many files.tar.gz

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
В настоящий момент текст на данной странице отсутствует. Вы можете найти упоминание данного названия в других статьях или создать страницу с таким названием.
Получено с http://spravkaweb.local/index.php/images/b/b0/images/b/b0/images/b/b0/images/b/b0/Download_spravkaweb_ru_many_files.tar.gz
Просмотры
  • Статья
  • Обсуждение
  • Править
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Загрузить файл
  • Спецстраницы
Rambler's Top100 ������ ����������� Powered by MediaWiki
  • Политика конфиденциальности
1.43928813934


images/b/b0/images/b/b0/images/b/b0/images/b/b0/images/b/b0/images/b/b0/images/b/b0/images/b/b0/Download spravkaweb ru many files.tar.gz — Справочник Web-языков

images/b/b0/images/b/b0/images/b/b0/images/b/b0/images/b/b0/images/b/b0/images/b/b0/images/b/b0/Download spravkaweb ru many files.tar.gz

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
В настоящий момент текст на данной странице отсутствует. Вы можете найти упоминание данного названия в других статьях или создать страницу с таким названием.
Получено с http://spravkaweb.local/index.php/images/b/b0/images/b/b0/images/b/b0/images/b/b0/images/b/b0/images/b/b0/images/b/b0/images/b/b0/Download_spravkaweb_ru_many_files.tar.gz
Просмотры
  • Статья
  • Обсуждение
  • Править
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Загрузить файл
  • Спецстраницы
Rambler's Top100 ������ ����������� Powered by MediaWiki
  • Политика конфиденциальности
1.42906284332


images/f/fb/Download spravkaweb ru many files.zip — Справочник Web-языков

images/f/fb/Download spravkaweb ru many files.zip

В настоящий момент текст на данной странице отсутствует. Вы можете найти упоминание данного названия в других статьях или создать страницу с таким названием.
Получено с http://spravkaweb.local/index.php/images/f/fb/Download_spravkaweb_ru_many_files.zip
Просмотры
  • Статья
  • Обсуждение
  • Править
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Загрузить файл
  • Спецстраницы
Rambler's Top100 Powered by MediaWiki
  • Политика конфиденциальности
  • Описание Справочник Web-языков
  • Отказ от ответственности
1.51098608971


images/f/fb/images/f/fb/Download spravkaweb ru many files.zip — Справочник Web-языков

images/f/fb/images/f/fb/Download spravkaweb ru many files.zip

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
В настоящий момент текст на данной странице отсутствует. Вы можете найти упоминание данного названия в других статьях или создать страницу с таким названием.
Получено с http://spravkaweb.local/index.php/images/f/fb/images/f/fb/Download_spravkaweb_ru_many_files.zip
Просмотры
  • Статья
  • Обсуждение
  • Править
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Загрузить файл
  • Спецстраницы
Rambler's Top100 ������ ����������� Powered by MediaWiki
  • Политика конфиденциальности
1.21734881401


images/f/fb/images/f/fb/images/f/fb/images/f/fb/Download spravkaweb ru many files.zip — Справочник Web-языков

images/f/fb/images/f/fb/images/f/fb/images/f/fb/Download spravkaweb ru many files.zip

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
В настоящий момент текст на данной странице отсутствует. Вы можете найти упоминание данного названия в других статьях или создать страницу с таким названием.
Получено с http://spravkaweb.local/index.php/images/f/fb/images/f/fb/images/f/fb/images/f/fb/Download_spravkaweb_ru_many_files.zip
Просмотры
  • Статья
  • Обсуждение
  • Править
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Загрузить файл
  • Спецстраницы
Rambler's Top100 ������ ����������� Powered by MediaWiki
  • Политика конфиденциальности
1.22905087471


images/f/fb/images/f/fb/images/f/fb/images/f/fb/images/f/fb/images/f/fb/images/f/fb/images/f/fb/Download spravkaweb ru many files.zip — Справочник Web-языков

images/f/fb/images/f/fb/images/f/fb/images/f/fb/images/f/fb/images/f/fb/images/f/fb/images/f/fb/Download spravkaweb ru many files.zip

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
В настоящий момент текст на данной странице отсутствует. Вы можете найти упоминание данного названия в других статьях или создать страницу с таким названием.
Получено с http://spravkaweb.local/index.php/images/f/fb/images/f/fb/images/f/fb/images/f/fb/images/f/fb/images/f/fb/images/f/fb/images/f/fb/Download_spravkaweb_ru_many_files.zip
Просмотры
  • Статья
  • Обсуждение
  • Править
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Загрузить файл
  • Спецстраницы
Rambler's Top100 ������ ����������� Powered by MediaWiki
  • Политика конфиденциальности
1.15129780769


Справочник по JavaScript : Алфавитный указатель событий браузера — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель событий браузера

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель событий браузера
onActivate
- Наступает, когда элемент страницы получает фокус ввода.
onAbort
- Наступает, когда пользователь прерывает загрузку графического изображения.
onAfterPrint
- Наступает сразу после вывода на принтер или предварительный просмотр текущей Web-страницы.
onAfterUpdate
- Событие наступает после того, как данные будут перенесены из элемента управления в соответствующее поле базы данных.
onBeforeCopy
- Наступает перед копированием данных из текущего элемента страницы в буфер обмена Windows.
onBeforeCut
- Наступает перед переносом данных из текущего элемента страницы в буфер обмена Windows.
onBeforeDeactivate
- Наступает перед потерей фокуса текущим элементом страницы.
onBeforeEditFocus
- Наступает перед переходом элемента страницы в режим редактирования.
onBeforePaste
- Наступает непосредственно перед вставкой данных из буфера обмена в текущий элемент страницы.
onBeforePrint
- Наступает перед выводом на принтер или предварительным просмотром текущей Web-страницы.
onBeforeUnload
- Возникает перед выгрузкой страницы при переходе на другую страницу или закрытия окна.
onBeforeUpdate
- Наступает перед переносом данных из элемента управления в соответствующее поле базы данных.
onBlur
- Событие приосходит при переходе фокуса с этого элемента с помощью курсора мышки или последовательности перехода.
onBounce
- Срабатывает, когда бегущаяя строка достигла границы и меняет направление.
onCellChange
- Событие наступает, когда изменяются данные, находящиеся в базе данных.
onChange
- Событи происходит при потере управляющим элементом фокуса ввода, если его значение было изменено с момента получения фокуса.
onClick
- Событие происходит при однократном щелчке левой кнопки мышки на элементе, при нажатии клавиши <Enter> на форме, использовании клавиши-ускорителя или выборе пункта в списке.
onContextMenu
- Наступает при щелчке правой кнопкой мыши по элементу страницы, перед выводом контекстного меню.
onControlSelect
- Это событие наступает при попытки пользователя выбрать элемент страницы, имеющий собственный пользовательский интерфейс.
onCopy
- Наступает при копировании данных из текущего элемента страницы в буфер обмена Windows.
onCut
- Событие наступает при переносе данных из текущего элемента страницы в буфер обмена Windows.
onDatAvailable
- Наступает каждый раз, когда очередная партия данных переносится из базы данных на Web-страницу.
onDataSetChanged
- Событие наступает, когда данные в базе данных изменяются, а также когда начальная порция данных готова для переноса на Web-страницу.
onDataSetComplete
- Событие наступает, когда все данные перенесены из базы данных на Web-страницу.
onDblClick
- Событие происходит при двойном щелчке левой кнопкой мышки на элементе.
onDeactivate
- Наступает при потере фокуса текущим элементом страницы.
onDrag
- Наступает во время операции drag-n-drop в элементе-источнике.
onDragDrop
- Событие наступает, когда пользователь "бросает" в окно Web-обозревателя ссылки на интернет-адреса.
onDragEnd
- Событие наступает, когда пользователь отпускает кнопку мыши, завершая операцию drag-n-drop, в элементе-источнике.
onDragEnter
- Событие наступает, когда пользователь перетаскивает данные в допустимое место, в элементе-цели.
onDragLeave
- Событие наступает, когда пользователь перетаскивает данные из допустимого места, в элементе-цели.
onDragOver
- Событие наступает во время операции drag-n-drop в элементе-цели, когда пользователь перетаскивает данные над допустимым местом.
onDragStart
- Событие наступает, когда пользователь начинает перетаскивать данные, в элементе-источнике.
onDrop
- Событие наступает, когда пользователь отпускает кнопку мыши, завершая операцию drag-n-drop, в элементе-цели.
onError
- Событие происходит при ошибке загрузки документа или графического изображения.
onErrorUpdate
- Событие наступает, если при переносе измененных данных в базу данных происходит ошибка.
onFilterChange
- Событие наступает, когда визуальный фильтр изменяет свое состояние или когда визуальное преобразование заканчивает свою работу.
onFinish
- Событие наступает, когда очередной цикл движения текста в теге <MARQUEE> завершается.
onFocus
- Событие происходит при получении элементом фокуса с помощью мышки или последовательного перехода.
onHelp
- Возникает при нажатии клавиши F1.
onKeyDown
- Событие происходит при нажатии клавиши на клавиатуре.
onKeyPress
- Событие происходит при нажатии и отпускании клавиши на клавиатуре.
onKeyUp
- Событие происходит при отпускании клавиши на клавиатуре.
onLayoutComplete
- Событие наступает, когда Web-страница уже готова для печати на принтере или предварительного просмотра.
onLoad
- Событие происходит, когда "браузер" заканчивает загружать окно или все фреймы элемента <FRAMESET>.
onLoseCapture
- Событие наступает, когда когда элемент страницы перестает перехватывать все события мыши.
onMouseDown
- Событие происходит при нажатии кнопки мышки на элементе.
onMouseEnter
- Событие наступает, когда пользователь помещает курсор мыши на элемент страницы.
onMouseLeave
- Событие наступает, когда пользователь убирает курсор мыши с элемента страницы.
onMouseMove
- Событие наступает, когда пользователь перемещает курсор мыши над элементом страницы.
onMouseOut
- Событие происходит при перемещении курсора мышки за пределы элемента.
onMouseOver
- Событие происходит при наведении курсора мыши на элемент.
onMouseUp
- sСобытие происходит при отпускании кнопки мышки на элементе.
onMove
- Событие наступает, когда пользователь перемещает окно Web-обозревателя или изменяет размера фрейма.
onPaste
- Событие наступает при вставке данных из буфера обмена Windows в текущий элемент страницы.
onPropertyChange
- Событие наступает при изменении одного из свойств текущего элемента страницы.
onReadyStateChange
- Событие наступает при изменении состояния элемента страницы.
onReset
- Событие происходит при сбросе формы.
onResize
- Возникает при изменении размеров окна, фрейма или другого элемента страницы.
onResizeEnd
- Событие наступает по окончания изменения пользователем размеров элемента страницы, имеющего собственный пользовательский интерфейс.
onResizeStart
- Событие наступает, когда пользователь начинает изменять размеры элемента страницы, имеющего собственный пользовательский интерфейс.
onRowEnter
- Событие происходит при переходе на другую запись базы данных.
onRowExit
- Событие наступает перед переходом с текущей записи базы данных на другую.
onRowsDelete
- Событие наступает непосредственно перед удалением текущей записи из базы данных.
onRowsInserted
- Событие наступает сразу после новой записи в базу данных.
onScroll
- Возникает при скроллировании содержимого окна.
onSelect
- Событие происходит при выделении некоторого текста в текстовом поле.
onSelection
- Событие наступает, когда пользователь выделяет фрагмент содержимого страницы или поля ввода.
onSelectionChange
- Событие наступает, когда меняется тип выделения.
onSelectStart
- Событие наступает, когда пользователь начинает выделять фрагмент содержимого элемента страницы.
onStart
- Событие наступает, когда текст в элементе <MARQUEE> начинает двигаться.
onStop
- Событие наступает, когда пользователь прерывает загрузку текущей Web-страницы нажав кнопку Стоп или отжав ее.
onSubmit
- Событие происходит при отправке формы.
onUnload
- Событие происходит, когда "браузер" удаляет документ из окна или фрейма.
Получено с http://spravkaweb.local/index.php/javascript/event
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 13:49, 6 января 2007.
  • К этой странице обращались 185 раз.
12.5363910198


Справочкик по JavaScript — Справочник Web-языков

Справочкик по JavaScript

Главная ::. JavaScript

[править] Разделы справки

  • Совместное использование HTML и JavaScript
    • Правила написания скриптов
    • Объектная модель документа
  • Объект document
    • Свойства
    • Методы
    • Коллекция объектов
    • Подчиненные объекты и коллекции объекта document
    • Обращение к элементам страницы
  • Объект location
  • Объект style
    • Свойства и методы
    • Работа с объектом style
    • Объект style в Internet Explorer
    • Объект style в Navigator. JavaScript-стили
  • Объект window
    • Свойства
    • Методы
    • Свойства окна, передаваемые методу open
    • Работа с окнами
  • Объект layer
    • Доступ к слоям
    • Свойства
    • Методы
  • Объект navigator
  • Объект screen
  • Объект history

[править] Алфавитный указатель свойств

Все :: A :: B :: C :: D :: E :: F :: H :: I :: K :: L

[править] Алфавитный указатель методов

Все :: A :: B :: C :: D :: E :: F :: G :: H :: I :: J :: L :: M :: N :: O :: P :: Q :: R :: S :: T :: U :: W

[править] Алфавитный указатель событий браузера

Все :: A :: B :: C :: D :: E :: F :: H :: K :: L :: M :: P :: R :: S :: U

[править] Советы по JavaScript

  • Передача и обработка данных в html-файле
  • Чем заменить SSI, или необычное использование JavaScript
  • Как сделать страницу стартовой
  • Как добавить страницу в избранное
  • Как вывести дату последнего изменения страницы
  • Как убрать в теге SELECT рамку и стрелку
  • Интересный JavaScript - побуквенное появление текста

[править] Полезные ссылки

  • Форум по JavaScript
  • http://msdn.microsoft.com/library - Обширный справочник по JavaScript (англ.)
  • Yahoo! User Interface Library - Очень полезный framework. Богатые возможности и кроссбраузерность (англ.).
  • Prototype is a JavaScript Framework
  • Firebug - Отладчик JavaScript (Описание к нему на русском)
Получено с http://spravkaweb.local/index.php/javascript
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 12:33, 21 марта 2007.
  • К этой странице обращались 940 раз.
1.38395595551


Справочник по JavaScript : Алфавитный указатель методов — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель методов

Главная | ::. | JavaScript | ::. | Алфавитный указатель методов
add
- добавляет новый объект в коллекцию.
add(namespace)
- создает новый объект namespace и добавляет его в коллекцию namespaces.
addBehavior
- добавляет к текущему элементу страницы поведение.
AddChannel
- выводит на экран диалоговое окно, позволяющее пользователю добавить канал или отредактировать его интернет-адрес, если такой канал уже добавлен.
AddDesktopComponent
- добавляет на активный рабочий стол новый компонент.
AddFavorite
- Выводит на экран диалоговое окно, позволяющее пользователю добавить интернет-адрес в список Избранное.
addImport
- Добавляет таблицу стилей в коллекцию imports текущей таблицы стилей.
addPageRule
- Добавляет новое правило для печатных страниц в текущую таблицу стилей.
addReadRequest
- Добавляет запрос в очередь запросов объекта userProfile.
addRule
- Добавляет новое правило в текущую таблицу стилей.
alert
- Выводит на экран диалоговое окно предупреждения.
appendChild
- Этот метод помещает вновь созданный элемент на Web-страницу.
applyElement
- Данный метод делает заданный элемент страницы либо родителем, либо потомком текущего элемента.
assign
- Загружает новую Web-страницу в текущее окно Web-обозревателя.
atob
- Декодирует строку текста, закодированную алгоритмом base-64.
attachEvent
- Привязывает к обработчику события функцию, которая будет вызвана после наступления этого события.
AutoCompleteSaveForm
- Сохраняет содержимое полей ввода формы в хранилище данных для последующего автосохранения.
AutoScan
- Принимает строку, являющуюся неполным интернет-адресом Web-сайта, дополняет его с помощью встроенной функции автоввода и пытается соединиться с сайтом.
back
- Метод загружает в окно Web-обозревателя предыдущую Web-страницу из списка "истории".
blur
- Заставляет элемент страницы потерять фокус ввода.
borderWidths
- Задает значения толщины всех границ элемента страницы в один прием.
captureEvents
- Позволяет перехватить события заданного типа, наступившие в других элементах страницы.
clear(document)
- Удаляет все содержимое текущей Web-страницы.
clear(selection)
- Удаляет все содержимое выделенного фрагмента текущей Web-страницы.
clearAttributes
- Удаляет все атрибуты и их значения текущего элемента страницы.
clearData
- Удаляет данные в каком-либо формате в объектах clipboardData или dataTransfer.
clearInterval
- Удаляет интервальный таймер, определенный методом setInterval.
clearRequest
- Очищает очередь запросов объекта userProfile.
clearTimeout
- Удаляет тайм-аут, определенный методом setTimeout.
click
- Имитирует щелчок левой кнопкой мыши по элементу страницы.
cloneNode
- Создает копию текущего элемента страницы.
close(document)
- Заставляет Web-страницу немедленно обновить свое содержимое после использования методов write.
close(window)
- Закрывает текущее окно Web-обозревателя.
collapse
- Этот метод производит сжатие содержимого текущего объекта TextRange в точку и помещает его в начале или конце исходного содержимого объекта.
compareEndPoints
- Сравнивает границы текущего объекта TextRange с границами другого.
componentFromPoint
- Возвращает ссылку на фрагмент элемента страницы, имеющий заданные координаты.
confirm
- Производит вывод на экран диалогового окна предупреждения с кнопками OK и Отмена.
contains
- Проверяет, является ли то или иной элемент страницы потомком текущего элемента.
createCaption
- Создает пустой заголовок таблицы <CAPTION>.
createControlRange
- Создает коллекцию controlRange.
createElement
- Создает элемент страницы.
createEventObject
- Создает новый объект event для передачи контекста события, используя метод fiveEvent.
createPopup
- Создает всплывающее окно.
createRange
- Создает объект TextRange из выделенного фрагмента Web-страницы.
createRangeCollection
- Создает коллекцию объектов TextRange из всех выделенных фрагментов Web-страницы.
createStyleSheet
- Создает новую таблицу стилей.
createTextNode
- Создает объект TextNode.
createTextRange
- Создает объект TextRange.
createTFoot
- Создает пустой раздел основания таблицы <TFOOT>.
createTHead
- Создает пустую секцию заголовка таблицы <THEAD>.
deleteCaption
- Удаляет заголовок таблицы <CAPTION>.
deleteCell
- Удаляет ячейку таблицы.
deleteRow
- Удаляет строку таблицы.
deleteTFoot
- Удаляет основание таблицы <TFOOT>.
deleteTHead
- Удаляет заголовок таблицы <THEAD>.
detachEvent
- Открепляет от обработчика события ранее привязанную методом attachEvent функцию.
disableExternalCapture
- Отключает перехват внешних событий.
doImport
- Импортирует в пространство имен поведение.
doReadRequest
- Выполняет все запросы, находящиеся в очереди объекта userProfile.
doScroll
- Заставляет содержимое элемента страницы прокручиваться, имитируя щелчки по полосам прокрутки.
dragDrop
- Инициирует событие ondragstart и начало операции перетаскивания.
duplicate
- Дублирует объект TextRange.
elementFromPoint
- Метод возвращает ссылку на элемент страницы, находящийся по данным координатам.
empty
- Убирает выделение с Web-страницы.
enableExternalCapture
- Разрешает перехват внешних событий.
execCommand
- Выполняет одну из предопределенных команд над содержимым документа или объекта TextRange или controlRange.
execScript
- Выполняет заданный код на одном из скриптовых языков.
expand
- Расширяет содержимое объекта TextRangeтак, чтобы частично входящий в него элемент текста входил в него полностью.
find
- Производит поиск в содержимом Web-страницы, загруженной в текущее окно.
findText
- Производит поиск в содержимом объекта TextRange и в случае удачного поиска изменяет расположение TextRange так, чтобы он включал в себя найденный фрагмент.
fireEvent
- Вызывает наступление определенного события для заданного объекта.
firstPage
- Отображает в таблице, привязанной к данным, первую страницу этих данных.
focus
- Переносит фокус ввода на заданный элемент страницы.
forward
- Загружает в окно Web-обозревателя следующую Web-страницу из списка истории.
getAdjacentText
- Возвращает текст, находящийся возле тегов текущего элемента страницы.
getAttribute
- Возвращает атрибут текущего элемента страницы.
getAttribute(userProfile)
- Возвращает значение именованного атрибута.
getBookmark
- Возвращает "закладку" - уникальную текстовую строку, позволяющую в дальнейшем идентифицировать данный фрагмент текста.
getBoundingClientRect
- Метод возвращает объект TextRectangle, задающий местоположение и размеры текущего элемента страницы.
getClientRects
- Метод возвращает коллекцию объектов TextRectangle, задающих местоположение и размеры каждой строки текста текущего элемента страницы.
getData
- Метод возвращает данные, хранимые в объекте clipboardData или dataTransfer.
getElementById
- Метод возвращает ссылку на первый элемент страницы с заданным именем (значением атрибута ID).
getElementByName
- Метод возвращает коллекцию элементов страницы с заданным значением атрибута NAME.
getElementByTagName
- Метод возвращает коллекцию элементов страницы с заданным именем тега.
getExpression
- Метод возвращает текст выражения, присвоенного динамическому атрибуту стиля.
getSelection
- Метод возвращает строку, содержащую выделенный пользователем текст.
go
- Метод загружает в окно Web-обозревателя станицу, находящуюся под определенным номером в списке "истории".
handleEvent
- Метод вызывает обработчик заданного события.
hasChildNodes
- Метод проверяет, есть ли у указанного объекта дочерние элементы.
hasFocus
- Метод проверяет, находится ли данный элемент в фокусе.
hide
- Метод делает всплывающее окно невидимым.
home
- Метод заставляет Web-обозреватель загрузить "домашнюю" страничку.
ImportExportFavorites
- Метод позволяет импортировать или экспортировать "избранные" закладки.
inRange
- Метод позволяет узнать, находится ли внутри объекта заданный объект TextRange.
insertAdjacentElement
- Метод вставляет вновь созданный элемент страницы внутрь текущего элемента или рядом с ним.
insertAdjacentHTML
- Метод вставляет кусок HTML-кода внутри или рядом с определенным тегом.
insertadjacentText
- Метод вставляет текст внутри или рядом с определенным элементом страницы.
insertBefore
- Метод вставляет элемент в страницу.
insertCell
- Метод вставляет ячейку в строку таблицы.
insertRow
- Метод вставляет ячейку в таблицу или одну из столбцов.
isEqual
- Метод позволяет сравнить некоторый объект TextRange с текущим объектом.
IsSubscribed
- Метод позволяет узнать, подписан ли клиент на определенный канал, или нет.
item
- Метод возвращает элемент коллекции под заданным номером.
javaEnabled
- Метод определяет, разрешено ли пользователю использовать скриптовые программы.
lastPage
- Метод для таблицы, привязанной к данным, отобразить последнюю таблицу этих данных.
load
- Метод загружает в слой Web-страницу.
margins
- Метод задает размеры отступов между элементом страницы и его соседями.
mergeAttributes
- Метод позволяет копировать в текущий элемент страницы все атрибуты с их значениями из другого элемента страницы.
move
- Метод перемещает содержимое объекта TextRange на заданное количество элементов текста.
moveAbove
- Метод помещает текущий слой выше заданного.
moveBelow
- Метод помещает текущий слой ниже заданного.
moveBy
- Метод позволяет переместить слой или окно Web-обозревателя на заданное количество пикселей.
moveEnd
- Метод позволяет переместить конечную границу объекта TextRange на заданное количество элементов текста.
moveRow
- Метод позволяет переместить секцию таблицы или ее строку на новую позицию.
moveStart
- Метод позволяет переместить начальную границу объекта TextRange на заданное количество элементов текста.
moveTo
- Метод позволяет переместить слой или окно Web-обозревателя в определенную точку экрана.
moveToAbsolute
- Метод позволяет переместить слой в заданную точку относительно страницы.
moveToBookmark
- Метод позволяет переместить объект TextRange на фрагмент текста, заданный "закладкой".
moveToElementText
- Метод позволяет переместить объект TextRange на фрагмент текста, находящийся в заданном элементе страницы.
moveToPoint
- Метод перемещает объект TextRange в определенную точку.
namedRecordset
- Метод возвращает ссылку на объект именованного поднабора данных.
navigate
- Метод позволяет загрузить новую Web-страницу в текущее окно Web-обозревателя.
NavigateAndFind
- Метод загружает новую Web-страницу в текущее окно Web-обозревателя и выделяет в ней заданный текст, если он присутствует.
nextPage
- Метод отображает в таблице, привязанной к данным, следующую порцию (страницу) этих данных.
open
- Метод открывает новое окно Web-обозревателя или новую Web-страницу.
paddings
- Метод задает размер отступов между элементом страницы и рамкой.
parentElement
- Метод возвращает ссылку на родительский элемент данного объекта TextRange.
pasteHTML
- Метод позволяет вставить фрагмент HTML-кода в объект TextRange, заменяя все его содержимое.
preference
- Метод позволяет получить или изменить значения некоторых пользовательских настроек.
previousPage
- Метод позволяет отобразить в таблице, привязанной к данным, предыдущую порцию (страницу) этих данных.
print
- Метод печатает Web-страницу, находящуюся в текущем окне, на принтере.
prompt
- Метод выводит на экран диалоговое окно с полем ввода, предлагающее пользователю ввести некое значение.
queryCommandEnabled
- Метод проверяет возможность выполнения определенной команды для данного элемента страницы.
queryCommandIndeterm
- Метод проверяет в каком состоянии находится команда, доступная для данного фрагмента страницы.
queryCommandState
- Метод проверяет, выполнена ли данная команда.
queryCommandSupported
- Метод проверяет, поддерживается ли данным фрагментом страницы данная команда.
queryCommandValue
- Метод возвращает значение команды, которая доступна для данного фрагмента страницы.
random
- Метод возвращает псевдослучайную строку символов заданной длины.
recalc
- Метод заставляет все динамические свойства перевычислить свои значения.
refresh
- Данный метод обновляет содержимое таблицы или коллекции plugins.
releaseCapture
- Метод отменяет "захват мыши" для текущего элемента страницы.
releaseEvents
- Метод отменяет перехват событий данного типа.
reload
- Метод перезагружает текущую Web-страницу.
remove
- Метод удаляет элемент коллекции.
removeAttribute
- Метод удаляет заданный атрибут из тега.
removeBehavior
- Метод удаляет заданное поведение.
removeChild
- Метод удаляет дочерний элемент из текущего элемента.
removeExpression
- Метод удаляет выражение, присвоенное динамическому атрибуту стиля.
removeNode
- Метод удаляет текущий элемент из Web-страницы.
removeRule
- Метод удаляет правило из текущей таблицы стилей.
replace
- Метод заменяет текущую Web-страницу новой с заменой соответствующей позиции в списке "истории".
replaceAdjacentText
- Метод заменяет текст текущего элемента страницы на другой текст.
replaceChild
- Метод заменяет дочерний элемент на другой.
replaceNode
- Метод заменяет текущий элемент Web-страницы на другой.
reset
- Метод производит сброс данных формы.
resizeBy
- Метод изменяет размеры окна или слоя.
resizeTo
- Метод задает размеры окна или слоя.
routeEvent
- Метод передает событие элемента, в котором оно произошло, для дальнейшей обработки.
savePreferences
- Метод позволяет сохранить пользовательские настройки.
scroll
- Метод позволяет прокрутить содержимое Web-обозревателя до заданной точки.
scrollBy
- Метод позволяет прокрутить содержимое Web-обозревателя на определенное количество пикселов.
scrollIntoView
- Метод позволяет прокрутить содержимое Web-обозревателя так, чтобы текущий элемент страницы стал виден.
scrollTo
- Метод позволяет прокрутить содержимое окна Web-обозревателя до заданной точки.
select
- Метод выделяет элемент управления или текст.
setActive
- Метод делает текущий элемент страницы активным без переноса на него фокуса ввода.
setAttribute
- Метод помещает в тег элемента страницы новый атрибут вместе со значением.
setCapture
- Метод заставляет текущий элемент страницы перехватить все события мыши вне зависимости от того, каким элементом страницы они были вызваны.
setData
- Метод помещает данные в объект clipboardData или dataTransfer.
setEndPoint
- Метод устанавливает границу текущего объекта TetRange по границе другого аналогичного объекта.
setExpression
- Метод присваивает выражение динамическому атрибуту стиля.
setHotKeys
- Метод разрешает или запрещает "горячие" клавиши в окне без строки меню.
setInterval
- Метод создает новый интервальный таймер.
setResizable
- Метод разрешает или запрещает пользователю изменить размеры окна.
setTimeout
- Метод создает новый тайм-аут.
setZOption
- Метод задает порядок перекрытия текущего окна другими окнами.
show
- Метод показывает всплывающее окно.
ShowBrowserUI
- Метод открывает одно из диалоговых окон программы Web-обозревателя.
showHelp
- Метод выводит окно справки.
showModalDialog
- Метод выводит модальное диалоговое Web-окно.
showModelessDialog
- Метод выводит немодальное диалоговое Web-окно.
signText
- Метод шифрует строку текста.
splitText
- Метод делит текст текущего объекта TextNode страницы на две части и помещает вторую часть во вновь созданный объект TextNode.
start
- Метод запускает прокрутку текста в теге <MARQUEE>.
stop
- Метод останавливает прокрутку текста в теге <MARQUEE> или останавливает загрузку Web-страницы.
submit
- Метод вызывает отправку данных формой серверному приложению.
swapNode
- Метод меняет местами два элемента страницы: текущий и переданный в параметре.
tags
- Метод возвращает коллекцию элементов страницы, созданных с помощью заданного тега, или null, если таковых нет.
taintEnabled
- Метод позволяет определить, поддерживает ли Web-обозреватель бойкот данных.
urns
- Метод возвращает коллекцию элементов страницы, к которым было привязано данное поведение, или null, если таковых нет.
write
- Метод помещает в данное место Web-страницы HTML-код или простой текст, переданный в качестве параметра.
writeln
- Метод помещает в данное место Web-страницы HTML-код или простой текст, переданный в качестве параметра.
Получено с http://spravkaweb.local/index.php/javascript/method
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 10:47, 5 января 2007.
  • К этой странице обращались 153 раза.
16.1018869877


Справочник по JavaScript : Алфавитный указатель свойств — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель свойств

Главная | ::. | JavaScript | ::. | Алфавитный указатель свойств
above
- Возвращает ссылку на слой, находящийся выше текущего, или на окно Web-обозревателя, если текущий слой - самый верхний.
accelerator
- Указывает, содержит ли текст элемента страницы клавишу ускоритель.
accessKey
- Задает или возвращает клавишу-ускоритель для быстрого доступа к элементу страницы.
action
- Задает или возвращает интернет-адрес серверной программы, которой форма передаст введенные пользователем данные.
activeElement
- Возвращает указатель на активный элемент страницы.
align
- Задает или возвращает выравнивание элемента страницы или содержимого элемента страницы.
alink
- Задает или возвращает цвет активных гиперссылок в документе.
alinkColor
- Задает или возвращает цвет активных гиперссылок в документе.
allowTransparency
- Задает или возвращает прозрачность обычного или "плавающего" фрейма.
alt
- Задает или возвращает "альтернативный" текст, обображаемый на месте изображения, если оно не загружено.
altHTML
- Задает "альтернативный" HTML-код, который подставляется вместо внедренного объекта при ошибке его загрузки.
altKey
- Задает или возвращает состояние клавиши <Alt>.
altLeft
- Задает или возвращает состояние левой клавиши <Alt>.
appCodeName
- Возвращает имя кода программы Web-обозревателя.
appMinorVersion
- Возвращает младший номер версии программы Web-обозревателя.
appName
- Возвращает имя программы Web-обозревателя.
appVersion
- Возвращает версию программы Web-обозревателя и сведения о комьютере.
autocomplete
- Задает или возвращает возможность "автозаполнения" форм и полей ввода текста.
availHeight
- Возвращает высоту доступной области экрана компьютера.
availLeft
- Возвращает горизонтальную координату первого пиксела.
availTop
- Возвращает вертикальную координату первого пиксела.
availWidth
- Возвращает ширину доступной области экрана.
background
- Задает или возвращает интернет-адрес файла фонового рисунка, а также все свойства фона для документа или страницы.
backgroundAttachment
- Это свойство позволяет зафиксировать фоновый рисунок так, что он не будет прокручиваться вместе с содержимым объекта.
backgroundColor
- Задает или возвращает фоновый цвет Web-страницы или ее элемента.
backgroundImage
- Задает или возвращает фоновый рисунок Web-страницы или ее элемента.
backgroundPosition
- Задает или возвращает местонахождение фонового рисунка.
backgroundPositionX
- Задает или возвращает горизонтальную координату фонового рисунка.
backgroundPositionY
- Задает или возвращает вертикальную координату фонового рисунка.
backgroundRepeat
- Задает или возвращает порядок повторения фонового рисунка на Web-странице или ее элементе.
balance
- Задает или возвращает значение стереобаланса при воспроизведении фонового звука, заданного тегом <BGSOUND>.
BaseHref
- Возвращает интернет-адрес Web-страницы, в которую встроен объект <OBJECT>.
behavior
- Задает или возвращает поведение прокручиваемого текста в элементе <MARQUEE> или DHTML для элемента страницы.
behaviorCookie
- Возвращает cookie, идентифицирующий поведение отображения, на котором произошло текущее событие.
behaviorPart
- Возвращает значение, идентифицирующее поведение отображения, на котором произошло текущее событие.
below
- Возвращает ссылку на слой, находящийся ниже текущего.
bgColor
- Задает или возвращает цвет фона .
bgProperties
- Задает или возвращает поведение фонового рисунка документа: будет ли он перемещаться при прокрутке содержимого или нет.
blockDirection
- Возвращает направление написания текста: слева направо или справа налево.
border
- Задает или возвращает значение толщины границы рисунка, таблицы, фрейма или т.д.
borderBottom
- Задает или возвращает все свойства нижней границы элемента страницы в один прием.
borderBottomColor
- Задает цвет нижней границы элемента страницы.
borderBottomStyle
- Задает или возвращает тип нижней границы элемента страницы.
borderBottomWidth
- Задает или возвращает значение толщины нижней границы элемента страницы.
borderCollapse
- Задает, будут ли граница ячеек и общая граница таблицы сливаться в одну или нет, или возвращает этот признак.
borderColor
- Задает или возвращает цвет границы элемента.
borderColorDark
- Задает или возвращает цвет "затененной" части трехмерной границы таблицы или ее элемента.
borderColorLight
- Задает или возвращает цвет "освещенной" части трехмерной границы таблицы или ее элемента.
borderLeft
- Задает или возвращает все свойства левой границы элемента страницы в один прием.
borderLeftColor
- Задает или возвращает цвет левой границы элемента страницы.
borderLeftStyle
- Задает или возвращает тип левой границы элемента страницы.
borderLeftWidth
- Задает или возвращает значение толщины левой границы элемента страницы.
borderRight
- Задает или возвращает все свойства правой границы элемента страницы в один прием.
borderRightColor
- Задает или возвращает цвет правой границы элемента страницы.
borderRightStyle
- Задает или возвращает тип правой границы элемента страницы.
borderRightWidth
- Задает или возвращает значение толщины правой границы элемента страницы.
borderStyle
- Задает или возвращает тип сразу всех границ элемента страницы в один прием.
borderTop
- Задает или возвращает все свойства верхней границы элемента страницы в один прием.
borderTopColor
- Задает или возвращает цвет верхней границы элемента страницы.
borderTopStyle
- Задает или возвращает тип верхней границы элемента страницы.
borderTopWidth
- Задает или возвращает значение толщины верхней границы элемента страницы.
borderWidth
- Задает или возвращает значения толщины всех границ элемента страницы.
bottom
- Задает или возвращает вертикальную координату или позицию нижней границы объекта TextRange или свободно позиционированного элемента.
bottomMargin
- Задает или возвращает расстояние от нижней границы окна Web-обозревателя до нижней границы содержимого Web-страницы в пикселах.
boundingHeight
- Возвращает высоту содержимого объекта TextRange в пикселах.
boundingLeft
- Возвращает горизонтальную координату левой границы содержимого объекта TextRange относительно родителя в пикселах.
boundingTop
- Возвращает вертикальную координату верхней границы содержимого объекта TextRange относительно родителя в пикселах.
boundingWidth
- Возвращает ширину содержимого объекта TextRange в пикселах.
browserLanguage
- Возвращает язык программы Web-обозревателя или операционной системы.
bufferDepth
- Задает или возвращает количество двоичных разрядов, используемых для представления цвета при буферизации графических изображений в памяти.
button
- Задает или возвращает номер кнопки мыши, нажатой пользователем.
cancelBubble
- Задает или возвращает признак прохождения событий через иерархию объектов странцицы.
canHaveChildren
- Возвращает признак, может ли элемент страницы иметь потомков.
canHaveHTML
- Задает или возвращает признак, может ли элемент страницы содержать HTML-текст.
caption
- Возвращает указатель на заголовок <CAPTION> таблицы <TABLE> или null, если такового нет.
cellIndex
- Возвращает позицию ячейки <TD> в коллекции cell.
cellPadding
- Задает или возвращает расстояние между границей и содержимым ячейки таблицы в пикселах либо как процент от доступного пространства.
cellSpacing
- Задает или возвращает расстояние между ячейками таблицы в пикселах либо как процент от доступного пространства.
checked
- Задает или возвращает включенное состояние флажка или радиокнопки.
class
- Задает или возвращает стилевой класс элемента страницы.
classid
- Задает или возвращает уникальный идентификатор класса элемента ActiveX.
clear
- Задает или возвращает поведение разорванного тегом <BR> текста при "обтекании" им некоторых элементов страницы, таких как изображения.
clear(CSS)
- Задает или возвращает поведение текста при "обтекании" им некоторых элементов страницы, таких как изображения.
clientHeight
- Возвращает высоту клиентской области элемента страницы без учета всех отступов, границ и полос прокрутки.
clientLeft
- Возвращает горизонтальную координату левой границы клиентской области элемента страницы без учета всех отступов, границ и полос прокрутки.
clientTop
- Возвращает вертикальную координату верхней границы клиентской области элемента страницы без учета всех отступов, границ и полос прокрутки.
clientWidth
- Возвращает ширину клиентской области элемента страницы без учета всех отступов, границ и полос прокрутки.
clientX
- Задает или возвращает горизонтальную координату курсора мыши относительно клиентской области окна Web-обозревателя.
clientY
- Задает или возвращает вертикальную координату курсора мыши относительно клиентской области окна Web-обозревателя.
clip
- Задает или возвращает прямоугольный фрагмент элемента страницы, который будет видим.
clip.bottom
- Задает или возвращает вертикальную координату нижней границы видимого прямоугольного фрагмента слоя.
clip.height
- Задает или возвращает высоту видимого прямоугольного фрагмента слоя.
clip.left
- Задает или возвращает горизонтальную координату левой границы видимого прямоугольного фрагмента слоя.
clip.right
- Задает или возвращает горизонтальную координату правой границы видимого прямоугольного фрагмента слоя.
clip.top
- Задает или возвращает вертикальную координату верхней границы видимого прямоугольного фрагмента слоя.
clip.width
- Задает или возвращает ширину видимого прямоугольного фрагмента слоя.
clipBottom
- Возвращает вертикальную координату нижней границы видимого прямоугольного фрагмента элемента страницы.
clipLeft
- Возвращает горизонтальную координату левой границы видимого прямоугольного фрагмента элемента страницы.
clipRight
- Возвращает горизонтальную координату правой границы видимого прямоугольного фрагмента элемента страницы.
clipTop
- Возвращает вертикальную координату верхней границы видимого прямоугольного фрагмента элемента страницы.
closed
- Позволяет определить, закрыто окно Web-обозревателя, или нет.
code
- Задает или возвращает интернет-адрес файла, содержащего откомпилированный класс Java.
codeBase
- Задает или возвращает интернет-адрес папки, где содержится дистрибутивный файл элемента ActiveX, Java-класса или расширения Web-обозревателя.
codeType
- Задает или возвращает тип данных MIME элемента ActiveX.
color
- Задает или возвращает цвет шрифта или горизонтальной линии.
color(CSS)
- Задает или возвращает цвет текста.
colorDepth
- Задает или возвращает количество двоичных разрядов, используемых для представления цвета на экране.
cols(<FRAMESET>)
- Задает или возвращает количество и значения ширины всех фреймов-колонок в наборе фреймов.
cols(<TABLE>)
- Задает или возвращает количество колонок в таблице.
cols(<TEXTAREA>)
- Задает или возвращает ширину области редактирования в символах текста.
colSpan
- Задает или возвращает количество ячеек, которые должны быть объединены в одну.
compact
- Задает или возвращает признак компактного отображения позиций списков.
complete
- Возвращает true, если загрузка графического изображения завершена, и false - в противном случае.
content
- Задает или возвращает метаданные в теге <META>.
contentEditable
- Задает или возвращает признак, дающий пользователю возможность редактирования содержимого Web-страницы или ее элемента.
contentOverflow
- Возвращает true, если для форматирования страницы нужен новый объект LayoutRect, и false - в противном случае.
contentWindow
- Возвращает ссылку на объект window фрейма <FRAME> или <IFRAME>.
cookie
- Задает или возвращает значение cookie, связанное с Web-страницей.
cookieEnabled
- Позволяет определить, разрешил ли пользователь сохранять cookie на жестком диске.
coords
- Задает или возвращает координаты "горячей" области на карте-изображении.
cpuClass
- Возвращает тип процессора клиентского компьютера.
current
- Возвращает интернет-адрес текущей позиции в списке "истории".
cssText
- Задает или возвращает исходный текст определения стиля или таблицы стилей.
ctrlKey
- Задает или возвращает состояние клавиши <Ctrl>.
ctrlLeft
- Задает или возвращает состояние левой клавиши <Ctrl>.
cursor
- Задает или возвращает форму курсора мыши, которую он принимает при наведении на элемент страницы.
data (event)
- Задает или возвращает массив строк, содержащий интернет-адреса ярлыков, "брошенных" в окно Web-обозревателя.
data (<OBJECT>)
- Задает или возвращает интернет-адрес файла данных, требуемых элементом ActiveX.
data (TextNode)
- Задает или возвращает значение объекта TextNode.
dataFld
- Задает или возвращает поле таблицы базы данных, значение которого будет отображаться в данном элементе страницы.
dataFld (event)
- Задает или возвращает имя поля таблицы базы данных, значение которого изменилось.
dataFormatAs
- Задает или возвращает представление, используемое для отображения данных из полей таблицы.
dataPageSize
- Задает или возвращает размер страницы данных, выводимых в один прием, в записях.
dataSrc
- Задает или возвращает объект-источник данных.
defaultCharset
- Возвращает текстовую кодировку, заданную для Web-страницы по умолчанию.
defaultChecked
- Свойство задает или возвращает состояние флажка или радиокнопки по умолчанию.
defaultSelected
- Свойство задает или возвращает состояние позиции списка <option> по умолчанию.
defaultStatus
- Свойство задает или возвращает значение, отображаемое Web-обозревателем в строке состояния окна по умолчанию, если не задано свойство status.
defaultValue
- Свойство задает или возвращает содержимое элемента управления по умолчанию.
defer
- Свойство задает или возвращает состояние скрипта: отложено ли его выполнение или нет.
description
- Свойство возвращает описание типа MIME или расширения Web-обозревателя.
designMode
- Свойство задает или возвращает состояние документа: может ли он редактироваться пользователем.
dialogArguments
- Свойство возвращает значение или массив значений, переданных в диалоговое Well окно.
dialogHeight
- Свойство задает или возвращает высоту диалогового Web-окна в одной из единиц измерения, поддерживаемых CSS.
dialogLeft
- Свойство задает или возвращает горизонтальную координату левой стороны диалогового Web-окна в одной из единиц измерения, поддерживаемых CSS.
dialogTop
- Свойство задает или возвращает вертикальную координату верхней стороны диалогового Web-окна в одной из единиц измерения, поддерживаемых CSS.
dialogWidth
- Свойство задает или возвращает ширину диалогового Web-окна в одной из единиц измерения, поддерживаемых CSS.
dir
- Свойство задает или возвращает порядок чтения текста.
direction
- Свойство задает или возвращает направление прокрутки текста в элементе <MARQUEE>.
direction (CSS)
- Свойство задает или возвращает порядок чтения текста: слева направо или справа налево.
disabled
- Свойство задает или возвращает состояние элемента страницы: разрешен он для доступа пользователя или запрещен.
disabled (таблицы стилей)
- Свойство задает или возвращает состояние таблицы стилей: применяется ли она к Web-странице или нет.
display
- Свойство задает или возвращает вид элемента страницы: встроенный, блочный, позиция списка или вообще не видимый на странице.
document (popup)
- Свойство возвращает ссылку на Web-страницу, загруженную во всплывающее окно.
document (window)
- Свойство возвращает ссылку на Web-страницу, загруженную в текущее окно Web-обозревателя.
document (слой)
- Свойство возвращает ссылку на Web-страницу, загруженную в слой.
documentElement
- Свойство возвращает ссылку на самый верхний в иерархии объект, содержащийся в текущей Web-странице. Как правило, это объект <html>.
domain
- Свойство задает или возвращает домен Web-сервера, с которого была загружена Web-страница.
dropEffect
- Свойство задает или возвращает тип операции drag-n-drop, разрешенной объектом-приемником.
dynsrc
- Свойство задает или возвращает интернет-адрес динамического содержимого, отображаемого вместо статичного рисунка.
effectAllowed
- Свойство задает или возвращает тип операции drag-n-drop, разрешенной объектом-источником.
enabledPlugin
- Свойство возвращает ссылку на объект plugin, поддерживающий текущий тип данных MIME.
encoding
- Свойство задает или возвращает метод кодирования данных, отправляемых формой, в виде MIME.
event
- Свойство задает или возвращает событие, к которому привязан скрипт-обработчик.
expando
- Свойство задает или возвращает состояние объектной модели Web-обозревателя: можно или нельзя создавать произвольные свойства объектов.
face
- Свойство задает или возвращает имя шрифта.
fgColor
- Свойство задает или возвращает цвет текста.
fileCreatedDate
- Свойство возвращает дату создания файла HTML-документа или графического изображения.
fileName
- Свойство возвращает имя файла расширения Web-обозревателя.
fileModifiedDate
- Свойство возвращает дату последнего изменения файла HTML-документа или графического изображения.
fileSize
- Свойство возвращает размер файла HTML-документа или графического изображения.
fileUpdatedDate
- Свойство возвращает дату последнего обновления файла графического изображения.
filter
- Свойство задает или возвращает набор визуальных фильтров и преобразований, применяемых к элементу страницы.
firstChild
- Свойство возвращает ссылку на первый элемент с коллекции childNodes.
font
- Свойство задает или возвращает параметры шрифта элемента страницы.
fontFamily
- Свойство задает или возвращает имя шрифта, используемого в элементе страницы.
fontSize
- Свойство задает или возвращает имя размера шрифта, используемого в элементе страницы.
fontSmoothingEnabled
- Свойство проверяет, включено ли сглаживание шрифтов при отображении их на экране.
fontStyle
- Свойство задает или возвращает вид шрифта, используемого в элементе страницы.
fontVariant
- Свойство задает или возвращает вид малых букв шрифта, используемого в элементе страницы.
fontWeight
- Свойство задает или возвращает "жирность" шрифта, используемого в элементе страницы.
form
- Свойство возвращает ссылку на форму, к которой привязан элемент управления.
frame
- Свойство задает или возвращает значение, предписывающее отобразить или скрыть внешние границы таблицы.
frameborder (фреймы)
- Свойство задает или возвращает признак отображения границ между фреймами.
frameElement
- Свойство возвращает ссылку на объект фрейма.
frameSpacing
- Свойство задает или возвращает интервал между фреймами в пикселах.
fromElement
- Свойство задает или возвращает ссылку на элемент управления, с которого "ушел" курсор мыши.
hash
- Свойство задает или возвращает часть интернет-адреса текущей Web-страницы или гиперссылки, следующей за символом "решетки" #.
hasLayout
- Проверка абсолютно позиционированного объекта.
height
- Свойство задает или возвращает высоту элемента страницы в пикселах или как процент от доступного пространства.
height (document)
- Свойство задает или возвращает высоту документа в пикселах.
height (event)
- Свойство задает или возвращает высоту окна или фрейма в пикселах.
height (screen)
- Свойство возвращает полную высоту экрана компьютера в пикселах.
height (CSS)
- Свойство задает или возвращает высоту свободно позиционированного элемента.
hidden
- Свойство задает или возвращает признак внедренного элемента <embed>: будет ли тот виден на Web-странице.
hideFocus
- Свойство задает или возвращает признак: показывать фокус ввода (текстовый курсор) в элементе страницы или нет.
host
- Свойство задает или возвращает доменное имя сервера и номер порта, являющиеся частью интернет-адреса текущей Web-страницы или гиперссылки.
hostname
- Свойство задает или возвращает доменное имя сервера, являющееся частью интернет-адреса текущей Web-страницы или гиперссылки.
href (<BASE>)
- Свойство задает или возвращает базовый интернет-адрес в теге <base>, относительно которого отсчитываются все ссылки.
href (location)
- Свойство задает или возвращает полный интернет-адрес текущей Web-страницы.
href (styleSheet)
- Свойство задает или возвращает интернет-адрес файла таблицы стилей.
href (гиперссылки)
- Свойство задает или возвращает интернет-адрес назначения, куда пользователь попадет после активизации гиперссылки.
hspace
- Свойство задает или возвращает расстояние по горизонтали от элемента страницы до окружающего его текста.
htmlFor (<LABEL>)
- Свойство задает или возвращает элемент управления, к которому привязана метка <LABEL>.
htmlFor (<SCRIPT>)
- Свойство задает или возвращает элемент страницы, к которому привязан скрипт.
htmlText
- Свойство возвращает HTML-код текстового фрагмента TextRange.
httpEquiv
- Свойство задает или возвращает тип метаданных, задаваемых в теге <META>.
id
- Свойство возвращает уникальное имя элемента страницы, заданное атрибутом id.
imeMode
- Свойство задает или возвращает состояние IME (Input Method Editor — редактор способа ввода), с помощью которого вводятся иероглифические тексты на китайском, корейском и японском языках.
indeterminate
- Свойство задает или возвращает признак: находится ли флажок в неопределенном состоянии.
index
- Свойство задает или возвращает порядковую позицию пункта списка <option> в списке выбора <select>.
innerHeight
- Свойство задает или возвращает высоту клиентской области окна Web-обозревателя.
innerHTML
- Свойство задает или возвращает фрагмент HTML-кода, заключенного между открывающим и закрывающим тегами текущего элемента страницы.
innerText
- Свойство задает или возвращает фрагмент текста, заключенного между открывающим и закрывающим тегами текущего элемента страницы, без HTML-тегов.
innerWidth
- Свойство задает или возвращает ширину клиентской области окна Web-обозревателя.
isContentEditable
- Свойство возвращает признак возможности редактирования элемента страницы.
isDisabled
- Свойство возвращает признак возможности взаимодействия с элементом страницы.
isMap
- Свойство задает или возвращает признак рисунка <IMG>: будет ли он вести себя как карта-изображение.
isOpen
- Свойство возвращает признак всплывающего окна: открыто оно или закрыто.
isTextEdit
- Свойство возвращает true, если объект TextRange может быть создан с использованием текущего элемента страницы, и false, если не может быть создан.
keyCode
- Свойство задает или возвращает в формате Unicode код символа, связанного с нажатой клавишей.
lang
- Свойство задает или возвращает язык, на котором набран текст.
language
- Свойство задает или возвращает название языка программирования, на котором написан скрипт, привязанный к элементу страницы.
language (navigator)
- Свойство возвращает код языка программы Web-обозревателя.
lastChild
- Свойство возвращает ссылку на последний элемент коллекции childNodes.
lastModified
- Свойство возвращает дату последнего изменения файла Web-страницы.
layerX
- Свойство задает или возвращает либо ширину элемента страницы (при наступлении события изменения размера), либо горизонтальную координату курсора мыши относительно слоя в пикселах.
layerY
- Свойство задает или возвращает либо высоту элемента страницы (при наступлении события изменения размера), либо вертикальную координату курсора мыши относительно слоя в пикселах.
layoutFlow
- Свойство задает или возвращает направление написания текста: по горизонтали или по вертикали.
layoutGrid
- Свойство задает или возвращает параметры разметки элемента страницы, используемой для вывода иероглифических текстов на китайском, корейском и японском языках.
layoutGridChar
- Свойство задает или возвращает шаг горизонтальной разметки элемента страницы, используемой для вывода иероглифических текстов на китайском, корейском и японском языках.
layoutGridLine
- Свойство задает или возвращает шаг вертикальной разметки элемента страницы, используемой для вывода иероглифических текстов на китайском, корейском и японском языках.
layoutGridMode
- Свойство задает или возвращает тип разметки элемента страницы, используемой для вывода иероглифических текстов на китайском, корейском и японском языках.
layoutGridType
- Свойство задает или возвращает режим форматирования текстов на китайском, корейском и японском языках с использованием разметки элемента страницы.
left (TextRectangle)
- Свойство задает или возвращает горизонтальную координату левой границы объекта TextRectangle в пикселах.
left (слой)
- Свойство задает или возвращает горизонтальную координату левой границы слоя в пикселах.
left (CSS)
- Свойство задает или возвращает горизонтальную позицию левой границы свободно позиционированного элемента относительно родителя.
leftMargin
- Свойство задает или возвращает расстояние от левой границы окна Web-обозревателя до левой границы содержимого Web-страницы в пикселах.
length (<FORM>)
- Свойство возвращает количество элементов управления в форме.
length (history)
- Свойство возвращает количество позиций в списке "истории" Web-обозревателя.
length (<OPTION>)
- Свойство возвращает количество пунктов <option> в списке <select>.
length (plugin)
- Свойство возвращает количество элементов коллекции navigator.plugins.
length (<SELECT>)
- Свойство возвращает количество пунктов <option> в списке <select>.
length (TextNode)
- Свойство возвращает длину содержимого объекта TextNode в символах текста.
length (window)
- Свойство возвращает количество фреймов в окне Web-обозревателя.
length (коллекция)
- Свойство возвращает количество элементов коллекции.
letterSpacing
- Свойство задает или возвращает интервал, добавляемый между символами текста.
lineBreak
- Свойство задает или возвращает правила разрыва строк для текста на японском языке.
lineHeight
- Свойство задает или возвращает расстояние по вертикали между строками текста.
link
- Свойство задает или возвращает цвет гиперссылок в документе.
linkColor
- Свойство задает или возвращает цвет гиперссылок в документе.
listStyle
- Свойство задает или возвращает параметры маркера или номера позиции списка.
listStyleImage
- Свойство задает или возвращает интернет-адрес файла графического изображения, отображаемого в качестве маркера позиции списка.
listStylePosition
- Свойство задает или возвращает местонахождение маркера позиции списка.
listStyleType
- Свойство задает или возвращает тип маркера или номера позиции списка.
locationbar
- Свойство задает или возвращает состояние панели адреса: показана ли она на экране или скрыта.
loop (<BGSOUND>, <IMG>, <INPUT type="image">)
- Свойство задает или возвращает количество повторений фонового звука или видеофильма.
loop (<MARQUEE>)
- Свойство задает или возвращает количество "прокруток" текста в элементе <marquee>.
lowsrc
- Свойство задает или возвращает интернет-адрес файла с изображением низкого разрешения.
Получено с http://spravkaweb.local/index.php/javascript/property
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 06:52, 3 января 2007.
  • К этой странице обращались 124 раза.
17.6874558926


Советы по JavaScript — Справочник Web-языков

Советы по JavaScript

Главная | ::. | JavaScript | ::. | Советы по JavaScript

[править] Советы по JavaScript

  • Передача и обработка данных в html-файле
  • Чем заменить SSI, или необычное использование JavaScript
  • Как сделать страницу стартовой
  • Как добавить страницу в избранное
  • Как вывести дату последнего изменения страницы
  • Как убрать в теге SELECT рамку и стрелку
  • Интересный JavaScript - побуквенное появление текста
Получено с http://spravkaweb.local/index.php/javascript/sovet
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 06:58, 3 марта 2007.
  • К этой странице обращались 84 раза.
1.42245793343


Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву A — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву A

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель событий браузера | ::. | A : B : C : D : E : F : H : K : L : M : P : R : S : U

Содержание

  • 1 onActivate
  • 2 onAbort
  • 3 onAfterPrint
  • 4 onAfterUpdate

[править] onActivate

Наступает, когда элемент страницы получает фокус ввода.

Поддерживается IE начиная с 5.5

[править] onAbort

Наступает, когда пользователь прерывает загрузку графического изображения.

Действие по умолчанию: прерывание загрузки соответствующего файла.

Поддерживается IE начиная с 4.0 и NN начиная с 3.0

[править] onAfterPrint

Наступает сразу после вывода на принтер или предварительный просмотр текущей Web-страницы.

Событие может пригодиться, например, если требуется изменить текст или стиль печатаемого документа после распечатки.

Допустим, у нас текст написан шрифтом размером 9pt. Нам надо перед распечаткой страницы сделать текст 12pt, а после распечатки опять вернуть к 9pt.

Для этого можно написать следующий скрипт:

function bodyBeforePrint() {
    document.body.currentStyle.fontSize = "12pt";
}
function bodyAfterPrint () {
  document.body.currentStyle.fontSize = "9pt";
}

А в теге <BODY> надо записать следующее:

<BODY onBeforePrint="bodyBeforePrint()" onAfterPrint="bodyAfterPrint()">

Поддерживается IE начиная с 5.0

[править] onAfterUpdate

Событие наступает после того, как данные будут перенесены из элемента управления в соответствующее поле базы данных.

Доступно только для элементов управления, привязанных к данным.

Действие по умолчанию: сохранение данных. Не прерывается присвоением значения false свойству returnValue.

Поддерживается IE начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/event/a
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 13:57, 6 января 2007.
  • К этой странице обращались 56 раз.
1.34442210197


Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву B — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву B

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель событий браузера | ::. | A : B : C : D : E : F : H : K : L : M : P : R : S : U

Содержание

  • 1 onBeforeCopy
  • 2 onBeforeCut
  • 3 onBeforedeActivate
  • 4 onBeforeEditFocus
  • 5 onBeforePaste
  • 6 onBeforePrint
  • 7 onBeforeUnload
  • 8 onBeforeUpdate
  • 9 onBlur
  • 10 onBounce

[править] onBeforeCopy

Наступает перед копированием данных из текущего элемента страницы в буфер обмена Windows.

Событие onBeforeCopy() можно использовать, чтобы разрешить или запретить пункт контекстного меню Скопировать.

Для этого достаточно присвоить свойству returnValue объекта event значение false. Значение false разрешает, т.к. в этом случае мы отменяем поведение меню по умолчанию.

Присвоив значение true мы, тем самым, запрещаем пункт контекстного меню.

По умолчанию пункт Скопировать разрешен всегда, тогда как пункты Вырезать и Вставить всегда запрещены, т.к. пользователь не имеет права изменять содержимое Web-страницы.

Например, мы хотим сделать так, чтобы пользователь не мог скопировать определенный текст на странице:

<p onBeforeCopy="window.event.returnValue = false">
Этот текст нельзя скопировать!
</p>

Данное событие браузера можно использовать для защиты фрагмента страницы от несанкционированного копирования.

Если вы хотите, чтобы пользователь не смог скопировать всю страницу, надо обработчик события применить для тела документа:

<BODY onBeforeCopy="window.event.returnValue = false">

Поддерживается IE начиная с 5.0

[править] onBeforeCut

Наступает перед переносом данных из текущего элемента страницы в буфер обмена Windows.

Событие onBeforeCut() можно использовать, чтобы разрешить или запретить пункт контекстного меню Вырезать.

Для этого достаточно присвоить свойству returnValue объекта event значение false. Значение false разрешает, т.к. в этом случае мы отменяем поведение меню по умолчанию.

Присвоив значение true мы, тем самым, разрешает пункт контекстного меню.

По умолчанию пункт Вырезать запрещен всегда, т.к. пользователь не имеет права изменять содержимое Web-страницы.

Например надо разрешить пользователю вырезать часть страницы:

<p onBeforeCut="window.event.returnValue = false">
Этот текст можно вырезать!
</p>

В примере мы отменили поведение Web-обозревателя по умолчанию и разрешили пункт меню Вырезать.

Надо отметить, что если вы разрешаете пользователю вырезать текст на своей странице, то не придется писать для этого дополнительный код. Web-обозреватель выполняет заданные необходимые операции самостоятельно.

Поддерживается IE начиная с 5.0

[править] onBeforedeActivate

Наступает перед потерей фокуса текущим элементом страницы.

Поддерживается IE начиная с 5.5

[править] onBeforeEditFocus

Наступает перед переходом элемента страницы в режим редактирования.

Доступно только если свойство designMode установлено в on.

Действие по умолчанию: перевод элемента страницы в режим редактирования.

Поддерживается IE начиная с 5.0

[править] onBeforePaste

Наступает непосредственно перед вставкой данных из буфера обмена в текущий элемент страницы.

Событие onBeforePaste() можно использовать, чтобы разрешить или запретить пункт контекстного меню Вставить.

Для этого достаточно присвоить свойству returnValue объекта event значение false. Значение false разрешает, т.к. в этом случае мы отменяем поведение меню по умолчанию.

Присвоив значение true мы, тем самым, разрешаем пункт контекстного меню.

По умолчанию пункт Вставить запрещен всегда, т.к. пользователь не имеет права изменять содержимое Web-страницы.

Например надо разрешить пользователю вставить текст в элемент страницы:

<p onBeforePaste="window.event.returnValue = false">
Вставте сюда скопированный текст!
</p>

В примере мы отменили поведение Web-обозревателя по умолчанию и разрешили пункт меню Вставить.

Надо отметить, что если вы разрешаете пользователю вставлять текст на своей странице, то не придется писать для этого дополнительный код. Web-обозреватель выполняет заданные необходимые операции самостоятельно.

Только есть небольшая особенность: для того, чтобы вставить текст в элемент, не предназначенный для редактирования текста (все, кроме полей ввода), пользователю придется выделить фрагмент текста, куда будет вставлен текст.

Поддерживается IE начиная с 5.0

[править] onBeforePrint

Наступает перед выводом на принтер или предварительным просмотром текущей Web-страницы.

Событие может пригодиться, например, если требуется изменить текст или стиль печатаемого документа перед распечаткой.

Допустим, у нас текст написан шрифтом размером 9pt. Нам надо перед распечаткой страницы сделать текст 12pt, а после распечатки опять вернуть к 9pt.

Для этого можно написать следующий скрипт:

function bodyBeforePrint() {
  document.body.currentStyle.fontSize = "12pt";
}

function bodyAfterPrint () {
  document.body.currentStyle.fontSize = "9pt";
}

А в теге <BODY> надо записать следующее:

<BODY onBeforePrint="bodyBeforePrint()" onAfterPrint="bodyAfterPrint()">

Действие по умолчанию: вывод на принтер или предварительный просмотр текущей Web-страницы.

Поддерживается IE начиная с 5.0

[править] onBeforeUnload

Возникает перед выгрузкой страницы при переходе на другую страницу или закрытия окна.

Действие по умолчанию: сигнализация, что Web-страница сейчас будет закрыта.

Поддерживается IE начиная с 4.0

[править] onBeforeUpdate

Наступает перед переносом данных из элемента управления в соответствующее поле базы данных.

Доступно только для элементов управления, привязанных к данным.

Действие по умолчанию: сигнализация, что данные были изменены.

Поддерживается IE начиная с 4.0

[править] onBlur

Событие приосходит при переходе фокуса с этого элемента с помощью курсора мышки или последовательности перехода.

Поддерживается IE начиная с 3.02 для <SELECT> и <TEXTAREA>, начиная с 4.0 для остальных элементов управления, фреймов, гиперссылок, внедренных объектов, таблиц и т.д.

Поддерживатеся NN начиная с 2.0

[править] onBounce

Срабатывает, когда бегущаяя строка достигла границы и меняет направление.

Допускается, когда значение behavior установлено на "alternate".

Действие по умолчанию: изменение направления движения текста.

Поддерживается IE начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/event/b
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:04, 6 января 2007.
  • К этой странице обращались 59 раз.
1.36702895164


Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву C — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву C

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель событий браузера | ::. | A : B : C : D : E : F : H : K : L : M : P : R : S : U

Содержание

  • 1 onCellChange
  • 2 onChange
  • 3 onClick
  • 4 onContextMenu
  • 5 onControlSelect
  • 6 onCopy
  • 7 onCut

[править] onCellChange

Событие наступает, когда изменяются данные, находящиеся в базе данных.

Действие по умолчанию: сигнализация об изменении данных в базе данных.

Поддерживается IE начиная с 5.0

[править] onChange

Событи происходит при потере управляющим элементом фокуса ввода, если его значение было изменено с момента получения фокуса.

Элемент <INPUT>, <SELECT>, <TEXTAREA>.

Действие по умолчанию: изменение содержимого элемента управления.

Поддерживается IE начиная с 5.0

[править] onClick

Событие происходит при однократном щелчке левой кнопки мышки на элементе, при нажатии клавиши <Enter> на форме, использовании клавиши-ускорителя или выборе пункта в списке.

Это событие полезно, если Вам надо обработать нажатие пользователя на тот или иной элемент страницы.

Пример, приведенный далее, показывает как можно обработать событие onClick():

<HTML>
<HEAD>
<TITLE>Событие onClick()</TITLE>
<SCRIPT>
function clickAlert(str) {
  alert("Вы нажали на "+str);
}
</SCRIPT>
<BODY>
<table border=1>
<tr>
  <td onclick="clickAlert('левую ячейку!')">Левая ячейка</td>
  <td onclick="clickAlert('правую ячейку!')">Правая ячейка</td>
</tr>
<tr>
  <td colspan=2>
  <input type=button onclick="alert('Вы нажали на кнопку!')"
   value="Нажми для проверки работы события onClick()">
  </td>
</tr>
</table>
</BODY>
</HTML>

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 2.0

[править] onContextMenu

Наступает при щелчке правой кнопкой мыши по элементу страницы, перед выводом контекстного меню.

Действие по умолчанию: вывод контекстного меню.

Поддерживается IE начиная с 5.0

[править] onControlSelect

Это событие наступает при попытки пользователя выбрать элемент страницы, имеющий собственный пользовательский интерфейс.

Действие по умолчанию: активизация ползунков изменения размера.

Поддерживается IE начиная с 5.5

[править] onCopy

Наступает при копировании данных из текущего элемента страницы в буфер обмена Windows.

Действие по умолчанию: копирование выделенного фрагмента в буфер обмена.

Это событие можно использовать для операций копирования, если данные, помещаемые в Буфер обмена, нужно предварительно обработать.

<P onCopy="funCopy();" id="id1"
  onBeforeCopy="window.event.returnValue = false;">
Скопируйте этот текст!
</P>
<SCRIPT>
function funCopy() {
  window.event.returnValue = false;
  window.clipboardData.setData("Text", id1.innerText);
}
</SCRIPT>

В вышеприведенном примере реализована специальная операция копирования текста.

Содержимое элемента id1 копируется в Буфер обмена целиком.

Поддерживается IE начиная с 5.0

[править] onCut

Событие наступает при переносе данных из текущего элемента страницы в буфер обмена Windows.

Действие по умолчанию: перенос выделенного фрагмента в буфер обмена.

Это событие можно использовать для операций вырезания, если данные, помещаемые в Буфер обмена, нужно предварительно обработать.

Поддерживается IE начиная с 5.0

Получено с http://spravkaweb.local/index.php/javascript/event/c
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 08:33, 7 января 2007.
  • К этой странице обращались 59 раз.
1.35533213615


Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву D — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву D

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель событий браузера | ::. | A : B : C : D : E : F : H : K : L : M : P : R : S : U

Содержание

  • 1 onDataAvailable
  • 2 onDataSetChanged
  • 3 onDataSetComplete
  • 4 onDblClick
  • 5 onDeactivate
  • 6 onDrag
  • 7 onDragDrop
  • 8 onDragEnd
  • 9 onDragEnter
  • 10 onDragLeave
  • 11 onDragOver
  • 12 onDragStart
  • 13 onDrop

[править] onDataAvailable

Наступает каждый раз, когда очередная партия данных переносится из базы данных на Web-страницу.

Действие по умолчанию: сигнализация, что данные готовы для отображения.

Поддерживается IE начиная с 4.0

[править] onDataSetChanged

Событие наступает, когда данные в базе данных изменяются, а также когда начальная порция данных готова для переноса на Web-страницу.

Действие по умолчанию: сигнализация, что данные изменились.

Поддерживается IE начиная с 4.0

[править] onDataSetComplete

Событие наступает, когда все данные перенесены из базы данных на Web-страницу.

Действие по умолчанию: сигнализация, что все данные готовы для отображения.

Поддерживается IE начиная с 4.0

[править] onDblClick

Событие происходит при двойном щелчке левой кнопкой мышки на элементе.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 4.0

[править] onDeactivate

Наступает при потере фокуса текущим элементом страницы.

Поддерживается IE начиная с 5.5

[править] onDrag

Наступает во время операции drag-n-drop в элементе-источнике.

Действие по умолчанию: вызов функции-обработчика, если такая есть.

Поддерживается IE начиная с 5.0

[править] onDragDrop

Событие наступает, когда пользователь "бросает" в окно Web-обозревателя ссылки на интернет-адреса.

Параметры:

  • type - тип события;
  • target - ссылка на элемент страницы, где оно наступило;
  • data - массив строк, каждая из которых содержит "брошенный" в окно адрес;
  • modifiers - модификаторы, указывающие, какая клавиша на клавиатуре была при этом нажата;
  • screenX и screenY - экранные координаты курсора мыши.

Поддерживается NN начиная с 4.0

[править] onDragEnd

Событие наступает, когда пользователь отпускает кнопку мыши, завершая операцию drag-n-drop, в элементе-источнике.

Действие по умолчанию: вызов функции-обработчика, если такая есть.

Поддерживается IE начиная с 5.0

[править] onDragEnter

Событие наступает, когда пользователь перетаскивает данные в допустимое место, в элементе-цели.

Действие по умолчанию: вызов функции-обработчика.

Поддерживается IE начиная с 5.0

[править] onDragLeave

Событие наступает, когда пользователь перетаскивает данные из допустимого места, в элементе-цели.

Действие по умолчанию: вызов функции-обработчика.

Поддерживается IE начиная с 5.0

[править] onDragOver

Событие наступает во время операции drag-n-drop в элементе-цели, когда пользователь перетаскивает данные над допустимым местом.

Действие по умолчанию: вызов функции-обработчика.

Поддерживается IE начиная с 5.0

[править] onDragStart

Событие наступает, когда пользователь начинает перетаскивать данные, в элементе-источнике.

Действие по умолчанию: вызов функции-обработчика.

Поддерживается IE начиная с 4.0

[править] onDrop

Событие наступает, когда пользователь отпускает кнопку мыши, завершая операцию drag-n-drop, в элементе-цели.

Действие по умолчанию: вызов функции-обработчика.

Поддерживается IE начиная с 5.0

Получено с http://spravkaweb.local/index.php/javascript/event/d
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 08:41, 7 января 2007.
  • К этой странице обращались 61 раз.
1.35965490341


Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву E — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву E

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель событий браузера | ::. | A : B : C : D : E : F : H : K : L : M : P : R : S : U

[править] onError

Событие происходит при ошибке загрузки документа или графического изображения.

В обработчике этого события можно предусмотреть вывод каких-либо предупреждений о произошедшей ошибке.

Например, если адрес графического элемента задан в полном формате URL, а мы просматриваем локальную копию, не имея доступа к Internet.

onError=скрипт

Пример:

<html>
<head><title>Пример onError</title>
<script language="JavaScript">
function doError() {
alert ("Ошибка загрузки графики. Проверьте соединение.")
}
</script>
</head>
<body>
<img src="http://spravkaweb.ru/img/menu_all_out.gif" onError="doError()">
</body>
</html>

Поддерживается IE начиная с 3.02 для window и начиная с 4.0 для остальных элементов.

Поддерживается NN начиная с 3.0

[править] onErrorUpdate

Событие наступает, если при переносе измененных данных в базу данных происходит ошибка.

Действие по умолчанию: вызов функции-обработчика.

Поддерживается IE начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/event/e
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 08:43, 7 января 2007.
  • К этой странице обращались 48 раз.
1.32810282707


Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву F — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву F

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель событий браузера | ::. | A : B : C : D : E : F : H : K : L : M : P : R : S : U

[править] noFilterChange

Событие наступает, когда визуальный фильтр изменяет свое состояние или когда визуальное преобразование заканчивает свою работу.

Действие по умолчанию: сигнализация о завершении работы фильтра или преобразования.

Поддерживается IE начиная с 4.0

[править] onFinish

Событие наступает, когда очередной цикл движения текста в теге <MARQUEE> завершается.

Действие по умолчанию: прекращение цикла.

Поддерживается IE начиная с 4.0

[править] onFocus

Событие происходит при получении элементом фокуса с помощью мышки или последовательного перехода.

Действие по умолчанию: установка фокуса ввода на текущий элемент страницы.

Поддерживается IE начиная с 3.02 для элементов управления и <TEXTAREA>, начиная с 4.0 для фреймов, гиперссылок, внедренных объектов, таблиц и т.д. и начиная с 5.0 для всех элементов.

Поддерживается NN начиная с 2.0

Получено с http://spravkaweb.local/index.php/javascript/event/f
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 08:45, 7 января 2007.
  • К этой странице обращались 54 раза.
1.28616905212


Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву H — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву H

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель событий браузера | ::. | A : B : C : D : E : F : H : K : L : M : P : R : S : U

[править] onHelp

Возникает при нажатии клавиши F1.

Действие по умолчанию: открытие окна справки.

Поддерживается IE начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/event/h
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 08:47, 7 января 2007.
  • К этой странице обращались 49 раз.
1.15779995918


Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву K — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву K

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель событий браузера | ::. | A : B : C : D : E : F : H : K : L : M : P : R : S : U

[править] onKeyDown

Событие происходит при нажатии клавиши на клавиатуре.

Действие по умолчанию: возвращение кода нажатой клавиши.

Поддерживается IE начиная 4.0

Поддерживается NN начиная с 4.0

[править] onKeyPress

Событие происходит при нажатии и отпускании клавиши на клавиатуре.

Действие по умолчанию: возвращение кода нажатой клавиши в формате Unicode.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 4.0

[править] onKeyUp

Событие происходит при отпускании клавиши на клавиатуре.

Действие по умолчанию: возвращение кода нажатой клавиши.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/event/k
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 08:49, 7 января 2007.
  • К этой странице обращались 52 раза.
1.39647507668


Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву L — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву L

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель событий браузера | ::. | A : B : C : D : E : F : H : K : L : M : P : R : S : U

[править] onLayoutComplete

Событие наступает, когда Web-страница уже готова для печати на принтере или предварительного просмотра.

Действие по умолчанию: вызов функции-обработчика, если такая есть.

Поддерживается IE начиная с 5.5

[править] onLoad

Событие происходит, когда "браузер" заканчивает загружать окно или все фреймы элемента <FRAMESET>.

Действие по умолчанию: отображение элемента или ее элемента.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0

[править] onLoseCapture

Событие наступает, когда когда элемент страницы перестает перехватывать все события мыши.

Действие по умолчанию: вызов функции-обработчика, если такой есть.

Поддерживается IE начиная с 5.0

Получено с http://spravkaweb.local/index.php/javascript/event/l
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 08:52, 7 января 2007.
  • К этой странице обращались 58 раз.
1.47786593437


Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву M — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву M

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель событий браузера | ::. | A : B : C : D : E : F : H : K : L : M : P : R : S : U

Содержание

  • 1 onMouseDown
  • 2 onMouseEnter
  • 3 onMouseLeave
  • 4 onMouseOut
  • 5 onMouseOver
  • 6 onMouseUp
  • 7 onMove

[править] onMouseDown

Событие происходит при нажатии кнопки мышки на элементе.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 4.0

[править] onMouseEnter

Событие наступает, когда пользователь помещает курсор мыши на элемент страницы.

Поддерживается IE начиная с 5.5

[править] onMouseLeave

Событие наступает, когда пользователь убирает курсор мыши с элемента страницы.

Поддерживается IE начиная с 5.5

==onMouseMove== - Событие наступает, когда пользователь перемещает курсор мыши над элементом страницы.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 4.0

[править] onMouseOut

Событие происходит при перемещении курсора мышки за пределы элемента.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 3.0

[править] onMouseOver

Событие происходит при наведении курсора мыши на элемент.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 2.0

[править] onMouseUp

Событие происходит при отпускании кнопки мышки на элементе.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 4.0

[править] onMove

Событие наступает, когда пользователь перемещает окно Web-обозревателя или изменяет размера фрейма.

Параметры:

  • type - тип события;
  • target - ссылка на элемент страницы, где оно наступило;
  • X и Y - координаты левого верхнего угла окна или фрейма.

Поддерживается NN начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/event/m
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 08:57, 7 января 2007.
  • К этой странице обращались 52 раза.
1.28549385071


Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву P — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву P

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель событий браузера | ::. | A : B : C : D : E : F : H : K : L : M : P : R : S : U

[править] onPaste

Событие наступает при вставке данных из буфера обмена Windows в текущий элемент страницы.

Действие по умолчанию: вставка содержимого буфера обмена.

Это событие можно использовать для операций вставки, если данные, извлекаемые из Буфер обмена, нужно предварительно обработать.

Но перед этим необходимо отменить выполнение этих операций по умолчанию, присвоив false свойству returnValue объекта event.

Поддерживается IE начиная с 5.0

[править] onPropertyChange

Событие наступает при изменении одного из свойств текущего элемента страницы.

Действие по умолчанию: сигнализация об изменениее значения свойства.

Поддерживается IE начиная с 5.0

Получено с http://spravkaweb.local/index.php/javascript/event/p
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 08:16, 29 марта 2007.
  • К этой странице обращались 69 раз.
1.35519790649


Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву R — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву R

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель событий браузера | ::. | A : B : C : D : E : F : H : K : L : M : P : R : S : U

Содержание

  • 1 onReadyStateChange
  • 2 onReset
  • 3 onResize
  • 4 onResizeEnd
  • 5 onResizeStart
  • 6 onRowEnter
  • 7 onRowExit
  • 8 onRowsDelete
  • 9 onRowsInserted

[править] onReadyStateChange

Событие наступает при изменении состояния элемента страницы.

Действие по умолчанию: сигнализация об изменении значения свойства readyState.

Поддерживается IE начиная с 3.02 для <Hn> и namespace, начиная с 4.0 для <LINK>, <OBJECT>, <SCRIPT> и document, начиная с 5.0 для остальных элементов и начиная с 5.5 для <IFRAME>.

[править] onReset

Событие происходит при сбросе формы.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 3.0

[править] onResize

Возникает при изменении размеров окна, фрейма или другого элемента страницы.

Поддерживается IE с 4.0 для всех элементов, кроме <FRAME>, и начиная с 5.0 - для <FRAME>.

Поддерживается NN начиная с 4.0

[править] onResizeEnd

Событие наступает по окончания изменения пользователем размеров элемента страницы, имеющего собственный пользовательский интерфейс.

Действие по умолчанию: изменение размеров элемента страницы.

Поддерживается IE начиная с 5.5

[править] onResizeStart

Событие наступает, когда пользователь начинает изменять размеры элемента страницы, имеющего собственный пользовательский интерфейс.

Поддерживается IE начиная с 5.5

[править] onRowEnter

Событие происходит при переходе на другую запись базы данных.

Действие по умолчанию: сигнализация о готовности данных, содержащихся в новой записи.

Поддерживается IE начиная с 4.0

[править] onRowExit

Событие наступает перед переходом с текущей записи базы данных на другую.

Действие по умолчанию: сигнализация об изменении записи.

Поддерживается IE начиная с 4.0

[править] onRowsDelete

Событие наступает непосредственно перед удалением текущей записи из базы данных.

Действие по умолчанию: сигнализация об удалении записи.

Поддерживается IE начиная с 5.0

[править] onRowsInserted

Событие наступает сразу после новой записи в базу данных.

Действие по умолчанию: сигнализация о вставке новой записи.

Поддерживается IE начиная с 5.0

Получено с http://spravkaweb.local/index.php/javascript/event/r
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 09:01, 7 января 2007.
  • К этой странице обращались 63 раза.
1.35088706017


Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву S — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву S

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель событий браузера | ::. | A : B : C : D : E : F : H : K : L : M : P : R : S : U

Содержание

  • 1 onScroll
  • 2 onSelect
  • 3 onSelection
  • 4 onSelectionChange
  • 5 onSelectStart
  • 6 onStart
  • 7 onStop
  • 8 onSubmit

[править] onScroll

Возникает при скроллировании содержимого окна.

Действие по умолчанию: прокрутка содержимого элемента страницы.

Поддерживается IE начиная с 4.0

[править] onSelect

Событие происходит при выделении некоторого текста в текстовом поле.

Параметры:

  • type - тип события;
  • target - ссылка на элемент страницы, где оно наступило.

Поддерживается NN начиная с 2.0

[править] onSelection

Событие наступает, когда пользователь выделяет фрагмент содержимого страницы или поля ввода.

Действие по умолчанию: выделение фрагмента содержимого страницы или поля ввода.

Поддерживается IE начиная с 3.02 для полей ввода и начиная с 4.0 для <BODY>.

[править] onSelectionChange

Событие наступает, когда меняется тип выделения.

Поддерживается IE начиная с 5.5

[править] onSelectStart

Событие наступает, когда пользователь начинает выделять фрагмент содержимого элемента страницы.

Действие по умолчанию: выделение фрагмента содержимого элемнта страницы.

Поддерживается IE начиная с 4.0

[править] onStart

Событие наступает, когда текст в элементе <MARQUEE> начинает двигаться.

Доступно, только если свойство loop установлено в 1.

Действие по умолчанию: начало движения. Не "всплывает" и не прерывается присвоением значения false свойству returnValue.

Поддерживается IE начиная с 4.0

[править] onStop

Событие наступает, когда пользователь прерывает загрузку текущей Web-страницы нажав кнопку Стоп или отжав ее.

Поддерживается IE начиная с 5.0

[править] onSubmit

Событие происходит при отправке формы.

Действие по умолчанию: отправка введенных в форму данных.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0

Получено с http://spravkaweb.local/index.php/javascript/event/s
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 09:03, 7 января 2007.
  • К этой странице обращались 48 раз.
1.32617497444


Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву U — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель событий браузера : События JavaScript на букву U

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель событий браузера | ::. | A : B : C : D : E : F : H : K : L : M : P : R : S : U

[править] onUnLoad

Событие происходит, когда "браузер" удаляет документ из окна или фрейма.

Действие по умолчанию: выгрузка страницы.

Поддерживается IE начиная с 3.02 для window и начиная с 4.0 для <BODY> и <FRAMESET>.

Поддерживается NN начиная с 2.0

Получено с http://spravkaweb.local/index.php/javascript/event/u
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 09:05, 7 января 2007.
  • К этой странице обращались 50 раз.
1.25581693649


Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву A — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву A

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель методов | ::. | A : B : C : D : E : F : G : H : I : J : L : M : N : O : P : Q : R : S : T : U : W

Содержание

  • 1 add
  • 2 add(namespace)
  • 3 addBehavior
  • 4 AddChannel
  • 5 AddDesktopComponent
  • 6 AddFavorite
  • 7 addImport
  • 8 addPageRule
  • 9 addReadRequest
  • 10 addRule
  • 11 alert
  • 12 appendChild
  • 13 applyElement
  • 14 assign
  • 15 atob
  • 16 attachEvent
  • 17 AutoCompleteSaveForm
  • 18 AutoScan

[править] add

добавляет новый объект в коллекцию.

{Коллекция}.add({Объект}[, {Индекс}]);

Метод принимает два параметра. Первый из них задает ссылку на добавляемый в коллекцию объект, необязательный второй - индекс в коллекции, который будет ему соответствовать. Если второй параметр не задан, будет использован следующий свободный индекс в коллекции.

Метод не возвращает никакого значения.

Поддерживается IE начиная c 4.0

[править] add(namespace)

создает новый объект namespace и добавляет его в коллекцию namespaces.

namespaces.add("{Имя}", "{Интернет-адрес файла определения объекта}" [, "{Интернет-адрес файла поведения}"]);

Метод принимает три параметра. Первый из них задает имя создаваемого объекта, второй - интернет-адрес файла определения объекта, необязательный третий - интернет-адрес файла поведения, которое будет использоваться с этим объектом.

Метод возвращает ссылку на созданный объект namespace.

Поддерживается IE начиная c 5.5

[править] addBehavior

добавляет к текущему элементу страницы поведение.

{Объект}.addBehavior("{Интернет-адрес файла поведения}|#{Имя элемента ActiveX, реализующего это поведение}|
                              #default#{Имя встроенного поведения}"[, {Интерфейс}]);

Метод принимает два параметра. Первый из них - интернет-адрес файла поведения, имя поведения по умолчанию, реализованного Web-обозревателем, или имя объекта <OBJECT>, реализующего это представление. Необязательный второй параметр задает ссылку на интерфейс IElementBehaviorFactory поведения.

Метод возвращает целочисленный идентификатор добавленного поведения, который можно потом использовать, например, для его удаления.

Поддерживается IE начиная c 5.0

[править] AddChannel

выводит на экран диалоговое окно, позволяющее пользователю добавить канал или отредактировать его интернет-адрес, если такой канал уже добавлен.

external.AddChannel("{Интернет-адрес"}");

Метод принимает один параметр - интернет-адрес файла CDF, содержащий определение канала.

Метод не возвращает никакого параметра.

Поддерживается IE начиная c 4.0

[править] AddDesktopComponent

добавляет на активный рабочий стол новый компонент.

external.AddDesktopComponent("{Интернет-адрес}", "image|website" [, {Слева}][, {Сверху}][, {Ширина}][, {Высота}]);

Метод принимает шесть параметров. Первый из них - интернет-адрес Web-сайта или файла изображения. Второй может принимать два возможных значения в зависимости от типа отображаемого содержимого: image определяет изображение, а website - Web-сайт. Также могут приниматься еще четыре необязательных параметра, задающие для компонента активного рабочего стола горизонтальную координату левой стороны, вертикальную координату верхней стороны, ширину и высоту соответственно.

Метод не возвращает никакого параметра.

Поддерживается IE начиная c 4.0

[править] AddFavorite

Выводит на экран диалоговое окно, позволяющее пользователю добавить интернет-адрес в список Избранное.

external.AddFavorite("{Интернет-адрес}"[, "{Заголовок}"]);

Метод принимает два параметра. Первый - интернет-адрес. Необязательный второй - задает заголовок, под которым этот адрес появится в списке Избранное.

Метод не возвращает никакого параметра.

Поддерживается IE начиная c 4.0

[править] addImport

Добавляет таблицу стилей в коллекцию imports текущей таблицы стилей.

{Объект таблицы стилей}.addImport("{Интернет-адрес}"[, {Индекс}]);

Метод принимает два параметра. Первый - задает интернет-адрес добавляемой таблицы стилей, необязательный второй - индекс в коллекции, который будет ей соответствовать. В случае если второй параметр не задан, будет использован следующий свободный индекс в коллекции.

Метод возвращает числовой индекс, который займет в коллекции вновь добавленная таблица стилей.

Поддерживается IE начиная c 4.0

[править] addPageRule

Добавляет новое правило для печатных страниц в текущую таблицу стилей.

{Объект таблицы стилей}.addPageRule("{Селектор}", "{Определение стиля}"[, {Индекс}]);

Метод принимает три параметра. Первый из них задает наименование селектора добавляемого правила: :first для первой страницы, :left для четной и :right для нечетной. Второй параметр задает определение стиля для добавляемого правила. Необязательный третий параметр задает индекс в коллекции, который будет ей соответствовать. Если третий параметр не задан, будет использован следующий свободный индекс в коллекции.

Возвращаемое значение метода не используется.

Поддерживается IE начиная c 5.5

[править] addReadRequest

Добавляет запрос в очередь запросов объекта userProfile.

userProfile.addReadRequest("{Свойство}");

Метод принимает только один параметр - имя одного из свойств vCard.

Метод возвращает true, если запрос был успешно добавлен в очередь, и false - в противном случае.

Поддерживается IE начиная c 4.0

[править] addRule

Добавляет новое правило в текущую таблицу стилей.

{Объект таблицы стилей}.addRule("{Селектор}", "{Определение стиля}"[, {Индекс}]);

Метод принимает три параметра. Первый задает имя селектора добавляемого правила, которое может иметь вид "H1" или "H1 B". Второй параметр задает определение стиля для добавляемого правила. Третий параметр необязателен. Он задает индекс в коллекции, который будет ей соответствовать. Если третий параметр не задан, или его значение равно -1, будет использован следующий свободный индекс в коллекции.

Возвращаемое значение метода не используется.

Поддерживается IE начиная c 4.0

[править] alert

Выводит на экран диалоговое окно предупреждения.

window.alert("{Текст предупреждения}");

Метод принимает только один параметр, который задает текст предупреждения.

Метод не возвращает никакого значения.

Поддерживается IE начиная c 3.02 и NN начиная с 2.0

[править] appendChild

Этот метод помещает вновь созданный элемент на Web-страницу.

{Объект}.appendChild({Объект});

Метод принимает только один параметр - ссылку на добавляемый элемент.

Метод возвращает ссылку на добавленный элемент.

Поддерживается IE начиная c 5.0

[править] applyElement

Данный метод делает заданный элемент страницы либо родителем, либо потомком текущего элемента.

{Объект}.applyElement({Объект}[, "outside|inside"]);

Метод принимает два параметра. Первый из них задает ссылку на элемент страницы, который будет либо родителем, либо потомком текущего элемента. Второй - необязательный - задает, чем же, собственно, будет переданный в первом параметре элемент страницы для текущего элемента. Значение outside делает его родителем текущего элемента (значение по умолчанию), а значение inside - потомком.

Метод возвращает ссылку на переданный в первом параметре элемент.

Поддерживается IE начиная c 5.0

[править] assign

Загружает новую Web-страницу в текущее окно Web-обозревателя.

location.assign("{Интернет-адрес}");

Метод принимает только один параметр - интернет-адрес новой Web-страницы.

Метод не возвращает никакого значения.

Поддерживается IE начиная c 4.0

[править] atob

Декодирует строку текста, закодированную алгоритмом base-64.

window.atob("{Закодированная строка}");

Метод принимает только один параметр - закодированную строку.

Метод возвращает раскодированную строку.

Поддерживается NN начиная c 4.0

[править] attachEvent

Привязывает к обработчику события функцию, которая будет вызвана после наступления этого события.

{Объект}.attachEvent("{Событие}", {Имя функции});

Метод принимает два параметра.

Первый параметр задает имя события.

Второй параметр задает имя функции, которая будет вызвана при его наступлении.

Метод возвращает true, если функция была успешно привязана к обработчику.

Метод возвращает false в противном случае.

Поддерживается IE начиная c 5.0

[править] AutoCompleteSaveForm

Сохраняет содержимое полей ввода формы в хранилище данных для последующего автосохранения.

external.AutoCompleteSaveForm({Форма});

Метод принимает единственный параметр - ссылку на объект формы, данные которого будут сохранены.

Метод не возвращает никакого значения.

Поддерживается IE начиная c 5.0

[править] AutoScan

Принимает строку, являющуюся неполным интернет-адресом Web-сайта, дополняет его с помощью встроенной функции автоввода и пытается соединиться с сайтом.

external.AutoScan("{Неполный интернет-адрес}", "{Интернет-адрес страницы сообщения об ошибке}"[, "{Имя окна или фрейма}"]);

Метод принимает три параметра. Первый параметр задает неполный интернет-адрес. Второй параметр задает интернет-адрес Web-страницы, которая отображается в случае неудачи (например, если указанного интернет-адреса не существует). Третий необязательный параметр позволяет задать имя окна или фрейма, в котором будут выводиться результаты.

Метод не возвращает никакого значения.

Поддерживается IE начиная c 5.0

Получено с http://spravkaweb.local/index.php/javascript/method/a
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:03, 5 января 2007.
  • К этой странице обращались 81 раз.
1.39707279205


Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву B — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву B

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель методов | ::. | A : B : C : D : E : F : G : H : I : J : L : M : N : O : P : Q : R : S : T : U : W

[править] back

Метод загружает в окно Web-обозревателя предыдущую Web-страницу из списка "истории".

history.back();

Метод не принимает параметров.

Метод не возвращает никакого значения.

Поддерживается IE начиная c 3.02

Поддерживается NN начиная с 2.0 для history и начиная с 4.0 для window.

[править] blur

Заставляет элемент страницы потерять фокус ввода.

{Объект}.blur();

Метод не принимает параметров.

Метод не возвращает никакого значения.

Поддерживается IE начиная c 4.0 для гиперссылок, элементов управления, внедренных объектов, фреймов, таблиц,<DIV>, <SPAN> и window и начиная с 5.0 - для остальных элементов.

Поддерживается NN начиная с 2.0

[править] borderWidths

Задает значения толщины всех границ элемента страницы в один прием.

{Объект стиля}.borderWidths("{Верхняя}", "{Правая}", "{Нижняя}", "{Левая}");

Метод принимает четыре строковых параметра, задающие значения толщины верхней, правой, нижней и левой границ соответственно.

Метод не возвращает никакого значения.

Поддерживается NN начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/method/b
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:07, 5 января 2007.
  • К этой странице обращались 66 раз.
1.44488501549


Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву C — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву C

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель методов | ::. | A : B : C : D : E : F : G : H : I : J : L : M : N : O : P : Q : R : S : T : U : W

Содержание

  • 1 captureEvents
  • 2 clear(document)
  • 3 clear(selection)
  • 4 clearAttributes
  • 5 clearData
  • 6 clearInterval
  • 7 clearRequest
  • 8 clearTimeout
  • 9 click
  • 10 clonenode
  • 11 close(document)
  • 12 close(window)
  • 13 collapse
  • 14 compareEndPoints
  • 15 componentFromPoint
  • 16 confirm
  • 17 contains
  • 18 createCaption
  • 19 createControlRange
  • 20 createElement
  • 21 createEventObject
  • 22 createPopUp
  • 23 createRange
  • 24 createRangeCollection
  • 25 createStyleSheet
  • 26 createTextNode
  • 27 createTextRange
  • 28 createTFoot
  • 29 createTHead

[править] captureEvents

Позволяет перехватить события заданного типа, наступившие в других элементах страницы.

document.captureEvents("{Список имен событий}");

Метод принимает только одни параметр - список строковых имен событий, разделенных вертикальной чертой.

Метод не возвращает никакого значения.

Поддерживается NN начиная с 4.0

[править] clear(document)

Удаляет все содержимое текущей Web-страницы.

document.clear();

Метод не принимает параметров.

Метод не возвращает никакого значения.

Поддерживается IE начиная с 3.02

[править] clear(selection)

Удаляет все содержимое выделенного фрагмента текущей Web-страницы.

selection.clear();

Метод не принимает параметров.

Метод не возвращает никакого значения.

Поддерживается IE начиная с 4.0

[править] clearAttributes

Удаляет все атрибуты и их значения текущего элемента страницы.

{Объект}.clearAttributes();

Метод не принимает параметров.

Метод не возвращает никакого значения.

Поддерживается IE начиная с 5.0

[править] clearData

Удаляет данные в каком-либо формате в объектах clipboardData или dataTransfer.

{Объект}.clearData(["{Список форматов, разделенных пробелами}"]);

Метод принимает один необязательный параметр, который задает формат удаляемых данных.

Форматы могут быть следующими:

  • Text - текстовые данные;
  • URL - интернет-адрес;
  • File - файл;
  • HTML - код HTML;
  • Image - графическое изображение.

В случае если параметр не задан, удаляются все данные.

Поддерживается IE начиная с 5.0

[править] clearInterval

Удаляет интервальный таймер, определенный методом setInterval.

window.clearInterval({Идентификатор таймера});

Метод принимает только один параметр, который задает идентификатор интервального таймера, возвращенный методом setInterval.

Метод не возвращает значения.

Поддерживается IE и NN начиная с 4.0

[править] clearRequest

Очищает очередь запросов объекта userProfile.

userProfile.clearRequest;

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

[править] clearTimeout

Удаляет тайм-аут, определенный методом setTimeout.

window.clearTimeout({Идентификатор таймаута});

Метод принимает один параметр - идентификатор тайм-аута, возвращенный методом setTimeout.

Метод значения не возвращает.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0

[править] click

Имитирует щелчок левой кнопкой мыши по элементу страницы.

{Объект}.click();

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 3.02 для <INPUT type="button"> И начиная с 4.0 - для остальных элементов.

Поддерживается NN начиная с 2.0

[править] clonenode

Создает копию текущего элемента страницы.

{Объект}.cloneNode([true|false]);

Метод принимает один необязательный параметр. Значение false запрещает копирование вместе с элементом страницы его содержимого, а true - разрешает. Если необязательный параметр не указан, используется значение false.

Метод возвращает ссылку на вновь созданную копию элемента страницы.

Поддерживается IE начиная с 5.0

[править] close(document)

Заставляет Web-страницу немедленно обновить свое содержимое после использования методов write.

document.close();

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 2.0

[править] close(window)

Закрывает текущее окно Web-обозревателя.

window.close();

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0

[править] collapse

Этот метод производит сжатие содержимого текущего объекта TextRange в точку и помещает его в начале или конце исходного содержимого объекта.

{Объект TextRange}.collapse([true|false]);

Метод принимает только один параметр (необязательный). Если он равен true, то новое содержимое объекта перемещается в начало исходного содержимого. Если параметр равен false, то в конец. В случае, если параметр не указан, то используется значение true (в начало).

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

[править] compareEndPoints

Сравнивает границы текущего объекта TextRange с границами другого.

{Объект TextRange}.compareEndPoints(StartToEnd|StartToStart|EndToStart|EndToEnd, {Второй сравниваемый объект TextRange});

Метод принимает два параметра. Первый параметр задает, какие границы объектов будут сравниваться.

У этого параметра могут быть четыре значения:

  • StartToEnd - начальная граница текущего объекта сравнивается с конечной границей второго объекта;
  • StartToStart - начальная с начальной;
  • EndToStart - конечная с начальной;
  • EndToEnd - конечная с конечной.

Второй параметр задает ссылку на второй сравниваемый объект TextRange.

Метод возвращает одно из трех значений:

  • -1 - граница текущего элемента расположена левее (ближе к началу документа), чем граница второго объекта;
  • 0 - они совпадают;
  • 1 - граница второго объекта расположена правее, чем граница текущего.

Поддерживается IE начиная с 4.0

[править] componentFromPoint

Возвращает ссылку на фрагмент элемента страницы, имеющий заданные координаты.

{Объект}.componentFromPoint({X}, {Y});

Метод принимает два параметра, которые задают в пикселах горизонтальную и вертикальную координаты соответственно.

Данный метод возвращает текстовые значения, которые имеют следующие обозначения:

  • Пустая строка - один из дочерних элементов текущего элемента страницы;
  • outside - элемент страницы, который расположен за границами текущего элемента;
  • scrollbarDown - нижняя кнопка-стрелка полосы прокрутки;
  • scrollbarHThumb - ползунок горизонтальной полосы прокрутки;
  • scrollbarLeft - левая кнопка-стрелка полосы прокрутки;
  • scrollbarPageDown - область на вертикальной полосе прокрутки, которая расположена ниже ползунка;
  • scrollbarPageLeft - область на горизонтальной полосе прокрутки, которая расположена левее ползунка;
  • scrollbarPageRight - область на горизонтальной полосе прокрутки, которая расположена правее ползунка;
  • scrollbarPageUp - область на вертикальной полосе прокрутки, которая расположена выше ползунка;
  • scrollbarRight - правая кнопка-стрелка полосы прокрутки;
  • scrollbarUp - верхняя кнопка-стрелка полосы прокрутки;
  • scrollbarVThumb - ползунок вертикальной полосы прокрутки;
  • handleBottom - ползунок изменения размера на нижней границе;
  • handleBottomLeft - ползунок изменения размера на нижнем левом углу;
  • handleBottomRight - ползунок изменения размера на нижнем правом углу;
  • handleLeft - ползунок изменения размера на левой границе;
  • handleRight - ползунок изменения размера на правой границе;
  • handleTop - ползунок изменения размера на верхней границе;
  • handleTopLeft - ползунок изменения размера на верхнем левом углу;
  • handleTopRight - ползунок изменения размера на верхнем правом углу.

Поддерживается IE начиная с 5.0

[править] confirm

Производит вывод на экран диалогового окна предупреждения с кнопками OK и Отмена.

window.confirm(["{Текст предупреждения}"]);

Метод принимает только один необязательный параметр - текст предупреждения. В случае, если параметр не задан, окно предупреждения не будет содержать текста.

Метод возвращает true, если пользователь нажал кнопку OK. Если нажал Омтена - возвращает false.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0

[править] contains

Проверяет, является ли то или иной элемент страницы потомком текущего элемента.

{Объект}.contains({Объект});

Метод принимает только один параметр - ссылку на проверяемый элемент страницы.

Метод возвращает true, если переданный в параметре элемент страницы является потомком текущего элемента. Возвращает false в противном случае.

Поддерживается IE начиная с 4.0

[править] createCaption

Создает пустой заголовок таблицы <CAPTION>.

{Объект таблицы}.createCaption();

Метод не принимает параметров.

Метод возвращает ссылку на созданный элемент заголовка таблицы.

Поддерживается IE начиная с 4.0

[править] createControlRange

Создает коллекцию controlRange.

body.createControlRange();

Метод не принимает параметров.

Метод возвращает ссылку на созданную коллекцию.

Поддерживается IE начиная с 5.0

[править] createElement

Создает элемент страницы.

body.createElement("{Тег}");

Данный метод принимает только один параметр - имя тега для создания элемента страницы. При помощи этого метода можно создавать любые теги, кроме <FRAME> и <IFRAME>.

Метод возвращает ссылку на созданный элемент.

Поддерживается IE начиная с 4.0 для <AREA>, <IMG> и <OPTION> и начиная с 5.0 - для всех остальных.

[править] createEventObject

Создает новый объект event для передачи контекста события, используя метод fiveEvent.

document.createEventObject([{Существующий объект event}]);

Метод принимает только один необязательный параметр - ссылку на уже существующий объект event, на котором будет основан вновь создаваемый объект.

Метод возвращает ссылку на созданный объект event.

Поддерживается IE начиная с 5.5

[править] createPopUp

Создает всплывающее окно.

window.createPopUp();

Метод не принимает параметров и не возвращает значения.

Поддерживается IE начиная с 5.5

[править] createRange

Создает объект TextRange из выделенного фрагмента Web-страницы.

selection.createRange();

Метод не принимает параметров.

Метод возвращает ссылку на созданный объект.

Поддерживается IE начиная с 4.0

[править] createRangeCollection

Создает коллекцию объектов TextRange из всех выделенных фрагментов Web-страницы.

selection.createRangeCollection();

Т.к. современные версии Web-обозревателей не поддерживают множественное выделение, эта коллекция содержит всего один объект TextRange.

Метод не принимает параметров.

Метод возвращает ссылку на созданную коллекцию.

Поддерживается IE начиная с 5.5

[править] createStyleSheet

Создает новую таблицу стилей.

document.createStyleSheet(["{Интернет-адрес}"][, {Индекс}]);

Метод принимает два параметра, которые необязательны. Первый параметр задает интернет-адрес файла таблицы стилей. Второй параметр задает индекс в коллекции styleSheets, который будет ей соответствовать. Если индекс не задан, то будет использоваться следующий свободный индекс в коллекции.

Метод возвращает ссылку на созданный объект таблицы стилей.

Поддерживается IE начиная с 4.0

[править] createTextNode

Создает объект TextNode.

document.createTextNode(["{Текст}"]);

Метод принимает строку текста, которая станет содержимым создаваемого объекта.

Метод возвращает ссылку на созданный объект.

Поддерживается IE начиная с 5.0

[править] createTextRange

Создает объект TextRange.

{Объект}.createTextRange();

Метод не принимает параметров.

Метод не возвращает значений.

Поддерживается IE начиная с 4.0

[править] createTFoot

Создает пустой раздел основания таблицы <TFOOT>.

{Объект таблицы}.createTFoot();

Метод не принимает параметров.

Метод возвращает ссылку на созданный элемент раздела основания таблицы.

Поддерживается IE начиная с 4.0

[править] createTHead

Создает пустую секцию заголовка таблицы <THEAD>.

{Объект таблицы}.createTHead();

Метод не принимает параметров.

Метод возвращает ссылку на созданный элемент раздела заголовка таблицы.

Поддерживается IE начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/method/c
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:46, 5 января 2007.
  • К этой странице обращались 98 раз.
1.37939119339


Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву D — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву D

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель методов | ::. | A : B : C : D : E : F : G : H : I : J : L : M : N : O : P : Q : R : S : T : U : W

Содержание

  • 1 deleteCaption
  • 2 deleteCell
  • 3 deleteRow
  • 4 deleteTFoot
  • 5 detachEvent
  • 6 disableExternalCapture
  • 7 doImport
  • 8 doReadRequest
  • 9 doScroll
  • 10 dragDrop
  • 11 duplicate

[править] deleteCaption

Удаляет заголовок таблицы <CAPTION>.

{Объект таблицы}.deleteCaption();

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

[править] deleteCell

Удаляет ячейку таблицы.

{Объект строки таблицы}.deleteCell([{Индекс}]);

Метод принимает только один необязательный параметр, который задает порядковый номер ячейки в коллекции cells. В случае, если параметр не задан, удаляется последняя ячейка.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

[править] deleteRow

Удаляет строку таблицы.

{Объект таблицы или ее секции}.deleteRow([{Индекс}]);

Метод принимает только один необязательный параметр, который задает порядковый номер ячейки в коллекции rows. В случае, если параметр не задан, удаляется последняя строка.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

[править] deleteTFoot

Удаляет основание таблицы <TFOOT>.

{Объект таблицы}.deleteTFoot();

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

==deleteTHead

Удаляет заголовок таблицы <THEAD>.

{Объект таблицы}.deleteTHead();

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

[править] detachEvent

Открепляет от обработчика события ранее привязанную методом attachEvent функцию.

{Объект}.detachEevent("{Событие}", {Имя функции});

Метод принимает два параметра. Первый параметр задает имя события. Второй параметр задает имя функции, которая вызывается при наступлении заданного в первом параметре события.

Метод не возвращает значения.

Поддерживается IE начиная с 5.0

[править] disableExternalCapture

Отключает перехват внешних событий.

window.disableExternalCapture();

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается NN начиная с 4.0

[править] doImport

Импортирует в пространство имен поведение.

{Объект}.doImport("{Интернет-адрес}");

Метод принимает всего один параметр, который задает интернет-адрес файла поведения.

Метод не возвращает значения.

Поддерживается IE начиная с 5.5

[править] doReadRequest

Выполняет все запросы, находящиеся в очереди объекта userProfile.

userProfile.doReadRequest({Код доступа}[, "{Псевдоним}"][, "{Интернет-адрес}"][, "{Путь}][, {Дата устаревания}]);

Метод принимает до пяти параметров. Первый параметр, который является обязательным, указывает код доступа. Код доступа может быть указан тринадцатью значениями от 0 до 12 в порядке убывания защищенности и приоритета. Второй параметр задает псевдоним для доступа к защищенной информации. Третий, четвертый и пятый параметры задают адрес Web-сайта, путь местонахождения файлов Web-страниц, с которых разрешено получать запросы, и дату устаревания запросов соответственно.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

[править] doScroll

Заставляет содержимое элемента страницы прокручиваться, имитируя щелчки по полосам прокрутки.

{Объект}.doScroll(["{Действие}"]);

Метод принимает только один необязательный параметр, задающий действие, которое выполняется над полосой прокрутки.

Параметр может иметь следующие значения:

  • scrollbarDown - Щелчок по нижней кнопке-стрелке (по умолчанию);
  • scrollbarHTumb - Перемещение бегунка горизонтальной полосы прокрутки;
  • scrollbarLeft - Щелчок по левой кнопке-стрелке;
  • scrollbarPageDown - Прокрутка на страницу вниз;
  • scrollbarPageLeft - Прокрутка на страницу влево;
  • scrollbarPageRight - Прокрутка на страницу вправо;
  • scrollbarPageUp - Прокрутка на страницу вверх;
  • scrollbarRight - Щелчок по правой кнопке-стрелке;
  • scrollbarUp - Щелчок по верхней кнопке-стрелке;
  • scrollbarVThumb - Перемещение бегунка вертикальной полосы прокрутки;
  • down - То же самое, что scrollbarDown;
  • left - То же самое, что scrollbarLeft;
  • pageDown - То же самое, что scrollbarPageDown;
  • pageLeft - То же самое, что scrollbarPageLeft;
  • pageRight - То же самое, что scrollbarPageRight;
  • pageUp - То же самое, что scrollbarPageUp;
  • right - То же самое, что scrollbarRight;
  • up - То же самое, что scrollbarUp;

Поддерживается IE начиная с 5.0

[править] dragDrop

Инициирует событие ondragstart и начало операции перетаскивания.

{Объект}.dragDrop();

Метод параметров не принимает.

Метод возвратит true, если операция drag-n-drop успешно завершена.

Метод возвратит false, если она была прервана в обработчике события ondragstart.

Поддерживается IE начиная с 5.5

[править] duplicate

Дублирует объект TextRange.

{Объект}.duplicate();

Метод параметров не принимает.

Метод возвратит указатель на копию текущего объекта TextRange.

Поддерживается IE начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/method/d
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 20:12, 5 января 2007.
  • К этой странице обращались 82 раза.
1.64190101624


Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву E — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву E

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель методов | ::. | A : B : C : D : E : F : G : H : I : J : L : M : N : O : P : Q : R : S : T : U : W

Содержание

  • 1 elementFromPoint
  • 2 empty
  • 3 enableExternalCapture
  • 4 execCommand
  • 5 execSript
  • 6 expand

[править] elementFromPoint

Метод возвращает ссылку на элемент страницы, находящийся по данным координатам.

document.elementFromPoint({X,}, {Y});

Два параметра, которые можно передать этому методу, задают в пикселах горизонтальную и вертикальную координаты соответственно.

Метод возвратит ссылку на элемент страницы, имеющий заданные в параметрах координаты.

Поддерживается IE начиная с 4.0

[править] empty

Убирает выделение с Web-страницы.

selection.empty();

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

[править] enableExternalCapture

Разрешает перехват внешних событий.

window.enableExternalCapture();

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается NN начиная с 4.0

[править] execCommand

Выполняет одну из предопределенных команд над содержимым документа или объекта TextRange или controlRange.

{Объект}.execCommand("{Команда}"[, true|false][, {Параметр команды}]);

Метод принимает до трех параметров. Первый параметр задает обозначение команды, которая будет выполнена над содержимым объекта. Второй необязательный параметр задает, будет ли Web-браузер запрашивать у пользователя дополнительные параметры для выполнения команды (значение true; используется по умолчанию), если она это поддерживает, или нет (значение false). Третий необязательный параметр позволяет задать дополнительные данные для выполняемой команды.

Метод возвращает true, если команда была выполнена благополучно, и false - в противном случае.

Поддерживается IE начиная с 4.0 для document и TexRange и начиная с 5.0 для controlRange.

[править] execSript

Выполняет заданный код на одном из скриптовых языков.

window.execSript("{Код скрипта}", "{Язык}");

Метод принимает два параметра.

Первый параметр задает код скрипта в виде текстовой строки.

Второй параметр задает обозначение скриптового языка, на котором написан этот скрипт.

Для скриптов, написанных на JavaScript второй параметр будет равен "JScript" или "javascript".

Метод всегда возвращает null.

Поддерживается IE начиная с 4.0

[править] expand

Расширяет содержимое объекта TextRangeтак, чтобы частично входящий в него элемент текста входил в него полностью.

{Объект TextRange}.expand("character|word|sentence|textedit");

Метод принимает только один параметр, который задает тип элемента текста.

  • character - символ;
  • word - слово;
  • sentence - предложение;
  • textedit - весь абзац.

Метод возвращает true, если содержимое объекта TextRange было расширено успешно.

Метод возвращает false в противном случае.

Поддерживается IE начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/method/e
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 09:40, 6 января 2007.
  • К этой странице обращались 73 раза.
1.38753390312


Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву F — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву F

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель методов | ::. | A : B : C : D : E : F : G : H : I : J : L : M : N : O : P : Q : R : S : T : U : W

Содержание

  • 1 find
  • 2 findText
  • 3 fireEvent
  • 4 firstPage
  • 5 focus
  • 6 forward

[править] find

Производит поиск в содержимом Web-страницы, загруженной в текущее окно.

window.find(["{Искомый текст}"[, true|false, true|false]]);

Метод принимает три необязательных параметра.

Первый параметр задает строку, которая будет искаться на странице.

Второй параметр задет, будет ли поиск производиться с учетом регистра букв (true) или без учета регистра (false - по умолчанию).

Третий параметр задает направление поиска: от начала к концу (значение false - по умолчанию) или от конца к началу (значение true).

В случае, если ни один из параметров не задан, Web-обозреватель отобразит диалоговое окно поиска.

Метод возвращает true, если искомый текст был найден.

Метод возвращает false в противном случае.

Поддерживается NN начиная с 4.0

[править] findText

Производит поиск в содержимом объекта TextRange и в случае удачного поиска изменяет расположение TextRange так, чтобы он включал в себя найденный фрагмент.

{Объект TextRange}.findText("{Искомый текст}"[, {Номер вхождения}][, {Параметры}]);

Метод принимает три параметра.

  • Первый параметр задает искомую строку.
  • Второй параметр (необязательный) задет номер вхождения искомой строки в тексте.
  • Третий параметр (необязательный) - это целое число, которое задает параметры поиска.

Это число может принимать значения:

  • 2 - искать только целые слова, а не фрагменты;
  • 4 - искать с совпадением регистра символов;
  • 6 - совмещает режимы 2 и 4.

Метод возвращает true, если искомый текст был найден. Метод возвращает false в противном случае.

Поддерживается IE начиная с 4.0

[править] fireEvent

Вызывает наступление определенного события для заданного объекта.

{Объект}.fireEvent("{Событие}"[, {Объект}]);

Метод принимает два параметра.

  • Первый параметр задает название события, которое должно наступить.
  • Второй параметр (необязательный) задет ссылку на элемент страницы, для которого наступит это событие.

Если ссылка не указана, то событие наступает для текущего объекта.

Метод возвращает true, если событие успешно произошло. Метод возвращает false в противном случае.

Поддерживается IE начиная с 5.5

[править] firstPage

Отображает в таблице, привязанной к данным, первую страницу этих данных.

{Объект таблицы}.firstPage();

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 5.0

[править] focus

Переносит фокус ввода на заданный элемент страницы.

{Объект}.focus();

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 3.02 для элементов управления, начиная с 4.0 для гиперссылок, внедренных объектов, фреймов, таблиц, <BUTTON>, <SELECT>, <SPAN> и window и начиная с 5.0 для остальных элементов.

Поддерживается IE начиная с 3.02 для элементов управления, начиная с 4.0 для гиперссылок, внедренных объектов, фреймов, таблиц, <BUTTON>, <SELECT>, <SPAN> и window и начиная с 5.0 для остальных элементов.

Поддерживается NN начиная с 2.0 для элементов управления и начиная с 3.0 для window.

[править] forward

Загружает в окно Web-обозревателя следующую Web-страницу из списка истории.

history.forward();

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0 для history и начиная с 4.0 для window.

Получено с http://spravkaweb.local/index.php/javascript/method/f
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 09:46, 6 января 2007.
  • К этой странице обращались 71 раз.
1.34372282028


Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву G — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву G

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель методов | ::. | A : B : C : D : E : F : G : H : I : J : L : M : N : O : P : Q : R : S : T : U : W

Содержание

  • 1 getAdjacentText
  • 2 getAttribute
  • 3 getAttribute (userProfile)
  • 4 getBookmark
  • 5 getBoundingClientRect
  • 6 getClientRects
  • 7 getData
  • 8 getElementById
  • 9 getElementByName
  • 10 getElementByTagName
  • 11 getЕxpression
  • 12 getSelection
  • 13 go

[править] getAdjacentText

Возвращает текст, находящийся возле тегов текущего элемента страницы.

{Объект}.getAdjacentText("beforeBegin|afterBegin|beforeEnd|afterEnd");

Метод принимает всего один параметр, который задает место, откуда будет взят текст.

Этот параметр может иметь четыре значения:

  • beforeBegin - текст, расположенный непосредственно перед открывающим тегом;
  • afterBegin - после открывающего тега, но перед всем остальным содержимым элемента;
  • beforeEnd - перед закрывающим тегом, но после всего остального содержимого элемента;
  • afterEnd - текст, расположенный непосредственно после закрывающего тега.

Поддерживается IE начиная с 5.0

[править] getAttribute

Возвращает атрибут текущего элемента страницы.

{Объект}.getAttribute("{Имя атрибута}"[, {Параметры}]);

Метод принимает два параметра.

Первый параметр задает имя атрибута.

Второй необязательный параметр задает дополнительные параметры в виде целого числа. Эти числа обозначают следующее:

  • 0 - задает поиск без учета регистра символов и, если атрибут не задан, возвращает значение по умолчанию;
  • 1 - поиск с учетом регистра символов;
  • 2 - возвращает значение, только если атрибут задан, в противном случае возвращает null;
  • 3 - является комбинацией значений 1 и 2.

Значение по умолчанию - 0.

Если в первом параметре задан атрибут, который не поддерживается тегом, то метод возвращает null.

Поддерживается IE начиная с 4.0

[править] getAttribute (userProfile)

Возвращает значение именованного атрибута.

userProfile.getAttribute("{Имя атрибута}");

Метод принимает только один параметр, который задает имя атрибута.

Поддерживается IE начиная с 4.0

[править] getBookmark

Возвращает "закладку" - уникальную текстовую строку, позволяющую в дальнейшем идентифицировать данный фрагмент текста.

{Объект TextRange}.getBookmark();

Метод не принимает параметров.

Поддерживается IE начиная с 4.0

[править] getBoundingClientRect

Метод возвращает объект TextRectangle, задающий местоположение и размеры текущего элемента страницы.

{Объект}.getBoundingClientRect();

Метод не принимает параметров.

Поддерживается IE начиная с 5.0

[править] getClientRects

Метод возвращает коллекцию объектов TextRectangle, задающих местоположение и размеры каждой строки текста текущего элемента страницы.

{Объект}.getClientRects();

Метод не принимает параметров.

Поддерживается IE начиная с 5.0

[править] getData

Метод возвращает данные, хранимые в объекте clipboardData или dataTransfer.

{Объект}.getData("{Формат}");

Метод принимает всего один параметр, который задает формат возвращаемых данных. Этот параметр может принимать следующие значения:

  • text - позволяет вернуть обычный текст;
  • URL - интернет-адрес.

Поддерживается IE начиная с 5.0

[править] getElementById

Метод возвращает ссылку на первый элемент страницы с заданным именем (значением атрибута ID).

document.getElementById("{Имя}");

Метод принимает всего один параметр, который задает имя элемента страницы.

Поддерживается IE начиная с 5.0

[править] getElementByName

Метод возвращает коллекцию элементов страницы с заданным значением атрибута NAME.

document.getElementByName("{Имя}");

Метод принимает всего один параметр, который задает имя элемента страницы.

Поддерживается IE начиная с 5.0

[править] getElementByTagName

Метод возвращает коллекцию элементов страницы с заданным именем тега.

{Объект}.getElementByTagName("{Тег}");

Метод принимает всего один параметр, который задает тег элементов страницы.

Поддерживается IE начиная с 5.0

[править] getЕxpression

Метод возвращает текст выражения, присвоенного динамическому атрибуту стиля.

{Объект стиля}.getExpression("{Имя атрибута}");

Метод принимает всего один параметр, который задает имя атрибута стиля.

Поддерживается IE начиная с 5.0

[править] getSelection

Метод возвращает строку, содержащую выделенный пользователем текст.

document.getSelection();

Метод не принимает параметров.

Поддерживается IE начиная с 4.0

[править] go

Метод загружает в окно Web-обозревателя станицу, находящуюся под определенным номером в списке "истории".

Для IE:

history.go({Номер позиции});

Метод принимает только один параметр, который задает порядковый номер позиции страницы в списке "истории".

Метод не возвращает значения.

Поддерживается IE начиная с 3.02

Для NN:

history.go("{Интернет-адрес}"|{Приращение});

Метод принимает только один параметр.

Это либо интернет-адрес одной из ранее посещенных Web-страниц, либо целочисленное приращение, сдвиг текущей позиции в списке "истории".

Метод не возвращает значения.

Поддерживается NN начиная с 2.0

Получено с http://spravkaweb.local/index.php/javascript/method/g
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 09:53, 6 января 2007.
  • К этой странице обращались 82 раза.
1.64793992043


Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву H — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву H

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель методов | ::. | A : B : C : D : E : F : G : H : I : J : L : M : N : O : P : Q : R : S : T : U : W

Содержание

  • 1 handleEvent
  • 2 hasChildNodes
  • 3 hasFocus
  • 4 hide
  • 5 home

[править] handleEvent

Метод вызывает обработчик заданного события.

{Объект}.handleEvent({Событие});

Метод принимает только один параметр, который задает ссылку на объект event.

Метод не возвращает значения.

Поддерживается NN начиная с 4.0

[править] hasChildNodes

Метод проверяет, есть ли у указанного объекта дочерние элементы.

{Объект}.hasChildNodes();

Метод не принимает параметров.

Метод возвращает true, если у объекта есть дочерние элементы, и false - в противном случае.

Поддерживается IE начиная с 5.0

[править] hasFocus

Метод проверяет, находится ли данный элемент в фокусе.

{Объект}.hasFocus();

Метод не принимает параметров.

Метод возвращает true, если элемент страницы имеет фокус ввода, и false - в противном случае.

Поддерживается IE начиная с 5.0

[править] hide

Метод делает всплывающее окно невидимым.

{Объект}.hide();

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 5.5

[править] home

Метод заставляет Web-обозреватель загрузить "домашнюю" страничку.

window.home();

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается NN начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/method/h
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 09:56, 6 января 2007.
  • К этой странице обращались 68 раз.
1.32506608963


Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву I — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву I

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель методов | ::. | A : B : C : D : E : F : G : H : I : J : L : M : N : O : P : Q : R : S : T : U : W

Содержание

  • 1 ImportExportFavorites
  • 2 inRange
  • 3 insertAdjacentElement
  • 4 insertAdjacentHTML
  • 5 insertAdjacentText
  • 6 insertBefore
  • 7 insertCell
  • 8 insertRow
  • 9 isEqual
  • 10 IsSubscribed
  • 11 item

[править] ImportExportFavorites

Метод позволяет импортировать или экспортировать "избранные" закладки.

external.ImportExportFavorites(true|false, "{Путь}");

Метод принимает два параметра.

Первый параметр задает операцию: импорт (значение true) или экспорт (значение false).

Второй параметр задает путь, откуда будут импортироваться или куда будут экспортироваться закладки. В случае, если задать пустую строку, Web-обозреватель выдаст стандартное диалоговое окно с выбором папки.

Метод не возвращает значения.

Поддерживается NN начиная с 4.0

[править] inRange

Метод позволяет узнать, находится ли внутри объекта заданный объект TextRange.

{Объект TextRange}.inRange({Сравниваемый объект TextRange});

Метод возвращает true, если переданный в параметре объект TextRange содержится внутри текущего объекта или равен ему, и false - в противном случае.

Метод принимает всего один параметр, который задает ссылку на сравниваемый объект TextRange.

Поддерживается NN начиная с 4.0

[править] insertAdjacentElement

Метод вставляет вновь созданный элемент страницы внутрь текущего элемента или рядом с ним.

{Объект}.insertAdjacentElement("beforeBegin|afterBegin|beforeEnd|afterEnd", {Вставляемый элемент страницы});

Метод принимает два параметра.

Первый параметр задает место, куда будет вставлен элемент страницы. Для этого параметра доступно четыре параметра:

  • beforeBegin - элемент будет вставлен перед открывающим тегом текущего элемента страницы;
  • afterBegin - будет вставлен после открывающего тега текущего элемента страницы;
  • beforeEnd - будет вставлен перед закрывающим тегом текущего элемента страницы (но после всего содержимого тега);
  • afterEnd - будет вставлен после закрывающего тега текущего элемента страницы.

Второй параметр задает ссылку на элемент страницы, который мы хотим вставить.

Этот метод возвращает ссылку на элемент страницы, который мы вставили.

Поддерживается IE начиная с 5.0

[править] insertAdjacentHTML

Метод вставляет кусок HTML-кода внутри или рядом с определенным тегом.

{Объект}.insertAdjacentHTML("beforeBegin|afterBegin|beforeEnd|afterEnd", {Вставляемый HTML-код});

Метод принимает два параметра.

Первый параметр задает место, куда будет вставлен HTML-код. Для этого параметра доступно четыре параметра:

  • beforeBegin - код будет вставлен перед открывающим тегом текущего элемента страницы;
  • afterBegin - будет вставлен после открывающего тега текущего элемента страницы;
  • beforeEnd - будет вставлен перед закрывающим тегом текущего элемента страницы (но после всего содержимого тега);
  • afterEnd - будет вставлен после закрывающего тега текущего элемента страницы.

Второй параметр задает HTML-код, который мы хотим вставить.

Этот метод не возвращает значения.

Поддерживается IE начиная с 4.0

[править] insertAdjacentText

Метод вставляет текст внутри или рядом с определенным элементом страницы.

{Объект}.insertAdjacentText("beforeBegin|afterBegin|beforeEnd|afterEnd", {Вставляемый текст});

Метод принимает два параметра.

Первый параметр задает место, куда будет вставлен текст. Для этого параметра доступно четыре параметра:

  • beforeBegin - текст будет вставлен перед открывающим тегом текущего элемента страницы;
  • afterBegin - будет вставлен после открывающего тега текущего элемента страницы;
  • beforeEnd - будет вставлен перед закрывающим тегом текущего элемента страницы (но после всего содержимого тега);
  • afterEnd - будет вставлен после закрывающего тега текущего элемента страницы.

Второй параметр задает текст, который мы хотим вставить.

Этот метод не возвращает значения.

Поддерживается IE начиная с 4.0

[править] insertBefore

Метод вставляет элемент в страницу.

{Объект}.insertBefore({Элемент страницы, который мы хотим вставить}[, "{Дочерний элемент}"]);

Метод принимает два параметра.

Первый параметр задает ссылку на элемент, который мы хотим вставить.

Второй необязательный параметр задает ссылку на элемент Web-страницы, перед которым будет произведена вставка.

Этот метод возвращает ссылку, на элемент страницы, который мы вставили.

Поддерживается IE начиная с 5.0

[править] insertCell

Метод вставляет ячейку в строку таблицы.

{Объект строки таблицы}.insertСell([{Индекс}]);

Метод принимает всего один необязательный параметр, который задает индекс только что вставленной ячейки в коллекции cells.

В случае, если параметр не указан, ячейка добавляется в конец коллекции (значение -1).

Этот метод возвращает ссылку на вставленную ячейку.

Поддерживается IE начиная с 4.0

[править] insertRow

Метод вставляет ячейку в таблицу или одну из столбцов.

{Объект строки таблицы}.insertRow([{Индекс}]);

Метод принимает всего один необязательный параметр, который задает индекс только что вставленной строки в коллекции rows.

В случае, если параметр не указан, строка добавляется в конец коллекции (значение -1).

Этот метод возвращает ссылку на вставленную строку.

Поддерживается IE начиная с 4.0

[править] isEqual

Метод позволяет сравнить некоторый объект TextRange с текущим объектом.

{Объект TextRange}.isEqual({Сравниваемый объект TextRange});

Метод принимает всего один параметр, который задает ссылку на сравниваемый объект TextRange.

Метод возвращает true, если переданный в параметре объект TextRange равен текущему объекту.

Поддерживается IE начиная с 4.0

[править] IsSubscribed

Метод позволяет узнать, подписан ли клиент на определенный канал, или нет.

external.IsSubscribed("{Интернет-адрес CDF-файла}");

Метод принимает всего один параметр, который задает интернет-адрес CDF-файла, который описывает канал.

Метод возвращает true, если клиент подписан на данный канал, и false - в противном случае.

Поддерживается IE начиная с 4.0

[править] item

Метод возвращает элемент коллекции под заданным номером.

{Коллекция}.item({Индекс}[, {Вторичный индекс}]);

Метод принимает два параметра.

Первый параметр задает индекс нужного элемента в коллекции. Индекс может быть представлен как в числовом виде, так и при помощи строкового значения.

Если индекс задан как число, то возвращается элемент под данным номером.

Если индекс задан как строковое значение, то возвращается элемент, у которого значение атрибутов ID и NAME совпадают с этим строковым значением.

В случае, если возвращенных значений несколько, то возвращается новая коллекция, которая содержит все найденные элементы коллекции. В этом случае может быть задан второй необязательный параметр, который задает вторичный индекс, задающий номер элемента вторичной коллекции.

Если подходящий элемент коллекции не найден, метод возвращает null.

Числовые индексы поддерживаются для коллекций: bookmarks, children, pages, childNodes, controlRange, rules.

Вторичные индексы недоступны для коллекций: attributes, behaviorUrns, filters, frames, imports, namespaces, styleSheets, TextRange, TextRectangle.

Поддерживается IE начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/method/i
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 10:40, 6 января 2007.
  • К этой странице обращались 74 раза.
1.23571491241


Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву J — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву J

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель методов | ::. | A : B : C : D : E : F : G : H : I : J : L : M : N : O : P : Q : R : S : T : U : W

[править] javaEnabled

Метод определяет, разрешено ли пользователю использовать скриптовые программы.

navigator.javaEnabled();

Метод не принимает параметров.

Метод возвращает true, если пользователю разрешено использование скриптовых программ, и false - в противном случае.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 3.0

Получено с http://spravkaweb.local/index.php/javascript/method/j
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 10:41, 6 января 2007.
  • К этой странице обращались 62 раза.
1.38151478767


Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву L — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву L

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель методов | ::. | A : B : C : D : E : F : G : H : I : J : L : M : N : O : P : Q : R : S : T : U : W

[править] lastPage

Метод для таблицы, привязанной к данным, отобразить последнюю таблицу этих данных.

{Объект таблицы}.lastPage();

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 5.0

[править] load

Метод загружает в слой Web-страницу.

{Объект слоя}.load("{Интернет-адрес страницы}", {Ширина слоя});

Метод принимает два параметра.

Первый параметр задает интернет-адрес страницы, которая будет загружена в слой.

Второй параметр задает новую ширину слоя в пикселах.

Метод не возвращает значения.

Поддерживается NN начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/method/l
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 10:43, 6 января 2007.
  • К этой странице обращались 62 раза.
1.56378793716


Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву M — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву M

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель методов | ::. | A : B : C : D : E : F : G : H : I : J : L : M : N : O : P : Q : R : S : T : U : W

Содержание

  • 1 margins
  • 2 mergeAttributes
  • 3 move
  • 4 moveAbove
  • 5 moveBelow
  • 6 moveBy
  • 7 moveEnd
  • 8 moveRow
  • 9 moveStart
  • 10 moveTo
  • 11 moveToAbsolute
  • 12 moveToBookmark
  • 13 moveToElementText
  • 14 moveToPoint

[править] margins

Метод задает размеры отступов между элементом страницы и его соседями.

{Объект стиля}.margins("{Верхний отступ}", "{Правый}", "{Нижний}", "{Левый}");

Метод принимает четыре параметра, которые задаются строковыми значениями. Эти параметры задают размеры верхнего, правого, нижнего и левого отступа соответственно.

Метод не возвращает значения.

Поддерживается NN начиная с 4.0

[править] mergeAttributes

Метод позволяет копировать в текущий элемент страницы все атрибуты с их значениями из другого элемента страницы.

{Объект}.mergeAttributes({Источник-элемент страницы}[, true|false]);

Метод принимает два параметра.

Первый параметр задает ссылку на элемент страницы, из которого будут копироваться атрибуты.

Второй необязательный параметр позволяет разрешить конфликты при копировании атрибутов у источника, которые уже содержаться в данном элементе страницы.

Если второй параметр имеет значение true (по умолчанию), то все значения атрибутов у текущего элемента при совпадении с копируемыми атрибутами будут сохранены.

Если второй параметр имеет значение false, то все значения атрибутов при совпадении с копируемыми будут переписаны.

Начиная с версии браузера IE 5.5 разрешается копировать атрибуты, предназначенные только для чтения, например, ID.

Метод не возвращает значения.

Поддерживается IE начиная с 5.0

[править] move

Метод перемещает содержимое объекта TextRange на заданное количество элементов текста.

{Объект TextRange}.move("character|word|sentence|textedit"[, {Количество}]);

Метод принимает два параметра.

Первый параметр задает тип элемента текста.

Доступны следующие значения:

  • character - символ;
  • word - слово;
  • sentence - предложение;
  • textedit - область текста, находившаяся в этом объекте ранее.

Второй необязательный параметр задает количество элементов текста, на которое будет сдвинут объект TextRange.

Второй параметр имеет значение по умолчанию 1.

Метод возвращает количество элементов текста, на которое фактически был сдвинут объект TextRange.

Поддерживается IE начиная с 4.0

[править] moveAbove

Метод помещает текущий слой выше заданного.

{Объект слоя}.moveAabove({Слой});

Метод принимает только один параметр, который задает ссылку на слой, выше которого надо поместить текущий слой.

Метод не возвращает значения.

Поддерживается NN начиная с 4.0

[править] moveBelow

Метод помещает текущий слой ниже заданного.

{Объект слоя}.moveBelow({Слой});

Метод принимает только один параметр, который задает ссылку на слой, ниже которого надо поместить текущий слой.

Метод не возвращает значения.

Поддерживается NN начиная с 4.0

[править] moveBy

Метод позволяет переместить слой или окно Web-обозревателя на заданное количество пикселей.

window.moveBy({X}, {Y});

Метод принимает два параметра.

Эти параметры задают смещение окна по горизонтали и вертикали соответственно.

Метод не возвращает значения.

Поддерживается IE и NN начиная с 4.0

{Объект слоя}.moveBy({X}, {Y});

Метод принимает два параметра.

Эти параметры задают смещение слоя по горизонтали и вертикали соответственно.

Метод не возвращает значения.

Поддерживается NN начиная с 4.0

[править] moveEnd

Метод позволяет переместить конечную границу объекта TextRange на заданное количество элементов текста.

{Объект TextRange}.moveEnd("character|word|sentence|textedit"[, {Количество}]);

Метод принимает два параметра.

Первый параметр задает тип элемента текста, на который будет смещена конечная граница объекта TextRange. Этот параметр может иметь следующие значения:

  • character - символ;
  • word - слово;
  • sentence - предложение;
  • textedit - область текста, находившаяся в этом объекте ранее.

Второй параметр задает количество элементов текста, на которое будет смещена конечная граница объекта TextRange.

Значение для второго параметра по умолчанию 1.

Метод возвращает фактическое количество элементов текста, на которое была смещена конечная граница объекта TextRange.

Поддерживается IE начиная с 4.0

[править] moveRow

Метод позволяет переместить секцию таблицы или ее строку на новую позицию.

{Объект}.moveRow({Старый индекс}, {Новый индекс});

Метод принимает два параметра.

Первый параметр задает старый индекс строки или секции в коллекции row.

Второй параметр задает новый индекс строки или секции в коллекции row.

Метод возвращает ссылку на перемещенную строку или секцию.

Поддерживается IE начиная с 5.0

[править] moveStart

Метод позволяет переместить начальную границу объекта TextRange на заданное количество элементов текста.

{Объект TextRange}.moveStart("character|word|sentence|textedit"[, {Количество}]);

Метод принимает два параметра.

Первый параметр задает тип элемента текста, на который будет смещена начальная граница объекта TextRange. Этот параметр может иметь следующие значения:

  • character - символ;
  • word - слово;
  • sentence - предложение;
  • textedit - область текста, находившаяся в этом объекте ранее.

Второй параметр задает количество элементов текста, на которое будет смещена начальная граница объекта TextRange.

Значение для второго параметра по умолчанию 1.

Метод возвращает фактическое количество элементов текста, на которое была смещена начальная граница объекта TextRange.

Поддерживается IE начиная с 4.0

[править] moveTo

Метод позволяет переместить слой или окно Web-обозревателя в определенную точку экрана.

window.moveTo({X}, {Y});

Метод принимает два параметра.

Эти параметры задают координаты в пикселах смещения левого верхнего угла окна по горизонтали и вертикали соответственно.

Метод не возвращает значения.

Поддерживается IE и NN начиная с 4.0

{Объект слоя}.moveTo({X}, {Y});

Метод принимает два параметра.

Эти параметры задают координаты в пикселах смещение левого верхнего угла слоя по горизонтали и вертикали соответственно.

Метод не возвращает значения.

Поддерживается NN начиная с 4.0

[править] moveToAbsolute

Метод позволяет переместить слой в заданную точку относительно страницы.

{Объект слоя}.moveToAbsolute({X}, {Y});

Метод принимает два параметра.

Эти параметры задают смещение в пикселах левого верхнего угла слоя относительно страницы по горизонтали и вертикали соответственно.

Метод не возвращает значения.

Поддерживается NN начиная с 4.0

[править] moveToBookmark

Метод позволяет переместить объект TextRange на фрагмент текста, заданный "закладкой".

{Объект TextRange}.moveToBookmark("{Закладка}");

Метод принимает всего один параметр - "закладку", полученную с помощью метода getBookmark.

Метод возвращает true, если перемещение на нужный фрагмент текста произошло успешно, и false - в противном случае.

Поддерживается IE начиная с 4.0

[править] moveToElementText

Метод позволяет переместить объект TextRange на фрагмент текста, находящийся в заданном элементе страницы.

{Объект TextRange}.moveToElementText("{Элемент страницы}");

Метод принимает всего один параметр - ссылку на элемент страницы.

Метод не возвращает значения.

Поддерживается IE начиная с 5.0

[править] moveToPoint

Метод перемещает объект TextRange в определенную точку.

{Объект TextRange}.moveToPoint({X}, {Y});

Метод принимает два параметра.

Эти параметры задают в пикселах координаты точки относительно верхнего левого угла окна.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/method/m
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 10:58, 6 января 2007.
  • К этой странице обращались 66 раз.
1.47529387474


Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву N — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву N

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель методов | ::. | A : B : C : D : E : F : G : H : I : J : L : M : N : O : P : Q : R : S : T : U : W

Содержание

  • 1 namedRecordset
  • 2 navigate
  • 3 NavigateAndFind
  • 4 nextpage

[править] namedRecordset

Метод возвращает ссылку на объект именованного поднабора данных.

{Внедренный объект}.namedRecordset("{Имя}"[, "{Путь}"]);

Метод принимает два параметра.

Первый параметр задает имя поднабора данных.

Второй необязательный параметр задает путь к набору данных.

Поддерживается IE начиная с 5.0

[править] navigate

Метод позволяет загрузить новую Web-страницу в текущее окно Web-обозревателя.

window.navigate("{Интернет-адрес}");

Метод принимает всего один параметр, который задает интернет-адрес новой страницы.

Метод не возвращает значения.

Поддерживается IE начиная с 3.02

[править] NavigateAndFind

Метод загружает новую Web-страницу в текущее окно Web-обозревателя и выделяет в ней заданный текст, если он присутствует.

external.NavigateAndFind("{Интернет-адрес}", "{Искомый текст}", "{Фрейм}");

Метод принимает три параметра.

Первый параметр задает интренет-адрес Web-страницы, которая будет загружена в текущий Web-обозреватель.

Второй параметр задает текст, который следует найти на этой новой странице.

Третий параметр задает имя фрейма, в который будет выведена новая только что подгруженная страница. Этот параметр можно указать пустой строкой.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

[править] nextpage

Метод отображает в таблице, привязанной к данным, следующую порцию (страницу) этих данных.

{Объект таблицы}.nextPage();

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/method/n
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:00, 6 января 2007.
  • К этой странице обращались 66 раз.
1.78195881844


Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву O — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву O

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель методов | ::. | A : B : C : D : E : F : G : H : I : J : L : M : N : O : P : Q : R : S : T : U : W

[править] open

Метод открывает новое окно Web-обозревателя или новую Web-страницу.

document.open("{Тип данных MIME}"[, "{Имя новой страницы}"]);

В такой интерпретации метод открывает Web-страницу перед использованием методов write и writeln.

Метод принимает два параметра.

Первый параметр задает тип данных MIME, которые будут переданы в страницу.

Второй необязательный параметр может принимать только имя replace, позволяющее заменить текущую позицию в списке "истории".

Метод возвращает ссылку на текущую Web-страницу.

Поддерживается IE начиная с 3.02 и NN начиная с 2.0

window.open(["{Интернет-адрес}"][, "{Имя окна}"][, "{Параметры}"][, true|false]);

В такой интерпретации метод открывает новое окно Web-обозревателя.

Метод принимает четыре необязательных параметра.

Первый необязательный параметр задает интернет-адрес Web-страницы, которая будет загружена в только что открытое окно.

Второй необязательный параметр задает имя нового окна или имеет одно из пяти предопределенных значений:

  • _blank - открывает страницу в новом окне без имени;
  • _parent - открывает страницу в родительском окне;
  • _search - открывает страницу в панели поиска (доступно только в IE 5.0 и более поздних);
  • _self - открывает страницу в том же окне;
  • _top - открывает страницу в самом верхнем родительском окне.

Третий необязательный параметр задает список дополнительных характеристик окна.

И, наконец, четвертый необязательный параметр позволяет указать, заменить ли текущую позицию в списке "истории" на новую (значение true) или оставить все как было (значение false).

Метод возвращает ссылку на новое окно.

Поддерживается IE начиная с 3.02 и NN начиная с 2.0

Получено с http://spravkaweb.local/index.php/javascript/method/o
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:02, 6 января 2007.
  • К этой странице обращались 77 раз.
1.41847491264


Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву P — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву P

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель методов | ::. | A : B : C : D : E : F : G : H : I : J : L : M : N : O : P : Q : R : S : T : U : W

Содержание

  • 1 paddings
  • 2 parentElement
  • 3 pasteHTML
  • 4 preference
  • 5 previousPage
  • 6 print
  • 7 prompt

[править] paddings

Метод задает размер отступов между элементом страницы и рамкой.

{Объект стиля}.paddings("{Верхний}", "{Правый}", "{Нижний}", "{Левый}");

Метод принимает четыре параметра.

Параметры задают верхний, правый, нижний и левый отступы соответственно.

Метод не возвращает значения.

Поддерживается NN начиная с 4.0

[править] parentElement

Метод возвращает ссылку на родительский элемент данного объекта TextRange.

{Объект TextRange}.parentElement();

В случае, если родительский элемент отсутствует, метод возвращает null.

Метод не принимает параметров.

Поддерживается IE начиная с 4.0

[править] pasteHTML

Метод позволяет вставить фрагмент HTML-кода в объект TextRange, заменяя все его содержимое.

{Объект TextRange}.pasteHTML("{Вставляемый HTML-код}");

Метод принимает всего один параметр, который задает непосредственно сам вставляемый HTML-код.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

[править] preference

Метод позволяет получить или изменить значения некоторых пользовательских настроек.

navigator.preference("{Имя настройки}"[, {Значение}]);

Метод принимает два параметра.

Первый параметр задает имя настройки, которую надо получить или изменить.

Второй необязательный параметр задает значение выбранной настройки.

В случае, если второй параметр не указан, метод возвратит текущее значение настройки.

Перечень всех доступных настроек указан в следующей таблице:

Настройка | Описание | Значение
general.always_load_images | Загружать или не загружать рисунки автоматически | true - загружать, false - не загружать
security.enable_java | Разрешить или запретить выполнение Java-апплетов | true - разрешить,false - запретить
javascript.enabled | Разрешить или запретить выполнение Java-скриптов | true - разрешить, false - запретить
browser.enable_style_sheets | Разрешить или запретить использование таблиц стилей | true - разрешить, false - запретить
autoupdate.enabled | Разрешить или запретить SmartUpdate (автоматическое обновление программы Web-обозревателя через Интернет) | true - разрешить, false - запретить
network.cookie_cookieBehavior | Разрешить получение всех cookie | 0
network.cookie_cookieBehavior | Получать только те cookie, которые отправляются обратно на Web-сервер | 1
network.cookie_cookieBehavior | Запретить все cookie | 2
network.cookie.warnAboutCookies | Спрашивать или не спрашивать у пользователя разрешения на получение cookie | true - спрашивать, false - не спрашивать

Поддерживается NN начиная с 4.0

[править] previousPage

Метод позволяет отобразить в таблице, привязанной к данным, предыдущую порцию (страницу) этих данных.

{Объект таблицы}.previousPage();

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

[править] print

Метод печатает Web-страницу, находящуюся в текущем окне, на принтере.

window.print();

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 5.0

Поддерживается NN начиная с 4.0

[править] prompt

Метод выводит на экран диалоговое окно с полем ввода, предлагающее пользователю ввести некое значение.

window.prompt(["{Текст приглашения}"][, "{Начальное значение}"]);

Метод принимает два необязательных параметра.

Первый параметр задает текст приглашения, который будет отображаться в диалоговом окне.

Второй параметр задает текст, изначально находящийся в поле ввода.

Метод возвращает текстовые или цифровые значения, которые были введены пользователем в поле ввода.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0

Получено с http://spravkaweb.local/index.php/javascript/method/p
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:08, 6 января 2007.
  • К этой странице обращались 76 раз.
1.26675510406


Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву Q — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву Q

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель методов | ::. | A : B : C : D : E : F : G : H : I : J : L : M : N : O : P : Q : R : S : T : U : W

Содержание

  • 1 queryCommandEnabled
  • 2 queryCommandIndeterm
  • 3 queryCommandState
  • 4 queryCommandSupported
  • 5 queryCommandValue

[править] queryCommandEnabled

Метод проверяет возможность выполнения определенной команды для данного элемента страницы.

{Объект}.queryCommandEnabled("{Команда}");

Метод принимает всего один параметр, который задает обозначение команды, выполняемый с помощью метода execComand.

Метод возвращает true, если для данного фрагмента страницы может быть выполнена данная команда, и false - в противном случае.

Поддерживается IE начиная с 4.0 для document и TextRange

Поддерживается IE начиная с 5.0 для controlRange

[править] queryCommandIndeterm

Метод проверяет в каком состоянии находится команда, доступная для данного фрагмента страницы.

{Объект}.queryCommandIndeterm("{Команда}");

Метод принимает всего один параметр, который задает обозначение команды, выполняемый с помощью метода execComand.

Метод возвращает true, если команда, доступная для данного фрагмента страницы, находится в неопределенном состоянии, и false - в противном случае.

Поддерживается IE начиная с 4.0 для document и TextRange

Поддерживается IE начиная с 5.0 для controlRange

[править] queryCommandState

Метод проверяет, выполнена ли данная команда.

{Объект}.queryCommandState("{Команда}");

Метод принимает всего один параметр, который задает обозначение команды, выполняемый с помощью метода execComand.

Метод возвращает true, если команда, доступная для данного фрагмента страницы, была выполнена.

Поддерживается IE начиная с 4.0 для document и TextRange

Поддерживается IE начиная с 5.0 для controlRange

[править] queryCommandSupported

Метод проверяет, поддерживается ли данным фрагментом страницы данная команда.

{Объект}.queryCommandSupported("{Команда}");

Метод принимает всего один параметр, который задает обозначение команды, выполняемый с помощью метода execComand.

Метод возвращает true, если данным фрагментом страницы поддерживается данная программа.

Поддерживается IE начиная с 4.0 для document и TextRange

Поддерживается IE начиная с 5.0 для controlRange

[править] queryCommandValue

Метод возвращает значение команды, которая доступна для данного фрагмента страницы.

{Объект}.queryCommandValue("{Команда}");

Метод принимает всего один параметр, который задает обозначение команды, выполняемый с помощью метода execComand.

Метод возвращает значение команды, доступное для данного фрагмента страницы, или false, если таковое не поддерживается командой.

Поддерживается IE начиная с 4.0 для document и TextRange

Поддерживается IE начиная с 5.0 для controlRange

Получено с http://spravkaweb.local/index.php/javascript/method/q
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:13, 6 января 2007.
  • К этой странице обращались 64 раза.
1.22448587418


Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву R — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву R

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель методов | ::. | A : B : C : D : E : F : G : H : I : J : L : M : N : O : P : Q : R : S : T : U : W

Содержание

  • 1 random
  • 2 recalc
  • 3 refresh
  • 4 releaseCapture
  • 5 releaseEvents
  • 6 reload
  • 7 remove
  • 8 removeAttribute
  • 9 removeBehavior
  • 10 removeChild
  • 11 removeExpression
  • 12 removeNode
  • 13 removeRule
  • 14 replace
  • 15 replaceAdjacentText
  • 16 replaceChild
  • 17 replaceNode
  • 18 reset
  • 19 resizeBy
  • 20 resizeTo
  • 21 routeEvent

[править] random

Метод возвращает псевдослучайную строку символов заданной длины.

crypto.random({Длина строки в байтах});

Метод принимает всего один параметр, который задает длину возвращаемой строки в байтах.

Поддерживается NN начиная с 4.0

[править] recalc

Метод заставляет все динамические свойства перевычислить свои значения.

document.recalc([true|false});

Метод принимает всего один параметр, который необязателен.

Если этот параметр равен false (значение по умолчанию), то метод производит перевычисление только тех выражений, аргументы которых изменились после последнего перевычисления.

Если параметр равен true, то метод производит перевычисление всех выражений.

Данный метод не возвращает значения.

Поддерживается IE начиная с 5.0

[править] refresh

Данный метод обновляет содержимое таблицы или коллекции plugins.

{Объект таблицы}.refresh();

В данном случае метод обновляет содержимое таблицы.

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

plugins.refresh();

В данном случае метод обновляет содержимое коллекции plugins.

Это может понадобиться, например, для того, чтобы сделать вновь установленные расширения доступными.

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 3.0

[править] releaseCapture

Метод отменяет "захват мыши" для текущего элемента страницы.

{Объект}.releaseCapture();

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 5.0

[править] releaseEvents

Метод отменяет перехват событий данного типа.

document.releaseEvents("{Список имен события}");

Метод принимает всего один параметр, который задает список строковых имен событий, которые должны быть разделены вертикальной чертой "|".

Метод не возвращает значения.

Поддерживается NN начиная с 4.0

[править] reload

Метод перезагружает текущую Web-страницу.

location.reload([true|false});

Метод принимает всего один параметр (необязательный).

Если параметр задан как false (значение по умолчанию), то страница будет перезагружена с жесткого диска, где она была сохранена ранее.

Если параметр задан как true, то страница будет перезагружена прямо с Web-сервера.

Метод не возвращает значения.

Поддерживается IE начиная с 5.0

Поддерживается NN начиная с 3.0

[править] remove

Метод удаляет элемент коллекции.

{Коллекция}.remove({Индекс});

Метод принимает всего один параметр, который задает индекс удаляемого элемента коллекции.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0 для areas и options и начиная с 5.0 для controlRange.

[править] removeAttribute

Метод удаляет заданный атрибут из тега.

{Объект}.removeAttribute("{Имя атрибута}"[, 0|1]);

Метод удаляет заданный атрибут из тега элемента страницы вместе со значением.

Метод принимает два параметра.

Первый параметр задает имя параметра, который будет удален.

Второй необязательный параметр задает, учитывать или нет регистр символов при поиске атрибута.

Если второй параметр имеет значение 1 (по умолчанию), то регистр символов при поиске учитывается.

Если имеет значение 0, то не учитывается.

Если имеются несколько атрибутов с именами, различающимися только регистром символов, удаляется только последний атрибут.

Метод возвращает true, если атрибут был успешно удален, и false в противном случае.

Поддерживается IE начиная с 4.0

[править] removeBehavior

Метод удаляет заданное поведение.

{Объект}.removeBehavior({Идентификатор поведения});

Метод принимает всего один параметр, который задает идентификатор поведения, возвращенный методом addBehavior.

Метод возвращает true, если поведение было успешно удалено, и false - в противном случае.

Поддерживается IE начиная с 5.0

[править] removeChild

Метод удаляет дочерний элемент из текущего элемента.

{Объект}.removeChild({Объект});

Метод принимает всего один параметр, который задает ссылку на удаляемый элемент страницы.

Метод возвращает ссылку на удаленный дочерний элемент.

Поддерживается IE начиная с 5.0

[править] removeExpression

Метод удаляет выражение, присвоенное динамическому атрибуту стиля.

{Объект стиля}.removeExpression("{Имя атрибута}");

Метод принимает всего один параметр, который задает имя атрибута стиля.

Метод возвращает true, если выражение было успешно удалено, и false - в противном случае.

Поддерживается IE начиная с 5.0

[править] removeNode

Метод удаляет текущий элемент из Web-страницы.

{Объект}.removeNode([true|false]);

Метод принимает всего один необязательный параметр, который задает удалять коллекцию childNodes удаляемого элемента страницы (значение true) или нет (значение false, которое используется по умолчанию).

Метод возвращает ссылку на удаленный элемент.

Поддерживается IE начиная с 5.0

[править] removeRule

Метод удаляет правило из текущей таблицы стилей.

{Объект таблицы стилей}.removeRule([{Индекс}]);

Метод принимает всего один необязательный параметр, который задает индекс удаляемого правила в коллекции. В случае, если он не задан, будет удалено первое правило.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

[править] replace

Метод заменяет текущую Web-страницу новой с заменой соответствующей позиции в списке "истории".

location.replace("{Интернет-адрес новой Web-страницы}");

Метод принимает всего один необязательный параметр, который задает интернет-адрес новой Web-страницы.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 3.0

[править] replaceAdjacentText

Метод заменяет текст текущего элемента страницы на другой текст.

{Объект}.replaceAdjacentText("beforeBegin|afterBegin|beforeEnd|afterEnd", "{Заменяющий текст}");

Данный метод заменяет текст, находящийся внутри текущего элемента страницы или рядом с ним, на другой текст. HTML-форматирование при этом игнорируется.

Метод принимает два параметра.

Первый параметр задает место, куда будет вставлен элемент страницы. Для этого параметра доступно четыре значения:

  • beforeBegin - непосредственно перед открывающим тегом текущего элемента страницы;
  • afterBegin - после открывающего тега, но перед всем остальным содержимым элемента;
  • beforeEnd - перед закрывающим тегом, но после всего остального содержимого элемента;
  • afterEnd - непосредственно после закрывающего тега текущего элемента страницы.

Второй параметр задает непосредственно сам заменяющий текст.

Метод возвратит строку, содержащую замещенный текст.

Поддерживается IE начиная с 5.0

[править] replaceChild

Метод заменяет дочерний элемент на другой.

{Объект}.replaceChild({Новый объект}, {Старый объект});

Метод принимает два параметра.

Первый параметр задает ссылку на замещающий элемент страницы.

Второй параметр задает ссылку на замещаемый элемент страницы.

Метод возвратит ссылку на замененный дочерний элемент.

Поддерживается IE начиная с 5.0

[править] replaceNode

Метод заменяет текущий элемент Web-страницы на другой.

{Объект}.replacenode({Новый объект});

Метод принимает всего один параметр, который задает ссылку на новый элемент страницы.

Метод возвратит ссылку на замененный элемент страницы.

Поддерживается IE начиная с 5.0

[править] reset

Метод производит сброс данных формы.

{Объект формы}.reset();

Этот метод аналогичен по действию нажатию кнопки reset (<input type=reset>).

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 3.0

[править] resizeBy

Метод изменяет размеры окна или слоя.

window.resizeBy({X}, {Y});

В такой интерпретации метод изменяет размеры окна Web-обозревателя на заданное количество пикселов.

Метод принимает два параметра.

Эти параметры задают приращение ширины и высоты окна в пикселах соответственно.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 4.0

{Объект слоя}.resizeBy({X}, {Y});

В такой интерпретации метод изменяет размеры слоя на заданное количество пикселов.

Метод принимает два параметра.

Эти параметры задают приращение ширины и высоты слоя в пикселах соответственно.

Метод не возвращает значения.

Поддерживается NN начиная с 4.0

[править] resizeTo

Метод задает размеры окна или слоя.

window.resizeTo({X}, {Y});

В такой интерпретации метод задает размеры окна Web-обозревателя.

Метод принимает два параметра.

Эти параметры задают ширину и высоту окна в пикселах соответственно.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 4.0

{Объект слоя}.resizeTo({X}, {Y});

В такой интерпретации метод задает размеры слоя.

Метод принимает два параметра.

Эти параметры задают ширину и высоту слоя в пикселах соответственно.

Метод не возвращает значения.

Поддерживается NN начиная с 4.0

[править] routeEvent

Метод передает событие элемента, в котором оно произошло, для дальнейшей обработки.

document.routeEvent({СОбытие});

Метод принимает один параметр, который задает ссылку на объект event.

Метод не возвращает значения.

Поддерживается NN начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/method/r
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:26, 6 января 2007.
  • К этой странице обращались 79 раз.
1.50053501129


Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву S — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву S

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель методов | ::. | A : B : C : D : E : F : G : H : I : J : L : M : N : O : P : Q : R : S : T : U : W

Содержание

  • 1 savePreferences
  • 2 scroll
  • 3 scrollBy
  • 4 scrollIntoView
  • 5 scrollTo
  • 6 select
  • 7 setActive
  • 8 setattribute
  • 9 setCapture
  • 10 setData
  • 11 setEndPoint
  • 12 setExpression
  • 13 setHotKeys
  • 14 setInterval
  • 15 setResizable
  • 16 setTimeout
  • 17 setZOption
  • 18 show
  • 19 ShowBrowserUI
  • 20 showHelp
  • 21 showModalDialog
  • 22 showModelessDialog
  • 23 signText
  • 24 splitText
  • 25 start
  • 26 stop
  • 27 submit
  • 28 swapNode

[править] savePreferences

Метод позволяет сохранить пользовательские настройки.

navigator.savePreferences();

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается NN начиная с 4.0

[править] scroll

Метод позволяет прокрутить содержимое Web-обозревателя до заданной точки.

window.scroll({X}, {Y});

Метод принимает два параметра.

Эти параметры задают координаты точки в пикселах, до которой следует прокрутить содержимое окна, - горизонтальную и вертикальную соответственно.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 3.0, удален в NN 4.0

[править] scrollBy

Метод позволяет прокрутить содержимое Web-обозревателя на определенное количество пикселов.

window.scrollBy({X}, {Y});

Метод принимает два параметра.

Эти параметры задают приращение для прокрутки по горизонтали и вертикали окна соответственно. Положительные величины задают прокрутку вправо и вниз, отрицательные - влево и вверх.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 4.0

[править] scrollIntoView

Метод позволяет прокрутить содержимое Web-обозревателя так, чтобы текущий элемент страницы стал виден.

{Объект}.scrollIntoView([true|false]);

Метод принимает один необязательный параметр, который задает, должен ли текущий элемент страницы быть виден у верхнего края окна (значение true, используемое по умолчанию) или у нижнего (значение false).

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

[править] scrollTo

Метод позволяет прокрутить содержимое окна Web-обозревателя до заданной точки.

window.scrollTo({X}, {Y});

Метод принимает два параметра, которые задают координаты точки в пикселах, до которой следует прокрутить содержимое окна, - горизонтальную и вертикальную соответственно.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 4.0

[править] select

Метод выделяет элемент управления или текст.

{Объект}.select();

В такой интерпретации метод позволяет выделить на Web-странице текст, являющийся содержимым текущего объекта.

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0 для TextRange и начиная с 5.0 для controlRange.

{Объект элемента управления}.select();

В такой интерпретации метод позволяет выделить элемент управления.

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 2.0

[править] setActive

Метод делает текущий элемент страницы активным без переноса на него фокуса ввода.

{Объект}.setActive();

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 5.0

[править] setattribute

Метод помещает в тег элемента страницы новый атрибут вместе со значением.

{Объект}.setAttribute("{Имя атрибута}", "{Значение атрибута}"[, 0|1]);

Метод принимает три параметра.

Первый параметр задает имя помещаемого атрибута.

Второй параметр задает значение помещаемого атрибута.

Если имя вновь помещаемого атрибута совпадает с именем другого атрибута, который уже существует, то старый атрибут будет перезаписан новым значением.

Третий необязательный параметр задает, учитывать при замене регистр символов (значение 1, используется по умолчанию) или нет (значение 0).

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

[править] setCapture

Метод заставляет текущий элемент страницы перехватить все события мыши вне зависимости от того, каким элементом страницы они были вызваны.

{Объект}.setCapture([true|false]);

Метод принимает только один необязательный параметр, который задает, будет ли текущий элемент страницы перехватывать все события, вызванные дочерними элементами (значение true, используемое по умолчанию), или нет (значение false).

Если параметр равен false, то события направляются соответствующим элементам и потом постепенно "всплывают" к родителям (обычное поведение событий).

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

[править] setData

Метод помещает данные в объект clipboardData или dataTransfer.

{Объект}.setData("{Формат}", "{Данные}");

Метод принимает два параметра.

Первый параметр задает формат помещаемых данных. Это параметр может принимать два значения:

  • text - помещает обычный текст;
  • URL - помещает интернет-адрес.

Второй параметр задает помещаемые данные.

Метод возвращает true, если данные были успешно помещены, и false - в противном случае.

Поддерживается IE начиная с 5.0

[править] setEndPoint

Метод устанавливает границу текущего объекта TetRange по границе другого аналогичного объекта.

{Объект TextRange}.setEndPoint(StartToEnd|StartToStart|EndToStart|EndToEnd, {Второй объект TextRange});

Метод принимает два параметра.

Первый параметр задает границы объектов. Возможны четыре значения:

  • StartToEnd - начальная граница текущего объекта совмещается с конечной границей второго объекта;
  • StartToStart - начальная с начальной;
  • EndToStart - конечная с начальной;
  • EndToEnd - конечная с конечной.

Второй параметр задает ссылку на второй объект TextRange.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

[править] setExpression

Метод присваивает выражение динамическому атрибуту стиля.

{Объект стиля}.setEexpression("{Имя атрибута}", "{Выражение}"[, "JScript|VBScript|JavaScript"]);

Метод принимает три параметра.

Первый параметр задает имя атрибута стиля.

Второй параметр задает исходный текст выражения на скриптовом языке.

Третий необязательный параметр задает сам скриптовый язык.

Для третьего параметра доступны три значения:

JScript (по умолчанию), VBScript и JavaScript.

Метод не возвращает значения.

Поддерживается IE начиная с 5.0

[править] setHotKeys

Метод разрешает или запрещает "горячие" клавиши в окне без строки меню.

window.setHotKeys(true|false);

Метод принимает один параметр, который разрешает (значение true) или запрещает (значение false) использование "горячих" клавиш.

Поддерживается NN начиная с 4.0

[править] setInterval

Метод создает новый интервальный таймер.

window.setInterval("{Выражение}"|{Функция}, {Интервал}[, "{Язык}"]);

Метод принимает три параметра.

Первый параметр задает либо имя функции, либо текст выражения, которое будет выполняться каждый раз по истечении заданного времени.

Второй параметр задает само это время в миллисекундах.

Третий необязательный параметр задает скриптовый язык, на котором написано выражение или функция.

Метод возвращает целочисленный идентификатор вновь созданного интервального таймера.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 4.0

[править] setResizable

Метод разрешает или запрещает пользователю изменить размеры окна.

window.setResizable(true|false);

Метод принимает один параметр, который разрешает (значение true) или запрещает (значение false) изменять размеры окна.

Поддерживается NN начиная с 4.0

[править] setTimeout

Метод создает новый тайм-аут.

window.setTimeout("{Выражение}"|{Функция}, {Интервал}[, "{Язык}"]);

Метод принимает три параметра.

Первый параметр задает или имя функции, или текст выражения, которое выполниться по истечении заданного времени.

Второй параметр задает само это время в миллисекундах.

Третий необязательный параметр задает скриптовый язык, на котором написано выражение или функция. Возможны три значения:

JScript (по умолчанию), JavaScript и VBScript.

Метод возвращает целочисленный идентификатор вновь созданного тайм-аута.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0; вызов функции - только с 4.0

[править] setZOption

Метод задает порядок перекрытия текущего окна другими окнами.

window.setZOption("alwaysRaised|alwaysLowered|z-lock");

Метод принимает один параметр, который может принимать три значения:

  • alwaysRaised - заставляет текущее окно находиться над остальными окнами, даже если оно неактивно;
  • alwaysLowered - заставляет текущее окно находиться под остальными окнами, даже если оно активно;
  • z-lock - заставляет текущее окно сохранять свое расположение.

Поддерживается NN начиная с 4.0

[править] show

Метод показывает всплывающее окно.

{Объект}.show({X}, {Y}, {Ширина}, {Высота}[, {Объект}]);

Метод принимает до пяти параметров.

Первые четыре из них задают горизонтальную и вертикальную координаты левого верхнего угла окна, его ширину и высоту.

Последний необязательный параметр задает ссылку на объект, относительно которого будут вычисляться эти координаты: по умолчанию это экран компьютера screen.

Поддерживается IE начиная с 5.5

[править] ShowBrowserUI

Метод открывает одно из диалоговых окон программы Web-обозревателя.

external.ShowBrowserUI("LanguageDialog|OrganizeFavorites", null);

Метод принимает два параметра.

Первый параметр задает диалоговое окно, которое будет открыто при вызове этого метода.

Для первого параметра доступно два значения:

  • LanguageDialog - вызов языка;
  • OrganizeFavorites - упорядочить избранное.

Второй параметр всегда равен null.

Значение, возвращаемое методом, не используется.

Поддерживается IE начиная с 5.0

[править] showHelp

Метод выводит окно справки.

window.showHelp("{Интернет-адрес}"[, "{Контекстный идентификатор}"]);

Метод принимает два параметра.

Первый параметр задает интернет-адрес Web-страницы, которая будет выводиться в окне справки.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

[править] showModalDialog

Метод выводит модальное диалоговое Web-окно.

window.showModalDialog("{Интернет-адрес}"[, {Аргументы}][, "{Параметры}"]);

Метод принимает три параметра.

Первый параметр задает интернет-адрес Web-страницы, которая будет выведена как модальное диалоговое окно.

Второй необязательный параметр задает дополнительные данные, которые будут переданы в диалоговое окно. В этот параметр можно задать данные любого типа, в том числе и массив.

Третий необязательный параметр задает дополнительные характеристики самого окна.

Метод возвращает значение, присвоенное свойству returnValue диалогового окна.

Поддерживается IE начиная с 4.0

[править] showModelessDialog

Метод выводит немодальное диалоговое Web-окно.

window.showModelessDialog("{Интернет-адрес}"[, {Аргументы}][, "{Параметры}"]);

Метод принимает три параметра.

Первый параметр задает интернет-адрес Web-страницы, которая будет выведена как немодальное диалоговое окно.

Второй необязательный параметр задает дополнительные данные, которые будут переданы в диалоговое окно. В этот параметр можно задать данные любого типа, в том числе и массив.

Третий необязательный параметр задает дополнительные характеристики самого окна.

Метод возвращает ссылку на созданное окно.

Поддерживается IE начиная с 5.0

[править] signText

Метод шифрует строку текста.

crypto.signText("{Текст}", "ask|auto"[, "{Сертификат 1}"]...[, "{Сертификат n}"]);

Метод принимает два необязательных параметра.

Первый параметр задает шифруемый текст.

Второй параметр позволяет задать пользовательский сертификат, с помощью которого текст будет шифроваться: значение ask приведет к показу диалогового окна, в котором пользователь должен будет выбрать нужный сертификат, а значение auto отдаст выбор сертификата на откуп Web-обозревателю. В последнем случае необходимо будет задать дополнительные строковые параметры - список сертификатов.

Метод возвращает зашифрованный текст.

Поддерживается NN начиная с 4.0

[править] splitText

Метод делит текст текущего объекта TextNode страницы на две части и помещает вторую часть во вновь созданный объект TextNode.

TextNode.splitText([{Индекс}]);

Метод принимает один необязательный параметр, который задает индекс (номер) символа в строке, по которому строка будет разделена на две части. Если он пропущен или равен 0, будет создан новый объект TextNode, содержащий пустую строку.

Метод возвращает ссылку на вновь созданный объект TextNode.

Поддерживается IE начиная с 5.0

[править] start

Метод запускает прокрутку текста в теге <MARQUEE>.

{Объект}.start();

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

[править] stop

Метод останавливает прокрутку текста в теге <MARQUEE> или останавливает загрузку Web-страницы.

{Объект}.stop();

В такой интерпретации метод останавливает прокрутку текста в текущем элементе <MARQUEE>.

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 4.0

window.stop();

В такой интерпретации метод останавливает загрузку Web-страницы.

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается NN начиная с 4.0

[править] submit

Метод вызывает отправку данных формой серверному приложению.

{Объект формы}.submit();

Данный метод аналогичен по действию нажатию кнопки submit (<input type=submit>).

Метод не принимает параметров.

Метод не возвращает значения.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0

[править] swapNode

Метод меняет местами два элемента страницы: текущий и переданный в параметре.

{Объект}.swapNode({Второй элемент});

Метод принимает один параметр, который задает ссылку на второй элемент страницы.

Метод возвращает ссылку на текущий элемент страницы.

Поддерживается IE начиная с 5.0

Получено с http://spravkaweb.local/index.php/javascript/method/s
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 13:21, 6 января 2007.
  • К этой странице обращались 107 раз.
1.59507393837


Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву T — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву T

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель методов | ::. | A : B : C : D : E : F : G : H : I : J : L : M : N : O : P : Q : R : S : T : U : W

[править] tags

Метод возвращает коллекцию элементов страницы, созданных с помощью заданного тега, или null, если таковых нет.

{Коллекция}.tags({Тег});

Метод принимает один параметр, который задает имя нужного тега.

Поддерживается IE начиная с 4.0

[править] taintEnabled

Метод позволяет определить, поддерживает ли Web-обозреватель бойкот данных.

navigator.taintEnabled();

Метод не принимает параметров.

Метод возвращает true, если Web-обозреватель поддерживает бойкот данных, и false - в противном случае.

Поддерживается IE начиная с 4.0, но возвращает всегда false.

Поддерживается только NN 3.0, в 4.0 и более поздних версиях этот метод удален.

Получено с http://spravkaweb.local/index.php/javascript/method/t
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 13:22, 6 января 2007.
  • К этой странице обращались 63 раза.
1.44901704788


Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву U — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву U

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель методов | ::. | A : B : C : D : E : F : G : H : I : J : L : M : N : O : P : Q : R : S : T : U : W

[править] urns

Метод возвращает коллекцию элементов страницы, к которым было привязано данное поведение, или null, если таковых нет.

{Коллекция}.urns("{Поведение}");

Метод принимает один параметр, который задает имя нужного поведения в формате URN.

Поддерживается IE начиная с 5.0

Получено с http://spravkaweb.local/index.php/javascript/method/u
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 13:23, 6 января 2007.
  • К этой странице обращались 62 раза.
1.54809188843


Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву W — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель методов : Методы JavaScript на букву W

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель методов | ::. | A : B : C : D : E : F : G : H : I : J : L : M : N : O : P : Q : R : S : T : U : W

[править] write

Метод помещает в данное место Web-страницы HTML-код или простой текст, переданный в качестве параметра.

document.write("{Текст или HTML-код}");

Метод принимает один параметр, который задает строку вставляемого текста или HTML-кода.

Метод не возвращает значения.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0

[править] writeln

Метод помещает в данное место Web-страницы HTML-код или простой текст, переданный в качестве параметра.

document.writeln("{Текст или HTML-код}");

Данный метод завершает вставленный текст или HTML-код символом возврата каретки, что может иметь значение в тексте с заданным форматом.

Метод принимает один параметр, который задает строку вставляемого текста или HTML-кода.

Метод не возвращает значения.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0

Получено с http://spravkaweb.local/index.php/javascript/method/w
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 13:25, 6 января 2007.
  • К этой странице обращались 68 раз.
1.50269389153


Справочник по JavaScript : Алфавитный указатель свойств : Свойства JavaScript на букву A — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель свойств : Свойства JavaScript на букву A

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель свойств | ::. | A : B : C : D : E : F : H : I : K : L

Содержание

  • 1 above
  • 2 accelerator
  • 3 accessKey
  • 4 action
  • 5 activeElement
  • 6 align
  • 7 aLink
  • 8 alinkColor
  • 9 allowTransparency
  • 10 alt
  • 11 altHTML
  • 12 altKey
  • 13 altLeft
  • 14 appCodeName
  • 15 appMinorVersion
  • 16 appName
  • 17 appVersion
  • 18 autocomplete
  • 19 availHeight
  • 20 availLeft
  • 21 availTop
  • 22 availWidth

[править] above

Возвращает ссылку на слой, находящийся выше текущего, или на окно Web-обозревателя, если текущий слой - самый верхний.

{Объект слоя}.above();

Свойство доступно только для чтения.

Поддерживается NN начиная c 4.0

[править] accelerator

Указывает, содержит ли текст элемента страницы клавишу ускоритель.

{Объект стиля}.accelerator[ = "true|false"];

Клавиша-ускоритель - специальная клавиша на клавиатуре, при нажатии на которую совместно с клавишей <ALT> происходит переход к данному элементу страницы.

Для этого свойства доступны два значения:

  • Первое значение true указывает, что текст содержит клавишу-ускоритель.
  • Второе значение false указывает, что не содержит.

Значения по умолчанию нет.

Данное свойства доступно для чтения и для записи. В случае объекта currentStyle - только для чтения.

Поддерживается IE начиная c 5.0

[править] accessKey

Задает или возвращает клавишу-ускоритель для быстрого доступа к элементу страницы.

{Объект}.accessKey[ = "{Клавиша-ускоритель}"];

Например, можно присвоить клавишу-ускоритель полю ввода, и при нажатии ее вместе с клавишей <ALT> поле ввода будет активизироваться.

Поддерживается IE начиная c 4.0 для элементов управления и внедренных объектов и начиная с 5.0 для всех остальных элементов.

[править] action

Задает или возвращает интернет-адрес серверной программы, которой форма передаст введенные пользователем данные.

{Объект формы}.action[ = "{Интернет-адрес серверной программы}"];

Поддерживается IE начиная c 3.02

Поддерживается NN начиная c 2.0

[править] activeElement

Возвращает указатель на активный элемент страницы.

document.activeElement;

Доступно только для чтения.

Поддерживается IE начиная c 4.0

[править] align

Задает или возвращает выравнивание элемента страницы или содержимого элемента страницы.

Для тегов <CAPTION> и <LEGEND>:

Свойство задает или возвращает выравнивание элемента заголовка таблицы (<CAPTION>) или группы элементов управления (<LEGEND>).

{Объект}.align[ = "bottom|center|left|right|top"];

Для свойства доступны пять значений:

  • bottom - выравнивание по нижнему краю и по центру;
  • center - выравнивание по центру;
  • left - выравнивание по левому краю;
  • right - выравнивание по правому краю;
  • top - выравнивание по верхнему краю и по центру.

Поддерживается IE начиная c 3.02 для <CAPTION> и начиная с 4.0 для <LEGEND>

Для тегов <DIV>, <Hn>, <HR>, <P>, элементов таблицы:

Свойство задает или возвращает выравнивание содержимого элемента страницы.

{Объект}.align[ = "left|center|right|justify"];

Для свойства доступны четыре значения:

  • left - выравнивание по левой границе (значение по умолчанию);
  • center - выравнивание по центру (значение по умолчанию для <TH>);
  • right - выравнивание по правой границе;
  • justify - выравнивание по ширине (доступно только для <DIV>, <Hn> и <P>).

Поддерживается IE начиная c 3.02 для <COL>, <COLGROUP>, <DIV>, <HR>, <P>, <TD>, <TH>, <TR> и начиная с 4.0 для <Hn>, <TBODY>, <TFOOT>, <THEAD>.

Для тегов <IFRAME> и <TABLE>:

Свойство задает или возвращает выравнивание "плавающего" фрейма (<IFRAME>) или таблицы (<TABLE>).

{Объект}.align[ = "left|center|right"];

Для свойства доступны три значения:

  • left - выравнивание по левому краю доступного пространства (значение по умолчанию);
  • center - выравнивание по центру доступного пространства;
  • right - выравнивание по правому краю доступного пространства.

Поддерживается IE начиная c 3.02 для <TABLE> и начиная с 4.0 для <IFRAME>.

Для тега <IMG>, элементов управления и внедренных объектов:

Свойство задает или возвращает местоположение рисунка, элемента управления или внедренного элемента относительно "обтекающего" его текста.

{Объект}.align[ = "left|right|top|texttop|middle|absmiddle|baseline|bottom|absbottom"];

Для свойства доступны следующие значения:

  • left - элемент смещается влево, а текст обтекает его справа (значение по умолчанию);
  • right - элемент смещается вправо, а текст обтекает его слева;
  • top - вершина элемента выравнивается по верхней границе строки;
  • texttop - вершина элемента выравнивается по вершине самого высокого символа строки;
  • middle - элемент центрируется в строке;
  • absmiddle - центр элемента выравнивается точно по центру строки;
  • baseline - низ элемента выравнивается по базовой линии строки;
  • bottom - низ элемента выравнивается по низу строки;
  • absbottom - низ изображения выравнивается по низу самого низкого сидящего символа строки.

Поддерживается IE начиная c 3.02 для <APPLET>, <IMG>, <INPUT>, <OBJECT> и начиная с 4.0 для <EMBED>, <FIELDSET>, <SELECT>.

Для таблицы стилей (CSS):

Свойство задает или возвращает принудительное выравнивание элемента страницы относительно родителя.

{Объект стиля}.align[ = "none|left|right"];

Для свойства доступны три значения:

  • none - заставляет элемент страницы появляться там, где он задан (значение по умолчанию);
  • left - принудительно выравнивает элемент страницы по левому краю;
  • right - по правому.

Поддерживается NN начиная c 4.0

[править] aLink

Задает или возвращает цвет активных гиперссылок в документе.

body.aLink[ = "{Цвет}"];

Поддерживается IE начиная c 4.0

[править] alinkColor

Задает или возвращает цвет активных гиперссылок в документе.

body.alinkColor[ = "{Цвет}"];

Значение по умолчанию #0000FF.

Поддерживается IE начиная c 3.02

Поддерживается NN начиная c 2.0

[править] allowTransparency

Задает или возвращает прозрачность обычного или "плавающего" фрейма.

{Объект фрейма}.allowTransparency[ = false|true];

Если у свойства указано значение false (по умолчанию), то фон фрейма определяется отображаемой в нем Web-страницей.

Если свойству присвоить значение true, то фон фрейма можно задать любым.

Если фон фрейма не задан, используется цвет фона Web-страницы, где определен фрейм.

Поддерживается IE начиная c 5.5

[править] alt

Задает или возвращает "альтернативный" текст, обображаемый на месте изображения, если оно не загружено.

{объект}.alt[ = "{Альтернативный текст}"];

Поддерживается IE начиная c 3.02 для <IMG> И <INPUT type="image"> и начиная с 4.0 для <AREA>.

[править] altHTML

Задает "альтернативный" HTML-код, который подставляется вместо внедренного объекта при ошибке его загрузки.

{Внедренный объект}.altHTML = "{Альтернативный HTML-код}";

Доступно только для записи.

Поддерживается IE начиная c 4.0

[править] altKey

Задает или возвращает состояние клавиши <Alt>.

event.altKey[ = false|true];

Для этого свойства доступно два значения.

  • false - обозначает, что клавиша <Alt> не нажата.
  • true - нажата.

Поддерживается IE начиная c 4.0 только для чтения и начиная с 5.0 для чтения и записи.

[править] altLeft

Задает или возвращает состояние левой клавиши <Alt>.

event.altLeft[ = false|true];

Для этого свойства доступно два значения.

  • false - обозначает, что левая клавиша <Alt> не нажата.
  • true - нажата.

Поддерживается IE начиная c 5.5 только в Windows NT 4.0 и Windows 2000.

[править] appCodeName

Возвращает имя кода программы Web-обозревателя.

navigator.appCodeName;

Свойство доступно только для чтения.

IE и NN возращает строку "Mozilla".

Поддерживается IE начиная c 3.02 для navigator и начиная с 4.0 для clientInformation.

Поддерживается NN начиная c 2.0

[править] appMinorVersion

Возвращает младший номер версии программы Web-обозревателя.

navigator.appMinorVersion;

Свойство доступно только для чтения.

Поддерживается IE начиная c 4.0

[править] appName

Возвращает имя программы Web-обозревателя.

navigator.appName;

Свойство доступно только для чтения.

Поддерживается IE начиная c 3.02 для navigator и начиная с 4.0 для clientInformation.

Поддерживается NN начиная c 2.0

[править] appVersion

Возвращает версию программы Web-обозревателя и сведения о комьютере.

navigator.appVersion;

Свойство доступно только для чтения.

Поддерживается IE начиная c 3.02 для navigator и начиная с 4.0 для clientInformation.

Поддерживается NN начиная c 2.0

[править] autocomplete

Задает или возвращает возможность "автозаполнения" форм и полей ввода текста.

{Объект}.autocomplete[ = "on|off"];

Для свойства доступно два значения:

  • on - включает автозаполнение;
  • off - отключает автозаполнение.

Поддерживается IE начиная c 5.0

[править] availHeight

Возвращает высоту доступной области экрана компьютера.

screen.availHeight;

Возвращается высота исключая панель задач Windows.

Свойство доступно только для чтения.

Поддерживается IE начиная c 4.0

Поддерживается NN начиная c 4.0

[править] availLeft

Возвращает горизонтальную координату первого пиксела.

screen.availLeft;

Возвращается координата первого пиксела, не занятого панелью задачь и аналогичными ей элементами интерфейса Windows.

Свойство доступно только для чтения.

Поддерживается NN начиная c 4.0

[править] availTop

Возвращает вертикальную координату первого пиксела.

screen.availTop;

Возвращается координата первого пиксела, не занятого панелью задачь и аналогичными ей элементами интерфейса Windows.

Свойство доступно только для чтения.

Поддерживается NN начиная c 4.0

[править] availWidth

Возвращает ширину доступной области экрана.

screen.availWidth;

Возвращается ширина исключая панель задач Windows.

Свойство доступно только для чтения.

Поддерживается IE начиная c 4.0

Поддерживается NN начиная c 4.0

Получено с http://spravkaweb.local/index.php/javascript/property/a
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 08:37, 3 января 2007.
  • К этой странице обращались 77 раз.
1.49043083191


Справочник по JavaScript : Алфавитный указатель свойств : Свойства JavaScript на букву B — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель свойств : Свойства JavaScript на букву B

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель свойств | ::. | A : B : C : D : E : F : H : I : K : L

Содержание

  • 1 background
  • 2 backgroundAttachment
  • 3 backgroundColor
  • 4 backgroundImage
  • 5 backgroundPosition
  • 6 backgroundPositionX
  • 7 backgroundPositionY
  • 8 backgroundRepeat
  • 9 balance
  • 10 BaseHref
  • 11 behavior
  • 12 behaviorCookie
  • 13 behaviorPart
  • 14 below
  • 15 bgColor
  • 16 bgProperties
  • 17 blockDirection
  • 18 border
  • 19 borderBottom
  • 20 borderBottomColor
  • 21 borderBottomStyle
  • 22 borderBottomWidth
  • 23 borderCollapse
  • 24 borderColor
  • 25 borderColorDark
  • 26 borderColorLight
  • 27 borderLeft
  • 28 borderLeftColor
  • 29 borderLeftStyle
  • 30 borderLeftWidth
  • 31 borderRight
  • 32 borderRightColor
  • 33 borderRightStyle
  • 34 borderRightWidth
  • 35 borderStyle
  • 36 borderTop
  • 37 borderTopColor
  • 38 borderTopStyle
  • 39 borderTopWidth
  • 40 borderWidth
  • 41 bottom
  • 42 bottomMargin
  • 43 boundingHeight
  • 44 boundingLeft
  • 45 boundingTop
  • 46 boundingWidth
  • 47 browserLanguage
  • 48 bufferDepth
  • 49 button

[править] background

Задает или возвращает интернет-адрес файла фонового рисунка, а также все свойства фона для документа или страницы.

{Объект}.background[ = "{Интернет-адрес файла изображения}"];

В такой интерпретации свойство задает или возвращает интернет-адрес файла фонового рисунка для документа или страницы.

Поддерживается IE начиная c 3.02

Поддерживается NN начиная c 4.0

{Объект стиля}.background[ = "[{background-color}] [{background-image}] [{background-repeat}] [{background-attachment}] [{background-position}]"];

В этой интерпретации свойство задает или возвращает все свойства фона элемента страницы в один прием, заменяя собой свойства backgroundColor, backgroundImage, backgroundRepeat, backgroundAttachment и backgroundPosition.

Значения этих свойств могут распологаться в любом порядке.

Значение по умолчанию: "transparent none repeat scroll 0% 0%".

Поддерживается IE начиная c 3.02

Задание значений backgroundPosition и backgroundRepeat поддерживается начиная с IE 4.0

[править] backgroundAttachment

Это свойство позволяет зафиксировать фоновый рисунок так, что он не будет прокручиваться вместе с содержимым объекта.

{Объект стиля}.background[ = "scroll|fixed"];

Для этого свойства доступно два значения:

  • scroll - заставляет фоновый рисунок прокручиваться вместе с содержимым объекта;
  • fixed - заставляет фоновый рисунок не прокручиваться вместе с содержимым объекта;

Свойство доступно для чтения и записи.

Если свойство применяется к объекту currentStyle, то доступно только для чтения.

Поддерживается IE начиная c 4.0

[править] backgroundColor

Задает или возвращает фоновый цвет Web-страницы или ее элемента.

{Объект стиля}.backgroundСolor[ = "{Цвет}|transparent"];

Если требуется задать фоновый цвет, то свойство может принять в качестве параметра следующие величины:

  • {Цвет} - указывает цвет фона;
  • transparent - задает прозрачный фон (значение по умолчанию).

Свойство доступно для чтения и записи.

Если свойство применяется к объекту currentStyle, то доступно только для чтения.

Поддерживается IE начиная c 4.0

Поддерживается NN начиная c 4.0

[править] backgroundImage

Задает или возвращает фоновый рисунок Web-страницы или ее элемента.

{Объект стиля}.backgroundImage[ = "url({Интернет-адрес файла рисунка})|none"];
  • none - отключает фоновый рисунок (значение по умолчанию).

Свойство доступно для чтения и записи.

Если свойство применяется к объекту currentStyle, то доступно только для чтения.

Поддерживается IE начиная c 4.0

Поддерживается NN начиная c 4.0

[править] backgroundPosition

Задает или возвращает местонахождение фонового рисунка.

{Объект стиля}.backgroundPosition[ = "[{backgroundPositionX}] [{backgroundPositionY}]"];

Это свойство заменяет собой свойства backgroundPositionX и backgroundPositionY.

  • backgroundPositionX - задается горизонтальная позиция фонового рисунка;
  • backgroundPositionY - задается вертикальная позиция фонового рисунка.

Значение по умолчанию 0% 0%.

В случае, если задана только одна координата, то она считается горизонтальной, а для вертикальной координаты принимается значение 50%.

Поддерживается IE начиная c 4.0

[править] backgroundPositionX

Задает или возвращает горизонтальную координату фонового рисунка.

{Объект стиля}.backgroundPositionX[ = "{X}|{X}%|left|center|rightquot;];

Это свойство принимает следующие значения:

  • {X} - задает координату целым числом (абсолютная координата);
  • {X}% - процент от соответствующего размера фонового рисунка (относительная координата);
  • left - выравнивание фонового рисунка на странице по левому краю;
  • center - по центру;
  • right - по правому краю.

Значение по умолчанию 0%.

Данное свойство применяется для чтения и записи. Если применяется для объекта currentStyle, то только для чтения.

Поддерживается IE начиная c 4.0

[править] backgroundPositionY

Задает или возвращает вертикальную координату фонового рисунка.

{Объект стиля}.backgroundPositionY[ = "{Y}|{Y}%|top|center|bottom;];

Это свойство принимает следующие значения:

  • {Y} - задает координату целым числом (абсолютная координата);
  • {Y}% - процент от соответствующего размера фонового рисунка (относительная координата);
  • top - выравнивание фонового рисунка на странице по верхнему краю;
  • center - по центру;
  • bottom - по нижнему краю.

Значение по умолчанию 0%.

Данное свойство применяется для чтения и записи. Если применяется для объекта currentStyle, то только для чтения.

Поддерживается IE начиная c 4.0

[править] backgroundRepeat

Задает или возвращает порядок повторения фонового рисунка на Web-странице или ее элементе.

{Объект стиля}.backgroundRepeat[ = "repeat|no-repeat|repeat-x|repeat-y"];

Это свойство принимает следующие значения:

  • repeat - заставляет фоновый рисунок повторяться по вертикали и по горизонтали (значение по умолчанию);
  • no-repeat - запрещает фоновому рисунку повторяться;
  • repeat-x - заставляет фоновый рисунок повторяться только по горизонтали;
  • repeat-y - заставляет фоновый рисунок повторяться только по вертикали.

Поддерживается IE начиная c 4.0

[править] balance

Задает или возвращает значение стереобаланса при воспроизведении фонового звука, заданного тегом <BGSOUND>.

{Объект фонового звука}.balance[ = "{Значение баланса}"];

Это свойство может принимать значения от -10000 (крайняя левая позиция) до 10000 (крайняя правая позиция).

Значение по умолчанию 0 (центр).

Поддерживается IE начиная c 4.0

[править] BaseHref

Возвращает интернет-адрес Web-страницы, в которую встроен объект <OBJECT>.

{Объект}.BaseHref;

Свойство доступно только для чтения.

Поддерживается IE начиная c 3.02

[править] behavior

Задает или возвращает поведение прокручиваемого текста в элементе <MARQUEE> или DHTML для элемента страницы.

{Объект}.behavior[ = "scroll|alternate|slide"];

В такой интерпретации свойство задает или возвращает поведение прокручиваемого текста в элементе <MARQUEE>.

Для этого свойства доступно три значения:

  • scroll - задает обычную прокрутку, т.е. текст уходит в одну сторону и появляется с противоположной (значение по умолчанию);
  • alternate - заставляет текст двигаться взад-вперед;
  • slide - заставляет текст прокрутиться до конца и остановиться.

Поддерживается IE начиная c 3.02

{Объект стиля}.behavior[ = "url({Интернет-адрес файла поведения})|url(#{Имя элемента ActiveX, реализующего это поведение})|url(#default#{Имя встроенного поведения})"];

В такой интерпретации свойство задает или возвращает DHTML для элемента страницы.

Свойство доступно для чтения и записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная c 5.0

[править] behaviorCookie

Возвращает cookie, идентифицирующий поведение отображения, на котором произошло текущее событие.

event.behaviorCookie;

Свойство доступно только для чтения.

Поддерживается IE начиная c 5.5

[править] behaviorPart

Возвращает значение, идентифицирующее поведение отображения, на котором произошло текущее событие.

event.behaviorPart;

Свойство доступно только для чтения.

Поддерживается IE начиная c 5.5

[править] below

Возвращает ссылку на слой, находящийся ниже текущего.

{Объект слоя}.below;

Свойство возвращает null, если текущий слой - самый нижний.

Свойство доступно только для чтения.

Поддерживается NN начиная c 4.0

[править] bgColor

Задает или возвращает цвет фона .

{Объект}.bgColor[ = "{Цвет}"];

Поддерживается IE начиная c 3.02

Поддерживается NN начиная c 2.0

[править] bgProperties

Задает или возвращает поведение фонового рисунка документа: будет ли он перемещаться при прокрутке содержимого или нет.

body.bgProperties[ = ""|"fixed"];

Если в качестве значения этого свойства указана пустая строка (значение по умолчанию), фоновый рисунок будет перемещаться при прокрутке содержимого документа.

В случае, если указано значение fixed, то фон прокручиваться не будет.

Поддерживается IE начиная c 3.02

[править] blockDirection

Возвращает направление написания текста: слева направо или справа налево.

{Объект}.blockDirection;

Свойство может возвратить одно из двух значений:

  • ltr - направление написания текста слева направо;
  • rtl - справа налево.

Поддерживается IE начиная c 5.0

[править] border

Задает или возвращает значение толщины границы рисунка, таблицы, фрейма или т.д.

(Для <FRAMESET> и <IFRAME>)

{Объект фрейма}.border[ = "{Толщина границы в пикселах}"];

В таком виде свойство задает или возвращает значение толщины границы между фреймами в пикселах.

Если толщина равна 0, то границы убираются совсем.

Значение по умолчанию - 5.

Поддерживается IE начиная c 4.0

(Для <IMG>, LayoutRect и <TABLE>)

{Объект}.border[ = "{Толщина границы в пикселах}"];

Свойство задает или возвращает значение толщины в пикселах границы, отображаемой вокруг рисунка, или границы таблицы.

Если толщина равна 0, то границы убираются совсем.

Для NN свойство доступно только для чтения.

Поддерживается IE начиная c 3.02

Поддерживается NN начиная c 3.0

(Для CSS)

{Объект стиля}.border[ = "[{borderColor}] [{borderStyle}] [{borderWidth}]"];

Свойство задает или возвращает все свойства границы элемента страницы в один прием. Задает свойства borderColor, borderStyle и borderWidth.

Значения этих свойств могут распологаться в любом порядке.

Значение по умолчанию medium none.

Поддерживается IE начиная c 4.0

[править] borderBottom

Задает или возвращает все свойства нижней границы элемента страницы в один прием.

{Объект стиля}.borderBottom[ = "[{borderBottomColor}] [{borderBottomStyle}] [{borderBottomWidth}]"];

Данное свойство заменяет собой свойства borderBottomColor, borderBottomStyle и borderBottomWidth.

Значения этих свойств могут распологаться в любом порядке.

Значение по умолчанию medium none.

Поддерживается IE начиная c 4.0

[править] borderBottomColor

Задает цвет нижней границы элемента страницы.

{Объект стиля}.borderBottomColor[ = "{Цвет}"];

Свойство доступно для чтения и для записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная c 4.0

[править] borderBottomStyle

Задает или возвращает тип нижней границы элемента страницы.

{Объект стиля}.borderBottomStyle[ = "none|dotted|dashed|solid|double|groove|ridge|inset|outset"];

Для свойства доступны следующие значения:

  • none - запрещает рисование границы (значение по умолчанию);
  • dotted - рисует точечную линию;
  • dashed - рисует штриховую линию;
  • solid - рисует сплошную линию;
  • double - рисует двойную сплошную линию;
  • groove - рисует трехмерную вдавленную границу;
  • ridge - рисует трехмерную выпуклую границу;
  • inset - рисует трехмерную "ступеньку вверх";
  • outset - рисует трехмерную "ступеньку вниз".

Свойство доступно для чтения и записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная c 4.0

[править] borderBottomWidth

Задает или возвращает значение толщины нижней границы элемента страницы.

{Объект стиля}.borderBottomWidth[ = "medium|thick|{Толщина}"];

Для свойства доступны следующие значения:

  • Толщина - можно задавать толщину числовым значением;
  • thin - рисует тонкую линию;
  • medium - рисует среднюю линию (значение по умолчанию);
  • thick - рисует толстую линию.

Свойство доступно для чтения и записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная c 4.0

Поддерживается NN начиная c 4.0

[править] borderCollapse

Задает, будут ли граница ячеек и общая граница таблицы сливаться в одну или нет, или возвращает этот признак.

{Объект таблицы}.style.borderCollapse[ = "separate|collapse"];

Данное свойство применяется только для тега <TABLE>.

Для свойства доступны следующие значения:

  • separate - разделяет рамку таблицы и границы ее ячеек (значение по умолчанию);
  • collapse - по возможности объединяет рамку таблицы и границы ее ячеек.

Свойство доступно для чтения и записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная c 5.0

[править] borderColor

Задает или возвращает цвет границы элемента.

{Объект}.borderColor[ = "{Цвет}"];

В такой интерпретации свойство задает или возвращает цвет границы Объекта.

Поддерживается IE начиная с 5.0

{Объект стиля}.borderColor[ = "{borderTopColor} [{borderRightColor}] [{borderBottomColor}] [{borderLeftColor}]"];

В такой интерпретации свойство задает или возвращает цвет всех границ элемента страницы.

Свойство заменяет свойства borderTopColor, borderRightColor, borderBottomColor и borderLeftColor.

Может быть задано от одного до четырех значений. Если задано одно значение, оно применяется ко всем четырем границам.

Если задано два значения, первое относиться к верхней и нижней границе, а второе - к левой и правой.

Если задано три значения, то первое применяется к верхней границе, второе - к левой и правой, третье - к нижней.

Свойство доступно для чтения и записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная с 4.0

{Объект стиля}.borderColor[ = "none|{Цвет}"];

Здесь свойсто задает цвет границ элемента страницы.

Свойство может быть задано либо цветовым значением (RGB), либо none, обозначающее отсутствие границ.

Поддерживается NN начиная с 4.0

[править] borderColorDark

Задает или возвращает цвет "затененной" части трехмерной границы таблицы или ее элемента.

{Объект таблицы}.borderColorDark[ = "{Цвет}"];

Поддерживается IE начиная с 3.02

[править] borderColorLight

Задает или возвращает цвет "освещенной" части трехмерной границы таблицы или ее элемента.

{Объект таблицы}.borderColorLight[ = "{Цвет}"];

Поддерживается IE начиная с 3.02

[править] borderLeft

Задает или возвращает все свойства левой границы элемента страницы в один прием.

{Объект стиля}.borderLeft[ = "[{borderLeftColor}] [{borderLeftStyle}] [{borderLeftWidth}]"];

Заменяет свойства borderLeftColor, borderLeftStyle и borderLeftWidth.

Значения этих свойств могут распологаться в любом порядке.

Значение по умолчанию medium none.

Поддерживается IE начиная с 4.0

[править] borderLeftColor

Задает или возвращает цвет левой границы элемента страницы.

{Объект стиля}.borderLeftColor[ = "{Цвет}"];

Свойство доступно для чтения и записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная с 4.0

[править] borderLeftStyle

Задает или возвращает тип левой границы элемента страницы.

{Объект стиля}.borderLeftStyle[ = "none|dotted|dashed|solid|double|groove|ridge|inset|outset"];

Для данного свойства доступны девять значений:

  • none - запрещает рисование границы (значение по умолчанию);
  • dotted - рисует точечную линию;
  • dashed - рисует штриховую линию;
  • solid - рисует сплошную линию;
  • double - рисует двойную сплошную линию;
  • groove - рисует трехмерную вдавленную границу;
  • ridge - рисует трехмерную выпуклую гранцу;
  • inset - рисует трехмерную "ступеньку вверх";
  • outset - рисует трехмерную "ступеньку вниз".

Данное свойство доступно для чтения и записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная с 4.0

[править] borderLeftWidth

Задает или возвращает значение толщины левой границы элемента страницы.

{Объект стиля}.borderLeftWidth[ = "medium|thin|thick|{Толщина}"];

Толщина может быть задана числовым значением. Также доступны три предопределенных значения: thin, medium и thick, рисующие тонкую, среднюю и толстую линию соответственно. Значение по умолчанию medium.

Данное свойство доступно для чтения и записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 4.0

[править] borderRight

Задает или возвращает все свойства правой границы элемента страницы в один прием.

{Объект стиля}.borderRight[ = "[{borderRightColor}] [{borderRightStyle}] [{borderRightWidth}]"];

Заменяет свойства borderRightColor, borderRightStyle и borderRightWidth.

Значения этих свойств могут распологаться в любом порядке.

Значение по умолчанию medium none.

Поддерживается IE начиная с 4.0

[править] borderRightColor

Задает или возвращает цвет правой границы элемента страницы.

{Объект стиля}.borderRightColor[ = "{Цвет}"];

Свойство доступно для чтения и записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная с 4.0

[править] borderRightStyle

Задает или возвращает тип правой границы элемента страницы.

{Объект стиля}.borderRightStyle[ = "none|dotted|dashed|solid|double|groove|ridge|inset|outset"];

Для данного свойства доступны девять значений:

  • none - запрещает рисование границы (значение по умолчанию);
  • dotted - рисует точечную линию;
  • dashed - рисует штриховую линию;
  • solid - рисует сплошную линию;
  • double - рисует двойную сплошную линию;
  • groove - рисует трехмерную вдавленную границу;
  • ridge - рисует трехмерную выпуклую гранцу;
  • inset - рисует трехмерную "ступеньку вверх";
  • outset - рисует трехмерную "ступеньку вниз".

Данное свойство доступно для чтения и записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная с 4.0

[править] borderRightWidth

Задает или возвращает значение толщины правой границы элемента страницы.

{Объект стиля}.borderRightWidth[ = "medium|thin|thick|{Толщина}"];

Толщина может быть задана числовым значением. Также доступны три предопределенных значения: thin, medium и thick, рисующие тонкую, среднюю и толстую линию соответственно. Значение по умолчанию medium.

Данное свойство доступно для чтения и записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 4.0

[править] borderStyle

Задает или возвращает тип сразу всех границ элемента страницы в один прием.

{Объект стиля}.borderStyle[ = "none|dotted|dashed|solid|double|groove|ridge|inset|outset"];

Данное свойство заменяет собой свойства borderTopStyle, borderRightStyle, borderBottomStyle и borderLeftStyle.

Для свойства доступны девять значений:

  • none - запрещает рисование границы (значение по умолчанию);
  • dotted - рисует точечную линию;
  • dashed - рисует штриховую линию;
  • solid - рисует сплошную линию;
  • double - рисует двойную сплошную линию;
  • groove - рисует трехмерную вдавленную границу;
  • ridge - рисует трехмерную выпуклую гранцу;
  • inset - рисует трехмерную "ступеньку вверх";
  • outset - рисует трехмерную "ступеньку вниз".

Свойство доступно для чтения и записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 4.0

[править] borderTop

Задает или возвращает все свойства верхней границы элемента страницы в один прием.

{Объект стиля}.borderTop[ = "[{borderTopColor}] [{borderTopStyle}] [{borderTopWidth}]"];

Данное свойство заменяет собой свойства borderTopColor, borderTopStyle и borderTopWidth.

Значение по умолчанию medium none

Поддерживается IE начиная с 4.0

[править] borderTopColor

Задает или возвращает цвет верхней границы элемента страницы.

{Объект стиля}.borderTopColor[ = "{Цвет}"];

Свойство доступно для чтения и записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная с 4.0

[править] borderTopStyle

Задает или возвращает тип верхней границы элемента страницы.

{Объект стиля}.borderTopStyle[ = "none|dotted|dashed|solid|double|groove|ridge|inset|outset"];

Для свойства доступны девять значений:

  • none - запрещает рисование границы (значение по умолчанию);
  • dotted - рисует точечную линию;
  • dashed - рисует штриховую линию;
  • solid - рисует сплошную линию;
  • double - рисует двойную сплошную линию;
  • groove - рисует трехмерную вдавленную границу;
  • ridge - рисует трехмерную выпуклую гранцу;
  • inset - рисует трехмерную "ступеньку вверх";
  • outset - рисует трехмерную "ступеньку вниз".

Свойство доступно для чтения и записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная с 4.0

[править] borderTopWidth

Задает или возвращает значение толщины верхней границы элемента страницы.

{Объект стиля}.borderTopWidth[ = "medium|thin|thick|{Толщина}"];

Толщина может быть задана числовым значением. Также доступны три предопределенных значения: thin, medium и thick, рисующие тонкую, среднюю и толстую линию соответственно.

Значение по умолчанию medium.

Данное свойство доступно для чтения и записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 4.0

[править] borderWidth

Задает или возвращает значения толщины всех границ элемента страницы.

{Объект стиля}.borderWidth[ = "{borderTopWidth} [{borderRightWidth}] [{borderBottomWidth}] [{borderLeftWidth}]"];

Свойство заменяет собой свойства borderTopWidth, borderRightWidth, borderBottomWidth и borderLeftWidth.

Может быть задано от одного до четырех значений.

Если задано одно значение, оно применяется ко всем четырем страницам.

Если задано два значения, первое относиться к верхней и нижней границе, а второе - к левой и правой.

Если задано три значения, то первое применяется к верхней границе, второе - к левой и правой, третье - к нижней.

Толщина может быть задана числовым значением. Также доступны три предопределенных значения: thin, medium и thick, рисующие тонкую, среднюю и толстую линию соответственно.

Значение по умолчанию medium.

Данное свойство доступно для чтения и записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная с 4.0

[править] bottom

Задает или возвращает вертикальную координату или позицию нижней границы объекта TextRange или свободно позиционированного элемента.

(Для TextRectangle):

{Объект TextRectangle}.bottom[ = {Y}];

В таком виде свойство задает или возвращает вертикальную координату нижней границы объекта TextRectangle в пикселах.

Поддерживается IE начиная с 5.0

(Для CSS):

{Объект стиля}.bottom[ = "auto|{Y}|{Y}%"];

Координата может быть задана как абсолютной величиной, так и процентом от высоты родителя.

Предопределенное значение auto заставляет Web-обозреватель позиционировать элемент самостоятельно.

Значение по умолчанию auto.

Свойсто доступно для чтения и записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная с 4.0

[править] bottomMargin

Задает или возвращает расстояние от нижней границы окна Web-обозревателя до нижней границы содержимого Web-страницы в пикселах.

body.bottomMargin[ = "{Расстояние}"];

Значение по умолчанию 15.

Поддерживается IE начиная с 4.0

[править] boundingHeight

Возвращает высоту содержимого объекта TextRange в пикселах.

{Объект TextRange}.boundingHeight;

Доступно только для чтения.

Поддерживается IE начиная с 4.01

[править] boundingLeft

Возвращает горизонтальную координату левой границы содержимого объекта TextRange относительно родителя в пикселах.

{Объект TextRange}.boundingLeft;

Доступно только для чтения.

Поддерживается IE начиная с 4.01

[править] boundingTop

Возвращает вертикальную координату верхней границы содержимого объекта TextRange относительно родителя в пикселах.

{Объект TextRange}.boundingTop;

Доступно только для чтения.

Поддерживается IE начиная с 4.01

[править] boundingWidth

Возвращает ширину содержимого объекта TextRange в пикселах.

{Объект TextRange}.boundingWidth;

Доступно только для чтения.

Поддерживается IE начиная с 4.01

[править] browserLanguage

Возвращает язык программы Web-обозревателя или операционной системы.

navigator.browserLanguage;

В IE версии 4.x это свойство возвращает язык программы Web-обозревателя.

В IE версий 5.x и более поздних возвращает язык операционной системы клиента.

Доступно только для чтения.

Поддерживается IE начиная с 4.0

[править] bufferDepth

Задает или возвращает количество двоичных разрядов, используемых для представления цвета при буферизации графических изображений в памяти.

screen.bufferDepth[ = 0|-1|1|4|8|15|16|24|32];

Для данного свойства доступны следующие значения:

  • 0 - отключает буферизацию изображений в памяти (значение по умолчанию);
  • -1 - для буферизации в памяти используется такое же представление цвета, как и на экране;
  • 1, 4, 8, 15, 16, 24, 32 - задают количество двоичных разрядов для представления цвета при буферизации в памяти.

Поддерживается IE начиная с 4.0

[править] button

Задает или возвращает номер кнопки мыши, нажатой пользователем.

event.button[ = 0|1|2|3|4|5|6|7];

Для данного свойства доступны следующие значения:

  • 0 - ни одна кнопка мыши не была нажата (значение по умолчанию);
  • 1 - была нажата левая кнопка;
  • 2 - правая;
  • 3 - левая и правая одновременно;
  • 4 - средняя;
  • 5 - левая и средняя одновременно;
  • 6 - правая и средняя одновременно;
  • 7 - все кнопки одновременно.

В IE версий 4.x доступно только для чтения.

Поддерживается IE начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/property/b
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 09:15, 3 января 2007.
  • К этой странице обращались 82 раза.
1.43763899803


Справочник по JavaScript : Алфавитный указатель свойств : Свойства JavaScript на букву C — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель свойств : Свойства JavaScript на букву C

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель свойств | ::. | A : B : C : D : E : F : H : I : K : L

Содержание

  • 1 cancelBubble
  • 2 canHaveChildren
  • 3 canHaveHTML
  • 4 caption
  • 5 cellIndex
  • 6 cellPadding
  • 7 cellSpacing
  • 8 checked
  • 9 class
  • 10 classid
  • 11 clear
  • 12 clear (CSS)
  • 13 clientHeight
  • 14 clientLeft
  • 15 clientTop
  • 16 clientWidth
  • 17 clientX
  • 18 clientY
  • 19 clip
  • 20 clip.bottom
  • 21 clip.height
  • 22 clip.left
  • 23 clip.right
  • 24 clip.top
  • 25 clip.width
  • 26 clipBottom
  • 27 clipLeft
  • 28 clipRight
  • 29 clipTop
  • 30 closed
  • 31 code
  • 32 codeBase
  • 33 codeType
  • 34 color
  • 35 color (CSS)
  • 36 colorDepth
  • 37 cols (<FRAMESET>)
  • 38 cols (<TABLE>)
  • 39 cols (<TEXTAREA>)
  • 40 colSpan
  • 41 compact
  • 42 complete
  • 43 content
  • 44 contentEditable
  • 45 contentOverflow
  • 46 contentWindow
  • 47 cookie
  • 48 cookieEnabled
  • 49 coords
  • 50 cpuСlass
  • 51 current
  • 52 cssText
  • 53 ctrlKey
  • 54 ctrlLeft
  • 55 cursor

[править] cancelBubble

Задает или возвращает признак прохождения событий через иерархию объектов странцицы.

event.cancelBubble[ = false|true];

По умолчанию (значение false) события последовательно проходят от потомкам к родителям через всю иерархию объектов страницы.

Присвоив этому свойству значение true, можно прервать это прохождение.

Поддерживается IE начиная с 4.0

[править] canHaveChildren

Возвращает признак, может ли элемент страницы иметь потомков.

{Объект}.canHaveChildren;

Свойство возвращает значение true, если элемент страницы может иметь потомков, либо false, если не может.

Свойство доступно только для чтения.

Поддерживается IE начиная с 5.0

[править] canHaveHTML

Задает или возвращает признак, может ли элемент страницы содержать HTML-текст.

{Объект}.canHaveHTML[ = true|false];

Для свойства доступны два значения: true - элемент страницы может содержать HTML-текст; false - не может.

Свойство доступно только для чтения для всех объектов, за исключением defaults.

Поддерживается IE начиная с 5.5

[править] caption

Возвращает указатель на заголовок <CAPTION> таблицы <TABLE> или null, если такового нет.

{Объект таблицы}.caption;

Свойство доступно только для чтения.

Поддерживается IE начиная с 4.0

[править] cellIndex

Возвращает позицию ячейки <TD> в коллекции cell.

{Объект ячейки таблицы}.cellIndex;

Свойство доступно только для чтения.

Поддерживается IE начиная с 4.0

[править] cellPadding

Задает или возвращает расстояние между границей и содержимым ячейки таблицы в пикселах либо как процент от доступного пространства.

{Объект таблицы}.cellPadding[ = "{Расстояние}"];

Значение по умолчанию 1.

Поддерживается IE начиная с 3.02

[править] cellSpacing

Задает или возвращает расстояние между ячейками таблицы в пикселах либо как процент от доступного пространства.

{Объект таблицы}.cellSpacing[ = "{Расстояние}"];

Значение по умолчанию 2.

Поддерживается IE начиная с 3.02

[править] checked

Задает или возвращает включенное состояние флажка или радиокнопки.

{Объект флажка или радиокнопки}.checked[ = true|false];

По умолчанию все флажки и радиокнопки выключены (значение false). Чтобы включить флажок или радокнопку, присвойте этому свойству значение true.

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0

[править] class

Задает или возвращает стилевой класс элемента страницы.

{Объект}.class[ = "{Стилевой класс, определенный в таблице стилей}"];

Поддерживается IE начиная с 4.0

[править] classid

Задает или возвращает уникальный идентификатор класса элемента ActiveX.

{Внедренный объект}.classid[ = "{Уникальный идентификатор класса}"];

Поддерживается IE начиная с 3.02

[править] clear

Задает или возвращает поведение разорванного тегом <BR> текста при "обтекании" им некоторых элементов страницы, таких как изображения.

{Объект разрыва}.clear[ = "all|left|right|none"];

Для данного свойства доступны четыре значения:

  • all - запрещает тексту "обтекать" элемент страницы с обеих сторон;
  • left - с левой стороны;
  • right - с правой стороны;
  • none - разрешается тексту "обтекать" элемент страницы.

Поддерживается IE начиная с 3.02

[править] clear (CSS)

Задает или возвращает поведение текста при "обтекании" им некоторых элементов страницы, таких как изображения.

{Объект стиля}.clear[ = "all|left|right|none"];

Атрибут задается для текста, а не для элемента страницы, который он будет "обтекать".

Для данного свойства доступны четыре значения:

  • none - разрешается тексту "обтекать" элемент страницы (значение по умолчанию).
  • left - запрещает тексту "обтекать" элемент страницы с левой тороны;
  • right - с правой стороны;
  • all - с обеих сторон;

Свойство доступно для чтения и записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 4.0

[править] clientHeight

Возвращает высоту клиентской области элемента страницы без учета всех отступов, границ и полос прокрутки.

{Объект}.clientHeight;

Свойство доступно только для чтения.

Поддерживается IE начиная с 4.0 для внедренных элементов, элементов управления и таблиц и начиная с 5.0 для остальных элементов.

[править] clientLeft

Возвращает горизонтальную координату левой границы клиентской области элемента страницы без учета всех отступов, границ и полос прокрутки.

{Объект}.clientLeft;

Свойство доступно только для чтения.

Поддерживается IE начиная с 4.0 для внедренных элементов, элементов управления и таблиц и начиная с 5.0 для остальных элементов.

[править] clientTop

Возвращает вертикальную координату верхней границы клиентской области элемента страницы без учета всех отступов, границ и полос прокрутки.

{Объект}.clientTop;

Свойство доступно только для чтения.

Поддерживается IE начиная с 4.0 для внедренных элементов, элементов управления и таблиц и начиная с 5.0 для остальных элементов.

[править] clientWidth

Возвращает ширину клиентской области элемента страницы без учета всех отступов, границ и полос прокрутки.

{Объект}.clientWidth;

Свойство доступно только для чтения.

Поддерживается IE начиная с 4.0 для внедренных элементов, элементов управления и таблиц и начиная с 5.0 для остальных элементов.

[править] clientX

Задает или возвращает горизонтальную координату курсора мыши относительно клиентской области окна Web-обозревателя.

event.clientX[ = {X}];

В IE версий 4.x свойство доступно только для чтения.

Поддерживается IE начиная с 4.0

[править] clientY

Задает или возвращает вертикальную координату курсора мыши относительно клиентской области окна Web-обозревателя.

event.clientY[ = {Y}];

В IE версий 4.x свойство доступно только для чтения.

Поддерживается IE начиная с 4.0

[править] clip

Задает или возвращает прямоугольный фрагмент элемента страницы, который будет видим.

{Объект стиля}.clip[ = "auto|rect({Верхняя граница} {Правая граница} {Нижняя граница} {Левая граница})"];

Предопределенное значение auto задает видимость всего элемента страницы (значение по умолчанию). Для того чтобы ограничить видимую часть элемента страницы прямоугольным фрагментом, задаются координаты границ этого прямоугольника, разделенные пробелами.

Поддерживается IE начиная с 4.0

[править] clip.bottom

Задает или возвращает вертикальную координату нижней границы видимого прямоугольного фрагмента слоя.

{Объект стиля}.clip.bottom[ = "auto|{Y}"];

Поддерживается NN начиная с 4.0

[править] clip.height

Задает или возвращает высоту видимого прямоугольного фрагмента слоя.

{Объект стиля}.clip.height[ = {Y}];

Поддерживается NN начиная с 4.0

[править] clip.left

Задает или возвращает горизонтальную координату левой границы видимого прямоугольного фрагмента слоя.

{Объект стиля}.clip.left[ = {X}];

Поддерживается NN начиная с 4.0

[править] clip.right

Задает или возвращает горизонтальную координату правой границы видимого прямоугольного фрагмента слоя.

{Объект стиля}.clip.right[ = {X}];

Поддерживается NN начиная с 4.0

[править] clip.top

Задает или возвращает вертикальную координату верхней границы видимого прямоугольного фрагмента слоя.

{Объект стиля}.clip.top[ = {Y}];

Поддерживается NN начиная с 4.0

[править] clip.width

Задает или возвращает ширину видимого прямоугольного фрагмента слоя.

{Объект стиля}.clip.width[ = {X}];

Поддерживается NN начиная с 4.0

[править] clipBottom

Возвращает вертикальную координату нижней границы видимого прямоугольного фрагмента элемента страницы.

{Объект}.currentStyle.clipBottom;

Предопределенное значение auto говорит о том, что элемент страницы полностью видим.

Свойство доступно только для чтения.

Поддерживается IE начиная с 5.0

[править] clipLeft

Возвращает горизонтальную координату левой границы видимого прямоугольного фрагмента элемента страницы.

{Объект}.currentStyle.clipLeft;

Предопределенное значение auto говорит о том, что элемент страницы полностью видим.

Свойство доступно только для чтения.

Поддерживается IE начиная с 5.0

[править] clipRight

Возвращает горизонтальную координату правой границы видимого прямоугольного фрагмента элемента страницы.

{Объект}.currentStyle.clipRight;

Предопределенное значение auto говорит о том, что элемент страницы полностью видим.

Свойство доступно только для чтения.

Поддерживается IE начиная с 5.0

[править] clipTop

Возвращает вертикальную координату верхней границы видимого прямоугольного фрагмента элемента страницы.

{Объект}.currentStyle.clipTop;

Предопределенное значение auto говорит о том, что элемент страницы полностью видим.

Свойство доступно только для чтения.

Поддерживается IE начиная с 5.0

[править] closed

Позволяет определить, закрыто окно Web-обозревателя, или нет.

window.closed;

Возвращает true, если окно Web-обозревателя закрыто, и false - в противном случае.

Свойство доступно только для чтения.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 3.0

[править] code

Задает или возвращает интернет-адрес файла, содержащего откомпилированный класс Java.

{Внедренный объект}.code[ = "{Интернет-адрес файла с классом Java}"];

Поддерживается IE начиная с 4.0

[править] codeBase

Задает или возвращает интернет-адрес папки, где содержится дистрибутивный файл элемента ActiveX, Java-класса или расширения Web-обозревателя.

{Внедренный объект}.codeBase[ = "{Интернет-адрес дистрибутивного файла}"];

Поддерживается IE начиная с 3.02

[править] codeType

Задает или возвращает тип данных MIME элемента ActiveX.

{Внедренный объект}.codeType[ = "{Тип данных MIME}"];

Поддерживается IE начиная с 3.02

[править] color

Задает или возвращает цвет шрифта или горизонтальной линии.

{Объект}.color[ = "{Цвет}"];

Поддерживается IE начиная с 3.02

[править] color (CSS)

Задает или возвращает цвет текста.

{Объект стиля}.color[ = "{Цвет}"];

Свойство доступно для чтения и записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная с 3.02 для текстовых элементов страницы и начиная с 4.0 для нетекстовых.

Поддерживается NN начиная с 4.0

[править] colorDepth

Задает или возвращает количество двоичных разрядов, используемых для представления цвета на экране.

screen.colorDepth[ = 1|4|8|15|16|24|32];

Для свойства доступны значения 1, 4, 8, 15, 16, 24, 32, которые задают количество двоичных разрядов для представления цвета на экране.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 4.0

[править] cols (<FRAMESET>)

Задает или возвращает количество и значения ширины всех фреймов-колонок в наборе фреймов.

{Объект набора фреймов}.cols[ = "Список значений ширины фреймов-колонок, разделенных запятыми"];

Значения ширины фреймов-колонок могут быть заданы как в пикселах, так и в процентах от ширины всех наборов фреймов. Также может быть использовано значение *, предписывающее Web-обозревателю отвести соответствующему фрейму все оставшееся место.

someFrameset.cols = "100, 20%, *";

Поддерживается IE начиная с 3.02

[править] cols (<TABLE>)

Задает или возвращает количество колонок в таблице.

{Объект таблицы}.cols[ = "Количество колонок"];

Поддерживается IE начиная с 3.02

[править] cols (<TEXTAREA>)

Задает или возвращает ширину области редактирования в символах текста.

{Объект области редактирования}.cols[ = "Ширина символа"];

Значение по умолчанию 20.

Поддерживается IE начиная с 3.02

[править] colSpan

Задает или возвращает количество ячеек, которые должны быть объединены в одну.

{Объект ячейки}.colspan[ = "{Количество ячеек, объединяемых в одну}"];

Значение этого свойства может быть изменено только после загрузки страницы.

Поддерживается IE начиная с 3.02

[править] compact

Задает или возвращает признак компактного отображения позиций списков.

{Объект списка}.compact[ = true|false];

По умолчанию все списки отображаются в обычном режиме (значение false). Чтобы включить компактное отображение (т.е. без дополнительных пробелов), присвойте этому свойству значение true.

Поддерживается IE начиная с 4.0

[править] complete

Возвращает true, если загрузка графического изображения завершена, и false - в противном случае.

{Объект рисунка}.complete;

Свойство доступно только для чтения.

Поддерживается IE начиная с 4.0

Поддерживается NN начиная с 3.02

[править] content

Задает или возвращает метаданные в теге <META>.

{Объект метаданных}.content[ = "{Метаданные}"];

Тип метаданных зависит от значений свойств httpEquiv или name.

Поддерживается IE начиная с 3.02

[править] contentEditable

Задает или возвращает признак, дающий пользователю возможность редактирования содержимого Web-страницы или ее элемента.

{Объект}.contentEditable[ = "inherit|true|false"];

Для свойства доступны три значения:

  • inherit - заставляет элемент страницы "наследовать" эту возможность от родителя (значение по умолчанию);
  • true - разрешает пользователю редактировать содержимое элемента страницы;
  • false - запрещает редактирование.

Поддерживается IE начиная с 5.5

[править] contentOverflow

Возвращает true, если для форматирования страницы нужен новый объект LayoutRect, и false - в противном случае.

event.contentOverflow;

Свойство доступно только для чтения.

Поддерживается IE начиная с 5.5

[править] contentWindow

Возвращает ссылку на объект window фрейма <FRAME> или <IFRAME>.

{Объект фрейма}.contentwindow;

Свойство доступно только для чтения.

Поддерживается IE начиная с 5.5

[править] cookie

Задает или возвращает значение cookie, связанное с Web-страницей.

document.cookie[ = "[expires={Дата}][; ][domain={Домашний адрес}][; ][path={Путь}][; ][secure][; ][{Параметр}={Значение}]"];

В качестве значения присваивается или возвращается список пар вида {Параметр}={Значение}, разделенные точками с запятой.

Также могут указываться следующие специальные параметры:

  • expires={Дата} - задает дату "устаревания" cookie. Если указанная дата находится в прошлом, cookie удаляются немедленно, если это текущая дата - после закрытия Web-обозревателя;
  • domain={Домашний адрес} - задает доменный адрес, страницы с которого могут получать доступ к этому cookie;
  • path={Путь} - задает путь на текущем сайте, страницы с которого могут получать доступ к этому cookie;
  • secure - разрешает доступ к cookie только по защищенному протоколу.

Пример значения cookie:

"userid=23233131; expires=Fri, 31 Dec 2001 23:59:59 GMT;"

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0

[править] cookieEnabled

Позволяет определить, разрешил ли пользователь сохранять cookie на жестком диске.

navigator.cookieEnabled;

Свойство возвращает true, если пользователь разрешил Web-обозревателю сохранять на жестком диске компьютера cookie, и false - в противном случае.

Свойство доступно только для чтения.

Поддерживается IE начиная с 4.0

[править] coords

Задает или возвращает координаты "горячей" области на карте-изображении.

{Объект карты-изображения}.coords[ = "{Координаты "горячей" области}"];

Для данного свойства доступны три типа "горячих" областей и, соответственно, типа значения свойств coords:

  • rect - прямоугольник, coords="{X1}, {Y1}, {X2}, {Y2}", где X1 и Y1 - координаты верхнего левого, а X2 и Y2 - правого нижнего угла прямоугольника;
  • circle - круг, coords="{X центра}, {Y центра}, {Радиус}";
  • poly - многоугольник, coords="{X1}, {Y1}, {X2}, {Y2}, {X3}, {Y3},...", где Xn и Yn - координаты соответствующей точки.

Поддерживается IE начиная с 3.02

[править] cpuСlass

Возвращает тип процессора клиентского компьютера.

navigator.cpuClass;

Данное свойство возвращает одно из пяти значений:

  • x86 - Intel-совместимый процессор;
  • 68K - процессор Motorola 68xxx;
  • Alpha - процессор Digital Alpha;
  • PPC - процессор Motorola PowerPC;
  • Other - другой процессор.

Свойство доступно только для чтения.

Поддерживается IE начиная с 4.0

[править] current

Возвращает интернет-адрес текущей позиции в списке "истории".

history.current;

Свойство доступно только для чтения.

Поддерживается NN начиная с 3.0

[править] cssText

Задает или возвращает исходный текст определения стиля или таблицы стилей.

style.cssText[ = "{Исходный текст определения стиля или таблицы стилей}"];

Поддерживается IE начиная с 5.0

[править] ctrlKey

Задает или возвращает состояние клавиши <Ctrl>.

event.ctrlKey[ = false|true];

Для свойства доступны два значения: flase говорит о том, что клавиша <Ctrl> не нажата, а true - что нажата.

Поддерживается IE начиная с 4.0 только для чтения и начиная с 5.0 для чтения и записи.

[править] ctrlLeft

Задает или возвращает состояние левой клавиши <Ctrl>.

event.ctrlLeft[ = false|true];

Для свойства доступны два значения: false говорит о том, что левая клавиша <Ctrl> не нажата, а true - что нажата.

Поддерживается IE начиная с 5.5 и только на операционных системах Windows NT 4.0 и WIndows 2000.

[править] cursor

Задает или возвращает форму курсора мыши, которую он принимает при наведении на элемент страницы.

{Объект стиля}.cursor[ = "auto|crosshair|default|hand|move|*-resize|text|wait|helt"];

Для свойства доступны следующие значения:

  • auto - заставляет Web-обозреватель самому определять нужную форму курсора мыши (значение по умолчанию);
  • crosshair - крестообразный курсор;
  • default - курсор по умолчанию, обычно стрелка;
  • hand - указывающий перст;
  • move - стрелка, указывающая на все четыре стороны;
    • -resize - указывает направление (вместо * могут быть следующие приставки: n, ne, nw, s, se, sw, e, w);
  • text - текстовой курсор;
  • wait - курсор ожидания;
  • help - стрелка с вопросительным знаком.

Поддерживается IE начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/property/c
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 10:34, 3 января 2007.
  • К этой странице обращались 82 раза.
2.8127758503


Справочник по JavaScript : Алфавитный указатель свойств : Свойства JavaScript на букву D — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель свойств : Свойства JavaScript на букву D

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель свойств | ::. | A : B : C : D : E : F : H : I : K : L

Содержание

  • 1 data (event)
  • 2 data (<OBJECT>)
  • 3 data (TextNode)
  • 4 dataFld
  • 5 event (event)
  • 6 dataFormatAs
  • 7 dataPageSize
  • 8 dataSrc
  • 9 defaultCharset
  • 10 defaultChecked
  • 11 defaultSelected
  • 12 defaultStatus
  • 13 defaultValue
  • 14 defer
  • 15 description
  • 16 designMode
  • 17 dialogArguments
  • 18 dialogHeight
  • 19 dialogLeft
  • 20 dialogTop
  • 21 dialоgWidth
  • 22 dir
  • 23 direction
  • 24 direction (CSS)
  • 25 disabled
  • 26 disabled (таблицы стилей)
  • 27 display
  • 28 document (popup)
  • 29 document (window)
  • 30 document (слой)
  • 31 documentElement
  • 32 domain
  • 33 dropEffect
  • 34 dynsrc

[править] data (event)

Задает или возвращает массив строк, содержащий интернет-адреса ярлыков, "брошенных" в окно Web-обозревателя.

event.data[ = ({Массив строк})];

Поддерживается NN начиная с 4.0.

[править] data (<OBJECT>)

Задает или возвращает интернет-адрес файла данных, требуемых элементом ActiveX.

{Внедренный объект}.data[ = "{Интернет-адрес файла данных}"];

Поддерживается IE начиная с 3.02.

[править] data (TextNode)

Задает или возвращает значение объекта TextNode.

{Объект}.data;

Поддерживается IE начиная с 5.0

[править] dataFld

Задает или возвращает поле таблицы базы данных, значение которого будет отображаться в данном элементе страницы.

{Объект}.dataFld[ = "{Имя поля таблицы базы данных}"];

Поддерживается IE начиная с 4.0

[править] event (event)

Задает или возвращает имя поля таблицы базы данных, значение которого изменилось.

event.dataFld[ = "{Имя поля таблицы базы данных}"];

Доступно при возникновении события oncellchange.

Поддерживается IE начиная с 5.0

[править] dataFormatAs

Задает или возвращает представление, используемое для отображения данных из полей таблицы.

{Объект}.dataFormatAs[ = "text|html|localized-text"];

Для данного свойства доступны следующие значения:

  • text - задает текстовое представление (значение по умолчанию);
  • html - заставляет Web-обозреватель учитывать все теги HTML, встречающиеся в значениях полей;
  • localized-text - работает аналогично text, за тем исключением, что при этом используются региональные настройки Windows.

Поддерживается IE начиная с 4.0

[править] dataPageSize

Задает или возвращает размер страницы данных, выводимых в один прием, в записях.

{Объект таблицы}.dataPageSize[ = "{Размер страницы данных}"];

Свойство требуется, если нужно привязать таблицу к данным.

Поддерживается IE начиная с 4.0

[править] dataSrc

Задает или возвращает объект-источник данных.

{Объект}.dataSrc[ = "#{Имя объекта-источника данных}"];

Поддерживается IE начиная с 4.0

[править] defaultCharset

Возвращает текстовую кодировку, заданную для Web-страницы по умолчанию.

document.defaultCharset;

Свойство доступно только для чтения.

Поддерживается IE начиная с 4.0

[править] defaultChecked

Свойство задает или возвращает состояние флажка или радиокнопки по умолчанию.

{Объект флажка или радиокнопки}.defaultChecked[ = true|false];

По умолчанию все флажки и радиокнопки изначально (сразу после загрузки Web-страницы или сброса формы) включены (значение true). Чтобы изначально отключить их, присвойте этому свойству значение false.

Свойство аналогично атрибуту checked.

Поддерживается IE начиная с 3.02 и NN начиная с 2.0.

[править] defaultSelected

Свойство задает или возвращает состояние позиции списка <option> по умолчанию.

{Объект позиции списка}.defaultSelected[ = true|false];

По умолчанию все позиции списка изначально (сразу после загрузки Web-страницы или сброса формы) включены (значение true). Чтобы отключить их, присвойте этому свойству значение false.

Свойство аналогично атрибуту selected.

Поддерживается IE начиная с 3.02 и NN начиная с 3.0.

[править] defaultStatus

Свойство задает или возвращает значение, отображаемое Web-обозревателем в строке состояния окна по умолчанию, если не задано свойство status.

window.defaultStatus[ = "{Текст строки состояния}"];

Поддерживается IE начиная с 3.02 и NN начиная с 2.0.

[править] defaultValue

Свойство задает или возвращает содержимое элемента управления по умолчанию.

{Объект}.defaultValue[ = "{Значение по умолчанию}"];

Свойство аналогично атрибуту value.

Поддерживается IE начиная с 3.02 и NN начиная с 2.0.

[править] defer

Свойство задает или возвращает состояние скрипта: отложено ли его выполнение или нет.

{Объект скрипта}.defer[ = true|false];

По умолчанию скрипты выполняются при загрузке Web-страницы (значение false). Если вы хотите отложить их выполнение до полной загрузки страницы, дайте этому свойству значение true.

Поддерживается IE начиная с 4.0

[править] description

Свойство возвращает описание типа MIME или расширения Web-обозревателя.

{Объект}.description;

Свойство доступно только для чтения.

Поддерживается NN начиная с 3.0

[править] designMode

Свойство задает или возвращает состояние документа: может ли он редактироваться пользователем.

document.designMode[ = "on|off"];

По умолчанию Web-страницу редактировать нельзя (значение off). Если вы I хотите перевести Web-обозреватель в состояние, при котором пользователь сможет ее редактировать, присвойте этому свойству значение on.

Поддерживается IE начиная с 5.0

[править] dialogArguments

Свойство возвращает значение или массив значений, переданных в диалоговое Well окно.

window.dialogArguments;

Свойство доступно исключительно для чтения и только для модальных или немодальных диалоговых Web-окон.

Поддерживается IE начиная с 4.0

[править] dialogHeight

Свойство задает или возвращает высоту диалогового Web-окна в одной из единиц измерения, поддерживаемых CSS.

window.dialogHeight[ = "{Высота}"];

Свойство доступно только для модальных или немодальных диалоговых Web-окон.

Поддерживается IE начиная с 4.0

[править] dialogLeft

Свойство задает или возвращает горизонтальную координату левой стороны диалогового Web-окна в одной из единиц измерения, поддерживаемых CSS.

window.dialogLeft[ = "{X}"];

Свойство доступно только для модальных или немодальных диалоговых Web-окон.

Поддерживается IE начиная с 4.0

[править] dialogTop

Свойство задает или возвращает вертикальную координату верхней стороны диалогового Web-окна в одной из единиц измерения, поддерживаемых CSS.

window.dialogTop[ = "{Y}"];

Свойство доступно только для модальных или немодальных диалоговых Web-окон.

Поддерживается IE начиная с 4.0

[править] dialоgWidth

Свойство задает или возвращает ширину диалогового Web-окна в одной из единиц измерения, поддерживаемых CSS.

window.dialogWidth[ = "{Ширина}"];

Свойство доступно только для модальных или немодальных диалоговых Web-окон.

Поддерживается IE начиная с 4.0

[править] dir

Свойство задает или возвращает порядок чтения текста.

{Объект}.dir[ = "ltr|rtl"];

По умолчанию текст читается слева направо (ltr). Значение rtl позволяет задать порядок чтения справа налево. Для документов, составленных на европейских языках, порядок чтения всегда слева направо (ltr).

Поддерживается IE начиная с 5.0

[править] direction

Свойство задает или возвращает направление прокрутки текста в элементе <MARQUEE>.

{Объект}.direction[ = "{left|right|up|down}"];

Текст может прокручиваться налево (left; значение по умолчанию), направо (right), вверх (up) и вниз (down).

Поддерживается IE начиная с 3.02

[править] direction (CSS)

Свойство задает или возвращает порядок чтения текста: слева направо или справа налево.

{Объект стиля}.direction[ = "{ltr|rtl|inherit}"];

Для данного свойства доступны следующие значения:

  • ltr - задает порядок чтения слева направо (значение по умолчанию);
  • rtl - справа налево;
  • inherit - заставляет наследовать порядок чтения у родителя.

Для документов, составленных на европейских языках, порядок чтения всегда слева направо (ltr). Свойство доступно для чтения и записи, в случае объекта currentstyle — только для чтения.

Поддерживается IE начиная с 5.0

[править] disabled

Свойство задает или возвращает состояние элемента страницы: разрешен он для доступа пользователя или запрещен.

{Объект}.disabled[ = true|false];

По умолчанию доступ к элементу страницы разрешен (значение true). При этом пользователь может редактировать текст в поле ввода, включать и отключать флажки и радиокнопки, выбирать пункты из списков, нажимать командные кнопки и редактировать содержимое остальных элементов страницы, если для них было задано соответствующее значение свойства contentEditable. Чтобы запретить доступ к элементу страницы, присвойте этому свойству значение false.

Поддерживается IE начиная с 4.0 для элементов управления и начиная с 5.5 для остальных элементов страницы.

[править] disabled (таблицы стилей)

Свойство задает или возвращает состояние таблицы стилей: применяется ли она к Web-странице или нет.

{Объект таблицы стиля}.disabled[ = true|false];

По умолчанию таблица стиля применяется к Web-странице (значение true). Чтобы отменить ее действие, присвойте этому свойству значение false.

Поддерживается IE начиная с 4.0.

[править] display

Свойство задает или возвращает вид элемента страницы: встроенный, блочный, позиция списка или вообще не видимый на странице.

{Объект стиля}.display[ = "inline|block|none[inline-block|list-item| table-header-group|table-footer-group"];

Для данного свойства доступны следующие значения:

  • inline - заставляет элемент страницы вести себя как встроенный. При этом он располагается внутри текста, и его позиция и размеры рассчитываются согласно позиции и размерам текста. Пример встроенного элемента — <I> (значение по умолчанию);
  • block - делает элемент страницы блочным. При этом он может быть свободно позиционирован. Пример блочного элемента - <div>;
  • none - делает элемент страницы невидимым. При этом страница отображается так, будто этого элемента вообще не существует;
  • inline-block - аналогично inline, но содержимое элемента страницы ведет себя как блочный элемент (NN не поддерживается);
  • list-item - аналогично block, но при этом элемент страницы считается позицией списка;
  • table-header-group - заставляет элемент страницы отображаться после верхнего заголовка таблицы и перед всеми строками данных аналогично тегу <thead> (NN не поддерживается);
  • table-footer-group - заставляет элемент страницы отображаться перед основанием таблицы и после всех строк данных аналогично тегу <tfoot> (NN не поддерживается).

Поддерживается IE и NN начиная с 4.0.

[править] document (popup)

Свойство возвращает ссылку на Web-страницу, загруженную во всплывающее окно.

{Объект всплывающего окна}.document;

Свойство доступно только для чтения.

Поддерживается IE начиная с 5.5.

[править] document (window)

Свойство возвращает ссылку на Web-страницу, загруженную в текущее окно Web-обозревателя.

window.document;

Свойство доступно только для чтения.

Поддерживается NN начиная с 2.0.

[править] document (слой)

Свойство возвращает ссылку на Web-страницу, загруженную в слой.

{Объект слоя}.document;

Свойство доступно только для чтения.

Поддерживается NN начиная с 4.0.

[править] documentElement

Свойство возвращает ссылку на самый верхний в иерархии объект, содержащийся в текущей Web-странице. Как правило, это объект <html>.

document.documentElement;

Свойство доступно только для чтения.

Поддерживается IE начиная с 5.0.

[править] domain

Свойство задает или возвращает домен Web-сервера, с которого была загружена Web-страница.

document.domain[ = "{Домен}"];

Изначально возвращает доменное имя Web-сервера. Может использоваться, чтобы сделать несколько Web-страниц "дружественными", если они загружены с разных серверов. Это может понадобиться, чтобы обойти систему безопасности серверов. Например, если две страницы в наборе фреймов загружены с серверов http://forum.spravkaweb.ru и http://server.spravkaweb.ru, то, присвоив этому свойству значение microsoft. com, можно "подружить" эти страницы.

Поддерживается IE начиная с 4.0 и NN начиная с 3.0.

[править] dropEffect

Свойство задает или возвращает тип операции drag-n-drop, разрешенной объектом-приемником.

dataTransfer.dropEffect[ = "none|move|copy|link"];

Для данного свойства доступны следующие значения:

  • none - вообще отменяет любые операции drag-n-drop (значение по умолчанию);
  • move - разрешает операцию переноса;
  • cору - копирования;
  • link - создания ссылки или ярлыка.

Поддерживается IE начиная с 5.0

[править] dynsrc

Свойство задает или возвращает интернет-адрес динамического содержимого, отображаемого вместо статичного рисунка.

{Объект рисунка}.dynsrc[ = "{Интернет-адрес динамичного содержимого}"];

Динамическим содержимым для рисунка может быть видеофильм.

Если задан этот атрибут, то вместо обычного статичного рисунка будет отображен видеофильм, содержащийся в файле, интернет-адрес которого был задан в этом атрибуте.

Поддерживается IE начиная с 3.02

Получено с http://spravkaweb.local/index.php/javascript/property/d
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 10:47, 3 января 2007.
  • К этой странице обращались 80 раз.
1.96067905426


Справочник по JavaScript : Алфавитный указатель свойств : Свойства JavaScript на букву E — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель свойств : Свойства JavaScript на букву E

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель свойств | ::. | A : B : C : D : E : F : H : I : K : L

Содержание

  • 1 effectAllowed
  • 2 enabledPlugin
  • 3 encoding
  • 4 event
  • 5 expando

[править] effectAllowed

Свойство задает или возвращает тип операции drag-n-drop, разрешенной объектом-источником.

dataTransfer.effectAllowed[ = "uninitialized|none|move|copy|link|copyLink|copyMove|linkMove|all"];

Для данного свойства доступны следующие значения:

  • unitialized - задает операцию drag-n-drop, выполняемую по умолчанию самим Web-обозревателем (значение по умолчанию);
  • none - вообще отменяет любые операции drag-n-drop;
  • move - разрешает операцию переноса;
  • cору - копирования;
  • link - создания ссылки или ярлыка;
  • copyLink - копирования и создания ссылки или ярлыка;
  • copyMove - копирования и перемещения;
  • linkMove - перемещения и создания ссылки или ярлыка;
  • all - разрешает все.

Поддерживается IE начиная с 5.0

[править] enabledPlugin

Свойство возвращает ссылку на объект plugin, поддерживающий текущий тип данных MIME.

{Объект типа MIME}.enabledPlugin;

Если такого типа нет, свойство возвращается null.

Свойство доступно только для чтения.

Поддерживается NN начиная с 3.0

[править] encoding

Свойство задает или возвращает метод кодирования данных, отправляемых формой, в виде MIME.

{Объект формы}.encoding[ = "{Метод кодирования данных}"];

Значение по умолчанию application/x-www-form-urlencoded.

Может также использоваться значение multipart/form-data, если в форме используется элемент <input TYPE="file">.

Поддерживается IE начиная с 3.02 и NN начиная с 2.0.

[править] event

Свойство задает или возвращает событие, к которому привязан скрипт-обработчик.

{Объект формы}.event[ = "{Тип события}"];

Этот способ создания обработчиков событий специфичен для Internet Explorer.

Поддерживается IE начиная с 3.02

[править] expando

Свойство задает или возвращает состояние объектной модели Web-обозревателя: можно или нельзя создавать произвольные свойства объектов.

document.expando[ = true|false];

По умолчанию объектная модель Web-обозревателя разрешает создавать у объектов произвольные свойства (значение true), например, для хранения каких-либо значений продолжительное время. Вы можете запретить это, присвоив данному свойству значение false.

Поддерживается IE начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/property/e
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:05, 3 января 2007.
  • К этой странице обращались 72 раза.
1.8983168602


Справочник по JavaScript : Алфавитный указатель свойств : Свойства JavaScript на букву F — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель свойств : Свойства JavaScript на букву F

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель свойств | ::. | A : B : C : D : E : F : H : I : K : L

Содержание

  • 1 face
  • 2 fgColor
  • 3 fileCreatedDate
  • 4 filename
  • 5 fileModifiedDate
  • 6 fileSize
  • 7 fileUpdatedDate
  • 8 filter
  • 9 firstChild
  • 10 font
  • 11 fontFamily
  • 12 fontSize
  • 13 fontSmoothingEnabled
  • 14 fontStyle
  • 15 fontVariant
  • 16 fontWeight
  • 17 form
  • 18 frame
  • 19 frameBorder (фреймы)
  • 20 frameElement
  • 21 frameSpacing
  • 22 fromElement

[править] face

Свойство задает или возвращает имя шрифта.

{Объект}.face[ = "{Имя шрифта}"];

Поддерживается IE начиная с 3.02 для <font> и начиная с 4.0 для <BASEFONT>.

[править] fgColor

Свойство задает или возвращает цвет текста.

{Объект}.fgColor[ = "{Цвет}"];

Значение по умолчанию #000000.

Поддерживается IE начиная с 3.02 и NN начиная с 2.0.

[править] fileCreatedDate

Свойство возвращает дату создания файла HTML-документа или графического изображения.

{Объект}.fileCreatedDate;

Свойство доступно только для чтения.

Поддерживается IE начиная с 4.0

[править] filename

Свойство возвращает имя файла расширения Web-обозревателя.

{Объект}.filename;

Свойство доступно только для чтения.

Поддерживается NN начиная с 3.0

[править] fileModifiedDate

Свойство возвращает дату последнего изменения файла HTML-документа или графического изображения.

{Объект}.fileModifiedDate;

Свойство доступно только для чтения.

Поддерживается IE начиная с 4.0

[править] fileSize

Свойство возвращает размер файла HTML-документа или графического изображения.

{Объект}.fileSize;

Свойство доступно только для чтения.

Поддерживается IE начиная с 4.0

[править] fileUpdatedDate

Свойство возвращает дату последнего обновления файла графического изображения.

{Объект}.fileUpdatedDate;

Свойство доступно только для чтения.

Поддерживается IE начиная с 4.0

[править] filter

Свойство задает или возвращает набор визуальных фильтров и преобразований, применяемых к элементу страницы.

{Объект стиля}.filter[ = "{Список фильтров и преобразований с параметрами, разделенных пробелами}"];

Поддерживается IE начиная с 4.0

[править] firstChild

Свойство возвращает ссылку на первый элемент с коллекции childNodes.

{Объект}.firstChild;

Свойство доступно только для чтения.

Поддерживается IE начиная с 5.0

[править] font

Свойство задает или возвращает параметры шрифта элемента страницы.

{Объект стиля}.font[ = "{fontFamily} [{fontHeight}] [{fontSize}] [{fontStyle}] [{fontVariant}] [{fontWeight}]"];

Данное свойство заменяет свойства fontFamily, fontHeight, fontSize, fontStyle, fontVariant и fontWeight. Значения этих свойств могут располагаться в любом порядке.

Значение по умолчанию: normal normal normal medium normal "Times New Roman".

Альтернативный формат:

{Объект стиля}.font[ = "caption|icon|menu|message-box|small-caption|status-bar"];

В этом случае доступны шесть предопределенных значений, задающих один из стандартных шрифтов, используемых в элементах интерфейса Windows:

  • caption - шрифт заголовков кнопок, текстовых меток и т.п.;
  • icon - шрифт подписей под пиктограммами;
  • menu - шрифт пунктов меню;
  • message-box — шрифт содержимого стандартных окон-предупреждений;
  • small-caption — мелкий шрифт заголовков;
  • status-bar — шрифт содержимого строки состояния.

Свойство доступно для чтения и записи, в случае объекта currentstyle — только для чтения.

Поддерживается IE начиная с 4.0

[править] fontFamily

Свойство задает или возвращает имя шрифта, используемого в элементе страницы.

{Объект стиля}.fontFamily[ = "{Имя шрифта}|serif|san-serif|cursive|fantasy|monospace"];

В качестве значения этого свойства задается либо непосредственно имя нужного шрифта, либо одно из пяти предопределенных значений, задающих имя шрифтового семейства. Можно задавать одновременно несколько шрифтов, разделив их имена запятыми; в этом случае Web-обозреватель сможет выбрать из них тот, который установлен на компьютере клиента.

Если имя шрифта содержит пробелы, его следует взять в одинарные кавычки.

Свойство доступно для чтения и записи, в случае объекта currentstyle — только для чтения.

Поддерживается IE начиная с 3.02 для текстовых элементов и начиная с 4.0 для нетекстовых.

Поддерживается NN начиная с 4.0.

[править] fontSize

Свойство задает или возвращает имя размера шрифта, используемого в элементе страницы.

font-size: xx-small|x-small|small|medium|large|x-large|xx-large| larger|smaller|{Абсолютный размер}|{Относительный размер}%

Возможно задание либо абсолютного размера шрифта в одной из поддерживаемых CSS единиц измерения, либо как процент от размера шрифта родителя.

Также доступны девять предопределенных значений.

Значения хх-small, x-small, small, medium, large, x-large и xx-large задают один из семи размеров шрифтов, поддерживаемых HTML. Значения smaller и larger задают размер шрифта относительно шрифта родителя — на размер меньше или больше соответственно.

Свойство доступно для чтения и записи, в случае объекта currentstyle — только для чтения.

Поддерживается IE начиная с 3.02 для текстовых элементов и начиная с 4.0 для нетекстовых.

Поддерживается NN начиная с 4.0.

[править] fontSmoothingEnabled

Свойство проверяет, включено ли сглаживание шрифтов при отображении их на экране.

screen.fontSmoothingEnabled;

Свойство возвращает true, если пользователем включено сглаживание шрифтов при отображении их на экране, и false — в противном случае.

Доступно только для чтения.

Поддерживается IE начиная 4.0.

[править] fontStyle

Свойство задает или возвращает вид шрифта, используемого в элементе страницы.

{Объект стиля}.fontStyle[ = "normal|italic|oblique"];

Свойству доступны три значения:

  • normal (значение по умолчанию) — задает обычный вид шрифта;
  • italic — задает курсивное начертание;
  • oblique — задает наклонное начертание (IE отображает его как курсив).

Свойство доступно для чтения и записи, в случае объекта currentstyle — только для чтения.

Поддерживается IE начиная с 3.02 для текстовых элементов и начиная с 4.0 для нетекстовых.

Поддерживается NN начиная с 4.0.

[править] fontVariant

Свойство задает или возвращает вид малых букв шрифта, используемого в элементе страницы.

{Объект стиля}.fontVariant[ = "normal|small-caps"];

Свойству доступны два значения:

  • normal (значение по умолчанию) — задает обычный вид малых букв шрифта;
  • small-caps — делает их такими же, как большие буквы, только меньшего размера (капитель).

Свойство доступно для чтения и записи, в случае объекта currentStyle — только для чтения.

Поддерживается IE начиная с 4.0

[править] fontWeight

Свойство задает или возвращает "жирность" шрифта, используемого в элементе страницы.

{Объект стиля}.fontWeight[ = "normal|bold|bolder|lighter|100|200|300|400|500|600|700|800|900"];

"Жирность" может быть задана тремя способами.

Во-первых, предопределенными значениями normal и bold, задающими обычное и жирное начертание соответственно.

Во-вторых, относительными значениями bolder И lighter, делающими шрифт элемента страницы жирнее и светлее шрифта родителя.

И, в-третьих, одним из девяти значений от 100 до 900; здесь нормальному начертанию соответствует значение 400, а жирному — 700. Значение по умолчанию normal.

Свойство доступно для чтения и записи, в случае объекта currentStyle — только для чтения.

Поддерживается IE начиная с 3.02 для текстовых элементов и начиная с 4.0 для нетекстовых. При этом IE 4.0 и более старые версии поддерживали только значения normal и bold этого атрибута.

Поддерживается NN начиная с 4.0.

[править] form

Свойство возвращает ссылку на форму, к которой привязан элемент управления.

{Объект элемента управления}.form;

Свойство доступно только для чтения.

Поддерживается IE начиная с 3.02 и NN начиная с 2.0.

[править] frame

Свойство задает или возвращает значение, предписывающее отобразить или скрыть внешние границы таблицы.

{Объект таблицы}.frame[ = "void|above|below|border|hsides|lhs|rhs|vsides| box"];

Доступны девять значений:

  • void — внешней границы нет вообще (значение по умолчанию);
  • above — рисуется только верхняя линия внешней границы;
  • below — рисуется только нижняя линия внешней границы;
  • border — рисуются все линии внешней границы;
  • hsides — рисуются только горизонтальные линии внешней границы, т. е. верхняя и нижняя;
  • lhs — рисуется только левая линия внешней границы;
  • rhs — рисуется только правая линия внешней границы;
  • vsides — рисуются только вертикальные линии внешней границы, т. е. левая и правая;
  • box — рисуются все линии внешней границы.

Свойство доступно только для чтения.

Поддерживается IE начиная с 3.02

[править] frameBorder (фреймы)

Свойство задает или возвращает признак отображения границ между фреймами.

{Объект фрейма}.frameBorder[ = "1|0|yes|no"];

По умолчанию границы между фреймами отображаются (значения 1 или yes). Значения 0 или no отключают отображение границ.

Поддерживается IE начиная с 3.02

[править] frameElement

Свойство возвращает ссылку на объект фрейма.

window.frameElement;

Свойство доступно только для чтения.

Поддерживается IE начиная с 5.5

[править] frameSpacing

Свойство задает или возвращает интервал между фреймами в пикселах.

{Объект фрейма}.frameSpacing[ = "{Интервал между фреймами}"];

Значение по умолчанию 2.

Поддерживается IE начиная с 3.02

[править] fromElement

Свойство задает или возвращает ссылку на элемент управления, с которого "ушел" курсор мыши.

event.fromElement[ = {Элемент страницы}];

Имеет смысл только при возникновении событий onmouseover и onmouseout.

В IE 4.x доступно только для чтения.

Поддерживается IE начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/property/f
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 12:16, 3 января 2007.
  • К этой странице обращались 70 раз.
1.77902698517


Справочник по JavaScript : Алфавитный указатель свойств : Свойства JavaScript на букву H — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель свойств : Свойства JavaScript на букву H

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель свойств | ::. | A : B : C : D : E : F : H : I : K : L

Содержание

  • 1 hash
  • 2 hasLayout
  • 3 height
  • 4 height (document)
  • 5 height (event)
  • 6 height (screen)
  • 7 height (CSS)
  • 8 hidden
  • 9 hideFocus
  • 10 host
  • 11 hostname
  • 12 href (<BASE>)
  • 13 href (location)
  • 14 href (styleSheet)
  • 15 href (гиперссылки)
  • 16 hspace
  • 17 htmlFor (<LABEL>)
  • 18 htmlFor (<SCRIPT>)
  • 19 htmlText
  • 20 httpEquiv

[править] hash

Свойство задает или возвращает часть интернет-адреса текущей Web-страницы или гиперссылки, следующей за символом "решетки" #.

location.hash[ = "{Часть адреса, следующая за #}"];

Обычно это имя "якоря".

В IE 4.x доступно только для чтения.

Поддерживается IE начиная с 3.02 для <A> и location и начиная с 4.0 для <AREA>. Поддерживается NN начиная с 2.0.

[править] hasLayout

Проверка абсолютно позиционированного объекта.

{Объект}.hasLayout;

Совойство возвращает true, если элемент страницы абсолютно позиционирован, и его ширина и/или высота заданы. В противном случае возвращается false.

Свойство доступно только для чтения

Поддерживается IE начиная с 5.5.

[править] height

Свойство задает или возвращает высоту элемента страницы в пикселах или как процент от доступного пространства.

{Объект}.height[ = "{Высота}"];

В NN доступно только для чтения.

Поддерживается IE начиная с 3.02 для <embed>, <img>, <marquee>, <object>, <td> и <th>, начиная с 4.0 для <table>, начиная с 5.0 для <tr> и начиная с 5.5 для <frame>.

Поддерживается NN начиная с 3.0.

[править] height (document)

Свойство задает или возвращает высоту документа в пикселах.

document.height;

Поддерживается NN начиная с 4.0.

[править] height (event)

Свойство задает или возвращает высоту окна или фрейма в пикселах.

document.height[ = {Y}];

Поддерживается NN начиная с 4.0.

[править] height (screen)

Свойство возвращает полную высоту экрана компьютера в пикселах.

screen.height;

Свойство доступно только для чтения.

Поддерживается IE и NN начиная с 4.0.

[править] height (CSS)

Свойство задает или возвращает высоту свободно позиционированного элемента.

{Объект стиля}.height[ = "auto|{Y}|{Y}%"];

Высота может быть задана как абсолютной величиной, так и процентом от высоты родителя. Предопределенное значение auto заставляет Web-обозреватель устанавливать высоту элемента самостоятельно. Значение по умолчанию auto.

Свойство доступно для чтения и записи, в случае объекта currentStyle — только для чтения.

Поддерживается IE начиная с 4.0.

[править] hidden

Свойство задает или возвращает признак внедренного элемента <embed>: будет ли тот виден на Web-странице.

{Внедренный объект}.hidden[ = true|false];

По умолчанию внедренный элемент <embed> видим (значение false). Чтобы скрыть его, присвойте этому свойству значение true.

Свойство доступно для чтения и записи, в случае объекта currentStyle — только для чтения.

Поддерживается IE начиная с 3.02.

[править] hideFocus

Свойство задает или возвращает признак: показывать фокус ввода (текстовый курсор) в элементе страницы или нет.

{Объект}.hideFocus[ = true|false];

По умолчанию фокус ввода всегда показывается (значение false). Чтобы скрыть его, присвойте этому свойству значение true.

Свойство доступно для чтения и записи, в случае объекта currentStyle — только для чтения.

Поддерживается IE начиная с 5.5.

[править] host

Свойство задает или возвращает доменное имя сервера и номер порта, являющиеся частью интернет-адреса текущей Web-страницы или гиперссылки.

location.host[ = "{Доменное имя и номер порта}"];

Поддерживается IE начиная с 3.02 для <а> и location и начиная с 4.0 для <area>.

Поддерживается NN начиная с 2.0.

[править] hostname

Свойство задает или возвращает доменное имя сервера, являющееся частью интернет-адреса текущей Web-страницы или гиперссылки.

location.hostname[ = "{Доменное имя}"];

Поддерживается IE начиная с 3.02 для <а> и location и начиная с 4.0 для <area>.

Поддерживается NN начиная с 2.0.

[править] href (<BASE>)

Свойство задает или возвращает базовый интернет-адрес в теге <base>, относительно которого отсчитываются все ссылки.

{Объект}.href[ = "{Базовый интернет-адрес}"];

Поддерживается IE начиная с 3.02

[править] href (location)

Свойство задает или возвращает полный интернет-адрес текущей Web-страницы.

location.host[ = "{Полный интернет-адрес}"];

Поддерживается IE начиная с 3.02

[править] href (styleSheet)

Свойство задает или возвращает интернет-адрес файла таблицы стилей.

{Объект таблицы стилей}.href[ = "{Интернет-адрес файла таблицы стилей}"];

Поддерживается IE начиная с 4.0

[править] href (гиперссылки)

Свойство задает или возвращает интернет-адрес назначения, куда пользователь попадет после активизации гиперссылки.

{Объект}.href[ = "{Интернет-адрес назначения}"];

Поддерживается IE начиная с 3.02

Поддерживается NN начиная с 2.0

[править] hspace

Свойство задает или возвращает расстояние по горизонтали от элемента страницы до окружающего его текста.

{Объект}.hspace[ = "{Горизонтальный отступ}"];

Значение по умолчанию 0.

В NN доступно только для чтения.

Поддерживается IE начиная с 3.02 для <applet>, <img>, <input TYPE="image">, <MARQUEE> и <OBJECT> и начиная С 4.0 для <IFRAME>.

Поддерживается NN начиная с 3.0

[править] htmlFor (<LABEL>)

Свойство задает или возвращает элемент управления, к которому привязана метка <LABEL>.

{Объект метки}.htmlFor[ = "{Имя элемента управления}"];

Поддерживается IE начиная с 4.0.

[править] htmlFor (<SCRIPT>)

Свойство задает или возвращает элемент страницы, к которому привязан скрипт.

{Объект метки}.htmlFor[ = "{Имя элемента страницы}"];

Этот способ создания обработчиков событий специфичен для IE.

Поддерживается IE начиная с 3.02

[править] htmlText

Свойство возвращает HTML-код текстового фрагмента TextRange.

{Объект}.htmlText;

Свойство доступно только для чтения.

Поддерживается IE начиная с 4.0

[править] httpEquiv

Свойство задает или возвращает тип метаданных, задаваемых в теге <META>.

{Объект метатега}.httpEquiv[ = "description|refresh|ur|mimetype|charset"];

Свойству доступны следующие значения:

  • description — задает описание Web-страницы;
  • refresh — задает интервал обновления Web-страницы, отображенной Web-обозревателем, в секундах;
  • url — задает адрес, откуда будет загружаться Web-страница при обновлении. Требует наличия тега <META>, задающего интервал обновления (refresh);
  • mimetype — задает тип данных MIME Web-страницы (всегда text/html);
  • charset — задает кодовую страницу, которая использовалась при написании текста.

Также могут поддерживаться другие, нестандартные типы метаданных.

Поддерживается IE начиная с 3.02

Получено с http://spravkaweb.local/index.php/javascript/property/h
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:04, 3 января 2007.
  • К этой странице обращались 79 раз.
1.62913799286


Справочник по JavaScript : Алфавитный указатель свойств : Свойства JavaScript на букву I — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель свойств : Свойства JavaScript на букву I

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель свойств | ::. | A : B : C : D : E : F : H : I : K : L

Содержание

  • 1 id
  • 2 imeMode
  • 3 indeterminate
  • 4 index
  • 5 innerHeight
  • 6 innerHTML
  • 7 innerText
  • 8 innerWidth
  • 9 isContentEditable
  • 10 isDisabled
  • 11 isMap
  • 12 isOpen
  • 13 isTextEdit

[править] id

Свойство возвращает уникальное имя элемента страницы, заданное атрибутом id.

{Объект}.id[ = "{Имя элемента страницы}"];

Свойство доступно только для чтения.

Поддерживается IE начиная с 4.0

[править] imeMode

Свойство задает или возвращает состояние IME (Input Method Editor — редактор способа ввода), с помощью которого вводятся иероглифические тексты на китайском, корейском и японском языках.

{Объект поля ввода}.style.imeMode[ = "auto|active|inactive|disabled"];

Для свойства доступны четыре значения:

  • auto (значение по умолчанию) — передает управление IME Web-обозревателю;
  • active — активизирует IME. Пользователь может его деактивизировать;
  • inactive — деактивизирует IME. Пользователь может его активизировать;
  • disabled — отключает IME.

Свойство доступно для чтения и записи, в случае объекта currentStyle — только для чтения.

Поддерживается IE начиная с 5.0

[править] indeterminate

Свойство задает или возвращает признак: находится ли флажок в неопределенном состоянии.

{Объект флажка}.indeterminate[ = true|false];

Неопределенным состоянием флажка называется такое состояние, когда он закрашен серым. При этом пользователь все еще может щелкать по флажку, меняя тем самым его состояние.

По умолчанию флажок находится в обычном — включенном либо выключенном — состоянии (значение false). Чтобы ввести его в неопределенное состояние, присвойте этому свойству значение true.

Поддерживается IE начиная с 4.0

[править] index

Свойство задает или возвращает порядковую позицию пункта списка <option> в списке выбора <select>.

{Объект позиции списка}.index[ = {Номер позиции}];

Поддерживается IE начиная с 3.02 и NN начиная с 2.0.

[править] innerHeight

Свойство задает или возвращает высоту клиентской области окна Web-обозревателя.

window.innerHeight[ = {Y}];

Поддерживается NN начиная с 4.0.

[править] innerHTML

Свойство задает или возвращает фрагмент HTML-кода, заключенного между открывающим и закрывающим тегами текущего элемента страницы.

{Объект}.innerHTML[ = "{HTML-код}"];

Доступно для чтения и записи, для тегов <COL>, <COLGROUP>, <FRAMESET>, <HEAD>, <HTML>, <STYLE>, <TABLE>, <TBODY>, <TFOOT>, <THEAD>, <TITLE> и <TR> — только для чтения.

Поддерживается IE начиная с 4.0.

[править] innerText

Свойство задает или возвращает фрагмент текста, заключенного между открывающим и закрывающим тегами текущего элемента страницы, без HTML-тегов.

{Объект}.innerText[ = "{Текст}"];

При присвоении этому свойству некоего текста все HTML-теги также игнорируются.

Доступно для чтения и записи, для тегов <HTML>, <TABLE>, <TBODY>, <TFOOT>, <THEAD> и <TR> — только для чтения.

Поддерживается IE начиная с 4.0.

[править] innerWidth

Свойство задает или возвращает ширину клиентской области окна Web-обозревателя.

window.innerWidth[ = {X}];

Поддерживается NN начиная с 4.0.

[править] isContentEditable

Свойство возвращает признак возможности редактирования элемента страницы.

{Объект}.isContentEditable;

Свойство возвращает true, если пользователь может редактировать содержимое Web-страницы или ее элемента, и false, если не может.

Доступно только для чтения.

Поддерживается IE начиная с 5.5.

[править] isDisabled

Свойство возвращает признак возможности взаимодействия с элементом страницы.

{Объект}.isDisabled;

Свойство возвращает true, если пользователь может взаимодействовать с элементом страницы, и false, если не может.

Доступно только для чтения.

Поддерживается IE начиная с 5.5.

[править] isMap

Свойство задает или возвращает признак рисунка <IMG>: будет ли он вести себя как карта-изображение.

{Объект рисунка}.isMap[ = true|false];

По умолчанию рисунок не является картой-изображением (значение false). Чтобы сделать его таковым, присвойте этому свойству значение true.

Поддерживается IE начиная с 3.02.

[править] isOpen

Свойство возвращает признак всплывающего окна: открыто оно или закрыто.

{Объект окна}.isOpen;

Свойство возвращает true, если всплывающее окно открыто, и false, если закрыто.

Свойство доступно только для чтения.

Поддерживается IE начиная с 5.5

[править] isTextEdit

Свойство возвращает true, если объект TextRange может быть создан с использованием текущего элемента страницы, и false, если не может быть создан.

{Объект}.isTextEdit;

Свойство доступно только для чтения.

Поддерживается IE начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/property/i
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:36, 3 января 2007.
  • К этой странице обращались 78 раз.
1.44402194023


Справочник по JavaScript : Алфавитный указатель свойств : Свойства JavaScript на букву K — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель свойств : Свойства JavaScript на букву K

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель свойств | ::. | A : B : C : D : E : F : H : I : K : L

[править] keyCode

Свойство задает или возвращает в формате Unicode код символа, связанного с нажатой клавишей.

event.keyCode[ = "{Код символа Unicode}"];

Если ни одна клавиша не была нажата, возвращается 0.

Поддерживается IE начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/property/k
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 15:50, 3 января 2007.
  • К этой странице обращались 60 раз.
1.36694288254


Справочник по JavaScript : Алфавитный указатель свойств : Свойства JavaScript на букву L — Справочник Web-языков

Справочник по JavaScript : Алфавитный указатель свойств : Свойства JavaScript на букву L

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Алфавитный указатель свойств | ::. | A : B : C : D : E : F : H : I : K : L

Содержание

  • 1 lang
  • 2 language
  • 3 language (navigator)
  • 4 lastChild
  • 5 lastModified
  • 6 layerX
  • 7 layerY
  • 8 layoutFlow
  • 9 layoutGrid
  • 10 layoutGridChar
  • 11 layoutGridLine
  • 12 layoutGridMode
  • 13 layoutGridType
  • 14 left (TextRectangle)
  • 15 left (слой)
  • 16 left (CSS)
  • 17 leftMargin
  • 18 length (<FORM>)
  • 19 length (history)
  • 20 length (<OPTION>)
  • 21 length (plugin)
  • 22 length (<SELECT>)
  • 23 length (TextNode)
  • 24 length (window)
  • 25 length (коллекция)
  • 26 letterSpacing
  • 27 lineBreak
  • 28 lineHeight
  • 29 link
  • 30 linkColor
  • 31 listStyle
  • 32 listStyleImage
  • 33 listStylePosition
  • 34 listStyleType
  • 35 locationbar
  • 36 loop (<BGSOUND>, <IMG>, <INPUT type="image">)
  • 37 loop (<MARQUEE>)
  • 38 lowsrc

[править] lang

Свойство задает или возвращает язык, на котором набран текст.

{Объект}.lang[ = "{Код языка}"];

Поддерживается IE начиная с 4.0

[править] language

Свойство задает или возвращает название языка программирования, на котором написан скрипт, привязанный к элементу страницы.

{Объект}.language[ = "JScript|javascript|vbs|vbscript|XML|{Код языка}"];

Для свойства доступны следующие значения:

  • JScript
  • javascript
  • vbs
  • vbscript
  • XML

Могут поддерживаться и другие, нестандартные языки.

Поддерживается IE начиная с 4.0

Пример 1:

<script language="JavaScript" id=scriptId>
document.writeln(scriptId.language);
</script>

Пример выведет:

JavaScript

[править] language (navigator)

Свойство возвращает код языка программы Web-обозревателя.

navigator.language;

Свойство доступно только для чтения.

Поддерживается NN начиная с 4.0

[править] lastChild

Свойство возвращает ссылку на последний элемент коллекции childNodes.

{Объект}.lastChild;

Свойство доступно только для чтения.

Поддерживается IE начиная с 5.0

[править] lastModified

Свойство возвращает дату последнего изменения файла Web-страницы.

document.lastModified;

Свойство доступно только для чтения.

Поддерживается IE начиная с 3.02 и NN с 2.0

[править] layerX

Свойство задает или возвращает либо ширину элемента страницы (при наступлении события изменения размера), либо горизонтальную координату курсора мыши относительно слоя в пикселах.

event.layerX[ = {X}];

Поддерживается NN начиная с 4.0

[править] layerY

Свойство задает или возвращает либо высоту элемента страницы (при наступлении события изменения размера), либо вертикальную координату курсора мыши относительно слоя в пикселах.

event.layerY[ = {Y}];

Поддерживается NN начиная с 4.0

[править] layoutFlow

Свойство задает или возвращает направление написания текста: по горизонтали или по вертикали.

{Объект стиля}.layoutFlow[ = "horizontal|vertical-ideographic"];

Для этого свойства доступны следующие значения:

  • horizontal - задает горизонтальное направление написания текста (значение по умолчанию);
  • vertical-ideographic - вертикальное направление написания текста.

Свойство доступно для чтения и записи, в случае объекта currentstyle — только для чтения.

Поддерживается IE начиная с 5.5.

В настоящее время признано устаревшим; вместо него рекомендуется использовать свойство writingMode.

[править] layoutGrid

Свойство задает или возвращает параметры разметки элемента страницы, используемой для вывода иероглифических текстов на китайском, корейском и японском языках.

{Объект стиля}.layoutGrid[ = ["{layoutGridChar}] [{layoutGridLine}] [{layoutGridMode}] [{layoutGridType}]"];

Заменяет свойства layoutGridChar, layoutGridLine, layoutGridMode и layoutGridType.

Значения этих свойств могут располагаться в любом порядке.

Значение по умолчанию both loose none none.

Поддерживается IE начиная с 5.0

[править] layoutGridChar

Свойство задает или возвращает шаг горизонтальной разметки элемента страницы, используемой для вывода иероглифических текстов на китайском, корейском и японском языках.

{Объект стиля}.layoutGridChar = ["none|auto|(Y)|{Y}%"];

Шаг разметки может быть задан как абсолютной величиной, так и процентом от шага разметки родителя. Предопределенное значение auto заставляет Web-обозреватель устанавливать шаг разметки по максимальному символу текста. Другое предопределенное значение none вообще отключает разметку.

Значение по умолчанию none.

Свойство доступно для чтения и записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная с 5.0

[править] layoutGridLine

Свойство задает или возвращает шаг вертикальной разметки элемента страницы, используемой для вывода иероглифических текстов на китайском, корейском и японском языках.

{Объект стиля}.layoutGridLine = ["none|auto|(Y)|{Y}%"];

Шаг разметки может быть задан как абсолютной величиной, так и процентом от шага разметки родителя. Предопределенное значение auto заставляет Web-обозреватель устанавливать шаг разметки по максимальному символу текста. Другое предопределенное значение none вообще отключает разметку.

Значение по умолчанию none. Свойство доступно для чтения и записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная с 5.0

[править] layoutGridMode

Свойство задает или возвращает тип разметки элемента страницы, используемой для вывода иероглифических текстов на китайском, корейском и японском языках.

{Объект стиля}.layoutGridMode = ["both|none|char|line"];

Для свойства доступны следующие значения:

  • both - задает использование и горизонтальной, и вертикальной разметок (значение по умолчанию);
  • none - отключает разметку;
  • char - задает использование горизонтальной разметки;
  • line - задает использование вертикальной разметки.

Свойство доступно для чтения и записи, в случае объекта currentStyle - только для чтения.

Поддерживается IE начиная с 5.0

[править] layoutGridType

Свойство задает или возвращает режим форматирования текстов на китайском, корейском и японском языках с использованием разметки элемента страницы.

{Объект стиля}.layoutGridType[ = "loose|strict|fixed"];

Для свойства доступны следующие значения:

  • loose - задает "гибкое" форматирование, используемое для корейских и японских текстов (значение по умолчанию);
  • strict - задает более "строгое" форматирование, используемое для китайских, корейских и японских текстов;
  • fixed - задает самое "строгое" форматирование, когда символы жестко привязываются к разметке.

Свойство доступно для чтения и записи, в случае объекта currentstyle - только для чтения.

Поддерживается IE начиная с 5.0

[править] left (TextRectangle)

Свойство задает или возвращает горизонтальную координату левой границы объекта TextRectangle в пикселах.

{Объект TextRectangle}.left[ = {X}];

Поддерживается IE начиная с 5.0

[править] left (слой)

Свойство задает или возвращает горизонтальную координату левой границы слоя в пикселах.

{Объект слоя}.left[ = {X}];

Поддерживается NN начиная с 5.0

[править] left (CSS)

Свойство задает или возвращает горизонтальную позицию левой границы свободно позиционированного элемента относительно родителя.

{Объект стиля}.left[ = "auto|{X}|{X}%"];

Координата может быть задана как абсолютной величиной, так и процентом от ширины родителя. Предопределенное значение auto заставляет Web-обозреватель позиционировать элемент самостоятельно.

Значение по умолчанию auto.

Свойство доступно для чтения и записи, в случае объекта currentstyle — только для чтения.

Поддерживается IE начиная с 4.0

[править] leftMargin

Свойство задает или возвращает расстояние от левой границы окна Web-обозревателя до левой границы содержимого Web-страницы в пикселах.

body.leftMargin[ = "{Расстояние}"];

Значение по умолчанию 10.

Поддерживается IE начиная с 4.0

[править] length (<FORM>)

Свойство возвращает количество элементов управления в форме.

{Объект формы}.length;

Свойство доступно только для чтения.

Поддерживается IE начиная с 3.02 и NN начиная с 2.0

[править] length (history)

Свойство возвращает количество позиций в списке "истории" Web-обозревателя.

history.length;

Свойство доступно только для чтения.

Поддерживается IE начиная с 3.02 и NN начиная с 2.0

[править] length (<OPTION>)

Свойство возвращает количество пунктов <option> в списке <select>.

{Объект пункта списка}.length;

Свойство доступно только для чтения.

Поддерживается NN начиная с 2.0

[править] length (plugin)

Свойство возвращает количество элементов коллекции navigator.plugins.

{Объект расширения Web-обозревателя}.length;

Свойство доступно только для чтения.

Поддерживается NN начиная с 3.0

[править] length (<SELECT>)

Свойство возвращает количество пунктов <option> в списке <select>.

{Объект списка}.length;

Свойство доступно только для чтения.

Поддерживается IE начиная с 3.02 и NN начиная с 2.0

[править] length (TextNode)

Свойство возвращает длину содержимого объекта TextNode в символах текста.

{Объект TextNode}.length;

Свойство доступно только для чтения.

Поддерживается IE начиная с 5.0

[править] length (window)

Свойство возвращает количество фреймов в окне Web-обозревателя.

window.length;

Свойство доступно только для чтения.

Поддерживается IE начиная с 3.02 и NN начиная с 2.0

[править] length (коллекция)

Свойство возвращает количество элементов коллекции.

{Коллекция}.length;

Свойство доступно только для чтения.

Поддерживается IE начиная с 3.02

[править] letterSpacing

Свойство задает или возвращает интервал, добавляемый между символами текста.

{Объект стиля}.letterSpacing[ = "normal|{Величина}"];

Значение этого свойства может быть задано либо абсолютной величиной в одной из поддерживаемых CSS единиц измерения, либо предопределенным значением normal, задающим стандартную величину расстояния между символами.

Значение по умолчанию normal.

Свойство доступно для чтения и записи, в случае объекта currentStyle — только для чтения.

Поддерживается IE начиная с 4.0

[править] lineBreak

Свойство задает или возвращает правила разрыва строк для текста на японском языке.

{Объект стиля}.lineBreak[ = "normal|strict"];

Доступны два значения: normal (значение по умолчанию), задающее обычные правила разрыва японского текста, и strict, задающее строгие правила.

Свойство доступно для чтения и записи, в случае объекта currentStyle — только для чтения.

Поддерживается IE начиная с 5.0

[править] lineHeight

Свойство задает или возвращает расстояние по вертикали между строками текста.

{Объект стиля}.lineHeight[ = "normal|{Y}|{Y}%"];

Высота может быть задана как абсолютной величиной, так и процентом от высоты родителя. Предопределенное значение normal задает стандартное расстояние.

Значение по умолчанию normal.

Свойство доступно для чтения и записи, в случае объекта currentstyle — только для чтения.

Поддерживается IE и NN начиная с 4.0

[править] link

Свойство задает или возвращает цвет гиперссылок в документе.

body.link[ = "{Цвет}"];

Поддерживается IE начиная с 3.02

[править] linkColor

Свойство задает или возвращает цвет гиперссылок в документе.

document.linkColor[ = "{Цвет}"];

Значение по умолчанию #0000FF.

Поддерживается IE начиная с 3.02 и NN начиная с 2.0

[править] listStyle

Свойство задает или возвращает параметры маркера или номера позиции списка.

{Объект стиля}.listStyle[ = "[{listStylelmage}] [{listStylePosition}] [ {listStyleType}]"];

Это свойство заменяет свойства listStylelmage, listStylePosition И listStyleType. Значения этих свойств могут располагаться в любом порядке.

Значение по умолчанию disc outside none.

Поддерживается IE начиная с 4.0

[править] listStyleImage

Свойство задает или возвращает интернет-адрес файла графического изображения, отображаемого в качестве маркера позиции списка.

{Объект стиля}.listStylelmage[ = "none|url({Интернет-адрес файла изображения}) "];

Это свойство Имеет приоритет над свойством listStyleType.

Если задано предопределенное значение none, то стиль маркера берется из установок свойства listStyleType. Если задан интернет-адрес файла изображения, то это изображение отображается в качестве маркера, перекрывая установки свойства listStyleType.

Значение по умолчанию none.

Свойство доступно для чтения и записи, в случае объекта currentStyle — только для чтения.

Поддерживается IE начиная с 4.0

[править] listStylePosition

Свойство задает или возвращает местонахождение маркера позиции списка.

{Объект стиля}.listStylePosition[ = "outside|inside"];

Доступны два значения. Значение outside (по умолчанию) задает отображение маркера позиции списка вне текста позиции. Значение же inside заставляет Web-обозреватель отобразить маркер позиции в ее тексте в качестве первого символа.

Свойство доступно для чтения и записи, в случае объекта currentStyle — только для чтения.

Поддерживается IE начиная с 4.0

[править] listStyleType

Свойство задает или возвращает тип маркера или номера позиции списка.

{Объект стиля}.listStyleType[ = "disc|circle|square|decimal|lower-roman| upper-roman|lower-alpha|upper-alpha|none"];

Для свойства доступны следующие значения:

  • disc - отображает сплошной кружок (значение по умолчанию);
  • circle - окружность;
  • square - сплошной квадрат;
  • decimal - нумерует позиции арабскими цифрами;
  • lower-roman - малыми римскими;
  • upper-roman - большими римскими;
  • lower-alpha - помечает позиции малыми латинскими буквами;
  • upper-alpha - большими латинскими;
  • none - вообще убирает маркер или нумерацию.

Свойство доступно для чтения и записи, в случае объекта currentStyle — только для чтения.

Поддерживается IE и NN начиная с 4.0

[править] locationbar

Свойство задает или возвращает состояние панели адреса: показана ли она на экране или скрыта.

window.locationbar[ = true|false];

Значение true показывает панель адреса на экране, значение false скрывает.

Свойство доступно для чтения и записи, в случае объекта currentStyle — только для чтения.

Поддерживается NN начиная с 4.0

[править] loop (<BGSOUND>, <IMG>, <INPUT type="image">)

Свойство задает или возвращает количество повторений фонового звука или видеофильма.

{Объект}.loop[ = "-1|0|{Количество}"];

Значение -1 или 0 задает бесконечное повторение.

Значение по умолчанию 1.

Поддерживается IE начиная с 3.02

[править] loop (<MARQUEE>)

Свойство задает или возвращает количество "прокруток" текста в элементе <marquee>.

{Объект}.loop[ = "-1|0|{Количество}"];

Значение -1 или 0 задает бесконечное повторение.

Значение по умолчанию -1.

Поддерживается IE начиная с 3.02

[править] lowsrc

Свойство задает или возвращает интернет-адрес файла с изображением низкого разрешения.

{Объект изображения}.lowsrc[ = "{Интернет-адрес файла изображения}"];

Значение -1 или 0 задает бесконечное повторение.

Значение по умолчанию -1.

Поддерживается IE начиная с 4.0 и NN начиная с 3.0

Получено с http://spravkaweb.local/index.php/javascript/property/l
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 10:44, 4 января 2007.
  • К этой странице обращались 72 раза.
1.38509702682


Справочник по JavaScript : Объект history — Справочник Web-языков

Справочник по JavaScript : Объект history

 |  |  |  | Объект screen
Главная | ::. | JavaScript | ::. | Объект history
 |  |  |  | Алфавитный указатель свойств

Объект history представляет интерфейс к списку истории Web-обозревателя, т.е. списку всех Web-страниц, просмотренных пользователем в течение времени, указанного в настройках.

Содержание

  • 1 Свойства объекта history
  • 2 current
  • 3 length
  • 4 next
  • 5 previous
  • 6 Методы объекта history
  • 7 back()
  • 8 forward()
  • 9 go()

[править] Свойства объекта history

[править] current

Возвращает интернет-адрес документа, загруженного в настоящее время.

[править] length

Возвращает размер списка истории.

[править] next

Возвращает интернет-адрес следующего в списке истории документа.

[править] previous

Возвращает интернет-адрес предыдущего в списке истории документа.

[править] Методы объекта history

[править] back()

Загружает в окно Web-обозревателя предыдущий документ из списка истории.

[править] forward()

Загружает в окно Web-обозревателя следующий документ из списка истории.

[править] go()

go({Адрес})

Загружает в окно Web-обозревателя следующий документ из списка истории, интернет-адрес которого наиболее близок к переданному в качестве параметра.

Поддерживается только NN.

go({Позиция})

Перемещается в списке истории на позицию, номер которой передан в качестве параметра.

Поддерживается только IE начиная с 4.0

go({Приращение})

Перемещается в списке историй на количество позиций, переданных в качестве параметра. Можно задавать как положительные, так и отрицательные значения приращения.

Поддерживается только NN.

Получено с http://spravkaweb.local/index.php/javascript/reference/history
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 06:25, 3 января 2007.
  • К этой странице обращались 94 раза.
7.1665019989


Справочник по JavaScript : Объект location — Справочник Web-языков

Справочник по JavaScript : Объект location

 |  |  |  | Объект document: Обращение к элементам страницы
Главная | ::. | JavaScript | ::. | Объект location
 |  |  |  | Объект style

Объект location содержит информацию о местонахождении текущего документа, т.е. его интернет-адрес. Его также можно использовать для перехода на другой документ и перезагрузки текущего документа.

[править] Свойства объекта location

  • hash - Имя "якоря" в интернет-адресе документа, если оно есть.
  • host - Имя компьютера в сети интернет вместе с номером порта, если он указан.
  • hostname - Имя компьютера в сети Интернет.
  • href - Полный интернет-адрес документа.
  • pathname - Путь и имя файла, если они есть.
  • port - Номер порта. Если не указан, возвращает номер 80 - стандартный порт, через который работает протокол HTTP.
  • protocol - Идентификатор протокола. Если не указан, возвращается "http:".
  • search - Строка параметров, если она есть.

[править] Методы объекта location

  • assign({Адрес}) - Загружает документ, адрес которого передан в качестве параметра. Поддерживаетс только IE начиная с 4.0
  • reload([true|false]) - Перезагружает документ с Web-сервера. Необязательный параметр нужен только для NN: значение true заставляет Web-обозреватель перезагрузить документ с жесткого диска, где он был сохранен ранее, а false (значение по умолчанию) - прямо с Web-сервера.
  • replace({Адрес}) - Загружает документ, адерс которого передан в качестве параметра, и заменяет в списке истории Web-обозревателя адрес предыдущего документа адресом нового.

Пользуясь объектом location, можно загрузить другой документ на место текущего. Для этого просто присвойте значение нового интернет-адреса свойству href.

document.location.href = "http://www.spravkaweb.ru";

Пользователи IE также могут воспользоваться методом assign:

document.location.assign("http://www.spravkaweb.ru");

Если вы хотите полностью заменить текущий документ, чтобы даже адрес его не появлялся в списке истории, воспользуйтесь методом replace:

document.location.replace("http://www.spravkaweb.ru");
Получено с http://spravkaweb.local/index.php/javascript/reference/location
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 08:52, 2 января 2007.
  • К этой странице обращались 137 раз.
5.21464395523


Справочник по JavaScript : Объект navigator — Справочник Web-языков

Справочник по JavaScript : Объект navigator

 |  |  |  | Объект layer ::. Методы
Главная | ::. | JavaScript | ::. | Объект navigator
 |  |  |  | Объект screen

Объект navigator служит для доступа к самой программе Web-обозревателя. Не путайте его с объектом window, представляющем текущее окно Web-обозревателя, и названием программы Netscape Navigator.

[править] appCodeName

Возвращает имя кода программы Web-обозревателя. И для Internet Explorer, и для Navigator вернет строку "Mozilla".

[править] appMinorVersion

Возвращает младшую цифру номера версии программы Web-обозревателя. Например, для Internet Explorer 5.0 вернет "0", а для 5.5 - "5".

Поддерживается только Internet Explorer начиная с 4.0

[править] appName

Возвращает имя программы Web-обозревателя, например, "Netscape" или "Microsoft Internet Explorer".

[править] appVersion

Возвращает версию программы Web-обозревателя.

[править] browserLanguage

Возвращает код программы Web-обозревателя. Поддерживается только IE начиная с 4.0

[править] cookieEnabled

Возвращает true, если Web-обозревателю разрешен пользователем прием cookie. Поддерживается только IE начиная с 4.0

[править] cpuClass

Возвращает класс процессора клиентского компьютера, например, "x86" или "Alpha". Поддерживается только IE начиная с 4.0

[править] language

Возвращает код языка программы Web-обозревателя. Поддерживается только NN начиная с 4.0

[править] onLine

Возвращает true, если клиент в настоящее время подключен к интернету (находится в режиме on-line), и false, если отключен (off-line).

Поддерживается только IE начиная с 4.0

[править] platform

Возвращает название клиентской платформы, например, "Win32".

[править] systemLanguage

Возвращает код языка операционной системы клиента. Поддерживается только IE начиная с 4.0

[править] userAgent

Возвращает строку, идентифицирующую Web-обозреватель клиента. Является комбинацией значений свойств appCodeName и appVersion.

[править] userLanguage

То же самое, что browserLanguage.

Поддерживается только IE начиная с 4.0

Объект navigator поддерживает, кроме того, метод javaEnabled(), возвращающий true, если Web-обозревателю разрешено пользователем выполнение сценариев JavaScript.

Немного более подробно хотелось бы сказать о свойстве appVersion, а точнее о возвращаемом им значении. Все дело в том, что у IE и NN оно будет разным.

Вот какой формат будет у Navigator:

{Версия} [{Язык}] ({Операционная система}; U|I)

Здесь {Версия} представляет собой версию Web-обозревателя, {Язык} - язык программы (но может и отсутствовать), {Операционная система} - обозначение операционной системы клиента, например, "Win96", "Win16" или "WinNT", буква "U" - американскую версию программы, а "I" - интернациональную.

Например:

4.0 [ru] (Win95; I)

У Internet Explorer формат вывода значений свойства appVersion другой:

{Совместимая версия Navigator} (compatible; {Версия}; {Операционная система})

Здесь {Операционная система} может принимать значения "Windows 3.1", "Windows 3.11", "Windows 95" или "Windows NT".

2.0 (compatible; 3.01; Win95)

Свойство userAgent возвращает значение, имеющее формат:

{Значение appCodeName}/{Значение appVersion}

То есть, для двух предыдущих примеров мы получим следующие значения:

Mozilla/4.0 (Win95; I)
Mozilla/2.0 (compatible; 3.01; Win95)
Получено с http://spravkaweb.local/index.php/javascript/reference/navigator
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 06:18, 3 января 2007.
  • К этой странице обращались 111 раз.
9.09508705139


Справочник по JavaScript : Объект screen — Справочник Web-языков

Справочник по JavaScript : Объект screen

 |  |  |  | Объект navigator
Главная | ::. | JavaScript | ::. | Объект screen
 |  |  |  | Объект history

Объект screen служит для доступа к характеристикам видеосистемы компьютера клиента.

Содержание

  • 1 availHeight
  • 2 availWidth
  • 3 colorDepth
  • 4 height
  • 5 width

[править] availHeight

Возвращает высоту полезной области экрана без панели задач и подобных ей элементов графического интерфейса системы.

[править] availWidth

Возвращает ширину полезной области экрана без панели задач и подобных ей элементов графического интерфейса системы.

[править] colorDepth

Возвращает глубину цвета. Для 16 цветов возвращается 2, для 256 - 8, для 16,7 миллионов цветов (режим High Color) - 32

[править] height

Возвращает полную высоту экрана.

[править] width

Возвращает полную ширину экрана.

Получено с http://spravkaweb.local/index.php/javascript/reference/screen
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 06:20, 3 января 2007.
  • К этой странице обращались 115 раз.
8.41816997528


Справочник по JavaScript : Объект document : Коллекция объектов — Справочник Web-языков

Справочник по JavaScript : Объект document : Коллекция объектов

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Методы объекта document
Главная | ::. | JavaScript | ::. | Объект document | ::. | Коллекция объектов
 |  |  |  |  |  | Подчиненные объекты и коллекции объекта document

Коллекция - это своего рода массив объектов, проиндексированный не только по числовым номерам элементов, но и по их именам, и имеющий свойства и методы. Коллекция отличается от ассоциативного массива именно наличием свойств и методов, т.е. коллекция - сама по себе объект.

Рассмотрим, например, коллекцию images, которую включает в себя объект document. Вы можете получить доступ к отдельным ее элементам по порядковому номеру или уникальному имени.

document.images.item(1)
document.images("iamge1")

Заметьте, что мы указываем индекс элемента коллекции не в квадратных, а в круглых скобках, потому что он фактически является аргументом функции-метода item, поддерживаемой всеми коллекциями. Имя этого метода можно опускать.

document.images(1)
document.images("image1")

Все элементы Web-страницы нумеруются в порядке их появления в HTML-коде. А уникальные имена задаются специальным атрибутом ID, доступным практически во всех тегах.

<IMG src="img1.gif" id="image1">
<SCRIPT>
<!--
var someImage = document.images("image1");
-->
</SCRIPT>

Для некоторых тегов (в частности <IMG> и <FRAME>) доступен также атрибут NAME, выполняющий ту же функцию, что и ID.

Коллекция all представляет все элементы Web-страницы без исключений, в том числе и изображения. К элементам этой коллекции можно обращаться по номеру (нумеруются они в порядке появления в HTML-коде) или по имени.

document.all(8)
document.all("iamge1")

Атрибут ID требует уникальности имен всех элементов, но только формально. Реально же на странице могут встретиться два или более элемента с одинаковыми именами. В таком случае нужно будет указать второй индекс

document.all("image1", 2)

или выражение document.all("image1") вернет коллекцию всех изображений с именем image1.

Также все коллекции имеют свойство length, вызывающее количество элементов коллекции. Надо отметить, что элементы коллекции нумеруются с нуля, поэтому последний ее элемент будет иметь номер length-1.

Некоторые коллекции могут иметь методы для добавления и удаления элементов и других целей.

Получено с http://spravkaweb.local/index.php/javascript/reference/document/collection
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 15:00, 23 декабря 2006.
  • К этой странице обращались 102 раза.
1.43745994568


Справочник по JavaScript : Объект document : Обращение к элементам страницы — Справочник Web-языков

Справочник по JavaScript : Объект document : Обращение к элементам страницы

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Подчиненные объекты и коллекции объекта document
Главная | ::. | JavaScript | ::. | Объект document | ::. | Обращение к элементам страницы
 |  |  |  |  |  | Объект location

Объект document имеет несколько полезных методов, которые можно использовать в скриптах. Но главное его значение - предоставление доступа к отдельным элементам Web-страницы. Как же можно добраться до отдельного элемента страницы? Прежде всего, через коллекции. Например, коллекцию all:

document.all("image1").outerHTML

Или через коллекцию images:

document.images("image1").outerHTML

IE позволяет опускать ссылку на объект document. Так что можно будет написать и так:

all("image1").outerHTML
images("image1").outerHTML

NN делать так не позволяет. Он требует обязательной ссылки на document. Вдобавок он не поддерживает коллекцию all.

document.images("image2").src

Имя элемента Web-страницы задается при помощи атрибутов ID и NAME. Если каждый элемент страницы имеет уникальное имя, то можно использовать так называемое прямое обращение к элементам. То есть, обращаться к нему не как к элементу коллекции, а как к отдельному объекту. Это работает и в IE и в NN.

image1.outerHTML
layer1.top

Прямое обращение происходит быстрее, чем обращение через коллекцию. Поэтому его рекомендуется использовать во всех случаях, когда не нужно специальное обращение к коллекциям и когда каждый элемент страницы, к которому производится обращение из скриптов, имеет уникальное имя.

Получено с http://spravkaweb.local/index.php/javascript/reference/document/element
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 08:37, 2 января 2007.
  • К этой странице обращались 103 раза.
1.47906494141


Справочник по JavaScript : Объект document : Методы объекта document — Справочник Web-языков

Справочник по JavaScript : Объект document : Методы объекта document

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Свойства объекта document
Главная | ::. | JavaScript | ::. | Объект document | ::. | Методы объекта document
 |  |  |  |  |  | Коллекция объектов

Содержание

  • 1 clear()
  • 2 close()
  • 3 createAttribute()
  • 4 setAttributeNode
  • 5 createElement()
  • 6 elementFromPoint()
  • 7 getElementById()
  • 8 getSelection()
  • 9 write()
  • 10 writeLn()

[править] clear()

Этот метод предназначен для очистки текущего документа из окна браузера.

  • Возвращаемое значение: отсутствует
  • Совместимость:IE начиная с 3.02, NN начиная с 2.0

[править] close()

Заставляет Web-страницу немедленно обновить свое содержимое после использования методов write. Метод не принимает параметров и не возвращает значения.

  • Возвращает: нет
  • Совместимость:IE начиная с 4.0, NN начиная с 2.0

[править] createAttribute()

createAttribute( "Имя Атрибута" )

Генерирует объект атрибута и возвращает ссылку на него. При вызове метода указывается только название атрибута, таким образом, в сценарии назначается значение свойству nodeValue, а затем новый атрибур добавляется в существующий элемент с помощью метода *Возвращает: ссылка на объект атрибута

[править] setAttributeNode

var newAttr = document.createAttribute("width");
newAttr.nodeValue = "80%";
document.getElementById("myTable").setAttributeNode(newAttr);
  • Совместимость:NN начиная с 6.0

[править] createElement()

createElement( "Имя дескриптора" )

Генерирует объект атрибута для любого дескриптора HTML(или XML), указанного в качастве параметра. Этот объект официально не является частью объектной модели текущего документа, так как он в состав документа пока ещё не входит. Но данный метод используется для вызова объекта элемента, который в конечном счёте будет помещён в документ.

  • Возвращает: ссылка на объект атрибута
  • Совместимость:IE начиная с 4.0, NN начиная с 6.0

[править] elementFromPoint()

elementFromPoint({X}, {Y})

Возвращает ссылку на элемент, находящийся по координатам X и Y. Метод принимает два параметра, задающие в пикселях горизональную и вертикальную координаты соответственно.

  • Поддерживается IE начиная с 4.0

[править] getElementById()

getElementById({Имя элемента})

Возвращает элемент, имя которого передано в качестве параметра. Имя элемента страницы задается атрибутом ID. Метод принимает единственный параметр - имя элемента страницы.

  • Поддерживаестя IE начиная с 5.0

[править] getSelection()

Возвращает строку, содержащую текст, выделенный пользователем на странице. Метод не принимает параметров.

  • Поддерживается только NN начиная с 4.0

[править] write()

write({Текст})

Записывает текст или HTML-код, переданный как параметр, в текущее место документа.

  • Поддерживается IE начиная с 3.02 и NN начиная с 2.0

[править] writeLn()

writeLn({Текст})

То же самое, что write, но в конце добавляет символ возврата каретки и перевода строки.

  • Поддерживается IE начиная с 3.02 и NN начиная с 2.0
Получено с http://spravkaweb.local/index.php/javascript/reference/document/method
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 18:00, 22 декабря 2006.
  • К этой странице обращались 104 раза.
1.3856651783


Справочник по JavaScript : Объект document : Подчиненные объекты и коллекции объекта document — Справочник Web-языков

Справочник по JavaScript : Объект document : Подчиненные объекты и коллекции объекта document

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Коллекция объектов
Главная | ::. | JavaScript | ::. | Объект document | ::. | Подчиненные объекты и коллекции объекта document
 |  |  |  |  |  | Обращение к элементам страницы

Объект document содержит внутри себя множество подчиненных объектов и коллекций. В следующей таблице перечисленны свойства, возвращающие ссылки на них, и приведены описания соответствующих объектов и коллекций.

  • all - Все элементы страницы, включая теги <HTML>, <HEAD>, <TITLE> и <BODY>. Поддерживается только IE начиная с 4.0
  • anchors - Все "якоря" страницы
  • applets - Все Java-апплеты, изображения и элементы ActiveX
  • embeds - Все расширения, внедренные в страницу.
  • forms - Все Web-формы.
  • frames - Все фреймы набора фреймов. Как свойство объекта document поддерживается только IE.
  • images - Все изображения на странице.
  • layers - Все слои страницы. Поддерживается только NN начиная с 4.0
  • links - Все гиперссылки на странице. В случае NN также все "горячие" области <AREA>.
  • location - Объект location для данного документа. Как свойство объекта document поддерживается только IE.
  • scripts - Все скрипты, внедренные в страницу. Поддерживается только IE начиная с 4.0
  • selection - Объект selection, представляющий выделенный пользователем на странице текст. Поддерживается только IE начиная с 4.0 В NN используется метод getSelection.
  • styleSheets - Все таблицы стилей встроенные или привязанные к странице. Поддерживается только IE начиная с 4.0

Коллекция all имеет дополнительный метод tags, позволяющий фильтровать элементы коллекции по их тегу. В качестве параметра этот метод принимает строковое значение нужного тега.

document.all.tags("H1")

Данное выражение вернет ссылку на коллекцию, содержащую только заголовки первого уровня.

Такой же метод поддерживает коллекция links.

Также хочу упомянуть два метода, поддерживаемых Internet Explorer начиная с 5.0. Это методы getElementByName и getElementByTagName. Первый из них возвращает коллекцию элементов со значением атрубута NAME, переданным в качестве параметра. Поскольку атрибут NAME применяется в современном HTML очень редко, польза от этого метода невелика. Второй метод возвращает коллекцию элементов, созданных посредством тега, переданного в качестве параметра.

document.getElementByName("someimage")
document.getElementByTagName("H1")
Получено с http://spravkaweb.local/index.php/javascript/reference/document/object
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 15:21, 23 декабря 2006.
  • К этой странице обращались 102 раза.
1.3816549778


Справочник по JavaScript : Объект document : Свойства объекта document — Справочник Web-языков

Справочник по JavaScript : Объект document : Свойства объекта document

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Объектная модель документа
Главная | ::. | JavaScript | ::. | Объект document | ::. | Свойства объекта document
 |  |  |  |  |  | Методы объекта document

Прежде всего надо отметить, что объект document существует в единственном экземпляре для всего HTML-документа. Он присутствует всегда, если существует HTML-документ, поэтому специально создавать его не требуется.

Содержание

  • 1 activeElement
  • 2 alinkColor
  • 3 anchors
  • 4 applets
  • 5 bgColor
  • 6 body
  • 7 charset
  • 8 characterSet
  • 9 compatMode
  • 10 defaultCharset
  • 11 designMode
  • 12 documentElement
  • 13 embeds
  • 14 expando
  • 15 fgColor
  • 16 fileCreatedDate
  • 17 fileModifiedDate
  • 18 fileSize
  • 19 forms
  • 20 frames
  • 21 height
  • 22 images
  • 23 lastModified
  • 24 layers
  • 25 linkColor
  • 26 links
  • 27 location
  • 28 URL
  • 29 parentWindow
  • 30 plugins
  • 31 protocol
  • 32 readState
  • 33 referrer
  • 34 script
  • 35 security
  • 36 selection
  • 37 styleSheets
  • 38 title
  • 39 URL
  • 40 URLUnencoded
  • 41 vlinkColor
  • 42 wigth

[править] activeElement

Используется в сценарии для получения ссылки на элемент странички находящийся в данный момент в фокусе

  • Возвращает: ссылка на объект
  • Совместимость: IE начиная с 4.0

[править] alinkColor

Задает или возвращает цвет активных гиперссылок.

document.alinkColor[ ="{Цвет}"];
  • Возвращает: шестнадцатеричное значение или название цвета
  • Значение по умолчанию #0000FF.
  • Совместимость: IE начиная с 3.02, NN начиная с 2.0

[править] anchors

Объекты анкеров представляют собой выражения в документе HTML, описанные в дескрипторе . Данные объекты обозначаются в URL символом #, расположенным между URL странички и именем анкера.

Пример: Получение количества анкеров в документе

var anchorCount=document.anchors.length
  • Возвращает: массив объектов анкеров
  • Совместимость: IE начиная с 3.02, NN начиная с 2.0

[править] applets

Благодаря свойству applets можно обращаться к аплетам java, содержащимся в документе.

  • Возвращает: массив объектов аплетов
  • Совместимость: IE начиная с 4.0, NN начиная с 3.0

[править] bgColor

Задает или возвращает цвет фона страницы. В IE работает правильно, только если цвет страницы установлен атрибутом BGCOLOR.

  • Возвращает: шестнадцатеричное значение или название цвета
  • Совместимость: IE начиная с 3.02, NN начиная с 2.0

[править] body

Этот объект имеет множество ключевых свойств для управления внешним видом странички. Для доступа к его свойствам лучше использовать выражение document.body.

  • Возвращает: ссылку на все содержимое тега <BODY>
  • Совместимость: IE начиная с 4.0, NN начиная с 6.0

[править] charset

Это свойство устанавливает кодировку, используемую браузером для отображения текущей странички. Используется только IE.

  • Возвращает: строковое представление (описание) кодировки
  • Совместимость: IE начиная с 3.02, NN начиная с 2.0

[править] characterSet

Это свойство устанавливает кодировку, используемую браузером для отображения текущей странички.Используется только NN.

  • Возвращает: строковое
  • Совместимость: NN начиная с 6.0

[править] compatMode

в Internet Explorer 6 появилось новое свойство объекта document, которое обзывается compatMode. Благодаря этому свойству (оно, кстати, только для чтения) мы можем определить, какой режим включён в данный момент — BackCompat (IE 4.x–IE 5.x) или CSS1Compat (IE 6). Исходя из значения этого свойство, мы можем, например, указывать различные значения CSS свойств width, margin или padding:

if (document.getElementById)
{
oBlock = document.getElementById("mydiv");
oBlock.style.width =
  ((document.compatMode) && (document.compatMode == "CSS1Compat")) ? "200px" : "250px";
}
  • Возвращает: строковое
  • Совместимость: IE начиная с 6.0

[править] defaultCharset

Это свойство устанавливает кодировку, используемую браузером для отображения текущей странички.Различия между charset и defaultCharset не найдено, однако если в сценарии временно изменять свойство charset, для восстановления оригинального набора символов можно воспользоваться defaultCharset.

  • Возвращает: строковое
  • Совместимость: IE начиная с 4.0

[править] designMode

Это свойство используется, когда браузер IE выступает в качестве компонента другого приложения, данная ситуация описана здесь. Оно разрешает/запрещает изменение HTML кода текущей странички, в обычных условиях это свойство не имеет никакого действия.

  • Возвращает: строковое
  • Совместимость: IE начиная с 5.0

[править] documentElement

Возвращает ссылку на объект HTML или XML - элемента, который представляет содержимое всего текущего документа.

  • Возвращает: ссылка на элемент HTML или XML- объекта
  • Совместимость: IE начиная с 5.0, NN начиная с 6.0

[править] embeds

Всякий раз, когда необходимо загрузить данные, требующие надстройки (внедряемого модуля)-приложения для их воспроизведения либо вывода на экран, используют дескриптор Свойство document.embeds - это единственный способ определения таких дескрипторов, добавленных в документ

var сount=document.embeds.length
  • Возвращает: массив объектов элемента embed
  • Совместимость: IE начиная с 4.0, NN начиная с 3.0

[править] expando

Это свойство установленное в true позволяет использовать новые свойства объекта, добавленные вами при выполнении сценария

  • Возвращает: булево
  • Совместимость: IE начиная с 3.02, NN начиная с 2.0

[править] fgColor

Задает или возвращает цвет текста. Значение по умолчанию #000000.

  • Возвращает: шестнадцатеричное значение или название цвета
  • Совместимость: IE начиния с 3.02, NN начиная с 2.0

[править] fileCreatedDate

Возвращает дату создания файла HTML-документа в формате mm/dd/yyyy, только для чтения.

  • Возвращает: строка
  • Совместимость: IE начиния с 4.0

[править] fileModifiedDate

Возвращает дату последнего изменения файла HTML-документа в формате mm/dd/yyyy, только для чтения.

  • Возвращает: строка
  • Совместимость: IE начиния с 4.0

[править] fileSize

Возвращает размер файла HTML-документа или графического изображения.

  • Возвращает: строка
  • Совместимость: IE начиния с 4.0

[править] forms

Возвращает массив объектов form. Первым элементом массива document.forms[0] является ссылка на самую первую форму, определённую в документе.

  • Возвращает: массив
  • Совместимость: IE начиния с 3.02, NN начиная с 2.0

[править] frames

Возвращает массив объектов frame. Первым элементом массива document.frames[0] является ссылка на самую первыйфрейм, определённый в документе.

  • Возвращает: массив
  • Совместимость: IE начиния с 4.0

[править] height

Задает или возвращает высоту текущего окна или фрейма в пикселях, соответствует свойству в IE scrollHeight.

  • Возвращает: целочисленное
  • Совместимость: NN начиная с 4.0

[править] images

Содержит массив дескрипторов всех изображений загруженных на текущей страничке, благодаря этому можно обращаться к изображениям так
edocument.images[0]
  • Возвращает: массив
  • Совместимость: IE начиния с 4.0, NN начиная с 3.0

[править] lastModified

Возвращает дату последнего изменения документа в виде строки.

  • Возвращает: строковая дата
  • Совместимость: IE начиная с 3.02, NN начиная с 2.0

[править] layers

Это массив слоёв расположенных в документе

  • Возвращает: массив
  • Совместимость: NN 4.0

[править] linkColor

Задает или возвращает цвет гиперссылок в документе. В IE работает правильно, только если цвет гипессылок установлен атрибутом LINK.

  • Возвращает: шестнадцатеричное значение или название цвета
  • Совместимость:IE начиная с 3.02, NN начиная с 2.0

[править] links

Массив содержит в себе ссылки на все объекты ссылок в текущем документе, нумерация начинается с 0.

  • Возвращает: массив
  • Совместимость:IE начиная с 3.02, NN начиная с 2.0

[править] location

Установка нового URL адреса свойству location приведёт к загрузке странички находящейся по этому адресу

  • Возвращает: строковое
  • Совместимость:IE начиная с 3.02, NN начиная с 2.0

[править] URL

Свойство только для чтения, возвращает адрес текущей загруженной в браузер странички.

  • Возвращает: строковое
  • Совместимость:IE начиная с 3.02, NN начиная с 2.0

[править] parentWindow

Свойство document.parentWindow возвращает ссылку на объект window, который содержит текущий документ.

  • Возвращает: ссылка на объект window
  • Совместимость:IE начиная с 4.0

[править] plugins

Аналог document.embeds

  • Возвращает: массив
  • Совместимость:IE начиная с 4.0, NN начиная с 4.0

[править] protocol

Возвращает версию протокола, с помощью которой и осуществлялся доступ к текущему документы

  • Возвращает: строковое
  • Совместимость:c NN начиная с 2.0

[править] readState

Возвращает текущее состояние документа.

Возвращает одно из четырех значений
complete - означает, что документ полностью загружен
interactive - загружен не полностью но доступен для просмотра и управления
loading - загружается
uninitialized - недоступен, как правило, загружается.
  • Доступен только для чтения.
  • Возвращает: строковое
  • Совместимость:IE начиная с 4.0

[править] referrer

Возвращает Интернет-адрес Web-страницы, с которой пользователь перешел на текущую страницу. Если же пользователь перешел на нее простым набором адреса в строке Web-обозревателя, возвращается пустая строка.

  • Возвращает: строковое
  • Совместимость:IE начиная с 3.02, NN начиная с 2.0

[править] script

Возвращает массив всех элементов SCRIPT содержащихся в документе. Имеется возможность не только просматривать массив, но и добавлять/удалять элементы.

  • Возвращает: массив
  • Совместимость:IE начиная с 4.0

[править] security

Это свойство предоставляет информацию о типе защиты, если таковая применяется в текущем документе.

  • Возвращает: строковое
  • Совместимость:IE начиная с 5.5

[править] selection

Свойство document.selection возвращает объект selection, содержимое которого отображается в окне браузера как выделение основного текста. Это выделение может осуществляется пользователем или с помощью сценария в объекте TextRange

  • Возвращает: объект
  • Совместимость:IE начиная с 4.0

[править] styleSheets

Массив styleSheets содержит ссылки на все элементы STYLE, присутствующие на текущей страничке.

  • Возвращает: массив
  • Совместимость:IE начиная с 4.0, NN начиная с 6.0

[править] title

Возвращает заголовок Web-страницы, заданный в теге <TITLE>

  • Возвращает: массив
  • Совместимость:IE начиная с 3.02, NN начиная с 2.0

[править] URL

Задает или возвращает интернет-адрес текущей Web-страницы.

  • Возвращает: массив
  • В NN доступно только для чтения.
  • Совместимость:IE начиная с 4.0, NN начиная с 2.0

[править] URLUnencoded

Свойство возвращает строку URL-адреса в виде кода. Это означает, что все не буквенно-цифровые символы (имеются ввиду только цифры и буквы латинского алфавита) будут перекодированны в их URL-представление. т.е.знак % и шестнадцатеричный код символа ( например пробел будет выглядеть как %20).

  • Возвращает: строковое
  • Совместимость: IE начиная с 5.5

[править] vlinkColor

Задает или возвращает цвет посещенных гиперссылок в документе. В IE работает правильно, только если цвет посещенных гиперссылок установлени атрибутом VLINK.

  • Значение по умолчанию №800080
  • Возвращает: строковое
  • Совместимость:IE начиная с 3.02, NN начиная с 2.0

[править] wigth

Ширина документа в пикселях.

  • Доступно только для чтения
  • Возвращает: строковое
  • Совместимость:NN начиная с 4.0
Получено с http://spravkaweb.local/index.php/javascript/reference/document/property
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 17:43, 22 декабря 2006.
  • К этой странице обращались 224 раза.
11.7240149975


Справочник по JavaScript : Совместное использование HTML и JavaScript : Объектная модель документа — Справочник Web-языков

Справочник по JavaScript : Совместное использование HTML и JavaScript : Объектная модель документа

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Правила написания скриптов
Главная | ::. | JavaScript | ::. | Совместное использование HTML и JavaScript | ::. | Объектная модель документа
 |  |  |  |  |  | Объект document

Надо отметить, что JavaScript поддерживает так называемые внешние классы и объекты, определенные другими программами. Web-страница, которую вы просматриваете в окне Web-обозревателя, может быть описана как набор объектов. Скажем, она включает большой объект "документ-в-целом" и более мелкие объекты: "абзац-1", "абзац-2", "абзац-1" и "рисунок". Вы можете обращаться к этим объектам из того же JavaScript.

Рисунок.ДвигайВперед;
Абзац-1.Ширина = 80%;
Абзац-3.Покажи;

Конечно, здесь сильно утрируется, но принцып таков.

Например, рассмотрим скрипт:

var d;
d=new Date();
document.write(d.toString());

Документ document - это наш "документ-в-целом". А write - его метод, вставляющий текст, переданный в качестве параметра, в текущее место HTML-документа.

Совокупность объектов, описывающая web-страницу, со всеми их методами и свойствами называется объектной моделью документа. А технология создания web-страницы, при которой обычный HTML-код объединяется с JavaScript-кодом, причем последний управляет страницей с помощью объектной модели, называется динамическим HTML (DHTML).

Получено с http://spravkaweb.local/index.php/javascript/reference/html_javascript/object
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 09:21, 7 января 2007.
  • К этой странице обращались 118 раз.
1.32459592819


Справочник по JavaScript : Совместное использование HTML и JavaScript : Правила написания скриптов — Справочник Web-языков

Справочник по JavaScript : Совместное использование HTML и JavaScript : Правила написания скриптов

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Совместное использование HTML и JavaScript | ::. | Правила написания скриптов
 |  |  |  |  |  | Объектная модель документа

Прежде всего надо рассмотреть тег <SCRIPT>. Этот тег служит для вставки скриптов в HTML-код страницы. Его формат:

<SCRIPT [language="{Язык программирования, на котором написан скрипт}"] [src="{Адрес файла со скриптом}"]>
. . . Текст скрипта
</SCRIPT>

Текст скрипта помещаетс внутрь тега <SCRIPT>

Атрибут language позволяет указать, на каком языке программирования написан скрипт.

Значение по умолчанию - "JavaScript".

Internet Explorer поддерживается скрипты, написанные на языке VBScript, которому соответствует значение атрибута "VBScript".

Navigator позволяет задавать версию интерпретатора JavaScript:

<SCRIPT language="JavaScript 1.2">

Это может пригодиться в случаях, когда вы используете возможность языка JavaScript, специфичную для какой-либо версии.

В следующей таблице приведены версии интерпретатора JavaScript и соответствие их разным версиям Navigator:

JavaScript | Navigator
1.0 | 2.0
1.1 | 3.0
1.2 | 4.0
1.3 | 4.06

Второй атрибут src служит для задания адреса файла, содержащего скрипт.

В этом случае обычно парный тег <SCRIPT> превращается в одинарный:

<SCRIPT src="menu.js">

js - стандартное расширение для JavaScript-файлов.

Но что случиться, если Web-обозреватель не поддерживает скрипты? (Например, это слишком старая версия программы, или пользователь отключил поддержку скриптов в настройках безопасности.) Web-обозреватель проигнорирует тег <SCRIPT> и выведет на экран текст скрипта.

Чтобы избежать этого, скрипт внутри тега <SCRIPT> рекомендуют заключать в комментарий.

<SCRIPT>
<--
. . . Текс скрипта
-->
</SCRIPT>

Однако некоторые версии Navigator в этом случае "не видят" скрипта, хотя, согласно техническим руководствам самой Netscape, должны. Так что этот совет применим только для Internet Explorer.

В качестве альтернативы вы можете использовать тег <NOSCRIPT>.

Этот тег поддерживается Internet Explorer и Navigator:

<NOSCRIPT>
. . . Текст, отображаемый, если Web-обозреватель не
поддерживает скрипты
</NOSCRIPT>

Тег <NOSCRIPT> может помещаться где угодно в тексте страницы, даже вне тега <BODY>. Текст, помещенный внутрь этого тега, будет отображаться вместо всей страницы. То есть, пользователь Web-обозревателя с отключенной поддержкой скриптов увидит в окне только этот текст и больше ничего.

Получено с http://spravkaweb.local/index.php/javascript/reference/html_javascript/rule
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 16:31, 19 декабря 2006.
  • К этой странице обращались 192 раза.
11.8339250088


Справочник по JavaScript : Объект layer : Доступ к слоям — Справочник Web-языков

Справочник по JavaScript : Объект layer : Доступ к слоям

 |  |  |  |  |  | Объект window ::. Работа с окнами
Главная | ::. | JavaScript | ::. | Объект layer | ::. | Доступ к слоям
 |  |  |  |  |  | Свойства

Все слои, определенные в документе, доступны как элементы коллекции layers.

document.layers[2];
document.layers["somelayer"];

NN поддерживает прямой доступ к слоям по имени. Имена слоям даются с помощью атрибута NAME тегов <LAYER> и <ILAYER>:

document.somelayer;

Для доступа к слою, находящемуся внутри другого слоя, используется такой способ:

document.layers["outerlayer"].layers["innerlayer"]
Получено с http://spravkaweb.local/index.php/javascript/reference/layer/access
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 05:59, 3 января 2007.
  • К этой странице обращались 104 раза.
10.1462368965


Справочник по JavaScript : Объект layer : Методы — Справочник Web-языков

Справочник по JavaScript : Объект layer : Методы

 |  |  |  |  |  | Свойства
Главная | ::. | JavaScript | ::. | Объект layer | ::. | Методы
 |  |  |  |  |  | Объект navigator

Содержание

  • 1 load
  • 2 moveAbove
  • 3 moveBelow
  • 4 moveBy
  • 5 moveTo
  • 6 moveToAbsolute
  • 7 resizeBy
  • 8 resizeTo

[править] load

load({Адрес файла нового документа}, {Новая ширина слоя в пикселах})

Позволяет заменить содержимое слоя. В качестве первого параметра принимается интернет-адрес документа, который будет отображен в текущем слое. В качестве второго параметра указывается новая ширина текущего слоя в пикселах.

[править] moveAbove

moveAbove({Имя слоя})

Перемещает текущий слой выше слоя, имя которого передано в качестве параметра.

[править] moveBelow

moveBelow({Имя слоя})

Перемещает текущий слой ниже слоя, имя которого передано в качестве параметра.

[править] moveBy

moveBy({X},{Y})

Перемещает слой на X пикселов вправо и на Y пикселов вниз. Для перемещения влево и вверх задайте отрицательные значения X и Y.

[править] moveTo

moveTo({X},{Y})

Перемещает слой в точку, заданную координатами X и Y. Координаты отсчитываются относительно родительского слоя (если такой есть).

[править] moveToAbsolute

moveToAbsolute({X},{Y})

Перемещает слой в точку, заданную координатами X и Y. Координаты отсчитываются относительно документа.

[править] resizeBy

resizeBy({X},{Y})

Увеличивает слой на X пикселов по горизонтали и на Y пикселов по вертикали. Для его уменьшения задайте отрицательные значения X и Y.

[править] resizeTo

resizeTo({X},{Y})

Увеличивает слой до размера, заданного значениями X и Y.

Получено с http://spravkaweb.local/index.php/javascript/reference/layer/method
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 06:10, 3 января 2007.
  • К этой странице обращались 70 раз.
1.65323495865


Справочник по JavaScript : Объект layer : Свойства — Справочник Web-языков

Справочник по JavaScript : Объект layer : Свойства

 |  |  |  |  |  | Доступ к слоям
Главная | ::. | JavaScript | ::. | Объект layer | ::. | Свойства
 |  |  |  |  |  | Методы

Содержание

  • 1 above
  • 2 background
  • 3 below
  • 4 bgcolor
  • 5 document
  • 6 left
  • 7 name
  • 8 pageX
  • 9 pageY
  • 10 parentLayer
  • 11 siblingAbove
  • 12 siblingBelow
  • 13 src
  • 14 top
  • 15 visibility
  • 16 window
  • 17 x
  • 18 y
  • 19 zIndex

[править] above

Возвращает ссылку на слой, находящийся над текущим (т.е. выше в z-последовательности). Если таких нет, возвращается null.

[править] background

Ссылка но объект Image, представляющий фоновый ресунок текущего слоя. Вы можете использовать свойство src этого объекта для задания или получения адреса файла рисунка. Этому свойству можно присвоить ссылку на другой объект Image. Если для текущего слоя не задан фоновый рисунок, возвращается null.

[править] below

Возвращает ссылку на слой, находящийся под текущим (т.е. ниже в z-последовательности). Если таких нет, возвращается null.

[править] bgcolor

Цвет фона слоя.

[править] document

Возвращает ссылку на объект document, представляющий содержимое слоя.

[править] left

Горизонтальная координата левого верхнего угла слоя в пикселах.

[править] name

Имя тега, заданного в атрибуте NAME.

[править] pageX

Горизонтальная координата слоя относительно остального документа в пикселах.

[править] pageY

Вертикальная координата слоя относительно остального документа в пикселах.

[править] parentLayer

Возвращает ссылку на родительский слой или объект window, если родительского слоя нет.

[править] siblingAbove

Возвращает ссылку на слой, находящийся над текущим (т.е. выше в z-последовательности) и имеющий того же родителя. Если таких нет, возвращает null.

[править] siblingBelow

Возвращает ссылку на слой, находящийся под текущим (т.е. виже в z-последовательности) и имеющий того же родителя. Если таких нет, возвращает null.

[править] src

Возвращает адрес файла документа, отображаемого в слое.

[править] top

Вертикальная координата левого верхнего угла слоя в пикселах.

[править] visibility

Видимость слоя: show показывает его, hide скрывает, а inherit наследует видимость от родителя (это поведение по умолчанию).

[править] window

Возвращает ссылку на объект window (или frame), где находится текущий слой.

[править] x

То же самое, что left.

[править] y

То же самое, что top.

[править] zIndex

Порядок перекрытия слоев. Слои с большим значением этого свойства перекрывают слои с меньшим значением. По умолчанию равно нулю.

Получено с http://spravkaweb.local/index.php/javascript/reference/layer/property
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 06:05, 3 января 2007.
  • К этой странице обращались 70 раз.
1.41092801094


Справочник по JavaScript : Объект style : Объект style в Internet Explorer — Справочник Web-языков

Справочник по JavaScript : Объект style : Объект style в Internet Explorer

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Работа с объектом style
Главная | ::. | JavaScript | ::. | Объект style | ::. | Объект style в Internet Explorer
 |  |  |  |  |  | Объект style в Navigator. JavaScript-стили

Как же получить доступ к объекту style? Internet Explorer предоставляет для этого три свойства: style, currentStyle и runtimeStyle.

Первое свойство позволяет получить доступ к стилю, встроенному в тег элемента с помощью атрибута STYLE:

<P id="par1" style="color: green">Любой текст</P>
someColor = par1.style.color;

Вышеприведенное выражение поместит в переменную someColor значение атрибута color встроенного стиля элемента, т.е. "green".

someFontSize = par1.style.fontSize;

Это выражение вернет null, даже если где-то в таблице стилей атрибут font-size для этого элемента определен. А все потому, что интересы свойства style не выходят за рамки встроенного ситиля.

Чтобы получить стиль элемента с учетом и встроенных стилей, и таблиц стилей, и атрибутов тега, используйте свойство currentStyle:

<FONT id="par1" style="color: green" size="7">Любой текст</FONT>
someColor = par1.currentStyle.color;
someBColor = par1.currentStyle.backgroundColor;
someFontSize = par1.currentStyle.fontSize;
someOther = par1.currentStyle.textDecoration;

Предположим, что где-то в таблице стилей определен для этого элемента атрибут background-color, равный "teal", а text-decoration не определен вообще. Эти выражения вернут следующие значения: первое - "green", второе - "teal", третье - "largest" (или "7"), а четвертое - "none"? т.е. значение по умолчанию для этого атрибута стиля.

Если вы измените какое-либо свойство объекта style, измениться то же свойство и у объекта currentStyle, и наоборот. Единственная деталь: если вы изменили какое-либо свойство currentStyle и потом сразу же обратились к нему, вернется старое значение. То есть, между присвоением значения и его применением к элементу должно пройти некоторое время.

Свойство runtimeStyle довольно странное. Оно возвращает ссылку на объект runtimeStyle, который является примерно тем же самым, что и currentStyle, но присвоение его свойствам новых значений не затригивает аналогичных свойств style. То есть, вы можете переопределить свойства стиля runtimeStyle, и соответствующие свойства style (но не currentStyle) не изменятся.

[править] Объект styleSheet и коллекция styleSheets

Объект document в IE имеет встроенную коллекцию styleSheets, которую можно использовать для доступа к отдельным таблицам стилей документа. А отдельная таблица стилей представляется объектом styleSheet:

address = document.styleSheets(1).href;

Для нас будут полезны три свойства объекта таблицы стилей.

Первое из них - это href, представляющее интернет-адресс файла внешней таблицы стилей. Вы можете изменить этот адрес, чтобы загрузить другую таблицу стилей.

Второе - disabled, разрешающее или запрещающее Web-обозревателю применять эту таблицу для форматирования документа. Заметьте, что в данном случае false разрашает применение таблицы, а true запрещает.

И последнее свойство - type - имеет для нас только теоретический интерес: оно задает тип таблицы стилей, который для IE всегда равен "text/css".

Получено с http://spravkaweb.local/index.php/javascript/reference/style/ie
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:38, 2 января 2007.
  • К этой странице обращались 83 раза.
1.2373149395


Справочник по JavaScript : Объект style : Объект style в Navigator. JavaScript-стили — Справочник Web-языков

Справочник по JavaScript : Объект style : Объект style в Navigator. JavaScript-стили

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Объект style в Internet Explorer
Главная | ::. | JavaScript | ::. | Объект style | ::. | Объект style в Navigator. JavaScript-стили
 |  |  |  |  |  | Объект window

Navigator поддерживает прямое обращение по идентификаторам только для объектов layer и не поддерживает коллекцию all. Да и поддержка атрибута ID в нем реализована так себе, в основном, для присвоения элементам стилей. Но объект document Navigator предусматривает четыре очень мощьных свойства для работы со стилями.

Свойство classes позволит вым получить доступ к отдельному поименованному стилю:

document.classes.{Имя стиля}.{Имя тега}|all.{Имя свойства}

Здесь {Имя тега} может быть именем любого тега. Если нужно определить стиль для всех тегов, используйте слово all.

Например, предположим, что вы определили в таблице стилей некий стиль:

.somestyle {color: green}

Тогда в коде скрипта вы можете получить к нему доступ:

document.classes.somestyle.all.fontFamily = "Arial";

Аналогично вы можете определить какой-либо стиль для одного определенного тега:

P.somestyle {color: green}
document.classes.somestyle.P.fontFamily = "Arial";

В свою очередь свойство ids позволит вам получить доступ к стилю, присвоенному отдельному идентификатору ID:

document.ids.{Идентификатор}.{Имя свойства}

Например:

#someid {color: green}
document.ids.someid.fontFamily = "Arial";

Но что делать, если вы переопределили стиль какого-либо тега? В этом случае воспользуйтесь свойством tags:

document.tags.{тег}.{Имя свойства}

Например:

H1 {color: green}
document.tags.H1.fontFamily = "Courier";

А если вам нужно, скажем, изменить стиль элемента <B>, находящегося внутри заголовка второго уровня? Для этого существует свойство contextual:

document.contextual({Контекст 1}[, {Контекст 2}[, ...]]).{Имя свойства}

Тогда для описанного нами случая:

document.contextual(document.tags.H2, document.tags.B).fontStyle=
    "oblique";

что аналогично заданию в таблице стилей

H2 B {font-style: oblique}

Но если вы думаете, что можете динамически изменять внешний вид элементов страницы в Navigator путем изменения их стилей, вы жестоко ошибаетесь. Реально объект style нужен Navigator только для поддержки нового вида таблиц стилей, так называемых JavaScript-стилей.

JavaScript-стили отличаются от обычных тем, что больше всего похожи на скрипты. Собственно, это и есть скрипты. Давайте рассмотрим два примера: обычной таблицы стилей и таблице JavaScript-стилей:

<STYLE type="text/css">
P {color: blue}
.bigtext {font-size: 72pt; font-weight: boldest}
H1 B {text-decoration: underline}
</STYLE>

Это обычная таблица стилей. Теперь преобразуем ее в таблицу JavaScript-стилей:

<STYLE type="text/javascript">
document.tags.P.color = "blue";
width (document.classes.bigtext.all) {
  fontSize = "72pt";
  fontWeight = "boldest"; }
document.contextual(document.tags.H1, document.tags.B).textDecoration =
    "underline";
</STYLE>

Теперь вы видете, как таблица JavaScript-стилей похожа на скрипт. Заметьте также, что в этом случае атрибут type обязателен, т.к. он указвывает тип таблицы стилей.

Во всех предыдущих примерах для Navigator мы всегда приводили ссылку на объект document. Но в таблицах JavaScript-стилей ее можно опустить.

<STYLE type="text/javascript">
tags.P.color = "blue";
width (classes.bigtext.all) {
  fontSize = "72pt";
  fontWeight = "boldest"; }
contextual(tags.H1, tags.B).textDecoration = "underline";
</STYLE>
Получено с http://spravkaweb.local/index.php/javascript/reference/style/nn
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 15:08, 2 января 2007.
  • К этой странице обращались 93 раза.
1.30242490768


Справочник по JavaScript : Объект style : Свойства и методы объекта style — Справочник Web-языков

Справочник по JavaScript : Объект style : Свойства и методы объекта style

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Объект location
Главная | ::. | JavaScript | ::. | Объект style | ::. | Свойства и методы объекта style
 |  |  |  |  |  | Работа с объектом style

Как и все остальные объекты, style поддерживает ряд свойств и методов. Их можно разделить на две группы:

  • задающие стиль документа

и

  • относящиеся к самому объекту style.

Свойства первой группы в целом аналогичны соответствующим атрибутам стиля и имеют почти такие же имена за тем исключением, что символы "-" убираются, т.к. не соответстуют соглашению об именах JavaScript, а первые буквы всех слов, образующих имя атрибута, кроме первого, делаются прописными. В следующей таблице показаны примеры преобразования имен атрибутов стиля в имена свойств объекта style, устанавливающих стиль элемента.

Атрибут стиля | Свойство объекта
background-attachment | backgroundAttachment
borderBottomColor
font-family | fontFamily
z-index | zIndex

По аналогии вы можете преобразовать все атрибуты стилей в свойства объекта style. Все не относящееся к стилю свойства объекта style перечислены в нижерасположенной таблице. Кроме того, у этого объекта имеются методы getAttribute, removeAttribute и setAttribute. Но эти дополнительные свойства и методы поддерживаются только IE начиная с 4.0

Свойство | Описание
cssText | текстовое представление стиля (параметр атибута STYLE).
pixelHeight | Высота элемента в пикселах.
pixelLeft | Смещение левого края элемента в пикселах.
pixelTop | Смещение верхнего края элемента в пикселах.
pixelWidth | Ширина элемента в пикселах.
posHeight | Высота элемента в тех единицах измерения, в которых она была установлена в определении стиля.
posLeft | Смещение левого края элемента в тех единицах измерения, в которых она была установлена в определении стиля.
posTop | Смещение верхнего края элемента в тех единицах измерения, в которых она была установлена в определении стиля.
posWidth | Ширина элемента в тех единицах измерения, в которых она была установлена в определении стиля.
Получено с http://spravkaweb.local/index.php/javascript/reference/style/property_and_method
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 09:32, 2 января 2007.
  • К этой странице обращались 139 раз.
9.54082894325


Справочник по JavaScript : Объект style : Работа с объектом style — Справочник Web-языков

Справочник по JavaScript : Объект style : Работа с объектом style

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Свойства и методы объекта style
Главная | ::. | JavaScript | ::. | Объект style | ::. | Работа с объектом style
 |  |  |  |  |  | Объект style в Internet Explorer

Объект style позволяет изменить стиль любого элемента Web-страницы, просто присвоив нужному свойству необходимое значение.

paragraph1.style.fontSize = 7;

Можно изменить геометрические размеры элемента:

image1.style.height = "100mm";
image1.style.width = "120mm";

и его месторасположение:

iamge1.style.top = "200px";
image1.style.left = "50px";

Заметьте, что мы присваиваем свойству строковые значения геометрических параметров с указанием единицы измерения. Это не очень удобно для вычислений, поэтому объект style предоставляет свойства pixel, принимающие и возвращающие числовые значения в пикселах:

image1.style.pixelHeight = 400;
iamge1.style.pixelLeft +=5;

Также можно использовать свойства pos, возвращающие и принимающие числовые значения в тех единицах измерения, в которых эти значения были заданы в определении стиля.

<IMG src="image1.gif" id="image1" style="height: 100mm; width: 100">
nheight = image1.style.posHeight; // Значение в миллиметрах
nwidth = image1.style.posWidth;   // Значение в пикселах

Вы можете использовать методы getAttribute, setAttribute и removeAttribute для получения и установки значения и удаления какого-либо свойства стиля:

paragraph1.style.setAttribute("borderBottomWidth", 5, false);
paragraph1.style.removeAttribute("borderTopWidth", false);
Получено с http://spravkaweb.local/index.php/javascript/reference/style/work
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 10:32, 2 января 2007.
  • К этой странице обращались 95 раз.
1.32750701904


Справочник по JavaScript : Объект window : Методы — Справочник Web-языков

Справочник по JavaScript : Объект window : Методы

 |  |  |  |  |  | Свойства
Главная | ::. | JavaScript | ::. | Объект window | ::. | Методы
 |  |  |  |  |  | Свойства окна, передаваемые методу open

Содержание

  • 1 alert()
  • 2 back()
  • 3 blur()
  • 4 clearInterval()
  • 5 clearTimeout()
  • 6 close()
  • 7 confirm()
  • 8 execScript()
  • 9 find()
  • 10 focus()
  • 11 forward()
  • 12 home()
  • 13 moveBy()
  • 14 moveTo()
  • 15 navigate()
  • 16 open()
  • 17 print()
  • 18 prompt()
  • 19 resizeBy()
  • 20 resizeTo()
  • 21 scroll()
  • 22 scrollBy()
  • 23 scrollTo()
  • 24 setHotKeys()
  • 25 setInterval()
  • 26 setResizeeable()
  • 27 setTimeout()
  • 28 stop()

[править] alert()

alert({Текст})

Выводит на экран окно предупреждения с текстом, переданным в качестве параметра.

[править] back()

Возвращается к предыдущему документу, как если бы на панели инструментов нажали кнопку Назад.

Поддерживается только NN начиная с 4.0

[править] blur()

Удаляет фокус с окна.

[править] clearInterval()

clearInterval({Таймер})

Останавливает таймер, установленный методом setInterval.

[править] clearTimeout()

clearTimeout({Таймер})

Останавливает таймер, установленный методом setTimeout.

[править] close()

Закрывает текущее окно. Если окно было открыто методом open(), то оно закрывается сразу же, если же оно было открыто пользователем, сначало появляется окно предупреждения, предлагающее пользователю сделать выбор.

[править] confirm()

confirm({Текст})

Выводит на экран окно предупреждения с текстом, переданным в качестве параметра, предлагающее пользователю сделать выбор. Если пользователь нажмет Ок, возвращается true, если Отмена - false.

[править] execScript()

execScript({Выражение},{Язык})

Вычисляет переданное в качестве первого параметра выражение. Второй аргумент должен иметь значение "JavaScript".

Поддерживается только IE начиная с 4.0

[править] find()

find([{Строка поиска}[, true|false, true|false]])

Выводит на экран диалоговое окно задания параметров поиска.

Первым аргументом передается строка поиска.

Второй задает, будет ли поиск производиться с учетом регистра символов (true) или нет (false, значение по умолчанию).

Третий - будет ли поиск производиться с конца документа к началу (true) или обычным порядком (false, значение по умолчанию).

Возвращает true, если поиск был успешным.

Поддерживается тольк NN начиная с 4.0

[править] focus()

Переносит фокус на текущее окно.

[править] forward()

Переходит к следующему документу в списке истории, как если бы на панели инструментов нажали кнопку Вперед.

Поддерживается только NN начиная с 4.0

[править] home()

Переходит на "домашнюю" страницу, заданную в настройках Web-обозревателя, как если бы на панели инструментов нажали кнопку Домой.

Поддерживается только NN начиная с 4.0

[править] moveBy()

moveBy({X},{Y})

Перемещает окно на X пикселов вправо и на Y пикселов вниз. Для перемещения влево и вверх задайте отрицательные значения X и Y.

[править] moveTo()

moveTo({X},{Y})

Перемещает окно в точку экрана, заданную координатами X и Y.

[править] navigate()

navigate({Адрес})

Загружает в окно Web-страницу, адрес которой передан в качестве параметра.

Поддерживается только IE.

[править] open()

open({Адрес}, {Имя окна}, [{Список свойств окна, разделенных запятыми}])

Открывает новое окно Web-обозревателя, загружает в него документ, адрес которого передан в первом параметре, и присваивает окну имя, переданное во втором параметре.

В третьем параметре может быть передан список свойств окна.

[править] print()

Печатает содержимое окна на принтере.

[править] prompt()

prompt({Приглашение}, [{Значение по умолчанию}])

Выводит на экран диалоговое окно с полем ввода, приглашающее пользователя ввести какое-либо строковое значени. Текст приглашения передается в качестве первого параметра; во втором параметре может быть передано значение по умолчанию.

[править] resizeBy()

resizeBy({X},{Y})

Увеличивает окно на X пикселов по горизонтали и на Y пикселов по вертикали. Для уменьшения окна задайте отрицательные значения X и Y.

[править] resizeTo()

resizeTo({X},{Y})

Увеличивает или уменьшает окно до размера, заданного значениями X и Y.

[править] scroll()

scroll({X},{Y})

Прокручивает содержимое окна до точки с координатами X и Y. Не рекомендуется к использованию и сохранен только для совместимости.

[править] scrollBy()

scrollBy({X},{Y})

Прокручивает содержимое окна на X пикселов вправо и на Y пикселов вниз. Для прокрутки влево и вверх задайте отрицательные значения X и Y.

[править] scrollTo()

scrollTo({X},{Y})

Прокручивает содержимое окно в точку, заданную значениями X и Y.

[править] setHotKeys()

setHotKeys(true|false)

Разрешает (true) или запрещает (false) "горячие" клавиши в окне, не имеющем строки меню.

Поддерживается только NN начиная с 4.0

[править] setInterval()

setInterval({Функции или выражение},{Интервал}, [{Список аргументов функции, разделенных запятыми}])

Вычисляет значение выражения или вызывает функцию каждый раз по истечении заданного интервала (в миллисекундах). Может передавать в функцию заданные в списке аргументы.

Возвращает указатель на объект таймера, который можно использовать в методе clearInterval для остановки и уничтожения таймера.

[править] setResizeeable()

setResizeeable(true|false)

Разрашает (true) или запрещает (false) пользователю изменять размеры окна.

Поддерживается только NN начиная с 4.0

[править] setTimeout()

setTimeout({Функции или выражение},{Интервал}, [{Список аргументов функции, разделенных запятыми}])

Вычисляет значение выражения или вызывает функцию по истечении заданного интервала (в миллисекундах), если до этого небыл вызван метод clearTimeout. Может передавать в функцию заданные в списке аргументы. Возварщает указатель на объект таймера, который можно использовать в методе clearTimeout для остановки и уничтожения таймера.

[править] stop()

Останавливает загрузку текущей страницы.

Поддерживается только NN начиная с 4.0

Получено с http://spravkaweb.local/index.php/javascript/reference/window/method
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 15:40, 2 января 2007.
  • К этой странице обращались 96 раз.
1.25069880486


Справочник по JavaScript : Объект window : Свойства окна, передаваемые методу open — Справочник Web-языков

Справочник по JavaScript : Объект window : Свойства окна, передаваемые методу open

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Методы
Главная | ::. | JavaScript | ::. | Объект window | ::. | Свойства окна, передаваемые методу open
 |  |  |  |  |  | Работа с окнами

Содержание

  • 1 alwaysLowered
  • 2 alwaysRaised
  • 3 channelmode
  • 4 dependent
  • 5 directories
  • 6 fullscreen
  • 7 height
  • 8 hotkeys
  • 9 innerHeight
  • 10 innerWidth
  • 11 left
  • 12 location
  • 13 menubar
  • 14 outerHeight
  • 15 outerWidth
  • 16 replace
  • 17 resizable
  • 18 screenX
  • 19 screenY
  • 20 scrollbars
  • 21 status
  • 22 titlebar
  • 23 toolbar
  • 24 top
  • 25 width
  • 26 z-lock

[править] alwaysLowered

alwaysLowered=yes|no

Если yes, то создаваемое окно будет всегда находиться под другими окнами, даже если оно имеет фокус.

Поддерживается только NN начиная с 4.06

[править] alwaysRaised

alwaysRaised=yes|no

Если yes, то создаваемое окно будет всегда находиться над другими окнами, даже если оно не имеет фокуса.

Поддерживается только NN начиная с 4.06

[править] channelmode

channelmode=yes|no

Если yes, то создаваемое окно будет отображаться с панелью каналов (так называемый "режим театра").

Поддерживается только IE начиная с 4.0

[править] dependent

dependent=yes|no

Если yes, то создаваемое окно будет дочерним по отношению к создавшему, т.е. при закрытии создающего окна будет закрываться и создаваемое.

Поддерживается только NN начиная с 4.06

[править] directories

directories=yes|no

Включает или отключает отображение кнопок директорий Navigator, у создаваемого окна.

[править] fullscreen

fullscreen=yes|no

Если yes, то создаваемое окно займет весь экран (так называемый "режим киоска").

Поддерживается только IE начиная с 4.0

[править] height

height={Высота}

Задает высоту создаваемого окна в пикселах.

[править] hotkeys

hotkeys=yes|no

Если no, то большинство "горячих" клавиш будут запрещены в создаваемом окне.

Поддерживается тольк NN начиная с 4.06

[править] innerHeight

innerHeight={Высота}

Задает высоту клиентской области создаваемого окна в пикселах.

Поддерживается только NN начиная с 4.06

Рекомендуется использовать вместо height

[править] innerWidth

innerWidth={Ширина}

Задает ширину клиентской области создаваемого окна в пикселах.

Поддерживается только NN начиная с 4.06

Рекомендуется использовать вместо width

[править] left

left={X}

Задает горизонтальную координату левого верхнего угла создаваемого окна.

Поддерживается только IE начиная с 4.0

[править] location

location=yes|no

Включает или отключает отображение панели адреса, включающего строку ввода адреса, у создаваемого окна.

[править] menubar

menubar=yes|no

Включает или отключает отображение строки меню у создаваемого окна.

[править] outerHeight

outerHeight={Высота}

Задает полную (с рамками, строкой меню, полосами инструментов) высоту создаваемого окна в пикселах.

Поддерживается только NN начиная с 4.06

Рекомендуется к использованию вместо height.

[править] outerWidth

outerWidth={Ширина}

Задает полную (с рамками, строкой меню, полосами инструментов) ширину создаваемого окна в пикселах.

Поддерживается только NN начиная с 4.06

Рекомендуется к использованию вместо width.

[править] replace

replace=yes|no

Если yes, то адрес документа, размещаемого в создаваемом окне, заменит в списке истории адрес документа, находящегося в создающем окне.

Поддерживается тольк IE начиная с 4.0

[править] resizable

resizable=yes|no

Включает или отключает возможность изменения размера создаваемого окна.

[править] screenX

screenX={X}

То же, что и left для IE.

Поддерживается только NN начиная с 4.06

[править] screenY

screenY={Y}

То же, что и top для IE.

Поддерживается только NN начиная с 4.06

[править] scrollbars

scrollbars=yes|no

Включает или отключает отображение полос прокрутки у создаваемого окна.

[править] status

status=yes|no

Включает или отключает отображение строки состояния у создаваемого окна.

[править] titlebar

titlebar=yes|no

Включает или отключает отображение заголовка у создаваемого окна.

Поддерживается только IE начиная с 4.0

[править] toolbar

toolbar=yes|no

Включает или отключает отображение панели инструментов у создаваемого окна.

[править] top

top={Y}

Задает вертикальную координату левого верхнего угла создаваемого окна.

Поддерживается только IE начиная с 4.0

[править] width

width={Ширина}

Задает ширину создаваемого окна в пикселах.

[править] z-lock

z-lock=yes|no

Если yes, то создаваемое окно никогда не будет перемещаться выше других окон, даже если получает фокус.

Поддерживается только NN начиная с 4.06

Вместо значений yes и no вы можете использовать 1 и 0, либо если вообще указывается параметр - соответствует yes, если параметр не указан - no.

Некоторые версии Web-обозревателей для определенных параметров принимают только значения 1 и 0.

Получено с http://spravkaweb.local/index.php/javascript/reference/window/open
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 05:34, 3 января 2007.
  • К этой странице обращались 85 раз.
1.35983896255


Справочник по JavaScript : Объект window : Свойства — Справочник Web-языков

Справочник по JavaScript : Объект window : Свойства

 |  |  |  |  |  | Объект style : Объект style в Navigator. JavaScript-стили
Главная | ::. | JavaScript | ::. | Объект window | ::. | Свойства
 |  |  |  |  |  | Методы

Объект window представляет текущее окно Web-обозревателя или отдельный фрейм, если окно разделено на фреймы.

Содержание

  • 1 closed
  • 2 defaultStatus
  • 3 document
  • 4 frames
  • 5 history
  • 6 innerHeight
  • 7 innerWidth
  • 8 length
  • 9 location
  • 10 locationbar
  • 11 menubar
  • 12 name
  • 13 navigator
  • 14 opener
  • 15 outerHeight
  • 16 outerWidth
  • 17 pageXOffset
  • 18 pageYOffset
  • 19 parent
  • 20 personalbar
  • 21 screen
  • 22 screenLeft
  • 23 screenTop
  • 24 screenX
  • 25 screenY
  • 26 scrollbars
  • 27 self
  • 28 status
  • 29 statusbar
  • 30 toolbar
  • 31 top
  • 32 window

[править] closed

Возвращает true, если текущее окно закрыто. Может быть использовано при работе с несколькими окнами.

[править] defaultStatus

Сообщение по умолчанию, отображаемое в строке состояния окна.

[править] document

Возвращает ссылку на документ, загруженный в текущее окно.

[править] frames

Возвращает ссылку на коллекцию фреймов.

[править] history

Возвращает ссылку на объект истории Web-обозревателя.

[править] innerHeight

Возвращает высоту клиентской области окна (без рамок, меню, панелей инструментов) в пикселах.

Поддерживается только NN начиная с 4.0

[править] innerWidth

Возвращает ширину клиентской области окна (без рамок, меню, панелей инструментов) в пикселах.

Поддерживается только NN начиная с 4.0

[править] length

Возвращает количество фреймов.

[править] location

Возвращает ссылку на объект location документа, загруженного в текущее окно.

[править] locationbar

Возвращает ссылку на объект панели адреса окна Navigator (она же Location Toolbar). Единственное свойство этого объекта visible позволит показать ее или убрать; значение true этого свойства показывает панель адреса, false убирает.

Поддерживается только NN начиная с 4.0

[править] menubar

Возвращает ссылку на объект панели адреса окна Navigator. Единственное свойство этого объекта visible позволит показать ее или убрать; значение true этого свойства показывает панель адреса, false убирает.

Поддерживается только NN начиная с 4.0

[править] name

Возвращает имя окна или фрейма.

[править] navigator

Возвращает ссылку на объект Web-обозревателя.

[править] opener

Возвращает ссылку на окно, которое открыло текущее окно, например, методом open.

[править] outerHeight

Возвращает полную высоту окна (с рамками, меню, панелями инструментов) в пикселах.

Поддерживается только NN начиная с 4.0

[править] outerWidth

Возвращает полную ширину окна (с рамками, меню, панелями инструментов) в пикселах.

Поддерживается только NN начиная с 4.0

[править] pageXOffset

Возвращает расстояние по горизонтали между текущей позицией окна и левой границей документа. При прокручивании содержимого окна право значение этого свойства увеличивается, влево - уменьшается.

Поддерживается только NN начиная с 4.0

[править] pageYOffset

Возвращает расстояние по вертикали между текущей позицией окна и левой границей документа. При прокручивании содержимого окна вниз значение этого свойства увеличивается, вверх - уменьшается.

Поддерживается только NN начиная с 4.0

[править] parent

Возвращает ссылку на родительское окно, если текущий объект window представляет собой фреймы. В противном случае возвращается ссылка на само это окно.

[править] personalbar

Возвращает ссылку на объект панели Personal Bar окна Navigator. ЕдИнственное свойство этого объекта visible позволяет показать ее или убрать; значение true этого объекта показывает панель адреса, false убирает.

Поддерживается только Navigator начиная с 4.0

[править] screen

Возвращает ссылку на объект screen.

[править] screenLeft

Возвращает горизонтальную координату левого верхнего угла окна.

Поддерживается только IE начиная с 5.0

[править] screenTop

Возвращает вертикальную координату левого верхнего угла окна.

Поддерживается только IE начиная с 5.0

[править] screenX

Горизонатльная координата левого верхнего угла окна.

Поддерживается только NN начиная с 4.0

[править] screenY

Вертикальная координата левого верхнего угла окна.

Поддерживается только NN начиная с 4.0

[править] scrollbars

Возвращает ссылку на объект полос прокрутки окна NN. Единственное свойство этого объекта visible позволит показать полосу или убрать; значение true этого свойства показывает полосу прокрутки, false убирает.

Поддерживается только NN начиная с 4.0

[править] self

Возвращает ссылку на объект window текущего окна.

[править] status

Текст, отображаемый в строке состояния окна Web-обозревателя.

[править] statusbar

Возвращает ссылку на объект строки состояния окна NN. Единственное свойство этого объекта visible позволит показать ее или убрать; значение true этого свойства показывает строку состояния, false убирает.

Поддерживается только NN начиная с 4.0

[править] toolbar

Возвращает ссылку на объект панели инструментов окна NN. Единственное свойство этого объекта visible позволит показать полосу или убрать; значение true этого свойства показывает панель инструментов, false убирает.

Поддерживается только NN начиная с 4.0

[править] top

Возвращает ссылку на родительское окно самого верхнего уровня, если текущий объект window представляет собой фрейм. В противном случае возвращается ссылка на само это окно.

[править] window

То же, что и self.

Получено с http://spravkaweb.local/index.php/javascript/reference/window/property
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 15:19, 2 января 2007.
  • К этой странице обращались 178 раз.
9.66142010689


Справочник по JavaScript : Объект window : Работа с окнами — Справочник Web-языков

Справочник по JavaScript : Объект window : Работа с окнами

 |  |  |  |  |  | Свойства окна, передаваемые методу open
Главная | ::. | JavaScript | ::. | Объект window | ::. | Работа с окнами
 |  |  |  |  |  | Объект layer ::. Доступ к слоям

Давайте поподробнее остановимся на некоторых моментах использования свойств и методов окон.

Прежде всего, требуется дополнительное рассмотрение метода open. Он позволяет Web-дизайнеру открыть на экране дополнительное окно Web-обозревателя и поместить в него какую-либо страницу - очень полезное средство для разработки сложных многостраничных сайтов.

var contentsWindow;
contentsWindow = window.open("http://www.spravkaweb.ru/contents.htm","contents");

В этом примере мы создали новое окно, загрузили в него некую Web-страницу и присвоили ей имя contents. Метод open вернул ссылку на объект вновь созданного окна, которую мы можем впоследствии использовать для работы с этим окном:

contentsWindow.Left = 300;

Имя окна можно использовать в атрибуте TARGET тега <A>:

<A href="http://www.spravkaweb.ru/contents2.htm"
target="contents">Содержание</A>

Можно использовать дополнительные свойства окна, чтобы тонко управлять его характеристиками. Например, мы очень легко можем убрать у вновь создаваемого окна полосу инструментов и строку состояния:

contentsWindow = window.open("http://www.spravkaweb.ru/contents.htm",
"contents", "toolbar=no", "status=no");

Мы можем задать начальные координаты и размеры создаваемого окна:

contentsWindow = window.open("http://www.spravkaweb.ru/contents.htm",
"contents", "top=100", "left=200", "width=400", height="200");

А эта строка будет работать только в NN версии 4.06 или более поздней:

contentsWindow = window.open("http://www.spravkaweb.ru/contents.htm",
"contents", "screenY=100", "screenX=200", "outerWidth=400",
outerHeight="200");

Когда создание окна перестанет быть нужным, его можно закрыть при помощи метода close. Свойство closed позволит в дальнейшем проверить, закрыто ли это окно (например, если его закроет пользователь):

contentsWindow.close;
if(contentsWindow.closed) . . .

Свойство status позволяет поместить в строку состояния какой-либо текст, отличный от текста по умолчанию:

window.status = "Справочник WEB - языков";

А свойство defaultStatus позволит также просто вернуть туда текст по умолчанию:

window.status = window.defaultStatus;

Вы также можете вести примитивный диалог с пользователем, используя три специально предусмотренных метода. Метод alert выводит на экран окно предупреждения с заданным текстом и кнопкой Ок:

window.alert("Привет!!!");

Метод confirm отображает окно сообщения с текстом и кнопками Ок и Отмена. Если пользователь нажал Ок, возвращается true, иначе - false.

if(window.confirm("Выберите что-нибудь.")) alert("Вы нажали Ок");
else alert("Вы нажали Отмена");

Метод prompt позволяет запросить у пользователя какие-либо данные. Он выводит диалоговое окно с полем ввода и кнопками Ок и Отмена. В качестве параметров принимается текст приглашения и необязательный текст по умолчанию, отображаемый в поле ввода:

string=window.prompt("Пример использования метода prompt:", "Введите что-нибудь");
alert(string);
Получено с http://spravkaweb.local/index.php/javascript/reference/window/windows
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 05:42, 3 января 2007.
  • К этой странице обращались 83 раза.
1.32067990303


Советы по JavaScript : Передача и обработка данных в html-файле — Справочник Web-языков

Советы по JavaScript : Передача и обработка данных в html-файле

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | JavaScript | ::. | Советы по JavaScript | ::. | Передача и обработка данных в html-файле
 |  |  |  |  |  | Чем заменить SSI, или необычное использование JavaScript

[править] Передача данных в html-файл:

Передачу данных в html-файл можно произвести через URL-адрес. После адреса ставиться знак вопроса и после него параметр, который Вы хотите передать. Если этих параметров несколько, то между ними ставиться амперсанд (&).

Пример 1:

"youfile.html?parametr"

Пример 2:

"youfile.html?parametr1&parametr2&parametr3"

Также данные можно передавать при помощи форм. Для этого надо воспользоваться методом GET.

Вот как буде выглядеть URL-адрес в строке броузера:

Пример:

"youfile.html?name1=value1&name2=value2&name3=value3"

[править] Получение переданных данных:

Получение переданных данных выполняется при помощи JavaScript.

Сначало мы присваиваем переменной все то, что находится после знака вопроса:

var p_url=location.search.substring(1);

Если Вы передавали один параметр, то переменную p_url можно обрабатывать.

Если параметров было много, то их надо разделить:

var parametr=p_url.split("&");

У нас получился массив parametr, который содержит полученные данные.

Если Вы пересылали данные при помощи форм, то надо избавиться от знака равенства и присвоить каждой переменной свое значение:

var values= new Array();
for(i=0; i
    var j=parametr.split("=");
    values[j[0]]=unescape(j[1]);
}

Пример:

Если строка была:

"youfile.html?name=Serg&city=Рязань&age=21"

то получим массив:

values[name]="Serg";
values[city]="Рязань";
values[age]="21";

или можно так:

values[0]="Serg";
values[1]="Рязань";
values[2]="21";
Получено с http://spravkaweb.local/index.php/javascript/sovet/get
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 10:34, 3 марта 2007.
  • К этой странице обращались 105 раз.
1.28668093681


Советы по JavaScript : Как добавить страницу в избранное — Справочник Web-языков

Советы по JavaScript : Как добавить страницу в избранное

 |  |  |  |  |  | Как сделать страницу стартовой
Главная | ::. | JavaScript | ::. | Советы по JavaScript | ::. | Как добавить страницу в избранное
 |  |  |  |  |  | Как вывести дату последнего изменения страницы

Добавляет вашу страницу в "Избранное".

Эта возможность позволяет посетителю вашей страницы сделать закладку, если он не успевает просмотреть или просто запомнить адрес вашего ресурса.

<a href="#" onClick="window.external.addFavorite
("http://www.spravkaweb.ru/", "Краткий справочник WEB-языков"); return false;">
Добавить сайт в избранное</a>
Получено с http://spravkaweb.local/index.php/javascript/sovet/izbr
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 16:54, 4 марта 2007.
  • К этой странице обращались 107 раз.
1.39633989334


Советы по JavaScript : Как вывести дату последнего изменения страницы — Справочник Web-языков

Советы по JavaScript : Как вывести дату последнего изменения страницы

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Как добавить страницу в избранное
Главная | ::. | JavaScript | ::. | Советы по JavaScript | ::. | Как вывести дату последнего изменения страницы
 |  |  |  |  |  | Как убрать в теге SELECT рамку и стрелку

Эта возможность позволяет автоматически указывать дату последней модификации данной страницы.

Но данная возможность таит и свой минус: требуется почаще обновлять страницу, а иначе пользователь будет думать, что срок годности вашего ресурса уже давно истек.

<script language="JavaScript">
<!--
document.write ("Дата последнего изменения: "
+ document.lastModified);
//-->
</script>
Получено с http://spravkaweb.local/index.php/javascript/sovet/lasttimepage
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 16:54, 4 марта 2007.
  • К этой странице обращались 72 раза.
1.25441884995


Советы по JavaScript : Как убрать в теге SELECT рамку и стрелку — Справочник Web-языков

Советы по JavaScript : Как убрать в теге SELECT рамку и стрелку

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Как вывести дату последнего изменения страницы
Главная | ::. | JavaScript | ::. | Советы по JavaScript | ::. | Как убрать в теге SELECT рамку и стрелку
 |  |  |  |  |  | Интересный JavaScript - побуквенное появление текста

При помощи каскадных таблиц стилей (CSS) можно изменить стандартный вид объекта <SELECT>:

<SELECT size=1 style="position:absolute;width:100px;
clip:rect(2px 82px 20px 2px);background:pink;top:10px;">
<OPTION VALUE=1>One
<OPTION VALUE=2>Two
<OPTION VALUE=3>Three
</SELECT>
Получено с http://spravkaweb.local/index.php/javascript/sovet/selectborder
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 16:50, 4 марта 2007.
  • К этой странице обращались 94 раза.
1.31445598602


Советы по JavaScript : Интересный JavaScript - побуквенное появление текста — Справочник Web-языков

Советы по JavaScript : Интересный JavaScript - побуквенное появление текста

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Как убрать в теге SELECT рамку и стрелку
Главная | ::. | JavaScript | ::. | Советы по JavaScript | ::. | Интересный JavaScript - побуквенное появление текста

Данный эффект позволяет выводить текст побуквенно. Есть возможность задавать количество выводимых за один раз символов и скорость вывода.

Вот код:

<script>
var source,dest,len,now=0,delay=100,letters=1;
function show_text()
{
    source = document.getElementById("pageTextSource");
    dest = document.getElementById("pageText");
    len = source.innerHTML.length;
    show();
}

function show()
{
    dest.innerHTML += source.innerHTML.substr(now,letters);
    now+=letters;

    if(now<len)
        setTimeout("show()",delay);
    }
</script>
<body onload="show_text();">
<p style="display:none" id="pageTextSource">

Текст для вывода...

<p id="pageText">
</p>
</body>
Получено с http://spravkaweb.local/index.php/javascript/sovet/showtext
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 16:51, 4 марта 2007.
  • К этой странице обращались 106 раз.
1.36427092552


Советы по JavaScript : Чем заменить SSI, или необычное использование JavaScript — Справочник Web-языков

Советы по JavaScript : Чем заменить SSI, или необычное использование JavaScript

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Передача и обработка данных в html-файле
Главная | ::. | JavaScript | ::. | Советы по JavaScript | ::. | Чем заменить SSI, или необычное использование JavaScript
 |  |  |  |  |  | Как сделать страницу стартовой

Структура подавляющего количества интернет-страничек примерно одинакова: это заголовок странички, навигационное меню и, непосредственно, само содержимое. Нет проблем, когда на Вашем сайте несколько страниц. Если Вы захотели изменить дизайн, то на это уйдет немного времени. А если страниц не 8-10 а 100-200? Чтобы поменять дизайн нужен долгий однообразный кропотливый труд. А если в меню появился новый пункт? Опять же везде на каждой странице надо вводить изменения.

Помочь в этом может SSI - возможность собрать страничку из отдельных блоков. Т.е у Вас есть меню, которое одинаково на всех страницах. Вы его выносите в отдельный файл, а затем включаете его в нужное место на странице. Теперь, чтобы изменить меню на всех страницах, надо изменить его только в одном файле.

Это конечно удобно, но данная возможность имеется только при платном хостинге, или Вам придется вставлять баннеры хостера, что может быть нежелательно для Вас.

Справиться с этой проблемой может язык JavaScript, а именно атрибут SRC в теле тега <SCRIPT>.

Атрибут SRC задает URL файла, в котором находится код программы JavaScript, а в самом файле с расширением *.js мы запишем то, что должно выводиться на экран при помощи метода document.write

Например у нас есть меню состоящее из двух пунктов и страница, в которую надо вставить это меню:

Файл menu.js:

document.write("<B>Меню:</B><BR>");
document.write("<A href="page1.html">Ссылка1</A><BR>");
document.write("<A href="page2.html">Ссылка2</A>");

Файл page.html:

<html>
<head>
<title>Проверка</title>
</head>
<body>
<h1>Моя страница</h1>
<script src="menu.js"></script>
. . .
</body>
</html>

Т.е. вместо

<script src="menu.js"></script>

браузер вставил:

<B>Меню:</B><BR>
<A href="page1.html">Ссылка1</A><BR>
<A href="page2.html">Ссылка2</A>

И если вместо меню на всех страницах вставить <script src="menu.js"></script>, то для изменения меню на всех страницах нужно изменить только файл menu.js

Но у этого метода есть небольшие недостатки:

  • Исходный код увеличивается за счет прибавления document.write
  • Достаточно старые браузеры не распознают тег <SCRIPT>, а следовательно ничего не подставят.
  • Достаточно часто происходит путаница с двойными и одинарными кавычками, т.к. они должны быть вложены друг в друга.
Получено с http://spravkaweb.local/index.php/javascript/sovet/src
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 16:14, 4 марта 2007.
  • К этой странице обращались 77 раз.
1.42008805275


Советы по JavaScript : Как сделать страницу стартовой — Справочник Web-языков

Советы по JavaScript : Как сделать страницу стартовой

 |  |  |  |  |  | Чем заменить SSI, или необычное использование JavaScript
Главная | ::. | JavaScript | ::. | Советы по JavaScript | ::. | Как сделать страницу стартовой
 |  |  |  |  |  | Как добавить страницу в избранное

Сделав страницу стартовой при запуске Internet Explorer браузер пользователя будет автоматически загружать указанный адрес.

Вот код ссылки, нажав которую пользователь сделает страницу стартовой:

<a href="#" onClick="this.style.behavior="url(#default#homepage)";
this.setHomePage("http://www.spravkaweb.ru/"); return false;">
Сделать страницу стартовой</a>
Получено с http://spravkaweb.local/index.php/javascript/sovet/start
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 16:53, 4 марта 2007.
  • К этой странице обращались 78 раз.
1.36158299446


jscript/errors — Справочник Web-языков

jscript/errors

Главная | ::. | JScript | ::. | Обработка ошибок в JScript
 |  |  |  | Список функций JScript
  • Ошибки во время исполнения - List of JScript run-time errors
  • Синтаксические ошибки - List of JScript syntax errors
Получено с http://spravkaweb.local/index.php/jscript/errors
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 11:08, 20 марта 2007.
  • К этой странице обращались 14 раз.
1.1472928524


jscript/functions — Справочник Web-языков

jscript/functions

 |  |  |  | Обработка ошибок в JScript
Главная | ::. | JScript | ::. | Список функций JScript
 |  |  |  | Список методов JScript
  • Функция GetObject - Returns a reference to an Automation object from a file.
  • Функция ScriptEngine - Returns a string representing the scripting language in use.
  • Функция ScriptEngineBuildVersion - Returns the build version number of the scripting engine in use.
  • Функция ScriptEngineMajorVersion - Returns the major version number of the scripting engine in use.
  • Функция ScriptEngineMinorVersion - Returns the minor version number of the scripting engine in use.
Получено с http://spravkaweb.local/index.php/jscript/functions
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 11:11, 20 марта 2007.
  • К этой странице обращались 14 раз.
1.11245298386


jscript/methods — Справочник Web-языков

jscript/methods

 |  |  |  | Список функций JScript
Главная | ::. | JScript | ::. | Список методов JScript
 |  |  |  | Список объектов JScript
  • Метод abs - Возвращает модуль числа.
  • Метод acos - Возвращает арк косинус числа.
  • Метод anchor - Вставляет HTML-якорь с атрибутом NAME вокруг заданного текста.
  • Метод apply - Applies a method of an object, substituting another object for the current object.
  • Метод asin - Returns the arcsine of a number.
  • Метод atan - Возвращает арк тангенс числа.
  • Метод atan2 - Returns the angle (in radians) from the X axis to a point (y,x).
  • Метод atEnd - Returns a Boolean value indicating if the enumerator is at the end of the collection.
  • Метод big - Places HTML <BIG> tags around text in a String object.
  • Метод blink - Вставляет HTML-тег <BLINK> вокруг заданного текста.
  • Метод bold - Вставляет HTML-тег <B> вокруг заданного текста.
  • Метод call - Calls a method of an object, substituting another object for the current object.
  • Метод ceil - Returns the smallest integer greater than or equal to its numeric argument.
  • Метод charAt - Returns the character at the specified index.
  • Метод charCodeAt - Returns the Unicode encoding of the specified character.
  • Метод compile - Compiles a regular expression into an internal format.
  • Метод concat (Массив) - Returns a new array consisting of a combination of two arrays.
  • Метод concat (Строка) - Returns a String object containing the concatenation of two supplied strings.
  • Метод cos - Returns the cosine of a number.
  • Метод decodeURI - Returns the unencoded version of an encoded Uniform Resource Identifier.
  • Метод decodeURIComponent - Returns the unencoded version of an encoded component of a Uniform Resource Identifier.
  • Метод dimensions - Returns the number of dimensions in a VBArray.
  • Метод encodeURI - Encodes a text string as a valid Uniform Resource Identifier.
  • Метод encodeURIComponent - Encodes a text string as a valid component of a Uniform Resource Identifier.
  • Метод escape - Encodes String objects so they can be read on all computers.
  • Метод eval - Evaluates JScript code and executes it.
  • Метод exec - Executes a search for a match in a specified string.
  • Метод exp - Returns e (the base of natural logarithms) raised to a power.
  • Метод fixed - Вставляе HTML-тег <TT> вокруг заданного объекта.
  • Метод floor - Returns the greatest integer less than or equal to its numeric argument.
  • Метод fontcolor - Places an HTML <FONT> tag with the COLOR attribute around the text in a String object.
  • Метод fontsize - Вставляет HTML-тег <FONT> с атрибутом SIZE вокруг заданного текста.
  • Метод fromCharCode - Returns a string from a number of Unicode character values.
  • Метод getDate - Returns the day of the month value in a Date object using local time.
  • Метод getDay - Returns the day of the week value in a Date object using local time.
  • Метод getFullYear - Returns the year value in the Date object using local time.
  • Метод getHours - Returns the hours value in a Date object using local time.
  • Метод getItem - Returns the item at the specified location.
  • Метод getMilliseconds - Returns the milliseconds value in a Date object using local time.
  • Метод getMinutes - Returns the minutes value stored in a Date object using local time.
  • Метод getMonth - Returns the month value in the Date object using local time.
  • Метод getSeconds - Returns seconds value stored in a Date object using local time.
  • Метод getTime - Returns the time value in a Date object.
  • Метод getTimezoneOffset - Returns the difference in minutes between the time on the host computer and Universal Coordinated Time (UTC).
  • Метод getUTCDate - Returns the date value in a Date object using Universal Coordinated Time (UTC).
  • Метод getUTCDay - Returns the day of the week value in a Date object using Universal Coordinated Time (UTC).
  • Метод getUTCFullYear - Returns the year value in a Date object using Universal Coordinated Time (UTC).
  • Метод getUTCHours - Returns the hours value in a Date object using Universal Coordinated Time (UTC).
  • Метод getUTCMilliseconds - Returns the milliseconds value in a Date object using Universal Coordinated Time (UTC).
  • Метод getUTCMinutes - Returns the minutes value in a Date object using Universal Coordinated Time (UTC).
  • Метод getUTCMonth - Returns the month value in a Date object using Universal Coordinated Time (UTC).
  • Метод getUTCSeconds - Returns the seconds value in a Date object using Universal Coordinated Time (UTC).
  • Метод getVarDate - Returns the VT_DATE value in a Date object.
  • Метод getYear - Returns the year value in a Date object.
  • Метод hasOwnProperty - Returns a Boolean value indicating whether an object has a property with the specified name.
  • Метод indexOf - Returns the character position where the first occurrence of a substring occurs within a String object.
  • Метод isFinite - Returns a Boolean value that indicates if a supplied number is finite.
  • Метод isNaN - Returns a Boolean value that indicates whether a value is the reserved value NaN (not a number).
  • Метод isPrototypeOf - Returns a Boolean value indicating whether an object exists in another object's prototype chain.
  • Метод italics - Вставляет HTML-тег <I> вокруг заданного текста.
  • Метод item - Returns the current item in the collection.
  • Метод join - Returns a String object consisting of all the elements of an array concatenated together.
  • Метод lastIndexOf - Returns the last occurrence of a substring within a String object.
  • Метод lbound - Returns the lowest index value used in the specified dimension of a VBArray.
  • Метод link - Places an HTML anchor with an HREF attribute around the text in a String object.
  • Метод localeCompare - Returns a value indicating whether two strings are equivalent in the current locale.
  • Метод log - Returns the natural logarithm of a number.
  • Метод match - Returns, as an array, the results of a search on a string using a supplied Regular Expression object.
  • Метод max - Возвращает наибольшее из двух значений.
  • Метод min - Возвращает наименьшее из двух значений.
  • Метод moveFirst - Resets the current item in the collection to the first item.
  • Метод moveNext - Moves the current item to the next item in the collection.
  • Метод parse - Parses a string containing a date, and returns the number of milliseconds between that date and midnight, January 1, 1970.
  • Метод parseFloat - Returns a floating-point number converted from a string.
  • Метод parseInt - Returns an integer converted from a string.
  • Метод pop - Removes the last element from an array and returns it.
  • Метод pow - Returns the value of a base expression raised to a specified power.
  • Метод push - Appends new elements to an array, and returns the new length of the array.
  • Метод random - Returns a pseudorandom number between 0 and 1.
  • Метод replace - Returns a copy of a string with text replaced using a regular expression.
  • Метод reverse - Returns an Array object with the elements reversed.
  • Метод round - Returns a specified numeric expression rounded to the nearest integer.
  • Метод search - Returns the position of the first substring match in a regular expression search.
  • Метод setDate - Sets the numeric date of the Date object using local time.
  • Метод setFullYear - Sets the year value in the Date object using local time.
  • Метод setHours - Sets the hour value in the Date object using local time.
  • Метод setMilliseconds - Sets the milliseconds value in the Date object using local time.
  • Метод setMinutes - Sets the minutes value in the Date object using local time.
  • Метод setMonth - Sets the month value in the Date object using local time.
  • Метод setSeconds - Sets the seconds value in the Date object using local time.
  • Метод setTime - Sets the date and time value in the Date object.
  • Метод setUTCDate - Sets the numeric date in the Date object using Universal Coordinated Time (UTC).
  • Метод setUTCFullYear - Sets the year value in the Date object using Universal Coordinated Time (UTC).
  • Метод setUTCHours - Sets the hours value in the Date object using Universal Coordinated Time (UTC).
  • Метод setUTCMilliseconds - Sets the milliseconds value in the Date object using Universal Coordinated Time (UTC).
  • Метод setUTCMinutes - Sets the minutes value in the Date object using Universal Coordinated Time (UTC).
  • Метод setUTCMonth - Sets the month value in the Date object using Universal Coordinated Time (UTC).
  • Метод setUTCSeconds - Sets the seconds value in the Date object using Universal Coordinated Time (UTC).
  • Метод setYear - Sets the year value in the Date object.
  • Метод shift - Removes the first element from an array and returns it.
  • Метод sin - Returns the sine of a number.
  • Метод slice (Массив) - Returns a section of an array.
  • Метод slice (Строка) - Returns a section of a string.
  • Метод small - Places HTML <SMALL> tags around text in a String object.
  • Метод sort - Returns an Array object with the elements sorted.
  • Метод splice - Removes elements from an array and, if necessary, inserts new elements in their place, returning the deleted elements.
  • Метод split - Returns the array of strings that results when a string is separated into substrings.
  • Метод sqrt - Returns the square root of a number.
  • Метод strike - Вставляет HTML-тег <STRIKE> вокруг заданного текста.
  • Метод sub - Вставляет HTML-тег <SUB> вокруг заданного текста.
  • Метод substr - Returns a substring beginning at a specified location and having a specified length.
  • Метод substring - Returns the substring at a specified location within a String object.
  • Метод sup - Places HTML <SUP> tags around text in a String object.
  • Метод tan - Returns the tangent of a number.
  • Метод test - Returns a Boolean value that indicates whether or not a pattern exists in a searched string.
  • Метод toArray - Returns a standard JScript array converted from a VBArray.
  • Метод toDateString - Returns a date as a string value.
  • Метод toExponential - Returns a string containing a number represented in exponential notation.
  • Метод toFixed - Returns a string representing a number in fixed-point notation.
  • Метод toGMTString - Returns a date converted to a string using Greenwich Mean Time (GMT).
  • Метод toLocaleDateString - Returns a date as a string value appropriate to the host environment's current locale.
  • Метод toLocaleLowerCase - Returns a string where all alphabetic characters have been converted to lowercase, taking into account the host environment's current locale.
  • Метод toLocaleString - Returns a date converted to a string using the current locale.
  • Метод toLocaleTimeString - Returns a time as a string value appropriate to the host environment's current locale.
  • Метод toLocaleUpperCase - Returns a string where all alphabetic characters have been converted to uppercase, taking into account the host environment's current locale.
  • Метод toLowerCase - Returns a string where all alphabetic characters have been converted to lowercase.
  • Метод toPrecision - Returns a string containing a number represented either in exponential or fixed-point notation with a specified number of digits.
  • Метод toString - Returns a string representation of an object.
  • Метод toTimeString - Returns a time as a string value.
  • Метод toUpperCase - Returns a string where all alphabetic characters have been converted to uppercase.
  • Метод toUTCString - Returns a date converted to a string using Universal Coordinated Time (UTC).
  • Метод ubound - Returns the highest index value used in the specified dimension of the VBArray.
  • Метод unescape - Decodes String objects encoded with the escape method.
  • Метод unshift - Returns an array with specified elements inserted at the beginning.
  • Метод UTC - Returns the number of milliseconds between midnight, January 1, 1970 Universal Coordinated Time (UTC) (or GMT) and the supplied date.
  • Метод valueOf - Returns the primitive value of the specified object.
  • Метод write - Sends strings to the script debugger.
  • Метод writeln - Sends strings to the script debugger, followed with a newline character.
Получено с http://spravkaweb.local/index.php/jscript/methods
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 13:03, 27 марта 2007.
  • К этой странице обращались 41 раз.
1.25689601898


jscript/objects — Справочник Web-языков

jscript/objects

 |  |  |  | Список методов JScript
Главная | ::. | JScript | ::. | Список объектов JScript
 |  |  |  | Список операторов JScript

  • Объект ActiveXObject - Поддерживает и возвращает связь с объектами ActiveX.
  • Объект Array - Осуществляет поддержку создания массивов с любыми типами данных.
  • Объект arguments - Объект, предоставляющий доступ к аргументам текущей функции или к функции, которая была вызвана.
  • Объект Boolean - Создание нового логического значения.
  • Объект Date - Осуществляет поддержку основополагающей работы с датами и временем.
  • Объект Debug - Внутренний объект, который может послать строку во внешний отладчик.
  • Объект Enumerator - Делает возможным определение численности элементов в коллекциях.
  • Объект Error - Объект, содержащий информацию о ошибках, произошедших во время выполнения кода JScript.
  • Объект Function - Создание новых функций.
  • Объект Global - Объект, чье назначение собирать глобальные методы в один объект.
  • Объект Math - Объект, позволяющий получить доступ к базовым математическим функциям и константам.
  • Объект Number - Объект, содержащий определение числовых данных и получение числовых констант.
  • Объект Object - Осуществляет функциональную поддержку для всех объектов JScript.
  • Объект RegExp - Содержит информацию о поисковых регулярных выражениях.
  • Объект Regular Expression - Содержит информацию о регулярных выражениях.
  • Объект String - Позволяет производить различные манипуляции с текстом: форматирование, размещение подстрок в исходынх строках и т.д..
  • Объект VBArray - Обеспечивает доступ к Visual Basic через специальные массивы.
Получено с http://spravkaweb.local/index.php/jscript/objects
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 07:26, 21 марта 2007.
  • К этой странице обращались 19 раз.
1.15777897835


jscript/operators — Справочник Web-языков

jscript/operators

 |  |  |  | Список объектов JScript
Главная | ::. | JScript | ::. | Список операторов JScript
 |  |  |  | Список свойств JScript
  • Оператор (+=) - Adds the value of an expression to the value of a variable and assigns the result to the variable.
  • Оператор (+) - Sums two numbers or concatenates two strings.
  • Оператор (=) - Assigns a value to a variable.
  • Оператор (&=) - Performs a bitwise AND on the value of a variable and the value of an expression and assigns the result to the variable.
  • Оператор (&) - Performs a bitwise AND on two expressions.
  • Оператор (<<) - Shifts the bits of an expression to the left.
  • Оператор (~) - Performs a bitwise NOT (negation) on an expression.
  • Оператор (|=) - Performs a bitwise OR on the value of a variable and the value of an expression and assigns the result to the variable.
  • Оператор (|) - Performs a bitwise OR on two expressions.
  • Оператор (>>) - Shifts the bits of an expression to the right, maintaining sign.
  • Оператор (^=) - Performs a bitwise exclusive OR on a variable and an expression and assigns the result to the variable.
  • Оператор (^) - Performs a bitwise exclusive OR on two expressions.
  • Оператор (,) - Causes two expressions to be executed sequentially.
  • Оператор Сравнения - Returns a Boolean value indicating the result of the comparison.
  • Оператор Compound Assignment Operators - List of compound assignment operators.
  • Оператор (?:) - Executes one of two expressions depending on a condition.
  • Оператор (--) - Decrements a variable by one.
  • Оператор delete - Deletes a property from an object, or removes an element from an array.
  • Оператор (/=) - Divides the value of a variable by the value of an expression and assigns the result to the variable.
  • Оператор (/) - Divides two numbers and returns a numeric result.
  • Оператор in - Tests for the existence of a property in an object.
  • Оператор (==) - Compares two expressions to determine if they are equal.
  • Оператор (>) - Compares two expressions to determine if one is greater than the other.
  • Оператор (>=) - Compares two expressions to determine if one is greater than or equal to the other.
  • Оператор (===) - Compares two expressions to determine if they are equal in value and of the same data type.
  • Оператор (++) - Increments a variable by one.
  • Оператор (!=) - Compares two expressions to determine if they are unequal.
  • Оператор instanceof - Returns a Boolean value that indicates whether or not an object is an instance of a particular class.
  • Оператор (<<=) - Left shifts the value of a variable by the number of bits specified in the value of an expression and assigns the result to the variable.
  • Оператор (<) - Compares two expressions to determine if one is less than the other.
  • Оператор (<=) - Compares two expressions to determine if one is less than or equal to the other.
  • Оператор (&&) - Performs a logical conjunction on two expressions.
  • Оператор (!) - Performs logical negation on an expression.
  • Оператор (||) - Performs a logical disjunction on two expressions.
  • Оператор (%=) - Divides the value of a variable by the value of an expression, and assigns the remainder to the variable.
  • Оператор (%) - Divides two numbers and returns the remainder.
  • Оператор (*=) - Multiplies the value of a variable by the value of an expression and assigns the result to the variable.
  • Оператор (*) - Multiplies two numbers.
  • Оператор new - Creates a new object.
  • Оператор (!==) - Compares two expressions to determine that they are not equal in value or of the same data type.
  • Оператор (>>=) - Right shifts the value of a variable by the number of bits specified in the value of an expression, maintaining the sign, and assigns the result to the variable.
  • Оператор (-=) - Subtracts the value of an expression from the value of a variable and assigns the result to the variable.
  • Оператор (-) - Performs subtraction of two expressions.
  • Оператор typeof - Returns a string that identifies the data type of an expression.
  • Оператор (-) - Indicates the negative value of a numeric expression.
  • Оператор (>>>=) - Right shifts the value of a variable by the number of bits specified in the value of an expression, without maintaining sign, and assigns the result to the variable.
  • Оператор (>>>) - Performs an unsigned right shift of the bits in an expression.
  • Оператор void - Prevents an expression from returning a value.
Получено с http://spravkaweb.local/index.php/jscript/operators
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 07:03, 21 марта 2007.
  • К этой странице обращались 39 раз.
1.08650684357


jscript/properties — Справочник Web-языков

jscript/properties

 |  |  |  | Список операторов JScript
Главная | ::. | JScript | ::. | Список свойств JScript
 |  |  |  | Список конструкций языка JScript
  • Свойство 0...n - Returns the value of individual arguments from an arguments object.
  • Свойство $1...$9 - Returns the nine most-recently memorized portions found during pattern matching.
  • Свойство arguments - Returns an array containing each argument passed to the currently executing function.
  • Свойство callee - Returns the Function object being executed.
  • Свойство caller - Returns a reference to the function that invoked the current function.
  • Свойство constructor - Specifies the function that creates an object.
  • Свойство description - Returns or sets the descriptive string associated with a specific error.
  • Свойство E - Returns Euler's constant, the base of natural logarithms.
  • Свойство global - Returns a Boolean value indicating the state of the global flag (g) used with a regular expression.
  • Свойство ignoreCase - Returns a Boolean value indicating the state of the ignoreCase flag (i) used with a regular expression.
  • Свойство index - Returns the character position where the first successful match begins in a searched string.
  • Свойство Infinity - Returns an initial value of Number.POSITIVE_INFINITY.
  • Свойство input - Returns the string against which a search was performed.
  • Свойство lastIndex - Returns the character position where the last successful match begins in a searched string.
  • Свойство lastMatch - Returns the last matched characters from any regular expression search.
  • Свойство lastParen - Returns the last parenthesized submatch from any regular expression search, if any.
  • Свойство leftContext - Returns the characters from the beginning of a searched string up to the position before the beginning of the last match.
  • Свойство length (аргументы) - Returns the actual number of arguments passed to a function by the caller.
  • Свойство length (Массив) - Returns an integer value one higher than the highest element defined in an array.
  • Свойство length (Функция) - Returns the number of arguments defined for a function.
  • Свойство length (Строка) - Returns the length of a String object.
  • Свойство LN2 - Returns the natural logarithm of 2.
  • Свойство LN10 - Returns the natural logarithm of 10.
  • Свойство LOG2E - Returns the base-2 logarithm of e, Euler's constant.
  • Свойство LOG10E - Returns the base-10 logarithm of e, Euler's constant.
  • Свойство MAX_VALUE - Returns the largest number that can be represented in JScript.
  • Свойство message - Returns an error message string.
  • Свойство MIN_VALUE - Returns the number closest to zero that can be represented in JScript.
  • Свойство multiline - Returns a Boolean value indicating the state of the multiline flag (m) used with a regular expression.
  • Свойство name - Returns the name of an error.
  • Свойство NaN (Глобальное свойство) - Returns the special value NaN indicating that an expression is not a number.
  • Свойство NaN (Число) - Returns the special value (NaN) indicating that an expression is not a number.
  • Свойство NEGATIVE_INFINITY - Returns a value more negative than the largest negative number (-Number.MAX_VALUE) that can be represented in JScript.
  • Свойство number - Returns or sets the numeric value associated with a specific error.
  • Свойство PI - Returns the ratio of the circumference of a circle to its diameter, approximately 3.141592653589793.
  • Свойство POSITIVE_INFINITY - Returns a value larger than the largest number (Number.MAX_VALUE) that can be represented in JScript.
  • Свойство propertyIsEnumerable - Returns a Boolean value indicating whether a specified property is part of an object and if it is enumerable.
  • Свойство prototype - Returns a reference to the prototype for a class of objects.
  • Свойство rightContext - Returns the characters from the position following the last match to the end of the searched string.
  • Свойство source - Returns a copy of the text of the regular expression pattern.
  • Свойство SQRT1_2 - Returns the square root of 0.5, or one divided by the square root of 2.
  • Свойство SQRT2 - Returns the square root of 2.
  • Свойство undefined - Returns an initial value of undefined.
Получено с http://spravkaweb.local/index.php/jscript/properties
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 05:17, 21 марта 2007.
  • К этой странице обращались 26 раз.
1.52414488792


jscript/statements — Справочник Web-языков

jscript/statements

 |  |  |  | Список свойств JScript
Главная | ::. | JScript | ::. | Список конструкций языка JScript
  • Конструкция break - Terminates the current loop, or if in conjunction with a label, terminates the associated statement.
  • Конструкция catch - Contains statements to execute when an error occurs in code within the try block.
  • Конструкция @cc_on - Activates conditional compilation support.
  • Конструкция // (Однострочный комментарий) - Causes single-line comments to be ignored by the JScript parser.
  • Конструкция /*..*/ (Многострочный комментарий) - Causes multiline comments to be ignored by the JScript parser.
  • Конструкция continue - Stops the current iteration of a loop, and starts a new iteration.
  • Конструкция debugger - Starts the debugger.
  • Конструкция do...while - Executes a statement block once, and then repeats execution of the loop until a condition expression evaluates to false.
  • Конструкция for - Executes a block of statements for as long as a specified condition is true.
  • Конструкция for...in - Executes one or more statements for each element of an object or array.
  • Конструкция function - Declares a new function.
  • Конструкция @if - Conditionally executes a group of statements, depending on the value of an expression.
  • Конструкция if...else - Conditionally executes a group of statements, depending on the value of an expression.
  • Конструкция Labeled - Provides an identifier for a statement.
  • Конструкция return - Exits from the current function and returns a value from that function.
  • Конструкция @set - Creates variables used with conditional compilation statements.
  • Конструкция switch - Enables the execution of one or more statements when a specified expression's value matches a label.
  • Конструкция this - Refers to the current object.
  • Конструкция throw - Generates an error condition that can be handled by a try...catch statement.
  • Конструкция try - Implements error handling for JScript.
  • Конструкция var - Declares a variable.
  • Конструкция while - Executes a statement until a specified condition is false.
  • Конструкция with - Establishes the default object for a statement.
Получено с http://spravkaweb.local/index.php/jscript/statements
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 05:26, 21 марта 2007.
  • К этой странице обращались 14 раз.
1.23408699036


jscript/methods/abs — Справочник Web-языков

jscript/methods/abs

Главная | ::. | JScript | ::. | Методы | ::. | Метод abs
 |  |  |  |  |  | Метод acos

Разместите здесь информацию о методе abs

Получено с http://spravkaweb.local/index.php/jscript/methods/abs
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 13:04, 31 марта 2007.
  • К этой странице обращались 2 раза.
1.54947686195


jscript/methods/acos — Справочник Web-языков

jscript/methods/acos

 |  |  |  |  |  | Метод abs
Главная | ::. | JScript | ::. | Методы | ::. | Метод acos
 |  |  |  |  |  | Метод anchor

Разместите здесь информацию о методе anchor

Получено с http://spravkaweb.local/index.php/jscript/methods/acos
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 13:06, 31 марта 2007.
  • К этой странице обращались 1 раз.
1.09199380875


jscript/methods/anchor — Справочник Web-языков

jscript/methods/anchor

 |  |  |  |  |  | Метод acos
Главная | ::. | JScript | ::. | Методы | ::. | Метод anchor
 |  |  |  |  |  | Метод apply

Разместите здесь информацию о методе apply

Получено с http://spravkaweb.local/index.php/jscript/methods/anchor
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 13:07, 31 марта 2007.
  • К этой странице обращались 2 раза.
1.13831591606


jscript/methods/apply — Справочник Web-языков

jscript/methods/apply

 |  |  |  |  |  | Метод anchor
Главная | ::. | JScript | ::. | Методы | ::. | Метод apply
 |  |  |  |  |  | Метод asin

Разместите здесь информацию о методе apply

Получено с http://spravkaweb.local/index.php/jscript/methods/apply
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 13:09, 31 марта 2007.
  • К этой странице обращались 3 раза.
1.38116383553


jscript/methods/asin — Справочник Web-языков

jscript/methods/asin

 |  |  |  |  |  | Метод apply
Главная | ::. | JScript | ::. | Методы | ::. | Метод asin
 |  |  |  |  |  | Метод atan

Разместите здесь информацию о методе asin

Получено с http://spravkaweb.local/index.php/jscript/methods/asin
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 13:11, 31 марта 2007.
  • К этой странице обращались 1 раз.
1.31742119789


jscript/methods/atan — Справочник Web-языков

jscript/methods/atan

 |  |  |  |  |  | Метод asin
Главная | ::. | JScript | ::. | Методы | ::. | Метод atan
 |  |  |  |  |  | Метод atan2

Разместите здесь информацию о методе atan

Получено с http://spravkaweb.local/index.php/jscript/methods/atan
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 13:12, 31 марта 2007.
  • К этой странице обращались 2 раза.
1.24371695518


jscript/methods/atan2 — Справочник Web-языков

jscript/methods/atan2

 |  |  |  |  |  | Метод atan
Главная | ::. | JScript | ::. | Методы | ::. | Метод atan2
 |  |  |  |  |  | Метод atEnd

Разместите здесь информацию о методе atan2

Получено с http://spravkaweb.local/index.php/jscript/methods/atan2
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 07:42, 1 апреля 2007.
  • К этой странице обращались 1 раз.
1.10890412331


jscript/methods/atend — Справочник Web-языков

jscript/methods/atend

 |  |  |  |  |  | Метод atan2
Главная | ::. | JScript | ::. | Методы | ::. | Метод atEnd
 |  |  |  |  |  | Метод big

Разместите здесь информацию о методе atEnd

Получено с http://spravkaweb.local/index.php/jscript/methods/atend
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 07:43, 1 апреля 2007.
  • К этой странице обращались 1 раз.
1.36138081551


jscript/methods/big — Справочник Web-языков

jscript/methods/big

 |  |  |  |  |  | Метод atEnd
Главная | ::. | JScript | ::. | Методы | ::. | Метод big
 |  |  |  |  |  | Метод blink

Разместите здесь информацию о методе big

Получено с http://spravkaweb.local/index.php/jscript/methods/big
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 07:44, 1 апреля 2007.
  • К этой странице обращались 1 раз.
1.39688205719


jscript/methods/blink — Справочник Web-языков

jscript/methods/blink

 |  |  |  |  |  | Метод big
Главная | ::. | JScript | ::. | Методы | ::. | Метод blink
 |  |  |  |  |  | Метод bold

Разместите здесь информацию о методе blink

Получено с http://spravkaweb.local/index.php/jscript/methods/blink
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 07:45, 1 апреля 2007.
  • К этой странице обращались 1 раз.
1.4361011982


jscript/methods/bold — Справочник Web-языков

jscript/methods/bold

 |  |  |  |  |  | Метод blink
Главная | ::. | JScript | ::. | Методы | ::. | Метод bold
 |  |  |  |  |  | Метод call

Разместите здесь информацию о методе bold

Получено с http://spravkaweb.local/index.php/jscript/methods/bold
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 07:46, 1 апреля 2007.
  • К этой странице обращались 1 раз.
1.36903619766


jscript/methods/call — Справочник Web-языков

jscript/methods/call

 |  |  |  |  |  | Метод bold
Главная | ::. | JScript | ::. | Методы | ::. | Метод call
 |  |  |  |  |  | Метод ceil

Разместите здесь информацию о методе call

Получено с http://spravkaweb.local/index.php/jscript/methods/call
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 07:47, 1 апреля 2007.
  • К этой странице обращались 1 раз.
1.19854998589


jscript/methods/ceil — Справочник Web-языков

jscript/methods/ceil

 |  |  |  |  |  | Метод call
Главная | ::. | JScript | ::. | Методы | ::. | Метод ceil
 |  |  |  |  |  | Метод charAt

Разместите здесь информацию о методе ceil

Получено с http://spravkaweb.local/index.php/jscript/methods/ceil
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 07:48, 1 апреля 2007.
  • К этой странице обращались 1 раз.
1.3250451088


jscript/methods/charat — Справочник Web-языков

jscript/methods/charat

 |  |  |  |  |  | Метод ceil
Главная | ::. | JScript | ::. | Методы | ::. | Метод charAt
 |  |  |  |  |  | Метод charCodeAt

Разместите здесь информацию о методе charat

Получено с http://spravkaweb.local/index.php/jscript/methods/charat
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 07:49, 1 апреля 2007.
  • К этой странице обращались 1 раз.
1.23205089569


jscript/methods/charcodeat — Справочник Web-языков

jscript/methods/charcodeat

 |  |  |  |  |  | Метод charAt
Главная | ::. | JScript | ::. | Методы | ::. | Метод charCodeAt
 |  |  |  |  |  | Метод compile

Разместите здесь информацию о методе charcodeat

Получено с http://spravkaweb.local/index.php/jscript/methods/charcodeat
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 07:51, 1 апреля 2007.
  • К этой странице обращались 1 раз.
1.33851194382


jscript/methods/compile — Справочник Web-языков

jscript/methods/compile

 |  |  |  |  |  | Метод charCodeAt
Главная | ::. | JScript | ::. | Методы | ::. | Метод compile
 |  |  |  |  |  | Метод concat (Массив)

Разместите здесь информацию о методе compile

Получено с http://spravkaweb.local/index.php/jscript/methods/compile
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 07:53, 1 апреля 2007.
  • К этой странице обращались 2 раза.
1.43202018738


jscript/methods/concat array — Справочник Web-языков

jscript/methods/concat array

 |  |  |  |  |  | Метод compile
Главная | ::. | JScript | ::. | Методы | ::. | Метод concat (Массив)
 |  |  |  |  |  | Метод concat (Строка)

Разместите здесь информацию о методе Метод concat (Массив)

Получено с http://spravkaweb.local/index.php/jscript/methods/concat_array
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 10:25, 1 апреля 2007.
  • К этой странице обращались 1 раз.
1.25145292282


Справочник по MySQL — Справочник Web-языков

Справочник по MySQL

Главная ::. MySQL

[править] Разделы справки

  • Типы данных, используемые в базе данных MySQL
  • Создание базы данных MySQL (CREATE DATABASE)
  • Удаление базы данных MySQL (DROP DATABASE)
  • Создание таблицы в базе данных MySQL (CREATE TABLE)
  • Удаление таблицы из базы данных MySQL (DROP TABLE)
  • Изменение свойств таблицы
    • Переименование таблицы (ALTER TABLE RENAME)
    • Вставка столбцов (ALTER TABLE ADD)
    • Изменение свойств столбца (ALTER TABLE CHANGE)
    • Удаление столбцов (ALTER TABLE DROP)
  • Вставка строки в таблицу INSERT
  • Удаление строк из таблицы (DELETE FROM)
  • Обновление записей в таблице(UPDATE)
  • Поиск записей в таблице(SELECT)

[править] Полезные ссылки

  • Форум по MySQL
  • http://www.mysql.ru/ - Рускоязычный сайт поддержки базы данных MySQL
  • http://www.mysql.com/ - Официальный сайт базы данных MySQL
Получено с http://spravkaweb.local/index.php/mysql
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 12:50, 20 марта 2007.
  • К этой странице обращались 437 раз.
1.59491586685


Справочник по MySQL : SQL : Создание базы данных MySQL (CREATE DATABASE) — Справочник Web-языков

Справочник по MySQL : SQL : Создание базы данных MySQL (CREATE DATABASE)

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Типы данных, используемые в базе данных MySQL
Главная | ::. | MySQL | ::. | SQL | ::. | Создание базы данных MySQL (CREATE DATABASE)
 |  |  |  |  |  | Удаление базы данных MySQL (DROP DATABASE)

Создание базы данных выполняется с помощью оператора CREATE DATABASE.

Синтаксис оператора CREATE DATABASE

CREATE DATABASE [IF NOT EXISTS] db_name
db_name
- Имя, которое будет присвоено создаваемой базе данных.
IF NOT EXISTS
- Если не указать этот параметр, то при попытке создания базы данных с уже существующим именем, возникнет ошибка выполнения команды.

Следущий пример создает базу данных "my_db":

CREATE DATABASE `my_db`

При создании новой базы данных в MySQL следует придерживаться некоторых правил относительно имени базы данных:

  • Максимальная длина имени не должна превышать 64 символов.
  • Разрешены любые символы, которые допускаются в имени каталога, за исключением / (слеш) и . (точка). Но следует принять во внимание, что нельзя использовать символы ASCII(0) и ASCII(255).
Получено с http://spravkaweb.local/index.php/mysql/sql/createdb
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:26, 20 февраля 2007.
  • К этой странице обращались 173 раза.
1.26256084442


Справочник по MySQL : SQL : Создание таблицы в базе данных MySQL (CREATE TABLE) — Справочник Web-языков

Справочник по MySQL : SQL : Создание таблицы в базе данных MySQL (CREATE TABLE)

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Удаление базы данных MySQL (DROP DATABASE)
Главная | ::. | MySQL | ::. | SQL | ::. | Создание таблицы в базе данных MySQL (CREATE TABLE)
 |  |  |  |  |  | Удаление таблицы из базы данных MySQL (DROP TABLE)

Создание таблицы в базе данных производится командой CREATE TABLE.

[править] Синтаксис:

CREATE [TEMPORARY] TABLE [IF NOT EXISTS] tbl_name [(create_definition,...)]
    [table_options] [select_statement]
tbl_name
- Задает имя таблицы, которая будет создана в текущей базе данных. Если никакая база данных на момен вызова команды CREATE TABLE не была принята текущей, то возникнет ошибка выполнения команды. Начиная с MySQL 3.22 введена возможность явно указать базу данных, в которой будет создана новая таблица, при помощи синтаксиса db_name.tbl_name.
TEMPORARY
- Этот параметр используется для создания временной таблицы с именем tbl_name в течении только текущего сценария. По окончанию выполнения сценария созданная таблица удаляется. Данная возможность появилась в MySQL 3.23 В MySQL 4.0.2 для создания временных таблиц требуются привелегии CREATE TEMPORARY TABLES.
IF NOT EXISTS
- Если указан этот параметр и производится попытка создать таблицу с дублирующим именем (т.е. таблица с таким именем в текущей БД уже есть), то таблица создана не будет и сообщение об ошибке не появиться. В противном случае таблица также создана не будет, но команда вызовет ошибку. Следует отметить, что при создании сравниваются только имена таблиц. Внутренние структуры не сравниваются.
create_definition
- Определяет внутреннюю структуру создаваемой таблицы (названия и типы полей, ключи, индексы и т.д.)
Возможные синтаксисы create_definition:
col_name type [NOT NULL | NULL] [DEFAULT default_value] [AUTO_INCREMENT] [PRIMARY KEY] [reference_definition]
или
PRIMARY KEY (index_col_name,...)
или
KEY [index_name] (index_col_name,...)
или
INDEX [index_name] (index_col_name,...)
или
UNIQUE [INDEX] [index_name] (index_col_name,...)
или
FULLTEXT [INDEX] [index_name] (index_col_name,...)
или
[CONSTRAINT symbol] FOREIGN KEY [index_name] (index_col_name,...) [reference_definition]
или
CHECK (expr)
col_name
- Задает имя столбца в создаваемой таблице.
type
- Задает тип данных для столбца col_name.
Возможные значения параметра type:
  • TINYINT[(length)] [UNSIGNED] [ZEROFILL]
  • SMALLINT[(length)] [UNSIGNED] [ZEROFILL]
  • MEDIUMINT[(length)] [UNSIGNED] [ZEROFILL]
  • INT[(length)] [UNSIGNED] [ZEROFILL]
  • INTEGER[(length)] [UNSIGNED] [ZEROFILL]
  • BIGINT[(length)] [UNSIGNED] [ZEROFILL]
  • REAL[(length,decimals)] [UNSIGNED] [ZEROFILL]
  • DOUBLE[(length,decimals)] [UNSIGNED] [ZEROFILL]
  • FLOAT[(length,decimals)] [UNSIGNED] [ZEROFILL]
  • DECIMAL(length,decimals) [UNSIGNED] [ZEROFILL]
  • NUMERIC(length,decimals) [UNSIGNED] [ZEROFILL]
  • CHAR(length) [BINARY]
  • VARCHAR(length) [BINARY]
  • DATE
  • TIME
  • TIMESTAMP
  • DATETIME
  • TINYBLOB
  • BLOB
  • MEDIUMBLOB
  • LONGBLOB
  • TINYTEXT
  • TEXT
  • MEDIUMTEXT
  • LONGTEXT
  • ENUM(value1,value2,value3,...)
  • SET(value1,value2,value3,...)
Подробнее о допустимых типах столбцов и их синтаксисе смотрите Типы данных, используемые в базе данных MySQL
[NOT NULL | NULL]
- Указывавет, может ли данных столбец содержать значение NULL или нет. Если не указано, то по умолчанию принимается NULL (т.е. может содержать NULL).
[DEFAULT default_value]
- Задает значение по умолчанию для данного столбца. При вставке новой записи в таблицу командой INSERT если значение для поля col_name явно указано не было, то устанавливается значение default_value.
[AUTO_INCREMENT]
- При вставке новой записи в таблицу поле с этим атрибутом автоматически получит числовое значение, на 1 больше самого большого значения для этого поля в текущий момент времени. Данная возможность обычно используется для генерирования уникальных идентификаторов строк. Столбец, для которого применяется атрибут AUTO_INCREMENT, должен иметь целочисленный тип. В таблице может быть только один столбец с атрибутом AUTO_INCREMENT. Так же этот столбец должен быть проиндексирован. Отсчет последовательности чисел для AUTO_INCREMENT начинается с 1. Это могут быть только положительные числа.
Следующий пример создает таблицу users с 3 полями, где первое поле - уникальный идентификатор записи, второе поле - имя пользователя, а третье поле - его возраст:
CREATE TABLE `users` (
 `id` INT( 11  ) NOT NULL AUTO_INCREMENT,  `name` CHAR( 30  ) NOT NULL,  `age` SMALLINT( 6  ) NOT NULL, PRIMARY KEY(
 `id`
)
)
Вставляем четыре новые записи:
INSERT INTO `users` (
 `name` ,  `age`
)VALUES(
 'Катя', 12
), (
 'Лена', 18
), (
 'Миша', 16
), (
 'Саша', 20
)
Выводим все записи таблицы users:
SELECT * FROM `users`
Полученный результат:
+----+------+-----+
| id | name | age |
+----+------+-----+
|  1 | Катя |  12 |
|  2 | Лена |  18 |
|  3 | Миша |  16 |
|  4 | Саша |  20 |
+----+------+-----+
4 rows in set (0.00 sec)
В таблицах MyISAM и BDB существует возможность задавать параметр AUTO_INCREMENT для вторичного столбца составного ключа.
В этом случае ключем записи (его уникальным значением) будет являться значение сразу двух полей. При этом первое поле является своеобразным префиксом, а второе уже как раз уникальным числовым значением для этого префикса.
Эту особенность удобно использовать, если необходимо добавлять новые данные по группам.
Покажем эту особенность на следующем примере:
Допустим, нам необходимо записывать свои контакты в таблицу. Создаем таблицу users с четырьмя полями для записи.
Первое поле содержит тип контакта (дом, работа, учеба);
второе поле - уникальный идентификатор записи;
третье поле - имя человека;
четвертое поле - его возраст.
CREATE TABLE `users` (
 `category` ENUM(
 'дом',  'работа',  'учеба'
)NOT NULL,  `id` MEDIUMINT NOT NULL AUTO_INCREMENT,  `name` CHAR( 30  ) NOT NULL,  `age` SMALLINT( 6  ) NOT NULL, PRIMARY KEY(
 `id` ,  `category`
)
)
Вставляем в созданную таблицу новые записи:
INSERT INTO `users` (
 `category` ,  `name` ,  `age`
)VALUES(
 'дом',  'Оля', 26
), (
 'дом',  'Настя', 20
), (
 'работа',  'Артем', 26
), (
 'учеба',  'Дима', 25
), (
 'работа',  'Саша', 27
), (
 'учеба',  'Миша', 25
), (
 'работа',  'Лена', 35
)
Теперь просмотрим все записи в таблице users, упорядочив их по полю category и id:
SELECT * FROM `users` GROUP BY `category` ,  `id`
Вот что получится в результате:
+----------+----+-------+-----+
| category | id | name  | age |
+----------+----+-------+-----+
| дом      |  1 | Оля   |  26 |
| дом      |  2 | Настя |  20 |
| работа   |  3 | Артем |  26 |
| работа   |  5 | Саша  |  27 |
| работа   |  7 | Лена  |  35 |
| учеба    |  4 | Дима  |  25 |
| учеба    |  6 | Миша  |  25 |
+----------+----+-------+-----+
7 rows in set (0.00 sec)
Чтобы получить значение ID последней вставленной записи, можно воспользоваться командой MySQL
SELECTLAST_INSERT_ID(
)
Либо функцией API mysql_insert_id().
[PRIMARY KEY]
- Задает первичный ключ таблицы.
В таблице может быть задан только одни первичный ключ. Все значения столбца, помеченного как перичный ключ, не должны содержать значения NULL. Если при создании таблицы первичный ключ явно указан не был, а приложение его запрашивает, то БД MySQL автоматически устанавливает первый столбец с параметром UNIQUE, если во всех значениях этого столбца нигде не встречается значение NULL.
В качестве первичного ключа можно задать как один, так и несколько столбцов:
PRIMARY KEY(col_1, col_2, ...)
Только в этом случае ни один другой столбец не может быть первичным, т.е. не может быть описан:
PRIMARY KEY(col_1), PRIMARY KEY(col_1, col_2)
Поля PRIMARY KEY являются проиндексированными полями (более подробную информацию по индексам читайте далее в INDEX).
KEY
- Является синонимом к INDEX
INDEX
- Задает поля, которые будут проиндексированы.
Индексация полей полезна для ускорения работы команды SELECT (причем ускорение порой бывает очень даже хорошее).
В качестве наглядного примера пользы от использования индексов можно взять книгу. В ней индексами будет являться оглавление. Если нам в книге надо найти определенный раздел и нет оглавления, то придется всю книгу перелистывать страница за страницей, пока нужный раздел не будет найден. А с оглавлением мы быстро можем найти любое место в книге за считанные секунды. Тоже самое и с таблицей. Если у таблицы нет индексов, то при поиске определенного значения MySQL "проходится" по всем записям таблицы и пытается найти необходимое значение. Если задать поля, которые должны быть проиндексированы, то MySQL создает специальное хранилище, в котором содержатся все значения проиндесированных полей таблицы и точное местоуказание, где это значение находится. Т.е. поиск значения происходит практически мгновенно, что несомненно сказывается на скорости выполнения скрипта.
Но за удобство и скорость работы приходится платить. В случае с индексами оплатой является увеличение базы данных примерно в два раза.
В MySQL проиндексированы могут быть поля любого типа. Для ускорения работы в полях типа CHAR и VARCHAR можно индексировать только несколько первых символов.
При задании индексов необходимо учитывать, что только у таблиц типа MyISAM, InnoDB и BDB индексируемое поле может иметь значения NULL. Чтобы небыло ошибок советуют полям, которые будут проиндексированы, всегда назначать NOT NULL.
Если параметр index_name, который задает имя индекса, не указан, то индесу присвоится имя первого индексируемого столбца.
В следующем примере создадим таблицу users с полями name и age и проиндексируем таблицу по полю name по первым 12 буквам:
CREATE TABLE `users` (
 `name` CHAR( 200  ) NOT NULL,  `age` SMALLINT( 3  ) , INDEX(
 `name` ( 12  )
)
)
Если для столбцов CHAR и VARCHAR было желательным индексирование только части столбца, то для полей типа TEXT и BLOB это является обязательным. При этом поля с типом TEXT или BLOB могут быть проиндексированы только в таблице типа MyISAM.
Получить сведения о индексах таблицы tbl_name можно выполнив следующий SQL-запрос:
SHOW INDEX FROM `tbl_name`
UNIQUE
- Этот ключ указывает на то, что данный столбец может иметь только уникальные значения. При попытке добавления повторяющегося значения в таблицу в поле с ключом UNIQUE, эта операция завершится ошибкой.
Уникальными можно задать как один, так и несколько столбцов:
CREATE TABLE `users` (
 `name` VARCHAR( 200  ) NOT NULL,  `address` VARCHAR( 255  ) NOT NULL, UNIQUE(
 `name` ,  `address`
)
)
FULLTEXT
- Задает поля, к которым в последствии может быть применен полнотекстный поиск.
Полнотекстный поиск является средством MySQL, направленным на поиск нужной информации в базе данных и выводе результатов в соответствии с релевантностью найденных строк относительно поискового запроса.
Полнотестный поиск введен в MySQL начиная с версии 3.23.23 для таблиц типа MyISAM и только для полей типа VARCHAR и TEXT.
При индексировании полей с ключом FULLTEXT происходит индексация всего значения, а не его части (т.е. задать для индексации первые n-символов НЕЛЬЗЯ).
FOREIGN KEY и CHECK
- Введены для совместимости при переносе кода с других SQL-баз данных при запуске приложений, создающих таблицы со ссылками.
Фактически ничего не делают.
table_options
- Задает дополнительные параметры создаваемой таблицы.
Данная возможность появилась в MySQL начиная с версии 3.23.
Возможные дополнительные параметры:
  • TYPE = {BDB | HEAP | ISAM | InnoDB | MERGE | MRG_MYISAM | MYISAM }
  • AUTO_INCREMENT = #
  • AVG_ROW_LENGTH = #
  • CHECKSUM = {0 | 1}
  • COMMENT = "string"
  • MAX_ROWS = #
  • MIN_ROWS = #
  • PACK_KEYS = {0 | 1 | DEFAULT}
  • PASSWORD = "string"
  • DELAY_KEY_WRITE = {0 | 1}
  • ROW_FORMAT= { default | dynamic | fixed | compressed }
  • RAID_TYPE= {1 | STRIPED | RAID0 } RAID_CHUNKS=# RAID_CHUNKSIZE=#
  • UNION = (table_name,[table_name...])
  • INSERT_METHOD= {NO | FIRST | LAST }
  • DATA DIRECTORY="абсолютный путь к каталогу"
  • INDEX DIRECTORY="абсолютный путь к каталогу"
TYPE
- Задает тип создаваемой таблицы.
Возможные типы таблиц в MySQL:
  • BDB - Таблицы с поддержкой транзакций и блокировкой страниц.
  • HEAP - Данные этой таблицы храняться только в памяти.
  • ISAM - Оригинальный обработчик таблиц.
  • InnoDB - Таблицы с поддержкой транзакций и блокировкой строк.
  • MERGE - Набор таблиц MyISAM, используемый как одна таблица.
  • MRG_MYISAM - Псевдоним для MERGE.
  • MyISAM - Новый обработчик, обеспечивающий переносимость таблиц в бинарном виде, который заменяет ISAM.
AUTO_INCREMENT
- Устанавливает для данной таблицы следующее значение AUTO_INCREMENT.
AVG_ROW_LENGTH
- Приближенное значение средней длины строки для данной таблицы. Имеет смысл устанавливать только для обширных таблиц с записями переменной длины.
CHECKSUM
- Следует установить в 1, чтобы в MySQL поддерживалась проверка контрольной суммы для всех строк (это делает таблицы немного более медленными при обновлении, но позволяет легче находить поврежденные таблицы) (MyISAM).
COMMENT
- Комментарий для данной таблицы длиной 60 символов.
MAX_ROWS
- Максимальное число строк, которые планируется хранить в данной таблице.
MIN_ROWS
- Минимальное число строк, которые планируется хранить в данной таблице.
PACK_KEYS
- Следует установить в 1 для получения меньшего индекса. Обычно это замедляет обновление и ускоряет чтение (MyISAM, ISAM). Установка в 0 отключит уплотнение ключей. При установке в DEFAULT (MySQL 4.0) обработчик таблиц будет уплотнять только длинные столбцы CHAR/VARCHAR.
PASSWORD
- Шифрует файл `.frm' с помощью пароля. Эта опция не функционирует в стандартной версии MySQL.
DELAY_KEY_WRITE
- Установка в 1 задерживает операции обновления таблицы ключей, пока не закроется указанная таблица (MyISAM).
ROW_FORMAT
- Определяет, каким образом должны храниться строки. В настоящее время эта опция работает только с таблицами MyISAM, которые поддерживают форматы строк DYNAMIC и FIXED.
RAID_TYPE
- Воспользовавшись опцией RAID_TYPE, можно разбить файл данных MyISAM на участки с тем, чтобы преодолеть 2Гб/4Гб лимит файловой системы под управлением ОС, не поддерживающих большие файлы. Разбиение не касается файла индексов. Следует учесть, что для файловых систем, которые поддерживают большие файлы, эта опция не рекомендуется! Для получения более высокой скорости ввода-вывода можно разместить RAID-директории на различных физических дисках. RAID_TYPE будет работать под любой операционной системой, если конфигурация MySQL выполнена с параметром --with-raid. В настоящее время для опции RAID_TYPE возможен только параметр STRIPED (1 и RAID0 являются псевдонимами для него). Если указывается RAID_TYPE=STRIPED для таблицы MyISAM, то MyISAM создаст поддиректории RAID_CHUNKS с именами `00', `01', `02' в директории базы данных. В каждой из этих директорий MyISAM создаст файл `table_name.MYD'. При записи данных в файл данных обработчик RAID установит соответствие первых RAID_CHUNKSIZE*1024 байтов первому упомянутому файлу, следующих RAID_CHUNKSIZE*1024 байтов - следующему файлу и так далее.
UNION
- Опция UNION применяется, если необходимо использовать совокупность идентичных таблиц как одну таблицу. Она работает только с таблицами MERGE. На данный момент для таблиц, сопоставляемых с таблицей MERGE, необходимо иметь привилегии SELECT, UPDATE и DELETE. Все сопоставляемые таблицы должны принадлежать той же базе данных, что и таблица MERGE.
INSERT_METHOD
- Для внесения данных в таблицу MERGE необходимо указать с помощью INSERT_METHOD, в какую таблицу данная строка должна быть внесена. Эта опция была введена в MySQL 4.0.0.
DATA DIRECTORY и INDEX DIRECTORY
- Используя опции DATA DIRECTORY="каталог" или INDEX DIRECTORY="каталог", можно указать, где обработчик таблицы должен помещать свои табличные и индексные файлы. Следует учитывать, что указываемый параметр directory должен представлять собой полный путь к требуемому каталогу (а не относительный путь). Данные опции работают только для таблиц MyISAM в версии MySQL 4.0, если при этом не используется опция --skip-symlink.
select_statement
- Добавляет к создаваемой таблице поля и значения, полученные в результате работы команды SELECT.
Приведем наглядный пример.
Допустим, у нас есть таблица с именами городов:
CREATE TABLE `city` (
 `name` CHAR( 200  ) NOT NULL
)
INSERT INTO `city` VALUES(
 'Москва'
), (
 'Рязань'
), (
 'Луховицы'
), (
 'Коломна'
)
и мы хотим создать таблицу с именами пользователей и названием городов где они живут:
CREATE TABLE `users` (
 `id` INT( 11  ) NOT NULL AUTO_INCREMENT,  `name` CHAR( 200  ) NOT NULL, PRIMARY KEY(
 `id`
)
)SELECT * FROM `city`
Теперь таблица user имеет стобцы и содержит значения:
Приведенный пример никакой смысловой нагрузки не несет, т.к. поле name не получило никаких значений. Здесь просто показан принцып присоединения слева новых столбцов при помощи конструкции SELECT.
Еще пример:
CREATE TABLE `city_new` SELECT `id` ,  `city_name` AS `name` FROM `users`
SELECT * FROM `city_new`
+----+----------+
| id | name     |
+----+----------+
|  1 | Москва   |
|  2 | Рязань   |
|  3 | Луховицы |
|  4 | Коломна  |
+----+----------+
4 rows in set (0.00 sec)
Получено с http://spravkaweb.local/index.php/mysql/sql/createtable
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 18:03, 24 февраля 2007.
  • К этой странице обращались 224 раза.
1.29125094414


Справочник по MySQL : SQL : Удаление строк из таблицы (DELETE FROM) — Справочник Web-языков

Справочник по MySQL : SQL : Удаление строк из таблицы (DELETE FROM)

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Вставка строки в таблицу INSERT
Главная | ::. | MySQL | ::. | SQL | ::. | Удаление строк из таблицы (DELETE FROM)
 |  |  |  |  |  | Обновление записей в таблице(UPDATE)

Удаление записей осуществляется командой DELETE FROM.

[править] Синтаксис оператора DELETE FROM

DELETE [LOW_PRIORITY | QUICK] FROM table_name
    [WHERE where_definition]
    [ORDER BY ...]
    [LIMIT rows]

или

DELETE [LOW_PRIORITY | QUICK] table_name[.*] [,table_name[.*] ...]
    FROM table-references
    [WHERE where_definition]

или

DELETE [LOW_PRIORITY | QUICK]
    FROM table_name[.*], [table_name[.*] ...]
    USING table-references
    [WHERE where_definition]

Команда DELETE удаляет из таблицы table_name все записи, удовлетворяющие условию where_definition. Если условие WHERE where_definition не задано, то из таблицы table_name удаляются все записи.

Команда DELETE возвращает количество удаленных записей.

Следует учитывать, что если в команде DELETE не задано условие WHERE where_definition, то команда возвратит 0, хотя записи были удалены.

Если все же необходимо удалить все записи и узнать их количество, то в условии where_definition нужно задать заведомо истинное значение:

DELETE FROM `users` WHERE1 =1

Но в этом случае выполнение команды происходит значительно медленнее.

LOW_PRIORITY
- Если указано это ключевое слово, то удаление записей из таблицы table_name не будет произведено до тех пор, пока другие процессы не закончат чтение их этой таблицы.
QUICK
- Если указано это ключевое слово, то при удалении записей обработчик таблицы не будет объединять индексы, что может ускорить операцию удаления.
table_name
- Имя таблицы в базе данных, из которой будет происходить удаление строк.
LIMIT
- Задает максимальное количество строк, которые могут быть удалены за текущий запрос.
Следующий запрос удалит из таблицы users только 5 строк:
DELETE FROM `users` LIMIT5
ORDER BY
- Задает имя поля, или имена полей через запятую, по которым происходит сортировка удаляемых записей.
Эта возможность актуальна при необходимости удалить только определенное кол-во записей, отсортированных по какому-либо свойству.
Следующий пример удалит из таблицы users запись самого молодого человека.
Допустим таблица users имеет следующий вид:
CREATE TABLE `users` (
 `name` VARCHAR( 255  ) NOT NULL,  `age` SMALLINT( 3  ) NOT NULL
)
Запишем в нее несколько записей:
INSERT INTO `users` (
 `name` ,  `age`
)VALUES(
 'Миша', 25
), (
 'Ксюша', 15
), (
 'Настя', 12
), (
 'Саша', 26
), (
 'Дима', 30
)
Таблица users имеет значения:
SELECT * FROM `users`
+-------+-----+
| name  | age |
+-------+-----+
| Миша  |  25 |
| Ксюша |  15 |
| Настя |  12 |
| Саша  |  26 |
| Дима  |  30 |
+-------+-----+
5 rows in set (0.00 sec)
Удаляем самого молодого:
DELETE FROM `users` ORDER BY `age` LIMIT1
Теперь таблица имеет значения:
SELECT * FROM `users`
+-------+-----+
| name  | age |
+-------+-----+
| Миша  |  25 |
| Ксюша |  15 |
| Саша  |  26 |
| Дима  |  30 |
+-------+-----+
4 rows in set (0.00 sec)
Можем также удалить самого старого:
DELETE FROM `users` ORDER BY `age` DESCLIMIT1
Теперь таблица имеет значения:
SELECT * FROM `users`
+-------+-----+
| name  | age |
+-------+-----+
| Миша  |  25 |
| Ксюша |  15 |
| Саша  |  26 |
+-------+-----+
3 rows in set (0.00 sec)
Сортировка удаляемых записей при помощи команды ORDER BY появилась в MySQL начиная с версии 4.0.
FROM table-references и USING ...
- Позволяют удалять записи сразу из нескольких таблиц руководствуясь многотабличным условием WHERE where_definition.
Следующие два примера равнозначны по производимым действиям и удаляют одинаковые записи в таблицах table_1 и table_2 и используя при поиске значений еще и таблицу table_3:
DELETE `table_1` ,  `table_2` FROM `table_1` ,  `table_2` ,  `table_3` WHERE `table_1`.`id`  =  `table_2`.`id`  &&  `table_2`.`id`  =  `table_3`.`id`
Аналогичный запрос:
DELETE FROM `table_1` ,  `table_2` USING `table_1` ,  `table_2` ,  `table_3` WHERE `table_1`.`id`  =  `table_2`.`id`  &&  `table_2`.`id`  =  `table_3`.`id`
Возможность многотабличного удаления записей появилась в MySQL начиная с версии 4.0.
Получено с http://spravkaweb.local/index.php/mysql/sql/delete
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:57, 27 февраля 2007.
  • К этой странице обращались 156 раз.
2.49403882027


Справочник по MySQL : SQL : Удаление базы данных MySQL (DROP DATABASE) — Справочник Web-языков

Справочник по MySQL : SQL : Удаление базы данных MySQL (DROP DATABASE)

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Создание базы данных MySQL (CREATE DATABASE)
Главная | ::. | MySQL | ::. | SQL | ::. | Удаление базы данных MySQL (DROP DATABASE)
 |  |  |  |  |  | Создание таблицы в базе данных MySQL (CREATE TABLE)

Для удаления базы данных используется оператор DROP DATABASE.

[править] Синтаксис:

DROP DATABASE [IF NOT EXISTS] db_name
db_name
- Задает имя базы данных, которую необходимо удалить.
IF NOT EXISTS
- Если не указать этот параметр, то при попытке удаления не существующей базы данных, возникнет ошибка выполнения команды. Данный параметр доступен в MySQL 3.22 и более поздних версиях.

При выполнении команды DROP DATABASE удаляется как сама база данных, так и все таблицы, которые в ней находятся.

Если производится удаление базы данных, которая символически связана с другой базой данных, то удалиться как сама ссылка, так и оригинальная база данных.

В следующем примере мы удалим базу данных db_test:

DROP DATABASE `db_test`
Получено с http://spravkaweb.local/index.php/mysql/sql/dropdb
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:03, 24 февраля 2007.
  • К этой странице обращались 112 раз.
1.36602091789


Справочник по MySQL : SQL : Удаление таблицы из базы данных MySQL (DROP TABLE) — Справочник Web-языков

Справочник по MySQL : SQL : Удаление таблицы из базы данных MySQL (DROP TABLE)

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Создание таблицы в базе данных MySQL (CREATE TABLE)
Главная | ::. | MySQL | ::. | SQL | ::. | Удаление таблицы из базы данных MySQL (DROP TABLE)
 |  |  |  |  |  | Изменение свойств таблицы : Переименование таблицы (ALTER TABLE RENAME)

Удаление таблицы производится командой DROP TABLE.

[править] Синтаксис оператора DROP TABLE

DROP TABLE [IF EXISTS] tbl_name [, tbl_name,...] [RESTRICT | CASCADE]

Этот оператор удаляет таблицу или таблицы из текущей базы данных.

tbl_name
- Имя удаляемой таблицы.
IF EXISTS
- Если указан этот параметр, то при попытке удаления несущестующей таблицы ошибки не возникнет. В противном случае возникнет ошибка выполнения команды. Данный параметр появился в MySQL начиная с версии 3.22.
RESTRICT и CASCADE
- Не несут никакой функциональности. Оставлены для упрощения переноса программы.

В следующем примере производится удаление таблицы users:

DROP TABLE `users`
Получено с http://spravkaweb.local/index.php/mysql/sql/droptable
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 18:10, 24 февраля 2007.
  • К этой странице обращались 109 раз.
1.45055007935


Справочник по MySQL : SQL : Вставка строки в таблицу INSERT — Справочник Web-языков

Справочник по MySQL : SQL : Вставка строки в таблицу INSERT

 |  |  |  |  |  | Изменение свойств таблицы : Удаление столбцов (ALTER TABLE DROP)
Главная | ::. | MySQL | ::. | SQL | ::. | Вставка строки в таблицу INSERT
 |  |  |  |  |  | Удаление строк из таблицы (DELETE FROM)

Команда MySQL INSERT производит вставку новых строк в таблицу.

[править] Синтаксис команды INSERT

INSERT [LOW_PRIORITY | DELAYED] [IGNORE]
    [INTO] tbl_name [(col_name,...)]
    VALUES (expression,...),(...),...

либо

INSERT [LOW_PRIORITY | DELAYED] [IGNORE]
    [INTO] tbl_name
    SET col_name=expression, col_name=expression, ...

либо

INSERT [LOW_PRIORITY | DELAYED] [IGNORE]
    [INTO] tbl_name [(col_name,...)]
    SELECT ...

[править] Общие положения работы команды INSERT:

tbl_name
- Задает имя таблицы, в которую будет вставлена новая строка. На момент запуска команды INSERT таблица с таким именем должна существовать в базе данных.
LOW_PRIORITY
- Если указан этот параметр, то вставка новой записи будет отложена до тех пор, пока другие сценарии не закончат чтение из этой таблицы. Надо отметить, что если таблица часто используется, то при указании этого параметра может пройти достаточно много времени, прежде чем данная команда будет выполнена.
DELAYED
- Если указан этот параметр, то после выполнения команды INSERT сценарий сразу же получит ответ от БД о успешной вставке новой записи, а запись будет вставлено только после завершения использования данной таблицы другим сценарием. Это может быть удобно, если требуется высокая скорость работы скрипта. Данный параметр работает только с таблицами типа ISAM и MyISAM. Следуем отметить, что если таблица, в которую происходит вставка записи, в данный момент не используется другими запросами, то команда INSERT DELAYED будет работать медленнее, нежели INSER. Так что рекомендуется использовать параметр DELAYED только при большой нагрузке на таблицу.
IGNORE
- Если некоторые поля таблицы имеют ключи PRIMARY или UNIQUE, и производится вставка новой строки, в которой эти поля имеют дублирующее значение, то действие команды аварийно завершается и выдается ошибка №1062 ("Duplicate entry 'val' for key N"). Если в команде INSERT указано ключевое слово IGNORE, то вставка записей не прерывается, а строки с дублирующими значениями просто не вставляются.

Если MySQL был сконфигурирован с использованием опции DONT_USE_DEFAULT_FIELDS, то команда INSERT будет генерировать ошибку, если явно не указать величины для всех столбцов, которые требуют значений не-NULL.

Для того, чтобы узнать значение, присвоенное полю с ключом AUTO_INCREMENT, можно воспользоваться функцией mysql_insert_id().

Для добавления новых записей в существующую таблицу при помощи команды INSERT существует три основных синтаксиса:

INSERT ... VALUES
- В этом случае в команде четко указывается порядок следования устанавливаемых полей и их значений.
Следующая команда вставит в таблицу users новую запись, присвоив полям name, age, country, city значения Evgen, 26, Russia, Ryazan соответственно:
INSERT INTO `users` (
 `name` ,  `age` ,  `country` ,  `city`
)VALUES(
 'Evgen', 26,  'Russia',  'Ryazan'
)
Если для поля или группы полей, присутствующих в таблице, не установить значение, то используется значение, установленное по умолчанию при создании таблицы:
INSERT INTO `users` (
 `name` ,  `age` ,  `city`
)VALUES(
 'Evgen', 26,  'Ryazan'
)
После выполнения этой команды поле country получит значение по умолчанию.
Если при выполнении команды INSERT не были указаны названия полей, то в VALUES() должны быть указаны значения для всех полей таблицы.
Если список полей таблицы заранее не известен, то его можно узнать при помощи команды:
DESCRIBE `users`
Результатом этой команды будет таблица примерно следующего содержания:
+---------+-------------+------+-----+---------+-------+
| Field   | Type        | Null | Key | Default | Extra |
+---------+-------------+------+-----+---------+-------+
| name    | varchar(50) | YES  |     | NULL    |       |
| age     | int(3)      | YES  |     | NULL    |       |
| country | varchar(64) | NO   |     |         |       |
| city    | varchar(64) | NO   |     |         |       |
+---------+-------------+------+-----+---------+-------+
4 rows in set (0.01 sec)
Здесь обработав полученные данные в поле Field можно получить все поля таблицы.
INSERT ... SET
- В этом случае в команде каждому полю, присутствующему в таблице, присваивается значение в виде имя поля='значение'.
Следующий пример по результату идентичен первому примеру для INSERT ... VALUE:
INSERT INTO `users` SET `name`  =  'Evgen',  `age`  =26,  `country`  =  'Russia',  `city`  =  'Ryazan'
Так же, как и с INSERT ... VALUES, если одному или нескольким полям не задать значение, то установится значение по умолчанию.
В качестве значений полям можно присваивать не только значения, но и выражения. В выражениях разрешено использовать значения полей таблицы, которые уже были установлены в этой команде:
INSERT INTO `tbl_name` SET `field1`  =4,  `field2`  =  `field1`  *  `field1`
или
INSERT INTO `tbl_name` (
 `field1` ,  `field2`
)VALUES( 4,  `field1`  *  `field1`  )
INSERT ... SELECT
- Такой синтаксис позволяет внести в таблицу большое количество записей за один раз, причем из разных таблиц.
Следующий пример запишет в таблицу users_new все записи из таблицы users, в которых поле country равно "Russia".
INSERT INTO `users_new` SELECT * FROM `users` WHERE `country`  =  'Russia'
Если для таблицы, в которую происходит вставка записей, не указан список полей, то значения для всех полей будут определены на основании результата работы SELECT.
Если некоторые поля не определены, то для них будут принято значение по умолчанию.
Особенности синтаксиса INSERT ... SELECT:
  • Имя таблицы, в которую вставляются записи, не должна присутствовать в списке таблиц FROM части SELECT, т.к. это может привести к ошибке вставки (ведь условие WHERE части SELECT может найти записи, которые уже вставлены этой командой ранее).
  • Другим сценариям запрещено производить вставку в таблицы, учавствующие в запросе, во время выполнения этого запроса.
  • Столбцы AUTO_INCREMENT работают, как обычно.
Получено с http://spravkaweb.local/index.php/mysql/sql/insert
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:45, 27 февраля 2007.
  • К этой странице обращались 142 раза.
2.11442899704


Справочник по MySQL : SQL : Поиск записей в таблице(SELECT) — Справочник Web-языков

Справочник по MySQL : SQL : Поиск записей в таблице(SELECT)

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Обновление записей в таблице(UPDATE)
Главная | ::. | MySQL | ::. | SQL | ::. | Поиск записей в таблице(SELECT)

Поиск записей осуществляется командой SELECT

SELECT * FROM table_name WHERE (выражение) [order by field_name [desc][asc]]

Эта команда ищет все записи в таблице table_name, которые удовлетворяют выражению выражение.

Если записей несколько, то при указанном предложении order by они будут отсортированы по тому полю, имя которого записывается правее этого ключевого слова (если задано слово desc, то упорядочивание происходит в обратном порядке). В предложении order by могут также задаваться несколько полей.

Особое значение имеет символ *. Он предписывает, что из отобранных записей следует извлечь все поля, когда будет выполнена команда получения выборки. С другой стороны, вместо звездочки можно через запятую непосредственно перечислить имена полей, которые требуют извлечения. Но чаще всего все же пользуются именно *.

Например, нам надо найти в таблице, содержащей сообщения в гостевой книге, все записи, которые оставил определенный пользователь.

// Имя пользователя
$user="Admin";
// name - имя поля в таблице, которое содержит имена пользователей,
// оставивших свои сообщения в гостевой
// db_guest - имя таблицы, содержащей сообщения, оставленные в гостевой
$sql="select * from db_guest where (name='$user')";
$result=mysql_query($sql);
// Находим кол-во записей, удовлетворяющих условию
$rows=mysql_num_rows($result);
echo "$user оставил в гостевой $rows записей.";

Но что делать, если искомый текст не занимает все поле, а является частью этого поля (например, при поиске слова или словосочетания в общем массиве текста)?

Например я использую следующую команду (наверно этот способ не самый лучший, но тем не менее он работает):

// $search - содержит искомый тест
$sql="select * form db_guest where (locate('$search',content)>0)";
$result=mysql_query($sql);

Смысл такой: если кол-во вхождений строки $search в поле content больше 0 (т.е. оно вообще есть), то запись добавляется к остальным найденным записям.

Надо отметить, что указанный способ ищет текст с учетом регистра. Чтобы искать без учета регистра, можно воспользоваться следующей командой:

// $search - содержит искомый тест
$sql="select * form db_guest where (locate(lower('$search'),lower(content))>0)";
$result=mysql_query($sql);

т.е. искомая строка и запись в таблице переводится в верхний регистр и затем производится поиск.

Теперь представим, что у нас есть база сообщений гостевой книги, и нам надо отсортировать сообщения по времени, когда они были оставлены.

Для этого одно из полей таблицы базы должно содержать время записи сообщения.

Сортировка по какому-либо столбцу осуществляется при помощи конструкции order by.

В нашем случае, при учете, что более "свежие" сообщения будут сортироваться верхними:

// time - столбец, содержащий время написания записи
// в формате "UNIX timestamp"
$sql="SELECT * FROM db_guest ORDER BY data DESC";
$result=mysql_query($sql);

Т.е. данные были отсортированны по убыванию.

Если нам надо отсортировать данные по возрастанию, надо вместо ключевого слова DESC применить ASC:

$sql="SELECT * FROM db_guest ORDER BY data ASC";
$result=mysql_query($sql);

Данные также можно отсортировать по нескольким столбцам. Для этого надо названия столбцов указать через запятую. Это может пригодиться, например, если в столбце, по которому производится сортировка, есть несколько одинаковых значений.

$sql="SELECT * FROM db_name ORDER BY field1,field2 ASC";
$result=mysql_query($sql);

Сначало данные сортируются по первому столбцу field1. Затем, если в первом столбце есть несколько одинаковых значений, выполняется дополнительная сортировка по второму столбцу (внутри группы с одинаковыми значениями в первом столбце).

Если требуется, чтобы при поиске выдавались не все найденные записи, а определенная группа, то нужно использовать параметр LIMIT.

В этом параметре задается два значения:

LIMIT start,length
  • start - указывает, с какой позиции нужно выдавать найденные записи
  • length - кол-во записей

Например, нам нужно выбрать из базы данных гостевой книги записи начиная с 20 по 45 (т.е. чтоб вывести 25 записей):

$sql="select * from db_guest limit 20,25";
$result=mysql_query($sql);
Получено с http://spravkaweb.local/index.php/mysql/sql/select
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 10:29, 28 февраля 2007.
  • К этой странице обращались 137 раз.
1.84996318817


Справочник по MySQL : SQL : Обновление записей в таблице(UPDATE) — Справочник Web-языков

Справочник по MySQL : SQL : Обновление записей в таблице(UPDATE)

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Удаление строк из таблицы (DELETE FROM)
Главная | ::. | MySQL | ::. | SQL | ::. | Обновление записей в таблице(UPDATE)
 |  |  |  |  |  | Поиск записей в таблице(SELECT)

Обновление записи осуществляется командой UPDATE.

[править] Синтаксис команды UPDATE

UPDATE [LOW_PRIORITY] [IGNORE] tbl_name
    SET col_name1=expr1 [, col_name2=expr2, ...]
    [WHERE where_definition]
    [LIMIT #]
tbl_name
- Задает имя таблицы, в которой будут обновляться записи. На момент запуска команды UPDATE таблица с таким именем должна существовать в базе данных.
LOW_PRIORITY
- Если указан этот параметр, то обновление записи будет отложена до тех пор, пока другие сценарии не закончат чтение из этой таблицы.
IGNORE
- Если некоторые поля таблицы имеют ключи PRIMARY или UNIQUE, и производится обновление строки, в которой эти поля имеют дублирующее значение, то действие команды аварийно завершается и выдается ошибка №1062 ("Duplicate entry 'val' for key N"). Если в команде INSERT указано ключевое слово IGNORE, то обновление записей не прерывается, а строки с дублирующими значениями просто не изменяются.
SET
- После этого ключевого слова должен идти список полей таблицы, которые будут обновлены и непосредственно сами новые значения полей в виде:
имя поля='значение'
Следующий пример производит обновление поля country у ВСЕХ записей в таблице users:
UPDATE `users` SET `country`  =  'Russia'
А здесь обновление полей country и city у ВСЕХ записей таблицы users:
UPDATE `users` SET `country`  =  'Russia',  `city`  =  'Ryazan'
Если новое значение, присваиваемое командой UPDATE соответствует старому, то обновление этого поля не происходит.
Для задания нового значения можно использовать выражения.
Следующий пример увеличит возраст всех пользователей, записанных в таблице users на один год:
UPDATE `users` SET `age`  =  `age`  +1
WHERE
- Задает условие отбора записей, подлежащих изменению.
Следующий пример изменит название города в записях пользователей с "Ryazan" на "Рязань":
UPDATE `users` SET `city`  =  'Рязань'WHERE `city`  =  'Ryazan'
LIMIT
- Задает максимальное количество строк, которые могут быть изменены.
UPDATE `users` SET `age`  =  `age`  +1LIMIT5
Получено с http://spravkaweb.local/index.php/mysql/sql/update
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 10:25, 28 февраля 2007.
  • К этой странице обращались 133 раза.
1.85761499405


Справочник по MySQL : SQL : Типы данных, используемые в базе данных MySQL — Справочник Web-языков

Справочник по MySQL : SQL : Типы данных, используемые в базе данных MySQL

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Главная | ::. | MySQL | ::. | SQL | ::. | Типы данных, используемые в базе данных MySQL
 |  |  |  |  |  | Создание базы данных MySQL (CREATE DATABASE)

Содержание

  • 1 Целые числа
  • 2 Дробные числа
  • 3 Строки
  • 4 Бинарные данные
  • 5 Дата и время

[править] Целые числа

Общий вид указания типа данных:

префиксINT [UNSIGNED]

Необязательный флаг UNSIGNED задает, что будет создано поле для хранения без знаковых чисел (больших или равных 0).

TINYINT | Может хранить числа от -128 до 127
SMALLINT | Диапазон от -32 768 до 32 767
MEDIUMINT | Диапазон от -8 388 608 до 8 388 607
INT | Диапазон от -2 147 483 648 до 2 147 483 647
BIGINT | Диапазон от -9 223 372 036 854 775 808 до 9 223 372 036 854 775 807

[править] Дробные числа

Точно так же, как целые числа подразделяются в MySQL на несколько разновидностей, MySQL поддерживает и несколько типов дробных чисел.

В общем виде они записываются так:

ИмяТипа[(length, decimals)] [UNSIGNED]

Здесь length - количество знакомест (ширина поля), в которых будет размещено дробное число при его передаче.

decimals - количество знаков после десятичной точки, которые будут учитываться.

UNSIGNED
- задает беззнаковые числа.
FLOAT
Число с плавающей точкой небольшой точности.
DOUBLE
Число с плавающей точкой двойной точности.
REAL
Синоним для DOUBLE.
DECIMAL
Дробное число, хранящееся в виде строки.
NUMERIC
Синоним для DECIMAL.

[править] Строки

Строки представляют собой массивы символов. Обычно при поиске по текстовым полям по запросу SELECT не берется в рассмотрение регистр символов, т.е. строки "Вася" и "ВАСЯ" считаются одинаковыми. Кроме того, если база данных настроена на автоматическую перекодировку текста при его помещении и извлечении, эти поля будут храниться в указанной вами кодировке.

Для начала ознакомимся с типом строки, которая может хранить не более length символов, где length принадлежит диапазону от 1 до 255.

VARCHAR (length) [BINARY]

При занесении некоторого значения в поле такого типа из него автоматически вырезаются концевые пробелы. Если указан флаг BINARY, то при запросе SELECT строка будет сравниваться с учетом регистра.

VARCHAR | Может хранить не более 255 символов.
TINYTEXT | Может хранить не более 255 символов.
TEXT | Может хранить не более 65 535 символов.
MEDIUMTEXT | Может хранить не более 16 777 215 символов.
LONGTEXT | Может хранить не более 4 294 967 295 символов.

Чаще всего применяется тип TEXT, но если вы не уверены, что данные не будут превышать 65 536 символов, используйте LONGTEXT.

[править] Бинарные данные

Бинарные данные - это почти то же самое, что и данные в формате TEXT, но только при поиске в них учитывается регистр символов.

TINYBLOB | Может хранить не более 255 символов.
BLOB | Может хранить не более 65 535 символов.
MEDIUMBLOB | Может хранить не более 16 777 215 символов.
LONGBLOB | Может хранить не более 4 294 967 295 символов.

BLOD-данные не перекодируются автоматически, если при работе с установленным соединением включена возможность перекодирования текста "на лету".

[править] Дата и время

MySQL поддерживает несколько типов полей, специально приспособленных для хранения дат и времени в различных форматах.

DATE | Дата в формате ГГГГ-ММ-ДД
TIME | Время в формате ЧЧ:ММ:СС
DATETIME | Дата и время в формате ГГГГ-ММ-ДД ЧЧ:ММ:СС
TIMESTAMP | Дата и время в формате timestamp. Однако при получении значения поля оно отображается не в формате timestamp, а в виде ГГГГММДДЧЧММСС, что сильно умаляет преимущества его использования в PHP
Получено с http://spravkaweb.local/index.php/mysql/sql/vartype
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:09, 20 февраля 2007.
  • К этой странице обращались 169 раз.
1.27799391747


Справочник по MySQL : SQL : Изменение свойств таблицы : Вставка столбцов (ALTER TABLE ADD) — Справочник Web-языков

Справочник по MySQL : SQL : Изменение свойств таблицы : Вставка столбцов (ALTER TABLE ADD)

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Переименование таблицы (ALTER TABLE RENAME)
Главная | ::. | MySQL | ::. | SQL | ::. | Изменение свойств таблицы | ::. | Вставка столбцов (ALTER TABLE ADD)
 |  |  |  |  |  |  |  | Изменение свойств столбца (ALTER TABLE CHANGE)

Вставку нового столбца можно осуществить при помощи следующей конструкции:

ALTER TABLE table_name ADD field_name parametrs
table_name
- имя таблицы, в которой будет вставлен новый столбец;
field_name
- имя вставляемого столбца;
parametrs
- параметры, описывающие вставляемый столбец.

Обязательным параметром является указание типа данных. (Про возможные типы данных подробно написано в Создание и удаление таблицы).

Например, нам надо вставить в таблицу my_frends столбец под названием adress_2, который будет содержать текстовые значения:

$sql="ALTER TABLE my_frends ADD adress_2 TEXT";
mysql_query($sql);

По умолчанию новый столбец вставляется в конец таблицы.

Если необходимо, чтобы столбец встал в начало таблицы, нужно после параметров вставляемого столбца написать ключевое слово FIRST:

$sql="ALTER TABLE my_frends ADD adress_2 TEXT FIRST";
mysql_query($sql);

Теперь только что вставленный столбец окажется вначале таблицы.

Если необходимо, чтобы столбец был вставлен не в начале таблицы, и не в конце, а после определенного столбца, то нужно применить ключевое слово AFTER имя столбца, после которого будет установлен новый столбец:

$sql="ALTER TABLE my_frends ADD adress_2 TEXT AFTER adress_1";
mysql_query($sql);

В этом примере новый столбец adress_2 будет установлен после столбца adress_1.

Если нужно дописать к таблице не один, а несколько столбцов, то для каждого столбца нужно ADD field_name parametrs записать через запятую:

$sql="ALTER TABLE my_frends ADD adress_2 TEXT,
      ADD adress_3 TEXT, ADD adress_4 TEXT";
mysql_query($sql);

В случае, если надо дописать два столбца внутри таблицы, можно поступить следующим образом:

$sql="ALTER TABLE my_frends ADD adress_2 TEXT AFTER adress_1,
      ADD adress_3 TEXT AFTER adress_2";
mysql_query($sql);

Т.е. мы первый вставляемый столбец записываем после adress_1, а второй после первого.

Получено с http://spravkaweb.local/index.php/mysql/sql/altertable/add
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 18:53, 24 февраля 2007.
  • К этой странице обращались 96 раз.
1.25636482239


Справочник по MySQL : SQL : Изменение свойств таблицы : Изменение свойств столбца (ALTER TABLE CHANGE) — Справочник Web-языков

Справочник по MySQL : SQL : Изменение свойств таблицы : Изменение свойств столбца (ALTER TABLE CHANGE)

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Вставка столбцов (ALTER TABLE ADD)
Главная | ::. | MySQL | ::. | SQL | ::. | Изменение свойств таблицы | ::. | Изменение свойств столбца (ALTER TABLE CHANGE)
 |  |  |  |  |  |  |  | Удаление столбцов (ALTER TABLE DROP)

Изменить свойства одного или нескольких столбцов можно при помощи следующей конструкции:

ALTER TABLE table_name CHANGE field_name_old field_name_new parametrs
table_name
- имя таблицы, в которой находится изменяемый столбец;
field_name_old
- имя столбца изменяемого столбца;
field_name_new
- новое имя изменяемого столбца (должно равняться field_name_old, если мы не хотим поменять имя столбца);
parametrs
- новые параметры столбца.

В следующем примере установим тип строки field_1 как текст:

$sql="ALTER TABLE my_table CHANGE field_1 field_1 TEXT";
mysql_query($sql);

А если необходимо при этом еще и переименовать столбец в field_2, то получиться так:

$sql="ALTER TABLE my_table CHANGE field_1 field_2 TEXT";
mysql_query($sql);

В случае, если надо изменить свойства сразу нескольких столбцов, то конструкцию CHANGE field_name_old field_name_new parametrs повторяем через запятую для каждого столбца:

$sql="ALTER TABLE my_table CHANGE field_1 field_2 TEXT,
      CHANGE field_3 field_3 TEXT";
mysql_query($sql);
Получено с http://spravkaweb.local/index.php/mysql/sql/altertable/change
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 12:19, 25 февраля 2007.
  • К этой странице обращались 69 раз.
1.53804588318


Справочник по MySQL : SQL : Изменение свойств таблицы : Удаление столбцов (ALTER TABLE DROP) — Справочник Web-языков

Справочник по MySQL : SQL : Изменение свойств таблицы : Удаление столбцов (ALTER TABLE DROP)

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Изменение свойств столбца (ALTER TABLE CHANGE)
Главная | ::. | MySQL | ::. | SQL | ::. | Изменение свойств таблицы | ::. | Удаление столбцов (ALTER TABLE DROP)
 |  |  |  |  |  |  |  | Вставка строки в таблицу INSERT

Удаление столбца можно сделать при помощи следующей конструкции:

ALTER TABLE table_name DROP field_name
table_name
- имя таблицы, в которой будет удален столбец;
field_name
- имя удаляемого столбца.
$sql="ALTER TABLE search DROP id_num";
mysql_query($sql);

Если мы хотим удалить сразу несколько полей, то надо через запятую повторить DROP field_name для каждого столбца:

$sql="ALTER TABLE search DROP id_1, DROP id_2, DROP id_3";
mysql_query($sql);
Получено с http://spravkaweb.local/index.php/mysql/sql/altertable/drop
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 12:21, 25 февраля 2007.
  • К этой странице обращались 63 раза.
1.3541560173


Справочник по MySQL : SQL : Изменение свойств таблицы : Переименование таблицы (ALTER TABLE RENAME) — Справочник Web-языков

Справочник по MySQL : SQL : Изменение свойств таблицы : Переименование таблицы (ALTER TABLE RENAME)

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Удаление таблицы из базы данных MySQL (DROP TABLE)
Главная | ::. | MySQL | ::. | SQL | ::. | Изменение свойств таблицы | ::. | Переименование таблицы (ALTER TABLE RENAME)
 |  |  |  |  |  |  |  | Вставка столбцов (ALTER TABLE ADD)

Изменение свойств таблицы производиться при помощи команды ALTER TABLE.

[править] Синтаксис команды ALTER TABLE

ALTER [IGNORE] TABLE tbl_name alter_specification [, alter_specification ...]

Команда ALTER TABLE позволяет изменять внутреннюю структуру уже существующей таблицы.

tbl_name
- Задает имя таблицы, в которой будут производиться изменения.
IGNORE
- Если этот параметр не задан, то при обнаружении дублирующих значений в уникальных ключах в новой таблице производиться отмена всех изменений. В противном случае при обнаружении дублирующих значений в уникальных ключах первая запись с дублирующим ключем остается, а остальные удаляются.
alter_specification
- Задает непосредственно само действие, которое должно быть произведено с таблицей.
Возможные синтаксисы:
ADD [COLUMN] create_definition [FIRST | AFTER column_name ]
ADD [COLUMN] (create_definition, create_definition,...)
ADD INDEX [index_name] (index_col_name,...)
ADD PRIMARY KEY (index_col_name,...)
ADD UNIQUE [index_name] (index_col_name,...)
ADD FULLTEXT [index_name] (index_col_name,...)
ADD [CONSTRAINT symbol] FOREIGN KEY index_name (index_col_name,...) [reference_definition]
ALTER [COLUMN] col_name {SET DEFAULT literal | DROP DEFAULT}
CHANGE [COLUMN] old_col_name create_definition [FIRST | AFTER column_name]
MODIFY [COLUMN] create_definition [FIRST | AFTER column_name]
DROP [COLUMN] col_name
DROP PRIMARY KEY
DROP INDEX index_name
DISABLE KEYS
ENABLE KEYS
RENAME [TO] new_tbl_name
ORDER BY col
table_options
  • ADD [COLUMN] create_definition [FIRST | AFTER column_name ]
Используется для добавления нового поля в таблицу. При этом можно четко указать позиционирование нового поля.
  • COLUMN
- Необязательный параметр, который может быть опущен.
  • create_definition
- Определение имени и свойств нового столбца. Синтаксис идентичен определению столбца при создании таблицы (CREATE TABLE).
  • FIRST
- Указывает, что новое поле необходимо добавить в самое начало списка полей таблицы (по умолчанию новое поле добавляется в конец списка).
  • AFTER column_name
- Задает имя поля в таблице, после которого будет добавлено новое поле.
Допустим, у нас есть таблица users со следующими полями: name, age
Добавим новое поле country в конец списка:
ALTER TABLE `users` ADD `country` VARCHAR( 64  ) NOT NULL
Список полей таблицы users:
SHOW COLUMNS FROM `users` ;

+---------+-------------+------+-----+---------+-------+
| Field   | Type        | Null | Key | Default | Extra |
+---------+-------------+------+-----+---------+-------+
| name    | varchar(50) | YES  |     | NULL    |       |
| age     | int(3)      | YES  |     | NULL    |       |
| country | varchar(64) | NO   |     |         |       |
+---------+-------------+------+-----+---------+-------+
3 rows in set (0.03 sec)
Добавим новое поле id в начало списка:
ALTER TABLE `users` ADD `id` INT( 11  ) NOT NULL AUTO_INCREMENT PRIMARY KEYFIRST
Список полей таблицы users:
SHOW COLUMNS FROM `users` ;

+---------+-------------+------+-----+---------+----------------+
| Field   | Type        | Null | Key | Default | Extra          |
+---------+-------------+------+-----+---------+----------------+
| id      | int(11)     | NO   | PRI | NULL    | auto_increment |
| name    | varchar(50) | YES  |     | NULL    |                |
| age     | int(3)      | YES  |     | NULL    |                |
| country | varchar(64) | NO   |     |         |                |
+---------+-------------+------+-----+---------+----------------+
4 rows in set (0.00 sec)
Добавим новое поле city перед полем country (т.е. после поля age):
ALTER TABLE `users` ADD `city` VARCHAR( 64  ) AFTER `age`
Список полей таблицы users:
SHOW COLUMNS FROM `users` ;

+---------+-------------+------+-----+---------+----------------+
| Field   | Type        | Null | Key | Default | Extra          |
+---------+-------------+------+-----+---------+----------------+
| id      | int(11)     | NO   | PRI | NULL    | auto_increment |
| name    | varchar(50) | YES  |     | NULL    |                |
| age     | int(3)      | YES  |     | NULL    |                |
| city    | varchar(64) | YES  |     | NULL    |                |
| country | varchar(64) | NO   |     |         |                |
+---------+-------------+------+-----+---------+----------------+
5 rows in set (0.00 sec)
ADD [COLUMN] (create_definition, create_definition,...)
- Добавляет одно поле или группу полей в таблицу.
COLUMN
- Необязательный параметр, который может быть опущен.
create_definition
- Определение имени и свойств нового столбца. Синтаксис идеентичен определению столбца при создании таблицы (CREATE TABLE).
Допустим, у нас есть таблица users со следующими полями:
SHOW COLUMNS FROM `users` ;

+-------+-------------+------+-----+---------+----------------+
| Field | Type        | Null | Key | Default | Extra          |
+-------+-------------+------+-----+---------+----------------+
| id    | int(11)     | NO   | PRI | NULL    | auto_increment |
| name  | varchar(50) | YES  |     | NULL    |                |
| age   | int(3)      | YES  |     | NULL    |                |
+-------+-------------+------+-----+---------+----------------+
3 rows in set (0.00 sec)
Добавим новые поля city и country:
ALTER TABLE `users` ADD(
 `city` VARCHAR( 64  ) NOT NULL,  `country` VARCHAR( 64  ) NOT NULL
)
Список полей таблицы users:
SHOW COLUMNS FROM `users` ;

+---------+-------------+------+-----+---------+----------------+
| Field   | Type        | Null | Key | Default | Extra          |
+---------+-------------+------+-----+---------+----------------+
| id      | int(11)     | NO   | PRI | NULL    | auto_increment |
| name    | varchar(50) | YES  |     | NULL    |                |
| age     | int(3)      | YES  |     | NULL    |                |
| city    | varchar(64) | NO   |     |         |                |
| country | varchar(64) | NO   |     |         |                |
+---------+-------------+------+-----+---------+----------------+
5 rows in set (0.00 sec)
ALTER TABLE table_name_old RENAME table_name_new
  • table_name_old - старое имя таблицы, которое нам нужно переименовать;
  • table_name_new - новое имя таблицы.

Допустим, нам нужно переименовать таблицу search в search_en:

$sql="ALTER TABLE search RENAME search_en";
mysql_query($sql);

Получено с http://spravkaweb.local/index.php/mysql/sql/altertable/rename
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 18:43, 24 февраля 2007.
  • К этой странице обращались 130 раз.
1.49354481697


Указатель элементов справочника : Новости на SpravkaWeb.Ru от 24 марта 2007г — Справочник Web-языков

Указатель элементов справочника : Новости на SpravkaWeb.Ru от 24 марта 2007г

Материал из Справочник Web-языков.

Перейти к: навигация, поиск

Теперь справочником SpravkaWeb.ru стало пользоваться еще удобнее! В систему добавлен указатель элементов справочника!

Находится он на каждой странице сайта в левой панели:

Пользоваться указателем очень просто - Вы начинаете вводить название искомой функции в поле ввода, а система ищет в справочнике элементы, удовлетворяющие уже введенным символам, и выводит внизу список найденных элементов:

Поиск можно конкретизировать по определенному разделу справочника:

Надеюсь, что этот инструмент понравится Вам; упростит и ускорит работу с справочником!

Получено с http://spravkaweb.local/index.php/news/2007/03/24
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 09:35, 25 марта 2007.
  • К этой странице обращались 76 раз.
1.25727581978


Справочник по Perl : Функции обработки массивов скаляров — Справочник Web-языков

Справочник по Perl : Функции обработки массивов скаляров

 |  |  |  | Числовые функции
Главная | ::. | Perl | ::. | Функции обработки массивов скаляров
 |  |  |  | Функции обработки списков

Содержание

  • 1 pop
  • 2 push
  • 3 shift
  • 4 splice
  • 5 unshift

[править] pop

Удаляет из массива скаляров последний элемент и возвращает его значение. Если массив пустой, то возвращает неопределенное значение undef.

pop МАССИВ
pop       (в основной программе эквивалентно pop @ARGV)
pop       (в подпрограмме эквивалентно pop @_)

[править] push

Рассматривает массив, заданный параметром МАССИВ, как стек и добавляет в конец массива элементы списка, определяемого параметром СПИСОК. Возвращает новое количество элементов полученного массива.

push МАССИВ, СПИСОК

[править] shift

Удаляет из массива скаляров первый элемент и возвращает его значение. После удаления элемента оставшиеся сдвигаются влево: второй становится первым, третий вторым и т.д. Если массив пустой, то возвращает неопределенное значение undef.

shift МАССИВ
shift     (в основной программе эквивалентно
shift @ARGV, в подпрограмме эквивалентно
shift @_)

[править] splice

Удаляет из массива заданное КОЛИЧЕСТВО элементов, начиная с элемента, определенного параметром НОМЕР. В случае задания параметра СПИСОК заменяет указанные элементы элемента списка. В списковом контексте возвращает удаленные элементы; в скалярном контексте - последний удаленный элемент. Если параметр КОЛИЧЕСТВО не задан, то удаляются все элементы после элемента с номером, определенным параметром НОМЕР.

splice МАССИВ, НОМЕР[, КОЛИЧЕСТВО[, СПИСОК]]

[править] unshift

Добавляет элементы списка, определенного параметром СПИСОК, в начало массива, заданного параметром МАССИВ. Выполняет действия, противоположные действиям функции shift.

unshift МАССИВ, СПИСОК
Получено с http://spravkaweb.local/index.php/perl/array
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:13, 21 января 2007.
  • К этой странице обращались 109 раз.
1.83185982704


Справочник по Perl : Функции, относящиеся к классам и объектно-ориентированным технологиям — Справочник Web-языков

Справочник по Perl : Функции, относящиеся к классам и объектно-ориентированным технологиям

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  | Функции, относящиеся к модулям Perl
Главная | ::. | Perl | ::. | Функции, относящиеся к классам и объектно-ориентированным технологиям
 |  |  |  | Разные функции

Содержание

  • 1 bless
  • 2 ref
  • 3 tie
  • 4 tied
  • 5 untie

[править] bless

После выполнения функции bless() ссылка на субъект Perl (переменную, массив или хеш), определенная параметром ССЫЛКА, становиться ссылкой на объект, определяемый пакетом с именем, равным значению параметра ИМЯ_КЛАССА. Если этот параметр не задан, то подразумевается текущий пакет.Возвращаемое значение - ссылка на объект.

bless ССЫЛКА, ИМЯ_КЛАССА
bless ССЫЛКА

[править] ref

Если параметр ВЫРАЖЕНИЕ является ссылкой, то возвращает тип субъекта ссылки; в противном случае Ложь. Если параметр опущен, то используется переменная $_. Возвращаемым значением может быть : REF,SCALAR,ARRAY,HASH,CODE,GLOB или имя пакета, если ссылка была переопределена функцией bless().

ref [ВЫРАЖЕНИЕ]

[править] tie

Связывает переменную, определенную параметром ПЕРЕМЕННАЯ, с классом ИМЯ_КЛАССА, который будет обеспечивать реализацию методов доступа для этой переменной, список которых зависит от типа связываемой переменной (скаляр, массив, хеш, дескриптор файла). Операции доступа к связанной переменной (например, получение и присваивание значения для скалярной переменной или присваивание значения элементу массива и т.д.) автоматически вызывают соответствующие методы определенного класса. Элементы параметра СПИСОК передаются соответствующим конструкторам этого класса в зависимости от типа связываемой переменной; TIESCALAR(), TIEARRAY(), TIEHASH() или TIEHANDLE(). Возвращаемым значением функции является объект класса, к которому привязывается переменная.

tie ПЕРЕМЕННАЯ, ИМЯ_КЛАССА, СПИСОК

[править] tied

Возвращает объект класса, с которым связана переменная, определенная параметром ПЕРЕМЕННАЯ, с помощью функции tie().

$object = tied ПЕРЕМЕННАЯ

[править] untie

Разрывает созданную функцией tie() связь между переменной, определенной параметром ПЕРЕМЕННАЯ, и классом, реализующим методы доступа к ней.

untie ПЕРЕМЕННАЯ
Получено с http://spravkaweb.local/index.php/perl/class
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:36, 21 января 2007.
  • К этой странице обращались 97 раз.
1.82879400253


Справочник по Perl : Функции для работы со временем и датой — Справочник Web-языков

Справочник по Perl : Функции для работы со временем и датой

 |  |  |  | Низкоуровневые функции работы с сокетами
Главная | ::. | Perl | ::. | Функции для работы со временем и датой
 |  |  |  | Информация о пользователях и группах

Содержание

  • 1 gmtime
  • 2 localtime
  • 3 time
  • 4 times

[править] gmtime

Преобразует значение даты и времени, полученное функцией time() в 9-элементный массив, соответствующий временной зоне Гринвича. Все элементы массива являются числами. Месяцы ($mon) нумеруются целыми числами от 0 до 11; дни недели ($wday) целыми от 0 до 6, причем 0 соответствует воскресенью; год ($year) отсчитывается от года 1900. В скалярном контексте возвращает такую же структуру даты, что и системная функция ctime(3): "Thu Oct 13 04:54:34 2000"

($sec,$min,$hour,$mday,$mon,$year,$wday,$yday,$isdst)=gmtime(time);

[править] localtime

Полностью соответствует функции gmtime() за исключением того, что значения элементов возвращаемого массива соответствуют зоне местного времени, а не гринвичской.

($sec,$min,$hour,$mday,$mon,$year,$wday,$yday,$isdst)=localtime(time);

[править] time

Возвращает число секунд, прошедших от начала эпохи - 1 января 1970 года.

time

[править] times

Возвращает четырехэлементный массив, содержащий пользовательское и системное время для процесса и порожденного им процесса.

($user,$system,$cuser,$csystem)=times;
Получено с http://spravkaweb.local/index.php/perl/datetime
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:46, 23 января 2007.
  • К этой странице обращались 125 раз.
1.90926790237


Справочник по Perl : Функции для работы с файлами и каталогами — Справочник Web-языков

Справочник по Perl : Функции для работы с файлами и каталогами

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  | Функции ввода/вывода
Главная | ::. | Perl | ::. | Функции для работы с файлами и каталогами
 |  |  |  | Функции, относящиеся к управлению выполнением программы

Содержание

  • 1 -X
  • 2 chdir
  • 3 chmod
  • 4 chown
  • 5 chroot
  • 6 close
  • 7 closedir
  • 8 fcntl
  • 9 glob
  • 10 ioctl
  • 11 link
  • 12 lstat
  • 13 mkdir
  • 14 open
  • 15 opendir
  • 16 readlink
  • 17 rename
  • 18 stat
  • 19 symlink
  • 20 umask
  • 21 unlink
  • 22 utime

[править] -X

В Perl предусмотрен набор унарных операций, возвращающих значение только одного поля структуры индексного дескриптора. Эти операции в документации называются "операциями -X", так как их названия состоят из дефиса с последующим единственным символом. Все они являются унарными именованными операциями и имеют свой приоритет в сложных выражениях.

Полный перечень унарных операций проверки файлов

-r
Файл может читаться эффективным uid/gid
-w
Записывать в файл может эффективный uid/gid
-x
Файл может выполняться эффективным uid/gid
-o
Владельцем файла является эффективный uid/gid
-R
Файл может читаться действительным uid/gid
-W
Записывать в файл может действительный uid/gid
-X
Файл может выполняться действительным uid/gid
-O
Владельцем файла является действительный uid/gid
-e
Файл существует
-z
Размер файла равен нулю
-s
Размер файла отличен от нуля (возвращает размер)
-f
Файл является обычным (plain) файлом
-d
Файл является каталогом
-l
Файл является символической ссылкой
-p
Файл является именованным програмным каналом (FIFO) или проверяемый дескриптор связан с програмным каналом
-S
Файл является сокетом
-b
Файл является специальным блочным файлом
-c
Файл является специальным символьным файлом
-t
Дескриптор файла связан с терминалом
-u
У файла установлен бит setuid
-g
У файла установлен бит setgid
-k
У файла установлен бит запрета (sticky bit)
-T
Файл является текстовым файлом
-B
Файл является двоичным (противоположным текстовому)
-M
Возраст файла в днях на момент выполнения программы
-A
То же для врмени последнего обращения к файлу
-C
То же для время последней модификации индексного дескриптора файла

Унарные операции применяются к строке, содержащей имя файла, к выражению, вычисляемым значением которого является имя файла, или к файловому дескриптору Perl. Если параметр операции не задан, то она тестирует файл, чье имя содержится в специальной переменной $_. Каждая операция проверки атрибута файла возвращает 1, если файл обладает соответствующим атрибутом, пустую строку "" в противном случае и неопределенное значение undef, если указанный в параметре файл не существует.

Несколько слов об алгоритме определения текстовых и двоичных файлов (операции -T и -B). Эти операции анализируют содержимое первого блока файла на наличие "странных" символов - необычных управляющих последовательностей или байтов с установленными старшими битами. Если обнаружено достаточно большое количество подобных символов (больше 30%), то файл считается двоичным, иначе текстовым. Любой файл с пустым первым блоком рассматривается как двоичный.

Если эти операции применяются к файловым дескрипторам Perl, то проверяется содержимое буфера ввода/вывода, а не первого блока файла. Обе эти операции, примененные к файловым дескрипторам, возвращают булево значение Истина, если связанный с дескриптором файл пуст или установлен на конец файла.

При выполнении унарных именованных операций проверки файла на самом деле неявно вызывается функция stat(), причем результаты ее вычисления кэшируются, что позволяет использовать специальный файловый дескриптор _ для ускорения множественных проверок файла:

if( -s("filename") && -T _) {
# Что-то делаем для текстовых файлов не нулевого размера
. . . . . . . . . . . . . .
}

[править] chdir

Изменение текущего рабочего каталога на каталог, определяемый значением параметра ВЫРАЖЕНИЕ. Если параметр опущен, домашний каталог становится текущим. Возвращает бклево значение Истина в случае успешного выполнения операции замены текущего каталога и Ложь в противном случае.

chdir [ВЫРАЖЕНИЕ]

[править] chmod

chmod СПИСОК

Функция chmod() изменяет права доступа для файлов, представленных в списке, переданном ей в качестве параметра. Первым элементом этого списка должно быть трехзначное восьмеричное число, задающее права доступа для владельца, пользователей из группы, в которую входит владелец, и прочих пользователей. Каждая восьмеричная цифра определяет право на чтение файла, запись в файл и его выполнение (в случае если файл представляет выполняемую программу) для указанных выше групп пользователей. Установленные биты ее двоичного представления отражают соответствующие права доступа к файлу. Например, если установлены все три бита (восьмеричное число 7), то соответствующая группа пользователей обладает всеми перечисленными правами: может читать из файла, записывать в файл и выполнять его. Значение равное 6 определяет право на чтение и запись, 5 позволяет читать из файла, выполнять его, но не позволяет записывать в этот файл и т.д. Обычно не выполняемый файл создается с режимом доступа 0666 - все пользователи могут читать и записывать информацию в файл, выполняемый файл - с режимом 0777. Если владелец файла желает ограничить запись в файл пользователей не его группы, то следует выполнить следующий оператор:

chmod 0664, "file.dat";

Возвращаемым значением функции chmod(), как и функции chown(), является количество файлов из списка, для которых операция изменения прав доступа завершилась успешно.

В операционных системах DOS и Windows имеет значение только установка режимов доступа владельца.

[править] chown

chown СПИСОК

Любой пользователь, создавший собственный файл, считается его владельцем. Изменить владельца файла из сценария Perl можно функцией chown(). Параметром этой функции является список, первые два элемента которого должны представлять числовые идентификаторы uid и gid. Остальные элементы списка являются именами файлов, для которых изменяется владелец. Эта функция возвращает количество файлов, для которых операция изменения владельца и группы прошла успешно.

Пример:

@list = (234, 3, "file1.dat", "file2.dat");
$number = chown(@list);
warn "Изменился владелец не у всех файлов!" if $number != @list-2;

Изменить владельца файла может только сам владелец или суперпользователь (обычно системный администратор) системы UNIX. В операционных системах с файловой системой отличной от UNIX (DOS, Windows) эта функция отрабатывает, но ее установки не влияют на доступ к файлу.

[править] chroot

Определяет новый корневой каталог для всех относительных (начинающихся с косой черты "/") имен файлов процесса пользователя и порожденных им процессов. Не меняет текущий рабочий каталог. В отсутствии параметра используется значение специальной переменной $_. Может вызываться только суперпользователем.

chroot ИМЯ_КАТАЛОГА

[править] close

close ДЕСКРИПТОР

По завершению работы с файлом он закрывается функцией close(). Единственным необязательным параметром этой функции является дескриптор, ассоциированный с файлом.

Эта функция возвращает значение Истина, если успешно очищен буфер ввода/вывода и закрыт системный дескриптор файла. Вызванная без параметра, функция close закрывает файл, связанный с текущим дескриптором, установленным функцией select().

При возникновении ошибок закрытия файла их можно обнаружить применяя специальную переменную $!: close ( FILE ) or die "Ошибка закрытия файла: $!";

[править] closedir

Закрывает каталог, ассоциированный с дескриптором каталога, заданным параметром ДЕСКРИПТОР. Возвращает булево значение Истина, если каталог успешно закрыт.

closedir ДЕСКРИПТОР

[править] fcntl

Реализует системную команду Unix fcntl(2). Перед использованием следует получить доступ к определениям системных констант оператором use Fcntl.

Возвращаемое значение: если системная функция возвращает -1, то функция Perl - неопределенное значение; если системная функция возвращает 0, то функция Perl строку "0 but true"; если системная функция возвращает какое-либо другое значение, функция Perl возвращает это же значение.

fcntl ДЕСКРИПТОР, ФУНКЦИЯ, СКАЛЯР

[править] glob

Возвращает найденные в текущем каталоге файлы, имена которых удовлетворяют заданному шаблону (с использованием метасимволов Unix "*","?"). Значением выражения должна быть строка, содержащая шаблон имен файлов.

glob ВЫРАЖЕНИЕ

[править] ioctl

Реализует системную команду Unix ioctl(2). Перед использованием следует получить доступ к определениям системных констант оператором require "ioctl.ph";

Возвращаемое значение:

  • если системная функция возвращает -1, то функция Perl - неопределенное значение;
  • если системная функция возвращает 0, то функция Perl строку "0 but true";
  • если системная функция возвращает какое-либо другое значение, функция Perl возвращает это же значение.
fcntl ДЕСКРИПТОР, ФУНКЦИЯ, СКАЛЯР

[править] link

Создает новую "жесткую" ссылку на файл, заданный параметром СТАРЫЙ. Возвращает булево значение Истина в случае успешного создания ссылки и Ложь в противном случае.

link СТАРЫЙ, НОВЫЙ

[править] lstat

Возвращает список значений полей структуры индекснего дескриптора символической ссылки на файл. Если параметр опущен, то используется значение специальной переменной $_.

lstat [ДЕСКРИПТОР]
lstat [ВЫРАЖЕНИЕ]

Используется для получения информации о символических ссылках. Возвращает список значений полей структуры индексного дескриптора самой ссылки, а не файла, на который она ссылается. Эта функция работает аналогично функции stat().

[править] mkdir

Создание нового каталога с именем, заданным в параметре КАТАЛОГ, и режимом доступа, определяемым параметром РЕЖИМ. При успешном создании каталога возвращает булево значение Истина, в противном случае Ложь и в переменную $! заносится сообщение об ошибке.

mkdir КАТАЛОГ, РЕЖИМ

[править] open

open ДЕСКРИПТОР, ИМЯ_ФАЙЛА;
open ДЕСКРИПТОР;

Для доступа к файлу из программы Perl необходим дескриптор. Для создания дескриптора используется функция open(). При выполнении операции open с заданым в параметрах именем файла открывается соответствующий файл и создается дескриптор этого файла. В качестве дескриптора файла можно использовать выражение - его значение и будет именем дескриптора. Имя файла задается непосредственно в виде строкового литерала или выражения, значением которого является строка. Операция open без имени файла открывает файл, имя которого содержится в скалярной переменной $ДЕСКРИПТОР, которая не может быть лексической переменной, определенной функцией my().

Пример:

#! perl -w
$var = "out.dat";
$FILE4 = "file4.dat";
open FILE1, "in.dat";                # Имя файла задано строкой
open FILE2, $var;                    # Имя файла задано
   переменной
open FILE3, "/perlourbook/01/".$var; # Имя файла вычисляется
   в выражении
open FILE4;                          # Имя файла в
   переменной $FILE4

Если задано не полное имя файла, то открывается файл с указанным именем и расположенный в том же каталоге, что и программа Perl. Можно задавать полное имя файла, однако следует иметь в виду, что оно зависит от используемой операйионной системы. Например, в Windows следует обязательно задавать имя диска: d:/perlbook/file1.doc

Любой файл можно открыть в одном из следующих режимов: чтения, записи или добавления в конец файла. Это осуществляется присоединением соответствующего префикса к имени файла:

  • < (чтение)
  • > (запись)
  • >> (добавление)

Если префикс опущен, то по умолчанию файл открывается в режиме чтения.

Запись информации в файл, открытый в режиме записи, осуществляется в начало файла, что приводит к уничтожению содержащейся в нем до его открытия информации.

Информация, содержащаяся в файле, открытом в режиме добавления, не уничтожается, новые записи добавляются в конец файла.

Если при открытии файла в режиме записи или добавления не существует файла с указанным именем, то он создается, что оличает эти режимы открытия файла от режима чтения, при котором файл должен существовать. В противном случае операция открытия завершается с ошибкой и соответствующий дескриптор не создается.

Perl позволяет открыть файл еще в одном режиме - режиме чтения/записи.

Для этого перед префиксом чтения <, записи > или добавления >> следует поставить знак +.

  • +< - сохраняют содержимое открываемого файла
  • +> - сначало очищает содержимое открываемого файла
  • +>> - сохраняют содержимое открываемого файла, запись в файл всегда осуществляется в конец содержимого файла

[править] opendir

Открытие каталога, имя которого равно значению параметра ВЫРАЖЕНИЕ, и связывает его с дескриптором, определяемым параметром ДЕСКРИПТОР. Имена дескрипторов каталогов хранаятся в собственном пространстве имен таблицы имен Perl.

opendir ДЕСКРИПТОР, ВЫРАЖЕНИЕ

[править] readlink

Возвращает значение сиволической ссылки, определяемой параметром ВЫРАЖЕНИЕ, если символические ссылки реализуются операционной системой; в противном случае - фатальная ошибка. Если при получении значения символической ссылки были получены системные ошибки, возвращает неопределенное значение и в специальную переменную $! заносится сообщение об ошибке. Если параметр опущен, используется значение переменной $_.

readlink [ВЫРАЖЕНИЕ]

[править] rename

Переименовывает файл. Возвращает 1 в случае успешного переименования и 0 в противном случае.

rename СТАРОЕ_ИМЯ, НОВОЕ_ИМЯ

[править] stat

В файловой структуре UNIX информация о файле храниться в его индексном дескрипторе (штщву). Структура индексного дескриптора состоит из 13 полей, для которых используются специальные обозначения:

Поле | Описание
dev | Номер устройства в файловой системе
ino | Номер индексного дескриптора
mode | Режим файла (тип и права доступа)
nlink | Количество жестких ссылок на файл (в отсутствии ссылок равно 1)
uid | Числовой идентификатор владельца файла
gid | Числовой идентификатор группы владельца файла
rdev | Идентификатор устройства (только для специальных файлов)
size | Размер файла в байтах
atime | Время последнего обращения к файлу с начала эпохи
mtime | Время последнего изменения файла с начала эпохи
ctime | Время изменения индексного дескриптора с начала эпохи
blksize | Предпочтительный размер блока для операций ввода/вывода
blocks | Фактическое количество выделенных блоков для размещения файла

Начало эпохи датируется 1 января 1970 года 0 часов 0 минут.

Не все перечисленные поля структуры индексного дескриптора поддерживаются всеми файловыми системами.

Функция stat() предназначена для получения значений полей структуры индексного дескриптора файла. Ее единственным параметорм может быть либо имя файла, либо дескриптор открытого в программе файла. Она возвращает список из 13 элементов, содержащих значения полей структуры индексного дескриптора файла в том порядке, как они перечислены в таблице.

Типичное использование в программе Perl представлено ниже:

($dev,$ino,$mode,$nlink,$uid,$gid,$rdev,$size,
$atime,$mtime,$ctime,$blksize,$blocks) = stat($filename);

Присваивание значение полей списку скалярных переменных с идентификаторами, соответствующими названиям полей, способствует лучшей читаемости программы, чем присваивание массиву скаляров:

@inode = stat($filename);

В последнем случае получить значение соответствующего поля можно только с помощью индекса, что не совсем удобно, так как нужно помнить номер нужного поля структуры.

Если при обращении к функции stat() не указан параметр, то она возвращает структуру индексного дескриптора файла, чье имя содержится в специальной переменной $_.

Функция получения информации о файле при успешном выполнении в списковом контексте возвращает список значений полей структуры индексного дескриптора файла или пустой список в случае неудачного завершения. В скалярном контексте она возвращает булево значение Истина или Ложь в зависимости от результатов своего выполнения.

Для удобства использования информации о файле функция stat() при успешном выполнении кэширует полученные значения полей. Если вызвать эту функцию со специальным дескриптором файла _ (символ подчеркивания), то она возвратит информацию, хранящуюся в кэше от предыдущего ее вызова. Это позволяет проверять различные атрибуты файла без повторного вызова функции stat() или сохранения результатов ее выполнения в переменных программы.

Функцию stat() можно использовать для получения структуры индексного дескриптора не только файла, но и жестких ссылок на него, а также каталогов, так как они являются также файлами, блоки данных которых содержат имена файлов каталога и их числовых индексных дескрипторов.

[править] symlink

Создание символической ссылки (параметр НОВОЕ_ИМЯ) на файл (параметр СТАРОЕ_ИМЯ). Возвращает 1 в случае успешного создания символической ссылки и 0 в противном случае.

symlink СТАРОЕ_ИМЯ, НОВОЕ_ИМЯ

[править] umask

Устанавливает маску режима доступа процесса, заданную значением параметра ВЫРАЖЕНИЕ (восьмеричное число), и возвращает предыдущее значение маски режима доступа.

umask ВЫРАЖЕНИЕ

[править] unlink

Удаление файлов, определенных параметром СПИСОК. Возвращает количество успешно удаленных файлов.

unlink СПИСОК

[править] utime

utime СПИСОК

В структуре индексного дескриптора файла существует три поля, в которых храниться время последнего обращения (atime) к файлу, его изменения (mtime) файла и изменения индексного дескриптора (ctime). Функцией utime() можно изменить время последнего обращения и модификации файла. Ее параметром является список, содержащий имена обрабатываемых файлов, причем первые два элемента списка - числовые значения нового времени последнего доступа и модификации:

@files = ("file1.dat", "file2.dat");
$now = time;
utime $now, $now, @files;

В этом фрагменте кода время последнего доступа и модификации файлов из списка @files изменяется на текущее время, полученное с помощью функции time.

Отметим, что при выполнении функции utime() изменяется и время последней модификации индексного дескриптора (ctime) - оно устанавливается равным текущему времени. Возвращаемым значением является количество файлов, для которых операция изменения времени последнего доступа и модификации прошла успешно.

Получено с http://spravkaweb.local/index.php/perl/file
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:22, 21 января 2007.
  • К этой странице обращались 152 раза.
1.29944801331


Справочник по Perl — Справочник Web-языков

Справочник по Perl

Главная ::. Perl

[править] Разделы справки

  • Функции обработки строк и скаляров
  • Функции, связанные с регулярными выражениями
  • Числовые функции
  • Функции обработки массивов скаляров
  • Функции обработки списков
  • Функции обработки хеш-массивов
  • Функции ввода/вывода
  • Функции для работы с файлами и каталогами
  • Функции, относящиеся к управлению выполнением программы
  • Функции, относящиеся к области видимости переменных
  • Функции, относящиеся к модулям Perl
  • Функции, относящиеся к классам и объектно-ориентированным технологиям
  • Разные функции
  • Функции для работы с процессами и группами процессов
  • Низкоуровневые функции работы с сокетами
  • Функции для работы со временем и датой
  • Информация о пользователях и группах
  • Сетевая информация
  • Функции взаимодействия между процессами
  • Стандартные модули Perl
  • Специальные переменные

[править] Полезные ссылки

  • Форум по Perl
Получено с http://spravkaweb.local/index.php/perl
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 12:47, 20 марта 2007.
  • К этой странице обращались 343 раза.
1.21914100647


Справочник по Perl : Информация о пользователях и группах — Справочник Web-языков

Справочник по Perl : Информация о пользователях и группах

 |  |  |  | Функции для работы со временем и датой
Главная | ::. | Perl | ::. | Информация о пользователях и группах
 |  |  |  | Сетевая информация

Содержание

  • 1 endpwent
  • 2 getpwent
  • 3 getpwnam
  • 4 getpwuid
  • 5 setpwent
  • 6 endgrent
  • 7 getgrgid
  • 8 getgrnam
  • 9 setgrent
  • 10 getlogin

[править] endpwent

Закрытие файла паролей после завершения обработки его содержимого.

endpwent

[править] getpwent

Возвращает следующую запись файла паролей при очередном вызове.

getpwent

[править] getpwnam

Получение записи из файла паролей от пользователя по его регистрационному имени.

getpwnam ИМЯ

[править] getpwuid

Получение записи из файла паролей от пользователя по его числовому идентификатору, заданному параметром UID.

getpwuid UID

[править] setpwent

Позиционирование файла паролей на первую запись. последующий вызов функции getpwent() начинает его обработку с первой записи.

setpwent

[править] endgrent

Закрытие файла групп после завершения обработки его содержимого.

[править] getgrgid

Получение записи из файла групп о группе по его числовому идентификатору, заданному параметром GID.

getgrgid GID

[править] getgrnam

Получение записи из файла групп о группе по ее имени, заданному параметром ИМЯ.

getgrnam ИМЯ

[править] setgrent

Позиционирование файла групп на первую запись. Последующий вызов функции getgrent() начинает его обработку с первой записи.

setgrent

[править] getlogin

Возвращает регистрационное имя пользователя на рабочей станции, где выполняется программа Perl.

getlogin
Получено с http://spravkaweb.local/index.php/perl/infouser
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:49, 23 января 2007.
  • К этой странице обращались 96 раз.
1.81740403175


Справочник по Perl : Функции обработки списков — Справочник Web-языков

Справочник по Perl : Функции обработки списков

 |  |  |  | Функции обработки массивов скаляров
Главная | ::. | Perl | ::. | Функции обработки списков
 |  |  |  | Функции обработки хеш-массивов

Содержание

  • 1 grep
  • 2 join
  • 3 map
  • 4 reverse
  • 5 sort
  • 6 unpack

[править] grep

Вычисляет блок операторов БЛОК или ВЫРАЖЕНИЕ для всех элементов списка, заданного параметром СПИСОК, локально устанавливая значение специальной переменной <>$_ равным значению элемента списка. В списковом контексте возвращается список элементов, для которых ВЫРАЖЕНИЕ вычисляется равным Истина. В скалярном контексте - количество раз, когда ВЫРАЖЕНИЕ вычислялось равным Истина.

grep БЛОК СПИСОК
grep ВЫРАЖЕНИЕ, СПИСОК

[править] join

Соединяет отдельные строковые элементы списка параметра СПИСОК в одну строку, вставляя между ними разделитель, равный значению параметра ВЫРАЖЕНИЕ и возвращает полученную строку.

join ВЫРАЖЕНИЕ, СПИСОК

[править] map

Вычисляет блок операторов БЛОК или ВЫРАЖЕНИЕ для всех элементов списка, заданного параметром СПИСОК, локально устанавливая значение специальной переменной $_ равным значению элемента списка. Возвращает список элементов, составленный из результатов указанных вычислений для каждого элемента заданного списка. Операторы из БЛОК и ВЫРАЖЕНИЕ вычисляются в списковом контексте.

map БЛОК СПИСОК
map ВЫРАЖЕНИЕ, СПИСОК

[править] reverse

В списковом контексте возвращает список значений элементов заданного параметром СПИСОК списка в обратном порядке. В скалярном контексте соединяет все элементы списка в одну строку и возвращает строку, в которой символы расположены в обратном порядке.

reverse СПИСОК

[править] sort

Сортирует список значений, определенный параметром СПИСОК. Если параметры БЛОК или ПОДПРОГРАММА не заданы, то используется стандартная процедура сравнения строковых данных; если заданы, то операторы блока или подпрограмма используются в качестве процедуры сравнения при сортировки элементов списка. Возвращает отсортированный список значений исходного списка.

sort [ПОДПРОГРАММА] СПИСОК
sort [БЛОК] СПИСОК

[править] unpack

Выполняет обратные действия относительно действий функции pack(): берет строку (параметр ВЫРАЖЕНИЕ), представляющую двоичную структуру упакованного массива или списка значений, и распаковывает ее в соответствии с заданным параметром ШАБЛОН шаблоном. В списковом контексте возвращает массив полученных значений, в скалярном - значение первого полученного элемента массива. Шаблон должен быть такой же, как и в функции pack().

unpack ШАБЛОН, ВЫРАЖЕНИЕ
Получено с http://spravkaweb.local/index.php/perl/list
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:16, 21 января 2007.
  • К этой странице обращались 111 раз.
2.22822594643


Справочник по Perl : Стандартные модули Perl — Справочник Web-языков

Справочник по Perl : Стандартные модули Perl

 |  |  |  | Функции взаимодействия между процессами
Главная | ::. | Perl | ::. | Стандартные модули Perl
 |  |  |  | Специальные переменные

Стандартная постановка Perl включает в себя большое число модулей, в которых представлены разные средства и функции для решения многих задач, возникающих при программировании на Perl. Простым подключением соответствующего модуля к своей программе можно получить необходимые средства для решения конкретной задачи. Более того, все перечисленные ниже модули присутствуют в системах программирования на языке Perl на всех известных платформах. Поэтому, если использовать их в своих разработках, то проблем с переносимостью программ Perl никогда не возникнет.

Содержание

  • 1 AnyDBM_File
  • 2 AutoSplit
  • 3 Benchmark
  • 4 Carp
  • 5 Config
  • 6 Cwd
  • 7 DB_File
  • 8 Devel::SelfStubber
  • 9 diagnostics
  • 10 DirHandle
  • 11 DynaLoader
  • 12 Env
  • 13 Exporter
  • 14 ExtUtils::Install
  • 15 ExtUtils::Liblist
  • 16 ExtUtils::MakeMaker
  • 17 ExtUtils::Manifest
  • 18 ExtUtils::Miniperl
  • 19 ExtUtils::MkbootStrap
  • 20 ExtUtils::Mksymlists
  • 21 ExtUtils::MM_OS2
  • 22 ExtUtils::MM_Unix
  • 23 ExtUtils::MM_VMS
  • 24 Fcntl
  • 25 File::Basename
  • 26 File::CheckTree
  • 27 File::Copy
  • 28 File::Find
  • 29 File::Path
  • 30 FileCashe
  • 31 FileHandle
  • 32 GDBM_File
  • 33 Getopt::Long
  • 34 Getopt::Std
  • 35 I18N::Collate
  • 36 integer
  • 37 IPC::Open2
  • 38 IPC::Open3
  • 39 lib
  • 40 Math::BigFloat
  • 41 Math::BigInt
  • 42 Math::Complex
  • 43 NDBM_File
  • 44 Net::Ping
  • 45 ODBM_File
  • 46 overload
  • 47 POSIX
  • 48 Pod::Text
  • 49 Safe
  • 50 SDBM_File
  • 51 Search::Dict
  • 52 SelectSaver
  • 53 SelfLoader
  • 54 Shell
  • 55 sigtrap
  • 56 Socket
  • 57 strict
  • 58 subs
  • 59 Symbol
  • 60 Sys::Hostname

[править] AnyDBM_File

Этот модуль всего лищь загружает один из модулей для связывания хешей Perl с файлами DBM в следующей последовательности: NDBM_File, DB_File, GDBM_File, SDBM_File и ODBM_File. Если установлен модуль NDBM_File, то загружается он; если его нет, то ищется следующий из приведенного списка и т.д. Модуль SDBM_File всегда присутствует, так как он входит в стандартную постановку Perl. AutoLoader

Предоставляет стандартный механизм для отложенной загрузки функций, хранящихся в отдельных файлах на диске. Используется при создания собственных модулей расширения Perl.

[править] AutoSplit

Содержит функции, разбивающие программу или модуль Perl на файлы, которые в последствии может обрабатывать модуль AutoLoader. Основное применение - построение библиотечных модулей Perl с автозагрузкой.

[править] Benchmark

Содержит набор функций для проведения тестов на быстродействие выполнения отдельных фрагментов кода программы.

[править] Carp

Содержит функции carp() и croak() - аналогии функций warn() и die(). Они отображают сообщение с указанием подпрограммы и номера ее строки, откуда вызываются эти функции, тогда как warn() и die() отображают номер строки в коде всей программы.

[править] Config

Содержит набор функций для доступа к конфигурационной информации Perl, которую сценарий Configure занес в компьютер при установке Perl.

[править] Cwd

Содержит функции для определения полного имени текущего рабочего каталога и его изменения. Эти функции работают надежнее и быстрее, чем соответствующие встроенные функции Perl.

[править] DB_File

Позволяет использовать в программе Perl возможности, предоставляемые библиотекой Berkeley DB, предлагая единообразный интерфейс доступа к базам данных разных форматов.

[править] Devel::SelfStubber

Генерация шаблонов (заготовок) для самозагружающихся модулей.

[править] diagnostics

Позволяет отбражать более полные и развернутые диагностические сообщения компилятора и интерпретатора perl по сравнению с используемой по умолчанию краткой диагностикой.

[править] DirHandle

Предоставляет объектный интерфейс к функциям работы с каталогами: opendir(), closedir(), readdir() и rewinddir().

[править] DynaLoader

Определяет стандартный интерфейс Perl к механизмам механической загрузки, доступных на большинстве компьютерных платформ. Используется при создании собственных модулей расширения Perl.

[править] Env

Perl поддерживает работу с переменными среды через ассоциативный массив %ENV. Модуль позволяет использовать переменные среды как обычные скалярные переменные Perl, используя имена этих переменных в качестве идентификатора переменных Perl. Например, $PATH, $HOME и т.д.

[править] Exporter

Реализует метод import(), который обычно наследуется другими модулями вместо определения ими собственных методов импортирования своих определений и функций.

[править] ExtUtils::Install

Предоставляет две функции install() и uninstall(), необходимые модулю ExtUtils::MakeMaker для выполнения зависимой от платформы установки и удаления расшерений Perl.

[править] ExtUtils::Liblist

Содержит функцию ext(), которая преобразует список библиотек в строки, пригодные для включения в файл Makefile расширения Perl на текущей платформе.

[править] ExtUtils::MakeMaker

Автоматизирует создание файла Makefile.pl, необходимого для построения расширения Perl.

[править] ExtUtils::Manifest

Содержит функции для создания файла MANIFEST, который содержит список имен файлов (одно имя в строке с необязательным коментарием). Содержимое файла лего прочитать командой awk "{print $1}" MANIFEST. Этот модуль используется модулем ExtUtils::MakeMaker для создания списков файлов, содержащиф функции модуля.

[править] ExtUtils::Miniperl

Содержит единственную функцию writemain(), получающую список катологов, содержащих архивные библиотеки, которые необходимы модулям Perl и которые следует включить в новый двоичный файл Perl. Обычно используется из файла Makefile, сгенерированного модулем ExtUtils::MakeMaker. программист непосредственно не работает с этим модулем.

[править] ExtUtils::MkbootStrap

Единственная функция этого модуля mkbootstrap() обычно вызывается из файла Makefile соответствующего расширения и создает файл *.bs, необходимый для динамической загрузки в некоторых архитектурах операционных систем.

[править] ExtUtils::Mksymlists

Единственная функция этого модуля Mksymlists() создает файлы, которые используются компановщиком некоторых операционных систем при создании совместно используемых (shared) библиотек для динамических расширений Perl. Обычно вызывается из файла Makefile, сгенерированного модулем ExtUtils::MakeMaker при построении расширения.

[править] ExtUtils::MM_OS2

Перекрывает методы модуля ExtUtils::MM_Unix, используемые модулем ExtUtils::MakeMaker, для работы в операционной системе OS2.

[править] ExtUtils::MM_Unix

Методы этого модуля используются модулем ExtUtils::MakeMaker. Программист никогда не работает с ним, если только он не улучшает модуль EtxUtils::MakeMaker в связи с его переносимостью.

[править] ExtUtils::MM_VMS

Перекрывает методы модуля ExtUtils::MM_Unix, используемые модулем ExtUtils_MakeMaker, для работы в операционной системе VMS.

[править] Fcntl

Этот модуль всего лишь трансляция заголовочного файла fcntl.h языка C, содержащего определения разных констант.

[править] File::Basename

Функции этого модуля осуществляют синтаксический разбор полного имени файла, выделяя ключевые единицы. Можно использовать синтаксис имен файлов разных операционных систем. Например, в Unix ключевыми единицами будет путь, имя файла и расширение.

[править] File::CheckTree

Единственная функция этого модуля validate() позволяет выполнять унарные именованные операции проверки над группой файлов, причем для каждого файла группы можно задать свои операции. Все операции проверки выполняются за одно обращение к функции.

[править] File::Copy

Содержит единственную функцию copy(), которая копирует группу файлов за одно обращение.

[править] File::Find

Содержит две функции поиска файлов по критерию, определенному в пользовательской подпрограмме. Функция find() отыскивает все файлы в каталогах заданного списка, последовательно переходя на поиск в каталогах нижнего уровня. Функция finddepth() также отыскивает файлы в каталогах заданного списка, но начинает поиск с последнего вложенного каталога, последовательно переходя на поиск в каталогах верхнего уровня.

[править] File::Path

Содержит две функции mkpath() и rmtree(), которые, соответственно, создают и удаляют каталоги. В отличии от встроенной функции создания каталога mkdir() функция этого модуля создает каталоги верхнего уровня, если они не существуют. Функция удаления каталога, в отличие от встроенной функции rmdir(), удаляет любой, не обязательно пустой каталог, причем возвращает количество удаленных файлов.

[править] FileCashe

Предоставляет функцию casheout(), которая открывает файл, не обращая внимания на установленное в соответствующей переменной среды количество одновременно открытых файлов. Ее использование для открытия файлов позволяет открыть произвольное количество файлов.

[править] FileHandle

Предоставляет объектный интерфейс для работы с дескрипторами файлов.

[править] GDBM_File

Позволяет программе Perl использовать возможности, предоставляемые библиотекой gdbm, распространяемой на условии лицензии GNU. См. описание модуля DB_File.

[править] Getopt::Long

Реализует функцию GetOption(), позволяющую получать и обрабатывать опции командной строки, с которыми была запущена программа Perl. Параметры этой функции определяют синтаксис правильных опций: опция с обязательным/необязательным строковым/целым/числовым параметром, опция без параметров.

[править] Getopt::Std

Содержит функции getopt() и getopts(), реализующие простой механизм обработки односимвольных опций (например, -v). Опции можно объединять в группы.

[править] I18N::Collate

Предоставляет объекты, которым можно присвоить строки данных, и в дальнейшем сравнивать и упорядочивать их в соответствии с таблицей символов национального алфавита. Для правильной работы объектов и методов этого модуля необходимо иметь установленный модуль POSIX языка Perl. Системе также должны быть доступны POSIX-функции setlocale(3) и strxfrm(3).

[править] integer

Использование в программе этого модуля предписывает компилятору применять арифметику целых чисел, начиная от строки вызова модуля (use integer;) до конца блока, в котором он вызван.

[править] IPC::Open2

Содержит функцию open2(), которая порождает новый процесс и выполняет в нем команду, определяемую значением параметра функции. Ассоциируя со стандартными файлами ввода и вывода два дескриптора, позволяет программе Perl получать и передавать информацию для порожденного процесса.

[править] IPC::Open3

Содержит функцию open3(), которая работает аналогично функции open2() модуля IPC::Open2 за исключением того, что открывается еще и третий файл для обмена информацией - стандартный файл вывода ошибок.

[править] lib

Упрощает работу со специальной переменной @INC во время компиляции. Позволяет добавлять дополнительные каталоги поиска для операторов use и require.

[править] Math::BigFloat

Позволяет создать объекты, представляющие вещественные числа с произвольным количеством цифр в мантиссе, и выполнять над ними арифметические операции.

[править] Math::BigInt

Позволяет создавать объекты, представляющие целые числа с произвольным количеством цифр в мантиссе, и выполнять над ними арифметические операции.

[править] Math::Complex

Позволяет создавать объекты, представляющие комплексные числа с произвольным количеством цифр в мантиссе, и выполнять над ними арифметические операции.

[править] NDBM_File

Позволяет связывать функцией tie() хеши с файлами NDBM. См. описание модуля DB_File.

[править] Net::Ping

Содержит функцию pingecho(), которая использует TCP-службу эхо (echo) (не ICMD) для определения, доступен ли удаленный хост.

[править] ODBM_File

Позволяет связывать функцией tie() хеши с файлами ODBM. См. описание модуля DB_File.

[править] overload

Позволяет осуществлять перегрузку стандартных операций Perl, т.е. при вызове в программе стандартной функции выполнять вместо предусмотренных стандартных операций методы каких-либо классов или собственные программы. Модуль постоянно изменяется, поэтому рекомендуем внимательно ознакомиться с документацией установленного на компьютере интерпретатора perl.

[править] POSIX

Обеспечивает доступ ко всем (или почти всем) идентификаторам стандарта POSIX версии 1003.1. Для многих из этих идентификаторов реализованы Perl-подобные интерфейсы.

[править] Pod::Text

Содержит функцию pod2text(), которая в программе Perl позволяет преобразовывать файл документации в формате POD в обычный текстовой ASCII файл. (В стандартную постановку Perl входит отдельная программа pod2text, которую можно запустить из командной строки).

[править] Safe

Создает специальную область, в которой можно выполнить небезовасный код Perl. Эта область имеет собственное пространство имен и ассоциированную маску операций. Код, выполняемый в ней, не может ссылаться на переменные вне своего пространства имен. Компилируемый вне этой области код может поместить некоторые свои переменные в пространство имен этой области. Тогда они станут доступны коду, компилируемому в ней. Задаваемая маска операций позволяет исключить из выполняемого в безопасной области кода Perl потенциально опасные операции. По умолчанию любые операции доступа к системным ресурсам не выполняются в безопасной области.

[править] SDBM_File

Позволяет связывать функцией tie() хеши с файлами SDBM. См. описание модуля DB_File.

[править] Search::Dict

Содержит функцию look(), которая устанавливает указатель позиции в файле на строку, содержимое которой больше или равно некоторому строковому значению, переданному в функцию в качестве параметра.

[править] SelectSaver

Позволяет создать объект SelectSaver, с помощью которого можно выбрать новый дескривтор файла, при этом старый дескриптор сохраняется и восстанавливается при уничтожении объекта SelectSaver.

[править] SelfLoader

Этот модуль предоставляет механизм отсроченной загрузки функций, объявления которых расположены после лексемы _DATA_пакета, определенного в файле программы Perl. Функция будет автоматически загружена при первом к ней обращении. Этот модуль отличается от модуля AutoLoader, который работает с функциями в отдельных самостоятельных файлах.

[править] Shell

Позволяет вызывать утилиты UNIX, доступные из командной строки, как будто они являются подпрограммами Perl. Параметры, включая ключи, передаются в утилиты как строковые данные.

[править] sigtrap

Позволяет инициализировать обработчик сигнала для сигналов, переданных в качестве параметов модулю при его подключении оператором use.

[править] Socket

Загружает определение констант и функций заголовочного файла socket.h языка C, а также специальных функций обработки некоторых структур данных, необходимых для работы с сетью.

[править] strict

Позволяет ограничить небезопасные конструкции: переменные, ссылки и простые слова, не являющиеся заранее объявленными подпрограммами.

[править] subs

Осуществляет объявление подпрограмм, чьи имена передаются в списке при подключении модуля в программу Perl. Это объявление позволяет вызывать в сценарии эти подпрограммы, задавая их параметры без скобок, даже до их определения. Можно перекрыть встроенные функции.

[править] Symbol

Предоставляет функцию gensym(), которая создает анонимную глобальную переменную и возвращает ссылку на нее. Такую переменную можно использовать в качестве дескриптора файла или каталога. Функция gualify() уточняет имена переменных, добавляя к ним префикс, состоящий из имени пакета, где они определены, и двойного двоеточия "::".

[править] Sys::Hostname

Предоставляет функцию hostname(), которая всеми возможными способами пытается получить имя хоста, последовательно вызывая разные системные программы.

Получено с http://spravkaweb.local/index.php/perl/mod
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:05, 23 января 2007.
  • К этой странице обращались 120 раз.
1.43971800804


Справочник по Perl : Функции, относящиеся к модулям Perl — Справочник Web-языков

Справочник по Perl : Функции, относящиеся к модулям Perl

 |  |  |  | Функции, относящиеся к области видимости переменных
Главная | ::. | Perl | ::. | Функции, относящиеся к модулям Perl
 |  |  |  | Функции, относящиеся к классам и объектно-ориентированным технологиям

[править] no

Отказ от импортирования символических имен (параметр СПИСОК) модуля (параметр МОДУЛЬ) во время компиляции программы. Является антонимом функции use.

no МОДУЛЬ СПИСОК

[править] require

Загружает модуль или класс, имя которого является значением параметра ВЫРАЖЕНИЕ, во время выполнения программы. Если параметр опущен, то используется значение специальной переменной $_. Если значение параметра ВЫРАЖЕНИЕ является число, то оно определяет минимальную версию Perl, необходимую для выполнения программы.

require [ВЫРАЖЕНИЕ]
Получено с http://spravkaweb.local/index.php/perl/modul
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:34, 21 января 2007.
  • К этой странице обращались 100 раз.
1.56775307655


Справочник по Perl : Сетевая информация — Справочник Web-языков

Справочник по Perl : Сетевая информация

 |  |  |  | Информация о пользователях и группах
Главная | ::. | Perl | ::. | Сетевая информация
 |  |  |  | Функции взаимодействия между процессами

Содержание

  • 1 endhostent
  • 2 gethostbyaddr
  • 3 gethostbyname
  • 4 gethostent
  • 5 sethostent
  • 6 endnetent
  • 7 getnetbyaddr
  • 8 getnetbyname
  • 9 getnetent
  • 10 setnetent
  • 11 endprotoent
  • 12 getprotobyname
  • 13 getprotobynumber
  • 14 getprotoent
  • 15 setprotoent
  • 16 endservent
  • 17 getservbyname
  • 18 getservbyport
  • 19 getservent
  • 20 setservent

[править] endhostent

Закрытие файла хостов после завершения обработки его содержимого.

endhostent

[править] gethostbyaddr

Получение записи из файла хостов о хосте с заданным IP-адресом и типом.

gethostbyaddr ADDR, ADDRTYPE

[править] gethostbyname

Получение записи из файла хостов о хосте с заданным именем.

gethostbyname ИМЯ

[править] gethostent

Возвращает следующую запись файла хостов при очередном вызове.

gethostent

[править] sethostent

Позиционирование файла хостов на первую запись. Последующий вызов функции gethostent() начинает его обработку с первой записи.

sethostent STAYOPEN

[править] endnetent

Закрытие файла сетей после завершения обработки его содержимого.

endnetent

[править] getnetbyaddr

Получение записи из файла сетей о сети с заданным адресом и типом.

getnetbyaddr ADDR, ADDRTYPE

[править] getnetbyname

Получение записи из файла сетей о сети с заданным сетевым именем.

getnetbyname ИМЯ

[править] getnetent

Возвращает следующую запись файла сетей при очередном вызове.

getnetent

[править] setnetent

Позиционирование файла сетей на первую запись. Последующий вызов функции getnetent() начинает его обработку с первой записи.

setnetent STAYOPEN

[править] endprotoent

Закрытие файла протоколов после завершения обработки его содержимого.

endprotoent

[править] getprotobyname

Получение записи из файла протоколов о протоколе с заданным именем.

getnetbyname ИМЯ

[править] getprotobynumber

Получение записи из файла протоколов о протоколе с заданным номером.

getprotobynumber НОМЕР

[править] getprotoent

Возвращает следующую запись файла протоколов при очередном вызове.

getprotoent

[править] setprotoent

Позиционирование файла протоколов на первую запись. Последующий вызов функции getprotoent() начинает его обработку с первой записи.

setprotoent STAYOPEN

[править] endservent

Закрытие файла служб после завершения обработки его содержимого.

endservent

[править] getservbyname

Получение записи из файла служб о службе с заданным именем и протоколом.

getservbyname ИМЯ, ПРОТОКОЛ

[править] getservbyport

Получение записи из файла служб о службе с заданным номером порта и протоколом.

getservbyport ПОРТ, ПРОТОКОЛ

[править] getservent

Возвращает следующую запись файла служб при очередном вызове.

getservent

[править] setservent

Позиционирование файла служб на первую запись. Последующий вызов функции getservent() начинает его обработку с первой записи.

setservent
Получено с http://spravkaweb.local/index.php/perl/netinfo
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:53, 23 января 2007.
  • К этой странице обращались 91 раз.
1.5742828846


Справочник по Perl : Числовые функции — Справочник Web-языков

Справочник по Perl : Числовые функции

 |  |  |  | Функции, связанные с регулярными выражениями
Главная | ::. | Perl | ::. | Числовые функции
 |  |  |  | Функции обработки массивов скаляров

Содержание

  • 1 abs
  • 2 atan2
  • 3 cos
  • 4 exp
  • 5 hex
  • 6 int
  • 7 log
  • 8 oct
  • 9 rand
  • 10 sin
  • 11 sqrt
  • 12 srand

[править] abs

Вычисление абсолютного значения выражения.

abs ВЫРАЖЕНИЕ
abs       (эквивалентно abs $_)

[править] atan2

Вычисление arctg(X/Y).

atan2 X, Y

[править] cos

Вычисление функции cos (ВЫРАЖЕНИЕ), выражение в радианах.

cos ВЫРАЖЕНИЕ
cos       (эквивалентно cos $_)

[править] exp

Вычисление значения экспоненциальной функции eВЫРАЖЕНИЕ.

exp ВЫРАЖЕНИЕ
exp       (эквивалентно exp $_)

[править] hex

Интерпретирует строковое ВЫРАЖЕНИЕ как шестнадцатиричное число и вычисляет его десятичный эквивалент.

hex ВЫРАЖЕНИЕ
hex       (эквивалентно hex $_)

[править] int

Вычисление целой части числа (отбрасывается дробная часть).

int ВЫРАЖЕНИЕ
int       (эквивалентно int $_)

[править] log

Вычисляет натуральный логарифм числа (по основанию e).

log ВЫРАЖЕНИЕ
log       (эквивалентно log $_)

[править] oct

Интерпретирует строковое ВЫРАЖЕНИЕ как восьмеричное число и вычисляет его десятичный эквивалент. Если строка начинается с символов "0x", то ее содержимое интерпретируется как шестнадцатиричное число.

oct ВЫРАЖЕНИЕ
oct       (эквивалентно oct $_)

[править] rand

Возвращает случайное дробное число в интервале 0 до значения параметра ВЫРАЖЕНИЕ.

rand ВЫРАЖЕНИЕ
rand      (эквивалентно rand 1)

[править] sin

Вычисление функции sin(ВЫРАЖЕНИЕ), выраженное в радианах.

sin ВЫРАЖЕНИЕ
sin (эквивалентно sin $_)

[править] sqrt

Вычисляет квадратный корень числа.

sqrt ВЫРАЖЕНИЕ
sqrt      (эквивалентно $_)

[править] srand

Затравка перед первым вызовом rand() (в Perl 5.005 и выше вызывается автоматически при обращении к rand).

srand ВЫРАЖЕНИЕ
srand
Получено с http://spravkaweb.local/index.php/perl/number
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:07, 21 января 2007.
  • К этой странице обращались 115 раз.
3.10195398331


Справочник по Perl : Разные функции — Справочник Web-языков

Справочник по Perl : Разные функции

 |  |  |  | Функции, относящиеся к классам и объектно-ориентированным технологиям
Главная | ::. | Perl | ::. | Разные функции
 |  |  |  | Функции для работы с процессами и группами процессов

Содержание

  • 1 defined
  • 2 formline
  • 3 reset
  • 4 reset [ВЫРАЖЕНИЕ]
  • 5 scalar
  • 6 undef
  • 7 vec

[править] defined

Проверяет, не равно ли значение выражения, заданное параметром ВЫРАЖЕНИЕ, неопределенной величине undef; если не равно, то возвращает булево значение Истина, в противном случае Ложь. Если параметр функции опущен, то используется значение специальной переменной $_.

defined [ВЫРАЖЕНИЕ]

[править] formline

Внутренняя функция, используемая операцией format, но ее можно вызывать и явным образом. Выводит значения элементов списка, представленного параметром СПИСОК, в специальную переменную $^A - аккумулятор форматного вывода. Вывод осуществляется в соответствии с заданной параметром ШАБЛОН строкой шаблонов. Управляющие символы "~" и "~~" игнорируются. Всегда возвращает значение Истина.

formline ШАБЛОН, СПИСОК

[править] reset

Используется для очистки переменных и переустановки команды поиска ?образец? (обычно в блоке continue цикла). Значением параметра ВЫРАЖЕНИЕ должна быть строка, представляющая символ, с которого начинается имя переменной (допустим дефис "-" для задания интервалов символов). Если параметр опущен, то переустанавливает команду поиска ?образец?, чтобы она могла осуществить очередной поиск в соответствии с заданным образцом. Действует только на переменные текущего пакета. Всегда возвращает значение 1.

[править] reset [ВЫРАЖЕНИЕ]

[править] scalar

Вычисляет выражение, определяемое параметром ВЫРАЖЕНИЕ, в скалярном контексте и возвращает вычисленное значение.

scalar ВЫРАЖЕНИЕ

[править] undef

Унарная операция, присваивающая lvalue, представленным параметром ВЫРАЖЕНИЕ, неопределенное значение. Применяется к скалярным переменным ($), массивам скаляров (@), хешам (%), подпрограммам (&) и глобальным типам(*). Всегда возвращает неопределенное значение. Вызванная без параметра, просто вычисляет неопределенное значение, которое можно использовать, например, в качестве возвращаемого значения функции.

undef [ВЫРАЖЕНИЕ]

[править] vec

Рассматривает строковое значение параметра ВЫРАЖЕНИЕ как последовательность целых чисел без знака и возвращает значение битового поля, номер которого определяется значением параметра СМЕЩЕНИЕ (первое поле в строке всегда имеет номер 0). Параметр БИТЫ_ПОЛЯ задает ширину битового поля в битах. Может использоваться в качестве левого значения операции присваивания (в этом случае параметры должны быть заключены в скобки).

vec ВЫРАЖЕНИЕ, СМЕЩЕНИЕ, БИТЫ_ПОЛЯ
Получено с http://spravkaweb.local/index.php/perl/othe
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:38, 21 января 2007.
  • К этой странице обращались 111 раз.
1.69039297104


Справочник по Perl : Функции, связанные с регулярными выражениями — Справочник Web-языков

Справочник по Perl : Функции, связанные с регулярными выражениями

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  | Функции обработки строк и скаляров
Главная | ::. | Perl | ::. | Функции, связанные с регулярными выражениями
 |  |  |  | Числовые функции

[править] pos

Синтаксис:

pos [$SCALAR]

Функция pos() возвращает позицию, в которой завершился последний глобальный поиск $SCALAR=~m/.../g, осуществленный в строке, задаваемой переменной $SCALAR. Возвращаемое значение равно числу length($`) + length($&). Следующий глобальный поиск m/.../g в данной строке начнется именно с этой позиции.

Если аргумент $SCALAR отсутствует, возвращается позиция завершения последнего глобального поиска, осуществленного в строке $_.

Пример:

$words = "one two three four";
while ($words =~m/w+/g) {
  print "pos=",pos($words)," length($`)=",length($`),
" length($&)=",length($&),"n";
}

В результате выполнения данного скрипта будут выделены номера позиций, соответствующих окончаниям слов в строке $words:

pos=3    length($`)=0    length($&)=3
pos=7    length($`)=4    length($&)=3
pos=13   length($`)=8    length($&)=5
pos=18   length($`)=14   length($&)=4

функцию pos() можно использовать в левой части операции присваивания для изменения начальной позиции следующего поиска:

# изменение начальной позиции для последующего поиска
$words = "one two three four";
pos $words = 4;
while ($words =~m/w+/g) {
  print pos $words, "n";
}

Здесь поиск слов начнется со второго слова, и будут выделены номера позиций 7, 13 и 18.

[править] quotemeta

Возвращает строку, в которой перед каждым не алфавитно-цифровым символом поставлена обратная косая черта. Значение параметра ВЫРАЖЕНИЕ интерпретируется как строка. (Внутренняя функция реализации управляющего символа Q в строках в двойных кавычках.)

quotemeta ВЫРАЖЕНИЕ
quotemeta (эквивалентно quotemeta $_)

Например, в результате выполнения

print quotemeta "*****", "n";

будет выведена строка

***** split

Синтаксис:

split [/PATTERN/[, EXPR[, LIMIT]]]

Разбивает строку EXPR на отдельные строки, используя в качестве разделителя образец, задаваемый регулярным выражением PATTERN. В списковом контексте возвращает массив полученных строк, в скалярном контексте - их число. Если функция split() вызывается в скалярном контексте, выделяемые строки помещаются предопределенный массив @_. Об этом не следует забывать, так как массив @_ обычно используется для передачи параметров в подпрограмму, и обращение к функции split() неявно в скалярном контексте эти параметры уничтожит. Если присутствует параметр LIMIT, то он задает максимальное количество строк, на которое может быть разбита исходная строка. Отрицательное значение параметра LIMIT трактуется как произвольно большое положительное число. Если параметр EXPR опущен, разбивается строка $_. Если отсутствует также параметр PATTERN, то в качестве разделителя полей используются пробельные символы после пропуска всех начальных пробельных символов (что соответствует заданию образца в виде /s+). К пробельным символам относится пробел (space), символ табуляции (tab), возврат каретки (carriage return), символ перевода строки (line feed) и символ перевода страницы (form feed). Предопределенная глобальная переменная $_ служит для обозначения используемой по умолчанию области ввода и поиска по образцу. Обычно мы осуществляем ввод при помощи операции "<>"("ромб"). Внутри угловых скобок <> может стоять дескриптор файла ввода, например, <STDIN>. Если дескриптор файла отсутствует, то в качестве файлов ввода используются файлы, переданные программе Perl в качестве аргументов командной строки.

Пусть, например, программа содержится в файле script.pl:

#! /usr/bin/perl
while (<>) {
  print;
};

Программа вызвана следующим образом: script.pl file1 file2 file3 Тогда операция <> будет считывать строки сначала из файла file1, затем из файла file2 и, наконец, из файла file3. Если в командной строке файлы не указаны, то в качестве файла ввода будет использован стандартный ввод. Только в случае, когда условное выражение оператора while состоит из единственной операции "ромб", вводимое значение автоматически присваивается предопределенной переменной $_. Вот что означают слова о том, что переменная $_ применяется для обозначения используемой по умолчанию области ввода. Аналогично обстоит дело с поиском по образцу.

Пример использования функции split():

#!/usr/bin/perl
while (<>) {
  chop;
  print "Число полей во входной строке '$_' равно ", $n=split;
  print "nВходная строка разбита на строки:n";
  foreach $i (@_) {
print $i . "n";
  }
  print "Объединение списка строк в одну строку через '+':n";
  $joined = join "+", @_;
  print "$joinedn";
}

В результате применения операции ввода <> внутри условного выражения оператора while вводимая строка будет присвоена переменной $_. Функция chop() без параметров применяется к переменной $_. В операции print вторым операндом является выражение $n=split, в котором функция split вызывается в скалярном контексте и без параметров. Поэтому она применяется по умолчанию к переменной $_. В качестве разделителя полей по умолчанию используется множество пробельных символов, а результат помещается в массив @_. А затем к массиву @_ применяется функция join(), объединяющая строки-элементы массива в одну строку.

Если ввести строку "one two three", то вывод будет иметь вид:

one two three

Число полей во входной строке 'one two three' равно 3 Входная строка разбита на строки:

one
two
three
Объединение списка строк в одну строку через '+':
one+two+three

[править] study

Оптимизирует строковые данные переметра СТРОКА для дальнейшего использования в повторных операциях поиска по образцу. В цикле с несколькими опрерациями поиска может сэкономить время выполнения.

study ВЫРАЖЕНИЕ
study     (эквивалентно study $_)
Получено с http://spravkaweb.local/index.php/perl/pregfun
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:01, 21 января 2007.
  • К этой странице обращались 124 раза.
2.0315580368


Справочник по Perl : Функции ввода/вывода — Справочник Web-языков

Справочник по Perl : Функции ввода/вывода

 |  |  |  | Функции обработки хеш-массивов
Главная | ::. | Perl | ::. | Функции ввода/вывода
 |  |  |  | Функции для работы с файлами и каталогами

Содержание

  • 1 binmode
  • 2 dbmclose
  • 3 dbmopen
  • 4 die
  • 5 eof
  • 6 fileno
  • 7 flock
  • 8 format
  • 9 getc
  • 10 print
  • 11 printf
  • 12 read
  • 13 readdir
  • 14 rewinddir
  • 15 seek
  • 16 seekdir
  • 17 select
  • 18 syscall
  • 19 sysread
  • 20 syswrite
  • 21 tell
  • 22 telldir
  • 23 truncate
  • 24 warn
  • 25 write

[править] binmode

Подготавливает файл, ассоциированный с дескриптом ДЕСКРИПТОР, для чтения и записи в двоичном формате, а не в текстовом, в операционных системах, которые различают двоичные и текстовые файлы. В Unix эта функция не имеет никакого эффекта; необходима в MS-DOS и других архаичных системах, иначе двоичный файл может быть испорчен.

binmode ДЕСКРИПТОР

[править] dbmclose

Разрывает связывание хеш-массива и файлом базы DBM. Заменена функцией untie().

dbmclose ХЕШ

[править] dbmopen

Создает связывание хеш-массива с файлом базы DBM, имя которого определяется значением параметра ФАЙЛ_DB. Заменена функцией tie(). Файл базы данных открывается в режиме, указанном параметром РЕЖИМ.

dbmopen ХЕШ, ФАЙЛ_DB, РЕЖИМ

[править] die

Вне тела функции eval() выводит значения элементов списков, заданного параметром СПИСОК, в стандартный файл ошибок STDERR и завершает выполнение сценария Perl с текущим значением специальной переменной $!. Если используется в теле функции eval(), то сообщение об ошибке помещается в переменную $@ и функция eval() завершается с неопределенным значением. Такое поведение позволяет использовать функцию die() для генерирования исключительных состояний.

die СПИСОК

Применяется также в функциях, относящихся к управлению выполнением программ.

[править] eof

Тестирует файл, ассоциированный с дескриптом, заданным параметром ДЕСКРИПТОР, на конец файла. Возвращает 1, если следующая операция чтения из файла возвратит конец файла. Употребленная без параметра, использует в качестве параметра файл, для которого выполнялась последняя операция чтения. Если используется с пустыми скобками eof(), то тестирует символ конца самого последнего файла из списка файлов, переданных в сценарий через командную строку.

eof ДЕСКРИПТОР
eof ()
eof

[править] fileno

Возвращает числовой системный дескриптор для файла, ассоциированного с дескриптором, заданным параметром ДЕСКРИПТОР.

fileno ДЕСКРИПТОР

[править] flock

Блокирует файл, ассоциированный с дескриптором, заданным параметром ДЕСКРИПТОР, для выполнения другими пользователями операций, определенных параметром ОПЕРАЦИЯ. Возвращает булево значение Истина в случае успешной блокировки файла и Ложь в противном случае. Блокирует полностью весь файл, а не отдельные записи.

flock ДЕСКРИПТОР, ОПЕРАЦИЯ

[править] format

Объявляет формат, используемый для вывода функцией write().

format ИМЯ_ФОРМАТА =
ФОРМАТЫ_СТРОК

Параметр ИМЯ_ФОМАТА представляет правильный идентификатор Perl. Он должен в точности соответствовать имени дескриптора файла, который используется в качестве единственного параметра в функции вывода write().

Так как операция format не является вычисляемой операцией Perl, то объявление формата может осуществляться в любом месте программы. Обычно все объявления форматов задаются либо в начале, либо в конце программы.

[править] getc

Функция getc возвращает символ в текущей позиции файла, дескриптор которого передан ей в качестве параметра, или неопределенное значение в случае достижения конца файла или возникновения ошибки. Если функция вызывается без параметра, то она читает символ из стандартного файла вывода STDIN.

getc;       # Чтение символа из STDIN
getc F1;    # чтение символа в текущей позиции файла с дескриптором F1

[править] print

print ДЕСКРИПТОР СПИСОК;

Здесь ДЕСКРИПТОР представляет дескриптор файла, в который функция выводит строковые данные, представленные списком вывода СПИСОК. Он может состоять из переменных, элементов массивов и выражений, вычисляемых как строковые данные. Дескриптор файла создается функцией open(). Он может быть опущен, и в этом случае вывод осуществляется в стандартный файл вывода STDOUT, если только функцией select() не выбран другой файл вывода по умолчанию. Обычное стандартное устройство вывода - экран монитора компьютера.

Функция print при выводе своего списка не завервает его символом новой строки "n". Это означает, что следующая функция print начнет вывод на экран непосредственно после последнего выведенного предыдущей функцией print символа. Если такое поведение не желательно, то следует список вывода каждой функции print явно завершать строкой, содержащей символ новой строки, или включать его последним символом последнего элемента списка вывода.

Пример 1:

#! perl -w
print "Строка 1:";
print "Строка 2:n";
print "Строка 3:","n";
print STDOUT "Строка 4:n";

Вот что получится на экране :

Строка 1:Строка 2:
Строка 3:
Строка 4:

Вторая функция print начинает свой вывод на той же строке, на которой завершила вывод первая функция, в которой в списке вывода нет символа перехода на новую строку. В четвертой функции явно указан дескриптор стандартного файла вывода STDOUT. Функция print, как и большинство других функций, является списковой операцией, и все элементы списка вывода вычисляются в списковом контексте. Это обстоятельство следует учитывать при использовании в качестве элементов списка вывода выражений с вызовами подпрограмм. Если параметры функции print, включая дескриптор файла, заключены в круглые скобки, то такая синтаксическая конструкция считается термом и в выражении имеет наивычший приоритет вычисления.

Пример 2:

print ($m + $n) **2;

Будет напечатана сумма значений переменных $m и $n, а не их сумму, возведенную в квадрат. Компилятор Perl, обнаружив после лексемы print левую круглую скобку, найдет правую круглую скобку и будет рассматривать их содержимое как список параметров функции print. А так как такая констркция есть терм, то сначало будет выполнена операция печати суммы значений переменных, а потом результат этой операции (Истина = 1) будет возведен в квадрат. Добавление необязательного дескриптора стандартного файла вывода STDOUT исправит подобную ошибку :

Пример 3:

print STDOUT ($m + $n) ** 2; # Выведет ($m + $n) ** 2

Если в функции печати print не задан список вывода, то она по умолчанию выводит содержимое специальной переменной $_ в файл, определенный параметром ДЕСКРИПТОР.

Пример 4:

print;         # Выводится содержимое переменной $_
 на экран монитора
print STDOUT;  # Эквивалентен предыдущему оператору
print FILEOUT; # Выводится содержимое переменной $_  в файл
   # с дескриптором FILEOUT

[править] printf

Выводит форматированный список строковых данных в файл, ассоциированный с дескриптом, заданный параметром ДЕСКРИПТОР. Если этот параметр опущен, то вывод осуществляется в стандартный файл вывода STDIN или текущий файл, установленный функцией select(). Параметр ФОРМАТ представляет строку, содержащую символы форматирования, полностью совпадающие с символами форматирования системной функцией Unix printf(3).

printf ДЕСКРИПТОР ФОРМАТ, СПИСОК
printf ФОРМАТ, СПИСОК

[править] read

read ДЕСКРИПТОР, ПЕРЕМЕННАЯ, ДЛИНА [,СМЕЩЕНИЕ];

Читает количество байтов, определенное значением параметра ДЛИНА, в скалярную переменную, определяемую параметром ПЕРЕМЕННАЯ, из файла с дескриптором, заданным первым параметром ДЕСКРИПТОР. Возвращаемое значение - действительное количество прочитанных байтов, 0 при попытке чтения в позиции конца файла и неопределенное значение в случае возникновения ошибки. Параметр СМЕЩЕНИЕ определяет количество сохраняемых байтов из содержимого переменной ПЕРЕМЕННАЯ, т.е. запись прочитанных из файла данных будет добавлена к содержимому переменной после байта, определяемого значением параметра СМЕЩЕНИЕ. Отрицательное значение смещения -n (n - целое число) означает, что из содержимого переменной ПЕРЕМЕННАЯ отбрасываются последние n байтов и к оставшейся строке добавляется запись, прочитанная из файла.

Пример:

Предположим, что файл in.dat содержит три строки данных:

One
Two
Three
#! perl -w
open (F1, "in.dat") or die "Ошибка открытия файла: $!";
$string = "1234567890"
read F1, $string, 6;                  # Чтение шести байт в переменную без смещения
print $string,"n";                   # $string = "OnenTw"
read F1, $string, 6, length($string);
print $string,"n";                   # $string = "OnenTwonThre"

[править] readdir

В скалярном контексте читает следующее имя элемента каталога, ассоциированного с дескриптором каталога (параметр ДЕСКРИПТОР) функцией opendir(). В списковом контексте возвращает имена всех оставшихся элементов (файлов и каталогов). Если больше не осталось прочитанных элементов, возвращает неопределенное значение в скалярном контексте и пустой список в списковом контексте.

readdir ДЕСКРИПТОР

[править] rewinddir

Устанавливает текущую позицию каталога, ассоциированного с дескриптором ДЕСКРИПТОР, на начало.

rewinddir ДЕСКРИПТОР

[править] seek

seek ДЕСКРИПТОР, СМЕЩЕНИЕ, ТОЧКА_ОТСЧЕТА

Текущая позиция в файле автоматически изменяется в соответствии с выполненными операциями чтения/записи. Ее можно изменить с помощью функции seek(), которой передаются в качестве параметров дескриптор файла, смещение и точка отсчета. Для связанного с дескриптором файла устанавливается новая текущая позиция, смещенная на заданное параметром СМЕЩЕНИЕ число байт относительно точки отсчета.

Параметр ТОЧКА_ОТСЧЕТА может принимать одно из трех значений:

  • 0 - начало файла
  • 1 - текущая позиция
  • 2 - конец файла

Смещение может быть как положительным, так и отрицательным. Обычно оно отрицательно для смещения относительно конца файла и положительно для смещения относительно начала файла. Для задания точки отсчета можно воспользоваться константами SEEK_SET,SEEk_CUP и SEEK_END из модуля IO::Seekable, которые соответствуют началу файла, текущей позиции и концу файла. Естественно, необходимо подключить этот модуль к программе с помощью ключевого слова use.

Например, следующие операторы устанавливают одинаковые текущие позиции в файлах:

use IO::Seekable;
seek FILE1, 5, 0;
seek FILE2, 5, SEEK_SET;

Для перехода в начало или конец файла следует использовать нулевое смещение относительно соответствующих точек отсчета при обращении к функции seek():

seek FILE1, 0, 0;   # Переход в начало файла
seek FILE1, 0, 2;   # Переход в конец файла

[править] seekdir

Устанавливает текущую позицию каталога, ассоциированного со своим дескриптором (параметр ДЕСКРИПТОР), для функции readdir(). Параметр ПОЛОЖЕНИЕ должен быть значением, возвращаемым функцией telldir.

seekdir ДЕСКРИПТОР, ПОЛОЖЕНИЕ

[править] select

Возвращает дескриптор текущего установленного файла вывода. Если задан параметр ДЕСКРИПТОР, делает файл, ассоциированный с этим дескриптором текущим установленным файлом вывода. Это приводит к тому, что функции print() и write() без дескрипторов будут осуществлять вывод именно в этот файл.

select [ДЕСКРИПТОР]

[править] syscall

Осуществляет вызов системной команды, заданной первым элементом передаваемого функции списка ( параметр СПИСОК); остальные элементы списка передаются этой команде в качестве параметров. В случае не успешного выполнения системной команды, возвращает -1 и в переменной $! содержится информация об ошибке.

syscall СПИСОК

[править] sysread

Аналогична функции read(), за исключением того, что осуществляет не буферизованный ввод данных, не используя буферы стандартной системы ввода/вывода stdio.

sysread ДЕСКРИПТОР, СКАЛЯР, КОЛИЧЕСТВО[, СМЕЩЕНИЕ]

[править] syswrite

Запись заданного количества байт из скалярной переменной, определяемой параметром СКАЛЯР, в файл, ассоциированный с заданным параметром ДЕСКРИПТОР дескриптором. Возвращает истинное количество прочитанных байтов или неопределенное значение undef привозникновении ошибки. Параметр СМЕЩЕНИЕ задает позицию в строковой переменной СКАЛЯР, с которой записываются в файл данные (по умолчанию с начала строки данных скалярной переменной); отрицательное значение этого параметра определяет запись заданного количества байт, начиная с конца строки. Осуществляет не буферизованный вывод данных, не используя буферы стандартной системы ввода/вывода stdio.

syswrite ДЕСКРИПТОР, СКАЛЯР, КОЛИЧЕСТВО[, СМЕЩЕНИЕ]

[править] tell

Возвращает текущую позицию в файле, ассоциированным с заданным параметром ДЕСКРИПТОР дескриптором. Если параметр опущен, то подразумевается последний файл, для которого была выполнена операция чтения данных.

tell [ДЕСКРИПТОР]

[править] telldir

Возвращает текущую позицию в каталоге, ассоциированного с заданным параметром ДЕСКРИПТОР дескриптором.

telldir ДЕСКРИПТОР

[править] truncate

truncate ДЕСКРИПТОР, ДЛИНА;
truncate ИМЯ_ФАЙЛА, ДЛИНА;

Функция truncate() усекает файл до заданной длины. Для задания файла можно использовать как имя файла, так и дескриптор открытого файла.

Функция возвращает значение Истина, если длина файла успешно усечена до количества байт, определенных в параметре ДЛИНА, или неопределенное значение undef в противном случае. Под усечением файла понимается не только уменьшение его длины, но и увеличение. Это означает, что значение второго параметра функции truncate() может быть больше истинной длины файла, что позволяет делать "дыры" в содержимом файла, которые в дальнейшем можно использовать для записи необходимой информации, не уничтожая уже записанную в файл.

Пример (Файл с "дырами"):

#! perl -w
# Создание файла с "дырами"
for ($i=1;$i<=3;$i++) {
  open (F, ">>>out.dat") or die $!;
print F "Запись".$i;
  close F;

  open (F, ">>out.dat") or die $!;
truncate F, 19*$i;
  close F;
}
# Запись информации в "дыры"
open (F, "+<out.dat") or die $!;
for ($i=1;$i<=3;$i++) {
  seek F,0,1;
  read F,$recl,7;
  seek F,0,1;
  print F "<CONTENTS:".$i.">"
}
close F;

На каждом шаге первого цикла for в конец файла out.dat записывается информация длиной 7 байтов, а потом его длина увеличивается на 12 байтов, образуя пустое пространство в файле. Следующий цикл for заносит в эти созданные "дыры" информацию длиной 12 байтов, не затирая хранящуюся в файле информацию. Для изменения длины файла функцией truncate приходится закрывать его и снова открывать. Это связано с тем обстоятельством, что функция truncate() добавляет пустое пространство в начало файла, сдвигая в конец его содержимое, если применять ее, не закрывая файл. После выполнения первого цикла for содержимое файла out.dat выглядит так:

Запись1      Запись2      Запись3

По завершении всей программы файл будет содержать следуюшую строку:

Запись1<CONTENTS:1>Запись2<CONTENTS:2>Запись3<CONTENTS:3>

[править] warn

Выводит в стандартный файл ошибок STDERR значения элементов списка, определяемого параметром СПИСОК. Если он пуст, то выводит содержимое специальной переменной $@ (обычно после выполнения функции eval), добавляя строку "t...caught", а если и она пуста, то выводит сообщение "Warning: Something-s wrong"

warn СПИСОК

[править] write

Осуществляет форматный вывод в файл, Ассоциированный с заданным параметром ДЕСКРИПТОР дескриптором, в соответствии с определенным форматом. Если параметр не задан, то выводит в стандартный файл вывода STDOUT или в файл, выбранный функцией select().

write [ДЕСКРИПТОР]
Получено с http://spravkaweb.local/index.php/perl/print
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:09, 21 января 2007.
  • К этой странице обращались 118 раз.
1.44752693176


Справочник по Perl : Функции для работы с процессами и группами процессов — Справочник Web-языков

Справочник по Perl : Функции для работы с процессами и группами процессов

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  | Разные функции
Главная | ::. | Perl | ::. | Функции для работы с процессами и группами процессов
 |  |  |  | Низкоуровневые функции работы с сокетами

Содержание

  • 1 alarm
  • 2 exec
  • 3 fork
  • 4 getpgrp
  • 5 getppid
  • 6 getpriority
  • 7 kill
  • 8 pipe
  • 9 setpgrp
  • 10 setpriority
  • 11 sleep
  • 12 system
  • 13 times
  • 14 wait
  • 15 waitpid

[править] alarm

Определяет количество секунд (параметр СЕКУНДЫ), через который должен быть выдан сигнал SIGALARM. Если параметр отсутствует, используется значение специальной переменной $_.

alarm [СЕКУНДЫ]

[править] exec

Выполняет заданную параметром СПИСОК команду, прекращая дальнейшее выполнение программы Perl. Никогда не возвращает кода возврата выполнения команды, только в случае, если команда не существует, возвращает булево значение Ложь. Если СПИСОК состоит более чем из одного элемента, вызывает системную команду execvp(3) и передает ей в качестве параметров значения списка, которая вызывает заданную первым элементом списка команду, интерпретируя оставшиеся элементы как ее параметры. Если список представлен одной скалярной переменной или массивом из одного элемента, то его значение проверяется на наличие метасимволов командного интерпретатора shell. Если таковые обнаружены, то вся строка передается анализатору shell(в Unix это /bin/sh -c); в противном случае она разбивается на слова и передается в качестве параметра системной команде execvp(). В системной переменной $0 сохраняется имя выполняемой команды. В форме с параметром ПРОГРАММА выполняет команду, заданную этим параметром, а в системную переменную $0 заносится содержимое первого элемента списка. Таким образом можно скрыть от программы Perl имя истинной выполняемой команды.

exec СПИСОК
exec ПРОГРАММА СПИСОК

[править] fork

Осуществляет вызов системной функции fork(2), создающей новый процесс. Возвращает идентификатор порожденного процесса в родительский процесс, значение 0 в порожденный процесс и неопределенное значение undef, если не удалось создать новый процесс.

fork

[править] getpgrp

Возвращает текущую группу процесса с заданным идентификатором PID. Если значение параметра PID равно 0, или он опущен, то возвращается текущая группа текущего процесса.

getpgrp PID

[править] getppid

Возвращает идентификатор процесса (ID) родительского процесса.

getppid

[править] getpriority

Возвращает текщий приоритет процесса, группы процесса или пользователя.

getpriority WHICH, WHO

[править] kill

Посылает сигнал процессам, определенным в элементах списка параметра СПИСОК. Первым элементом списка должен быть посылаемый сигнал; если он отрицательный, то уничтожаются группы процессов, а не сами процессы. Возвращает количество процессов, которым передан сигнал.

kill СПИСОК

[править] pipe

Открывает пару соединенных дескрипторов файлов, образуя програмный канал (pipe). Записанные в один файл данные можно прочитать из другого. При передачи данных используются буферы стандартной системы ввода/вывода stdio.

pipe ДЕСКРИПТОР_ЧТЕНИЯ, ДЕСКРИПТОР_ЗАПИСИ

[править] setpgrp

Устанавливает для процесса с заданным идентификатором (параметр PID) текущую группу равной значению параметра PGRP. Значение 0 идентификатора процесса соответствует текущему процессу. Если оба параметра опущены, то по умолчанию их значения принимаются равными 0.

setpgrp PID, PGRP

[править] setpriority

Устанавливает текущий приоритет процесса, группы процесса или пользователя.

setpriority WHICH, WHO, PRIORITY

[править] sleep

Приостанавливает работу программы Perl на заданное значением параметра ВЫРАЖЕНИЕ количество секунд или на всегда, если параметр отсутствует. Выходит из состояния ожидания раньше указанного времени, если процесс получает сигнал GIGALARM. Возвращает действительное количество секунд нахождения программы в состоянии ожидания.

sleep ВЫРАЖЕНИЕ

[править] system

Аналогична функции exec(), но для выполнения команды порождает новый процесс, окончания которого ожидает родительский процесс, прежде чем продолжить свое выполнение. Все, что сказано относительно параметров функции exec(), распространяется и на параметры функции system(). Возвращает такой же код завершения команды, что и функция wait(); для получения истинного кода завершения полученное значение следует разделить на 256.

system СПИСОК
system ПРОГРАММА СПИСОК

[править] times

Возвращает четырехэлементный список, содержащий пользовательское и системное время для процесса и порожденного им процесса.

($user, $system, $cuser, $csystem) = times;

[править] wait

Ожидает завершение порожденного процесса и возвращает идентификатор завершенного порожденного процесса или -1 в случае, если порожденных процессов не существует. В специальной переменной $? сохраняется статус завершения.

wait

[править] waitpid

Ожидает завершения процесса с заданным в параметре PID идентификатором процесса (-1 означает любой процесс) и возвращает идентификатор завершенного порожденного процесса или -1 в случае, если порожденных процессов не существует. Параметр FLAGS представляет набор флагов, уточняющих действие функции. Например, флаг WHOANG означает не блокирующее ожидание завершения любого процесса. Во всех системах реализован флаг 0, означающий блокирующий вызов. В специальной переменной $? сохраняется статус завершения.

waitpid PID, FLAGS
Получено с http://spravkaweb.local/index.php/perl/process
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 18:03, 21 января 2007.
  • К этой странице обращались 107 раз.
1.32679414749


Справочник по Perl : Функции взаимодействия между процессами — Справочник Web-языков

Справочник по Perl : Функции взаимодействия между процессами

 |  |  |  | Сетевая информация
Главная | ::. | Perl | ::. | Функции взаимодействия между процессами
 |  |  |  | Стандартные модули Perl

Содержание

  • 1 msgctl
  • 2 msgget
  • 3 msgrcv
  • 4 msgsnd
  • 5 semctl
  • 6 semget
  • 7 semop
  • 8 shmctl
  • 9 shmget
  • 10 shmread
  • 11 shmwrite

[править] msgctl

Вызывает системную функцию msgctl(2). Если команда, заданная параметром CMD, является командой IPC_STAT, то параметр ARG должен быть переменной, которая будет содержать структуру msgid_ds. Возвращаемое значение функции аналогично возвращаемому значению функции ioctl(): если системная функция возвращает -1, то функция Perl - строку "0 but true"; если системная функция возвращает какое-либо другое значение, то функция Perl возвращает это же значение. См. также документацию по модулям IPC::SysV и IPC::SysV::Msg.

msgctl ID, CMD, ARG

[править] msgget

Создает очередь сообщений с заданным параметром КЛЮЧ ключом, вызывая системную функцию msgget(2). Возвращает идентификатор очереди сообщений, если она успешно создана, или неопределенное значение в противном случае. См. также жокументацию по модулям IPC::SysV и IPC::SysV::Msg.

msgget КЛЮЧ, ФЛАГИ

[править] msgrcv

Вызывает системную функцию msgrcv для получения сообщения из очереди сообщений с идентификатором, заданным параметром ID, и сохраняя его в переменной, определяемой параметром ПЕРЕМЕННАЯ. Максимальная длина сообщения не может превышать значения, заданного параметром ДЛИНА. Если сообщение получено, то в переменной перед самим сообщением сохраняется его тип. Возвращает булево значение Истина в случае успешного получения сообщения или Ложь в противном случае. См. также документацию по модулям IPC::SysV и IPC::SysV::Msg.

msgrcv ID, ПЕРЕМЕННАЯ, ДЛИНА, ТИП, ФЛАГИ

[править] msgsnd

Вызывает системную функцию msgsnd для посылки сообщения, заданного параметром СООБЩЕНИЕ, в очередь сообщений с идентификатором, заданным параметром ID. Сообщение должно начинаться с типа сообщения, представленного длинным целым числом, которое можно создать функцией pack("l", $type). Возвращает булево значение Истина в случае успешной посылки сообщения и Ложь в противном случае. См. также документацию по модулям IPC::SysV и IPC::SysV::Msg.

msgsnd ID, СООБЩЕНИЕ, ФЛАГИ

[править] semctl

Вызывает системную функцию semctl(). Если команда, заданная параметром CMD, является командой IPC_STAT или GETALL, то параметр ARG должен быть переменной, которая будет содержать возвращаемую форму semid_ds или массив значений семафора. Возвращаемое значение функции аналогично возвращаемому значению функции ioctl(): если системная функция возвращает -1, то функция Perl неопределенное значение; если системная функция возвращает 0, то функция Perl строку "0 but true"; если системная функция возвращает какое-либо другое значение, то функция Perl возвращает это же значение. См. также документацию по модулям IPC::SysV и IPC::SysV::Msg.

semctl ID, SEMNUM, CMD, ARG

[править] semget

Создает набор симафоров, вызывая системную функцию semget. Возвращает идентификатор семафора, если набор успешно создан, или неопределенное значение в противном случае. См. также документацию по модулям IPC::SysV и IPC::SysV::Msg.

semget KEY, NSEMS, FLAGS

[править] semop

Вызывает системную функцию semop для выполнения операций с семафором, например, сигнализация или ожидание. Параметр OPSTRING должен быть упакованным массивом структур semop, каждая из которых создается функцией pack("sss", $semnum, $semop, $semfkag). Количество операций с семафором определяется числом элементов массива OPSTRING. Возвращает булево значение Истина в случае успешного выполнения операций с семафором или Ложь в противном случае. См. также документацию по модулям IPC::SysV и IPC::SysV::Msg.

semop KEY, OPSTRING

[править] shmctl

Вызывает системную функцию shmctl. Если команда, заданная параметром CMD, является командой IPC_STAT, то параметр ARG должен быть переменной, которая будет содержать возвращаемую структуру shmid_ds. Возвращаемое значение функции аналогично возвращаемому значению функции ioctl(): если системная функция возвращает -1, то функция Perl неопределенное значение; если системная функция возвращает 0, то функция Perl строку "0 but true"; если системная функция возвращает какое- либо другое значение, то и функция Perl возвращает это же значение. См. также документацию по модулям IPC::SysV и IPC::SysV::Msg.

shmctl ID, CMD, ARG

[править] shmget

Создает область памяти для совместного использования (разделяемая область памяти), вызывая системную функцию shmget. Возвращает идентификатор разделяемой области памяти, если она успешно создана, или неопределенное значение в противном случае.См. также документацию по модулям IPC::SysV и IPC::SysV::Msg.

shmget KEY, SIZE, FLAGS

[править] shmread

Читает в переменную VAR заданное параметром SIZE количество байт из разделяемой области с идентификатором, определенным параметром ID, начиная с позиции, указанной параметром POS. Возвращает булево значение Истина в случае успешного чтения данных и Ложь в противном случае. См. также документацию по модулям IPC::SysV.

shmread ID, VAR, POS, SIZE

[править] shmwrite

Записывает заданное параметром SIZE количество байт из строки данных STRING в разделяемую область памяти с идентификатором, определяемым параметром ID, начиная с позиции, указанной параметром POS. Если строка данных содержит меньшее количество байт, то добавляются нулевые значения "\0". Возвращает булево значение Истина в случае успешной записи данных и Ложь в противном случае. См. также документацию по модулям IPC::SysV.

shmwrite ID, STRING, POS, SIZE
Получено с http://spravkaweb.local/index.php/perl/processfun
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:57, 23 января 2007.
  • К этой странице обращались 95 раз.
2.33864998817


Справочник по Perl : Функции, относящиеся к управлению выполнением программы — Справочник Web-языков

Справочник по Perl : Функции, относящиеся к управлению выполнением программы

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  | Функции для работы с файлами и каталогами
Главная | ::. | Perl | ::. | Функции, относящиеся к управлению выполнением программы
 |  |  |  | Функции, относящиеся к области видимости переменных

Содержание

  • 1 caller
  • 2 do
  • 3 dump
  • 4 eval
  • 5 exit
  • 6 return
  • 7 sub
  • 8 wantarray

[править] caller

Возвращает контекст выполняемой подпрограммы, если вызвана без параметра. В скалярном контексте возвращает имя пакета, в котором находится вызывающая данную подпрограмму (т.е. если наша подпрограмма вызывается из другой подпрограммы, функции eval() или require() ), или неопределенное значение в противном случае. В списковом контексте возвращает список с разнообразными сведениями. Можно передать в качестве параметра число, определяющее уровень вложенности получаемой информации, т.е к какой подпрограмме она относится: 0 - наша подпрограмма; 1 - подпрограмма, вызывающая нашу, и т.д.

Полный синтаксис:

($package, $filename, $line, $subroutine, $hasargs, $wantarray, $evaltext, $is_require) = caller($i); die

Вне тела функции eval() выводит значения элементов списка, заданного параметром СПИСОК, в стандартный файл ошибок STDERR и завершает выполнение сценария Perl с текущим значением специальной переменной $!. Если используется в теле функции eval(), то сообщение об ошибке помешается в переменную $@ и функция eval() заверщается с неопределенным значением. Такое поведение позволяет использовать функцию die() для генерирования исключительных состояний.

die СПИСОК

[править] do

В действительности не является функцией. Выполняет последовательность операторов Perl, заданных в блоке БЛОК, и возвращает значение последнего выполненного оператора. Если параметром является ВЫРАЖЕНИЕ, то рассматривает его значение как имя файла, который загружает и выполняет как последовательность операторов Perl. Если не удается прочитать файл, возвращает неопределенное значение и помещает в переменную $! сообщение об ошибке; если не может откомпилировать файл, то также возвращает неопределенное значение и помещает сообщение об ошибке в переменную $@. Если содержимое файла успешно откомпилированно, то возвращает значение последнего выполненного оператора.

do БЛОК
do ВЫРАЖЕНИЕ

[править] dump

Создание дампа ядра, которое системной командой undump может быть преобразованно в двоичный выполняемый файл. Если задан параметр МЕТКА, то при повторном вычислении двоичного файла, сначала выполнится оператор goto МЕТКА;. Функция устаревшая - существует компилятор из Perl в C, который выполняет ее функцию.

dump МЕТКА

[править] eval

eval EXPR

Функция eval() рассматривает параметр EXPR как текст Perl-программы, кампилирует его и, если не обнаруживает ошибок, выполняет в текущем вычислительном окружении. Если параметр EXPR отсутствует, вместо него по умолчанию используется глобальная переменная $_. Компиляция програмного кода EXPR осуществляется при каждом вызове функции eval() во время выполнения основной программы. Если выполнения мини-программы EXPR завершается успешно, функция eval() возвращает значение последнего выражения, вычисленного внутри EXPR. Если код EXPR содержит синтаксические ошибки, или обращение к функции die(), или возникла ошибка во время выполнения EXPR, то в специальную переменную $@ помещается сообщение об ошибке, а функция eval() возвращает неопределенное значение.

Если скалярной переменной не присвоено никакое допустимое значение (число, строка или ссылка), то говорят, что она имеет неопределенное значение. Неопределенные значения возникают в различных случаях, например, при попытке чтения данных после достижения конца файла или в результате системных ошибок. Неопределенное значение представляется пустой строкой "", но его следует отличать от определенного значения, равного "". Например, в результате выполнения операторов

$e = eval '$a = 1/0'; # деление на 0
$b = "";
print "a= $an" if defined $a;
print "e= $en" if defined $e;
print "b= $bn" if defined $b;

переменные $a и $e будут иметь неопределенное значение, а переменная $b - определенное значение "".

Для того чтобы определить, имеет выражение EXPR определенное значение или нет, существует функция defined EXPR, возвращающая соответствующее булевское значение. В данном примере результатом выполнения будет вывод единственной строки b=

Специальная переменная $@ служит для запоминания сообщения об ошибке, возникшей при последнем обращении к функции eval().

Существует вторая форма функции eval()

eval BLOCK,

где BLOCK придставляет собой блок - последовательность операторов, заключенную в фигурные скобки. Вторая форма отличается от первой тем, что синтаксический анализ параметра BLOCK осуществляется всего один раз - во время компиляции основной программы, содержащей обращение к функции eval(). Таким образом, если параметр BLOCK содержит синтаксические ошибки, то они обнаружатся на этапе компиляции основной программы. При использовании первой формы синтаксические ошибки обнаружатся только во время выполнения.

Основным применением функции eval() является перехватывание исключений. Исключением мы называем ошибку, возникающую при выполнении программы, когда нормальная последовательность выполнения прерывается (например, при делении на нуль). Обычно реакцией на исключение является аварийное завершение программы. Язык Perl предоставляет возможность перехватывать исключения без аварийного выхода. Если исключение возникло в основной программе, то программа завершается. Если ошибка возникла внутри мини-программы функции eval(), то аварийно завершается только функция eval(), а основная программа продолжает выполняться и может реагировать на возникшую ошибку, сообщение о которой ей достанется через переменную $@.

В следующем примере функция eval() применяется для перехватывания ошибки, связянной с делением на 0 при вычислении функции ctg(x). Используются встроенные функции sin, cos и warn. Последняя функция осуществляет вывод сообщения, задаваемого ее аргументом, на стандартное устройство вывода ошибок STDERR.

Пример:

#!/bin/perl
$fi = 0.314159265358979;
$f = '$ctg = cod($x)/sin($x)';
for $i (0..10) {
  $x = $i*$fi;
  eval $f;
  print "x= $x     ctg(x) = $stgn" if defined $ctg;
  warn "x= $x ", $@ if not defined $ctg;
};

Вывод программы выглядит следующим образом

x= 0 Illegal division zero at (eval 1) line 1.
x= 0.314159265358979 ctg(x) = 3.07768353717526
x= 0.628318530717958 ctg(x) = 1.37638192047118
. . .

Иногда бывает полезно искусственно вызвать исключительную ситуацию. Для этого можно воспользоваться функцией die() LIST. Назначение функции die() - генерировать исключения. Если функция die() вызывается в основной программе вне функции eval(), то она осуществляет аварийное завершение основной программы и выводит сообщение об ошибке LIST на стандартное устройство вывода ошибок STDERR. Если она вызывается внутри функции eval(), то осуществляется аварийное завершение eval() и помещает сообщение об ошибке в специальную переменную $@.

[править] exit

Немедленно прекращает выполнение программы с кодом завершения, равным значению параметра ВЫРАЖЕНИЕ. Если параметр не задан, программа завершается с кодом 0.

exit [ВЫРАЖЕНИЕ]

[править] return

Выход из подпрограммы, функции eval() или do ФАЙЛ с кодом завершения равным значению параметра ВЫРАЖЕНИЕ. Если в подпрограмме, функции eval() или do ФАЙЛ не используется эта функция, то они завершаются с кодом, равным значению последнего выполненного оператора.

return ВЫРАЖЕНИЕ

[править] sub

В действительности это не функция, а объявление подпрограммы: анонимной (без параметрп ИМЯ, но с блоком операторов БЛОК), прототипа (без блока операторов БЛОК) и нормальной.

sub БЛОК
sub ИМЯ
sub ИМЯ БЛОК

[править] wantarray

Возвращает значение Истина, если контексту выполняемой подпрограммы требуется списковое значение, и Ложь, если требуется скалярное значение. Возвращает неопределенное значение, если подпрограмме требуется безразличный (void) контекст.

wantarray
Получено с http://spravkaweb.local/index.php/perl/progs
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:28, 21 января 2007.
  • К этой странице обращались 104 раза.
1.9291510582


Справочник по Perl : Функции обработки строк и скаляров — Справочник Web-языков

Справочник по Perl : Функции обработки строк и скаляров

Главная | ::. | Perl | ::. | Функции обработки строк и скаляров
 |  |  |  | Функции, связанные с регулярными выражениями

Содержание

  • 1 chomp
  • 2 chop
  • 3 chr
  • 4 crypt
  • 5 hex
  • 6 index
  • 7 lc
  • 8 lcfirst
  • 9 length
  • 10 oct
  • 11 ord
  • 12 pack
  • 13 reverse
  • 14 rindex
  • 15 sprintf
  • 16 substr
  • 17 uc
  • 18 ucfirst

[править] chomp

Удаляет из каждого строкового элемента списка замыкающий символ завершения записи, соответствующий значению переменной $/ (по умолчанию - символ новой строки "n"). Возвращает общее количество удаленных символов. Список может состоять из одной переменной.

chomp СПИСОК
chomp     (эквивалентно chmod $_)

[править] chop

Удаляет из каждого строкового элемента списка последний символ. Возвращаемое значение - удаленный символ из последнего элемента списка. Сисок может состоять из одной переменной.

chop СПИСОК
chop      (эквивалентно chop $_)

[править] chr

Возвращает символ, код которого представлен числовым параметром.

chr ЧИСЛО
chr       (эквивалентно chr $_)

[править] crypt

Шифрует ТЕКСТ с использованием заданного в параметре шифра. Обратной функции дешифровки не существует.

crypt ТЕКСТ, ШИФР

[править] hex

Интерпретирует строковое ВЫРАЖЕНИЕ как шестнадцатиричное число и вычисляет его десятичный эквивалент.

hex ВЫРАЖЕНИЕ
hex       (эквивалентно hex $_)

[править] index

Возвращает позицию первого вхождения указанной подстроки в заданную строку или -1, если подстрока не найдена. Если задан параметр ПОЗИЦИЯ, то поиск подстроки осуществляется, начиная с заданной позиции в строке (0 - начало строки)

index СТРОКА, ПОДСТРОКА[, ПОЗИЦИЯ]

[править] lc

Преобразует все прописные буквы строкового параметра ВЫРАЖЕНИЕ в строчные и возвращает полученную строку. Использует текущие установки локализации, если используется use local.

lc ВЫРАЖЕНИЕ
lc        (эквивалентно lc $_)

[править] lcfirst

Преобразует первый символ строкового параметра ВЫРАЖЕНИЕ в нижний регистр и возвращает полученную строку. Использует текущие установки локализации, если используется use local.

lcfirst ВЫРАЖЕНИЕ
lcfirst   (эквивалентно lcfirst $_)

[править] length

Возвращает количество байтов в строке, являющейся значением параметра ВЫРАЖЕНИЕ.

length ВЫРАЖЕНИЕ
length    (эквивалентно length $_)

[править] oct

Интерпретирует строковое ВЫРАЖЕНИЕ как восьмеричное число и вычисляет его десятичный эквивалент. Если строка начинается с символов "0x", то ее содержимое интерпретируется как шестнадцатиричное число.

oct ВЫРАЖЕНИЕ
oct       (эквивалентно oct $_)

[править] ord

Возвращает числовой ASCII-код первого символа строки, являющейся значением параметра ВЫРАЖЕНИЕ.

ord ВЫРАЖЕНИЕ
ord       (эквивалентно ord $_)

[править] pack

Упаковывает массив или список значений в двоичную структуру в соответствии с заданным шаблоном, представляющим собой последовательность символов, которые задают порядок и тип значений. Возвращает строку, содержащую полученную структуру.

pack ШАБЛОН, СПИСОК

[править] reverse

В списковом контексте возвращает список значений, состоящих из элементов заданного параметром СПИСОК списка; в скалярном контексте соединяет все элементы списка в одну строку и возвращает строку, состоящую из символов полученной строки, но в обратном порядке.

reverse СПИСОК

[править] rindex

Синтаксис:

rindex STR, SUBSTR, POSITION

Находит последнее, ограниченное справа позицией POSITION, вхождение подстроки SUBSTR в строку STR, и возвращает найденную позицию. Если подстрока SUBSTR не найдена, возвращается значение $[ -1.

Пример:

    #!/bin/perl
    $STR = "Этот безумный, безумный, безумный, безумный мир!";
    $SUBSTR = "безумный";
    $POS = 7;
    print "Индекс первого символа строки по умолчанию равен $[n";
    print "Позиция первого вхождения подстроки '$SUBSTR'
               в строку '$STR' = ",index($STR, $SUBSTR), "n";
    print "Позиция первого после позиции $POS вхождения подстроки '$SUBSTR'
               в строку '$STR' = ",index($STR, $SUBSTR, $POS), "n";
    print "Позиция последнего вхождения подстроки '$SUBSTR'
               в строку '$STR' = ",rindex($STR, $SUBSTR), "n";
    print "Позиция последнего перед позицией $POS вхождения подстроки '$SUBSTR'
               в строку '$STR' = ",rindex($STR, $SUBSTR, $POS), "n";
    $[=2;
    print "nИндех первого символа строки по умолчанию изменен на $[n";
    print "Позиция первого вхождения подстроки '$SUBSTR'
               в строку '$STR' = ",index($STR, $SUBSTR), "n";
    print "Позиция первого после позиции $POS вхождения подстроки '$SUBSTR'
               в строку '$STR' = ",index($STR, $SUBSTR, $POS), "n";
    print "Позиция последнего вхождения подстроки '$SUBSTR'
               в строку '$STR' = ",rindex($STR, $SUBSTR), "n";
    print "Позиция последнего перед позицией $POS вхождения подстроки '$SUBSTR'
               в строку '$STR' = ",rindex($STR, $SUBSTR, $POS), "n";

В результате выполнения скрипта будут выведены следующие строки :

    Индекс первого символа строки по умолчанию равен 0
    Позиция первого вхождения подстроки 'безумный'
       в строрку 'Этот безумный, безумный, безумный, безумный мир!' = 5
    Позиция первого после позиции 7 вхождения подстроки 'безумный'
       в строку 'Этот безумный, безумный, безумный, безумный мир!' = 15
    Позиция последнего вхождения подстроки 'безумный'
       в строрку 'Этот безумный, безумный, безумный, безумный мир!' = 35
    Позиция последнего перед позицией 7 вхождения подстроки 'безумный'
       в строку 'Этот безумный, безумный, безумный, безумный мир!' = 5
    Индекс первого символа строки по умолчанию изменен на 2
    Позиция первого вхождения подстроки 'безумный'
       в строрку 'Этот безумный, безумный, безумный, безумный мир!' = 7
    Позиция первого после позиции 7 вхождения подстроки 'безумный'
       в строку 'Этот безумный, безумный, безумный, безумный мир!' = 7
    Позиция последнего вхождения подстроки 'безумный'
       в строрку 'Этот безумный, безумный, безумный, безумный мир!' = 37
    Позиция последнего перед позицией 7 вхождения подстроки 'безумный'
       в строку 'Этот безумный, безумный, безумный, безумный мир!' = 7

[править] sprintf

Возвращает строку, представляющую форматный вывод списка значений определяемого параметра СПИСОК, в соответствии с заданной первым параметром ФОРМАТ строкой формата. Символы форматирования соответствуют аналогичной функции в языке C.

sprintf ФОРМАТ, СПИСОК

[править] substr

Извлекает из строки, заданной параметром СТРОКА, подстроку длиной равной значению параметра ДЛИНА, начиная с символа, заданного параметром СМЕЩЕНИЕ. Если СМЕЩЕНИЕ отрицательно, то извлечение начинается с последнего символа строки. Если значение параметра ДЛИНА отрицательно, то от конца строки отсекается количество символов, равное абсолютному значению этого параметра. Если задана строка ЗАМЕЩЕНИЕ, то выделенная подстрока замещается ею в параметре СТРОКА, которы в этом случае должен быть lvalue.

substr СТРОКА, СМЕЩЕНИЕ [, ДЛИНА[, ЗАМЕЩЕНИЕ]]

[править] uc

Преобразаут все строчные буквы строкового параметра ВЫРАЖЕНИЕ в прописные и возвращает полученную строку. Использует текущие установки локализации, если используется use local.

uc ВЫРАЖЕНИЕ
uc        (эквивалентно uc $_)

[править] ucfirst

Преобразует первый символ строкового параметра ВЫРАЖЕНИЕ в верхний регистр и возвращает полученную строку. Использует текущие установки локализации, если используется use local.

ucfirst ВЫРАЖЕНИЕ
ucfirst   (эквивалентно ucfirst $_)
Получено с http://spravkaweb.local/index.php/perl/scalar
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 15:44, 21 января 2007.
  • К этой странице обращались 150 раз.
2.92407488823


Справочник по Perl : Функции, относящиеся к области видимости переменных — Справочник Web-языков

Справочник по Perl : Функции, относящиеся к области видимости переменных

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  | Функции, относящиеся к управлению выполнением программы
Главная | ::. | Perl | ::. | Функции, относящиеся к области видимости переменных
 |  |  |  | Функции, относящиеся к модулям Perl

Содержание

  • 1 import
  • 2 local
  • 3 my
  • 4 package
  • 5 use

[править] import

Встпвляет пространство имен одного модуля в другой. Это не встроенная функция, а всего лищь метод, наследуемый от модуля (параметр МОДУЛЬ), которому необходимо экспортировать свои имена (параметр СПИСОК) в другой модуль.

import МОДУЛЬ СПИСОК

[править] local

Функция local() используется для объявления и инициализации одной или нескольких переменных:

local EXPR
local ($myvar, $@mylist, %myhash);
local $pi = 3.14159;
local ($pi, $exp) = (3.14159, 2.71828);

но, в отличие от функции my() она создает не локальные переменные, а временные значения для глобальных переменных внутри:

  • подпрограммы;
  • заключенного в фигурные скобки блока операторов;
  • выражения, пареданного на выполнение функции eval();
  • файла;

В зависимости от того, в каком месте вызвана для объявления переменных сама функция local(). Если функция local() применяется для описания нескольких переменных, они должны быть заключены в скобки. Если глобальня перемнная, объявленная при помощи этой функции, ранее встречалась до объявления и имела некоторое значение, то это значение сохраняется в скрытом стеке и восстанавливается после выхода соответственно из подпрограммы, блока, функции eval() или файла. Переменная, объявленная при помощи функции local(), или, точнее, ее временное значение, доступна для любой функции, вызванной внутри подпрограммы, блока, функции eval() или файла, в которых сделано объявление. Такую переменную называют динамической, а ее область видимости - динамической областью видимости. В названии отражается тот факт, что область видимости переменной динамически изменяется с каждым вызовом функции, получающей доступ к этой переменной.

Пример:

sub f1{
  local ($x) = "aaaa";
  my($y)     = "bbbb";
  print("f1: x = $xn");
  print("f1: y = $ynn");
  f2();
  print("f1: x = $xn");
  print("f1: y = $ynn");
}
sub f2{
  print("f2: x = $xn");
  print("f2: y = $ynn");
  $x = "cccc";
  $y = "dddd";
  print("f2: x = $xn");
  print("f2: y = $ynn");
}
f1;

Результатом выполнения данного примера будет следующий вывод:

f1: x = aaaa
f1: y = bbbb

f2: x = aaaa
f2: y =

f2: x = cccc
f2: y = dddd

f1: x = cccc
f1: y = bbbb

Как видно из приведенного результата, функция f2() не имеет доступа к переменной $y, объявленной при помощи функции my() внутри функции f1(), и,напртив, имеет доступ к переменной $x, объявленной внутри f1() при помощи функции local().

[править] my

Функция my() используется для объявления одной или нескольких переменных локальными:

my EXPR

и ограничивает их область действия:

  • подпрограммой;
  • заключенным в фигурные скобки блоком операторов;
  • выражением, пареданным на выполнение функции eval();
  • файлом, в зависимости от того, в каком месте вызвана для объявления переменных сама функция my().

Если выражение EXPR содержит список переменных, то он должен быть заключен в скобки:

my ($myvar, @mylist, %myhash);

Одновременно с объявлением переменные могут быть инициализированны:

my $pi = 3.14159;
my ($pi, $exp) = (3.14159, 2.71828);

Переменные, объявленные при помощи функции my(), доступны в своей области действия только для подпрограмм, определенных в этой области. Для подпрограмм, определенных за ее пределами, они недоступны. Такие переменные называются лексическими, а саму область видимости - лексической или статической областью видимости.

Пример:

sub f1{
  local ($x) = "aaaa";
  my($y)     = "bbbb";
  print("f1: x = $xn");
  print("f1: y = $ynn");
  f2();
  print("f1: x = $xn");
  print("f1: y = $ynn");
}
sub f2{
  print("f2: x = $xn");
  print("f2: y = $ynn");
  $x = "cccc";
  $y = "dddd";
  print("f2: x = $xn");
  print("f2: y = $ynn");
}
f1;

Результатом выполнения данного примера будет следующий вывод:

f1: x = aaaa
f1: y = bbbb

f2: x = aaaa
f2: y =

f2: x = cccc
f2: y = dddd

f1: x = cccc
f1: y = bbbb

Как видно из приведенного результата, функция f2() не имеет доступа к переменной $y, объявленной при помощи функции my() внутри функции f1(), и,напртив, имеет доступ к переменной $x, объявленной внутри f1() при помощи функции local().

[править] package

Определяет отдельное глобальное пространство имен (пакет): все неопределенные динамические идентификаторы (включая те, которые объявлены через local(), но не my() ) будут храниться в нем. Для доступа к ним вне пакета следует указывать префикс, представляющий имя пакета с последующими двумя символами двоеточий "::". Область видимости переменных пакета распространяется до конца блока операторов, в котором расположен пакет или до нового объявления пакета. Если опущено имя пакета, то предписывает, чтобы все индентификаторы были определены, включая имена функций.

package [ИМЯ_ПАКЕТА]

[править] use

Загружает модуль во время компиляции; если модуль не доступен, то компиляция всей программы прекращается.

use МОДУЛЬ СПИСОК
use МОДУЛЬ
use МОДУЛЬ ВЕРСИЯ СПИСОК
use ВЕРСИЯ
Получено с http://spravkaweb.local/index.php/perl/showvar
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:33, 21 января 2007.
  • К этой странице обращались 99 раз.
1.90564513206


Справочник по Perl : Низкоуровневые функции работы с сокетами — Справочник Web-языков

Справочник по Perl : Низкоуровневые функции работы с сокетами

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  | Функции для работы с процессами и группами процессов
Главная | ::. | Perl | ::. | Низкоуровневые функции работы с сокетами
 |  |  |  | Функции для работы со временем и датой

Содержание

  • 1 accept
  • 2 bind
  • 3 connect
  • 4 getpeername
  • 5 getsockname
  • 6 getsockopt
  • 7 listen
  • 8 recv
  • 9 send
  • 10 setsockopt
  • 11 shutdown
  • 12 socket
  • 13 socketpair

[править] accept

Принимает входящее подключение через сокет; работает анологично системной команде accept(2). Возвращает упакованный адрес сокета в случае успешного подключения; иначе булево значение Ложь.

accept НОВЫЙ_СОКЕТ, РОДОВОЙ_СОКЕТ

[править] bind

Назначает сокету, определенному параметром СОКЕТ, сетевой адрес, заданный параметром ИМЯ. Имя сокета представляет собой упакованный адрес сокета соответствующего типа. Возвращает булево значение Истина в случае успешного назначения и Ложь в противном случае.

bind СОКЕТ, ИМЯ

[править] connect

Осуществляет подключение сокета, определенного параметром СОКЕТ, к удаленному сокету, имя которого заданно параметром ИМЯ. Имя удаленного сокета представляет собой упакованный адрес сокета соответствующего типа. Возвращает булево значение Истина в случае успешного назначения и Ложь в противном случае.

connect СОКЕТ, ИМЯ

[править] getpeername

Возвращает упакованный адрес удаленного сокета, к которому подключен СОКЕТ функцией connect().

getpeername СОКЕТ

[править] getsockname

Возвращает упакованный адрес сокета программы, который подключен функцией connect() к удаленному сокету.

getsockname СОКЕТ

[править] getsockopt

Возвращает значение затребованной опции (параметр ИМЯ_ОПЦИИ) сокета (параметр СОКЕТ) заданного уровня (параметр УРОВЕНЬ) или неопределенное значение в случае возникновения ошибки.

getsockopt СОКЕТ, УРОВЕНЬ, ИМЯ_ОПЦИИ

[править] listen

Включает режим приема для указанного сокета, регистрируя его как сервер. Возвращает булево значение Истина в случае успешного включения и Ложь в противном случае.

listen СОКЕТ, РАЗМЕР_ОЧЕРЕДИ

[править] recv

Получение заданного значением параметра ДЛИНА количества байтов через указанный сокет (параметр СОКЕТ) и сохранение их в скалярной переменной СКАЛЯР. Возвращает адреса удаленного сокета, из которого прочитанны данные, или неопределенное значение в случае возникновения ошибки при получении данных. В действительности вызывает C- функцию recvfrom(); параметр ФЛАГИ полностью соответствует аналогичному параметру указанной функции C.

recv СОКЕТ, СКАЛЯР, ДЛИНА, ФЛАГИ

[править] send

Посылает строку сообщения (параметр СООБЩЕНИЕ) через сокет, заданный параметром СОКЕТ. Параметр ФЛАГИ имеет то же смусл, что и при вызове системной функции с одноименным названием. Если сокет не подключен к удаленному сокету, то параметр АДРЕС определяет адрес сокета, к которому следует подключиться. Возвращает количество переданных символов или неопределенное значение в случае возникновения ошибки.

send СОКЕТ, СООБЩЕНИЕ, ФЛАГИ[, АДРЕС]

[править] setsockopt

Устанавливает заданную параметром ИМЯ_ОПЦИИ опцию сокета. Возвращает неопределенное значение undef в случае возникновения ошибки.

setsockopt СОКЕТ, УРОВЕНЬ, ИМЯ_ОПЦИИ, ЗНАЧЕНИЕ

[править] shutdown

Закрывает указанный в параметре СОКЕТ сокет на выполнение определенных операций, задаваемых параметром ДЕЙСТВИЕ: 0 - прекращает чтение, 1 - прекращает запись, 2 - прекращает использование сокета.

shutdown СОКЕТ, ДЕЙСТВИЕ

[править] socket

Открывает сокет указанного типа и ассоциирует его с дескриптором сокета, заданного параметром СОКЕТ. Параметры ОБЛАСТЬ, ТИП и ПРОТОКОЛ аналогичны таким же параметрам при вызове системной функции с таким же именем. Перед использованием этой функции следует оператором use Socket; импортировать необходимые определения.

socket СОКЕТ, ОБЛАСТЬ, ТИП, ПРОТОКОЛ

[править] socketpair

Создает безимянную пару двунаправленных сокетов указанного типа в заданной области. Параметры ОБЛАСТЬ, ТИП и ПРОТОКОЛ аналогичны таким же параметрам привызове системной функции с таким же именем. Возвращает булево значение Истина в случае успешного создания пары сокетов.

socketpair СОКЕТ1, СОКЕТ1, ОБЛАСТЬ, ТИП, ПРОТОКОЛ
Получено с http://spravkaweb.local/index.php/perl/socket
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:34, 23 января 2007.
  • К этой странице обращались 105 раз.
1.64468097687


Справочник по Perl : Специальные переменные — Справочник Web-языков

Справочник по Perl : Специальные переменные

 |  |  |  | Стандартные модули Perl
Главная | ::. | Perl | ::. | Специальные переменные

Содержание

  • 1 $_
  • 2 $nn
  • 3 $&
  • 4 s`
  • 5 $'
  • 6 $+
  • 7 $*
  • 8 $.
  • 9 $/
  • 10 $|
  • 11 $,
  • 12 $\
  • 13 $"
  • 14 $;
  • 15 $#
  • 16 $%
  • 17 $=
  • 18 $-
  • 19 $~
  • 20 $^
  • 21 $:
  • 22 $^L
  • 23 $^A
  • 24 $?
  • 25 $!
  • 26 $^E
  • 27 $@
  • 28 $$
  • 29 $<
  • 30 $>
  • 31 $(
  • 32 $)
  • 33 $0
  • 34 $[
  • 35 $]
  • 36 $^D
  • 37 $^F
  • 38 $^H
  • 39 $^I
  • 40 $^M
  • 41 $^O
  • 42 $^P
  • 43 $^R
  • 44 $^T
  • 45 $^W
  • 46 $^X
  • 47 $ARGV
  • 48 @ARGV
  • 49 @INC
  • 50 @_
  • 51 %INC
  • 52 %ENV
  • 53 %SIG
  • 54 @EXPORT
  • 55 @EXPORT_OK
  • 56 ARGV
  • 57 DATA
  • 58 STDERR
  • 59 STDIN
  • 60 STDOUT

[править] $_

Используется по умолчанию во многих функциях и операциях, в том числе :

  • в качестве области поиска в операциях сопоставления с образцом m//, замены s/// и транслитерации y///, когда область поиска не задана явно операцией связывания =`;
  • в качестве области ввода, когда условное выражение оператора while состоит из единственной операции ввода <>;
  • в качестве параметра функции chop, split, print;
  • в качестве переменной цикла в операторе foreach, если переменная цикла не задана явно.

[править] $nn

Переменные $1, $2,... содержат подобразы из соответствующих наборов круглых скобок в последней успешной операции сопоставления с образцом.

[править] $&

Часть строки, найденная при последней успешной операции сопоставления с образцом.

[править] s`

Часть строки, стоящая перед совпавшей частью при последней успешной операции сопоставления с образцом.

[править] $'

Часть строки, стоящая после совпавшей части при последней успешной операции сопоставления с образцом.

[править] $+

Содержит подобразец из последнего набора круглых скобок в последней успешной операции сопоставления с образцом. Например, в результате операции

"1234.5678"=~m/(\d+)\.(\d+)/;

переменная $+ получит значение 5678.

[править] $*

Устанавливает значение 0, чтобы в операциях сопоставления с образцом строка рассматривалась как мультистрока, состоящая из нескольких строк, розделенных символом новой.

Установить значение 1, чтобы в операциях сопоставления с образцом строка рассматривалась как одна строка. В этом случае метасимволу "." соответствует любой одиночный символ, в том числе и новой строки.

Устарела, для указанных целей рекомендуется в операциях сопоставления с образцом использовать ключ m и s, соответственно.

Значение по умолчанию равно 0.

[править] $.

Номер последней строки, считанной из того файла, для которого выполнялась последняя операция чтения.

[править] $/

Разделитель записей, считываемых из взодного файла. По умолчанию равен символу новой строки. Может состоять из нескольких символов. Если значение установлено неопределенным при помощи функции undef, то при чтении из входного файла границей записи является признак конца файла.

[править] $|

Обычно данные, выводимые в файл функциями print или write, предварительно помещаются в буфер. Когда буфер заполняется, его содержимое записывается в файл. Буферизация повышает эффиктивность операций вывода. По умолчанию Perl использует буферизацию для каждого выходного файла, что ссответствует нулевому значению переменной $|. Чтобы ее отменить, следует выбрать файл при помощи функции select и установить значение переменной $| не равным 0.

[править] $,

Разделитель полей выходных записей для функции print. Параметры функции print при выводе разделяются символом, который является значением переменной $,. По умолчанию этим значением является нулевой символ, т.е. выводимые элементы печатаются друг за другом. Если переменной $, присвоить, например, значение символа новой строки, то каждый параметр функции print будет напечатан в отдельной строке.

[править] $\

Разделитель выходных записей для функции print. Добавляется в конец списка параметров функции print. По умолчанию равен нулевому символу. Если установить его значение равным символу новой строки, каждый вызов функции print будет завершаться переводом на новую строку.

[править] $"

Когда переменная-массив, заключенная в двойные кавычки, передается в качестве параметра функции print, ее элементы при выводе разделяются последовательностью символов, содержащейся в переменной $". По умолчанию ее значением является символ пробела.

[править] $;

Символ, используемый в качестве разделителя индексов при эмуляции многомерных массивов. Значение по умолчанию \034. Интерпретатор, встретив запись $array{"bim","bom"}, преобразует ее к виду $array{"bim" . $; . "bom"}.

[править] $#

Формат, используемый по умолчанию для вывода чисел. Значение по умолчанию %20g, что означает представление выводимых чисел в формате с 20 знаками после десятичной точки. Не рекомендуется использовать в версиях Perl 5 и старше.

[править] $%

Каждый файл, открываемый программой Perl для ввода, имеет свою копию переменной $%, в которой храниться номер текущей страницы. В каждый момент значение переменной $% равно номеру текущей страницы текущего файла вывода.

[править] $=

Длина текущей страницы текущего файла вывода. По умолчанию значение равно 60.

[править] $-

Число строк, оставшихся на текущей странице текущего файла вывода.

[править] $~

Имя текущего формата для текущего файла вывода. Значением по умолчанию является имя дескриптора этого файла.

[править] $^

Имя текущего формата заголовка страницы для текущего файла вывода. Значением по умолчанию является имя дескриптора файла, к которому добавлен суффикс _TOP.

[править] $:

Текущее множество символов переноса слова. Если поле вывода в формате начинается с символа ^, то интерпретатор помещает в это поле вводимое слово только тогда, когда в нем достаточно места для этого слова. Чтобы определить, может ли слово поместится в поле формата, интерпретатор подсчитывает число символов между следующими выводимым символом и следующим символом переноса слова. Символ переноса слова обозначает или конец слова, или место, где слово может быть разбито на две части. По умолчанию значением переменно $: является строка, состоящая из символов пробела, новой строки и дефиса:" \n-".

[править] $^L

Признак перехода на новую страницу, используемый в шаблонах формата. Значение по умолчанию \f.

[править] $^A

Аккумулятор, используется функцией write() для временного хранения выводимых отформатированных строк.

[править] $?

Информация, возвращаемая последней операцией ``, операцией закрытия програмного канала или вызовом функции system. Представляет 16-битное целое число, состоящее из двух частей по 8 бит. Старшие 8 разрядов содержат код завершения процесса, младшие - дополнительную системную информацию о завершении процесса.

[править] $!

Некоторые функции Perl обращаются к функциям операционной системы. Если системная функция генерирует ошибку, код ошибки сохраняется в переменной $!. В числовом контексте переменная $! дает код системной ошибки, в строковом контексте - соответствующее текстовое сообщение.

[править] $^E

Информация о системной ошибке, специфическая для текущей операционной системы. Отличается от переменной $! для платформ Win32, OS/2 и VMS, для остальных платформ эти переменные совпадают.

[править] $@

Сообщение об ошибке, сгенерированное интерпретатором в результате последнего вызова функции eval(). Нулевое значение означает, что функция eval() завершилась успешно.

[править] $$

Идентификатор процесса выполняющегося интерпретатора perl.

[править] $<

Действительный идентификатор пользователя данного процесса.

[править] $>

Эффективный идентификатор пользователя данного процесса.

[править] $(

Действительный идентификатор группы данного процесса.

[править] $)

Эффективный идентификатор группы данного процесса.

[править] $0

Имя файла, содержащего выполняющуюся Perl-программу.

[править] $[

Индекс первого элемента массива и первого символа в подстроке. Значение по умолчанию 0. Не рекомендуется изменять.

[править] $]

Номер версии интерпретатора perl.

[править] $^D

Текущее значение флагов отладки, которые передаются при вызове интерпретатора с ключом -D.

[править] $^F

Максимальный номер дескриптора системного файла. Обычно системными файлами считаются стандартные файлы SYDIN, STDOUT, STDERR, которые в OC UNIX имеют дескрипторы 0, 1, 2 соответственно. Поэтому значением по умолчанию является 2.

[править] $^H

Значение, содержащее информацию о том, какие проверки синтаксиса заданы дерективой use strict.

[править] $^I

При вызове интерпретатора Perl с флагом -iextension входные файлы, полученные при помощи операции <>, можно редактировать непосредственно на месте. При этом для резервной копии файла используется имя с расширением extension. Это расширение и сохраняется в переменной $^I. Если ее значение сделать неопределенным при помощи функции undef, редактирование на месте будет запрещено.

[править] $^M

Эта переменная используется только в специально скомпилированной версии интерпретатора Perl для создания резервного буфера памяти.

[править] $^O

Имя операционной системы, в которой была осуществлена компиляция данного интерпретатора Perl.

[править] $^P

Содержит внутренние флаги отладчика Perl. Если значение равно 0, режим отладки отключен.

[править] $^R

Результат последнего удачного выполнения конструкции (?{code}), представляющий расширенный синтаксис регулярного выражения.

[править] $^T

Время, когда была запущенна программа. Измеряется в секундах относительно 1970 года.

[править] $^W

Значение ключа командной строки -w. Значение 0 подавляет вывод предупреждающих сообщений о возможных синтаксических и других ошибках, значение 1 - разрешает.

[править] $^X

Имя, по которому была вызвана выполняющаяся программа.

[править] $ARGV

Имя текущего файла при чтении из <>.

[править] @ARGV

Содержит аргументы командной строки выполняющейся программы.

[править] @INC

Содержит имена каталогов, в которых следует искать сценарии Perl, подлежащие выполнению в конструкциях do filename, require или use. Первоначально содержит: имена каталогов, переданные при запуске интерпретатору perl в качестве ключа -I; имена библиотечных каталогов по умолчанию (зависят от операционной системы); символическое обозначение текущего каталога ".".

[править] @_

Внутри подпрограммы содержится список переданных ей параметров.

[править] %INC

Содержит по одному элементу для каждого файла, подключенного при помощи функции do или require. Ключем является имя файла в том виде, как оно указано в качестве аргумента функции do или require, а значением - его полное маршрутное имя.

[править] %ENV

Содержит текущие значения переменных среды.

[править] %SIG

Служит для настройки обработки сигналов. Ключем является мнемоническое имя сигнала, значением - либо строка "IGNORE" (игнорировать сигнал), либо строка "DEFAULT" (восстановить реакцию на сигнал по умолчанию), либо строка, задающая квалифицированное имя подпрограммы-обработчика сигнала.

[править] @EXPORT

Содержит имена, которые пакет экспортирует по умолчанию.

[править] @EXPORT_OK

Содержит имена, которые пакет экспортирует по запросу вызывающей программы.

[править] ARGV

Дескриптор, ассоциированный с текущим файлом ввода, из которого осуществляется считывание при помощи операции <>. Последовательно ассоциируется с файлами, переданными в программу в качестве аргументов командной строки, имена которых сохраняются в массиве @ARGV.

[править] DATA

Специальный дескриптор файла, ассоциированный с частью файла, которая расположена после лексемы _END_. Чтение из дескриптора DATA означает считывание строки, расположенной в файле сразу за лексемой _END_, что позволяет поместить программу и данные в один файл.:

#!/usr/local/bin/perl
$line = <DATA>;
print ("$line");
_END_

Эта строка расположена в одном файле с Perl-программой.

[править] STDERR

Дескриптор стандартного файла диагностики, который обычно связан с экраном.

[править] STDIN

Дескриптор стандартного файла ввода, обычно ассоциированный с клавиатурой.

[править] STDOUT

Дескриптор стандартного файла вывода, обычно ассоциированный с экраном.

Получено с http://spravkaweb.local/index.php/perl/specialvar
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 17:12, 23 января 2007.
  • К этой странице обращались 99 раз.
2.05414795876


Справочник по Perl : Функции обработки хеш-массивов — Справочник Web-языков

Справочник по Perl : Функции обработки хеш-массивов

 |  |  |  | Функции обработки списков
Главная | ::. | Perl | ::. | Функции обработки хеш-массивов
 |  |  |  | Функции ввода/вывода

Содержание

  • 1 delete
  • 2 each
  • 3 exists
  • 4 keys
  • 5 values

[править] delete

Удаляет из хеш-массива ключ и ассоциированное с ним значение. Ключ можно задавать как вычисляемое значение выражения. Возвращет значение, ассоциированное с удаленным ключом, или неопределенное значение, если заданного ключа в хеш-массиве не существует.

delete ВЫРАЖЕНИЕ

[править] each

Возвращет следующую пару ключ/значение из хеш-массива, определенного параметром ХЕШ. Можно использовать в цикле для организации чтения хеша. В списковом контексте возвращает пару ключ/значение в виде двухэлементного списка, в скалярном контексте - только ключ. Если перебраны все элементы хеша, то в списковом контексте возвращает пустой список, а в скалярном контексте - неопределенное значение undef; следующий вызов функции each() начинает новый итерационный процесс.

each ХЕШ

[править] exists

Проверяет, существует ли в хеш-массиве заданный ключ. Если существует, то возвращает булево значение Истина, иначе - Ложь. Параметр может быть выражением, возвращающим ссылку на элемент хеша с заданным ключом, например, $hash{$key}.

exists ВЫРАЖЕНИЕ

[править] keys

В списковом контексте возвращает список, элементами которого являются все ключи хеш-массива, заданного параметром ХЕШ; в скалярном контексте возвращает количество ключей хеш-массива.

keys ХЕШ

[править] values

В списковом контексте возвращает список, элементами которого являются все значения хеш-массива, заданного параметром ХЕШ; в скалярном контексте возвращает количество значений хеш-массива.

values ХЕШ
Получено с http://spravkaweb.local/index.php/perl/xesh
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:18, 21 января 2007.
  • К этой странице обращались 103 раза.
1.91194701195


Справочник по PHP — Справочник Web-языков

Справочник по PHP

Главная ::. PHP

[править] Синтаксис языка и операторы

  • Выражения

[править] Функции работы с данными

  • Математические функции
    • Функции округления
    • Случайные числа
    • Перевод в различные системы счисления
    • Минимум и максимум
    • Степенные функции
    • Тригонометрия
    • Функции повышенной точности BCMath
    • Функции GMP
      • Введение
      • Значения функции GMP
      • Арифметика
      • Математика
      • Бинарные операции
  • Работа с массивами
    • Введение
    • Создание массива
    • Сортировка массивов
    • Курсор массива
    • Ключи и значения
    • Работа с несколькими массивами
    • Получение и удаление части массива
    • Вставка / удаление элементов
    • Переменные и массивы
  • Строковые функции
    • Функции для работы с одиночными символами
    • Функции отрезания пробелов
    • Поиск в тексте
    • Функции сравнения
    • Форматирование и вывод строк
    • Составление/разбиение строк
    • Работа с блоками текста
    • Функции для преобразования символов
    • Функции изменения регистра
    • Установка локали (локальных настроек)
    • Преобразование кодировок
    • Функции URL
    • Работа с бинарными данными
    • Строковые суммы и хеш-функции
  • XML
    • SimpleXML
      • asXML
      • attributes
      • children
      • xpath
      • simplexml_import_dom
      • simplexml_load_file
      • simplexml_load_string
  • Символические ссылки. Жесткие ссылки.
  • Функции даты и времени
  • Логические функции определения типа переменной
  • Функции переменных
  • Функции для работы с функциями
  • Календарные функции

[править] Файлы и сети

  • Работа с файлами
    • Открытие файла
    • Закрытие файла
    • Чтение и запись
    • Положение указателя текущей позиции
    • Функции для определения типов файлов
    • Определение параметров файла
    • Функции для работы с именами файлов
    • Функции манипулирования целыми файлами
    • Другие функции
  • Функции для работы с каталогами
    • Манипулирование каталогами
    • Работа с записями
  • FTP
    • Работа с FTP-сервером
    • Работа с файлами
  • Функции сжатия Bzip2
    • Введение
    • Работа с файлами Bzip2
  • Функции IMAP
  • Функции SNMP
  • Функции Vmailmgr
  • Сетевые функции

[править] Управляющие функции

  • Отслеживание и обработка ошибок
    • Введение
    • Функции обработки ошибок
    • Установка пользовательского обработчика ошибок
  • Управление сессиями
    • Зачем нужны сессии.Механизм работы сессий.
    • Инициализация сессии и регистрация переменных
    • Имя группы сессии
    • Идентификатор сессии
    • Другие функции
    • Обзор обработчиков
    • Про сессии и Cookies
  • Работа с WWW
    • Установка заголовков ответа
    • Получение заголовков запроса
    • Работа с Cookies
    • SSI и функция virtual()
  • Управление выводом
    • Введение
    • Функции управления выводом
  • Управление исполнением сценария PHP
    • Функции управления сценарием
    • Статус подключений
    • Дополнительные функции
  • Почтовые функции
  • Функции запуска программ
  • Функции динамической загрузки
  • Информационные функции

[править] Взаимодействие с базами данных

  • База данных MySQL
    • Работа с базами данных
    • Обработка результатов запроса

[править] Графика

  • Работа с изображениями и библиотека GD
    • Параметры изображения
    • Манипулирование изображениями
    • Работа с цветом в формате RGB
    • Графические примитивы
    • Работа с фиксированными шрифтами
    • Работа со шрифтами TrueType и PostScript Type 1
  • PDF-документы
    • Введение
    • Открытие документа
    • Работа с текстом
    • Установка масштаба и системы координат
    • Черчение и заполнение фигур
    • Размещение рисунков
    • Стиль документа

[править] Приложения

  • Переменные окружения
  • MIME-типы файлов

[править] Советы

  • Запрет кэширования посредством PHP
  • Создание голосования на PHP
  • Отправка писем при помощи PHP
  • Из PHP в Excel: работа с COM-объектами

[править] Полезные ссылки

  • Форум по PHP
  • www.php.net - Официальный сайт PHP
  • pear.php.net - Библиотека скриптов PEAR
  • http://www.zend.com/products/zend_studio - Среда разработки проектов на PHP от Zend.com (Форум поддержки)
  • http://framework.zend.com/ - Фреймворк от Zend.com (Форум поддержки)
Получено с http://spravkaweb.local/index.php/php
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 06:40, 25 марта 2007.
  • К этой странице обращались 1162 раза.
1.27205300331


Приложения PHP — Справочник Web-языков

Приложения PHP

Главная | ::. | PHP | ::. | Приложения PHP

[править] Приложения PHP

  • Переменные окружения
  • MIME-типы файлов
Получено с http://spravkaweb.local/index.php/php/pril
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 10:57, 18 марта 2007.
  • К этой странице обращались 88 раз.
1.52249503136


Советы по PHP — Справочник Web-языков

Советы по PHP

Главная | ::. | PHP | ::. | Советы по PHP

[править] Советы по PHP

  • Запрет кэширования посредством PHP
  • Создание голосования на PHP
  • Отправка писем при помощи PHP
    • Прикрепление файла
    • Как вставить в письмо картинку
  • Из PHP в Excel: работа с COM-объектами
    • Открытие, запись, закрытие документа
    • Формат ячеек: Выравнивание
    • Формат ячеек: Шрифт
    • Работа со строками
    • Работа с колонками
    • Добавление / Удаление / Переименование листов
    • Рисование таблиц
    • Копирование / вставка ячеек
Получено с http://spravkaweb.local/index.php/php/sovet
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 14:04, 18 марта 2007.
  • К этой странице обращались 110 раз.
1.37088894844


Справочник по PHP : Функции работы с данными : Календарные функции — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Календарные функции

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Функции для работы с функциями
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Календарные функции
 |  |  |  |  |  | Файлы и сети : Работа с файлами : Открытие файла

Содержание

  • 1 JDToGregorian
  • 2 GregorianToJD
  • 3 JDToJulian
  • 4 JulianToJD
  • 5 JDToJewish
  • 6 JewishToJD
  • 7 JDToFrench
  • 8 FrenchToJD
  • 9 JDMonthName
  • 10 JDDayOfWeek

[править] JDToGregorian

Преобразование дневного Юлианcкого счета в Грегорианскую дату.

Синтаксис:

string jdtogregorian(int julianday);

Преобразование дневного Юлианcкого счета в Грегорианскую в формате "месяц/день/год"

[править] GregorianToJD

Преобразовывает Грегорианскую дату на Дневный Юлианский cчет.

Синтаксис:

int gregoriantojd(int month, int day, int year);

Правильный диапазон для Грегорианского календаря 4714 д.э. до 9999 н.э.

Хотя это программное обеспечение может оперировать даты в обратном порядке до 4714 д.э., такое использование может быть бесполезно и не значительно. Грегорианский календарь не был учрежден до Октября 15, 1582 (или Октябрь 5, 1582 в Юлианском календаре). Некоторые страны еще очень долго не принимали его. Например, Великобритания преобразовалась в 1752, СССР в 1918 и Греции в 1923. Наиболее Европейские страны использовали Юлианский Календарь До Грегорианского.

Пример:

<?php
$jd = GregorianToJD(10,11,1970);
echo("$jdn");
$gregorian = JDToGregorian($jd);
echo("$gregoriann");
?>

[править] JDToJulian

Преобразовывает дату Юлианского календаря на дневный Юлианский счет.

Синтаксис:

string jdtojulian(int julianday);

Преобразование дневного Юлианского счета в строку, содержащую дату Юлианского Календаря в формате "месяц/день/год".

[править] JulianToJD

Преобразовывает дату Юлианского Календаря на дневной Юлианский счет.

Синтаксис:

int juliantojd(int month, int day, int year);

Правильный диапазон для Юлианского календаря 4713 д.э. до 9999 н.э.

Хотя это программное обеспечение может оперировать даты в обратном порядке до 4713 д.э. такое использование может быть бесполезно и не значительно. Календарь был создан в 46 д.э., но подробные не стабилизировался до по крайней мере 8 н.э., и возможно позднее в 4-ом столетии. Также, начало года различно от одной культуры к другой - не все соглашаются, что Январь это первый месяц.

[править] JDToJewish

Преобразовывает дневной Юлианский счет в Еврейский календарь.

Синтаксис:

string jdtojewish(int julianday);

[править] JewishToJD

Преобразовывает дату в Еврейском Календаре на дневной Юлианский счет.

Синтаксис:

int jewishtojd(int month, int day, int year);

Еврейский календарь использовался в течение нескольких тысячелетий, но в течение начального периода не было никакой формулы, чтобы определить начало месяца. Новый месяц начинался когда замечено полнолуние.

[править] JDToFrench

Преобразовывает дневной Юлианский счет в Французский Республиканский календарь.

Синтаксис:

string jdtofrench(int month, int day, int year);

Преобразовывает дневной Юлианский счет в Французский Республиканский календарь.

[править] FrenchToJD

Преобразовывает дату и Французского Республиканского календаря в дневной Юлианский счет.

Синтаксис:

int frenchtojd(int month, int day, int year);

Эта программа преобразовывают даты в начиная с 1 до 14 (Грегорианские даты 22 Сентября 1792 до 22 1806 Сентября). Это покрывает тот период когда календарь использовался.

[править] JDMonthName

Возвращает название месяца.

Синтаксис:

string jdmonthname(int julianday, int mode);

Возвращает строку с названием месяца. julianday сообщает функции, в какой календарь нужно преобразовать древний Юлианский счет на, и какой тип месячных имен должен быть возвращен.

Календарные способы

  • 0 - Грегорианский - apreviated
  • 1 - Грегорианский
  • 2 - Юлианский - apreviated
  • 3 - Юлианский
  • 4 - Еврейский
  • 5 - Французский Республиканский

[править] JDDayOfWeek

Возвращает день недели.

Синтаксис:

mixed jddayofweek(int julianday, int mode);

Возвращает день недели. Может возвратить строку(string) или int в зависимости от способа(mode).

Календарные недельные пути

Способ | Значение
0 | возвращает дневной номер как int (0=воскресенье, 1=понедельник, и т.п.)
1 | возврат string содержание дня недели (английское-грегорианское)
2 | возвращает string содержа abreviated дени недели (английский-грегорианский)
Получено с http://spravkaweb.local/index.php/php/datafun/calendar
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:59, 7 февраля 2007.
  • К этой странице обращались 77 раз.
1.64803791046


Справочник по PHP : Функции работы с данными : Функции даты и времени — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Функции даты и времени

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Символические ссылки. Жесткие ссылки.
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Функции даты и времени
 |  |  |  |  |  | Логические функции определения типа переменной

Содержание

  • 1 checkdate
  • 2 date
  • 3 localtime
  • 4 gettimeofday
  • 5 strftime
  • 6 getdate
  • 7 gmdate
  • 8 gmstrftime
  • 9 mktime
  • 10 gmmktime
  • 11 time
  • 12 microtime
  • 13 strtotime

[править] checkdate

Проверяет правильность даты/времени.

Синтаксис:

int checkdate(int month, int day, int year);

Функция checkdate() проверяет правильность даты, заданной в ее аргументах.

Возвращает true если дата, указанная как "month, day, year" (месяц, число, год), правильна, иначе false. Дата считается правильной, если:

  • год между 1 и 32767 включительно
  • месяц между 1 и 12 включительно
  • день находится в диапазоне разрешенных дней данного месяца. Високосные годы учитываются.
$month=1;
$day=10;
$year=2002;
if(checkdate($month,$day,$year)) echo "Такой день есть!";
else echo "Такого дня нет!";

Выведет:

Такой день есть!
$month=13;
$day=10;
$year=2002;
if(checkdate($month,$day,$year)) echo "Такой день есть!";
else echo "Такого дня нет!";

Выведет:

Такого дня нет!

[править] date

Формат локального времени/даты.

Синтаксис:

string date(string format [, int timestamp]);

Эта функция возвращает строку, содержащую дату и время, отформатированную согласно строке format и используя временную метку timestamp или текущее локальное время, если не задана временная метка.

В фоматной строке должны использоваться следующие символы:

  • a - "до" и "после" полудня: "am" или "pm"
  • A - "До" и "После" полудня: "AM" или "PM"
  • d - день месяца, 2 цифры (на первом месте ноль) (от 01 до 31)
  • D - день недели, текстовый, 3 буквы; т.е. "Fri"
  • j - день месяца, 1-2 цифры без начальных нулей (от 1 до 31)
  • F - месяц, текстовый, длинный; т.е. "January"
  • h - час, 12-часовой формат (от 01 до 12)
  • H - час, 24-часовой формат (от 00 до 23)
  • g - час, 12-часовой формат без нулей (от 1 до 12)
  • G - час, 24-часовой формат без нулей (от 0 до 23)
  • i - минуты (от 00 до 59)
  • I(большая i) - 1, если действует переход на летнее время, иначе 0
  • L - 0, если год не високосный, или 1 в противном случае
  • B - Swatch Internet time
  • T - временная зона компьютера, например: MDT (доступна не всегда)
  • l (строчная "L") - день недели, текстовый, длинный; т.е. "Friday"
  • m - месяц, две цифры с нулями (от 01 до 12)
  • n - месяц, одна-две цифры без нулей (от 1 до 12)
  • M - трехбуквенное английское сокращение месяца; т.е. "Jan"
  • t - число дней в указанном месяце (от 28 до 31)
  • s - секунды (от 0 до 59)
  • S - англоязычный порядковый суффикс числа из двух букв, текстовый, т.е. "th", "nd"
  • U - целое число секунд, прошедших с момента начала эпохи UNIX (доступно не всегда)
  • Y - год, цифровой, 4 цифры (1999)
  • y - год, цифровой, 2 цифры (99)
  • w - порядковое число дня в неделе,(от 0-воскресенье до 6-суббота)
  • z - порядковое число дня в году (от 0 до 365)
  • Z - смешение временной зоны в секундах (от -43200 до 43200)

Все остальные символы в строковом аргументе format возвращаются в результирующей строке "как есть".

Формат "Z" всегда возвращает 0 при использовании с функцией gmdate().

echo date("Сегодня d.m.Y");
//Сегодня 31.01.2002
echo date( "l dS of F Y h:i:s A" );
// Thursday 31st of January 2002 12:51:19 PM
echo "July 1, 2000 is on a " . date("l", mktime(0,0,0,7,1,2000));
// July 1, 2000 is on a Saturday

Функции date() и mktime() возможно использовать вместе для того, чтобы найти даты в будущем или прошлом.

$tomorrow  = mktime(0,0,0,date("m")  ,date("d")+1,date("Y"));
$lastmonth = mktime(0,0,0,date("m")-1,date("d"),  date("Y"));
$nextyear  = mktime(0,0,0,date("m"),  date("d"),   date("Y")+1);

[править] localtime

Получает информацию о дате/времени.

Синтаксис:

array localtime([int timestamp [, bool is_associative]]);

Первый необязательный аргумент этой функции задает метку времени Unix. В случае, если он не указан, то используется текущее время.

Если второй необязательный параметр равен нулю (по умолчанию), то возвращаемый массив будет численно индексирован; в противном случае возвращается ассоциативный массив, где элементы имеют следующие значения:

  • ([1])"tm_sec" - секунды
  • ([2])"tm_min" - минуты
  • ([3])"tm_hours" - часы
  • ([4])"tm_mday" - день месяца
  • ([5])"tm_mon" - месяц в году
  • ([6])"tm_year" - год, цифровой
  • ([7])"tm_wday" - день недели
  • ([8])"tm_yday" - день в году
  • ([9])"tm_isdst" - активен ли переход на летнее время

[править] gettimeofday

Получени даты системным вызовом.

Синтаксис:

array gettimeofday();

Эта функция возвращает ассоциативный массив, который содержит дату, возвращенную системным вызовом. Функция является интерфейсом системной функции gettimeofday(2). Возвращаемый ассоциативный массив содержит следующие элементы:

  • "sec" - секунды
  • "usec" - микросекунды
  • "minuteswest" - смещение к западу от Гринвича, в минутах
  • "dsttime" - тип dst коррекции (переход на летнее время)

[править] strftime

Форматирует время согласно локальным установкам.

Синтаксис:

string strftime(string format [, int timestamp]);

Возвращает строку, отформатированную согласно данной форматной строке format и используя данную временную метку timestamp или текущее локальное время, если метка не задана.

Функцией setlocale() можно выставить язык, на котором будут выводиться названия месяцев и дней.

В форматной строке следует использовать следующие спецификаторы преобразований:

  • %a - сокращенное название дня недели по умолчанию (Wed);
  • %A - полное название дня недели по умолчанию (Wednesday);
  • %b - сокращенное название месяца по умолчанию (Apr);
  • %B - полное название месяца по умолчанию (April);
  • %c - предпочтительное представление даты и времени (06/19/02 15:45:11);
  • %C - номер века (год, деленный на 100 и без дробной части, от 00 до 99);
  • %d - день месяца как десятичное число (в диапазоне от 0 до 31);
  • %D - эквивалент %m/%d/%y;
  • %e - число месяца (вместо незначащего нуля ставится пробел) (от 1 до 31);
  • %h - аналог %b;
  • %H - час как десятичное число в 24-часовом формате (в диапазоне от 00 до 23);
  • %I - час как десятичное число в 12-часовом формате (в диапазоне от 01 до 12);
  • %j - номер дня в году как десятичное число (в диапазоне от 001 до 366);
  • %m - номер месяца как десятичное число (в диапазоне от 1 до 12);
  • %M - минуты как десятичное число;
  • %n - символ перехода на новую строку;
  • %p - "am" или "pm" (до и после полудня) согласно текущему времени;
  • %r - время в 12-часовом формате (a.m. или p.m.);
  • %R - время в 24-часовом формате;
  • %S - секунды как десятичное число;
  • %t - символ табуляции;
  • %T - текущее время, эквивалентно %H:%M:$S;
  • %u - число дня в неделе (от 1 до 7) (понедельник - 1);
  • %U - номер недели в году как десятичное число, начиная с первого Воскресенья в качестве первого дня первой недели;
  • %V - номер недели в году по стандарту ISO 8601:1988 (от 1 до 53), где первая неделя - та, в которой насчитывается больше 3-х дней в текущем году;
  • %W - номер недели в году как десятичное число, начиная с первого понедельника в качестве первого дня первой недели;
  • %w - номер дня в неделе (от 0 до 6) (воскресенье - 0);
  • %x - представление даты в системном формате без указания времени (06/13/02);
  • %X - представление времени в системном формате без указания даты (15:34:54);
  • %y - год как десятичное число без столетия (в диапазоне от 00 до 99);
  • %Y - год как десятичное число, включая столетие;
  • %Z - временная зона или название или сокращение;
  • %% - символ "%".
setlocale ("LC_TIME", "C");
print(strftime("%A in Finnish is "));
setlocale ("LC_TIME", "fi");
print(strftime("%A, in French "));
setlocale ("LC_TIME", "fr");
print(strftime("%A and in German "));
setlocale ("LC_TIME", "de");
print(strftime("A.n"));

Форматирует локальное время согласно установкам locale.

[править] getdate

Получает информацию о дате/времени.

Синтаксис:

array getdate(int timestamp);

Возвращает ассоциативный массив, содержащий информацию о дате со следующими элементами:

  • "seconds" - секунды
  • "minutes" - минуты
  • "hours" - часы
  • "mday" - день месяца
  • "wday" - день недели, цифровой
  • "mon" - месяц, цифровой
  • "year" - год, цифровой
  • "yday" - день года, цифровой; т.е. "299"
  • "weekday" - день недели, текстовый, полный; т.е. "Friday"
  • "month" - месяц, текстовый, полный; т.е. "January"
  • 0 - "UNIX timestamp", полученный аргумент.
print_r(getdate(time()));

Приведенный пример выведет следующее:

Array
(
    [seconds] => 23
    [minutes] => 44
    [hours] => 22
    [mday] => 15
    [wday] => 0
    [mon] => 8
    [year] => 2004
    [yday] => 227
    [weekday] => Sunday
    [month] => August
    [0] => 1092595463
)

[править] gmdate

Получение даты в форматированной строке для времени GMT.

Синтаксис:

string gmdate(string format, int timestamp);

Аналогична функции date() за исключением того, что время возвращается в Гринвичском формате Greenwich Mean Time (GMT). Например, при запуске в Финляндии (GMT +0200), первая строка ниже напечатает "Jan 01 1998 00:00:00", в то время как вторая строка напечатает "Dec 31 1997 22:00:00".

echo date( "M d Y H:i:s",mktime(0,0,0,1,1,1998) );
echo gmdate( "M d Y H:i:s",mktime(0,0,0,1,1,1998) );

[править] gmstrftime

Форматирование локальных времени/даты.

Синтаксис:

string gmstrftime(string format, int timestamp);

Действие этой функции аналогично действию функции strftime() с тем отличием, что возвращается время по Гринвичу (GMT).

Например, при запуске в зоне (GMT -0500) первая строка бедт следующей: "Dec 31 1998 20:00:00", а вторая: " Jan 01 1999 01:00:00".

setlocale("LC_TIME", "en_US");
echo strftime("%b %d %Y %H:%M:%S", mktime(20,0,0,12,31,98))."n";
echo gmstrftime("%b %d %Y %H:%M:%S", mktime(20,0,0,12,31,98))."n";

[править] mktime

Получает временную метку UNIX для даты.

Синтаксис:

int mktime([int hour] [,int minute] [,int second] [,int month] [,int day] [,int year] [, int is_dst]);

Возвращает временную метку Unix согласно данным аргументам. Эта временная метка является целым числом, равным количеству секунд между эпохой Unix (1 Января 1970) и указанным временем.

Все парамеры это функции необязательны, но пропускать их можно только справо налево. Если какие-то параметры не заданы, на их место подставляются значения, соответствующие текущей дате.

Аргумент is_dst, указывает, осуществлен ли переход на летнее время (1) или нет (0); если не известно, то аргумент - (-1)

Функция возвращает timestamp, соответствующий указанной дате.

Правильность даты, переданной в параметрах, не проверяется. В случае некорректной даты ничего особенного не происходит - функция "делает вид", что ее не касается, и формирует соответствующий timestamp.

echo date( "M-d-Y", mktime(0,0,0,12,32,1997) ); // правильная дата
echo date( "M-d-Y", mktime(0,0,0,13,1,1997) );  // неправильная дата
echo date( "M-d-Y", mktime(0,0,0,1,1,1998) );   // неправильная дата

Выводит три одинаковых числа

[править] gmmktime

Аналог функции time() для времени GMT.

Синтаксис:

int gmmktime(int hour, int minute, int second, int month, int day, int year [, int is_dst]);

Идентична mktime() за исключением того, что передаваемые параметры передают время по Гринвичу (GMT).

[править] time

Получение времени в секунадх.

Синтаксис:

int time();

Возвращает текущее время, измеренное в числе секунд с эпохи Unix (1 Января 1970 00:00:00 GMT).

Этот формат данных принят в Unix как стандартный (называется "UNIX timestamp"): в частности, время последнего изменения файлов указывается именно в таком формате. Вообще говоря, почти все функции по работе со временеи имеют дело именно с таким его представлением (которое называется timestamp). То есть представление " количество секунд с 1 января 1970 года" весьма универсально и, что главное, - удобно.

echo time();

[править] microtime

Возвращает текущую временную метку UNIX в микросекундах.

Синтаксис:

string microtime();

Возвращает строку "msec sec" где sec текущее время, измеренное в числе секунд с эпохи Unix (0:00:00 1 Января, 1970 GMT), а msec - это часть в микросекундах. Эти функции доступны только в операционных системах, поддерживающих системный вызов gettimeofday().

Но дело в том, что милисекунды в различных OC выглядят по разному. Например в Unix это действительно число микросекунд, а в Windows - непонятное значение.

echo microtime(); // в Windows выведет что-то типа 0.53033200 1012468870

[править] strtotime

Лексическое преобразование строки времени в Unix timestamp.

Синтаксис:

int strtotime(string time [, int now]);

В аргументе time функция получает дату в англоязычном формате, а затем преобразует ее в целочисленный формат Unix timestamp.

echo strtotime("now")."n";
echo strtotime("10 September 2002")."n";
echo strtotime("+2 day")."n";
echo strtotime("+3 week")."n";
echo strtotime("+1 week 2 days 4 hours 34 seconds")."n";
Получено с http://spravkaweb.local/index.php/php/datafun/datetime
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:44, 6 февраля 2007.
  • К этой странице обращались 114 раз.
2.11665081978


Справочник по PHP : Функции работы с данными : Функции для работы с функциями — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Функции для работы с функциями

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Функции переменных
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Функции для работы с функциями
 |  |  |  |  |  | Календарные функции

Содержание

  • 1 get_defined_functions
  • 2 function_exists
  • 3 call_user_func
  • 4 create_function
  • 5 func_get_arg
  • 6 func_get_args
  • 7 func_num_args

[править] get_defined_functions

Возвращает перечень всех доступных функций.

Синтаксис:

array get_defined_functions()

Функция get_defined_functions() возвращает многомерный массив, который содержит имена всех доступных сценарию функций.

print_r(get_defined_functions);

[править] function_exists

Проверяет существование функции.

Синтаксис:

bool function_exists(string fuction_name)

Функция function_exists() возвращает значение true, если функция с именем function_name имеется в сценарии. В противном случае возвращает false.

if(function_exists("imagecreate")) {
  echo "Библиотека работы с графикой доступна!
";
} else {
  echo "Библиотека работы с графикой недоступна!
";
};

[править] call_user_func

Производит косвенный выбор функции.

Синтаксис:

mixed call_user_func(string function_name [, mixed parameter [, mixed ...]])

Функция call_user_func() вызывает функцию function_name и передает ей все остальные параметры parameter ...

<?php
function myFunc($str) {
  echo $str;
};
call_user_func("myFunc", "Hello World");
?>

[править] create_function

Динамическое создание функции.

Синтаксис:

string create_function(string args, string code)

Функция create_function() создает анонимную функцию и возвращает имя, созданное для этой функции. Аргументы функции, перечисленные в аргументе args, обычно передаются в одинарных кавычках. Также передается тело функции в аргументе code. Это необходимо для того, чтобы не допустить замену интерпретатором переменных на значения. Если всеже ограничивать двойными кавычками, то необходимо предварять указание переменных слешем :$var.

Обычно возвращаемые функцией имена содержат префикс lambda_.

При помощи этой функции можно создавать функции на основе информации, полученной во время исполнения сценария.

$func = create_function('$a,$b',
          'return "$a*$b = ".$a*$b);');
echo "Имя новой функции: $func<br>";
echo $func(2,3);

Данный пример выведет следующее:

Имя новой функции: lambda_1
6

[править] func_get_arg

Получение аргумента функции.

Синтаксис:

mixed func_get_arg(int arg_num);

Функция func_get_arg() возвращает указанный в arg_num агрумент, который был передан в текущую пользовательскую функцию в качестве параметра. Перечисление переданных в функцию параметров начинается с нуля.

В случае, если эта функция вызывается вне определения функции, то она выдает предупреждение об ошибке. Также предупреждение будет выдаваться при попытке узнать параметр, которого не существует в списке аргументов (функция возвратит false). Для того, чтобы функция работала корректно, необходимо заранее узнать общее количество параметров, которое передается в пользовательскую функцию с помощью функции func_num_args().

<?php
function func() {
  $num_args=func_num_args();
  echo "Число аргументов у этой функции: $num_args<br>";
  for($i=0;$i<$num_args;$i++)
    echo "$i агрумент: ".func_get_arg($i)."<br>";
};

func("2",1,"tree");
?>

[править] func_get_args

Получение аргументов функции в массиве.

Синтаксис:

array func_get_args();

Функция func_get_args() возвращает в массиве список аргументов, с которым была вызвана текущая пользовательская функция. Если функция func_get_args() вызывается вне определения пользовательской функции, то выдается предупреждение об ошибке.

<?php
function func() {
  $num_args = func_num_args();
  echo "Число аргументов у этой функции: $num_args<br>";
  $func_list = func_get_args();
  for($i=0;$i<$num_args;$i++)
    echo "$i агрумент номер $i: ".$func_list[$i]."<br>";
};

func("2",1,"tree");
?>

[править] func_num_args

Возвращает число полученных аргументов в пользовательской функции.

Синтаксис:

int func_num_args();

Функция func_num_args() возвращает число аргументов, которые были переданы в текущую пользовательскую функцию.

Обычно эту функцию используют совместно с функциями func_get_arg() и func_get_args() в пользовательских функциях, которые могут принимать неопределенное количество параметров.

<?php
function func() {
  $num_args = func_num_args();
  echo "Число аргументов у этой функции: $num_args<br>";
  $func_list = func_get_args();
  for($i=0;$i<$num_args;$i++)
    echo "$i агрумент номер $i: ".$func_list[$i]."<br>";
};

func("2",1,"tree");
?>
Получено с http://spravkaweb.local/index.php/php/datafun/funforfun
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:46, 7 февраля 2007.
  • К этой странице обращались 70 раз.
1.78915381432


Справочник по PHP : Функции работы с данными : Символические ссылки. Жесткие ссылки. — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Символические ссылки. Жесткие ссылки.

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | XML : SimpleXML : simplexml_load_string
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Символические ссылки. Жесткие ссылки.
 |  |  |  |  |  | Функции даты и времени

Содержание

  • 1 Немного теории
  • 2 Жесткие ссылки
  • 3 readlink
  • 4 symlink
  • 5 lstat
  • 6 linkinfo

[править] Немного теории

В системах Unix довольно часто возникает необходимость иметь для одного и того же файла или каталога разные имена. При этом одно из имен логично назвать основным, а все другие - его псевдонимами. В терминологии Unix такие псевдонимы называются символическими ссылками.

Символическая ссылка - это просто бинарный файл специального вида, который содержит ссылку на основной файл. При обращении к такому файлу (например, открытию его на чтение) система "соображает", к какому объекту на самом деле запрашивается доступ, и прозрачно его обеспечивает. Это означает, что мы можем использовать символические ссылки точно так же, как и обычные файлы. Однако иногда нужно бывает работать со ссылкой именно как со ссылкой, а не как с файлом. Для этого и существуют перечисленные ниже функции PHP.

[править] Жесткие ссылки

Создание символической ссылки - не единственный способ задать для одного файла несколько имен. Главный недостаток символических ссылок - существование основного имени файла, на которое все и ссылаются. Попробуйте удалить этот файл - и вся "паутина" ссылок, если таковая имелась, развалиться на куски. Есть и другой недостаток: открытие файла, на который указывает ссылка, происходит несколько медленнее, т.к. системе нужно проанализировать содержимое ссылки и установить связь с "настоящим" файлом. Особенно это чувствуется, если одна ссылка указывает на другую, а та на третью и т.д. уровней на 10.

Жесткие ссылки позволяют вам иметь для одного файла несколько совершенно равноправных имен, причем доступ по ним осуществляется одинаково быстро. При этом, если одно из таких имен будет удалено, то сам файл удалиться только в том случае, если данное имя было последним, и других имен у файла нет.

Зарегистрировать новое имя у файла (то есть создать для него жесткую ссылку) можно с помощью функции link(). Ее синтаксис полностью идеентичен функции symlink(), да и работает она по тем же правилам, за исключением того, что создает не символическую, а жесткую ссылку.

[править] readlink

Возвращает имя основного файла.

Синтаксис:

string readlink(string $linkname)

Возвращает имя основного файла, с которым связан его синоним $linkname. Это бывает полезно, если вы хотите узнать основное имя файла, чтобы, например, удалить сам файл, а не ссылку на него. В случае ошибки функция возвращает значение "ложь".

[править] symlink

Создает символическую ссылку.

Синтаксис:

bool symlink(string $target, string $link)

Эта функция создает символическую ссылку с именем $link на объект (файл или каталог), заданную в $target. В случае "провала" функция возвращает false.

[править] lstat

Функция собирает вместе всю информацию, выдаваемую операционной системой для указанной ссылки, и возвращает ее в виде массива.

Синтаксис:

array lstat(string $filename)

Функция полностью аналогична вызову stat(), за исключением того, что если $filename задает не файл, а символическую ссылку, будет возвращена информация именно об этой ссылке (а не о файле, на который она указывает, как это делает stat()).

[править] linkinfo

Функция возвращает значение поля "устройство" из результата, выдаваемого функцией lstat().

Синтаксис:

int linkinfo(string $linkname)

Ее обычно задействуют, если хотят определить, существует ли еще объект, на который указывает символическая ссылка в $linkname.

Получено с http://spravkaweb.local/index.php/php/datafun/link
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:32, 6 февраля 2007.
  • К этой странице обращались 82 раза.
3.03884983063


Справочник по PHP : Функции работы с данными : Логические функции определения типа переменной — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Логические функции определения типа переменной

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Функции даты и времени
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Логические функции определения типа переменной
 |  |  |  |  |  | Функции переменных

Содержание

  • 1 is_scalar
  • 2 is_null
  • 3 is_numeric
  • 4 is_bool
  • 5 is_int
  • 6 is_integer
  • 7 is_long
  • 8 is_real
  • 9 is_float
  • 10 is_double
  • 11 is_string
  • 12 is_array
  • 13 is_object
  • 14 is_resource
  • 15 get_resource_type

[править] is_scalar

Проверяет, является ли переменная простой.

Синтаксис:

bool is_scalar(mixed var)

Возвращает true, если var имеет скалярный тип (чила, строки, логические значения), но не комплексный (массивы или объекты).

[править] is_null

Проверяет, является ли переменная пустой.

Синтаксис:

bool is_null(mixed var)

Возвращает true, если var не существует (или ей явно присвоено пустое значение null). Функция эквивалентна выражению: (var===null или is_set(var)

[править] is_numeric

Проверяет, является ли переменная числовой.

Синтаксис:

bool is_numeric(mixed var)

Возвращает true, если var имеет численный тип (integer, double), или строковой с числовым значением.

[править] is_bool

Проверяет, является ли переменная логической.

Синтаксис:

bool is_bool(mixed var)

Возвращает true, если var имеет тип логического значения (TRUE или FALSE), а иначе - false.

[править] is_int

Определяет, является ли переменная типа integer(целочисленной).

Синтаксис:

bool is_int(mixed var);

Возвращает true, если var имеет целочисленный тип.

[править] is_integer

Определяет, является ли переменная типа integer.

Синтаксис:

bool is_integer(mixed var);

Возвращает true, если var является типа integer (целочисленной), или false в обратном случае.

[править] is_long

Определяет, является ли переменная типа integer(целочисленной).

Синтаксис:

bool is_long(mixed var);

Возвращает true, если var имеет целочисленный тип (integer, long), или false в обратном случае.

[править] is_real

Определяет, является ли переменная типа real (дробной).

Синтаксис:

bool is_real(mixed var);

Возвращает true, если var типа real (дробная), или false в обратном случае.

[править] is_float

Определяет, является ли переменная типа float (дробная).

Синтаксис:

bool is_float(mixed var);

Возвращает true, если var типа float (дробная), или false в обратном случае.

[править] is_double

Определяет, является ли переменная типа double (дробная).

Синтаксис:

bool is_double(mixed var);

Возвращает true, если var является типа double (дробной), или false в обратном случае.

[править] is_string

Определяет, является ли переменная строкой.

Синтаксис:

bool is_string(mixed var);

Возвращает true, если var - это строка, или false в обратном случае.

[править] is_array

Определяет, является ли переменная массивом.

Синтаксис:

bool is_array(mixed var);

Возвращает true, если var - это массив, или false в обратном случае.

[править] is_object

Определяет, является ли переменная объектом.

Синтаксис:

bool is_object(mixed var);

Возвращает true, если var - это объект (object), или false в обратном случае.

[править] is_resource

Определяет, является ли переменная указателем на ресурс.

Синтаксис:

bool is_resource(mixed var);

Возвращает true, если var указывает на ресурс, выделенный и возвращенный предназначенной для этого функцией.

Ресурсы - это объекты, подобные файлам или результатам запросов к базам данных, выделяемые и освобождаемые внутренними функциями PHP. Когда программе больше не требуется какой-либо ресурс, хорошей практикой программирования является его явное освобождение предназначенными для этого функциями. Но в большинстве случаев интерпретатор PHP самостоятельно, по мере необходимости освобождает ненужные ресурсы (обычно при завершении сценария).

[править] get_resource_type

Определение типа дескриптора ресурса.

Синтаксис:

string get_resource_type(resource $handle);

Эта функция возвращает строку, содержащую описание типа ресурса. Если в аргументе передается неверный указатель на ресурс, то возникает ошибка.

$c = mysql_connect();
echo get_resource_type($c)."n";
// выведет: mysql link

$file = fopen("filename.txt","w");
echo get_resource_type($file)."n";
// выведет: file

$doc = new_xmldoc("1.0");
echo get_resource_type($doc)."n";
// выведет: domxml document

Получено с http://spravkaweb.local/index.php/php/datafun/type
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 20:09, 6 февраля 2007.
  • К этой странице обращались 74 раза.
1.5248799324


Справочник по PHP : Функции работы с данными : Функции переменных — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Функции переменных

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Логические функции определения типа переменной
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Функции переменных
 |  |  |  |  |  | Функции для работы с функциями

Содержание

  • 1 gettype
  • 2 intval
  • 3 doubleval
  • 4 empty
  • 5 isset
  • 6 settype
  • 7 strval
  • 8 unset

[править] gettype

Получает тип переменной.

Синтаксис:

string gettype(mixed var);

Возвращает тип переменной PHP var.

Возможные значения для возвращаемой строки:

  • integer
  • double
  • string
  • array
  • object
  • unknown type

[править] intval

Возвращает целочисленное значение переменной.

Синтаксис:

int intval(mixed var, int [base]);

Возвращает целочисленное значение переменной var, используя указанное основание для перевода (по умолчанию 10). var может быть скалярного типа. Вы не можете использовать функцию intval() для массивов или объектов.

[править] doubleval

Получает значение переменной в формате double.

Синтаксис:

double doubleval(mixed var);

Возвращает double (с плавающей точкой) значение переменной var.

var может быть скалярного типа. Вы не можете использовать doubleval() на массивах и объектах.

[править] empty

Определяет, есть ли у переменной какое либо значение.

Синтаксис:

int empty(mixed var);

Возвращает false, если var существует и имеет не пустое или не нулевое значение; true в обратном случае.

Фактически функция проверяет, имеет ли переменное значение, которое может быть приравнено к 0, то есть: (var==0)

$var=0;
if(empty($var)) {
  echo "$var - либо 0, либо не имеет значения";
  if(!isset($var)) {
    echo "$var не имеет значения";
  };
};

Заметьте, что эту функцию бесполезно использовать с аргументом, отличным от переменной, например выражение empty (Addslashes($name)) бессмысленно, т.к. здесь проверяется значение, возвращаемое функцией. Единственное, что может выявить в данном варианте функция empty(), это имеет ли выражение значение, эквивалентное true (не равное нулю), а это может быть проверено и без использования функции.

[править] isset

Определяет, существует ли переменная.

Синтаксис:

int isset(mixed var);

Возвращает true, если var существует; false в обратном случае.

Фактически функция проверяет, имеет ли переменная значение, идентичное null, то есть: (var===null). Отметьте различие между равенством и идентичностью.

Если переменная была удалена функцией unset(), она больше не будет определяться функцией isset().

$a = "test";
echo isset($a); // true
unset($a);
echo isset($a); // false

[править] settype

Устанавливает тип переменной.

Синтаксис:

int settype(string var, string type);

Устанавливает тип переменной var на type.

Возможные значения type :

  • integer
  • double
  • string
  • array
  • object

Возвращает true, при успехе; false в обратном случае.

[править] strval

Получает строковое значение переменной.

Синтаксис:

string strval(mixed var);

Получает строковое значение var.

var может быть любого скалярного типа. Вы не можете использовать strval() на массивах или объектах.

[править] unset

Удаляет указанную переменную.

Синтаксис:

int unset(mixed var);

unset() уничтожает указанную переменную и возвращает true.

Пример:

unset( $foo );
unset( $bar["quux"] );
Получено с http://spravkaweb.local/index.php/php/datafun/variable
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:40, 7 февраля 2007.
  • К этой странице обращались 77 раз.
1.37258696556


Справочник по PHP : Функции работы с данными : Работа с массивами : Введение — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Работа с массивами : Введение

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Математические функции > Функции GMP > Бинарные операции
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Работа с массивами | ::. | Введение
 |  |  |  |  |  |  |  | Создание массива

Содержание

  • 1 Функции для работы с массивами
    • 1.1 Введение
    • 1.2 Требования
    • 1.3 Установка
    • 1.4 Настройка во время выполнения
    • 1.5 Типы ресурсов
    • 1.6 Предопределенные константы
    • 1.7 Содержание

[править] Функции для работы с массивами

[править] Введение

Эти функции позволят вам различными способами оперировать с массивами. Массивы идеально подходят для хранения, изменения и работы с наборами переменных.

Поддерживаются одно- и многоразмерные массивы, как созданные пользователем, так и возвращенные в качестве результата какой-либо функцией. Существуют специальные функции для работы с базами данных, облегчающие работу с массивами данных, возвращаемых в результате выполнения запросов; также существуют функции, возвращающие массивы в качестве результата.

[править] Требования

Эти функции всегда доступны.

[править] Установка

Для использования этих функций не требуется проведение установки, поскольку они являются частью ядра PHP.

[править] Настройка во время выполнения

Данное расширение не определяет никакие директивы конфигурации в php.ini.

[править] Типы ресурсов

Данное расширение не определяет никакие типы ресурсов.

[править] Предопределенные константы

Перечисленные ниже константы всегда доступны как часть ядра PHP.

CASE_LOWER (integer)
CASE_LOWER используется с функцией array_change_key_case() для указания необходимости преобразования ключей массива в нижний регистр символов. По умолчанию функцией array_change_key_case() используется именно эта константа.
CASE_UPPER (integer)
CASE_UPPER используется с функцией array_change_key_case() для указания необходимости преобразования ключей массива в верхний регистр символов.

Флаги типа сортировки:

SORT_ASC (integer)
SORT_ASC - сортировка в порядке возрастания (по умолчанию)
SORT_DESC (integer)
SORT_DESC - сортировка в порядке убывания
SORT_REGULAR (integer)
SORT_REGULAR - сравнивать элементы как есть (по умолчанию)
SORT_NUMERIC (integer)
SORT_NUMERIC - сравнивать элементы как числа
SORT_STRING (integer)
SORT_STRING - сравнивать элементы как строки
EXTR_OVERWRITE (integer)
EXTR_SKIP (integer)
EXTR_PREFIX_SAME (integer)
EXTR_PREFIX_ALL (integer)
EXTR_PREFIX_INVALID (integer)
EXTR_IF_EXISTS (integer)
EXTR_PREFIX_IF_EXISTS (integer)
EXTR_REFS (integer)

[править] Содержание

  • array() -- Создание и инициализация массива.
  • array_change_key_case() -- Функция устанавливает значения ключей массива в верхний или нижний регистр.
  • array_chunk() -- Функция разбивает массив на части.
  • array_combine() -- Функция объединяет два массива, причем значения первого становяться ключами, а значения второго - значениями.
  • array_count_values() -- Возвращает количество значений массива.
  • array_diff() -- Определение исключительного пересечения массивов.
  • array_diff_assoc() -- Определение исключительного пересечения массивов с учетом индексов массивов.
  • array_diff_uassoc() -- Определение различия между массивами при помощи пользовательской функции с дополнительной проверкой ключей массива.
  • array_fill() -- Функция заполняет массив определенными значениями.
  • array_filter() -- Функция применяет фильтр к массиву, используя пользовательскую функцию.
  • array_flip() -- Меняет местами индексы и значения массива.
  • array_intersect() -- Определение включительного пересечения массивов.
  • array_intersect_assoc() -- Функция возвращает пересечения значений массивов с сохранением индексов.
  • array_key_exists() -- Проверка существования заданного ключа в массиве.
  • array_keys() -- Возвращает список из ключей массива.
  • array_map() -- Применение пользовательской функции ко всем элементам указанных массивов.
  • array_merge() -- Слияние массивов.
  • array_merge_recursive() -- Рекурсивное слияние сложных массивов.
  • array_multisort() -- Сортировка нескольких массивов или многомерного массива.
  • array_pad() -- Добавляет в массив несколько элементов.
  • array_pop() -- Извлекает и удаляет последние элементы массива.
  • array_push() -- Добавляет один или несколько элементов в конец массива.
  • array_rand() -- Производит случайную выборку индексов массива.
  • array_reverse() -- Расстановка элементов массива в обратном порядке.
  • array_shift() -- Извлекает и удаляет первый элемент массива.
  • array_slice() -- Получение части массива.
  • array_splice() -- Удаляет часть массива или заменяет ее частью другого массива.
  • array_sum() -- Возвращает сумму всех элементов массива.
  • array_udiff() -- Сравнивает массивы используя пользовательскую функцию.
  • array_udiff_assoc() -- Сравнивает массивы используя пользовательскую функцию.
  • array_udiff_uassoc() -- Сравнивает массивы используя пользовательскую функцию.
  • array_unique() -- Удаляет дублирующие значения в массиве.
  • array_unshift() -- Добавляет одно или несколько значений в начало массива.
  • array_values() -- Удаление ассоциативных индексов массива.
  • array_walk() -- Применение пользовательской функции к элементам массива.
  • arsort() -- Сортировка ассоциативного массива по убыванию.
  • asort() -- Сортировка ассоциативного массива по возрастанию.
  • compact() -- Упаковывает в массив переменные из текущего контекста.
  • count() -- Возвращает число элементов в массиве или объекте.
  • current() -- Определение текущего элемента массива.
  • each() -- Получение текущего элемента массива.
  • end() -- Производит перенос курсора в конец массива.
  • extract() -- Импорт элементов массива в переменные.
  • in_array() -- Осуществляет проверку массива на наличие значения.
  • key() -- Функция возвращает индекс текущего элемента массива.
  • krsort() -- Сортировка массива по убыванию индексов.
  • ksort() -- Сортировка массива по возрастанию ключей.
  • list() -- Заносит элементы массива в переменные.
  • natcasesort() -- Выполняет естественную сортировку массива без учета регистра символов.
  • natsort() -- Выполняет "естественную" сортировку массива.
  • next() -- Производит перенос курсора вперед.
  • pos() -- Определение текущего элемента массива.
  • prev() -- Производит перенос курсора назад и возвращает предыдущее значени.
  • range() -- Создает массив и заполняет его значениями.
  • reset() -- Производит сброс курсора массива.
  • rsort() -- Сортировка массива по убыванию.
  • shuffle() -- Перемешивание элементов массива.
  • sizeof() -- Возвращает число элементов массива.
  • sort() -- Сортировка массива по возрастанию.
  • uasort() -- Пользовательская сортировка ассоциативного массива с сохранением индексных ассоциаций.
  • uksort() -- Пользовательская сортировка массива по ключам.
  • usort() -- Пользоваетльская сортировка значений массива.
Получено с http://spravkaweb.local/index.php/php/datafun/array/about
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 06:26, 25 марта 2007.
  • К этой странице обращались 178 раз.
1.84012985229


Справочник по PHP : Функции работы с данными : Работа с массивами : Создание массива — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Работа с массивами : Создание массива

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Введение
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Работа с массивами | ::. | Создание массива
 |  |  |  |  |  |  |  | Сортировка массивов

[править] array

Создание и инициализация массива.

Синтаксис:

array array([mixed ...])

Функция возвращает созданный массив. Индексы и значения в массиве разделяются оператором =>. Пары index=>value разделяются запятыми, они определяют индекс и значение.

Индекс может быть как числовым, так и строковым. В ассоциированных массивах индекс всегда ведет себя как строковой. В случае, если индекс не указан, будет подставляться автоинкремент (на 1 больше), начиная с 0. Если при создании массива были указаны два элемента с одинаковыми индексами, то последний элемент заменяет первый.

Пример использования функции array():

<?php
$arr=array( // Далее мы создадим двумерный массив
"fruit" => array("a"=>"orange", "b"=>"banan", "c"=>"apple"),
// эта запись эквивалентна записи: $arr["fruit"]["a"]="orange"; и т.д.
"number" => array(1,2,3,4,5,6),
// эта запись эквивалентна записи: $arr["number"][]=1; и т.д.
"hotel" => array("first", 5=>"second", "third")
);
?>
$arr=array(1, 1, 1, 1, 2=>5, 19, 3=>20);
print_r($arr);
// Далее распечатка этого массива
Array
(
    [0] => 1
    [1] => 1
    [2] => 5
    [3] => 20
    [4] => 19
)
$arr=array(1 => "Январь", "Февраль", "Март");
print_r($arr);
// распечатка
Array
(
    [1] => Январь
    [2] => Февраль
    [3] => Март
)

Функция поддерживается PHP 3, PHP 4, PHP 5

[править] range

Создает массив и заполняет его значениями.

Синтаксис:

array range(int low, int high[, int step])

Функция range() возвращает массив с значениями от low по high включительно. Если low > high, то последовательность будет от high до low.

Дополнительный параметр step был введен в PHP 5.0.

Если третий параметр указан, то числа будут вводиться от low до high с шагом step. Если он не указан, то шаг будет равен 1.

Пример использования функции range():

<?php
// array(0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12)
foreach (range(0, 12) as $number) {
    echo $number;
}

// The step parameter was introduced in 5.0.0
// array(0, 10, 20, 30, 40, 50, 60, 70, 80, 90, 100)
foreach (range(0, 100, 10) as $number) {
    echo $number;
}

// Use of character sequences introduced in 4.1.0
// array("a", "b", "c", "d", "e", "f", "g", "h", "i");
foreach (range("a", "i") as $letter) {
    echo $letter;
}
// array("c", "b", "a");
foreach (range("c", "a") as $letter) {
    echo $letter;
}
?>

Функция поддерживается PHP 3 >= 3.0.8, PHP 4, PHP 5

Получено с http://spravkaweb.local/index.php/php/datafun/array/create
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 20:43, 25 января 2007.
  • К этой странице обращались 108 раз.
1.39182591438


Справочник по PHP : Функции работы с данными : Работа с массивами : Вставка / удаление элементов — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Работа с массивами : Вставка / удаление элементов

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Получение и удаление части массива
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Работа с массивами | ::. | Вставка / удаление элементов
 |  |  |  |  |  |  |  | Переменные и массивы

Содержание

  • 1 array_pad
  • 2 array_pop
  • 3 array_push
  • 4 array_shift
  • 5 array_unshift
  • 6 array_unique
  • 7 array_chunk
  • 8 array_fill
  • 9 array_filter
  • 10 array_map

[править] array_pad

Добавляет в массив несколько элементов.

Синтаксис:

array array_pad(array input, int pad_size, mixed pad_value)

Функция array_pad() возвращает копию массива input, в который были добавлены элементы с значениями pad_value, так, что число элементов в получившемся массиве будет равно pad_size.

Если pad_size>0, то элементы будут добавлены в конец массива, а если <0 - то в начало.

В случае, если значение pad_size меньше элементов в исходном массиве input, то никакого добавления не произойдет, и функция вернет исходный массив input.

Пример использования функции array_pad():

$arr = array(12, 10, 4);
$result = array_pad($arr, 5, 0);
// $result = array(12, 10, 4, 0, 0);

$result = array_pad($arr, -7, -1);
// $result = array(-1, -1, -1, -1, 12, 10, 4)

$result = array_pad($arr, 2, "noop");
// не добавит

Функция поддерживается PHP 4, PHP 5

[править] array_pop

Извлекает и удаляет последние элементы массива.

Синтаксис:

mixed array_pop(array arr);

Функция array_pop() извлекает последний элемент из массива arr и возвращает его, удалив после этого. С помощью этой функции мы можем строить конструкции, напоминающие стек. Если массив arr был пуст, или это не массив, функция возвращает пустую строку NULL.

После использования функции array_pop() курсор массива устанавливается в начало.

Пример использования функции array_pop():

<?php
$stack = array("orange", "apple", "raspberry");
$fruits = array_pop($stack);
print_r($stack);
print_r($fruits);
?>

Пример выведет следующее:

Array
(
    [0] => orange
    [1] => banana
    [2] => apple
)

Функция поддерживается PHP 4, PHP 5

[править] array_push

Добавляет один или несколько элементов в конец массива.

Синтаксис:

int array_push(array arr, mixed var1 [, mixed var2, ..])

Функция array_push() добавляет к массиву arr элементы var1, var2 и т.д. Она присваивает им числовые индексы - точно так же, как это происходит для стандартных []. Если вам нужно добавить всего один элемент, наверное, проще будет воспользоваться этим оператором:

array_push($Arr,1000);     // вызываем функцию
$Arr[]=100;                // то же самое, но короче

Пример использования функции array_push():

<?php
$stack = array("orange", "banana");
array_push($stack, "apple", "raspberry");
print_r($stack);
?>

Пример выведет следующее:

Array
(
    [0] => orange
    [1] => banana
    [2] => apple
    [3] => raspberry
)

Обратите внимание, что функция array_push() воспринимает массив, как стек, и добавляет элементы всегда в его конец.

Функция поддерживается PHP 4, PHP 5

[править] array_shift

Извлекает и удаляет первый элемент массива.

Синтаксис:

mixed array_shift(array arr)

Функция array_shift() извлекает первый элемент массива arr и возвращает его. Она сильно напоминает array_pop(), но только получает начальный, а не конечный элемент, а также производит довольно сильную "встряску" всего массива: ведь при извлечении первого элемента приходится корректировать все числовые индексы у всех оставшихся элементов, т.к. все последующие элементы массива сдвигаются на одну позицию вперед. Строковые ключи массива не изменяются.

Если массив arr пустой или он не является массивом, функция возвращает NULL.

После использования этой функции указатель массива становится в начало.

Пример использования функции array_shift():

<?php
$stack = array("orange", "banana", "apple", "raspberry");
$fruit = array_shift($stack);
print_r($stack);
?>

Данный пример выведет следующее:

Array
(
    [0] => banana
    [1] => apple
    [2] => raspberry
)

а переменная $fruit будет иметь значение "orange"

Функция поддерживается PHP 4, PHP 5

[править] array_unshift

Добавляет одно или несколько значений в начало массива.

Синтаксис:

int array_unshift(list arr, mixed var1 [,mixed var2, ...])

Функция array_unshift() добавляет переданные значения var в начало массива arr. Порядок расположения новых элементов в массиве сохраняется. Все цифровые индексы массива будут изменены таким образом, чтобы она начинались с нуля. Все строковые индексы массива не изменяются.

Функция возвращает новое количество элементов в массиве.

Пример использования функции array_unshift():

<?php
$queue = array("orange", "banana");
array_unshift($queue, "apple", "raspberry");
?>

Теперь переменная $queue будет иметь следующие элементы:

Array
(
    [0] => apple
    [1] => raspberry
    [2] => orange
    [3] => banana
)

Функция поддерживается PHP 4, PHP 5

[править] array_unique

Удаляет дублирующие значения в массиве.

Синтаксис:

array array_unique(array arr)

Функция array_unique() возвращает массив, составленный из всех уникальных значений массива arr вместе с их ключами, путем удаления всех дублирующих значений. В результирующий массив помещаются первые встретившиеся пары ключ=>значение. Индексы сохраняются.

Пример использования функции array_unique():

<?php
$input = array("a" => "green", "red", "b" =>
         "green", "blue", "red");
$result = array_unique($input);
print_r($result);
?>

Пример выведет следующее:

Array
(
    [a] => green
    [0] => red
    [1] => blue
)

Пример использования функции array_unique(): Сравнение типов данных

<?php
$input = array(4, "4", "3", 4, 3, "3");
$result = array_unique($input);
var_dump($result);
?>

Пример выведет следующее:

array(2) {
  [0] => int(4)
  [2] => string(1) "3"
}

Функция поддерживается PHP 4 >= 4.0.1, PHP 5

[править] array_chunk

Функция разбивает массив на части.

Синтаксис:

array array_chunk(array arr, int size [, bool preserve_keys])

Функция array_chunk() разбивает исходный массив arr на несколько массивов, длина которых задается числом size. Если размерность исходного массива не делится ровно на size частей, то последний массив будет иметь меньшую размерность.

Функция array_chunk() возвращает многомерный массив, индексами которого начинаются от 0 и до кол-ва полученных массивов, а значения - полученные в результате разбивки массивы.

Необязательный параметр preserve_keys указывает, стоит ли сохранять ключи исходного массива или нет. Если этот параметр равен false (значение по умолчанию), то индексы полученных массивов будут заданы числами начиная с нуля. Если же параметр равен true, то ключи исходного массива сохраняются.

Пример использования функции array_chunk():

$array = array("1-ый элемент",
               "2-ой элемент",
               "3-ий элемент",
               "4-ый элемент",
               "5-ый элемент");

print_r(array_chunk($array, 2));
print_r(array_chunk($array, 2, TRUE));

Пример выведет следующее:

Array
(
    [0] => Array
        (
            [0] => 1-ый элемент
            [1] => 2-ой элемент
        )

    [1] => Array
        (
            [0] => 3-ий элемент
            [1] => 4-ый элемент
        )

    [2] => Array
        (
            [0] => 5-ый элемент
        )

)
Array
(
    [0] => Array
        (
            [0] => 1-ый элемент
            [1] => 2-ой элемент
        )

    [1] => Array
        (
            [2] => 3-ий элемент
            [3] => 4-ый элемент
        )

    [2] => Array
        (
            [4] => 5-ый элемент
        )

)

Функция поддерживается PHP 4 >= 4.2.0, PHP 5

[править] array_fill

Функция заполняет массив определенными значениями.

Синтаксис:

array array_fill(int start_index, int num, mixed value)

Функция array_fill() возвращает массив, который содержит значения, указанные в параметре value размерностью num начиная с элемента, указанного в параметре start_index.

Пример использования array_diff_uassoc():

<?php
$a = array_fill(5, 6, 'banana');
print_r($a);
?>

Пример выведет следующее:

Array
(
    [5]  => banana
    [6]  => banana
    [7]  => banana
    [8]  => banana
    [9]  => banana
    [10] => banana
)

Функция поддерживается PHP 4 >= 4.2.0, PHP 5

[править] array_filter

Функция применяет фильтр к массиву, используя пользовательскую функцию.

Синтаксис:

array array_filter(array input [, callback callback])

Функция array_filter() возвращает массив, который содержит значения, имеющиеся в массиве input отфильтрованные в соответсвтии с результатами работы пользовательской функции callback.

В случае, если исходный массив input является ассоциативным массивом, в результирующем массиве индексы сохраняются.

Пример использования функции array_filter():

<?php
function odd($var) {
    return ($var % 2 == 1);
}

function even($var) {
    return ($var % 2 == 0);
}

$array1 = array ("a"=>1, "b"=>2, "c"=>3, "d"=>4, "e"=>5);
$array2 = array (6, 7, 8, 9, 10, 11, 12);

echo "Нечетные :n";
print_r(array_filter($array1, "odd"));
echo "Четные   :n";
print_r(array_filter($array2, "even"));
?>

Пример выведет следующее:

Нечетные :
Array
(
    [a] => 1
    [c] => 3
    [e] => 5
)
Четные   :
Array
(
    [0] => 6
    [2] => 8
    [4] => 10
    [6] => 12
)

Стоит отметить, что вместо имени фильтрующей функции можно указать массив, который содержит ссылку на объект и имя метода.

Также стоит отметить, что при обработке массива фукцией array_filter() его нельзя изменять: добавлять, удалять элементы или обнулять массив, т.к. это может привести к некоррекстной работе функции.

Функция поддерживается PHP 4 >= 4.0.6, PHP 5

[править] array_map

Применение пользовательской функции ко всем элементам указанных массивов.

Синтаксис:

array array_map(mixed callback, array arr1 [, array ...])

Функция array_map() возвращает массив, который содержит элементы всех указанных массивов после обработки пользовательской функцией callback.

Количество параметров, передаваемых пользовательской функции, должно совпадать с количеством массивов, переданных функции array_map().

Пример испольльзования функции array_map(): Обработка одного массива

<?php
function cube($n) {
    return $n*$n*$n;
}

$a = array(1, 2, 3, 4, 5);
$b = array_map("cube", $a);
print_r($b);
?>

Приведенный пример выведет следующее:

Array
(
    [0] => 1
    [1] => 8
    [2] => 27
    [3] => 64
    [4] => 125
)

Пример испольльзования функции array_map(): Обработка нескольких массивов

<?php
function show_Spanish($n, $m) {
    return "Число $n по-испански -  $m";
}

function map_Spanish($n, $m) {
    return array ($n => $m);
}

$a = array(1, 2, 3, 4, 5);
$b = array("uno", "dos", "tres", "cuatro", "cinco");

$c = array_map("show_Spanish", $a, $b);
print_r($c);

$d = array_map("map_Spanish", $a , $b);
print_r($d);
?>

Приведенный пример выведет следующее:

// printout of $c
Array
(
    [0] => Число 1 по-испански -  uno
    [1] => Число 2 по-испански -  dos
    [2] => Число 3 по-испански -  tres
    [3] => Число 4 по-испански -  cuatro
    [4] => Число 5 по-испански -  cinco
)

// printout of $d
Array
(
    [0] => Array
        (
            [1] => uno
        )

    [1] => Array
        (
            [2] => dos
        )

    [2] => Array
        (
            [3] => tres
        )

    [3] => Array
        (
            [4] => cuatro
        )

    [4] => Array
        (
            [5] => cinco
        )

)

Обычно функцию array_map() применяют к массивам, имеющим одинаковую размерность. Если массивы имеют разную длину, то меньшие из них дополняются элементами с пустыми значениями.

Следует отметить, что если вместо имени обрабатывающей функции задать null, то будет создан массив массивов.

Пример испольльзования функции array_map(): Создание массива массивов

<?php
$a = array(1, 2, 3, 4, 5);
$b = array("one", "two", "three", "four", "five");
$c = array("uno", "dos", "tres", "cuatro", "cinco");

$d = array_map(null, $a, $b, $c);
print_r($d);
?>

Приведенный пример выведет следующее:

Array
(
    [0] => Array
        (
            [0] => 1
            [1] => one
            [2] => uno
        )

    [1] => Array
        (
            [0] => 2
            [1] => two
            [2] => dos
        )

    [2] => Array
        (
            [0] => 3
            [1] => three
            [2] => tres
        )

    [3] => Array
        (
            [0] => 4
            [1] => four
            [2] => cuatro
        )

    [4] => Array
        (
            [0] => 5
            [1] => five
            [2] => cinco
        )

)

Функция поддерживается PHP 4 >= 4.0.6, PHP 5

Получено с http://spravkaweb.local/index.php/php/datafun/array/element
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 15:47, 28 января 2007.
  • К этой странице обращались 105 раз.
1.76027989388


Справочник по PHP : Функции работы с данными : Работа с массивами : Ключи и значения — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Работа с массивами : Ключи и значения

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Курсор массива
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Работа с массивами | ::. | Ключи и значения
 |  |  |  |  |  |  |  | Работа с несколькими массивами

Содержание

  • 1 array_flip
  • 2 array_keys
  • 3 array_values
  • 4 in_array
  • 5 array_count_values
  • 6 sizeof
  • 7 count
  • 8 array_sum
  • 9 array_rand
  • 10 array_change_key_case
  • 11 array_combine
  • 12 array_key_exists

[править] array_flip

Меняет местами индексы и значения массива.

Синтаксис:

array array_flip(array arr)

Эта функция "пробегает" по массиву и меняет местами его ключи и значения. Исходный массив arr не изменяется, а результирующий массив просто возвращается. Если в массиве присутствовало несколько элементов с одинаковыми значениями, учитываться будет только последний из них.

Значения массива arr должны быть либо целыми числами, либо строковыми значениями. Иначе пара ключ / значение не будут обработаны.

Функция array_flip() возвратит FALSE, если обработка массива вызвала ошибку.

Пример использования функции array_flip():

$trans = array_flip ($trans);
$original = strtr ($str, $trans);

Пример использования функции array_flip():

многократное повторение значения

<php
$trans = array ("a" => 1, "b" => 1, "c" => 2);
$trans = array_flip ($trans);
print_r($trans);

Приведенный выше пример выведет следующее:

Array
(
    [1] => b
    [2] => c
)

Функция поддерживается PHP 4, PHP 5

[править] array_keys

Возвращает список из ключей массива.

Синтаксис:

array array_keys(array arr [,mixed search_value])

Функция возвращает массив, значениями которого являются все строковые и числовые ключи массива arr. Если задан необязательный параметр search_value, то она вернет только те ключи, которым соответствуют значению search_value.

Пример испольльзования функции array_keys():

<?php
$arr = array(0 => 100, "color" => "red", 15);
print_r(array_keys($arr));

$arr = array("blue", "red", "green", "blue", "blue");
print_r(array_keys($arr, "blue"));

$array = array ("color" => array("blue", "red", "green"), "size" => array("small", "medium", "large"));
print_r(array_keys ($array));
?>

Приведенный выше пример выведет следующее:

Array
(
    [0] => 0
    [1] => color
)
Array
(
    [0] => 0
    [1] => 3
    [2] => 4
)
Array
(
    [0] => color
    [1] => size
)

Функция array_keys() появилась в PHP 4.

Ее эквивалент для PHP 3:

function array_keys ($arr, $term="") {
    $t = array();
    while (list($k,$v) = each($arr)) {
        if ($term && $v != $term) {
            continue;
        }
        $t[] = $k;
    }
    return $t;
}

Функция поддерживается PHP 4, PHP 5

[править] array_values

Удаление ассоциативных индексов массива.

Синтаксис:

array array_values(array arr)

Функция array_values() возвращает список всех значений в ассоциативном массиве arr. При этом она заменяет все строковые ключи на числовые.

Пример использования функции array_values():

$arr = array("size" => "XL", "color" => "gold");
print_r(array_values($arr));

Этот пример выведет:

Array
(
    [0] => XL
    [1] => gold
)

Функция поддерживается PHP 4, PHP 5

[править] in_array

Осуществляет проверку массива на наличие значения.

Синтаксис:

bool in_array ( mixed needle, array haystack [, bool strict])

Функция in_array() возвратит TRUE, если в массиве haystack содержится элемент со значением needle, и FALSE в противном случае.

Если установить третий необязательный параметр strict в значение TRUE, то функция in_array() при проверке также будет сравнивать типы значений.

Замечание: Если параметр needle является строкой, то при сравнении регистр символов учитывается.

Замечание: В PHP версии ниже 4.2.0 параметр needle не мог быть массивом.

Пример использования функции in_array():

<?php
$os = array("Mac", "NT", "Irix", "Linux");
if (in_array("Irix", $os)) {
    echo "Got Irix";
}
if (in_array("mac", $os)) {
    echo "Got mac";
}
?>

Второе условие не сработает, т.к. поиск в массиве идет с учетом регистра.

Пример выведет:

Got Irix

Пример использования функции in_array(): Использование параметра strict

<?php
$a = array(array("p", "h"), array("p", "r"), "o");

if (in_array(array("p", "h"), $a)) {
    echo "ph was foundn";
}

if (in_array(array("f", "i"), $a)) {
    echo "fi was foundn";
}

if (in_array("o", $a)) {
    echo "o was foundn";
}
?>

Пример выведет:

ph was found
    o was found

Функция поддерживается PHP 4, PHP 5

[править] array_count_values

Возвращает количество значений массива.

Синтаксис:

array array_count_values(array arr)

Эта функция подсчитывает, сколько раз каждое значение встречается в массиве arr, и возвращает ассоциативный массив с ключами - элементами массива и значениями - количеством повторов этих элементов. Иными словами, функция array_count_values() подсчитывает частоту появления значений в массиве arr.

Пример использования функции array_count_values():

$arr = array(1, "hello", 1, "world", "hello");
print_r(array_count_values($arr));

Пример выведет следующее:

Array
(
    [1] => 2
    [hello] => 2
    [world] => 1
)

Функция поддерживается PHP 4, PHP 5

[править] sizeof

Возвращает число элементов массива.

Синтаксис:

int sizeof(array arr)

Функция sizeof() возвращает количество элементов в массиве arr на подобие действия функции count().

[править] count

Возвращает число элементов в массиве или объекте.

Синтаксис:

int count(mixed var [, int mode])

Функция count() возвращает число элементов в массиве или объекте var. В случае, если var - скалярная переменная, то функция возвращает 1, если такая переменная существует, или 0, если такой переменной нет.

Надо отметить, что 0 возвращается и тогда, когда указан массив, не содержащий элементов (NULL).

Если задан необязательный параметр mode, то будет подсчитано общее количество элементов в массиве. Это может быть полезно при нахождении количества элементов в многомерных массивах.

Пример использования функции count():

<?php
$a[0] = 1;
$a[1] = 3;
$a[2] = 5;
$result = count($a);
// $result == 3

$b[0]  = 7;
$b[5]  = 9;
$b[10] = 11;
$result = count($b);
// $result == 3;
?>

Пример использования функции count(): (PHP >= 4.2.0)

<?php
$food = array("fruits" => array("orange", "banana", "apple"),
              "veggie" => array("carrot", "collard", "pea"));

// recursive count
echo count($food, COUNT_RECURSIVE);  // выведет 8

// normal count
echo count($food);                  // выведет 2
?>

Функция поддерживается PHP 3, PHP 4, PHP 5

[править] array_sum

Возвращает сумму всех элементов массива.

Синтаксис:

mixed array_sum(array arr)

Функция array_sum() возвращает сумму всех числовых элементов массива. От типа значений в массиве зависит тип возвращаемого числа (integer или float).

Пример использования функции array_sum():

<?php
$a = array(2, 4, 6, 8);
echo "sum(a) = " . array_sum($a) . "<BR>";

$b = array("a" => 1.2, "b" => 2.3, "c" => 3.4);
echo "sum(b) = " . array_sum($b) . "<BR>";
?>

Этот пример выведет следующее:

sum(a) = 20
sum(b) = 6.9

Функция поддерживается PHP 4 >=4.0.4, PHP 5

[править] array_rand

Производит случайную выборку индексов массива.

Синтаксис:

mixed array_rand(array arr [, int num_req])

Функция array_rand() будет полезной, если вы хотите выбрать одно или несколько случайных значений из массива. Эта функция возвращает в массиве выбранные случайным образом индексы элементов массива arr.

Аргумент num_req указывает число возвращаемых индексов. В случае, если выбирается один элемент, то функция array_rand() возвратит случайный ключ в виде значения.

Пример использования функции array_rand():

<?php
srand((double)microtime() *1000000);
// здесь мы проинициализировали генератор случайных чисел
$arr = array("Neo", "Morpheus", "Trinity", "Cypher", "Tank");
$rand_keys = array_rand($arr, 2);
echo $arr[$rand_key[0]]."<BR>";
echo $arr[$rand_key[1]]."<BR>";
?>

Функция поддерживается PHP 4, PHP 5

[править] array_change_key_case

Функция устанавливает значения ключей массива в верхний или нижний регистр.

Синтаксис:

array array_change_key_case(array arr[, int registr])

Функция array_change_key_case() возвращает исходный массив arr, ключи которого преобразованы в верхний или нижний регистр.

Необязательный параметр registr может принимать следующие значения:

  • CASE_LOWER - все ключи массива преобразуются в нижний регистр (значение по умолчанию);
  • CASE_UPPER - в верхний регистр.

Данная функция не изменяет ключи, состоящие из чисел.

Пример использования функции array_change_key_case():

$array = array("FirSt" => 1, "SecOnd" => 4);
print_r(array_change_key_case($array, CASE_UPPER));
print_r(array_change_key_case($array, CASE_LOWER));

Пример выведет следующее:

Array
(
    [FIRST] => 1
    [SECOND] => 2
)
Array
(
    [first] => 1
    [second] => 2
)

Функция поддерживается PHP 4 >= 4.2.0, PHP 5

[править] array_combine

Функция объединяет два массива, причем значения первого становяться ключами, а значения второго - значениями.

Синтаксис:

array array_combine(array keys, array values)

Функция array_combine() возвращает массив, ключами которого являются значения массива keys, а значениями - значения массива values.

Функция возвратит FALSE, если размерность массивов keys и values не совпадают, или эти массивы не содержат значений.

Пример использования функции array_combine():

<?php
$a = array("green", "red", "yellow");
$b = array("avocado", "apple", "banana");
$c = array_combine($a, $b);

print_r($c);
?>

Пример выведет следующее:

Array
(
    [green]  => avocado
    [red]    => apple
    [yellow] => banana
)

Функция поддерживается PHP 5

[править] array_key_exists

Проверка существования заданного ключа в массиве.

Синтаксис:

bool array_key_exists(mixed key, array search)

Функция array_key_exists() возвратит TRUE, если в массиве search присутствует элемент с индексом key.

В противном случае возвратит FALSE.

Пример использования функции array_key_exists():

<?php
$search_array = array("first" => 1, "second" => 4);
if (array_key_exists("first", $search_array)) {
    echo "The <I>first</I> element is in the array";
}
?>

В PHP 4.0.6. имя этой функции key_exists().

Функция поддерживается PHP 4 >= 4.0.1, PHP 5

Получено с http://spravkaweb.local/index.php/php/datafun/array/keyval
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 15:44, 26 января 2007.
  • К этой странице обращались 110 раз.
1.75753998756


Справочник по PHP : Функции работы с данными : Работа с массивами : Получение и удаление части массива — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Работа с массивами : Получение и удаление части массива

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Работа с несколькими массивами
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Работа с массивами | ::. | Получение и удаление части массива
 |  |  |  |  |  |  |  | Вставка / удаление элементов

[править] array_slice

Получение части массива.

Синтаксис:

array array_slice(array arr, int offset [, int lenght])

Функция array_slice() возвращает часть ассоциативного массива arr, начиная с элемента со смещением (номером) offset от начала и длиной lenght (если последний параметр не задан, до конца массива).

Параметры offset и lenght задаются по точно таким же правилам, как и аналогичные параметры в функции substr(). А именно, если offset>0, то последовательность будет начинаться с элемента, имеющего позицию offset от начала массива, а если <0, то отсчет производится от конца массива. Надо отметить, что первый элемент имеет нулевую позицию, а последний (-1).

Если указать length>0, то это число возвращаемых в массиве элементов, а если length<0, то это позиция последнего возвращаемого элемента в массиве arr от его конца.

Пример использования функции array_slice():

<?php
$input = array("a", "b", "c", "d", "e");
$output = array_slice($input, 2);        // "c", "d", "e"
$output = array_slice($input, 2, -1);    // "c", "d"
$output = array_slice($input, -2, 1);    // "d"
$output = array_slice($input, 0, 3);     // "a", "b", "c"
?>

Функция поддерживается PHP 4, PHP 5

[править] array_splice

Удаляет часть массива или заменяет ее частью другого массива.

Синтаксис:

array array_splice(array arr, int offset [, int lenght [, int replacement]])

Функция array_splice(), также как и array_slice(), возвращает подмасcив arr начиная с индекса offset максимальной длины lenght, но, вместе с тем, она делает и другое полезное действие. А именно, она заменяет только что указанные элементы на то, что находится в массиве replacement (или просто удаляет, если replacement не указан).

Если offset>0, то последовательность будет начинаться с элемента, имеющего позицию offset от начала массива, а если <0, то отсчет производится от конца массива. Надо отметить, что первый элемент имеет нулевую позицию, а последний (-1).

Если указать length>0, то это число возвращаемых в массиве элементов, а если length<0, то это позиция последнего возвращаемого элемента в массиве arr от его конца.

В качестве примера укажем следующие эквивалентыне замены:

array_push($input, $x, $y)     array_splice($input, count($input), 0, array($x, $y))
array_pop($input)     array_splice($input, -1)
array_shift($input)     array_splice($input, -1)
array_unshift($input, $x, $y)     array_splice($input, 0, 0, array($x, $y))
$a[$x] = $y     array_splice($input, $x, 1, $y)

Пример использования функции array_splice():

<?php
$input = array("red", "green", "blue", "yellow");
array_splice($input, 2);
// $input is now array("red", "green")

$input = array("red", "green", "blue", "yellow");
array_splice($input, 1, -1);
// $input is now array("red", "yellow")

$input = array("red", "green", "blue", "yellow");
array_splice($input, 1, count($input), "orange");
// $input is now array("red", "orange")

$input = array("red", "green", "blue", "yellow");
array_splice($input, -1, 1, array("black", "maroon"));
// $input is now array("red", "green",
//          "blue", "black", "maroon")

$input = array("red", "green", "blue", "yellow");
array_splice($input, 3, 0, "purple");
// $input is now array("red", "green",
//          "blue", "purple", "yellow");
?>

Функция поддерживается PHP 4, PHP 5

Получено с http://spravkaweb.local/index.php/php/datafun/array/part
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 15:34, 28 января 2007.
  • К этой странице обращались 83 раза.
1.8941988945


Справочник по PHP : Функции работы с данными : Работа с массивами : Работа с несколькими массивами — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Работа с массивами : Работа с несколькими массивами

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Ключи и значения
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Работа с массивами | ::. | Работа с несколькими массивами
 |  |  |  |  |  |  |  | Получение и удаление части массива

Содержание

  • 1 array_diff
  • 2 array_diff_assoc
  • 3 array_diff_uassoc
  • 4 array_udiff
  • 5 array_udiff_assoc
  • 6 array_udiff_uassoc
  • 7 array_intersect
  • 8 array_intersect_assoc
  • 9 array_merge
  • 10 array_merge_recursive

[править] array_diff

Определение исключительного пересечения массивов.

Синтаксис:

array array_diff(array arr1, array arr2 [, array ...])

Данная функция возвращает массив, который содержит значения, имеющиеся только в массиве arr1 ( и не имеющиеся в любых других). При этом индексы сохраняются.

$arr1 = array("a" => "green", "red", "blue", "red");
$arr2 = array("b" => "green", "yellow", "red");
$result = array_diff($arr1, $arr2);
// $result = array("blue")

Повторение одного и того же значения "red" в массиве arr1 обрабатывается как одно значение.

Стоит отметить, что два элемента считаются одинаковыми, только если их строковое представление идентично. Т.е. (string) $elem1 === (string) $elem2.

Также стоит отметить, что данная функция корректно обрабатывает только одно измерение N-мерного массива. Если есть необходимость обрабатывать более глубокие уровни вложенности, можно использовать конструкцию array_diff($arr1[0], $arr2[0]);.

Функция поддерживается PHP 4 >= 4.0.1, PHP 5

[править] array_diff_assoc

Определение исключительного пересечения массивов с учетом индексов массивов.

Синтаксис:

array array_diff_assoc(array arr1, array arr2 [, array ...])

Данная функция возвращает массив, который содержит значения, имеющиеся только в массиве arr1 ( и не имеющиеся в любых других). Обратите внимание, что в отличии от функции array_diff(), при сравнении учитываются ключи.

Пример использования array_diff_assoc():

<?php
$array1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array("a" => "green", "yellow", "red");
$result = array_diff_assoc($array1, $array2);
print_r($result);
?>

Пример выведет следующее:

Array
(
    [b] => brown
    [c] => blue
    [0] => red
)

В приведенном примере пара "a" => "green" присутствует в обоих массивах, поэтому она не вошла в результирующий массив. В отличие от этого, значение red присутствует в результирующем массиве, т.к. в первом массиве это значение имело ключ 0, а во втором массиве оно имело ключ 1.

Две пары ключ => значение считаются равными, если они тождественны друг другу, т.е. (string) $elem1 === (string) $elem2.

Обратите внимание, что данная функция не позволяет напрямую сравнивать многомерные массивы. Хотя конечно можно сравнить вложенные массивы, используя, например, array_diff_assoc ($array1 [0], $array2 [0]);.

Функция поддерживается PHP 4 >=4.3.0, PHP 5

[править] array_diff_uassoc

Определение различия между массивами при помощи пользовательской функции с дополнительной проверкой ключей массива.

Синтаксис:

array array_diff_uassoc(array arr1, array arr2 [, array ..., callback key_compare_func])

Функция array_diff_uassoc() возвращает массив, который содержит значения, имеющиеся только в массиве arr1 ( и не имеющиеся в любых других).

Обратите внимание, что в отличии от функции array_diff(), при сравнении учитываются ключи. Сделано это при помощи пользовательской функции key_compare_func. Эта функция должна возвращать целое число, которое должно быть меньше нуля, если первый переданный ей аргумент меньше чем второй, равное нулю, если первый аргумент равен второму, и больше нуля, если первый аргумент больше второго. Эта функция отличается от array_diff_assoc(), где сравнение значений и индексов происходит автоматически.

Пример использования array_diff_uassoc():

<?php
function key_compare_func($a, $b)
{
    if ($a === $b) {
        return 0;
    }
    return ($a > $b)? 1:-1;
}

$array1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array("a" => "green", "yellow", "red");
$result = array_diff_uassoc($array1, $array2, "key_compare_func");
?>

Пример выведет следующее:

Array
(
    [b] => brown
    [c] => blue
    [0] => red
)

В приведенном примере пара "a" => "green" присутствует в обоих массивах, поэтому она не вошла в результирующий массив. В отличие от этого, значение red присутствует в результирующем массиве, т.к. в первом массиве это значение имело ключ 0, а во втором массиве оно имело ключ 1.

Равенство индексов проверяется пользовательской функцией.

Обратите внимание, что данная функция не позволяет напрямую сравнивать многомерные массивы. Хотя конечно можно сравнить вложенные массивы, используя, например, array_diff_uassoc ($array1[0], $array2[0], "key_compare_func");.

Функция поддерживается PHP 5

[править] array_udiff

Сравнивает массивы используя пользовательскую функцию.

Синтаксис:

array array_udiff( array array1, array array2 [, array ..., callback data_compare_func])

Функция array_udiff() возвращает массив, содержащий все значения массива array1, которые не присутствуют в других массивах, переданных в параметрах.

Стоит отметить, что ключи значений сохраняются.

Для сравнения значений массивов используется пользовательская функция data_compare_func. Она возвращает число, большее нуля, равное нулю или меньшее нуля, если первый аргумент, переданные ей в виде параметра, больше, равен или меньше второго параметра соответственно. Это отличается от функции array_diff(), где используется встроенная функция сравнения. Пример использования функции array_udiff_assoc():

<?php
class cr {
    private $priv_member;
    function cr($val)
    {
        $this->priv_member = $val;
    }

    function comp_func_cr($a, $b)
    {
        if ($a->priv_member === $b->priv_member) return 0;
        return ($a->priv_member > $b->priv_member)? 1:-1;
    }
}
$a = array("0.1" => new cr(9), "0.5" => new cr(12), 0 => new cr(23), 1=> new cr(4), 2 => new cr(-15),);
$b = array("0.2" => new cr(9), "0.5" => new cr(22), 0 => new cr(3), 1=> new cr(4), 2 => new cr(-15),);

$result = array_udiff($a, $b, array("cr", "comp_func_cr"));
print_r($result);
?>

Этот пример выведет следующее:

Array
(
    [0.5] => cr Object
        (
            [priv_member:private] => 12
        )

    [0] => cr Object
        (
            [priv_member:private] => 23
        )

)

Два значения будут сочтены равными, только если (string) $elem1 === (string) $elem2 (т.е. когда строки содержат одно и тоже).

Стоит отметить, что данная функция в случае многомерного массива использует для сравнения одного измерение. Если вы хотите пройтись по всем измерениям, стоит использовать конструкцию array_udiff($array1[0], $array2[0], "data_compare_func");

Функция поддерживается PHP 5

[править] array_udiff_assoc

Сравнивает массивы используя пользовательскую функцию.

Синтаксис:

array array_udiff_assoc( array array1, array array2 [, array ..., callback data_compare_func])

Функция array_udiff_assoc() возвращает массив, содержащий все значения массива array1, которые не присутствуют в других массивах, переданные в параметрах. Стоит отметить, что ключи значений используются при сравнении в отличии от функций array_diff() и array_udiff().

Для сравнения значений массивов используется пользовательская функция. Этим данная функция отличается от array_diff_assoc(), которая использует внутреннюю функции для сравнения.

Пример использования функции array_udiff_assoc():

<?php
class cr {
    private $priv_member;
    function cr($val)
    {
        $this->priv_member = $val;
    }

    function comp_func_cr($a, $b)
    {
        if ($a->priv_member === $b->priv_member) return 0;
        return ($a->priv_member > $b->priv_member)? 1:-1;
    }
}

$a = array("0.1" => new cr(9), "0.5" => new cr(12), 0 => new cr(23), 1=> new cr(4), 2 => new cr(-15),);
$b = array("0.2" => new cr(9), "0.5" => new cr(22), 0 => new cr(3), 1=> new cr(4), 2 => new cr(-15),);

$result = array_udiff_assoc($a, $b, array("cr", "comp_func_cr"));
print_r($result);
?>

Этот пример выведет следующее:

Array
(
    [0.1] => cr Object
        (
            [priv_member:private] => 9
        )

    [0.5] => cr Object
        (
            [priv_member:private] => 12
        )

    [0] => cr Object
        (
            [priv_member:private] => 23
        )
)

В нашем примере пара 1=> new cr(4) присутствует в обеих массивах и по этому она не вошла в результирующий массив.

Для сравнения используется пользовательская функция. Она возвращает значение, меньшее нуля, равное нулю или большее нуля, если переданный ей первый параметр меньше второго, равен второму или больше второго соответственно.

Функция поддерживается PHP 5

[править] array_udiff_uassoc

Сравнивает массивы используя пользовательскую функцию.

Синтаксис:

array array_udiff_uassoc ( array array1, array array2 [, array ..., callback data_compare_func, callback key_compare_func])

Функция array_udiff_uassoc() возвращает массив, содержащий все значения массива array1, которые не присутствуют в других массивах, переданные в параметрах. Стоит отметить, что ключи значений используются при сравнении в отличии от функций array_diff() и array_udiff().

Для сравнения значений массивов используется пользовательская функция data_compare_func. Этим данная функция отличается от array_diff_assoc(), которая использует внутреннюю функции для сравнения.

Сравнение ключей (индексов) происходит при помощи пользовательской функции key_compare_func. Этим данная функция отличается от array_udiff_assoc(), которая использует внутреннюю функции для сравнения.

Пример использования функции array_udiff_uassoc():

<?php
class cr {
    private $priv_member;
    function cr($val)
    {
        $this->priv_member = $val;
    }

    function comp_func_cr($a, $b)
    {
        if ($a->priv_member === $b->priv_member) return 0;
        return ($a->priv_member > $b->priv_member)? 1:-1;
    }

    function comp_func_key($a, $b)
    {
        if ($a === $b) return 0;
        return ($a > $b)? 1:-1;
    }
}
$a = array("0.1" => new cr(9), "0.5" => new cr(12), 0 => new cr(23), 1=> new cr(4), 2 => new cr(-15),);
$b = array("0.2" => new cr(9), "0.5" => new cr(22), 0 => new cr(3), 1=> new cr(4), 2 => new cr(-15),);

$result = array_udiff_uassoc($a, $b, array("cr", "comp_func_cr"), array("cr", "comp_func_key"));
print_r($result);
?>

Этот пример выведет следующее:

Array
(
    [0.1] => cr Object
        (
            [priv_member:private] => 9
        )

    [0.5] => cr Object
        (
            [priv_member:private] => 12
        )

    [0] => cr Object
        (
            [priv_member:private] => 23
        )
)

В нашем примере пара 1=> new cr(4) присутствует в обеих массивах и по этому она не вошла в результирующий массив.

Для сравнения используется пользовательская функция. Она возвращает значение, меньшее нуля, равное нулю или большее нуля, если переданный ей первый параметр меньше второго, равен второму или больше второго соответственно.

Функция поддерживается PHP 5

[править] array_intersect

Определение включительного пересечения массивов.

Синтаксис:

array array_intersect(array arr1, array arr2 [, array ...])

Функция array_intersect() возвращает массив, который содержит значения массива arr1, имеющиеся во всех остальных массивах. При этом индексы сохраняются.

Пример использования функции array_intersect():

<?php
$arr1 = array("a" => "green", "red", "blue");
$arr2 = array("b" => "green", "yellow", "red");
$result = array_intersect($arr1, $arr2);
print_r($result);
?>

Пример выведет:

Array
(
    [a] => green
    [0] => red
)

Функция поддерживается PHP 4 >= 4.0.1, PHP 5

[править] array_intersect_assoc

Функция возвращает пересечения значений массивов с сохранением индексов.

Синтаксис:

array array_intersect_assoc(array array1, array array2 [, array ...])

Функция array_intersect_assoc() возвращает массив, который содержит все значения array1, имеющиеся во всех остальных перечисленных массивах. В отличие от функции array_intersect() при сравнении ключи учитываются.

Пример использования функции array_intersect_assoc():

<?php
$array1 = array("a" => "яблоко", "b" => "груша", "c" => "дыня", "слива");
$array2 = array("a" => "яблоко", "апельсин", "слива");
$result_array = array_intersect_assoc($array1, $array2);
?>

Пример выведет следующее:

Array
(
    [a] => яблоко
)

Приведенный пример вывел только значение [a] => яблоко, т.к. это значение присутствовало и в первом и во втором массиве.

Значение дыня не выведено, т.к. в первом массиве у него был индекс 0, а во втором - 1

Функция поддерживается PHP 4 >= 4.3.0, PHP 5

[править] array_merge

Слияние массивов.

Синтаксис:

array array_merge(array arr1, array arr2 [, array ...])

Функция array_merge() призвана устранить все недостатки, присущие оператору + для слияния массивов. А именно, она сливает массивы, перечисленные в ее аргументах, в оди большой массив и возвращает результат. Т.е. значени одного массива присоединяются к значениям предыдущего.

Если в массивах встречаются одинаковые строковые ключи, то тогда значения, принадлежащие этим ключам, сливаются в один массив таким образом, чтобы если одно из значений в свою очередь является массивом, функция array_merge() сливает его с соответствующим значением в другом массиве.

Однако это не затрагивает числовые ключи: элементы с такими ключами помещаются в конец результирующего массива в любом случае.

Пример использования функции array_merge():

<?php
$array1 = array ("color" => "red", 2, 4);
$array2 = array ("a", "b", "color" => "green", "shape" => "trapezoid", 4);
$result = array_merge ($array1, $array2);
print_r($result);
?>

Пример выведет следующее:

Array
(
    [color] => green
    [0] => 2
    [1] => 4
    [2] => a
    [3] => b
    [shape] => trapezoid
    [4] => 4
)

Другой пример использования функции array_merge():

<?php
$array1 = array();
$array2 = array(1 => "data");
$result = array_merge($array1, $array2);
print_r($result);
?>

Пример выведет следующее:

Array
(
    [0] => data
)

Стоит отметить, что числовые ключи были потеряны.

Если есть необходимость просто слить массивы вместе, используйте оператор +

<?php
$array1 = array();
$array2 = array(1 => "data");
$result = $array1 + $array2;
print_r($result);
?>

Пример выведет следующее:

Array
(
    [1] => data
)

Функция поддерживается PHP 4, PHP 5

[править] array_merge_recursive

Рекурсивное слияние сложных массивов.

Синтаксис:

array array_merge_recursive(array arr1, array arr2 [, array ...])

Функция array_merge_recursive() объединяет элементы массивов, переданных в ее параметрах таким образом, что значения одного массива присоединяются к значениям предудущих.

Функция возвращает массив, состоящий из объединенных массивов.

Если массивы, переданные в параметрах этой функции, имеют одинаковые строковые ключи, тогда значения, соответствующие этим ключам, сливаются в один массив. При этом если одно из значений само является массивом, то оно будет слито с соответствующим значением в другом массиве.

Но если в массивах присутствуют одинаковые числовые ключи, то тогда значение такого ключа, упомянутое последним, не заменит исходное значение, а будет слито с ним.

Пример использования функции array_merge_recursive():

<?php
$arr1 = array("color" => array("favorite" =>"red"), 5);
$arr2 = array(10, "color" => array("favorite" =>"green", "blue"));
$result = array_merge_recursive($arr1, $arr2);
print_r($result_;
?>

Пример выведет:

Array
(
    [color] => Array
        (
            [favorite] => Array
                (
                    [0] => red
                    [1] => green
                )

            [0] => blue
        )

    [0] => 5
    [1] => 10
)

Функция поддерживается PHP 4 >=, PHP 5

Получено с http://spravkaweb.local/index.php/php/datafun/array/some
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 06:23, 25 марта 2007.
  • К этой странице обращались 80 раз.
2.60228395462


Справочник по PHP : Функции работы с данными : Работа с массивами : Сортировка массивов — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Работа с массивами : Сортировка массивов

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Создание массива
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Работа с массивами | ::. | Сортировка массивов
 |  |  |  |  |  |  |  | Курсор массива

Содержание

  • 1 array_reverse
  • 2 shuffle
  • 3 sort
  • 4 rsort
  • 5 asort
  • 6 arsort
  • 7 ksort
  • 8 krsort
  • 9 natsort
  • 10 natcasesort
  • 11 uasort
  • 12 uksort
  • 13 usort
  • 14 array_multisort

[править] array_reverse

Расстановка элементов массива в обратном порядке.

Синтаксис:

array array_reverse(array arr [, bool preserve_keys])

Функция array_reverse() возвращает массив, элементы которого следуют в обратном порядке относительно массива, переданного в параметре. При этом связи между ключами и значениями не теряются, если дополнительный параметр preserve_keys = TRUE.

Пример использования функции array_reverse():

<?php
$input  = array("php", 4.0, array("green", "red"));
$result = array_reverse($input);
$result_keyed = array_reverse($input, true);
?>

Этот пример сделает оба массива $result и $result_keyed с одинаковыми значениями, но различными ключами. Распечатка массивов $result и $result_keyed будет следующей:

Array
(
    [0] => Array
        (
            [0] => green
            [1] => red
        )

    [1] => 4
    [2] => php
)
Array
(
    [2] => Array
        (
            [0] => green
            [1] => red
        )

    [1] => 4
    [0] => php
)

Примечание: Второй параметр preserve_keys был добавлен в PHP 4.0.3.

Функция поддерживается PHP 4, PHP 5

[править] shuffle

Перемешивание элементов массива.

Синтаксис:

void shuffle(array arr)

Функция shuffle() "перемешивает" список, переданный ей первым параметром arr, так, чтобы его значения распределялись случайным образом. При этом измениться сам массив и ассоциативные массивы воспринимаются как списки.

Пример использования функции shuffle():

<?php
$numbers = range(1, 20);
srand((float)microtime() * 1000000);
shuffle($numbers);
while (list(, $number) = each($numbers)) {
    echo "$number ";
}
?>

Замечание: Начиная с PHP 4.2.0, больше нет необходимости инициализировать генератор случайных чисел функциями srand() или mt_srand(), поскольку теперь это происходит автоматически.

Функция поддерживается PHP 3 >= 3.0.8, PHP 4, PHP 5

[править] sort

Сортировка массива по возрастанию.

Синтаксис:

bool sort(array arr [, int sort_flags])

Функция sort() предназначена для сортировки массивов в порядке возрастания.

Замечание: Эта функция изменяет ключи у отсортированных значений. Т.е. любой ассоциативный массив воспринимается этой функцией как список. После упорядочивания последовательность ключей превращается в 0,1,2,..., а значения нужным образом перераспределяются. Как видим, связи между параметрами ключ=>значение не сохраняются, более того - ключи просто пропадают, поэтому сортировать что-либо, отличное от списка, вряд ли целесообразно.

Пример использования функции sort():

<?php
$fruits = array("lemon", "orange", "banana", "apple");
sort($fruits);
reset($fruits);
while (list($key, $val) = each($fruits)) {
    echo "fruits[" . $key . "] = " . $val . "n";
}
?>

Этот пример выведет:

fruits[0] = apple
fruits[1] = banana
fruits[2] = lemon
fruits[3] = orange

Аргумент sort_flags задает следующие флаги сортировки:

  • SORT_REGULAR - сравнивает элементы "как есть";
  • SORT_NUMERIC - сравнивает элементы как числа;
  • SORT_STRING - сравнивает элементы как строки.

Функция поддерживается PHP 3, PHP 4, PHP 5

[править] rsort

Сортировка массива по убыванию.

Синтаксис:

bool rsort ( array array [, int sort_flags])

Функция rsort() сортирует массив array в порядке убывания (от высших значений к низшим).

Функция возвращает TRUE в случае успешного завершения, и FALSE в противном случае.

Пример использования функции rsort():

<?php
$fruits = array("lemon", "orange", "banana", "apple");
rsort($fruits);
reset($fruits);
while (list($key, $val) = each($fruits)) {
    echo "$key = $valn";
}
?>

Этот пример выведет:

0 = orange
1 = lemon
2 = banana
3 = apple

Аргумент sort_flags задает следующие флаги сортировки:

  • SORT_REGULAR - сравнивает элементы "как есть"
  • SORT_NUMERIC - сравнивает элементы как числа
  • SORT_STRING - сравнивает элементы как строки

Функция поддерживается PHP 3, PHP 4, PHP 5

[править] asort

Сортировка ассоциативного массива по возрастанию.

Синтаксис:

bool asort(array arr [, int sort_flags])

Функция asort() сортирует массив, указанный в ее параметре, так, чтобы его значения шли в алфавитном (если это строки) или возрастающем (для чисел) порядке. При этом сохраняются связи между ключами и соответствующими им значениями, т.е. некоторые пары ключ=>значение просто "всплывают" наверх, а некоторые - наоборот, "опускаются".

Функция возвращает true в случае успешного завершения, и false в случае возникновения ошибки.

Пример использования функции asort():

<?php
$fruits = array("d" => "lemon", "a" => "orange", "b" => "banana", "c" => "apple");
asort($fruits);
reset($fruits);
while (list($key, $val) = each($fruits)) {
    echo "$key = $valn";
}
?>

Пример выведет следующее:

c = apple
b = banana
d = lemon
a = orange

Массив $fruits был отсортирован в возрастающем символьном порядке, при этом индексы массива были сохранены.

Метод сортировки может быть изменен при помощи необязательного параметра sort_flags.

Этот параметр может указать, как сравнивать значения (как строки или как числа). Он может принимать следующие предопределенные значения:

  • SORT_REGULAR - нормальное сравение значений;
  • SORT_NUMERIC - сравнивать как числа;
  • SORT_STRING - сравнивать как строки.

Этот параметр был введен в PHP начиная с 4 версии.

Функция поддерживается PHP 3, PHP 4, PHP 5

[править] arsort

Сортировка ассоциативного массива по убыванию.

Синтаксис:

bool arsort(array arr [, int sort_flags])

Функция arsort() сортирует массив arr по убыванию с сохранением индексных ассоциаций.

Эта функция используется главным образом там, где существенен порядок элемента в массиве.

Функция возвращает true в случае успешной сортировки, и false в случае возникновения ошибки.

Пример использования функции arsort():

$arr=array("d"=>"lemon", "a"=>"orange", "b"=>"banana", "c"=>"apple");
arsort($arr);
reset($arr);
while(list ($key, $val) = each ($arr)) {
  echo "$key = $val<BR>l";
}

Пример выведет:

a = orange
d = lemon
b = banana
c = apple

Массив $arr был отсортирован в убывающем символьном порядке, при этом индексы массива были сохранены.

Метод сортировки может быть изменен при помощи необязательного параметра sort_flags.

Этот параметр может указать, как сравнивать значения (как строки или как числа). Он может принимать следующие предопределенные значения:

  • SORT_REGULAR - нормальное сравение значений;
  • SORT_NUMERIC - сравнивать как числа;
  • SORT_STRING - сравнивать как строки.

Этот параметр был введен в PHP начиная с 4 версии.

Функция поддерживается PHP 3, PHP 4, PHP 5

[править] ksort

Сортировка массива по возрастанию ключей.

Синтаксис:

bool ksort(array arr [, int sort_flags])

Функция ksort() сортирует массив в порядке возрастания ключей с сохранением взаимосвязей ключей и значений. Эта функция особенно полезна при сортировке ассоциативных массивов.

Функция возвратит true, если все прошло успешно, и false в противном случае.

Пример использования функции ksort():

<?php
$fruits = array("d"=>"lemon", "a"=>"orange", "b"=>"banana", "c"=>"apple");
ksort($fruits);
reset($fruits);
while (list($key, $val) = each($fruits)) {
    echo "$key = $valn";
}
?>

Данный пример выведет:

a = orange
b = banana
c = apple
d = lemon

Аргумент sort_flags задает следующие флаги сортировки:

  • SORT_REGULAR - сравнивает элементы "как есть"
  • SORT_NUMERIC - сравнивает элементы как числа
  • SORT_STRING - сравнивает элементы как строки

Функция поддерживается PHP 3, PHP 4, PHP 5

[править] krsort

Сортировка массива по убыванию индексов.

Синтаксис:

bool krsort(array arr [, int sort_flags])

Функция krsort() сортирует ключи в массиве arr в обратном порядке. При этом связка ключей и значений сохраняется. Эта функци полезна при сортировке ассоциативных массивов.

Функция возвращает true в случае успешного завершения, и false в противном случае.

Пример использования функции krsort():

<?php
$fruits = array("d"=>"lemon", "a"=>"orange", "b"=>"banana", "c"=>"apple");
krsort($fruits);
reset($fruits);
while (list($key, $val) = each($fruits)) {
    echo "$key = $valn";
}
?>

Данный пример выведет:

d = lemon
c = apple
b = banana
a = orange

Аргумент sort_flags задает следующие флаги сортировки:

  • SORT_REGULAR - сравнивает элементы "как есть"
  • SORT_NUMERIC - сравнивает элементы как числа
  • SORT_STRING - сравнивает элементы как строки

Функция поддерживается PHP 3 >= 3.0.13, PHP 4, PHP 5

[править] natsort

Выполняет "естественную" сортировку массива.

Синтаксис:

void natsort(array arr)

Функция natsort() сортирует массив arr в естественном для человека порядке с сохранением индексных ассициаций.

Пример использования функции natsort():

<?php
$array1 = $array2 = array("img12.png", "img10.png", "img2.png", "img1.png");

sort($array1);
echo "Стандартная сортировкаn";
print_r($array1);

natsort($array2);
echo "nЕстественная сортировкаn";
print_r($array2);
?>

Этот пример выведет следующее:

Стандартная сортировка
Array
(
    [0] => img1.png
    [1] => img10.png
    [2] => img12.png
    [3] => img2.png
)

Естественная сортировка
Array
(
    [3] => img1.png
    [2] => img2.png
    [1] => img10.png
    [0] => img12.png
)

Функция поддерживается PHP 4, PHP 5

[править] natcasesort

Выполняет естественную сортировку массива без учета регистра символов.

Синтаксис:

void natcasesort(array arr)

Функция natcasesort() сортирует массив arr в естественном для человека порядке с сохранением индексных ассициаций.

Эта функция схожа с natsort(), только не учитывает регистр символов.

Пример использования функции natcasesort():

<?php
$array1 = $array2 = array("IMG0.png", "img12.png", "img10.png",
                          "img2.png", "img1.png", "IMG3.png");

sort($array1);
echo "Стандартная сортировкаn";
print_r($array1);

natcasesort($array2);
echo "nЕстественная сортировка (без учета регистра)n";
print_r($array2);
?>

Приведенный пример выведет следующее:

Стандартная сортировка
Array
(
    [0] => IMG0.png
    [1] => IMG3.png
    [2] => img1.png
    [3] => img10.png
    [4] => img12.png
    [5] => img2.png
)

Естественная сортировка (без учета регистра)
Array
(
    [0] => IMG0.png
    [4] => img1.png
    [3] => img2.png
    [5] => IMG3.png
    [2] => img10.png
    [1] => img12.png
)

Функция поддерживается PHP 4, PHP 5

[править] uasort

Пользовательская сортировка ассоциативного массива с сохранением индексных ассоциаций.

Синтаксис:

bool uasort(array arr, function cmp_function)

Функция uasort() сортирует массив arr с сохранением индексных ассоциаций, используя для сравнения индексов элементов пользовательскую функцию, указанную аргументом cmp_function.

Эта функция используется главным образом когда соответствие индексов и значений массива существенно.

Функция uasort() возвращает true в случае успешного завершения сортировки, и false в противном случае.

Замечание: Смотрите функции usort() и uksort() для написания пользовательской функции.

Функция поддерживается PHP 3 >=3.0.4, PHP 4, PHP 5

[править] uksort

Пользовательская сортировка массива по ключам.

Синтаксис:

bool uksort(array arr, function cmp_function)

Функция uksort() сортирует массив arr по индексам с сохранением индексных ассоциаций, используя для сравнения индексов элементов пользовательскую функцию, указанную в аргументе cmp_function. В эту функцию передаются два сравниваемых индекса элементов, а она должна вернуть положительное или отрицательное число или 0.

Функция uksort() возвращает true в случае успешного завершения сортировки, и FALSE в противном случае.

Довольно часто нам приходится сортировать что-то по более сложному критерию, чем просто по алфавиту. Например, пусть в $Files храниться список имен файлов и подкаталогов в текущем каталоге. Возможно, мы захотим вывести этот список не только в лексографическом порядке, но также чтобы все каталоги предшествовали файлам. В этом случае нам стоит воспользоваться функцией uksort(), написав предварительно функцию сравнения с двумя параметрами, как того требует uksort().

1 пример использования функции uksort():

// Эта функция должна сравнивать значения $f1 и $f2 и возвращать:
// -1, если $f1<$f2,
//  0, если $f1==$f2
//  1, если $f1>$f2
// Под < и > понимаем следование этих имен в выводимом списке
function FCmp($f1,$f2)
{ // Каталог всегда предшествует файлу
  if(is_dir($f1) && !is_dir($f2)) return -1;
  // Файл всегда идет после каталога
  if(!is_dir($f1) && is_dir($f2)) return 1;
  // Иначе сравниваем лексиграфически
  if($f1<$f2) return -1; elseif($f1>$f2) return 1; else return 0;
}
// Пусть $Files содержит массив с ключами - именами файлов
// в текущем каталоге. Отсортируем его.
uksort($Files,"FCmp");  //передаем функцию сортировки "по ссылке"

2 пример использования функции uksort():

<?php
function cmp($a, $b)
{
    if ($a == $b) {
        return 0;
    }
    return ($a > $b) ? -1 : 1;
}

$a = array(4 => "four", 3 => "three", 20 => "twenty", 10 => "ten");

uksort($a, "cmp");

while (list($key, $value) = each($a)) {
    echo "$key: $valuen";
}
?>

Этот пример выведет:

20: twenty
10: ten
4: four
3: three

Функция поддерживается PHP 3 >=3.0.4, PHP 4, PHP 5

[править] usort

Пользоваетльская сортировка значений массива.

Синтаксис:

bool usort(array arr, callback cmp_function)

Функция usort() сортирует массив arr без сохраненя индексных ассоциаций, используя для сравнения значений пользовательскую функцию, указанную в аргументе cmp_function. В эту функцию передаются два сравниваемых индекса элементов, а она должна вернуть положительное или отрицательное число или 0.

Эта функция как бы является "гибридом" функций uasort() и sort(). От sort() она отличается тем, что критерий сравнения обеспечивается пользовательской функцией. А от uasort() - тем, что она не сохраняет связей между ключами и значениями, а потому пригодна разве что для сортировки списков.

Пример использования функции usort():

<?php
function cmp($a, $b)
{
    if ($a == $b) {
        return 0;
    }
    return ($a < $b) ? -1 : 1;
}

$a = array(3, 2, 5, 6, 1);

usort($a, "cmp");

while (list($key, $value) = each($a)) {
    echo "$key: $valuen";
}
?>

Пример одномерного массива:

function cmp($a, $b) {
  if($a==$b) return 0;
  return ($a > $b) ? -1 : 1;
}
$a=array (3,2,5,6,1);
usort($a, "cmp");
while(list($key,$val)=each($a)) {
  echo "$key: $valn";
}

При выполнении будет напечатано:

0: 6
1: 5
2: 3
3: 2
4: 1

Пример многомерного массива:

function cmp($a,$b) {
  return strcmp($a["fruit"],$b["fruit"]);
};
$fruit[0]["fruit"]="lemons";
$fruit[1]["fruit"]="apples";
$fruit[2]["fruit"]="grapes";

usort($fruit, "cmp");

while(list($key,$val)=each($fruit)) {
  echo "$fruit[$key]:".$val["fruit"]."n";
}

При сортировке многомерных массивов $a и $b содержит ссылки на первый индекс массива.

Будет напечатано:

$fruit[0]: apples
$fruit[1]: grapes
$fruit[2]: lemons

Если необходимо отсортировать массив с различными вторыми ключами, можно поступить следующим образом:

<?php
function arr_sort($a,$b) {
  list($key1,$val)=each($a);
  list($key2,$val)=each($b);
  return strcmp($a[$key1],$b[$key2]);
};

$arr[0]["1-ый элемент"]="яблока";
$arr[1]["2-ый элемент"]="груша";
$arr[2]["3-ый элемент"]="персик";
$arr[3]["4-ый элемент"]="дыня";
$arr[4]["5-ый элемент"]="малина";
$arr[5]["6-ый элемент"]="ананас";

usort($arr,"arr_sort");

echo "<pre>";
print_r($arr);
echo "</pre>";
?>

Приведенный скрипт выведет следующее:

Array
(
    [0] => Array
        (
            [6-ый элемент] => ананас
        )

    [1] => Array
        (
            [2-ый элемент] => груша
        )

    [2] => Array
        (
            [4-ый элемент] => дыня
        )

    [3] => Array
        (
            [5-ый элемент] => малина
        )

    [4] => Array
        (
            [3-ый элемент] => персик
        )

    [5] => Array
        (
            [1-ый элемент] => яблока
        )
)

Функция поддерживается PHP 3 >=3.0.3, PHP 4, PHP 5

[править] array_multisort

Сортировка нескольких массивов или многомерного массива.

Синтаксис:

bool array_multisort(array ar1, [, mixed arg [, mixed ... [, array ...]]])

Функция array_multisort() сортирует сразу несколько массивов или многомерные массивы с сохранением индексной ассоциации, возвращая true при отсутствии ошибок.

Исходные массивы рассматриваются как столбцы таблицы, сортируемой построчно. Поэтому массивы должны иметь одинаковое число элементов, и взаимосвязь между ними, как в строках таблицы, сохраняется. Приоритетом сортировки пользуются первые массивы. Флаги сортировки могут указваться для каждого массива, и их действие распространяется только на тот массив, после которого они указаны.

Флаги определения порядка сортировки:

  • SORT_ASC - сортировка в порядке возрастания (по умолчанию)
  • SORT_DESC - сортировка в порядке убывания

Флаги типа сортировки:

  • SORT_REGULAR - сравнивать элементы как есть (по умолчанию)
  • SORT_NUMERIC - сравнивать элементы как числа
  • SORT_STRING - сравнивать элементы как строки

Уазание несколько флагов сортировки после одного массива недопустимо. Флаги сортировки, которые переются после аргумента arr применяются только к этому аргументу. Если после следующего аргумента флаги не указаны, то принимаются флаги по умолчанию (SORT_ASC, SORT_REGULAR).

Пример использования функции array_multisort():

Сортировка нескольких массивов

ar1 = array("10", 100, 100, "a");
ar2 = array(1, 3, "2", 1);
array_multisort($ar1, $ar2);
  // $ar1 = array("10", "a", 100, 100);
  // $ar2 = array(1, 1, "2", 3);

Элементы второго массива, соответствующие одинаковым элементам (100 и 100) первого массива, также отсортированны.

Сортировка многомерного массива

$ar = array(array("10", 100, 100, "a"), array(1, 3, "2", 1));
array_multisort($ar[0], SORT_ASC, SORT_STRING,
                   $ar[1], $SORT_NUMERIC, SORT_DESC);

// $ar[0] = ("10", 100, 100, "a") - сортируются как строки по возрастанию
// $ar[1] = (1, 3, "2", 1) - сортируются как числа по убыванию

Функция поддерживается PHP 4, PHP 5

Получено с http://spravkaweb.local/index.php/php/datafun/array/sort
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 15:07, 26 января 2007.
  • К этой странице обращались 132 раза.
1.44338798523


Справочник по PHP : Функции работы с данными : Работа с массивами : Курсор массива — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Работа с массивами : Курсор массива

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Сортировка массивов
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Работа с массивами | ::. | Курсор массива
 |  |  |  |  |  |  |  | Ключи и значения

Содержание

  • 1 reset
  • 2 end
  • 3 next
  • 4 prev
  • 5 current
  • 6 pos
  • 7 key
  • 8 each
  • 9 array_walk

[править] reset

Производит сброс курсора массива.

Синтаксис:

mixed reset(array arr)

Функция reset() устанавливает внутренний курсор массива arr на его начало и возвращает значение начального элемента.

Пример использования функции reset():

<?php
$array = array("step one", "step two", "step three", "step four");

// by default, the pointer is on the first element
echo current($array) . "<br />n"; // "step one"

// skip two steps
next($array);
next($array);
echo current($array) . "<br />n"; // "step three"

// reset pointer, start again on step one
reset($array);
echo current($array) . "<br />n"; // "step one"
?>

Функция поддерживается PHP 3, PHP 4, PHP 5

[править] end

Производит перенос курсора в конец массива.

Синтаксис:

mixed end(array arr)

Функция end() устанавливает внутренний курсор массива arr на последний элемент и возвращает значение этого элемента.

Пример использования функции end():

<?php
$fruits = array("apple", "banana", "cranberry");
echo end($fruits); // cranberry
?>

Функция поддерживается PHP 3, PHP 4, PHP 5

[править] next

Производит перенос курсора вперед.

Синтаксис:

mixed next(array arr)

Функция next() возвращает значение элемента, на котором в данный момент находится курсор, и перемещает курсор массива на следующий элемент. Возвращает false, если элементов больше не осталось.

Также false возвращается, если встречается элемент с пустым значением, следовательно для корректной работы с массивом, содержащим пустые элементы, лучще использовать функцию each().

Пример использования функции next():

<?php
$transport = array("foot", "bike", "car", "plane");
$mode = current($transport); // $mode = "foot";
$mode = next($transport);    // $mode = "bike";
$mode = next($transport);    // $mode = "car";
$mode = prev($transport);    // $mode = "bike";
$mode = end($transport);     // $mode = "plane";
?>

Функция поддерживается PHP 3, PHP 4, PHP 5

[править] prev

Производит перенос курсора назад и возвращает предыдущее значени.

Синтаксис:

mixed prev(array arr)

Функция prev() перемещает курсор массива на предыдущий элемент и возвращает его значение. Возвращает false, если элементов больше не осталось.

Также false возвращается, если встречается элемент с пустым значением, следовательно для корректной работы с массивом, содержащим пустые элементы, лучще использовать функцию each().

Пример использования функции prev():

<?php
$transport = array("foot", "bike", "car", "plane");
$mode = current($transport); // $mode = "foot";
$mode = next($transport);    // $mode = "bike";
$mode = next($transport);    // $mode = "car";
$mode = prev($transport);    // $mode = "bike";
$mode = end($transport);     // $mode = "plane";
?>

Функция поддерживается PHP 3, PHP 4, PHP 5

[править] current

Определение текущего элемента массива.

Синтаксис:

mixed current(array arr)

Каждый массив имеет внутренний указатель(курсор) текущего элемента. Обычно он указывает на первый элемент массива.

Функция current() возвращает значение элемента, на котором в данный момент находится курсор массива, при этом не сдвигая курсор.

Если указатель находиться за пределами массива, или массив пустой, то функция возвратит FALSE.

Пример использования функции current():

<?php
$transport = array("foot", "bike", "car", "plane");
$mode = current($transport); // $mode = "foot";
$mode = next($transport);    // $mode = "bike";
$mode = current($transport); // $mode = "bike";
$mode = prev($transport);    // $mode = "foot";
$mode = end($transport);     // $mode = "plane";
$mode = current($transport); // $mode = "plane";
?>

Функция поддерживается PHP 3, PHP 4, PHP 5

[править] pos

Определение текущего элемента массива.

Синтаксис:

mixed pos(array arr)

Эта функция синоним функции current().

[править] key

Функция возвращает индекс текущего элемента массива.

Синтаксис:

mixed key(array arr)

Функция key() возвращает индекс текущего элемента массива.

Пример использования функции key():

<?php
$array = array(
    "fruit1" => "apple",
    "fruit2" => "orange",
    "fruit3" => "grape",
    "fruit4" => "apple",
    "fruit5" => "apple");

// этот цикл пройдется по всему массиву
// и выведет имя ключа элемента массива
// значение которого равно "apple"

while ($fruit_name = current($array)) {
    if ($fruit_name == "apple") {
        echo key($array)."*<br />";
    }
    next($array);
}
?>

Функция поддерживается PHP 3, PHP 4, PHP 5

[править] each

Получение текущего элемента массива.

Синтаксис:

array each(array arr)

Функция each() возвращает пару"индекс и значение" текущего элемента массива, на который указывает внутренний курсор, и сдвигает курсор массива на следующий элемент.

Пример использования функции each():

<?php
$foo = array("bob", "fred", "jussi", "jouni", "egon", "marliese");
$bar = each($foo);
print_r($bar);
?>

Массив $bar будет иметь ключи и значения:

Array
(
    [1] => bob
    [value] => bob
    [0] => 0
    [key] => 0
)
<?php
$foo = array("Robert" => "Bob", "Seppo" => "Sepi");
$bar = each($foo);
print_r($bar);
?>

Массив $bar будет иметь ключи и значения:

Array
(
    [1] => Bob
    [value] => Bob
    [0] => Robert
    [key] => Robert
)

Пример использования функции each():

Пролистывание массива

<?php
$fruit = array("a" => "apple", "b" => "banana", "c" => "cranberry");

reset($fruit);
while (list($key, $val) = each($fruit)) {
    echo "$key => $valn";
}
?>

Пример выведет:

a => apple
b => banana
c => cranberry

Функция поддерживается PHP 3, PHP 4, PHP 5

[править] array_walk

Применение пользовательской функции к элементам массива.

Синтаксис:

bool array_walk(array arr, callback function [, mixed userdata])

Функция array_walk() применяет пользовательскую функцию function к каждому элементу массива arr. В пользовательскую функцию передаются три или два (в случае, если аргумент userdata не указан) аргумента: значение текущего элемента, его индекс и аргумент userdata.

В случае, если function требует более трех аргументов, при каждом ее вызове будет выдаваться предупреждение. Чтобы блокировать выдачу этих предупреждений, поставте знак "@" перед функцией array_walk() или воспользуйтесь функцией error_reporting().

Функция function будет получать значения и индексы массива arr по занчению, т.е. не сможет вносить в него изменения. Если это необходимо, передайте аргумент arr по ссылке, указав перед его именем "&", и тогда все изменения отразяться в массиве.

В PHP 4 необходимо явно вызывать функцию reset(), чтобы установить внутренний курсор на первый элемент.

Пример использования функции array_walk():

<?php
$fruits = array("d" => "lemon", "a" => "orange", "b" => "banana", "c" => "apple");

function test_alter(&$item1, $key, $prefix)
{
    $item1 = "$prefix: $item1";
}

function test_print($item2, $key)
{
    echo "$key. $item2<br />n";
}

echo "Before ...:n";
array_walk($fruits, "test_print");

array_walk($fruits, "test_alter", "fruit");
echo "... and after:n";

array_walk($fruits, "test_print");
?>

Приведенный пример выведет следующее:

Before ...:
d. lemon
a. orange
b. banana
c. apple
... and after:
d. fruit: lemon
a. fruit: orange
b. fruit: banana
c. fruit: apple

Функция поддерживается PHP 3 >= 3.0.3, PHP 4, PHP 5

Получено с http://spravkaweb.local/index.php/php/datafun/array/spire
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 15:29, 26 января 2007.
  • К этой странице обращались 96 раз.
2.17270898819


Справочник по PHP : Функции работы с данными : Работа с массивами : Переменные и массивы — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Работа с массивами : Переменные и массивы

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Вставка / удаление элементов
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Работа с массивами | ::. | Переменные и массивы
 |  |  |  |  |  |  |  | Строковые функции > Функции для работы с одиночными символами

[править] list

Заносит элементы массива в переменные.

Синтаксис:

void list ( mixed ...)

Наподобие array(), функция list() не совсем функция, а языковая конструкция. Она используется для формирования списка переменных.

Замечание: list() работает только с цифровыми индексами массива и принимает ключи элементов начиная с 0.

Пример использования функции list():

<?php
$info = array("coffee", "brown", "caffeine");

// Выведем все переменные
list($drink, $color, $power) = $info;
echo "$drink is $color and $power makes it special.n";

// Выведем первый и последний
list($drink, , $power) = $info;
echo "$drink has $power.n";

// Выведем только третий
list( , , $power) = $info;
echo "I need $power!n";
?>

Пример использования функции list():

<table>
    <tr>
        <th>Employee name</th>
        <th>Salary</th>
    </tr>

    <?php

    $result = mysql_query("SELECT id, name, salary FROM employees", $conn);
    while (list($id, $name, $salary) = mysql_fetch_row($result)) {
        echo " <tr>n" .
              "  <td><a href="info.php?id=$id">$name</a></td>n" .
              "  <td>$salary</td>n" .
              " </tr>n";
    }
    ?&gt;

</table>

Пример использования функции list(): Индексы

<?php
$info = array("coffee", "brown", "caffeine");

list($a[0], $a[1], $a[2]) = $info;

var_dump($a);
?>
array(3) {
  [2]=>
  string(8) "caffeine"
  [1]=>
  string(5) "brown"
  [0]=>
  string(6) "coffee"
}

Функция поддерживается PHP 3, PHP 4, PHP 5

[править] compact

Упаковывает в массив переменные из текущего контекста.

Синтаксис:

array compact(mixed varname1 [, mixed $varname2, ...])

Функция compact() упаковывает в массив переменные из текущего контекста (глобального или контекста функции), заданные своими именами в varname1, $varname2 и т.д. При этом в массиве образуются пары с ключами, равными содержимому varnameN, и значениями соответствующих переменных.

Число аргументов может быть неопределенное.

Если в аргументе указано имя несуществующей переменной, он пропускается. Действие этой функции противоположно функции extract().

Пример использования функции compact():

<?php
$city  = "San Francisco";
$state = "CA";
$event = "SIGGRAPH"";

$location_vars = array("city", "state");

$result = compact("event", "nothing_here", $location_vars);
?>

В результате выполнения кода переменная $result имеет значение:

Array
(
    [event] => SIGGRAPH
    [city] => San Francisco
    [state] => CA
)

Почему же тогда параметры функции обозначены как mixed? Дело в том, что они могут быть не только строками, но и списками строк. В этом случае функция последнего перебирает все элементы этого списка, и упаковывает те переменные из текущего контекста, имена которых она встретила. Более того - эти списки могут, в свою очередь, также содержать списки строк, и т.д. Правда, последнее используется достаточно редко.

Пример использования функции compact():

<?php
$a="Test";
$b="Text";
$c="CCC";
$d="DDD";
$List=array("b",array("c","d"));
$A=compact("a",$List);
?>

Теперь:

// теперь $A===array("a"=>"Test", "b"=>"Text",
          "c"=>"CCC", "d"=>"DDD")

Функция поддерживается PHP 4, PHP 5

[править] extract

Импорт элементов массива в переменные.

Синтаксис:

int extract (array var_array [, int extract_type [, string prefix]])

Функция extract() используется для импортирования значений массива в строку. Эта функция берет ассоциативный массив var_array, использую ключ элемента как имя переменной, а значение элемента как значение полученной переменной. Для создания переменных из пары ключ => значение можно также использовать необязательные параметры extract_type и prefix.

Замечание: начиная с PHP версии 4.0.5 эта функция возвращала количество извлеченных переменных.

Функция extract() проверяет, действительно ли каждый ключ массива может быть названием переменной. Она также проверяет на наличие одинаковых названий получаемых переменных. В случае, если обнаруживаются недействительные или числовые ключи, поведение функции предопределяет параметр extract_type, который может принимать следующие значения:

EXTR_OVERWRITE
Если переменная с таким именем уже существует, то ее значение будет заменено (значение по умолчанию).
EXTR_SKIP
Если переменная с таким именем уже существует, то ее значение не будет заменено.
EXTR_PREFIX_SAME
Если переменная с таким именем уже существует, то к ее имени добавится префикс, определенный в параметре prefix.
EXTR_PREFIX_ALL
Ко всем образуемым переменным будет добавлен префикс prefix.
EXTR_PREFIX_INVALID
Только при неправильных или числовых индексах массива к имени переменной будет добавлен префикс prefix.
EXTR_IF_EXISTS
Если переменная с таким именем уже существует, то ее значение будет переписано. Иначе ничего не сделает. Это может быть полезно, если вы задали список всех переменных, а затем хотите извлечь только те переменные, которые были определены, например, из $_REQUEST. Этот флаг был добавлен в PHP 4.2.0
EXTR_PREFIX_IF_EXISTS
Создает переменные с префиксом, если такие переменные без префикса уже существовали. В любом другом случае ничего не создает. Этот флаг был добавлен в PHP 4.2.0
EXTR_REFS
Переменные создаются как ссылки. Это означает, что созданные переменные все еще ссылаются на значения соответствующих элементов массива var_array. Вы можете применять этот флаг как в одиночку, так и совместно с другими флагами. Этот флаг был добавлен в PHP 4.3.0

Пример использования функции extract():

<?php

/* Предположим, что $var_array массив,
   полученный при помощи функции wddx_deserialize */

$size = "large";
$var_array = array("color" => "blue",
                   "size"  => ""medium",
                   "shape" => "sphere");
extract($var_array, EXTR_PREFIX_SAME, "wddx");

echo "$color, $size, $shape, $wddx_sizen";
?>

Пример выведет:

blue, large, sphere, medium

Здесь переменная $size не была переписана, т.к. мы указали параметр EXTR_PREFIX_SAME. Если указать EXTR_SKIP, тогда переменная $wddx_size даже не была бы создана. Если указать EXTR_OVERWRITE, то переменная $size имела бы значение "medium". Если EXTR_PREFIX_ALL - то в результате были бы созданы переменные $wddx_color, $wddx_size, и $wddx_shape.

Лучше всего использовать ассоциативные массивы. Массивы с цифровыми ключами не могут быть использованы в этой функции, если установлены флаги EXTR_PREFIX_ALL или EXTR_PREFIX_INVALID.

Функция поддерживается PHP 3 >= 3.0.7, PHP 4, PHP 5

Получено с http://spravkaweb.local/index.php/php/datafun/array/vararr
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 16:17, 28 января 2007.
  • К этой странице обращались 95 раз.
1.62633800507


Справочник по PHP : Функции работы с данными : Математические функции : Функции повышенной точности BCMath — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Математические функции : Функции повышенной точности BCMath

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Тригонометрия
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Математические функции | ::. | Функции повышенной точности BCMath
 |  |  |  |  |  |  |  | Функции GMP

Содержание

  • 1 bcadd
  • 2 bccomp
  • 3 bcdiv
  • 4 bcmod
  • 5 bcmul
  • 6 bcpow
  • 7 bcscale
  • 8 bcsqrt
  • 9 bcsub

[править] bcadd

Сложение двух чисел произвольной точности.

Синтаксис:

string bcadd(string left_operand, string right_operand [, int scale]);

Эта функция возвращает строковое представление суммы двух параметров (left_operand + right_operand) с точностью, которая указана в необязательном параметре scale.

Точность (scale) указывает количество десятичных знаков после запятой).

[править] bccomp

Сравнение двух чисел произвольной точности.

Синтаксис:

int bccomp(string left_operand, string right_operand, [int scale]);

Сравнивает числа (left_operand с right_operand) и возвращает результат типа integer (целое). Параметр scale используется для установки количества цифр после десятичной отметки, используемых при сравнении. При равенстве двух частей возвращается значение 0. Если левая часть больше правой части возвращается +1, и если левая часть меньше правой части возвращается -1.

[править] bcdiv

Операция деления для двух чисел произвольной точности.

Синтаксис:

string bcdiv(string left_operand, string right_operand [, intscale]);

Делит left_operand на right_operand и возвращает результат с точностью (знаками после запятой), заданной в параметре scale.

[править] bcmod

Возвращает остаток целочисленного деления.

Синтаксис:

string bcmod(left_operand, string modulus);

Данная функция возвращает остаток от целочисленного деления left_operand на modulus.

[править] bcmul

Операция умножения для двух чисел произвольной точности.

Синтаксис:

string bcmul(string left_operand, string right_operand [, int scale]);

Производит умножение left_operand на right_operand, и выдает результат в виде строки с точностью, заданной в переменной scale.

[править] bcpow

Возведение одного числа произвольной точности в степень другого.

Синтаксис:

string bcpow(string x, string y, [int scale]);

Возведение x в степень y. Параметр scale может использоваться для установки количества цифр после точки.

[править] bcscale

Устанавливает точность вычислений.

Синтаксис:

string bcscale(int scale);

Эта функция устанавливает заданную по умолчанию точность вычислений для всех математических функций BCMath, которые явно не определяют точность.

[править] bcsqrt

Получение квадратного корня числа произвольной точности.

Синтаксис:

string bcsqrt(string operand [,int scale]);

Возвращает квадратный корень аргумента operand. Параметр scale устанавливает количество цифр после десятичной отметки в результате.

[править] bcsub

Вычитает одно число произвольной точности из другого.

Синтаксис:

string bcsub(string left_operand, right_operand [, int scale]);

Возвращает разность двух переменных, указанных в параметрах функции (left_operand - right_operand) с точностью, указанной в необязательном параметре scale.

Получено с http://spravkaweb.local/index.php/php/datafun/math/bcmath
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 10:54, 12 февраля 2007.
  • К этой странице обращались 83 раза.
1.25159811974


php/datafun/math/gmp — Справочник Web-языков

php/datafun/math/gmp

 |  |  |  |  |  |  |  | Функции повышенной точности BCMath
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Математические функции | ::. | Функции GMP
 |  |  |  |  |  |  |  | Введение

[править] Подразделы

  • Введение
  • Значения функции GMP
  • Арифметика
  • Математика
  • Бинарные операции

[править] Функции

  • gmp_init - Создает число GMP.
  • gmp_intval - Преобразование GMP-числа в целое.
  • gmp_strval - Преобразование GMP-числа в строку.
  • gmp_abs - Вычисляет модуль GMP-числа.
  • gmp_sign - Возвращает знак числа.
  • gmp_neg - Возвращает отрицательное значение числа.
  • gmp_add - Сложение двух чисел.
  • gmp_sub - Вычитание двух чисел.
  • gmp_mul - Умножение двух чисел.
  • gmp_div - Деление двух чисел.
  • gmp_div_q - Деление двух чисел.
  • gmp_div_r - Возвращает остаток от целочисленного деления.
  • gmp_div_qr - Производит деление с остатком.
  • gmp_mod - Возвращает модуль остатка деления.
  • gmp_divexact - Производит безостаточное деление.
  • gmp_cmp - Производит сравнение двух чисел.
Получено с http://spravkaweb.local/index.php/php/datafun/math/gmp
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:03, 12 февраля 2007.
  • К этой странице обращались 73 раза.
1.42656183243


Справочник по PHP : Функции работы с данными : Математические функции : Минимум и максимум — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Математические функции : Минимум и максимум

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Перевод в различные системы счисления
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Математические функции | ::. | Минимум и максимум
 |  |  |  |  |  |  |  | Степенные функции

[править] min

Эта функция возвращает наименьшее из чисел, заданных в ее аргументах.

Синтаксис:

mixed min(mixed $arg1 [int $arg2, ..., int $argn])

Различают два способа вызова этой функции: с одним параметром или с несколькими. Если указан лишь один параметр (первый), то он обязательно должен быть массивом и возвращается минимальный элемент этого массива. В противном случае первый (и остальные) аргументы трактуются как числа с плавающей точкой, они сравниваются, и возвращается наименьшее. Тип возвращаемого значения выбирается так: если хотябы одно из чисел, переданных на вход, задано в формате с плавающей точкой, то и результат будет с плавающей точкой, в противном случае результат будет целым числом. С помощью этой функции нельзя лексографически сравнивать строки - только числа.

$x = min(5,3,4,6,5,6,8,9);
// $x = 3
$x[0]=4;
$x[1]=1;
$x[2]=5;
$x[3]=2;
echo min($x); // выведет 1

[править] max

Получение наибольшего аргумента.

Синтаксис:

mixed max(mixed $arg1 [int $arg2, ..., int $argn])

Функция работает аналогично min(), только ищет максимальное значение.

$x = max(5,3,4,6,5,6,8,9);
// $x = 9
$x[0]=4;
$x[1]=1;
$x[2]=5;
$x[3]=2;
echo max($x); // выведет 5
Получено с http://spravkaweb.local/index.php/php/datafun/math/minmax
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:41, 25 января 2007.
  • К этой странице обращались 76 раз.
1.04650783539


Справочник по PHP : Функции работы с данными : Математические функции : Случайные числа — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Математические функции : Случайные числа

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Функции округления
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Математические функции | ::. | Случайные числа
 |  |  |  |  |  |  |  | Перевод в различные системы счисления

Содержание

  • 1 srand
  • 2 getrandmax
  • 3 rand
  • 4 mt_rand
  • 5 mt_srand
  • 6 mt_getrandmax
  • 7 lcg_value

[править] srand

Производит инициализацию генератора случайных чисел.

Синтаксис:

void srand(int seed)

Инициализирует генератор случайных чисел занчением seed.

srand((double) microtime()*1000000);
$random = rand();
echo $random;

[править] getrandmax

Возвращает максимально возможное случайное число.

Синтаксис:

int getrandmax()

Эта функция возвращает максимальное значение, которое можно получить при помощи функции генерации случайных чисел rand().

Обычно это 32767

[править] rand

Производит генерацию случайного числа.

Синтаксис:

int rand([int max [, int min]])

При вызове с необязательными параметрами min и max эта функция генерирует случайное число, лежащее в пределах этих параметров включительно.

Если параметры min и max отсутствуют, возвращается число, лежащее в пределах от 0 до RAND_MAX.

Для корректной работы данной функции перед ее использованием нужно проинициализировать генератор случайных чисел функцией srand().

[править] mt_rand

Функция возвращает MT-случайное число, достаточно равномерно даже для того, чтобы использовать его в криптографии.

Синтаксис:

int mt_rand(int $min=0, int $max=RAND_MAX)

Если вы хотите генерировать числа не от 0 до RAND_MAX (эта константа задает максимально допустимое случайное число, и ее можно получить при помощи вызова mt_getrandmax()), задайте соответствующий интервал в параметрах $min и $max. Не забудьте только перед первым вызовом этой функции запустить mt_srand().

mt_srand(time()+(double)microtime()*1000000);
$x = mt_rand(1,100); // $x - значение от 1 до 100

[править] mt_srand

Настраивает MT-генератор случайных чисел на новую последовательность.

Синтаксис:

void mt_srand(int seed)

Дело в том, что хотя числа, генерируемые mt_rand(), достаточно равновероятны, но у них есть один нелостаток: последовательность сгенерированных чисел будет одинакова если сценарий вызывать несколько раз подряд. Функция mt_srand() как раз решает данную проблему: она выбирает новую последовательность на основе параметра $seed, причем практически непредсказуемым образом.

mt_srand(time()+(double)microtime()*1000000);
for($i=0;$i<=10;$i++) {
  $x = mt_rand(1,10);
};

В этом случае последовательность устанавливается на основе времени запуска сценария (в секундах), поэтому она достаточно непредсказуема. Для еще более надежного результата рекомендуется приплюсовать сюда еще микросекунды (что и было сделано), а также идентификатор процесса, вызывавшего сценарий.

[править] mt_getrandmax

Возвращает максимальное MT-случайное число.

Синтаксис:

int mt_getrandmax()

Возвращает максимальное число, которое может быть сгенерированно функцией mt_rand() - иными словами, константу RAND_MAX

$max = mt_getrandmax();
// $max = 2147483647

[править] lcg_value

функция генерирует случайное дробное число.

Синтаксис:

double lcg_value()

Эта функция возвращает псевдослучайное дробное число в диапазоне от 0 до 1.

Получено с http://spravkaweb.local/index.php/php/datafun/math/random
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 15:06, 25 января 2007.
  • К этой странице обращались 105 раз.
2.06296086311


Справочник по PHP : Функции работы с данными : Математические функции : Функции округления — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Математические функции : Функции округления

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Синтаксис языка и операторы > Выражения
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Математические функции | ::. | Функции округления
 |  |  |  |  |  |  |  | Случайные числа

Содержание

  • 1 abs
  • 2 round
  • 3 ceil
  • 4 floor

[править] abs

Возвращает модуль числа.

Синтаксис:

mixed abs(mixed $number)

Тип параметра $number может быть float или int, а ти п возвращаемого значения всегда совпадает с типом этого параметра.

$x = abs(-4);    // $x=4
$x = abs(-7.45); // $x=7.45

[править] round

Округление дробного числа до целого.

Синтаксис:

double round(double $val)

Округляет $val до ближайшего целого и возвращает результат.

$foo = round(3.4); // $foo == 3.0
$foo = round(3.5); // $foo == 4.0
$foo = round(3.6); // $foo == 4.0
$x = round(5.3);  // $x=5
$x = round(5.4);  // $x=5
$x = round(5.45); // $x=5
$x = round(5.5);  // $x=6

[править] ceil

Дополнение дробного числа до следующего целого.

Синтаксис:

int ceil(float $number)

Возвращает наименьшее целое число, не меньше $number. Разумеется, передавать в $number целое число бессмысленно.

$x = ceil(5.0);  // $x=5
$x = ceil(5.1);  // $x=6
$x = ceil(5.9);  // $x=6

[править] floor

Удаление дробной части числа.

Синтаксис:

int floor(float $number)

Возвращает максимальное целое число, не превосходящее $number.

$x = floor(5.1);  // $x=5
$x = floor(5.9);  // $x=5
Получено с http://spravkaweb.local/index.php/php/datafun/math/round
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 17:49, 24 января 2007.
  • К этой странице обращались 220 раз.
1.91973185539


Справочник по PHP : Функции работы с данными : Математические функции : Степенные функции — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Математические функции : Степенные функции

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Минимум и максимум
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Математические функции | ::. | Степенные функции
 |  |  |  |  |  |  |  | Тригонометрия

Содержание

  • 1 sqrt
  • 2 log
  • 3 log10
  • 4 exp
  • 5 pow

[править] sqrt

Возвращает квадратный корень из аргумента.

Синтаксис:

float sqrt(float $arg)

Если аргумент отрицателен, то генерируется предупреждение, но работа программы не прекращается!

$x = sqrt(9);
// $x = 3
echo sqrt(25);     // выведет 5
echo sqrt(-25); // выведет -1.#IND

[править] log

Возвращает натуральный логарифм аргумента.

Синтаксис:

float log(float $arg)

В случае недопустимого числа печатает предупреждение, но не завершает программу.

$x = log(exp(2));  // exp(2) - e в степени 2
                   // $x = 2
$x = log(M_E);     // $x = 1
echo log(10);      // выведет 2.302585092994

[править] log10

Возвращает десятичный логарифм аргумента.

Синтаксис:

float log10(float $arg)

В случае недопустимого числа печатает предупреждение, но не завершает программу.

echo log10(100); // выведет 2

[править] exp

Возвращает e (2,718281828) в степени $arg.

Синтаксис:

float exp(float $arg)
$x = exp(1);
// $x = 2.718281828459

[править] pow

Возведение в степень.

Синтаксис:

float pow(float $base, float $exp)

Возвращает $base в степени $exp.

$x = pow(3,2);   // $x = 9
$x = pow("3",2); // $x = 9
Получено с http://spravkaweb.local/index.php/php/datafun/math/sqrt
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:44, 25 января 2007.
  • К этой странице обращались 85 раз.
1.18141698837


Справочник по PHP : Функции работы с данными : Математические функции : Перевод в различные системы счисления — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Математические функции : Перевод в различные системы счисления

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Случайные числа
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Математические функции | ::. | Перевод в различные системы счисления
 |  |  |  |  |  |  |  | Минимум и максимум

Содержание

  • 1 base_convert
  • 2 bindec
  • 3 decbin
  • 4 dechex
  • 5 decoct
  • 6 hexdec
  • 7 octdec
  • 8 deg2rad
  • 9 rad2deg
  • 10 number_format

[править] base_convert

Конвертация числа из одной системы счисления в другую.

Синтаксис:

string base_convert(string $number, int $frombase, int $tobase)

Переводит число $number (заданное как строка в системе счисления по основанию $frombase) в систему по основанию $tobase. Параметры $frombase и $tobase могут принимать значения только от 2 до 36 включительно. В строке $number цифры обозначают сами себя, а буква a соответствует 11, b -12, и т.д. до z, которая обозначает 36. Например, следующие команды выведут 11111111 (8 единичек), потому что это - не что иное, как представление шестнадцатиричного числа FF в двоичной системе счисления:

$x = base_convert("FF",16,2);       //$x = 11111111
$x = base_convert("11111111",2,16); //$x = FF
$x = base_convert("200",10,16);     //$x = C8

[править] bindec

Производит конвертацию двоичного числа в десятичное.

Синтаксис:

int bindec(string binary_string)

Преобразует двоичное число, заданное в строке binary_string, в десятичное число. Максимальное число, которое еще может быть преобразовано, равно 2 147 483 647

$x = bindec(11111111); // $x = 255
$x = bindec(10101010); // $x = 170
$x = bindec(2147483647); // $x = 1111111111111111111111111111111

[править] decbin

Производит конвертацию десятичного числа в двоичное.

Синтаксис:

string decbin(int $number)

Возвращает строку, представляющую собой двоичное представление целого числа $number. Максимальное число, которое еще может быть преобразовано, равно 2 147 483 647, которое выглядит как 31 единичка в двоичной системе.

Существует аналогичные функции для восьмеричной и шестнадцатиричной систем. Называются они так же, только вместо "bin" подставляются соответственно "oct" и "hex".

$x = decbin(255); // $x = 11111111
$x = decbin(2147483647); // $x = 1111111111111111111111111111111

[править] dechex

Производит конвертацию десятичного числа в шестнадцатеричное.

Синтаксис:

string dechex(int number)

Возвращает строку, представляющую собой шестнадцатеричное представление целого числа number. Максимальное число, которое еще может быть преобразовано, равно 2 147 483 647

$x = dechex(2147483647); // $x = 7fffffff

[править] decoct

Производит конвертацию десятичного числа в восьмеричное.

Синтаксис:

string decoct(int number)

Возвращает строку, представляющую собой восьмеричное представление целого числа number. Максимальное число, которое еще может быть преобразовано, равно 2 147 483 647

$x = dechex(2147483647); // $x = 17777777777

[править] hexdec

Производит конвертацию шестнадцатеричного числа в десятичное.

Синтаксис:

int hexdec(string hex_string)

Преобразует шестнадцатеричное число, заданное в строке hex_string, в десятичное число. Максимальное число, которое еще может быть преобразовано, равно 7fffffff

$x = hexdec(7fffffff); // $x = 2147483647

[править] octdec

Производит конвертацию восьмеричного числа в десятичное.

Синтаксис:

int octdec(string octal_string)

Преобразует восьмеричное число, заданное в строке octal_string, в десятичное число. Максимальное число, которое еще может быть преобразовано, равно 17777777777

$x = octdec(17777777777); // $x = 2147483647

[править] deg2rad

Производит конвертацию градусов в радианы.

Синтаксис:

double deg2rad(double number)

Преобразует градусы, заданные в параметре number, в радианы.

[править] rad2deg

Производит конвертацию радианов в градусы.

Синтаксис:

double rad2deg(double number)

Преобразует радианы, заданные в параметре number, в градусы.

[править] number_format

Форматирование числа.

Синтаксис:

number_format($number, $decimals, $dec_point=".", $thousands_sep=",");

Эта функция форматирует число с плавающей точкой с разделением его на триады с указанной точностью. Она может быть вызвана с двумя или четырьмя аргументами, но не с тремя! Параметр $decimals задает, сколько цифр после запятой должно быть у числа в выходной строке.

Параметр $dec_point представляет собой разделитель целой и дробной частей, а параметр $thousands_sep - разделитель триад в числе (если указать на его месте пустую строку, то триады не отделяются друг от друга).

Получено с http://spravkaweb.local/index.php/php/datafun/math/system
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:39, 25 января 2007.
  • К этой странице обращались 97 раз.
1.5828537941


Справочник по PHP : Функции работы с данными : Математические функции : Тригонометрия — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Математические функции : Тригонометрия

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Степенные функции
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Математические функции | ::. | Тригонометрия
 |  |  |  |  |  |  |  | Функции повышенной точности BCMath

Содержание

  • 1 sin
  • 2 cos
  • 3 tan
  • 4 acos
  • 5 asin
  • 6 atan
  • 7 atan2
  • 8 pi

[править] sin

Возвращает синус аргумента.

Синтаксис:

float sin(float $arg)

Аргумент задается в радианах.

$x = sin(M_PI_2); // $x = 1

[править] cos

Возвращает косинус аргумента.

Синтаксис:

float cos(float $arg)
$x = cos(0); // $x = 0
$x = cos(M_PI); // $x = -1

[править] tan

Возвращает тангенс аргумента, заданного в радианах.

Синтаксис:

float tan(float $arg)
$x = tan(M_PI_4); // $x = 1

[править] acos

Возвращает арккосинус аргумента.

Синтаксис:

float acos(float $arg)
$x = acos(0); // $x = pi/2
$x = acos(1); // $x = 0

[править] asin

Возвращает арксинус.

Синтаксис:

float asin(float $arg)
$x = asin(0); // $x = 0
$x = asin(1); // $x = pi/2

[править] atan

Возвращает арктангенс аргумента.

Синтаксис:

float atan(float $arg)
$x = atan(0); // $x = 0
$x = atan(1); // $x = pi/4

[править] atan2

Получение арктангенса двух чисел.

Синтаксис:

float atan2(float $y, float $x)

Возвращает арктангенс величины $y/$x, но с учетом той четверти, в которой лежит точка ($x,$y). Эта функция возвращает результат в радианах, принадлежащий отрезку от -? до ?.

$x = atan2(1,1);   // $x = pi/4
$x = atan2(-1,-1); // $x = -3*pi/4

[править] pi

Возвращает число пи - 3,14.

Синтаксис:

double pi()

Эту функцию обязательно нужно вызывать с парой пустых скобок:

$x = pi()*2 // $x = 31.415926535898
Получено с http://spravkaweb.local/index.php/php/datafun/math/trigonometry
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:49, 25 января 2007.
  • К этой странице обращались 80 раз.
1.47524118423


Справочник по PHP : Функции работы с данными : Математические функции : Функции GMP : Введение — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Математические функции : Функции GMP : Введение

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  |  |  | Функции повышенной точности BCMath
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Математические функции | ::. | Функции GMP | ::. | Введение
 |  |  |  |  |  |  |  |  |  | Значения функции GMP

Функции этого вида позволяют работать с целыми числами повышенной точности определенного формата используя библиотеку GNU MP. Эта библиотека не входит в стандартный пакет PHP. Загрузить коды библиотеки и документацию по ней можно на сайте http://www.swox.com/gmp/.

Функции, приведенные в этой библиотеке, могут также работать с обычными целочисленными аргументами. В этом случае они будут автоматически преобразовываться в формат GMP. Но для увеличения производительности рекомендуется все же использовать числа формата GMP.

Получено с http://spravkaweb.local/index.php/php/datafun/math/gmp/about
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
������ ����������� Powered by MediaWiki
  • Последнее изменение этой страницы: 10:55, 12 февраля 2007.
  • К этой странице обращались 83 раза.
1.27937507629


Справочник по PHP : Функции работы с данными : Математические функции : Функции GMP : Арифметика — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Математические функции : Функции GMP : Арифметика

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  |  |  | Значения функции GMP
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Математические функции | ::. | Функции GMP | ::. | Арифметика
 |  |  |  |  |  |  |  |  |  | Математика

Содержание

  • 1 gmp_add
  • 2 gmp_sub
  • 3 gmp_mul
  • 4 gmp_div
  • 5 gmp_div_q
  • 6 gmp_div_r
  • 7 gmp_div_qr
  • 8 gmp_mod
  • 9 gmp_divexact
  • 10 gmp_cmp

[править] gmp_add

Сложение двух чисел.

Синтаксис:

recource gmp_add(resource x, recource y)

Функция возвратит GMP-число, равное сумме аргументов x и y.

[править] gmp_sub

Вычитание двух чисел.

Синтаксис:

recource gmp_sub(resource x, recource y)

Функция возвратит GMP-число, равное разности аргументов x и y.

[править] gmp_mul

Умножение двух чисел.

Синтаксис:

recource gmp_mul(resource x, recource y)

Функция возвратит GMP-число, равное произведению аргументов x и y.

[править] gmp_div

Деление двух чисел.

Синтаксис:

recource gmp_div(resource x, recource y [, int round])

Функция возвратит GMP-число, равное делению аргументов x на y. В зависимости от необязательного параметра round, результат деления будет округляться следующим образом:

  • GMP_ROUND_ZERO - цифры после точки отбрасываются
  • GMP_ROUND_PLUSINF - результат деления округляется в большую сторону
  • GMP_ROUND_MINUSINF - результат деления округляется в меньшую сторону

Эта функция - синоним gmp_div_q().

[править] gmp_div_q

Деление двух чисел.

Синтаксис:

recource gmp_div_q(resource x, recource y [, int round])

Функция возвратит GMP-число, равное делению аргументов x на y. В зависимости от необязательного параметра round, результат деления будет округляться следующим образом:

  • GMP_ROUND_ZERO - цифры после точки отбрасываются
  • GMP_ROUND_PLUSINF - результат деления округляется в большую сторону
  • GMP_ROUND_MINUSINF - результат деления округляется в меньшую сторону

У этой функции есть синоним - gmp_div().

[править] gmp_div_r

Возвращает остаток от целочисленного деления.

Синтаксис:

recource gmp_div_r(resource x, recource y [, int round])

Функция возвращает остаток от деления x на y. Знак будет наследован от аргумента x.

[править] gmp_div_qr

Производит деление с остатком.

Синтаксис:

array gmp_div_qr(resource x, recource y [, int round])

Данная функция комбинирует в себе действие двух предыдущих функций gmp_div_q() и gmp_div_r(). Она возвращает массив, состоящий из двух элементов:

  • под индексом [0] - целое частное
  • под индексом [1] - остаток деления
$x=gmp_init("0xf3c3b5");
$result=gmp_div_qr($x, "0xb1");
echo "Целое: ".gmp[strval($result[0]);
echo "Остаток: ".gmp[strval($result[1]);

[править] gmp_mod

Возвращает модуль остатка деления.

Синтаксис:

resource gmp_mod(resource x, recource y)

Данная функция эквивалентна gmp_div_r(), за исключением того, что она возвращает абсолютное значение.

[править] gmp_divexact

Производит безостаточное деление.

Синтаксис:

resource gmp_divexact(resource x, recource y)

Данная функция использует алгоритм "точного" деления. Результат будет достоверным, только если x будет нацело делим y.

[править] gmp_cmp

Производит сравнение двух чисел.

Синтаксис:

int gmp_cmp(resource x, recource y)

Функция возвратит положительное значение, если x > y; ноль, елси x = y; отрицательное значени, если x < y.

Получено с http://spravkaweb.local/index.php/php/datafun/math/gmp/arithmetic
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
������ ����������� Powered by MediaWiki
  • Последнее изменение этой страницы: 11:03, 12 февраля 2007.
  • К этой странице обращались 117 раз.
1.30924201012


Справочник по PHP : Функции работы с данными : Математические функции : Функции GMP : Бинарные операции — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Математические функции : Функции GMP : Бинарные операции

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  |  |  | Математика
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Математические функции | ::. | Функции GMP | ::. | Бинарные операции
 |  |  |  |  |  |  |  |  |  | Работа с массивами > Введение

Содержание

  • 1 gmp_and
  • 2 gmp_or
  • 3 gmp_xor
  • 4 gmp_setbin
  • 5 gmp_clrbit
  • 6 gmp_scan0
  • 7 gmp_scan1

[править] gmp_and

Логическое И (AND).

Синтаксис:

resource gmp_and(resource x, resource y)

[править] gmp_or

Логическое ИЛИ (OR).

Синтаксис:

resource gmp_or(resource x, resource y)

[править] gmp_xor

Логическое исключающее-ИЛИ (XOR).

Синтаксис:

resource gmp_xor(resource x, resource y)

[править] gmp_setbin

Установка бита.

Синтаксис:

resource gmp_setbin(resource &x, int index [, bool set_clear])

Устанавливает бит в позиции index в числе x. Аргумент set_clear указывает, в какое значение устанавливать бит: 0 или 1 (по умолчанию).

[править] gmp_clrbit

Производит сброс бита.

Синтаксис:

resource gmp_clrbit(resource &x, int index)

Устанавливает бит в позиции index в числе x в значение 0.

[править] gmp_scan0

Производит поиск бита 0.

Синтаксис:

int gmp_scan0(resource x, int start)

Функция gmp_scan0() ищет в числе x бит 0, начиная с позиции start, в сторону увеличения значимости разрядов. Возвращает позицию найденного бита.

[править] gmp_scan1

Производит поиск бита 1.

Синтаксис:

int gmp_scan1(resource x, int start)

Функция gmp_scan0() ищет в числе x бит 1, начиная с позиции start, в сторону увеличения значимости разрядов. Возвращает позицию найденного бита.

Получено с http://spravkaweb.local/index.php/php/datafun/math/gmp/binary
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
������ ����������� Powered by MediaWiki
  • Последнее изменение этой страницы: 10:57, 12 февраля 2007.
  • К этой странице обращались 86 раз.
1.34034895897


Справочник по PHP : Функции работы с данными : Математические функции : Функции GMP : Математика — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Математические функции : Функции GMP : Математика

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  |  |  | Арифметика
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Математические функции | ::. | Функции GMP | ::. | Математика
 |  |  |  |  |  |  |  |  |  | Бинарные операции

Содержание

  • 1 gmp_fact
  • 2 gmp_sqrt
  • 3 gmp_sqrtrm
  • 4 gmp_perfect_square
  • 5 gmp_pow
  • 6 gmp_powm
  • 7 gmp_prob_prime
  • 8 gmp_gcd
  • 9 gmp_gcdext
  • 10 gmp_invert
  • 11 gmp_legendre
  • 12 gmp_jacobi
  • 13 gmp_random
  • 14 gmp_popcount
  • 15 gmp_hamdist

[править] gmp_fact

Вычисляет факториал.

Синтаксис:

resource gmp_fact(resourse x)

Возвращает факториал числа, заданного в параметре x.

[править] gmp_sqrt

Вычисляет квадратный корень.

Синтаксис:

resource gmp_sqrt(resourse x)

Возвращает квадратный корень числа, заданного в параметре x.

[править] gmp_sqrtrm

Вычисляет квадратный корень с остатком.

Синтаксис:

array gmp_sqrtrm(resourse x)

Данная функция возвращает массив, в котором элемент с индексом [0] - это квадратный корень аргумента, элемент с индексом [1] - разность между аргументом и элементом [0] в квадрате.

[править] gmp_perfect_square

Определяет, является ли число полным квадратом.

Синтаксис:

bool gmp_perfect_square(resourse x)

Функция gmp_perfect_square() возвратит true, если x является квадратом целого числа. В противном случае вернет false.

[править] gmp_pow

Возведение в степень.

Синтаксис:

resource gmp_pow(resourse x, int y)

Эта функция возвращает результат, равный возведения аргумента x в степень y, при условии, что y не отрицательный.

echo gmp_pow(2,3); // Выведет 8
echo gmp_pow(0,0); // Выведет 1

[править] gmp_powm

[править] gmp_prob_prime

Проверка "вероятно" простого числа.

Синтаксис:

int gmp_prob_prime(resourse x [, int reps])

Эта функция возвратит 0, в случае если x сложное число, т.е. имеющее более двух целых делителей. Возвратит 1, если x, возможно, простое число. Если возвращает 2, то тогда x - наверняка простое число.

Аргумент reps определяет качество проверки. Чем большее это число, тем точнее результат. Может принимать значения от 5 до 10 (по умолчанию).

Эта функция использует алгоритм вероятностного теста Миллера-Рабина.

[править] gmp_gcd

Находит наибольший общий делитель.

Синтаксис:

resource gmp_gcd(resourse x, resource y)

Всегда возвращает положительный результат.

[править] gmp_gcdext

Нахождение наибольшего общего делителя со множителями.

Синтаксис:

array gmp_gcdext(resourse x, resource y)

Функция gmp_gcdext() возвращает массив со значениями g,s,t, такими, что x*s+y*t=g=НОД(x,y), гдн НОД - наибольший общий делитель.

[править] gmp_invert

Производит инверсию по модулю.

Синтаксис:

resource gmp_invert(resourse x, resource y)

Функция возвращает дополнение x до значения, делящегося нацело на y. В случае, если результат не может быть найден, возвращает false.

[править] gmp_legendre

Возвращает число Легранжа.

Синтаксис:

int gmp_legendre(resourse x, resource p)

Функция возвращает число Легранжа. p должен быть четным положительным.

[править] gmp_jacobi

Возвращает число Якоби.

Синтаксис:

int gmp_jacobi(resourse x, resource p)

Функция возвращает число Якоби. p должен быть четным положительным.

[править] gmp_random

Производит генерацию случайного числа.

Синтаксис:

resource gmp_random(int limited)

limited задает длину генерируемого числа. В случае, если значение limited отрицательно, генерируется отрицательное число.

[править] gmp_popcount

Получение популяции.

Синтаксис:

int gmp_popcount(resource x)

Функция возвращает числитель популяции.

[править] gmp_hamdist

Вычисление дистанции.

Синтаксис:

int gmp_hamdist(resource x, resource y)

Функция возвращает дистанцию между числами x и y. Аргументы x и y должны быть неотрицательными.

Получено с http://spravkaweb.local/index.php/php/datafun/math/gmp/mathematics
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
������ ����������� Powered by MediaWiki
  • Последнее изменение этой страницы: 10:56, 12 февраля 2007.
  • К этой странице обращались 93 раза.
1.43292999268


Справочник по PHP : Функции работы с данными : Математические функции : Функции GMP : Значения функции GMP — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Математические функции : Функции GMP : Значения функции GMP

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  |  |  | Введение
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Математические функции | ::. | Функции GMP | ::. | Значения функции GMP
 |  |  |  |  |  |  |  |  |  | Арифметика

Содержание

  • 1 gmp_init
  • 2 gmp_intval
  • 3 gmp_strval
  • 4 gmp_abs
  • 5 gmp_sign
  • 6 gmp_neg

[править] gmp_init

Создает число GMP.

Синтаксис:

resource gmp_init(mixed number)

Число GMP создается из целочисленного или строкового аргумента.

В строке может быть указано число десятеричного или шестнадцатеричного формата. Если это шестнадцатеричный формат, то перед числом должен стоять префикс 0x.

$x = gmp_init(45);
$y = gmp_init("46");
$z = gmp_init("0xfa4b");

Данная функция не обязательна (аргументы автоматически конвертируются в формат GMP), но желательна (при использовании функции gmp_init() повышается быстродействие).

[править] gmp_intval

Преобразование GMP-числа в целое.

Синтаксис:

int gmp_intval(resource gmpnumber)

Эта функция конвертирует GMP-число в целое в том случае, если получаемое число не превышает своего максимально допустимого размера.

[править] gmp_strval

Преобразование GMP-числа в строку.

Синтаксис:

string gmp_strval(resource gmpnumber [, int base])

Функция возвращает число gmpnumber в строковом формате в системе счисления, заданной в необязательном параметре base. По умолчанию возвращает в десятичной системе счисления).

Параметр base может принимать значения от 2 до 36.

$x = gmp_init("0xf1a5");
echo "В десятичной : ".gmp_strval($x);
echo "В base-36: ".gmp_strval($x,36);

[править] gmp_abs

Вычисляет модуль GMP-числа.

Синтаксис:

resource gmp_abs(resourse x)

Возвращает абсолютное значение числа, заданного в параметре x.

[править] gmp_sign

Возвращает знак числа.

Синтаксис:

int gmp_sign(resource x)

Функция gmp_sign() возвратит 1, если x - положительное число, и 0 - если отрицательное.

[править] gmp_neg

Возвращает отрицательное значение числа.

Синтаксис:

recource gmp_neg(resource x)

Возвратит -x.

Получено с http://spravkaweb.local/index.php/php/datafun/math/gmp/value
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
������ ����������� Powered by MediaWiki
  • Последнее изменение этой страницы: 10:56, 12 февраля 2007.
  • К этой странице обращались 87 раз.
1.53204989433


Справочник по PHP : Функции работы с данными : Строковые функции : Работа с бинарными данными — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Строковые функции : Работа с бинарными данными

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Функции URL
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Строковые функции | ::. | Работа с бинарными данными
 |  |  |  |  |  |  |  | Строковые суммы и хеш-функции

[править] pack

Пакетирование данных в двоичную строку.

Синтаксис:

string pack(string format [,mixed $args, ...]);

Функция pack() упаковывает заданные аргументы в бинарную строку, которая затем и возвращается. Формат параметров, а также их количество, задается при помощи строки $format, которая представляет собой набор однобуквенных спецификаторов форматирования - наподобие тех, которые указываются в sprintf(), но только без знака %. После каждого спецификатора может стоять число, которое отмечает, сколько информации будет обработано данным спецификатором. А именно, для форматов a,A,h и H число задает, какое количество символов будет помещено в бинарную строку из тех, что находится в очередном параметре-строке при вызове функции (то есть, определяет размер поля для вывода строки). В случае @ оно определяет абсолютную позицию, в которую будут помещены следующие данные. Для всех остальных спецификаторов следующие за ними числа задают количество аргументов, на которые распространяется действие данного формата. Вместо числа можно указать *, в этом случае подразумевается, что спецификатор действует на все оставшиеся данные.

Вот полный список спецификаторов формата:

  • a - строка, свободные места в поле заполняются символом с кодом 0;
  • A - строка, свободные места заполняются пробелами;
  • h - шестнадцатиричная строка, младшие разряды в начале;
  • H - шестнадцатиричная строка, старшие разряды в начале;
  • c - знаковый байт (символ);
  • C - беззнаковый байт;
  • s - знаковое короткое целое (16 битовб порядок байтов определяется архитектурой процессора);
  • S - беззнаковое короткое число;
  • n - беззнаковое целое (16 битов, старшие разряды в конце);
  • v - беззнаковое целое (16 битов, младшие разряды в конце);
  • i - знаковое целое (размер и порядок байтов определяется архитектурой);
  • I - беззнаковое целое;
  • l - знаковое длинное целое (32 бита, порядок знаков определяется архитектурой);
  • L - беззнаковое длинное целое;
  • N - беззнаковое длинное целое (32 бита, старшие разряды в конце);
  • V - беззнаковое целое (32 бита, младшие разряды в конце);
  • f - число с плавающей точкой (зависит от архитектуры);
  • d - число с плавающей точкой двойной точности (зависит от архитектуры);
  • x - символ с нулевым кодом;
  • X - возврат назад на 1 байт;
  • @ - заполнение нулевым кодом до заданной абсолютной позиции.
// Целое, целое, все остальное - сиволы
$bindata = pack("nvc*", 0x1234, 0x5678, 65, 66);

После выполнения приведенного кода в строке $bindata будет содержаться 6 байтов в такой последовательности: 0x12, 0x34, 0x78, 0x56, 0x41, 0x42 (в шестнадцатиричной системе счисления).

[править] unpack

Распаковывает данные из двоичной строки.

Синтаксис:

array unpack(string format, string data);

Распаковывает данные из двоичной строки в массив согласно формату. Возвращает массив, содержащий распакованные элементы.

$array = unpack("c2chars/nint", $binarydata);

Возникающий в результате массив будет содержать "chars1", "chars2" и "int".

Получено с http://spravkaweb.local/index.php/php/datafun/string/binary
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 16:52, 5 февраля 2007.
  • К этой странице обращались 72 раза.
7.90506005287


Справочник по PHP : Функции работы с данными : Строковые функции : Работа с блоками текста — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Строковые функции : Работа с блоками текста

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Составление/разбиение строк
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Строковые функции | ::. | Работа с блоками текста
 |  |  |  |  |  |  |  | Функции для преобразования символов

Содержание

  • 1 str_replace
  • 2 substr_replace
  • 3 wordwrap
  • 4 strtr
  • 5 stripslashes
  • 6 stripcslashes
  • 7 addslashes
  • 8 addcslashes
  • 9 quotemeta
  • 10 strrev

[править] str_replace

Заменяет в исходной строке одни подстроки на другие.

Синтаксис:

string str_replace(string from, string to, string str)

Эта функция заменяет в строке str все вхождения подстроки from (с учетом регистра) на to и возвращает результат. Исходная строка, переданная третьим параметром, при этом не меняется.

Также эта функция может работать с двоичными строками.

[править] substr_replace

Заменяет в исходной строке одни подстроки на другие.

Синтаксис:

string substr_replace(string str, string replacement, int start [, int lemgth])

Эта функция возвращает строку str, в которой часть от символа с позицией start и длиной length (или до конца, если аргумент длины не указан) заменяется строкой replacement.

Если значение start положительно, отсчет производится от начала строки str, иначе - от конца (-1 - последний символ строки).

Если значение length неотрицательное, тогда оно указывает длину заменяемого фрагмента. Если оно отрицательно, то это число символов от конца строки str до последнего символа заменяемого фрагмента (со знаком минус).

[править] wordwrap

Разбивает исходный текст на строки с определенными завершающими символами.

Синтаксис:

string wordwrap(string str [, int width [, string break [, int cut]]])

Эта функция разбивает блок текста str на несколько строк, завершаемых символами break, так, чтобы на одной строке было не более width букв. Разбиение происходит по границе слова, так что текст остается читаемым.

[править] strtr

Комплексная замена в строке.

Синтаксис:

string strtr(string str, string from, string to)
string strtr(string str, array from)

В первом случае функция strtr() возвращает строку str, у которой каждый символ, присутствующий в строку from, заменяется на корреспондирующий из строки to. В случае, если строки from и to различной длины, то лишние конечные символы длинной строки игнорируются.

Во втором случае функция strtr() возвращает строку, в которой фрагменты строки str заменяются на соответствующие индексам значения элементов массива from. При этом функция пытается заменить сначало наибольшие фрагменты исходной строки и не выполняет замену в уже модифицированных частях строки. Таким образом, теперь мы можем выполнить несколько замен сразу:

$Subs = array(
  "<name>" => "Larry",
  "<time>" => date("d.m.Y")
);
$st="Привет, <name>! Сейчас <time";
echo strtr($st,$Subs);

А вот как можно "отменить" действие функции HtmlSpecialChars():

$Trans=array_flip(get_html_translation_table());
$st=strtr($st, $Trans);

В результате мы из строки, в которой все спецсимволы заменены на их HTML-эквиваленты, получим исходную строку.

[править] stripslashes

Удаление обратных слешей.

Синтаксис:

string stripslashes(string str);

Заменяет в строке str некоторые предваренные слешем символы на их однокодовые эквиваленты. Это относится к следующим символам: ", ", .

[править] stripcslashes

Преобразование специальных символов в их двоичное представление.

Синтаксис:

string stripcslashes(string str);

Возвращает строку, в которой те специальные символы, которые закомментированы (для визуального отображения) обратным слешем, преобразуются в их естественное двоичное представление. Распознаются C-подобные записи, например: n, r ..., восьмеричные и шестнадцатеричные последовательности.

[править] addslashes

Добавление слешей перед специальными символами строки.

Синтаксис:

string addslashes(string str);

Вставляет слеши только перед следующими символами:", " и . Функцию очень удобно использовать при вызове eval().

[править] addcslashes

Форматирование строки слешами в С-представление.

Синтаксис:

string addcslashes(string str, string charlist);

Функция addcslashes() возвращает строку str, в которую вставлены символы обратного слеша "" перед перечисленными в строке-списке charlist символами. Это позволяет преобразовать непечатные символы в их визуальное С-представление.

[править] quotemeta

Цитирование метасимволов.

Синтаксис:

string quotemeta(string str);

Возвращает строку, в которую добавлены обратные слеши "" перед каждым из следующих символов: . \ + * ? [ ^ ] ( $ )

Может использоваться для подготовки шаблонов в регулярных выражениях.

[править] strrev

Производит реверс строки.

Синтаксис:

string strrev(string str)

функция strrev() возвращает строку str "задом наперед".

Получено с http://spravkaweb.local/index.php/php/datafun/string/block
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 16:17, 1 февраля 2007.
  • К этой странице обращались 93 раза.
8.11589288712


Справочник по PHP : Функции работы с данными : Строковые функции : Функции для работы с одиночными символами — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Строковые функции : Функции для работы с одиночными символами

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Работа с массивами > Переменные и массивы
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Строковые функции | ::. | Функции для работы с одиночными символами
 |  |  |  |  |  |  |  | Функции отрезания пробелов

[править] chr

Возвращает один символ с определенным кодом.

Синтаксис:

string chr(int ascii)

Возвращает строку из одного символа с кодом $code. Эта функция полезна для вставки каких-либо непечатаемых символов в строку - например, кода нуля или символа прогона страницы, а также при работе с бинарными файлами.

<?
// Сначало создаем массив того, что мы собираемся выводить,
// не заботясь о форматировании (дизайне) информации
for($i=0, $x=0; $x<16; $x++) {
  for($y=0; $y<16; $y++) {
    $Chars[$x][$y]=array($i,chr($i));
    $i++;
  }
}
// Теперь выводим накопленную информацию, используя идеологию
// вставки участков кода в HTML-документ
?>

<table border=1 cellpadding=1 cellspacing=0>
<?for($y=0; $y<16; $y++) {?>
  <tr>
  <?for($x=0; $x<16; $x++) {?>
    <td>
      <?=$Chars[$x][$y][0]?>:
      <b><tt><?=$Chars[$x][$y][1]?></tt></b>
    </td>
  <?}?>
  </tr>
<?}?>
</table>

[править] ord

Возвращает ascii код символа.

Синтаксис:

int ord(string str)

Эта функция возвращает ASCII код первого символа строки str. Например, ord(chr($n)) всегда равно $n - конечно, если $n заключено между нулем и 255.

Получено с http://spravkaweb.local/index.php/php/datafun/string/char
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 16:23, 28 января 2007.
  • К этой странице обращались 139 раз.
1.44433879852


php/datafun/string/code — Справочник Web-языков

php/datafun/string/code

 |  |  |  |  |  |  |  | Установка локали (локальных настроек)
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Строковые функции | ::. | Преобразование кодировок
 |  |  |  |  |  |  |  | Функции URL

[править] convert_cyr_string

Преобразует строку из одной кодировки кириллицы в другую.

Синтаксис:

string convert_cyr_string(string str, string from, string to);

Функция переводит строку str из кодировки from в кодировку to. Конечно, это имеет смысл только для строк, содержащих "русские" буквы, т.к. латиница во всех кодировках выглядит одинаково. Разумеется, кодировка from должна совпадать с истинной кодировкой строки, иначе результат получится неверным. Значения from и to - одиночный символ, определяющий кодировку:

  • k - koi8-r
  • w - windows-1251
  • i - iso8859-5
  • a - x-cp866
  • d - x-cp866
  • m - x-mac-cyrillic

Функция работает достаточно быстро, так что ее вполне можно применять для перекодировки писем в нужную форму перед их отправкой по электронной почте.

[править] bin2hex

Производит преобразование символьных данных в шестнадцатеричный вид.

Синтаксис:

string bin2hex(string str)

Функция bin2hex() возвращает строковое шестнадцатеричное представление символьно-байтовых данных, содержащихся в строке str.

Конвертация производиться побайтово, старший полубайт указывается первым.

Получено с http://spravkaweb.local/index.php/php/datafun/string/code
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 06:42, 25 марта 2007.
  • К этой странице обращались 72 раза.
4.9190030098


Справочник по PHP : Функции работы с данными : Строковые функции : Функции сравнения — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Строковые функции : Функции сравнения

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Поиск в тексте
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Строковые функции | ::. | Функции сравнения
 |  |  |  |  |  |  |  | Форматирование и вывод строк

Содержание

  • 1 strcmp
  • 2 strncmp
  • 3 strcasecmp
  • 4 strncasecmp
  • 5 strnatcmp
  • 6 strnatcasecmp
  • 7 similar_text
  • 8 levenshtein

[править] strcmp

Сравнивает строки.

Синтаксис:

int strcmp(string str1, string str2)

Эта функция сравнивает две строки посимвольно (точнее, бобайтово) и возвращает:

  • 0 - если строки полностью совпадают;
  • -1 - если строка str1 лексикографически меньше str2;
  • 1 - если, наоборот, str1 "больше" str2.

Так как сравнение идет побайтово, то регистр символов влияет на результаты сравнений.

[править] strncmp

Сравнивает начала строк.

Синтаксис:

int strncmp(string str1, string str2, int len)

Эта функция отличается от strcmp() тем, что сравнивает не все слово целиком, а первые len байтов. В случае, если len меньше длины наименьшей из строк, то строки сравниваются целиком.

Эта функция сравнивает две строки посимвольно (точнее, бобайтово) и возвращает:

  • 0 - если строки полностью совпадают;
  • -1 - если строка str1 лексикографически меньше str2;
  • 1 - если, наоборот, str1 "больше" str2.

Так как сравнение идет побайтово, то регистр символов влияет на результаты сравнений.

[править] strcasecmp

Сравнивает строки без учета регистра.

Синтаксис:

int strcasecmp(string str1, string str2)

То же самое, что и strcmp(), только при работе не учитывается регистр букв.

$str1 = "Привет!";
$str2 = "привет!";
if(!strcesecmp($str1, $str2))
  echo "$str1 == $str2 при сравнении строк без учета регистра";

[править] strncasecmp

Сравнивает начала строк без учета регистра.

Синтаксис:

int strncasecmp(string str1, string str2, int len)

Функция strncasecmp() является комбинацией функций strcasecmp() и strncmp().

[править] strnatcmp

Производит "естественное" сравнение строк.

Синтаксис:

int strnatcmp(string str1, string str2)

Данная функция имитирует сравнение строк, которое использовал бы человек.

$arr1 = $arr2 = array("img12.png", "img10.png", "img2.png", "img1.png");
echo "Обычная сортировкаn";
usort($arr1, "strcmp");
print_r($arr1);
echo "nЕстенственная сортировкаn";
usort($arr2, "strnatcmp");
print_r($arr2);

Данный скприпт выведет следующее:

Обычная сортировка
Array
(
    [0] => img1.png
    [1] => img10.png
    [2] => img12.png
    [3] => img2.png
)

Естественная сортировка
Array
(
    [0] => img1.png
    [1] => img2.png
    [2] => img10.png
    [3] => img12.png
)

[править] strnatcasecmp

Производит "естественное" сравнение строк без учета регистра.

Синтаксис:

int strnatcasecmp(string str1, string str2)

То же, что и strnatcmp(), только игнорирует регистр.

[править] similar_text

Производит определение схожести двух строк.

Синтаксис:

int similar_text(string firsrt, string second [, double percent])

Функция similar_text() вычисляет схожесть двух строк по алгоритму, описанному Оливером (Oliver [1993]). Но вместо стека (как в псевдокоде Оливера) она использует рекурсивные вызовы.

Сложность алгоритма делает функцию медленной, и ее скорость пропорциональна (N^3), где N - длина наибольшей строки.

Функция возвращает число символов, совпавших в обеих строках. При передаче по ссылке третьего необязательного параметра в нем сохраняется процент совпадения строк.

[править] levenshtein

Определение различия Левенштейна двух строк.

Синтаксис:

int levenshtein(string str1, string str2)
int levenshtein(string str1, string str2, int cost_ins, int cost_rep, int cost_del)
int levenshtein(string str1, string str2, function cost)

"Различие Левенштейна" - это минимальное чило символов, которое требовалось бы заменить, вставить или удалить для того, чтобы превратить строку str1 в str2. Сложность алгоритма пропорциональна произведению длин строк str1 и str2, что делает функцию более быстродействующей, чем similar_text().

Первая форма функции возвращает число необходимых операций над символами строк для трансформации str1 в str2.

Вторая форма имеет три дополнительных параметра: стоимость операции вставки, замены и удаления, что делает ее более адаптированной для вычисления, но при этом менее быстродействующей. Возвращается интегральный показатель сложности трансформации.

Третий вариант позволяет указать функцию, используемую для расчета сложности трансформации.

Функция cost вызывается со следующими аргументами:

  • применяемая операция (вставить, изменить, удалить): "I*quot;, "R", "D";
  • фактический символ первой строки
  • фактический символ второй строки
  • позиция строки 1
  • позиция строки 2
  • оставшаяся длина строки 1
  • оставшаяся длина строки 2

Вызываемая функция должна будет возвратить стоимость этой операции.

Если длина одной из строк более 255 символов, функция levenshtein() возвращает -1, но такая длина более чем достаточна.

Получено с http://spravkaweb.local/index.php/php/datafun/string/comparison
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 17:46, 28 января 2007.
  • К этой странице обращались 99 раз.
1.2620511055


Справочник по PHP : Функции работы с данными : Строковые функции : Составление/разбиение строк — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Строковые функции : Составление/разбиение строк

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Форматирование и вывод строк
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Строковые функции | ::. | Составление/разбиение строк
 |  |  |  |  |  |  |  | Работа с блоками текста

Содержание

  • 1 substr
  • 2 str_repeat
  • 3 str_pad
  • 4 chunk_split
  • 5 strtok
  • 6 explode
  • 7 implode
  • 8 join

[править] substr

Возвращает участок строки с определенной длиной.

Синтаксис:

string substr(string str, int start [,int length])

Возвращает участок строки str, начиная с позиции start и длиной length. Если length не задана, то подразумевается подстрока от start до конца строки str. Если start больше, чем длина строки, или же значение length равно нулю, то возвращается пустая подстрока.

Однако эта функция может делать и еще довольно полезные вещи. К примеру, если мы передадим в start отрицательное число, то будет считаться, что это число является индексом подстроки, но только отсчитываемым от конца str (например, -1 означает "начинается с последнего символа строки").

Параметр length, если он задан, тоже может быть отрицательным. В этом случае последним символом возвращаемой подстроки будет символ из str с индексом length, определяемым от конца строки.

$str = substr("abcdef", 1);     // возвратит "bcdef"
$str = substr("abcdef", 1, 3);  // возвратит "bcd"
$str = substr("abcdef", -1);    // возвратит "f"
$str = substr("abcdef", -2);    // возвратит "ef"
$str = substr("abcdef", -3, 1); // возвратит "d"
$str = substr("abcdef", 1, -1); // возвратит "bcde"

[править] str_repeat

Повторяет строку определенное количество раз.

Синтаксис:

string str_repeat(string str, int number)

Функция "повторяет" строку str number раз и возвращает объединенный результат.

echo str_repeat("test!",3); // выводит test!test!test!

[править] str_pad

Дополняет строку другой строкой до определенной длины.

Синтаксис:

string str_pad(string input, int pad_length [, string pad_string [, int pad_type]])

Аргумент input задает исходную строку. Аргумент pad_length задает длину возвращаемой строки. Если он имеет значение меньше, чем исходная строка, то никакого добавления не производится.

При помощи необязательного аргумента pad_string можно указать, какую строку использовать в качестве заполнителя (по умолчанию - пробелы).

При помощи необязательного аргумента pad_type можно указать, с какой стороны следует дополнять строку: справо, слево или с обеих сторон.

Этот аргумент может принимать следующие значения:

  • STR_PAD_RIGHT (по умолчанию)
  • STR_PAD_LEFT
  • STR_PAD_BOTH
$str = "Aaaaa";
echo str_pad($str, 10);
// возвратит "Aaaaa"
echo str_pad($str, 10, "-=", STR_PAD_LEFT);
// возвратит "-=-=-Aaaaa"
echo str_pad($str, 10, "_", STR_PAD_BOTH)
// возвратит "_Aaaa_"

[править] chunk_split

Возвращает фрагмент строки.

Синтаксис:

string chunk_split(string str [, int chunklen [, string end]])

Функция chunk_split() возвращает строку, в которой между каждым блоком строки str длиной chunklen (по умолчанию 76) вставляется последовательность разделителей end (по умолчанию: "rn").

Данная функция может быть полезна при конвертировании в формат "base64" для соответствия правилам RFC 2045.

// отформатируем $data, используя семантику RFC 2045
$str = chunk_split(base64_encode($data));

Эта функция работает значительно быстрее, чем ereg_replace().

[править] strtok

Возвращает строку по частям.

Синтаксис:

string strtok(string arg1, string arg2)

Функция возвращает часть строки arg1 до разделителя arg2. При последующих вызовах возвращается следующая часть до следующего разделителя, и так до конца строки. При первом вызове функция принимает два аргумента: исходную строку arg1 и разделитель arg2. При каждом последующем вызове аргумент arg1 указывать не надо, иначе будет возвращаться первая часть строки. Когда возвращать больше нечего, функция вернет false. Если часть строки состоит из 0 или из пустой строки, то функция также вернет false.

$str="This is an example№string№ Aaa";
$tok = strtok($str, " ");
while($tok) {
  echo "$tok";
  $tok = strtok(" №");
};
// выведет: "This" "is" "an" "example" "string"

Надо заметить, что в качестве разделителей указывается последовательность символов, каждый из которых в отдельности может являться разделителем, но когда в строке последовательно встречаются два или более разделителей, функция возвращает пустую строку (что может прекратить цикл обработки, как в примере).

[править] explode

Производит разделение строки в массив.

Синтаксис:

array explode(string seperator, string str [, int limit])

Функция explode() возвращает массив строк, каждая из которых соответствует фрагменту исходной строки str, находящемуся между разделителями, указанными аргументом separator.

Необязательный параметр limit указывает максимальное количество элементов в массиве. Оставшаяся неразделенная часть будет содержаться в последнем элементе.

$str = "Path1 Path2 Path3  Path4";
$str_exp = explode(" ", $str);
// теперь $str_exp = array([0] => Path1, [1] => Path2,
//        [2] => Path3, [3] => '', [4] => Path4)

[править] implode

Производит объединение массива в строку.

Синтаксис:

string implode(string glue, array pieces)

Функция implode() возвращает строку, которая содержит последовательно все элементы массива, заданного в параметре pieces, между которыми вставляется значение, указанное в параметре glue.

$str = implode(":", $arr);

[править] join

Производит объединение массива в строку.

Синтаксис:

string join(string glue, array pieces)

То же, что и implode().

Получено с http://spravkaweb.local/index.php/php/datafun/string/composition
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 18:01, 28 января 2007.
  • К этой странице обращались 118 раз.
9.29294610023


Справочник по PHP : Функции работы с данными : Строковые функции : Установка локали (локальных настроек) — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Строковые функции : Установка локали (локальных настроек)

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Функции изменения регистра
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Строковые функции | ::. | Установка локали (локальных настроек)
 |  |  |  |  |  |  |  | Преобразование кодировок

[править] setlocale

Установка региональных настроек.

Синтаксис:

string SetLocale(string category, string locale);

Функция setlocale устанавливает текущую локаль, с которой будут работать функции преобразования регистра символов, вывода даты-времени и т.д. Вообще говоря, для каждой категории функций локаль определяется отдельно и выглядит по-разному. То, какую именно категорию функций затронет вызов setlocale(), задается в параметре category. Он может принимать следующие строковые значения:

  • LC_CTYPE - активизирует указанную локаль для функций перевода в верхний/нижний регистры;
  • LC_NUMERIC - активизирует локаль для функций форматирования дробных чисел - а именно, задает разделитель целой и дробной части в числах;
  • LC_TIME - задает формат вывода даты и времени по умолчанию;
  • LC_ALL - устанавливает все вышеперечисленные режимы.

Теперь поговорим о параметре locale. Как известно, каждая локаль, установленная в системе, имеет свое уникальное имя, по которому к ней можно обратиться. Именно оно и фиксируется в этом параметре. Однако, есть два важных исключения из этого правила. Во-первых, если величина locale равна пустой строке "", то устанавливается та локаль, которая указана в глобальной переменной окружения с именем, совпадающем с именем категории category (или LANG - она практически всегда присутствует в Unix). Во-вторых, если в этом параметре передается 0, то новая локаль не устанавливается, а просто возвращается имя текущей локали для указанного режима.

setlocale("LC_CTYPE","ru_SU.KOI*-R");
// Здесь вызов устанавливает таблицу замены
// регистра букв в соответствии с кодировкой KOI8-R.
Получено с http://spravkaweb.local/index.php/php/datafun/string/local
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 16:39, 1 февраля 2007.
  • К этой странице обращались 67 раз.
7.61875104904


Справочник по PHP : Функции работы с данными : Строковые функции : Функции отрезания пробелов — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Строковые функции : Функции отрезания пробелов

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Функции для работы с одиночными символами
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Строковые функции | ::. | Функции отрезания пробелов
 |  |  |  |  |  |  |  | Поиск в тексте

[править] trim

Удаляет из заданной строки начальные и конечные пробельные символы.

Синтаксис:

string trim(string str)

Возвращает копию str, только с удаленными ведущими и концевыми пробельными символами. Под пробельными символами надо понимать и пробел.

Например, вызов trim(" testn ") вернет строку "test".

Получено с http://spravkaweb.local/index.php/php/datafun/string/obrez
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 16:26, 28 января 2007.
  • К этой странице обращались 82 раза.
1.44566011429


Справочник по PHP : Функции работы с данными : Строковые функции : Форматирование и вывод строк — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Строковые функции : Форматирование и вывод строк

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Функции сравнения
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Строковые функции | ::. | Форматирование и вывод строк
 |  |  |  |  |  |  |  | Составление/разбиение строк

Содержание

  • 1 print
  • 2 echo
  • 3 printf
  • 4 sprintf
  • 5 sscanf

[править] print

Выводит строку, значение переменной или выражение.

Синтаксис:

print(string arg)

Функция print() выводит аргумент arg, в качестве которого может быть переменная или выражение.

[править] echo

Производит вывод одного или нескольких значений.

Синтаксис:

echo(string arg1, string [argn]...)

Функция echo() выводит значения перечисленных параметров.

echo() - фактически языковая конструкция, поэтому для нее не обязательны скобки, даже если используется несколько аргументов.

echo "Перенос на следующую строку,
имеющийся в коде, сохраняется
и используется при выводе".
"чтобы избежать этого используйте".
"оператор конкатенации";

[править] printf

Вывод отформатированной строки.

Синтаксис:

int printf(string format [, mixed args, ...]);

Делает то же самое, что и sprintf(), только результирующая строка не возвращается, а направляется в браузер пользователя.

[править] sprintf

Производит форматирование строки с подстановкой переменных.

Синтаксис:

sprintf($format [,args, ...])

Эта функция возвращает строку, составленную на основе строки форматирования, содержащей некоторые специальные символы, которые будут впоследствии заменены на значения соответствующих переменных из списка аргументов.

Строка форматирования $format может включать в себя команды форматирования, предваренные символом %. Все остальные символы копируются в выходную строку как есть. Каждый спецификатор формата (то есть, символ % и следующие за ним команды) соответствуют одному, и только одному параметру, указанному после параметра $format. Если же нужно поместить в текст % как обычный символ, необходимо его удвоить:

echo sprintf("The percentage was %d%%",$percentage);

Каждый спецификатор формата включает максимум пять элементов (в порядке их следования после символа %):

  • Необязательный спецификатор размера поля, который указывает, сколько символов будет отведено под выводимую величину. В качестве символов-заполнителей (если значение имеет меньший размер, чем размер поля для его вывода) может использоваться пробел или 0, по умолчанию подставляется пробел. Можно задать любой другой символ-наполнитель, если указать его в строке форматирования, предварив фпострофом.
  • Опциональный спецификатор выравнивания, определяющий, будет результат выровнен по правому или по левому краю поля. По умолчанию производится выравнивание по правому краю, однако можно указать и левое выравнивание, задав символ - (минус).
  • Необязательное число, определяющее размер поля для вывода величины. Если результат не будет в поле помещаться, то он "вылезет" за края этого поля, но не будет усечен.
  • Необязательное число, которое предварено точкой ".", предписывающее, сколько знаков после запятой будет в результирующей строке. Этот спецификатор учитывается только в том случае, если происходит вывод числа с плавающей точкой, в противном случае он игнорируется.
  • Наконец, обязательный (заметьте - единственный обязательный!) спецификатор типа величины, которая будет помещена в выходную строку:
    • b - очередной аргумент из списка выводится как двоичное целое число
    • c - выводится символ с указанным в аргументе кодом
    • d - целое число
    • f - число с плавающей точкой
    • o - восьмеричное целое число
    • s - строка символов
    • x - шестнадцатиричное целое число с маленькими буквами a-z
    • X - шестнадцатиричное целое число с большими буквами A-Z

Вот как можно указать точность представления чисел с плавающей точкой:

$money1 = 68.75;
$money2 = 54.35;
$money = $money1 + $money2;
// echo $money выведет "123.1"...
$formatted = sprintf ("%01.2f", $money);
// echo $formatted выведет "123.10"!

Вот пример вывода целого числа, предваренного нужным количеством нулей:

$isodate=sprintf("%04d-%02d-%02d",$year,$month,$day);

[править] sscanf

Производит интерпретацию строки согласно формату и занесение значений в переменные.

Синтаксис:

mixed sscanf(string str, string format [, string var1 ...])

Функция sscanf() является противоположностью функции printf(). Она интерпретирует строку str согласно формату format, аналогично спецификации printf(). При указании только двух аргументов полученные значения возвращаются в массиве.

// получение серийного номера
$serial = sscanf("SN/235-0001", "SN/%3d-%4d");
echo $serial[0]*10000+$serial[1]; // выводит: 2350001
// и даты изготовления
$date = "January 01 2000";
list($month, $day, $year) = sscanf($date, "%s %d %d");
echo "Дата: $year-".substr($month,0,3)."-$dayn";
// выводит: 2000-Jan-01

При указании дополнительных необязательных параметров (их следует передавать по ссылке) функция возвращает их число. Те переменные, которые не получают значений, в возвращаемом значении не учитываются.

// генерируем XML запись из строки
$auth = "765tLewis Carroll";
$n = sscan($auth,"%dt%s %s", &$id, &$first, &$last);
echo "<author id="$id">
  <firstname>$first</firrstname>
  <surname>$last</surname>
</author>n";
Получено с http://spravkaweb.local/index.php/php/datafun/string/printformat
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 17:52, 28 января 2007.
  • К этой странице обращались 121 раз.
8.10999178886


Справочник по PHP : Функции работы с данными : Строковые функции : Функции изменения регистра — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Строковые функции : Функции изменения регистра

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Функции для преобразования символов
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Строковые функции | ::. | Функции изменения регистра
 |  |  |  |  |  |  |  | Установка локали (локальных настроек)

Содержание

  • 1 strtolower
  • 2 strtoupper
  • 3 ucfirst
  • 4 ucwords

[править] strtolower

Производит преобразование символов строки в нижний регистр.

Синтаксис:

string strtolower(string str);

Преобразует строку в нижний регистр. Возвращает результат перевода.

Надо заметить, что при неправильной настройке локали функция будет выдавать, мягко говоря, странные результаты при работе с буквами кириллицы.

$str = "HeLLo World";
$str = strtolower($str);
echo $str;
// выведет hello world

[править] strtoupper

Производит преобразование заданной строки в верхний регистр.

Синтаксис:

string strtoupper(string str);

Переводит строку в верхний регистр. Возвращает результат преобразования. Эта функция хорошо работает с английскими буквами, но с русскими может чудить.

$str = "Hello World";
$str = strtoupper($str);
echo $str;
// выведет HELLO WORLD

[править] ucfirst

Производит преобразование первого символа строки в верхний регистр.

Синтаксис:

string ucfirst(string str);

Возвращает строку, у которой первый символ заглавный.

Символы кириллицы могут быть неправильно конвертированы.

$str = "hello world";
$str = ucfirst($str);
echo $str;
// выведет Hello world

[править] ucwords

Производит преобразование первого символа каждого слова строки в верхний регистр.

Синтаксис:

string ucwords(string str);

Возвращает строку, у которой первый символ каждого слова в строке заглавный.

Под словом здесь понимается участок строки, которому предшествует пробельный символ: пробел, переход на новую строку, прогонка страницы, возврат каретки, горизонтальная и вертикальная табуляция.

Символы кириллицы могут быть неправильно конвертированы.

$str = "hello world";
$str = ucfirst($str);
echo $str;
// выведет Hello World
Получено с http://spravkaweb.local/index.php/php/datafun/string/register
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 16:37, 1 февраля 2007.
  • К этой странице обращались 75 раз.
5.98000192642


Справочник по PHP : Функции работы с данными : Строковые функции : Поиск в тексте — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Строковые функции : Поиск в тексте

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Функции отрезания пробелов
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Строковые функции | ::. | Поиск в тексте
 |  |  |  |  |  |  |  | Функции сравнения

Содержание

  • 1 strchr
  • 2 strstr
  • 3 stristr
  • 4 strrchr
  • 5 strpos
  • 6 strrpos
  • 7 substr_count
  • 8 strspn
  • 9 strcspn

[править] strchr

Поиск первого вхождения символа в строку.

Синтаксис:

string strchr(string haystack, string needle)

Данная функция работает идентично функции strstr().

[править] strstr

Поиск первого вхождения подстроки в строку.

Синтаксис:

string strstr(string haystack, string needle)

Функция strstr() возвращает участок строки, заданной в параметре haystack, начиная с первого фрагмента, указанного в параметре needle и до конца.

В случае неудачи возвращает false.

Данная функция чувствительна к регистру.

В случае, если needle не является строкой, то значение преобразуется в целое и используется как код искомого символа.

$email = "mailname@mail.ru";
$domain = strstr($email, "@");
// или
$domain = strstr($email, ord("@"))
echo $domain;
// выведет @mail.ru

[править] stristr

Нахождение первого вхождения подстроки, не учитывая регистр.

Синтаксис:

string stristr(string haystack, string needle)

Функция stristr() возвращает участок строки, заданной в параметре haystack, начиная с первого фрагмента, указанного в параметре needle и до конца.

В случае неудачи возвращает false.

Данная функция нечувствительна к регистру.

В случае, если needle не является строкой, то значение преобразуется в целое и используется как код искомого символа.

[править] strrchr

Поиск последнего вхождения подстроки.

Синтаксис:

string strrchr(string haystack, string needle)

Функция strrchr() возвращает участок строки, заданной в параметре haystack, начиная с последнего фрагмента, указанного в параметре needle и до конца.

В случае неудачи возвращает false.

Данная функция чувствительна к регистру.

В случае, если needle не является строкой, то значение преобразуется в целое и используется как код искомого символа.

// получим последний каталог в $PATH
$dir = substr(strrchr($PATH, ":"), 1);
// а здесь получим все после последнего перевода строки
$text = "text 1nText2nText3";
echo substr(strrchr($text, 10), 1);

[править] strpos

Находит позицию первого вхождения подстроки в заданной строке.

Синтаксис:

int strpos(string where, string what [, int fromwhere])

Функция strpos() пытается найти в строке were подстроку what и в случае успеха возвращает позицию (индекс) этой подстроки в строке. Первый символ строки имеет индекс 0. Необязательный параметр fromwhere можно задавать, если поиск нужно вести не с начало строки, а с какой-то другой позиции. В этом случае следует эту позицию передать в fromwhere. Если подстроку не удалось найти, функция возвращает false.

Если параметр what не строка, в этом случае его значение преобразуется в целое и используется как код искомого символа.

if(strpos($text, "a")===false) echo "Не найдено!";
// Проверка: три знака равенства

[править] strrpos

Находит в заданной строке последнюю позицию, в которой находится заданный фрагмент.

Синтаксис:

int strrpos(string where, string what)

Данная функция ищет в строке where последнюю позицию, в которой встречался символ what (если what - строка из нескольких символов, то выявляется только первый из них, остальные не играют никакой роли).

Если искомый символ стоит первый в строке или его вообще нет, функция возвратит 0.

В случае, если искомый символ не найден, возвращает false.

[править] substr_count

Находит количество вхождений фрагмента в строку.

Синтаксис:

int substr_count(string where, string what)

Функция substr_count() возвращает число фрагментов what, присутствующих в строке where.

echo substr_count("www.spravkaweb.ru", ".");
// Выведет 3

[править] strspn

Определяет присутствие начальных символов в строке.

Синтаксис:

int strspn(string str1, string str2)

Функция strspn() возвращает длину начального фрагмента строки str1, состоящего полностью из символов, которые есть в строке str2.

echo strspn("www.spravkaweb.ru", "abc");
// Выведет 3

[править] strcspn

Определяет отсутствие начальных символов в строке.

Синтаксис:

int strcspn(string str1, string str2)

Функция strspn() возвращает длину начального фрагмента строки str1, состоящего полностью не из символов, которые есть в строке str2.

Получено с http://spravkaweb.local/index.php/php/datafun/string/search
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 17:11, 28 января 2007.
  • К этой странице обращались 137 раз.
1.33758401871


Справочник по PHP : Функции работы с данными : Строковые функции : Функции для преобразования символов — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Строковые функции : Функции для преобразования символов

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Работа с блоками текста
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Строковые функции | ::. | Функции для преобразования символов
 |  |  |  |  |  |  |  | Функции изменения регистра

Содержание

  • 1 nl2br
  • 2 strip_tags
  • 3 get_meta_tags
  • 4 get_html_translation_table
  • 5 htmlspecialchars
  • 6 htmlentities
  • 7 hebrev
  • 8 hebrevc
  • 9 quoted_printable_decode

[править] nl2br

Заменяет символы перевода строки.

Синтаксис:

string nl2br(string string)

Заменяет в строке все символы новой строки \n на <br>\n и возвращает результат. Исходная строка не изменяется. Обратите внимание на то, что символы \r, которые присутствуют в конце строки текстовых файлов Windows, этой функцией никак не учитываются, а потому остаются на старом месте.

[править] strip_tags

Удаляет из строки теги.

Синтаксис:

string strip_tags(string str [, string allowable_tags])

Эта функция удаляет из строки все HTML- и PHP-теги и возвращает результат.

Незавершенные или фиктивные теги вызывают ошибку.

В параметре allowable_tags можно передать теги, которые не следует удалять из строки. Они должны перечисляться вплотную друг к другу.

$st="
&lt;b&gt;Жирный текст&lt;/b&gt;
&lt;tt&gt;Моноширный текст&lt;/tt&gt;
&lt;a href=http://spravkaweb.ru&gt;Ссылка&lt;/a&gt;";
echo "Исходный текст: $st";
echo "&lt;hr&gt;После удаления тегов: ".striptags($st,"&lt;a&gt;&lt;b&gt;").
     "&lt;hr&gt;";

Запустив этот пример, мы сможем заметить, что теги <a> и <b> не были удалены (ровно как и их парные закрывающие), в то время как <tt> исчез.

[править] get_meta_tags

Функция ищет и обрабатывает все теги <META>.

Синтаксис:

array get_meta_tags(string filename, int use_include_path)

Функция открывает файл и ищет в нем все теги <META> до тех пор, пока не встретится закрывающий тег </head>.

Если очередной тег <META> имеет вид:

<meta name="название" content="содержимое">

то пара название=>содержимое добавляется в результирующий массив, который под конец и возвращается.

Спецсимволы в значении атрибута filename заменяются на знак подчеркивания "_", а алфавитные символы преобразуются в нижний регистр.

Функция удобно использовать для быстрого получения всех метатегов из указанного файла.

Если необязательный параметр use_include_path установлен, то поиск файла осуществляется не только в текущем каталоге, но и во всех тех, которые назначены для поиска инструкциями include и require.

[править] get_html_translation_table

Функция возвращает таблицу трансляции, которая используется функциями htmlspecialchars() и htmlentities().

Синтаксис:

string get_html_translation_table(int table [, int quote_style])

В этой функции аргумент table указывает, какую таблицу трансляции необходимо получить: HTML_SPECIALCHARS для функции htmlspecialchars() или HTML_ENTITIES для функции htmlentities(). Описание необязательного параметра quote_style приведено в функции htmlspecialchars().

$trans = get_html_translation_table(HTML_ENTITIES);
$str = "&lt;A & B&gt;";
$encoded = strtr($str, $strans);
// $encoded = "&amplt; A &amp; B &gt;"

Иногда удобно использовать функцию array_flip() для изменения направления транслитерации.

$trans = array_flip($trans);
$original = strtr($encoded, $trans);

[править] htmlspecialchars

Производит преобразование спецсимволов в HTML-представление.

Синтаксис:

string HtmlSpecialChars(string str [, int quote_style]);

Основное назначение этой функции - гарантировать, что в выводимой строке ни один участок не будет воспринят как тэг.

Заменяет в строке некоторые символы (такие как амперсанд, кавычки и знаки "больше" и "меньше") на их HTML-эквиваленты,так, чтобы они выглядели на странице "самими собой". Самое типичное применение этой функции - формирование параметра value в различных элементах формы, чтобы не было никаких проблем с кавычками, или же вывод сообщения в гостевой книге, если вставлять теги пользователю запрещено.

При помощи необязательного атрибута quote_style можно указать, что делать с кавычками:

  • ENT_COMPAT (по умолчанию) - разрешить трансляцию только двойных кавычек
  • ENT_QUOTES - разрешить трансляцию любых кавычек
  • ENT_NOQUOTES - запретить трансляцию любых кавычек
$str = htmlspecialchars("&lt;a href=index.php&gt;Главная&lt;/a&gt;", ENT_QUOTES);

[править] htmlentities

Производит конвертацию символов, имеющих HTML-представление.

Синтаксис:

string htmlentities(string str [, int quote_style]);

Эта функция похожа на htmlspecialchars(), но только в ней производиться не выборочная трансляция, а полная - для всех символов, которые могут иметь эквивалентные HTML-представления.

При помощи необязательного атрибута quote_style можно указать, что делать с кавычками:

  • ENT_COMPAT (по умолчанию) - разрешить трансляцию только двойных кавычек
  • ENT_QUOTES - разрешить трансляцию любых кавычек
  • ENT_NOQUOTES - запретить трансляцию любых кавычек

[править] hebrev

Конвертация логического текста Hebrew в отображаемый.

Синтаксис:

string hebrev(string hebrew_text [, int max_chars_per_line]);

Необязательный аргумент max_chars_per_line указывает число символов на строку вывода. Функция пытается избежать разрыва слова.

[править] hebrevc

Аналог функции hebrev() с расстановкой переносов.

Синтаксис:

string hebrevc(string hebrew_text [, int max_chars_per_line]);

Функция hebrevc() сходна с hebrev() с тем отличием, что она преобразует символы перевода строк "n" в "<br>n".

Необязательный аргумент max_chars_per_line указывает число символов на строку вывода. Функция пытается избежать разрыва слов.

[править] quoted_printable_decode

Преобразование цитированной строки в 8-битную.

Синтаксис:

string quoted_printable_decode(string str);
Получено с http://spravkaweb.local/index.php/php/datafun/string/transformation
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 16:29, 1 февраля 2007.
  • К этой странице обращались 110 раз.
9.50250983238


Справочник по PHP : Функции работы с данными : Строковые функции : Функции URL — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Строковые функции : Функции URL

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Преобразование кодировок
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Строковые функции | ::. | Функции URL
 |  |  |  |  |  |  |  | Работа с бинарными данными

Содержание

  • 1 parse_url
  • 2 parse_str
  • 3 urlencode
  • 4 urldecode
  • 5 rawurlencode
  • 6 rawurldecode
  • 7 base64_encode
  • 8 base64_decode

[править] parse_url

Обрабатывает URL и возвращает его компоненты.

Синтаксис:

array parse_url(string url);

Эта функция возвращает ассоциативный массив, включающий множество различных существующих компонентов URL. Они включают "scheme", "host", "port", "user", "pass", "path", "query" и "fragment".

[править] parse_str

Заносит строки URL в переменные.

Синтаксис:

void parse_str(string str [, array arr]);

Функция parse_str() интерпретирует строку str, как если бы эта строка содержала в себе переменные и их значения и передавалась бы в URL. Наша функция устанавливает для этих переменных значения.

Если задан второй необязательный параметр, то значения, найденные при помощи функции parse_str(), сохраняться не в глобальных переменных, а в элементах указанного массива.

$str = "name[]=Vasia&name[]=Pupkin&id=12645&mail=vasia@mail.ru&url=www.vasia.ru";
parse_str($str);
parse_str($str, $arr);
echo $id;        // выведет 1264
echo $name[0];   // выведет Vasia
echo $name[1];   // выведет Pupkin
print_r($arr);

выведет

Array
(
    [name] => Array
        (
            [0] => Vasia
            [1] => Pupkin
        )

    [id] => 12645
    [mail] => vasia@mail.ru
    [url] => www.vasia.ru
)

[править] urlencode

Кодирование строки в URL

Синтаксис:

string urlencode (string str)

Возвращает строку, в которой все не алфавитно-цифровые символы (за исключением дефиса "-" и знака подчеркивания "_" и точки ".") заменены последовательностями: знак процента (%), за которым следуют две шестнадцатеричные цифры (обозначающие код символа), а символ пробела заменен на знак "+". Именно таким образом кодируются все данные, посылаемые HTML-формами. Медиа-тип этого кодирования обозначается как application/x-www-form-urlencoded; он отличается от стандарта кодирования RFC 1738 (rawurlencode()) тем, что по историческим причинам пробелы заменяются на знак плюс. Эта функция удобна при кодировании строки для использования в строке запроса, являющейся частью URL, и при передаче переменных на следующую страницу:

<?php
echo '<a href="mycgi?foo=', urlencode($userinput), '">';
?>
<?php
$query_string = 'foo=' . urlencode($foo) . '&bar=' . urlencode($bar);
echo '<a href="mycgi?' . htmlentities($query_string) . '">';
?>

[править] urldecode

Декодирование строки из URL

Синтаксис:

string urldecode (string str)

Декодирует в строке последовательности %## (так в URL кодируются спецсимволы).

<?php
$a = explode('&', $QUERY_STRING);
$i = 0;
while ($i < count($a)) {
    $b = split('=', $a[$i]);
    echo 'Value for parameter ', htmlspecialchars(urldecode($b[0])),
         ' is ', htmlspecialchars(urldecode($b[1])), "<br />\n";
    $i++;
}
?>

[править] rawurlencode

Кодирование URL.

Синтаксис:

string RawUrlEncode(string str);

Функция RawUrlEncode() возвращает строку, в которой все не алфавитно-цифровые символы (за исключением дефиса "-", знака подчеркивания "_" и точки ".") заменены последовательностями: знак процента (%), за которым следуют две шестнадцатеричные цифры, которые обозначают код символа. Это кодирование нужно для того, чтобы буквенные символы не обрабатывались в качестве разделителей строки URL и не искажались при передаче в сетях.

echo "<A href=ftp://user:".rawurlencode($mypasswd).
      "@ftp.my.com/x.txt>"; // передача пароля в гиперссылке

[править] rawurldecode

Производит декодирование URL.

Синтаксис:

string rawurldecode(string str);

Эта функция возвращает строку, в которой последовательности с знаком процента (%) и следующими за ним двумя шестнадцатеричных числа преобразует в символы, соответствующими этому коду. Аналогична urldecode(), но не воспринимает + как пробел.

$str="foo%20bar%40baz";
echo rawurldecode($str);
// выведет foo bar@baz

[править] base64_encode

Кодирует данные в кодировке MIME base64.

Синтаксис:

string base64_encode(string data);

base64_encode() возвращает data закодированные в кодировке base64. Эта кодировка разработана для того, чтобы передавать двоичные данные через транспортные слои, которые не содержат восьмой бит, такие как почтовые тела. Данные в кодировке Base64 занимают примерно на 33% больше места, чем оригинал.

[править] base64_decode

Декодирует данные, закодированные в кодировке MIME base64.

Синтаксис:

string base64_decode(string encoded_data);

base64_decode() декодирует encoded_data и возвращает оригинал данных. Возвращаемые данные могут быть двоичными.

Получено с http://spravkaweb.local/index.php/php/datafun/string/url
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 06:58, 25 марта 2007.
  • К этой странице обращались 89 раз.
6.57953095436


Справочник по PHP : Функции работы с данными : Строковые функции : Строковые суммы и хеш-функции — Справочник Web-языков

Справочник по PHP : Функции работы с данными : Строковые функции : Строковые суммы и хеш-функции

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Работа с бинарными данными
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | Строковые функции | ::. | Строковые суммы и хеш-функции
 |  |  |  |  |  |  |  | XML: SimpleXML

Содержание

  • 1 strlen
  • 2 count_chars
  • 3 md5
  • 4 crc32
  • 5 crypt
  • 6 metaphone
  • 7 soundex

[править] strlen

Возвращает длину строки.

Синтаксис:

int strlen(string str)

Возвращает просто длину строки, т.е., сколько символов содержится в str.

Строка может содержать любые символы, в том числе и с нулевым кодом. Функция strlen() будет правильно работать и с такими строками.

[править] count_chars

Возвращает информацию о символах строки.

Синтаксис:

mixed count_chars(string str [, int mode])

Функция count_chars() подсчитывает частоту встречаемости каждого байта (0-255) в строке str и возвращает в массиве результат согласно необязательному аргументу mode. mode может принимать следующие значения:

  • 0 (по умолчанию)- массив с байтами в качестве индексов и частотой повторения в качестве значений элемента массива
  • 1 - похож на 0, но отсутствующие в строке str байты не возвращаются
  • 2 - похож на 0, но возвращаются только те байты, которые отсутствуют
  • 3 - возвращается строка, состоящая из всех обнаруженных символов
  • 4 - возвращается строка, состоящая из всех отсутствующих символов

[править] md5

Получение строки-хеша MD5.

Синтаксис:

string md5(string str);

Возвращает хеш-код строки str, основанный на алгоритме корпорации RSA Data Security под названием "MD5 Message-Digest Algorithm".

Хеш-код - это просто строка, практически уникальная для каждой из строк str. То есть вероятность того, что две разные строки, переданные в str, дадут нам одинаковый хеш-код, стремиться к нулю.

В то же время, если длина строки str может достигать нескольких тысяч символов, то ее MD5-код занимает максимум 32 символа.

[править] crc32

Получение полиминала строки crc32.

Синтаксис:

int crc32(string str);

Функция crc32() вычисляет 32-битную контрольную сумму строки str. То есть, результат ее работы - 32-битное (4-байтовое) целое число.

Обычно эту функцию используют для проверки целостности переданных данных.

Эта функция работает гораздо быстрее md5(), но в то же время выдает гораздо менее надежные "хеш-коды" для строки. Так что, теперь, чтобы получить методом случайного подбора для двух разных строк одинаковые "хеш-коды", вам потребуется не триллион лет работы самого мощного компьютера, а всего лишь год-другой.

[править] crypt

Производит симметричное шифрование.

Синтаксис:

string crypt(string str [,string salt]);

В аргументе str задается строка, которую надо зашифровать.

Хеш-код для одной и той же строки, но с различными значениями salt (Кстати, это должна быть обязательно двухсимвольная строка) дает разные результаты. Если параметр salt пропущен, PHP сгенерирует его случайным образом.

В системах, которые поддерживают несколько алгоритмов шифрования, следующие константы устанавливаются равными 1 или 0, в зависимости от того, поддерживается ли данный алгоритм или нет:

  • CRYPT_STD_DES - стандартное 2-байтовое DES-шифрование (SALT=2)
  • CRYPT_EXT_DES - расширенное 9-байтовое DES-шифрование (SALT=9)
  • CRYPT_MD5 - 12-байтовое MD5-шифрование (SALT начинается с $1$)
  • CRYPT_BLOWFISH - расширенное 12-байтовое DES-шифрование (SALT начинается с $2$)

Т.к. данная функция использует односторонний алгоритм шифрования, то функции дешифрования не имеется.

[править] metaphone

Производит вычисление метафон-хеша.

Синтаксис:

string metaphone(string str);

Данная функция схожа по действию с soundex(), вычисляет код произношения слова, переданного в строке str, но с повышенной точностью вычисления, т.к. использует правила произношения английского языка.

Возвращаемое строковое значение может быть переменной длины.

[править] soundex

Вычисления хеша сходности произношения.

Синтаксис:

string soundex(string str);

Функция soundex() используется для проверки правописания, когда приблизительно известно как звучит слово, но не известно, как оно пишется, и имеется словарь (база данных), относительно которого можно осуществить проверку.

Возвращается строка из 4 символов: первая буква слова и 3 цифры.

soundex("Euler") == soundex("Ellery") == "E460";
soundex("Gauss") == soundex("Ghosh") == "G200";
soundex("Hilbert") == soundex("Heilbronn") == "H416";
soundex("Knuth") == soundex("Kant") == "K530";
soundex("Lloyd") == soundex("Ladd") == "L300";
soundex("Lukasiewicz") == soundex("Lissajous") == "L222";
Получено с http://spravkaweb.local/index.php/php/datafun/string/xesh
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 17:05, 5 февраля 2007.
  • К этой странице обращались 91 раз.
6.99523591995


Справочник по PHP : Функции работы с данными : XML : SimpleXML — Справочник Web-языков

Справочник по PHP : Функции работы с данными : XML : SimpleXML

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Строковые функции : Строковые суммы и хеш-функции
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | XML | ::. | SimpleXML
 |  |  |  |  |  |  |  | asXML

Содержание

  • 1 Введение
  • 2 Требования
  • 3 Установка
  • 4 Примеры
  • 5 Содержание:

[править] Введение

SimpleXML предоставляет очень простой в восприятии, интуитивно-понятный доступ к XML-документам, позволяющий совершать разнообразные операции с элементами XML-документа и их атрибутами.

[править] Требования

SimpleXML присутствует в PHP начиная с версии 5.

[править] Установка

SimpleXML установлен в PHP по умолчанию. Для того, чтобы отключить это расширение, перекомпилируйте PHP с ключом --disable-simplexml.

[править] Примеры

Практически все примеры используют XML-документ. Вместо того, чтобы каждый раз повторять содержание XML-документа в каждом примере, мы поместим XML-документ в файл, который будет читать при помощи функции simplexml_load_file().

<?php
$xmlstr = <<<XML
<?xml version='1.0' standalone='yes'?>
<movies>
 <movie>
  <title>PHP: Behind the Parser</title>
  <characters>
   <character>
    <name>Ms. Coder</name>
    <actor>Onlivia Actora</actor>
   </character>
   <character>
    <name>Mr. Coder</name>
    <actor>El Act&amp;#211;r</actor>
   </character>
  </characters>
  <plot>
   So, this language. It's like, a programming language. Or is it a
   scripting language? All is revealed in this thrilling horror spoof
   of a documentary.
  </plot>
  <rating type="thumbs">7</rating>
  <rating type="stars">5</rating>
 </movie>
</movies>
XML;
?>

Простоту работы с SimpleXML можно продемонстрировать извлечением текста из заданного элемента XML-документа.

Пример 2. Получение текста в <plot>

<?php
include 'example.php';
$xml = simplexml_load_string($xmlstr);
echo $xml-&gt;movie[0]-&gt;plot; // "So this language. It's like..."
?>

Пример 3. Работа с группой элементов в SimpleXML

Можно применять циклы для получения дочерних элементов заданного элемента (если дочерние элементы существуют).

<?php
include 'example.php';

$xml = simplexml_load_string($xmlstr);

/* Для каждого элемента &lt;movie&gt; мы отображаем элемент . */
foreach ($xml-&gt;movie as $movie) {
   echo $movie-&gt;plot, '&lt;br /&gt;';
}

?>

Пример 4. Использование атрибутов

Выше было показано как работать с элементами XML-документа и их значениями. SimpleXML также имеет доступ к атрибутам элементов. Атрибуты указанного элемента доступны как ассоциативный массив данного элемента.

<?php
include 'example.php';

$xml = simplexml_load_string($xmlstr);

/* Получение доступа к атрибутам элементов &lt;rating&gt; для первого кино.*/
foreach ($xml-&gt;movie[0]-&gt;rating as $rating) {
    switch((string) $rating['type']) { // Возвращает атрибуты как элементы массива
    case 'thumbs':
        echo $rating, ' thumbs up';
        break;
    case 'stars':
        echo $rating, ' stars';
        break;
    }
}
?>

Пример 5. Сравнение элементов и их атрибутов с текстовыми значениями

Для того, чтобы сравнивать элемент или атрибут со строковыми значениями, или передавать содержание элемента или атрибута в функцию, которая использует строковое значение передаваемого параметра, вы должны использовать элементы и атрибуты как строки с признаком (string). В противном случае PHP воспримет передаваемое значение как объект.

<?php
include 'example.php';

$xml = simplexml_load_string($xmlstr);

if ((string) $xml-&gt;movie-&gt;title == 'PHP: Behind the Parser') {
    print 'Мой любимый фильм.';
}

htmlentities((string) $xml-&gt;movie-&gt;title);
?>

Пример 6. Использование Xpath

В SimpleXML включена поддержка запросов Xpath. Поиск всех элементов :

<?php
include 'example.php';
$xml = simplexml_load_string($xmlstr);

foreach ($xml-&gt;xpath('//character') as $character) {
    echo $character-&gt;name, ' съиграл ', $character-&gt;actor, '&lt;br /&gt;';
}
?>

'//' служит групповым символом. Чтобы задать абсолютный путь, требуется убрать один слеш.

Пример 7. Задание новых значений

Данные в SimpleXML не могут быть постоянными. Объект учитывает изменения всех его элементов.

<?php
include 'example.php';
$xml = simplexml_load_string($xmlstr);

$xml-&gt;movie[0]-&gt;characters-&gt;character[0]-&gt;name = 'Miss Coder';

echo $xml-&gt;asXML();
?>

Результатом вышеуказанного примера будет новый XML-документ, идеентичный оригиналу за исключением того, что в новом XML-документе будет вместо Ms. Coder будет Miss Coder.

Пример 8. Взаимодействие с DOM

PHP имеет механизм конвертации XML-документов из формата SimpleXML в DOM и обратно. Следующий пример показывает как конвертировать DOM-элемент в SimpleXML-элемент:

<?php
$dom = new domDocument;
$dom-&gt;loadXML('&lt;books&gt;&lt;book&gt;&lt;title&gt;blah&lt;/title&gt;&lt;/book&gt;&lt;/books&gt;');
if (!$dom) {
     echo 'Ошибка преобразования документа';
     exit;
}

$s = simplexml_import_dom($dom);

echo $s-&gt;book[0]-&gt;title;
?>

[править] Содержание:

SimpleXMLElement->asXML -- Возвращает правильно сформированный XML-документ

SimpleXMLElement->attributes -- Возвращает атрибуты элемента.

SimpleXMLElement->children -- Возвращает дочерние элементы для заданного элемента

SimpleXMLElement->xpath -- Выполняет Xpath-запрос к XML-данным

simplexml_import_dom -- Возвращает объектSimpleXMLElement, созданный из DOM-объекта.

simplexml_load_file -- Интерпретирует XML-файл в объект

simplexml_load_string -- Интерпретирует строку с XML в объект

Получено с http://spravkaweb.local/index.php/php/datafun/xml/simplexml
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:53, 5 февраля 2007.
  • К этой странице обращались 128 раз.
1.6673719883


Справочник по PHP : Функции работы с данными : XML : SimpleXML : asXML — Справочник Web-языков

Справочник по PHP : Функции работы с данными : XML : SimpleXML : asXML

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  |  |  | SimpleXML
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | XML | ::. | SimpleXML | ::. | asXML
 |  |  |  |  |  |  |  |  |  | attributes

Содержание

  • 1 SimpleXMLElement->asXML
  • 2 Описание
  • 3 Список параметров
  • 4 Возвращаемые значения
  • 5 Замечания
  • 6 Примеры

[править] SimpleXMLElement->asXML

SimpleXMLElement->asXML -- Возвращает правильно сформированный XML-документ

[править] Описание

mixed SimpleXMLElement->asXML ( [string filename] )

Метод asXML формирует данные в XML версии 1.0.

[править] Список параметров

filename
Если указан, то метод запишет данные в указанный файл.

[править] Возвращаемые значения

Если имя файла задано, то метод запишет XML данные в указанный файл. В противном случае метод возвратит XML-данные в виде строки.

[править] Замечания

Если в исходном документе в заголовках была указана кодировка XML-документа при помощи параметра encoding, то метод asXML возвратит XML-документ в указанной кодировке. Изменение кодировки XML-документа при помощи расширения SIMPLEXML невозможно.

[править] Примеры

Пример 1. Вывести XML

<?php
$string = <<<XML
<a>
 <b>
  <c>text</c>
  <c>stuff</c>
 </b>
 <d>
  <c>code</c>
 </d>
</a>
XML;

$xml = simplexml_load_string($string);

echo $xml->asXML(); // <?xml ... <a><b><c>text</c><c>stuff</c> ...

?>

Метод asXML также может работать с Xpath:

Пример 2. Использование метода asXML() в работе с Xpath

<?php
// Продолжение примера, указанного выше.
/* Поиск <a><b><c> */
$result = $xml->xpath('/a/b/c');
while(list( , $node) = each($result)) {
    echo $node->asXML(); // <c>text</c> и <c>stuff</c>
}
?>
Получено с http://spravkaweb.local/index.php/php/datafun/xml/simplexml/asxml
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
������ ����������� Powered by MediaWiki
  • Последнее изменение этой страницы: 17:48, 5 февраля 2007.
  • К этой странице обращались 46 раз.
5.58131599426


Справочник по PHP : Функции работы с данными : XML : SimpleXML : attributes — Справочник Web-языков

Справочник по PHP : Функции работы с данными : XML : SimpleXML : attributes

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  |  |  | asXML
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | XML | ::. | SimpleXML | ::. | attributes
 |  |  |  |  |  |  |  |  |  | children

[править] SimpleXMLElement->attributes

SimpleXMLElement->attributes -- Возвращает атрибуты элемента.

[править] Описание

SimpleXMLElement simplexml_element->attributes ( [string data] )

Эта функция возвращает названия и значения атрибутов выбранного xml-элемента.

Замечание: SimpleXML содержит правило добавления итеративных свойств к большинству методов. Они не могут быть просмотрены с испольванием var_dump() или каких-либо других средств анализа объектов.

Пример 1. Интепретация XML-строки

<?php
$string = <<<XML
<users>
 <user name="Evgen" age="27">admin@spravkaweb.ru</user>
</users>
XML;
$xml = simplexml_load_string($string);
foreach($xml->users[0]->attributes() as $a => $b) {
    echo $a,'="',$b,"\"\n";
}
?>

Данный пример выведет:

name="Evgen"
age="27
Получено с http://spravkaweb.local/index.php/php/datafun/xml/simplexml/attributes
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
������ ����������� Powered by MediaWiki
  • Последнее изменение этой страницы: 17:52, 5 февраля 2007.
  • К этой странице обращались 48 раз.
7.21205496788


Справочник по PHP : Функции работы с данными : XML : SimpleXML : children — Справочник Web-языков

Справочник по PHP : Функции работы с данными : XML : SimpleXML : children

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  |  |  | attributes
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | XML | ::. | SimpleXML | ::. | children
 |  |  |  |  |  |  |  |  |  | xpath

[править] SimpleXMLElement->children

SimpleXMLElement->children -- Возвращает дочерние элементы для заданного элемента

[править] Описание

SimpleXMLElement simplexml_element->children ( [string nsprefix] )

Данный метод находит дочерние элементы для заданного элемента.

Замечание: SimpleXML содержит правило добавления итеративных свойств к большинству методов. Они не могут быть просмотрены с использованием var_dump() или каких-либо других средств анализа объектов.

Пример 1. Использование метода children()

<?php
$xml = simplexml_load_string(
'<sites>
     <site name="spravkaweb.ru">
          <site name="links.spravkaweb.ru" />
          <site name="forum.spravkaweb.ru" />
          <site name="server.spravkaweb.ru" />
    </site>
    <site name="yandex.ru">
        <site name="money.yandex.ru" />
        <site name="map.yandex.ru" />
        <site name="market.yandex.ru" />
    </site>
</sites>');
echo '<ul>';
foreach ($xml->children() as $site) {
    echo '<dt>' . $site['name'];
    foreach ($site->children() as $subsite) {
        echo '<dd>' . $subsite['name'];
    }
}
echo '</ul>';
?>

Данный пример выведет:

spravkaweb.ru
    links.spravkaweb.ru
    forum.spravkaweb.ru
    server.spravkaweb.ru
yandex.ru
    money.yandex.ru
    map.yandex.ru
    market.yandex.ru
Получено с http://spravkaweb.local/index.php/php/datafun/xml/simplexml/children
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
������ ����������� Powered by MediaWiki
  • Последнее изменение этой страницы: 17:59, 5 февраля 2007.
  • К этой странице обращались 53 раза.
4.92366194725


php/datafun/xml/simplexml/simplexml import dom — Справочник Web-языков

php/datafun/xml/simplexml/simplexml import dom

 |  |  |  |  |  |  |  |  |  | xpath
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | XML | ::. | SimpleXML | ::. | simplexml_import_dom
 |  |  |  |  |  |  |  |  |  | simplexml_load_file

[править] simplexml_import_dom

(PHP 5)

simplexml_import_dom -- Возвращает объект SimpleXMLElement, созданный из DOM-объекта.

[править] Описание

SimpleXMLElement simplexml_import_dom ( DOMNode node [, string class_name] )

Данная функция берет объект DOM и создает на его основе объект SimpleXML. Этот новый объект может быть использован как нормальный объект SimpleXML. Если во время создания объекта произошли ошибки, метод вернет false.

Пример 1. Import DOM

<?php
$dom = new domDocument;
$dom->loadXML('<sites><site><url>spravkaweb.ru</url></site></sites>');
if (!$dom) {
    echo 'Ошибка парсинга документа!';
    exit;
}
$s = simplexml_import_dom($dom);
echo $s->site[0]->url; // spravkaweb.ru
?>
Получено с http://spravkaweb.local/index.php/php/datafun/xml/simplexml/simplexml_import_dom
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
������ ����������� Powered by MediaWiki
  • Последнее изменение этой страницы: 19:41, 5 февраля 2007.
  • К этой странице обращались 51 раз.
4.66147279739


php/datafun/xml/simplexml/simplexml load file — Справочник Web-языков

php/datafun/xml/simplexml/simplexml load file

 |  |  |  |  |  |  |  |  |  | simplexml_import_dom
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | XML | ::. | SimpleXML | ::. | simplexml_load_file
 |  |  |  |  |  |  |  |  |  | simplexml_load_string

[править] simplexml_load_file

(PHP 5)

simplexml_load_file -- Интерпретирует XML-файл в объект

[править] Описание

object simplexml_load_file ( string filename [, string class_name [, int options]] )

Эта функция интерпретирует файл filename с правильно сформированными XML-данными в объект SimpleXMLElement. Если в XML-данных имеются ошибки, функция возвратит FALSE.

Вы можете использовать необязательный параметр class_name в функции simplexml_load_file() для того, чтобы функция вернула объект указанного класса. При этом класс должен быть расширением класса SimpleXMLElement.

Начиная с PHP 5.1.0 и Libxml 2.6.0 вы можете использовать необязательный параметр options, спецификация которого описана в additional Libxml parameters.

Замечание: Libxml 2 преобразовывает URL к правильному виду. Т.е. если вы хотите присвоить переменной а значение b&c в URL-строке, вам не обязательно делать: simplexml_load_file(rawurlencode('http://example.com/?a=' . urlencode('b&c'))). Начиная с PHP 5.1.0 это делается в автоматическом режиме.

Пример 1. Интерпретация XML документа

<?php
// Файл test.xml содержит XML документ с корневым элементом
// и вложенным элементом title /[root]/title.
if (file_exists('test.xml')) {
    $xml = simplexml_load_file('test.xml');

    var_dump($xml);
} else {
    exit('Ошибка открытия test.xml.');
}
?>

Этот пример выведет следующее:

SimpleXMLElement Object
(
  [title] => Тестовый заголовок
  ...
)

В данном примере вы можете обратиться к элементу title следующим образом: $xml->title.

[править] Смотрите также:

simplexml_load_string()

Получено с http://spravkaweb.local/index.php/php/datafun/xml/simplexml/simplexml_load_file
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
������ ����������� Powered by MediaWiki
  • Последнее изменение этой страницы: 19:51, 5 февраля 2007.
  • К этой странице обращались 58 раз.
5.18159985542


php/datafun/xml/simplexml/simplexml load string — Справочник Web-языков

php/datafun/xml/simplexml/simplexml load string

 |  |  |  |  |  |  |  |  |  | simplexml_load_file
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | XML | ::. | SimpleXML | ::. | simplexml_load_string
 |  |  |  |  |  |  |  |  |  | Символические ссылки. Жесткие ссылки.

[править] simplexml_load_string

(PHP 5)

simplexml_load_string -- Интерпретирует строку с XML в объект

[править] Описание

object simplexml_load_string ( string data [, string class_name [, int options]] )

Эта функция берет "правильный" XML-документ, находящийся в строке data и возвращает объект класса SimpleXMLElement, имеющий свойства, равные содержимому xml-документа. Если XML-документ имеет ошибки, функция возвратит FALSE.

Вы можете использовать необязательный параметр class_name для того, чтобы функция simplexml_load_string() вернула объект заданного класса. Этот класс должен расширять класс SimpleXMLElement.

Начиная с PHP 5.1.0 и Libxml 2.6.0, вы можете также использовать необязательный параметр options, содержимое которого определено в additional Libxml parameters.

Пример 1. Преобразование XML-строки

<?php
$string = <<<XML
<?xml version='1.0'?>
<document>
 <title>Forty What?</title>
 <from>Joe</from>
 <to>Jane</to>
 <body>
  I know that's the answer -- but what's the question?
 </body>
</document>
XML;
$xml = simplexml_load_string($string);
var_dump($xml);
?>

Этот пример выведет:

SimpleXMLElement Object
(
  [title] => Forty What?
  [from] => Joe
  [to] => Jane
  [body] =>
   I know that's the answer -- but what's the question?
)

В этом примере вы можете также использовать конструкции $xml->body и т.д.

Получено с http://spravkaweb.local/index.php/php/datafun/xml/simplexml/simplexml_load_string
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
������ ����������� Powered by MediaWiki
  • Последнее изменение этой страницы: 19:52, 5 февраля 2007.
  • К этой странице обращались 56 раз.
4.00311994553


Справочник по PHP : Функции работы с данными : XML : SimpleXML : xpath — Справочник Web-языков

Справочник по PHP : Функции работы с данными : XML : SimpleXML : xpath

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  |  |  | children
Главная | ::. | PHP | ::. | Функции работы с данными | ::. | XML | ::. | SimpleXML | ::. | xpath
 |  |  |  |  |  |  |  |  |  | simplexml_import_dom

[править] SimpleXMLElement->xpath

SimpleXMLElement->xpath -- Выполняет Xpath-запрос к XML-данным

[править] Описание

array SimpleXMLElement->xpath ( string path )

Метод xpath ищет дочерние элементы элемента SimpleXML, путь к которому указан в параметре path. Метод возвращает массив объектов SimpleXMLElement.

Пример 1. Xpath

<?php
$string = <<<XML
<a>
    <b>
         <c>text</c>
        <c>stuff</c>
    </b>
    <d>
         <c>code</c>
         <b>
             <c>plain</c>
         </b>
    </d>
</a>
XML;
$xml = simplexml_load_string($string);
/* Поиск по <a><b><c> */
$result = $xml->xpath('/a/b/c');
foreach ($result as $node) {
    echo '/a/b/c: ' . $node . '<BR>';
}
/* Относительные дорожки также работают ... */
$result = $xml->xpath('b/c');
foreach ($result as $node) {
    echo 'b/c: ' . $node . '<BR>';
}
?>

Данный скрипт выведет:

/a/b/c: text
/a/b/c: stuff
b/c: text
b/c: stuff

Два результата в данном случае одинаковы.

Получено с http://spravkaweb.local/index.php/php/datafun/xml/simplexml/xpath
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
������ ����������� Powered by MediaWiki
  • Последнее изменение этой страницы: 19:37, 5 февраля 2007.
  • К этой странице обращались 47 раз.
5.95796298981


Справочник по PHP : Взаимодействие с базами данных : База данных MySQL : Работа с базами данных — Справочник Web-языков

Справочник по PHP : Взаимодействие с базами данных : База данных MySQL : Работа с базами данных

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Управляющие функции : Информационные функции
Главная | ::. | PHP | ::. | Взаимодействие с базами данных | ::. | База данных MySQL | ::. | Работа с базами данных
 |  |  |  |  |  |  |  | Обработка результатов запроса

Содержание

  • 1 mysql_connect
  • 2 mysql_pconnect
  • 3 mysql_close
  • 4 mysql_change_user
  • 5 mysql_list_dbs
  • 6 mysql_db_name
  • 7 mysql_select_db
  • 8 mysql_create_db
  • 9 mysql_drop_db
  • 10 mysql_list_tables
  • 11 mysql_tablename
  • 12 mysql_query
  • 13 mysql_db_query
  • 14 mysql_num_rows
  • 15 mysql_affected_rows
  • 16 mysql_insert_id
  • 17 mysql_data_seek
  • 18 mysql_free_result

[править] mysql_connect

Устанавливает сетевое соединение с базой данных MySQL.

Синтаксис:

int mysql_connect([string $hostname[:port][:/path/to/socket][, [,string $username [,string $password]]])

Функция mysql_connect() устанавливает сетевое соединение с базой данных MySQL, расположенной на хосте $hostname, и возвращает идентификатор открытого соединения. Вся дальнейшая работа ведется именно с этим идентификатором. При регистрации указывается имя пользователя $username и пароль $password. Строка $hostname также может включать в себя номер порта в виде "hostname:port" или путь к сокету для локальной машины в системах Unix - ":/path/to/socket" (если сервер MySQL настроен не на стандартный, а на какой-то другой порт).

При ошибке выдается предупреждение. Выдачу сообщения об ошибке можно блокировать, указав перед именем функции оператор "@".

При следующем запуске функции с теми же самыми аргументами второе соединение не будет открыто, а функция возвратит идентификатор уже существующего.

В конце сценария обычно принято закрывать подключения функцией mysql_close(), но этого можно не делать, т.к. PHP автоматически закрывает все (неустойчивые) подключения при завершении сценария.

<?php
   $conn = mysql_connect ("localhost", "username", "pass")
        or die ("Соединение не установлено!");
   print ("Соединение установлено!");
   mysql_close($conn);
?>

[править] mysql_pconnect

Устанавливает устойчивое сетевое соединение с базой данных MySQL.

Синтаксис:

int mysql_pconnect([string $hostname[:port][:/path/to/socket][, [,string $username [,string $password]]])

Функция mysql_pconnect() устанавливает устойчивое сетевое соединение с базой данных MySQL, расположенной на хосте $hostname, и возвращает идентификатор открытого соединения. Вся дальнейшая работа ведется именно с этим идентификатором. При регистрации указывается имя пользователя $username и пароль $password. Строка $hostname также может включать в себя номер порта в виде "hostname:port"или путь к сокету для локальной машины в системах Unix - ":/path/to/socket" (если сервер MySQL настроен не на стандартный, а на какой-то другой порт).

При ошибке выдается предупреждение. Выдачу сообщения об ошибке можно блокировать, указав перед именем функции оператор "@".

При следующем запуске функции с теми же самыми аргументами второе соединение не будет открыто, а функция возвратит идентификатор уже существующего.

mysql_pconnect() действует аналогично mysql_connect(), но с двумя отличиями:

  • Перед подключением функция пытается проверить, имеется ли уже открытое подключение. Если есть, то возвращается идентификатор вместо создания нового подключения.
  • При завершении сценария подключение не закрывается, а остается действующим для дальнейшего использования, т.е. функция mysql_close() не может закрыть подключения, созданное с помощью mysql_pconnect().

[править] mysql_close

Закрывает установленное ранее соединение с базой данных.

Синтаксис:

int mysql_close ([int link_identifier])

Закрывает соединение с MySQL-сервером с идентификатором link_identifier, или последнее открытое соединение, если используется без идентификатора.

Возвращает true при удачном закрытии или false при ошибке.

Использование этой функции не обязательно, т.к. PHP автоматически закрывает все неустойчивые подключения при завершении работы сценария.

Подключения, установленные функцией mysql_pconnect(), не закрываются.

<?php
   $conn = mysql_connect ("localhost", "username", "pass")
        or die ("Соединение не установлено!");
   print ("Соединение установлено!");
   mysql_close($conn);
?>

[править] mysql_change_user

Изменяет параметры подключения.

Синтаксис:

int mysql_change_user(string user, string password [, string database [, int link_identifier]])

Если не указывается БД или подключение, то используется последняя активная БД.

Если авторизация не произошла, то параметры подключения не изменяются.

Работает с MySQL 3.23.3 и выше.

[править] mysql_list_dbs

Возвращает список БД на сервере.

Синтаксис:

int mysql_list_dbs([int link_identifier])

Возвращает набор записей, содержащий список БД на сервере.

$bd=mysql_connect("localhost", "name", "pass");
$bd_list=mysql_list_dbs($bd);
while($row=mysql_fetch_object($bd_list)) {
  echo $row->Database."n";
}

Надо отметить, что список баз данных можно получить не имея привелегий, т.е. не указывая пароль доступа.

[править] mysql_db_name

Возвращает имя базы данных из списка.

Синтаксис:

int mysql_db_name(int result, int row [, mixed field])

Параметр result задает дескриптор набора записей, полученных при помощи функции mysql_list_dbs(). Аргумент row указывает номер записи.

В случае ошибки данная функция возвращает false.

mysql_connect("localhost", "username", "pass");
$db_list=mysql_list();
for($i=0;$i<($cnt=mysql_num_rows($db_list));$i++) {
  echo mysql_db_name($db_list,$i)."n";
}

Ранее функция называлась mysql_dbname().

[править] mysql_select_db

Выбор одной базы данных MySQL.

Синтаксис:

int mysql_select_db (string database_name [, int link_identifier])

Возвращает true при удачном закрытии или false при ошибке.

Если Вы планируете открывать только одно соединение с базой данных за все время работы сценария, то можете не сохранять возвращенное значение, а также не указывать идентификатор при вызове всех остальных функций.

До того как послать первый запрос серверу MySQL, необходимо указать, с какой базой данных мы собираемся работать. Для этого и предназначена данная функция. Она уведомляет, что в дальнейших операциях с соединением link_identifier (или с последним открытым соединением, если указанный параметр не задан) будет использоваться база данных database_name.

Если на момент вызова данной функции подключений к базе данных нет, то косвенно вызывается функция mysql_connect() с параметрами по умолчанию.

[править] mysql_create_db

Создание базы данных MySQL.

Синтаксис:

int mysql_create_db(string dbname [, int link_identifier])

Эта функция создает новую базу данных MySQL с именем dbname, используя подключение link_identifier.

$db=mysql_connect("localhost", "name", "pass");
if(mysql_create_db("my_db_name")) {
  echo "БД my_db_name создана");
} else {
  echo "Ошибка создания БД: %sn".mysql_error());
}

[править] mysql_drop_db

Удаление базы данных MySQL.

Синтаксис:

int mysql_drop_db(string database_name [, int link_identifier])

Функция mysql_drop_db() удаляет базу данных database_name, доступную в подключении link_identifier.

В случае успешного удаления возвращает true, при ошибке - false.

[править] mysql_list_tables

Возвращает список таблиц в БД.

Синтаксис:

int mysql_list_tables(string database [,int link_identifier])

Функция возвращает идентификатор результата (одна колонка), в котором содержаться имена всех таблиц, присутствующих в базе данных. Для извлечения этих имен можно использовать функцию mysql_result() с номером колонки, равным 0, иди функцию mysql_tablename().

Следующий пример выведет все имена баз данных и таблиц, которые в них содержаться:

$db=mysql_connect("localhost", "user_name", "");
$db_list=mysql_list_dbs($db);
while($r_db=mysql_fetch_object($db_list)) {
  echo $r_db->Database."n";
    // распечатать список таблиц
  $t_list=mysql_list_tables($r_db->Database);
  for($i=0;$i<mysql_num_rows($t_list);$i++) {
    echo " - ".mysql_tablename($t_list,$i)."n";
  }
}

[править] mysql_tablename

Возвращает имя таблицы в БД.

Синтаксис:

int mysql_tablename(int result, int i)

Функция возвращает имя таблицы с номером i из набора записей, полученных при помощи функции mysql_list_tables().

$db=mysql_connect("localhost", "user_name", "");
$result=mysql_list_tables("db_name");
$i=0;
while($i<mysql_num_rows($result)) {
  $t_name[$i]=mysql_tablename($result, $i);
  echo $t_name[$i]."<BR>";
  $i++;
}

[править] mysql_query

Посылает запрос базе данных MySQL.

Синтаксис:

int mysql_query(string query [,int link_identifier])

Эта функция посылает запрос query базе данных, связанной с идентификатором link_identifier. Если идентификатор не указан, то принимается во внимание последнее открытое соединение. Если до этого соединение небыло установлено, то выполняется операция mysql_connect() с параметрами по умолчанию.

SQL-выражение, указанное в параметре query, не должно оканчиваться ";".

Если выражение содержит ошибки, или его выполнение приводит к ошибкам, то функция mysql_query() возвращает false.

В результате успешно выполненного запроса возвращается набор записей, который можно обработать следующими функциями:

  • mysql_result() - получить элемент набора записей
  • mysql_fetch_array() - внести запись в массив
  • mysql_fetch_row() - занести запись в нумерованный массив
  • mysql_fetch_assoc() - занести запись в ассоциативный массив
  • mysql_fetch_object() - занести запись в объект

Чтобы узнать, сколько записей было найдено командой SELECT, воспользуйтесь функцией mysql_num_rows().

Для того, чтобы узнать, сколько записей было изменено в результате выполнения запросов DELETE, INSERT, REPLACE или UPDATE, воспользуйтесь функцией mysql_affected_rows().

После обработки результатов запроса он может быть удален функцией mysql_free_result(). Но в этом нет необходимости, т.к. результаты сами уничтожаются после завершения работы сценария.

[править] mysql_db_query

Посылает запрос к указанной базе данных MySQL.

Синтаксис:

int mysql_db_query(string database, string query [,int link_identifier])

Эта функция эквивалентна следующей последовательности функций:

mysql_select_db(string database [, int link_identifier]);
mysql_query(string query [, int link_identifier]);

[править] mysql_num_rows

Возвращает количество строк в результате запроса.

Синтаксис:

int mysql_num_rows(int result)

Эта функция возвращает число записей, найденных в результате выполнения SQL-команды SELECT (поиск по базе данных).

<?php
$link = mysql_connect("localhost", "username", "password");
mysql_select_db("database", $link);

$result = mysql_query("SELECT * FROM table1", $link);
$num_rows = mysql_num_rows($result);

echo "Получено строк: $num_rowsn";
?>

[править] mysql_affected_rows

Возвращает количество измененных записей в БД MySQL.

Синтаксис:

int mysql_affected_rows([int link_identifier]);

Функция mysql_affected_rows() возвращает количество записей, которые были изменены в базе данных в результате выполнения запросов DELETE, INSERT, REPLACE или UPDATE.

Если последним запросом была команда DELETE без ограничения WHERE (т.е. из таблицы были удалены все записи), то наша функция возвратит 0.

[править] mysql_insert_id

Получает вставленный идентификатор.

Синтаксис:

int mysql_insert_id([int $link_identifier])

Функция возвращает непосредственно перед ее вызовом сгенерированный идентификатор записи для автоинкрементного поля после выполнения команды insert. Вызывать ее разумно только сразу после выполнения инструкции insert, например, в таком контексте:

mysql_query("insert into Таблица(поле 1, поле 2) values("aa","bb")");
$id=mysql_insert_id();

Теперь к только что вставленной записи можно обратиться, используя идентификатор $id:

$r=mysql_query("select * from Таблица where id=$id");
$Row=mysql_fetch_array($r);

[править] mysql_data_seek

Устанавливает указатель текущей строки.

Синтаксис:

int mysql_data_seek(int result, int row_number)

Эта функция устанавливает указатель текущей строки в результате result в позицию row_number, так что следующий вызов mysql_fetch_row() и mysql_fetch_array() вернет значения полей именно этой строки.

Нумерация записей ведется с 0.

Возвращает false в случае ошибки или если строки кончились.

[править] mysql_free_result

Уничтожает набор записей.

Синтаксис:

int mysql_free_result(int result)

Данная функция освобождает память, занимаемую набором записей result, возвращенным запросом.

Эта функция необходима, когда нужно экономить память, т.к. PHP автоматически освобождает память при завершении сценария.

Получено с http://spravkaweb.local/index.php/php/db/mysql/db
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 05:02, 20 марта 2007.
  • К этой странице обращались 222 раза.
1.26363420486


Справочник по PHP : Взаимодействие с базами данных : База данных MySQL : Обработка результатов запроса — Справочник Web-языков

Справочник по PHP : Взаимодействие с базами данных : База данных MySQL : Обработка результатов запроса

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Работа с базами данных
Главная | ::. | PHP | ::. | Взаимодействие с базами данных | ::. | База данных MySQL | ::. | Обработка результатов запроса
 |  |  |  |  |  |  |  | Графика : Работа с изображениями и библиотека GD : Параметры изображения

Содержание

  • 1 mysql_result
  • 2 mysql_fetch_array
  • 3 mysql_fetch_row
  • 4 mysql_fetch_object
  • 5 mysql_fetch_lengths
  • 6 mysql_fetch_field
  • 7 mysql_field_seek
  • 8 mysql_field_name
  • 9 mysql_field_table
  • 10 mysql_field_len
  • 11 mysql_field_type
  • 12 mysql_field_flags
  • 13 mysql_list_fields
  • 14 mysql_num_fields
  • 15 mysql_errno
  • 16 mysql_error

[править] mysql_result

Получение определенного поля результата.

Синтаксис:

int mysql_result(int result, int row [, mixed field])

Функция возвращает значение поля field в строке результата с номером row. Параметр field может задавать не только имя поля, но и его номер - позицию, на которой столбец "стоял" при создании таблицы, а также полное имя поля вида: "имя_таблицы.имя_поля". Тем не менее, рекомендуется везде, где это только возможно,использовать именно имена полей.

Функция универсальна: с ее помощью можно "обойти" весь результат по одной ячейке. И хотя это не возбраняется, но делать, однако, не рекомендуется, т.к. mysql_result() работает довольно медленно.

[править] mysql_fetch_array

Извлекает из результата очередную запись и помещает ее в ассоциативный массив.

Синтаксис:

array mysql_fetch_array(int result [, int result_type])

Функция mysql_fetch_array() возвращает очередную строку результата в виде ассоциативного массива, где каждому полю сопоставлен элемент с ключом, совпадающим с именем поля. Дополнительно в массив записываются элементы с числовыми ключами и значениями, соответствующими величинам полей с этими индексами. В возвращаемом массиве они размещаются сразу за элементами с "обычными" ключами.

Параметр result_type задает вид возвращаемого массива и может принимать одно из следующих значений: MYSQL_NUM, MYSQL_ASSOC, MYSQL_BOTH (по умолчанию).

Может возникнуть вопрос: зачем вообще нужны числовые индексы. Ответ прост: дело в том, что в результате выборки в действительности могут присутствовать поля (фактически, колонки) с одинаковыми именами, но, соответственно, с различными индексами. Это происходит тогда, когда выборка в SELECT производится одновременно из нескольких таблиц.

mysql_connect($host, $user, $pass);
$result=mysql_db_query("database", "select id, name from tabl");
while($row=mysql_fetch_array($result)) {
  echo "id: ".$row["id"]."<BR>";
  echo "id: ".$row[0]."<BR>";
  echo "name: ".$row["name"]."<BR>";
  echo "name: ".$row[1]."<BR>";
};
mysql_free_result($result);

[править] mysql_fetch_row

Записывает запись в нумерованный массив.

Синтаксис:

array mysql_fetch_row(int result)

Функция возвращает массив-список со значениями полей очередной строки результата result. Если указатель текущей позиции результата был установлен за последней записью (то есть строки кончились), возвращается false. Текущая позиция сдвигается к следующей записи, так что очередной вызов mysql_fetch_row() вернет следующую строку результата.

Каждое поле записи сохраняется в нумерованном элементе массива. Нумерация начинается с 0.

$r=mysql_query("select * from OutTable where age<30");
while($Row=mysql_fetch_row($r)) {
  // обрабатываем строку $Row
}

Как видим, цикл оборвется, как только строки закончатся, т.е. когда mysql_fetch_row() вернет false.

[править] mysql_fetch_object

Получение записи в свойствах объекта.

Синтаксис:

object mysql_fetch_object(int result)

Функция возвращает объект, в свойствах которого находятся поля текущей записи. В случае, если записи кончились, возвращает false.

mysql_connect($host, $user, $pass);
$result=mysql_db_query("database", "select * from table");
while($rows=mysql_fetch_object($result)) {
  echo $rows->id;
  echo $rows->name;
};

[править] mysql_fetch_lengths

Возвращает длину элемента записи.

Синтаксис:

array mysql_fetch_lengths(int result)

Функция mysql_fetch_lengths() возвращает длину значения, полученного при помощи функций mysql_fetch_row(), mysql_fetch_array() или mysql_fetch_object().

Например, в следующем примере:

$arr=mysql_fetch_row($result);
$len=mysql_fetch_lengths($result);

массив $len будет содержать длину соответствующих элементов массива $arr, т.е. $len[0]=strlen(arr[0]) и т.д.

[править] mysql_fetch_field

Возвращает информацию о свойствах объекта и о поле записи.

Синтаксис:

object mysql_fetch_field(int result [, int field_offset])

В необязательном параметре field_offset задается номер поля, свойства которого мы хотим получить. Если этот параметр не указан, при каждом вызове функции mysql_fetch_field() возвращаются свойства следующего поля из набора записей result.

Возвращаемый объект имеет следующие свойства:

  • name - имя поля
  • table - имя таблицы, которой принадлежит поле
  • max_length - максимальная длина поля
  • not_null - 1, если полю разрешено пустое значение
  • primary_key - 1, если поле является ключевым
  • unique_key - 1, если в поле допускаются только уникальные значения
  • multiple_key - 1, если в поле допустимо иметь повторяющиеся значения
  • numeric - 1, если поле числовое
  • blob - 1, если поле имеет тип BLOB
  • type - тип поля
  • unsigned - 1, если поле числовое беззнаковое
  • zerofill - 1, есле поле заполняется нулями
mysql_connect($host,$user,$pass);
$result=mysql_db_query("database", select * from table");
for($i=0;$i<mysql_num_fields($result);$i++) {
  echo "Свойства поля $i:<BR>";
  $param=mysql_fetch_field($result);
  if(!$param) echo "Нет информации о свойствах!";
  echo "<PRE>
name:          $param->name
table:         $param->table
max_length:    $param->max_length
not_null:      $param->not_null
primary_key:   $param->primary_key
unique_key:    $param->unique_key
multiple_key:  $param->multiple_key
numeric:       $param->numeric
blob:          $param->blob
type:          $param->type
unsigned:      $param->unsigned
zerofill:      $param->zerofill
</PRE>";
}

[править] mysql_field_seek

Производит перемещение курсора к указанному полю.

Синтаксис:

int mysql_field_seek(int result, int field_offset)

Данная функция является излишней. Следующие фрагменты будут эквивалентны:

$param=mysql_fetch_field($result, field_offset);

и

mysql_field_seek($result, field_offset);
$param=mysql_fetch_field($result);

[править] mysql_field_name

Возвращает имя поля.

Синтаксис:

string mysql_field_name(int result, int filed_index)

Функция mysql_field_name() возвращает имя поля, которое расположено в результате result с индексом filed_index (нумерация начинается с 0).

$result=mysql_query("SELECT id, name from table");
echo mysql_field_name($result,1); // Выведет: name

[править] mysql_field_table

Возвращает имя таблицы, из которой было извлечено поле.

Синтаксис:

string mysql_field_table(int result, int field_offset)

Возвращает имя таблицы, из которой было извлечено поле со смещением field_offset в результате result.

[править] mysql_field_len

Возвращает длину поля.

Синтаксис:

int mysql_field_len(int result, int filed_offset)

Функция возвращает длину поля в результате result. Поле, как обычно, задается указанием его смещения. Под длиной здесь подразумевается не размер данных поля в байтах, а тот размер, который был указан при его создании. Например, если поле имеет тип varchar и было создано (вместе с таблицей) с типом varchar(100), то для него будет возвращено 100.

[править] mysql_field_type

Возвращает тип набора записей в результате.

Синтаксис:

string mysql_field_type(int result, int filed_offset)

Эта функция похожа на mysql_filed_name(), только возвращает не имя , а тип соответствующей колонки в результате. Им может быть, например, int, double, real и т.д.

mysql_connect($host,$user,$pass);
mysql_select_db("mydb");
$result=mysql_query("SELECT * FROM tabl");
$fields=mysql_num_fields($result);
$rows=mysql_num_rows($result);
$i=0;
$table=mysql_field_table($result,$i);
echo "Таблица "$table" имеет $fields полей и $rows записей<BR>";
echo "Структура таблицы:<BR>";
while($i<$fields) {
  $type=mysql_field_type($result,$i);
  $name=mysql_field_name($result,$i);
  $len=mysql_field_len($result,$i);
  $flags=mysql_field_flags($result,$i);
  echo $type." ".$name." ".$len." ".$flags."<BR>";
  $i++;
}

[править] mysql_field_flags

Эта функция возвращает флаги, которые были использованы при создании указанного поля в таблице.

Синтаксис:

string mysql_field_flags(int result, int field_offset)

Возвращаемая строка представляет собой набор слов, разделенных пробелами, так что вы можете преобразовать ее в массив при помощи функции explode():

$Flags=explode(" ",mysql_field_flags($r,$field_offset));

Поля записей в MySQL могут иметь следующие свойства-флаги:

  • "not_nul"
  • "primary_key"
  • "unique_key"
  • "multiple_key"
  • "blob"
  • "unsigned"
  • "zerofill"
  • "binary"
  • "enum"
  • "auto_increment"
  • "timestamp"

[править] mysql_list_fields

Возвращает список полей таблицы.

Синтаксис:

int mysql_list_fields(string dbname, string tblname [,int link_identifier])

Функция mysql_list_fields() возвращает информацию об указанной таблице tblname в базе данных bdname, используя идентификатор соединения link_identifier, если он задан (в противном случае - последнее открытое соединение). Возвращаемое значение - идентификатор результата, который может быть проанализирован обычными средствами. В случае ошибки возвращается -1, текст сообщения ошибки может быть получен обычным способом.

$link=mysql_connect($host,$user,$pass);
$fields=mysql_list_fields("db1", "table", $link);
$colums=mysql_num_fields($fields); // число полей в таблице
// Далее распечатаем имена всех полей таблицы
for($i=0;$i<$colums;$i++) {
  echo mysql_field_name($fields,$i)."<BR>";
}

[править] mysql_num_fields

Эта функция возвращает число полей в одной строке результата, т.е. число колонок в результате.

Синтаксис:

int mysql_num_fields(int result)

В силу сказанного, функция позволяет определить горизонтальную размерность "двумерного массива результата".

[править] mysql_errno

Возвращает номер последней ошибки.

Синтаксис:

int mysql_errno ([int link_identifier])

Данная функция возвращает номер последней зарегистрированной ошибки или 0, если ошибок нет.

Идентификатор link_identifier можно не указывать, если за время работы сценария было установлено только одно соединение.

mysql_connect("dbname");
echo mysql_errno().": ".mysql_error()."<BR>";

[править] mysql_error

Возвращает сообщение об ошибке.

Синтаксис:

string mysql_error ([int link_identifier])

Эта функция возвращает строку, содержащую текст сообщения об ошибке или пустую строку, если ошибок небыло.

mysql_connect("dbname");
echo mysql_errno().": ".mysql_error()."<BR>";
Получено с http://spravkaweb.local/index.php/php/db/mysql/get
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:44, 18 февраля 2007.
  • К этой странице обращались 103 раза.
1.19320893288


Справочник по PHP : Графика : Работа с изображениями и библиотека GD : Работа с фиксированными шрифтами — Справочник Web-языков

Справочник по PHP : Графика : Работа с изображениями и библиотека GD : Работа с фиксированными шрифтами

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Графические примитивы
Главная | ::. | PHP | ::. | Графика | ::. | Работа с изображениями и библиотека GD | ::. | Работа с фиксированными шрифтами
 |  |  |  |  |  |  |  | Работа со шрифтами TrueType и PostScript Type 1

Библиотека GD имеет некоторые возможности по работе с текстом и шрифтами. Шрифты представляют собой специальные ресурсы, имеющие собственный идентификатор, и чаще всего загружаемые из файла или встроенные в GD. Каждый символ шрифта может быть отображен лишь в моноцветном режиме, т.е. "рисованные" символы не поддерживаются. Встроенных шрифтов всего 5 (идентификаторы от 1 до 5), чаще всего в них входят моноширные символы разных размеров. Остальные шрифты должны быть предварительно загружены.

Содержание

  • 1 imageLoadFont
  • 2 imageFontHeight
  • 3 imageFontWidth
  • 4 imageString
  • 5 imageStringUp
  • 6 imageChar
  • 7 imageCharUp

[править] imageLoadFont

Загрузка шрифта.

Синтаксис:

int imageLoadFont(string file)

Функция загружает файл шрифтов file и возвращает идентификатор шрифта - это будет цифра, большая 5, потому что пять первых номеров зарезервировано как встроенные. Формат файла - бинарный, а потому зависит от архитектуры машины. Это значит, что файл со шрифтами должен быть сгенерирован по крайней мере на машине с процессором такой же архитектуры, как и у той, на котором вы собираетесь использовать PHP.

Формат файла со шрифтом

Смещение | Тип | Описание
Byte 0-3 | long Число символов в шрифте (nchars)
byte 4-7 | long | Индекс первого символа шрифта (обычно 32 - пробел)
byte 8-11 | long | Ширина (в пикселях) каждого знака (width)
byte 12-15 | long | Высота (в пикселях) каждого знака (height)
byte 16-... | array | Массив с информацией о начертании каждого символа, по одному байту на пиксел. На один символ, таким образом, приходится width*height*nchars байтов. 0 означает отсутствие точки в данной позиции, все остальное - ее присутствие.

Левая колонка задает смещение начала данных внутри файла, а группами цифр, записанных через дефис, определяется, до какого адреса продолжаются данные.

[править] imageFontHeight

Установка высоты шрифта.

Синтаксис:

int imageFontHeight(int font)

Функция возвращает высоту в пикселях символов в заданном шрифте.

[править] imageFontWidth

Установка ширины шрифта.

Синтаксис:

int imageFontWidth(int font)

Функция возвращает ширину в пикселях символов в заданном шрифте.

[править] imageString

Выводит строку в горизонтальном направлении.

Синтаксис:

int imageString(int im, int font, int x, int y, string s, int color)

Функция выводит строку s в изображение im, используя шрифт font и цвет color. Координаты (x, y) будут координатами верхнего левого угла прямоугольника, в который вписана строка.

Если параметр font задан как 1, 2, 3, 4 или 5, то выводится шрифт соответствующего размера.

<?php
  // создаем изображение 100x30
  $im = imagecreate(100, 30);

  // задаем цвет текста
  $textcolor = imagecolorallocate($im, 0, 0, 255);

  // выводим надпись в верхнем левом углу
  imagestring($im, 5, 0, 0, "Hello world!", $textcolor);

  // выводим изображение в браузер
  header("Content-type: image/jpg");
  imagejpeg($im);
?>

[править] imageStringUp

Выводит строку в вертикальном направлении.

Синтаксис:

int imageStringUp(int im, int font, int x, int y, string s, int color)

Эта функция также выводит строку текста, но не в горизонтальном, а в вертикальном направлении.

Верхний левый угол задается координатами (x, y).

Если параметр font задан как 1, 2, 3, 4 или 5, то выводится шрифт соответствующего размера.

[править] imageChar

Вывод символа горизонтально.

Синтаксис:

int imageChar(int im, int font, int x, int y, string c, int color)

Функция выводит символ c в горизонтальном положении в месте на рисунке, заданном координатами (x, y). Шрифт символа задается параметром font. Если этот параметр принимает значение от 1 до 5, то используются встроенные шрифты. Цвет символа задается параметром color.

<?php
// создаем картинку размером 100x100
$im = imagecreate(100, 100);

$string = "PHP";

// задаем цвет символа
$black = imagecolorallocate($im, 0, 0, 0);

// Выведем символ "P" в верхнем левом углу
imagechar($im, 1, 0, 0, $string, $black);

// выведем картинку в браузер
header("Content-type: image/png");
imagepng($im);
?>

[править] imageCharUp

Вывод символа вертикально.

Синтаксис:

int imageCharUp(int im, int font, int x, int y, string c, int color)

Функция выводит символ c в вертикальном положении в месте на рисунке, заданном координатами (x, y). Шрифт символа задается параметром font. Если этот параметр принимает значение от 1 до 5, то используются встроенные шрифты. Цвет символа задается параметром color.

Получено с http://spravkaweb.local/index.php/php/image/gd/font
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 17:30, 18 февраля 2007.
  • К этой странице обращались 84 раза.
1.51345014572


Справочник по PHP : Графика : Работа с изображениями и библиотека GD : Графические примитивы — Справочник Web-языков

Справочник по PHP : Графика : Работа с изображениями и библиотека GD : Графические примитивы

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Работа с цветом в формате RGB
Главная | ::. | PHP | ::. | Графика | ::. | Работа с изображениями и библиотека GD | ::. | Графические примитивы
 |  |  |  |  |  |  |  | Работа с фиксированными шрифтами

Содержание

  • 1 imageSetPixel
  • 2 imageLine
  • 3 imageDashedLine
  • 4 imageRectangle
  • 5 imageFilledRectangle
  • 6 imageArc
  • 7 imageFill
  • 8 imageFillToBorder
  • 9 imagePolygon
  • 10 imageFilledPolygon

[править] imageSetPixel

Рисует пиксель.

Синтаксис:

int imageSetPixel(int im, int x, int y, int color)

Выводит один пиксель цвета color в изображении im, расположенный в точке (x, y).

[править] imageLine

Рисует сплошную тонкую линию.

Синтаксис:

int imageLine(int im, int x1, int y1, int x2, int y2, int color)

Эта функция рисует сплошную тонкую линию в изображении im, проходящую через точки (x1, y1) и (x2, y2), цветом color. Линия получается слабо связанной.

<?php

function imagelinethick($image, $x1, $y1, $x2, $y2, $color, $thick = 1)
{
    /* this way it works well only for orthogonal lines
    imagesetthickness($image, $thick);
    return imageline($image, $x1, $y1, $x2, $y2, $color);
    */
    if ($thick == 1) {
        return imageline($image, $x1, $y1, $x2, $y2, $color);
    }
    $t = $thick / 2 - 0.5;
    if ($x1 == $x2 || $y1 == $y2) {
        return imagefilledrectangle($image,
         round(min($x1, $x2) - $t),
         round(min($y1, $y2) - $t),
         round(max($x1, $x2) + $t),
         round(max($y1, $y2) + $t), $color);
    }
    $k = ($y2 - $y1) / ($x2 - $x1); //y = kx + q
    $a = $t / sqrt(1 + pow($k, 2));
    $points = array(
        round($x1 - (1+$k)*$a), round($y1 + (1-$k)*$a),
        round($x1 - (1-$k)*$a), round($y1 - (1+$k)*$a),
        round($x2 + (1+$k)*$a), round($y2 - (1-$k)*$a),
        round($x2 + (1-$k)*$a), round($y2 + (1+$k)*$a),
    );
    imagefilledpolygon($image, $points, 4, $color);
    return imagepolygon($image, $points, 4, $color);
};
?>

[править] imageDashedLine

Рисует пунктирную линию.

Синтаксис:

int imageDashedLine(int im, int x1, int y1, int x2, int y2, int color)

Эта функция работает почти так же, как и imageLine(), только рисует не сплошную, а пунктирную линию. К сожалению, ни размер, ни шаг штрихов задавать нельзя, так что, если вам обязательна нужна пунктирная линия произвольной фактуры, придется заняться математическими расчетами и использовать imageLine().

[править] imageRectangle

Рисует прямоугольник.

Синтаксис:

int imageRectangle(int im, int x1, int y1, int x2, int y2, int color)

Эта функция рисует в изображении im прямоугольник с границей толщиной 1 пиксель цветом color.

Левый верхний угол задается (x1, y1), а правый нижний - (x2, y2).

[править] imageFilledRectangle

Зарисовка прямоугольной области.

Синтаксис:

int imageFilledRectangle(int im, int x1, int y1, int x2, int y2, int color)

Эта функция рисует закрашенный прямоугольник в изображении, заданном идентификатором im, цветом color (полученным, например, при помощи функции imageColorAllocate()). Координаты (x1, y1) и (x2, y2) задают координаты верхнего левого и правого нижнего углов, соответственно (отсчет, как обычно, начинается с верхнего угла и идет слева направо и сверху вниз).

Эта функция часто применяется для того, чтобы целиком закрасить только что созданный рисунок, например, прозрачным цветом:

<?php
$im=imageCreate(100,100);
$color=imageColorAllocate($i,0,0,0);
imageColorTransparent($im,$color);
imageFilledRectangle($im,0,0,imageSX($im)-1,imageSY($im)-1,$color);
// дальше работаем с изначально прозрачным фоном
?>

[править] imageArc

Рисование части эллипса.

Синтаксис:

int imageArc(int im, int cx, int cy, int w, int h, int s, int e, int color)

Эта функция рисует в изображении im дугу сектора эллипса от угла s до e (углы указываются в градусах против часовой стрелки, отсчитываемых от горизонтали). Эллипс рисуется такого размера, чтобы вписываться в прямоугольник (w, h), где w и h задают его ширину и высоту. cx и cy - координаты центра эллипса. Сама фигура не закрашивается, обводится только ее контур, для чего используется цвет color.

<?php
// создаем изображение размером 200x200
$img = imagecreate(200, 200);
// задаем цвет окружности
$white = imagecolorallocate($img, 255, 255, 255);
// рисуем окружность
imagearc($img, 100, 100, 150, 150, 0, 360, $white);
// вывод рисунка в браузер
header("Content-type: image/png");
imagepng($img);
// закрытие рисунка
imagedestroy($img);
?>

[править] imageFill

Заливка цветом ограниченной области.

Синтаксис:

int imageFill(int im, int x, int y, int color)

Эта функция выполняет сплошную заливку одноцветной области, содержащей точку с координатами (x, y) цветом color. Нужно замерить, что современные алгоритмы заполнения работают довольно эффективно, так что не стоит особо заботиться о скорости ее работы. Будут закрашены только те точки, к которым можно проложить "одноцветный сильно связанный путь" из точки x, y.

Две точки называются связанными сильно, если у них совпадает, по крайней мере, одна координата, а по другой координате они отличаются не более, чем на 1 в любую сторону.

[править] imageFillToBorder

Заливка области, ограниченной бордюром.

Синтаксис:

int imageFillToBorder(int im, int x, int y, int border, int color)

Эта функция очень похожа на imageFill(), только она выполняет закраску цветом color не одноцветных точек, а любых, но до тех пор, пока не будет достигнута граница цвета border.

[править] imagePolygon

Рисует многоугольник с заданными вершинами.

Синтаксис:

int imagePolygon(int im, array points, int num_points, int color)

Эта функция рисует в изображении im многоугольник, заданный своими вершинами. Координаты углов передаются в массиве points, причем $points[0]=x0, $points[1]=y0, $points[2]=x1, $points[3]=y1 и т.д.

Параметр num_points указывает общее число вершин - на тот случай, если в массиве их больше, чем нужно нарисовать. Многоугольник не закрашивается - только рисуется его граница цветом color.

<?php
// создаем изображение 400x300
$image = imagecreate(400, 300);

// устанавливаем цвет бордюра многоугольника
$col_poly = imagecolorallocate($image, 255, 255, 255);

// рисуем многоугольник
imagepolygon($image,
             array (
                    0, 0,
                    100, 200,
                    300, 200
             ),
             3, $col_poly);

// вывод картинки в браузер
header("Content-type: image/png");
imagepng($image);
?>

[править] imageFilledPolygon

Рисует закрашенный многоугольник с заданными вершинами.

Синтаксис:

int imageFilledPolygon(int im, array points, int num_points, int color)

Эта функция делает практически то же самое, что и imagePolygon(), за исключением одного очень важного свойства: полученный многоугольник целиком заливается цветом color.

При этом правильно обрабатываются вогнутые части фигуры, если она не выпукла.

<?php
// задаем массив с координатами углов
$values = array(
  0  => 40,    // x1
  1  => 50,    // y1
  2  => 20,    // x2
  3  => 240,   // y2
  4  => 60,    // x3
  5  => 60,    // y3
  6  => 240,   // x4
  7  => 20,    // y4
  8  => 50,    // x5
  9  => 40,    // y5
  10 => 10,    // x6
  11 => 10,    // y6
);

// создаем картинку 250x250
$im = imagecreate(250, 250);

// задаем цвет заполнения многоугольника
$blue = imagecolorallocate($im, 0, 0, 255);

// рисуем многоугольник
imagefilledpolygon($im, $values, 6, $blue );

// вывод каринки в браузер и ее закрытие
header('Content-type: image/png');
imagepng($im);
imagedestroy($im);
?>
Получено с http://spravkaweb.local/index.php/php/image/gd/graf
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 16:57, 18 февраля 2007.
  • К этой странице обращались 80 раз.
1.36513710022


Справочник по PHP : Графика : Работа с изображениями и библиотека GD : Манипулирование изображениями — Справочник Web-языков

Справочник по PHP : Графика : Работа с изображениями и библиотека GD : Манипулирование изображениями

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Параметры изображения
Главная | ::. | PHP | ::. | Графика | ::. | Работа с изображениями и библиотека GD | ::. | Манипулирование изображениями
 |  |  |  |  |  |  |  | Работа с цветом в формате RGB

Содержание

  • 1 imageCreate
  • 2 imageCreateFromPng
  • 3 imageCreateFromJpeg
  • 4 imageCreateFromGif
  • 5 imagePng
  • 6 imageJpeg
  • 7 image2WBMP
  • 8 imageGif
  • 9 imageCopy
  • 10 imageCopyResized
  • 11 imageDestroy

[править] imageCreate

Создание пустой картинки.

Синтаксис:

int imageCreate(int x, int y)

Создает пустую картинку размером x на y точек и возвращает ее идентификатор. После того, как картинка создана, вся работа с ней осуществляется именно через этот идентификатор, по аналогии с тем, как мы работаем с файлом через его дескриптор.

Пример:

Создание новой картинки при помощи GD и вывод ее в экран браузера:

<?php
header ("Content-type: image/png");
$im = @imagecreate (50, 100)
    or die ("Не удается открыть новую картинку!");
$background_color = imagecolorallocate ($im, 255, 255, 255);
$text_color = imagecolorallocate ($im, 233, 14, 91);
imagestring ($im, 1, 5, 5,  "A Simple Text String", $text_color);
imagepng ($im);
?>

[править] imageCreateFromPng

Создание рисунка из файла PNG.

Синтаксис:

int imageCreateFromPng(string filename)

Эта функция загружают изображения из файла PNG в память и возвращает его идентификатор. Как и после вызова imageCreate(), дальнейшая работа с картинкой возможна только через этот идентификатор. При загрузке с диска изображение распаковывается и храниться в память уже в неупакованном формате, для того чтобы можно было максимально быстро производить с ним различные операции, такие как масштабирование, рисование линий и т.д.

Пример:

Пример нахождения ошибки при открытии графического файла.

function LoadPNG ($imgname) {
  $im = @imagecreatefrompng ($imgname); /* Attempt to open */
  if (!$im) { /* See if it failed */
    $im  = imagecreate (150, 30); /* Create a blank image */
    $bgc = imagecolorallocate ($im, 255, 255, 255);
    $tc  = imagecolorallocate ($im, 0, 0, 0);
    imagefilledrectangle ($im, 0, 0, 150, 30, $bgc);
    /* Output an errmsg */
    imagestring ($im, 1, 5, 5, "Error loading $imgname", $tc);
  }
  return $im;
}

[править] imageCreateFromJpeg

Создание рисунка из файла JPEG.

Синтаксис:

int imageCreateFromJpeg(string filename)

Эта функция загружают изображения из файла в память и возвращают его идентификатор. Как и после вызова imageCreate(), дальнейшая работа с картинкой возможна только через этот идентификатор. При загрузке с диска изображение распаковывается и храниться в память уже в неупакованном формате, для того чтобы можно было максимально быстро производить с ним различные операции, такие как масштабирование, рисование линий и т.д.

[править] imageCreateFromGif

Создание рисунка из файла GIF.

Синтаксис:

int imageCreateFromGif(string filename)

Эта функция загружают изображения из файла в память и возвращают его идентификатор. Как и после вызова imageCreate(), дальнейшая работа с картинкой возможна только через этот идентификатор. При загрузке с диска изображение распаковывается и храниться в память уже в неупакованном формате, для того чтобы можно было максимально быстро производить с ним различные операции, такие как масштабирование, рисование линий и т.д.

Стоит упомянуть, что GD начиная с версии 1.6 не поддерживает формат GIF. В связи с этим данная функция практически не используется.

[править] imagePng

Функция выводит изображение в PNG-формате в любой браузер или в файл.

Синтаксис:

int imagePng(int im [, string filename])

Эта функция сохраняет изображение, заданное своим идентификатором и находящееся в памяти, на диск, или же выводят его в браузер.

Разумеется, вначале изображение должно быть загружено или создано при помощи функции imageCreate(), т.е. мы должны знать его идентификатор im.

Если аргумент filename опущен, то сжатые данные в соответствующем формате выводятся прямо в стандартный выходной поток, т.е. в браузер. Нужный заголовок Content-type при этом не выводится, ввиду чего нужно выводить его вручную при помощи Header().

Фактически, вы должны вызвать одну из трех команд, в зависимости от типа изображения:

Header("Content-type: image/png") для PNG.

Пример: Пример использования функции imagepng():

<?php
$im = imagecreatefrompng ("test.png");
Header("Content-type: image/png")
imagepng ($im);
?>

[править] imageJpeg

Отсылка рисунка JPEG браузеру или сохранение его в файле.

Синтаксис:

int imageJPEG(int im [, string filename [, int quality]])

Эта функция сохраняет изображение, заданное своим идентификатором и находящееся в памяти, на диск, или же выводит его в браузер.

Разумеется, вначале изображение должно быть загружено или создано при помощи функции imageCreate(), т.е. мы должны знать его идентификатор im.

Если аргумент filename опущен, то сжатые данные в соответствующем формате выводятся прямо в стандартный выходной поток, т.е. в браузер. Нужный заголовок Content-type при этом не выводится, ввиду чего нужно выводить его вручную при помощи Header().

Фактически, вы должны вызвать одну из трех команд, в зависимости от типа изображения:

Header("Content-type: image/jpeg") для Jpeg

Третий необязательный параметр quality задает качество изображения (от 0 до 100).

<?php
$im=imageCreateFromJPEG("img/file.jpg");
Header("Content-type: image/jpeg");
imageJPEG($im,"",30);
?>

[править] image2WBMP

Вывод изображения в браузер или файл.

Синтаксис:

int image2WBMP( resource image [, string filename [, int threshold]])

Функция выводит изображение, заданное дескриптором image, в браузер, либо в файл, имя которого задано необязательным параметром filename.

Если изображение выводится в браузер, необходимо задать его тип WBMP как image/vnd.wap.wbmp функцией Header():

<?php
$file = "php.png";
$image = imagecreatefrompng($file);

header("Content-type: " . image_type_to_mime_type(IMAGETYPE_WBMP));
image2wbmp($image); // Вывод wbmp-картинки в браузер
?>

Функция image2WBMP() доступна PHP только если версия библиотеки GD 1.8 или ниже.

[править] imageGif

Отсылка рисунка GIF браузеру или сохранение его в файле.

Синтаксис:

int imageGIF(int im [, string filename])

Функция сохраняют изображение, заданное своим идентификатором и находящееся в памяти, на диск, или же выводят его в браузер.

Разумеется, вначале изображение должно быть загружено или создано при помощи функции imageCreate(), т.е. мы должны знать его идентификатор im.

Если аргумент filename опущен, то сжатые данные в соответствующем формате выводятся прямо в стандартный выходной поток, т.е. в браузер. Нужный заголовок Content-type при этом не выводится, ввиду чего нужно выводить его вручную при помощи Header().

Фактически, вы должны вызвать одну из трех команд, в зависимости от типа изображения:

Header("Content-type: image/gif")

Т.к. библиотека GD, начиная с версии 1.6, не поддерживает формат GIF, данная функция используется редко.

[править] imageCopy

Копирование части рисунка.

Синтаксис:

int imageCopy(int dst_im, int src_im, int dst_x, int dst_y, int src_x, int src_y, int src_w, int src_h)

Функция копирует прямоугольную область начиная с позиции (src_x, src_y) шириной src_w и высотой src_h из рисунка src_im в рисунок dst_im, придав копируемой области смещение (dst_x, dst_y).

В следующем примере будет картинка file1.png целиком скопирована в file2.png

<?php
// Создаем первую картинку на основе готового изображения
$im1=imageCreateFromPNG("img/file1.png");
// Определяем ее размеры
$size_x=imageSX($im1);
$size_y=imageSY($im1);
// Создаем вторую пустую картинку
$im2=imageCreate($size_x,$size_y);
// Копируем рисунок целиком из первого изображения во второе
imageCopy($im2,$im1,0,0,0,0,$size_x,$size_y);
// Сохранение скопированной картинки в файле
imagePNG($im2, "img/file2.png");
?>

[править] imageCopyResized

Копирование части рисунка с масштабированием.

Синтаксис:

int imageCopyResized(int dst_im, int src_im, int dstX, int dstY, int srcX, int srcY, int dstW, int dstH, int srcW, int srcH)

Эта функция - одна из самых мощных и универсальных. С помощью нее можно копировать изображения (или их участки), перемещать или масштабировать их.

dst_im задает идентификатор изображения, в который будет помещен результат работы функции. Это изображение должно уже быть создано или загружено и иметь надлежащие размеры.

src_im - идентификатор изображения, над которым проводится работа. Впрочем, src_im и dst_imмогут и совпадать.

Параметры srcX, srcY, srcW, srcH задают область внутри исходного изображения, над которой будет осуществлена операция - соответственно, координаты ее верхнего левого угла, ширину и высоту.

Наконец, четверка dstX, dstY, dstW, dstH задает то место на изображении dst_im, в которое будет "втиснут" указанный в предыдущей четверке прямоугольник. Заметьте, что, если ширина или высота двух прямоугольников не совпадают, то картинка автоматически будет нужным образом растянута или сжата.

В следующем примере файл file1.jpg уменьшается вдвое и записывается в файл file2.jpg:

<?php
$old = imageCreateFromJpeg("img/file1.jpg");
$w = imageSX($old);
$h = imageSY($old);
$w_new=rounr($w/2);
$h_new=round($h/2);
$new = imageCreate($w_new, $h_new);
imageCopyResized($new, $old, 0, 0, 0, 0, $w_new, $h_new, $w, $h);
imageJpeg($new, "img/file2.jpg");
imageDestroy($old);
imageDestroy($new);
?>

[править] imageDestroy

Уничтожение рисунка.

Синтаксис:

int imageDestroy(int im)

Функция уничтожает дескриптор im ранее созданного рисунка (наподобие закрытия файла fclose() после открытия fopen()).

Получено с http://spravkaweb.local/index.php/php/image/gd/move
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 15:06, 18 февраля 2007.
  • К этой странице обращались 129 раз.
1.31280183792


Справочник по PHP : Графика : Работа с изображениями и библиотека GD : Параметры изображения — Справочник Web-языков

Справочник по PHP : Графика : Работа с изображениями и библиотека GD : Параметры изображения

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Взаимодействие с базами данных : База данных MySQL : Обработка результатов запроса
Главная | ::. | PHP | ::. | Графика | ::. | Работа с изображениями и библиотека GD | ::. | Параметры изображения
 |  |  |  |  |  |  |  | Манипулирование изображениями

Содержание

  • 1 Применение и установка
  • 2 imageTypes
  • 3 GetImageSize
  • 4 imageSX
  • 5 imageSY
  • 6 read_exif_data
  • 7 imageInterlace
  • 8 gd_info
  • 9 image_type_to_mime_type

[править] Применение и установка

Здесь мы рассмотрим идею создания рисунков сценарием "на лету". Это очень может пригодиться при создании сценариев-счетчиков, графиков, картинок-заголовков, да и многого другого.

Для деятельности такого рода существует специальная библиотека под названием GD. Она содержит в себе множество функций (такие как рисование линий, растяжение/сжатие изображения, заливка до границы, вывод текста и т.д.), которые могут использовать программы, поддерживающие работу с данной библиотекой.

Поддержка GD включается при компиляции и установке PHP. Возможно, некоторые хостинг-провайдеры ее не имеют.

Для подключения модуля на вашем локальном диске нужно открыть в Блокноте файл php.ini из каталога с файлами Windows (обычно C:\Windows)

Затем: 1. Настройте следующий параметр: extension_dir=C:\Program Files\PHP4\extensions

 Здесь мы уведомляем PHP, что модули он должен искать
 в каталоге C:\Program Files\PHP4\extensions.

2. Найдите закомментированную строку ;extension=php_gd.dll

  и разкомментируйте ее, т.е. уберите ; в начале.

3. Сохраните изменения в файле php.ini

[править] imageTypes

Определение графических форматов, поддерживаемых PHP.

Синтаксис:

int imageTypes(void)

Функция возвращает битовую маску графических форматов, которые поддерживает данная версия библиотеки GD: IMG_GIF | IMG_JPG | IMG_PNG | IMG_WBMP

<?php
if(imageTypes() && IMG_PNG) echo "формат PNG поддерживается";
?>

[править] GetImageSize

Определение размеров рисунка.

Синтаксис:

array GetImageSize(string filename [,array imageinfo])

Эта функция предназначена для быстрого определения в сценарии размеров (в пикселях) и формата рисунка, имя файла которого передано ей в первом параметре. Она возвращает список из четырех элементов. Первый элемент (с ключем 0) хранит ширину картинки в пикселях, второй (с ключем 1) - его высоту. Ячейка массива с ключем 2 определяется форматом изображения: 1, если это GIF, 2 в случае JPG, 3 для PNG и 4 - SWF. Следующий элемент, имеющий ключ 3, будет содержать после вызова функции строку примерно следующего вида: height=sx width=sy, где sx и sy - соответственно ширина и высота изображения. Это применение задумывалось для того, чтобы облегчить вставку данных о размере изображения в тег <img>, который может быть сгенерирован сценарием:

<?php
$size_img=GetImageSize("img/image.jpg");
echo "<IMG src='img/image.jpg' $size_img>";
?>

Если при обращении к функции был указан второй необязательный массив imageinfo, в него можно записать дополнительную информацию о файле. Это могут быть, например, различные маркеры JPG APP (внедренная информация). Функция iptcparse() позволяет конвертировать эти данные в читаемый вид:

<?php
$size_img=GetImageSize("img/image.jpg", &$info_arr);
if(isset($info_Arr["APP13"])) {
  $iptc = iptcparse($info_arr["APP13"]);
  var_dump($iptc);
};
?>

Данная функция не требует наличия библиотеки GD.

[править] imageSX

Определение ширины рисунка.

Синтаксис:

int imageSX(int im)

Функция возвращает горизонтальный размер изображения, заданного своим идентификатором im, в пикселях.

[править] imageSY

Определение высоты рисунка.

Синтаксис:

int imageSY(int im)

Функция возвращает вертикальный размер изображения, заданного своим идентификатором im, в пикселях.

[править] read_exif_data

Чтение заголовков EXIF из файла JPEG.

Синтаксис:

array read_exif_data(string filename)

Параметр filename не может быть URL.

Функция возвращает ассоциативный массив, в котором индексами являются имена заголовков EXIF.

Заголовки EXIF обычно хранят информацию цифровых камер (в различном виде).

<?php
$exif = read_exif_data("img/file.jpg");
print_r($exif);
?>

Данный пример выведет что-то наподобие:

Array
(
    [FileName] => file.jpg
    [FileDateTime] => 1064566998
    [FileSize] => 31646
    [CameraMake] => Eastman Kodak Company
    [CameraModel] => KODAK DC265 ZOOM DIGITAL CAMERA (V01.00)
    [DateTime] => 2002:08:31 02:12:45
    [Height] => 454
    [Width] => 620
    [IsColor] => 1
    [FlashUsed] => 0
    [FocalLength] => 8.0mm
    [RawFocalLength] => 8
    [ExposureTime] => 0.004 s (1/250)
    [RawExposureTime] => 0.0040000001899898
    [ApertureFNumber] => f/ 9.5
    [RawApertureFNumber] => 9.5100002288818
    [FocusDistance] => 16.66m
    [RawFocusDistance] => 16.659999847412
    [Orientation] => 1
    [ExifVersion] => 0200
)

Данная функция доступна, если подключена библиотека EXIF.

Для этого необходимо либо снять комментарий со строки ;extension=php_exif.dll в файле php.ini (должно быть extension=php_exif.dll), либо откомпилировать PHP с параметром --enable-exif.

Для работы этой функции библиотека GD не требуется.

[править] imageInterlace

Установка черезстрочности.

Синтаксис:

int imageInterlace(int im [, int interlace])

Если в функции задан второй необязательный параметр interlace, и он равен 1, то рисунок im отображается черезстрочно, если равен 0, то последовательно.

Функция возвращает текущую установку черезстрочности.

[править] gd_info

Возвращает информацию о библиотеке GD.

Синтаксис:

array gd_info(void)

Функция возвращает массив, содержащий версию и параметры установленной библиотеки GD.

<?php
$gd=gd_info();
echo "<pre>";
print_r($gd);
echo "</pre>";
?>

Приведенный пример выведет примерно следующее:

Array
(
    [GD Version] => bundled (2.0.22 compatible)
    [FreeType Support] => 1
    [FreeType Linkage] => with freetype
    [T1Lib Support] =>
    [GIF Read Support] => 1
    [GIF Create Support] =>
    [JPG Support] => 1
    [PNG Support] => 1
    [WBMP Support] => 1
    [XBM Support] => 1
    [JIS-mapped Japanese Font Support] =>
)

[править] image_type_to_mime_type

Возвращает Mime-Type типа изображения.

Синтаксис:

string image_type_to_mime_type( int imagetype)

Функция возвращает MIME-тип картинки, заданный константой в параметре imagetype.

<?php
header("Content-type: " . image_type_to_mime_type(IMAGETYPE_PNG));
?>

Список констант и возвращаемых значений функции image_type_to_mime_type():

  • IMAGETYPE_GIF - image/gif
  • IMAGETYPE_JPEG - image/jpeg
  • IMAGETYPE_PNG - image/png
  • IMAGETYPE_SWF - application/x-shockwave-flash
  • IMAGETYPE_PSD - image/psd
  • IMAGETYPE_BMP - image/bmp
  • IMAGETYPE_TIFF_II - image/tiff
  • IMAGETYPE_TIFF_MM - image/tiff
  • IMAGETYPE_JPC - application/octet-stream
  • IMAGETYPE_JP2 - image/jp2
  • IMAGETYPE_JPX - application/octet-stream
  • IMAGETYPE_JB2 - application/octet-stream
  • IMAGETYPE_SWC - application/x-shockwave-flash
  • IMAGETYPE_IFF - image/iff
  • IMAGETYPE_WBMP - image/vnd.wap.wbmp
  • IMAGETYPE_XBM - image/xbm

Данная функция не требует наличия библиотеки GD.

Получено с http://spravkaweb.local/index.php/php/image/gd/param
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:58, 18 февраля 2007.
  • К этой странице обращались 156 раз.
1.5490860939


Справочник по PHP : Графика : Работа с изображениями и библиотека GD : Работа с цветом в формате RGB — Справочник Web-языков

Справочник по PHP : Графика : Работа с изображениями и библиотека GD : Работа с цветом в формате RGB

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Манипулирование изображениями
Главная | ::. | PHP | ::. | Графика | ::. | Работа с изображениями и библиотека GD | ::. | Работа с цветом в формате RGB
 |  |  |  |  |  |  |  | Графические примитивы

Содержание

  • 1 imageColorAllocate
  • 2 imageColorDeAllocate
  • 3 imageColorSet
  • 4 imageColorClosest
  • 5 imageColorTransparent
  • 6 imageColorsForIndex
  • 7 imageColorAt
  • 8 imageColorsTotal
  • 9 imageColorExact
  • 10 imageColorResolve
  • 11 imageGammaCorrect

[править] imageColorAllocate

Создание нового цвета и занесение его в палитру рисунка.

Синтаксис:

int imageColorAllocate(int im, int red, int green, int blue)

Функция возвращает идентификатор цвета, связанного с соответствующей тройкой RGB. Первым параметром функция требует идентификатор изображения, загруженного в память или созданного до этого.

Параметры red, green и blue задают красный, зеленый и синий компоненты цвета соответственно. Значения этих параметров должны лежать в пределах от 0 до 255, или от 0x00 до 0xFF.

Практически каждый цвет, который планируется в дальнейшем использовать, должен быть получен (определен) при помощи вызова этой функции.

Пример: Пример использования функции imageColorAllocate():

<?php
. . .
// белый
$white = imagecolorallocate($im, 255, 255, 255);
$white = imagecolorallocate($im, 0xFF, 0xFF, 0xFF);
// черный
$black = imagecolorallocate($im, 0, 0, 0);
$black = imagecolorallocate($im, 0x00, 0x00, 0x00);
. . .
?>

[править] imageColorDeAllocate

Исключение цвета из палитры рисунка.

Синтаксис:

int imageColorDeAllocate(int im, int color)

Эта функция удаляет из палитры рисунка im цвет color, который был предварительно занесен в рисунок функцией imageColorAllocate().

Пример: Пример использования функции imageColorDeAllocate():

<?php
. . .
$white = imageColorAllocate ($im, 255, 255, 255);
imageColorDeAllocate ($im, $white);
. . .
?>

[править] imageColorSet

Замена цвета определенного элемента палитры.

Синтаксис:

bool imageColorSet(int im, int index, int red, int green, int blue)

Данная функция устанавливает для элемента палитры index рисунка im значения компонент цвета: red (красный), green (зеленый), blue (синий). При этом все части рисунка, закрашенные данным цветом, также изменят свой оттенок.

[править] imageColorClosest

Получение цвета палитры, наиболее близкого к указанному.

Синтаксис:

int imageColorClosest(int im, int red, int green, int blue)

Вместо того, чтобы пытаться выискать свободное место в палитре цветов, эта функция просто возвращает идентификатор цвета, уже существующего в рисунке и находящегося ближе всего к затребованному. Таким образом, нового цвета в палитру не добавляется. Если палитра не велика, то функция может вернуть не совсем тот цвет, который вы ожидаете. Например, в палитре из трех цветов "красный-зеленый-синий" на запрос желтого цвета будет, скорее всего, возвращен идентификатор зеленого - он ближе всего с точки зрения GD соответствует понятию "зеленый".

[править] imageColorTransparent

Определение цвета прозрачности.

Синтаксис:

int imageColorTransparent(int im [,int color])

Эта функция указывает GD, что соответствующий цвет color (заданный своим идентификатором при помощи функции imageColorAllocate()) в изображении im (im - идентификатор изображения, заданный функцией imageCreate()) должен обозначиться как прозрачный. Возвращает идентификатор установленного до этого прозрачного цвета, либо false, если таковой не был определен ранее.

Надо отметить, что не все форматы поддерживают задание прозрачного цвета - например, JPEG не может его содержать.

[править] imageColorsForIndex

Получение RGB-составляющих элемента палитры.

Синтаксис:

array imageColorsForIndex(int im, int index)

Функция возвращает ассоциативный массив с ключами red, green, blue (именно в таком порядке), которым соответствуют значения, равные величинам компонент RGB в идентификаторе цвета index. Но мы можем и не обращать особого внимания на ключи и преобразовать возвращенное значение как список:

<?php
. . .
$color=imageColorAt($im,0,0);
list($r,$g,$b)=array_values(imageColorsForIndex($im,$color));
echo "R=$r, g=$g, b=$b";
. . .
?>

[править] imageColorAt

Возвращает индекс цвета точки.

Синтаксис:

int imageColorAt(int im, int x, int y)

Эта функция возвращает цвет точки, расположенной на координатах (x, y). Если PHP скомпилирован с GD library 2.0 или выше, а картинка - truecolor, то эта функция возвратит идентификатор цвета, а не его RGB-представление.

<?php
$im = imageCreateFromPng("file.png");
$rgb = ImageColorAt($im, 100, 100);
$r = ($rgb >> 16) & 0xFF;
$g = ($rgb >> 8) & 0xFF;
$b = $rgb & 0xFF;
?>

[править] imageColorsTotal

Получение количества цветов в палитре.

Синтаксис:

int imageColorsTotal(int im)

Функция возвращает число цветов в палитре указанного изображения.

[править] imageColorExact

Получение индекса цвета палитры.

Синтаксис:

int imageColorExact(int im, int red, int green, int blue)

Функция возвращает индекс указанного цвета (red, green, blue) в палитре изображения im.

Функция возвратит -1, если указанного цвета нет в палитре изображения.

[править] imageColorResolve

Нахождение или создание указанного цвета.

Синтаксис:

int imageColorResolve(int im, int red, int green, int blue)

Функция возвращает индекс указанного цвета (red, green, blue) в палитре изображения im.

В случае, если такой цвет в палитре отсутствует, то он создается.

[править] imageGammaCorrect

Применение гамма-коррекции рисунка.

Синтаксис:

int imageGammaCorrect(int im, double inputgamma, double outputgamma)

Эта функция производит исправления гаммы к изображению, заданному дескриптором im. Параметр inputgamma задает входную гамму, а outputgamma - гамму вывода.

Получено с http://spravkaweb.local/index.php/php/image/gd/rgb
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 15:23, 18 февраля 2007.
  • К этой странице обращались 87 раз.
1.43076992035


Справочник по PHP : Графика : Работа с изображениями и библиотека GD : Работа со шрифтами TrueType и PostScript Type 1 — Справочник Web-языков

Справочник по PHP : Графика : Работа с изображениями и библиотека GD : Работа со шрифтами TrueType и PostScript Type 1

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Работа с фиксированными шрифтами
Главная | ::. | PHP | ::. | Графика | ::. | Работа с изображениями и библиотека GD | ::. | Работа со шрифтами TrueType и PostScript Type 1
 |  |  |  |  |  |  |  | PDF-документы : Введение

Библиотека GD поддерживает также работу со шрифтами PostScript и TrueType. Для того чтобы заработали приведенные ниже функции, PHP должен быть откомпилирован и установлен вместе с библиотекой FreeType, доступной по адресу http://www.freetype.org. В Windows-версии PHP она установлена по умолчанию.

Содержание

  • 1 imageTTFText
  • 2 imageTTFBBox
  • 3 imagePSLoadFont
  • 4 imagePSFreeFont
  • 5 imagePSEncodeFont
  • 6 imagePsExtendFont
  • 7 imagePsSlantFont
  • 8 imagePSBBox
  • 9 imagePSText

[править] imageTTFText

Рисование текста шрифтом TrueType.

Синтаксис:

array imageTTFText(int im, int size, int angle, int x, int y, int color, string fontfile, string text)

Эта функция помещает строку text в изображение im цветом color. Как обычно, color должен представлять собой допустимый идентификатор цвета. Параметр angle задает угол наклона в градусах выводимой строки, отсчитываемой от горизонтали против часовой стрелки. Координаты (x, y) указывают положение так называемой базовой точки строки (обычно это ее левый нижний угол). Параметр size задает размер шрифта, который будет использоваться при выводе строки. fontfile должен содержать имя TTF-файла, в котором и храниться шрифт.

Функция возвращает список из 8 элементов. Первая их пара задает координаты (x,y) верхнего левого угла прямоугольника, описанного вокруг строки текста в изображении, вторая пара - координаты верхнего правого угла, и т.д. Так как в общем случае строка может иметь любой наклон angle, здесь требуются 4 пары координат.

Строка текста text может содержать символьные последовательности UTF-8 (в виде {) для вывода символов с кодами, большими 255.

При использовании отрицательного значения индекса цвета color отключается сглаживание шрифта (antialiasing).

Данная функция требует библиотеке GD и FreeType.

<?php
  header("Content-type: image/jpeg");
  $im = imagecreate(400, 30);
  $white = imagecolorallocate($im, 255, 255, 255);
  $black = imagecolorallocate($im, 0, 0, 0);

  // Replace path by your own font path
  imagettftext($im, 20, 0, 10, 20, $black, "/path/arial.ttf",
  "Testing... Omega: &#937;");
  imagejpeg($im);
  imagedestroy($im);
?>

Следующий пример выводит строку по центру рисунка

<?php
$gi = imageCreate(200,100);
$bg = imageColorAllocate($gi,0,220,0);
$tx = imageColorAllocate($gi,25,2,228);
$w = imageSX($gi); // ширина рисунка
$h = imageSY($gi); // высота рисунка
imageFilledRectangle($gi,0,0,$w,$h,$bg);

$szf = 20; // размер шрифта
$ang = 240; // угол поворота строки
$str = "Heyou"; // текст строки
$font = "symbol.ttf" // файл шрифта
$sz = imageTTFBBox($szf,$ang,$font,$str);
$sdx = $sz[4]/2;
$sdy = ($sz[7]+$sz[3])/2;
imageTTFText($gi,$szf,$ang,$w/2-$sdx,$h/2-$sdy,$tx,$font,$str);
Header("Content-Type: image/png");
imagePng($gi,"file.png");
?>

[править] imageTTFBBox

Расчет площади, занимаемой строкой шрифта TrueType.

Синтаксис:

array imageTTFBBox(int size, int angle, string fontfile, string text)

Эта функция ничего не выводит в изображение, а просто определяет, какой размер и положение заняла бы строка текста text размера size, выведенная под углом angle в какой-нибудь рисунок. Параметр fontfile задает абсолютный путь к файлу шрифта, который будет использован при выводе.

Возвращаемый список содержит всю информацию о размерах строки в формате, похожем на тот, что выдает функция imageTTFText(). Однако порядок точек в нем отличается.

Содержимое массива, возвращаемого функцией imageTTFBBox():

  • 0 и 1 - (x,y) левого нижнего угла
  • 2 и 3 - (x,y) правого нижнего угла
  • 4 и 5 - (x,y) правого верхнего угла
  • 6 и 7 - (x,y) левого верхнего угла

Координаты могут иметь отрицательные значения.

Функция требует библиотеки GD и FreeType.

[править] imagePSLoadFont

Загрузка из файла шрифта PostScript Type 1.

Синтаксис:

int imagePSLoadFont(string filename)

Возвращает дескриптор загруженного шрифта или FALSE при ошибке (также выводится предупреждение).

<?php
header("Content-type: image/jpeg");
$im = imagecreate(350, 45);
$black = imagecolorallocate($im, 0, 0, 0);
$white = imagecolorallocate($im, 255, 255, 255);
$font = imagepsloadfont("bchbi.pfb"); // or locate your .pfb files on your machine
imagepstext($im, "Testing... It worked!", $font, 32, $white, $black, 32, 32);
imagepsfreefont($font);
imagejpeg($im, "", 100); //for best quality...your mileage may vary
imagedestroy($im);
?>

Эта функция доступна только в том случае, если PHP был скомпилирован с опцией --enable-t1lib.

[править] imagePSFreeFont

Выгрузка шрифта PostScript Type 1.

Синтаксис:

void imagePSFreeFont(int fontindex)

Данная функция освобождает память от шрифта, заданного параметром fontindex.

Эта функция доступна только в том случае, если PHP был скомпилирован с опцией --enable-t1lib.

[править] imagePSEncodeFont

Установка схемы перекодировки текста.

Синтаксис:

int imagePSEncodeFont(int font_ndex, string encodingfile)

Загружает файл перекодировки encodingfile для шрифта font_index. Поскольку шрифты PostScript по умолчанию не используют символы с кодами, большими 127, перекодировка требуется при необходимости использования не английского языка. Формат файла описан в документации Tllibs, также с библиотекой поставляются 2 готовых файла: IsoLatinl.enc и IsoL.atin2.enc.

Если перекодировка используется постоянно, установите параметр ps.default_encoding в файле конфигурации со значением имени файла перекодировки, который будет загружаться автоматически.

Эта функция доступна только в том случае, если PHP был скомпилирован с опцией --enable-t1lib.

[править] imagePsExtendFont

Масштабирование шрифта.

Синтаксис:

bool imagePsExtendFont (int font_index, float extend)

Функция производит растяжение или сжатие шрифта, заданного параметром font_index до размера, заданного параметром extend.

Если значение параметра extend меньше 1, то шрифт будет уменьшаться.

Эта функция доступна только в том случае, если PHP был скомпилирован с опцией --enable-t1lib.

[править] imagePsSlantFont

Установка наклона шрифта.

Синтаксис:

bool imagePsSlantFont(int font_index, double slant)

Функция устанавливает наклон шрифта font_index в значение, заданное параметром slant.

Эта функция доступна только в том случае, если PHP был скомпилирован с опцией --enable-t1lib.

[править] imagePSBBox

Расчет площади, занимаемой строкой шрифта PostScript Type 1.

Синтаксис:

array imagePSBBox( string text, int font, int size [, int space [, int tightness [, float angle]]])

Расчеты производятся на основании аргументов:

  • size - размер шрифта в пикселах;
  • space — изменение размера пробелов по отношению к нормальному (может быть отрицательным);
  • tightness — промежутки между символами по отношении) к нормальному (может быть отрицательным);
  • angle — угол наклона строки в градусах.

Значения space и tightness измеряются в долях пробела (1/1000).

Аргументы space, tightness, angle не обязательны.

Результаты расчета недостаточно точны. Функция возвращает массив:

  • 0 - нижний левый угол, Х-координата;
  • 1 - нижний левый угол, Y-координата;
  • 2 - верхний правый угол, Х-координата;
  • 3 - верхний правый угол, Y- координата.

Эта функция доступна только в том случае, если PHP был скомпилирован с опцией --enable-t1lib.

[править] imagePSText

Вывод текста поверх рисунка шрифтом PostScript Type 1.

Синтаксис:

array imagePSText ( resource image, string text, int font, int size, int foreground, int background, int x, int y [, int space [, int tightness [, float angle [, int antialias_steps]]]])

Параметр size задает размер шрифта.

Координаты x, у указывают левый нижний угол первого символа.

Аргументами foreground и background задаются цвета текста и фона (фон необходим только для сглаживания шрифта).

Аргумент antialias_steps позволяет указать число цветов, используемых при сглаживании текста (допустимые значения 4 и 16). Для шрифтов размером меньше 20 используйте большее значение, так как это улучшает читабельность; для больших шрифтов используйте меньшее значение, так как это увеличивает быстродействие.

Параметр angle задает наклон текста в градусах.

Функция возвращает массив, подобно imagepsbbox().

Эта функция доступна только в том случае, если PHP был скомпилирован с опцией --enable-t1lib.

Получено с http://spravkaweb.local/index.php/php/image/gd/truetype
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 17:45, 18 февраля 2007.
  • К этой странице обращались 84 раза.
1.17814898491


Справочник по PHP : Графика : PDF-документы : Размещение рисунков — Справочник Web-языков

Справочник по PHP : Графика : PDF-документы : Размещение рисунков

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Черчение и заполнение фигур
Главная | ::. | PHP | ::. | Графика | ::. | PDF-документы | ::. | Размещение рисунков
 |  |  |  |  |  |  |  | Стиль документа

Содержание

  • 1 pdf_open_gif
  • 2 pdf_open_png
  • 3 pdf_open_jpeg
  • 4 pdf_open_tiff
  • 5 pdf_open_image_file
  • 6 pdf_open_memory_image
  • 7 pdf_close_image
  • 8 pdf_get_image_height
  • 9 pdf_get_image_width
  • 10 pdf_place_image
  • 11 pdf_put_image
  • 12 pdf_execute_image

[править] pdf_open_gif

Открытие рисунка GIF.

Синтаксис:

void pdf_open_gif(int pdf_document, string filename)

Используйте функцию pdf_open_image_file().

<?php
$im = pdf_open_gif($pdf, "test.gif");
pdf_place_image($pdf, $im, 100, 100, 1);
pdf_close_image($pdf, $im);
?>

[править] pdf_open_png

Открытие рисунка PNG.

Синтаксис:

void pdf_open_png(int pdf_document, string filename)

Используйте функцию pdf_open_image_file().

[править] pdf_open_jpeg

Открытие рисунка JPEG.

Синтаксис:

void pdf_open_jpeg(int pdf_document, string filename)

Используйте функцию pdf_open_image_file().

[править] pdf_open_tiff

Открытие рисунка TIFF.

Синтаксис:

void pdf_open_tiff(int pdf_document, string filename)

Используйте функцию pdf_open_image_file().

[править] pdf_open_image_file

Чтение рисунка из файла.

Синтаксис:

void pdf_open_tiff(int pdf_document, string format, string filename)

Эта функция загружает рисунок формата format из файла filename и возвращает его идентификатор.

Возможные форматы:

  • PNG
  • TIFF
  • JPEG
  • GIF
<?php
$pim = pdf_open_image_file($pdf, "png", "pic.png");
pdf_place_image($pdf, $pim, 100, 100, 1);
pdf_close_image($pdf, $pim);
?>

Эта функция заменяет pdf_open_image(), pdf_open_gif(), pdf_open_tiff(), pdf_open_png().

[править] pdf_open_memory_image

Открытие рисунка, созданного графическими функциями PHP.

Синтаксис:

void pdf_open_memory_image(int pdf_document, int image)

Функция принимает дескриптор рисунка, созданного PHP, и делает его доступным для документа pdf. Функция возвращает идентификатор рисунка pdf.

<?php
$im = ImageCreate(100, 100);
$col = ImageColorAllocate($im, 80, 45, 190);
ImageFill($im, 10, 10, $col);
$pim = pdf_open_memory_image($pdf, $im);
ImageDestroy($im);
pdf_place_image($pdf, $pim, 100, 100, 1);
pdf_close_image($pdf, $pim);
?>

[править] pdf_close_image

Закрытие рисунка.

Синтаксис:

void pdf_close_image(int pdf_document, int image)

Закрывает рисунок, открытый функциями pdf_open_().

[править] pdf_get_image_height

Установка высоты рисунка в пикселах.

Синтаксис:

void pdf_get_image_height(int pdf_document, int image)

[править] pdf_get_image_width

Установка ширины рисунка в пикселах.

Синтаксис:

void pdf_get_image_width(int pdf_document, int image)

[править] pdf_place_image

Размещение рисунка на странице.

Синтаксис:

void pdf_place_image(int pdf_document, int image, double x, double y, souble scale)

Позиция размещения задается (x,y); масштаб - scale.

[править] pdf_put_image

Сохранение рисунка в pdf для дальнейшего использования.

Синтаксис:

void pdf_put_image(int pdf_document, int image)

Функция внедряет рисунок в документ без его отображения. Затем рисунок может быть размещен на странице функцией pdf_execute_image() необходимое число раз. Полезно при многократной вставке рисунка (уменьшает размер файла).

Начиная с версии 2.01 pdflib функция бесполезна и выводит только предупреждение.

[править] pdf_execute_image

Размещение сохраненного рисунка на странице.

Синтаксис:

void pdf_execute_image(int pdf_document, int image, double x, double y, double scale)

Отображает рисунок, внедренный функцией pdf_put_image().

Начиная с версии 2.01 pdflib функция бесполезна и выводит только предупреждение.

<?php
$im = ImageCreate(100, 100);
$col1 = ImageColorAllocate($im, 80, 45, 190);
ImageFill($im, 10, 10, $col1);
$pim = pdf_open_memory_image($pdf, $im);
pdf_put_image($pdf, $pim);
pdf_execute_image($pdf, $pim, 100, 100, 1);
// 200%
pdf_execute_image($pdf, $pim, 200, 200, 2);
pdf_close_image($pdf, $pim);
?>
Получено с http://spravkaweb.local/index.php/php/image/pdf/img
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:34, 19 февраля 2007.
  • К этой странице обращались 70 раз.
1.67427802086


Справочник по PHP : Графика : PDF-документы : Введение — Справочник Web-языков

Справочник по PHP : Графика : PDF-документы : Введение

 |  |  |  |  |  |  |  | Работа с изображениями и библиотека GD : Работа со шрифтами TrueType и PostScript Type 1
Главная | ::. | PHP | ::. | Графика | ::. | PDF-документы | ::. | Введение
 |  |  |  |  |  |  |  | Открытие документа

PDF-функции позволяют PHP создавать PDF-файлы с помощью библиотеки PDF, созданной Томасом Мерзем; также могут потребоваться библиотеки JPEG и TIFF.

С pdflib поставляется хорошая документация, описывающая возможности библиотеки. Имена функций и аргументы идентичны в библиотеке и PHP. Размеры и координаты измеряются в единицах Postscript (72 на дюйм), но это зависит от выбранного разрешения.

Аналогом библиотеки является ClibPDF.

Версии ниже 3.0 pdflib не поддерживается в PHP 4.

<?php
$fp = fopen("test.pdf". "w");
$pdf = pdf_open($fp);
pdf_set_info($pdf, "Author", "Uwe Streinmann");
pdf_set_info($pdf, "Title", "Test for PHP PDFlib");
pdf_set_info($pdf, "Creator", "See Author");
pdf_set_info($pdf, "Subject", "Testing");
pdf_begin_page($pdf, 595, 842);
pdf_add_outline($pdf, "Page 1");
pdf_set_font("$pdf, "Times-Roman", 30, "host");
pdf_set_value($pdf, "textrendering", 1);
pdf_show_xy($pdf, "Times Roman outlined", 50, 750);
pdf_moveto($pdf, 50, 740);
pdf_lineto($pdf, 330, 740);
pdf_stroke($pdf);
pdf_end_page($pdf);
pdf_close($pdf);
fclose($fp);
echo "<A href=getpdf.php>finished</A>";
?>
<?php
// Сценарий getpdf.php просто возвращает документ pdf
$fp = fopen("test.pdf", "r");
header("Content-type: application/pdf");
fpassthru($fp);
fclose($fp);
?>
Получено с http://spravkaweb.local/index.php/php/image/pdf/introduction
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 16:58, 19 февраля 2007.
  • К этой странице обращались 87 раз.
1.53179192543


Справочник по PHP : Графика : PDF-документы : Открытие документа — Справочник Web-языков

Справочник по PHP : Графика : PDF-документы : Открытие документа

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Введение
Главная | ::. | PHP | ::. | Графика | ::. | PDF-документы | ::. | Открытие документа
 |  |  |  |  |  |  |  | Работа с текстом

Содержание

  • 1 pdf_set_info
  • 2 pdf_open
  • 3 pdf_close
  • 4 pdf_begin_page
  • 5 pdf_end_page

[править] pdf_set_info

Заполнение поля информации документа.

Синтаксис:

void pdf_set_info(int pdf_document, string fieldname, string value)

Возможные поля fieldname:

  • Subject
  • Title
  • Creator
  • Author
  • Keywords
  • Одно, определяемое пользователем.

Функция должна вызываться до создания страниц.

<?php
$fd = fopen("test.pdf", "w");
$pdfdoc = pdf_open($fd);
pdf_set_info($pdfdoc, "Author", "Имя автора");
pdf_set_info($pdfdoc, "Creator", "Название создателя");
pdf_set_info($pdfdoc, "Title", "Заголовок");
pdf_set_info($pdfdoc, "Subject", "Тема");
pdf_set_info($pdfdoc, "Kewwords", "Ключевые, слова");
pdf_set_info($pdfdoc, "CustomField", "Чтото еще");
pdf_begin_page($pdfdoc, 595, 842);
pdf_end_page($pdfdoc);
pdf_close($pdfdoc);
?>

Эта функция заменяет собой pdf_set_info_keyword(), pdf_set_info_title(), pdf_set_info_subject(), pdf_set_info_creator().

[править] pdf_open

Открытие нового документа pdf.

Синтаксис:

int pdf_open(int file)

Функция делает файл, открытый функцией fopen(), документом pdf. Если не указывать дескриптор файла, он создается в памяти и затем может выводиться на стандартный поток вывода или отсылаться броузеру. Функция возвращает дескриптор документа, который следует указывать в последующих pdf-функциях.

[править] pdf_close

Закрытие документа pdf.

Синтаксис:

void pdf_close(int pdf_document)

[править] pdf_begin_page

Начало новой страницы.

Синтаксис:

void pdf_begin_page(int pdf_document, double width, double height)

Аргументы height и width задают высоту и ширину страницы. После внесения на страницу информации ее следует закрыть функцией pdf_end_page().

[править] pdf_end_page

Завершение страницы.

Синтаксис:

void pdf_end_page(int pdf_document)

После этой функции модификация этой страницы невозможна.

Получено с http://spravkaweb.local/index.php/php/image/pdf/open
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 17:02, 19 февраля 2007.
  • К этой странице обращались 62 раза.
1.41600418091


Справочник по PHP : Графика : PDF-документы : Черчение и заполнение фигур — Справочник Web-языков

Справочник по PHP : Графика : PDF-документы : Черчение и заполнение фигур

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Черчение и заполнение фигур
Главная | ::. | PHP | ::. | Графика | ::. | PDF-документы | ::. | Черчение и заполнение фигур
 |  |  |  |  |  |  |  | Размещение рисунков

Содержание

  • 1 pdf_curveto
  • 2 pdf_lineto
  • 3 pdf_circle
  • 4 pdf_arc
  • 5 pdf_rect
  • 6 pdf_closepath
  • 7 pdf_stroke
  • 8 pdf_closepath_stroke
  • 9 pdf_fill
  • 10 pdf_fill_stroke
  • 11 pdf_closepath_fill_stroke
  • 12 pdf_endpath
  • 13 pdf_clip
  • 14 pdf_setgray_fill
  • 15 pdf_setgray_stroke
  • 16 pdf_setgray
  • 17 pdf_setrgbcolor_fill
  • 18 pdf_setrgbcolor_stroke
  • 19 pdf_setrgbcolor
  • 20 pdf_add_outline
  • 21 pdf_set_transition
  • 22 pdf_set_duration

[править] pdf_curveto

Черчение кривой.

Синтаксис:

void pdf_curveto(int pdf_document, double x1, double y1, double x2, double y2, double x3, double y3)

Чертит кривую Безье от текущей точки до (x3,y3), использую точки (x1,y1) и (x2,y2) как ориентирующие.

[править] pdf_lineto

Черчение отрезка.

Синтаксис:

void pdf_lineto(int pdf_document, double x, double y)

Чертит линию от текущей точки до указанной (x,y).

[править] pdf_circle

Черчение окружности.

Синтаксис:

void pdf_circle(int pdf_document, double x, double y, double radius)

[править] pdf_arc

Черчение дуги.

Синтаксис:

void pdf_arc(int pdf_document, double x, double y, double radius, double start, double end)

Начальный и конечный угол задаются в start и end.

[править] pdf_rect

Черчение прямоугольника.

Синтаксис:

void pdf_rect(int pdf_document, double x, double y, double width, double height)

Левый нижний угол задается (x,y); высота и ширина - height и width.

[править] pdf_closepath

Завершение текущего пути.

Синтаксис:

void pdf_closepath(int pdf_document)

Чертит линию от текущей точки до точки, где начиналась первая линия. Многие функции, например pdf_moveto(), pdf_circle(), pdf_rect() начинают новый путь.

[править] pdf_stroke

Заштриховка пути.

Синтаксис:

void pdf_stroke(int pdf_document)

Текущий путь - это совокупность всех линий. Без этой функции линии начерчены не будут.

[править] pdf_closepath_stroke

Черчение и закрытие пути.

Синтаксис:

void pdf_closepath_stroke(int pdf_document)

Это комбинация pdf_closepath() и pdf_stroke().

[править] pdf_fill

Заполнение пути цветом.

Синтаксис:

void pdf_fill(int pdf_document)

[править] pdf_fill_stroke

Заполнение пути цветом и закрытие его.

Синтаксис:

void pdf_fill_stroke(int pdf_document)

[править] pdf_closepath_fill_stroke

Черчение, закрашивание и закрытие пути.

Синтаксис:

void pdf_closepath_fill_stroke(int pdf_document)

[править] pdf_endpath

Завершение пути без его закрытия.

Синтаксис:

void pdf_endpath(int pdf_document)

[править] pdf_clip

Прикрепление всех линий к текущему пути.

Синтаксис:

void pdf_clip(int pdf_document)

[править] pdf_setgray_fill

Установка заполнения серым цветом.

Синтаксис:

void pdf_setgray_fill(int pdf_document, double gray_value)

[править] pdf_setgray_stroke

Установка штриховки серым цветом.

Синтаксис:

void pdf_setgray_stroke(int pdf_document, double gray_value)

[править] pdf_setgray

Установка заполнения и штриховки серым цветом.

Синтаксис:

void pdf_setgray(int pdf_document, double gray_value)

[править] pdf_setrgbcolor_fill

Установка заполнения цветом RGB.

Синтаксис:

void pdf_setrgbcolor_fill(int pdf_document, double red_value, double green_value, double blue_value)

[править] pdf_setrgbcolor_stroke

Установка штриховки цветом RGB.

Синтаксис:

void pdf_setrgbcolor_stroke(int pdf_document, double red_value, double green_value, double blue_value)

[править] pdf_setrgbcolor

Установка заполнения и штриховки цветом RGB.

Синтаксис:

void pdf_setrgbcolor(int pdf_document, double red_value, double green_value, double blue_value)

[править] pdf_add_outline

Добавление закладки для текущей страницы.

Синтаксис:

void pdf_add_outline(int pdf_document, string text [, int parent [, int open]])

Название закладки определяется аргументом text. Она становится дочерним объектом объекта parent и по умолчанию открыта (если аргумент open не равен 0). Возвращается идентификатор закладки, который может использоваться как родительский для других закладок.

[править] pdf_set_transition

Установка режима перехода между страницами.

Синтаксис:

void pdf_set_transition(int pdf_document, int transition)

Используйте функцию pdf_set_parameter() с параметром "transition".

[править] pdf_set_duration

Установка интервала между страницами.

Синтаксис:

void pdf_set_duration(int pdf_document, double duration)
Получено с http://spravkaweb.local/index.php/php/image/pdf/poly
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:30, 19 февраля 2007.
  • К этой странице обращались 69 раз.
1.6893119812


Справочник по PHP : Графика : PDF-документы : Стиль документа — Справочник Web-языков

Справочник по PHP : Графика : PDF-документы : Стиль документа

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Размещение рисунков
Главная | ::. | PHP | ::. | Графика | ::. | PDF-документы | ::. | Стиль документа

Содержание

  • 1 pdf_set_border_style
  • 2 pdf_set_border_color
  • 3 pdf_set_border_dash
  • 4 pdf_add_annotation

[править] pdf_set_border_style

Установка стиля обрамления примечаний и гиперссылок.

Синтаксис:

void pdf_set_border_style(int pdf_document, string style, double width)

Аргумент style может принимать значения "solid" или "dashed". Ширина задается аргументом width.

[править] pdf_set_border_color

Установка цвета обрамления примечаний и гиперссылок.

Синтаксис:

void pdf_set_border_color(int pdf_document, double red, double green, double blue)

Три компонента цвета могут принимать значения из диапазона от 0.0 до 1.0

[править] pdf_set_border_dash

Установка стиля окантовки ссылок и примечаний.

Синтаксис:

void pdf_set_border_dash(int pdf_document, double black, double white)

Устанавливает длину черных и белых полос прерывистых линий.

[править] pdf_add_annotation

Добавление примечания.

Синтаксис:

void pdf_add_annotation(int pdf_document, double llx, double lly, double urx, double ury, string title, string content)

Примечание предполагается в нижнем левом углу (llx, lly), верхний правый угол (urx, ury).

Получено с http://spravkaweb.local/index.php/php/image/pdf/style
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:37, 19 февраля 2007.
  • К этой странице обращались 63 раза.
1.17946600914


Справочник по PHP : Графика : PDF-документы : Работа с текстом — Справочник Web-языков

Справочник по PHP : Графика : PDF-документы : Работа с текстом

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Открытие документа
Главная | ::. | PHP | ::. | Графика | ::. | PDF-документы | ::. | Работа с текстом
 |  |  |  |  |  |  |  | Установка масштаба и системы координат

Содержание

  • 1 pdf_show
  • 2 pdf_show_boxed
  • 3 pdf_show_xy
  • 4 pdf_set_font
  • 5 pdf_set_leading
  • 6 pdf_set_parameter
  • 7 pdf_get_parameter
  • 8 pdf_set_value
  • 9 pdf_get_value
  • 10 pdf_set_text_rendering
  • 11 pdf_set_horiz_scaling
  • 12 pdf_set_text_rise
  • 13 pdf_set_text_matrix
  • 14 pdf_set_text_pos
  • 15 pdf_set_char_spacing
  • 16 pdf_set_word_spacing
  • 17 pdf_skew
  • 18 pdf_continue_text
  • 19 pdf_stringwidth
  • 20 pdf_save
  • 21 pdf_restore

[править] pdf_show

Вывод текста в текущую позицию.

Синтаксис:

void pdf_show(int pdf_document, string text)

Для вывода используются текущая позиция и текущий шрифт.

[править] pdf_show_boxed

Вывод текста в прямоугольную область.

Синтаксис:

void pdf_show_boxed(int pdf_document, string text, double x, double y, double width, double height, string mode [, string feature])

Левый нижний угол области вывода задается (x:y); высота и ширина - height, width.

Аргумент mode определяет выравнивание текста: если высота и ширина равны нулю, то возможны значения:

  • left
  • right
  • center,

если они не равны нулю, то

  • justify
  • fulljustify

Если аргумент feature содержит значение "blind", текст не отображается.

Функция возвращает число символов, которые не поместились в указанный прямоугольник.

[править] pdf_show_xy

Вывод текста в указанную позицию.

Синтаксис:

void pdf_show_xy(int pdf_document, string text, double x, double y)

[править] pdf_set_font

Выбор шрифта, его размера и кодировки.

Синтаксис:

void pdf_set_font(int pdf_document, string font_name, double size, string encoding [, int embed])

Аргумент вида кодировки encoding может принимать значения:

  • winansi (по умолчанию)
  • builtin
  • host
  • macroman и т.д.

Если для последнего аргумента задано значение 1, шрифт будет внедрен в документ pdf (иначе нет). Если шрифт распространен, внедрять его не следует из-за увеличения размера документа.

Функция должна вызываться после pdf_begin_page().

[править] pdf_set_leading

Установка промежутка между строками текста.

Синтаксис:

void pdf_set_leading(int pdf_document, double distance)

Используется при выводе текста функцией pdf_continue_text().

[править] pdf_set_parameter

Установка строкового значения параметра pdflib.

Синтаксис:

void pdf_set_parameter(int pdf_document, string name, string value)

[править] pdf_get_parameter

Получение строкового значения параметра pdflib.

Синтаксис:

void pdf_get_parameter(int pdf_document, string name [, double modifier])

Аргумент modifier используется при необходимости.

[править] pdf_set_value

Установка численного значения параметра pdflib.

Синтаксис:

void pdf_set_value(int pdf_document, string name, double value)

[править] pdf_get_value

Получение численного значения параметра pdflib.

Синтаксис:

void pdf_get_value(int pdf_document, string name [, double modifier])

Аргумент modifier используется при необходимости.

[править] pdf_set_text_rendering

Установка метода вывода текста.

Синтаксис:

void pdf_set_text_rendering(int pdf_document, string mode)

Устарела, используйте pdf_set_value().

[править] pdf_set_horiz_scaling

Установка масштабирования текста по горизонтали.

Синтаксис:

void pdf_set_horiz_scaling(int pdf_document, double scale)

[править] pdf_set_text_rise

Установка подъема текста.

Синтаксис:

void pdf_set_text_rise(int pdf_document, double rise)

[править] pdf_set_text_matrix

Установка матрицы преобразований шрифта.

Синтаксис:

void pdf_set_text_matrix(int pdf_document, array matrix)

Начиная с версии pdflib 2.3 эта функция недоступна.

[править] pdf_set_text_pos

Установка позиции шрифта.

Синтаксис:

void pdf_set_text_pos(int pdf_document, double x-coor, double y-coor)

Устанавливает позицию вывода текста последующим вызовом pdf_show().

[править] pdf_set_char_spacing

Установка интервала между символами.

Синтаксис:

void pdf_set_char_spacing(int pdf_document, double space)

Устарела, используйте pdf_set_value().

[править] pdf_set_word_spacing

Установка интервала между символами.

Синтаксис:

void pdf_set_word_spacing(int pdf_document, double space)

Устарела, используйте pdf_set_value().

[править] pdf_skew

Поворот системы координат.

Синтаксис:

void pdf_skew(int pdf_document, double alpha, double beta)

Угол поворота в градусах указывается относительно осей alpha (x) и beta (y). Углы не могут принимать значения 90 или 270 градусов.

[править] pdf_continue_text

Вывод текста со следующей строки.

Синтаксис:

void pdf_continue_text(int pdf_document, string text)

Расстояние между строками может быть установлено функцией pdf_set_leading().

[править] pdf_stringwidth

Вычисление ширины текста.

Синтаксис:

void pdf_stringwidth(int pdf_document, string text)

При вычислении длины строки используется текущий шрифт. Предварительно шрифт должен быть установлен с помощью pdf_set_font().

[править] pdf_save

Сохранение текущих установок.

Синтаксис:

void pdf_save(int pdf_document)

Действует подобно команде postscript gsave. Полезна при необходимости масштабировать или развернуть объект, не воздействуя на другие объекты. pdf_save() требует, чтобы затем была вызвана функция pdf_restore().

[править] pdf_restore

Восстановление ранее сохраненных установок.

Синтаксис:

void pdf_restore(int pdf_document)

Восстанавливает установки, сохраненные pdf_save(). Действует подобно команде postscript grestore.

<?php
pdf_save($pdf);
// всякие вращения и трансформации ...
pdf_restore($pdf);
?>
Получено с http://spravkaweb.local/index.php/php/image/pdf/text
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 18:04, 19 февраля 2007.
  • К этой странице обращались 67 раз.
1.19409799576


Справочник по PHP : Графика : PDF-документы : Установка масштаба и системы координат — Справочник Web-языков

Справочник по PHP : Графика : PDF-документы : Установка масштаба и системы координат

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Работа с текстом
Главная | ::. | PHP | ::. | Графика | ::. | PDF-документы | ::. | Установка масштаба и системы координат
 |  |  |  |  |  |  |  | Черчение и заполнение фигур

Содержание

  • 1 pdf_translate
  • 2 pdf_scale
  • 3 pdf_rotate
  • 4 pdf_setflat
  • 5 pdf_setlinejoin
  • 6 pdf_setlinecap
  • 7 pdf_setmiterlimit
  • 8 pdf_setlinewidth
  • 9 pdf_setdash
  • 10 pdf_moveto

[править] pdf_translate

Установка начала системы координат.

Синтаксис:

void pdf_translate(int pdf_document, double x, double y)

Координаты указываются относительно текущей точки отсчета. Затем, до начала рисования объектов, требуется установить текущую точку.

<?php
pdf_moveto($pdf, 0, 0);
pdf_lineto($pdf, 100, 100);
pdf_stroke($pdf);
psd_translate($pdf, 100, 100);
pdf_moveto($pdf, 0, 0);
pdf_lineto($pdf, 100, 100);
pdf_stroke($pdf);
?>

[править] pdf_scale

Установка масштабирования.

Синтаксис:

void pdf_scale(int pdf_document, double x_scale, double y_scale)
<?php
pdf_scale($pdf, 72.0, 72.0);
pdf_lineto($pdf, 1, 1); // на дюйм
pdf_stroke($pdf);
?>

[править] pdf_rotate

Установка угла вращения в градусах.

Синтаксис:

void pdf_rotate(int pdf_document, double angle)

[править] pdf_setflat

Установка равномерности.

Синтаксис:

void pdf_setflat(int pdf_document, double value)

Возможные значения параметра - от 0 до 100.

[править] pdf_setlinejoin

Установка параметра linejoin.

Синтаксис:

void pdf_setlinejoin(int pdf_document, double value)

Возможные значения параметра - от 0 до 2.

[править] pdf_setlinecap

Установка параметра linecap.

Синтаксис:

void pdf_setlinecap(int pdf_document, double value)

Возможные значения параметра - от 0 до 2.

[править] pdf_setmiterlimit

Установка параметра miter limit.

Синтаксис:

void pdf_miterlimit(int pdf_document, double value)

Возможные значения параметра - 1 и более.

[править] pdf_setlinewidth

Установка ширины строк.

Синтаксис:

void pdf_setlinewidth(int pdf_document, double width)

[править] pdf_setdash

Установка текущей точки.

Синтаксис:

void pdf_setdash(int pdf_document, double white, double black)

[править] pdf_moveto

Установка текущей точки.

Синтаксис:

void pdf_moveto(int pdf_document, double x, double y)
Получено с http://spravkaweb.local/index.php/php/image/pdf/xyz
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:23, 19 февраля 2007.
  • К этой странице обращались 65 раз.
1.61910700798


Справочник по PHP : Синтаксис языка и операторы : Выражения — Справочник Web-языков

Справочник по PHP : Синтаксис языка и операторы : Выражения

Главная | ::. | PHP | ::. | Синтаксис языка и операторы | ::. | Выражения
 |  |  |  |  |  | Функции работы с данными > Математические функции > Функции округления

Содержание

  • 1 if
  • 2 else
  • 3 elseif
  • 4 if ... endif
  • 5 while
  • 6 do_while
  • 7 for
  • 8 break
  • 9 continue
  • 10 switch
  • 11 require
  • 12 include
  • 13 function
  • 14 old_function
  • 15 class

[править] if

Позволяет организовывать выполнение фрагментов кода по условию.

Синтаксис :

if (выражение) statement

Может иметь неограниченную степень вложенности в другие IF.

if($a > $b) print "$a больше $b";
<?php
if($a > $b) {
    echo "$a больше $b;
    $b=$a;
}
?>

[править] else

Расширяет возможности IF по части обработки вариантов выражения, когда оно равно FALSE.

Выражение ELSE выполняется только если IF равно FALSE.

if($a>$b) {
    echo "a больше b";
} else {
    echo "a меньше b";
}

[править] elseif

Является комбинацией IF и ELSE. Позволяет выполнить выражение, если значение IF равно FALSE, но в отличии от ELSE оно выполниться, если выражение ELSEIF равно TRUE.

if ($a > $b) {
  echo "a больше b";
} elseif ($a == $b) {
  echo "a равно b";
} else {
  echo "a меньше b";
}

[править] if ... endif

Один из возможных вариантов группирования операторов с оператором IF.

Удобно при внедрении больших блоков HTML-кода внутрь оператора IF.

if ($a == 1):
  echo "a равно 1";
elseif ($a == 2):
  echo "a равно 2";
else:
  echo "а не равно 1 и 2";
endif;
<?php if ($a==5):?>A=5<?php endif;?>

Блок HTML-кода A=5 будет виден, если выполнется условие $a==5

[править] while

Простейший тип цикла в PHP. Заставляет PHP выполнять вложенные операторы до тех пор, пока условие равно TRUE. Если условие равно FALSE с самого начала, то цикл не выполнится не разу.

Синтаксис:

WHILE(условие)выражения

Можно сгруппировать несколько операторов внутри фигурных скобок или использовать альтернативный синтаксис : WHILE(условие)выражения... ENDWHILE;

<?php
$a=1;
while ($a <= 5) {
    echo $a++;
}
?>
<?php
$a = 1;
while($a <= 5):
  echo $a;
  $a++;
endwhile;
?>

- Эти два примера выводят номера с 1 до 5.

[править] do_while

Цикл, аналогичный WHILE, но значение логического выражения проверяется не до, а после окончания итерации. Основное отличие - то что цикл хоть один раз но выполнится.

<?php
$a = 1;
do {
  echo $a;
} while ($a > 1);
?>

Можно прекратить использовать блок операторов в середине путем внедрения оператора BREAK в цикл DO..WHILE(0) :

<?php
do {
  if ($a == 5) {
    echo "A равно 5"
    break;
  }
  $a *= $b;
  if ($a < $minimum) {
    break;
  }
  echo "A равен $a";
} while(0);
?>

[править] for

Наиболее мощный цикл в PHP.

Синтаксис:

FOR (условие1; условие2; условие3)выражения
  • условие1 - Безусловно выполняется (вычисляется) в начале цикла

(условие2 - Проверяется в начале каждой итерации. Если оно равно TRUE, то цикл продолжается и выполняются вложенные операторы. Если оно равно FALSE, то цикл заканчивается. (условие3 - Выполняется (вычисляется) в конце каждой итерации.

Каждое из этих условий может быть пустым.

Пример1:

for ($a = 1; $a <= 5; $a++) {
    echo $a;
}

Пример 2:

for ($a = 1;;$a++) {
    if ($a > 5) {
        break;
    }
    echo $a;
}

Пример 3:

$a = 1;
for (;;) {
  if ($a > 5) {
    break;
  }
  print $a;
  $a++;
}

Пример 4:

for ($a = 1; $a <= 5; print $a, $a++);

PHP поддерживает альтернативный синтаксис FOR:

FOR(усл1; уcл2; усл3;):операторы;...;ENDFOR;

[править] break

Прерывает выполнение текущего цикла.

Пример:

$a = 0;
while ($a < 5) {
    if ($arr[$a] == "stop") {
        break;
    }
    $a++;
}

[править] continue

Переходит на начало ближайшего цикла.

<?php
while (list($key,$value) = each($arr)) {
  if ($key % 2) {
    continue;
  }
  do_something_odd ($value);
}
?>

[править] switch

Сравнивает переменную или выражение с различными значениями и выполняет различные фрагменты кода в зависимости от того, чему будет равно значение выражения.

<?php
switch ($a) {
  case 0:
    echo "A равно 0";
    break;
  case 1:
    echo "A равно 1";
    break;
  case 2:
    echo "A равно 2";
    break;
  default:
    echo "A не равно 0, 1, 2";
}
?>
  • default - соответствует всем значениям, которые не удовлетворяют другим CASE. CASE - могут быть любого скалярного типа, т.е. целые числа или числа с плавающей запятой и строки.

[править] require

Заменяет себя содержимым указанного файла.

Пример:

require("include.inc");

Но его нельзя поместить внутрь цикла и ожидать, что он включит содержимое другого файла несколько раз в процессе каждой итерации. Для этого есть INCLUDE.

[править] include

Вставляет и выполняет содержимое указанного файла.

<?php
$files = array ("first.inc", "second.inc", "third.inc");
for ($a = 0; $a < count($files); $a++) {
  include($files[$a]);
}
?>

Так как INCLUDE() это специальный оператор, требуется заключать его в фигурные скобки при использовании внутри условного оператора.

<?php
if ($a < 5) {
  include("file_1.inc");
} else {
  include("file_2.inc");
}
?>

[править] function

Объявление функции.

Внутри функции может быть любой верный код PHP, даже объявление другой функции или класса. Функции должны быть объявлены перед тем, как на них ссылаться.

<?php
function foo ($arg_1, $arg_2, ..., $arg_n) {
  echo "Пример функции.";
  return $retvalue;
}
?>

Возвращение результатов:

  • Результаты возвращаются через необязательный оператор return.
  • Возвращаемый результат может быть любого типа, включая списки и объекты.
<?php
function my_sqrt ($num) {
  return $num * $num;
}
echo my_sqrt(4); //выведет 16
?>

Множественные результаты не могут быть возвращены в качестве результата, но вы можете реализовать это путем возврата списка:

function foo() {
  return array (0, 1, 2);
}
list ($zero, $one, $two) = foo();

Аргументы:

Информация может быть передана функции через список аргументов, которые являются разделенным запятыми списком переменных и/или констант.

Списки аргументов переменной длины не поддерживаются, но того же можно достичь, передавая массивы.

function takes_array($input) {
  echo "$input[0] + $input[1] = ", $input[0]+$input[1];
}

Передача по ссылке:

По умолчанию, аргументы функции передаются по значению. Для изменения аргументов в функции их надо передавать по ссылке. Для этого надо поставить амперсанд (&) перед именем аргумента в объявлении функции:

function foo( &$bar) {
  $bar .= "и добавочная строка.";
}
$str = "Это строка, ";
foo($str);
echo $str;   // выведет : "Это строка, и добавочная строка."
function foo($bar) {
  $bar .= "и добавочная строка.";
}
$str = "Это строка, ";
foo($str);
echo $str;  //выведет : "Это строка, "
foo(&$str);
echo $str;  //выведет : "Это строка, и добавочная строка."

Значения по умолчанию:

Значение по умолчанию должно быть константой, а не переменной или членом класса.

function day ($type = "понедельник") {
  echo "Сегодня $type.";
}
echo day();           //выведет : Сегодня понедельник.
echo day("вторник");  //выведет : Сегодня вторник.

Аргументы по умолчанию при описании должны находиться справо от остальных аргументов.

function day($day_num, $type = "понедельник") {
  return "Сегодня $day_num - $type.";
}

[править] old_function

Оператор OLD_FUNCTION позволяет вам определяить функцию используя синтаксис PHP/FI2 (за исключением того, что вы должны заменить "function" на "old_function").

Это свойство только для совместимости и должно использоваться лишь конверторами PHP/FI2 -> PHP3. Описанные таким образом функции не могут быть вызваны из служебного кода PHP. Вы можете обойти это путем введения специальной функции в терминах PHP3, которая будет вызывать OLD_FUNCTION.

[править] class

Набор переменных и функций, работающих с этими переменными.

<?php
class Cart {
  var $items; // Количество вещей в корзине покупателя
  // Добавить $num наименований типа $artnr в корзину
  function add_item ($artnr, $num) {
    $this->items[$artnr] += $num;
  }
  // Убрать $num наименований $artnr из корзины
  function remove_item ($artnr, $num) {
    if ($this->items[$artnr] > $num) {
        $this->items[$artnr] -= $num;
        return true;
    } else {
      return false;
    }
  }
}
?>

Классы это типы, то есть, заготовки для реальных переменных. Вы должны создавать переменные желаемого типа, используя оператор new:

$cart = new Cart;
$cart->add_item("10", 1);

Классы могут быть расширениями других классов. Расширенный класс обладает всеми переменными и функциями базового класса и тем, что вы определите при расширении класса. Это делается используя ключевое слово extends :

class Named_Cart extends Cart {
  var $owner;
  function set_owner ($name) {
    $this->owner = $name;
  }
}

Это определяет класс Named_Cart, который имеет все переменные и функции класса Cart плюс дополнительную переменную $owner и дополнительную функцию set_owner(). Вы можете создать поименованую корзину обычным образом и установить или получить владельца корзины. Также вы можете использовать и нормальные функции корзины в поименованой корзине :

$ncart = new Named_Cart;   //Создать корзину
$ncart->set_owner ("kris");//Указать владельцаprint
$ncart->owner;             //Распечатать имя владельца корзины
$ncart->add_item ("10", 1);//унаследовано из обычной корзины
Получено с http://spravkaweb.local/index.php/php/lang/vir
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 06:46, 24 марта 2007.
  • К этой странице обращались 209 раз.
2.69182515144


Справочник по PHP : Управляющие функции : Функции динамической загрузки — Справочник Web-языков

Справочник по PHP : Управляющие функции : Функции динамической загрузки

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Функции запуска программ
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Функции динамической загрузки
 |  |  |  |  |  | Информационные функции

Содержание

  • 1 dl
  • 2 get_loaded_extensions
  • 3 extension_loaded
  • 4 get_extension_funcs

[править] dl

Загрузка библиотеки расширения PHP во время выполнения.

Синтаксис:

int dl(string library);
dl("extensions/php_db.dll");

Загружает PHP расширение определенное в library.

[править] get_loaded_extensions

Определения перечня загруженных модулей.

Синтаксис:

array get_loaded_extensions(void);

Возвращает массив, содержащий список имен модулей PHP, которые были скомпилированны, загружены при старте PHP и загружены во время исполнения функцией dl().

print_r (get_loaded_extensions());

Выводит информацию, подобную следующей:

Array
(
    [0] => standard
    [1] => bcmath
    [2] => calendar
    [3] => ctype
    [4] => com
    [5] => ftp
    [6] => mysql
    [7] => odbc
    [8] => overload
    [9] => pcre
    [10] => session
    [11] => tokenizer
    [12] => xml
    [13] => wddx
    [14] => zlib
    [15] => exif
    [16] => gd
    [17] => zip
)

[править] extension_loaded

Проверка загрузки модуля.

Синтаксис:

bool extension_loaded(string name);

Возвращает true, если указанный модуль name уже был загружен. Следует обращать внимание на то, как пишется имя модуля, и на регистр символов.

[править] get_extension_funcs

Определение функций модуля.

Синтаксис:

array get_extension_funcs(string module_name);

Возвращает массив, содержащий перечисление имен функций, содержащихся в модуле module_name. Этот модуль должен быть предварительно загружен.

print_r(get_extension_funcs("xml"));
Получено с http://spravkaweb.local/index.php/php/managfun/dll
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 15:12, 12 февраля 2007.
  • К этой странице обращались 105 раз.
1.45755195618


Справочник по PHP : Управляющие функции : Информационные функции — Справочник Web-языков

Справочник по PHP : Управляющие функции : Информационные функции

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Функции динамической загрузки
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Информационные функции
 |  |  |  |  |  | Взаимодействие с базами данных : База данных MySQL : Работа с базами данных

Содержание

  • 1 phpinfo
  • 2 phpversion
  • 3 phpcredits
  • 4 php_sapi_name
  • 5 php_uname
  • 6 ini_set
  • 7 ini_alter
  • 8 ini_get
  • 9 ini_restore
  • 10 get_cfg_var
  • 11 getenv
  • 12 putenv
  • 13 get_magic_quotes_gpc
  • 14 get_magic_quotes_runtime
  • 15 set_magic_quotes_runtime
  • 16 php_logo_guid
  • 17 zend_logo_guid

[править] phpinfo

Выводит текущее состояние всех параметров PHP.

Синтаксис:

int phpinfo([int what])

Для сокращения объема выводимой информации можно указать один из следующих разделов what (если он не указывается, то подразумевается INFO_ALL):

  • INFO_GENERAL
  • INFO_CREDITS
  • INFO_CONFIGURATION
  • INFO_MODULES
  • INFO_ENVIRONMENT
  • INFO_VARIABLES
  • INFO_LICENSE
  • INFO_ALL

Эта функция,которая в общем-то не должна появляться в законченной программе, выводит в броузер большое количество различной информации, касающейся настроек PHP и параметров вызова сценария. Именно, в стандартный выходной поток (то есть в браузер пользователя) печатается:

  • версия PHP;
  • опции, которые были установлены при компиляции PHP;
  • информация о дополнительных модулях;
  • переменные окружения, в том числе и установленные сервером при получении запроса от пользователя на вызов сценария;
  • версия операционной системы;
  • состояние основных и локальных настроек интерпретатора;
  • HTTP-заголовки;
  • лицензия PHP.

Функция phpinfo() в основном применяется при первоначальной установке PHP для проверки его работоспособности (уж больно много она выдает информации).

[править] phpversion

Возвращает текущую версию PHP.

Синтаксис:

string phpversion();

Возвращает строку, содержащую название версии интерпретатора PHP.

echo phpversion();

[править] phpcredits

HTML-распечатка разработчиков PHP.

Синтаксис:

void phpcredits(inf flag);

Выводит информацию о создателях и их вкладе в разработку пакета PHP.

phpcredits(CREDITS_GENERAL);

Флаги можно комбинировать следующим образом:

phpcredits(CREDITS_GROUP + CREDITS_DOCS + CREDITS_FULLPAGE);

Далее приведу список доступных флагов:

  • CREDITS_ALL - Полный HTML-листинг.
  • CREDITS_DOCS - Список разработчиков документации.
  • CREDITS_FULLPAGE - Обычно используется в комбинации с другими флагами. Выбирает вариант, подготовленный к распечатке.
  • CREDITS_GENERAL - Общая разработка языка PHP 4.0 и SAPI
  • CREDITS_GROUP - Список разработчиков ядра.
  • CREDITS_MODULES - Список модулей расширения и их авторов.
  • CREDITS_SAPI - Список разработчиков PHP модуля API сервера.

[править] php_sapi_name

Получение типа интерфейса между Web-сервером и PHP.

Синтаксис:

string php_sapi_name();

Возвращает строку, содержащую строчными буквами тип интерфейса. Для CGI PHP, это будет строка "cgi", для mod_php под Apache - "apache" и т.п.

$sapi_type = php_sapi_name();
if($sapi_type == "cgi")
  echo "Это CGI PHPn";
else
  echo "Это не CGI PHP а $sapi_type";

[править] php_uname

Определение операционной системы.

Синтаксис:

string php_uname();

Возвращает строку, содержащую название операционной системы, например "Windows NT MYCOMP 5.1 build 2600".

if(substr(php_uname(),0,7) != "Windows") {
  die("Этот сценарий должен выполняться в Windows.");
}

[править] ini_set

Изменение параметра конфигурации.

Синтаксис:

string ini_set(string varname, string newvalue);

Устанавливает для указанного параметра varname значение newvalue. При успехе возвращает прежнее значение, при ошибке - false.

[править] ini_alter

Тоже, что и ini_set().

Синтаксис:

string ini_alter(string varname, string newvalue);

[править] ini_get

Эта функция получает значения параметров конфигурации.

Синтаксис:

string ini_get(string varname);

Возвращает текущее значение параметра конфигурации, заданное в переменной varname.

Данная функция позволяет получить все доступные в PHP параметры.

В случае ошибки возвращает false.

[править] ini_restore

Производит восстановление параметра конфигурации.

Синтаксис:

string ini_restore(string varname);

Устанавливает значение параметра конфигурации varname в первоначальное.

echo ini_set("precision",20).ini_get("precision").
      ini_restore("precision").ini_get("precision");
// Выведет 14 20 14

[править] get_cfg_var

Получает значения параметра непосредственно из файла php.ini.

Синтаксис:

string get_cfg_var(string varname);

Надо отметить, что в отличии от функции ini_get(), которая возвращает текущее значение параметра, функция get_cfg_var() возвращает значение параметра, которое установлено в файле конфигурации php.ini. Также эта функция не возвращает другие параметры (например, из конфигурации самого сервера).

[править] getenv

Функция возвращает значение переменной окружения.

Синтаксис:

string getenv(string varname);
$ip = getenv("REMOTE_ADDR");
echo "Ваш IP-адрес: $ip";

Список переменных окружения можно посмотреть в Приложения->Переменные окружения, или при помощи функции phpinfo().

Эта функция не работает в модуле PHP ISAPI.

[править] putenv

Устанавливает переменную окружения.

Синтаксис:

void putenv(string setting);
putenv("UNIQID=$uniquid");

[править] get_magic_quotes_gpc

Получает текущее значение параметра magic_quotes_gpc.

Синтаксис:

long get_magic_quotes_gpc();

Эта функция возвратит 0 для Off и 1 для On.

[править] get_magic_quotes_runtime

Предназначена для получения текущего значения параметра magic_quotes_runtime.

Синтаксис:

long get_magic_quotes_runtime();

Эта функция возвратит 0 для Off и 1 для On.

[править] set_magic_quotes_runtime

Предназначена для установки текущего значения параметра magic_quotes_runtime.

Синтаксис:

long set_magic_quotes_runtime(int new_setting);

Для установки magic_quotes_runtime в Off задайте параметр new_setting равным 0, а для установки в On равным 1.

[править] php_logo_guid

Функция получения GUID логотипа PHP.

Синтаксис:

string php_logo_guid();

Строка

echo php_logo_guid();

возвратит

PHPE9568F34-D428-11d2-A769-00AA001ACF42

[править] zend_logo_guid

Функция получения GUID логотипа Zend.

Синтаксис:

string zend_logo_guid();

Строка

echo zend_logo_guid();

возвратит

PHPE9568F35-D428-11d2-A769-00AA001ACF42
Получено с http://spravkaweb.local/index.php/php/managfun/info
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 07:36, 18 февраля 2007.
  • К этой странице обращались 96 раз.
1.26255297661


Справочник по PHP : Управляющие функции : Почтовые функции — Справочник Web-языков

Справочник по PHP : Управляющие функции : Почтовые функции

 |  |  |  |  |  | Управление исполнением сценария PHP : Дополнительные функции
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Почтовые функции
 |  |  |  |  |  | Функции запуска программ

[править] mail

Отсылает почту.

Синтаксис:

mail($to, $subject, $msg [,$headers]);

Функция mail() посылает сообщение с телом $msg (это может быть "многострочная строка", т.е. переменная, содержащая несколько строк, разделенных символом перевода строки) по адресу $to. Можно задать сразу несколько получателей, разделив их адреса пробелами в параметре $to.

Пример:

mail("info@spravkaweb.ru admin@spravkaweb.ru",
     "Мое сообщение",
     "Первая строка\nВторая строка\nТретья строка"
);

В случае, если указан четвертый параметр, переданная в нем строка вставляется между концом стандартных почтовых заголовков (таких как To, Content-type и т.д.) и началом текста письма. Обычно этот параметр используется для задания дополнительных заголовков письма.

Пример:

mail("info@spravkaweb.ru admin@spravkaweb.ru",
     "Тема",
     "Тело письма",
     "From: webmaster@chat.run".
     "Reply-To: webmaster@chat.run".
     "X-Mailer: PHP/" . phpvarsion()
);
Получено с http://spravkaweb.local/index.php/php/managfun/mail
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 15:00, 12 февраля 2007.
  • К этой странице обращались 106 раз.
1.55341982841


Справочник по PHP : Управляющие функции : Функции запуска программ — Справочник Web-языков

Справочник по PHP : Управляющие функции : Функции запуска программ

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  | Почтовые функции
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Функции запуска программ
 |  |  |  |  |  | Функции динамической загрузки

Содержание

  • 1 escapeshellcmd
  • 2 exec
  • 3 system
  • 4 passthru

[править] escapeshellcmd

Убирает shell метасимволы.

Синтаксис:

string escapeshellcmd(string command);

Убирает любые символы в строке, которые могут быть использованы в командном интерпретаторе как произвольные команды. Эту функцию нужно использовать, что бы убедится, что все ваши данные введены правильно, и эту функцию лучше всего вставлять в функции exec() или system().

Стандартное использование этой функции выглядит так:

system(EscapeShellCmd($cmd))

[править] exec

Запуск внешней программы.

Синтаксис:

string exec(string command [, string array [, int return_var]]);

Функция exec() скрыто от пользователя запускает программу из строки command, весь стандартный вывод отключен. Возвращает последнюю строку результата выполнения программы.

Если параметр array установлен, то указанный массив будет заполнен выводом из программы. Помните, если массив уже содержит данные, то exec() добавляет свои данные в конец массива. Для очистки массива можно использовать функцию unset().

Если параметр return_var установлен наряду с параметром array, то в него записывается результат выполнения команды.

<?php
$se = "dir c:\";
$s0 = exec($se, $sa, $sr);
echo "При запуске команды "$se" последняя выведенная строка была:n",
    $s0,"n Код возврата ($sr) nА это все что было выведено: ";
print_r($sa);
?>

Если требуется запустить программу в фоновом режиме (на длительное время), то поток ее вывода должен быть перенаправлен в файл (или иной поток вывода); иначе по истечении допустимого времени исполнения сценария (ожидания завершения внешней программы) он будет принудительно завершен с ошибкой.

[править] system

Запуск внешней программы с выводом результата.

Синтаксис:

string system(string command, int [return_var]);

это функция для запуска command и вывода результата. Если используется второй параметр, то в него записывается результат выполнения команды.

Вызов System() также пробует автоматически вставить в буфер вывода web сервера после каждой строки вывода, если PHP запущен как модуль сервера.

[править] passthru

Запускает внешнюю программу и выводит данные напрямую.

Синтаксис:

string passthru(string command [, int return_var]);

Функция passthru() похожа на функцию exec() для запуска command. Если параметр return_var установлен, то результат Unix команды помещается здесь. Эта функция должна использоваться вместо exec() или system() тогда, когда вывод из Unix команды является двоичными данными, которые должны быть переданы непосредственно обратно в окно просмотра(browser). Это можно использовать, например, для запуска утилиты pbmplus для вывода непосредственно потока изображения. Установка типа image/gif и вызов программы pbmplus, чтобы вывести gif-рисунок, вы можете создавать PHP скрипты, которые выводят изображения непосредственно.

Получено с http://spravkaweb.local/index.php/php/managfun/run
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 15:09, 12 февраля 2007.
  • К этой странице обращались 114 раз.
1.65922498703


Справочник по PHP : Управляющие функции : Отслеживание и обработка ошибок : Функции обработки ошибок — Справочник Web-языков

Справочник по PHP : Управляющие функции : Отслеживание и обработка ошибок : Функции обработки ошибок

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Введение
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Отслеживание и обработка ошибок | ::. | Функции обработки ошибок
 |  |  |  |  |  |  |  | Установка пользовательского обработчика ошибок

Содержание

  • 1 error_log
  • 2 error_reporting
  • 3 restore_error_handler
  • 4 trigger_error
  • 5 user_error

[править] error_log

Посылка сообщения об ошибке.

Синтаксис:

int error_log(string message, int message_type [, string destination [, string extra_headers]])

Сообщение, посылаемое этой функцией, может быть направлено в журнал системных сообщений web-сервера, прот TCP или в файл.

В первом аргументе message указывается само содержание сообщения. Во втором аргументе message_type - куда оно должно быть направлено.

Назначение обозначается следующими значениями:

  • 0 - Сообщение заносится в системный журнал событий (файл) согласно установке параметра конфигурации error_log.
  • 1 - Сообщение отправляется по электронной почте, по адресу, указанному в аргументе destination. Это единственный тип сообщения, использующий четвертый параметр extra_headers, в котором можно указать дополнительные заголовки (как в функции mail()).
  • 2 - Сообщение посылается через подключение отладки. Это возможно только в случае, если параметр удаленной отладки был разрешен в файле конфигурации. Для этого также должен быть определен адрес хоста (имя или его IP адрес) и порт сокета, который будет принимать сообщения отладки. Это можно указать в аргументе destination или параметрах конфигурации.
  • 3 - message добавляется в конец файла destination.
if(!Ora_London($username, $password)) {
  error_log("Сервер Oracle недоступен!", 0);
};

if(!($foo = allocate_new_foo()) {
  error_log("Нельзя выделить FOO!", 1, "operator@mydomain.ru");
}

// other ways of calling error_log():
error_log("У нас ошибка!", 2, "127.0.0.1:7000");
error_log("У нас ошибка!", 2, "localhost");
error_log("У нас ошибка!", 3, "/var/tmp/my-errors.log");

[править] error_reporting

Установка видов сообщаемых ошибок.

Синтаксис:

int error_reporting([int level])

Функция error_reporting() возвращает предыдущую установку типа сообщаемых ошибок. Если указан аргумент, то заново переопределяет ее. В аргументе можно указывать константу, число или битовую маску. Старайтесь использовать константы вместо численных значений, чтобы сохранить совместимость с будущими версиями PHP.

error_reporting(2039); // в PHP эквивалент E_ALL ^ E_NOTICE
error_reporting(E_ALL ^ E_NOTICE); // установка по умолчанию
error_reporting(0); // отключить сообщения об ошибках
// общие ошибки выполнения
error_reporting(E_ERROR | E_WARNING | E_PARSE);
// также сообщать о неизвестных переменных
error_reporting(E_ERROR | E_WARNING | E_PARSE | E_NOTICE);
error_reporting(E_ALL); // сообщать все ошибки

[править] restore_error_handler

Восстановление предыдущего обработчика ошибок.

Синтаксис:

void restore_error_handler()

Эта функция устанавливает в качестве функции обработчика ошибок ту, которая была таковой до последнего вызова функции set_error_handler(). Предыдущим обработчиком может быть ранее установленный пользовательский обработчик или встроенный обработчик PHP.

[править] trigger_error

Генерация ошибки.

Синтаксис:

void trigger_error(string error_msg [, int error_type])

Явно вызывает функцию, установленную для обработки ошибок, и обычно используется в паре с обработчиком ошибок. Функция способна генерировать только пользовательские типы ошибок ( семейство констант E_USER), и по умолчанию, если не указан тип ошибки error_type, он считается E_USER_NOTICE.

Возможно конструировать сложные конструкции генерации и обработки ошибок и исключительных ситуаций.

if(assert($divisor == 0))
  trigger_error ("Нельзя делить на 0 ", E_USER_ERROR);

[править] user_error

Синоним функции trigger_error().

Синтаксис:

void user_error(string error_msg [, int error_type])
Получено с http://spravkaweb.local/index.php/php/managfun/error/fun
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:19, 10 февраля 2007.
  • К этой странице обращались 71 раз.
1.4207379818


Справочник по PHP : Управляющие функции : Отслеживание и обработка ошибок : Введение — Справочник Web-языков

Справочник по PHP : Управляющие функции : Отслеживание и обработка ошибок : Введение

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Файлы и сети : Сетевые функции
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Отслеживание и обработка ошибок | ::. | Введение
 |  |  |  |  |  |  |  | Функции обработки ошибок

PHP имеет следующие типы ошибок и предупреждений:

Значение | Константа | Описание
1 | E_ERROR | Фатальная ошибка времени исполнения.
2 | E_WARNING | Предупреждение времени исполнения.
4 | E_PARSE | Сообщение интерпретации времени исполнения.
8 | E_NOTICE | Простое сообщение времени исполнения.
16 | E_CORE_ERROR | Фатальная ошибка при инициализации PHP.
32 | E_CORE_WARNING | Предупреждение инициализации.
64 | E_COMPILE_ERROR | Фатальная ошибка компиляции.
128 | E_COMPILE_WARNING | Предупреждение компиляции.
256 | E_USER_ERROR | Ошибки, определяемые пользователем.
512 | E_USER_WARNING | Предупреждения, определяемые пользователем.
1024 | E_USER_NOTICE | Сообщения, определяемые пользователем.
2047 | E_ALL | Все перечисленные сообщения.

Указанные значения в виде чисел или констант можно комбинировать, формируя битовую маску ошибок, о которых необходимо сообщать в ходе исполнения сценария. Для комбинирования используются битовые операторы, но в конфигурационном файле php.ini распознаются только "|", "~", "!" и "&".

В PHP 4 по умолчанию разрешены сообщения вида E_ALL & ~E_NOTICE, то есть сообщаться должно все, кроме обычных сообщений. Можно переопределить эту установку параметром файла конфигурации error_reporting() (ее также можно указывать в файлах конфигурации сервера Apache).

Если при вызове функции перед ее именем указать символ "@", то в случае возникновения ошибки в этой функции сообщение о нем выдаваться не будет.

В настоящее время оператор игнорирования ошибок блокирует даже выдачу сообщений о критических ошибках, при возникновении которых сценарий досрочно завершается.

Если разрешен параметр конфигурации track_errors, то сообщение об ошибке сохраняется в глобальной переменной $php_errormsg.

<?php
// определенный пользователем обработчик ошибок
function userErrorHandler($errno,$errmsg,$filename,$linenum,$vars) {
  // время возникновения ошибки
  $dt=date("Y-m-d H:i:s (T)");
  $errortype = array(
    1    => "Error",
    2    => "Warning",
    4    => "Parsing Error",
    8    => "Notice",
    16   => "Core Error",
    32   => "Core Warning",
    64   => "Compile Error",
    128  => "Compile Warning",
    256  => "User Error",
    512  => "User Warning",
    1024 => "User Notice"
    );

  $err.="время ($dt), номер ошибки ($errno), ";
  $err.="тип ошибки (".$errortype[$errno]."): ";
  $err.=""$errmsg".файл "$filename", строка (";
  $err.=$linenum.")n";

  $user_errors=array(E_USER_ERROR, E_USER_WARNING, E_USER_NOTICE);
  if(in_array($errno, $user_errors))
  // выдать сообщение для ошибок пользователя
  echo $err;

  // сохранить событие ошибки в системном журнале
  error_log($err, 3, "/usr/local/php4/error.log");
}

// установить уровень контроля ошибок и обработчик
error_reporting(0); // не выводить сообщения PHP
$old_error_handler=set_error_handler("userErrorHAndler");

// неопределенная константа вызывает предупреждение
$t=_NOT_DEFINED_CONSTANT;

trigger_error("Моя ошибка", E_USER_ERROR);
trigger_error("Мое предупреждение", E_USER_WARNING);

?>
Получено с http://spravkaweb.local/index.php/php/managfun/error/leading
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:15, 10 февраля 2007.
  • К этой странице обращались 97 раз.
1.44677710533


Справочник по PHP : Управляющие функции : Отслеживание и обработка ошибок : Установка пользовательского обработчика ошибок — Справочник Web-языков

Справочник по PHP : Управляющие функции : Отслеживание и обработка ошибок : Установка пользовательского обработчика ошибок

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Функции обработки ошибок
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Отслеживание и обработка ошибок | ::. | Установка пользовательского обработчика ошибок
 |  |  |  |  |  |  |  | Управление сессиями : Зачем нужны сессии.Механизм работы сессий

[править] set_error_handler

Установка пользовательского обработчика ошибок.

Синтаксис:

string set_error_handler(string error_handler)

Функция возвращает имя функции, ранее определенной в качестве обработчика ошибок (или FALSE при ошибке), и устанавливает, в качестве нового обработчика, функцию с указанным в аргументе error_handler именем.

Обычно пользовательский обработчик ошибок работает в паре с функцией trigger_error(), генерирующей ошибку. Это может быть использовано (подобно аналогичной конструкции работы с исключениями в C) для освобождения выделенных ресурсов (например, удаления созданных файлов), если сценарий не может нормально завершиться.

Функция, устанавливаемая в качестве обработчика ошибок, должна принимать пять параметров (три последних являются дополнительными и могут не обрабатываться):

  • код ошибки
  • строку, описывающую ошибку
  • имя сценария, в котором произошла ошибка
  • номер строки сценария, содержащей ошибку
  • контекст (массив, содержащий значения переменных, в момент возникновения ошибки)
<?php
// определить константы пользовательских ошибок
define(FATAL, E_USER_ERROR);
define(ERROR, E_USER_WARNING);
define(WARNING, E_USER_NOTICE);

// установить, какие ошибки должны обрабатываться в сценарии
error_reporting (FATAL | ERROR | WARNING);

// пользовательский обработчик ошибок
function myErrorHandler($errno,$errstr,$errfile,$errline) {
  switch ($errno) {
  case FATAL:
    echo "<b>Критическая ошибка</b> [$errno] $errstr<br>n";
    echo "в строке: $errline файла:".$errfile;
    echo ", PHP ".PHP_VERSION." (".PHP_OS.")<br>n";
    echo "Aborting...<br>n";
    exit -1;
    break;
  case ERROR:
    echo "<b>Ошибка</b> [$errno] $errstr<br>n";
    break;
  case WARNING:
    echo "<b>Предупреждение</b> [$errno] $errstr<br>n";
    break;
  default:
    echo "Неизвестный тип ошибки: [$errno] $errstr<br>n";
  }
}

// функция для проверки обработки ошибок
// (масштабирование массива
function scale_by_log($vect, $scale) {
  if(!is_numeric($scale) || $scale <= 0)
    trigger_error("вычислить log(x) для x <= 0 нельзя. ",
                  "(x = $scale)", FATAL);
  if(!is_array($vect)) {
    trigger_error("Требуется массив ", ERROR);
    return null;
  }
  for($i=0; $i<count($vect); $i++) {
    if(!is_numeric($vect[$i]))
      trigger_error("Элемент ($i) не число и
                     его значением считается 0", WARNING);
    $temp[$i]=log($scale)*$vect[$i];
  }
  return $temp;
}

// установить пользовательский обработчик ошибок
$old_error_handler=set_error_handler("myErrorHandler");

$a=array(2,3,"foo",5.5,43.3,21.11);
print_r($a);

$b=scale_by_log($a,M_PI); // здесь выдается предупреждение
echo "Массив, масштабированный на логарифм(Пи): ";
print_r($b);

$c=scale_by_log("not array",2,3); // здесь ошибка
var_dump($c);

$d=scale_by_log($a, -2.5); // здесь критическая ошибка

echo "Продолжение сценария...";
?>

При выполнении сценария вывод будет следующим:

Array
(
  [0] => 2
  [1] => 3
  [2] => foo
  [3] => 5.5
  [4] => 43.3
  [5] => 21.11
)

Предупреждение [1024] Элемент (2) не число,
  и его значением считается 0<br>
Массив, масштабированный на логарифм(Пи): Array
(
  [0] => 2.2894597716988
  [1] => 3.4341896575482
  [2] => 0
  [3] => 6.2960143721717
  [4] => 49.566804057279
  [5] => 24.165247890281
)
<b>Ошибка</b> [512] Требуется массив <br>
NULL
<b>Критическая ошибка</b> [256] вычислить log(x) для x <=0 нельзя,
  (x = -2.5)<br>
  в строке: 37, файла E:wwwexampl.php, PHP 4.0.5 (WINNT)<br>
Aborting...<br>

Не забывайте, что при установке пользовательского обработчика ошибок стандартный обработчик PHP не используется. Установки error_reporting() также не будут иметь эффекта, и пользовательский обработчик должен уметь обрабатывать все виды ошибок (значение error_reporting() можно выяснить и действовать соотвественно). Заметьте, что код ошибки будет равен 0, если ошибка возникла в функции, вывод ошибок для которой был блокирован оператором "@".

Также помните, что завершать сценарий в обработчике необходимо явно (например, с помощью функции die(), если, конечно, в этом есть необходимость. Если обработчик ошибок завершается с помощью return, то выполнение сценария продолжается с того места, в котором возникла ошибка (то есть исполняются инструкции, которые следуют за той инструкцией, в которой возникла ошибка).

Получено с http://spravkaweb.local/index.php/php/managfun/error/userfun
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:27, 10 февраля 2007.
  • К этой странице обращались 66 раз.
1.57694482803


Справочник по PHP : Управляющие функции : Управление выводом : Введение — Справочник Web-языков

Справочник по PHP : Управляющие функции : Управление выводом : Введение

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | SSI и функция virtual()
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Управление выводом | ::. | Введение
 |  |  |  |  |  |  |  | Функции управления выводом

Данная группа функций позволяет управлять тем, как PHP при выполнении сценария выводит информацию. Это может быть полезно в различных ситуациях, в особенности при посылке браузеру HTML-заголовков (headers) после того, как сценарий начал выводить HTML-текст. (В обычном случае невозможно послать заголовок после того, как был начат вывод текста.)

Эти функции не воздействуют на заголовки, посланные функциями header() или setcookie(), а только на функции, подобные echo() и HTML-тексту между блоками PHP-кода.

<?php

ob_start();
echo "Hellon"

setcookie("cookiename", "cookiedata");

ob_end_flush();

?>

В примере выше вывод командой echo() будет сохранен в буфере вывода до вызова функции ob_end_flush(). В то же время вызов setcookie() успешно сохраняет cookie, не вызывая ошибки.

Получено с http://spravkaweb.local/index.php/php/managfun/print/about
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:22, 10 февраля 2007.
  • К этой странице обращались 90 раз.
1.50250887871


Справочник по PHP : Управляющие функции : Управление выводом : Функции управления выводом — Справочник Web-языков

Справочник по PHP : Управляющие функции : Управление выводом : Функции управления выводом

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Введение
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Управление выводом | ::. | Функции управления выводом
 |  |  |  |  |  |  |  | Управление исполнением сценария PHP : Функции управления сценарием

Содержание

  • 1 ob_start
  • 2 ob_get_contents
  • 3 ob_get_length
  • 4 ob_end_flush
  • 5 flush
  • 6 ob_end_clean
  • 7 ob_implicit_flush

[править] ob_start

Включение буферизации вывода.

Синтаксис:

void ob_start([string output_callback])

После вызова этой функции включается буферизация вывода и, пока она активна, никакие из выводящихся данных не будут посланы браузеру, а будут сохраняться во внутреннем буфере PHP.

Содержимое буфера может быть скопировано в строковую переменную функцией ob_get_contents(). Для вывода содержимого из буфера используется функция ob_end_flush(). Удалить содержимое буфера позволяет функция ob_end_clean().

В аргументе output_callback можно указать функцию, которая будет автоматически вызываться при выводе содержимого буфера. Обычно это используется для модификации содержимого буфера перед выводом (например, сжатия). Тогда при вызове функции ob_end_flush() в указанную функцию будет передаваться содержимое буфера, а то, что она возвратит, будет выведено (заметьте, сама функция не должна ничего выводить).

Буферизация может быть вложенной, и тогда она обрабатывается соответственно вложенности; и содержимое, выводимое из буфера нижнего уровня, будет включаться в буфер верхнего уровня. Не забывайте, что для вывода всего буферизованного содержимого необходимо вызывать функцию ob_end_flush() столько же раз, сколько была вызвана ob_start().

<?php
function c($str) { // получает содержимое буфера
  return nl2br($str); // возвращает содержимое буфера
}
function d($str) { // получает содержимое буфера
  return strtoupper($str); // возвращает содержимое буфера
}
?>
<?php
ob_start("c");
?>
Тут различный текст...
<?php
// преобразовывать текст длее в верхний регистр
ob_start("d");
?>
еще что-то...
<?php
ob_end_flush();
?>

.......

<?php
ob_end_flush();
?>

[править] ob_get_contents

Получение содержимого буфера вывода.

Синтаксис:

string ob_get_contents()

Если буферизация неактивна, возвращается false.

[править] ob_get_length

Получение длины данных в буфере вывода.

Синтаксис:

string ob_get_length()

Если буферизация неактивна, возвращается false.

[править] ob_end_flush

Вывод содержимого буфера.

Синтаксис:

void ob_end_flush(void)

После вывода буфер текущего уровня очищается, поэтому вызывайте функцию ob_get_contents() заранее, если необходимо получить его содержимое.

[править] flush

Вывод всего содержимого буфера.

Синтаксис:

void flush(void);

Функция воздействует только на буферизацию PHP и не может контролировать схему буферизации web-сервера или браузера.

Некоторые серверы, в особенности под Win32, буферизуют выводящиеся сценарием данные до того, как сценарий завершится и данные будут отосланы браузеру.

Браузер, в свою очередь, также может буферизировать получаемые данные до их отображения. Netscape, например, буферизирует текст до получения символа завершения строки или открывающего тега, а для таблиц - до получения тега </table> таблицы верхнего уровня.

[править] ob_end_clean

Очистка буфера.

Синтаксис:

void ob_end_clean(void);

Вызов функции отключает буферизацию на текущем уровне.

[править] ob_implicit_flush

Установление режима буферизации.

Синтаксис:

void ob_implicit_flush([int flag]);

Если в аргументе указано ненулевое значение или оно не указано, то при осуществлении каждой операции вывода будет неявно вызываются функция flush().

Надо отметить, что часто эта функция работает курьезно; например, если в конце сценария вызвать функцию ob_end_clean(), то сценарий не выведет ничего, если вывод из буфера не производился явно другими функциями.

Получено с http://spravkaweb.local/index.php/php/managfun/print/fun
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:29, 10 февраля 2007.
  • К этой странице обращались 77 раз.
1.24728798866


php/managfun/script/fun — Справочник Web-языков

php/managfun/script/fun

 |  |  |  |  |  |  |  | Управление выводом : Функции управления выводом
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Управление исполнением сценария PHP | ::. | Функции управления сценарием
 |  |  |  |  |  |  |  | Статус подключений

Содержание

  • 1 set_time_limit
  • 2 sleep
  • 3 usleep
  • 4 die
  • 5 exit
  • 6 assert
  • 7 assert_options
  • 8 eval

[править] set_time_limit

Установка предельного времени исполнения сценария.

Синтаксис:

void set_time_limit(int seconds)

При запуске сценария PHP запускает системный таймер, и если время (выделенное сценарию для выполнения) истекает, а сценарий еще не завершился, PHP принудительно завершает сценарий (генерируя фатальную ошибку исполнения). Это не допускает скопления большого количества сценариев, расходующих ресурсы сервера, но, повидимому, "зависших" (например, если в них обнаружился бесконечный цикл или они пытаются дождаться подключения к не отвечающему серверу).

По умолчанию допустимое время исполнения сценария устанавливается в файле конфигурации параметром max_execution_time (обычно оно равно 30 с). Но для текущего сценария это время можно изменить вызовом данной функции, указав время в секундах в ее аргументе. Если указывается значение 0, то тогда временное ограничение снимается.

Отсчет времени начинается от момента вызова функции. Например, если сценарий уже выполнялся в течении 15 секунд, а затем вызывается функция set_time_limit(20), то общее максимальное время исполнения сценария становится равным 35 секундам.

Если сценарий выполняется в безопасном режиме (с установленным параметром safe mode), то тогда вызов этой функции игнорируется и используется значение из файла конфигурации.

[править] sleep

Задержка выполнения сценария.

Синтаксис:

void sleep(int seconds);

Фукция sleep() выполняет задержку выполнения сценария в секундах (seconds).

[править] usleep

Задержка выполнения сценария в микросекундах.

Синтаксис:

void usleep(int micro_seconds);

Задержка выполнения сценария в микросекундах (micro_seconds).

Эта функция не работает в Windows.

[править] die

Вывод сообщения и завершение текущего сценария.

Синтаксис:

void die(string message);

Эта функция выводит сообщение и прекращает выполнение текущего скрипта. Не возвращает значение.

<?php
$filename = '/path/to/data-file';
$file = fopen($filename, 'r')
 or die "unable to open file ($filename)";
?>

[править] exit

Завершает текущий сценарий.

Синтаксис:

void exit(void);

Эта функция завершает текущий сценарий. Не возвращает значение.

[править] assert

Проверка истинности значения.

Синтаксис:

int assert(string|bool assertion);

В качестве аргумента функции может быть указано значение или строка, содержащая код PHP (как в функции eval()). Функция проверяет, является ли значение (или выражение) равным false, и, если это так, выполняет определенные действия.

Поведение функции определяется установками в файле конфигурации или при вызове функции assert_options().

Обычно эта функция используется исключительно в целях отладки, для проверки тех значений, которые всегда должны быть истинны (например: подключение модуля, свободное пространство на диске и т.д.).

В целом же выполнение сценария не должно зависеть от таких проверок, а использовать обычные проверки возвращаемых функциями значений.

<?php
function handler() {
  echo "n* Failed * n";
}

assert("$a='1';");
echo "a: $a n";
assert(0);
// завершать сценарий
echo assert_options(ASSERT_BAIL, 1);
// вызвать обработчик
assert_options(ASSERT_CALLBACK, "handler");
// не выдавать сообщений PHP
@assert(--$a);
// эта строка не будет выполнена
echo "n ... n";
?>

Приведенный пример выведет:

a: 1
Warning: Assertion failed in file.php on line 20
0
* Failed *

[править] assert_options

Определение параметров assert.

Синтаксис:

mixed assert_options(int parameter [, mixed value])

Эта функция позволяет определить поведение конструкции assert().

Возвращается предыдущее значение параметра (или значение false при ошибке), указанного в первом аргументе одной из следующих констант:

Параметр | ini-параметр | Умолчание | Описание
ASSERT_ACTIVE | asser.active | 1 | Разрешить указание кода в assert().
ASSERT_WARNING | assert.warning | 1 | Выдавать предупреждение PHP.
ASSERT_BAIL | assert.bail | 0 | Завершать выполнение, если "неистинно".
ASSERT_QUIET_EVAL | assert.quiet_eval | 0 | Не выдавать сообщений.
ASSERT_CALLBACK | assert_callback | (null) | Установить функцию в качестве обработчика "неистинных" assert().

Если значение необходимо переопределить, его указывают во втором аргументе.

[править] eval

Производит выполнение строки содержащей PHP код.

Синтаксис:

void eval(string code_str);

Функция eval() производит выполнение строки, заданной в code_str содержащей PHP код. Кстати, это может пригодиться для сохранения кода в текстовом поле базы данных для более позднего выполнения. Не забывайте, что указанный в строке код должен быть синтаксически правильным (например, должны присутствовать точки с запятой после каждой команды и т.п.), в противном случае сценарий будет завершен в этой строке с ошибкой. Учитывайте также, что те значения переменных, которые будут установлены в данной строке, будут использоваться в оставшейся части сценария.

При изменении переменных значений в eval() эти переменные будут изменены и в основных данных.

Если в строке указан оператор return, то тогда выполнение указанного кода будет досрочно завершено и возвращенное значение можно будет получить как значение, возвращаемое самой функции.

<?php
$string = 'cup';
$name = 'coffee';
$str = 'This is a $string with my $name in it.
';
echo $str;
eval( "$str = "$str";" );
echo $str;
?>

Результатом выполнения этого кода будет:

This is a $string with my $name in it.
This is a cup with my coffee in it.
Получено с http://spravkaweb.local/index.php/php/managfun/script/fun
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:39, 10 февраля 2007.
  • К этой странице обращались 117 раз.
1.98187398911


Справочник по PHP : Управляющие функции : Управление исполнением сценария PHP : Дополнительные функции — Справочник Web-языков

Справочник по PHP : Управляющие функции : Управление исполнением сценария PHP : Дополнительные функции

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Статус подключений
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Управление исполнением сценария PHP | ::. | Дополнительные функции
 |  |  |  |  |  |  |  | Почтовые функции

Содержание

  • 1 get_browser
  • 2 highlight_file
  • 3 highlight_string
  • 4 show_source
  • 5 pack
  • 6 unpack
  • 7 iptcparse
  • 8 leak
  • 9 serialize
  • 10 unserialize
  • 11 uniqid

[править] get_browser

Определение возможностей браузера.

Синтаксис:

object get_browser([string user_agent]);

Возвращаемая информация извлекается из файла browscap.ini. Для определения браузера используется значение переменной $HTTP_USER_AGENT или значение, содержащееся в аргументе user_agent.

Информация возвращается в виде свойств объекта и отражает возможности клиентского браузера (например, версию, поддерживает ли он javascript или cookies).

<?php
function list_array($array) {
  while (list ($key, $val) == each ($array)) {
    $str .= "<b>$key:</b> $val<br>n";
  }
  return $str;
}

echo "$HTTP_USER_AGENT<hr>";
$bouser = get_browser();
echo list_array ((array) $browser);
?>

Содержимое возможного вывода:

Mozilla/4.5 [en] (X11: Linux 2.2.9 i586)<hr>
<b>browser_name_pattern:</b>Mozilla/4.5.*<br>
<b>parent:</b>Netscape<br>
<b>platform:</b>Unknown<br>
<b>majorver:</b>4<br>
<b>minorver:</b>5<br>
<b>browser:</b>Netscape<br>
<b>version:</b>4<br>
<b>frames:</b>1<br>
<b>tables:</b>1<br>
<b>cookies:</b>1<br>
<b>backgroundsounds:</b> <br>
<b>vbscript:</b> <br>
<b>javascript:</b>1<br>
<b>javaapplets:</b>1<br>
<b>activexcontrols:</b> <br>
<b>beta:</b> <br>
<b>crawler:</b> <br>
<b>authenticodeupdate:</b> <br>
<b>msn:</b> <br>

Для того чтобы функция могла функционировать, следует правильно указать месторасположение файла browscan.ini в файле конфигурации.

[править] highlight_file

Вывод содержимого файла с цветовой разметкой.

Синтаксис:

boolean highlight_file(string filename);

Имя или путь файла указывается в аргументе. Цвета выделения синтаксиса определяются в файле конфигурации PHP. Возвращает true или false при ошибке.

Например, чтобы заставить сервер Apache при получении запроса с URL, содержащего значение вида "http://имя.сервера/source/путь/к/файлу.php", выводит листинг файла "http://имя.сервера/source/путь/к/файлу.php", сделайте следующее. Добавьте в файл httpd.conf следующий фрагмент:

# Используем директиву "ForceType" чтобы указать,
# что значение source в URL - не каталог, а имя сценария PHP
<Location /source>
  ForceType application/x-httpd-php
</Location>

Создайте в корневом web-каталоге следующий файл с именем source:

<HTML><HEAD>
<TITLE>Source Display</TITLE>
</HEAD>
<BODY bgcolor=#FFEEDD>
<?php
$script = getenv ("PATH_TRANSLATED");
if(!$script) {
  echo "<BR><B>ERROR: Укажите имя сценария</B><BR>";
} else {
  if(ereg("(.php|.inc)$",$script)) {
    echo "<H!>Листинг файла: $PATH_INFO</H1>n<hr>n";
    if(!@highlight_file($script))
      echo "Ошибка вывода файла";
  } else {
    echo "<H1>ERROR: Показываются только листинги PHP файлов </H1>";
  }
}
echo "<HR>Распечатано: ".date("Y/M/d H:i:s",time());
?>
</BODY>
</HTML>

[править] highlight_string

Выделение строки цветом.

Синтаксис:

void highlight_string(string str);

Функция действует подобно highlight_file(), но использует не содержимое файла, а указанной строки.

[править] show_source

Синоним функции highlight_file.

Синтаксис:

boolean show_source(string str);

[править] pack

Пакетирование данных в двоичную строку.

Синтаксис:

string pack(string format [,mixed $args, ...]);

Функция pack() упаковывает заданные аргументы в бинарную строку, которая затем и возвращается. Формат параметров, а также их количество, задается при помощи строки $format, которая представляет собой набор однобуквенных спецификаторов форматирования - наподобие тех, которые указываются в sprintf(), но только без знака %. После каждого спецификатора может стоять число, которое отмечает, сколько информации будет обработано данным спецификатором. А именно, для форматов a,A,h и H число задает, какое количество символов будет помещено в бинарную строку из тех, что находится в очередном параметре-строке при вызове функции (то есть, определяет размер поля для вывода строки). В случае @ оно определяет абсолютную позицию, в которую будут помещены следующие данные. Для всех остальных спецификаторов следующие за ними числа задают количество аргументов, на которые распространяется действие данного формата. Вместо числа можно указать *, в этом случае подразумевается, что спецификатор действует на все оставшиеся данные.

Вот полный список спецификаторов формата:

  • a - строка, свободные места в поле заполняются символом с кодом 0;
  • A - строка, свободные места заполняются пробелами;
  • h - шестнадцатиричная строка, младшие разряды в начале;
  • H - шестнадцатиричная строка, старшие разряды в начале;
  • c - знаковый байт (символ);
  • C - без знаковый байт;
  • s - знаковое короткое целое (16 битов порядок байтов определяется архитектурой процессора);
  • S - беззнаковое короткое число;
  • n - беззнаковое целое (16 битов, старшие разряды в конце);
  • v - беззнаковое целое (16 битов, младшие разряды в конце);
  • i - знаковое целое (размер и порядок байтов определяется архитектурой);
  • I - беззнаковое целое;
  • l - знаковое длинное целое (32 бита, порядок знаков определяется архитектурой);
  • L - беззнаковое длинное целое;
  • N - беззнаковое длинное целое (32 бита, старшие разряды в конце);
  • V - беззнаковое целое (32 бита, младшие разряды в конце);
  • f - число с плавающей точкой (зависит от архитектуры);
  • d - число с плавающей точкой двойной точности (зависит от архитектуры);
  • x - символ с нулевым кодом;
  • X - возврат назад на 1 байт;
  • @ - заполнение нулевым кодом до заданной абсолютной позиции.
// Целое, целое, все остальное - сиволы
$bindata = pack("nvc*", 0x1234, 0x5678, 65, 66);

После выполнения приведенного кода в строке $bindata будет содержаться 6 байтов в такой последовательности: 0x12, 0x34, 0x78, 0x56, 0x41, 0x42 (в шестнадцатиричной системе счисления).

[править] unpack

Распаковывает данные из двоичной строки.

Синтаксис:

array unpack(string format, string data);

Распаковывает данные из двоичной строки в массив согласно формату. Возвращает массив, содержащий распакованные элементы.

$array = unpack("c2chars/nint", $binarydata);

Возникающий в результате массив будет содержать "chars1", "chars2" и "int".

[править] iptcparse

Анализирует двоичный IPTC блок на одиночные тэги.

Синтаксис:

array iptcparse(string iptcblock);

Эта функция анализирует двоичный блок IPTC на одиночные теги. Возвращает массив, использующий tagmarker как индекс и значение как значение. Возвращает false при ошибке или если никаких IPTC данных не было найдено.

[править] leak

Имитация утечки памяти.

Синтаксис:

void leak(int bytes);

leak() отсекает определенный объем памяти.

Это полезно при отладке диспетчера памяти, который автоматически очищает "отсеченную" память при выполнении запроса.

Размер блока памяти указывается в байтах аргументом bytes.

[править] serialize

Генерирует удобохраниемое представление значения.

Синтаксис:

string serialize(mixed value);

serialize() возвращает строку состоящую из потока байтов при представлении значения value, которое может где-нибудь сохранено.

Это полезно для сохранения или передачи значений PHP без потери их типа и структуры.

Пример:

//$session_data содержит многомерный массив
       с информацией о сессии
//текущего пользователя.  Мы используем
       serialize() для сохранения
//этого в базе данных в конце запроса.

$conn = odbc_connect("webdb", "php", "chicken");
$stmt = odbc_prepare($conn,
  "UPDATE sessions SET data = ? WHERE id = ?");
$sqldata = array(serialize($session_data),
  $PHP_AUTH_USER);
if (!odbc_execute($stmt, &$sqldata)) {
  $stmt = odbc_prepare($conn,
    INSERT INTO sessions (id, data) VALUES(?, ?)");
  if (!odbc_execute($stmt, &$sqldata)) {
      /* Что-то сделано неправильно. */
  }
}

[править] unserialize

Создает PHP значение из сохраненного представления.

Синтаксис:

mixed unserialize(string str);

unserialize() берет одно сохраненное значение и преобразует обратно в PHP значение. Возвращает преобразованное значение, и может иметь тип: integer, double, string, array или object. Если был преобразован object, то методы не востановятся.

Пример:

// Здесь мы используем unserialize() для загрузки
        данных о сессии из базы данных
// в $session_data.  Этот пример дополняет
        описанный в месте
// с serialize() .

$conn = odbc_connect("webdb", "php", "chicken");
$stmt = odbc_prepare($conn,
  "SELECT data FROM sessions WHERE id = ?");
$sqldata = array($PHP_AUTH_USER);
if (!odbc_execute($stmt, &$sqldata) ||
  !odbc_fetch_into($stmt, &$tmp)) {
// Если сбой запуска или выборки ,
//        то инициализируем массив
    $session_data = array();
} else {
    // Мы должны иметь представление в $tmp[0].
    $session_data = unserialize($tmp[0]);
    if (!is_array($session_data)) {
// Что-то неправильно, инициализируем массив
        $session_data = array();
    }
}

[править] uniqid

Генерирует уникальный идентификатор.

Синтаксис:

int uniqid(string prefix [, boolean lcg]);

Функция uniqid() возвращает уникальный идентификатор, основанный на текущем времени в микросекундах и имеющий префикс prefix. Префикс может быть полезен, например, если Вы генерируете идентификаторы одновременно на отдельных хостах, которые, могли бы случилось, генерировали идентификатор в одной и той же микросекунде. Префикс может быть длиной до 114 символов. Если в качестве его значения передается пустая строка, то длина сгенерированного идентификатора будет 13 символов (при lcg=true - 23 символа).

Если указан необязательный аргумент lcg со значением true, к концу идентификатора будет добавляться "комбинированный хеш энтропии LCG", делающий его значение более уникальным.

Принято также дообрабатывать полученное значение криптографическими методами (например, это часто делается в идентификаторах сессий).

// без случайной части
$token = md5(uniqid(""));
// посложнее
$better_token = md5(uniqid(rnad()));

Эти строки генерируют 32 байта (128-битное шестнадцатеричное число): они обладают максимальной унакальностью, которая только может потребоваться.

Получено с http://spravkaweb.local/index.php/php/managfun/script/othe
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 13:23, 11 февраля 2007.
  • К этой странице обращались 64 раза.
1.31253218651


Справочник по PHP : Управляющие функции : Управление исполнением сценария PHP : Статус подключений — Справочник Web-языков

Справочник по PHP : Управляющие функции : Управление исполнением сценария PHP : Статус подключений

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Функции управления сценарием
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Управление исполнением сценария PHP | ::. | Статус подключений
 |  |  |  |  |  |  |  | Дополнительные функции

Внутренне PHP имеет три статуса подключения:

  • 0 - NORMAL;
  • 1 - ABORTED (прервано пользователем);
  • 2 - TIMEOUT (истеклож время ожидания ответа).

При нормальном выполнении сценария активно состояние NORMAL. Если во время загрузки страницы пользователь нажал кнопку STOP, активным становится состояние ABORTED. Если сценарий выполняется дольше отведенного ему времени, устанавливается флаг состояния TIMEOUT. Возможно определить, как должен вести себя сценарий в зависимости от этих условий.

Если требуется, чтобы сценарий продолжал свое выполнение при разрыве соединения пользователем, нужно установить в файле конфигурации значение параметра ignore_user_abort = 1 (это также можно сделать в файлах конфигурации Apache). Можно также воспользоваться функцией ignore_user_abort(). В противном случае, сценарий завершается.

Чтобы игнорировать завершение сценария таймером, необходимо использовать функцию set_time_limit().

Если функцией register_shutdown_function() была установлена функция "запускаемая при завершении сценария", то, вне зависимости от статуса подключения, она будет исполнена перед тем, как сценарий завершится. И в "завершающей" функции можно будет выяснить (с помощью функции: connection_aborted(), connection_timeout() и connection_status()), был ли сценарий завершен нормально или досрочно.

Содержание

  • 1 connection_aborted
  • 2 connection_status
  • 3 connection_timeout
  • 4 ignore_user_abort
  • 5 register_shutdown_function

[править] connection_aborted

Определения разрыва подключения пользователем.

Синтаксис:

int connection_aborted(void);

Функция connection_aborted() возвращает true, если подключение было разорвано пользователем.

[править] connection_status

Определения статуса подключения.

Синтаксис:

int connection_status(void);

Возвращает значение битового поля, позволяющее выяснить в "завершающей" функции, был ли сценарий завершен досрочно и причину этого. Например, если возвращается 3 (ABORTED | TIMEOUT), то это означает, что время выполнения истекло, а также то, что пользователь отказался от загрузки страницы.

Если возвращается 0 (то есть значение NORMAL), то это означает, что выполнение сценария не было прервано.

[править] connection_timeout

Определения наступления тайм-аута.

Синтаксис:

int connection_timeout(void);

Возвращает true, если время выполнения сценария истекло.

[править] ignore_user_abort

Прерывание сценария при разрыве подключения.

Синтаксис:

int ignore_user_abort([int setting]);

Аргументом setting можно указать, необходимо ли досрочно завершать выполнение сценария, если связь с клиентом потеряна. Если аргумент не указан, то возвращается текущая установка.

[править] register_shutdown_function

Устанавливает функцию, которая будет выполнена при завершении.

Синтаксис:

int register_shutdown_function(string func);

Регистрирует функцию с именем func в качестве функции, запускаемой после завершения сценария.

Заметьте: так как после завершения функции никакие средства вывода недоступны, это делает для функции, зарегистрированной в качестве "завершающей", недоступными обычные средства отладки, такие команды как print или echo.

Получено с http://spravkaweb.local/index.php/php/managfun/script/status
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 13:14, 11 февраля 2007.
  • К этой странице обращались 64 раза.
1.55213189125


Справочник по PHP : Управляющие функции : Управление сессиями : Зачем нужны сессии.Механизм работы сессий — Справочник Web-языков

Справочник по PHP : Управляющие функции : Управление сессиями : Зачем нужны сессии.Механизм работы сессий

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Отслеживание и обработка ошибок : Установка пользовательского обработчика ошибок
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Управление сессиями | ::. | Зачем нужны сессии.Механизм работы сессий
 |  |  |  |  |  |  |  | Иинициализация сессии и регистрация переменных

[править] Зачем нужны сессии

Сессия представляет собой механизм, позволяющий хранить некоторые данные, индивидуальные для каждого пользователя (например, его имя и номер счета), между запусками сценария.

В Web-программировании есть один класс задач, который может вызвать довольно много проблем, если писать сценарий "в лоб". Речь идет о слабой стороне CGI - невозможности запустить программу на длительное время, позволив ей при этом обмениваться данными с пользователями.

Представте, что мы пишем форму, но в ней такое большое число полей, что было бы глупо поместить их на одну страницу. Нам нужно разбить процесс заполнения формы на несколько этапов, или стадий, и представить их в виде отдельных HTML-документов. Например, в первом документе с диалогом у пользователя может запрашиваться его имя и фамилия, во втором - данные о его месте жительства, и в третьем - номер кредитной карточки. В любой момент можно вернуться на шаг назад, чтобы исправить те или иные данные. Наконец, если все в порядке, накопленная информация обрабатывается - например, помещается в базу данных.

Реализация такой схемы оказывается для Web-приложений довольно нетривиальной проблемой. Действительно, нам придется хранить все ранее введенные данные в каком-нибудь хранилище, которое должно аннулироваться, если пользователь вдруг передумает и уйдет с сайта. Для этого можно использовать функции сериализации и файлы. Однако ими мы решаем только половину проблемы: нам нужно как то привязать конкретного пользователя к конкретному временному хранилищу. Действительно, предположим, мы этого не сделали. Тогда, если в момент заполнения какой-нибудь формы одним пользователем на сайт зайдет другой и тоже попытается ввести свои данные, получится белеберда. Все эти проблемы решаются при помощи сессий.

[править] Механизм работы сессий

Для начала должен существовать механизм, который бы позволил PHP идентифицировать каждого пользователя, запустившего сценарий. То есть при следующем запуске PHP нужно однозначно определить, кто его запустил: тот же человек, или другой. Делается это путем присвоения клиенту так называемого уникального идентификатора сессии. Чтобы этот идентификатор был доступен при каждом запуске сценария, PHP помещает его Cookies браузера. Теперь, зная идентификатор (дальше SID), PHP может определить, в каком же файле на диске хранятся данные пользователя.

Немного о том, как сохранять переменную (обязательно глобальную) в сессии. Для этого мы должны ее зарегистрировать с помощью специальной функции. После регистрации мы можем быть уверены, что при следующем запуске сценария тем же пользователем она получит то же самое значение, которое было у нее при предыдущем завершении программы. Это произойдет потому, что при завершении сценария PHP автоматически сохраняет все переменные, зарегистрированные в сессии, во временное хранилище. Конечно, можно в любой момент аннулировать переменную - вычеркнуть ее из сессии, или же уничтожить вообще все данные сессии.

Где же находиться то промежуточное хранилище, которое использует PHP? Вообще говоря, вы вольны сами это задать, написав соответствующие функции и зарегистрировав их как обработчики сессии. Впрочем, делать это не обязательно: в PHP уже существуют обработчики по умолчанию, которые хранят данные в файлах. Если вы не собираетесь создавать что-то особенное, вам они вполне подойдут.

Получено с http://spravkaweb.local/index.php/php/managfun/session/about
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:31, 10 февраля 2007.
  • К этой странице обращались 109 раз.
1.57585716248


Справочник по PHP : Управляющие функции : Управление сессиями : Про сессии и Cookies — Справочник Web-языков

Справочник по PHP : Управляющие функции : Управление сессиями : Про сессии и Cookies

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Обзор обработчиков
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Управление сессиями | ::. | Про сессии и Cookies
 |  |  |  |  |  |  |  | Работа с WWW : Установка заголовков ответа

Проблема: - отключены Cookies

Бытует распространенное мнение, что сессии без Cookies не может существовать. Действительно, Cookies наиболее просто решает проблему идентификации пользователя, что необходимо для связи временного хранилища и данных сессии. Но вот что делать, если пользователь у себя в настройках отключил прием Cookies?

На этот случай разработчики PHP позаботились о передаче идентификаторов сессии не в Cookies, а каким-нибудь аналогичным путем, например через адресную строку броузера.

Решение: - изменение гиперссылок и форм

В PHP существует одна специальная константа с именем SID. Она всегда содержит имя группы сессии и ее идентификатор в формате имя=идентификатор. Именно в таком формате данные принимаются, когда они приходят из Cookies браузера. Таким образом, нам достаточно просто передать значение константы SID в сценарий, чтобы он "подумал", будто бы данные пришли из Cookies. Вот пример использования сессий без Cookies:

<?php
session_name("testses");
session_start();
session_register("i");
$i=@$i+1;
?>
<body>
Вы открыли эту страницу
<?=$i?> раз. При закрытии браузера счетчик обнулиться.<BR>
<A href=sesclick.php?<?=SID?>>Нажмите для записи в счетчик!</A>
</body>

Этот пример будет работать, если у пользователя действительно отключены Cookies. Если они включены, PHP просто не будет генерировать константу SID и задействует Cookies.

Но в приведенном способе есть одно неудобство, а именно, везде в участки кода нужно вставлять <?=SID?>, и если вы гдето пропустили, то программа может не работать!

К счастью, разработчики PHP учли эту возможность, и решили уберечь нас от этого. По-этому если в какой-нибудь гиперссылке вы по ошибке пропустите <?=SID?>, PHP вставит его автоматически. При этом не повредив остальные параметры, которые могут присутствовать в URL.

Для проверки можно использовать следующий пример:

<?session_start()?>
<body>
<A href="php.php">PHP</A>
<A href="php.php?ss=1">PHP - выражения</A>

Вот что получиться, при наведении мышки на эти ссылки:

http://www.spravkaweb.ru/php.php?PHPSESSID=81456f6a886f2104
http://www.spravkaweb.ru/php.php?ss=1&PHPSESSID=34f5d04a35601510f45

В PHP существует еще одна возможность использовать сессии с отключенными Cookies - добавление скрытых полей в формы, которые формируют сценарий, чтобы передать идентификатор сессии вызываемому документу.

Приведем пример, который выявляет эту возможность:

<?session_start()?>
<form action=act.php mathod=post>
</form>

А вот что получиться при просмотре нашей страницы в виде HTML:

<form action="act.php" method="post">
<INPUT TYPE=HIDDEN NAME="PHPSESSID" VALUE="0a561093f84d4321">
</form>

Из примера мы видим, что PHP добавил в форму скрытое поле с нужным именем и значением.

Получено с http://spravkaweb.local/index.php/php/managfun/session/cookies
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:08, 10 февраля 2007.
  • К этой странице обращались 71 раз.
1.12426900864


Справочник по PHP : Управляющие функции : Управление сессиями : Обзор обработчиков — Справочник Web-языков

Справочник по PHP : Управляющие функции : Управление сессиями : Обзор обработчиков

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Другие функции
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Управление сессиями | ::. | Обзор обработчиков
 |  |  |  |  |  |  |  | Про сессии и Cookies

Содержание

  • 1 handler_open
  • 2 handler_close
  • 3 handler_read
  • 4 handler_write
  • 5 handler_gc
  • 6 session_set_save_handler

[править] handler_open

Этот обработчик должен взять на себя всю работу по открытию базы данных для группы сессий с именем, которое было передано ей в параметрах.

Синтаксис:

bool handler_open(string $save_path, string $session_name)

Функция вызывается, когда вызывается session_start(). Обработчик должен взять на себя всю работу, связанную с открытием базы данных для группы сессий с именем $session_name. В параметре $save_path передается то, что было указано при вызове session_save_path() или же путь к файлам-хранилищам данных сессий по умолчанию.

[править] handler_close

Этот обработчик вызывается, когда данные сессии записаны во временное хранилище и его нужно закрыть.

Синтаксис:

bool handler_close()

[править] handler_read

Чтение данных сессии.

Синтаксис:

string handler_read(string $sid)

Этот обработчик вызывают, когда нужно прочитать данные сессии с идентификатором $sid из временного хранилища.

Возвращаемые данные представлены в следующем виде:

имя1=значение1;имя2=значение2;имя3=значение3;...

имяN задает имя очередной переменной, зарегистрированной в сессии, а занчениеN - результат вызова функции Serialize() для значения этой переменной.

Например, наша запись может иметь следующий вид:

foo|i:1;count|i:10;

Она говорит о том, что из временного хранилища были прочитаны две целые переменные, первая из которых равна 1, а вторая - 10.

[править] handler_write

Запись данных сессии.

Синтаксис : string handler_write(string $sid, string $data)

Этот обработчик предназначен для записи данных сессии с идентификатором $sid во временное хранилище - например, открытое ранее обработчиком handler_open(). Параметр $data задается в точно таком же формате. Фактически, чаще всего действие этой функции сводится к записи в базу данных строки $data без каких-либо ее изменений.

[править] handler_gc

Очищает временное хранилище данных через определенный промежуток времени.

Синтаксис:

bool handler_gc(int $maxlifetime)

Этот обработчик вызывается каждый раз при завершении работы сценария. Если пользователь окончательно покинул сервер, значит, данные сессии во временном хранилище можно уничтожить. Этим и должна заниматься функция handler_gc(). Ей передается в параметрах то время (в секундах), по прошествии которого PHP принимает решение о необходимости удалить все ненужные данные.

[править] session_set_save_handler

Регистрация обработчиков.

При описании обработчиков мы указывали их имена с префиксом handler. На самом деле, это совсем не является обязательным. Даже наоборот - вы можете давать такие имена своим обработчикам, какие только захотите.

Но возникает вопрос: как же тогда PHP их найдет? Вот для этого и существует функция регистрации обработчиков, которая говорит интерпретатору, какую функцию он должен вызывать при наступлении того или иного события.

Синтаксис:

void session_set_save_handler($open, $close, $read, $write, $destroy, $gc)

Эта функция регистрирует подпрограммы, имена которых переданы в ее параметрах, как обработчики текущих сессии. Параметр $open содержит имя функции, которая будет вызвана при инициализации сессии, а $close - функции, вызываемой при ее закрытии. В $read и $write нужно указать имена обработчиков, соответственно, для чтения и записи во временное хранилище. Функция с именем, заданным в $destroy, будет вызвана при уничтожении сессии. Наконец, обработчик, определяемый параметром $gc, используется как обработчик мусора.

Эту функцию можно вызывать только до инициализации сессии, в противном случае она просто игнорируется.

Получено с http://spravkaweb.local/index.php/php/managfun/session/handler
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:50, 10 февраля 2007.
  • К этой странице обращались 65 раз.
1.11164188385


Справочник по PHP : Управляющие функции : Управление сессиями : Идентификатор сессии — Справочник Web-языков

Справочник по PHP : Управляющие функции : Управление сессиями : Идентификатор сессии

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Имя группы сессии
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Управление сессиями | ::. | Идентификатор сессии
 |  |  |  |  |  |  |  | Другие функции

Итак, идентификатор сессии является именем временного хранилища, которое будет использовано для хранения данных сессии между запусками сценария. Один SID - одно хранилище. Нет SID, нет и хранилища, и наоборот.

Так как же соотносится идентификатор и имя группы? Имя - это всего лишь собирательное название для нескольких сессий (то есть, для многих SID), запущенных разными пользователями. Один и тот же клиент никогда не будет иметь два различных SID в пределах одного имени группы. Но его браузер вполне может работать с несколькими SID, расположенными логически в разных "пространствах имен".

Итак, все SID уникальны и однозначно определяют сессию на компьютере, выполняющем сценарий - независимо от имени сессии. Имя же задает пространство имен, в которое будут сгруппированы сессии, запущенные разными пользователями. Один клиент может иметь сразу несколько активных пространств имен (то есть несколько имен групп сессий).

[править] session_id

Эта функция возвращает текущий идентификатор сессии SID.

Синтаксис:

string session_id([string $sid])

Если задан параметр $sid, то у активной сессии изменяется идентификатор на $sid.

Вызвав session_id() до session_start(), мы можем подключиться к любой (в том числе и к чужой) сессии на сервере, если знаем ее идентификатор. Мы можем также создать сессию с угодным нам идентификатором, при этом автоматически установив его в Cookies пользователя.

Получено с http://spravkaweb.local/index.php/php/managfun/session/id
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:40, 10 февраля 2007.
  • К этой странице обращались 63 раза.
1.46509981155


Справочник по PHP : Управляющие функции : Управление сессиями : Иинициализация сессии и регистрация переменных — Справочник Web-языков

Справочник по PHP : Управляющие функции : Управление сессиями : Иинициализация сессии и регистрация переменных

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Зачем нужны сессии.Механизм работы сессий
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Управление сессиями | ::. | Иинициализация сессии и регистрация переменных
 |  |  |  |  |  |  |  | Имя группы сессии

[править] session_start

Эта функция инициализирует механизм сессий для текущего пользователя, запустившего сценарий.

Синтаксис:

void session_start()

Если посетитель запускает программу впервые, у него устанавливается Cookies с уникальным идентификатором, и создается временное хранилище, ассоциированное с этим идентификатором. Определяется, какое хранилище связано с текущим идентификатором пользователя. Если в хранилище имеются какие-то переменные, их значения восстанавливаются. Точнее, создаются глобальные переменные, которые были сохранены в сессии при предыдущем завершении сценария.

Надо заметить, что если вы поставили в настройках PHP режим session.auto_start=1, то функция инициализации вызывается автоматически при запуске сценария. Так же надо следить за тем, чтобы до нашей функции не было никакого вывода в браузер - иначе PHP не сможет установить SID для пользователя.

Функция всегда возвращает true.

[править] session_register

Указывает PHP на то, что ту или иную переменную нужно сохранить в сессии.

Синтаксис:

bool session_register(mixed name [, mixed name1, ...])

Функция принимает в параметрах одно или несколько имен переменных (имена задаются в скобках, без знака $ слева), регистрируют их в текущей запущенной сессии и возвращает true, если регистрация прошла успешно.

Повторная запись одной переменной в сессии не приведет к ошибке.

<?php
session_start();
session_register("count");
$count=@$count+1;
?>
<h2>Счетчик</h2>
В текущей сессии работы с браузером вы открыли эту страницу
<?=$count?> раз(а). Закройте браузер, чтобы обнулить счетчик.
</body>
Получено с http://spravkaweb.local/index.php/php/managfun/session/init
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:34, 10 февраля 2007.
  • К этой странице обращались 71 раз.
1.39629817009


Справочник по PHP : Управляющие функции : Управление сессиями : Другие функции — Справочник Web-языков

Справочник по PHP : Управляющие функции : Управление сессиями : Другие функции

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Идентификатор сессии
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Управление сессиями | ::. | Другие функции
 |  |  |  |  |  |  |  | Обзор обработчиков

Содержание

  • 1 session_is_registered
  • 2 session_unregister
  • 3 session_unset
  • 4 session_save_path

[править] session_is_registered

Проверяет, зарегистрирована или нет та или иная переменная.

Синтаксис:

bool session_is_registered(string $name)

Функция возвращает true, если переменная с именем $name была зарегистрирована в сессии, иначе возвращает false.

[править] session_unregister

Отменяет регистрацию переменной.

Синтаксис:

bool session_unregister(string $name)

Эта функция отменяет регистрацию для переменной с именем $name для текущей сессии. Или иначе, при завершении сценария все будет выглядеть так, словно переменная с именем $name и небыла никогда зарегистрирована.

Возвращает true, если все прошло успешно, и false - в противном случае.

Отметим, что после вызова функции session_unregister() глобальная переменная, которая была "аннулирована", не уничтожается, а сохраняет свое значение.

[править] session_unset

Отменяет регистрацию и уничтожает глобальные переменные.

Синтаксис:

void session_unset()

Эта функция, в отличии от session_unregister(), не только отменяет регистрацию переменных (всех переменных сессии, а не только какой-то одной), но и уничтожает глобальные переменные, которые были зарегестрированы в сессии.

[править] session_save_path

Имя каталога, в котором будут храниться файлы с данными из сессий.

Синтаксис:

string session_save_path([string $path])

Эта функция возвращает имя каталога, в котором будут помещаться файлы - временные хранилища данных сессии. В случае, если указан параметр, активное имя каталога будет переустановлено на $path. При этом функция вернет предыдущий каталог.

Получено с http://spravkaweb.local/index.php/php/managfun/session/othefun
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:45, 10 февраля 2007.
  • К этой странице обращались 62 раза.
1.26343417168


Справочник по PHP : Управляющие функции : Управление сессиями : Имя группы сессии — Справочник Web-языков

Справочник по PHP : Управляющие функции : Управление сессиями : Имя группы сессии

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Иинициализация сессии и регистрация переменных
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Управление сессиями | ::. | Имя группы сессии
 |  |  |  |  |  |  |  | Идентификатор сессии

Надо отметить, что на одном и том же сайте могут существовать сразу несколько сценариев, которые нуждаются в услугах поддержки сессий PHP. Они "ничего не знают" друг о друге, поэтому временные хранилища для сессий должны выбираться не только на основе идентификатора пользователя, но и на основе того, какой из сценариев запросил обслуживание сессии.

Для наглядности рассмотрим пример:

Пусть разработчик А написал сценарий счетчика. Он использует переменную $count, и не имеет никаких проблем. До тех пор, пока разработчик В, ничего не знающий о сценарии А, не создал систему статистики, которая тоже использует сессии. Самое ужасное, что он также регистрирует переменную $count, не зная о том, что она уже занята. В результате, как всегда, страдает пользователь: запустив сначало сценарий разработчика В, а потом - А, он видит, что данные счетчиков перемешались.

Нам нужно как-то разграничить сессии, принадлежащие одному сценарию, от сессии, принадлежащих другому. К счастью, разработчики PHP предусмотрели такое положение вещей. Мы можем давать группам сессии непересекающиеся имена, и сценарий, знающий имя своей группы сессии, сможет получить к ней доступ. Вот теперь-то разработчики А и В могут оградить свои сценарии от проблем с пересечением имен переменных. Достаточно в первой программе указать PHP, что мы хотим использовать группу с именем, например, sesA, а во второй - sesB.

[править] session_name

Эта функция устанавливает или возвращает имя группы сессии, которая будет использоваться PHP для хранения зарегистрированных переменных.

Синтаксис:

string session_name([string $newname])

Если $newname не задан, то возвращается текущее имя. Если же этот параметр указан, то имя группы будет изменено на $newname, при этом функция вернет предыдущее имя.

Отметим, что session_name() лишь сменяет имя текущей группы и сессии, но не создает новую сессию и временное хранилище. Это значит, что мы должны в большинстве случаев вызывать session_name(имя_группы) еще до ее инициализации - вызова session_start(), в противном случае мы получим совсем не то, что ожидали.

Если функция session_name() не была вызвана по инициализации, PHP будет использовать имя по умолчанию - PHPSESID.

Пример:

<?php
session_name("CounterScript"
session_start();
session_register("count");
$count=@$count+1;
?>

В текущей сессии вы открыли эту страницу <?=$count?> раз(а).

Получено с http://spravkaweb.local/index.php/php/managfun/session/sessionname
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:38, 10 февраля 2007.
  • К этой странице обращались 61 раз.
1.19916892052


Справочник по PHP : Управляющие функции : Работа с WWW : Работа с Cookies — Справочник Web-языков

Справочник по PHP : Управляющие функции : Работа с WWW : Работа с Cookies

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Получение заголовков запроса
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Работа с WWW | ::. | Работа с Cookies
 |  |  |  |  |  |  |  | SSI и функция virtual()

[править] Немного теории

Cookie - это именованная порция информации, которая может сохраняться прямо в настройках браузера пользователя между сеансами. Причина, по которой применяются Cookies - большое количество посетителей вашего сервера, а также нежелание иметь нечто подобное базе данных для хранения информации о каждом посетителе. Поиск в такой базе данных может очень и очень затянуться, и, в тоже время, нет никакого смысла централизованно хранить столь отрывочные сведения. Использование Cookies фактически перекладывает задачу на плечи браузера, решая одним махом как проблему быстродействия, так и проблему большого объема базы данных с информацией о пользователе.

Самый распространенный прием применения Cookies - логин и пароль пользователя, использующего некоторые защищенные ресурсы вашего сайта. Эти данные, конечно же, между открытиями страниц хранятся в Cookies, для того чтобы пользователю не пришлось их каждый раз набирать вручную заново.

У каждого Cookies есть определенное время жизни, по истечении которого он автоматически уничтожается. Существуют также Cookies, которые "живут" только в течение текущего сеанса работы с браузером.

Каждый Cookie устанавливается сценарием на сервере. Для этого он должен послать браузеру специальный заголовок вида:

Set-cookie: данные

Сценарии с других серверов, а также расположенные в другом каталоге, не будут извещены о "чужих" Cookies. Для них их словно и нет. И это правильно с точки зрения безопасности - кто знает, насколько секретна может быть информация, сохраненная в Cookies?

[править] Получение Cookie

Предположим, сценарий отработал и установил какой-то Cookie, например, с именем Cook и значением Val. В следующий раз при запуске этого сценария (на самом деле, и всех других сценариев, расположенных на том же сервере в том же каталоге или ниже по дереву) ему предастся пара типа Cook=Val (через специальную переменную окружения). PHP это событие перехватит и автоматически создаст переменную $Cook со значением Val. То есть интерпретатор действует точно так же, как если бы значение нашего Cookie пришло откуда-то из формы. Та переменная, которую мы установили в прошлый раз, будет доступна и сейчас.

[править] setcookie

Установка Cookie.

Синтаксис:

int setcookie(string $name [,string $value] [,int $expire] [,string $path] [,string $domain] [,book $secure])

Так как Cookie фактически представляет собой заголовок, установить его можно только перед первой командой вывода в сценарий.

Вызов setcookie() определяет новый Cookie, который тут же посылается браузеру вместе с остальными заголовками. Все аргументы, кроме имени, необязательны. Если задан только параметр $name (имя Cookie), то Cookie с указанным именем у пользователя удаляется. Вы можете пропускать аргументы, которые не хотите задавать, пустыми строками "". Аргументы $expire и $secure не могут быть представлены строками, а потому вместо пустых строк здесь нужно использовать 0.

Параметр $expire задает timestamp, который, например, может быть сформирован функциями time() или mktime().

Параметр $secure говорит о том, что величина Cookie может передаваться только через безопасное HTTPS-соединение.

Примеры:

// Cookie на одну сессию, т.е. до закрытия браузера
SetCookie("TextCookie","value");

// Эти Cookies уничтожаются браузером через 1 час после установки
SetCookie("TextCookie",$val,time()+3600);
SetCookie("TextCookie",$val,time()+3600,"/~rasmus/",".utoronto.ca",1);

После вызова SetCookie() только что созданный Cookie сразу появляется среди глобальных переменных как переменная с заданным в параметре $name именем. Она появиться и при следующем запуске сценария - даже если SetCookie() в нем и не будет вызвана.

Получено с http://spravkaweb.local/index.php/php/managfun/www/cookies
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:17, 10 февраля 2007.
  • К этой странице обращались 82 раза.
1.36763381958


Справочник по PHP : Управляющие функции : Работа с WWW : Установка заголовков ответа — Справочник Web-языков

Справочник по PHP : Управляющие функции : Работа с WWW : Установка заголовков ответа

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Управление сессиями : Про сессии и Cookies
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Работа с WWW | ::. | Установка заголовков ответа
 |  |  |  |  |  |  |  | Получение заголовков запроса

[править] Header

Вывод заголовка.

Синтаксис:

int Header(string $string)

Обычно функция Header() является одной из первых команд сценария. Она предназначена для установки заголовков ответа, которые будут переданы браузеру - по одному заголовку на вызов. Вызов Header() обязательно должен осуществляться до любого оператора вывода в сценарии - в противном случае вы получете предупреждение. Текст вне <? и ?> также рассматривается как оператор вывода.

Пример:

// перенаправляет браузер на сайт PHP
Header("Location: http://www.php.net");
// теперь принудительно завершаем сценарий, ввиду того, что после
// перенаправления больше делать нечего
exit;

[править] Смотреть также

  • Советы по PHP : Запрет кэширования посредством PHP
Получено с http://spravkaweb.local/index.php/php/managfun/www/headeranswer
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 13:29, 18 марта 2007.
  • К этой странице обращались 128 раз.
1.3133149147


Справочник по PHP : Управляющие функции : Работа с WWW : Получение заголовков запроса — Справочник Web-языков

Справочник по PHP : Управляющие функции : Работа с WWW : Получение заголовков запроса

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Установка заголовков ответа
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Работа с WWW | ::. | Получение заголовков запроса
 |  |  |  |  |  |  |  | Работа с Cookies

[править] getallheaders

Получение всех заголовков запроса.

Синтаксис:

array GetAllHeaders()

Функция GetAllHeaders() возвращает ассоциативный массив, содержащий данные о HTTP-заголовках запроса клиента, породившего запуск сценария. Ключи массива содержат названия заголовков, а значения - их величины.

$headers = GetAllHeaders();
foreach($headers as $header=>$value)
echo "$header: $value<br>n";

Функция GetAllHeaders() поддерживается PHP только в том случае, если он установлен в виде модуля Apache. В противном случае этой функции просто не будет (да и не может быть, потому что обычный CGI-сценарий не имеет доступа к заголовкам запроса). В частности, в PHP для Windows (который чаще всего реализуют именно в виде сценария) функция GetAllHeaders() недоступна.

Получено с http://spravkaweb.local/index.php/php/managfun/www/headerquery
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:13, 10 февраля 2007.
  • К этой странице обращались 77 раз.
1.21503996849


Справочник по PHP : Управляющие функции : Работа с WWW : SSI и функция virtual() — Справочник Web-языков

Справочник по PHP : Управляющие функции : Работа с WWW : SSI и функция virtual()

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Работа с Cookies
Главная | ::. | PHP | ::. | Управляющие функции | ::. | Работа с WWW | ::. | SSI и функция virtual()
 |  |  |  |  |  |  |  | Управление выводом : Введение

[править] Немного теории

Для одного и того же документа в Apache нельзя применять два "обработчика". Иными словами, действует принцип: либо PHP, либо SSI.

Однако в PHP имеются определенные средства для "эмуляции" SSI-конструкции include virtual.

Конструкция include virtual загружает файл, URL которого указан у нее в параметрах, обрабатывает его нужным обработчиком и выводит в браузер. То есть все происходит так, будто указанный URL был затребован виртуальным браузером. Большинство SSI-файлов ограничиваются использованием этой возможности.

[править] virtual

Имитация include virtual.

Синтаксис:

int virtual(string $url)

Функция virtual() представляет собой процедуру, которая может поддерживаться только в случае, если PHP установлен как модуль Apache. Она делает то же самое, что и SSI-инструкция <-- #include virtual=... -->. Иными словами, она генерирует новый запрос серверу, обрабатываемый им обычным образом, а затем выводит данные в стандартный поток вывода.

Чаше всего функция virtual() используется для запуска внешних CGI-сценариев, написанных на другом языке программирования, или же для обработки SSI-файлов более сложной структуры. В случае, если запускается сценарий, он должен генерировать правильные HTTP-заголовки, иначе будет выведено сообщение об ошибке. Для включения обычных PHP-файлов с участками кода функция virtual() неприменима - это выполняет оператор include.

Получено с http://spravkaweb.local/index.php/php/managfun/www/ssi
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:20, 10 февраля 2007.
  • К этой странице обращались 65 раз.
1.11659884453


Справочник по PHP : Файлы и сети : Функции IMAP — Справочник Web-языков

Справочник по PHP : Файлы и сети : Функции IMAP

 |  |  |  |  |  | Функции сжатия Bzip2 : Работа с файлами Bzip2
Главная | ::. | PHP | ::. | Файлы и сети | ::. | Функции IMAP
 |  |  |  |  |  | Функции SNMP

Для того, чтобы эти функции заработали вы должны скомпилировать PHP с флагом --with-imap.

Этот флаг требует,чтобы была установлена библиотека c-client. Последнюю версию можно получить по адресу ftp://ftp.cac.washington.edu/imap/.

Затем скопируйте c-client/c-client.a в /usr/local/lib или какую либо другую директорию, прописанную в пути, затем скопируйте c-client/rfc822.h, mail.h и linkage.h в /usr/local/include или другую директорию с include-файлами.

Не смотря на имя модуля, имеющиеся в нем функции позволяют выполнять также много других полезных операций, выходящих за рамки простого использования протокола IMAP. Лежащая в основе библиотека C-клиента также поддерживает NNTP, POP3 и методы доступа к локальным почтовым ящикам.

Содержание

  • 1 imap_append
  • 2 imap_base64
  • 3 imap_body
  • 4 imap_check
  • 5 imap_close
  • 6 imap_createmailbox
  • 7 imap_delete
  • 8 imap_deletemailbox
  • 9 imap_expunge
  • 10 imap_fetchbody
  • 11 imap_fetchstructure
  • 12 imap_header
  • 13 imap_headers
  • 14 imap_listmailbox
  • 15 imap_listsubscribed
  • 16 imap_mail_copy
  • 17 imap_mail_move
  • 18 imap_num_msg
  • 19 imap_num_recent
  • 20 imap_open
  • 21 imap_ping
  • 22 imap_renamemailbox
  • 23 imap_reopen
  • 24 imap_subscribe
  • 25 imap_undelete
  • 26 imap_unsubscribe
  • 27 imap_qprint
  • 28 imap_8bit
  • 29 imap_binary
  • 30 imap_scanmailbox
  • 31 imap_mailboxmsginfo
  • 32 imap_rfc822_write_address
  • 33 imap_rfc822_parse_adrlist
  • 34 imap_setflag_full
  • 35 imap_clearflag_full
  • 36 imap_sort
  • 37 imap_fetchheader
  • 38 imap_uid

[править] imap_append

Добавляет текстовое сообщение в указанный почтовый ящик.

Синтаксис:

int imap_append(int imap_stream, string mbox, string message, stringflags);

Возвращает true в случае успеха или false иначе.

imap_append() добавляет текстовое сообщение в указанный почтовый ящик mbox. Если указаны необязательные флаги, также записывает в почтовый ящик и флаги. При общении с сервером Cyrus IMAP нужно использовать в качестве ограничителей строки "rn" вместо "n",иначе действие не выполнится.

[править] imap_base64

Декодирует текст, закодированный с помощью BASE64.

Синтаксис:

string imap_base64(string text);

Функция imap_base64() декодирует текст в формате BASE-64. Декодированное сообщение возвращается как строка.

[править] imap_body

Читает тело сообщения.

Синтаксис:

string imap_body(int imap_stream, int msg_number, int flags);

Функция imap_body() возвращает тело сообщения, имеющего номер п/п msg_number в текущем почтовом ящике.

Необязательные флаги это битовые маски из

  • FT_UID - Номер сообщения msgno является UID-ом сообщения
  • FT_PEEK - Не устанавливать флаг Seen если он еще не установлен.
  • FT_INTERNAL - Возвращаемая строка записана во внутреннем формате и не может быть приведена к канонической форме с CRLF.

[править] imap_check

Проверяет текущий почтовый ящик.

Синтаксис:

array imap_check(int imap_stream);

Возвращает информацию о текущем почтовом ящике. В случае неуспеха возвращает FALSE.

Функция imap_check() проверяет статус текущего почтового ящика на сервере и возвращает информацию в объекте со следующими свойствами :

  • Date : дата сообщения
  • Driver : драйвер
  • Mailbox : название почтового ящика
  • Nmsgs : количество сообщений
  • Recent : количество недавно пришедших сообщений

[править] imap_close

Закрывает поток IMAP.

Синтаксис:

int imap_close(int imap_stream, int flags);

Закрывает поток imap. Необязательный флаг CL_EXPUNGE заставляет стереть помеченные на удаление сообщения при закрытии.

[править] imap_createmailbox

Создает новый почтовый ящик.

Синтаксис:

int imap_createmailbox(int imap_stream, string mbox);

imap_createmailbox() создает новый почтовый ящик указанный в mbox.Возвращает true в случае успеха и false при ошибке.

[править] imap_delete

Помечает сообщение из текущего почтового ящика на удаление.

Синтаксис:

int imap_delete(int imap_stream, int msg_number);

Возвращает true. Функция imap_delete() помечает сообщение, указанное через msg_number на удаление. Настоящее удаление сообщений осуществляется функцией imap_expunge().

[править] imap_deletemailbox

Удаляет почтовый ящик.

Синтаксис:

int imap_deletemailbox(int imap_stream, string mbox);

Возвращает true в случае успеха и false иначе.

[править] imap_expunge

Удаляет все сообщения, помеченные на удаление.

Синтаксис:

int imap_expunge(int imap_stream);

imap_expunge() удаляет все сообщения помеченные на удаление с помощью imap_delete().

Возвращает true.

[править] imap_fetchbody

Извлекает простую секцию тела сообщения.

Синтаксис:

string imap_fetchbody(int imap_stream, int msg_number, int part_number, flags flags);

Эта функция заставляет извлечь подробную секцию указанного сообщения как текстовую строку. Секция это строка целых чисел, разделенных точками, которые указывают на части тела сообщения в списке частей согласно спецификации IMAP4. Части тела не декодируются этой функцией.

Необязательным параметром к imap_fetchbody() является битовая маска из

  • FT_UID - msgono является
  • UID-ом FT_PEEK - не устанавливать флаг Seen если он не установлен
  • FT_UID - возвращаемая строка записана во внутреннем формате, которое не может быть канонизированна с помощью CRLF

[править] imap_fetchstructure

Читает структуру простого сообщения.

Синтаксис:

array imap_fetchstructure(int imap_stream, int msg_number);

Эта функция заставляет извлечь всю информацию о структуре сообщения с номером msg_number. Возвращаемая величина является объектом со следующими элементами :

  • type - тип
  • encoding - кодировка
  • ifsubtype - подтип интерфейса
  • subtype - подтип
  • ifdescription - описание интерфейса
  • description - описание
  • ifid - идентификатор интерфейса
  • id
  • lines - строки
  • bytes - байты
  • ifparameters - параметры интерфейса

Также функция возвращает массив объектов под названием parameters[]. Этот объект имеет следующие свойства :

  • attribute - атрибут

value - величина

В случае сообщения из нескольких частей, функция также возвращает массив объектов всех свойств под название parts[].

[править] imap_header

Читает заголовок сообщения.

Синтаксис:

object imap_header(int imap_stream, int msg_number, int fromlength, int subjectlength, int defaulthost);

Эта функция возвращает объект различных элементов заголовка

  • remail
  • date
  • Date
  • subject
  • Subject
  • in_reply_to
  • message_id
  • newsgroups
  • followup_to
  • references
  • toaddress (полная строка To: строка длиной до 1024 символов)
  • to[] (возвращает массив объектов из строки To, содержит:)
  • personal
  • adl
  • mailbox
  • host
  • fromaddress (полная строка From: строка длиной до 1024 символов)
  • from[] (возвращает массив объектов из строки From, содержит:)
  • personal
  • adl
  • mailbox
  • host
  • ccaddress (полная строка Cc: строка длиной до 1024 символов)
  • cc[] (возвращает массив объектов из строки Cc, содержит)
  • personal
  • adl
  • mailbox
  • host
  • bccaddress (полная строка Bcc: строка длиной до 1024 символов)
  • bcc[] (возвращает массив объектов из строки Bcc, содержит:)
  • personal
  • adl
  • mailbox
  • host
  • reply_toaddress (полная строка Reply_to: строка длиной до 1024 символов)
  • reply_to[] (возвращает массив объектов из строки Reply_to, содержит:)
  • personal
  • adl
  • mailbox
  • host
  • senderaddress (полная строка Sender: строка длиной до 1024 символов)
  • sender[] (возвращает массив объектов из строки Sender, содержит:)
  • personal
  • adl
  • mailbox
  • host
  • return_path (полная строка Return-path: строка длиной до 1024 символов)
  • return_path[] (возвращает массив объектов из строки Return_path, содержит:)
  • personal
  • adl
  • mailbox
  • host
  • udate ( дата сообщения в формате времени unix)
  • fetchfrom (строка From, отформатированная до fromlength символов)
  • fetchsubject (строка Subject, отформатированная до subjectlength символов)

[править] imap_headers

Возвращает заголовки всех сообщений в почтовом ящике.

Синтаксис:

array imap_headers(int imap_stream);

Возвращает строковый массив из информации по заголокам. Один элемент массива на сообщение.

[править] imap_listmailbox

Читает список почтовых ящиков.

Синтаксис:

array imap_listmailbox(int imap_stream, string ref, string pat);

Возвращает массив, содержащий названия почтовых ящиков.

[править] imap_listsubscribed

Перечисляет все подписанные ящики.

Синтаксис:

array imap_listsubscribed(int imap_stream, string ref, string pattern);

Возвращает массив всех почтовых ящиков на которые Вы подписаны. Аргументы ref и pattern указывают начальноеместорасположение откуда начинать поиск и шаблон, которому должны удовлетворять названия почтовых ящиков.

[править] imap_mail_copy

Копирует указанные сообщения в почтовый ящик.

Синтаксис:

int imap_mail_copy(int imap_stream, string msglist, string mbox, int flags);

Возвращает true в случае успеха и false иначе.

Копирует почтовые сообщения указанные с помощью msglist в почтовый ящик mbox.

msglist - это диапазон, а не простономера сообщений.

Флаги - это битовые маски из

  • CP_UID - номера в последовательности содержат
  • UID-ы CP_MOVE - после копирования удалить сообщения из текущего почтового ящика

[править] imap_mail_move

Переносит указанные сообщения в почтовый ящик.

Синтаксис:

int imap_mail_move(int imap_stream, string msglist, string mbox);

Переносит почтовые сообщения указанные с помощью msglist в почтовый ящик mbox.

msglist - это диапазон, а не простономера сообщений.

Возвращает true в случае успеха и false иначе.

[править] imap_num_msg

Выдает количество сообщений в текущем почтовом ящике.

Синтаксис:

int imap_num_msg(void);

Возвращает количество сообщений в текущем почтовом ящике.

[править] imap_num_recent

Возвращает количество недавно пришедших сообщений в текущем почтовом ящике.

Синтаксис:

int imap_num_recent(int imap_stream);

[править] imap_open

Подключение к серверу (открытие почтового ящика).

Синтаксис:

int imap_open(string mailbox, string username, string password [, int flags]);

Функция imap_open() возвращает дескриптор почтового ящика IMAP (дескриптор подключения к серверу IMAP) или false при ошибке.

Эта функция может быть использована для открытия потоков к POP3 и NNTP серверам, но в этом случае некоторые функции будут недоступны.

Аргумент mailbox - задает имя сервера и путь к почтовому ящику. Имя сервера следует заключать в фигурные скобки "{" и "}", внутри которых должно содержаться: имя сервера (или его IP-адрес), возможно указание протокола (который начинается со слеша "/") и номера порта.

Для того, чтобы присоединиться к серверу IMAP на 143-й порт на локальной машине сделайте следующее:

$mbox = imap_open("{localhost:143}INBOX","user_id","password");

Для того, чтобы подсоединиться к POP3-серверу на 110-й порт на локальном сервере используйте:

$mbox = imap_open("{localhost/pop3:110}INBOX","user_id","password");

Для того, чтобы подсоединиться к NNTP-серверу на 119-й порт на локальном сервере используйте:

$nntp = imap_open("{localhost/nntp:119}comp.test","","");

Для того, чтобы подсоединиться к удаленному серверу замените "localhost" на имя или IP-адрес сервера к которому Вы хотите подсоединиться.

Опции - битовая маска из

  • OP_READONLY - Открыть почтовый ящик в режим "только чтение"
  • OP_ANONYMOUS - Не использовать или не обновлять .newsrc при использовании новостей
  • OP_HALFOPEN - Для IMAP и NNTP устанавливает соединение, но не открывает почтовый ящик
  • CL_EXPUNGE - Автоматически очищать почтовый ящик при закрытии

[править] imap_ping

Проверяет поток IMAP на работоспособность.

Синтаксис:

int imap_ping(int imap_stream);

Возвращает true если поток еще работоспособен и false иначе.

Функция imap_ping() проверяет поток на работоспособность. Он может также проверять новую почту; это предпочтительный метод для периодической проверки новой почты и "живучести" удаленных серверов.

[править] imap_renamemailbox

Переименовывает старый почтовый ящик в новый.

Синтаксис:

int imap_renamemailbox(int imap_stream, string old_mbox, string new_mbox);

Эта функция переименовывает старый почтовый ящик в новый. Возвращает true в случае успеха и false иначе.

[править] imap_reopen

Заново открывает поток IMAP на новый почтовый ящик.

Синтаксис:

int imap_reopen(string imap_stream, string mailbox, string [flags]);

Возвращает true в случае успеха и false иначе.

Эта функция заново открывает указанный поток на новый ящик.

Опции - битовая маска из

  • OP_READONLY - Открыть почтовый ящик в режиме только чтение
  • OP_ANONYMOUS - Не использовать или не обновлять .newsrc при работе с новостями
  • OP_HALFOPEN - Для IMAP и NNTP устанавливает связь но не открывает почтовый ящик
  • CL_EXPUNGE - Очищает почтовый ящик при закрытии

[править] imap_subscribe

Подписывает на почтовый ящик.

Синтаксис:

int imap_subscribe(int imap_stream, string mbox);

Возвращает true в случае успеха и false иначе.

[править] imap_undelete

Снимает отметку с сообщения помеченного на удаление.

Синтаксис:

int imap_undelete(int imap_stream, int msg_number);

Эта функция cнимает отметку с сообщения помеченного на удаление функцией imap_delete().

Возвращает true в случае успеха и false иначе.

[править] imap_unsubscribe

Снимает подписку с почтового ящика.

Синтаксис:

int imap_unsubscribe(int imap_stream, string mbox);

Возвращает true в случае успеха и false иначе.

[править] imap_qprint

Конвертирует строку формата quoted-printable в 8-битовую строку.

Синтаксис:

string imap_qprint(string string);

Возвращает 8-битовую (бинарную) строку.

[править] imap_8bit

Конвертирует 8-битовую строку в формат quoted-printable.

Синтаксис:

string imap_8bit(string string);

Возвращает строку в формате quoted-printable.

[править] imap_binary

Конвертирует 8-битную строку в формат base64.

Синтаксис:

string imap_binary(string string);

Возвращает строку в формате base64.

[править] imap_scanmailbox

Читает список почтовых ящиков, проводит поиск в названиях ящиков.

Синтаксис:

array imap_scanmailbox(int imap_stream, string string);

Возвращает массив, содержащий имена почтовых ящиков, которые имеют строку string в названии.

[править] imap_mailboxmsginfo

Получает информацию о текущем почтовом ящике.

Синтаксис:

array imap_mailboxmsginfo(int imap_stream);

Возвращает информацию о текущем почтовом ящике. FALSE в случае неудачи.

Функция imap_mailboxmsginfo() проверяет статус текущего почтового ящика на сервере и возвращает информацию в объекте со следующими свойствами:

  • Date : дата сообщения
  • Driver : драйвер
  • Mailbox : название почтового ящика
  • Nmsgs : количество сообщений
  • Recent : количество недавно пришедших сообщений
  • Unread : количество непрочитанных сообщений
  • Size : размер почтового ящика

[править] imap_rfc822_write_address

Возвращает правильно отформатированный email адрес.

Синтаксис:

string imap_rfc822_write_address(string mailbox, string host, string personal);

Возвращает правильно отформатированный email адрес по данному почтовому ящику, хосту и персональной информации.

[править] imap_rfc822_parse_adrlist

Проводит разбор адресной строки.

Синтаксис:

string imap_rfc822_parse_adrlist(string address, string default_host);

Эта функция разбирает адресную строку и для каждого адреса возвращает массив объектов.

Есть 4 типа объектов:

  • mailbox - название почтового ящика (имя пользователя)
  • host - название хоста
  • personal - личное имя
  • adl - путь к домену-источнику

[править] imap_setflag_full

Устанавливает флаги на сообщения.

Синтаксис:

string imap_setflag_full(int stream, string sequence, string flag, string options);

Эта функция застваляет добавить указанный флаг к набору флагов сообщения в указанной последовательности.

options - это битовая маска из ST_UID

Аргументы последовательности содержат UIDы вместо номеров

[править] imap_clearflag_full

Очищает флаги сообщения.

Синтаксис:

string imap_clearflag_full(int stream, string sequence, string flag, string options);

Эта функция заставляет удалить флаги из набора флагов сообщения в указанной последовательности.

options - это битовая маска из ST_UID

Аргументы последовательности содержат UIDы вместо номеров

[править] imap_sort

Сортирует сообщения в текущем почтовом ящике.

Синтаксис:

string imap_sort(int stream, int criteria, int reverse, int options);

Возвращает массив номеров сообщений рассортированных по данному параметру

reverse должен быть равен 1 если нужна сортировка в обратном порядке

Критерии сортировки (должен быть указан только один):

  • SORTDATE - по дате сообщения
  • SORTARRIVAL - по дате поступления
  • SORTFROM - по полю From
  • SORTSUBJECT - по теме сообщения
  • SORTTO - по полю To
  • SORTCC - по полю cc
  • SORTSIZE - по размеру

опции - битовая маска из

  • SE_UID - Возвратить UIDы вместо номеров последовательности
  • SE_NOPREFETCH - Не извелекать заранее найденные сообщения

[править] imap_fetchheader

Возвращает заголовок сообщения.

Синтаксис:

string imap_fetchheader(int imap_stream, int msgno, int flags);

Эта функция заставляет извлечь полный, не отфильтрованный заголовок указанного сообщения в формате RFC 822 как текстовую строку.

Опиции:

  • FT_UID msgno является UID-ом
  • FT_INTERNAL Возвращаемая строка записана во внутреннем формате без каких-либо попыток канонизировать ее с помощью CRLF
  • FT_PREFETCHTEXT RFC822. Текст должен быть предварительно разобран. Это поможет избежать экстренных задержек если требуется извлечь полный текст сообщения (например, в операции "сохранить в локальном файле")

[править] imap_uid

Эта функция возвращает UID по данному номеру сообщения в последовательности.

Синтаксис:

string imap_uid(string mailbox, int msgno);
Получено с http://spravkaweb.local/index.php/php/netfile/imap
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:12, 8 февраля 2007.
  • К этой странице обращались 117 раз.
1.66294789314


Справочник по PHP : Файлы и сети : Сетевые функции — Справочник Web-языков

Справочник по PHP : Файлы и сети : Сетевые функции

 |  |  |  |  |  | Функции Vmailmgr
Главная | ::. | PHP | ::. | Файлы и сети | ::. | Сетевые функции
 |  |  |  |  |  | Управляющие функции : Отслеживание и обработка ошибок : Введение

Содержание

  • 1 ip2long
  • 2 long2ip
  • 3 gethostbyaddr
  • 4 gethostbyname
  • 5 gethostbynamel
  • 6 getprotobyname
  • 7 getprotobynumber
  • 8 getservbyname
  • 9 getservbyport
  • 10 checkdnsrr
  • 11 getmxrr

[править] ip2long

Производит конвертацию строки адреса IPv4 в число.

Синтаксис:

int ip2long(string ip_address);

Функция ip2long() возвращает четырех байтовое численное представление адреса IP v4 из строки (числа, разделенные точками, например: "127.0.0.1").

// получить IP адрес хоста
$ip=gethostbyname("www.php.net");
echo "Следующие URL эквивалентны:<br>";
echo "http://www.php.net/, http://".$ip.
     "/, и http://".ip2long($ip)."/<br>";

[править] long2ip

Производит конвертацию числа в строку адреса IP v4.

Синтаксис:

string long2ip(int proper_address);

Функция long2ip() возвращает строковое представление IP-адреса (в формате: "aaa.bbb.ccc.ddd") из численного представления.

[править] gethostbyaddr

Возвращает имя хоста, который соответствует заданному IP-адресу.

Синтаксис:

string gethostbyaddr(string ip_address);

Функция gethostbyaddr() возвращает доменное имя хоста, заданного своим IP-адресом. В аргументе указывается адрес IP в строковом формате. В случае ошибки возвращает ip_address.

Надо отметить, что функция не гарантирует, что полученное имя на самом деле будет соответствовать действительности. Она лишь опрашивает хост по адресу ip_address и просит его сообщить свое имя. Владелец хоста, таким образом, может передавать все, что ему заблагорассудится.

echo gethostbyaddr("127.0.0.1");

[править] gethostbyname

Возвращает IP-адрес хоста.

Синтаксис:

string gethostbyname(string hostname);

Функция gethostbyname() получает в параметрах доменное имя хоста и возвращает его IP-адрес. Если адрес определить не удалось, функция возвращает hostname.

[править] gethostbynamel

Возвращает список IP-адресов хоста.

Синтаксис:

array gethostbynamel(string hostname);

Одному доменному имени может соответствовать сразу несколько IP-адресов, и в случае сильной загруженности серверов DNS-сервер сам выбирает, по какому IP-адресу перенаправить запрос. Он выбирает тот адрес, который использовался наиболее редко.

Функция gethostbynamel() возвращает не один, а все IP-адреса хоста с именем hostname.

Стоит заметить, что в Интернете существует множество виртуальных хостов, которые имеют различные доменные имена, но один и тот же IP-адресс. Таким образом, если следующая последовательность команд для существующего хоста с IP-адресом ip всегда печатает этот же адрес:

$host = gethostbyaddr($ip);
echo gethostbyname($host);

то аналогичная последовательность для домена с DNS-именем $host, наоборот, может напечатать не то же имя, а другое:

$ip = gethostbyname($host);
echo gethostbyaddr($ip);

[править] getprotobyname

Производит определение номера порта, используемого протоколом.

Синтаксис:

int getprotobyname(string name);

[править] getprotobynumber

Производит определение протокола порта.

Синтаксис:

string getprotobynumber(int number);

[править] getservbyname

Производит определение протокола интернет-службы.

Синтаксис:

int getservbyname(string service, string protocol);

Эта функция возвращает номер порта, который использует служба service.

В аргументе protocol указывается тип протокола - TCP или UDP.

echo getservbyname("HTTP", "TCP"); // может вывести 80

[править] getservbyport

Производит определение интернет-службы, которая использует заданный порт.

Синтаксис:

string getservbyport(int port, string protocol);

Здесь в аргументе protocol нужно указать тип протокола - TCP либо UDP.

echo getservbyport(21, "TCP"); // выведет: ftp
echo getservbyport(23, "TCP"); // выведет: telnet

[править] checkdnsrr

Производит проверку записи DNS.

Синтаксис:

int checkdnsrr(string host [, string type]);

Эта функция отправляет запрос DNS-серверу для поиска записей, которые имеются для хоста host. Если были найдены записи типа type, то функция возвращает true. В противном случае и при ошибке - false.

Аргумент typeможет принимать значения:

  • A
  • MX (по умолчанию)
  • NS
  • SOA
  • PTR
  • CNAME
  • ANY

Аргумент host может указываться строкой в формате IP с разделением точками, либо быть именем хоста.

[править] getmxrr

Производит получение MX записи для интернет-хоста.

Синтаксис:

int getmxrr(string hostname, array mxhosts [, array weight]);

Функция getmxrr() инициирует поиск в базе данных DNS записи MX (почтовый сервер домена) для хоста hostname.

Если запись найдена, возвращает true, если нет - то false.

Список записей MX заносится в массив mxhosts. Если указан массив weight, он заполняется дополнительной информацией о записях.

Получено с http://spravkaweb.local/index.php/php/netfile/net
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 10:54, 9 февраля 2007.
  • К этой странице обращались 116 раз.
1.5411760807


Справочник по PHP : Файлы и сети : Функции SNMP — Справочник Web-языков

Справочник по PHP : Файлы и сети : Функции SNMP

 |  |  |  |  |  | Функции IMAP
Главная | ::. | PHP | ::. | Файлы и сети | ::. | Функции SNMP
 |  |  |  |  |  | Функции Vmailmgr

[править] snmpget

Получает объект SNMP.

Синтаксис:

int snmpget(string hostname, string community, string object_id);

Возвращает значение SNMP объекта при успехе и false при ошибке.

Функция snmpget() используется для чтения значения SNMP объекта, указанного в object_id.

SNMP агент определяется именем хоста hostname и группа чтения определяется параметром community.

snmpget("127.0.0.1", "public", "system.SysContact.0")

[править] snmpwalk

Получает все SNMP объекты у агента.

Синтаксис:

array snmpwalk(string hostname, string community, string object_id);

Возвращает массив значений SNMP объектов начиная с object_id и false при ошибке.

Функция snmpwalk() используется для чтения всех значений у SNMP агента, определяемого параметром hostname.

Community определяет группу чтения для агента.

Нулевой object_id берется как корень дерева SNMP объектов и все объекты под этим деревом возвращаются как массив.

Если object_id указан, то возвращаются все SNMP объекты ниже этого объекта.

$a = snmpwalk("127.0.0.1", "public", "");

Указанный выше вызов функции вернет все SNMP объекты из SNMP агента, напущенного на локальном хосте. По всем значениям можно пройти с помощью цикла :

for($i=0; $i<count($a); $i++) {
    echo $a[$i];
}
Получено с http://spravkaweb.local/index.php/php/netfile/snmp
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 10:28, 9 февраля 2007.
  • К этой странице обращались 96 раз.
1.47073578835


Справочник по PHP : Файлы и сети : Функции Vmailmgr — Справочник Web-языков

Справочник по PHP : Файлы и сети : Функции Vmailmgr

 |  |  |  |  |  | Функции SNMP
Главная | ::. | PHP | ::. | Файлы и сети | ::. | Функции Vmailmgr
 |  |  |  |  |  | Сетевые функции

Эти функции требуют пакетов QMAIL www.qmail.org и vmailmgr Bruce Guenter

Для всех функций следующие две переменные определяются как: строка vdomain - имя домена вашего виртуального домена (vdomain.com) , строка basepwd - пароль для "real" пользователя, который поддерживает виртуальных пользователей.

Только до 8 символов распознаются в пароле для виртуальных пользователей.

Возвращается статус для всех функциональных значений ответа в response.h

  • 0 ok
  • 1 плохой
  • 2 ошибка
  • 3 ошибка соединения
<?php
dl("php3_vmailmgr.so"); //load the shared library
$vdomain="vdomain.com";
$basepwd="password";
?>

Содержание

  • 1 vm_adduser
  • 2 vm_addalias
  • 3 vm_passwd
  • 4 vm_delalias
  • 5 vm_deluser

[править] vm_adduser

Добавляет нового виртуального пользователя с паролем.

Синтаксис:

int vm_adduser(string vdomain, string basepwd, string newusername, string newuserpassword);

Добавляет нового виртуального пользователя с паролем. newusername - это имя почтового login-а и newuserpassword - это пароль для это пользователя.

[править] vm_addalias

Добавляет новый псевдоним для виртуального пользователя.

Синтаксис:

int vm_addalias(string vdomain, string basepwd, string username, string alias);

Добавляет псевдоним виртуальному пользователю. username - это имя почтового login-а и alias - это псевдоним для этого пользователя.

[править] vm_passwd

Изменяет пароль виртуальных пользователей.

Синтаксис:

int vm_passwd(string vdomain, string username, string password, string newpassword);

Изменяет пароль виртуальных пользователей. username - это имя почтового login-а, password - старый пароль пользователя, и newpassword - новый пароль.

[править] vm_delalias

Удаляет псевдоним.

Синтаксис:

int vm_delalias(string vdomain, string basepwd, string alias);

[править] vm_deluser

Удаляет псевдоним виртуального пользователя.

Синтаксис:

int vm_deluser (string vdomain, string username);
Получено с http://spravkaweb.local/index.php/php/netfile/vmailmgr
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 15:30, 24 марта 2007.
  • К этой странице обращались 110 раз.
1.4786260128


Справочник по PHP : Файлы и сети : Функции сжатия Bzip2 : Введение — Справочник Web-языков

Справочник по PHP : Файлы и сети : Функции сжатия Bzip2 : Введение

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | FTP : Работа с файлами
Главная | ::. | PHP | ::. | Файлы и сети | ::. | Функции сжатия Bzip2 | ::. | Введение
 |  |  |  |  |  |  |  | Работа с файлами Bzip2

Содержание

  • 1 Введение:
  • 2 Требования:
  • 3 Установка:
  • 4 Настройка во время выполнения:
  • 5 Типы ресурсов:
  • 6 Предопределенные константы:
  • 7 Пример:
  • 8 Содержание:

[править] Введение:

Расширение используется для чтения, записи файлов (.bz2), с использованием метода сжатия bzip2.

[править] Требования:

Расширение использует функции библиотеки bzip2 (автор: Julian Seward) и требует bzip2/libbzip2 версий >= 1.0.x.

[править] Установка:

Поддержка Bzip2 в PHP не включена по умолчанию. Вам придется скомпилировать PHP с указанием директивы --with-bz2[=DIR].

[править] Настройка во время выполнения:

Данное расширение не определяет никакие директивы конфигурации в php.ini.

[править] Типы ресурсов:

Расширение определяет один новый тип ресурсов: указатель на bz2-файл, с которым идет работа.

[править] Предопределенные константы:

Данное расширение не определяет никакие константы.

[править] Пример:

<?php

$filename = "/tmp/testfile.bz2";
$str = "This is a test string.n";

// открываем файл для записи
$bz = bzopen($filename, "w");

// пишем строку в файл
bzwrite($bz, $str);

// закрываем файл
bzclose($bz);

// открываем файл для чтения
$bz = bzopen($filename, "r");

// читаем и выводим 10 символов
print bzread($bz, 10);

// выводим всё, до конца файла и закрываем его.
print bzread($bz);

bzclose($bz);

?>

[править] Содержание:

  • bzclose() -- Закрывает файл bzip2.
  • bzcompress() -- Сжимает данные с использованием bzip2.
  • bzdecompress() -- Распаковывает данные, сжатые с использованием bzip2.
  • bzerrno() -- Возвращает код ошибки работы с bzip2.
  • bzerror() -- Возвращает код и строку ошибки работы с bzip2.
  • bzerrstr() -- Возвращает строку ошибки работы с bzip2.
  • bzflush() -- Вызывает запись всех буфферизированных данных.
  • bzopen() -- Открывает для работы файл, сжатый с использованием bzip2.
  • bzread() -- Бинарно-безопасное чтение файла bzip2.
  • bzwrite() -- Бинарно-безопасная запись bzip2 файла.
Получено с http://spravkaweb.local/index.php/php/netfile/bzip2/about
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 16:21, 8 февраля 2007.
  • К этой странице обращались 103 раза.
1.63884687424


Справочник по PHP : Файлы и сети : Функции сжатия Bzip2 : Работа с файлами Bzip2 — Справочник Web-языков

Справочник по PHP : Файлы и сети : Функции сжатия Bzip2 : Работа с файлами Bzip2

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Введение
Главная | ::. | PHP | ::. | Файлы и сети | ::. | Функции сжатия Bzip2 | ::. | Работа с файлами Bzip2
 |  |  |  |  |  |  |  | Функции IMAP

Содержание

  • 1 bzclose
  • 2 bzcompress
  • 3 bzdecompress
  • 4 bzerrno
  • 5 bzerror
  • 6 bzerrstr
  • 7 bzflush
  • 8 bzopen
  • 9 bzread
  • 10 bzwrite

[править] bzclose

Закрывает файл bzip2.

Синтаксис:

int bzclose (resource bz)

Функция bzclose() Закрывает файл bzip2, на который ссылается указатель bz.

Функция возвращает TRUE в случае успешного завершения, FALSE в случае возникновения ошибки.

Указатель должен быть рабочим и должен ссылаться на файл, успешно открытый функцией bzopen().

Функция поддерживается PHP 4 >= 4.0.4, PHP 5

[править] bzcompress

Сжимает данные с использованием bzip2.

Синтаксис:

string bzcompress ( string source [, int blocksize [, int workfactor]])

Функция bzcompress() возвращает строку source, сжатую с использованием bzip2.

Опциональный параметр blocksize указывает размер блока используемого во время сжатия и должен быть числом от 1 до 9, где 9 дает наилучшее качество сжатия, но использует больше ресурсов. По умолчанию blocksize равен 4.

Опциональный параметр workfactor указывает как поведет себя процесс сжатия в худшем случае, при часто повторяющихся блоках. Параметр может принимать значения от 0 до 250, с 0 в специальном случае и с 30 по умолчанию. Независимо от параметра workfactor, результат сжатия всегда один.

Пример использования функции bzcompress():

<?php
$str = "sample data";
$bzstr = bzcompress($str, 9);
print( $bzstr );
?>

Функция поддерживается PHP 4 >= 4.0.4, PHP 5

[править] bzdecompress

Распаковывает данные, сжатые с использованием bzip2.

Синтаксис:

string bzdecompress ( string source [, int small])

Функция bzdecompress() распаковывает и возвращает source строку, содержащую данные, сжатые с использованием bzip2. Если опциональный параметр small указан как TRUE, будет использован альтернативный алгоритм декомпрессии. Он использует меньше памяти (максимальный размер используемой памяти -- около 2300K), но работает в два раза медленнее.

Пример использования функции bzdecompress():
<?php
$start_str = "This is not an honest face?";
$bzstr = bzcompress($start_str);

print( "Compressed String: " );
print( $bzstr );
print( "n<br>n" );

$str = bzdecompress($bzstr);
print( "Decompressed String: " );
print( $str );
print( "n<br>n" );
?>

Функция поддерживается PHP 4 >= 4.0.4, PHP 5

[править] bzerrno

Возвращает код ошибки работы с bzip2.

Синтаксис:

int bzerrno ( resource bz)

Функция bzerrno() возвращает код ошибки последней bzip2 функций, отработавшей с указателем bz.

Функция поддерживается PHP 4 >= 4.0.4, PHP 5

[править] bzerror

Возвращает код и строку ошибки работы с bzip2.

Синтаксис:

array bzerror ( resource bz)

Функция bzerror() возвращает ассоциативный массив с кодом и строкой ошибки последней bzip2 функции, отработавшей с указателем bz.

Пример использования функции bzerror():

<?php
$error = bzerror($bz);

echo $error["errno"];
echo $error["errstr"];
?>

Функция поддерживается PHP 4 >= 4.0.4, PHP 5

[править] bzerrstr

Возвращает строку ошибки работы с bzip2.

Синтаксис:

string bzerrstr ( resource bz)

Функция bzerrstr() возвращает строку ошибки последней bzip2 функции, отработавшей с указателем bz.

Функция поддерживается PHP 4 >= 4.0.4, PHP 5

[править] bzflush

Вызывает запись всех буфферизированных данных.

Синтаксис:

sint bzflush ( resource bz)

Функция bzflush() записывает все буфферизированные bzip2 данные в файл, на который ссылается указатель bz.

Возвращает TRUE в случае успешного завершения, FALSE в случае возникновения ошибки.

Функция поддерживается PHP 4 >= 4.0.4, PHP 5

[править] bzopen

Открывает для работы файл, сжатый с использованием bzip2.

Синтаксис:

resource bzopen ( string filename, string mode)

Функция bzopen() открывает файл bzip2 (.bz2) для чтения или записи. filename путь к файлу. mode параметр аналогичный одноименному параметру функции fopen() ("r" -- чтение, "w" -- запись, и т.д.).

При ошибке открытия функция возвращает FALSE, иначе она возвращает указатель на открытый файл.

Пример использования функции bzopen():

<?php
$bz = bzopen("/tmp/foo.bz2", "r");

$decompressed_file = "";
while (!feof($bz)) {
    $decompressed_file .= bzread($bz, 4096);
}
bzclose($bz);

print( "The contents of /tmp/foo.bz2 are: " );
print( "n<br>n" );
print( $decompressed_file );
?>

Функция поддерживается PHP 4 >= 4.0.4, PHP 5

[править] bzread

Бинарно-безопасное чтение файла bzip2.

Синтаксис:

string bzread ( resource bz [, int length])

Функция bzread() считывает length байт из файла bzip2, на который ссылается указатель bz. Чтение останавливается, когда length (несжатых) байт прочитано или достигнут конец файла (EOF). Если опциональный параметр length не задан, bzread() будет считывать по 1024 (несжатых) байт за раз.

Пример использования функции bzread():

<?php
$bz = bzopen("/tmp/foo.bz2", "r");
$str = bzread($bz, 2048);
print( $str );
?>

Функция поддерживается PHP 4 >= 4.0.4, PHP 5

[править] bzwrite

Бинарно-безопасная запись bzip2 файла.

Синтаксис:

int bzwrite ( resource bz, string data [, int length])

Функция bzwrite() записывает содержание строки data в поток файла bzip2, на который ссылается указатель bz. Если указан опциональный параметр length, запись будет остановлена по достижению length байт (несжатых), либо по достижению конца строки.

Пример использования функции bzwrite():

<?php
$str = "uncompressed data";
$bz = bzopen("/tmp/foo.bz2", "w");
bzwrite($bz, $str, strlen($str));
bzclose($bz);
?>

Функция поддерживается PHP 4 >= 4.0.4, PHP 5

Получено с http://spravkaweb.local/index.php/php/netfile/bzip2/file
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 16:19, 8 февраля 2007.
  • К этой странице обращались 65 раз.
1.27662801743


Справочник по PHP : Файлы и сети : Функции для работы с каталогами : Манипулирование каталогами — Справочник Web-языков

Справочник по PHP : Файлы и сети : Функции для работы с каталогами : Манипулирование каталогами

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Работа с файлами : Другие функции
Главная | ::. | PHP | ::. | Файлы и сети | ::. | Функции для работы с каталогами | ::. | Манипулирование каталогами
 |  |  |  |  |  |  |  | Работа с записями

Содержание

  • 1 mkdir
  • 2 rmdir
  • 3 chdir
  • 4 getcwd
  • 5 diskfreespace

[править] mkdir

Создание каталога.

Синтаксис:

bool mkdir(string $name, int $perms)

Создает каталог с именем $name и правами доступа perms. Права доступа для каталогов указываются точно так же, как и для файлов. Чаще всего значение $perms устанавливают равным 0770 (предваряющий ноль обязателен - он указывает PHP на то, что это - восьмеричная константа, а не десятичное число).

Пример:

mkdir("my_directory",0755);
     // создает подкаталог в текущем каталоге
mkdir("/data");
     // создает подкаталог data в корневом каталоге

В случае успеха функция возвращает true, иначе - false.

[править] rmdir

Удаление каталога.

Синтаксис:

bool rmdir(string $name)

Удаляет каталог с именем $name.

Каталог должен быть пустым, а его атрибуты должны позволять это.

В случае успеха функция возвращает true, иначе - false.

[править] chdir

Смена текущего каталога.

Синтаксис:

int chdir(string $directory);

Изменяет текущий PHP каталог на directory. Возвращает FALSE если не может изменить, TRUE если смена произошла. Параметр $directory может определять и относительный путь, задающийся от текущего каталога.

Примеры:

chdir("/tmp/data"); // переходим по абсолютному пути
chdir("./js"); // переходим в подкаталог текущего каталога
chdir(".."); // переходим в родительский каталог
chdir("~/data"); // переходим в /home/пользователь/data (для Unix)

[править] getcwd

Полный путь.

Синтаксис:

string getcwd()

Данная функция возвращает текущую директорию, относительно которой проводятся файловые операции, т.е. возвращает полный путь к текущему каталогу, начиная от "корня" (/). Если такой путь не может быть отслежен, вызов "проваливается" и возвращается false.

[править] diskfreespace

Определяет свободное пространство в каталоге

Синтаксис:

float diskfreespace (string directory);

Данная функция возвращает в байтах свободное пространство в каталоге directory, то есть в соответствующей ей файловой системе или на разделе диска.

Пример:

$diskspace=diskfreespace("/");
// Тем самым мы определили свободное место в корневой директории "/"
Получено с http://spravkaweb.local/index.php/php/netfile/dir/move
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 15:16, 8 февраля 2007.
  • К этой странице обращались 101 раз.
1.59878587723


Справочник по PHP : Файлы и сети : Функции для работы с каталогами : Работа с записями — Справочник Web-языков

Справочник по PHP : Файлы и сети : Функции для работы с каталогами : Работа с записями

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Манипулирование каталогами
Главная | ::. | PHP | ::. | Файлы и сети | ::. | Функции для работы с каталогами | ::. | Работа с записями
 |  |  |  |  |  |  |  | FTP : Работа с FTP-сервером

Содержание

  • 1 dir
  • 2 closedir
  • 3 opendir
  • 4 readdir
  • 5 rewinddir

[править] dir

Класс каталога (псевдо-объектно ориентированный механизм).

Синтаксис:

new dir(string directory);

Псевдо-объектно ориентированный механизм для получения списка файлов каталога. Открывает каталог из directory.

После этого становятся доступны два свойства объекта: дескриптор каталога handle и строка path, указывающая, какой каталог в настоящий момент используется. Эти свойства доступны, если только каталог был открыт. Свойство handle может быть использован вместе с другими функциями работы с каталогом типа readdir(), rewinddir() и closedir(). Для класса доступны три метода: чтение, возврат к началу и закрытие (read, rewind и close соответственно).

Пример:

$d = dir("/etc");
echo "Handle: ".$d->handle."<br>n";
echo "Path: ".$d->path."<br>n";
while($entry=$d->read()) { // Последовательно выводить
  echo $entry."<br>n";    // имя каждого файла,
}                          // имеющегося в каталоге
$d->close();

[править] closedir

Закрыть дескриптор(handle) каталога.

Синтаксис:

void closedir(int dir_handle);

Закрывает поток каталога, обозначенный как dir_handle. Поток предварительно должен быть открыт функцией opendir().

[править] opendir

Открыть дескриптор каталога.

Синтаксис:

int opendir(string path);

Возвращает дескриптор открытого каталога path, который в последующем используется в функциях closedir(), readdir(), и rewinddir().

[править] readdir

Получение имени следующего файла в списке каталога.

Синтаксис:

string readdir(int dir_handle);

Возвращает имя следующего файла из каталога. Имена файлов возвращаются в виде неупорядоченной последовательности.

Пример:

<?php
  $handle=opendir(".");
  echo "Directory handle: $handlen";
  echo "Files:n";
  while ($file = readdir($handle)) {
    echo "$filen";
  }
  closedir($handle);
?>

Следует отметить, что функция также возвращает значения "." и "..". Если эти значения не требуются, то их можно исключить следующим образом:

<?php
$handle=opendir(".");
while($file=readdir($handle)) {
  if($file != "." && $file != "..") {
    echo "Имя файла: $file<br>";
  };
};
closedir($handle);
?>

[править] rewinddir

Реинициализация дескриптора каталога.

Синтаксис:

void rewinddir(int dir_handle);

После вызова этой функции функция readdir() с аргументом dir_handle будет возвращать имена файлов с начала в списке каталога.

Получено с http://spravkaweb.local/index.php/php/netfile/dir/rec
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 15:16, 8 февраля 2007.
  • К этой странице обращались 72 раза.
1.52603387833


Справочник по PHP : Файлы и сети : Работа с файлами : Закрытие файла — Справочник Web-языков

Справочник по PHP : Файлы и сети : Работа с файлами : Закрытие файла

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Открытие файла
Главная | ::. | PHP | ::. | Файлы и сети | ::. | Работа с файлами | ::. | Закрытие файла
 |  |  |  |  |  |  |  | Чтение и запись

[править] fclose

Закрывает файл, открытый предварительно функцией fopen().

Синтаксис:

int fclose(int $fp)

Возвращает false, если файл закрыть не удалось (например, что-то с ним случилось или же разорвалась связь с удаленным хостом). В противном случае возвращает значение "истина".

Всегда нужно закрывать FTP- и HTTP-соединения, потому что в противном случае "беспризорный" файл приведет к неоправданному простою канала и излишней загрузке сервера. Кроме того, успешно закрыв соединение, вы будете уверены в том, что все данные были доставлены без ошибок.

Получено с http://spravkaweb.local/index.php/php/netfile/file/close
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 22:13, 7 февраля 2007.
  • К этой странице обращались 68 раз.
1.5923409462


Справочник по PHP : Файлы и сети : Работа с файлами : Функции для работы с именами файлов — Справочник Web-языков

Справочник по PHP : Файлы и сети : Работа с файлами : Функции для работы с именами файлов

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Определение параметров файла
Главная | ::. | PHP | ::. | Файлы и сети | ::. | Работа с файлами | ::. | Функции для работы с именами файлов
 |  |  |  |  |  |  |  | Функции манипулирования целыми файлами

Содержание

  • 1 basename
  • 2 dirname
  • 3 tempnam
  • 4 realpath

[править] basename

Выделяет имя файла из пути.

Синтаксис:

string basename(string $path)

Выделяет основное имя из пути $path

Примеры:

echo basename("/home/somebody/somefile.txt");  // выводит "somefile.txt"
echo basename("/");                            // ничего не выводит
echo basename("/.");                           // выводит "."
echo basename("/./");                          // также выводит "."

Функция basename() не проверяет существование файла. Она просто берет часть строки после самого правого слеша и возвращает ее.

Эта функция правильно обрабатывает как прямые, так и обратные слеши под Windows.

[править] dirname

Выделяет имя каталога.

Синтаксис:

string dirname(string $path)

Возвращает имя каталога, выделенное из пути $path. Функция довольно "разумна" и умеет выделять нетривиальные ситуации, которые описаны в примерах:

echo dirname("/home/file.txt"); // выводит "/home"
echo dirname("../file.txt");    // выводит ".."
echo dirname("/file.txt");      // выводит "/" под Unix,
                                //         "" под Windows
echo dirname("/");              // то же самое
echo dirname("file.txt");       // выводит "."

Если функции dirname() передать просто имя файла, она вернет ".", что означает "текущий каталог".

[править] tempnam

Генерирует уникальное имя файла в определенном каталоге.

Синтаксис:

string tempnam(string $dir, string $prefix)

Генерирует имя файла в каталоге $dir с префиксом $prefix в имени, причем так, чтобы созданный под этим именем в будущем файл был уникален. Для этого к строке $prefix присоединяется некое случайное число.

Например, вызов tempnam("/tmp","temp") может возвратить /tmp/temp3a6b243c.

Если такое имя нужно создать в текущем каталоге, передайте $dir="."

[править] realpath

Преобразует относительный путь в абсолютный.

Синтаксис:

string realpath(string $path)

Преобразует относительный путь $path в абсолютный, т.е. начинающийся от корня.

Пример:

echo realpath("../t.php"); // например, /home/t.php
echo realpath(".");        // выводит имя текущего каталога

Файл, который указан в параметре $path, должен существовать, иначе функция возвратит false.

Получено с http://spravkaweb.local/index.php/php/netfile/file/filename
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 10:44, 8 февраля 2007.
  • К этой странице обращались 77 раз.
1.42536401749


Справочник по PHP : Файлы и сети : Работа с файлами : Функции для определения типов файлов — Справочник Web-языков

Справочник по PHP : Файлы и сети : Работа с файлами : Функции для определения типов файлов

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Положение указателя текущей позиции
Главная | ::. | PHP | ::. | Файлы и сети | ::. | Работа с файлами | ::. | Функции для определения типов файлов
 |  |  |  |  |  |  |  | Определение параметров файла

Содержание

  • 1 file_exists
  • 2 filetype
  • 3 is_file
  • 4 is_dir
  • 5 is_link
  • 6 is_readable
  • 7 is_writeable
  • 8 is_executable
  • 9 is_uploaded_file

[править] file_exists

Проверяет существование вызываемого файла.

Синтаксис:

bool file_exists(string filename)

Возвращает true, если файл с именем filename существует на момент вызова. Следует использовать эту функцию с осторожностью.

Например, следующий код никуда не годится с точки зрения безопасности:

if(!file_exists($fname))
  $f=fopen($fname,"w");
else
  $f=fopen($fname,"r");

Дело в том, что между вызовом file_exists() и открытием файла в режиме w проходит некоторое время, в течение которого другой процесс может вклиниться и подменить используемый нами файл. Данная проблема выходит на передний план при написании сценария счетчика.

Функция не работает с удаленными файлами, файл должен находиться в доступной для сервера файловой системе.

Результаты функции кэшируются, см. функцию clearstatcache().

[править] filetype

Возвращает тип файла.

Синтаксис:

string filetype(string filename)

Возвращает строку, которая описывает тип файла с именем filename. Если такого файла не существует, возвращает false.

После вызова строка будет содержать одно из следующих значений:

  • file - обычный файл;
  • dir - каталог;
  • link - символическая ссылка;
  • fifo - fifo-канал;
  • block - блочно-ориентированное устройство;
  • char - символьно-ориентированное устройство;
  • unknown - неизвестный тип файла;

[править] is_file

Проверка существования обычного файла.

Синтаксис:

bool is_file(string filename)

Возвращает true, если filename - обычный файл.

[править] is_dir

Проверка существования каталога.

Синтаксис:

bool is_dir(string filename)

Возвращает true, если каталог filename существует.

[править] is_link

Проверка существования символической ссылки на файл.

Синтаксис:

bool is_link(string filename)

Возвращает true, если filename - символическая ссылка.

Функция не работает под Windows.

[править] is_readable

Проверка существования файла, доступного для чтения.

Синтаксис:

bool is_readable(string filename)

Возвращает true, если файл может быть открыт для чтения.

Обычно PHP осуществляет доступ к файлу с привелегиями пользователя, запускающего web-сервер (часто "nobody"). Соображения безопасности должны приниматься в расчет.

[править] is_writeable

Проверка существования файла, доступного для записи.

Синтаксис:

bool is_writeable(string filename)

Возвращает true, если в файл можно писать. Обычно PHP осуществляет доступ к файлу с привелегиями пользователя, запускающего web-сервер (часто "nobody"). Соображения безопасности должны приниматься в расчет.

[править] is_executable

Проверка существования запускаемого файла.

Синтаксис:

bool is_executable(string filename)

Возвращает true, если файл filename - исполняемый.

[править] is_uploaded_file

Проверка существования файла, загруженного методом HTTP POST.

Синтаксис:

bool is_uploaded_file(string filename)

Возвращает true, если файл с именем filename был загружен на сервер посредством HTTP POST.

Часто это полезно, чтобы убедиться, что пользователи из злого умысла не пытались заставить сценарий работать с теми файлами, с которыми им работать не следует.

Получено с http://spravkaweb.local/index.php/php/netfile/file/gettype
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 22:25, 7 февраля 2007.
  • К этой странице обращались 87 раз.
1.49483680725


Справочник по PHP : Файлы и сети : Работа с файлами : Функции манипулирования целыми файлами — Справочник Web-языков

Справочник по PHP : Файлы и сети : Работа с файлами : Функции манипулирования целыми файлами

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Функции для работы с именами файлов
Главная | ::. | PHP | ::. | Файлы и сети | ::. | Работа с файлами | ::. | Функции манипулирования целыми файлами
 |  |  |  |  |  |  |  | Другие функции

[править] copy

Копирует файл.

Синтаксис:

bool copy(string $src, string $dst)

Копирует файл с именем $src в файл с именем $dst. При этом, если файл $dst на момент вызова существовал, осуществляется его перезапись.

Функция возвращает true, если копирование прошло успешно, а в случае провала - false.

Функция не выполняет переименования файла, если его новое имя расположено в другой файловой системе (на другой смонтированной системе в Unix или на другом диске в Windows).

[править] unlink

Удаление файла.

Синтаксис:

bool unlink(string $filename)

Удаляет файл с именем $filename. В случае неудачи возвращает false, иначе - true.

Надо заметить, что файл удаляется только в том случае, если число "жестких" ссылок на него стало равным 0. Правда, эта схема специфична для Unix-систем.

[править] file

Считывает файл и разбивает его по строкам.

Синтаксис:

list file(string $filename)

Считывает файл с именем $filename целиком и возвращает массив-список, каждый элемент которого соответствует строке в прочитанном файле.

Неудобство этой функции состоит в том, что символы конца строки (обычно \n), не вырезаются из строк файла, а также не транслируются, как это делается для текстовых файлов.

Получено с http://spravkaweb.local/index.php/php/netfile/file/move
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 10:47, 8 февраля 2007.
  • К этой странице обращались 75 раз.
1.25715780258


Справочник по PHP : Файлы и сети : Работа с файлами : Открытие файла — Справочник Web-языков

Справочник по PHP : Файлы и сети : Работа с файлами : Открытие файла

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Функции работы с данными : Календарные функции
Главная | ::. | PHP | ::. | Файлы и сети | ::. | Работа с файлами | ::. | Открытие файла
 |  |  |  |  |  |  |  | Закрытие файла

[править] fopen

Открывает файл и привязывает его к дескриптору.

Синтаксис:

int fopen(string $filename, string $mode, bool $use_include_path=false)

Открывает файл с именем $filename в режиме $mode и возвращает дескриптор открытого файла. Если операция "провалилась", то функция возвращает false. Необязательный параметр use_include_path говорит о том, что, если задано относительное имя файла, его следует искать также и списке путей, используемом инструкциями include() и require(). Обычно этот параметр не используют.

Параметр $mode может принимать следующие значения:

r
Файл открывается только для чтения. Если файла не существует, вызов регистрирует ошибку. После удачного открытия указатель файла устанавливается на его первый байт, т.е. на начало.
r+
Файл открывается одновременно на чтение и запись. Указатель текущей позиции устанавливается на ее первый байт. Если файла не существует, возвращает false. Если в момент записи указатель файла установлен где-то в середине файла, то данные запишутся прямо поверх уже имеющихся, а не раздвинут их, при необходимости увеличив размер файла.
w
Создает новый пустой файл. Если на момент вызова уже был файл с таким именем, то он предварительно уничтожается. В случае неверно заданного имени файла вызов "проваливается".
w+
Аналогичен r+, но если файл изначально не существовало, создает его. После этого с файлом можно работать как в режиме чтения, так и записи. Если файл существовал до момента вызова, его содержимое удаляется.
a
Открывает существующий файл в режиме записи, и при этом сдвигает указатель текущей позиции за последний байт файла. Как водится, вызов не успешен в случае отсутствия файла.
a+
Открывает файл в режиме чтения и записи, указатель файла устанавливается на конец файла, при этом содержимое файла не уничтожается. Отличается от a тем, что если файла изначально не существовало, то он создается. Этот режим полезен, если вам нужно что-то дописать в файл, но вы не знаете, создан ли уже такой файл.

Но это еще не полное описание параметра $mode. Дело в том, что в конце любой из строк r,w,a,r+,w+ и a+ может находиться еще один необязательный символ - b или t. Если указан b (или не указан вообще никакой), то файл открывается в режиме бинарного чтения/записи. Если же это t, то для файла устанавливается режим трансляции символа перевода строки, т.е. он воспринимается как текстовой.

[править] tmpfile

Создает новый временный файл с уникальным именем и открывает его на чтение и запись.

Синтаксис:

int tmpfile()

В дальнейшем вся работа должна вестись с возвращенным файловым дескриптором, потому что имя файла недоступно.

Пространство, занимаемое временным файлом, автоматически освобождается при его закрытии и при завершении работы программы.

Получено с http://spravkaweb.local/index.php/php/netfile/file/open
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 22:12, 7 февраля 2007.
  • К этой странице обращались 125 раз.
1.70867013931


Справочник по PHP : Файлы и сети : Работа с файлами : Другие функции — Справочник Web-языков

Справочник по PHP : Файлы и сети : Работа с файлами : Другие функции

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Функции манипулирования целыми файлами
Главная | ::. | PHP | ::. | Файлы и сети | ::. | Работа с файлами | ::. | Другие функции
 |  |  |  |  |  |  |  | Функции для работы с каталогами : Манипулирование каталогами

Содержание

  • 1 ftruncate
  • 2 fflush
  • 3 set_file_buffer
  • 4 flock

[править] ftruncate

Усекает файл.

Синтаксис:

bool ftruncate(int $f, int $newsize)

Эта функция усекает открытый файл $f до размера $newsize. Разумеется, файл должен быть открыт в режиме, разрешающим запись.

Например, следующий код очищает весь файл:

ftruncate($f,0);

[править] fflush

Немедленная запись всех изменений в файле.

Синтаксис:

void fflush(int $f)

Заставляет PHP немедленно записать на диск все изменения, которые производились до этого с открытым файлом $f. Что это за изменения? Дело в том, что для повышения производительности все операции записи в файл буферизируются: например, вызов fputs($f, "Это строка!") не приводит к непосредственной записи данных на диск - сначало они попадают во внутренний буфер (обычно размером 8К). Как только буфер заполняется, его содержимое отправляется на диск, а сам он очищается, и все повторяется вновь. Особенный выигрыш от буферизации чувствуется в сетевых операциях, когда просто глупо отправлять данные маленькими порциями.

[править] set_file_buffer

Устанавливает размер буфера.

Синтаксис:

int set_file_buffer(int $f, int $size)

Эта функция устанавливает размер буфера, о котором говорилось выше, для указанного открытого файла $f.

Чаще всего она используется так:

set_file_buffer($f,0);

Приведенный код отключает буферизацию для указанного файла, так что теперь все данные, записываемые в файл, немедленно отправляются на диск или в сеть.

[править] flock

Блокирование файла.

Синтаксис:

bool flock(int $f, int $operation [, int $wouldblock])

Функция устанавливает для указанного открытого дескриптора файла $f режим блокировки, который бы хотел получить текущий процесс. Этот режим задается аргументом $operation и может быть одной из следующих констант:

  • LOCK_SH (или 1) - разделяемая блокировка;
  • LOCK_EX (или 2) - исключительная блокировка;
  • LOCK_UN (или 3) - снять блокировку;
  • LOCK_NB (или 4) - эту константу нужно прибавить к одной из предыдущих, если вы не хотите, чтобы программа подвисала на flock() в ожидании своей очереди, а сразу возвращала управление.

В случае, если был затребован режим без ожидания, и блокировка не была успешно установлена, в необязательный параметр-переменную $wouldblock будет записано значение истина true.

В случае ошибки функция возвращает false, а в случае успешного завершения - true.

Получено с http://spravkaweb.local/index.php/php/netfile/file/othe
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 10:51, 8 февраля 2007.
  • К этой странице обращались 64 раза.
1.2955429554


Справочник по PHP : Файлы и сети : Работа с файлами : Чтение и запись — Справочник Web-языков

Справочник по PHP : Файлы и сети : Работа с файлами : Чтение и запись

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Закрытие файла
Главная | ::. | PHP | ::. | Файлы и сети | ::. | Работа с файлами | ::. | Чтение и запись
 |  |  |  |  |  |  |  | Положение указателя текущей позиции

Содержание

  • 1 fread
  • 2 fwrite
  • 3 fgets
  • 4 fputs
  • 5 fgetcsv

[править] fread

Читает из открытого файла определенное количество символов.

Синтаксис:

string fread(int $f, int $numbytes)

Читает из файла $f $numbytes символов и возвращает строку этих символов. После чтения указатель файла продвигается к следующему после прочитанного блока позициям. Если $numbytes больше, чем можно прочитать из файла, возвращается то, что удалось считать. Этот прием можно использовать, если вам нужно считать в строку файл целиком. Для этого просто задайте в $numbytes очень большое число. Но если вы заботитесь об экономии памяти в системе, так поступать не рекомендуется.

[править] fwrite

Запись в файл.

Синтаксис:

int fwrite(int $f, string $str)

Записывает в файл $f все содержимое строки $str. Эта функция составляет пару для fread(), действуя "в обратном направлении".

При работе с текстовыми файлами (то есть когда указан символ t в режиме открытия файла) все n автоматически преобразуются в тот разделитель строк, который принят в вашей операционной системе.

[править] fgets

Читает из файла одну строку, заканчивающуюся символом новой строки n.

Синтаксис:

string fgets(int $f, int $length)

Этот символ также считывается и включается в результат. Если строка в файле занимает больше $length-1 байтов, то возвращаются только ее $length-1 символов. Функция полезна, если вы открыли файл и хотите "пройтись" по всем ее строкам. Однако даже в этом случае (и быстрее) будет воспользоваться функцией File(). Стоит также заметить, что эта функция (как и функция fread()) в случае текстового режима в Windows заботиться о преобразовании пар \r\n в один символ \n.

[править] fputs

Полный аналог fwrite().

Синтаксис:

int fputs(int $f, string $str)

[править] fgetcsv

Функция для работы с одним из форматов файлов, в котором может сохранять данные Excel.

Синтаксис:

list fgetcsv(int $f, int $length, char $delim=",")

Функция читает строку из файла, заданного дескриптором $f, и разбивает ее по символу $delim. Параметр $delim должен обязательно быть строкой из одного символа, в противном случае принимается во внимание только первый символ этой строки. Функция возвращает получившийся список или false, если строки кончились. Параметр $length задает максимальную длину строки точно так же, как это делается в fgets(). Пустые строки в файле не игнорируются, а возвращаются как список из одного элемента - пустой строки.

Пример:

$f=fopen("file.csv","r") or die("Ошибка");
for($i=0; $data=fgetscsv($f, 1000, ";"); $i++) {
  $num = count($data);
  if($num==1 && $data[0]==="") continue;
  echo "<h3>Строка номер $i ($num полей):</h3>";
  for($c=0; $c<$num; $c++)
    print "[$c]: $data[$c]<br>";
}
fclose($f);
Получено с http://spravkaweb.local/index.php/php/netfile/file/read
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 22:17, 7 февраля 2007.
  • К этой странице обращались 87 раз.
1.51252388954


Справочник по PHP : Файлы и сети : Работа с файлами : Положение указателя текущей позиции — Справочник Web-языков

Справочник по PHP : Файлы и сети : Работа с файлами : Положение указателя текущей позиции

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Чтение и запись
Главная | ::. | PHP | ::. | Файлы и сети | ::. | Работа с файлами | ::. | Положение указателя текущей позиции
 |  |  |  |  |  |  |  | Функции для определения типов файлов

[править] feof

Указатель конца файла.

Синтаксис:

int feof(int $f)

Возвращает true, если достигнут конец файла (то есть если указатель файла установлен за концом файла).

Пример:

$f=fopen("myfile.txt","r");
while(!feof($f))
{  $str=fgets($f);
   // Обрабатываем очередную строку $str

}
fclose($f);

[править] fseek

Устанавливает указатель файла на определенную позицию.

Синтаксис:

int fseek(int $f, int $offset, int $whence=SEEK_SET)

Устанавливает указатель файла на байт со смещением $offset (от начала файла, от его конца или от текущей позиции, в зависимости от параметра $whence). Это может и не сработать, если дескриптор $f ассоциирован не с обычным локальным файлом, а с соединением HTTP или FTP.

Параметр $whence задает с какого места отсчитывается смещение $offset. В PHP для этого существуют три константы, равные, соответственно, 0, 1 и 2:

SEEK_SET
устанавливает позицию начиная с начала файла;
SEEK_CUR
отсчитывает позицию относительно текущей позиции;
SEEK_END
отсчитывает позицию относительно конца файла;

В случае использования последних двух констант параметр $offset вполне может быть отрицательным (а при применении SEEK_END он будет отрицательным наверняка). В случае успешного завершения эта функция возвращает 0, а в случае неудачи -1.

[править] ftell

Возвращает положение указателя файла.

Синтаксис:

int ftell(int $f)
Получено с http://spravkaweb.local/index.php/php/netfile/file/seek
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 22:20, 7 февраля 2007.
  • К этой странице обращались 70 раз.
1.4470770359


Справочник по PHP : Файлы и сети : Работа с файлами : Определение параметров файла — Справочник Web-языков

Справочник по PHP : Файлы и сети : Работа с файлами : Определение параметров файла

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Функции для определения типов файлов
Главная | ::. | PHP | ::. | Файлы и сети | ::. | Работа с файлами | ::. | Определение параметров файла
 |  |  |  |  |  |  |  | Функции для работы с именами файлов

Содержание

  • 1 stat
  • 2 fileatime
  • 3 filemtime
  • 4 filectime
  • 5 filesize
  • 6 touch

[править] stat

Функция собирает вместе всю информацию, выдаваемую операционной системой для указанного файла, и возвращает ее в виде массива.

Синтаксис:

array stat(string $filename)

Этот массив всегда содержит следующие элементы с указанными ключами:

  • 0 - устройство;
  • 1 - Номер узла inode;
  • 2 - атрибуты защиты файла;
  • 3 - число синонимов ("жестких" ссылок) файла;
  • 4 - идентификатор uid владельца;
  • 5 - идентификатор gid группы;
  • 6 - тип устройства;
  • 7 - размер файла в байтах;
  • 8 - время последнего доступа в секундах, прошедших с 1 января 1970 года;
  • 9 - время последней модификации содержимого файла;
  • 10 - время последнего изменения атрибутов файла;
  • 11 - размер блока;
  • 12 - число занятых блоков;

Этот массив помещает информацию, которая доступна в системах Unix. Под Windows многие поля могут быть пусты.

Если $filename задает не имя файла, а имя символической ссылки, то всетаки будет возвращена информация о том файле, на который ссылается эта ссылка (а не о ссылке).

[править] fileatime

Возвращает время последнего доступа к файлу.

Синтаксис:

int fileatime(string filename)

Время выражается в количестве секунд, прошедших с 1 января 1970 года (Unix timestamp). Если файл не обнаружен, возвращает false.

Атрибут времени последнего доступа к файлу изменяется каждый раз, когда данные файла читаются. Так как это сильно снижает производительность при интенсивной работе с файлами и каталогами, часто изменение этого атрибута в операционных системах блокируют, и тогда функция бесполезна.

[править] filemtime

Возвращает время последнего изменения файла или false в случае отсутствия файла.

Синтаксис:

int filemtime(string $filename)

[править] filectime

Возвращает время создания файла.

Синтаксис:

int filectime(string $filename)

[править] filesize

Возвращает размер файла в байтах или false, если файла не существует.

Синтаксис:

int filesize(string $filename)

[править] touch

Устанавливает время модификации.

Синтаксис:

int touch(string $filename [, int $timestamp])

Устанавливает время модификации указанного файла $filename равным $timestamp (в секундах, прошедших с 1 января 1970 года). Если второй параметр не указан, то подразумевается текущее время. В случае ошибки возвращает false.

Если файл с указанным именем не существует, он создается пустым.

Получено с http://spravkaweb.local/index.php/php/netfile/file/type
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 22:28, 7 февраля 2007.
  • К этой странице обращались 77 раз.
1.41731405258


Справочник по PHP : Файлы и сети : FTP : Работа с файлами — Справочник Web-языков

Справочник по PHP : Файлы и сети : FTP : Работа с файлами

 |  |  |  |  |  |  |  | Работа с FTP-сервером
Главная | ::. | PHP | ::. | Файлы и сети | ::. | FTP | ::. | Работа с файлами
 |  |  |  |  |  |  |  | Функции сжатия Bzip2 : Введение

Содержание

  • 1 ftp_get
  • 2 ftp_fget
  • 3 ftp_put
  • 4 ftp_fput
  • 5 ftp_size
  • 6 ftp_mdtm
  • 7 ftp_rename
  • 8 ftp_delete
  • 9 ftp_site

[править] ftp_get

Производит загрузку с FTP-сервера.

Синтаксис:

int ftp_get(int ftp_stream, string local_file, string remote_file, int mode)

Функция ftp_get() загружает файл под названием remote_file с FTP-сервера и локально сохраняет его под именем local_file.

Параметр mode устанавливает режим передачи файла и может принимать значения FTP_ASCII(текстовой) или FTP_BINARY(бинарный, двоичный).

Функция возвращает true или false при ошибке.

[править] ftp_fget

Производит загрузку и запись файла.

Синтаксис:

int ftp_fget(int ftp_stream, string fp, string remote_file, int mode)

Функция ftp_fget() загружает файл под названием remote_file с FTP-сервера и сохраняет его в файле, который имеет дескриптор fp. Параметр mode устанавливает режим передачи файла и может принимать значения FTP_ASCII(текстовой) или FTP_BINARY(бинарный, двоичный).

Функция возвращает true или false при ошибке.

[править] ftp_put

Производит загрузку файла на FTP-сервер.

Синтаксис:

int ftp_put(int ftp_stream, string remote_file, string local_file, int mode)

Функция ftp_put() загружает файл на FTP-сервер под именем remote_file. Параметр mode устанавливает режим передачи файла и может принимать значения FTP_ASCII(текстовой) или FTP_BINARY(бинарный, двоичный).

Функция возвращает true или false при ошибке.

$upload = ftp_put($ftp_id, "C:\file.txt", "/file.txt", FTP_ASCII);

[править] ftp_fput

Производит чтение и загрузку файла на FTP-сервер.

Синтаксис:

int ftp_fput(int ftp_stream, string remote_file, string fp, int mode)

Функция ftp_fput() читает открытый файл с дескриптором fp до конца и загружает этот файл на FTP-сервер под именем remote_file. Параметр mode устанавливает режим передачи файла и может принимать значения FTP_ASCII(текстовой) или FTP_BINARY(бинарный, двоичный).

Функция возвращает true или false при ошибке.

[править] ftp_size

Определяет размер файла.

Синтаксис:

int ftp_size(int ftp_stream, string remote_file)

Функция ftp_size() возвращает размер файла, заданного в параметре remote_file, в байтах или -1 при ошибке.

Не все серверы поддерживают эту возможность.

[править] ftp_mdtm

Возвращает время последней модификации файла.

Синтаксис:

int ftp_mdtm(int ftp_stream, string remote_file)

Функция ftp_mdtm() возвращает время, последней модификации, представленное в формате Unix, или -1 при ошибке.

Данная функция не работает с каталогами.

[править] ftp_rename

Производит переименование файла.

Синтаксис:

int ftp_rename(int ftp_stream, string from, string to)

Функция ftp_rename() переименовывает файл from в to.

Функция возвращает true или false в случае ошибки.

[править] ftp_delete

Производит удаление файла с сервера.

Синтаксис:

int ftp_delete(int ftp_stream, string path)

Функция ftp_delete() удаляет файл, имя которого задано в параметре path.

Функция возвращает true или false в случае ошибки.

[править] ftp_site

Производит выполнение команды SITE на сервере.

Синтаксис:

int ftp_site(int ftp_stream, string cmd)

Функция ftp_site() посылает серверу команду cmd.

Т.к. команды SITE не стандартизированы, они могут различаться. Обычно они полезны для изменения прав доступа к файлам и групповой принадлежности.

Функция возвращает true или false в случае ошибки.

Получено с http://spravkaweb.local/index.php/php/netfile/ftp/file
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 16:22, 8 февраля 2007.
  • К этой странице обращались 81 раз.
1.63901495934


Справочник по PHP : Файлы и сети : FTP : Работа с FTP-сервером — Справочник Web-языков

Справочник по PHP : Файлы и сети : FTP : Работа с FTP-сервером

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Функции для работы с каталогами : Работа с записями
Главная | ::. | PHP | ::. | Файлы и сети | ::. | FTP | ::. | Работа с FTP-сервером
 |  |  |  |  |  |  |  | Работа с файлами

Содержание

  • 1 ftp_connect
  • 2 ftp_pasv
  • 3 ftp_login
  • 4 ftp_quit
  • 5 ftp_pwd
  • 6 ftp_cdup
  • 7 ftp_chdir
  • 8 ftp_mkdir
  • 9 ftp_rmdir
  • 10 ftp_nlist
  • 11 ftp_rawlist
  • 12 ftp_systype

[править] ftp_connect

Производит подключение к FTP-серверу.

Синтаксис:

int ftp_connect(string host [, int port])

В функции ftp_connect() аргумент host указывает имя сервера, к которому производится подключение, а необязательный аргумент port указывает какой порт нужно использовать (по умолчанию это 21).

Функция возвращает дескриптор потока FTP или false в случае ошибки.

[править] ftp_pasv

Производит переключение пассивного режима.

Синтаксис:

int ftp_pasv(int ftp_stream, int pasv)

Функция ftp_pasv() производит переключение режима подключения в пассивный, в случае, если аргумент pasv равен true. Если false - то режим подключения будет активный.

В пассивном режиме передача данных инициируется клиентом, а в активном - сервером (это бывает необходимо при блокировке портов у клиента).

Функция возвращает true или false при ошибке.

[править] ftp_login

Производит вход на сервер FTP.

Синтаксис:

int ftp_login(int ftp_stream, string username, string password)

Функция ftp_login() производит регистрацию в системе под именем username с паролем password. Возвращает true или false при ошибке.

[править] ftp_quit

Производит завершение сеанса FTP.

Синтаксис:

int ftp_quit(int ftp_stream)

[править] ftp_pwd

Производит определение текущего каталога.

Синтаксис:

int ftp_pwd(int ftp_stream)

Эта функция возвращает текущий каталог FTP-сервера или false при ошибке.

[править] ftp_cdup

Производит переход в корневой каталог.

Синтаксис:

int ftp_cdup(int ftp_stream)

Функция возвращает true или false при ошибке.

[править] ftp_chdir

Производит переход в каталог.

Синтаксис:

int ftp_chdir(int ftp_stream, string directory)

Функция возвращает true или false при ошибке.

[править] ftp_mkdir

Производит создание каталога.

Синтаксис:

int ftp_mkdir(int ftp_stream, string directory)

Функция возвращает имя созданного каталога или false при ошибке.

[править] ftp_rmdir

Производит удаление каталога.

Синтаксис:

int ftp_rmdir(int ftp_stream, string directory)

Функция true или false при ошибке.

[править] ftp_nlist

Производит получение листинга каталога.

Синтаксис:

int ftp_nlist(int ftp_stream, string directory)

Функция ftp_nlist() возвращает массив файловых имен или false при ошибке.

[править] ftp_rawlist

Получение подробного листинга каталога.

Синтаксис:

int ftp_rawlist(int ftp_stream, string directory)

Функция ftp_rawlist() выполняет FTP-команду LIST, и возвращате его результаты в массиве, где каждый элемент соответствует строке текста "как есть". Идентификатор типа системы, возвращаемый ftp_systype(), может быть использован для определения того, как следует интерпретировать результаты.

[править] ftp_systype

Возвращает системный идентификатор типа FTP-сервера.

Синтаксис:

int ftp_systype(int ftp_stream)

Функция возвращает строковое значение или false в случае ошибки.

Получено с http://spravkaweb.local/index.php/php/netfile/ftp/server
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 16:22, 8 февраля 2007.
  • К этой странице обращались 106 раз.
1.68295288086


Приложения PHP : Переменные окружения в PHP — Справочник Web-языков

Приложения PHP : Переменные окружения в PHP

Главная | ::. | PHP | ::. | Приложения PHP | ::. | Переменные окружения
 |  |  |  |  |  | MIME-типы файлов

Содержание

  • 1 Переменные окружения в PHP
  • 2 HTTP_ACCEPT
  • 3 HTTP_REFERER
  • 4 HTTP_COOKIE
  • 5 HTTP_USER_AGENT
  • 6 HTTP_HOST
  • 7 HTTP_FROM
  • 8 SERVER_NAME
  • 9 SERVER_SOFTWARE
  • 10 SERVER_PORT
  • 11 SERVER_PROTOCOL
  • 12 REMOTE_ADDR
  • 13 REMOTE_PORT
  • 14 REMOTE_USER
  • 15 SCRIPT_NAME
  • 16 DOCUMENT_ROOT
  • 17 REQUEST_METHOD
  • 18 QUERY_STRING
  • 19 PATH_INFO
  • 20 PATH_TRANSLATED
  • 21 CONTENT_TYPE
  • 22 CONTENT_LENGTH
  • 23 GATEWAY_INTERFACE
  • 24 Пример использования переменных окружения

[править] Переменные окружения в PHP

Непосредственно перед запуском сценария сервер передает ему некие переменные окружения с информацией. В определенных переменных содержаться некоторые заголовки, но не все (получить все заголовки нельзя). Далее я приведу список наиболее важных переменных окружения.

[править] HTTP_ACCEPT

- В этой переменной перечислены все MIME-типы данных, которые могут быть восприняты браузером. Строка */* означает, что браузер понимает любой тип.

HTTP_ACCEPT= image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash, application/vnd.ms-excel, application/msword, */*

[править] HTTP_REFERER

- Эта переменная представляет сведения о странице, с которой пользователь попал на данную. Эту переменную можно использовать, например, для отслеживания перемещения пользователя по вашему сайту, а затем просматривать наиболее популярные маршруты.

HTTP_REFERER= http://www.spravkaweb.ru/php/pril/

[править] HTTP_COOKIE

- В этой переменной хранятся все Cookies в URL-кодировке.

HTTP_COOKIE= hotlog=1; ZDEDebuggerPresent=php,phtml,php3; b=b; PHPSESSID=16805922a9258cda274316e60f649cf8

[править] HTTP_USER_AGENT

- Идентифицирует браузер пользователя. Для установления типа браузера нужно проверить эту строку на наличие слов: если браузер - Internet Explorer, то будет присутствовать подстрока MSIE, а если в наличии лишь слово Mozilla, то это Netscape.

Например:

HTTP_USER_AGENT= Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; MyIE2; Maxthon)

[править] HTTP_HOST

- Содержит доменное имя Web-сервера, на котором запустился сценарий. Эту переменную достаточно удобно использовать, например, для генерации полного пути, который требуется в заголовке Location, чтобы не привязываться к конкретному серверу.

HTTP_HOST= www.spravkaweb.ru

[править] HTTP_FROM

- Адрес электронной почты пользователя, направившего запрос.

[править] SERVER_NAME

- Доменное имя или IP-адрес сервера.

SERVER_NAME= www.spravkaweb.ru

[править] SERVER_SOFTWARE

- Имя и версия программы-сервера, отвечающей на запрос клиента.

[править] SERVER_PORT

- Эта переменная содержит порт сервера, к которому обратился браузер пользователя. Обычно это 80. Переменная так-же может применяться для формирования параметра заголовка Location.

SERVER_PORT= 80

[править] SERVER_PROTOCOL

- Переменная содержит имя и версию информационного протокола, который был использован для запроса.

SERVER_PROTOCOL= HTTP/1.1

[править] REMOTE_ADDR

- Эта переменная содержит IP-адрес (или доменное имя) узла пользователя, на котором был запущен браузер.

[править] REMOTE_PORT

- Порт, который закрепляется за браузером пользователя для получения ответа сервера.

[править] REMOTE_USER

- Идентификационное имя пользователя, посылающего запрос.

[править] SCRIPT_NAME

- Содержит имя файла, содержащего данный сценарий. Эту переменную удобно использовать при формировании заголовка Location при переадресации на себя (self-redirect), а также для подставления значения атрибута action тега <form> на странице, которую вызывает сценарий при запуске без параметров (для того чтобы не привязываться к конкретному имени сценария).

[править] DOCUMENT_ROOT

- Корневой каталог дерева Web-документов.

[править] REQUEST_METHOD

- Метод, который применяет пользователь при передаче данных. Надо заметить, что грамотно составленный сценарий должен сам определять на основе этой переменной, какой метод задействует пользователь, и принимать данные из соответствующего источника, а не расчитывать, что передача будет осуществляться, например, только методом POST.

[править] QUERY_STRING

- Содержит параметры, которые в URL указаны после вопросительного знака. Напомним, что они доступны как при методе GET, так и при методе POST (если в последнем случае они были определены в атрибуте action тега <form>).

[править] PATH_INFO

- Содержит дополнительную информацию о пути.

[править] PATH_TRANSLATED

- Та же информация, что и в переменной PATH_INFO с префиксом, задающим путь к корневому каталогу дерева Web-документов.

[править] CONTENT_TYPE

- Медиа-тип данных запроса.

[править] CONTENT_LENGTH

- Возвращает количество байт данных, присланных пользователем. Эту переменную необходимо анализировать, если вы занимаетесь приемом и обработкой POST-формы.

[править] GATEWAY_INTERFACE

- Версия CGI, которую использует сервер.

[править] Пример использования переменных окружения

Далее я приведу пример использования некоторых переменных:

<html>
<head><title>Переменные окружения</title><head>
<body>
<h1>Переменные окружения:</h1>
<hr>
<?
echo "Вы пришли из: ".getenv("HTTP_REFERER")."<BR>";
$br=getenv("HTTP_USER_AGENT");
if(strpos($br,"MSIE")!==false) echo "У вас Internet Explorer<BR>";
else echo "У вас Netscape или др.<BR>";
echo "Ваш IP: ".getenv("REMOTE_ADDR")."<BR>";
echo "Вот параметры в строке браузера: ".getenv("QUERY_STRING");
?>
</body>
</html>
Получено с http://spravkaweb.local/index.php/php/pril/getenv
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:11, 18 марта 2007.
  • К этой странице обращались 108 раз.
1.5759499073


Приложения PHP : MIME-типы файлов — Справочник Web-языков

Приложения PHP : MIME-типы файлов

 |  |  |  |  |  | Переменные окружения
Главная | ::. | PHP | ::. | Приложения PHP | ::. | MIME-типы файлов

[править] MIME-типы файлов

MIME (Multipurpose Internet Mail Extensions
- Многоцелевые расширения почты интернета, были разработаны как стандарт идентификации различных типов файлов для отправки их по почте, но в последствии их функции были расширены и на другие сервисы Интернета.
Для типа MIME, который приписывается в реестре Windows и используется различными программами, в частности, указывается расширение файла и программа, с помощью которой данный тип файлов будет обрабатываться.
Типы MIME | Тип файла
Архив RAR (.rar) | application/x-tar
Архив ZIP (.zip) | application/x-zip-compressed
Исполняемый файл для DOS или Microsoft Windows (.e | application/octet-stream
Аудио- или видеозапись ASF | video/x-ms-asf
Аудио- или видеозапись WMV | video/x-ms-wmv
Аудиозапись AIFF | audio/aiff
Аудиозапись AU (.au .snd) | audio/basic
Аудиозапись MIDI | audio/mid
Аудиозапись MP3 | audio/mpeg
Аудиозапись WAV (.wav) | audio/x-wav
Аудиозапись WMA | audio/x-ms-wma
Аудиозапись AVI | video/avi
Аудиозапись AVI (.avi) | video/x-msvideo
Видеозапись Indeo (IVF) | video/x-ivf
Видеозапись MPEG (.mpeg .mpg .mpe) | video/mpeg
Видеозапись QuickTime (.qt .mov) | video/quicktime
Визитная карточка, используемая почтовыми программ | text/x-vcard
Графический файл ART | image/x-jg
Графический файл BMP | image/bmp
Графический файл GIF | image/gif
Графический файл JPEG | image/jpeg
Графический файл PNG (.png) | image/png
Графический файл Macromedia Flash | application/futuresplash
Графический файл TIFF | image/tiff
Документ Adobe Acrobat | application/pdf
Документ HTML | text/html
Документ Microsoft Excel | application/x-msexcel
Документ Microsoft Word | application/msword
Документ RTF | application/msword
Документ RTX | text/richtext
Документ XML | text/xml
Приложение | application/x-msdownload
Приложение HTML (HTA) | application/hta
Таблица стилей HTML | text/css
Текстовой документ | text/plain
ECMAScript | text/ecmascript
Microsoft JScript | text/Jscript
Microsoft JScript | text/javascript
Microsoft VBScript | text/vbs
Microsoft VBScript | text/vbscript
Трехмерная интерактивная графика в формате VRML (. | x-world/x-vrml
Получено с http://spravkaweb.local/index.php/php/pril/mime
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:19, 18 марта 2007.
  • К этой странице обращались 83 раза.
1.37551879883


Советы по PHP : Запрет кэширования посредством PHP — Справочник Web-языков

Советы по PHP : Запрет кэширования посредством PHP

(Перенаправлено с php/sover/nocash)
Перейти к: навигация, поиск
Главная | ::. | PHP | ::. | Советы по PHP | ::. | Запрет кэширования посредством PHP
 |  |  |  |  |  | Создание голосования на PHP

[править] Запрет кэширования посредством PHP

Большинство сценариев формируют документы, которые при каждом запуске программы изменяются. Очевидно, если браузер пользователя начнет кэшировать такие документы, ничего хорошего не получиться.

Запретить кэшировать документы браузером и Proxy-серверами можно при помощи средств языка PHP, а именно функции Header().

Для этого надо использовать в начале сценария следующие команды:

Header("Expires: Mon, 26 Jul 1997 05:00:00 GMT"); //Дата в прошлом
Header("Cache-Control: no-cache, must-revalidate"); // HTTP/1.1
Header("Pragma: no-cache"); // HTTP/1.1
Header("Last-Modified: ".gmdate("D, d M Y H:i:s")."GMT");

Для полного запрета кэширования приходиться всегда посылать 4 указанных заголовка, и ни один пропустить нельзя - в противном случае не сработает либо браузер, либо Proxy-сервер.

Получено с http://spravkaweb.local/index.php/php/sovet/nocash
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 13:31, 18 марта 2007.
  • К этой странице обращались 115 раз.
1.25504779816


Советы по PHP : Из PHP в Excel: работа с COM-объектами : Введение — Справочник Web-языков

Советы по PHP : Из PHP в Excel: работа с COM-объектами : Введение

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Отправка писем при помощи PHP
Главная | ::. | PHP | ::. | Советы по PHP | ::. | Из PHP в Excel: работа с COM-объектами | ::. | Введение
 |  |  |  |  |  |  |  | Открытие, запись, закрытие документа

Данная серия статей посвящена созданию документов Excel при помощи PHP. Данная возможнось может понадобиться, например, если нужно предоставить пользователю загружаемые данные в виде листов Excel. Это могут быть прайсы на продукцию, автоматически генерируемые из базы данных на сервере, либо какие-то документы, которые также необходимо представить в виде документов Excel.

Здесь рассматривается возможность работы с Excel-документами через COM-объект. К сожалению работа с COM-объектами в PHP возможна только на Windows-платформах. По-этому если Вы используете Unix-хостинг, то создавать и редактировать Excel-документы приведенным ниже способом не получится.

Работа с COM-объектами производится при помощи синтаксиса

$com_object = new COM($object);

где

  • $com_object - новый COM-объект;
  • $object - id-класс требуемого объекта.

Для создания Excel-документов переменной $object необходимо задать значение "Excel.Application" либо "Excel.sheet".

$xsl = new COM("Excel.Application");

После создания нового COM-объекта, можно обращаться к его свойствам и методам:

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

$rangeValue = $xls->Range("A1");
$rangeValue->Value = "В выделенном блоке текст будет жирный, подчеркнутый, наклонный";
$rangeValue = $xls->Range("A2");
$rangeValue->Value = "Шрифт будет иметь высоту 12";
$rangeValue = $xls->Range("A3");
$rangeValue->Value = "Имя шрифта - Times New Roman";

$range=$xls->Range("A1:J10");               // Определяем область ячеек
$range->Select();                           // Выделяем ее
$fontRange=$xls->Selection();               // Присваиваем переменной выделенную область

// Далее задаем параметры форматирования текста в выделенной области
$fontRange->Font->Bold = true;              // Жирный
$fontRange->Font->Italic = true;            // Курсив
$fontRange->Font->Underline = true;         // Подчеркнутый
$fontRange->Font->Name = "Times New Roman"; // Имя шрифта
$fontRange->Font->Size = 12;                // Размер шрифта

?>
Получено с http://spravkaweb.local/index.php/php/sovet/excelcom
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 11:51, 25 марта 2007.
  • К этой странице обращались 70 раз.
1.36256098747


Советы по PHP : Отправка писем при помощи PHP — Справочник Web-языков

Советы по PHP : Отправка писем при помощи PHP

 |  |  |  |  |  | Создание голосования на PHP
Главная | ::. | PHP | ::. | Советы по PHP | ::. | Отправка писем при помощи PHP
 |  |  |  |  |  | Отправка писем при помощи PHP : Прикрепление файла

Содержание

  • 1 Отправка писем при помощи PHP
    • 1.1 Общие возможности
    • 1.2 Решение проблемы кодировок
    • 1.3 Отправка письма в HTML-виде
  • 2 Смотреть также

[править] Отправка писем при помощи PHP

[править] Общие возможности

Рано или поздно каждый владелец сайта сталкивается с необходимостью отправки писем непосредственно с сайта через скрипт, а не через почтовые программы. Это могут быть письма, отправляемые скриптом гостевой книги, сообщающее владельцу сайта что у него в гостевой появилось новое сообщение, или форумом, для оповещения о новом вопросе.

Во всех этих случаях необходима именно автоматическая отправка писем миную разнообразные почтовые программы и утилиты. Сделать это можно при помощи функции mail(), которую мы сейчас и будем изучать.

Синтаксис функции mail():

bool mail(string $to, string $subject, string $msg [, string $header]);

Функция mail() посылает письмо с темой $subject и содержанием $msg по адресу $to.

Если Вы хотите, чтобы письмо ушло по нескольким адресам, разделите их пробелами.

Само сообщение может быть многострочным. Для перехода на новую строку поставьте знак перехода на новую строку "\n" в конце каждой строки.

mail("name@mail.ru", "my subject", "stroka1nstroka2nstroka3");

Или тотже самое можно записать так:

mail("name@mail.ru", "my subject", "stroka1
stroka2
stroka3");

В четвертом необязательном параметре $header можно указать заголовки нашего сообщения.

Под заголовками я подразумеваю информацию, передаваемую вместе с письмом почтовому клиенту, которая будет содержать некоторые технические данные, такие как: кодировка письма, имя отправителя, обратный адрес отправителя и т.д. Это схоже с использованием тега <META> в HTML.

Чтобы было более понятно, что из себя представляют заголовки, и где они находятся в письме, откройте почтовый клиент и посмотрите на любое письмо в том виде, как оно пришло (Для Outlook это можно сделать нажав правой клавишей мыши на сообщение->Свойства->Подробно->Исходное сообщение).

Как мы видим, письмо представляет простой текстовой файл, состоящий из двух общих разделов: Вверху идут заголовки письма, затем через две строки идет само письмо.

Заголовков письма достаточно много, но не все они используются при написании скрипта отправки почты.

Вот некоторые наиболее часто используемые:

  • From: "Имя пользователя отправителя" <Обратный адрес отправителя>
  • To: <Адрес, по которому отправляют письмо>
  • Subject: Тема письма

[править] Решение проблемы кодировок

Я не зря выше привел пример отправки письма со словами латинского алфавита. Их любой почтовый клиент прочтет без труда. Но вот с русским алфавитом труднее. Русских кодировок существует огромное множество. И от того, насколько умело Вы перекодируете письмо, будет зависеть прочтет ли получатель его, или не будет возиться с установкой нужной кодировки и просто удалит его в корзину.

Кодировку письма задает заголовок Content-type:

$header="From: "Evgen" <evgen@mail.ru>";
$header.="Content-type: text/plain; charset="windows-1251"";
$subject="Тема письма";
$msg="Сторака 1nСтрока 2nСтрока 3";
mail("name@mail.ru", $subject, $msg, $header);

В заголовке мы указали, что тип письма будет простой текст, а кодировка - Windows.

Теперь наше письмо придет в понятной для почтового клиента кодировке.

Но стоит отметить, что в некоторых случаях в правильной кодировке будет отображено только само письмо. Заголовок же так и останется нечитаемым. Связано это с тем, где расположен заголовок Content-type относительно заголовка Subject, который и содержит тему письма. Дело в том, что существуют почтовые программы, которые понимают заголовок Content-type, но не понимают русский текст в поле Subject, если это поле стоит до Content-type. В то же время, другие почтовые программы обязывают нас задавать Content-type последним заголовком в списке. Чтобы обойти эти препятствия, можно разместить поле Content-type сразу в начале и в конце списка заголовков:

$subject="Тема письма";
$header="Content-type: text/plain; charset="windows-1251"";
$header.="From: Evgen <evgen@mail.ru>";
$header.="Subject: $subject";
$header.="Content-type: text/plain; charset="windows-1251"";
$msg="Сторака 1nСтрока 2nСтрока 3";
mail("name@mail.ru", $subject, $msg, $header);

Теперь это письмо прочтет любая почтовая программа!

[править] Отправка письма в HTML-виде

Для отправки письма в HTML-виде достаточно в заголовке Content-type указать тип документа не text/plain (простой текст), а text/html (html-текст).

А само письмо записать в html-виде:

$subject="Тема письма";
$header="Content-type: text/html; charset="windows-1251"";
$header.="From: Evgen <evgen@mail.ru>";
$header.="Subject: $subject";
$header.="Content-type: text/html; charset="windows-1251"";
$msg="<body>
<li>Сторака 1
<li>Сторака 2
<li>Сторака 3
</body>";
mail("name@mail.ru", $subject, $msg, $header);

[править] Смотреть также

  • Прикрепление файла
  • Как вставить в письмо картинку
Получено с http://spravkaweb.local/index.php/php/sovet/mail
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 16:39, 18 марта 2007.
  • К этой странице обращались 110 раз.
1.40967178345


Советы по PHP : Запрет кэширования посредством PHP — Справочник Web-языков

Советы по PHP : Запрет кэширования посредством PHP

Главная | ::. | PHP | ::. | Советы по PHP | ::. | Запрет кэширования посредством PHP
 |  |  |  |  |  | Создание голосования на PHP

[править] Запрет кэширования посредством PHP

Большинство сценариев формируют документы, которые при каждом запуске программы изменяются. Очевидно, если браузер пользователя начнет кэшировать такие документы, ничего хорошего не получиться.

Запретить кэшировать документы браузером и Proxy-серверами можно при помощи средств языка PHP, а именно функции Header().

Для этого надо использовать в начале сценария следующие команды:

Header("Expires: Mon, 26 Jul 1997 05:00:00 GMT"); //Дата в прошлом
Header("Cache-Control: no-cache, must-revalidate"); // HTTP/1.1
Header("Pragma: no-cache"); // HTTP/1.1
Header("Last-Modified: ".gmdate("D, d M Y H:i:s")."GMT");

Для полного запрета кэширования приходиться всегда посылать 4 указанных заголовка, и ни один пропустить нельзя - в противном случае не сработает либо браузер, либо Proxy-сервер.

Получено с http://spravkaweb.local/index.php/php/sovet/nocash
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 13:31, 18 марта 2007.
  • К этой странице обращались 114 раз.
1.269977808


Советы по PHP : Создание голосования на PHP — Справочник Web-языков

Советы по PHP : Создание голосования на PHP

 |  |  |  |  |  | Запрет кэширования посредством PHP
Главная | ::. | PHP | ::. | Советы по PHP | ::. | Создание голосования на PHP
 |  |  |  |  |  | Отправка писем при помощи PHP

[править] Создание голосования на PHP

Для начала надо определиться, о чем мы будем спрашивать посетителей. Например, понравился им ваш сайт или нет.

Для нашего голосования нам потребуются четыре файла:

  • В первом будет находиться форма с голосованием (form.html).
  • Второй файл будет отвечать за обработку результатов (golos.php).
  • В третьем будут храниться данные голосования (data.txt).
  • Четвертый будет отвечать за выдачу графической информации (img.php).

Например мы хотим задать посетителям следующие вопросы:

Ваше мнение о сайте
  • просто супер
  • нормальный
  • так себе
  • мне все равно
  • плохой
  • хуже не видел

В файл form.html запишем:

<form action=golos.php method=post>
<table cellspacing cellpadding=0 border=0>
<tr><td align=center colspan=2><B>Голосование:</B></td></tr>
<tr><td align=center colspan=2><B>Ваше мнение о сайте:</B></td></tr>
<tr><td><input type=radio name=otv value=1 checked></td>
<td>Просто супер!</td></tr>
<tr><td><input type=radio name=otv value=2></td>
<td>Нормальный.</td></tr>
<tr><td><input type=radio name=otv value=3></td><
td>Так себе.</td></tr>
<tr><td><input type=radio name=otv value=4></td><
td>Мне все равно.</td></tr>
<tr><td><input type=radio name=otv value=5></td><
td>Плохой.</td></tr>
<tr><td><input type=radio name=otv value=6></td><
td>Хуже не видел!</td></tr>
<tr><td colspan=2 align=center>
<input type=submit name=golos value="Голосовать"></td></tr>
</table</form>

После нажатия кнопки Голосовать переменная $otv перейдет на обработку сценарием в файле golos.php

В файл data.txt надо записать начальные данные, которые затем будут оттуда считаны и обработаны.

Создайте файл data.txt и в текстовом редакторе запишите в него следующие строки:

Результаты голосования:
0
0
0
0
0
0

Первая строка у нас учитываться не будет.

В остальные шесть строк надо ввести нули, нажимая после каждой цифры клавишу Enter.

В файле golos.php, который у нас отвечает за обработку результатов, напишем следующее:

<html>
<head>
<title>Обработка голосования</title>
</head>
<body>
<?php
if(@$golos) {
// Здесь мы запускаем обработку данных только если
// была нажата клавиша Голосовать
  $file_name="data.txt";
  // Переменная $file_name задает имя файла с результатами
  $file=file($file_name);
  // Записываем файл с данными в массив $file
  $file_len=count($file);
  // $file_len - количество строк в файле data.txt
  for($i=1,$n=0;$i<$file_len;$i++) {
    $file[$i]=trim($file[$i]);
    $n=$n+$file[$i];
  };
  // В этом цикле мы убираем символы перевода строки и записываем в
  // переменную $n сколько человек уже проголосовало
  echo "<center><h2>Спасибо, Ваше мнение учтено!</h2></center>";
  $file[$otv]++;
  $n++;
  // Здесь мы учитываем номер ответа, который пришел к нам из формы,
  // увеличив соответствующее значение в массиве и число проголосовавших на 1
  $rez="Результаты голосования:n";
  // Переменная $rez будет содержать данные о голосовании,
  // которые затем запишем обратно в файл
  for($i=1;$i<$file_len;$i++) $rez.=$file[$i]."n";
  $rez=trim($rez);
  $file_rec=@fopen($file_name,"w");
  // Здесь мы создаем новый файл, в который затем запишем обновленные данные
  if($file_rec) {
    $counter=fputs($file_rec,$rez);
    // Запись обновленных данных в файл data.txt
    fclose($file_rec);
  }
  else echo "Произошла ошибка записи результатов!";
  for($i=1;$i<$file_len;$i++) $pr[$i]=round(($file[$i]/$n)*100);
// Записали в массив $pr, сколько процентов от общего числа голосовавших
// занимает каждый ответ
// Далее идет кусок HTML-кода, который
// отвечает за вывод наших данных на экран
?>
<center><h2>Ваше мнение о сайте:</h2></center><BR>
<table border=1 align=center>
<tr><td>
<B>Просто супер! (<?php echo $file[1];?>):</B>
</td><td>
<img src="img.php?pr=<?php echo $pr[1];?>" height=15>
</td></tr>
<tr><td>
<B>Нормальный. (<?php echo $file[2];?>):</B>
</td><td>
<img src="img.php?pr=<?php echo $pr[2];?>" height=15>
</td></tr>
<tr><td>
<B>Так себе. (<?php echo $file[3];?>):</B>
</td><td>
<img src="img.php?pr=<?php echo $pr[3];?>" height=15>
</td></tr>
<tr><td>
<B>Мне все равно. (<?php echo $file[4];?>):</B>
</td><td>
<img src="img.php?pr=<?php echo $pr[4];?>" height=15>
</td></tr>
<tr><td>
<B>Плохой. (<?php echo $file[5];?>):</B>
</td><td>
<img src="img.php?pr=<?php echo $pr[5];?>" height=15>
</td></tr>
<tr><td>
<B>Хуже не видел! (<?php echo $file[6];?>):</B>
</td><td>
<img src="img.php?pr=<?php echo $pr[6];?>" height=15>
</td></tr>
</table>
<table border=1 align=center>
<tr><td align=center><B>Всего проголосовало:</B></td></tr>
<tr><td align=center><?echo $n." человек";?></td></tr>
</table>
<?
};
?>
</body>
</html>

Записав в атрибут SRC тега <IMG> значение "img.php?pr=количество процентов" мы тем самым передаем файлу img.php (который отвечает за вывод графической информации) значение, на основании которого будет на лету сгенерировано изображение голосования.

Далее приведу листинг файла img.php:

<?php
  $otstup=35;
  // $otstup - задает отступ, в прелелах которого
  // в картинку впишем процентное значение
  $string=$pr."%";
  // $string - содержит значение процентов плюс знак процента
  $im=imageCreate($pr*2+$otstup,15);
  // Здесь создаем идентификатор, при помощи
  // которого мы будем работать с картинкой
  $fon=imageColorAllocate($im,220,20,60);
  $fon1=imageColorAllocate($im,255,20,147);
  // Задаем цвет фона
  $col_b=imageColorAllocate($im,0,0,0);
  // Задаем цвет обводки
  $shrift=imageColorAllocate($im,255,255,255);
  // Цвет вывода процентного значения
  imageFill($im,2,2,$fon);
  // Заполнили наш прямоугольник основным фоном
  $x1=0;$x2=$pr*2+$otstup-1;
  $y1=0;$y2=14;
  // Формирование улов для обводки контуром
  imageLine($im,$x1,$y1,$x2,$y1,$col_b);
  imageLine($im,$x2,$y1,$x2,$y2,$col_b);
  imageLine($im,$x2,$y2,$x1,$y2,$col_b);
  imageLine($im,$x1,$y1,$x1,$y2,$col_b);
  imageLine($im,$x1+$otstup,$y1,$x1+$otstup,$y2,$col_b);
  // Создание контура и разделяющей полосы
  if($pr!=0) imageFill($im,$otstup+1,2,$fon1);
  // Если значение процента не равно 0, то заполняем
  // правую часть цветом $fon1
  imageString($im,3,5,1,$string,$shrift);
  // Пишем в правую часть картинки процентное значение
  header("Content-type: image/png");
  imagePng($im);
  imageDestroy($im);
  // Здесь производим вывод полученной картинки в
  // стандартный поток вывода и уничтожаем идентификатор
?>
Получено с http://spravkaweb.local/index.php/php/sovet/voting
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 13:39, 18 марта 2007.
  • К этой странице обращались 86 раз.
1.38743591309


php/sovet/excelcom/cell — Справочник Web-языков

php/sovet/excelcom/cell

 |  |  |  |  |  |  |  | Рисование таблиц
Главная | ::. | PHP | ::. | Советы по PHP | ::. | Из PHP в Excel: работа с COM-объектами | ::. | Копирование / вставка ячеек

В Excel при помощи PHP можно копировать ячейки и вставлять ранее скопированные ячейки.

[править] Общие возможности

копирование ячеек;
вставка скопированных ячеек;
перемещение ячеек;

[править] Копирование / вставка ячеек

Копирование ячеек происходит в два этапа: сначало надо выделить копируемую область и копировать ее методом Copy(), а затем нужно выделить область, в которую будут вставлены скопированные ячейки и вставить их

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

// Задаем копируемую ячейку
$range=$xls->Range("A1");
$range->Value = "Cправочник Web-языков";
// Копируем ее
$range->Copy();
// Задаем область, в которую скопируется ячейка
$range=$xls->Range("A3:A9");
$range->Select();
$range=$xls->Selection();
// Вставляем
$xls->ActiveSheet->Paste();
?>

Здесь ActiveSheet - ссылка на выделенные ячейки.

[править] Перемещение ячеек

Если при копировании копируемые ячейки оставались на месте, то при перемещении копируемые ячейки удаляются. Перемещение осуществляется методом Cut().

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

// Задаем копируемую ячейку
$range=$xls->Range("A1");
$range->Value = "Cправочник Web-языков";
// Копируем ее
$range->Cut();
// Задаем область, в которую скопируется ячейка
$range=$xls->Range("A3");
$range->Select();
$range=$xls->Selection();
// Вставляем
$xls->ActiveSheet->Paste();
?>
Получено с http://spravkaweb.local/index.php/php/sovet/excelcom/cell
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 15:10, 27 марта 2007.
  • К этой странице обращались 15 раз.
1.2868938446


Советы по PHP : Из PHP в Excel: работа с COM-объектами : Работа с колонками — Справочник Web-языков

Советы по PHP : Из PHP в Excel: работа с COM-объектами : Работа с колонками

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Работа со строками
Главная | ::. | PHP | ::. | Советы по PHP | ::. | Из PHP в Excel: работа с COM-объектами | ::. | Работа с колонками
 |  |  |  |  |  |  |  | Добавление / Удаление / Переименование листов

Содержание

  • 1 Общие возможности
  • 2 Добавление колонки
  • 3 Удаление колонки
  • 4 Задание ширины колонки
  • 5 Автоподбор ширины колонок
  • 6 Скрытие/отображение колонок

[править] Общие возможности

В Excel при помощи PHP можно произвести следующие действия с колонками:

  • добавить колонку;
  • удалить колонку;
  • задать ширину одной или нескольких колонок;
  • сделать автоподбор ширины одной или нескольких колонок;
  • скрыть колонку или группу колонок;
  • отобразить ранее скрытую колонку или группу колонок;
  • установить ширину для всех колонок.

[править] Добавление колонки

Добавить колонку можно при помощи метода Insert() объекта EntireColumn():

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

// Вставляем в первую и вторую верхнюю ячейку значения
$range=$xls->Range("A1");            // Выбрали ячейку A1
$range->Value = "1-ая колонка";      // Вставили значение
$range=$xls->Range("B1");            // Выбрали ячейку B1
$range->Value = "2-ая колонка";      // Вставили значение

// Добавляем колонку
$range=$xls->Range("B:B");           // Определяем коноку
$range->EntireColumn->Insert();      // Вставляем на ее место новую колонку

// Запись нового значения
$range=$xls->Range("B1");            // Выбираем вторую верхнюю ячейку
$range->Value = "Вставка";           // Записываем в нее значение
?>

[править] Удаление колонки

Удаление колонки производится при помощи метода Delete() объекта EntireColumn():

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

// Вставляем в 1-ую, 2-ую и 3-ю верхние ячейки значения
$range=$xls->Range("A1");            // Выбрали ячейку A1
$range->Value = "1-ая колонка";      // Вставили значение
$range=$xls->Range("B1");            // Выбрали ячейку B1
$range->Value = "2-ая колонка";      // Вставили значение
$range=$xls->Range("C1");            // Выбрали ячейку C1
$range->Value = "3-ая колонка";      // Вставили значение

// Удаляем колонку
$range=$xls->Range("B:B");           // Определяем коноку
$range->EntireColumn->Delete();      // Удаляем ее
?>

[править] Задание ширины колонки

Принцип задания ширины колонки или группы колонок в целом аналогичен заданию высоты строк за исключением того, что за ширину отвечает свойство ColumnWidth() а не RowHeight(). Высота задается в миллиметрах.

В следующем примере для столбца "A:A" задается ширина 40 мм:

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

// Изменение ширины столбца
$range=$xls->Range("A:A");           // Выбираем 1-й столбец
$range->Select();                    // Выделяем его
$cellRange=$xls->Selection;          // Определяем $cellRange как выделенный фрагмент
$cellRange->ColumnWidth = 40;        // Устанавливаем ширину столбца
?>

По аналогии можно задать ширину для нескольких колонок

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

// Изменение ширины колонок
$range=$xls->Range("A:E");           // Выбираем колонки с A по E
$range->Select();                    // Выделяем их
$cellRange=$xls->Selection;           // Определяем $cellRange как выделенный фрагмент
$cellRange->ColumnWidth = 40;           // Устанавливаем ширину колонок
?>

[править] Автоподбор ширины колонок

Автоподбор ширины колонок используется для лучшей читабельности отображенных данных. Т.е. если длина текста много больше или много меньше ширины колонки, то есть возможность "подогнать" ширину колонки под этот текст.

Для автоподбора используется метод AutoFit() объекта Columns():

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

$range=$xls->Range("A1");            // Задаем 1-ую ячейку
$range->Font->Size = 20;             // Задаем размер шрифта
// Выводим в 1-ую выбранную ячейку значение
$range->Value = "Справочник Web-языков: www.spravkaweb.ru";

$range=$xls->Range("B2");            // Задаем 2-ую ячейку
$range->Font->Size = 20;             // Задаем размер шрифта
// Выводим во 2-ую выбранную ячейку значение
$range->Value = "Справочник Web-языков: www.spravkaweb.ru";

$range=$xls->Range("A:B");           // Задаем для работы 2 строки
$range->Select();                    // Выделяем эти строки
$rangeCells=$xls->Selection();       // Задаем $rangeCells как выделенный фрагмент
$rangeCells->ColumnWidth = 5;        // Устанавливаем ширину колонок = 5 мм

$rangeCells=$xls->Range("B:B");      // Выделяем 2-ю колонку
$rangeCells->Columns->AutoFit();     // Делаем автоподбор ширины
                                     // для второй колонки
?>

Т.е. у нас получилось следующее:

В ячейки A1 и B2 мы записали текст Справочник Web-языков: www.spravkaweb.ru. Шрифт для текста задали 20. Затем установили ширину колонок равной 5, и для второй колонки сделали автоподбор ширины. В итоге первая колонка так и осталась шириной 5 мм, а вторая по ширине растянулась на всю длину надписи.

[править] Скрытие/отображение колонок

За визуальное отображение колонок отвечает свойство Hidden() объекта EntireColumn().

Если присвоить этому свойству значение True, то выбранные колонки будут скрыты, если False, то показаны.

Следующий пример скроет колонки с B по D:

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

$range=$xls->Range("B:D");           // Выбираем колонки с B по D

$range->EntireColumn->Hidden = True; // Скрыть выбранные колонки
?>

Установка ширины для всех колонок:
Если возникла необходимость установить для всех колонок ширину, отличную от установленной по умолчанию, то это можно сделать при помощи свойства StandardWidth() объекта ActiveSheet():

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

// Установить ширину для всех колонок
$xls->ActiveSheet->StandardWidth = 5;
?>
Получено с http://spravkaweb.local/index.php/php/sovet/excelcom/cols
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:03, 26 марта 2007.
  • К этой странице обращались 17 раз.
0.867395877838


Советы по PHP : Из PHP в Excel: работа с COM-объектами : Формат ячеек: Выравнивание — Справочник Web-языков

Советы по PHP : Из PHP в Excel: работа с COM-объектами : Формат ячеек: Выравнивание

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Открытие, запись, закрытие документа
Главная | ::. | PHP | ::. | Советы по PHP | ::. | Из PHP в Excel: работа с COM-объектами | ::. | Формат ячеек: Выравнивание
 |  |  |  |  |  |  |  | Формат ячеек: Шрифт

В Excel при помощи PHP можно делать выравнивание данных, находящихся в ячейках как по вертикали, так и по горизонтали.

Содержание

  • 1 Общие возможности
  • 2 Выравнивание по горизонтали
  • 3 Выравнивание по вертикали
  • 4 Задание отступа

[править] Общие возможности

Доступны следующие действия:

выравнивание по значению;
выравнивание по левому краю;
выравнивание по центру;
выравнивание по правому краю;
выравнивание с заполнением;
выравнивание по ширине;
распределение по центру выделения;
распределение по горизонтали;
выравнивание по верхнему краю;
центрирование по вертикали;
выравнивание по нижнему краю;
выравнивание по высоте;
распределение по вертикали;
задание отступа в ячейке.

[править] Выравнивание по горизонтали

За выравнивание по горизонтали отвечает свойство HorizontalAlignment().

Выровнять значение можно как в одной ячейке, так и в диапазоне ячеек. Для этого надо выделить ячейку (или диапазон ячеек), и присвоить свойству HorizontalAlignment() одно из 8 предопределенных значений:

HorizontalAlignment = 1
- выравнивание по значению (используется по умолчанию);
HorizontalAlignment = 2
- выравнивание по левому краю;
HorizontalAlignment = 3
- выравнивание по центру;
HorizontalAlignment = 4
- выравнивание по правому краю;
HorizontalAlignment = 5
- выравнивание с заполнением;
HorizontalAlignment = 6
- выравнивание по ширине;
HorizontalAlignment = 7
- выравнивание по центру выделения;
HorizontalAlignment = 8
- распределение по горизонтали.

В приведенном ниже примере в верхней строчке таблицы "1:1" все значения будут выравниваться по центру.

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

// Выравниваем по центру
$rangeAlignment = $xls->Range("1:1");
$rangeAlignmeny->HorizontalAlignment = 3;
$rangeAlignment->Value = "Hello";
?>

[править] Выравнивание по вертикали

За выравнивание по вертикали отвечает свойство VerticalAlignment().

Так же как и по горизонтали, выровнять значение можно как в одной ячейке, так и в диапазоне ячеек. Для этого надо выделить ячейку (или диапазон ячеек), и присвоить свойству VerticalAlignment() одно из 5 предопределенных значений:

VerticalAlignment = 1
- выравнивание по верхнему краю;
VerticalAlignment = 2
- выравнивание по центру;
VerticalAlignment = 3
- выравнивание по нижнему краю (значение по умолчанию);
VerticalAlignment = 4
- выравнивание по высоте;
VerticalAlignment = 5
- распределение по вертикали.

В приведенном ниже примере в верхней строчке таблицы "1:1" все значения будут выравниваться по верхнему краю.

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

// Выравниваем по центру
$rangeAlignment = $xls->Range("1:1");
// Задаем выравнивание для ячеек: по верхнему краю
$rangeAlignment->VerticalAlignment = 1;
// Устанавливаем размер шрифта: 8
$rangeAlignment->Font->Size = 8;
// Устанавливаем высоту строки: 25
$rangeAlignment->RowHeight = 25;
// Выводим надпись: Hello
$rangeAlignment->Value = "Hello";
?>

[править] Задание отступа

Отступ в ячейке задается при помощи свойства IndentLevel().

Этому свойству приравнивают значение, равное количеству знаков, на которые нужно сместить данные влево.

В следующем примере мы в ячейку A1 запишем текст с отступом в 5 знаков, а в ячейку A2 - без отступа:

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

// Задание отступа
$rangeAlignment = $xls->Range("A1");
$rangeAlignment->IndentLevel = 5;
$rangeAlignment->Value = "Отступ равен 5 символам";

// Без отступа
$rangeAlignment = $xls->Range("A2");
$rangeAlignment->Value = "Без отступа";
?>
Получено с http://spravkaweb.local/index.php/php/sovet/excelcom/formatalign
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:56, 26 марта 2007.
  • К этой странице обращались 19 раз.
1.46089911461


Советы по PHP : Из PHP в Excel: работа с COM-объектами : Формат ячеек: Шрифт — Справочник Web-языков

Советы по PHP : Из PHP в Excel: работа с COM-объектами : Формат ячеек: Шрифт

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Формат ячеек: Выравнивание
Главная | ::. | PHP | ::. | Советы по PHP | ::. | Из PHP в Excel: работа с COM-объектами | ::. | Формат ячеек: Шрифт
 |  |  |  |  |  |  |  | Работа со строками

[править] Общие возможности

В Excel при помощи PHP с текстом, записанным в ячейках, можно сделать следующее:

  • сделать жирным;
  • выделить курсивом;
  • сделать подчеркнутым;
  • установить шрифт;
  • установить размер шрифта;
  • установить цвет текста;

[править] Форматирование текста

Методика обращения к свойствам текста следующая:

  • сначала в ранее созданном документе задаем диапазон ячеек, к которым будет применено форматирование текста;
  • выделяем его;
  • присваиваем переменной выделенный диапазон значений;
  • при помощи объекта Font() получаем доступ к форматированию выделенного фрагмента.
<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

$rangeValue = $xls->Range("A1");
$rangeValue->Value = "В выделенном блоке текст будет жирный, подчеркнутый, наклонный";
$rangeValue = $xls->Range("A2");
$rangeValue->Value = "Шрифт будет иметь высоту 12";
$rangeValue = $xls->Range("A3");
$rangeValue->Value = "Имя шрифта - Times New Roman";

$range=$xls->Range("A1:J10");               // Определяем область ячеек
$range->Select();                           // Выделяем ее
$fontRange=$xls->Selection();               // Присваиваем переменной выделенную область

// Далее задаем параметры форматирования текста в выделенной области
$fontRange->Font->Bold = true;              // Жирный
$fontRange->Font->Italic = true;            // Курсив
$fontRange->Font->Underline = true;         // Подчеркнутый
$fontRange->Font->Name = "Times New Roman"; // Имя шрифта
$fontRange->Font->Size = 12;                // Размер шрифта

?>

[править] Задание цвета текста

Цвет текста задается при помощи свойства ColorIndex() все того же объекта Font().

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

$range = $xls->Range("A1");
$range->Value = "Текст будет написан красным";
$range->Font->ColorIndex = 3;
?>

Есть одна особенность: цвет текста задается не в каком-либо формате (RGB, CMYK и т.д.), а номером, под которым он находится в палитре Excel-а.

Всего в палитре присутствует 55 цветов и одно значение отводиться под автоцвет. Итого при помощи свойства ColorIndex() можно задать 56 значений цвета.

Следующий пример выведет в документе Excel все возможные значения свойства ColorIndex():

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

$min_color_index=0;                  // Начальный индекс цвета
$max_color_index=55;                 // Конечный индекс цвета
$start_position=2;                   // Номер позиции, с которой начнется показ
                                     // индексов цвета
// Выводим надпись "Номер цвета"
$range = $xls->Range("A1:B1");
$range->Font->Bold = true;
$range = $xls->Range("A1");
$range->Value = "Номера цветов";

// Выводим значения индексов цвета и окрашиваем эти значения
// соответствующим цветом
for($i=$min_color_index;$i<=$max_color_index;$i++) {
  $range = $xls->Range("A".($i+$start_position));
  $range->Value = "ColorIndex = ".$i;
  $range->Font->ColorIndex = $i;
};
?>
Получено с http://spravkaweb.local/index.php/php/sovet/excelcom/formatprint
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:58, 26 марта 2007.
  • К этой странице обращались 15 раз.
1.20063781738


Советы по PHP : Из PHP в Excel: работа с COM-объектами : Добавление / Удаление / Переименование листов — Справочник Web-языков

Советы по PHP : Из PHP в Excel: работа с COM-объектами : Добавление / Удаление / Переименование листов

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Работа с колонками
Главная | ::. | PHP | ::. | Советы по PHP | ::. | Из PHP в Excel: работа с COM-объектами | ::. | Добавление / Удаление / Переименование листов
 |  |  |  |  |  |  |  | Рисование таблиц

[править] Общие возможности

В Excel при помощи PHP можно произвести следующие действия с листами:

  • выбрать лист;
  • добавить новый лист;
  • переместить лист;
  • удалить лист;
  • переименовать лист;

[править] Работа с листами

Доступ к листам в Excel осуществляется через объект Sheets.

Метод Select() позволяет сделать активным тот или иной лист документа:

$rangeSheet=$xls->Sheets("Лист2");
$rangeSheet->Select();

где "Лист2" - имя листа, который должен стать активным.

Добавить новый лист можно при помощи метода Add():

$rangeSheet=$xls->Sheets;
$rangeSheet->Add();

Если это первое добавление нового листа, то ему присваивается имя "Лист4". Обычно лист добавляется перед активным листом. Т.е. если до вызова метода Add() метод выбора листа Select() не вызывался, то новый лист добавляется в начало списка листов.

Имя листа содержится в свойстве Name() объекта Sheets().

В следующем примере создадим новый документ и переименуем листы "Лист1", "Лист2" и "Лист3" (которые создаются автоматически) в "Прайсы", "Контактная информация", "Заказ" соответственно:

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

$rangeSheet=$xls->Sheets("Лист1");
$rangeSheet->Name = "Прайсы";
$rangeSheet=$xls->Sheets("Лист2");
$rangeSheet->Name = "Контактная информация";
$rangeSheet=$xls->Sheets("Лист3");
$rangeSheet->Name = "Заказ";
?>
Получено с http://spravkaweb.local/index.php/php/sovet/excelcom/listupdate
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:04, 26 марта 2007.
  • К этой странице обращались 16 раз.
1.28661608696


Советы по PHP : Из PHP в Excel: работа с COM-объектами : Открытие, запись, закрытие документа — Справочник Web-языков

Советы по PHP : Из PHP в Excel: работа с COM-объектами : Открытие, запись, закрытие документа

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Введение
Главная | ::. | PHP | ::. | Советы по PHP | ::. | Из PHP в Excel: работа с COM-объектами | ::. | Открытие, запись, закрытие документа
 |  |  |  |  |  |  |  | Формат ячеек: Выравнивание

Содержание

  • 1 Общие возможности
  • 2 Создание нового документа
  • 3 Открытие ранее созданного документа
  • 4 Сохранение открытого документа
  • 5 Закрытие документа

[править] Общие возможности

В Excel при помощи PHP можно произвести следующие действия с документами:

  • создать новый документ;
  • открыть ранее созданный документ;
  • сохранить открытый документ;
  • закрыть документ.

[править] Создание нового документа

Создание нового документа в Excel происходит в три действия:

  • - Создаем "связь" между PHP и Excel (создается дескриптор, как при работе с файлами);
  • - Указываем, будет ли визуально открыта программа или нет;
  • - Указываем программе через дескриптор, что нужно открыть новый документ.

Для создания дескриптора ("связи") нужно использовать обращение к Excel через COM-объект:

$xls = new COM("Excel.Application");

Теперь через дескриптор $xls мы можем обращаться ко всем свойствам и методам Excel.

Будет ли отображаться Excel или нет, указывается в свойстве Visible() объекта Application().

Если мы этому свойству присвоим значение 1, то программа будет отображаться, если 0, то нет:

$xls->Application->Visible = 1;

Ну и, наконец, добавить новый документ можно при помощи метода Add() объекта Workbooks():

$xls->Workbooks->Add();

Т.е. чтобы просто запустить при помощи PHP Excel нужно выполнить следующий код:

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ
?>

Первые две строки этого примера нужно использовать всегда при работе с Excel через PHP.

[править] Открытие ранее созданного документа

Открытие документа можно сделать при помощи метода Open() объекта Workbooks().

В передаваемом методу Open() параметре нужно указать имя открываемого файла:

<?php
$xls = new COM("Excel.Application");  // Создаем новый COM-объект
$xls->Application->Visible = 1;       // Заставляем его отобразиться
$xls->Workbooks->Open("C:test.xls"); // Открываем ранее сохраненный документ
?>

Если указать не полный а относительный путь, то поиск открываемого файла будет происходить не на сервере а на компьютере пользователя (по умолчанию это папка "Мои документы").

[править] Сохранение открытого документа

Сохранение открытого документа производится при помощи метода SaveAs() объекта Workbooks():

<?php
$xls = new COM("Excel.Application");  // Создаем новый COM-объект
$xls->Application->Visible = 1;       // Заставляем его отобразиться
$xls->Workbooks->Add();
$range=$xls->Range("A1");            // Выбрали ячейку A1
$range->Value = "Проба записи";      // Вставили значение

// Сохраняем документ
$xls->Workbooks[1]->SaveAs("test.xls");

$xls->Quit();                        //Закрываем приложение
$xls->Release();                     //Высвобождаем объекты
$xls = Null;
$range = Null;
?>

[править] Закрытие документа

Закрытие документа производится методом Quit().

<?php
$xls = new COM("Excel.Application");  // Создаем новый COM-объект
$xls->Application->Visible = 1;       // Заставляем его отобразиться
$xls->Workbooks->Add();
$range=$xls->Range("A1");            // Выбрали ячейку A1
$range->Value = "Что-то записываем";      // Вставили значение

// Сохраняем документ
$xls->Workbooks[1]->SaveAs("test.xls");

$xls->Quit();                        //Закрываем приложение
$xls->Release();                     //Высвобождаем объекты
$xls = Null;
$range = Null;
?>
Получено с http://spravkaweb.local/index.php/php/sovet/excelcom/open
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 13:57, 26 марта 2007.
  • К этой странице обращались 21 раз.
1.12871789932


Советы по PHP : Из PHP в Excel: работа с COM-объектами : Работа со строками — Справочник Web-языков

Советы по PHP : Из PHP в Excel: работа с COM-объектами : Работа со строками

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Формат ячеек: Шрифт
Главная | ::. | PHP | ::. | Советы по PHP | ::. | Из PHP в Excel: работа с COM-объектами | ::. | Работа со строками
 |  |  |  |  |  |  |  | Работа с колонками

Содержание

  • 1 Общие возможности
  • 2 Добавление строки
  • 3 Удаление строки
  • 4 Задание высоты строки
  • 5 Автоподбор высоты строк
  • 6 Скрытие/отображение строк

[править] Общие возможности

В Excel при помощи PHP можно произвести следующие действия со строками:

  • добавить строку;
  • удалить строку;
  • задать высоту одной строки или группы строк;
  • сделать автоподбор высоты одной строки или группы строк;
  • скрыть строку или группу строк;
  • отобразить ранее скрытую строку или группу строк.

[править] Добавление строки

Добавить строку можно при помощи метода Insert() объекта EntireRow():

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

// Вставляем в 1-ую, 2-ую и 3-ю верхние ячейки значения
$range=$xls->Range("A1");            // Выбрали ячейку A1
$range->Value = "1-ая строка";       // Вставили значение
$range=$xls->Range("A2");            // Выбрали ячейку A2
$range->Value = "2-ая строка;       // Вставили значение
$range=$xls->Range("A3");            // Выбрали ячейку A3
$range->Value = "3-ая строка";       // Вставили значение

// Вставляем строку
$range=$xls->Range("2:2");           // Определяем место
$range->EntireRow->Insert();         // Вставляем строку
?>

[править] Удаление строки

Удаление строки производится при помощи метода Delete() объекта EntireRow():

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

// Вставляем в 1-ую, 2-ую и 3-ю верхние ячейки значения
$range=$xls->Range("A1");            // Выбрали ячейку A1
$range->Value = "1-ая строка";       // Вставили значение
$range=$xls->Range("A2");            // Выбрали ячейку A2
$range->Value = "2-ая строка";       // Вставили значение
$range=$xls->Range("A3");            // Выбрали ячейку A3
$range->Value = "3-ая строка";       // Вставили значение

// Удаляем строку
$range=$xls->Range("2:2");           // Определяем строку
$range->EntireRow->Delete();         // Удаляем ее
?>

[править] Задание высоты строки

Задать высоту строки можно при помощи свойства RowHeight. Высота задается в миллиметрах.

В следующем примере для строки "2:2" задается высота 25 мм:

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

// Изменение высоты строки
$range=$xls->Range("2:2");           // Выбираем 2-ю строку
$range->Select();                    // Выделяем ее
$rowRange=$xls->Selection;           // Определяем $rowRange как выделенный фрагмент
$rowRange->RowHeight = 25;           // Устанавливаем высоту строки
?>

По аналогии можно задать высоту для нескольких строк:

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

// Изменение высоты строки
$range=$xls->Range("2:7");           // Выбираем строки со 2-ой по 7-ю
$range->Select();                    // Выделяем их
$rowRange=$xls->Selection;           // Определяем $rowRange как выделенный фрагмент
$rowRange->RowHeight = 25;           // Устанавливаем высоту строк
?>

[править] Автоподбор высоты строк

Автоподбор высоты строк используется для лучшей читабельности отображенных данных. Т.е. если размер шрифта текста, размещенного в строках, намного меньше высоты строки, или намного больше высоты, то такой текст читать не очень приятно.

Для автоподбора используется метод AutoFit() объекта Rows:

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

$range=$xls->Range("B1");            // Задаем 1-ую ячейку
$range->Font->Size = 20;             // Задаем размер шрифта
// Выводим в 1-ую выбранную ячейку значение
$range->Value = "Справочник Web-языков: www.spravkaweb.ru";

$range=$xls->Range("B2");            // Задаем 2-ую ячейку
$range->Font->Size = 20;             // Задаем размер шрифта
// Выводим во 2-ую выбранную ячейку значение
$range->Value = "Справочник Web-языков: www.spravkaweb.ru";

$range=$xls->Range("1:2");            // Задаем для работы 2 строки
$range->Select();                     // Выделяем эти строки
$rangeRows=$xls->Selection();         // Задаем $rangeRows как выделенный фрагмент
$rangeRows->RowHeight = 15;           // Устанавливаем высоту строки = 15 мм

$rowRange=$xls->Range("2:2");         // Выделяем 2-ю строку

$rowRange->Rows->AutoFit();           // Делаем автоподбор высоты
                                      // для третьей строки
?>

Т.е. у нас получилось следующее:

На первую и вторую строку мы записали текст Справочник Web-языков: www.spravkaweb.ru. Шрифт для текста задали 20. Затем установили высоту строк 15, и для второй строки сделали автоподбор высоты. В итоге первая строка отображается некорректно (верхняя часть букв не видна), а вторая нормально.

[править] Скрытие/отображение строк

За визуальное отображение строк отвечает свойство Hidden() объекта EntireRow().

Если присвоить этому свойству значение True, то выбранные строки будут скрыты, если False, то показаны.

Следующий пример скроет строки с 5-ой по 10-ую:

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

$range=$xls->Range("5:10");          // Выбираем строки с 5-ой по 10-ую

$range->EntireRow->Hidden = True;    // Скрыть выбранные строки
?>
Получено с http://spravkaweb.local/index.php/php/sovet/excelcom/rows
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:00, 26 марта 2007.
  • К этой странице обращались 17 раз.
0.816346883774


Советы по PHP : Из PHP в Excel: работа с COM-объектами : Рисование таблиц — Справочник Web-языков

Советы по PHP : Из PHP в Excel: работа с COM-объектами : Рисование таблиц

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Добавление / Удаление / Переименование листов
Главная | ::. | PHP | ::. | Советы по PHP | ::. | Из PHP в Excel: работа с COM-объектами | ::. | Рисование таблиц
 |  |  |  |  |  |  |  | Копирование / вставка ячеек

[править] Общие возможности

В Excel при помощи PHP можно делать следующие операции с таблицами:

  • задать толщину и стиль линий бордюра таблицы;
  • задать толщину и стиль линий внутренней сетки таблицы;
  • установить цвет бордюра и внутренней сетки таблицы;

[править] Работа с таблицей

Все свойства таблицы находятся в объекте Borders(). Вернее не в объекте, а в массиве объектов Borders[]. Каждый элемент этого массива отвечает за определенную часть таблицы (верхняя граница таблицы, нижняя, внутренние линии и т.д.). А уже у каждого элемента массива есть свои свойства, которые определяются только для данного объекта.

Таким образом если мы хотим нарисовать табличку с жирным внешним бордюром синего цвета и тонкими внутренними линиями красного цвета, то должны выполнить следующий код:

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

// Задаем область таблицы
$range=$xls->Range("B2:E10");
// Выделяем ее
$range->Select();
// Присваиваем переменной $range выделенный фрагмент
$range=$xls->Selection();

// Задаем свойства левой стенки таблицы
$rangeBordersLeft=$range->Borders("7");
$rangeBordersLeft->LineStyle = 1;
$rangeBordersLeft->Weight = 3;
$rangeBordersLeft->ColorIndex = 5;
// Задаем свойства верхней стенки таблицы
$rangeBordersTop=$range->Borders("8");
$rangeBordersTop->LineStyle = 1;
$rangeBordersTop->Weight = 3;
$rangeBordersTop->ColorIndex = 5;
// Задаем свойства нижней стенки таблицы
$rangeBordersBottom=$range->Borders("9");
$rangeBordersBottom->LineStyle = 1;
$rangeBordersBottom->Weight = 3;
$rangeBordersBottom->ColorIndex = 5;
// Задаем свойства правой стенки таблицы
$rangeBordersRight=$range->Borders("10");
$rangeBordersRight->LineStyle = 1;
$rangeBordersRight->Weight = 3;
$rangeBordersRight->ColorIndex = 5;
// Задаем свойства внутренних вертикальных линий
$rangeBordersVertical=$range->Borders("11");
$rangeBordersVertical->LineStyle = 1;
$rangeBordersVertical->Weight = 2;
$rangeBordersVertical->ColorIndex = 3;
// Задаем свойства внутренних горизонтальных линий
$rangeBordersHorizontal=$range->Borders("12");
$rangeBordersHorizontal->LineStyle = 1;
$rangeBordersHorizontal->Weight = 2;
$rangeBordersHorizontal->ColorIndex = 3;
?>

Т.е. сначало берется левая стенка таблицы

$rangeBordersLeft=$range->Borders("7");

Для нее задаются: тип линии (сплошная),

$rangeBordersLeft->LineStyle = 1;

толщина линии (жирная),

$rangeBordersLeft->Weight = 3;

цвет линии (синий)

$rangeBordersLeft->ColorIndex = 5;

Аналогично мы поступаем для правой, верхней, нижней стенок. Для внутренних вертикальных линий

$rangeBordersVertical=$range->Borders("11");

и внутренних горизонтальных линий

$rangeBordersHorizontal=$range->Borders("12");

задаем тип линий - сплошная, толщина линий - обычная, цвет линий - красный:

$rangeBordersVertical->LineStyle = 1;
$rangeBordersVertical->Weight = 2;
$rangeBordersVertical->ColorIndex = 3;

и

$rangeBordersHorizontal->LineStyle = 1;
$rangeBordersHorizontal->Weight = 2;
$rangeBordersHorizontal->ColorIndex = 3;

Свойство LineStyle() (тип линии) может принимать значения от 1 до 13, а свойство Weight (толщина) может принимать значения от 1 до 4.

Как будут выглядеть линии при различных значениях свойств LineStyle и Weight показано в следующей таблице:

LineStyle | Weight = 1 | Weight = 2 | Weight = 3 | Weight = 4
LineStyle = 1 |  |  |  |
LineStyle = 2 |  |  |  |
LineStyle = 3 |  |  |  |
LineStyle = 4 |  |  |  |
LineStyle = 5 |  |  |  |
LineStyle = 6 |  |  |  |
LineStyle = 7 |  |  |  |
LineStyle = 8 |  |  |  |
LineStyle = 9 |  |  |  |
LineStyle = 10 |  |  |  |
LineStyle = 11 |  |  |  |
LineStyle = 12 |  |  |  |
LineStyle = 13 |  |  |  |

Пример формирования такой таблички в Excel при помощи PHP:

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

// Задаем для всего диапазона: выравнивание по центру
//                             размер шрифта: 8
//                             ширина колонок: 12
$range=$xls->Range("A1:E14");
$range->HorizontalAlignment = 3;
$range->Font->Size = 8;
$range->ColumnWidth = 12;

// Формируем "шапку"
$range=$xls->Range("A1");
$range->Font->Bold = true;
$range->Value = "LineStyle";

$range=$xls->Range("B1");
$range->Font->Bold = true;
$range->Value = "Weight = 1";

$range=$xls->Range("C1");
$range->Font->Bold = true;
$range->Value = "Weight = 2";

$range=$xls->Range("D1");
$range->Font->Bold = true;
$range->Value = "Weight = 3";

$range=$xls->Range("E1");
$range->Font->Bold = true;
$range->Value = "Weight = 4";

// Для каждого столбца выводим нижний бордюр ячейки
// с соответствующими значениями свойств LineStyle и Width
for($i=1;$i<=13;$i++) {
  $range=$xls->Range("A".($i+1));
  $range->Value = "LineStyle = $i";
  $range=$xls->Range("B".($i+1));
  $rangeBordersRight=$range->Borders("9");
  $rangeBordersRight->LineStyle = $i;
  $rangeBordersRight->Weight = 1;
};

for($i=1;$i<=13;$i++) {
  $range=$xls->Range("C".($i+1));
  $rangeBordersRight=$range->Borders("9");
  $rangeBordersRight->LineStyle = $i;
  $rangeBordersRight->Weight = 2;
};

for($i=1;$i<=13;$i++) {
  $range=$xls->Range("D".($i+1));
  $rangeBordersRight=$range->Borders("9");
  $rangeBordersRight->LineStyle = $i;
  $rangeBordersRight->Weight = 3;
};

for($i=1;$i<=13;$i++) {
  $range=$xls->Range("E".($i+1));
  $rangeBordersRight=$range->Borders("9");
  $rangeBordersRight->LineStyle = $i;
  $rangeBordersRight->Weight = 4;
};

?>

Для закрепления материала рассмотрим как осуществить на PHP формирование границ таблицы на примере некоторых стандратных средств Excel.

Принцып действия:

Удаляет в выбранном диапазоне все границы, рамки и т.д.

Как реализовать:

Задаем для всех стенок и внутренних линий стиль отображения: отсутствуют (LineStyle = Null)

Код:

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

// Задаем область таблицы
$range=$xls->Range("B2:E10");
// Выделяем ее
$range->Select();
// Присваиваем переменной $range выделенный фрагмент
$range=$xls->Selection();

// Задаем свойства для всей таблицы
$rangeDiagonalDown=$range->Borders("5");
$rangeDiagonalDown->LineStyle = Null;
$rangeDiagonalUp=$range->Borders("6");
$rangeDiagonalUp->LineStyle = Null;
$rangeBordersLeft=$range->Borders("7");
$rangeBordersLeft->LineStyle = Null;
$rangeBordersTop=$range->Borders("8");
$rangeBordersTop->LineStyle = Null;
$rangeBordersBottom=$range->Borders("9");
$rangeBordersBottom->LineStyle = Null;
$rangeBordersRight=$range->Borders("10");
$rangeBordersRight->LineStyle = Null;
$rangeBordersVertical=$range->Borders("11");
$rangeBordersVertical->LineStyle = Null;
$rangeBordersHorizontal=$range->Borders("12");
$rangeBordersHorizontal->LineStyle = Null;

// ..... какие-то дальнейшие действия .....
?>
Принцып действия:

Рисует нижний бордюр выделенного фрагмента сплошной линией одинарной толщины.

Как реализовать:

Задаем для нижнего бордюра стиль линии: сплошная (LineStyle = 1), толщина: одинарная (Weight = 2)

Код:

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

// Задаем область таблицы
$range=$xls->Range("B2:E10");
// Выделяем ее
$range->Select();
// Присваиваем переменной $range выделенный фрагмент
$range=$xls->Selection();

// Задаем свойства для нижней стенки таблицы
$rangeBordersBottom=$range->Borders("9");
$rangeBordersBottom->LineStyle = 1;
$rangeBordersBottom->Weight = 2;

// ..... какие-то дальнейшие действия .....
?>
Принцип действия:

Рисует левый бордюр выделенного фрагмента сплошной линией одинарной толщины.

Как реализовать:

Задаем для левого бордюра стиль линии: сплошная (LineStyle = 1), толщина: одинарная (Weight = 2)

Код:

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

// Задаем область таблицы
$range=$xls->Range("B2:E10");
// Выделяем ее
$range->Select();
// Присваиваем переменной $range выделенный фрагмент
$range=$xls->Selection();

// Задаем свойства для левой стенки таблицы
$rangeBordersLeft=$range->Borders("7");
$rangeBordersLeft->LineStyle = 1;
$rangeBordersLeft->Weight = 2;

// ..... какие-то дальнейшие действия .....
?>
Принцип действия:

Рисует правый бордюр выделенного фрагмента сплошной линией одинарной толщины.

Как реализовать:

Задаем для правого бордюра стиль линии: сплошная (LineStyle = 1), толщина: одинарная (Weight = 2)

Код:

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

// Задаем область таблицы
$range=$xls->Range("B2:E10");
// Выделяем ее
$range->Select();
// Присваиваем переменной $range выделенный фрагмент
$range=$xls->Selection();

// Задаем свойства для правой стенки таблицы
$rangeBordersRight=$range->Borders("10");
$rangeBordersRight->LineStyle = 1;
$rangeBordersRight->Weight = 2;

// ..... какие-то дальнейшие действия .....
?>
Принцип действия:

Рисует нижний бордюр выделенного фрагмента сплошной двойной линией.

Как реализовать:

Задаем для нижнего бордюра стиль линии: двойная (LineStyle = 9), толщина: Weight = 4

Код:

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

// Задаем область таблицы
$range=$xls->Range("B2:E10");
// Выделяем ее
$range->Select();
// Присваиваем переменной $range выделенный фрагмент
$range=$xls->Selection();

// Задаем свойства для правой стенки таблицы
$rangeBordersRight=$range->Borders("10");
$rangeBordersRight->LineStyle = 9;
$rangeBordersRight->Weight = 4;

// ..... какие-то дальнейшие действия .....
?>
Принцип действия:

Рисует нижний бордюр выделенного фрагмента сплошной линией двойной толщины.

Как реализовать:

Задаем для нижнего бордюра стиль линии: одинарная (LineStyle = 1), толщина: Weight = 3

Код:

<?php
$xls = new COM("Excel.Application"); // Создаем новый COM-объект
$xls->Application->Visible = 1;      // Заставляем его отобразиться
$xls->Workbooks->Add();              // Добавляем новый документ

// Задаем область таблицы
$range=$xls->Range("B2:E10");
// Выделяем ее
$range->Select();
// Присваиваем переменной $range выделенный фрагмент
$range=$xls->Selection();

// Задаем свойства для правой стенки таблицы
$rangeBordersRight=$range->Borders("10");
$rangeBordersRight->LineStyle = 1;
$rangeBordersRight->Weight = 3;

// ..... какие-то дальнейшие действия .....
?>
Получено с http://spravkaweb.local/index.php/php/sovet/excelcom/table
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 15:46, 27 марта 2007.
  • К этой странице обращались 22 раза.
1.24319291115


Советы по PHP : Отправка писем при помощи PHP : Прикрепление файла — Справочник Web-языков

Советы по PHP : Отправка писем при помощи PHP : Прикрепление файла

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Пара вводных слов
Главная | ::. | PHP | ::. | Советы по PHP | ::. | Отправка писем при помощи PHP | ::. | Прикрепление файла
 |  |  |  |  |  |  |  | Как вставить в письмо картинку

[править] Отправка писем при помощи PHP: Прикрепление файла

Письмо, содержащее прикрепленный файл, несколько отличается от простого. В нем добавляются некоторые заголовки, и немного меняется само построение, хотя несомненно само письмо остается текстовым файлом. Но давайте все по порядку.

Одна из особенностей - наличие заголовка Mime-Version.

Этот заголовок указывает стандарт, которому соответствует тело сообщения.

Сообщения, соответствующие MIME обязаны содержать такое поле заголовка со следующим текстом:

MIME-Version: 1.0

Если мы хотим отослать письмо с прикрепленными файлами, то необходимо использовать заголовок

Content-type: multipart/mixed

который обозначает, что письмо состоит из нескольких частей, каждая из которых содержит свой заголовок Content-type.

Для обозначения границы этих частей необходимо использовать параметр boundary, который еще называется маркером границы.

Значением этого параметра может служить любая строка. Но надо учесть, что она должна быть уникальной и не встречалась в теле письма. Иначе письмо может быть неправильно разбито на части.

From: "Uspenskii Evgeny" <evgeny@spravkaweb.ru>
To: user@domain.ru
Subject: Hello
Mime-Version: 1.0
Content-Type: multipart/mixed; boundary="spravkaweb-12345"

При разделении письма на части перед маркером должны стоять два знака дефиса.

А последний маркер, который обозначает конец письма, должен содержать в конце два знака дефиса.

Для каждой части необходимо установить свои заголовки.

После заголовков необходимо поставить два знака перевода строки.

From: "Uspenskii Evgeny" <evgeny@spravkaweb.ru>
To: user@domain.ru
Subject: Hello
Mime-Version: 1.0
Content-Type: multipart/mixed; boundary="spravkaweb-12345"
--spravkaweb-1234
Content-type: text/plain; charset="windows-1251"
Content-Transfer-Encoding: quoted-printable

Hi!
Here's that my file!

--spravkaweb-1234
Content-Type: application/x-rar-compressed; name="file.rar"
Content-Transfer-Encoding:base64
Content-Disposition:attachment

UmFyIRoHAM+QcwAADQAAAAAAAABvYXQg ......
spravkaweb-1234--

Если у нас идет часть с текстом, то надо заголовок Content-Transfer-Encoding присвоить значение quoted-printable, либо 7bit, либо 8bit.

Для части с файлом этот заголовок должен быть равен base64.

Заголовок Content-Disposition, присутствующий во второй части, указывает, как почтовой программе следует отобразить данную часть письма. Он может принимать значение attachment (этот участок не является частью письма, а просто прикреплен к нему в виде файла) и inline (включение, которое используется непосредственно в письме, например, картинка, вставляемая в HTML).

В первой части заголовком

Content-type: text/plain; charset="windows-1251"

указали, что это простой текст с кодировкой Windows.

Во второй же части заголовком

Content-Type: application/x-rar-compressed; name="file.rar"

указали, что тип файла - rar-архив, а имя файла - file.rar.

Если отправляем gif-картинку, его Content-type будет выглядеть:

Content-Type: image/gif; name="file.gif"

В случае, если заранее не известно, какой тип файла отправляем, или формат файла не является стандартным, следует заголовку Content-type присвоить значение application/octet-stream.

Content-Type: application/octet-stream; name="file.dat"

Прикрепленные файлы должны быть размещены в письме в формате base64. Преобразовать файл в этот формат можно при помощи PHP-функции base64_encode():

// Открываем файл для чтения в бинарном формате
$file=fopen("file.zip", "rb");
// Считываем его в строку $str_file
$str_file=fread($file,filesize("file.zip"));
// Преобразуем эту строку в base64-формат
$str_file=base64_encode($str_file);

Теперь переменную $str_file, которая содержит файл, можно вставлять в письмо.

Для окончательного закрепления материала напишем функцию, которая отправляет письмо в HTML-формате по указанному адресату с прикрепленным файлом:

/*
$to - адрес получателя письма
$from_mail - адрес отправителя письма
$from_name - имя отправителя письма
$subject - тема письма
$message - само сообщение в HTML-формате
$file_name - путь к файлу, который надо прикрепить к письму
(это может быть имя файла, выбранного в поле <input type=file name=file_name>)
*/
function sendMail($to,$from_mail,$from_name,$subject,$message,$file_name) {
  $bound="spravkaweb-1234";
  $header="From: "$from_name" <$from_mail>n";
  $header.="To: $ton";
  $header.="Subject: $subjectn";
  $header.="Mime-Version: 1.0n";
  $header.="Content-Type: multipart/mixed; boundary="$bound"";
  $body="nn--$boundn";
  $body.="Content-type: text/html; charset="windows-1251"n";
  $body.="Content-Transfer-Encoding: quoted-printablenn";
  $body.="$message";
  $file=fopen($file_name,"rb");
  $body.="nn--$boundn";
  $body.="Content-Type: application/octet-stream;";
  $body.="name="".basename($file_name).""n";
  $body.="Content-Transfer-Encoding:base64n";
  $body.="Content-Disposition:attachmentnn";
  $body.=base64_encode(fread($file,filesize($file_name)))."n";
  $body.="$bound--nn";
  if(mail($to, $subject, $body, $header)) {
    echo "<center>Письмо было успешно отправлено!</center>";
  } else {
    echo "<center>Сообщение не отправлено!</center>";
  };
};
Получено с http://spravkaweb.local/index.php/php/sovet/mail/file
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 06:43, 25 марта 2007.
  • К этой странице обращались 44 раза.
1.22845005989


Советы по PHP : Отправка писем при помощи PHP : Как вставить в письмо картинку — Справочник Web-языков

Советы по PHP : Отправка писем при помощи PHP : Как вставить в письмо картинку

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
 |  |  |  |  |  |  |  | Прикрепление файла
Главная | ::. | PHP | ::. | Советы по PHP | ::. | Отправка писем при помощи PHP | ::. | Как вставить в письмо картинку
 |  |  |  |  |  |  |  | Из PHP в Excel: работа с COM-объектами

[править] Отправка писем при помощи PHP: Как вставить в письмо картинку

Допустим, у нас задача - вставить в письмо, отправляемое с сайта пользователю, свой баннер (кнопку).

Сделать это можно двумя способами:

  • Первый - в HTML-коде письма указываем адрес картинки как на простой страничке <IMG src="http://spravkaweb.ru/img/88x31.gif">

В этом случае, если пользователь читает ваше письмо online, картинка благополучно загрузится с указанного сервера и отобразится в письме. Но если пользователь не в online, картинка загрузиться не сможет.

  • Второй способ - это поместить картинку в само письмо как прикрепленный файл (более подробно о прикреплениb файлов к письму читайте здесь), присвоить этому файлу уникальный идентификатор, а затем в теле письма при указании адреса картинки сослаться на этот идентификатор.

Таким образом, в письмо можно вставлять не только изображения, но и flash-ролики, музыку, элементы ActiveX.

Конечно, при этом размер письма увеличится, но зато мы будем уверены, что пользователь точно увидит выставляемую картинку (если конечно в его почтовой программе не отключено отображение изображений).

Чтобы присвоить идентификатор картинке, надо в разделе письма, где она располагается, поместить следующий заголовок:

Content-ID: <идентификатор>

где идентификатор является строкой, которая будет уникальной для данного письма (по примеру параметра boundary заголовка Content-Type).

Теперь в самом письме можно в адресе картинки подставлять ее идентификатор.

<IMG src="cid:идентификатор">

Почтовая программа проанализирует его, извлечет из соответствующей секции картинку и покажет ее.

Вот как может выглядеть письмо:

Date: Sat, 13 Mar 2004 09:56:31 -0300
Subject: Отправка изображения
From: "Evgen" <admin@spravkaweb.ru>
To: admin@localhost.ru
Subject: Отправка изображения
Mime-Version: 1.0
Content-Type: multipart/alternative; boundary="spravkaweb-1234"

--spravkaweb-1234
Content-type: text/html; charset="windows-1251"
Content-Transfer-Encoding: 8bit

<h3>Привет</h3>
Это проба отправки письма с прикрепленной картинкой.<BR>
А вот и сама картинка:<BR>
<img src="cid:spravkaweb_img_1">

--spravkaweb-1234
Content-Type: image/jpeg; name="5.jpg"
Content-Transfer-Encoding:base64
Content-ID: <spravkaweb_img_1>

/9j/4AAQSkZJRgABAQAAAQABAAD/2wBD ....
--spravkaweb-1234--

Как и в случае с прикрепляемыми файлами, если нам заранее неизвестно, какой тип картинки будет прикреплен, заголовку Content-Type можно присвоить значение application/octet-stream.

Для закрепления этой темы напишем программу, которая отправляет письмо с картинкой:

<?php
/*
Зададим в переменной $file_name путь до вставляемой картинки.
В нашем случае она находится в том же каталоге, что и
файл отправки письма. Но вместо этого сюда можно подставить
файл, полученный сценарием из <INPUT type=file name=file_name>.
*/
$file_name="5.jpg";
$subj="Отправка изображения";
$bound="spravkaweb-1234";
$headers="From: "Evgen" <admin@spravkaweb.ru>n";
$headers.="To: admin@localhost.run";
$headers.="Subject: $subjn";
$headers.="Mime-Version: 1.0n";
$headers.="Content-Type: multipart/alternative; boundary="$bound"n";
$body="--$boundn";
$body.="Content-type: text/html; charset="windows-1251"n";
$body.="Content-Transfer-Encoding: 8bitnn";
$body.="<h3>Привет</h3>
Это проба отправки письма с прикрепленной картинкой.<BR>
А вот и сама картинка:<BR>
<img src="cid:spravkaweb_img_1">";
$body.="nn--$boundn";
$body.="Content-Type: image/jpeg; name="".basename($file_name).""n";
$body.="Content-Transfer-Encoding:base64n";
$body.="Content-ID: <spravkaweb_img_1>nn";
$f=fopen($file_name,"rb");
$body.=base64_encode(fread($f,filesize($file_name)))."n";
$body.="--$bound--nn";
mail("admin@localhost.ru", $subj, $body, $headers);
?>

Хочу отметить, что аналогичным образом в письмо можно вставлять не только картинки, но, например, flash-ролики, звук, и другие элементы, которые должны погружаться к странице из файлов.

Получено с http://spravkaweb.local/index.php/php/sovet/mail/image
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 14:11, 18 марта 2007.
  • К этой странице обращались 46 раз.
1.32684397697


Программное обеспечение — Справочник Web-языков

Программное обеспечение

Главная ::. Программное обеспечение
Этот раздел находится на стадии разработки!

Содержание

  • 1 Для разработчкика
  • 2 Для дизайнера
  • 3 Для администратора
  • 4 Сравнение

[править] Для разработчкика

  • Продукция от Zend.com
    • ZendStudio
    • ZendServer

[править] Для дизайнера

  • Продукция от Adobe.com
    • Flash
    • Photoshop

[править] Для администратора

  • Apache - Web-cервер
  • MySQL - DB-cервер
  • Postgres - DB-cервер

[править] Сравнение

  • Бесплатные аналоги платных программ - SOHO-сегмент
Получено с http://spravkaweb.local/index.php/po
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 10:59, 31 марта 2007.
  • К этой странице обращались 23 раза.
1.62815999985


Программное обеспечение : Бесплатные аналоги платных программ : SOHO-сегмент — Справочник Web-языков

Программное обеспечение : Бесплатные аналоги платных программ : SOHO-сегмент

Материал из Справочник Web-языков.

Перейти к: навигация, поиск
Этот раздел находится на стадии разработки!

Здесь собраны аналоги платных программ для небольшого офиса (SOHO-сегмент). В свете последних изменений в обстановке с проверками лицензий может быть весьма актуально не платить кучу денег за программы, у которых есть бесплатные аналоги.

В этой таблице предпочтение отдается OpenSorce-программам, т.к. в них никогда не будет написано в лицензионном соглашении мелким шрифтом "только для домашнего и некоммерческого использования".По этой причине freeware-программы, в лицензиях которых были малейшие намеки по ограничениям области использования включены не были. Также, при наличии нормальных OpenSource аналогов freeware программы не рассматриваются.

При создании данного документа не ставилась цель охватить 100% всего ПО, существующего под Windows, задача была охватить 80-90% потребностей среднего офиса. Поэтому, если вы чего-то не нашли, воспользуйтесь ссылками в конце статьи.

[править] Для администратора

Тип программ | Платные | OpenSource | Freeware
Антивирусы | DrWeb, KAV etc. | ClamWin проверяет только файлы и процессы) | Comodo AntiVirus
Восстановление данных | EasyRecovery | TestDisk
Шифрование данных | ??? | AxCrypt, TrueCrypt
Почтовый сервер | Mdaemon, KMS | XMail, hMailServer
Снифер | SnifferPro | Wireshark (бывш. Ethereal)
FTP-сервер | IIS | Filezilla
HTTP-сервер | IIS | Apache, Savant, MyServer
Удаленное управление | Remote Admin | UltraVNC, TightVNC, MetaVNC
Восстановление системы | пиратские диски типа "Reanimator" | SystemRescueCd
Клонирование дисков | Norton Ghost | Ghost for Unix (G4U), Partition Logic
Управление разделами | Norton Partition Magic | GParted, Partition Logic
Подключение к ssh-серверам | Private Shell, | PuTTY, WinSCP
Безопасное удаление данных | ??? | Eraser
Firewall | Kerio | WIPFW | Comodo Firewall
proxy-сервера | UserGate | DeleGate, Privoxy, Squid for Windows, 3proxy
Инвентаризация ПО и АО | ??? | OCS Inventory NG
Дефрагментирование дисков | Nortom SpeedDisk | JkDefrag (использует WinAPI, имеет консольную и GUI версию, больше настроек и скорость чем у штатной программы)
Bugtracking/helpdesk | ??? | Mantis
Backup | Veritas | Bacula

[править] Для пользователя

Тип программ | Платные | OpenSource | Freeware
Архиваторы | Winrar, WinZip | 7Zip | TUGZip
Запись CD/DVD | Nero | Infra Recorder | Deepburner, AVS Disc Creator, SCDWriter, CDBurnerXP Pro
Файл-менеджеры | Total Commander | freeCommander, File Navigator
Видеоплейеры | PowerDVD | VLC, Media Player Classic | AVS DVD Player
Аудиоплейер | WinAMP | VLC, Songbird, Zinf, wxMusik | Apollo, Quintessential Player, foobar2000, XMPlay
Аудиоредактор | SondForge | Audacity
Конвертация CD-DA в mp3 | Audiograber | CDex, X-Tractor
Просмотр картинок | ACDSee | Cornice | Commander (просмотр и управление картинками), PhotoView
FTP-клиент | SmartFTP | Filezilla
Офисный пакет | MS Office | OpenOffice.org (русская сборка), AbiWord (текстовый редактор), Gnumeric (электронные таблицы)
Создание web-страниц | HomeSite | Nvu, KompoZer, Amaya (редактор и браузер от W3C)
Растровый редактор | Photoshop, ACDSee | Gimp, Tux Paint (простой редактор для детей) | Picasa
Кодеки | DivX | ffdshow, Real Alternative, QuickTime Alternative, Xvid
Бухучет | 1С | Ананас, Дебет Плюс
Конвертация DVD в avi | различные DVD Ripper'ы | Auto Gordian Knot
Почтовый клиент | The Bat | Mozilla Thunderbird, Blat (консольная отправка почты), Sylpheed
Словарь | Lingvo, Сократ | StarDict
IM-клиенты | ICQ, MSN | Miranda, SIM, Gaim
CAD | AutoCAD, P-CAD | BRL-CAD, TinyCAD, Kicad, OCTREE, gCAD3D, QCad(существуют платная и OpenSource-версии)
Организация работы | Microsoft Project, Outlook | Open Workbench, GanttProject, Evolution (имеется коннектор для Exchange), Mozilla Calendar Project
3D-моделирование | 3D Max, Maya | Wings 3D, Blender, OpenFX , K-3D
Download-менеджер | ReGet | wxDownload Fast, TrueDownloader, WinWGet | Orbit, Free Download Manager
Векторная графика | CorelDraw | Inkscape, OpenOffice Draw
Верстка | PageMaker | Scribus
Работа с pdf | ??? | PDFCreator, http://sourceforge.net/projects/qvpdf qvPDF]
Создание диаграмм | Visio | Dia

Таблица создана на основе "Аналоги бесплатных программ для Windows"

Получено с http://spravkaweb.local/index.php/po/survey/payware_equivalent/soho
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Rambler's Top100 Powered by MediaWiki
  • Последнее изменение этой страницы: 19:59, 30 марта 2007.
  • К этой странице обращались 51 раз.
1.39613986015


Справочник по SSI : Базовые директивы — Справочник Web-языков

Справочник по SSI : Базовые директивы

Главная | ::. | SSI | ::. | Базовые директивы
 |  |  |  | Переменные включения

Содержание

  • 1 config
  • 2 echo
  • 3 fsize
  • 4 flastmod
  • 5 include
  • 6 printenv
  • 7 set
  • 8 if, elif, else, endif

[править] config

Контролирует различные аспекты сканирования.

Атрибуты:

errmsg
- устанавливает сообщение, выводящееся при возникновении ошибки; в большинстве случаев целесообразно установить в пустую строку;
sizefmt
- устанавливает формат, в котором будет выводиться размер файла. Формат соответствует передаваемому библиотечной функции strftime;
timefmt
- устанавливает формат, в котором будет выводиться дата.

[править] echo

Выводит значение установленной переменной SSI.

Допустимым атрибутом является var.

[править] fsize

Выводит размер файла в определенном с помощью sizefmt формате.

Атрибуты:

file
- определяет путь к файлу, относительно сканируемого документа;
virtual
- определяет стандартный кодированный URL, относительно сканируемого документа, или, при наличии в начале слеша (/) - относительно корня документов узла.

[править] flastmod

Выводит дату последней модификации файла в определенном с помощью timefmt формате.

Атрибуты:

file
- определяет путь к файлу, относительно сканируемого документа;
virtual
- определяет стандартный кодированный URL, относительно сканируемого документа, или, при наличии в начале слеша (/) - относительно корня документов узла.

[править] include

Включает текст другого документа или файла в сканируемый файл.

К включаемому файлу применяются все установленные правила ограничения доступа. Если для каталога, из которого включается файл, установлена опция IncludesNOEXEC, и включение данного документа привело бы к запуску программы, то документ не включается, и выводится сообщение об ошибке. CGI сценарии вызываются, как обычно с помощью URL, который может содержать кодированную строку запроса (query string).

Атрибуты:

file
- указывает путь, относительно сканируемого документа; путь не может содержать ../ и не может быть абсолютным путем; всегда предпочтительнее использовать атрибут virtual;
virtual
- содержит кодированный URL, относительный или абсолютный; URL не может содержать имя протокола или имя хоста, и может содержать строку запроса.

[править] printenv

Выводит содержимое переменных окружения.

Вызывается без параметров.

[править] set

Устанавливает значение переменной.

Ее атрибутами являются var, определяющий имя переменной, и value, определяющий ее значение.

Пример:

<!--#set var="pic" value="picture.gif" -->

[править] if, elif, else, endif

Условные операторы.

Синтаксис:

<!--#if expr="условие" -->
<!--#elif expr="условие" -->
<!--#else -->
<!--#endif -->
elif,else
- необязательные атрибуты
endif
- заканчивает
if
- обязательный
Получено с http://spravkaweb.local/index.php/ssi/base
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 10:46, 28 февраля 2007.
  • К этой странице обращались 108 раз.
1.81590080261


Справочник по SSI : Переменные включения — Справочник Web-языков

Справочник по SSI : Переменные включения

 |  |  |  | Базовые директивы
Главная | ::. | SSI | ::. | Переменные включения
 |  |  |  | Подстановка переменных

В дополнение к стандартным окружения CGI, модуль SSI делает доступными для директив и условий, а также для вызываемых через SSI сценариев следующие переменные:

  • DATE_GMT - текущее время по Гринвичу;
  • DATE_LOCAL - текущее локальное (для сервера) время;
  • DOCUMENT_NAME - имя файла (без каталогов) документа, запрошенного пользователем;
  • DOCUMENT_URI - декодированный URL запрошенного пользователем документа;
  • LAST_MODIFIED - дата последней модификации документа, запрошенного пользователем. То есть во вложенном SSI эта переменная будет содержать имя "главного" документа, а не вложенного.
Получено с http://spravkaweb.local/index.php/ssi/include
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 10:15, 1 марта 2007.
  • К этой странице обращались 93 раза.
1.57850289345


Справочник по SSI — Справочник Web-языков

Справочник по SSI

Главная ::. SSI

[править] Разделы справки

  • Базовые директивы
  • Переменные включения
  • Подстановка переменных
Получено с http://spravkaweb.local/index.php/ssi
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 10:40, 28 февраля 2007.
  • К этой странице обращались 184 раза.
1.47889304161


Справочник по SSI : Подстановка переменных — Справочник Web-языков

Справочник по SSI : Подстановка переменных

 |  |  |  | Переменные включения
Главная | ::. | SSI | ::. | Подстановка переменных

Подстановка переменных производится внутри заключенных в кавычки строк в большинстве аргументов SSI директив. В этих случаях знак доллара можно вставить, предварив его слешом:

<!--#if expr="$a = /$test" -->

Для предотвращения двусмысленности можно заключать имя переменной в фигурные скобки:

<!--#set var="Zed" value="${a}bc_${abc}" -->

В результате такого присвоения переменная Zed будет иметь значение "Xbc_Y", если переменная a равна X, а переменная abc равна Y.

Получено с http://spravkaweb.local/index.php/ssi/set
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 10:17, 1 марта 2007.
  • К этой странице обращались 92 раза.
1.32217001915


Справочник по VBScript : Общие сведения — Справочник Web-языков

Справочник по VBScript : Общие сведения

Главная | ::. | VBScript | ::. | Общие сведения
 |  |  |  | Текстовые функции

Содержание

  • 1 cint
  • 2 set
  • 3 erase
  • 4 randomize
  • 5 alert
  • 6 sub
  • 7 status
  • 8 Abs(число)
  • 9 Asc(символ)
  • 10 Chr(число)
  • 11 Fix(число)
  • 12 Int(число)
  • 13 Hex(число)
  • 14 Oct(число)
  • 15 Sgn(число)
  • 16 Date
  • 17 Day(выражение)
  • 18 Time
  • 19 Timer
  • 20 Now
  • 21 Hour(выражение)
  • 22 Minute(выражение)
  • 23 Month(выражение)
  • 24 Second(выражение)
  • 25 Year(выражение)
  • 26 Weekday(выражение)
  • 27 Atn(число)
  • 28 Tan(число)
  • 29 Cos(число)
  • 30 Sin(число)
  • 31 Exp(число)
  • 32 Log(число)
  • 33 Sqr(число)
  • 34 Rnd(число)

[править] cint

Преобразование переменной в целочисленный тип

v=cint(v)

[править] set

Писваивание переменной значение ссылки на объект

set переменная=объект
set a=document.forma1

[править] erase

Очистка содержимого массива

Erase имя_массива
Erase v

[править] randomize

Включает генератор случайных чисел

randomize

[править] alert

Вывод сообщения в отдельном окне

alert "Ваше сообщение"

[править] sub

Определение подпрограмм

sub name_событие .... end sub
  • name - имя процедуры(например, имя нажимаемой кнопки)
  • событие - то, что может случиться в окне браузера

[править] status

Вывод сообщений в строку статуса

status="Мой текст"

[править] Abs(число)

Абсолютное значение числа

a=Abs(-5.67) ...... a=5.67

[править] Asc(символ)

ANSI код символа

a=Asc("s") ...... a=115

[править] Chr(число)

Символ, соответствующий коду

a=Chr(115) ...... a="s"

[править] Fix(число)

Целое число, округление в уменьшение

a=Fix(-2.5) ...... a=-2

[править] Int(число)

Целое число, округление в увеличение

a=Int(-2.5) ...... a=-3

[править] Hex(число)

Шестнадцатиричное представление

a=Hex(543) ...... a="21F"

[править] Oct(число)

Восьмеричное представление

a=Oct(543) ...... a="1037"

[править] Sgn(число)

Знак числа

a=Sgn(-4) ...... a=-1

[править] Date

Текущая дата

a=Date

[править] Day(выражение)

День

a=Day(Date)

[править] Time

Время

a=Time

[править] Timer

Количество секунд, истекших после полуночи

a=Timer

[править] Now

Дата и время

a=Now

[править] Hour(выражение)

Час

a=Hour(Now)

[править] Minute(выражение)

Минута

a=Minute(Now)

[править] Month(выражение)

Месяц

a=Month(Now)

[править] Second(выражение)

Секунда

a=Second(Now)

[править] Year(выражение)

Год

a=Year(Now)

[править] Weekday(выражение)

День недели(воск=1)

a=Weekday(Now)

[править] Atn(число)

Артангенс числа

a=Atn(0.37)

[править] Tan(число)

Тангенс

a=Tan(0.37)

[править] Cos(число)

Косинус

a=Cos(0.37)

[править] Sin(число)

Синус

a=Sin(0.37)

[править] Exp(число)

Экспонента

a=Exp(0.37)

[править] Log(число)

Логарифм

a=Log(0.37)

[править] Sqr(число)

Квадратный корень

a=Sqr(0.37)

[править] Rnd(число)

Случайное число 0...1

a=Rnd(1)
Получено с http://spravkaweb.local/index.php/vbscript/about
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 10:06, 7 января 2007.
  • К этой странице обращались 136 раз.
16.3016450405


Справочник по VBScript : Объявление функций и процедур — Справочник Web-языков

Справочник по VBScript : Объявление функций и процедур

 |  |  |  | Ветвления и циклы
Главная | ::. | VBScript | ::. | Объявление функций и процедур
 |  |  |  | Прочее

Содержание

  • 1 Dim
  • 2 Sub
  • 3 Function
  • 4 Exit

[править] Dim

Объявление переменной

Dim переменная
Dim имя_массива(индексы)
Dim a
Dim v(10),z(10,20)

[править] Sub

Определение подпрограммы

Sub имя_событие
...
End sub
  • имя - имя процедуры(например, имя нажимаемой кнопки)
  • событие - то,что может случиться в окне браузера
Sub but_onclick
alert x
End sub

[править] Function

Функция

Function имя(параметры)
...
End function
Function(x,y)
x=x*y
End function

[править] Exit

Досрочный выход

Exit ...
Exit Do(For,Function,Sub)
Получено с http://spravkaweb.local/index.php/vbscript/function
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 16:07, 7 января 2007.
  • К этой странице обращались 119 раз.
10.3575699329


Справочник по VBScript — Справочник Web-языков

Справочник по VBScript

Главная ::. VBScript

[править] Разделы справки

  • Общие сведения
  • Текстовые функции
  • Ветвления и циклы
  • Объявление функций и процедур
  • Прочее
Получено с http://spravkaweb.local/index.php/vbscript
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 09:53, 7 января 2007.
  • К этой странице обращались 247 раз.
1.3243098259


Справочник по VBScript : Прочее — Справочник Web-языков

Справочник по VBScript : Прочее

 |  |  |  | Объявление функций и процедур
Главная | ::. | VBScript | ::. | Прочее

[править] Rem

Коментарии

Получено с http://spravkaweb.local/index.php/vbscript/othe
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 05:31, 20 марта 2007.
  • К этой странице обращались 127 раз.
7.79266786575


Справочник по VBScript : Текстовые функции — Справочник Web-языков

Справочник по VBScript : Текстовые функции

 |  |  |  | Общие сведения
Главная | ::. | VBScript | ::. | Текстовые функции
 |  |  |  | Ветвления и циклы

Содержание

  • 1 Instr()
  • 2 Lcase()
  • 3 Ucase()
  • 4 Left()
  • 5 Right()
  • 6 Len()
  • 7 Ltrim()
  • 8 Rtrim()
  • 9 Trim()
  • 10 Mid()
  • 11 Space()
  • 12 String()

[править] Instr()

Возвращает номер символа в строке, с которого начинается искомая подстрока

Instr(начало,строка,искомая подстрока)
a=Instr(1,mail,@)

[править] Lcase()

Преобразование символов строки в строчные буквы

Lcase(строка)
a=Lcase("ВаШе СлоВО")...
a="ваше слово"

[править] Ucase()

Преобразование символов строки в заглавные буквы

Ucase(строка)
a=Ucase("ВаША СтроКа")...
a="ВАША СТРОКА"

[править] Left()

Левая часть строки длиной N символов

Left(строка,N символов)
a=Left("Ваш текст",3)...
a="Ваш"

[править] Right()

Правая часть строки длиной N символов

Right(строка,N символов)
a=Right("Ваш текст",3)...
a="кст"

[править] Len()

Длина строки

Len(строка)
a=Len("Ваш текст")...
a=9

[править] Ltrim()

Удалает начальные пробелы

Ltrim(строка)
a=Ltrim(" Ваш текст ")...
a="Ваш текст "

[править] Rtrim()

Удалает конечные пробелы

Rtrim(строка)
a=Rtrim(" Ваш текст ")...
a=" Ваш текст"

[править] Trim()

Удалает начальные и конечные пробелы

Trim(строка)
a=Trim(" Ваш текст ")...
a="Ваш текст"

[править] Mid()

Часть строки с позиции "начало" и длиной N символов

Mid(строка,начало,N символов)
a=Mid("Ваш текст",4,2)...
a="те"

[править] Space()

Строка из N символов

Space(N)
a=Space(5)

[править] String()

String(N символов,символ)
a=String(5,"A")...
a="AAAAA"
Получено с http://spravkaweb.local/index.php/vbscript/text
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 10:51, 7 января 2007.
  • К этой странице обращались 139 раз.
15.2161099911


Справочник по VBScript : Ветвления и циклы — Справочник Web-языков

Справочник по VBScript : Ветвления и циклы

 |  |  |  | Текстовые функции
Главная | ::. | VBScript | ::. | Ветвления и циклы
 |  |  |  | Объявление функций и процедур

Содержание

  • 1 Call
  • 2 Do...Loop Until
  • 3 Do...Loop While
  • 4 Do Until ... Loop
  • 5 Do While ... Loop
  • 6 For
  • 7 If ... Then
  • 8 Select Case
  • 9 While

[править] Call

Вызов подпрограммы

Call имя_событие
Call but_onclick

[править] Do...Loop Until

Выполняет код хотябы один раз, пока условие не будет истинным

Do
...
Loop Until условие

Do
a=a+1
Loop Until a>=5

[править] Do...Loop While

Выполняет код хотябы один раз, пока условие справедливо

Do
...
Loop While условие
Do
a=a+1
Loop While a<5

[править] Do Until ... Loop

Повторяет выполнение кода, пока условие не станет истинным

Do Until условие
...
Loop
Do Until a>=5
a=a+1
Loop

[править] Do While ... Loop

Повторяет выполнение кода, пока условие справедливо

Do While условие
...
Loop
Do While a<5
a=a+1
Loop

[править] For

Цикл

For счетчик=начало To конец
Step шаг
...
next
For i=1 to 5
a=a+1
next

[править] If ... Then

Выполнение кода при выполнении условия

IF условие Then
действие1
Else
действие2
End if

IF a>1 Then alert "больше"

[править] Select Case

Выборочное выполнение кода при совпадениизначения

Select Case X
Case значение1
действие
Case значение 2
действие2
...
End select
Select Case X
Case 10
alert"x=10"
Case 20
alert"x=20"
End select

[править] While

Выполнение кода поку условие истинно

While условие
действие
Wend
While a<5
a=a+1
Wend
Получено с http://spravkaweb.local/index.php/vbscript/while
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 11:26, 7 января 2007.
  • К этой странице обращались 120 раз.
11.9455199242


Справочник по VRML : Цвет и текстура — Справочник Web-языков

Справочник по VRML : Цвет и текстура

 |  |  |  | Примитивы VRML
Главная | ::. | VRML | ::. | Цвет и текстура
 |  |  |  | Положение фигуры в пространстве

Содержание

  • 1 Material
  • 2 MaterialBinding
  • 3 Texture2
  • 4 Texture2Transform
  • 5 TextureCoordinate2
  • 6 Transform
  • 7 DirectionalLight
  • 8 FontStyle
  • 9 MatrixTransform
  • 10 OrthographicCamera
  • 11 PerspectiveCamera
  • 12 PointLight
  • 13 ShapeHints
  • 14 SpotLight

[править] Material

Используется для того, чтобы определить свойства материала поверхностей текущей формы и форм, которые она содержит. Используя этот узел с узлом MaterialBinding ( который обсуждается дальше ), можно придать объектам сцены различный вид.

Пример:

Material {
    ambientColor 0.2 0.2 0.2
    diffuseColor 0.7 0.7 0.7
    specularColor 0 0 0
    shininess 0.2
    emissiveColor 0 0 0
    transparency 0
    }
ambientColor,diffuseColor,specularColor
- Управляют цветами и указываются в палитре RGB(красный, зеленый, синий)
shininess и transparency
- Определяет степень прозрачности, и может принимать значения от 0 (не прозрачный) до 1 (прозрачный).Для того, чтобы объект выглядел очень ярким, установите поле shininess равным 1. Чтобы сделать объект прозрачным, установите значение поля transparensy равным 1.

Узел Material определяет то, как выглядит материал. Необходимо отметить, что различные формы интерпретируют материал по-разному. Для того, чтобы связать материалы с образами, формами, документы VRML используют узел MaterialBinding.

[править] MaterialBinding

Документы VRML используют этот узел для того, чтобы определить, каким образом именно броузер должен связать текущие материалы с формами рамках графа сцены.

Пример:

MaterailBinding {
    value DEFAULT # SFEnum
    }
value
- Описывает, как узел MaterialBinding связывает материал с объектом, его частями, гранями, вершинами.
Значения:
  • DEFAULT - броузер использует связывание по умолчанию
  • OVERALL - броузер использует то самое связывание ко всему объекту
  • PER_FACE - броузер использует указанный материал к каждой грани объекта
  • PER_FACE_INDEXED - броузер использует указанный материал к каждой грани объекта, основываясь на значениях индекса материала
  • PER_PART - броузер использует указанный материал к каждой части объекта
  • PER_PART_INDEXED - броузер использует указанный материал к каждой части объекта, основываясь на значениях индекса материала
  • PER_VERTEX - броузер использует указанный материал для каждой вершины объекта
  • PER_VERTEX_INDEXED - броузер использует указанный материал для каждой вершины объекта, основываясь на индексе материала

Заметьте, что броузер может интерпретировать связывание материала для каждого узла, для каждой вершины, формы различным образом. Текущий материал всегда имеет базовое значение, которое определено первым значением всех полей материалов. Поскольку поля материалов могут иметь различные значения, узел MaterialBinding определяет, каким способом броузер применяет, т.е. связывает материалы в пределах формы. Когда броузер должен связать набор материалов с объектом, он циклически просматривает значения материалов от начала до конца.

[править] Texture2

Имитирование различных поверхностей.

Синтаксис:

Texture2 {
    filename "image.gif"
    image 0 0 0
    wrapS REPEAT
    wrapT REPEAT
    }

В качестве текстуры лучше всего указывать графический файл. Тогда для "натягивания" изображения на объект достаточно только указать путь к файлу в параметре filename.

wrapS,wrapT
- управляют натягивание текстуры на объект по соответственно горизонтально и вертикальной осям.
Возможные значения:
  • wrapS, wrapT
  • REPEAT
  • CLAMP

[править] Texture2Transform

Используется для того, чтобы определить двумерное преобразование, которое броузер применяет к координатам текстуры. Узел воздействует на способ, которым броузер накладывает текстуры на поверхность форм.

Пример:

Texture2Transform {
    center 0 0 # SFVec2f
    rotation 0 # SFFloat
    scaleFactor 1 1 # SFVec2f
    translation 0 0 # SFVec2f
    }
translation
- Определяет неоднородное масштабирование относительно произвольной точки, взятой в качестве центра.
rotation
- Задает вращение вокруг той же самой точки.

Вместе эти поля определяют двумерное преобразование, которое броузер применяет к текстурам.

[править] TextureCoordinate2

Используется для того, чтобы определить набор двумерных координат, которые броузер использует для того, чтобы отобразить текстуры на вершины объектов PointSet, IndexedLineSet, IndexedFaceSet. Используя рассматриваемый узел, документы VRML заменяют текущие координаты текстуры.

Пример:

TextureCoordinate2 {
    point 0 0 # MFVec2f
    }
point
- Задает отображение пар координат ( состоящих из двух чисел в диапазоне от 0 до 1 ), которые устанавливают соответствие специфических точек и текстуры на соответствующем индексном множестве. Величина 0 служит началом отсчета на оси, а величина 1 есть наиболее удаленная точка текстуры вдоль оси. Сначала задают горизонтальную координату, а затем вертикальную.

[править] Transform

Используется для того, чтобы определить геометрическое трехмерное преобразование, состоящее из неоднородного масштабирования относительно произвольной точки, вращения относительно произвольной точки и оси, а также переноса.

Пример:

Transform {
    center 0 0 0 # SFVec3f
    rotation 0 0 1 0 # SFRotation
    scaleFactor 1 1 1 # SFVec3f
    scaleOrientation 0 0 1 0 # SFRotation
    translation 0 0 0 # SFVec3f
    }
center
- Определяет начало отсчета для выполнения преобразования.
rotation
- Определяет угол, на который броузер вращает объект - на манер, сходный с узлом Rotation.
scaleFactor
- Определяет, как броузер изменяет размер объекта подобно тому, как это выполняется узлом Scale.
scaleOrientation
- Определяет ориентацию для поля scaleFactor, что позволяет броузеру выполнить неоднородное масштабирование.
translation
- Определяет, как броузер двигает объект.

Рассматриваемый узел может содержать один или более следующих узлов: Rotation, Scale, Translation.

[править] DirectionalLight

Используется для того, чтобы определить источники направленного света, которые освещают объекты лучами, идущими параллельно заданному трехмерному вектору на сцене графа VRML.

Пример:

DirectionalLight {
    color 1 1 1 # SFColor
    direction 0 0 -1 # SFVec3f
    intensity 1 # SFFloat
    on TRUE # SFBool
    }
color
- Определяет цветовые компоненты: красный, зеленый и синий. Величины значений поля изменяются в пределах от 0.0 до 1.0. Например, если значением поля служат величины 1 0 0, то цвет оказывается чисто красным. Аналогично, значение поля равное 0 1 0, отвечает зеленому цвету.
direction
- Описывает трехмерный вектор, который задает направление света. Направление световых лучей оказывается параллельным трехмерному вектору, определенному полем direction.
intensity
- (Интенсивность) изменяется в пределах от 0.0 до 1.0, причем значение 1.0 соответствует наивысшей интенсивности.
on
- Включает направленный источник света, когда поле принимает значение TRUE и выключает его, когда значение - FALSE.

Узел DirectionalLight определяет источник освещения, который может воздействовать на соответствующий узел простой геометрии графа сцены в соответствии с текущим стилем освещения. Броузер применяет текущее преобразование к источнику направленного освещения. Используя сепаратор, можно отключить действие узла на объекты, которые находятся вне сферы сепаратора.

[править] FontStyle

Используется для того, чтобы определить текущий стиль шрифтов, который будет использован узлами AsciiText. Броузер в свою очередь определяет спецификации шрифтов (исходные коды VRML не имеют элементов прямого управления атрибутами шрифтов).

Пример:

FontStyle {
    family SERIF # SFEnum
    size 10 # SFFloat
    style NONE # SFBitMask
    }
family
- Указывает на семейство шрифтов, такое как SERIF, SANS или TYPEWRITER.
size
- Определяет высоту шрифта.
style
- Служит для задания жирного шрифта или курсива. Оно может принимать значения соответственно NONE, BOLD, ITALIC.

[править] MatrixTransform

Используется для того, чтобы определить матрицу трехмерных геометрических преобразований. Трехмерные преобразования требуют матрицы размером 4х4.

Пример:

MatrixTransform {
    matrix 1 0 0 0 # SFMatrix
    0 1 0 0
    0 0 1 0
    0 0 0 1
    }

[править] OrthographicCamera

Используется для того, чтобы определить параллельное проектирование из точки обзора. Как вы, вероятно, знаете, используя камеры, дизайнеры могут управлять углом или перспективой, в которой пользователь видит сцену VRML. Ортографическая камера не уменьшает объектов в зависимости от расстояния , как это делает перспективная камера. При проектировании с ортографической камерой по мере удаления пользователя от сцены объект отступает на задний план, но не приближается к точке исчезновения ( vanishing point - точке в центре наблюдаемой области, где объекты сходятся и исчезают в перспективе ).

Пример:

OrthographicCamera {
    focalDistance 5 # SFFloat
    height 2 # SFFloat
    orientation 0 0 1 0 # SFRotation
    position 0 0 1 # SFVec3f
    }
FocalDistance
- Определяет расстояние от ортографической камеры до объектов.
height
- Определяет общую высоту наблюдаемого объема ( прямоугольник, в рамках которого появляются объекты ).
position
- Определяет координаты ортографической камеры x, y, z.
orientation
- Вращает ортографическую камеру. По умолчанию ортографическая камера расположена в точке ( 0,0,1 ) и ваш взгляд направлен вдоль оси Z в монитор.

Броузер применяет текущее преобразование к ортографической камере. Камеру можно позиционировать, помещая узел Transform перед узлом OrthographicCamera в графе сцены.

[править] PerspectiveCamera

Используется для того, чтобы определить перспективное проектирование образов из точки наблюдения. Как вы, возможно, знаете, используя камеры, дизайнеры могут контролировать угол или перспективу, под которыми пользователь видит сцену VRML. Перспективная камера уменьшает размеры объекта с увеличением расстояния до него в противоположность ортографической камере. при проектировании с перспективной камерой по мере удаления пользователя от сцены объекты приближаются к точке перспективы или точки исчезновения.

Пример:

PerspectiveCamera {
    focalDistance 5 # SFFloat
    heightAngle 0.785398 # SFFloat
    orientation 0 0 1 0 # SFRotation
    position 0 0 1 # SFVec3f
    }
focalDistance
- Определяет расстояние от камеры до объекта.
heightAngle
- Определяет общий вертикальный угол обозреваемого пространства. Это пространство ограниченно правильной пирамидой.
position
- Определяет координаты камеры x,y,z.
orientation
- Вращает камеру. По умолчанию камера расположена в точке с координатами ( 0,0,1 ) и ваш взгляд направлен вдоль оси Z на монитор.

[править] PointLight

Используется для того, чтобы поместить источник света в заданную точку трехмерного пространства. Точечный источник излучает одинаково по всем направлениям. Узел определяет источник света, который может воздействовать на следующие за ним формы в иерархии классов в графе сцены. Освещение зависит от текущего стиля освещения, который вы выбрали.

Пример:

PointLight {
    color 1 1 1 # SFColor
    intensity 1 # SFFloat
    location 0 0 1 # SFVec3f
    on TRUE # SFBool
    }
color
- Управляет цветом, задавая смесь красного, зеленого и голубого. Значение цвета изменяется от 0 до 1 для каждого компонента.
location
- Определяет положение источника света в пределах сцены.
intensity
- Управляет интенсивностью источника света. Его значение изменяется от 0 до 1, где 1 отвечает наивысшей интенсивностью.
on
- Включает и выключает свет, где значение TRUE соответствует включенному, а FALSE - выключенному источнику. Броузер применяет текущее преобразование к источнику света.

Узел PointLight, расположенный в рамках узла Separator, не влияет на какие-либо объекты вне узла Separator.

[править] ShapeHints

Используется для того, чтобы определить являются ли значения IndexedFaceSet отмечающими жестким или выпуклым граням, содержат ли они упорядоченные вершины. Документы VRML используют этот узел, чтобы программы обработки VRML-документов могли оптимизировать процесс рендеринга. В такую оптимизацию входит исключение невидимых граней и устранение двустороннего освещения, эффект которого также не виден. Например, если объект сцены является жестким и имеет упорядоченные вершины, программа реализации VRML может включить процесс устранения обратных граней и выключения освещения обеих сторон грани.

Пример:

ShapeHints {
    creaseAngle 0.5 # SFFloat
    faceType CONVEX # SFEnum
    shapeType UNKNOWN_SHAPE_TYPE # SFEnum
    vertexOrdering UNKNOWN_ORDERING # SFEnum
    }
creaseAngle
- Устанавливает угол между нормалями на смежных гранях. Когда требуется IndexedFaceSet для формирования нормалей по умолчанию, используется поле creaseAngle, чтобы определить, какие края броузер должен плавно затемнить, а какие края должны иметь отчетливые границы. Угол складки ( crease angle ) определяется как угол между двумя нормалями к поверхности на смежных гранях. Например, угол складки 0.5 радиан ( значение по умолчанию ) указывает, что переход между двумя смежными полигональными гранями будет выглядеть плавным в случае, когда нормали к двум граням образуют угол, который меньше 0.5 радиан ( приближенно 30* ). В противном случае переход между этими двумя гранями будет резко обозначенным.
faceType
- Указывает, являются ли все грани форму выпуклыми ( значение CONVEX ), или же что документу неизвестно ничего о гранях ( значение UNKNOWN_SHAPE_TYPE ).
vertexOrdering
- Позволяет указывать на упорядоченность вершин объектов.
Возможные значения:
  • UNKNOWN_ORDERING - упорядоченность неизвестна
  • CLOCKWISE - упорядоченность по часовой стрелке
  • COUNTERCLOCKWISE - упорядоченность против часовой стрелки
shapeType
- Показывает, ограничивает ли форма объем ( значение SOLID ), или же тип формы неизвестен ( значение UNKNOWN_SHAPE_TYPE ).

[править] SpotLight

Используется для направленной подсветки объектов. Узел определяет направленный источник освещения, который может воздействовать на формы в сцене графа в соответствии с текущим стилем освещения.

Пример:

SpotLight {
    color 1 1 1 # SFVec3f
    cutOffAngle 0.785398 # SFFloat
    direction 0 0 -1 # SFVec3f
    dropOffRate 0 # SFFloat
    intensity 1 # SFFloat
    location 0 0 1 # SFVec3f
    on TRUE # SFBool
    }
color
- Определяет смесь цветов: красного, зеленого и голубого. Броузер направит лучи прожектора в конусе вокруг трехмерного вектора направления, заданного полем direction. Интенсивность света уменьшается экспоненциально по мере смещения лучей от центра конуса.
cutOffAngle
- Контролирует угол конуса.
location
- Определяет координаты прожектора в рамках графа сцены.
dropOffRate
- Задает, как быстро спадает освещенность по мере увеличения расстояния ( принимает значения от 0 до 1, где 0 соответствует наименьшему ослаблению с расстояния ).
on
- Включает и выключает прожектор.
intensity
- Управляет интенсивностью освещения. Его значение изменяется от 0 ( низкая интенсивность ) до 1 ( высокая интенсивность ).

Броузер применяет текущее преобразование к узлу. Если узел расположен внутри узла Separator , то он влияет на объекты, расположенные вне узла Separator.

Получено с http://spravkaweb.local/index.php/vrml/color
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 11:12, 1 марта 2007.
  • К этой странице обращались 137 раз.
1.32466101646


Справочник по VRML : Положение фигуры в пространстве — Справочник Web-языков

Справочник по VRML : Положение фигуры в пространстве

 |  |  |  | Цвет и текстура
Главная | ::. | VRML | ::. | Положение фигуры в пространстве
 |  |  |  | Определение собственных объектов

Содержание

  • 1 Coordinate3
  • 2 Translation
  • 3 Separator
  • 4 Rotation
  • 5 Scale
  • 6 Group
  • 7 LOD
  • 8 Switch
  • 9 TransformSeparator

[править] Coordinate3

Используется для того, чтобы определить множество трехмерных координат, которые могут быть использованы графом сцены для узлов IndexedFaceSet, IndexedLineSet, PointSet.

Синтаксис:

Coordinate3 {
    point 0 0 0 # MFVec3f
    }

Поле point служит для представления трехмерных координат.

[править] Translation

Определяет координаты объекта.

Синтаксис:

Translation {
    translation 1 2 3 # т.е. соответственно x=1, y=2, z=3
    }

При описании какого-либо объекта по умолчанию он появляется в середине экрана. Так, при описании двух цилиндров, они сольются вместе. По-этому для их разделения применяют узел Translation.

Координаты, указанные в Translation, являются относительными по отношению к предыдущему узлу Translation.

[править] Separator

Группировка узлов и объектов.

Синтаксис:

Separator {
    Другие узлы
    }

В VRML существует правило: свойства фигур (Translation, Material и т.д.) действуют на все следом идущие объекты.

Узел Separation - своеобразный контейнер, который может содержать другие узлы и объекты, и ограничивать область действия узлов типа Translation и Material.

Для того, чтобы вставить ранне описанную фигуру, используем команду USE.

Separator {
    USE name
    }

[править] Rotation

Вращение фигуры вокруг осей.

Синтаксис:

Rotation {
    rotation 0 1 0 1.57
    }

Первые три цифры указывают на возможность поворота фигуры по осям x,y,z соответственно.

Последняя цифра указывает угол поворота в радианах.

Углы в градусах | Углы в радианах
30 | 0.52
45 | 0.78
60 | 1.04
90 | 1.57
180 | 3.14
270 | 4.71

[править] Scale

Масштабирование фигур.

Синтаксис:

Scale {
    scaleFactor 1 1 1 # определяют коэффициенты масштабирования по x,y,z соответственно
    }

Узел Scale масштабирует фигуры по одному или нескольким измерениям.

[править] Group

Используется для того, чтобы определить базовый класс для целой группы узлов.

Пример ( данный узел не имеет полей ):

Group {
    # Child nodes defined here
    }

Узел Group определяет узел-контейнер, который содержит упорядоченный список узлов-потомков. Узел Group не изменяет порядок обхода ( логику обработки броузером узлов и порядок, в котором броузер их прорисовывает ). Как уже было кратко обсуждено ранее, VRML передает текущее состояние ( цвета, текстуры, трансформации и т.д.) каждому последующему узлу-потомку. Узел Group не сохраняет и не восстанавливает порядок обхода, в противоположность методу, используемому узлом Separator, который сохраняет и восстанавливает состояние.

[править] LOD

Документы VRML используют узел LOD ( Level of Detail - уровень детализации ) для того, чтобы позволить броузеру автоматически переключаться между различными представлениями объектов вашего графа сцены. Таким способом броузер может входить или выходить из образа, основываясь на расстояниях, определенными пользователем от объекта к объекту.

Пример:

LOD {
    center 0 0 0 # SFVec3f
    range [ ] # MFFloat
    }
center
- Определяет центр группы объектов LOD. Броузер применяет текущее преобразование к центру объекта.
range
- Определяет массив значений, которые соответствуют расстояниям от пользователя до центра группы объектов в узле LOD. Броузер сравнивает текущее расстояние до первого значения в массиве range. Если расстояние меньше, чем первое значение массива, броузер прорисовывает первого потомка группы LOD. Если расстояние больше, чем первое значение массива, но меньше, чем второе значение, то броузер прорисовывает второго потомка группы LOD и т.д.

[править] Switch

Используется для того, чтобы включать и выключать свойства. В зависимости от значения своего поля, группа, указанная в узле, ведет себя в точности или сходно с поведением, задаваемым узлом Group.

Пример:

Switch {
    whichChild -1 # SFLong
    }
whichChild
- Если принимает значение -3, то узел ведет себя в точности так же, как узел Group. Если значение поля whichChild равно -1, то узел направляет броузеру всех своих потомков. Значение whichChild указывает потомка, к которому узел адресует броузер. Первый потомок имеет значение индекса, равное 0.

[править] TransformSeparator

Используется таким же образом, как и узел Separation. Оба узла сохраняют состояние сцены перед переходом к узлам-потомкам. Аналогично оба узла восстанавливают состояние сцены после окончания обработки узлов-потомков. Но рассматриваемый узел сохраняет только текущее преобразование, все остальные параметры состояния остаются не сохраненными.

Пример:

TransformSeparator {
    # Other nodes here
    }

Документы VRML используют этот узел для позиционирования камеры, поскольку преобразование относительно камеры не воздействует на остальную сцену. Кроме того, документы VRML используют этот узел, чтобы изолировать преобразования относительно источников света и других объектов.

Получено с http://spravkaweb.local/index.php/vrml/coord
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 05:08, 3 марта 2007.
  • К этой странице обращались 90 раз.
1.21971917152


Справочник по VRML : Заголовок VRML-файла — Справочник Web-языков

Справочник по VRML : Заголовок VRML-файла

Главная | ::. | VRML | ::. | Заголовок VRML-файла
 |  |  |  | Примитивы VRML

[править] #VRML V1.0 ascii

Этот заголовок указывает VRML-браузеру что перед ним файл с VRML-кодом. Такой заголовок обязателен. Перед знаком диеза не должно быть пробелов.

[править] Info

Используется для того, чтобы определить информационный узел ( такой как сообщение о правах на копирование или об авторстве ) в графе сцены

Пример:

Info {
    string "" # SFString
}
Получено с http://spravkaweb.local/index.php/vrml/header
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 10:22, 1 марта 2007.
  • К этой странице обращались 93 раза.
1.37641191483


Справочник по VRML — Справочник Web-языков

Справочник по VRML

Главная ::. VRML

[править] Разделы справки

  • Заголовок VRML-файла
  • Примитивы VRML
  • Цвет и текстура
  • Положение фигуры в пространстве
  • Определение собственных объектов
  • Однозначные поля
  • Многозначные поля

[править] Полезные ссылки

  • Форум по VRML
Получено с http://spravkaweb.local/index.php/vrml
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 12:51, 20 марта 2007.
  • К этой странице обращались 211 раз.
1.19266104698


Справочник по VRML : Определение собственных объектов — Справочник Web-языков

Справочник по VRML : Определение собственных объектов

 |  |  |  | Положение фигуры в пространстве
Главная | ::. | VRML | ::. | Определение собственных объектов
 |  |  |  | Однозначные поля

Содержание

  • 1 DEF
  • 2 WWWAnchor
  • 3 WWWInline
  • 4 IndexedFaceSet
  • 5 IndexedLineSet
  • 6 Normal
  • 7 NormalBinding

[править] DEF

Задает имя описываемой фигуре.

Синтаксис:

DEF name
    Cube {}

или

DEF name
    Material {}

или

DEF name
Separator {
    Сгруппированные узлы, описывающие фигуру
    }

Для того, чтобы вставить ранне описанную фигуру, используем команду USE.

Separator {
    USE name
    }

[править] WWWAnchor

Используется для того, чтобы загрузить новую сцену в броузер VRML, когда пользователь выбирает узел-потомок. Узел очень напоминает узел Separator в том отношении, что он сохраняет состояние перед обходом узлов-потомков и восстанавливает состояние по завершении этого действия.

Пример:

WWWAnchor {
    description "" # SFString
    map NONE # SFEnum
    name "" # SFString
    }
description
- Определяет выражение, которое броузер может выводить на экран в своей строке name вместо URL.
map
- Указывает, будет или нет броузер посылать координаты точки в пространстве объекта вместе с URL, когда пользователь выберет этот achor ( якорь ).
Возможные значения:
  • NONE - по умолчанию
  • POINT - координаты точки на объекте, которую выбрал пользователь, будут добавлены в URL в поле name в формате "? x, y, z".
name
- Определяет локальный файл или файл на Web, который содержит новую сцену.

[править] WWWInline

Вставка объекта из другого файла.

Синтаксис:

WWWInline {
    name ""
    bboxSize 0 0 0
    bboxCenter 0 0 0
    }
name
- путь к файлу
bboxSize,bboxCenter
- показывают пользователю размеры и положение вставляемого объекта, пока файл погружается (не обязательны).

[править] IndexedFaceSet

Используется для представления трехмерных фигур, используя многоугольники с вершинами, расположенными в текущих координатах.

Пример:

IndexedFaceSet {
    coordIndex 0 # MFLong
    materialIndex -1 # MFLong
    normalIndex -1 # MFLong
    textureCoordIndex -1 # MFLong
    }
coordIndex
- Определяет координаты граней многогранников, причем значение индекса начинается с 0. Неотрицательные значения индекса отвечают трехмерной точке ( х, у, z ). По определению многогранник должен иметь три или более линии, ограничивающие каждую грань. Поэтому необходимо определить как минимум три координатных индекса ( координаты трех точек в пространстве ) для каждой грани многогранника. Величина, равная -1 в поле coordIndex, указывает на конец текущей грани. Если многогранник содержит боле одной грани, необходимо отделять каждую грань от следующей значением -1. После последней грани многогранника также необходимо поставить значение -1.
materilIndex
- Определяет индекс материалов, который будет использоваться броузером для каждой вершины многогранника.
normalIndex
- Определяет индексы нормалей, которые броузер использует для узлов простой геометрии. с их помощью вычисляется эффект света от поверхностей.
textureCoordIndex
- Определяет индексы текстур, которые броузер свяжет с заданными координатами.

Документы VRML используют индексы IndexedFaceSet в рамках поля coordinateIndex для того, чтобы определить грани многогранника. Броузер преобразует вершины многогранника, используя текущего преобразования.

Если привязка координат текстуры имеет тип PER_VERTEX, то можно связывать явные координаты текстуры ( определенные узлом textureCoordinate2 ) с вершинами группы узлов простой геометрии, одна после другой. Однако если привязка определена как PER_VERTEX_INDEXED, тогда можно связывать координаты текстуры с вершинами многогранника, используя индексы, которые вы указали в поле textureCoordIndex.

Для всех узлов простой геометрии, основанных на описании вершин, справедливо следующее. Если вы определяете текущую текстуру, но не указываете координат текстуры, броузер применяет задаваемое по умолчанию отображение координат текстуры, используя ограничивающий прямоугольник. Размеры этого ограничивающего прямоугольника заданы в терминах S и T. Наибольший размер этого прямоугольника определяет S-координаты, а следующий по длине размер прямоугольника определяет T-оординаты. S-координаты изменяются в пределах от 0 до 1, пробегая значения от одного конца прямоугольника до другого. Область значений Т-координат начинается с числа, лежащего между 0 и отношением второго по длине размера прямоугольника к его самому длинному размеру.

[править] IndexedLineSet

Документы VRML используют этот узел для того, чтобы представлять трехмерные формы путем построения поли линий ( polylilines ) т.е. формировать "проволочные" многогранники, используя вершины, расположенные в текущих координатах. Другими словами, поли линии показывают грани, которые не являются сплошными.

Пример:

IndexedLineSet {
    coordIndex 0 # MFLong
    materialIndex -1 # MFLong
    normalIndex -1 # MFLong
    textureCoordIndex -1 # MFLong
    }
coordInex
- Определяет координаты вершин узлов поли линий, где значение индекса начинается с 0. Неотрицательные значения индекса соответствуют трехмерным точкам ( x, y, z ). Поскольку поли линия является фомой многогранника, она должна по определению иметь три или более линии, которые ограничивают воображаемую грань. Необходимо определить как минимум три координатных индекса, т.е. три трехмерных точки для каждой грани поли линии. Значение индекса, равное -1 в поле coordIndex, указывает на конец текущей грани. Если многоугольник имеет более одной грани, то каждая из них отделена от другой величиной -1. После последней грани также должно идти значение -1.
materilIndex
- Определяет индекс материалов, который броузер будет использовать для каждой вершины поли линии.
normalIndex
- Определяет индексы нормалей, которые броузер использует для вершин, входящих в состав класса узлов простой геометрии.
textureCoordIndex
- Определяет индексы для каждой текстуры, которую броузер связывает с заданными координатами ( вершинами ).

Документы VRML используют индексы IndexedLineSet в поле CoordIndex для того, чтобы задать вершины поли линии. Броузер преобразует вершины, используя текущие преобразования.

[править] Normal

Используется для того, чтобы определить множество нормальных векторов к поверхностям в трехмерном пространстве. Эти векторы используются узлами, которые следуют в иерархии объектов после узла Normal и основываются на использовании вершин. Другими словами, используя узел Normal, можно определить трехмерный нормальный вектор.

Пример:

Normal {
    vector 0 0 1 # MFVec3f
    }

[править] NormalBinding

Используется для того, чтобы определить, как броузер связывает текущие нормали с формами.

Пример:

NormalBinding {
    value DEFAULT # SFEnum
    }
value
- Определяет, как броузер связывает нормали с объектами сцены. Броузер может интерпретировать связывание различным образом для различных форм.
Возможные значения:
  • DEFAULT - броузер использует связывание по умолчанию
  • OVERALL - броузер использует связывание по умолчанию к целому объекту
  • PER_FACE - броузер использует указанную нормаль к каждой грани объекта
  • PER_FACE_INDEXED - Броузер использует указанную нормаль к каждой грани объекта, основываясь на значениях индекса материала
  • PER_PART - броузер использует указанную нормаль для каждой части объекта
  • PER_PART_INDEXED - броузер использует указанную нормаль для каждой части объекта, основываясь на значениях индекса материалов
  • PER_VERTEX - броузер использует указанную нормаль для каждой вершины объекта
  • PER_VERTEX_INDEXED - броузер использует указанную нормаль для каждой вершины объекта, основываясь на значениях индекса материалов
Получено с http://spravkaweb.local/index.php/vrml/object
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 05:24, 3 марта 2007.
  • К этой странице обращались 87 раз.
1.33347892761


Справочник по VRML : Примитивы VRML — Справочник Web-языков

Справочник по VRML : Примитивы VRML

 |  |  |  | Заголовок VRML-файла
Главная | ::. | VRML | ::. | Примитивы VRML
 |  |  |  | Цвет и текстура

Содержание

  • 1 Cube
  • 2 Sphere
  • 3 Cone
  • 4 Cylinder
  • 5 AsciiText
  • 6 PointSet

[править] Cube

Трехмерный куб.

Поля width, height и depth описывают ширину, высоту и глубину куба, измеряемые от его центра.

По умолчанию броузер центрирует куб в начале координат ( 0,0,0 ) с размерами две единицы по каждому из направлений, т.е. в пределах от -1 до +1. Броузер преобразует, двигает куб, используя текущее преобразование графа сцены, материал и текстуру.

Когда вы определите узел Cube, можно использовать текстуру для его различных граней. Броузер наложит текстуру на соответствующую часть куба. Броузер присоединит текстуру к фронтальной, задней, правой, левой сторонам куба. Броузер наложит текстуру на верхнюю часть куба, если она видна пользователю ( с точки зрения камеры ), или на нижнюю часть, если она видна.

[править] Sphere

Используется для представления сферы.

Пример:

Sphere {
    radius 1 # SFFloat
}
radius
- Определяет размер и объем сферы. По умолчанию сфера имеет своим центром начало координат.

Броузер применяет текущее преобразование к узлу Sphere и использует текущие материал и текстуру.

Сфера не имеет граней или частей. Поэтому узлы Sphere игнорируют связывание материала и нормалей, используя первый материал для покрытия сферы целиком и собственные нормали сферы. Когда броузер применяет текстуру к этому узлу, текстура покрывает целиком всю поверхность сферы, накатываясь вокруг сферы сначала на обратной стороне сферы. Текстура имеет шов на обратной стороне сферы.

[править] Cone

Конус.

Синтаксис:

Cone {
    parts ALL # видны и основание, и боковая поверхность конуса
    bottomRadius 2 # радиус основания
    height 1 # высота
    }
  • parts - задает части хуя и может принимать значения :
  • ALL - Отвечает всему конусу целиком.
  • SIDES - Описывает коническую часть конуса.
  • BOTTOM - Описывает нижнюю круговую поверхность конуса.
  • bottomRadius - Определяет размеры конуса.
  • height - Определяет размеры конуса.

[править] Cylinder

Цилиндр.

Синтаксис:

Cylinder {
    parts ALL # видны все части цилиндра
    radius 1 # радиус основания
    height 2 # высота цилиндра
    }

Возможные значения:

parts
ALL
SIDES
BOTTOM
TOP

[править] AsciiText

Документы VRML используют узел AsciiText для представления трехмерного текста в графе сцены VRML. Символы, которые броузер может вывести на экран, определены набором символов ASCII.

Пример:

AsciiText {
    jusrification LEFT # SFEnum
    spacing 1 # SFFloat
    string "" # MFString
    width 0 # MFFloat
    }
string
- Значение этого поля выводится на экран браузером.
Первая строка, которую вы выведете на экран, будет расположена в точке с координатами ( 0,0,0 ). Последующие строки будут смещаться вперед вдоль оси Y в соответствии с формулой: -1*(size*spacing). Вы задаете значение size используя узел FontStyle.
spacing
- Определяет вертикальное расстояние между строками.
justifcation
- Выравнивание.
  • LEFT (по умолчанию) - Помещает левый край строки в положение с координатой х=0.
  • CENTER - Соответствует размещению центра строки в позицию с координатой х=0.
  • RIGHT - Помещает правый край строки в позицию х=0.
Броузер перемещает строки справа налево, сверху вниз, используя спецификации, заданные в узле FontStyle.
width
- Задает ограничения на ширину каждого поля. Значение по умолчанию равно 0 и соответствует естественной ширине строки.
Броузер переносит текст, используя текущие преобразования с накоплением, и принимает текущее значение материала и текстуры.

[править] PointSet

Используется для того, чтобы представить множество точек, расположенных в заданных координатах. Этот узел можно представить себе как массив величин.

Пример:

PointSet {
    numPoints -1 # SFLong
    startIndex 0 # SFLong
    }
numpoints
Определяет число точек в множестве, которые броузер прорисовывает. Значение, равное -1 для поля numPoints указывает, что броузер должен использовать все остающиеся значения текущих координат как точки.
startIndex
-Определяет индекс, соответствующий начальной точке. Броузер применяет технику преобразования к координатам точек.
Броузер изображает точки, используя текущие материал и текстуру.
Получено с http://spravkaweb.local/index.php/vrml/prim
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 10:38, 1 марта 2007.
  • К этой странице обращались 120 раз.
1.26827478409


Справочник по VRML : Однозначные поля — Справочник Web-языков

Справочник по VRML : Однозначные поля

 |  |  |  | Определение собственных объектов
Главная | ::. | VRML | ::. | Однозначные поля
 |  |  |  | Многозначные поля

Поля VRML обеспечивают возможность использования документами чисел, как целых, так и с плавающей точкой, булевых значений, векторов, строк и т.д. Поля VRML используются для описания в математических терминах того, как броузер должен выполнить рендеринг трехмерных объектов. Как вы можете вспомнить,, по соглашению о наименовании имена однозначных полей имеют префиксом две буквы SF , а имена многозначных полей начинаются с букв MF. Спецификация VRML 2.0 также добавляет поля, которые поддерживают узлы: это поля для задания времени, что необходимо для анимации, и т.д. Подробности относительно типов полей VRML 2.0 вы сможете найти в соответствующей спецификации VRML 2.0.

Содержание

  • 1 SFBitMask
  • 2 SFBool
  • 3 SFColor
  • 4 SFEnum
  • 5 SFFloat
  • 6 SFImage
  • 7 SFLong
  • 8 SFMatrix
  • 9 SFRotation
  • 10 SFString
  • 11 SFVec2f
  • 12 SFVec3f

[править] SFBitMask

Поле является однозначным и содержит битовую маску флагов, которую документы VRML применяют с целью позволить броузеру пробегать через различные состояния графа сцены, используя занумерованные имена. Документы VRML применяют этот класс полей для узлов, использующих мнемонические имена в качестве битовых флагов.

[править] SFBool

Поле является однозначным. Документы VRML используют его для записи булевых величин. Численное значение 0 по определению равно строке "FALSE". Аналогично исленное значение 1 равно строке "TRUE".

[править] SFColor

Поле является однозначным полем, которое содержит определение цвета. Документы VRML определяют значение SFColor, используя стандартное определение цветов RGB ( red, green, blue ). Например, тройка ( 1,0,0 ) представляет собой 100% красного цвета, 0% зеленого, 0% голубого соответственно.

[править] SFEnum

Поле является однозначным полем, которое содержит перечисленный тип, обычно использующийся для определения мнемонического имени для численного значения.

[править] SFFloat

Поле является однозначным и определяет числа с плавающей точкой единичной точности. Документы VRML присваивают значение SFFloat , используя научную нотацию, например, 0.125.

[править] SFImage

Поле является однозначным полем, служащим для хранения растровых, т.е. битовых образов. Поле может содержать несжатый черно-белый или цветной образ. Докуенты VRML определяют поле, используя три целых числа, которые представляют высоту, ширину и число компонентов образа, за ними следует число пикселов в рисунке.

Однокомпонентный образ характеризуется также однобайтным числом в шестнадцатиричной системе, которое представляет собой интенсивность образа ( 0хFF соответствует наибольшей интенсивности, а 0х00 - отсутствию интенсивности ). В двухкомпонентном рисунке интенсивность записывается в первый ( верхний ) байт, а прозрачность - во второй ( нижний ) байт. В четырехкомпонентном рисунке байт прозрачности помещается после значений красного, зеленого и голубого.

[править] SFLong

Поле является однозначным полем, которое определяет длинное целое ( 32 бита ). Докуенты VRML могут присваивать значения полю, используя десятичную, шестнадцатиричную или восьмеричную запись значений.

[править] SFMatrix

Поле является однозначным полем, которое содержит матрицу преобразований. Документы VRML задают матрицу преобразования в виде шестнадцати чисел с плавающей точкой, записывая их одно за другим и разделяя пробелами.

[править] SFRotation

Поле является однозначным полем, которое определяет вращение. Поле задается четырьмя числами с плавающей точкой, разделенными пробелами. Эти четыре значения задают ось вращения, а также угол поворота вокруг нее в радианах.

[править] SFString

Поле является однозначным полем, которое определяет строку символов ASCII. Документы VRML присваивают значение полю, используя последовательность символов ASCII, заключенную в двойные кавычки. Если строка не содержит пробелов, то кавычки можно опустить. В кавычках могут быть записаны любые символы, включая знак новой строки. Для того, чтобы включить саму двойную кавычку в качестве символа строки, перед ней надо написать обратный слэш.

[править] SFVec2f

Поле является однозначным и содержит двумерные вектора. Документы VRML присваивают значения полю, используя пару чисел с плавающей точкой, разделенных пробелом.

[править] SFVec3f

Поле является однозначным и содержит двумерные вектора. Документы VRML присваивают значения полю, используя три числа с плавающей точкой, разделенных пробелом.

Получено с http://spravkaweb.local/index.php/vrml/xfield
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 05:58, 3 марта 2007.
  • К этой странице обращались 82 раза.
1.39444589615


Справочник по VRML : Многозначные поля — Справочник Web-языков

Справочник по VRML : Многозначные поля

 |  |  |  | Однозначные поля
Главная | ::. | VRML | ::. | Многозначные поля

VRML поддерживает многозначные поля, которые определяют процесс рендеринга трехмерных объектов. Различия между однозначными и многозначными полями заключаются в том факте, что многозначные поля могут воздействовать более чем на один узел, тогда как однозначные поля воздействуют только на один узел.

Содержание

  • 1 MFColor
  • 2 MFLong
  • 3 MFVec2f
  • 4 MFVec3f

[править] MFColor

Поле является многозначным и содержит произвольное число цветов, заданных в формате RGB. Документы VRML присваивают полю значение, используя одну и более троек чисел в формате RGB. Для того, чтобы задать больше одного значения, документ должен заключать эти значения к квадратные скобки, а сами значения разделяются запятыми.

[править] MFLong

Поле является многозначным полем, которое содержит произвольное число длинных целых ( 32-битных ) чисел. Документы VRML присваивают полю значение, используя одно или больше число значений в десятичной, шестнадцатиричной или восьмеричной форме. Для того, чтобы задать более одного значения, их необходимо заключить в квадратные скобки и разделить запятыми.

[править] MFVec2f

Поле является многозначным и содержит произвольное число двумерных векторов. Документы VRML присваивают полю значения, используя одну или больше пар чисел с плавающей точкой, разделенных пробелами. Если присваивается больше одного вектора, то значения пары разделяются запятыми, а весь набор векторов заключается в квадратные скобки.

[править] MFVec3f

Поле является многозначным полем, которое содержит произвольное число трехмерных векторов. Докуенты VRML присваивают значения полю, используя одну или больше троек чисел с плавающей точкой, разделенных пробелами. Если присваивать больше одного вектора, то значения пары разделяются запятыми, а весь набор заключается в квадратные скобки.

Получено с http://spravkaweb.local/index.php/vrml/xxfield
Просмотры
  • Статья
  • Обсуждение
  • Править
  • История
Личные инструменты
  • Представиться системе
разделы сайта
  • Заглавная страница
  • HTML
  • JavaScript
  • VBScript
  • CSS
  • Flash
  • Perl
  • PHP
  • MySQL
  • SSI
  • VRML
  • Форум
  • Download
Навигация
  • main
  • Сообщество
  • Текущие события
  • Свежие правки
  • Случайная статья
  • Справка
  • Пожертвования
в разработке
  • JScript
  • Программное обеспечение
  • Разработка сайтов
Инструменты
  • Ссылки сюда
  • Связанные правки
  • Загрузить файл
  • Спецстраницы
  • Версия для печати
  • Постоянная ссылка
Powered by MediaWiki
  • Последнее изменение этой страницы: 06:02, 3 марта 2007.
  • К этой странице обращались 80 раз.
1.41722297668