FORM

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

FORM

(HTML 2.0) – Form

Используется для создания заполяемой формы. Необходимо присутствие начального и конечного тегов. Внутри элемента FORM разрешается использовать большинство HTML-элементов.

Атрибуты:

NAME – определяет имя формы, уникальное для данного документа. Используется, если в документе присутствует несколько форм.

ACTION – обязательный атрибут. Определяет URL, по которому будет отправлено содержимое формы – путь к скрипту сервера, обслуживающему данную форму.

METHOD – определяет способ отправки содержимого формы. Возможные значения GET (по умолчанию) и POST.

ENCTYPE – определяет способ кодирования содержимого формы при отправке. По умолчанию используется "application/x-www-form-urlencoded".

TARGET – определяет имя окна, в которое возвращается результат обработки отправленной формы. Возможные значения : _self, _parent, _top, _blank или явно указанное имя окна. Подробное описание значений смотрите в атрибуте TARGET элемента A.

Пример:
<!-- Создаем форму -->
<FORM ACTION="/cgi-bin/thanks.pl" METHOD=GET NAME="TestForm">

    <!-- Внутри формы создаем поле ввода: -->
    Фамилия:
    <INPUT TYPE="text" name="lastname" SIZE="20" VALUE="Пупкин"><br>

    <!-- Кнопка "Отправить": -->
    <INPUT TYPE="submit" VALUE="Отправить">
</FORM>
<!-- Все, конец форме -->'

Примечания:

 Во время отладки скрипта, принимающего данные, удобнее всего использовать метод GET.

Метод GET не позволяет передать скрипту большой объём данных. Если предполагается, что пользователь будет заполнять очень большую форму или вводить объёмные текстовые данные, или пересылать файл – используйте METHOD="POST".

Перед тегом <FORM> в браузерах Netscape образуется пустое пространство, вертикальный отступ. Если вас это не устраивает и при этом форма на странице одна, поместите тег <FORM> в начало страницы, сразу после тега <BODY>, это должно помочь.

Designed by Vladimir Gorodulin , Copyright © 1999-2004
Частичная или полная перепечатка или иное использование материалов сайта допускается только с разрешения автора. Ссылка на источник обязательна. Нарушители преследуются по закону РФ и все такое.


INPUT

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

INPUT

(HTML 2.0) – Input

Элемент INPUT создает поле формы (кнопку, поле ввода, чекбокс и т.п.), содержание которого может быть изменено или активизировано пользователем. Элемент не имеет конечного тега. Элемент INPUT должен располагаться внутри элемента FORM.

Атрибуты:

NAME – определяет имя, используемое при передаче содержания данной формы на сервер. Этот атрибут необходим для большинства типов (атрибут TYPE – cм. ниже) элемента INPUT и обычно используется для идентификации поля или для группы полей, связанных логически.

TYPE – определяет тип поля для ввода данных. По умолчанию – это "text". Возможные значения:

    text – создает поле ввода под одну строку текста. Как правило используется совместно с атрибутами SIZE и MAXLENGTH.
    textarea – создает поле ввода для текста в несколько строк. Но для этих целей лучше использовать элемент TEXTAREA
    file – дает возможность пользователю приобщить файл к текущей форме. Возможно использование совместно с атрибутом ACCEPT.
    password – создает поле ввода под одну строку, однако текст, вводимый пользователем, отображается в виде значков "*", скрывая тем самым его содержание от любопытных глаз.
    checkbox – создает поле ввода для атрибутов типа Boolean ("да"/"нет") или для атрибутов, которые могут одновременно принимать несколько значений. Эти атрибуты представляют собой несколько полей checkbox, которые могут иметь одинаковые имена. Каждое выбранное поле chackbox создает отдельную пару name/value в информации, посылаемой на сервер, даже если результатом будут дублирующиеся имена. Поле этого типа обязательно должно иметь атрибуты NAME и VALUE, а также необязательный атрибут CHECKED, который указывает на то, что поле активизировано.
    radio – создает поле ввода для атрибутов, которые принимают одно значение из нескольких возможных. Все кнопки (radio buttons) в группе должны иметь одинаковые имена, но только выбранная кнопка в группе создает пару name/value, которая будет послана на сервер. Как и для полей checkbox, атрибут CHECKED необязателен; он может быть использован для определения выделенной кнопки в группе кнопок (radio button).
    submit – создает кнопку, при нажатии которой заполненная форма посылается на сервер. Атрибут VALUE в данном случае изменяет надпись на кнопке, содержание которой, заданное по умолчанию, зависит от браузера. Если атрибут NAME указан, то при нажатии данной кнопки к информации, посылаемой на сервер, добавляется пара name/value, указанная для для атрибута SUBMIT, в противном случае пара не добавляется.
    image – создает графическую кнопку-картинку, инициализирующую передачу данных на сервер. Местонахождение графического изображения можно задать с помощью атрибута SRC. При передаче данных серверу сообщаются координаты x и y той точки на изображении, где был произведен щелчок клавишей мыши. Координаты измеряются из верхнего левого угла изображения. При этом информация о поле типа image записывается в виде двух пар значений name/value. Значение name получается посредством добавления к названию соответствующего поля суффиксов ".x" (абсциссы), и ".y" (ординаты).
    reset – создает кнопку, сбрасывающую значения полей формы к их первоначальным значениям. При нажатии кнопки данные на сервер не отправляются. Надпись на кнопке может быть изменена с помощью атрибута VALUE. По умолчанию надпись на кнопке зависит от версии браузера.
    hidden – поля этого типа не отображаются на экране монитора, что позволяет разместить "секретную" информацию в рамках формы. Содержание этого поля посылается на сервер в виде name/value вместе с остальной информацией формы. Этот тип полей удобно использовать для передачи данных от скрипта скрипту незаметно для пользователя.
    button – позволяет создать пользовательскую кнопку в HTML документе, что, при умелом использовании JavaScript, добавляет форме функциональность. Атрибут NAME позволяет задать имя данной кнопке, которое может быть использовано для какой-либо функции в скрипте. Атрибут VALUE позволяет задать текст, который будет отображен на кнопке в документе.

VALUE – задает текстовый заголовок для полей любого типа, в том числе и кнопок. Для таких полей как checkbox или radio, будет возвращено значение, заданное в атрибуте VALUE.

CHECKED – указывает, что поля типов checkbox и/или radio (см. выше атрибут TYPE) активизированы.

SIZE – определяет размер поля в символах. Например, чтобы определить поле с видимой шириной в 24 символа, надо указать SIZE="24".

MAXLENGTH – определяет максимальное количество символов, которые можно ввести в текстовом поле. Оно может быть больше, чем количество символов, указанных в атрибуте SIZE. По умолчанию количество символов не ограничено.

SRC – задает URL-адрес картинки, используемой при создании графической кнопки. Используется совместно с атрибутом TYPE="image".

ALIGN – определяет способ вертикального выравнивания для изображений. Используется совместно с атрибутом TYPE="image". Полностью аналогичен атрибуту ALIGN элемента IMG. По умолчанию имеет значение bottom.

ACCEPT – конкретизирует тип файла. Используется только совместно с параметром TYPE="file". Значение задается в виде MIME-типа.

Пример 1:
<FORM NAME="Form1" ACTION="http://www.igf.ru/cgi-bin/banya.pl">
    <INPUT TYPE="hidden" NAME="info" VALUE="Запись в баню на воскресенье">
    <INPUT TYPE="radio" NAME="sex" VALUE="Male" CHECKED> Мужик<BR>
    <INPUT TYPE="radio" NAME="sex" VALUE="Female"> Баба<BR>
    Имя:<BR>
    <INPUT TYPE="text" NAME="textfield" VALUE="Вася Пупкин" SIZE="30" MAXLENGTH="60"><BR>
    Пароль:<BR>
    <INPUT TYPE="password" WIDTH="10" NAME="passwd"><BR><BR>
    <INPUT TYPE="submit" VALUE="Запулить">
</FORM>

Пример 2:
Хочу получать следующие издания:<br>
<FORM NAME="Form2" ACTION="http://www.igf.ru/cgi-bin/magazines.pl">
    <INPUT TYPE="checkbox" NAME="m1">Страшная газета<br>
    <INPUT TYPE="checkbox" NAME="m2">6 соток<BR>
    <INPUT TYPE="checkbox" NAME="m3" CHECKED>Мурзилка<BR>
    <INPUT type="image" src="/img/button.gif" WIDTH="60" HEIGHT="30">
</FORM>


OPTION

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

OPTION

(HTML 2.0) – Option

Используется только с элементом SELECT. Элемент OPTION описывает отдельные пункты меню. Не имеет конечного тега.

Атрибуты:

SELECTED – Определяет пункт меню, который будет выбран изначально при загрузке документа. Если меню имеет тип "один из многих", то флагом SELECTED может быть помечен лишь один пунктов меню.

VALUE – Задает данному пункту значение, которое будет использовано наряду с другими сведениями о содержимом заполненной формы. При предоставлении информации на сервер это значение будет объединено со значением атрибута NAME в элементе SELECT.

Пример:
...
<FORM ACTION="script.cgi">
<SELECT NAME="gender">
    <OPTION VALUE="male" SELECTED>Мужской
    <OPTION VALUE="female">Женский
    <OPTION VALUE="not_yet">Определяюсь
</SELECT>
<INPUT TYPE="submit" VALUE="OK">
</FORM>
...

Результат:


SELECT

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

SELECT

(HTML 2.0) – Select

Элемент SELECT создает в заполняемой форме меню типа "Выбор одного пункта из многих" или "Выбор нескольких пунктов из многих". Должен располагаться внутри элемента FORM и иметь как начальный, так и конечный теги. Содержит несколько элементов OPTION, иначе не имеет смысла.

Атрибуты:

MULTIPLE – дает возможность выбора нескольких пунктов меню при удержании клавиши Ctrl. По умолчанию можно выбрать только один пункт меню.

NAME – определяет имя меню, уникальное для данной формы, которое будет использоватся при передаче данных на сервер. Каждый выбранный пункт меню при передаче на сервер будет иметь вид: name/value. Значение (value) формируется элементом OPTION.

SIZE – определяет количество видимых пунктов в меню. Если значение этого атрибута больше единицы, то результатом будет список пунктов.

Пример:
...
<FORM ACTION="receive.cgi">
<SELECT NAME="OS" MULTIPLE>
    <OPTION VALUE="DOS">MS-DOS
    <OPTION VALUE="WinXP">MS Windows98
    <OPTION VALUE="Unix" SELECTED>UNIX
    <OPTION VALUE="WinNT">MS Windows NT
</SELECT>
<INPUT TYPE="submit" VALUE="Послать">
</FORM>
...

Результат:


TEXTAREA

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

TEXTAREA

(HTML 2.0) – Text Area

Создает поле для ввода нескольких строк текста. Обычно содержит текст инициализации, который при загрузке документа изначально будет записываться в данное поле. Элемент TEXTAREA должен располагаться внутри элемента FORM.

Атрибуты:

NAME – обязательный атрибут. Определяет название, которое будет использоваться при идентификации заполненого поля сервером.

ROWS – определяет количество строк текста, видимых на экране.

COLS – определяет ширину текстового поля – в печатных символах.

WRAP – определяет способ переноса слов в заполняемой данной заполняемой форме. Возможные значения:

    off – перенос слов не происходит (значение по умолчанию)
    virtual – перенос слов только отображается, на сервер же поступает неделимая строка.
    physical – перенос слов будет происходить во всех точках переноса.

Пример:
...
<FORM ACTION="receive.html" METHOD=POST>
    <TEXTAREA NAME="address" WRAP="virtual" COLS="40" ROWS="3">Ваш адрес...</TEXTAREA><br>
    <INPUT TYPE="submit" VALUE="OK">
</FORM>
...

Результат:

Примечание:

 Поле типа TEXTAREA позволяет пользователю набрать довольно большой блок текста. Поэтому, если в форме присутствует поле TEXTAREA, передавайте скрипту данные методом POST (см. элемент FORM) иначе есть вероятность потери данных.

ПОЧИТАТЬ НА АНГЛИЙСКОМ:
Methods GET and POST in HTML forms – what's the difference?


A

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

A

(HTML 1.0) – Anchor

Самый необходимый элемент, без которого Интернет просто немыслим. Используется для создания и использования гипертекстовых ссылок.

Атрибуты:

HREF – определяет находящийся между начальным и конечным тегами текст или изображение как гипертекстовую ссылку (URL, или линк) на документ (и/или область документа), указанный в значении данного атрибута. Возможные значения:

    http://... – создает ссылку на www-документ;
    ftp://... – создает ссылку на ftp-сайт или расположенный на нем файл;
    mailto:... – запускает почтовую программу-клиент с заполненным полем имени получателя. Если после адреса поставить знак вопроса, то можно указать дополнительные атрибуты, разделенные знаком "&";
    news:.. – создает ссылку на конференцию сервера новостей;
    telnet://... – создает ссылку на telnet-сессию с удаленной машиной;
    wais://... – создает ссылку на WAIS – сервер;
    gopher://... – создает ссылку на Gopher – сервер;

Если тип соединения и адрес машины не указаны, в качестве отправной точки используется адрес текущего документа. Это позволяет использовать относительные ссылки.
Например, линк <A HREF="docs/title.html">Документация</A> будет ссылаться на файл title.html в подкаталоге docs (относительно текущего).

NAME – помечает находящуюся между начальным и конечным тегами область документа как возможный объект для ссылки. В качестве значения нужно латиницей написать любое слово-указатель, уникальное для данного документа.
Например: <A NAME="part">Раздел1</A>. Теперь вы можете ссылаться на помеченную область простым указанием ее имени после имени документа. Например, линк <A HREF="document.html#part">Раздел1</A> отправит вас в раздел "part" файла document.html, а линк <A HREF="#bottom">В конец документа</A> – в раздел "bottom" текущего документа. (см. Пример 1)

TARGET – определяет окно (фрейм), на которое указывает гипертекстовая ссылка. Этот атрибут используется только совместно с атрибутом HREF. В качестве значения необходимо задать либо имя одного из существующих фреймов, либо одно из следующих зарезевированных имен:

    _self – указывает, что определенный в атрибуте HREF документ должен отображаться в текущем фрейме;
    _parent – указывает, что документ должен отображаться во фрейме-родителе текущего фрейма. Иначе говоря, _parent ссылается на окно, содержащее FRAMESET, включающий текущий фрейм;
    _top – указывает, что документ должен отображаться в окне-родителе всей текущей фреймовой структуры;
    _blank – указывает, что документ должен отображаться в новом окне.

Пример 1:
<!-- Использование атрибута NAME: -->
<A NAME="history">История бодибилдинга</A>
...
<A NAME="now">Спорт глазами современника</A>
...
Вернуться к разделу<A HREF="#history">истории</A>

Пример 2:
<!-- Использование атрибута HREF: -->
<A HREF="ftp://ftp.cdrom.com" TARGET="_blank">FTP-site</A>
<A HREF="http://opengl.rdc.ru">Русский проект по OpenGL</A>
...

Пример 3:
<!-- Создадим ссылку для письма с указанием кучи атрибутов -->
<A HREF="mailto:green@igf.ru?subject=Приглашение &cc=bg@microsoft.com&body=Приезжай на вечеринку.">
Отправить приглашение </A>.
<!-- или просто письмо : -->
<A HREF="mailto:green@igf.ru?subject=Привет">авторам</A>.

Примечания:

 Элемент A не может быть вложенным в себе подобные, то есть недопустимы конструкции вроде
<A HREF="link1.html">
Первый линк
    <A HREF="link2.html">Второй линк</A>
Продолжаем первый линк
</A>

Если в атрибуте TARGET указать имя несуществующего окна или фрейма, создастся новое окно с указанным именем. Как мы видим, результат получится тот же, что и при задании нового окна: <A HREF="..." TARGET="_blank">, с той лишь разницей, что в последнем случае окно не будет иметь имени и на него нельзя будет ссылаться.

С помощью элемента BASE вы можете указать значение TARGET для всех гиперссылок в текущем документе.

ССЫЛКИ НА ДРУГИЕ САЙТЫ ПО ДАННОЙ ТЕМАТИКЕ
- Краткий экскурс в историю гипертекста (А.Лебедев)


DD

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

DD

(HTML 2.0) – Definition Description

Cоздает определение термина внутри элемента DL.


DL

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

DL

(HTML 2.0) – Definition List

Открывает и закрывает список определений (терминов и их описаний). Определения задаются с помощью элементов DT и DD.

Атрибуты:

COMPACT – включает режим "компактного" отображения списка. Удобно использовать, если список определений очень велик. Данный атрибут является флагом и не требует присвоения значения.

Пример:
<DL COMPACT>
    <DT>Жапура<DD>Река в Колумбии и Бразилии
    <DT>Зайцы<DD>Семейство млекопитающих отряда зайцеобразных
    ...
</DL>


DT

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

DT

(HTML 2.0) – Definition Term

Создает термин в списке определений внутри элемента DL.


LI

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

LI

(HTML 2.0) – List Item

Создает пункт в списке. Располагается внутри элементов OL или UL.

Атрибуты:

VALUE – изменяет порядок нумерации элементов списка. Используется только если элемент LI находится внутри элемента OL. В качестве значения указывается порядковый номер элемента.

Пример:
<OL TYPE="A" START="2">
    <LI> Пункт, озаглавленный буквой B. </LI>
    <LI VALUE="6"> Пункт, озаглавленный буквой F. </LI>
    <LI> Пункт, озаглавленный буквой G. </LI>
</OL>

Примечания:

 Некоторые разработчики употребляют LI вне элементов OL и UL, объясняя это тем, что браузеры и так нормально справятся с отображением списка. Это неверно, коллеги, почитайте спецификацию!

Согласно официальной рекомендации консорциума W3C закрывающий тег </LI> писать не обязательно. По этому поводу скажу следующее: хоть HTML и не является языком программирования, у вас, как и у всякого хорошего программиста, должен быть свой стиль написания кода. Кто-то будет писать </LI>, кто-то не будет – это не так уж и важно. Главное, чтобы вы однажды определились и не изменяли своему решению.


MENU, DIR

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

MENU, DIR

(HTML 2.0) – Menu, Directory List

Данные теги предназначены для создания неупорядоченных списков, подобных UL. Эти элементы не вошли в спецификацию HTML 4.0, однако браузеры могут распознавать их в целях обратной совместимости. Авторам же рекомендуется использовать вместо MENU и DIR элемент UL.


OL

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

OL

(HTML 2.0) – Ordered List

Создает упорядоченный список. Между начальным и конечным тегами должны присутствовать один или несколько элементов LI, обозначающих отдельные пункты списка.

Атрибуты:

START – определяет первое число, с которого начинается нумерация пунктов. (только целые числа)

TYPE – определяет стиль нумерации пунктов. Может иметь значения:

    "A" – заглавные буквы A, B, C ...
    "a" – строчные буквы a, b, c ...
    "I" – большие римские числа I, II, III ...
    "i" – маленькие римские числа i, ii, iii ...
    "1" – арабские числа 1, 2, 3 ...

По умолчанию <UL TYPE="1">.

Пример:
<OL TYPE="I" START="2">
    <LI> Пункт два </LI>
    <LI> Пункт три </LI>
    <LI> Пункт четыре </LI>
</OL>


UL

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

UL

(HTML 2.0) – Unsorted List

Создает неупорядоченный список. Между начальным и конечным тегами должны присутствовать один или несколько элементов LI, обозначающих отдельные пункты списка.

Пример:
<UL>
    <LI> Первый пункт списка </LI>
    <LI> Второй пункт списка </LI>
    <LI> Третий пункт списка </LI>
</UL>


APPLET

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

APPLET

(HTML 3.2) – Applet

Имеет начальный и конечный теги. Используется для вставки в HTML-страницу Java-апплетов – программ на языке Java, исполняемых браузером на вашем компьютере. Java-апплет исполняется в специально отведенном для него месте, отображаясь в документе наподобие картинки. Поэтому многие атрибуты элемента APPLET сходны с атрибутами элемента IMG.

Если ваш браузер не имеет встроенной виртуальной Java-машины (и, соответственно, не поддерживает элемента APPLET), то на месте окошка Java-апплета вы увидите текст, заключенный между начальным и конечным тегами.

Атрибуты:

CODE – обязательный атрибут. Определяет имя файла исполняемого Java-апплета.

CODEBASE – указывает базовый адрес (URL), по которому находится файл с кодом исполняемого Java-апплета. Если парамер CODEBASE опущен, используется URL текущего документа.

ALIGN – обязательный атрибут. Указывает способ выравнивания Java-апплета. Может принимать те же значения, что и аналогичный атрибут элемента IMG.

HEIGHT и WIDTH – обязательные атрибуты. Определяют ширину и высоту (в пикселах) окошка вывода программы.

HSPACE и VSPACE – определяют отступ (в пикселах) по горизонтали и вертикали от других объектов документа.

NAME – указывает имя Java-апплета, уникальное для данного документа. Позволяет Java-апплетам на данной странице находить себе подобных и взаимодействовать друг с другом.

ALT – определяет текст, отображаемый на месте апплета браузером, если браузер понимает элемент APPLET, но не может выполнять Java-апплеты.

SRC – указывает адрес (URL), ассоциированный с апплетом. Например, адрес сайта разработчика апплета.

Пример 1:
<APPLET CODE="JumpingGirl.class" WIDTH="30" HEIGHT="40" ALIGN="left" ALT="Прыгающая девочка">
Если вы видите этот текст, значит ваш браузер не поддерживает Java.
</APPLET>

В результате слева отображается окошко (размером 30x40 точек) с прыгающей девочкой. Само собой, у вас должен быть файл JumpingGirl.class, который должен лежать в той же директории, что и текущий документ.

Пример 2:
<APPLET CODEBASE="http://www.igf.ru/javagames" CODE="CrazyTetris.class" WIDTH="300" HEIGHT="500" ALIGN="right" SRC="http://www.igf.ru" ALT="Игра Тетрис">
</APPLET>

В данном примере справа отображается окошко (размером 300x500 точек) с игрой Тетрис. Браузер будет пытаться загрузить игру используя URL "http://www.igf.ru/javagames/СrazyTetris.class".

Примечание:

 Для передачи Java-программе каких-либо параметров используется элемент PARAM.


EMBED

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

EMBED

(В спецификациях W3C отсутствует) – Embed

Используется для вставки в HTML различных объектов: не-html документов и media-файлов. Тип вставляемого объекта, будь то музыкальный wav/midi-файл или трехмерный мир VRML, должен быть зарегистрирован на машине пользователя как проигрываемый одним из имеющихся plug-in'ов или поддерживаемый каким-либо приложением. Если браузер поддерживает элемент EMBED, содержащиеся между начальным и конечным тегами текст и элементы будут игнорироваться.

Атрибуты:

Вставка объекта происходит так же, как и вставка изображения (см. элемент IMG) : под внедряемый объект необходимо сначала выделить место. Поэтому элемент EMBED имеет ряд одинаковых с элементом IMG атрибутов, а именно: NAME, ALIGN, ALT, BORDER, WIDTH, HEIGHT, HSPACE и VSPACE.

Другие атрибуты:

SRC – обязательный атрибут. Определяет имя файла вставляемого объекта.

PLUGINSPACE – указывает на адрес (URL), по которому можно найти plug-in, необ-ходимый для просмотра типа файлов, аналогичных указанному в атрибуте SRC.

PALETTE – определяет тип цветовой палитры для просмотра объекта. Данный атрибут работает только на Windows-машинах с 256-цветной системной палитрой. Возможные значения:

    background – использовать background-палитру для отображения объекта (используется по умолчанию).
    foreground – использовать foreground-палитру для отображения объекта.

HIDDEN – определяет, отображать указанный объект или нет. Возможные значения:

    true – не отображать объект.
    false – отображать объект (используется по умолчанию).

TYPE – явно указывает браузеру к какому типу файлов относится загружаемый объект, помогая определить необходимое средство просмотра (plug-in). В качестве значения указывается зарегестрированный MIME-тип файла.

Пример 1:
<EMBED SRC="music.mid" HIDDEN="true">
    <NOEMBED>Альтернативный текст для старых браузеров</NOEMBED>
</EMBED>

Пример 2:
<EMBED SRC="music.vrml" HEIGHT="300" WIDTH="200" HSPACE="10" ALIGN="center" PLUGINSPACE="../plugins/download_vrml.html">
    <NOEMBED>Альтернативный текст для старых браузеров</NOEMBED>
</EMBED>

Примечания:

 Для старых браузеров, не поддерживающих элемент EMBED, необходимо использовать элемент NOEMBED с указанием между начальным и конечным тегами альтернативного текста, как показано в примерах выше.

Обратите внимание – в спецификациях консорциума W3C про EMBED ничего не сказано (!), скороее всего данный элемент появился по инициативе разработчиков Netscape 1.1 и с тех пор поддерживается всеми браузерами для совместимости (начиная с MSIE 3.0-beta-2 и выше).

Каким бы привлекательным элемент EMBED вам ни казался, но, поверьте, лучше его не использовать. Далеко не каждому может понравиться принудительное проигрывание MID-файла или попытка прокрутить ролик в неизвестном браузеру формате. Если вам все же не терпится украсить HTML чем-нибудь из ряда вон выходящим, не поленитесь, потратьте время на усиленное тестирование со всеми популярными видами браузеров.

СМОТРИТЕ ТАКЖЕ:
- Элемент NOEMBED – пригодится для поддержки старых браузеров.

ССЫЛКИ НА ДРУГИЕ САЙТЫ ПО ДАННОЙ ТЕМАТИКЕ:
- Почему сайты не должны издавать звуков (А.Лебедев)


IMG

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

IMG

(HTML 2.0) – Image

Используется для вставки изображений в HTML-документ.
Это один из самых популярных элементов, незаменимый инструмент web-дизайнера. Элемент допускает вставку изображений в форматах JPEG (в том числе progressive jpeg) и Compuserve GIF (включая прозрачные и анимированные). Червертые версии браузеров позволяют также использовать формат PNG, но до тех пор, пока они не устареют, от применения PNG лучше воздержаться.
Элемент IMG не имеет конечного тега.

Атрибуты:

SRC – обязательный атрибут. Указывает адрес (URL) файла с изображением.

HEIGHT и WIDTH – определяют ширину и высоту изображения соответственно. Если указанные значения не совпадают с реальным размером изображения, изображение масштабируется (порой с заметной потерей качества).

HSPACE и VSPACE – определяют отступ картинки (в пикселах) по горизонтали и вертикали от других объектов документа. Просто необходимо при обтекании изображения текстом.

ALIGN – обязательный атрибут. Указывает способ выравнивания изображения в документе. Может принимать следующие значения:

    left – выравнивает изображение по левому краю документа. Прилегающий текст обтекает изображение справа.
    right – выравнивает изображение по правому краю документа. Прилегающий текст обтекает изображение слева.
    top и texttop – выравнивают верхнюю кромку изображения с верхней линией текущей текстовой строки.
    middle – выравнивает базовую линию текущей текстовой строки с центром изображения.
    absmiddle – выравнивает центр текущей текстовой строки с центром изображения.
    bottom и baseline – выравнивает нижнюю кромку изображения с базовой линией текущей текстовой строки.
    absbottom – выравнивает нижнюю кромку изображения с нижней кромкой текущей текстовой строки.

NAME – определяет имя изображения, уникальное для данного документа. Вы можете указать любое имя без пробелов с использованием латинских символов и цифр. Имя необходимо, если вы планируете осуществлять доступ к изображению, например, из JavaScript-сценариев.

ALT – определяет текст, отображаемый браузером на месте изображения, если браузер не может найти файл с изображением или включен в текстовый режим. В качестве значения задается текст с описанием изображения.

BORDER – определяет ширину рамки вокруг изображения в пикселах. Рамка возникает, только если изображение является гипертекстовой ссылкой. В таких случаях значение BORDER обычно указывают равным нулю.

LOWSRC – указывает адрес (URL) файла с альтернативным изображением более низкого качества (и, соответственно, меньшего объема), чем изображение, указанное в атрибуте SRC. Браузеры Netscape, поддерживающие данный атрибут, сначала загрузят картинку из LOWSRC, a затем заменят ее картинкой из SRC.

USEMAP – применяет к изображению навигационную карту (image map), заданную элементом MAP. В качестве значения задается имя карты с предшествующей ему решеткой. Например, если имя карты – "map1", то ссылка на нее будет выглядеть как "#map1" (см. Пример 4). Обратите внимание: прописные и строчные буквы в данном атрибуте трактуются браузером как разные.

ISMAP – определяет изображение как навигационную карту (image map), обрабатываемую сервером. Имеет смысл использовать только тогда, когда изображение является гиперссылкой. После клика мышкой на изображении серверу отправляются x,y-координаты нажатия. В зависимости от полученных координат, сервер (при наличии на нем соответствующего программного обеспечения) может показать вам тот или иной документ. Данный атрибут является флагом и не требует присвоения значения.

Пример 1:
<IMG src="/img/picture.gif" WIDTH="45" HEIGHT="53" ALT="Рысь" HSPACE="10" ALIGN="left"> Этот текст обтекает картинку справа и находится от нее на расстоянии 10 пикселов.

Пример 2. Использование изображения в качестве гиперссылки:
<A HREF="carlson.html">
<IMG src="/img/button.jpg" WIDTH="70" HEIGHT="30" ALIGN="right" BORDER="0" ALT="Досье Карлсона">
</A>
Для просмотра досье нажмите на кнопку справа.

Пример 3. Использование ISMAP:
<A HREF="http://www.igf.ru/bin/imagemaps/map1">
<IMG SRC="map.gif" ISMAP></A>');

Пример 4. Использование USEMAP:
<IMG src="/img/buttons.jpg" WIDTH="170" HEIGHT="120" ALIGN="middle" BORDER="0" USEMAP="#ButtonsMap">');

Примечания (особо важно):

 Золотое правило web-мастера – всегда явно задавать размеры картинки в атрибутах HEIGHT и WIDTH, резервируя тем самым место в окне браузера еще до загрузки изображения. В противном случае документ при загрузке каждой картинки будет заново перерисовываться. А на медленных машинах (или при подключении к сети через модем) это смотрится просто отвратительно.

Второе золотое правило web-мастера: если на картинке изображено что-то разборчивое, нужно описать это словами в атрибуте ALT.

Всегда сразу после <IMG ...> ставьте <BR>! А то проблем не миновать – после картинки появится пустое пространство в несколько пикселей. Причём ставьте вплотную, без пробелов: <img ...><br>.

Для завершения обтекания изображения текстом используйте атрибут CLEAR элемента BR.

Значения top и texttop атрибута ALIGN не совсем идентичны, и их использование порой дает разный результат. Попробуйте поэкспериментировать.

Указывайте значения атрибутов HSPACE и VSPACE, даже если вы хотите оставить поля нулевой ширины. Бывает, что некоторые браузеры по умолчанию присваивают им какое-то небольшое значение, не равное нулю.

По возможности старайтесь не создавать навигационных карт, обрабатываемых на сервере. Иначе говоря, вместо атрибута ISMAP используйте атрибут USEMAP + локальные карты.

СМОТРИТЕ ТАКЖЕ:
- "Форматы изображений – GIF или JPG?" – для начинающих.


NOEMBED

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

NOEMBED

(HTML 3.2) – No Embed

Определяет блок, который будет отображен, если браузер по какой-либо причине не работает с элементом EMBED.

Пример:
<EMBED SRC="music.mid" HIDDEN="true">
    <NOEMBED> Ваш браузер морально устарел ;-D </NOEMBED>
</EMBED>


PARAM

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

PARAM

(HTML 3.2) – Parameter

Располагается в начале элемента APPLET. Используется для передачи Java-программе каких-либо параметров. Элемент задает пару "имя – значение" переменной, которая будет передана Java-программе.

Пример:
<APPLET CODEBASE="http://www.igf.ru/applets" CODE="JavaTetris.class" WIDTH="440" HEIGHT="475" ALIGN="center">
    <PARAM NAME="width" VALUE="10">
    <PARAM NAME="height" VALUE="20">
    <PARAM NAME="name" VALUE="Cool Tetris">
    ...
</APPLET>


CAPTION

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

CAPTION

(HTML 3.2) – Caption

Задает заголовок таблицы. Содержание заголовка должно состоять только из текста. Использование блочных элементов в этом случае недопустимо.

Атрибуты:

ALIGN – определяет способ вертикального выравнивания заголовка таблицы. Возможные значения:

    top – помещает заголовок над таблицей (значение по умолчанию);
    bottom – помещает заголовок под таблицей.

Пример:
<TABLE BORDER="1">
    <CAPTION ALIGN="bottom">Заголовок таблицы</CAPTION>
    <TR>
        <TD>Ячейка таблицы</TD>
    </TR>
</TABLE>


TABLE

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

TABLE

(HTML 3.2) – Table

Элемент для создания таблицы. Обязательно должен иметь начальный и конечный теги. По умолчанию таблица печатается без рамки, а разметка осуществляется автоматически в зависимости от объема содержащейся в ней информации. Ячейки внутри таблицы создаются с помощью элементов TR, TD, TH и CAPTION.

Атрибуты:

ALIGN – определяет способ горизонтального выравнивания таблицы. Возможные значения: left, center, right. Значение по умолчанию – left.

VALIGN – должен определять способ вертикального выравнивания таблицы. Возможные значения: top, bottom, middle.

BORDER – определяет ширину внешней рамки таблицы (в пикселах). При BORDER="0" или при отсутствии этого атрибута рамка отображаться не будет.

CELLPADDING – определяет расстояние (в пикселах) между рамкой каждой ячейки таблицы и содержащимся в ней материалом.

CELLSPACING – определяет расстояние (в пикселах) между границами соседних ячеек.

WIDTH – определяет ширину таблицы. Ширина задается либо в пикселах, либо в процентном отношении к ширине окна браузера. По умолчанию этот атрибут определяется автоматически в зависимости от объема содержащегося в таблице материала.

HEIGHT – определяет высоту таблицы. Высота задается либо в пикселах, либо в процентном отношении к высоте окна браузера. По умолчанию этот атрибут определяется автоматически в зависимости от объема содержащегося в таблице материала.

BGCOLOR – определяет цвет фона ячеек таблицы. Задается либо RGB-значением в шестнадцатиричной системе, либо одним из 16 базовых цветов.

BACKGROUND – позволяет заполнить фон таблицы рисунком. В качестве значения необходимо указать URL рисунка.

Примеры таблиц

Примечания:

 Если атрибут HEIGHT указать равным 100%, то старые версии Internet Explorer будут создавать таблицу высотой чуть превышающей высоту окна браузера. Чтобы этого избежать, можно пожертвовать рамкой таблицы, указав BORDER="0".

Старые версии Netscape работают некорректно, если ширина и высота таблицы равны 100%. В этом случае вокруг таблицы остается свободное пространство.

Атрибут VALIGN работает очень загадочно. Скорее, вообще не работает.

Атрибут ALIGN не работает в старых версиях браузера Internet Explorer. Чтобы осуществить желаемое выравнивание таблицы, нужно поместить ее между тегами элемента DIV:
Пример:
<DIV ALIGN="center">
    <TABLE WIDTH="70">
    ...
    </TABLE>
</DIV>


TD и TH

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

TD и TH

(HTML 3.2) – Table Data & Table Head

Элемент TD создает ячейку с данными в текущей строке. Элемент TH также создает ячейку, но определяет ее как ячейку-заголовок.

Такое разграничение позволяет браузерам оформлять содержимое ячейки-заголовка и ячеек с данными разными шрифтами. Кроме того, должна улучшиться работа браузеров, использующих речевой интерфейс. В качестве содержимого ячейки можно использовать другие таблицы.

Атрибуты:

ALIGN – определяет способ горизонтального выравнивания содержимого ячейки. Возможные значения: left, center, right. По умолчанию способ выравнивания определяется значением атрибута ALIGN элемента TR. Если же и он не задан, то для TD выполняется выравнивание по левому краю, а для TH – центрирование.

VALIGN – определяет способ вертикального выравнивания содержимого ячейки. Возможные значения: top, bottom, middle. По умолчанию происходит выравнивание по центру (VALIGN="middle"), если значение этого атрибута не было задано ранее в элементе TR.

WIDTH – определяет ширину ячейки. Ширина задается в пикселах или в процентном отношении к ширине таблицы.

HEIGHT – определяет высоту ячейки. Высота задается в пикселах или в процентном отношении к высоте таблицы.

COLSPAN – определяет количество столбцов, на которые простирается данная ячейка. По умолчанию имеет значение 1.

ROWSPAN – определяет количество рядов, на которые простирается данная ячейка. По умолчанию имеет значение 1.

NOWRAP – блокирует автоматический перенос слов в пределах текущей ячейки. Обратите внимания на примечание, касающееся использования данного атрибута (далее, внизу страницы).

BGCOLOR – определяет цвет фона ячейки. Задается либо RGB-значением в шестнадцатиричной системе, либо одним из 16 базовых цветов.

BACKGROUND – заполняет ячейку фоновым рисунком. Необходимо указать URL рисунка. Данный атрибут не работает в старых версиях браузера Netscape (до 3.X включительно).

Примеры таблиц

Примечания:

 Границы ячейки отображаются только в том случае, когда она имеет некое содержание. Чтобы получить пустую ячейку с границами, достаточно поместить в нее специальный символ &nbsp; или маленькую прозрачную gif-картинку.

Если вы используете одновременно атрибуты NOWRAP и WIDTH="x", где x – маленькое число, то следует дополнительно вставлять внутрь ячейки <NOBR>
Пример:
<!-- Так делать неправильно -->
<TABLE border=1>
    ...
    <TR><TD WIDTH=5 NOWRAP>Текст, который не должен переноситься</TD></TR>
    ...
</TABLE>

<!-- А вот так &#150; правильно и работает всегда -->
<TABLE border=1>
    ...
    <TR><TD WIDTH=5 NOWRAP><NOBR>Текст, который не будет переноситься</NOBR></TD></TR>
    ...
</TABLE>
Дело в том, что в браузерах Internet Explorer для полной отмены переноса слов используется именно <NOBR>, а атрибут NOWRAP действует только при отсутствии WIDTH.

Атрибут HEIGHT, указанный в процентном отношении, работает нормально лишь в том случае, когда явно задана высота всей таблицы.

Один из наиболее распространенных приемов web-дизайнера – "таблица в таблице". Для этого достаточно расположить одну таблицу внутри ячейки другой. Таким образом можно создавать даже очень сложные вложенные "каркасы" дизайна страницы.


TR

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

TR

(HTML 3.2) – Table Row

Создает новый ряд (строку) ячеек таблицы. Ячейки в ряду создаются с помощью элементов TD и TH

Атрибуты:

ALIGN – определяет способ горизонтального выравнивания содержимого всех ячеек данного ряда. Возможные значения: left, center, right.

VALIGN – определяет способ вертикального выравнивания содержимого всех ячеек данного ряда. Возможные значения: top, bottom, middle.

BGCOLOR – определяет цвет фона для всех ячеек данного ряда. Задается либо RGB-значением в шестнадцатиричной системе, либо одним из 16 базовых цветов.

Примеры таблиц


Примеры таблиц

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

Примеры таблиц

Пример 1:
<TABLE BORDER>
  <TR>
    <TH ROWSPAN=2>HDD</TH>
    <TD>WD Caviar 3.1Gb</TD><TD ALIGN="right">85$</TD>
  </TR>
  <TR>
    <TD>Quantum FB ST 6.4Gb</TD><TD ALIGN="right">110$</TD>
  </TR>
</TABLE>

Результат:

HDD | WD Caviar 3.1Gb | 85$
 | Quantum FB ST 6.4Gb | 110$

Пример 2:
<TABLE BORDER>
    <TR>
        <TH COLSPAN=2>Video</TH>
    </TR>
    <TR>
        <TD>Matrox G400</TD><TD ALIGN="right">115$</TD>
    </TR>
    <TR>
        <TD>Voodoo III</TD><TD ALIGN="right">129.95$</TD>
    </TR>
</TABLE>

Результат:

Video
Matrox G400 | 115$
Voodoo III | 129.95$


ADDRESS

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

ADDRESS

(HTML 2.0) – Address

Находящийся между начальным и конечным тегами текст оформляется как почтовый адрес. Чаще всего оформление выражается в выделении строки адреса курсивом.

Пример:
Пишите по следующему адресу:
<ADDRESS>
    Москва. ул. Академика Королева, 13 <BR>
    Мурзилке
</ADDRESS>

Примечание:

 Internet Explorer версии 3.0 неверно интерпретирует конечный тег </ADDRESS>, поэтому весь текст, находящийся после адреса, будет отображаться курсивом. Эту ошибку можно легко устранить, поставив после </ADDRESS> любой элемент форматирования текста.
Пример:
<ADDRESS>
    Мой адрес не дом и не улица, <BR>
    Мой адрес &#150; Советский Союз.
</ADDRESS>
<!-- избавляемся от глюка -->
<I></I>
Нормальный текст
...


BLOCKQUOTE

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

BLOCKQUOTE

(HTML 2.0) – Block Quote

Оформляет находящийся между начальным и конечным тегами текст как цитату. Используется для длинных цитат (в отличие от элемента CITE). Цитируемый текст отображается отдельным абзацем с увеличенным отступом.

Пример:
Редакция журнала "Домосед" выражает благодарность
Бухаресту Магарычу Шницелю за замечательное стихотворение:
<BLOCKQUOTE>
    Синели красные ромашки,<BR>
    Желтели в небе облака,<BR>
    Синицы в теплый край летели,<BR>
    К истоку двигалась река.<BR>
    ...
</BLOCKQUOTE>


BR

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

BR

(HTML 2.0) – Break

Данный элемент осуществляет перевод строки, то есть практически аналогичен нажатию Enter в текстовом редакторе. После того, как в браузерах появилась возможность обтекания изображения текстом (cм. атрибут ALIGN элемента IMG), понадобился дополнительный атрибут CLEAR. Элемент не имеет конечного тега.

Атрибуты:

CLEAR – указывает на необходимость завершения обтекания изображения текстом. Может принимать следующие значения :

    all – завершить обтекание изображения текстом.
    left – завершить обтекание текстом изображения, выровненного по левому краю.
    right – завершить обтекание текстом изображения, выровненного по правому краю.

Пример:
Первое предложение<BR>Второе предложение на следующей строке

Примечание:

 Возьмите себе за правило всегда ставить <br> после тега <img ...>. В противном случае все картинки будут иметь неприятный отступ.

Атрибут CLEAR почему-то используется очень редко. А зря.


DIV

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

DIV

(HTML 3.2) – Division

Используется для логического выделения блока HTML-документа. Элемент группировки, как и элемент SPAN. В современном сайтостроении используется как удобный контейнер для объектов страницы, которым легко динамически манипулировать – перемещать, включать/выключать, создавать слои, регулировать отступы и т.п.

В браузеронезависимой вёрстке обычно используется для выравнивания блока html-кода в окне браузера.

Находящиеся между начальным и конечным тегами текст или HTML-элементы по умолчанию оформляются как отдельный параграф.

Атрибуты:

ALIGN – определяет выравнивание содержимого элемента DIV. Атрибут может принимать значения: left, right, center.

Пример:
...Текст документа...
<DIV ALIGN="center">
...Текст, таблицы, изображения. Выравнивание по центру.
</DIV>
...Текст документа...

Примечания:

 У атрибута ALIGN есть еще одно значение – justify, поддерживаемое современными браузерами. Оно позволяет выравнивать текст по ширине (одновременно по левому и правому краям документа). Не понимающие justify браузеры будут выравнивать текст по левому краю.


H1,H2,...H6

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

H1,H2,...H6

(HTML 2.0) – Headers

Используются для создания заголовков текста. Существует шесть уровней заголовков, различающихся величиной шрифта. С их помощью можно разбивать текст на смысловые уровни – разделы и подразделы.

Атрибуты:

ALIGN – определяет способ выравнивания заголовка по горизонтали.
Возможные значения: left, right, center.

Пример:
<H1 ALIGN="center">Самый большой заголовок посередине</H1>
<H2>Заголовок поменьше</H2>
...
<H6>Малюююсенький такой заголовочек</H6>


HR

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

HR

(HTML 2.0) – Horisontal Rule

Вставляет в текст горизонтальную разделительную линию.

Атрибуты:

WIDTH – определяет длину линии в пикселах или процентах от ширины окна браузера.

SIZE – определяет толщину линии в пикселах.

ALIGN – определяет выравнивание горизонтальной линии. Атрибут может принимать следующие значения:

    left – выравнивание по левому краю документа.
    right – выравнивание по правому краю документа.
    center – выравнивание по центру документа (используется по умолчанию).

NOSHADE – определяет способ закраски линии как сплошной. Атрибут является флагом и не требует указания значения. Без данного атрибута линия отображается объемной.

COLOR – определяет цвет линии. Задается либо RGB-значением в шестнадцатиричной системе, либо одним из 16 базовых цветов. Атрибут работает только в Internet Explorer.

Пример:
Текст, разделенный <HR NOSHADE WIDTH="50%"> сплошной горизонтальной линией.


LISTING, PLAINTEXT, XMP

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

LISTING, PLAINTEXT, XMP

Данные элементы предназначены для воспроизведения предварительно отформатированного текста. Они использовались до появления элемента PRE и на данный момент являются устаревшими.

Эти элементы не вошли в спецификацию HTML 4.0, однако браузеры еще могут распозновать их в целях обратной совместимости версий.


P

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

P

(HTML 2.0) – Paragraph

Используется для разметки параграфов.

Атрибуты:

ALIGN – определяет способ горизонтального выравнивания параграфа.
Возможные значения: left, center, right. По умолчанию имеет значение left.

Пример:
<P ALIGN="center">Это центрированный параграф.<BR>
Текст располагается в центре окна браузера</P>

<P ALIGN="right">А это параграф, выровненный по правому краю.</P>


PRE

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

PRE

(HTML 2.0) – Preformatted Text

Используется для включения в документ уже отформатированного текста. Браузеры воспроизводят содержимое этого элемента с помощью моноширинного шрифта, сохраняя пробелы и символы конца строки.

Пример:
<PRE>
Ать!
    Два!
        Три!
</PRE>

Примечание:

 Желательно избегать использования символа горизонтальной табуляции внутри PRE, т.к. он может быть неадекватно интерпретирован некоторыми браузерами. Вместо символа табуляции рекомендуется использовать число пробелов, кратное четырем.


B

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

B

(HTML 3.2) – Bold

Текст, заключенный между начальным и конечным тегами, будет выделен жирным шрифтом.

Пример:
Текст с <B>выделенным</B> словом


BASEFONT

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

BASEFONT

(HTML 4.0) – Base Font

Не имеет конечного тега. Определяет основной шрифт, которым должен отображаться текст документа.
Впоследствии вы можете легко изменить шрифт в любой части документа, используя элемент FONT. Действие элемента BASEFONT не распространяется на текст, заключенный в ячейки таблиц.

Атрибуты:

SIZE – обязательный атрибут. Определяет базовый размер шрифта. Возможные значения : целые числа от 1 до 7 включительно.

FACE – определяет используемый шрифт (гарнитуру).

Пример:
<BODY>
<BASEFONT SIZE="3">
...
Текст документа шрифтом 3 размера
...
    <FONT SIZE="+1">
    Слегка увеличиваем шрифт
    </FONT>
...
Продолжаем шрифтом 3 размера
...
</BODY>

Примечание:

 Атрибут FACE игнорируется большинством браузеров. Если вы хотите явно указать тип шрифта для всего документа, используйте элемент FONT:
Пример:
<BODY>
<FONT FACE="Arial">
...
Основной текст документа шрифтом Arial
...
    <FONT FACE="Times" SIZE="5">
    Вставка текста увеличенным шрифтом Таймс
    </FONT>
...
Продолжается основной текст документа шрифтом Arial
...
</FONT>
</BODY>


BIG

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

BIG

(HTML 3.2) – Big

Текст, заключенный между начальным и конечным тегами, отображается увеличенным шрифтом (относительно текущего).

Пример:
Текст с <BIG>увеличенным</BIG> словом

Примечание:

 Тег <BIG> аналогичен по действию тегу <FONT SIZE="+1"> (см. элемент FONT).


CITE

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

CITE

(HTML 2.0) – Citation

Оформляет находящийся между начальным и конечным тегами текст как цитату или ссылку на источник. Обычно используется для коротких цитат (в отличие от элемента BLOCKQUOTE). Цитируемый текст отображается курсивом.

Пример:
Как сказал классик:<BR>
<CITE>"Грамотное написание HTML способствует пищеварению"</CITE>


CODE, SAMP

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

CODE, SAMP

(HTML 2.0) – Code, Sample

Данные элементы оформляют текст, находящийся между начальным и конечным тегами, как формулу или программный код. Текст при этом как правило отображается моноширинным шрифтом.

Пример:
Формула: <CODE> n=((x*15-z/1.25)/4)^5 </CODE>


EM

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

EM

(HTML 2.0) – Emphasis

Логическое ударение. Используется для смыслового выделения текста, стоящего между начальным и конечным тегами. Результат обычно отображается курсивом. То есть элемент EM по действию практически аналогичен элементу I.

Пример:
Порой в России встречаются <EM>действительно талантливые</EM> веб-мастера. Но только не друг с другом.

Примечание:

 Согласно рекомендациям W3C, приветствуется использование <EM> вместо <I>.


FONT

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

FONT

(HTML 3.2) – Font

Позволяет изменять цвет, размер и тип шрифта текста, находящегося между начальным и конечным тегами. Вне тегов <FONT> и </FONT> используется шрифт, указанный в элементе BASEFONT.

Атрибуты:

SIZE – определяет размер шрифта. Возможные значения:

    – целое число от 1 до 7;
    – относительный размер с указанием знака, вычисляется путем сложения с базовым размером, определенным с помощью атрибута SIZE элемента BASEFONT.

COLOR – определяет цвет текста. Задается либо RGB-значением в шестнадцатиричной системе, либо одним из 16 базовых цветов.

FACE – определяет используемый шрифт.

Пример:
<FONT SIZE="+2" COLOR="#AA0000">Увеличенный красный шрифт</FONT>
<FONT SIZE="3" FACE="Courier New" COLOR="Magenta">Моноширинный фиолетовый текст 3 размера</FONT>

Примечание:

 Атрибут FACE старайтесь не использовать. Если на компьютере пользователя не окажется указанного шрифта – глюки неизбежны. Если указать шрифт всё же необходимо, используйте только: Times New Roman, Arial, Tahoma, Courier, Courier New. Они установлены почти у всех.

Будьте внимательны. Многие элементы форматирования текста (PRE, CODE, KBD, SAMP...), расположенные внутри элемента FONT, работают некорректно.


I

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

I

(HTML 2.0) – Italic

Текст, заключенный между начальным и конечным тегами, будет выделен курсивом.

Пример:
Текст с <I>курсивом</I>


KBD

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

KBD

(HTML 2.0) – Keyboard

Предназначен для отображения текста, который пользователь должен набрать на клавиатуре (например, при заполнении формы, введении пароля и т.п.). Как правило текст, заключенный между начальным и конечным тегами, выделяется жирным моноширинным шрифтом.

Пример:
Чтобы войти в систему наберите <KBD>"GUEST"</KBD> заглавными буквами.


S, STRIKE

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

S, STRIKE

(HTML 2.0) – Strike

Элемент STRIKE отображает помещенный между начальным и конечным тегами текст как перечеркнутый. В HTML 3.2 вместо <STRIKE> был предложен более краткий тег <S>.

Пример:
Лена + <STRIKE>Вася</STRIKE> Коля = Love


SMALL

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

SMALL

(HTML 3.2) – Small

Текст, заключенный между начальным и конечным тегами, отображается уменьшенным шрифтом (относительно текущего).

Пример:
Небоскребы, небоскребы, а я <SMALL>маленький</SMALL> такой.

Примечание:

 Тег <SMALL> аналогичен по действию тегу <FONT SIZE="-1"> (см. элемент FONT).


STRONG

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

STRONG

(HTML 2.0) – Stronger emphasis

Усиленное выделение. Текст, заключенный между начальным и конечным тегами, будет выделен жирным шрифтом. То есть элемент STRONG практически аналогичен по действию элементу B.

Пример:
Я <STRONG>сильный</STRONG>, но легкий.

Примечание:

 Согласно рекомендациям W3C, приветствуется использование <STRONG> вместо <B>.


SUB

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

SUB

(HTML 2.0) – Subscript

Отображает текст со сдвигом вниз (нижний индекс) и уменьшением размера текущего шрифта на единицу.

Пример:
X<SUB>i</SUB> = B<SUB>i</SUB> + C<SUB>i</SUB>


SUP

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

SUP

(HTML 2.0) – Superscript

Отображает текст со сдвигом вверх (верхний индекс) и уменьшением размера текущего шрифта на единицу.

Пример:
Microsoft <SUP>TM</SUP>


TT

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

TT

(HTML 2.0) – Tele Type

Данный элемент отображает помещенный между начальным и конечным тегами текст моноширинным шрифтом.

Пример:
<TT>СЕНЯ ЗПТ ТВОЮ МАТЬ ТЧК ПОДРОБНОСТИ В ПИСЬМЕ ТЧК</TT>


U

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

U

(HTML 2.0) – Underline

Данный элемент отображает помещенный между начальным и конечным тегами текст как подчеркнутый.

Пример:
<U> Подчеркнутый текст </U>


VAR

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

VAR

(HTML 2.0) – Variable

Элемент VAR предназначен для обозначения в тексте переменных. Как правило, отображается курсивом.

Пример:
Переменная <VAR>IndexZ</VAR> равна 5.


BODY

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

BODY

(HTML 2.0) – Body

Указывает начало и конец тела HTML-документа. Между начальным и конечным тегами содержится текст документа, изображения и таблицы. Одним словом, все HTML-элементы, отвечающие за отображение документа, управление им и гипертекстовые ссылки. Элемент BODY должен встречаться в документе не более одного раза.

Атрибуты:

MARGINHEIGHT – определяет ширину (в пикселах) верхнего и нижнего полей документа. Работает только в браузерах Netscape.

TOPMARGIN – определяет ширину (в пикселах) верхнего и нижнего полей документа. Работает только в браузерах Internet Explorer.

MARGINWIDTH – определяет ширину (в пикселах) левого и правого полей документа. Работает только в браузерах Netscape.

LEFTMARGIN – определяет ширину (в пикселах) левого и правого полей документа. Работает только в браузерах Internet Explorer.

BACKGROUND – определяет изображение для "заливки" фона. Значение задается в виде полного URL или имени файла с картинкой в формате GIF или JPG.

BGCOLOR – определяет цвет фона документа.

TEXT – определяет цвет текста в документе.

LINK – определяет цвет гиперссылок в документе.

ALINK – определяет цвет подсветки гиперссылок в момент нажатия.

VLINK – определяет цвет гиперссылок на документы, которые вы уже просмотрели.

Значения атрибутов BGCOLOR, TEXT, LINK, ALINK и VLINK задаются либо RGB-значением в шестнадцатиричной системе, либо одним из 16 базовых цветов.

Пример:
<HTML>
<BODY BACKGROUND="images/bricks.jpg" BGCOLOR="#202020" TEXT="#FFFFFF" LINK="#FF0000" VLINK="#505050" MARGINHEIGHT="30" TOPMARGIN="30" LEFTMARGIN="40" MARGINWIDTH="40">
...
Текст документа.
...
</BODY>
</HTML>

Примечания:

 При задании ширины полей для обеспечения совместимости со всеми видами браузеров используйте одновременно атрибуты MARGINWIDTH/MARGINHEIGHT и TOPMARGIN/LEFTMARGIN как показано в примере.

Всегда указывайте атрибуты BGCOLOR и TEXT одновременно. Считайте, что они неразлучны. Если один из этих атрибутов не указан, браузер по умолчанию будет использовать цвет из текущей цветовой схемы Windows. А теперь представьте, что будет, если пользователь использует нестандартную раскраску Windows, где все цвета инвертированы? То-то. Некрасиво получится.


Гиперссылки

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

Гиперссылки

Ссылки на другие документы в HTML создаются либо с помощью элемента A, либо с помощью навигационных карт.
Элемент A применяется, если ссылкой планируется сделать часть текста или целое изображение. Навигационные карты имеет смысл применять, если ссылкой будет часть изображения.

ССЫЛКИ НА ДРУГИЕ САЙТЫ ПО ДАННОЙ ТЕМАТИКЕ
- Краткий экскурс в историю гипертекста (А.Лебедев)


Объекты

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

Объекты

Объекты – это графические и мультимедийные вставки в HTML-документ, такие как картинки, Flash-анимация, Java-апплеты, звуки, музыка, VRML.

Элементы:
- | IMG | Используется для вставки в HTML изображений
- | EMBED | Используется для вставки в HTML различных объектов
- | NOEMBED | Используется, если браузер не поддерживает элемент EMBED
- | APPLET | Используется для вставки в HTML Java-апплетов
- | PARAM | Используется для передачи параметров Java-программе (см. элемент APPLET)


Списки

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

Списки

Списки в HTML бывают двух видов: упорядоченные (пронумерованные) и неупорядоченные (непронумерованные). Отличаются они лишь способом оформления. Перед пунктами неупорядоченных списков обычно ставятся символы-буллеты (bullets), например, точки, ромбики и т.п., в то время как пунктам упорядоченных списков предшествуют их номера.

Элементы:
- | UL | Создает неупорядоченный список
- | OL | Создает упорядоченный список
- | LI | Создает пункт меню внутри элементов OL или UL
- | MENU, DIR | Создает неупорядоченный список, подобный UL
- | DL | Открывает и закрывает список определений
- | DT | Создает термин в списке определений внутри элемента DL
- | DD | Cоздает определение термина внутри элемента DL


Таблицы

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

Таблицы

Элементы для создания таблиц:

Таблицы в HTML формируются нетрадиционным способом – построчно. Сначала c помощью элемента TR необходимо создать ряд таблицы, в который затем элементом TD помещаются ячейки.

Важно:

В HTML таблицы используются не только для отображения таблиц как таковых, но и для дизайна. С помощью таблиц можно создать невидимый "каркас" страницы, помогающий расположить текст и изображения так, как вам нравится.

Элементы для создания таблиц:
- | TABLE | Создает таблицу
- | CAPTION | Задает заголовок таблицы
- | TR | Создает новый ряд (строку) ячеек таблицы
- | TD и TH | Создает ячейку с данными в текущей строке
- | Примеры таблиц |

Пример:
<TABLE BORDER>
    <TR>
        <TD>A1</TD> <TD>B1</TD> <TD>C1</TD>
    </TR>
    <TR>
        <TD>A2</TD> <TD>B2</TD> <TD>C2</TD>
    </TR>
</TABLE>

Результат:
A1 | B1 | C1
A2 | B2 | C2

Примеры таблиц


Текстовые блоки

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

Текстовые блоки

В этом разделе описаны элементы, разбивающие текст документа на блоки тем или иным способом. Типичными примерами текстовых блоков являются параграфы, абзацы и главы. Для отделения одной части текста от другой также используются разделительные горизонтальные линии и символы возврата каретки.

Элементы:
- | H1,H2,...H6 | Используются для создания заголовков текста
- | P | Используется для разметки параграфов.
- | DIV | Отделяет блок HTML-документа от остальной его части
- | ADDRESS | Оформляет текст как почтовый адрес
- | BLOCKQUOTE | Оформляет текст как цитату
- | BR | Осуществляет перевод строки
- | HR | Вставляет в текст горизонтальную разделительную линию.
- | PRE | Включает в документ (моноширинным шрифтом) блок предварительно отформатированного текста
- | LISTING, PLAINTEXT, XMP | Включают в документ (моноширинным шрифтом) блок предварительно отформатированного текста (устаревшие элементы)


Форматирование текста

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

Форматирование текста

В этом разделе описаны элементы для оформления и смыслового выделения текста – подчеркивания, изменения шрифта, выделения курсивом, цитирования и т.д.

Элементы форматирования текста:
- | BASEFONT | Определяет основной шрифт, которым должен отображаться текст документа
- | FONT | Позволяет изменять цвет, размер и тип шрифта текста
- | I | Выделяет текст курсивом
- | EM | Используется для смыслового выделения текста (курсивом)
- | B | Выделяет текст жирным шрифтом
- | STRONG | Усиленное выделение текста (жирным)
- | U | Выделяет текст подчеркнутым
- | S, STRIKE | Выделяет текст перечеркнутым
- | BIG | Отображает текст увеличенным шрифтом (относительно текущего)
- | SMALL | Отображает текст уменьшенным шрифтом (относительно текущего)
- | SUP | Отображает текст со сдвигом вверх (верхний индекс)
- | SUB | Отображает текст со сдвигом вниз (нижний индекс)
- | CODE, SAMP | Оформляют текст как формулу или программный код
- | TT | Отображает текст моноширинным шрифтом
- | KBD | Выделяет текст, который предлагается набрать на клавиатуре
- | VAR | Используется для обозначения в тексте переменных
- | CITE | Оформляет текст как цитату или ссылку на источник


Формы

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

Формы

С помощью описанных ниже элементов вы можете создавать заполняемые анкеты, опросники и различные поля для ввода текста пользователем с возможностью последующей отправки заполненной формы на ваш сервер.

Элементы для создания форм:
- | FORM | Создает заполяемую форму
- | TEXTAREA | Создает поле для ввода нескольких строк текста
- | SELECT | Создает меню в заполняемой форме
- | OPTION | Создает отдельные пункты в меню (см. SELECT)
- | INPUT | Создает поле в форме


FRAME

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

FRAME

(HTML 4.0) – Frame
Определяет фрейм и его свойства внутри FRAMESET-структуры. (см. элемент FRAMESET)

Атрибуты:

SRC – обязательный атрибут. Указывает адрес (URL) HTML-файла, отображаемого в данном фрейме.

NAME – определяет имя данного фрейма, которое будет в дальнейшем использоваться для ссылки на него из других документов с помощью атрибута TARGET (см. элемент A). В качестве значения нужно указать любое имя без пробелов с использованием латинских символов и цифр. Имя не должно начинаться с цифр и специальных символов.

MARGINWIDTH – определяет ширину (в пикселах) левого и правого полей фрейма. Если атрибут не указан, браузер самостоятельно определит оптимальный размер отступа.

MARGINHEIGHT – определяет ширину (в пикселах) верхнего и нижнего полей фрейма. Если атрибут не указан, браузер самостоятельно определит оптимальный размер отступа.

SCROLLING – определяет наличие линеек прокрутки содержимого фрейма. Возможные значения:

    yes – отображать линейки прокрутки.
    no – не отображать линейки прокрутки.
    auto – отображать линейки прокрутки при необходимости (если документ, указанный в атрибуте SRC, не умещается во фрейме).

NORESIZE – не позволяет изменять размеры фрейма. Данный атрибут является флагом и не требует указания значения.

FRAMEBORDER – определяет наличие рамок у фрейма. Возможные значения:

    yes – отображать рамки;
    no или 0 – не отображать рамки;

Браузеры Netscape не поддерживают данный атрибут в полной мере и для глобального определения ширины рамок используют атрибут BORDER элемента FRAMESET.

Пример (файл index.html):
...
<FRAMESET FRAMEBORDER="0" FRAMESPACING="0" BORDER="0" COLS="265,*">
    <FRAME SRC="frame1.html" NAME="page">
    <FRAMESET ROWS="165,*">
        <FRAME SRC="frame2.html" NAME="menu1" MARGINWIDTH="0">
        <FRAME SRC="frame3.html" NAME="menu2" MARGINWIDTH="0">
    </FRAMESET>
    <NOFRAMES>Ваш браузер не поддерживает фреймы</NOFRAMES>
</FRAMESET>

<BODY>
</BODY>
...

В результате окно браузера разделится на три фрейма, как показано ниже. Причем frame1.html будет иметь ширину 265 пикселов, а frame2.html – высоту 165.

Окно с фреймами


FRAMESET

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

FRAMESET

(HTML 4.0) – Frame Set

Определяет фреймовую (оконную) структуру документа: размеры и расположение фреймов на странице. Создаётся вместо тела документа (то есть элемент BODY в документе не используется).
Открывает и закрывает список фреймов, определяемых с помощью элемента FRAME. Между начальным и конечным тегами кроме элементов FRAME и NOFRAMES могут находиться другие элементы FRAMESET. То есть элемент FRAMESET поддерживает вложенные конструкции фреймов.

Атрибуты:

ROWS – определяет количество и размеры горизонтальных фреймов (фреймов-строк) в окне браузера. В качестве значения задается список размеров фреймов через запятую. Способы задания размеров:

    • в процентах от высоты рабочей области окна браузера. Например: "30%,30%,40%";
    • в виде знака "*" (звездочка), говорящего о том, что фрейм занимает все свободное пространство окна браузера, незанятое другими фреймами с явно указанными размерами. Например, звездочка в записи "25%,25%,*" равносильна 50%;
    • в пикселах. Например: "75,*";

Все три способа можно совмещать. Например, "25%,40,*" разобъет экран на три горизонтальных фрейма, первый из которых будет высотой в четверть окна браузера, второй – в 40 пикселов, а третий займет всю оставшуюся площадь.

COLS – определяет количество и размеры вертикальных фреймов (фреймов-столбцов) в окне браузера. В качестве значения задается список размеров фреймов через запятую. Размеры задаются так же, как и в предыдущем атрибуте ROWS.

BORDER – определяет ширину рамок фреймов в пикселах. Данный атрибут действует только в браузерах Netscape;

FRAMEBORDER – определяет наличие рамок у содержащихся внутри FRAMESET фреймов. Возможные значения:

    Yes – отображать рамки;
    No или 0 – не отображать рамки;

Браузеры Netscape не поддерживают данный атрибут в полной мере и для глобального определения ширины рамок используют атрибут BORDER.

FRAMESPACING – определяет расстояние (так называемую "серую область") между фреймами в пикселах. Данный атрибут необходим для создания фреймов без рамок.

Примечание:

 Обратите внимание на то, что FRAMESET-структура создаётся вместо элемента BODY. FRAMESET-структура, расположенная в заголовке (внутри элемента HEAD) считается ошибкой.


NOFRAMES

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

NOFRAMES

(HTML 4.0) – No Frames

Все, что находится между начальным и конечным тегами данного элемента, будет отображено браузером, если он не поддерживает фреймы. Элемент NOFRAMES не имеет атрибутов и должен находиться внутри элемента FRAMESET.

Пример:
<FRAMESET ROWS="*,*">
<NOFRAMES>Ваш браузер не поддерживает фреймы. Обыдно, да?</NOFRAMES>
    <FRAME SRC="frame1.html">
    <FRAME SRC="frame2.html">
</FRAMESET>


BASE

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

BASE

(HTML 3.2) – Base URL

Указывает базовый адрес текущего документа (URL), который станет отправной точкой для расчета относительных адресов внутри документа. Элемент не имеет конечного тега. Обязательно присутствие хотя бы одного из атрибутов.

Атрибуты:

HREF – определяет базовый адрес (URL) текущего документа.

TARGET – определяет имя фрейма, которое будет использоваться в гиперссылках по умолчанию. Это может вам пригодиться, если вы хотите открывать все ссылки документа в другом фрейме.

Пример:
<HEAD>
    <!-- Пусть браузер думает, что находится по адресу : -->
    <BASE HREF="http://www.igf.ru/other/index.html">
    <TITLE>Руководство по эксплуатации</TITLE>
</HEAD>
...
<!-- А теперь создадим относительную ссылку на документ -->
<!-- http://www.igf.ru/list.html -->
<A HREF="../list.html">Список</A>
...


HEAD

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

HEAD

(HTML 1.0) – Head

Определяет начало и конец заголовка документа. Является контейнером для элементов, содержащих техническую информацию о документе. (TITLE,BASE,STYLE,LINK,META).

Пример:
<HTML>
<!-- Начинаем заголовок... -->
<HEAD>
    <title>Справочник по HTML</title>
</HEAD>
<!-- ...кончили. Дальше пошло тело документа -->

<BODY>
Текст документа
</BODY>

</HTML>


LINK

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

LINK

(HTML 2.0) – Link

Элемент LINK описывает взаимосвязь документа с другими документами на сайте, указывая его место в иерархической структуре сайта. Элемент не имеет конечного тега. В заголовке может содержаться несколько элементов LINK.

Атрибуты:

HREF – определяет URL объекта.

REL – определяет тип взаимосвязи текущего документа с объектом, определенным атрибутом HREF. Возможные значения:

    stylesheet – указывает на файл, содержащий таблицу стилей (CSS) для текущего документа. Браузер загрузит css-файл с указанного в атрибуте HREF адреса и применит его к текущему документу (см. также элемент STYLE)
    home – указывает на заглавную страницу вашего сайта
    toc, contents – указывают на файл, содержащий оглавление данного документа.
    index – указывает на файл, содержащий информацию для индексного поиска по текущему документу.
    glossary – указывает на файл, содержащий перечень терминов, относящихся к текущему документу.
    copyright – указывает на страницу сайта, в которой говорится о его создателях, авторских правах и т.п.
    up, parent – указывает на "родительскую" страницу (документ, стоящий на ступеньку выше в иерархической структуре вашего сайта).
    child – указывает на "дочернюю" страницу (документ, стоящий на ступеньку ниже в иерархической структуре вашего сайта).
    next – указывает на следующую страницу в последовательности документов (напр. следующую страницу электронного каталога, документации или словаря).
    previous – указывает на предыдущую страницу в последовательности документов.
    last, end – указывает на последнюю страницу в последовательности документов.
    first – указывает на первую страницу в последовательности документов.
    help – указывает на страницу с подсказкой (напр. по навигации по вашему сайту).

TYPE – определяет MIME-тип для объекта, указанного в атрибуте HREF.

Пример 1:
<HEAD>
    <TITLE>Элемент DIV</TITLE>
    <LINK REL="HOME" TITLE="HTML-справочник" HREF="index.html">
    <LINK REL="UP" TITLE="Текстовые блоки" HREF="textblocks.html">
    <LINK REL="PREVIOUS" TITLE="Элемент P" HREF="p.html">
    <LINK REL="NEXT" TITLE="Элемент ADDRESS" HREF="address.html">
</HEAD>

Пример 2:
<HEAD>
    <TITLE>Полдневье</TITLE>
    <LINK REL="stylesheet" TYPE="text/css" HREF="deco1.css">
</HEAD>

Примечания:

 Элемент LINK, к сожалению, используется web-мастерами довольно редко, чаще всего только для внедрения CSS из отдельного файла. Почти все браузеры игнорируют информацию о положении документа в структуре сайта – эта информация интересна только индексирующим роботам поисковых систем.


META

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

META

(HTML 2.0) – Meta

Элемент МЕТА используется для техописания документа, которое представляет собой метаданные в виде пары "имя-значение". С помощью этого элемента в заголовок документа внедряется дополнительная полезная информация, невидимая для пользователя, но порой просто незаменимая для правильной индексации вашей страницы роботами поисковых серверов. Элемент не имеет конечного тега.

Атрибуты:

NAME – определяет имя мета-записи. Существует множество предопределенных имен, некоторые из которых вы можете увидеть в указанном ниже примере.

HTTP-EQUIV – определяет имя мета-записи. Практически аналогичен атрибуту NAME, но используется лишь в случае необходимости передачи дополнительной информации в HTTP-заголовке.

CONTENT – присваивает значение мета-записи, определенной в атрибуте NAME (или HTTP-EQUIV).

Пример:
<HEAD>
...
<META HTTP-EQUIV="Expires" CONTENT="Sat, 26 Jun 1999 17:38:15 GMT">
<META NAME="GENERATOR" CONTENT="Greenback">
<META NAME="Publisher-Email" CONTENT="green@igf.ru">
<META NAME="Publisher-URL" CONTENT="Idea GraFix &#150; http://www.igf.ru/">
<META NAME="Keywords" CONTENT="OpenGL,3D,graphics,3Dfx,Permedia,Diamond,графика">
<META NAME="Description" CONTENT="Российский сайт, полностью посвященный 3D-графике, ее разработке и использованию.">
...
</HEAD>

ССЫЛКИ НА ДРУГИЕ САЙТЫ ПО ДАННОЙ ТЕМАТИКЕ
- Бойцы невидимого фронта (Mike Melnikov)
- Использование метаданных при создании HTML документов (www.webclub.ru)


STYLE

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

STYLE

(HTML 3.2) – Style

Используется для вставки в документ таблицы стилей (CSS – Cascade Style Sheet).

Атрибуты:

TYPE – обязательный атрибут. Определяет MIME-тип вставляемого блока стилей. Как правило, значением этого атрибута является "text/css".

TITLE – определяет имя создаваемой таблицы стилей. Необходим, если вы собираетесь использовать несколько элементов STYLE в одном документе. В этом случае браузер должен спросить пользователя, какой из предложенных стилей будет применен к документу.

Пример:
<HEAD>
    <TITLE>Пример использования таблицы стилей</TITLE>
    <!-- Втыкаем табличку стилей -->
    <STYLE TYPE="text/css" TITLE="Cool table">
        <!--
        A {text-decoration : none;}
        P {color : blue; font-size : 12pt; font-family : Arial;}
        H1 {color : red; font-size : 18pt;}
        -->
    </STYLE>
    <!-- ... кончили втыкать -->
</HEAD>

Примечания:

 Практически все популярные браузеры игнорируют атрибут TITLE, поэтому можете его не использовать. А жаль, задумка-то была неплохая...

РЕКОМЕНДУЕМ ПОЧИТАТЬ ПРО CSS:
- Отличное руководство по CSS на MANUAL.RU
- Раздел нашего форума, посвящённый CSS
- Доступное описание CSS (Cascading Style Sheets) (www.citforum.ru)


TITLE

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

TITLE

(HTML 2.0) – Title

Определяет имя всего документа. Имя, как правило, отображается в заголовке окна браузера. Данный элемент обязателен для любого HTML-документа и может быть указан не более одного раза.

Пример:
...
<HEAD>
    <TITLE>Руководство по эксплуатации</TITLE>
</HEAD>
...


AREA

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

AREA

(HTML 3.2) – Map Area

Создает область карты, определенной с помощью элемента MAP. Элемент должен располагаться между начальным и конечным тегами элемента MAP. Не имеет конечного тега.

Атрибуты:

SHAPE – определяет форму навигационной области. Возможные значения:

    rect – прямоугольник;
    circle – окружность;
    poly – многоугольник.
В зависимости от выбранной формы меняется способ задания ее координат в атрибуте COORDS.

COORDS – определяет координаты навигационной области на карте. Используется в паре с атрибутом SHAPE. Способы задания координат для разных типов областей:

    SHAPE="rect" COORDS="левый x, верхний y, правый x, нижний y";
    SHAPE="circle" COORDS="центр x, центр y, радиус";
    SHAPE="poly" COORDS="x1,y1,x2,y2,x3,y3,...";

HREF – определяет область как гипертекстовую ссылку. Значение задается в виде ссылки (URL).

TARGET – определяет окно (фрейм), на которое указывает гипертекстовая ссылка. Этот атрибут используется только совместно с атрибутом HREF. В качестве значения необходимо задать либо имя одного из существующих фреймов (см. элемент FRAME) либо одно из зарезевированных имен, подробно описанных в атрибуте TARGET элемента A.

NOHREF – определяет область как неактивную (невосприимчивую к нажатию). Данный атрибут противоположен атрибуту HREF и используется для отмены действия последнего.

ALT – определяет альтернативный текст-подсказку для данной области.

Пример:
<!-- Создаем хитрую карту с круглой дыркой посередине -->
<MAP NAME="map1">
    <AREA NOHREF SHAPE="circle" COORDS="80,70,40">
    <AREA HREF="guide.html" ALT="Путеводитель" SHAPE="rect" COORDS="0,0,167,140">
</MAP>
...
<!-- Применяем ее к картинке -->
<IMG src="/img/logo.gif" WIDTH="167" HEIGHT="140" BORDER="0" ALT="Путеводитель" USEMAP="#map1">

Примечания:

 В последовательности из нескольких элементов AREA наибольший приоритет имеют те, которые были определены первыми. Они перекрывают области, определенные позже. Именно поэтому в приведенном выше примере сначала создается пассивная область (отверстие) и лишь потом – активная со ссылкой.

Старайтесь всегда указывать атрибут ALT. Пользователи, работающие в текстовом режиме (а таких немало!), скажут вам спасибо.


MAP

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

MAP

(HTML 3.2) – Map

Создает новую навигационную карту. Между начальным и конечным тегами содержит один или несколько элементов AREA, определяющих навигационные области карты.

Атрибуты:

NAME – единственный и обязательный атрибут. Определяет имя навигационной карты, уникальное для данного документа. Используется для вызова карты с помощью атрибута USEMAP элемента IMG. Вы можете указать любое имя без пробелов с использованием латинских символов и цифр.

Пример:
<!-- Создаем карту Map1 : -->
<MAP NAME="Map1">
    <!-- Задаем области -->
    <AREA HREF="...>
    <AREA HREF="...>
    ...
</MAP>
<!-- Карта готова. Применим её к картинке: -->
<IMG SRC="image.gif" USEMAP="#Map1" WIDTH=200 HEIGHT=100 ALT="Картинка">


NOSCRIPT

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

NOSCRIPT

(HTML 4.0) – No Script

Определяет текст, который будет отображен, если браузер по какой-либо причине не работает со скриптами.

Пример:
<SCRIPT LANGUAGE="JavaScript">
    <NOSCRIPT> Пора менять браузер... </NOSCRIPT>
    <!--
    window.location="http://www.igf.ru";
    -->
</SCRIPT>


SCRIPT

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

SCRIPT

(HTML 3.2) – Script

Вставляет скрипт в документ. Сам текст скрипта либо располагается между начальным и конечным тегами, либо определяется как URL файла, содержащего скрипт, в атрибуте SRC.

Атрибуты:

LANGUAGE – определяет язык, на котором написан скрипт, например, JavaScript.

SRC – определяет URL скрипта.

Пример 1:
<SCRIPT LANGUAGE="JavaScript" SRC="http://www.igf.ru/js/script.js">
</SCRIPT>

В целях совместимости со старыми браузерами, содержимое элемента SCRIPT следует заключать между <!-- и -->, т.е. оформлять его как html-комментарий:

Пример 2:
<SCRIPT LANGUAGE="JavaScript">
<!--
window.location="http://www.art-russia.com";
// -->
</SCRIPT>

Где размещать скрипт:

Элемент SCRIPT можно располагать либо в заголовке (внутри элемента HEAD) либо в теле документа (внутри BODY).


<!-- -->

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

<!-- -->

(HTML 1.0) – Comment (<!-- ... -->)

Используется для создания комментариев в любой части документа. Все, что находится внутри <!-- -->, будь то элемент или текст – будет проигнорировано браузером (не будет обрабатываться и выводиться на экран).

Пример:
<HTML>
...
<!-- Начинаем чуткую работу с телом документа -->
<BODY>
<!-- Всталяем табличку с прайс-листом -->
...
</BODY>
<!-- Все. Готово -->
</HTML>

Примечания:

 Комментарии, расположенные внутри элемента TITLE (как, впрочем, и любые другие теги) трактуются как текст и будут видны в заголовке документа. Иначе говоря, тег <!-- --> внутри TITLE не действует.

Не ленитесь комментировать все, что написали. Это волшебное правило сэкономит вам немало времени при попытке разобраться в собственном творении пару месяцев спустя.


Заголовок HTML-документа

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

Заголовок HTML-документа

Создается с помощью элемента HEAD, между тегами которого размещаются элементы, содержащие техническую информацию о документе. Заголовок обычно располагается до тела документа (см. структуру HTML-документа).

Элементы, относящиеся к заголовку документа:
- | HEAD | Определяет начало и конец заголовка документа
- | TITLE | Определяет имя всего документа, которое отображается в заголовке окна браузера
- | BASE | Определяет базовый адрес, от которого отсчитываются относительные линки внутри документа
- | STYLE | Используется для вставки в документ таблицы стилей CSS
- | LINK | Описывает взаимосвязь документа с другими объектами
- | META | Используется для вставки метаданных


Навигационные карты

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

Навигационные карты

Карты, обрабатываемые на клиентской машине браузером, создаются с помощью элементов MAP и AREA и представляют собой гиперссылки, офомленные в виде активных областей на изображении. Применить созданную карту к изображению можно вызвав ее по имени с помощью атрибута USEMAP элемента IMG.

Пример:
<!-- Создаем карту с именем ImageMap: -->
<MAP NAME="ImageMap">
<AREA HREF="something.html" SHAPE="rect" COORDS="0,0,70,140" ALT="Левая половинка">
<AREA HREF="anything.html" SHAPE="rect" COORDS="71,0,140,140" ALT="Правая половинка">
</MAP>
<!-- Создали. -->

<BODY>
<!-- Привинчиваем ее к изображению -->
<IMG src="/img/block.gif" USEMAP="#ImageMap" HEIGHT="140" WIDTH="140" BORDER="0">
...

В данном примере мы создали квадратное изображение размером 140x140 пикселов, левая часть которого является ссылкой на файл something.html, а правая – на файл anything.html.

Примечание:

 Для создания карт, обрабатываемых на сервере, используется атрибут ISMAP элемента IMG. Мы их сознательно не рассматриваем, ибо механизм обработки карт на удаленной машине осуществляется с помощью скриптов и не имеет к HTML никакого отношения.


Скрипты

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

Скрипты

Скрипты – это включения в HTML не-html кода, дополняющего его возможности. С помощью сприптов вы можете создавать анимированные кнопки меню, осуществлять автоматическое перенаправление на другие документы и т.д. Большинство скриптов пишется на языке JavaScript.

К сожалению, в этом справочнике вы не найдете описания языка JavaScript, но для его изучения можете воспользоваться одним из сайтов, представленных в разделе ссылок на другие материалы, а также почитать наш форум, самый полный в российском Интернете.

Элементы для работы со скриптами:
- | SCRIPT | Вставляет скрипт в HTML-документ
- | NOSCRIPT | Определяет текст, который будет отображен, если браузер не поддерживает скрипты


Структура HTML-документа. Начинаем работу.

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

Структура HTML-документа. Начинаем работу.

С чего начинается HTML

Для того, чтобы текстовый файл превратился в HTML-файл, поменять его расширение с ".txt" на ".html" недостаточно. Надо соблюсти "правило первой строки":

Каждый HTML-документ, отвечающий спецификации HTML какой-либо версии, обязан начинаться со строки декларации версии HTML !DOCTYPE, которая обычно выглядит так:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">

Эта строка поможет браузеру определить, как правильно интерпретировать данный документ. В данном случае мы говорим браузеру, что HTML соответствует международной спецификации версии 3.2, которая хоть и не отличается новизной, но, в отличие от более поздних версий, является полноценным, широко распространенным стандартом без каких-либо неопределенностей. Как видно из примера, самый короткий html-документ состоит буквально из одной строки.

Пример самого короткого HTML-документа:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">

С чего начинается работа

На самом деле одной строкой дело не обходится. После объявления версии и типа документа необходимо обозначить его начало и конец. Это делается с помощью тега-контейнера <HTML>. Необходимо отметить, что любой HTML-документ открывется тегом <HTML> и им же закрывается.

Затем, между тегами <HTML> и </HTML> следует разместить заголовок и тело документа. Вот и все! Начало положено – вы получили прекрасную заготовку. Вот как должен выглядеть ваш базовый HTML-файл перед началом работы:

Правильный пример самого короткого HTML-документа:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
<HTML>
    <HEAD>
    <TITLE>Заголовок документа</TITLE>
    </HEAD>
<BODY>
Текст документа
</BODY>
</HTML>

Разжевать?

Если приведенный выше пример пояснить схематически, получится следующее:

Из схемы видно, что документ состоит из двух основных блоков – "заголовка" и "тела документа". Заголовок определяется с помощью элемента HEAD, а тело – элементом BODY.

Заголовок содержит "техническую" информацию о документе, хотя чаще всего используется только для обозначения его названия (см. элемент TITLE).

Тело документа – святая святых. Именно в нем находится все то, что отображается на странице: текст, картинки, таблицы. Соответственно, делаем вывод: большинство ваших HTML-экспериментов будет проводиться в пространстве между тегами <BODY> и </BODY>

Распространённые ошибки:

 Размещение заголовка в теле документа (или наоборот) совершенно недопустимо. Сначала закрываем заголовок </HEAD>, и лишь затем открываем тело <BODY>.


Тело документа

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

Тело документа

Создается с помощью элемента BODY. Именно в теле документа содержится все то, что мы видим на странице. А на странице мы обычно видим:

  • Текст, блоки текста (причем текста форматированного)
  • Гиперссылки
  • Разнообразные списки
  • Таблицы
  • Всяческие объекты, картинки
  • Заполняемые формы

Примечания:

 "Бестелесных" документов не бывает. Документ без тела будет похож на одинокую голову профессора Доуэля (см. структуру HTML=документа).

Документ может иметь несколько "тел" – фреймов. В этом случае тело вместе со всем его содержимым удаляется и вместо него вставляется FRAMESET.


Фреймы

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

Фреймы

Фреймы (frames) используются для разбивки окна браузера на несколько областей, каждая из которых представляет собой отдельный HTML-документ (фрейм). Как правило, фреймы используются для облегчения навигации по сайту, создания навигационного меню. Тем не менее, большинство разработчиков избегают использования фреймов, к чему, поверьте, имеют довольно веские основания. Старайтесь использовать фреймы только тогда, когда это действительно необходимо.

Окно с фреймами

Элементы для создания фреймов и работы с ними:
- | FRAMESET | Определяет фреймовую (оконную) структуру документа: размеры и расположение фреймов на странице
- | FRAME | Определяет фрейм и его свойства внутри FRAMESET-структуры
- | NOFRAMES | Определяет что показывать, если браузер не поддерживает фреймы

Примечания:

 Внимательно следите, чтобы все вышеперечисленные элементы находились вне элемента BODY. Фреймы к телу документа никоим образом не относятся!


FAQ

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

FAQ

Как сделать красную строку?

Существует множество способов создания красной строки, большинство из них с недостатками. На эту тему написано много, но раз уж задали вопрос, отвечу и я 8)

Итак, красной строки в HTML не предусмотрено, что неудивительно – в английском ее не используют вообще, а специально для русских HTML никто разрабатывать не собирался. Именно поэтому все способы создания красных строк суть своеобразный "финт ушами", попытка обмануть природу. Казалось бы, что идеологически верно – не корежить текст, а воспользоваться CSS:

Пример:
<HEAD>
<STYLE type="text/css">
    <!--
    P:first-line { margin-left: 20; }
    -->
</style>
</HEAD>
...
<BODY...>
<p>тут всякий текст и все такое </p>

Но у этого способа есть недостаток – не работает в древних браузерах.

Наиболее распространенные способы обмана (работают везде):

  1. <font color="#ЦВЕТ_ФОНА">_______</font>
  2. <img src="/img/null.gif" width=20 height=10>
    3. , где null.gif – прозрачный gif-файл размером 1x1.
  3. &nbsp;&nbsp;&nbsp;&nbsp;

Лично я предпочитаю второй способ с прозрачным гифом, т.к. остальные меняют содержимое публикуемого текста, и при попытке его скопировать (например, через Ctrl-C) появится мусор.


Полезные линки

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Полезные линки

Если у Вас есть ссылки на сайты про Интернет-дизайн, HTML, CGI-скрипты,... одним словом, про все, что может быть полезно web-мастеру, пожалуйста, присылайте.

HTML:

www.echoecho.com – хороший буржуйский сайт, обучающий созданию сайтов. Все разжевано и понятно.
www.artlebedev.ru/kovodstvo – интересные дизайнерские мысли на сетевые и околосетевые темы.

CGI:

www.scriptsearch.com – поисковая система по скриптам.
www.7thgate.com/tools/cgi/cgi.html – коллекция CGI.

ГРАФИКА:

wintorez.chat.ru – страничка с полным описанием горячих клавиш для программ: Photoshop, Illustrator и FreeHand. Очень полезная вещь. Рекомендую.


Спецсимволы в HTML

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

Спецсимволы в HTML

Обозначения специальных символов в HTML 4

Вид по имени | Вид по коду | Имя | Код | Описание | Unicode | Подмножество ISO 8879

Литеры для кодовой страницы ISO 8859-1

HTMLlat1 – Latin 1
nbsp | &#160; | неразрывный пробел | U+00A0 | ISOnum
¡ ¡ iexcl &#161; перев,рнутый восклицательный знак U+00A1 ISOnum
¢ ¢ cent &#162; цент U+00A2 ISOnum
£ £ pound &#163; фунт стерлингов U+00A3 ISOnum
¤ ¤ curren &#164; денежная единица U+00A4 ISOnum
¥ ¥ yen &#165; иена или юань U+00A5 ISOnum
¦ ¦ brvbar &#166; разорванная вертикальная черта U+00A6 ISOnum
§ § sect &#167; параграф U+00A7 ISOnum
¨ ¨ uml &#168; diaeresis = spacing diaeresis U+00A8 ISOdia
© © copy &#169; знак copyright U+00A9 ISOnum
ª | ª | ordf | &#170; | feminine ordinal indicator | U+00AA | ISOnum
« « laquo &#171; левая двойная угловая скобка U+00AB ISOnum
¬ ¬ not &#172; знак отрицания U+00AC ISOnum
shy | &#173; | место возможного переноса | U+00AD | ISOnum
® ® reg &#174; знак зарегистрированной торговой марки U+00AE ISOnum
¯ ¯ macr &#175; macron = spacing macron = overline = APL overbar U+00AF ISOdia
° ° deg &#176; градус U+00B0 ISOnum
± ± plusmn &#177; плюс-минус U+00B1 ISOnum
² | ² | sup2 | &#178; | верхний индекс 'два' – 'квадрат' | U+00B2 | ISOnum
³ | ³ | sup3 | &#179; | верхний индекс 'три' – 'куб' | U+00B3 | ISOnum
´ ´ acute &#180; acute accent = spacing acute U+00B4 ISOdia
µ | µ | micro | &#181; | микро | U+00B5 | ISOnum
¶ ¶ para &#182; pilcrow sign = paragraph sign U+00B6 ISOnum
· · middot &#183; middle dot = Georgian comma = Greek middle dot U+00B7 ISOnum
¸ ¸ cedil &#184; cedilla = spacing cedilla U+00B8 ISOdia
¹ | ¹ | sup1 | &#185; | верхний индекс 'один' | U+00B9 | ISOnum
º | º | ordm | &#186; | masculine ordinal indicator | U+00BA | ISOnum
» » raquo &#187; правая двойная угловая скобка U+00BB ISOnum
¼ | ¼ | frac14 | &#188; | дробь – одна четверть | U+00BC | ISOnum
½ | ½ | frac12 | &#189; | дробь – одна вторая | U+00BD | ISOnum
¾ | ¾ | frac34 | &#190; | дробь – три четверти | U+00BE | ISOnum
¿ ¿ iquest &#191; перев,рнутый вопросительный знак U+00BF ISOnum
À | À | Agrave | &#192; | latin capital letter A with grave = latin capital letter A grave | U+00C0 | ISOlat1
Á | Á | Aacute | &#193; | latin capital letter A with acute | U+00C1 | ISOlat1
Â | Â | Acirc | &#194; | latin capital letter A with circumflex | U+00C2 | ISOlat1
Ã | Ã | Atilde | &#195; | latin capital letter A with tilde | U+00C3 | ISOlat1
Ä | Ä | Auml | &#196; | latin capital letter A with diaeresis | U+00C4 | ISOlat1
Å | Å | Aring | &#197; | latin capital letter A with ring above = latin capital letter A ring | U+00C5 | ISOlat1
Æ | Æ | AElig | &#198; | latin capital letter AE = latin capital ligature AE | U+00C6 | ISOlat1
Ç | Ç | Ccedil | &#199; | latin capital letter C with cedilla | U+00C7 | ISOlat1
È | È | Egrave | &#200; | latin capital letter E with grave | U+00C8 | ISOlat1
É | É | Eacute | &#201; | latin capital letter E with acute | U+00C9 | ISOlat1
Ê | Ê | Ecirc | &#202; | latin capital letter E with circumflex | U+00CA | ISOlat1
Ë | Ë | Euml | &#203; | latin capital letter E with diaeresis | U+00CB | ISOlat1
Ì | Ì | Igrave | &#204; | latin capital letter I with grave | U+00CC | ISOlat1
Í | Í | Iacute | &#205; | latin capital letter I with acute | U+00CD | ISOlat1
Î | Î | Icirc | &#206; | latin capital letter I with circumflex | U+00CE | ISOlat1
Ï | Ï | Iuml | &#207; | latin capital letter I with diaeresis | U+00CF | ISOlat1
Ð | Ð | ETH | &#208; | latin capital letter ETH | U+00D0 | ISOlat1
Ñ | Ñ | Ntilde | &#209; | latin capital letter N with tilde | U+00D1 | ISOlat1
Ò | Ò | Ograve | &#210; | latin capital letter O with grave | U+00D2 | ISOlat1
Ó | Ó | Oacute | &#211; | latin capital letter O with acute | U+00D3 | ISOlat1
Ô | Ô | Ocirc | &#212; | latin capital letter O with circumflex | U+00D4 | ISOlat1
Õ | Õ | Otilde | &#213; | latin capital letter O with tilde | U+00D5 | ISOlat1
Ö | Ö | Ouml | &#214; | latin capital letter O with diaeresis | U+00D6 | ISOlat1
× × times &#215; знак умножения U+00D7 ISOnum
Ø | Ø | Oslash | &#216; | latin capital letter O with stroke = latin capital letter O slash | U+00D8 | ISOlat1
Ù | Ù | Ugrave | &#217; | latin capital letter U with grave | U+00D9 | ISOlat1
Ú | Ú | Uacute | &#218; | latin capital letter U with acute | U+00DA | ISOlat1
Û | Û | Ucirc | &#219; | latin capital letter U with circumflex | U+00DB | ISOlat1
Ü | Ü | Uuml | &#220; | latin capital letter U with diaeresis | U+00DC | ISOlat1
Ý | Ý | Yacute | &#221; | latin capital letter Y with acute | U+00DD | ISOlat1
Þ | Þ | THORN | &#222; | latin capital letter THORN | U+00DE | ISOlat1
ß | ß | szlig | &#223; | latin small letter sharp s = ess-zed | U+00DF | ISOlat1
à | à | agrave | &#224; | latin small letter a with grave = latin small letter a grave | U+00E0 | ISOlat1
á | á | aacute | &#225; | latin small letter a with acute | U+00E1 | ISOlat1
â | â | acirc | &#226; | latin small letter a with circumflex | U+00E2 | ISOlat1
ã | ã | atilde | &#227; | latin small letter a with tilde | U+00E3 | ISOlat1
ä | ä | auml | &#228; | latin small letter a with diaeresis | U+00E4 | ISOlat1
å | å | aring | &#229; | latin small letter a with ring above = latin small letter a ring | U+00E5 | ISOlat1
æ | æ | aelig | &#230; | latin small letter ae = latin small ligature ae | U+00E6 | ISOlat1
ç | ç | ccedil | &#231; | latin small letter c with cedilla | U+00E7 | ISOlat1
è | è | egrave | &#232; | latin small letter e with grave | U+00E8 | ISOlat1
é | é | eacute | &#233; | latin small letter e with acute | U+00E9 | ISOlat1
ê | ê | ecirc | &#234; | latin small letter e with circumflex | U+00EA | ISOlat1
ë | ë | euml | &#235; | latin small letter e with diaeresis | U+00EB | ISOlat1
ì | ì | igrave | &#236; | latin small letter i with grave | U+00EC | ISOlat1
í | í | iacute | &#237; | latin small letter i with acute | U+00ED | ISOlat1
î | î | icirc | &#238; | latin small letter i with circumflex | U+00EE | ISOlat1
ï | ï | iuml | &#239; | latin small letter i with diaeresis | U+00EF | ISOlat1
ð | ð | eth | &#240; | latin small letter eth | U+00F0 | ISOlat1
ñ | ñ | ntilde | &#241; | latin small letter n with tilde | U+00F1 | ISOlat1
ò | ò | ograve | &#242; | latin small letter o with grave | U+00F2 | ISOlat1
ó | ó | oacute | &#243; | latin small letter o with acute | U+00F3 | ISOlat1
ô | ô | ocirc | &#244; | latin small letter o with circumflex | U+00F4 | ISOlat1
õ | õ | otilde | &#245; | latin small letter o with tilde | U+00F5 | ISOlat1
ö | ö | ouml | &#246; | latin small letter o with diaeresis | U+00F6 | ISOlat1
÷ ÷ divide &#247; знак деления U+00F7 ISOnum
ø | ø | oslash | &#248; | latin small letter o with stroke, = latin small letter o slash | U+00F8 | ISOlat1
ù | ù | ugrave | &#249; | latin small letter u with grave | U+00F9 | ISOlat1
ú | ú | uacute | &#250; | latin small letter u with acute | U+00FA | ISOlat1
û | û | ucirc | &#251; | latin small letter u with circumflex | U+00FB | ISOlat1
ü | ü | uuml | &#252; | latin small letter u with diaeresis | U+00FC | ISOlat1
ý | ý | yacute | &#253; | latin small letter y with acute | U+00FD | ISOlat1
þ | þ | thorn | &#254; | latin small letter thorn | U+00FE | ISOlat1
ÿ | ÿ | yuml | &#255; | latin small letter y with diaeresis | U+00FF | ISOlat1

Символы, в том числе математические, и греческие буквы

HTMLsymbol – Symbols

Latin Extended-B
ƒ | ƒ | fnof | &#402; | latin small f with hook = знак функции = florin | U+0192 | ISOtech

Греческие буквы
Α | Α | Alpha | &#913; | греческая заглавная буква альфа | U+0391
Β | Β | Beta | &#914; | греческая заглавная буква бета | U+0392
Γ | Γ | Gamma | &#915; | греческая заглавная буква гамма | U+0393 | ISOgrk3
Δ | Δ | Delta | &#916; | греческая заглавная буква дельта | U+0394 | ISOgrk3
Ε | Ε | Epsilon | &#917; | греческая заглавная буква эпсилон | U+0395
Ζ | Ζ | Zeta | &#918; | греческая заглавная буква дзета | U+0396
Η | Η | Eta | &#919; | греческая заглавная буква эта | U+0397
Θ | Θ | Theta | &#920; | греческая заглавная буква тета | U+0398 | ISOgrk3
Ι | Ι | Iota | &#921; | греческая заглавная буква иота | U+0399
Κ | Κ | Kappa | &#922; | греческая заглавная буква каппа | U+039A
Λ | Λ | Lambda | &#923; | греческая заглавная буква лямбда | U+039B | ISOgrk3
Μ | Μ | Mu | &#924; | греческая заглавная буква мю | U+039C
Ν | Ν | Nu | &#925; | греческая заглавная буква ню | U+039D
Ξ | Ξ | Xi | &#926; | греческая заглавная буква кси | U+039E | ISOgrk3
Ο | Ο | Omicron | &#927; | греческая заглавная буква омикрон | U+039F
Π | Π | Pi | &#928; | греческая заглавная буква пи | U+03A0 | ISOgrk3
Ρ | Ρ | Rho | &#929; | греческая заглавная буква ро | U+03A1
Буква Sigmaf отсутствует, и знак U+03A2 – тоже
Σ | Σ | Sigma | &#931; | греческая заглавная буква сигма | U+03A3 | ISOgrk3
Τ | Τ | Tau | &#932; | греческая заглавная буква тау | U+03A4
Υ | Υ | Upsilon | &#933; | греческая заглавная буква ипсилон | U+03A5 | ISOgrk3
Φ | Φ | Phi | &#934; | греческая заглавная буква фи | U+03A6 | ISOgrk3
Χ | Χ | Chi | &#935; | греческая заглавная буква хи | U+03A7
Ψ | Ψ | Psi | &#936; | греческая заглавная буква пси | U+03A8 | ISOgrk3
Ω | Ω | Omega | &#937; | греческая заглавная буква омега | U+03A9 | ISOgrk3
α | α | alpha | &#945; | греческая строчная буква альфа | U+03B1 | ISOgrk3
β | β | beta | &#946; | греческая строчная буква бета | U+03B2 | ISOgrk3
γ | γ | gamma | &#947; | греческая строчная буква гамма | U+03B3 | ISOgrk3
δ | δ | delta | &#948; | греческая строчная буква дельта | U+03B4 | ISOgrk3
ε | ε | epsilon | &#949; | греческая строчная буква эпсилон | U+03B5 | ISOgrk3
ζ | ζ | zeta | &#950; | греческая строчная буква дзета | U+03B6 | ISOgrk3
η | η | eta | &#951; | греческая строчная буква эта | U+03B7 | ISOgrk3
θ | θ | theta | &#952; | греческая строчная буква тета | U+03B8 | ISOgrk3
ι | ι | iota | &#953; | греческая строчная буква иота | U+03B9 | ISOgrk3
κ | κ | kappa | &#954; | греческая строчная буква каппа | U+03BA | ISOgrk3
λ | λ | lambda | &#955; | греческая строчная буква лямбда | U+03BB | ISOgrk3
μ | μ | mu | &#956; | греческая строчная буква мю | U+03BC | ISOgrk3
ν | ν | nu | &#957; | греческая строчная буква ню | U+03BD | ISOgrk3
ξ | ξ | xi | &#958; | греческая строчная буква кси | U+03BE | ISOgrk3
ο | ο | omicron | &#959; | греческая строчная буква омикрон | U+03BF | NEW
π | π | pi | &#960; | греческая строчная буква пи | U+03C0 | ISOgrk3
ρ | ρ | rho | &#961; | греческая строчная буква ро | U+03C1 | ISOgrk3
ς | ς | sigmaf | &#962; | греческая строчная буква сигма (final) | U+03C2 | ISOgrk3
σ | σ | sigma | &#963; | греческая строчная буква сигма | U+03C3 | ISOgrk3
τ | τ | tau | &#964; | греческая строчная буква тау | U+03C4 | ISOgrk3
υ | υ | upsilon | &#965; | греческая строчная буква ипсилон | U+03C5 | ISOgrk3
φ | φ | phi | &#966; | греческая строчная буква фи | U+03C6 | ISOgrk3
χ | χ | chi | &#967; | греческая строчная буква хи | U+03C7 | ISOgrk3
ψ | ψ | psi | &#968; | греческая строчная буква пси | U+03C8 | ISOgrk3
ω | ω | omega | &#969; | греческая строчная буква омега | U+03C9 | ISOgrk3
ϑ | ϑ | thetasym | &#977; | greek small letter theta symbol | U+03D1 | NEW
ϒ | ϒ | upsih | &#978; | greek upsilon with hook symbol | U+03D2 | NEW
ϖ | ϖ | piv | &#982; | greek pi symbol | U+03D6 | ISOgrk3

Знаки пунктуации
• • bull &#8226; bullet – маленький ч,рный кружок U+2022 ISOpub
bullet – не то же самое, что оператор bullet, U+2219
… … hellip &#8230; многоточие ... U+2026 ISOpub
′ ′ prime &#8242; одиночный штрих – минуты и футы U+2032 ISOtech
″ ″ Prime &#8243; двойной штрих – секунды и дюймы U+2033 ISOtech
‾ ‾ oline &#8254; надч,ркивание U+203E NEW
⁄ ⁄ frasl &#8260; косая дробная черта U+2044 NEW

Символы, производные от букв
℘ ℘ weierp &#8472; рукописное заглавное латинское P – power set – P Вейерштрасса U+2118 ISOamso
ℑ | ℑ | image | &#8465; | blackletter capital I = imaginary part | U+2111 | ISOamso
ℜ | ℜ | real | &#8476; | blackletter capital R = real part symbol | U+211C | ISOamso
™ ™ trade &#8482; знак торговой марки U+2122 ISOnum
ℵ | ℵ | alefsym | &#8501; | символ алеф – first transfinite cardinal | U+2135 | NEW
Символ алеф – не то же самое, что буква алеф из иврита, U+05D0, хотя и имеет то же начертание

Стрелки
← ← larr &#8592; стрелка влево U+2190 ISOnum
↑ ↑ uarr &#8593; стрелка вверх U+2191 ISOnum
→ → rarr &#8594; стрелка вправо U+2192 ISOnum
↓ ↓ darr &#8595; стрелка вниз U+2193 ISOnum
↔ ↔ harr &#8596; стрелка влево-вправо U+2194 ISOamsa
↵ ↵ crarr &#8629; стрелка вниз и влево – знак возврата каретки U+21B5 NEW
⇐ ⇐ lArr &#8656; двойная стрелка влево U+21D0 ISOtech
ISO 10646 не утверждает, что lArr – то же самое, что и стрелка для обозначения отношения 'следует из', но также и не предлагает для этого никакого другого символа. Так что (?) символ lArr может быть использован для обозначения отношения 'следует из', что и рекомендует ISOtech
⇑ ⇑ uArr &#8657; двойная стрелка вверх U+21D1 ISOamsa
⇒ ⇒ rArr &#8658; двойная стрелка вправо U+21D2 ISOtech
ISO 10646 не утверждает, что это – символ для обозначения отношения 'следовательно', но также и не предлагает для этого никакого другого символа. Так что (?) символ rArr может быть использован для обозначения отношения 'следовательно', что и рекомендует ISOtech
⇓ ⇓ dArr &#8659; двойная стрелка вниз U+21D3 ISOamsa
⇔ ⇔ hArr &#8660; двойная стрелка влево-вправо U+21D4 ISOamsa

Математические операторы
∀ ∀ forall &#8704; для всех U+2200 ISOtech
∂ ∂ part &#8706; частный дифференциал U+2202 ISOtech
∃ ∃ exist &#8707; существует U+2203 ISOtech
∅ ∅ empty &#8709; пустое множество; диаметр U+2205 ISOamso
∇ ∇ nabla &#8711; набла = backward difference U+2207 ISOtech
∈ ∈ isin &#8712; принадлежит U+2208 ISOtech
∉ ∉ notin &#8713; не принадлежит U+2209 ISOtech
∋ ∋ ni &#8715; содержит U+220B ISOtech
Возможно, следовало бы иметь более запоминающееся имя, чем 'ni'?
∏ ∏ prod &#8719; произведение последовательности – знак произведения U+220F ISOamsb
prod – не то же самое, что U+03A0 – 'греческая заглавная буква пи', хотя и может иметь то же начертание
∑ ∑ sum &#8721; сумма последовательности U+2211 ISOamsb
sum – не то же самое, что U+03A3 = 'греческая заглавная буква сигма', хотя и может иметь то же начертание
− − minus &#8722; минус U+2212 ISOtech
∗ ∗ lowast &#8727; оператор 'зв,здочка' U+2217 ISOtech
√ √ radic &#8730; квадратный корень U+221A ISOtech
∝ ∝ prop &#8733; пропорционально U+221D ISOtech
∞ ∞ infin &#8734; бесконечность U+221E ISOtech
∠ ∠ ang &#8736; угол U+2220 ISOamso
∧ ∧ and &#8743; логическое И – wedge U+2227 ISOtech
∨ ∨ or &#8744; логическое ИЛИ – vee U+2228 ISOtech
∩ ∩ cap &#8745; пересечение – cap U+2229 ISOtech
∪ ∪ cup &#8746; объединение – cup U+222A ISOtech
∫ ∫ int &#8747; интеграл U+222B ISOtech
∴ ∴ there4 &#8756; следовательно U+2234 ISOtech
∼ ∼ sim &#8764; знак тильда – 'изменяется с' – знак подобия U+223C ISOtech
знак тильда – не то же самое, что тильда – U+007E, хотя и может иметь то же начертание
≅ ≅ cong &#8773; approximately equal to U+2245 ISOtech
≈ ≈ asymp &#8776; почти равно – асимптотически стремится U+2248 ISOamsr
≠ ≠ ne &#8800; не равно U+2260 ISOtech
≡ ≡ equiv &#8801; тождественно U+2261 ISOtech
≤ ≤ le &#8804; меньше либо равно U+2264 ISOtech
≥ ≥ ge &#8805; больше либо равно U+2265 ISOtech
⊂ ⊂ sub &#8834; является подмножеством U+2282 ISOtech
⊃ ⊃ sup &#8835; является надмножеством U+2283 ISOtech
Заметим, что символ nsup, 'не является подмножеством', U+2283, не входит в кодировку шрифта Symbol и не включ,н сюда. Возможно, и следовало бы для симметрии? Этот символ содержится в ISOamsn
⊄ ⊄ nsub &#8836; не является подмножеством U+2284 ISOamsn
⊆ ⊆ sube &#8838; является подмножеством либо равно U+2286 ISOtech
⊇ ⊇ supe &#8839; является надмножеством либо равно U+2287 ISOtech
⊕ ⊕ oplus &#8853; плюс в кружке – direct sum U+2295 ISOamsb
⊗ ⊗ otimes &#8855; знак умножения в кружке – vector product U+2297 ISOamsb
⊥ ⊥ perp &#8869; ортогонально, перпендикулярно U+22A5 ISOtech
⋅ ⋅ sdot &#8901; оператор 'точка' U+22C5 ISOamsb
Оператор 'точка' – не то же самое, что U+00B7 – средняя точка

Различные технические знаки
⌈ ⌈ lceil &#8968; left ceiling = apl upstile U+2308 ISOamsc
⌉ ⌉ rceil &#8969; right ceiling U+2309 ISOamsc
⌊ ⌊ lfloor &#8970; left floor = apl downstile U+230A ISOamsc
⌋ ⌋ rfloor &#8971; right floor U+230B ISOamsc
⟨ 〈 lang &#9001; левая угловая скобка – bra U+2329 ISOtech
lang – это не то же, что U+003C – 'меньше чем' или U+2039 – 'одиночная левая угловая кавычка'
⟩ 〉 rang &#9002; правая угловая скобка – ket U+232A ISOtech
rang – это не то же, что U+003E – 'больше чем' или U+203A – 'одиночная правая угловая кавычка'

Геометрические формы
◊ ◊ loz &#9674; lozenge U+25CA ISOpub

Прочие символы
♠ ♠ spades &#9824; ч,рный знак масти 'пики' U+2660 ISOpub
'Ч,рный' здесь, похоже, означает заполненный, то есть не полый
♣ ♣ clubs &#9827; ч,рный знак масти 'трефы' – shamrock U+2663 ISOpub
♥ ♥ hearts &#9829; ч,рный знак масти 'червы' – valentine U+2665 ISOpub
♦ ♦ diams &#9830; ч,рный знак масти 'бубны' U+2666 ISOpub

Character entity references for markup-significant and internationalization characters

HTMLspecial – Special

C0 Controls и Basic Latin
" " quot &#34; двойная кавычка – APL quote U+0022 ISOnum
& & amp &#38; ampersand U+0026 ISOnum
< < lt &#60; знак 'меньше' U+003C ISOnum
> > gt &#62; знак 'больше' U+003E ISOnum

Latin Extended-A
Œ | Œ | OElig | &#338; | латинская заглавная лигатура OE | U+0152 | ISOlat2
œ | œ | oelig | &#339; | латинская строчная лигатура oe | U+0153 | ISOlat2
Лигатура – это misnomer, она является отдельным символом в некоторых языках
Š | Š | Scaron | &#352; | latin capital letter S with caron | U+0160 | ISOlat2
š | š | scaron | &#353; | latin small letter s with caron | U+0161 | ISOlat2
Ÿ | Ÿ | Yuml | &#376; | latin capital letter Y with diaeresis | U+0178 | ISOlat2

Spacing Modifier Letters
ˆ | ˆ | circ | &#710; | modifier letter circumflex accent | U+02C6 | ISOpub
˜ ˜ tilde &#732; small tilde U+02DC ISOdia

Общая пунктуация
    ensp | &#8194; | en space | U+2002 | ISOpub
    emsp | &#8195; | em space | U+2003 | ISOpub
    thinsp | &#8201; | thin space | U+2009 | ISOpub
‌ ‌ zwnj &#8204; zero width non-joiner U+200C NEW RFC 2070
‍ ‍ zwj &#8205; zero width joiner U+200D NEW RFC 2070
‎ ‎ lrm &#8206; left-to-right mark U+200E NEW RFC 2070
‏ ‏ rlm &#8207; right-to-left mark U+200F NEW RFC 2070
– – ndash &#8211; en dash U+2013 ISOpub
— — mdash &#8212; em dash U+2014 ISOpub
‘ ‘ lsquo &#8216; левая одиночная кавычка U+2018 ISOnum
’ ’ rsquo &#8217; правая одиночная кавычка U+2019 ISOnum
‚ ‚ sbquo &#8218; нижняя одиночная кавычка U+201A NEW
“ “ ldquo &#8220; левая двойная кавычка U+201C ISOnum
” ” rdquo &#8221; правая двойная кавычка U+201D ISOnum
„ „ bdquo &#8222; нижняя двойная кавычка U+201E NEW
† † dagger &#8224; кинжал (крест) U+2020 ISOpub
‡ ‡ Dagger &#8225; двойной кинжал (крест) U+2021 ISOpub
‰ ‰ permil &#8240; промилле U+2030 ISOtech
‹ ‹ lsaquo &#8249; левая угловая одиночная кавычка U+2039 ISO proposed
Знак lsaquo предложен, но ещ, не стандартизован ISO
› › rsaquo &#8250; правая угловая одиночная кавычка U+203A ISO proposed
Знак rsaquo предложен, но ещ, не стандартизован ISO
€ € euro &#8364; валюта евро U+20AC NEW


Таблица MIME-типов

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Таблица MIME-типов

ПРИЛОЖЕНИЕ 3. Таблица MIME-типов

MIME Type                          Extension

animation/narrative                nml
application/activemessage
application/andrew-inset
application/applefile
application/atomicmail
application/dca-rft
application/dec-dx
application/dsptype                tsp
application/fastman                lcc
application/font-tdpfr             pfr
application/futuresplash           spl
application/mac-binhex40           hqx
application/mac-compactpro         cpt
application/macwriteii
application/mspowerpoint           pot pps ppt ppz
application/msword
application/news-message-id
application/news-transmission
application/octet-stream           bin class dms exe sea
application/oda                    oda
application/pdf                    pdf
application/postscript             ai eps ps
application/remote-printing
application/rtf                    rtf
application/slate
application/softvision             svi
application/wita
application/wordperfect5.1
application/x-authorware-bin       aab
application/x-authorware-map       aam
application/x-authorware-seg       aas
application/x-bcpio                bcpio
application/x-bzip2                bz2
application/x-calquick             cqk
application/x-cdlink               vcd
application/x-cocoa                cco
application/x-compress             Z
application/x-cpio                 cpio
application/x-csh                  csh
application/x-director             dcr dir dxr
application/x-dvi                  dvi
application/x-excel                xls
application/x-expandedbook         ebk
application/x-gtar                 gtar
application/x-gzip                 gz
application/x-hdf                  hdf
application/x-httpd-cgi            cgi
application/x-javascript           js ls mocha
application/x-koan                 skd skm skp skt
application/x-latex                latex
application/x-lzh                  lha lzh
application/x-mapserver            mps
application/x-mascot               mct
application/x-mif                  mif
application/x-netcdf               cdf nc
application/x-ns-proxy-auto-config pac
application/x-pixelscooter         mpp
application/x-pointplus            css
application/x-sh                   sh
application/x-shar                 shar
application/x-shockwave-flash      swf
application/x-sprite               spr sprite
application/x-spt                  spt
application/x-stuffit              sit
application/x-sv4cpio              sv4cpio
application/x-sv4crc               sv4crc
application/x-tar                  tar tgz
application/x-tcl                  tcl
application/x-tex                  tex
application/x-texinfo              texi texinfo
application/x-troff                roff t tr
application/x-troff-man            man
application/x-troff-me             me
application/x-troff-ms             ms
application/x-ustar                ustar
application/x-wais-source          src
application/x-xdma                 xdm xdma
application/zip                    zip
audio/basic                        au snd
audio/echospeech                   es
audio/midi                         kar mid midi
audio/mpeg                         mp2 mp3 mpga
audio/tsplayer                     tsi
audio/voxware                      vox
audio/x-aiff                       aif aifc aiff
audio/x-bamba                      aba
audio/x-chacha                     cha
audio/x-mio                        mio
audio/x-pn-realaudio               ra ram rm
audio/x-pn-realaudio-plugin        rpm
audio/x-twinvq                     vqf vql
audio/x-twinvq-plugin              vqe
audio/x-wav                        wav
chemical/x-csml                    csm
chemical/x-embl-dl-nucleotide      emb
chemical/x-gaussian-input          gau
chemical/x-mdl-molfile             mol
chemical/x-mopac-input             mop
chemical/x-pdb                     pdb
chemical/x-xyz                     xyz
i-world/i-vrml                     ivr
image/fif                          fif
image/gif                          gif
image/ief                          ief
image/jpeg                         jpe jpeg jpg
image/png                          png
image/tiff                         tif tiff
image/vasa                         mcf
image/x-cmu-raster                 ras
image/x-freehand                   fh fh4 fh5 fh7 fhc
image/x-jps                        jps
image/x-portable-anymap            pnm
image/x-portable-bitmap            pbm
image/x-portable-graymap           pgm
image/x-portable-pixmap            ppm
image/x-rgb                        rgb
image/x-xbitmap                    xbm
image/x-xpixmap                    xpm
image/x-xres                       swx
image/x-xwindowdump                xwd
message/external-body
message/news
message/partial
message/rfc822
multipart/alternative
multipart/appledouble
multipart/digest
multipart/mixed
multipart/parallel
plugin/listenup                    ptlk
plugin/wanimate                    waf wan
text/html                          htm html
text/plain                         txt
text/richtext                      rtx
text/tab-separated-values          tsv
text/x-setext                      etx
text/x-sgml                        sgm sgml
text/x-speech                      talk
text/x-vcard                       vcf
video/mpeg                         mpe mpeg mpg
video/quicktime                    mov qt
video/vnd.vivo                     viv vivo
video/x-bamba                      vba
video/x-msvideo                    avi
video/x-sgi-movie                  movie
video/x-tango                      tgo
video/x-vif                        vif
workbook/formulaone                vts
world/x-panoramix                  pan
x-conference/x-cooltalk            ice
x-world/x-d96                      d96 mus
x-world/x-svr                      svr
x-world/x-vrml                     vrml wrl
x-world/x-vrt                      vrt


Таблица базовых цветов

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

Таблица базовых цветов

Это основные цвета, используемые в HTML. Именно эти цвета используются дизайнерами для создания страниц поисковых систем, а также в дизайне сайтов с огромной аудиторией, то есть используются там, где нужна максимальная совместимость. Все они прекрасно отображаются даже в 256-цветном режиме работы видеокарты. Несомненно, для оригинального цветового дизайна обычных сайтов их маловато.
Black | Navy
Gray | Blue
Silver | Aqua
White | Green
Red | Lime
Fuchsia | Teal
Maroon | Yellow
Purple | Olive

Для получения любого другого оттенка применяются комбинации RGB-значений цвета, записанные в шестнадцатиричном формате. Приведенные ниже 216 цветов также считаются "безопасными" (browser-safe).
Для удобства я расположил "безопасные" цвета в три таблицы по 216 цветов, отсортированные по разным цветовым компонентам.
Красный и Синий – добавляем Зеленый
000000 | 000033 | 000066 | 000099 | 0000cc | 0000ff
330000 | 330033 | 330066 | 330099 | 3300cc | 3300ff
660000 | 660033 | 660066 | 660099 | 6600cc | 6600ff
990000 | 990033 | 990066 | 990099 | 9900cc | 9900ff
cc0000 | cc0033 | cc0066 | cc0099 | cc00cc | cc00ff
ff0000 | ff0033 | ff0066 | ff0099 | ff00cc | ff00ff
003300 | 003333 | 003366 | 003399 | 0033cc | 0033ff
333300 | 333333 | 333366 | 333399 | 3333cc | 3333ff
663300 | 663333 | 663366 | 663399 | 6633cc | 6633ff
993300 | 993333 | 993366 | 993399 | 9933cc | 9933ff
cc3300 | cc3333 | cc3366 | cc3399 | cc33cc | cc33ff
ff3300 | ff3333 | ff3366 | ff3399 | ff33cc | ff33ff
006600 | 006633 | 006666 | 006699 | 0066cc | 0066ff
336600 | 336633 | 336666 | 336699 | 3366cc | 3366ff
666600 | 666633 | 666666 | 666699 | 6666cc | 6666ff
996600 | 996633 | 996666 | 996699 | 9966cc | 9966ff
cc6600 | cc6633 | cc6666 | cc6699 | cc66cc | cc66ff
ff6600 | ff6633 | ff6666 | ff6699 | ff66cc | ff66ff
009900 | 009933 | 009966 | 009999 | 0099cc | 0099ff
339900 | 339933 | 339966 | 339999 | 3399cc | 3399ff
669900 | 669933 | 669966 | 669999 | 6699cc | 6699ff
999900 | 999933 | 999966 | 999999 | 9999cc | 9999ff
cc9900 | cc9933 | cc9966 | cc9999 | cc99cc | cc99ff
ff9900 | ff9933 | ff9966 | ff9999 | ff99cc | ff99ff
00cc00 | 00cc33 | 00cc66 | 00cc99 | 00cccc | 00ccff
33cc00 | 33cc33 | 33cc66 | 33cc99 | 33cccc | 33ccff
66cc00 | 66cc33 | 66cc66 | 66cc99 | 66cccc | 66ccff
99cc00 | 99cc33 | 99cc66 | 99cc99 | 99cccc | 99ccff
cccc00 | cccc33 | cccc66 | cccc99 | cccccc | ccccff
ffcc00 | ffcc33 | ffcc66 | ffcc99 | ffcccc | ffccff
00ff00 | 00ff33 | 00ff66 | 00ff99 | 00ffcc | 00ffff
33ff00 | 33ff33 | 33ff66 | 33ff99 | 33ffcc | 33ffff
66ff00 | 66ff33 | 66ff66 | 66ff99 | 66ffcc | 66ffff
99ff00 | 99ff33 | 99ff66 | 99ff99 | 99ffcc | 99ffff
ccff00 | ccff33 | ccff66 | ccff99 | ccffcc | ccffff
ffff00 | ffff33 | ffff66 | ffff99 | ffffcc | ffffff
Красный и Зеленый – добавляем Синий
000000 | 003300 | 006600 | 009900 | 00cc00 | 00ff00
330000 | 333300 | 336600 | 339900 | 33cc00 | 33ff00
660000 | 663300 | 666600 | 669900 | 66cc00 | 66ff00
990000 | 993300 | 996600 | 999900 | 99cc00 | 99ff00
cc0000 | cc3300 | cc6600 | cc9900 | cccc00 | ccff00
ff0000 | ff3300 | ff6600 | ff9900 | ffcc00 | ffff00
000033 | 003333 | 006633 | 009933 | 00cc33 | 00ff33
330033 | 333333 | 336633 | 339933 | 33cc33 | 33ff33
660033 | 663333 | 666633 | 669933 | 66cc33 | 66ff33
990033 | 993333 | 996633 | 999933 | 99cc33 | 99ff33
cc0033 | cc3333 | cc6633 | cc9933 | cccc33 | ccff33
ff0033 | ff3333 | ff6633 | ff9933 | ffcc33 | ffff33
000066 | 003366 | 006666 | 009966 | 00cc66 | 00ff66
330066 | 333366 | 336666 | 339966 | 33cc66 | 33ff66
660066 | 663366 | 666666 | 669966 | 66cc66 | 66ff66
990066 | 993366 | 996666 | 999966 | 99cc66 | 99ff66
cc0066 | cc3366 | cc6666 | cc9966 | cccc66 | ccff66
ff0066 | ff3366 | ff6666 | ff9966 | ffcc66 | ffff66
000099 | 003399 | 006699 | 009999 | 00cc99 | 00ff99
330099 | 333399 | 336699 | 339999 | 33cc99 | 33ff99
660099 | 663399 | 666699 | 669999 | 66cc99 | 66ff99
990099 | 993399 | 996699 | 999999 | 99cc99 | 99ff99
cc0099 | cc3399 | cc6699 | cc9999 | cccc99 | ccff99
ff0099 | ff3399 | ff6699 | ff9999 | ffcc99 | ffff99
0000cc | 0033cc | 0066cc | 0099cc | 00cccc | 00ffcc
3300cc | 3333cc | 3366cc | 3399cc | 33cccc | 33ffcc
6600cc | 6633cc | 6666cc | 6699cc | 66cccc | 66ffcc
9900cc | 9933cc | 9966cc | 9999cc | 99cccc | 99ffcc
cc00cc | cc33cc | cc66cc | cc99cc | cccccc | ccffcc
ff00cc | ff33cc | ff66cc | ff99cc | ffcccc | ffffcc
0000ff | 0033ff | 0066ff | 0099ff | 00ccff | 00ffff
3300ff | 3333ff | 3366ff | 3399ff | 33ccff | 33ffff
6600ff | 6633ff | 6666ff | 6699ff | 66ccff | 66ffff
9900ff | 9933ff | 9966ff | 9999ff | 99ccff | 99ffff
cc00ff | cc33ff | cc66ff | cc99ff | ccccff | ccffff
ff00ff | ff33ff | ff66ff | ff99ff | ffccff | ffffff
Зеленый и Синий – добавляем Красный
000000 | 000033 | 000066 | 000099 | 0000cc | 0000ff
003300 | 003333 | 003366 | 003399 | 0033cc | 0033ff
006600 | 006633 | 006666 | 006699 | 0066cc | 0066ff
009900 | 009933 | 009966 | 009999 | 0099cc | 0099ff
00cc00 | 00cc33 | 00cc66 | 00cc99 | 00cccc | 00ccff
00ff00 | 00ff33 | 00ff66 | 00ff99 | 00ffcc | 00ffff
330000 | 330033 | 330066 | 330099 | 3300cc | 3300ff
333300 | 333333 | 333366 | 333399 | 3333cc | 3333ff
336600 | 336633 | 336666 | 336699 | 3366cc | 3366ff
339900 | 339933 | 339966 | 339999 | 3399cc | 3399ff
33cc00 | 33cc33 | 33cc66 | 33cc99 | 33cccc | 33ccff
33ff00 | 33ff33 | 33ff66 | 33ff99 | 33ffcc | 33ffff
660000 | 660033 | 660066 | 660099 | 6600cc | 6600ff
663300 | 663333 | 663366 | 663399 | 6633cc | 6633ff
666600 | 666633 | 666666 | 666699 | 6666cc | 6666ff
669900 | 669933 | 669966 | 669999 | 6699cc | 6699ff
66cc00 | 66cc33 | 66cc66 | 66cc99 | 66cccc | 66ccff
66ff00 | 66ff33 | 66ff66 | 66ff99 | 66ffcc | 66ffff
990000 | 990033 | 990066 | 990099 | 9900cc | 9900ff
993300 | 993333 | 993366 | 993399 | 9933cc | 9933ff
996600 | 996633 | 996666 | 996699 | 9966cc | 9966ff
999900 | 999933 | 999966 | 999999 | 9999cc | 9999ff
99cc00 | 99cc33 | 99cc66 | 99cc99 | 99cccc | 99ccff
99ff00 | 99ff33 | 99ff66 | 99ff99 | 99ffcc | 99ffff
cc0000 | cc0033 | cc0066 | cc0099 | cc00cc | cc00ff
cc3300 | cc3333 | cc3366 | cc3399 | cc33cc | cc33ff
cc6600 | cc6633 | cc6666 | cc6699 | cc66cc | cc66ff
cc9900 | cc9933 | cc9966 | cc9999 | cc99cc | cc99ff
cccc00 | cccc33 | cccc66 | cccc99 | cccccc | ccccff
ccff00 | ccff33 | ccff66 | ccff99 | ccffcc | ccffff
ff0000 | ff0033 | ff0066 | ff0099 | ff00cc | ff00ff
ff3300 | ff3333 | ff3366 | ff3399 | ff33cc | ff33ff
ff6600 | ff6633 | ff6666 | ff6699 | ff66cc | ff66ff
ff9900 | ff9933 | ff9966 | ff9999 | ff99cc | ff99ff
ffcc00 | ffcc33 | ffcc66 | ffcc99 | ffcccc | ffccff
ffff00 | ffff33 | ffff66 | ffff99 | ffffcc | ffffff


Форматы изображений – GIF или JPG?

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

Форматы изображений – GIF или JPG?

GIF и JPG ... в чем разница?

Изображения в Интернете хранятся в одном из двух форматов: GIF или JPG.

Для хранения изображений эти форматы используют совершенно разные алгоритмы, дающие порой колоссальный выигрыш в объеме. Но, с другой стороны, у каждого формата есть и свои ограничения. Умение выбирать нужный формат "на глаз" приходит не сразу, чаще всего сделать правильный выбор помогают лишь нескончаемые эксперименты.

GIF | JPG
256 цветов | True color (до 16.7 млн)
Поддерживает прозрачность участков изображения | Вся картинка непрозрачна
Обычно используется для кнопок, баннеров, элементов дизайна, логотипов, четких изображений с малым количеством оттенков, чертежей | Обычно используется для фотографий и иных "пестрых" картинок с большим количеством плавных переходов цветов

Выбор формата всегда направлен на то, чтобы добиться минимального объема получившегося файла. Старайтесь добиваться того, чтобы суммарный объем всех изображений, используемых в дизайне вашего сайта не превышал 30-50 килобайт. Чем меньше – тем лучше. Делать страницы с графикой большого объема просто неприлично – пользователи вам за это спасибо не скажут.

Для экспериментов вам понадобится соответствующий инструментарий – программы-оптимизаторы изображений, так называемые "сэйверы" (см. гл. "Возьми с собой в дорогу").

Эффект "Мозилла". Размер или количество?

Если на одной странице слишком много отдельных картинок, возникает так называемый эффект "Мозилла", выражающийся в увеличении общего времени ее загрузки. Дело в том, что для загрузки каждой картинки ваш браузер посылает серверу отдельный HTTP-запрос. На доставку запроса требуется некоторое время, по человеческим меркам очень небольшое. Но когда таких запросов сотни... сами понимаете.

СМОТРИТЕ ТАКЖЕ:
- "Возьми с собой в дорогу..." – обзор инструментария.
- Описание элемента IMG – используется для вставки изображений в страницу.
ССЫЛКИ НА ДРУГИЕ САЙТЫ ПО ДАННОЙ ТЕМАТИКЕ
- Оптимизация изображений в формате GIF (Mike Melnikov)
- Оптимизация изображений в формате JPG (Mike Melnikov)
- Простой секрет GIF'а – о принципе работы этого формата (А.Лебедев)


F5 или снова о клонировании

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

F5 или снова о клонировании

Почему нехорошо копировать чужие тексты

Представьте, что вам позарез понадобился знаменитый учебник по русскому языку Д. Э. Розенталя. Вы приходите в библиотеку и видите кучу полок с тысячами всевозможных книг. Вы зовёте библиотекаря, и спрашиваете:
– У вас есть Розенталь?
– Конечно! У нас каждая десятая книга содержит учебник Розенталя.
– Какая удача! Дайте мне его, пожалуйста.
– Какой именно?
– Как какой? Обычный, по которому все учатся!
– Понимаете, у нас все Розентали в разных обложках, разной толщины, разного содержания, многие без подписи или подписаны неправильно.
– Не путайте меня, дайте мне обычный учебник, свежий, 3-е издание, серенький.
– Это невозможно, в библиотеке отдельных учебников мало, почти все Розентали входят в сборники. Хотите "Самый Полный Сборник Материалов по Русскому Языку"? У нас их сотни, все очень толстые и разные.
– Бог с вами, давайте. А кто составитель-то? Розенталь?
– Нет, некто Вася Пупкин.
– Аааааааааааа!!!

Вам эта ситуация ничего не напоминает?

В Интернете не должно быть двух сайтов, содержащих один и тот же материал. Это все равно что наклеить на один и тот же фонарный столб два почти одинаковых объявления, но разным шрифтом и почти одинакового содержания. Какое из них читать?

Предположим, что мой сайт скопировали:

Если на своём сайте я внесу поправку в статью или допишу новую, каким образом мне внести те же изменения в свой же материал на сайте-клоне? Писать на e-mail уведомление, да? А если таких клонов пятьдесят? Каким образом пользователь обнаружит в Интернете наиболее свежий и правильный вариант статьи в этом случае? Как будет осуществляться синхронизация данных?

Неутешительные выводы

Любое копирование порождает страшную путаницу и засоряет Интернет. Хорошо хоть, что от этого озоновые дыры небе не появляются. Некоторые, конечно, попытаются возразить, что есть такое явление, как mirrors (зеркала). Но зеркалирование – это всегда только полное копирование сайта целиком в другой участок сети. И цели зеркалирования иные:

  • обеспечить скоростной доступ в другом регионе
  • обеспечить надежность работы, если сайт часто зависает или сильно перегружен

Чтобы представить, какой масштаб приобрело тупое копирование контента, взгляните на график:

[ Статистика Yandex ]
График роста российского Интернета по данным Yandex
Красная линия – рост Интернета в мегабайтах.
Зеленая линия – количество уникальных материалов.
По-моему, комментарии излишни. Если возникнет жгучее желание поработать ксероксом, знайте, что вы не одиноки в своём порыве.

Из личного опыта борьбы с клонированием

Кстати, справочник по HTML обдирают на удивление часто, будто о хороших манерах и об авторском праве никто и слыхом не слыхивал. Чаще всего воруют материалы люди с вопиющими признаками творческой импотенции. На создание "супер-пупер-дизайна" сил хватает, а вот на то, чтобы текст к своему сайту написать – увы, пшик. Вот и идут на manual.ru за чужими текстами.

Когда текст успешно содран и выложен в Интернет, прятать его от автора уже бесполезно. Мне тут же начинают приходить письма "Знаете, я видел ваш справочник там-то и там-то. Что он там делает?" Приходится выяснять, что он там делает.

Я связываюсь с "автором" и спрашиваю, что за дела, зачем сдалась копия? Ответы получаю следующие:

К-во | Полученный ответ | Как это нужно понимать
30% | Нет ответа | Ясен пень, баннеры накрутить хочу и прославиться. Что, сам не видишь? Внизу десять кнопок с рейтингами, моё имя, несуществующий e-mail и три баннера.
30% | Не знаю, хотел сделать свой сайт | Не хочу домашнюю страничку, хочу иметь настоящий сайт. Впервые в жизни сам нарисовал достойный дизайн, ну не пропадать же ему, а? Для такого крутого дизайна нужен хороший текст, а у меня по сочинениям всегда только тройки были. К тому же автора текста я указал, всё честно, ну чего ты придираешься?
30% | Хочу сделать сборник по данной теме | Хочу свой портал. Огромный и чтобы весь мой. Понимаете, в Интернете всё лежит в разных местах. Это же беспорядок какой-то! Нужно сделать один большой мега-портал, библиотеку по каждой теме. Про библиотеку Мошкова слышали? Вот! Я сделаю супер-сайт про html и дизайн, выложу на него всё что найду и это будет круто. Всё в одном месте и моё – это круто, люди оценят.
10% | Хочу доработать, довести до ума | Хочу почувствовать свою причастность к вашему труду. Мне непонятно, почему у вас так мало тэгов описано. При чём здесь "совместимость", а? Я думаю дописать справочник, а то он какой-то недоделанный. Про CSS нихрена нету, тег <nobr> вообще отсутствует. Я в Инете много недостающих материалов нашёл, надо только упорядочить и слить воедино. Когда закончу, у меня будет свой сайт, жутко полезный для людей.

Как видно из вышеприведенного списка, мотив почти всегда один и тот же: сделать "свой" сайт. То есть движущей силой и целью является желание удовлетворить собственные амбиции, а желание сделать что-то полезное для людей – просто хороший повод.

На самом деле всё должно быть наоборот. Почитайте, за что я люблю англоязычный Интернет.

И напоследок пара добрых советов:

Совет первый: не занимайтесь тюнингом.

Если уж вы взялись дорабатывать чужую работу, то нужно именно дорабатывать. То есть для начала связаться с автором и предложить свою помощь в пополнении имеющихся материалов. Я удивлён, что всегда узнаю о "доработке" post factum. Некрасиво получается.

Совет второй: не ставьте перед собой дурацкие цели.

Нет ничего глупее попытки сделать "свой сайт, взяв за основу чужой". Готов проиллюстрировать:

– На днях я выпустил свою первую книгу.
– Что вы говорите! О чём ваша книга?
– В неё вошли стихи Пушкина, Баркова и Ахмадулиной.
– Ах! В вас столько скрытых талантов!

Бред? Бред.

С сайтами то же самое.


Возьми с собой в дорогу

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

Возьми с собой в дорогу

Инструментарий

Для написания HTML и создания графики хороший инструментарий просто необходим. Вам понадобится хороший HTML-редактор, графический пакет для создания растровой графики и программа для ее оптимизации.

HTML-редакторы

Все специализированные редакторы делятся на две группы:

  • WYSIWYG-editors
  • Source editors

Аббревиатура первой группы расшифровывается как What You See Is What You Get ("Что видишь, то и получишь."). К ней относится, например, Microsoft FrontPage. Работа с FrontPage очень проста и напоминает работу с Microsoft Word. В редакторах этого типа создание HTML-кода возлагается на саму программу, а пользователь занимается лишь оформлением странички.

Вторая группа редакторов предназначена для профессиональных дизайнеров, которые пишут HTML вручную и, соответственно, хорошо понимают что делают.

Я бы советовал сразу забыть про существование WYSIWYG-редакторов, даже начинающим. Создавать web-страницы подобным образом такая же нелепость, как программирование с помощью мышки. Язык HTML не прост, он примитивен. Поэтому не стоит упрощать работу с элементарным, даже если вас об этом просит сам Microsoft.

Да-да, я призываю к написанию HTML "руками". Так вы быстрее разберетесь, что к чему, и очень быстро научитесь бегло читать HTML-код.

Миф о блокноте Windows

На свете есть особый род людей, которые гордятся тем, что пишут HTML в стандартном "блокноте" Windows. Как правило, это люди, занимающиеся web-дизайном непрофессионально, время от времени, ибо для солидных Internet-проектов HTML в "Блокноте" не пишется. Ну, разве что, особо изощренными мазохистами.

Откуда взялась эта странная мода, неизвестно. Конечно же, копать котлован совочком – это очень круто, но не лучше ли взять лопату?

"Редакция советует..."

Из HTML-редакторов особо выбирать не приходится: Macromedia HomeSite – лучший выбор. В нем есть все необходимое для профессиональной работы, плюс еще столько же. Я уже десятки раз разочаровывался в нем, жалея об отсутствии той или иной функции, и столько же раз был вне себя от счастья, находя ее буквально у себя перед носом.

Единственные недостатки Macromedia HomeSite – неудачно организованный поиск/замена и медленная работа на больших файлах.

Примерно такая же ситуация складывается и с графическими редакторами. Несмотря на растущее изобилие оных, выбор пока только один – PhotoShop.

Для счастливых обладателей ОС Linux могу также посоветовать поглубже изучить графический редактор GIMP с технологией Script-Fu. Он предоставляет невероятные возможности по созданию собственных графических фильтров и комбинированию имеющихся. Если вы хотите создать тысячу разных картинок с заданными атрибутами (например, графических кнопок или заголовков) – этот редактор для вас.

Оптимизаторы

Из программ-оптимизаторов изображений могу порекомендовать два продукта: Adobe ImageReady, поставляющийся в комплекте с Adobe Photoshop и программу Ulead SmartSaver Pro. Обе программы прекрасно интегрируются с Adobe Photoshop и предоставляют все необходимое для работы.


Дизайн vs Контент

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

Дизайн vs Контент

Простота – залог успеха

Вся сила хорошего дизайна – в простоте.
Если вы согласны с этим утверждением, можете дальше не читать 8)

В противном случае, вам придется осознать, что для создания качественного дизайна совсем не обязательно использовать Flash, анимацию, и голливудские DHTML-спецэффекты от Microsoft. Более того, даже вредно. Ведь подавляющее большинство действительно хороших сайтов, прежде всего, содержит интересную текстовую информацию. И, следовательно, дизайн подчинен содержимому, а не наоборот.

Основной показатель профессионализма в web-дизайне – аккуратность и чистота стиля. Откажите себе в возможности выбора разнообразных шрифтов, ограничьте цвет тремя оттенками, откажитесь от анимации и больших картинок... А теперь попробуйте придумать дизайн. Тяжело? А вы как думали?

А нужен ли вам сайт? Совет пессимиста.

Сначала определитесь, есть ли у вас то, что стоит опубликовать в Сети? Интересно ли это людям? Предположим, что вы положительно ответили на эти два вопроса, тогда – вперед! Если же нет – запомните: любые попытки создать сайт ради, собственно, создания сайта заранее обречены на провал.

Будьте уверены – никто не вернется на ваш сайт только для того, чтобы полюбоваться графикой, так же как никто не будет восхищен вашим творением больше вас самих. С другой стороны, если вы просто хотите размять мозги и разобраться в HTML (вдруг действительно пригодится?), можно сделать домашнюю страничку в стиле "Привет, меня зовут Вася, а вот моя собака."


За что надо отрывать руки

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

За что надо отрывать руки

За ламерство

Популярное слово "ламер", не правда ли? И очень обидное, между прочим. Есть еще одно слово, на которое люди почему-то тоже обижаются – слово "чайник", хотя "ламер" и "чайник" совсем не одно и то же.

Чайниками называют новичков в каком-то деле. Быть чайником, на мой взгляд, даже почетно – тебе только предстоит познать что-то интересное в доселе неведомой области, это как впервые открыть занимательную книгу, заполучив возможность научиться чему-то новому.

Что касается ламеров, то это люди особого сорта. Вечные "начинающие" : до них ничего не доходит. Настоящему ламеру плевать на то, что говорят опытные люди, любую попытку дать ему добрый совет он либо пресекает, либо игнорирует, всегда делая по-своему. Мнит себя профи, блин. Вот из-за таких умников мы сегодня и имеем в Интернете то, что имеем.

За порнуху

Иначе говоря, надо отрывать руки за "грязные" методы работы. За плодящиеся в невиданном количестве окошки с баннерами, за, собственно, сами баннеры в количестве пяти и более штук на страницу, за путаную навигацию, заводящую неизвестно куда, за "пустые" сайты, состоящие из одних линков, за страницы с сотнями линков, ссылающимися в невесомость. Наконец, за баннеры в стиле "поймай мартышку", "недосказанный анекдот", "клевая телка", "сруби миллион баксов" и "сломай глаза, заметь меня".

За эгоизм

Практически каждый сайт в той или иной мере страдает эгоизмом. А выражается этот эгоизм, как правило, в лени его создателя. Сейчас дизайнеру лень добиваться того, чтобы его сайт нормально смотрелся на браузерах, которые почему-то не установлены на рабочем компьютере дизайнера. "Третий Нетскейп? Вы шутите! Им уже давно никто не пользуется, посмотрите статистику!" – вот его основной аргумент.

Заметьте, дизайнеры крупных студий, разрабатывающие коммерческие проекты, так не говорят. У них каждый пользователь на счету – поддерживаются все браузеры, вплоть до текстовых. Но если разработчику коммерческого проекта просто непозволительно игнорировать даже самую малую часть аудитории, то почему это себе позволяет разработчик некоммерческий? Видимо, немеркантильный подход к работе и добротный результат несовместимы.


За что я люблю англоязычный Интернет

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

За что я люблю англоязычный Интернет

За его домашние странички. За то, что они сделаны без претензий и содержат интересную информацию.

Как это делается у них

Живёт себе иностранец, спокойно так живёт, работает, детей растит, а в свободное время занимается резьбой по яичной скорлупе. Причём занимается самозабвенно, это его хобби. В один прекрасный день он понимает, что Интернет позволяет бесплатно обменяться опытом, рассказать всем о том, до чего ж это здорово – вырезать бор-машиной в скорлупе диковинные узоры!

Иностранец садится, пишет по данной теме всё что он знает, пишет долго и с любовью. Потом лезет в Интернет, заводит где-нибудь страничку и выкладывает туда текст. Вот и всё! Никакого дизайна, никакой графики, рейтингов, баннеров и "красивых" доменов, только чистый текст и ссылки.

И скромная подпись внизу "Author: Larry Smith (larry@hotmail.com)".

Таких страниц тысячи, и каждая рассказывает о чьём-то личном опыте в любых областях – от разведения белок до секретов похоронного дела в условиях невесомости.

Как это делается у нас

Живёт себе русский, спокойно так живёт, иногда подрабатывает, в свободное время пьёт пиво с друзьями, компьютерные журналы почитывает и с девицами чатится. Причём чатится самозабвенно, т.к. других хобби не имеется. В один прекрасный день он понимает, что у Серёги домашняя страничка уже есть, а у него ещё нету!

Русский садится, регистрирует страничку там, где дают побольше мегабайт места и начинает клепать дизайн, клепать долго и с любовью. Целый вечер. Потом пишет какой-нибудь текст в духе "Меня зовут Вася, я слушаю Наутилус..." и выкладывает сайт в Интернет. Вот и всё! Хотя нет, не всё. Следующий вечер тратится на регистрацию в рейтингах, поисковиках, баннерных системах и тестирование гостевой книги.

...и скромная надпись внизу "Design by TheHarDCORE Studio, Copyright (C) 2002."

Таких страниц тысячи, и каждая рассказывает о том, насколько всё гибло и запущено в российском Интернете.

Если вы что-то умеете

Если вы что-то умеете, и готовы поделиться знаниями и опытом с другими – загляните на www.manual.ru. Здесь вам помогут с хостингом, программированием и дизайном сайта (конечно же, при условии, что ваш материал авторский, подробный и интересный).


Идеология HTML

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

Идеология HTML

Как работают профи

Как ни странно, даже у такой, казалось бы, простой вещи как HTML, есть своя идеология. HTML – это отнюдь не язык оформления документов. Это, в первую очередь, средство их разметки. Ваша первоочередная задача – разметить текст, описать с помощью тегов его структуру, сказав: "Это – параграф, это – цитата, это – список, а это – раздел".
В HTML для того чтобы, например, создать заголовок абзаца, недостаточно выделить слово жирным шрифтом. Нужно с помощью соответствующего HTML-кода сказать, что это слово – заголовок, возложив задачу оформления на хрупкие плечи браузера.

Но почему?

Дело в том, что документы HTML предназначены не только для отображения на экране. Нет. Вся прелесть HTML заключается в возможности его отправки практически на любое устройство вывода.

Представьте, что будет с обычным текстом при попытке, скажем, прочитать его вслух с помощью карманного голосового компьютера. Куда денется оформление? Наверняка исчезнет – ведь голос машины не в состоянии отобразить слово подчеркнутым, увеличенным или курсивным шрифтом. Но если вместо оформления документа будет описана его структура, то текст заголовков будет произнесен правильно (например, с изменением интонации), между абзацами компьютер выдержит паузу, а цитаты прочитает другим голосом.

А теперь представьте, что ваш документ просматривается на крохотном двустрочном дисплее наручных часов или Интернет-пэйджера. Если вы указали разметку документа, описали начало и конец параграфов, заголовки, формулы и адреса, то будьте спокойны: устройство подаст и оформит его в наиболее приемлемой форме.

А как же оформление?

Язык HTML содержит достаточное количество элементов, позволяющих оформить документ по вашему вкусу. Если вас не устраивает способ оформления документа браузером (хочется изменить шрифт, предложенный по умолчанию, или сделать его помельче:) – добавьте HTML-теги форматирования текста. Если и после этого внешний вид документа вас не устраивает, нанесите последний штрих: воспользуйтесь таблицами стилей (CSS).


На работе и дома

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

На работе и дома

Безнаказанно копируем справочник

Всем скачавшим рекомендую периодически заглядывать на сайт html.manual.ru за свежей версией. Материалы сайта исправляются и дополняются не очень часто, но всё же это иногда происходит.

Что можно и чего нельзя

Понимаю и приветствую стремление иметь копию для личного пользования, особенно если у вас дефицит времени on-line. Но мне совершенно непонятен мотив копирования для выкладывания материала в Интернете.

Я против самодеятельного распространения справочника в Интернете. Почему это так, читайте далее.


Проблемы, которые мы выбираем

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

Проблемы, которые мы выбираем

Удивительно, но никому в голову не приходит мысль разместить свои материалы на уже известном и посещаемом сайте. Надо обязательно на своём. Представляете, что будет, если каждый журналист начнет издавать свой журнал?

Это говорит только об одном – об отсутствии желания писать тексты для людей. Жажда обладания своим сайтом заедает, блин.

Если бы мне кто-то написал и сказал, что располагает хорошим авторским материалом по html/css, этот материал мог бы появиться на html.manual.ru. Я готов размещать любые хорошие материалы с обязательной ссылкой на автора. Разумеется, при условии, что материал написан профессионально. Только никому пока в голову подобная идея не приходила, хотя лучшего способа донести свои тексты до масс и не придумать.

Не взваливайте на себя лишние проблемы

Содержать популярный тематический сайт весьма обременительно. Я, например, никакой пользы от того, что этот чёртов справочник мой не имею, выгоды от сайта нет, только проблемы и расходы. Так почему бы вам, авторам, не избавить себя от подобной головной боли? Учитесь на чужих ошибках, размещайте свои статьи на уже известных, хорошо посещаемых сайтах. Ведь это так удобно – скинул текст на сайт и никаких проблем с поддержкой, только на письма отвечай.

Недоверчивые воскликнут: "Ага! Я, значит, статью отгрохаю, а кто-то свой сайт за мой счёт пополнять будет, раскручиваться, деньги грести!" Уймитесь, недоверчивые. Чтобы грести деньги нужно иметь, как минимум, масштаб Компьютерры или iXBT (которые, кстати, честно платят авторам гонорары).

Ещё раз повторюсь: содержать статейный сайт узкой тематики с посещаемостью двести и более человек в день – это Проблема с большой буквы "Пэ". Вы можете смело доверять людям, которые держат такие сайты. Если бы им хотелось только посещаемости и денег, то вместо ваших статей на сайте лежали бы анекдоты, порнуха, знакомства и прочий ширпотреб.

Честное слово. Даю вашу голову на отсечение.


HTML-справочник. Введение

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

HTML-справочник. Введение

Коротко о справочнике

Это не перевод скучной спецификации и не попытка написать учебник. Задача справочника – коротко и ясно описать действие всех элементов языка HTML, которые вы можете без опаски использовать при создании Internet-страниц, не боясь, что какая-то версия какого-либо браузера сделает вам неприятный сюрприз.

Иначе говоря, здесь представлен "классический" HTML, употребляемый профессиональными web-разработчиками. И ничего лишнего.

Все теги, не описанные в этом справочнике, можете смело выбросить в помойку.

Как устроен справочник

Очень просто. Эталоном построения справочника стали классические брошюры по всевозможным языкам программирования, описывающие элементы языка парой "элемент – описание".

Для "крутых"

Справочник не рассчитан лишь на начинающих. Я частенько пользуюсь им как шпаргалкой если что-нибудь подзабыл. Несмотря на то, что HTML – штука очень простая, иногда из головы напрочь вылетает какая-нибудь мелочь. Например, что у элемента HR есть жутко полезный атрибут NOSHADE.

Как понимать написанное

Справочник оперирует всего двумя понятиями, разобраться в которых, я думаю, не составляет никакого труда:

Тег – оформленная единица HTML-кода. Например, <HEAD>, <FONT ...>, <BODY>, <HTML> и так далее. Теги бывают начальными (открывающими) и конечными (закрывающими, начинающимися со знака "/"). Например, вышеуказанным тегам соответствуют закрывающие теги </HEAD>, </FONT>, </BODY>, </HTML>.

Элемент – понятие, введенное для удобства. Например, элемент HEAD состоит из двух тегов – открывающего <HEAD> и закрывающего </HEAD>. Следовательно, элемент – более емкое понятие, обозначающее пару тегов и участок документа между тегами, на который распространяется их влияние.

Если вы хотите иметь копию

Если справочник показался вам полезным, и вы хотите иметь копию для личного использования, зайдите сюда.


СООБРАЖЕНИЯ

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

СООБРАЖЕНИЯ

Прочитав изложенные ниже соображения, вы можете здорово упростить себе жизнь. Считайте, что это своеобразный путеводитель по граблям в области web-дизайна. По граблям, на которые вам наступать не стоит.

- | На работе и дома
- | F5 или снова о клонировании
- | За что я люблю англоязычный Интернет
- | Проблемы, которые мы выбираем
- | За что надо отрывать руки
- | Дизайн vs Контент
- | Идеология HTML
- | Возьми с собой в дорогу

ССЫЛКИ НА ДРУГИЕ ПОЛЕЗНЫЕ САЙТЫ
- Параграфы Ру/Ководства Артемия Лебедева
- Садовые грабли в газоностроении


Это вам пригодится

Соображения:

"Дизайн vs Контент"
"Интернет и клонирование"
"Иностранцы"
"За что надо отрывать руки"
"Возьми с собой в дорогу"
"Идеология HTML"

С чего начать

Введение
Структура HTML документов
Вставка комментариев

"Шапка" документа

Заголовок
HEAD
TITLE
BASE
STYLE
LINK
META

Фреймы
FRAMESET
FRAME
NOFRAMES

Скрипты
SCRIPT
NOSCRIPT

Навигационные карты
MAP
AREA

Тело документа

BODY

Гиперссылки
A

Текстовые блоки
H1,H2,...H6
P
DIV
ADDRESS
BLOCKQUOTE
BR
HR
PRE
LISTING, PLAINTEXT, XMP

Форматирование текста
BASEFONT
FONT
I
EM
B
STRONG
U
S, STRIKE
BIG
SMALL
SUP
SUB
CODE, SAMP
TT
KBD
VAR
CITE

Списки
UL
OL
LI
MENU, DIR
DL
DT
DD

Объекты
IMG
EMBED
NOEMBED
APPLET
PARAM

Таблицы
TABLE
CAPTION
TR
TD и TH
Примеры таблиц

Формы
FORM
TEXTAREA
SELECT
OPTION
INPUT

Это вам пригодится:

Таблица базовых цветов
Таблица MIME-типов
Спецсимволы в HTML
FAQ
Полезные линки

Aвтор: Vladimir Gorodulin

Это вам пригодится

- | Таблица базовых цветов
- | Таблица MIME-типов
- | Форматы изображений – GIF или JPG?
- | Спецсимволы в HTML
- | FAQ
- | Полезные линки


Справочник по HTML

html.manual.ru

Перед вами offline-копия популярного справочника по HTML, который всегда можно найти по адресу http://html.manual.ru

Приятной вам работы и творческих успехов!

Владимир Городулин

PS: Если у вас возникли вопросы - загляните на форум сайта, пожалуй, самый крупный русскоязычный форум на тему веб-дизайна.

Читать справочник »

О распространении и копировании справочника